REXExtension.GetTopWindowHandleForParent Method

REXExtension.GetTopWindowHandleForParent Method
REXExtension Class REX.Common Namespace REXExtension Class

This is GetTopWindowHandleForParent, a member of class REXExtension.

C#
public virtual IWin32Window GetTopWindowHandleForParent();
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.GetWindow Method

REXExtension.GetWindow Method
REXExtension Class REX.Common Namespace REXExtension Class

Get reference to main form.

C#
public virtual REXExtensionWindow GetWindow();
Returns

Returns reference to MainForm object based on REXExtensionForm object.

Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.GetWindowForParent Method

REXExtension.GetWindowForParent Method
REXExtension Class REX.Common Namespace REXExtension Class

Get the window for parent.

C#
public virtual Window GetWindowForParent();
Returns

Returns IWin32Window interface for main window. If MainForm is visible, method returns reference to MainForm, otherwise returns reference to main application window.

Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.GetWindowHandleForParent Method

REXExtension.GetWindowHandleForParent Method
REXExtension Class REX.Common Namespace REXExtension Class

Get the window for parent.

C#
public virtual IWin32Window GetWindowHandleForParent();
Returns

Returns IWin32Window interface for main window. If MainForm is visible, method returns reference to MainForm, otherwise returns reference to main application window.

Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.Initialize Method

REXExtension.Initialize Method
REXExtension Class REX.Common Namespace REXExtension Class

Initializes this instance.

C#
public void Initialize();
Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.OnActivateLayout Method

REXExtension.OnActivateLayout Method
REXExtension Class REX.Common Namespace REXExtension Class

Activates or deactivates layout - module can modify layout before or after activation.

C#
public virtual void OnActivateLayout(REXLayoutItem LItem, bool Activate);
Parameters
Parameters | Description
LItem | The layout item.
Activate | If set to true, layout is activated.
Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.OnCanActivateLayout Method

REXExtension.OnCanActivateLayout Method
REXExtension Class REX.Common Namespace REXExtension Class

Called when [can activate layout].

C#
public virtual bool OnCanActivateLayout(REXLayoutItem LItem);
Parameters
Parameters | Description
LItem | The layout item.
Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.OnCanClose Method ()

REXExtension.OnCanClose Method ()
REXExtension Class REX.Common Namespace REXExtension Class

If returns true, dialog will close after OK button clicked.

C#
public virtual bool OnCanClose();
Returns

Returns true if module can be closed.

Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.OnCanClose Method (REXCanCloseType)

REXExtension.OnCanClose Method (REXCanCloseType)
REXExtension Class REX.Common Namespace REXExtension Class

Called when closing module.

C#
public virtual bool OnCanClose(REXCanCloseType Type);
Parameters
Parameters | Description
Type | The closing type. See REXCanCloseType enum.
Returns

Returns true if module can be closed.

Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.OnCanRun Method

REXExtension.OnCanRun Method
REXExtension Class REX.Common Namespace REXExtension Class

Checks status of module and shows some information for user if module can't complete action.

C#
public virtual bool OnCanRun();
Returns

Returns true if module can do some action in OnRun method; otherwise false.

Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.OnCheckValidity Method

REXExtension.OnCheckValidity Method
REXExtension Class REX.Common Namespace REXExtension Class

Called when check validity.

C#
public virtual bool? OnCheckValidity();
Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.OnClear Method

REXExtension.OnClear Method
REXExtension Class REX.Common Namespace REXExtension Class

Called when clear.

C#
public virtual bool OnClear(out bool Implemented);
Parameters
Parameters | Description
Implemented | If returns true, the method is implemented.
Returns

Returns result of clear operation.

Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.OnClose Method

REXExtension.OnClose Method
REXExtension Class REX.Common Namespace REXExtension Class

Called during closing module.

C#
public virtual void OnClose();
Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.OnCommand Method

REXExtension.OnCommand Method
REXExtension Class REX.Common Namespace REXExtension Class

Called when command.

C#
public virtual object OnCommand(ref REXCommand CommandStruct);
Parameters
Parameters | Description
CommandStruct | The command struct.
Returns

Returns result of command operation.

Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.OnCreate Method

REXExtension.OnCreate Method
REXExtension Class REX.Common Namespace REXExtension Class

Creates needed structures and verify needs.

C#
public virtual void OnCreate();
Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.OnCreateDialogs Method

REXExtension.OnCreateDialogs Method
REXExtension Class REX.Common Namespace REXExtension Class

Creates sub dialogs.

C#
public virtual void OnCreateDialogs();
Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.OnCreateLayout Method

REXExtension.OnCreateLayout Method
REXExtension Class REX.Common Namespace REXExtension Class

Creates layout items and setups layout.

C#
public virtual void OnCreateLayout();
Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.OnDataLoad Method

REXExtension.OnDataLoad Method
REXExtension Class REX.Common Namespace REXExtension Class

Called when data load.

C#
public virtual bool OnDataLoad();
Returns

Returns true if succeeded.

Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.OnDataLoaded Method

REXExtension.OnDataLoaded Method
REXExtension Class REX.Common Namespace REXExtension Class

Called when data loaded.

C#
public virtual void OnDataLoaded(bool Result);
Parameters
Parameters | Description
Result | If set to true operation succeeded; Otherwise some errors found.
Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.OnDataSave Method

REXExtension.OnDataSave Method
REXExtension Class REX.Common Namespace REXExtension Class

Called when data save.

C#
public virtual bool OnDataSave();
Returns

Returns true if succeeded.

Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.OnDataSaved Method

REXExtension.OnDataSaved Method
REXExtension Class REX.Common Namespace REXExtension Class

Called when data saved.

C#