This is RoundingIncrement, a member of class DisplayDefinition.

C#
public double RoundingIncrement = 0;
Class

REXDFM.DisplayDefinition Class

Links
REXDFM.DisplayDefinition Class, REX.Common Namespace, REXDFM.DisplayDefinition Class

REXDFM.DisplayDefinition.Separator Field

REXDFM.DisplayDefinition.Separator Field
REXDFM.DisplayDefinition Class REX.Common Namespace REXDFM.DisplayDefinition Class

This is Separator, a member of class DisplayDefinition.

C#
public string Separator = ".";
Class

REXDFM.DisplayDefinition Class

Links
REXDFM.DisplayDefinition Class, REX.Common Namespace, REXDFM.DisplayDefinition Class

REXDFM.DisplayDefinition.UnitDefinition Field

REXDFM.DisplayDefinition.UnitDefinition Field
REXDFM.DisplayDefinition Class REX.Common Namespace REXDFM.DisplayDefinition Class

This is UnitDefinition, a member of class DisplayDefinition.

C#
public string UnitDefinition = null;
Class

REXDFM.DisplayDefinition Class

Links
REXDFM.DisplayDefinition Class, REX.Common Namespace, REXDFM.DisplayDefinition Class

REXDFM.DisplayDefinition.UnitSymbol Field

REXDFM.DisplayDefinition.UnitSymbol Field
REXDFM.DisplayDefinition Class REX.Common Namespace REXDFM.DisplayDefinition Class

This is UnitSymbol, a member of class DisplayDefinition.

C#
public string UnitSymbol = "";
Class

REXDFM.DisplayDefinition Class

Links
REXDFM.DisplayDefinition Class, REX.Common Namespace, REXDFM.DisplayDefinition Class

REXDFM.DisplayDefinition.Equals Method

REXDFM.DisplayDefinition.Equals Method
REXDFM.DisplayDefinition Class REX.Common Namespace REXDFM.DisplayDefinition Class

Determines whether the specified T:System.Object is equal to the current T:System.Object.

C#
public override bool Equals(object obj);
Parameters
Parameters | Description
obj | The T:System.Object to compare with the current T:System.Object.
Returns

true if the specified T:System.Object is equal to the current T:System.Object; otherwise, false.

Description
Class

REXDFM.DisplayDefinition Class

Links
REXDFM.DisplayDefinition Class, REX.Common Namespace, REXDFM.DisplayDefinition Class

REXDFM.DisplayDefinition.ReadFromCategory Method (REXUnits, Autodesk.REX.Framework.EUnitType, double)

REXDFM.DisplayDefinition.ReadFromCategory Method (REXUnits, Autodesk.REX.Framework.EUnitType, double)
REXDFM.DisplayDefinition Class REX.Common Namespace REXDFM.DisplayDefinition Class

Reads the unit definition based on the category.

C#
public void ReadFromCategory(REXUnits Units, Autodesk.REX.Framework.EUnitType UnitType, double Power);
Parameters
Parameters | Description
Units | The unit engine.
UnitType | The type of the unit.
Power | The power.
Description
Class

REXDFM.DisplayDefinition Class

Links
REXDFM.DisplayDefinition Class, REX.Common Namespace, REXDFM.DisplayDefinition Class

REXDFM.DisplayDefinition.ReadFromCategory Method (REXUnits, string, double)

REXDFM.DisplayDefinition.ReadFromCategory Method (REXUnits, string, double)
REXDFM.DisplayDefinition Class REX.Common Namespace REXDFM.DisplayDefinition Class

Reads the unit definition based on the category.

C#
public void ReadFromCategory(REXUnits Units, string UnitName, double Power);
Parameters
Parameters | Description
Units | The unit engine.
UnitName | The name of the unit.
Power | The power.
Description
Class

REXDFM.DisplayDefinition Class

Links
REXDFM.DisplayDefinition Class, REX.Common Namespace, REXDFM.DisplayDefinition Class

REXDFM.AddDisplayUnitObject Method (IUnitObject, Autodesk.REX.Framework.EUnitType, int, DisplayDefinition)

REXDFM.AddDisplayUnitObject Method (IUnitObject, Autodesk.REX.Framework.EUnitType, int, DisplayDefinition)
REXDFM Class REX.Common Namespace REXDFM Class

Registers an object which implements the IUnitObject interface.

C#
public bool AddDisplayUnitObject(IUnitObject myUnitObject, Autodesk.REX.Framework.EUnitType UnitType, int power, DisplayDefinition displayUnitDef);
Parameters
Parameters | Description
myUnitObject | The reference to the object.
UnitType | The type of the unit.
power | The power of the unit.
displayUnitDef | The unit display settings.
Returns

Returns true if the object was registered.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class

REXDFM.AddDisplayUnitObject Method (IUnitObject, DisplayDefinition)

REXDFM.AddDisplayUnitObject Method (IUnitObject, DisplayDefinition)
REXDFM Class REX.Common Namespace REXDFM Class

Registers an object which implements the IUnitObject interface.

C#
public bool AddDisplayUnitObject(IUnitObject myUnitObject, DisplayDefinition displayUnitDef);
Parameters
Parameters | Description
myUnitObject | The reference to the object.
displayUnitDef | The display settings.
Returns

Returns true if the object was registered.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class

REXDFM.AddDisplayUnitObject Method (IUnitObject, string, Autodesk.REX.Framework.EUnitType, int, DisplayDefinition)

REXDFM.AddDisplayUnitObject Method (IUnitObject, string, Autodesk.REX.Framework.EUnitType, int, DisplayDefinition)
REXDFM Class REX.Common Namespace REXDFM Class

Registers an object which implements the IUnitObject interface.

C#
public bool AddDisplayUnitObject(IUnitObject myUnitObject, string nameUnitObject, Autodesk.REX.Framework.EUnitType UnitType, int power, DisplayDefinition displayUnitDef);
Parameters
Parameters | Description
myUnitObject | The reference to the object.
nameUnitObject | The name of the unit object.
UnitType | The type of the unit.
power | The power of the unit.
displayUnitDef | The unit display settings.
Returns

Returns true if the object was registered.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class

REXDFM.AddDisplayUnitObject Method (IUnitObject, string, DisplayDefinition)

REXDFM.AddDisplayUnitObject Method (IUnitObject, string, DisplayDefinition)
REXDFM Class REX.Common Namespace REXDFM Class

Registers an object which implements the IUnitObject interface.

C#
public bool AddDisplayUnitObject(IUnitObject myUnitObject, string nameUnitObject, DisplayDefinition displayUnitDef);
Parameters
Parameters | Description
myUnitObject | The reference to the object.
nameUnitObject | The name of the unit object.
displayUnitDef | The unit display settings.
Returns

Returns true if the object was registered.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class

REXDFM.AddUnitObject Method (IUnitObject)

REXDFM.AddUnitObject Method (IUnitObject)
REXDFM Class REX.Common Namespace REXDFM Class

Registers an object which implements the IUnitObject interface.

C#
public bool AddUnitObject(IUnitObject myUnitObject);
Parameters
Parameters | Description
myUnitObject | The reference to the object.
Returns

Returns true if the object was registered.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class

REXDFM.AddUnitObject Method (IUnitObject, Autodesk.REX.Framework.EUnitType, int)

REXDFM.AddUnitObject Method (IUnitObject, Autodesk.REX.Framework.EUnitType, int)
REXDFM Class REX.Common Namespace REXDFM Class

Registers an object which implements the IUnitObject interface.

C#
public bool AddUnitObject(IUnitObject myUnitObject, Autodesk.REX.Framework.EUnitType UnitType, int power);
Parameters
Parameters | Description
myUnitObject | The reference to the object.
UnitType | The type of the unit.
power | The power of the unit.
Returns

Returns true if the object was registered.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class

REXDFM.AddUnitObject Method (IUnitObject, string)

REXDFM.AddUnitObject Method (IUnitObject, string)
REXDFM Class REX.Common Namespace REXDFM Class

Registers an object which implements the IUnitObject interface.

C#
public bool AddUnitObject(IUnitObject myUnitObject, string nameUnitObject);
Parameters
Parameters | Description
myUnitObject | The reference to the object.
nameUnitObject | The name of the unit object.