Modal | Creates and shows module as a modal dialog.
OnCreate | Called when create application object.
RestoreCultureInfo | Restores the culture info.
Show | Shows this module.

Methods (AutoDoc Folder)

Legend
Legend
Method
virtual

REXApplication Properties

REXApplication Properties
REXApplication Class Legend
REXApplication Properties
REXApplication Properties | Description
Context | Get the reference to the old context.
Context2 | Get the context2.
ContextProduct | Get the context product from the old context structure.
ContextProduct2 | Get the context product2.
ThisApplication | This is ThisApplication, a member of class REXApplication.
ThisContext | This is ThisContext, a member of class REXApplication.
ThisExtension | This is ThisExtension, a member of class REXApplication.
Visible | Get or set a value indicating whether this REXApplication is visible.

Properties (AutoDoc Folder)

Legend
Legend
Property
virtual

REXApplication Class Public Methods

REXApplication Class Public Methods
REXApplication Class Legend
Public Methods
Public Method | Description
REXApplication | Initializes a new instance of a REXApplication class.

REXDFM Classes

REXDFM Classes
REXDFM Class Legend
REXDFM Classes
REXDFM Classes | Description
DisplayDefinition | Represents the display settings of the specified unit category.

REXDFM Delegates

REXDFM Delegates
REXDFM Class
REXDFM Delegates
REXDFM Delegates | Description
EventHandlerChange | Delegate to the event handler changes.
EventHandlerLost | Delegate to the event handler lost focus.

REXDFM Events

REXDFM Events
REXDFM Class Legend
REXDFM Events
REXDFM Events | Description
ControlUnitObjectError | Raises when data is changed on Control and some error was occur.
ControlUnitObjectLostFocus | Raises when Control losts focus.
ControlUnitObjectOk | Raises when data is changed on Control and no errors.

Events (AutoDoc Folder)

Legend
Legend
Event
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

Legend

Legend
REXDFM Class
Legend
Constructor
Class
Property
Event
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXDFM Class Members

REXDFM Class Members
REXDFM Class Legend
Members
Public Methods
Public Method | Description
REXDFM | Initializes a new instance of the REXDFM class.
REXDFM | Initializes a new instance of the REXDFM class.
REXDFM | Initializes a new instance of the REXDFM class.
REXDFM Classes
REXDFM Classes | Description
DisplayDefinition | Represents the display settings of the specified unit category.
REXDFM Methods
REXDFM Methods | Description
AddDisplayUnitObject | Registers an object which implements the IUnitObject interface.
AddDisplayUnitObject | Registers an object which implements the IUnitObject interface.
AddDisplayUnitObject | Registers an object which implements the IUnitObject interface.
AddDisplayUnitObject | Registers an object which implements the IUnitObject interface.
AddUnitObject | Registers an object which implements the IUnitObject interface.
AddUnitObject | Registers an object which implements the IUnitObject interface.
AddUnitObject | Registers an object which implements the IUnitObject interface.
AddUnitObject | Registers an object which implements the IUnitObject interface.
AfterParamsChange | Method called after parameters change.
BeforeParamsChange | Method called before parameters change.
Clear | Clears this instance.
CreateGroupControl | Creates the group of controls from collection of controls and all childrenss.
CreateGroupControl | Creates the group of controls from all childrens.
CreateGroupControl | Creates the group of controls from collection of controls and all childrenss.
CreateGroupControl | Creates the group of controls from all childrens.
GetComplexDataBase | Gets the values and convert it to base units.
GetComplexDataBase | Gets the values and converts them to base units.
GetComplexDataDisplay | Gets the values and convert it to display units.
GetComplexDataDisplay | Gets the values and convert it to display units.
GetComplexDataInterface | Gets the values and convert it to interface units.
GetComplexDataInterface | Gets the values and converts it to interface units.
GetDataBase | Gets the value and converts it to base units.
GetDataBase | Gets the value and converts it to base units.
GetDataDisplay | Gets the value and converts it to display units.
GetDataDisplay | Gets the value and converts it to display units.
GetDataInterface | Gets the value and converts it to interface units.
GetDataInterface | Gets the value and converts it to interface units.
GetDataText | Gets the current text.
GetDataText | Gets the current text.
GetObjectsOfNotOkState | Gets the list of registered objects which are in a state other then OK.
RemoveUnitObject | Removes the unit object.
RemoveUnitObject | Removes the unit object.
SetBaseMaxValue | Sets the maximum value defined in base units.
SetBaseMaxValue | Sets the maximum value defined in base units.
SetBaseMinValue | Sets the minimum value in base units.
SetBaseMinValue | Sets the minimum value in base units.
SetComplexDataBase | Sets the list of values in base units.
SetComplexDataBase | Sets the list of values in base units.
SetComplexDataDisplay | Sets the list of values defined in display units.
SetComplexDataDisplay | Sets the list of values defined in display units.
SetComplexDataInterface | Sets the list of values in interface units.
SetComplexDataInterface | Sets the list of values in interface units.
SetDataBase | Sets the value defined in base units.
SetDataBase | Sets the value defined in base units.
SetDataDisplay | Sets the value defined in display units.
SetDataDisplay | Sets the value defined in display units.
SetDataInterface | Sets the value defined in interface units.
SetDataInterface | Sets the value defined in interface units.
SetDataText | Sets the current text.
SetDataText | Sets the current text.
SetInterfaceMaxValue | Sets the maximum value defined in interface units.
SetInterfaceMaxValue | Sets the maximum value defined in interface units.
SetInterfaceMinValue | Sets the minimum value defined in interface units.
SetInterfaceMinValue | Sets the minimum value defined in interface units.
SetUserValidFunction | Sets the user validation function.
SetUserValidFunction | Sets the user validation function.
SetUserValidFunctionComplex | Sets the user validation function for lists of values.
SetUserValidFunctionComplex | Sets the user validation function for lists of values.
ValidateDataBase | Validates the value in base units.
ValidateDataBase | Validates the value in base units.
ValidateDataDisplay | Validates the value in display units.
ValidateDataDisplay | Validates the value in display units.
ValidateDataInterface | Validates the value in interface units.
ValidateDataInterface | Validates the value in interface units.
REXDFM Properties
REXDFM Properties | Description
AllowReplaceObject | Gets or sets a value indicating whether controlling object may be replaced during registration.
Count | Gets the number of controling objects.
REXDFM Delegates
REXDFM Delegates | Description
EventHandlerChange | Delegate to the event handler changes.
EventHandlerLost | Delegate to the event handler lost focus.
REXDFM Events
REXDFM Events | Description
ControlUnitObjectError | Raises when data is changed on Control and some error was occur.
ControlUnitObjectLostFocus | Raises when Control losts focus.
ControlUnitObjectOk | Raises when data is changed on Control and no errors.

Members

Legend
Legend
Constructor
Class
Property
Event