ThisApplication | Get this application.
ThisContext | Get the context.
ThisProduct | Gets the this product.
ThisRunContext | Gets the this run context.
UI | Get the reference to UI object.
Units | Get the reference to Units object.
Links
REX.Common Namespace, Legend, Members, Public Methods, REXExtension Methods, REXExtension Properties

REXExtension.REXExtension Constructor

REXExtension.REXExtension Constructor
REXExtension Class REX.Common Namespace REXExtension Class

Initializes a new instance of the REXExtension class.

C#
public REXExtension(REXApplication App);
Parameters
Parameters | Description
App | The reference to REXApplication object.
Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.AddCommands Method

REXExtension.AddCommands Method
REXExtension Class REX.Common Namespace REXExtension Class

Adds the commands.

C#
public virtual void AddCommands();
Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.ApplyStyle Method (Window)

REXExtension.ApplyStyle Method (Window)
REXExtension Class REX.Common Namespace REXExtension Class

This is ApplyStyle, a member of class REXExtension.

C#
public void ApplyStyle(Window window);
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.ApplyStyle Method (Window, string, string)

REXExtension.ApplyStyle Method (Window, string, string)
REXExtension Class REX.Common Namespace REXExtension Class

This is ApplyStyle, a member of class REXExtension.

C#
public void ApplyStyle(Window window, string assemblyFullPath, string stylesName);
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.Close Method ()

REXExtension.Close Method ()
REXExtension Class REX.Common Namespace REXExtension Class

Close extension with all needed actions.

C#
public virtual void Close();
Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.Close Method (DialogResult, bool)

REXExtension.Close Method (DialogResult, bool)
REXExtension Class REX.Common Namespace REXExtension Class

Close extension with all needed actions.

C#
public virtual void Close(DialogResult Result, bool HideManager);
Parameters
Parameters | Description
Result | The result.
HideManager | if set to true hide manager.
Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.Close Method (bool?, bool)

REXExtension.Close Method (bool?, bool)
REXExtension Class REX.Common Namespace REXExtension Class

Close extension with all needed actions.

C#
public virtual void Close(bool? Result, bool HideManager);
Parameters
Parameters | Description
Result | The result.
HideManager | if set to true hide manager.
Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.Command Method

REXExtension.Command Method
REXExtension Class REX.Common Namespace REXExtension Class

Commands the specified command struct.

C#
public virtual object Command(ref REXCommand CommandStruct);
Parameters
Parameters | Description
CommandStruct | The command struct.
Returns

Returns result of event operation.

Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.Create Method

REXExtension.Create Method
REXExtension Class REX.Common Namespace REXExtension Class

Creates this extension.

C#
public virtual bool Create();
Returns

Returns true if succeeded.

Description

Calls: OnInitialize(), OnCreate(), OnCreateDialogs() virtual methods.

Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.Event Method

REXExtension.Event Method
REXExtension Class REX.Common Namespace REXExtension Class

Events the specified event struct.

C#
public virtual object Event(ref REXEvent EventStruct);
Parameters
Parameters | Description
EventStruct | The event struct.
Returns

Returns result of event operation.

Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.GetAPI Method

REXExtension.GetAPI Method
REXExtension Class REX.Common Namespace REXExtension Class

Get reference to main API object.

C#
public virtual Object GetAPI();
Returns

Returns reference to main API object object.

Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.GetCaption Method ()

REXExtension.GetCaption Method ()
REXExtension Class REX.Common Namespace REXExtension Class

Get standard caption.

C#
public virtual string GetCaption();
Returns

Returns caption.

Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.GetCaption Method (string)

REXExtension.GetCaption Method (string)
REXExtension Class REX.Common Namespace REXExtension Class

Get standard caption with additional information.

C#
public virtual string GetCaption(string AdditionalText);
Returns

Returns caption.

Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.GetControl Method

REXExtension.GetControl Method
REXExtension Class REX.Common Namespace REXExtension Class

Get reference to main control.

C#
public virtual REXExtensionControl GetControl();
Returns

Returns reference to MainControl object based on REXExtensionControl object.

Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.GetData Method

REXExtension.GetData Method
REXExtension Class REX.Common Namespace REXExtension Class

Get the data structure.

C#
public virtual REXData GetData();
Returns

Returns reference to object based on REXData object.

Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.GetForm Method

REXExtension.GetForm Method
REXExtension Class REX.Common Namespace REXExtension Class

Get reference to main form.

C#
public virtual REXExtensionForm GetForm();
Returns

Returns reference to MainForm object based on REXExtensionForm object.

Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.GetIcon Method

REXExtension.GetIcon Method
REXExtension Class REX.Common Namespace REXExtension Class

Get reference to icon.

C#
public virtual System.Windows.Media.ImageSource GetIcon();
Returns

Returns reference to icon object.

Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.GetResults Method

REXExtension.GetResults Method
REXExtension Class REX.Common Namespace REXExtension Class

Get the results structure.

C#
public virtual REXResults GetResults();
Returns

Returns reference to object based on REXResults object.

Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.GetREXEnvironment Method

REXExtension.GetREXEnvironment Method
REXExtension Class REX.Common Namespace REXExtension Class

Get the reference to REX environment object.

C#
public virtual REXEnvironment GetREXEnvironment();
Returns

Returns reference to REXEnvironment object.

Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.GetTopWindowForParent Method

REXExtension.GetTopWindowForParent Method
REXExtension Class REX.Common Namespace REXExtension Class

This is GetTopWindowForParent, a member of class REXExtension.

C#
public virtual Window GetTopWindowForParent();
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class