RVTFamilyConverter Class

Links
RVTFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, RVTFamilyConverter Class

RVTFamilyConverter.InitGlobal Method

RVTFamilyConverter.InitGlobal Method
RVTFamilyConverter Class REX.ContentGenerator.Converters Namespace RVTFamilyConverter Class

Initializes lists of existing families from the Active Document.

C#
public void InitGlobal();
Description
Class

RVTFamilyConverter Class

Links
RVTFamilyConverter Class, REX.ContentGenerator.Converters Namespace, RVTFamilyConverter Class

RVTFamilyConverter.IsElementSupported Method

RVTFamilyConverter.IsElementSupported Method
RVTFamilyConverter Class REX.ContentGenerator.Converters Namespace RVTFamilyConverter Class

This is IsElementSupported, a member of class RVTFamilyConverter.

C#
public bool IsElementSupported(REXFamilyType fam, ECategoryType category);
Class

RVTFamilyConverter Class

Links
RVTFamilyConverter Class, REX.ContentGenerator.Converters Namespace, RVTFamilyConverter Class

RVTFamilyConverter.RegisterCustomFactory Method

RVTFamilyConverter.RegisterCustomFactory Method
RVTFamilyConverter Class REX.ContentGenerator.Converters Namespace RVTFamilyConverter Class

Registers the custom factory.

C#
public bool RegisterCustomFactory<T_REXFamilyType, T_REXDescription>(string name, string parametersFilePath, string templatesFilePath, string templatesDirectory, Autodesk.Revit.DB.BuiltInCategory category) where T_REXFamilyType : new() where T_REXDescription : new();
Parameters
Parameters | Description
name | The name of the custom category (it will be used for identification so it has to be unique and consistent).
parametersFilePath | The parameters file path.
templatesFilePath | The templates file path.
templatesDirectory | The templates directory.
category | The Revit elements category.
Type Parameters
Type Parameters | Description
T_REXFamilyType | The type of the custom family type.
T_REXDescription | The type of the custom description.
Returns

True if registration succeeded.

Description
Class

RVTFamilyConverter Class

Links
RVTFamilyConverter Class, REX.ContentGenerator.Converters Namespace, RVTFamilyConverter Class

RVTFamilyConverter.Temporary Method

RVTFamilyConverter.Temporary Method
RVTFamilyConverter Class REX.ContentGenerator.Converters Namespace RVTFamilyConverter Class

This is Temporary, a member of class RVTFamilyConverter.

C#
public void Temporary();
Class

RVTFamilyConverter Class

Links
RVTFamilyConverter Class, REX.ContentGenerator.Converters Namespace, RVTFamilyConverter Class

RVTFamilyConverter.ContentMapper Property

RVTFamilyConverter.ContentMapper Property
RVTFamilyConverter Class REX.ContentGenerator.Converters Namespace RVTFamilyConverter Class

Gets the mapper object.

C#
public RVTContentMapper ContentMapper;
Description

The mapper.

Class

RVTFamilyConverter Class

Links
RVTFamilyConverter Class, REX.ContentGenerator.Converters Namespace, RVTFamilyConverter Class

RVTFamilyConverter.Settings Property

RVTFamilyConverter.Settings Property
RVTFamilyConverter Class REX.ContentGenerator.Converters Namespace RVTFamilyConverter Class

Gets the settings.

C#
public IRvtContentSettings Settings;
Description

The settings.

Class

RVTFamilyConverter Class

Links
RVTFamilyConverter Class, REX.ContentGenerator.Converters Namespace, RVTFamilyConverter Class

RVTFamilyConverter.EventElementGenerated Event

RVTFamilyConverter.EventElementGenerated Event
RVTFamilyConverter Class REX.ContentGenerator.Converters Namespace RVTFamilyConverter Class

Occurs when element is generated (when the list of elements is used).

C#
public event ElementGenerated EventElementGenerated;
Description
Class

RVTFamilyConverter Class

Links
RVTFamilyConverter Class, REX.ContentGenerator.Converters Namespace, RVTFamilyConverter Class

RVTMaterialFactory Class

RVTMaterialFactory Class
REX.ContentGenerator.Converters Namespace Legend Members Public Methods RVTMaterialFactory Methods

This is class REX.ContentGenerator.Converters.RVTMaterialFactory.

Class Hierarchy
C#
public class RVTMaterialFactory : RVTFamilyFactory;
Namespace

REX.ContentGenerator.Converters Namespace

Public Methods
Public Method | Description
RVTMaterialFactory | This is RVTMaterialFactory, a member of class RVTMaterialFactory.
RVTMaterialFactory | This is RVTMaterialFactory, a member of class RVTMaterialFactory.
RVTMaterialFactory Methods
RVTMaterialFactory Methods | Description
AddElement2FamList | This is AddElement2FamList, a member of class RVTMaterialFactory.
AddElement2FamList | This is AddElement2FamList, a member of class RVTMaterialFactory.
CreateNewMaterial | This is CreateNewMaterial, a member of class RVTMaterialFactory.
GetExistingNames | This is GetExistingNames, a member of class RVTMaterialFactory.
GetMaterialTypeCompLevel | This is GetMaterialTypeCompLevel, a member of class RVTMaterialFactory.
GetRevitTypesForInit | This is GetRevitTypesForInit, a member of class RVTMaterialFactory.
InitList | This is InitList, a member of class RVTMaterialFactory.
OnClose | This is OnClose, a member of class RVTMaterialFactory.
Recalculate | This is Recalculate, a member of class RVTMaterialFactory.
ValidateElement | This is ValidateElement, a member of class RVTMaterialFactory.
Links
REX.ContentGenerator.Converters Namespace, Legend, Members, Public Methods, RVTMaterialFactory Methods

RVTMaterialFactory.RVTMaterialFactory Constructor ()

RVTMaterialFactory.RVTMaterialFactory Constructor ()
RVTMaterialFactory Class REX.ContentGenerator.Converters Namespace RVTMaterialFactory Class

This is RVTMaterialFactory, a member of class RVTMaterialFactory.

C#
public RVTMaterialFactory();
Class

RVTMaterialFactory Class

Links
RVTMaterialFactory Class, REX.ContentGenerator.Converters Namespace, RVTMaterialFactory Class

RVTMaterialFactory.RVTMaterialFactory Constructor (RvtConversionSettings, RVTMaterialPropertySetFactory)

RVTMaterialFactory.RVTMaterialFactory Constructor (RvtConversionSettings, RVTMaterialPropertySetFactory)
RVTMaterialFactory Class REX.ContentGenerator.Converters Namespace RVTMaterialFactory Class

This is RVTMaterialFactory, a member of class RVTMaterialFactory.

C#
public RVTMaterialFactory(RvtConversionSettings Settings, RVTMaterialPropertySetFactory propertySetFactory);
Class

RVTMaterialFactory Class

Links
RVTMaterialFactory Class, REX.ContentGenerator.Converters Namespace, RVTMaterialFactory Class

RVTMaterialFactory.AddElement2FamList Method (Autodesk.Revit.DB.Element)

RVTMaterialFactory.AddElement2FamList Method (Autodesk.Revit.DB.Element)
RVTMaterialFactory Class REX.ContentGenerator.Converters Namespace RVTMaterialFactory Class

This is AddElement2FamList, a member of class RVTMaterialFactory.

C#
public override bool AddElement2FamList(Autodesk.Revit.DB.Element el);
Class

RVTMaterialFactory Class

Links
RVTMaterialFactory Class, REX.ContentGenerator.Converters Namespace, RVTMaterialFactory Class

RVTMaterialFactory.AddElement2FamList Method (Autodesk.Revit.DB.Element, REXFamilyType, bool)

RVTMaterialFactory.AddElement2FamList Method (Autodesk.Revit.DB.Element, REXFamilyType, bool)
RVTMaterialFactory Class REX.ContentGenerator.Converters Namespace RVTMaterialFactory Class

This is AddElement2FamList, a member of class RVTMaterialFactory.

C#
public override bool AddElement2FamList(Autodesk.Revit.DB.Element el, REXFamilyType ft, bool addToDict);
Class

RVTMaterialFactory Class

Links
RVTMaterialFactory Class, REX.ContentGenerator.Converters Namespace, RVTMaterialFactory Class

RVTMaterialFactory.CreateNewMaterial Method

RVTMaterialFactory.CreateNewMaterial Method
RVTMaterialFactory Class REX.ContentGenerator.Converters Namespace RVTMaterialFactory Class

This is CreateNewMaterial, a member of class RVTMaterialFactory.

C#
public Material CreateNewMaterial(EMaterial mat, string name);
Class

RVTMaterialFactory Class

Links
RVTMaterialFactory Class, REX.ContentGenerator.Converters Namespace, RVTMaterialFactory Class