REXMaterialCharacteristics Class REX.ContentGenerator.Families Namespace REXMaterialCharacteristics Class

Initializes a new instance of the REXMaterialCharacteristics class.

C#
public REXMaterialCharacteristics(REXMaterialCharacteristics pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

REXMaterialCharacteristics Class

Links
REXMaterialCharacteristics Class, REX.ContentGenerator.Families Namespace, REXMaterialCharacteristics Class

REXMaterialCharacteristics.REXMaterialCharacteristics Constructor (System.Data.DataRow)

REXMaterialCharacteristics.REXMaterialCharacteristics Constructor (System.Data.DataRow)
REXMaterialCharacteristics Class REX.ContentGenerator.Families Namespace REXMaterialCharacteristics Class

Initializes a new instance of the REXMaterialCharacteristics class.

C#
public REXMaterialCharacteristics(System.Data.DataRow pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

REXMaterialCharacteristics Class

Links
REXMaterialCharacteristics Class, REX.ContentGenerator.Families Namespace, REXMaterialCharacteristics Class

REXMaterialCharacteristics.Clone Method

REXMaterialCharacteristics.Clone Method
REXMaterialCharacteristics Class REX.ContentGenerator.Families Namespace REXMaterialCharacteristics Class

Creates a new object that is a copy of the current instance.

C#
public override object Clone();
Returns

A new object that is a copy of this instance.

Description
Class

REXMaterialCharacteristics Class

Links
REXMaterialCharacteristics Class, REX.ContentGenerator.Families Namespace, REXMaterialCharacteristics Class

REXMaterialCharacteristics.CS Property

REXMaterialCharacteristics.CS Property
REXMaterialCharacteristics Class REX.ContentGenerator.Families Namespace REXMaterialCharacteristics Class

Gets or sets the reduction factor for shear for steel / Burning velocity (mm/min) (data specific for timber design according to CB71).

C#
public double CS;
Description

The factor.

Class

REXMaterialCharacteristics Class

Links
REXMaterialCharacteristics Class, REX.ContentGenerator.Families Namespace, REXMaterialCharacteristics Class

REXMaterialCharacteristics.DAMPCOEF Property

REXMaterialCharacteristics.DAMPCOEF Property
REXMaterialCharacteristics Class REX.ContentGenerator.Families Namespace REXMaterialCharacteristics Class

Gets or sets the damping coefficient.

C#
public double DAMPCOEF;
Description

The damping coefficient.

Class

REXMaterialCharacteristics Class

Links
REXMaterialCharacteristics Class, REX.ContentGenerator.Families Namespace, REXMaterialCharacteristics Class

REXMaterialCharacteristics.E Property

REXMaterialCharacteristics.E Property
REXMaterialCharacteristics Class REX.ContentGenerator.Families Namespace REXMaterialCharacteristics Class

Gets or sets the E (Young's modulus).

C#
public double E;
Description

The E.

Class

REXMaterialCharacteristics Class

Links
REXMaterialCharacteristics Class, REX.ContentGenerator.Families Namespace, REXMaterialCharacteristics Class

REXMaterialCharacteristics.GMEAN Property

REXMaterialCharacteristics.GMEAN Property
REXMaterialCharacteristics Class REX.ContentGenerator.Families Namespace REXMaterialCharacteristics Class

Gets or sets the average modulus G.

C#
public double GMEAN;
Description

The average modulus G.

Class

REXMaterialCharacteristics Class

Links
REXMaterialCharacteristics Class, REX.ContentGenerator.Families Namespace, REXMaterialCharacteristics Class

REXMaterialCharacteristics.KIRCHOFF Property

REXMaterialCharacteristics.KIRCHOFF Property
REXMaterialCharacteristics Class REX.ContentGenerator.Families Namespace REXMaterialCharacteristics Class

Gets or sets the shear modulus G.

C#
public double KIRCHOFF;
Description

The shear modulus G.

Class

REXMaterialCharacteristics Class

Links
REXMaterialCharacteristics Class, REX.ContentGenerator.Families Namespace, REXMaterialCharacteristics Class

REXMaterialCharacteristics.LX Property

REXMaterialCharacteristics.LX Property
REXMaterialCharacteristics Class REX.ContentGenerator.Families Namespace REXMaterialCharacteristics Class

Gets or sets the thermal expansion coefficient.

C#
public double LX;
Description

The thermal expansion coefficient.

Class

REXMaterialCharacteristics Class

Links
REXMaterialCharacteristics Class, REX.ContentGenerator.Families Namespace, REXMaterialCharacteristics Class

REXMaterialCharacteristics.NU Property

REXMaterialCharacteristics.NU Property
REXMaterialCharacteristics Class REX.ContentGenerator.Families Namespace REXMaterialCharacteristics Class

Gets or sets the Poisson's ratio.

C#
public double NU;
Description

Poisson's ratio.

Class

REXMaterialCharacteristics Class

Links
REXMaterialCharacteristics Class, REX.ContentGenerator.Families Namespace, REXMaterialCharacteristics Class

REXMaterialCharacteristics.RE Property

REXMaterialCharacteristics.RE Property
REXMaterialCharacteristics Class REX.ContentGenerator.Families Namespace REXMaterialCharacteristics Class

Gets or sets the design strength.

C#
public double RE;
Description

The design strength.

Class

REXMaterialCharacteristics Class

Links
REXMaterialCharacteristics Class, REX.ContentGenerator.Families Namespace, REXMaterialCharacteristics Class

REXMaterialCharacteristics.RE_AXCOMP Property

REXMaterialCharacteristics.RE_AXCOMP Property
REXMaterialCharacteristics Class REX.ContentGenerator.Families Namespace REXMaterialCharacteristics Class

Gets or sets the axial compression resistance (for timber).

C#
public double RE_AXCOMP;
Description

The Axial compression resistance (for timber).

Class

REXMaterialCharacteristics Class

Links
REXMaterialCharacteristics Class, REX.ContentGenerator.Families Namespace, REXMaterialCharacteristics Class

REXMaterialCharacteristics.RE_AXTENS Property

REXMaterialCharacteristics.RE_AXTENS Property
REXMaterialCharacteristics Class REX.ContentGenerator.Families Namespace REXMaterialCharacteristics Class

Gets or sets the axial tension resistance (for timber).

C#
public double RE_AXTENS;
Description

The axial tension resistance (for timber).

Class

REXMaterialCharacteristics Class

Links
REXMaterialCharacteristics Class, REX.ContentGenerator.Families Namespace, REXMaterialCharacteristics Class

REXMaterialCharacteristics.RE_BENDING Property

REXMaterialCharacteristics.RE_BENDING Property
REXMaterialCharacteristics Class REX.ContentGenerator.Families Namespace REXMaterialCharacteristics Class

Gets or sets the bending strength (for timber).

C#
public double RE_BENDING;
Description

The bending strength (for timber).

Class

REXMaterialCharacteristics Class

Links
REXMaterialCharacteristics Class, REX.ContentGenerator.Families Namespace, REXMaterialCharacteristics Class

REXMaterialCharacteristics.RE_SHEAR Property

REXMaterialCharacteristics.RE_SHEAR Property
REXMaterialCharacteristics Class REX.ContentGenerator.Families Namespace REXMaterialCharacteristics Class

Gets or sets the shear strength (for timber).

C#
public double RE_SHEAR;
Description

The shear strength (for timber).

Class

REXMaterialCharacteristics Class

Links
REXMaterialCharacteristics Class, REX.ContentGenerator.Families Namespace, REXMaterialCharacteristics Class

REXMaterialCharacteristics.RE_TRCOMPR Property

REXMaterialCharacteristics.RE_TRCOMPR Property
REXMaterialCharacteristics Class REX.ContentGenerator.Families Namespace REXMaterialCharacteristics Class

Gets or sets the transversal compression resistance (for timber).

C#
public double RE_TRCOMPR;
Description

The transversal compression resistance (for timber).

Class

REXMaterialCharacteristics Class

Links
REXMaterialCharacteristics Class, REX.ContentGenerator.Families Namespace, REXMaterialCharacteristics Class

REXMaterialCharacteristics.RE_TRTENS Property

REXMaterialCharacteristics.RE_TRTENS Property
REXMaterialCharacteristics Class REX.ContentGenerator.Families Namespace REXMaterialCharacteristics Class