ContourLine Class REX.ContentGenerator.Geometry Namespace ContourLine Class

Initializes a new instance of the ContourLine class.

C#
public ContourLine(ContourLine pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

ContourLine Class

Links
ContourLine Class, REX.ContentGenerator.Geometry Namespace, ContourLine Class

ContourLine.ContourLine Constructor (REXxyz, REXxyz)

ContourLine.ContourLine Constructor (REXxyz, REXxyz)
ContourLine Class REX.ContentGenerator.Geometry Namespace ContourLine Class

Initializes a new instance of the ContourLine class.

C#
public ContourLine(REXxyz st, REXxyz end);
Parameters
Parameters | Description
st | The start.
end | The end.
Description
Class

ContourLine Class

Links
ContourLine Class, REX.ContentGenerator.Geometry Namespace, ContourLine Class

ContourLine.ContourLine Constructor (System.Runtime.Serialization.SerializationInfo, System.Runtime.Serialization.StreamingContext)

ContourLine.ContourLine Constructor (System.Runtime.Serialization.SerializationInfo, System.Runtime.Serialization.StreamingContext)
ContourLine Class REX.ContentGenerator.Geometry Namespace ContourLine Class

Initializes a new instance of the ContourLine class.

C#
public ContourLine(System.Runtime.Serialization.SerializationInfo info, System.Runtime.Serialization.StreamingContext context);
Parameters
Parameters | Description
info | Serialization data.
context | The context.
Description
Class

ContourLine Class

Links
ContourLine Class, REX.ContentGenerator.Geometry Namespace, ContourLine Class

ContourLine.ContourLine Constructor (double, double, double, double)

ContourLine.ContourLine Constructor (double, double, double, double)
ContourLine Class REX.ContentGenerator.Geometry Namespace ContourLine Class

Initializes a new instance of the ContourLine class.

C#
public ContourLine(double xst, double yst, double xend, double yend);
Parameters
Parameters | Description
xst | The x start.
yst | The y start.
xend | The x end.
yend | The y end.
Description
Class

ContourLine Class

Links
ContourLine Class, REX.ContentGenerator.Geometry Namespace, ContourLine Class

ContourLine.ContourLine Constructor (double, double, double, double, double, double)

ContourLine.ContourLine Constructor (double, double, double, double, double, double)
ContourLine Class REX.ContentGenerator.Geometry Namespace ContourLine Class

Initializes a new instance of the ContourLine class.

C#
public ContourLine(double xst, double yst, double zst, double xend, double yend, double zend);
Parameters
Parameters | Description
xst | The x start.
yst | The y start.
zst | The z start.
xend | The x end.
yend | The y end.
zend | The z end.
Description
Class

ContourLine Class

Links
ContourLine Class, REX.ContentGenerator.Geometry Namespace, ContourLine Class

ContourLine.GetEnd Method

ContourLine.GetEnd Method
ContourLine Class REX.ContentGenerator.Geometry Namespace ContourLine Class

Gets the end point in a plane.

C#
public REXxyz GetEnd(ECoords coords);
Parameters
Parameters | Description
coords | The coordinate system (plane).
Returns

The end point.

Description
Class

ContourLine Class

Links
ContourLine Class, REX.ContentGenerator.Geometry Namespace, ContourLine Class

ContourLine.GetPointList Method

ContourLine.GetPointList Method
ContourLine Class REX.ContentGenerator.Geometry Namespace ContourLine Class

Gets the list of points.

C#
public override List<REXxyz> GetPointList(bool end);
Parameters
Parameters | Description
end | If the end point included.
Returns

Returns the list of points.

Description
Class

ContourLine Class

Links
ContourLine Class, REX.ContentGenerator.Geometry Namespace, ContourLine Class

ContourLine.GetStart Method

ContourLine.GetStart Method
ContourLine Class REX.ContentGenerator.Geometry Namespace ContourLine Class

Gets the start point in a plane.

C#
public REXxyz GetStart(ECoords coords);
Parameters
Parameters | Description
coords | The coordinate system (plane).
Returns

The start point.

Description
Class

ContourLine Class

Links
ContourLine Class, REX.ContentGenerator.Geometry Namespace, ContourLine Class

ContourLine.MultiplyLengthDim Method

ContourLine.MultiplyLengthDim Method
ContourLine Class REX.ContentGenerator.Geometry Namespace ContourLine Class

Multiplies length dimensions by the coefficient.

C#
public override void MultiplyLengthDim(double coeff);
Parameters
Parameters | Description
coeff | The coefficient.
Description
Class

ContourLine Class

Links
ContourLine Class, REX.ContentGenerator.Geometry Namespace, ContourLine Class

ContourLine.Transform Method

ContourLine.Transform Method
ContourLine Class REX.ContentGenerator.Geometry Namespace ContourLine Class

Applies the specified transformation to the element.

C#
public override void Transform(TransformDbl trans, bool toLocal);
Parameters
Parameters | Description
trans | The transformation object.
toLocal | If transformation from the global to the local coordinate system.
Description
Class

ContourLine Class

Links
ContourLine Class, REX.ContentGenerator.Geometry Namespace, ContourLine Class

ContourLine.Translate Method

ContourLine.Translate Method
ContourLine Class REX.ContentGenerator.Geometry Namespace ContourLine Class

Applies the specified translation vector to the element.

C#
public override void Translate(double x, double y);
Parameters
Parameters | Description
x | The x.
y | The y.
Description
Class

ContourLine Class

Links
ContourLine Class, REX.ContentGenerator.Geometry Namespace, ContourLine Class

ContourLine.End Property

ContourLine.End Property
ContourLine Class REX.ContentGenerator.Geometry Namespace ContourLine Class

Gets or sets the end point.

C#
public REXxyz End;
Description

The end point.

Class

ContourLine Class

Links
ContourLine Class, REX.ContentGenerator.Geometry Namespace, ContourLine Class

ContourLine.Start Property

ContourLine.Start Property
ContourLine Class REX.ContentGenerator.Geometry Namespace ContourLine Class

Gets or sets the start point.

C#
public REXxyz Start;
Description

The start point.

Class

ContourLine Class

Links
ContourLine Class, REX.ContentGenerator.Geometry Namespace, ContourLine Class

REXSectionAnalyzer Class

REXSectionAnalyzer Class
REX.ContentGenerator.Geometry Namespace

This is class REX.ContentGenerator.Geometry.REXSectionAnalyzer.

Class Hierarchy
C#
public class REXSectionAnalyzer;
Namespace

REX.ContentGenerator.Geometry Namespace

Links
REX.ContentGenerator.Geometry Namespace
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXSectionTypeAnalyzer Class

REXSectionTypeAnalyzer Class
REX.ContentGenerator.Geometry Namespace Legend Members Public Methods REXSectionTypeAnalyzer Methods

This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer.

Class Hierarchy
C#
public abstract class REXSectionTypeAnalyzer;
Namespace

REX.ContentGenerator.Geometry Namespace

Public Methods
Public Method | Description
REXSectionTypeAnalyzer | This is REXSectionTypeAnalyzer, a member of class REXSectionTypeAnalyzer.
REXSectionTypeAnalyzer Methods
REXSectionTypeAnalyzer Methods | Description
BuildVectorShape | This is BuildVectorShape, a member of class REXSectionTypeAnalyzer.
FitCompoundProfilePattern | This is FitCompoundProfilePattern, a member of class REXSectionTypeAnalyzer.
GetMaximumLength | This is GetMaximumLength, a member of class REXSectionTypeAnalyzer.
GetNextIndex | This is GetNextIndex, a member of class REXSectionTypeAnalyzer.
GetParametricDescription | This is GetParametricDescription, a member of class REXSectionTypeAnalyzer.
GetParametricDescription | This is GetParametricDescription, a member of class REXSectionTypeAnalyzer.
GetPreviousIndex | This is GetPreviousIndex, a member of class REXSectionTypeAnalyzer.