public double MASS;
Description

The weight per length unit of a section.

Class

REXSectionDBCharacteristics Class

Links
REXSectionDBCharacteristics Class, REX.ContentGenerator.Families Namespace, REXSectionDBCharacteristics Class

REXSectionDBCharacteristics.MSY Property

REXSectionDBCharacteristics.MSY Property
REXSectionDBCharacteristics Class REX.ContentGenerator.Families Namespace REXSectionDBCharacteristics Class

Gets or sets the plastic section modulus (bending) about the Y axis.

C#
public double MSY;
Description

The plastic section modulus (bending) about the Y axis.

Class

REXSectionDBCharacteristics Class

Links
REXSectionDBCharacteristics Class, REX.ContentGenerator.Families Namespace, REXSectionDBCharacteristics Class

REXSectionDBCharacteristics.MSZ Property

REXSectionDBCharacteristics.MSZ Property
REXSectionDBCharacteristics Class REX.ContentGenerator.Families Namespace REXSectionDBCharacteristics Class

Gets or sets the plastic section modulus (bending) about the Z axis.

C#
public double MSZ;
Description

The plastic section modulus (bending) about the Z axis.

Class

REXSectionDBCharacteristics Class

Links
REXSectionDBCharacteristics Class, REX.ContentGenerator.Families Namespace, REXSectionDBCharacteristics Class

REXSectionDBCharacteristics.SX Property

REXSectionDBCharacteristics.SX Property
REXSectionDBCharacteristics Class REX.ContentGenerator.Families Namespace REXSectionDBCharacteristics Class

Gets or sets the cross-sectional area.

C#
public double SX;
Description

The cross-sectional area.

Class

REXSectionDBCharacteristics Class

Links
REXSectionDBCharacteristics Class, REX.ContentGenerator.Families Namespace, REXSectionDBCharacteristics Class

REXSectionDBCharacteristics.SY Property

REXSectionDBCharacteristics.SY Property
REXSectionDBCharacteristics Class REX.ContentGenerator.Families Namespace REXSectionDBCharacteristics Class

Gets or sets the reduced section area for XY-shear deformation calculations - considering the influence of shear forces along Y axis.

C#
public double SY;
Description

The reduced section.

Class

REXSectionDBCharacteristics Class

Links
REXSectionDBCharacteristics Class, REX.ContentGenerator.Families Namespace, REXSectionDBCharacteristics Class

REXSectionDBCharacteristics.SZ Property

REXSectionDBCharacteristics.SZ Property
REXSectionDBCharacteristics Class REX.ContentGenerator.Families Namespace REXSectionDBCharacteristics Class

Gets or sets the reduced section area for XZ-shear deformation calculations - considering the influence of shear forces along Z axis.

C#
public double SZ;
Description

The reduced section area.

Class

REXSectionDBCharacteristics Class

Links
REXSectionDBCharacteristics Class, REX.ContentGenerator.Families Namespace, REXSectionDBCharacteristics Class

REXSectionDBDescription Class

REXSectionDBDescription Class
REX.ContentGenerator.Families Namespace Legend Members Public Methods REXSectionDBDescription Methods REXSectionDBDescription Properties

Represents parameters of the database section.

Class Hierarchy
C#
[Serializable()]
public class REXSectionDBDescription : REXDBDescription;
Description
Namespace

REX.ContentGenerator.Families Namespace

Public Methods
Public Method | Description
REXSectionDBDescription | Initializes a new instance of the REXSectionDBDescription class.
REXSectionDBDescription | Initializes a new instance of the REXSectionDBDescription class.
REXSectionDBDescription | Initializes a new instance of the REXSectionDBDescription class.
REXSectionDBDescription | Initializes a new instance of the REXSectionDBDescription class.
REXSectionDBDescription | Initializes a new instance of the REXSectionDBDescription class.
REXSectionDBDescription Methods
REXSectionDBDescription Methods | Description
Clone | Creates a new object that is a copy of the current instance.
CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
GetContour | Gets the contour of the section.
GetName | Gets the name of the section.
GetSectionType | Gets the type of the section.
GetSectionType | Gets the type of the section.
REXSectionDBDescription Properties
REXSectionDBDescription Properties | Description
Characteristics | Gets or sets the characteristics of the section.
Description | Gets or sets the description of the section.
DIM1 | Gets or sets the first numeric component of the section label
DIM2 | Gets or sets the second numeric component of the section label.
DIM3 | Gets or sets the third numeric component of the section label.
Dimensions | Gets or sets the dimensions.
NAME | Gets or sets the name of the section.
Links
REX.ContentGenerator.Families Namespace, Legend, Members, Public Methods, REXSectionDBDescription Methods, REXSectionDBDescription Properties

REXSectionDBDescription.REXSectionDBDescription Constructor ()

REXSectionDBDescription.REXSectionDBDescription Constructor ()
REXSectionDBDescription Class REX.ContentGenerator.Families Namespace REXSectionDBDescription Class

Initializes a new instance of the REXSectionDBDescription class.

C#
public REXSectionDBDescription();
Description
Class

REXSectionDBDescription Class

Links
REXSectionDBDescription Class, REX.ContentGenerator.Families Namespace, REXSectionDBDescription Class

REXSectionDBDescription.REXSectionDBDescription Constructor (REXSectionDBDescription)

REXSectionDBDescription.REXSectionDBDescription Constructor (REXSectionDBDescription)
REXSectionDBDescription Class REX.ContentGenerator.Families Namespace REXSectionDBDescription Class

Initializes a new instance of the REXSectionDBDescription class.

C#
public REXSectionDBDescription(REXSectionDBDescription pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

REXSectionDBDescription Class

Links
REXSectionDBDescription Class, REX.ContentGenerator.Families Namespace, REXSectionDBDescription Class

REXSectionDBDescription.REXSectionDBDescription Constructor (string)

REXSectionDBDescription.REXSectionDBDescription Constructor (string)
REXSectionDBDescription Class REX.ContentGenerator.Families Namespace REXSectionDBDescription Class

Initializes a new instance of the REXSectionDBDescription class.

C#
public REXSectionDBDescription(string dbName);
Parameters
Parameters | Description
dbName | The name of the database.
Description
Class

REXSectionDBDescription Class

Links
REXSectionDBDescription Class, REX.ContentGenerator.Families Namespace, REXSectionDBDescription Class

REXSectionDBDescription.REXSectionDBDescription Constructor (string, string, DTableDataObjectCollection)

REXSectionDBDescription.REXSectionDBDescription Constructor (string, string, DTableDataObjectCollection)
REXSectionDBDescription Class REX.ContentGenerator.Families Namespace REXSectionDBDescription Class

Initializes a new instance of the REXSectionDBDescription class.

C#
public REXSectionDBDescription(string dir, string dbname, DTableDataObjectCollection col);
Parameters
Parameters | Description
dir | The directory.
dbname | The name of the database.
col | The collection.
Description
Class

REXSectionDBDescription Class

Links
REXSectionDBDescription Class, REX.ContentGenerator.Families Namespace, REXSectionDBDescription Class

REXSectionDBDescription.REXSectionDBDescription Constructor (string, string, System.Data.DataRow)

REXSectionDBDescription.REXSectionDBDescription Constructor (string, string, System.Data.DataRow)
REXSectionDBDescription Class REX.ContentGenerator.Families Namespace REXSectionDBDescription Class

Initializes a new instance of the REXSectionDBDescription class.

C#
public REXSectionDBDescription(string dir, string dbname, System.Data.DataRow row);
Parameters
Parameters | Description
dir | The directory.
dbname | The name of the database.
row | The row.
Description
Class

REXSectionDBDescription Class

Links