REXUnitComboBox.GetInterfaceMinValue Method

REXUnitComboBox.GetInterfaceMinValue Method
REXUnitComboBox Class REX.Controls.WPF Namespace REXUnitComboBox Class

Gets the minimum value and converts it to interface units.

C#
public double GetInterfaceMinValue(REXInterfaceType interfaceType);
Parameters
Parameters | Description
interfaceType | The product context.
Returns

The value.

Description
Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.WPF Namespace, REXUnitComboBox Class

REXUnitComboBox.SetBaseMaxValue Method

REXUnitComboBox.SetBaseMaxValue Method
REXUnitComboBox Class REX.Controls.WPF Namespace REXUnitComboBox Class

Set the maximum value defined in base units.

C#
public void SetBaseMaxValue(double value);
Parameters
Parameters | Description
value | The value.
Description
Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.WPF Namespace, REXUnitComboBox Class

REXUnitComboBox.SetBaseMinValue Method

REXUnitComboBox.SetBaseMinValue Method
REXUnitComboBox Class REX.Controls.WPF Namespace REXUnitComboBox Class

Set the minimum value defined in base units.

C#
public void SetBaseMinValue(double value);
Parameters
Parameters | Description
value | The value.
Description
Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.WPF Namespace, REXUnitComboBox Class

REXUnitComboBox.SetComplexDataBaseValue Method

REXUnitComboBox.SetComplexDataBaseValue Method
REXUnitComboBox Class REX.Controls.WPF Namespace REXUnitComboBox Class

Set the list of values defined in base units.

C#
public void SetComplexDataBaseValue(List<double> values);
Parameters
Parameters | Description
values | The values.
Description
Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.WPF Namespace, REXUnitComboBox Class

REXUnitComboBox.SetComplexDataInterfaceValue Method

REXUnitComboBox.SetComplexDataInterfaceValue Method
REXUnitComboBox Class REX.Controls.WPF Namespace REXUnitComboBox Class

Set the list of values defined in interface units.

C#
public void SetComplexDataInterfaceValue(List<double> values, REXInterfaceType interfaceType);
Parameters
Parameters | Description
values | The values.
interfaceType | The product context.
Description
Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.WPF Namespace, REXUnitComboBox Class

REXUnitComboBox.SetDataBaseValue Method

REXUnitComboBox.SetDataBaseValue Method
REXUnitComboBox Class REX.Controls.WPF Namespace REXUnitComboBox Class

Set the value in base units.

C#
public void SetDataBaseValue(double value);
Parameters
Parameters | Description
value | The value.
Description
Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.WPF Namespace, REXUnitComboBox Class

REXUnitComboBox.SetDataInterfaceValue Method

REXUnitComboBox.SetDataInterfaceValue Method
REXUnitComboBox Class REX.Controls.WPF Namespace REXUnitComboBox Class

Set the value in interface units.

C#
public void SetDataInterfaceValue(double value, REXInterfaceType interfaceType);
Parameters
Parameters | Description
value | The value.
interfaceType | The product context.
Description
Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.WPF Namespace, REXUnitComboBox Class

REXUnitComboBox.SetInterfaceMaxValue Method

REXUnitComboBox.SetInterfaceMaxValue Method
REXUnitComboBox Class REX.Controls.WPF Namespace REXUnitComboBox Class

Set the maximum value defined in interface units.

C#
public void SetInterfaceMaxValue(double value, REXInterfaceType interfaceType);
Parameters
Parameters | Description
value | The value.
interfaceType | The product context.
Description
Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.WPF Namespace, REXUnitComboBox Class

REXUnitComboBox.SetInterfaceMinValue Method

REXUnitComboBox.SetInterfaceMinValue Method
REXUnitComboBox Class REX.Controls.WPF Namespace REXUnitComboBox Class

Set the minimum value defined in interface units.

C#
public void SetInterfaceMinValue(double value, REXInterfaceType interfaceType);
Parameters
Parameters | Description
value | The value.
interfaceType | The product context.
Description
Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.WPF Namespace, REXUnitComboBox Class

REXUnitComboBox.ComplexDoubleValueBase Property

REXUnitComboBox.ComplexDoubleValueBase Property
REXUnitComboBox Class REX.Controls.WPF Namespace REXUnitComboBox Class

Gets or sets the complex double value.

C#
public ObservableCollection<double> ComplexDoubleValueBase;
Description

The complex double value.

Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.WPF Namespace, REXUnitComboBox Class

REXUnitComboBox.DoubleValueBase Property

REXUnitComboBox.DoubleValueBase Property
REXUnitComboBox Class REX.Controls.WPF Namespace REXUnitComboBox Class

Gets or sets the double value.

C#
public double DoubleValueBase;
Description

The double value.

Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.WPF Namespace, REXUnitComboBox Class

REXUnitComboBox.Power Property

REXUnitComboBox.Power Property
REXUnitComboBox Class REX.Controls.WPF Namespace REXUnitComboBox Class

Gets or sets the power of the unit.

C#
public double Power;
Description

The power.

Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.WPF Namespace, REXUnitComboBox Class

REXUnitComboBox.UnitEngine Property

REXUnitComboBox.UnitEngine Property
REXUnitComboBox Class REX.Controls.WPF Namespace REXUnitComboBox Class

Gets or sets the unit engine.

C#
public Autodesk.REX.Framework.IREXUnits UnitEngine;
Description

The unit engine.

Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.WPF Namespace, REXUnitComboBox Class

REXUnitComboBox.UnitType Property

REXUnitComboBox.UnitType Property
REXUnitComboBox Class REX.Controls.WPF Namespace REXUnitComboBox Class

Gets or sets the type of the unit.

C#
public Autodesk.REX.Framework.EUnitType UnitType;
Description

The type of the unit.

Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.WPF Namespace, REXUnitComboBox Class

REXUnitEditBox Class

REXUnitEditBox Class
REX.Controls.WPF Namespace Legend Members Public Methods REXUnitEditBox Fields REXUnitEditBox Methods REXUnitEditBox Properties

Represents the REXEditBox control with a built in IREXUnitEngine.

Class Hierarchy
C#
public class REXUnitEditBox : REXEditBox;
Description
Namespace

REX.Controls.WPF Namespace

Public Methods
Public Method | Description
REXUnitEditBox | This is REXUnitEditBox, a member of class REXUnitEditBox.
REXUnitEditBox Fields
REXUnitEditBox Fields | Description
ComplexDoubleValueBaseProperty | This is ComplexDoubleValueBaseProperty, a member of class REXUnitEditBox.
DoubleValueBaseProperty | This is DoubleValueBaseProperty, a member of class REXUnitEditBox.
PowerProperty | This is PowerProperty, a member of class REXUnitEditBox.
UnitTypeProperty | This is UnitTypeProperty, a member of class REXUnitEditBox.
REXUnitEditBox Methods
REXUnitEditBox Methods | Description
GetBaseMaxValue | Gets the maximum value and converts it to base units.
GetBaseMinValue | Gets the minimum value and converts it to base units.
GetComplexDataBaseValue | Get the values and convert it to base units.
GetComplexDataInterfaceValue | Get the values and convert it to interface units.
GetDataBaseValue | Gets the value and converts it to base units.
GetDataInterfaceValue | Gets the value and converts it to interface units.
GetInterfaceMaxValue | Gets the maximum value and converts it to interface units.
GetInterfaceMinValue | Gets the minimum value and converts it to interface units.
SetBaseMaxValue | Set the maximum value defined in base units.
SetBaseMinValue | Set the minimum value defined in base units.
SetComplexDataBaseValue | Set the list of values defined in base units.
SetComplexDataInterfaceValue | Set the list of values defined in interface units.