public new Boolean Multiline;
Returns

true if the control is a multiline T:System.Windows.Forms.TextBox control; otherwise, false. The default is false.

Description

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class

REXEditBox.OnDisableAction Property

REXEditBox.OnDisableAction Property
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets or sets a value indicating whether the foreground should be hidden when the control is disabled.

C#
[Browsable(true)]
[Category("Data")]
public EOnDisable OnDisableAction;
Description

The behaviour of the control's foreground.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class

REXEditBox.OriginalTextOnEnter Property

REXEditBox.OriginalTextOnEnter Property
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets or sets a value indicating whether an original text should be set when the user enters the control.

C#
[Browsable(true)]
[Category("Behavior")]
public bool OriginalTextOnEnter;
Description

True if original text is to be set; otherwise, false.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class

REXEditBox.PasswordChar Property

REXEditBox.PasswordChar Property
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets or sets the character used to mask characters of a password in a single-line T:System.Windows.Forms.TextBox control.

C#
[Browsable(false)]
public new Char PasswordChar;
Returns

The character used to mask characters entered in a single-line T:System.Windows.Forms.TextBox control. Set the value of this property to 0 (character value) if you do not want the control to mask characters as they are typed. Equals 0 (character value) by default.

Description

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class

REXEditBox.RangeMax Property

REXEditBox.RangeMax Property
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets or sets the highest possible value.

C#
[Browsable(true)]
[Category("Data")]
[DefaultValue(Double.PositiveInfinity)]
public Double RangeMax;
Description

The highest possible value.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class

REXEditBox.RangeMaxCheck Property

REXEditBox.RangeMaxCheck Property
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets or sets a value indicating whether the value should be validated due to the RangeMax.

C#
[Browsable(true)]
[Category("Data")]
[DefaultValue(false)]
public Boolean RangeMaxCheck;
Description

True if validate; otherwise false.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class

REXEditBox.RangeMin Property

REXEditBox.RangeMin Property
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets or sets the minimum possible value.

C#
[Browsable(true)]
[Category("Data")]
[DefaultValue(Double.NegativeInfinity)]
public Double RangeMin;
Description

The minimum possible value.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class

REXEditBox.RangeMinCheck Property

REXEditBox.RangeMinCheck Property
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets or sets a value indicating whether the value should be validated due to the RangeMin.

C#
[Browsable(true)]
[Category("Data")]
[DefaultValue(false)]
public Boolean RangeMinCheck;
Description

True if validate; otherwise false.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class

REXEditBox.RememberCorrect Property

REXEditBox.RememberCorrect Property
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets or sets a value indicating whether the correct value should be restored in case of the validation failure.

C#
[Browsable(true)]
[Category("Data")]
public Boolean RememberCorrect;
Description

True if the value should be restored; otherwise false.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class

REXEditBox.RoundingFractional Property

REXEditBox.RoundingFractional Property
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets or sets the rounding for fractional units.

C#
[Browsable(true)]
[Category("Data")]
public EFractialRound RoundingFractional;
Description

The rounding.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class

REXEditBox.RoundingIncrement Property

REXEditBox.RoundingIncrement Property
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets or sets the rounding increment (for the DECIMAL DataType).

C#
[Browsable(true)]
[Category("Data")]
[DefaultValue(1E-05)]
public Double RoundingIncrement;
Description

The rounding increment.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class

REXEditBox.Separator Property

REXEditBox.Separator Property
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets or sets the decimal separator.

C#
[Browsable(true)]
[Category("Data")]
public String Separator;
Description

The separator.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class

REXEditBox.Text Property

REXEditBox.Text Property
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets the text contents of the control.

C#
[Browsable(true)]
public new string Text;
Description

The text.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class

REXEditBox.TokensRangeMaxCheck Property

REXEditBox.TokensRangeMaxCheck Property
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets or sets a value indicating whether the number of elements should be validated due to the MaxTokens.

C#
[Category("Complex")]
[Browsable(true)]
[DefaultValue(false)]
public Boolean TokensRangeMaxCheck;
Description

True if validate; otherwise, false.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class

REXEditBox.TokensRangeMinCheck Property

REXEditBox.TokensRangeMinCheck Property
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets or sets a value indicating whether the number of elements should be validated due to the MinTokens.

C#
[Category("Complex")]
[Browsable(true)]
[DefaultValue(false)]
public Boolean TokensRangeMinCheck;
Description

True if validate; otherwise, false.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class

REXEditBox.UnitSymbol Property

REXEditBox.UnitSymbol Property
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets or sets the unit symbol.

C#
[Browsable(true)]
[Category("Data")]
[DefaultValue("")]
public String UnitSymbol;
Description

The unit symbol.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class

REXEditBox.UseSystemPasswordChar Property

REXEditBox.UseSystemPasswordChar Property
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets or sets a value indicating whether the text in the T:System.Windows.Forms.TextBox control should appear as the default password character.

C#
[Browsable(false)]
public new Boolean UseSystemPasswordChar;
Returns

true if the text in the T:System.Windows.Forms.TextBox control should appear as the default password character; otherwise, false.

Description

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class

REXEditBox.WordWrap Property

REXEditBox.WordWrap Property
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Indicates whether a multiline text box control automatically wraps words to the beginning of the next line when necessary.

C#
[Browsable(false)]
public new Boolean WordWrap;
Returns