REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.RoundingIncrement Property

REXEditControlEngine.RoundingIncrement Property
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets or sets the rounding increment (for the DECIMAL DataType).

C#
public Double RoundingIncrement;
Description

The rounding increment.

Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.Separator Property

REXEditControlEngine.Separator Property
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets or sets the decimal separator.

C#
public String Separator;
Description

The separator.

Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.Tag Property

REXEditControlEngine.Tag Property
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets or sets the tag.

C#
public object Tag;
Description

The tag.

Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.Text Property

REXEditControlEngine.Text Property
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets the text contents of the control.

C#
public string Text;
Description

The text.

Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.TokensRangeMaxCheck Property

REXEditControlEngine.TokensRangeMaxCheck Property
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets or sets a value indicating whether the number of elements should be validated due to the MaxTokens.

C#
[DefaultValue(false)]
public Boolean TokensRangeMaxCheck;
Description

True if validate; otherwise, false.

Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.TokensRangeMinCheck Property

REXEditControlEngine.TokensRangeMinCheck Property
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets or sets a value indicating whether the number of elements should be validated due to the MinTokens.

C#
[DefaultValue(false)]
public Boolean TokensRangeMinCheck;
Description

True if validate; otherwise, false.

Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.UnitEngine Property

REXEditControlEngine.UnitEngine Property
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets or sets the unit engine.

C#
public Autodesk.REX.Framework.IREXUnits UnitEngine;
Description

The unit engine.

Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.UnitSymbol Property

REXEditControlEngine.UnitSymbol Property
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets or sets the unit symbol.

C#
[DefaultValue("")]
public String UnitSymbol;
Description

The unit symbol.

Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.UnitType Property

REXEditControlEngine.UnitType Property
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets or sets the type of the unit.

C#
public Autodesk.REX.Framework.EUnitType UnitType;
Description

The type of the unit.

Remarks

Important when the UnitEngine is set.

Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.EventComplexDoubleValueChanged Event

REXEditControlEngine.EventComplexDoubleValueChanged Event
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Occurs when the complex value changes.

C#
public event ComplexDoubleValueChanged EventComplexDoubleValueChanged;
Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.EventDoubleValueChanged Event

REXEditControlEngine.EventDoubleValueChanged Event
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Occurs when the value changes.

C#
public event DoubleValueChanged EventDoubleValueChanged;
Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

IComboEditControl Interface

IComboEditControl Interface
REX.Controls.Common Namespace Legend Members IComboEditControl Methods

An interface that may be used to attach the custom control to the REXComboEditControlEngine.

Class Hierarchy
C#
public interface IComboEditControl : IEditControl;
Description
Namespace

REX.Controls.Common Namespace

IComboEditControl Methods
IComboEditControl Methods | Description
Editable | Gets a value indicating whether the control is editable.
GetItems | Gets the collection of the items contained in the control.
GetSelectedIndex | Gets the index specifying the currently selected item.
SetSelectedIndex | Sets the index specifying the currently selected item.
Links
REX.Controls.Common Namespace, Legend, Members, IComboEditControl Methods

IComboEditControl.Editable Method

IComboEditControl.Editable Method
IComboEditControl Interface REX.Controls.Common Namespace IComboEditControl Interface

Gets a value indicating whether the control is editable.

C#
bool Editable();
Returns

True if the control can be edited; otherwise false.

Description
Interface

IComboEditControl Interface

Links
IComboEditControl Interface, REX.Controls.Common Namespace, IComboEditControl Interface

IComboEditControl.GetItems Method

IComboEditControl.GetItems Method
IComboEditControl Interface REX.Controls.Common Namespace IComboEditControl Interface

Gets the collection of the items contained in the control.

C#
List<string> GetItems();
Returns

The list of items.

Description
Interface

IComboEditControl Interface

Links
IComboEditControl Interface, REX.Controls.Common Namespace, IComboEditControl Interface

IComboEditControl.GetSelectedIndex Method

IComboEditControl.GetSelectedIndex Method
IComboEditControl Interface REX.Controls.Common Namespace IComboEditControl Interface

Gets the index specifying the currently selected item.

C#
int GetSelectedIndex();
Returns

The index.

Description
Interface

IComboEditControl Interface

Links
IComboEditControl Interface, REX.Controls.Common Namespace, IComboEditControl Interface

IComboEditControl.SetSelectedIndex Method

IComboEditControl.SetSelectedIndex Method
IComboEditControl Interface REX.Controls.Common Namespace IComboEditControl Interface

Sets the index specifying the currently selected item.

C#
void SetSelectedIndex(int index);
Parameters
Parameters | Description
index | The index of the selected item.
Description
Interface

IComboEditControl Interface

Links
IComboEditControl Interface, REX.Controls.Common Namespace, IComboEditControl Interface

IEditControl Interface

IEditControl Interface
REX.Controls.Common Namespace Legend Members IEditControl Methods

An interface that may be used to attach the custom control to the REXEditControlEngine.

Class Hierarchy
C#
public interface IEditControl;
Description
Namespace

REX.Controls.Common Namespace

IEditControl Methods
IEditControl Methods | Description
GetBackground | Gets the background of the control.
GetEnable | Indicates whether the control is enabled.
GetText | Gets the text contents of the control.