REXFamilyConverter.GetFamilyDBSection Method (REX.ContentGenerator.Families.EElementType, EMaterial, string)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace Example REXFamilyConverter Class

Gets the section of the specified name (based on data from databases).

C#
public REXFamilyType_DBSection GetFamilyDBSection(REX.ContentGenerator.Families.EElementType elementType, EMaterial mat, string name);
Parameters
Parameters | Description
elementType | The type of the element.
mat | The material.
name | The name.
Returns

Returns the section.

Description
Example

The example shows how to get the „HEA 100” section from any database.

//Initializing the rex converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Database identification data.
string alias = "HEA 100";

//Getting the REXFamilyType from the database.
REXFamilyType_DBSection famDBSection = rex.GetFamilyDBSection(REX.ContentGenerator.Families.EElementType.BEAM, EMaterial.STEEL, alias);
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, REXFamilyConverter Class

REXFamilyConverter.GetFamilyDBSection Method (REX.ContentGenerator.Families.EElementType, EMaterial, string, double, double, double, string, string)

REXFamilyConverter.GetFamilyDBSection Method (REX.ContentGenerator.Families.EElementType, EMaterial, string, double, double, double, string, string)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace Example REXFamilyConverter Class

Gets the section of the specified key (based on data from the database).

C#
public REXFamilyType_DBSection GetFamilyDBSection(REX.ContentGenerator.Families.EElementType elementType, EMaterial mat, string name, double dim1, double dim2, double dim3, string dbName, string directory);
Parameters
Parameters | Description
elementType | The type of the element.
mat | The material.
name | The name.
dim1 | The dimension 1.
dim2 | The dimension 2.
dim3 | The dimension 3.
dbName | The name of the database.
directory | The directory where the database.
Returns

Returns the section.

Description
Example

The example shows how to get the „HEA 100” section from the Rcatpro database.

//Initializing the rex converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Database identification data.
string dbName = "Rcatpro";
string name = "HEA";
double dim1 = 100;
double dim2 = 0;
double dim3 = 0;
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Prof";

//Getting the REXFamilyType from the database.
REXFamilyType_DBSection famDBSection = rex.GetFamilyDBSection(REX.ContentGenerator.Families.EElementType.BEAM, EMaterial.STEEL, name, dim1, dim2, dim3, dbName, directory);
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, REXFamilyConverter Class

REXFamilyConverter.GetFamilyDBSection Method (REX.ContentGenerator.Families.EElementType, EMaterial, string, string)

REXFamilyConverter.GetFamilyDBSection Method (REX.ContentGenerator.Families.EElementType, EMaterial, string, string)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace Example REXFamilyConverter Class

Gets the section of the specified name (based on data from databases).

C#
public REXFamilyType_DBSection GetFamilyDBSection(REX.ContentGenerator.Families.EElementType elementType, EMaterial mat, string name, string directory);
Parameters
Parameters | Description
elementType | The type of the element.
mat | The material.
name | The name.
directory | The directory.
Returns

Returns the section.

Description
Example

The example shows how to get the „HEA 100” section from any database.

//Initializing the rex converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Database identification data.
string alias = "HEA 100";
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Prof";

//Getting the REXFamilyType from the database.
REXFamilyType_DBSection famDBSection = rex.GetFamilyDBSection(REX.ContentGenerator.Families.EElementType.BEAM, EMaterial.STEEL, alias, directory);
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, REXFamilyConverter Class

REXFamilyConverter.GetFamilyDBSection Method (REX.ContentGenerator.Families.EElementType, EMaterial, string, string, string)

REXFamilyConverter.GetFamilyDBSection Method (REX.ContentGenerator.Families.EElementType, EMaterial, string, string, string)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace Example REXFamilyConverter Class

Gets the section of the specified name (based on data from the database).

C#
public REXFamilyType_DBSection GetFamilyDBSection(REX.ContentGenerator.Families.EElementType elementType, EMaterial mat, string name, string dbName, string directory);
Parameters
Parameters | Description
elementType | The type of the element.
mat | The material.
name | The name.
dbName | The name of the database.
directory | The directory.
Returns

Returns the section.

Description
Example

The example shows how to get the „HEA 100” section from the Rcatptro database.

//Initializing the rex converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Database identification data.
string alias = "HEA 100";
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Prof";
string dbName = "Rcatpro";

//Getting the REXFamilyType from the database.
REXFamilyType_DBSection famDBSection = rex.GetFamilyDBSection(REX.ContentGenerator.Families.EElementType.BEAM, EMaterial.STEEL, alias, dbName, directory);
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, REXFamilyConverter Class

REXFamilyConverter.GetFamilyDefault Method

REXFamilyConverter.GetFamilyDefault Method
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace REXFamilyConverter Class

Gets the default REXFamilyType of the specified type.

C#
public REXFamilyType GetFamilyDefault(REX.ContentGenerator.Families.EElementType el, EMaterial mat, ECategoryType type, string typeName);
Parameters
Parameters | Description
el | The type of the element.
mat | The material.
type | The category.
typeName | The name.
Returns

Returns the REXFamilyType object.

Description
Remarks

It has all data filled with some default values (e.g. some default material with parameter is taken)

Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, REXFamilyConverter Class

REXFamilyConverter.GetFamilyMaterial Method (string)

REXFamilyConverter.GetFamilyMaterial Method (string)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace Example REXFamilyConverter Class

Gets the material of the specific name (based on data from the database).

C#
public REXFamilyType_Material GetFamilyMaterial(string name);
Parameters
Parameters | Description
name | The name of the material.
dbName | The name of the database.
directory | The directory.
Returns

Returns the material.

Description
Example

The example shows how to get the „C12/15” material from the Eurocode database.

//Initializing the rex converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Database identification data.
string name = "C12/15";
//Getting the REXFamilyType from the database.
REXFamilyType_Material famMaterial = rex.GetFamilyMaterial(name);
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, REXFamilyConverter Class

REXFamilyConverter.GetFamilyMaterial Method (string, string)

REXFamilyConverter.GetFamilyMaterial Method (string, string)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace Example REXFamilyConverter Class