ContourDimensionLine Class, REX.ContentGenerator.Geometry Namespace, ContourDimensionLine Class

ContourDimensionLine.ContourDimensionLine Constructor (double, double, double, double, int, bool, string, bool)

ContourDimensionLine.ContourDimensionLine Constructor (double, double, double, double, int, bool, string, bool)
ContourDimensionLine Class REX.ContentGenerator.Geometry Namespace ContourDimensionLine Class

Initializes a new instance of the ContourDimensionLine class.

C#
public ContourDimensionLine(double xst, double yst, double xend, double yend, int lev, bool up, string param, bool extend2Right);
Parameters
Parameters | Description
xst | The x start.
yst | The y start.
xend | The x end.
yend | The y end.
lev | The level.
up | Indicates whether the text should be placed above the reference.
param | The parameter (text).
extend2Right | Indicates whether the dimension should be extended to the right.
Description
Class

ContourDimensionLine Class

Links
ContourDimensionLine Class, REX.ContentGenerator.Geometry Namespace, ContourDimensionLine Class

ContourDimensionLine.MultiplyLengthDim Method

ContourDimensionLine.MultiplyLengthDim Method
ContourDimensionLine Class REX.ContentGenerator.Geometry Namespace ContourDimensionLine Class

Multiplies length dimensions by the coefficient.

C#
public override void MultiplyLengthDim(double coeff);
Parameters
Parameters | Description
coeff | The coefficient.
Description
Class

ContourDimensionLine Class

Links
ContourDimensionLine Class, REX.ContentGenerator.Geometry Namespace, ContourDimensionLine Class

ContourDimensionLine.Translate Method

ContourDimensionLine.Translate Method
ContourDimensionLine Class REX.ContentGenerator.Geometry Namespace ContourDimensionLine Class

Applies the specified translation vector to the element.

C#
public override void Translate(double x, double y);
Parameters
Parameters | Description
x | The x.
y | The y.
Description
Class

ContourDimensionLine Class

Links
ContourDimensionLine Class, REX.ContentGenerator.Geometry Namespace, ContourDimensionLine Class

ContourDimensionLine.End Property

ContourDimensionLine.End Property
ContourDimensionLine Class REX.ContentGenerator.Geometry Namespace ContourDimensionLine Class

Gets or sets the end.

C#
public REXxyz End;
Description

The end.

Class

ContourDimensionLine Class

Links
ContourDimensionLine Class, REX.ContentGenerator.Geometry Namespace, ContourDimensionLine Class

ContourDimensionLine.Extend2Right Property

ContourDimensionLine.Extend2Right Property
ContourDimensionLine Class REX.ContentGenerator.Geometry Namespace ContourDimensionLine Class

Gets or sets a value indicating whether the dimension should be extended to the right.

C#
public bool Extend2Right;
Description

True if extended to the right; otherwise, false.

Class

ContourDimensionLine Class

Links
ContourDimensionLine Class, REX.ContentGenerator.Geometry Namespace, ContourDimensionLine Class

ContourDimensionLine.Level Property

ContourDimensionLine.Level Property
ContourDimensionLine Class REX.ContentGenerator.Geometry Namespace ContourDimensionLine Class

Gets or sets the level.

C#
public int Level;
Description

The level.

Class

ContourDimensionLine Class

Links
ContourDimensionLine Class, REX.ContentGenerator.Geometry Namespace, ContourDimensionLine Class

ContourDimensionLine.Up Property

ContourDimensionLine.Up Property
ContourDimensionLine Class REX.ContentGenerator.Geometry Namespace ContourDimensionLine Class

Gets or sets a value indicating whether dimension is defined above the reference.

C#
public bool Up;
Description

True if above the reference; otherwise, false.

Class

ContourDimensionLine Class

Links
ContourDimensionLine Class, REX.ContentGenerator.Geometry Namespace, ContourDimensionLine Class

ContourDimensionRadius Class

ContourDimensionRadius Class
REX.ContentGenerator.Geometry Namespace Legend Members Public Methods ContourDimensionRadius Methods ContourDimensionRadius Properties

Represents the radial dimension.

Class Hierarchy
C#
public class ContourDimensionRadius : ContourDimension;
Description
Namespace

REX.ContentGenerator.Geometry Namespace

Public Methods
Public Method | Description
ContourDimensionRadius | Initializes a new instance of the ContourDimensionRadius class.
ContourDimensionRadius | Initializes a new instance of the ContourDimensionRadius class.
ContourDimensionRadius Methods
ContourDimensionRadius Methods | Description
MultiplyLengthDim | Multiplies length dimensions by the coefficient.
Translate | Applies the specified translation vector to the element.
ContourDimensionRadius Properties
ContourDimensionRadius Properties | Description
End | Gets or sets the end.
Up | Gets or sets a value indicating whether dimension is defined above the reference.
Links
REX.ContentGenerator.Geometry Namespace, Legend, Members, Public Methods, ContourDimensionRadius Methods, ContourDimensionRadius Properties

ContourDimensionRadius.ContourDimensionRadius Constructor (REXxyz, REXxyz, bool, string)

ContourDimensionRadius.ContourDimensionRadius Constructor (REXxyz, REXxyz, bool, string)
ContourDimensionRadius Class REX.ContentGenerator.Geometry Namespace ContourDimensionRadius Class

Initializes a new instance of the ContourDimensionRadius class.

C#
public ContourDimensionRadius(REXxyz st, REXxyz end, bool up, string param);
Parameters
Parameters | Description
st | The start.
end | The end.
up | Indicates whether the text should be placed above the reference.
param | The parameter (text).
Description
Class

ContourDimensionRadius Class

Links
ContourDimensionRadius Class, REX.ContentGenerator.Geometry Namespace, ContourDimensionRadius Class

ContourDimensionRadius.ContourDimensionRadius Constructor (double, double, double, double, bool, string)

ContourDimensionRadius.ContourDimensionRadius Constructor (double, double, double, double, bool, string)
ContourDimensionRadius Class REX.ContentGenerator.Geometry Namespace ContourDimensionRadius Class

Initializes a new instance of the ContourDimensionRadius class.

C#
public ContourDimensionRadius(double xst, double yst, double xend, double yend, bool up, string param);
Parameters
Parameters | Description
xst | The x start.
yst | The y start.
xend | The x end.
yend | The y end.
up | Indicates whether the text should be placed above the reference.
param | The parameter (text).
Description
Class

ContourDimensionRadius Class

Links
ContourDimensionRadius Class, REX.ContentGenerator.Geometry Namespace, ContourDimensionRadius Class

ContourDimensionRadius.MultiplyLengthDim Method

ContourDimensionRadius.MultiplyLengthDim Method
ContourDimensionRadius Class REX.ContentGenerator.Geometry Namespace ContourDimensionRadius Class

Multiplies length dimensions by the coefficient.

C#
public override void MultiplyLengthDim(double coeff);
Parameters
Parameters | Description
coeff | The coefficient.
Description
Class

ContourDimensionRadius Class

Links
ContourDimensionRadius Class, REX.ContentGenerator.Geometry Namespace, ContourDimensionRadius Class

ContourDimensionRadius.Translate Method

ContourDimensionRadius.Translate Method
ContourDimensionRadius Class REX.ContentGenerator.Geometry Namespace ContourDimensionRadius Class

Applies the specified translation vector to the element.

C#
public override void Translate(double x, double y);
Parameters
Parameters | Description
x | The x.
y | The y.
Description
Class

ContourDimensionRadius Class

Links
ContourDimensionRadius Class, REX.ContentGenerator.Geometry Namespace, ContourDimensionRadius Class

ContourDimensionRadius.End Property

ContourDimensionRadius.End Property
ContourDimensionRadius Class REX.ContentGenerator.Geometry Namespace ContourDimensionRadius Class

Gets or sets the end.

C#
public REXxyz End;
Description

The end.

Class

ContourDimensionRadius Class

Links
ContourDimensionRadius Class, REX.ContentGenerator.Geometry Namespace, ContourDimensionRadius Class

ContourDimensionRadius.Up Property