GetValue | Gets the value of the double type.
Reset | Resets the instance of the element.
SetComplexValue | Sets the complex (list) value of the double type.
SetComplexValue | Sets the complex (list) value of the string type.
SetExternalUnitBody | This is SetExternalUnitBody, a member of class IUnitObject.
SetUserValidation | Sets the user validation method.
SetUserValidationComplex | Sets the user validation method for complex values (list).
SetValue | Sets the value of the double type.
SetValue | Sets the value of the string type.

IUnitObject Properties

IUnitObject Properties
IUnitObject Interface Legend
IUnitObject Properties
IUnitObject Properties | Description
Complex | Gets or sets a value indicating whether this the control is in the complex mode (list mode).
ControlState | Gets the state of the control.
DataType | Gets or sets the type of the data in the control.
EngineeringFormat | Gets or sets a value indicating whether the text of the control should be formatted in according to the engineering (expotential) format.
RangeMax | Gets or sets the highest possible value.
RangeMaxCheck | Gets or sets a value indicating whether the value should be validated due to the RangeMax.
RangeMin | Gets or sets the minimum possible value.
RangeMinCheck | Gets or sets a value indicating whether the value should be validated due to the RangeMin.
RoundingFractional | Gets or sets the rounding for fractional units.
RoundingIncrement | Gets or sets the rounding increment.
Separator | Gets or sets the decimal separator.
Tag | Gets or sets the tag.
Text | Gets the text contents of the control.
UnitSymbol | Gets or sets the unit symbol.

Legend

Legend
REXComboEditControlEngine Class
Legend
Constructor
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXComboEditControlEngine Class Members

REXComboEditControlEngine Class Members
REXComboEditControlEngine Class Legend
Members
Public Methods
Public Method | Description
REXComboEditControlEngine | Initializes a new instance of the REXComboEditControlEngine class.
REXComboEditControlEngine Methods
REXComboEditControlEngine Methods | Description
GetPropertiesType | Gets the mode of the combo.
GetValue | Returns a double value of the control.
RefreshItems | Refreshes the internal items list based on the control items list.
RestorePropertiesType | Restores the mode of the combo.
SelectionChanged | Informs about changes in the selection.
SetPropertiesType | Sets the mode of the combo box.
SetValue | Sets the value of the double type.
SetValue | Sets the value of the string type.
TextChanged | Informs about changes in the control's text.
ValidateControl | Validates the current control based on the input values.
ValidateControl | Validates the current control based on the current text or the stored value.
ValidateControl | Validates the current control based on the input value.
ValidateControl | Validates the current control based on the input text.
REXComboEditControlEngine Properties
REXComboEditControlEngine Properties | Description
Items | Gets or sets the collection of the items contained in the control.
ListValidation | Gets or sets a value indicating whether the list should be validated.
SelectedIndex | Gets or sets the index specifying the currently selected item.
TextBoxMode | Gets or sets a value indicating whether the combobox should be in the editbox mode.

REXComboEditControlEngine Methods

REXComboEditControlEngine Methods
REXComboEditControlEngine Class Legend
REXComboEditControlEngine Methods
REXComboEditControlEngine Methods | Description
GetPropertiesType | Gets the mode of the combo.
GetValue | Returns a double value of the control.
RefreshItems | Refreshes the internal items list based on the control items list.
RestorePropertiesType | Restores the mode of the combo.
SelectionChanged | Informs about changes in the selection.
SetPropertiesType | Sets the mode of the combo box.
SetValue | Sets the value of the double type.
SetValue | Sets the value of the string type.
TextChanged | Informs about changes in the control's text.
ValidateControl | Validates the current control based on the input values.
ValidateControl | Validates the current control based on the current text or the stored value.
ValidateControl | Validates the current control based on the input value.
ValidateControl | Validates the current control based on the input text.

REXComboEditControlEngine Properties

REXComboEditControlEngine Properties
REXComboEditControlEngine Class Legend
REXComboEditControlEngine Properties
REXComboEditControlEngine Properties | Description
Items | Gets or sets the collection of the items contained in the control.
ListValidation | Gets or sets a value indicating whether the list should be validated.
SelectedIndex | Gets or sets the index specifying the currently selected item.
TextBoxMode | Gets or sets a value indicating whether the combobox should be in the editbox mode.

REXComboEditControlEngine Class Public Methods

REXComboEditControlEngine Class Public Methods
REXComboEditControlEngine Class Legend
Public Methods
Public Method | Description
REXComboEditControlEngine | Initializes a new instance of the REXComboEditControlEngine class.

REXEditControlEngine Events

REXEditControlEngine Events
REXEditControlEngine Class Legend
REXEditControlEngine Events
REXEditControlEngine Events | Description
EventComplexDoubleValueChanged | Occurs when the complex value changes.
EventDoubleValueChanged | Occurs when the value changes.

Legend

Legend
REXEditControlEngine Class
Legend
Constructor
virtual
static
Property
Event
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXEditControlEngine Class Members

REXEditControlEngine Class Members
REXEditControlEngine Class Legend
Members
Public Methods
Public Method | Description
REXEditControlEngine | Initializes a new instance of the REXEditControlEngine class.
REXEditControlEngine Methods
REXEditControlEngine Methods | Description
AddEnabledChangedHandler | Adds the handler to the event raised when the element changes it's enable state.
AddLostFocusHandler | Adds the handler to the event raised when the element loses logical focus.
AddTextChangedHandler | Adds the handler to the event raised when text changes.
EndEdit | Ends the edit mode.
GetBaseMaxValue | Gets the maximum value and converts it to base units.
GetBaseMinValue | Gets the minimum value and converts it to base units.
GetComplexDataBaseValue | Get the values and convert it to base units.
GetComplexDataInterfaceValue | Get the values and convert it to interface units.
GetComplexDoubleValue | Gets the complex (list) value of the double type.
GetComplexStringValue | Returns a complex string list.
GetControl | Gets the control.
GetDataBaseValue | Gets the value and converts it to base units.
GetDataInterfaceValue | Gets the value and converts it to interface units.
GetFullName | Gets the full name.
GetInterfaceMaxValue | Gets the maximum value and converts it to interface units.
GetInterfaceMinValue | Gets the minimum value and converts it to interface units.
GetLastCorrectValueStr | Gets the last correct stored value.
GetState | Gets the current state of the control.
GetStringValue | Returns the original text.
GetUniqueName | Returns the Unique ID generated for the current instance of the engine.
GetUnitName | Gets the name of the unit from EnumUnits type.
GetValue | Gets the value of the double type.
IsInEditMode | Determines whether control is in the edit mode.
Refresh | Refreshes the text on the control based on the current text.
RefreshValidationStatus | Refreshes the validation status.
Reset | Resets control (internal values).