ValidateComplexValue | Validates the complex (list) value of the string type.
ValidateValue | Validates the input value of the double type.
ValidateValue | Validates the value of the string type.
ValueFormat | Returns a text containing an expression formatted according the current settings of the element.
ValueFormat | Returns a text containing an expression formatted according the current settings of the element.
ValueParse | Converts the specified text to the numeric value according the current settings of the element.

REXComboBox Properties

REXComboBox Properties
REXComboBox Class Legend
REXComboBox Properties
REXComboBox Properties | Description
AcceptsTab | AcceptsTab property derived from the TextBox class.
ColorBackgroundDisabled | Gets or sets the background for the disabled state of the control in the hidden background mode.
ColorBackgroundError | Gets or sets the background for the Error state of the control.
ColorBackgroundNeutral | Gets or sets the background for the neutral state of the control.
ColorBackgroundOK | Gets or sets the background for the OK state of the control.
ColorBackgroundStandard | Gets or sets the background for the disabled state of the control.
Complex | Gets or sets a value indicating whether this REXEditControlEngine supports complex (list) values.
ComplexSeparator | Gets or sets the complex (list) separator.
ComplexSpaceSeparator | Gets or sets a value indicating whether a space should be respected as a list separator.
ComplexUnitOnEnd | Gets or sets a value indicating whether a unit symbol should be placed on the end of the formatted text.
ControlState | Gets the current state of the control.
CorrectValue | Gets or sets the correct value.
DataType | Gets or sets the type of the data in the control.
DropDownWidthLimit | Gets or sets the drop down width limit.
EditBox | Gets the reference to the REXEditBox control.
Enabled | Gets or sets a value indicating whether the control can respond to user interaction.
EngineeringFormat | Gets or sets a value indicating whether the text of the control should be formatted in according to the engineering (expotential) format.
Epsilon | Gets or sets the accuracy.
InvalidCharacters | Gets or sets the list invalid characters (for the control in TEXT mode).
ListValidation | Gets or sets a value indicating whether the list should be validated.
MaxTokens | Gets or sets the maximum number of elements in the complex mode (list).
MinTokens | Gets or sets the minimum number of elements in the complex mode (list).
Name | Gets or sets the name of the control.
OnDisableAction | Gets or sets a value indicating whether the foreground should be hidden when the control is disabled.
OriginalTextOnEnter | Gets or sets a value indicating whether an original text should be set when the user enters the control.
RangeMax | Gets or sets the highest possible value.
RangeMaxCheck | Gets or sets a value indicating whether the value should be validated due to the RangeMax.
RangeMin | Gets or sets the minimum possible value.
RangeMinCheck | Gets or sets a value indicating whether the value should be validated due to the RangeMin.
RememberCorrect | Gets or sets a value indicating whether the correct value should be restored in case of the validation failure.
RoundingFractional | Gets or sets the rounding for fractional units.
RoundingIncrement | Gets or sets the rounding increment (for the DECIMAL DataType).
Separator | Gets or sets the decimal separator.
TabIndex | Gets or sets the tab order of the control within its container.
Text | Gets the text contents of the control.
TextAlign | Gets or sets the text alignment.
TextBoxMode | Gets or sets a value indicating whether the combobox is in the editbox mode.
TokensRangeMaxCheck | Gets or sets a value indicating whether the number of elements should be validated due to the MaxTokens.
TokensRangeMinCheck | Gets or sets a value indicating whether the number of elements should be validated due to the MinTokens.
UnitSymbol | Gets or sets the unit symbol.

REXComboBox Class Public Methods

REXComboBox Class Public Methods
REXComboBox Class Legend
Public Methods
Public Method | Description
REXComboBox | Initializes a new instance of the REXComboBox class.

Legend

Legend
REXEditBox Class
Legend
Constructor
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXEditBox Class Members

REXEditBox Class Members
REXEditBox Class Legend
Members
Public Methods
Public Method | Description
REXEditBox | Initializes a new instance of the REXEditBox class.
REXEditBox Methods
REXEditBox Methods | Description
AddEnabledChangedHandler | Adds the handler to the event raised when the element changes it's enable state.
AddLostFocusHandler | Adds the handler to the event raised when the element loses logical focus.
AddTextChangedHandler | Adds the handler to the event raised when text changes.
GetBackground | Gets the background of the control.
GetComplexDoubleValue | Gets the complex (list) value of the double type.
GetComplexStringValue | Returns a complex string list.
GetEnable | Indicates whether the control is enabled.
GetFullName | Gets the full name.
GetLastCorrectValueStr | Gets the last correct stored value.
GetState | Gets the current state of the control.
GetStringValue | Returns the original text.
GetText | Gets the text contents of the control.
GetUniqueName | Returns the Unique ID generated for the current instance of the engine.
GetValue | Gets the value of the double type.
Refresh | Refreshes the text on the control based on the current text.
RefreshValidationStatus | Refreshes the validation status.
Reset | Resets control (internal values).
SetBackground | Sets the background of the control.
SetComplexValue | Sets the complex (list) value of the double type.
SetComplexValue | Sets the complex (list) value of the string type.
SetComplexValue | Sets the complex (list) value of the string type.
SetEnable | Sets the enable state.
SetExternalUnitBody | Sets external IUnitBody object for custom unit processing.
SetText | Sets the text contents of the control.
SetUserTextValidation | Sets the user validation method for the text control.
SetUserValidation | Sets the user validation method.
SetUserValidationComplex | Sets the user validation method for complex values (list).
SetValue | Sets the value of the double type.
SetValue | Sets the value of the string type.
ValidateComplexValue | Validates the complex (list) value of the double type.
ValidateComplexValue | Validates the complex (list) value of the string type.
ValidateComplexValue | Validates the complex (list) value of the string type.
ValidateValue | Validates the input value of the double type.
ValidateValue | Validates the value of the string type.
ValueFormat | Returns a text containing an expression formatted according the current settings of the element.
ValueFormat | Returns a text containing an expression formatted according the current settings of the element.
ValueParse | Converts the specified text to the numeric value according the current settings of the element.
REXEditBox Properties
REXEditBox Properties | Description
AcceptsTab | AcceptsTab property derived from the TextBox class.
ColorBackgroundDisabled | Gets or sets the background for the disabled state of the control in the hidden background mode.
ColorBackgroundError | Gets or sets the background for the Error state of the control.
ColorBackgroundNeutral | Gets or sets the background for the neutral state of the control.
ColorBackgroundOK | Gets or sets the background for the OK state of the control.
ColorBackgroundStandard | Gets or sets the background for the disabled state of the control.
Complex | Gets or sets a value indicating whether this REXEditControlEngine supports complex (list) values.
ComplexSeparator | Gets or sets the complex (list) separator.