REXToolboxObject | Initializes a new instance of the REXToolboxObject class.
REXToolboxObject Properties
REXToolboxObject Properties | Description
Description | Gets or sets the description.
Name | Gets or sets the name.
Tag | Gets or sets the tag.

REXToolboxObject Properties

REXToolboxObject Properties
REXToolboxObject Class Legend
REXToolboxObject Properties
REXToolboxObject Properties | Description
Description | Gets or sets the description.
Name | Gets or sets the name.
Tag | Gets or sets the tag.

REXToolboxObject Class Public Methods

REXToolboxObject Class Public Methods
REXToolboxObject Class Legend
Public Methods
Public Method | Description
REXToolboxObject | Initializes a new instance of the REXToolboxObject class.

REXUnitComboBox Fields

REXUnitComboBox Fields
REXUnitComboBox Class Legend
REXUnitComboBox Fields
REXUnitComboBox Fields | Description
ComplexDoubleValueBaseProperty | This is ComplexDoubleValueBaseProperty, a member of class REXUnitComboBox.
DoubleValueBaseProperty | This is DoubleValueBaseProperty, a member of class REXUnitComboBox.
PowerProperty | This is PowerProperty, a member of class REXUnitComboBox.
UnitTypeProperty | This is UnitTypeProperty, a member of class REXUnitComboBox.

Legend

Legend
REXUnitComboBox Class
Legend
Constructor
Data Member
static
read only
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXUnitComboBox Class Members

REXUnitComboBox Class Members
REXUnitComboBox Class Legend
Members
Public Methods
Public Method | Description
REXUnitComboBox | Initializes a new instance of the REXUnitComboBox class.
REXUnitComboBox Fields
REXUnitComboBox Fields | Description
ComplexDoubleValueBaseProperty | This is ComplexDoubleValueBaseProperty, a member of class REXUnitComboBox.
DoubleValueBaseProperty | This is DoubleValueBaseProperty, a member of class REXUnitComboBox.
PowerProperty | This is PowerProperty, a member of class REXUnitComboBox.
UnitTypeProperty | This is UnitTypeProperty, a member of class REXUnitComboBox.
REXUnitComboBox Methods
REXUnitComboBox Methods | Description
GetBaseMaxValue | Gets the maximum value and converts it to base units.
GetBaseMinValue | Gets the minimum value and converts it to base units.
GetComplexDataBaseValue | Get the values and convert it to base units.
GetComplexDataInterfaceValue | Get the values and convert it to interface units.
GetDataBaseValue | Gets the value and converts it to base units.
GetDataInterfaceValue | Gets the value and converts it to interface units.
GetInterfaceMaxValue | Gets the maximum value and converts it to interface units.
GetInterfaceMinValue | Gets the minimum value and converts it to interface units.
SetBaseMaxValue | Set the maximum value defined in base units.
SetBaseMinValue | Set the minimum value defined in base units.
SetComplexDataBaseValue | Set the list of values defined in base units.
SetComplexDataInterfaceValue | Set the list of values defined in interface units.
SetDataBaseValue | Set the value in base units.
SetDataInterfaceValue | Set the value in interface units.
SetInterfaceMaxValue | Set the maximum value defined in interface units.
SetInterfaceMinValue | Set the minimum value defined in interface units.
REXUnitComboBox Properties
REXUnitComboBox Properties | Description
ComplexDoubleValueBase | Gets or sets the complex double value.
DoubleValueBase | Gets or sets the double value.
Power | Gets or sets the power of the unit.
UnitEngine | Gets or sets the unit engine.
UnitType | Gets or sets the type of the unit.

REXUnitComboBox Properties

REXUnitComboBox Properties
REXUnitComboBox Class Legend
REXUnitComboBox Properties
REXUnitComboBox Properties | Description
ComplexDoubleValueBase | Gets or sets the complex double value.
DoubleValueBase | Gets or sets the double value.
Power | Gets or sets the power of the unit.
UnitEngine | Gets or sets the unit engine.
UnitType | Gets or sets the type of the unit.

REXUnitComboBox Class Public Methods

REXUnitComboBox Class Public Methods
REXUnitComboBox Class Legend
Public Methods
Public Method | Description
REXUnitComboBox | Initializes a new instance of the REXUnitComboBox class.

REXUnitEditBox Fields

REXUnitEditBox Fields
REXUnitEditBox Class Legend
REXUnitEditBox Fields
REXUnitEditBox Fields | Description
ComplexDoubleValueBaseProperty | This is ComplexDoubleValueBaseProperty, a member of class REXUnitEditBox.
DoubleValueBaseProperty | This is DoubleValueBaseProperty, a member of class REXUnitEditBox.
PowerProperty | This is PowerProperty, a member of class REXUnitEditBox.
UnitTypeProperty | This is UnitTypeProperty, a member of class REXUnitEditBox.

Legend

Legend
REXUnitEditBox Class
Legend
Constructor
Data Member
static
read only
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXUnitEditBox Class Members

REXUnitEditBox Class Members
REXUnitEditBox Class Legend
Members
Public Methods
Public Method | Description
REXUnitEditBox | This is REXUnitEditBox, a member of class REXUnitEditBox.
REXUnitEditBox Fields
REXUnitEditBox Fields | Description
ComplexDoubleValueBaseProperty | This is ComplexDoubleValueBaseProperty, a member of class REXUnitEditBox.
DoubleValueBaseProperty | This is DoubleValueBaseProperty, a member of class REXUnitEditBox.
PowerProperty | This is PowerProperty, a member of class REXUnitEditBox.
UnitTypeProperty | This is UnitTypeProperty, a member of class REXUnitEditBox.
REXUnitEditBox Methods
REXUnitEditBox Methods | Description
GetBaseMaxValue | Gets the maximum value and converts it to base units.
GetBaseMinValue | Gets the minimum value and converts it to base units.
GetComplexDataBaseValue | Get the values and convert it to base units.
GetComplexDataInterfaceValue | Get the values and convert it to interface units.
GetDataBaseValue | Gets the value and converts it to base units.
GetDataInterfaceValue | Gets the value and converts it to interface units.
GetInterfaceMaxValue | Gets the maximum value and converts it to interface units.
GetInterfaceMinValue | Gets the minimum value and converts it to interface units.
SetBaseMaxValue | Set the maximum value defined in base units.
SetBaseMinValue | Set the minimum value defined in base units.
SetComplexDataBaseValue | Set the list of values defined in base units.
SetComplexDataInterfaceValue | Set the list of values defined in interface units.
SetDataBaseValue | Set the value in base units.
SetDataInterfaceValue | Set the value in interface units.
SetInterfaceMaxValue | Set the maximum value defined in interface units.
SetInterfaceMinValue | Set the minimum value defined in interface units.
REXUnitEditBox Properties
REXUnitEditBox Properties | Description
ComplexDoubleValueBase | Gets or sets the complex double value.
DoubleValueBase | Gets or sets the double value.
Power | Gets or sets the power of the unit.
UnitEngine | Gets or sets the unit engine.
UnitType | Gets or sets the type of the unit.

REXUnitEditBox Properties

REXUnitEditBox Properties
REXUnitEditBox Class Legend
REXUnitEditBox Properties
REXUnitEditBox Properties | Description
ComplexDoubleValueBase | Gets or sets the complex double value.
DoubleValueBase | Gets or sets the double value.
Power | Gets or sets the power of the unit.
UnitEngine | Gets or sets the unit engine.
UnitType | Gets or sets the type of the unit.

REXUnitEditBox Class Public Methods

REXUnitEditBox Class Public Methods
REXUnitEditBox Class Legend
Public Methods
Public Method | Description
REXUnitEditBox | This is REXUnitEditBox, a member of class REXUnitEditBox.

Legend

Legend
WPFCommon Class
Legend
Method
static

WPFCommon Class Members

WPFCommon Class Members
WPFCommon Class Legend
Members