REXSectionDBDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionDBDimensions Class

REXSectionDBProperties Class

REXSectionDBProperties Class
REX.ContentGenerator.Families Namespace Legend Members Public Methods REXSectionDBProperties Methods REXSectionDBProperties Properties

Describes properties of the database section.

Class Hierarchy
C#
[Serializable()]
public class REXSectionDBProperties : REXDescription;
Description
Namespace

REX.ContentGenerator.Families Namespace

Public Methods
Public Method | Description
REXSectionDBProperties | Initializes a new instance of the REXSectionDBProperties class.
REXSectionDBProperties | Initializes a new instance of the REXSectionDBProperties class.
REXSectionDBProperties | Initializes a new instance of the
REXSectionDBProperties | Initializes a new instance of the REXSectionDBProperties class.
REXSectionDBProperties Methods
REXSectionDBProperties Methods | Description
Clone | Creates a new object that is a copy of the current instance.
REXSectionDBProperties Properties
REXSectionDBProperties Properties | Description
DIM1 | Gets or sets the first numeric component of the section label
DIM2 | Gets or sets the second numeric component of the section label.
DIM3 | Gets or sets the third numeric component of the section label.
NAME | Gets or sets the name of the section.
NAME_REVIT | Gets or sets the Revit name.
NAME1 | Gets or sets the section name.
Names | Gets or sets the list of optional names.
SHAPE_TYPE | Gets or sets the number of the section shape type.
Links
REX.ContentGenerator.Families Namespace, Legend, Members, Public Methods, REXSectionDBProperties Methods, REXSectionDBProperties Properties

REXSectionDBProperties.REXSectionDBProperties Constructor ()

REXSectionDBProperties.REXSectionDBProperties Constructor ()
REXSectionDBProperties Class REX.ContentGenerator.Families Namespace REXSectionDBProperties Class

Initializes a new instance of the REXSectionDBProperties class.

C#
public REXSectionDBProperties();
Description
Class

REXSectionDBProperties Class

Links
REXSectionDBProperties Class, REX.ContentGenerator.Families Namespace, REXSectionDBProperties Class

REXSectionDBProperties.REXSectionDBProperties Constructor (DTableDataObjectCollection)

REXSectionDBProperties.REXSectionDBProperties Constructor (DTableDataObjectCollection)
REXSectionDBProperties Class REX.ContentGenerator.Families Namespace REXSectionDBProperties Class

Initializes a new instance of the REXSectionDBProperties class.

C#
public REXSectionDBProperties(DTableDataObjectCollection pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

REXSectionDBProperties Class

Links
REXSectionDBProperties Class, REX.ContentGenerator.Families Namespace, REXSectionDBProperties Class

REXSectionDBProperties.REXSectionDBProperties Constructor (REXSectionDBProperties)

REXSectionDBProperties.REXSectionDBProperties Constructor (REXSectionDBProperties)
REXSectionDBProperties Class REX.ContentGenerator.Families Namespace REXSectionDBProperties Class

Initializes a new instance of the

C#
public REXSectionDBProperties(REXSectionDBProperties pattern);
Parameters
Parameters | Description
pattern | The pattern.
Class

REXSectionDBProperties Class

Links
REXSectionDBProperties Class, REX.ContentGenerator.Families Namespace, REXSectionDBProperties Class

REXSectionDBProperties.REXSectionDBProperties Constructor (System.Data.DataRow)

REXSectionDBProperties.REXSectionDBProperties Constructor (System.Data.DataRow)
REXSectionDBProperties Class REX.ContentGenerator.Families Namespace REXSectionDBProperties Class

Initializes a new instance of the REXSectionDBProperties class.

C#
public REXSectionDBProperties(System.Data.DataRow pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

REXSectionDBProperties Class

Links
REXSectionDBProperties Class, REX.ContentGenerator.Families Namespace, REXSectionDBProperties Class

REXSectionDBProperties.Clone Method

REXSectionDBProperties.Clone Method
REXSectionDBProperties Class REX.ContentGenerator.Families Namespace REXSectionDBProperties Class

Creates a new object that is a copy of the current instance.

C#
public override object Clone();
Returns

A new object that is a copy of this instance.

Description
Class

REXSectionDBProperties Class

Links
REXSectionDBProperties Class, REX.ContentGenerator.Families Namespace, REXSectionDBProperties Class

REXSectionDBProperties.DIM1 Property

REXSectionDBProperties.DIM1 Property
REXSectionDBProperties Class REX.ContentGenerator.Families Namespace REXSectionDBProperties Class

Gets or sets the first numeric component of the section label

C#
public double DIM1;
Description
Remarks

It is taken as key for identification process in a database (with combination of: NAME, DIM2, DIM3).

Class

REXSectionDBProperties Class

Links
REXSectionDBProperties Class, REX.ContentGenerator.Families Namespace, REXSectionDBProperties Class

REXSectionDBProperties.DIM2 Property

REXSectionDBProperties.DIM2 Property
REXSectionDBProperties Class REX.ContentGenerator.Families Namespace REXSectionDBProperties Class

Gets or sets the second numeric component of the section label.

C#
public double DIM2;
Description

The second numeric component of the section label.

Remarks

It is taken as key for identification process in a database (with combination of: NAME, DIM1, DIM3).

Class

REXSectionDBProperties Class

Links
REXSectionDBProperties Class, REX.ContentGenerator.Families Namespace, REXSectionDBProperties Class

REXSectionDBProperties.DIM3 Property

REXSectionDBProperties.DIM3 Property
REXSectionDBProperties Class REX.ContentGenerator.Families Namespace REXSectionDBProperties Class

Gets or sets the third numeric component of the section label.

C#
public double DIM3;
Description

The third numeric component of the section label.

Remarks

It is taken as key for identification process in a database (with combination of: NAME, DIM1, DIM2).

Class

REXSectionDBProperties Class

Links
REXSectionDBProperties Class, REX.ContentGenerator.Families Namespace, REXSectionDBProperties Class

REXSectionDBProperties.NAME Property

REXSectionDBProperties.NAME Property
REXSectionDBProperties Class REX.ContentGenerator.Families Namespace REXSectionDBProperties Class

Gets or sets the name of the section.

C#
public string NAME;
Description

The name.

Remarks

It is taken as key for identification process in a database (with combination of: DIM1, DIM2, DIM3).

Class

REXSectionDBProperties Class

Links
REXSectionDBProperties Class, REX.ContentGenerator.Families Namespace, REXSectionDBProperties Class

REXSectionDBProperties.NAME_REVIT Property

REXSectionDBProperties.NAME_REVIT Property
REXSectionDBProperties Class REX.ContentGenerator.Families Namespace REXSectionDBProperties Class

Gets or sets the Revit name.

C#
public string NAME_REVIT;
Description

The Revit name.

Remarks

It is taken as key for identification process in a database when element is mapped.

Class

REXSectionDBProperties Class

Links
REXSectionDBProperties Class, REX.ContentGenerator.Families Namespace, REXSectionDBProperties Class

REXSectionDBProperties.NAME1 Property

REXSectionDBProperties.NAME1 Property
REXSectionDBProperties Class REX.ContentGenerator.Families Namespace REXSectionDBProperties Class

Gets or sets the section name.

C#
public string NAME1;
Description

The section name.

Class

REXSectionDBProperties Class

Links
REXSectionDBProperties Class, REX.ContentGenerator.Families Namespace, REXSectionDBProperties Class

REXSectionDBProperties.Names Property

REXSectionDBProperties.Names Property
REXSectionDBProperties Class REX.ContentGenerator.Families Namespace REXSectionDBProperties Class

Gets or sets the list of optional names.

C#
public List<string> Names;
Description

The list of names.

Class

REXSectionDBProperties Class

Links