SetComplexValue | Sets the complex (list) value of the double type.
SetComplexValue | Sets the complex (list) value of the string type.
SetComplexValue | Sets the complex (list) value of the string type.
SetControl | Sets the control for which the current instance is the engine.
SetDataBaseValue | Set the value in base units.
SetDataInterfaceValue | Set the value in interface units.
SetExternalUnitBody | Set external IUnitBody object.
SetInterfaceMaxValue | Set the maximum value defined in interface units.
SetInterfaceMinValue | Set the minimum value defined in interface units.
SetUserTextValidation | Sets the user validation method for the text control.
SetUserValidation | Sets the user validation method.
SetUserValidationComplex | Sets the user validation method for complex values (list).
SetValue | Sets the value of the double type.
SetValue | Sets the value of the string type.
StartEdit | Starts the edit mode.
TextChanged | Informs about changes in the control's text.
ValidateComplexValue | Validates the complex (list) value of the double type.
ValidateComplexValue | Validates the complex (list) value of the string type.
ValidateComplexValue | Validates the complex (list) value of the string type.
ValidateControl | Validates the current control based on the input values.
ValidateControl | Validates the current control based on the input text.
ValidateControl | Validates the current control based on the current text or the stored value.
ValidateControl | Validates the current control based on the input value.
ValidateValue | Validates the input value of the double type.
ValidateValue | Validates the value of the string type.
ValueFormat | Returns a text containing an expression formatted according the current settings of the element.
ValueFormat | Returns a text containing an expression formatted according the current settings of the element.
ValueParse | Converts the specified text to the numeric value according the current settings of the element.
REXEditControlEngine Properties
REXEditControlEngine Properties | Description
Background | Gets or sets the background of the control.
BackgroundDisabledHidden | Gets or sets the background for the disabled state of the control in the hidden background mode.
BackgroundDisabledStandard | Gets or sets the background for the disabled state of the control.
BackgroundError | Gets or sets the background for the Error state of the control.
BackgroundNeutral | Gets or sets the background for the neutral state of the control.
BackgroundOK | Gets or sets the background for the OK state of the control.
Complex | Gets or sets a value indicating whether this REXEditControlEngine supports complex (list) values.
ComplexSeparator | Gets or sets the complex (list) separator.
ComplexSpaceSeparator | Gets or sets a value indicating whether a space should be respected as a list separator.
ComplexUnitOnEnd | Gets or sets a value indicating whether a unit symbol should be placed on the end of the formatted text.
ControlState | Gets the current state of the control.
CorrectValue | Gets or sets the correct value.
DataType | Gets or sets the type of the data in the control.
EngineeringFormat | Gets or sets a value indicating whether the text of the control should be formatted in according to the engineering (expotential) format.
Epsilon | Gets or sets the accuracy.
InvalidCharacters | Gets or sets the list invalid characters (for the control in TEXT mode).
IsEnabled | Gets or sets a value indicating whether this instance is enabled.
MaxTokens | Gets or sets the maximum number of elements in the complex mode (list).
MinTokens | Gets or sets the minimum number of elements in the complex mode (list).
OnDisableAction | Gets or sets a value indicating whether the foreground should be hidden when the control is disabled.
OriginalTextOnEnter | Gets or sets a value indicating whether an original text should be set when the user enters the control.
Power | Gets or sets the power of the unit.
RangeMax | Gets or sets the highest possible value.
RangeMaxCheck | Gets or sets a value indicating whether the value should be validated due to the RangeMax.
RangeMin | Gets or sets the minimum possible value.
RangeMinCheck | Gets or sets a value indicating whether the value should be validated due to the RangeMin.
RememberCorrect | Gets or sets a value indicating whether the correct value should be restored in case of the validation failure.
RoundingFractional | Gets or sets the rounding for fractional units.
RoundingIncrement | Gets or sets the rounding increment (for the DECIMAL DataType).
Separator | Gets or sets the decimal separator.
Tag | Gets or sets the tag.
Text | Gets the text contents of the control.
TokensRangeMaxCheck | Gets or sets a value indicating whether the number of elements should be validated due to the MaxTokens.
TokensRangeMinCheck | Gets or sets a value indicating whether the number of elements should be validated due to the MinTokens.
UnitEngine | Gets or sets the unit engine.
UnitSymbol | Gets or sets the unit symbol.
UnitType | Gets or sets the type of the unit.
Links
REX.Controls.Common Namespace, Legend, Members, Public Methods, REXEditControlEngine Events, REXEditControlEngine Methods, REXEditControlEngine Properties

REXEditControlEngine.REXEditControlEngine Constructor

REXEditControlEngine.REXEditControlEngine Constructor
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Initializes a new instance of the REXEditControlEngine class.

C#
public REXEditControlEngine(IEditControl control);
Parameters
Parameters | Description
control | The control which will use the current instance as it's engine .
Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.AddEnabledChangedHandler Method

REXEditControlEngine.AddEnabledChangedHandler Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Adds the handler to the event raised when the element changes it's enable state.

C#
public void AddEnabledChangedHandler(EventHandler eh);
Parameters
Parameters | Description
eh | The event handler.
Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.AddLostFocusHandler Method

REXEditControlEngine.AddLostFocusHandler Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Adds the handler to the event raised when the element loses logical focus.

C#
public void AddLostFocusHandler(EventHandler eh);
Parameters
Parameters | Description
eh | The event handler.
Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.AddTextChangedHandler Method

REXEditControlEngine.AddTextChangedHandler Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Adds the handler to the event raised when text changes.

C#
public void AddTextChangedHandler(EventHandler eh);
Parameters
Parameters | Description
eh | The event handler.
Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.EndEdit Method

REXEditControlEngine.EndEdit Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Ends the edit mode.

C#
public virtual void EndEdit();
Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.GetBaseMaxValue Method

REXEditControlEngine.GetBaseMaxValue Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets the maximum value and converts it to base units.

C#
public double GetBaseMaxValue();
Returns

The value.