InitList | This is InitList, a member of class RVTSectionFactory.
IsElementSupported | This is IsElementSupported, a member of class RVTSectionFactory.
OnClose | This is OnClose, a member of class RVTSectionFactory.
Recalculate | This is Recalculate, a member of class RVTSectionFactory.
ResetFamilyBufor | This is ResetFamilyBufor, a member of class RVTSectionFactory.
ValidateElement | This is ValidateElement, a member of class RVTSectionFactory.

RVTSectionFactory Methods

RVTSectionFactory Methods
RVTSectionFactory Class Legend
RVTSectionFactory Methods
RVTSectionFactory Methods | Description
AddElement2FamList | This is AddElement2FamList, a member of class RVTSectionFactory.
AddElement2FamList | This is AddElement2FamList, a member of class RVTSectionFactory.
GetElement | This is GetElement, a member of class RVTSectionFactory.
GetElement4ParamIdentity | This is GetElement4ParamIdentity, a member of class RVTSectionFactory.
GetElements | This is GetElements, a member of class RVTSectionFactory.
GetExistingNames | This is GetExistingNames, a member of class RVTSectionFactory.
GetFactory | This is GetFactory, a member of class RVTSectionFactory.
GetFactoryForGeneral | This is GetFactoryForGeneral, a member of class RVTSectionFactory.
GetFamily | This is GetFamily, a member of class RVTSectionFactory.
GetName4Mapping | This is GetName4Mapping, a member of class RVTSectionFactory.
GetRevitTypesForInit | This is GetRevitTypesForInit, a member of class RVTSectionFactory.
InitList | This is InitList, a member of class RVTSectionFactory.
IsElementSupported | This is IsElementSupported, a member of class RVTSectionFactory.
OnClose | This is OnClose, a member of class RVTSectionFactory.
Recalculate | This is Recalculate, a member of class RVTSectionFactory.
ResetFamilyBufor | This is ResetFamilyBufor, a member of class RVTSectionFactory.
ValidateElement | This is ValidateElement, a member of class RVTSectionFactory.

RVTSectionFactory Class Public Methods

RVTSectionFactory Class Public Methods
RVTSectionFactory Class Legend
Public Methods
Public Method | Description
RVTSectionFactory | This is RVTSectionFactory, a member of class RVTSectionFactory.

Legend

Legend
RVTSectionParamFactory Class
Legend
Constructor
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

RVTSectionParamFactory Class Members

RVTSectionParamFactory Class Members
RVTSectionParamFactory Class Legend
Members
Public Methods
Public Method | Description
RVTSectionParamFactory | This is RVTSectionParamFactory, a member of class RVTSectionParamFactory.
RVTSectionParamFactory Methods
RVTSectionParamFactory Methods | Description
AddFamily2ProjectDictionary | This is AddFamily2ProjectDictionary, a member of class RVTSectionParamFactory.
IsElementSupported | This is IsElementSupported, a member of class RVTSectionParamFactory.
Recalculate | This is Recalculate, a member of class RVTSectionParamFactory.

RVTSectionParamFactory Methods

RVTSectionParamFactory Methods
RVTSectionParamFactory Class Legend
RVTSectionParamFactory Methods
RVTSectionParamFactory Methods | Description
AddFamily2ProjectDictionary | This is AddFamily2ProjectDictionary, a member of class RVTSectionParamFactory.
IsElementSupported | This is IsElementSupported, a member of class RVTSectionParamFactory.
Recalculate | This is Recalculate, a member of class RVTSectionParamFactory.

RVTSectionParamFactory Class Public Methods

RVTSectionParamFactory Class Public Methods
RVTSectionParamFactory Class Legend
Public Methods
Public Method | Description
RVTSectionParamFactory | This is RVTSectionParamFactory, a member of class RVTSectionParamFactory.

REX.ContentGenerator.Dialog Namespace Classes

REX.ContentGenerator.Dialog Namespace Classes
REX.ContentGenerator.Dialog Namespace Legend
Classes
Class | Description
REXContentDialogCategorySettings | Contains settings for specific category.
REXContentDialogManager | Helps manage DRevitContentGenerator Extension directly by code.
REXContentDialogSettings | Describes settings of the ContentGenerator dialog.

Legend

Legend
REX.ContentGenerator.Dialog Namespace
Legend
Class
Enumeration
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REX.ContentGenerator.Dialog Namespace Structs, Records, Enums

REX.ContentGenerator.Dialog Namespace Structs, Records, Enums
REX.ContentGenerator.Dialog Namespace Legend
Structs, Records, Enums
Struct, Record, Enum | Description
EContentDialogMode | Describes modes in which the ContentGenerator dialog may be run.

Legend

Legend
REXContentDialogCategorySettings Class
Legend
Constructor
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXContentDialogCategorySettings Class Members

REXContentDialogCategorySettings Class Members
REXContentDialogCategorySettings Class Legend
Members
Public Methods
Public Method | Description
REXContentDialogCategorySettings | Initializes a new instance of the REXContentDialogCategorySettings class.
REXContentDialogCategorySettings Properties
REXContentDialogCategorySettings Properties | Description
Category | Gets the category type.
Databases | Gets or sets the list of databases.
SelectedElement | Gets or sets the selected element.
SelectedElements | Gets the selected elements.
Visible | Gets or sets a value indicating whether this category is visible.

REXContentDialogCategorySettings Properties

REXContentDialogCategorySettings Properties
REXContentDialogCategorySettings Class Legend
REXContentDialogCategorySettings Properties
REXContentDialogCategorySettings Properties | Description
Category | Gets the category type.
Databases | Gets or sets the list of databases.
SelectedElement | Gets or sets the selected element.
SelectedElements | Gets the selected elements.
Visible | Gets or sets a value indicating whether this category is visible.

REXContentDialogCategorySettings Class Public Methods

REXContentDialogCategorySettings Class Public Methods
REXContentDialogCategorySettings Class Legend
Public Methods
Public Method | Description
REXContentDialogCategorySettings | Initializes a new instance of the REXContentDialogCategorySettings class.

Legend

Legend
REXContentDialogManager Class
Legend
Constructor
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXContentDialogManager Class Members

REXContentDialogManager Class Members
REXContentDialogManager Class Legend
Members
Public Methods
Public Method | Description
REXContentDialogManager | Initializes a new instance of the REXContentDialogManager class.
REXContentDialogManager Methods
REXContentDialogManager Methods | Description
DisposeContentDialog | Disposes the DRevitContentGenerator Extension.
SetApplicationInstance | Sets the Extension Instance.
ShowContentDialog | Loads the ContentGenerator dialog.
ShowContentDialogParentIntPtr | Loads the ContentGenerator dialog.

REXContentDialogManager Methods

REXContentDialogManager Methods
REXContentDialogManager Class Legend
REXContentDialogManager Methods
REXContentDialogManager Methods | Description
DisposeContentDialog | Disposes the DRevitContentGenerator Extension.
SetApplicationInstance | Sets the Extension Instance.
ShowContentDialog | Loads the ContentGenerator dialog.
ShowContentDialogParentIntPtr | Loads the ContentGenerator dialog.

REXContentDialogManager Class Public Methods

REXContentDialogManager Class Public Methods