v2009_A |
v2009_A2 |
Links
REXRevitAccess Class, Legend, Members, Versions Fields

REXRevitAccess.Versions.v2008 Field

REXRevitAccess.Versions.v2008 Field
REXRevitAccess.Versions Class REX.Common Namespace REXRevitAccess.Versions Class
C#
public const string v2008 = "20070410_1700";
Class

REXRevitAccess.Versions Class

Links
REXRevitAccess.Versions Class, REX.Common Namespace, REXRevitAccess.Versions Class

REXRevitAccess.Versions.v2008_SP1 Field

REXRevitAccess.Versions.v2008_SP1 Field
REXRevitAccess.Versions Class REX.Common Namespace REXRevitAccess.Versions Class
C#
public const string v2008_SP1 = "20070607_1700";
Class

REXRevitAccess.Versions Class

Links
REXRevitAccess.Versions Class, REX.Common Namespace, REXRevitAccess.Versions Class

REXRevitAccess.Versions.v2008_SP2 Field

REXRevitAccess.Versions.v2008_SP2 Field
REXRevitAccess.Versions Class REX.Common Namespace REXRevitAccess.Versions Class
C#
public const string v2008_SP2 = "20070810_1700";
Class

REXRevitAccess.Versions Class

Links
REXRevitAccess.Versions Class, REX.Common Namespace, REXRevitAccess.Versions Class

REXRevitAccess.Versions.v2008_SP3 Field

REXRevitAccess.Versions.v2008_SP3 Field
REXRevitAccess.Versions Class REX.Common Namespace REXRevitAccess.Versions Class
C#
public const string v2008_SP3 = "20071109_2345";
Class

REXRevitAccess.Versions Class

Links
REXRevitAccess.Versions Class, REX.Common Namespace, REXRevitAccess.Versions Class

REXRevitAccess.Versions.v2008_SP4 Field

REXRevitAccess.Versions.v2008_SP4 Field
REXRevitAccess.Versions Class REX.Common Namespace REXRevitAccess.Versions Class
C#
public const string v2008_SP4 = "20071109_2345";
Class

REXRevitAccess.Versions Class

Links
REXRevitAccess.Versions Class, REX.Common Namespace, REXRevitAccess.Versions Class

REXRevitAccess.Versions.v2009_A Field

REXRevitAccess.Versions.v2009_A Field
REXRevitAccess.Versions Class REX.Common Namespace REXRevitAccess.Versions Class
C#
public const string v2009_A = "Development Build";
Class

REXRevitAccess.Versions Class

Links
REXRevitAccess.Versions Class, REX.Common Namespace, REXRevitAccess.Versions Class

REXRevitAccess.Versions.v2009_A2 Field

REXRevitAccess.Versions.v2009_A2 Field
REXRevitAccess.Versions Class REX.Common Namespace REXRevitAccess.Versions Class
C#
public const string v2009_A2 = "20071210_0209";
Class

REXRevitAccess.Versions Class

Links
REXRevitAccess.Versions Class, REX.Common Namespace, REXRevitAccess.Versions Class

REX.Common.REXRevitAccess.CompareVersionsResult Enumeration

REX.Common.REXRevitAccess.CompareVersionsResult Enumeration
REXRevitAccess Class

Dedicated enum for compare Revit's version.

C#
public enum CompareVersionsResult {
  Unknown,
  Lesser,
  Equal,
  Greater,
  Error
}
Members
Members | Description
Unknown | Unknown result.
Lesser | Lesser then current.
Equal | Equal to current.
Greater | Greater then current.
Error | Error on parsing one of versions.
Description
Class

REXRevitAccess Class

Links
REXRevitAccess Class
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXRevitAccess.AutoSelectionRestore Field

REXRevitAccess.AutoSelectionRestore Field
REXRevitAccess Class REX.Common Namespace REXRevitAccess Class

This is AutoSelectionRestore, a member of class REXRevitAccess.

C#
public bool AutoSelectionRestore = false;
Class

REXRevitAccess Class

Links
REXRevitAccess Class, REX.Common Namespace, REXRevitAccess Class

REXRevitAccess.UsingParameters Field

REXRevitAccess.UsingParameters Field
REXRevitAccess Class REX.Common Namespace REXRevitAccess Class

This is UsingParameters, a member of class REXRevitAccess.

C#
public bool UsingParameters = true;
Class

REXRevitAccess Class

Links
REXRevitAccess Class, REX.Common Namespace, REXRevitAccess Class

REXRevitAccess.Application Method

REXRevitAccess.Application Method
REXRevitAccess Class REX.Common Namespace REXRevitAccess Class

Access to Autodesk.Revit.ApplicationServices.ApplicationServices.Application object.

C#
public Autodesk.Revit.ApplicationServices.Application Application();
Returns

Returns reference to Autodesk.Revit.ApplicationServices.ApplicationServices.Application object.

Description
Class

REXRevitAccess Class

Links
REXRevitAccess Class, REX.Common Namespace, REXRevitAccess Class

REXRevitAccess.CommandData Method

REXRevitAccess.CommandData Method
REXRevitAccess Class REX.Common Namespace REXRevitAccess Class

Access to Autodesk.Revit.ExternalCommandData.

C#
public Autodesk.Revit.UI.ExternalCommandData CommandData();
Returns

Returns reference to Autodesk.Revit.ExternalCommandData.

Description
Class

REXRevitAccess Class

Links
REXRevitAccess Class, REX.Common Namespace, REXRevitAccess Class

REXRevitAccess.CompareVersions Method

REXRevitAccess.CompareVersions Method
REXRevitAccess Class REX.Common Namespace REXRevitAccess Class

Compares the versions.

C#
public CompareVersionsResult CompareVersions(string Version);
Parameters
Parameters | Description
Version | The version to compare.
Returns

Returns the result of comparison.

Description

Compare specified version with current version.

Class

REXRevitAccess Class

Links
REXRevitAccess Class, REX.Common Namespace, REXRevitAccess Class

REXRevitAccess.Create Method

REXRevitAccess.Create Method
REXRevitAccess Class REX.Common Namespace REXRevitAccess Class

Reads some data from Revit and sets system display units.

C#
public bool Create();
Returns

Returns true if succeeded.

Description
Class

REXRevitAccess Class

Links
REXRevitAccess Class, REX.Common Namespace, REXRevitAccess Class

REXRevitAccess.Destroy Method

REXRevitAccess.Destroy Method
REXRevitAccess Class REX.Common Namespace REXRevitAccess Class

Destroys and resets some objects connected to Revit.

C#
public bool Destroy();
Returns

Returns true if succeeded.

Description
Class

REXRevitAccess Class

Links
REXRevitAccess Class, REX.Common Namespace, REXRevitAccess Class

REXRevitAccess.Detach Method

REXRevitAccess.Detach Method
REXRevitAccess Class REX.Common Namespace REXRevitAccess Class

Detaches this instance.

C#
public void Detach();
Description
Class

REXRevitAccess Class

Links
REXRevitAccess Class, REX.Common Namespace, REXRevitAccess Class

REXRevitAccess.Elements Method

REXRevitAccess.Elements Method
REXRevitAccess Class REX.Common Namespace REXRevitAccess Class

Access to Autodesk.Revit.ExternalCommandData.

C#
public Autodesk.Revit.DB.ElementSet Elements();
Returns

Returns reference to Autodesk.Revit.ExternalCommandData.

Description
Class

REXRevitAccess Class

Links
REXRevitAccess Class, REX.Common Namespace, REXRevitAccess Class

REXRevitAccess.Event Method

REXRevitAccess.Event Method
REXRevitAccess Class REX.Common Namespace REXRevitAccess Class

Events the specified ev.

C#
public bool Event(REXAccess.REXAccessEvent Ev);
Parameters
Parameters | Description
Ev | The ev.
Description
Class

REXRevitAccess Class

Links
REXRevitAccess Class, REX.Common Namespace, REXRevitAccess Class

REXRevitAccess.Initialize Method

REXRevitAccess.Initialize Method
REXRevitAccess Class REX.Common Namespace REXRevitAccess Class

Initializes this instance.

C#
public void Initialize();
Description

Nostly sets language from parent application.

Class

REXRevitAccess Class

Links
REXRevitAccess Class, REX.Common Namespace, REXRevitAccess Class

REXRevitAccess.Message Method

REXRevitAccess.Message Method
REXRevitAccess Class REX.Common Namespace REXRevitAccess Class

Access to message string from Autodesk.Revit.IExternalCommand.Execute command.

C#
public string Message();
Returns

Returns the string.

Description
Class

REXRevitAccess Class

Links
REXRevitAccess Class, REX.Common Namespace, REXRevitAccess Class

REXRevitAccess.Update Method

REXRevitAccess.Update Method
REXRevitAccess Class REX.Common Namespace REXRevitAccess Class