REXEditControlEngine.IsInEditMode Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Determines whether control is in the edit mode.

C#
public bool IsInEditMode();
Returns

True if the control is in edit mode; otherwise, false.

Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.Refresh Method

REXEditControlEngine.Refresh Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Refreshes the text on the control based on the current text.

C#
public void Refresh();
Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.RefreshValidationStatus Method

REXEditControlEngine.RefreshValidationStatus Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Refreshes the validation status.

C#
public void RefreshValidationStatus();
Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.Reset Method

REXEditControlEngine.Reset Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Resets control (internal values).

C#
public void Reset();
Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.Restore Method

REXEditControlEngine.Restore Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Refreshes the text on the control based on the stored value.

C#
public void Restore();
Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.RestoreOriginalText Method

REXEditControlEngine.RestoreOriginalText Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Refreshes the text on the control based on the original text.

C#
public void RestoreOriginalText();
Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.SetBaseMaxValue Method

REXEditControlEngine.SetBaseMaxValue Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Set the maximum value defined in base units.

C#
public void SetBaseMaxValue(double value);
Parameters
Parameters | Description
value | The value.
Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.SetBaseMinValue Method

REXEditControlEngine.SetBaseMinValue Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Set the minimum value defined in base units.

C#
public void SetBaseMinValue(double value);
Parameters
Parameters | Description
value | The value.
Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.SetComplexDataBaseValue Method

REXEditControlEngine.SetComplexDataBaseValue Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Set the list of values defined in base units.

C#
public void SetComplexDataBaseValue(List<double> values);
Parameters
Parameters | Description
values | The values.
Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.SetComplexDataInterfaceValue Method

REXEditControlEngine.SetComplexDataInterfaceValue Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Set the list of values defined in interface units.

C#
public void SetComplexDataInterfaceValue(List<double> values, REXInterfaceType interfaceType);
Parameters
Parameters | Description
values | The values.
interfaceType | The product context.
Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.SetComplexValue Method (List<double>)

REXEditControlEngine.SetComplexValue Method (List<double>)
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Sets the complex (list) value of the double type.

C#
public virtual void SetComplexValue(List<double> values);
Parameters
Parameters | Description
values | The list of values.
Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.SetComplexValue Method (List<string>)

REXEditControlEngine.SetComplexValue Method (List<string>)
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Sets the complex (list) value of the string type.

C#
public void SetComplexValue(List<string> values);
Parameters
Parameters | Description
values | The list of values.
Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.SetComplexValue Method (String)

REXEditControlEngine.SetComplexValue Method (String)
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Sets the complex (list) value of the string type.

C#
public bool SetComplexValue(String value);
Parameters
Parameters | Description
value | The value.
Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.SetControl Method

REXEditControlEngine.SetControl Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Sets the control for which the current instance is the engine.

C#
public void SetControl(IEditControl control);
Parameters
Parameters | Description
control | The control.
Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.SetDataBaseValue Method

REXEditControlEngine.SetDataBaseValue Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Set the value in base units.

C#
public void SetDataBaseValue(double value);
Parameters
Parameters | Description
value | The value.
Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.SetDataInterfaceValue Method

REXEditControlEngine.SetDataInterfaceValue Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Set the value in interface units.

C#
public void SetDataInterfaceValue(double value, REXInterfaceType interfaceType);
Parameters
Parameters | Description
value | The value.
interfaceType | The product context.
Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.SetExternalUnitBody Method

REXEditControlEngine.SetExternalUnitBody Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Set external IUnitBody object.

C#
public void SetExternalUnitBody(IUnitBody unitBody);
Parameters
Parameters | Description
unitBody | External IUnitBody object
Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.SetInterfaceMaxValue Method

REXEditControlEngine.SetInterfaceMaxValue Method