ContentMapper.SetDefaults Method
ContentMapper Class REX.ContentGenerator.Map Namespace ContentMapper Class

Sets defaults in the mapping system.

C#
public void SetDefaults(Autodesk.REX.Framework.IREXRegionalSettings regionalSettings, ECategoryType type);
Parameters
Parameters | Description
regionalSettings | Regional settings.
type | The type.
Description
Class

ContentMapper Class

Links
ContentMapper Class, REX.ContentGenerator.Map Namespace, ContentMapper Class

ContentMapper.SetREXConverter Method

ContentMapper.SetREXConverter Method
ContentMapper Class REX.ContentGenerator.Map Namespace ContentMapper Class

Sets the REX converter.

C#
public void SetREXConverter(REXFamilyConverter converter);
Parameters
Parameters | Description
converter | The converter.
Description
Remarks

If there is already defined converter it can be passed to the map object. Otherwise Content Generator will create its own instance of the REXFamilyConverter class.

Class

ContentMapper Class

Links
ContentMapper Class, REX.ContentGenerator.Map Namespace, ContentMapper Class

ContentMapper.DialogSettings Property

ContentMapper.DialogSettings Property
ContentMapper Class REX.ContentGenerator.Map Namespace ContentMapper Class

Gets the dialog's settings.

C#
public REXContentMapDialogSettings DialogSettings;
Description

The dialog's settings.

Class

ContentMapper Class

Links
ContentMapper Class, REX.ContentGenerator.Map Namespace, ContentMapper Class

REXContentMapCategorySettings Class

REXContentMapCategorySettings Class
REX.ContentGenerator.Map Namespace Legend Members Public Methods REXContentMapCategorySettings Methods REXContentMapCategorySettings Properties

Represents settings for a specific category of elements.

Class Hierarchy
C#
public class REXContentMapCategorySettings;
Description
Namespace

REX.ContentGenerator.Map Namespace

Public Methods
Public Method | Description
REXContentMapCategorySettings | Initializes a new instance of the REXContentMapCategorySettings class.
REXContentMapCategorySettings Methods
REXContentMapCategorySettings Methods | Description
ContainsLabel | Determines whether the mapping system contains the specified label.
FilterFamilies | Filters the list of families.
FilterFamily | Filters the family object according settings.
REXContentMapCategorySettings Properties
REXContentMapCategorySettings Properties | Description
AddMappedDatabases | Gets or sets a value indicating whether databases saved in loaded files should be loaded to the system.
AllowToAddDatabases | Gets or sets a value indicating whether a user is able to add databases to the list.
Category | Gets the category.
Databases | Gets or sets the list of databases supported by this category.
DatabasesResult | Gets or sets the list of databases which were finally choosen by the user in the dialog.
Elements | Gets the list of elements which should be mapped.
LabelCategoryName | Gets or sets the name of the label category.
Labels | Gets the list of labels.
MapCertifiedFamilies | Gets or sets a value indicating whether certified families are mapped.
SetDefaultsForUnknown | Gets or sets a value indicating whether defaults are set for elements which weren't mapped.
Settings | Gets the settings of the dialog.
Visible | Gets or sets a value indicating whether this category is visible.
Links
REX.ContentGenerator.Map Namespace, Legend, Members, Public Methods, REXContentMapCategorySettings Methods, REXContentMapCategorySettings Properties

REXContentMapCategorySettings.REXContentMapCategorySettings Constructor

REXContentMapCategorySettings.REXContentMapCategorySettings Constructor
REXContentMapCategorySettings Class REX.ContentGenerator.Map Namespace REXContentMapCategorySettings Class

Initializes a new instance of the REXContentMapCategorySettings class.

C#
public REXContentMapCategorySettings(ECategoryType category, REXContentMapDialogSettings settings);
Parameters
Parameters | Description
category | The category.
settings | Settings.
Description
Class

REXContentMapCategorySettings Class

Links
REXContentMapCategorySettings Class, REX.ContentGenerator.Map Namespace, REXContentMapCategorySettings Class

REXContentMapCategorySettings.ContainsLabel Method

REXContentMapCategorySettings.ContainsLabel Method
REXContentMapCategorySettings Class REX.ContentGenerator.Map Namespace REXContentMapCategorySettings Class

Determines whether the mapping system contains the specified label.

C#
public virtual bool ContainsLabel(REXFamilyType_Label label);
Parameters
Parameters | Description
label | The label.
Returns

Whether specific label is already defined in the Content Generator.

Description
Class

REXContentMapCategorySettings Class

Links
REXContentMapCategorySettings Class, REX.ContentGenerator.Map Namespace, REXContentMapCategorySettings Class

REXContentMapCategorySettings.FilterFamilies Method

REXContentMapCategorySettings.FilterFamilies Method
REXContentMapCategorySettings Class REX.ContentGenerator.Map Namespace REXContentMapCategorySettings Class

Filters the list of families.

C#
public virtual List<REXFamilyType> FilterFamilies(List<REXFamilyType> families);
Parameters
Parameters | Description
families | The input list.
Returns

The filtered family list.

Description
Class

REXContentMapCategorySettings Class

Links
REXContentMapCategorySettings Class, REX.ContentGenerator.Map Namespace, REXContentMapCategorySettings Class

REXContentMapCategorySettings.FilterFamily Method

REXContentMapCategorySettings.FilterFamily Method
REXContentMapCategorySettings Class REX.ContentGenerator.Map Namespace REXContentMapCategorySettings Class

Filters the family object according settings.

C#
public virtual bool FilterFamily(REXFamilyType family);
Parameters
Parameters | Description
family | The family object.
Description
Class

REXContentMapCategorySettings Class

Links
REXContentMapCategorySettings Class, REX.ContentGenerator.Map Namespace, REXContentMapCategorySettings Class

REXContentMapCategorySettings.AddMappedDatabases Property

REXContentMapCategorySettings.AddMappedDatabases Property
REXContentMapCategorySettings Class REX.ContentGenerator.Map Namespace REXContentMapCategorySettings Class

Gets or sets a value indicating whether databases saved in loaded files should be loaded to the system.

C#
public bool AddMappedDatabases;
Description

True if databases loaded from files are visible; otherwise, false.

Class

REXContentMapCategorySettings Class

Links
REXContentMapCategorySettings Class, REX.ContentGenerator.Map Namespace, REXContentMapCategorySettings Class

REXContentMapCategorySettings.AllowToAddDatabases Property

REXContentMapCategorySettings.AllowToAddDatabases Property
REXContentMapCategorySettings Class REX.ContentGenerator.Map Namespace REXContentMapCategorySettings Class

Gets or sets a value indicating whether a user is able to add databases to the list.

C#
public bool AllowToAddDatabases;
Description

True if a user is able to add databases; otherwise, false.

Class

REXContentMapCategorySettings Class

Links
REXContentMapCategorySettings Class, REX.ContentGenerator.Map Namespace, REXContentMapCategorySettings Class

REXContentMapCategorySettings.Category Property

REXContentMapCategorySettings.Category Property
REXContentMapCategorySettings Class REX.ContentGenerator.Map Namespace REXContentMapCategorySettings Class

Gets the category.

C#
public ECategoryType Category;
Description

The category.

Class

REXContentMapCategorySettings Class

Links
REXContentMapCategorySettings Class, REX.ContentGenerator.Map Namespace, REXContentMapCategorySettings Class

REXContentMapCategorySettings.Databases Property

REXContentMapCategorySettings.Databases Property
REXContentMapCategorySettings Class REX.ContentGenerator.Map Namespace REXContentMapCategorySettings Class

Gets or sets the list of databases supported by this category.

C#
public List<string> Databases;
Description

The list of databases.

Remarks

If the list is empty all databases will be supported.