The accuracy.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.InvalidCharacters Property

REXComboBox.InvalidCharacters Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets or sets the list invalid characters (for the control in TEXT mode).

C#
[Browsable(true)]
public string InvalidCharacters;
Description

The list of invalid characters.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.ListValidation Property

REXComboBox.ListValidation Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets or sets a value indicating whether the list should be validated.

C#
public bool ListValidation;
Description

True if validate; otherwise false.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.MaxTokens Property

REXComboBox.MaxTokens Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets or sets the maximum number of elements in the complex mode (list).

C#
[Category("Complex")]
[Browsable(true)]
public int MaxTokens;
Description

The maximum number of elements.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.MinTokens Property

REXComboBox.MinTokens Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets or sets the minimum number of elements in the complex mode (list).

C#
[Category("Complex")]
[Browsable(true)]
public int MinTokens;
Description

The minimum number of elements.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.Name Property

REXComboBox.Name Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets or sets the name of the control.

C#
public new string Name;
Returns

The name of the control. The default is an empty string ("").

Description

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.OnDisableAction Property

REXComboBox.OnDisableAction Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets or sets a value indicating whether the foreground should be hidden when the control is disabled.

C#
[Browsable(true)]
[Category("Data")]
public EOnDisable OnDisableAction;
Description

The behaviour of the control's foreground.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.OriginalTextOnEnter Property

REXComboBox.OriginalTextOnEnter Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets or sets a value indicating whether an original text should be set when the user enters the control.

C#
[Browsable(true)]
[Category("Behavior")]
public bool OriginalTextOnEnter;
Description

True if original text is to be set; otherwise, false.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.RangeMax Property

REXComboBox.RangeMax Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets or sets the highest possible value.

C#
[Browsable(true)]
[Category("Data")]
[DefaultValue(Double.PositiveInfinity)]
public Double RangeMax;
Description

The highest possible value.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.RangeMaxCheck Property

REXComboBox.RangeMaxCheck Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets or sets a value indicating whether the value should be validated due to the RangeMax.

C#
[Browsable(true)]
[Category("Data")]
[DefaultValue(false)]
public Boolean RangeMaxCheck;
Description

True if validate; otherwise false.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.RangeMin Property

REXComboBox.RangeMin Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets or sets the minimum possible value.

C#
[Browsable(true)]
[Category("Data")]
[DefaultValue(Double.NegativeInfinity)]
public Double RangeMin;
Description

The minimum possible value.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.RangeMinCheck Property

REXComboBox.RangeMinCheck Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets or sets a value indicating whether the value should be validated due to the RangeMin.

C#
[Browsable(true)]
[Category("Data")]
[DefaultValue(false)]
public Boolean RangeMinCheck;
Description

True if validate; otherwise false.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.RememberCorrect Property

REXComboBox.RememberCorrect Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets or sets a value indicating whether the correct value should be restored in case of the validation failure.

C#
[Browsable(true)]
[Category("Data")]
public Boolean RememberCorrect;
Description

True if the value should be restored; otherwise false.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.RoundingFractional Property

REXComboBox.RoundingFractional Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets or sets the rounding for fractional units.

C#
[Browsable(true)]
[Category("Data")]
public EFractialRound RoundingFractional;
Description

The rounding.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.RoundingIncrement Property

REXComboBox.RoundingIncrement Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets or sets the rounding increment (for the DECIMAL DataType).

C#
[Browsable(true)]
[Category("Data")]
public Double RoundingIncrement;
Description

The rounding increment.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.Separator Property

REXComboBox.Separator Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets or sets the decimal separator.

C#
[Browsable(true)]
[Category("Data")]
public String Separator;
Description

The separator.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.TabIndex Property

REXComboBox.TabIndex Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets or sets the tab order of the control within its container.

C#
public new int TabIndex;
Returns

The index value of the control within the set of controls within its container. The controls in the container are included in the tab order.

Description

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.Text Property

REXComboBox.Text Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets the text contents of the control.

C#
[Browsable(true)]
public new string Text;
Description

The text.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.TextAlign Property

REXComboBox.TextAlign Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets or sets the text alignment.

C#
public HorizontalAlignment TextAlign;
Description

The text alignment.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.TextBoxMode Property

REXComboBox.TextBoxMode Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets or sets a value indicating whether the combobox is in the editbox mode.

C#
[Browsable(true)]
public bool TextBoxMode;
Description