REXDBDescription.CompareTo Method
REXDBDescription Class REX.ContentGenerator.Families Namespace REXDBDescription Class

Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.

C#
public override int CompareTo(object obj);
Parameters
Parameters | Description
obj | An object to compare with this instance.
Returns

Returns a result of the comparison.

Description
Class

REXDBDescription Class

Links
REXDBDescription Class, REX.ContentGenerator.Families Namespace, REXDBDescription Class

REXDBDescription.GetValue Method

REXDBDescription.GetValue Method
REXDBDescription Class REX.ContentGenerator.Families Namespace REXDBDescription Class

Gets the value.

C#
public override object GetValue(string name);
Parameters
Parameters | Description
name | The name of parameter.
Returns

The value of the specified parameter.

Description
Class

REXDBDescription Class

Links
REXDBDescription Class, REX.ContentGenerator.Families Namespace, REXDBDescription Class

REXDBDescription.RecalculateParameters Method

REXDBDescription.RecalculateParameters Method
REXDBDescription Class REX.ContentGenerator.Families Namespace REXDBDescription Class

Recalculates the parameters.

C#
public override void RecalculateParameters(double coeff);
Parameters
Parameters | Description
coeff | The coefficient.
Description
Class

REXDBDescription Class

Links
REXDBDescription Class, REX.ContentGenerator.Families Namespace, REXDBDescription Class

REXDBDescription.SetValue Method

REXDBDescription.SetValue Method
REXDBDescription Class REX.ContentGenerator.Families Namespace REXDBDescription Class

Sets the value.

C#
public override bool SetValue(string name, object val);
Parameters
Parameters | Description
name | The name.
val | The value.
Returns

True if value set; otherwise false.

Description
Class

REXDBDescription Class

Links
REXDBDescription Class, REX.ContentGenerator.Families Namespace, REXDBDescription Class

REXDBDescription.DBName Property

REXDBDescription.DBName Property
REXDBDescription Class REX.ContentGenerator.Families Namespace REXDBDescription Class

Gets or sets the name of the DB.

C#
public string DBName;
Description

The name of the DB.

Class

REXDBDescription Class

Links
REXDBDescription Class, REX.ContentGenerator.Families Namespace, REXDBDescription Class

REXDBDescription.Directory Property

REXDBDescription.Directory Property
REXDBDescription Class REX.ContentGenerator.Families Namespace REXDBDescription Class

Gets or sets the directory.

C#
public string Directory;
Description

The directory.

Class

REXDBDescription Class

Links
REXDBDescription Class, REX.ContentGenerator.Families Namespace, REXDBDescription Class

REXDescription Class

REXDescription Class
REX.ContentGenerator.Families Namespace Legend Members Public Methods REXDescription Methods

Base class for all descriptions of objects in REXFamilyType.

Class Hierarchy
C#
[Serializable()]
public abstract class REXDescription : SerializableObject, System.Collections.IEnumerable, IComparable, ICloneable;
Description
Namespace

REX.ContentGenerator.Families Namespace

Public Methods
Public Method | Description
REXDescription | Initializes a new instance of the REXDescription class.
REXDescription | Initializes a new instance of the REXDescription class.
REXDescription | Initializes a new instance of the REXDescription class.
REXDescription | Initializes a new instance of the REXDescription class.
REXDescription Methods
REXDescription Methods | Description
Clone | Creates a new object that is a copy of the current instance.
CompareProperty | This is CompareProperty, a member of class REXDescription.
CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
GetEnumerator | Returns an enumerator that iterates through a collection.
GetValue | Gets the value.
RecalculateParameters | Recalculates the parameters.
Set2Null | Sets all values to default one.
SetValue | Sets the value.
Links
REX.ContentGenerator.Families Namespace, Legend, Members, Public Methods, REXDescription Methods

REXDescription.REXDescription Constructor ()

REXDescription.REXDescription Constructor ()
REXDescription Class REX.ContentGenerator.Families Namespace REXDescription Class

Initializes a new instance of the REXDescription class.

C#
public REXDescription();
Description
Class

REXDescription Class

Links
REXDescription Class, REX.ContentGenerator.Families Namespace, REXDescription Class

REXDescription.REXDescription Constructor (DTableDataObjectCollection)

REXDescription.REXDescription Constructor (DTableDataObjectCollection)
REXDescription Class REX.ContentGenerator.Families Namespace REXDescription Class

Initializes a new instance of the REXDescription class.

C#
public REXDescription(DTableDataObjectCollection pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

REXDescription Class

Links
REXDescription Class, REX.ContentGenerator.Families Namespace, REXDescription Class

REXDescription.REXDescription Constructor (REXDescription)

REXDescription.REXDescription Constructor (REXDescription)
REXDescription Class REX.ContentGenerator.Families Namespace REXDescription Class

Initializes a new instance of the REXDescription class.

C#
public REXDescription(REXDescription pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

REXDescription Class

Links
REXDescription Class, REX.ContentGenerator.Families Namespace, REXDescription Class

REXDescription.REXDescription Constructor (System.Data.DataRow)

REXDescription.REXDescription Constructor (System.Data.DataRow)
REXDescription Class REX.ContentGenerator.Families Namespace REXDescription Class

Initializes a new instance of the REXDescription class.

C#
public REXDescription(System.Data.DataRow pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

REXDescription Class

Links
REXDescription Class, REX.ContentGenerator.Families Namespace, REXDescription Class

REXDescription.Clone Method

REXDescription.Clone Method
REXDescription Class REX.ContentGenerator.Families Namespace REXDescription Class

Creates a new object that is a copy of the current instance.

C#
public abstract object Clone();
Returns

A new object that is a copy of this instance.

Description
Class

REXDescription Class

Links
REXDescription Class, REX.ContentGenerator.Families Namespace, REXDescription Class

REXDescription.CompareProperty Method

REXDescription.CompareProperty Method
REXDescription Class REX.ContentGenerator.Families Namespace REXDescription Class

This is CompareProperty, a member of class REXDescription.

C#
public int CompareProperty(string name, REXDescription desc);
Class

REXDescription Class

Links
REXDescription Class, REX.ContentGenerator.Families Namespace, REXDescription Class

REXDescription.CompareTo Method

REXDescription.CompareTo Method
REXDescription Class REX.ContentGenerator.Families Namespace REXDescription Class

Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.

C#
public virtual int CompareTo(object obj);
Parameters
Parameters | Description
obj | An object to compare with this instance.
Returns

Returns a result of the comparison.

Description
Class

REXDescription Class

Links
REXDescription Class, REX.ContentGenerator.Families Namespace, REXDescription Class

REXDescription.GetEnumerator Method

REXDescription.GetEnumerator Method
REXDescription Class REX.ContentGenerator.Families Namespace REXDescription Class