B | Gets or sets the section's width.
B_2 | Gets or sets the AISC k value for design.
EA | Gets or sets the web thickness.
ES | Gets or sets the flange thickness.
ES_2 | Gets or sets the AISC design value k.
GAMMA | Gets or sets the angle of rotation of the section local to principal coordinate system (maximum moments of inertia of a section).
GAP | Gets or sets the distance between sections in compound sections.
H | Gets or sets the section's height.
P1_L | Gets or sets the length of slab P2 (cross-shaped section).
P1_T | Gets or sets the thickness of slab P1 (cross-shaped section).
P2_L | Gets or sets the length of slab P2 (cross-shaped section).
P2_T | Gets or sets the Thickness of slab P2 (cross-shaped section).
P3_L | Gets or sets the Length of slab P3 (cross-shaped section).
P3_T | Gets or sets the thickness of slab P3 (cross-shaped section).
P4_L | Gets or sets the length of slab P4 (cross-shaped section).
P4_T | Gets or sets the thickness of slab P4 (cross-shaped section).
RA | Gets or sets the fillet radius (web).
RS | Gets or sets the fillet radius (flange).
SLOPE_FACTOR | Gets or sets the slope factor.
VPY | Gets or sets the extreme distance from the local Z axis of the point on the negative side of the Y axis.
VPZ | Gets or sets the extreme distance from the local Y axis of the point on the negative side of the Z axis.
VY | Gets or sets the extreme distance from the local Z axis of the point on the positive side of the Y axis.
VZ | Gets or sets the extreme distance from the local Y axis of the point on the positive side of the Z axis.
Links
REX.ContentGenerator.Families Namespace, Legend, Members, Public Methods, REXSectionDBDimensions Methods, REXSectionDBDimensions Properties

REXSectionDBDimensions.REXSectionDBDimensions Constructor ()

REXSectionDBDimensions.REXSectionDBDimensions Constructor ()
REXSectionDBDimensions Class REX.ContentGenerator.Families Namespace REXSectionDBDimensions Class

Initializes a new instance of the REXSectionDBDimensions class.

C#
public REXSectionDBDimensions();
Description
Class

REXSectionDBDimensions Class

Links
REXSectionDBDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionDBDimensions Class

REXSectionDBDimensions.REXSectionDBDimensions Constructor (DTableDataObjectCollection)

REXSectionDBDimensions.REXSectionDBDimensions Constructor (DTableDataObjectCollection)
REXSectionDBDimensions Class REX.ContentGenerator.Families Namespace REXSectionDBDimensions Class

Initializes a new instance of the REXSectionDBDimensions class.

C#
public REXSectionDBDimensions(DTableDataObjectCollection pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

REXSectionDBDimensions Class

Links
REXSectionDBDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionDBDimensions Class

REXSectionDBDimensions.REXSectionDBDimensions Constructor (REXSectionDBDimensions)

REXSectionDBDimensions.REXSectionDBDimensions Constructor (REXSectionDBDimensions)
REXSectionDBDimensions Class REX.ContentGenerator.Families Namespace REXSectionDBDimensions Class

Initializes a new instance of the REXSectionDBDimensions class.

C#
public REXSectionDBDimensions(REXSectionDBDimensions pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

REXSectionDBDimensions Class

Links
REXSectionDBDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionDBDimensions Class

REXSectionDBDimensions.REXSectionDBDimensions Constructor (System.Data.DataRow)

REXSectionDBDimensions.REXSectionDBDimensions Constructor (System.Data.DataRow)
REXSectionDBDimensions Class REX.ContentGenerator.Families Namespace REXSectionDBDimensions Class

Initializes a new instance of the REXSectionDBDimensions class.

C#
public REXSectionDBDimensions(System.Data.DataRow pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

REXSectionDBDimensions Class

Links
REXSectionDBDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionDBDimensions Class

REXSectionDBDimensions.Clone Method

REXSectionDBDimensions.Clone Method
REXSectionDBDimensions Class REX.ContentGenerator.Families Namespace REXSectionDBDimensions Class

Creates a new object that is a copy of the current instance.

C#
public override object Clone();
Returns

A new object that is a copy of this instance.

Description
Class

REXSectionDBDimensions Class

Links
REXSectionDBDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionDBDimensions Class

REXSectionDBDimensions.A_1 Property

REXSectionDBDimensions.A_1 Property
REXSectionDBDimensions Class REX.ContentGenerator.Families Namespace REXSectionDBDimensions Class

Gets or sets the additional angle.

C#
public double A_1;
Description

The additional angle.

Class

REXSectionDBDimensions Class

Links
REXSectionDBDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionDBDimensions Class

REXSectionDBDimensions.A_2 Property

REXSectionDBDimensions.A_2 Property
REXSectionDBDimensions Class REX.ContentGenerator.Families Namespace REXSectionDBDimensions Class

Gets or sets the additional angle.

C#
public double A_2;
Description

The additional angle.

Class

REXSectionDBDimensions Class

Links
REXSectionDBDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionDBDimensions Class

REXSectionDBDimensions.B Property

REXSectionDBDimensions.B Property
REXSectionDBDimensions Class REX.ContentGenerator.Families Namespace REXSectionDBDimensions Class

Gets or sets the section's width.

C#
public double B;
Description

The section's width.

Class

REXSectionDBDimensions Class

Links
REXSectionDBDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionDBDimensions Class

REXSectionDBDimensions.B_2 Property

REXSectionDBDimensions.B_2 Property
REXSectionDBDimensions Class REX.ContentGenerator.Families Namespace REXSectionDBDimensions Class

Gets or sets the AISC k value for design.

C#
public double B_2;
Description

The AISC k value for design.

Class

REXSectionDBDimensions Class

Links
REXSectionDBDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionDBDimensions Class

REXSectionDBDimensions.EA Property

REXSectionDBDimensions.EA Property
REXSectionDBDimensions Class REX.ContentGenerator.Families Namespace REXSectionDBDimensions Class

Gets or sets the web thickness.

C#
public double EA;
Description

The web thickness.

Class

REXSectionDBDimensions Class

Links
REXSectionDBDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionDBDimensions Class

REXSectionDBDimensions.ES Property

REXSectionDBDimensions.ES Property
REXSectionDBDimensions Class REX.ContentGenerator.Families Namespace REXSectionDBDimensions Class

Gets or sets the flange thickness.

C#
public double ES;
Description

The flange thickness.

Class

REXSectionDBDimensions Class

Links
REXSectionDBDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionDBDimensions Class

REXSectionDBDimensions.ES_2 Property

REXSectionDBDimensions.ES_2 Property
REXSectionDBDimensions Class REX.ContentGenerator.Families Namespace REXSectionDBDimensions Class

Gets or sets the AISC design value k.

C#
public double ES_2;
Description

The AISC design value k.

Class

REXSectionDBDimensions Class

Links
REXSectionDBDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionDBDimensions Class

REXSectionDBDimensions.GAMMA Property

REXSectionDBDimensions.GAMMA Property
REXSectionDBDimensions Class REX.ContentGenerator.Families Namespace REXSectionDBDimensions Class

Gets or sets the angle of rotation of the section local to principal coordinate system (maximum moments of inertia of a section).

C#
public double GAMMA;
Description

The angle of rotation of the section.

Class

REXSectionDBDimensions Class

Links
REXSectionDBDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionDBDimensions Class

REXSectionDBDimensions.GAP Property