Returns an enumerator that iterates through a collection.

C#
public System.Collections.IEnumerator GetEnumerator();
Description
Class

REXDescription Class

Links
REXDescription Class, REX.ContentGenerator.Families Namespace, REXDescription Class

REXDescription.GetValue Method

REXDescription.GetValue Method
REXDescription Class REX.ContentGenerator.Families Namespace REXDescription Class

Gets the value.

C#
public virtual object GetValue(string name);
Parameters
Parameters | Description
name | The name.
Returns

The value.

Description
Class

REXDescription Class

Links
REXDescription Class, REX.ContentGenerator.Families Namespace, REXDescription Class

REXDescription.RecalculateParameters Method

REXDescription.RecalculateParameters Method
REXDescription Class REX.ContentGenerator.Families Namespace REXDescription Class

Recalculates the parameters.

C#
public virtual void RecalculateParameters(double coeff);
Parameters
Parameters | Description
coeff | The coefficient.
Description
Class

REXDescription Class

Links
REXDescription Class, REX.ContentGenerator.Families Namespace, REXDescription Class

REXDescription.Set2Null Method

REXDescription.Set2Null Method
REXDescription Class REX.ContentGenerator.Families Namespace REXDescription Class

Sets all values to default one.

C#
public virtual void Set2Null();
Description
Class

REXDescription Class

Links
REXDescription Class, REX.ContentGenerator.Families Namespace, REXDescription Class

REXDescription.SetValue Method

REXDescription.SetValue Method
REXDescription Class REX.ContentGenerator.Families Namespace REXDescription Class

Sets the value.

C#
public virtual bool SetValue(string name, object val);
Parameters
Parameters | Description
name | The name.
val | The value.
Returns

Returns if action succeeded.

Description
Class

REXDescription Class

Links
REXDescription Class, REX.ContentGenerator.Families Namespace, REXDescription Class

REXFamilyType Class

REXFamilyType Class
REX.ContentGenerator.Families Namespace Legend Members Public Methods REXFamilyType Methods REXFamilyType Properties

The base class for all content types supported by the REXContentGenerator.

Class Hierarchy
C#
[Serializable()]
public class REXFamilyType : SerializableObject, IComparable, ICloneable;
Description
Remarks

The REXFamilyType is the center point of the REX.ContentGenerator component. It is an intermediate container which represents the specified type of the element. Converters communicate with each other using this description and don’t have to know anything about themself.

Namespace

REX.ContentGenerator.Families Namespace

Public Methods
Public Method | Description
REXFamilyType | Initializes a new instance of the REXFamilyType class.
REXFamilyType | Initializes a new instance of the REXFamilyType class.
REXFamilyType | Initializes a new instance of the REXFamilyType class.
REXFamilyType Methods
REXFamilyType Methods | Description
Clone | Creates a new object that is a copy of the current instance.
CompareTo | Compares the current object with the other object.
REXFamilyType Properties
REXFamilyType Properties | Description
CategoryType | Gets the category.
Certified | Gets or sets a value indicating whether the element is certified.
Description | Gets or sets the description of the object.
Element | Gets or sets the element.
ElementType | Gets or sets the type of the element.
FamilyName | Gets or sets the name of the family.
Mapped | If the REXFamilyType is mapped.
Material | Gets or sets the material.
TypeName | Gets or sets the name of the type.
UniqueID | The unique id.
Links
REX.ContentGenerator.Families Namespace, Legend, Members, Public Methods, REXFamilyType Methods, REXFamilyType Properties

REXFamilyType.REXFamilyType Constructor ()

REXFamilyType.REXFamilyType Constructor ()
REXFamilyType Class REX.ContentGenerator.Families Namespace REXFamilyType Class

Initializes a new instance of the REXFamilyType class.

C#
public REXFamilyType();
Description
Class

REXFamilyType Class

Links
REXFamilyType Class, REX.ContentGenerator.Families Namespace, REXFamilyType Class

REXFamilyType.REXFamilyType Constructor (REXFamilyType)

REXFamilyType.REXFamilyType Constructor (REXFamilyType)
REXFamilyType Class REX.ContentGenerator.Families Namespace REXFamilyType Class

Initializes a new instance of the REXFamilyType class.

C#
public REXFamilyType(REXFamilyType pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

REXFamilyType Class

Links
REXFamilyType Class, REX.ContentGenerator.Families Namespace, REXFamilyType Class

REXFamilyType.REXFamilyType Constructor (string, string, REX.ContentGenerator.Families.EElementType, bool, EMaterial)

REXFamilyType.REXFamilyType Constructor (string, string, REX.ContentGenerator.Families.EElementType, bool, EMaterial)
REXFamilyType Class REX.ContentGenerator.Families Namespace REXFamilyType Class

Initializes a new instance of the REXFamilyType class.

C#
public REXFamilyType(string familyName, string typeName, REX.ContentGenerator.Families.EElementType category, bool certified, EMaterial material);
Parameters
Parameters | Description
familyName | The name of the family.
typeName | The name of the type.
category | The category.
certified | Indicates whether the object is certified.
material | The material.
Description
Class

REXFamilyType Class

Links
REXFamilyType Class, REX.ContentGenerator.Families Namespace, REXFamilyType Class

REXFamilyType.Clone Method

REXFamilyType.Clone Method
REXFamilyType Class REX.ContentGenerator.Families Namespace REXFamilyType Class

Creates a new object that is a copy of the current instance.

C#
public virtual object Clone();
Returns

A new object that is a copy of this instance.

Description
Class

REXFamilyType Class

Links
REXFamilyType Class, REX.ContentGenerator.Families Namespace, REXFamilyType Class

REXFamilyType.CompareTo Method

REXFamilyType.CompareTo Method
REXFamilyType Class REX.ContentGenerator.Families Namespace REXFamilyType Class

Compares the current object with the other object.

C#
public virtual int CompareTo(object obj);
Parameters
Parameters | Description
obj | The object.
Returns

Returns the result of the comparison.

Description
Class

REXFamilyType Class

Links
REXFamilyType Class, REX.ContentGenerator.Families Namespace, REXFamilyType Class

REXFamilyType.CategoryType Property

REXFamilyType.CategoryType Property
REXFamilyType Class REX.ContentGenerator.Families Namespace REXFamilyType Class

Gets the category.

C#
public virtual ECategoryType CategoryType;
Description

The category.

Class

REXFamilyType Class

Links
REXFamilyType Class, REX.ContentGenerator.Families Namespace, REXFamilyType Class

REXFamilyType.Certified Property

REXFamilyType.Certified Property
REXFamilyType Class REX.ContentGenerator.Families Namespace REXFamilyType Class

Gets or sets a value indicating whether the element is certified.

C#
public bool Certified;
Description

True if certified; otherwise, false.

Class

REXFamilyType Class

Links
REXFamilyType Class, REX.ContentGenerator.Families Namespace, REXFamilyType Class

REXFamilyType.Description Property

REXFamilyType.Description Property
REXFamilyType Class REX.ContentGenerator.Families Namespace REXFamilyType Class

Gets or sets the description of the object.

C#
public REXDescription Description;
Description

The description.

Class

REXFamilyType Class

Links
REXFamilyType Class, REX.ContentGenerator.Families Namespace, REXFamilyType Class

REXFamilyType.Element Property

REXFamilyType.Element Property
REXFamilyType Class REX.ContentGenerator.Families Namespace REXFamilyType Class

Gets or sets the element.

C#
public object Element;
Description

The element.

Class

REXFamilyType Class

Links
REXFamilyType Class, REX.ContentGenerator.Families Namespace, REXFamilyType Class

REXFamilyType.ElementType Property

REXFamilyType.ElementType Property
REXFamilyType Class REX.ContentGenerator.Families Namespace REXFamilyType Class