ROHTMLStdImages Class, ROHTML Namespace, ROHTMLStdImages Class

ROHTMLStdImages.ROSTD_TABLET_OK Field

ROHTMLStdImages.ROSTD_TABLET_OK Field
ROHTMLStdImages Class ROHTML Namespace ROHTMLStdImages Class

Image verified

C#
public const short ROSTD_TABLET_OK = &H0001;
Class

ROHTMLStdImages Class

Links
ROHTMLStdImages Class, ROHTML Namespace, ROHTMLStdImages Class

ROHTMLTableFormats Class

ROHTMLTableFormats Class
ROHTML Namespace Legend Members ROHTMLTableFormats Fields

This is class ROHTML.ROHTMLTableFormats.

Class Hierarchy
C#
public class ROHTMLTableFormats;
Namespace

ROHTML Namespace

ROHTMLTableFormats Fields
ROHTMLTableFormats Fields | Description
ROTF_LIST_1 | Columns:2, Style:list1
ROTF_LIST_2 | Columns:5, Width:100%, Style:list2 Column[1]:Width:8%, nowrap Column[2]:Width:8%, nowrap, Style:font-family:monospace;text-align:right; Column[3]:Width:10%, Style:text-align:center; Column[4]:Width:40% Column[5]:Style=text-align:right;
ROTF_LIST_3 | Columns:2, Width:100%, Style:list3 Column[2].style=text-align:right;
ROTF_LIST_4 | Columns:2, Style:list4 Column[1]:nowrap
ROTF_TABLE_1 | Width:100%, Style:table1, Header rows and columns:1
ROTF_TABLE_2 | Width:100%, Style:table2, Header rows and columns:1
ROTF_TABLE_3 | Width:100%, Style:table3, Header rows and columns:1
ROTF_VERIFY_1 | Columns:4, Width:100% Column[1]:Width:40%, nowrap, Column[2]:Width:25%, nowrap Column[3]:nowrap Column[4]:Width:25%, Style:text-align:right
Links
ROHTML Namespace, Legend, Members, ROHTMLTableFormats Fields

ROHTMLTableFormats.ROTF_LIST_1 Field

ROHTMLTableFormats.ROTF_LIST_1 Field
ROHTMLTableFormats Class ROHTML Namespace ROHTMLTableFormats Class

Columns:2, Style:list1

C#
public const short ROTF_LIST_1 = &H0001;
Class

ROHTMLTableFormats Class

Links
ROHTMLTableFormats Class, ROHTML Namespace, ROHTMLTableFormats Class

ROHTMLTableFormats.ROTF_LIST_2 Field

ROHTMLTableFormats.ROTF_LIST_2 Field
ROHTMLTableFormats Class ROHTML Namespace ROHTMLTableFormats Class

Columns:5, Width:100%, Style:list2 Column[1]:Width:8%, nowrap Column[2]:Width:8%, nowrap, Style:font-family:monospace;text-align:right; Column[3]:Width:10%, Style:text-align:center; Column[4]:Width:40% Column[5]:Style=text-align:right;

C#
public const short ROTF_LIST_2 = &H0002;
Class

ROHTMLTableFormats Class

Links
ROHTMLTableFormats Class, ROHTML Namespace, ROHTMLTableFormats Class

ROHTMLTableFormats.ROTF_LIST_3 Field

ROHTMLTableFormats.ROTF_LIST_3 Field
ROHTMLTableFormats Class ROHTML Namespace ROHTMLTableFormats Class

Columns:2, Width:100%, Style:list3 Column[2].style=text-align:right;

C#
public const short ROTF_LIST_3 = &H0003;
Class

ROHTMLTableFormats Class

Links
ROHTMLTableFormats Class, ROHTML Namespace, ROHTMLTableFormats Class

ROHTMLTableFormats.ROTF_LIST_4 Field

ROHTMLTableFormats.ROTF_LIST_4 Field
ROHTMLTableFormats Class ROHTML Namespace ROHTMLTableFormats Class

Columns:2, Style:list4 Column[1]:nowrap

C#
public const short ROTF_LIST_4 = &H0004;
Class

ROHTMLTableFormats Class

Links
ROHTMLTableFormats Class, ROHTML Namespace, ROHTMLTableFormats Class

ROHTMLTableFormats.ROTF_TABLE_1 Field

ROHTMLTableFormats.ROTF_TABLE_1 Field
ROHTMLTableFormats Class ROHTML Namespace ROHTMLTableFormats Class

Width:100%, Style:table1, Header rows and columns:1

C#
public const short ROTF_TABLE_1 = &H0201;
Class

ROHTMLTableFormats Class

Links
ROHTMLTableFormats Class, ROHTML Namespace, ROHTMLTableFormats Class

ROHTMLTableFormats.ROTF_TABLE_2 Field

ROHTMLTableFormats.ROTF_TABLE_2 Field
ROHTMLTableFormats Class ROHTML Namespace ROHTMLTableFormats Class

Width:100%, Style:table2, Header rows and columns:1

C#
public const short ROTF_TABLE_2 = &H0202;
Class

ROHTMLTableFormats Class

Links
ROHTMLTableFormats Class, ROHTML Namespace, ROHTMLTableFormats Class

ROHTMLTableFormats.ROTF_TABLE_3 Field

ROHTMLTableFormats.ROTF_TABLE_3 Field
ROHTMLTableFormats Class ROHTML Namespace ROHTMLTableFormats Class

Width:100%, Style:table3, Header rows and columns:1

C#
public const short ROTF_TABLE_3 = &H0203;
Class

ROHTMLTableFormats Class

Links
ROHTMLTableFormats Class, ROHTML Namespace, ROHTMLTableFormats Class

ROHTMLTableFormats.ROTF_VERIFY_1 Field

ROHTMLTableFormats.ROTF_VERIFY_1 Field
ROHTMLTableFormats Class ROHTML Namespace ROHTMLTableFormats Class

Columns:4, Width:100% Column[1]:Width:40%, nowrap, Column[2]:Width:25%, nowrap Column[3]:nowrap Column[4]:Width:25%, Style:text-align:right

C#
public const short ROTF_VERIFY_1 = &H0101;
Class

ROHTMLTableFormats Class

Links
ROHTMLTableFormats Class, ROHTML Namespace, ROHTMLTableFormats Class

XHTMLDocument Class

XHTMLDocument Class
ROHTML Namespace Legend Members XHTMLDocument Fields XHTMLDocument Methods

This is class ROHTML.XHTMLDocument.

Class Hierarchy
C#
public class XHTMLDocument;
Namespace

ROHTML Namespace

XHTMLDocument Fields
XHTMLDocument Fields | Description
Body | XHTMLElement that represents the body of the document.
CSSFile | String containing the CSS (Cascading Style Sheets) file path for the document.
Head | XHTMLElement that represents the header of the document.
Language | Short that indicates the language in which the document is written.
Name |
NumberedHeaders | Bool that indicates whether headers are numbered automatically by the document, e.g.
Status | ROHTMLMessages indicates the status of the document, it is used in note header and footer.
Version | String (read-only) that indicates the version of the component, e.g.
XHTMLDocument Methods
XHTMLDocument Methods | Description
IsVersion | Returns True if the version of the component is greater or equal to the given version, version should be formatted as follow: "MAJOR.MINOR.PATCH.COMPILATION", e.g.
Save | Saves the XHTML document to the specified location.
SaveAsSingleFile | Saves the document to the specified location as MS MHTML file.
Show | Launches Internet Explorer and navigates to the specified file.
ToString | Returns String containing the generated document.
Links
ROHTML Namespace, Legend, Members, XHTMLDocument Fields, XHTMLDocument Methods

XHTMLDocument.Body Field

XHTMLDocument.Body Field
XHTMLDocument Class ROHTML Namespace XHTMLDocument Class

XHTMLElement that represents the body of the document.

C#
public XHTMLElement Body;
Description
Class

XHTMLDocument Class

Links
XHTMLDocument Class, ROHTML Namespace, XHTMLDocument Class

XHTMLDocument.CSSFile Field

XHTMLDocument.CSSFile Field
XHTMLDocument Class ROHTML Namespace XHTMLDocument Class

String containing the CSS (Cascading Style Sheets) file path for the document.

C#
public string CSSFile;
Description

Default value is "rohtml.css". If the file name doesn't contain the full path, document tries to find the file in ROC directory (use InitSysPaths method to make it possible).

Class

XHTMLDocument Class

Links
XHTMLDocument Class, ROHTML Namespace, XHTMLDocument Class

XHTMLDocument.Head Field

XHTMLDocument.Head Field
XHTMLDocument Class ROHTML Namespace XHTMLDocument Class

XHTMLElement that represents the header of the document.

C#
public XHTMLElement Head;
Description
Class

XHTMLDocument Class

Links
XHTMLDocument Class, ROHTML Namespace, XHTMLDocument Class

XHTMLDocument.Language Field

XHTMLDocument.Language Field
XHTMLDocument Class ROHTML Namespace XHTMLDocument Class

Short that indicates the language in which the document is written.

C#
public short Language;
Description
Class

XHTMLDocument Class

Links
XHTMLDocument Class, ROHTML Namespace, XHTMLDocument Class

XHTMLDocument.Name Field

XHTMLDocument.Name Field
XHTMLDocument Class ROHTML Namespace XHTMLDocument Class
C#
public string Name;
Class

XHTMLDocument Class

Links
XHTMLDocument Class, ROHTML Namespace, XHTMLDocument Class

XHTMLDocument.NumberedHeaders Field

XHTMLDocument.NumberedHeaders Field
XHTMLDocument Class ROHTML Namespace XHTMLDocument Class

Bool that indicates whether headers are numbered automatically by the document, e.g.

C#
public bool NumberedHeaders;
Description

1.1.1. Header.

Class