Autodesk.Revit.DB.FilteredElementCollector collector = new FilteredElementCollector(ThisExtension.Revit.ActiveDocument);
List<Element> Sections = new List<Element>();
//Sections.
rvt.ContentMapper.DialogSettings.SectionSettings.Visible = true;
//-adding elements
foreach (FamilySymbol obj in collector.OfClass(typeof(FamilySymbol)).ToElements())
{
    if(((BuiltInCategory)obj.Category.Id.IntegerValue) == BuiltInCategory.OST_StructuralFraming)
        rvt.ContentMapper.DialogSettings.SectionSettings.Elements.Add(obj);
}
if (rvt.ContentMapper.DialogSettings.SectionSettings.Elements.Count > 1)
{
    rvt.ContentMapper.SetMapElement(true, (Element)rvt.ContentMapper.DialogSettings.SectionSettings.Elements[0], label1, ECategoryType.SECTION_DB);
    rvt.ContentMapper.SetMapElement(true, (Element)rvt.ContentMapper.DialogSettings.SectionSettings.Elements[1], label2, ECategoryType.SECTION_DB);
}
//-databases start list
rvt.ContentMapper.DialogSettings.SectionSettings.Databases.Add("Rcatpro");

//Materials.
rvt.ContentMapper.DialogSettings.MaterialSettings.Visible = false;

//Rebars.
rvt.ContentMapper.DialogSettings.RebarTypeSettings.Visible = false;

//Launching
Autodesk.REX.Common.REXContext cont = ThisExtension.Context;
bool ok = rvt.ContentMapper.LaunchMapDialog(ref cont);

if (ok)
{
        REXFamilyType sect = rvt.ContentMapper.GetMapElement(Sections[0],ECategoryType.SECTION_DB);
}

Example

Example
ContentMapper.CreateMapControl Method

The example shows how to customize and launch the map dialog.

//Revit converter.
RVTFamilyConverter rvt = new RVTFamilyConverter(ThisExtension.Revit.CommandData(), true);

Autodesk.Revit.DB.FilteredElementCollector collector = new FilteredElementCollector(ThisExtension.Revit.ActiveDocument);

List<Element> Sections = new List<Element>();

//General settings.
rvt.ContentMapper.DialogSettings.CheckIfAllMappedBeforeLeave = false;
rvt.ContentMapper.DialogSettings.Menu = false;
rvt.ContentMapper.DialogSettings.List = false;
rvt.ContentMapper.DialogSettings.ShowWhenNoElementsToMap = true;

//Sections.
rvt.ContentMapper.DialogSettings.SectionSettings.Visible = true;
//-adding elements
foreach (FamilySymbol obj in collector.OfClass(typeof(FamilySymbol)).ToElements())
{
    rvt.ContentMapper.DialogSettings.SectionSettings.Elements.Add(obj);
    Sections.Add(obj);
}
//-databases start list
rvt.ContentMapper.DialogSettings.SectionSettings.Databases.Add("Rcatpro");

//Launching.
Autodesk.REX.Common.REXContext cont = ThisExtension.Context;
object ctr = rvt.ContentMapper.CreateMapControl(ref cont);

Example

Example
ContentMapper.LaunchMapDialog Method

The example shows how to customize and launch the map dialog.

//Revit converter.
RVTFamilyConverter rvt = new RVTFamilyConverter(ThisExtension.Revit.CommandData(), true);

Autodesk.Revit.DB.FilteredElementCollector collector = new FilteredElementCollector(ThisExtension.Revit.ActiveDocument);

List<Element> Sections = new List<Element>();
List<Element> Rebars = new List<Element>();

//General settings.
rvt.ContentMapper.DialogSettings.CheckIfAllMappedBeforeLeave = true;
rvt.ContentMapper.DialogSettings.NotAllMappedText = "Not all elements are mapped";

//Sections.
rvt.ContentMapper.DialogSettings.SectionSettings.Visible = true;
//-adding elements
foreach (FamilySymbol obj in collector.OfClass(typeof(FamilySymbol)).ToElements())
{
    rvt.ContentMapper.DialogSettings.SectionSettings.Elements.Add(obj);
    Sections.Add(obj);
}
//-databases start list
rvt.ContentMapper.DialogSettings.SectionSettings.Databases.Add("Rcatpro");

//Materials.
rvt.ContentMapper.DialogSettings.MaterialSettings.Visible = false;

//Rebars.
rvt.ContentMapper.DialogSettings.RebarTypeSettings.Visible = true;
//-user won't be able to add databases
rvt.ContentMapper.DialogSettings.RebarTypeSettings.AllowToAddDatabases = false;
//-if there will be find the map element with some database assigned this database won't be loaded to Content dialog automatically
rvt.ContentMapper.DialogSettings.RebarTypeSettings.AddMappedDatabases = false;
//-adding elements
foreach (RebarBarType obj in collector.OfClass(typeof(RebarBarType)).ToElements())
{
     rvt.ContentMapper.DialogSettings.SectionSettings.Elements.Add(obj);
     Rebars.Add(obj);
}
//-database list
rvt.ContentMapper.DialogSettings.RebarTypeSettings.Databases.Add("bar_BAEL M");
//-available steels
rvt.ContentMapper.DialogSettings.RebarTypeSettings.SteelsAvailable.Add("HA 400");
//-if defaults should be set
rvt.ContentMapper.DialogSettings.RebarTypeSettings.SetDefaultsForUnknown = true;

//-if certified elements should be mapped
rvt.ContentMapper.DialogSettings.RebarTypeSettings.MapCertifiedFamilies = true;
//-setting default elements for rebartype
rvt.ContentMapper.SetDefaults(ThisExtension.Preferences.PreferencesBase2.RegionalSettings, ECategoryType.REBAR_BARTYPE);

//Launching.
Autodesk.REX.Common.REXContext cont = ThisExtension.Context;
bool ok = rvt.ContentMapper.LaunchMapDialog(ref cont);

if (ok)
{
    //Getting mapped element
    REXFamilyType sect = rvt.ContentMapper.GetMapElement(Sections[0],ECategoryType.SECTION_DB);
}

Legend

Legend
REXContentMapCategorySettings Class
Legend
Constructor
virtual
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXContentMapCategorySettings Class Members

REXContentMapCategorySettings Class Members
REXContentMapCategorySettings Class Legend
Members
Public Methods
Public Method | Description
REXContentMapCategorySettings | Initializes a new instance of the REXContentMapCategorySettings class.
REXContentMapCategorySettings Methods
REXContentMapCategorySettings Methods | Description
ContainsLabel | Determines whether the mapping system contains the specified label.
FilterFamilies | Filters the list of families.
FilterFamily | Filters the family object according settings.
REXContentMapCategorySettings Properties
REXContentMapCategorySettings Properties | Description
AddMappedDatabases | Gets or sets a value indicating whether databases saved in loaded files should be loaded to the system.
AllowToAddDatabases | Gets or sets a value indicating whether a user is able to add databases to the list.
Category | Gets the category.
Databases | Gets or sets the list of databases supported by this category.
DatabasesResult | Gets or sets the list of databases which were finally choosen by the user in the dialog.
Elements | Gets the list of elements which should be mapped.
LabelCategoryName | Gets or sets the name of the label category.
Labels | Gets the list of labels.
MapCertifiedFamilies | Gets or sets a value indicating whether certified families are mapped.
SetDefaultsForUnknown | Gets or sets a value indicating whether defaults are set for elements which weren't mapped.
Settings | Gets the settings of the dialog.
Visible | Gets or sets a value indicating whether this category is visible.

REXContentMapCategorySettings Methods

REXContentMapCategorySettings Methods
REXContentMapCategorySettings Class Legend
REXContentMapCategorySettings Methods
REXContentMapCategorySettings Methods | Description
ContainsLabel | Determines whether the mapping system contains the specified label.
FilterFamilies | Filters the list of families.
FilterFamily | Filters the family object according settings.

REXContentMapCategorySettings Properties

REXContentMapCategorySettings Properties
REXContentMapCategorySettings Class Legend
REXContentMapCategorySettings Properties
REXContentMapCategorySettings Properties | Description
AddMappedDatabases | Gets or sets a value indicating whether databases saved in loaded files should be loaded to the system.
AllowToAddDatabases | Gets or sets a value indicating whether a user is able to add databases to the list.
Category | Gets the category.
Databases | Gets or sets the list of databases supported by this category.