REXUnitEditBox Class, REX.Controls.WPF Namespace, REXUnitEditBox Class

REXUnitEditBox.SetDataBaseValue Method

REXUnitEditBox.SetDataBaseValue Method
REXUnitEditBox Class REX.Controls.WPF Namespace REXUnitEditBox Class

Set the value in base units.

C#
public void SetDataBaseValue(double value);
Parameters
Parameters | Description
value | The value.
Description
Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.WPF Namespace, REXUnitEditBox Class

REXUnitEditBox.SetDataInterfaceValue Method

REXUnitEditBox.SetDataInterfaceValue Method
REXUnitEditBox Class REX.Controls.WPF Namespace REXUnitEditBox Class

Set the value in interface units.

C#
public void SetDataInterfaceValue(double value, REXInterfaceType interfaceType);
Parameters
Parameters | Description
value | The value.
interfaceType | The product context.
Description
Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.WPF Namespace, REXUnitEditBox Class

REXUnitEditBox.SetInterfaceMaxValue Method

REXUnitEditBox.SetInterfaceMaxValue Method
REXUnitEditBox Class REX.Controls.WPF Namespace REXUnitEditBox Class

Set the maximum value defined in interface units.

C#
public void SetInterfaceMaxValue(double value, REXInterfaceType interfaceType);
Parameters
Parameters | Description
value | The value.
interfaceType | The product context.
Description
Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.WPF Namespace, REXUnitEditBox Class

REXUnitEditBox.SetInterfaceMinValue Method

REXUnitEditBox.SetInterfaceMinValue Method
REXUnitEditBox Class REX.Controls.WPF Namespace REXUnitEditBox Class

Set the minimum value defined in interface units.

C#
public void SetInterfaceMinValue(double value, REXInterfaceType interfaceType);
Parameters
Parameters | Description
value | The value.
interfaceType | The product context.
Description
Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.WPF Namespace, REXUnitEditBox Class

REXUnitEditBox.ComplexDoubleValueBase Property

REXUnitEditBox.ComplexDoubleValueBase Property
REXUnitEditBox Class REX.Controls.WPF Namespace REXUnitEditBox Class

Gets or sets the complex double value.

C#
public ObservableCollection<double> ComplexDoubleValueBase;
Description

The complex double value.

Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.WPF Namespace, REXUnitEditBox Class

REXUnitEditBox.DoubleValueBase Property

REXUnitEditBox.DoubleValueBase Property
REXUnitEditBox Class REX.Controls.WPF Namespace REXUnitEditBox Class

Gets or sets the double value.

C#
public double DoubleValueBase;
Description

The double value.

Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.WPF Namespace, REXUnitEditBox Class

REXUnitEditBox.Power Property

REXUnitEditBox.Power Property
REXUnitEditBox Class REX.Controls.WPF Namespace REXUnitEditBox Class

Gets or sets the power of the unit.

C#
public double Power;
Description

The power.

Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.WPF Namespace, REXUnitEditBox Class

REXUnitEditBox.UnitEngine Property

REXUnitEditBox.UnitEngine Property
REXUnitEditBox Class REX.Controls.WPF Namespace REXUnitEditBox Class

Gets or sets the unit engine.

C#
public Autodesk.REX.Framework.IREXUnits UnitEngine;
Description

The unit engine.

Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.WPF Namespace, REXUnitEditBox Class

REXUnitEditBox.UnitType Property

REXUnitEditBox.UnitType Property
REXUnitEditBox Class REX.Controls.WPF Namespace REXUnitEditBox Class

Gets or sets the type of the unit.

C#
public Autodesk.REX.Framework.EUnitType UnitType;
Description

The type of the unit.

Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.WPF Namespace, REXUnitEditBox Class

WPFCommon Class

WPFCommon Class
REX.Controls.WPF Namespace Legend Members WPFCommon Methods

This is class REX.Controls.WPF.WPFCommon.

Class Hierarchy
C#
public class WPFCommon;
Namespace

REX.Controls.WPF Namespace

WPFCommon Methods
WPFCommon Methods | Description
FindChild | Finds the child.
SetPropertyToAllElements | This is SetPropertyToAllElements, a member of class WPFCommon.
UpdateDoubleObserveCollection | This is UpdateDoubleObserveCollection, a member of class WPFCommon.
Links
REX.Controls.WPF Namespace, Legend, Members, WPFCommon Methods

WPFCommon.FindChild Method

WPFCommon.FindChild Method
WPFCommon Class REX.Controls.WPF Namespace WPFCommon Class

Finds the child.

C#
public static T FindChild<T>(DependencyObject parent, string childName) where T : DependencyObject;
Parameters
Parameters | Description
parent | The parent.
childName | Name of the child.
Type Parameters
Type Parameters | Description
T |
Description
Class

WPFCommon Class

Links
WPFCommon Class, REX.Controls.WPF Namespace, WPFCommon Class

WPFCommon.SetPropertyToAllElements Method

WPFCommon.SetPropertyToAllElements Method
WPFCommon Class REX.Controls.WPF Namespace WPFCommon Class

This is SetPropertyToAllElements, a member of class WPFCommon.

C#
public static void SetPropertyToAllElements(DependencyObject parent, DependencyProperty property, object value);
Class

WPFCommon Class

Links
WPFCommon Class, REX.Controls.WPF Namespace, WPFCommon Class

WPFCommon.UpdateDoubleObserveCollection Method

WPFCommon.UpdateDoubleObserveCollection Method
WPFCommon Class REX.Controls.WPF Namespace WPFCommon Class

This is UpdateDoubleObserveCollection, a member of class WPFCommon.

C#
public static void UpdateDoubleObserveCollection(List<double> values, System.Collections.ObjectModel.ObservableCollection<double> obsColl);
Class

WPFCommon Class

Links
WPFCommon Class, REX.Controls.WPF Namespace, WPFCommon Class

ROHTML Namespace

Previous | Next
ROHTML Namespace
Legend Classes

This is namespace ROHTML.

Classes
Class | Description
ROHTMLMessages | This is class ROHTML.ROHTMLMessages.
ROHTMLStdImages | This is class ROHTML.ROHTMLStdImages.
ROHTMLTableFormats | This is class ROHTML.ROHTMLTableFormats.
XHTMLDocument | This is class ROHTML.XHTMLDocument.
XHTMLElement | This is class ROHTML.XHTMLElement.
XHTMLTable | This is class ROHTML.XHTMLTable.
Links
Legend, Classes
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

ROHTMLMessages Class

ROHTMLMessages Class
ROHTML Namespace Legend Members ROHTMLMessages Fields

This is class ROHTML.ROHTMLMessages.

Class Hierarchy
C#
public class ROHTMLMessages;
Namespace

ROHTML Namespace

ROHTMLMessages Fields
ROHTMLMessages Fields | Description
ROTF_MSG_ERROR | Error
ROTF_MSG_OK | Verified
Links
ROHTML Namespace, Legend, Members, ROHTMLMessages Fields

ROHTMLMessages.ROTF_MSG_ERROR Field

ROHTMLMessages.ROTF_MSG_ERROR Field
ROHTMLMessages Class ROHTML Namespace ROHTMLMessages Class

Error

C#
public const short ROTF_MSG_ERROR = &H0002;
Class

ROHTMLMessages Class

Links
ROHTMLMessages Class, ROHTML Namespace, ROHTMLMessages Class

ROHTMLMessages.ROTF_MSG_OK Field

ROHTMLMessages.ROTF_MSG_OK Field
ROHTMLMessages Class ROHTML Namespace ROHTMLMessages Class

Verified

C#
public const short ROTF_MSG_OK = &H0001;
Class

ROHTMLMessages Class

Links
ROHTMLMessages Class, ROHTML Namespace, ROHTMLMessages Class

ROHTMLStdImages Class

ROHTMLStdImages Class
ROHTML Namespace Legend Members ROHTMLStdImages Fields

This is class ROHTML.ROHTMLStdImages.

Class Hierarchy
C#
public class ROHTMLStdImages;
Namespace

ROHTML Namespace

ROHTMLStdImages Fields
ROHTMLStdImages Fields | Description
ROSTD_TABLET_ERR | Image error
ROSTD_TABLET_OK | Image verified
Links
ROHTML Namespace, Legend, Members, ROHTMLStdImages Fields

ROHTMLStdImages.ROSTD_TABLET_ERR Field

ROHTMLStdImages.ROSTD_TABLET_ERR Field
ROHTMLStdImages Class ROHTML Namespace ROHTMLStdImages Class

Image error

C#
public const short ROSTD_TABLET_ERR = &H0002;
Class

ROHTMLStdImages Class

Links