REXSectionParamDescription | Initializes a new instance of the REXSectionParamDescription class.
REXSectionParamDescription Methods
REXSectionParamDescription Methods | Description
CalculataMainAxisAndCharacteristics | Calculatas the main axis and characteristics of the section.
CalculateCharacteristics | Calculates characteristics of the section.
CalculateMainAxisParams | Calculates the main axis of the section.
Clone | Creates a new object that is a copy of the current instance.
CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
GetContour | Gets the contour.
GetMaterialDependence | Gets the material dependence.
REXSectionParamDescription Properties
REXSectionParamDescription Properties | Description
Angle | Gets or sets the angle of the section.
Characteristics | Gets or sets the characteristics.
CharacteristicsEnd | Gets or sets the characteristics of the end.
Contour | Gets or sets the contour.
Dimensions | Gets or sets the dimensions.
DimensionsEnd | Gets or sets the dimensions of the end.
IsTurned | Gets or sets a value indicating whether this instance is turned.
SectionType | Gets or sets the type of the section.
Tapered | Gets or sets a value indicating whether this REXSectionParamDescription is tapered.
Links
REX.ContentGenerator.Families Namespace, Legend, Members, Public Methods, REXSectionParamDescription Methods, REXSectionParamDescription Properties

REXSectionParamDescription.REXSectionParamDescription Constructor ()

REXSectionParamDescription.REXSectionParamDescription Constructor ()
REXSectionParamDescription Class REX.ContentGenerator.Families Namespace REXSectionParamDescription Class

Initializes a new instance of the REXSectionParamDescription class.

C#
public REXSectionParamDescription();
Description
Class

REXSectionParamDescription Class

Links
REXSectionParamDescription Class, REX.ContentGenerator.Families Namespace, REXSectionParamDescription Class

REXSectionParamDescription.REXSectionParamDescription Constructor (REXSectionParamDescription)

REXSectionParamDescription.REXSectionParamDescription Constructor (REXSectionParamDescription)
REXSectionParamDescription Class REX.ContentGenerator.Families Namespace REXSectionParamDescription Class

Initializes a new instance of the REXSectionParamDescription class.

C#
public REXSectionParamDescription(REXSectionParamDescription pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

REXSectionParamDescription Class

Links
REXSectionParamDescription Class, REX.ContentGenerator.Families Namespace, REXSectionParamDescription Class

REXSectionParamDescription.REXSectionParamDescription Constructor (REXSectionParams, EMaterial, REX.ContentGenerator.Families.EElementType)

REXSectionParamDescription.REXSectionParamDescription Constructor (REXSectionParams, EMaterial, REX.ContentGenerator.Families.EElementType)
REXSectionParamDescription Class REX.ContentGenerator.Families Namespace REXSectionParamDescription Class

Initializes a new instance of the REXSectionParamDescription class.

C#
public REXSectionParamDescription(REXSectionParams par, EMaterial mat, REX.ContentGenerator.Families.EElementType elemcat);
Parameters
Parameters | Description
par | The section parameters.
mat | The material.
elemcat | The type of the element.
Description
Class

REXSectionParamDescription Class

Links
REXSectionParamDescription Class, REX.ContentGenerator.Families Namespace, REXSectionParamDescription Class

REXSectionParamDescription.REXSectionParamDescription Constructor (bool)

REXSectionParamDescription.REXSectionParamDescription Constructor (bool)
REXSectionParamDescription Class REX.ContentGenerator.Families Namespace REXSectionParamDescription Class

Initializes a new instance of the REXSectionParamDescription class.

C#
public REXSectionParamDescription(bool tapered);
Parameters
Parameters | Description
tapered | Indicates whether the section is tapered.
Description
Class

REXSectionParamDescription Class

Links
REXSectionParamDescription Class, REX.ContentGenerator.Families Namespace, REXSectionParamDescription Class

REXSectionParamDescription.CalculataMainAxisAndCharacteristics Method

REXSectionParamDescription.CalculataMainAxisAndCharacteristics Method
REXSectionParamDescription Class REX.ContentGenerator.Families Namespace REXSectionParamDescription Class

Calculatas the main axis and characteristics of the section.

C#
public void CalculataMainAxisAndCharacteristics();
Description
Class

REXSectionParamDescription Class

Links
REXSectionParamDescription Class, REX.ContentGenerator.Families Namespace, REXSectionParamDescription Class

REXSectionParamDescription.CalculateCharacteristics Method

REXSectionParamDescription.CalculateCharacteristics Method
REXSectionParamDescription Class REX.ContentGenerator.Families Namespace REXSectionParamDescription Class

Calculates characteristics of the section.

C#
public void CalculateCharacteristics();
Description
Class

REXSectionParamDescription Class

Links
REXSectionParamDescription Class, REX.ContentGenerator.Families Namespace, REXSectionParamDescription Class

REXSectionParamDescription.CalculateMainAxisParams Method

REXSectionParamDescription.CalculateMainAxisParams Method
REXSectionParamDescription Class REX.ContentGenerator.Families Namespace REXSectionParamDescription Class

Calculates the main axis of the section.

C#
public void CalculateMainAxisParams();
Description
Class

REXSectionParamDescription Class

Links
REXSectionParamDescription Class, REX.ContentGenerator.Families Namespace, REXSectionParamDescription Class

REXSectionParamDescription.Clone Method

REXSectionParamDescription.Clone Method
REXSectionParamDescription Class REX.ContentGenerator.Families Namespace REXSectionParamDescription Class

Creates a new object that is a copy of the current instance.

C#
public override object Clone();
Returns

A new object that is a copy of this instance.

Description
Class

REXSectionParamDescription Class

Links
REXSectionParamDescription Class, REX.ContentGenerator.Families Namespace, REXSectionParamDescription Class

REXSectionParamDescription.CompareTo Method

REXSectionParamDescription.CompareTo Method
REXSectionParamDescription Class REX.ContentGenerator.Families Namespace REXSectionParamDescription Class

Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.

C#
public override int CompareTo(object obj);
Parameters
Parameters | Description
obj | An object to compare with this instance.
Returns

Returns a result of the comparison.

Description
Class

REXSectionParamDescription Class

Links
REXSectionParamDescription Class, REX.ContentGenerator.Families Namespace, REXSectionParamDescription Class

REXSectionParamDescription.GetContour Method

REXSectionParamDescription.GetContour Method
REXSectionParamDescription Class REX.ContentGenerator.Families Namespace REXSectionParamDescription Class

Gets the contour.

C#
public REX.ContentGenerator.Geometry.Contour_Section GetContour(bool start);
Parameters
Parameters | Description
start | If of the start.
Description
Class

REXSectionParamDescription Class

Links
REXSectionParamDescription Class, REX.ContentGenerator.Families Namespace, REXSectionParamDescription Class

REXSectionParamDescription.GetMaterialDependence Method

REXSectionParamDescription.GetMaterialDependence Method
REXSectionParamDescription Class REX.ContentGenerator.Families Namespace REXSectionParamDescription Class

Gets the material dependence.

C#
public bool GetMaterialDependence(EMaterial mat, REX.ContentGenerator.Families.EElementType type);
Parameters
Parameters | Description
mat | The material.
type | The type.
Returns