public System.Windows.Controls.WebBrowser WB;
Description
Class

REXWebBrowser Class

Links
REXWebBrowser Class, REX.Common Namespace, REXWebBrowser Class

REXWebBrowser.Start Method

REXWebBrowser.Start Method
REXWebBrowser Class REX.Common Namespace REXWebBrowser Class

Starts thread and loads html page on thread.

C#
public void Start();
Description
Class

REXWebBrowser Class

Links
REXWebBrowser Class, REX.Common Namespace, REXWebBrowser Class

REXWebBrowser.StartThread Method

REXWebBrowser.StartThread Method
REXWebBrowser Class REX.Common Namespace REXWebBrowser Class

Starts the thread.

C#
public void StartThread();
Description
Class

REXWebBrowser Class

Links
REXWebBrowser Class, REX.Common Namespace, REXWebBrowser Class

IREXConnector Interface

IREXConnector Interface
REX.Common Namespace Legend Members IREXConnector Methods IREXConnector Properties

This is class REX.Common.IREXConnector.

Class Hierarchy
C#
public interface IREXConnector;
Namespace

REX.Common Namespace

IREXConnector Methods
IREXConnector Methods | Description
Connect | This is Connect, a member of class IREXConnector.
VerifyVersion | This is VerifyVersion, a member of class IREXConnector.
VerifyVersion | This is VerifyVersion, a member of class IREXConnector.
IREXConnector Properties
IREXConnector Properties | Description
Connected | This is Connected, a member of class IREXConnector.
Installed | This is Installed, a member of class IREXConnector.
IsCOMObject | This is IsCOMObject, a member of class IREXConnector.
Links
REX.Common Namespace, Legend, Members, IREXConnector Methods, IREXConnector Properties

IREXConnector.Connect Method

IREXConnector.Connect Method
IREXConnector Interface REX.Common Namespace IREXConnector Interface

This is Connect, a member of class IREXConnector.

C#
bool Connect();
Interface

IREXConnector Interface

Links
IREXConnector Interface, REX.Common Namespace, IREXConnector Interface

IREXConnector.VerifyVersion Method (string)

IREXConnector.VerifyVersion Method (string)
IREXConnector Interface REX.Common Namespace IREXConnector Interface

This is VerifyVersion, a member of class IREXConnector.

C#
bool VerifyVersion(ref string Version);
Interface

IREXConnector Interface

Links
IREXConnector Interface, REX.Common Namespace, IREXConnector Interface

IREXConnector.VerifyVersion Method (string, System.Collections.Generic.List<string>)

IREXConnector.VerifyVersion Method (string, System.Collections.Generic.List<string>)
IREXConnector Interface REX.Common Namespace IREXConnector Interface

This is VerifyVersion, a member of class IREXConnector.

C#
bool VerifyVersion(ref string Version, System.Collections.Generic.List<string> Versions);
Interface

IREXConnector Interface

Links
IREXConnector Interface, REX.Common Namespace, IREXConnector Interface

IREXConnector.Connected Property

IREXConnector.Connected Property
IREXConnector Interface REX.Common Namespace IREXConnector Interface

This is Connected, a member of class IREXConnector.

C#
bool Connected;
Interface

IREXConnector Interface

Links
IREXConnector Interface, REX.Common Namespace, IREXConnector Interface

IREXConnector.Installed Property

IREXConnector.Installed Property
IREXConnector Interface REX.Common Namespace IREXConnector Interface

This is Installed, a member of class IREXConnector.

C#
bool Installed;
Interface

IREXConnector Interface

Links
IREXConnector Interface, REX.Common Namespace, IREXConnector Interface

IREXConnector.IsCOMObject Property

IREXConnector.IsCOMObject Property
IREXConnector Interface REX.Common Namespace IREXConnector Interface

This is IsCOMObject, a member of class IREXConnector.

C#
bool IsCOMObject;
Interface

IREXConnector Interface

Links
IREXConnector Interface, REX.Common Namespace, IREXConnector Interface

IREXExtension Interface

IREXExtension Interface
REX.Common Namespace Legend Members IREXExtension Methods

Main interface for extension module.

Class Hierarchy
C#
public interface IREXExtension;
Description
Namespace

REX.Common Namespace

IREXExtension Methods
IREXExtension Methods | Description
OnActivateLayout | Activates or deactivates layout - module can modify layout before or after activation.
OnCanClose | If returns true, dialog will close after OK button clicked.
OnCanClose | Called when closing module.
OnCanRun | Checks status of module and shows some information for user if modult can't run action.
OnClear | Called when clear data.
OnClose | Called during closing module.
OnCommand | Called when command.
OnCreate | Creates needed structures and verify needs.
OnCreateDialogs | Creates sub dialogs.
OnCreateLayout | Creates layout items and setups layout.
OnDataLoad | Called when data are loaded.
OnDataLoaded | Called when data are loaded.
OnDataSave | Called when data are saved.
OnDataSaved | Called when data are saved.
OnErrorSelected | Called when error selected on errors list dialog.
OnEvent | Called when event.
OnGetText | Get specified text from resources.
OnInitialize | Called when initialize.
OnLoadTemplate | Called when load template.
OnPreferencesChanged | Called when preferences changed.
OnRun | Run process calculations or other operations.
OnSaveTemplate | Called when save template.
OnSetData | Get data from dialogs and sets Data's strucutres.
OnSetDialogs | Set data in dialogs.
OnShowResults | Shows results.
OnUpdateDialogs | Called when update dialogs.
Links
REX.Common Namespace, Legend, Members, IREXExtension Methods

IREXExtension.OnActivateLayout Method

IREXExtension.OnActivateLayout Method
IREXExtension Interface REX.Common Namespace IREXExtension Interface

Activates or deactivates layout - module can modify layout before or after activation.

C#
void OnActivateLayout(REXLayoutItem LItem, bool Activate);
Parameters
Parameters | Description
LItem | The layout item.
Activate | If set to true, layout is activated.
Description
Interface

IREXExtension Interface

Links
IREXExtension Interface, REX.Common Namespace, IREXExtension Interface

IREXExtension.OnCanClose Method ()

IREXExtension.OnCanClose Method ()
IREXExtension Interface REX.Common Namespace IREXExtension Interface

If returns true, dialog will close after OK button clicked.

C#
bool OnCanClose();
Returns

Returns true if module can be closed.

Description
Interface

IREXExtension Interface

Links
IREXExtension Interface, REX.Common Namespace, IREXExtension Interface

IREXExtension.OnCanClose Method (REXCanCloseType)

IREXExtension.OnCanClose Method (REXCanCloseType)
IREXExtension Interface REX.Common Namespace IREXExtension Interface

Called when closing module.

C#
bool OnCanClose(REXCanCloseType Type);
Parameters
Parameters | Description
Type | The closing type. See REXCanCloseType enum.
Returns

Returns true if module can be closed.

Description
Interface

IREXExtension Interface

Links
IREXExtension Interface, REX.Common Namespace, IREXExtension Interface

IREXExtension.OnCanRun Method

IREXExtension.OnCanRun Method
IREXExtension Interface REX.Common Namespace IREXExtension Interface

Checks status of module and shows some information for user if modult can't run action.

C#
bool OnCanRun();
Returns

Returns true if module can do some action in OnRun method; otherwise false.

Description
Interface

IREXExtension Interface

Links
IREXExtension Interface, REX.Common Namespace, IREXExtension Interface

IREXExtension.OnClear Method

IREXExtension.OnClear Method
IREXExtension Interface REX.Common Namespace IREXExtension Interface

Called when clear data.

C#
bool OnClear(out bool Implemented);
Parameters
Parameters | Description
Implemented | If returns true method was implemented.
Returns

Returns result of clear operation.

Description
Interface

IREXExtension Interface

Links
IREXExtension Interface, REX.Common Namespace, IREXExtension Interface

IREXExtension.OnClose Method

IREXExtension.OnClose Method
IREXExtension Interface REX.Common Namespace IREXExtension Interface

Called during closing module.

C#
void OnClose();
Description