IREXExtensionAccessUnitsControl.Setup Method

IREXExtensionAccessUnitsControl.Setup Method
IREXExtensionAccessUnitsControl Interface REX.Common Namespace IREXExtensionAccessUnitsControl Interface

Setups this instance.

C#
bool Setup();
Description
Interface

IREXExtensionAccessUnitsControl Interface

Links
IREXExtensionAccessUnitsControl Interface, REX.Common Namespace, IREXExtensionAccessUnitsControl Interface

IREXExtensionAccessUnitsControl.Update Method

IREXExtensionAccessUnitsControl.Update Method
IREXExtensionAccessUnitsControl Interface REX.Common Namespace IREXExtensionAccessUnitsControl Interface

Updates this instance.

C#
void Update();
Description
Interface

IREXExtensionAccessUnitsControl Interface

Links
IREXExtensionAccessUnitsControl Interface, REX.Common Namespace, IREXExtensionAccessUnitsControl Interface

IREXThisExtension Interface

IREXThisExtension Interface
REX.Common Namespace Legend Members IREXThisExtension Properties

Base interface for access to main extension's objects.

Class Hierarchy
C#
public interface IREXThisExtension;
Description
Namespace

REX.Common Namespace

IREXThisExtension Properties
IREXThisExtension Properties | Description
ThisApplication | This is ThisApplication, a member of class IREXThisExtension.
ThisContext | This is ThisContext, a member of class IREXThisExtension.
ThisExtension | This is ThisExtension, a member of class IREXThisExtension.
Links
REX.Common Namespace, Legend, Members, IREXThisExtension Properties

IREXThisExtension.ThisApplication Property

IREXThisExtension.ThisApplication Property
IREXThisExtension Interface REX.Common Namespace IREXThisExtension Interface

This is ThisApplication, a member of class IREXThisExtension.

C#
REXApplication ThisApplication;
Interface

IREXThisExtension Interface

Links
IREXThisExtension Interface, REX.Common Namespace, IREXThisExtension Interface

IREXThisExtension.ThisContext Property

IREXThisExtension.ThisContext Property
IREXThisExtension Interface REX.Common Namespace IREXThisExtension Interface

This is ThisContext, a member of class IREXThisExtension.

C#
REXContext ThisContext;
Interface

IREXThisExtension Interface

Links
IREXThisExtension Interface, REX.Common Namespace, IREXThisExtension Interface

IREXThisExtension.ThisExtension Property

IREXThisExtension.ThisExtension Property
IREXThisExtension Interface REX.Common Namespace IREXThisExtension Interface

This is ThisExtension, a member of class IREXThisExtension.

C#
REXExtension ThisExtension;
Interface

IREXThisExtension Interface

Links
IREXThisExtension Interface, REX.Common Namespace, IREXThisExtension Interface

REX.Common.REXCanCloseType Enumeration

REX.Common.REXCanCloseType Enumeration
REX.Common Namespace

Determines closing mode.

C#
public enum REXCanCloseType {
  Close,
  OK,
  Check
}
Members
Members | Description
Close | User selected Cancel button or closed the module.
OK | User selected OK button.
Check | OnCanClose method called for check if it is possible to close the module.
Description
Namespace

REX.Common Namespace

Links
REX.Common Namespace
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REX.Common.REXSetFormStruct Structure

REX.Common.REXSetFormStruct Structure
REX.Common Namespace

This is record REX.Common.REXSetFormStruct.

C#
public struct REXSetFormStruct {
  public Size AllControlsSize;
  public Size BottomAllControlsSize;
  public long Options;
}
Namespace

REX.Common Namespace

Links
REX.Common Namespace
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REX.Common.Revit.Units Namespace

Previous | Next
REX.Common.Revit.Units Namespace
Legend Classes

This is namespace REX.Common.Revit.Units.

Classes
Class | Description
REXUnitsControl | Display units management class for Revit context.
Links
Legend, Classes
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXUnitsControl Class

REXUnitsControl Class
REX.Common.Revit.Units Namespace Legend Members Public Methods REXUnitsControl Methods

Display units management class for Revit context.

Class Hierarchy
C#
public class REXUnitsControl : REXExtensionObject;
Description

The class is automatically used by base SDK classes for mapping units of parent program. Called from REXRCADAccess class. Used only by extensions launched from Revit.

Namespace

REX.Common.Revit.Units Namespace

Public Methods
Public Method | Description
REXUnitsControl | Initializes a new instance of the REXUnitsControl class.
REXUnitsControl Methods
REXUnitsControl Methods | Description
Setup | Setups display units.
Update | Updates display units.
Links
REX.Common.Revit.Units Namespace, Legend, Members, Public Methods, REXUnitsControl Methods

REXUnitsControl.REXUnitsControl Constructor

REXUnitsControl.REXUnitsControl Constructor
REXUnitsControl Class REX.Common.Revit.Units Namespace REXUnitsControl Class

Initializes a new instance of the REXUnitsControl class.

C#
public REXUnitsControl(REXExtension Ext);
Parameters
Parameters | Description
Ext | The reference to REXExtension class.
Description
Class

REXUnitsControl Class

Links
REXUnitsControl Class, REX.Common.Revit.Units Namespace, REXUnitsControl Class

REXUnitsControl.Setup Method

REXUnitsControl.Setup Method
REXUnitsControl Class REX.Common.Revit.Units Namespace REXUnitsControl Class

Setups display units.

C#
public bool Setup();
Returns

Returns true if succesfull.

Description
Class

REXUnitsControl Class

Links
REXUnitsControl Class, REX.Common.Revit.Units Namespace, REXUnitsControl Class

REXUnitsControl.Update Method

REXUnitsControl.Update Method
REXUnitsControl Class REX.Common.Revit.Units Namespace REXUnitsControl Class See Also

Updates display units.

C#
public void Update();
Description
See Also

Setup()

Class

REXUnitsControl Class

Links
REXUnitsControl Class, REX.Common.Revit.Units Namespace, REXUnitsControl Class, See Also

REX.ContentGenerator.Converters Namespace

Previous | Next
REX.ContentGenerator.Converters Namespace
Legend Classes Interfaces Structs, Records, Enums Types

This is namespace REX.ContentGenerator.Converters.

Classes
Class | Description
FieldParams | Represents parameters of the field.
REXContentFilter | Base class for all filters.
REXContentLogicFilter | Describes a logic filter.
REXContentParamFilter | Describes the filter for the specified parameter.
REXCustomFactory | This is class REX.ContentGenerator.Converters.REXCustomFactory.
REXDBSectionFactory | This is class REX.ContentGenerator.Converters.REXDBSectionFactory.
REXFamilyConverter | This class represents a converter which provides access to common databases.
REXMaterialFactory | This is class REX.ContentGenerator.Converters.REXMaterialFactory.
REXParamSectionFactory | This is class REX.ContentGenerator.Converters.REXParamSectionFactory.
RVTCommonSectionFactory | This is class REX.ContentGenerator.Converters.RVTCommonSectionFactory.
RVTCustomFactory | This is class REX.ContentGenerator.Converters.RVTCustomFactory.
RVTDBSectionFactory | This is class REX.ContentGenerator.Converters.RVTDBSectionFactory.
RVTFamilyConverter | This class represents a converter which provides access to Revit project.
RVTMaterialFactory | This is class REX.ContentGenerator.Converters.RVTMaterialFactory.
RVTMaterialPropertySetFactory | This is class REX.ContentGenerator.Converters.RVTMaterialPropertySetFactory.
RVTSectionFactory | This is class REX.ContentGenerator.Converters.RVTSectionFactory.