DataType | Determines the data type.
OperationStatus | Determines the status after operation.
REXExtensionData Methods
REXExtensionData Methods | Description
CompareData | Compares the data with another data.
CompareData | Compares the data with another data.
Load | Loads data strucuture from a BinaryReader object.
LoadHeader | Loads data strucuture from a BinaryReader object.
LoadHeader | Loads data strucuture from a BinaryReader object.
LoadHeader | This is LoadHeader, a member of class REXExtensionData.
Save | Saves data structure to a BinaryWriter object.
SaveHeader | Saves data structure to a BinaryWriter object.
SaveHeader | This is SaveHeader, a member of class REXExtensionData.
SetDefaults | Sets the defaults.
REXExtensionData Properties
REXExtensionData Properties | Description
DateTimeData | Get the date and time of data which load.
DateTimeDataCreation | Get the creation date and time of data which load.
EnableDynamicUpdate | This is EnableDynamicUpdate, a member of class REXExtensionData.
LoadedRegionalSettings | This is LoadedRegionalSettings, a member of class REXExtensionData.
Mode | Get or set the mode.
NoHeader | This is NoHeader, a member of class REXExtensionData.
ProductType | Loaded product type
RunContext | Loaded run context
StandardRunContext | Loaded standard run context
Status | Get or set the status.
Version | Get the current version.
VersionData | Get the version data which load.
Links
REX.Common Namespace, Legend, Members, Public Methods, REXExtensionData Enumerations, REXExtensionData Methods, REXExtensionData Properties

REXExtensionData.REXExtensionData Constructor

REXExtensionData.REXExtensionData Constructor
REXExtensionData Class REX.Common Namespace REXExtensionData Class

Initializes a new instance of the REXExtensionData class.

C#
public REXExtensionData(REXExtension Ext);
Parameters
Parameters | Description
Ext | The reference to a REXExtension object.
Description
Class

REXExtensionData Class

Links
REXExtensionData Class, REX.Common Namespace, REXExtensionData Class

REX.Common.REXExtensionData.DataMode Enumeration

REX.Common.REXExtensionData.DataMode Enumeration
REXExtensionData Class

Determines the target of serialization.

C#
public enum DataMode {
  ModeNone,
  ModeFile,
  ModeObject,
  ModeProject,
  ModeJournaling
}
Members
Members | Description
ModeNone | Unknown target.
ModeFile | Serialization to file.
ModeObject | Serialization to object.
ModeProject | Serialization to project.
ModeJournaling | Serialization to journaling.
Description
Class

REXExtensionData Class

Links
REXExtensionData Class
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REX.Common.REXExtensionData.DataType Enumeration

REX.Common.REXExtensionData.DataType Enumeration
REXExtensionData Class

Determines the data type.

C#
public enum DataType {
  Data,
  Results
}
Members
Members | Description
Data | Data.
Results | Results.
Description
Class

REXExtensionData Class

Links
REXExtensionData Class
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REX.Common.REXExtensionData.OperationStatus Enumeration

REX.Common.REXExtensionData.OperationStatus Enumeration
REXExtensionData Class

Determines the status after operation.

C#
public enum OperationStatus {
  OperationStatusOK,
  OperationStatusError,
  OperationStatusErrorData,
  OperationStatusBadExtension,
  OperationStatusNewExtension,
  OperationStatusDiffrentGeometry,
  OperationStatusDiffrentParams
}
Members
Members | Description
OperationStatusOK | All is ok.
OperationStatusError | Unknown error during operation.
OperationStatusErrorData | Unknown error during operation on data structures.
OperationStatusBadExtension | Trying to load data from another module.
OperationStatusNewExtension | Trying to load data from a newer module.
OperationStatusDiffrentGeometry | Geometry of element is diffrent (multiselection).
OperationStatusDiffrentParams | Parameters of element are diffrent (multiselection).
Description
Class

REXExtensionData Class

Links
REXExtensionData Class
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXExtensionData.CompareData Method (REXExtensionData)

REXExtensionData.CompareData Method (REXExtensionData)
REXExtensionData Class REX.Common Namespace REXExtensionData Class

Compares the data with another data.

C#
public int CompareData(REXExtensionData Data);
Parameters
Parameters | Description
Data | The data to compare.
Returns

Returns -1 if specified Data is older, 0 if equal, and 1 if specified Data is newer.

Description

Uses version and date time marker.

Class

REXExtensionData Class

Links
REXExtensionData Class, REX.Common Namespace, REXExtensionData Class

REXExtensionData.CompareData Method (REXExtensionData, bool)

REXExtensionData.CompareData Method (REXExtensionData, bool)
REXExtensionData Class REX.Common Namespace REXExtensionData Class

Compares the data with another data.

C#
public int CompareData(REXExtensionData Data, bool CompareOnlyDateTime);
Parameters
Parameters | Description
Data | The data to compare.
CompareOnlyDateTime | if set to true compare only date time.
Returns

Returns -1 if specified Data is older, 0 if equal, and 1 if specified Data is newer.

Description

Uses version and date time marker optionally.

Class

REXExtensionData Class

Links
REXExtensionData Class, REX.Common Namespace, REXExtensionData Class

REXExtensionData.Load Method

REXExtensionData.Load Method
REXExtensionData Class REX.Common Namespace REXExtensionData Class

Loads data strucuture from a BinaryReader object.

C#
public bool Load(ref BinaryReader Data, DataMode DataModeSet);
Parameters
Parameters | Description
Data | The data.
DataModeSet | The data mode set.
Returns

Returns true if succeeded.

Description
Class

REXExtensionData Class

Links
REXExtensionData Class, REX.Common Namespace, REXExtensionData Class

REXExtensionData.LoadHeader Method (BinaryReader, DataMode)

REXExtensionData.LoadHeader Method (BinaryReader, DataMode)
REXExtensionData Class REX.Common Namespace REXExtensionData Class

Loads data strucuture from a BinaryReader object.

C#
public bool LoadHeader(ref BinaryReader Data, DataMode DataModeSet);
Parameters
Parameters | Description
Data | The data.
DataModeSet | The data mode set.
Returns

Returns true if succeeded.

Description
Class

REXExtensionData Class

Links
REXExtensionData Class, REX.Common Namespace, REXExtensionData Class

REXExtensionData.LoadHeader Method (BinaryReader, DataMode, bool)

REXExtensionData.LoadHeader Method (BinaryReader, DataMode, bool)
REXExtensionData Class REX.Common Namespace REXExtensionData Class

Loads data strucuture from a BinaryReader object.

C#
public bool LoadHeader(ref BinaryReader Data, DataMode DataModeSet, bool CheckExtensionsModuleData);
Parameters
Parameters | Description
Data | The data.
DataModeSet | The data mode set.
Returns

Returns true if succeeded.

Description
Class

REXExtensionData Class

Links
REXExtensionData Class, REX.Common Namespace, REXExtensionData Class

REXExtensionData.LoadHeader Method (REXStorageExtensionHeader)

REXExtensionData.LoadHeader Method (REXStorageExtensionHeader)
REXExtensionData Class REX.Common Namespace REXExtensionData Class

This is LoadHeader, a member of class REXExtensionData.

C#
public void LoadHeader(REXStorageExtensionHeader header);
Class

REXExtensionData Class

Links
REXExtensionData Class, REX.Common Namespace, REXExtensionData Class

REXExtensionData.Save Method

REXExtensionData.Save Method