Base class for all custom description types.

Class Hierarchy
C#
[Serializable()]
public abstract class REXCustomDescription : REXDBDescription;
Description
Namespace

REX.ContentGenerator.Families Namespace

Public Methods
Public Method | Description
REXCustomDescription | Initializes a new instance of the REXCustomDescription class.
REXCustomDescription | Initializes a new instance of the REXCustomDescription class.
REXCustomDescription Methods
REXCustomDescription Methods | Description
Clone | Clones this instance.
GetTypeName | Gets the name of the type.
Links
REX.ContentGenerator.Families Namespace, Legend, Members, Public Methods, REXCustomDescription Methods

REXCustomDescription.REXCustomDescription Constructor ()

REXCustomDescription.REXCustomDescription Constructor ()
REXCustomDescription Class REX.ContentGenerator.Families Namespace REXCustomDescription Class

Initializes a new instance of the REXCustomDescription class.

C#
public REXCustomDescription();
Description
Class

REXCustomDescription Class

Links
REXCustomDescription Class, REX.ContentGenerator.Families Namespace, REXCustomDescription Class

REXCustomDescription.REXCustomDescription Constructor (REXCustomDescription)

REXCustomDescription.REXCustomDescription Constructor (REXCustomDescription)
REXCustomDescription Class REX.ContentGenerator.Families Namespace REXCustomDescription Class

Initializes a new instance of the REXCustomDescription class.

C#
public REXCustomDescription(REXCustomDescription pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

REXCustomDescription Class

Links
REXCustomDescription Class, REX.ContentGenerator.Families Namespace, REXCustomDescription Class

REXCustomDescription.Clone Method

REXCustomDescription.Clone Method
REXCustomDescription Class REX.ContentGenerator.Families Namespace REXCustomDescription Class

Clones this instance.

C#
public abstract override object Clone();
Returns

New instance

Description
Class

REXCustomDescription Class

Links
REXCustomDescription Class, REX.ContentGenerator.Families Namespace, REXCustomDescription Class

REXCustomDescription.GetTypeName Method

REXCustomDescription.GetTypeName Method
REXCustomDescription Class REX.ContentGenerator.Families Namespace REXCustomDescription Class

Gets the name of the type.

C#
public abstract string GetTypeName();
Description
Class

REXCustomDescription Class

Links
REXCustomDescription Class, REX.ContentGenerator.Families Namespace, REXCustomDescription Class

REXDBDescription Class

REXDBDescription Class
REX.ContentGenerator.Families Namespace Legend Members Public Methods REXDBDescription Methods REXDBDescription Properties

Base class for all descriptions of objects in REXFamilyType which were created based on a database.

Class Hierarchy
C#
[Serializable()]
public class REXDBDescription : REXDescription;
Description
Namespace

REX.ContentGenerator.Families Namespace

Public Methods
Public Method | Description
REXDBDescription | Initializes a new instance of the REXDBDescription class.
REXDBDescription | Initializes a new instance of the REXDBDescription class.
REXDBDescription | Initializes a new instance of the REXDBDescription class.
REXDBDescription | Initializes a new instance of the REXDBDescription class.
REXDBDescription | Initializes a new instance of the REXDBDescription class.
REXDBDescription | Initializes a new instance of the REXDBDescription class.
REXDBDescription Methods
REXDBDescription Methods | Description
Clone | Creates a new object that is a copy of the current instance.
CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
GetValue | Gets the value.
RecalculateParameters | Recalculates the parameters.
SetValue | Sets the value.
REXDBDescription Properties
REXDBDescription Properties | Description
DBName | Gets or sets the name of the DB.
Directory | Gets or sets the directory.
Links
REX.ContentGenerator.Families Namespace, Legend, Members, Public Methods, REXDBDescription Methods, REXDBDescription Properties

REXDBDescription.REXDBDescription Constructor ()

REXDBDescription.REXDBDescription Constructor ()
REXDBDescription Class REX.ContentGenerator.Families Namespace REXDBDescription Class

Initializes a new instance of the REXDBDescription class.

C#
public REXDBDescription();
Description
Class

REXDBDescription Class

Links
REXDBDescription Class, REX.ContentGenerator.Families Namespace, REXDBDescription Class

REXDBDescription.REXDBDescription Constructor (DTableDataObjectCollection)

REXDBDescription.REXDBDescription Constructor (DTableDataObjectCollection)
REXDBDescription Class REX.ContentGenerator.Families Namespace REXDBDescription Class

Initializes a new instance of the REXDBDescription class.

C#
public REXDBDescription(DTableDataObjectCollection pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

REXDBDescription Class

Links
REXDBDescription Class, REX.ContentGenerator.Families Namespace, REXDBDescription Class

REXDBDescription.REXDBDescription Constructor (REXDBDescription)

REXDBDescription.REXDBDescription Constructor (REXDBDescription)
REXDBDescription Class REX.ContentGenerator.Families Namespace REXDBDescription Class

Initializes a new instance of the REXDBDescription class.

C#
public REXDBDescription(REXDBDescription pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

REXDBDescription Class

Links
REXDBDescription Class, REX.ContentGenerator.Families Namespace, REXDBDescription Class

REXDBDescription.REXDBDescription Constructor (string)

REXDBDescription.REXDBDescription Constructor (string)
REXDBDescription Class REX.ContentGenerator.Families Namespace REXDBDescription Class

Initializes a new instance of the REXDBDescription class.

C#
public REXDBDescription(string dbName);
Parameters
Parameters | Description
dbName | Name of the database.
Description
Class

REXDBDescription Class

Links
REXDBDescription Class, REX.ContentGenerator.Families Namespace, REXDBDescription Class

REXDBDescription.REXDBDescription Constructor (string, string, DTableDataObjectCollection)

REXDBDescription.REXDBDescription Constructor (string, string, DTableDataObjectCollection)
REXDBDescription Class REX.ContentGenerator.Families Namespace REXDBDescription Class

Initializes a new instance of the REXDBDescription class.

C#
public REXDBDescription(string dir, string dbName, DTableDataObjectCollection col);
Parameters
Parameters | Description
dir | The directory.
dbName | The name of the database.
col | The collection.
Description
Class

REXDBDescription Class

Links
REXDBDescription Class, REX.ContentGenerator.Families Namespace, REXDBDescription Class

REXDBDescription.REXDBDescription Constructor (string, string, System.Data.DataRow)

REXDBDescription.REXDBDescription Constructor (string, string, System.Data.DataRow)
REXDBDescription Class REX.ContentGenerator.Families Namespace REXDBDescription Class

Initializes a new instance of the REXDBDescription class.

C#
public REXDBDescription(string dir, string dbName, System.Data.DataRow row);
Parameters
Parameters | Description
dir | The directory.
dbName | The name of the database.
row | The row.
Description
Class

REXDBDescription Class

Links
REXDBDescription Class, REX.ContentGenerator.Families Namespace, REXDBDescription Class

REXDBDescription.Clone Method

REXDBDescription.Clone Method
REXDBDescription Class REX.ContentGenerator.Families Namespace REXDBDescription Class

Creates a new object that is a copy of the current instance.

C#
public override object Clone();
Returns

A new object that is a copy of this instance.

Description
Class

REXDBDescription Class

Links
REXDBDescription Class, REX.ContentGenerator.Families Namespace, REXDBDescription Class

REXDBDescription.CompareTo Method