SetInterfaceMaxValue | Set the maximum value defined in interface units.
SetInterfaceMinValue | Set the minimum value defined in interface units.
REXUnitComboBox Properties
REXUnitComboBox Properties | Description
Power | Gets or sets the power of the unit.
UnitEngine | Gets or sets the unit engine.
UnitType | Gets or sets the type of the unit.
Links
REX.Controls.Forms Namespace, Legend, Members, REXUnitComboBox Methods, REXUnitComboBox Properties

REXUnitComboBox.GetBaseMaxValue Method

REXUnitComboBox.GetBaseMaxValue Method
REXUnitComboBox Class REX.Controls.Forms Namespace REXUnitComboBox Class

Gets the maximum value and converts it to base units.

C#
public double GetBaseMaxValue();
Returns

The value.

Description
Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.Forms Namespace, REXUnitComboBox Class

REXUnitComboBox.GetBaseMinValue Method

REXUnitComboBox.GetBaseMinValue Method
REXUnitComboBox Class REX.Controls.Forms Namespace REXUnitComboBox Class

Gets the minimum value and converts it to base units.

C#
public double GetBaseMinValue();
Returns

The value.

Description
Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.Forms Namespace, REXUnitComboBox Class

REXUnitComboBox.GetComplexDataBaseValue Method

REXUnitComboBox.GetComplexDataBaseValue Method
REXUnitComboBox Class REX.Controls.Forms Namespace REXUnitComboBox Class

Get the values and convert it to base units.

C#
public List<double> GetComplexDataBaseValue();
Returns

The list of values.

Description
Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.Forms Namespace, REXUnitComboBox Class

REXUnitComboBox.GetComplexDataInterfaceValue Method

REXUnitComboBox.GetComplexDataInterfaceValue Method
REXUnitComboBox Class REX.Controls.Forms Namespace REXUnitComboBox Class

Get the values and convert it to interface units.

C#
public List<double> GetComplexDataInterfaceValue(REXInterfaceType interfaceType);
Parameters
Parameters | Description
interfaceType | The product context.
Returns

The list of values.

Description
Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.Forms Namespace, REXUnitComboBox Class

REXUnitComboBox.GetDataBaseValue Method

REXUnitComboBox.GetDataBaseValue Method
REXUnitComboBox Class REX.Controls.Forms Namespace REXUnitComboBox Class

Gets the value and converts it to base units.

C#
public double GetDataBaseValue();
Returns

The value.

Description
Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.Forms Namespace, REXUnitComboBox Class

REXUnitComboBox.GetDataInterfaceValue Method

REXUnitComboBox.GetDataInterfaceValue Method
REXUnitComboBox Class REX.Controls.Forms Namespace REXUnitComboBox Class

Gets the value and converts it to interface units.

C#
public double GetDataInterfaceValue(REXInterfaceType interfaceType);
Parameters
Parameters | Description
interfaceType | The product context.
Returns

The value.

Description
Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.Forms Namespace, REXUnitComboBox Class

REXUnitComboBox.GetInterfaceMaxValue Method

REXUnitComboBox.GetInterfaceMaxValue Method
REXUnitComboBox Class REX.Controls.Forms Namespace REXUnitComboBox Class

Gets the maximum value and converts it to interface units.

C#
public double GetInterfaceMaxValue(REXInterfaceType interfaceType);
Parameters
Parameters | Description
interfaceType | The product context.
Returns

The value.

Description
Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.Forms Namespace, REXUnitComboBox Class

REXUnitComboBox.GetInterfaceMinValue Method

REXUnitComboBox.GetInterfaceMinValue Method
REXUnitComboBox Class REX.Controls.Forms Namespace REXUnitComboBox Class

Gets the minimum value and converts it to interface units.

C#
public double GetInterfaceMinValue(REXInterfaceType interfaceType);
Parameters
Parameters | Description
interfaceType | The product context.
Returns

The value.

Description
Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.Forms Namespace, REXUnitComboBox Class

REXUnitComboBox.SetBaseMaxValue Method

REXUnitComboBox.SetBaseMaxValue Method
REXUnitComboBox Class REX.Controls.Forms Namespace REXUnitComboBox Class

Set the maximum value defined in base units.

C#
public void SetBaseMaxValue(double value);
Parameters
Parameters | Description
value | The value.
Description
Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.Forms Namespace, REXUnitComboBox Class

REXUnitComboBox.SetBaseMinValue Method

REXUnitComboBox.SetBaseMinValue Method
REXUnitComboBox Class REX.Controls.Forms Namespace REXUnitComboBox Class

Set the minimum value defined in base units.

C#
public void SetBaseMinValue(double value);
Parameters
Parameters | Description
value | The value.
Description
Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.Forms Namespace, REXUnitComboBox Class

REXUnitComboBox.SetComplexDataBaseValue Method

REXUnitComboBox.SetComplexDataBaseValue Method
REXUnitComboBox Class REX.Controls.Forms Namespace REXUnitComboBox Class

Set the list of values defined in base units.

C#
public void SetComplexDataBaseValue(List<double> values);
Parameters
Parameters | Description
values | The values.
Description
Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.Forms Namespace, REXUnitComboBox Class

REXUnitComboBox.SetComplexDataInterfaceValue Method

REXUnitComboBox.SetComplexDataInterfaceValue Method
REXUnitComboBox Class REX.Controls.Forms Namespace REXUnitComboBox Class

Set the list of values defined in interface units.

C#
public void SetComplexDataInterfaceValue(List<double> values, REXInterfaceType interfaceType);
Parameters
Parameters | Description
values | The values.
interfaceType | The product context.
Description
Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.Forms Namespace, REXUnitComboBox Class

REXUnitComboBox.SetDataBaseValue Method

REXUnitComboBox.SetDataBaseValue Method
REXUnitComboBox Class REX.Controls.Forms Namespace REXUnitComboBox Class

Set the value in base units.

C#
public void SetDataBaseValue(double value);
Parameters
Parameters | Description
value | The value.
Description
Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.Forms Namespace, REXUnitComboBox Class

REXUnitComboBox.SetDataInterfaceValue Method

REXUnitComboBox.SetDataInterfaceValue Method
REXUnitComboBox Class REX.Controls.Forms Namespace REXUnitComboBox Class

Set the value in interface units.

C#
public void SetDataInterfaceValue(double value, REXInterfaceType interfaceType);
Parameters
Parameters | Description
value | The value.
interfaceType | The product context.
Description
Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.Forms Namespace, REXUnitComboBox Class

REXUnitComboBox.SetInterfaceMaxValue Method

REXUnitComboBox.SetInterfaceMaxValue Method
REXUnitComboBox Class REX.Controls.Forms Namespace REXUnitComboBox Class

Set the maximum value defined in interface units.

C#
public void SetInterfaceMaxValue(double value, REXInterfaceType interfaceType);
Parameters
Parameters | Description
value | The value.
interfaceType | The product context.
Description
Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.Forms Namespace, REXUnitComboBox Class

REXUnitComboBox.SetInterfaceMinValue Method

REXUnitComboBox.SetInterfaceMinValue Method
REXUnitComboBox Class REX.Controls.Forms Namespace REXUnitComboBox Class

Set the minimum value defined in interface units.

C#
public void SetInterfaceMinValue(double value, REXInterfaceType interfaceType);
Parameters
Parameters | Description
value | The value.
interfaceType | The product context.
Description
Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.Forms Namespace, REXUnitComboBox Class

REXUnitComboBox.Power Property

REXUnitComboBox.Power Property