REXContentDialogManager.ShowContentDialogParentIntPtr Method

REXContentDialogManager.ShowContentDialogParentIntPtr Method
REXContentDialogManager Class REX.ContentGenerator.Dialog Namespace Example REXContentDialogManager Class

Loads the ContentGenerator dialog.

C#
public bool ShowContentDialogParentIntPtr(REXContentDialogSettings settings, IntPtr owner);
Parameters
Parameters | Description
settings | The dialog's settings.
owner | The parent for the window.
Returns

Returns the result of the dialog show.

Description
Example

The example shows how to launch the DRevitContentGenerator dialog and use it as a family browser.

//Manager initialize.
REX.ContentGenerator.Dialog.REXContentDialogManager mng = new REX.ContentGenerator.Dialog.REXContentDialogManager(ThisExtension.Context);

//Settings initialize
//-general
REX.ContentGenerator.Dialog.REXContentDialogSettings settings = new REX.ContentGenerator.Dialog.REXContentDialogSettings();
settings.DialogMode = REX.ContentGenerator.Dialog.EContentDialogMode.MultiSelection;
settings.RegionalSettings = true;
settings.ShowList = true;
settings.Progress = false;
settings.Caption = "Example1";
//-for sections
settings.SectionDBSettings.SelectedElements.Clear();
settings.SectionDBSettings.Visible = true;

//Launching the dialog.
mng.ShowContentDialog(settings, ThisExtension.GetWindowForParent().Handle);

//Getting selection.
List<REXFamilyType> families = new List<REXFamilyType>(settings.SectionDBSettings.SelectedElements);

//Disposing dialog.
mng.DisposeContentDialog();
Class

REXContentDialogManager Class

Links
REXContentDialogManager Class, REX.ContentGenerator.Dialog Namespace, Example, REXContentDialogManager Class

REXContentDialogSettings Class

REXContentDialogSettings Class
REX.ContentGenerator.Dialog Namespace Legend Members Public Methods REXContentDialogSettings Methods REXContentDialogSettings Properties

Describes settings of the ContentGenerator dialog.

Class Hierarchy
C#
public class REXContentDialogSettings;
Description
Namespace

REX.ContentGenerator.Dialog Namespace

Public Methods
Public Method | Description
REXContentDialogSettings | Initializes a new instance of the REXContentDialogSettings class.
REXContentDialogSettings Methods
REXContentDialogSettings Methods | Description
GetSettings | Gets settings.
GetVisibleCategories | Gets visible categories.
IsVisible | Determines whether the specified category is visible.
SetOneCategoryVisible | Sets visibility of specific category.
REXContentDialogSettings Properties
REXContentDialogSettings Properties | Description
Caption | Gets or sets the caption.
Categories | Gets or sets the settings for all categories.
DialogIcon | Gets or sets the dialog icon.
DialogMode | Gets or sets the dialog mode.
MaterialSettings | Gets the settings for the material category.
Progress | Gets or sets a value indicating whether a progress bar should be visible.
RebarShapeSettings | Gets the settings for the rebar shape category.
RebarTypeSettings | Gets the settings for the rebar type category.
RegionalSettings | Gets or sets a value indicating whether regional settings are supported.
SectionDBSettings | Gets the settings for the database section category..
SectionParamSettings | Gets the settings for the parametric section category.
ShowList | Gets or sets a value indicating whether the list of categories should be visible.
ValidateTypes | Gets or sets a value indicating whether types should be validated.
Links
REX.ContentGenerator.Dialog Namespace, Legend, Members, Public Methods, REXContentDialogSettings Methods, REXContentDialogSettings Properties

REXContentDialogSettings.REXContentDialogSettings Constructor

REXContentDialogSettings.REXContentDialogSettings Constructor
REXContentDialogSettings Class REX.ContentGenerator.Dialog Namespace REXContentDialogSettings Class

Initializes a new instance of the REXContentDialogSettings class.

C#
public REXContentDialogSettings();
Description
Class

REXContentDialogSettings Class

Links
REXContentDialogSettings Class, REX.ContentGenerator.Dialog Namespace, REXContentDialogSettings Class

REXContentDialogSettings.GetSettings Method

REXContentDialogSettings.GetSettings Method
REXContentDialogSettings Class REX.ContentGenerator.Dialog Namespace REXContentDialogSettings Class

Gets settings.

C#
public REXContentDialogCategorySettings GetSettings(ECategoryType category);
Parameters
Parameters | Description
category | The category.
Returns

Returns settings.

Description
Class

REXContentDialogSettings Class

Links
REXContentDialogSettings Class, REX.ContentGenerator.Dialog Namespace, REXContentDialogSettings Class

REXContentDialogSettings.GetVisibleCategories Method

REXContentDialogSettings.GetVisibleCategories Method
REXContentDialogSettings Class REX.ContentGenerator.Dialog Namespace REXContentDialogSettings Class

Gets visible categories.

C#
public List<ECategoryType> GetVisibleCategories();
Returns

Returns categories.

Description
Class

REXContentDialogSettings Class

Links
REXContentDialogSettings Class, REX.ContentGenerator.Dialog Namespace, REXContentDialogSettings Class

REXContentDialogSettings.IsVisible Method

REXContentDialogSettings.IsVisible Method
REXContentDialogSettings Class REX.ContentGenerator.Dialog Namespace REXContentDialogSettings Class

Determines whether the specified category is visible.

C#
public bool IsVisible(ECategoryType category);
Parameters
Parameters | Description
category | The category.
Returns

Returns if the specified category is visible.

Description
Class

REXContentDialogSettings Class

Links
REXContentDialogSettings Class, REX.ContentGenerator.Dialog Namespace, REXContentDialogSettings Class

REXContentDialogSettings.SetOneCategoryVisible Method

REXContentDialogSettings.SetOneCategoryVisible Method
REXContentDialogSettings Class REX.ContentGenerator.Dialog Namespace REXContentDialogSettings Class

Sets visibility of specific category.

C#
public void SetOneCategoryVisible(ECategoryType category);
Parameters
Parameters | Description
category | The category.
Description

Rest of categories are not visible.

Class

REXContentDialogSettings Class

Links
REXContentDialogSettings Class, REX.ContentGenerator.Dialog Namespace, REXContentDialogSettings Class

REXContentDialogSettings.Caption Property

REXContentDialogSettings.Caption Property
REXContentDialogSettings Class REX.ContentGenerator.Dialog Namespace REXContentDialogSettings Class

Gets or sets the caption.

C#
public string Caption;
Description

The caption.

Class

REXContentDialogSettings Class

Links
REXContentDialogSettings Class, REX.ContentGenerator.Dialog Namespace, REXContentDialogSettings Class

REXContentDialogSettings.Categories Property

REXContentDialogSettings.Categories Property
REXContentDialogSettings Class REX.ContentGenerator.Dialog Namespace REXContentDialogSettings Class

Gets or sets the settings for all categories.

C#
public Dictionary<ECategoryType, REXContentDialogCategorySettings> Categories;
Description

The categories.

Class

REXContentDialogSettings Class

Links
REXContentDialogSettings Class, REX.ContentGenerator.Dialog Namespace, REXContentDialogSettings Class

REXContentDialogSettings.DialogIcon Property

REXContentDialogSettings.DialogIcon Property
REXContentDialogSettings Class REX.ContentGenerator.Dialog Namespace REXContentDialogSettings Class

Gets or sets the dialog icon.

C#
public System.Drawing.Icon DialogIcon;
Description

The dialog icon.

Class

REXContentDialogSettings Class

Links
REXContentDialogSettings Class, REX.ContentGenerator.Dialog Namespace, REXContentDialogSettings Class

REXContentDialogSettings.DialogMode Property

REXContentDialogSettings.DialogMode Property
REXContentDialogSettings Class REX.ContentGenerator.Dialog Namespace REXContentDialogSettings Class

Gets or sets the dialog mode.

C#
public EContentDialogMode DialogMode;
Description

The dialog mode.

Class

REXContentDialogSettings Class

Links