XHTMLDocument Class

Links
XHTMLDocument Class, ROHTML Namespace, XHTMLDocument Class

XHTMLDocument.Status Field

XHTMLDocument.Status Field
XHTMLDocument Class ROHTML Namespace XHTMLDocument Class

ROHTMLMessages indicates the status of the document, it is used in note header and footer.

C#
public ROHTMLMessages Status;
Description
Class

XHTMLDocument Class

Links
XHTMLDocument Class, ROHTML Namespace, XHTMLDocument Class

XHTMLDocument.Version Field

XHTMLDocument.Version Field
XHTMLDocument Class ROHTML Namespace XHTMLDocument Class

String (read-only) that indicates the version of the component, e.g.

C#
public string Version;
Description

"18.0.0.1887".

Class

XHTMLDocument Class

Links
XHTMLDocument Class, ROHTML Namespace, XHTMLDocument Class

XHTMLDocument.IsVersion Method

XHTMLDocument.IsVersion Method
XHTMLDocument Class ROHTML Namespace XHTMLDocument Class

Returns True if the version of the component is greater or equal to the given version, version should be formatted as follow: "MAJOR.MINOR.PATCH.COMPILATION", e.g.

C#
public void IsVersion(String version);
Parameters
Parameters | Description
version |
Description

"18.0.4.1887".

Class

XHTMLDocument Class

Links
XHTMLDocument Class, ROHTML Namespace, XHTMLDocument Class

XHTMLDocument.Save Method

XHTMLDocument.Save Method
XHTMLDocument Class ROHTML Namespace XHTMLDocument Class

Saves the XHTML document to the specified location.

C#
public void Save(String fileName);
Parameters
Parameters | Description
fileName |
Description
Class

XHTMLDocument Class

Links
XHTMLDocument Class, ROHTML Namespace, XHTMLDocument Class

XHTMLDocument.SaveAsSingleFile Method

XHTMLDocument.SaveAsSingleFile Method
XHTMLDocument Class ROHTML Namespace XHTMLDocument Class

Saves the document to the specified location as MS MHTML file.

C#
public void SaveAsSingleFile(String fileName);
Parameters
Parameters | Description
fileName |
Description
Class

XHTMLDocument Class

Links
XHTMLDocument Class, ROHTML Namespace, XHTMLDocument Class

XHTMLDocument.Show Method

XHTMLDocument.Show Method
XHTMLDocument Class ROHTML Namespace XHTMLDocument Class

Launches Internet Explorer and navigates to the specified file.

C#
public void Show(String fileName);
Description
Class

XHTMLDocument Class

Links
XHTMLDocument Class, ROHTML Namespace, XHTMLDocument Class

XHTMLDocument.ToString Method

XHTMLDocument.ToString Method
XHTMLDocument Class ROHTML Namespace XHTMLDocument Class

Returns String containing the generated document.

C#
public string ToString();
Description
Class

XHTMLDocument Class

Links
XHTMLDocument Class, ROHTML Namespace, XHTMLDocument Class

XHTMLElement Class

XHTMLElement Class
ROHTML Namespace Legend Members XHTMLElement Fields XHTMLElement Methods

This is class ROHTML.XHTMLElement.

Class Hierarchy
C#
public class XHTMLElement;
Namespace

ROHTML Namespace

XHTMLElement Fields
XHTMLElement Fields | Description
TagName | String containing the tag name of the element (may be empty).
XHTMLElement Methods
XHTMLElement Methods | Description
AddAttribute | Adds an HTML attribute and its value to the element.
AddBlockquote | Adds an element of type "blockquote" to the document and returns newly created XHTMLElement object.
AddElement | Adds an element of given name to the document and returns newly created XHTMLElement object.
AddHeader | Adds an element of type h1 through h6 (size=1 is the largest) to the document and returns newly created XHTMLElement object.
AddHorizontalRule | Inserts a horizontal rule ().
AddImage | Adds an image retrieved from resource (DLL or EXE) using protocol.
AddImageStd | Adds a standard image loaded from internal resources to the document.
AddLine | Writes the given text, followed by a newline character, to the document.
AddLineBreak | Inserts a single line break ().
AddMessage | Adds a decorated text to the document and returns newly created XHTMLElement object.
AddMessage2 | Adds a left text aligned text with right aligned note.
AddNoteFooter | Writes calculation note footer
AddNoteHeader | Writes calculation note header
AddParagraph | Adds an element of type "p" to the document and returns newly created XHTMLElement object.
AddPicture | Adds an image loaded from file.
AddSpan | Adds an element of type "span" to the document and returns newly created XHTMLElement object.
AddSubscript | Writes the given text to the document as a subscript.
AddSuperscript | Writes the given text to the document as a superscript.
AddSymbol | Writes the given text to the document using symbol (greek) font, e.g.
AddTable | Adds a table to the document and returns newly created XHTMLTable object
AddText | Writes the given text to the document.
AddText2 | Writes the given value name and its description to the document.
AddTextBold | Writes the given text to the document using a bold font.
AddUnit | Writes the given unit name to the document, adds braces if needed and moves all digits to uppercase, e.g mm2 -> [mm2].
AddValue | Writes the given value of any type, that can be converted to a string, to the document.
AddValue2 | Writes the given value of any type and it's name.
AddValue4 | Extended AddValue method (Similar to Verify, different order of parameters)
AddValue5 | Extended AddValue method
Verify | Similar to AddValue4 (different order of parameters),
Links
ROHTML Namespace, Legend, Members, XHTMLElement Fields, XHTMLElement Methods

XHTMLElement.TagName Field

XHTMLElement.TagName Field
XHTMLElement Class ROHTML Namespace XHTMLElement Class

String containing the tag name of the element (may be empty).

C#
public string TagName;
Description
Class

XHTMLElement Class

Links
XHTMLElement Class, ROHTML Namespace, XHTMLElement Class

XHTMLElement.AddAttribute Method

XHTMLElement.AddAttribute Method
XHTMLElement Class ROHTML Namespace XHTMLElement Class

Adds an HTML attribute and its value to the element.

C#
public void AddAttribute(String name, String value);
Parameters
Parameters | Description
name |
value |
Description
Class

XHTMLElement Class

Links
XHTMLElement Class, ROHTML Namespace, XHTMLElement Class

XHTMLElement.AddBlockquote Method

XHTMLElement.AddBlockquote Method
XHTMLElement Class ROHTML Namespace XHTMLElement Class

Adds an element of type "blockquote" to the document and returns newly created XHTMLElement object.

C#
public void AddBlockquote(String text);
Parameters
Parameters | Description
text |
Description

Writes the given text to the created element of the document

Class

XHTMLElement Class

Links
XHTMLElement Class, ROHTML Namespace, XHTMLElement Class

XHTMLElement.AddElement Method

XHTMLElement.AddElement Method
XHTMLElement Class ROHTML Namespace XHTMLElement Class

Adds an element of given name to the document and returns newly created XHTMLElement object.

C#
public void AddElement(String name);
Parameters
Parameters | Description
name |
Description
Class

XHTMLElement Class

Links
XHTMLElement Class, ROHTML Namespace, XHTMLElement Class

XHTMLElement.AddHeader Method

XHTMLElement.AddHeader Method
XHTMLElement Class ROHTML Namespace XHTMLElement Class

Adds an element of type h1 through h6 (size=1 is the largest) to the document and returns newly created XHTMLElement object.

C#
public void AddHeader(Short size, String text);
Parameters
Parameters | Description
size |
text |
Description

Writes the given text to the created element of the document.

Class

XHTMLElement Class

Links
XHTMLElement Class, ROHTML Namespace, XHTMLElement Class

XHTMLElement.AddHorizontalRule Method

XHTMLElement.AddHorizontalRule Method
XHTMLElement Class ROHTML Namespace XHTMLElement Class

Inserts a horizontal rule ().

C#
public void AddHorizontalRule();
Description
Class

XHTMLElement Class

Links
XHTMLElement Class, ROHTML Namespace, XHTMLElement Class

XHTMLElement.AddImage Method

XHTMLElement.AddImage Method
XHTMLElement Class ROHTML Namespace XHTMLElement Class

Adds an image retrieved from resource (DLL or EXE) using protocol.

C#