public REX.Common.REXExtensionContext.REXStandardRunContext ThisRunContext;
Description

The this run context.

Class

REXExtensionWindow Class

Links
REXExtensionWindow Class, REX.Common Namespace, REXExtensionWindow Class

REXExtensionWindow.WindowStatus Property

REXExtensionWindow.WindowStatus Property
REXExtensionWindow Class REX.Common Namespace REXExtensionWindow Class

This is WindowStatus, a member of class REXExtensionWindow.

C#
public REXStatusType WindowStatus;
Class

REXExtensionWindow Class

Links
REXExtensionWindow Class, REX.Common Namespace, REXExtensionWindow Class

REXFoundationApplication Class

REXFoundationApplication Class
REX.Common Namespace Legend Members Public Methods REXFoundationApplication Methods

Foundation class for REX.Foundation usage.

Class Hierarchy
C#
public class REXFoundationApplication : Autodesk.REX.Framework.IREXApplication4;
Description
Namespace

REX.Common Namespace

Public Methods
Public Method | Description
REXFoundationApplication | Initializes a new instance of the REXApplication class.
REXFoundationApplication Methods
REXFoundationApplication Methods | Description
Close | Closes this instance.
Command | Commands the specified command struct.
Control | Controls this instance.
Create | Creates and shows module as modal dialog.
Create | Creates and shows module as modal dialog.
Event | Called when event.
GetService | Gets the the service.
GetUniqueId | Returns the unique id for the module
Modal | Creates and shows module as modal dialog.
Modal | Creates and shows module as modal dialog.
Show | Shows this module.
Links
REX.Common Namespace, Legend, Members, Public Methods, REXFoundationApplication Methods

REXFoundationApplication.REXFoundationApplication Constructor

REXFoundationApplication.REXFoundationApplication Constructor
REXFoundationApplication Class REX.Common Namespace REXFoundationApplication Class

Initializes a new instance of the REXApplication class.

C#
public REXFoundationApplication();
Description
Class

REXFoundationApplication Class

Links
REXFoundationApplication Class, REX.Common Namespace, REXFoundationApplication Class

REXFoundationApplication.Close Method

REXFoundationApplication.Close Method
REXFoundationApplication Class REX.Common Namespace REXFoundationApplication Class

Closes this instance.

C#
public void Close();
Description
Class

REXFoundationApplication Class

Links
REXFoundationApplication Class, REX.Common Namespace, REXFoundationApplication Class

REXFoundationApplication.Command Method

REXFoundationApplication.Command Method
REXFoundationApplication Class REX.Common Namespace REXFoundationApplication Class

Commands the specified command struct.

C#
public object Command(ref Autodesk.REX.Framework.REXCommand CommandStruct);
Parameters
Parameters | Description
CommandStruct | The command struct.
Description
Class

REXFoundationApplication Class

Links
REXFoundationApplication Class, REX.Common Namespace, REXFoundationApplication Class

REXFoundationApplication.Control Method

REXFoundationApplication.Control Method
REXFoundationApplication Class REX.Common Namespace REXFoundationApplication Class

Controls this instance.

C#
public object Control();
Description
Class

REXFoundationApplication Class

Links
REXFoundationApplication Class, REX.Common Namespace, REXFoundationApplication Class

REXFoundationApplication.Create Method (Autodesk.REX.Framework.REXApplicationContext)

REXFoundationApplication.Create Method (Autodesk.REX.Framework.REXApplicationContext)
REXFoundationApplication Class REX.Common Namespace REXFoundationApplication Class

Creates and shows module as modal dialog.

C#
public bool Create(ref Autodesk.REX.Framework.REXApplicationContext AppContext);
Parameters
Parameters | Description
AppContext | The application context.
Returns

Returns true if suceeded.

Description
Class

REXFoundationApplication Class

Links
REXFoundationApplication Class, REX.Common Namespace, REXFoundationApplication Class

REXFoundationApplication.Create Method (Autodesk.REX.Framework.REXContext)

REXFoundationApplication.Create Method (Autodesk.REX.Framework.REXContext)
REXFoundationApplication Class REX.Common Namespace REXFoundationApplication Class

Creates and shows module as modal dialog.

C#
public bool Create(Autodesk.REX.Framework.REXContext AppContext);
Parameters
Parameters | Description
AppContext | The application context.
Returns

Returns true if suceeded.

Description
Class

REXFoundationApplication Class

Links
REXFoundationApplication Class, REX.Common Namespace, REXFoundationApplication Class

REXFoundationApplication.Event Method

REXFoundationApplication.Event Method
REXFoundationApplication Class REX.Common Namespace REXFoundationApplication Class

Called when event.

C#
public object Event(ref Autodesk.REX.Framework.REXEvent EventStruct);
Parameters
Parameters | Description
EventStruct | The event structure.
Returns

Returns result of event operation.

Description
Class

REXFoundationApplication Class

Links
REXFoundationApplication Class, REX.Common Namespace, REXFoundationApplication Class

REXFoundationApplication.GetService Method

REXFoundationApplication.GetService Method
REXFoundationApplication Class REX.Common Namespace REXFoundationApplication Class

Gets the the service.

C#
public object GetService();
Returns

Returns the service.

Description
Class

REXFoundationApplication Class

Links
REXFoundationApplication Class, REX.Common Namespace, REXFoundationApplication Class

REXFoundationApplication.GetUniqueId Method

REXFoundationApplication.GetUniqueId Method
REXFoundationApplication Class REX.Common Namespace REXFoundationApplication Class

Returns the unique id for the module

C#
public Guid GetUniqueId();
Class

REXFoundationApplication Class

Links
REXFoundationApplication Class, REX.Common Namespace, REXFoundationApplication Class

REXFoundationApplication.Modal Method (Autodesk.REX.Framework.REXApplicationContext)

REXFoundationApplication.Modal Method (Autodesk.REX.Framework.REXApplicationContext)
REXFoundationApplication Class REX.Common Namespace REXFoundationApplication Class

Creates and shows module as modal dialog.

C#
public bool Modal(ref Autodesk.REX.Framework.REXApplicationContext AppContext);
Parameters
Parameters | Description
AppContext | The application context.
Returns

Returns true if suceeded.

Description
Class

REXFoundationApplication Class

Links
REXFoundationApplication Class, REX.Common Namespace, REXFoundationApplication Class

REXFoundationApplication.Modal Method (Autodesk.REX.Framework.REXContext)

REXFoundationApplication.Modal Method (Autodesk.REX.Framework.REXContext)
REXFoundationApplication Class REX.Common Namespace REXFoundationApplication Class

Creates and shows module as modal dialog.

C#
public bool Modal(Autodesk.REX.Framework.REXContext AppContext);
Parameters
Parameters | Description
AppContext | The application context.
Returns

Returns true if suceeded.

Description
Class

REXFoundationApplication Class

Links
REXFoundationApplication Class, REX.Common Namespace, REXFoundationApplication Class

REXFoundationApplication.Show Method

REXFoundationApplication.Show Method
REXFoundationApplication Class REX.Common Namespace REXFoundationApplication Class

Shows this module.

C#
public bool Show();
Returns

Returns true if succeeded.

Description
Class

REXFoundationApplication Class

Links
REXFoundationApplication Class, REX.Common Namespace, REXFoundationApplication Class

REXLayout Class

REXLayout Class
REX.Common Namespace Legend Members Public Methods REXLayout Methods REXLayout Properties
Class Hierarchy
C#
public class REXLayout;
Namespace

REX.Common Namespace

Public Methods
Public Method | Description
REXLayout | Initializes a new instance of the REXLayout class.
REXLayout Methods
REXLayout Methods | Description
AddLayout | Adds the layout.
AddLayout | Adds the layout.
AddLayout | Adds the layout.
AddLayout_Dialog | Adds the predefined layout with one dialog.