Contour_Compound2D Class REX.ContentGenerator.Geometry Namespace Contour_Compound2D Class

Gets the geometry params.

C#
public void GetGeometryParams(out double Ac, out double Sy, out double Sz, out double yc, out double zc, out double Jy, out double Jz, out double Jy0, out double Jz0);
Parameters
Parameters | Description
Ac | The area.
Sy | The static moment - Y.
Sz | The static moment - Z.
yc | The center - Y.
zc | The center - Z.
Jy | The moment of inertia - Y.
Jz | The moment of inertia - Z.
Jy0 | The moment of inertia - center Y.
Jz0 | The moment of inertia - center Z.
Description
Class

Contour_Compound2D Class

Links
Contour_Compound2D Class, REX.ContentGenerator.Geometry Namespace, Contour_Compound2D Class

Contour_Compound2D.GetPoint Method

Contour_Compound2D.GetPoint Method
Contour_Compound2D Class REX.ContentGenerator.Geometry Namespace Contour_Compound2D Class

Gets the point in the specified plane.

C#
public REXxyz GetPoint(REXxyz pt, ECoords coords);
Parameters
Parameters | Description
pt | The point.
coords | The coordinate system (plane).
Returns

The point.

Description
Class

Contour_Compound2D Class

Links
Contour_Compound2D Class, REX.ContentGenerator.Geometry Namespace, Contour_Compound2D Class

Contour_Compound2D.LineTo Method (double, double)

Contour_Compound2D.LineTo Method (double, double)
Contour_Compound2D Class REX.ContentGenerator.Geometry Namespace Contour_Compound2D Class

Defines a line to the specified point.

C#
public void LineTo(double x, double y);
Parameters
Parameters | Description
x | The x coordinate.
y | The y coordinate.
Description
Class

Contour_Compound2D Class

Links
Contour_Compound2D Class, REX.ContentGenerator.Geometry Namespace, Contour_Compound2D Class

Contour_Compound2D.LineTo Method (double, double, bool)

Contour_Compound2D.LineTo Method (double, double, bool)
Contour_Compound2D Class REX.ContentGenerator.Geometry Namespace Contour_Compound2D Class

Defines a line to the specified point.

C#
public void LineTo(double x, double y, bool trans);
Parameters
Parameters | Description
x | The x coordinate.
y | The y coordinate.
trans | Indicates whether x, y should be taken as a point or a transversal vector.
Description
Class

Contour_Compound2D Class

Links
Contour_Compound2D Class, REX.ContentGenerator.Geometry Namespace, Contour_Compound2D Class

Contour_Compound2D.LineToX Method

Contour_Compound2D.LineToX Method
Contour_Compound2D Class REX.ContentGenerator.Geometry Namespace Contour_Compound2D Class

Defines a line to the specified point (parallel to X axis).

C#
public void LineToX(double x);
Parameters
Parameters | Description
x | The x coordinate.
Description
Class

Contour_Compound2D Class

Links
Contour_Compound2D Class, REX.ContentGenerator.Geometry Namespace, Contour_Compound2D Class

Contour_Compound2D.LineToY Method

Contour_Compound2D.LineToY Method
Contour_Compound2D Class REX.ContentGenerator.Geometry Namespace Contour_Compound2D Class

Defines a line to the specified point (parallel to Y axis).

C#
public void LineToY(double y);
Parameters
Parameters | Description
y | The y coordinate.
Description
Class

Contour_Compound2D Class

Links
Contour_Compound2D Class, REX.ContentGenerator.Geometry Namespace, Contour_Compound2D Class

Contour_Compound2D.LoadFromString Method

Contour_Compound2D.LoadFromString Method
Contour_Compound2D Class REX.ContentGenerator.Geometry Namespace Contour_Compound2D Class

Loads the contour from the string.

C#
public void LoadFromString(string serializedString);
Parameters
Parameters | Description
serializedString | The serialized string.
Description
Class

Contour_Compound2D Class

Links
Contour_Compound2D Class, REX.ContentGenerator.Geometry Namespace, Contour_Compound2D Class

Contour_Compound2D.MultiplyLengthDim Method

Contour_Compound2D.MultiplyLengthDim Method
Contour_Compound2D Class REX.ContentGenerator.Geometry Namespace Contour_Compound2D Class

Multiplies all length dimensions by the input coefficient.

C#
public void MultiplyLengthDim(double coeff);
Parameters
Parameters | Description
coeff | The coefficient.
Description
Class

Contour_Compound2D Class

Links
Contour_Compound2D Class, REX.ContentGenerator.Geometry Namespace, Contour_Compound2D Class

Contour_Compound2D.SaveToString Method

Contour_Compound2D.SaveToString Method
Contour_Compound2D Class REX.ContentGenerator.Geometry Namespace Contour_Compound2D Class

Saves the contour to the string.

C#
public string SaveToString();
Returns

Serialized contour.

Description
Class

Contour_Compound2D Class

Links
Contour_Compound2D Class, REX.ContentGenerator.Geometry Namespace, Contour_Compound2D Class

Contour_Compound2D.StartContour Method (double, double)

Contour_Compound2D.StartContour Method (double, double)
Contour_Compound2D Class REX.ContentGenerator.Geometry Namespace Contour_Compound2D Class

Starts the definition of the contour.

C#
public ContourCont StartContour(double x, double y);
Parameters
Parameters | Description
x | The x coordinate.
y | The y coordinate.
Description
Class

Contour_Compound2D Class

Links
Contour_Compound2D Class, REX.ContentGenerator.Geometry Namespace, Contour_Compound2D Class

Contour_Compound2D.StartContour Method (double, double, bool, ContourCont)

Contour_Compound2D.StartContour Method (double, double, bool, ContourCont)
Contour_Compound2D Class REX.ContentGenerator.Geometry Namespace Contour_Compound2D Class

Starts the definition of the contour.

C#
public ContourCont StartContour(double x, double y, bool hole, ContourCont parent);
Parameters
Parameters | Description
x | The x coordinate.
y | The y coordinate.
hole | Indicates whether the current contour is a hole.
parent | The parent.
Returns

The new created contour.

Description
Class

Contour_Compound2D Class

Links
Contour_Compound2D Class, REX.ContentGenerator.Geometry Namespace, Contour_Compound2D Class

Contour_Compound2D.StartContour Method (double, double, bool, bool)

Contour_Compound2D.StartContour Method (double, double, bool, bool)
Contour_Compound2D Class REX.ContentGenerator.Geometry Namespace Contour_Compound2D Class

Starts the definition of the contour.

C#
public ContourCont StartContour(double x, double y, bool hole, bool add2Current);
Parameters
Parameters | Description
x | The x coordinate.
y | The y coordinate.
hole | Indicates whether the current contour is a hole.
add2Current | Indicates whether the contour should be added to the last contour.
Returns

The new created contour.

Description
Class

Contour_Compound2D Class

Links
Contour_Compound2D Class, REX.ContentGenerator.Geometry Namespace, Contour_Compound2D Class

Contour_Compound2D.Translate Method

Contour_Compound2D.Translate Method
Contour_Compound2D Class REX.ContentGenerator.Geometry Namespace Contour_Compound2D Class

Applies the specified translation vector to all elements.

C#
public void Translate(double x, double y);
Parameters
Parameters | Description
x | The x.
y | The y.
Description
Class

Contour_Compound2D Class

Links
Contour_Compound2D Class, REX.ContentGenerator.Geometry Namespace, Contour_Compound2D Class

Contour_Compound2D.Axis Property

Contour_Compound2D.Axis Property
Contour_Compound2D Class REX.ContentGenerator.Geometry Namespace Contour_Compound2D Class

Gets or sets the list of axis.

C#
public List<ContourLine> Axis;
Description

The list of axis.

Class

Contour_Compound2D Class

Links
Contour_Compound2D Class, REX.ContentGenerator.Geometry Namespace, Contour_Compound2D Class

Contour_Compound2D.Dimensions Property

Contour_Compound2D.Dimensions Property
Contour_Compound2D Class REX.ContentGenerator.Geometry Namespace Contour_Compound2D Class

Gets or sets the list of dimensions.

C#
public List<ContourDimension> Dimensions;
Description

The dimensions.

Class

Contour_Compound2D Class

Links
Contour_Compound2D Class, REX.ContentGenerator.Geometry Namespace, Contour_Compound2D Class

Contour_Compound2D.Shape Property

Contour_Compound2D.Shape Property