Log | This is Log, a member of class REXLogger.
Log | This is Log, a member of class REXLogger.
Log | This is Log, a member of class REXLogger.
Log | Logs specified warning.
Log | Logs specified warning and message.
Links
REX.Common Namespace, Legend, Members, REXLogger Methods

REXLogger.Log Method (REXErrors.ErrorCode)

REXLogger.Log Method (REXErrors.ErrorCode)
REXLogger Class REX.Common Namespace REXLogger Class

This is Log, a member of class REXLogger.

C#
public static void Log(REXErrors.ErrorCode err);
Class

REXLogger Class

Links
REXLogger Class, REX.Common Namespace, REXLogger Class

REXLogger.Log Method (REXErrors.ErrorCode, Exception)

REXLogger.Log Method (REXErrors.ErrorCode, Exception)
REXLogger Class REX.Common Namespace REXLogger Class

This is Log, a member of class REXLogger.

C#
public static void Log(REXErrors.ErrorCode err, Exception ex);
Class

REXLogger Class

Links
REXLogger Class, REX.Common Namespace, REXLogger Class

REXLogger.Log Method (REXErrors.ErrorCode, Exception, LogCategory)

REXLogger.Log Method (REXErrors.ErrorCode, Exception, LogCategory)
REXLogger Class REX.Common Namespace REXLogger Class

This is Log, a member of class REXLogger.

C#
public static void Log(REXErrors.ErrorCode err, Exception ex, LogCategory cat);
Class

REXLogger Class

Links
REXLogger Class, REX.Common Namespace, REXLogger Class

REXLogger.Log Method (REXErrors.ErrorCode, LogCategory)

REXLogger.Log Method (REXErrors.ErrorCode, LogCategory)
REXLogger Class REX.Common Namespace REXLogger Class

This is Log, a member of class REXLogger.

C#
public static void Log(REXErrors.ErrorCode err, LogCategory cat);
Class

REXLogger Class

Links
REXLogger Class, REX.Common Namespace, REXLogger Class

REXLogger.Log Method (REXErrors.ErrorCode, String)

REXLogger.Log Method (REXErrors.ErrorCode, String)
REXLogger Class REX.Common Namespace REXLogger Class

This is Log, a member of class REXLogger.

C#
public static void Log(REXErrors.ErrorCode err, String msg);
Class

REXLogger Class

Links
REXLogger Class, REX.Common Namespace, REXLogger Class

REXLogger.Log Method (REXErrors.ErrorCode, String, LogCategory)

REXLogger.Log Method (REXErrors.ErrorCode, String, LogCategory)
REXLogger Class REX.Common Namespace REXLogger Class

This is Log, a member of class REXLogger.

C#
public static void Log(REXErrors.ErrorCode err, String msg, LogCategory cat);
Class

REXLogger Class

Links
REXLogger Class, REX.Common Namespace, REXLogger Class

REXLogger.Log Method (REXErrors.ErrorCode, string, Exception)

REXLogger.Log Method (REXErrors.ErrorCode, string, Exception)
REXLogger Class REX.Common Namespace REXLogger Class

This is Log, a member of class REXLogger.

C#
public static void Log(REXErrors.ErrorCode err, string text, Exception ex);
Class

REXLogger Class

Links
REXLogger Class, REX.Common Namespace, REXLogger Class

REXLogger.Log Method (REXWarnings.WarningCode)

REXLogger.Log Method (REXWarnings.WarningCode)
REXLogger Class REX.Common Namespace REXLogger Class

Logs specified warning.

C#
public static void Log(REXWarnings.WarningCode wrn);
Parameters
Parameters | Description
wrn | The warning code.
Description
Class

REXLogger Class

Links
REXLogger Class, REX.Common Namespace, REXLogger Class

REXLogger.Log Method (REXWarnings.WarningCode, String)

REXLogger.Log Method (REXWarnings.WarningCode, String)
REXLogger Class REX.Common Namespace REXLogger Class

Logs specified warning and message.

C#
public static void Log(REXWarnings.WarningCode wrn, String msg);
Parameters
Parameters | Description
wrn | The warning code.
msg | The message.
Description
Class

REXLogger Class

Links
REXLogger Class, REX.Common Namespace, REXLogger Class

REXResults Class

REXResults Class
REX.Common Namespace Legend Members Public Methods

Base class for results.

Class Hierarchy
C#
public class REXResults : REXExtensionData;
Description
Namespace

REX.Common Namespace

Public Methods
Public Method | Description
REXResults | Initializes a new instance of a REXResults class.
Links
REX.Common Namespace, Legend, Members, Public Methods

REXResults.REXResults Constructor

REXResults.REXResults Constructor
REXResults Class REX.Common Namespace REXResults Class

Initializes a new instance of a REXResults class.

C#
public REXResults(REXExtension Ext);
Parameters
Parameters | Description
Ext | The reference to REXExtension object.
Description
Class

REXResults Class

Links
REXResults Class, REX.Common Namespace, REXResults Class

REXRevitAccess Class

REXRevitAccess Class
REX.Common Namespace Legend Members Public Methods REXRevitAccess Classes REXRevitAccess Enumerations REXRevitAccess Fields REXRevitAccess Methods REXRevitAccess Properties

The class dedicated to settings data from Revit.

Class Hierarchy
C#
public class REXRevitAccess : IREXExtensionAccess3;
Description

Called internally from base SDK's classes.

Namespace

REX.Common Namespace

Public Methods
Public Method | Description
REXRevitAccess | Initializes a new instance of the REXRevitAccess class.
REXRevitAccess Classes
REXRevitAccess Classes | Description
Versions | Constants for all known versions.
REXRevitAccess Enumerations
REXRevitAccess Enumerations | Description
CompareVersionsResult | Dedicated enum for compare Revit's version.
REXRevitAccess Fields
REXRevitAccess Fields | Description
AutoSelectionRestore | This is AutoSelectionRestore, a member of class REXRevitAccess.
UsingParameters | This is UsingParameters, a member of class REXRevitAccess.
REXRevitAccess Methods
REXRevitAccess Methods | Description
Application | Access to Autodesk.Revit.ApplicationServices.ApplicationServices.Application object.
CommandData | Access to Autodesk.Revit.ExternalCommandData.
CompareVersions | Compares the versions.
Create | Reads some data from Revit and sets system display units.
Destroy | Destroys and resets some objects connected to Revit.
Detach | Detaches this instance.
Elements | Access to Autodesk.Revit.ExternalCommandData.
Event | Events the specified ev.
Initialize | Initializes this instance.
Message | Access to message string from Autodesk.Revit.IExternalCommand.Execute command.
Update | Reads some data from Revit and set system display units.
UpdaterData | Access to updater data (in update context only).
REXRevitAccess Properties
REXRevitAccess Properties | Description
ActiveDocument | Actives the UI document.
ActiveUIDocument | Actives the UI document.
EventService | This is EventService, a member of class REXRevitAccess.
IsArchitecture | This is IsArchitecture, a member of class REXRevitAccess.
IsMEP | This is IsMEP, a member of class REXRevitAccess.
IsStructure | This is IsStructure, a member of class REXRevitAccess.
Parameters | Access to REX parameters.
Selection | Actives the UI document.
ThisApplication | This is ThisApplication, a member of class REXRevitAccess.
ThisContext | This is ThisContext, a member of class REXRevitAccess.
ThisExtension | This is ThisExtension, a member of class REXRevitAccess.
UIApplication | UIs the application.
Links
REX.Common Namespace, Legend, Members, Public Methods, REXRevitAccess Classes, REXRevitAccess Enumerations, REXRevitAccess Fields, REXRevitAccess Methods, REXRevitAccess Properties

REXRevitAccess.REXRevitAccess Constructor

REXRevitAccess.REXRevitAccess Constructor
REXRevitAccess Class REX.Common Namespace REXRevitAccess Class

Initializes a new instance of the REXRevitAccess class.

C#
public REXRevitAccess(REXApplication App);
Parameters
Parameters | Description
App | The reference to a REXApplication object.
Description
Class

REXRevitAccess Class

Links
REXRevitAccess Class, REX.Common Namespace, REXRevitAccess Class

REXRevitAccess.Versions Class

REXRevitAccess.Versions Class
REXRevitAccess Class Legend Members Versions Fields

Constants for all known versions.

Class Hierarchy
C#
public class Versions;
Description
Class

REXRevitAccess Class

Versions Fields
Versions Fields | Description
v2008 |
v2008_SP1 |
v2008_SP2 |
v2008_SP3 |
v2008_SP4 |