REXUI.FindHiddenCommand Method (REXUI.CommandOptions)

REXUI.FindHiddenCommand Method (REXUI.CommandOptions)
REXUI Class REX.Common Namespace REXUI Class

Determines whether the input command is hidden.

C#
public bool FindHiddenCommand(REXUI.CommandOptions command);
Parameters
Parameters | Description
command | The command.
Returns

Returns true if succeeded.

Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class

REXUI.FindHiddenCommand Method (string)

REXUI.FindHiddenCommand Method (string)
REXUI Class REX.Common Namespace REXUI Class

Finds the hidden command.

C#
public bool FindHiddenCommand(string Name);
Parameters
Parameters | Description
Name | The name of the command.
Returns

Returns true if succeeded.

Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class

REXUI.GetAboutLink Method

REXUI.GetAboutLink Method
REXUI Class REX.Common Namespace REXUI Class

Gets the about link.

C#
public FrameworkElement GetAboutLink();
Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class

REXUI.GetDialog Method

REXUI.GetDialog Method
REXUI Class REX.Common Namespace REXUI Class

Gets the dialog control.

C#
public FrameworkElement GetDialog();
Returns

Returns dialog's container.

Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class

REXUI.GetHelpLink Method

REXUI.GetHelpLink Method
REXUI Class REX.Common Namespace REXUI Class

Gets the help link.

C#
public FrameworkElement GetHelpLink();
Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class

REXUI.GetList Method

REXUI.GetList Method
REXUI Class REX.Common Namespace REXUI Class

This is GetList, a member of class REXUI.

C#
public ListView GetList();
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class

REXUI.GetLogo Method

REXUI.GetLogo Method
REXUI Class REX.Common Namespace REXUI Class

Gets the reference to PictureBox which contains logo.

C#
public Image GetLogo();
Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class

REXUI.GetMenu Method

REXUI.GetMenu Method
REXUI Class REX.Common Namespace REXUI Class

Gets the menu control.

C#
public Menu GetMenu();
Returns

Returns menu strip control.

Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class

REXUI.GetMenuBar Method

REXUI.GetMenuBar Method
REXUI Class REX.Common Namespace REXUI Class

Gets the menu bar.

C#
public ToolBar GetMenuBar();
Returns

Returns menu control.

Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class

REXUI.GetNote Method

REXUI.GetNote Method
REXUI Class REX.Common Namespace REXUI Class

Gets the note control.

C#
public FrameworkElement GetNote();
Returns

Returns html note's container.

Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class

REXUI.GetNoteWebBrowser Method

REXUI.GetNoteWebBrowser Method
REXUI Class REX.Common Namespace REXUI Class

Gets the note web browser control.

C#
public WebBrowser GetNoteWebBrowser();
Returns

Returns web browser control.

Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class

REXUI.GetStatus Method

REXUI.GetStatus Method
REXUI Class REX.Common Namespace REXUI Class

Gets the status control.

C#
public StatusBar GetStatus();
Returns

Returns status control.

Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class

REXUI.GetStatusHeaderLabel Method

REXUI.GetStatusHeaderLabel Method
REXUI Class REX.Common Namespace REXUI Class

Gets the status header label.

C#
public Label GetStatusHeaderLabel();
Returns

Returns label which represents header placed on status bar.

Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class

REXUI.GetStatusLabel Method

REXUI.GetStatusLabel Method
REXUI Class REX.Common Namespace REXUI Class

Gets the status label.

C#
public Label GetStatusLabel();
Returns

Returns label placed on status bar.

Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class

REXUI.GetStatusProgress Method

REXUI.GetStatusProgress Method
REXUI Class REX.Common Namespace REXUI Class

Gets the status progress.

C#
public ProgressBar GetStatusProgress();
Returns

Returns progress bar placed on status bar.

Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class

REXUI.GetToolBar Method

REXUI.GetToolBar Method
REXUI Class REX.Common Namespace REXUI Class

Gets the tool bar.

C#
public ToolBar GetToolBar();
Returns

Returns tool bar control.

Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class

REXUI.GetToolBarInner Method

REXUI.GetToolBarInner Method
REXUI Class REX.Common Namespace REXUI Class

Gets the tool bar inner.

C#
public ToolBar GetToolBarInner();
Returns

Returns tool bar control.

Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class

REXUI.GetToolbox Method

REXUI.GetToolbox Method
REXUI Class REX.Common Namespace REXUI Class

Gets the toolbox control.

C#
public REXToolbox GetToolbox();
Returns

Returns the tool box control.

Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class

REXUI.GetViewer Method

REXUI.GetViewer Method
REXUI Class REX.Common Namespace REXUI Class

Gets the viewer's container.

C#
public FrameworkElement GetViewer();
Returns

Returns the viewer's container.

Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class

REXUI.GetWindow Method

REXUI.GetWindow Method
REXUI Class REX.Common Namespace REXUI Class

Gets the reference to main form.

C#
public Window GetWindow();
Returns

Returns the reference to main form.

Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class

REXUI.HideAboutControls Method

REXUI.HideAboutControls Method
REXUI Class REX.Common Namespace REXUI Class

This is HideAboutControls, a member of class REXUI.

C#
public void HideAboutControls();
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class

REXUI.HideAboutLink Method

REXUI.HideAboutLink Method
REXUI Class REX.Common Namespace REXUI Class

Hides the about link.

C#
public void HideAboutLink();
Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class

REXUI.HideCommand Method (REXUI.CommandOptions)

REXUI.HideCommand Method (REXUI.CommandOptions)
REXUI Class REX.Common Namespace REXUI Class

Hides the command.

C#
public void HideCommand(REXUI.CommandOptions command);
Parameters
Parameters | Description
command | The command.
Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class

REXUI.HideCommand Method (string)

REXUI.HideCommand Method (string)
REXUI Class REX.Common Namespace REXUI Class

Hides the command.

C#
public void HideCommand(string Name);
Parameters
Parameters | Description
Name | The name of the command.
Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class

REXUI.HideHelpLink Method

REXUI.HideHelpLink Method
REXUI Class REX.Common Namespace REXUI Class

Hides the help link.

C#
public void HideHelpLink();
Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class

REXUI.LoadNoteUrl Method

REXUI.LoadNoteUrl Method
REXUI Class REX.Common Namespace REXUI Class

Loads the URL to note control.

C#
public void LoadNoteUrl(string URL);
Parameters
Parameters | Description
URL | The URL.
Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class

REXUI.RememberControl Method

REXUI.RememberControl Method
REXUI Class REX.Common Namespace REXUI Class

Remembers the active tab control in specified LayoutItem in ActivTabPage property.

C#
public void RememberControl(long Options, REXLayoutItem LayoutItem);
Parameters
Parameters | Description
Options | The layout's options.