Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXRevitAccess.Versions Class Members

REXRevitAccess.Versions Class Members
REXRevitAccess.Versions Class Legend
Members
Versions Fields
Versions Fields | Description
v2008 |
v2008_SP1 |
v2008_SP2 |
v2008_SP3 |
v2008_SP4 |
v2009_A |
v2009_A2 |

Members

Legend
Legend
Data Member
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

Legend

Legend
REXRevitContextAccess Class
Legend
Constructor
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXRevitContextAccess Class Members

REXRevitContextAccess Class Members
REXRevitContextAccess Class Legend
Members
Public Methods
Public Method | Description
REXRevitContextAccess | This is REXRevitContextAccess, a member of class REXRevitContextAccess.
REXRevitContextAccess Methods
REXRevitContextAccess Methods | Description
Create | Reads some data from parent application and set system display units.
Destroy | Destroys and resets some objects connected to parent application.
Event | Events the specified ev.
Initialize | Initializes this instance.
Update | Reads some data from parent application and set system display units.

REXRevitContextAccess Methods

REXRevitContextAccess Methods
REXRevitContextAccess Class Legend
REXRevitContextAccess Methods
REXRevitContextAccess Methods | Description
Create | Reads some data from parent application and set system display units.
Destroy | Destroys and resets some objects connected to parent application.
Event | Events the specified ev.
Initialize | Initializes this instance.
Update | Reads some data from parent application and set system display units.

REXRevitContextAccess Class Public Methods

REXRevitContextAccess Class Public Methods
REXRevitContextAccess Class Legend
Public Methods
Public Method | Description
REXRevitContextAccess | This is REXRevitContextAccess, a member of class REXRevitContextAccess.

REXUI Enumerations

REXUI Enumerations
REXUI Class Legend
REXUI Enumerations
REXUI Enumerations | Description
CommandOptions | Identifies commands settings on the user interface.
SetupOptions | Identifies all elements of user interface.

REXUI Fields

REXUI Fields
REXUI Class Legend
REXUI Fields
REXUI Fields | Description
NameDialog | Name of dialog's container.
NameHSplit | Name of horizontal splitter.
NameHSplitGrid | Name of horizontal splitter.
NameHSplitGridBottom | Name of vertical splitter.
NameHSplitGridTop | Name of vertical splitter.
NameList | Name of list of options.
NameListImageListLarge | Name of large list of large images (32 x 32 pixels).
NameListImageListSmall | Name of large list of small images (16 x 16 pixels).
NameLogo | Name of logo's container.
NameMainPanel | Name of main panel which contains all controls.
NameMenu | Name of menu bar.
NameNote | Name of note's container.
NameRightContainer | Name of inner tool strip container.
NameStatus | Name of status bar.
NameStatusHeaderLabel | Name of label which represents header placed on status bar.
NameStatusLabel | Name of label placed on status bar.
NameStatusProgress | Name of progress placed on status bar.
NameTabControl | Name of tab control.
NameTabDialog | Name of tab dialog.
NameTabNote | Name of tab note.
NameTabView | Name of tab view.
NameToolBar | Name of tool bar.
NameToolBarInner | Name of inner tool bar.
NameToolbox | Name of toolbox control.
NameToolMenu | Name of menu bar based on tool bar.
NameView | Name of view's container.
NameVSplit | Name of vertical splitter.
NameVSplitGrid | Name of vertical splitter.
NameVSplitGridLeft | Name of vertical splitter.
NameVSplitGridRight | Name of vertical splitter.

Fields (AutoDoc Folder)

Legend
Legend
Data Member
static

Legend

Legend
REXUI Class
Legend
Constructor
Enumeration
Data Member
static
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXUI Class Members

REXUI Class Members
REXUI Class Legend
Members
Public Methods
Public Method | Description
REXUI | Initializes a new instance of the REXUI class.
REXUI Enumerations
REXUI Enumerations | Description
CommandOptions | Identifies commands settings on the user interface.
SetupOptions | Identifies all elements of user interface.
REXUI Fields
REXUI Fields | Description
NameDialog | Name of dialog's container.
NameHSplit | Name of horizontal splitter.
NameHSplitGrid | Name of horizontal splitter.
NameHSplitGridBottom | Name of vertical splitter.
NameHSplitGridTop | Name of vertical splitter.
NameList | Name of list of options.
NameListImageListLarge | Name of large list of large images (32 x 32 pixels).
NameListImageListSmall | Name of large list of small images (16 x 16 pixels).
NameLogo | Name of logo's container.
NameMainPanel | Name of main panel which contains all controls.
NameMenu | Name of menu bar.
NameNote | Name of note's container.
NameRightContainer | Name of inner tool strip container.
NameStatus | Name of status bar.
NameStatusHeaderLabel | Name of label which represents header placed on status bar.
NameStatusLabel | Name of label placed on status bar.
NameStatusProgress | Name of progress placed on status bar.
NameTabControl | Name of tab control.
NameTabDialog | Name of tab dialog.
NameTabNote | Name of tab note.
NameTabView | Name of tab view.
NameToolBar | Name of tool bar.
NameToolBarInner | Name of inner tool bar.
NameToolbox | Name of toolbox control.
NameToolMenu | Name of menu bar based on tool bar.
NameView | Name of view's container.
NameVSplit | Name of vertical splitter.
NameVSplitGrid | Name of vertical splitter.
NameVSplitGridLeft | Name of vertical splitter.
NameVSplitGridRight | Name of vertical splitter.
REXUI Methods
REXUI Methods | Description
AddToolStrip | Adds the tool strip to repositioning.
FindHiddenCommand | Determines whether the input command is hidden.
FindHiddenCommand | Finds the hidden command.
GetAboutLink | Gets the about link.
GetDialog | Gets the dialog control.
GetHelpLink | Gets the help link.
GetList | This is GetList, a member of class REXUI.
GetLogo | Gets the reference to PictureBox which contains logo.
GetMenu | Gets the menu control.
GetMenuBar | Gets the menu bar.
GetNote | Gets the note control.
GetNoteWebBrowser | Gets the note web browser control.
GetStatus | Gets the status control.
GetStatusHeaderLabel | Gets the status header label.
GetStatusLabel | Gets the status label.
GetStatusProgress | Gets the status progress.
GetToolBar | Gets the tool bar.
GetToolBarInner | Gets the tool bar inner.
GetToolbox | Gets the toolbox control.
GetViewer | Gets the viewer's container.
GetWindow | Gets the reference to main form.
HideAboutControls | This is HideAboutControls, a member of class REXUI.
HideAboutLink | Hides the about link.
HideCommand | Hides the command.
HideCommand | Hides the command.
HideHelpLink | Hides the help link.
LoadNoteUrl | Loads the URL to note control.
RememberControl | Remembers the active tab control in specified LayoutItem in ActivTabPage property.
SetLogo | Sets the logo image.
SetupControl | Setups the main control according to default settings.
SetupControl | Setups the main control according to layout item settings.
ShowCommand | Shows the command.
ShowCommand | Shows the command.
REXUI Properties
REXUI Properties | Description
MainControl | Gets or sets the main control.
MainWindow | Gets or sets the main form.

Members

Legend
Legend
Constructor
Enumeration