Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.GetBaseMinValue Method

REXEditControlEngine.GetBaseMinValue Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets the minimum value and converts it to base units.

C#
public double GetBaseMinValue();
Returns

The value.

Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.GetComplexDataBaseValue Method

REXEditControlEngine.GetComplexDataBaseValue Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Get the values and convert it to base units.

C#
public List<double> GetComplexDataBaseValue();
Returns

The list of values.

Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.GetComplexDataInterfaceValue Method

REXEditControlEngine.GetComplexDataInterfaceValue Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Get the values and convert it to interface units.

C#
public List<double> GetComplexDataInterfaceValue(REXInterfaceType interfaceType);
Parameters
Parameters | Description
interfaceType | The product context.
Returns

The list of values.

Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.GetComplexDoubleValue Method

REXEditControlEngine.GetComplexDoubleValue Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets the complex (list) value of the double type.

C#
public virtual List<double> GetComplexDoubleValue();
Returns

The list of values.

Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.GetComplexStringValue Method

REXEditControlEngine.GetComplexStringValue Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Returns a complex string list.

C#
public List<string> GetComplexStringValue();
Returns

The list of values.

Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.GetControl Method

REXEditControlEngine.GetControl Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets the control.

C#
public IEditControl GetControl();
Returns

Returns the control.

Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.GetDataBaseValue Method

REXEditControlEngine.GetDataBaseValue Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets the value and converts it to base units.

C#
public double GetDataBaseValue();
Returns

The value.

Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.GetDataInterfaceValue Method

REXEditControlEngine.GetDataInterfaceValue Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets the value and converts it to interface units.

C#
public double GetDataInterfaceValue(REXInterfaceType interfaceType);
Parameters
Parameters | Description
interfaceType | The product context.
Returns

The value.

Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.GetFullName Method

REXEditControlEngine.GetFullName Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets the full name.

C#
public string GetFullName();
Returns

The full name.

Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.GetInterfaceMaxValue Method

REXEditControlEngine.GetInterfaceMaxValue Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets the maximum value and converts it to interface units.

C#
public double GetInterfaceMaxValue(REXInterfaceType interfaceType);
Parameters
Parameters | Description
interfaceType | The product context.
Returns

The value.

Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.GetInterfaceMinValue Method

REXEditControlEngine.GetInterfaceMinValue Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets the minimum value and converts it to interface units.

C#
public double GetInterfaceMinValue(REXInterfaceType interfaceType);
Parameters
Parameters | Description
interfaceType | The product context.
Returns

The value.

Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.GetLastCorrectValueStr Method

REXEditControlEngine.GetLastCorrectValueStr Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets the last correct stored value.

C#
public String GetLastCorrectValueStr();
Returns

The correct value.

Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.GetState Method

REXEditControlEngine.GetState Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets the current state of the control.

C#
public EControlState GetState();
Returns

The state of the control.

Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.GetStringValue Method

REXEditControlEngine.GetStringValue Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Returns the original text.

C#
public string GetStringValue();
Returns

The text value.

Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.GetUniqueName Method

REXEditControlEngine.GetUniqueName Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Returns the Unique ID generated for the current instance of the engine.

C#
public string GetUniqueName();
Returns

The unique ID.

Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.GetUnitName Method

REXEditControlEngine.GetUnitName Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets the name of the unit from EnumUnits type.

C#
public static string GetUnitName(Autodesk.REX.Framework.EUnitType u);
Parameters
Parameters | Description
u | The unit type.
Returns

Returns unit name.

Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.GetValue Method

REXEditControlEngine.GetValue Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets the value of the double type.

C#
public virtual double GetValue();
Returns

The value.

Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.IsInEditMode Method