Parameters | Description
Name | The name of the layout.
GroupName | Name of the group.
Description | The description.
Dialog | The dialog control.
BottomDialog | The bottom dialog control.
LayoutImage | The layout image.
Description
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class

REXLayout.AddLayout_OptionsList_Menu_BottomDialog_RightDialogAndHtmlNoteOnTabs Method

REXLayout.AddLayout_OptionsList_Menu_BottomDialog_RightDialogAndHtmlNoteOnTabs Method
REXLayout Class REX.Common Namespace REXLayout Class

Adds the predefined layout which contains options list, dialog and html note on tabs on the right side, secound dialog on the bottom and standard menu.

C#
public void AddLayout_OptionsList_Menu_BottomDialog_RightDialogAndHtmlNoteOnTabs(string Name, string GroupName, string Description, Control Dialog, Control BottomDialog, ImageSource LayoutImage);
Parameters
Parameters | Description
Name | The name of the layout.
GroupName | Name of the group.
Description | The description.
Dialog | The dialog control.
BottomDialog | The bottom dialog control.
LayoutImage | The layout image.
Description
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class

REXLayout.AddLayout_OptionsList_Menu_RightDialog Method

REXLayout.AddLayout_OptionsList_Menu_RightDialog Method
REXLayout Class REX.Common Namespace REXLayout Class

Adds the predefined layout which contains options list, one dialog and standard menu.

C#
public void AddLayout_OptionsList_Menu_RightDialog(string Name, string GroupName, string Description, Control Dialog, ImageSource LayoutImage);
Parameters
Parameters | Description
Name | The name of the layout.
GroupName | Name of the group.
Description | The description.
Dialog | The dialog control.
LayoutImage | The layout image.
Description
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class

REXLayout.AddLayout_OptionsList_Menu_RightDialogAndViewAndHtmlNoteOnTabs Method

REXLayout.AddLayout_OptionsList_Menu_RightDialogAndViewAndHtmlNoteOnTabs Method
REXLayout Class REX.Common Namespace REXLayout Class

Adds the predefined layout which contains options list, one dialog, view (or dialog), html note on tabs and standard menu.

C#
public void AddLayout_OptionsList_Menu_RightDialogAndViewAndHtmlNoteOnTabs(string Name, string GroupName, string Description, Control Dialog, Control View, ImageSource LayoutImage);
Parameters
Parameters | Description
Name | The name of the layout.
GroupName | Name of the group.
Description | The description.
Dialog | The dialog control.
View | The view control.
LayoutImage | The layout image.
Description
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class

REXLayout.AddLayout_OptionsList_Menu_RightDialogAndViewOnTabs Method

REXLayout.AddLayout_OptionsList_Menu_RightDialogAndViewOnTabs Method
REXLayout Class REX.Common Namespace REXLayout Class

Adds the predefined layout which contains options list, one dialog and view (or dialog) on tabs and standard menu.

C#
public void AddLayout_OptionsList_Menu_RightDialogAndViewOnTabs(string Name, string GroupName, string Description, Control Dialog, Control View, ImageSource LayoutImage);
Parameters
Parameters | Description
Name | The name of the layout.
GroupName | Name of the group.
Description | The description.
Dialog | The dialog control.
View | The view control.
LayoutImage | The layout image.
Description
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class

REXLayout.AddLayout_OptionsList_ToolBarMenu_ToolBar_BottomDialog_RightDialog Method

REXLayout.AddLayout_OptionsList_ToolBarMenu_ToolBar_BottomDialog_RightDialog Method
REXLayout Class REX.Common Namespace REXLayout Class

Adds the predefined layout which contains options list, first dialog on the right side and secound dialog on the bottom, tool bar as menu and tool bar.

C#
public void AddLayout_OptionsList_ToolBarMenu_ToolBar_BottomDialog_RightDialog(string Name, string GroupName, string Description, Control Dialog, Control BottomDialog, ImageSource LayoutImage);
Parameters
Parameters | Description
Name | The name of the layout.
GroupName | Name of the group.
Description | The description.
Dialog | The dialog.
BottomDialog | The bottom dialog.
LayoutImage | The layout image.
Description
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class

REXLayout.AddLayout_OptionsList_ToolBarMenu_ToolBar_BottomDialog_RightDialogAndHtmlNoteOnTabs Method

REXLayout.AddLayout_OptionsList_ToolBarMenu_ToolBar_BottomDialog_RightDialogAndHtmlNoteOnTabs Method
REXLayout Class REX.Common Namespace REXLayout Class

Adds the predefined layout which contains options list, dialog and html note on tabs on the right side, secound dialog on the bottom and tool bar as menu and tool bar.

C#
public void AddLayout_OptionsList_ToolBarMenu_ToolBar_BottomDialog_RightDialogAndHtmlNoteOnTabs(string Name, string GroupName, string Description, Control BottomDialog, Control Dialog, ImageSource LayoutImage);
Parameters
Parameters | Description
Name | The name of the layout.
GroupName | Name of the group.
Description | The description.
BottomDialog | The bottom dialog.
Dialog | The dialog.
LayoutImage | The layout image.
Description
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class

REXLayout.AddLayout_OptionsList_ToolBarMenu_ToolBar_RightDialog Method

REXLayout.AddLayout_OptionsList_ToolBarMenu_ToolBar_RightDialog Method
REXLayout Class REX.Common Namespace REXLayout Class

Adds the predefined layout which contains options list, one dialog, tool bar as menu and tool bar.

C#
public void AddLayout_OptionsList_ToolBarMenu_ToolBar_RightDialog(string Name, string GroupName, string Description, Control Dialog, ImageSource LayoutImage);
Parameters
Parameters | Description
Name | The name of the layout.
GroupName | Name of the group.
Description | The description.
Dialog | The dialog.
LayoutImage | The layout image.
Description
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class

REXLayout.AddLayout_OptionsList_ToolBarMenu_ToolBar_RightDialogAndViewOnTabs Method

REXLayout.AddLayout_OptionsList_ToolBarMenu_ToolBar_RightDialogAndViewOnTabs Method
REXLayout Class REX.Common Namespace REXLayout Class

Adds the predefined layout which contains options list, dialog and view (or dialog) on tabs, tool bar as menu and tool bar.

C#
public void AddLayout_OptionsList_ToolBarMenu_ToolBar_RightDialogAndViewOnTabs(string Name, string GroupName, string Description, Control Dialog, Control View, ImageSource LayoutImage);
Parameters
Parameters | Description
Name | The name of the layout.
GroupName | Name of the group.
Description | The description.
Dialog | The dialog.
View | The view.
LayoutImage | The layout image.
Description
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class

REXLayout.CalculateMainControlSize Method

REXLayout.CalculateMainControlSize Method
REXLayout Class REX.Common Namespace REXLayout Class

This is CalculateMainControlSize, a member of class REXLayout.

C#
public REXSetFormStruct CalculateMainControlSize();
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class

REXLayout.Clear Method

REXLayout.Clear Method
REXLayout Class REX.Common Namespace REXLayout Class

Clears all layouts items.

C#
public void Clear();
Description

Doesn't dispose controls.

Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class

REXLayout.DeSelect Method (REXLayoutItem)

REXLayout.DeSelect Method (REXLayoutItem)
REXLayout Class REX.Common Namespace REXLayout Class

Called after deselect the specified LayoutItem.

C#
public void DeSelect(REXLayoutItem LI);
Parameters
Parameters | Description
LI | The LayoutItem.
Description
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class