Gets or sets the transversal tension resistance (for timber).

C#
public double RE_TRTENS;
Description

The transversal tension resistance (for timber).

Class

REXMaterialCharacteristics Class

Links
REXMaterialCharacteristics Class, REX.ContentGenerator.Families Namespace, REXMaterialCharacteristics Class

REXMaterialCharacteristics.RO Property

REXMaterialCharacteristics.RO Property
REXMaterialCharacteristics Class REX.ContentGenerator.Families Namespace REXMaterialCharacteristics Class

Gets or sets the unit weight.

C#
public double RO;
Description

The unit weight.

Class

REXMaterialCharacteristics Class

Links
REXMaterialCharacteristics Class, REX.ContentGenerator.Families Namespace, REXMaterialCharacteristics Class

REXMaterialCharacteristics.RT Property

REXMaterialCharacteristics.RT Property
REXMaterialCharacteristics Class REX.ContentGenerator.Families Namespace REXMaterialCharacteristics Class

Gets or sets the design tensile strength.

C#
public double RT;
Description

The design tensile strength.

Class

REXMaterialCharacteristics Class

Links
REXMaterialCharacteristics Class, REX.ContentGenerator.Families Namespace, REXMaterialCharacteristics Class

REXMaterialDBDescription Class

REXMaterialDBDescription Class
REX.ContentGenerator.Families Namespace Legend Members Public Methods REXMaterialDBDescription Methods REXMaterialDBDescription Properties

Represents description of the material.

Class Hierarchy
C#
[Serializable()]
public class REXMaterialDBDescription : REXDBDescription;
Description
Namespace

REX.ContentGenerator.Families Namespace

Public Methods
Public Method | Description
REXMaterialDBDescription | Initializes a new instance of the REXMaterialDBDescription class.
REXMaterialDBDescription | Initializes a new instance of the REXMaterialDBDescription class.
REXMaterialDBDescription | Initializes a new instance of the REXMaterialDBDescription class.
REXMaterialDBDescription | Initializes a new instance of the REXMaterialDBDescription class.
REXMaterialDBDescription | Initializes a new instance of the REXMaterialDBDescription class.
REXMaterialDBDescription Methods
REXMaterialDBDescription Methods | Description
Clone | Creates a new object that is a copy of the current instance.
CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
GetName | Gets the name.
REXMaterialDBDescription Properties
REXMaterialDBDescription Properties | Description
Characteristics | Gets or sets characteristics.
Description | Gets or sets the description.
NAME | Gets or sets the material name.
Links
REX.ContentGenerator.Families Namespace, Legend, Members, Public Methods, REXMaterialDBDescription Methods, REXMaterialDBDescription Properties

REXMaterialDBDescription.REXMaterialDBDescription Constructor ()

REXMaterialDBDescription.REXMaterialDBDescription Constructor ()
REXMaterialDBDescription Class REX.ContentGenerator.Families Namespace REXMaterialDBDescription Class

Initializes a new instance of the REXMaterialDBDescription class.

C#
public REXMaterialDBDescription();
Description
Class

REXMaterialDBDescription Class

Links
REXMaterialDBDescription Class, REX.ContentGenerator.Families Namespace, REXMaterialDBDescription Class

REXMaterialDBDescription.REXMaterialDBDescription Constructor (REXMaterialDBDescription)

REXMaterialDBDescription.REXMaterialDBDescription Constructor (REXMaterialDBDescription)
REXMaterialDBDescription Class REX.ContentGenerator.Families Namespace REXMaterialDBDescription Class

Initializes a new instance of the REXMaterialDBDescription class.

C#
public REXMaterialDBDescription(REXMaterialDBDescription pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

REXMaterialDBDescription Class

Links
REXMaterialDBDescription Class, REX.ContentGenerator.Families Namespace, REXMaterialDBDescription Class

REXMaterialDBDescription.REXMaterialDBDescription Constructor (string)

REXMaterialDBDescription.REXMaterialDBDescription Constructor (string)
REXMaterialDBDescription Class REX.ContentGenerator.Families Namespace REXMaterialDBDescription Class

Initializes a new instance of the REXMaterialDBDescription class.

C#
public REXMaterialDBDescription(string dbName);
Parameters
Parameters | Description
dbName | The name of the database.
Description
Class

REXMaterialDBDescription Class

Links
REXMaterialDBDescription Class, REX.ContentGenerator.Families Namespace, REXMaterialDBDescription Class

REXMaterialDBDescription.REXMaterialDBDescription Constructor (string, string, DTableDataObjectCollection)

REXMaterialDBDescription.REXMaterialDBDescription Constructor (string, string, DTableDataObjectCollection)
REXMaterialDBDescription Class REX.ContentGenerator.Families Namespace REXMaterialDBDescription Class

Initializes a new instance of the REXMaterialDBDescription class.

C#
public REXMaterialDBDescription(string dir, string dbname, DTableDataObjectCollection col);
Parameters
Parameters | Description
dir | The directory.
dbname | The name of the database.
col | The collection.
Description
Class

REXMaterialDBDescription Class

Links
REXMaterialDBDescription Class, REX.ContentGenerator.Families Namespace, REXMaterialDBDescription Class

REXMaterialDBDescription.REXMaterialDBDescription Constructor (string, string, System.Data.DataRow)

REXMaterialDBDescription.REXMaterialDBDescription Constructor (string, string, System.Data.DataRow)
REXMaterialDBDescription Class REX.ContentGenerator.Families Namespace REXMaterialDBDescription Class

Initializes a new instance of the REXMaterialDBDescription class.

C#
public REXMaterialDBDescription(string dir, string dbname, System.Data.DataRow row);
Parameters
Parameters | Description
dir | The directory.
dbname | The name of the database.
row | The row.
Description
Class

REXMaterialDBDescription Class

Links
REXMaterialDBDescription Class, REX.ContentGenerator.Families Namespace, REXMaterialDBDescription Class

REXMaterialDBDescription.Clone Method

REXMaterialDBDescription.Clone Method
REXMaterialDBDescription Class REX.ContentGenerator.Families Namespace REXMaterialDBDescription Class

Creates a new object that is a copy of the current instance.

C#
public override object Clone();
Returns

A new object that is a copy of this instance.

Description
Class

REXMaterialDBDescription Class

Links
REXMaterialDBDescription Class, REX.ContentGenerator.Families Namespace, REXMaterialDBDescription Class

REXMaterialDBDescription.CompareTo Method

REXMaterialDBDescription.CompareTo Method
REXMaterialDBDescription Class REX.ContentGenerator.Families Namespace REXMaterialDBDescription Class

Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.

C#
public override int CompareTo(object obj);
Parameters
Parameters | Description
obj | An object to compare with this instance.
Returns

Returns a result of the comparison.

Description
Class

REXMaterialDBDescription Class

Links
REXMaterialDBDescription Class, REX.ContentGenerator.Families Namespace, REXMaterialDBDescription Class

REXMaterialDBDescription.GetName Method

REXMaterialDBDescription.GetName Method
REXMaterialDBDescription Class REX.ContentGenerator.Families Namespace REXMaterialDBDescription Class

Gets the name.

C#
public override string GetName();
Returns

Returns the name.

Description
Class

REXMaterialDBDescription Class

Links
REXMaterialDBDescription Class, REX.ContentGenerator.Families Namespace, REXMaterialDBDescription Class

REXMaterialDBDescription.Characteristics Property

REXMaterialDBDescription.Characteristics Property
REXMaterialDBDescription Class REX.ContentGenerator.Families Namespace REXMaterialDBDescription Class