REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Sets the value of the double type.

C#
public void SetValue(Double value);
Parameters
Parameters | Description
value | The value.
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class

REXComboBox.SetValue Method (String)

REXComboBox.SetValue Method (String)
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Sets the value of the string type.

C#
public void SetValue(String value);
Parameters
Parameters | Description
value | The value.
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class

REXComboBox.ValidateComplexValue Method (List<double>)

REXComboBox.ValidateComplexValue Method (List<double>)
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Validates the complex (list) value of the double type.

C#
public bool ValidateComplexValue(List<double> values);
Parameters
Parameters | Description
values | The values to validate.
Returns

True if validated; otherwise false.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class

REXComboBox.ValidateComplexValue Method (List<string>)

REXComboBox.ValidateComplexValue Method (List<string>)
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Validates the complex (list) value of the string type.

C#
public bool ValidateComplexValue(List<string> values);
Parameters
Parameters | Description
values | The values to validate.
Returns

True if validated; otherwise false.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class

REXComboBox.ValidateComplexValue Method (String)

REXComboBox.ValidateComplexValue Method (String)
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Validates the complex (list) value of the string type.

C#
public bool ValidateComplexValue(String value);
Parameters
Parameters | Description
value | The value to validate.
Returns

True if validated; otherwise false.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class

REXComboBox.ValidateValue Method (Double)

REXComboBox.ValidateValue Method (Double)
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Validates the input value of the double type.

C#
public bool ValidateValue(Double value);
Parameters
Parameters | Description
value | The value to validate.
Returns

True if validated; otherwise false.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class

REXComboBox.ValidateValue Method (String)

REXComboBox.ValidateValue Method (String)
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Validates the value of the string type.

C#
public bool ValidateValue(String value);
Parameters
Parameters | Description
value | The value to validate.
Returns

True if validated; otherwise false.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class

REXComboBox.ValueFormat Method (Double)

REXComboBox.ValueFormat Method (Double)
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Returns a text containing an expression formatted according the current settings of the element.

C#
public string ValueFormat(Double value);
Parameters
Parameters | Description
value | The value to format.
Returns

The formatted text.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class

REXComboBox.ValueFormat Method (String)

REXComboBox.ValueFormat Method (String)
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Returns a text containing an expression formatted according the current settings of the element.

C#
public string ValueFormat(String value);
Parameters
Parameters | Description
value | The value to format.
Returns

The formatted text.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class

REXComboBox.ValueParse Method

REXComboBox.ValueParse Method
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Converts the specified text to the numeric value according the current settings of the element.

C#
public double ValueParse(String value);
Parameters
Parameters | Description
value | The text.
Returns

The converted value.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class

REXComboBox.BackgroundDisabledHidden Property

REXComboBox.BackgroundDisabledHidden Property
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Gets or sets the background for the disabled state of the control in the hidden background mode.

C#
[Browsable(true)]
[Category("Appearance")]
public Brush BackgroundDisabledHidden;
Description

The background.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class

REXComboBox.BackgroundDisabledStandard Property

REXComboBox.BackgroundDisabledStandard Property
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Gets or sets the background for the disabled state of the control.

C#
[Browsable(true)]
[Category("Appearance")]
[DefaultValue(typeof(Color), "LightBlue")]
public Brush BackgroundDisabledStandard;
Description

The background.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class

REXComboBox.BackgroundError Property

REXComboBox.BackgroundError Property
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Gets or sets the background for the Error state of the control.

C#
[Browsable(true)]
[Category("Appearance")]
[DefaultValue(typeof(Color), "LightCoral")]
public Brush BackgroundError;
Description

The Error background.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class

REXComboBox.BackgroundNeutral Property

REXComboBox.BackgroundNeutral Property
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Gets or sets the background for the neutral state of the control.

C#
[Browsable(true)]
[Category("Appearance")]
[DefaultValue(typeof(SystemColors), "Window")]
public Brush BackgroundNeutral;
Description

The neutral background.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class

REXComboBox.BackgroundOK Property

REXComboBox.BackgroundOK Property
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Gets or sets the background for the OK state of the control.

C#
[Browsable(true)]
[Category("Appearance")]
[DefaultValue(typeof(Color), "LightGreen")]
public Brush BackgroundOK;
Description

The OK background.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class

REXComboBox.Complex Property

REXComboBox.Complex Property
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Gets or sets a value indicating whether this REXEditControlEngine supports complex (list) values.

C#
[Category("Complex")]
[Browsable(true)]
public bool Complex;
Description

True if the engine supports complex values; otherwise false.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class

REXComboBox.ComplexDoubleValue Property

REXComboBox.ComplexDoubleValue Property
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Gets or sets the complex double value.

C#
public ObservableCollection<double> ComplexDoubleValue;
Description

The complex double value.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class

REXComboBox.ComplexSeparator Property

REXComboBox.ComplexSeparator Property
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Gets or sets the complex (list) separator.

C#
[Category("Complex")]
[Browsable(true)]
[DefaultValue(";")]