GetRebar | Gets the rebar object due to the defined contour, the bar's type and the shape's database.
GetRebar | Gets the rebar object due to the defined contour, the bar's type and the shape's database.
GetRebar | Gets the rebar object due to the defined contour, the bar's type and the shape's database.
GetRebar | Gets the rebar object due to the defined contour, the bar's type and the shape's database.
GetRebar | Gets the rebar object due to the defined contour, the bar's type and the shape's database.
GetRebar | Gets the rebar object due to the defined contour, the bar's type and the shape's database.
GetRebar | Gets the rebar object due to the defined contour, the bar's type and the shape's database.
GetRebar | Gets the rebar object due to the defined contour, the bar's type and the shape's database.
GetRebar | Gets the rebar object due to the defined contour, the bar's type and the shape's database.
GetRebar | Gets the rebar object due to the defined contour, the bar's type and the shape's database.
GetRebar | Gets the rebar object due to the defined contour, the bar's type and the shape's database.
GetRebar | Gets the rebar object due to the defined contour, the bar's type and the shape's database.
GetRebar | Gets the rebar object due to the defined contour, the bar's type and the shape's database.
GetRebar | Gets the rebar object due to the defined contour, the bar's type and the shape's database.
GetRebar | Gets the rebar object due to the defined contour, the bar's type and the shape's database.
GetRebar | Gets the rebar object due to the defined contour, the bar's type and the shape's database.
GetRoundRebar | Gets the round rebar object due to parameters.
GetSpiralRebar | Gets the spiral rebar object due to parameters.
GetUserDatabaseDirectory | Returns directory for user databases of the specified category.
RegisterCustomFactory | Registers the custom factory.
REXFamilyConverter Properties
REXFamilyConverter Properties | Description
ContentMapper | Gets the mapper object.
Settings | Gets the settings.
Links
REX.ContentGenerator.Converters Namespace, Legend, Members, Public Methods, REXFamilyConverter Methods, REXFamilyConverter Properties

REXFamilyConverter.REXFamilyConverter Constructor

REXFamilyConverter.REXFamilyConverter Constructor
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace REXFamilyConverter Class

Initializes a new instance of the REXFamilyConverter class.

C#
public REXFamilyConverter();
Description
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, REXFamilyConverter Class

REXFamilyConverter.Close Method

REXFamilyConverter.Close Method
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace REXFamilyConverter Class

Clears collections, releases COM objects.

C#
public void Close();
Description
Remarks

It should be called before the end of the converter usage.

Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, REXFamilyConverter Class

REXFamilyConverter.FindFamily Method

REXFamilyConverter.FindFamily Method
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace REXFamilyConverter Class

Finds the REXFamilyType in the specific list.

C#
public REXFamilyType FindFamily(REXFamilyType pattern, List<REXFamilyType> families, bool assignDefault);
Parameters
Parameters | Description
pattern | The pattern.
families | The list of families.
assignDefault | If default family should be set.
Returns

Return the REXFamilyType object.

Description
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, REXFamilyConverter Class

REXFamilyConverter.GenerateMaps Method

REXFamilyConverter.GenerateMaps Method
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace REXFamilyConverter Class

Generates a file used in the mapping aliases system.

C#
public void GenerateMaps(string code, string materialDir, string sectionDir);
Parameters
Parameters | Description
code | The code.
materialDir | The material directory.
sectionDir | The section directory.
Description
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, REXFamilyConverter Class

REXFamilyConverter.GetDatabaseDirectory Method

REXFamilyConverter.GetDatabaseDirectory Method
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace Example REXFamilyConverter Class

Returns directory for databases of the specific category.

C#
public string GetDatabaseDirectory(ECategoryType category);
Description
Example

The example shows how to get directory for all databases of material category.

//Initializing the rex converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Getting directory.
string dir = rex.GetDatabaseDirectory(ECategoryType.MATERIAL);
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, REXFamilyConverter Class

REXFamilyConverter.GetDatabasePath Method

REXFamilyConverter.GetDatabasePath Method
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace Example REXFamilyConverter Class

Return a path for particular database of the specified category.

C#
public string GetDatabasePath(ECategoryType category, string dbname);
Description
Example

The example shows how to get database path of the material category.

//Initializing the rex converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Getting path.
string path = rex.GetDatabasePath(ECategoryType.MATERIAL, "Eurocode");
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, REXFamilyConverter Class

REXFamilyConverter.GetDBList Method (List<REXFamilyType>, List<string>, string, ECategoryType)

REXFamilyConverter.GetDBList Method (List<REXFamilyType>, List<string>, string, ECategoryType)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace Example REXFamilyConverter Class

Gets the list of database's records adequate for the list of input objects.

C#
public List<REXDBDescription> GetDBList(List<REXFamilyType> list, List<string> dbList, string dir, ECategoryType type);
Parameters
Parameters | Description
list | The list.
dbList | The list of databases.
dir | The directory.
type | The category of the element.
Returns

Returns the list of database's records.

Description
Example

The example shows how to get a list of records which exist in databases defined in the input list and fit to at least one specific element.

//Initializing the rex converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Definition of elements. In the current example they are created as empty families with alias names but they can be taken from different sources (e.g. Revit).
REXFamilyType fam1 = rex.GetEmptyFamilyOfAlias(REX.ContentGenerator.Families.EElementType.BEAM, "HEB 100", ECategoryType.SECTION_DB);
REXFamilyType fam2 = rex.GetEmptyFamilyOfAlias(REX.ContentGenerator.Families.EElementType.BEAM, "HEA 200", ECategoryType.SECTION_DB);
List<REXFamilyType> families = new List<REXFamilyType>() { fam1, fam2 };

//Database identification data.
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Prof";
List<string> databases = new List<string>() { "Otuapro", "CorusPro", "Aiscpro" };

//Getting the list of databases
List<REXDBDescription> dbList = rex.GetDBList(families, databases, directory, ECategoryType.SECTION_DB);
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, REXFamilyConverter Class

REXFamilyConverter.GetDBList Method (List<REXFamilyType>, string, ECategoryType)

REXFamilyConverter.GetDBList Method (List<REXFamilyType>, string, ECategoryType)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace Example REXFamilyConverter Class