Gets or sets the background for the disabled state of the control in the hidden background mode.

C#
[Browsable(true)]
[Category("Appearance")]
public Color ColorBackgroundDisabled;
Description

The background.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class

REXEditBox.ColorBackgroundError Property

REXEditBox.ColorBackgroundError Property
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets or sets the background for the Error state of the control.

C#
[Browsable(true)]
[Category("Appearance")]
[DefaultValue(typeof(Color), "LightCoral")]
public Color ColorBackgroundError;
Description

The Error background.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class

REXEditBox.ColorBackgroundNeutral Property

REXEditBox.ColorBackgroundNeutral Property
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets or sets the background for the neutral state of the control.

C#
[Browsable(true)]
[Category("Appearance")]
[DefaultValue(typeof(SystemColors), "Window")]
public Color ColorBackgroundNeutral;
Description

The neutral background.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class

REXEditBox.ColorBackgroundOK Property

REXEditBox.ColorBackgroundOK Property
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets or sets the background for the OK state of the control.

C#
[Browsable(true)]
[Category("Appearance")]
[DefaultValue(typeof(Color), "LightGreen")]
[Description("test")]
public Color ColorBackgroundOK;
Description

The OK background.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class

REXEditBox.ColorBackgroundStandard Property

REXEditBox.ColorBackgroundStandard Property
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets or sets the background for the disabled state of the control.

C#
[Browsable(true)]
[Category("Appearance")]
[DefaultValue(typeof(Color), "LightBlue")]
public Color ColorBackgroundStandard;
Description

The background.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class

REXEditBox.Complex Property

REXEditBox.Complex Property
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets or sets a value indicating whether this REXEditControlEngine supports complex (list) values.

C#
[Category("Complex")]
[Browsable(true)]
public Boolean Complex;
Description

True if the engine supports complex values; otherwise false.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class

REXEditBox.ComplexSeparator Property

REXEditBox.ComplexSeparator Property
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets or sets the complex (list) separator.

C#
[Category("Complex")]
[Browsable(true)]
[DefaultValue(";")]
public string ComplexSeparator;
Description

The complex separator.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class

REXEditBox.ComplexSpaceSeparator Property

REXEditBox.ComplexSpaceSeparator Property
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets or sets a value indicating whether a space should be respected as a list separator.

C#
[Category("Complex")]
[Browsable(true)]
public Boolean ComplexSpaceSeparator;
Description

True if space respected as a list separator; otherwise, false.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class

REXEditBox.ComplexUnitOnEnd Property

REXEditBox.ComplexUnitOnEnd Property
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets or sets a value indicating whether a unit symbol should be placed on the end of the formatted text.

C#
[Category("Complex")]
[Browsable(true)]
public Boolean ComplexUnitOnEnd;
Description

True if the unit one the end; otherwise, false.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class

REXEditBox.ControlState Property

REXEditBox.ControlState Property
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets the current state of the control.

C#
[Browsable(false)]
public EControlState ControlState;
Description

The state of the control.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class

REXEditBox.CorrectValue Property

REXEditBox.CorrectValue Property
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets or sets the correct value.

C#
[Browsable(false)]
public String CorrectValue;
Description

The correct value.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class

REXEditBox.DataType Property

REXEditBox.DataType Property
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets or sets the type of the data in the control.

C#
[Browsable(true)]
[Category("Data")]
public REX.Controls.Common.EControlType DataType;
Description

The type of the data.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class

REXEditBox.Enabled Property

REXEditBox.Enabled Property
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets or sets a value indicating whether the control can respond to user interaction.

C#
[Browsable(true)]
public new Boolean Enabled;
Returns

true if the control can respond to user interaction; otherwise, false. The default is true.

Description

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class

REXEditBox.EngineeringFormat Property

REXEditBox.EngineeringFormat Property
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets or sets a value indicating whether the text of the control should be formatted in according to the engineering (expotential) format.

C#
[Browsable(true)]
[Category("Data")]
[DefaultValue(false)]
public Boolean EngineeringFormat;
Description

True if engineering format; otherwise false.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class

REXEditBox.Epsilon Property

REXEditBox.Epsilon Property
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets or sets the accuracy.

C#
[Browsable(true)]
public double Epsilon;
Description

The accuracy.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class

REXEditBox.InvalidCharacters Property

REXEditBox.InvalidCharacters Property
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets or sets the list invalid characters (for the control in TEXT mode).

C#
[Browsable(true)]
public string InvalidCharacters;
Description

The list of invalid characters.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class

REXEditBox.MaxTokens Property

REXEditBox.MaxTokens Property
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets or sets the maximum number of elements in the complex mode (list).

C#
[Category("Complex")]
[Browsable(true)]
public int MaxTokens;
Description

The maximum number of elements.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class

REXEditBox.MinTokens Property

REXEditBox.MinTokens Property
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets or sets the minimum number of elements in the complex mode (list).

C#
[Category("Complex")]
[Browsable(true)]
public int MinTokens;
Description

The minimum number of elements.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class

REXEditBox.Multiline Property

REXEditBox.Multiline Property
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets or sets a value indicating whether this is a multiline T:System.Windows.Forms.TextBox control.

C#
[Browsable(false)]