public bool Modal(REXContext AppContext);
Parameters
Parameters | Description
AppContext | The application context.
Returns

Returns true if succeeded.

Description
Class

REXApplication Class

Links
REXApplication Class, REX.Common Namespace, REXApplication Class

REXApplication.OnCreate Method

REXApplication.OnCreate Method
REXApplication Class REX.Common Namespace REXApplication Class

Called when create application object.

C#
public virtual bool OnCreate();
Returns

Returns true if succeeded.

Description
Class

REXApplication Class

Links
REXApplication Class, REX.Common Namespace, REXApplication Class

REXApplication.RestoreCultureInfo Method

REXApplication.RestoreCultureInfo Method
REXApplication Class REX.Common Namespace REXApplication Class

Restores the culture info.

C#
public void RestoreCultureInfo();
Description
Class

REXApplication Class

Links
REXApplication Class, REX.Common Namespace, REXApplication Class

REXApplication.Show Method

REXApplication.Show Method
REXApplication Class REX.Common Namespace REXApplication Class

Shows this module.

C#
public virtual bool Show();
Returns

Returns true if succeeded.

Description
Class

REXApplication Class

Links
REXApplication Class, REX.Common Namespace, REXApplication Class

REXApplication.Context Property

REXApplication.Context Property
REXApplication Class REX.Common Namespace REXApplication Class

Get the reference to the old context.

C#
public REXApplicationContext Context;
Description

The context.

Class

REXApplication Class

Links
REXApplication Class, REX.Common Namespace, REXApplication Class

REXApplication.Context2 Property

REXApplication.Context2 Property
REXApplication Class REX.Common Namespace REXApplication Class

Get the context2.

C#
public REXContext Context2;
Description

The context2.

Class

REXApplication Class

Links
REXApplication Class, REX.Common Namespace, REXApplication Class

REXApplication.ContextProduct Property

REXApplication.ContextProduct Property
REXApplication Class REX.Common Namespace REXApplication Class

Get the context product from the old context structure.

C#
public REXProduct ContextProduct;
Description

The product context.

Class

REXApplication Class

Links
REXApplication Class, REX.Common Namespace, REXApplication Class

REXApplication.ContextProduct2 Property

REXApplication.ContextProduct2 Property
REXApplication Class REX.Common Namespace REXApplication Class

Get the context product2.

C#
public REXContextProduct ContextProduct2;
Description

The product2 context.

Class

REXApplication Class

Links
REXApplication Class, REX.Common Namespace, REXApplication Class

REXApplication.ThisApplication Property

REXApplication.ThisApplication Property
REXApplication Class REX.Common Namespace REXApplication Class

This is ThisApplication, a member of class REXApplication.

C#
public REXApplication ThisApplication;
Class

REXApplication Class

Links
REXApplication Class, REX.Common Namespace, REXApplication Class

REXApplication.ThisContext Property

REXApplication.ThisContext Property
REXApplication Class REX.Common Namespace REXApplication Class

This is ThisContext, a member of class REXApplication.

C#
public REXContext ThisContext;
Class

REXApplication Class

Links
REXApplication Class, REX.Common Namespace, REXApplication Class

REXApplication.ThisExtension Property

REXApplication.ThisExtension Property
REXApplication Class REX.Common Namespace REXApplication Class

This is ThisExtension, a member of class REXApplication.

C#
public REXExtension ThisExtension;
Class

REXApplication Class

Links
REXApplication Class, REX.Common Namespace, REXApplication Class

REXApplication.Visible Property

REXApplication.Visible Property
REXApplication Class REX.Common Namespace REXApplication Class

Get or set a value indicating whether this REXApplication is visible.

C#
public virtual bool Visible;
Description

true if visible; otherwise, false.

Class

REXApplication Class

Links
REXApplication Class, REX.Common Namespace, REXApplication Class

REXDFM Class

REXDFM Class
REX.Common Namespace Legend Members Public Methods REXDFM Classes REXDFM Delegates REXDFM Events REXDFM Methods REXDFM Properties

Manages UI controls registered in it.

Class Hierarchy
C#
public class REXDFM : REXExtensionObject;
Description

It provides support for Revit Extension units.

Namespace

REX.Common Namespace

Public Methods
Public Method | Description
REXDFM | Initializes a new instance of the REXDFM class.
REXDFM | Initializes a new instance of the REXDFM class.
REXDFM | Initializes a new instance of the REXDFM class.
REXDFM Classes
REXDFM Classes | Description
DisplayDefinition | Represents the display settings of the specified unit category.
REXDFM Delegates
REXDFM Delegates | Description
EventHandlerChange | Delegate to the event handler changes.
EventHandlerLost | Delegate to the event handler lost focus.
REXDFM Events
REXDFM Events | Description
ControlUnitObjectError | Raises when data is changed on Control and some error was occur.
ControlUnitObjectLostFocus | Raises when Control losts focus.
ControlUnitObjectOk | Raises when data is changed on Control and no errors.
REXDFM Methods
REXDFM Methods | Description
AddDisplayUnitObject | Registers an object which implements the IUnitObject interface.
AddDisplayUnitObject | Registers an object which implements the IUnitObject interface.
AddDisplayUnitObject | Registers an object which implements the IUnitObject interface.
AddDisplayUnitObject | Registers an object which implements the IUnitObject interface.
AddUnitObject | Registers an object which implements the IUnitObject interface.
AddUnitObject | Registers an object which implements the IUnitObject interface.
AddUnitObject | Registers an object which implements the IUnitObject interface.
AddUnitObject | Registers an object which implements the IUnitObject interface.
AfterParamsChange | Method called after parameters change.
BeforeParamsChange | Method called before parameters change.
Clear | Clears this instance.
CreateGroupControl | Creates the group of controls from collection of controls and all childrenss.
CreateGroupControl | Creates the group of controls from all childrens.
CreateGroupControl | Creates the group of controls from collection of controls and all childrenss.
CreateGroupControl | Creates the group of controls from all childrens.
GetComplexDataBase | Gets the values and convert it to base units.
GetComplexDataBase | Gets the values and converts them to base units.
GetComplexDataDisplay | Gets the values and convert it to display units.
GetComplexDataDisplay | Gets the values and convert it to display units.
GetComplexDataInterface | Gets the values and convert it to interface units.
GetComplexDataInterface | Gets the values and converts it to interface units.
GetDataBase | Gets the value and converts it to base units.
GetDataBase | Gets the value and converts it to base units.
GetDataDisplay | Gets the value and converts it to display units.
GetDataDisplay | Gets the value and converts it to display units.
GetDataInterface | Gets the value and converts it to interface units.
GetDataInterface | Gets the value and converts it to interface units.
GetDataText | Gets the current text.
GetDataText | Gets the current text.
GetObjectsOfNotOkState | Gets the list of registered objects which are in a state other then OK.
RemoveUnitObject | Removes the unit object.
RemoveUnitObject | Removes the unit object.
SetBaseMaxValue | Sets the maximum value defined in base units.
SetBaseMaxValue | Sets the maximum value defined in base units.
SetBaseMinValue | Sets the minimum value in base units.
SetBaseMinValue | Sets the minimum value in base units.
SetComplexDataBase | Sets the list of values in base units.
SetComplexDataBase | Sets the list of values in base units.
SetComplexDataDisplay | Sets the list of values defined in display units.
SetComplexDataDisplay | Sets the list of values defined in display units.