Legend
Constructor
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

RVTDBSectionFactory Class Members

RVTDBSectionFactory Class Members
RVTDBSectionFactory Class Legend
Members
Public Methods
Public Method | Description
RVTDBSectionFactory | This is RVTDBSectionFactory, a member of class RVTDBSectionFactory.
RVTDBSectionFactory Methods
RVTDBSectionFactory Methods | Description
IsElementSupported | This is IsElementSupported, a member of class RVTDBSectionFactory.
Recalculate | This is Recalculate, a member of class RVTDBSectionFactory.

RVTDBSectionFactory Methods

RVTDBSectionFactory Methods
RVTDBSectionFactory Class Legend
RVTDBSectionFactory Methods
RVTDBSectionFactory Methods | Description
IsElementSupported | This is IsElementSupported, a member of class RVTDBSectionFactory.
Recalculate | This is Recalculate, a member of class RVTDBSectionFactory.

RVTDBSectionFactory Class Public Methods

RVTDBSectionFactory Class Public Methods
RVTDBSectionFactory Class Legend
Public Methods
Public Method | Description
RVTDBSectionFactory | This is RVTDBSectionFactory, a member of class RVTDBSectionFactory.

RVTFamilyConverter Events

RVTFamilyConverter Events
RVTFamilyConverter Class Legend
RVTFamilyConverter Events
RVTFamilyConverter Events | Description
EventElementGenerated | Occurs when element is generated (when the list of elements is used).

Legend

Legend
RVTFamilyConverter Class
Legend
Constructor
Property
Event
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

RVTFamilyConverter Class Members

RVTFamilyConverter Class Members
RVTFamilyConverter Class Legend
Members
Public Methods
Public Method | Description
RVTFamilyConverter | Initializes a new instance of the RVTFamilyConverter class.
RVTFamilyConverter | Initializes a new instance of the RVTFamilyConverter class.
RVTFamilyConverter Methods
RVTFamilyConverter Methods | Description
Close | Saves data to the Revit document, clears collections, releases objects.
CreateRebar | Creates the rebar element based on the input REXFamilyType_Rebar object.
GetCertifiedCategoryOfElement | Gets category of the certified element.
GetElement | Gets the Revit element created based on the REXFamilyType object.
GetElement | Gets the Revit element created based on the REXFamilyType object.
GetElement | Gets the Revit element created based on the REXFamilyType object.
GetElements | Gets the list of Revit elements created based on the list of REXFamilyTypes.
GetExistingNames | Returns the list of names existing for specific REXFamilyType object.
GetFamily | Gets the REXFamilyType object based on the input element.
GetFamily | Gets the REXFamilyType object based on the input element.
GetFamily | Gets the REXFamilyType object based on the input element.
GetRebarContour | Gets the rebar's contour based on the Revit element.
InitGlobal | Initializes lists of existing families from the Active Document.
IsElementSupported | This is IsElementSupported, a member of class RVTFamilyConverter.
RegisterCustomFactory | Registers the custom factory.
Temporary | This is Temporary, a member of class RVTFamilyConverter.
RVTFamilyConverter Properties
RVTFamilyConverter Properties | Description
ContentMapper | Gets the mapper object.
Settings | Gets the settings.
RVTFamilyConverter Events
RVTFamilyConverter Events | Description
EventElementGenerated | Occurs when element is generated (when the list of elements is used).

Members

Legend
Legend
Constructor
Property
Event
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

RVTFamilyConverter Methods

RVTFamilyConverter Methods
RVTFamilyConverter Class Legend
RVTFamilyConverter Methods
RVTFamilyConverter Methods | Description
Close | Saves data to the Revit document, clears collections, releases objects.
CreateRebar | Creates the rebar element based on the input REXFamilyType_Rebar object.
GetCertifiedCategoryOfElement | Gets category of the certified element.
GetElement | Gets the Revit element created based on the REXFamilyType object.
GetElement | Gets the Revit element created based on the REXFamilyType object.
GetElement | Gets the Revit element created based on the REXFamilyType object.
GetElements | Gets the list of Revit elements created based on the list of REXFamilyTypes.
GetExistingNames | Returns the list of names existing for specific REXFamilyType object.
GetFamily | Gets the REXFamilyType object based on the input element.
GetFamily | Gets the REXFamilyType object based on the input element.
GetFamily | Gets the REXFamilyType object based on the input element.
GetRebarContour | Gets the rebar's contour based on the Revit element.
InitGlobal | Initializes lists of existing families from the Active Document.
IsElementSupported | This is IsElementSupported, a member of class RVTFamilyConverter.
RegisterCustomFactory | Registers the custom factory.
Temporary | This is Temporary, a member of class RVTFamilyConverter.

RVTFamilyConverter Properties

RVTFamilyConverter Properties
RVTFamilyConverter Class Legend
RVTFamilyConverter Properties
RVTFamilyConverter Properties | Description
ContentMapper | Gets the mapper object.
Settings | Gets the settings.

RVTFamilyConverter Class Public Methods

RVTFamilyConverter Class Public Methods
RVTFamilyConverter Class Legend
Public Methods
Public Method | Description
RVTFamilyConverter | Initializes a new instance of the RVTFamilyConverter class.
RVTFamilyConverter | Initializes a new instance of the RVTFamilyConverter class.

Example

Example
RVTFamilyConverter.CreateRebar Method

The example shows how to get the rebar element in Revit based on specific shape from the database.

//Initializing converters.
REXFamilyConverter rex = new REXFamilyConverter();//Needed for proper rebar description.
RVTFamilyConverter rvt = new RVTFamilyConverter(commandData, true);

//The RebarType taken from the Revit project (the first one on the list).
System.Collections.IEnumerator it = commandData.Application.ActiveUIDocument.Document.RebarBarTypes.GetEnumerator();
it.MoveNext();
RebarBarType RevitRebarBarType = (RebarBarType)it.Current;
REXFamilyType_RebarBarType rbt = (REXFamilyType_RebarBarType)rvt.GetFamily(RevitRebarBarType);
//Using Element property to use particular element as RebarType.
rbt.Element=RevitRebarBarType;

//The RebarHook taken from the Revit project (the first one on the list).
it = commandData.Application.ActiveUIDocument.Document.RebarHookTypes.GetEnumerator();
it.MoveNext();
RebarHookType RevitRebarHookType = (RebarHookType)it.Current;
REXFamilyType_RebarHook rht = (REXFamilyType_RebarHook)rvt.GetFamily(RevitRebarHookType);
//Using Element property to use particular element as RebarType.
rht.Element = RevitRebarHookType;

//defining contour
List<REX.Common.Geometry.REXxyz> l = new List<REX.Common.Geometry.REXxyz>();

l.Add(new REX.Common.Geometry.REXxyz(0, 0));
l.Add(new REX.Common.Geometry.REXxyz(2, 0));

//Getting the rebar object.
REXFamilyType_Rebar r = rex.GetRebar(l, rbt,false,rht,rht,"barlib7_iso");

//Creating the rebar in Revit.
it = commandData.Application.ActiveUIDocument.Selection.Elements.GetEnumerator();
it.MoveNext();
Element host = (Element)it.Current;
Rebar RevitRebar = rvt.CreateRebar(r, host);

rvt.Close();//!!To clear structures and save data to the project.

Example

Example
RVTFamilyConverter.GetCertifiedCategoryOfElement Method

The example shows how to learn if some specific element is certified and get the category of it.

//Initializing the converter.