RVTMaterialPropertySetFactory | This is class REX.ContentGenerator.Converters.RVTMaterialPropertySetFactory.
RVTSectionFactory | This is class REX.ContentGenerator.Converters.RVTSectionFactory.
RVTSectionParamFactory | This is class REX.ContentGenerator.Converters.RVTSectionParamFactory.

Classes (AutoDoc Folder)

Legend
Legend
Class
abstract

REX.ContentGenerator.Converters Namespace Interfaces

REX.ContentGenerator.Converters Namespace Interfaces
REX.ContentGenerator.Converters Namespace Legend
Interfaces
Interface | Description
IRexContentSettings | Provides interface for the settings of the REXFamilyConverter.
IRvtContentSettings | Provides interface for the settings of the RVTFamilyConverter.

Legend

Legend
REX.ContentGenerator.Converters Namespace
Legend
Class
abstract
Interface
Enumeration
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REX.ContentGenerator.Converters Namespace Structs, Records, Enums

REX.ContentGenerator.Converters Namespace Structs, Records, Enums
REX.ContentGenerator.Converters Namespace Legend
Structs, Records, Enums
Struct, Record, Enum | Description
EDBAccess | Describes the access to databases.

Structs, Records, Enums (AutoDoc Folder)

Legend
Legend
Enumeration
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REX.ContentGenerator.Converters Namespace Types

REX.ContentGenerator.Converters Namespace Types
REX.ContentGenerator.Converters Namespace
Types
Type | Description
ElementGenerated | Delagate for the generation event (when the list of elements is used).

Legend

Legend
FieldParams Class
Legend
Constructor
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

FieldParams Class Members

FieldParams Class Members
FieldParams Class Legend
Members
Public Methods
Public Method | Description
FieldParams | Initializes a new instance of the FieldParams class.
FieldParams Methods
FieldParams Methods | Description
GetDefaultValue | Gets the default value.
GetDefaultValue | Gets the default value.
FieldParams Properties
FieldParams Properties | Description
database | Gets or sets the name in database.
display | Gets or sets the display name.
identity | Gets or sets a value indicating whether this field is used for identification.
name | Gets or sets the name.
power | Gets or sets the power.
template | Gets or sets a value indicating whether this field is used for template identification.
unitName | Gets or sets the name of the unit.
visible | Gets or sets a value indicating whether this FieldParams is visible.

FieldParams Methods

FieldParams Methods
FieldParams Class Legend
FieldParams Methods
FieldParams Methods | Description
GetDefaultValue | Gets the default value.
GetDefaultValue | Gets the default value.

FieldParams Properties

FieldParams Properties
FieldParams Class Legend
FieldParams Properties
FieldParams Properties | Description
database | Gets or sets the name in database.
display | Gets or sets the display name.
identity | Gets or sets a value indicating whether this field is used for identification.
name | Gets or sets the name.
power | Gets or sets the power.
template | Gets or sets a value indicating whether this field is used for template identification.
unitName | Gets or sets the name of the unit.
visible | Gets or sets a value indicating whether this FieldParams is visible.

FieldParams Class Public Methods

FieldParams Class Public Methods
FieldParams Class Legend
Public Methods
Public Method | Description
FieldParams | Initializes a new instance of the FieldParams class.

Legend

Legend
IRexContentSettings Interface
Legend
Method
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

IRexContentSettings Interface Members

IRexContentSettings Interface Members
IRexContentSettings Interface Legend
Members
IRexContentSettings Methods
IRexContentSettings Methods | Description
GetParamsForDisplayName | Gets parameters for the specified display name of the specified category.
GetParamsForField | Gets parameters for the specified name of the specified category.
GetResource | Gets the resource for the specified name of the specified category.
LoadCustomParametersFile | Loads the custom parameters file.
IRexContentSettings Properties
IRexContentSettings Properties | Description
CodeFilteredShapeAnalysis | Gets or sets a value indicating whether the filtered list of rebar shapes should be taken to consideration during rebars analysis.
DatabaseAccess | Gets or sets the database access.
Labels | Gets or sets a value indicating whether labels are taken to consideration during mapping.
MirroredShapeAnalysis | Gets or sets a value indicating whether mirrored rebar shapes should be taken to consideration during rebars analysis.
MultiSearch | Gets or sets a value indicating whether during searching databases multiply result should be returned (if false - when first result is found algorithm will stop - In case of GetDBList(List…) function will stop if any REXFamilyType in database will be found) .
MultiThread | Gets or sets a value indicating whether multithread operations should be used for database searching (only if DbRoot is used)..
ReleaseDBAfterEachAction | Gets or sets a value indicating whether the database should be released after each action (if not it will be kept in memory).
SupportUserDatabases | Gets or sets a value indicating whether users databases should be supported

IRexContentSettings Methods

IRexContentSettings Methods
IRexContentSettings Interface Legend
IRexContentSettings Methods
IRexContentSettings Methods | Description
GetParamsForDisplayName | Gets parameters for the specified display name of the specified category.
GetParamsForField | Gets parameters for the specified name of the specified category.
GetResource | Gets the resource for the specified name of the specified category.
LoadCustomParametersFile | Loads the custom parameters file.

IRexContentSettings Properties

IRexContentSettings Properties
IRexContentSettings Interface Legend
IRexContentSettings Properties
IRexContentSettings Properties | Description
CodeFilteredShapeAnalysis | Gets or sets a value indicating whether the filtered list of rebar shapes should be taken to consideration during rebars analysis.
DatabaseAccess | Gets or sets the database access.
Labels | Gets or sets a value indicating whether labels are taken to consideration during mapping.
MirroredShapeAnalysis | Gets or sets a value indicating whether mirrored rebar shapes should be taken to consideration during rebars analysis.
MultiSearch | Gets or sets a value indicating whether during searching databases multiply result should be returned (if false - when first result is found algorithm will stop - In case of GetDBList(List…) function will stop if any REXFamilyType in database will be found) .
MultiThread | Gets or sets a value indicating whether multithread operations should be used for database searching (only if DbRoot is used)..
ReleaseDBAfterEachAction | Gets or sets a value indicating whether the database should be released after each action (if not it will be kept in memory).
SupportUserDatabases | Gets or sets a value indicating whether users databases should be supported

Legend

Legend
IRvtContentSettings Interface
Legend
Method
Property