REXSectionTypeAnalyzer Class

Links
REXSectionTypeAnalyzer Class, REX.ContentGenerator.Geometry Namespace, REXSectionTypeAnalyzer Class

REXSectionTypeAnalyzer.RepairShapeLines Method

REXSectionTypeAnalyzer.RepairShapeLines Method
REXSectionTypeAnalyzer Class REX.ContentGenerator.Geometry Namespace REXSectionTypeAnalyzer Class

This is RepairShapeLines, a member of class REXSectionTypeAnalyzer.

C#
public static void RepairShapeLines(REXSectionShape shape);
Class

REXSectionTypeAnalyzer Class

Links
REXSectionTypeAnalyzer Class, REX.ContentGenerator.Geometry Namespace, REXSectionTypeAnalyzer Class

REXSectionTypeAnalyzer.TransformCompoundProfile Method

REXSectionTypeAnalyzer.TransformCompoundProfile Method
REXSectionTypeAnalyzer Class REX.ContentGenerator.Geometry Namespace REXSectionTypeAnalyzer Class

This is TransformCompoundProfile, a member of class REXSectionTypeAnalyzer.

C#
public static void TransformCompoundProfile(REXCompoundSectionProfile compoundProfile, TransformREXxyz trans);
Class

REXSectionTypeAnalyzer Class

Links
REXSectionTypeAnalyzer Class, REX.ContentGenerator.Geometry Namespace, REXSectionTypeAnalyzer Class

REXSectionTypeAnalyzer.TransformProfile Method

REXSectionTypeAnalyzer.TransformProfile Method
REXSectionTypeAnalyzer Class REX.ContentGenerator.Geometry Namespace REXSectionTypeAnalyzer Class

This is TransformProfile, a member of class REXSectionTypeAnalyzer.

C#
public static void TransformProfile(REXSectionProfile profile, TransformREXxyz trans);
Class

REXSectionTypeAnalyzer Class

Links
REXSectionTypeAnalyzer Class, REX.ContentGenerator.Geometry Namespace, REXSectionTypeAnalyzer Class

REXSectionTypeAnalyzer.TransformShape Method

REXSectionTypeAnalyzer.TransformShape Method
REXSectionTypeAnalyzer Class REX.ContentGenerator.Geometry Namespace REXSectionTypeAnalyzer Class

This is TransformShape, a member of class REXSectionTypeAnalyzer.

C#
public static void TransformShape(REXSectionShape shape, TransformREXxyz trans);
Class

REXSectionTypeAnalyzer Class

Links
REXSectionTypeAnalyzer Class, REX.ContentGenerator.Geometry Namespace, REXSectionTypeAnalyzer Class

REXSectionTypeAnalyzer.ValidateCircle Method (List<REXxyz>, out double, out REXxyz)

REXSectionTypeAnalyzer.ValidateCircle Method (List<REXxyz>, out double, out REXxyz)
REXSectionTypeAnalyzer Class REX.ContentGenerator.Geometry Namespace REXSectionTypeAnalyzer Class

This is ValidateCircle, a member of class REXSectionTypeAnalyzer.

C#
public static bool ValidateCircle(List<REXxyz> Points, out double radius, out REXxyz center);
Class

REXSectionTypeAnalyzer Class

Links
REXSectionTypeAnalyzer Class, REX.ContentGenerator.Geometry Namespace, REXSectionTypeAnalyzer Class

REXSectionTypeAnalyzer.ValidateCircle Method (REXSectionShape, out double, out REXxyz)

REXSectionTypeAnalyzer.ValidateCircle Method (REXSectionShape, out double, out REXxyz)
REXSectionTypeAnalyzer Class REX.ContentGenerator.Geometry Namespace REXSectionTypeAnalyzer Class

This is ValidateCircle, a member of class REXSectionTypeAnalyzer.

C#
public static bool ValidateCircle(REXSectionShape profile, out double radius, out REXxyz center);
Class

REXSectionTypeAnalyzer Class

Links
REXSectionTypeAnalyzer Class, REX.ContentGenerator.Geometry Namespace, REXSectionTypeAnalyzer Class

REXSectionTypeAnalyzer.VectorDrivenAnalysis Method

REXSectionTypeAnalyzer.VectorDrivenAnalysis Method
REXSectionTypeAnalyzer Class REX.ContentGenerator.Geometry Namespace REXSectionTypeAnalyzer Class

This is VectorDrivenAnalysis, a member of class REXSectionTypeAnalyzer.

C#
public virtual bool VectorDrivenAnalysis();
Class

REXSectionTypeAnalyzer Class

Links
REXSectionTypeAnalyzer Class, REX.ContentGenerator.Geometry Namespace, REXSectionTypeAnalyzer Class

REXSectionTypeAnalyzer_BOX1 Class

REXSectionTypeAnalyzer_BOX1 Class
REX.ContentGenerator.Geometry Namespace

This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_BOX1.

Class Hierarchy
C#
public class REXSectionTypeAnalyzer_BOX1 : REXSectionTypeAnalyzer_RECTHOLLOW;
Namespace

REX.ContentGenerator.Geometry Namespace

Links
REX.ContentGenerator.Geometry Namespace
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXSectionTypeAnalyzer_BOX2 Class

REXSectionTypeAnalyzer_BOX2 Class
REX.ContentGenerator.Geometry Namespace

This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_BOX2.

Class Hierarchy
C#
public class REXSectionTypeAnalyzer_BOX2 : REXSectionTypeAnalyzer;
Namespace

REX.ContentGenerator.Geometry Namespace

Links
REX.ContentGenerator.Geometry Namespace
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXSectionTypeAnalyzer_BOX3 Class

REXSectionTypeAnalyzer_BOX3 Class
REX.ContentGenerator.Geometry Namespace

This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_BOX3.

Class Hierarchy
C#
public class REXSectionTypeAnalyzer_BOX3 : REXSectionTypeAnalyzer;
Namespace

REX.ContentGenerator.Geometry Namespace

Links
REX.ContentGenerator.Geometry Namespace
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXSectionTypeAnalyzer_C Class

REXSectionTypeAnalyzer_C Class
REX.ContentGenerator.Geometry Namespace

This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_C.

Class Hierarchy
C#
public class REXSectionTypeAnalyzer_C : REXSectionTypeAnalyzer;
Namespace

REX.ContentGenerator.Geometry Namespace

Links
REX.ContentGenerator.Geometry Namespace
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXSectionTypeAnalyzer_CROSS Class

REXSectionTypeAnalyzer_CROSS Class
REX.ContentGenerator.Geometry Namespace

This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_CROSS.

Class Hierarchy
C#
public class REXSectionTypeAnalyzer_CROSS : REXSectionTypeAnalyzer;
Namespace

REX.ContentGenerator.Geometry Namespace

Links
REX.ContentGenerator.Geometry Namespace
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXSectionTypeAnalyzer_DRECT Class

REXSectionTypeAnalyzer_DRECT Class
REX.ContentGenerator.Geometry Namespace

This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_DRECT.

Class Hierarchy
C#
public class REXSectionTypeAnalyzer_DRECT : REXSectionTypeAnalyzer;
Namespace

REX.ContentGenerator.Geometry Namespace

Links
REX.ContentGenerator.Geometry Namespace
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXSectionTypeAnalyzer_I Class

REXSectionTypeAnalyzer_I Class
REX.ContentGenerator.Geometry Namespace

This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_I.

Class Hierarchy
C#
public class REXSectionTypeAnalyzer_I : REXSectionTypeAnalyzer;
Namespace

REX.ContentGenerator.Geometry Namespace

Links
REX.ContentGenerator.Geometry Namespace
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXSectionTypeAnalyzer_IASYM Class

REXSectionTypeAnalyzer_IASYM Class