public REXImageComboBoxItem(string Text, Image Image, bool Mark, Color ForeColor);
Parameters
Parameters | Description
Text | The text.
Mark | If set to true [mark].
ForeColor | Color of the foreground.
ImageIndex | The image.
Description
Class

REXImageComboBoxItem Class

Links
REXImageComboBoxItem Class, REX.Controls.Forms Namespace, REXImageComboBoxItem Class

REXImageComboBoxItem.REXImageComboBoxItem Constructor (string, Image, bool, Color, object)

REXImageComboBoxItem.REXImageComboBoxItem Constructor (string, Image, bool, Color, object)
REXImageComboBoxItem Class REX.Controls.Forms Namespace REXImageComboBoxItem Class

Initializes a new instance of a ImageComboItem class.

C#
public REXImageComboBoxItem(string Text, Image Image, bool Mark, Color ForeColor, object Tag);
Parameters
Parameters | Description
Text | The text.
Mark | If set to true [mark].
ForeColor | Color of the foreground.
Tag | The tag.
ImageIndex | The image.
Description
Class

REXImageComboBoxItem Class

Links
REXImageComboBoxItem Class, REX.Controls.Forms Namespace, REXImageComboBoxItem Class

REXImageComboBoxItem.REXImageComboBoxItem Constructor (string, int)

REXImageComboBoxItem.REXImageComboBoxItem Constructor (string, int)
REXImageComboBoxItem Class REX.Controls.Forms Namespace REXImageComboBoxItem Class

Initializes a new instance of a ImageComboItem class.

C#
public REXImageComboBoxItem(string Text, int ImageIndex);
Parameters
Parameters | Description
Text | The text.
ImageIndex | Index of the image.
Description
Class

REXImageComboBoxItem Class

Links
REXImageComboBoxItem Class, REX.Controls.Forms Namespace, REXImageComboBoxItem Class

REXImageComboBoxItem.REXImageComboBoxItem Constructor (string, int, bool)

REXImageComboBoxItem.REXImageComboBoxItem Constructor (string, int, bool)
REXImageComboBoxItem Class REX.Controls.Forms Namespace REXImageComboBoxItem Class

Initializes a new instance of a ImageComboItem class.

C#
public REXImageComboBoxItem(string Text, int ImageIndex, bool Mark);
Parameters
Parameters | Description
Text | The text.
ImageIndex | Index of the image.
Mark | If set to true [mark].
Description
Class

REXImageComboBoxItem Class

Links
REXImageComboBoxItem Class, REX.Controls.Forms Namespace, REXImageComboBoxItem Class

REXImageComboBoxItem.REXImageComboBoxItem Constructor (string, int, bool, Color)

REXImageComboBoxItem.REXImageComboBoxItem Constructor (string, int, bool, Color)
REXImageComboBoxItem Class REX.Controls.Forms Namespace REXImageComboBoxItem Class

Initializes a new instance of a ImageComboItem class.

C#
public REXImageComboBoxItem(string Text, int ImageIndex, bool Mark, Color ForeColor);
Parameters
Parameters | Description
Text | The text.
ImageIndex | Index of the image.
Mark | If set to true [mark].
ForeColor | Color of the foreground.
Description
Class

REXImageComboBoxItem Class

Links
REXImageComboBoxItem Class, REX.Controls.Forms Namespace, REXImageComboBoxItem Class

REXImageComboBoxItem.REXImageComboBoxItem Constructor (string, int, bool, Color, object)

REXImageComboBoxItem.REXImageComboBoxItem Constructor (string, int, bool, Color, object)
REXImageComboBoxItem Class REX.Controls.Forms Namespace REXImageComboBoxItem Class

Initializes a new instance of a ImageComboItem class.

C#
public REXImageComboBoxItem(string Text, int ImageIndex, bool Mark, Color ForeColor, object Tag);
Parameters
Parameters | Description
Text | The text.
ImageIndex | Index of the image.
Mark | If set to true [mark].
ForeColor | Color of the foreground.
Tag | The tag.
Description
Class

REXImageComboBoxItem Class

Links
REXImageComboBoxItem Class, REX.Controls.Forms Namespace, REXImageComboBoxItem Class

REXImageComboBoxItem.ToString Method

REXImageComboBoxItem.ToString Method
REXImageComboBoxItem Class REX.Controls.Forms Namespace REXImageComboBoxItem Class

Returns a T:System.String that represents the current T:System.Object.

C#
public override string ToString();
Returns

A T:System.String that represents the current T:System.Object.

Description
Class

REXImageComboBoxItem Class

Links
REXImageComboBoxItem Class, REX.Controls.Forms Namespace, REXImageComboBoxItem Class

REXImageComboBoxItem.ForegroundColor Property

REXImageComboBoxItem.ForegroundColor Property
REXImageComboBoxItem Class REX.Controls.Forms Namespace REXImageComboBoxItem Class

Gets or sets the color of the foreground.

C#
public Color ForegroundColor;
Description

The color of the foreground.

Class

REXImageComboBoxItem Class

Links
REXImageComboBoxItem Class, REX.Controls.Forms Namespace, REXImageComboBoxItem Class

REXImageComboBoxItem.Image Property

REXImageComboBoxItem.Image Property
REXImageComboBoxItem Class REX.Controls.Forms Namespace REXImageComboBoxItem Class

Gets or sets the image.

C#
public Image Image;
Description

The image.

Class

REXImageComboBoxItem Class

Links
REXImageComboBoxItem Class, REX.Controls.Forms Namespace, REXImageComboBoxItem Class

REXImageComboBoxItem.ImageIndex Property

REXImageComboBoxItem.ImageIndex Property
REXImageComboBoxItem Class REX.Controls.Forms Namespace REXImageComboBoxItem Class

Gets or sets the index of the image.

C#
public int ImageIndex;
Description

The index of the image.

Class

REXImageComboBoxItem Class

Links
REXImageComboBoxItem Class, REX.Controls.Forms Namespace, REXImageComboBoxItem Class

REXImageComboBoxItem.Mark Property

REXImageComboBoxItem.Mark Property
REXImageComboBoxItem Class REX.Controls.Forms Namespace REXImageComboBoxItem Class

Gets or sets a value indicating whether this ImageComboItem is a mark.

C#
public bool Mark;
Description

true if mark; otherwise, false.

Class

REXImageComboBoxItem Class

Links
REXImageComboBoxItem Class, REX.Controls.Forms Namespace, REXImageComboBoxItem Class

REXImageComboBoxItem.Tag Property

REXImageComboBoxItem.Tag Property
REXImageComboBoxItem Class REX.Controls.Forms Namespace REXImageComboBoxItem Class

Gets or sets the tag.

C#
public object Tag;
Description

The tag.

Class

REXImageComboBoxItem Class

Links
REXImageComboBoxItem Class, REX.Controls.Forms Namespace, REXImageComboBoxItem Class

REXImageComboBoxItem.Text Property

REXImageComboBoxItem.Text Property
REXImageComboBoxItem Class REX.Controls.Forms Namespace REXImageComboBoxItem Class

Gets or sets the text.

C#
public string Text;
Description

The text.

Class

REXImageComboBoxItem Class

Links
REXImageComboBoxItem Class, REX.Controls.Forms Namespace, REXImageComboBoxItem Class

REXImageComboBoxItem.Tooltip Property

REXImageComboBoxItem.Tooltip Property
REXImageComboBoxItem Class REX.Controls.Forms Namespace REXImageComboBoxItem Class

Gets or sets the tooltip.

C#
public string Tooltip;
Description

The tooltip.

Class

REXImageComboBoxItem Class

Links
REXImageComboBoxItem Class, REX.Controls.Forms Namespace, REXImageComboBoxItem Class

REXImageComboBoxItem.UseTextAsTooltip Property

REXImageComboBoxItem.UseTextAsTooltip Property
REXImageComboBoxItem Class REX.Controls.Forms Namespace REXImageComboBoxItem Class

Gets or sets a value indicating whether the text should be used as a Tooltip.

C#
public bool UseTextAsTooltip;
Description

True if text used as a tooltip; otherwise, false.

Class

REXImageComboBoxItem Class

Links
REXImageComboBoxItem Class, REX.Controls.Forms Namespace, REXImageComboBoxItem Class

REXImageComboBoxItem.VisibleOnList Property

REXImageComboBoxItem.VisibleOnList Property
REXImageComboBoxItem Class REX.Controls.Forms Namespace REXImageComboBoxItem Class

Gets or sets a value indicating whether item should be visible on the list.

C#
public bool VisibleOnList;
Description
Class

REXImageComboBoxItem Class

Links
REXImageComboBoxItem Class, REX.Controls.Forms Namespace, REXImageComboBoxItem Class

REXIndexLabel Class

REXIndexLabel Class
REX.Controls.Forms Namespace Legend Members Public Methods REXIndexLabel Methods REXIndexLabel Properties

Represents the REXIndexLabel control.

Class Hierarchy
C#
[System.ComponentModel.ToolboxItem(true)]