Interface

IREXExtension Interface

Links
IREXExtension Interface, REX.Common Namespace, IREXExtension Interface

IREXExtension.OnCommand Method

IREXExtension.OnCommand Method
IREXExtension Interface REX.Common Namespace IREXExtension Interface

Called when command.

C#
object OnCommand(ref REXCommand CommandStruct);
Parameters
Parameters | Description
CommandStruct | The command struct.
Returns

Returns result of command operation.

Description
Interface

IREXExtension Interface

Links
IREXExtension Interface, REX.Common Namespace, IREXExtension Interface

IREXExtension.OnCreate Method

IREXExtension.OnCreate Method
IREXExtension Interface REX.Common Namespace IREXExtension Interface

Creates needed structures and verify needs.

C#
void OnCreate();
Description
Interface

IREXExtension Interface

Links
IREXExtension Interface, REX.Common Namespace, IREXExtension Interface

IREXExtension.OnCreateDialogs Method

IREXExtension.OnCreateDialogs Method
IREXExtension Interface REX.Common Namespace IREXExtension Interface

Creates sub dialogs.

C#
void OnCreateDialogs();
Description
Interface

IREXExtension Interface

Links
IREXExtension Interface, REX.Common Namespace, IREXExtension Interface

IREXExtension.OnCreateLayout Method

IREXExtension.OnCreateLayout Method
IREXExtension Interface REX.Common Namespace IREXExtension Interface

Creates layout items and setups layout.

C#
void OnCreateLayout();
Description
Interface

IREXExtension Interface

Links
IREXExtension Interface, REX.Common Namespace, IREXExtension Interface

IREXExtension.OnDataLoad Method

IREXExtension.OnDataLoad Method
IREXExtension Interface REX.Common Namespace IREXExtension Interface

Called when data are loaded.

C#
bool OnDataLoad();
Returns

Returns true if succeeded.

Description
Interface

IREXExtension Interface

Links
IREXExtension Interface, REX.Common Namespace, IREXExtension Interface

IREXExtension.OnDataLoaded Method

IREXExtension.OnDataLoaded Method
IREXExtension Interface REX.Common Namespace IREXExtension Interface

Called when data are loaded.

C#
void OnDataLoaded(bool Result);
Parameters
Parameters | Description
Result | If set to true operation succeeded; Otherwise some errors found.
Description
Interface

IREXExtension Interface

Links
IREXExtension Interface, REX.Common Namespace, IREXExtension Interface

IREXExtension.OnDataSave Method

IREXExtension.OnDataSave Method
IREXExtension Interface REX.Common Namespace IREXExtension Interface

Called when data are saved.

C#
bool OnDataSave();
Returns

Returns true if succeeded.

Description
Interface

IREXExtension Interface

Links
IREXExtension Interface, REX.Common Namespace, IREXExtension Interface

IREXExtension.OnDataSaved Method

IREXExtension.OnDataSaved Method
IREXExtension Interface REX.Common Namespace IREXExtension Interface

Called when data are saved.

C#
void OnDataSaved(bool Result);
Parameters
Parameters | Description
Result | If set to true operation succeeded; Otherwise some errors found.
Description
Interface

IREXExtension Interface

Links
IREXExtension Interface, REX.Common Namespace, IREXExtension Interface

IREXExtension.OnErrorSelected Method

IREXExtension.OnErrorSelected Method
IREXExtension Interface REX.Common Namespace IREXExtension Interface

Called when error selected on errors list dialog.

C#
void OnErrorSelected(REXErrorsEventArgs e);
Parameters
Parameters | Description
e | The Autodesk.REX.Framework.REXErrorsEventArgs instance containing the event data.
Description

Raises the ErrorSelected event.

Interface

IREXExtension Interface

Links
IREXExtension Interface, REX.Common Namespace, IREXExtension Interface

IREXExtension.OnEvent Method

IREXExtension.OnEvent Method
IREXExtension Interface REX.Common Namespace IREXExtension Interface

Called when event.

C#
object OnEvent(ref REXEvent EventStruct);
Parameters
Parameters | Description
EventStruct | The event struct.
Returns

Returns result of eventoperation.

Description
Interface

IREXExtension Interface

Links
IREXExtension Interface, REX.Common Namespace, IREXExtension Interface

IREXExtension.OnGetText Method

IREXExtension.OnGetText Method
IREXExtension Interface REX.Common Namespace IREXExtension Interface

Get specified text from resources.

C#
string OnGetText(string Name);
Parameters
Parameters | Description
Name | The name of string.
Returns

Returns specified text.

Description

Needed for obfuscated strings tables.

Interface

IREXExtension Interface

Links
IREXExtension Interface, REX.Common Namespace, IREXExtension Interface

IREXExtension.OnInitialize Method

IREXExtension.OnInitialize Method
IREXExtension Interface REX.Common Namespace IREXExtension Interface

Called when initialize.

C#
bool OnInitialize();
Returns

Returns true if succeeded.

Description
Interface

IREXExtension Interface

Links
IREXExtension Interface, REX.Common Namespace, IREXExtension Interface

IREXExtension.OnLoadTemplate Method

IREXExtension.OnLoadTemplate Method
IREXExtension Interface REX.Common Namespace IREXExtension Interface

Called when load template.

C#
bool OnLoadTemplate();
Parameters
Parameters | Description
Result | If set to true operation succeeded; Otherwise some errors found.
Description

Only if ExtensionContext.Control.StandardRunContext is equals to REXExtensionContext.REXStandardRunContext.OperationEditTemplate.

Interface

IREXExtension Interface

Links
IREXExtension Interface, REX.Common Namespace, IREXExtension Interface

IREXExtension.OnPreferencesChanged Method

IREXExtension.OnPreferencesChanged Method
IREXExtension Interface REX.Common Namespace IREXExtension Interface

Called when preferences changed.

C#
void OnPreferencesChanged();
Description
Interface

IREXExtension Interface

Links
IREXExtension Interface, REX.Common Namespace, IREXExtension Interface

IREXExtension.OnRun Method

IREXExtension.OnRun Method
IREXExtension Interface REX.Common Namespace IREXExtension Interface

Run process calculations or other operations.

C#
void OnRun();
Description
Interface

IREXExtension Interface

Links
IREXExtension Interface, REX.Common Namespace, IREXExtension Interface

IREXExtension.OnSaveTemplate Method

IREXExtension.OnSaveTemplate Method
IREXExtension Interface REX.Common Namespace IREXExtension Interface

Called when save template.

C#
bool OnSaveTemplate();
Parameters
Parameters | Description
Result | If set to true operation succeeded; Otherwise some errors found.
Description
Interface

IREXExtension Interface

Links
IREXExtension Interface, REX.Common Namespace, IREXExtension Interface

IREXExtension.OnSetData Method

IREXExtension.OnSetData Method
IREXExtension Interface REX.Common Namespace IREXExtension Interface

Get data from dialogs and sets Data's strucutres.

C#
void OnSetData();
Description
Interface

IREXExtension Interface

Links
IREXExtension Interface, REX.Common Namespace, IREXExtension Interface

IREXExtension.OnSetDialogs Method

IREXExtension.OnSetDialogs Method
IREXExtension Interface REX.Common Namespace IREXExtension Interface

Set data in dialogs.

C#
void OnSetDialogs();
Description
Interface

IREXExtension Interface

Links
IREXExtension Interface, REX.Common Namespace, IREXExtension Interface

IREXExtension.OnShowResults Method

IREXExtension.OnShowResults Method
IREXExtension Interface REX.Common Namespace IREXExtension Interface

Shows results.

C#
void OnShowResults();
Description
Interface

IREXExtension Interface

Links
IREXExtension Interface, REX.Common Namespace, IREXExtension Interface

IREXExtension.OnUpdateDialogs Method

IREXExtension.OnUpdateDialogs Method
IREXExtension Interface REX.Common Namespace IREXExtension Interface

Called when update dialogs.

C#
void OnUpdateDialogs();
Description

Currently is not used.

Interface

IREXExtension Interface

Links
IREXExtension Interface, REX.Common Namespace, IREXExtension Interface

IREXExtension2 Interface

IREXExtension2 Interface
REX.Common Namespace Legend Members IREXExtension2 Methods