REXMaterialProperties | Initializes a new instance of the REXMaterialProperties class.
REXMaterialProperties Methods
REXMaterialProperties Methods | Description
Clone | Creates a new object that is a copy of the current instance.
REXMaterialProperties Properties
REXMaterialProperties Properties | Description
DESCRIPTION | Gets or sets the detailed material description.
NAME | Gets or sets the material name.
RE_CODE | Gets or sets /1.
SECOND_NAME | Gets or sets the material's name (used for a steel to give an equivalent according to Eurocode).
THERM | Gets or sets the material type /for steel: thermal treatment-1 /for timber: natural-0, glued-1, glued KertoS specific for Kerto code-2, glued KertoQ specific for Kerto code-3, glued KertoS-4, glued KertoQ-5.

REXMaterialProperties Methods

REXMaterialProperties Methods
REXMaterialProperties Class Legend
REXMaterialProperties Methods
REXMaterialProperties Methods | Description
Clone | Creates a new object that is a copy of the current instance.

REXMaterialProperties Properties

REXMaterialProperties Properties
REXMaterialProperties Class Legend
REXMaterialProperties Properties
REXMaterialProperties Properties | Description
DESCRIPTION | Gets or sets the detailed material description.
NAME | Gets or sets the material name.
RE_CODE | Gets or sets /1.
SECOND_NAME | Gets or sets the material's name (used for a steel to give an equivalent according to Eurocode).
THERM | Gets or sets the material type /for steel: thermal treatment-1 /for timber: natural-0, glued-1, glued KertoS specific for Kerto code-2, glued KertoQ specific for Kerto code-3, glued KertoS-4, glued KertoQ-5.

REXMaterialProperties Class Public Methods

REXMaterialProperties Class Public Methods
REXMaterialProperties Class Legend
Public Methods
Public Method | Description
REXMaterialProperties | Initializes a new instance of the REXMaterialProperties class.
REXMaterialProperties | Initializes a new instance of the REXMaterialProperties class.
REXMaterialProperties | Initializes a new instance of the REXMaterialProperties class.
REXMaterialProperties | Initializes a new instance of the REXMaterialProperties class.

Legend

Legend
REXSectionDBCharacteristics Class
Legend
Constructor
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXSectionDBCharacteristics Class Members

REXSectionDBCharacteristics Class Members
REXSectionDBCharacteristics Class Legend
Members
Public Methods
Public Method | Description
REXSectionDBCharacteristics | Initializes a new instance of the REXSectionDBCharacteristics class.
REXSectionDBCharacteristics | Initializes a new instance of the EXSectionDBCharacteristics class.
REXSectionDBCharacteristics | Initializes a new instance of the REXSectionDBCharacteristics class.
REXSectionDBCharacteristics | Initializes a new instance of the REXSectionDBCharacteristics class.
REXSectionDBCharacteristics Methods
REXSectionDBCharacteristics Methods | Description
Clone | Creates a new object that is a copy of the current instance.
REXSectionDBCharacteristics Properties
REXSectionDBCharacteristics Properties | Description
IOMEGA | Gets or sets the warping constant (for thin-walled sections).
IX | Gets or sets the torsional constant.
IY | Gets or sets the moment of inertia (Iy).
IZ | Gets or sets the moment of inertia (Iz).
MASS | Gets or sets the weight per length unit of a section.
MSY | Gets or sets the plastic section modulus (bending) about the Y axis.
MSZ | Gets or sets the plastic section modulus (bending) about the Z axis.
SX | Gets or sets the cross-sectional area.
SY | Gets or sets the reduced section area for XY-shear deformation calculations - considering the influence of shear forces along Y axis.
SZ | Gets or sets the reduced section area for XZ-shear deformation calculations - considering the influence of shear forces along Z axis.

REXSectionDBCharacteristics Methods

REXSectionDBCharacteristics Methods
REXSectionDBCharacteristics Class Legend
REXSectionDBCharacteristics Methods
REXSectionDBCharacteristics Methods | Description
Clone | Creates a new object that is a copy of the current instance.

REXSectionDBCharacteristics Properties

REXSectionDBCharacteristics Properties
REXSectionDBCharacteristics Class Legend
REXSectionDBCharacteristics Properties
REXSectionDBCharacteristics Properties | Description
IOMEGA | Gets or sets the warping constant (for thin-walled sections).
IX | Gets or sets the torsional constant.
IY | Gets or sets the moment of inertia (Iy).
IZ | Gets or sets the moment of inertia (Iz).
MASS | Gets or sets the weight per length unit of a section.
MSY | Gets or sets the plastic section modulus (bending) about the Y axis.
MSZ | Gets or sets the plastic section modulus (bending) about the Z axis.
SX | Gets or sets the cross-sectional area.
SY | Gets or sets the reduced section area for XY-shear deformation calculations - considering the influence of shear forces along Y axis.
SZ | Gets or sets the reduced section area for XZ-shear deformation calculations - considering the influence of shear forces along Z axis.

REXSectionDBCharacteristics Class Public Methods

REXSectionDBCharacteristics Class Public Methods
REXSectionDBCharacteristics Class Legend
Public Methods
Public Method | Description
REXSectionDBCharacteristics | Initializes a new instance of the REXSectionDBCharacteristics class.
REXSectionDBCharacteristics | Initializes a new instance of the EXSectionDBCharacteristics class.
REXSectionDBCharacteristics | Initializes a new instance of the REXSectionDBCharacteristics class.
REXSectionDBCharacteristics | Initializes a new instance of the REXSectionDBCharacteristics class.

Legend

Legend
REXSectionDBDescription Class
Legend
Constructor
static
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXSectionDBDescription Class Members

REXSectionDBDescription Class Members
REXSectionDBDescription Class Legend
Members
Public Methods
Public Method | Description
REXSectionDBDescription | Initializes a new instance of the REXSectionDBDescription class.
REXSectionDBDescription | Initializes a new instance of the REXSectionDBDescription class.
REXSectionDBDescription | Initializes a new instance of the REXSectionDBDescription class.
REXSectionDBDescription | Initializes a new instance of the REXSectionDBDescription class.
REXSectionDBDescription | Initializes a new instance of the REXSectionDBDescription class.
REXSectionDBDescription Methods
REXSectionDBDescription Methods | Description
Clone | Creates a new object that is a copy of the current instance.
CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
GetContour | Gets the contour of the section.
GetName | Gets the name of the section.
GetSectionType | Gets the type of the section.
GetSectionType | Gets the type of the section.
REXSectionDBDescription Properties
REXSectionDBDescription Properties | Description
Characteristics | Gets or sets the characteristics of the section.
Description | Gets or sets the description of the section.
DIM1 | Gets or sets the first numeric component of the section label
DIM2 | Gets or sets the second numeric component of the section label.
DIM3 | Gets or sets the third numeric component of the section label.
Dimensions | Gets or sets the dimensions.
NAME | Gets or sets the name of the section.

Members

Legend
Legend
Constructor
static
Property