Gets or sets characteristics.

C#
public REX.ContentGenerator.Families.REXMaterialCharacteristics Characteristics;
Description

The characteristics.

Class

REXMaterialDBDescription Class

Links
REXMaterialDBDescription Class, REX.ContentGenerator.Families Namespace, REXMaterialDBDescription Class

REXMaterialDBDescription.Description Property

REXMaterialDBDescription.Description Property
REXMaterialDBDescription Class REX.ContentGenerator.Families Namespace REXMaterialDBDescription Class

Gets or sets the description.

C#
public REX.ContentGenerator.Families.REXMaterialProperties Description;
Description

The description.

Class

REXMaterialDBDescription Class

Links
REXMaterialDBDescription Class, REX.ContentGenerator.Families Namespace, REXMaterialDBDescription Class

REXMaterialDBDescription.NAME Property

REXMaterialDBDescription.NAME Property
REXMaterialDBDescription Class REX.ContentGenerator.Families Namespace REXMaterialDBDescription Class

Gets or sets the material name.

C#
public string NAME;
Description

The material name.

Remarks

It is taken as key for identification process in a database.

Class

REXMaterialDBDescription Class

Links
REXMaterialDBDescription Class, REX.ContentGenerator.Families Namespace, REXMaterialDBDescription Class

REXMaterialProperties Class

REXMaterialProperties Class
REX.ContentGenerator.Families Namespace Legend Members Public Methods REXMaterialProperties Methods REXMaterialProperties Properties

Represents properties of the material.

Class Hierarchy
C#
[Serializable()]
public class REXMaterialProperties : REXDescription;
Description
Namespace

REX.ContentGenerator.Families Namespace

Public Methods
Public Method | Description
REXMaterialProperties | Initializes a new instance of the REXMaterialProperties class.
REXMaterialProperties | Initializes a new instance of the REXMaterialProperties class.
REXMaterialProperties | Initializes a new instance of the REXMaterialProperties class.
REXMaterialProperties | Initializes a new instance of the REXMaterialProperties class.
REXMaterialProperties Methods
REXMaterialProperties Methods | Description
Clone | Creates a new object that is a copy of the current instance.
REXMaterialProperties Properties
REXMaterialProperties Properties | Description
DESCRIPTION | Gets or sets the detailed material description.
NAME | Gets or sets the material name.
RE_CODE | Gets or sets /1.
SECOND_NAME | Gets or sets the material's name (used for a steel to give an equivalent according to Eurocode).
THERM | Gets or sets the material type /for steel: thermal treatment-1 /for timber: natural-0, glued-1, glued KertoS specific for Kerto code-2, glued KertoQ specific for Kerto code-3, glued KertoS-4, glued KertoQ-5.
Links
REX.ContentGenerator.Families Namespace, Legend, Members, Public Methods, REXMaterialProperties Methods, REXMaterialProperties Properties

REXMaterialProperties.REXMaterialProperties Constructor ()

REXMaterialProperties.REXMaterialProperties Constructor ()
REXMaterialProperties Class REX.ContentGenerator.Families Namespace REXMaterialProperties Class

Initializes a new instance of the REXMaterialProperties class.

C#
public REXMaterialProperties();
Description
Class

REXMaterialProperties Class

Links
REXMaterialProperties Class, REX.ContentGenerator.Families Namespace, REXMaterialProperties Class

REXMaterialProperties.REXMaterialProperties Constructor (DTableDataObjectCollection)

REXMaterialProperties.REXMaterialProperties Constructor (DTableDataObjectCollection)
REXMaterialProperties Class REX.ContentGenerator.Families Namespace REXMaterialProperties Class

Initializes a new instance of the REXMaterialProperties class.

C#
public REXMaterialProperties(DTableDataObjectCollection pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

REXMaterialProperties Class

Links
REXMaterialProperties Class, REX.ContentGenerator.Families Namespace, REXMaterialProperties Class

REXMaterialProperties.REXMaterialProperties Constructor (REXMaterialProperties)

REXMaterialProperties.REXMaterialProperties Constructor (REXMaterialProperties)
REXMaterialProperties Class REX.ContentGenerator.Families Namespace REXMaterialProperties Class

Initializes a new instance of the REXMaterialProperties class.

C#
public REXMaterialProperties(REXMaterialProperties pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

REXMaterialProperties Class

Links
REXMaterialProperties Class, REX.ContentGenerator.Families Namespace, REXMaterialProperties Class

REXMaterialProperties.REXMaterialProperties Constructor (System.Data.DataRow)

REXMaterialProperties.REXMaterialProperties Constructor (System.Data.DataRow)
REXMaterialProperties Class REX.ContentGenerator.Families Namespace REXMaterialProperties Class

Initializes a new instance of the REXMaterialProperties class.

C#
public REXMaterialProperties(System.Data.DataRow pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

REXMaterialProperties Class

Links
REXMaterialProperties Class, REX.ContentGenerator.Families Namespace, REXMaterialProperties Class

REXMaterialProperties.Clone Method

REXMaterialProperties.Clone Method
REXMaterialProperties Class REX.ContentGenerator.Families Namespace REXMaterialProperties Class

Creates a new object that is a copy of the current instance.

C#
public override object Clone();
Returns

A new object that is a copy of this instance.

Description
Class

REXMaterialProperties Class

Links
REXMaterialProperties Class, REX.ContentGenerator.Families Namespace, REXMaterialProperties Class

REXMaterialProperties.DESCRIPTION Property

REXMaterialProperties.DESCRIPTION Property
REXMaterialProperties Class REX.ContentGenerator.Families Namespace REXMaterialProperties Class

Gets or sets the detailed material description.

C#
public string DESCRIPTION;
Description

The detailed material description.

Class

REXMaterialProperties Class

Links
REXMaterialProperties Class, REX.ContentGenerator.Families Namespace, REXMaterialProperties Class

REXMaterialProperties.NAME Property

REXMaterialProperties.NAME Property
REXMaterialProperties Class REX.ContentGenerator.Families Namespace REXMaterialProperties Class

Gets or sets the material name.

C#
public string NAME;
Description

The material name.

Remarks

It is taken as key for identification process in a database.

Class

REXMaterialProperties Class

Links
REXMaterialProperties Class, REX.ContentGenerator.Families Namespace, REXMaterialProperties Class

REXMaterialProperties.RE_CODE Property

REXMaterialProperties.RE_CODE Property
REXMaterialProperties Class REX.ContentGenerator.Families Namespace REXMaterialProperties Class

Gets or sets /1.

C#
public int RE_CODE;
Description

a digit stands for (characteristic or design) resistance, 2. a cubic or cylindric sample).

The resistance.

Class

REXMaterialProperties Class

Links
REXMaterialProperties Class, REX.ContentGenerator.Families Namespace, REXMaterialProperties Class

REXMaterialProperties.SECOND_NAME Property

REXMaterialProperties.SECOND_NAME Property
REXMaterialProperties Class REX.ContentGenerator.Families Namespace REXMaterialProperties Class

Gets or sets the material's name (used for a steel to give an equivalent according to Eurocode).

C#
public string SECOND_NAME;
Description

The material's name (used for a steel to give an equivalent according to Eurocode).

Class

REXMaterialProperties Class

Links
REXMaterialProperties Class, REX.ContentGenerator.Families Namespace, REXMaterialProperties Class

REXMaterialProperties.THERM Property

REXMaterialProperties.THERM Property
REXMaterialProperties Class REX.ContentGenerator.Families Namespace REXMaterialProperties Class

Gets or sets the material type /for steel: thermal treatment-1 /for timber: natural-0, glued-1, glued KertoS specific for Kerto code-2, glued KertoQ specific for Kerto code-3, glued KertoS-4, glued KertoQ-5.

C#
public int THERM;
Description