REXSectionDBProperties Class, REX.ContentGenerator.Families Namespace, REXSectionDBProperties Class

REXSectionDBProperties.SHAPE_TYPE Property

REXSectionDBProperties.SHAPE_TYPE Property
REXSectionDBProperties Class REX.ContentGenerator.Families Namespace REXSectionDBProperties Class

Gets or sets the number of the section shape type.

C#
public int SHAPE_TYPE;
Description

The number of the section shape type.

Class

REXSectionDBProperties Class

Links
REXSectionDBProperties Class, REX.ContentGenerator.Families Namespace, REXSectionDBProperties Class

REXSectionParamCharacteristics Class

REXSectionParamCharacteristics Class
REX.ContentGenerator.Families Namespace Legend Members Public Methods REXSectionParamCharacteristics Methods REXSectionParamCharacteristics Properties

Describes characteristics of the parametric section.

Class Hierarchy
C#
[Serializable()]
public class REXSectionParamCharacteristics : REXDescription;
Description
Namespace

REX.ContentGenerator.Families Namespace

Public Methods
Public Method | Description
REXSectionParamCharacteristics | Initializes a new instance of the REXSectionParamCharacteristics class.
REXSectionParamCharacteristics | Initializes a new instance of the REXSectionParamCharacteristics class.
REXSectionParamCharacteristics | Initializes a new instance of the REXSectionParamCharacteristics class.
REXSectionParamCharacteristics | Initializes a new instance of the REXSectionParamCharacteristics class.
REXSectionParamCharacteristics Methods
REXSectionParamCharacteristics Methods | Description
Clone | Clones this instance.
REXSectionParamCharacteristics Properties
REXSectionParamCharacteristics Properties | Description
A | Gets or sets the Cross-section area.
IY | Gets or sets the moment of inertia about the Y axis.
IZ | Gets or sets the moment of inertia about the Z axis.
MASS | Gets or sets the nominal weight per unit length.
Links
REX.ContentGenerator.Families Namespace, Legend, Members, Public Methods, REXSectionParamCharacteristics Methods, REXSectionParamCharacteristics Properties

REXSectionParamCharacteristics.REXSectionParamCharacteristics Constructor ()

REXSectionParamCharacteristics.REXSectionParamCharacteristics Constructor ()
REXSectionParamCharacteristics Class REX.ContentGenerator.Families Namespace REXSectionParamCharacteristics Class

Initializes a new instance of the REXSectionParamCharacteristics class.

C#
public REXSectionParamCharacteristics();
Description
Class

REXSectionParamCharacteristics Class

Links
REXSectionParamCharacteristics Class, REX.ContentGenerator.Families Namespace, REXSectionParamCharacteristics Class

REXSectionParamCharacteristics.REXSectionParamCharacteristics Constructor (DTableDataObjectCollection)

REXSectionParamCharacteristics.REXSectionParamCharacteristics Constructor (DTableDataObjectCollection)
REXSectionParamCharacteristics Class REX.ContentGenerator.Families Namespace REXSectionParamCharacteristics Class

Initializes a new instance of the REXSectionParamCharacteristics class.

C#
public REXSectionParamCharacteristics(DTableDataObjectCollection pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

REXSectionParamCharacteristics Class

Links
REXSectionParamCharacteristics Class, REX.ContentGenerator.Families Namespace, REXSectionParamCharacteristics Class

REXSectionParamCharacteristics.REXSectionParamCharacteristics Constructor (REXSectionParamCharacteristics)

REXSectionParamCharacteristics.REXSectionParamCharacteristics Constructor (REXSectionParamCharacteristics)
REXSectionParamCharacteristics Class REX.ContentGenerator.Families Namespace REXSectionParamCharacteristics Class

Initializes a new instance of the REXSectionParamCharacteristics class.

C#
public REXSectionParamCharacteristics(REXSectionParamCharacteristics pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

REXSectionParamCharacteristics Class

Links
REXSectionParamCharacteristics Class, REX.ContentGenerator.Families Namespace, REXSectionParamCharacteristics Class

REXSectionParamCharacteristics.REXSectionParamCharacteristics Constructor (System.Data.DataRow)

REXSectionParamCharacteristics.REXSectionParamCharacteristics Constructor (System.Data.DataRow)
REXSectionParamCharacteristics Class REX.ContentGenerator.Families Namespace REXSectionParamCharacteristics Class

Initializes a new instance of the REXSectionParamCharacteristics class.

C#
public REXSectionParamCharacteristics(System.Data.DataRow pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

REXSectionParamCharacteristics Class

Links
REXSectionParamCharacteristics Class, REX.ContentGenerator.Families Namespace, REXSectionParamCharacteristics Class

REXSectionParamCharacteristics.Clone Method

REXSectionParamCharacteristics.Clone Method
REXSectionParamCharacteristics Class REX.ContentGenerator.Families Namespace REXSectionParamCharacteristics Class

Clones this instance.

C#
public override object Clone();
Returns

New instance

Description
Class

REXSectionParamCharacteristics Class

Links
REXSectionParamCharacteristics Class, REX.ContentGenerator.Families Namespace, REXSectionParamCharacteristics Class

REXSectionParamCharacteristics.A Property

REXSectionParamCharacteristics.A Property
REXSectionParamCharacteristics Class REX.ContentGenerator.Families Namespace REXSectionParamCharacteristics Class

Gets or sets the Cross-section area.

C#
public double A;
Description

The Cross-section area.

Class

REXSectionParamCharacteristics Class

Links
REXSectionParamCharacteristics Class, REX.ContentGenerator.Families Namespace, REXSectionParamCharacteristics Class

REXSectionParamCharacteristics.IY Property

REXSectionParamCharacteristics.IY Property
REXSectionParamCharacteristics Class REX.ContentGenerator.Families Namespace REXSectionParamCharacteristics Class

Gets or sets the moment of inertia about the Y axis.

C#
public double IY;
Description

The moment of inertia about the Y axis.

Class

REXSectionParamCharacteristics Class

Links
REXSectionParamCharacteristics Class, REX.ContentGenerator.Families Namespace, REXSectionParamCharacteristics Class

REXSectionParamCharacteristics.IZ Property

REXSectionParamCharacteristics.IZ Property
REXSectionParamCharacteristics Class REX.ContentGenerator.Families Namespace REXSectionParamCharacteristics Class

Gets or sets the moment of inertia about the Z axis.

C#
public double IZ;
Description

The moment of inertia about the Z axis.

Class

REXSectionParamCharacteristics Class

Links
REXSectionParamCharacteristics Class, REX.ContentGenerator.Families Namespace, REXSectionParamCharacteristics Class

REXSectionParamCharacteristics.MASS Property

REXSectionParamCharacteristics.MASS Property
REXSectionParamCharacteristics Class REX.ContentGenerator.Families Namespace REXSectionParamCharacteristics Class

Gets or sets the nominal weight per unit length.

C#
public double MASS;
Description

The nominal weight per unit length.

Class

REXSectionParamCharacteristics Class

Links
REXSectionParamCharacteristics Class, REX.ContentGenerator.Families Namespace, REXSectionParamCharacteristics Class

REXSectionParamDescription Class

REXSectionParamDescription Class
REX.ContentGenerator.Families Namespace Legend Members Public Methods REXSectionParamDescription Methods REXSectionParamDescription Properties

Represents parameters of the parametric section.

Class Hierarchy
C#
[Serializable()]
public class REXSectionParamDescription : REXParamDescription;
Description
Namespace

REX.ContentGenerator.Families Namespace

Public Methods
Public Method | Description
REXSectionParamDescription | Initializes a new instance of the REXSectionParamDescription class.
REXSectionParamDescription | Initializes a new instance of the REXSectionParamDescription class.
REXSectionParamDescription | Initializes a new instance of the REXSectionParamDescription class.