REX.Common Namespace

Revit Extensions API 2018
Next
REX.Common Namespace
Legend Classes Interfaces Structs, Records, Enums

This is namespace REX.Common.

Classes
Class | Description
REXAccess | The class dedicated to settings data from parent application.
REXApplication | Base class for Application.This object controls the lifetime of the extensions.
REXDFM | Manages UI controls registered in it.
REXDirectAccess | Base class for main DirectAccess class.
REXDirectRevitAccess | Base class for main DirectAccess class.
REXDirectRevitExecute | This is class REX.Common.REXDirectRevitExecute.
REXErrors | Supprots REX errors for logging system.
REXExtension | Additional functionality of REXExtension class.
REXExtensionContext | Internal class for controlling behavior of the extension.
REXExtensionControl | Base class for user controls.
REXExtensionData | Base class for REXData and REXResults classes.
REXExtensionDataSerializable | Base class for REXDataSerializable and REXResultsSerializable classes.
REXExtensionMainControl | Base class for main control.
REXExtensionObject | Base class for all objects created in extension module.
REXExtensionPanel | Base class for panel control.
REXExtensionProduct | Represents the Extension element used by the main Extension class to separate product dependent part of the code from general one.
REXExtensionSettings | Allows reading base settings from "Configuration / settings.xml" file.
REXExtensionWindow | Base class for user forms.
REXFoundationApplication | Foundation class for REX.Foundation usage.
REXLayout |
REXLayoutItem | Represents all layout of main control.
REXLogger | This is class REX.Common.REXLogger.
REXResults | Base class for results.
REXRevitAccess | The class dedicated to settings data from Revit.
REXRevitContextAccess | Allaws for access to Revit's objects.
REXUI | Main class which provides access to all data connected with main control.
REXVersion | Foundation class for REX.Foundation usage.
REXWarnings | This is class REX.Common.REXWarnings.
REXWebBrowser | Proxy class for web browser control.
Interfaces
Interface | Description
IREXConnector | This is class REX.Common.IREXConnector.
IREXExtension | Main interface for extension module.
IREXExtension2 | Main interface for extension module.
IREXExtension3 | Main interface for extension module.
IREXExtension4 | Main interface for extension module.
IREXExtensionAccess | Main interface for REXAccess class.
IREXExtensionAccess2 | Main interface for REXAccess class.
IREXExtensionAccess3 | Main interface for REXAccess class.
IREXExtensionAccessUnitsControl | Main interface for REXAccess class.
IREXThisExtension | Base interface for access to main extension's objects.
Structs, Records, Enums
Struct, Record, Enum | Description
REXCanCloseType | Determines closing mode.
REXSetFormStruct | This is record REX.Common.REXSetFormStruct.
Links
Legend, Classes, Interfaces, Structs, Records, Enums
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.
Copyright (c) 2015. All rights reserved.

REXAccess Class

Previous | Up | Next
REXAccess Class
REX.Common Namespace Legend Members Public Methods REXAccess Enumerations REXAccess Methods REXAccess Properties

The class dedicated to settings data from parent application.

Class Hierarchy
C#
public class REXAccess : IREXExtensionAccess3;
Description

Called internally from base SDK's classes.

Namespace

REX.Common Namespace

Public Methods
Public Method | Description
REXAccess | Initializes a new instance of the REXAccess class.
REXAccess Enumerations
REXAccess Enumerations | Description
REXAccessEvent |
REXAccess Methods
REXAccess Methods | Description
Access | This is Access, a member of class REXAccess.
Create | Reads some data from parent application and set system display units.
Destroy | Destroys and reset some objects connected to parent application.
Detach | Detaches this instance.
Event | Events the specified event.
Initialize | Initializes this instance.
Update | Reads some data from parent application and set system display units.
REXAccess Properties
REXAccess Properties | Description
Interfaces | This is Interfaces, a member of class REXAccess.
Links
REX.Common Namespace, Legend, Members, Public Methods, REXAccess Enumerations, REXAccess Methods, REXAccess Properties
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.
Copyright (c) 2015. All rights reserved.
Home

REXAccess.REXAccess Constructor

REXAccess.REXAccess Constructor
REXAccess Class REX.Common Namespace REXAccess Class

Initializes a new instance of the REXAccess class.

C#
public REXAccess(REXApplication App);
Parameters
Parameters | Description
App | The reference to REXApplication object.
Description
Class

REXAccess Class

Links
REXAccess Class, REX.Common Namespace, REXAccess Class
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REX.Common.REXAccess.REXAccessEvent Enumeration

REX.Common.REXAccess.REXAccessEvent Enumeration
REXAccess Class
C#
public enum REXAccessEvent {
  LoadRegionalSettings,
  SaveRegionalSettings,
  LoadJournalingData,
  SaveJournalingData
}
Class

REXAccess Class

Links
REXAccess Class
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXAccess.Access Method

REXAccess.Access Method
REXAccess Class REX.Common Namespace REXAccess Class

This is Access, a member of class REXAccess.

C#
public IREXExtensionAccess Access(string Interface);
Class

REXAccess Class

Links
REXAccess Class, REX.Common Namespace, REXAccess Class

REXAccess.Create Method

REXAccess.Create Method
REXAccess Class REX.Common Namespace REXAccess Class

Reads some data from parent application and set system display units.

C#
public bool Create();
Returns

Returns true if succeeded.

Description
Class

REXAccess Class

Links
REXAccess Class, REX.Common Namespace, REXAccess Class

REXAccess.Destroy Method

REXAccess.Destroy Method
REXAccess Class REX.Common Namespace REXAccess Class

Destroys and reset some objects connected to parent application.

C#
public bool Destroy();
Returns

Returns true if succeeded.

Description
Class

REXAccess Class

Links
REXAccess Class, REX.Common Namespace, REXAccess Class

REXAccess.Detach Method

REXAccess.Detach Method
REXAccess Class REX.Common Namespace REXAccess Class

Detaches this instance.

C#
public void Detach();
Description
Class

REXAccess Class

Links
REXAccess Class, REX.Common Namespace, REXAccess Class

REXAccess.Event Method

REXAccess.Event Method
REXAccess Class REX.Common Namespace REXAccess Class

Events the specified event.

C#
public bool Event(REXAccessEvent Ev);
Parameters
Parameters | Description
Ev | The event.
Description
Class

REXAccess Class

Links
REXAccess Class, REX.Common Namespace, REXAccess Class

REXAccess.Initialize Method

REXAccess.Initialize Method
REXAccess Class REX.Common Namespace REXAccess Class

Initializes this instance.

C#
public void Initialize();
Description

Nostly sets language from parent application.

Class

REXAccess Class

Links
REXAccess Class, REX.Common Namespace, REXAccess Class

REXAccess.Update Method

REXAccess.Update Method
REXAccess Class REX.Common Namespace REXAccess Class

Reads some data from parent application and set system display units.

C#
public void Update();
Description
Class

REXAccess Class

Links
REXAccess Class, REX.Common Namespace, REXAccess Class