public override REXDescription Recalculate(REXDescription description, bool fromInterface, ECategoryType category, bool create_new);
Class

RVTCustomFactory Class

Links
RVTCustomFactory Class, REX.ContentGenerator.Converters Namespace, RVTCustomFactory Class

RVTCustomFactory.Recalculate Method (REXDescription, bool, ECategoryType, bool, string)

RVTCustomFactory.Recalculate Method (REXDescription, bool, ECategoryType, bool, string)
RVTCustomFactory Class REX.ContentGenerator.Converters Namespace RVTCustomFactory Class

This is Recalculate, a member of class RVTCustomFactory.

C#
public REXDescription Recalculate(REXDescription description, bool fromInterface, ECategoryType category, bool create_new, string root);
Class

RVTCustomFactory Class

Links
RVTCustomFactory Class, REX.ContentGenerator.Converters Namespace, RVTCustomFactory Class

RVTCustomFactory.ValidateElement Method

RVTCustomFactory.ValidateElement Method
RVTCustomFactory Class REX.ContentGenerator.Converters Namespace RVTCustomFactory Class

This is ValidateElement, a member of class RVTCustomFactory.

C#
public override bool ValidateElement(Element el);
Class

RVTCustomFactory Class

Links
RVTCustomFactory Class, REX.ContentGenerator.Converters Namespace, RVTCustomFactory Class

RVTDBSectionFactory Class

RVTDBSectionFactory Class
REX.ContentGenerator.Converters Namespace Legend Members Public Methods RVTDBSectionFactory Methods

This is class REX.ContentGenerator.Converters.RVTDBSectionFactory.

Class Hierarchy
C#
public class RVTDBSectionFactory : RVTCommonSectionFactory;
Namespace

REX.ContentGenerator.Converters Namespace

Public Methods
Public Method | Description
RVTDBSectionFactory | This is RVTDBSectionFactory, a member of class RVTDBSectionFactory.
RVTDBSectionFactory Methods
RVTDBSectionFactory Methods | Description
IsElementSupported | This is IsElementSupported, a member of class RVTDBSectionFactory.
Recalculate | This is Recalculate, a member of class RVTDBSectionFactory.
Links
REX.ContentGenerator.Converters Namespace, Legend, Members, Public Methods, RVTDBSectionFactory Methods

RVTDBSectionFactory.RVTDBSectionFactory Constructor

RVTDBSectionFactory.RVTDBSectionFactory Constructor
RVTDBSectionFactory Class REX.ContentGenerator.Converters Namespace RVTDBSectionFactory Class

This is RVTDBSectionFactory, a member of class RVTDBSectionFactory.

C#
public RVTDBSectionFactory(RvtConversionSettings Settings, CompositeLevel Families);
Class

RVTDBSectionFactory Class

Links
RVTDBSectionFactory Class, REX.ContentGenerator.Converters Namespace, RVTDBSectionFactory Class

RVTDBSectionFactory.IsElementSupported Method

RVTDBSectionFactory.IsElementSupported Method
RVTDBSectionFactory Class REX.ContentGenerator.Converters Namespace RVTDBSectionFactory Class

This is IsElementSupported, a member of class RVTDBSectionFactory.

C#
public override bool IsElementSupported(REXFamilyType fam, ECategoryType category);
Class

RVTDBSectionFactory Class

Links
RVTDBSectionFactory Class, REX.ContentGenerator.Converters Namespace, RVTDBSectionFactory Class

RVTDBSectionFactory.Recalculate Method

RVTDBSectionFactory.Recalculate Method
RVTDBSectionFactory Class REX.ContentGenerator.Converters Namespace RVTDBSectionFactory Class

This is Recalculate, a member of class RVTDBSectionFactory.

C#
public override REXDescription Recalculate(REXDescription DBdesc, bool fromInterface, ECategoryType category, bool create_new);
Class

RVTDBSectionFactory Class

Links
RVTDBSectionFactory Class, REX.ContentGenerator.Converters Namespace, RVTDBSectionFactory Class

RVTFamilyConverter Class

RVTFamilyConverter Class
REX.ContentGenerator.Converters Namespace Legend Members Public Methods RVTFamilyConverter Events RVTFamilyConverter Methods RVTFamilyConverter Properties

This class represents a converter which provides access to Revit project.

Class Hierarchy
C#
public class RVTFamilyConverter : IMapConverter;
Description

It allows user to generate objects as well as read them.

Namespace

REX.ContentGenerator.Converters Namespace

Public Methods
Public Method | Description
RVTFamilyConverter | Initializes a new instance of the RVTFamilyConverter class.
RVTFamilyConverter | Initializes a new instance of the RVTFamilyConverter class.
RVTFamilyConverter Events
RVTFamilyConverter Events | Description
EventElementGenerated | Occurs when element is generated (when the list of elements is used).
RVTFamilyConverter Methods
RVTFamilyConverter Methods | Description
Close | Saves data to the Revit document, clears collections, releases objects.
CreateRebar | Creates the rebar element based on the input REXFamilyType_Rebar object.
GetCertifiedCategoryOfElement | Gets category of the certified element.
GetElement | Gets the Revit element created based on the REXFamilyType object.
GetElement | Gets the Revit element created based on the REXFamilyType object.
GetElement | Gets the Revit element created based on the REXFamilyType object.
GetElements | Gets the list of Revit elements created based on the list of REXFamilyTypes.
GetExistingNames | Returns the list of names existing for specific REXFamilyType object.
GetFamily | Gets the REXFamilyType object based on the input element.
GetFamily | Gets the REXFamilyType object based on the input element.
GetFamily | Gets the REXFamilyType object based on the input element.
GetRebarContour | Gets the rebar's contour based on the Revit element.
InitGlobal | Initializes lists of existing families from the Active Document.
IsElementSupported | This is IsElementSupported, a member of class RVTFamilyConverter.
RegisterCustomFactory | Registers the custom factory.
Temporary | This is Temporary, a member of class RVTFamilyConverter.
RVTFamilyConverter Properties
RVTFamilyConverter Properties | Description
ContentMapper | Gets the mapper object.
Settings | Gets the settings.
Links
REX.ContentGenerator.Converters Namespace, Legend, Members, Public Methods, RVTFamilyConverter Events, RVTFamilyConverter Methods, RVTFamilyConverter Properties

RVTFamilyConverter.RVTFamilyConverter Constructor (Autodesk.Revit.UI.ExternalCommandData, bool)

RVTFamilyConverter.RVTFamilyConverter Constructor (Autodesk.Revit.UI.ExternalCommandData, bool)
RVTFamilyConverter Class REX.ContentGenerator.Converters Namespace RVTFamilyConverter Class

Initializes a new instance of the RVTFamilyConverter class.

C#
public RVTFamilyConverter(Autodesk.Revit.UI.ExternalCommandData commandData, bool initialize);
Parameters
Parameters | Description
commandData | The Revit Application handler.
initialize | Indicates whether internal lists of families are to be filled. If set to false existing items won't be taken to considaration during generation and it is necessarry to call InitGlobal method to fill them up.
Description
Class

RVTFamilyConverter Class

Links
RVTFamilyConverter Class, REX.ContentGenerator.Converters Namespace, RVTFamilyConverter Class

RVTFamilyConverter.RVTFamilyConverter Constructor (Document, bool)

RVTFamilyConverter.RVTFamilyConverter Constructor (Document, bool)
RVTFamilyConverter Class REX.ContentGenerator.Converters Namespace RVTFamilyConverter Class

Initializes a new instance of the RVTFamilyConverter class.

C#
public RVTFamilyConverter(Document doc, bool initialize);
Parameters
Parameters | Description
doc | The Revit document.
initialize | Indicates whether internal lists of families are to be filled. If set to false existing items won't be taken to considaration during generation and it is necessarry to call InitGlobal method to fill them up.
Description
Class

RVTFamilyConverter Class

Links
RVTFamilyConverter Class, REX.ContentGenerator.Converters Namespace, RVTFamilyConverter Class

RVTFamilyConverter.Close Method

RVTFamilyConverter.Close Method
RVTFamilyConverter Class REX.ContentGenerator.Converters Namespace RVTFamilyConverter Class

Saves data to the Revit document, clears collections, releases objects.

C#
public void Close();
Description
Remarks