SECTION_PARAM | The parametric section.
SECTION_DB | The database section.
MATERIAL | The material.
REBAR_SHAPE | The rebar shape.
REBAR_BARTYPE | The rebar type.
REBAR_HOOK | The rebar hook.
BOLT | The bolt.
BOLT_CLASS | The bolt class.
CUSTOM | The custom type.
Namespace

REX.ContentGenerator.Families Namespace

Links
REX.ContentGenerator.Families Namespace
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REX.ContentGenerator.Families.EDBSectionType Enumeration

REX.ContentGenerator.Families.EDBSectionType Enumeration
REX.ContentGenerator.Families Namespace

Describes the type of the database section.

C#
public enum EDBSectionType {
  ANGLE_EQ_LEG = 1,
  ANGLE_UNEQ_LEG,
  ANGLE_EQ_LEG_MAIN,
  ANGLE_UNEQ_LEG_MAIN,
  ANGLE_CROSS,
  ANGLE_CROSS_MAIN,
  ANGLE_DOUBLE,
  I_WIDE,
  I_WIDE_WELDED,
  I_PAR,
  I_NORM,
  I_DOUBLE,
  I_ASYM,
  T_WIDE,
  T_PAR,
  T_NORM,
  HEX_PIPE,
  RECT_PIPE,
  ROUND_PIPE,
  C_PAR,
  C_NORM,
  C_DOUBLE_PAR,
  C_DOUBLE_NORM,
  C_DOUBLE_BACK,
  C_COLD,
  RECT,
  ROUND,
  C_HCLOSED,
  U,
  RECT_PIPE_ROUND,
  COLD_SIGMA1,
  COLD_SIGMA2,
  COLD_ZED1,
  COLD_U,
  COLD_CE1,
  COLD_ANGLE,
  COLD_OMEGA,
  COLD_S01,
  COLD_CEEPLUS,
  COLD_ZEDROT,
  COLD_SIGMA,
  COLD_ZET,
  COLD_L_LIPS,
  COLD_ZETROT,
  UNKNOWN
}
Members
Members | Description
ANGLE_EQ_LEG | Equal angles.
ANGLE_UNEQ_LEG | Unequal angles.
ANGLE_EQ_LEG_MAIN | Equal angles (in principal axes).
ANGLE_UNEQ_LEG_MAIN | Unequal angles (in principal axes).
ANGLE_CROSS | 2 angles - cross-shape.
ANGLE_CROSS_MAIN | 2 angles - cross-shape (in principal axes).
ANGLE_DOUBLE | 2 angles back to back.
I_WIDE | I-sections with wide flanges.
I_WIDE_WELDED | I-sections with wide flanges (welded).
I_PAR | I-sections (with constant flange thickness).
I_NORM | Regular I-sections.
I_DOUBLE | 2 I-sections.
I_ASYM | Asymmetrical I-sections.
T_WIDE | T-sections with wide flanges.
T_PAR | T-sections (with constant flange thickness).
T_NORM | Regular T-sections.
HEX_PIPE | Hexagonal tubes.
RECT_PIPE | Rectangular tubes.
ROUND_PIPE | Round tubes.
C_PAR | Channels (with constant flange thickness).
C_NORM | Regular channels.
C_DOUBLE_PAR | 2 channels (with constant flange thickness) back to back.
C_DOUBLE_NORM | 2 regular channels back to back.
C_DOUBLE_BACK | 2 channels (with constant flange thickness) back to back.
C_COLD | Cold-bent channels.
RECT | Rectangular solid.
ROUND | Round solid.
C_HCLOSED | Half-closed channels.
U | U-type rounded section.
RECT_PIPE_ROUND | Rectangular tube - rounded.
COLD_SIGMA1 | Thin-walled sections Sigma1.
COLD_SIGMA2 | Thin-walled sections Sigma2.
COLD_ZED1 | Stiffened Z-sections (thin-walled).
COLD_U | Open channels (thin-walled).
COLD_CE1 | Half-closed channels (thin-walled).
COLD_ANGLE | Thin-walled angles.
COLD_OMEGA | Thin-walled sections Omega.
COLD_S01 | Asymmetrical Z-sections (thin-walled).
COLD_CEEPLUS | Stiffened channels (thin-walled).
COLD_ZEDROT | Stiffened Z-sections (thin-walled) (in principal axes).
COLD_SIGMA | Thin-walled sections Sigma.
COLD_ZET | Thin-walled Z-sections.
COLD_L_LIPS | Thin-walled sections (angles).
COLD_ZETROT | Thin-walled Z-sections (in principal axes).
UNKNOWN | Unknown sections.
Description
Namespace

REX.ContentGenerator.Families Namespace

Links
REX.ContentGenerator.Families Namespace
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REX.ContentGenerator.Families.EElementType Enumeration

REX.ContentGenerator.Families.EElementType Enumeration
REX.ContentGenerator.Families Namespace

Describes the type of the element

C#
public enum EElementType {
  UNKNOWN = 0,
  BEAM = 1,
  COLUMN = 2
}
Members
Members | Description
UNKNOWN | Unknown.
BEAM | Beam.
COLUMN | Column.
Namespace

REX.ContentGenerator.Families Namespace

Links
REX.ContentGenerator.Families Namespace
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REX.ContentGenerator.Families.EMaterial Enumeration

REX.ContentGenerator.Families.EMaterial Enumeration
REX.ContentGenerator.Families Namespace

Describes the type of material

C#
public enum EMaterial {
  STEEL = 1,
  WOOD = 2,
  CONCRETE = 3,
  GENERIC = 4,
  UNKNOWN = 0
}
Members
Members | Description
STEEL | Steel.
WOOD | Wood.
CONCRETE | Concrete.
GENERIC | Generic.
UNKNOWN | Unknown.
Namespace

REX.ContentGenerator.Families Namespace

Links
REX.ContentGenerator.Families Namespace
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REX.ContentGenerator.Families.ESectionType Enumeration

REX.ContentGenerator.Families.ESectionType Enumeration
REX.ContentGenerator.Families Namespace
C#
public enum ESectionType {
  RECT_HOLLOW = 1,
  RECT = 2,
  TUBE = 3,
  ROUND = 4,
  ROUNDH = 5,
  ROUNDQ = 6,
  BOX1 = 7,
  BOX2 = 8,
  BOX3 = 9,
  I = 10,
  IASYM = 11,
  T = 12,
  C = 13,
  Z = 14,
  CROSS = 15,
  POLYG = 16,
  POLYG_HOLLOW = 17,
  L = 18,
  DRECT = 19,
  CABLE = 20,
  TASYM = 21,
  UNKNOWN = 0
}
Members
Members | Description
RECT_HOLLOW | Rectangular tube
RECT | Rectangular.
TUBE | Round tubes.
ROUND | Round.
ROUNDH | Round 1-2.
ROUNDQ | Round 1-4.
BOX1 | Box-I.
BOX2 | Box-II.
BOX3 | Box-III.
I | I-sections.
IASYM | Asymmetrical I-sections.
T | T-sections.
C | C-sections.
Z | Z-sections.
CROSS | Cross-shaped.
POLYG | Polygonal.
POLYG_HOLLOW | Polygonal tubes.
L | L type
DRECT | Double rectangular.
CABLE | Cables
TASYM | Asymmetrical T-sections.
UNKNOWN | Unknown.
Namespace

REX.ContentGenerator.Families Namespace

Links
REX.ContentGenerator.Families Namespace
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REX.ContentGenerator.Geometry Namespace

Previous | Next
REX.ContentGenerator.Geometry Namespace
Legend Classes Structs, Records, Enums

This is namespace REX.ContentGenerator.Geometry.

Classes
Class | Description
Contour_3D | Represents contour 3D.
Contour_Compound2D | Represents the compound contour.
Contour_Section | Represents the contour of the section.
ContourArc | Represents the arc defined by the start, middle and end point.
ContourCircle | Represents the circle element.
ContourCont | Represents the contour element.
ContourDimension | Represents dimensions.
ContourDimensionLine | Represents the linear dimension.
ContourDimensionRadius | Represents the radial dimension.
ContourElem | Base class for all contour elements.
ContourLine | Represents the line element.
REXSectionAnalyzer | This is class REX.ContentGenerator.Geometry.REXSectionAnalyzer.
REXSectionTypeAnalyzer | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer.
REXSectionTypeAnalyzer_BOX1 | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_BOX1.
REXSectionTypeAnalyzer_BOX2 | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_BOX2.
REXSectionTypeAnalyzer_BOX3 | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_BOX3.
REXSectionTypeAnalyzer_C | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_C.
REXSectionTypeAnalyzer_CROSS | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_CROSS.
REXSectionTypeAnalyzer_DRECT | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_DRECT.
REXSectionTypeAnalyzer_I | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_I.