REXUnitEditBox Class REX.Controls.Forms Namespace REXUnitEditBox Class

Set the list of values defined in interface units.

C#
public void SetComplexDataInterfaceValue(List<double> values, REXInterfaceType interfaceType);
Parameters
Parameters | Description
values | The values.
interfaceType | The product context.
Description
Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.Forms Namespace, REXUnitEditBox Class

REXUnitEditBox.SetDataBaseValue Method

REXUnitEditBox.SetDataBaseValue Method
REXUnitEditBox Class REX.Controls.Forms Namespace REXUnitEditBox Class

Set the value in base units.

C#
public void SetDataBaseValue(double value);
Parameters
Parameters | Description
value | The value.
Description
Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.Forms Namespace, REXUnitEditBox Class

REXUnitEditBox.SetDataInterfaceValue Method

REXUnitEditBox.SetDataInterfaceValue Method
REXUnitEditBox Class REX.Controls.Forms Namespace REXUnitEditBox Class

Set the value in interface units.

C#
public void SetDataInterfaceValue(double value, REXInterfaceType interfaceType);
Parameters
Parameters | Description
value | The value.
interfaceType | The product context.
Description
Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.Forms Namespace, REXUnitEditBox Class

REXUnitEditBox.SetInterfaceMaxValue Method

REXUnitEditBox.SetInterfaceMaxValue Method
REXUnitEditBox Class REX.Controls.Forms Namespace REXUnitEditBox Class

Set the maximum value defined in interface units.

C#
public void SetInterfaceMaxValue(double value, REXInterfaceType interfaceType);
Parameters
Parameters | Description
value | The value.
interfaceType | The product context.
Description
Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.Forms Namespace, REXUnitEditBox Class

REXUnitEditBox.SetInterfaceMinValue Method

REXUnitEditBox.SetInterfaceMinValue Method
REXUnitEditBox Class REX.Controls.Forms Namespace REXUnitEditBox Class

Set the minimum value defined in interface units.

C#
public void SetInterfaceMinValue(double value, REXInterfaceType interfaceType);
Parameters
Parameters | Description
value | The value.
interfaceType | The product context.
Description
Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.Forms Namespace, REXUnitEditBox Class

REXUnitEditBox.Power Property

REXUnitEditBox.Power Property
REXUnitEditBox Class REX.Controls.Forms Namespace REXUnitEditBox Class

Gets or sets the power of the unit.

C#
public double Power;
Description

The power.

Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.Forms Namespace, REXUnitEditBox Class

REXUnitEditBox.UnitEngine Property

REXUnitEditBox.UnitEngine Property
REXUnitEditBox Class REX.Controls.Forms Namespace REXUnitEditBox Class

Gets or sets the unit engine.

C#
public Autodesk.REX.Framework.IREXUnits UnitEngine;
Description

The unit engine.

Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.Forms Namespace, REXUnitEditBox Class

REXUnitEditBox.UnitType Property

REXUnitEditBox.UnitType Property
REXUnitEditBox Class REX.Controls.Forms Namespace REXUnitEditBox Class

Gets or sets the type of the unit.

C#
public Autodesk.REX.Framework.EUnitType UnitType;
Description

The type of the unit.

Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.Forms Namespace, REXUnitEditBox Class

REX.Controls.WPF Namespace

Previous | Next
REX.Controls.WPF Namespace
Legend Classes

This is namespace REX.Controls.WPF.

Classes
Class | Description
REXComboBox | Represents a REX combo box control.
REXEditBox | Represents the REXEditBox control.
REXImageComboBox | Represents combobox with images.
REXImageComboBoxItem | Represents the combobox item with an image inside.
REXIndexLabel | Represents the REXIndexLabel control.
REXToolbox | Represents the REXToolbox control
REXToolboxCategoriesCollection | Represents collection of categories of the REXToolbox control.
REXToolboxCategory | Represents the REXToolbox category.
REXToolboxCollection | Base classes for REXToolboxs collections.
REXToolboxItem | Represents the REXToolbox item.
REXToolboxItemsCollection | Represents collection of items of the REXToolbox control.
REXToolboxObject | The base class for all toolbox objects (categories and items)
REXUnitComboBox | Represents the REXUnitComboBox control with a built in IREXUnitEngine.
REXUnitEditBox | Represents the REXEditBox control with a built in IREXUnitEngine.
WPFCommon | This is class REX.Controls.WPF.WPFCommon.
Links
Legend, Classes
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXComboBox Class

REXComboBox Class
REX.Controls.WPF Namespace Legend Members Public Methods REXComboBox Fields REXComboBox Methods REXComboBox Properties

Represents a REX combo box control.

Class Hierarchy
C#
public class REXComboBox : ComboBox, IUnitObject3, Common.IComboEditControl;
Description

It works in two modes: combo box mode, edit box mode.

Namespace

REX.Controls.WPF Namespace

Public Methods
Public Method | Description
REXComboBox | Initializes a new instance of the REXComboBox class.
REXComboBox Fields
REXComboBox Fields | Description
BackgroundDisabledHiddenProperty | This is BackgroundDisabledHiddenProperty, a member of class REXComboBox.
BackgroundDisabledStandardProperty | This is BackgroundDisabledStandardProperty, a member of class REXComboBox.
BackgroundErrorProperty | This is BackgroundErrorProperty, a member of class REXComboBox.
BackgroundNeutralProperty | This is BackgroundNeutralProperty, a member of class REXComboBox.
BackgroundOKProperty | This is BackgroundOKProperty, a member of class REXComboBox.
ComplexDoubleValueProperty | This is ComplexDoubleValueProperty, a member of class REXComboBox.
ComplexProperty | This is ComplexProperty, a member of class REXComboBox.
ComplexSeparatorProperty | This is ComplexSeparatorProperty, a member of class REXComboBox.
ComplexSpaceSeparatorProperty | This is ComplexSpaceSeparatorProperty, a member of class REXComboBox.
ComplexUnitOnEndProperty | This is ComplexUnitOnEndProperty, a member of class REXComboBox.
CorrectValueProperty | This is CorrectValueProperty, a member of class REXComboBox.
DataTypeProperty | This is DataTypeProperty, a member of class REXComboBox.
DoubleValueProperty | This is DoubleValueProperty, a member of class REXComboBox.
EngineeringFormatProperty | This is EngineeringFormatProperty, a member of class REXComboBox.
EpsilonProperty | This is EpsilonProperty, a member of class REXComboBox.
InvalidCharactersProperty | This is InvalidCharactersProperty, a member of class REXComboBox.
ListValidationProperty | This is ListValidationProperty, a member of class REXComboBox.
MaxTokensProperty | This is MaxTokensProperty, a member of class REXComboBox.
MinTokensProperty | This is MinTokensProperty, a member of class REXComboBox.
OnDisableActionProperty | This is OnDisableActionProperty, a member of class REXComboBox.
OriginalTextOnEnterProperty | This is OriginalTextOnEnterProperty, a member of class REXComboBox.
RangeMaxCheckProperty | This is RangeMaxCheckProperty, a member of class REXComboBox.
RangeMaxProperty | This is RangeMaxProperty, a member of class REXComboBox.
RangeMinCheckProperty | This is RangeMinCheckProperty, a member of class REXComboBox.
RangeMinProperty | This is RangeMinProperty, a member of class REXComboBox.
RememberCorrectProperty | This is RememberCorrectProperty, a member of class REXComboBox.
RoundingFractionalProperty | This is RoundingFractionalProperty, a member of class REXComboBox.
RoundingIncrementProperty | This is RoundingIncrementProperty, a member of class REXComboBox.
SeparatorProperty | This is SeparatorProperty, a member of class REXComboBox.