REXExtensionProduct | Represents the Extension element used by the main Extension class to separate product dependent part of the code from general one.
REXExtensionSettings | Allows reading base settings from "Configuration / settings.xml" file.
REXExtensionWindow | Base class for user forms.
REXFoundationApplication | Foundation class for REX.Foundation usage.
REXLayout |
REXLayoutItem | Represents all layout of main control.
REXLogger | This is class REX.Common.REXLogger.
REXResults | Base class for results.
REXRevitAccess | The class dedicated to settings data from Revit.
REXRevitContextAccess | Allaws for access to Revit's objects.
REXUI | Main class which provides access to all data connected with main control.
REXVersion | Foundation class for REX.Foundation usage.
REXWarnings | This is class REX.Common.REXWarnings.
REXWebBrowser | Proxy class for web browser control.

Classes (AutoDoc Folder)

Legend
Legend
Class
abstract
static

REX.Common Namespace Interfaces

REX.Common Namespace Interfaces
REX.Common Namespace Legend
Interfaces
Interface | Description
IREXConnector | This is class REX.Common.IREXConnector.
IREXExtension | Main interface for extension module.
IREXExtension2 | Main interface for extension module.
IREXExtension3 | Main interface for extension module.
IREXExtension4 | Main interface for extension module.
IREXExtensionAccess | Main interface for REXAccess class.
IREXExtensionAccess2 | Main interface for REXAccess class.
IREXExtensionAccess3 | Main interface for REXAccess class.
IREXExtensionAccessUnitsControl | Main interface for REXAccess class.
IREXThisExtension | Base interface for access to main extension's objects.

Interfaces (AutoDoc Folder)

Legend
Legend
Interface
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

Legend

Legend
REX.Common Namespace
Legend
Class
abstract
static
Interface
Enumeration
Structure
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REX.Common Namespace Structs, Records, Enums

REX.Common Namespace Structs, Records, Enums
REX.Common Namespace Legend
Structs, Records, Enums
Struct, Record, Enum | Description
REXCanCloseType | Determines closing mode.
REXSetFormStruct | This is record REX.Common.REXSetFormStruct.

Structs, Records, Enums (AutoDoc Folder)

Legend
Legend
Enumeration
Structure
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

Legend

Legend
IREXConnector Interface
Legend
Method
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

IREXConnector Interface Members

IREXConnector Interface Members
IREXConnector Interface Legend
Members
IREXConnector Methods
IREXConnector Methods | Description
Connect | This is Connect, a member of class IREXConnector.
VerifyVersion | This is VerifyVersion, a member of class IREXConnector.
VerifyVersion | This is VerifyVersion, a member of class IREXConnector.
IREXConnector Properties
IREXConnector Properties | Description
Connected | This is Connected, a member of class IREXConnector.
Installed | This is Installed, a member of class IREXConnector.
IsCOMObject | This is IsCOMObject, a member of class IREXConnector.

Members

Legend
Legend
Method
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

IREXConnector Methods

IREXConnector Methods
IREXConnector Interface Legend
IREXConnector Methods
IREXConnector Methods | Description
Connect | This is Connect, a member of class IREXConnector.
VerifyVersion | This is VerifyVersion, a member of class IREXConnector.
VerifyVersion | This is VerifyVersion, a member of class IREXConnector.

Methods (AutoDoc Folder)

Legend
Legend
Method
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

IREXConnector Properties

IREXConnector Properties
IREXConnector Interface Legend
IREXConnector Properties
IREXConnector Properties | Description
Connected | This is Connected, a member of class IREXConnector.
Installed | This is Installed, a member of class IREXConnector.
IsCOMObject | This is IsCOMObject, a member of class IREXConnector.

Properties (AutoDoc Folder)

Legend
Legend
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

Legend

Legend
IREXExtension2 Interface
Legend
Method
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

IREXExtension2 Interface Members

IREXExtension2 Interface Members
IREXExtension2 Interface Legend
Members
IREXExtension2 Methods
IREXExtension2 Methods | Description
OnCanActivateLayout | Ask for activation - module can modify layout before or after activation.
OnGetExtensionName | Called when get extension name.
OnRegionalSettingsChanged | Called when regional settings changed.

Members

Legend
Legend
Method
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

IREXExtension2 Methods

IREXExtension2 Methods
IREXExtension2 Interface Legend
IREXExtension2 Methods
IREXExtension2 Methods | Description
OnCanActivateLayout | Ask for activation - module can modify layout before or after activation.
OnGetExtensionName | Called when get extension name.
OnRegionalSettingsChanged | Called when regional settings changed.

Legend

Legend
IREXExtension3 Interface
Legend
Method
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

IREXExtension3 Interface Members

IREXExtension3 Interface Members
IREXExtension3 Interface Legend
Members
IREXExtension3 Methods
IREXExtension3 Methods | Description
OnSetContext | Called when regional settings changed.

IREXExtension3 Methods

IREXExtension3 Methods
IREXExtension3 Interface Legend
IREXExtension3 Methods
IREXExtension3 Methods | Description
OnSetContext | Called when regional settings changed.

Legend

Legend
IREXExtension4 Interface
Legend
Method
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

IREXExtension4 Interface Members

IREXExtension4 Interface Members
IREXExtension4 Interface Legend
Members
IREXExtension4 Methods
IREXExtension4 Methods | Description
OnCheckValidity | Called when check validity.

IREXExtension4 Methods

IREXExtension4 Methods
IREXExtension4 Interface Legend
IREXExtension4 Methods
IREXExtension4 Methods | Description
OnCheckValidity | Called when check validity.

Legend

Legend
IREXExtension Interface
Legend
Method