AddLayout_Dialog_Menu | Adds the predefined layout which contains one dialog and standard menu.
AddLayout_Dialog_ToolBarMenu_ToolBar | Adds the predefined layout which contains one dialog, menu as tool bar and tool bar.
AddLayout_OptionsList_Menu_BottomDialog_RightDialog | Adds the predefined layout which contains options list, first dialog on the right side, secound dialog on the bottom and standard menu.
AddLayout_OptionsList_Menu_BottomDialog_RightDialogAndHtmlNoteOnTabs | Adds the predefined layout which contains options list, dialog and html note on tabs on the right side, secound dialog on the bottom and standard menu.
AddLayout_OptionsList_Menu_RightDialog | Adds the predefined layout which contains options list, one dialog and standard menu.
AddLayout_OptionsList_Menu_RightDialogAndViewAndHtmlNoteOnTabs | Adds the predefined layout which contains options list, one dialog, view (or dialog), html note on tabs and standard menu.
AddLayout_OptionsList_Menu_RightDialogAndViewOnTabs | Adds the predefined layout which contains options list, one dialog and view (or dialog) on tabs and standard menu.
AddLayout_OptionsList_ToolBarMenu_ToolBar_BottomDialog_RightDialog | Adds the predefined layout which contains options list, first dialog on the right side and secound dialog on the bottom, tool bar as menu and tool bar.
AddLayout_OptionsList_ToolBarMenu_ToolBar_BottomDialog_RightDialogAndHtmlNoteOnTabs | Adds the predefined layout which contains options list, dialog and html note on tabs on the right side, secound dialog on the bottom and tool bar as menu and tool bar.
AddLayout_OptionsList_ToolBarMenu_ToolBar_RightDialog | Adds the predefined layout which contains options list, one dialog, tool bar as menu and tool bar.
AddLayout_OptionsList_ToolBarMenu_ToolBar_RightDialogAndViewOnTabs | Adds the predefined layout which contains options list, dialog and view (or dialog) on tabs, tool bar as menu and tool bar.
CalculateMainControlSize | This is CalculateMainControlSize, a member of class REXLayout.
Clear | Clears all layouts items.
DeSelect | Called after deselect the specified LayoutItem.
DeSelect | This is DeSelect, a member of class REXLayout.
DisposeControls | Disposes all controls in all added layouts.
GetItem | Gets the layout item identified by mame.
GetLayoutIndex | Gets the index of the layout.
GetLayoutItem | This is GetLayoutItem, a member of class REXLayout.
InsertLayout | Adds the layout.
RemoveLayout | Removes the layout.
Select | Called after select the specified LayoutItem.
Select | This is Select, a member of class REXLayout.
SelectLayout | Selects the layout.
Setup | Setups layout and all layout's items.
ToolboxDeSelect | This is ToolboxDeSelect, a member of class REXLayout.
ToolboxGetItem | This is ToolboxGetItem, a member of class REXLayout.
ToolboxRemoveLayout | This is ToolboxRemoveLayout, a member of class REXLayout.
ToolboxSelect | This is ToolboxSelect, a member of class REXLayout.
ToolboxSelectLayout | This is ToolboxSelectLayout, a member of class REXLayout.
ToolboxSetup | This is ToolboxSetup, a member of class REXLayout.
ToolboxSetup | This is ToolboxSetup, a member of class REXLayout.
ToolboxUpdate | This is ToolboxUpdate, a member of class REXLayout.
Update | Updates layout all layout's items.
REXLayout Properties
REXLayout Properties | Description
CommandsOptions | Gets or sets the options for commands.
CommandsOptionsByEnum | Gets or sets the options for commands.
ConstOptions | Gets or sets the const options for all layouts.
ConstOptionsByEnum | Gets or sets the const options for all layouts.
Count | Gets the count of layout items.
Current | Gets the current layout item.
DefaultOptions | Gets or sets the default options for layout.
DisableEvents | Gets a value indicating whether events are disabled.
Links
REX.Common Namespace, Legend, Members, Public Methods, REXLayout Methods, REXLayout Properties

REXLayout.REXLayout Constructor

REXLayout.REXLayout Constructor
REXLayout Class REX.Common Namespace REXLayout Class

Initializes a new instance of the REXLayout class.

C#
public REXLayout(REXUI UI);
Parameters
Parameters | Description
UI | The refernce to UI class.
Description
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class

REXLayout.AddLayout Method (REXLayoutItem)

REXLayout.AddLayout Method (REXLayoutItem)
REXLayout Class REX.Common Namespace REXLayout Class

Adds the layout.

C#
public void AddLayout(REXLayoutItem LayoutItem);
Parameters
Parameters | Description
LayoutItem | The layout item.
Description
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class

REXLayout.AddLayout Method (REXLayoutItem, int)

REXLayout.AddLayout Method (REXLayoutItem, int)
REXLayout Class REX.Common Namespace REXLayout Class

Adds the layout.

C#
public void AddLayout(REXLayoutItem LayoutItem, int PreviousLayoutIndex);
Parameters
Parameters | Description
LayoutItem | The layout item.
PreviousLayoutIndex | Index of the previous layout.
Description
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class

REXLayout.AddLayout Method (REXLayoutItem, string)

REXLayout.AddLayout Method (REXLayoutItem, string)
REXLayout Class REX.Common Namespace REXLayout Class

Adds the layout.

C#
public void AddLayout(REXLayoutItem LayoutItem, string PreviousLayoutName);
Parameters
Parameters | Description
LayoutItem | The layout item.
PreviousLayoutName | Name of the previous layout.
Description
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class

REXLayout.AddLayout_Dialog Method

REXLayout.AddLayout_Dialog Method
REXLayout Class REX.Common Namespace REXLayout Class

Adds the predefined layout with one dialog.

C#
public void AddLayout_Dialog(string Name, string GroupName, string Description, Control Dialog, ImageSource LayoutImage);
Parameters
Parameters | Description
Name | The name of layout.
GroupName | Name of the group.
Description | The description.
Dialog | The dialog control.
LayoutImage | The layout image.
Description
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class

REXLayout.AddLayout_Dialog_Menu Method

REXLayout.AddLayout_Dialog_Menu Method
REXLayout Class REX.Common Namespace REXLayout Class

Adds the predefined layout which contains one dialog and standard menu.

C#
public void AddLayout_Dialog_Menu(string Name, string GroupName, string Description, Control Dialog, ImageSource LayoutImage);
Parameters
Parameters | Description
Name | The name of the layout.
GroupName | Name of the group.
Description | The description.
Dialog | The dialog control.
LayoutImage | The layout image.
Description
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class

REXLayout.AddLayout_Dialog_ToolBarMenu_ToolBar Method

REXLayout.AddLayout_Dialog_ToolBarMenu_ToolBar Method
REXLayout Class REX.Common Namespace REXLayout Class

Adds the predefined layout which contains one dialog, menu as tool bar and tool bar.

C#
public void AddLayout_Dialog_ToolBarMenu_ToolBar(string Name, string GroupName, string Description, Control Dialog, ImageSource LayoutImage);
Parameters
Parameters | Description
Name | The name of the layout.
GroupName | Name of the group.
Description | The description.
Dialog | The dialog control.
LayoutImage | The layout image.
Description
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class

REXLayout.AddLayout_OptionsList_Menu_BottomDialog_RightDialog Method

REXLayout.AddLayout_OptionsList_Menu_BottomDialog_RightDialog Method
REXLayout Class REX.Common Namespace REXLayout Class

Adds the predefined layout which contains options list, first dialog on the right side, secound dialog on the bottom and standard menu.

C#
public void AddLayout_OptionsList_Menu_BottomDialog_RightDialog(string Name, string GroupName, string Description, Control Dialog, Control BottomDialog, ImageSource LayoutImage);
Parameters