AddLayout_Dialog_Menu | Adds the predefined layout which contains one dialog and standard menu.
AddLayout_Dialog_ToolBarMenu_ToolBar | Adds the predefined layout which contains one dialog, menu as tool bar and tool bar.
AddLayout_OptionsList_Menu_BottomDialog_RightDialog | Adds the predefined layout which contains options list, first dialog on the right side, secound dialog on the bottom and standard menu.
AddLayout_OptionsList_Menu_BottomDialog_RightDialogAndHtmlNoteOnTabs | Adds the predefined layout which contains options list, dialog and html note on tabs on the right side, secound dialog on the bottom and standard menu.
AddLayout_OptionsList_Menu_RightDialog | Adds the predefined layout which contains options list, one dialog and standard menu.
AddLayout_OptionsList_Menu_RightDialogAndViewAndHtmlNoteOnTabs | Adds the predefined layout which contains options list, one dialog, view (or dialog), html note on tabs and standard menu.
AddLayout_OptionsList_Menu_RightDialogAndViewOnTabs | Adds the predefined layout which contains options list, one dialog and view (or dialog) on tabs and standard menu.
AddLayout_OptionsList_ToolBarMenu_ToolBar_BottomDialog_RightDialog | Adds the predefined layout which contains options list, first dialog on the right side and secound dialog on the bottom, tool bar as menu and tool bar.
AddLayout_OptionsList_ToolBarMenu_ToolBar_BottomDialog_RightDialogAndHtmlNoteOnTabs | Adds the predefined layout which contains options list, dialog and html note on tabs on the right side, secound dialog on the bottom and tool bar as menu and tool bar.
AddLayout_OptionsList_ToolBarMenu_ToolBar_RightDialog | Adds the predefined layout which contains options list, one dialog, tool bar as menu and tool bar.
AddLayout_OptionsList_ToolBarMenu_ToolBar_RightDialogAndViewOnTabs | Adds the predefined layout which contains options list, dialog and view (or dialog) on tabs, tool bar as menu and tool bar.
CalculateMainControlSize | This is CalculateMainControlSize, a member of class REXLayout.
Clear | Clears all layouts items.
DeSelect | Called after deselect the specified LayoutItem.
DeSelect | This is DeSelect, a member of class REXLayout.
DisposeControls | Disposes all controls in all added layouts.
GetItem | Gets the layout item identified by mame.
GetLayoutIndex | Gets the index of the layout.
GetLayoutItem | This is GetLayoutItem, a member of class REXLayout.
InsertLayout | Adds the layout.
RemoveLayout | Removes the layout.
Select | Called after select the specified LayoutItem.
Select | This is Select, a member of class REXLayout.
SelectLayout | Selects the layout.
Setup | Setups layout and all layout's items.
ToolboxDeSelect | This is ToolboxDeSelect, a member of class REXLayout.
ToolboxGetItem | This is ToolboxGetItem, a member of class REXLayout.
ToolboxRemoveLayout | This is ToolboxRemoveLayout, a member of class REXLayout.
ToolboxSelect | This is ToolboxSelect, a member of class REXLayout.
ToolboxSelectLayout | This is ToolboxSelectLayout, a member of class REXLayout.
ToolboxSetup | This is ToolboxSetup, a member of class REXLayout.
ToolboxSetup | This is ToolboxSetup, a member of class REXLayout.
ToolboxUpdate | This is ToolboxUpdate, a member of class REXLayout.
Update | Updates layout all layout's items.

REXLayout Properties

REXLayout Properties
REXLayout Class Legend
REXLayout Properties
REXLayout Properties | Description
CommandsOptions | Gets or sets the options for commands.
CommandsOptionsByEnum | Gets or sets the options for commands.
ConstOptions | Gets or sets the const options for all layouts.
ConstOptionsByEnum | Gets or sets the const options for all layouts.
Count | Gets the count of layout items.
Current | Gets the current layout item.
DefaultOptions | Gets or sets the default options for layout.
DisableEvents | Gets a value indicating whether events are disabled.

REXLayout Class Public Methods

REXLayout Class Public Methods
REXLayout Class Legend
Public Methods
Public Method | Description
REXLayout | Initializes a new instance of the REXLayout class.

REXLayoutItem Enumerations

REXLayoutItem Enumerations
REXLayoutItem Class Legend
REXLayoutItem Enumerations
REXLayoutItem Enumerations | Description
LayoutType | Determines type of layout item.

REXLayoutItem Fields

REXLayoutItem Fields
REXLayoutItem Class Legend
REXLayoutItem Fields
REXLayoutItem Fields | Description
ActiveTabPage | Gets or sets ActiveTabPage attribute of layout.
Description | Gets or sets Description attribute of layout.
Dialog | Gets or sets Dialog attribute of layout.
DisableCommands | Gets or sets DisableCommands attribute of layout.
GroupName | Gets or sets GroupName attribute of layout.
LayoutImage | Gets or sets LayoutImage attribute of layout.
Name | Gets or sets Name attribute of layout.
Options | Gets or sets Options attribute of layout.
Type | Gets or sets Type attribute of layout.
View | Gets or sets View attribute of layout.
Visible | Gets or sets visibility attribute of layout.

Legend

Legend
REXLayoutItem Class
Legend
Constructor
Enumeration
Data Member
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXLayoutItem Class Members

REXLayoutItem Class Members
REXLayoutItem Class Legend
Members
Public Methods
Public Method | Description
REXLayoutItem | Initializes a new instance of the REXLayoutItem class.
REXLayoutItem | Initializes a new instance of the REXLayoutItem class.
REXLayoutItem | Initializes a new instance of the REXLayoutItem class.
REXLayoutItem | Initializes a new instance of the REXLayoutItem class.
REXLayoutItem | Initializes a new instance of the REXLayoutItem class.
REXLayoutItem | Initializes a new instance of the REXLayoutItem class.
REXLayoutItem | Initializes a new instance of the REXLayoutItem class.
REXLayoutItem | Initializes a new instance of the REXLayoutItem class.
REXLayoutItem | Initializes a new instance of the REXLayoutItem class.
REXLayoutItem Enumerations
REXLayoutItem Enumerations | Description
LayoutType | Determines type of layout item.
REXLayoutItem Fields
REXLayoutItem Fields | Description
ActiveTabPage | Gets or sets ActiveTabPage attribute of layout.
Description | Gets or sets Description attribute of layout.
Dialog | Gets or sets Dialog attribute of layout.
DisableCommands | Gets or sets DisableCommands attribute of layout.
GroupName | Gets or sets GroupName attribute of layout.
LayoutImage | Gets or sets LayoutImage attribute of layout.
Name | Gets or sets Name attribute of layout.
Options | Gets or sets Options attribute of layout.
Type | Gets or sets Type attribute of layout.
View | Gets or sets View attribute of layout.
Visible | Gets or sets visibility attribute of layout.
REXLayoutItem Properties
REXLayoutItem Properties | Description
DefaultDialogSize | Gets the default size of the dialog.
DefaultViewSize | Gets the default size of the view.

Members

Legend
Legend
Constructor
Enumeration
Data Member
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXLayoutItem Properties

REXLayoutItem Properties
REXLayoutItem Class Legend
REXLayoutItem Properties
REXLayoutItem Properties | Description
DefaultDialogSize | Gets the default size of the dialog.
DefaultViewSize | Gets the default size of the view.

REXLayoutItem Class Public Methods

REXLayoutItem Class Public Methods
REXLayoutItem Class Legend
Public Methods
Public Method | Description
REXLayoutItem | Initializes a new instance of the REXLayoutItem class.
REXLayoutItem | Initializes a new instance of the REXLayoutItem class.
REXLayoutItem | Initializes a new instance of the REXLayoutItem class.
REXLayoutItem | Initializes a new instance of the REXLayoutItem class.