ThisRunContext | Gets the this run context.
UI | Get the reference to UI object.
Units | Get the reference to Units object.

REXExtension Class Public Methods

REXExtension Class Public Methods
REXExtension Class Legend
Public Methods
Public Method | Description
REXExtension | Initializes a new instance of the REXExtension class.

REXExtensionContext Enumerations

REXExtensionContext Enumerations
REXExtensionContext Class Legend
REXExtensionContext Enumerations
REXExtensionContext Enumerations | Description
REXLevelType | Level type.
REXStandardOwner | Owner of module.
REXStandardRunContext | Defines standard running context.

REXExtensionContext Fields

REXExtensionContext Fields
REXExtensionContext Class Legend
REXExtensionContext Fields
REXExtensionContext Fields | Description
Control | Reference to Control object.

Legend

Legend
REXExtensionContext Class
Legend
Constructor
Structure
Enumeration
Data Member
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXExtensionContext Class Members

REXExtensionContext Class Members
REXExtensionContext Class Legend
Members
Public Methods
Public Method | Description
REXExtensionContext | Initializes a new instance of a REXExtensionContext class and sets defaults.
REXExtensionContext Structures
REXExtensionContext Structures | Description
REXControl | Controls behavior of module.
REXControlFlags | Flags used for detecting forced settings.
REXExtensionContext Enumerations
REXExtensionContext Enumerations | Description
REXLevelType | Level type.
REXStandardOwner | Owner of module.
REXStandardRunContext | Defines standard running context.
REXExtensionContext Fields
REXExtensionContext Fields | Description
Control | Reference to Control object.

Members

Legend
Legend
Constructor
Structure
Enumeration
Data Member
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXExtensionContext Class Public Methods

REXExtensionContext Class Public Methods
REXExtensionContext Class Legend
Public Methods
Public Method | Description
REXExtensionContext | Initializes a new instance of a REXExtensionContext class and sets defaults.

REXExtensionContext Structures

REXExtensionContext Structures
REXExtensionContext Class Legend
REXExtensionContext Structures
REXExtensionContext Structures | Description
REXControl | Controls behavior of module.
REXControlFlags | Flags used for detecting forced settings.

Structures (AutoDoc Folder)

Legend
Legend
Structure
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXControl Fields

REXControl Fields
REXExtensionContext.REXControl Structure Legend
REXControl Fields
REXControl Fields | Description
APIContext | Indicates that module is running in API context.
Flags | Flags used for detecting forced settings.
ForceHideManager | Orders to hide manager of extensions.
InteractiveCommand | Indicates that module uses interactive modal dialog.
LanguagesSupport | Indicates that module has multi-language architecture.
LevelType | Level type.
NoUI | Indicates that module can't show any messages and dialogs.
Owner | Owner of extension.
RegionalSettingsSupport | If true, regional settings will be added to menu and toolbars.
RunContext | String which set up running context.
ShowErrorsDialog | Enables or disables showing of errors in dialog.
StandardOwner | Owner of extension.
StandardRunContext | String mapped to enum which set up running context.
VerifySelection | Indicates that module is running for verification current selection.

Legend

Legend
REXExtensionContext.REXControl Structure
Legend
Data Member
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXExtensionContext.REXControl Structure Members

REXExtensionContext.REXControl Structure Members
REXExtensionContext.REXControl Structure Legend
Members
REXControl Fields
REXControl Fields | Description
APIContext | Indicates that module is running in API context.
Flags | Flags used for detecting forced settings.
ForceHideManager | Orders to hide manager of extensions.
InteractiveCommand | Indicates that module uses interactive modal dialog.
LanguagesSupport | Indicates that module has multi-language architecture.
LevelType | Level type.
NoUI | Indicates that module can't show any messages and dialogs.
Owner | Owner of extension.
RegionalSettingsSupport | If true, regional settings will be added to menu and toolbars.
RunContext | String which set up running context.
ShowErrorsDialog | Enables or disables showing of errors in dialog.
StandardOwner | Owner of extension.
StandardRunContext | String mapped to enum which set up running context.
VerifySelection | Indicates that module is running for verification current selection.
REXControl Properties
REXControl Properties | Description
UserInterface | Enables or disables user interface operations.

Members

Legend
Legend
Data Member
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXControl Properties

REXControl Properties
REXExtensionContext.REXControl Structure Legend
REXControl Properties
REXControl Properties | Description
UserInterface | Enables or disables user interface operations.

Legend

Legend
REXExtensionControl Class
Legend
Constructor
virtual
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXExtensionControl Class Members

REXExtensionControl Class Members
REXExtensionControl Class Legend
Members
Public Methods
Public Method | Description
REXExtensionControl | Initializes a new instance of a REXExtensionControl class.
REXExtensionControl | Initializes a new instance of a REXExtensionControl class.
REXExtensionControl Methods
REXExtensionControl Methods | Description
OnActivateLayout | Called when activate layout.
REXExtensionControl Properties
REXExtensionControl Properties | Description
ThisApplication | Get this application.
ThisContext | Get this context.
ThisExtension | Get this extension.
ThisProduct | Gets the this product.
ThisRunContext | Gets the this run context.

REXExtensionControl Methods

REXExtensionControl Methods
REXExtensionControl Class Legend
REXExtensionControl Methods
REXExtensionControl Methods | Description
OnActivateLayout | Called when activate layout.

REXExtensionControl Properties

REXExtensionControl Properties
REXExtensionControl Class Legend
REXExtensionControl Properties
REXExtensionControl Properties | Description
ThisApplication | Get this application.
ThisContext | Get this context.
ThisExtension | Get this extension.
ThisProduct | Gets the this product.
ThisRunContext | Gets the this run context.

REXExtensionControl Class Public Methods

REXExtensionControl Class Public Methods
REXExtensionControl Class Legend
Public Methods
Public Method | Description
REXExtensionControl | Initializes a new instance of a REXExtensionControl class.
REXExtensionControl | Initializes a new instance of a REXExtensionControl class.

REXExtensionData Enumerations

REXExtensionData Enumerations
REXExtensionData Class Legend
REXExtensionData Enumerations
REXExtensionData Enumerations | Description