REXSectionTypeAnalyzer_IASYM | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_IASYM.
REXSectionTypeAnalyzer_L | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_L.
REXSectionTypeAnalyzer_POLYG | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_POLYG.
REXSectionTypeAnalyzer_POLYGHOLLOW | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_POLYGHOLLOW.
REXSectionTypeAnalyzer_RECT | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_RECT.
REXSectionTypeAnalyzer_RECTHOLLOW | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_RECTHOLLOW.
REXSectionTypeAnalyzer_ROUND | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_ROUND.
REXSectionTypeAnalyzer_ROUNDH | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_ROUNDH.
REXSectionTypeAnalyzer_ROUNDQ | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_ROUNDQ.
REXSectionTypeAnalyzer_T | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_T.
REXSectionTypeAnalyzer_TASYM | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_TASYM.
REXSectionTypeAnalyzer_TUBE | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_TUBE.
REXSectionTypeAnalyzer_Z | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_Z.
Structs, Records, Enums
Struct, Record, Enum | Description
EArcDir | Describes the direction of an arc.
EContElemType | Represents the type of the element.
ECoords | Describes the coordinate system type.
Links
Legend, Classes, Structs, Records, Enums
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

Contour_3D Class

Contour_3D Class
REX.ContentGenerator.Geometry Namespace Legend Members Public Methods Contour_3D Methods

Represents contour 3D.

Class Hierarchy
C#
public class Contour_3D : ContourCont;
Description
Namespace

REX.ContentGenerator.Geometry Namespace

Public Methods
Public Method | Description
Contour_3D | Initializes a new instance of the Contour_3D class.
Contour_3D | Initializes a new instance of the Contour_3D class.
Contour_3D | Initializes a new instance of the Contour_3D class.
Contour_3D Methods
Contour_3D Methods | Description
ArcTo | Defines an arc.
LineTo | Defines a line to the specific point.
LineTo | Defines a line to the specific point.
Reverse | Reverses elements.
StartContour | Starts the defintion of the contour.
Links
REX.ContentGenerator.Geometry Namespace, Legend, Members, Public Methods, Contour_3D Methods

Contour_3D.Contour_3D Constructor ()

Contour_3D.Contour_3D Constructor ()
Contour_3D Class REX.ContentGenerator.Geometry Namespace Contour_3D Class

Initializes a new instance of the Contour_3D class.

C#
public Contour_3D();
Description
Class

Contour_3D Class

Links
Contour_3D Class, REX.ContentGenerator.Geometry Namespace, Contour_3D Class

Contour_3D.Contour_3D Constructor (Contour_3D)

Contour_3D.Contour_3D Constructor (Contour_3D)
Contour_3D Class REX.ContentGenerator.Geometry Namespace Contour_3D Class

Initializes a new instance of the Contour_3D class.

C#
public Contour_3D(Contour_3D pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

Contour_3D Class

Links
Contour_3D Class, REX.ContentGenerator.Geometry Namespace, Contour_3D Class

Contour_3D.Contour_3D Constructor (List<REXxyz>)

Contour_3D.Contour_3D Constructor (List<REXxyz>)
Contour_3D Class REX.ContentGenerator.Geometry Namespace Contour_3D Class

Initializes a new instance of the Contour_3D class.

C#
public Contour_3D(List<REXxyz> points);
Parameters
Parameters | Description
points | The points.
Description
Class

Contour_3D Class

Links
Contour_3D Class, REX.ContentGenerator.Geometry Namespace, Contour_3D Class

Contour_3D.ArcTo Method

Contour_3D.ArcTo Method
Contour_3D Class REX.ContentGenerator.Geometry Namespace Contour_3D Class

Defines an arc.

C#
public void ArcTo(REXxyz pt, REXxyz middle);
Parameters
Parameters | Description
pt | The point.
middle | The middle point.
Description
Class

Contour_3D Class

Links
Contour_3D Class, REX.ContentGenerator.Geometry Namespace, Contour_3D Class

Contour_3D.LineTo Method (REXxyz)

Contour_3D.LineTo Method (REXxyz)
Contour_3D Class REX.ContentGenerator.Geometry Namespace Contour_3D Class

Defines a line to the specific point.

C#
public void LineTo(REXxyz pt);
Parameters
Parameters | Description
pt | The point.
Description
Class

Contour_3D Class

Links
Contour_3D Class, REX.ContentGenerator.Geometry Namespace, Contour_3D Class

Contour_3D.LineTo Method (REXxyz, bool)

Contour_3D.LineTo Method (REXxyz, bool)
Contour_3D Class REX.ContentGenerator.Geometry Namespace Contour_3D Class

Defines a line to the specific point.

C#
public void LineTo(REXxyz pt, bool trans);
Parameters
Parameters | Description
pt | The point or the vector.
trans | Indicates whether pt should be taken as a point or a transversal vector.
Description
Class

Contour_3D Class

Links
Contour_3D Class, REX.ContentGenerator.Geometry Namespace, Contour_3D Class

Contour_3D.Reverse Method

Contour_3D.Reverse Method
Contour_3D Class REX.ContentGenerator.Geometry Namespace Contour_3D Class

Reverses elements.

C#
public void Reverse();
Description
Class

Contour_3D Class

Links
Contour_3D Class, REX.ContentGenerator.Geometry Namespace, Contour_3D Class

Contour_3D.StartContour Method

Contour_3D.StartContour Method
Contour_3D Class REX.ContentGenerator.Geometry Namespace Contour_3D Class

Starts the defintion of the contour.

C#
public void StartContour(REXxyz pt);
Parameters
Parameters | Description
pt | The point.
Description
Class

Contour_3D Class

Links
Contour_3D Class, REX.ContentGenerator.Geometry Namespace, Contour_3D Class

Contour_Compound2D Class

Contour_Compound2D Class
REX.ContentGenerator.Geometry Namespace Legend Members Public Methods Contour_Compound2D Methods Contour_Compound2D Properties

Represents the compound contour.

Class Hierarchy
C#
[Serializable()]
public class Contour_Compound2D : SerializableObject;
Description
Namespace

REX.ContentGenerator.Geometry Namespace

Public Methods
Public Method | Description
Contour_Compound2D | Initializes a new instance of the Contour_Compound2D class.
Contour_Compound2D | Initializes a new instance of the Contour_Compound2D class.
Contour_Compound2D | Initializes a new instance of the Contour_Compound2D class.
Contour_Compound2D | Initializes a new instance of the Contour_Compound2D class.
Contour_Compound2D Methods
Contour_Compound2D Methods | Description
ArcTo | Defines an arc.
ArcTo | Defines an arc.
AxisLine | Defines an axis line.
Circle | Defines a circle.
Dimension | Defines a dimension.
DimensionLine | Defines a dimension line.
DimensionLine | Defines a dimension line.
DimensionRadius | Defines a radial dimension.
GetBoundingBox | Gets the bounding box.
GetGeometryParams | Gets the geometry params.
GetPoint | Gets the point in the specified plane.
LineTo | Defines a line to the specified point.
LineTo | Defines a line to the specified point.
LineToX | Defines a line to the specified point (parallel to X axis).
LineToY | Defines a line to the specified point (parallel to Y axis).
LoadFromString | Loads the contour from the string.
MultiplyLengthDim | Multiplies all length dimensions by the input coefficient.
SaveToString | Saves the contour to the string.
StartContour | Starts the definition of the contour.
StartContour | Starts the definition of the contour.
StartContour | Starts the definition of the contour.
Translate | Applies the specified translation vector to all elements.
Contour_Compound2D Properties
Contour_Compound2D Properties | Description
Axis | Gets or sets the list of axis.
Dimensions | Gets or sets the list of dimensions.
Shape | Gets or sets the list of shapes.
Links