Returns

Returns true if the object was registered.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class

REXDFM.AddUnitObject Method (IUnitObject, string, Autodesk.REX.Framework.EUnitType, int)

REXDFM.AddUnitObject Method (IUnitObject, string, Autodesk.REX.Framework.EUnitType, int)
REXDFM Class REX.Common Namespace REXDFM Class

Registers an object which implements the IUnitObject interface.

C#
public bool AddUnitObject(IUnitObject myUnitObject, string nameUnitObject, Autodesk.REX.Framework.EUnitType UnitType, int power);
Parameters
Parameters | Description
myUnitObject | The reference to the object.
nameUnitObject | The name of the unit object.
UnitType | The type of the unit.
power | The power of the unit.
Returns

Returns true if the object was registered.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class

REXDFM.AfterParamsChange Method

REXDFM.AfterParamsChange Method
REXDFM Class REX.Common Namespace REXDFM Class

Method called after parameters change.

C#
public void AfterParamsChange();
Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class

REXDFM.BeforeParamsChange Method

REXDFM.BeforeParamsChange Method
REXDFM Class REX.Common Namespace REXDFM Class

Method called before parameters change.

C#
public void BeforeParamsChange();
Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class

REXDFM.Clear Method

REXDFM.Clear Method
REXDFM Class REX.Common Namespace REXDFM Class

Clears this instance.

C#
public void Clear();
Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class

REXDFM.CreateGroupControl Method (System.Windows.Controls.ContentControl)

REXDFM.CreateGroupControl Method (System.Windows.Controls.ContentControl)
REXDFM Class REX.Common Namespace REXDFM Class

Creates the group of controls from collection of controls and all childrenss.

C#
public void CreateGroupControl(System.Windows.Controls.ContentControl contentControl);
Parameters
Parameters | Description
controls | The controls.
Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class

REXDFM.CreateGroupControl Method (System.Windows.Controls.UserControl)

REXDFM.CreateGroupControl Method (System.Windows.Controls.UserControl)
REXDFM Class REX.Common Namespace REXDFM Class

Creates the group of controls from all childrens.

C#
public void CreateGroupControl(System.Windows.Controls.UserControl myUserControl);
Parameters
Parameters | Description
myUserControl | My user control.
Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class

REXDFM.CreateGroupControl Method (System.Windows.Forms.Control.ControlCollection)

REXDFM.CreateGroupControl Method (System.Windows.Forms.Control.ControlCollection)
REXDFM Class REX.Common Namespace REXDFM Class

Creates the group of controls from collection of controls and all childrenss.

C#
public void CreateGroupControl(System.Windows.Forms.Control.ControlCollection controls);
Parameters
Parameters | Description
controls | The controls.
Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class

REXDFM.CreateGroupControl Method (System.Windows.Forms.UserControl)

REXDFM.CreateGroupControl Method (System.Windows.Forms.UserControl)
REXDFM Class REX.Common Namespace REXDFM Class

Creates the group of controls from all childrens.

C#
public void CreateGroupControl(System.Windows.Forms.UserControl myUserControl);
Parameters
Parameters | Description
myUserControl | My user control.
Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class

REXDFM.GetComplexDataBase Method (IUnitObject)

REXDFM.GetComplexDataBase Method (IUnitObject)
REXDFM Class REX.Common Namespace REXDFM Class

Gets the values and convert it to base units.

C#
public List<double> GetComplexDataBase(IUnitObject myUnitObject);
Parameters
Parameters | Description
myUnitObject | The reference to the unit object.
Returns

Returns the list of values.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class

REXDFM.GetComplexDataBase Method (string)

REXDFM.GetComplexDataBase Method (string)
REXDFM Class REX.Common Namespace REXDFM Class

Gets the values and converts them to base units.

C#
public List<double> GetComplexDataBase(string nameUnitObject);
Parameters
Parameters | Description
nameUnitObject | The name of the unit object.
Returns

Returns the list of values.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class

REXDFM.GetComplexDataDisplay Method (IUnitObject)

REXDFM.GetComplexDataDisplay Method (IUnitObject)
REXDFM Class REX.Common Namespace REXDFM Class

Gets the values and convert it to display units.

C#
public List<double> GetComplexDataDisplay(IUnitObject myUnitObject);
Parameters
Parameters | Description
myUnitObject | The reference to the unit object.
Returns

Returns the list of values.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class

REXDFM.GetComplexDataDisplay Method (string)

REXDFM.GetComplexDataDisplay Method (string)
REXDFM Class REX.Common Namespace REXDFM Class

Gets the values and convert it to display units.

C#
public List<double> GetComplexDataDisplay(string nameUnitObject);
Parameters
Parameters | Description
nameUnitObject | The name of the unit object.
Returns

Returns the list of values.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class

REXDFM.GetComplexDataInterface Method (IUnitObject)

REXDFM.GetComplexDataInterface Method (IUnitObject)
REXDFM Class REX.Common Namespace REXDFM Class

Gets the values and convert it to interface units.

C#
public List<double> GetComplexDataInterface(IUnitObject myUnitObject);
Parameters
Parameters | Description
myUnitObject | The reference to the unit object.
Returns

Returns the list of values.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class

REXDFM.GetComplexDataInterface Method (string)

REXDFM.GetComplexDataInterface Method (string)
REXDFM Class REX.Common Namespace REXDFM Class

Gets the values and converts it to interface units.

C#
public List<double> GetComplexDataInterface(string nameUnitObject);
Parameters
Parameters | Description
nameUnitObject | The name of the unit object.
Returns

Returns the list of values.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class

REXDFM.GetDataBase Method (IUnitObject)

REXDFM.GetDataBase Method (IUnitObject)
REXDFM Class REX.Common Namespace REXDFM Class

Gets the value and converts it to base units.

C#
public double GetDataBase(IUnitObject myUnitObject);
Parameters
Parameters | Description
myUnitObject | The reference to the unit object.
Returns

Returns value.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class

REXDFM.GetDataBase Method (string)

REXDFM.GetDataBase Method (string)
REXDFM Class REX.Common Namespace REXDFM Class

Gets the value and converts it to base units.

C#
public double GetDataBase(string nameUnitObject);
Parameters
Parameters | Description
nameUnitObject | The name of the unit object.
Returns

Returns value.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class

REXDFM.GetDataDisplay Method (IUnitObject)

REXDFM.GetDataDisplay Method (IUnitObject)
REXDFM Class REX.Common Namespace REXDFM Class

Gets the value and converts it to display units.

C#
public double GetDataDisplay(IUnitObject myUnitObject);
Parameters
Parameters | Description
myUnitObject | The reference to the unit object.
Returns

Returns value.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class

REXDFM.GetDataDisplay Method (string)

REXDFM.GetDataDisplay Method (string)
REXDFM Class REX.Common Namespace REXDFM Class