REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Gets the index specifying the currently selected item.

C#
public int GetSelectedIndex();
Returns

The index.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class

REXComboBox.GetState Method

REXComboBox.GetState Method
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Gets the current state of the control.

C#
public EControlState GetState();
Returns

The state of the control.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class

REXComboBox.GetText Method

REXComboBox.GetText Method
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Gets the text contents of the control.

C#
public string GetText();
Returns

The text contents of the control.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class

REXComboBox.GetUniqueName Method

REXComboBox.GetUniqueName Method
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Returns the Unique ID generated for the current instance of the engine.

C#
public string GetUniqueName();
Returns

The unique ID.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class

REXComboBox.GetValue Method

REXComboBox.GetValue Method
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Gets the value of the double type.

C#
public double GetValue();
Returns

The value.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class

REXComboBox.Refresh Method

REXComboBox.Refresh Method
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Refreshes the text on the control based on the current text.

C#
public void Refresh();
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class

REXComboBox.RefreshValidationStatus Method

REXComboBox.RefreshValidationStatus Method
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Refreshes the validation status.

C#
public void RefreshValidationStatus();
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class

REXComboBox.Reset Method

REXComboBox.Reset Method
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Resets control (internal values).

C#
public void Reset();
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class

REXComboBox.RestorePropertiesType Method

REXComboBox.RestorePropertiesType Method
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Restores the mode of the combo.

C#
public void RestorePropertiesType();
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class

REXComboBox.SetBackground Method

REXComboBox.SetBackground Method
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Sets the background of the control.

C#
public void SetBackground(object brush);
Parameters
Parameters | Description
background | The background.
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class

REXComboBox.SetComplexValue Method (List<double>)

REXComboBox.SetComplexValue Method (List<double>)
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Sets the complex (list) value of the string type.

C#
public void SetComplexValue(List<double> values);
Parameters
Parameters | Description
value | The value.
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class

REXComboBox.SetComplexValue Method (List<string>)

REXComboBox.SetComplexValue Method (List<string>)
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Sets the complex (list) value of the string type.

C#
public void SetComplexValue(List<string> values);
Parameters
Parameters | Description
value | The value.
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class

REXComboBox.SetComplexValue Method (String)

REXComboBox.SetComplexValue Method (String)
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Set complex value to the control

C#
public bool SetComplexValue(String value);
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class

REXComboBox.SetEnable Method

REXComboBox.SetEnable Method
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Sets the enable state.

C#
public void SetEnable(bool enable);
Parameters
Parameters | Description
enable | If the control is to be enabled.
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class

REXComboBox.SetExternalUnitBody Method

REXComboBox.SetExternalUnitBody Method
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Sets external IUnitBody object for custom unit processing.

C#
public void SetExternalUnitBody(IUnitBody unitBody);
Parameters
Parameters | Description
unitBody | External IUnitBody.
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class

REXComboBox.SetPropertiesType Method

REXComboBox.SetPropertiesType Method
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Sets the mode of the combo.

C#
public void SetPropertiesType(EComboPropertiesType propertiesType);
Parameters
Parameters | Description
propertiesType | The mode of the combo.
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class

REXComboBox.SetSelectedIndex Method

REXComboBox.SetSelectedIndex Method
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Sets the index specifying the currently selected item.

C#
public void SetSelectedIndex(int index);
Parameters
Parameters | Description
index | The index of the selected item.
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class

REXComboBox.SetText Method

REXComboBox.SetText Method
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Sets the text contents of the control.

C#
public void SetText(string txt);
Parameters
Parameters | Description
txt | The text.
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class

REXComboBox.SetUserTextValidation Method

REXComboBox.SetUserTextValidation Method
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Sets the user validation method for the text control.

C#
public void SetUserTextValidation(UserTextValidation ValidFunction);
Parameters
Parameters | Description
ValidFunction | The validation method.
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class

REXComboBox.SetUserValidation Method

REXComboBox.SetUserValidation Method
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Sets the user validation method.

C#
public void SetUserValidation(UserValidation ValidFunction);
Parameters
Parameters | Description
ValidFunction | The validation method.
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class

REXComboBox.SetUserValidationComplex Method

REXComboBox.SetUserValidationComplex Method
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Sets the user validation method for complex values (list).

C#
public void SetUserValidationComplex(UserValidationComplex ValidFunction);
Parameters
Parameters | Description
ValidFunction | The validation method.
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class

REXComboBox.SetValue Method (Double)

REXComboBox.SetValue Method (Double)