RVTFamilyConverter rvt = new RVTFamilyConverter(commandData, true);

//Iteration threw all rebars selected in Revit.
FilteredElementCollector filterCollector = new FilteredElementCollector(commandData.Application.ActiveUIDocument.Document);
foreach (Element el in filterCollector.WhereElementIsElementType())
{
    ECategoryType category = rvt.GetCertifiedCategoryOfElement(el);

    REXFamilyType familyType = null;

    if (category != ECategoryType.UNKNOWN)//certified
    {
           familyType = rvt.GetFamily(el, category);
    }
    else//not certified
    {
        if (el is RebarHookType)
        {
            familyType = rvt.GetFamily(el, ECategoryType.REBAR_HOOK);
        }
        else if(el is RebarBarType)
        {
            familyType = rvt.GetFamily(el, ECategoryType.REBAR_BARTYPE);
        }
        else if (el is RebarShape)
        {
            familyType = rvt.GetFamily(el, ECategoryType.REBAR_SHAPE);
        }
        else if (el is FamilyInstance)
       {
            familyType = rvt.GetFamily(el, ECategoryType.SECTION_PARAM);
        }
    }
}

Example

Example
RVTFamilyConverter.GetElement Method (REXFamilyType, ECategoryType)

The example shows how to get Revit element bases on the REXFamilyType object.

//Initialize the converter.
RVTFamilyConverter rvt = new RVTFamilyConverter(commandData, true);

//creating parametric description
REXFamilyType_ParamSection paramSection = new REXFamilyType_ParamSection();
paramSection.ElementType = REX.ContentGenerator.Families.EElementType.BEAM;
paramSection.Material = EMaterial.CONCRETE;

//seting parameters
paramSection.Parameters.SectionType = ESectionType.RECT;
paramSection.Parameters.Tapered = false;
//setting dimensions
paramSection.Parameters.Dimensions.h = 0.3;
paramSection.Parameters.Dimensions.b = 0.2;
paramSection.Parameters.CalculataMainAxisAndCharacteristics();
paramSection.TypeName = "RECT1";

//getting Revit element
Element el = rvt.GetElement(paramSection, ECategoryType.SECTION_PARAM);
FamilySymbol fs = el as FamilySymbol;

Example

Example
RVTFamilyConverter.GetElement Method (REXFamilyType)

The example shows how to get Revit element bases on the REXFamilyType object.

//Initialize the converter.
RVTFamilyConverter rvt = new RVTFamilyConverter(commandData, true);

//creating parametric description
REXFamilyType_ParamSection paramSection = new REXFamilyType_ParamSection();
paramSection.ElementType = REX.ContentGenerator.Families.EElementType.BEAM;
paramSection.Material = EMaterial.CONCRETE;

//seting parameters
paramSection.Parameters.SectionType = ESectionType.RECT;
paramSection.Parameters.Tapered = false;
//setting dimensions
paramSection.Parameters.Dimensions.h = 0.3;
paramSection.Parameters.Dimensions.b = 0.2;
paramSection.Parameters.CalculataMainAxisAndCharacteristics();
paramSection.TypeName = "RECT1";

//getting Revit element
Element el = rvt.GetElement(paramSection);
FamilySymbol fs = el as FamilySymbol;

Example

Example
RVTFamilyConverter.GetElements Method

The example shows how to get the list of Revit elements based on the list of the REXFamilyType.

//Initialize the converter.
RVTFamilyConverter rvt = new RVTFamilyConverter(commandData, true);

rvt.EventElementGenerated += new ElementGenerated(rvt_EventElementGenerated);

List<REXFamilyType> families = new List<REXFamilyType>();

for (int i = 1; i < 4; i++)
{
    //creating parametric description
    REXFamilyType_ParamSection paramSection = new REXFamilyType_ParamSection();
    paramSection.ElementType = REX.ContentGenerator.Families.EElementType.BEAM;
    paramSection.Material = EMaterial.CONCRETE;
    paramSection.Parameters.SectionType = ESectionType.RECT;
    paramSection.Parameters.Tapered = false;
    paramSection.Parameters.Dimensions.h = i*0.2;
    paramSection.Parameters.Dimensions.b = i*0.1;
    paramSection.Parameters.CalculataMainAxisAndCharacteristics();
    paramSection.TypeName = "RECT" + i.ToString();
    families.Add(paramSection);
}

List<Element> elements = rvt.GetElements(families, ECategoryType.SECTION_PARAM);

static void rvt_EventElementGenerated(string id)
{
}

Example

Example
RVTFamilyConverter.GetFamily Method (RevitElement, ECategoryType)

The example shows how to get REXFamilyType from the element defined in Revit.

//Initializing the converter.
RVTFamilyConverter rvt = new RVTFamilyConverter(commandData, true);

//Investigation of selected FamilyInstances
foreach(Element el in commandData.Application.ActiveUIDocument.Selection.Elements)
{
    FamilyInstance famInstance = el as FamilyInstance;

    if (famInstance != null
       && (famInstance.StructuralType == Autodesk.Revit.DB.Structure.StructuralType.Beam
       || famInstance.StructuralType == Autodesk.Revit.DB.Structure.StructuralType.Brace
       || famInstance.StructuralType == Autodesk.Revit.DB.Structure.StructuralType.Column))
    {
        //Geting REXFamilyType object from the current element.
        REXFamilyType fam = rvt.GetFamily(famInstance, ECategoryType.SECTION_PARAM);

        if (fam != null)
        {
            REXFamilyType_ParamSection paramSection = fam as REXFamilyType_ParamSection;
        }
    }
}

Example

Example
RVTFamilyConverter.GetFamily Method (RevitElement)

The example shows how to get REXFamilyType from the element defined in Revit.

//Initializing the converter.
RVTFamilyConverter rvt = new RVTFamilyConverter(commandData, true);

//Investigation of selected FamilyInstances
foreach(Element el in commandData.Application.ActiveUIDocument.Selection.Elements)
{
    FamilyInstance famInstance = el as FamilyInstance;

    if (famInstance != null
       && (famInstance.StructuralType == Autodesk.Revit.DB.Structure.StructuralType.Beam
       || famInstance.StructuralType == Autodesk.Revit.DB.Structure.StructuralType.Brace
       || famInstance.StructuralType == Autodesk.Revit.DB.Structure.StructuralType.Column))
    {
        //Geting REXFamilyType object from the current element.
        REXFamilyType fam = rvt.GetFamily(famInstance);

        if (fam != null)
        {
            //parametric section
            REXFamilyType_ParamSection paramSection = fam as REXFamilyType_ParamSection;

            if (paramSection != null)
            {
                continue;
            }

            //database section
            REXFamilyType_DBSection dbSection = fam as REXFamilyType_DBSection;

            if (dbSection != null)
            {
               continue;
            }
        }
    }
}

Example

Example
RVTFamilyConverter.GetRebarContour Method

The example shows how to get a simplified rebar contour (without bending segments) from the Revit rebar.

//Initializing the converter.
RVTFamilyConverter rvt = new RVTFamilyConverter(commandData, true);

//Iteration threw all rebars selected in Revit.
foreach (Element el in commandData.Application.ActiveUIDocument.Selection.Elements)
{
    Rebar r = el as Rebar;

    if (r != null)
    {
        REX.Common.Geometry.REXxyz normal;
        REX.Common.Geometry.REXxyz distribution;
        double spacing;
        int count;

        REX.ContentGenerator.Geometry.Contour_3D cont3D = rvt.GetRebarContour(r, out normal, out spacing, out count, out distribution);
    }
}

Legend

Legend
RVTMaterialFactory Class
Legend
Constructor
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

RVTMaterialFactory Class Members

RVTMaterialFactory Class Members
RVTMaterialFactory Class Legend
Members
Public Methods
Public Method | Description
RVTMaterialFactory | This is RVTMaterialFactory, a member of class RVTMaterialFactory.
RVTMaterialFactory | This is RVTMaterialFactory, a member of class RVTMaterialFactory.
RVTMaterialFactory Methods
RVTMaterialFactory Methods | Description
AddElement2FamList | This is AddElement2FamList, a member of class RVTMaterialFactory.