ContourDimensionRadius.Up Property
ContourDimensionRadius Class REX.ContentGenerator.Geometry Namespace ContourDimensionRadius Class

Gets or sets a value indicating whether dimension is defined above the reference.

C#
public bool Up;
Description

True if above the reference; otherwise, false.

Class

ContourDimensionRadius Class

Links
ContourDimensionRadius Class, REX.ContentGenerator.Geometry Namespace, ContourDimensionRadius Class

ContourElem Class

ContourElem Class
REX.ContentGenerator.Geometry Namespace Legend Members Public Methods ContourElem Methods ContourElem Properties

Base class for all contour elements.

Class Hierarchy
C#
[Serializable()]
public class ContourElem : SerializableObject;
Description
Namespace

REX.ContentGenerator.Geometry Namespace

Public Methods
Public Method | Description
ContourElem | Initializes a new instance of the ContourElem class.
ContourElem | Initializes a new instance of the ContourElem class.
ContourElem Methods
ContourElem Methods | Description
GetFlatPointInCoords | Gets the flat point in the plane.
GetPointList | Gets the list of points.
MultiplyLengthDim | Multiplies length dimensions by the coefficient.
Transform | Applies the specified transformation to the element.
Transform | Applies the specified transformation to the element.
Translate | Applies the specified translation vector to the element.
ContourElem Properties
ContourElem Properties | Description
ElemType | Gets the type of the elem.
Tag | Gets or sets the tag.
Links
REX.ContentGenerator.Geometry Namespace, Legend, Members, Public Methods, ContourElem Methods, ContourElem Properties

ContourElem.ContourElem Constructor ()

ContourElem.ContourElem Constructor ()
ContourElem Class REX.ContentGenerator.Geometry Namespace ContourElem Class

Initializes a new instance of the ContourElem class.

C#
public ContourElem();
Description
Class

ContourElem Class

Links
ContourElem Class, REX.ContentGenerator.Geometry Namespace, ContourElem Class

ContourElem.ContourElem Constructor (System.Runtime.Serialization.SerializationInfo, System.Runtime.Serialization.StreamingContext)

ContourElem.ContourElem Constructor (System.Runtime.Serialization.SerializationInfo, System.Runtime.Serialization.StreamingContext)
ContourElem Class REX.ContentGenerator.Geometry Namespace ContourElem Class

Initializes a new instance of the ContourElem class.

C#
public ContourElem(System.Runtime.Serialization.SerializationInfo info, System.Runtime.Serialization.StreamingContext context);
Parameters
Parameters | Description
info | Serialization data.
context | The context.
Description
Class

ContourElem Class

Links
ContourElem Class, REX.ContentGenerator.Geometry Namespace, ContourElem Class

ContourElem.GetFlatPointInCoords Method

ContourElem.GetFlatPointInCoords Method
ContourElem Class REX.ContentGenerator.Geometry Namespace ContourElem Class

Gets the flat point in the plane.

C#
public REXxyz GetFlatPointInCoords(REXxyz pt, ECoords coords);
Parameters
Parameters | Description
pt | The point.
coords | The coordinate system (plane).
Returns

The point

Description
Class

ContourElem Class

Links
ContourElem Class, REX.ContentGenerator.Geometry Namespace, ContourElem Class

ContourElem.GetPointList Method

ContourElem.GetPointList Method
ContourElem Class REX.ContentGenerator.Geometry Namespace ContourElem Class

Gets the list of points.

C#
public virtual List<REXxyz> GetPointList(bool end);
Parameters
Parameters | Description
end | Indicates whether the end point should be included.
Returns

Returns the list of points

Description
Class

ContourElem Class

Links
ContourElem Class, REX.ContentGenerator.Geometry Namespace, ContourElem Class

ContourElem.MultiplyLengthDim Method

ContourElem.MultiplyLengthDim Method
ContourElem Class REX.ContentGenerator.Geometry Namespace ContourElem Class

Multiplies length dimensions by the coefficient.

C#
public virtual void MultiplyLengthDim(double coeff);
Parameters
Parameters | Description
coeff | The coefficient.
Description
Class

ContourElem Class

Links
ContourElem Class, REX.ContentGenerator.Geometry Namespace, ContourElem Class

ContourElem.Transform Method (REXxyz, TransformDbl, bool)

ContourElem.Transform Method (REXxyz, TransformDbl, bool)
ContourElem Class REX.ContentGenerator.Geometry Namespace ContourElem Class

Applies the specified transformation to the element.

C#
public REXxyz Transform(REXxyz pt, TransformDbl trans, bool toLocal);
Parameters
Parameters | Description
pt | The point.
trans | The transformation object.
toLocal | Indicates the direction of transformation: true if from global to local; otherwise false.
Returns

Returns the transformed point.

Description
Class

ContourElem Class

Links
ContourElem Class, REX.ContentGenerator.Geometry Namespace, ContourElem Class

ContourElem.Transform Method (TransformDbl, bool)

ContourElem.Transform Method (TransformDbl, bool)
ContourElem Class REX.ContentGenerator.Geometry Namespace ContourElem Class

Applies the specified transformation to the element.

C#
public virtual void Transform(TransformDbl trans, bool toLocal);
Parameters
Parameters | Description
trans | The transformation object.
toLocal | Indicates the direction of transformation: true if from global to local; otherwise false.
Description
Class

ContourElem Class

Links
ContourElem Class, REX.ContentGenerator.Geometry Namespace, ContourElem Class

ContourElem.Translate Method

ContourElem.Translate Method
ContourElem Class REX.ContentGenerator.Geometry Namespace ContourElem Class

Applies the specified translation vector to the element.

C#
public virtual void Translate(double x, double y);
Parameters
Parameters | Description
x | The x.
y | The y.
Description
Class

ContourElem Class

Links
ContourElem Class, REX.ContentGenerator.Geometry Namespace, ContourElem Class

ContourElem.ElemType Property

ContourElem.ElemType Property
ContourElem Class REX.ContentGenerator.Geometry Namespace ContourElem Class

Gets the type of the elem.

C#
public EContElemType ElemType;
Description

The type of the elem.

Class

ContourElem Class

Links
ContourElem Class, REX.ContentGenerator.Geometry Namespace, ContourElem Class

ContourElem.Tag Property

ContourElem.Tag Property
ContourElem Class REX.ContentGenerator.Geometry Namespace ContourElem Class

Gets or sets the tag.

C#
public object Tag;
Description

The tag.

Class

ContourElem Class

Links
ContourElem Class, REX.ContentGenerator.Geometry Namespace, ContourElem Class

ContourLine Class

ContourLine Class
REX.ContentGenerator.Geometry Namespace Legend Members Public Methods ContourLine Methods ContourLine Properties

Represents the line element.

Class Hierarchy
C#
[Serializable()]
public class ContourLine : ContourElem;
Description
Namespace

REX.ContentGenerator.Geometry Namespace

Public Methods
Public Method | Description
ContourLine | Initializes a new instance of the ContourLine class.
ContourLine | Initializes a new instance of the ContourLine class.
ContourLine | Initializes a new instance of the ContourLine class.
ContourLine | Initializes a new instance of the ContourLine class.
ContourLine | Initializes a new instance of the ContourLine class.
ContourLine Methods
ContourLine Methods | Description
GetEnd | Gets the end point in a plane.
GetPointList | Gets the list of points.
GetStart | Gets the start point in a plane.
MultiplyLengthDim | Multiplies length dimensions by the coefficient.
Transform | Applies the specified transformation to the element.
Translate | Applies the specified translation vector to the element.
ContourLine Properties
ContourLine Properties | Description
End | Gets or sets the end point.
Start | Gets or sets the start point.
Links
REX.ContentGenerator.Geometry Namespace, Legend, Members, Public Methods, ContourLine Methods, ContourLine Properties

ContourLine.ContourLine Constructor (ContourLine)

ContourLine.ContourLine Constructor (ContourLine)