Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

XHTMLElement Class Members

XHTMLElement Class Members
XHTMLElement Class Legend
Members
XHTMLElement Fields
XHTMLElement Fields | Description
TagName | String containing the tag name of the element (may be empty).
XHTMLElement Methods
XHTMLElement Methods | Description
AddAttribute | Adds an HTML attribute and its value to the element.
AddBlockquote | Adds an element of type "blockquote" to the document and returns newly created XHTMLElement object.
AddElement | Adds an element of given name to the document and returns newly created XHTMLElement object.
AddHeader | Adds an element of type h1 through h6 (size=1 is the largest) to the document and returns newly created XHTMLElement object.
AddHorizontalRule | Inserts a horizontal rule ().
AddImage | Adds an image retrieved from resource (DLL or EXE) using protocol.
AddImageStd | Adds a standard image loaded from internal resources to the document.
AddLine | Writes the given text, followed by a newline character, to the document.
AddLineBreak | Inserts a single line break ().
AddMessage | Adds a decorated text to the document and returns newly created XHTMLElement object.
AddMessage2 | Adds a left text aligned text with right aligned note.
AddNoteFooter | Writes calculation note footer
AddNoteHeader | Writes calculation note header
AddParagraph | Adds an element of type "p" to the document and returns newly created XHTMLElement object.
AddPicture | Adds an image loaded from file.
AddSpan | Adds an element of type "span" to the document and returns newly created XHTMLElement object.
AddSubscript | Writes the given text to the document as a subscript.
AddSuperscript | Writes the given text to the document as a superscript.
AddSymbol | Writes the given text to the document using symbol (greek) font, e.g.
AddTable | Adds a table to the document and returns newly created XHTMLTable object
AddText | Writes the given text to the document.
AddText2 | Writes the given value name and its description to the document.
AddTextBold | Writes the given text to the document using a bold font.
AddUnit | Writes the given unit name to the document, adds braces if needed and moves all digits to uppercase, e.g mm2 -> [mm2].
AddValue | Writes the given value of any type, that can be converted to a string, to the document.
AddValue2 | Writes the given value of any type and it's name.
AddValue4 | Extended AddValue method (Similar to Verify, different order of parameters)
AddValue5 | Extended AddValue method
Verify | Similar to AddValue4 (different order of parameters),

XHTMLElement Methods

XHTMLElement Methods
XHTMLElement Class Legend
XHTMLElement Methods
XHTMLElement Methods | Description
AddAttribute | Adds an HTML attribute and its value to the element.
AddBlockquote | Adds an element of type "blockquote" to the document and returns newly created XHTMLElement object.
AddElement | Adds an element of given name to the document and returns newly created XHTMLElement object.
AddHeader | Adds an element of type h1 through h6 (size=1 is the largest) to the document and returns newly created XHTMLElement object.
AddHorizontalRule | Inserts a horizontal rule ().
AddImage | Adds an image retrieved from resource (DLL or EXE) using protocol.
AddImageStd | Adds a standard image loaded from internal resources to the document.
AddLine | Writes the given text, followed by a newline character, to the document.
AddLineBreak | Inserts a single line break ().
AddMessage | Adds a decorated text to the document and returns newly created XHTMLElement object.
AddMessage2 | Adds a left text aligned text with right aligned note.
AddNoteFooter | Writes calculation note footer
AddNoteHeader | Writes calculation note header
AddParagraph | Adds an element of type "p" to the document and returns newly created XHTMLElement object.
AddPicture | Adds an image loaded from file.
AddSpan | Adds an element of type "span" to the document and returns newly created XHTMLElement object.
AddSubscript | Writes the given text to the document as a subscript.
AddSuperscript | Writes the given text to the document as a superscript.
AddSymbol | Writes the given text to the document using symbol (greek) font, e.g.
AddTable | Adds a table to the document and returns newly created XHTMLTable object
AddText | Writes the given text to the document.
AddText2 | Writes the given value name and its description to the document.
AddTextBold | Writes the given text to the document using a bold font.
AddUnit | Writes the given unit name to the document, adds braces if needed and moves all digits to uppercase, e.g mm2 -> [mm2].
AddValue | Writes the given value of any type, that can be converted to a string, to the document.
AddValue2 | Writes the given value of any type and it's name.
AddValue4 | Extended AddValue method (Similar to Verify, different order of parameters)
AddValue5 | Extended AddValue method
Verify | Similar to AddValue4 (different order of parameters),

XHTMLTable Fields

XHTMLTable Fields
XHTMLTable Class Legend
XHTMLTable Fields
XHTMLTable Fields | Description
Border | Short Border width in pixels.
Columns | Long Number of columns in the table.
FooterRows | Long Number of footer rows.
HeaderColumns | Long Number of header columns.
HeaderRows | Long Number of header rows.
Rows | Long Number of rows in the table (including header rows).
Width | Sets or gets the overall table width, default: "Auto".

Legend

Legend
XHTMLTable Class
Legend
Data Member
Method
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

XHTMLTable Class Members

XHTMLTable Class Members
XHTMLTable Class Legend
Members
XHTMLTable Fields
XHTMLTable Fields | Description
Border | Short Border width in pixels.
Columns | Long Number of columns in the table.
FooterRows | Long Number of footer rows.
HeaderColumns | Long Number of header columns.
HeaderRows | Long Number of header rows.
Rows | Long Number of rows in the table (including header rows).
Width | Sets or gets the overall table width, default: "Auto".
XHTMLTable Methods
XHTMLTable Methods | Description
AddAttribute | Adds an HTML attribute and its value to the entire table.
AddColumnAttribute | Adds an HTML attribute and its value to the specified column.
AddRow | Adds one row to the table.
AutoFormat | Initializes a couple of table properties according to given predefined format.
Cell | XHTMLElement that represents the cell of the table.
ColumnWidth | String Sets or gets the column width of the desired column, e.g.

XHTMLTable Methods

XHTMLTable Methods
XHTMLTable Class Legend
XHTMLTable Methods
XHTMLTable Methods | Description
AddAttribute | Adds an HTML attribute and its value to the entire table.
AddColumnAttribute | Adds an HTML attribute and its value to the specified column.
AddRow | Adds one row to the table.
AutoFormat | Initializes a couple of table properties according to given predefined format.
Cell | XHTMLElement that represents the cell of the table.
ColumnWidth | String Sets or gets the column width of the desired column, e.g.

REX.Common Namespace

Next
REX.Common Namespace
Legend Classes Interfaces Structs, Records, Enums

This is namespace REX.Common.

Classes
Class | Description
REXAccess | The class dedicated to settings data from parent application.
REXApplication | Base class for Application.This object controls the lifetime of the extensions.
REXDFM | Manages UI controls registered in it.
REXDirectAccess | Base class for main DirectAccess class.
REXDirectRevitAccess | Base class for main DirectAccess class.
REXDirectRevitExecute | This is class REX.Common.REXDirectRevitExecute.