public class RVTSectionFactory : RVTFamilyFactory;
Namespace

REX.ContentGenerator.Converters Namespace

Public Methods
Public Method | Description
RVTSectionFactory | This is RVTSectionFactory, a member of class RVTSectionFactory.
RVTSectionFactory Methods
RVTSectionFactory Methods | Description
AddElement2FamList | This is AddElement2FamList, a member of class RVTSectionFactory.
AddElement2FamList | This is AddElement2FamList, a member of class RVTSectionFactory.
GetElement | This is GetElement, a member of class RVTSectionFactory.
GetElement4ParamIdentity | This is GetElement4ParamIdentity, a member of class RVTSectionFactory.
GetElements | This is GetElements, a member of class RVTSectionFactory.
GetExistingNames | This is GetExistingNames, a member of class RVTSectionFactory.
GetFactory | This is GetFactory, a member of class RVTSectionFactory.
GetFactoryForGeneral | This is GetFactoryForGeneral, a member of class RVTSectionFactory.
GetFamily | This is GetFamily, a member of class RVTSectionFactory.
GetName4Mapping | This is GetName4Mapping, a member of class RVTSectionFactory.
GetRevitTypesForInit | This is GetRevitTypesForInit, a member of class RVTSectionFactory.
InitList | This is InitList, a member of class RVTSectionFactory.
IsElementSupported | This is IsElementSupported, a member of class RVTSectionFactory.
OnClose | This is OnClose, a member of class RVTSectionFactory.
Recalculate | This is Recalculate, a member of class RVTSectionFactory.
ResetFamilyBufor | This is ResetFamilyBufor, a member of class RVTSectionFactory.
ValidateElement | This is ValidateElement, a member of class RVTSectionFactory.
Links
REX.ContentGenerator.Converters Namespace, Legend, Members, Public Methods, RVTSectionFactory Methods

RVTSectionFactory.RVTSectionFactory Constructor

RVTSectionFactory.RVTSectionFactory Constructor
RVTSectionFactory Class REX.ContentGenerator.Converters Namespace RVTSectionFactory Class

This is RVTSectionFactory, a member of class RVTSectionFactory.

C#
public RVTSectionFactory(RvtConversionSettings Settings);
Class

RVTSectionFactory Class

Links
RVTSectionFactory Class, REX.ContentGenerator.Converters Namespace, RVTSectionFactory Class

RVTSectionFactory.AddElement2FamList Method (Autodesk.Revit.DB.Element, REXFamilyType, bool)

RVTSectionFactory.AddElement2FamList Method (Autodesk.Revit.DB.Element, REXFamilyType, bool)
RVTSectionFactory Class REX.ContentGenerator.Converters Namespace RVTSectionFactory Class

This is AddElement2FamList, a member of class RVTSectionFactory.

C#
public override bool AddElement2FamList(Autodesk.Revit.DB.Element el, REXFamilyType ft, bool addToDict);
Class

RVTSectionFactory Class

Links
RVTSectionFactory Class, REX.ContentGenerator.Converters Namespace, RVTSectionFactory Class

RVTSectionFactory.AddElement2FamList Method (RevitElement)

RVTSectionFactory.AddElement2FamList Method (RevitElement)
RVTSectionFactory Class REX.ContentGenerator.Converters Namespace RVTSectionFactory Class

This is AddElement2FamList, a member of class RVTSectionFactory.

C#
public override bool AddElement2FamList(RevitElement el);
Class

RVTSectionFactory Class

Links
RVTSectionFactory Class, REX.ContentGenerator.Converters Namespace, RVTSectionFactory Class

RVTSectionFactory.GetElement Method

RVTSectionFactory.GetElement Method
RVTSectionFactory Class REX.ContentGenerator.Converters Namespace RVTSectionFactory Class

This is GetElement, a member of class RVTSectionFactory.

C#
public override Autodesk.Revit.DB.Element GetElement(REXFamilyType obj, ECategoryType desc, bool copyFamily, bool recalculate);
Class

RVTSectionFactory Class

Links
RVTSectionFactory Class, REX.ContentGenerator.Converters Namespace, RVTSectionFactory Class

RVTSectionFactory.GetElement4ParamIdentity Method

RVTSectionFactory.GetElement4ParamIdentity Method
RVTSectionFactory Class REX.ContentGenerator.Converters Namespace RVTSectionFactory Class

This is GetElement4ParamIdentity, a member of class RVTSectionFactory.

C#
public override RevitElement GetElement4ParamIdentity(Autodesk.Revit.DB.Element el);
Class

RVTSectionFactory Class

Links
RVTSectionFactory Class, REX.ContentGenerator.Converters Namespace, RVTSectionFactory Class

RVTSectionFactory.GetElements Method

RVTSectionFactory.GetElements Method
RVTSectionFactory Class REX.ContentGenerator.Converters Namespace RVTSectionFactory Class

This is GetElements, a member of class RVTSectionFactory.

C#
public override List<Autodesk.Revit.DB.Element> GetElements(List<REXFamilyType> list, ECategoryType desc, bool recalculate);
Class

RVTSectionFactory Class

Links
RVTSectionFactory Class, REX.ContentGenerator.Converters Namespace, RVTSectionFactory Class

RVTSectionFactory.GetExistingNames Method

RVTSectionFactory.GetExistingNames Method
RVTSectionFactory Class REX.ContentGenerator.Converters Namespace RVTSectionFactory Class

This is GetExistingNames, a member of class RVTSectionFactory.

C#
public override List<string> GetExistingNames(REXFamilyType obj, bool type);
Class

RVTSectionFactory Class

Links
RVTSectionFactory Class, REX.ContentGenerator.Converters Namespace, RVTSectionFactory Class

RVTSectionFactory.GetFactory Method

RVTSectionFactory.GetFactory Method
RVTSectionFactory Class REX.ContentGenerator.Converters Namespace RVTSectionFactory Class

This is GetFactory, a member of class RVTSectionFactory.

C#
public override RVTFamilyFactory GetFactory(ECategoryType type);
Class

RVTSectionFactory Class

Links
RVTSectionFactory Class, REX.ContentGenerator.Converters Namespace, RVTSectionFactory Class

RVTSectionFactory.GetFactoryForGeneral Method

RVTSectionFactory.GetFactoryForGeneral Method
RVTSectionFactory Class REX.ContentGenerator.Converters Namespace RVTSectionFactory Class

This is GetFactoryForGeneral, a member of class RVTSectionFactory.

C#
public override RVTFamilyFactory GetFactoryForGeneral();
Class

RVTSectionFactory Class

Links
RVTSectionFactory Class, REX.ContentGenerator.Converters Namespace, RVTSectionFactory Class

RVTSectionFactory.GetFamily Method

RVTSectionFactory.GetFamily Method
RVTSectionFactory Class REX.ContentGenerator.Converters Namespace RVTSectionFactory Class

This is GetFamily, a member of class RVTSectionFactory.

C#
public override REXFamilyType GetFamily(Autodesk.Revit.DB.Element obj, ECategoryType desc, bool recalculate);
Class

RVTSectionFactory Class

Links
RVTSectionFactory Class, REX.ContentGenerator.Converters Namespace, RVTSectionFactory Class

RVTSectionFactory.GetName4Mapping Method

RVTSectionFactory.GetName4Mapping Method
RVTSectionFactory Class REX.ContentGenerator.Converters Namespace RVTSectionFactory Class

This is GetName4Mapping, a member of class RVTSectionFactory.

C#
public override string GetName4Mapping(Autodesk.Revit.DB.Element elem);
Class

RVTSectionFactory Class

Links
RVTSectionFactory Class, REX.ContentGenerator.Converters Namespace, RVTSectionFactory Class

RVTSectionFactory.GetRevitTypesForInit Method

RVTSectionFactory.GetRevitTypesForInit Method
RVTSectionFactory Class REX.ContentGenerator.Converters Namespace RVTSectionFactory Class

This is GetRevitTypesForInit, a member of class RVTSectionFactory.

C#
public override Type[] GetRevitTypesForInit();
Class

RVTSectionFactory Class

Links
RVTSectionFactory Class, REX.ContentGenerator.Converters Namespace, RVTSectionFactory Class

RVTSectionFactory.InitList Method

RVTSectionFactory.InitList Method
RVTSectionFactory Class REX.ContentGenerator.Converters Namespace RVTSectionFactory Class

This is InitList, a member of class RVTSectionFactory.

C#
public override void InitList();
Class

RVTSectionFactory Class

Links
RVTSectionFactory Class, REX.ContentGenerator.Converters Namespace, RVTSectionFactory Class

RVTSectionFactory.IsElementSupported Method

RVTSectionFactory.IsElementSupported Method
RVTSectionFactory Class REX.ContentGenerator.Converters Namespace RVTSectionFactory Class

This is IsElementSupported, a member of class RVTSectionFactory.

C#