REX.Common.REXErrors.ErrorCode Enumeration
REXErrors Class

Standard REX error codes.

C#
public enum ErrorCode {
  eUNKNOWN = 0,
  eIO_EXCEPTION = 1,
  eMANAGER_NOT_FOUND = 1000,
  eMANAGER_EXECUTE_FAIL = 1001,
  eXML_PARSER_FATAL = 1500,
  eENGINE_CREATE_ASSEMBLY = 2000,
  eENGINE_APP_INTERFACE = 2001,
  eENGINE_LOAD_ENGINE = 2002,
  eENGINE_LOAD_PREFERENCES = 2003,
  eENGINE_LOAD_SYSTEM = 2004,
  eENGINE_REG = 2005,
  eENGINE_REG_LANGUAGE = 2006,
  eENGINE_LOAD_PRODUCT = 2007,
  eENGINE_BAD_ENV = 2008,
  ePREFS_LOAD_UNITS = 2020,
  ePREFS_NO_INT_UNITS = 2021,
  eSERVICE_START_FAIL = 3000,
  eSERVICE_STOP_FAIL = 3001
}
Members
Members | Description
eUNKNOWN | Unknown error.
eIO_EXCEPTION | Input / output exception
eMANAGER_NOT_FOUND | Internal REX error.
eMANAGER_EXECUTE_FAIL | Internal REX error.
eXML_PARSER_FATAL | Parser fail.
eENGINE_CREATE_ASSEMBLY | Internal REX engine error.
eENGINE_APP_INTERFACE | Internal REX engine error.
eENGINE_LOAD_ENGINE | Internal REX engine error.
eENGINE_LOAD_PREFERENCES | Internal REX engine error.
eENGINE_LOAD_SYSTEM | Internal REX engine error.
eENGINE_REG | Internal REX engine error.
eENGINE_REG_LANGUAGE | Internal REX engine error.
eENGINE_LOAD_PRODUCT | Internal REX engine error.
eENGINE_BAD_ENV | Internal REX engine error.
ePREFS_LOAD_UNITS | Internal REX engine error.
ePREFS_NO_INT_UNITS | Internal REX engine error.
eSERVICE_START_FAIL | Internal REX engine error.
eSERVICE_STOP_FAIL | Internal REX engine error.
Description
Class

REXErrors Class

Links
REXErrors Class
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXErrors.GetCategory Method

REXErrors.GetCategory Method
REXErrors Class REX.Common Namespace REXErrors Class

Returns category for specified error code.

C#
public static REXLogger.LogCategory GetCategory(ErrorCode e);
Parameters
Parameters | Description
e | The error code.
Returns

Returns LogCategory category.

Description
Class

REXErrors Class

Links
REXErrors Class, REX.Common Namespace, REXErrors Class

REXErrors.GetMessage Method

REXErrors.GetMessage Method
REXErrors Class REX.Common Namespace REXErrors Class

Returns formated error string.

C#
public static String GetMessage(ErrorCode e);
Parameters
Parameters | Description
e | Defined error code.
Returns

Returns string formated message.

Description
Class

REXErrors Class

Links
REXErrors Class, REX.Common Namespace, REXErrors Class

REXExtension Class

REXExtension Class
REX.Common Namespace Legend Members Public Methods REXExtension Methods REXExtension Properties

Additional functionality of REXExtension class.

Class Hierarchy
C#
public class REXExtension : IREXExtension4, IREXExtension3;
Description
Namespace

REX.Common Namespace

Public Methods
Public Method | Description
REXExtension | Initializes a new instance of the REXExtension class.
REXExtension Methods
REXExtension Methods | Description
AddCommands | Adds the commands.
ApplyStyle | This is ApplyStyle, a member of class REXExtension.
ApplyStyle | This is ApplyStyle, a member of class REXExtension.
Close | Close extension with all needed actions.
Close | Close extension with all needed actions.
Close | Close extension with all needed actions.
Command | Commands the specified command struct.
Create | Creates this extension.
Event | Events the specified event struct.
GetAPI | Get reference to main API object.
GetCaption | Get standard caption.
GetCaption | Get standard caption with additional information.
GetControl | Get reference to main control.
GetData | Get the data structure.
GetForm | Get reference to main form.
GetIcon | Get reference to icon.
GetResults | Get the results structure.
GetREXEnvironment | Get the reference to REX environment object.
GetTopWindowForParent | This is GetTopWindowForParent, a member of class REXExtension.
GetTopWindowHandleForParent | This is GetTopWindowHandleForParent, a member of class REXExtension.
GetWindow | Get reference to main form.
GetWindowForParent | Get the window for parent.
GetWindowHandleForParent | Get the window for parent.
Initialize | Initializes this instance.
OnActivateLayout | Activates or deactivates layout - module can modify layout before or after activation.
OnCanActivateLayout | Called when [can activate layout].
OnCanClose | If returns true, dialog will close after OK button clicked.
OnCanClose | Called when closing module.
OnCanRun | Checks status of module and shows some information for user if module can't complete action.
OnCheckValidity | Called when check validity.
OnClear | Called when clear.
OnClose | Called during closing module.
OnCommand | Called when command.
OnCreate | Creates needed structures and verify needs.
OnCreateDialogs | Creates sub dialogs.
OnCreateLayout | Creates layout items and setups layout.
OnDataLoad | Called when data load.
OnDataLoaded | Called when data loaded.
OnDataSave | Called when data save.
OnDataSaved | Called when data saved.
OnErrorSelected | Called when error selected on errors list dialog.
OnEvent | Called when event.
OnGetExtensionName | Called when get extension name.
OnGetText | Get specified text from resources.
OnInitialize | Called when Initialize.
OnLoadJournalingData | Called when load journaling data.
OnLoadTemplate | Called when load template.
OnPreferencesChanged | Called when preferences changed.
OnRegionalSettingsChanged | Called when regional settings changed.
OnRun | Runs process calculations or other operations.
OnSaveJournalingData | Called when save journaling data.
OnSaveTemplate | Called when save template.
OnSetContext | Called when regional settings changed.
OnSetData | Get data from dialogs and sets Data's strucutres.
OnSetDialogs | Set data in dialogs.
OnShowResults | Shows results.
OnUpdate | Called when update.
OnUpdateDialogs | Called when update dialogs.
ROHTMLDocument | Access to ROHTML's document.
ROHTMLReleaseDocument | Releases ROHTML's document.
Run | Runs process calculations or other operations.
RunQuestion | Runs the question.
SetCanClose | If the method will be called on OnCanRun method, Module will not close after return false.
SetContext | Initializes this instance.
SetCreateFail | If the method will be called on OnCreate method, Module will not continue work.
SetCreateFail | If the method will be called on OnCreate method, Module will not continue work.
Setup | Setups this extension.
SetupCommands | Initializes the commands.
SetupDefaultCommands | Initializes the default commands.
ShowMessageBox | This is ShowMessageBox, a member of class REXExtension.
ShowMessageBox | This is ShowMessageBox, a member of class REXExtension.
ShowMessageBox | This is ShowMessageBox, a member of class REXExtension.
ShowMessageBox | This is ShowMessageBox, a member of class REXExtension.
ShowMessageBox | This is ShowMessageBox, a member of class REXExtension.
ShowMessageBox | This is ShowMessageBox, a member of class REXExtension.
ShowMessageBox | This is ShowMessageBox, a member of class REXExtension.
ShowPreferencesDialog | This is ShowPreferencesDialog, a member of class REXExtension.
Status | Get current status of module.
REXExtension Properties
REXExtension Properties | Description
Context | Get the reference to current context object.
DFM | Gets the DFM object to manage all UI controls which support Revit Extension units.
ExtensionContext | Get the reference to the old extension context object.
Layout | Get the reference to Layout object.
MainAccess | Get the reference to object which controls interactions between module, and main application.
Preferences | Get the reference to Preferences object.
Progress | Get the reference to progress object.
Revit | Get the reference to object which controls interactions between module, and Revit.
Style | This is Style, a member of class REXExtension.
System | Get the reference to System object.