REXContentLogicFilter.REXContentLogicFilter Constructor (ELogicOperator, params REXContentFilter[])

REXContentLogicFilter.REXContentLogicFilter Constructor (ELogicOperator, params REXContentFilter[])
REXContentLogicFilter Class REX.ContentGenerator.Converters Namespace REXContentLogicFilter Class

Initializes a new instance of the REXContentLogicFilter class.

C#
public REXContentLogicFilter(ELogicOperator logicOperator, params REXContentFilter[] filters);
Parameters
Parameters | Description
logicOperator | The logic operator.
filters | The filters.
Description
Class

REXContentLogicFilter Class

Links
REXContentLogicFilter Class, REX.ContentGenerator.Converters Namespace, REXContentLogicFilter Class

REX.ContentGenerator.Converters.REXContentLogicFilter.ELogicOperator Enumeration

REX.ContentGenerator.Converters.REXContentLogicFilter.ELogicOperator Enumeration
REXContentLogicFilter Class

Describes operators.

C#
public enum ELogicOperator {
  Or,
  And
}
Members
Members | Description
Or | Agregation.
And | Conjunction.
Description
Class

REXContentLogicFilter Class

Links
REXContentLogicFilter Class
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXContentLogicFilter.Filters Property

REXContentLogicFilter.Filters Property
REXContentLogicFilter Class REX.ContentGenerator.Converters Namespace REXContentLogicFilter Class

Gets or sets the filters.

C#
public List<REXContentFilter> Filters;
Description

The filters.

Class

REXContentLogicFilter Class

Links
REXContentLogicFilter Class, REX.ContentGenerator.Converters Namespace, REXContentLogicFilter Class

REXContentLogicFilter.LogicOperator Property

REXContentLogicFilter.LogicOperator Property
REXContentLogicFilter Class REX.ContentGenerator.Converters Namespace REXContentLogicFilter Class

Gets or sets the logic operator.

C#
public ELogicOperator LogicOperator;
Description

The logic operator.

Class

REXContentLogicFilter Class

Links
REXContentLogicFilter Class, REX.ContentGenerator.Converters Namespace, REXContentLogicFilter Class

REXContentParamFilter Class

REXContentParamFilter Class
REX.ContentGenerator.Converters Namespace Legend Members Public Methods REXContentParamFilter Methods REXContentParamFilter Properties

Describes the filter for the specified parameter.

Class Hierarchy
C#
public class REXContentParamFilter : REXContentFilter;
Description
Namespace

REX.ContentGenerator.Converters Namespace

Public Methods
Public Method | Description
REXContentParamFilter | Initializes a new instance of the REXContentParamFilter class.
REXContentParamFilter | Initializes a new instance of the REXContentParamFilter class.
REXContentParamFilter | Initializes a new instance of the REXContentParamFilter class.
REXContentParamFilter Methods
REXContentParamFilter Methods | Description
Validate | Validates the specified value due to the current filter's parameters.
REXContentParamFilter Properties
REXContentParamFilter Properties | Description
ConstraintValue | Gets or sets the constraint value.
Equal | Gets or sets a value indicating whether a parameter is to be equal to the constraint value.
Less | Gets or sets a value indicating whether a parameter is to be smaller then the constraint value.
More | Gets or sets a value indicating whether a parameter is to be larger then the constraint value.
ParamName | Gets or sets the name of the parameter which is constrained.
Links
REX.ContentGenerator.Converters Namespace, Legend, Members, Public Methods, REXContentParamFilter Methods, REXContentParamFilter Properties

REXContentParamFilter.REXContentParamFilter Constructor ()

REXContentParamFilter.REXContentParamFilter Constructor ()
REXContentParamFilter Class REX.ContentGenerator.Converters Namespace REXContentParamFilter Class

Initializes a new instance of the REXContentParamFilter class.

C#
public REXContentParamFilter();
Description
Class

REXContentParamFilter Class

Links
REXContentParamFilter Class, REX.ContentGenerator.Converters Namespace, REXContentParamFilter Class

REXContentParamFilter.REXContentParamFilter Constructor (string, object)

REXContentParamFilter.REXContentParamFilter Constructor (string, object)
REXContentParamFilter Class REX.ContentGenerator.Converters Namespace REXContentParamFilter Class

Initializes a new instance of the REXContentParamFilter class.

C#
public REXContentParamFilter(string paramName, object constraintValue);
Parameters
Parameters | Description
paramName | The name of the parameter.
constraintValue | The constraint value.
Description
Class

REXContentParamFilter Class

Links
REXContentParamFilter Class, REX.ContentGenerator.Converters Namespace, REXContentParamFilter Class

REXContentParamFilter.REXContentParamFilter Constructor (string, object, bool, bool, bool)

REXContentParamFilter.REXContentParamFilter Constructor (string, object, bool, bool, bool)
REXContentParamFilter Class REX.ContentGenerator.Converters Namespace REXContentParamFilter Class

Initializes a new instance of the REXContentParamFilter class.

C#
public REXContentParamFilter(string paramName, object constraintValue, bool more, bool less, bool equal);
Parameters
Parameters | Description
paramName | The name of the parameter.
constraintValue | The constraint value.
more | Indicates whether the parameter is to be larger then the constraint value.
less | Indicates whether the parameter is to be smaller then the constraint value.
equal | Indicates whether the parameter is to be equal to the constraint value.
Description
Class

REXContentParamFilter Class

Links
REXContentParamFilter Class, REX.ContentGenerator.Converters Namespace, REXContentParamFilter Class

REXContentParamFilter.Validate Method

REXContentParamFilter.Validate Method
REXContentParamFilter Class REX.ContentGenerator.Converters Namespace REXContentParamFilter Class

Validates the specified value due to the current filter's parameters.

C#
public bool Validate(IComparable val);
Parameters
Parameters | Description
val | The value.
Returns

True if the value respects all constraints; otherwise false.

Description
Class

REXContentParamFilter Class

Links
REXContentParamFilter Class, REX.ContentGenerator.Converters Namespace, REXContentParamFilter Class

REXContentParamFilter.ConstraintValue Property

REXContentParamFilter.ConstraintValue Property
REXContentParamFilter Class REX.ContentGenerator.Converters Namespace REXContentParamFilter Class

Gets or sets the constraint value.

C#
public object ConstraintValue;
Description

The constraint value.

Class

REXContentParamFilter Class

Links
REXContentParamFilter Class, REX.ContentGenerator.Converters Namespace, REXContentParamFilter Class

REXContentParamFilter.Equal Property

REXContentParamFilter.Equal Property
REXContentParamFilter Class REX.ContentGenerator.Converters Namespace REXContentParamFilter Class

Gets or sets a value indicating whether a parameter is to be equal to the constraint value.

C#
public bool Equal;
Description
Class

REXContentParamFilter Class

Links
REXContentParamFilter Class, REX.ContentGenerator.Converters Namespace, REXContentParamFilter Class

REXContentParamFilter.Less Property

REXContentParamFilter.Less Property
REXContentParamFilter Class REX.ContentGenerator.Converters Namespace REXContentParamFilter Class

Gets or sets a value indicating whether a parameter is to be smaller then the constraint value.

C#
public bool Less;
Description
Class

REXContentParamFilter Class

Links
REXContentParamFilter Class, REX.ContentGenerator.Converters Namespace, REXContentParamFilter Class

REXContentParamFilter.More Property

REXContentParamFilter.More Property
REXContentParamFilter Class REX.ContentGenerator.Converters Namespace REXContentParamFilter Class

Gets or sets a value indicating whether a parameter is to be larger then the constraint value.

C#
public bool More;