RVTContentMapper Class REX.ContentGenerator.Map Namespace RVTContentMapper Class

Sets the map element for specified Revit element.

C#
public void SetMapElement(bool user, RevitElement elem, REXFamilyType fam, ECategoryType type);
Parameters
Parameters | Description
user | Indicates whether the user map should be used.
elem | The element.
fam | The mapped REXFamilyType object.
type | The type of the element.
Description
Class

RVTContentMapper Class

Links
RVTContentMapper Class, REX.ContentGenerator.Map Namespace, RVTContentMapper Class

REX.Controls.Common Namespace

Previous | Next
REX.Controls.Common Namespace
Legend Classes Interfaces Structs, Records, Enums

This is namespace REX.Controls.Common.

Classes
Class | Description
REXComboEditControlEngine | Represents the engine for the combobox edit control.
REXEditControlEngine | Represents the engine for edit controls.
Interfaces
Interface | Description
IComboEditControl | An interface that may be used to attach the custom control to the REXComboEditControlEngine.
IEditControl | An interface that may be used to attach the custom control to the REXEditControlEngine.
IUnitObject | Defines common functionality for controls that are unit dependent.
IUnitObject2 | Defines common functionality for controls that are unit dependent.
IUnitObject3 | Defines common functionality for controls that are unit dependent.
Structs, Records, Enums
Struct, Record, Enum | Description
EComboPropertiesType | An enumerated type listing all modes of the combo.
Links
Legend, Classes, Interfaces, Structs, Records, Enums

REXComboEditControlEngine Class

REXComboEditControlEngine Class
REX.Controls.Common Namespace Legend Members Public Methods REXComboEditControlEngine Methods REXComboEditControlEngine Properties

Represents the engine for the combobox edit control.

Class Hierarchy
C#
public class REXComboEditControlEngine<T_Background> : REXEditControlEngine<T_Background>;
Type Parameters
Type Parameters | Description
T_Background | The type of the background.
Description
Namespace

REX.Controls.Common Namespace

Public Methods
Public Method | Description
REXComboEditControlEngine | Initializes a new instance of the REXComboEditControlEngine class.
REXComboEditControlEngine Methods
REXComboEditControlEngine Methods | Description
GetPropertiesType | Gets the mode of the combo.
GetValue | Returns a double value of the control.
RefreshItems | Refreshes the internal items list based on the control items list.
RestorePropertiesType | Restores the mode of the combo.
SelectionChanged | Informs about changes in the selection.
SetPropertiesType | Sets the mode of the combo box.
SetValue | Sets the value of the double type.
SetValue | Sets the value of the string type.
TextChanged | Informs about changes in the control's text.
ValidateControl | Validates the current control based on the input values.
ValidateControl | Validates the current control based on the current text or the stored value.
ValidateControl | Validates the current control based on the input value.
ValidateControl | Validates the current control based on the input text.
REXComboEditControlEngine Properties
REXComboEditControlEngine Properties | Description
Items | Gets or sets the collection of the items contained in the control.
ListValidation | Gets or sets a value indicating whether the list should be validated.
SelectedIndex | Gets or sets the index specifying the currently selected item.
TextBoxMode | Gets or sets a value indicating whether the combobox should be in the editbox mode.
Links
REX.Controls.Common Namespace, Legend, Members, Public Methods, REXComboEditControlEngine Methods, REXComboEditControlEngine Properties

REXComboEditControlEngine.REXComboEditControlEngine Constructor

REXComboEditControlEngine.REXComboEditControlEngine Constructor
REXComboEditControlEngine Class REX.Controls.Common Namespace REXComboEditControlEngine Class

Initializes a new instance of the REXComboEditControlEngine class.

C#
public REXComboEditControlEngine(IEditControl control);
Parameters
Parameters | Description
control | The control which will use the current instance as it's engine.
Description
Class

REXComboEditControlEngine Class

Links
REXComboEditControlEngine Class, REX.Controls.Common Namespace, REXComboEditControlEngine Class

REXComboEditControlEngine.GetPropertiesType Method

REXComboEditControlEngine.GetPropertiesType Method
REXComboEditControlEngine Class REX.Controls.Common Namespace REXComboEditControlEngine Class

Gets the mode of the combo.

C#
public EComboPropertiesType GetPropertiesType();
Returns

The mode of the combo box.

Description
Class

REXComboEditControlEngine Class

Links
REXComboEditControlEngine Class, REX.Controls.Common Namespace, REXComboEditControlEngine Class

REXComboEditControlEngine.GetValue Method

REXComboEditControlEngine.GetValue Method
REXComboEditControlEngine Class REX.Controls.Common Namespace REXComboEditControlEngine Class

Returns a double value of the control.

C#
public override double GetValue();
Description
Class

REXComboEditControlEngine Class

Links
REXComboEditControlEngine Class, REX.Controls.Common Namespace, REXComboEditControlEngine Class

REXComboEditControlEngine.RefreshItems Method

REXComboEditControlEngine.RefreshItems Method
REXComboEditControlEngine Class REX.Controls.Common Namespace REXComboEditControlEngine Class

Refreshes the internal items list based on the control items list.

C#
public void RefreshItems();
Description
Class

REXComboEditControlEngine Class

Links
REXComboEditControlEngine Class, REX.Controls.Common Namespace, REXComboEditControlEngine Class

REXComboEditControlEngine.RestorePropertiesType Method

REXComboEditControlEngine.RestorePropertiesType Method
REXComboEditControlEngine Class REX.Controls.Common Namespace REXComboEditControlEngine Class

Restores the mode of the combo.

C#
public void RestorePropertiesType();
Description
Class

REXComboEditControlEngine Class

Links
REXComboEditControlEngine Class, REX.Controls.Common Namespace, REXComboEditControlEngine Class

REXComboEditControlEngine.SelectionChanged Method

REXComboEditControlEngine.SelectionChanged Method
REXComboEditControlEngine Class REX.Controls.Common Namespace REXComboEditControlEngine Class

Informs about changes in the selection.

C#
public void SelectionChanged();
Description
Class

REXComboEditControlEngine Class

Links
REXComboEditControlEngine Class, REX.Controls.Common Namespace, REXComboEditControlEngine Class

REXComboEditControlEngine.SetPropertiesType Method

REXComboEditControlEngine.SetPropertiesType Method
REXComboEditControlEngine Class REX.Controls.Common Namespace REXComboEditControlEngine Class

Sets the mode of the combo box.

C#
public void SetPropertiesType(EComboPropertiesType propertiesType);
Parameters
Parameters | Description
propertiesType | The mode of the combo box.
Description
Class

REXComboEditControlEngine Class

Links
REXComboEditControlEngine Class, REX.Controls.Common Namespace, REXComboEditControlEngine Class

REXComboEditControlEngine.SetValue Method (double)

REXComboEditControlEngine.SetValue Method (double)
REXComboEditControlEngine Class REX.Controls.Common Namespace REXComboEditControlEngine Class

Sets the value of the double type.

C#
public override void SetValue(double value);
Parameters
Parameters | Description
value | The value.
Description
Class

REXComboEditControlEngine Class

Links
REXComboEditControlEngine Class, REX.Controls.Common Namespace, REXComboEditControlEngine Class

REXComboEditControlEngine.SetValue Method (string)

REXComboEditControlEngine.SetValue Method (string)
REXComboEditControlEngine Class REX.Controls.Common Namespace REXComboEditControlEngine Class

Sets the value of the string type.

C#
public override void SetValue(string value);
Parameters
Parameters | Description
value | The value.
Description
Class

REXComboEditControlEngine Class

Links