REXFamilyConverter.GetRebar Method (REX.ContentGenerator.Geometry.Contour_3D, REXxyz, REXFamilyType_RebarBarType, bool, REXFamilyType_RebarHook, REXFamilyType_RebarHook, string)

REXFamilyConverter.GetRebar Method (REX.ContentGenerator.Geometry.Contour_3D, REXxyz, REXFamilyType_RebarBarType, bool, REXFamilyType_RebarHook, REXFamilyType_RebarHook, string)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace Example REXFamilyConverter Class

Gets the rebar object due to the defined contour, the bar's type and the shape's database.

C#
public REXFamilyType_Rebar GetRebar(REX.ContentGenerator.Geometry.Contour_3D contour3D, REXxyz normal, REXFamilyType_RebarBarType barType, bool stirrup, REXFamilyType_RebarHook hookStart, REXFamilyType_RebarHook hookEnd, string dbShapeName);
Parameters
Parameters | Description
contour3D | The contour of the rebar.
normal | The normal of the plane on which the rebar is defined.
barType | The type of the rebar.
stirrup | If the rebar is a stirrup.
hookStart | The hook start.
hookEnd | The hook end.
dbShapeName | The name of the database.
Returns

Returns the rebar object.

Description
Example

The example shows how to get rebar object based on the specific contour.

//Initializing converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Rebar data (it can be taken from different sources e.g. Revit).
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Reinf";
REXFamilyType_RebarBarType famRebarType = rex.GetFamilyRebarType("Grade 40", "#8", "bar_ACI 318-08", directory);
REXFamilyType_RebarHook hookStart = new REXFamilyType_RebarHook();
hookStart.Parameters.Angle = EHookAngles.none;
REXFamilyType_RebarHook hookEnd = new REXFamilyType_RebarHook();
hookEnd.Parameters.Angle = EHookAngles.none;

//Contour.
REX.ContentGenerator.Geometry.Contour_3D cont = new REX.ContentGenerator.Geometry.Contour_3D();
cont.StartContour(new REXxyz(0, 0));
cont.LineTo(new REXxyz(2, 0));
cont.LineTo(new REXxyz(2, 1));
REXxyz normal = new REXxyz(0, 0, 1);

//Getting Rebar object from contour.
REXFamilyType_Rebar r = rex.GetRebar(cont, normal, famRebarType, false, hookStart, hookEnd, "barlib7_iso");

The rebar object can be used by other converters to create a rebar of the specific shape (e.g. RVTFamilyConverter: CreateRebar).

Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, REXFamilyConverter Class

REXFamilyConverter.GetRebar Method (REX.ContentGenerator.Geometry.Contour_3D, REXxyz, REXFamilyType_RebarBarType, bool, REXFamilyType_RebarHook, REXFamilyType_RebarHook, string, bool)

REXFamilyConverter.GetRebar Method (REX.ContentGenerator.Geometry.Contour_3D, REXxyz, REXFamilyType_RebarBarType, bool, REXFamilyType_RebarHook, REXFamilyType_RebarHook, string, bool)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace Example REXFamilyConverter Class

Gets the rebar object due to the defined contour, the bar's type and the shape's database.

C#
public REXFamilyType_Rebar GetRebar(REX.ContentGenerator.Geometry.Contour_3D contour3D, REXxyz normal, REXFamilyType_RebarBarType barType, bool stirrup, REXFamilyType_RebarHook hookStart, REXFamilyType_RebarHook hookEnd, string dbShapeName, bool closedShape);
Parameters
Parameters | Description
contour3D | The contour of the rebar.
normal | The normal of the plane on which the rebar is defined.
barType | The type of the rebar.
stirrup | If the rebar is a stirrup.
hookStart | The hook start.
hookEnd | The hook end.
dbShapeName | The name of the database.
closedShape | If the rebar is closed.
Returns

Returns the rebar object.

Description
Example

The example shows how to get rebar object based on the specific contour.

//Initializing converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Rebar data (it can be taken from different sources e.g. Revit).
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Reinf";
REXFamilyType_RebarBarType famRebarType = rex.GetFamilyRebarType("Grade 40", "#8", "bar_ACI 318-08", directory);
REXFamilyType_RebarHook hookStart = new REXFamilyType_RebarHook();
hookStart.Parameters.Angle = EHookAngles.none;
REXFamilyType_RebarHook hookEnd = new REXFamilyType_RebarHook();
hookEnd.Parameters.Angle = EHookAngles.none;

//Contour.
REX.ContentGenerator.Geometry.Contour_3D cont = new REX.ContentGenerator.Geometry.Contour_3D();
cont.StartContour(new REXxyz(0, 0));
cont.LineTo(new REXxyz(2, 0));
cont.LineTo(new REXxyz(2, 1));
REXxyz normal = new REXxyz(0, 0, 1);

//Getting Rebar object from contour.
REXFamilyType_Rebar r = rex.GetRebar(cont, normal, famRebarType, false, hookStart, hookEnd, "barlib7_iso",true);

The rebar object can be used by other converters to create a rebar of the specific shape (e.g. RVTFamilyConverter: CreateRebar).

Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, REXFamilyConverter Class

REXFamilyConverter.GetRebar Method (REX.ContentGenerator.Geometry.Contour_3D, REXxyz, REXFamilyType_RebarBarType, bool, REXFamilyType_RebarHook, REXFamilyType_RebarHook, string, string)

REXFamilyConverter.GetRebar Method (REX.ContentGenerator.Geometry.Contour_3D, REXxyz, REXFamilyType_RebarBarType, bool, REXFamilyType_RebarHook, REXFamilyType_RebarHook, string, string)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace Example REXFamilyConverter Class

Gets the rebar object due to the defined contour, the bar's type and the shape's database.

C#
public REXFamilyType_Rebar GetRebar(REX.ContentGenerator.Geometry.Contour_3D contour3D, REXxyz normal, REXFamilyType_RebarBarType barType, bool stirrup, REXFamilyType_RebarHook hookStart, REXFamilyType_RebarHook hookEnd, string dbShapeName, string shape);
Parameters
Parameters | Description
contour3D | The contour of the rebar.
normal | The normal of the plane on which the rebar is defined.
barType | The type of the rebar.
stirrup | If the rebar is a stirrup.
hookStart | The hook start.
hookEnd | The hook end.
dbShapeName | The name of the database.
shape | The suggested shape (if empty the arbitrary rebar will be generated).
Returns

Returns the rebar object.

Description
Example

The example shows how to get rebar object based on the specific contour (with shape suggested).

//Initializing converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Rebar data (it can be taken from different sources e.g. Revit).
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Reinf";
REXFamilyType_RebarBarType famRebarType = rex.GetFamilyRebarType("Grade 40", "#8", "bar_ACI 318-08", directory);
REXFamilyType_RebarHook hookStart = new REXFamilyType_RebarHook();
hookStart.Parameters.Angle = EHookAngles.none;
REXFamilyType_RebarHook hookEnd = new REXFamilyType_RebarHook();
hookEnd.Parameters.Angle = EHookAngles.none;

//Contour.
REX.ContentGenerator.Geometry.Contour_3D cont = new REX.ContentGenerator.Geometry.Contour_3D();
cont.StartContour(new REXxyz(0, 0));
cont.LineTo(new REXxyz(2, 0));
cont.LineTo(new REXxyz(2, 1));
REXxyz normal = new REXxyz(0, 0, 1);

//Getting Rebar object from contour.
REXFamilyType_Rebar r = rex.GetRebar(cont, normal, famRebarType, false, hookStart, hookEnd, "barlib7_iso","12");

The rebar object can be used by other converters to create a rebar of the specific shape (e.g. RVTFamilyConverter: CreateRebar).

Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, REXFamilyConverter Class

REXFamilyConverter.GetRebar Method (REX.ContentGenerator.Geometry.Contour_3D, REXxyz, REXFamilyType_RebarBarType, bool, REXFamilyType_RebarHook, REXFamilyType_RebarHook, string, string, bool)