Initializes a new instance of the REXLayoutItem class.

C#
public REXLayoutItem(LayoutType Type, string Name, string GroupName, string Description, long Options, Control Dialog, Control View);
Parameters
Parameters | Description
Type | The type.
Name | The name.
GroupName | Name of the group.
Description | The description.
Options | The options.
Dialog | The dialog control.
View | The view or dialog control.
ImageIndex | Index of the image.
Description
Class

REXLayoutItem Class

Links
REXLayoutItem Class, REX.Common Namespace, REXLayoutItem Class

REXLayoutItem.REXLayoutItem Constructor (LayoutType, string, string, string, long, Control, Control, ImageSource)

REXLayoutItem.REXLayoutItem Constructor (LayoutType, string, string, string, long, Control, Control, ImageSource)
REXLayoutItem Class REX.Common Namespace REXLayoutItem Class

Initializes a new instance of the REXLayoutItem class.

C#
public REXLayoutItem(LayoutType Type, string Name, string GroupName, string Description, long Options, Control Dialog, Control View, ImageSource LayoutImage);
Parameters
Parameters | Description
Type | The type.
Name | The name.
GroupName | Name of the group.
Description | The description.
Options | The options.
Dialog | The dialog control.
View | The view or dialog control.
LayoutImage | The layout image.
Description
Class

REXLayoutItem Class

Links
REXLayoutItem Class, REX.Common Namespace, REXLayoutItem Class

REXLayoutItem.REXLayoutItem Constructor (LayoutType, string, string, string, long, System.Windows.Controls.Control)

REXLayoutItem.REXLayoutItem Constructor (LayoutType, string, string, string, long, System.Windows.Controls.Control)
REXLayoutItem Class REX.Common Namespace REXLayoutItem Class

Initializes a new instance of the REXLayoutItem class.

C#
public REXLayoutItem(LayoutType Type, string Name, string GroupName, string Description, long Options, System.Windows.Controls.Control Dialog);
Parameters
Parameters | Description
Type | The type.
Name | The name.
GroupName | Name of the group.
Description | The description.
Options | The options.
Dialog | The dialog control.
Description
Class

REXLayoutItem Class

Links
REXLayoutItem Class, REX.Common Namespace, REXLayoutItem Class

REX.Common.REXLayoutItem.LayoutType Enumeration

REX.Common.REXLayoutItem.LayoutType Enumeration
REXLayoutItem Class

Determines type of layout item.

C#
public enum LayoutType {
  Group = 1,
  Layout = 2
}
Members
Members | Description
Group | Group of items.
Layout | Standard layout.
Description
Class

REXLayoutItem Class

Links
REXLayoutItem Class
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXLayoutItem.ActiveTabPage Field

REXLayoutItem.ActiveTabPage Field
REXLayoutItem Class REX.Common Namespace REXLayoutItem Class

Gets or sets ActiveTabPage attribute of layout.

C#
public int ActiveTabPage;
Description

If layout contains standard tab control: TabDialog and TabView or TabNote, The property enables control for tab control. Must call Layout.Update method after changing.

Class

REXLayoutItem Class

Links
REXLayoutItem Class, REX.Common Namespace, REXLayoutItem Class

REXLayoutItem.Description Field

REXLayoutItem.Description Field
REXLayoutItem Class REX.Common Namespace REXLayoutItem Class

Gets or sets Description attribute of layout.

C#
public string Description;
Description

Must call Layout.Update method after changing.

Class

REXLayoutItem Class

Links
REXLayoutItem Class, REX.Common Namespace, REXLayoutItem Class

REXLayoutItem.Dialog Field

REXLayoutItem.Dialog Field
REXLayoutItem Class REX.Common Namespace REXLayoutItem Class

Gets or sets Dialog attribute of layout.

C#
public Control Dialog;
Description

Must call Layout.Update method after changing.

Class

REXLayoutItem Class

Links
REXLayoutItem Class, REX.Common Namespace, REXLayoutItem Class

REXLayoutItem.DisableCommands Field

REXLayoutItem.DisableCommands Field
REXLayoutItem Class REX.Common Namespace REXLayoutItem Class

Gets or sets DisableCommands attribute of layout.

C#
public List<string> DisableCommands = new List<string>();
Description

Must call Layout.Update method after changing.

Class

REXLayoutItem Class

Links
REXLayoutItem Class, REX.Common Namespace, REXLayoutItem Class

REXLayoutItem.GroupName Field

REXLayoutItem.GroupName Field
REXLayoutItem Class REX.Common Namespace REXLayoutItem Class

Gets or sets GroupName attribute of layout.

C#
public string GroupName;
Description

Must call Layout.Update method after changing.

Class

REXLayoutItem Class

Links
REXLayoutItem Class, REX.Common Namespace, REXLayoutItem Class

REXLayoutItem.LayoutImage Field

REXLayoutItem.LayoutImage Field
REXLayoutItem Class REX.Common Namespace REXLayoutItem Class

Gets or sets LayoutImage attribute of layout.

C#
public ImageSource LayoutImage;
Description

Must call Layout.Update method after changing.

Class

REXLayoutItem Class

Links
REXLayoutItem Class, REX.Common Namespace, REXLayoutItem Class

REXLayoutItem.Name Field

REXLayoutItem.Name Field
REXLayoutItem Class REX.Common Namespace REXLayoutItem Class

Gets or sets Name attribute of layout.

C#
public string Name;
Description

Must call Layout.Update method after changing.

Class

REXLayoutItem Class

Links
REXLayoutItem Class, REX.Common Namespace, REXLayoutItem Class

REXLayoutItem.Options Field

REXLayoutItem.Options Field
REXLayoutItem Class REX.Common Namespace REXLayoutItem Class

Gets or sets Options attribute of layout.

C#
public long Options;
Description

Must call Layout.Update method after changing.

Class

REXLayoutItem Class

Links
REXLayoutItem Class, REX.Common Namespace, REXLayoutItem Class

REXLayoutItem.Type Field

REXLayoutItem.Type Field
REXLayoutItem Class REX.Common Namespace REXLayoutItem Class

Gets or sets Type attribute of layout.

C#
public LayoutType Type;
Description

Must call Layout.Update method after changing.

Class

REXLayoutItem Class

Links
REXLayoutItem Class, REX.Common Namespace, REXLayoutItem Class

REXLayoutItem.View Field

REXLayoutItem.View Field
REXLayoutItem Class REX.Common Namespace REXLayoutItem Class

Gets or sets View attribute of layout.

C#
public Control View;
Description

Must call Layout.Update method after changing.

Class

REXLayoutItem Class

Links
REXLayoutItem Class, REX.Common Namespace, REXLayoutItem Class

REXLayoutItem.Visible Field

REXLayoutItem.Visible Field
REXLayoutItem Class REX.Common Namespace REXLayoutItem Class

Gets or sets visibility attribute of layout.

C#
public bool Visible;
Description

Must call Layout.Update method after changing.

Class

REXLayoutItem Class

Links
REXLayoutItem Class, REX.Common Namespace, REXLayoutItem Class

REXLayoutItem.DefaultDialogSize Property

REXLayoutItem.DefaultDialogSize Property
REXLayoutItem Class REX.Common Namespace REXLayoutItem Class

Gets the default size of the dialog.

C#
public Size DefaultDialogSize;
Description

The default size of the dialog.

Class

REXLayoutItem Class

Links
REXLayoutItem Class, REX.Common Namespace, REXLayoutItem Class

REXLayoutItem.DefaultViewSize Property

REXLayoutItem.DefaultViewSize Property
REXLayoutItem Class REX.Common Namespace REXLayoutItem Class

Gets the default size of the view.

C#
public Size DefaultViewSize;
Description

The default size of the view.

Class

REXLayoutItem Class

Links
REXLayoutItem Class, REX.Common Namespace, REXLayoutItem Class

REXLogger Class

REXLogger Class
REX.Common Namespace Legend Members REXLogger Methods

This is class REX.Common.REXLogger.

Class Hierarchy
C#
public class REXLogger;
Namespace

REX.Common Namespace

REXLogger Methods
REXLogger Methods | Description
Log | This is Log, a member of class REXLogger.
Log | This is Log, a member of class REXLogger.
Log | This is Log, a member of class REXLogger.
Log | This is Log, a member of class REXLogger.