Main interface for extension module.

Class Hierarchy
C#
public interface IREXExtension2 : IREXExtension;
Description
Namespace

REX.Common Namespace

IREXExtension2 Methods
IREXExtension2 Methods | Description
OnCanActivateLayout | Ask for activation - module can modify layout before or after activation.
OnGetExtensionName | Called when get extension name.
OnRegionalSettingsChanged | Called when regional settings changed.
Links
REX.Common Namespace, Legend, Members, IREXExtension2 Methods

IREXExtension2.OnCanActivateLayout Method

IREXExtension2.OnCanActivateLayout Method
IREXExtension2 Interface REX.Common Namespace IREXExtension2 Interface

Ask for activation - module can modify layout before or after activation.

C#
bool OnCanActivateLayout(REXLayoutItem LItem);
Parameters
Parameters | Description
LItem | The layout item.
Description
Interface

IREXExtension2 Interface

Links
IREXExtension2 Interface, REX.Common Namespace, IREXExtension2 Interface

IREXExtension2.OnGetExtensionName Method

IREXExtension2.OnGetExtensionName Method
IREXExtension2 Interface REX.Common Namespace IREXExtension2 Interface

Called when get extension name.

C#
string OnGetExtensionName(REXExtensionNameContext nameContext);
Parameters
Parameters | Description
nameContext | The name context.
Description
Interface

IREXExtension2 Interface

Links
IREXExtension2 Interface, REX.Common Namespace, IREXExtension2 Interface

IREXExtension2.OnRegionalSettingsChanged Method

IREXExtension2.OnRegionalSettingsChanged Method
IREXExtension2 Interface REX.Common Namespace IREXExtension2 Interface

Called when regional settings changed.

C#
void OnRegionalSettingsChanged();
Description
Interface

IREXExtension2 Interface

Links
IREXExtension2 Interface, REX.Common Namespace, IREXExtension2 Interface

IREXExtension3 Interface

IREXExtension3 Interface
REX.Common Namespace Legend Members IREXExtension3 Methods

Main interface for extension module.

Class Hierarchy
C#
public interface IREXExtension3 : IREXExtension2;
Description
Namespace

REX.Common Namespace

IREXExtension3 Methods
IREXExtension3 Methods | Description
OnSetContext | Called when regional settings changed.
Links
REX.Common Namespace, Legend, Members, IREXExtension3 Methods

IREXExtension3.OnSetContext Method

IREXExtension3.OnSetContext Method
IREXExtension3 Interface REX.Common Namespace IREXExtension3 Interface

Called when regional settings changed.

C#
void OnSetContext(REXContext context);
Description
Interface

IREXExtension3 Interface

Links
IREXExtension3 Interface, REX.Common Namespace, IREXExtension3 Interface

IREXExtension4 Interface

IREXExtension4 Interface
REX.Common Namespace Legend Members IREXExtension4 Methods

Main interface for extension module.

Class Hierarchy
C#
public interface IREXExtension4 : IREXExtension3;
Description
Namespace

REX.Common Namespace

IREXExtension4 Methods
IREXExtension4 Methods | Description
OnCheckValidity | Called when check validity.
Links
REX.Common Namespace, Legend, Members, IREXExtension4 Methods

IREXExtension4.OnCheckValidity Method

IREXExtension4.OnCheckValidity Method
IREXExtension4 Interface REX.Common Namespace IREXExtension4 Interface

Called when check validity.

C#
bool? OnCheckValidity();
Description
Interface

IREXExtension4 Interface

Links
IREXExtension4 Interface, REX.Common Namespace, IREXExtension4 Interface

IREXExtensionAccess Interface

IREXExtensionAccess Interface
REX.Common Namespace Legend Members IREXExtensionAccess Methods

Main interface for REXAccess class.

Class Hierarchy
C#
public interface IREXExtensionAccess;
Description
Namespace

REX.Common Namespace

IREXExtensionAccess Methods
IREXExtensionAccess Methods | Description
Create | Reads some data from parent application and set system display units.
Destroy | Destroys and resets some objects connected to parent application.
Initialize | Initializes this instance.
Update | Reads some data from parent application and set system display units.
Links
REX.Common Namespace, Legend, Members, IREXExtensionAccess Methods

IREXExtensionAccess.Create Method

IREXExtensionAccess.Create Method
IREXExtensionAccess Interface REX.Common Namespace IREXExtensionAccess Interface

Reads some data from parent application and set system display units.

C#
bool Create();
Returns

Returns true if succeeded.

Description
Interface

IREXExtensionAccess Interface

Links
IREXExtensionAccess Interface, REX.Common Namespace, IREXExtensionAccess Interface

IREXExtensionAccess.Destroy Method

IREXExtensionAccess.Destroy Method
IREXExtensionAccess Interface REX.Common Namespace IREXExtensionAccess Interface

Destroys and resets some objects connected to parent application.

C#
bool Destroy();
Returns

Returns true if succeeded.

Description
Interface

IREXExtensionAccess Interface

Links
IREXExtensionAccess Interface, REX.Common Namespace, IREXExtensionAccess Interface

IREXExtensionAccess.Initialize Method

IREXExtensionAccess.Initialize Method
IREXExtensionAccess Interface REX.Common Namespace IREXExtensionAccess Interface

Initializes this instance.

C#
void Initialize();
Description

Nostly sets language from parent application.

Interface

IREXExtensionAccess Interface

Links
IREXExtensionAccess Interface, REX.Common Namespace, IREXExtensionAccess Interface

IREXExtensionAccess.Update Method

IREXExtensionAccess.Update Method
IREXExtensionAccess Interface REX.Common Namespace IREXExtensionAccess Interface

Reads some data from parent application and set system display units.

C#
void Update();
Description
Interface

IREXExtensionAccess Interface

Links
IREXExtensionAccess Interface, REX.Common Namespace, IREXExtensionAccess Interface

IREXExtensionAccess2 Interface

IREXExtensionAccess2 Interface
REX.Common Namespace Legend Members IREXExtensionAccess2 Methods

Main interface for REXAccess class.

Class Hierarchy
C#
public interface IREXExtensionAccess2 : IREXExtensionAccess;
Description
Namespace

REX.Common Namespace

IREXExtensionAccess2 Methods
IREXExtensionAccess2 Methods | Description
Event | Events the specified ev.
Links
REX.Common Namespace, Legend, Members, IREXExtensionAccess2 Methods

IREXExtensionAccess2.Event Method

IREXExtensionAccess2.Event Method
IREXExtensionAccess2 Interface REX.Common Namespace IREXExtensionAccess2 Interface

Events the specified ev.

C#
bool Event(REXAccess.REXAccessEvent Ev);
Parameters
Parameters | Description
Ev | The ev.
Description
Interface

IREXExtensionAccess2 Interface

Links
IREXExtensionAccess2 Interface, REX.Common Namespace, IREXExtensionAccess2 Interface

IREXExtensionAccess3 Interface

IREXExtensionAccess3 Interface
REX.Common Namespace Legend Members IREXExtensionAccess3 Methods

Main interface for REXAccess class.

Class Hierarchy
C#
public interface IREXExtensionAccess3 : IREXExtensionAccess2;
Description
Namespace

REX.Common Namespace

IREXExtensionAccess3 Methods
IREXExtensionAccess3 Methods | Description
Detach | Detaches this instance.
Links
REX.Common Namespace, Legend, Members, IREXExtensionAccess3 Methods

IREXExtensionAccess3.Detach Method

IREXExtensionAccess3.Detach Method
IREXExtensionAccess3 Interface REX.Common Namespace IREXExtensionAccess3 Interface

Detaches this instance.

C#
void Detach();
Description
Interface

IREXExtensionAccess3 Interface

Links
IREXExtensionAccess3 Interface, REX.Common Namespace, IREXExtensionAccess3 Interface

IREXExtensionAccessUnitsControl Interface

IREXExtensionAccessUnitsControl Interface
REX.Common Namespace Legend Members IREXExtensionAccessUnitsControl Methods

Main interface for REXAccess class.

Class Hierarchy
C#
public interface IREXExtensionAccessUnitsControl;
Description
Namespace

REX.Common Namespace

IREXExtensionAccessUnitsControl Methods
IREXExtensionAccessUnitsControl Methods | Description
Setup | Setups this instance.
Update | Updates this instance.
Links
REX.Common Namespace, Legend, Members, IREXExtensionAccessUnitsControl Methods