ThisRunContext | Gets the this run context.

REXExtensionObject Class Public Methods

REXExtensionObject Class Public Methods
REXExtensionObject Class Legend
Public Methods
Public Method | Description
REXExtensionObject | Initializes a new instance of a REXExtensionObject class.

Legend

Legend
REXExtensionPanel Class
Legend
Constructor
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXExtensionPanel Class Members

REXExtensionPanel Class Members
REXExtensionPanel Class Legend
Members
Public Methods
Public Method | Description
REXExtensionPanel | Initializes a new instance of a REXExtensionForm class.
REXExtensionPanel | Initializes a new instance of a REXExtensionForm class.
REXExtensionPanel Methods
REXExtensionPanel Methods | Description
SetControl | Sets the control.
REXExtensionPanel Properties
REXExtensionPanel Properties | Description
ThisApplication | Get this application.
ThisContext | Get this context.
ThisExtension | Get this extension.
ThisProduct | Gets the this product.
ThisRunContext | Gets the this run context.

REXExtensionPanel Methods

REXExtensionPanel Methods
REXExtensionPanel Class Legend
REXExtensionPanel Methods
REXExtensionPanel Methods | Description
SetControl | Sets the control.

REXExtensionPanel Properties

REXExtensionPanel Properties
REXExtensionPanel Class Legend
REXExtensionPanel Properties
REXExtensionPanel Properties | Description
ThisApplication | Get this application.
ThisContext | Get this context.
ThisExtension | Get this extension.
ThisProduct | Gets the this product.
ThisRunContext | Gets the this run context.

REXExtensionPanel Class Public Methods

REXExtensionPanel Class Public Methods
REXExtensionPanel Class Legend
Public Methods
Public Method | Description
REXExtensionPanel | Initializes a new instance of a REXExtensionForm class.
REXExtensionPanel | Initializes a new instance of a REXExtensionForm class.

Legend

Legend
REXExtensionProduct Class
Legend
Constructor
virtual

REXExtensionProduct Class Members

REXExtensionProduct Class Members
REXExtensionProduct Class Legend
Members
Public Methods
Public Method | Description
REXExtensionProduct | Initializes a new instance of the REXExtensionFactory class.
REXExtensionProduct Methods
REXExtensionProduct Methods | Description
OnActivateLayout | Activates or deactivates layout - module can modify layout before or after activation.
OnCanClose | If returns true dialog will close after OK button is clicked.
OnCanClose | If returns true dialog will close after OK button is clicked.
OnCanRun | Checks status of module and shows some information for user if module can't excecute action.
OnClear | Called when data are cleared.
OnClose | Called during closing module.
OnCommand | Commands the specified command struct.
OnCreate | Creates needed structures and verify needs.
OnCreateDialogs | Creates sub dialogs.
OnCreateLayout | Creates layout items and setups layout.
OnDataLoad | Called when data are loaded.
OnDataLoaded | Called when data loaded.
OnDataSave | Called when data are saved.
OnDataSaved | Called when data are saved.
OnErrorSelected | Called when an error is selected on errors list dialog.
OnEvent | Called when event.
OnGetText | Get specified text from resources.
OnInitialize | Called when Initialize.
OnLoadTemplate | Called when template is loaded.
OnPreferencesChanged | Called when preferences changed.
OnRun | Runs process calculations or other operations.
OnSaveTemplate | Called when template is saved.
OnSetData | Get data from dialogs and sets Data's strucutres.
OnSetDialogs | Set data on dialogs.
OnShowResults | Shows results.
OnUpdateDialogs | This is OnUpdateDialogs, a member of class REXExtensionProduct.

REXExtensionProduct Methods

REXExtensionProduct Methods
REXExtensionProduct Class Legend
REXExtensionProduct Methods
REXExtensionProduct Methods | Description
OnActivateLayout | Activates or deactivates layout - module can modify layout before or after activation.
OnCanClose | If returns true dialog will close after OK button is clicked.
OnCanClose | If returns true dialog will close after OK button is clicked.
OnCanRun | Checks status of module and shows some information for user if module can't excecute action.
OnClear | Called when data are cleared.
OnClose | Called during closing module.
OnCommand | Commands the specified command struct.
OnCreate | Creates needed structures and verify needs.
OnCreateDialogs | Creates sub dialogs.
OnCreateLayout | Creates layout items and setups layout.
OnDataLoad | Called when data are loaded.
OnDataLoaded | Called when data loaded.
OnDataSave | Called when data are saved.
OnDataSaved | Called when data are saved.
OnErrorSelected | Called when an error is selected on errors list dialog.
OnEvent | Called when event.
OnGetText | Get specified text from resources.
OnInitialize | Called when Initialize.
OnLoadTemplate | Called when template is loaded.
OnPreferencesChanged | Called when preferences changed.
OnRun | Runs process calculations or other operations.
OnSaveTemplate | Called when template is saved.
OnSetData | Get data from dialogs and sets Data's strucutres.
OnSetDialogs | Set data on dialogs.
OnShowResults | Shows results.
OnUpdateDialogs | This is OnUpdateDialogs, a member of class REXExtensionProduct.

REXExtensionProduct Class Public Methods

REXExtensionProduct Class Public Methods
REXExtensionProduct Class Legend
Public Methods
Public Method | Description
REXExtensionProduct | Initializes a new instance of the REXExtensionFactory class.

Legend

Legend
REXExtensionSettings Class
Legend
Constructor
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXExtensionSettings Class Members

REXExtensionSettings Class Members
REXExtensionSettings Class Legend
Members
Public Methods
Public Method | Description
REXExtensionSettings | Initializes a new instance of the REXExtensionSettings class.
REXExtensionSettings | Initializes a new instance of the REXExtensionSettings class.
REXExtensionSettings Methods
REXExtensionSettings Methods | Description
LoadSettings | This is LoadSettings, a member of class REXExtensionSettings.
REXExtensionSettings Properties
REXExtensionSettings Properties | Description
ThisApplication | Get the application.
ThisContext | Get the context.
ThisExtension | Get the extension.

REXExtensionSettings Methods

REXExtensionSettings Methods
REXExtensionSettings Class Legend
REXExtensionSettings Methods
REXExtensionSettings Methods | Description
LoadSettings | This is LoadSettings, a member of class REXExtensionSettings.

REXExtensionSettings Properties

REXExtensionSettings Properties
REXExtensionSettings Class Legend
REXExtensionSettings Properties
REXExtensionSettings Properties | Description
ThisApplication | Get the application.
ThisContext | Get the context.
ThisExtension | Get the extension.

REXExtensionSettings Class Public Methods

REXExtensionSettings Class Public Methods
REXExtensionSettings Class Legend
Public Methods
Public Method | Description
REXExtensionSettings | Initializes a new instance of the REXExtensionSettings class.
REXExtensionSettings | Initializes a new instance of the REXExtensionSettings class.

Legend

Legend
REXExtensionWindow Class
Legend
Constructor
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXExtensionWindow Class Members

REXExtensionWindow Class Members
REXExtensionWindow Class Legend
Members
Public Methods
Public Method | Description