Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.Layout Property

REXExtension.Layout Property
REXExtension Class REX.Common Namespace REXExtension Class

Get the reference to Layout object.

C#
public REXLayout Layout;
Description

Uses for setting up layout of user interface of this module.

The Layout object.

Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.MainAccess Property

REXExtension.MainAccess Property
REXExtension Class REX.Common Namespace REXExtension Class

Get the reference to object which controls interactions between module, and main application.

C#
public REXAccess MainAccess;
Description

The reference to MainAccess object.

Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.Preferences Property

REXExtension.Preferences Property
REXExtension Class REX.Common Namespace REXExtension Class

Get the reference to Preferences object.

C#
public REXPreferences Preferences;
Description

The Preferences object.

Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.Progress Property

REXExtension.Progress Property
REXExtension Class REX.Common Namespace REXExtension Class

Get the reference to progress object.

C#
public Autodesk.REX.Framework.IREXProgress Progress;
Description

The progress object.

Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.Revit Property

REXExtension.Revit Property
REXExtension Class REX.Common Namespace REXExtension Class

Get the reference to object which controls interactions between module, and Revit.

C#
public REXRevitAccess Revit;
Description

The reference to RevitAccess object.

Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.Style Property

REXExtension.Style Property
REXExtension Class REX.Common Namespace REXExtension Class

This is Style, a member of class REXExtension.

C#
public ResourceDictionary Style;
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.System Property

REXExtension.System Property
REXExtension Class REX.Common Namespace REXExtension Class

Get the reference to System object.

C#
public REXSystem System;
Description

Uses for some system's operations like as save or load data from file, units calculation, etc.

The System> object.

Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.ThisApplication Property

REXExtension.ThisApplication Property
REXExtension Class REX.Common Namespace REXExtension Class

Get this application.

C#
public REXApplication ThisApplication;
Description

This application.

Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.ThisContext Property

REXExtension.ThisContext Property
REXExtension Class REX.Common Namespace REXExtension Class

Get the context.

C#
public REXContext ThisContext;
Description

The context.

Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.ThisProduct Property

REXExtension.ThisProduct Property
REXExtension Class REX.Common Namespace REXExtension Class

Gets the this product.

C#
public REXInterfaceType ThisProduct;
Description

The this product.

Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.ThisRunContext Property

REXExtension.ThisRunContext Property
REXExtension Class REX.Common Namespace REXExtension Class

Gets the this run context.

C#
public REX.Common.REXExtensionContext.REXStandardRunContext ThisRunContext;
Description

The this run context.

Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.UI Property

REXExtension.UI Property
REXExtension Class REX.Common Namespace REXExtension Class

Get the reference to UI object.

C#
public REXUI UI;
Description

The UI object.

Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.Units Property

REXExtension.Units Property
REXExtension Class REX.Common Namespace REXExtension Class

Get the reference to Units object.

C#
public REXUnits Units;
Description

The Units object.

Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtensionContext Class

REXExtensionContext Class
REX.Common Namespace Legend Members Public Methods REXExtensionContext Enumerations REXExtensionContext Fields REXExtensionContext Structures

Internal class for controlling behavior of the extension.

Class Hierarchy
C#
public class REXExtensionContext;
Description
Namespace

REX.Common Namespace

Public Methods
Public Method | Description
REXExtensionContext | Initializes a new instance of a REXExtensionContext class and sets defaults.
REXExtensionContext Enumerations
REXExtensionContext Enumerations | Description
REXLevelType | Level type.
REXStandardOwner | Owner of module.
REXStandardRunContext | Defines standard running context.
REXExtensionContext Fields
REXExtensionContext Fields | Description
Control | Reference to Control object.
REXExtensionContext Structures
REXExtensionContext Structures | Description
REXControl | Controls behavior of module.
REXControlFlags | Flags used for detecting forced settings.
Links
REX.Common Namespace, Legend, Members, Public Methods, REXExtensionContext Enumerations, REXExtensionContext Fields, REXExtensionContext Structures

REXExtensionContext.REXExtensionContext Constructor

REXExtensionContext.REXExtensionContext Constructor
REXExtensionContext Class REX.Common Namespace REXExtensionContext Class

Initializes a new instance of a REXExtensionContext class and sets defaults.

C#
public REXExtensionContext();
Description
Class

REXExtensionContext Class

Links
REXExtensionContext Class, REX.Common Namespace, REXExtensionContext Class

REXExtensionContext.REXControl Structure

REXExtensionContext.REXControl Structure
REXExtensionContext Class Legend Members REXControl Fields REXControl Properties

Controls behavior of module.

C#
public struct REXControl {
  public bool ShowErrorsDialog;
  public string RunContext;
  public REXStandardRunContext StandardRunContext;
  public bool VerifySelection;
  public bool APIContext;
  public bool NoUI;
  public bool LanguagesSupport;
  public bool ForceHideManager;
  public bool InteractiveCommand;
  public bool RegionalSettingsSupport;
  public REXLevelType LevelType;
  public REXStandardOwner StandardOwner;
  public string Owner;
  public REXControlFlags Flags;
}
Description
Class

REXExtensionContext Class

REXControl Fields
REXControl Fields | Description
APIContext | Indicates that module is running in API context.
Flags | Flags used for detecting forced settings.
ForceHideManager | Orders to hide manager of extensions.
InteractiveCommand | Indicates that module uses interactive modal dialog.
LanguagesSupport | Indicates that module has multi-language architecture.
LevelType | Level type.
NoUI | Indicates that module can't show any messages and dialogs.
Owner | Owner of extension.
RegionalSettingsSupport | If true, regional settings will be added to menu and toolbars.
RunContext | String which set up running context.
ShowErrorsDialog | Enables or disables showing of errors in dialog.
StandardOwner | Owner of extension.
StandardRunContext | String mapped to enum which set up running context.
VerifySelection | Indicates that module is running for verification current selection.
REXControl Properties
REXControl Properties | Description
UserInterface | Enables or disables user interface operations.
Links
REXExtensionContext Class, Legend, Members, REXControl Fields, REXControl Properties