Databases | Gets or sets the list of databases.
SelectedElement | Gets or sets the selected element.
SelectedElements | Gets the selected elements.
Visible | Gets or sets a value indicating whether this category is visible.
Links
REX.ContentGenerator.Dialog Namespace, Legend, Members, Public Methods, REXContentDialogCategorySettings Properties

REXContentDialogCategorySettings.REXContentDialogCategorySettings Constructor

REXContentDialogCategorySettings.REXContentDialogCategorySettings Constructor
REXContentDialogCategorySettings Class REX.ContentGenerator.Dialog Namespace REXContentDialogCategorySettings Class

Initializes a new instance of the REXContentDialogCategorySettings class.

C#
public REXContentDialogCategorySettings(ECategoryType category, REXContentDialogSettings parent);
Parameters
Parameters | Description
category | The category.
parent | The parent.
Description
Class

REXContentDialogCategorySettings Class

Links
REXContentDialogCategorySettings Class, REX.ContentGenerator.Dialog Namespace, REXContentDialogCategorySettings Class

REXContentDialogCategorySettings.Category Property

REXContentDialogCategorySettings.Category Property
REXContentDialogCategorySettings Class REX.ContentGenerator.Dialog Namespace REXContentDialogCategorySettings Class

Gets the category type.

C#
public ECategoryType Category;
Description

The category type.

Class

REXContentDialogCategorySettings Class

Links
REXContentDialogCategorySettings Class, REX.ContentGenerator.Dialog Namespace, REXContentDialogCategorySettings Class

REXContentDialogCategorySettings.Databases Property

REXContentDialogCategorySettings.Databases Property
REXContentDialogCategorySettings Class REX.ContentGenerator.Dialog Namespace REXContentDialogCategorySettings Class

Gets or sets the list of databases.

C#
public Dictionary<string, List<REXFamilyType>> Databases;
Description

The databases.

Class

REXContentDialogCategorySettings Class

Links
REXContentDialogCategorySettings Class, REX.ContentGenerator.Dialog Namespace, REXContentDialogCategorySettings Class

REXContentDialogCategorySettings.SelectedElement Property

REXContentDialogCategorySettings.SelectedElement Property
REXContentDialogCategorySettings Class REX.ContentGenerator.Dialog Namespace REXContentDialogCategorySettings Class

Gets or sets the selected element.

C#
public REXFamilyType SelectedElement;
Description

The selected element.

Class

REXContentDialogCategorySettings Class

Links
REXContentDialogCategorySettings Class, REX.ContentGenerator.Dialog Namespace, REXContentDialogCategorySettings Class

REXContentDialogCategorySettings.SelectedElements Property

REXContentDialogCategorySettings.SelectedElements Property
REXContentDialogCategorySettings Class REX.ContentGenerator.Dialog Namespace REXContentDialogCategorySettings Class

Gets the selected elements.

C#
public List<REXFamilyType> SelectedElements;
Description

The selected elements.

Class

REXContentDialogCategorySettings Class

Links
REXContentDialogCategorySettings Class, REX.ContentGenerator.Dialog Namespace, REXContentDialogCategorySettings Class

REXContentDialogCategorySettings.Visible Property

REXContentDialogCategorySettings.Visible Property
REXContentDialogCategorySettings Class REX.ContentGenerator.Dialog Namespace REXContentDialogCategorySettings Class

Gets or sets a value indicating whether this category is visible.

C#
public bool Visible;
Description

True if the category is visible; otherwise, false.

Class

REXContentDialogCategorySettings Class

Links
REXContentDialogCategorySettings Class, REX.ContentGenerator.Dialog Namespace, REXContentDialogCategorySettings Class

REXContentDialogManager Class

REXContentDialogManager Class
REX.ContentGenerator.Dialog Namespace Legend Members Public Methods REXContentDialogManager Methods

Helps manage DRevitContentGenerator Extension directly by code.

Class Hierarchy
C#
public class REXContentDialogManager;
Description
Namespace

REX.ContentGenerator.Dialog Namespace

Public Methods
Public Method | Description
REXContentDialogManager | Initializes a new instance of the REXContentDialogManager class.
REXContentDialogManager Methods
REXContentDialogManager Methods | Description
DisposeContentDialog | Disposes the DRevitContentGenerator Extension.
SetApplicationInstance | Sets the Extension Instance.
ShowContentDialog | Loads the ContentGenerator dialog.
ShowContentDialogParentIntPtr | Loads the ContentGenerator dialog.
Links
REX.ContentGenerator.Dialog Namespace, Legend, Members, Public Methods, REXContentDialogManager Methods

REXContentDialogManager.REXContentDialogManager Constructor

REXContentDialogManager.REXContentDialogManager Constructor
REXContentDialogManager Class REX.ContentGenerator.Dialog Namespace REXContentDialogManager Class

Initializes a new instance of the REXContentDialogManager class.

C#
public REXContentDialogManager(REXContext context);
Parameters
Parameters | Description
context | The context.
Description
Class

REXContentDialogManager Class

Links
REXContentDialogManager Class, REX.ContentGenerator.Dialog Namespace, REXContentDialogManager Class

REXContentDialogManager.DisposeContentDialog Method

REXContentDialogManager.DisposeContentDialog Method
REXContentDialogManager Class REX.ContentGenerator.Dialog Namespace REXContentDialogManager Class

Disposes the DRevitContentGenerator Extension.

C#
public void DisposeContentDialog();
Description
Class

REXContentDialogManager Class

Links
REXContentDialogManager Class, REX.ContentGenerator.Dialog Namespace, REXContentDialogManager Class

REXContentDialogManager.SetApplicationInstance Method

REXContentDialogManager.SetApplicationInstance Method
REXContentDialogManager Class REX.ContentGenerator.Dialog Namespace REXContentDialogManager Class

Sets the Extension Instance.

C#
public void SetApplicationInstance(REXContentDialogSettings settings);
Parameters
Parameters | Description
settings | The dialogs settings
Description
Remarks

The loading Extension process is time consuming. It is better to set the application instance during other items initilization.

Class

REXContentDialogManager Class

Links
REXContentDialogManager Class, REX.ContentGenerator.Dialog Namespace, REXContentDialogManager Class

REXContentDialogManager.ShowContentDialog Method

REXContentDialogManager.ShowContentDialog Method
REXContentDialogManager Class REX.ContentGenerator.Dialog Namespace Example REXContentDialogManager Class

Loads the ContentGenerator dialog.

C#
public System.Windows.Forms.DialogResult ShowContentDialog(REXContentDialogSettings settings, IWin32Window owner);
Parameters
Parameters | Description
settings | The dialog's settings.
owner | The parent for the window.
Returns

Returns the result of the dialog show.

Description
Example

The example shows how to launch the DRevitContentGenerator dialog and use it as a family browser.

//Manager initialize.
REX.ContentGenerator.Dialog.REXContentDialogManager mng = new REX.ContentGenerator.Dialog.REXContentDialogManager(ThisExtension.Context);

//Settings initialize
//-general
REX.ContentGenerator.Dialog.REXContentDialogSettings settings = new REX.ContentGenerator.Dialog.REXContentDialogSettings();
settings.DialogMode = REX.ContentGenerator.Dialog.EContentDialogMode.MultiSelection;
settings.RegionalSettings = true;
settings.ShowList = true;
settings.Progress = false;
settings.Caption = "Example1";
//-for sections
settings.SectionDBSettings.SelectedElements.Clear();
settings.SectionDBSettings.Visible = true;

//Launching the dialog.
mng.ShowContentDialog(settings, ThisExtension.GetWindowForParent());

//Getting selection.
List<REXFamilyType> families = new List<REXFamilyType>(settings.SectionDBSettings.SelectedElements);

//Disposing dialog.
mng.DisposeContentDialog();
Class

REXContentDialogManager Class

Links
REXContentDialogManager Class, REX.ContentGenerator.Dialog Namespace, Example, REXContentDialogManager Class