SetInterfaceMaxValue | Set the maximum value defined in interface units.
SetInterfaceMinValue | Set the minimum value defined in interface units.

REXUnitComboBox Properties

REXUnitComboBox Properties
REXUnitComboBox Class Legend
REXUnitComboBox Properties
REXUnitComboBox Properties | Description
Power | Gets or sets the power of the unit.
UnitEngine | Gets or sets the unit engine.
UnitType | Gets or sets the type of the unit.

Legend

Legend
REXUnitEditBox Class
Legend
Method
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXUnitEditBox Class Members

REXUnitEditBox Class Members
REXUnitEditBox Class Legend
Members
REXUnitEditBox Methods
REXUnitEditBox Methods | Description
GetBaseMaxValue | Gets the maximum value and converts it to base units.
GetBaseMinValue | Gets the minimum value and converts it to base units.
GetComplexDataBaseValue | Get the values and convert it to base units.
GetComplexDataInterfaceValue | Get the values and convert it to interface units.
GetDataBaseValue | Gets the value and converts it to base units.
GetDataInterfaceValue | Gets the value and converts it to interface units.
GetInterfaceMaxValue | Gets the maximum value and converts it to interface units.
GetInterfaceMinValue | Gets the minimum value and converts it to interface units.
SetBaseMaxValue | Set the maximum value defined in base units.
SetBaseMinValue | Set the minimum value defined in base units.
SetComplexDataBaseValue | Set the list of values defined in base units.
SetComplexDataInterfaceValue | Set the list of values defined in interface units.
SetDataBaseValue | Set the value in base units.
SetDataInterfaceValue | Set the value in interface units.
SetInterfaceMaxValue | Set the maximum value defined in interface units.
SetInterfaceMinValue | Set the minimum value defined in interface units.
REXUnitEditBox Properties
REXUnitEditBox Properties | Description
Power | Gets or sets the power of the unit.
UnitEngine | Gets or sets the unit engine.
UnitType | Gets or sets the type of the unit.

REXUnitEditBox Methods

REXUnitEditBox Methods
REXUnitEditBox Class Legend
REXUnitEditBox Methods
REXUnitEditBox Methods | Description
GetBaseMaxValue | Gets the maximum value and converts it to base units.
GetBaseMinValue | Gets the minimum value and converts it to base units.
GetComplexDataBaseValue | Get the values and convert it to base units.
GetComplexDataInterfaceValue | Get the values and convert it to interface units.
GetDataBaseValue | Gets the value and converts it to base units.
GetDataInterfaceValue | Gets the value and converts it to interface units.
GetInterfaceMaxValue | Gets the maximum value and converts it to interface units.
GetInterfaceMinValue | Gets the minimum value and converts it to interface units.
SetBaseMaxValue | Set the maximum value defined in base units.
SetBaseMinValue | Set the minimum value defined in base units.
SetComplexDataBaseValue | Set the list of values defined in base units.
SetComplexDataInterfaceValue | Set the list of values defined in interface units.
SetDataBaseValue | Set the value in base units.
SetDataInterfaceValue | Set the value in interface units.
SetInterfaceMaxValue | Set the maximum value defined in interface units.
SetInterfaceMinValue | Set the minimum value defined in interface units.

REXUnitEditBox Properties

REXUnitEditBox Properties
REXUnitEditBox Class Legend
REXUnitEditBox Properties
REXUnitEditBox Properties | Description
Power | Gets or sets the power of the unit.
UnitEngine | Gets or sets the unit engine.
UnitType | Gets or sets the type of the unit.

REX.Controls.WPF Namespace Classes

REX.Controls.WPF Namespace Classes
REX.Controls.WPF Namespace Legend
Classes
Class | Description
REXComboBox | Represents a REX combo box control.
REXEditBox | Represents the REXEditBox control.
REXImageComboBox | Represents combobox with images.
REXImageComboBoxItem | Represents the combobox item with an image inside.
REXIndexLabel | Represents the REXIndexLabel control.
REXToolbox | Represents the REXToolbox control
REXToolboxCategoriesCollection | Represents collection of categories of the REXToolbox control.
REXToolboxCategory | Represents the REXToolbox category.
REXToolboxCollection | Base classes for REXToolboxs collections.
REXToolboxItem | Represents the REXToolbox item.
REXToolboxItemsCollection | Represents collection of items of the REXToolbox control.
REXToolboxObject | The base class for all toolbox objects (categories and items)
REXUnitComboBox | Represents the REXUnitComboBox control with a built in IREXUnitEngine.
REXUnitEditBox | Represents the REXEditBox control with a built in IREXUnitEngine.
WPFCommon | This is class REX.Controls.WPF.WPFCommon.

Legend

Legend
REX.Controls.WPF Namespace
Legend
Class
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXComboBox Fields

REXComboBox Fields
REXComboBox Class Legend
REXComboBox Fields
REXComboBox Fields | Description
BackgroundDisabledHiddenProperty | This is BackgroundDisabledHiddenProperty, a member of class REXComboBox.
BackgroundDisabledStandardProperty | This is BackgroundDisabledStandardProperty, a member of class REXComboBox.
BackgroundErrorProperty | This is BackgroundErrorProperty, a member of class REXComboBox.
BackgroundNeutralProperty | This is BackgroundNeutralProperty, a member of class REXComboBox.
BackgroundOKProperty | This is BackgroundOKProperty, a member of class REXComboBox.
ComplexDoubleValueProperty | This is ComplexDoubleValueProperty, a member of class REXComboBox.
ComplexProperty | This is ComplexProperty, a member of class REXComboBox.
ComplexSeparatorProperty | This is ComplexSeparatorProperty, a member of class REXComboBox.
ComplexSpaceSeparatorProperty | This is ComplexSpaceSeparatorProperty, a member of class REXComboBox.
ComplexUnitOnEndProperty | This is ComplexUnitOnEndProperty, a member of class REXComboBox.
CorrectValueProperty | This is CorrectValueProperty, a member of class REXComboBox.
DataTypeProperty | This is DataTypeProperty, a member of class REXComboBox.
DoubleValueProperty | This is DoubleValueProperty, a member of class REXComboBox.
EngineeringFormatProperty | This is EngineeringFormatProperty, a member of class REXComboBox.
EpsilonProperty | This is EpsilonProperty, a member of class REXComboBox.
InvalidCharactersProperty | This is InvalidCharactersProperty, a member of class REXComboBox.
ListValidationProperty | This is ListValidationProperty, a member of class REXComboBox.
MaxTokensProperty | This is MaxTokensProperty, a member of class REXComboBox.
MinTokensProperty | This is MinTokensProperty, a member of class REXComboBox.
OnDisableActionProperty | This is OnDisableActionProperty, a member of class REXComboBox.
OriginalTextOnEnterProperty | This is OriginalTextOnEnterProperty, a member of class REXComboBox.
RangeMaxCheckProperty | This is RangeMaxCheckProperty, a member of class REXComboBox.
RangeMaxProperty | This is RangeMaxProperty, a member of class REXComboBox.
RangeMinCheckProperty | This is RangeMinCheckProperty, a member of class REXComboBox.
RangeMinProperty | This is RangeMinProperty, a member of class REXComboBox.
RememberCorrectProperty | This is RememberCorrectProperty, a member of class REXComboBox.
RoundingFractionalProperty | This is RoundingFractionalProperty, a member of class REXComboBox.
RoundingIncrementProperty | This is RoundingIncrementProperty, a member of class REXComboBox.
SeparatorProperty | This is SeparatorProperty, a member of class REXComboBox.
TextBoxModeProperty | This is TextBoxModeProperty, a member of class REXComboBox.