REXToolbox Class REX.Controls.WPF Namespace REXToolbox Class

Occurs when the selected item changed.

C#
public event EventSelectedItemChanged SelectedItemChanged;
Description
Class

REXToolbox Class

Links
REXToolbox Class, REX.Controls.WPF Namespace, REXToolbox Class

REXToolboxCategoriesCollection Class

REXToolboxCategoriesCollection Class
REX.Controls.WPF Namespace Legend Members Public Methods

Represents collection of categories of the REXToolbox control.

Class Hierarchy
C#
public class REXToolboxCategoriesCollection : REXToolboxCollection<REXToolboxCategory>;
Description
Namespace

REX.Controls.WPF Namespace

Public Methods
Public Method | Description
REXToolboxCategoriesCollection | Initializes a new instance of the REXToolboxCategoriesCollection class.
Links
REX.Controls.WPF Namespace, Legend, Members, Public Methods

REXToolboxCategoriesCollection.REXToolboxCategoriesCollection Constructor

REXToolboxCategoriesCollection.REXToolboxCategoriesCollection Constructor
REXToolboxCategoriesCollection Class REX.Controls.WPF Namespace REXToolboxCategoriesCollection Class

Initializes a new instance of the REXToolboxCategoriesCollection class.

C#
public REXToolboxCategoriesCollection(REXToolbox toolbox);
Parameters
Parameters | Description
toolbox | The toolbox.
Description
Class

REXToolboxCategoriesCollection Class

Links
REXToolboxCategoriesCollection Class, REX.Controls.WPF Namespace, REXToolboxCategoriesCollection Class

REXToolboxCategory Class

REXToolboxCategory Class
REX.Controls.WPF Namespace Legend Members Public Methods REXToolboxCategory Properties

Represents the REXToolbox category.

Class Hierarchy
C#
public class REXToolboxCategory : REXToolboxObject;
Description
Namespace

REX.Controls.WPF Namespace

Public Methods
Public Method | Description
REXToolboxCategory | Initializes a new instance of the REXToolboxCategory class.
REXToolboxCategory Properties
REXToolboxCategory Properties | Description
Items | Gets or sets the items.
Links
REX.Controls.WPF Namespace, Legend, Members, Public Methods, REXToolboxCategory Properties

REXToolboxCategory.REXToolboxCategory Constructor

REXToolboxCategory.REXToolboxCategory Constructor
REXToolboxCategory Class REX.Controls.WPF Namespace REXToolboxCategory Class

Initializes a new instance of the REXToolboxCategory class.

C#
public REXToolboxCategory();
Description
Class

REXToolboxCategory Class

Links
REXToolboxCategory Class, REX.Controls.WPF Namespace, REXToolboxCategory Class

REXToolboxCategory.Items Property

REXToolboxCategory.Items Property
REXToolboxCategory Class REX.Controls.WPF Namespace REXToolboxCategory Class

Gets or sets the items.

C#
public REXToolboxItemsCollection Items;
Description

The items.

Class

REXToolboxCategory Class

Links
REXToolboxCategory Class, REX.Controls.WPF Namespace, REXToolboxCategory Class

REXToolboxCollection Class

REXToolboxCollection Class
REX.Controls.WPF Namespace Legend Members Public Methods

Base classes for REXToolboxs collections.

Class Hierarchy
C#
public class REXToolboxCollection<T_Item> : System.Collections.ObjectModel.ObservableCollection<T_Item>;
Description
Namespace

REX.Controls.WPF Namespace

Public Methods
Public Method | Description
REXToolboxCollection | Initializes a new instance of the REXToolboxCollection<T_Item> class.
Links
REX.Controls.WPF Namespace, Legend, Members, Public Methods

REXToolboxCollection.REXToolboxCollection Constructor

REXToolboxCollection.REXToolboxCollection Constructor
REXToolboxCollection Class REX.Controls.WPF Namespace REXToolboxCollection Class

Initializes a new instance of the REXToolboxCollection<T_Item> class.

C#
public REXToolboxCollection(REXToolbox toolbox);
Parameters
Parameters | Description
toolbox | The toolbox.
Description
Class

REXToolboxCollection Class

Links
REXToolboxCollection Class, REX.Controls.WPF Namespace, REXToolboxCollection Class

REXToolboxItem Class

REXToolboxItem Class
REX.Controls.WPF Namespace Legend Members Public Methods REXToolboxItem Properties

Represents the REXToolbox item.

Class Hierarchy
C#
public class REXToolboxItem : REXToolboxObject;
Description
Namespace

REX.Controls.WPF Namespace

Public Methods
Public Method | Description
REXToolboxItem | Initializes a new instance of the REXToolboxItem class.
REXToolboxItem Properties
REXToolboxItem Properties | Description
Image | Gets or sets the image.
Links
REX.Controls.WPF Namespace, Legend, Members, Public Methods, REXToolboxItem Properties

REXToolboxItem.REXToolboxItem Constructor

REXToolboxItem.REXToolboxItem Constructor
REXToolboxItem Class REX.Controls.WPF Namespace REXToolboxItem Class

Initializes a new instance of the REXToolboxItem class.

C#
public REXToolboxItem();
Description
Class

REXToolboxItem Class

Links
REXToolboxItem Class, REX.Controls.WPF Namespace, REXToolboxItem Class

REXToolboxItem.Image Property

REXToolboxItem.Image Property
REXToolboxItem Class REX.Controls.WPF Namespace REXToolboxItem Class

Gets or sets the image.

C#
public ImageSource Image;
Description

The image.

Class

REXToolboxItem Class

Links
REXToolboxItem Class, REX.Controls.WPF Namespace, REXToolboxItem Class

REXToolboxItemsCollection Class

REXToolboxItemsCollection Class
REX.Controls.WPF Namespace Legend Members Public Methods

Represents collection of items of the REXToolbox control.

Class Hierarchy
C#
public class REXToolboxItemsCollection : REXToolboxCollection<REXToolboxItem>;
Description
Namespace

REX.Controls.WPF Namespace

Public Methods
Public Method | Description
REXToolboxItemsCollection | Initializes a new instance of the REXToolboxItemsCollection class.
Links
REX.Controls.WPF Namespace, Legend, Members, Public Methods

REXToolboxItemsCollection.REXToolboxItemsCollection Constructor

REXToolboxItemsCollection.REXToolboxItemsCollection Constructor
REXToolboxItemsCollection Class REX.Controls.WPF Namespace REXToolboxItemsCollection Class

Initializes a new instance of the REXToolboxItemsCollection class.

C#
public REXToolboxItemsCollection(REXToolbox toolbox);
Parameters
Parameters | Description
toolbox | The toolbox.
Description
Class

REXToolboxItemsCollection Class

Links
REXToolboxItemsCollection Class, REX.Controls.WPF Namespace, REXToolboxItemsCollection Class

REXToolboxObject Class

REXToolboxObject Class
REX.Controls.WPF Namespace Legend Members Public Methods REXToolboxObject Properties

The base class for all toolbox objects (categories and items)

Class Hierarchy
C#
public class REXToolboxObject;
Namespace

REX.Controls.WPF Namespace

Public Methods
Public Method | Description
REXToolboxObject | Initializes a new instance of the REXToolboxObject class.
REXToolboxObject Properties
REXToolboxObject Properties | Description
Description | Gets or sets the description.
Name | Gets or sets the name.
Tag | Gets or sets the tag.
Links
REX.Controls.WPF Namespace, Legend, Members, Public Methods, REXToolboxObject Properties

REXToolboxObject.REXToolboxObject Constructor

REXToolboxObject.REXToolboxObject Constructor
REXToolboxObject Class REX.Controls.WPF Namespace REXToolboxObject Class

Initializes a new instance of the REXToolboxObject class.

C#
public REXToolboxObject();
Description
Class

REXToolboxObject Class

Links
REXToolboxObject Class, REX.Controls.WPF Namespace, REXToolboxObject Class

REXToolboxObject.Description Property

REXToolboxObject.Description Property
REXToolboxObject Class REX.Controls.WPF Namespace REXToolboxObject Class

Gets or sets the description.

C#
public string Description;
Description

The description.

Class

REXToolboxObject Class

Links
REXToolboxObject Class, REX.Controls.WPF Namespace, REXToolboxObject Class

REXToolboxObject.Name Property

REXToolboxObject.Name Property
REXToolboxObject Class REX.Controls.WPF Namespace REXToolboxObject Class

Gets or sets the name.

C#
public string Name;
Description

The name.

Class

REXToolboxObject Class

Links
REXToolboxObject Class, REX.Controls.WPF Namespace, REXToolboxObject Class