REXContentDialogSettings Class, REX.ContentGenerator.Dialog Namespace, REXContentDialogSettings Class

REXContentDialogSettings.MaterialSettings Property

REXContentDialogSettings.MaterialSettings Property
REXContentDialogSettings Class REX.ContentGenerator.Dialog Namespace REXContentDialogSettings Class

Gets the settings for the material category.

C#
public REXContentDialogCategorySettings MaterialSettings;
Description

The settings.

Class

REXContentDialogSettings Class

Links
REXContentDialogSettings Class, REX.ContentGenerator.Dialog Namespace, REXContentDialogSettings Class

REXContentDialogSettings.Progress Property

REXContentDialogSettings.Progress Property
REXContentDialogSettings Class REX.ContentGenerator.Dialog Namespace REXContentDialogSettings Class

Gets or sets a value indicating whether a progress bar should be visible.

C#
public bool Progress;
Description

True if the progress bar is visible; otherwise, false.

Class

REXContentDialogSettings Class

Links
REXContentDialogSettings Class, REX.ContentGenerator.Dialog Namespace, REXContentDialogSettings Class

REXContentDialogSettings.RebarShapeSettings Property

REXContentDialogSettings.RebarShapeSettings Property
REXContentDialogSettings Class REX.ContentGenerator.Dialog Namespace REXContentDialogSettings Class

Gets the settings for the rebar shape category.

C#
public REXContentDialogCategorySettings RebarShapeSettings;
Description

The settings.

Class

REXContentDialogSettings Class

Links
REXContentDialogSettings Class, REX.ContentGenerator.Dialog Namespace, REXContentDialogSettings Class

REXContentDialogSettings.RebarTypeSettings Property

REXContentDialogSettings.RebarTypeSettings Property
REXContentDialogSettings Class REX.ContentGenerator.Dialog Namespace REXContentDialogSettings Class

Gets the settings for the rebar type category.

C#
public REXContentDialogCategorySettings RebarTypeSettings;
Description

The settings.

Class

REXContentDialogSettings Class

Links
REXContentDialogSettings Class, REX.ContentGenerator.Dialog Namespace, REXContentDialogSettings Class

REXContentDialogSettings.RegionalSettings Property

REXContentDialogSettings.RegionalSettings Property
REXContentDialogSettings Class REX.ContentGenerator.Dialog Namespace REXContentDialogSettings Class

Gets or sets a value indicating whether regional settings are supported.

C#
public bool RegionalSettings;
Description

True if regional settings supported; otherwise, false.

Class

REXContentDialogSettings Class

Links
REXContentDialogSettings Class, REX.ContentGenerator.Dialog Namespace, REXContentDialogSettings Class

REXContentDialogSettings.SectionDBSettings Property

REXContentDialogSettings.SectionDBSettings Property
REXContentDialogSettings Class REX.ContentGenerator.Dialog Namespace REXContentDialogSettings Class

Gets the settings for the database section category..

C#
public REXContentDialogCategorySettings SectionDBSettings;
Description

The settings.

Class

REXContentDialogSettings Class

Links
REXContentDialogSettings Class, REX.ContentGenerator.Dialog Namespace, REXContentDialogSettings Class

REXContentDialogSettings.SectionParamSettings Property

REXContentDialogSettings.SectionParamSettings Property
REXContentDialogSettings Class REX.ContentGenerator.Dialog Namespace REXContentDialogSettings Class

Gets the settings for the parametric section category.

C#
public REXContentDialogCategorySettings SectionParamSettings;
Description

The settings.

Class

REXContentDialogSettings Class

Links
REXContentDialogSettings Class, REX.ContentGenerator.Dialog Namespace, REXContentDialogSettings Class

REXContentDialogSettings.ShowList Property

REXContentDialogSettings.ShowList Property
REXContentDialogSettings Class REX.ContentGenerator.Dialog Namespace REXContentDialogSettings Class

Gets or sets a value indicating whether the list of categories should be visible.

C#
public bool ShowList;
Description

True if the list is visible; otherwise, false.

Class

REXContentDialogSettings Class

Links
REXContentDialogSettings Class, REX.ContentGenerator.Dialog Namespace, REXContentDialogSettings Class

REXContentDialogSettings.ValidateTypes Property

REXContentDialogSettings.ValidateTypes Property
REXContentDialogSettings Class REX.ContentGenerator.Dialog Namespace REXContentDialogSettings Class

Gets or sets a value indicating whether types should be validated.

C#
public bool ValidateTypes;
Description

True if validate types; otherwise, false.

Class

REXContentDialogSettings Class

Links
REXContentDialogSettings Class, REX.ContentGenerator.Dialog Namespace, REXContentDialogSettings Class

REX.ContentGenerator.Dialog.EContentDialogMode Enumeration

REX.ContentGenerator.Dialog.EContentDialogMode Enumeration
REX.ContentGenerator.Dialog Namespace

Describes modes in which the ContentGenerator dialog may be run.

C#
public enum EContentDialogMode {
  Generator,
  Selection,
  MultiSelection
}
Members
Members | Description
Generator | Generation.
Selection | Single selection.
MultiSelection | Multiple selection.
Description
Namespace

REX.ContentGenerator.Dialog Namespace

Links
REX.ContentGenerator.Dialog Namespace
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REX.ContentGenerator.Families Namespace

Previous | Next
REX.ContentGenerator.Families Namespace
Legend Classes Structs, Records, Enums

This is namespace REX.ContentGenerator.Families.

Classes
Class | Description
REXCustomDescription | Base class for all custom description types.
REXDBDescription | Base class for all descriptions of objects in REXFamilyType which were created based on a database.
REXDescription | Base class for all descriptions of objects in REXFamilyType.
REXFamilyType | The base class for all content types supported by the REXContentGenerator.
REXFamilyType_Custom | Base class for all custom types.
REXFamilyType_DBSection | Represents a database section.
REXFamilyType_Label | Represents labels.
REXFamilyType_Material | Represents a material element.
REXFamilyType_ParamSection | Represents a parametric section.
REXFamilyType_Section | Base class for all sections.
REXLabelDescription | Represents label's parameters.
REXMaterialCharacteristics | Represents characteristics of a material.
REXMaterialDBDescription | Represents description of the material.
REXMaterialProperties | Represents properties of the material.
REXParamDescription | Base class for all descriptions of objects in REXFamilyType which were created based on a parametric description (not database).
REXSectionDBCharacteristics | Describes geometry characteristics of a database section.
REXSectionDBDescription | Represents parameters of the database section.
REXSectionDBDimensions | Describes dimensions of the database section.
REXSectionDBProperties | Describes properties of the database section.
REXSectionParamCharacteristics | Describes characteristics of the parametric section.
REXSectionParamDescription | Represents parameters of the parametric section.
REXSectionParamDimensions | Desribes dimentsions of the parametric section.
SerializableObject | Allows to save an object into a stream.
Structs, Records, Enums
Struct, Record, Enum | Description
ECategoryType | Describes the category of the element
EDBSectionType | Describes the type of the database section.
EElementType | Describes the type of the element
EMaterial | Describes the type of material
ESectionType |
Links
Legend, Classes, Structs, Records, Enums
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXCustomDescription Class

REXCustomDescription Class
REX.ContentGenerator.Families Namespace Legend Members Public Methods REXCustomDescription Methods