SetDataBaseValue | Set the value in base units.
SetDataInterfaceValue | Set the value in interface units.
SetInterfaceMaxValue | Set the maximum value defined in interface units.
SetInterfaceMinValue | Set the minimum value defined in interface units.
REXUnitEditBox Properties
REXUnitEditBox Properties | Description
ComplexDoubleValueBase | Gets or sets the complex double value.
DoubleValueBase | Gets or sets the double value.
Power | Gets or sets the power of the unit.
UnitEngine | Gets or sets the unit engine.
UnitType | Gets or sets the type of the unit.
Links
REX.Controls.WPF Namespace, Legend, Members, Public Methods, REXUnitEditBox Fields, REXUnitEditBox Methods, REXUnitEditBox Properties

REXUnitEditBox.REXUnitEditBox Constructor

REXUnitEditBox.REXUnitEditBox Constructor
REXUnitEditBox Class REX.Controls.WPF Namespace REXUnitEditBox Class

This is REXUnitEditBox, a member of class REXUnitEditBox.

C#
public REXUnitEditBox();
Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.WPF Namespace, REXUnitEditBox Class

REXUnitEditBox.ComplexDoubleValueBaseProperty Field

REXUnitEditBox.ComplexDoubleValueBaseProperty Field
REXUnitEditBox Class REX.Controls.WPF Namespace REXUnitEditBox Class

This is ComplexDoubleValueBaseProperty, a member of class REXUnitEditBox.

C#
public static readonly DependencyProperty ComplexDoubleValueBaseProperty;
Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.WPF Namespace, REXUnitEditBox Class

REXUnitEditBox.DoubleValueBaseProperty Field

REXUnitEditBox.DoubleValueBaseProperty Field
REXUnitEditBox Class REX.Controls.WPF Namespace REXUnitEditBox Class

This is DoubleValueBaseProperty, a member of class REXUnitEditBox.

C#
public static readonly DependencyProperty DoubleValueBaseProperty;
Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.WPF Namespace, REXUnitEditBox Class

REXUnitEditBox.PowerProperty Field

REXUnitEditBox.PowerProperty Field
REXUnitEditBox Class REX.Controls.WPF Namespace REXUnitEditBox Class

This is PowerProperty, a member of class REXUnitEditBox.

C#
public static readonly DependencyProperty PowerProperty;
Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.WPF Namespace, REXUnitEditBox Class

REXUnitEditBox.UnitTypeProperty Field

REXUnitEditBox.UnitTypeProperty Field
REXUnitEditBox Class REX.Controls.WPF Namespace REXUnitEditBox Class

This is UnitTypeProperty, a member of class REXUnitEditBox.

C#
public static readonly DependencyProperty UnitTypeProperty;
Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.WPF Namespace, REXUnitEditBox Class

REXUnitEditBox.GetBaseMaxValue Method

REXUnitEditBox.GetBaseMaxValue Method
REXUnitEditBox Class REX.Controls.WPF Namespace REXUnitEditBox Class

Gets the maximum value and converts it to base units.

C#
public double GetBaseMaxValue();
Returns

The value.

Description
Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.WPF Namespace, REXUnitEditBox Class

REXUnitEditBox.GetBaseMinValue Method

REXUnitEditBox.GetBaseMinValue Method
REXUnitEditBox Class REX.Controls.WPF Namespace REXUnitEditBox Class

Gets the minimum value and converts it to base units.

C#
public double GetBaseMinValue();
Returns

The value.

Description
Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.WPF Namespace, REXUnitEditBox Class

REXUnitEditBox.GetComplexDataBaseValue Method

REXUnitEditBox.GetComplexDataBaseValue Method
REXUnitEditBox Class REX.Controls.WPF Namespace REXUnitEditBox Class

Get the values and convert it to base units.

C#
public List<double> GetComplexDataBaseValue();
Returns

The list of values.

Description
Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.WPF Namespace, REXUnitEditBox Class

REXUnitEditBox.GetComplexDataInterfaceValue Method

REXUnitEditBox.GetComplexDataInterfaceValue Method
REXUnitEditBox Class REX.Controls.WPF Namespace REXUnitEditBox Class

Get the values and convert it to interface units.

C#
public List<double> GetComplexDataInterfaceValue(REXInterfaceType interfaceType);
Parameters
Parameters | Description
interfaceType | The product context.
Returns

The list of values.

Description
Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.WPF Namespace, REXUnitEditBox Class

REXUnitEditBox.GetDataBaseValue Method

REXUnitEditBox.GetDataBaseValue Method
REXUnitEditBox Class REX.Controls.WPF Namespace REXUnitEditBox Class

Gets the value and converts it to base units.

C#
public double GetDataBaseValue();
Returns

The value.

Description
Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.WPF Namespace, REXUnitEditBox Class

REXUnitEditBox.GetDataInterfaceValue Method

REXUnitEditBox.GetDataInterfaceValue Method
REXUnitEditBox Class REX.Controls.WPF Namespace REXUnitEditBox Class

Gets the value and converts it to interface units.

C#
public double GetDataInterfaceValue(REXInterfaceType interfaceType);
Parameters
Parameters | Description
interfaceType | The product context.
Returns

The value.

Description
Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.WPF Namespace, REXUnitEditBox Class

REXUnitEditBox.GetInterfaceMaxValue Method

REXUnitEditBox.GetInterfaceMaxValue Method
REXUnitEditBox Class REX.Controls.WPF Namespace REXUnitEditBox Class

Gets the maximum value and converts it to interface units.

C#
public double GetInterfaceMaxValue(REXInterfaceType interfaceType);
Parameters
Parameters | Description
interfaceType | The product context.
Returns

The value.

Description
Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.WPF Namespace, REXUnitEditBox Class

REXUnitEditBox.GetInterfaceMinValue Method

REXUnitEditBox.GetInterfaceMinValue Method
REXUnitEditBox Class REX.Controls.WPF Namespace REXUnitEditBox Class

Gets the minimum value and converts it to interface units.

C#
public double GetInterfaceMinValue(REXInterfaceType interfaceType);
Parameters
Parameters | Description
interfaceType | The product context.
Returns

The value.

Description
Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.WPF Namespace, REXUnitEditBox Class

REXUnitEditBox.SetBaseMaxValue Method

REXUnitEditBox.SetBaseMaxValue Method
REXUnitEditBox Class REX.Controls.WPF Namespace REXUnitEditBox Class

Set the maximum value defined in base units.

C#
public void SetBaseMaxValue(double value);
Parameters
Parameters | Description
value | The value.
Description
Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.WPF Namespace, REXUnitEditBox Class

REXUnitEditBox.SetBaseMinValue Method

REXUnitEditBox.SetBaseMinValue Method
REXUnitEditBox Class REX.Controls.WPF Namespace REXUnitEditBox Class

Set the minimum value defined in base units.

C#
public void SetBaseMinValue(double value);
Parameters
Parameters | Description
value | The value.
Description
Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.WPF Namespace, REXUnitEditBox Class

REXUnitEditBox.SetComplexDataBaseValue Method

REXUnitEditBox.SetComplexDataBaseValue Method
REXUnitEditBox Class REX.Controls.WPF Namespace REXUnitEditBox Class

Set the list of values defined in base units.

C#
public void SetComplexDataBaseValue(List<double> values);
Parameters
Parameters | Description
values | The values.
Description
Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.WPF Namespace, REXUnitEditBox Class

REXUnitEditBox.SetComplexDataInterfaceValue Method

REXUnitEditBox.SetComplexDataInterfaceValue Method
REXUnitEditBox Class REX.Controls.WPF Namespace REXUnitEditBox Class

Set the list of values defined in interface units.

C#
public void SetComplexDataInterfaceValue(List<double> values, REXInterfaceType interfaceType);
Parameters
Parameters | Description
values | The values.
interfaceType | The product context.
Description
Class

REXUnitEditBox Class

Links