Class

REXContentMapCategorySettings Class

Links
REXContentMapCategorySettings Class, REX.ContentGenerator.Map Namespace, REXContentMapCategorySettings Class

REXContentMapCategorySettings.DatabasesResult Property

REXContentMapCategorySettings.DatabasesResult Property
REXContentMapCategorySettings Class REX.ContentGenerator.Map Namespace REXContentMapCategorySettings Class

Gets or sets the list of databases which were finally choosen by the user in the dialog.

C#
public List<string> DatabasesResult;
Description

The list of databases.

Class

REXContentMapCategorySettings Class

Links
REXContentMapCategorySettings Class, REX.ContentGenerator.Map Namespace, REXContentMapCategorySettings Class

REXContentMapCategorySettings.Elements Property

REXContentMapCategorySettings.Elements Property
REXContentMapCategorySettings Class REX.ContentGenerator.Map Namespace REXContentMapCategorySettings Class

Gets the list of elements which should be mapped.

C#
public List<object> Elements;
Description

The list of elements.

Class

REXContentMapCategorySettings Class

Links
REXContentMapCategorySettings Class, REX.ContentGenerator.Map Namespace, REXContentMapCategorySettings Class

REXContentMapCategorySettings.LabelCategoryName Property

REXContentMapCategorySettings.LabelCategoryName Property
REXContentMapCategorySettings Class REX.ContentGenerator.Map Namespace REXContentMapCategorySettings Class

Gets or sets the name of the label category.

C#
public string LabelCategoryName;
Description

The name of the label category.

Class

REXContentMapCategorySettings Class

Links
REXContentMapCategorySettings Class, REX.ContentGenerator.Map Namespace, REXContentMapCategorySettings Class

REXContentMapCategorySettings.Labels Property

REXContentMapCategorySettings.Labels Property
REXContentMapCategorySettings Class REX.ContentGenerator.Map Namespace REXContentMapCategorySettings Class

Gets the list of labels.

C#
public List<REXFamilyType_Label> Labels;
Description

The list of labels.

Class

REXContentMapCategorySettings Class

Links
REXContentMapCategorySettings Class, REX.ContentGenerator.Map Namespace, REXContentMapCategorySettings Class

REXContentMapCategorySettings.MapCertifiedFamilies Property

REXContentMapCategorySettings.MapCertifiedFamilies Property
REXContentMapCategorySettings Class REX.ContentGenerator.Map Namespace REXContentMapCategorySettings Class

Gets or sets a value indicating whether certified families are mapped.

C#
public bool MapCertifiedFamilies;
Description

True if certified families are mapped; otherwise, false.

Class

REXContentMapCategorySettings Class

Links
REXContentMapCategorySettings Class, REX.ContentGenerator.Map Namespace, REXContentMapCategorySettings Class

REXContentMapCategorySettings.SetDefaultsForUnknown Property

REXContentMapCategorySettings.SetDefaultsForUnknown Property
REXContentMapCategorySettings Class REX.ContentGenerator.Map Namespace REXContentMapCategorySettings Class

Gets or sets a value indicating whether defaults are set for elements which weren't mapped.

C#
public bool SetDefaultsForUnknown;
Description

True if unknown elements are mapped automatically; otherwise, false.

Class

REXContentMapCategorySettings Class

Links
REXContentMapCategorySettings Class, REX.ContentGenerator.Map Namespace, REXContentMapCategorySettings Class

REXContentMapCategorySettings.Settings Property

REXContentMapCategorySettings.Settings Property
REXContentMapCategorySettings Class REX.ContentGenerator.Map Namespace REXContentMapCategorySettings Class

Gets the settings of the dialog.

C#
public REXContentMapDialogSettings Settings;
Description

Settings.

Class

REXContentMapCategorySettings Class

Links
REXContentMapCategorySettings Class, REX.ContentGenerator.Map Namespace, REXContentMapCategorySettings Class

REXContentMapCategorySettings.Visible Property

REXContentMapCategorySettings.Visible Property
REXContentMapCategorySettings Class REX.ContentGenerator.Map Namespace REXContentMapCategorySettings Class

Gets or sets a value indicating whether this category is visible.

C#
public bool Visible;
Description

True if the category is visible; otherwise, false.

Class

REXContentMapCategorySettings Class

Links
REXContentMapCategorySettings Class, REX.ContentGenerator.Map Namespace, REXContentMapCategorySettings Class

REXContentMapDialogSettings Class

REXContentMapDialogSettings Class
REX.ContentGenerator.Map Namespace Legend Members Public Methods REXContentMapDialogSettings Methods REXContentMapDialogSettings Properties

Represents settings for the map dialog.

Class Hierarchy
C#
public class REXContentMapDialogSettings;
Description
Namespace

REX.ContentGenerator.Map Namespace

Public Methods
Public Method | Description
REXContentMapDialogSettings | Initializes a new instance of the REXContentMapDialogSettings class.
REXContentMapDialogSettings Methods
REXContentMapDialogSettings Methods | Description
GetSettings | Gets settings of the specific type.
REXContentMapDialogSettings Properties
REXContentMapDialogSettings Properties | Description
CheckIfAllMappedBeforeLeave | Gets or sets a value indicating whether dialog should be validated before leaving.
List | Gets or sets a value indicating whether the list should be visible on the dialog.
Mapper | Gets the mapper.
MaterialSettings | Gets the material settings.
Menu | Gets or sets a value indicating whether menu should be visible on the dialog.
NotAllMappedText | Gets or sets the text which should appear when validation didn't succeed (if CheckIfAllMappedBeforeLeave option).
RebarTypeSettings | Gets the rebar type settings.
SectionSettings | Gets the section settings.
ShowWhenNoElementsToMap | Gets or sets a value indicating whether dialog should appear when there are no elements to map.
Links
REX.ContentGenerator.Map Namespace, Legend, Members, Public Methods, REXContentMapDialogSettings Methods, REXContentMapDialogSettings Properties

REXContentMapDialogSettings.REXContentMapDialogSettings Constructor

REXContentMapDialogSettings.REXContentMapDialogSettings Constructor
REXContentMapDialogSettings Class REX.ContentGenerator.Map Namespace REXContentMapDialogSettings Class

Initializes a new instance of the REXContentMapDialogSettings class.

C#
public REXContentMapDialogSettings(ContentMapper mapper);
Parameters
Parameters | Description
mapper | The mapper.
Description
Class

REXContentMapDialogSettings Class

Links
REXContentMapDialogSettings Class, REX.ContentGenerator.Map Namespace, REXContentMapDialogSettings Class

REXContentMapDialogSettings.GetSettings Method

REXContentMapDialogSettings.GetSettings Method
REXContentMapDialogSettings Class REX.ContentGenerator.Map Namespace REXContentMapDialogSettings Class

Gets settings of the specific type.

C#
public REXContentMapCategorySettings GetSettings(ECategoryType category);
Parameters
Parameters | Description
category | The category.
Returns

The settings.

Description
Class

REXContentMapDialogSettings Class

Links
REXContentMapDialogSettings Class, REX.ContentGenerator.Map Namespace, REXContentMapDialogSettings Class

REXContentMapDialogSettings.CheckIfAllMappedBeforeLeave Property

REXContentMapDialogSettings.CheckIfAllMappedBeforeLeave Property
REXContentMapDialogSettings Class REX.ContentGenerator.Map Namespace REXContentMapDialogSettings Class

Gets or sets a value indicating whether dialog should be validated before leaving.

C#
public bool CheckIfAllMappedBeforeLeave;
Description

True if the dialog is validated when before leaving; otherwise, false.

Class

REXContentMapDialogSettings Class

Links
REXContentMapDialogSettings Class, REX.ContentGenerator.Map Namespace, REXContentMapDialogSettings Class

REXContentMapDialogSettings.List Property

REXContentMapDialogSettings.List Property
REXContentMapDialogSettings Class REX.ContentGenerator.Map Namespace REXContentMapDialogSettings Class

Gets or sets a value indicating whether the list should be visible on the dialog.

C#