REXExtensionProduct Class

Links
REXExtensionProduct Class, REX.Common Namespace, REXExtensionProduct Class

REXExtensionProduct.OnCommand Method

REXExtensionProduct.OnCommand Method
REXExtensionProduct Class REX.Common Namespace REXExtensionProduct Class

Commands the specified command struct.

C#
public virtual object OnCommand(ref REXCommand CommandStruct);
Parameters
Parameters | Description
CommandStruct | The command struct.
Returns

Returns result of event operation.

Description
Class

REXExtensionProduct Class

Links
REXExtensionProduct Class, REX.Common Namespace, REXExtensionProduct Class

REXExtensionProduct.OnCreate Method

REXExtensionProduct.OnCreate Method
REXExtensionProduct Class REX.Common Namespace REXExtensionProduct Class

Creates needed structures and verify needs.

C#
public virtual void OnCreate();
Description
Class

REXExtensionProduct Class

Links
REXExtensionProduct Class, REX.Common Namespace, REXExtensionProduct Class

REXExtensionProduct.OnCreateDialogs Method

REXExtensionProduct.OnCreateDialogs Method
REXExtensionProduct Class REX.Common Namespace REXExtensionProduct Class

Creates sub dialogs.

C#
public virtual void OnCreateDialogs();
Description
Class

REXExtensionProduct Class

Links
REXExtensionProduct Class, REX.Common Namespace, REXExtensionProduct Class

REXExtensionProduct.OnCreateLayout Method

REXExtensionProduct.OnCreateLayout Method
REXExtensionProduct Class REX.Common Namespace REXExtensionProduct Class

Creates layout items and setups layout.

C#
public virtual void OnCreateLayout();
Description
Class

REXExtensionProduct Class

Links
REXExtensionProduct Class, REX.Common Namespace, REXExtensionProduct Class

REXExtensionProduct.OnDataLoad Method

REXExtensionProduct.OnDataLoad Method
REXExtensionProduct Class REX.Common Namespace REXExtensionProduct Class

Called when data are loaded.

C#
public virtual bool OnDataLoad();
Returns

Returns true if succeeded.

Description
Class

REXExtensionProduct Class

Links
REXExtensionProduct Class, REX.Common Namespace, REXExtensionProduct Class

REXExtensionProduct.OnDataLoaded Method

REXExtensionProduct.OnDataLoaded Method
REXExtensionProduct Class REX.Common Namespace REXExtensionProduct Class

Called when data loaded.

C#
public virtual void OnDataLoaded(bool Result);
Parameters
Parameters | Description
Result | If set to true operation succeeded; Otherwise some errors found.
Description
Class

REXExtensionProduct Class

Links
REXExtensionProduct Class, REX.Common Namespace, REXExtensionProduct Class

REXExtensionProduct.OnDataSave Method

REXExtensionProduct.OnDataSave Method
REXExtensionProduct Class REX.Common Namespace REXExtensionProduct Class

Called when data are saved.

C#
public virtual bool OnDataSave();
Returns

Returns true if succeeded.

Description
Class

REXExtensionProduct Class

Links
REXExtensionProduct Class, REX.Common Namespace, REXExtensionProduct Class

REXExtensionProduct.OnDataSaved Method

REXExtensionProduct.OnDataSaved Method
REXExtensionProduct Class REX.Common Namespace REXExtensionProduct Class

Called when data are saved.

C#
public virtual void OnDataSaved(bool Result);
Parameters
Parameters | Description
Result | If set to true operation succeeded; Otherwise some errors found.
Description
Class

REXExtensionProduct Class

Links
REXExtensionProduct Class, REX.Common Namespace, REXExtensionProduct Class

REXExtensionProduct.OnErrorSelected Method

REXExtensionProduct.OnErrorSelected Method
REXExtensionProduct Class REX.Common Namespace REXExtensionProduct Class

Called when an error is selected on errors list dialog.

C#
public virtual void OnErrorSelected(Autodesk.REX.Framework.REXErrorsEventArgs e);
Parameters
Parameters | Description
e | The Autodesk.REX.Framework.REXErrorsEventArgs instance containing the event data.
Description

Raises the ErrorSelected event.

Class

REXExtensionProduct Class

Links
REXExtensionProduct Class, REX.Common Namespace, REXExtensionProduct Class

REXExtensionProduct.OnEvent Method

REXExtensionProduct.OnEvent Method
REXExtensionProduct Class REX.Common Namespace REXExtensionProduct Class

Called when event.

C#
public virtual object OnEvent(ref REXEvent EventStruct);
Parameters
Parameters | Description
EventStruct | The event struct.
Returns

Returns result of event operation.

Description
Class

REXExtensionProduct Class

Links
REXExtensionProduct Class, REX.Common Namespace, REXExtensionProduct Class

REXExtensionProduct.OnGetText Method

REXExtensionProduct.OnGetText Method
REXExtensionProduct Class REX.Common Namespace REXExtensionProduct Class

Get specified text from resources.

C#
public virtual string OnGetText(string Name);
Parameters
Parameters | Description
Name | The name of string.
Returns

Returns specified text.

Description

Needed for obfuscated strings tables.

Class

REXExtensionProduct Class

Links
REXExtensionProduct Class, REX.Common Namespace, REXExtensionProduct Class

REXExtensionProduct.OnInitialize Method

REXExtensionProduct.OnInitialize Method
REXExtensionProduct Class REX.Common Namespace REXExtensionProduct Class

Called when Initialize.

C#
public virtual bool OnInitialize();
Description

Creates dedicated extension class according main context.

Class

REXExtensionProduct Class

Links
REXExtensionProduct Class, REX.Common Namespace, REXExtensionProduct Class

REXExtensionProduct.OnLoadTemplate Method

REXExtensionProduct.OnLoadTemplate Method
REXExtensionProduct Class REX.Common Namespace REXExtensionProduct Class

Called when template is loaded.

C#
public virtual bool OnLoadTemplate();
Parameters
Parameters | Description
Result | If set to true operation succeeded; Otherwise some errors found.
Description

Only if ExtensionContext.Control.StandardRunContext is equals to REXExtensionContext.REXStandardRunContext.OperationEditTemplate.

Class

REXExtensionProduct Class

Links
REXExtensionProduct Class, REX.Common Namespace, REXExtensionProduct Class

REXExtensionProduct.OnPreferencesChanged Method

REXExtensionProduct.OnPreferencesChanged Method
REXExtensionProduct Class REX.Common Namespace REXExtensionProduct Class

Called when preferences changed.

C#
public virtual void OnPreferencesChanged();
Description
Class

REXExtensionProduct Class

Links
REXExtensionProduct Class, REX.Common Namespace, REXExtensionProduct Class

REXExtensionProduct.OnRun Method

REXExtensionProduct.OnRun Method
REXExtensionProduct Class REX.Common Namespace REXExtensionProduct Class

Runs process calculations or other operations.

C#
public virtual void OnRun();
Description
Class

REXExtensionProduct Class

Links
REXExtensionProduct Class, REX.Common Namespace, REXExtensionProduct Class

REXExtensionProduct.OnSaveTemplate Method

REXExtensionProduct.OnSaveTemplate Method
REXExtensionProduct Class REX.Common Namespace REXExtensionProduct Class

Called when template is saved.

C#
public virtual bool OnSaveTemplate();
Parameters
Parameters | Description
Result | If set to true operation succeeded; Otherwise some errors found.
Description
Class

REXExtensionProduct Class

Links
REXExtensionProduct Class, REX.Common Namespace, REXExtensionProduct Class

REXExtensionProduct.OnSetData Method

REXExtensionProduct.OnSetData Method
REXExtensionProduct Class REX.Common Namespace REXExtensionProduct Class

Get data from dialogs and sets Data's strucutres.

C#
public virtual void OnSetData();
Description
Class

REXExtensionProduct Class

Links
REXExtensionProduct Class, REX.Common Namespace, REXExtensionProduct Class

REXExtensionProduct.OnSetDialogs Method

REXExtensionProduct.OnSetDialogs Method
REXExtensionProduct Class REX.Common Namespace REXExtensionProduct Class

Set data on dialogs.

C#
public virtual void OnSetDialogs();
Description
Class

REXExtensionProduct Class

Links
REXExtensionProduct Class, REX.Common Namespace, REXExtensionProduct Class

REXExtensionProduct.OnShowResults Method

REXExtensionProduct.OnShowResults Method