Gets the list of database's records adequate for the list of input objects.

C#
public List<REXDBDescription> GetDBList(List<REXFamilyType> list, string dir, ECategoryType type);
Parameters
Parameters | Description
list | The list.
dir | The directory.
type | The category of the element.
Returns

Returns the list of database's records.

Description
Example

The example shows how to get a list of records which exist in databases from specific directory which fit to at least one specific element.

//Initializing the rex converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Definition of elements. In the current example they are created as empty families with alias names but they can be taken from different sources (e.g. Revit).        ///
REXFamilyType fam1 = rex.GetEmptyFamilyOfAlias(REX.ContentGenerator.Families.EElementType.BEAM, "HEB 100", ECategoryType.SECTION_DB);
REXFamilyType fam2 = rex.GetEmptyFamilyOfAlias(REX.ContentGenerator.Families.EElementType.BEAM, "HEA 200", ECategoryType.SECTION_DB);
List<REXFamilyType> families = new List<REXFamilyType>() { fam1, fam2 };

//Database identification data.
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Prof";

//Getting the list of databases
List<REXDBDescription> dbList = rex.GetDBList(families, directory, ECategoryType.SECTION_DB);
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, REXFamilyConverter Class

REXFamilyConverter.GetDBList Method (REXFamilyType, ECategoryType)

REXFamilyConverter.GetDBList Method (REXFamilyType, ECategoryType)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace Example REXFamilyConverter Class

Gets the list of database's records adequate for the input object.

C#
public List<REXDBDescription> GetDBList(REXFamilyType obj, ECategoryType type);
Parameters
Parameters | Description
obj | The REXFamilyType object (should be dedicated for the specific category).
type | The category of the element.
Returns

Returns the list of database's records.

Description
Example

The example shows how to get a list of records which exist in databases of the specific directory and fit to the specific element.

//Initializing the rex converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Definition of the element. In the current example it is created as the empty family with the alias name but it can be taken from different sources (e.g. Revit).
REXFamilyType fam = rex.GetEmptyFamilyOfAlias(REX.ContentGenerator.Families.EElementType.BEAM, "HEB 100", ECategoryType.SECTION_DB);

//Getting the list of databases
List<REXDBDescription> dbList = rex.GetDBList(fam,ECategoryType.SECTION_DB);
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, REXFamilyConverter Class

REXFamilyConverter.GetDBList Method (REXFamilyType, ECategoryType, List<string>)

REXFamilyConverter.GetDBList Method (REXFamilyType, ECategoryType, List<string>)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace Example REXFamilyConverter Class

Gets the list of database's records adequate for the input object.

C#
public List<REXDBDescription> GetDBList(REXFamilyType obj, ECategoryType type, List<string> directories);
Parameters
Parameters | Description
obj | The REXFamilyType object (should be dedicated for the specific category).
type | The category of the element.
directories | The list of directories.
Returns

Returns the list of database's records.

Description
Example

The example shows how to get a list of records which exist in databases of the specific directory and fit to the specific element.

//Initializing the rex converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Definition of the element. In the current example it is created as the empty family with the alias name but it can be taken from different sources (e.g. Revit).
REXFamilyType fam = rex.GetEmptyFamilyOfAlias(REX.ContentGenerator.Families.EElementType.BEAM, "HEB 100", ECategoryType.SECTION_DB);

//Database identification data.
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Prof";

//Getting the list of databases
List<REXDBDescription> dbList = rex.GetDBList(fam, ECategoryType.SECTION_DB,new List<string>(){directory});
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, REXFamilyConverter Class

REXFamilyConverter.GetDBList Method (REXFamilyType, ECategoryType, string, string)

REXFamilyConverter.GetDBList Method (REXFamilyType, ECategoryType, string, string)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace Example REXFamilyConverter Class

Gets the list of database's records adequate for the input object.

C#
public List<REXDBDescription> GetDBList(REXFamilyType obj, ECategoryType type, string directory1, string directory2);
Parameters
Parameters | Description
obj | The REXFamilyType object (should be dedicated for the specific category).
type | The category of the element.
directory1 | The first directory.
directory2 | The second directory.
Returns

Returns the list of database's records.

Description
Example

The example shows how to get a list of records which exist in databases of the specific directory and fit to the specific element.

//Initializing the rex converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Definition of the element. In the current example it is created as the empty family with the alias name but it can be taken from different sources (e.g. Revit).
REXFamilyType fam = rex.GetEmptyFamilyOfAlias(REX.ContentGenerator.Families.EElementType.BEAM, "HEB 100", ECategoryType.SECTION_DB);

//Database identification data.
string directory1 = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Prof";
string directory1 = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2012\Data\Prof";

//Getting the list of databases
List<REXDBDescription> dbList = rex.GetDBList(fam, ECategoryType.SECTION_DB,directory1,directory2);
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, REXFamilyConverter Class

REXFamilyConverter.GetDBList Method (REXFamilyType, List<string>, string, ECategoryType)

REXFamilyConverter.GetDBList Method (REXFamilyType, List<string>, string, ECategoryType)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace Example REXFamilyConverter Class

Gets the list of database's records adequate for the input object.

C#
public List<REXDBDescription> GetDBList(REXFamilyType obj, List<string> dbNames, string dir, ECategoryType type);
Parameters
Parameters | Description
obj | The REXFamilyType object (should be dedicated for the specific category).
dbNames | The list of databases.
dir | The directory.
type | The category of the element.
Returns

Returns the list of database's records.

Description
Example

The example shows how to get a list of records which exist in databases defined in the input list and fit to the specific element.

//Initializing the rex converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Definition of the element. In the current example it is created as the empty family with the alias name but it can be taken from different sources (e.g. Revit).
REXFamilyType fam = rex.GetEmptyFamilyOfAlias(REX.ContentGenerator.Families.EElementType.BEAM, "HEB 100", ECategoryType.SECTION_DB);

//Database identification data.
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Prof";
List<string> databases = new List<string>() { "Otuapro", "CorusPro", "Aiscpro" };

//Getting the list of databases