REXSectionTypeAnalyzer_RECT | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_RECT.
REXSectionTypeAnalyzer_RECTHOLLOW | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_RECTHOLLOW.
REXSectionTypeAnalyzer_ROUND | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_ROUND.
REXSectionTypeAnalyzer_ROUNDH | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_ROUNDH.
REXSectionTypeAnalyzer_ROUNDQ | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_ROUNDQ.
REXSectionTypeAnalyzer_T | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_T.
REXSectionTypeAnalyzer_TASYM | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_TASYM.
REXSectionTypeAnalyzer_TUBE | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_TUBE.
REXSectionTypeAnalyzer_Z | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_Z.

Legend

Legend
REX.ContentGenerator.Geometry Namespace
Legend
Class
abstract
Enumeration
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REX.ContentGenerator.Geometry Namespace Structs, Records, Enums

REX.ContentGenerator.Geometry Namespace Structs, Records, Enums
REX.ContentGenerator.Geometry Namespace Legend
Structs, Records, Enums
Struct, Record, Enum | Description
EArcDir | Describes the direction of an arc.
EContElemType | Represents the type of the element.
ECoords | Describes the coordinate system type.

Legend

Legend
Contour_3D Class
Legend
Constructor
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

Contour_3D Class Members

Contour_3D Class Members
Contour_3D Class Legend
Members
Public Methods
Public Method | Description
Contour_3D | Initializes a new instance of the Contour_3D class.
Contour_3D | Initializes a new instance of the Contour_3D class.
Contour_3D | Initializes a new instance of the Contour_3D class.
Contour_3D Methods
Contour_3D Methods | Description
ArcTo | Defines an arc.
LineTo | Defines a line to the specific point.
LineTo | Defines a line to the specific point.
Reverse | Reverses elements.
StartContour | Starts the defintion of the contour.

Contour_3D Methods

Contour_3D Methods
Contour_3D Class Legend
Contour_3D Methods
Contour_3D Methods | Description
ArcTo | Defines an arc.
LineTo | Defines a line to the specific point.
LineTo | Defines a line to the specific point.
Reverse | Reverses elements.
StartContour | Starts the defintion of the contour.

Contour_3D Class Public Methods

Contour_3D Class Public Methods
Contour_3D Class Legend
Public Methods
Public Method | Description
Contour_3D | Initializes a new instance of the Contour_3D class.
Contour_3D | Initializes a new instance of the Contour_3D class.
Contour_3D | Initializes a new instance of the Contour_3D class.

Legend

Legend
Contour_Compound2D Class
Legend
Constructor
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

Contour_Compound2D Class Members

Contour_Compound2D Class Members
Contour_Compound2D Class Legend
Members
Public Methods
Public Method | Description
Contour_Compound2D | Initializes a new instance of the Contour_Compound2D class.
Contour_Compound2D | Initializes a new instance of the Contour_Compound2D class.
Contour_Compound2D | Initializes a new instance of the Contour_Compound2D class.
Contour_Compound2D | Initializes a new instance of the Contour_Compound2D class.
Contour_Compound2D Methods
Contour_Compound2D Methods | Description
ArcTo | Defines an arc.
ArcTo | Defines an arc.
AxisLine | Defines an axis line.
Circle | Defines a circle.
Dimension | Defines a dimension.
DimensionLine | Defines a dimension line.
DimensionLine | Defines a dimension line.
DimensionRadius | Defines a radial dimension.
GetBoundingBox | Gets the bounding box.
GetGeometryParams | Gets the geometry params.
GetPoint | Gets the point in the specified plane.
LineTo | Defines a line to the specified point.
LineTo | Defines a line to the specified point.
LineToX | Defines a line to the specified point (parallel to X axis).
LineToY | Defines a line to the specified point (parallel to Y axis).
LoadFromString | Loads the contour from the string.
MultiplyLengthDim | Multiplies all length dimensions by the input coefficient.
SaveToString | Saves the contour to the string.
StartContour | Starts the definition of the contour.
StartContour | Starts the definition of the contour.
StartContour | Starts the definition of the contour.
Translate | Applies the specified translation vector to all elements.
Contour_Compound2D Properties
Contour_Compound2D Properties | Description
Axis | Gets or sets the list of axis.
Dimensions | Gets or sets the list of dimensions.
Shape | Gets or sets the list of shapes.

Contour_Compound2D Methods

Contour_Compound2D Methods
Contour_Compound2D Class Legend
Contour_Compound2D Methods
Contour_Compound2D Methods | Description
ArcTo | Defines an arc.
ArcTo | Defines an arc.
AxisLine | Defines an axis line.
Circle | Defines a circle.
Dimension | Defines a dimension.
DimensionLine | Defines a dimension line.
DimensionLine | Defines a dimension line.
DimensionRadius | Defines a radial dimension.
GetBoundingBox | Gets the bounding box.
GetGeometryParams | Gets the geometry params.
GetPoint | Gets the point in the specified plane.
LineTo | Defines a line to the specified point.
LineTo | Defines a line to the specified point.
LineToX | Defines a line to the specified point (parallel to X axis).
LineToY | Defines a line to the specified point (parallel to Y axis).
LoadFromString | Loads the contour from the string.
MultiplyLengthDim | Multiplies all length dimensions by the input coefficient.
SaveToString | Saves the contour to the string.
StartContour | Starts the definition of the contour.
StartContour | Starts the definition of the contour.
StartContour | Starts the definition of the contour.
Translate | Applies the specified translation vector to all elements.

Contour_Compound2D Properties

Contour_Compound2D Properties
Contour_Compound2D Class Legend
Contour_Compound2D Properties
Contour_Compound2D Properties | Description
Axis | Gets or sets the list of axis.
Dimensions | Gets or sets the list of dimensions.
Shape | Gets or sets the list of shapes.

Contour_Compound2D Class Public Methods

Contour_Compound2D Class Public Methods
Contour_Compound2D Class Legend
Public Methods
Public Method | Description
Contour_Compound2D | Initializes a new instance of the Contour_Compound2D class.
Contour_Compound2D | Initializes a new instance of the Contour_Compound2D class.
Contour_Compound2D | Initializes a new instance of the Contour_Compound2D class.
Contour_Compound2D | Initializes a new instance of the Contour_Compound2D class.

Legend

Legend
Contour_Section Class
Legend
Constructor
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

Contour_Section Class Members

Contour_Section Class Members
Contour_Section Class Legend
Members
Public Methods
Public Method | Description
Contour_Section | Initializes a new instance of the Contour_Section class.
Contour_Section | Initializes a new instance of the Contour_Section class.
Contour_Section | Initializes a new instance of the Contour_Section class.

Contour_Section Class Public Methods

Contour_Section Class Public Methods
Contour_Section Class Legend
Public Methods
Public Method | Description