REXAccess.Interfaces Property

REXAccess.Interfaces Property
REXAccess Class REX.Common Namespace REXAccess Class

This is Interfaces, a member of class REXAccess.

C#
public Dictionary<string, IREXExtensionAccess> Interfaces;
Class

REXAccess Class

Links
REXAccess Class, REX.Common Namespace, REXAccess Class

REXApplication Class

REXApplication Class
REX.Common Namespace Legend Members Public Methods REXApplication Methods REXApplication Properties

Base class for Application.This object controls the lifetime of the extensions.

Class Hierarchy
C#
public abstract class REXApplication : IREXApplication4, IREXThisExtension;
Description
Namespace

REX.Common Namespace

Public Methods
Public Method | Description
REXApplication | Initializes a new instance of a REXApplication class.
REXApplication Methods
REXApplication Methods | Description
CheckValidity | Checks the date limit.
Close | Closes this instance.
Command | Called when command.
Control | Get main control for embeding in a application form.
Create | Create module.
Create | Create module.
Event | Called when event.
GetExtension | Get the extension.
GetService | This is GetService, a member of class REXApplication.
GetText | Gets the text.
GetUniqueId | This is GetUniqueId, a member of class REXApplication.
GetVersion | Gets the minimum required version of specified engine's component.
Modal | Creates and shows module as modal dialog.
Modal | Creates and shows module as a modal dialog.
OnCreate | Called when create application object.
RestoreCultureInfo | Restores the culture info.
Show | Shows this module.
REXApplication Properties
REXApplication Properties | Description
Context | Get the reference to the old context.
Context2 | Get the context2.
ContextProduct | Get the context product from the old context structure.
ContextProduct2 | Get the context product2.
ThisApplication | This is ThisApplication, a member of class REXApplication.
ThisContext | This is ThisContext, a member of class REXApplication.
ThisExtension | This is ThisExtension, a member of class REXApplication.
Visible | Get or set a value indicating whether this REXApplication is visible.
Links
REX.Common Namespace, Legend, Members, Public Methods, REXApplication Methods, REXApplication Properties

REXApplication.REXApplication Constructor

REXApplication.REXApplication Constructor
REXApplication Class REX.Common Namespace REXApplication Class

Initializes a new instance of a REXApplication class.

C#
public REXApplication();
Description
Class

REXApplication Class

Links
REXApplication Class, REX.Common Namespace, REXApplication Class

REXApplication.CheckValidity Method

REXApplication.CheckValidity Method
REXApplication Class REX.Common Namespace REXApplication Class

Checks the date limit.

C#
public virtual bool CheckValidity();
Description
Class

REXApplication Class

Links
REXApplication Class, REX.Common Namespace, REXApplication Class

REXApplication.Close Method

REXApplication.Close Method
REXApplication Class REX.Common Namespace REXApplication Class

Closes this instance.

C#
public virtual void Close();
Description
Class

REXApplication Class

Links
REXApplication Class, REX.Common Namespace, REXApplication Class

REXApplication.Command Method

REXApplication.Command Method
REXApplication Class REX.Common Namespace REXApplication Class

Called when command.

C#
public virtual object Command(ref REXCommand CommandStruct);
Parameters
Parameters | Description
CommandStruct | The command structure.
Returns

Returns result of command operation.

Description
Class

REXApplication Class

Links
REXApplication Class, REX.Common Namespace, REXApplication Class

REXApplication.Control Method

REXApplication.Control Method
REXApplication Class REX.Common Namespace REXApplication Class

Get main control for embeding in a application form.

C#
public virtual object Control();
Returns

Returns reference to MainControl.

Description
Class

REXApplication Class

Links
REXApplication Class, REX.Common Namespace, REXApplication Class

REXApplication.Create Method (REXApplicationContext)

REXApplication.Create Method (REXApplicationContext)
REXApplication Class REX.Common Namespace REXApplication Class

Create module.

C#
public bool Create(ref REXApplicationContext AppContext);
Parameters
Parameters | Description
AppContext | The application context.
Returns

Returns true if succeeded.

Description
Class

REXApplication Class

Links
REXApplication Class, REX.Common Namespace, REXApplication Class

REXApplication.Create Method (REXContext)

REXApplication.Create Method (REXContext)
REXApplication Class REX.Common Namespace REXApplication Class

Create module.

C#
public bool Create(REXContext AppContext);
Parameters
Parameters | Description
AppContext | The application context.
Returns

Returns true if succeeded.

Description
Class

REXApplication Class

Links
REXApplication Class, REX.Common Namespace, REXApplication Class

REXApplication.Event Method

REXApplication.Event Method
REXApplication Class REX.Common Namespace REXApplication Class

Called when event.

C#
public virtual object Event(ref REXEvent EventStruct);
Parameters
Parameters | Description
EventStruct | The event structure.
Returns

Returns result of event operation.

Description
Class

REXApplication Class

Links
REXApplication Class, REX.Common Namespace, REXApplication Class

REXApplication.GetExtension Method

REXApplication.GetExtension Method
REXApplication Class REX.Common Namespace REXApplication Class

Get the extension.

C#
public virtual REXExtension GetExtension();
Returns

Returns reference to an extension object.

Description
Class

REXApplication Class

Links
REXApplication Class, REX.Common Namespace, REXApplication Class

REXApplication.GetService Method

REXApplication.GetService Method
REXApplication Class REX.Common Namespace REXApplication Class

This is GetService, a member of class REXApplication.

C#
public virtual object GetService();
Class

REXApplication Class

Links
REXApplication Class, REX.Common Namespace, REXApplication Class

REXApplication.GetText Method

REXApplication.GetText Method
REXApplication Class REX.Common Namespace REXApplication Class

Gets the text.

C#
public string GetText(string Name);
Parameters
Parameters | Description
Name | The name.
Returns

Returns specified text.

Description

See Extension.GetText() method.

Class

REXApplication Class

Links
REXApplication Class, REX.Common Namespace, REXApplication Class

REXApplication.GetUniqueId Method

REXApplication.GetUniqueId Method
REXApplication Class REX.Common Namespace REXApplication Class

This is GetUniqueId, a member of class REXApplication.

C#
public virtual Guid GetUniqueId();
Class

REXApplication Class

Links
REXApplication Class, REX.Common Namespace, REXApplication Class

REXApplication.GetVersion Method

REXApplication.GetVersion Method
REXApplication Class REX.Common Namespace REXApplication Class

Gets the minimum required version of specified engine's component.

C#
public string GetVersion(REXVersionType Version);
Parameters
Parameters | Description
Version | The version.
Returns

Returns version string - "Major.Minor".

Description
Class

REXApplication Class

Links
REXApplication Class, REX.Common Namespace, REXApplication Class

REXApplication.Modal Method (REXApplicationContext)

REXApplication.Modal Method (REXApplicationContext)
REXApplication Class REX.Common Namespace REXApplication Class

Creates and shows module as modal dialog.

C#
public bool Modal(ref REXApplicationContext AppContext);
Parameters
Parameters | Description
AppContext | The application context.
Returns

Returns true if suceeded.

Description
Class

REXApplication Class

Links
REXApplication Class, REX.Common Namespace, REXApplication Class

REXApplication.Modal Method (REXContext)

REXApplication.Modal Method (REXContext)
REXApplication Class REX.Common Namespace REXApplication Class

Creates and shows module as a modal dialog.

C#