true if the multiline text box control wraps words; false if the text box control automatically scrolls horizontally when the user types past the right edge of the control. The default is true.

Description

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class

REXImageComboBox Class

REXImageComboBox Class
REX.Controls.Forms Namespace Legend Members Public Methods REXImageComboBox Properties

Combo box with images.

Class Hierarchy
C#
[System.ComponentModel.ToolboxItem(true)]
[ToolboxBitmapAttribute(typeof(REXImageComboBox), "REXImageComboBox.Icon.bmp")]
public class REXImageComboBox : ComboBox;
Description
Namespace

REX.Controls.Forms Namespace

Public Methods
Public Method | Description
REXImageComboBox | Initializes a new instance of the ComboBoxImage class.
REXImageComboBox Properties
REXImageComboBox Properties | Description
ImageList | Get or set the image list.
Links
REX.Controls.Forms Namespace, Legend, Members, Public Methods, REXImageComboBox Properties

REXImageComboBox.REXImageComboBox Constructor

REXImageComboBox.REXImageComboBox Constructor
REXImageComboBox Class REX.Controls.Forms Namespace REXImageComboBox Class

Initializes a new instance of the ComboBoxImage class.

C#
public REXImageComboBox();
Description
Class

REXImageComboBox Class

Links
REXImageComboBox Class, REX.Controls.Forms Namespace, REXImageComboBox Class

REXImageComboBox.ImageList Property

REXImageComboBox.ImageList Property
REXImageComboBox Class REX.Controls.Forms Namespace REXImageComboBox Class

Get or set the image list.

C#
public ImageList ImageList;
Description

The image list.

Class

REXImageComboBox Class

Links
REXImageComboBox Class, REX.Controls.Forms Namespace, REXImageComboBox Class

REXImageComboBoxItem Class

REXImageComboBoxItem Class
REX.Controls.Forms Namespace Legend Members Public Methods REXImageComboBoxItem Methods REXImageComboBoxItem Properties

Represents the combobox item with an image inside.

Class Hierarchy
C#
public class REXImageComboBoxItem : object;
Description
Namespace

REX.Controls.Forms Namespace

Public Methods
Public Method | Description
REXImageComboBoxItem | Initializes a new instance of a ImageComboItem class.
REXImageComboBoxItem | Initializes a new instance of a ImageComboItem class.
REXImageComboBoxItem | Initializes a new instance of a ImageComboItem class.
REXImageComboBoxItem | Initializes a new instance of a ImageComboItem class.
REXImageComboBoxItem | Initializes a new instance of a ImageComboItem class.
REXImageComboBoxItem | Initializes a new instance of a ImageComboItem class.
REXImageComboBoxItem | Initializes a new instance of a ImageComboItem class.
REXImageComboBoxItem | Initializes a new instance of a ImageComboItem class.
REXImageComboBoxItem | Initializes a new instance of a ImageComboItem class.
REXImageComboBoxItem | Initializes a new instance of a ImageComboItem class.
REXImageComboBoxItem | Initializes a new instance of a ImageComboItem class.
REXImageComboBoxItem | Initializes a new instance of a ImageComboItem class.
REXImageComboBoxItem | Initializes a new instance of a ImageComboItem class.
REXImageComboBoxItem Methods
REXImageComboBoxItem Methods | Description
ToString | Returns a T:System.String that represents the current T:System.Object.
REXImageComboBoxItem Properties
REXImageComboBoxItem Properties | Description
ForegroundColor | Gets or sets the color of the foreground.
Image | Gets or sets the image.
ImageIndex | Gets or sets the index of the image.
Mark | Gets or sets a value indicating whether this ImageComboItem is a mark.
Tag | Gets or sets the tag.
Text | Gets or sets the text.
Tooltip | Gets or sets the tooltip.
UseTextAsTooltip | Gets or sets a value indicating whether the text should be used as a Tooltip.
VisibleOnList | Gets or sets a value indicating whether item should be visible on the list.
Links
REX.Controls.Forms Namespace, Legend, Members, Public Methods, REXImageComboBoxItem Methods, REXImageComboBoxItem Properties

REXImageComboBoxItem.REXImageComboBoxItem Constructor ()

REXImageComboBoxItem.REXImageComboBoxItem Constructor ()
REXImageComboBoxItem Class REX.Controls.Forms Namespace REXImageComboBoxItem Class

Initializes a new instance of a ImageComboItem class.

C#
public REXImageComboBoxItem();
Description
Class

REXImageComboBoxItem Class

Links
REXImageComboBoxItem Class, REX.Controls.Forms Namespace, REXImageComboBoxItem Class

REXImageComboBoxItem.REXImageComboBoxItem Constructor (Image)

REXImageComboBoxItem.REXImageComboBoxItem Constructor (Image)
REXImageComboBoxItem Class REX.Controls.Forms Namespace REXImageComboBoxItem Class

Initializes a new instance of a ImageComboItem class.

C#
public REXImageComboBoxItem(Image Image);
Parameters
Parameters | Description
ImageIndex | The image.
Description
Class

REXImageComboBoxItem Class

Links
REXImageComboBoxItem Class, REX.Controls.Forms Namespace, REXImageComboBoxItem Class

REXImageComboBoxItem.REXImageComboBoxItem Constructor (Image, string)

REXImageComboBoxItem.REXImageComboBoxItem Constructor (Image, string)
REXImageComboBoxItem Class REX.Controls.Forms Namespace REXImageComboBoxItem Class

Initializes a new instance of a ImageComboItem class.

C#
public REXImageComboBoxItem(Image Image, string Tooltip);
Parameters
Parameters | Description
ImageIndex | The image.
Description
Class

REXImageComboBoxItem Class

Links
REXImageComboBoxItem Class, REX.Controls.Forms Namespace, REXImageComboBoxItem Class

REXImageComboBoxItem.REXImageComboBoxItem Constructor (int)

REXImageComboBoxItem.REXImageComboBoxItem Constructor (int)
REXImageComboBoxItem Class REX.Controls.Forms Namespace REXImageComboBoxItem Class

Initializes a new instance of a ImageComboItem class.

C#
public REXImageComboBoxItem(int ImageIndex);
Parameters
Parameters | Description
ImageIndex | Index of the image.
Description
Class

REXImageComboBoxItem Class

Links
REXImageComboBoxItem Class, REX.Controls.Forms Namespace, REXImageComboBoxItem Class

REXImageComboBoxItem.REXImageComboBoxItem Constructor (string)

REXImageComboBoxItem.REXImageComboBoxItem Constructor (string)
REXImageComboBoxItem Class REX.Controls.Forms Namespace REXImageComboBoxItem Class

Initializes a new instance of a ImageComboItem class.

C#
public REXImageComboBoxItem(string Text);
Parameters
Parameters | Description
Text | The text.
Description
Class

REXImageComboBoxItem Class

Links
REXImageComboBoxItem Class, REX.Controls.Forms Namespace, REXImageComboBoxItem Class

REXImageComboBoxItem.REXImageComboBoxItem Constructor (string, Image)

REXImageComboBoxItem.REXImageComboBoxItem Constructor (string, Image)
REXImageComboBoxItem Class REX.Controls.Forms Namespace REXImageComboBoxItem Class

Initializes a new instance of a ImageComboItem class.

C#
public REXImageComboBoxItem(string Text, Image Image);
Parameters
Parameters | Description
Text | The text.
ImageIndex | The image.
Description
Class

REXImageComboBoxItem Class

Links
REXImageComboBoxItem Class, REX.Controls.Forms Namespace, REXImageComboBoxItem Class

REXImageComboBoxItem.REXImageComboBoxItem Constructor (string, Image, bool)

REXImageComboBoxItem.REXImageComboBoxItem Constructor (string, Image, bool)
REXImageComboBoxItem Class REX.Controls.Forms Namespace REXImageComboBoxItem Class

Initializes a new instance of a ImageComboItem class.

C#
public REXImageComboBoxItem(string Text, Image Image, bool Mark);
Parameters
Parameters | Description
Text | The text.
Mark | If set to true [mark].
ImageIndex | The image.
Description
Class

REXImageComboBoxItem Class

Links
REXImageComboBoxItem Class, REX.Controls.Forms Namespace, REXImageComboBoxItem Class

REXImageComboBoxItem.REXImageComboBoxItem Constructor (string, Image, bool, Color)

REXImageComboBoxItem.REXImageComboBoxItem Constructor (string, Image, bool, Color)
REXImageComboBoxItem Class REX.Controls.Forms Namespace REXImageComboBoxItem Class

Initializes a new instance of a ImageComboItem class.

C#