REXToolboxObject.Tag Property

REXToolboxObject.Tag Property
REXToolboxObject Class REX.Controls.WPF Namespace REXToolboxObject Class

Gets or sets the tag.

C#
public object Tag;
Description

The tag.

Class

REXToolboxObject Class

Links
REXToolboxObject Class, REX.Controls.WPF Namespace, REXToolboxObject Class

REXUnitComboBox Class

REXUnitComboBox Class
REX.Controls.WPF Namespace Legend Members Public Methods REXUnitComboBox Fields REXUnitComboBox Methods REXUnitComboBox Properties

Represents the REXUnitComboBox control with a built in IREXUnitEngine.

Class Hierarchy
C#
public class REXUnitComboBox : REXComboBox;
Description
Namespace

REX.Controls.WPF Namespace

Public Methods
Public Method | Description
REXUnitComboBox | Initializes a new instance of the REXUnitComboBox class.
REXUnitComboBox Fields
REXUnitComboBox Fields | Description
ComplexDoubleValueBaseProperty | This is ComplexDoubleValueBaseProperty, a member of class REXUnitComboBox.
DoubleValueBaseProperty | This is DoubleValueBaseProperty, a member of class REXUnitComboBox.
PowerProperty | This is PowerProperty, a member of class REXUnitComboBox.
UnitTypeProperty | This is UnitTypeProperty, a member of class REXUnitComboBox.
REXUnitComboBox Methods
REXUnitComboBox Methods | Description
GetBaseMaxValue | Gets the maximum value and converts it to base units.
GetBaseMinValue | Gets the minimum value and converts it to base units.
GetComplexDataBaseValue | Get the values and convert it to base units.
GetComplexDataInterfaceValue | Get the values and convert it to interface units.
GetDataBaseValue | Gets the value and converts it to base units.
GetDataInterfaceValue | Gets the value and converts it to interface units.
GetInterfaceMaxValue | Gets the maximum value and converts it to interface units.
GetInterfaceMinValue | Gets the minimum value and converts it to interface units.
SetBaseMaxValue | Set the maximum value defined in base units.
SetBaseMinValue | Set the minimum value defined in base units.
SetComplexDataBaseValue | Set the list of values defined in base units.
SetComplexDataInterfaceValue | Set the list of values defined in interface units.
SetDataBaseValue | Set the value in base units.
SetDataInterfaceValue | Set the value in interface units.
SetInterfaceMaxValue | Set the maximum value defined in interface units.
SetInterfaceMinValue | Set the minimum value defined in interface units.
REXUnitComboBox Properties
REXUnitComboBox Properties | Description
ComplexDoubleValueBase | Gets or sets the complex double value.
DoubleValueBase | Gets or sets the double value.
Power | Gets or sets the power of the unit.
UnitEngine | Gets or sets the unit engine.
UnitType | Gets or sets the type of the unit.
Links
REX.Controls.WPF Namespace, Legend, Members, Public Methods, REXUnitComboBox Fields, REXUnitComboBox Methods, REXUnitComboBox Properties

REXUnitComboBox.REXUnitComboBox Constructor

REXUnitComboBox.REXUnitComboBox Constructor
REXUnitComboBox Class REX.Controls.WPF Namespace REXUnitComboBox Class

Initializes a new instance of the REXUnitComboBox class.

C#
public REXUnitComboBox();
Description
Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.WPF Namespace, REXUnitComboBox Class

REXUnitComboBox.ComplexDoubleValueBaseProperty Field

REXUnitComboBox.ComplexDoubleValueBaseProperty Field
REXUnitComboBox Class REX.Controls.WPF Namespace REXUnitComboBox Class

This is ComplexDoubleValueBaseProperty, a member of class REXUnitComboBox.

C#
public static readonly DependencyProperty ComplexDoubleValueBaseProperty;
Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.WPF Namespace, REXUnitComboBox Class

REXUnitComboBox.DoubleValueBaseProperty Field

REXUnitComboBox.DoubleValueBaseProperty Field
REXUnitComboBox Class REX.Controls.WPF Namespace REXUnitComboBox Class

This is DoubleValueBaseProperty, a member of class REXUnitComboBox.

C#
public static readonly DependencyProperty DoubleValueBaseProperty;
Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.WPF Namespace, REXUnitComboBox Class

REXUnitComboBox.PowerProperty Field

REXUnitComboBox.PowerProperty Field
REXUnitComboBox Class REX.Controls.WPF Namespace REXUnitComboBox Class

This is PowerProperty, a member of class REXUnitComboBox.

C#
public static readonly DependencyProperty PowerProperty;
Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.WPF Namespace, REXUnitComboBox Class

REXUnitComboBox.UnitTypeProperty Field

REXUnitComboBox.UnitTypeProperty Field
REXUnitComboBox Class REX.Controls.WPF Namespace REXUnitComboBox Class

This is UnitTypeProperty, a member of class REXUnitComboBox.

C#
public static readonly DependencyProperty UnitTypeProperty;
Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.WPF Namespace, REXUnitComboBox Class

REXUnitComboBox.GetBaseMaxValue Method

REXUnitComboBox.GetBaseMaxValue Method
REXUnitComboBox Class REX.Controls.WPF Namespace REXUnitComboBox Class

Gets the maximum value and converts it to base units.

C#
public double GetBaseMaxValue();
Returns

The value.

Description
Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.WPF Namespace, REXUnitComboBox Class

REXUnitComboBox.GetBaseMinValue Method

REXUnitComboBox.GetBaseMinValue Method
REXUnitComboBox Class REX.Controls.WPF Namespace REXUnitComboBox Class

Gets the minimum value and converts it to base units.

C#
public double GetBaseMinValue();
Returns

The value.

Description
Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.WPF Namespace, REXUnitComboBox Class

REXUnitComboBox.GetComplexDataBaseValue Method

REXUnitComboBox.GetComplexDataBaseValue Method
REXUnitComboBox Class REX.Controls.WPF Namespace REXUnitComboBox Class

Get the values and convert it to base units.

C#
public List<double> GetComplexDataBaseValue();
Returns

The list of values.

Description
Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.WPF Namespace, REXUnitComboBox Class

REXUnitComboBox.GetComplexDataInterfaceValue Method

REXUnitComboBox.GetComplexDataInterfaceValue Method
REXUnitComboBox Class REX.Controls.WPF Namespace REXUnitComboBox Class

Get the values and convert it to interface units.

C#
public List<double> GetComplexDataInterfaceValue(REXInterfaceType interfaceType);
Parameters
Parameters | Description
interfaceType | The product context.
Returns

The list of values.

Description
Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.WPF Namespace, REXUnitComboBox Class

REXUnitComboBox.GetDataBaseValue Method

REXUnitComboBox.GetDataBaseValue Method
REXUnitComboBox Class REX.Controls.WPF Namespace REXUnitComboBox Class

Gets the value and converts it to base units.

C#
public double GetDataBaseValue();
Returns

The value.

Description
Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.WPF Namespace, REXUnitComboBox Class

REXUnitComboBox.GetDataInterfaceValue Method

REXUnitComboBox.GetDataInterfaceValue Method
REXUnitComboBox Class REX.Controls.WPF Namespace REXUnitComboBox Class

Gets the value and converts it to interface units.

C#
public double GetDataInterfaceValue(REXInterfaceType interfaceType);
Parameters
Parameters | Description
interfaceType | The product context.
Returns

The value.

Description
Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.WPF Namespace, REXUnitComboBox Class

REXUnitComboBox.GetInterfaceMaxValue Method

REXUnitComboBox.GetInterfaceMaxValue Method
REXUnitComboBox Class REX.Controls.WPF Namespace REXUnitComboBox Class

Gets the maximum value and converts it to interface units.

C#
public double GetInterfaceMaxValue(REXInterfaceType interfaceType);
Parameters
Parameters | Description
interfaceType | The product context.
Returns

The value.

Description
Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.WPF Namespace, REXUnitComboBox Class