T_REXFamilyType | The type of the custom family type.
T_REXDescription | The type of the custom description.
Returns

Returns whether registration succeeded.

Description
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, REXFamilyConverter Class

REXFamilyConverter.ContentMapper Property

REXFamilyConverter.ContentMapper Property
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace REXFamilyConverter Class

Gets the mapper object.

C#
public REXContentMapper ContentMapper;
Description

The content mapper.

Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, REXFamilyConverter Class

REXFamilyConverter.Settings Property

REXFamilyConverter.Settings Property
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace REXFamilyConverter Class

Gets the settings.

C#
public IRexContentSettings Settings;
Description

The settings.

Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, REXFamilyConverter Class

REXMaterialFactory Class

REXMaterialFactory Class
REX.ContentGenerator.Converters Namespace Legend Members Public Methods REXMaterialFactory Methods

This is class REX.ContentGenerator.Converters.REXMaterialFactory.

Class Hierarchy
C#
public class REXMaterialFactory : REXFamilyFactoryDbRootAdo;
Namespace

REX.ContentGenerator.Converters Namespace

Public Methods
Public Method | Description
REXMaterialFactory | This is REXMaterialFactory, a member of class REXMaterialFactory.
REXMaterialFactory Methods
REXMaterialFactory Methods | Description
CompareRows | This is CompareRows, a member of class REXMaterialFactory.
FillDBDescription | This is FillDBDescription, a member of class REXMaterialFactory.
FillDBObjectCollection | This is FillDBObjectCollection, a member of class REXMaterialFactory.
FillFamilyTypeProperties | This is FillFamilyTypeProperties, a member of class REXMaterialFactory.
FillFamilyTypeProperties | This is FillFamilyTypeProperties, a member of class REXMaterialFactory.
GetAliasName | This is GetAliasName, a member of class REXMaterialFactory.
GetFamiliesOfAlias | This is GetFamiliesOfAlias, a member of class REXMaterialFactory.
GetFamilyDefault | This is GetFamilyDefault, a member of class REXMaterialFactory.
GetFamilyOfAlias | This is GetFamilyOfAlias, a member of class REXMaterialFactory.
GetFamilyTemplate | This is GetFamilyTemplate, a member of class REXMaterialFactory.
GetMaterial | This is GetMaterial, a member of class REXMaterialFactory.
GetNewDescription | This is GetNewDescription, a member of class REXMaterialFactory.
GetNewDescription | This is GetNewDescription, a member of class REXMaterialFactory.
GetNewFamily | This is GetNewFamily, a member of class REXMaterialFactory.
GetPropertiesADO | This is GetPropertiesADO, a member of class REXMaterialFactory.
GetPropertiesDBRoot | This is GetPropertiesDBRoot, a member of class REXMaterialFactory.
RecalculatDBDesc | This is RecalculatDBDesc, a member of class REXMaterialFactory.
ValidateDB | This is ValidateDB, a member of class REXMaterialFactory.
ValidateDB | This is ValidateDB, a member of class REXMaterialFactory.
Links
REX.ContentGenerator.Converters Namespace, Legend, Members, Public Methods, REXMaterialFactory Methods

REXMaterialFactory.REXMaterialFactory Constructor

REXMaterialFactory.REXMaterialFactory Constructor
REXMaterialFactory Class REX.ContentGenerator.Converters Namespace REXMaterialFactory Class

This is REXMaterialFactory, a member of class REXMaterialFactory.

C#
public REXMaterialFactory(RexConversionSettings Settings);
Class

REXMaterialFactory Class

Links
REXMaterialFactory Class, REX.ContentGenerator.Converters Namespace, REXMaterialFactory Class

REXMaterialFactory.CompareRows Method

REXMaterialFactory.CompareRows Method
REXMaterialFactory Class REX.ContentGenerator.Converters Namespace REXMaterialFactory Class

This is CompareRows, a member of class REXMaterialFactory.

C#
public override bool CompareRows(bool certified, REXDescription ft, IDbRootLib.IDbTableRow row, IDbRootLib.DbDatabase db, Dictionary<string, int> ColumnDict);
Class

REXMaterialFactory Class

Links
REXMaterialFactory Class, REX.ContentGenerator.Converters Namespace, REXMaterialFactory Class

REXMaterialFactory.FillDBDescription Method

REXMaterialFactory.FillDBDescription Method
REXMaterialFactory Class REX.ContentGenerator.Converters Namespace REXMaterialFactory Class

This is FillDBDescription, a member of class REXMaterialFactory.

C#
public override void FillDBDescription(IDbRootLib.IDbDatabase db, IDbRootLib.IDbTableRow row, REXDBDescription desc, string dir, string dbname, bool recalc, int tableIndex, Dictionary<string, int> ColumnDict, bool forMapping);
Class

REXMaterialFactory Class

Links
REXMaterialFactory Class, REX.ContentGenerator.Converters Namespace, REXMaterialFactory Class

REXMaterialFactory.FillDBObjectCollection Method

REXMaterialFactory.FillDBObjectCollection Method
REXMaterialFactory Class REX.ContentGenerator.Converters Namespace REXMaterialFactory Class

This is FillDBObjectCollection, a member of class REXMaterialFactory.

C#
public override void FillDBObjectCollection(bool certified, REXDescription db, DTableDataObjectCollection dtdoc, out bool ok);
Class

REXMaterialFactory Class

Links
REXMaterialFactory Class, REX.ContentGenerator.Converters Namespace, REXMaterialFactory Class

REXMaterialFactory.FillFamilyTypeProperties Method (REXFamilyType, DTableDataObjectCollection, string, string)

REXMaterialFactory.FillFamilyTypeProperties Method (REXFamilyType, DTableDataObjectCollection, string, string)
REXMaterialFactory Class REX.ContentGenerator.Converters Namespace REXMaterialFactory Class

This is FillFamilyTypeProperties, a member of class REXMaterialFactory.

C#
public override void FillFamilyTypeProperties(REXFamilyType fam, DTableDataObjectCollection col, string path, string dbName);
Class

REXMaterialFactory Class

Links
REXMaterialFactory Class, REX.ContentGenerator.Converters Namespace, REXMaterialFactory Class

REXMaterialFactory.FillFamilyTypeProperties Method (REXFamilyType, IDbRootLib.IDbTableRow, string, string)

REXMaterialFactory.FillFamilyTypeProperties Method (REXFamilyType, IDbRootLib.IDbTableRow, string, string)
REXMaterialFactory Class REX.ContentGenerator.Converters Namespace REXMaterialFactory Class

This is FillFamilyTypeProperties, a member of class REXMaterialFactory.

C#
public override void FillFamilyTypeProperties(REXFamilyType fam, IDbRootLib.IDbTableRow row, string path, string dbName);
Class

REXMaterialFactory Class

Links
REXMaterialFactory Class, REX.ContentGenerator.Converters Namespace, REXMaterialFactory Class

REXMaterialFactory.GetAliasName Method

REXMaterialFactory.GetAliasName Method
REXMaterialFactory Class REX.ContentGenerator.Converters Namespace REXMaterialFactory Class

This is GetAliasName, a member of class REXMaterialFactory.

C#
public override bool GetAliasName(REXDBDescription DBdesc, out string type, out List<string> alias);
Class

REXMaterialFactory Class

Links
REXMaterialFactory Class, REX.ContentGenerator.Converters Namespace, REXMaterialFactory Class

REXMaterialFactory.GetFamiliesOfAlias Method

REXMaterialFactory.GetFamiliesOfAlias Method
REXMaterialFactory Class REX.ContentGenerator.Converters Namespace REXMaterialFactory Class

This is GetFamiliesOfAlias, a member of class REXMaterialFactory.

C#
public override List<REXFamilyType> GetFamiliesOfAlias(REX.ContentGenerator.Families.EElementType el, string alias, out bool found);
Class

REXMaterialFactory Class

Links
REXMaterialFactory Class, REX.ContentGenerator.Converters Namespace, REXMaterialFactory Class

REXMaterialFactory.GetFamilyDefault Method

REXMaterialFactory.GetFamilyDefault Method
REXMaterialFactory Class REX.ContentGenerator.Converters Namespace REXMaterialFactory Class