public void AddImage(String dllName, Long number);
Parameters
Parameters | Description
dllName |
number |
Description
Class

XHTMLElement Class

Links
XHTMLElement Class, ROHTML Namespace, XHTMLElement Class

XHTMLElement.AddImageStd Method

XHTMLElement.AddImageStd Method
XHTMLElement Class ROHTML Namespace XHTMLElement Class

Adds a standard image loaded from internal resources to the document.

C#
public void AddImageStd(ROHTMLStdImages image);
Parameters
Parameters | Description
image |
Description

See ROHTMLStdImages constants description.

Class

XHTMLElement Class

Links
XHTMLElement Class, ROHTML Namespace, XHTMLElement Class

XHTMLElement.AddLine Method

XHTMLElement.AddLine Method
XHTMLElement Class ROHTML Namespace XHTMLElement Class

Writes the given text, followed by a newline character, to the document.

C#
public void AddLine(String text);
Parameters
Parameters | Description
text |
Description
Class

XHTMLElement Class

Links
XHTMLElement Class, ROHTML Namespace, XHTMLElement Class

XHTMLElement.AddLineBreak Method

XHTMLElement.AddLineBreak Method
XHTMLElement Class ROHTML Namespace XHTMLElement Class

Inserts a single line break ().

C#
public void AddLineBreak();
Description
Class

XHTMLElement Class

Links
XHTMLElement Class, ROHTML Namespace, XHTMLElement Class

XHTMLElement.AddMessage Method

XHTMLElement.AddMessage Method
XHTMLElement Class ROHTML Namespace XHTMLElement Class

Adds a decorated text to the document and returns newly created XHTMLElement object.

C#
public void AddMessage(String text, ROHTMLMessages type);
Parameters
Parameters | Description
text |
type |
Description

See ROHTMLMessages to preview available formats.

Class

XHTMLElement Class

Links
XHTMLElement Class, ROHTML Namespace, XHTMLElement Class

XHTMLElement.AddMessage2 Method

XHTMLElement.AddMessage2 Method
XHTMLElement Class ROHTML Namespace XHTMLElement Class

Adds a left text aligned text with right aligned note.

C#
public void AddMessage2(String text, String note);
Parameters
Parameters | Description
text |
note |
Description
Class

XHTMLElement Class

Links
XHTMLElement Class, ROHTML Namespace, XHTMLElement Class

XHTMLElement.AddNoteFooter Method

XHTMLElement.AddNoteFooter Method
XHTMLElement Class ROHTML Namespace XHTMLElement Class

Writes calculation note footer

C#
public void AddNoteFooter(String message, String name, Variant value);
Parameters
Parameters | Description
message |
name |
value |
Class

XHTMLElement Class

Links
XHTMLElement Class, ROHTML Namespace, XHTMLElement Class

XHTMLElement.AddNoteHeader Method

XHTMLElement.AddNoteHeader Method
XHTMLElement Class ROHTML Namespace XHTMLElement Class

Writes calculation note header

C#
public void AddNoteHeader(String title, String subtitle, String code, String dllName, Long number);
Parameters
Parameters | Description
title |
subtitle |
code |
dllName |
number |
Class

XHTMLElement Class

Links
XHTMLElement Class, ROHTML Namespace, XHTMLElement Class

XHTMLElement.AddParagraph Method

XHTMLElement.AddParagraph Method
XHTMLElement Class ROHTML Namespace XHTMLElement Class

Adds an element of type "p" to the document and returns newly created XHTMLElement object.

C#
public void AddParagraph(String text);
Parameters
Parameters | Description
text |
Description

Writes the given text to the created element of the document.

Class

XHTMLElement Class

Links
XHTMLElement Class, ROHTML Namespace, XHTMLElement Class

XHTMLElement.AddPicture Method

XHTMLElement.AddPicture Method
XHTMLElement Class ROHTML Namespace XHTMLElement Class

Adds an image loaded from file.

C#
public void AddPicture(String file);
Parameters
Parameters | Description
file |
Description
Class

XHTMLElement Class

Links
XHTMLElement Class, ROHTML Namespace, XHTMLElement Class

XHTMLElement.AddSpan Method

XHTMLElement.AddSpan Method
XHTMLElement Class ROHTML Namespace XHTMLElement Class

Adds an element of type "span" to the document and returns newly created XHTMLElement object.

C#
public void AddSpan(String text);
Parameters
Parameters | Description
text |
Description

Writes the given text to the created element of the document.

Class

XHTMLElement Class

Links
XHTMLElement Class, ROHTML Namespace, XHTMLElement Class

XHTMLElement.AddSubscript Method

XHTMLElement.AddSubscript Method
XHTMLElement Class ROHTML Namespace XHTMLElement Class

Writes the given text to the document as a subscript.

C#
public void AddSubscript(String text);
Parameters
Parameters | Description
text |
Description
Class

XHTMLElement Class

Links
XHTMLElement Class, ROHTML Namespace, XHTMLElement Class

XHTMLElement.AddSuperscript Method

XHTMLElement.AddSuperscript Method
XHTMLElement Class ROHTML Namespace XHTMLElement Class

Writes the given text to the document as a superscript.

C#
public void AddSuperscript(String text);
Parameters
Parameters | Description
text |
Description
Class

XHTMLElement Class

Links
XHTMLElement Class, ROHTML Namespace, XHTMLElement Class

XHTMLElement.AddSymbol Method

XHTMLElement.AddSymbol Method
XHTMLElement Class ROHTML Namespace XHTMLElement Class

Writes the given text to the document using symbol (greek) font, e.g.

C#
public void AddSymbol(String text);
Parameters
Parameters | Description
text |
Description

abcdefg.

Class

XHTMLElement Class

Links
XHTMLElement Class, ROHTML Namespace, XHTMLElement Class

XHTMLElement.AddTable Method

XHTMLElement.AddTable Method
XHTMLElement Class ROHTML Namespace XHTMLElement Class

Adds a table to the document and returns newly created XHTMLTable object

C#
public void AddTable();
Class

XHTMLElement Class

Links
XHTMLElement Class, ROHTML Namespace, XHTMLElement Class

XHTMLElement.AddText Method

XHTMLElement.AddText Method
XHTMLElement Class ROHTML Namespace XHTMLElement Class

Writes the given text to the document.

C#
public void AddText(String text);
Parameters
Parameters | Description
text |
Description
Class

XHTMLElement Class

Links
XHTMLElement Class, ROHTML Namespace, XHTMLElement Class

XHTMLElement.AddText2 Method

XHTMLElement.AddText2 Method
XHTMLElement Class ROHTML Namespace XHTMLElement Class

Writes the given value name and its description to the document.

C#
public void AddText2(String name, String description);
Parameters
Parameters | Description
name |
description |
Description
Class

XHTMLElement Class

Links
XHTMLElement Class, ROHTML Namespace, XHTMLElement Class

XHTMLElement.AddTextBold Method

XHTMLElement.AddTextBold Method
XHTMLElement Class ROHTML Namespace XHTMLElement Class

Writes the given text to the document using a bold font.

C#
public void AddTextBold(String text);
Parameters
Parameters | Description
text |
Description
Class

XHTMLElement Class

Links
XHTMLElement Class, ROHTML Namespace, XHTMLElement Class

XHTMLElement.AddUnit Method

XHTMLElement.AddUnit Method
XHTMLElement Class ROHTML Namespace XHTMLElement Class

Writes the given unit name to the document, adds braces if needed and moves all digits to uppercase, e.g mm2 -> [mm2].

C#
public void AddUnit(String unit);
Parameters
Parameters | Description
unit |
Description
Class

XHTMLElement Class

Links
XHTMLElement Class, ROHTML Namespace, XHTMLElement Class

XHTMLElement.AddValue Method

XHTMLElement.AddValue Method
XHTMLElement Class ROHTML Namespace XHTMLElement Class

Writes the given value of any type, that can be converted to a string, to the document.

C#
public void AddValue(Variant value);
Parameters
Parameters | Description
value |
Description

Usually useful with integer values. Text will be written using monospace font.

Class

XHTMLElement Class

Links
XHTMLElement Class, ROHTML Namespace, XHTMLElement Class

XHTMLElement.AddValue2 Method

XHTMLElement.AddValue2 Method
XHTMLElement Class ROHTML Namespace XHTMLElement Class

Writes the given value of any type and it's name.

C#
public void AddValue2(String name, Variant value);
Parameters
Parameters | Description
name |
value |
Description