Validates the current control based on the input value.

C#
public virtual bool ValidateControl(double val);
Parameters
Parameters | Description
val | The value.
Returns

True if validated; otherwise false.

Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.ValidateValue Method (Double)

REXEditControlEngine.ValidateValue Method (Double)
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Validates the input value of the double type.

C#
public bool ValidateValue(Double value);
Parameters
Parameters | Description
value | The value to validate.
Returns

True if validated; otherwise false.

Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.ValidateValue Method (String)

REXEditControlEngine.ValidateValue Method (String)
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Validates the value of the string type.

C#
public bool ValidateValue(String value);
Parameters
Parameters | Description
value | The value to validate.
Returns

True if validated; otherwise false.

Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.ValueFormat Method (Double)

REXEditControlEngine.ValueFormat Method (Double)
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Returns a text containing an expression formatted according the current settings of the element.

C#
public string ValueFormat(Double value);
Parameters
Parameters | Description
value | The value to format.
Returns

The formatted text.

Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.ValueFormat Method (String)

REXEditControlEngine.ValueFormat Method (String)
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Returns a text containing an expression formatted according the current settings of the element.

C#
public string ValueFormat(String value);
Parameters
Parameters | Description
value | The value to format.
Returns

The formatted text.

Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.ValueParse Method

REXEditControlEngine.ValueParse Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Converts the specified text to the numeric value according the current settings of the element.

C#
public double ValueParse(String value);
Parameters
Parameters | Description
value | The text.
Returns

The converted value.

Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.Background Property

REXEditControlEngine.Background Property
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets or sets the background of the control.

C#
public T_Background Background;
Description

The background.

Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.BackgroundDisabledHidden Property

REXEditControlEngine.BackgroundDisabledHidden Property
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets or sets the background for the disabled state of the control in the hidden background mode.

C#
public T_Background BackgroundDisabledHidden;
Description

The background.

Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.BackgroundDisabledStandard Property

REXEditControlEngine.BackgroundDisabledStandard Property
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets or sets the background for the disabled state of the control.

C#
public T_Background BackgroundDisabledStandard;
Description

The background.

Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.BackgroundError Property

REXEditControlEngine.BackgroundError Property
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets or sets the background for the Error state of the control.

C#
public T_Background BackgroundError;
Description

The Error background.

Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.BackgroundNeutral Property

REXEditControlEngine.BackgroundNeutral Property
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets or sets the background for the neutral state of the control.

C#
public T_Background BackgroundNeutral;
Description

The neutral background.

Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.BackgroundOK Property

REXEditControlEngine.BackgroundOK Property
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets or sets the background for the OK state of the control.

C#
public T_Background BackgroundOK;
Description

The OK background.

Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.Complex Property

REXEditControlEngine.Complex Property
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets or sets a value indicating whether this REXEditControlEngine supports complex (list) values.

C#
public Boolean Complex;
Description

True if the engine supports complex values; otherwise false.

Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.ComplexSeparator Property

REXEditControlEngine.ComplexSeparator Property
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets or sets the complex (list) separator.

C#
[DefaultValue(";")]
public string ComplexSeparator;
Description

The complex separator.

Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.ComplexSpaceSeparator Property

REXEditControlEngine.ComplexSpaceSeparator Property
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets or sets a value indicating whether a space should be respected as a list separator.

C#
public Boolean ComplexSpaceSeparator;
Description

True if space respected as a list separator; otherwise, false.

Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.ComplexUnitOnEnd Property

REXEditControlEngine.ComplexUnitOnEnd Property
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets or sets a value indicating whether a unit symbol should be placed on the end of the formatted text.

C#
public Boolean ComplexUnitOnEnd;
Description

True if the unit one the end; otherwise, false.

Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.ControlState Property

REXEditControlEngine.ControlState Property
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets the current state of the control.

C#