ContourLine | Initializes a new instance of the ContourLine class.
ContourLine | Initializes a new instance of the ContourLine class.
ContourLine | Initializes a new instance of the ContourLine class.
ContourLine | Initializes a new instance of the ContourLine class.
ContourLine | Initializes a new instance of the ContourLine class.
ContourLine Methods
ContourLine Methods | Description
GetEnd | Gets the end point in a plane.
GetPointList | Gets the list of points.
GetStart | Gets the start point in a plane.
MultiplyLengthDim | Multiplies length dimensions by the coefficient.
Transform | Applies the specified transformation to the element.
Translate | Applies the specified translation vector to the element.
ContourLine Properties
ContourLine Properties | Description
End | Gets or sets the end point.
Start | Gets or sets the start point.

ContourLine Methods

ContourLine Methods
ContourLine Class Legend
ContourLine Methods
ContourLine Methods | Description
GetEnd | Gets the end point in a plane.
GetPointList | Gets the list of points.
GetStart | Gets the start point in a plane.
MultiplyLengthDim | Multiplies length dimensions by the coefficient.
Transform | Applies the specified transformation to the element.
Translate | Applies the specified translation vector to the element.

ContourLine Properties

ContourLine Properties
ContourLine Class Legend
ContourLine Properties
ContourLine Properties | Description
End | Gets or sets the end point.
Start | Gets or sets the start point.

ContourLine Class Public Methods

ContourLine Class Public Methods
ContourLine Class Legend
Public Methods
Public Method | Description
ContourLine | Initializes a new instance of the ContourLine class.
ContourLine | Initializes a new instance of the ContourLine class.
ContourLine | Initializes a new instance of the ContourLine class.
ContourLine | Initializes a new instance of the ContourLine class.
ContourLine | Initializes a new instance of the ContourLine class.

Legend

Legend
REXSectionTypeAnalyzer Class
Legend
Constructor
static
virtual

REXSectionTypeAnalyzer Class Members

REXSectionTypeAnalyzer Class Members
REXSectionTypeAnalyzer Class Legend
Members
Public Methods
Public Method | Description
REXSectionTypeAnalyzer | This is REXSectionTypeAnalyzer, a member of class REXSectionTypeAnalyzer.
REXSectionTypeAnalyzer Methods
REXSectionTypeAnalyzer Methods | Description
BuildVectorShape | This is BuildVectorShape, a member of class REXSectionTypeAnalyzer.
FitCompoundProfilePattern | This is FitCompoundProfilePattern, a member of class REXSectionTypeAnalyzer.
GetMaximumLength | This is GetMaximumLength, a member of class REXSectionTypeAnalyzer.
GetNextIndex | This is GetNextIndex, a member of class REXSectionTypeAnalyzer.
GetParametricDescription | This is GetParametricDescription, a member of class REXSectionTypeAnalyzer.
GetParametricDescription | This is GetParametricDescription, a member of class REXSectionTypeAnalyzer.
GetPreviousIndex | This is GetPreviousIndex, a member of class REXSectionTypeAnalyzer.
ReorderShape | This is ReorderShape, a member of class REXSectionTypeAnalyzer.
RepairCompoundSectionProfile | This is RepairCompoundSectionProfile, a member of class REXSectionTypeAnalyzer.
RepairSectionProfile | This is RepairSectionProfile, a member of class REXSectionTypeAnalyzer.
RepairShapeCounterClockWise | This is RepairShapeCounterClockWise, a member of class REXSectionTypeAnalyzer.
RepairShapeDue2BoundingBox | This is RepairShapeDue2BoundingBox, a member of class REXSectionTypeAnalyzer.
RepairShapeLines | This is RepairShapeLines, a member of class REXSectionTypeAnalyzer.
TransformCompoundProfile | This is TransformCompoundProfile, a member of class REXSectionTypeAnalyzer.
TransformProfile | This is TransformProfile, a member of class REXSectionTypeAnalyzer.
TransformShape | This is TransformShape, a member of class REXSectionTypeAnalyzer.
ValidateCircle | This is ValidateCircle, a member of class REXSectionTypeAnalyzer.
ValidateCircle | This is ValidateCircle, a member of class REXSectionTypeAnalyzer.
VectorDrivenAnalysis | This is VectorDrivenAnalysis, a member of class REXSectionTypeAnalyzer.

Members

Legend
Legend
Constructor
static
virtual

REXSectionTypeAnalyzer Methods

REXSectionTypeAnalyzer Methods
REXSectionTypeAnalyzer Class Legend
REXSectionTypeAnalyzer Methods
REXSectionTypeAnalyzer Methods | Description
BuildVectorShape | This is BuildVectorShape, a member of class REXSectionTypeAnalyzer.
FitCompoundProfilePattern | This is FitCompoundProfilePattern, a member of class REXSectionTypeAnalyzer.
GetMaximumLength | This is GetMaximumLength, a member of class REXSectionTypeAnalyzer.
GetNextIndex | This is GetNextIndex, a member of class REXSectionTypeAnalyzer.
GetParametricDescription | This is GetParametricDescription, a member of class REXSectionTypeAnalyzer.
GetParametricDescription | This is GetParametricDescription, a member of class REXSectionTypeAnalyzer.
GetPreviousIndex | This is GetPreviousIndex, a member of class REXSectionTypeAnalyzer.
ReorderShape | This is ReorderShape, a member of class REXSectionTypeAnalyzer.
RepairCompoundSectionProfile | This is RepairCompoundSectionProfile, a member of class REXSectionTypeAnalyzer.
RepairSectionProfile | This is RepairSectionProfile, a member of class REXSectionTypeAnalyzer.
RepairShapeCounterClockWise | This is RepairShapeCounterClockWise, a member of class REXSectionTypeAnalyzer.
RepairShapeDue2BoundingBox | This is RepairShapeDue2BoundingBox, a member of class REXSectionTypeAnalyzer.
RepairShapeLines | This is RepairShapeLines, a member of class REXSectionTypeAnalyzer.
TransformCompoundProfile | This is TransformCompoundProfile, a member of class REXSectionTypeAnalyzer.
TransformProfile | This is TransformProfile, a member of class REXSectionTypeAnalyzer.
TransformShape | This is TransformShape, a member of class REXSectionTypeAnalyzer.
ValidateCircle | This is ValidateCircle, a member of class REXSectionTypeAnalyzer.
ValidateCircle | This is ValidateCircle, a member of class REXSectionTypeAnalyzer.
VectorDrivenAnalysis | This is VectorDrivenAnalysis, a member of class REXSectionTypeAnalyzer.

Methods (AutoDoc Folder)

Legend
Legend
Method
static
virtual

REXSectionTypeAnalyzer Class Public Methods

REXSectionTypeAnalyzer Class Public Methods
REXSectionTypeAnalyzer Class Legend
Public Methods
Public Method | Description
REXSectionTypeAnalyzer | This is REXSectionTypeAnalyzer, a member of class REXSectionTypeAnalyzer.

Legend

Legend
REXSectionTypeAnalyzer_ROUND Class
Legend
Method
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXSectionTypeAnalyzer_ROUND Class Members

REXSectionTypeAnalyzer_ROUND Class Members
REXSectionTypeAnalyzer_ROUND Class Legend
Members
REXSectionTypeAnalyzer_ROUND Methods
REXSectionTypeAnalyzer_ROUND Methods | Description
GetParametricDescription | This is GetParametricDescription, a member of class REXSectionTypeAnalyzer_ROUND.
GetParametricDescription | This is GetParametricDescription, a member of class REXSectionTypeAnalyzer_ROUND.
VectorDrivenAnalysis | This is VectorDrivenAnalysis, a member of class REXSectionTypeAnalyzer_ROUND.

REXSectionTypeAnalyzer_ROUND Methods

REXSectionTypeAnalyzer_ROUND Methods
REXSectionTypeAnalyzer_ROUND Class Legend
REXSectionTypeAnalyzer_ROUND Methods
REXSectionTypeAnalyzer_ROUND Methods | Description
GetParametricDescription | This is GetParametricDescription, a member of class REXSectionTypeAnalyzer_ROUND.
GetParametricDescription | This is GetParametricDescription, a member of class REXSectionTypeAnalyzer_ROUND.
VectorDrivenAnalysis | This is VectorDrivenAnalysis, a member of class REXSectionTypeAnalyzer_ROUND.

Legend

Legend
REXSectionTypeAnalyzer_ROUNDH Class
Legend
Method