REXLabelDescription.REXLabelDescription Constructor ()

REXLabelDescription.REXLabelDescription Constructor ()
REXLabelDescription Class REX.ContentGenerator.Families Namespace REXLabelDescription Class

Initializes a new instance of the REXLabelDescription class.

C#
public REXLabelDescription();
Description
Class

REXLabelDescription Class

Links
REXLabelDescription Class, REX.ContentGenerator.Families Namespace, REXLabelDescription Class

REXLabelDescription.REXLabelDescription Constructor (ECategoryType, string)

REXLabelDescription.REXLabelDescription Constructor (ECategoryType, string)
REXLabelDescription Class REX.ContentGenerator.Families Namespace REXLabelDescription Class

Initializes a new instance of the REXLabelDescription class.

C#
public REXLabelDescription(ECategoryType cat, string name);
Parameters
Parameters | Description
cat | The category.
name | The name.
Description
Class

REXLabelDescription Class

Links
REXLabelDescription Class, REX.ContentGenerator.Families Namespace, REXLabelDescription Class

REXLabelDescription.REXLabelDescription Constructor (REXLabelDescription)

REXLabelDescription.REXLabelDescription Constructor (REXLabelDescription)
REXLabelDescription Class REX.ContentGenerator.Families Namespace REXLabelDescription Class

Initializes a new instance of the REXLabelDescription class.

C#
public REXLabelDescription(REXLabelDescription pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

REXLabelDescription Class

Links
REXLabelDescription Class, REX.ContentGenerator.Families Namespace, REXLabelDescription Class

REXLabelDescription.Clone Method

REXLabelDescription.Clone Method
REXLabelDescription Class REX.ContentGenerator.Families Namespace REXLabelDescription Class

Creates a new object that is a copy of the current instance.

C#
public override object Clone();
Returns

A new object that is a copy of this instance.

Description
Class

REXLabelDescription Class

Links
REXLabelDescription Class, REX.ContentGenerator.Families Namespace, REXLabelDescription Class

REXLabelDescription.CompareTo Method

REXLabelDescription.CompareTo Method
REXLabelDescription Class REX.ContentGenerator.Families Namespace REXLabelDescription Class

Compares the current object with the other object.

C#
public override int CompareTo(object obj);
Parameters
Parameters | Description
obj | The object.
Returns

Returns the result of the comparison.

Description
Class

REXLabelDescription Class

Links
REXLabelDescription Class, REX.ContentGenerator.Families Namespace, REXLabelDescription Class

REXLabelDescription.GetName Method

REXLabelDescription.GetName Method
REXLabelDescription Class REX.ContentGenerator.Families Namespace REXLabelDescription Class

Gets the name.

C#
public override string GetName();
Returns

The name.

Description
Class

REXLabelDescription Class

Links
REXLabelDescription Class, REX.ContentGenerator.Families Namespace, REXLabelDescription Class

REXLabelDescription.Category Property

REXLabelDescription.Category Property
REXLabelDescription Class REX.ContentGenerator.Families Namespace REXLabelDescription Class

Gets or sets the category.

C#
public ECategoryType Category;
Description

The category.

Class

REXLabelDescription Class

Links
REXLabelDescription Class, REX.ContentGenerator.Families Namespace, REXLabelDescription Class

REXLabelDescription.LabelFamilyDescription Property

REXLabelDescription.LabelFamilyDescription Property
REXLabelDescription Class REX.ContentGenerator.Families Namespace REXLabelDescription Class

Gets or sets the label family description.

C#
public REXFamilyType LabelFamilyDescription;
Description

The label family description.

Remarks

Label represents any type of the content. In the LabelFamilyDescription object can be placed element which is represented by the label (for mapping mainly - to draw sections).

Class

REXLabelDescription Class

Links
REXLabelDescription Class, REX.ContentGenerator.Families Namespace, REXLabelDescription Class

REXLabelDescription.Name Property

REXLabelDescription.Name Property
REXLabelDescription Class REX.ContentGenerator.Families Namespace REXLabelDescription Class

Gets or sets the name.

C#
public string Name;
Description

The name.

Class

REXLabelDescription Class

Links
REXLabelDescription Class, REX.ContentGenerator.Families Namespace, REXLabelDescription Class

REXMaterialCharacteristics Class

REXMaterialCharacteristics Class
REX.ContentGenerator.Families Namespace Legend Members Public Methods REXMaterialCharacteristics Methods REXMaterialCharacteristics Properties

Represents characteristics of a material.

Class Hierarchy
C#
[Serializable()]
public class REXMaterialCharacteristics : REXDescription;
Description
Namespace

REX.ContentGenerator.Families Namespace

Public Methods
Public Method | Description
REXMaterialCharacteristics | Initializes a new instance of the REXMaterialCharacteristics class.
REXMaterialCharacteristics | Initializes a new instance of the REXMaterialCharacteristics class.
REXMaterialCharacteristics | Initializes a new instance of the REXMaterialCharacteristics class.
REXMaterialCharacteristics | Initializes a new instance of the REXMaterialCharacteristics class.
REXMaterialCharacteristics Methods
REXMaterialCharacteristics Methods | Description
Clone | Creates a new object that is a copy of the current instance.
REXMaterialCharacteristics Properties
REXMaterialCharacteristics Properties | Description
CS | Gets or sets the reduction factor for shear for steel / Burning velocity (mm/min) (data specific for timber design according to CB71).
DAMPCOEF | Gets or sets the damping coefficient.
E | Gets or sets the E (Young's modulus).
GMEAN | Gets or sets the average modulus G.
KIRCHOFF | Gets or sets the shear modulus G.
LX | Gets or sets the thermal expansion coefficient.
NU | Gets or sets the Poisson's ratio.
RE | Gets or sets the design strength.
RE_AXCOMP | Gets or sets the axial compression resistance (for timber).
RE_AXTENS | Gets or sets the axial tension resistance (for timber).
RE_BENDING | Gets or sets the bending strength (for timber).
RE_SHEAR | Gets or sets the shear strength (for timber).
RE_TRCOMPR | Gets or sets the transversal compression resistance (for timber).
RE_TRTENS | Gets or sets the transversal tension resistance (for timber).
RO | Gets or sets the unit weight.
RT | Gets or sets the design tensile strength.
Links
REX.ContentGenerator.Families Namespace, Legend, Members, Public Methods, REXMaterialCharacteristics Methods, REXMaterialCharacteristics Properties

REXMaterialCharacteristics.REXMaterialCharacteristics Constructor ()

REXMaterialCharacteristics.REXMaterialCharacteristics Constructor ()
REXMaterialCharacteristics Class REX.ContentGenerator.Families Namespace REXMaterialCharacteristics Class

Initializes a new instance of the REXMaterialCharacteristics class.

C#
public REXMaterialCharacteristics();
Description
Class

REXMaterialCharacteristics Class

Links
REXMaterialCharacteristics Class, REX.ContentGenerator.Families Namespace, REXMaterialCharacteristics Class

REXMaterialCharacteristics.REXMaterialCharacteristics Constructor (DTableDataObjectCollection)

REXMaterialCharacteristics.REXMaterialCharacteristics Constructor (DTableDataObjectCollection)
REXMaterialCharacteristics Class REX.ContentGenerator.Families Namespace REXMaterialCharacteristics Class

Initializes a new instance of the REXMaterialCharacteristics class.

C#
public REXMaterialCharacteristics(DTableDataObjectCollection pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

REXMaterialCharacteristics Class

Links
REXMaterialCharacteristics Class, REX.ContentGenerator.Families Namespace, REXMaterialCharacteristics Class

REXMaterialCharacteristics.REXMaterialCharacteristics Constructor (REXMaterialCharacteristics)

REXMaterialCharacteristics.REXMaterialCharacteristics Constructor (REXMaterialCharacteristics)