Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REX.ContentGenerator.Families Namespace Structs, Records, Enums

REX.ContentGenerator.Families Namespace Structs, Records, Enums
REX.ContentGenerator.Families Namespace Legend
Structs, Records, Enums
Struct, Record, Enum | Description
ECategoryType | Describes the category of the element
EDBSectionType | Describes the type of the database section.
EElementType | Describes the type of the element
EMaterial | Describes the type of material
ESectionType |

Legend

Legend
REXCustomDescription Class
Legend
Constructor
abstract

REXCustomDescription Class Members

REXCustomDescription Class Members
REXCustomDescription Class Legend
Members
Public Methods
Public Method | Description
REXCustomDescription | Initializes a new instance of the REXCustomDescription class.
REXCustomDescription | Initializes a new instance of the REXCustomDescription class.
REXCustomDescription Methods
REXCustomDescription Methods | Description
Clone | Clones this instance.
GetTypeName | Gets the name of the type.

Members

Legend
Legend
Constructor
abstract

REXCustomDescription Methods

REXCustomDescription Methods
REXCustomDescription Class Legend
REXCustomDescription Methods
REXCustomDescription Methods | Description
Clone | Clones this instance.
GetTypeName | Gets the name of the type.

Methods (AutoDoc Folder)

Legend
Legend
Method
abstract

REXCustomDescription Class Public Methods

REXCustomDescription Class Public Methods
REXCustomDescription Class Legend
Public Methods
Public Method | Description
REXCustomDescription | Initializes a new instance of the REXCustomDescription class.
REXCustomDescription | Initializes a new instance of the REXCustomDescription class.

Legend

Legend
REXDBDescription Class
Legend
Constructor
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXDBDescription Class Members

REXDBDescription Class Members
REXDBDescription Class Legend
Members
Public Methods
Public Method | Description
REXDBDescription | Initializes a new instance of the REXDBDescription class.
REXDBDescription | Initializes a new instance of the REXDBDescription class.
REXDBDescription | Initializes a new instance of the REXDBDescription class.
REXDBDescription | Initializes a new instance of the REXDBDescription class.
REXDBDescription | Initializes a new instance of the REXDBDescription class.
REXDBDescription | Initializes a new instance of the REXDBDescription class.
REXDBDescription Methods
REXDBDescription Methods | Description
Clone | Creates a new object that is a copy of the current instance.
CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
GetValue | Gets the value.
RecalculateParameters | Recalculates the parameters.
SetValue | Sets the value.
REXDBDescription Properties
REXDBDescription Properties | Description
DBName | Gets or sets the name of the DB.
Directory | Gets or sets the directory.

REXDBDescription Methods

REXDBDescription Methods
REXDBDescription Class Legend
REXDBDescription Methods
REXDBDescription Methods | Description
Clone | Creates a new object that is a copy of the current instance.
CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
GetValue | Gets the value.
RecalculateParameters | Recalculates the parameters.
SetValue | Sets the value.

REXDBDescription Properties

REXDBDescription Properties
REXDBDescription Class Legend
REXDBDescription Properties
REXDBDescription Properties | Description
DBName | Gets or sets the name of the DB.
Directory | Gets or sets the directory.

REXDBDescription Class Public Methods

REXDBDescription Class Public Methods
REXDBDescription Class Legend
Public Methods
Public Method | Description
REXDBDescription | Initializes a new instance of the REXDBDescription class.
REXDBDescription | Initializes a new instance of the REXDBDescription class.
REXDBDescription | Initializes a new instance of the REXDBDescription class.
REXDBDescription | Initializes a new instance of the REXDBDescription class.
REXDBDescription | Initializes a new instance of the REXDBDescription class.
REXDBDescription | Initializes a new instance of the REXDBDescription class.

Legend

Legend
REXDescription Class
Legend
Constructor
abstract
virtual

REXDescription Class Members

REXDescription Class Members
REXDescription Class Legend
Members
Public Methods
Public Method | Description
REXDescription | Initializes a new instance of the REXDescription class.
REXDescription | Initializes a new instance of the REXDescription class.
REXDescription | Initializes a new instance of the REXDescription class.
REXDescription | Initializes a new instance of the REXDescription class.
REXDescription Methods
REXDescription Methods | Description
Clone | Creates a new object that is a copy of the current instance.
CompareProperty | This is CompareProperty, a member of class REXDescription.
CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
GetEnumerator | Returns an enumerator that iterates through a collection.
GetValue | Gets the value.
RecalculateParameters | Recalculates the parameters.
Set2Null | Sets all values to default one.
SetValue | Sets the value.

Members

Legend
Legend
Constructor
abstract
virtual

REXDescription Methods

REXDescription Methods
REXDescription Class Legend
REXDescription Methods
REXDescription Methods | Description
Clone | Creates a new object that is a copy of the current instance.
CompareProperty | This is CompareProperty, a member of class REXDescription.
CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
GetEnumerator | Returns an enumerator that iterates through a collection.
GetValue | Gets the value.
RecalculateParameters | Recalculates the parameters.
Set2Null | Sets all values to default one.
SetValue | Sets the value.

Methods (AutoDoc Folder)

Legend
Legend
Method
abstract
virtual

REXDescription Class Public Methods

REXDescription Class Public Methods
REXDescription Class Legend
Public Methods
Public Method | Description
REXDescription | Initializes a new instance of the REXDescription class.
REXDescription | Initializes a new instance of the REXDescription class.
REXDescription | Initializes a new instance of the REXDescription class.
REXDescription | Initializes a new instance of the REXDescription class.

Legend

Legend
REXFamilyType Class
Legend
Constructor
virtual
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXFamilyType Class Members

REXFamilyType Class Members
REXFamilyType Class Legend
Members
Public Methods
Public Method | Description
REXFamilyType | Initializes a new instance of the REXFamilyType class.
REXFamilyType | Initializes a new instance of the REXFamilyType class.
REXFamilyType | Initializes a new instance of the REXFamilyType class.
REXFamilyType Methods