REXFamilyType_ParamSection.REXFamilyType_ParamSection Constructor (REXFamilyType_ParamSection)
REXFamilyType_ParamSection Class REX.ContentGenerator.Families Namespace REXFamilyType_ParamSection Class

Initializes a new instance of the REXFamilyType_ParamSection class.

C#
public REXFamilyType_ParamSection(REXFamilyType_ParamSection pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

REXFamilyType_ParamSection Class

Links
REXFamilyType_ParamSection Class, REX.ContentGenerator.Families Namespace, REXFamilyType_ParamSection Class

REXFamilyType_ParamSection.REXFamilyType_ParamSection Constructor (string, string, REX.ContentGenerator.Families.EElementType, bool, EMaterial)

REXFamilyType_ParamSection.REXFamilyType_ParamSection Constructor (string, string, REX.ContentGenerator.Families.EElementType, bool, EMaterial)
REXFamilyType_ParamSection Class REX.ContentGenerator.Families Namespace REXFamilyType_ParamSection Class

Initializes a new instance of the REXFamilyType_ParamSection class.

C#
public REXFamilyType_ParamSection(string familyName, string typeName, REX.ContentGenerator.Families.EElementType category, bool certified, EMaterial material);
Parameters
Parameters | Description
familyName | The name of the family.
typeName | The name of the type.
category | The category.
certified | Indicates whether the object is certified.
material | The material.
Description
Class

REXFamilyType_ParamSection Class

Links
REXFamilyType_ParamSection Class, REX.ContentGenerator.Families Namespace, REXFamilyType_ParamSection Class

REXFamilyType_ParamSection.Clone Method

REXFamilyType_ParamSection.Clone Method
REXFamilyType_ParamSection Class REX.ContentGenerator.Families Namespace REXFamilyType_ParamSection Class

Creates a new object that is a copy of the current instance.

C#
public override object Clone();
Returns

A new object that is a copy of this instance.

Description
Class

REXFamilyType_ParamSection Class

Links
REXFamilyType_ParamSection Class, REX.ContentGenerator.Families Namespace, REXFamilyType_ParamSection Class

REXFamilyType_ParamSection.CompareTo Method

REXFamilyType_ParamSection.CompareTo Method
REXFamilyType_ParamSection Class REX.ContentGenerator.Families Namespace REXFamilyType_ParamSection Class

Compares the current object with the other object.

C#
public override int CompareTo(object obj);
Parameters
Parameters | Description
obj | The object.
Returns

Returns the result of the comparison.

Description
Class

REXFamilyType_ParamSection Class

Links
REXFamilyType_ParamSection Class, REX.ContentGenerator.Families Namespace, REXFamilyType_ParamSection Class

REXFamilyType_ParamSection.GetMaterialDependence Method

REXFamilyType_ParamSection.GetMaterialDependence Method
REXFamilyType_ParamSection Class REX.ContentGenerator.Families Namespace REXFamilyType_ParamSection Class

Gets the material dependence.

C#
public bool GetMaterialDependence();
Description
Class

REXFamilyType_ParamSection Class

Links
REXFamilyType_ParamSection Class, REX.ContentGenerator.Families Namespace, REXFamilyType_ParamSection Class

REXFamilyType_ParamSection.CategoryType Property

REXFamilyType_ParamSection.CategoryType Property
REXFamilyType_ParamSection Class REX.ContentGenerator.Families Namespace REXFamilyType_ParamSection Class

Gets the category.

C#
public override ECategoryType CategoryType;
Description

The category.

Class

REXFamilyType_ParamSection Class

Links
REXFamilyType_ParamSection Class, REX.ContentGenerator.Families Namespace, REXFamilyType_ParamSection Class

REXFamilyType_ParamSection.Parameters Property

REXFamilyType_ParamSection.Parameters Property
REXFamilyType_ParamSection Class REX.ContentGenerator.Families Namespace REXFamilyType_ParamSection Class

Gets or sets the parameters.

C#
public REXSectionParamDescription Parameters;
Description

The parameters.

Class

REXFamilyType_ParamSection Class

Links
REXFamilyType_ParamSection Class, REX.ContentGenerator.Families Namespace, REXFamilyType_ParamSection Class

REXFamilyType_Section Class

REXFamilyType_Section Class
REX.ContentGenerator.Families Namespace Legend Members Public Methods

Base class for all sections.

Class Hierarchy
C#
[Serializable()]
public class REXFamilyType_Section : REXFamilyType;
Description
Namespace

REX.ContentGenerator.Families Namespace

Public Methods
Public Method | Description
REXFamilyType_Section | Initializes a new instance of the REXFamilyType_Section class.
REXFamilyType_Section | Initializes a new instance of the REXFamilyType_Section class.
REXFamilyType_Section | Initializes a new instance of the REXFamilyType_Section class.
Links
REX.ContentGenerator.Families Namespace, Legend, Members, Public Methods

REXFamilyType_Section.REXFamilyType_Section Constructor ()

REXFamilyType_Section.REXFamilyType_Section Constructor ()
REXFamilyType_Section Class REX.ContentGenerator.Families Namespace REXFamilyType_Section Class

Initializes a new instance of the REXFamilyType_Section class.

C#
public REXFamilyType_Section();
Description
Class

REXFamilyType_Section Class

Links
REXFamilyType_Section Class, REX.ContentGenerator.Families Namespace, REXFamilyType_Section Class

REXFamilyType_Section.REXFamilyType_Section Constructor (REXFamilyType_Section)

REXFamilyType_Section.REXFamilyType_Section Constructor (REXFamilyType_Section)
REXFamilyType_Section Class REX.ContentGenerator.Families Namespace REXFamilyType_Section Class

Initializes a new instance of the REXFamilyType_Section class.

C#
public REXFamilyType_Section(REXFamilyType_Section pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

REXFamilyType_Section Class

Links
REXFamilyType_Section Class, REX.ContentGenerator.Families Namespace, REXFamilyType_Section Class

REXFamilyType_Section.REXFamilyType_Section Constructor (string, string, REX.ContentGenerator.Families.EElementType, bool, EMaterial)

REXFamilyType_Section.REXFamilyType_Section Constructor (string, string, REX.ContentGenerator.Families.EElementType, bool, EMaterial)
REXFamilyType_Section Class REX.ContentGenerator.Families Namespace REXFamilyType_Section Class

Initializes a new instance of the REXFamilyType_Section class.

C#
public REXFamilyType_Section(string familyName, string typeName, REX.ContentGenerator.Families.EElementType category, bool certified, EMaterial material);
Parameters
Parameters | Description
familyName | Name of the family.
typeName | Name of the type.
category | The category.
certified | Indicates whether the object is certified.
material | The material.
Description
Class

REXFamilyType_Section Class

Links
REXFamilyType_Section Class, REX.ContentGenerator.Families Namespace, REXFamilyType_Section Class

REXLabelDescription Class

REXLabelDescription Class
REX.ContentGenerator.Families Namespace Legend Members Public Methods REXLabelDescription Methods REXLabelDescription Properties

Represents label's parameters.

Class Hierarchy
C#
public class REXLabelDescription : REXDescription;
Description
Namespace

REX.ContentGenerator.Families Namespace

Public Methods
Public Method | Description
REXLabelDescription | Initializes a new instance of the REXLabelDescription class.
REXLabelDescription | Initializes a new instance of the REXLabelDescription class.
REXLabelDescription | Initializes a new instance of the REXLabelDescription class.
REXLabelDescription Methods
REXLabelDescription Methods | Description
Clone | Creates a new object that is a copy of the current instance.
CompareTo | Compares the current object with the other object.
GetName | Gets the name.
REXLabelDescription Properties
REXLabelDescription Properties | Description
Category | Gets or sets the category.
LabelFamilyDescription | Gets or sets the label family description.
Name | Gets or sets the name.
Links
REX.ContentGenerator.Families Namespace, Legend, Members, Public Methods, REXLabelDescription Methods, REXLabelDescription Properties