Contour_Section | Initializes a new instance of the Contour_Section class.
Contour_Section | Initializes a new instance of the Contour_Section class.
Contour_Section | Initializes a new instance of the Contour_Section class.

Legend

Legend
ContourArc Class
Legend
Constructor
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

ContourArc Class Members

ContourArc Class Members
ContourArc Class Legend
Members
Public Methods
Public Method | Description
ContourArc | Initializes a new instance of the ContourArc2> class.
ContourArc | Initializes a new instance of the ContourArc2 class.
ContourArc | Initializes a new instance of the ContourArc2> class.
ContourArc | This is ContourArc, a member of class ContourArc.
ContourArc | Initializes a new instance of the ContourArc2 class.
ContourArc Methods
ContourArc Methods | Description
GetCenter | Gets the center of the arc.
GetCenter | Gets the center of the arc.
GetEnd | Gets the end.
GetMiddlePoint | Gets the middle point.
GetPointList | Gets the list of points.
GetStart | Gets the start.
MultiplyLengthDim | Multiplies length dimensions by the coefficient.
Transform | Applies the specified transformation to the element.
Translate | Applies the specified translation vector to the element.
ContourArc Properties
ContourArc Properties | Description
End | Gets or sets the end.
Middle | Gets or sets the middle.
Start | Gets or sets the start.

ContourArc Methods

ContourArc Methods
ContourArc Class Legend
ContourArc Methods
ContourArc Methods | Description
GetCenter | Gets the center of the arc.
GetCenter | Gets the center of the arc.
GetEnd | Gets the end.
GetMiddlePoint | Gets the middle point.
GetPointList | Gets the list of points.
GetStart | Gets the start.
MultiplyLengthDim | Multiplies length dimensions by the coefficient.
Transform | Applies the specified transformation to the element.
Translate | Applies the specified translation vector to the element.

ContourArc Properties

ContourArc Properties
ContourArc Class Legend
ContourArc Properties
ContourArc Properties | Description
End | Gets or sets the end.
Middle | Gets or sets the middle.
Start | Gets or sets the start.

ContourArc Class Public Methods

ContourArc Class Public Methods
ContourArc Class Legend
Public Methods
Public Method | Description
ContourArc | Initializes a new instance of the ContourArc2> class.
ContourArc | Initializes a new instance of the ContourArc2 class.
ContourArc | Initializes a new instance of the ContourArc2> class.
ContourArc | This is ContourArc, a member of class ContourArc.
ContourArc | Initializes a new instance of the ContourArc2 class.

Legend

Legend
ContourCircle Class
Legend
Constructor
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

ContourCircle Class Members

ContourCircle Class Members
ContourCircle Class Legend
Members
Public Methods
Public Method | Description
ContourCircle | Initializes a new instance of the ContourCircle class.
ContourCircle | Initializes a new instance of the ContourCircle class.
ContourCircle | Initializes a new instance of the ContourCircle class.
ContourCircle | Initializes a new instance of the ContourCircle class.
ContourCircle Methods
ContourCircle Methods | Description
GetPointList | Gets the list of points.
GetStart | Gets the start (center).
MultiplyLengthDim | Multiplies length dimensions by the coefficient.
Translate | Applies the specified translation vector to the element.
ContourCircle Properties
ContourCircle Properties | Description
Center | Gets or sets the start (center).
R | Gets or sets the radius.

ContourCircle Methods

ContourCircle Methods
ContourCircle Class Legend
ContourCircle Methods
ContourCircle Methods | Description
GetPointList | Gets the list of points.
GetStart | Gets the start (center).
MultiplyLengthDim | Multiplies length dimensions by the coefficient.
Translate | Applies the specified translation vector to the element.

ContourCircle Properties

ContourCircle Properties
ContourCircle Class Legend
ContourCircle Properties
ContourCircle Properties | Description
Center | Gets or sets the start (center).
R | Gets or sets the radius.

ContourCircle Class Public Methods

ContourCircle Class Public Methods
ContourCircle Class Legend
Public Methods
Public Method | Description
ContourCircle | Initializes a new instance of the ContourCircle class.
ContourCircle | Initializes a new instance of the ContourCircle class.
ContourCircle | Initializes a new instance of the ContourCircle class.
ContourCircle | Initializes a new instance of the ContourCircle class.

Legend

Legend
ContourCont Class
Legend
Constructor
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

ContourCont Class Members

ContourCont Class Members
ContourCont Class Legend
Members
Public Methods
Public Method | Description
ContourCont | Initializes a new instance of the ContourCont class.
ContourCont | Initializes a new instance of the ContourCont class.
ContourCont | Initializes a new instance of the ContourCont class.
ContourCont | Initializes a new instance of the ContourCont class.
ContourCont Methods
ContourCont Methods | Description
GetGeometryParams | Gets the geometry params.
GetPointList | Gets the list of points.
IsContourInsideMe | Determines whether the contour is inside current one.
MultiplyLengthDim | Multiplies length dimensions by the coefficient.
Transform | Applies the specified transformation to the element.
Translate | Applies the specified translation vector to the element.
ContourCont Properties
ContourCont Properties | Description
ContList | Gets or sets the list of contours.
ElemList | Gets or sets the list of elements.
Hole | Gets or sets a value indicating whether this contour is a hole.

ContourCont Methods

ContourCont Methods
ContourCont Class Legend
ContourCont Methods
ContourCont Methods | Description
GetGeometryParams | Gets the geometry params.
GetPointList | Gets the list of points.
IsContourInsideMe | Determines whether the contour is inside current one.
MultiplyLengthDim | Multiplies length dimensions by the coefficient.
Transform | Applies the specified transformation to the element.
Translate | Applies the specified translation vector to the element.

ContourCont Properties

ContourCont Properties
ContourCont Class Legend
ContourCont Properties
ContourCont Properties | Description
ContList | Gets or sets the list of contours.
ElemList | Gets or sets the list of elements.
Hole | Gets or sets a value indicating whether this contour is a hole.

ContourCont Class Public Methods

ContourCont Class Public Methods
ContourCont Class Legend
Public Methods
Public Method | Description
ContourCont | Initializes a new instance of the ContourCont class.
ContourCont | Initializes a new instance of the ContourCont class.
ContourCont | Initializes a new instance of the ContourCont class.
ContourCont | Initializes a new instance of the ContourCont class.

Legend

Legend
ContourDimension Class
Legend
Constructor
virtual
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

ContourDimension Class Members

ContourDimension Class Members
ContourDimension Class Legend
Members
Public Methods
Public Method | Description
ContourDimension | Initializes a new instance of the ContourDimension class.