public bool List;
Description

True if the list is visible; otherwise, false.

Class

REXContentMapDialogSettings Class

Links
REXContentMapDialogSettings Class, REX.ContentGenerator.Map Namespace, REXContentMapDialogSettings Class

REXContentMapDialogSettings.Mapper Property

REXContentMapDialogSettings.Mapper Property
REXContentMapDialogSettings Class REX.ContentGenerator.Map Namespace REXContentMapDialogSettings Class

Gets the mapper.

C#
public ContentMapper Mapper;
Description

The mapper.

Class

REXContentMapDialogSettings Class

Links
REXContentMapDialogSettings Class, REX.ContentGenerator.Map Namespace, REXContentMapDialogSettings Class

REXContentMapDialogSettings.MaterialSettings Property

REXContentMapDialogSettings.MaterialSettings Property
REXContentMapDialogSettings Class REX.ContentGenerator.Map Namespace REXContentMapDialogSettings Class

Gets the material settings.

C#
public REXContentMapCategorySettings MaterialSettings;
Description

The material settings.

Class

REXContentMapDialogSettings Class

Links
REXContentMapDialogSettings Class, REX.ContentGenerator.Map Namespace, REXContentMapDialogSettings Class

REXContentMapDialogSettings.Menu Property

REXContentMapDialogSettings.Menu Property
REXContentMapDialogSettings Class REX.ContentGenerator.Map Namespace REXContentMapDialogSettings Class

Gets or sets a value indicating whether menu should be visible on the dialog.

C#
public bool Menu;
Description

True if menu is visible; otherwise, false.

Class

REXContentMapDialogSettings Class

Links
REXContentMapDialogSettings Class, REX.ContentGenerator.Map Namespace, REXContentMapDialogSettings Class

REXContentMapDialogSettings.NotAllMappedText Property

REXContentMapDialogSettings.NotAllMappedText Property
REXContentMapDialogSettings Class REX.ContentGenerator.Map Namespace REXContentMapDialogSettings Class

Gets or sets the text which should appear when validation didn't succeed (if CheckIfAllMappedBeforeLeave option).

C#
public string NotAllMappedText;
Description

The text.

Class

REXContentMapDialogSettings Class

Links
REXContentMapDialogSettings Class, REX.ContentGenerator.Map Namespace, REXContentMapDialogSettings Class

REXContentMapDialogSettings.RebarTypeSettings Property

REXContentMapDialogSettings.RebarTypeSettings Property
REXContentMapDialogSettings Class REX.ContentGenerator.Map Namespace REXContentMapDialogSettings Class

Gets the rebar type settings.

C#
public REXContentMapCategorySettingsRebarType RebarTypeSettings;
Description

The rebar type settings.

Class

REXContentMapDialogSettings Class

Links
REXContentMapDialogSettings Class, REX.ContentGenerator.Map Namespace, REXContentMapDialogSettings Class

REXContentMapDialogSettings.SectionSettings Property

REXContentMapDialogSettings.SectionSettings Property
REXContentMapDialogSettings Class REX.ContentGenerator.Map Namespace REXContentMapDialogSettings Class

Gets the section settings.

C#
public REXContentMapCategorySettings SectionSettings;
Description

The section settings.

Class

REXContentMapDialogSettings Class

Links
REXContentMapDialogSettings Class, REX.ContentGenerator.Map Namespace, REXContentMapDialogSettings Class

REXContentMapDialogSettings.ShowWhenNoElementsToMap Property

REXContentMapDialogSettings.ShowWhenNoElementsToMap Property
REXContentMapDialogSettings Class REX.ContentGenerator.Map Namespace REXContentMapDialogSettings Class

Gets or sets a value indicating whether dialog should appear when there are no elements to map.

C#
public bool ShowWhenNoElementsToMap;
Description

True if the dialog is shown when there is no elements to map; otherwise, false.

Class

REXContentMapDialogSettings Class

Links
REXContentMapDialogSettings Class, REX.ContentGenerator.Map Namespace, REXContentMapDialogSettings Class

REXContentMapper Class

REXContentMapper Class
REX.ContentGenerator.Map Namespace Legend Members REXContentMapper Fields REXContentMapper Methods

Provides interface to the mapping system of the Content Generator in REX context.

Class Hierarchy
C#
public class REXContentMapper : ContentMapper;
Description
Namespace

REX.ContentGenerator.Map Namespace

REXContentMapper Fields
REXContentMapper Fields | Description
valRexContext | This is valRexContext, a member of class REXContentMapper.
REXContentMapper Methods
REXContentMapper Methods | Description
GetMapElement | Gets the map element for the specified element.
SetMapElement | Sets the map element for specified element.
Links
REX.ContentGenerator.Map Namespace, Legend, Members, REXContentMapper Fields, REXContentMapper Methods

REXContentMapper.valRexContext Field

REXContentMapper.valRexContext Field
REXContentMapper Class REX.ContentGenerator.Map Namespace REXContentMapper Class

This is valRexContext, a member of class REXContentMapper.

C#
public const string valRexContext = "REX";
Class

REXContentMapper Class

Links
REXContentMapper Class, REX.ContentGenerator.Map Namespace, REXContentMapper Class

REXContentMapper.GetMapElement Method

REXContentMapper.GetMapElement Method
REXContentMapper Class REX.ContentGenerator.Map Namespace REXContentMapper Class

Gets the map element for the specified element.

C#
public REXFamilyType GetMapElement(REXFamilyType elem, ECategoryType type);
Parameters
Parameters | Description
elem | The element.
type | The type of the element.
Returns

The mapped REXFamilyType object.

Description
Class

REXContentMapper Class

Links
REXContentMapper Class, REX.ContentGenerator.Map Namespace, REXContentMapper Class

REXContentMapper.SetMapElement Method

REXContentMapper.SetMapElement Method
REXContentMapper Class REX.ContentGenerator.Map Namespace REXContentMapper Class

Sets the map element for specified element.

C#
public void SetMapElement(bool user, REXFamilyType elem, REXFamilyType fam, ECategoryType type);
Parameters
Parameters | Description
user | Indicates whether the user map should be used.
elem | The element.
fam | The mapped REXFamilyType object.
type | The type of the element.
Description
Class

REXContentMapper Class

Links
REXContentMapper Class, REX.ContentGenerator.Map Namespace, REXContentMapper Class

RVTContentMapper Class

RVTContentMapper Class
REX.ContentGenerator.Map Namespace Legend Members RVTContentMapper Fields RVTContentMapper Methods

Provides interface to the mapping system of the Content Generator in Revit context.

Class Hierarchy
C#
public class RVTContentMapper : ContentMapper;
Description
Namespace

REX.ContentGenerator.Map Namespace

RVTContentMapper Fields
RVTContentMapper Fields | Description
valRvtContext | This is valRvtContext, a member of class RVTContentMapper.
RVTContentMapper Methods
RVTContentMapper Methods | Description
GetMapElement | Gets the map element for specified Revit element.
SetMapElement | Sets the map element for specified Revit element.
Links
REX.ContentGenerator.Map Namespace, Legend, Members, RVTContentMapper Fields, RVTContentMapper Methods

RVTContentMapper.valRvtContext Field

RVTContentMapper.valRvtContext Field
RVTContentMapper Class REX.ContentGenerator.Map Namespace RVTContentMapper Class

This is valRvtContext, a member of class RVTContentMapper.

C#
public const string valRvtContext = "RVT";
Class

RVTContentMapper Class

Links
RVTContentMapper Class, REX.ContentGenerator.Map Namespace, RVTContentMapper Class

RVTContentMapper.GetMapElement Method

RVTContentMapper.GetMapElement Method
RVTContentMapper Class REX.ContentGenerator.Map Namespace RVTContentMapper Class

Gets the map element for specified Revit element.

C#
public REXFamilyType GetMapElement(RevitElement elem, ECategoryType type);
Parameters
Parameters | Description
elem | The element.
type | The type of the element.
Returns

The mapped REXFamilyType object.

Description
Class

RVTContentMapper Class

Links
RVTContentMapper Class, REX.ContentGenerator.Map Namespace, RVTContentMapper Class

RVTContentMapper.SetMapElement Method

RVTContentMapper.SetMapElement Method