WordWrap | Indicates whether a multiline text box control automatically wraps words to the beginning of the next line when necessary.
Links
REX.Controls.Forms Namespace, Legend, Members, Public Methods, REXEditBox Methods, REXEditBox Properties

REXEditBox.REXEditBox Constructor

REXEditBox.REXEditBox Constructor
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Initializes a new instance of the REXEditBox class.

C#
public REXEditBox();
Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class

REXEditBox.AddEnabledChangedHandler Method

REXEditBox.AddEnabledChangedHandler Method
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Adds the handler to the event raised when the element changes it's enable state.

C#
public void AddEnabledChangedHandler(EventHandler eh);
Parameters
Parameters | Description
eh | The event handler.
Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class

REXEditBox.AddLostFocusHandler Method

REXEditBox.AddLostFocusHandler Method
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Adds the handler to the event raised when the element loses logical focus.

C#
public void AddLostFocusHandler(EventHandler eh);
Parameters
Parameters | Description
eh | The event handler.
Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class

REXEditBox.AddTextChangedHandler Method

REXEditBox.AddTextChangedHandler Method
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Adds the handler to the event raised when text changes.

C#
public void AddTextChangedHandler(EventHandler eh);
Parameters
Parameters | Description
eh | The event handler.
Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class

REXEditBox.GetBackground Method

REXEditBox.GetBackground Method
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets the background of the control.

C#
public object GetBackground();
Returns

The background.

Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class

REXEditBox.GetComplexDoubleValue Method

REXEditBox.GetComplexDoubleValue Method
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets the complex (list) value of the double type.

C#
public List<double> GetComplexDoubleValue();
Returns

The list of values.

Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class

REXEditBox.GetComplexStringValue Method

REXEditBox.GetComplexStringValue Method
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Returns a complex string list.

C#
public List<string> GetComplexStringValue();
Returns

The list of values.

Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class

REXEditBox.GetEnable Method

REXEditBox.GetEnable Method
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Indicates whether the control is enabled.

C#
public bool GetEnable();
Returns

True if the element is enabled; otherwise, false.

Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class

REXEditBox.GetFullName Method

REXEditBox.GetFullName Method
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets the full name.

C#
public string GetFullName();
Returns

The full name.

Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class

REXEditBox.GetLastCorrectValueStr Method

REXEditBox.GetLastCorrectValueStr Method
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets the last correct stored value.

C#
public String GetLastCorrectValueStr();
Returns

The correct value.

Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class

REXEditBox.GetState Method

REXEditBox.GetState Method
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets the current state of the control.

C#
public EControlState GetState();
Returns

The state of the control.

Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class

REXEditBox.GetStringValue Method

REXEditBox.GetStringValue Method
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Returns the original text.

C#
public string GetStringValue();
Returns

The text value.

Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class

REXEditBox.GetText Method

REXEditBox.GetText Method
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets the text contents of the control.

C#
public string GetText();
Returns

The text contents of the control.

Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class

REXEditBox.GetUniqueName Method

REXEditBox.GetUniqueName Method
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Returns the Unique ID generated for the current instance of the engine.

C#
public string GetUniqueName();
Returns

The unique ID.

Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class

REXEditBox.GetValue Method

REXEditBox.GetValue Method
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets the value of the double type.

C#
public double GetValue();
Returns

The value.

Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class

REXEditBox.Refresh Method

REXEditBox.Refresh Method
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Refreshes the text on the control based on the current text.

C#
public void Refresh();
Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class

REXEditBox.RefreshValidationStatus Method

REXEditBox.RefreshValidationStatus Method
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Refreshes the validation status.

C#
public void RefreshValidationStatus();
Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class

REXEditBox.Reset Method

REXEditBox.Reset Method
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Resets control (internal values).

C#
public void Reset();
Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class

REXEditBox.SetBackground Method

REXEditBox.SetBackground Method
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Sets the background of the control.

C#
public void SetBackground(object color);
Parameters
Parameters | Description
background | The background.
Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class

REXEditBox.SetComplexValue Method (List<double>)

REXEditBox.SetComplexValue Method (List<double>)
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Sets the complex (list) value of the double type.

C#
public void SetComplexValue(List<double> values);
Parameters
Parameters | Description
values | The list of values.
Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class

REXEditBox.SetComplexValue Method (List<string>)

REXEditBox.SetComplexValue Method (List<string>)
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Sets the complex (list) value of the string type.

C#
public void SetComplexValue(List<string> values);
Parameters
Parameters | Description
values | The list of values.
Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class

REXEditBox.SetComplexValue Method (String)