REXFamilyConverter Class REX.ContentGenerator.Converters Namespace Example REXFamilyConverter Class

Gets the list of filtered elements in selected database.

C#
public List<REXFamilyType> GetFilteredFamilies(string dir, string dbName, REXContentFilter filter, ECategoryType type);
Parameters
Parameters | Description
dir | The directory.
dbName | The database.
filter | The filter.
type | The category of the element.
Returns

Returns the list of REXFamilyTypes.

Description
Example

The example shows how to get filtered sections from the Rcatptro database (of HEB NAME and height more than 0.4).

//Initializing the rex converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Database identification data.
string database = "Rcatpro";
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Prof";

REXContentParamFilter filterNAME = new REXContentParamFilter("NAME", "HEB", false, false, true);
REXContentParamFilter filterH = new REXContentParamFilter("H", 0.4, true, false, false);
REXContentLogicFilter filterLogic = new REXContentLogicFilter(REXContentLogicFilter.ELogicOperator.And, filterNAME, filterH);

//Getting the REXFamilyType from the database.
List<REXFamilyType> families = rex.GetFamilies(directory, database, filterLogic, ECategoryType.SECTION_DB);
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, REXFamilyConverter Class

REXFamilyConverter.GetFilteredFamilies Method (string, string, REXContentFilter, string)

REXFamilyConverter.GetFilteredFamilies Method (string, string, REXContentFilter, string)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace REXFamilyConverter Class

Gets the list of filtered elements in the selected database.

C#
public List<REXFamilyType> GetFilteredFamilies(string dir, string dbName, REXContentFilter filter, string customCategory);
Parameters
Parameters | Description
dir | The directory.
dbName | The database.
filter | The filter.
customCategory | The custom category.
Returns

Returns the list of REXFamilyTypes.

Description
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, REXFamilyConverter Class

REXFamilyConverter.GetNameForAlias Method

REXFamilyConverter.GetNameForAlias Method
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace REXFamilyConverter Class

Gets the certified name for the alias.

C#
public string GetNameForAlias(string alias, ECategoryType type);
Parameters
Parameters | Description
alias | The alias.
type | The type.
Returns

Returns the certified name.

Description
Remarks

This name exists in databases in NAME_REVIT column (sections), NAME (materials).

Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, REXFamilyConverter Class

REXFamilyConverter.GetRebar Method (List<REXxyz>, REXFamilyType_RebarBarType, bool, REXFamilyType_RebarHook, REXFamilyType_RebarHook, string)

REXFamilyConverter.GetRebar Method (List<REXxyz>, REXFamilyType_RebarBarType, bool, REXFamilyType_RebarHook, REXFamilyType_RebarHook, string)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace Example REXFamilyConverter Class

Gets the rebar object due to the defined contour, the bar's type and the shape's database.

C#
public REXFamilyType_Rebar GetRebar(List<REXxyz> contour3D, REXFamilyType_RebarBarType barType, bool stirrup, REXFamilyType_RebarHook hookStart, REXFamilyType_RebarHook hookEnd, string dbShapeName);
Parameters
Parameters | Description
contour3D | The contour of the rebar.
barType | The type of the rebar.
stirrup | If the rebar is a stirrup.
hookStart | The hook start.
hookEnd | The hook end.
dbShapeName | The name of the database.
Returns

Returns the rebar object.

Description
Example

The example shows how to get rebar object based on the specific contour.

//Initializing converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Rebar data (it can be taken from different sources e.g. Revit).
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Reinf";
REXFamilyType_RebarBarType famRebarType = rex.GetFamilyRebarType("Grade 40","#8","bar_ACI 318-08",directory);
REXFamilyType_RebarHook hookStart = new REXFamilyType_RebarHook();
hookStart.Parameters.Angle = EHookAngles.none;
REXFamilyType_RebarHook hookEnd = new REXFamilyType_RebarHook();
hookEnd.Parameters.Angle = EHookAngles.none;

//Contour.
List<REXxyz> l = new List<REXxyz>();
l.Add(new REXxyz(0, 0));
l.Add(new REXxyz(2, 0));
l.Add(new REXxyz(2, 1));

//Getting Rebar object from contour.
REXFamilyType_Rebar r = rex.GetRebar(l, famRebarType,false,hookStart,hookEnd,"barlib7_iso");

The rebar object can be used by other converters to create a rebar of the specific shape (e.g. RVTFamilyConverter: CreateRebar).

Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, REXFamilyConverter Class

REXFamilyConverter.GetRebar Method (List<REXxyz>, REXFamilyType_RebarBarType, bool, REXFamilyType_RebarHook, REXFamilyType_RebarHook, string, bool)

REXFamilyConverter.GetRebar Method (List<REXxyz>, REXFamilyType_RebarBarType, bool, REXFamilyType_RebarHook, REXFamilyType_RebarHook, string, bool)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace Example REXFamilyConverter Class

Gets the rebar object due to the defined contour, the bar's type and the shape's database.

C#
public REXFamilyType_Rebar GetRebar(List<REXxyz> contour3D, REXFamilyType_RebarBarType barType, bool stirrup, REXFamilyType_RebarHook hookStart, REXFamilyType_RebarHook hookEnd, string dbShapeName, bool closedShape);
Parameters
Parameters | Description
contour3D | The contour of the rebar.
barType | The type of the rebar.
stirrup | If the rebar is a stirrup.
hookStart | The hook start.
hookEnd | The hook end.
dbShapeName | The name of the database.
closedShape | If the rebar is closed.
Returns

Returns the rebar object.

Description
Example

The example shows how to get rebar object based on the specific contour.

//Initializing converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Rebar data (it can be taken from different sources e.g. Revit).
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Reinf";
REXFamilyType_RebarBarType famRebarType = rex.GetFamilyRebarType("Grade 40","#8","bar_ACI 318-08",directory);
REXFamilyType_RebarHook hookStart = new REXFamilyType_RebarHook();
hookStart.Parameters.Angle = EHookAngles.none;
REXFamilyType_RebarHook hookEnd = new REXFamilyType_RebarHook();
hookEnd.Parameters.Angle = EHookAngles.none;

//Contour.
List<REXxyz> l = new List<REXxyz>();
l.Add(new REXxyz(0, 0));
l.Add(new REXxyz(2, 0));
l.Add(new REXxyz(2, 1));
l.Add(new REXxyz(0, 1));
l.Add(new REXxyz(0, 0));

//Getting Rebar object from contour.
REXFamilyType_Rebar r = rex.GetRebar(l, famRebarType,false,hookStart,hookEnd,"barlib7_iso",true);

The rebar object can be used by other converters to create a rebar of the specific shape (e.g. RVTFamilyConverter: CreateRebar).

Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, REXFamilyConverter Class

REXFamilyConverter.GetRebar Method (List<REXxyz>, REXFamilyType_RebarBarType, bool, REXFamilyType_RebarHook, REXFamilyType_RebarHook, string, string)

REXFamilyConverter.GetRebar Method (List<REXxyz>, REXFamilyType_RebarBarType, bool, REXFamilyType_RebarHook, REXFamilyType_RebarHook, string, string)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace Example REXFamilyConverter Class

Gets the rebar object due to the defined contour, the bar's type and the shape's database.

C#