RVTFamilyConverter Class, REX.ContentGenerator.Converters Namespace, RVTFamilyConverter Class

RVTFamilyConverter.GetElements Method

RVTFamilyConverter.GetElements Method
RVTFamilyConverter Class REX.ContentGenerator.Converters Namespace Example RVTFamilyConverter Class

Gets the list of Revit elements created based on the list of REXFamilyTypes.

C#
public List<RevitElement> GetElements(List<REXFamilyType> list, ECategoryType category);
Parameters
Parameters | Description
list | The list of REXFamilyTypes.
category | The category of elements.
Returns

The list of Revit elements.

Description
Example

The example shows how to get the list of Revit elements based on the list of the REXFamilyType.

//Initialize the converter.
RVTFamilyConverter rvt = new RVTFamilyConverter(commandData, true);

rvt.EventElementGenerated += new ElementGenerated(rvt_EventElementGenerated);

List<REXFamilyType> families = new List<REXFamilyType>();

for (int i = 1; i < 4; i++)
{
    //creating parametric description
    REXFamilyType_ParamSection paramSection = new REXFamilyType_ParamSection();
    paramSection.ElementType = REX.ContentGenerator.Families.EElementType.BEAM;
    paramSection.Material = EMaterial.CONCRETE;
    paramSection.Parameters.SectionType = ESectionType.RECT;
    paramSection.Parameters.Tapered = false;
    paramSection.Parameters.Dimensions.h = i*0.2;
    paramSection.Parameters.Dimensions.b = i*0.1;
    paramSection.Parameters.CalculataMainAxisAndCharacteristics();
    paramSection.TypeName = "RECT" + i.ToString();
    families.Add(paramSection);
}

List<Element> elements = rvt.GetElements(families, ECategoryType.SECTION_PARAM);

static void rvt_EventElementGenerated(string id)
{
}
Class

RVTFamilyConverter Class

Links
RVTFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, RVTFamilyConverter Class

RVTFamilyConverter.GetExistingNames Method

RVTFamilyConverter.GetExistingNames Method
RVTFamilyConverter Class REX.ContentGenerator.Converters Namespace RVTFamilyConverter Class

Returns the list of names existing for specific REXFamilyType object.

C#
public List<string> GetExistingNames(REXFamilyType el, ECategoryType category, bool typeNames);
Parameters
Parameters | Description
el | The REXFamilyType object.
category | The category of the element.
typeNames | If names of types should be returned.
Returns

The list of names.

Description
Class

RVTFamilyConverter Class

Links
RVTFamilyConverter Class, REX.ContentGenerator.Converters Namespace, RVTFamilyConverter Class

RVTFamilyConverter.GetFamily Method (RevitElement)

RVTFamilyConverter.GetFamily Method (RevitElement)
RVTFamilyConverter Class REX.ContentGenerator.Converters Namespace Example RVTFamilyConverter Class

Gets the REXFamilyType object based on the input element.

C#
public REXFamilyType GetFamily(RevitElement el);
Parameters
Parameters | Description
el | The Revit element.
Returns

The REXFamilyType object.

Description
Example

The example shows how to get REXFamilyType from the element defined in Revit.

//Initializing the converter.
RVTFamilyConverter rvt = new RVTFamilyConverter(commandData, true);

//Investigation of selected FamilyInstances
foreach(Element el in commandData.Application.ActiveUIDocument.Selection.Elements)
{
    FamilyInstance famInstance = el as FamilyInstance;

    if (famInstance != null
       && (famInstance.StructuralType == Autodesk.Revit.DB.Structure.StructuralType.Beam
       || famInstance.StructuralType == Autodesk.Revit.DB.Structure.StructuralType.Brace
       || famInstance.StructuralType == Autodesk.Revit.DB.Structure.StructuralType.Column))
    {
        //Geting REXFamilyType object from the current element.
        REXFamilyType fam = rvt.GetFamily(famInstance);

        if (fam != null)
        {
            //parametric section
            REXFamilyType_ParamSection paramSection = fam as REXFamilyType_ParamSection;

            if (paramSection != null)
            {
                continue;
            }

            //database section
            REXFamilyType_DBSection dbSection = fam as REXFamilyType_DBSection;

            if (dbSection != null)
            {
               continue;
            }
        }
    }
}
Class

RVTFamilyConverter Class

Links
RVTFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, RVTFamilyConverter Class

RVTFamilyConverter.GetFamily Method (RevitElement, ECategoryType)

RVTFamilyConverter.GetFamily Method (RevitElement, ECategoryType)
RVTFamilyConverter Class REX.ContentGenerator.Converters Namespace Example RVTFamilyConverter Class

Gets the REXFamilyType object based on the input element.

C#
public REXFamilyType GetFamily(RevitElement el, ECategoryType category);
Parameters
Parameters | Description
el | The Revit element.
category | The category of the element.
Returns

The REXFamilyType object.

Description
Example

The example shows how to get REXFamilyType from the element defined in Revit.

//Initializing the converter.
RVTFamilyConverter rvt = new RVTFamilyConverter(commandData, true);

//Investigation of selected FamilyInstances
foreach(Element el in commandData.Application.ActiveUIDocument.Selection.Elements)
{
    FamilyInstance famInstance = el as FamilyInstance;

    if (famInstance != null
       && (famInstance.StructuralType == Autodesk.Revit.DB.Structure.StructuralType.Beam
       || famInstance.StructuralType == Autodesk.Revit.DB.Structure.StructuralType.Brace
       || famInstance.StructuralType == Autodesk.Revit.DB.Structure.StructuralType.Column))
    {
        //Geting REXFamilyType object from the current element.
        REXFamilyType fam = rvt.GetFamily(famInstance, ECategoryType.SECTION_PARAM);

        if (fam != null)
        {
            REXFamilyType_ParamSection paramSection = fam as REXFamilyType_ParamSection;
        }
    }
}
Class

RVTFamilyConverter Class

Links
RVTFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, RVTFamilyConverter Class

RVTFamilyConverter.GetFamily Method (RevitElement, string)

RVTFamilyConverter.GetFamily Method (RevitElement, string)
RVTFamilyConverter Class REX.ContentGenerator.Converters Namespace RVTFamilyConverter Class

Gets the REXFamilyType object based on the input element.

C#
public REXFamilyType GetFamily(RevitElement el, string customCategory);
Parameters
Parameters | Description
el | The Revit element.
customCategory | The custom category.
Returns

The REXFamilyType object.

Description
Class

RVTFamilyConverter Class

Links
RVTFamilyConverter Class, REX.ContentGenerator.Converters Namespace, RVTFamilyConverter Class

RVTFamilyConverter.GetRebarContour Method

RVTFamilyConverter.GetRebarContour Method
RVTFamilyConverter Class REX.ContentGenerator.Converters Namespace Example RVTFamilyConverter Class

Gets the rebar's contour based on the Revit element.

C#
public Contour_3D GetRebarContour(Rebar rebar, out REXxyz normal, out double spacing, out int count, out REXxyz distribution);
Parameters
Parameters | Description
rebar | The Revit rebar.
normal | The output normal of plane vector on which the rebar is defined.
spacing | The output spacing of the rebar.
count | The output number of subrebars.
distribution | The output distribution vector.
Returns

The contour of the rebar.

Description
Example

The example shows how to get a simplified rebar contour (without bending segments) from the Revit rebar.

//Initializing the converter.
RVTFamilyConverter rvt = new RVTFamilyConverter(commandData, true);

//Iteration threw all rebars selected in Revit.
foreach (Element el in commandData.Application.ActiveUIDocument.Selection.Elements)
{
    Rebar r = el as Rebar;

    if (r != null)
    {
        REX.Common.Geometry.REXxyz normal;
        REX.Common.Geometry.REXxyz distribution;
        double spacing;
        int count;

        REX.ContentGenerator.Geometry.Contour_3D cont3D = rvt.GetRebarContour(r, out normal, out spacing, out count, out distribution);
    }
}
Class