coords | The coordinate system (plane).
Returns

Returns coordinates of the center of the arc.

Description
Class

ContourArc Class

Links
ContourArc Class, REX.ContentGenerator.Geometry Namespace, ContourArc Class

ContourArc.GetEnd Method

ContourArc.GetEnd Method
ContourArc Class REX.ContentGenerator.Geometry Namespace ContourArc Class

Gets the end.

C#
public REXxyz GetEnd(ECoords coords);
Parameters
Parameters | Description
coords | The coordinate system (plane).
Returns

The end point.

Description
Class

ContourArc Class

Links
ContourArc Class, REX.ContentGenerator.Geometry Namespace, ContourArc Class

ContourArc.GetMiddlePoint Method

ContourArc.GetMiddlePoint Method
ContourArc Class REX.ContentGenerator.Geometry Namespace ContourArc Class

Gets the middle point.

C#
public REXxyz GetMiddlePoint(ECoords coords);
Parameters
Parameters | Description
coords | The coordinate system (plane).
Returns

Returns the middle point.

Description
Class

ContourArc Class

Links
ContourArc Class, REX.ContentGenerator.Geometry Namespace, ContourArc Class

ContourArc.GetPointList Method

ContourArc.GetPointList Method
ContourArc Class REX.ContentGenerator.Geometry Namespace ContourArc Class

Gets the list of points.

C#
public override List<REXxyz> GetPointList(bool end);
Parameters
Parameters | Description
end | If the end point included.
Returns

Returns the list of points

Description
Class

ContourArc Class

Links
ContourArc Class, REX.ContentGenerator.Geometry Namespace, ContourArc Class

ContourArc.GetStart Method

ContourArc.GetStart Method
ContourArc Class REX.ContentGenerator.Geometry Namespace ContourArc Class

Gets the start.

C#
public REXxyz GetStart(ECoords coords);
Parameters
Parameters | Description
coords | The coordinate system (plane).
Returns

The start point.

Description
Class

ContourArc Class

Links
ContourArc Class, REX.ContentGenerator.Geometry Namespace, ContourArc Class

ContourArc.MultiplyLengthDim Method

ContourArc.MultiplyLengthDim Method
ContourArc Class REX.ContentGenerator.Geometry Namespace ContourArc Class

Multiplies length dimensions by the coefficient.

C#
public override void MultiplyLengthDim(double coeff);
Parameters
Parameters | Description
coeff | The coefficient.
Description
Class

ContourArc Class

Links
ContourArc Class, REX.ContentGenerator.Geometry Namespace, ContourArc Class

ContourArc.Transform Method

ContourArc.Transform Method
ContourArc Class REX.ContentGenerator.Geometry Namespace ContourArc Class

Applies the specified transformation to the element.

C#
public override void Transform(TransformDbl trans, bool toLocal);
Parameters
Parameters | Description
trans | The transformation object.
toLocal | Indicates the direction of transformation: true if from global to local; otherwise false.
Description
Class

ContourArc Class

Links
ContourArc Class, REX.ContentGenerator.Geometry Namespace, ContourArc Class

ContourArc.Translate Method

ContourArc.Translate Method
ContourArc Class REX.ContentGenerator.Geometry Namespace ContourArc Class

Applies the specified translation vector to the element.

C#
public override void Translate(double x, double y);
Parameters
Parameters | Description
x | The x.
y | The y.
Description
Class

ContourArc Class

Links
ContourArc Class, REX.ContentGenerator.Geometry Namespace, ContourArc Class

ContourArc.End Property

ContourArc.End Property
ContourArc Class REX.ContentGenerator.Geometry Namespace ContourArc Class

Gets or sets the end.

C#
public REXxyz End;
Description

The end.

Class

ContourArc Class

Links
ContourArc Class, REX.ContentGenerator.Geometry Namespace, ContourArc Class

ContourArc.Middle Property

ContourArc.Middle Property
ContourArc Class REX.ContentGenerator.Geometry Namespace ContourArc Class

Gets or sets the middle.

C#
public REXxyz Middle;
Description

The middle.

Class

ContourArc Class

Links
ContourArc Class, REX.ContentGenerator.Geometry Namespace, ContourArc Class

ContourArc.Start Property

ContourArc.Start Property
ContourArc Class REX.ContentGenerator.Geometry Namespace ContourArc Class

Gets or sets the start.

C#
public REXxyz Start;
Description

The start.

Class

ContourArc Class

Links
ContourArc Class, REX.ContentGenerator.Geometry Namespace, ContourArc Class

ContourCircle Class

ContourCircle Class
REX.ContentGenerator.Geometry Namespace Legend Members Public Methods ContourCircle Methods ContourCircle Properties

Represents the circle element.

Class Hierarchy
C#
[Serializable()]
public class ContourCircle : ContourElem;
Description
Namespace

REX.ContentGenerator.Geometry Namespace

Public Methods
Public Method | Description
ContourCircle | Initializes a new instance of the ContourCircle class.
ContourCircle | Initializes a new instance of the ContourCircle class.
ContourCircle | Initializes a new instance of the ContourCircle class.
ContourCircle | Initializes a new instance of the ContourCircle class.
ContourCircle Methods
ContourCircle Methods | Description
GetPointList | Gets the list of points.
GetStart | Gets the start (center).
MultiplyLengthDim | Multiplies length dimensions by the coefficient.
Translate | Applies the specified translation vector to the element.
ContourCircle Properties
ContourCircle Properties | Description
Center | Gets or sets the start (center).
R | Gets or sets the radius.
Links
REX.ContentGenerator.Geometry Namespace, Legend, Members, Public Methods, ContourCircle Methods, ContourCircle Properties

ContourCircle.ContourCircle Constructor (ContourCircle)

ContourCircle.ContourCircle Constructor (ContourCircle)
ContourCircle Class REX.ContentGenerator.Geometry Namespace ContourCircle Class

Initializes a new instance of the ContourCircle class.

C#
public ContourCircle(ContourCircle pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

ContourCircle Class

Links
ContourCircle Class, REX.ContentGenerator.Geometry Namespace, ContourCircle Class

ContourCircle.ContourCircle Constructor (REXxyz, double)

ContourCircle.ContourCircle Constructor (REXxyz, double)
ContourCircle Class REX.ContentGenerator.Geometry Namespace ContourCircle Class

Initializes a new instance of the ContourCircle class.

C#
public ContourCircle(REXxyz st, double r);
Parameters
Parameters | Description
st | The start (center).
r | The radius.
Description
Class

ContourCircle Class

Links
ContourCircle Class, REX.ContentGenerator.Geometry Namespace, ContourCircle Class

ContourCircle.ContourCircle Constructor (System.Runtime.Serialization.SerializationInfo, System.Runtime.Serialization.StreamingContext)

ContourCircle.ContourCircle Constructor (System.Runtime.Serialization.SerializationInfo, System.Runtime.Serialization.StreamingContext)
ContourCircle Class REX.ContentGenerator.Geometry Namespace ContourCircle Class

Initializes a new instance of the ContourCircle class.

C#
public ContourCircle(System.Runtime.Serialization.SerializationInfo info, System.Runtime.Serialization.StreamingContext context);
Parameters
Parameters | Description
info | Serialization data.
context | The context.
Description
Class

ContourCircle Class

Links
ContourCircle Class, REX.ContentGenerator.Geometry Namespace, ContourCircle Class

ContourCircle.ContourCircle Constructor (double, double, double)

ContourCircle.ContourCircle Constructor (double, double, double)
ContourCircle Class REX.ContentGenerator.Geometry Namespace ContourCircle Class

Initializes a new instance of the ContourCircle class.

C#
public ContourCircle(double xst, double yst, double r);
Parameters
Parameters | Description
xst | The x start.
yst | The y start.
r | The radius.
Description
Class

ContourCircle Class

Links
ContourCircle Class, REX.ContentGenerator.Geometry Namespace, ContourCircle Class

ContourCircle.GetPointList Method

ContourCircle.GetPointList Method
ContourCircle Class REX.ContentGenerator.Geometry Namespace ContourCircle Class

Gets the list of points.

C#
public override List<REXxyz> GetPointList(bool end);