REXLayoutItem | Initializes a new instance of the REXLayoutItem class.
REXLayoutItem | Initializes a new instance of the REXLayoutItem class.
REXLayoutItem | Initializes a new instance of the REXLayoutItem class.
REXLayoutItem | Initializes a new instance of the REXLayoutItem class.
REXLayoutItem | Initializes a new instance of the REXLayoutItem class.

Legend

Legend
REXLogger Class
Legend
Method
static

REXLogger Class Members

REXLogger Class Members
REXLogger Class Legend
Members
REXLogger Methods
REXLogger Methods | Description
Log | This is Log, a member of class REXLogger.
Log | This is Log, a member of class REXLogger.
Log | This is Log, a member of class REXLogger.
Log | This is Log, a member of class REXLogger.
Log | This is Log, a member of class REXLogger.
Log | This is Log, a member of class REXLogger.
Log | This is Log, a member of class REXLogger.
Log | Logs specified warning.
Log | Logs specified warning and message.

REXLogger Methods

REXLogger Methods
REXLogger Class Legend
REXLogger Methods
REXLogger Methods | Description
Log | This is Log, a member of class REXLogger.
Log | This is Log, a member of class REXLogger.
Log | This is Log, a member of class REXLogger.
Log | This is Log, a member of class REXLogger.
Log | This is Log, a member of class REXLogger.
Log | This is Log, a member of class REXLogger.
Log | This is Log, a member of class REXLogger.
Log | Logs specified warning.
Log | Logs specified warning and message.

Legend

Legend
REXResults Class
Legend
Constructor
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXResults Class Members

REXResults Class Members
REXResults Class Legend
Members
Public Methods
Public Method | Description
REXResults | Initializes a new instance of a REXResults class.

REXResults Class Public Methods

REXResults Class Public Methods
REXResults Class Legend
Public Methods
Public Method | Description
REXResults | Initializes a new instance of a REXResults class.

REXRevitAccess Classes

REXRevitAccess Classes
REXRevitAccess Class Legend
REXRevitAccess Classes
REXRevitAccess Classes | Description
Versions | Constants for all known versions.

REXRevitAccess Enumerations

REXRevitAccess Enumerations
REXRevitAccess Class Legend
REXRevitAccess Enumerations
REXRevitAccess Enumerations | Description
CompareVersionsResult | Dedicated enum for compare Revit's version.

REXRevitAccess Fields

REXRevitAccess Fields
REXRevitAccess Class Legend
REXRevitAccess Fields
REXRevitAccess Fields | Description
AutoSelectionRestore | This is AutoSelectionRestore, a member of class REXRevitAccess.
UsingParameters | This is UsingParameters, a member of class REXRevitAccess.

Legend

Legend
REXRevitAccess Class
Legend
Constructor
Class
Enumeration
Data Member
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXRevitAccess Class Members

REXRevitAccess Class Members
REXRevitAccess Class Legend
Members
Public Methods
Public Method | Description
REXRevitAccess | Initializes a new instance of the REXRevitAccess class.
REXRevitAccess Classes
REXRevitAccess Classes | Description
Versions | Constants for all known versions.
REXRevitAccess Enumerations
REXRevitAccess Enumerations | Description
CompareVersionsResult | Dedicated enum for compare Revit's version.
REXRevitAccess Fields
REXRevitAccess Fields | Description
AutoSelectionRestore | This is AutoSelectionRestore, a member of class REXRevitAccess.
UsingParameters | This is UsingParameters, a member of class REXRevitAccess.
REXRevitAccess Methods
REXRevitAccess Methods | Description
Application | Access to Autodesk.Revit.ApplicationServices.ApplicationServices.Application object.
CommandData | Access to Autodesk.Revit.ExternalCommandData.
CompareVersions | Compares the versions.
Create | Reads some data from Revit and sets system display units.
Destroy | Destroys and resets some objects connected to Revit.
Detach | Detaches this instance.
Elements | Access to Autodesk.Revit.ExternalCommandData.
Event | Events the specified ev.
Initialize | Initializes this instance.
Message | Access to message string from Autodesk.Revit.IExternalCommand.Execute command.
Update | Reads some data from Revit and set system display units.
UpdaterData | Access to updater data (in update context only).
REXRevitAccess Properties
REXRevitAccess Properties | Description
ActiveDocument | Actives the UI document.
ActiveUIDocument | Actives the UI document.
EventService | This is EventService, a member of class REXRevitAccess.
IsArchitecture | This is IsArchitecture, a member of class REXRevitAccess.
IsMEP | This is IsMEP, a member of class REXRevitAccess.
IsStructure | This is IsStructure, a member of class REXRevitAccess.
Parameters | Access to REX parameters.
Selection | Actives the UI document.
ThisApplication | This is ThisApplication, a member of class REXRevitAccess.
ThisContext | This is ThisContext, a member of class REXRevitAccess.
ThisExtension | This is ThisExtension, a member of class REXRevitAccess.
UIApplication | UIs the application.

Members

Legend
Legend
Constructor
Class
Enumeration
Data Member
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXRevitAccess Methods

REXRevitAccess Methods
REXRevitAccess Class Legend
REXRevitAccess Methods
REXRevitAccess Methods | Description
Application | Access to Autodesk.Revit.ApplicationServices.ApplicationServices.Application object.
CommandData | Access to Autodesk.Revit.ExternalCommandData.
CompareVersions | Compares the versions.
Create | Reads some data from Revit and sets system display units.
Destroy | Destroys and resets some objects connected to Revit.
Detach | Detaches this instance.
Elements | Access to Autodesk.Revit.ExternalCommandData.
Event | Events the specified ev.
Initialize | Initializes this instance.
Message | Access to message string from Autodesk.Revit.IExternalCommand.Execute command.
Update | Reads some data from Revit and set system display units.
UpdaterData | Access to updater data (in update context only).

REXRevitAccess Properties

REXRevitAccess Properties
REXRevitAccess Class Legend
REXRevitAccess Properties
REXRevitAccess Properties | Description
ActiveDocument | Actives the UI document.
ActiveUIDocument | Actives the UI document.
EventService | This is EventService, a member of class REXRevitAccess.
IsArchitecture | This is IsArchitecture, a member of class REXRevitAccess.
IsMEP | This is IsMEP, a member of class REXRevitAccess.
IsStructure | This is IsStructure, a member of class REXRevitAccess.
Parameters | Access to REX parameters.
Selection | Actives the UI document.
ThisApplication | This is ThisApplication, a member of class REXRevitAccess.
ThisContext | This is ThisContext, a member of class REXRevitAccess.
ThisExtension | This is ThisExtension, a member of class REXRevitAccess.
UIApplication | UIs the application.

REXRevitAccess Class Public Methods

REXRevitAccess Class Public Methods
REXRevitAccess Class Legend
Public Methods
Public Method | Description
REXRevitAccess | Initializes a new instance of the REXRevitAccess class.

Versions Fields

Versions Fields
REXRevitAccess.Versions Class Legend
Versions Fields
Versions Fields | Description
v2008 |
v2008_SP1 |
v2008_SP2 |
v2008_SP3 |
v2008_SP4 |
v2009_A |
v2009_A2 |

Legend

Legend
REXRevitAccess.Versions Class
Legend
Data Member