Reads some data from Revit and set system display units.

C#
public void Update();
Description
Class

REXRevitAccess Class

Links
REXRevitAccess Class, REX.Common Namespace, REXRevitAccess Class

REXRevitAccess.UpdaterData Method

REXRevitAccess.UpdaterData Method
REXRevitAccess Class REX.Common Namespace REXRevitAccess Class

Access to updater data (in update context only).

C#
public Autodesk.Revit.DB.UpdaterData UpdaterData();
Returns

Return the updater data.

Description
Class

REXRevitAccess Class

Links
REXRevitAccess Class, REX.Common Namespace, REXRevitAccess Class

REXRevitAccess.ActiveDocument Property

REXRevitAccess.ActiveDocument Property
REXRevitAccess Class REX.Common Namespace REXRevitAccess Class

Actives the UI document.

C#
public Autodesk.Revit.DB.Document ActiveDocument;
Description
Class

REXRevitAccess Class

Links
REXRevitAccess Class, REX.Common Namespace, REXRevitAccess Class

REXRevitAccess.ActiveUIDocument Property

REXRevitAccess.ActiveUIDocument Property
REXRevitAccess Class REX.Common Namespace REXRevitAccess Class

Actives the UI document.

C#
public Autodesk.Revit.UI.UIDocument ActiveUIDocument;
Description
Class

REXRevitAccess Class

Links
REXRevitAccess Class, REX.Common Namespace, REXRevitAccess Class

REXRevitAccess.EventService Property

REXRevitAccess.EventService Property
REXRevitAccess Class REX.Common Namespace REXRevitAccess Class

This is EventService, a member of class REXRevitAccess.

C#
public REX.Common.Events.Revit.REXRevitEventService EventService;
Class

REXRevitAccess Class

Links
REXRevitAccess Class, REX.Common Namespace, REXRevitAccess Class

REXRevitAccess.IsArchitecture Property

REXRevitAccess.IsArchitecture Property
REXRevitAccess Class REX.Common Namespace REXRevitAccess Class

This is IsArchitecture, a member of class REXRevitAccess.

C#
public bool IsArchitecture;
Class

REXRevitAccess Class

Links
REXRevitAccess Class, REX.Common Namespace, REXRevitAccess Class

REXRevitAccess.IsMEP Property

REXRevitAccess.IsMEP Property
REXRevitAccess Class REX.Common Namespace REXRevitAccess Class

This is IsMEP, a member of class REXRevitAccess.

C#
public bool IsMEP;
Class

REXRevitAccess Class

Links
REXRevitAccess Class, REX.Common Namespace, REXRevitAccess Class

REXRevitAccess.IsStructure Property

REXRevitAccess.IsStructure Property
REXRevitAccess Class REX.Common Namespace REXRevitAccess Class

This is IsStructure, a member of class REXRevitAccess.

C#
public bool IsStructure;
Class

REXRevitAccess Class

Links
REXRevitAccess Class, REX.Common Namespace, REXRevitAccess Class

REXRevitAccess.Parameters Property

REXRevitAccess.Parameters Property
REXRevitAccess Class REX.Common Namespace REXRevitAccess Class

Access to REX parameters.

C#
public IREXStorage<Element> Parameters;
Description

Uses for serialization data to Revit's elements.

Returns reference to REXParameters2 object.

Class

REXRevitAccess Class

Links
REXRevitAccess Class, REX.Common Namespace, REXRevitAccess Class

REXRevitAccess.Selection Property

REXRevitAccess.Selection Property
REXRevitAccess Class REX.Common Namespace REXRevitAccess Class

Actives the UI document.

C#
public Autodesk.Revit.UI.Selection.Selection Selection;
Description
Class

REXRevitAccess Class

Links
REXRevitAccess Class, REX.Common Namespace, REXRevitAccess Class

REXRevitAccess.ThisApplication Property

REXRevitAccess.ThisApplication Property
REXRevitAccess Class REX.Common Namespace REXRevitAccess Class

This is ThisApplication, a member of class REXRevitAccess.

C#
public REXApplication ThisApplication;
Class

REXRevitAccess Class

Links
REXRevitAccess Class, REX.Common Namespace, REXRevitAccess Class

REXRevitAccess.ThisContext Property

REXRevitAccess.ThisContext Property
REXRevitAccess Class REX.Common Namespace REXRevitAccess Class

This is ThisContext, a member of class REXRevitAccess.

C#
public Autodesk.REX.Framework.REXContext ThisContext;
Class

REXRevitAccess Class

Links
REXRevitAccess Class, REX.Common Namespace, REXRevitAccess Class

REXRevitAccess.ThisExtension Property

REXRevitAccess.ThisExtension Property
REXRevitAccess Class REX.Common Namespace REXRevitAccess Class

This is ThisExtension, a member of class REXRevitAccess.

C#
public REXExtension ThisExtension;
Class

REXRevitAccess Class

Links
REXRevitAccess Class, REX.Common Namespace, REXRevitAccess Class

REXRevitAccess.UIApplication Property

REXRevitAccess.UIApplication Property
REXRevitAccess Class REX.Common Namespace REXRevitAccess Class

UIs the application.

C#
public Autodesk.Revit.UI.UIApplication UIApplication;
Description
Class

REXRevitAccess Class

Links
REXRevitAccess Class, REX.Common Namespace, REXRevitAccess Class

REXRevitContextAccess Class

REXRevitContextAccess Class
REX.Common Namespace Legend Members Public Methods REXRevitContextAccess Methods

Allaws for access to Revit's objects.

Class Hierarchy
C#
public class REXRevitContextAccess : IREXExtensionAccess2;
Description
Namespace

REX.Common Namespace

Public Methods
Public Method | Description
REXRevitContextAccess | This is REXRevitContextAccess, a member of class REXRevitContextAccess.
REXRevitContextAccess Methods
REXRevitContextAccess Methods | Description
Create | Reads some data from parent application and set system display units.
Destroy | Destroys and resets some objects connected to parent application.
Event | Events the specified ev.
Initialize | Initializes this instance.
Update | Reads some data from parent application and set system display units.
Links
REX.Common Namespace, Legend, Members, Public Methods, REXRevitContextAccess Methods

REXRevitContextAccess.REXRevitContextAccess Constructor

REXRevitContextAccess.REXRevitContextAccess Constructor
REXRevitContextAccess Class REX.Common Namespace REXRevitContextAccess Class

This is REXRevitContextAccess, a member of class REXRevitContextAccess.

C#
public REXRevitContextAccess(REXRevitAccess ContextAccess);
Class

REXRevitContextAccess Class

Links
REXRevitContextAccess Class, REX.Common Namespace, REXRevitContextAccess Class

REXRevitContextAccess.Create Method

REXRevitContextAccess.Create Method
REXRevitContextAccess Class REX.Common Namespace REXRevitContextAccess Class

Reads some data from parent application and set system display units.

C#
public bool Create();
Returns

Returns true if succeeded.

Description
Class

REXRevitContextAccess Class

Links
REXRevitContextAccess Class, REX.Common Namespace, REXRevitContextAccess Class

REXRevitContextAccess.Destroy Method

REXRevitContextAccess.Destroy Method
REXRevitContextAccess Class REX.Common Namespace REXRevitContextAccess Class

Destroys and resets some objects connected to parent application.

C#
public bool Destroy();
Returns

Returns true if succeeded.

Description
Class

REXRevitContextAccess Class

Links
REXRevitContextAccess Class, REX.Common Namespace, REXRevitContextAccess Class

REXRevitContextAccess.Event Method

REXRevitContextAccess.Event Method
REXRevitContextAccess Class REX.Common Namespace REXRevitContextAccess Class

Events the specified ev.

C#
public bool Event(REXAccess.REXAccessEvent Ev);
Parameters
Parameters | Description
Ev | The ev.
Description
Class

REXRevitContextAccess Class

Links
REXRevitContextAccess Class, REX.Common Namespace, REXRevitContextAccess Class

REXRevitContextAccess.Initialize Method

REXRevitContextAccess.Initialize Method
REXRevitContextAccess Class REX.Common Namespace REXRevitContextAccess Class

Initializes this instance.

C#
public void Initialize();
Description

Nostly sets language from parent application.

Class

REXRevitContextAccess Class

Links
REXRevitContextAccess Class, REX.Common Namespace, REXRevitContextAccess Class

REXRevitContextAccess.Update Method

REXRevitContextAccess.Update Method
REXRevitContextAccess Class REX.Common Namespace REXRevitContextAccess Class

Reads some data from parent application and set system display units.

C#
public void Update();
Description
Class