IRvtContentSettings.Clean Method
IRvtContentSettings Interface REX.ContentGenerator.Converters Namespace IRvtContentSettings Interface

Cleans temporary files.

C#
bool Clean();
Returns

Whether cleaning succeeded.

Description
Interface

IRvtContentSettings Interface

Links
IRvtContentSettings Interface, REX.ContentGenerator.Converters Namespace, IRvtContentSettings Interface

IRvtContentSettings.LoadCustomParametersFile Method

IRvtContentSettings.LoadCustomParametersFile Method
IRvtContentSettings Interface REX.ContentGenerator.Converters Namespace IRvtContentSettings Interface

Loads the custom parameters file.

C#
bool LoadCustomParametersFile(string category, string path);
Parameters
Parameters | Description
category | The custom category name.
path | The path.
Returns

Loads the custom parameters file.

Description
Interface

IRvtContentSettings Interface

Links
IRvtContentSettings Interface, REX.ContentGenerator.Converters Namespace, IRvtContentSettings Interface

IRvtContentSettings.SetLanguage Method

IRvtContentSettings.SetLanguage Method
IRvtContentSettings Interface REX.ContentGenerator.Converters Namespace IRvtContentSettings Interface

Sets the language for created families (names of families will be translated according to this) - “en-US”, “pl-PL” etc.

C#
void SetLanguage(string lang);
Parameters
Parameters | Description
lang | The language.
Description
Interface

IRvtContentSettings Interface

Links
IRvtContentSettings Interface, REX.ContentGenerator.Converters Namespace, IRvtContentSettings Interface

IRvtContentSettings.BufferElements Property

IRvtContentSettings.BufferElements Property
IRvtContentSettings Interface REX.ContentGenerator.Converters Namespace IRvtContentSettings Interface

Gets or sets a value indicating whether elements should be buffered after investigation – using RevitId.

C#
bool BufferElements;
Description

If false it will be analyzed each time.

True if elements are buffored; otherwise, false.

Interface

IRvtContentSettings Interface

Links
IRvtContentSettings Interface, REX.ContentGenerator.Converters Namespace, IRvtContentSettings Interface

IRvtContentSettings.CreateNewElement Property

IRvtContentSettings.CreateNewElement Property
IRvtContentSettings Interface REX.ContentGenerator.Converters Namespace IRvtContentSettings Interface

Gets or sets a value indicating whether a new family should be created if the element wasn’t found among existing ones.

C#
bool CreateNewElement;
Description

True if a new family is created; otherwise, false.

Interface

IRvtContentSettings Interface

Links
IRvtContentSettings Interface, REX.ContentGenerator.Converters Namespace, IRvtContentSettings Interface

IRvtContentSettings.IgnoreFamilyNameLanguage Property

IRvtContentSettings.IgnoreFamilyNameLanguage Property
IRvtContentSettings Interface REX.ContentGenerator.Converters Namespace IRvtContentSettings Interface

Gets or sets a value indicating whether language should be taken to consideration during element search (language set by SetLanguage function).

C#
bool IgnoreFamilyNameLanguage;
Description

True if the language should be taken to considaration when created; otherwise, false.

Remarks

If IgnoreFamilyNameLanguage is set to false there will be

Interface

IRvtContentSettings Interface

Links
IRvtContentSettings Interface, REX.ContentGenerator.Converters Namespace, IRvtContentSettings Interface

IRvtContentSettings.Labels Property

IRvtContentSettings.Labels Property
IRvtContentSettings Interface REX.ContentGenerator.Converters Namespace IRvtContentSettings Interface

Gets or sets a value indicating whether labels should be taken to consideration during mapping.

C#
bool Labels;
Description

True if labels are supported; otherwise, false.

Interface

IRvtContentSettings Interface

Links
IRvtContentSettings Interface, REX.ContentGenerator.Converters Namespace, IRvtContentSettings Interface

IRvtContentSettings.RebarPostGenerateCorrection Property

IRvtContentSettings.RebarPostGenerateCorrection Property
IRvtContentSettings Interface REX.ContentGenerator.Converters Namespace IRvtContentSettings Interface

Gets or sets a value indicating whether correction of rebar geometry should be made after generation process.

C#
bool RebarPostGenerateCorrection;
Description

True if postgeneration correction; otherwise, false.

Interface

IRvtContentSettings Interface

Links
IRvtContentSettings Interface, REX.ContentGenerator.Converters Namespace, IRvtContentSettings Interface

IRvtContentSettings.SupportUserDatabases Property

IRvtContentSettings.SupportUserDatabases Property
IRvtContentSettings Interface REX.ContentGenerator.Converters Namespace IRvtContentSettings Interface

Gets or sets a value indicating whether users databases should be supported

C#
bool SupportUserDatabases;
Description

True if user databases are supported; otherwise, false.

Interface

IRvtContentSettings Interface

Links
IRvtContentSettings Interface, REX.ContentGenerator.Converters Namespace, IRvtContentSettings Interface

IRvtContentSettings.Update Property

IRvtContentSettings.Update Property
IRvtContentSettings Interface REX.ContentGenerator.Converters Namespace IRvtContentSettings Interface

Gets or sets a value indicating whether element found in the project (if it already exists) should be updated with new data.

C#
bool Update;
Description

True if elements are updated; otherwise, false.

Interface

IRvtContentSettings Interface

Links
IRvtContentSettings Interface, REX.ContentGenerator.Converters Namespace, IRvtContentSettings Interface

REX.ContentGenerator.Converters.EDBAccess Enumeration

REX.ContentGenerator.Converters.EDBAccess Enumeration
REX.ContentGenerator.Converters Namespace

Describes the access to databases.

C#
public enum EDBAccess {
  ADO_mdb,
  DbRoot_xml,
  DbRoot_mdb
}
Members
Members | Description
ADO_mdb | ADO access to mdb files.
DbRoot_xml | DBRoot access to xml files.
DbRoot_mdb | DBRoot access to mdb files.
Description
Namespace

REX.ContentGenerator.Converters Namespace

Links
REX.ContentGenerator.Converters Namespace

REX.ContentGenerator.Converters.ElementGenerated Type

REX.ContentGenerator.Converters.ElementGenerated Type
REX.ContentGenerator.Converters Namespace

Delagate for the generation event (when the list of elements is used).

C#
public delegate void ElementGenerated(string id);
Description
Namespace

REX.ContentGenerator.Converters Namespace

Links
REX.ContentGenerator.Converters Namespace

REX.ContentGenerator.Dialog Namespace

Previous | Next
REX.ContentGenerator.Dialog Namespace
Legend Classes Structs, Records, Enums

This is namespace REX.ContentGenerator.Dialog.

Classes
Class | Description
REXContentDialogCategorySettings | Contains settings for specific category.
REXContentDialogManager | Helps manage DRevitContentGenerator Extension directly by code.
REXContentDialogSettings | Describes settings of the ContentGenerator dialog.
Structs, Records, Enums
Struct, Record, Enum | Description
EContentDialogMode | Describes modes in which the ContentGenerator dialog may be run.
Links
Legend, Classes, Structs, Records, Enums
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXContentDialogCategorySettings Class

REXContentDialogCategorySettings Class
REX.ContentGenerator.Dialog Namespace Legend Members Public Methods REXContentDialogCategorySettings Properties

Contains settings for specific category.

Class Hierarchy
C#
public class REXContentDialogCategorySettings;
Description
Namespace

REX.ContentGenerator.Dialog Namespace

Public Methods
Public Method | Description
REXContentDialogCategorySettings | Initializes a new instance of the REXContentDialogCategorySettings class.
REXContentDialogCategorySettings Properties
REXContentDialogCategorySettings Properties | Description
Category | Gets the category type.