String Separator;
Description

The separator.

Interface

IUnitObject Interface

Links
IUnitObject Interface, REX.Controls.Common Namespace, IUnitObject Interface

IUnitObject.Tag Property

IUnitObject.Tag Property
IUnitObject Interface REX.Controls.Common Namespace IUnitObject Interface

Gets or sets the tag.

C#
object Tag;
Description

The tag.

Interface

IUnitObject Interface

Links
IUnitObject Interface, REX.Controls.Common Namespace, IUnitObject Interface

IUnitObject.Text Property

IUnitObject.Text Property
IUnitObject Interface REX.Controls.Common Namespace IUnitObject Interface

Gets the text contents of the control.

C#
string Text;
Description

The text.

Interface

IUnitObject Interface

Links
IUnitObject Interface, REX.Controls.Common Namespace, IUnitObject Interface

IUnitObject.UnitSymbol Property

IUnitObject.UnitSymbol Property
IUnitObject Interface REX.Controls.Common Namespace IUnitObject Interface

Gets or sets the unit symbol.

C#
String UnitSymbol;
Description

The unit symbol.

Interface

IUnitObject Interface

Links
IUnitObject Interface, REX.Controls.Common Namespace, IUnitObject Interface

IUnitObject2 Interface

IUnitObject2 Interface
REX.Controls.Common Namespace Legend Members IUnitObject2 Methods

Defines common functionality for controls that are unit dependent.

Class Hierarchy
C#
public interface IUnitObject2 : IUnitObject;
Description
Namespace

REX.Controls.Common Namespace

IUnitObject2 Methods
IUnitObject2 Methods | Description
ValidateComplexValue | Validates the complex (list) value of the double type.
ValidateComplexValue | Validates the complex (list) value of the string type.
ValidateValue | Validates the input value of the double type.
ValidateValue | Validates the value of the string type.
Links
REX.Controls.Common Namespace, Legend, Members, IUnitObject2 Methods

IUnitObject2.ValidateComplexValue Method (List<double>)

IUnitObject2.ValidateComplexValue Method (List<double>)
IUnitObject2 Interface REX.Controls.Common Namespace IUnitObject2 Interface

Validates the complex (list) value of the double type.

C#
bool ValidateComplexValue(List<double> values);
Parameters
Parameters | Description
values | The values to validate.
Returns

True if validated; otherwise false.

Description
Interface

IUnitObject2 Interface

Links
IUnitObject2 Interface, REX.Controls.Common Namespace, IUnitObject2 Interface

IUnitObject2.ValidateComplexValue Method (List<string>)

IUnitObject2.ValidateComplexValue Method (List<string>)
IUnitObject2 Interface REX.Controls.Common Namespace IUnitObject2 Interface

Validates the complex (list) value of the string type.

C#
bool ValidateComplexValue(List<string> values);
Parameters
Parameters | Description
values | The values to validate.
Returns

True if validated; otherwise false.

Description
Interface

IUnitObject2 Interface

Links
IUnitObject2 Interface, REX.Controls.Common Namespace, IUnitObject2 Interface

IUnitObject2.ValidateValue Method (Double)

IUnitObject2.ValidateValue Method (Double)
IUnitObject2 Interface REX.Controls.Common Namespace IUnitObject2 Interface

Validates the input value of the double type.

C#
bool ValidateValue(Double value);
Parameters
Parameters | Description
value | The value to validate.
Returns

True if validated; otherwise false.

Description
Interface

IUnitObject2 Interface

Links
IUnitObject2 Interface, REX.Controls.Common Namespace, IUnitObject2 Interface

IUnitObject2.ValidateValue Method (String)

IUnitObject2.ValidateValue Method (String)
IUnitObject2 Interface REX.Controls.Common Namespace IUnitObject2 Interface

Validates the value of the string type.

C#
bool ValidateValue(String value);
Parameters
Parameters | Description
value | The value to validate.
Returns

True if validated; otherwise false.

Description
Interface

IUnitObject2 Interface

Links
IUnitObject2 Interface, REX.Controls.Common Namespace, IUnitObject2 Interface

IUnitObject3 Interface

IUnitObject3 Interface
REX.Controls.Common Namespace Legend Members IUnitObject3 Methods

Defines common functionality for controls that are unit dependent.

Class Hierarchy
C#
public interface IUnitObject3 : IUnitObject2;
Description
Namespace

REX.Controls.Common Namespace

IUnitObject3 Methods
IUnitObject3 Methods | Description
RefreshValidationStatus | Refreshes the validation status.
ValueFormat | Returns a text containing an expression formatted according the current settings of the element.
ValueFormat | Returns a text containing an expression formatted according the current settings of the element.
ValueParse | Converts the specified text to the numeric value according the current settings of the element.
Links
REX.Controls.Common Namespace, Legend, Members, IUnitObject3 Methods

IUnitObject3.RefreshValidationStatus Method

IUnitObject3.RefreshValidationStatus Method
IUnitObject3 Interface REX.Controls.Common Namespace IUnitObject3 Interface

Refreshes the validation status.

C#
void RefreshValidationStatus();
Description
Interface

IUnitObject3 Interface

Links
IUnitObject3 Interface, REX.Controls.Common Namespace, IUnitObject3 Interface

IUnitObject3.ValueFormat Method (Double)

IUnitObject3.ValueFormat Method (Double)
IUnitObject3 Interface REX.Controls.Common Namespace IUnitObject3 Interface

Returns a text containing an expression formatted according the current settings of the element.

C#
string ValueFormat(Double value);
Parameters
Parameters | Description
value | The value to format.
Returns

The formatted text.

Description
Interface

IUnitObject3 Interface

Links
IUnitObject3 Interface, REX.Controls.Common Namespace, IUnitObject3 Interface

IUnitObject3.ValueFormat Method (String)

IUnitObject3.ValueFormat Method (String)
IUnitObject3 Interface REX.Controls.Common Namespace IUnitObject3 Interface

Returns a text containing an expression formatted according the current settings of the element.

C#
string ValueFormat(String value);
Parameters
Parameters | Description
value | The value to format.
Returns

The formatted text.

Description
Interface

IUnitObject3 Interface

Links
IUnitObject3 Interface, REX.Controls.Common Namespace, IUnitObject3 Interface

IUnitObject3.ValueParse Method

IUnitObject3.ValueParse Method
IUnitObject3 Interface REX.Controls.Common Namespace IUnitObject3 Interface

Converts the specified text to the numeric value according the current settings of the element.

C#
double ValueParse(String value);
Parameters
Parameters | Description
value | The text.
Returns

The converted value.

Description
Interface

IUnitObject3 Interface

Links
IUnitObject3 Interface, REX.Controls.Common Namespace, IUnitObject3 Interface

REX.Controls.Common.EComboPropertiesType Enumeration

REX.Controls.Common.EComboPropertiesType Enumeration
REX.Controls.Common Namespace

An enumerated type listing all modes of the combo.

C#
public enum EComboPropertiesType {
  Main,
  List
}
Description
Namespace

REX.Controls.Common Namespace

Links
REX.Controls.Common Namespace
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REX.Controls.Forms Namespace

Previous | Next
REX.Controls.Forms Namespace
Legend Classes

This is namespace REX.Controls.Forms.

Classes
Class | Description
REXComboBox | Represents a REX combo box control.
REXEditBox | Represents the REXEditBox control.
REXImageComboBox | Combo box with images.
REXImageComboBoxItem | Represents the combobox item with an image inside.
REXIndexLabel | Represents the REXIndexLabel control.
REXPictureBox | This is class REX.Controls.Forms.REXPictureBox.
REXProgressBar | Represents a REX progress bar control.
REXUnitComboBox | Represents the REXUnitComboBox control with a IREXUnitEngine.
REXUnitEditBox | Represents the REXEditBox control with a IREXUnitEngine.
Links
Legend, Classes