Value will be written using monospace font. Name can contain subscripts in braces, e.g. name="B{1}" will be rendered as B1

Class

XHTMLElement Class

Links
XHTMLElement Class, ROHTML Namespace, XHTMLElement Class

XHTMLElement.AddValue4 Method

XHTMLElement.AddValue4 Method
XHTMLElement Class ROHTML Namespace XHTMLElement Class

Extended AddValue method (Similar to Verify, different order of parameters)

C#
public void AddValue4(String name, String condition, String message, ROHTMLMessages type, Variant value);
Parameters
Parameters | Description
name |
condition |
message |
type |
value |
Class

XHTMLElement Class

Links
XHTMLElement Class, ROHTML Namespace, XHTMLElement Class

XHTMLElement.AddValue5 Method

XHTMLElement.AddValue5 Method
XHTMLElement Class ROHTML Namespace XHTMLElement Class

Extended AddValue method

C#
public void AddValue5(String name, Variant value, String unit, String description, String note);
Parameters
Parameters | Description
name |
value |
unit |
description |
note |
Class

XHTMLElement Class

Links
XHTMLElement Class, ROHTML Namespace, XHTMLElement Class

XHTMLElement.Verify Method

XHTMLElement.Verify Method
XHTMLElement Class ROHTML Namespace XHTMLElement Class

Similar to AddValue4 (different order of parameters),

C#
public void Verify(String name, String condition, String message, Variant value, ROHTMLMessages type);
Parameters
Parameters | Description
name |
condition |
message |
value |
type |
Class

XHTMLElement Class

Links
XHTMLElement Class, ROHTML Namespace, XHTMLElement Class

XHTMLTable Class

XHTMLTable Class
ROHTML Namespace Legend Members XHTMLTable Fields XHTMLTable Methods

This is class ROHTML.XHTMLTable.

Class Hierarchy
C#
public class XHTMLTable;
Namespace

ROHTML Namespace

XHTMLTable Fields
XHTMLTable Fields | Description
Border | Short Border width in pixels.
Columns | Long Number of columns in the table.
FooterRows | Long Number of footer rows.
HeaderColumns | Long Number of header columns.
HeaderRows | Long Number of header rows.
Rows | Long Number of rows in the table (including header rows).
Width | Sets or gets the overall table width, default: "Auto".
XHTMLTable Methods
XHTMLTable Methods | Description
AddAttribute | Adds an HTML attribute and its value to the entire table.
AddColumnAttribute | Adds an HTML attribute and its value to the specified column.
AddRow | Adds one row to the table.
AutoFormat | Initializes a couple of table properties according to given predefined format.
Cell | XHTMLElement that represents the cell of the table.
ColumnWidth | String Sets or gets the column width of the desired column, e.g.
Links
ROHTML Namespace, Legend, Members, XHTMLTable Fields, XHTMLTable Methods

XHTMLTable.Border Field

XHTMLTable.Border Field
XHTMLTable Class ROHTML Namespace XHTMLTable Class

Short Border width in pixels.

C#
public short Border;
Description

0 indicates no border.

Class

XHTMLTable Class

Links
XHTMLTable Class, ROHTML Namespace, XHTMLTable Class

XHTMLTable.Columns Field

XHTMLTable.Columns Field
XHTMLTable Class ROHTML Namespace XHTMLTable Class

Long Number of columns in the table.

C#
public long Columns;
Parameters
Parameters | Description
nColumn |
Description
Class

XHTMLTable Class

Links
XHTMLTable Class, ROHTML Namespace, XHTMLTable Class

XHTMLTable.FooterRows Field

XHTMLTable.FooterRows Field
XHTMLTable Class ROHTML Namespace XHTMLTable Class

Long Number of footer rows.

C#
public long FooterRows;
Description
Class

XHTMLTable Class

Links
XHTMLTable Class, ROHTML Namespace, XHTMLTable Class

XHTMLTable.HeaderColumns Field

XHTMLTable.HeaderColumns Field
XHTMLTable Class ROHTML Namespace XHTMLTable Class

Long Number of header columns.

C#
public long HeaderColumns;
Description
Class

XHTMLTable Class

Links
XHTMLTable Class, ROHTML Namespace, XHTMLTable Class

XHTMLTable.HeaderRows Field

XHTMLTable.HeaderRows Field
XHTMLTable Class ROHTML Namespace XHTMLTable Class

Long Number of header rows.

C#
public long HeaderRows;
Description
Class

XHTMLTable Class

Links
XHTMLTable Class, ROHTML Namespace, XHTMLTable Class

XHTMLTable.Rows Field

XHTMLTable.Rows Field
XHTMLTable Class ROHTML Namespace XHTMLTable Class

Long Number of rows in the table (including header rows).

C#
public long Rows;
Description
Class

XHTMLTable Class

Links
XHTMLTable Class, ROHTML Namespace, XHTMLTable Class

XHTMLTable.Width Field

XHTMLTable.Width Field
XHTMLTable Class ROHTML Namespace XHTMLTable Class

Sets or gets the overall table width, default: "Auto".

C#
public string Width;
Description
Class

XHTMLTable Class

Links
XHTMLTable Class, ROHTML Namespace, XHTMLTable Class

XHTMLTable.AddAttribute Method

XHTMLTable.AddAttribute Method
XHTMLTable Class ROHTML Namespace XHTMLTable Class

Adds an HTML attribute and its value to the entire table.

C#
public void AddAttribute(String name, String value);
Parameters
Parameters | Description
name |
value |
Description
Class

XHTMLTable Class

Links
XHTMLTable Class, ROHTML Namespace, XHTMLTable Class

XHTMLTable.AddColumnAttribute Method

XHTMLTable.AddColumnAttribute Method
XHTMLTable Class ROHTML Namespace XHTMLTable Class

Adds an HTML attribute and its value to the specified column.

C#
public void AddColumnAttribute(Long nColumn, String name, String value);
Description
Class

XHTMLTable Class

Links
XHTMLTable Class, ROHTML Namespace, XHTMLTable Class

XHTMLTable.AddRow Method

XHTMLTable.AddRow Method
XHTMLTable Class ROHTML Namespace XHTMLTable Class

Adds one row to the table.

C#
public void AddRow();
Parameters
Parameters | Description
format |
Description
Class

XHTMLTable Class

Links
XHTMLTable Class, ROHTML Namespace, XHTMLTable Class

XHTMLTable.AutoFormat Method

XHTMLTable.AutoFormat Method
XHTMLTable Class ROHTML Namespace XHTMLTable Class

Initializes a couple of table properties according to given predefined format.

C#
public void AutoFormat(ROHTMLTableFormats format);
Parameters
Parameters | Description
format |
Description

See ROHTMLTableFormats to preview available formats.

Class

XHTMLTable Class

Links
XHTMLTable Class, ROHTML Namespace, XHTMLTable Class

XHTMLTable.Cell Method

XHTMLTable.Cell Method
XHTMLTable Class ROHTML Namespace XHTMLTable Class

XHTMLElement that represents the cell of the table.

C#
public XHTMLElement Cell(Long nRow, Long nColumn);
Parameters
Parameters | Description
nRow |
nColumn |
Description
Class

XHTMLTable Class

Links
XHTMLTable Class, ROHTML Namespace, XHTMLTable Class

XHTMLTable.ColumnWidth Method

Previous | Up
XHTMLTable.ColumnWidth Method
XHTMLTable Class ROHTML Namespace XHTMLTable Class

String Sets or gets the column width of the desired column, e.g.

C#
public string ColumnWidth(Long nColumn);
Description

"40%".

Class

XHTMLTable Class

Links
XHTMLTable Class, ROHTML Namespace, XHTMLTable Class

REX.Common Namespace Classes

REX.Common Namespace Classes
REX.Common Namespace Legend
Classes
Class | Description
REXAccess | The class dedicated to settings data from parent application.
REXApplication | Base class for Application.This object controls the lifetime of the extensions.
REXDFM | Manages UI controls registered in it.
REXDirectAccess | Base class for main DirectAccess class.
REXDirectRevitAccess | Base class for main DirectAccess class.
REXDirectRevitExecute | This is class REX.Common.REXDirectRevitExecute.
REXErrors | Supprots REX errors for logging system.
REXExtension | Additional functionality of REXExtension class.
REXExtensionContext | Internal class for controlling behavior of the extension.
REXExtensionControl | Base class for user controls.
REXExtensionData | Base class for REXData and REXResults classes.
REXExtensionDataSerializable | Base class for REXDataSerializable and REXResultsSerializable classes.
REXExtensionMainControl | Base class for main control.
REXExtensionObject | Base class for all objects created in extension module.
REXExtensionPanel | Base class for panel control.