REX.Common.Revit.Units Namespace Classes

REX.Common.Revit.Units Namespace Classes
REX.Common.Revit.Units Namespace Legend
Classes
Class | Description
REXUnitsControl | Display units management class for Revit context.

Classes (AutoDoc Folder)

Legend
Legend
Class
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

Legend

Legend
REX.Common.Revit.Units Namespace
Legend
Class
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

Legend

Legend
REXUnitsControl Class
Legend
Constructor
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXUnitsControl Class Members

REXUnitsControl Class Members
REXUnitsControl Class Legend
Members
Public Methods
Public Method | Description
REXUnitsControl | Initializes a new instance of the REXUnitsControl class.
REXUnitsControl Methods
REXUnitsControl Methods | Description
Setup | Setups display units.
Update | Updates display units.

Members

Legend
Legend
Constructor
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXUnitsControl Methods

REXUnitsControl Methods
REXUnitsControl Class Legend
REXUnitsControl Methods
REXUnitsControl Methods | Description
Setup | Setups display units.
Update | Updates display units.

REXUnitsControl Class Public Methods

REXUnitsControl Class Public Methods
REXUnitsControl Class Legend
Public Methods
Public Method | Description
REXUnitsControl | Initializes a new instance of the REXUnitsControl class.

Public Methods

Legend
Legend
Constructor
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

See Also

See Also
REXUnitsControl.Update Method
See Also

Setup()

REXAccess Enumerations

REXAccess Enumerations
REXAccess Class Legend
REXAccess Enumerations
REXAccess Enumerations | Description
REXAccessEvent |

Enumerations (AutoDoc Folder)

Legend
Legend
Enumeration
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

Legend

Legend
REXAccess Class
Legend
Constructor
Enumeration
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXAccess Class Members

REXAccess Class Members
REXAccess Class Legend
Members
Public Methods
Public Method | Description
REXAccess | Initializes a new instance of the REXAccess class.
REXAccess Enumerations
REXAccess Enumerations | Description
REXAccessEvent |
REXAccess Methods
REXAccess Methods | Description
Access | This is Access, a member of class REXAccess.
Create | Reads some data from parent application and set system display units.
Destroy | Destroys and reset some objects connected to parent application.
Detach | Detaches this instance.
Event | Events the specified event.
Initialize | Initializes this instance.
Update | Reads some data from parent application and set system display units.
REXAccess Properties
REXAccess Properties | Description
Interfaces | This is Interfaces, a member of class REXAccess.

Members

Legend
Legend
Constructor
Enumeration
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXAccess Methods

REXAccess Methods
REXAccess Class Legend
REXAccess Methods
REXAccess Methods | Description
Access | This is Access, a member of class REXAccess.
Create | Reads some data from parent application and set system display units.
Destroy | Destroys and reset some objects connected to parent application.
Detach | Detaches this instance.
Event | Events the specified event.
Initialize | Initializes this instance.
Update | Reads some data from parent application and set system display units.

REXAccess Properties

REXAccess Properties
REXAccess Class Legend
REXAccess Properties
REXAccess Properties | Description
Interfaces | This is Interfaces, a member of class REXAccess.

REXAccess Class Public Methods

REXAccess Class Public Methods
REXAccess Class Legend
Public Methods
Public Method | Description
REXAccess | Initializes a new instance of the REXAccess class.

Legend

Legend
REXApplication Class
Legend
Constructor
virtual
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXApplication Class Members

REXApplication Class Members
REXApplication Class Legend
Members
Public Methods
Public Method | Description
REXApplication | Initializes a new instance of a REXApplication class.
REXApplication Methods
REXApplication Methods | Description
CheckValidity | Checks the date limit.
Close | Closes this instance.
Command | Called when command.
Control | Get main control for embeding in a application form.
Create | Create module.
Create | Create module.
Event | Called when event.
GetExtension | Get the extension.
GetService | This is GetService, a member of class REXApplication.
GetText | Gets the text.
GetUniqueId | This is GetUniqueId, a member of class REXApplication.
GetVersion | Gets the minimum required version of specified engine's component.
Modal | Creates and shows module as modal dialog.
Modal | Creates and shows module as a modal dialog.
OnCreate | Called when create application object.
RestoreCultureInfo | Restores the culture info.
Show | Shows this module.
REXApplication Properties
REXApplication Properties | Description
Context | Get the reference to the old context.
Context2 | Get the context2.
ContextProduct | Get the context product from the old context structure.
ContextProduct2 | Get the context product2.
ThisApplication | This is ThisApplication, a member of class REXApplication.
ThisContext | This is ThisContext, a member of class REXApplication.
ThisExtension | This is ThisExtension, a member of class REXApplication.
Visible | Get or set a value indicating whether this REXApplication is visible.

Members

Legend
Legend
Constructor
virtual
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXApplication Methods

REXApplication Methods
REXApplication Class Legend
REXApplication Methods
REXApplication Methods | Description
CheckValidity | Checks the date limit.
Close | Closes this instance.
Command | Called when command.
Control | Get main control for embeding in a application form.
Create | Create module.
Create | Create module.
Event | Called when event.
GetExtension | Get the extension.
GetService | This is GetService, a member of class REXApplication.
GetText | Gets the text.
GetUniqueId | This is GetUniqueId, a member of class REXApplication.
GetVersion | Gets the minimum required version of specified engine's component.
Modal | Creates and shows module as modal dialog.