REXFamilyType_Label.CategoryType Property

REXFamilyType_Label.CategoryType Property
REXFamilyType_Label Class REX.ContentGenerator.Families Namespace REXFamilyType_Label Class

Gets the category.

C#
public override ECategoryType CategoryType;
Description

The category.

Class

REXFamilyType_Label Class

Links
REXFamilyType_Label Class, REX.ContentGenerator.Families Namespace, REXFamilyType_Label Class

REXFamilyType_Label.Parameters Property

REXFamilyType_Label.Parameters Property
REXFamilyType_Label Class REX.ContentGenerator.Families Namespace REXFamilyType_Label Class

Gets the parameters.

C#
public REXLabelDescription Parameters;
Description

The parameters.

Class

REXFamilyType_Label Class

Links
REXFamilyType_Label Class, REX.ContentGenerator.Families Namespace, REXFamilyType_Label Class

REXFamilyType_Material Class

REXFamilyType_Material Class
REX.ContentGenerator.Families Namespace Legend Members Public Methods REXFamilyType_Material Methods REXFamilyType_Material Properties

Represents a material element.

Class Hierarchy
C#
[Serializable()]
public class REXFamilyType_Material : REXFamilyType;
Description
Namespace

REX.ContentGenerator.Families Namespace

Public Methods
Public Method | Description
REXFamilyType_Material | Initializes a new instance of the REXFamilyType_Material class.
REXFamilyType_Material | Initializes a new instance of the REXFamilyType_Material class.
REXFamilyType_Material | Initializes a new instance of the REXFamilyType_Material class.
REXFamilyType_Material Methods
REXFamilyType_Material Methods | Description
Clone | Creates a new object that is a copy of the current instance.
CompareTo | Compares the current object with the other object.
REXFamilyType_Material Properties
REXFamilyType_Material Properties | Description
CategoryType | Gets the category.
Parameters | Gets or sets the parameters.
Links
REX.ContentGenerator.Families Namespace, Legend, Members, Public Methods, REXFamilyType_Material Methods, REXFamilyType_Material Properties

REXFamilyType_Material.REXFamilyType_Material Constructor ()

REXFamilyType_Material.REXFamilyType_Material Constructor ()
REXFamilyType_Material Class REX.ContentGenerator.Families Namespace REXFamilyType_Material Class

Initializes a new instance of the REXFamilyType_Material class.

C#
public REXFamilyType_Material();
Description
Class

REXFamilyType_Material Class

Links
REXFamilyType_Material Class, REX.ContentGenerator.Families Namespace, REXFamilyType_Material Class

REXFamilyType_Material.REXFamilyType_Material Constructor (REXFamilyType_Material)

REXFamilyType_Material.REXFamilyType_Material Constructor (REXFamilyType_Material)
REXFamilyType_Material Class REX.ContentGenerator.Families Namespace REXFamilyType_Material Class

Initializes a new instance of the REXFamilyType_Material class.

C#
public REXFamilyType_Material(REXFamilyType_Material pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

REXFamilyType_Material Class

Links
REXFamilyType_Material Class, REX.ContentGenerator.Families Namespace, REXFamilyType_Material Class

REXFamilyType_Material.REXFamilyType_Material Constructor (string, string, REX.ContentGenerator.Families.EElementType, bool, EMaterial)

REXFamilyType_Material.REXFamilyType_Material Constructor (string, string, REX.ContentGenerator.Families.EElementType, bool, EMaterial)
REXFamilyType_Material Class REX.ContentGenerator.Families Namespace REXFamilyType_Material Class

Initializes a new instance of the REXFamilyType_Material class.

C#
public REXFamilyType_Material(string familyName, string typeName, REX.ContentGenerator.Families.EElementType category, bool certified, EMaterial material);
Parameters
Parameters | Description
familyName | The name of the family.
typeName | The name of the type.
category | The category.
certified | Indicates whether the object is certified.
material | The material.
Description
Class

REXFamilyType_Material Class

Links
REXFamilyType_Material Class, REX.ContentGenerator.Families Namespace, REXFamilyType_Material Class

REXFamilyType_Material.Clone Method

REXFamilyType_Material.Clone Method
REXFamilyType_Material Class REX.ContentGenerator.Families Namespace REXFamilyType_Material Class

Creates a new object that is a copy of the current instance.

C#
public override object Clone();
Returns

A new object that is a copy of this instance.

Description
Class

REXFamilyType_Material Class

Links
REXFamilyType_Material Class, REX.ContentGenerator.Families Namespace, REXFamilyType_Material Class

REXFamilyType_Material.CompareTo Method

REXFamilyType_Material.CompareTo Method
REXFamilyType_Material Class REX.ContentGenerator.Families Namespace REXFamilyType_Material Class

Compares the current object with the other object.

C#
public override int CompareTo(object obj);
Parameters
Parameters | Description
obj | The object.
Returns

Returns a result of the comparison.

Description
Class

REXFamilyType_Material Class

Links
REXFamilyType_Material Class, REX.ContentGenerator.Families Namespace, REXFamilyType_Material Class

REXFamilyType_Material.CategoryType Property

REXFamilyType_Material.CategoryType Property
REXFamilyType_Material Class REX.ContentGenerator.Families Namespace REXFamilyType_Material Class

Gets the category.

C#
public override ECategoryType CategoryType;
Description

The category.

Class

REXFamilyType_Material Class

Links
REXFamilyType_Material Class, REX.ContentGenerator.Families Namespace, REXFamilyType_Material Class

REXFamilyType_Material.Parameters Property

REXFamilyType_Material.Parameters Property
REXFamilyType_Material Class REX.ContentGenerator.Families Namespace REXFamilyType_Material Class

Gets or sets the parameters.

C#
public REXMaterialDBDescription Parameters;
Description

The parameters.

Class

REXFamilyType_Material Class

Links
REXFamilyType_Material Class, REX.ContentGenerator.Families Namespace, REXFamilyType_Material Class

REXFamilyType_ParamSection Class

REXFamilyType_ParamSection Class
REX.ContentGenerator.Families Namespace Legend Members Public Methods REXFamilyType_ParamSection Methods REXFamilyType_ParamSection Properties

Represents a parametric section.

Class Hierarchy
C#
[Serializable()]
public class REXFamilyType_ParamSection : REXFamilyType_Section;
Description
Namespace

REX.ContentGenerator.Families Namespace

Public Methods
Public Method | Description
REXFamilyType_ParamSection | Initializes a new instance of the REXFamilyType_ParamSection class.
REXFamilyType_ParamSection | Initializes a new instance of the REXFamilyType_ParamSection class.
REXFamilyType_ParamSection | Initializes a new instance of the REXFamilyType_ParamSection class.
REXFamilyType_ParamSection Methods
REXFamilyType_ParamSection Methods | Description
Clone | Creates a new object that is a copy of the current instance.
CompareTo | Compares the current object with the other object.
GetMaterialDependence | Gets the material dependence.
REXFamilyType_ParamSection Properties
REXFamilyType_ParamSection Properties | Description
CategoryType | Gets the category.
Parameters | Gets or sets the parameters.
Links
REX.ContentGenerator.Families Namespace, Legend, Members, Public Methods, REXFamilyType_ParamSection Methods, REXFamilyType_ParamSection Properties

REXFamilyType_ParamSection.REXFamilyType_ParamSection Constructor ()

REXFamilyType_ParamSection.REXFamilyType_ParamSection Constructor ()
REXFamilyType_ParamSection Class REX.ContentGenerator.Families Namespace REXFamilyType_ParamSection Class

Initializes a new instance of the REXFamilyType_ParamSection class.

C#
public REXFamilyType_ParamSection();
Description
Class

REXFamilyType_ParamSection Class

Links
REXFamilyType_ParamSection Class, REX.ContentGenerator.Families Namespace, REXFamilyType_ParamSection Class

REXFamilyType_ParamSection.REXFamilyType_ParamSection Constructor (REXFamilyType_ParamSection)