Gets the value and converts it to display units.

C#
public double GetDataDisplay(string nameUnitObject);
Parameters
Parameters | Description
nameUnitObject | The name of the unit object.
Returns

Returns value.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class

REXDFM.GetDataInterface Method (IUnitObject)

REXDFM.GetDataInterface Method (IUnitObject)
REXDFM Class REX.Common Namespace REXDFM Class

Gets the value and converts it to interface units.

C#
public double GetDataInterface(IUnitObject myUnitObject);
Parameters
Parameters | Description
myUnitObject | The reference to the unit object.
Returns

Returns value.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class

REXDFM.GetDataInterface Method (string)

REXDFM.GetDataInterface Method (string)
REXDFM Class REX.Common Namespace REXDFM Class

Gets the value and converts it to interface units.

C#
public double GetDataInterface(string nameUnitObject);
Parameters
Parameters | Description
nameUnitObject | The name of the unit object.
Returns

Returns value.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class

REXDFM.GetDataText Method (IUnitObject)

REXDFM.GetDataText Method (IUnitObject)
REXDFM Class REX.Common Namespace REXDFM Class

Gets the current text.

C#
public string GetDataText(IUnitObject myUnitObject);
Parameters
Parameters | Description
myUnitObject | The reference to the unit object.
Returns

Returns the current text.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class

REXDFM.GetDataText Method (string)

REXDFM.GetDataText Method (string)
REXDFM Class REX.Common Namespace REXDFM Class

Gets the current text.

C#
public string GetDataText(string nameUnitObject);
Parameters
Parameters | Description
nameUnitObject | The name of the unit object.
Returns

Returns the current text.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class

REXDFM.GetObjectsOfNotOkState Method

REXDFM.GetObjectsOfNotOkState Method
REXDFM Class REX.Common Namespace REXDFM Class

Gets the list of registered objects which are in a state other then OK.

C#
public List<IUnitObject> GetObjectsOfNotOkState();
Returns

The list of objects.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class

REXDFM.RemoveUnitObject Method (IUnitObject)

REXDFM.RemoveUnitObject Method (IUnitObject)
REXDFM Class REX.Common Namespace REXDFM Class

Removes the unit object.

C#
public bool RemoveUnitObject(IUnitObject myUnitObject);
Parameters
Parameters | Description
myUnitObject | The reference to the unit object.
Returns

Returns true if operation succeeded

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class

REXDFM.RemoveUnitObject Method (string)

REXDFM.RemoveUnitObject Method (string)
REXDFM Class REX.Common Namespace REXDFM Class

Removes the unit object.

C#
public bool RemoveUnitObject(string nameUnitObject);
Parameters
Parameters | Description
nameUnitObject | The name of the unit object.
Returns

Returns true if operation succeeded

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class

REXDFM.SetBaseMaxValue Method (IUnitObject, bool, double)

REXDFM.SetBaseMaxValue Method (IUnitObject, bool, double)
REXDFM Class REX.Common Namespace REXDFM Class

Sets the maximum value defined in base units.

C#
public bool SetBaseMaxValue(IUnitObject myUnitObject, bool CheckVal, double baseVal);
Parameters
Parameters | Description
myUnitObject | Reference to based control on IUnitObject interface.
CheckVal | If set to true, value is checked.
baseVal | The base value.
Returns

Returns true if succeeded.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class

REXDFM.SetBaseMaxValue Method (string, bool, double)

REXDFM.SetBaseMaxValue Method (string, bool, double)
REXDFM Class REX.Common Namespace REXDFM Class

Sets the maximum value defined in base units.

C#
public bool SetBaseMaxValue(string nameUnitObject, bool CheckVal, double baseVal);
Parameters
Parameters | Description
nameUnitObject | The name of the unit object.
CheckVal | If set to true, value is checked.
baseVal | The base value.
Returns

Returns true if succeeded.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class

REXDFM.SetBaseMinValue Method (IUnitObject, bool, double)

REXDFM.SetBaseMinValue Method (IUnitObject, bool, double)
REXDFM Class REX.Common Namespace REXDFM Class

Sets the minimum value in base units.

C#
public bool SetBaseMinValue(IUnitObject myUnitObject, bool CheckVal, double baseVal);
Parameters
Parameters | Description
myUnitObject | The reference to the unit object.
CheckVal | If set to true, value is checked.
baseVal | The base value.
Returns

Returns true if succeeded.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class

REXDFM.SetBaseMinValue Method (string, bool, double)

REXDFM.SetBaseMinValue Method (string, bool, double)
REXDFM Class REX.Common Namespace REXDFM Class

Sets the minimum value in base units.

C#
public bool SetBaseMinValue(string nameUnitObject, bool CheckVal, double baseVal);
Parameters
Parameters | Description
nameUnitObject | The name of the unit object.
CheckVal | If set to true, value is checked.
baseVal | The base value.
Returns

Returns true if succeeded.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class

REXDFM.SetComplexDataBase Method (IUnitObject, List<double>)

REXDFM.SetComplexDataBase Method (IUnitObject, List<double>)
REXDFM Class REX.Common Namespace REXDFM Class

Sets the list of values in base units.

C#
public bool SetComplexDataBase(IUnitObject myUnitObject, List<double> Value);
Parameters
Parameters | Description
myUnitObject | The reference to the unit object.
Value | The values.
Returns

Returns true if succeeded.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class

REXDFM.SetComplexDataBase Method (string, List<double>)

REXDFM.SetComplexDataBase Method (string, List<double>)
REXDFM Class REX.Common Namespace REXDFM Class

Sets the list of values in base units.

C#
public bool SetComplexDataBase(string nameUnitObject, List<double> Value);
Parameters
Parameters | Description
nameUnitObject | The name of the unit object.
Value | The values.
Returns

Returns true if succeeded.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class

REXDFM.SetComplexDataDisplay Method (IUnitObject, List<double>)

REXDFM.SetComplexDataDisplay Method (IUnitObject, List<double>)
REXDFM Class REX.Common Namespace REXDFM Class

Sets the list of values defined in display units.

C#
public bool SetComplexDataDisplay(IUnitObject myUnitObject, List<double> Value);
Parameters
Parameters | Description
myUnitObject | The reference to the unit object.
Value | The values.
Returns

Returns true if succeeded.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class

REXDFM.SetComplexDataDisplay Method (string, List<double>)

REXDFM.SetComplexDataDisplay Method (string, List<double>)
REXDFM Class REX.Common Namespace REXDFM Class

Sets the list of values defined in display units.

C#
public bool SetComplexDataDisplay(string nameUnitObject, List<double> Value);
Parameters
Parameters | Description
nameUnitObject | The name of the unit object.
Value | The values.
Returns

Returns true if succeeded.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class

REXDFM.SetComplexDataInterface Method (IUnitObject, List<double>)

REXDFM.SetComplexDataInterface Method (IUnitObject, List<double>)
REXDFM Class REX.Common Namespace REXDFM Class

Sets the list of values in interface units.

C#
public bool SetComplexDataInterface(IUnitObject myUnitObject, List<double> Value);
Parameters