REXParamSectionFactory.GetAliasName Method
REXParamSectionFactory Class REX.ContentGenerator.Converters Namespace REXParamSectionFactory Class

This is GetAliasName, a member of class REXParamSectionFactory.

C#
public override bool GetAliasName(REXDBDescription DBdesc, out string type, out List<string> alias);
Class

REXParamSectionFactory Class

Links
REXParamSectionFactory Class, REX.ContentGenerator.Converters Namespace, REXParamSectionFactory Class

REXParamSectionFactory.GetAllFamilies Method

REXParamSectionFactory.GetAllFamilies Method
REXParamSectionFactory Class REX.ContentGenerator.Converters Namespace REXParamSectionFactory Class

This is GetAllFamilies, a member of class REXParamSectionFactory.

C#
public override List<REXFamilyType> GetAllFamilies(string dir, string path, REXContentFilter filter, bool forMapping);
Class

REXParamSectionFactory Class

Links
REXParamSectionFactory Class, REX.ContentGenerator.Converters Namespace, REXParamSectionFactory Class

REXParamSectionFactory.GetDBList Method (List<REXFamilyType>, string, string)

REXParamSectionFactory.GetDBList Method (List<REXFamilyType>, string, string)
REXParamSectionFactory Class REX.ContentGenerator.Converters Namespace REXParamSectionFactory Class

This is GetDBList, a member of class REXParamSectionFactory.

C#
public override List<REXDBDescription> GetDBList(List<REXFamilyType> obj, string dbname, string dir);
Class

REXParamSectionFactory Class

Links
REXParamSectionFactory Class, REX.ContentGenerator.Converters Namespace, REXParamSectionFactory Class

REXParamSectionFactory.GetDBList Method (REXFamilyType, string, string)

REXParamSectionFactory.GetDBList Method (REXFamilyType, string, string)
REXParamSectionFactory Class REX.ContentGenerator.Converters Namespace REXParamSectionFactory Class

This is GetDBList, a member of class REXParamSectionFactory.

C#
public override List<REXDBDescription> GetDBList(REXFamilyType obj, string dbname, string dir);
Class

REXParamSectionFactory Class

Links
REXParamSectionFactory Class, REX.ContentGenerator.Converters Namespace, REXParamSectionFactory Class

REXParamSectionFactory.GetFamiliesOfAlias Method

REXParamSectionFactory.GetFamiliesOfAlias Method
REXParamSectionFactory Class REX.ContentGenerator.Converters Namespace REXParamSectionFactory Class

This is GetFamiliesOfAlias, a member of class REXParamSectionFactory.

C#
public override List<REXFamilyType> GetFamiliesOfAlias(REX.ContentGenerator.Families.EElementType el, string alias, out bool found);
Class

REXParamSectionFactory Class

Links
REXParamSectionFactory Class, REX.ContentGenerator.Converters Namespace, REXParamSectionFactory Class

REXParamSectionFactory.GetFamily Method

REXParamSectionFactory.GetFamily Method
REXParamSectionFactory Class REX.ContentGenerator.Converters Namespace REXParamSectionFactory Class

This is GetFamily, a member of class REXParamSectionFactory.

C#
public override REXFamilyType GetFamily(REXDBDescription DBdesc, REX.ContentGenerator.Families.EElementType el, EMaterial mat);
Class

REXParamSectionFactory Class

Links
REXParamSectionFactory Class, REX.ContentGenerator.Converters Namespace, REXParamSectionFactory Class

REXParamSectionFactory.GetFamilyDefault Method

REXParamSectionFactory.GetFamilyDefault Method
REXParamSectionFactory Class REX.ContentGenerator.Converters Namespace REXParamSectionFactory Class

This is GetFamilyDefault, a member of class REXParamSectionFactory.

C#
public override REXFamilyType GetFamilyDefault(REX.ContentGenerator.Families.EElementType el, EMaterial mat, string type);
Class

REXParamSectionFactory Class

Links
REXParamSectionFactory Class, REX.ContentGenerator.Converters Namespace, REXParamSectionFactory Class

REXParamSectionFactory.GetFamilyOfAlias Method

REXParamSectionFactory.GetFamilyOfAlias Method
REXParamSectionFactory Class REX.ContentGenerator.Converters Namespace REXParamSectionFactory Class

This is GetFamilyOfAlias, a member of class REXParamSectionFactory.

C#
public override REXFamilyType GetFamilyOfAlias(REX.ContentGenerator.Families.EElementType el, string alias, out bool found);
Class

REXParamSectionFactory Class

Links
REXParamSectionFactory Class, REX.ContentGenerator.Converters Namespace, REXParamSectionFactory Class

REXParamSectionFactory.GetFamilyTemplate Method

REXParamSectionFactory.GetFamilyTemplate Method
REXParamSectionFactory Class REX.ContentGenerator.Converters Namespace REXParamSectionFactory Class

This is GetFamilyTemplate, a member of class REXParamSectionFactory.

C#
public override REXFamilyType GetFamilyTemplate(REX.ContentGenerator.Families.EElementType el, EMaterial mat);
Class

REXParamSectionFactory Class

Links
REXParamSectionFactory Class, REX.ContentGenerator.Converters Namespace, REXParamSectionFactory Class

RVTCommonSectionFactory Class

RVTCommonSectionFactory Class
REX.ContentGenerator.Converters Namespace Legend Members Public Methods RVTCommonSectionFactory Methods

This is class REX.ContentGenerator.Converters.RVTCommonSectionFactory.

Class Hierarchy
C#
public class RVTCommonSectionFactory : RVTFamilyFactory;
Namespace

REX.ContentGenerator.Converters Namespace

Public Methods
Public Method | Description
RVTCommonSectionFactory | This is RVTCommonSectionFactory, a member of class RVTCommonSectionFactory.
RVTCommonSectionFactory Methods
RVTCommonSectionFactory Methods | Description
AddElement2FamList | This is AddElement2FamList, a member of class RVTCommonSectionFactory.
AddElement2FamList | This is AddElement2FamList, a member of class RVTCommonSectionFactory.
GetElement4ParamIdentity | This is GetElement4ParamIdentity, a member of class RVTCommonSectionFactory.
GetExistingNames | This is GetExistingNames, a member of class RVTCommonSectionFactory.
GetName4Mapping | This is GetName4Mapping, a member of class RVTCommonSectionFactory.
GetRevitTypesForInit | This is GetRevitTypesForInit, a member of class RVTCommonSectionFactory.
OnClose | This is OnClose, a member of class RVTCommonSectionFactory.
Recalculate | This is Recalculate, a member of class RVTCommonSectionFactory.
ValidateElement | This is ValidateElement, a member of class RVTCommonSectionFactory.
Links
REX.ContentGenerator.Converters Namespace, Legend, Members, Public Methods, RVTCommonSectionFactory Methods

RVTCommonSectionFactory.RVTCommonSectionFactory Constructor

RVTCommonSectionFactory.RVTCommonSectionFactory Constructor
RVTCommonSectionFactory Class REX.ContentGenerator.Converters Namespace RVTCommonSectionFactory Class

This is RVTCommonSectionFactory, a member of class RVTCommonSectionFactory.

C#
public RVTCommonSectionFactory(RvtConversionSettings Settings, CompositeLevel Fams);
Class

RVTCommonSectionFactory Class

Links
RVTCommonSectionFactory Class, REX.ContentGenerator.Converters Namespace, RVTCommonSectionFactory Class

RVTCommonSectionFactory.AddElement2FamList Method (Autodesk.Revit.DB.Element)

RVTCommonSectionFactory.AddElement2FamList Method (Autodesk.Revit.DB.Element)
RVTCommonSectionFactory Class REX.ContentGenerator.Converters Namespace RVTCommonSectionFactory Class

This is AddElement2FamList, a member of class RVTCommonSectionFactory.

C#
public override bool AddElement2FamList(Autodesk.Revit.DB.Element el);
Class

RVTCommonSectionFactory Class

Links
RVTCommonSectionFactory Class, REX.ContentGenerator.Converters Namespace, RVTCommonSectionFactory Class

RVTCommonSectionFactory.AddElement2FamList Method (Autodesk.Revit.DB.Element, REXFamilyType, bool)

RVTCommonSectionFactory.AddElement2FamList Method (Autodesk.Revit.DB.Element, REXFamilyType, bool)
RVTCommonSectionFactory Class REX.ContentGenerator.Converters Namespace RVTCommonSectionFactory Class

This is AddElement2FamList, a member of class RVTCommonSectionFactory.

C#
public override bool AddElement2FamList(Autodesk.Revit.DB.Element el, REXFamilyType ft, bool addToDict);
Class

RVTCommonSectionFactory Class

Links