REXSectionDBDescription Class, REX.ContentGenerator.Families Namespace, REXSectionDBDescription Class

REXSectionDBDescription.Clone Method

REXSectionDBDescription.Clone Method
REXSectionDBDescription Class REX.ContentGenerator.Families Namespace REXSectionDBDescription Class

Creates a new object that is a copy of the current instance.

C#
public override object Clone();
Returns

A new object that is a copy of this instance.

Description
Class

REXSectionDBDescription Class

Links
REXSectionDBDescription Class, REX.ContentGenerator.Families Namespace, REXSectionDBDescription Class

REXSectionDBDescription.CompareTo Method

REXSectionDBDescription.CompareTo Method
REXSectionDBDescription Class REX.ContentGenerator.Families Namespace REXSectionDBDescription Class

Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.

C#
public override int CompareTo(object obj);
Parameters
Parameters | Description
obj | An object to compare with this instance.
Returns

Returns a result of the comparison.

Description
Class

REXSectionDBDescription Class

Links
REXSectionDBDescription Class, REX.ContentGenerator.Families Namespace, REXSectionDBDescription Class

REXSectionDBDescription.GetContour Method

REXSectionDBDescription.GetContour Method
REXSectionDBDescription Class REX.ContentGenerator.Families Namespace REXSectionDBDescription Class

Gets the contour of the section.

C#
public REX.ContentGenerator.Geometry.Contour_Section GetContour();
Description
Class

REXSectionDBDescription Class

Links
REXSectionDBDescription Class, REX.ContentGenerator.Families Namespace, REXSectionDBDescription Class

REXSectionDBDescription.GetName Method

REXSectionDBDescription.GetName Method
REXSectionDBDescription Class REX.ContentGenerator.Families Namespace REXSectionDBDescription Class

Gets the name of the section.

C#
public override string GetName();
Returns

Returns the name.

Description
Class

REXSectionDBDescription Class

Links
REXSectionDBDescription Class, REX.ContentGenerator.Families Namespace, REXSectionDBDescription Class

REXSectionDBDescription.GetSectionType Method ()

REXSectionDBDescription.GetSectionType Method ()
REXSectionDBDescription Class REX.ContentGenerator.Families Namespace REXSectionDBDescription Class

Gets the type of the section.

C#
public EDBSectionType GetSectionType();
Description
Class

REXSectionDBDescription Class

Links
REXSectionDBDescription Class, REX.ContentGenerator.Families Namespace, REXSectionDBDescription Class

REXSectionDBDescription.GetSectionType Method (int)

REXSectionDBDescription.GetSectionType Method (int)
REXSectionDBDescription Class REX.ContentGenerator.Families Namespace REXSectionDBDescription Class

Gets the type of the section.

C#
public static EDBSectionType GetSectionType(int st);
Parameters
Parameters | Description
st | The section type.
Description
Class

REXSectionDBDescription Class

Links
REXSectionDBDescription Class, REX.ContentGenerator.Families Namespace, REXSectionDBDescription Class

REXSectionDBDescription.Characteristics Property

REXSectionDBDescription.Characteristics Property
REXSectionDBDescription Class REX.ContentGenerator.Families Namespace REXSectionDBDescription Class

Gets or sets the characteristics of the section.

C#
public REXSectionDBCharacteristics Characteristics;
Description

The characteristics of the section.

Class

REXSectionDBDescription Class

Links
REXSectionDBDescription Class, REX.ContentGenerator.Families Namespace, REXSectionDBDescription Class

REXSectionDBDescription.Description Property

REXSectionDBDescription.Description Property
REXSectionDBDescription Class REX.ContentGenerator.Families Namespace REXSectionDBDescription Class

Gets or sets the description of the section.

C#
public REX.ContentGenerator.Families.REXSectionDBProperties Description;
Description

The description of the section.

Class

REXSectionDBDescription Class

Links
REXSectionDBDescription Class, REX.ContentGenerator.Families Namespace, REXSectionDBDescription Class

REXSectionDBDescription.DIM1 Property

REXSectionDBDescription.DIM1 Property
REXSectionDBDescription Class REX.ContentGenerator.Families Namespace REXSectionDBDescription Class

Gets or sets the first numeric component of the section label

C#
public double DIM1;
Description
Remarks

It is taken as key for identification process in a database (with combination of: NAME, DIM2, DIM3).

Class

REXSectionDBDescription Class

Links
REXSectionDBDescription Class, REX.ContentGenerator.Families Namespace, REXSectionDBDescription Class

REXSectionDBDescription.DIM2 Property

REXSectionDBDescription.DIM2 Property
REXSectionDBDescription Class REX.ContentGenerator.Families Namespace REXSectionDBDescription Class

Gets or sets the second numeric component of the section label.

C#
public double DIM2;
Description

The second numeric component of the section label.

Remarks

It is taken as key for identification process in a database (with combination of: NAME, DIM1, DIM3).

Class

REXSectionDBDescription Class

Links
REXSectionDBDescription Class, REX.ContentGenerator.Families Namespace, REXSectionDBDescription Class

REXSectionDBDescription.DIM3 Property

REXSectionDBDescription.DIM3 Property
REXSectionDBDescription Class REX.ContentGenerator.Families Namespace REXSectionDBDescription Class

Gets or sets the third numeric component of the section label.

C#
public double DIM3;
Description

The third numeric component of the section label.

Remarks

It is taken as key for identification process in a database (with combination of: NAME, DIM1, DIM2).

Class

REXSectionDBDescription Class

Links
REXSectionDBDescription Class, REX.ContentGenerator.Families Namespace, REXSectionDBDescription Class

REXSectionDBDescription.Dimensions Property

REXSectionDBDescription.Dimensions Property
REXSectionDBDescription Class REX.ContentGenerator.Families Namespace REXSectionDBDescription Class

Gets or sets the dimensions.

C#
public REX.ContentGenerator.Families.REXSectionDBDimensions Dimensions;
Description

The dimensions.

Class

REXSectionDBDescription Class

Links
REXSectionDBDescription Class, REX.ContentGenerator.Families Namespace, REXSectionDBDescription Class

REXSectionDBDescription.NAME Property

REXSectionDBDescription.NAME Property
REXSectionDBDescription Class REX.ContentGenerator.Families Namespace REXSectionDBDescription Class

Gets or sets the name of the section.

C#
public string NAME;
Description

The name.

Remarks

It is taken as key for identification process in a database (with combination of: DIM1, DIM2, DIM3).

Class

REXSectionDBDescription Class

Links
REXSectionDBDescription Class, REX.ContentGenerator.Families Namespace, REXSectionDBDescription Class

REXSectionDBDimensions Class

REXSectionDBDimensions Class
REX.ContentGenerator.Families Namespace Legend Members Public Methods REXSectionDBDimensions Methods REXSectionDBDimensions Properties

Describes dimensions of the database section.

Class Hierarchy
C#
[Serializable()]
public class REXSectionDBDimensions : REXDescription;
Description
Namespace

REX.ContentGenerator.Families Namespace

Public Methods
Public Method | Description
REXSectionDBDimensions | Initializes a new instance of the REXSectionDBDimensions class.
REXSectionDBDimensions | Initializes a new instance of the REXSectionDBDimensions class.
REXSectionDBDimensions | Initializes a new instance of the REXSectionDBDimensions class.
REXSectionDBDimensions | Initializes a new instance of the REXSectionDBDimensions class.
REXSectionDBDimensions Methods
REXSectionDBDimensions Methods | Description
Clone | Creates a new object that is a copy of the current instance.
REXSectionDBDimensions Properties
REXSectionDBDimensions Properties | Description
A_1 | Gets or sets the additional angle.
A_2 | Gets or sets the additional angle.