REXExtensionWindow | Initializes a new instance of a REXExtensionForm class.
REXExtensionWindow | Initializes a new instance of a REXExtensionForm class.
REXExtensionWindow Properties
REXExtensionWindow Properties | Description
ThisApplication | Get this application.
ThisContext | Get this context.
ThisExtension | Get this extension.
ThisProduct | Gets the this product.
ThisRunContext | Gets the this run context.
WindowStatus | This is WindowStatus, a member of class REXExtensionWindow.

REXExtensionWindow Properties

REXExtensionWindow Properties
REXExtensionWindow Class Legend
REXExtensionWindow Properties
REXExtensionWindow Properties | Description
ThisApplication | Get this application.
ThisContext | Get this context.
ThisExtension | Get this extension.
ThisProduct | Gets the this product.
ThisRunContext | Gets the this run context.
WindowStatus | This is WindowStatus, a member of class REXExtensionWindow.

REXExtensionWindow Class Public Methods

REXExtensionWindow Class Public Methods
REXExtensionWindow Class Legend
Public Methods
Public Method | Description
REXExtensionWindow | Initializes a new instance of a REXExtensionForm class.
REXExtensionWindow | Initializes a new instance of a REXExtensionForm class.

Legend

Legend
REXFoundationApplication Class
Legend
Constructor
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXFoundationApplication Class Members

REXFoundationApplication Class Members
REXFoundationApplication Class Legend
Members
Public Methods
Public Method | Description
REXFoundationApplication | Initializes a new instance of the REXApplication class.
REXFoundationApplication Methods
REXFoundationApplication Methods | Description
Close | Closes this instance.
Command | Commands the specified command struct.
Control | Controls this instance.
Create | Creates and shows module as modal dialog.
Create | Creates and shows module as modal dialog.
Event | Called when event.
GetService | Gets the the service.
GetUniqueId | Returns the unique id for the module
Modal | Creates and shows module as modal dialog.
Modal | Creates and shows module as modal dialog.
Show | Shows this module.

REXFoundationApplication Methods

REXFoundationApplication Methods
REXFoundationApplication Class Legend
REXFoundationApplication Methods
REXFoundationApplication Methods | Description
Close | Closes this instance.
Command | Commands the specified command struct.
Control | Controls this instance.
Create | Creates and shows module as modal dialog.
Create | Creates and shows module as modal dialog.
Event | Called when event.
GetService | Gets the the service.
GetUniqueId | Returns the unique id for the module
Modal | Creates and shows module as modal dialog.
Modal | Creates and shows module as modal dialog.
Show | Shows this module.

REXFoundationApplication Class Public Methods

REXFoundationApplication Class Public Methods
REXFoundationApplication Class Legend
Public Methods
Public Method | Description
REXFoundationApplication | Initializes a new instance of the REXApplication class.

Legend

Legend
REXLayout Class
Legend
Constructor
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXLayout Class Members

REXLayout Class Members
REXLayout Class Legend
Members
Public Methods
Public Method | Description
REXLayout | Initializes a new instance of the REXLayout class.
REXLayout Methods
REXLayout Methods | Description
AddLayout | Adds the layout.
AddLayout | Adds the layout.
AddLayout | Adds the layout.
AddLayout_Dialog | Adds the predefined layout with one dialog.
AddLayout_Dialog_Menu | Adds the predefined layout which contains one dialog and standard menu.
AddLayout_Dialog_ToolBarMenu_ToolBar | Adds the predefined layout which contains one dialog, menu as tool bar and tool bar.
AddLayout_OptionsList_Menu_BottomDialog_RightDialog | Adds the predefined layout which contains options list, first dialog on the right side, secound dialog on the bottom and standard menu.
AddLayout_OptionsList_Menu_BottomDialog_RightDialogAndHtmlNoteOnTabs | Adds the predefined layout which contains options list, dialog and html note on tabs on the right side, secound dialog on the bottom and standard menu.
AddLayout_OptionsList_Menu_RightDialog | Adds the predefined layout which contains options list, one dialog and standard menu.
AddLayout_OptionsList_Menu_RightDialogAndViewAndHtmlNoteOnTabs | Adds the predefined layout which contains options list, one dialog, view (or dialog), html note on tabs and standard menu.
AddLayout_OptionsList_Menu_RightDialogAndViewOnTabs | Adds the predefined layout which contains options list, one dialog and view (or dialog) on tabs and standard menu.
AddLayout_OptionsList_ToolBarMenu_ToolBar_BottomDialog_RightDialog | Adds the predefined layout which contains options list, first dialog on the right side and secound dialog on the bottom, tool bar as menu and tool bar.
AddLayout_OptionsList_ToolBarMenu_ToolBar_BottomDialog_RightDialogAndHtmlNoteOnTabs | Adds the predefined layout which contains options list, dialog and html note on tabs on the right side, secound dialog on the bottom and tool bar as menu and tool bar.
AddLayout_OptionsList_ToolBarMenu_ToolBar_RightDialog | Adds the predefined layout which contains options list, one dialog, tool bar as menu and tool bar.
AddLayout_OptionsList_ToolBarMenu_ToolBar_RightDialogAndViewOnTabs | Adds the predefined layout which contains options list, dialog and view (or dialog) on tabs, tool bar as menu and tool bar.
CalculateMainControlSize | This is CalculateMainControlSize, a member of class REXLayout.
Clear | Clears all layouts items.
DeSelect | Called after deselect the specified LayoutItem.
DeSelect | This is DeSelect, a member of class REXLayout.
DisposeControls | Disposes all controls in all added layouts.
GetItem | Gets the layout item identified by mame.
GetLayoutIndex | Gets the index of the layout.
GetLayoutItem | This is GetLayoutItem, a member of class REXLayout.
InsertLayout | Adds the layout.
RemoveLayout | Removes the layout.
Select | Called after select the specified LayoutItem.
Select | This is Select, a member of class REXLayout.
SelectLayout | Selects the layout.
Setup | Setups layout and all layout's items.
ToolboxDeSelect | This is ToolboxDeSelect, a member of class REXLayout.
ToolboxGetItem | This is ToolboxGetItem, a member of class REXLayout.
ToolboxRemoveLayout | This is ToolboxRemoveLayout, a member of class REXLayout.
ToolboxSelect | This is ToolboxSelect, a member of class REXLayout.
ToolboxSelectLayout | This is ToolboxSelectLayout, a member of class REXLayout.
ToolboxSetup | This is ToolboxSetup, a member of class REXLayout.
ToolboxSetup | This is ToolboxSetup, a member of class REXLayout.
ToolboxUpdate | This is ToolboxUpdate, a member of class REXLayout.
Update | Updates layout all layout's items.
REXLayout Properties
REXLayout Properties | Description
CommandsOptions | Gets or sets the options for commands.
CommandsOptionsByEnum | Gets or sets the options for commands.
ConstOptions | Gets or sets the const options for all layouts.
ConstOptionsByEnum | Gets or sets the const options for all layouts.
Count | Gets the count of layout items.
Current | Gets the current layout item.
DefaultOptions | Gets or sets the default options for layout.
DisableEvents | Gets a value indicating whether events are disabled.

REXLayout Methods

REXLayout Methods
REXLayout Class Legend
REXLayout Methods
REXLayout Methods | Description
AddLayout | Adds the layout.
AddLayout | Adds the layout.
AddLayout | Adds the layout.
AddLayout_Dialog | Adds the predefined layout with one dialog.