Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXSectionTypeAnalyzer_ROUNDH Class Members

REXSectionTypeAnalyzer_ROUNDH Class Members
REXSectionTypeAnalyzer_ROUNDH Class Legend
Members
REXSectionTypeAnalyzer_ROUNDH Methods
REXSectionTypeAnalyzer_ROUNDH Methods | Description
GetParametricDescription | This is GetParametricDescription, a member of class REXSectionTypeAnalyzer_ROUNDH.
GetParametricDescription | This is GetParametricDescription, a member of class REXSectionTypeAnalyzer_ROUNDH.
VectorDrivenAnalysis | This is VectorDrivenAnalysis, a member of class REXSectionTypeAnalyzer_ROUNDH.

REXSectionTypeAnalyzer_ROUNDH Methods

REXSectionTypeAnalyzer_ROUNDH Methods
REXSectionTypeAnalyzer_ROUNDH Class Legend
REXSectionTypeAnalyzer_ROUNDH Methods
REXSectionTypeAnalyzer_ROUNDH Methods | Description
GetParametricDescription | This is GetParametricDescription, a member of class REXSectionTypeAnalyzer_ROUNDH.
GetParametricDescription | This is GetParametricDescription, a member of class REXSectionTypeAnalyzer_ROUNDH.
VectorDrivenAnalysis | This is VectorDrivenAnalysis, a member of class REXSectionTypeAnalyzer_ROUNDH.

Legend

Legend
REXSectionTypeAnalyzer_ROUNDQ Class
Legend
Method
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXSectionTypeAnalyzer_ROUNDQ Class Members

REXSectionTypeAnalyzer_ROUNDQ Class Members
REXSectionTypeAnalyzer_ROUNDQ Class Legend
Members
REXSectionTypeAnalyzer_ROUNDQ Methods
REXSectionTypeAnalyzer_ROUNDQ Methods | Description
GetParametricDescription | This is GetParametricDescription, a member of class REXSectionTypeAnalyzer_ROUNDQ.
GetParametricDescription | This is GetParametricDescription, a member of class REXSectionTypeAnalyzer_ROUNDQ.
VectorDrivenAnalysis | This is VectorDrivenAnalysis, a member of class REXSectionTypeAnalyzer_ROUNDQ.

REXSectionTypeAnalyzer_ROUNDQ Methods

REXSectionTypeAnalyzer_ROUNDQ Methods
REXSectionTypeAnalyzer_ROUNDQ Class Legend
REXSectionTypeAnalyzer_ROUNDQ Methods
REXSectionTypeAnalyzer_ROUNDQ Methods | Description
GetParametricDescription | This is GetParametricDescription, a member of class REXSectionTypeAnalyzer_ROUNDQ.
GetParametricDescription | This is GetParametricDescription, a member of class REXSectionTypeAnalyzer_ROUNDQ.
VectorDrivenAnalysis | This is VectorDrivenAnalysis, a member of class REXSectionTypeAnalyzer_ROUNDQ.

Legend

Legend
REXSectionTypeAnalyzer_TUBE Class
Legend
Method
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXSectionTypeAnalyzer_TUBE Class Members

REXSectionTypeAnalyzer_TUBE Class Members
REXSectionTypeAnalyzer_TUBE Class Legend
Members
REXSectionTypeAnalyzer_TUBE Methods
REXSectionTypeAnalyzer_TUBE Methods | Description
GetParametricDescription | This is GetParametricDescription, a member of class REXSectionTypeAnalyzer_TUBE.
GetParametricDescription | This is GetParametricDescription, a member of class REXSectionTypeAnalyzer_TUBE.
VectorDrivenAnalysis | This is VectorDrivenAnalysis, a member of class REXSectionTypeAnalyzer_TUBE.

REXSectionTypeAnalyzer_TUBE Methods

REXSectionTypeAnalyzer_TUBE Methods
REXSectionTypeAnalyzer_TUBE Class Legend
REXSectionTypeAnalyzer_TUBE Methods
REXSectionTypeAnalyzer_TUBE Methods | Description
GetParametricDescription | This is GetParametricDescription, a member of class REXSectionTypeAnalyzer_TUBE.
GetParametricDescription | This is GetParametricDescription, a member of class REXSectionTypeAnalyzer_TUBE.
VectorDrivenAnalysis | This is VectorDrivenAnalysis, a member of class REXSectionTypeAnalyzer_TUBE.

REX.ContentGenerator.Map Namespace Classes

REX.ContentGenerator.Map Namespace Classes
REX.ContentGenerator.Map Namespace Legend
Classes
Class | Description
ContentMapper | Provides interface to the mapping system of the ContentGenerator.
REXContentMapCategorySettings | Represents settings for a specific category of elements.
REXContentMapDialogSettings | Represents settings for the map dialog.
REXContentMapper | Provides interface to the mapping system of the Content Generator in REX context.
RVTContentMapper | Provides interface to the mapping system of the Content Generator in Revit context.

Legend

Legend
REX.ContentGenerator.Map Namespace
Legend
Class
abstract

Legend

Legend
ContentMapper Class
Legend
Method
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

ContentMapper Class Members

ContentMapper Class Members
ContentMapper Class Legend
Members
ContentMapper Methods
ContentMapper Methods | Description
AddLabel | Adds the label to the list.
ApplyMapControl | Applies the map control.
CloseMapControl | Closes the map control.
CreateMapControl | Creates the map control.
GetLabels | Gets the labels.
LaunchMapDialog | Launches the map dialog.
LoadUserMap | Loads the user map to the Content Generator.
RefreshMapControl | Refreshes the map control.
ReloadGlobalMap | Reloads the global map.
ResetUserMap | Resets the user map.
SaveGlobalMap | Saves the global map.
SaveUserMap | Saves the user map.
SetDefaults | Sets defaults in the mapping system.
SetREXConverter | Sets the REX converter.
ContentMapper Properties
ContentMapper Properties | Description
DialogSettings | Gets the dialog's settings.

ContentMapper Methods

ContentMapper Methods
ContentMapper Class Legend
ContentMapper Methods
ContentMapper Methods | Description
AddLabel | Adds the label to the list.
ApplyMapControl | Applies the map control.
CloseMapControl | Closes the map control.
CreateMapControl | Creates the map control.
GetLabels | Gets the labels.
LaunchMapDialog | Launches the map dialog.
LoadUserMap | Loads the user map to the Content Generator.
RefreshMapControl | Refreshes the map control.
ReloadGlobalMap | Reloads the global map.
ResetUserMap | Resets the user map.
SaveGlobalMap | Saves the global map.
SaveUserMap | Saves the user map.
SetDefaults | Sets defaults in the mapping system.
SetREXConverter | Sets the REX converter.

ContentMapper Properties

ContentMapper Properties
ContentMapper Class Legend
ContentMapper Properties
ContentMapper Properties | Description
DialogSettings | Gets the dialog's settings.

Example

Example
ContentMapper.AddLabel Method

The example shows how to use labels in a mapping system.

//Revit converter
RVTFamilyConverter rvt = new RVTFamilyConverter(ThisExtension.Revit.CommandData(), true);
rvt.Settings.Labels = true;

//-example label without description
REXFamilyType_Label label1 = new REXFamilyType_Label(ECategoryType.SECTION_DB, "test1");

//-example label with section defined manually
REXFamilyType_Label label2 = new REXFamilyType_Label(ECategoryType.SECTION_DB, "test2");
REXFamilyType_ParamSection paramSection = new REXFamilyType_ParamSection();
paramSection.Material = EMaterial.CONCRETE;
paramSection.ElementType = REX.ContentGenerator.Families.EElementType.BEAM;
paramSection.Parameters.SectionType = ESectionType.RECT;
paramSection.Parameters.Dimensions.b = 1;
paramSection.Parameters.Dimensions.h = 1;
label2.Parameters.LabelFamilyDescription = paramSection;

//-definition of category
rvt.ContentMapper.DialogSettings.SectionSettings.LabelCategoryName = "MyCategory";

//-adding labels to list
rvt.ContentMapper.DialogSettings.SectionSettings.Labels.Add(label1);
rvt.ContentMapper.DialogSettings.SectionSettings.Labels.Add(label2);

//Map dialog.