DataMode | Determines the target of serialization.
DataType | Determines the data type.
OperationStatus | Determines the status after operation.

Legend

Legend
REXExtensionData Class
Legend
Constructor
Enumeration
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXExtensionData Class Members

REXExtensionData Class Members
REXExtensionData Class Legend
Members
Public Methods
Public Method | Description
REXExtensionData | Initializes a new instance of the REXExtensionData class.
REXExtensionData Enumerations
REXExtensionData Enumerations | Description
DataMode | Determines the target of serialization.
DataType | Determines the data type.
OperationStatus | Determines the status after operation.
REXExtensionData Methods
REXExtensionData Methods | Description
CompareData | Compares the data with another data.
CompareData | Compares the data with another data.
Load | Loads data strucuture from a BinaryReader object.
LoadHeader | Loads data strucuture from a BinaryReader object.
LoadHeader | Loads data strucuture from a BinaryReader object.
LoadHeader | This is LoadHeader, a member of class REXExtensionData.
Save | Saves data structure to a BinaryWriter object.
SaveHeader | Saves data structure to a BinaryWriter object.
SaveHeader | This is SaveHeader, a member of class REXExtensionData.
SetDefaults | Sets the defaults.
REXExtensionData Properties
REXExtensionData Properties | Description
DateTimeData | Get the date and time of data which load.
DateTimeDataCreation | Get the creation date and time of data which load.
EnableDynamicUpdate | This is EnableDynamicUpdate, a member of class REXExtensionData.
LoadedRegionalSettings | This is LoadedRegionalSettings, a member of class REXExtensionData.
Mode | Get or set the mode.
NoHeader | This is NoHeader, a member of class REXExtensionData.
ProductType | Loaded product type
RunContext | Loaded run context
StandardRunContext | Loaded standard run context
Status | Get or set the status.
Version | Get the current version.
VersionData | Get the version data which load.

REXExtensionData Methods

REXExtensionData Methods
REXExtensionData Class Legend
REXExtensionData Methods
REXExtensionData Methods | Description
CompareData | Compares the data with another data.
CompareData | Compares the data with another data.
Load | Loads data strucuture from a BinaryReader object.
LoadHeader | Loads data strucuture from a BinaryReader object.
LoadHeader | Loads data strucuture from a BinaryReader object.
LoadHeader | This is LoadHeader, a member of class REXExtensionData.
Save | Saves data structure to a BinaryWriter object.
SaveHeader | Saves data structure to a BinaryWriter object.
SaveHeader | This is SaveHeader, a member of class REXExtensionData.
SetDefaults | Sets the defaults.

REXExtensionData Properties

REXExtensionData Properties
REXExtensionData Class Legend
REXExtensionData Properties
REXExtensionData Properties | Description
DateTimeData | Get the date and time of data which load.
DateTimeDataCreation | Get the creation date and time of data which load.
EnableDynamicUpdate | This is EnableDynamicUpdate, a member of class REXExtensionData.
LoadedRegionalSettings | This is LoadedRegionalSettings, a member of class REXExtensionData.
Mode | Get or set the mode.
NoHeader | This is NoHeader, a member of class REXExtensionData.
ProductType | Loaded product type
RunContext | Loaded run context
StandardRunContext | Loaded standard run context
Status | Get or set the status.
Version | Get the current version.
VersionData | Get the version data which load.

REXExtensionData Class Public Methods

REXExtensionData Class Public Methods
REXExtensionData Class Legend
Public Methods
Public Method | Description
REXExtensionData | Initializes a new instance of the REXExtensionData class.

Legend

Legend
REXExtensionDataSerializable Class
Legend
Constructor
virtual

REXExtensionDataSerializable Class Members

REXExtensionDataSerializable Class Members
REXExtensionDataSerializable Class Legend
Members
Public Methods
Public Method | Description
REXExtensionDataSerializable | Initializes a new instance of the REXExtensionDataSerializable class.
REXExtensionDataSerializable Methods
REXExtensionDataSerializable Methods | Description
GetObjectData | A required method by ISerializable to serialize the object.

Members

Legend
Legend
Constructor
virtual

REXExtensionDataSerializable Methods

REXExtensionDataSerializable Methods
REXExtensionDataSerializable Class Legend
REXExtensionDataSerializable Methods
REXExtensionDataSerializable Methods | Description
GetObjectData | A required method by ISerializable to serialize the object.

REXExtensionDataSerializable Class Public Methods

REXExtensionDataSerializable Class Public Methods
REXExtensionDataSerializable Class Legend
Public Methods
Public Method | Description
REXExtensionDataSerializable | Initializes a new instance of the REXExtensionDataSerializable class.

Example

Example
REXExtensionDataSerializable.GetObjectData Method
public virtual void GetObjectData(System.Runtime.Serialization.SerializationInfo info, System.Runtime.Serialization.StreamingContext ctx)
{
    info.AddValue("s1", strPrivate);
    info.AddValue("s2", strPublic);
    into.AddValue("ob", obMyClass);       // Serializing an object
}

Legend

Legend
REXExtensionMainControl Class
Legend
Constructor
Property
virtual

REXExtensionMainControl Class Members

REXExtensionMainControl Class Members
REXExtensionMainControl Class Legend
Members
Public Methods
Public Method | Description
REXExtensionMainControl | Initializes a new instance of a REXExtensionMainControl class.
REXExtensionMainControl | Initializes a new instance of a REXExtensionMainControl class.
REXExtensionMainControl Properties
REXExtensionMainControl Properties | Description
Components | Get the component.

Members

Legend
Legend
Constructor
Property
virtual

REXExtensionMainControl Properties

REXExtensionMainControl Properties
REXExtensionMainControl Class Legend
REXExtensionMainControl Properties
REXExtensionMainControl Properties | Description
Components | Get the component.

REXExtensionMainControl Class Public Methods

REXExtensionMainControl Class Public Methods
REXExtensionMainControl Class Legend
Public Methods
Public Method | Description
REXExtensionMainControl | Initializes a new instance of a REXExtensionMainControl class.
REXExtensionMainControl | Initializes a new instance of a REXExtensionMainControl class.

Legend

Legend
REXExtensionObject Class
Legend
Constructor
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXExtensionObject Class Members

REXExtensionObject Class Members
REXExtensionObject Class Legend
Members
Public Methods
Public Method | Description
REXExtensionObject | Initializes a new instance of a REXExtensionObject class.
REXExtensionObject Properties
REXExtensionObject Properties | Description
ThisApplication | Get the application.
ThisContext | Get the context.
ThisExtension | Get the extension.
ThisProduct | Gets the this product.
ThisRunContext | Gets the this run context.

Members

Legend
Legend
Constructor
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXExtensionObject Properties

REXExtensionObject Properties
REXExtensionObject Class Legend
REXExtensionObject Properties
REXExtensionObject Properties | Description
ThisApplication | Get the application.
ThisContext | Get the context.
ThisExtension | Get the extension.
ThisProduct | Gets the this product.