REXEditBox.SetText Method

REXEditBox.SetText Method
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Sets the text contents of the control.

C#
public void SetText(string txt);
Parameters
Parameters | Description
txt | The text.
Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class

REXEditBox.SetUserTextValidation Method

REXEditBox.SetUserTextValidation Method
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Sets the user validation method for the text control.

C#
public void SetUserTextValidation(UserTextValidation ValidFunction);
Parameters
Parameters | Description
ValidFunction | The validation method.
Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class

REXEditBox.SetUserValidation Method

REXEditBox.SetUserValidation Method
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Sets the user validation method.

C#
public void SetUserValidation(UserValidation ValidFunction);
Parameters
Parameters | Description
ValidFunction | The validation method.
Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class

REXEditBox.SetUserValidationComplex Method

REXEditBox.SetUserValidationComplex Method
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Sets the user validation method for complex values (list).

C#
public void SetUserValidationComplex(UserValidationComplex ValidFunction);
Parameters
Parameters | Description
ValidFunction | The validation method.
Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class

REXEditBox.SetValue Method (Double)

REXEditBox.SetValue Method (Double)
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Sets the value of the double type.

C#
public void SetValue(Double value);
Parameters
Parameters | Description
value | The value.
Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class

REXEditBox.SetValue Method (String)

REXEditBox.SetValue Method (String)
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Sets the value of the string type.

C#
public void SetValue(String value);
Parameters
Parameters | Description
value | The value.
Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class

REXEditBox.ValidateComplexValue Method (List<double>)

REXEditBox.ValidateComplexValue Method (List<double>)
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Validates the complex (list) value of the double type.

C#
public bool ValidateComplexValue(List<double> values);
Parameters
Parameters | Description
values | The values to validate.
Returns

True if validated; otherwise false.

Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class

REXEditBox.ValidateComplexValue Method (List<string>)

REXEditBox.ValidateComplexValue Method (List<string>)
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Validates the complex (list) value of the string type.

C#
public bool ValidateComplexValue(List<string> values);
Parameters
Parameters | Description
values | The values to validate.
Returns

True if validated; otherwise false.

Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class

REXEditBox.ValidateComplexValue Method (String)

REXEditBox.ValidateComplexValue Method (String)
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Validates the complex (list) value of the string type.

C#
public bool ValidateComplexValue(String value);
Parameters
Parameters | Description
value | The value to validate.
Returns

True if validated; otherwise false.

Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class

REXEditBox.ValidateValue Method (Double)

REXEditBox.ValidateValue Method (Double)
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Validates the input value of the double type.

C#
public bool ValidateValue(Double value);
Parameters
Parameters | Description
value | The value to validate.
Returns

True if validated; otherwise false.

Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class

REXEditBox.ValidateValue Method (String)

REXEditBox.ValidateValue Method (String)
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Validates the value of the string type.

C#
public bool ValidateValue(String value);
Parameters
Parameters | Description
value | The value to validate.
Returns

True if validated; otherwise false.

Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class

REXEditBox.ValueFormat Method (Double)

REXEditBox.ValueFormat Method (Double)
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Returns a text containing an expression formatted according the current settings of the element.

C#
public string ValueFormat(Double value);
Parameters
Parameters | Description
value | The value to format.
Returns

The formatted text.

Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class

REXEditBox.ValueFormat Method (String)

REXEditBox.ValueFormat Method (String)
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Returns a text containing an expression formatted according the current settings of the element.

C#
public string ValueFormat(String value);
Parameters
Parameters | Description
value | The value to format.
Returns

The formatted text.

Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class

REXEditBox.ValueParse Method

REXEditBox.ValueParse Method
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Converts the specified text to the numeric value according the current settings of the element.

C#
public double ValueParse(String value);
Parameters
Parameters | Description
value | The text.
Returns

The converted value.

Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class

REXEditBox.BackgroundDisabledHidden Property

REXEditBox.BackgroundDisabledHidden Property
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Gets or sets the background for the disabled state of the control in the hidden background mode.

C#
[Browsable(true)]
[Category("Appearance")]
public Brush BackgroundDisabledHidden;
Description

The background.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class

REXEditBox.BackgroundDisabledStandard Property

REXEditBox.BackgroundDisabledStandard Property
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Gets or sets the background for the standard disabled status.

C#
[Browsable(true)]
[Category("Appearance")]
[DefaultValue(typeof(Color), "LightBlue")]
public Brush BackgroundDisabledStandard;
Description

The background standard.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class

REXEditBox.BackgroundError Property

REXEditBox.BackgroundError Property
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Gets or sets the background for the Error state of the control.

C#
[Browsable(true)]
[Category("Appearance")]
[DefaultValue(typeof(Color), "LightCoral")]
public Brush BackgroundError;
Description

The Error background.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class

REXEditBox.BackgroundNeutral Property

REXEditBox.BackgroundNeutral Property
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Gets or sets the background for the neutral state of the control.

C#
[Browsable(true)]
[Category("Appearance")]
[DefaultValue(typeof(SystemColors), "Window")]