REXComboEditControlEngine Class, REX.Controls.Common Namespace, REXComboEditControlEngine Class

REXComboEditControlEngine.TextChanged Method

REXComboEditControlEngine.TextChanged Method
REXComboEditControlEngine Class REX.Controls.Common Namespace REXComboEditControlEngine Class

Informs about changes in the control's text.

C#
public override void TextChanged(string txt);
Parameters
Parameters | Description
txt | The new text.
Description
Class

REXComboEditControlEngine Class

Links
REXComboEditControlEngine Class, REX.Controls.Common Namespace, REXComboEditControlEngine Class

REXComboEditControlEngine.ValidateControl Method (List<double>)

REXComboEditControlEngine.ValidateControl Method (List<double>)
REXComboEditControlEngine Class REX.Controls.Common Namespace REXComboEditControlEngine Class

Validates the current control based on the input values.

C#
public override bool ValidateControl(List<double> values);
Parameters
Parameters | Description
values | The list of values.
Returns

True if validated; otherwise false.

Description
Class

REXComboEditControlEngine Class

Links
REXComboEditControlEngine Class, REX.Controls.Common Namespace, REXComboEditControlEngine Class

REXComboEditControlEngine.ValidateControl Method (bool)

REXComboEditControlEngine.ValidateControl Method (bool)
REXComboEditControlEngine Class REX.Controls.Common Namespace REXComboEditControlEngine Class

Validates the current control based on the current text or the stored value.

C#
public override void ValidateControl(bool currentText);
Parameters
Parameters | Description
currentText | Declares whether the current text should be validated (true to validate the current text; false to validate the stored value).
Description
Class

REXComboEditControlEngine Class

Links
REXComboEditControlEngine Class, REX.Controls.Common Namespace, REXComboEditControlEngine Class

REXComboEditControlEngine.ValidateControl Method (double)

REXComboEditControlEngine.ValidateControl Method (double)
REXComboEditControlEngine Class REX.Controls.Common Namespace REXComboEditControlEngine Class

Validates the current control based on the input value.

C#
public override bool ValidateControl(double val);
Parameters
Parameters | Description
val | The value.
Returns

True if validated; otherwise false.

Description
Class

REXComboEditControlEngine Class

Links
REXComboEditControlEngine Class, REX.Controls.Common Namespace, REXComboEditControlEngine Class

REXComboEditControlEngine.ValidateControl Method (string)

REXComboEditControlEngine.ValidateControl Method (string)
REXComboEditControlEngine Class REX.Controls.Common Namespace REXComboEditControlEngine Class

Validates the current control based on the input text.

C#
public override bool ValidateControl(string text);
Parameters
Parameters | Description
text | The text.
Returns

True if validated; otherwise false.

Description
Class

REXComboEditControlEngine Class

Links
REXComboEditControlEngine Class, REX.Controls.Common Namespace, REXComboEditControlEngine Class

REXComboEditControlEngine.Items Property

REXComboEditControlEngine.Items Property
REXComboEditControlEngine Class REX.Controls.Common Namespace REXComboEditControlEngine Class

Gets or sets the collection of the items contained in the control.

C#
public List<string> Items;
Description

The items collection.

Class

REXComboEditControlEngine Class

Links
REXComboEditControlEngine Class, REX.Controls.Common Namespace, REXComboEditControlEngine Class

REXComboEditControlEngine.ListValidation Property

REXComboEditControlEngine.ListValidation Property
REXComboEditControlEngine Class REX.Controls.Common Namespace REXComboEditControlEngine Class

Gets or sets a value indicating whether the list should be validated.

C#
public bool ListValidation;
Description

True if validate; otherwise false.

Class

REXComboEditControlEngine Class

Links
REXComboEditControlEngine Class, REX.Controls.Common Namespace, REXComboEditControlEngine Class

REXComboEditControlEngine.SelectedIndex Property

REXComboEditControlEngine.SelectedIndex Property
REXComboEditControlEngine Class REX.Controls.Common Namespace REXComboEditControlEngine Class

Gets or sets the index specifying the currently selected item.

C#
public int SelectedIndex;
Description

The index of the selected item.

Class

REXComboEditControlEngine Class

Links
REXComboEditControlEngine Class, REX.Controls.Common Namespace, REXComboEditControlEngine Class

REXComboEditControlEngine.TextBoxMode Property

REXComboEditControlEngine.TextBoxMode Property
REXComboEditControlEngine Class REX.Controls.Common Namespace REXComboEditControlEngine Class

Gets or sets a value indicating whether the combobox should be in the editbox mode.

C#
public bool TextBoxMode;
Description

True if editbox mode; otherwise false.

Class

REXComboEditControlEngine Class

Links
REXComboEditControlEngine Class, REX.Controls.Common Namespace, REXComboEditControlEngine Class

REXEditControlEngine Class

REXEditControlEngine Class
REX.Controls.Common Namespace Legend Members Public Methods REXEditControlEngine Events REXEditControlEngine Methods REXEditControlEngine Properties

Represents the engine for edit controls.

Class Hierarchy
C#
public class REXEditControlEngine<T_Background> : IUnitObject3;
Type Parameters
Type Parameters | Description
T_Background | The type of the background.
Description
Namespace

REX.Controls.Common Namespace

Public Methods
Public Method | Description
REXEditControlEngine | Initializes a new instance of the REXEditControlEngine class.
REXEditControlEngine Events
REXEditControlEngine Events | Description
EventComplexDoubleValueChanged | Occurs when the complex value changes.
EventDoubleValueChanged | Occurs when the value changes.
REXEditControlEngine Methods
REXEditControlEngine Methods | Description
AddEnabledChangedHandler | Adds the handler to the event raised when the element changes it's enable state.
AddLostFocusHandler | Adds the handler to the event raised when the element loses logical focus.
AddTextChangedHandler | Adds the handler to the event raised when text changes.
EndEdit | Ends the edit mode.
GetBaseMaxValue | Gets the maximum value and converts it to base units.
GetBaseMinValue | Gets the minimum value and converts it to base units.
GetComplexDataBaseValue | Get the values and convert it to base units.
GetComplexDataInterfaceValue | Get the values and convert it to interface units.
GetComplexDoubleValue | Gets the complex (list) value of the double type.
GetComplexStringValue | Returns a complex string list.
GetControl | Gets the control.
GetDataBaseValue | Gets the value and converts it to base units.
GetDataInterfaceValue | Gets the value and converts it to interface units.
GetFullName | Gets the full name.
GetInterfaceMaxValue | Gets the maximum value and converts it to interface units.
GetInterfaceMinValue | Gets the minimum value and converts it to interface units.
GetLastCorrectValueStr | Gets the last correct stored value.
GetState | Gets the current state of the control.
GetStringValue | Returns the original text.
GetUniqueName | Returns the Unique ID generated for the current instance of the engine.
GetUnitName | Gets the name of the unit from EnumUnits type.
GetValue | Gets the value of the double type.
IsInEditMode | Determines whether control is in the edit mode.
Refresh | Refreshes the text on the control based on the current text.
RefreshValidationStatus | Refreshes the validation status.
Reset | Resets control (internal values).
Restore | Refreshes the text on the control based on the stored value.
RestoreOriginalText | Refreshes the text on the control based on the original text.
SetBaseMaxValue | Set the maximum value defined in base units.
SetBaseMinValue | Set the minimum value defined in base units.
SetComplexDataBaseValue | Set the list of values defined in base units.
SetComplexDataInterfaceValue | Set the list of values defined in interface units.