public virtual void OnDataSaved(bool Result);
Parameters
Parameters | Description
Result | If set to true operation succeeded; Otherwise some errors found.
Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.OnErrorSelected Method

REXExtension.OnErrorSelected Method
REXExtension Class REX.Common Namespace REXExtension Class

Called when error selected on errors list dialog.

C#
public virtual void OnErrorSelected(REXErrorsEventArgs e);
Parameters
Parameters | Description
e | A Autodesk.REX.Framework.REXErrorsEventArgs instance containing the event data.
Description

Raises the ErrorSelected event.

Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.OnEvent Method

REXExtension.OnEvent Method
REXExtension Class REX.Common Namespace REXExtension Class

Called when event.

C#
public virtual object OnEvent(ref REXEvent EventStruct);
Parameters
Parameters | Description
EventStruct | The event struct.
Returns

Returns result of eventoperation.

Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.OnGetExtensionName Method

REXExtension.OnGetExtensionName Method
REXExtension Class REX.Common Namespace REXExtension Class

Called when get extension name.

C#
public virtual string OnGetExtensionName(REXExtensionNameContext nameContext);
Parameters
Parameters | Description
nameContext | The name context.
Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.OnGetText Method

REXExtension.OnGetText Method
REXExtension Class REX.Common Namespace REXExtension Class

Get specified text from resources.

C#
public virtual string OnGetText(string Name);
Parameters
Parameters | Description
Name | The name of string.
Returns

Returns specified text.

Description

Needed for obfuscated strings tables.

Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.OnInitialize Method

REXExtension.OnInitialize Method
REXExtension Class REX.Common Namespace REXExtension Class

Called when Initialize.

C#
public virtual bool OnInitialize();
Returns

Returns true if succeeded.

Description

Creates dedicated extension class according main context.

Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.OnLoadJournalingData Method

REXExtension.OnLoadJournalingData Method
REXExtension Class REX.Common Namespace REXExtension Class

Called when load journaling data.

C#
public virtual void OnLoadJournalingData();
Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.OnLoadTemplate Method

REXExtension.OnLoadTemplate Method
REXExtension Class REX.Common Namespace REXExtension Class

Called when load template.

C#
public virtual bool OnLoadTemplate();
Parameters
Parameters | Description
Result | If set to true operation succeeded; Otherwise some errors found.
Description

Only if ExtensionContext.Control.StandardRunContext is equals to REXExtensionContext.REXStandardRunContext.OperationEditTemplate.

Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.OnPreferencesChanged Method

REXExtension.OnPreferencesChanged Method
REXExtension Class REX.Common Namespace REXExtension Class

Called when preferences changed.

C#
public virtual void OnPreferencesChanged();
Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.OnRegionalSettingsChanged Method

REXExtension.OnRegionalSettingsChanged Method
REXExtension Class REX.Common Namespace REXExtension Class

Called when regional settings changed.

C#
public virtual void OnRegionalSettingsChanged();
Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.OnRun Method

REXExtension.OnRun Method
REXExtension Class REX.Common Namespace REXExtension Class

Runs process calculations or other operations.

C#
public virtual void OnRun();
Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.OnSaveJournalingData Method

REXExtension.OnSaveJournalingData Method
REXExtension Class REX.Common Namespace REXExtension Class

Called when save journaling data.

C#
public virtual void OnSaveJournalingData();
Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.OnSaveTemplate Method

REXExtension.OnSaveTemplate Method
REXExtension Class REX.Common Namespace REXExtension Class

Called when save template.

C#
public virtual bool OnSaveTemplate();
Parameters
Parameters | Description
Result | If set to true operation succeeded; Otherwise some errors found.
Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.OnSetContext Method

REXExtension.OnSetContext Method
REXExtension Class REX.Common Namespace REXExtension Class

Called when regional settings changed.

C#
public virtual void OnSetContext(REXContext context);
Parameters
Parameters | Description
context |
Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.OnSetData Method

REXExtension.OnSetData Method
REXExtension Class REX.Common Namespace REXExtension Class

Get data from dialogs and sets Data's strucutres.

C#
public virtual void OnSetData();
Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.OnSetDialogs Method

REXExtension.OnSetDialogs Method
REXExtension Class REX.Common Namespace REXExtension Class

Set data in dialogs.

C#
public virtual void OnSetDialogs();
Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.OnShowResults Method

REXExtension.OnShowResults Method
REXExtension Class REX.Common Namespace REXExtension Class

Shows results.

C#
public virtual void OnShowResults();
Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.OnUpdate Method

REXExtension.OnUpdate Method
REXExtension Class REX.Common Namespace REXExtension Class

Called when update.

C#
public virtual bool OnUpdate(out bool Implemented);
Parameters
Parameters | Description
Implemented | If returns true, the method is implemented.
Returns

Returns result of clear operation.

Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.OnUpdateDialogs Method

REXExtension.OnUpdateDialogs Method
REXExtension Class REX.Common Namespace REXExtension Class

Called when update dialogs.

C#
public virtual void OnUpdateDialogs();
Description

Currently is not used.

Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.ROHTMLDocument Method

REXExtension.ROHTMLDocument Method
REXExtension Class REX.Common Namespace REXExtension Class

Access to ROHTML's document.

C#
public ROHTMLLib.IXHTMLDocument ROHTMLDocument();
Returns

Returns ROHTMLLib.IXHTMLDocument interface.

Description

Creates, initializes and returns ROHTML's document.

Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.ROHTMLReleaseDocument Method

REXExtension.ROHTMLReleaseDocument Method
REXExtension Class REX.Common Namespace REXExtension Class

Releases ROHTML's document.

C#
public void ROHTMLReleaseDocument();
Parameters
Parameters | Description
ROHTMLDocument | The ROHTML document.
Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.Run Method