REXComboBox.SetComplexValue Method (List<string>)

REXComboBox.SetComplexValue Method (List<string>)
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Sets the complex (list) value of the string type.

C#
public void SetComplexValue(List<string> values);
Parameters
Parameters | Description
values | The list of values.
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.SetComplexValue Method (String)

REXComboBox.SetComplexValue Method (String)
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Sets the complex (list) value of the string type.

C#
public bool SetComplexValue(String value);
Parameters
Parameters | Description
value | The value.
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.SetExternalUnitBody Method

REXComboBox.SetExternalUnitBody Method
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Sets external IUnitBody object for custom unit processing.

C#
public void SetExternalUnitBody(IUnitBody unitBody);
Parameters
Parameters | Description
unitBody | External IUnitBody.
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.SetPropertiesType Method

REXComboBox.SetPropertiesType Method
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Sets the mode of the combo.

C#
public void SetPropertiesType(EComboPropertiesType propertiesType);
Parameters
Parameters | Description
propertiesType | The mode of the combo.
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.SetSelectedIndex Method

REXComboBox.SetSelectedIndex Method
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Sets the index specifying the currently selected item.

C#
public void SetSelectedIndex(int index);
Parameters
Parameters | Description
index | The index of the selected item.
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.SetUserTextValidation Method

REXComboBox.SetUserTextValidation Method
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Sets the user validation method for the text control.

C#
public void SetUserTextValidation(UserTextValidation ValidFunction);
Parameters
Parameters | Description
ValidFunction | The validation method.
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.SetUserValidation Method

REXComboBox.SetUserValidation Method
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Sets the user validation method.

C#
public void SetUserValidation(UserValidation ValidFunction);
Parameters
Parameters | Description
ValidFunction | The validation method.
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.SetUserValidationComplex Method

REXComboBox.SetUserValidationComplex Method
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Sets the user validation method for complex values (list).

C#
public void SetUserValidationComplex(UserValidationComplex ValidFunction);
Parameters
Parameters | Description
ValidFunction | The validation method.
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.SetValue Method (Double)

REXComboBox.SetValue Method (Double)
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Sets the value of the double type.

C#
public void SetValue(Double value);
Parameters
Parameters | Description
value | The value.
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.SetValue Method (String)

REXComboBox.SetValue Method (String)
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Sets the value of the string type.

C#
public void SetValue(String value);
Parameters
Parameters | Description
value | The value.
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.ValidateComplexValue Method (List<double>)

REXComboBox.ValidateComplexValue Method (List<double>)
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Validates the complex (list) value of the double type.

C#
public bool ValidateComplexValue(List<double> values);
Parameters
Parameters | Description
values | The values to validate.
Returns

True if validated; otherwise false.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.ValidateComplexValue Method (List<string>)

REXComboBox.ValidateComplexValue Method (List<string>)
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Validates the complex (list) value of the string type.

C#
public bool ValidateComplexValue(List<string> values);
Parameters
Parameters | Description
values | The values to validate.
Returns

True if validated; otherwise false.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.ValidateComplexValue Method (String)

REXComboBox.ValidateComplexValue Method (String)
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Validates the complex (list) value of the string type.

C#
public bool ValidateComplexValue(String value);
Parameters
Parameters | Description
value | The value to validate.
Returns

True if validated; otherwise false.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.ValidateValue Method (Double)

REXComboBox.ValidateValue Method (Double)
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Validates the input value of the double type.

C#
public bool ValidateValue(Double value);
Parameters
Parameters | Description
value | The value to validate.
Returns

True if validated; otherwise false.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.ValidateValue Method (String)

REXComboBox.ValidateValue Method (String)
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Validates the value of the string type.

C#
public bool ValidateValue(String value);
Parameters
Parameters | Description
value | The value to validate.
Returns

True if validated; otherwise false.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.ValueFormat Method (Double)

REXComboBox.ValueFormat Method (Double)
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Returns a text containing an expression formatted according the current settings of the element.

C#
public string ValueFormat(Double value);
Parameters
Parameters | Description
value | The value to format.
Returns

The formatted text.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.ValueFormat Method (String)

REXComboBox.ValueFormat Method (String)
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Returns a text containing an expression formatted according the current settings of the element.

C#
public string ValueFormat(String value);
Parameters
Parameters | Description
value | The value to format.
Returns

The formatted text.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.ValueParse Method

REXComboBox.ValueParse Method
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Converts the specified text to the numeric value according the current settings of the element.

C#