Restore | Refreshes the text on the control based on the stored value.
RestoreOriginalText | Refreshes the text on the control based on the original text.
SetBaseMaxValue | Set the maximum value defined in base units.
SetBaseMinValue | Set the minimum value defined in base units.
SetComplexDataBaseValue | Set the list of values defined in base units.
SetComplexDataInterfaceValue | Set the list of values defined in interface units.
SetComplexValue | Sets the complex (list) value of the double type.
SetComplexValue | Sets the complex (list) value of the string type.
SetComplexValue | Sets the complex (list) value of the string type.
SetControl | Sets the control for which the current instance is the engine.
SetDataBaseValue | Set the value in base units.
SetDataInterfaceValue | Set the value in interface units.
SetExternalUnitBody | Set external IUnitBody object.
SetInterfaceMaxValue | Set the maximum value defined in interface units.
SetInterfaceMinValue | Set the minimum value defined in interface units.
SetUserTextValidation | Sets the user validation method for the text control.
SetUserValidation | Sets the user validation method.
SetUserValidationComplex | Sets the user validation method for complex values (list).
SetValue | Sets the value of the double type.
SetValue | Sets the value of the string type.
StartEdit | Starts the edit mode.
TextChanged | Informs about changes in the control's text.
ValidateComplexValue | Validates the complex (list) value of the double type.
ValidateComplexValue | Validates the complex (list) value of the string type.
ValidateComplexValue | Validates the complex (list) value of the string type.
ValidateControl | Validates the current control based on the input values.
ValidateControl | Validates the current control based on the input text.
ValidateControl | Validates the current control based on the current text or the stored value.
ValidateControl | Validates the current control based on the input value.
ValidateValue | Validates the input value of the double type.
ValidateValue | Validates the value of the string type.
ValueFormat | Returns a text containing an expression formatted according the current settings of the element.
ValueFormat | Returns a text containing an expression formatted according the current settings of the element.
ValueParse | Converts the specified text to the numeric value according the current settings of the element.
REXEditControlEngine Properties
REXEditControlEngine Properties | Description
Background | Gets or sets the background of the control.
BackgroundDisabledHidden | Gets or sets the background for the disabled state of the control in the hidden background mode.
BackgroundDisabledStandard | Gets or sets the background for the disabled state of the control.
BackgroundError | Gets or sets the background for the Error state of the control.
BackgroundNeutral | Gets or sets the background for the neutral state of the control.
BackgroundOK | Gets or sets the background for the OK state of the control.
Complex | Gets or sets a value indicating whether this REXEditControlEngine supports complex (list) values.
ComplexSeparator | Gets or sets the complex (list) separator.
ComplexSpaceSeparator | Gets or sets a value indicating whether a space should be respected as a list separator.
ComplexUnitOnEnd | Gets or sets a value indicating whether a unit symbol should be placed on the end of the formatted text.
ControlState | Gets the current state of the control.
CorrectValue | Gets or sets the correct value.
DataType | Gets or sets the type of the data in the control.
EngineeringFormat | Gets or sets a value indicating whether the text of the control should be formatted in according to the engineering (expotential) format.
Epsilon | Gets or sets the accuracy.
InvalidCharacters | Gets or sets the list invalid characters (for the control in TEXT mode).
IsEnabled | Gets or sets a value indicating whether this instance is enabled.
MaxTokens | Gets or sets the maximum number of elements in the complex mode (list).
MinTokens | Gets or sets the minimum number of elements in the complex mode (list).
OnDisableAction | Gets or sets a value indicating whether the foreground should be hidden when the control is disabled.
OriginalTextOnEnter | Gets or sets a value indicating whether an original text should be set when the user enters the control.
Power | Gets or sets the power of the unit.
RangeMax | Gets or sets the highest possible value.
RangeMaxCheck | Gets or sets a value indicating whether the value should be validated due to the RangeMax.
RangeMin | Gets or sets the minimum possible value.
RangeMinCheck | Gets or sets a value indicating whether the value should be validated due to the RangeMin.
RememberCorrect | Gets or sets a value indicating whether the correct value should be restored in case of the validation failure.
RoundingFractional | Gets or sets the rounding for fractional units.
RoundingIncrement | Gets or sets the rounding increment (for the DECIMAL DataType).
Separator | Gets or sets the decimal separator.
Tag | Gets or sets the tag.
Text | Gets the text contents of the control.
TokensRangeMaxCheck | Gets or sets a value indicating whether the number of elements should be validated due to the MaxTokens.
TokensRangeMinCheck | Gets or sets a value indicating whether the number of elements should be validated due to the MinTokens.
UnitEngine | Gets or sets the unit engine.
UnitSymbol | Gets or sets the unit symbol.
UnitType | Gets or sets the type of the unit.
REXEditControlEngine Events
REXEditControlEngine Events | Description
EventComplexDoubleValueChanged | Occurs when the complex value changes.
EventDoubleValueChanged | Occurs when the value changes.

Members

Legend
Legend
Constructor
virtual
static
Property
Event
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXEditControlEngine Methods

REXEditControlEngine Methods
REXEditControlEngine Class Legend
REXEditControlEngine Methods
REXEditControlEngine Methods | Description
AddEnabledChangedHandler | Adds the handler to the event raised when the element changes it's enable state.
AddLostFocusHandler | Adds the handler to the event raised when the element loses logical focus.
AddTextChangedHandler | Adds the handler to the event raised when text changes.
EndEdit | Ends the edit mode.
GetBaseMaxValue | Gets the maximum value and converts it to base units.
GetBaseMinValue | Gets the minimum value and converts it to base units.
GetComplexDataBaseValue | Get the values and convert it to base units.
GetComplexDataInterfaceValue | Get the values and convert it to interface units.
GetComplexDoubleValue | Gets the complex (list) value of the double type.
GetComplexStringValue | Returns a complex string list.
GetControl | Gets the control.
GetDataBaseValue | Gets the value and converts it to base units.
GetDataInterfaceValue | Gets the value and converts it to interface units.
GetFullName | Gets the full name.
GetInterfaceMaxValue | Gets the maximum value and converts it to interface units.
GetInterfaceMinValue | Gets the minimum value and converts it to interface units.
GetLastCorrectValueStr | Gets the last correct stored value.
GetState | Gets the current state of the control.
GetStringValue | Returns the original text.
GetUniqueName | Returns the Unique ID generated for the current instance of the engine.
GetUnitName | Gets the name of the unit from EnumUnits type.
GetValue | Gets the value of the double type.
IsInEditMode | Determines whether control is in the edit mode.
Refresh | Refreshes the text on the control based on the current text.
RefreshValidationStatus | Refreshes the validation status.
Reset | Resets control (internal values).
Restore | Refreshes the text on the control based on the stored value.