True if the control is in editbox mode; otherwise, false.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.TokensRangeMaxCheck Property

REXComboBox.TokensRangeMaxCheck Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets or sets a value indicating whether the number of elements should be validated due to the MaxTokens.

C#
[Category("Complex")]
[Browsable(true)]
[DefaultValue(false)]
public Boolean TokensRangeMaxCheck;
Description

True if validate; otherwise, false.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.TokensRangeMinCheck Property

REXComboBox.TokensRangeMinCheck Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets or sets a value indicating whether the number of elements should be validated due to the MinTokens.

C#
[Category("Complex")]
[Browsable(true)]
[DefaultValue(false)]
public Boolean TokensRangeMinCheck;
Description

True if validate; otherwise, false.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.UnitSymbol Property

REXComboBox.UnitSymbol Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets or sets the unit symbol.

C#
[Browsable(true)]
[Category("Data")]
[DefaultValue("")]
public String UnitSymbol;
Description

The unit symbol.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXEditBox Class

REXEditBox Class
REX.Controls.Forms Namespace Legend Members Public Methods REXEditBox Methods REXEditBox Properties

Represents the REXEditBox control.

Class Hierarchy
C#
[ToolboxItem(true)]
[ToolboxBitmapAttribute(typeof(REXEditBox),"REXEditBox.Icon.bmp")]
public class REXEditBox : TextBox, IUnitObject3, REX.Controls.Common.IEditControl;
Description
Namespace

REX.Controls.Forms Namespace

Public Methods
Public Method | Description
REXEditBox | Initializes a new instance of the REXEditBox class.
REXEditBox Methods
REXEditBox Methods | Description
AddEnabledChangedHandler | Adds the handler to the event raised when the element changes it's enable state.
AddLostFocusHandler | Adds the handler to the event raised when the element loses logical focus.
AddTextChangedHandler | Adds the handler to the event raised when text changes.
GetBackground | Gets the background of the control.
GetComplexDoubleValue | Gets the complex (list) value of the double type.
GetComplexStringValue | Returns a complex string list.
GetEnable | Indicates whether the control is enabled.
GetFullName | Gets the full name.
GetLastCorrectValueStr | Gets the last correct stored value.
GetState | Gets the current state of the control.
GetStringValue | Returns the original text.
GetText | Gets the text contents of the control.
GetUniqueName | Returns the Unique ID generated for the current instance of the engine.
GetValue | Gets the value of the double type.
Refresh | Refreshes the text on the control based on the current text.
RefreshValidationStatus | Refreshes the validation status.
Reset | Resets control (internal values).
SetBackground | Sets the background of the control.
SetComplexValue | Sets the complex (list) value of the double type.
SetComplexValue | Sets the complex (list) value of the string type.
SetComplexValue | Sets the complex (list) value of the string type.
SetEnable | Sets the enable state.
SetExternalUnitBody | Sets external IUnitBody object for custom unit processing.
SetText | Sets the text contents of the control.
SetUserTextValidation | Sets the user validation method for the text control.
SetUserValidation | Sets the user validation method.
SetUserValidationComplex | Sets the user validation method for complex values (list).
SetValue | Sets the value of the double type.
SetValue | Sets the value of the string type.
ValidateComplexValue | Validates the complex (list) value of the double type.
ValidateComplexValue | Validates the complex (list) value of the string type.
ValidateComplexValue | Validates the complex (list) value of the string type.
ValidateValue | Validates the input value of the double type.
ValidateValue | Validates the value of the string type.
ValueFormat | Returns a text containing an expression formatted according the current settings of the element.
ValueFormat | Returns a text containing an expression formatted according the current settings of the element.
ValueParse | Converts the specified text to the numeric value according the current settings of the element.
REXEditBox Properties
REXEditBox Properties | Description
AcceptsTab | AcceptsTab property derived from the TextBox class.
ColorBackgroundDisabled | Gets or sets the background for the disabled state of the control in the hidden background mode.
ColorBackgroundError | Gets or sets the background for the Error state of the control.
ColorBackgroundNeutral | Gets or sets the background for the neutral state of the control.
ColorBackgroundOK | Gets or sets the background for the OK state of the control.
ColorBackgroundStandard | Gets or sets the background for the disabled state of the control.
Complex | Gets or sets a value indicating whether this REXEditControlEngine supports complex (list) values.
ComplexSeparator | Gets or sets the complex (list) separator.
ComplexSpaceSeparator | Gets or sets a value indicating whether a space should be respected as a list separator.
ComplexUnitOnEnd | Gets or sets a value indicating whether a unit symbol should be placed on the end of the formatted text.
ControlState | Gets the current state of the control.
CorrectValue | Gets or sets the correct value.
DataType | Gets or sets the type of the data in the control.
Enabled | Gets or sets a value indicating whether the control can respond to user interaction.
EngineeringFormat | Gets or sets a value indicating whether the text of the control should be formatted in according to the engineering (expotential) format.
Epsilon | Gets or sets the accuracy.
InvalidCharacters | Gets or sets the list invalid characters (for the control in TEXT mode).
MaxTokens | Gets or sets the maximum number of elements in the complex mode (list).
MinTokens | Gets or sets the minimum number of elements in the complex mode (list).
Multiline | Gets or sets a value indicating whether this is a multiline T:System.Windows.Forms.TextBox control.
OnDisableAction | Gets or sets a value indicating whether the foreground should be hidden when the control is disabled.
OriginalTextOnEnter | Gets or sets a value indicating whether an original text should be set when the user enters the control.
PasswordChar | Gets or sets the character used to mask characters of a password in a single-line T:System.Windows.Forms.TextBox control.
RangeMax | Gets or sets the highest possible value.
RangeMaxCheck | Gets or sets a value indicating whether the value should be validated due to the RangeMax.
RangeMin | Gets or sets the minimum possible value.
RangeMinCheck | Gets or sets a value indicating whether the value should be validated due to the RangeMin.
RememberCorrect | Gets or sets a value indicating whether the correct value should be restored in case of the validation failure.
RoundingFractional | Gets or sets the rounding for fractional units.
RoundingIncrement | Gets or sets the rounding increment (for the DECIMAL DataType).
Separator | Gets or sets the decimal separator.
Text | Gets the text contents of the control.
TokensRangeMaxCheck | Gets or sets a value indicating whether the number of elements should be validated due to the MaxTokens.
TokensRangeMinCheck | Gets or sets a value indicating whether the number of elements should be validated due to the MinTokens.
UnitSymbol | Gets or sets the unit symbol.
UseSystemPasswordChar | Gets or sets a value indicating whether the text in the T:System.Windows.Forms.TextBox control should appear as the default password character.