Gets the material of the specified name (based on data from the database).

C#
public REXFamilyType_Material GetFamilyMaterial(string name, string directory);
Parameters
Parameters | Description
name | The name of the material.
directory | The directory.
dbname | The name of the database.
Returns

Returns the material.

Description
Example

The example shows how to get the „C12/15” material from any database.

//Initializing the rex converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Database identification data.
string name = "C12/15";
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Mate";

//Getting the REXFamilyType from the database.
REXFamilyType_Material famMaterial = rex.GetFamilyMaterial(name, directory);
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, REXFamilyConverter Class

REXFamilyConverter.GetFamilyMaterial Method (string, string, string)

REXFamilyConverter.GetFamilyMaterial Method (string, string, string)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace Example REXFamilyConverter Class

Gets the material of the specific name (based on data from the database).

C#
public REXFamilyType_Material GetFamilyMaterial(string name, string dbName, string directory);
Parameters
Parameters | Description
name | The name of material.
dbName | The name of the database.
directory | The directory.
Returns

Returns the material.

Description
Example

The example shows how to get the „C12/15” material from the Eurocode database.

//Initializing the rex converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Database identification data.
string dbName = "Eurocode";
string name = "C12/15";
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Mate";

//Getting the REXFamilyType from the database.
REXFamilyType_Material famMaterial = rex.GetFamilyMaterial(name, dbName, directory);
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, REXFamilyConverter Class

REXFamilyConverter.GetFamilyRebarHook Method

REXFamilyConverter.GetFamilyRebarHook Method
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace REXFamilyConverter Class

Gets the family rebar hook.

C#
public REXFamilyType_RebarHook GetFamilyRebarHook(EHookAngles angle, bool stirrup, bool seismic);
Parameters
Parameters | Description
angle | The angle.
stirrup | If stirrup.
seismic | If seismic.
Returns

Returns the rebar hook.

Description
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, REXFamilyConverter Class

REXFamilyConverter.GetFamilyRebarShape Method

REXFamilyConverter.GetFamilyRebarShape Method
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace REXFamilyConverter Class

Gets the rebar shape of specified code and database.

C#
public REXFamilyType_RebarShape GetFamilyRebarShape(string code, bool stirrup, string dbName);
Parameters
Parameters | Description
code | The code.
stirrup | If stirrup.
dbName | The name of the database.
Returns

Returns the rebar shape.

Description
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, REXFamilyConverter Class

REXFamilyConverter.GetFamilyRebarType Method

REXFamilyConverter.GetFamilyRebarType Method
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace Example REXFamilyConverter Class

Gets the rebar's type of the specified steel and the bar's size (based on data from the database).

C#
public REXFamilyType_RebarBarType GetFamilyRebarType(string steel, string barsize, string dbName, string directory);
Parameters
Parameters | Description
steel | The name of the steel.
barsize | The size of the bar.
dbName | The name of the database.
directory | The directory where the database is located.
Returns

Returns the rebar's type.

Description
Example

The example shows how to get the bar of Grade 40 and #8 size from the database bar_ACI 318-08 database.

//Initializing the rex converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Database identification data.
string dbName = "bar_ACI 318-08";
string grade = "Grade 40";
string size = "#8";
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Reinf";

//Getting the REXFamilyType from the database.
REXFamilyType_RebarBarType famRebarType = rex.GetFamilyRebarType(grade, size, dbName, directory);
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, REXFamilyConverter Class

REXFamilyConverter.GetFamilyTemplate Method

REXFamilyConverter.GetFamilyTemplate Method
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace REXFamilyConverter Class

Gets the dedicated template of the REXFamilyType (with initial data).

C#
public REXFamilyType GetFamilyTemplate(REX.ContentGenerator.Families.EElementType el, EMaterial mat, ECategoryType type);
Parameters
Parameters | Description
el | The element's type.
mat | The material.
type | The category of the element.
Returns

Returns the REXFamilyType object.

Description
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, REXFamilyConverter Class

REXFamilyConverter.GetFilteredFamilies Method (string, REXContentFilter, ECategoryType)

REXFamilyConverter.GetFilteredFamilies Method (string, REXContentFilter, ECategoryType)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace Example REXFamilyConverter Class

Gets the list of filtered elements in the selected database.

C#
public List<REXFamilyType> GetFilteredFamilies(string path, REXContentFilter filter, ECategoryType type);
Parameters
Parameters | Description
path | The path.
filter | The filter.
type | The category of the element.
Returns

Returns the list of REXFamilyTypes.

Description
Example

The example shows how to get filtered sections from the Rcatptro database (of HEB NAME and height more than 0.4).

//Initializing the rex converter.
REXFamilyConverter rex = new REXFamilyConverter();

REXContentParamFilter filterNAME = new REXContentParamFilter("NAME", "HEB", false, false, true);
REXContentParamFilter filterH = new REXContentParamFilter("H", 0.4, true, false, false);
REXContentLogicFilter filterLogic = new REXContentLogicFilter(REXContentLogicFilter.ELogicOperator.And, filterNAME, filterH);

//Database identification data.
string path = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Prof\Rcatpro.xml";

//Getting the REXFamilyType from the database.
List<REXFamilyType> families = rex.GetFamilies(path,filterLogic, ECategoryType.SECTION_DB);
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, REXFamilyConverter Class

REXFamilyConverter.GetFilteredFamilies Method (string, REXContentFilter, string)

REXFamilyConverter.GetFilteredFamilies Method (string, REXContentFilter, string)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace REXFamilyConverter Class

Gets the list of filtered elements in the selected database.

C#
public List<REXFamilyType> GetFilteredFamilies(string path, REXContentFilter filter, string customCategory);
Parameters
Parameters | Description
path | The path.
filter | The filter.
customCategory | The custom category.
Returns

Returns the list of REXFamilyTypes.

Description
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, REXFamilyConverter Class

REXFamilyConverter.GetFilteredFamilies Method (string, string, REXContentFilter, ECategoryType)

REXFamilyConverter.GetFilteredFamilies Method (string, string, REXContentFilter, ECategoryType)