REXExtensionPanel Class, REX.Common Namespace, REXExtensionPanel Class

REXExtensionPanel.SetControl Method

REXExtensionPanel.SetControl Method
REXExtensionPanel Class REX.Common Namespace REXExtensionPanel Class

Sets the control.

C#
public void SetControl(System.Windows.Controls.Control control, System.Windows.Controls.Control controlMain, bool OneInstance);
Parameters
Parameters | Description
control | The control.
OneInstance | if set to true controls one instance of user control.
Description
Class

REXExtensionPanel Class

Links
REXExtensionPanel Class, REX.Common Namespace, REXExtensionPanel Class

REXExtensionPanel.ThisApplication Property

REXExtensionPanel.ThisApplication Property
REXExtensionPanel Class REX.Common Namespace REXExtensionPanel Class

Get this application.

C#
[Browsable(false)]
public REXApplication ThisApplication;
Description

This application.

Class

REXExtensionPanel Class

Links
REXExtensionPanel Class, REX.Common Namespace, REXExtensionPanel Class

REXExtensionPanel.ThisContext Property

REXExtensionPanel.ThisContext Property
REXExtensionPanel Class REX.Common Namespace REXExtensionPanel Class

Get this context.

C#
[Browsable(false)]
public REXContext ThisContext;
Description

This context.

Class

REXExtensionPanel Class

Links
REXExtensionPanel Class, REX.Common Namespace, REXExtensionPanel Class

REXExtensionPanel.ThisExtension Property

REXExtensionPanel.ThisExtension Property
REXExtensionPanel Class REX.Common Namespace REXExtensionPanel Class

Get this extension.

C#
[Browsable(false)]
public REXExtension ThisExtension;
Description

This extension.

Class

REXExtensionPanel Class

Links
REXExtensionPanel Class, REX.Common Namespace, REXExtensionPanel Class

REXExtensionPanel.ThisProduct Property

REXExtensionPanel.ThisProduct Property
REXExtensionPanel Class REX.Common Namespace REXExtensionPanel Class

Gets the this product.

C#
public REXInterfaceType ThisProduct;
Description

The this product.

Class

REXExtensionPanel Class

Links
REXExtensionPanel Class, REX.Common Namespace, REXExtensionPanel Class

REXExtensionPanel.ThisRunContext Property

REXExtensionPanel.ThisRunContext Property
REXExtensionPanel Class REX.Common Namespace REXExtensionPanel Class

Gets the this run context.

C#
public REX.Common.REXExtensionContext.REXStandardRunContext ThisRunContext;
Description

The this run context.

Class

REXExtensionPanel Class

Links
REXExtensionPanel Class, REX.Common Namespace, REXExtensionPanel Class

REXExtensionProduct Class

REXExtensionProduct Class
REX.Common Namespace Legend Members Public Methods REXExtensionProduct Methods

Represents the Extension element used by the main Extension class to separate product dependent part of the code from general one.

Class Hierarchy
C#
public class REXExtensionProduct : REX.Common.REXExtensionObject, REX.Common.IREXExtension;
Description

It mainly concerns external API (e.g. RevitAPI).

Namespace

REX.Common Namespace

Public Methods
Public Method | Description
REXExtensionProduct | Initializes a new instance of the REXExtensionFactory class.
REXExtensionProduct Methods
REXExtensionProduct Methods | Description
OnActivateLayout | Activates or deactivates layout - module can modify layout before or after activation.
OnCanClose | If returns true dialog will close after OK button is clicked.
OnCanClose | If returns true dialog will close after OK button is clicked.
OnCanRun | Checks status of module and shows some information for user if module can't excecute action.
OnClear | Called when data are cleared.
OnClose | Called during closing module.
OnCommand | Commands the specified command struct.
OnCreate | Creates needed structures and verify needs.
OnCreateDialogs | Creates sub dialogs.
OnCreateLayout | Creates layout items and setups layout.
OnDataLoad | Called when data are loaded.
OnDataLoaded | Called when data loaded.
OnDataSave | Called when data are saved.
OnDataSaved | Called when data are saved.
OnErrorSelected | Called when an error is selected on errors list dialog.
OnEvent | Called when event.
OnGetText | Get specified text from resources.
OnInitialize | Called when Initialize.
OnLoadTemplate | Called when template is loaded.
OnPreferencesChanged | Called when preferences changed.
OnRun | Runs process calculations or other operations.
OnSaveTemplate | Called when template is saved.
OnSetData | Get data from dialogs and sets Data's strucutres.
OnSetDialogs | Set data on dialogs.
OnShowResults | Shows results.
OnUpdateDialogs | This is OnUpdateDialogs, a member of class REXExtensionProduct.
Links
REX.Common Namespace, Legend, Members, Public Methods, REXExtensionProduct Methods

REXExtensionProduct.REXExtensionProduct Constructor

REXExtensionProduct.REXExtensionProduct Constructor
REXExtensionProduct Class REX.Common Namespace REXExtensionProduct Class

Initializes a new instance of the REXExtensionFactory class.

C#
public REXExtensionProduct(REXExtension extension);
Parameters
Parameters | Description
extension | The extension.
Description
Class

REXExtensionProduct Class

Links
REXExtensionProduct Class, REX.Common Namespace, REXExtensionProduct Class

REXExtensionProduct.OnActivateLayout Method

REXExtensionProduct.OnActivateLayout Method
REXExtensionProduct Class REX.Common Namespace REXExtensionProduct Class

Activates or deactivates layout - module can modify layout before or after activation.

C#
public virtual void OnActivateLayout(REX.Common.REXLayoutItem LItem, bool Activate);
Parameters
Parameters | Description
LItem | The layout item.
Activate | If set to true activate.
Description
Class

REXExtensionProduct Class

Links
REXExtensionProduct Class, REX.Common Namespace, REXExtensionProduct Class

REXExtensionProduct.OnCanClose Method ()

REXExtensionProduct.OnCanClose Method ()
REXExtensionProduct Class REX.Common Namespace REXExtensionProduct Class

If returns true dialog will close after OK button is clicked.

C#
public virtual bool OnCanClose();
Returns

Returns true if module can be closed.

Description
Class

REXExtensionProduct Class

Links
REXExtensionProduct Class, REX.Common Namespace, REXExtensionProduct Class

REXExtensionProduct.OnCanClose Method (REX.Common.REXCanCloseType)

REXExtensionProduct.OnCanClose Method (REX.Common.REXCanCloseType)
REXExtensionProduct Class REX.Common Namespace REXExtensionProduct Class

If returns true dialog will close after OK button is clicked.

C#
public virtual bool OnCanClose(REX.Common.REXCanCloseType Type);
Parameters
Parameters | Description
Type | The closing type. See REXCanCloseType enum.
Returns

Returns true if module can be closed.

Description
Class

REXExtensionProduct Class

Links
REXExtensionProduct Class, REX.Common Namespace, REXExtensionProduct Class

REXExtensionProduct.OnCanRun Method

REXExtensionProduct.OnCanRun Method
REXExtensionProduct Class REX.Common Namespace REXExtensionProduct Class

Checks status of module and shows some information for user if module can't excecute action.

C#
public virtual bool OnCanRun();
Returns

Returns true if module can do some action in OnRun method; otherwise false.

Description
Class

REXExtensionProduct Class

Links
REXExtensionProduct Class, REX.Common Namespace, REXExtensionProduct Class

REXExtensionProduct.OnClear Method

REXExtensionProduct.OnClear Method
REXExtensionProduct Class REX.Common Namespace REXExtensionProduct Class

Called when data are cleared.

C#
public virtual bool OnClear(out bool Implemented);
Parameters
Parameters | Description
Implemented | If returns true method was implemented.
Returns

Returns result of clear operation.

Description
Class

REXExtensionProduct Class

Links
REXExtensionProduct Class, REX.Common Namespace, REXExtensionProduct Class

REXExtensionProduct.OnClose Method

REXExtensionProduct.OnClose Method
REXExtensionProduct Class REX.Common Namespace REXExtensionProduct Class

Called during closing module.

C#
public virtual void OnClose();
Description
Class