REXUnitComboBox Class REX.Controls.Forms Namespace REXUnitComboBox Class

Gets or sets the power of the unit.

C#
public double Power;
Description

The power.

Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.Forms Namespace, REXUnitComboBox Class

REXUnitComboBox.UnitEngine Property

REXUnitComboBox.UnitEngine Property
REXUnitComboBox Class REX.Controls.Forms Namespace REXUnitComboBox Class

Gets or sets the unit engine.

C#
public Autodesk.REX.Framework.IREXUnits UnitEngine;
Description

The unit engine.

Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.Forms Namespace, REXUnitComboBox Class

REXUnitComboBox.UnitType Property

REXUnitComboBox.UnitType Property
REXUnitComboBox Class REX.Controls.Forms Namespace REXUnitComboBox Class

Gets or sets the type of the unit.

C#
public Autodesk.REX.Framework.EUnitType UnitType;
Description

The type of the unit.

Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.Forms Namespace, REXUnitComboBox Class

REXUnitEditBox Class

REXUnitEditBox Class
REX.Controls.Forms Namespace Legend Members REXUnitEditBox Methods REXUnitEditBox Properties

Represents the REXEditBox control with a IREXUnitEngine.

Class Hierarchy
C#
[System.ComponentModel.ToolboxItem(true)]
[ToolboxBitmapAttribute(typeof(REXUnitEditBox), "REXUnitEditBox.Icon.bmp")]
public class REXUnitEditBox : REXEditBox;
Description
Namespace

REX.Controls.Forms Namespace

REXUnitEditBox Methods
REXUnitEditBox Methods | Description
GetBaseMaxValue | Gets the maximum value and converts it to base units.
GetBaseMinValue | Gets the minimum value and converts it to base units.
GetComplexDataBaseValue | Get the values and convert it to base units.
GetComplexDataInterfaceValue | Get the values and convert it to interface units.
GetDataBaseValue | Gets the value and converts it to base units.
GetDataInterfaceValue | Gets the value and converts it to interface units.
GetInterfaceMaxValue | Gets the maximum value and converts it to interface units.
GetInterfaceMinValue | Gets the minimum value and converts it to interface units.
SetBaseMaxValue | Set the maximum value defined in base units.
SetBaseMinValue | Set the minimum value defined in base units.
SetComplexDataBaseValue | Set the list of values defined in base units.
SetComplexDataInterfaceValue | Set the list of values defined in interface units.
SetDataBaseValue | Set the value in base units.
SetDataInterfaceValue | Set the value in interface units.
SetInterfaceMaxValue | Set the maximum value defined in interface units.
SetInterfaceMinValue | Set the minimum value defined in interface units.
REXUnitEditBox Properties
REXUnitEditBox Properties | Description
Power | Gets or sets the power of the unit.
UnitEngine | Gets or sets the unit engine.
UnitType | Gets or sets the type of the unit.
Links
REX.Controls.Forms Namespace, Legend, Members, REXUnitEditBox Methods, REXUnitEditBox Properties

REXUnitEditBox.GetBaseMaxValue Method

REXUnitEditBox.GetBaseMaxValue Method
REXUnitEditBox Class REX.Controls.Forms Namespace REXUnitEditBox Class

Gets the maximum value and converts it to base units.

C#
public double GetBaseMaxValue();
Returns

The value.

Description
Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.Forms Namespace, REXUnitEditBox Class

REXUnitEditBox.GetBaseMinValue Method

REXUnitEditBox.GetBaseMinValue Method
REXUnitEditBox Class REX.Controls.Forms Namespace REXUnitEditBox Class

Gets the minimum value and converts it to base units.

C#
public double GetBaseMinValue();
Returns

The value.

Description
Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.Forms Namespace, REXUnitEditBox Class

REXUnitEditBox.GetComplexDataBaseValue Method

REXUnitEditBox.GetComplexDataBaseValue Method
REXUnitEditBox Class REX.Controls.Forms Namespace REXUnitEditBox Class

Get the values and convert it to base units.

C#
public List<double> GetComplexDataBaseValue();
Returns

The list of values.

Description
Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.Forms Namespace, REXUnitEditBox Class

REXUnitEditBox.GetComplexDataInterfaceValue Method

REXUnitEditBox.GetComplexDataInterfaceValue Method
REXUnitEditBox Class REX.Controls.Forms Namespace REXUnitEditBox Class

Get the values and convert it to interface units.

C#
public List<double> GetComplexDataInterfaceValue(REXInterfaceType interfaceType);
Parameters
Parameters | Description
interfaceType | The product context.
Returns

The list of values.

Description
Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.Forms Namespace, REXUnitEditBox Class

REXUnitEditBox.GetDataBaseValue Method

REXUnitEditBox.GetDataBaseValue Method
REXUnitEditBox Class REX.Controls.Forms Namespace REXUnitEditBox Class

Gets the value and converts it to base units.

C#
public double GetDataBaseValue();
Returns

The value.

Description
Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.Forms Namespace, REXUnitEditBox Class

REXUnitEditBox.GetDataInterfaceValue Method

REXUnitEditBox.GetDataInterfaceValue Method
REXUnitEditBox Class REX.Controls.Forms Namespace REXUnitEditBox Class

Gets the value and converts it to interface units.

C#
public double GetDataInterfaceValue(REXInterfaceType interfaceType);
Parameters
Parameters | Description
interfaceType | The product context.
Returns

The value.

Description
Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.Forms Namespace, REXUnitEditBox Class

REXUnitEditBox.GetInterfaceMaxValue Method

REXUnitEditBox.GetInterfaceMaxValue Method
REXUnitEditBox Class REX.Controls.Forms Namespace REXUnitEditBox Class

Gets the maximum value and converts it to interface units.

C#
public double GetInterfaceMaxValue(REXInterfaceType interfaceType);
Parameters
Parameters | Description
interfaceType | The product context.
Returns

The value.

Description
Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.Forms Namespace, REXUnitEditBox Class

REXUnitEditBox.GetInterfaceMinValue Method

REXUnitEditBox.GetInterfaceMinValue Method
REXUnitEditBox Class REX.Controls.Forms Namespace REXUnitEditBox Class

Gets the minimum value and converts it to interface units.

C#
public double GetInterfaceMinValue(REXInterfaceType interfaceType);
Parameters
Parameters | Description
interfaceType | The product context.
Returns

The value.

Description
Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.Forms Namespace, REXUnitEditBox Class

REXUnitEditBox.SetBaseMaxValue Method

REXUnitEditBox.SetBaseMaxValue Method
REXUnitEditBox Class REX.Controls.Forms Namespace REXUnitEditBox Class

Set the maximum value defined in base units.

C#
public void SetBaseMaxValue(double value);
Parameters
Parameters | Description
value | The value.
Description
Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.Forms Namespace, REXUnitEditBox Class

REXUnitEditBox.SetBaseMinValue Method

REXUnitEditBox.SetBaseMinValue Method
REXUnitEditBox Class REX.Controls.Forms Namespace REXUnitEditBox Class

Set the minimum value defined in base units.

C#
public void SetBaseMinValue(double value);
Parameters
Parameters | Description
value | The value.
Description
Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.Forms Namespace, REXUnitEditBox Class

REXUnitEditBox.SetComplexDataBaseValue Method

REXUnitEditBox.SetComplexDataBaseValue Method
REXUnitEditBox Class REX.Controls.Forms Namespace REXUnitEditBox Class

Set the list of values defined in base units.

C#
public void SetComplexDataBaseValue(List<double> values);
Parameters
Parameters | Description
values | The values.
Description
Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.Forms Namespace, REXUnitEditBox Class

REXUnitEditBox.SetComplexDataInterfaceValue Method

REXUnitEditBox.SetComplexDataInterfaceValue Method