Contour_Compound2D Class REX.ContentGenerator.Geometry Namespace Contour_Compound2D Class

Gets or sets the list of shapes.

C#
public List<ContourCont> Shape;
Description

The list of shapes.

Class

Contour_Compound2D Class

Links
Contour_Compound2D Class, REX.ContentGenerator.Geometry Namespace, Contour_Compound2D Class

Contour_Section Class

Contour_Section Class
REX.ContentGenerator.Geometry Namespace Legend Members Public Methods

Represents the contour of the section.

Class Hierarchy
C#
[Serializable()]
public class Contour_Section : Contour_Compound2D;
Description
Namespace

REX.ContentGenerator.Geometry Namespace

Public Methods
Public Method | Description
Contour_Section | Initializes a new instance of the Contour_Section class.
Contour_Section | Initializes a new instance of the Contour_Section class.
Contour_Section | Initializes a new instance of the Contour_Section class.
Links
REX.ContentGenerator.Geometry Namespace, Legend, Members, Public Methods

Contour_Section.Contour_Section Constructor (REXSectionDBDimensions, int)

Contour_Section.Contour_Section Constructor (REXSectionDBDimensions, int)
Contour_Section Class REX.ContentGenerator.Geometry Namespace Contour_Section Class

Initializes a new instance of the Contour_Section class.

C#
public Contour_Section(REXSectionDBDimensions db, int typesec);
Parameters
Parameters | Description
db | The database description.
typesec | The type of the section.
Description
Class

Contour_Section Class

Links
Contour_Section Class, REX.ContentGenerator.Geometry Namespace, Contour_Section Class

Contour_Section.Contour_Section Constructor (REXSectionParamDescription, bool)

Contour_Section.Contour_Section Constructor (REXSectionParamDescription, bool)
Contour_Section Class REX.ContentGenerator.Geometry Namespace Contour_Section Class

Initializes a new instance of the Contour_Section class.

C#
public Contour_Section(REXSectionParamDescription par, bool start);
Parameters
Parameters | Description
par | The parametric description.
start | Indicates whether the contour should be taken from the start.
Description
Class

Contour_Section Class

Links
Contour_Section Class, REX.ContentGenerator.Geometry Namespace, Contour_Section Class

Contour_Section.Contour_Section Constructor (System.Runtime.Serialization.SerializationInfo, System.Runtime.Serialization.StreamingContext)

Contour_Section.Contour_Section Constructor (System.Runtime.Serialization.SerializationInfo, System.Runtime.Serialization.StreamingContext)
Contour_Section Class REX.ContentGenerator.Geometry Namespace Contour_Section Class

Initializes a new instance of the Contour_Section class.

C#
public Contour_Section(System.Runtime.Serialization.SerializationInfo info, System.Runtime.Serialization.StreamingContext context);
Parameters
Parameters | Description
info | Serialization data.
context | The context.
Description
Class

Contour_Section Class

Links
Contour_Section Class, REX.ContentGenerator.Geometry Namespace, Contour_Section Class

ContourArc Class

ContourArc Class
REX.ContentGenerator.Geometry Namespace Legend Members Public Methods ContourArc Methods ContourArc Properties

Represents the arc defined by the start, middle and end point.

Class Hierarchy
C#
[Serializable()]
public class ContourArc : ContourElem;
Description
Namespace

REX.ContentGenerator.Geometry Namespace

Public Methods
Public Method | Description
ContourArc | Initializes a new instance of the ContourArc2> class.
ContourArc | Initializes a new instance of the ContourArc2 class.
ContourArc | Initializes a new instance of the ContourArc2> class.
ContourArc | This is ContourArc, a member of class ContourArc.
ContourArc | Initializes a new instance of the ContourArc2 class.
ContourArc Methods
ContourArc Methods | Description
GetCenter | Gets the center of the arc.
GetCenter | Gets the center of the arc.
GetEnd | Gets the end.
GetMiddlePoint | Gets the middle point.
GetPointList | Gets the list of points.
GetStart | Gets the start.
MultiplyLengthDim | Multiplies length dimensions by the coefficient.
Transform | Applies the specified transformation to the element.
Translate | Applies the specified translation vector to the element.
ContourArc Properties
ContourArc Properties | Description
End | Gets or sets the end.
Middle | Gets or sets the middle.
Start | Gets or sets the start.
Links
REX.ContentGenerator.Geometry Namespace, Legend, Members, Public Methods, ContourArc Methods, ContourArc Properties

ContourArc.ContourArc Constructor (ContourArc)

ContourArc.ContourArc Constructor (ContourArc)
ContourArc Class REX.ContentGenerator.Geometry Namespace ContourArc Class

Initializes a new instance of the ContourArc2> class.

C#
public ContourArc(ContourArc pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

ContourArc Class

Links
ContourArc Class, REX.ContentGenerator.Geometry Namespace, ContourArc Class

ContourArc.ContourArc Constructor (REXxyz, REXxyz, REXxyz)

ContourArc.ContourArc Constructor (REXxyz, REXxyz, REXxyz)
ContourArc Class REX.ContentGenerator.Geometry Namespace ContourArc Class

Initializes a new instance of the ContourArc2 class.

C#
public ContourArc(REXxyz st, REXxyz end, REXxyz middle);
Parameters
Parameters | Description
st | The start.
end | The end.
middle | The middle.
Description
Class

ContourArc Class

Links
ContourArc Class, REX.ContentGenerator.Geometry Namespace, ContourArc Class

ContourArc.ContourArc Constructor (REXxyz, REXxyz, double, EArcDir)

ContourArc.ContourArc Constructor (REXxyz, REXxyz, double, EArcDir)
ContourArc Class REX.ContentGenerator.Geometry Namespace ContourArc Class

Initializes a new instance of the ContourArc2> class.

C#
public ContourArc(REXxyz st, REXxyz end, double R, EArcDir dir);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

ContourArc Class

Links
ContourArc Class, REX.ContentGenerator.Geometry Namespace, ContourArc Class

ContourArc.ContourArc Constructor (System.Runtime.Serialization.SerializationInfo, System.Runtime.Serialization.StreamingContext)

ContourArc.ContourArc Constructor (System.Runtime.Serialization.SerializationInfo, System.Runtime.Serialization.StreamingContext)
ContourArc Class REX.ContentGenerator.Geometry Namespace ContourArc Class

This is ContourArc, a member of class ContourArc.

C#
public ContourArc(System.Runtime.Serialization.SerializationInfo info, System.Runtime.Serialization.StreamingContext context);
Class

ContourArc Class

Links
ContourArc Class, REX.ContentGenerator.Geometry Namespace, ContourArc Class

ContourArc.ContourArc Constructor (double, double, double, double, double, EArcDir)

ContourArc.ContourArc Constructor (double, double, double, double, double, EArcDir)
ContourArc Class REX.ContentGenerator.Geometry Namespace ContourArc Class

Initializes a new instance of the ContourArc2 class.

C#
public ContourArc(double xst, double yst, double xend, double yend, double R, EArcDir dir);
Parameters
Parameters | Description
st | The start.
end | The end.
middle | The middle.
Description
Class

ContourArc Class

Links
ContourArc Class, REX.ContentGenerator.Geometry Namespace, ContourArc Class

ContourArc.GetCenter Method (ECoords)

ContourArc.GetCenter Method (ECoords)
ContourArc Class REX.ContentGenerator.Geometry Namespace ContourArc Class

Gets the center of the arc.

C#
public REXxyz GetCenter(ECoords coords);
Parameters
Parameters | Description
coords | The coordinate system (plane).
Returns

Returns coordinates of the center of the arc.

Description
Class

ContourArc Class

Links
ContourArc Class, REX.ContentGenerator.Geometry Namespace, ContourArc Class

ContourArc.GetCenter Method (REXxyz, REXxyz, REXxyz)

ContourArc.GetCenter Method (REXxyz, REXxyz, REXxyz)
ContourArc Class REX.ContentGenerator.Geometry Namespace ContourArc Class

Gets the center of the arc.

C#
public REXxyz GetCenter(REXxyz start, REXxyz middle, REXxyz end);
Parameters
Parameters | Description