REXImageComboBoxItem Class REX.Controls.WPF Namespace REXImageComboBoxItem Class

Gets or sets the image.

C#
public ImageSource Image;
Description

The image.

Class

REXImageComboBoxItem Class

Links
REXImageComboBoxItem Class, REX.Controls.WPF Namespace, REXImageComboBoxItem Class

REXImageComboBoxItem.Text Property

REXImageComboBoxItem.Text Property
REXImageComboBoxItem Class REX.Controls.WPF Namespace REXImageComboBoxItem Class

Gets or sets the text.

C#
public string Text;
Description

The text.

Class

REXImageComboBoxItem Class

Links
REXImageComboBoxItem Class, REX.Controls.WPF Namespace, REXImageComboBoxItem Class

REXImageComboBoxItem.VisibleOnList Property

REXImageComboBoxItem.VisibleOnList Property
REXImageComboBoxItem Class REX.Controls.WPF Namespace REXImageComboBoxItem Class

Gets or sets a value indicating whether item should be visible on the list.

C#
public bool VisibleOnList;
Description

True if item should be visible on the list; otherwise, false.

Class

REXImageComboBoxItem Class

Links
REXImageComboBoxItem Class, REX.Controls.WPF Namespace, REXImageComboBoxItem Class

REXIndexLabel Class

REXIndexLabel Class
REX.Controls.WPF Namespace Legend Members Public Methods REXIndexLabel Fields REXIndexLabel Methods REXIndexLabel Properties

Represents the REXIndexLabel control.

Class Hierarchy
C#
public class REXIndexLabel : Control;
Description

It can be used to draw small letters below or above the text baseline.

Remarks

In order to draw small letters it is necessarry to place them in curly brackets: rex{lower}{^upper}. In order to draw the specified letter using Symbolic font it is necessarry to start it with @: @rex.

Namespace

REX.Controls.WPF Namespace

Public Methods
Public Method | Description
REXIndexLabel | Initializes a new instance of the REXIndexLabel class.
REXIndexLabel Fields
REXIndexLabel Fields | Description
IndexCoeffProperty | This is IndexCoeffProperty, a member of class REXIndexLabel.
LeftAlignProperty | This is LeftAlignProperty, a member of class REXIndexLabel.
TextProperty | This is TextProperty, a member of class REXIndexLabel.
REXIndexLabel Methods
REXIndexLabel Methods | Description
GetTextSize | Gets the size of the text.
REXIndexLabel Properties
REXIndexLabel Properties | Description
IndexCoeff | Gets or sets the proportion between index and it's parent.
LeftAlign | Gets or sets a value indicating whether the content of the control should be aligned to the left.
Text | Gets or sets the current text in the REXIndexLabel.
Links
REX.Controls.WPF Namespace, Legend, Members, Public Methods, REXIndexLabel Fields, REXIndexLabel Methods, REXIndexLabel Properties

REXIndexLabel.REXIndexLabel Constructor

REXIndexLabel.REXIndexLabel Constructor
REXIndexLabel Class REX.Controls.WPF Namespace REXIndexLabel Class

Initializes a new instance of the REXIndexLabel class.

C#
public REXIndexLabel();
Description
Class

REXIndexLabel Class

Links
REXIndexLabel Class, REX.Controls.WPF Namespace, REXIndexLabel Class

REXIndexLabel.IndexCoeffProperty Field

REXIndexLabel.IndexCoeffProperty Field
REXIndexLabel Class REX.Controls.WPF Namespace REXIndexLabel Class

This is IndexCoeffProperty, a member of class REXIndexLabel.

C#
public static readonly DependencyProperty IndexCoeffProperty;
Class

REXIndexLabel Class

Links
REXIndexLabel Class, REX.Controls.WPF Namespace, REXIndexLabel Class

REXIndexLabel.LeftAlignProperty Field

REXIndexLabel.LeftAlignProperty Field
REXIndexLabel Class REX.Controls.WPF Namespace REXIndexLabel Class

This is LeftAlignProperty, a member of class REXIndexLabel.

C#
public static readonly DependencyProperty LeftAlignProperty;
Class

REXIndexLabel Class

Links
REXIndexLabel Class, REX.Controls.WPF Namespace, REXIndexLabel Class

REXIndexLabel.TextProperty Field

REXIndexLabel.TextProperty Field
REXIndexLabel Class REX.Controls.WPF Namespace REXIndexLabel Class

This is TextProperty, a member of class REXIndexLabel.

C#
public static readonly DependencyProperty TextProperty;
Class

REXIndexLabel Class

Links
REXIndexLabel Class, REX.Controls.WPF Namespace, REXIndexLabel Class

REXIndexLabel.GetTextSize Method

REXIndexLabel.GetTextSize Method
REXIndexLabel Class REX.Controls.WPF Namespace REXIndexLabel Class

Gets the size of the text.

C#
public double GetTextSize(string text, double fontSize);
Parameters
Parameters | Description
text | The text.
fontSize | The size of the font.
Returns

The size of the text.

Description
Class

REXIndexLabel Class

Links
REXIndexLabel Class, REX.Controls.WPF Namespace, REXIndexLabel Class

REXIndexLabel.IndexCoeff Property

REXIndexLabel.IndexCoeff Property
REXIndexLabel Class REX.Controls.WPF Namespace REXIndexLabel Class

Gets or sets the proportion between index and it's parent.

C#
[Category("Appearance")]
public double IndexCoeff;
Description

The index coefficient.

Class

REXIndexLabel Class

Links
REXIndexLabel Class, REX.Controls.WPF Namespace, REXIndexLabel Class

REXIndexLabel.LeftAlign Property

REXIndexLabel.LeftAlign Property
REXIndexLabel Class REX.Controls.WPF Namespace REXIndexLabel Class

Gets or sets a value indicating whether the content of the control should be aligned to the left.

C#
[Category("Appearance")]
public bool LeftAlign;
Description

True if left alignment; otherwise, false.

Class

REXIndexLabel Class

Links
REXIndexLabel Class, REX.Controls.WPF Namespace, REXIndexLabel Class

REXIndexLabel.Text Property

REXIndexLabel.Text Property
REXIndexLabel Class REX.Controls.WPF Namespace REXIndexLabel Class

Gets or sets the current text in the REXIndexLabel.

C#
[Category("Common Properties")]
public string Text;
Description

The text.

Class

REXIndexLabel Class

Links
REXIndexLabel Class, REX.Controls.WPF Namespace, REXIndexLabel Class

REXToolbox Class

REXToolbox Class
REX.Controls.WPF Namespace Legend Members Public Methods REXToolbox Delegates REXToolbox Events REXToolbox Fields REXToolbox Methods REXToolbox Properties

Represents the REXToolbox control

Class Hierarchy
C#
public class REXToolbox : DockPanel;
Namespace

REX.Controls.WPF Namespace

Public Methods
Public Method | Description
REXToolbox | Initializes a new instance of the REXToolbox class.
REXToolbox Delegates
REXToolbox Delegates | Description
EventSelectedItemChanged | This is nested type REX.Controls.WPF.REXToolbox.EventSelectedItemChanged.
REXToolbox Events
REXToolbox Events | Description
SelectedItemChanged | Occurs when the selected item changed.
REXToolbox Fields
REXToolbox Fields | Description
ApplyGradientsProperty | This is ApplyGradientsProperty, a member of class REXToolbox.
BorderBrushProperty | This is BorderBrushProperty, a member of class REXToolbox.
BorderThicknessProperty | This is BorderThicknessProperty, a member of class REXToolbox.
CategoryFontFamilyProperty | This is CategoryFontFamilyProperty, a member of class REXToolbox.
CategoryFontSizeProperty | This is CategoryFontSizeProperty, a member of class REXToolbox.
CategoryFontWeightProperty | This is CategoryFontWeightProperty, a member of class REXToolbox.
CategoryHeightProperty | This is CategoryHeightProperty, a member of class REXToolbox.
CategorySplitterProperty | This is CategorySplitterProperty, a member of class REXToolbox.
ItemBorderBrushProperty | This is ItemBorderBrushProperty, a member of class REXToolbox.
ItemBorderThicknessProperty | This is ItemBorderThicknessProperty, a member of class REXToolbox.
ItemFontFamilyProperty | This is ItemFontFamilyProperty, a member of class REXToolbox.
ItemFontSizeProperty | This is ItemFontSizeProperty, a member of class REXToolbox.
ItemFontWeightProperty | This is ItemFontWeightProperty, a member of class REXToolbox.
ItemHeightProperty | This is ItemHeightProperty, a member of class REXToolbox.
ItemHoverColorProperty | This is ItemHoverColorProperty, a member of class REXToolbox.
ItemSelectColorProperty | This is ItemSelectColorProperty, a member of class REXToolbox.
REXToolbox Methods
REXToolbox Methods | Description