REXDBSectionFactory.GetFamilyTemplate Method
REXDBSectionFactory Class REX.ContentGenerator.Converters Namespace REXDBSectionFactory Class

This is GetFamilyTemplate, a member of class REXDBSectionFactory.

C#
public override REXFamilyType GetFamilyTemplate(REX.ContentGenerator.Families.EElementType el, EMaterial mat);
Class

REXDBSectionFactory Class

Links
REXDBSectionFactory Class, REX.ContentGenerator.Converters Namespace, REXDBSectionFactory Class

REXDBSectionFactory.GetNewDescription Method ()

REXDBSectionFactory.GetNewDescription Method ()
REXDBSectionFactory Class REX.ContentGenerator.Converters Namespace REXDBSectionFactory Class

This is GetNewDescription, a member of class REXDBSectionFactory.

C#
public override REXDBDescription GetNewDescription();
Class

REXDBSectionFactory Class

Links
REXDBSectionFactory Class, REX.ContentGenerator.Converters Namespace, REXDBSectionFactory Class

REXDBSectionFactory.GetNewDescription Method (string, string, DTableDataObjectCollection)

REXDBSectionFactory.GetNewDescription Method (string, string, DTableDataObjectCollection)
REXDBSectionFactory Class REX.ContentGenerator.Converters Namespace REXDBSectionFactory Class

This is GetNewDescription, a member of class REXDBSectionFactory.

C#
public override REXDBDescription GetNewDescription(string dir, string dbName, DTableDataObjectCollection dtdoc);
Class

REXDBSectionFactory Class

Links
REXDBSectionFactory Class, REX.ContentGenerator.Converters Namespace, REXDBSectionFactory Class

REXDBSectionFactory.GetNewFamily Method

REXDBSectionFactory.GetNewFamily Method
REXDBSectionFactory Class REX.ContentGenerator.Converters Namespace REXDBSectionFactory Class

This is GetNewFamily, a member of class REXDBSectionFactory.

C#
public override REXFamilyType GetNewFamily();
Class

REXDBSectionFactory Class

Links
REXDBSectionFactory Class, REX.ContentGenerator.Converters Namespace, REXDBSectionFactory Class

REXDBSectionFactory.RecalculatDBDesc Method

REXDBSectionFactory.RecalculatDBDesc Method
REXDBSectionFactory Class REX.ContentGenerator.Converters Namespace REXDBSectionFactory Class

This is RecalculatDBDesc, a member of class REXDBSectionFactory.

C#
public override void RecalculatDBDesc(REXDBDescription sec, string DBPath, string DBName, bool fromInterface);
Class

REXDBSectionFactory Class

Links
REXDBSectionFactory Class, REX.ContentGenerator.Converters Namespace, REXDBSectionFactory Class

REXDBSectionFactory.ValidateDB Method (IDbRootLib.IDbDatabase)

REXDBSectionFactory.ValidateDB Method (IDbRootLib.IDbDatabase)
REXDBSectionFactory Class REX.ContentGenerator.Converters Namespace REXDBSectionFactory Class

This is ValidateDB, a member of class REXDBSectionFactory.

C#
public override bool ValidateDB(IDbRootLib.IDbDatabase db);
Class

REXDBSectionFactory Class

Links
REXDBSectionFactory Class, REX.ContentGenerator.Converters Namespace, REXDBSectionFactory Class

REXDBSectionFactory.ValidateDB Method (string)

REXDBSectionFactory.ValidateDB Method (string)
REXDBSectionFactory Class REX.ContentGenerator.Converters Namespace REXDBSectionFactory Class

This is ValidateDB, a member of class REXDBSectionFactory.

C#
public override bool ValidateDB(string dbName);
Class

REXDBSectionFactory Class

Links
REXDBSectionFactory Class, REX.ContentGenerator.Converters Namespace, REXDBSectionFactory Class

REXDBSectionFactory.ValidateDBADO Method

REXDBSectionFactory.ValidateDBADO Method
REXDBSectionFactory Class REX.ContentGenerator.Converters Namespace REXDBSectionFactory Class

This is ValidateDBADO, a member of class REXDBSectionFactory.

C#
public override bool ValidateDBADO(string dbName);
Class

REXDBSectionFactory Class

Links
REXDBSectionFactory Class, REX.ContentGenerator.Converters Namespace, REXDBSectionFactory Class

REXFamilyConverter Class

REXFamilyConverter Class
REX.ContentGenerator.Converters Namespace Legend Members Public Methods REXFamilyConverter Methods REXFamilyConverter Properties

This class represents a converter which provides access to common databases.

Class Hierarchy
C#
public class REXFamilyConverter : REX.ContentGenerator.Map.IMapConverter;
Description

It allows user to get the REXFamilyType object from the specific record in the database as well as get the record based on the specified REXFamilyType object.

Namespace

REX.ContentGenerator.Converters Namespace

Public Methods
Public Method | Description
REXFamilyConverter | Initializes a new instance of the REXFamilyConverter class.
REXFamilyConverter Methods
REXFamilyConverter Methods | Description
Close | Clears collections, releases COM objects.
FindFamily | Finds the REXFamilyType in the specific list.
GenerateMaps | Generates a file used in the mapping aliases system.
GetDatabaseDirectory | Returns directory for databases of the specific category.
GetDatabasePath | Return a path for particular database of the specified category.
GetDBList | Gets the list of database's records adequate for the list of input objects.
GetDBList | Gets the list of database's records adequate for the list of input objects.
GetDBList | Gets the list of database's records adequate for the input object.
GetDBList | Gets the list of database's records adequate for the input object.
GetDBList | Gets the list of database's records adequate for the input object.
GetDBList | Gets the list of database's records adequate for the input object.
GetDBList | Gets the list of database's records adequate for the input object.
GetDBList | Gets the list of database's records adequate for the input object.
GetDBList | Gets the list of database's records adequate for the input object.
GetDBList | Gets the list of database's records adequate for the input object.
GetDBList | Gets the list of database's records adequate for the input object.
GetDbProperty | Gets the property of specific name for the database.
GetEmptyFamilyOfAlias | Gets the empty family of alias name.
GetFamilies | Gets the list of all elements in the selected database.
GetFamilies | Gets the list of all elements in the selected database.
GetFamilies | Gets the list of all elements in selected database.
GetFamilies | Gets the list of all elements in selected database.
GetFamily | Gets the REXFamilyType object based on specific database's record.
GetFamily | Gets the REXFamilyType object based on specific database's record.
GetFamily | Gets the REXFamilyType object based on specific database's record.
GetFamily | Gets the REXFamilyType object based on the specified database's record.
GetFamilyDBSection | Gets the section of the specified name (based on data from databases).
GetFamilyDBSection | Gets the section of the specified key (based on data from the database).
GetFamilyDBSection | Gets the section of the specified name (based on data from databases).
GetFamilyDBSection | Gets the section of the specified name (based on data from the database).
GetFamilyDefault | Gets the default REXFamilyType of the specified type.
GetFamilyMaterial | Gets the material of the specific name (based on data from the database).
GetFamilyMaterial | Gets the material of the specified name (based on data from the database).
GetFamilyMaterial | Gets the material of the specific name (based on data from the database).
GetFamilyRebarHook | Gets the family rebar hook.
GetFamilyRebarShape | Gets the rebar shape of specified code and database.
GetFamilyRebarType | Gets the rebar's type of the specified steel and the bar's size (based on data from the database).
GetFamilyTemplate | Gets the dedicated template of the REXFamilyType (with initial data).
GetFilteredFamilies | Gets the list of filtered elements in the selected database.
GetFilteredFamilies | Gets the list of filtered elements in the selected database.
GetFilteredFamilies | Gets the list of filtered elements in selected database.
GetFilteredFamilies | Gets the list of filtered elements in the selected database.
GetNameForAlias | Gets the certified name for the alias.