REXExtensionContext Class
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REX.Common.REXExtensionContext.REXStandardOwner Enumeration

REX.Common.REXExtensionContext.REXStandardOwner Enumeration
REXExtensionContext Class

Owner of module.

C#
public enum REXStandardOwner {
  Parent = REXInterfaceType.None,
  Other = REXInterfaceType.Common,
  RSA = REXInterfaceType.Robot,
  ASD = REXInterfaceType.RCAD,
  Revit = REXInterfaceType.Revit
}
Members
Members | Description
Parent | Standard extension.
Other | Other protection level.
RSA | RSA.
ASD | ASD.
Revit | Revit.
Description
Class

REXExtensionContext Class

Links
REXExtensionContext Class
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REX.Common.REXExtensionContext.REXStandardRunContext Enumeration

REX.Common.REXExtensionContext.REXStandardRunContext Enumeration
REXExtensionContext Class

Defines standard running context.

C#
public enum REXStandardRunContext {
  None,
  Other,
  RCad,
  Robot,
  Revit,
  ESOP,
  CBS,
  OperationClear,
  OperationUpdate,
  OperationEditTemplate
}
Members
Members | Description
None | Module is running in standard mode.
Other | Module is running in unknown mode.
RCad | Module is running n order to transfer model to Autocad Structural Detailing.
Robot | Module is running in order to transfer model to Robot Structural Analysis.
Revit | Module is running in order to transfer model to Revit Strucutre, Architecture or MEP.
ESOP | Module is running in order to transfer model to Spreadsheet Calculator.
CBS | Module is running in order to transfer model to Concrete Building Strucutres.
OperationClear | Module is running in order to clear all previously generated elements.
OperationUpdate | Module is running in order to update elements.
OperationEditTemplate | Module is running in order to edit template.
Description

Set it from REXContext object.

Class

REXExtensionContext Class

Links
REXExtensionContext Class
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXExtensionContext.Control Field

REXExtensionContext.Control Field
REXExtensionContext Class REX.Common Namespace REXExtensionContext Class

Reference to Control object.

C#
public REXControl Control = new REXControl();
Description
Class

REXExtensionContext Class

Links
REXExtensionContext Class, REX.Common Namespace, REXExtensionContext Class

REXExtensionControl Class

REXExtensionControl Class
REX.Common Namespace Legend Members Public Methods REXExtensionControl Methods REXExtensionControl Properties

Base class for user controls.

Class Hierarchy
C#
public class REXExtensionControl : System.Windows.Controls.UserControl, IREXThisExtension;
Description

Enables easy access to main module's objects.

Namespace

REX.Common Namespace

Public Methods
Public Method | Description
REXExtensionControl | Initializes a new instance of a REXExtensionControl class.
REXExtensionControl | Initializes a new instance of a REXExtensionControl class.
REXExtensionControl Methods
REXExtensionControl Methods | Description
OnActivateLayout | Called when activate layout.
REXExtensionControl Properties
REXExtensionControl Properties | Description
ThisApplication | Get this application.
ThisContext | Get this context.
ThisExtension | Get this extension.
ThisProduct | Gets the this product.
ThisRunContext | Gets the this run context.
Links
REX.Common Namespace, Legend, Members, Public Methods, REXExtensionControl Methods, REXExtensionControl Properties

REXExtensionControl.REXExtensionControl Constructor ()

REXExtensionControl.REXExtensionControl Constructor ()
REXExtensionControl Class REX.Common Namespace REXExtensionControl Class

Initializes a new instance of a REXExtensionControl class.

C#
public REXExtensionControl();
Description
Class

REXExtensionControl Class

Links
REXExtensionControl Class, REX.Common Namespace, REXExtensionControl Class

REXExtensionControl.REXExtensionControl Constructor (REXExtension)

REXExtensionControl.REXExtensionControl Constructor (REXExtension)
REXExtensionControl Class REX.Common Namespace REXExtensionControl Class

Initializes a new instance of a REXExtensionControl class.

C#
public REXExtensionControl(REXExtension Ext);
Parameters
Parameters | Description
Ext | The reference to a REXExtension object.
Description
Class

REXExtensionControl Class

Links
REXExtensionControl Class, REX.Common Namespace, REXExtensionControl Class

REXExtensionControl.OnActivateLayout Method

REXExtensionControl.OnActivateLayout Method
REXExtensionControl Class REX.Common Namespace REXExtensionControl Class

Called when activate layout.

C#
public virtual void OnActivateLayout(ref REXLayoutItem LItem, bool Activate);
Parameters
Parameters | Description
LItem | The layout item.
Activate | If set to true,layout is activated.
Description
Class

REXExtensionControl Class

Links
REXExtensionControl Class, REX.Common Namespace, REXExtensionControl Class

REXExtensionControl.ThisApplication Property

REXExtensionControl.ThisApplication Property
REXExtensionControl Class REX.Common Namespace REXExtensionControl Class

Get this application.

C#
[Browsable(false)]
public REXApplication ThisApplication;
Description

This application.

Class

REXExtensionControl Class

Links
REXExtensionControl Class, REX.Common Namespace, REXExtensionControl Class

REXExtensionControl.ThisContext Property

REXExtensionControl.ThisContext Property
REXExtensionControl Class REX.Common Namespace REXExtensionControl Class

Get this context.

C#
[Browsable(false)]
public REXContext ThisContext;
Description

This context.

Class

REXExtensionControl Class

Links
REXExtensionControl Class, REX.Common Namespace, REXExtensionControl Class

REXExtensionControl.ThisExtension Property

REXExtensionControl.ThisExtension Property
REXExtensionControl Class REX.Common Namespace REXExtensionControl Class

Get this extension.

C#
[Browsable(false)]
public REXExtension ThisExtension;
Description

This extension.

Class

REXExtensionControl Class

Links
REXExtensionControl Class, REX.Common Namespace, REXExtensionControl Class

REXExtensionControl.ThisProduct Property

REXExtensionControl.ThisProduct Property
REXExtensionControl Class REX.Common Namespace REXExtensionControl Class

Gets the this product.

C#
public REXInterfaceType ThisProduct;
Description

The this product.

Class

REXExtensionControl Class

Links
REXExtensionControl Class, REX.Common Namespace, REXExtensionControl Class

REXExtensionControl.ThisRunContext Property

REXExtensionControl.ThisRunContext Property
REXExtensionControl Class REX.Common Namespace REXExtensionControl Class

Gets the this run context.

C#
public REX.Common.REXExtensionContext.REXStandardRunContext ThisRunContext;
Description

The this run context.

Class

REXExtensionControl Class

Links
REXExtensionControl Class, REX.Common Namespace, REXExtensionControl Class

REXExtensionData Class

REXExtensionData Class
REX.Common Namespace Legend Members Public Methods REXExtensionData Enumerations REXExtensionData Methods REXExtensionData Properties

Base class for REXData and REXResults classes.

Class Hierarchy
C#
public class REXExtensionData : REXExtensionObject;
Description

Allows these structures serialization, loading and saving.

Namespace

REX.Common Namespace

Public Methods
Public Method | Description
REXExtensionData | Initializes a new instance of the REXExtensionData class.
REXExtensionData Enumerations
REXExtensionData Enumerations | Description
DataMode | Determines the target of serialization.