MapLanguageToCultureInfoName | This is MapLanguageToCultureInfoName, a member of class REXDirectRevitAccess.
PresetContext | Presets the context.
Links
REX.Common Namespace, Legend, Members, REXDirectRevitAccess Methods

REXDirectRevitAccess.GetRevitSubName Method (Autodesk.Revit.ApplicationServices.Application)

REXDirectRevitAccess.GetRevitSubName Method (Autodesk.Revit.ApplicationServices.Application)
REXDirectRevitAccess Class REX.Common Namespace REXDirectRevitAccess Class

Gets the name of the revit sub.

C#
public static string GetRevitSubName(Autodesk.Revit.ApplicationServices.Application RevitApp);
Parameters
Parameters | Description
RevitApp | The revit app.
Description
Class

REXDirectRevitAccess Class

Links
REXDirectRevitAccess Class, REX.Common Namespace, REXDirectRevitAccess Class

REXDirectRevitAccess.GetRevitSubName Method (string)

REXDirectRevitAccess.GetRevitSubName Method (string)
REXDirectRevitAccess Class REX.Common Namespace REXDirectRevitAccess Class

Gets the name of the revit sub.

C#
public static string GetRevitSubName(string VersionName);
Parameters
Parameters | Description
VersionName | Name of the version.
Description
Class

REXDirectRevitAccess Class

Links
REXDirectRevitAccess Class, REX.Common Namespace, REXDirectRevitAccess Class

REXDirectRevitAccess.MapLanguageToCultureInfoName Method

REXDirectRevitAccess.MapLanguageToCultureInfoName Method
REXDirectRevitAccess Class REX.Common Namespace REXDirectRevitAccess Class

This is MapLanguageToCultureInfoName, a member of class REXDirectRevitAccess.

C#
public string MapLanguageToCultureInfoName(Autodesk.Revit.ApplicationServices.LanguageType language);
Class

REXDirectRevitAccess Class

Links
REXDirectRevitAccess Class, REX.Common Namespace, REXDirectRevitAccess Class

REXDirectRevitAccess.PresetContext Method

REXDirectRevitAccess.PresetContext Method
REXDirectRevitAccess Class REX.Common Namespace REXDirectRevitAccess Class

Presets the context.

C#
public void PresetContext(ref Autodesk.Revit.UI.ExternalCommandData commandData, ref string message, ref ElementSet elements, ref REXContext Context);
Parameters
Parameters | Description
commandData | The command data.
message | The message.
elements | The elements.
Context | The context.
Description

Set dedicated version name. For example "2009", "2010".

On second step the method sets:

Context.Product.Objects -> REX.Common.REXConst.REX_RevitObjectAutodesk.Revit.ExternalCommandData as commandData.

Context.Product.Objects -> REX.Common.REXConst.REX_RevitObjectElements as elements.

Context.Product.Data -> REX.Common.REXConst.REX_RevitDataMessage as message.

Class

REXDirectRevitAccess Class

Links
REXDirectRevitAccess Class, REX.Common Namespace, REXDirectRevitAccess Class

REXDirectRevitExecute Class

REXDirectRevitExecute Class
REX.Common Namespace Legend Members Public Methods REXDirectRevitExecute Methods

This is class REX.Common.REXDirectRevitExecute.

Class Hierarchy
C#
[Autodesk.Revit.Attributes.Transaction(Autodesk.Revit.Attributes.TransactionMode.Manual)]
[Autodesk.Revit.Attributes.Regeneration(Autodesk.Revit.Attributes.RegenerationOption.Manual)]
public class REXDirectRevitExecute : Autodesk.Revit.UI.IExternalCommand;
Namespace

REX.Common Namespace

Public Methods
Public Method | Description
REXDirectRevitExecute | This is REXDirectRevitExecute, a member of class REXDirectRevitExecute.
REXDirectRevitExecute Methods
REXDirectRevitExecute Methods | Description
Execute | This is Execute, a member of class REXDirectRevitExecute.
Execute | This is Execute, a member of class REXDirectRevitExecute.
Execute | This is Execute, a member of class REXDirectRevitExecute.
Execute | This is Execute, a member of class REXDirectRevitExecute.
Execute | This is Execute, a member of class REXDirectRevitExecute.
Links
REX.Common Namespace, Legend, Members, Public Methods, REXDirectRevitExecute Methods

REXDirectRevitExecute.REXDirectRevitExecute Constructor

REXDirectRevitExecute.REXDirectRevitExecute Constructor
REXDirectRevitExecute Class REX.Common Namespace REXDirectRevitExecute Class

This is REXDirectRevitExecute, a member of class REXDirectRevitExecute.

C#
public REXDirectRevitExecute(REXApplication application);
Class

REXDirectRevitExecute Class

Links
REXDirectRevitExecute Class, REX.Common Namespace, REXDirectRevitExecute Class

REXDirectRevitExecute.Execute Method (Autodesk.Revit.UI.ExternalCommandData, string, ElementSet)

REXDirectRevitExecute.Execute Method (Autodesk.Revit.UI.ExternalCommandData, string, ElementSet)
REXDirectRevitExecute Class REX.Common Namespace REXDirectRevitExecute Class

This is Execute, a member of class REXDirectRevitExecute.

C#
public Autodesk.Revit.UI.Result Execute(Autodesk.Revit.UI.ExternalCommandData commandData, ref string message, ElementSet elements);
Class

REXDirectRevitExecute Class

Links
REXDirectRevitExecute Class, REX.Common Namespace, REXDirectRevitExecute Class

REXDirectRevitExecute.Execute Method (Autodesk.Revit.UI.ExternalCommandData, string, ElementSet, REXMode, REXControlMode, string, Dictionary<string,object>)

REXDirectRevitExecute.Execute Method (Autodesk.Revit.UI.ExternalCommandData, string, ElementSet, REXMode, REXControlMode, string, Dictionary<string,object>)
REXDirectRevitExecute Class REX.Common Namespace REXDirectRevitExecute Class

This is Execute, a member of class REXDirectRevitExecute.

C#
public Autodesk.Revit.UI.Result Execute(Autodesk.Revit.UI.ExternalCommandData commandData, ref string message, ElementSet elements, REXMode mode, REXControlMode controlMode, string runContext, Dictionary<string,object> objects);
Class

REXDirectRevitExecute Class

Links
REXDirectRevitExecute Class, REX.Common Namespace, REXDirectRevitExecute Class

REXDirectRevitExecute.Execute Method (Document, REXMode, REXControlMode, string, List<Element>)

REXDirectRevitExecute.Execute Method (Document, REXMode, REXControlMode, string, List<Element>)
REXDirectRevitExecute Class REX.Common Namespace REXDirectRevitExecute Class

This is Execute, a member of class REXDirectRevitExecute.

C#
public Autodesk.Revit.UI.Result Execute(Document doc, REXMode mode, REXControlMode controlMode, string runContext, List<Element> elements);
Class

REXDirectRevitExecute Class

Links
REXDirectRevitExecute Class, REX.Common Namespace, REXDirectRevitExecute Class

REXDirectRevitExecute.Execute Method (Document, string, List<Element>)

REXDirectRevitExecute.Execute Method (Document, string, List<Element>)
REXDirectRevitExecute Class REX.Common Namespace REXDirectRevitExecute Class

This is Execute, a member of class REXDirectRevitExecute.

C#
public Autodesk.Revit.UI.Result Execute(Document doc, string runContext, List<Element> elements);
Class

REXDirectRevitExecute Class

Links
REXDirectRevitExecute Class, REX.Common Namespace, REXDirectRevitExecute Class

REXDirectRevitExecute.Execute Method (UpdaterData)

REXDirectRevitExecute.Execute Method (UpdaterData)
REXDirectRevitExecute Class REX.Common Namespace REXDirectRevitExecute Class

This is Execute, a member of class REXDirectRevitExecute.

C#
public Autodesk.Revit.UI.Result Execute(UpdaterData updaterData);
Class

REXDirectRevitExecute Class

Links
REXDirectRevitExecute Class, REX.Common Namespace, REXDirectRevitExecute Class

REXErrors Class

REXErrors Class
REX.Common Namespace Legend Members REXErrors Enumerations REXErrors Methods

Supprots REX errors for logging system.

Class Hierarchy
C#
public class REXErrors;
Description

It can be used for logging general errors in REX modules.

Namespace

REX.Common Namespace

REXErrors Enumerations
REXErrors Enumerations | Description
ErrorCode | Standard REX error codes.
REXErrors Methods
REXErrors Methods | Description
GetCategory | Returns category for specified error code.
GetMessage | Returns formated error string.
Links
REX.Common Namespace, Legend, Members, REXErrors Enumerations, REXErrors Methods

REX.Common.REXErrors.ErrorCode Enumeration