TokensRangeMaxCheckProperty | This is TokensRangeMaxCheckProperty, a member of class REXComboBox.
TokensRangeMinCheckProperty | This is TokensRangeMinCheckProperty, a member of class REXComboBox.
UnitSymbolProperty | This is UnitSymbolProperty, a member of class REXComboBox.

Fields (AutoDoc Folder)

Legend
Legend
Data Member
static
read only

Legend

Legend
REXComboBox Class
Legend
Constructor
Data Member
static
read only
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXComboBox Class Members

REXComboBox Class Members
REXComboBox Class Legend
Members
Public Methods
Public Method | Description
REXComboBox | Initializes a new instance of the REXComboBox class.
REXComboBox Fields
REXComboBox Fields | Description
BackgroundDisabledHiddenProperty | This is BackgroundDisabledHiddenProperty, a member of class REXComboBox.
BackgroundDisabledStandardProperty | This is BackgroundDisabledStandardProperty, a member of class REXComboBox.
BackgroundErrorProperty | This is BackgroundErrorProperty, a member of class REXComboBox.
BackgroundNeutralProperty | This is BackgroundNeutralProperty, a member of class REXComboBox.
BackgroundOKProperty | This is BackgroundOKProperty, a member of class REXComboBox.
ComplexDoubleValueProperty | This is ComplexDoubleValueProperty, a member of class REXComboBox.
ComplexProperty | This is ComplexProperty, a member of class REXComboBox.
ComplexSeparatorProperty | This is ComplexSeparatorProperty, a member of class REXComboBox.
ComplexSpaceSeparatorProperty | This is ComplexSpaceSeparatorProperty, a member of class REXComboBox.
ComplexUnitOnEndProperty | This is ComplexUnitOnEndProperty, a member of class REXComboBox.
CorrectValueProperty | This is CorrectValueProperty, a member of class REXComboBox.
DataTypeProperty | This is DataTypeProperty, a member of class REXComboBox.
DoubleValueProperty | This is DoubleValueProperty, a member of class REXComboBox.
EngineeringFormatProperty | This is EngineeringFormatProperty, a member of class REXComboBox.
EpsilonProperty | This is EpsilonProperty, a member of class REXComboBox.
InvalidCharactersProperty | This is InvalidCharactersProperty, a member of class REXComboBox.
ListValidationProperty | This is ListValidationProperty, a member of class REXComboBox.
MaxTokensProperty | This is MaxTokensProperty, a member of class REXComboBox.
MinTokensProperty | This is MinTokensProperty, a member of class REXComboBox.
OnDisableActionProperty | This is OnDisableActionProperty, a member of class REXComboBox.
OriginalTextOnEnterProperty | This is OriginalTextOnEnterProperty, a member of class REXComboBox.
RangeMaxCheckProperty | This is RangeMaxCheckProperty, a member of class REXComboBox.
RangeMaxProperty | This is RangeMaxProperty, a member of class REXComboBox.
RangeMinCheckProperty | This is RangeMinCheckProperty, a member of class REXComboBox.
RangeMinProperty | This is RangeMinProperty, a member of class REXComboBox.
RememberCorrectProperty | This is RememberCorrectProperty, a member of class REXComboBox.
RoundingFractionalProperty | This is RoundingFractionalProperty, a member of class REXComboBox.
RoundingIncrementProperty | This is RoundingIncrementProperty, a member of class REXComboBox.
SeparatorProperty | This is SeparatorProperty, a member of class REXComboBox.
TextBoxModeProperty | This is TextBoxModeProperty, a member of class REXComboBox.
TokensRangeMaxCheckProperty | This is TokensRangeMaxCheckProperty, a member of class REXComboBox.
TokensRangeMinCheckProperty | This is TokensRangeMinCheckProperty, a member of class REXComboBox.
UnitSymbolProperty | This is UnitSymbolProperty, a member of class REXComboBox.
REXComboBox Methods
REXComboBox Methods | Description
AddEnabledChangedHandler | Adds the handler to the event raised when the element changes it's enable state.
AddLostFocusHandler | Adds the handler to the event raised when the element loses logical focus.
AddTextChangedHandler | Adds the handler to the event raised when text changes.
Editable | Gets a value indicating whether the control is editable.
GetBackground | Gets the background of the control.
GetComplexDoubleValue | Gets the complex (list) value of the double type.
GetComplexStringValue | Returns a complex string list.
GetEnable | Indicates whether the control is enabled.
GetFullName | Gets the full name.
GetItems | Gets the collection of the items contained in the control.
GetLastCorrectValueStr | Gets the last correct stored value.
GetPropertiesType | Gets the mode of the combo.
GetSelectedIndex | Gets the index specifying the currently selected item.
GetState | Gets the current state of the control.
GetText | Gets the text contents of the control.
GetUniqueName | Returns the Unique ID generated for the current instance of the engine.
GetValue | Gets the value of the double type.
Refresh | Refreshes the text on the control based on the current text.
RefreshValidationStatus | Refreshes the validation status.
Reset | Resets control (internal values).
RestorePropertiesType | Restores the mode of the combo.
SetBackground | Sets the background of the control.
SetComplexValue | Sets the complex (list) value of the string type.
SetComplexValue | Sets the complex (list) value of the string type.
SetComplexValue | Set complex value to the control
SetEnable | Sets the enable state.
SetExternalUnitBody | Sets external IUnitBody object for custom unit processing.
SetPropertiesType | Sets the mode of the combo.
SetSelectedIndex | Sets the index specifying the currently selected item.
SetText | Sets the text contents of the control.
SetUserTextValidation | Sets the user validation method for the text control.
SetUserValidation | Sets the user validation method.
SetUserValidationComplex | Sets the user validation method for complex values (list).
SetValue | Sets the value of the double type.
SetValue | Sets the value of the string type.
ValidateComplexValue | Validates the complex (list) value of the double type.
ValidateComplexValue | Validates the complex (list) value of the string type.
ValidateComplexValue | Validates the complex (list) value of the string type.
ValidateValue | Validates the input value of the double type.
ValidateValue | Validates the value of the string type.
ValueFormat | Returns a text containing an expression formatted according the current settings of the element.
ValueFormat | Returns a text containing an expression formatted according the current settings of the element.
ValueParse | Converts the specified text to the numeric value according the current settings of the element.
REXComboBox Properties
REXComboBox Properties | Description
BackgroundDisabledHidden | Gets or sets the background for the disabled state of the control in the hidden background mode.
BackgroundDisabledStandard | Gets or sets the background for the disabled state of the control.
BackgroundError | Gets or sets the background for the Error state of the control.
BackgroundNeutral | Gets or sets the background for the neutral state of the control.
BackgroundOK | Gets or sets the background for the OK state of the control.
Complex | Gets or sets a value indicating whether this REXEditControlEngine supports complex (list) values.
ComplexDoubleValue | Gets or sets the complex double value.
ComplexSeparator | Gets or sets the complex (list) separator.
ComplexSpaceSeparator | Gets or sets a value indicating whether a space should be respected as a list separator.
ComplexUnitOnEnd | Gets or sets a value indicating whether a unit symbol should be placed on the end of the formatted text.
ControlState | Gets the current state of the control.
CorrectValue | Gets or sets the correct value.
DataType | Gets or sets the type of the data in the control.
DoubleValue | Gets or sets the double value.