RestoreOriginalText | Refreshes the text on the control based on the original text.
SetBaseMaxValue | Set the maximum value defined in base units.
SetBaseMinValue | Set the minimum value defined in base units.
SetComplexDataBaseValue | Set the list of values defined in base units.
SetComplexDataInterfaceValue | Set the list of values defined in interface units.
SetComplexValue | Sets the complex (list) value of the double type.
SetComplexValue | Sets the complex (list) value of the string type.
SetComplexValue | Sets the complex (list) value of the string type.
SetControl | Sets the control for which the current instance is the engine.
SetDataBaseValue | Set the value in base units.
SetDataInterfaceValue | Set the value in interface units.
SetExternalUnitBody | Set external IUnitBody object.
SetInterfaceMaxValue | Set the maximum value defined in interface units.
SetInterfaceMinValue | Set the minimum value defined in interface units.
SetUserTextValidation | Sets the user validation method for the text control.
SetUserValidation | Sets the user validation method.
SetUserValidationComplex | Sets the user validation method for complex values (list).
SetValue | Sets the value of the double type.
SetValue | Sets the value of the string type.
StartEdit | Starts the edit mode.
TextChanged | Informs about changes in the control's text.
ValidateComplexValue | Validates the complex (list) value of the double type.
ValidateComplexValue | Validates the complex (list) value of the string type.
ValidateComplexValue | Validates the complex (list) value of the string type.
ValidateControl | Validates the current control based on the input values.
ValidateControl | Validates the current control based on the input text.
ValidateControl | Validates the current control based on the current text or the stored value.
ValidateControl | Validates the current control based on the input value.
ValidateValue | Validates the input value of the double type.
ValidateValue | Validates the value of the string type.
ValueFormat | Returns a text containing an expression formatted according the current settings of the element.
ValueFormat | Returns a text containing an expression formatted according the current settings of the element.
ValueParse | Converts the specified text to the numeric value according the current settings of the element.

Methods (AutoDoc Folder)

Legend
Legend
Method
virtual
static

REXEditControlEngine Properties

REXEditControlEngine Properties
REXEditControlEngine Class Legend
REXEditControlEngine Properties
REXEditControlEngine Properties | Description
Background | Gets or sets the background of the control.
BackgroundDisabledHidden | Gets or sets the background for the disabled state of the control in the hidden background mode.
BackgroundDisabledStandard | Gets or sets the background for the disabled state of the control.
BackgroundError | Gets or sets the background for the Error state of the control.
BackgroundNeutral | Gets or sets the background for the neutral state of the control.
BackgroundOK | Gets or sets the background for the OK state of the control.
Complex | Gets or sets a value indicating whether this REXEditControlEngine supports complex (list) values.
ComplexSeparator | Gets or sets the complex (list) separator.
ComplexSpaceSeparator | Gets or sets a value indicating whether a space should be respected as a list separator.
ComplexUnitOnEnd | Gets or sets a value indicating whether a unit symbol should be placed on the end of the formatted text.
ControlState | Gets the current state of the control.
CorrectValue | Gets or sets the correct value.
DataType | Gets or sets the type of the data in the control.
EngineeringFormat | Gets or sets a value indicating whether the text of the control should be formatted in according to the engineering (expotential) format.
Epsilon | Gets or sets the accuracy.
InvalidCharacters | Gets or sets the list invalid characters (for the control in TEXT mode).
IsEnabled | Gets or sets a value indicating whether this instance is enabled.
MaxTokens | Gets or sets the maximum number of elements in the complex mode (list).
MinTokens | Gets or sets the minimum number of elements in the complex mode (list).
OnDisableAction | Gets or sets a value indicating whether the foreground should be hidden when the control is disabled.
OriginalTextOnEnter | Gets or sets a value indicating whether an original text should be set when the user enters the control.
Power | Gets or sets the power of the unit.
RangeMax | Gets or sets the highest possible value.
RangeMaxCheck | Gets or sets a value indicating whether the value should be validated due to the RangeMax.
RangeMin | Gets or sets the minimum possible value.
RangeMinCheck | Gets or sets a value indicating whether the value should be validated due to the RangeMin.
RememberCorrect | Gets or sets a value indicating whether the correct value should be restored in case of the validation failure.
RoundingFractional | Gets or sets the rounding for fractional units.
RoundingIncrement | Gets or sets the rounding increment (for the DECIMAL DataType).
Separator | Gets or sets the decimal separator.
Tag | Gets or sets the tag.
Text | Gets the text contents of the control.
TokensRangeMaxCheck | Gets or sets a value indicating whether the number of elements should be validated due to the MaxTokens.
TokensRangeMinCheck | Gets or sets a value indicating whether the number of elements should be validated due to the MinTokens.
UnitEngine | Gets or sets the unit engine.
UnitSymbol | Gets or sets the unit symbol.
UnitType | Gets or sets the type of the unit.

REXEditControlEngine Class Public Methods

REXEditControlEngine Class Public Methods
REXEditControlEngine Class Legend
Public Methods
Public Method | Description
REXEditControlEngine | Initializes a new instance of the REXEditControlEngine class.

REX.Controls.Forms Namespace Classes

REX.Controls.Forms Namespace Classes
REX.Controls.Forms Namespace Legend
Classes
Class | Description
REXComboBox | Represents a REX combo box control.
REXEditBox | Represents the REXEditBox control.
REXImageComboBox | Combo box with images.
REXImageComboBoxItem | Represents the combobox item with an image inside.
REXIndexLabel | Represents the REXIndexLabel control.
REXPictureBox | This is class REX.Controls.Forms.REXPictureBox.
REXProgressBar | Represents a REX progress bar control.
REXUnitComboBox | Represents the REXUnitComboBox control with a IREXUnitEngine.
REXUnitEditBox | Represents the REXEditBox control with a IREXUnitEngine.

Legend

Legend
REX.Controls.Forms Namespace
Legend
Class
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

Legend

Legend
REXComboBox Class
Legend
Constructor
virtual
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXComboBox Class Members

REXComboBox Class Members
REXComboBox Class Legend
Members
Public Methods
Public Method | Description
REXComboBox | Initializes a new instance of the REXComboBox class.
REXComboBox Methods
REXComboBox Methods | Description
AddEnabledChangedHandler | Adds the handler to the event raised when the element changes it's enable state.
AddLostFocusHandler | Adds the handler to the event raised when the element loses logical focus.
AddTextChangedHandler | Adds the handler to the event raised when text changes.
Editable | Gets a value indicating whether the control is editable.
GetBackground | Gets the background of the control.
GetComplexDoubleValue | Gets the complex (list) value of the double type.
GetComplexStringValue | Returns a complex string list.
GetEnable | Indicates whether the control is enabled.
GetFullName | Gets the full name.