[ToolboxBitmapAttribute(typeof(REXIndexLabel), "REXIndexLabel.Icon.bmp")]
public class REXIndexLabel : Label;
Description

It can be used to draw small letters below or above the text baseline.

Remarks

In order to draw small letters it is necessarry to place them in curly brackets: rex{lower}{^upper}. In order to draw the specified letter using Symbolic font it is necessarry to start it with @: @rex.

Namespace

REX.Controls.Forms Namespace

Public Methods
Public Method | Description
REXIndexLabel | Initializes a new instance of the REXIndexLabel class.
REXIndexLabel Methods
REXIndexLabel Methods | Description
GetTextSize | Gets the size of the text.
REXIndexLabel Properties
REXIndexLabel Properties | Description
AutoSize | Gets or sets a value indicating whether the control is automatically resized to display its entire contents.
IndexCoeff | Gets or sets the proportion between index and it's parent.
LeftAlign | Gets or sets a value indicating whether the content of the control should be aligned to the left.
Text | Gets the text contents of the control.
TextAlign | Gets or sets the alignment of text in the label.
Links
REX.Controls.Forms Namespace, Legend, Members, Public Methods, REXIndexLabel Methods, REXIndexLabel Properties

REXIndexLabel.REXIndexLabel Constructor

REXIndexLabel.REXIndexLabel Constructor
REXIndexLabel Class REX.Controls.Forms Namespace REXIndexLabel Class

Initializes a new instance of the REXIndexLabel class.

C#
public REXIndexLabel();
Description
Class

REXIndexLabel Class

Links
REXIndexLabel Class, REX.Controls.Forms Namespace, REXIndexLabel Class

REXIndexLabel.GetTextSize Method

REXIndexLabel.GetTextSize Method
REXIndexLabel Class REX.Controls.Forms Namespace REXIndexLabel Class

Gets the size of the text.

C#
public static SizeF GetTextSize(string text, Control control, Font font);
Parameters
Parameters | Description
text | The text.
control | The control where the text is placed.
font | The font.
Returns

The size of the text.

Description
Class

REXIndexLabel Class

Links
REXIndexLabel Class, REX.Controls.Forms Namespace, REXIndexLabel Class

REXIndexLabel.AutoSize Property

REXIndexLabel.AutoSize Property
REXIndexLabel Class REX.Controls.Forms Namespace REXIndexLabel Class

Gets or sets a value indicating whether the control is automatically resized to display its entire contents.

C#
[Browsable(false)]
public override bool AutoSize;
Returns

true if the control adjusts its width to closely fit its contents; otherwise, false. The default is true.

Description

Class

REXIndexLabel Class

Links
REXIndexLabel Class, REX.Controls.Forms Namespace, REXIndexLabel Class

REXIndexLabel.IndexCoeff Property

REXIndexLabel.IndexCoeff Property
REXIndexLabel Class REX.Controls.Forms Namespace REXIndexLabel Class

Gets or sets the proportion between index and it's parent.

C#
[Category("Appearance")]
[Description("describes proportion between index and it's parent")]
public double IndexCoeff;
Description

The index coefficient.

Class

REXIndexLabel Class

Links
REXIndexLabel Class, REX.Controls.Forms Namespace, REXIndexLabel Class

REXIndexLabel.LeftAlign Property

REXIndexLabel.LeftAlign Property
REXIndexLabel Class REX.Controls.Forms Namespace REXIndexLabel Class

Gets or sets a value indicating whether the content of the control should be aligned to the left.

C#
[Category("Appearance")]
[Description("describes text align (right and left available)")]
public bool LeftAlign;
Description

True if left alignment; otherwise, false.

Class

REXIndexLabel Class

Links
REXIndexLabel Class, REX.Controls.Forms Namespace, REXIndexLabel Class

REXIndexLabel.Text Property

REXIndexLabel.Text Property
REXIndexLabel Class REX.Controls.Forms Namespace REXIndexLabel Class

Gets the text contents of the control.

C#
public override string Text;
Description

The text.

Class

REXIndexLabel Class

Links
REXIndexLabel Class, REX.Controls.Forms Namespace, REXIndexLabel Class

REXIndexLabel.TextAlign Property

REXIndexLabel.TextAlign Property
REXIndexLabel Class REX.Controls.Forms Namespace REXIndexLabel Class

Gets or sets the alignment of text in the label.

C#
[Browsable(false)]
public override ContentAlignment TextAlign;
Returns

One of the T:System.Drawing.ContentAlignment values. The default is F:System.Drawing.ContentAlignment.TopLeft.

Description

Class

REXIndexLabel Class

Links
REXIndexLabel Class, REX.Controls.Forms Namespace, REXIndexLabel Class

REXPictureBox Class

REXPictureBox Class
REX.Controls.Forms Namespace Legend Members Public Methods

This is class REX.Controls.Forms.REXPictureBox.

Class Hierarchy
C#
[System.ComponentModel.ToolboxItem(false)]
public class REXPictureBox : PictureBox;
Namespace

REX.Controls.Forms Namespace

Public Methods
Public Method | Description
REXPictureBox | This is REXPictureBox, a member of class REXPictureBox.
Links
REX.Controls.Forms Namespace, Legend, Members, Public Methods

REXPictureBox.REXPictureBox Constructor

REXPictureBox.REXPictureBox Constructor
REXPictureBox Class REX.Controls.Forms Namespace REXPictureBox Class

This is REXPictureBox, a member of class REXPictureBox.

C#
public REXPictureBox();
Class

REXPictureBox Class

Links
REXPictureBox Class, REX.Controls.Forms Namespace, REXPictureBox Class

REXProgressBar Class

REXProgressBar Class
REX.Controls.Forms Namespace Legend Members Public Methods REXProgressBar Delegates REXProgressBar Events REXProgressBar Methods REXProgressBar Properties

Represents a REX progress bar control.

Class Hierarchy
C#
[System.ComponentModel.ToolboxItem(false)]
public class REXProgressBar : UserControl;
Description
Namespace

REX.Controls.Forms Namespace

Public Methods
Public Method | Description
REXProgressBar | Initializes a new instance of the REXProgressBar class.
REXProgressBar Delegates
REXProgressBar Delegates | Description
MaxChangedHandler | This is nested type REX.Controls.Forms.REXProgressBar.MaxChangedHandler.
MinChangedHandler | This is nested type REX.Controls.Forms.REXProgressBar.MinChangedHandler.
ValueChangedHandler | This is nested type REX.Controls.Forms.REXProgressBar.ValueChangedHandler.
REXProgressBar Events
REXProgressBar Events | Description
MaxChanged | This is MaxChanged, a member of class REXProgressBar.
MinChanged | This is MinChanged, a member of class REXProgressBar.
ValueChanged | This is ValueChanged, a member of class REXProgressBar.
REXProgressBar Methods
REXProgressBar Methods | Description
StepBack | Takes a step back.
StepForward | Takes a step forward.
REXProgressBar Properties
REXProgressBar Properties | Description
Animate | Gets or sets a value indicating whether animation should be run.
BackgroundColor | Gets or sets the color of the background.
EndColor | Gets or sets the end color.
GlowColor | Gets or sets the color of the glow.
HighlightColor | Gets or sets the color of the highlight.
MaxValue | Gets or sets the maximum value of the range of the control.
MinValue | Gets or sets the minimum value of the range of the control.
StartColor | Gets or sets the start color.
Step | Gets or sets the step.
Value | Gets or sets the current position of the progress bar.
Links
REX.Controls.Forms Namespace, Legend, Members, Public Methods, REXProgressBar Delegates, REXProgressBar Events, REXProgressBar Methods, REXProgressBar Properties

REXProgressBar.REXProgressBar Constructor

REXProgressBar.REXProgressBar Constructor
REXProgressBar Class REX.Controls.Forms Namespace REXProgressBar Class

Initializes a new instance of the REXProgressBar class.

C#
public REXProgressBar();
Description
Class

REXProgressBar Class

Links
REXProgressBar Class, REX.Controls.Forms Namespace, REXProgressBar Class

REXProgressBar.StepBack Method

REXProgressBar.StepBack Method
REXProgressBar Class REX.Controls.Forms Namespace REXProgressBar Class

Takes a step back.

C#
public void StepBack();
Description
Class

REXProgressBar Class

Links
REXProgressBar Class, REX.Controls.Forms Namespace, REXProgressBar Class