REXSectionParamDimensions Class REX.ContentGenerator.Families Namespace REXSectionParamDimensions Class

Gets or sets the P3_T.

C#
public double P3_T;
Description

The P3_T.

Class

REXSectionParamDimensions Class

Links
REXSectionParamDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionParamDimensions Class

REXSectionParamDimensions.P4_L Property

REXSectionParamDimensions.P4_L Property
REXSectionParamDimensions Class REX.ContentGenerator.Families Namespace REXSectionParamDimensions Class

Gets or sets the P4_L.

C#
public double P4_L;
Description

The P4_L.

Class

REXSectionParamDimensions Class

Links
REXSectionParamDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionParamDimensions Class

REXSectionParamDimensions.P4_T Property

REXSectionParamDimensions.P4_T Property
REXSectionParamDimensions Class REX.ContentGenerator.Families Namespace REXSectionParamDimensions Class

Gets or sets the P4_T.

C#
public double P4_T;
Description

The P4_T.

Class

REXSectionParamDimensions Class

Links
REXSectionParamDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionParamDimensions Class

REXSectionParamDimensions.t Property

REXSectionParamDimensions.t Property
REXSectionParamDimensions Class REX.ContentGenerator.Families Namespace REXSectionParamDimensions Class

Gets or sets the t.

C#
public double t;
Description

The t.

Class

REXSectionParamDimensions Class

Links
REXSectionParamDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionParamDimensions Class

REXSectionParamDimensions.tf Property

REXSectionParamDimensions.tf Property
REXSectionParamDimensions Class REX.ContentGenerator.Families Namespace REXSectionParamDimensions Class

Gets or sets the tf.

C#
public double tf;
Description

The tf.

Class

REXSectionParamDimensions Class

Links
REXSectionParamDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionParamDimensions Class

REXSectionParamDimensions.tf1 Property

REXSectionParamDimensions.tf1 Property
REXSectionParamDimensions Class REX.ContentGenerator.Families Namespace REXSectionParamDimensions Class

Gets or sets the tf1.

C#
public double tf1;
Description

The tf1.

Class

REXSectionParamDimensions Class

Links
REXSectionParamDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionParamDimensions Class

REXSectionParamDimensions.tf2 Property

REXSectionParamDimensions.tf2 Property
REXSectionParamDimensions Class REX.ContentGenerator.Families Namespace REXSectionParamDimensions Class

Gets or sets the tf2.

C#
public double tf2;
Description

The tf2.

Class

REXSectionParamDimensions Class

Links
REXSectionParamDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionParamDimensions Class

REXSectionParamDimensions.tw Property

REXSectionParamDimensions.tw Property
REXSectionParamDimensions Class REX.ContentGenerator.Families Namespace REXSectionParamDimensions Class

Gets or sets the tw.

C#
public double tw;
Description

The tw.

Class

REXSectionParamDimensions Class

Links
REXSectionParamDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionParamDimensions Class

REXSectionParamDimensions.vpy Property

REXSectionParamDimensions.vpy Property
REXSectionParamDimensions Class REX.ContentGenerator.Families Namespace REXSectionParamDimensions Class

Gets or sets the vpy.

C#
public double vpy;
Description

The vpy.

Class

REXSectionParamDimensions Class

Links
REXSectionParamDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionParamDimensions Class

REXSectionParamDimensions.vpz Property

REXSectionParamDimensions.vpz Property
REXSectionParamDimensions Class REX.ContentGenerator.Families Namespace REXSectionParamDimensions Class

Gets or sets the vpz.

C#
public double vpz;
Description

The vpz.

Class

REXSectionParamDimensions Class

Links
REXSectionParamDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionParamDimensions Class

REXSectionParamDimensions.vy Property

REXSectionParamDimensions.vy Property
REXSectionParamDimensions Class REX.ContentGenerator.Families Namespace REXSectionParamDimensions Class

Gets or sets the vy.

C#
public double vy;
Description

The vy.

Class

REXSectionParamDimensions Class

Links
REXSectionParamDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionParamDimensions Class

REXSectionParamDimensions.vz Property

REXSectionParamDimensions.vz Property
REXSectionParamDimensions Class REX.ContentGenerator.Families Namespace REXSectionParamDimensions Class

Gets or sets the vz.

C#
public double vz;
Description

The vz.

Class

REXSectionParamDimensions Class

Links
REXSectionParamDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionParamDimensions Class

SerializableObject Class

SerializableObject Class
REX.ContentGenerator.Families Namespace Legend Members Public Methods SerializableObject Methods

Allows to save an object into a stream.

Class Hierarchy
C#
[Serializable()]
public abstract class SerializableObject : ISerializable;
Description
Namespace

REX.ContentGenerator.Families Namespace

Public Methods
Public Method | Description
SerializableObject | Initializes a new instance of the SerializableObject class.
SerializableObject Methods
SerializableObject Methods | Description
GetObjectData | Serializes the instance to the Serialization object.
Load | Loads object from the stream.
Save | Saves the object to the stream.
Links
REX.ContentGenerator.Families Namespace, Legend, Members, Public Methods, SerializableObject Methods

SerializableObject.SerializableObject Constructor

SerializableObject.SerializableObject Constructor
SerializableObject Class REX.ContentGenerator.Families Namespace SerializableObject Class

Initializes a new instance of the SerializableObject class.

C#
public SerializableObject();
Description
Class

SerializableObject Class

Links
SerializableObject Class, REX.ContentGenerator.Families Namespace, SerializableObject Class

SerializableObject.GetObjectData Method

SerializableObject.GetObjectData Method
SerializableObject Class REX.ContentGenerator.Families Namespace SerializableObject Class

Serializes the instance to the Serialization object.

C#
public void GetObjectData(SerializationInfo info, StreamingContext context);
Parameters
Parameters | Description
info | Serialization data.
context | The context.
Description
Class

SerializableObject Class

Links
SerializableObject Class, REX.ContentGenerator.Families Namespace, SerializableObject Class

SerializableObject.Load Method

SerializableObject.Load Method
SerializableObject Class REX.ContentGenerator.Families Namespace SerializableObject Class

Loads object from the stream.

C#
public virtual void Load(SerializationInfo info, StreamingContext context);
Parameters
Parameters | Description
info | Serialization data.
context | The context.
Description
Class

SerializableObject Class

Links
SerializableObject Class, REX.ContentGenerator.Families Namespace, SerializableObject Class

SerializableObject.Save Method

SerializableObject.Save Method
SerializableObject Class REX.ContentGenerator.Families Namespace SerializableObject Class

Saves the object to the stream.

C#
public virtual void Save(SerializationInfo info, StreamingContext context);
Parameters
Parameters | Description
info | Serialization data.
context | The context.
Description
Class

SerializableObject Class

Links
SerializableObject Class, REX.ContentGenerator.Families Namespace, SerializableObject Class

REX.ContentGenerator.Families.ECategoryType Enumeration

REX.ContentGenerator.Families.ECategoryType Enumeration
REX.ContentGenerator.Families Namespace

Describes the category of the element

C#
public enum ECategoryType {
  UNKNOWN = 0,
  SECTION_PARAM = 1,
  SECTION_DB = 2,
  MATERIAL = 3,
  REBAR_SHAPE = 4,
  REBAR_BARTYPE = 5,
  REBAR_HOOK = 6,
  BOLT = 7,
  BOLT_CLASS = 8,
  CUSTOM = 9
}
Members
Members | Description
UNKNOWN | The unknown.