WPFCommon Methods
WPFCommon Methods | Description
FindChild | Finds the child.
SetPropertyToAllElements | This is SetPropertyToAllElements, a member of class WPFCommon.
UpdateDoubleObserveCollection | This is UpdateDoubleObserveCollection, a member of class WPFCommon.

WPFCommon Methods

WPFCommon Methods
WPFCommon Class Legend
WPFCommon Methods
WPFCommon Methods | Description
FindChild | Finds the child.
SetPropertyToAllElements | This is SetPropertyToAllElements, a member of class WPFCommon.
UpdateDoubleObserveCollection | This is UpdateDoubleObserveCollection, a member of class WPFCommon.

ROHTML Namespace Classes

ROHTML Namespace Classes
ROHTML Namespace Legend
Classes
Class | Description
ROHTMLMessages | This is class ROHTML.ROHTMLMessages.
ROHTMLStdImages | This is class ROHTML.ROHTMLStdImages.
ROHTMLTableFormats | This is class ROHTML.ROHTMLTableFormats.
XHTMLDocument | This is class ROHTML.XHTMLDocument.
XHTMLElement | This is class ROHTML.XHTMLElement.
XHTMLTable | This is class ROHTML.XHTMLTable.

Legend

Legend
ROHTML Namespace
Legend
Class
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

ROHTMLMessages Fields

ROHTMLMessages Fields
ROHTMLMessages Class Legend
ROHTMLMessages Fields
ROHTMLMessages Fields | Description
ROTF_MSG_ERROR | Error
ROTF_MSG_OK | Verified

Legend

Legend
ROHTMLMessages Class
Legend
Data Member
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

ROHTMLMessages Class Members

ROHTMLMessages Class Members
ROHTMLMessages Class Legend
Members
ROHTMLMessages Fields
ROHTMLMessages Fields | Description
ROTF_MSG_ERROR | Error
ROTF_MSG_OK | Verified

ROHTMLStdImages Fields

ROHTMLStdImages Fields
ROHTMLStdImages Class Legend
ROHTMLStdImages Fields
ROHTMLStdImages Fields | Description
ROSTD_TABLET_ERR | Image error
ROSTD_TABLET_OK | Image verified

Legend

Legend
ROHTMLStdImages Class
Legend
Data Member
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

ROHTMLStdImages Class Members

ROHTMLStdImages Class Members
ROHTMLStdImages Class Legend
Members
ROHTMLStdImages Fields
ROHTMLStdImages Fields | Description
ROSTD_TABLET_ERR | Image error
ROSTD_TABLET_OK | Image verified

ROHTMLTableFormats Fields

ROHTMLTableFormats Fields
ROHTMLTableFormats Class Legend
ROHTMLTableFormats Fields
ROHTMLTableFormats Fields | Description
ROTF_LIST_1 | Columns:2, Style:list1
ROTF_LIST_2 | Columns:5, Width:100%, Style:list2 Column[1]:Width:8%, nowrap Column[2]:Width:8%, nowrap, Style:font-family:monospace;text-align:right; Column[3]:Width:10%, Style:text-align:center; Column[4]:Width:40% Column[5]:Style=text-align:right;
ROTF_LIST_3 | Columns:2, Width:100%, Style:list3 Column[2].style=text-align:right;
ROTF_LIST_4 | Columns:2, Style:list4 Column[1]:nowrap
ROTF_TABLE_1 | Width:100%, Style:table1, Header rows and columns:1
ROTF_TABLE_2 | Width:100%, Style:table2, Header rows and columns:1
ROTF_TABLE_3 | Width:100%, Style:table3, Header rows and columns:1
ROTF_VERIFY_1 | Columns:4, Width:100% Column[1]:Width:40%, nowrap, Column[2]:Width:25%, nowrap Column[3]:nowrap Column[4]:Width:25%, Style:text-align:right

Legend

Legend
ROHTMLTableFormats Class
Legend
Data Member
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

ROHTMLTableFormats Class Members

ROHTMLTableFormats Class Members
ROHTMLTableFormats Class Legend
Members
ROHTMLTableFormats Fields
ROHTMLTableFormats Fields | Description
ROTF_LIST_1 | Columns:2, Style:list1
ROTF_LIST_2 | Columns:5, Width:100%, Style:list2 Column[1]:Width:8%, nowrap Column[2]:Width:8%, nowrap, Style:font-family:monospace;text-align:right; Column[3]:Width:10%, Style:text-align:center; Column[4]:Width:40% Column[5]:Style=text-align:right;
ROTF_LIST_3 | Columns:2, Width:100%, Style:list3 Column[2].style=text-align:right;
ROTF_LIST_4 | Columns:2, Style:list4 Column[1]:nowrap
ROTF_TABLE_1 | Width:100%, Style:table1, Header rows and columns:1
ROTF_TABLE_2 | Width:100%, Style:table2, Header rows and columns:1
ROTF_TABLE_3 | Width:100%, Style:table3, Header rows and columns:1
ROTF_VERIFY_1 | Columns:4, Width:100% Column[1]:Width:40%, nowrap, Column[2]:Width:25%, nowrap Column[3]:nowrap Column[4]:Width:25%, Style:text-align:right

XHTMLDocument Fields

XHTMLDocument Fields
XHTMLDocument Class Legend
XHTMLDocument Fields
XHTMLDocument Fields | Description
Body | XHTMLElement that represents the body of the document.
CSSFile | String containing the CSS (Cascading Style Sheets) file path for the document.
Head | XHTMLElement that represents the header of the document.
Language | Short that indicates the language in which the document is written.
Name |
NumberedHeaders | Bool that indicates whether headers are numbered automatically by the document, e.g.
Status | ROHTMLMessages indicates the status of the document, it is used in note header and footer.
Version | String (read-only) that indicates the version of the component, e.g.

Legend

Legend
XHTMLDocument Class
Legend
Data Member
Method
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

XHTMLDocument Class Members

XHTMLDocument Class Members
XHTMLDocument Class Legend
Members
XHTMLDocument Fields
XHTMLDocument Fields | Description
Body | XHTMLElement that represents the body of the document.
CSSFile | String containing the CSS (Cascading Style Sheets) file path for the document.
Head | XHTMLElement that represents the header of the document.
Language | Short that indicates the language in which the document is written.
Name |
NumberedHeaders | Bool that indicates whether headers are numbered automatically by the document, e.g.
Status | ROHTMLMessages indicates the status of the document, it is used in note header and footer.
Version | String (read-only) that indicates the version of the component, e.g.
XHTMLDocument Methods
XHTMLDocument Methods | Description
IsVersion | Returns True if the version of the component is greater or equal to the given version, version should be formatted as follow: "MAJOR.MINOR.PATCH.COMPILATION", e.g.
Save | Saves the XHTML document to the specified location.
SaveAsSingleFile | Saves the document to the specified location as MS MHTML file.
Show | Launches Internet Explorer and navigates to the specified file.
ToString | Returns String containing the generated document.

XHTMLDocument Methods

XHTMLDocument Methods
XHTMLDocument Class Legend
XHTMLDocument Methods
XHTMLDocument Methods | Description
IsVersion | Returns True if the version of the component is greater or equal to the given version, version should be formatted as follow: "MAJOR.MINOR.PATCH.COMPILATION", e.g.
Save | Saves the XHTML document to the specified location.
SaveAsSingleFile | Saves the document to the specified location as MS MHTML file.
Show | Launches Internet Explorer and navigates to the specified file.
ToString | Returns String containing the generated document.

XHTMLElement Fields

XHTMLElement Fields
XHTMLElement Class Legend
XHTMLElement Fields
XHTMLElement Fields | Description
TagName | String containing the tag name of the element (may be empty).

Legend

Legend
XHTMLElement Class
Legend
Data Member
Method