It should be obligatory called before the end of the converter usage.

Class

RVTFamilyConverter Class

Links
RVTFamilyConverter Class, REX.ContentGenerator.Converters Namespace, RVTFamilyConverter Class

RVTFamilyConverter.CreateRebar Method

RVTFamilyConverter.CreateRebar Method
RVTFamilyConverter Class REX.ContentGenerator.Converters Namespace Example RVTFamilyConverter Class

Creates the rebar element based on the input REXFamilyType_Rebar object.

C#
public Rebar CreateRebar(REXFamilyType_Rebar rebar, RevitElement host);
Parameters
Parameters | Description
rebar | The REXFamilyType_Rebar object.
host | The host of a rebar.
Returns

The new Revit rebar.

Description
Example

The example shows how to get the rebar element in Revit based on specific shape from the database.

//Initializing converters.
REXFamilyConverter rex = new REXFamilyConverter();//Needed for proper rebar description.
RVTFamilyConverter rvt = new RVTFamilyConverter(commandData, true);

//The RebarType taken from the Revit project (the first one on the list).
System.Collections.IEnumerator it = commandData.Application.ActiveUIDocument.Document.RebarBarTypes.GetEnumerator();
it.MoveNext();
RebarBarType RevitRebarBarType = (RebarBarType)it.Current;
REXFamilyType_RebarBarType rbt = (REXFamilyType_RebarBarType)rvt.GetFamily(RevitRebarBarType);
//Using Element property to use particular element as RebarType.
rbt.Element=RevitRebarBarType;

//The RebarHook taken from the Revit project (the first one on the list).
it = commandData.Application.ActiveUIDocument.Document.RebarHookTypes.GetEnumerator();
it.MoveNext();
RebarHookType RevitRebarHookType = (RebarHookType)it.Current;
REXFamilyType_RebarHook rht = (REXFamilyType_RebarHook)rvt.GetFamily(RevitRebarHookType);
//Using Element property to use particular element as RebarType.
rht.Element = RevitRebarHookType;

//defining contour
List<REX.Common.Geometry.REXxyz> l = new List<REX.Common.Geometry.REXxyz>();

l.Add(new REX.Common.Geometry.REXxyz(0, 0));
l.Add(new REX.Common.Geometry.REXxyz(2, 0));

//Getting the rebar object.
REXFamilyType_Rebar r = rex.GetRebar(l, rbt,false,rht,rht,"barlib7_iso");

//Creating the rebar in Revit.
it = commandData.Application.ActiveUIDocument.Selection.Elements.GetEnumerator();
it.MoveNext();
Element host = (Element)it.Current;
Rebar RevitRebar = rvt.CreateRebar(r, host);

rvt.Close();//!!To clear structures and save data to the project.
Class

RVTFamilyConverter Class

Links
RVTFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, RVTFamilyConverter Class

RVTFamilyConverter.GetCertifiedCategoryOfElement Method

RVTFamilyConverter.GetCertifiedCategoryOfElement Method
RVTFamilyConverter Class REX.ContentGenerator.Converters Namespace Example RVTFamilyConverter Class

Gets category of the certified element.

C#
public ECategoryType GetCertifiedCategoryOfElement(RevitElement el);
Parameters
Parameters | Description
el | The Revit element.
Returns

The category of the element.

Description

If the element is not certified the UNKNOWN result will be returned.

Example

The example shows how to learn if some specific element is certified and get the category of it.

//Initializing the converter.
RVTFamilyConverter rvt = new RVTFamilyConverter(commandData, true);

//Iteration threw all rebars selected in Revit.
FilteredElementCollector filterCollector = new FilteredElementCollector(commandData.Application.ActiveUIDocument.Document);
foreach (Element el in filterCollector.WhereElementIsElementType())
{
    ECategoryType category = rvt.GetCertifiedCategoryOfElement(el);

    REXFamilyType familyType = null;

    if (category != ECategoryType.UNKNOWN)//certified
    {
           familyType = rvt.GetFamily(el, category);
    }
    else//not certified
    {
        if (el is RebarHookType)
        {
            familyType = rvt.GetFamily(el, ECategoryType.REBAR_HOOK);
        }
        else if(el is RebarBarType)
        {
            familyType = rvt.GetFamily(el, ECategoryType.REBAR_BARTYPE);
        }
        else if (el is RebarShape)
        {
            familyType = rvt.GetFamily(el, ECategoryType.REBAR_SHAPE);
        }
        else if (el is FamilyInstance)
       {
            familyType = rvt.GetFamily(el, ECategoryType.SECTION_PARAM);
        }
    }
}
Class

RVTFamilyConverter Class

Links
RVTFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, RVTFamilyConverter Class

RVTFamilyConverter.GetElement Method (REXFamilyType)

RVTFamilyConverter.GetElement Method (REXFamilyType)
RVTFamilyConverter Class REX.ContentGenerator.Converters Namespace Example RVTFamilyConverter Class

Gets the Revit element created based on the REXFamilyType object.

C#
public RevitElement GetElement(REXFamilyType el);
Parameters
Parameters | Description
el | The REXFamilyType object.
Returns

The Revit element.

Description
Example

The example shows how to get Revit element bases on the REXFamilyType object.

//Initialize the converter.
RVTFamilyConverter rvt = new RVTFamilyConverter(commandData, true);

//creating parametric description
REXFamilyType_ParamSection paramSection = new REXFamilyType_ParamSection();
paramSection.ElementType = REX.ContentGenerator.Families.EElementType.BEAM;
paramSection.Material = EMaterial.CONCRETE;

//seting parameters
paramSection.Parameters.SectionType = ESectionType.RECT;
paramSection.Parameters.Tapered = false;
//setting dimensions
paramSection.Parameters.Dimensions.h = 0.3;
paramSection.Parameters.Dimensions.b = 0.2;
paramSection.Parameters.CalculataMainAxisAndCharacteristics();
paramSection.TypeName = "RECT1";

//getting Revit element
Element el = rvt.GetElement(paramSection);
FamilySymbol fs = el as FamilySymbol;
Class

RVTFamilyConverter Class

Links
RVTFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, RVTFamilyConverter Class

RVTFamilyConverter.GetElement Method (REXFamilyType, ECategoryType)

RVTFamilyConverter.GetElement Method (REXFamilyType, ECategoryType)
RVTFamilyConverter Class REX.ContentGenerator.Converters Namespace Example RVTFamilyConverter Class

Gets the Revit element created based on the REXFamilyType object.

C#
public RevitElement GetElement(REXFamilyType el, ECategoryType category);
Parameters
Parameters | Description
el | The REXFamilyType object.
category | The category of the element.
Returns

The Revit element.

Description
Example

The example shows how to get Revit element bases on the REXFamilyType object.

//Initialize the converter.
RVTFamilyConverter rvt = new RVTFamilyConverter(commandData, true);

//creating parametric description
REXFamilyType_ParamSection paramSection = new REXFamilyType_ParamSection();
paramSection.ElementType = REX.ContentGenerator.Families.EElementType.BEAM;
paramSection.Material = EMaterial.CONCRETE;

//seting parameters
paramSection.Parameters.SectionType = ESectionType.RECT;
paramSection.Parameters.Tapered = false;
//setting dimensions
paramSection.Parameters.Dimensions.h = 0.3;
paramSection.Parameters.Dimensions.b = 0.2;
paramSection.Parameters.CalculataMainAxisAndCharacteristics();
paramSection.TypeName = "RECT1";

//getting Revit element
Element el = rvt.GetElement(paramSection, ECategoryType.SECTION_PARAM);
FamilySymbol fs = el as FamilySymbol;
Class

RVTFamilyConverter Class

Links
RVTFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, RVTFamilyConverter Class

RVTFamilyConverter.GetElement Method (REXFamilyType_Custom, string)

RVTFamilyConverter.GetElement Method (REXFamilyType_Custom, string)
RVTFamilyConverter Class REX.ContentGenerator.Converters Namespace RVTFamilyConverter Class

Gets the Revit element created based on the REXFamilyType object.

C#
public RevitElement GetElement(REXFamilyType_Custom el, string customCategory);
Parameters
Parameters | Description
el | The REXFamilyType object.
customCategory | The custom category.
Returns

The Revit element.

Description
Class

RVTFamilyConverter Class

Links