SetBackground | Sets the background of the control.
SetText | Sets the text contents of the control.
Links
REX.Controls.Common Namespace, Legend, Members, IEditControl Methods

IEditControl.GetBackground Method

IEditControl.GetBackground Method
IEditControl Interface REX.Controls.Common Namespace IEditControl Interface

Gets the background of the control.

C#
object GetBackground();
Returns

The background.

Description
Interface

IEditControl Interface

Links
IEditControl Interface, REX.Controls.Common Namespace, IEditControl Interface

IEditControl.GetEnable Method

IEditControl.GetEnable Method
IEditControl Interface REX.Controls.Common Namespace IEditControl Interface

Indicates whether the control is enabled.

C#
bool GetEnable();
Returns

True if the element is enabled; otherwise, false.

Description
Interface

IEditControl Interface

Links
IEditControl Interface, REX.Controls.Common Namespace, IEditControl Interface

IEditControl.GetText Method

IEditControl.GetText Method
IEditControl Interface REX.Controls.Common Namespace IEditControl Interface

Gets the text contents of the control.

C#
string GetText();
Returns

The text contents of the control.

Description
Interface

IEditControl Interface

Links
IEditControl Interface, REX.Controls.Common Namespace, IEditControl Interface

IEditControl.SetBackground Method

IEditControl.SetBackground Method
IEditControl Interface REX.Controls.Common Namespace IEditControl Interface

Sets the background of the control.

C#
void SetBackground(object background);
Parameters
Parameters | Description
background | The background.
Description
Interface

IEditControl Interface

Links
IEditControl Interface, REX.Controls.Common Namespace, IEditControl Interface

IEditControl.SetText Method

IEditControl.SetText Method
IEditControl Interface REX.Controls.Common Namespace IEditControl Interface

Sets the text contents of the control.

C#
void SetText(string txt);
Parameters
Parameters | Description
txt | The text.
Description
Interface

IEditControl Interface

Links
IEditControl Interface, REX.Controls.Common Namespace, IEditControl Interface

IUnitObject Interface

IUnitObject Interface
REX.Controls.Common Namespace Legend Members IUnitObject Methods IUnitObject Properties

Defines common functionality for controls that are unit dependent.

Class Hierarchy
C#
public interface IUnitObject;
Description
Namespace

REX.Controls.Common Namespace

IUnitObject Methods
IUnitObject Methods | Description
AddEnabledChangedHandler | Adds the handler to the event raised when the element changes it's enable state.
AddLostFocusHandler | Adds the handler to the event raised when the element loses logical focus.
AddTextChangedHandler | Adds the handler to the event raised when text changes.
GetComplexDoubleValue | Gets the complex (list) value of the double type.
GetComplexStringValue | Gets the complex (list) string value of the string type.
GetFullName | Gets the full name of the control.
GetState | Gets the current state of the control.
GetUniqueName | Gets the unique name of the control.
GetValue | Gets the value of the double type.
Reset | Resets the instance of the element.
SetComplexValue | Sets the complex (list) value of the double type.
SetComplexValue | Sets the complex (list) value of the string type.
SetExternalUnitBody | This is SetExternalUnitBody, a member of class IUnitObject.
SetUserValidation | Sets the user validation method.
SetUserValidationComplex | Sets the user validation method for complex values (list).
SetValue | Sets the value of the double type.
SetValue | Sets the value of the string type.
IUnitObject Properties
IUnitObject Properties | Description
Complex | Gets or sets a value indicating whether this the control is in the complex mode (list mode).
ControlState | Gets the state of the control.
DataType | Gets or sets the type of the data in the control.
EngineeringFormat | Gets or sets a value indicating whether the text of the control should be formatted in according to the engineering (expotential) format.
RangeMax | Gets or sets the highest possible value.
RangeMaxCheck | Gets or sets a value indicating whether the value should be validated due to the RangeMax.
RangeMin | Gets or sets the minimum possible value.
RangeMinCheck | Gets or sets a value indicating whether the value should be validated due to the RangeMin.
RoundingFractional | Gets or sets the rounding for fractional units.
RoundingIncrement | Gets or sets the rounding increment.
Separator | Gets or sets the decimal separator.
Tag | Gets or sets the tag.
Text | Gets the text contents of the control.
UnitSymbol | Gets or sets the unit symbol.
Links
REX.Controls.Common Namespace, Legend, Members, IUnitObject Methods, IUnitObject Properties

IUnitObject.AddEnabledChangedHandler Method

IUnitObject.AddEnabledChangedHandler Method
IUnitObject Interface REX.Controls.Common Namespace IUnitObject Interface

Adds the handler to the event raised when the element changes it's enable state.

C#
void AddEnabledChangedHandler(System.EventHandler eh);
Parameters
Parameters | Description
eh | The event handler.
Description
Interface

IUnitObject Interface

Links
IUnitObject Interface, REX.Controls.Common Namespace, IUnitObject Interface

IUnitObject.AddLostFocusHandler Method

IUnitObject.AddLostFocusHandler Method
IUnitObject Interface REX.Controls.Common Namespace IUnitObject Interface

Adds the handler to the event raised when the element loses logical focus.

C#
void AddLostFocusHandler(System.EventHandler eh);
Parameters
Parameters | Description
eh | The event handler.
Description
Interface

IUnitObject Interface

Links
IUnitObject Interface, REX.Controls.Common Namespace, IUnitObject Interface

IUnitObject.AddTextChangedHandler Method

IUnitObject.AddTextChangedHandler Method
IUnitObject Interface REX.Controls.Common Namespace IUnitObject Interface

Adds the handler to the event raised when text changes.

C#
void AddTextChangedHandler(System.EventHandler eh);
Parameters
Parameters | Description
eh | The event handler.
Description
Interface

IUnitObject Interface

Links
IUnitObject Interface, REX.Controls.Common Namespace, IUnitObject Interface

IUnitObject.GetComplexDoubleValue Method

IUnitObject.GetComplexDoubleValue Method
IUnitObject Interface REX.Controls.Common Namespace IUnitObject Interface

Gets the complex (list) value of the double type.

C#
List<double> GetComplexDoubleValue();
Returns

The list of values.

Description
Interface

IUnitObject Interface

Links
IUnitObject Interface, REX.Controls.Common Namespace, IUnitObject Interface

IUnitObject.GetComplexStringValue Method

IUnitObject.GetComplexStringValue Method
IUnitObject Interface REX.Controls.Common Namespace IUnitObject Interface

Gets the complex (list) string value of the string type.

C#
List<string> GetComplexStringValue();
Returns

The list of values.

Description
Interface

IUnitObject Interface

Links
IUnitObject Interface, REX.Controls.Common Namespace, IUnitObject Interface

IUnitObject.GetFullName Method

IUnitObject.GetFullName Method
IUnitObject Interface REX.Controls.Common Namespace IUnitObject Interface

Gets the full name of the control.

C#
string GetFullName();
Returns

The full name of the control.

Description
Interface

IUnitObject Interface

Links
IUnitObject Interface, REX.Controls.Common Namespace, IUnitObject Interface

IUnitObject.GetState Method

IUnitObject.GetState Method
IUnitObject Interface REX.Controls.Common Namespace IUnitObject Interface

Gets the current state of the control.

C#
EControlState GetState();
Returns

The state of the control.

Description
Interface

IUnitObject Interface

Links
IUnitObject Interface, REX.Controls.Common Namespace, IUnitObject Interface

IUnitObject.GetUniqueName Method

IUnitObject.GetUniqueName Method
IUnitObject Interface REX.Controls.Common Namespace IUnitObject Interface

Gets the unique name of the control.

C#
string GetUniqueName();
Returns

The unique name.

Description
Interface