This is GetFamilyDefault, a member of class REXMaterialFactory.

C#
public override REXFamilyType GetFamilyDefault(REX.ContentGenerator.Families.EElementType el, EMaterial mat, string type);
Class

REXMaterialFactory Class

Links
REXMaterialFactory Class, REX.ContentGenerator.Converters Namespace, REXMaterialFactory Class

REXMaterialFactory.GetFamilyOfAlias Method

REXMaterialFactory.GetFamilyOfAlias Method
REXMaterialFactory Class REX.ContentGenerator.Converters Namespace REXMaterialFactory Class

This is GetFamilyOfAlias, a member of class REXMaterialFactory.

C#
public override REXFamilyType GetFamilyOfAlias(REX.ContentGenerator.Families.EElementType el, string alias, out bool found);
Class

REXMaterialFactory Class

Links
REXMaterialFactory Class, REX.ContentGenerator.Converters Namespace, REXMaterialFactory Class

REXMaterialFactory.GetFamilyTemplate Method

REXMaterialFactory.GetFamilyTemplate Method
REXMaterialFactory Class REX.ContentGenerator.Converters Namespace REXMaterialFactory Class

This is GetFamilyTemplate, a member of class REXMaterialFactory.

C#
public override REXFamilyType GetFamilyTemplate(REX.ContentGenerator.Families.EElementType el, EMaterial mat);
Class

REXMaterialFactory Class

Links
REXMaterialFactory Class, REX.ContentGenerator.Converters Namespace, REXMaterialFactory Class

REXMaterialFactory.GetMaterial Method

REXMaterialFactory.GetMaterial Method
REXMaterialFactory Class REX.ContentGenerator.Converters Namespace REXMaterialFactory Class

This is GetMaterial, a member of class REXMaterialFactory.

C#
public EMaterial GetMaterial(int i);
Class

REXMaterialFactory Class

Links
REXMaterialFactory Class, REX.ContentGenerator.Converters Namespace, REXMaterialFactory Class

REXMaterialFactory.GetNewDescription Method ()

REXMaterialFactory.GetNewDescription Method ()
REXMaterialFactory Class REX.ContentGenerator.Converters Namespace REXMaterialFactory Class

This is GetNewDescription, a member of class REXMaterialFactory.

C#
public override REXDBDescription GetNewDescription();
Class

REXMaterialFactory Class

Links
REXMaterialFactory Class, REX.ContentGenerator.Converters Namespace, REXMaterialFactory Class

REXMaterialFactory.GetNewDescription Method (string, string, DTableDataObjectCollection)

REXMaterialFactory.GetNewDescription Method (string, string, DTableDataObjectCollection)
REXMaterialFactory Class REX.ContentGenerator.Converters Namespace REXMaterialFactory Class

This is GetNewDescription, a member of class REXMaterialFactory.

C#
public override REXDBDescription GetNewDescription(string dir, string dbName, DTableDataObjectCollection objCol);
Class

REXMaterialFactory Class

Links
REXMaterialFactory Class, REX.ContentGenerator.Converters Namespace, REXMaterialFactory Class

REXMaterialFactory.GetNewFamily Method

REXMaterialFactory.GetNewFamily Method
REXMaterialFactory Class REX.ContentGenerator.Converters Namespace REXMaterialFactory Class

This is GetNewFamily, a member of class REXMaterialFactory.

C#
public override REXFamilyType GetNewFamily();
Class

REXMaterialFactory Class

Links
REXMaterialFactory Class, REX.ContentGenerator.Converters Namespace, REXMaterialFactory Class

REXMaterialFactory.GetPropertiesADO Method

REXMaterialFactory.GetPropertiesADO Method
REXMaterialFactory Class REX.ContentGenerator.Converters Namespace REXMaterialFactory Class

This is GetPropertiesADO, a member of class REXMaterialFactory.

C#
public override REXDBParams GetPropertiesADO(string dbpath, string dbname);
Class

REXMaterialFactory Class

Links
REXMaterialFactory Class, REX.ContentGenerator.Converters Namespace, REXMaterialFactory Class

REXMaterialFactory.GetPropertiesDBRoot Method

REXMaterialFactory.GetPropertiesDBRoot Method
REXMaterialFactory Class REX.ContentGenerator.Converters Namespace REXMaterialFactory Class

This is GetPropertiesDBRoot, a member of class REXMaterialFactory.

C#
public override REXDBParams GetPropertiesDBRoot(string dbpath, string dbname);
Class

REXMaterialFactory Class

Links
REXMaterialFactory Class, REX.ContentGenerator.Converters Namespace, REXMaterialFactory Class

REXMaterialFactory.RecalculatDBDesc Method

REXMaterialFactory.RecalculatDBDesc Method
REXMaterialFactory Class REX.ContentGenerator.Converters Namespace REXMaterialFactory Class

This is RecalculatDBDesc, a member of class REXMaterialFactory.

C#
public override void RecalculatDBDesc(REXDBDescription db, string DBPath, string DBName, bool fromInterface);
Class

REXMaterialFactory Class

Links
REXMaterialFactory Class, REX.ContentGenerator.Converters Namespace, REXMaterialFactory Class

REXMaterialFactory.ValidateDB Method (IDbRootLib.IDbDatabase)

REXMaterialFactory.ValidateDB Method (IDbRootLib.IDbDatabase)
REXMaterialFactory Class REX.ContentGenerator.Converters Namespace REXMaterialFactory Class

This is ValidateDB, a member of class REXMaterialFactory.

C#
public override bool ValidateDB(IDbRootLib.IDbDatabase db);
Class

REXMaterialFactory Class

Links
REXMaterialFactory Class, REX.ContentGenerator.Converters Namespace, REXMaterialFactory Class

REXMaterialFactory.ValidateDB Method (string)

REXMaterialFactory.ValidateDB Method (string)
REXMaterialFactory Class REX.ContentGenerator.Converters Namespace REXMaterialFactory Class

This is ValidateDB, a member of class REXMaterialFactory.

C#
public override bool ValidateDB(string dbName);
Class

REXMaterialFactory Class

Links
REXMaterialFactory Class, REX.ContentGenerator.Converters Namespace, REXMaterialFactory Class

REXParamSectionFactory Class

REXParamSectionFactory Class
REX.ContentGenerator.Converters Namespace Legend Members Public Methods REXParamSectionFactory Methods

This is class REX.ContentGenerator.Converters.REXParamSectionFactory.

Class Hierarchy
C#
public class REXParamSectionFactory : REXFamilyFactory;
Namespace

REX.ContentGenerator.Converters Namespace

Public Methods
Public Method | Description
REXParamSectionFactory | This is REXParamSectionFactory, a member of class REXParamSectionFactory.
REXParamSectionFactory Methods
REXParamSectionFactory Methods | Description
Close | This is Close, a member of class REXParamSectionFactory.
GetAliasName | This is GetAliasName, a member of class REXParamSectionFactory.
GetAllFamilies | This is GetAllFamilies, a member of class REXParamSectionFactory.
GetDBList | This is GetDBList, a member of class REXParamSectionFactory.
GetDBList | This is GetDBList, a member of class REXParamSectionFactory.
GetFamiliesOfAlias | This is GetFamiliesOfAlias, a member of class REXParamSectionFactory.
GetFamily | This is GetFamily, a member of class REXParamSectionFactory.
GetFamilyDefault | This is GetFamilyDefault, a member of class REXParamSectionFactory.
GetFamilyOfAlias | This is GetFamilyOfAlias, a member of class REXParamSectionFactory.
GetFamilyTemplate | This is GetFamilyTemplate, a member of class REXParamSectionFactory.
Links
REX.ContentGenerator.Converters Namespace, Legend, Members, Public Methods, REXParamSectionFactory Methods

REXParamSectionFactory.REXParamSectionFactory Constructor

REXParamSectionFactory.REXParamSectionFactory Constructor
REXParamSectionFactory Class REX.ContentGenerator.Converters Namespace REXParamSectionFactory Class

This is REXParamSectionFactory, a member of class REXParamSectionFactory.

C#
public REXParamSectionFactory(RexConversionSettings Settings);
Class

REXParamSectionFactory Class

Links
REXParamSectionFactory Class, REX.ContentGenerator.Converters Namespace, REXParamSectionFactory Class

REXParamSectionFactory.Close Method

REXParamSectionFactory.Close Method
REXParamSectionFactory Class REX.ContentGenerator.Converters Namespace REXParamSectionFactory Class

This is Close, a member of class REXParamSectionFactory.

C#
public override void Close();
Class

REXParamSectionFactory Class

Links
REXParamSectionFactory Class, REX.ContentGenerator.Converters Namespace, REXParamSectionFactory Class

REXParamSectionFactory.GetAliasName Method