REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Set the maximum value defined in interface units.

C#
public void SetInterfaceMaxValue(double value, REXInterfaceType interfaceType);
Parameters
Parameters | Description
value | The value.
interfaceType | The product context.
Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.SetInterfaceMinValue Method

REXEditControlEngine.SetInterfaceMinValue Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Set the minimum value defined in interface units.

C#
public void SetInterfaceMinValue(double value, REXInterfaceType interfaceType);
Parameters
Parameters | Description
value | The value.
interfaceType | The product context.
Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.SetUserTextValidation Method

REXEditControlEngine.SetUserTextValidation Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Sets the user validation method for the text control.

C#
public void SetUserTextValidation(UserTextValidation ValidFunction);
Parameters
Parameters | Description
ValidFunction | The validation method.
Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.SetUserValidation Method

REXEditControlEngine.SetUserValidation Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Sets the user validation method.

C#
public void SetUserValidation(UserValidation ValidFunction);
Parameters
Parameters | Description
ValidFunction | The validation method.
Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.SetUserValidationComplex Method

REXEditControlEngine.SetUserValidationComplex Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Sets the user validation method for complex values (list).

C#
public void SetUserValidationComplex(UserValidationComplex ValidFunction);
Parameters
Parameters | Description
ValidFunction | The validation method.
Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.SetValue Method (Double)

REXEditControlEngine.SetValue Method (Double)
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Sets the value of the double type.

C#
public virtual void SetValue(Double value);
Parameters
Parameters | Description
value | The value.
Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.SetValue Method (String)

REXEditControlEngine.SetValue Method (String)
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Sets the value of the string type.

C#
public virtual void SetValue(String value);
Parameters
Parameters | Description
value | The value.
Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.StartEdit Method

REXEditControlEngine.StartEdit Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Starts the edit mode.

C#
public virtual void StartEdit();
Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.TextChanged Method

REXEditControlEngine.TextChanged Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Informs about changes in the control's text.

C#
public virtual void TextChanged(string txt);
Parameters
Parameters | Description
txt | The new text.
Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.ValidateComplexValue Method (List<double>)

REXEditControlEngine.ValidateComplexValue Method (List<double>)
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Validates the complex (list) value of the double type.

C#
public bool ValidateComplexValue(List<double> values);
Parameters
Parameters | Description
values | The values to validate.
Returns

True if validated; otherwise false.

Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.ValidateComplexValue Method (List<string>)

REXEditControlEngine.ValidateComplexValue Method (List<string>)
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Validates the complex (list) value of the string type.

C#
public bool ValidateComplexValue(List<string> values);
Parameters
Parameters | Description
values | The values to validate.
Returns

True if validated; otherwise false.

Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.ValidateComplexValue Method (String)

REXEditControlEngine.ValidateComplexValue Method (String)
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Validates the complex (list) value of the string type.

C#
public bool ValidateComplexValue(String value);
Parameters
Parameters | Description
value | The value to validate.
Returns

True if validated; otherwise false.

Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.ValidateControl Method (List<double>)

REXEditControlEngine.ValidateControl Method (List<double>)
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Validates the current control based on the input values.

C#
public virtual bool ValidateControl(List<double> values);
Parameters
Parameters | Description
values | The list of values.
Returns

True if validated; otherwise false.

Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.ValidateControl Method (String)

REXEditControlEngine.ValidateControl Method (String)
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Validates the current control based on the input text.

C#
public virtual bool ValidateControl(String text);
Parameters
Parameters | Description
text | The text.
Returns

True if validated; otherwise false.

Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.ValidateControl Method (bool)

REXEditControlEngine.ValidateControl Method (bool)
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Validates the current control based on the current text or the stored value.

C#
public virtual void ValidateControl(bool currentText);
Parameters
Parameters | Description
currentText | Declares whether the current text should be validated (true to validate the current text; false to validate the stored value).
Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class

REXEditControlEngine.ValidateControl Method (double)

REXEditControlEngine.ValidateControl Method (double)
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class