Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXSectionDBDescription Methods

REXSectionDBDescription Methods
REXSectionDBDescription Class Legend
REXSectionDBDescription Methods
REXSectionDBDescription Methods | Description
Clone | Creates a new object that is a copy of the current instance.
CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
GetContour | Gets the contour of the section.
GetName | Gets the name of the section.
GetSectionType | Gets the type of the section.
GetSectionType | Gets the type of the section.

REXSectionDBDescription Properties

REXSectionDBDescription Properties
REXSectionDBDescription Class Legend
REXSectionDBDescription Properties
REXSectionDBDescription Properties | Description
Characteristics | Gets or sets the characteristics of the section.
Description | Gets or sets the description of the section.
DIM1 | Gets or sets the first numeric component of the section label
DIM2 | Gets or sets the second numeric component of the section label.
DIM3 | Gets or sets the third numeric component of the section label.
Dimensions | Gets or sets the dimensions.
NAME | Gets or sets the name of the section.

REXSectionDBDescription Class Public Methods

REXSectionDBDescription Class Public Methods
REXSectionDBDescription Class Legend
Public Methods
Public Method | Description
REXSectionDBDescription | Initializes a new instance of the REXSectionDBDescription class.
REXSectionDBDescription | Initializes a new instance of the REXSectionDBDescription class.
REXSectionDBDescription | Initializes a new instance of the REXSectionDBDescription class.
REXSectionDBDescription | Initializes a new instance of the REXSectionDBDescription class.
REXSectionDBDescription | Initializes a new instance of the REXSectionDBDescription class.

Legend

Legend
REXSectionDBDimensions Class
Legend
Constructor
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXSectionDBDimensions Class Members

REXSectionDBDimensions Class Members
REXSectionDBDimensions Class Legend
Members
Public Methods
Public Method | Description
REXSectionDBDimensions | Initializes a new instance of the REXSectionDBDimensions class.
REXSectionDBDimensions | Initializes a new instance of the REXSectionDBDimensions class.
REXSectionDBDimensions | Initializes a new instance of the REXSectionDBDimensions class.
REXSectionDBDimensions | Initializes a new instance of the REXSectionDBDimensions class.
REXSectionDBDimensions Methods
REXSectionDBDimensions Methods | Description
Clone | Creates a new object that is a copy of the current instance.
REXSectionDBDimensions Properties
REXSectionDBDimensions Properties | Description
A_1 | Gets or sets the additional angle.
A_2 | Gets or sets the additional angle.
B | Gets or sets the section's width.
B_2 | Gets or sets the AISC k value for design.
EA | Gets or sets the web thickness.
ES | Gets or sets the flange thickness.
ES_2 | Gets or sets the AISC design value k.
GAMMA | Gets or sets the angle of rotation of the section local to principal coordinate system (maximum moments of inertia of a section).
GAP | Gets or sets the distance between sections in compound sections.
H | Gets or sets the section's height.
P1_L | Gets or sets the length of slab P2 (cross-shaped section).
P1_T | Gets or sets the thickness of slab P1 (cross-shaped section).
P2_L | Gets or sets the length of slab P2 (cross-shaped section).
P2_T | Gets or sets the Thickness of slab P2 (cross-shaped section).
P3_L | Gets or sets the Length of slab P3 (cross-shaped section).
P3_T | Gets or sets the thickness of slab P3 (cross-shaped section).
P4_L | Gets or sets the length of slab P4 (cross-shaped section).
P4_T | Gets or sets the thickness of slab P4 (cross-shaped section).
RA | Gets or sets the fillet radius (web).
RS | Gets or sets the fillet radius (flange).
SLOPE_FACTOR | Gets or sets the slope factor.
VPY | Gets or sets the extreme distance from the local Z axis of the point on the negative side of the Y axis.
VPZ | Gets or sets the extreme distance from the local Y axis of the point on the negative side of the Z axis.
VY | Gets or sets the extreme distance from the local Z axis of the point on the positive side of the Y axis.
VZ | Gets or sets the extreme distance from the local Y axis of the point on the positive side of the Z axis.

REXSectionDBDimensions Methods

REXSectionDBDimensions Methods
REXSectionDBDimensions Class Legend
REXSectionDBDimensions Methods
REXSectionDBDimensions Methods | Description
Clone | Creates a new object that is a copy of the current instance.

REXSectionDBDimensions Properties

REXSectionDBDimensions Properties
REXSectionDBDimensions Class Legend
REXSectionDBDimensions Properties
REXSectionDBDimensions Properties | Description
A_1 | Gets or sets the additional angle.
A_2 | Gets or sets the additional angle.
B | Gets or sets the section's width.
B_2 | Gets or sets the AISC k value for design.
EA | Gets or sets the web thickness.
ES | Gets or sets the flange thickness.
ES_2 | Gets or sets the AISC design value k.
GAMMA | Gets or sets the angle of rotation of the section local to principal coordinate system (maximum moments of inertia of a section).
GAP | Gets or sets the distance between sections in compound sections.
H | Gets or sets the section's height.
P1_L | Gets or sets the length of slab P2 (cross-shaped section).
P1_T | Gets or sets the thickness of slab P1 (cross-shaped section).
P2_L | Gets or sets the length of slab P2 (cross-shaped section).
P2_T | Gets or sets the Thickness of slab P2 (cross-shaped section).
P3_L | Gets or sets the Length of slab P3 (cross-shaped section).
P3_T | Gets or sets the thickness of slab P3 (cross-shaped section).
P4_L | Gets or sets the length of slab P4 (cross-shaped section).
P4_T | Gets or sets the thickness of slab P4 (cross-shaped section).
RA | Gets or sets the fillet radius (web).
RS | Gets or sets the fillet radius (flange).
SLOPE_FACTOR | Gets or sets the slope factor.
VPY | Gets or sets the extreme distance from the local Z axis of the point on the negative side of the Y axis.
VPZ | Gets or sets the extreme distance from the local Y axis of the point on the negative side of the Z axis.
VY | Gets or sets the extreme distance from the local Z axis of the point on the positive side of the Y axis.
VZ | Gets or sets the extreme distance from the local Y axis of the point on the positive side of the Z axis.

REXSectionDBDimensions Class Public Methods

REXSectionDBDimensions Class Public Methods
REXSectionDBDimensions Class Legend
Public Methods
Public Method | Description
REXSectionDBDimensions | Initializes a new instance of the REXSectionDBDimensions class.
REXSectionDBDimensions | Initializes a new instance of the REXSectionDBDimensions class.
REXSectionDBDimensions | Initializes a new instance of the REXSectionDBDimensions class.
REXSectionDBDimensions | Initializes a new instance of the REXSectionDBDimensions class.

Legend

Legend
REXSectionDBProperties Class
Legend
Constructor
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXSectionDBProperties Class Members

REXSectionDBProperties Class Members
REXSectionDBProperties Class Legend
Members
Public Methods
Public Method | Description
REXSectionDBProperties | Initializes a new instance of the REXSectionDBProperties class.