If element is material dependent.

Description
Class

REXSectionParamDescription Class

Links
REXSectionParamDescription Class, REX.ContentGenerator.Families Namespace, REXSectionParamDescription Class

REXSectionParamDescription.Angle Property

REXSectionParamDescription.Angle Property
REXSectionParamDescription Class REX.ContentGenerator.Families Namespace REXSectionParamDescription Class

Gets or sets the angle of the section.

C#
public double Angle;
Description

The angle.

Remarks

It isn't taken to considaration during generation in Revit (only for detection of not certified families)

Class

REXSectionParamDescription Class

Links
REXSectionParamDescription Class, REX.ContentGenerator.Families Namespace, REXSectionParamDescription Class

REXSectionParamDescription.Characteristics Property

REXSectionParamDescription.Characteristics Property
REXSectionParamDescription Class REX.ContentGenerator.Families Namespace REXSectionParamDescription Class

Gets or sets the characteristics.

C#
public REXSectionParamCharacteristics Characteristics;
Description

The characteristics.

Class

REXSectionParamDescription Class

Links
REXSectionParamDescription Class, REX.ContentGenerator.Families Namespace, REXSectionParamDescription Class

REXSectionParamDescription.CharacteristicsEnd Property

REXSectionParamDescription.CharacteristicsEnd Property
REXSectionParamDescription Class REX.ContentGenerator.Families Namespace REXSectionParamDescription Class

Gets or sets the characteristics of the end.

C#
public REXSectionParamCharacteristics CharacteristicsEnd;
Description

The characteristics of the end.

Class

REXSectionParamDescription Class

Links
REXSectionParamDescription Class, REX.ContentGenerator.Families Namespace, REXSectionParamDescription Class

REXSectionParamDescription.Contour Property

REXSectionParamDescription.Contour Property
REXSectionParamDescription Class REX.ContentGenerator.Families Namespace REXSectionParamDescription Class

Gets or sets the contour.

C#
public REX.ContentGenerator.Geometry.Contour_Compound2D Contour;
Description

The contour.

Class

REXSectionParamDescription Class

Links
REXSectionParamDescription Class, REX.ContentGenerator.Families Namespace, REXSectionParamDescription Class

REXSectionParamDescription.Dimensions Property

REXSectionParamDescription.Dimensions Property
REXSectionParamDescription Class REX.ContentGenerator.Families Namespace REXSectionParamDescription Class

Gets or sets the dimensions.

C#
public REX.ContentGenerator.Families.REXSectionParamDimensions Dimensions;
Description

The dimensions.

Class

REXSectionParamDescription Class

Links
REXSectionParamDescription Class, REX.ContentGenerator.Families Namespace, REXSectionParamDescription Class

REXSectionParamDescription.DimensionsEnd Property

REXSectionParamDescription.DimensionsEnd Property
REXSectionParamDescription Class REX.ContentGenerator.Families Namespace REXSectionParamDescription Class

Gets or sets the dimensions of the end.

C#
public REX.ContentGenerator.Families.REXSectionParamDimensions DimensionsEnd;
Description

The dimensions of the end.

Class

REXSectionParamDescription Class

Links
REXSectionParamDescription Class, REX.ContentGenerator.Families Namespace, REXSectionParamDescription Class

REXSectionParamDescription.IsTurned Property

REXSectionParamDescription.IsTurned Property
REXSectionParamDescription Class REX.ContentGenerator.Families Namespace REXSectionParamDescription Class

Gets or sets a value indicating whether this instance is turned.

C#
public bool IsTurned;
Description

True if the instance is turned; otherwise, false.

Class

REXSectionParamDescription Class

Links
REXSectionParamDescription Class, REX.ContentGenerator.Families Namespace, REXSectionParamDescription Class

REXSectionParamDescription.SectionType Property

REXSectionParamDescription.SectionType Property
REXSectionParamDescription Class REX.ContentGenerator.Families Namespace REXSectionParamDescription Class

Gets or sets the type of the section.

C#
public REX.ContentGenerator.Families.ESectionType SectionType;
Description

The type of the section.

Class

REXSectionParamDescription Class

Links
REXSectionParamDescription Class, REX.ContentGenerator.Families Namespace, REXSectionParamDescription Class

REXSectionParamDescription.Tapered Property

REXSectionParamDescription.Tapered Property
REXSectionParamDescription Class REX.ContentGenerator.Families Namespace REXSectionParamDescription Class

Gets or sets a value indicating whether this REXSectionParamDescription is tapered.

C#
public bool Tapered;
Description

True if tapered; otherwise, false.

Class

REXSectionParamDescription Class

Links
REXSectionParamDescription Class, REX.ContentGenerator.Families Namespace, REXSectionParamDescription Class

REXSectionParamDimensions Class

REXSectionParamDimensions Class
REX.ContentGenerator.Families Namespace Legend Members Public Methods REXSectionParamDimensions Methods REXSectionParamDimensions Properties

Desribes dimentsions of the parametric section.

Class Hierarchy
C#
[Serializable()]
public class REXSectionParamDimensions : REXDescription;
Description
Namespace

REX.ContentGenerator.Families Namespace

Public Methods
Public Method | Description
REXSectionParamDimensions | Initializes a new instance of the REXSectionParamDimensions class.
REXSectionParamDimensions | Initializes a new instance of the REXSectionParamDimensions class.
REXSectionParamDimensions | Initializes a new instance of the REXSectionParamDimensions class.
REXSectionParamDimensions | Initializes a new instance of the REXSectionParamDimensions class.
REXSectionParamDimensions Methods
REXSectionParamDimensions Methods | Description
Clone | Creates a new object that is a copy of the current instance.
REXSectionParamDimensions Properties
REXSectionParamDimensions Properties | Description
b | Gets or sets the b.
b1 | Gets or sets the b1.
b2 | Gets or sets the b2.
bf | Gets or sets the bf.
d | Gets or sets the d.
h | Gets or sets the h.
h1 | Gets or sets the h1.
h2 | Gets or sets the h2.
l1 | Gets or sets the l1.
l2 | Gets or sets the l2.
P1_L | Gets or sets the P1_L.
P1_T | Gets or sets the P1_T.
P2_L | Gets or sets the P2_L.
P2_T | Gets or sets the P2_T.
P3_L | Gets or sets the P3_L.
P3_T | Gets or sets the P3_T.
P4_L | Gets or sets the P4_L.
P4_T | Gets or sets the P4_T.
t | Gets or sets the t.
tf | Gets or sets the tf.
tf1 | Gets or sets the tf1.
tf2 | Gets or sets the tf2.
tw | Gets or sets the tw.
vpy | Gets or sets the vpy.
vpz | Gets or sets the vpz.
vy | Gets or sets the vy.
vz | Gets or sets the vz.
Links
REX.ContentGenerator.Families Namespace, Legend, Members, Public Methods, REXSectionParamDimensions Methods, REXSectionParamDimensions Properties

REXSectionParamDimensions.REXSectionParamDimensions Constructor ()

REXSectionParamDimensions.REXSectionParamDimensions Constructor ()
REXSectionParamDimensions Class REX.ContentGenerator.Families Namespace REXSectionParamDimensions Class

Initializes a new instance of the REXSectionParamDimensions class.

C#
public REXSectionParamDimensions();
Description
Class

REXSectionParamDimensions Class

Links
REXSectionParamDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionParamDimensions Class

REXSectionParamDimensions.REXSectionParamDimensions Constructor (DTableDataObjectCollection)

REXSectionParamDimensions.REXSectionParamDimensions Constructor (DTableDataObjectCollection)
REXSectionParamDimensions Class REX.ContentGenerator.Families Namespace REXSectionParamDimensions Class

Initializes a new instance of the REXSectionParamDimensions class.

C#
public REXSectionParamDimensions(DTableDataObjectCollection pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

REXSectionParamDimensions Class

Links
REXSectionParamDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionParamDimensions Class