IUnitObject Interface

Links
IUnitObject Interface, REX.Controls.Common Namespace, IUnitObject Interface

IUnitObject.GetValue Method

IUnitObject.GetValue Method
IUnitObject Interface REX.Controls.Common Namespace IUnitObject Interface

Gets the value of the double type.

C#
Double GetValue();
Returns

The value.

Description
Interface

IUnitObject Interface

Links
IUnitObject Interface, REX.Controls.Common Namespace, IUnitObject Interface

IUnitObject.Reset Method

IUnitObject.Reset Method
IUnitObject Interface REX.Controls.Common Namespace IUnitObject Interface

Resets the instance of the element.

C#
void Reset();
Description
Interface

IUnitObject Interface

Links
IUnitObject Interface, REX.Controls.Common Namespace, IUnitObject Interface

IUnitObject.SetComplexValue Method (List<double>)

IUnitObject.SetComplexValue Method (List<double>)
IUnitObject Interface REX.Controls.Common Namespace IUnitObject Interface

Sets the complex (list) value of the double type.

C#
void SetComplexValue(List<double> values);
Parameters
Parameters | Description
values | The list of values.
Description
Interface

IUnitObject Interface

Links
IUnitObject Interface, REX.Controls.Common Namespace, IUnitObject Interface

IUnitObject.SetComplexValue Method (List<string>)

IUnitObject.SetComplexValue Method (List<string>)
IUnitObject Interface REX.Controls.Common Namespace IUnitObject Interface

Sets the complex (list) value of the string type.

C#
void SetComplexValue(List<string> values);
Parameters
Parameters | Description
values | The list of values.
Description
Interface

IUnitObject Interface

Links
IUnitObject Interface, REX.Controls.Common Namespace, IUnitObject Interface

IUnitObject.SetExternalUnitBody Method

IUnitObject.SetExternalUnitBody Method
IUnitObject Interface REX.Controls.Common Namespace IUnitObject Interface

This is SetExternalUnitBody, a member of class IUnitObject.

C#
void SetExternalUnitBody(IUnitBody unitBody);
Interface

IUnitObject Interface

Links
IUnitObject Interface, REX.Controls.Common Namespace, IUnitObject Interface

IUnitObject.SetUserValidation Method

IUnitObject.SetUserValidation Method
IUnitObject Interface REX.Controls.Common Namespace IUnitObject Interface

Sets the user validation method.

C#
void SetUserValidation(UserValidation ValidFunction);
Parameters
Parameters | Description
ValidFunction | The validation method.
Description
Interface

IUnitObject Interface

Links
IUnitObject Interface, REX.Controls.Common Namespace, IUnitObject Interface

IUnitObject.SetUserValidationComplex Method

IUnitObject.SetUserValidationComplex Method
IUnitObject Interface REX.Controls.Common Namespace IUnitObject Interface

Sets the user validation method for complex values (list).

C#
void SetUserValidationComplex(UserValidationComplex ValidFunction);
Parameters
Parameters | Description
ValidFunction | The validation method.
Description
Interface

IUnitObject Interface

Links
IUnitObject Interface, REX.Controls.Common Namespace, IUnitObject Interface

IUnitObject.SetValue Method (Double)

IUnitObject.SetValue Method (Double)
IUnitObject Interface REX.Controls.Common Namespace IUnitObject Interface

Sets the value of the double type.

C#
void SetValue(Double value);
Parameters
Parameters | Description
value | The value.
Description
Interface

IUnitObject Interface

Links
IUnitObject Interface, REX.Controls.Common Namespace, IUnitObject Interface

IUnitObject.SetValue Method (String)

IUnitObject.SetValue Method (String)
IUnitObject Interface REX.Controls.Common Namespace IUnitObject Interface

Sets the value of the string type.

C#
void SetValue(String value);
Parameters
Parameters | Description
value | The value.
Description
Interface

IUnitObject Interface

Links
IUnitObject Interface, REX.Controls.Common Namespace, IUnitObject Interface

IUnitObject.Complex Property

IUnitObject.Complex Property
IUnitObject Interface REX.Controls.Common Namespace IUnitObject Interface

Gets or sets a value indicating whether this the control is in the complex mode (list mode).

C#
bool Complex;
Description

True if complex; otherwise false.

Interface

IUnitObject Interface

Links
IUnitObject Interface, REX.Controls.Common Namespace, IUnitObject Interface

IUnitObject.ControlState Property

IUnitObject.ControlState Property
IUnitObject Interface REX.Controls.Common Namespace IUnitObject Interface

Gets the state of the control.

C#
EControlState ControlState;
Description

The state of the control.

Interface

IUnitObject Interface

Links
IUnitObject Interface, REX.Controls.Common Namespace, IUnitObject Interface

IUnitObject.DataType Property

IUnitObject.DataType Property
IUnitObject Interface REX.Controls.Common Namespace IUnitObject Interface

Gets or sets the type of the data in the control.

C#
EControlType DataType;
Description

The type of the data.

Interface

IUnitObject Interface

Links
IUnitObject Interface, REX.Controls.Common Namespace, IUnitObject Interface

IUnitObject.EngineeringFormat Property

IUnitObject.EngineeringFormat Property
IUnitObject Interface REX.Controls.Common Namespace IUnitObject Interface

Gets or sets a value indicating whether the text of the control should be formatted in according to the engineering (expotential) format.

C#
Boolean EngineeringFormat;
Description

True if engineering format; otherwise false.

Interface

IUnitObject Interface

Links
IUnitObject Interface, REX.Controls.Common Namespace, IUnitObject Interface

IUnitObject.RangeMax Property

IUnitObject.RangeMax Property
IUnitObject Interface REX.Controls.Common Namespace IUnitObject Interface

Gets or sets the highest possible value.

C#
Double RangeMax;
Description

The highest possible value.

Interface

IUnitObject Interface

Links
IUnitObject Interface, REX.Controls.Common Namespace, IUnitObject Interface

IUnitObject.RangeMaxCheck Property

IUnitObject.RangeMaxCheck Property
IUnitObject Interface REX.Controls.Common Namespace IUnitObject Interface

Gets or sets a value indicating whether the value should be validated due to the RangeMax.

C#
Boolean RangeMaxCheck;
Description

True if validate; otherwise false.

Interface

IUnitObject Interface

Links
IUnitObject Interface, REX.Controls.Common Namespace, IUnitObject Interface

IUnitObject.RangeMin Property

IUnitObject.RangeMin Property
IUnitObject Interface REX.Controls.Common Namespace IUnitObject Interface

Gets or sets the minimum possible value.

C#
Double RangeMin;
Description

The minimum possible value.

Interface

IUnitObject Interface

Links
IUnitObject Interface, REX.Controls.Common Namespace, IUnitObject Interface

IUnitObject.RangeMinCheck Property

IUnitObject.RangeMinCheck Property
IUnitObject Interface REX.Controls.Common Namespace IUnitObject Interface

Gets or sets a value indicating whether the value should be validated due to the RangeMin.

C#
Boolean RangeMinCheck;
Description

True if validate; otherwise false.

Interface

IUnitObject Interface

Links
IUnitObject Interface, REX.Controls.Common Namespace, IUnitObject Interface

IUnitObject.RoundingFractional Property

IUnitObject.RoundingFractional Property
IUnitObject Interface REX.Controls.Common Namespace IUnitObject Interface

Gets or sets the rounding for fractional units.

C#
EFractialRound RoundingFractional;
Description

The rounding.

Interface

IUnitObject Interface

Links
IUnitObject Interface, REX.Controls.Common Namespace, IUnitObject Interface

IUnitObject.RoundingIncrement Property

IUnitObject.RoundingIncrement Property
IUnitObject Interface REX.Controls.Common Namespace IUnitObject Interface

Gets or sets the rounding increment.

C#
Double RoundingIncrement;
Description

The rounding increment.

Interface

IUnitObject Interface

Links
IUnitObject Interface, REX.Controls.Common Namespace, IUnitObject Interface

IUnitObject.Separator Property

IUnitObject.Separator Property
IUnitObject Interface REX.Controls.Common Namespace IUnitObject Interface

Gets or sets the decimal separator.

C#