REXLayout Class, REX.Common Namespace, REXLayout Class

REXLayout.Current Property

REXLayout.Current Property
REXLayout Class REX.Common Namespace REXLayout Class

Gets the current layout item.

C#
public REXLayoutItem Current;
Description

The current layout item.

Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class

REXLayout.DefaultOptions Property

REXLayout.DefaultOptions Property
REXLayout Class REX.Common Namespace REXLayout Class

Gets or sets the default options for layout.

C#
public long DefaultOptions;
Description

The default options.

Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class

REXLayout.DisableEvents Property

REXLayout.DisableEvents Property
REXLayout Class REX.Common Namespace REXLayout Class

Gets a value indicating whether events are disabled.

C#
public bool DisableEvents;
Description

true if events are disabled; otherwise, false.

Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class

REXLayoutItem Class

REXLayoutItem Class
REX.Common Namespace Legend Members Public Methods REXLayoutItem Enumerations REXLayoutItem Fields REXLayoutItem Properties

Represents all layout of main control.

Class Hierarchy
C#
public class REXLayoutItem;
Description

All layout items are listed on left panel in options list control.

Namespace

REX.Common Namespace

Public Methods
Public Method | Description
REXLayoutItem | Initializes a new instance of the REXLayoutItem class.
REXLayoutItem | Initializes a new instance of the REXLayoutItem class.
REXLayoutItem | Initializes a new instance of the REXLayoutItem class.
REXLayoutItem | Initializes a new instance of the REXLayoutItem class.
REXLayoutItem | Initializes a new instance of the REXLayoutItem class.
REXLayoutItem | Initializes a new instance of the REXLayoutItem class.
REXLayoutItem | Initializes a new instance of the REXLayoutItem class.
REXLayoutItem | Initializes a new instance of the REXLayoutItem class.
REXLayoutItem | Initializes a new instance of the REXLayoutItem class.
REXLayoutItem Enumerations
REXLayoutItem Enumerations | Description
LayoutType | Determines type of layout item.
REXLayoutItem Fields
REXLayoutItem Fields | Description
ActiveTabPage | Gets or sets ActiveTabPage attribute of layout.
Description | Gets or sets Description attribute of layout.
Dialog | Gets or sets Dialog attribute of layout.
DisableCommands | Gets or sets DisableCommands attribute of layout.
GroupName | Gets or sets GroupName attribute of layout.
LayoutImage | Gets or sets LayoutImage attribute of layout.
Name | Gets or sets Name attribute of layout.
Options | Gets or sets Options attribute of layout.
Type | Gets or sets Type attribute of layout.
View | Gets or sets View attribute of layout.
Visible | Gets or sets visibility attribute of layout.
REXLayoutItem Properties
REXLayoutItem Properties | Description
DefaultDialogSize | Gets the default size of the dialog.
DefaultViewSize | Gets the default size of the view.
Links
REX.Common Namespace, Legend, Members, Public Methods, REXLayoutItem Enumerations, REXLayoutItem Fields, REXLayoutItem Properties

REXLayoutItem.REXLayoutItem Constructor (LayoutType, string, string, string)

REXLayoutItem.REXLayoutItem Constructor (LayoutType, string, string, string)
REXLayoutItem Class REX.Common Namespace REXLayoutItem Class

Initializes a new instance of the REXLayoutItem class.

C#
public REXLayoutItem(LayoutType Type, string Name, string GroupName, string Description);
Parameters
Parameters | Description
Type | The type.
Name | The name.
GroupName | Name of the group.
Description | The description.
Description
Class

REXLayoutItem Class

Links
REXLayoutItem Class, REX.Common Namespace, REXLayoutItem Class

REXLayoutItem.REXLayoutItem Constructor (LayoutType, string, string, string, REXUI.SetupOptions)

REXLayoutItem.REXLayoutItem Constructor (LayoutType, string, string, string, REXUI.SetupOptions)
REXLayoutItem Class REX.Common Namespace REXLayoutItem Class

Initializes a new instance of the REXLayoutItem class.

C#
public REXLayoutItem(LayoutType Type, string Name, string GroupName, string Description, REXUI.SetupOptions Options);
Parameters
Parameters | Description
Type | The type.
Name | The name.
GroupName | Name of the group.
Description | The description.
Options | The options.
Description
Class

REXLayoutItem Class

Links
REXLayoutItem Class, REX.Common Namespace, REXLayoutItem Class

REXLayoutItem.REXLayoutItem Constructor (LayoutType, string, string, string, REXUI.SetupOptions, Control, Control)

REXLayoutItem.REXLayoutItem Constructor (LayoutType, string, string, string, REXUI.SetupOptions, Control, Control)
REXLayoutItem Class REX.Common Namespace REXLayoutItem Class

Initializes a new instance of the REXLayoutItem class.

C#
public REXLayoutItem(LayoutType Type, string Name, string GroupName, string Description, REXUI.SetupOptions Options, Control Dialog, Control View);
Parameters
Parameters | Description
Type | The type.
Name | The name.
GroupName | Name of the group.
Description | The description.
Options | The options.
Dialog | The dialog control.
View | The view or dialog control.
Description
Class

REXLayoutItem Class

Links
REXLayoutItem Class, REX.Common Namespace, REXLayoutItem Class

REXLayoutItem.REXLayoutItem Constructor (LayoutType, string, string, string, REXUI.SetupOptions, Control, Control, ImageSource)

REXLayoutItem.REXLayoutItem Constructor (LayoutType, string, string, string, REXUI.SetupOptions, Control, Control, ImageSource)
REXLayoutItem Class REX.Common Namespace REXLayoutItem Class

Initializes a new instance of the REXLayoutItem class.

C#
public REXLayoutItem(LayoutType Type, string Name, string GroupName, string Description, REXUI.SetupOptions Options, Control Dialog, Control View, ImageSource LayoutImage);
Parameters
Parameters | Description
Type | The type.
Name | The name.
GroupName | Name of the group.
Description | The description.
Options | The options.
Dialog | The dialog control.
View | The view or dialog control.
LayoutImage | The layout image.
Description
Class

REXLayoutItem Class

Links
REXLayoutItem Class, REX.Common Namespace, REXLayoutItem Class

REXLayoutItem.REXLayoutItem Constructor (LayoutType, string, string, string, REXUI.SetupOptions, System.Windows.Controls.Control)

REXLayoutItem.REXLayoutItem Constructor (LayoutType, string, string, string, REXUI.SetupOptions, System.Windows.Controls.Control)
REXLayoutItem Class REX.Common Namespace REXLayoutItem Class

Initializes a new instance of the REXLayoutItem class.

C#
public REXLayoutItem(LayoutType Type, string Name, string GroupName, string Description, REXUI.SetupOptions Options, System.Windows.Controls.Control Dialog);
Parameters
Parameters | Description
Type | The type.
Name | The name.
GroupName | Name of the group.
Description | The description.
Options | The options.
Dialog | The dialog control.
Description
Class

REXLayoutItem Class

Links
REXLayoutItem Class, REX.Common Namespace, REXLayoutItem Class

REXLayoutItem.REXLayoutItem Constructor (LayoutType, string, string, string, long)

REXLayoutItem.REXLayoutItem Constructor (LayoutType, string, string, string, long)
REXLayoutItem Class REX.Common Namespace REXLayoutItem Class

Initializes a new instance of the REXLayoutItem class.

C#
public REXLayoutItem(LayoutType Type, string Name, string GroupName, string Description, long Options);
Parameters
Parameters | Description
Type | The type.
Name | The name.
GroupName | Name of the group.
Description | The description.
Options | The options.
Description
Class

REXLayoutItem Class

Links
REXLayoutItem Class, REX.Common Namespace, REXLayoutItem Class

REXLayoutItem.REXLayoutItem Constructor (LayoutType, string, string, string, long, Control, Control)

REXLayoutItem.REXLayoutItem Constructor (LayoutType, string, string, string, long, Control, Control)
REXLayoutItem Class REX.Common Namespace REXLayoutItem Class