REXComboBox.AddLostFocusHandler Method

REXComboBox.AddLostFocusHandler Method
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Adds the handler to the event raised when the element loses logical focus.

C#
public void AddLostFocusHandler(EventHandler eh);
Parameters
Parameters | Description
eh | The event handler.
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.AddTextChangedHandler Method

REXComboBox.AddTextChangedHandler Method
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Adds the handler to the event raised when text changes.

C#
public void AddTextChangedHandler(EventHandler eh);
Parameters
Parameters | Description
eh | The event handler.
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.Editable Method

REXComboBox.Editable Method
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets a value indicating whether the control is editable.

C#
public bool Editable();
Returns

True if the control can be edited; otherwise false.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.GetBackground Method

REXComboBox.GetBackground Method
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets the background of the control.

C#
public object GetBackground();
Returns

The background.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.GetComplexDoubleValue Method

REXComboBox.GetComplexDoubleValue Method
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets the complex (list) value of the double type.

C#
public List<double> GetComplexDoubleValue();
Returns

The list of values.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.GetComplexStringValue Method

REXComboBox.GetComplexStringValue Method
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Returns a complex string list.

C#
public List<string> GetComplexStringValue();
Returns

The list of values.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.GetEnable Method

REXComboBox.GetEnable Method
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Indicates whether the control is enabled.

C#
public bool GetEnable();
Returns

True if the element is enabled; otherwise, false.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.GetFullName Method

REXComboBox.GetFullName Method
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets the full name.

C#
public string GetFullName();
Returns

The full name.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.GetItems Method

REXComboBox.GetItems Method
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets the collection of the items contained in the control.

C#
public List<string> GetItems();
Returns

The list of items.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.GetLastCorrectValueStr Method

REXComboBox.GetLastCorrectValueStr Method
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets the last correct stored value.

C#
public String GetLastCorrectValueStr();
Returns

The correct value.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.GetPropertiesType Method

REXComboBox.GetPropertiesType Method
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets the mode of the combo.

C#
public EComboPropertiesType GetPropertiesType();
Returns

The mode of the combo box.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.GetSelectedIndex Method

REXComboBox.GetSelectedIndex Method
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets the index specifying the currently selected item.

C#
public int GetSelectedIndex();
Returns

The index.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.GetState Method

REXComboBox.GetState Method
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets the current state of the control.

C#
public EControlState GetState();
Returns

The state of the control.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.GetText Method

REXComboBox.GetText Method
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets the text contents of the control.

C#
public string GetText();
Returns

The text contents of the control.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.GetUniqueName Method

REXComboBox.GetUniqueName Method
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Returns the Unique ID generated for the current instance of the engine.

C#
public string GetUniqueName();
Returns

The unique ID.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.GetValue Method

REXComboBox.GetValue Method
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets the value of the double type.

C#
public double GetValue();
Returns

The value.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.OnTextBoxModeChanged Method

REXComboBox.OnTextBoxModeChanged Method
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Called when text box mode changes.

C#
public virtual void OnTextBoxModeChanged();
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.Refresh Method

REXComboBox.Refresh Method
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Refreshes the text on the control based on the current text.

C#
public void Refresh();
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.RefreshValidationStatus Method

REXComboBox.RefreshValidationStatus Method
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Refreshes the validation status.

C#
public void RefreshValidationStatus();
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.Reset Method

REXComboBox.Reset Method
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Resets control (internal values).

C#
public void Reset();
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.RestorePropertiesType Method

REXComboBox.RestorePropertiesType Method
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Restores the mode of the combo.

C#
public void RestorePropertiesType();
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.SetComplexValue Method (List<double>)

REXComboBox.SetComplexValue Method (List<double>)
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Sets the complex (list) value of the double type.

C#
public void SetComplexValue(List<double> values);
Parameters
Parameters | Description
values | The list of values.
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class