REX.ContentGenerator.Geometry Namespace, Legend, Members, Public Methods, Contour_Compound2D Methods, Contour_Compound2D Properties

Contour_Compound2D.Contour_Compound2D Constructor ()

Contour_Compound2D.Contour_Compound2D Constructor ()
Contour_Compound2D Class REX.ContentGenerator.Geometry Namespace Contour_Compound2D Class

Initializes a new instance of the Contour_Compound2D class.

C#
public Contour_Compound2D();
Description
Class

Contour_Compound2D Class

Links
Contour_Compound2D Class, REX.ContentGenerator.Geometry Namespace, Contour_Compound2D Class

Contour_Compound2D.Contour_Compound2D Constructor (Contour_Compound2D)

Contour_Compound2D.Contour_Compound2D Constructor (Contour_Compound2D)
Contour_Compound2D Class REX.ContentGenerator.Geometry Namespace Contour_Compound2D Class

Initializes a new instance of the Contour_Compound2D class.

C#
public Contour_Compound2D(Contour_Compound2D pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

Contour_Compound2D Class

Links
Contour_Compound2D Class, REX.ContentGenerator.Geometry Namespace, Contour_Compound2D Class

Contour_Compound2D.Contour_Compound2D Constructor (List<REXxyz>)

Contour_Compound2D.Contour_Compound2D Constructor (List<REXxyz>)
Contour_Compound2D Class REX.ContentGenerator.Geometry Namespace Contour_Compound2D Class

Initializes a new instance of the Contour_Compound2D class.

C#
public Contour_Compound2D(List<REXxyz> points);
Parameters
Parameters | Description
points | The list of points.
Description
Class

Contour_Compound2D Class

Links
Contour_Compound2D Class, REX.ContentGenerator.Geometry Namespace, Contour_Compound2D Class

Contour_Compound2D.Contour_Compound2D Constructor (System.Runtime.Serialization.SerializationInfo, System.Runtime.Serialization.StreamingContext)

Contour_Compound2D.Contour_Compound2D Constructor (System.Runtime.Serialization.SerializationInfo, System.Runtime.Serialization.StreamingContext)
Contour_Compound2D Class REX.ContentGenerator.Geometry Namespace Contour_Compound2D Class

Initializes a new instance of the Contour_Compound2D class.

C#
public Contour_Compound2D(System.Runtime.Serialization.SerializationInfo info, System.Runtime.Serialization.StreamingContext context);
Parameters
Parameters | Description
info | Serialization data.
context | The context.
Description
Class

Contour_Compound2D Class

Links
Contour_Compound2D Class, REX.ContentGenerator.Geometry Namespace, Contour_Compound2D Class

Contour_Compound2D.ArcTo Method (REXxyz, REXxyz)

Contour_Compound2D.ArcTo Method (REXxyz, REXxyz)
Contour_Compound2D Class REX.ContentGenerator.Geometry Namespace Contour_Compound2D Class

Defines an arc.

C#
public void ArcTo(REXxyz pt, REXxyz middle);
Parameters
Parameters | Description
pt | The point.
middle | The middle point.
Description
Class

Contour_Compound2D Class

Links
Contour_Compound2D Class, REX.ContentGenerator.Geometry Namespace, Contour_Compound2D Class

Contour_Compound2D.ArcTo Method (double, double, double, EArcDir)

Contour_Compound2D.ArcTo Method (double, double, double, EArcDir)
Contour_Compound2D Class REX.ContentGenerator.Geometry Namespace Contour_Compound2D Class

Defines an arc.

C#
public void ArcTo(double x, double y, double r, EArcDir dir);
Parameters
Parameters | Description
x | The x coordinate.
y | The y coordinate.
r | The radius.
dir | The direction.
Description
Class

Contour_Compound2D Class

Links
Contour_Compound2D Class, REX.ContentGenerator.Geometry Namespace, Contour_Compound2D Class

Contour_Compound2D.AxisLine Method

Contour_Compound2D.AxisLine Method
Contour_Compound2D Class REX.ContentGenerator.Geometry Namespace Contour_Compound2D Class

Defines an axis line.

C#
public void AxisLine(double xst, double yst, double xend, double yend);
Parameters
Parameters | Description
xst | The x start.
yst | The y start.
xend | The x end.
yend | The y end.
Description
Class

Contour_Compound2D Class

Links
Contour_Compound2D Class, REX.ContentGenerator.Geometry Namespace, Contour_Compound2D Class

Contour_Compound2D.Circle Method

Contour_Compound2D.Circle Method
Contour_Compound2D Class REX.ContentGenerator.Geometry Namespace Contour_Compound2D Class

Defines a circle.

C#
public void Circle(double x, double y, double r);
Parameters
Parameters | Description
x | The x (center).
y | The y (center).
r | The radius.
Description
Class

Contour_Compound2D Class

Links
Contour_Compound2D Class, REX.ContentGenerator.Geometry Namespace, Contour_Compound2D Class

Contour_Compound2D.Dimension Method

Contour_Compound2D.Dimension Method
Contour_Compound2D Class REX.ContentGenerator.Geometry Namespace Contour_Compound2D Class

Defines a dimension.

C#
public void Dimension(double xst, double yst, string param);
Parameters
Parameters | Description
xst | The x start.
yst | The y start.
param | The parameter (text).
Description
Class

Contour_Compound2D Class

Links
Contour_Compound2D Class, REX.ContentGenerator.Geometry Namespace, Contour_Compound2D Class

Contour_Compound2D.DimensionLine Method (double, double, double, double, int, bool, string)

Contour_Compound2D.DimensionLine Method (double, double, double, double, int, bool, string)
Contour_Compound2D Class REX.ContentGenerator.Geometry Namespace Contour_Compound2D Class

Defines a dimension line.

C#
public void DimensionLine(double xst, double yst, double xend, double yend, int lev, bool up, string param);
Parameters
Parameters | Description
xst | The x start.
yst | The y start.
xend | The x end.
yend | The y end.
lev | The level.
up | Indicates whether the text should be placed above the line.
param | The parameter (text).
Description
Class

Contour_Compound2D Class

Links
Contour_Compound2D Class, REX.ContentGenerator.Geometry Namespace, Contour_Compound2D Class

Contour_Compound2D.DimensionLine Method (double, double, double, double, int, bool, string, bool)

Contour_Compound2D.DimensionLine Method (double, double, double, double, int, bool, string, bool)
Contour_Compound2D Class REX.ContentGenerator.Geometry Namespace Contour_Compound2D Class

Defines a dimension line.

C#
public void DimensionLine(double xst, double yst, double xend, double yend, int lev, bool up, string param, bool extend2Right);
Parameters
Parameters | Description
xst | The x start.
yst | The y start.
xend | The x end.
yend | The y end.
lev | The level.
up | Indicates whether the text should be placed above the line.
param | The parameter (text).
extend2Right | Indicates whether dimension should be extended to the right.
Description
Class

Contour_Compound2D Class

Links
Contour_Compound2D Class, REX.ContentGenerator.Geometry Namespace, Contour_Compound2D Class

Contour_Compound2D.DimensionRadius Method

Contour_Compound2D.DimensionRadius Method
Contour_Compound2D Class REX.ContentGenerator.Geometry Namespace Contour_Compound2D Class

Defines a radial dimension.

C#
public void DimensionRadius(double xst, double yst, double xend, double yend, double r, bool descOnEnd, EArcDir dir, string param);
Parameters
Parameters | Description
xst | The x start.
yst | The y start.
xend | The x end.
yend | The y end.
r | The radius.
dir | The direction.
param | The parameter (text).
DescOnEnd | Indicates whether the description should be placed on the end.
Description
Class

Contour_Compound2D Class

Links
Contour_Compound2D Class, REX.ContentGenerator.Geometry Namespace, Contour_Compound2D Class

Contour_Compound2D.GetBoundingBox Method

Contour_Compound2D.GetBoundingBox Method
Contour_Compound2D Class REX.ContentGenerator.Geometry Namespace Contour_Compound2D Class

Gets the bounding box.

C#
public REX.Common.Geometry.BoundingBoxREXxyz GetBoundingBox();
Returns

The bounding box.

Description
Class

Contour_Compound2D Class

Links
Contour_Compound2D Class, REX.ContentGenerator.Geometry Namespace, Contour_Compound2D Class

Contour_Compound2D.GetGeometryParams Method

Contour_Compound2D.GetGeometryParams Method