RVTSectionParamFactory | This is class REX.ContentGenerator.Converters.RVTSectionParamFactory.
Interfaces
Interface | Description
IRexContentSettings | Provides interface for the settings of the REXFamilyConverter.
IRvtContentSettings | Provides interface for the settings of the RVTFamilyConverter.
Structs, Records, Enums
Struct, Record, Enum | Description
EDBAccess | Describes the access to databases.
Types
Type | Description
ElementGenerated | Delagate for the generation event (when the list of elements is used).
Links
Legend, Classes, Interfaces, Structs, Records, Enums, Types

FieldParams Class

FieldParams Class
REX.ContentGenerator.Converters Namespace Legend Members Public Methods FieldParams Methods FieldParams Properties

Represents parameters of the field.

Class Hierarchy
C#
public class FieldParams : Attribute;
Description
Namespace

REX.ContentGenerator.Converters Namespace

Public Methods
Public Method | Description
FieldParams | Initializes a new instance of the FieldParams class.
FieldParams Methods
FieldParams Methods | Description
GetDefaultValue | Gets the default value.
GetDefaultValue | Gets the default value.
FieldParams Properties
FieldParams Properties | Description
database | Gets or sets the name in database.
display | Gets or sets the display name.
identity | Gets or sets a value indicating whether this field is used for identification.
name | Gets or sets the name.
power | Gets or sets the power.
template | Gets or sets a value indicating whether this field is used for template identification.
unitName | Gets or sets the name of the unit.
visible | Gets or sets a value indicating whether this FieldParams is visible.
Links
REX.ContentGenerator.Converters Namespace, Legend, Members, Public Methods, FieldParams Methods, FieldParams Properties

FieldParams.FieldParams Constructor

FieldParams.FieldParams Constructor
FieldParams Class REX.ContentGenerator.Converters Namespace FieldParams Class

Initializes a new instance of the FieldParams class.

C#
public FieldParams(string name, string unit_name, int pow, bool vis, string dis, string def);
Parameters
Parameters | Description
name | The name.
unit_name | The unit name.
pow | The power.
vis | If visible.
dis | The display name.
def | The default.
Description
Class

FieldParams Class

Links
FieldParams Class, REX.ContentGenerator.Converters Namespace, FieldParams Class

FieldParams.GetDefaultValue Method ()

FieldParams.GetDefaultValue Method ()
FieldParams Class REX.ContentGenerator.Converters Namespace FieldParams Class

Gets the default value.

C#
public object GetDefaultValue();
Returns

The default value.

Description
Class

FieldParams Class

Links
FieldParams Class, REX.ContentGenerator.Converters Namespace, FieldParams Class

FieldParams.GetDefaultValue Method (string)

FieldParams.GetDefaultValue Method (string)
FieldParams Class REX.ContentGenerator.Converters Namespace FieldParams Class

Gets the default value.

C#
public object GetDefaultValue(string key);
Parameters
Parameters | Description
key | The key.
Returns

The default value.

Description
Class

FieldParams Class

Links
FieldParams Class, REX.ContentGenerator.Converters Namespace, FieldParams Class

FieldParams.database Property

FieldParams.database Property
FieldParams Class REX.ContentGenerator.Converters Namespace FieldParams Class

Gets or sets the name in database.

C#
public string database;
Description

The name in the database.

Class

FieldParams Class

Links
FieldParams Class, REX.ContentGenerator.Converters Namespace, FieldParams Class

FieldParams.display Property

FieldParams.display Property
FieldParams Class REX.ContentGenerator.Converters Namespace FieldParams Class

Gets or sets the display name.

C#
public string display;
Description

The display name.

Class

FieldParams Class

Links
FieldParams Class, REX.ContentGenerator.Converters Namespace, FieldParams Class

FieldParams.identity Property

FieldParams.identity Property
FieldParams Class REX.ContentGenerator.Converters Namespace FieldParams Class

Gets or sets a value indicating whether this field is used for identification.

C#
public bool identity;
Description
Class

FieldParams Class

Links
FieldParams Class, REX.ContentGenerator.Converters Namespace, FieldParams Class

FieldParams.name Property

FieldParams.name Property
FieldParams Class REX.ContentGenerator.Converters Namespace FieldParams Class

Gets or sets the name.

C#
public string name;
Description

The name.

Class

FieldParams Class

Links
FieldParams Class, REX.ContentGenerator.Converters Namespace, FieldParams Class

FieldParams.power Property

FieldParams.power Property
FieldParams Class REX.ContentGenerator.Converters Namespace FieldParams Class

Gets or sets the power.

C#
public int power;
Description

The power.

Class

FieldParams Class

Links
FieldParams Class, REX.ContentGenerator.Converters Namespace, FieldParams Class

FieldParams.template Property

FieldParams.template Property
FieldParams Class REX.ContentGenerator.Converters Namespace FieldParams Class

Gets or sets a value indicating whether this field is used for template identification.

C#
public bool template;
Description
Class

FieldParams Class

Links
FieldParams Class, REX.ContentGenerator.Converters Namespace, FieldParams Class

FieldParams.unitName Property

FieldParams.unitName Property
FieldParams Class REX.ContentGenerator.Converters Namespace FieldParams Class

Gets or sets the name of the unit.

C#
public string unitName;
Description

The name of the unit.

Class

FieldParams Class

Links
FieldParams Class, REX.ContentGenerator.Converters Namespace, FieldParams Class

FieldParams.visible Property

FieldParams.visible Property
FieldParams Class REX.ContentGenerator.Converters Namespace FieldParams Class

Gets or sets a value indicating whether this FieldParams is visible.

C#
public bool visible;
Description

If visible.

Class

FieldParams Class

Links
FieldParams Class, REX.ContentGenerator.Converters Namespace, FieldParams Class

REXContentFilter Class

REXContentFilter Class
REX.ContentGenerator.Converters Namespace

Base class for all filters.

Class Hierarchy
C#
public abstract class REXContentFilter;
Description
Namespace

REX.ContentGenerator.Converters Namespace

Links
REX.ContentGenerator.Converters Namespace

REXContentLogicFilter Class

REXContentLogicFilter Class
REX.ContentGenerator.Converters Namespace Legend Members Public Methods REXContentLogicFilter Enumerations REXContentLogicFilter Properties

Describes a logic filter.

Class Hierarchy
C#
public class REXContentLogicFilter : REXContentFilter;
Description
Namespace

REX.ContentGenerator.Converters Namespace

Public Methods
Public Method | Description
REXContentLogicFilter | Initializes a new instance of the REXContentLogicFilter class.
REXContentLogicFilter | Initializes a new instance of the REXContentLogicFilter class.
REXContentLogicFilter Enumerations
REXContentLogicFilter Enumerations | Description
ELogicOperator | Describes operators.
REXContentLogicFilter Properties
REXContentLogicFilter Properties | Description
Filters | Gets or sets the filters.
LogicOperator | Gets or sets the logic operator.
Links
REX.ContentGenerator.Converters Namespace, Legend, Members, Public Methods, REXContentLogicFilter Enumerations, REXContentLogicFilter Properties

REXContentLogicFilter.REXContentLogicFilter Constructor (ELogicOperator)

REXContentLogicFilter.REXContentLogicFilter Constructor (ELogicOperator)
REXContentLogicFilter Class REX.ContentGenerator.Converters Namespace REXContentLogicFilter Class

Initializes a new instance of the REXContentLogicFilter class.

C#
public REXContentLogicFilter(ELogicOperator logicOperator);
Parameters
Parameters | Description
logicOperator | The logic operator.
Description
Class

REXContentLogicFilter Class

Links
REXContentLogicFilter Class, REX.ContentGenerator.Converters Namespace, REXContentLogicFilter Class