REXExtensionProduct Class REX.Common Namespace REXExtensionProduct Class

Shows results.

C#
public virtual void OnShowResults();
Description
Class

REXExtensionProduct Class

Links
REXExtensionProduct Class, REX.Common Namespace, REXExtensionProduct Class

REXExtensionProduct.OnUpdateDialogs Method

REXExtensionProduct.OnUpdateDialogs Method
REXExtensionProduct Class REX.Common Namespace REXExtensionProduct Class

This is OnUpdateDialogs, a member of class REXExtensionProduct.

C#
public virtual void OnUpdateDialogs();
Class

REXExtensionProduct Class

Links
REXExtensionProduct Class, REX.Common Namespace, REXExtensionProduct Class

REXExtensionSettings Class

REXExtensionSettings Class
REX.Common Namespace Legend Members Public Methods REXExtensionSettings Methods REXExtensionSettings Properties

Allows reading base settings from "Configuration / settings.xml" file.

Class Hierarchy
C#
public class REXExtensionSettings : REXExtensionBaseSettings, IREXThisExtensioninternalclassREXExtensionSettings:REXExtensionBaseSettings, IREXThisExtension;
Description
Namespace

REX.Common Namespace

Public Methods
Public Method | Description
REXExtensionSettings | Initializes a new instance of the REXExtensionSettings class.
REXExtensionSettings | Initializes a new instance of the REXExtensionSettings class.
REXExtensionSettings Methods
REXExtensionSettings Methods | Description
LoadSettings | This is LoadSettings, a member of class REXExtensionSettings.
REXExtensionSettings Properties
REXExtensionSettings Properties | Description
ThisApplication | Get the application.
ThisContext | Get the context.
ThisExtension | Get the extension.
Links
REX.Common Namespace, Legend, Members, Public Methods, REXExtensionSettings Methods, REXExtensionSettings Properties

REXExtensionSettings.REXExtensionSettings Constructor (Autodesk.REX.Framework.REXContext)

REXExtensionSettings.REXExtensionSettings Constructor (Autodesk.REX.Framework.REXContext)
REXExtensionSettings Class REX.Common Namespace REXExtensionSettings Class

Initializes a new instance of the REXExtensionSettings class.

C#
public REXExtensionSettings(Autodesk.REX.Framework.REXContext Ctx);
Parameters
Parameters | Description
Ctx | The reference to a REXContext object.
Description
Class

REXExtensionSettings Class

Links
REXExtensionSettings Class, REX.Common Namespace, REXExtensionSettings Class

REXExtensionSettings.REXExtensionSettings Constructor (REXExtension)

REXExtensionSettings.REXExtensionSettings Constructor (REXExtension)
REXExtensionSettings Class REX.Common Namespace REXExtensionSettings Class

Initializes a new instance of the REXExtensionSettings class.

C#
public REXExtensionSettings(REXExtension Ext);
Parameters
Parameters | Description
Ext | The reference to a REXExtension object.
Description
Class

REXExtensionSettings Class

Links
REXExtensionSettings Class, REX.Common Namespace, REXExtensionSettings Class

REXExtensionSettings.LoadSettings Method

REXExtensionSettings.LoadSettings Method
REXExtensionSettings Class REX.Common Namespace REXExtensionSettings Class

This is LoadSettings, a member of class REXExtensionSettings.

C#
public override bool LoadSettings();
Class

REXExtensionSettings Class

Links
REXExtensionSettings Class, REX.Common Namespace, REXExtensionSettings Class

REXExtensionSettings.ThisApplication Property

REXExtensionSettings.ThisApplication Property
REXExtensionSettings Class REX.Common Namespace REXExtensionSettings Class

Get the application.

C#
public REXApplication ThisApplication;
Description

The application.

Class

REXExtensionSettings Class

Links
REXExtensionSettings Class, REX.Common Namespace, REXExtensionSettings Class

REXExtensionSettings.ThisContext Property

REXExtensionSettings.ThisContext Property
REXExtensionSettings Class REX.Common Namespace REXExtensionSettings Class

Get the context.

C#
public REXContext ThisContext;
Description

The context.

Class

REXExtensionSettings Class

Links
REXExtensionSettings Class, REX.Common Namespace, REXExtensionSettings Class

REXExtensionSettings.ThisExtension Property

REXExtensionSettings.ThisExtension Property
REXExtensionSettings Class REX.Common Namespace REXExtensionSettings Class

Get the extension.

C#
public REXExtension ThisExtension;
Description

The extension.

Class

REXExtensionSettings Class

Links
REXExtensionSettings Class, REX.Common Namespace, REXExtensionSettings Class

REXExtensionWindow Class

REXExtensionWindow Class
REX.Common Namespace Legend Members Public Methods REXExtensionWindow Properties

Base class for user forms.

Class Hierarchy
C#
public class REXExtensionWindow : Window, IREXThisExtension;
Description

Enables easy access to main module's objects.

Namespace

REX.Common Namespace

Public Methods
Public Method | Description
REXExtensionWindow | Initializes a new instance of a REXExtensionForm class.
REXExtensionWindow | Initializes a new instance of a REXExtensionForm class.
REXExtensionWindow Properties
REXExtensionWindow Properties | Description
ThisApplication | Get this application.
ThisContext | Get this context.
ThisExtension | Get this extension.
ThisProduct | Gets the this product.
ThisRunContext | Gets the this run context.
WindowStatus | This is WindowStatus, a member of class REXExtensionWindow.
Links
REX.Common Namespace, Legend, Members, Public Methods, REXExtensionWindow Properties

REXExtensionWindow.REXExtensionWindow Constructor ()

REXExtensionWindow.REXExtensionWindow Constructor ()
REXExtensionWindow Class REX.Common Namespace REXExtensionWindow Class

Initializes a new instance of a REXExtensionForm class.

C#
public REXExtensionWindow();
Description
Class

REXExtensionWindow Class

Links
REXExtensionWindow Class, REX.Common Namespace, REXExtensionWindow Class

REXExtensionWindow.REXExtensionWindow Constructor (REXExtension)

REXExtensionWindow.REXExtensionWindow Constructor (REXExtension)
REXExtensionWindow Class REX.Common Namespace REXExtensionWindow Class

Initializes a new instance of a REXExtensionForm class.

C#
public REXExtensionWindow(REXExtension Ext);
Parameters
Parameters | Description
Ext | The reference to a REXExtension object.
Description
Class

REXExtensionWindow Class

Links
REXExtensionWindow Class, REX.Common Namespace, REXExtensionWindow Class

REXExtensionWindow.ThisApplication Property

REXExtensionWindow.ThisApplication Property
REXExtensionWindow Class REX.Common Namespace REXExtensionWindow Class

Get this application.

C#
[Browsable(false)]
public REXApplication ThisApplication;
Description

This application.

Class

REXExtensionWindow Class

Links
REXExtensionWindow Class, REX.Common Namespace, REXExtensionWindow Class

REXExtensionWindow.ThisContext Property

REXExtensionWindow.ThisContext Property
REXExtensionWindow Class REX.Common Namespace REXExtensionWindow Class

Get this context.

C#
[Browsable(false)]
public REXContext ThisContext;
Description

This context.

Class

REXExtensionWindow Class

Links
REXExtensionWindow Class, REX.Common Namespace, REXExtensionWindow Class

REXExtensionWindow.ThisExtension Property

REXExtensionWindow.ThisExtension Property
REXExtensionWindow Class REX.Common Namespace REXExtensionWindow Class

Get this extension.

C#
[Browsable(false)]
public REXExtension ThisExtension;
Description

This extension.

Class

REXExtensionWindow Class

Links
REXExtensionWindow Class, REX.Common Namespace, REXExtensionWindow Class

REXExtensionWindow.ThisProduct Property

REXExtensionWindow.ThisProduct Property
REXExtensionWindow Class REX.Common Namespace REXExtensionWindow Class

Gets the this product.

C#
public REXInterfaceType ThisProduct;
Description

The this product.

Class

REXExtensionWindow Class

Links
REXExtensionWindow Class, REX.Common Namespace, REXExtensionWindow Class

REXExtensionWindow.ThisRunContext Property

REXExtensionWindow.ThisRunContext Property
REXExtensionWindow Class REX.Common Namespace REXExtensionWindow Class

Gets the this run context.

C#