RVTCommonSectionFactory Class, REX.ContentGenerator.Converters Namespace, RVTCommonSectionFactory Class

RVTCommonSectionFactory.GetElement4ParamIdentity Method

RVTCommonSectionFactory.GetElement4ParamIdentity Method
RVTCommonSectionFactory Class REX.ContentGenerator.Converters Namespace RVTCommonSectionFactory Class

This is GetElement4ParamIdentity, a member of class RVTCommonSectionFactory.

C#
public override RevitElement GetElement4ParamIdentity(RevitElement el);
Class

RVTCommonSectionFactory Class

Links
RVTCommonSectionFactory Class, REX.ContentGenerator.Converters Namespace, RVTCommonSectionFactory Class

RVTCommonSectionFactory.GetExistingNames Method

RVTCommonSectionFactory.GetExistingNames Method
RVTCommonSectionFactory Class REX.ContentGenerator.Converters Namespace RVTCommonSectionFactory Class

This is GetExistingNames, a member of class RVTCommonSectionFactory.

C#
public override List<string> GetExistingNames(REXFamilyType obj, bool type);
Class

RVTCommonSectionFactory Class

Links
RVTCommonSectionFactory Class, REX.ContentGenerator.Converters Namespace, RVTCommonSectionFactory Class

RVTCommonSectionFactory.GetName4Mapping Method

RVTCommonSectionFactory.GetName4Mapping Method
RVTCommonSectionFactory Class REX.ContentGenerator.Converters Namespace RVTCommonSectionFactory Class

This is GetName4Mapping, a member of class RVTCommonSectionFactory.

C#
public override string GetName4Mapping(Autodesk.Revit.DB.Element elem);
Class

RVTCommonSectionFactory Class

Links
RVTCommonSectionFactory Class, REX.ContentGenerator.Converters Namespace, RVTCommonSectionFactory Class

RVTCommonSectionFactory.GetRevitTypesForInit Method

RVTCommonSectionFactory.GetRevitTypesForInit Method
RVTCommonSectionFactory Class REX.ContentGenerator.Converters Namespace RVTCommonSectionFactory Class

This is GetRevitTypesForInit, a member of class RVTCommonSectionFactory.

C#
public override Type[] GetRevitTypesForInit();
Class

RVTCommonSectionFactory Class

Links
RVTCommonSectionFactory Class, REX.ContentGenerator.Converters Namespace, RVTCommonSectionFactory Class

RVTCommonSectionFactory.OnClose Method

RVTCommonSectionFactory.OnClose Method
RVTCommonSectionFactory Class REX.ContentGenerator.Converters Namespace RVTCommonSectionFactory Class

This is OnClose, a member of class RVTCommonSectionFactory.

C#
public override bool OnClose();
Class

RVTCommonSectionFactory Class

Links
RVTCommonSectionFactory Class, REX.ContentGenerator.Converters Namespace, RVTCommonSectionFactory Class

RVTCommonSectionFactory.Recalculate Method

RVTCommonSectionFactory.Recalculate Method
RVTCommonSectionFactory Class REX.ContentGenerator.Converters Namespace RVTCommonSectionFactory Class

This is Recalculate, a member of class RVTCommonSectionFactory.

C#
public override REXDescription Recalculate(REXDescription DBdesc, bool fromInterface, ECategoryType category, bool create_new);
Class

RVTCommonSectionFactory Class

Links
RVTCommonSectionFactory Class, REX.ContentGenerator.Converters Namespace, RVTCommonSectionFactory Class

RVTCommonSectionFactory.ValidateElement Method

RVTCommonSectionFactory.ValidateElement Method
RVTCommonSectionFactory Class REX.ContentGenerator.Converters Namespace RVTCommonSectionFactory Class

This is ValidateElement, a member of class RVTCommonSectionFactory.

C#
public override bool ValidateElement(RevitElement el);
Class

RVTCommonSectionFactory Class

Links
RVTCommonSectionFactory Class, REX.ContentGenerator.Converters Namespace, RVTCommonSectionFactory Class

RVTCustomFactory Class

RVTCustomFactory Class
REX.ContentGenerator.Converters Namespace Legend Members Public Methods RVTCustomFactory Methods

This is class REX.ContentGenerator.Converters.RVTCustomFactory.

Class Hierarchy
C#
public class RVTCustomFactory<T_REXFamilyType, T_REXDescription> : RVTFamilyFactory where T_REXFamilyType : new() where T_REXDescription : new();
Namespace

REX.ContentGenerator.Converters Namespace

Public Methods
Public Method | Description
RVTCustomFactory | This is RVTCustomFactory, a member of class RVTCustomFactory.
RVTCustomFactory Methods
RVTCustomFactory Methods | Description
AddElement2FamList | This is AddElement2FamList, a member of class RVTCustomFactory.
AddElement2FamList | This is AddElement2FamList, a member of class RVTCustomFactory.
GetExistingNames | This is GetExistingNames, a member of class RVTCustomFactory.
GetRevitTypesForInit | This is GetRevitTypesForInit, a member of class RVTCustomFactory.
GetSubCategory | This is GetSubCategory, a member of class RVTCustomFactory.
Recalculate | This is Recalculate, a member of class RVTCustomFactory.
Recalculate | This is Recalculate, a member of class RVTCustomFactory.
ValidateElement | This is ValidateElement, a member of class RVTCustomFactory.
Links
REX.ContentGenerator.Converters Namespace, Legend, Members, Public Methods, RVTCustomFactory Methods

RVTCustomFactory.RVTCustomFactory Constructor

RVTCustomFactory.RVTCustomFactory Constructor
RVTCustomFactory Class REX.ContentGenerator.Converters Namespace RVTCustomFactory Class

This is RVTCustomFactory, a member of class RVTCustomFactory.

C#
public RVTCustomFactory(BuiltInCategory rvtCategory, string categoryName, RvtConversionSettings Settings);
Class

RVTCustomFactory Class

Links
RVTCustomFactory Class, REX.ContentGenerator.Converters Namespace, RVTCustomFactory Class

RVTCustomFactory.AddElement2FamList Method (Element)

RVTCustomFactory.AddElement2FamList Method (Element)
RVTCustomFactory Class REX.ContentGenerator.Converters Namespace RVTCustomFactory Class

This is AddElement2FamList, a member of class RVTCustomFactory.

C#
public override bool AddElement2FamList(Element el);
Class

RVTCustomFactory Class

Links
RVTCustomFactory Class, REX.ContentGenerator.Converters Namespace, RVTCustomFactory Class

RVTCustomFactory.AddElement2FamList Method (Element, REXFamilyType, bool)

RVTCustomFactory.AddElement2FamList Method (Element, REXFamilyType, bool)
RVTCustomFactory Class REX.ContentGenerator.Converters Namespace RVTCustomFactory Class

This is AddElement2FamList, a member of class RVTCustomFactory.

C#
public override bool AddElement2FamList(Element el, REXFamilyType ft, bool addToDict);
Class

RVTCustomFactory Class

Links
RVTCustomFactory Class, REX.ContentGenerator.Converters Namespace, RVTCustomFactory Class

RVTCustomFactory.GetExistingNames Method

RVTCustomFactory.GetExistingNames Method
RVTCustomFactory Class REX.ContentGenerator.Converters Namespace RVTCustomFactory Class

This is GetExistingNames, a member of class RVTCustomFactory.

C#
public override List<string> GetExistingNames(REXFamilyType obj, bool type);
Class

RVTCustomFactory Class

Links
RVTCustomFactory Class, REX.ContentGenerator.Converters Namespace, RVTCustomFactory Class

RVTCustomFactory.GetRevitTypesForInit Method

RVTCustomFactory.GetRevitTypesForInit Method
RVTCustomFactory Class REX.ContentGenerator.Converters Namespace RVTCustomFactory Class

This is GetRevitTypesForInit, a member of class RVTCustomFactory.

C#
public override Type[] GetRevitTypesForInit();
Class

RVTCustomFactory Class

Links
RVTCustomFactory Class, REX.ContentGenerator.Converters Namespace, RVTCustomFactory Class

RVTCustomFactory.GetSubCategory Method

RVTCustomFactory.GetSubCategory Method
RVTCustomFactory Class REX.ContentGenerator.Converters Namespace RVTCustomFactory Class

This is GetSubCategory, a member of class RVTCustomFactory.

C#
public override string GetSubCategory();
Class

RVTCustomFactory Class

Links
RVTCustomFactory Class, REX.ContentGenerator.Converters Namespace, RVTCustomFactory Class

RVTCustomFactory.Recalculate Method (REXDescription, bool, ECategoryType, bool)

RVTCustomFactory.Recalculate Method (REXDescription, bool, ECategoryType, bool)
RVTCustomFactory Class REX.ContentGenerator.Converters Namespace RVTCustomFactory Class

This is Recalculate, a member of class RVTCustomFactory.

C#