Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

IComboEditControl Interface Members

IComboEditControl Interface Members
IComboEditControl Interface Legend
Members
IComboEditControl Methods
IComboEditControl Methods | Description
Editable | Gets a value indicating whether the control is editable.
GetItems | Gets the collection of the items contained in the control.
GetSelectedIndex | Gets the index specifying the currently selected item.
SetSelectedIndex | Sets the index specifying the currently selected item.

IComboEditControl Methods

IComboEditControl Methods
IComboEditControl Interface Legend
IComboEditControl Methods
IComboEditControl Methods | Description
Editable | Gets a value indicating whether the control is editable.
GetItems | Gets the collection of the items contained in the control.
GetSelectedIndex | Gets the index specifying the currently selected item.
SetSelectedIndex | Sets the index specifying the currently selected item.

Legend

Legend
IEditControl Interface
Legend
Method
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

IEditControl Interface Members

IEditControl Interface Members
IEditControl Interface Legend
Members
IEditControl Methods
IEditControl Methods | Description
GetBackground | Gets the background of the control.
GetEnable | Indicates whether the control is enabled.
GetText | Gets the text contents of the control.
SetBackground | Sets the background of the control.
SetText | Sets the text contents of the control.

IEditControl Methods

IEditControl Methods
IEditControl Interface Legend
IEditControl Methods
IEditControl Methods | Description
GetBackground | Gets the background of the control.
GetEnable | Indicates whether the control is enabled.
GetText | Gets the text contents of the control.
SetBackground | Sets the background of the control.
SetText | Sets the text contents of the control.

Legend

Legend
IUnitObject2 Interface
Legend
Method
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

IUnitObject2 Interface Members

IUnitObject2 Interface Members
IUnitObject2 Interface Legend
Members
IUnitObject2 Methods
IUnitObject2 Methods | Description
ValidateComplexValue | Validates the complex (list) value of the double type.
ValidateComplexValue | Validates the complex (list) value of the string type.
ValidateValue | Validates the input value of the double type.
ValidateValue | Validates the value of the string type.

IUnitObject2 Methods

IUnitObject2 Methods
IUnitObject2 Interface Legend
IUnitObject2 Methods
IUnitObject2 Methods | Description
ValidateComplexValue | Validates the complex (list) value of the double type.
ValidateComplexValue | Validates the complex (list) value of the string type.
ValidateValue | Validates the input value of the double type.
ValidateValue | Validates the value of the string type.

Legend

Legend
IUnitObject3 Interface
Legend
Method
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

IUnitObject3 Interface Members

IUnitObject3 Interface Members
IUnitObject3 Interface Legend
Members
IUnitObject3 Methods
IUnitObject3 Methods | Description
RefreshValidationStatus | Refreshes the validation status.
ValueFormat | Returns a text containing an expression formatted according the current settings of the element.
ValueFormat | Returns a text containing an expression formatted according the current settings of the element.
ValueParse | Converts the specified text to the numeric value according the current settings of the element.

IUnitObject3 Methods

IUnitObject3 Methods
IUnitObject3 Interface Legend
IUnitObject3 Methods
IUnitObject3 Methods | Description
RefreshValidationStatus | Refreshes the validation status.
ValueFormat | Returns a text containing an expression formatted according the current settings of the element.
ValueFormat | Returns a text containing an expression formatted according the current settings of the element.
ValueParse | Converts the specified text to the numeric value according the current settings of the element.

Legend

Legend
IUnitObject Interface
Legend
Method
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

IUnitObject Interface Members

IUnitObject Interface Members
IUnitObject Interface Legend
Members
IUnitObject Methods
IUnitObject Methods | Description
AddEnabledChangedHandler | Adds the handler to the event raised when the element changes it's enable state.
AddLostFocusHandler | Adds the handler to the event raised when the element loses logical focus.
AddTextChangedHandler | Adds the handler to the event raised when text changes.
GetComplexDoubleValue | Gets the complex (list) value of the double type.
GetComplexStringValue | Gets the complex (list) string value of the string type.
GetFullName | Gets the full name of the control.
GetState | Gets the current state of the control.
GetUniqueName | Gets the unique name of the control.
GetValue | Gets the value of the double type.
Reset | Resets the instance of the element.
SetComplexValue | Sets the complex (list) value of the double type.
SetComplexValue | Sets the complex (list) value of the string type.
SetExternalUnitBody | This is SetExternalUnitBody, a member of class IUnitObject.
SetUserValidation | Sets the user validation method.
SetUserValidationComplex | Sets the user validation method for complex values (list).
SetValue | Sets the value of the double type.
SetValue | Sets the value of the string type.
IUnitObject Properties
IUnitObject Properties | Description
Complex | Gets or sets a value indicating whether this the control is in the complex mode (list mode).
ControlState | Gets the state of the control.
DataType | Gets or sets the type of the data in the control.
EngineeringFormat | Gets or sets a value indicating whether the text of the control should be formatted in according to the engineering (expotential) format.
RangeMax | Gets or sets the highest possible value.
RangeMaxCheck | Gets or sets a value indicating whether the value should be validated due to the RangeMax.
RangeMin | Gets or sets the minimum possible value.
RangeMinCheck | Gets or sets a value indicating whether the value should be validated due to the RangeMin.
RoundingFractional | Gets or sets the rounding for fractional units.
RoundingIncrement | Gets or sets the rounding increment.
Separator | Gets or sets the decimal separator.
Tag | Gets or sets the tag.
Text | Gets the text contents of the control.
UnitSymbol | Gets or sets the unit symbol.

IUnitObject Methods

IUnitObject Methods
IUnitObject Interface Legend
IUnitObject Methods
IUnitObject Methods | Description
AddEnabledChangedHandler | Adds the handler to the event raised when the element changes it's enable state.
AddLostFocusHandler | Adds the handler to the event raised when the element loses logical focus.
AddTextChangedHandler | Adds the handler to the event raised when text changes.
GetComplexDoubleValue | Gets the complex (list) value of the double type.
GetComplexStringValue | Gets the complex (list) string value of the string type.
GetFullName | Gets the full name of the control.
GetState | Gets the current state of the control.
GetUniqueName | Gets the unique name of the control.