cont.LineTo(new REXxyz(2, 0));
cont.LineTo(new REXxyz(2, 1));
REXxyz normal = new REXxyz(0, 0, 1);

//Getting Rebar object from contour.
REXFamilyType_Rebar r = rex.GetRebar(cont, normal, famRebarType, false, hookStart, hookEnd, "barlib7_iso","12");

The rebar object can be used by other converters to create a rebar of the specific shape (e.g. RVTFamilyConverter: CreateRebar).

Example

Example
REXFamilyConverter.GetRebar Method (REX.ContentGenerator.Geometry.Contour_3D, REXxyz, REXFamilyType_RebarBarType, bool, REXFamilyType_RebarHook, REXFamilyType_RebarHook, string)

The example shows how to get rebar object based on the specific contour.

//Initializing converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Rebar data (it can be taken from different sources e.g. Revit).
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Reinf";
REXFamilyType_RebarBarType famRebarType = rex.GetFamilyRebarType("Grade 40", "#8", "bar_ACI 318-08", directory);
REXFamilyType_RebarHook hookStart = new REXFamilyType_RebarHook();
hookStart.Parameters.Angle = EHookAngles.none;
REXFamilyType_RebarHook hookEnd = new REXFamilyType_RebarHook();
hookEnd.Parameters.Angle = EHookAngles.none;

//Contour.
REX.ContentGenerator.Geometry.Contour_3D cont = new REX.ContentGenerator.Geometry.Contour_3D();
cont.StartContour(new REXxyz(0, 0));
cont.LineTo(new REXxyz(2, 0));
cont.LineTo(new REXxyz(2, 1));
REXxyz normal = new REXxyz(0, 0, 1);

//Getting Rebar object from contour.
REXFamilyType_Rebar r = rex.GetRebar(cont, normal, famRebarType, false, hookStart, hookEnd, "barlib7_iso");

The rebar object can be used by other converters to create a rebar of the specific shape (e.g. RVTFamilyConverter: CreateRebar).

Example

Example
REXFamilyConverter.GetRoundRebar Method

The example shows how to get a round rebar.

//Initializing converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Rebar data (it can be taken from different sources e.g. Revit).
string directory = @"C:Documents and SettingsAll UsersApplication DataAutodeskStructuralCommon Data2011DataReinf";
REXFamilyType_RebarBarType famRebarType = rex.GetFamilyRebarType("Grade 40", "#8", "bar_ACI 318-08", directory);

REXFamilyType_RebarHook hookStart = new REXFamilyType_RebarHook();
hookStart.Parameters.Angle = EHookAngles.none;

REXFamilyType_RebarHook hookEnd = new REXFamilyType_RebarHook();
hookEnd.Parameters.Angle = EHookAngles.none;

REX.Common.Geometry.REXxyz normal = new REX.Common.Geometry.REXxyz(0, 0, 1);
REX.Common.Geometry.REXxyz center = new REX.Common.Geometry.REXxyz(0, 0, 0);
double diameter = 1;
double lapSplice = 0.2;

//Getting Rebar object from contour.
REXFamilyType_Rebar r = rex.GetRoundRebar(center,normal,diameter,lapSplice, famRebarType, false, hookStart, hookEnd);

The rebar object can be used by other converters to create a rebar of the specific shape (e.g. RVTFamilyConverter: CreateRebar).

Example

Example
REXFamilyConverter.GetSpiralRebar Method

The example shows how to get a round rebar.

//Initializing converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Rebar data (it can be taken from different sources e.g. Revit).
string directory = @"C:Documents and SettingsAll UsersApplication DataAutodeskStructuralCommon Data2011DataReinf";
REXFamilyType_RebarBarType famRebarType = rex.GetFamilyRebarType("Grade 40", "#8", "bar_ACI 318-08", directory);

REXFamilyType_RebarHook hookStart = new REXFamilyType_RebarHook();
hookStart.Parameters.Angle = EHookAngles.none;

REXFamilyType_RebarHook hookEnd = new REXFamilyType_RebarHook();
hookEnd.Parameters.Angle = EHookAngles.none;

REX.Common.Geometry.REXxyz normal = new REX.Common.Geometry.REXxyz(0, 0, 1);
REX.Common.Geometry.REXxyz center = new REX.Common.Geometry.REXxyz(0, 0, 0);
double diameter = 1;
double height = 2;
double pitch = 0.3;

//Getting Rebar object from contour.
REXFamilyType_Rebar r = rex.GetSpiralRebar(center, normal, diameter,height,pitch, famRebarType, false, hookStart, hookEnd);

The rebar object can be used by other converters to create a rebar of the specific shape (e.g. RVTFamilyConverter: CreateRebar).

Legend

Legend
REXMaterialFactory Class
Legend
Constructor
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXMaterialFactory Class Members

REXMaterialFactory Class Members
REXMaterialFactory Class Legend
Members
Public Methods
Public Method | Description
REXMaterialFactory | This is REXMaterialFactory, a member of class REXMaterialFactory.
REXMaterialFactory Methods
REXMaterialFactory Methods | Description
CompareRows | This is CompareRows, a member of class REXMaterialFactory.
FillDBDescription | This is FillDBDescription, a member of class REXMaterialFactory.
FillDBObjectCollection | This is FillDBObjectCollection, a member of class REXMaterialFactory.
FillFamilyTypeProperties | This is FillFamilyTypeProperties, a member of class REXMaterialFactory.
FillFamilyTypeProperties | This is FillFamilyTypeProperties, a member of class REXMaterialFactory.
GetAliasName | This is GetAliasName, a member of class REXMaterialFactory.
GetFamiliesOfAlias | This is GetFamiliesOfAlias, a member of class REXMaterialFactory.
GetFamilyDefault | This is GetFamilyDefault, a member of class REXMaterialFactory.
GetFamilyOfAlias | This is GetFamilyOfAlias, a member of class REXMaterialFactory.
GetFamilyTemplate | This is GetFamilyTemplate, a member of class REXMaterialFactory.
GetMaterial | This is GetMaterial, a member of class REXMaterialFactory.
GetNewDescription | This is GetNewDescription, a member of class REXMaterialFactory.
GetNewDescription | This is GetNewDescription, a member of class REXMaterialFactory.
GetNewFamily | This is GetNewFamily, a member of class REXMaterialFactory.
GetPropertiesADO | This is GetPropertiesADO, a member of class REXMaterialFactory.
GetPropertiesDBRoot | This is GetPropertiesDBRoot, a member of class REXMaterialFactory.
RecalculatDBDesc | This is RecalculatDBDesc, a member of class REXMaterialFactory.
ValidateDB | This is ValidateDB, a member of class REXMaterialFactory.
ValidateDB | This is ValidateDB, a member of class REXMaterialFactory.

REXMaterialFactory Methods

REXMaterialFactory Methods
REXMaterialFactory Class Legend
REXMaterialFactory Methods
REXMaterialFactory Methods | Description
CompareRows | This is CompareRows, a member of class REXMaterialFactory.
FillDBDescription | This is FillDBDescription, a member of class REXMaterialFactory.
FillDBObjectCollection | This is FillDBObjectCollection, a member of class REXMaterialFactory.
FillFamilyTypeProperties | This is FillFamilyTypeProperties, a member of class REXMaterialFactory.
FillFamilyTypeProperties | This is FillFamilyTypeProperties, a member of class REXMaterialFactory.
GetAliasName | This is GetAliasName, a member of class REXMaterialFactory.
GetFamiliesOfAlias | This is GetFamiliesOfAlias, a member of class REXMaterialFactory.
GetFamilyDefault | This is GetFamilyDefault, a member of class REXMaterialFactory.
GetFamilyOfAlias | This is GetFamilyOfAlias, a member of class REXMaterialFactory.
GetFamilyTemplate | This is GetFamilyTemplate, a member of class REXMaterialFactory.
GetMaterial | This is GetMaterial, a member of class REXMaterialFactory.
GetNewDescription | This is GetNewDescription, a member of class REXMaterialFactory.
GetNewDescription | This is GetNewDescription, a member of class REXMaterialFactory.
GetNewFamily | This is GetNewFamily, a member of class REXMaterialFactory.
GetPropertiesADO | This is GetPropertiesADO, a member of class REXMaterialFactory.
GetPropertiesDBRoot | This is GetPropertiesDBRoot, a member of class REXMaterialFactory.
RecalculatDBDesc | This is RecalculatDBDesc, a member of class REXMaterialFactory.