Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

IREXExtension Interface Members

IREXExtension Interface Members
IREXExtension Interface Legend
Members
IREXExtension Methods
IREXExtension Methods | Description
OnActivateLayout | Activates or deactivates layout - module can modify layout before or after activation.
OnCanClose | If returns true, dialog will close after OK button clicked.
OnCanClose | Called when closing module.
OnCanRun | Checks status of module and shows some information for user if modult can't run action.
OnClear | Called when clear data.
OnClose | Called during closing module.
OnCommand | Called when command.
OnCreate | Creates needed structures and verify needs.
OnCreateDialogs | Creates sub dialogs.
OnCreateLayout | Creates layout items and setups layout.
OnDataLoad | Called when data are loaded.
OnDataLoaded | Called when data are loaded.
OnDataSave | Called when data are saved.
OnDataSaved | Called when data are saved.
OnErrorSelected | Called when error selected on errors list dialog.
OnEvent | Called when event.
OnGetText | Get specified text from resources.
OnInitialize | Called when initialize.
OnLoadTemplate | Called when load template.
OnPreferencesChanged | Called when preferences changed.
OnRun | Run process calculations or other operations.
OnSaveTemplate | Called when save template.
OnSetData | Get data from dialogs and sets Data's strucutres.
OnSetDialogs | Set data in dialogs.
OnShowResults | Shows results.
OnUpdateDialogs | Called when update dialogs.

IREXExtension Methods

IREXExtension Methods
IREXExtension Interface Legend
IREXExtension Methods
IREXExtension Methods | Description
OnActivateLayout | Activates or deactivates layout - module can modify layout before or after activation.
OnCanClose | If returns true, dialog will close after OK button clicked.
OnCanClose | Called when closing module.
OnCanRun | Checks status of module and shows some information for user if modult can't run action.
OnClear | Called when clear data.
OnClose | Called during closing module.
OnCommand | Called when command.
OnCreate | Creates needed structures and verify needs.
OnCreateDialogs | Creates sub dialogs.
OnCreateLayout | Creates layout items and setups layout.
OnDataLoad | Called when data are loaded.
OnDataLoaded | Called when data are loaded.
OnDataSave | Called when data are saved.
OnDataSaved | Called when data are saved.
OnErrorSelected | Called when error selected on errors list dialog.
OnEvent | Called when event.
OnGetText | Get specified text from resources.
OnInitialize | Called when initialize.
OnLoadTemplate | Called when load template.
OnPreferencesChanged | Called when preferences changed.
OnRun | Run process calculations or other operations.
OnSaveTemplate | Called when save template.
OnSetData | Get data from dialogs and sets Data's strucutres.
OnSetDialogs | Set data in dialogs.
OnShowResults | Shows results.
OnUpdateDialogs | Called when update dialogs.

Legend

Legend
IREXExtensionAccess2 Interface
Legend
Method
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

IREXExtensionAccess2 Interface Members

IREXExtensionAccess2 Interface Members
IREXExtensionAccess2 Interface Legend
Members
IREXExtensionAccess2 Methods
IREXExtensionAccess2 Methods | Description
Event | Events the specified ev.

IREXExtensionAccess2 Methods

IREXExtensionAccess2 Methods
IREXExtensionAccess2 Interface Legend
IREXExtensionAccess2 Methods
IREXExtensionAccess2 Methods | Description
Event | Events the specified ev.

Legend

Legend
IREXExtensionAccess3 Interface
Legend
Method
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

IREXExtensionAccess3 Interface Members

IREXExtensionAccess3 Interface Members
IREXExtensionAccess3 Interface Legend
Members
IREXExtensionAccess3 Methods
IREXExtensionAccess3 Methods | Description
Detach | Detaches this instance.

IREXExtensionAccess3 Methods

IREXExtensionAccess3 Methods
IREXExtensionAccess3 Interface Legend
IREXExtensionAccess3 Methods
IREXExtensionAccess3 Methods | Description
Detach | Detaches this instance.

Legend

Legend
IREXExtensionAccess Interface
Legend
Method
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

IREXExtensionAccess Interface Members

IREXExtensionAccess Interface Members
IREXExtensionAccess Interface Legend
Members
IREXExtensionAccess Methods
IREXExtensionAccess Methods | Description
Create | Reads some data from parent application and set system display units.
Destroy | Destroys and resets some objects connected to parent application.
Initialize | Initializes this instance.
Update | Reads some data from parent application and set system display units.

IREXExtensionAccess Methods

IREXExtensionAccess Methods
IREXExtensionAccess Interface Legend
IREXExtensionAccess Methods
IREXExtensionAccess Methods | Description
Create | Reads some data from parent application and set system display units.
Destroy | Destroys and resets some objects connected to parent application.
Initialize | Initializes this instance.
Update | Reads some data from parent application and set system display units.

Legend

Legend
IREXExtensionAccessUnitsControl Interface
Legend
Method
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

IREXExtensionAccessUnitsControl Interface Members

IREXExtensionAccessUnitsControl Interface Members
IREXExtensionAccessUnitsControl Interface Legend
Members
IREXExtensionAccessUnitsControl Methods
IREXExtensionAccessUnitsControl Methods | Description
Setup | Setups this instance.
Update | Updates this instance.

IREXExtensionAccessUnitsControl Methods

IREXExtensionAccessUnitsControl Methods
IREXExtensionAccessUnitsControl Interface Legend
IREXExtensionAccessUnitsControl Methods
IREXExtensionAccessUnitsControl Methods | Description
Setup | Setups this instance.
Update | Updates this instance.

Legend

Legend
IREXThisExtension Interface
Legend
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

IREXThisExtension Interface Members

IREXThisExtension Interface Members
IREXThisExtension Interface Legend
Members
IREXThisExtension Properties
IREXThisExtension Properties | Description
ThisApplication | This is ThisApplication, a member of class IREXThisExtension.
ThisContext | This is ThisContext, a member of class IREXThisExtension.
ThisExtension | This is ThisExtension, a member of class IREXThisExtension.

Members

Legend
Legend
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

IREXThisExtension Properties

IREXThisExtension Properties
IREXThisExtension Interface Legend
IREXThisExtension Properties
IREXThisExtension Properties | Description
ThisApplication | This is ThisApplication, a member of class IREXThisExtension.
ThisContext | This is ThisContext, a member of class IREXThisExtension.
ThisExtension | This is ThisExtension, a member of class IREXThisExtension.