REXSectionTypeAnalyzer_TUBE.VectorDrivenAnalysis Method
REXSectionTypeAnalyzer_TUBE Class REX.ContentGenerator.Geometry Namespace REXSectionTypeAnalyzer_TUBE Class

This is VectorDrivenAnalysis, a member of class REXSectionTypeAnalyzer_TUBE.

C#
public override bool VectorDrivenAnalysis();
Class

REXSectionTypeAnalyzer_TUBE Class

Links
REXSectionTypeAnalyzer_TUBE Class, REX.ContentGenerator.Geometry Namespace, REXSectionTypeAnalyzer_TUBE Class

REXSectionTypeAnalyzer_Z Class

REXSectionTypeAnalyzer_Z Class
REX.ContentGenerator.Geometry Namespace

This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_Z.

Class Hierarchy
C#
public class REXSectionTypeAnalyzer_Z : REXSectionTypeAnalyzer;
Namespace

REX.ContentGenerator.Geometry Namespace

Links
REX.ContentGenerator.Geometry Namespace
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REX.ContentGenerator.Geometry.EArcDir Enumeration

REX.ContentGenerator.Geometry.EArcDir Enumeration
REX.ContentGenerator.Geometry Namespace

Describes the direction of an arc.

C#
public enum EArcDir {
  CCW,
  CW
}
Members
Members | Description
CCW | Counterclockwise.
CW | Clockwise.
Description
Namespace

REX.ContentGenerator.Geometry Namespace

Links
REX.ContentGenerator.Geometry Namespace
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REX.ContentGenerator.Geometry.EContElemType Enumeration

REX.ContentGenerator.Geometry.EContElemType Enumeration
REX.ContentGenerator.Geometry Namespace

Represents the type of the element.

C#
public enum EContElemType {
  contour,
  line,
  arc,
  circle
}
Members
Members | Description
contour | Contour.
line | Line.
arc | Arc defined by start, middle point and end.
circle | Circle.
Description
Namespace

REX.ContentGenerator.Geometry Namespace

Links
REX.ContentGenerator.Geometry Namespace
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REX.ContentGenerator.Geometry.ECoords Enumeration

REX.ContentGenerator.Geometry.ECoords Enumeration
REX.ContentGenerator.Geometry Namespace

Describes the coordinate system type.

C#
public enum ECoords {
  XY,
  XZ,
  YZ,
  XYZ,
  USER
}
Members
Members | Description
XY | XY plane.
XZ | XZ plane.
YZ | YZ plane.
XYZ | 3D space.
USER | User.
Description
Namespace

REX.ContentGenerator.Geometry Namespace

Links
REX.ContentGenerator.Geometry Namespace
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REX.ContentGenerator.Map Namespace

Previous | Next
REX.ContentGenerator.Map Namespace
Legend Classes

This is namespace REX.ContentGenerator.Map.

Classes
Class | Description
ContentMapper | Provides interface to the mapping system of the ContentGenerator.
REXContentMapCategorySettings | Represents settings for a specific category of elements.
REXContentMapDialogSettings | Represents settings for the map dialog.
REXContentMapper | Provides interface to the mapping system of the Content Generator in REX context.
RVTContentMapper | Provides interface to the mapping system of the Content Generator in Revit context.
Links
Legend, Classes
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

ContentMapper Class

ContentMapper Class
REX.ContentGenerator.Map Namespace Legend Members ContentMapper Methods ContentMapper Properties

Provides interface to the mapping system of the ContentGenerator.

Class Hierarchy
C#
public abstract class ContentMapper;
Description
Namespace

REX.ContentGenerator.Map Namespace

ContentMapper Methods
ContentMapper Methods | Description
AddLabel | Adds the label to the list.
ApplyMapControl | Applies the map control.
CloseMapControl | Closes the map control.
CreateMapControl | Creates the map control.
GetLabels | Gets the labels.
LaunchMapDialog | Launches the map dialog.
LoadUserMap | Loads the user map to the Content Generator.
RefreshMapControl | Refreshes the map control.
ReloadGlobalMap | Reloads the global map.
ResetUserMap | Resets the user map.
SaveGlobalMap | Saves the global map.
SaveUserMap | Saves the user map.
SetDefaults | Sets defaults in the mapping system.
SetREXConverter | Sets the REX converter.
ContentMapper Properties
ContentMapper Properties | Description
DialogSettings | Gets the dialog's settings.
Links
REX.ContentGenerator.Map Namespace, Legend, Members, ContentMapper Methods, ContentMapper Properties

ContentMapper.AddLabel Method

ContentMapper.AddLabel Method
ContentMapper Class REX.ContentGenerator.Map Namespace Example ContentMapper Class

Adds the label to the list.

C#
public void AddLabel(REXFamilyType_Label fam);
Parameters
Parameters | Description
fam | The label.
Description
Example

The example shows how to use labels in a mapping system.

//Revit converter
RVTFamilyConverter rvt = new RVTFamilyConverter(ThisExtension.Revit.CommandData(), true);
rvt.Settings.Labels = true;

//-example label without description
REXFamilyType_Label label1 = new REXFamilyType_Label(ECategoryType.SECTION_DB, "test1");

//-example label with section defined manually
REXFamilyType_Label label2 = new REXFamilyType_Label(ECategoryType.SECTION_DB, "test2");
REXFamilyType_ParamSection paramSection = new REXFamilyType_ParamSection();
paramSection.Material = EMaterial.CONCRETE;
paramSection.ElementType = REX.ContentGenerator.Families.EElementType.BEAM;
paramSection.Parameters.SectionType = ESectionType.RECT;
paramSection.Parameters.Dimensions.b = 1;
paramSection.Parameters.Dimensions.h = 1;
label2.Parameters.LabelFamilyDescription = paramSection;

//-definition of category
rvt.ContentMapper.DialogSettings.SectionSettings.LabelCategoryName = "MyCategory";

//-adding labels to list
rvt.ContentMapper.DialogSettings.SectionSettings.Labels.Add(label1);
rvt.ContentMapper.DialogSettings.SectionSettings.Labels.Add(label2);

//Map dialog.
Autodesk.Revit.DB.FilteredElementCollector collector = new FilteredElementCollector(ThisExtension.Revit.ActiveDocument);
List<Element> Sections = new List<Element>();
//Sections.
rvt.ContentMapper.DialogSettings.SectionSettings.Visible = true;
//-adding elements
foreach (FamilySymbol obj in collector.OfClass(typeof(FamilySymbol)).ToElements())
{
    if(((BuiltInCategory)obj.Category.Id.IntegerValue) == BuiltInCategory.OST_StructuralFraming)
        rvt.ContentMapper.DialogSettings.SectionSettings.Elements.Add(obj);
}
if (rvt.ContentMapper.DialogSettings.SectionSettings.Elements.Count > 1)
{
    rvt.ContentMapper.SetMapElement(true, (Element)rvt.ContentMapper.DialogSettings.SectionSettings.Elements[0], label1, ECategoryType.SECTION_DB);
    rvt.ContentMapper.SetMapElement(true, (Element)rvt.ContentMapper.DialogSettings.SectionSettings.Elements[1], label2, ECategoryType.SECTION_DB);
}
//-databases start list
rvt.ContentMapper.DialogSettings.SectionSettings.Databases.Add("Rcatpro");

//Materials.
rvt.ContentMapper.DialogSettings.MaterialSettings.Visible = false;

//Rebars.
rvt.ContentMapper.DialogSettings.RebarTypeSettings.Visible = false;

//Launching
Autodesk.REX.Common.REXContext cont = ThisExtension.Context;
bool ok = rvt.ContentMapper.LaunchMapDialog(ref cont);

if (ok)
{
        REXFamilyType sect = rvt.ContentMapper.GetMapElement(Sections[0],ECategoryType.SECTION_DB);
}
Class

ContentMapper Class

Links