public double ValueParse(String value);
Parameters
Parameters | Description
value | The text.
Returns

The converted value.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.AcceptsTab Property

REXComboBox.AcceptsTab Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

AcceptsTab property derived from the TextBox class.

C#
[Browsable(false)]
public new Boolean AcceptsTab;
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.ColorBackgroundDisabled Property

REXComboBox.ColorBackgroundDisabled Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets or sets the background for the disabled state of the control in the hidden background mode.

C#
[Browsable(true)]
[Category("Appearance")]
public Color ColorBackgroundDisabled;
Description

The background.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.ColorBackgroundError Property

REXComboBox.ColorBackgroundError Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets or sets the background for the Error state of the control.

C#
[Browsable(true)]
[Category("Appearance")]
[DefaultValue(typeof(Color), "LightCoral")]
public Color ColorBackgroundError;
Description

The Error background.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.ColorBackgroundNeutral Property

REXComboBox.ColorBackgroundNeutral Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets or sets the background for the neutral state of the control.

C#
[Browsable(true)]
[Category("Appearance")]
[DefaultValue(typeof(SystemColors), "Window")]
public Color ColorBackgroundNeutral;
Description

The neutral background.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.ColorBackgroundOK Property

REXComboBox.ColorBackgroundOK Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets or sets the background for the OK state of the control.

C#
[Browsable(true)]
[Category("Appearance")]
[DefaultValue(typeof(Color), "LightGreen")]
[Description("test")]
public Color ColorBackgroundOK;
Description

The OK background.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.ColorBackgroundStandard Property

REXComboBox.ColorBackgroundStandard Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets or sets the background for the disabled state of the control.

C#
[Browsable(true)]
[Category("Appearance")]
[DefaultValue(typeof(Color), "LightBlue")]
public Color ColorBackgroundStandard;
Description

The background.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.Complex Property

REXComboBox.Complex Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets or sets a value indicating whether this REXEditControlEngine supports complex (list) values.

C#
[Category("Complex")]
[Browsable(true)]
public Boolean Complex;
Description

True if the engine supports complex values; otherwise false.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.ComplexSeparator Property

REXComboBox.ComplexSeparator Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets or sets the complex (list) separator.

C#
[Category("Complex")]
[Browsable(true)]
[DefaultValue(";")]
public string ComplexSeparator;
Description

The complex separator.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.ComplexSpaceSeparator Property

REXComboBox.ComplexSpaceSeparator Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets or sets a value indicating whether a space should be respected as a list separator.

C#
[Category("Complex")]
[Browsable(true)]
public Boolean ComplexSpaceSeparator;
Description

True if space respected as a list separator; otherwise, false.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.ComplexUnitOnEnd Property

REXComboBox.ComplexUnitOnEnd Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets or sets a value indicating whether a unit symbol should be placed on the end of the formatted text.

C#
[Category("Complex")]
[Browsable(true)]
public Boolean ComplexUnitOnEnd;
Description

True if the unit one the end; otherwise, false.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.ControlState Property

REXComboBox.ControlState Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets the current state of the control.

C#
[Browsable(false)]
public EControlState ControlState;
Description

The state of the control.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.CorrectValue Property

REXComboBox.CorrectValue Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets or sets the correct value.

C#
[Browsable(false)]
public String CorrectValue;
Description

The correct value.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.DataType Property

REXComboBox.DataType Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets or sets the type of the data in the control.

C#
[Browsable(true)]
[Category("Data")]
public REX.Controls.Common.EControlType DataType;
Description

The type of the data.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.DropDownWidthLimit Property

REXComboBox.DropDownWidthLimit Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets or sets the drop down width limit.

C#
public int DropDownWidthLimit;
Description

The drop down width limit.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.EditBox Property

REXComboBox.EditBox Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets the reference to the REXEditBox control.

C#
public REX.Controls.Forms.REXEditBox EditBox;
Description

Enables settings for edit box mode.

The REXEditBox control.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.Enabled Property

REXComboBox.Enabled Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets or sets a value indicating whether the control can respond to user interaction.

C#
[Browsable(true)]
public new Boolean Enabled;
Returns

true if the control can respond to user interaction; otherwise, false. The default is true.

Description

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.EngineeringFormat Property

REXComboBox.EngineeringFormat Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets or sets a value indicating whether the text of the control should be formatted in according to the engineering (expotential) format.

C#
[Browsable(true)]
[Category("Data")]
[DefaultValue(false)]
public Boolean EngineeringFormat;
Description

True if engineering format; otherwise false.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class

REXComboBox.Epsilon Property

REXComboBox.Epsilon Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets or sets the accuracy.

C#
[Browsable(true)]
public double Epsilon;
Description