public override bool IsElementSupported(REXFamilyType fam, ECategoryType category);
Class

RVTSectionFactory Class

Links
RVTSectionFactory Class, REX.ContentGenerator.Converters Namespace, RVTSectionFactory Class

RVTSectionFactory.OnClose Method

RVTSectionFactory.OnClose Method
RVTSectionFactory Class REX.ContentGenerator.Converters Namespace RVTSectionFactory Class

This is OnClose, a member of class RVTSectionFactory.

C#
public override bool OnClose();
Class

RVTSectionFactory Class

Links
RVTSectionFactory Class, REX.ContentGenerator.Converters Namespace, RVTSectionFactory Class

RVTSectionFactory.Recalculate Method

RVTSectionFactory.Recalculate Method
RVTSectionFactory Class REX.ContentGenerator.Converters Namespace RVTSectionFactory Class

This is Recalculate, a member of class RVTSectionFactory.

C#
public override REXDescription Recalculate(REXDescription DBdesc, bool fromInterface, ECategoryType category, bool create_new);
Class

RVTSectionFactory Class

Links
RVTSectionFactory Class, REX.ContentGenerator.Converters Namespace, RVTSectionFactory Class

RVTSectionFactory.ResetFamilyBufor Method

RVTSectionFactory.ResetFamilyBufor Method
RVTSectionFactory Class REX.ContentGenerator.Converters Namespace RVTSectionFactory Class

This is ResetFamilyBufor, a member of class RVTSectionFactory.

C#
public override void ResetFamilyBufor();
Class

RVTSectionFactory Class

Links
RVTSectionFactory Class, REX.ContentGenerator.Converters Namespace, RVTSectionFactory Class

RVTSectionFactory.ValidateElement Method

RVTSectionFactory.ValidateElement Method
RVTSectionFactory Class REX.ContentGenerator.Converters Namespace RVTSectionFactory Class

This is ValidateElement, a member of class RVTSectionFactory.

C#
public override bool ValidateElement(RevitElement el);
Class

RVTSectionFactory Class

Links
RVTSectionFactory Class, REX.ContentGenerator.Converters Namespace, RVTSectionFactory Class

RVTSectionParamFactory Class

RVTSectionParamFactory Class
REX.ContentGenerator.Converters Namespace Legend Members Public Methods RVTSectionParamFactory Methods

This is class REX.ContentGenerator.Converters.RVTSectionParamFactory.

Class Hierarchy
C#
public class RVTSectionParamFactory : RVTCommonSectionFactory;
Namespace

REX.ContentGenerator.Converters Namespace

Public Methods
Public Method | Description
RVTSectionParamFactory | This is RVTSectionParamFactory, a member of class RVTSectionParamFactory.
RVTSectionParamFactory Methods
RVTSectionParamFactory Methods | Description
AddFamily2ProjectDictionary | This is AddFamily2ProjectDictionary, a member of class RVTSectionParamFactory.
IsElementSupported | This is IsElementSupported, a member of class RVTSectionParamFactory.
Recalculate | This is Recalculate, a member of class RVTSectionParamFactory.
Links
REX.ContentGenerator.Converters Namespace, Legend, Members, Public Methods, RVTSectionParamFactory Methods

RVTSectionParamFactory.RVTSectionParamFactory Constructor

RVTSectionParamFactory.RVTSectionParamFactory Constructor
RVTSectionParamFactory Class REX.ContentGenerator.Converters Namespace RVTSectionParamFactory Class

This is RVTSectionParamFactory, a member of class RVTSectionParamFactory.

C#
public RVTSectionParamFactory(RvtConversionSettings Settings, CompositeLevel Families, RVTDBSectionFactory factoryDB);
Class

RVTSectionParamFactory Class

Links
RVTSectionParamFactory Class, REX.ContentGenerator.Converters Namespace, RVTSectionParamFactory Class

RVTSectionParamFactory.AddFamily2ProjectDictionary Method

RVTSectionParamFactory.AddFamily2ProjectDictionary Method
RVTSectionParamFactory Class REX.ContentGenerator.Converters Namespace RVTSectionParamFactory Class

This is AddFamily2ProjectDictionary, a member of class RVTSectionParamFactory.

C#
public override void AddFamily2ProjectDictionary(Autodesk.Revit.DB.Element el, Autodesk.Revit.DB.Element idElement, REXFamilyType fam);
Class

RVTSectionParamFactory Class

Links
RVTSectionParamFactory Class, REX.ContentGenerator.Converters Namespace, RVTSectionParamFactory Class

RVTSectionParamFactory.IsElementSupported Method

RVTSectionParamFactory.IsElementSupported Method
RVTSectionParamFactory Class REX.ContentGenerator.Converters Namespace RVTSectionParamFactory Class

This is IsElementSupported, a member of class RVTSectionParamFactory.

C#
public override bool IsElementSupported(REXFamilyType fam, ECategoryType category);
Class

RVTSectionParamFactory Class

Links
RVTSectionParamFactory Class, REX.ContentGenerator.Converters Namespace, RVTSectionParamFactory Class

RVTSectionParamFactory.Recalculate Method

RVTSectionParamFactory.Recalculate Method
RVTSectionParamFactory Class REX.ContentGenerator.Converters Namespace RVTSectionParamFactory Class

This is Recalculate, a member of class RVTSectionParamFactory.

C#
public override REXDescription Recalculate(REXDescription DBdesc, bool fromInterface, ECategoryType category, bool create_new);
Class

RVTSectionParamFactory Class

Links
RVTSectionParamFactory Class, REX.ContentGenerator.Converters Namespace, RVTSectionParamFactory Class

IRexContentSettings Interface

IRexContentSettings Interface
REX.ContentGenerator.Converters Namespace Legend Members IRexContentSettings Methods IRexContentSettings Properties

Provides interface for the settings of the REXFamilyConverter.

Class Hierarchy
C#
public interface IRexContentSettings;
Description
Namespace

REX.ContentGenerator.Converters Namespace

IRexContentSettings Methods
IRexContentSettings Methods | Description
GetParamsForDisplayName | Gets parameters for the specified display name of the specified category.
GetParamsForField | Gets parameters for the specified name of the specified category.
GetResource | Gets the resource for the specified name of the specified category.
LoadCustomParametersFile | Loads the custom parameters file.
IRexContentSettings Properties
IRexContentSettings Properties | Description
CodeFilteredShapeAnalysis | Gets or sets a value indicating whether the filtered list of rebar shapes should be taken to consideration during rebars analysis.
DatabaseAccess | Gets or sets the database access.
Labels | Gets or sets a value indicating whether labels are taken to consideration during mapping.
MirroredShapeAnalysis | Gets or sets a value indicating whether mirrored rebar shapes should be taken to consideration during rebars analysis.
MultiSearch | Gets or sets a value indicating whether during searching databases multiply result should be returned (if false - when first result is found algorithm will stop - In case of GetDBList(List…) function will stop if any REXFamilyType in database will be found) .
MultiThread | Gets or sets a value indicating whether multithread operations should be used for database searching (only if DbRoot is used)..
ReleaseDBAfterEachAction | Gets or sets a value indicating whether the database should be released after each action (if not it will be kept in memory).
SupportUserDatabases | Gets or sets a value indicating whether users databases should be supported
Links
REX.ContentGenerator.Converters Namespace, Legend, Members, IRexContentSettings Methods, IRexContentSettings Properties

IRexContentSettings.GetParamsForDisplayName Method

IRexContentSettings.GetParamsForDisplayName Method
IRexContentSettings Interface REX.ContentGenerator.Converters Namespace IRexContentSettings Interface

Gets parameters for the specified display name of the specified category.

C#
FieldParams GetParamsForDisplayName(string generalname, ECategoryType type);
Parameters
Parameters | Description
generalname | The name of the field.
type | The category.
Returns

Return parameters.

Description
Remarks

The general name is the same name as it is shown in Content Generator

Interface

IRexContentSettings Interface

Links
IRexContentSettings Interface, REX.ContentGenerator.Converters Namespace, IRexContentSettings Interface

IRexContentSettings.GetParamsForField Method

IRexContentSettings.GetParamsForField Method