The material type.

Class

REXMaterialProperties Class

Links
REXMaterialProperties Class, REX.ContentGenerator.Families Namespace, REXMaterialProperties Class

REXParamDescription Class

REXParamDescription Class
REX.ContentGenerator.Families Namespace

Base class for all descriptions of objects in REXFamilyType which were created based on a parametric description (not database).

Class Hierarchy
C#
[Serializable()]
public abstract class REXParamDescription : REXDescription;
Description
Namespace

REX.ContentGenerator.Families Namespace

Links
REX.ContentGenerator.Families Namespace
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXSectionDBCharacteristics Class

REXSectionDBCharacteristics Class
REX.ContentGenerator.Families Namespace Legend Members Public Methods REXSectionDBCharacteristics Methods REXSectionDBCharacteristics Properties

Describes geometry characteristics of a database section.

Class Hierarchy
C#
[Serializable()]
public class REXSectionDBCharacteristics : REXDescription;
Description
Namespace

REX.ContentGenerator.Families Namespace

Public Methods
Public Method | Description
REXSectionDBCharacteristics | Initializes a new instance of the REXSectionDBCharacteristics class.
REXSectionDBCharacteristics | Initializes a new instance of the EXSectionDBCharacteristics class.
REXSectionDBCharacteristics | Initializes a new instance of the REXSectionDBCharacteristics class.
REXSectionDBCharacteristics | Initializes a new instance of the REXSectionDBCharacteristics class.
REXSectionDBCharacteristics Methods
REXSectionDBCharacteristics Methods | Description
Clone | Creates a new object that is a copy of the current instance.
REXSectionDBCharacteristics Properties
REXSectionDBCharacteristics Properties | Description
IOMEGA | Gets or sets the warping constant (for thin-walled sections).
IX | Gets or sets the torsional constant.
IY | Gets or sets the moment of inertia (Iy).
IZ | Gets or sets the moment of inertia (Iz).
MASS | Gets or sets the weight per length unit of a section.
MSY | Gets or sets the plastic section modulus (bending) about the Y axis.
MSZ | Gets or sets the plastic section modulus (bending) about the Z axis.
SX | Gets or sets the cross-sectional area.
SY | Gets or sets the reduced section area for XY-shear deformation calculations - considering the influence of shear forces along Y axis.
SZ | Gets or sets the reduced section area for XZ-shear deformation calculations - considering the influence of shear forces along Z axis.
Links
REX.ContentGenerator.Families Namespace, Legend, Members, Public Methods, REXSectionDBCharacteristics Methods, REXSectionDBCharacteristics Properties

REXSectionDBCharacteristics.REXSectionDBCharacteristics Constructor ()

REXSectionDBCharacteristics.REXSectionDBCharacteristics Constructor ()
REXSectionDBCharacteristics Class REX.ContentGenerator.Families Namespace REXSectionDBCharacteristics Class

Initializes a new instance of the REXSectionDBCharacteristics class.

C#
public REXSectionDBCharacteristics();
Description
Class

REXSectionDBCharacteristics Class

Links
REXSectionDBCharacteristics Class, REX.ContentGenerator.Families Namespace, REXSectionDBCharacteristics Class

REXSectionDBCharacteristics.REXSectionDBCharacteristics Constructor (DTableDataObjectCollection)

REXSectionDBCharacteristics.REXSectionDBCharacteristics Constructor (DTableDataObjectCollection)
REXSectionDBCharacteristics Class REX.ContentGenerator.Families Namespace REXSectionDBCharacteristics Class

Initializes a new instance of the EXSectionDBCharacteristics class.

C#
public REXSectionDBCharacteristics(DTableDataObjectCollection pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

REXSectionDBCharacteristics Class

Links
REXSectionDBCharacteristics Class, REX.ContentGenerator.Families Namespace, REXSectionDBCharacteristics Class

REXSectionDBCharacteristics.REXSectionDBCharacteristics Constructor (REXSectionDBCharacteristics)

REXSectionDBCharacteristics.REXSectionDBCharacteristics Constructor (REXSectionDBCharacteristics)
REXSectionDBCharacteristics Class REX.ContentGenerator.Families Namespace REXSectionDBCharacteristics Class

Initializes a new instance of the REXSectionDBCharacteristics class.

C#
public REXSectionDBCharacteristics(REXSectionDBCharacteristics pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

REXSectionDBCharacteristics Class

Links
REXSectionDBCharacteristics Class, REX.ContentGenerator.Families Namespace, REXSectionDBCharacteristics Class

REXSectionDBCharacteristics.REXSectionDBCharacteristics Constructor (System.Data.DataRow)

REXSectionDBCharacteristics.REXSectionDBCharacteristics Constructor (System.Data.DataRow)
REXSectionDBCharacteristics Class REX.ContentGenerator.Families Namespace REXSectionDBCharacteristics Class

Initializes a new instance of the REXSectionDBCharacteristics class.

C#
public REXSectionDBCharacteristics(System.Data.DataRow pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

REXSectionDBCharacteristics Class

Links
REXSectionDBCharacteristics Class, REX.ContentGenerator.Families Namespace, REXSectionDBCharacteristics Class

REXSectionDBCharacteristics.Clone Method

REXSectionDBCharacteristics.Clone Method
REXSectionDBCharacteristics Class REX.ContentGenerator.Families Namespace REXSectionDBCharacteristics Class

Creates a new object that is a copy of the current instance.

C#
public override object Clone();
Returns

A new object that is a copy of this instance.

Description
Class

REXSectionDBCharacteristics Class

Links
REXSectionDBCharacteristics Class, REX.ContentGenerator.Families Namespace, REXSectionDBCharacteristics Class

REXSectionDBCharacteristics.IOMEGA Property

REXSectionDBCharacteristics.IOMEGA Property
REXSectionDBCharacteristics Class REX.ContentGenerator.Families Namespace REXSectionDBCharacteristics Class

Gets or sets the warping constant (for thin-walled sections).

C#
public double IOMEGA;
Description

The warping constant.

Class

REXSectionDBCharacteristics Class

Links
REXSectionDBCharacteristics Class, REX.ContentGenerator.Families Namespace, REXSectionDBCharacteristics Class

REXSectionDBCharacteristics.IX Property

REXSectionDBCharacteristics.IX Property
REXSectionDBCharacteristics Class REX.ContentGenerator.Families Namespace REXSectionDBCharacteristics Class

Gets or sets the torsional constant.

C#
public double IX;
Description

The torsional constant.

Class

REXSectionDBCharacteristics Class

Links
REXSectionDBCharacteristics Class, REX.ContentGenerator.Families Namespace, REXSectionDBCharacteristics Class

REXSectionDBCharacteristics.IY Property

REXSectionDBCharacteristics.IY Property
REXSectionDBCharacteristics Class REX.ContentGenerator.Families Namespace REXSectionDBCharacteristics Class

Gets or sets the moment of inertia (Iy).

C#
public double IY;
Description

The moment of inertia (Iy).

Class

REXSectionDBCharacteristics Class

Links
REXSectionDBCharacteristics Class, REX.ContentGenerator.Families Namespace, REXSectionDBCharacteristics Class

REXSectionDBCharacteristics.IZ Property

REXSectionDBCharacteristics.IZ Property
REXSectionDBCharacteristics Class REX.ContentGenerator.Families Namespace REXSectionDBCharacteristics Class

Gets or sets the moment of inertia (Iz).

C#
public double IZ;
Description

The moment of inertia (Iz).

Class

REXSectionDBCharacteristics Class

Links
REXSectionDBCharacteristics Class, REX.ContentGenerator.Families Namespace, REXSectionDBCharacteristics Class

REXSectionDBCharacteristics.MASS Property

REXSectionDBCharacteristics.MASS Property
REXSectionDBCharacteristics Class REX.ContentGenerator.Families Namespace REXSectionDBCharacteristics Class

Gets or sets the weight per length unit of a section.

C#