IRexContentSettings Interface REX.ContentGenerator.Converters Namespace IRexContentSettings Interface

Gets parameters for the specified name of the specified category.

C#
FieldParams GetParamsForField(string fieldname, ECategoryType type);
Parameters
Parameters | Description
fieldname | The name of the field.
type | The type.
Returns

Return parameters.

Description
Interface

IRexContentSettings Interface

Links
IRexContentSettings Interface, REX.ContentGenerator.Converters Namespace, IRexContentSettings Interface

IRexContentSettings.GetResource Method

IRexContentSettings.GetResource Method
IRexContentSettings Interface REX.ContentGenerator.Converters Namespace IRexContentSettings Interface

Gets the resource for the specified name of the specified category.

C#
string GetResource(ECategoryType cat, string item);
Parameters
Parameters | Description
cat | The category.
item | The item.
Returns

The resource.

Description
Interface

IRexContentSettings Interface

Links
IRexContentSettings Interface, REX.ContentGenerator.Converters Namespace, IRexContentSettings Interface

IRexContentSettings.LoadCustomParametersFile Method

IRexContentSettings.LoadCustomParametersFile Method
IRexContentSettings Interface REX.ContentGenerator.Converters Namespace IRexContentSettings Interface

Loads the custom parameters file.

C#
bool LoadCustomParametersFile(string category, string path);
Parameters
Parameters | Description
category | The custom category name.
path | The path.
Returns

True if loading succeeded; otherwise, false.

Description
Interface

IRexContentSettings Interface

Links
IRexContentSettings Interface, REX.ContentGenerator.Converters Namespace, IRexContentSettings Interface

IRexContentSettings.CodeFilteredShapeAnalysis Property

IRexContentSettings.CodeFilteredShapeAnalysis Property
IRexContentSettings Interface REX.ContentGenerator.Converters Namespace IRexContentSettings Interface

Gets or sets a value indicating whether the filtered list of rebar shapes should be taken to consideration during rebars analysis.

C#
bool CodeFilteredShapeAnalysis;
Description

If filtered shapes are supported only.

Interface

IRexContentSettings Interface

Links
IRexContentSettings Interface, REX.ContentGenerator.Converters Namespace, IRexContentSettings Interface

IRexContentSettings.DatabaseAccess Property

IRexContentSettings.DatabaseAccess Property
IRexContentSettings Interface REX.ContentGenerator.Converters Namespace IRexContentSettings Interface

Gets or sets the database access.

C#
EDBAccess DatabaseAccess;
Description

The database access.

Interface

IRexContentSettings Interface

Links
IRexContentSettings Interface, REX.ContentGenerator.Converters Namespace, IRexContentSettings Interface

IRexContentSettings.Labels Property

IRexContentSettings.Labels Property
IRexContentSettings Interface REX.ContentGenerator.Converters Namespace IRexContentSettings Interface

Gets or sets a value indicating whether labels are taken to consideration during mapping.

C#
bool Labels;
Description

True if labels supported; otherwise false.

Interface

IRexContentSettings Interface

Links
IRexContentSettings Interface, REX.ContentGenerator.Converters Namespace, IRexContentSettings Interface

IRexContentSettings.MirroredShapeAnalysis Property

IRexContentSettings.MirroredShapeAnalysis Property
IRexContentSettings Interface REX.ContentGenerator.Converters Namespace IRexContentSettings Interface

Gets or sets a value indicating whether mirrored rebar shapes should be taken to consideration during rebars analysis.

C#
bool MirroredShapeAnalysis;
Description

If mirrored shapes are supported.

Interface

IRexContentSettings Interface

Links
IRexContentSettings Interface, REX.ContentGenerator.Converters Namespace, IRexContentSettings Interface

IRexContentSettings.MultiSearch Property

IRexContentSettings.MultiSearch Property
IRexContentSettings Interface REX.ContentGenerator.Converters Namespace IRexContentSettings Interface

Gets or sets a value indicating whether during searching databases multiply result should be returned (if false - when first result is found algorithm will stop - In case of GetDBList(List…) function will stop if any REXFamilyType in database will be found) .

C#
bool MultiSearch;
Description

If multiply result is needed.

Interface

IRexContentSettings Interface

Links
IRexContentSettings Interface, REX.ContentGenerator.Converters Namespace, IRexContentSettings Interface

IRexContentSettings.MultiThread Property

IRexContentSettings.MultiThread Property
IRexContentSettings Interface REX.ContentGenerator.Converters Namespace IRexContentSettings Interface

Gets or sets a value indicating whether multithread operations should be used for database searching (only if DbRoot is used)..

C#
bool MultiThread;
Description

True if multithread operations supported; otherwise, false.

Interface

IRexContentSettings Interface

Links
IRexContentSettings Interface, REX.ContentGenerator.Converters Namespace, IRexContentSettings Interface

IRexContentSettings.ReleaseDBAfterEachAction Property

IRexContentSettings.ReleaseDBAfterEachAction Property
IRexContentSettings Interface REX.ContentGenerator.Converters Namespace IRexContentSettings Interface

Gets or sets a value indicating whether the database should be released after each action (if not it will be kept in memory).

C#
bool ReleaseDBAfterEachAction;
Description

True if the database is released after usage; otherwise, false.

Interface

IRexContentSettings Interface

Links
IRexContentSettings Interface, REX.ContentGenerator.Converters Namespace, IRexContentSettings Interface

IRexContentSettings.SupportUserDatabases Property

IRexContentSettings.SupportUserDatabases Property
IRexContentSettings Interface REX.ContentGenerator.Converters Namespace IRexContentSettings Interface

Gets or sets a value indicating whether users databases should be supported

C#
bool SupportUserDatabases;
Description

True if user databases are supported; otherwise, false.

Interface

IRexContentSettings Interface

Links
IRexContentSettings Interface, REX.ContentGenerator.Converters Namespace, IRexContentSettings Interface

IRvtContentSettings Interface

IRvtContentSettings Interface
REX.ContentGenerator.Converters Namespace Legend Members IRvtContentSettings Methods IRvtContentSettings Properties

Provides interface for the settings of the RVTFamilyConverter.

Class Hierarchy
C#
public interface IRvtContentSettings;
Description
Namespace

REX.ContentGenerator.Converters Namespace

IRvtContentSettings Methods
IRvtContentSettings Methods | Description
Clean | Cleans temporary files.
LoadCustomParametersFile | Loads the custom parameters file.
SetLanguage | Sets the language for created families (names of families will be translated according to this) - “en-US”, “pl-PL” etc.
IRvtContentSettings Properties
IRvtContentSettings Properties | Description
BufferElements | Gets or sets a value indicating whether elements should be buffered after investigation – using RevitId.
CreateNewElement | Gets or sets a value indicating whether a new family should be created if the element wasn’t found among existing ones.
IgnoreFamilyNameLanguage | Gets or sets a value indicating whether language should be taken to consideration during element search (language set by SetLanguage function).
Labels | Gets or sets a value indicating whether labels should be taken to consideration during mapping.
RebarPostGenerateCorrection | Gets or sets a value indicating whether correction of rebar geometry should be made after generation process.
SupportUserDatabases | Gets or sets a value indicating whether users databases should be supported
Update | Gets or sets a value indicating whether element found in the project (if it already exists) should be updated with new data.
Links
REX.ContentGenerator.Converters Namespace, Legend, Members, IRvtContentSettings Methods, IRvtContentSettings Properties

IRvtContentSettings.Clean Method