ContourCont Class, REX.ContentGenerator.Geometry Namespace, ContourCont Class

ContourCont.Transform Method

ContourCont.Transform Method
ContourCont Class REX.ContentGenerator.Geometry Namespace ContourCont Class

Applies the specified transformation to the element.

C#
public override void Transform(TransformDbl trans, bool toLocal);
Parameters
Parameters | Description
trans | The transformation object.
toLocal | If transformation from the global to the local coordinate system.
Description
Class

ContourCont Class

Links
ContourCont Class, REX.ContentGenerator.Geometry Namespace, ContourCont Class

ContourCont.Translate Method

ContourCont.Translate Method
ContourCont Class REX.ContentGenerator.Geometry Namespace ContourCont Class

Applies the specified translation vector to the element.

C#
public override void Translate(double x, double y);
Parameters
Parameters | Description
x | The x.
y | The y.
Description
Class

ContourCont Class

Links
ContourCont Class, REX.ContentGenerator.Geometry Namespace, ContourCont Class

ContourCont.ContList Property

ContourCont.ContList Property
ContourCont Class REX.ContentGenerator.Geometry Namespace ContourCont Class

Gets or sets the list of contours.

C#
public List<ContourCont> ContList;
Description

The list of contours.

Class

ContourCont Class

Links
ContourCont Class, REX.ContentGenerator.Geometry Namespace, ContourCont Class

ContourCont.ElemList Property

ContourCont.ElemList Property
ContourCont Class REX.ContentGenerator.Geometry Namespace ContourCont Class

Gets or sets the list of elements.

C#
public List<ContourElem> ElemList;
Description

The list of elements.

Class

ContourCont Class

Links
ContourCont Class, REX.ContentGenerator.Geometry Namespace, ContourCont Class

ContourCont.Hole Property

ContourCont.Hole Property
ContourCont Class REX.ContentGenerator.Geometry Namespace ContourCont Class

Gets or sets a value indicating whether this contour is a hole.

C#
public bool Hole;
Description

True if the contour is a hole; otherwise, false.

Class

ContourCont Class

Links
ContourCont Class, REX.ContentGenerator.Geometry Namespace, ContourCont Class

ContourDimension Class

ContourDimension Class
REX.ContentGenerator.Geometry Namespace Legend Members Public Methods ContourDimension Methods ContourDimension Properties

Represents dimensions.

Class Hierarchy
C#
public class ContourDimension;
Description
Namespace

REX.ContentGenerator.Geometry Namespace

Public Methods
Public Method | Description
ContourDimension | Initializes a new instance of the ContourDimension class.
ContourDimension | Initializes a new instance of the ContourDimension class.
ContourDimension Methods
ContourDimension Methods | Description
MultiplyLengthDim | Multiplies length dimensions by the coefficient.
Translate | Applies the specified translation vector to the element.
ContourDimension Properties
ContourDimension Properties | Description
Parameter | Gets or sets the parameter (text).
Start | Gets or sets the start.
Links
REX.ContentGenerator.Geometry Namespace, Legend, Members, Public Methods, ContourDimension Methods, ContourDimension Properties

ContourDimension.ContourDimension Constructor (string, REXxyz)

ContourDimension.ContourDimension Constructor (string, REXxyz)
ContourDimension Class REX.ContentGenerator.Geometry Namespace ContourDimension Class

Initializes a new instance of the ContourDimension class.

C#
public ContourDimension(string param, REXxyz st);
Parameters
Parameters | Description
param | The parameter (text).
st | The start.
Description
Class

ContourDimension Class

Links
ContourDimension Class, REX.ContentGenerator.Geometry Namespace, ContourDimension Class

ContourDimension.ContourDimension Constructor (string, double, double)

ContourDimension.ContourDimension Constructor (string, double, double)
ContourDimension Class REX.ContentGenerator.Geometry Namespace ContourDimension Class

Initializes a new instance of the ContourDimension class.

C#
public ContourDimension(string param, double xst, double yst);
Parameters
Parameters | Description
param | The parameter (text).
xst | The x start.
yst | The y start.
Description
Class

ContourDimension Class

Links
ContourDimension Class, REX.ContentGenerator.Geometry Namespace, ContourDimension Class

ContourDimension.MultiplyLengthDim Method

ContourDimension.MultiplyLengthDim Method
ContourDimension Class REX.ContentGenerator.Geometry Namespace ContourDimension Class

Multiplies length dimensions by the coefficient.

C#
public virtual void MultiplyLengthDim(double coeff);
Parameters
Parameters | Description
coeff | The coefficient.
Description
Class

ContourDimension Class

Links
ContourDimension Class, REX.ContentGenerator.Geometry Namespace, ContourDimension Class

ContourDimension.Translate Method

ContourDimension.Translate Method
ContourDimension Class REX.ContentGenerator.Geometry Namespace ContourDimension Class

Applies the specified translation vector to the element.

C#
public virtual void Translate(double x, double y);
Parameters
Parameters | Description
x | The x.
y | The y.
Description
Class

ContourDimension Class

Links
ContourDimension Class, REX.ContentGenerator.Geometry Namespace, ContourDimension Class

ContourDimension.Parameter Property

ContourDimension.Parameter Property
ContourDimension Class REX.ContentGenerator.Geometry Namespace ContourDimension Class

Gets or sets the parameter (text).

C#
public string Parameter;
Description

The parameter (text).

Class

ContourDimension Class

Links
ContourDimension Class, REX.ContentGenerator.Geometry Namespace, ContourDimension Class

ContourDimension.Start Property

ContourDimension.Start Property
ContourDimension Class REX.ContentGenerator.Geometry Namespace ContourDimension Class

Gets or sets the start.

C#
public REXxyz Start;
Description

The start.

Class

ContourDimension Class

Links
ContourDimension Class, REX.ContentGenerator.Geometry Namespace, ContourDimension Class

ContourDimensionLine Class

ContourDimensionLine Class
REX.ContentGenerator.Geometry Namespace Legend Members Public Methods ContourDimensionLine Methods ContourDimensionLine Properties

Represents the linear dimension.

Class Hierarchy
C#
public class ContourDimensionLine : ContourDimension;
Description
Namespace

REX.ContentGenerator.Geometry Namespace

Public Methods
Public Method | Description
ContourDimensionLine | Initializes a new instance of the ContourDimensionLine class.
ContourDimensionLine | Initializes a new instance of the ContourDimensionLine class.
ContourDimensionLine Methods
ContourDimensionLine Methods | Description
MultiplyLengthDim | Multiplies length dimensions by the coefficient.
Translate | Applies the specified translation vector to the element.
ContourDimensionLine Properties
ContourDimensionLine Properties | Description
End | Gets or sets the end.
Extend2Right | Gets or sets a value indicating whether the dimension should be extended to the right.
Level | Gets or sets the level.
Up | Gets or sets a value indicating whether dimension is defined above the reference.
Links
REX.ContentGenerator.Geometry Namespace, Legend, Members, Public Methods, ContourDimensionLine Methods, ContourDimensionLine Properties

ContourDimensionLine.ContourDimensionLine Constructor (REXxyz, REXxyz, int, bool, string, bool)

ContourDimensionLine.ContourDimensionLine Constructor (REXxyz, REXxyz, int, bool, string, bool)
ContourDimensionLine Class REX.ContentGenerator.Geometry Namespace ContourDimensionLine Class

Initializes a new instance of the ContourDimensionLine class.

C#
public ContourDimensionLine(REXxyz st, REXxyz end, int lev, bool up, string param, bool extend2Right);
Parameters
Parameters | Description
st | The start.
end | The end.
lev | The level.
up | Indicates whether the text should be placed above the reference.
param | The parameter (text).
extend2Right | Indicates whether the dimension should be extended to the right.
Description
Class

ContourDimensionLine Class

Links