REXSectionParamDescription Properties
REXSectionParamDescription Class Legend
REXSectionParamDescription Properties
REXSectionParamDescription Properties | Description
Angle | Gets or sets the angle of the section.
Characteristics | Gets or sets the characteristics.
CharacteristicsEnd | Gets or sets the characteristics of the end.
Contour | Gets or sets the contour.
Dimensions | Gets or sets the dimensions.
DimensionsEnd | Gets or sets the dimensions of the end.
IsTurned | Gets or sets a value indicating whether this instance is turned.
SectionType | Gets or sets the type of the section.
Tapered | Gets or sets a value indicating whether this REXSectionParamDescription is tapered.

REXSectionParamDescription Class Public Methods

REXSectionParamDescription Class Public Methods
REXSectionParamDescription Class Legend
Public Methods
Public Method | Description
REXSectionParamDescription | Initializes a new instance of the REXSectionParamDescription class.
REXSectionParamDescription | Initializes a new instance of the REXSectionParamDescription class.
REXSectionParamDescription | Initializes a new instance of the REXSectionParamDescription class.
REXSectionParamDescription | Initializes a new instance of the REXSectionParamDescription class.

Legend

Legend
REXSectionParamDimensions Class
Legend
Constructor
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXSectionParamDimensions Class Members

REXSectionParamDimensions Class Members
REXSectionParamDimensions Class Legend
Members
Public Methods
Public Method | Description
REXSectionParamDimensions | Initializes a new instance of the REXSectionParamDimensions class.
REXSectionParamDimensions | Initializes a new instance of the REXSectionParamDimensions class.
REXSectionParamDimensions | Initializes a new instance of the REXSectionParamDimensions class.
REXSectionParamDimensions | Initializes a new instance of the REXSectionParamDimensions class.
REXSectionParamDimensions Methods
REXSectionParamDimensions Methods | Description
Clone | Creates a new object that is a copy of the current instance.
REXSectionParamDimensions Properties
REXSectionParamDimensions Properties | Description
b | Gets or sets the b.
b1 | Gets or sets the b1.
b2 | Gets or sets the b2.
bf | Gets or sets the bf.
d | Gets or sets the d.
h | Gets or sets the h.
h1 | Gets or sets the h1.
h2 | Gets or sets the h2.
l1 | Gets or sets the l1.
l2 | Gets or sets the l2.
P1_L | Gets or sets the P1_L.
P1_T | Gets or sets the P1_T.
P2_L | Gets or sets the P2_L.
P2_T | Gets or sets the P2_T.
P3_L | Gets or sets the P3_L.
P3_T | Gets or sets the P3_T.
P4_L | Gets or sets the P4_L.
P4_T | Gets or sets the P4_T.
t | Gets or sets the t.
tf | Gets or sets the tf.
tf1 | Gets or sets the tf1.
tf2 | Gets or sets the tf2.
tw | Gets or sets the tw.
vpy | Gets or sets the vpy.
vpz | Gets or sets the vpz.
vy | Gets or sets the vy.
vz | Gets or sets the vz.

REXSectionParamDimensions Methods

REXSectionParamDimensions Methods
REXSectionParamDimensions Class Legend
REXSectionParamDimensions Methods
REXSectionParamDimensions Methods | Description
Clone | Creates a new object that is a copy of the current instance.

REXSectionParamDimensions Properties

REXSectionParamDimensions Properties
REXSectionParamDimensions Class Legend
REXSectionParamDimensions Properties
REXSectionParamDimensions Properties | Description
b | Gets or sets the b.
b1 | Gets or sets the b1.
b2 | Gets or sets the b2.
bf | Gets or sets the bf.
d | Gets or sets the d.
h | Gets or sets the h.
h1 | Gets or sets the h1.
h2 | Gets or sets the h2.
l1 | Gets or sets the l1.
l2 | Gets or sets the l2.
P1_L | Gets or sets the P1_L.
P1_T | Gets or sets the P1_T.
P2_L | Gets or sets the P2_L.
P2_T | Gets or sets the P2_T.
P3_L | Gets or sets the P3_L.
P3_T | Gets or sets the P3_T.
P4_L | Gets or sets the P4_L.
P4_T | Gets or sets the P4_T.
t | Gets or sets the t.
tf | Gets or sets the tf.
tf1 | Gets or sets the tf1.
tf2 | Gets or sets the tf2.
tw | Gets or sets the tw.
vpy | Gets or sets the vpy.
vpz | Gets or sets the vpz.
vy | Gets or sets the vy.
vz | Gets or sets the vz.

REXSectionParamDimensions Class Public Methods

REXSectionParamDimensions Class Public Methods
REXSectionParamDimensions Class Legend
Public Methods
Public Method | Description
REXSectionParamDimensions | Initializes a new instance of the REXSectionParamDimensions class.
REXSectionParamDimensions | Initializes a new instance of the REXSectionParamDimensions class.
REXSectionParamDimensions | Initializes a new instance of the REXSectionParamDimensions class.
REXSectionParamDimensions | Initializes a new instance of the REXSectionParamDimensions class.

Legend

Legend
SerializableObject Class
Legend
Constructor
virtual

SerializableObject Class Members

SerializableObject Class Members
SerializableObject Class Legend
Members
Public Methods
Public Method | Description
SerializableObject | Initializes a new instance of the SerializableObject class.
SerializableObject Methods
SerializableObject Methods | Description
GetObjectData | Serializes the instance to the Serialization object.
Load | Loads object from the stream.
Save | Saves the object to the stream.

SerializableObject Methods

SerializableObject Methods
SerializableObject Class Legend
SerializableObject Methods
SerializableObject Methods | Description
GetObjectData | Serializes the instance to the Serialization object.
Load | Loads object from the stream.
Save | Saves the object to the stream.

SerializableObject Class Public Methods

SerializableObject Class Public Methods
SerializableObject Class Legend
Public Methods
Public Method | Description
SerializableObject | Initializes a new instance of the SerializableObject class.

REX.ContentGenerator.Geometry Namespace Classes

REX.ContentGenerator.Geometry Namespace Classes
REX.ContentGenerator.Geometry Namespace Legend
Classes
Class | Description
Contour_3D | Represents contour 3D.
Contour_Compound2D | Represents the compound contour.
Contour_Section | Represents the contour of the section.
ContourArc | Represents the arc defined by the start, middle and end point.
ContourCircle | Represents the circle element.
ContourCont | Represents the contour element.
ContourDimension | Represents dimensions.
ContourDimensionLine | Represents the linear dimension.
ContourDimensionRadius | Represents the radial dimension.
ContourElem | Base class for all contour elements.
ContourLine | Represents the line element.
REXSectionAnalyzer | This is class REX.ContentGenerator.Geometry.REXSectionAnalyzer.
REXSectionTypeAnalyzer | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer.
REXSectionTypeAnalyzer_BOX1 | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_BOX1.
REXSectionTypeAnalyzer_BOX2 | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_BOX2.
REXSectionTypeAnalyzer_BOX3 | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_BOX3.
REXSectionTypeAnalyzer_C | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_C.
REXSectionTypeAnalyzer_CROSS | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_CROSS.
REXSectionTypeAnalyzer_DRECT | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_DRECT.
REXSectionTypeAnalyzer_I | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_I.
REXSectionTypeAnalyzer_IASYM | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_IASYM.
REXSectionTypeAnalyzer_L | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_L.
REXSectionTypeAnalyzer_POLYG | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_POLYG.
REXSectionTypeAnalyzer_POLYGHOLLOW | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_POLYGHOLLOW.