REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class

REXDFM.SetUserValidFunctionComplex Method (IUnitObject, UserValidationComplex)

REXDFM.SetUserValidFunctionComplex Method (IUnitObject, UserValidationComplex)
REXDFM Class REX.Common Namespace REXDFM Class

Sets the user validation function for lists of values.

C#
public bool SetUserValidFunctionComplex(IUnitObject myUnitObject, UserValidationComplex myFunction);
Parameters
Parameters | Description
myUnitObject | The reference to the unit object.
myFunction | The function.
Returns

Returns true if succeeded.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class

REXDFM.SetUserValidFunctionComplex Method (string, UserValidationComplex)

REXDFM.SetUserValidFunctionComplex Method (string, UserValidationComplex)
REXDFM Class REX.Common Namespace REXDFM Class

Sets the user validation function for lists of values.

C#
public bool SetUserValidFunctionComplex(string myUnitObject, UserValidationComplex myFunction);
Parameters
Parameters | Description
myUnitObject | The reference to the unit object.
myFunction | The function.
Returns

Returns true if succeeded.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class

REXDFM.ValidateDataBase Method (IUnitObject, double)

REXDFM.ValidateDataBase Method (IUnitObject, double)
REXDFM Class REX.Common Namespace REXDFM Class

Validates the value in base units.

C#
public bool ValidateDataBase(IUnitObject myUnitObject, double Value);
Parameters
Parameters | Description
myUnitObject | The reference to the unit object.
Value | The value.
Returns

Returns true if succeeded.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class

REXDFM.ValidateDataBase Method (string, double)

REXDFM.ValidateDataBase Method (string, double)
REXDFM Class REX.Common Namespace REXDFM Class

Validates the value in base units.

C#
public bool ValidateDataBase(string nameUnitObject, double Value);
Parameters
Parameters | Description
nameUnitObject | The name of the unit object.
Value | The value.
Returns

Returns true if succeeded.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class

REXDFM.ValidateDataDisplay Method (IUnitObject, double)

REXDFM.ValidateDataDisplay Method (IUnitObject, double)
REXDFM Class REX.Common Namespace REXDFM Class

Validates the value in display units.

C#
public bool ValidateDataDisplay(IUnitObject myUnitObject, double Value);
Parameters
Parameters | Description
myUnitObject | The reference to the unit object.
Value | The value.
Returns

Returns true if succeeded.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class

REXDFM.ValidateDataDisplay Method (string, double)

REXDFM.ValidateDataDisplay Method (string, double)
REXDFM Class REX.Common Namespace REXDFM Class

Validates the value in display units.

C#
public bool ValidateDataDisplay(string nameUnitObject, double Value);
Parameters
Parameters | Description
nameUnitObject | The name of the unit object.
Value | The value.
Returns

Returns true if succeeded.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class

REXDFM.ValidateDataInterface Method (IUnitObject, double)

REXDFM.ValidateDataInterface Method (IUnitObject, double)
REXDFM Class REX.Common Namespace REXDFM Class

Validates the value in interface units.

C#
public bool ValidateDataInterface(IUnitObject myUnitObject, double Value);
Parameters
Parameters | Description
myUnitObject | The reference to the unit object.
Value | The value.
Returns

Returns true if succeeded.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class

REXDFM.ValidateDataInterface Method (string, double)

REXDFM.ValidateDataInterface Method (string, double)
REXDFM Class REX.Common Namespace REXDFM Class

Validates the value in interface units.

C#
public bool ValidateDataInterface(string nameUnitObject, double Value);
Parameters
Parameters | Description
nameUnitObject | The name of the unit object.
Value | The value.
Returns

Returns true if succeeded.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class

REXDFM.AllowReplaceObject Property

REXDFM.AllowReplaceObject Property
REXDFM Class REX.Common Namespace REXDFM Class

Gets or sets a value indicating whether controlling object may be replaced during registration.

C#
public bool AllowReplaceObject;
Description

true if replacing objects is allowed; otherwise, false.

Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class

REXDFM.Count Property

REXDFM.Count Property
REXDFM Class REX.Common Namespace REXDFM Class

Gets the number of controling objects.

C#
public int Count;
Description

The count.

Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class

REXDFM.EventHandlerChange Delegate

REXDFM.EventHandlerChange Delegate
REXDFM Class REX.Common Namespace REXDFM Class

Delegate to the event handler changes.

C#
public delegate void EventHandlerChange(IUnitObject sender);
Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class

REXDFM.EventHandlerLost Delegate

REXDFM.EventHandlerLost Delegate
REXDFM Class REX.Common Namespace REXDFM Class

Delegate to the event handler lost focus.

C#
public delegate void EventHandlerLost(IUnitObject sender);
Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class

REXDFM.ControlUnitObjectError Event

REXDFM.ControlUnitObjectError Event
REXDFM Class REX.Common Namespace REXDFM Class

Raises when data is changed on Control and some error was occur.

C#
public event EventHandlerChange ControlUnitObjectError;
Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class

REXDFM.ControlUnitObjectLostFocus Event

REXDFM.ControlUnitObjectLostFocus Event
REXDFM Class REX.Common Namespace REXDFM Class

Raises when Control losts focus.

C#
public event EventHandlerLost ControlUnitObjectLostFocus;
Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class

REXDFM.ControlUnitObjectOk Event

REXDFM.ControlUnitObjectOk Event
REXDFM Class REX.Common Namespace REXDFM Class

Raises when data is changed on Control and no errors.

C#
public event EventHandlerChange ControlUnitObjectOk;
Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class

REXDirectAccess Class

REXDirectAccess Class
REX.Common Namespace Legend Members REXDirectAccess Methods

Base class for main DirectAccess class.

Class Hierarchy
C#
public class REXDirectAccess;
Description

The class enables direct connection between parent application and extension.

Namespace

REX.Common Namespace

REXDirectAccess Methods
REXDirectAccess Methods | Description
PresetContext | Presets the context.
Links
REX.Common Namespace, Legend, Members, REXDirectAccess Methods

REXDirectAccess.PresetContext Method

REXDirectAccess.PresetContext Method
REXDirectAccess Class REX.Common Namespace REXDirectAccess Class

Presets the context.

C#
public void PresetContext(ref REXContext Context);
Parameters
Parameters | Description
Context | The context.
Description

Set dedicated version name. For example "2009", "2010".

Class

REXDirectAccess Class

Links
REXDirectAccess Class, REX.Common Namespace, REXDirectAccess Class

REXDirectRevitAccess Class

REXDirectRevitAccess Class
REX.Common Namespace Legend Members REXDirectRevitAccess Methods

Base class for main DirectAccess class.

Class Hierarchy
C#
public class REXDirectRevitAccess : REXDirectAccess;
Description

The class enables direct connection between Revit and extension.

Namespace

REX.Common Namespace

REXDirectRevitAccess Methods
REXDirectRevitAccess Methods | Description
GetRevitSubName | Gets the name of the revit sub.
GetRevitSubName | Gets the name of the revit sub.