REXLayout.DeSelect Method (REXToolboxItem)

REXLayout.DeSelect Method (REXToolboxItem)
REXLayout Class REX.Common Namespace REXLayout Class

This is DeSelect, a member of class REXLayout.

C#
public void DeSelect(REXToolboxItem TBI);
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class

REXLayout.DisposeControls Method

REXLayout.DisposeControls Method
REXLayout Class REX.Common Namespace REXLayout Class

Disposes all controls in all added layouts.

C#
public void DisposeControls();
Description
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class

REXLayout.GetItem Method

REXLayout.GetItem Method
REXLayout Class REX.Common Namespace REXLayout Class

Gets the layout item identified by mame.

C#
public REXLayoutItem GetItem(string Name);
Parameters
Parameters | Description
Name | The name.
Description
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class

REXLayout.GetLayoutIndex Method

REXLayout.GetLayoutIndex Method
REXLayout Class REX.Common Namespace REXLayout Class

Gets the index of the layout.

C#
public int GetLayoutIndex(string LayoutName);
Parameters
Parameters | Description
LayoutName | Name of the layout.
Description
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class

REXLayout.GetLayoutItem Method

REXLayout.GetLayoutItem Method
REXLayout Class REX.Common Namespace REXLayout Class

This is GetLayoutItem, a member of class REXLayout.

C#
public REXLayoutItem GetLayoutItem(REXToolboxItem TBI);
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class

REXLayout.InsertLayout Method

REXLayout.InsertLayout Method
REXLayout Class REX.Common Namespace REXLayout Class

Adds the layout.

C#
public void InsertLayout(REXLayoutItem LayoutItem, int Index);
Parameters
Parameters | Description
LayoutItem | The layout item.
Index | The index.
Description
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class

REXLayout.RemoveLayout Method

REXLayout.RemoveLayout Method
REXLayout Class REX.Common Namespace REXLayout Class

Removes the layout.

C#
public void RemoveLayout(string Name);
Parameters
Parameters | Description
Name | The name of the layout.
Description
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class

REXLayout.Select Method (REXLayoutItem)

REXLayout.Select Method (REXLayoutItem)
REXLayout Class REX.Common Namespace REXLayout Class

Called after select the specified LayoutItem.

C#
public void Select(REXLayoutItem LI);
Parameters
Parameters | Description
LI | The LayoutItem.
Description
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class

REXLayout.Select Method (REXToolboxItem)

REXLayout.Select Method (REXToolboxItem)
REXLayout Class REX.Common Namespace REXLayout Class

This is Select, a member of class REXLayout.

C#
public void Select(REXToolboxItem TBI);
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class

REXLayout.SelectLayout Method

REXLayout.SelectLayout Method
REXLayout Class REX.Common Namespace REXLayout Class

Selects the layout.

C#
public void SelectLayout(string Name);
Parameters
Parameters | Description
Name | The name of the layout.
Description
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class

REXLayout.Setup Method

REXLayout.Setup Method
REXLayout Class REX.Common Namespace REXLayout Class

Setups layout and all layout's items.

C#
public void Setup();
Description
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class

REXLayout.ToolboxDeSelect Method

REXLayout.ToolboxDeSelect Method
REXLayout Class REX.Common Namespace REXLayout Class

This is ToolboxDeSelect, a member of class REXLayout.

C#
public void ToolboxDeSelect(REXToolboxItem TBI);
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class

REXLayout.ToolboxGetItem Method

REXLayout.ToolboxGetItem Method
REXLayout Class REX.Common Namespace REXLayout Class

This is ToolboxGetItem, a member of class REXLayout.

C#
public REXToolboxItem ToolboxGetItem(string Name);
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class

REXLayout.ToolboxRemoveLayout Method

REXLayout.ToolboxRemoveLayout Method
REXLayout Class REX.Common Namespace REXLayout Class

This is ToolboxRemoveLayout, a member of class REXLayout.

C#
public void ToolboxRemoveLayout(string Name);
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class

REXLayout.ToolboxSelect Method

REXLayout.ToolboxSelect Method
REXLayout Class REX.Common Namespace REXLayout Class

This is ToolboxSelect, a member of class REXLayout.

C#
public void ToolboxSelect(REXToolboxItem TBI);
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class

REXLayout.ToolboxSelectLayout Method

REXLayout.ToolboxSelectLayout Method
REXLayout Class REX.Common Namespace REXLayout Class

This is ToolboxSelectLayout, a member of class REXLayout.

C#
public void ToolboxSelectLayout(string Name);
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class

REXLayout.ToolboxSetup Method ()

REXLayout.ToolboxSetup Method ()
REXLayout Class REX.Common Namespace REXLayout Class

This is ToolboxSetup, a member of class REXLayout.

C#
public void ToolboxSetup();
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class

REXLayout.ToolboxSetup Method (bool)

REXLayout.ToolboxSetup Method (bool)
REXLayout Class REX.Common Namespace REXLayout Class

This is ToolboxSetup, a member of class REXLayout.

C#
public void ToolboxSetup(bool update);
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class

REXLayout.ToolboxUpdate Method

REXLayout.ToolboxUpdate Method
REXLayout Class REX.Common Namespace REXLayout Class

This is ToolboxUpdate, a member of class REXLayout.

C#
public void ToolboxUpdate();
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class

REXLayout.Update Method

REXLayout.Update Method
REXLayout Class REX.Common Namespace REXLayout Class

Updates layout all layout's items.

C#
public void Update();
Description
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class

REXLayout.CommandsOptions Property

REXLayout.CommandsOptions Property
REXLayout Class REX.Common Namespace REXLayout Class

Gets or sets the options for commands.

C#
public long CommandsOptions;
Description

The commands options.

Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class

REXLayout.CommandsOptionsByEnum Property

REXLayout.CommandsOptionsByEnum Property
REXLayout Class REX.Common Namespace REXLayout Class

Gets or sets the options for commands.

C#
public REXUI.CommandOptions CommandsOptionsByEnum;
Description

The commands options.

Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class

REXLayout.ConstOptions Property

REXLayout.ConstOptions Property
REXLayout Class REX.Common Namespace REXLayout Class

Gets or sets the const options for all layouts.

C#
public long ConstOptions;
Description

The const options.

Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class

REXLayout.ConstOptionsByEnum Property

REXLayout.ConstOptionsByEnum Property
REXLayout Class REX.Common Namespace REXLayout Class

Gets or sets the const options for all layouts.

C#
public REXUI.SetupOptions ConstOptionsByEnum;
Description

The const options.

Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class

REXLayout.Count Property

REXLayout.Count Property
REXLayout Class REX.Common Namespace REXLayout Class

Gets the count of layout items.

C#
public int Count;
Description

The count of layout items.

Class

REXLayout Class

Links