REXContentDialogManager Class Legend
Public Methods
Public Method | Description
REXContentDialogManager | Initializes a new instance of the REXContentDialogManager class.

Example

Example
REXContentDialogManager.ShowContentDialog Method

The example shows how to launch the DRevitContentGenerator dialog and use it as a family browser.

//Manager initialize.
REX.ContentGenerator.Dialog.REXContentDialogManager mng = new REX.ContentGenerator.Dialog.REXContentDialogManager(ThisExtension.Context);

//Settings initialize
//-general
REX.ContentGenerator.Dialog.REXContentDialogSettings settings = new REX.ContentGenerator.Dialog.REXContentDialogSettings();
settings.DialogMode = REX.ContentGenerator.Dialog.EContentDialogMode.MultiSelection;
settings.RegionalSettings = true;
settings.ShowList = true;
settings.Progress = false;
settings.Caption = "Example1";
//-for sections
settings.SectionDBSettings.SelectedElements.Clear();
settings.SectionDBSettings.Visible = true;

//Launching the dialog.
mng.ShowContentDialog(settings, ThisExtension.GetWindowForParent());

//Getting selection.
List<REXFamilyType> families = new List<REXFamilyType>(settings.SectionDBSettings.SelectedElements);

//Disposing dialog.
mng.DisposeContentDialog();

Example

Example
REXContentDialogManager.ShowContentDialogParentIntPtr Method

The example shows how to launch the DRevitContentGenerator dialog and use it as a family browser.

//Manager initialize.
REX.ContentGenerator.Dialog.REXContentDialogManager mng = new REX.ContentGenerator.Dialog.REXContentDialogManager(ThisExtension.Context);

//Settings initialize
//-general
REX.ContentGenerator.Dialog.REXContentDialogSettings settings = new REX.ContentGenerator.Dialog.REXContentDialogSettings();
settings.DialogMode = REX.ContentGenerator.Dialog.EContentDialogMode.MultiSelection;
settings.RegionalSettings = true;
settings.ShowList = true;
settings.Progress = false;
settings.Caption = "Example1";
//-for sections
settings.SectionDBSettings.SelectedElements.Clear();
settings.SectionDBSettings.Visible = true;

//Launching the dialog.
mng.ShowContentDialog(settings, ThisExtension.GetWindowForParent().Handle);

//Getting selection.
List<REXFamilyType> families = new List<REXFamilyType>(settings.SectionDBSettings.SelectedElements);

//Disposing dialog.
mng.DisposeContentDialog();

Legend

Legend
REXContentDialogSettings Class
Legend
Constructor
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXContentDialogSettings Class Members

REXContentDialogSettings Class Members
REXContentDialogSettings Class Legend
Members
Public Methods
Public Method | Description
REXContentDialogSettings | Initializes a new instance of the REXContentDialogSettings class.
REXContentDialogSettings Methods
REXContentDialogSettings Methods | Description
GetSettings | Gets settings.
GetVisibleCategories | Gets visible categories.
IsVisible | Determines whether the specified category is visible.
SetOneCategoryVisible | Sets visibility of specific category.
REXContentDialogSettings Properties
REXContentDialogSettings Properties | Description
Caption | Gets or sets the caption.
Categories | Gets or sets the settings for all categories.
DialogIcon | Gets or sets the dialog icon.
DialogMode | Gets or sets the dialog mode.
MaterialSettings | Gets the settings for the material category.
Progress | Gets or sets a value indicating whether a progress bar should be visible.
RebarShapeSettings | Gets the settings for the rebar shape category.
RebarTypeSettings | Gets the settings for the rebar type category.
RegionalSettings | Gets or sets a value indicating whether regional settings are supported.
SectionDBSettings | Gets the settings for the database section category..
SectionParamSettings | Gets the settings for the parametric section category.
ShowList | Gets or sets a value indicating whether the list of categories should be visible.
ValidateTypes | Gets or sets a value indicating whether types should be validated.

REXContentDialogSettings Methods

REXContentDialogSettings Methods
REXContentDialogSettings Class Legend
REXContentDialogSettings Methods
REXContentDialogSettings Methods | Description
GetSettings | Gets settings.
GetVisibleCategories | Gets visible categories.
IsVisible | Determines whether the specified category is visible.
SetOneCategoryVisible | Sets visibility of specific category.

REXContentDialogSettings Properties

REXContentDialogSettings Properties
REXContentDialogSettings Class Legend
REXContentDialogSettings Properties
REXContentDialogSettings Properties | Description
Caption | Gets or sets the caption.
Categories | Gets or sets the settings for all categories.
DialogIcon | Gets or sets the dialog icon.
DialogMode | Gets or sets the dialog mode.
MaterialSettings | Gets the settings for the material category.
Progress | Gets or sets a value indicating whether a progress bar should be visible.
RebarShapeSettings | Gets the settings for the rebar shape category.
RebarTypeSettings | Gets the settings for the rebar type category.
RegionalSettings | Gets or sets a value indicating whether regional settings are supported.
SectionDBSettings | Gets the settings for the database section category..
SectionParamSettings | Gets the settings for the parametric section category.
ShowList | Gets or sets a value indicating whether the list of categories should be visible.
ValidateTypes | Gets or sets a value indicating whether types should be validated.

REXContentDialogSettings Class Public Methods

REXContentDialogSettings Class Public Methods
REXContentDialogSettings Class Legend
Public Methods
Public Method | Description
REXContentDialogSettings | Initializes a new instance of the REXContentDialogSettings class.

REX.ContentGenerator.Families Namespace Classes

REX.ContentGenerator.Families Namespace Classes
REX.ContentGenerator.Families Namespace Legend
Classes
Class | Description
REXCustomDescription | Base class for all custom description types.
REXDBDescription | Base class for all descriptions of objects in REXFamilyType which were created based on a database.
REXDescription | Base class for all descriptions of objects in REXFamilyType.
REXFamilyType | The base class for all content types supported by the REXContentGenerator.
REXFamilyType_Custom | Base class for all custom types.
REXFamilyType_DBSection | Represents a database section.
REXFamilyType_Label | Represents labels.
REXFamilyType_Material | Represents a material element.
REXFamilyType_ParamSection | Represents a parametric section.
REXFamilyType_Section | Base class for all sections.
REXLabelDescription | Represents label's parameters.
REXMaterialCharacteristics | Represents characteristics of a material.
REXMaterialDBDescription | Represents description of the material.
REXMaterialProperties | Represents properties of the material.
REXParamDescription | Base class for all descriptions of objects in REXFamilyType which were created based on a parametric description (not database).
REXSectionDBCharacteristics | Describes geometry characteristics of a database section.
REXSectionDBDescription | Represents parameters of the database section.
REXSectionDBDimensions | Describes dimensions of the database section.
REXSectionDBProperties | Describes properties of the database section.
REXSectionParamCharacteristics | Describes characteristics of the parametric section.
REXSectionParamDescription | Represents parameters of the parametric section.
REXSectionParamDimensions | Desribes dimentsions of the parametric section.
SerializableObject | Allows to save an object into a stream.

Legend

Legend
REX.ContentGenerator.Families Namespace
Legend
Class
abstract
Enumeration