REXProgressBar.StepForward Method

REXProgressBar.StepForward Method
REXProgressBar Class REX.Controls.Forms Namespace REXProgressBar Class

Takes a step forward.

C#
public void StepForward();
Description
Class

REXProgressBar Class

Links
REXProgressBar Class, REX.Controls.Forms Namespace, REXProgressBar Class

REXProgressBar.Animate Property

REXProgressBar.Animate Property
REXProgressBar Class REX.Controls.Forms Namespace REXProgressBar Class

Gets or sets a value indicating whether animation should be run.

C#
[Category("Animation")]
public bool Animate;
Description

True if animate; otherwise, false.

Class

REXProgressBar Class

Links
REXProgressBar Class, REX.Controls.Forms Namespace, REXProgressBar Class

REXProgressBar.BackgroundColor Property

REXProgressBar.BackgroundColor Property
REXProgressBar Class REX.Controls.Forms Namespace REXProgressBar Class

Gets or sets the color of the background.

C#
[Category("Progress colors")]
public Color BackgroundColor;
Description

The color of the background.

Class

REXProgressBar Class

Links
REXProgressBar Class, REX.Controls.Forms Namespace, REXProgressBar Class

REXProgressBar.EndColor Property

REXProgressBar.EndColor Property
REXProgressBar Class REX.Controls.Forms Namespace REXProgressBar Class

Gets or sets the end color.

C#
[Category("Progress colors")]
public Color EndColor;
Description

The end color.

Class

REXProgressBar Class

Links
REXProgressBar Class, REX.Controls.Forms Namespace, REXProgressBar Class

REXProgressBar.GlowColor Property

REXProgressBar.GlowColor Property
REXProgressBar Class REX.Controls.Forms Namespace REXProgressBar Class

Gets or sets the color of the glow.

C#
[Category("Progress colors")]
public Color GlowColor;
Description

The color of the glow.

Class

REXProgressBar Class

Links
REXProgressBar Class, REX.Controls.Forms Namespace, REXProgressBar Class

REXProgressBar.HighlightColor Property

REXProgressBar.HighlightColor Property
REXProgressBar Class REX.Controls.Forms Namespace REXProgressBar Class

Gets or sets the color of the highlight.

C#
[Category("Progress colors")]
public Color HighlightColor;
Description

The color of the highlight.

Class

REXProgressBar Class

Links
REXProgressBar Class, REX.Controls.Forms Namespace, REXProgressBar Class

REXProgressBar.MaxValue Property

REXProgressBar.MaxValue Property
REXProgressBar Class REX.Controls.Forms Namespace REXProgressBar Class

Gets or sets the maximum value of the range of the control.

C#
[Category("Values")]
public int MaxValue;
Description

The maximum value of the range.

Class

REXProgressBar Class

Links
REXProgressBar Class, REX.Controls.Forms Namespace, REXProgressBar Class

REXProgressBar.MinValue Property

REXProgressBar.MinValue Property
REXProgressBar Class REX.Controls.Forms Namespace REXProgressBar Class

Gets or sets the minimum value of the range of the control.

C#
[Category("Values")]
public int MinValue;
Description

The minimum value of the range.

Class

REXProgressBar Class

Links
REXProgressBar Class, REX.Controls.Forms Namespace, REXProgressBar Class

REXProgressBar.StartColor Property

REXProgressBar.StartColor Property
REXProgressBar Class REX.Controls.Forms Namespace REXProgressBar Class

Gets or sets the start color.

C#
[Category("Progress colors")]
public Color StartColor;
Description

The start color.

Class

REXProgressBar Class

Links
REXProgressBar Class, REX.Controls.Forms Namespace, REXProgressBar Class

REXProgressBar.Step Property

REXProgressBar.Step Property
REXProgressBar Class REX.Controls.Forms Namespace REXProgressBar Class

Gets or sets the step.

C#
[Category("Values")]
public int Step;
Description

The step.

Class

REXProgressBar Class

Links
REXProgressBar Class, REX.Controls.Forms Namespace, REXProgressBar Class

REXProgressBar.Value Property

REXProgressBar.Value Property
REXProgressBar Class REX.Controls.Forms Namespace REXProgressBar Class

Gets or sets the current position of the progress bar.

C#
[Category("Values")]
public int Value;
Description

The position within the range of the progress bar.

Class

REXProgressBar Class

Links
REXProgressBar Class, REX.Controls.Forms Namespace, REXProgressBar Class

REXProgressBar.MaxChangedHandler Delegate

REXProgressBar.MaxChangedHandler Delegate
REXProgressBar Class REX.Controls.Forms Namespace REXProgressBar Class

This is nested type REX.Controls.Forms.REXProgressBar.MaxChangedHandler.

C#
public delegate void MaxChangedHandler(object sender, EventArgs e);
Class

REXProgressBar Class

Links
REXProgressBar Class, REX.Controls.Forms Namespace, REXProgressBar Class

REXProgressBar.MinChangedHandler Delegate

REXProgressBar.MinChangedHandler Delegate
REXProgressBar Class REX.Controls.Forms Namespace REXProgressBar Class

This is nested type REX.Controls.Forms.REXProgressBar.MinChangedHandler.

C#
public delegate void MinChangedHandler(object sender, EventArgs e);
Class

REXProgressBar Class

Links
REXProgressBar Class, REX.Controls.Forms Namespace, REXProgressBar Class

REXProgressBar.ValueChangedHandler Delegate

REXProgressBar.ValueChangedHandler Delegate
REXProgressBar Class REX.Controls.Forms Namespace REXProgressBar Class

This is nested type REX.Controls.Forms.REXProgressBar.ValueChangedHandler.

C#
public delegate void ValueChangedHandler(object sender, EventArgs e);
Class

REXProgressBar Class

Links
REXProgressBar Class, REX.Controls.Forms Namespace, REXProgressBar Class

REXProgressBar.MaxChanged Event

REXProgressBar.MaxChanged Event
REXProgressBar Class REX.Controls.Forms Namespace REXProgressBar Class

This is MaxChanged, a member of class REXProgressBar.

C#
public event MaxChangedHandler MaxChanged;
Class

REXProgressBar Class

Links
REXProgressBar Class, REX.Controls.Forms Namespace, REXProgressBar Class

REXProgressBar.MinChanged Event

REXProgressBar.MinChanged Event
REXProgressBar Class REX.Controls.Forms Namespace REXProgressBar Class

This is MinChanged, a member of class REXProgressBar.

C#
public event MinChangedHandler MinChanged;
Class

REXProgressBar Class

Links
REXProgressBar Class, REX.Controls.Forms Namespace, REXProgressBar Class

REXProgressBar.ValueChanged Event

REXProgressBar.ValueChanged Event
REXProgressBar Class REX.Controls.Forms Namespace REXProgressBar Class

This is ValueChanged, a member of class REXProgressBar.

C#
public event ValueChangedHandler ValueChanged;
Class

REXProgressBar Class

Links
REXProgressBar Class, REX.Controls.Forms Namespace, REXProgressBar Class

REXUnitComboBox Class

REXUnitComboBox Class
REX.Controls.Forms Namespace Legend Members REXUnitComboBox Methods REXUnitComboBox Properties

Represents the REXUnitComboBox control with a IREXUnitEngine.

Class Hierarchy
C#
[System.ComponentModel.ToolboxItem(true)]
[ToolboxBitmapAttribute(typeof(REXUnitComboBox), "REXUnitComboBox.Icon.bmp")]
public class REXUnitComboBox : REXComboBox;
Description
Namespace

REX.Controls.Forms Namespace

REXUnitComboBox Methods
REXUnitComboBox Methods | Description
GetBaseMaxValue | Gets the maximum value and converts it to base units.
GetBaseMinValue | Gets the minimum value and converts it to base units.
GetComplexDataBaseValue | Get the values and convert it to base units.
GetComplexDataInterfaceValue | Get the values and convert it to interface units.
GetDataBaseValue | Gets the value and converts it to base units.
GetDataInterfaceValue | Gets the value and converts it to interface units.
GetInterfaceMaxValue | Gets the maximum value and converts it to interface units.
GetInterfaceMinValue | Gets the minimum value and converts it to interface units.
SetBaseMaxValue | Set the maximum value defined in base units.
SetBaseMinValue | Set the minimum value defined in base units.
SetComplexDataBaseValue | Set the list of values defined in base units.
SetComplexDataInterfaceValue | Set the list of values defined in interface units.
SetDataBaseValue | Set the value in base units.
SetDataInterfaceValue | Set the value in interface units.