Simply add variables to be serialized as name/value pairs to SerializationInfo object. Here you decide which member variables to serialize. Note that any name can be used to identify each serialized field

Example
public virtual void GetObjectData(System.Runtime.Serialization.SerializationInfo info, System.Runtime.Serialization.StreamingContext ctx)
{
    info.AddValue("s1", strPrivate);
    info.AddValue("s2", strPublic);
    into.AddValue("ob", obMyClass);       // Serializing an object
}
Class

REXExtensionDataSerializable Class

Links
REXExtensionDataSerializable Class, REX.Common Namespace, Example, REXExtensionDataSerializable Class

REXExtensionMainControl Class

REXExtensionMainControl Class
REX.Common Namespace Legend Members Public Methods REXExtensionMainControl Properties

Base class for main control.

Class Hierarchy
C#
public class REXExtensionMainControl : REXExtensionControl;
Description

Enables easy access to main module's objects and support additional actions.

Namespace

REX.Common Namespace

Public Methods
Public Method | Description
REXExtensionMainControl | Initializes a new instance of a REXExtensionMainControl class.
REXExtensionMainControl | Initializes a new instance of a REXExtensionMainControl class.
REXExtensionMainControl Properties
REXExtensionMainControl Properties | Description
Components | Get the component.
Links
REX.Common Namespace, Legend, Members, Public Methods, REXExtensionMainControl Properties

REXExtensionMainControl.REXExtensionMainControl Constructor ()

REXExtensionMainControl.REXExtensionMainControl Constructor ()
REXExtensionMainControl Class REX.Common Namespace REXExtensionMainControl Class

Initializes a new instance of a REXExtensionMainControl class.

C#
public REXExtensionMainControl();
Description
Class

REXExtensionMainControl Class

Links
REXExtensionMainControl Class, REX.Common Namespace, REXExtensionMainControl Class

REXExtensionMainControl.REXExtensionMainControl Constructor (REXExtension)

REXExtensionMainControl.REXExtensionMainControl Constructor (REXExtension)
REXExtensionMainControl Class REX.Common Namespace REXExtensionMainControl Class

Initializes a new instance of a REXExtensionMainControl class.

C#
public REXExtensionMainControl(REXExtension Ext);
Parameters
Parameters | Description
Ext | The reference to a REXExtension object.
Description
Class

REXExtensionMainControl Class

Links
REXExtensionMainControl Class, REX.Common Namespace, REXExtensionMainControl Class

REXExtensionMainControl.Components Property

REXExtensionMainControl.Components Property
REXExtensionMainControl Class REX.Common Namespace REXExtensionMainControl Class

Get the component.

C#
public virtual IContainer Components;
Description

The component.

Class

REXExtensionMainControl Class

Links
REXExtensionMainControl Class, REX.Common Namespace, REXExtensionMainControl Class

REXExtensionObject Class

REXExtensionObject Class
REX.Common Namespace Legend Members Public Methods REXExtensionObject Properties

Base class for all objects created in extension module.

Class Hierarchy
C#
public class REXExtensionObject : IREXThisExtension;
Description
Namespace

REX.Common Namespace

Public Methods
Public Method | Description
REXExtensionObject | Initializes a new instance of a REXExtensionObject class.
REXExtensionObject Properties
REXExtensionObject Properties | Description
ThisApplication | Get the application.
ThisContext | Get the context.
ThisExtension | Get the extension.
ThisProduct | Gets the this product.
ThisRunContext | Gets the this run context.
Links
REX.Common Namespace, Legend, Members, Public Methods, REXExtensionObject Properties

REXExtensionObject.REXExtensionObject Constructor

REXExtensionObject.REXExtensionObject Constructor
REXExtensionObject Class REX.Common Namespace REXExtensionObject Class

Initializes a new instance of a REXExtensionObject class.

C#
public REXExtensionObject(REXExtension Extension);
Parameters
Parameters | Description
Extension | The extension.
Description
Class

REXExtensionObject Class

Links
REXExtensionObject Class, REX.Common Namespace, REXExtensionObject Class

REXExtensionObject.ThisApplication Property

REXExtensionObject.ThisApplication Property
REXExtensionObject Class REX.Common Namespace REXExtensionObject Class

Get the application.

C#
public REXApplication ThisApplication;
Description

The application.

Class

REXExtensionObject Class

Links
REXExtensionObject Class, REX.Common Namespace, REXExtensionObject Class

REXExtensionObject.ThisContext Property

REXExtensionObject.ThisContext Property
REXExtensionObject Class REX.Common Namespace REXExtensionObject Class

Get the context.

C#
public REXContext ThisContext;
Description

The context.

Class

REXExtensionObject Class

Links
REXExtensionObject Class, REX.Common Namespace, REXExtensionObject Class

REXExtensionObject.ThisExtension Property

REXExtensionObject.ThisExtension Property
REXExtensionObject Class REX.Common Namespace REXExtensionObject Class

Get the extension.

C#
public REXExtension ThisExtension;
Description

The extension.

Class

REXExtensionObject Class

Links
REXExtensionObject Class, REX.Common Namespace, REXExtensionObject Class

REXExtensionObject.ThisProduct Property

REXExtensionObject.ThisProduct Property
REXExtensionObject Class REX.Common Namespace REXExtensionObject Class

Gets the this product.

C#
public REXInterfaceType ThisProduct;
Description

The this product.

Class

REXExtensionObject Class

Links
REXExtensionObject Class, REX.Common Namespace, REXExtensionObject Class

REXExtensionObject.ThisRunContext Property

REXExtensionObject.ThisRunContext Property
REXExtensionObject Class REX.Common Namespace REXExtensionObject Class

Gets the this run context.

C#
public REX.Common.REXExtensionContext.REXStandardRunContext ThisRunContext;
Description

The this run context.

Class

REXExtensionObject Class

Links
REXExtensionObject Class, REX.Common Namespace, REXExtensionObject Class

REXExtensionPanel Class

REXExtensionPanel Class
REX.Common Namespace Legend Members Public Methods REXExtensionPanel Methods REXExtensionPanel Properties

Base class for panel control.

Class Hierarchy
C#
public class REXExtensionPanel : System.Windows.Controls.Panel, IREXThisExtension;
Description

Enables easy access to main module's objects and support additional actions. Additionally enables one instane control container.

Namespace

REX.Common Namespace

Public Methods
Public Method | Description
REXExtensionPanel | Initializes a new instance of a REXExtensionForm class.
REXExtensionPanel | Initializes a new instance of a REXExtensionForm class.
REXExtensionPanel Methods
REXExtensionPanel Methods | Description
SetControl | Sets the control.
REXExtensionPanel Properties
REXExtensionPanel Properties | Description
ThisApplication | Get this application.
ThisContext | Get this context.
ThisExtension | Get this extension.
ThisProduct | Gets the this product.
ThisRunContext | Gets the this run context.
Links
REX.Common Namespace, Legend, Members, Public Methods, REXExtensionPanel Methods, REXExtensionPanel Properties

REXExtensionPanel.REXExtensionPanel Constructor ()

REXExtensionPanel.REXExtensionPanel Constructor ()
REXExtensionPanel Class REX.Common Namespace REXExtensionPanel Class

Initializes a new instance of a REXExtensionForm class.

C#
public REXExtensionPanel();
Description
Class

REXExtensionPanel Class

Links
REXExtensionPanel Class, REX.Common Namespace, REXExtensionPanel Class

REXExtensionPanel.REXExtensionPanel Constructor (REXExtension)

REXExtensionPanel.REXExtensionPanel Constructor (REXExtension)
REXExtensionPanel Class REX.Common Namespace REXExtensionPanel Class

Initializes a new instance of a REXExtensionForm class.

C#
public REXExtensionPanel(REXExtension Ext);
Parameters
Parameters | Description
Ext | The reference to a REXExtension object.
Description
Class

REXExtensionPanel Class

Links