Description
Class

REXContentParamFilter Class

Links
REXContentParamFilter Class, REX.ContentGenerator.Converters Namespace, REXContentParamFilter Class

REXContentParamFilter.ParamName Property

REXContentParamFilter.ParamName Property
REXContentParamFilter Class REX.ContentGenerator.Converters Namespace REXContentParamFilter Class

Gets or sets the name of the parameter which is constrained.

C#
public string ParamName;
Description

The name of the parameter.

Class

REXContentParamFilter Class

Links
REXContentParamFilter Class, REX.ContentGenerator.Converters Namespace, REXContentParamFilter Class

REXCustomFactory Class

REXCustomFactory Class
REX.ContentGenerator.Converters Namespace Legend Members Public Methods REXCustomFactory Methods

This is class REX.ContentGenerator.Converters.REXCustomFactory.

Class Hierarchy
C#
public class REXCustomFactory<T_REXFamilyType, T_REXDescription> : REXFamilyFactory where T_REXFamilyType : new() where T_REXDescription : new();
Namespace

REX.ContentGenerator.Converters Namespace

Public Methods
Public Method | Description
REXCustomFactory | This is REXCustomFactory, a member of class REXCustomFactory.
REXCustomFactory Methods
REXCustomFactory Methods | Description
Close | This is Close, a member of class REXCustomFactory.
GetAliasName | This is GetAliasName, a member of class REXCustomFactory.
GetAllFamilies | This is GetAllFamilies, a member of class REXCustomFactory.
GetDBList | This is GetDBList, a member of class REXCustomFactory.
GetDBList | This is GetDBList, a member of class REXCustomFactory.
GetFamiliesOfAlias | This is GetFamiliesOfAlias, a member of class REXCustomFactory.
GetFamily | This is GetFamily, a member of class REXCustomFactory.
GetFamilyDefault | This is GetFamilyDefault, a member of class REXCustomFactory.
GetFamilyOfAlias | This is GetFamilyOfAlias, a member of class REXCustomFactory.
GetFamilyTemplate | This is GetFamilyTemplate, a member of class REXCustomFactory.
Links
REX.ContentGenerator.Converters Namespace, Legend, Members, Public Methods, REXCustomFactory Methods

REXCustomFactory.REXCustomFactory Constructor

REXCustomFactory.REXCustomFactory Constructor
REXCustomFactory Class REX.ContentGenerator.Converters Namespace REXCustomFactory Class

This is REXCustomFactory, a member of class REXCustomFactory.

C#
public REXCustomFactory(string categoryName, RexConversionSettings settings);
Class

REXCustomFactory Class

Links
REXCustomFactory Class, REX.ContentGenerator.Converters Namespace, REXCustomFactory Class

REXCustomFactory.Close Method

REXCustomFactory.Close Method
REXCustomFactory Class REX.ContentGenerator.Converters Namespace REXCustomFactory Class

This is Close, a member of class REXCustomFactory.

C#
public override void Close();
Class

REXCustomFactory Class

Links
REXCustomFactory Class, REX.ContentGenerator.Converters Namespace, REXCustomFactory Class

REXCustomFactory.GetAliasName Method

REXCustomFactory.GetAliasName Method
REXCustomFactory Class REX.ContentGenerator.Converters Namespace REXCustomFactory Class

This is GetAliasName, a member of class REXCustomFactory.

C#
public override bool GetAliasName(REXDBDescription DBdesc, out string type, out System.Collections.Generic.List<string> alias);
Class

REXCustomFactory Class

Links
REXCustomFactory Class, REX.ContentGenerator.Converters Namespace, REXCustomFactory Class

REXCustomFactory.GetAllFamilies Method

REXCustomFactory.GetAllFamilies Method
REXCustomFactory Class REX.ContentGenerator.Converters Namespace REXCustomFactory Class

This is GetAllFamilies, a member of class REXCustomFactory.

C#
public override System.Collections.Generic.List<REXFamilyType> GetAllFamilies(string dir, string dbname, REXContentFilter filter, bool forMapping);
Class

REXCustomFactory Class

Links
REXCustomFactory Class, REX.ContentGenerator.Converters Namespace, REXCustomFactory Class

REXCustomFactory.GetDBList Method (REXFamilyType, string, string)

REXCustomFactory.GetDBList Method (REXFamilyType, string, string)
REXCustomFactory Class REX.ContentGenerator.Converters Namespace REXCustomFactory Class

This is GetDBList, a member of class REXCustomFactory.

C#
public override System.Collections.Generic.List<REXDBDescription> GetDBList(REXFamilyType obj, string dbname, string dir);
Class

REXCustomFactory Class

Links
REXCustomFactory Class, REX.ContentGenerator.Converters Namespace, REXCustomFactory Class

REXCustomFactory.GetDBList Method (System.Collections.Generic.List<REXFamilyType>, string, string)

REXCustomFactory.GetDBList Method (System.Collections.Generic.List<REXFamilyType>, string, string)
REXCustomFactory Class REX.ContentGenerator.Converters Namespace REXCustomFactory Class

This is GetDBList, a member of class REXCustomFactory.

C#
public override System.Collections.Generic.List<REXDBDescription> GetDBList(System.Collections.Generic.List<REXFamilyType> obj, string dbname, string dir);
Class

REXCustomFactory Class

Links
REXCustomFactory Class, REX.ContentGenerator.Converters Namespace, REXCustomFactory Class

REXCustomFactory.GetFamiliesOfAlias Method

REXCustomFactory.GetFamiliesOfAlias Method
REXCustomFactory Class REX.ContentGenerator.Converters Namespace REXCustomFactory Class

This is GetFamiliesOfAlias, a member of class REXCustomFactory.

C#
public override List<REXFamilyType> GetFamiliesOfAlias(REX.ContentGenerator.Families.EElementType el, string alias, out bool found);
Class

REXCustomFactory Class

Links
REXCustomFactory Class, REX.ContentGenerator.Converters Namespace, REXCustomFactory Class

REXCustomFactory.GetFamily Method

REXCustomFactory.GetFamily Method
REXCustomFactory Class REX.ContentGenerator.Converters Namespace REXCustomFactory Class

This is GetFamily, a member of class REXCustomFactory.

C#
public override REXFamilyType GetFamily(REXDBDescription DBdesc, REX.ContentGenerator.Families.EElementType el, EMaterial mat);
Class

REXCustomFactory Class

Links
REXCustomFactory Class, REX.ContentGenerator.Converters Namespace, REXCustomFactory Class

REXCustomFactory.GetFamilyDefault Method

REXCustomFactory.GetFamilyDefault Method
REXCustomFactory Class REX.ContentGenerator.Converters Namespace REXCustomFactory Class

This is GetFamilyDefault, a member of class REXCustomFactory.

C#
public override REXFamilyType GetFamilyDefault(REX.ContentGenerator.Families.EElementType el, EMaterial mat, string type);
Class

REXCustomFactory Class

Links
REXCustomFactory Class, REX.ContentGenerator.Converters Namespace, REXCustomFactory Class

REXCustomFactory.GetFamilyOfAlias Method

REXCustomFactory.GetFamilyOfAlias Method
REXCustomFactory Class REX.ContentGenerator.Converters Namespace REXCustomFactory Class

This is GetFamilyOfAlias, a member of class REXCustomFactory.

C#
public override REXFamilyType GetFamilyOfAlias(REX.ContentGenerator.Families.EElementType el, string alias, out bool found);
Class

REXCustomFactory Class

Links
REXCustomFactory Class, REX.ContentGenerator.Converters Namespace, REXCustomFactory Class

REXCustomFactory.GetFamilyTemplate Method

REXCustomFactory.GetFamilyTemplate Method
REXCustomFactory Class REX.ContentGenerator.Converters Namespace REXCustomFactory Class

This is GetFamilyTemplate, a member of class REXCustomFactory.

C#
public override REXFamilyType GetFamilyTemplate(REX.ContentGenerator.Families.EElementType el, EMaterial mat);
Class

REXCustomFactory Class

Links
REXCustomFactory Class, REX.ContentGenerator.Converters Namespace, REXCustomFactory Class

REXDBSectionFactory Class

REXDBSectionFactory Class
REX.ContentGenerator.Converters Namespace Legend Members Public Methods REXDBSectionFactory Methods

This is class REX.ContentGenerator.Converters.REXDBSectionFactory.

Class Hierarchy
C#
public class REXDBSectionFactory : REXFamilyFactoryDbRootAdo;
Namespace

REX.ContentGenerator.Converters Namespace

Public Methods
Public Method | Description
REXDBSectionFactory | This is REXDBSectionFactory, a member of class REXDBSectionFactory.