Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXDFM Methods

REXDFM Methods
REXDFM Class Legend
REXDFM Methods
REXDFM Methods | Description
AddDisplayUnitObject | Registers an object which implements the IUnitObject interface.
AddDisplayUnitObject | Registers an object which implements the IUnitObject interface.
AddDisplayUnitObject | Registers an object which implements the IUnitObject interface.
AddDisplayUnitObject | Registers an object which implements the IUnitObject interface.
AddUnitObject | Registers an object which implements the IUnitObject interface.
AddUnitObject | Registers an object which implements the IUnitObject interface.
AddUnitObject | Registers an object which implements the IUnitObject interface.
AddUnitObject | Registers an object which implements the IUnitObject interface.
AfterParamsChange | Method called after parameters change.
BeforeParamsChange | Method called before parameters change.
Clear | Clears this instance.
CreateGroupControl | Creates the group of controls from collection of controls and all childrenss.
CreateGroupControl | Creates the group of controls from all childrens.
CreateGroupControl | Creates the group of controls from collection of controls and all childrenss.
CreateGroupControl | Creates the group of controls from all childrens.
GetComplexDataBase | Gets the values and convert it to base units.
GetComplexDataBase | Gets the values and converts them to base units.
GetComplexDataDisplay | Gets the values and convert it to display units.
GetComplexDataDisplay | Gets the values and convert it to display units.
GetComplexDataInterface | Gets the values and convert it to interface units.
GetComplexDataInterface | Gets the values and converts it to interface units.
GetDataBase | Gets the value and converts it to base units.
GetDataBase | Gets the value and converts it to base units.
GetDataDisplay | Gets the value and converts it to display units.
GetDataDisplay | Gets the value and converts it to display units.
GetDataInterface | Gets the value and converts it to interface units.
GetDataInterface | Gets the value and converts it to interface units.
GetDataText | Gets the current text.
GetDataText | Gets the current text.
GetObjectsOfNotOkState | Gets the list of registered objects which are in a state other then OK.
RemoveUnitObject | Removes the unit object.
RemoveUnitObject | Removes the unit object.
SetBaseMaxValue | Sets the maximum value defined in base units.
SetBaseMaxValue | Sets the maximum value defined in base units.
SetBaseMinValue | Sets the minimum value in base units.
SetBaseMinValue | Sets the minimum value in base units.
SetComplexDataBase | Sets the list of values in base units.
SetComplexDataBase | Sets the list of values in base units.
SetComplexDataDisplay | Sets the list of values defined in display units.
SetComplexDataDisplay | Sets the list of values defined in display units.
SetComplexDataInterface | Sets the list of values in interface units.
SetComplexDataInterface | Sets the list of values in interface units.
SetDataBase | Sets the value defined in base units.
SetDataBase | Sets the value defined in base units.
SetDataDisplay | Sets the value defined in display units.
SetDataDisplay | Sets the value defined in display units.
SetDataInterface | Sets the value defined in interface units.
SetDataInterface | Sets the value defined in interface units.
SetDataText | Sets the current text.
SetDataText | Sets the current text.
SetInterfaceMaxValue | Sets the maximum value defined in interface units.
SetInterfaceMaxValue | Sets the maximum value defined in interface units.
SetInterfaceMinValue | Sets the minimum value defined in interface units.
SetInterfaceMinValue | Sets the minimum value defined in interface units.
SetUserValidFunction | Sets the user validation function.
SetUserValidFunction | Sets the user validation function.
SetUserValidFunctionComplex | Sets the user validation function for lists of values.
SetUserValidFunctionComplex | Sets the user validation function for lists of values.
ValidateDataBase | Validates the value in base units.
ValidateDataBase | Validates the value in base units.
ValidateDataDisplay | Validates the value in display units.
ValidateDataDisplay | Validates the value in display units.
ValidateDataInterface | Validates the value in interface units.
ValidateDataInterface | Validates the value in interface units.

REXDFM Properties

REXDFM Properties
REXDFM Class Legend
REXDFM Properties
REXDFM Properties | Description
AllowReplaceObject | Gets or sets a value indicating whether controlling object may be replaced during registration.
Count | Gets the number of controling objects.

REXDFM Class Public Methods

REXDFM Class Public Methods
REXDFM Class Legend
Public Methods
Public Method | Description
REXDFM | Initializes a new instance of the REXDFM class.
REXDFM | Initializes a new instance of the REXDFM class.
REXDFM | Initializes a new instance of the REXDFM class.

DisplayDefinition Fields

DisplayDefinition Fields
REXDFM.DisplayDefinition Class Legend
DisplayDefinition Fields
DisplayDefinition Fields | Description
DisplayType | This is DisplayType, a member of class DisplayDefinition.
EngineeringFormat | This is EngineeringFormat, a member of class DisplayDefinition.
Power | This is Power, a member of class DisplayDefinition.
RoundingIncrement | This is RoundingIncrement, a member of class DisplayDefinition.
Separator | This is Separator, a member of class DisplayDefinition.
UnitDefinition | This is UnitDefinition, a member of class DisplayDefinition.
UnitSymbol | This is UnitSymbol, a member of class DisplayDefinition.

Fields (AutoDoc Folder)

Legend
Legend
Data Member
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

Legend

Legend
REXDFM.DisplayDefinition Class
Legend
Constructor
Data Member
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXDFM.DisplayDefinition Class Members

REXDFM.DisplayDefinition Class Members
REXDFM.DisplayDefinition Class Legend
Members
Public Methods
Public Method | Description
DisplayDefinition | Initializes a new instance of the DisplayDefinition class.
DisplayDefinition | Initializes a new instance of the DisplayDefinition class.
DisplayDefinition | Initializes a new instance of the DisplayDefinition class.
DisplayDefinition Fields
DisplayDefinition Fields | Description
DisplayType | This is DisplayType, a member of class DisplayDefinition.
EngineeringFormat | This is EngineeringFormat, a member of class DisplayDefinition.
Power | This is Power, a member of class DisplayDefinition.
RoundingIncrement | This is RoundingIncrement, a member of class DisplayDefinition.
Separator | This is Separator, a member of class DisplayDefinition.
UnitDefinition | This is UnitDefinition, a member of class DisplayDefinition.
UnitSymbol | This is UnitSymbol, a member of class DisplayDefinition.
DisplayDefinition Methods
DisplayDefinition Methods | Description
Equals | Determines whether the specified T:System.Object is equal to the current T:System.Object.
ReadFromCategory | Reads the unit definition based on the category.
ReadFromCategory | Reads the unit definition based on the category.

Members

Legend
Legend
Constructor
Data Member
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

DisplayDefinition Methods

DisplayDefinition Methods