REXExtension.Run Method
REXExtension Class REX.Common Namespace REXExtension Class

Runs process calculations or other operations.

C#
public virtual bool Run();
Returns

Returns true if succeeded.

Description

Calls: OnSetData(), OnCanRun(), OnClear(), OnSaveTemplate(), OnRun(), OnShowResults() methods.

Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.RunQuestion Method

REXExtension.RunQuestion Method
REXExtension Class REX.Common Namespace REXExtension Class

Runs the question.

C#
public virtual bool RunQuestion(string Caption, string Text);
Parameters
Parameters | Description
Caption | The caption.
Text | The text.
Returns

If user selects "Yes" returns true, otherwise returns false.

Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.SetCanClose Method

REXExtension.SetCanClose Method
REXExtension Class REX.Common Namespace REXExtension Class

If the method will be called on OnCanRun method, Module will not close after return false.

C#
public virtual void SetCanClose(bool CanClose);
Parameters
Parameters | Description
CanClose | if set to true can close.
Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.SetContext Method

REXExtension.SetContext Method
REXExtension Class REX.Common Namespace REXExtension Class

Initializes this instance.

C#
public void SetContext();
Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.SetCreateFail Method ()

REXExtension.SetCreateFail Method ()
REXExtension Class REX.Common Namespace REXExtension Class

If the method will be called on OnCreate method, Module will not continue work.

C#
public virtual void SetCreateFail();
Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.SetCreateFail Method (string)

REXExtension.SetCreateFail Method (string)
REXExtension Class REX.Common Namespace REXExtension Class

If the method will be called on OnCreate method, Module will not continue work.

C#
public virtual void SetCreateFail(string Error);
Parameters
Parameters | Description
Error | An error string for message box.
Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.Setup Method

REXExtension.Setup Method
REXExtension Class REX.Common Namespace REXExtension Class

Setups this extension.

C#
public virtual void Setup();
Description

Calls: OnCreateLayout(), OnSetDialogs(), OnLoadTemplate() virtual methods.

Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.SetupCommands Method

REXExtension.SetupCommands Method
REXExtension Class REX.Common Namespace REXExtension Class

Initializes the commands.

C#
public virtual void SetupCommands();
Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.SetupDefaultCommands Method

REXExtension.SetupDefaultCommands Method
REXExtension Class REX.Common Namespace REXExtension Class

Initializes the default commands.

C#
public virtual void SetupDefaultCommands();
Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.ShowMessageBox Method (IWin32Window, string)

REXExtension.ShowMessageBox Method (IWin32Window, string)
REXExtension Class REX.Common Namespace REXExtension Class

This is ShowMessageBox, a member of class REXExtension.

C#
public DialogResult ShowMessageBox(IWin32Window owner, string text);
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.ShowMessageBox Method (IWin32Window, string, MessageBoxButtons)

REXExtension.ShowMessageBox Method (IWin32Window, string, MessageBoxButtons)
REXExtension Class REX.Common Namespace REXExtension Class

This is ShowMessageBox, a member of class REXExtension.

C#
public DialogResult ShowMessageBox(IWin32Window owner, string text, MessageBoxButtons buttons);
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.ShowMessageBox Method (Window, string)

REXExtension.ShowMessageBox Method (Window, string)
REXExtension Class REX.Common Namespace REXExtension Class

This is ShowMessageBox, a member of class REXExtension.

C#
public MessageBoxResult ShowMessageBox(Window owner, string text);
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.ShowMessageBox Method (Window, string, MessageBoxButton)

REXExtension.ShowMessageBox Method (Window, string, MessageBoxButton)
REXExtension Class REX.Common Namespace REXExtension Class

This is ShowMessageBox, a member of class REXExtension.

C#
public MessageBoxResult ShowMessageBox(Window owner, string text, MessageBoxButton buttons);
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.ShowMessageBox Method (string)

REXExtension.ShowMessageBox Method (string)
REXExtension Class REX.Common Namespace REXExtension Class

This is ShowMessageBox, a member of class REXExtension.

C#
public MessageBoxResult ShowMessageBox(string text);
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.ShowMessageBox Method (string, MessageBoxButton)

REXExtension.ShowMessageBox Method (string, MessageBoxButton)
REXExtension Class REX.Common Namespace REXExtension Class

This is ShowMessageBox, a member of class REXExtension.

C#
public MessageBoxResult ShowMessageBox(string text, MessageBoxButton buttons);
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.ShowMessageBox Method (string, MessageBoxButtons)

REXExtension.ShowMessageBox Method (string, MessageBoxButtons)
REXExtension Class REX.Common Namespace REXExtension Class

This is ShowMessageBox, a member of class REXExtension.

C#
public DialogResult ShowMessageBox(string text, MessageBoxButtons buttons);
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.ShowPreferencesDialog Method

REXExtension.ShowPreferencesDialog Method
REXExtension Class REX.Common Namespace REXExtension Class

This is ShowPreferencesDialog, a member of class REXExtension.

C#
public void ShowPreferencesDialog();
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.Status Method

REXExtension.Status Method
REXExtension Class REX.Common Namespace REXExtension Class

Get current status of module.

C#
public virtual object Status();
Returns

Returns status. See Autodesk.REX.Framework.REXStatusType.

Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.Context Property

REXExtension.Context Property
REXExtension Class REX.Common Namespace REXExtension Class

Get the reference to current context object.

C#
public REXContext Context;
Description

The context object.

Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.DFM Property

REXExtension.DFM Property
REXExtension Class REX.Common Namespace REXExtension Class

Gets the DFM object to manage all UI controls which support Revit Extension units.

C#
public REXDFM DFM;
Description

A reference to DFM object.

Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class

REXExtension.ExtensionContext Property

REXExtension.ExtensionContext Property
REXExtension Class REX.Common Namespace REXExtension Class

Get the reference to the old extension context object.

C#
public REXExtensionContext ExtensionContext;
Description

The extension context object.