SetComplexDataInterface | Sets the list of values in interface units.
SetComplexDataInterface | Sets the list of values in interface units.
SetDataBase | Sets the value defined in base units.
SetDataBase | Sets the value defined in base units.
SetDataDisplay | Sets the value defined in display units.
SetDataDisplay | Sets the value defined in display units.
SetDataInterface | Sets the value defined in interface units.
SetDataInterface | Sets the value defined in interface units.
SetDataText | Sets the current text.
SetDataText | Sets the current text.
SetInterfaceMaxValue | Sets the maximum value defined in interface units.
SetInterfaceMaxValue | Sets the maximum value defined in interface units.
SetInterfaceMinValue | Sets the minimum value defined in interface units.
SetInterfaceMinValue | Sets the minimum value defined in interface units.
SetUserValidFunction | Sets the user validation function.
SetUserValidFunction | Sets the user validation function.
SetUserValidFunctionComplex | Sets the user validation function for lists of values.
SetUserValidFunctionComplex | Sets the user validation function for lists of values.
ValidateDataBase | Validates the value in base units.
ValidateDataBase | Validates the value in base units.
ValidateDataDisplay | Validates the value in display units.
ValidateDataDisplay | Validates the value in display units.
ValidateDataInterface | Validates the value in interface units.
ValidateDataInterface | Validates the value in interface units.
REXDFM Properties
REXDFM Properties | Description
AllowReplaceObject | Gets or sets a value indicating whether controlling object may be replaced during registration.
Count | Gets the number of controling objects.
Links
REX.Common Namespace, Legend, Members, Public Methods, REXDFM Classes, REXDFM Delegates, REXDFM Events, REXDFM Methods, REXDFM Properties

REXDFM.REXDFM Constructor (REXExtension)

REXDFM.REXDFM Constructor (REXExtension)
REXDFM Class REX.Common Namespace REXDFM Class

Initializes a new instance of the REXDFM class.

C#
public REXDFM(REXExtension extension);
Parameters
Parameters | Description
extension | The extension.
Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class

REXDFM.REXDFM Constructor (REXExtension, REXInterfaceType)

REXDFM.REXDFM Constructor (REXExtension, REXInterfaceType)
REXDFM Class REX.Common Namespace REXDFM Class

Initializes a new instance of the REXDFM class.

C#
public REXDFM(REXExtension extension, REXInterfaceType contextWork);
Parameters
Parameters | Description
extension | The extension.
contextWork | The context.
Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class

REXDFM.REXDFM Constructor (REXExtension, string)

REXDFM.REXDFM Constructor (REXExtension, string)
REXDFM Class REX.Common Namespace REXDFM Class

Initializes a new instance of the REXDFM class.

C#
public REXDFM(REXExtension extension, string contextWorkName);
Parameters
Parameters | Description
extension | The extension.
contextWorkName | The name of the context.
Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class

REXDFM.DisplayDefinition Class

REXDFM.DisplayDefinition Class
REXDFM Class Legend Members Public Methods DisplayDefinition Fields DisplayDefinition Methods

Represents the display settings of the specified unit category.

Class Hierarchy
C#
public class DisplayDefinition;
Description
Class

REXDFM Class

Public Methods
Public Method | Description
DisplayDefinition | Initializes a new instance of the DisplayDefinition class.
DisplayDefinition | Initializes a new instance of the DisplayDefinition class.
DisplayDefinition | Initializes a new instance of the DisplayDefinition class.
DisplayDefinition Fields
DisplayDefinition Fields | Description
DisplayType | This is DisplayType, a member of class DisplayDefinition.
EngineeringFormat | This is EngineeringFormat, a member of class DisplayDefinition.
Power | This is Power, a member of class DisplayDefinition.
RoundingIncrement | This is RoundingIncrement, a member of class DisplayDefinition.
Separator | This is Separator, a member of class DisplayDefinition.
UnitDefinition | This is UnitDefinition, a member of class DisplayDefinition.
UnitSymbol | This is UnitSymbol, a member of class DisplayDefinition.
DisplayDefinition Methods
DisplayDefinition Methods | Description
Equals | Determines whether the specified T:System.Object is equal to the current T:System.Object.
ReadFromCategory | Reads the unit definition based on the category.
ReadFromCategory | Reads the unit definition based on the category.
Links
REXDFM Class, Legend, Members, Public Methods, DisplayDefinition Fields, DisplayDefinition Methods

REXDFM.DisplayDefinition.DisplayDefinition Constructor ()

REXDFM.DisplayDefinition.DisplayDefinition Constructor ()
REXDFM.DisplayDefinition Class REX.Common Namespace REXDFM.DisplayDefinition Class

Initializes a new instance of the DisplayDefinition class.

C#
public DisplayDefinition();
Description
Class

REXDFM.DisplayDefinition Class

Links
REXDFM.DisplayDefinition Class, REX.Common Namespace, REXDFM.DisplayDefinition Class

REXDFM.DisplayDefinition.DisplayDefinition Constructor (REXUnits, Autodesk.REX.Framework.EUnitType, double)

REXDFM.DisplayDefinition.DisplayDefinition Constructor (REXUnits, Autodesk.REX.Framework.EUnitType, double)
REXDFM.DisplayDefinition Class REX.Common Namespace REXDFM.DisplayDefinition Class

Initializes a new instance of the DisplayDefinition class.

C#
public DisplayDefinition(REXUnits Units, Autodesk.REX.Framework.EUnitType UnitType, double Power);
Parameters
Parameters | Description
Units | The unit engine.
UnitType | The type of the unit.
Power | The power.
Description
Class

REXDFM.DisplayDefinition Class

Links
REXDFM.DisplayDefinition Class, REX.Common Namespace, REXDFM.DisplayDefinition Class

REXDFM.DisplayDefinition.DisplayDefinition Constructor (REXUnits, string, double)

REXDFM.DisplayDefinition.DisplayDefinition Constructor (REXUnits, string, double)
REXDFM.DisplayDefinition Class REX.Common Namespace REXDFM.DisplayDefinition Class

Initializes a new instance of the DisplayDefinition class.

C#
public DisplayDefinition(REXUnits Units, string UnitName, double Power);
Parameters
Parameters | Description
Units | The unit engine.
UnitName | The name of the unit.
Power | The power.
Description
Class

REXDFM.DisplayDefinition Class

Links
REXDFM.DisplayDefinition Class, REX.Common Namespace, REXDFM.DisplayDefinition Class

REXDFM.DisplayDefinition.DisplayType Field

REXDFM.DisplayDefinition.DisplayType Field
REXDFM.DisplayDefinition Class REX.Common Namespace REXDFM.DisplayDefinition Class

This is DisplayType, a member of class DisplayDefinition.

C#
public REXUnitsDisplayTypes DisplayType = REXUnitsDisplayTypes.Text;
Class

REXDFM.DisplayDefinition Class

Links
REXDFM.DisplayDefinition Class, REX.Common Namespace, REXDFM.DisplayDefinition Class

REXDFM.DisplayDefinition.EngineeringFormat Field

REXDFM.DisplayDefinition.EngineeringFormat Field
REXDFM.DisplayDefinition Class REX.Common Namespace REXDFM.DisplayDefinition Class

This is EngineeringFormat, a member of class DisplayDefinition.

C#
public bool EngineeringFormat = false;
Class

REXDFM.DisplayDefinition Class

Links
REXDFM.DisplayDefinition Class, REX.Common Namespace, REXDFM.DisplayDefinition Class

REXDFM.DisplayDefinition.Power Field

REXDFM.DisplayDefinition.Power Field
REXDFM.DisplayDefinition Class REX.Common Namespace REXDFM.DisplayDefinition Class

This is Power, a member of class DisplayDefinition.

C#
public double Power = 1;
Class

REXDFM.DisplayDefinition Class

Links
REXDFM.DisplayDefinition Class, REX.Common Namespace, REXDFM.DisplayDefinition Class

REXDFM.DisplayDefinition.RoundingIncrement Field

REXDFM.DisplayDefinition.RoundingIncrement Field
REXDFM.DisplayDefinition Class REX.Common Namespace REXDFM.DisplayDefinition Class