AutoSize | Gets or sets a value indicating whether the control is automatically resized to display its entire contents.
IndexCoeff | Gets or sets the proportion between index and it's parent.
LeftAlign | Gets or sets a value indicating whether the content of the control should be aligned to the left.
Text | Gets the text contents of the control.
TextAlign | Gets or sets the alignment of text in the label.

REXIndexLabel Class Public Methods

REXIndexLabel Class Public Methods
REXIndexLabel Class Legend
Public Methods
Public Method | Description
REXIndexLabel | Initializes a new instance of the REXIndexLabel class.

Legend

Legend
REXPictureBox Class
Legend
Constructor
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXPictureBox Class Members

REXPictureBox Class Members
REXPictureBox Class Legend
Members
Public Methods
Public Method | Description
REXPictureBox | This is REXPictureBox, a member of class REXPictureBox.

REXPictureBox Class Public Methods

REXPictureBox Class Public Methods
REXPictureBox Class Legend
Public Methods
Public Method | Description
REXPictureBox | This is REXPictureBox, a member of class REXPictureBox.

REXProgressBar Delegates

REXProgressBar Delegates
REXProgressBar Class
REXProgressBar Delegates
REXProgressBar Delegates | Description
MaxChangedHandler | This is nested type REX.Controls.Forms.REXProgressBar.MaxChangedHandler.
MinChangedHandler | This is nested type REX.Controls.Forms.REXProgressBar.MinChangedHandler.
ValueChangedHandler | This is nested type REX.Controls.Forms.REXProgressBar.ValueChangedHandler.

REXProgressBar Events

REXProgressBar Events
REXProgressBar Class Legend
REXProgressBar Events
REXProgressBar Events | Description
MaxChanged | This is MaxChanged, a member of class REXProgressBar.
MinChanged | This is MinChanged, a member of class REXProgressBar.
ValueChanged | This is ValueChanged, a member of class REXProgressBar.

Legend

Legend
REXProgressBar Class
Legend
Constructor
Property
Event
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXProgressBar Class Members

REXProgressBar Class Members
REXProgressBar Class Legend
Members
Public Methods
Public Method | Description
REXProgressBar | Initializes a new instance of the REXProgressBar class.
REXProgressBar Methods
REXProgressBar Methods | Description
StepBack | Takes a step back.
StepForward | Takes a step forward.
REXProgressBar Properties
REXProgressBar Properties | Description
Animate | Gets or sets a value indicating whether animation should be run.
BackgroundColor | Gets or sets the color of the background.
EndColor | Gets or sets the end color.
GlowColor | Gets or sets the color of the glow.
HighlightColor | Gets or sets the color of the highlight.
MaxValue | Gets or sets the maximum value of the range of the control.
MinValue | Gets or sets the minimum value of the range of the control.
StartColor | Gets or sets the start color.
Step | Gets or sets the step.
Value | Gets or sets the current position of the progress bar.
REXProgressBar Delegates
REXProgressBar Delegates | Description
MaxChangedHandler | This is nested type REX.Controls.Forms.REXProgressBar.MaxChangedHandler.
MinChangedHandler | This is nested type REX.Controls.Forms.REXProgressBar.MinChangedHandler.
ValueChangedHandler | This is nested type REX.Controls.Forms.REXProgressBar.ValueChangedHandler.
REXProgressBar Events
REXProgressBar Events | Description
MaxChanged | This is MaxChanged, a member of class REXProgressBar.
MinChanged | This is MinChanged, a member of class REXProgressBar.
ValueChanged | This is ValueChanged, a member of class REXProgressBar.

REXProgressBar Methods

REXProgressBar Methods
REXProgressBar Class Legend
REXProgressBar Methods
REXProgressBar Methods | Description
StepBack | Takes a step back.
StepForward | Takes a step forward.

REXProgressBar Properties

REXProgressBar Properties
REXProgressBar Class Legend
REXProgressBar Properties
REXProgressBar Properties | Description
Animate | Gets or sets a value indicating whether animation should be run.
BackgroundColor | Gets or sets the color of the background.
EndColor | Gets or sets the end color.
GlowColor | Gets or sets the color of the glow.
HighlightColor | Gets or sets the color of the highlight.
MaxValue | Gets or sets the maximum value of the range of the control.
MinValue | Gets or sets the minimum value of the range of the control.
StartColor | Gets or sets the start color.
Step | Gets or sets the step.
Value | Gets or sets the current position of the progress bar.

REXProgressBar Class Public Methods

REXProgressBar Class Public Methods
REXProgressBar Class Legend
Public Methods
Public Method | Description
REXProgressBar | Initializes a new instance of the REXProgressBar class.

Legend

Legend
REXUnitComboBox Class
Legend
Method
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXUnitComboBox Class Members

REXUnitComboBox Class Members
REXUnitComboBox Class Legend
Members
REXUnitComboBox Methods
REXUnitComboBox Methods | Description
GetBaseMaxValue | Gets the maximum value and converts it to base units.
GetBaseMinValue | Gets the minimum value and converts it to base units.
GetComplexDataBaseValue | Get the values and convert it to base units.
GetComplexDataInterfaceValue | Get the values and convert it to interface units.
GetDataBaseValue | Gets the value and converts it to base units.
GetDataInterfaceValue | Gets the value and converts it to interface units.
GetInterfaceMaxValue | Gets the maximum value and converts it to interface units.
GetInterfaceMinValue | Gets the minimum value and converts it to interface units.
SetBaseMaxValue | Set the maximum value defined in base units.
SetBaseMinValue | Set the minimum value defined in base units.
SetComplexDataBaseValue | Set the list of values defined in base units.
SetComplexDataInterfaceValue | Set the list of values defined in interface units.
SetDataBaseValue | Set the value in base units.
SetDataInterfaceValue | Set the value in interface units.
SetInterfaceMaxValue | Set the maximum value defined in interface units.
SetInterfaceMinValue | Set the minimum value defined in interface units.
REXUnitComboBox Properties
REXUnitComboBox Properties | Description
Power | Gets or sets the power of the unit.
UnitEngine | Gets or sets the unit engine.
UnitType | Gets or sets the type of the unit.

REXUnitComboBox Methods

REXUnitComboBox Methods
REXUnitComboBox Class Legend
REXUnitComboBox Methods
REXUnitComboBox Methods | Description
GetBaseMaxValue | Gets the maximum value and converts it to base units.
GetBaseMinValue | Gets the minimum value and converts it to base units.
GetComplexDataBaseValue | Get the values and convert it to base units.
GetComplexDataInterfaceValue | Get the values and convert it to interface units.
GetDataBaseValue | Gets the value and converts it to base units.
GetDataInterfaceValue | Gets the value and converts it to interface units.
GetInterfaceMaxValue | Gets the maximum value and converts it to interface units.
GetInterfaceMinValue | Gets the minimum value and converts it to interface units.
SetBaseMaxValue | Set the maximum value defined in base units.
SetBaseMinValue | Set the minimum value defined in base units.
SetComplexDataBaseValue | Set the list of values defined in base units.
SetComplexDataInterfaceValue | Set the list of values defined in interface units.
SetDataBaseValue | Set the value in base units.
SetDataInterfaceValue | Set the value in interface units.