Gets or sets the type of the element.

C#
public REX.ContentGenerator.Families.EElementType ElementType;
Description

The type of the element.

Class

REXFamilyType Class

Links
REXFamilyType Class, REX.ContentGenerator.Families Namespace, REXFamilyType Class

REXFamilyType.FamilyName Property

REXFamilyType.FamilyName Property
REXFamilyType Class REX.ContentGenerator.Families Namespace REXFamilyType Class

Gets or sets the name of the family.

C#
public string FamilyName;
Description

The name of the family.

Class

REXFamilyType Class

Links
REXFamilyType Class, REX.ContentGenerator.Families Namespace, REXFamilyType Class

REXFamilyType.Mapped Property

REXFamilyType.Mapped Property
REXFamilyType Class REX.ContentGenerator.Families Namespace REXFamilyType Class

If the REXFamilyType is mapped.

C#
public bool Mapped;
Description
Class

REXFamilyType Class

Links
REXFamilyType Class, REX.ContentGenerator.Families Namespace, REXFamilyType Class

REXFamilyType.Material Property

REXFamilyType.Material Property
REXFamilyType Class REX.ContentGenerator.Families Namespace REXFamilyType Class

Gets or sets the material.

C#
public REX.ContentGenerator.Families.EMaterial Material;
Description

The material.

Class

REXFamilyType Class

Links
REXFamilyType Class, REX.ContentGenerator.Families Namespace, REXFamilyType Class

REXFamilyType.TypeName Property

REXFamilyType.TypeName Property
REXFamilyType Class REX.ContentGenerator.Families Namespace REXFamilyType Class

Gets or sets the name of the type.

C#
public string TypeName;
Description

The name of the type.

Class

REXFamilyType Class

Links
REXFamilyType Class, REX.ContentGenerator.Families Namespace, REXFamilyType Class

REXFamilyType.UniqueID Property

REXFamilyType.UniqueID Property
REXFamilyType Class REX.ContentGenerator.Families Namespace REXFamilyType Class

The unique id.

C#
public string UniqueID;
Description
Class

REXFamilyType Class

Links
REXFamilyType Class, REX.ContentGenerator.Families Namespace, REXFamilyType Class

REXFamilyType_Custom Class

REXFamilyType_Custom Class
REX.ContentGenerator.Families Namespace Legend Members Public Methods REXFamilyType_Custom Methods REXFamilyType_Custom Properties

Base class for all custom types.

Class Hierarchy
C#
[Serializable()]
public abstract class REXFamilyType_Custom : REXFamilyType;
Description
Namespace

REX.ContentGenerator.Families Namespace

Public Methods
Public Method | Description
REXFamilyType_Custom | Initializes a new instance of the REXFamilyType_Custom class.
REXFamilyType_Custom | Initializes a new instance of the REXFamilyType_Custom class.
REXFamilyType_Custom | Initializes a new instance of the REXFamilyType_Custom class.
REXFamilyType_Custom Methods
REXFamilyType_Custom Methods | Description
Clone | Creates a new object that is a copy of the current instance.
REXFamilyType_Custom Properties
REXFamilyType_Custom Properties | Description
CategoryType | Gets the category.
CustomCategory | Gets the custom category.
CustomParameters | Gets the custom parameters.
Links
REX.ContentGenerator.Families Namespace, Legend, Members, Public Methods, REXFamilyType_Custom Methods, REXFamilyType_Custom Properties

REXFamilyType_Custom.REXFamilyType_Custom Constructor ()

REXFamilyType_Custom.REXFamilyType_Custom Constructor ()
REXFamilyType_Custom Class REX.ContentGenerator.Families Namespace REXFamilyType_Custom Class

Initializes a new instance of the REXFamilyType_Custom class.

C#
public REXFamilyType_Custom();
Description
Class

REXFamilyType_Custom Class

Links
REXFamilyType_Custom Class, REX.ContentGenerator.Families Namespace, REXFamilyType_Custom Class

REXFamilyType_Custom.REXFamilyType_Custom Constructor (REXFamilyType_Custom)

REXFamilyType_Custom.REXFamilyType_Custom Constructor (REXFamilyType_Custom)
REXFamilyType_Custom Class REX.ContentGenerator.Families Namespace REXFamilyType_Custom Class

Initializes a new instance of the REXFamilyType_Custom class.

C#
public REXFamilyType_Custom(REXFamilyType_Custom pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

REXFamilyType_Custom Class

Links
REXFamilyType_Custom Class, REX.ContentGenerator.Families Namespace, REXFamilyType_Custom Class

REXFamilyType_Custom.REXFamilyType_Custom Constructor (string, string, REX.ContentGenerator.Families.EElementType, bool, EMaterial)

REXFamilyType_Custom.REXFamilyType_Custom Constructor (string, string, REX.ContentGenerator.Families.EElementType, bool, EMaterial)
REXFamilyType_Custom Class REX.ContentGenerator.Families Namespace REXFamilyType_Custom Class

Initializes a new instance of the REXFamilyType_Custom class.

C#
public REXFamilyType_Custom(string familyName, string typeName, REX.ContentGenerator.Families.EElementType category, bool certified, EMaterial mat);
Parameters
Parameters | Description
familyName | The name of the family.
typeName | The name of the type.
category | The category.
certified | Indicates whether the element is certified.
mat | The material.
Description
Class

REXFamilyType_Custom Class

Links
REXFamilyType_Custom Class, REX.ContentGenerator.Families Namespace, REXFamilyType_Custom Class

REXFamilyType_Custom.Clone Method

REXFamilyType_Custom.Clone Method
REXFamilyType_Custom Class REX.ContentGenerator.Families Namespace REXFamilyType_Custom Class

Creates a new object that is a copy of the current instance.

C#
public override abstract object Clone();
Returns

A new object that is a copy of this instance.

Description
Class

REXFamilyType_Custom Class

Links
REXFamilyType_Custom Class, REX.ContentGenerator.Families Namespace, REXFamilyType_Custom Class

REXFamilyType_Custom.CategoryType Property

REXFamilyType_Custom.CategoryType Property
REXFamilyType_Custom Class REX.ContentGenerator.Families Namespace REXFamilyType_Custom Class

Gets the category.

C#
public override ECategoryType CategoryType;
Description

The category.

Class

REXFamilyType_Custom Class

Links
REXFamilyType_Custom Class, REX.ContentGenerator.Families Namespace, REXFamilyType_Custom Class

REXFamilyType_Custom.CustomCategory Property

REXFamilyType_Custom.CustomCategory Property
REXFamilyType_Custom Class REX.ContentGenerator.Families Namespace REXFamilyType_Custom Class

Gets the custom category.

C#
public abstract string CustomCategory;
Description

The custom category.

Class

REXFamilyType_Custom Class

Links
REXFamilyType_Custom Class, REX.ContentGenerator.Families Namespace, REXFamilyType_Custom Class

REXFamilyType_Custom.CustomParameters Property

REXFamilyType_Custom.CustomParameters Property
REXFamilyType_Custom Class REX.ContentGenerator.Families Namespace REXFamilyType_Custom Class

Gets the custom parameters.

C#
public REXCustomDescription CustomParameters;
Description

The custom parameters.

Class

REXFamilyType_Custom Class

Links
REXFamilyType_Custom Class, REX.ContentGenerator.Families Namespace, REXFamilyType_Custom Class

REXFamilyType_DBSection Class

REXFamilyType_DBSection Class
REX.ContentGenerator.Families Namespace Legend Members Public Methods REXFamilyType_DBSection Methods REXFamilyType_DBSection Properties

Represents a database section.

Class Hierarchy
C#
[Serializable()]
public class REXFamilyType_DBSection : REXFamilyType_Section;
Description
Namespace

REX.ContentGenerator.Families Namespace

Public Methods
Public Method | Description
REXFamilyType_DBSection | Initializes a new instance of the REXFamilyType_DBSection class.
REXFamilyType_DBSection | Initializes a new instance of the REXFamilyType_DBSection class.
REXFamilyType_DBSection | Initializes a new instance of the REXFamilyType_DBSection class.
REXFamilyType_DBSection Methods
REXFamilyType_DBSection Methods | Description
Clone | Creates a new object that is a copy of the current instance.
CompareTo | Compares the current object with the other object.
REXFamilyType_DBSection Properties
REXFamilyType_DBSection Properties | Description
CategoryType | Gets the category.