DatabasesResult | Gets or sets the list of databases which were finally choosen by the user in the dialog.
Elements | Gets the list of elements which should be mapped.
LabelCategoryName | Gets or sets the name of the label category.
Labels | Gets the list of labels.
MapCertifiedFamilies | Gets or sets a value indicating whether certified families are mapped.
SetDefaultsForUnknown | Gets or sets a value indicating whether defaults are set for elements which weren't mapped.
Settings | Gets the settings of the dialog.
Visible | Gets or sets a value indicating whether this category is visible.

REXContentMapCategorySettings Class Public Methods

REXContentMapCategorySettings Class Public Methods
REXContentMapCategorySettings Class Legend
Public Methods
Public Method | Description
REXContentMapCategorySettings | Initializes a new instance of the REXContentMapCategorySettings class.

Legend

Legend
REXContentMapDialogSettings Class
Legend
Constructor
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXContentMapDialogSettings Class Members

REXContentMapDialogSettings Class Members
REXContentMapDialogSettings Class Legend
Members
Public Methods
Public Method | Description
REXContentMapDialogSettings | Initializes a new instance of the REXContentMapDialogSettings class.
REXContentMapDialogSettings Methods
REXContentMapDialogSettings Methods | Description
GetSettings | Gets settings of the specific type.
REXContentMapDialogSettings Properties
REXContentMapDialogSettings Properties | Description
CheckIfAllMappedBeforeLeave | Gets or sets a value indicating whether dialog should be validated before leaving.
List | Gets or sets a value indicating whether the list should be visible on the dialog.
Mapper | Gets the mapper.
MaterialSettings | Gets the material settings.
Menu | Gets or sets a value indicating whether menu should be visible on the dialog.
NotAllMappedText | Gets or sets the text which should appear when validation didn't succeed (if CheckIfAllMappedBeforeLeave option).
RebarTypeSettings | Gets the rebar type settings.
SectionSettings | Gets the section settings.
ShowWhenNoElementsToMap | Gets or sets a value indicating whether dialog should appear when there are no elements to map.

REXContentMapDialogSettings Methods

REXContentMapDialogSettings Methods
REXContentMapDialogSettings Class Legend
REXContentMapDialogSettings Methods
REXContentMapDialogSettings Methods | Description
GetSettings | Gets settings of the specific type.

REXContentMapDialogSettings Properties

REXContentMapDialogSettings Properties
REXContentMapDialogSettings Class Legend
REXContentMapDialogSettings Properties
REXContentMapDialogSettings Properties | Description
CheckIfAllMappedBeforeLeave | Gets or sets a value indicating whether dialog should be validated before leaving.
List | Gets or sets a value indicating whether the list should be visible on the dialog.
Mapper | Gets the mapper.
MaterialSettings | Gets the material settings.
Menu | Gets or sets a value indicating whether menu should be visible on the dialog.
NotAllMappedText | Gets or sets the text which should appear when validation didn't succeed (if CheckIfAllMappedBeforeLeave option).
RebarTypeSettings | Gets the rebar type settings.
SectionSettings | Gets the section settings.
ShowWhenNoElementsToMap | Gets or sets a value indicating whether dialog should appear when there are no elements to map.

REXContentMapDialogSettings Class Public Methods

REXContentMapDialogSettings Class Public Methods
REXContentMapDialogSettings Class Legend
Public Methods
Public Method | Description
REXContentMapDialogSettings | Initializes a new instance of the REXContentMapDialogSettings class.

REXContentMapper Fields

REXContentMapper Fields
REXContentMapper Class Legend
REXContentMapper Fields
REXContentMapper Fields | Description
valRexContext | This is valRexContext, a member of class REXContentMapper.

Legend

Legend
REXContentMapper Class
Legend
Data Member
Method
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXContentMapper Class Members

REXContentMapper Class Members
REXContentMapper Class Legend
Members
REXContentMapper Fields
REXContentMapper Fields | Description
valRexContext | This is valRexContext, a member of class REXContentMapper.
REXContentMapper Methods
REXContentMapper Methods | Description
GetMapElement | Gets the map element for the specified element.
SetMapElement | Sets the map element for specified element.

REXContentMapper Methods

REXContentMapper Methods
REXContentMapper Class Legend
REXContentMapper Methods
REXContentMapper Methods | Description
GetMapElement | Gets the map element for the specified element.
SetMapElement | Sets the map element for specified element.

RVTContentMapper Fields

RVTContentMapper Fields
RVTContentMapper Class Legend
RVTContentMapper Fields
RVTContentMapper Fields | Description
valRvtContext | This is valRvtContext, a member of class RVTContentMapper.

Legend

Legend
RVTContentMapper Class
Legend
Data Member
Method
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

RVTContentMapper Class Members

RVTContentMapper Class Members
RVTContentMapper Class Legend
Members
RVTContentMapper Fields
RVTContentMapper Fields | Description
valRvtContext | This is valRvtContext, a member of class RVTContentMapper.
RVTContentMapper Methods
RVTContentMapper Methods | Description
GetMapElement | Gets the map element for specified Revit element.
SetMapElement | Sets the map element for specified Revit element.

RVTContentMapper Methods

RVTContentMapper Methods
RVTContentMapper Class Legend
RVTContentMapper Methods
RVTContentMapper Methods | Description
GetMapElement | Gets the map element for specified Revit element.
SetMapElement | Sets the map element for specified Revit element.

REX.Controls.Common Namespace Classes

REX.Controls.Common Namespace Classes
REX.Controls.Common Namespace Legend
Classes
Class | Description
REXComboEditControlEngine | Represents the engine for the combobox edit control.
REXEditControlEngine | Represents the engine for edit controls.

REX.Controls.Common Namespace Interfaces

REX.Controls.Common Namespace Interfaces
REX.Controls.Common Namespace Legend
Interfaces
Interface | Description
IComboEditControl | An interface that may be used to attach the custom control to the REXComboEditControlEngine.
IEditControl | An interface that may be used to attach the custom control to the REXEditControlEngine.
IUnitObject | Defines common functionality for controls that are unit dependent.
IUnitObject2 | Defines common functionality for controls that are unit dependent.
IUnitObject3 | Defines common functionality for controls that are unit dependent.

Legend

Legend
REX.Controls.Common Namespace
Legend
Class
Interface
Enumeration
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REX.Controls.Common Namespace Structs, Records, Enums

REX.Controls.Common Namespace Structs, Records, Enums
REX.Controls.Common Namespace Legend
Structs, Records, Enums
Struct, Record, Enum | Description
EComboPropertiesType | An enumerated type listing all modes of the combo.

Legend

Legend
IComboEditControl Interface
Legend
Method