ContentMapper Class, REX.ContentGenerator.Map Namespace, Example, ContentMapper Class

ContentMapper.ApplyMapControl Method

ContentMapper.ApplyMapControl Method
ContentMapper Class REX.ContentGenerator.Map Namespace ContentMapper Class

Applies the map control.

C#
public void ApplyMapControl();
Description
Class

ContentMapper Class

Links
ContentMapper Class, REX.ContentGenerator.Map Namespace, ContentMapper Class

ContentMapper.CloseMapControl Method

ContentMapper.CloseMapControl Method
ContentMapper Class REX.ContentGenerator.Map Namespace ContentMapper Class

Closes the map control.

C#
public void CloseMapControl();
Description
Class

ContentMapper Class

Links
ContentMapper Class, REX.ContentGenerator.Map Namespace, ContentMapper Class

ContentMapper.CreateMapControl Method

ContentMapper.CreateMapControl Method
ContentMapper Class REX.ContentGenerator.Map Namespace Example ContentMapper Class

Creates the map control.

C#
public object CreateMapControl(ref Autodesk.REX.Framework.REXContext context);
Parameters
Parameters | Description
context | The context.
Returns

Returns the control.

Description
Example

The example shows how to customize and launch the map dialog.

//Revit converter.
RVTFamilyConverter rvt = new RVTFamilyConverter(ThisExtension.Revit.CommandData(), true);

Autodesk.Revit.DB.FilteredElementCollector collector = new FilteredElementCollector(ThisExtension.Revit.ActiveDocument);

List<Element> Sections = new List<Element>();

//General settings.
rvt.ContentMapper.DialogSettings.CheckIfAllMappedBeforeLeave = false;
rvt.ContentMapper.DialogSettings.Menu = false;
rvt.ContentMapper.DialogSettings.List = false;
rvt.ContentMapper.DialogSettings.ShowWhenNoElementsToMap = true;

//Sections.
rvt.ContentMapper.DialogSettings.SectionSettings.Visible = true;
//-adding elements
foreach (FamilySymbol obj in collector.OfClass(typeof(FamilySymbol)).ToElements())
{
    rvt.ContentMapper.DialogSettings.SectionSettings.Elements.Add(obj);
    Sections.Add(obj);
}
//-databases start list
rvt.ContentMapper.DialogSettings.SectionSettings.Databases.Add("Rcatpro");

//Launching.
Autodesk.REX.Common.REXContext cont = ThisExtension.Context;
object ctr = rvt.ContentMapper.CreateMapControl(ref cont);
Class

ContentMapper Class

Links
ContentMapper Class, REX.ContentGenerator.Map Namespace, Example, ContentMapper Class

ContentMapper.GetLabels Method

ContentMapper.GetLabels Method
ContentMapper Class REX.ContentGenerator.Map Namespace ContentMapper Class

Gets the labels.

C#
public List<REXFamilyType_Label> GetLabels(ECategoryType cat);
Parameters
Parameters | Description
cat | The category of element.
Returns

The list of defined labels.

Description
Class

ContentMapper Class

Links
ContentMapper Class, REX.ContentGenerator.Map Namespace, ContentMapper Class

ContentMapper.LaunchMapDialog Method

ContentMapper.LaunchMapDialog Method
ContentMapper Class REX.ContentGenerator.Map Namespace Example ContentMapper Class

Launches the map dialog.

C#
public bool LaunchMapDialog(ref Autodesk.REX.Framework.REXContext context);
Parameters
Parameters | Description
context | The context.
Returns

If launching succeed or if changes were accepted by user.

Description
Example

The example shows how to customize and launch the map dialog.

//Revit converter.
RVTFamilyConverter rvt = new RVTFamilyConverter(ThisExtension.Revit.CommandData(), true);

Autodesk.Revit.DB.FilteredElementCollector collector = new FilteredElementCollector(ThisExtension.Revit.ActiveDocument);

List<Element> Sections = new List<Element>();
List<Element> Rebars = new List<Element>();

//General settings.
rvt.ContentMapper.DialogSettings.CheckIfAllMappedBeforeLeave = true;
rvt.ContentMapper.DialogSettings.NotAllMappedText = "Not all elements are mapped";

//Sections.
rvt.ContentMapper.DialogSettings.SectionSettings.Visible = true;
//-adding elements
foreach (FamilySymbol obj in collector.OfClass(typeof(FamilySymbol)).ToElements())
{
    rvt.ContentMapper.DialogSettings.SectionSettings.Elements.Add(obj);
    Sections.Add(obj);
}
//-databases start list
rvt.ContentMapper.DialogSettings.SectionSettings.Databases.Add("Rcatpro");

//Materials.
rvt.ContentMapper.DialogSettings.MaterialSettings.Visible = false;

//Rebars.
rvt.ContentMapper.DialogSettings.RebarTypeSettings.Visible = true;
//-user won't be able to add databases
rvt.ContentMapper.DialogSettings.RebarTypeSettings.AllowToAddDatabases = false;
//-if there will be find the map element with some database assigned this database won't be loaded to Content dialog automatically
rvt.ContentMapper.DialogSettings.RebarTypeSettings.AddMappedDatabases = false;
//-adding elements
foreach (RebarBarType obj in collector.OfClass(typeof(RebarBarType)).ToElements())
{
     rvt.ContentMapper.DialogSettings.SectionSettings.Elements.Add(obj);
     Rebars.Add(obj);
}
//-database list
rvt.ContentMapper.DialogSettings.RebarTypeSettings.Databases.Add("bar_BAEL M");
//-available steels
rvt.ContentMapper.DialogSettings.RebarTypeSettings.SteelsAvailable.Add("HA 400");
//-if defaults should be set
rvt.ContentMapper.DialogSettings.RebarTypeSettings.SetDefaultsForUnknown = true;

//-if certified elements should be mapped
rvt.ContentMapper.DialogSettings.RebarTypeSettings.MapCertifiedFamilies = true;
//-setting default elements for rebartype
rvt.ContentMapper.SetDefaults(ThisExtension.Preferences.PreferencesBase2.RegionalSettings, ECategoryType.REBAR_BARTYPE);

//Launching.
Autodesk.REX.Common.REXContext cont = ThisExtension.Context;
bool ok = rvt.ContentMapper.LaunchMapDialog(ref cont);

if (ok)
{
    //Getting mapped element
    REXFamilyType sect = rvt.ContentMapper.GetMapElement(Sections[0],ECategoryType.SECTION_DB);
}
Class

ContentMapper Class

Links
ContentMapper Class, REX.ContentGenerator.Map Namespace, Example, ContentMapper Class

ContentMapper.LoadUserMap Method

ContentMapper.LoadUserMap Method
ContentMapper Class REX.ContentGenerator.Map Namespace ContentMapper Class

Loads the user map to the Content Generator.

C#
public void LoadUserMap(string path);
Parameters
Parameters | Description
path | The path.
Description
Class

ContentMapper Class

Links
ContentMapper Class, REX.ContentGenerator.Map Namespace, ContentMapper Class

ContentMapper.RefreshMapControl Method

ContentMapper.RefreshMapControl Method
ContentMapper Class REX.ContentGenerator.Map Namespace ContentMapper Class

Refreshes the map control.

C#
public void RefreshMapControl();
Description
Class

ContentMapper Class

Links
ContentMapper Class, REX.ContentGenerator.Map Namespace, ContentMapper Class

ContentMapper.ReloadGlobalMap Method

ContentMapper.ReloadGlobalMap Method
ContentMapper Class REX.ContentGenerator.Map Namespace ContentMapper Class

Reloads the global map.

C#
public void ReloadGlobalMap();
Description
Class

ContentMapper Class

Links
ContentMapper Class, REX.ContentGenerator.Map Namespace, ContentMapper Class

ContentMapper.ResetUserMap Method

ContentMapper.ResetUserMap Method
ContentMapper Class REX.ContentGenerator.Map Namespace ContentMapper Class

Resets the user map.

C#
public void ResetUserMap();
Description
Class

ContentMapper Class

Links
ContentMapper Class, REX.ContentGenerator.Map Namespace, ContentMapper Class

ContentMapper.SaveGlobalMap Method

ContentMapper.SaveGlobalMap Method
ContentMapper Class REX.ContentGenerator.Map Namespace ContentMapper Class

Saves the global map.

C#
public void SaveGlobalMap();
Description
Class

ContentMapper Class

Links
ContentMapper Class, REX.ContentGenerator.Map Namespace, ContentMapper Class

ContentMapper.SaveUserMap Method

ContentMapper.SaveUserMap Method
ContentMapper Class REX.ContentGenerator.Map Namespace ContentMapper Class

Saves the user map.

C#
public void SaveUserMap(string path);
Parameters
Parameters | Description
path | The path.
Description
Class

ContentMapper Class

Links
ContentMapper Class, REX.ContentGenerator.Map Namespace, ContentMapper Class

ContentMapper.SetDefaults Method