REXExtensionData Class REX.Common Namespace REXExtensionData Class

Saves data structure to a BinaryWriter object.

C#
public bool Save(ref BinaryWriter Data, DataMode DataModeSet);
Parameters
Parameters | Description
Data | The data.
DataModeSet | The data mode set.
Returns

Returns true if succeeded.

Description
Class

REXExtensionData Class

Links
REXExtensionData Class, REX.Common Namespace, REXExtensionData Class

REXExtensionData.SaveHeader Method (BinaryWriter, DataMode)

REXExtensionData.SaveHeader Method (BinaryWriter, DataMode)
REXExtensionData Class REX.Common Namespace REXExtensionData Class

Saves data structure to a BinaryWriter object.

C#
public bool SaveHeader(ref BinaryWriter Data, DataMode DataModeSet);
Parameters
Parameters | Description
Data | The data.
DataModeSet | The data mode set.
Returns

Returns true if succeeded.

Description
Class

REXExtensionData Class

Links
REXExtensionData Class, REX.Common Namespace, REXExtensionData Class

REXExtensionData.SaveHeader Method (REXStorageExtensionHeader)

REXExtensionData.SaveHeader Method (REXStorageExtensionHeader)
REXExtensionData Class REX.Common Namespace REXExtensionData Class

This is SaveHeader, a member of class REXExtensionData.

C#
public void SaveHeader(REXStorageExtensionHeader header);
Class

REXExtensionData Class

Links
REXExtensionData Class, REX.Common Namespace, REXExtensionData Class

REXExtensionData.SetDefaults Method

REXExtensionData.SetDefaults Method
REXExtensionData Class REX.Common Namespace REXExtensionData Class

Sets the defaults.

C#
public void SetDefaults();
Description
Class

REXExtensionData Class

Links
REXExtensionData Class, REX.Common Namespace, REXExtensionData Class

REXExtensionData.DateTimeData Property

REXExtensionData.DateTimeData Property
REXExtensionData Class REX.Common Namespace REXExtensionData Class

Get the date and time of data which load.

C#
public DateTime DateTimeData;
Description

The date and time of data.

Class

REXExtensionData Class

Links
REXExtensionData Class, REX.Common Namespace, REXExtensionData Class

REXExtensionData.DateTimeDataCreation Property

REXExtensionData.DateTimeDataCreation Property
REXExtensionData Class REX.Common Namespace REXExtensionData Class

Get the creation date and time of data which load.

C#
public DateTime DateTimeDataCreation;
Description

The date and time of data.

Class

REXExtensionData Class

Links
REXExtensionData Class, REX.Common Namespace, REXExtensionData Class

REXExtensionData.EnableDynamicUpdate Property

REXExtensionData.EnableDynamicUpdate Property
REXExtensionData Class REX.Common Namespace REXExtensionData Class

This is EnableDynamicUpdate, a member of class REXExtensionData.

C#
public bool EnableDynamicUpdate;
Class

REXExtensionData Class

Links
REXExtensionData Class, REX.Common Namespace, REXExtensionData Class

REXExtensionData.LoadedRegionalSettings Property

REXExtensionData.LoadedRegionalSettings Property
REXExtensionData Class REX.Common Namespace REXExtensionData Class

This is LoadedRegionalSettings, a member of class REXExtensionData.

C#
public Autodesk.REX.Framework.IREXRegionalSettings LoadedRegionalSettings;
Class

REXExtensionData Class

Links
REXExtensionData Class, REX.Common Namespace, REXExtensionData Class

REXExtensionData.Mode Property

REXExtensionData.Mode Property
REXExtensionData Class REX.Common Namespace REXExtensionData Class

Get or set the mode.

C#
public DataMode Mode;
Description

The mode.

Class

REXExtensionData Class

Links
REXExtensionData Class, REX.Common Namespace, REXExtensionData Class

REXExtensionData.NoHeader Property

REXExtensionData.NoHeader Property
REXExtensionData Class REX.Common Namespace REXExtensionData Class

This is NoHeader, a member of class REXExtensionData.

C#
public bool NoHeader;
Class

REXExtensionData Class

Links
REXExtensionData Class, REX.Common Namespace, REXExtensionData Class

REXExtensionData.ProductType Property

REXExtensionData.ProductType Property
REXExtensionData Class REX.Common Namespace REXExtensionData Class

Loaded product type

C#
public REXInterfaceType ProductType;
Class

REXExtensionData Class

Links
REXExtensionData Class, REX.Common Namespace, REXExtensionData Class

REXExtensionData.RunContext Property

REXExtensionData.RunContext Property
REXExtensionData Class REX.Common Namespace REXExtensionData Class

Loaded run context

C#
public string RunContext;
Class

REXExtensionData Class

Links
REXExtensionData Class, REX.Common Namespace, REXExtensionData Class

REXExtensionData.StandardRunContext Property

REXExtensionData.StandardRunContext Property
REXExtensionData Class REX.Common Namespace REXExtensionData Class

Loaded standard run context

C#
public REXExtensionContext.REXStandardRunContext StandardRunContext;
Class

REXExtensionData Class

Links
REXExtensionData Class, REX.Common Namespace, REXExtensionData Class

REXExtensionData.Status Property

REXExtensionData.Status Property
REXExtensionData Class REX.Common Namespace REXExtensionData Class

Get or set the status.

C#
public OperationStatus Status;
Description

The status.

Class

REXExtensionData Class

Links
REXExtensionData Class, REX.Common Namespace, REXExtensionData Class

REXExtensionData.Version Property

REXExtensionData.Version Property
REXExtensionData Class REX.Common Namespace REXExtensionData Class

Get the current version.

C#
public long Version;
Description

The version.

Class

REXExtensionData Class

Links
REXExtensionData Class, REX.Common Namespace, REXExtensionData Class

REXExtensionData.VersionData Property

REXExtensionData.VersionData Property
REXExtensionData Class REX.Common Namespace REXExtensionData Class

Get the version data which load.

C#
public long VersionData;
Description

The version data.

Class

REXExtensionData Class

Links
REXExtensionData Class, REX.Common Namespace, REXExtensionData Class

REXExtensionDataSerializable Class

REXExtensionDataSerializable Class
REX.Common Namespace Legend Members Public Methods REXExtensionDataSerializable Methods

Base class for REXDataSerializable and REXResultsSerializable classes.

Class Hierarchy
C#
[Serializable]
public class REXExtensionDataSerializable : System.Runtime.Serialization.ISerializableinternalclassREXExtensionDataSerializable:System.Runtime.Serialization.ISerializable;
Description

Allows these structures standard .NET serialization, loading and saving.

Namespace

REX.Common Namespace

Public Methods
Public Method | Description
REXExtensionDataSerializable | Initializes a new instance of the REXExtensionDataSerializable class.
REXExtensionDataSerializable Methods
REXExtensionDataSerializable Methods | Description
GetObjectData | A required method by ISerializable to serialize the object.
Links
REX.Common Namespace, Legend, Members, Public Methods, REXExtensionDataSerializable Methods

REXExtensionDataSerializable.REXExtensionDataSerializable Constructor

REXExtensionDataSerializable.REXExtensionDataSerializable Constructor
REXExtensionDataSerializable Class REX.Common Namespace REXExtensionDataSerializable Class

Initializes a new instance of the REXExtensionDataSerializable class.

C#
public REXExtensionDataSerializable();
Description
Class

REXExtensionDataSerializable Class

Links
REXExtensionDataSerializable Class, REX.Common Namespace, REXExtensionDataSerializable Class

REXExtensionDataSerializable.GetObjectData Method

REXExtensionDataSerializable.GetObjectData Method
REXExtensionDataSerializable Class REX.Common Namespace Example REXExtensionDataSerializable Class

A required method by ISerializable to serialize the object.

C#
public virtual void GetObjectData(System.Runtime.Serialization.SerializationInfo info, System.Runtime.Serialization.StreamingContext ctx);
Parameters
Parameters | Description
info | The info.
ctx | The CTX.
Description