Parameters | Description
myUnitObject | The reference to the unit object.
Value | The values.
Returns

Returns true if succeeded.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class

REXDFM.SetComplexDataInterface Method (string, List<double>)

REXDFM.SetComplexDataInterface Method (string, List<double>)
REXDFM Class REX.Common Namespace REXDFM Class

Sets the list of values in interface units.

C#
public bool SetComplexDataInterface(string nameUnitObject, List<double> Value);
Parameters
Parameters | Description
nameUnitObject | The name of the unit object.
Value | The values.
Returns

Returns true if succeeded.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class

REXDFM.SetDataBase Method (IUnitObject, double)

REXDFM.SetDataBase Method (IUnitObject, double)
REXDFM Class REX.Common Namespace REXDFM Class

Sets the value defined in base units.

C#
public bool SetDataBase(IUnitObject myUnitObject, double Value);
Parameters
Parameters | Description
myUnitObject | The reference to the unit object.
Value | The value.
Returns

Returns true if succeeded.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class

REXDFM.SetDataBase Method (string, double)

REXDFM.SetDataBase Method (string, double)
REXDFM Class REX.Common Namespace REXDFM Class

Sets the value defined in base units.

C#
public bool SetDataBase(string nameUnitObject, double Value);
Parameters
Parameters | Description
nameUnitObject | The name of the unit object.
Value | The value.
Returns

Returns true if succeeded.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class

REXDFM.SetDataDisplay Method (IUnitObject, double)

REXDFM.SetDataDisplay Method (IUnitObject, double)
REXDFM Class REX.Common Namespace REXDFM Class

Sets the value defined in display units.

C#
public bool SetDataDisplay(IUnitObject myUnitObject, double Value);
Parameters
Parameters | Description
myUnitObject | Reference to the unit object.
Value | The value.
Returns

Returns true if succeeded.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class

REXDFM.SetDataDisplay Method (string, double)

REXDFM.SetDataDisplay Method (string, double)
REXDFM Class REX.Common Namespace REXDFM Class

Sets the value defined in display units.

C#
public bool SetDataDisplay(string nameUnitObject, double Value);
Parameters
Parameters | Description
nameUnitObject | The name of the unit object.
Value | The value.
Returns

Returns true if succeeded.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class

REXDFM.SetDataInterface Method (IUnitObject, double)

REXDFM.SetDataInterface Method (IUnitObject, double)
REXDFM Class REX.Common Namespace REXDFM Class

Sets the value defined in interface units.

C#
public bool SetDataInterface(IUnitObject myUnitObject, double Value);
Parameters
Parameters | Description
myUnitObject | The reference to the unit object.
Value | The value.
Returns

Returns true if succeeded.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class

REXDFM.SetDataInterface Method (string, double)

REXDFM.SetDataInterface Method (string, double)
REXDFM Class REX.Common Namespace REXDFM Class

Sets the value defined in interface units.

C#
public bool SetDataInterface(string nameUnitObject, double Value);
Parameters
Parameters | Description
nameUnitObject | The name of the unit object.
Value | The value.
Returns

Returns true if succeeded.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class

REXDFM.SetDataText Method (IUnitObject, string)

REXDFM.SetDataText Method (IUnitObject, string)
REXDFM Class REX.Common Namespace REXDFM Class

Sets the current text.

C#
public string SetDataText(IUnitObject myUnitObject, string Value);
Parameters
Parameters | Description
myUnitObject | The reference to the unit object.
Value | The value.
Returns

Returns current text.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class

REXDFM.SetDataText Method (string, string)

REXDFM.SetDataText Method (string, string)
REXDFM Class REX.Common Namespace REXDFM Class

Sets the current text.

C#
public string SetDataText(string nameUnitObject, string Value);
Parameters
Parameters | Description
nameUnitObject | The name of the unit object.
Value | The value.
Returns

Returns current text.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class

REXDFM.SetInterfaceMaxValue Method (IUnitObject, bool, double)

REXDFM.SetInterfaceMaxValue Method (IUnitObject, bool, double)
REXDFM Class REX.Common Namespace REXDFM Class

Sets the maximum value defined in interface units.

C#
public bool SetInterfaceMaxValue(IUnitObject myUnitObject, bool CheckVal, double baseVal);
Parameters
Parameters | Description
myUnitObject | Reference to based control on IUnitObject interface.
CheckVal | If set to true, value is checked.
baseVal | The base value.
Returns

Returns true if succeeded.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class

REXDFM.SetInterfaceMaxValue Method (string, bool, double)

REXDFM.SetInterfaceMaxValue Method (string, bool, double)
REXDFM Class REX.Common Namespace REXDFM Class

Sets the maximum value defined in interface units.

C#
public bool SetInterfaceMaxValue(string nameUnitObject, bool CheckVal, double baseVal);
Parameters
Parameters | Description
nameUnitObject | The name of the unit object.
CheckVal | If set to true, value is checked.
baseVal | The base value.
Returns

Returns true if succeeded.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class

REXDFM.SetInterfaceMinValue Method (IUnitObject, bool, double)

REXDFM.SetInterfaceMinValue Method (IUnitObject, bool, double)
REXDFM Class REX.Common Namespace REXDFM Class

Sets the minimum value defined in interface units.

C#
public bool SetInterfaceMinValue(IUnitObject myUnitObject, bool CheckVal, double baseVal);
Parameters
Parameters | Description
myUnitObject | Reference to based control on IUnitObject interface.
CheckVal | If set to true, value is checked.
baseVal | The base value.
Returns

Returns true if succeeded.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class

REXDFM.SetInterfaceMinValue Method (string, bool, double)

REXDFM.SetInterfaceMinValue Method (string, bool, double)
REXDFM Class REX.Common Namespace REXDFM Class

Sets the minimum value defined in interface units.

C#
public bool SetInterfaceMinValue(string nameUnitObject, bool CheckVal, double baseVal);
Parameters
Parameters | Description
nameUnitObject | The name of the unit object.
CheckVal | If set to true, value is checked.
baseVal | The base value.
Returns

Returns true if succeeded.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class

REXDFM.SetUserValidFunction Method (IUnitObject, UserValidation)

REXDFM.SetUserValidFunction Method (IUnitObject, UserValidation)
REXDFM Class REX.Common Namespace REXDFM Class

Sets the user validation function.

C#
public bool SetUserValidFunction(IUnitObject myUnitObject, UserValidation myFunction);
Parameters
Parameters | Description
myUnitObject | The reference to the unit object.
myFunction | The function.
Returns

Returns true if succeeded.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class

REXDFM.SetUserValidFunction Method (string, UserValidation)

REXDFM.SetUserValidFunction Method (string, UserValidation)
REXDFM Class REX.Common Namespace REXDFM Class

Sets the user validation function.

C#
public bool SetUserValidFunction(string myUnitObject, UserValidation myFunction);
Parameters
Parameters | Description
myUnitObject | The reference to the unit object.
myFunction | My function.
Returns

Returns true if succeeded.

Description
Class