REXRevitContextAccess Class

Links
REXRevitContextAccess Class, REX.Common Namespace, REXRevitContextAccess Class

REXUI Class

REXUI Class
REX.Common Namespace Legend Members Public Methods REXUI Enumerations REXUI Fields REXUI Methods REXUI Properties

Main class which provides access to all data connected with main control.

Class Hierarchy
C#
public class REXUI;
Description
Namespace

REX.Common Namespace

Public Methods
Public Method | Description
REXUI | Initializes a new instance of the REXUI class.
REXUI Enumerations
REXUI Enumerations | Description
CommandOptions | Identifies commands settings on the user interface.
SetupOptions | Identifies all elements of user interface.
REXUI Fields
REXUI Fields | Description
NameDialog | Name of dialog's container.
NameHSplit | Name of horizontal splitter.
NameHSplitGrid | Name of horizontal splitter.
NameHSplitGridBottom | Name of vertical splitter.
NameHSplitGridTop | Name of vertical splitter.
NameList | Name of list of options.
NameListImageListLarge | Name of large list of large images (32 x 32 pixels).
NameListImageListSmall | Name of large list of small images (16 x 16 pixels).
NameLogo | Name of logo's container.
NameMainPanel | Name of main panel which contains all controls.
NameMenu | Name of menu bar.
NameNote | Name of note's container.
NameRightContainer | Name of inner tool strip container.
NameStatus | Name of status bar.
NameStatusHeaderLabel | Name of label which represents header placed on status bar.
NameStatusLabel | Name of label placed on status bar.
NameStatusProgress | Name of progress placed on status bar.
NameTabControl | Name of tab control.
NameTabDialog | Name of tab dialog.
NameTabNote | Name of tab note.
NameTabView | Name of tab view.
NameToolBar | Name of tool bar.
NameToolBarInner | Name of inner tool bar.
NameToolbox | Name of toolbox control.
NameToolMenu | Name of menu bar based on tool bar.
NameView | Name of view's container.
NameVSplit | Name of vertical splitter.
NameVSplitGrid | Name of vertical splitter.
NameVSplitGridLeft | Name of vertical splitter.
NameVSplitGridRight | Name of vertical splitter.
REXUI Methods
REXUI Methods | Description
AddToolStrip | Adds the tool strip to repositioning.
FindHiddenCommand | Determines whether the input command is hidden.
FindHiddenCommand | Finds the hidden command.
GetAboutLink | Gets the about link.
GetDialog | Gets the dialog control.
GetHelpLink | Gets the help link.
GetList | This is GetList, a member of class REXUI.
GetLogo | Gets the reference to PictureBox which contains logo.
GetMenu | Gets the menu control.
GetMenuBar | Gets the menu bar.
GetNote | Gets the note control.
GetNoteWebBrowser | Gets the note web browser control.
GetStatus | Gets the status control.
GetStatusHeaderLabel | Gets the status header label.
GetStatusLabel | Gets the status label.
GetStatusProgress | Gets the status progress.
GetToolBar | Gets the tool bar.
GetToolBarInner | Gets the tool bar inner.
GetToolbox | Gets the toolbox control.
GetViewer | Gets the viewer's container.
GetWindow | Gets the reference to main form.
HideAboutControls | This is HideAboutControls, a member of class REXUI.
HideAboutLink | Hides the about link.
HideCommand | Hides the command.
HideCommand | Hides the command.
HideHelpLink | Hides the help link.
LoadNoteUrl | Loads the URL to note control.
RememberControl | Remembers the active tab control in specified LayoutItem in ActivTabPage property.
SetLogo | Sets the logo image.
SetupControl | Setups the main control according to default settings.
SetupControl | Setups the main control according to layout item settings.
ShowCommand | Shows the command.
ShowCommand | Shows the command.
REXUI Properties
REXUI Properties | Description
MainControl | Gets or sets the main control.
MainWindow | Gets or sets the main form.
Links
REX.Common Namespace, Legend, Members, Public Methods, REXUI Enumerations, REXUI Fields, REXUI Methods, REXUI Properties

REXUI.REXUI Constructor

REXUI.REXUI Constructor
REXUI Class REX.Common Namespace REXUI Class

Initializes a new instance of the REXUI class.

C#
public REXUI();
Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class

REX.Common.REXUI.CommandOptions Enumeration

REX.Common.REXUI.CommandOptions Enumeration
REXUI Class

Identifies commands settings on the user interface.

C#
[Flags]
public enum CommandOptions {
  None = 0,
  ToolBarOpen = 0x1,
  ToolBarSave = 0x2,
  ToolBarCalculate = 0x4,
  ToolBarHelp = 0x8,
  ToolMenuFile = 0x10,
  ToolMenuFileOpen = 0x20,
  ToolMenuFileSave = 0x40,
  ToolMenuFileSaveAs = 0x80,
  ToolMenuFilePrint = 0x100,
  ToolMenuFileClose = 0x200,
  ToolMenuCalculation = 0x400,
  ToolMenuCalculationRun = 0x800,
  ToolMenuHelp = 0x1000,
  ToolMenuHelpRun = 0x2000,
  ToolMenuHelpAbout = 0x4000,
  MenuFile = 0x8000,
  MenuFileOpen = 0x10000,
  MenuFileSave = 0x20000,
  MenuFileSaveAs = 0x40000,
  MenuFilePrint = 0x80000,
  MenuFileClose = 0x100000,
  MenuCalculation = 0x200000,
  MenuCalculationRun = 0x400000,
  MenuHelp = 0x800000,
  MenuHelpRun = 0x1000000,
  MenuHelpAbout = 0x2000000
}
Description
Class

REXUI Class

Links
REXUI Class
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REX.Common.REXUI.SetupOptions Enumeration

REX.Common.REXUI.SetupOptions Enumeration
REXUI Class

Identifies all elements of user interface.

C#
[Flags]
public enum SetupOptions {
  None = 0,
  List = 0x1,
  TabDialog = 0x2,
  TabView = 0x4,
  TabNote = 0x8,
  DialogBottom = 0x10,
  Status = 0x20,
  Menu = 0x40,
  ToolBar = 0x80,
  ToolBarInner = 0x100,
  ToolMenu = 0x200,
  ActivateControl = 0x400,
  FormFixed = 0x800,
  VSplitFixed = 0x1000,
  HSplitFixed = 0x2000,
  DisableDocking = 0x4000,
  ToolbarIncrementForm = 0x8000,
  AutoSizeForm = 0x10000
}
Members
Members | Description
None | No options.
List | List of options on the left side of main control.
TabDialog | Dialog placed on the right side of main control.
TabView | View (or dialog) placed on the right side of main control.
TabNote | HTML note placed on the right side of main control.
DialogBottom | Dialog placed on the bottom of main control.
Status | Status bar placed on the bottom of main control.
Menu | Standard menu bar placed on the top of main control.
ToolBar | Standard tool bar placed on the top of main control, but below the menu bar.
ToolBarInner | Standard tool bar placed on the top of right panel (controls on tabs).
ToolMenu | Menu based on tool bar placed on the top of main control, but below the menu bar, like tool bar.
ActivateControl | Sets focus on control after layout selection (currently is not implemented).
FormFixed | Sets main form fixed size.
VSplitFixed | Sets main control vertical splitter fixed.
HSplitFixed | Sets main control horizontal splitter fixed.
DisableDocking | Disables tool bars docking.
ToolbarIncrementForm | Increments size of main form by height of tool bar.
AutoSizeForm | Adapts main from to size of all controls (currently is not implemented).
Description
Class

REXUI Class

Links
REXUI Class
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXUI.NameDialog Field

REXUI.NameDialog Field
REXUI Class REX.Common Namespace REXUI Class

Name of dialog's container.

C#
public static string NameDialog = "DialogContainer";
Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class

REXUI.NameHSplit Field

REXUI.NameHSplit Field
REXUI Class REX.Common Namespace REXUI Class

Name of horizontal splitter.

C#
public static string NameHSplit = "HSplit";
Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class

REXUI.NameHSplitGrid Field

REXUI.NameHSplitGrid Field