Parameters | Gets or sets the parameters.
Links
REX.ContentGenerator.Families Namespace, Legend, Members, Public Methods, REXFamilyType_DBSection Methods, REXFamilyType_DBSection Properties

REXFamilyType_DBSection.REXFamilyType_DBSection Constructor ()

REXFamilyType_DBSection.REXFamilyType_DBSection Constructor ()
REXFamilyType_DBSection Class REX.ContentGenerator.Families Namespace REXFamilyType_DBSection Class

Initializes a new instance of the REXFamilyType_DBSection class.

C#
public REXFamilyType_DBSection();
Description
Class

REXFamilyType_DBSection Class

Links
REXFamilyType_DBSection Class, REX.ContentGenerator.Families Namespace, REXFamilyType_DBSection Class

REXFamilyType_DBSection.REXFamilyType_DBSection Constructor (REXFamilyType_DBSection)

REXFamilyType_DBSection.REXFamilyType_DBSection Constructor (REXFamilyType_DBSection)
REXFamilyType_DBSection Class REX.ContentGenerator.Families Namespace REXFamilyType_DBSection Class

Initializes a new instance of the REXFamilyType_DBSection class.

C#
public REXFamilyType_DBSection(REXFamilyType_DBSection pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

REXFamilyType_DBSection Class

Links
REXFamilyType_DBSection Class, REX.ContentGenerator.Families Namespace, REXFamilyType_DBSection Class

REXFamilyType_DBSection.REXFamilyType_DBSection Constructor (string, string, REX.ContentGenerator.Families.EElementType, bool, EMaterial)

REXFamilyType_DBSection.REXFamilyType_DBSection Constructor (string, string, REX.ContentGenerator.Families.EElementType, bool, EMaterial)
REXFamilyType_DBSection Class REX.ContentGenerator.Families Namespace REXFamilyType_DBSection Class

Initializes a new instance of the REXFamilyType_DBSection class.

C#
public REXFamilyType_DBSection(string familyName, string typeName, REX.ContentGenerator.Families.EElementType category, bool certified, EMaterial material);
Parameters
Parameters | Description
familyName | The name of the family.
typeName | The name of the type.
category | The category.
certified | Indicates whether the object is certified.
material | The material.
Description
Class

REXFamilyType_DBSection Class

Links
REXFamilyType_DBSection Class, REX.ContentGenerator.Families Namespace, REXFamilyType_DBSection Class

REXFamilyType_DBSection.Clone Method

REXFamilyType_DBSection.Clone Method
REXFamilyType_DBSection Class REX.ContentGenerator.Families Namespace REXFamilyType_DBSection Class

Creates a new object that is a copy of the current instance.

C#
public override object Clone();
Returns

A new object that is a copy of this instance.

Description
Class

REXFamilyType_DBSection Class

Links
REXFamilyType_DBSection Class, REX.ContentGenerator.Families Namespace, REXFamilyType_DBSection Class

REXFamilyType_DBSection.CompareTo Method

REXFamilyType_DBSection.CompareTo Method
REXFamilyType_DBSection Class REX.ContentGenerator.Families Namespace REXFamilyType_DBSection Class

Compares the current object with the other object.

C#
public override int CompareTo(object obj);
Parameters
Parameters | Description
obj | The object.
Returns

Returns the result of the comparison.

Description
Class

REXFamilyType_DBSection Class

Links
REXFamilyType_DBSection Class, REX.ContentGenerator.Families Namespace, REXFamilyType_DBSection Class

REXFamilyType_DBSection.CategoryType Property

REXFamilyType_DBSection.CategoryType Property
REXFamilyType_DBSection Class REX.ContentGenerator.Families Namespace REXFamilyType_DBSection Class

Gets the category.

C#
public override ECategoryType CategoryType;
Description

The category.

Class

REXFamilyType_DBSection Class

Links
REXFamilyType_DBSection Class, REX.ContentGenerator.Families Namespace, REXFamilyType_DBSection Class

REXFamilyType_DBSection.Parameters Property

REXFamilyType_DBSection.Parameters Property
REXFamilyType_DBSection Class REX.ContentGenerator.Families Namespace REXFamilyType_DBSection Class

Gets or sets the parameters.

C#
public REXSectionDBDescription Parameters;
Description

The parameters.

Class

REXFamilyType_DBSection Class

Links
REXFamilyType_DBSection Class, REX.ContentGenerator.Families Namespace, REXFamilyType_DBSection Class

REXFamilyType_Label Class

REXFamilyType_Label Class
REX.ContentGenerator.Families Namespace Legend Members Public Methods REXFamilyType_Label Methods REXFamilyType_Label Properties

Represents labels.

Class Hierarchy
C#
public class REXFamilyType_Label : REXFamilyType;
Description
Remarks

A label is not specified type which has specific name assigned. It can represent material, section etc. It is used for mapping mainly.

Namespace

REX.ContentGenerator.Families Namespace

Public Methods
Public Method | Description
REXFamilyType_Label | Initializes a new instance of the REXFamilyType_Label class.
REXFamilyType_Label | Initializes a new instance of the REXFamilyType_Label class.
REXFamilyType_Label | Initializes a new instance of the REXFamilyType_Label class.
REXFamilyType_Label Methods
REXFamilyType_Label Methods | Description
Clone | Creates a new object that is a copy of the current instance.
CompareTo | Compares the current object with the other object.
REXFamilyType_Label Properties
REXFamilyType_Label Properties | Description
CategoryType | Gets the category.
Parameters | Gets the parameters.
Links
REX.ContentGenerator.Families Namespace, Legend, Members, Public Methods, REXFamilyType_Label Methods, REXFamilyType_Label Properties

REXFamilyType_Label.REXFamilyType_Label Constructor ()

REXFamilyType_Label.REXFamilyType_Label Constructor ()
REXFamilyType_Label Class REX.ContentGenerator.Families Namespace REXFamilyType_Label Class

Initializes a new instance of the REXFamilyType_Label class.

C#
public REXFamilyType_Label();
Description
Class

REXFamilyType_Label Class

Links
REXFamilyType_Label Class, REX.ContentGenerator.Families Namespace, REXFamilyType_Label Class

REXFamilyType_Label.REXFamilyType_Label Constructor (ECategoryType, string)

REXFamilyType_Label.REXFamilyType_Label Constructor (ECategoryType, string)
REXFamilyType_Label Class REX.ContentGenerator.Families Namespace REXFamilyType_Label Class

Initializes a new instance of the REXFamilyType_Label class.

C#
public REXFamilyType_Label(ECategoryType cat, string name);
Parameters
Parameters | Description
cat | The category.
name | The name.
Description
Class

REXFamilyType_Label Class

Links
REXFamilyType_Label Class, REX.ContentGenerator.Families Namespace, REXFamilyType_Label Class

REXFamilyType_Label.REXFamilyType_Label Constructor (REXFamilyType_Label)

REXFamilyType_Label.REXFamilyType_Label Constructor (REXFamilyType_Label)
REXFamilyType_Label Class REX.ContentGenerator.Families Namespace REXFamilyType_Label Class

Initializes a new instance of the REXFamilyType_Label class.

C#
public REXFamilyType_Label(REXFamilyType_Label pattern);
Description
Class

REXFamilyType_Label Class

Links
REXFamilyType_Label Class, REX.ContentGenerator.Families Namespace, REXFamilyType_Label Class

REXFamilyType_Label.Clone Method

REXFamilyType_Label.Clone Method
REXFamilyType_Label Class REX.ContentGenerator.Families Namespace REXFamilyType_Label Class

Creates a new object that is a copy of the current instance.

C#
public override object Clone();
Returns

A new object that is a copy of this instance.

Description
Class

REXFamilyType_Label Class

Links
REXFamilyType_Label Class, REX.ContentGenerator.Families Namespace, REXFamilyType_Label Class

REXFamilyType_Label.CompareTo Method

REXFamilyType_Label.CompareTo Method
REXFamilyType_Label Class REX.ContentGenerator.Families Namespace REXFamilyType_Label Class

Compares the current object with the other object.

C#
public override int CompareTo(object obj);
Parameters
Parameters | Description
obj | The object.
Returns

Returns the result of the comparison.

Description
Class

REXFamilyType_Label Class

Links
REXFamilyType_Label Class, REX.ContentGenerator.Families Namespace, REXFamilyType_Label Class