LayoutItem | The layout item.
Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class

REXUI.SetLogo Method

REXUI.SetLogo Method
REXUI Class REX.Common Namespace REXUI Class

Sets the logo image.

C#
public void SetLogo(ImageSource LogoImage);
Parameters
Parameters | Description
LogoImage | The logo image.
Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class

REXUI.SetupControl Method (long)

REXUI.SetupControl Method (long)
REXUI Class REX.Common Namespace REXUI Class

Setups the main control according to default settings.

C#
public void SetupControl(long Options);
Parameters
Parameters | Description
Options | The options.
Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class

REXUI.SetupControl Method (long, REXLayoutItem)

REXUI.SetupControl Method (long, REXLayoutItem)
REXUI Class REX.Common Namespace REXUI Class

Setups the main control according to layout item settings.

C#
public void SetupControl(long Options, REXLayoutItem LayoutItem);
Parameters
Parameters | Description
Options | The options.
LayoutItem | The layout item.
Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class

REXUI.ShowCommand Method (REXUI.CommandOptions)

REXUI.ShowCommand Method (REXUI.CommandOptions)
REXUI Class REX.Common Namespace REXUI Class

Shows the command.

C#
public void ShowCommand(REXUI.CommandOptions command);
Parameters
Parameters | Description
command | The command.
Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class

REXUI.ShowCommand Method (string)

REXUI.ShowCommand Method (string)
REXUI Class REX.Common Namespace REXUI Class

Shows the command.

C#
public void ShowCommand(string Name);
Parameters
Parameters | Description
Name | The name of the command.
Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class

REXUI.MainControl Property

REXUI.MainControl Property
REXUI Class REX.Common Namespace REXUI Class

Gets or sets the main control.

C#
public REXExtensionControl MainControl;
Description

The main control.

Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class

REXUI.MainWindow Property

REXUI.MainWindow Property
REXUI Class REX.Common Namespace REXUI Class

Gets or sets the main form.

C#
public Window MainWindow;
Description

The main form.

Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class

REXVersion Class

REXVersion Class
REX.Common Namespace Legend Members REXVersion Fields

Foundation class for REX.Foundation usage.

Class Hierarchy
C#
public static class REXVersion;
Description
Namespace

REX.Common Namespace

REXVersion Fields
REXVersion Fields | Description
DedicatedVersionName | Dedicated version name (2009, 2010, etx).
Links
REX.Common Namespace, Legend, Members, REXVersion Fields

REXVersion.DedicatedVersionName Field

REXVersion.DedicatedVersionName Field
REXVersion Class REX.Common Namespace REXVersion Class

Dedicated version name (2009, 2010, etx).

C#
public const string DedicatedVersionName = "2018";
Description
Class

REXVersion Class

Links
REXVersion Class, REX.Common Namespace, REXVersion Class

REXWarnings Class

REXWarnings Class
REX.Common Namespace Legend Members REXWarnings Enumerations REXWarnings Methods REXWarnings Structures

This is class REX.Common.REXWarnings.

Class Hierarchy
C#
public class REXWarnings;
Namespace

REX.Common Namespace

REXWarnings Enumerations
REXWarnings Enumerations | Description
WarningCode | This is record REX.Common.REXWarnings.WarningCode.
REXWarnings Methods
REXWarnings Methods | Description
GetMessage | This is GetMessage, a member of class REXWarnings.
REXWarnings Structures
REXWarnings Structures | Description
errMapStr | This is class REX.Common.REXWarnings.errMapStr.
Links
REX.Common Namespace, Legend, Members, REXWarnings Enumerations, REXWarnings Methods, REXWarnings Structures

REXWarnings.errMapStr Structure

REXWarnings.errMapStr Structure
REXWarnings Class Legend Members Public Methods errMapStr Fields

This is class REX.Common.REXWarnings.errMapStr.

C#
public struct errMapStr {
  public WarningCode ecode;
  public String msg;
}
Class

REXWarnings Class

Public Methods
Public Method | Description
errMapStr | This is errMapStr, a member of class errMapStr.
errMapStr Fields
errMapStr Fields | Description
ecode | This is ecode, a member of class errMapStr.
msg | This is msg, a member of class errMapStr.
Links
REXWarnings Class, Legend, Members, Public Methods, errMapStr Fields

REXWarnings.errMapStr.errMapStr Constructor

REXWarnings.errMapStr.errMapStr Constructor
REXWarnings.errMapStr Structure REX.Common Namespace REXWarnings.errMapStr Structure

This is errMapStr, a member of class errMapStr.

C#
public errMapStr(WarningCode e, String m);
Structure

REXWarnings.errMapStr Structure

Links
REXWarnings.errMapStr Structure, REX.Common Namespace, REXWarnings.errMapStr Structure

REXWarnings.errMapStr.ecode Field

REXWarnings.errMapStr.ecode Field
REXWarnings.errMapStr Structure REX.Common Namespace REXWarnings.errMapStr Structure

This is ecode, a member of class errMapStr.

C#
public WarningCode ecode;
Structure

REXWarnings.errMapStr Structure

Links
REXWarnings.errMapStr Structure, REX.Common Namespace, REXWarnings.errMapStr Structure

REXWarnings.errMapStr.msg Field

REXWarnings.errMapStr.msg Field
REXWarnings.errMapStr Structure REX.Common Namespace REXWarnings.errMapStr Structure

This is msg, a member of class errMapStr.

C#
public String msg;
Structure

REXWarnings.errMapStr Structure

Links
REXWarnings.errMapStr Structure, REX.Common Namespace, REXWarnings.errMapStr Structure

REX.Common.REXWarnings.WarningCode Enumeration

REX.Common.REXWarnings.WarningCode Enumeration
REXWarnings Class

This is record REX.Common.REXWarnings.WarningCode.

C#
public enum WarningCode {
  eUNKNOWN = 0,
  eTREE_ADD_NODE = 1000,
  eLIST_ADD_NODE = 1001,
  eFILE_NOT_FOUND = 2000,
  eENGINE_PRODUCT_NOINFO = 3000
}
Class

REXWarnings Class

Links
REXWarnings Class
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXWarnings.GetMessage Method

REXWarnings.GetMessage Method
REXWarnings Class REX.Common Namespace REXWarnings Class

This is GetMessage, a member of class REXWarnings.

C#
public static String GetMessage(WarningCode e);
Class

REXWarnings Class

Links
REXWarnings Class, REX.Common Namespace, REXWarnings Class

REXWebBrowser Class

REXWebBrowser Class
REX.Common Namespace Legend Members REXWebBrowser Fields REXWebBrowser Methods

Proxy class for web browser control.

Class Hierarchy
C#
public class REXWebBrowser;
Description

Loads html page on thread.

Namespace

REX.Common Namespace

REXWebBrowser Fields
REXWebBrowser Fields | Description
ThreadRef | The reference to thread.
URL | The URL for html page.
WB | The reference to WebBrowser object.
REXWebBrowser Methods
REXWebBrowser Methods | Description
Start | Starts thread and loads html page on thread.
StartThread | Starts the thread.
Links
REX.Common Namespace, Legend, Members, REXWebBrowser Fields, REXWebBrowser Methods

REXWebBrowser.ThreadRef Field

REXWebBrowser.ThreadRef Field
REXWebBrowser Class REX.Common Namespace REXWebBrowser Class

The reference to thread.

C#
public Thread ThreadRef;
Description
Class

REXWebBrowser Class

Links
REXWebBrowser Class, REX.Common Namespace, REXWebBrowser Class

REXWebBrowser.URL Field

REXWebBrowser.URL Field
REXWebBrowser Class REX.Common Namespace REXWebBrowser Class

The URL for html page.

C#
public string URL;
Description
Class

REXWebBrowser Class

Links
REXWebBrowser Class, REX.Common Namespace, REXWebBrowser Class

REXWebBrowser.WB Field

REXWebBrowser.WB Field
REXWebBrowser Class REX.Common Namespace REXWebBrowser Class

The reference to WebBrowser object.

C#