REXFamilyConverter.GetRebar Method (REX.ContentGenerator.Geometry.Contour_3D, REXxyz, REXFamilyType_RebarBarType, bool, REXFamilyType_RebarHook, REXFamilyType_RebarHook, string, string, bool)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace Example REXFamilyConverter Class

Gets the rebar object due to the defined contour, the bar's type and the shape's database.

C#
public REXFamilyType_Rebar GetRebar(REX.ContentGenerator.Geometry.Contour_3D contour3D, REXxyz normal, REXFamilyType_RebarBarType barType, bool stirrup, REXFamilyType_RebarHook hookStart, REXFamilyType_RebarHook hookEnd, string dbShapeName, string shape, bool closedShape);
Parameters
Parameters | Description
contour3D | The contour of the rebar.
normal | The normal of the plane on which the rebar is defined.
barType | The type of the rebar.
stirrup | If the rebar is a stirrup.
hookStart | The hook start.
hookEnd | The hook end.
dbShapeName | The name of the database.
shape | The suggested shape (if empty the arbitrary rebar will be generated).
closedShape | If the rebar is closed.
Returns

Returns the rebar object.

Description
Example

The example shows how to get rebar object based on the specific contour.

//Initializing converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Rebar data (it can be taken from different sources e.g. Revit).
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Reinf";
REXFamilyType_RebarBarType famRebarType = rex.GetFamilyRebarType("Grade 40", "#8", "bar_ACI 318-08", directory);
REXFamilyType_RebarHook hookStart = new REXFamilyType_RebarHook();
hookStart.Parameters.Angle = EHookAngles.none;
REXFamilyType_RebarHook hookEnd = new REXFamilyType_RebarHook();
hookEnd.Parameters.Angle = EHookAngles.none;

//Contour.
REX.ContentGenerator.Geometry.Contour_3D cont = new REX.ContentGenerator.Geometry.Contour_3D();
cont.StartContour(new REXxyz(0, 0));
cont.LineTo(new REXxyz(2, 0));
cont.LineTo(new REXxyz(2, 1));
REXxyz normal = new REXxyz(0, 0, 1);

//Getting Rebar object from contour.
REXFamilyType_Rebar r = rex.GetRebar(cont, normal, famRebarType, false, hookStart, hookEnd, "barlib7_iso","31",true);

The rebar object can be used by other converters to create a rebar of the specific shape (e.g. RVTFamilyConverter: CreateRebar).

Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, REXFamilyConverter Class

REXFamilyConverter.GetRoundRebar Method

REXFamilyConverter.GetRoundRebar Method
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace Example REXFamilyConverter Class

Gets the round rebar object due to parameters.

C#
public REXFamilyType_Rebar GetRoundRebar(REXxyz insertPt, REXxyz normal, double diameter, double lapSplice, REXFamilyType_RebarBarType barType, bool stirrup, REXFamilyType_RebarHook hookStart, REXFamilyType_RebarHook hookEnd);
Parameters
Parameters | Description
insertPt | The insertion point (the center of a circle).
normal | The normal of the plane on which the rebar is defined.
diameter | The diameter of circle (in axes).
lapSplice | The lap splice.
barType | The type of the rebar.
stirrup | If the rebar is a stirrup.
hookStart | The hook start.
hookEnd | The hook end.
Returns

Returns the rebar object.

Description
Example

The example shows how to get a round rebar.

//Initializing converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Rebar data (it can be taken from different sources e.g. Revit).
string directory = @"C:Documents and SettingsAll UsersApplication DataAutodeskStructuralCommon Data2011DataReinf";
REXFamilyType_RebarBarType famRebarType = rex.GetFamilyRebarType("Grade 40", "#8", "bar_ACI 318-08", directory);

REXFamilyType_RebarHook hookStart = new REXFamilyType_RebarHook();
hookStart.Parameters.Angle = EHookAngles.none;

REXFamilyType_RebarHook hookEnd = new REXFamilyType_RebarHook();
hookEnd.Parameters.Angle = EHookAngles.none;

REX.Common.Geometry.REXxyz normal = new REX.Common.Geometry.REXxyz(0, 0, 1);
REX.Common.Geometry.REXxyz center = new REX.Common.Geometry.REXxyz(0, 0, 0);
double diameter = 1;
double lapSplice = 0.2;

//Getting Rebar object from contour.
REXFamilyType_Rebar r = rex.GetRoundRebar(center,normal,diameter,lapSplice, famRebarType, false, hookStart, hookEnd);

The rebar object can be used by other converters to create a rebar of the specific shape (e.g. RVTFamilyConverter: CreateRebar).

Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, REXFamilyConverter Class

REXFamilyConverter.GetSpiralRebar Method

REXFamilyConverter.GetSpiralRebar Method
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace Example REXFamilyConverter Class

Gets the spiral rebar object due to parameters.

C#
public REXFamilyType_Rebar GetSpiralRebar(REXxyz insertPt, REXxyz normal, double diameter, double height, double pitch, REXFamilyType_RebarBarType barType, bool stirrup, REXFamilyType_RebarHook hookStart, REXFamilyType_RebarHook hookEnd);
Parameters
Parameters | Description
insertPt | The insertion point (the center of a circle).
normal | The normal of the plane on which the rebar is defined.
diameter | The diameter of circle (in axes).
height | The height of the rebar
pitch | The pitch.
barType | The type of the rebar.
stirrup | If the rebar is a stirrup.
hookStart | The hook start.
hookEnd | The hook end.
Returns

Returns the rebar object.

Description
Example

The example shows how to get a round rebar.

//Initializing converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Rebar data (it can be taken from different sources e.g. Revit).
string directory = @"C:Documents and SettingsAll UsersApplication DataAutodeskStructuralCommon Data2011DataReinf";
REXFamilyType_RebarBarType famRebarType = rex.GetFamilyRebarType("Grade 40", "#8", "bar_ACI 318-08", directory);

REXFamilyType_RebarHook hookStart = new REXFamilyType_RebarHook();
hookStart.Parameters.Angle = EHookAngles.none;

REXFamilyType_RebarHook hookEnd = new REXFamilyType_RebarHook();
hookEnd.Parameters.Angle = EHookAngles.none;

REX.Common.Geometry.REXxyz normal = new REX.Common.Geometry.REXxyz(0, 0, 1);
REX.Common.Geometry.REXxyz center = new REX.Common.Geometry.REXxyz(0, 0, 0);
double diameter = 1;
double height = 2;
double pitch = 0.3;

//Getting Rebar object from contour.
REXFamilyType_Rebar r = rex.GetSpiralRebar(center, normal, diameter,height,pitch, famRebarType, false, hookStart, hookEnd);

The rebar object can be used by other converters to create a rebar of the specific shape (e.g. RVTFamilyConverter: CreateRebar).

Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, REXFamilyConverter Class

REXFamilyConverter.GetUserDatabaseDirectory Method

REXFamilyConverter.GetUserDatabaseDirectory Method
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace REXFamilyConverter Class

Returns directory for user databases of the specified category.

C#
public string GetUserDatabaseDirectory(ECategoryType category);
Description
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, REXFamilyConverter Class

REXFamilyConverter.RegisterCustomFactory Method

REXFamilyConverter.RegisterCustomFactory Method
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace REXFamilyConverter Class

Registers the custom factory.

C#
public bool RegisterCustomFactory<T_REXFamilyType, T_REXDescription>(string name, string parametersFilePath) where T_REXFamilyType : new() where T_REXDescription : new();
Parameters
Parameters | Description
name | The name of the custom category(it will be used for identification so it has to be unique and consistent).
parametersFilePath | The parameters file path.
Type Parameters
Type Parameters | Description