Parameters
Parameters | Description
end | Indicates whether the end point should be included.
Returns

Returns the list of points

Description
Class

ContourCircle Class

Links
ContourCircle Class, REX.ContentGenerator.Geometry Namespace, ContourCircle Class

ContourCircle.GetStart Method

ContourCircle.GetStart Method
ContourCircle Class REX.ContentGenerator.Geometry Namespace ContourCircle Class

Gets the start (center).

C#
public REXxyz GetStart(ECoords coords);
Parameters
Parameters | Description
coords | The coordinate system (plane).
Returns

The start (center) point.

Description
Class

ContourCircle Class

Links
ContourCircle Class, REX.ContentGenerator.Geometry Namespace, ContourCircle Class

ContourCircle.MultiplyLengthDim Method

ContourCircle.MultiplyLengthDim Method
ContourCircle Class REX.ContentGenerator.Geometry Namespace ContourCircle Class

Multiplies length dimensions by the coefficient.

C#
public override void MultiplyLengthDim(double coeff);
Parameters
Parameters | Description
coeff | The coefficient.
Description
Class

ContourCircle Class

Links
ContourCircle Class, REX.ContentGenerator.Geometry Namespace, ContourCircle Class

ContourCircle.Translate Method

ContourCircle.Translate Method
ContourCircle Class REX.ContentGenerator.Geometry Namespace ContourCircle Class

Applies the specified translation vector to the element.

C#
public override void Translate(double x, double y);
Parameters
Parameters | Description
x | The x.
y | The y.
Description
Class

ContourCircle Class

Links
ContourCircle Class, REX.ContentGenerator.Geometry Namespace, ContourCircle Class

ContourCircle.Center Property

ContourCircle.Center Property
ContourCircle Class REX.ContentGenerator.Geometry Namespace ContourCircle Class

Gets or sets the start (center).

C#
public REXxyz Center;
Description

The start (center).

Class

ContourCircle Class

Links
ContourCircle Class, REX.ContentGenerator.Geometry Namespace, ContourCircle Class

ContourCircle.R Property

ContourCircle.R Property
ContourCircle Class REX.ContentGenerator.Geometry Namespace ContourCircle Class

Gets or sets the radius.

C#
public double R;
Description

The radius.

Class

ContourCircle Class

Links
ContourCircle Class, REX.ContentGenerator.Geometry Namespace, ContourCircle Class

ContourCont Class

ContourCont Class
REX.ContentGenerator.Geometry Namespace Legend Members Public Methods ContourCont Methods ContourCont Properties

Represents the contour element.

Class Hierarchy
C#
[Serializable()]
public class ContourCont : ContourElem;
Description
Namespace

REX.ContentGenerator.Geometry Namespace

Public Methods
Public Method | Description
ContourCont | Initializes a new instance of the ContourCont class.
ContourCont | Initializes a new instance of the ContourCont class.
ContourCont | Initializes a new instance of the ContourCont class.
ContourCont | Initializes a new instance of the ContourCont class.
ContourCont Methods
ContourCont Methods | Description
GetGeometryParams | Gets the geometry params.
GetPointList | Gets the list of points.
IsContourInsideMe | Determines whether the contour is inside current one.
MultiplyLengthDim | Multiplies length dimensions by the coefficient.
Transform | Applies the specified transformation to the element.
Translate | Applies the specified translation vector to the element.
ContourCont Properties
ContourCont Properties | Description
ContList | Gets or sets the list of contours.
ElemList | Gets or sets the list of elements.
Hole | Gets or sets a value indicating whether this contour is a hole.
Links
REX.ContentGenerator.Geometry Namespace, Legend, Members, Public Methods, ContourCont Methods, ContourCont Properties

ContourCont.ContourCont Constructor (ContourCont)

ContourCont.ContourCont Constructor (ContourCont)
ContourCont Class REX.ContentGenerator.Geometry Namespace ContourCont Class

Initializes a new instance of the ContourCont class.

C#
public ContourCont(ContourCont pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

ContourCont Class

Links
ContourCont Class, REX.ContentGenerator.Geometry Namespace, ContourCont Class

ContourCont.ContourCont Constructor (System.Runtime.Serialization.SerializationInfo, System.Runtime.Serialization.StreamingContext)

ContourCont.ContourCont Constructor (System.Runtime.Serialization.SerializationInfo, System.Runtime.Serialization.StreamingContext)
ContourCont Class REX.ContentGenerator.Geometry Namespace ContourCont Class

Initializes a new instance of the ContourCont class.

C#
public ContourCont(System.Runtime.Serialization.SerializationInfo info, System.Runtime.Serialization.StreamingContext context);
Parameters
Parameters | Description
info | Serialization data.
context | The context.
Description
Class

ContourCont Class

Links
ContourCont Class, REX.ContentGenerator.Geometry Namespace, ContourCont Class

ContourCont.ContourCont Constructor (bool)

ContourCont.ContourCont Constructor (bool)
ContourCont Class REX.ContentGenerator.Geometry Namespace ContourCont Class

Initializes a new instance of the ContourCont class.

C#
public ContourCont(bool isHole);
Parameters
Parameters | Description
isHole | Indicates whether the contour is a hole.
Description
Class

ContourCont Class

Links
ContourCont Class, REX.ContentGenerator.Geometry Namespace, ContourCont Class

ContourCont.ContourCont Constructor (bool, ContourCont)

ContourCont.ContourCont Constructor (bool, ContourCont)
ContourCont Class REX.ContentGenerator.Geometry Namespace ContourCont Class

Initializes a new instance of the ContourCont class.

C#
public ContourCont(bool isHole, ContourCont parent);
Parameters
Parameters | Description
isHole | Indicates whether the contour is a hole.
parent | The parent.
Description
Class

ContourCont Class

Links
ContourCont Class, REX.ContentGenerator.Geometry Namespace, ContourCont Class

ContourCont.GetGeometryParams Method

ContourCont.GetGeometryParams Method
ContourCont Class REX.ContentGenerator.Geometry Namespace ContourCont Class

Gets the geometry params.

C#
public void GetGeometryParams(out double Ac, out double Sy, out double Sz, out double yc, out double zc, out double Jy, out double Jz, out double Jy0, out double Jz0);
Parameters
Parameters | Description
Ac | The area.
Sy | The static moment - Y.
Sz | The static moment - Z.
yc | The center - Y.
zc | The center - Z.
Jy | The moment of inertia - Y.
Jz | The moment of inertia - Z.
Jy0 | The moment of inertia - center Y.
Jz0 | The moment of inertia - center Z.
Description
Class

ContourCont Class

Links
ContourCont Class, REX.ContentGenerator.Geometry Namespace, ContourCont Class

ContourCont.GetPointList Method

ContourCont.GetPointList Method
ContourCont Class REX.ContentGenerator.Geometry Namespace ContourCont Class

Gets the list of points.

C#
public override List<REXxyz> GetPointList(bool end);
Parameters
Parameters | Description
end | If the end point included.
Returns

Returns the list of points

Description
Class

ContourCont Class

Links
ContourCont Class, REX.ContentGenerator.Geometry Namespace, ContourCont Class

ContourCont.IsContourInsideMe Method

ContourCont.IsContourInsideMe Method
ContourCont Class REX.ContentGenerator.Geometry Namespace ContourCont Class

Determines whether the contour is inside current one.

C#
public bool IsContourInsideMe(ContourCont cont);
Parameters
Parameters | Description
cont | The contour.
Returns

Returns whether contour is inside.

Description
Class

ContourCont Class

Links
ContourCont Class, REX.ContentGenerator.Geometry Namespace, ContourCont Class

ContourCont.MultiplyLengthDim Method

ContourCont.MultiplyLengthDim Method
ContourCont Class REX.ContentGenerator.Geometry Namespace ContourCont Class

Multiplies length dimensions by the coefficient.

C#
public override void MultiplyLengthDim(double coeff);
Parameters
Parameters | Description
coeff | The coefficient.
Description
Class

ContourCont Class

Links