REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class

REXEditBox.RangeMin Property

REXEditBox.RangeMin Property
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Gets or sets the minimum possible value.

C#
[Browsable(true)]
[Category("Data")]
[DefaultValue(Double.NegativeInfinity)]
public double RangeMin;
Description

The minimum possible value.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class

REXEditBox.RangeMinCheck Property

REXEditBox.RangeMinCheck Property
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Gets or sets a value indicating whether the value should be validated due to the RangeMin.

C#
[Browsable(true)]
[Category("Data")]
[DefaultValue(false)]
public bool RangeMinCheck;
Description

True if validate; otherwise false.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class

REXEditBox.RememberCorrect Property

REXEditBox.RememberCorrect Property
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Gets or sets a value indicating whether the correct value should be restored in case of the validation failure.

C#
[Browsable(true)]
[Category("Data")]
public bool RememberCorrect;
Description

True if the value should be restored; otherwise false.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class

REXEditBox.RoundingFractional Property

REXEditBox.RoundingFractional Property
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Gets or sets the rounding for fractional units.

C#
[Browsable(true)]
[Category("Data")]
public EFractialRound RoundingFractional;
Description

The rounding.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class

REXEditBox.RoundingIncrement Property

REXEditBox.RoundingIncrement Property
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Gets or sets the rounding increment (for the DECIMAL DataType).

C#
[Browsable(true)]
[Category("Data")]
public double RoundingIncrement;
Description

The rounding increment.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class

REXEditBox.Separator Property

REXEditBox.Separator Property
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Gets or sets the decimal separator.

C#
[Browsable(true)]
[Category("Data")]
public string Separator;
Description

The separator.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class

REXEditBox.TokensRangeMaxCheck Property

REXEditBox.TokensRangeMaxCheck Property
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Gets or sets a value indicating whether the number of elements should be validated due to the MaxTokens.

C#
[Category("Complex")]
[Browsable(true)]
[DefaultValue(false)]
public bool TokensRangeMaxCheck;
Description

True if validate; otherwise, false.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class

REXEditBox.TokensRangeMinCheck Property

REXEditBox.TokensRangeMinCheck Property
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Gets or sets a value indicating whether the number of elements should be validated due to the MinTokens.

C#
[Category("Complex")]
[Browsable(true)]
[DefaultValue(false)]
public bool TokensRangeMinCheck;
Description

True if validate; otherwise, false.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class

REXEditBox.UnitSymbol Property

REXEditBox.UnitSymbol Property
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Gets or sets the unit symbol.

C#
[Browsable(true)]
[Category("Data")]
[DefaultValue("")]
public string UnitSymbol;
Description

The unit symbol.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class

REXImageComboBox Class

REXImageComboBox Class
REX.Controls.WPF Namespace

Represents combobox with images.

Class Hierarchy
C#
public class REXImageComboBox : ComboBox;
Description
Namespace

REX.Controls.WPF Namespace

Links
REX.Controls.WPF Namespace
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXImageComboBoxItem Class

REXImageComboBoxItem Class
REX.Controls.WPF Namespace Legend Members REXImageComboBoxItem Fields REXImageComboBoxItem Properties

Represents the combobox item with an image inside.

Class Hierarchy
C#
[System.ComponentModel.ToolboxItem(false)]
public class REXImageComboBoxItem : ComboBoxItem;
Description
Namespace

REX.Controls.WPF Namespace

REXImageComboBoxItem Fields
REXImageComboBoxItem Fields | Description
FitToParentHeightProperty | This is FitToParentHeightProperty, a member of class REXImageComboBoxItem.
ImageProperty | This is ImageProperty, a member of class REXImageComboBoxItem.
TextProperty | This is TextProperty, a member of class REXImageComboBoxItem.
VisibleOnListProperty | This is VisibleOnListProperty, a member of class REXImageComboBoxItem.
REXImageComboBoxItem Properties
REXImageComboBoxItem Properties | Description
FitToParentHeight | Gets or sets a value indicating whether item height should be fit to the combobox's height.
Image | Gets or sets the image.
Text | Gets or sets the text.
VisibleOnList | Gets or sets a value indicating whether item should be visible on the list.
Links
REX.Controls.WPF Namespace, Legend, Members, REXImageComboBoxItem Fields, REXImageComboBoxItem Properties

REXImageComboBoxItem.FitToParentHeightProperty Field

REXImageComboBoxItem.FitToParentHeightProperty Field
REXImageComboBoxItem Class REX.Controls.WPF Namespace REXImageComboBoxItem Class

This is FitToParentHeightProperty, a member of class REXImageComboBoxItem.

C#
public static readonly DependencyProperty FitToParentHeightProperty;
Class

REXImageComboBoxItem Class

Links
REXImageComboBoxItem Class, REX.Controls.WPF Namespace, REXImageComboBoxItem Class

REXImageComboBoxItem.ImageProperty Field

REXImageComboBoxItem.ImageProperty Field
REXImageComboBoxItem Class REX.Controls.WPF Namespace REXImageComboBoxItem Class

This is ImageProperty, a member of class REXImageComboBoxItem.

C#
public static readonly DependencyProperty ImageProperty;
Class

REXImageComboBoxItem Class

Links
REXImageComboBoxItem Class, REX.Controls.WPF Namespace, REXImageComboBoxItem Class

REXImageComboBoxItem.TextProperty Field

REXImageComboBoxItem.TextProperty Field
REXImageComboBoxItem Class REX.Controls.WPF Namespace REXImageComboBoxItem Class

This is TextProperty, a member of class REXImageComboBoxItem.

C#
public static readonly DependencyProperty TextProperty;
Class

REXImageComboBoxItem Class

Links
REXImageComboBoxItem Class, REX.Controls.WPF Namespace, REXImageComboBoxItem Class

REXImageComboBoxItem.VisibleOnListProperty Field

REXImageComboBoxItem.VisibleOnListProperty Field
REXImageComboBoxItem Class REX.Controls.WPF Namespace REXImageComboBoxItem Class

This is VisibleOnListProperty, a member of class REXImageComboBoxItem.

C#
public static readonly DependencyProperty VisibleOnListProperty;
Class

REXImageComboBoxItem Class

Links
REXImageComboBoxItem Class, REX.Controls.WPF Namespace, REXImageComboBoxItem Class

REXImageComboBoxItem.FitToParentHeight Property

REXImageComboBoxItem.FitToParentHeight Property
REXImageComboBoxItem Class REX.Controls.WPF Namespace REXImageComboBoxItem Class

Gets or sets a value indicating whether item height should be fit to the combobox's height.

C#
public bool FitToParentHeight;
Description

True if item should be fit to parent; otherwise, false.

Class

REXImageComboBoxItem Class

Links
REXImageComboBoxItem Class, REX.Controls.WPF Namespace, REXImageComboBoxItem Class

REXImageComboBoxItem.Image Property

REXImageComboBoxItem.Image Property