REXExtensionContext.REXControl.APIContext Field

REXExtensionContext.REXControl.APIContext Field
REXExtensionContext.REXControl Structure REX.Common Namespace REXExtensionContext.REXControl Structure

Indicates that module is running in API context.

C#
public bool APIContext;
Description
Structure

REXExtensionContext.REXControl Structure

Links
REXExtensionContext.REXControl Structure, REX.Common Namespace, REXExtensionContext.REXControl Structure

REXExtensionContext.REXControl.Flags Field

REXExtensionContext.REXControl.Flags Field
REXExtensionContext.REXControl Structure REX.Common Namespace REXExtensionContext.REXControl Structure

Flags used for detecting forced settings.

C#
public REXControlFlags Flags;
Description
Structure

REXExtensionContext.REXControl Structure

Links
REXExtensionContext.REXControl Structure, REX.Common Namespace, REXExtensionContext.REXControl Structure

REXExtensionContext.REXControl.ForceHideManager Field

REXExtensionContext.REXControl.ForceHideManager Field
REXExtensionContext.REXControl Structure REX.Common Namespace REXExtensionContext.REXControl Structure

Orders to hide manager of extensions.

C#
public bool ForceHideManager;
Description
Structure

REXExtensionContext.REXControl Structure

Links
REXExtensionContext.REXControl Structure, REX.Common Namespace, REXExtensionContext.REXControl Structure

REXExtensionContext.REXControl.InteractiveCommand Field

REXExtensionContext.REXControl.InteractiveCommand Field
REXExtensionContext.REXControl Structure REX.Common Namespace REXExtensionContext.REXControl Structure

Indicates that module uses interactive modal dialog.

C#
public bool InteractiveCommand;
Description
Structure

REXExtensionContext.REXControl Structure

Links
REXExtensionContext.REXControl Structure, REX.Common Namespace, REXExtensionContext.REXControl Structure

REXExtensionContext.REXControl.LanguagesSupport Field

REXExtensionContext.REXControl.LanguagesSupport Field
REXExtensionContext.REXControl Structure REX.Common Namespace REXExtensionContext.REXControl Structure

Indicates that module has multi-language architecture.

C#
public bool LanguagesSupport;
Description
Structure

REXExtensionContext.REXControl Structure

Links
REXExtensionContext.REXControl Structure, REX.Common Namespace, REXExtensionContext.REXControl Structure

REXExtensionContext.REXControl.LevelType Field

REXExtensionContext.REXControl.LevelType Field
REXExtensionContext.REXControl Structure REX.Common Namespace REXExtensionContext.REXControl Structure

Level type.

C#
public REXLevelType LevelType;
Description
Structure

REXExtensionContext.REXControl Structure

Links
REXExtensionContext.REXControl Structure, REX.Common Namespace, REXExtensionContext.REXControl Structure

REXExtensionContext.REXControl.NoUI Field

REXExtensionContext.REXControl.NoUI Field
REXExtensionContext.REXControl Structure REX.Common Namespace REXExtensionContext.REXControl Structure

Indicates that module can't show any messages and dialogs.

C#
public bool NoUI;
Description
Structure

REXExtensionContext.REXControl Structure

Links
REXExtensionContext.REXControl Structure, REX.Common Namespace, REXExtensionContext.REXControl Structure

REXExtensionContext.REXControl.Owner Field

REXExtensionContext.REXControl.Owner Field
REXExtensionContext.REXControl Structure REX.Common Namespace REXExtensionContext.REXControl Structure

Owner of extension.

C#
public string Owner;
Description
Structure

REXExtensionContext.REXControl Structure

Links
REXExtensionContext.REXControl Structure, REX.Common Namespace, REXExtensionContext.REXControl Structure

REXExtensionContext.REXControl.RegionalSettingsSupport Field

REXExtensionContext.REXControl.RegionalSettingsSupport Field
REXExtensionContext.REXControl Structure REX.Common Namespace REXExtensionContext.REXControl Structure

If true, regional settings will be added to menu and toolbars.

C#
public bool RegionalSettingsSupport;
Description
Structure

REXExtensionContext.REXControl Structure

Links
REXExtensionContext.REXControl Structure, REX.Common Namespace, REXExtensionContext.REXControl Structure

REXExtensionContext.REXControl.RunContext Field

REXExtensionContext.REXControl.RunContext Field
REXExtensionContext.REXControl Structure REX.Common Namespace REXExtensionContext.REXControl Structure

String which set up running context.

C#
public string RunContext;
Description

Decides about output operation.

Structure

REXExtensionContext.REXControl Structure

Links
REXExtensionContext.REXControl Structure, REX.Common Namespace, REXExtensionContext.REXControl Structure

REXExtensionContext.REXControl.ShowErrorsDialog Field

REXExtensionContext.REXControl.ShowErrorsDialog Field
REXExtensionContext.REXControl Structure REX.Common Namespace REXExtensionContext.REXControl Structure

Enables or disables showing of errors in dialog.

C#
public bool ShowErrorsDialog;
Description
Structure

REXExtensionContext.REXControl Structure

Links
REXExtensionContext.REXControl Structure, REX.Common Namespace, REXExtensionContext.REXControl Structure

REXExtensionContext.REXControl.StandardOwner Field

REXExtensionContext.REXControl.StandardOwner Field
REXExtensionContext.REXControl Structure REX.Common Namespace REXExtensionContext.REXControl Structure

Owner of extension.

C#
public REXStandardOwner StandardOwner;
Description
Structure

REXExtensionContext.REXControl Structure

Links
REXExtensionContext.REXControl Structure, REX.Common Namespace, REXExtensionContext.REXControl Structure

REXExtensionContext.REXControl.StandardRunContext Field

REXExtensionContext.REXControl.StandardRunContext Field
REXExtensionContext.REXControl Structure REX.Common Namespace REXExtensionContext.REXControl Structure

String mapped to enum which set up running context.

C#
public REXStandardRunContext StandardRunContext;
Description

Decides about output operation.

Structure

REXExtensionContext.REXControl Structure

Links
REXExtensionContext.REXControl Structure, REX.Common Namespace, REXExtensionContext.REXControl Structure

REXExtensionContext.REXControl.VerifySelection Field

REXExtensionContext.REXControl.VerifySelection Field
REXExtensionContext.REXControl Structure REX.Common Namespace REXExtensionContext.REXControl Structure

Indicates that module is running for verification current selection.

C#
public bool VerifySelection;
Description
Structure

REXExtensionContext.REXControl Structure

Links
REXExtensionContext.REXControl Structure, REX.Common Namespace, REXExtensionContext.REXControl Structure

REXExtensionContext.REXControl.UserInterface Property

REXExtensionContext.REXControl.UserInterface Property
REXExtensionContext.REXControl Structure REX.Common Namespace REXExtensionContext.REXControl Structure

Enables or disables user interface operations.

C#
public bool UserInterface;
Description

Module may force these operations independently of main context.

Structure

REXExtensionContext.REXControl Structure

Links
REXExtensionContext.REXControl Structure, REX.Common Namespace, REXExtensionContext.REXControl Structure

REX.Common.REXExtensionContext.REXControlFlags Structure

REX.Common.REXExtensionContext.REXControlFlags Structure
REXExtensionContext Class

Flags used for detecting forced settings.

C#
public struct REXControlFlags {
  public bool UserInterface;
}
Description
Class

REXExtensionContext Class

Links
REXExtensionContext Class
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REX.Common.REXExtensionContext.REXLevelType Enumeration

REX.Common.REXExtensionContext.REXLevelType Enumeration
REXExtensionContext Class

Level type.

C#
public enum REXLevelType {
  Standard,
  RSA
}
Members
Members | Description
Standard | Standard extension.
RSA | RSA protection level.
Description
Class

REXExtensionContext Class

Links