Data Member
static
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXUI Methods

REXUI Methods
REXUI Class Legend
REXUI Methods
REXUI Methods | Description
AddToolStrip | Adds the tool strip to repositioning.
FindHiddenCommand | Determines whether the input command is hidden.
FindHiddenCommand | Finds the hidden command.
GetAboutLink | Gets the about link.
GetDialog | Gets the dialog control.
GetHelpLink | Gets the help link.
GetList | This is GetList, a member of class REXUI.
GetLogo | Gets the reference to PictureBox which contains logo.
GetMenu | Gets the menu control.
GetMenuBar | Gets the menu bar.
GetNote | Gets the note control.
GetNoteWebBrowser | Gets the note web browser control.
GetStatus | Gets the status control.
GetStatusHeaderLabel | Gets the status header label.
GetStatusLabel | Gets the status label.
GetStatusProgress | Gets the status progress.
GetToolBar | Gets the tool bar.
GetToolBarInner | Gets the tool bar inner.
GetToolbox | Gets the toolbox control.
GetViewer | Gets the viewer's container.
GetWindow | Gets the reference to main form.
HideAboutControls | This is HideAboutControls, a member of class REXUI.
HideAboutLink | Hides the about link.
HideCommand | Hides the command.
HideCommand | Hides the command.
HideHelpLink | Hides the help link.
LoadNoteUrl | Loads the URL to note control.
RememberControl | Remembers the active tab control in specified LayoutItem in ActivTabPage property.
SetLogo | Sets the logo image.
SetupControl | Setups the main control according to default settings.
SetupControl | Setups the main control according to layout item settings.
ShowCommand | Shows the command.
ShowCommand | Shows the command.

REXUI Properties

REXUI Properties
REXUI Class Legend
REXUI Properties
REXUI Properties | Description
MainControl | Gets or sets the main control.
MainWindow | Gets or sets the main form.

REXUI Class Public Methods

REXUI Class Public Methods
REXUI Class Legend
Public Methods
Public Method | Description
REXUI | Initializes a new instance of the REXUI class.

REXVersion Fields

REXVersion Fields
REXVersion Class Legend
REXVersion Fields
REXVersion Fields | Description
DedicatedVersionName | Dedicated version name (2009, 2010, etx).

Legend

Legend
REXVersion Class
Legend
Data Member
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXVersion Class Members

REXVersion Class Members
REXVersion Class Legend
Members
REXVersion Fields
REXVersion Fields | Description
DedicatedVersionName | Dedicated version name (2009, 2010, etx).

REXWarnings Enumerations

REXWarnings Enumerations
REXWarnings Class Legend
REXWarnings Enumerations
REXWarnings Enumerations | Description
WarningCode | This is record REX.Common.REXWarnings.WarningCode.

Legend

Legend
REXWarnings Class
Legend
Structure
Enumeration
Method
static

REXWarnings Class Members

REXWarnings Class Members
REXWarnings Class Legend
Members
REXWarnings Structures
REXWarnings Structures | Description
errMapStr | This is class REX.Common.REXWarnings.errMapStr.
REXWarnings Enumerations
REXWarnings Enumerations | Description
WarningCode | This is record REX.Common.REXWarnings.WarningCode.
REXWarnings Methods
REXWarnings Methods | Description
GetMessage | This is GetMessage, a member of class REXWarnings.

Members

Legend
Legend
Structure
Enumeration
Method
static

REXWarnings Methods

REXWarnings Methods
REXWarnings Class Legend
REXWarnings Methods
REXWarnings Methods | Description
GetMessage | This is GetMessage, a member of class REXWarnings.

REXWarnings Structures

REXWarnings Structures
REXWarnings Class Legend
REXWarnings Structures
REXWarnings Structures | Description
errMapStr | This is class REX.Common.REXWarnings.errMapStr.

errMapStr Fields

errMapStr Fields
REXWarnings.errMapStr Structure Legend
errMapStr Fields
errMapStr Fields | Description
ecode | This is ecode, a member of class errMapStr.
msg | This is msg, a member of class errMapStr.

Legend

Legend
REXWarnings.errMapStr Structure
Legend
Constructor
Data Member
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXWarnings.errMapStr Structure Members

REXWarnings.errMapStr Structure Members
REXWarnings.errMapStr Structure Legend
Members
Public Methods
Public Method | Description
errMapStr | This is errMapStr, a member of class errMapStr.
errMapStr Fields
errMapStr Fields | Description
ecode | This is ecode, a member of class errMapStr.
msg | This is msg, a member of class errMapStr.

REXWarnings.errMapStr Structure Public Methods

REXWarnings.errMapStr Structure Public Methods
REXWarnings.errMapStr Structure Legend
Public Methods
Public Method | Description
errMapStr | This is errMapStr, a member of class errMapStr.

REXWebBrowser Fields

REXWebBrowser Fields
REXWebBrowser Class Legend
REXWebBrowser Fields
REXWebBrowser Fields | Description
ThreadRef | The reference to thread.
URL | The URL for html page.
WB | The reference to WebBrowser object.

Legend

Legend
REXWebBrowser Class
Legend
Data Member
Method
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXWebBrowser Class Members

REXWebBrowser Class Members
REXWebBrowser Class Legend
Members
REXWebBrowser Fields
REXWebBrowser Fields | Description
ThreadRef | The reference to thread.
URL | The URL for html page.
WB | The reference to WebBrowser object.
REXWebBrowser Methods
REXWebBrowser Methods | Description
Start | Starts thread and loads html page on thread.
StartThread | Starts the thread.

Members

Legend
Legend
Data Member
Method
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXWebBrowser Methods

REXWebBrowser Methods
REXWebBrowser Class Legend
REXWebBrowser Methods
REXWebBrowser Methods | Description
Start | Starts thread and loads html page on thread.
StartThread | Starts the thread.

REX.ContentGenerator.Converters Namespace Classes

REX.ContentGenerator.Converters Namespace Classes
REX.ContentGenerator.Converters Namespace Legend
Classes
Class | Description
FieldParams | Represents parameters of the field.
REXContentFilter | Base class for all filters.
REXContentLogicFilter | Describes a logic filter.
REXContentParamFilter | Describes the filter for the specified parameter.
REXCustomFactory | This is class REX.ContentGenerator.Converters.REXCustomFactory.
REXDBSectionFactory | This is class REX.ContentGenerator.Converters.REXDBSectionFactory.
REXFamilyConverter | This class represents a converter which provides access to common databases.
REXMaterialFactory | This is class REX.ContentGenerator.Converters.REXMaterialFactory.
REXParamSectionFactory | This is class REX.ContentGenerator.Converters.REXParamSectionFactory.
RVTCommonSectionFactory | This is class REX.ContentGenerator.Converters.RVTCommonSectionFactory.
RVTCustomFactory | This is class REX.ContentGenerator.Converters.RVTCustomFactory.
RVTDBSectionFactory | This is class REX.ContentGenerator.Converters.RVTDBSectionFactory.
RVTFamilyConverter | This class represents a converter which provides access to Revit project.
RVTMaterialFactory | This is class REX.ContentGenerator.Converters.RVTMaterialFactory.