REXSectionDBProperties | Initializes a new instance of the REXSectionDBProperties class.
REXSectionDBProperties | Initializes a new instance of the
REXSectionDBProperties | Initializes a new instance of the REXSectionDBProperties class.
REXSectionDBProperties Methods
REXSectionDBProperties Methods | Description
Clone | Creates a new object that is a copy of the current instance.
REXSectionDBProperties Properties
REXSectionDBProperties Properties | Description
DIM1 | Gets or sets the first numeric component of the section label
DIM2 | Gets or sets the second numeric component of the section label.
DIM3 | Gets or sets the third numeric component of the section label.
NAME | Gets or sets the name of the section.
NAME_REVIT | Gets or sets the Revit name.
NAME1 | Gets or sets the section name.
Names | Gets or sets the list of optional names.
SHAPE_TYPE | Gets or sets the number of the section shape type.

REXSectionDBProperties Methods

REXSectionDBProperties Methods
REXSectionDBProperties Class Legend
REXSectionDBProperties Methods
REXSectionDBProperties Methods | Description
Clone | Creates a new object that is a copy of the current instance.

REXSectionDBProperties Properties

REXSectionDBProperties Properties
REXSectionDBProperties Class Legend
REXSectionDBProperties Properties
REXSectionDBProperties Properties | Description
DIM1 | Gets or sets the first numeric component of the section label
DIM2 | Gets or sets the second numeric component of the section label.
DIM3 | Gets or sets the third numeric component of the section label.
NAME | Gets or sets the name of the section.
NAME_REVIT | Gets or sets the Revit name.
NAME1 | Gets or sets the section name.
Names | Gets or sets the list of optional names.
SHAPE_TYPE | Gets or sets the number of the section shape type.

REXSectionDBProperties Class Public Methods

REXSectionDBProperties Class Public Methods
REXSectionDBProperties Class Legend
Public Methods
Public Method | Description
REXSectionDBProperties | Initializes a new instance of the REXSectionDBProperties class.
REXSectionDBProperties | Initializes a new instance of the REXSectionDBProperties class.
REXSectionDBProperties | Initializes a new instance of the
REXSectionDBProperties | Initializes a new instance of the REXSectionDBProperties class.

Legend

Legend
REXSectionParamCharacteristics Class
Legend
Constructor
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXSectionParamCharacteristics Class Members

REXSectionParamCharacteristics Class Members
REXSectionParamCharacteristics Class Legend
Members
Public Methods
Public Method | Description
REXSectionParamCharacteristics | Initializes a new instance of the REXSectionParamCharacteristics class.
REXSectionParamCharacteristics | Initializes a new instance of the REXSectionParamCharacteristics class.
REXSectionParamCharacteristics | Initializes a new instance of the REXSectionParamCharacteristics class.
REXSectionParamCharacteristics | Initializes a new instance of the REXSectionParamCharacteristics class.
REXSectionParamCharacteristics Methods
REXSectionParamCharacteristics Methods | Description
Clone | Clones this instance.
REXSectionParamCharacteristics Properties
REXSectionParamCharacteristics Properties | Description
A | Gets or sets the Cross-section area.
IY | Gets or sets the moment of inertia about the Y axis.
IZ | Gets or sets the moment of inertia about the Z axis.
MASS | Gets or sets the nominal weight per unit length.

REXSectionParamCharacteristics Methods

REXSectionParamCharacteristics Methods
REXSectionParamCharacteristics Class Legend
REXSectionParamCharacteristics Methods
REXSectionParamCharacteristics Methods | Description
Clone | Clones this instance.

REXSectionParamCharacteristics Properties

REXSectionParamCharacteristics Properties
REXSectionParamCharacteristics Class Legend
REXSectionParamCharacteristics Properties
REXSectionParamCharacteristics Properties | Description
A | Gets or sets the Cross-section area.
IY | Gets or sets the moment of inertia about the Y axis.
IZ | Gets or sets the moment of inertia about the Z axis.
MASS | Gets or sets the nominal weight per unit length.

REXSectionParamCharacteristics Class Public Methods

REXSectionParamCharacteristics Class Public Methods
REXSectionParamCharacteristics Class Legend
Public Methods
Public Method | Description
REXSectionParamCharacteristics | Initializes a new instance of the REXSectionParamCharacteristics class.
REXSectionParamCharacteristics | Initializes a new instance of the REXSectionParamCharacteristics class.
REXSectionParamCharacteristics | Initializes a new instance of the REXSectionParamCharacteristics class.
REXSectionParamCharacteristics | Initializes a new instance of the REXSectionParamCharacteristics class.

Legend

Legend
REXSectionParamDescription Class
Legend
Constructor
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXSectionParamDescription Class Members

REXSectionParamDescription Class Members
REXSectionParamDescription Class Legend
Members
Public Methods
Public Method | Description
REXSectionParamDescription | Initializes a new instance of the REXSectionParamDescription class.
REXSectionParamDescription | Initializes a new instance of the REXSectionParamDescription class.
REXSectionParamDescription | Initializes a new instance of the REXSectionParamDescription class.
REXSectionParamDescription | Initializes a new instance of the REXSectionParamDescription class.
REXSectionParamDescription Methods
REXSectionParamDescription Methods | Description
CalculataMainAxisAndCharacteristics | Calculatas the main axis and characteristics of the section.
CalculateCharacteristics | Calculates characteristics of the section.
CalculateMainAxisParams | Calculates the main axis of the section.
Clone | Creates a new object that is a copy of the current instance.
CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
GetContour | Gets the contour.
GetMaterialDependence | Gets the material dependence.
REXSectionParamDescription Properties
REXSectionParamDescription Properties | Description
Angle | Gets or sets the angle of the section.
Characteristics | Gets or sets the characteristics.
CharacteristicsEnd | Gets or sets the characteristics of the end.
Contour | Gets or sets the contour.
Dimensions | Gets or sets the dimensions.
DimensionsEnd | Gets or sets the dimensions of the end.
IsTurned | Gets or sets a value indicating whether this instance is turned.
SectionType | Gets or sets the type of the section.
Tapered | Gets or sets a value indicating whether this REXSectionParamDescription is tapered.

REXSectionParamDescription Methods

REXSectionParamDescription Methods
REXSectionParamDescription Class Legend
REXSectionParamDescription Methods
REXSectionParamDescription Methods | Description
CalculataMainAxisAndCharacteristics | Calculatas the main axis and characteristics of the section.
CalculateCharacteristics | Calculates characteristics of the section.
CalculateMainAxisParams | Calculates the main axis of the section.
Clone | Creates a new object that is a copy of the current instance.
CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
GetContour | Gets the contour.
GetMaterialDependence | Gets the material dependence.

REXSectionParamDescription Properties