REXDFM.DisplayDefinition Class Legend
DisplayDefinition Methods
DisplayDefinition Methods | Description
Equals | Determines whether the specified T:System.Object is equal to the current T:System.Object.
ReadFromCategory | Reads the unit definition based on the category.
ReadFromCategory | Reads the unit definition based on the category.

REXDFM.DisplayDefinition Class Public Methods

REXDFM.DisplayDefinition Class Public Methods
REXDFM.DisplayDefinition Class Legend
Public Methods
Public Method | Description
DisplayDefinition | Initializes a new instance of the DisplayDefinition class.
DisplayDefinition | Initializes a new instance of the DisplayDefinition class.
DisplayDefinition | Initializes a new instance of the DisplayDefinition class.

Legend

Legend
REXDirectAccess Class
Legend
Method
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXDirectAccess Class Members

REXDirectAccess Class Members
REXDirectAccess Class Legend
Members
REXDirectAccess Methods
REXDirectAccess Methods | Description
PresetContext | Presets the context.

REXDirectAccess Methods

REXDirectAccess Methods
REXDirectAccess Class Legend
REXDirectAccess Methods
REXDirectAccess Methods | Description
PresetContext | Presets the context.

Legend

Legend
REXDirectRevitAccess Class
Legend
Method
static

REXDirectRevitAccess Class Members

REXDirectRevitAccess Class Members
REXDirectRevitAccess Class Legend
Members
REXDirectRevitAccess Methods
REXDirectRevitAccess Methods | Description
GetRevitSubName | Gets the name of the revit sub.
GetRevitSubName | Gets the name of the revit sub.
MapLanguageToCultureInfoName | This is MapLanguageToCultureInfoName, a member of class REXDirectRevitAccess.
PresetContext | Presets the context.

Members

Legend
Legend
Method
static

REXDirectRevitAccess Methods

REXDirectRevitAccess Methods
REXDirectRevitAccess Class Legend
REXDirectRevitAccess Methods
REXDirectRevitAccess Methods | Description
GetRevitSubName | Gets the name of the revit sub.
GetRevitSubName | Gets the name of the revit sub.
MapLanguageToCultureInfoName | This is MapLanguageToCultureInfoName, a member of class REXDirectRevitAccess.
PresetContext | Presets the context.

Methods (AutoDoc Folder)

Legend
Legend
Method
static

Legend

Legend
REXDirectRevitExecute Class
Legend
Constructor
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXDirectRevitExecute Class Members

REXDirectRevitExecute Class Members
REXDirectRevitExecute Class Legend
Members
Public Methods
Public Method | Description
REXDirectRevitExecute | This is REXDirectRevitExecute, a member of class REXDirectRevitExecute.
REXDirectRevitExecute Methods
REXDirectRevitExecute Methods | Description
Execute | This is Execute, a member of class REXDirectRevitExecute.
Execute | This is Execute, a member of class REXDirectRevitExecute.
Execute | This is Execute, a member of class REXDirectRevitExecute.
Execute | This is Execute, a member of class REXDirectRevitExecute.
Execute | This is Execute, a member of class REXDirectRevitExecute.

REXDirectRevitExecute Methods

REXDirectRevitExecute Methods
REXDirectRevitExecute Class Legend
REXDirectRevitExecute Methods
REXDirectRevitExecute Methods | Description
Execute | This is Execute, a member of class REXDirectRevitExecute.
Execute | This is Execute, a member of class REXDirectRevitExecute.
Execute | This is Execute, a member of class REXDirectRevitExecute.
Execute | This is Execute, a member of class REXDirectRevitExecute.
Execute | This is Execute, a member of class REXDirectRevitExecute.

REXDirectRevitExecute Class Public Methods

REXDirectRevitExecute Class Public Methods
REXDirectRevitExecute Class Legend
Public Methods
Public Method | Description
REXDirectRevitExecute | This is REXDirectRevitExecute, a member of class REXDirectRevitExecute.

REXErrors Enumerations

REXErrors Enumerations
REXErrors Class Legend
REXErrors Enumerations
REXErrors Enumerations | Description
ErrorCode | Standard REX error codes.

Legend

Legend
REXErrors Class
Legend
Enumeration
Method
static

REXErrors Class Members

REXErrors Class Members
REXErrors Class Legend
Members
REXErrors Enumerations
REXErrors Enumerations | Description
ErrorCode | Standard REX error codes.
REXErrors Methods
REXErrors Methods | Description
GetCategory | Returns category for specified error code.
GetMessage | Returns formated error string.

Members

Legend
Legend
Enumeration
Method
static

REXErrors Methods

REXErrors Methods
REXErrors Class Legend
REXErrors Methods
REXErrors Methods | Description
GetCategory | Returns category for specified error code.
GetMessage | Returns formated error string.

Legend

Legend
REXExtension Class
Legend
Constructor
virtual
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXExtension Class Members

REXExtension Class Members
REXExtension Class Legend
Members
Public Methods
Public Method | Description
REXExtension | Initializes a new instance of the REXExtension class.
REXExtension Methods
REXExtension Methods | Description
AddCommands | Adds the commands.
ApplyStyle | This is ApplyStyle, a member of class REXExtension.
ApplyStyle | This is ApplyStyle, a member of class REXExtension.
Close | Close extension with all needed actions.
Close | Close extension with all needed actions.
Close | Close extension with all needed actions.
Command | Commands the specified command struct.
Create | Creates this extension.
Event | Events the specified event struct.
GetAPI | Get reference to main API object.
GetCaption | Get standard caption.
GetCaption | Get standard caption with additional information.
GetControl | Get reference to main control.
GetData | Get the data structure.
GetForm | Get reference to main form.
GetIcon | Get reference to icon.
GetResults | Get the results structure.
GetREXEnvironment | Get the reference to REX environment object.
GetTopWindowForParent | This is GetTopWindowForParent, a member of class REXExtension.
GetTopWindowHandleForParent | This is GetTopWindowHandleForParent, a member of class REXExtension.
GetWindow | Get reference to main form.
GetWindowForParent | Get the window for parent.
GetWindowHandleForParent | Get the window for parent.
Initialize | Initializes this instance.
OnActivateLayout | Activates or deactivates layout - module can modify layout before or after activation.
OnCanActivateLayout | Called when [can activate layout].
OnCanClose | If returns true, dialog will close after OK button clicked.
OnCanClose | Called when closing module.
OnCanRun | Checks status of module and shows some information for user if module can't complete action.
OnCheckValidity | Called when check validity.
OnClear | Called when clear.
OnClose | Called during closing module.
OnCommand | Called when command.
OnCreate | Creates needed structures and verify needs.
OnCreateDialogs | Creates sub dialogs.
OnCreateLayout | Creates layout items and setups layout.
OnDataLoad | Called when data load.
OnDataLoaded | Called when data loaded.
OnDataSave | Called when data save.
OnDataSaved | Called when data saved.
OnErrorSelected | Called when error selected on errors list dialog.
OnEvent | Called when event.
OnGetExtensionName | Called when get extension name.
OnGetText | Get specified text from resources.
OnInitialize | Called when Initialize.
OnLoadJournalingData | Called when load journaling data.
OnLoadTemplate | Called when load template.
OnPreferencesChanged | Called when preferences changed.