RVTMaterialFactory.GetExistingNames Method

RVTMaterialFactory.GetExistingNames Method
RVTMaterialFactory Class REX.ContentGenerator.Converters Namespace RVTMaterialFactory Class

This is GetExistingNames, a member of class RVTMaterialFactory.

C#
public override List<string> GetExistingNames(REXFamilyType obj, bool type);
Class

RVTMaterialFactory Class

Links
RVTMaterialFactory Class, REX.ContentGenerator.Converters Namespace, RVTMaterialFactory Class

RVTMaterialFactory.GetMaterialTypeCompLevel Method

RVTMaterialFactory.GetMaterialTypeCompLevel Method
RVTMaterialFactory Class REX.ContentGenerator.Converters Namespace RVTMaterialFactory Class

This is GetMaterialTypeCompLevel, a member of class RVTMaterialFactory.

C#
public CompositeLevel GetMaterialTypeCompLevel(EMaterial mat);
Class

RVTMaterialFactory Class

Links
RVTMaterialFactory Class, REX.ContentGenerator.Converters Namespace, RVTMaterialFactory Class

RVTMaterialFactory.GetRevitTypesForInit Method

RVTMaterialFactory.GetRevitTypesForInit Method
RVTMaterialFactory Class REX.ContentGenerator.Converters Namespace RVTMaterialFactory Class

This is GetRevitTypesForInit, a member of class RVTMaterialFactory.

C#
public override Type[] GetRevitTypesForInit();
Class

RVTMaterialFactory Class

Links
RVTMaterialFactory Class, REX.ContentGenerator.Converters Namespace, RVTMaterialFactory Class

RVTMaterialFactory.InitList Method

RVTMaterialFactory.InitList Method
RVTMaterialFactory Class REX.ContentGenerator.Converters Namespace RVTMaterialFactory Class

This is InitList, a member of class RVTMaterialFactory.

C#
public override void InitList();
Class

RVTMaterialFactory Class

Links
RVTMaterialFactory Class, REX.ContentGenerator.Converters Namespace, RVTMaterialFactory Class

RVTMaterialFactory.OnClose Method

RVTMaterialFactory.OnClose Method
RVTMaterialFactory Class REX.ContentGenerator.Converters Namespace RVTMaterialFactory Class

This is OnClose, a member of class RVTMaterialFactory.

C#
public override bool OnClose();
Class

RVTMaterialFactory Class

Links
RVTMaterialFactory Class, REX.ContentGenerator.Converters Namespace, RVTMaterialFactory Class

RVTMaterialFactory.Recalculate Method

RVTMaterialFactory.Recalculate Method
RVTMaterialFactory Class REX.ContentGenerator.Converters Namespace RVTMaterialFactory Class

This is Recalculate, a member of class RVTMaterialFactory.

C#
public override REXDescription Recalculate(REXDescription DBdesc, bool fromInterface, ECategoryType category, bool create_new);
Class

RVTMaterialFactory Class

Links
RVTMaterialFactory Class, REX.ContentGenerator.Converters Namespace, RVTMaterialFactory Class

RVTMaterialFactory.ValidateElement Method

RVTMaterialFactory.ValidateElement Method
RVTMaterialFactory Class REX.ContentGenerator.Converters Namespace RVTMaterialFactory Class

This is ValidateElement, a member of class RVTMaterialFactory.

C#
public override bool ValidateElement(RevitElement el);
Class

RVTMaterialFactory Class

Links
RVTMaterialFactory Class, REX.ContentGenerator.Converters Namespace, RVTMaterialFactory Class

RVTMaterialPropertySetFactory Class

RVTMaterialPropertySetFactory Class
REX.ContentGenerator.Converters Namespace Legend Members Public Methods RVTMaterialPropertySetFactory Methods

This is class REX.ContentGenerator.Converters.RVTMaterialPropertySetFactory.

Class Hierarchy
C#
public class RVTMaterialPropertySetFactory : RVTFamilyFactory;
Namespace

REX.ContentGenerator.Converters Namespace

Public Methods
Public Method | Description
RVTMaterialPropertySetFactory | This is RVTMaterialPropertySetFactory, a member of class RVTMaterialPropertySetFactory.
RVTMaterialPropertySetFactory | This is RVTMaterialPropertySetFactory, a member of class RVTMaterialPropertySetFactory.
RVTMaterialPropertySetFactory Methods
RVTMaterialPropertySetFactory Methods | Description
AddElement2FamList | This is AddElement2FamList, a member of class RVTMaterialPropertySetFactory.
AddElement2FamList | This is AddElement2FamList, a member of class RVTMaterialPropertySetFactory.
CreateNewPropertySet | This is CreateNewPropertySet, a member of class RVTMaterialPropertySetFactory.
GetConcreteParameter | This is GetConcreteParameter, a member of class RVTMaterialPropertySetFactory.
GetExistingNames | This is GetExistingNames, a member of class RVTMaterialPropertySetFactory.
GetGenericParameter | This is GetGenericParameter, a member of class RVTMaterialPropertySetFactory.
GetMaterialParams | This is GetMaterialParams, a member of class RVTMaterialPropertySetFactory.
GetMaterialTypeCompLevel | This is GetMaterialTypeCompLevel, a member of class RVTMaterialPropertySetFactory.
GetParameter | This is GetParameter, a member of class RVTMaterialPropertySetFactory.
GetRevitTypesForInit | This is GetRevitTypesForInit, a member of class RVTMaterialPropertySetFactory.
GetSteelParameter | This is GetSteelParameter, a member of class RVTMaterialPropertySetFactory.
GetWoodParameter | This is GetWoodParameter, a member of class RVTMaterialPropertySetFactory.
InitList | This is InitList, a member of class RVTMaterialPropertySetFactory.
OnClose | This is OnClose, a member of class RVTMaterialPropertySetFactory.
Recalculate | This is Recalculate, a member of class RVTMaterialPropertySetFactory.
ValidateElement | This is ValidateElement, a member of class RVTMaterialPropertySetFactory.
Links
REX.ContentGenerator.Converters Namespace, Legend, Members, Public Methods, RVTMaterialPropertySetFactory Methods

RVTMaterialPropertySetFactory.RVTMaterialPropertySetFactory Constructor ()

RVTMaterialPropertySetFactory.RVTMaterialPropertySetFactory Constructor ()
RVTMaterialPropertySetFactory Class REX.ContentGenerator.Converters Namespace RVTMaterialPropertySetFactory Class

This is RVTMaterialPropertySetFactory, a member of class RVTMaterialPropertySetFactory.

C#
public RVTMaterialPropertySetFactory();
Class

RVTMaterialPropertySetFactory Class

Links
RVTMaterialPropertySetFactory Class, REX.ContentGenerator.Converters Namespace, RVTMaterialPropertySetFactory Class

RVTMaterialPropertySetFactory.RVTMaterialPropertySetFactory Constructor (RvtConversionSettings)

RVTMaterialPropertySetFactory.RVTMaterialPropertySetFactory Constructor (RvtConversionSettings)
RVTMaterialPropertySetFactory Class REX.ContentGenerator.Converters Namespace RVTMaterialPropertySetFactory Class

This is RVTMaterialPropertySetFactory, a member of class RVTMaterialPropertySetFactory.

C#
public RVTMaterialPropertySetFactory(RvtConversionSettings Settings);
Class

RVTMaterialPropertySetFactory Class

Links
RVTMaterialPropertySetFactory Class, REX.ContentGenerator.Converters Namespace, RVTMaterialPropertySetFactory Class

RVTMaterialPropertySetFactory.AddElement2FamList Method (Autodesk.Revit.DB.Element)

RVTMaterialPropertySetFactory.AddElement2FamList Method (Autodesk.Revit.DB.Element)
RVTMaterialPropertySetFactory Class REX.ContentGenerator.Converters Namespace RVTMaterialPropertySetFactory Class

This is AddElement2FamList, a member of class RVTMaterialPropertySetFactory.

C#
public override bool AddElement2FamList(Autodesk.Revit.DB.Element el);
Class

RVTMaterialPropertySetFactory Class

Links
RVTMaterialPropertySetFactory Class, REX.ContentGenerator.Converters Namespace, RVTMaterialPropertySetFactory Class

RVTMaterialPropertySetFactory.AddElement2FamList Method (Autodesk.Revit.DB.Element, REXFamilyType, bool)

RVTMaterialPropertySetFactory.AddElement2FamList Method (Autodesk.Revit.DB.Element, REXFamilyType, bool)
RVTMaterialPropertySetFactory Class REX.ContentGenerator.Converters Namespace RVTMaterialPropertySetFactory Class

This is AddElement2FamList, a member of class RVTMaterialPropertySetFactory.

C#
public override bool AddElement2FamList(Autodesk.Revit.DB.Element el, REXFamilyType ft, bool addToDict);
Class

RVTMaterialPropertySetFactory Class

Links
RVTMaterialPropertySetFactory Class, REX.ContentGenerator.Converters Namespace, RVTMaterialPropertySetFactory Class