Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

IRvtContentSettings Interface Members

IRvtContentSettings Interface Members
IRvtContentSettings Interface Legend
Members
IRvtContentSettings Methods
IRvtContentSettings Methods | Description
Clean | Cleans temporary files.
LoadCustomParametersFile | Loads the custom parameters file.
SetLanguage | Sets the language for created families (names of families will be translated according to this) - “en-US”, “pl-PL” etc.
IRvtContentSettings Properties
IRvtContentSettings Properties | Description
BufferElements | Gets or sets a value indicating whether elements should be buffered after investigation – using RevitId.
CreateNewElement | Gets or sets a value indicating whether a new family should be created if the element wasn’t found among existing ones.
IgnoreFamilyNameLanguage | Gets or sets a value indicating whether language should be taken to consideration during element search (language set by SetLanguage function).
Labels | Gets or sets a value indicating whether labels should be taken to consideration during mapping.
RebarPostGenerateCorrection | Gets or sets a value indicating whether correction of rebar geometry should be made after generation process.
SupportUserDatabases | Gets or sets a value indicating whether users databases should be supported
Update | Gets or sets a value indicating whether element found in the project (if it already exists) should be updated with new data.

IRvtContentSettings Methods

IRvtContentSettings Methods
IRvtContentSettings Interface Legend
IRvtContentSettings Methods
IRvtContentSettings Methods | Description
Clean | Cleans temporary files.
LoadCustomParametersFile | Loads the custom parameters file.
SetLanguage | Sets the language for created families (names of families will be translated according to this) - “en-US”, “pl-PL” etc.

IRvtContentSettings Properties

IRvtContentSettings Properties
IRvtContentSettings Interface Legend
IRvtContentSettings Properties
IRvtContentSettings Properties | Description
BufferElements | Gets or sets a value indicating whether elements should be buffered after investigation – using RevitId.
CreateNewElement | Gets or sets a value indicating whether a new family should be created if the element wasn’t found among existing ones.
IgnoreFamilyNameLanguage | Gets or sets a value indicating whether language should be taken to consideration during element search (language set by SetLanguage function).
Labels | Gets or sets a value indicating whether labels should be taken to consideration during mapping.
RebarPostGenerateCorrection | Gets or sets a value indicating whether correction of rebar geometry should be made after generation process.
SupportUserDatabases | Gets or sets a value indicating whether users databases should be supported
Update | Gets or sets a value indicating whether element found in the project (if it already exists) should be updated with new data.

REXContentLogicFilter Enumerations

REXContentLogicFilter Enumerations
REXContentLogicFilter Class Legend
REXContentLogicFilter Enumerations
REXContentLogicFilter Enumerations | Description
ELogicOperator | Describes operators.

Legend

Legend
REXContentLogicFilter Class
Legend
Constructor
Enumeration
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXContentLogicFilter Class Members

REXContentLogicFilter Class Members
REXContentLogicFilter Class Legend
Members
Public Methods
Public Method | Description
REXContentLogicFilter | Initializes a new instance of the REXContentLogicFilter class.
REXContentLogicFilter | Initializes a new instance of the REXContentLogicFilter class.
REXContentLogicFilter Enumerations
REXContentLogicFilter Enumerations | Description
ELogicOperator | Describes operators.
REXContentLogicFilter Properties
REXContentLogicFilter Properties | Description
Filters | Gets or sets the filters.
LogicOperator | Gets or sets the logic operator.

REXContentLogicFilter Properties

REXContentLogicFilter Properties
REXContentLogicFilter Class Legend
REXContentLogicFilter Properties
REXContentLogicFilter Properties | Description
Filters | Gets or sets the filters.
LogicOperator | Gets or sets the logic operator.

REXContentLogicFilter Class Public Methods

REXContentLogicFilter Class Public Methods
REXContentLogicFilter Class Legend
Public Methods
Public Method | Description
REXContentLogicFilter | Initializes a new instance of the REXContentLogicFilter class.
REXContentLogicFilter | Initializes a new instance of the REXContentLogicFilter class.

Legend

Legend
REXContentParamFilter Class
Legend
Constructor
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXContentParamFilter Class Members

REXContentParamFilter Class Members
REXContentParamFilter Class Legend
Members
Public Methods
Public Method | Description
REXContentParamFilter | Initializes a new instance of the REXContentParamFilter class.
REXContentParamFilter | Initializes a new instance of the REXContentParamFilter class.
REXContentParamFilter | Initializes a new instance of the REXContentParamFilter class.
REXContentParamFilter Methods
REXContentParamFilter Methods | Description
Validate | Validates the specified value due to the current filter's parameters.
REXContentParamFilter Properties
REXContentParamFilter Properties | Description
ConstraintValue | Gets or sets the constraint value.
Equal | Gets or sets a value indicating whether a parameter is to be equal to the constraint value.
Less | Gets or sets a value indicating whether a parameter is to be smaller then the constraint value.
More | Gets or sets a value indicating whether a parameter is to be larger then the constraint value.
ParamName | Gets or sets the name of the parameter which is constrained.

REXContentParamFilter Methods

REXContentParamFilter Methods
REXContentParamFilter Class Legend
REXContentParamFilter Methods
REXContentParamFilter Methods | Description
Validate | Validates the specified value due to the current filter's parameters.

REXContentParamFilter Properties

REXContentParamFilter Properties
REXContentParamFilter Class Legend
REXContentParamFilter Properties
REXContentParamFilter Properties | Description
ConstraintValue | Gets or sets the constraint value.
Equal | Gets or sets a value indicating whether a parameter is to be equal to the constraint value.
Less | Gets or sets a value indicating whether a parameter is to be smaller then the constraint value.
More | Gets or sets a value indicating whether a parameter is to be larger then the constraint value.
ParamName | Gets or sets the name of the parameter which is constrained.

REXContentParamFilter Class Public Methods

REXContentParamFilter Class Public Methods
REXContentParamFilter Class Legend
Public Methods
Public Method | Description
REXContentParamFilter | Initializes a new instance of the REXContentParamFilter class.
REXContentParamFilter | Initializes a new instance of the REXContentParamFilter class.
REXContentParamFilter | Initializes a new instance of the REXContentParamFilter class.

Legend

Legend
REXCustomFactory Class
Legend
Constructor
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.

REXCustomFactory Class Members

REXCustomFactory Class Members
REXCustomFactory Class Legend
Members
Public Methods
Public Method | Description