List<REXDBDescription> dbList = rex.GetDBList(fam, databases, directory, ECategoryType.SECTION_DB);
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, REXFamilyConverter Class

REXFamilyConverter.GetDBList Method (REXFamilyType, string, ECategoryType)

REXFamilyConverter.GetDBList Method (REXFamilyType, string, ECategoryType)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace Example REXFamilyConverter Class

Gets the list of database's records adequate for the input object.

C#
public List<REXDBDescription> GetDBList(REXFamilyType obj, string dir, ECategoryType type);
Parameters
Parameters | Description
obj | The REXFamilyType object (should be dedicated for the specific category).
dir | The directory.
type | The category of the element.
Returns

Returns the list of database's records.

Description
Example

The example shows how to get a list of records which exist in databases of the specific directory and fit to the specific element.

//Initializing the rex converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Definition of the element. In the current example it is created as the empty family with the alias name but it can be taken from different sources (e.g. Revit).
REXFamilyType fam = rex.GetEmptyFamilyOfAlias(REX.ContentGenerator.Families.EElementType.BEAM, "HEB 100", ECategoryType.SECTION_DB);

//Database identification data.
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Prof";

//Getting the list of databases
List<REXDBDescription> dbList = rex.GetDBList(fam, directory, ECategoryType.SECTION_DB);
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, REXFamilyConverter Class

REXFamilyConverter.GetDBList Method (REXFamilyType, string, string, ECategoryType)

REXFamilyConverter.GetDBList Method (REXFamilyType, string, string, ECategoryType)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace Example REXFamilyConverter Class

Gets the list of database's records adequate for the input object.

C#
public List<REXDBDescription> GetDBList(REXFamilyType obj, string dbName, string dir, ECategoryType type);
Parameters
Parameters | Description
obj | The REXFamilyType object (should be dedicated for the specific category).
dbName | The database's name.
dir | The directory.
type | The category of the element.
Returns

Returns the list of database's records.

Description
Example

The example shows how to get a list of records which exist in the Rcatpro database and fit to the specific element.

//Initializing the rex converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Definition of the element. In the current example it is created as the empty family with the alias name but it can be taken from different sources (e.g. Revit).        ///
REXFamilyType fam = rex.GetEmptyFamilyOfAlias(REX.ContentGenerator.Families.EElementType.BEAM, "HEB 100", ECategoryType.SECTION_DB);

//Database identification data.
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Prof";
string dbName = "Rcatpro";

//Getting the list of databases
List<REXDBDescription> dbList = rex.GetDBList(fam, dbName, directory, ECategoryType.SECTION_DB);
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, REXFamilyConverter Class

REXFamilyConverter.GetDBList Method (REXFamilyType_Custom, List<string>, string, string)

REXFamilyConverter.GetDBList Method (REXFamilyType_Custom, List<string>, string, string)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace REXFamilyConverter Class

Gets the list of database's records adequate for the input object.

C#
public List<REXDBDescription> GetDBList(REXFamilyType_Custom obj, List<string> dbNames, string dir, string customCategory);
Parameters
Parameters | Description
obj | The REXFamilyType object (the external class has to be provided).
dbNames | The list of database names(xml files).
dir | The directory.
customCategory | The custom category.
Returns

Returns the list of database's records.

Description
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, REXFamilyConverter Class

REXFamilyConverter.GetDBList Method (REXFamilyType_Custom, string, string)

REXFamilyConverter.GetDBList Method (REXFamilyType_Custom, string, string)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace REXFamilyConverter Class

Gets the list of database's records adequate for the input object.

C#
public List<REXDBDescription> GetDBList(REXFamilyType_Custom obj, string dir, string customCategory);
Parameters
Parameters | Description
obj | The REXFamilyType object (the external class has to be provided).
dir | The directory.
customCategory | The custom category.
Returns

Returns the list of database's records.

Description
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, REXFamilyConverter Class

REXFamilyConverter.GetDBList Method (REXFamilyType_Custom, string, string, string)

REXFamilyConverter.GetDBList Method (REXFamilyType_Custom, string, string, string)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace REXFamilyConverter Class

Gets the list of database's records adequate for the input object.

C#
public List<REXDBDescription> GetDBList(REXFamilyType_Custom obj, string dbName, string dir, string customCategory);
Parameters
Parameters | Description
obj | The REXFamilyType object (the external class has to be provided).
dbName | The name of the database (xml file).
dir | The directory.
customCategory | The custom category.
Returns

Returns the list of database's records.

Description
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, REXFamilyConverter Class

REXFamilyConverter.GetDbProperty Method

REXFamilyConverter.GetDbProperty Method
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace REXFamilyConverter Class

Gets the property of specific name for the database.

C#
public virtual object GetDbProperty(ECategoryType type, string dir, string dbName, string name);
Parameters
Parameters | Description
type | The category of database.
dir | The directory.
dbName | The database's name.
name | The name of the property
Returns

Returns the property value.

Description
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, REXFamilyConverter Class

REXFamilyConverter.GetEmptyFamilyOfAlias Method

REXFamilyConverter.GetEmptyFamilyOfAlias Method
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace REXFamilyConverter Class

Gets the empty family of alias name.

C#
public REXFamilyType GetEmptyFamilyOfAlias(REX.ContentGenerator.Families.EElementType el, string alias, ECategoryType type);
Parameters
Parameters | Description
el | The element type.
alias | The alias.
type | The category of the element.
Returns

Returns the REXFamilyType object.

Description
Remarks

It doesn't have any data inside despite indentification and it can be used to take proper data from the database.

Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, REXFamilyConverter Class

REXFamilyConverter.GetFamilies Method (string, ECategoryType)

REXFamilyConverter.GetFamilies Method (string, ECategoryType)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace Example REXFamilyConverter Class

Gets the list of all elements in the selected database.

C#
public List<REXFamilyType> GetFamilies(string path, ECategoryType type);
Parameters
Parameters | Description
path | The path.
type | The category of the element.
Returns

Returns the list of REXFamilyTypes.

Description