Example

The example shows how to get all sections from the Rcatptro database.

//Initializing the rex converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Database identification data.
string path = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Prof\Rcatpro.xml";

//Getting the REXFamilyType from the database.
List<REXFamilyType> families = rex.GetFamilies(path, ECategoryType.SECTION_DB);
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, REXFamilyConverter Class

REXFamilyConverter.GetFamilies Method (string, string)

REXFamilyConverter.GetFamilies Method (string, string)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace REXFamilyConverter Class

Gets the list of all elements in the selected database.

C#
public List<REXFamilyType> GetFamilies(string path, string customCategory);
Parameters
Parameters | Description
path | The path.
customCategory | The custom category.
Returns

The list of REXFamilyTypes

Description
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, REXFamilyConverter Class

REXFamilyConverter.GetFamilies Method (string, string, ECategoryType)

REXFamilyConverter.GetFamilies Method (string, string, ECategoryType)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace Example REXFamilyConverter Class

Gets the list of all elements in selected database.

C#
public List<REXFamilyType> GetFamilies(string dir, string dbName, ECategoryType type);
Parameters
Parameters | Description
dir | The directory.
dbName | The database.
type | The category of the element.
Returns

Returns the list of REXFamilyTypes.

Description
Example

The example shows how to get all sections from the Rcatptro database.

//Initializing the rex converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Database identification data.
string database = "Rcatpro";
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Prof";

//Getting the REXFamilyType from the database.
List<REXFamilyType> families = rex.GetFamilies(directory, database, ECategoryType.SECTION_DB);
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, REXFamilyConverter Class

REXFamilyConverter.GetFamilies Method (string, string, string)

REXFamilyConverter.GetFamilies Method (string, string, string)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace REXFamilyConverter Class

Gets the list of all elements in selected database.

C#
public List<REXFamilyType> GetFamilies(string dir, string dbName, string customCategory);
Parameters
Parameters | Description
dir | The directory.
dbName | The database.
customCategory | The custom category.
Returns

Returns the list of REXFamilyTypes.

Description
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, REXFamilyConverter Class

REXFamilyConverter.GetFamily Method (REXDBDescription, ECategoryType)

REXFamilyConverter.GetFamily Method (REXDBDescription, ECategoryType)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace Example REXFamilyConverter Class

Gets the REXFamilyType object based on specific database's record.

C#
public REXFamilyType GetFamily(REXDBDescription dbDesc, ECategoryType type);
Parameters
Parameters | Description
dbDesc | The database description.
type | The category of the element.
Returns

Returns the REXFamilyType object.

Description
Example

The example shows how to get the„HEA 100” section from the Rcatptro database.

//Initializing the rex converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Creating the database description for the database query.
REXSectionDBDescription dbdesc = new REXSectionDBDescription("Rcatpro");
dbdesc.Directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Prof";
dbdesc.Description.NAME = "HEA";
dbdesc.Description.DIM1 = 100;
dbdesc.Description.DIM2 = 0;
dbdesc.Description.DIM3 = 0;

//Getting the REXFamilyType from the database.
REXFamilyType fam = rex.GetFamily(dbdesc, ECategoryType.SECTION_DB);
REXFamilyType_DBSection famDBSection = fam as REXFamilyType_DBSection;
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, REXFamilyConverter Class

REXFamilyConverter.GetFamily Method (REXDBDescription, REX.ContentGenerator.Families.EElementType, EMaterial, ECategoryType)

REXFamilyConverter.GetFamily Method (REXDBDescription, REX.ContentGenerator.Families.EElementType, EMaterial, ECategoryType)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace Example REXFamilyConverter Class

Gets the REXFamilyType object based on specific database's record.

C#
public REXFamilyType GetFamily(REXDBDescription dbDesc, REX.ContentGenerator.Families.EElementType el, EMaterial mat, ECategoryType type);
Parameters
Parameters | Description
dbDesc | The database description.
el | The element type.
mat | The material.
type | The category of the element.
Returns

Returns the REXFamilyType object.

Description
Example

The example shows how to get the„HEA 100” section from the Rcatptro database.

//Initializing the rex converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Creating the database description for the database query.
REXSectionDBDescription dbdesc = new REXSectionDBDescription("Rcatpro");
dbdesc.Directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Prof";
dbdesc.Description.NAME = "HEA";
dbdesc.Description.DIM1 = 100;
dbdesc.Description.DIM2 = 0;
dbdesc.Description.DIM3 = 0;

//Getting the REXFamilyType from the database.
REXFamilyType fam = rex.GetFamily(dbdesc, REX.ContentGenerator.Families.EElementType.BEAM, EMaterial.STEEL, ECategoryType.SECTION_DB);
REXFamilyType_DBSection famDBSection = fam as REXFamilyType_DBSection;
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, REXFamilyConverter Class

REXFamilyConverter.GetFamily Method (REXDBDescription, REX.ContentGenerator.Families.EElementType, EMaterial, string)

REXFamilyConverter.GetFamily Method (REXDBDescription, REX.ContentGenerator.Families.EElementType, EMaterial, string)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace REXFamilyConverter Class

Gets the REXFamilyType object based on specific database's record.

C#
public REXFamilyType GetFamily(REXDBDescription dbDesc, REX.ContentGenerator.Families.EElementType el, EMaterial mat, string customCategory);
Parameters
Parameters | Description
dbDesc | The database description.
el | The element type.
mat | The material.
customCategory | The custom category.
Returns

Returns the REXFamilyType object.

Description
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, REXFamilyConverter Class

REXFamilyConverter.GetFamily Method (REXDBDescription, string)

REXFamilyConverter.GetFamily Method (REXDBDescription, string)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace REXFamilyConverter Class

Gets the REXFamilyType object based on the specified database's record.

C#
public REXFamilyType GetFamily(REXDBDescription dbDesc, string customCategory);
Parameters
Parameters | Description
dbDesc | The database description.
customCategory | The custom category.
Returns

Returns the REXFamilyType object.

Description
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, REXFamilyConverter Class

REXFamilyConverter.GetFamilyDBSection Method (REX.ContentGenerator.Families.EElementType, EMaterial, string)