REX.Common Namespace

Revit Extensions API 2018
Next
REX.Common Namespace
Legend Classes Interfaces Structs, Records, Enums

This is namespace REX.Common.

Classes
Class | Description
REXAccess | The class dedicated to settings data from parent application.
REXApplication | Base class for Application.This object controls the lifetime of the extensions.
REXDFM | Manages UI controls registered in it.
REXDirectAccess | Base class for main DirectAccess class.
REXDirectRevitAccess | Base class for main DirectAccess class.
REXDirectRevitExecute | This is class REX.Common.REXDirectRevitExecute.
REXErrors | Supprots REX errors for logging system.
REXExtension | Additional functionality of REXExtension class.
REXExtensionContext | Internal class for controlling behavior of the extension.
REXExtensionControl | Base class for user controls.
REXExtensionData | Base class for REXData and REXResults classes.
REXExtensionDataSerializable | Base class for REXDataSerializable and REXResultsSerializable classes.
REXExtensionMainControl | Base class for main control.
REXExtensionObject | Base class for all objects created in extension module.
REXExtensionPanel | Base class for panel control.
REXExtensionProduct | Represents the Extension element used by the main Extension class to separate product dependent part of the code from general one.
REXExtensionSettings | Allows reading base settings from "Configuration / settings.xml" file.
REXExtensionWindow | Base class for user forms.
REXFoundationApplication | Foundation class for REX.Foundation usage.
REXLayout |
REXLayoutItem | Represents all layout of main control.
REXLogger | This is class REX.Common.REXLogger.
REXResults | Base class for results.
REXRevitAccess | The class dedicated to settings data from Revit.
REXRevitContextAccess | Allaws for access to Revit's objects.
REXUI | Main class which provides access to all data connected with main control.
REXVersion | Foundation class for REX.Foundation usage.
REXWarnings | This is class REX.Common.REXWarnings.
REXWebBrowser | Proxy class for web browser control.
Interfaces
Interface | Description
IREXConnector | This is class REX.Common.IREXConnector.
IREXExtension | Main interface for extension module.
IREXExtension2 | Main interface for extension module.
IREXExtension3 | Main interface for extension module.
IREXExtension4 | Main interface for extension module.
IREXExtensionAccess | Main interface for REXAccess class.
IREXExtensionAccess2 | Main interface for REXAccess class.
IREXExtensionAccess3 | Main interface for REXAccess class.
IREXExtensionAccessUnitsControl | Main interface for REXAccess class.
IREXThisExtension | Base interface for access to main extension's objects.
Structs, Records, Enums
Struct, Record, Enum | Description
REXCanCloseType | Determines closing mode.
REXSetFormStruct | This is record REX.Common.REXSetFormStruct.
Links
Legend, Classes, Interfaces, Structs, Records, Enums
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.
Copyright (c) 2015. All rights reserved.


REXAccess Class

Previous | Up | Next
REXAccess Class
REX.Common Namespace Legend Members Public Methods REXAccess Enumerations REXAccess Methods REXAccess Properties

The class dedicated to settings data from parent application.

Class Hierarchy
C#
public class REXAccess : IREXExtensionAccess3;
Description

Called internally from base SDK's classes.

Namespace

REX.Common Namespace

Public Methods
Public Method | Description
REXAccess | Initializes a new instance of the REXAccess class.
REXAccess Enumerations
REXAccess Enumerations | Description
REXAccessEvent |
REXAccess Methods
REXAccess Methods | Description
Access | This is Access, a member of class REXAccess.
Create | Reads some data from parent application and set system display units.
Destroy | Destroys and reset some objects connected to parent application.
Detach | Detaches this instance.
Event | Events the specified event.
Initialize | Initializes this instance.
Update | Reads some data from parent application and set system display units.
REXAccess Properties
REXAccess Properties | Description
Interfaces | This is Interfaces, a member of class REXAccess.
Links
REX.Common Namespace, Legend, Members, Public Methods, REXAccess Enumerations, REXAccess Methods, REXAccess Properties
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.
Copyright (c) 2015. All rights reserved.
Home


REXAccess.REXAccess Constructor

REXAccess.REXAccess Constructor
REXAccess Class REX.Common Namespace REXAccess Class

Initializes a new instance of the REXAccess class.

C#
public REXAccess(REXApplication App);
Parameters
Parameters | Description
App | The reference to REXApplication object.
Description
Class

REXAccess Class

Links
REXAccess Class, REX.Common Namespace, REXAccess Class
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REX.Common.REXAccess.REXAccessEvent Enumeration

REX.Common.REXAccess.REXAccessEvent Enumeration
REXAccess Class
C#
public enum REXAccessEvent {
  LoadRegionalSettings,
  SaveRegionalSettings,
  LoadJournalingData,
  SaveJournalingData
}
Class

REXAccess Class

Links
REXAccess Class
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXAccess.Access Method

REXAccess.Access Method
REXAccess Class REX.Common Namespace REXAccess Class

This is Access, a member of class REXAccess.

C#
public IREXExtensionAccess Access(string Interface);
Class

REXAccess Class

Links
REXAccess Class, REX.Common Namespace, REXAccess Class


REXAccess.Create Method

REXAccess.Create Method
REXAccess Class REX.Common Namespace REXAccess Class

Reads some data from parent application and set system display units.

C#
public bool Create();
Returns

Returns true if succeeded.

Description
Class

REXAccess Class

Links
REXAccess Class, REX.Common Namespace, REXAccess Class


REXAccess.Destroy Method

REXAccess.Destroy Method
REXAccess Class REX.Common Namespace REXAccess Class

Destroys and reset some objects connected to parent application.

C#
public bool Destroy();
Returns

Returns true if succeeded.

Description
Class

REXAccess Class

Links
REXAccess Class, REX.Common Namespace, REXAccess Class


REXAccess.Detach Method

REXAccess.Detach Method
REXAccess Class REX.Common Namespace REXAccess Class

Detaches this instance.

C#
public void Detach();
Description
Class

REXAccess Class

Links
REXAccess Class, REX.Common Namespace, REXAccess Class


REXAccess.Event Method

REXAccess.Event Method
REXAccess Class REX.Common Namespace REXAccess Class

Events the specified event.

C#
public bool Event(REXAccessEvent Ev);
Parameters
Parameters | Description
Ev | The event.
Description
Class

REXAccess Class

Links
REXAccess Class, REX.Common Namespace, REXAccess Class


REXAccess.Initialize Method

REXAccess.Initialize Method
REXAccess Class REX.Common Namespace REXAccess Class

Initializes this instance.

C#
public void Initialize();
Description

Nostly sets language from parent application.

Class

REXAccess Class

Links
REXAccess Class, REX.Common Namespace, REXAccess Class


REXAccess.Update Method

REXAccess.Update Method
REXAccess Class REX.Common Namespace REXAccess Class

Reads some data from parent application and set system display units.

C#
public void Update();
Description
Class

REXAccess Class

Links
REXAccess Class, REX.Common Namespace, REXAccess Class


REXAccess.Interfaces Property

REXAccess.Interfaces Property
REXAccess Class REX.Common Namespace REXAccess Class

This is Interfaces, a member of class REXAccess.

C#
public Dictionary<string, IREXExtensionAccess> Interfaces;
Class

REXAccess Class

Links
REXAccess Class, REX.Common Namespace, REXAccess Class


REXApplication Class

REXApplication Class
REX.Common Namespace Legend Members Public Methods REXApplication Methods REXApplication Properties

Base class for Application.This object controls the lifetime of the extensions.

Class Hierarchy
C#
public abstract class REXApplication : IREXApplication4, IREXThisExtension;
Description
Namespace

REX.Common Namespace

Public Methods
Public Method | Description
REXApplication | Initializes a new instance of a REXApplication class.
REXApplication Methods
REXApplication Methods | Description
CheckValidity | Checks the date limit.
Close | Closes this instance.
Command | Called when command.
Control | Get main control for embeding in a application form.
Create | Create module.
Create | Create module.
Event | Called when event.
GetExtension | Get the extension.
GetService | This is GetService, a member of class REXApplication.
GetText | Gets the text.
GetUniqueId | This is GetUniqueId, a member of class REXApplication.
GetVersion | Gets the minimum required version of specified engine's component.
Modal | Creates and shows module as modal dialog.
Modal | Creates and shows module as a modal dialog.
OnCreate | Called when create application object.
RestoreCultureInfo | Restores the culture info.
Show | Shows this module.
REXApplication Properties
REXApplication Properties | Description
Context | Get the reference to the old context.
Context2 | Get the context2.
ContextProduct | Get the context product from the old context structure.
ContextProduct2 | Get the context product2.
ThisApplication | This is ThisApplication, a member of class REXApplication.
ThisContext | This is ThisContext, a member of class REXApplication.
ThisExtension | This is ThisExtension, a member of class REXApplication.
Visible | Get or set a value indicating whether this REXApplication is visible.
Links
REX.Common Namespace, Legend, Members, Public Methods, REXApplication Methods, REXApplication Properties


REXApplication.REXApplication Constructor

REXApplication.REXApplication Constructor
REXApplication Class REX.Common Namespace REXApplication Class

Initializes a new instance of a REXApplication class.

C#
public REXApplication();
Description
Class

REXApplication Class

Links
REXApplication Class, REX.Common Namespace, REXApplication Class


REXApplication.CheckValidity Method

REXApplication.CheckValidity Method
REXApplication Class REX.Common Namespace REXApplication Class

Checks the date limit.

C#
public virtual bool CheckValidity();
Description
Class

REXApplication Class

Links
REXApplication Class, REX.Common Namespace, REXApplication Class


REXApplication.Close Method

REXApplication.Close Method
REXApplication Class REX.Common Namespace REXApplication Class

Closes this instance.

C#
public virtual void Close();
Description
Class

REXApplication Class

Links
REXApplication Class, REX.Common Namespace, REXApplication Class


REXApplication.Command Method

REXApplication.Command Method
REXApplication Class REX.Common Namespace REXApplication Class

Called when command.

C#
public virtual object Command(ref REXCommand CommandStruct);
Parameters
Parameters | Description
CommandStruct | The command structure.
Returns

Returns result of command operation.

Description
Class

REXApplication Class

Links
REXApplication Class, REX.Common Namespace, REXApplication Class


REXApplication.Control Method

REXApplication.Control Method
REXApplication Class REX.Common Namespace REXApplication Class

Get main control for embeding in a application form.

C#
public virtual object Control();
Returns

Returns reference to MainControl.

Description
Class

REXApplication Class

Links
REXApplication Class, REX.Common Namespace, REXApplication Class


REXApplication.Create Method (REXApplicationContext)

REXApplication.Create Method (REXApplicationContext)
REXApplication Class REX.Common Namespace REXApplication Class

Create module.

C#
public bool Create(ref REXApplicationContext AppContext);
Parameters
Parameters | Description
AppContext | The application context.
Returns

Returns true if succeeded.

Description
Class

REXApplication Class

Links
REXApplication Class, REX.Common Namespace, REXApplication Class


REXApplication.Create Method (REXContext)

REXApplication.Create Method (REXContext)
REXApplication Class REX.Common Namespace REXApplication Class

Create module.

C#
public bool Create(REXContext AppContext);
Parameters
Parameters | Description
AppContext | The application context.
Returns

Returns true if succeeded.

Description
Class

REXApplication Class

Links
REXApplication Class, REX.Common Namespace, REXApplication Class


REXApplication.Event Method

REXApplication.Event Method
REXApplication Class REX.Common Namespace REXApplication Class

Called when event.

C#
public virtual object Event(ref REXEvent EventStruct);
Parameters
Parameters | Description
EventStruct | The event structure.
Returns

Returns result of event operation.

Description
Class

REXApplication Class

Links
REXApplication Class, REX.Common Namespace, REXApplication Class


REXApplication.GetExtension Method

REXApplication.GetExtension Method
REXApplication Class REX.Common Namespace REXApplication Class

Get the extension.

C#
public virtual REXExtension GetExtension();
Returns

Returns reference to an extension object.

Description
Class

REXApplication Class

Links
REXApplication Class, REX.Common Namespace, REXApplication Class


REXApplication.GetService Method

REXApplication.GetService Method
REXApplication Class REX.Common Namespace REXApplication Class

This is GetService, a member of class REXApplication.

C#
public virtual object GetService();
Class

REXApplication Class

Links
REXApplication Class, REX.Common Namespace, REXApplication Class


REXApplication.GetText Method

REXApplication.GetText Method
REXApplication Class REX.Common Namespace REXApplication Class

Gets the text.

C#
public string GetText(string Name);
Parameters
Parameters | Description
Name | The name.
Returns

Returns specified text.

Description

See Extension.GetText() method.

Class

REXApplication Class

Links
REXApplication Class, REX.Common Namespace, REXApplication Class


REXApplication.GetUniqueId Method

REXApplication.GetUniqueId Method
REXApplication Class REX.Common Namespace REXApplication Class

This is GetUniqueId, a member of class REXApplication.

C#
public virtual Guid GetUniqueId();
Class

REXApplication Class

Links
REXApplication Class, REX.Common Namespace, REXApplication Class


REXApplication.GetVersion Method

REXApplication.GetVersion Method
REXApplication Class REX.Common Namespace REXApplication Class

Gets the minimum required version of specified engine's component.

C#
public string GetVersion(REXVersionType Version);
Parameters
Parameters | Description
Version | The version.
Returns

Returns version string - "Major.Minor".

Description
Class

REXApplication Class

Links
REXApplication Class, REX.Common Namespace, REXApplication Class


REXApplication.Modal Method (REXApplicationContext)

REXApplication.Modal Method (REXApplicationContext)
REXApplication Class REX.Common Namespace REXApplication Class

Creates and shows module as modal dialog.

C#
public bool Modal(ref REXApplicationContext AppContext);
Parameters
Parameters | Description
AppContext | The application context.
Returns

Returns true if suceeded.

Description
Class

REXApplication Class

Links
REXApplication Class, REX.Common Namespace, REXApplication Class


REXApplication.Modal Method (REXContext)

REXApplication.Modal Method (REXContext)
REXApplication Class REX.Common Namespace REXApplication Class

Creates and shows module as a modal dialog.

C#
public bool Modal(REXContext AppContext);
Parameters
Parameters | Description
AppContext | The application context.
Returns

Returns true if succeeded.

Description
Class

REXApplication Class

Links
REXApplication Class, REX.Common Namespace, REXApplication Class


REXApplication.OnCreate Method

REXApplication.OnCreate Method
REXApplication Class REX.Common Namespace REXApplication Class

Called when create application object.

C#
public virtual bool OnCreate();
Returns

Returns true if succeeded.

Description
Class

REXApplication Class

Links
REXApplication Class, REX.Common Namespace, REXApplication Class


REXApplication.RestoreCultureInfo Method

REXApplication.RestoreCultureInfo Method
REXApplication Class REX.Common Namespace REXApplication Class

Restores the culture info.

C#
public void RestoreCultureInfo();
Description
Class

REXApplication Class

Links
REXApplication Class, REX.Common Namespace, REXApplication Class


REXApplication.Show Method

REXApplication.Show Method
REXApplication Class REX.Common Namespace REXApplication Class

Shows this module.

C#
public virtual bool Show();
Returns

Returns true if succeeded.

Description
Class

REXApplication Class

Links
REXApplication Class, REX.Common Namespace, REXApplication Class


REXApplication.Context Property

REXApplication.Context Property
REXApplication Class REX.Common Namespace REXApplication Class

Get the reference to the old context.

C#
public REXApplicationContext Context;
Description

The context.

Class

REXApplication Class

Links
REXApplication Class, REX.Common Namespace, REXApplication Class


REXApplication.Context2 Property

REXApplication.Context2 Property
REXApplication Class REX.Common Namespace REXApplication Class

Get the context2.

C#
public REXContext Context2;
Description

The context2.

Class

REXApplication Class

Links
REXApplication Class, REX.Common Namespace, REXApplication Class


REXApplication.ContextProduct Property

REXApplication.ContextProduct Property
REXApplication Class REX.Common Namespace REXApplication Class

Get the context product from the old context structure.

C#
public REXProduct ContextProduct;
Description

The product context.

Class

REXApplication Class

Links
REXApplication Class, REX.Common Namespace, REXApplication Class


REXApplication.ContextProduct2 Property

REXApplication.ContextProduct2 Property
REXApplication Class REX.Common Namespace REXApplication Class

Get the context product2.

C#
public REXContextProduct ContextProduct2;
Description

The product2 context.

Class

REXApplication Class

Links
REXApplication Class, REX.Common Namespace, REXApplication Class


REXApplication.ThisApplication Property

REXApplication.ThisApplication Property
REXApplication Class REX.Common Namespace REXApplication Class

This is ThisApplication, a member of class REXApplication.

C#
public REXApplication ThisApplication;
Class

REXApplication Class

Links
REXApplication Class, REX.Common Namespace, REXApplication Class


REXApplication.ThisContext Property

REXApplication.ThisContext Property
REXApplication Class REX.Common Namespace REXApplication Class

This is ThisContext, a member of class REXApplication.

C#
public REXContext ThisContext;
Class

REXApplication Class

Links
REXApplication Class, REX.Common Namespace, REXApplication Class


REXApplication.ThisExtension Property

REXApplication.ThisExtension Property
REXApplication Class REX.Common Namespace REXApplication Class

This is ThisExtension, a member of class REXApplication.

C#
public REXExtension ThisExtension;
Class

REXApplication Class

Links
REXApplication Class, REX.Common Namespace, REXApplication Class


REXApplication.Visible Property

REXApplication.Visible Property
REXApplication Class REX.Common Namespace REXApplication Class

Get or set a value indicating whether this REXApplication is visible.

C#
public virtual bool Visible;
Description

true if visible; otherwise, false.

Class

REXApplication Class

Links
REXApplication Class, REX.Common Namespace, REXApplication Class


REXDFM Class

REXDFM Class
REX.Common Namespace Legend Members Public Methods REXDFM Classes REXDFM Delegates REXDFM Events REXDFM Methods REXDFM Properties

Manages UI controls registered in it.

Class Hierarchy
C#
public class REXDFM : REXExtensionObject;
Description

It provides support for Revit Extension units.

Namespace

REX.Common Namespace

Public Methods
Public Method | Description
REXDFM | Initializes a new instance of the REXDFM class.
REXDFM | Initializes a new instance of the REXDFM class.
REXDFM | Initializes a new instance of the REXDFM class.
REXDFM Classes
REXDFM Classes | Description
DisplayDefinition | Represents the display settings of the specified unit category.
REXDFM Delegates
REXDFM Delegates | Description
EventHandlerChange | Delegate to the event handler changes.
EventHandlerLost | Delegate to the event handler lost focus.
REXDFM Events
REXDFM Events | Description
ControlUnitObjectError | Raises when data is changed on Control and some error was occur.
ControlUnitObjectLostFocus | Raises when Control losts focus.
ControlUnitObjectOk | Raises when data is changed on Control and no errors.
REXDFM Methods
REXDFM Methods | Description
AddDisplayUnitObject | Registers an object which implements the IUnitObject interface.
AddDisplayUnitObject | Registers an object which implements the IUnitObject interface.
AddDisplayUnitObject | Registers an object which implements the IUnitObject interface.
AddDisplayUnitObject | Registers an object which implements the IUnitObject interface.
AddUnitObject | Registers an object which implements the IUnitObject interface.
AddUnitObject | Registers an object which implements the IUnitObject interface.
AddUnitObject | Registers an object which implements the IUnitObject interface.
AddUnitObject | Registers an object which implements the IUnitObject interface.
AfterParamsChange | Method called after parameters change.
BeforeParamsChange | Method called before parameters change.
Clear | Clears this instance.
CreateGroupControl | Creates the group of controls from collection of controls and all childrenss.
CreateGroupControl | Creates the group of controls from all childrens.
CreateGroupControl | Creates the group of controls from collection of controls and all childrenss.
CreateGroupControl | Creates the group of controls from all childrens.
GetComplexDataBase | Gets the values and convert it to base units.
GetComplexDataBase | Gets the values and converts them to base units.
GetComplexDataDisplay | Gets the values and convert it to display units.
GetComplexDataDisplay | Gets the values and convert it to display units.
GetComplexDataInterface | Gets the values and convert it to interface units.
GetComplexDataInterface | Gets the values and converts it to interface units.
GetDataBase | Gets the value and converts it to base units.
GetDataBase | Gets the value and converts it to base units.
GetDataDisplay | Gets the value and converts it to display units.
GetDataDisplay | Gets the value and converts it to display units.
GetDataInterface | Gets the value and converts it to interface units.
GetDataInterface | Gets the value and converts it to interface units.
GetDataText | Gets the current text.
GetDataText | Gets the current text.
GetObjectsOfNotOkState | Gets the list of registered objects which are in a state other then OK.
RemoveUnitObject | Removes the unit object.
RemoveUnitObject | Removes the unit object.
SetBaseMaxValue | Sets the maximum value defined in base units.
SetBaseMaxValue | Sets the maximum value defined in base units.
SetBaseMinValue | Sets the minimum value in base units.
SetBaseMinValue | Sets the minimum value in base units.
SetComplexDataBase | Sets the list of values in base units.
SetComplexDataBase | Sets the list of values in base units.
SetComplexDataDisplay | Sets the list of values defined in display units.
SetComplexDataDisplay | Sets the list of values defined in display units.
SetComplexDataInterface | Sets the list of values in interface units.
SetComplexDataInterface | Sets the list of values in interface units.
SetDataBase | Sets the value defined in base units.
SetDataBase | Sets the value defined in base units.
SetDataDisplay | Sets the value defined in display units.
SetDataDisplay | Sets the value defined in display units.
SetDataInterface | Sets the value defined in interface units.
SetDataInterface | Sets the value defined in interface units.
SetDataText | Sets the current text.
SetDataText | Sets the current text.
SetInterfaceMaxValue | Sets the maximum value defined in interface units.
SetInterfaceMaxValue | Sets the maximum value defined in interface units.
SetInterfaceMinValue | Sets the minimum value defined in interface units.
SetInterfaceMinValue | Sets the minimum value defined in interface units.
SetUserValidFunction | Sets the user validation function.
SetUserValidFunction | Sets the user validation function.
SetUserValidFunctionComplex | Sets the user validation function for lists of values.
SetUserValidFunctionComplex | Sets the user validation function for lists of values.
ValidateDataBase | Validates the value in base units.
ValidateDataBase | Validates the value in base units.
ValidateDataDisplay | Validates the value in display units.
ValidateDataDisplay | Validates the value in display units.
ValidateDataInterface | Validates the value in interface units.
ValidateDataInterface | Validates the value in interface units.
REXDFM Properties
REXDFM Properties | Description
AllowReplaceObject | Gets or sets a value indicating whether controlling object may be replaced during registration.
Count | Gets the number of controling objects.
Links
REX.Common Namespace, Legend, Members, Public Methods, REXDFM Classes, REXDFM Delegates, REXDFM Events, REXDFM Methods, REXDFM Properties


REXDFM.REXDFM Constructor (REXExtension)

REXDFM.REXDFM Constructor (REXExtension)
REXDFM Class REX.Common Namespace REXDFM Class

Initializes a new instance of the REXDFM class.

C#
public REXDFM(REXExtension extension);
Parameters
Parameters | Description
extension | The extension.
Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class


REXDFM.REXDFM Constructor (REXExtension, REXInterfaceType)

REXDFM.REXDFM Constructor (REXExtension, REXInterfaceType)
REXDFM Class REX.Common Namespace REXDFM Class

Initializes a new instance of the REXDFM class.

C#
public REXDFM(REXExtension extension, REXInterfaceType contextWork);
Parameters
Parameters | Description
extension | The extension.
contextWork | The context.
Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class


REXDFM.REXDFM Constructor (REXExtension, string)

REXDFM.REXDFM Constructor (REXExtension, string)
REXDFM Class REX.Common Namespace REXDFM Class

Initializes a new instance of the REXDFM class.

C#
public REXDFM(REXExtension extension, string contextWorkName);
Parameters
Parameters | Description
extension | The extension.
contextWorkName | The name of the context.
Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class


REXDFM.DisplayDefinition Class

REXDFM.DisplayDefinition Class
REXDFM Class Legend Members Public Methods DisplayDefinition Fields DisplayDefinition Methods

Represents the display settings of the specified unit category.

Class Hierarchy
C#
public class DisplayDefinition;
Description
Class

REXDFM Class

Public Methods
Public Method | Description
DisplayDefinition | Initializes a new instance of the DisplayDefinition class.
DisplayDefinition | Initializes a new instance of the DisplayDefinition class.
DisplayDefinition | Initializes a new instance of the DisplayDefinition class.
DisplayDefinition Fields
DisplayDefinition Fields | Description
DisplayType | This is DisplayType, a member of class DisplayDefinition.
EngineeringFormat | This is EngineeringFormat, a member of class DisplayDefinition.
Power | This is Power, a member of class DisplayDefinition.
RoundingIncrement | This is RoundingIncrement, a member of class DisplayDefinition.
Separator | This is Separator, a member of class DisplayDefinition.
UnitDefinition | This is UnitDefinition, a member of class DisplayDefinition.
UnitSymbol | This is UnitSymbol, a member of class DisplayDefinition.
DisplayDefinition Methods
DisplayDefinition Methods | Description
Equals | Determines whether the specified T:System.Object is equal to the current T:System.Object.
ReadFromCategory | Reads the unit definition based on the category.
ReadFromCategory | Reads the unit definition based on the category.
Links
REXDFM Class, Legend, Members, Public Methods, DisplayDefinition Fields, DisplayDefinition Methods


REXDFM.DisplayDefinition.DisplayDefinition Constructor ()

REXDFM.DisplayDefinition.DisplayDefinition Constructor ()
REXDFM.DisplayDefinition Class REX.Common Namespace REXDFM.DisplayDefinition Class

Initializes a new instance of the DisplayDefinition class.

C#
public DisplayDefinition();
Description
Class

REXDFM.DisplayDefinition Class

Links
REXDFM.DisplayDefinition Class, REX.Common Namespace, REXDFM.DisplayDefinition Class


REXDFM.DisplayDefinition.DisplayDefinition Constructor (REXUnits, Autodesk.REX.Framework.EUnitType, double)

REXDFM.DisplayDefinition.DisplayDefinition Constructor (REXUnits, Autodesk.REX.Framework.EUnitType, double)
REXDFM.DisplayDefinition Class REX.Common Namespace REXDFM.DisplayDefinition Class

Initializes a new instance of the DisplayDefinition class.

C#
public DisplayDefinition(REXUnits Units, Autodesk.REX.Framework.EUnitType UnitType, double Power);
Parameters
Parameters | Description
Units | The unit engine.
UnitType | The type of the unit.
Power | The power.
Description
Class

REXDFM.DisplayDefinition Class

Links
REXDFM.DisplayDefinition Class, REX.Common Namespace, REXDFM.DisplayDefinition Class


REXDFM.DisplayDefinition.DisplayDefinition Constructor (REXUnits, string, double)

REXDFM.DisplayDefinition.DisplayDefinition Constructor (REXUnits, string, double)
REXDFM.DisplayDefinition Class REX.Common Namespace REXDFM.DisplayDefinition Class

Initializes a new instance of the DisplayDefinition class.

C#
public DisplayDefinition(REXUnits Units, string UnitName, double Power);
Parameters
Parameters | Description
Units | The unit engine.
UnitName | The name of the unit.
Power | The power.
Description
Class

REXDFM.DisplayDefinition Class

Links
REXDFM.DisplayDefinition Class, REX.Common Namespace, REXDFM.DisplayDefinition Class


REXDFM.DisplayDefinition.DisplayType Field

REXDFM.DisplayDefinition.DisplayType Field
REXDFM.DisplayDefinition Class REX.Common Namespace REXDFM.DisplayDefinition Class

This is DisplayType, a member of class DisplayDefinition.

C#
public REXUnitsDisplayTypes DisplayType = REXUnitsDisplayTypes.Text;
Class

REXDFM.DisplayDefinition Class

Links
REXDFM.DisplayDefinition Class, REX.Common Namespace, REXDFM.DisplayDefinition Class


REXDFM.DisplayDefinition.EngineeringFormat Field

REXDFM.DisplayDefinition.EngineeringFormat Field
REXDFM.DisplayDefinition Class REX.Common Namespace REXDFM.DisplayDefinition Class

This is EngineeringFormat, a member of class DisplayDefinition.

C#
public bool EngineeringFormat = false;
Class

REXDFM.DisplayDefinition Class

Links
REXDFM.DisplayDefinition Class, REX.Common Namespace, REXDFM.DisplayDefinition Class


REXDFM.DisplayDefinition.Power Field

REXDFM.DisplayDefinition.Power Field
REXDFM.DisplayDefinition Class REX.Common Namespace REXDFM.DisplayDefinition Class

This is Power, a member of class DisplayDefinition.

C#
public double Power = 1;
Class

REXDFM.DisplayDefinition Class

Links
REXDFM.DisplayDefinition Class, REX.Common Namespace, REXDFM.DisplayDefinition Class


REXDFM.DisplayDefinition.RoundingIncrement Field

REXDFM.DisplayDefinition.RoundingIncrement Field
REXDFM.DisplayDefinition Class REX.Common Namespace REXDFM.DisplayDefinition Class

This is RoundingIncrement, a member of class DisplayDefinition.

C#
public double RoundingIncrement = 0;
Class

REXDFM.DisplayDefinition Class

Links
REXDFM.DisplayDefinition Class, REX.Common Namespace, REXDFM.DisplayDefinition Class


REXDFM.DisplayDefinition.Separator Field

REXDFM.DisplayDefinition.Separator Field
REXDFM.DisplayDefinition Class REX.Common Namespace REXDFM.DisplayDefinition Class

This is Separator, a member of class DisplayDefinition.

C#
public string Separator = ".";
Class

REXDFM.DisplayDefinition Class

Links
REXDFM.DisplayDefinition Class, REX.Common Namespace, REXDFM.DisplayDefinition Class


REXDFM.DisplayDefinition.UnitDefinition Field

REXDFM.DisplayDefinition.UnitDefinition Field
REXDFM.DisplayDefinition Class REX.Common Namespace REXDFM.DisplayDefinition Class

This is UnitDefinition, a member of class DisplayDefinition.

C#
public string UnitDefinition = null;
Class

REXDFM.DisplayDefinition Class

Links
REXDFM.DisplayDefinition Class, REX.Common Namespace, REXDFM.DisplayDefinition Class


REXDFM.DisplayDefinition.UnitSymbol Field

REXDFM.DisplayDefinition.UnitSymbol Field
REXDFM.DisplayDefinition Class REX.Common Namespace REXDFM.DisplayDefinition Class

This is UnitSymbol, a member of class DisplayDefinition.

C#
public string UnitSymbol = "";
Class

REXDFM.DisplayDefinition Class

Links
REXDFM.DisplayDefinition Class, REX.Common Namespace, REXDFM.DisplayDefinition Class


REXDFM.DisplayDefinition.Equals Method

REXDFM.DisplayDefinition.Equals Method
REXDFM.DisplayDefinition Class REX.Common Namespace REXDFM.DisplayDefinition Class

Determines whether the specified T:System.Object is equal to the current T:System.Object.

C#
public override bool Equals(object obj);
Parameters
Parameters | Description
obj | The T:System.Object to compare with the current T:System.Object.
Returns

true if the specified T:System.Object is equal to the current T:System.Object; otherwise, false.

Description
Class

REXDFM.DisplayDefinition Class

Links
REXDFM.DisplayDefinition Class, REX.Common Namespace, REXDFM.DisplayDefinition Class


REXDFM.DisplayDefinition.ReadFromCategory Method (REXUnits, Autodesk.REX.Framework.EUnitType, double)

REXDFM.DisplayDefinition.ReadFromCategory Method (REXUnits, Autodesk.REX.Framework.EUnitType, double)
REXDFM.DisplayDefinition Class REX.Common Namespace REXDFM.DisplayDefinition Class

Reads the unit definition based on the category.

C#
public void ReadFromCategory(REXUnits Units, Autodesk.REX.Framework.EUnitType UnitType, double Power);
Parameters
Parameters | Description
Units | The unit engine.
UnitType | The type of the unit.
Power | The power.
Description
Class

REXDFM.DisplayDefinition Class

Links
REXDFM.DisplayDefinition Class, REX.Common Namespace, REXDFM.DisplayDefinition Class


REXDFM.DisplayDefinition.ReadFromCategory Method (REXUnits, string, double)

REXDFM.DisplayDefinition.ReadFromCategory Method (REXUnits, string, double)
REXDFM.DisplayDefinition Class REX.Common Namespace REXDFM.DisplayDefinition Class

Reads the unit definition based on the category.

C#
public void ReadFromCategory(REXUnits Units, string UnitName, double Power);
Parameters
Parameters | Description
Units | The unit engine.
UnitName | The name of the unit.
Power | The power.
Description
Class

REXDFM.DisplayDefinition Class

Links
REXDFM.DisplayDefinition Class, REX.Common Namespace, REXDFM.DisplayDefinition Class


REXDFM.AddDisplayUnitObject Method (IUnitObject, Autodesk.REX.Framework.EUnitType, int, DisplayDefinition)

REXDFM.AddDisplayUnitObject Method (IUnitObject, Autodesk.REX.Framework.EUnitType, int, DisplayDefinition)
REXDFM Class REX.Common Namespace REXDFM Class

Registers an object which implements the IUnitObject interface.

C#
public bool AddDisplayUnitObject(IUnitObject myUnitObject, Autodesk.REX.Framework.EUnitType UnitType, int power, DisplayDefinition displayUnitDef);
Parameters
Parameters | Description
myUnitObject | The reference to the object.
UnitType | The type of the unit.
power | The power of the unit.
displayUnitDef | The unit display settings.
Returns

Returns true if the object was registered.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class


REXDFM.AddDisplayUnitObject Method (IUnitObject, DisplayDefinition)

REXDFM.AddDisplayUnitObject Method (IUnitObject, DisplayDefinition)
REXDFM Class REX.Common Namespace REXDFM Class

Registers an object which implements the IUnitObject interface.

C#
public bool AddDisplayUnitObject(IUnitObject myUnitObject, DisplayDefinition displayUnitDef);
Parameters
Parameters | Description
myUnitObject | The reference to the object.
displayUnitDef | The display settings.
Returns

Returns true if the object was registered.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class


REXDFM.AddDisplayUnitObject Method (IUnitObject, string, Autodesk.REX.Framework.EUnitType, int, DisplayDefinition)

REXDFM.AddDisplayUnitObject Method (IUnitObject, string, Autodesk.REX.Framework.EUnitType, int, DisplayDefinition)
REXDFM Class REX.Common Namespace REXDFM Class

Registers an object which implements the IUnitObject interface.

C#
public bool AddDisplayUnitObject(IUnitObject myUnitObject, string nameUnitObject, Autodesk.REX.Framework.EUnitType UnitType, int power, DisplayDefinition displayUnitDef);
Parameters
Parameters | Description
myUnitObject | The reference to the object.
nameUnitObject | The name of the unit object.
UnitType | The type of the unit.
power | The power of the unit.
displayUnitDef | The unit display settings.
Returns

Returns true if the object was registered.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class


REXDFM.AddDisplayUnitObject Method (IUnitObject, string, DisplayDefinition)

REXDFM.AddDisplayUnitObject Method (IUnitObject, string, DisplayDefinition)
REXDFM Class REX.Common Namespace REXDFM Class

Registers an object which implements the IUnitObject interface.

C#
public bool AddDisplayUnitObject(IUnitObject myUnitObject, string nameUnitObject, DisplayDefinition displayUnitDef);
Parameters
Parameters | Description
myUnitObject | The reference to the object.
nameUnitObject | The name of the unit object.
displayUnitDef | The unit display settings.
Returns

Returns true if the object was registered.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class


REXDFM.AddUnitObject Method (IUnitObject)

REXDFM.AddUnitObject Method (IUnitObject)
REXDFM Class REX.Common Namespace REXDFM Class

Registers an object which implements the IUnitObject interface.

C#
public bool AddUnitObject(IUnitObject myUnitObject);
Parameters
Parameters | Description
myUnitObject | The reference to the object.
Returns

Returns true if the object was registered.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class


REXDFM.AddUnitObject Method (IUnitObject, Autodesk.REX.Framework.EUnitType, int)

REXDFM.AddUnitObject Method (IUnitObject, Autodesk.REX.Framework.EUnitType, int)
REXDFM Class REX.Common Namespace REXDFM Class

Registers an object which implements the IUnitObject interface.

C#
public bool AddUnitObject(IUnitObject myUnitObject, Autodesk.REX.Framework.EUnitType UnitType, int power);
Parameters
Parameters | Description
myUnitObject | The reference to the object.
UnitType | The type of the unit.
power | The power of the unit.
Returns

Returns true if the object was registered.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class


REXDFM.AddUnitObject Method (IUnitObject, string)

REXDFM.AddUnitObject Method (IUnitObject, string)
REXDFM Class REX.Common Namespace REXDFM Class

Registers an object which implements the IUnitObject interface.

C#
public bool AddUnitObject(IUnitObject myUnitObject, string nameUnitObject);
Parameters
Parameters | Description
myUnitObject | The reference to the object.
nameUnitObject | The name of the unit object.
Returns

Returns true if the object was registered.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class


REXDFM.AddUnitObject Method (IUnitObject, string, Autodesk.REX.Framework.EUnitType, int)

REXDFM.AddUnitObject Method (IUnitObject, string, Autodesk.REX.Framework.EUnitType, int)
REXDFM Class REX.Common Namespace REXDFM Class

Registers an object which implements the IUnitObject interface.

C#
public bool AddUnitObject(IUnitObject myUnitObject, string nameUnitObject, Autodesk.REX.Framework.EUnitType UnitType, int power);
Parameters
Parameters | Description
myUnitObject | The reference to the object.
nameUnitObject | The name of the unit object.
UnitType | The type of the unit.
power | The power of the unit.
Returns

Returns true if the object was registered.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class


REXDFM.AfterParamsChange Method

REXDFM.AfterParamsChange Method
REXDFM Class REX.Common Namespace REXDFM Class

Method called after parameters change.

C#
public void AfterParamsChange();
Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class


REXDFM.BeforeParamsChange Method

REXDFM.BeforeParamsChange Method
REXDFM Class REX.Common Namespace REXDFM Class

Method called before parameters change.

C#
public void BeforeParamsChange();
Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class


REXDFM.Clear Method

REXDFM.Clear Method
REXDFM Class REX.Common Namespace REXDFM Class

Clears this instance.

C#
public void Clear();
Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class


REXDFM.CreateGroupControl Method (System.Windows.Controls.ContentControl)

REXDFM.CreateGroupControl Method (System.Windows.Controls.ContentControl)
REXDFM Class REX.Common Namespace REXDFM Class

Creates the group of controls from collection of controls and all childrenss.

C#
public void CreateGroupControl(System.Windows.Controls.ContentControl contentControl);
Parameters
Parameters | Description
controls | The controls.
Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class


REXDFM.CreateGroupControl Method (System.Windows.Controls.UserControl)

REXDFM.CreateGroupControl Method (System.Windows.Controls.UserControl)
REXDFM Class REX.Common Namespace REXDFM Class

Creates the group of controls from all childrens.

C#
public void CreateGroupControl(System.Windows.Controls.UserControl myUserControl);
Parameters
Parameters | Description
myUserControl | My user control.
Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class


REXDFM.CreateGroupControl Method (System.Windows.Forms.Control.ControlCollection)

REXDFM.CreateGroupControl Method (System.Windows.Forms.Control.ControlCollection)
REXDFM Class REX.Common Namespace REXDFM Class

Creates the group of controls from collection of controls and all childrenss.

C#
public void CreateGroupControl(System.Windows.Forms.Control.ControlCollection controls);
Parameters
Parameters | Description
controls | The controls.
Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class


REXDFM.CreateGroupControl Method (System.Windows.Forms.UserControl)

REXDFM.CreateGroupControl Method (System.Windows.Forms.UserControl)
REXDFM Class REX.Common Namespace REXDFM Class

Creates the group of controls from all childrens.

C#
public void CreateGroupControl(System.Windows.Forms.UserControl myUserControl);
Parameters
Parameters | Description
myUserControl | My user control.
Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class


REXDFM.GetComplexDataBase Method (IUnitObject)

REXDFM.GetComplexDataBase Method (IUnitObject)
REXDFM Class REX.Common Namespace REXDFM Class

Gets the values and convert it to base units.

C#
public List<double> GetComplexDataBase(IUnitObject myUnitObject);
Parameters
Parameters | Description
myUnitObject | The reference to the unit object.
Returns

Returns the list of values.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class


REXDFM.GetComplexDataBase Method (string)

REXDFM.GetComplexDataBase Method (string)
REXDFM Class REX.Common Namespace REXDFM Class

Gets the values and converts them to base units.

C#
public List<double> GetComplexDataBase(string nameUnitObject);
Parameters
Parameters | Description
nameUnitObject | The name of the unit object.
Returns

Returns the list of values.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class


REXDFM.GetComplexDataDisplay Method (IUnitObject)

REXDFM.GetComplexDataDisplay Method (IUnitObject)
REXDFM Class REX.Common Namespace REXDFM Class

Gets the values and convert it to display units.

C#
public List<double> GetComplexDataDisplay(IUnitObject myUnitObject);
Parameters
Parameters | Description
myUnitObject | The reference to the unit object.
Returns

Returns the list of values.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class


REXDFM.GetComplexDataDisplay Method (string)

REXDFM.GetComplexDataDisplay Method (string)
REXDFM Class REX.Common Namespace REXDFM Class

Gets the values and convert it to display units.

C#
public List<double> GetComplexDataDisplay(string nameUnitObject);
Parameters
Parameters | Description
nameUnitObject | The name of the unit object.
Returns

Returns the list of values.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class


REXDFM.GetComplexDataInterface Method (IUnitObject)

REXDFM.GetComplexDataInterface Method (IUnitObject)
REXDFM Class REX.Common Namespace REXDFM Class

Gets the values and convert it to interface units.

C#
public List<double> GetComplexDataInterface(IUnitObject myUnitObject);
Parameters
Parameters | Description
myUnitObject | The reference to the unit object.
Returns

Returns the list of values.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class


REXDFM.GetComplexDataInterface Method (string)

REXDFM.GetComplexDataInterface Method (string)
REXDFM Class REX.Common Namespace REXDFM Class

Gets the values and converts it to interface units.

C#
public List<double> GetComplexDataInterface(string nameUnitObject);
Parameters
Parameters | Description
nameUnitObject | The name of the unit object.
Returns

Returns the list of values.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class


REXDFM.GetDataBase Method (IUnitObject)

REXDFM.GetDataBase Method (IUnitObject)
REXDFM Class REX.Common Namespace REXDFM Class

Gets the value and converts it to base units.

C#
public double GetDataBase(IUnitObject myUnitObject);
Parameters
Parameters | Description
myUnitObject | The reference to the unit object.
Returns

Returns value.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class


REXDFM.GetDataBase Method (string)

REXDFM.GetDataBase Method (string)
REXDFM Class REX.Common Namespace REXDFM Class

Gets the value and converts it to base units.

C#
public double GetDataBase(string nameUnitObject);
Parameters
Parameters | Description
nameUnitObject | The name of the unit object.
Returns

Returns value.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class


REXDFM.GetDataDisplay Method (IUnitObject)

REXDFM.GetDataDisplay Method (IUnitObject)
REXDFM Class REX.Common Namespace REXDFM Class

Gets the value and converts it to display units.

C#
public double GetDataDisplay(IUnitObject myUnitObject);
Parameters
Parameters | Description
myUnitObject | The reference to the unit object.
Returns

Returns value.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class


REXDFM.GetDataDisplay Method (string)

REXDFM.GetDataDisplay Method (string)
REXDFM Class REX.Common Namespace REXDFM Class

Gets the value and converts it to display units.

C#
public double GetDataDisplay(string nameUnitObject);
Parameters
Parameters | Description
nameUnitObject | The name of the unit object.
Returns

Returns value.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class


REXDFM.GetDataInterface Method (IUnitObject)

REXDFM.GetDataInterface Method (IUnitObject)
REXDFM Class REX.Common Namespace REXDFM Class

Gets the value and converts it to interface units.

C#
public double GetDataInterface(IUnitObject myUnitObject);
Parameters
Parameters | Description
myUnitObject | The reference to the unit object.
Returns

Returns value.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class


REXDFM.GetDataInterface Method (string)

REXDFM.GetDataInterface Method (string)
REXDFM Class REX.Common Namespace REXDFM Class

Gets the value and converts it to interface units.

C#
public double GetDataInterface(string nameUnitObject);
Parameters
Parameters | Description
nameUnitObject | The name of the unit object.
Returns

Returns value.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class


REXDFM.GetDataText Method (IUnitObject)

REXDFM.GetDataText Method (IUnitObject)
REXDFM Class REX.Common Namespace REXDFM Class

Gets the current text.

C#
public string GetDataText(IUnitObject myUnitObject);
Parameters
Parameters | Description
myUnitObject | The reference to the unit object.
Returns

Returns the current text.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class


REXDFM.GetDataText Method (string)

REXDFM.GetDataText Method (string)
REXDFM Class REX.Common Namespace REXDFM Class

Gets the current text.

C#
public string GetDataText(string nameUnitObject);
Parameters
Parameters | Description
nameUnitObject | The name of the unit object.
Returns

Returns the current text.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class


REXDFM.GetObjectsOfNotOkState Method

REXDFM.GetObjectsOfNotOkState Method
REXDFM Class REX.Common Namespace REXDFM Class

Gets the list of registered objects which are in a state other then OK.

C#
public List<IUnitObject> GetObjectsOfNotOkState();
Returns

The list of objects.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class


REXDFM.RemoveUnitObject Method (IUnitObject)

REXDFM.RemoveUnitObject Method (IUnitObject)
REXDFM Class REX.Common Namespace REXDFM Class

Removes the unit object.

C#
public bool RemoveUnitObject(IUnitObject myUnitObject);
Parameters
Parameters | Description
myUnitObject | The reference to the unit object.
Returns

Returns true if operation succeeded

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class


REXDFM.RemoveUnitObject Method (string)

REXDFM.RemoveUnitObject Method (string)
REXDFM Class REX.Common Namespace REXDFM Class

Removes the unit object.

C#
public bool RemoveUnitObject(string nameUnitObject);
Parameters
Parameters | Description
nameUnitObject | The name of the unit object.
Returns

Returns true if operation succeeded

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class


REXDFM.SetBaseMaxValue Method (IUnitObject, bool, double)

REXDFM.SetBaseMaxValue Method (IUnitObject, bool, double)
REXDFM Class REX.Common Namespace REXDFM Class

Sets the maximum value defined in base units.

C#
public bool SetBaseMaxValue(IUnitObject myUnitObject, bool CheckVal, double baseVal);
Parameters
Parameters | Description
myUnitObject | Reference to based control on IUnitObject interface.
CheckVal | If set to true, value is checked.
baseVal | The base value.
Returns

Returns true if succeeded.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class


REXDFM.SetBaseMaxValue Method (string, bool, double)

REXDFM.SetBaseMaxValue Method (string, bool, double)
REXDFM Class REX.Common Namespace REXDFM Class

Sets the maximum value defined in base units.

C#
public bool SetBaseMaxValue(string nameUnitObject, bool CheckVal, double baseVal);
Parameters
Parameters | Description
nameUnitObject | The name of the unit object.
CheckVal | If set to true, value is checked.
baseVal | The base value.
Returns

Returns true if succeeded.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class


REXDFM.SetBaseMinValue Method (IUnitObject, bool, double)

REXDFM.SetBaseMinValue Method (IUnitObject, bool, double)
REXDFM Class REX.Common Namespace REXDFM Class

Sets the minimum value in base units.

C#
public bool SetBaseMinValue(IUnitObject myUnitObject, bool CheckVal, double baseVal);
Parameters
Parameters | Description
myUnitObject | The reference to the unit object.
CheckVal | If set to true, value is checked.
baseVal | The base value.
Returns

Returns true if succeeded.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class


REXDFM.SetBaseMinValue Method (string, bool, double)

REXDFM.SetBaseMinValue Method (string, bool, double)
REXDFM Class REX.Common Namespace REXDFM Class

Sets the minimum value in base units.

C#
public bool SetBaseMinValue(string nameUnitObject, bool CheckVal, double baseVal);
Parameters
Parameters | Description
nameUnitObject | The name of the unit object.
CheckVal | If set to true, value is checked.
baseVal | The base value.
Returns

Returns true if succeeded.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class


REXDFM.SetComplexDataBase Method (IUnitObject, List<double>)

REXDFM.SetComplexDataBase Method (IUnitObject, List<double>)
REXDFM Class REX.Common Namespace REXDFM Class

Sets the list of values in base units.

C#
public bool SetComplexDataBase(IUnitObject myUnitObject, List<double> Value);
Parameters
Parameters | Description
myUnitObject | The reference to the unit object.
Value | The values.
Returns

Returns true if succeeded.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class


REXDFM.SetComplexDataBase Method (string, List<double>)

REXDFM.SetComplexDataBase Method (string, List<double>)
REXDFM Class REX.Common Namespace REXDFM Class

Sets the list of values in base units.

C#
public bool SetComplexDataBase(string nameUnitObject, List<double> Value);
Parameters
Parameters | Description
nameUnitObject | The name of the unit object.
Value | The values.
Returns

Returns true if succeeded.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class


REXDFM.SetComplexDataDisplay Method (IUnitObject, List<double>)

REXDFM.SetComplexDataDisplay Method (IUnitObject, List<double>)
REXDFM Class REX.Common Namespace REXDFM Class

Sets the list of values defined in display units.

C#
public bool SetComplexDataDisplay(IUnitObject myUnitObject, List<double> Value);
Parameters
Parameters | Description
myUnitObject | The reference to the unit object.
Value | The values.
Returns

Returns true if succeeded.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class


REXDFM.SetComplexDataDisplay Method (string, List<double>)

REXDFM.SetComplexDataDisplay Method (string, List<double>)
REXDFM Class REX.Common Namespace REXDFM Class

Sets the list of values defined in display units.

C#
public bool SetComplexDataDisplay(string nameUnitObject, List<double> Value);
Parameters
Parameters | Description
nameUnitObject | The name of the unit object.
Value | The values.
Returns

Returns true if succeeded.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class


REXDFM.SetComplexDataInterface Method (IUnitObject, List<double>)

REXDFM.SetComplexDataInterface Method (IUnitObject, List<double>)
REXDFM Class REX.Common Namespace REXDFM Class

Sets the list of values in interface units.

C#
public bool SetComplexDataInterface(IUnitObject myUnitObject, List<double> Value);
Parameters
Parameters | Description
myUnitObject | The reference to the unit object.
Value | The values.
Returns

Returns true if succeeded.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class


REXDFM.SetComplexDataInterface Method (string, List<double>)

REXDFM.SetComplexDataInterface Method (string, List<double>)
REXDFM Class REX.Common Namespace REXDFM Class

Sets the list of values in interface units.

C#
public bool SetComplexDataInterface(string nameUnitObject, List<double> Value);
Parameters
Parameters | Description
nameUnitObject | The name of the unit object.
Value | The values.
Returns

Returns true if succeeded.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class


REXDFM.SetDataBase Method (IUnitObject, double)

REXDFM.SetDataBase Method (IUnitObject, double)
REXDFM Class REX.Common Namespace REXDFM Class

Sets the value defined in base units.

C#
public bool SetDataBase(IUnitObject myUnitObject, double Value);
Parameters
Parameters | Description
myUnitObject | The reference to the unit object.
Value | The value.
Returns

Returns true if succeeded.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class


REXDFM.SetDataBase Method (string, double)

REXDFM.SetDataBase Method (string, double)
REXDFM Class REX.Common Namespace REXDFM Class

Sets the value defined in base units.

C#
public bool SetDataBase(string nameUnitObject, double Value);
Parameters
Parameters | Description
nameUnitObject | The name of the unit object.
Value | The value.
Returns

Returns true if succeeded.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class


REXDFM.SetDataDisplay Method (IUnitObject, double)

REXDFM.SetDataDisplay Method (IUnitObject, double)
REXDFM Class REX.Common Namespace REXDFM Class

Sets the value defined in display units.

C#
public bool SetDataDisplay(IUnitObject myUnitObject, double Value);
Parameters
Parameters | Description
myUnitObject | Reference to the unit object.
Value | The value.
Returns

Returns true if succeeded.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class


REXDFM.SetDataDisplay Method (string, double)

REXDFM.SetDataDisplay Method (string, double)
REXDFM Class REX.Common Namespace REXDFM Class

Sets the value defined in display units.

C#
public bool SetDataDisplay(string nameUnitObject, double Value);
Parameters
Parameters | Description
nameUnitObject | The name of the unit object.
Value | The value.
Returns

Returns true if succeeded.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class


REXDFM.SetDataInterface Method (IUnitObject, double)

REXDFM.SetDataInterface Method (IUnitObject, double)
REXDFM Class REX.Common Namespace REXDFM Class

Sets the value defined in interface units.

C#
public bool SetDataInterface(IUnitObject myUnitObject, double Value);
Parameters
Parameters | Description
myUnitObject | The reference to the unit object.
Value | The value.
Returns

Returns true if succeeded.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class


REXDFM.SetDataInterface Method (string, double)

REXDFM.SetDataInterface Method (string, double)
REXDFM Class REX.Common Namespace REXDFM Class

Sets the value defined in interface units.

C#
public bool SetDataInterface(string nameUnitObject, double Value);
Parameters
Parameters | Description
nameUnitObject | The name of the unit object.
Value | The value.
Returns

Returns true if succeeded.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class


REXDFM.SetDataText Method (IUnitObject, string)

REXDFM.SetDataText Method (IUnitObject, string)
REXDFM Class REX.Common Namespace REXDFM Class

Sets the current text.

C#
public string SetDataText(IUnitObject myUnitObject, string Value);
Parameters
Parameters | Description
myUnitObject | The reference to the unit object.
Value | The value.
Returns

Returns current text.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class


REXDFM.SetDataText Method (string, string)

REXDFM.SetDataText Method (string, string)
REXDFM Class REX.Common Namespace REXDFM Class

Sets the current text.

C#
public string SetDataText(string nameUnitObject, string Value);
Parameters
Parameters | Description
nameUnitObject | The name of the unit object.
Value | The value.
Returns

Returns current text.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class


REXDFM.SetInterfaceMaxValue Method (IUnitObject, bool, double)

REXDFM.SetInterfaceMaxValue Method (IUnitObject, bool, double)
REXDFM Class REX.Common Namespace REXDFM Class

Sets the maximum value defined in interface units.

C#
public bool SetInterfaceMaxValue(IUnitObject myUnitObject, bool CheckVal, double baseVal);
Parameters
Parameters | Description
myUnitObject | Reference to based control on IUnitObject interface.
CheckVal | If set to true, value is checked.
baseVal | The base value.
Returns

Returns true if succeeded.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class


REXDFM.SetInterfaceMaxValue Method (string, bool, double)

REXDFM.SetInterfaceMaxValue Method (string, bool, double)
REXDFM Class REX.Common Namespace REXDFM Class

Sets the maximum value defined in interface units.

C#
public bool SetInterfaceMaxValue(string nameUnitObject, bool CheckVal, double baseVal);
Parameters
Parameters | Description
nameUnitObject | The name of the unit object.
CheckVal | If set to true, value is checked.
baseVal | The base value.
Returns

Returns true if succeeded.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class


REXDFM.SetInterfaceMinValue Method (IUnitObject, bool, double)

REXDFM.SetInterfaceMinValue Method (IUnitObject, bool, double)
REXDFM Class REX.Common Namespace REXDFM Class

Sets the minimum value defined in interface units.

C#
public bool SetInterfaceMinValue(IUnitObject myUnitObject, bool CheckVal, double baseVal);
Parameters
Parameters | Description
myUnitObject | Reference to based control on IUnitObject interface.
CheckVal | If set to true, value is checked.
baseVal | The base value.
Returns

Returns true if succeeded.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class


REXDFM.SetInterfaceMinValue Method (string, bool, double)

REXDFM.SetInterfaceMinValue Method (string, bool, double)
REXDFM Class REX.Common Namespace REXDFM Class

Sets the minimum value defined in interface units.

C#
public bool SetInterfaceMinValue(string nameUnitObject, bool CheckVal, double baseVal);
Parameters
Parameters | Description
nameUnitObject | The name of the unit object.
CheckVal | If set to true, value is checked.
baseVal | The base value.
Returns

Returns true if succeeded.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class


REXDFM.SetUserValidFunction Method (IUnitObject, UserValidation)

REXDFM.SetUserValidFunction Method (IUnitObject, UserValidation)
REXDFM Class REX.Common Namespace REXDFM Class

Sets the user validation function.

C#
public bool SetUserValidFunction(IUnitObject myUnitObject, UserValidation myFunction);
Parameters
Parameters | Description
myUnitObject | The reference to the unit object.
myFunction | The function.
Returns

Returns true if succeeded.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class


REXDFM.SetUserValidFunction Method (string, UserValidation)

REXDFM.SetUserValidFunction Method (string, UserValidation)
REXDFM Class REX.Common Namespace REXDFM Class

Sets the user validation function.

C#
public bool SetUserValidFunction(string myUnitObject, UserValidation myFunction);
Parameters
Parameters | Description
myUnitObject | The reference to the unit object.
myFunction | My function.
Returns

Returns true if succeeded.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class


REXDFM.SetUserValidFunctionComplex Method (IUnitObject, UserValidationComplex)

REXDFM.SetUserValidFunctionComplex Method (IUnitObject, UserValidationComplex)
REXDFM Class REX.Common Namespace REXDFM Class

Sets the user validation function for lists of values.

C#
public bool SetUserValidFunctionComplex(IUnitObject myUnitObject, UserValidationComplex myFunction);
Parameters
Parameters | Description
myUnitObject | The reference to the unit object.
myFunction | The function.
Returns

Returns true if succeeded.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class


REXDFM.SetUserValidFunctionComplex Method (string, UserValidationComplex)

REXDFM.SetUserValidFunctionComplex Method (string, UserValidationComplex)
REXDFM Class REX.Common Namespace REXDFM Class

Sets the user validation function for lists of values.

C#
public bool SetUserValidFunctionComplex(string myUnitObject, UserValidationComplex myFunction);
Parameters
Parameters | Description
myUnitObject | The reference to the unit object.
myFunction | The function.
Returns

Returns true if succeeded.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class


REXDFM.ValidateDataBase Method (IUnitObject, double)

REXDFM.ValidateDataBase Method (IUnitObject, double)
REXDFM Class REX.Common Namespace REXDFM Class

Validates the value in base units.

C#
public bool ValidateDataBase(IUnitObject myUnitObject, double Value);
Parameters
Parameters | Description
myUnitObject | The reference to the unit object.
Value | The value.
Returns

Returns true if succeeded.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class


REXDFM.ValidateDataBase Method (string, double)

REXDFM.ValidateDataBase Method (string, double)
REXDFM Class REX.Common Namespace REXDFM Class

Validates the value in base units.

C#
public bool ValidateDataBase(string nameUnitObject, double Value);
Parameters
Parameters | Description
nameUnitObject | The name of the unit object.
Value | The value.
Returns

Returns true if succeeded.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class


REXDFM.ValidateDataDisplay Method (IUnitObject, double)

REXDFM.ValidateDataDisplay Method (IUnitObject, double)
REXDFM Class REX.Common Namespace REXDFM Class

Validates the value in display units.

C#
public bool ValidateDataDisplay(IUnitObject myUnitObject, double Value);
Parameters
Parameters | Description
myUnitObject | The reference to the unit object.
Value | The value.
Returns

Returns true if succeeded.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class


REXDFM.ValidateDataDisplay Method (string, double)

REXDFM.ValidateDataDisplay Method (string, double)
REXDFM Class REX.Common Namespace REXDFM Class

Validates the value in display units.

C#
public bool ValidateDataDisplay(string nameUnitObject, double Value);
Parameters
Parameters | Description
nameUnitObject | The name of the unit object.
Value | The value.
Returns

Returns true if succeeded.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class


REXDFM.ValidateDataInterface Method (IUnitObject, double)

REXDFM.ValidateDataInterface Method (IUnitObject, double)
REXDFM Class REX.Common Namespace REXDFM Class

Validates the value in interface units.

C#
public bool ValidateDataInterface(IUnitObject myUnitObject, double Value);
Parameters
Parameters | Description
myUnitObject | The reference to the unit object.
Value | The value.
Returns

Returns true if succeeded.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class


REXDFM.ValidateDataInterface Method (string, double)

REXDFM.ValidateDataInterface Method (string, double)
REXDFM Class REX.Common Namespace REXDFM Class

Validates the value in interface units.

C#
public bool ValidateDataInterface(string nameUnitObject, double Value);
Parameters
Parameters | Description
nameUnitObject | The name of the unit object.
Value | The value.
Returns

Returns true if succeeded.

Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class


REXDFM.AllowReplaceObject Property

REXDFM.AllowReplaceObject Property
REXDFM Class REX.Common Namespace REXDFM Class

Gets or sets a value indicating whether controlling object may be replaced during registration.

C#
public bool AllowReplaceObject;
Description

true if replacing objects is allowed; otherwise, false.

Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class


REXDFM.Count Property

REXDFM.Count Property
REXDFM Class REX.Common Namespace REXDFM Class

Gets the number of controling objects.

C#
public int Count;
Description

The count.

Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class


REXDFM.EventHandlerChange Delegate

REXDFM.EventHandlerChange Delegate
REXDFM Class REX.Common Namespace REXDFM Class

Delegate to the event handler changes.

C#
public delegate void EventHandlerChange(IUnitObject sender);
Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class


REXDFM.EventHandlerLost Delegate

REXDFM.EventHandlerLost Delegate
REXDFM Class REX.Common Namespace REXDFM Class

Delegate to the event handler lost focus.

C#
public delegate void EventHandlerLost(IUnitObject sender);
Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class


REXDFM.ControlUnitObjectError Event

REXDFM.ControlUnitObjectError Event
REXDFM Class REX.Common Namespace REXDFM Class

Raises when data is changed on Control and some error was occur.

C#
public event EventHandlerChange ControlUnitObjectError;
Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class


REXDFM.ControlUnitObjectLostFocus Event

REXDFM.ControlUnitObjectLostFocus Event
REXDFM Class REX.Common Namespace REXDFM Class

Raises when Control losts focus.

C#
public event EventHandlerLost ControlUnitObjectLostFocus;
Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class


REXDFM.ControlUnitObjectOk Event

REXDFM.ControlUnitObjectOk Event
REXDFM Class REX.Common Namespace REXDFM Class

Raises when data is changed on Control and no errors.

C#
public event EventHandlerChange ControlUnitObjectOk;
Description
Class

REXDFM Class

Links
REXDFM Class, REX.Common Namespace, REXDFM Class


REXDirectAccess Class

REXDirectAccess Class
REX.Common Namespace Legend Members REXDirectAccess Methods

Base class for main DirectAccess class.

Class Hierarchy
C#
public class REXDirectAccess;
Description

The class enables direct connection between parent application and extension.

Namespace

REX.Common Namespace

REXDirectAccess Methods
REXDirectAccess Methods | Description
PresetContext | Presets the context.
Links
REX.Common Namespace, Legend, Members, REXDirectAccess Methods


REXDirectAccess.PresetContext Method

REXDirectAccess.PresetContext Method
REXDirectAccess Class REX.Common Namespace REXDirectAccess Class

Presets the context.

C#
public void PresetContext(ref REXContext Context);
Parameters
Parameters | Description
Context | The context.
Description

Set dedicated version name. For example "2009", "2010".

Class

REXDirectAccess Class

Links
REXDirectAccess Class, REX.Common Namespace, REXDirectAccess Class


REXDirectRevitAccess Class

REXDirectRevitAccess Class
REX.Common Namespace Legend Members REXDirectRevitAccess Methods

Base class for main DirectAccess class.

Class Hierarchy
C#
public class REXDirectRevitAccess : REXDirectAccess;
Description

The class enables direct connection between Revit and extension.

Namespace

REX.Common Namespace

REXDirectRevitAccess Methods
REXDirectRevitAccess Methods | Description
GetRevitSubName | Gets the name of the revit sub.
GetRevitSubName | Gets the name of the revit sub.
MapLanguageToCultureInfoName | This is MapLanguageToCultureInfoName, a member of class REXDirectRevitAccess.
PresetContext | Presets the context.
Links
REX.Common Namespace, Legend, Members, REXDirectRevitAccess Methods


REXDirectRevitAccess.GetRevitSubName Method (Autodesk.Revit.ApplicationServices.Application)

REXDirectRevitAccess.GetRevitSubName Method (Autodesk.Revit.ApplicationServices.Application)
REXDirectRevitAccess Class REX.Common Namespace REXDirectRevitAccess Class

Gets the name of the revit sub.

C#
public static string GetRevitSubName(Autodesk.Revit.ApplicationServices.Application RevitApp);
Parameters
Parameters | Description
RevitApp | The revit app.
Description
Class

REXDirectRevitAccess Class

Links
REXDirectRevitAccess Class, REX.Common Namespace, REXDirectRevitAccess Class


REXDirectRevitAccess.GetRevitSubName Method (string)

REXDirectRevitAccess.GetRevitSubName Method (string)
REXDirectRevitAccess Class REX.Common Namespace REXDirectRevitAccess Class

Gets the name of the revit sub.

C#
public static string GetRevitSubName(string VersionName);
Parameters
Parameters | Description
VersionName | Name of the version.
Description
Class

REXDirectRevitAccess Class

Links
REXDirectRevitAccess Class, REX.Common Namespace, REXDirectRevitAccess Class


REXDirectRevitAccess.MapLanguageToCultureInfoName Method

REXDirectRevitAccess.MapLanguageToCultureInfoName Method
REXDirectRevitAccess Class REX.Common Namespace REXDirectRevitAccess Class

This is MapLanguageToCultureInfoName, a member of class REXDirectRevitAccess.

C#
public string MapLanguageToCultureInfoName(Autodesk.Revit.ApplicationServices.LanguageType language);
Class

REXDirectRevitAccess Class

Links
REXDirectRevitAccess Class, REX.Common Namespace, REXDirectRevitAccess Class


REXDirectRevitAccess.PresetContext Method

REXDirectRevitAccess.PresetContext Method
REXDirectRevitAccess Class REX.Common Namespace REXDirectRevitAccess Class

Presets the context.

C#
public void PresetContext(ref Autodesk.Revit.UI.ExternalCommandData commandData, ref string message, ref ElementSet elements, ref REXContext Context);
Parameters
Parameters | Description
commandData | The command data.
message | The message.
elements | The elements.
Context | The context.
Description

Set dedicated version name. For example "2009", "2010".

On second step the method sets:

Context.Product.Objects -> REX.Common.REXConst.REX_RevitObjectAutodesk.Revit.ExternalCommandData as commandData.

Context.Product.Objects -> REX.Common.REXConst.REX_RevitObjectElements as elements.

Context.Product.Data -> REX.Common.REXConst.REX_RevitDataMessage as message.

Class

REXDirectRevitAccess Class

Links
REXDirectRevitAccess Class, REX.Common Namespace, REXDirectRevitAccess Class


REXDirectRevitExecute Class

REXDirectRevitExecute Class
REX.Common Namespace Legend Members Public Methods REXDirectRevitExecute Methods

This is class REX.Common.REXDirectRevitExecute.

Class Hierarchy
C#
[Autodesk.Revit.Attributes.Transaction(Autodesk.Revit.Attributes.TransactionMode.Manual)]
[Autodesk.Revit.Attributes.Regeneration(Autodesk.Revit.Attributes.RegenerationOption.Manual)]
public class REXDirectRevitExecute : Autodesk.Revit.UI.IExternalCommand;
Namespace

REX.Common Namespace

Public Methods
Public Method | Description
REXDirectRevitExecute | This is REXDirectRevitExecute, a member of class REXDirectRevitExecute.
REXDirectRevitExecute Methods
REXDirectRevitExecute Methods | Description
Execute | This is Execute, a member of class REXDirectRevitExecute.
Execute | This is Execute, a member of class REXDirectRevitExecute.
Execute | This is Execute, a member of class REXDirectRevitExecute.
Execute | This is Execute, a member of class REXDirectRevitExecute.
Execute | This is Execute, a member of class REXDirectRevitExecute.
Links
REX.Common Namespace, Legend, Members, Public Methods, REXDirectRevitExecute Methods


REXDirectRevitExecute.REXDirectRevitExecute Constructor

REXDirectRevitExecute.REXDirectRevitExecute Constructor
REXDirectRevitExecute Class REX.Common Namespace REXDirectRevitExecute Class

This is REXDirectRevitExecute, a member of class REXDirectRevitExecute.

C#
public REXDirectRevitExecute(REXApplication application);
Class

REXDirectRevitExecute Class

Links
REXDirectRevitExecute Class, REX.Common Namespace, REXDirectRevitExecute Class


REXDirectRevitExecute.Execute Method (Autodesk.Revit.UI.ExternalCommandData, string, ElementSet)

REXDirectRevitExecute.Execute Method (Autodesk.Revit.UI.ExternalCommandData, string, ElementSet)
REXDirectRevitExecute Class REX.Common Namespace REXDirectRevitExecute Class

This is Execute, a member of class REXDirectRevitExecute.

C#
public Autodesk.Revit.UI.Result Execute(Autodesk.Revit.UI.ExternalCommandData commandData, ref string message, ElementSet elements);
Class

REXDirectRevitExecute Class

Links
REXDirectRevitExecute Class, REX.Common Namespace, REXDirectRevitExecute Class


REXDirectRevitExecute.Execute Method (Autodesk.Revit.UI.ExternalCommandData, string, ElementSet, REXMode, REXControlMode, string, Dictionary<string,object>)

REXDirectRevitExecute.Execute Method (Autodesk.Revit.UI.ExternalCommandData, string, ElementSet, REXMode, REXControlMode, string, Dictionary<string,object>)
REXDirectRevitExecute Class REX.Common Namespace REXDirectRevitExecute Class

This is Execute, a member of class REXDirectRevitExecute.

C#
public Autodesk.Revit.UI.Result Execute(Autodesk.Revit.UI.ExternalCommandData commandData, ref string message, ElementSet elements, REXMode mode, REXControlMode controlMode, string runContext, Dictionary<string,object> objects);
Class

REXDirectRevitExecute Class

Links
REXDirectRevitExecute Class, REX.Common Namespace, REXDirectRevitExecute Class


REXDirectRevitExecute.Execute Method (Document, REXMode, REXControlMode, string, List<Element>)

REXDirectRevitExecute.Execute Method (Document, REXMode, REXControlMode, string, List<Element>)
REXDirectRevitExecute Class REX.Common Namespace REXDirectRevitExecute Class

This is Execute, a member of class REXDirectRevitExecute.

C#
public Autodesk.Revit.UI.Result Execute(Document doc, REXMode mode, REXControlMode controlMode, string runContext, List<Element> elements);
Class

REXDirectRevitExecute Class

Links
REXDirectRevitExecute Class, REX.Common Namespace, REXDirectRevitExecute Class


REXDirectRevitExecute.Execute Method (Document, string, List<Element>)

REXDirectRevitExecute.Execute Method (Document, string, List<Element>)
REXDirectRevitExecute Class REX.Common Namespace REXDirectRevitExecute Class

This is Execute, a member of class REXDirectRevitExecute.

C#
public Autodesk.Revit.UI.Result Execute(Document doc, string runContext, List<Element> elements);
Class

REXDirectRevitExecute Class

Links
REXDirectRevitExecute Class, REX.Common Namespace, REXDirectRevitExecute Class


REXDirectRevitExecute.Execute Method (UpdaterData)

REXDirectRevitExecute.Execute Method (UpdaterData)
REXDirectRevitExecute Class REX.Common Namespace REXDirectRevitExecute Class

This is Execute, a member of class REXDirectRevitExecute.

C#
public Autodesk.Revit.UI.Result Execute(UpdaterData updaterData);
Class

REXDirectRevitExecute Class

Links
REXDirectRevitExecute Class, REX.Common Namespace, REXDirectRevitExecute Class


REXErrors Class

REXErrors Class
REX.Common Namespace Legend Members REXErrors Enumerations REXErrors Methods

Supprots REX errors for logging system.

Class Hierarchy
C#
public class REXErrors;
Description

It can be used for logging general errors in REX modules.

Namespace

REX.Common Namespace

REXErrors Enumerations
REXErrors Enumerations | Description
ErrorCode | Standard REX error codes.
REXErrors Methods
REXErrors Methods | Description
GetCategory | Returns category for specified error code.
GetMessage | Returns formated error string.
Links
REX.Common Namespace, Legend, Members, REXErrors Enumerations, REXErrors Methods


REX.Common.REXErrors.ErrorCode Enumeration

REX.Common.REXErrors.ErrorCode Enumeration
REXErrors Class

Standard REX error codes.

C#
public enum ErrorCode {
  eUNKNOWN = 0,
  eIO_EXCEPTION = 1,
  eMANAGER_NOT_FOUND = 1000,
  eMANAGER_EXECUTE_FAIL = 1001,
  eXML_PARSER_FATAL = 1500,
  eENGINE_CREATE_ASSEMBLY = 2000,
  eENGINE_APP_INTERFACE = 2001,
  eENGINE_LOAD_ENGINE = 2002,
  eENGINE_LOAD_PREFERENCES = 2003,
  eENGINE_LOAD_SYSTEM = 2004,
  eENGINE_REG = 2005,
  eENGINE_REG_LANGUAGE = 2006,
  eENGINE_LOAD_PRODUCT = 2007,
  eENGINE_BAD_ENV = 2008,
  ePREFS_LOAD_UNITS = 2020,
  ePREFS_NO_INT_UNITS = 2021,
  eSERVICE_START_FAIL = 3000,
  eSERVICE_STOP_FAIL = 3001
}
Members
Members | Description
eUNKNOWN | Unknown error.
eIO_EXCEPTION | Input / output exception
eMANAGER_NOT_FOUND | Internal REX error.
eMANAGER_EXECUTE_FAIL | Internal REX error.
eXML_PARSER_FATAL | Parser fail.
eENGINE_CREATE_ASSEMBLY | Internal REX engine error.
eENGINE_APP_INTERFACE | Internal REX engine error.
eENGINE_LOAD_ENGINE | Internal REX engine error.
eENGINE_LOAD_PREFERENCES | Internal REX engine error.
eENGINE_LOAD_SYSTEM | Internal REX engine error.
eENGINE_REG | Internal REX engine error.
eENGINE_REG_LANGUAGE | Internal REX engine error.
eENGINE_LOAD_PRODUCT | Internal REX engine error.
eENGINE_BAD_ENV | Internal REX engine error.
ePREFS_LOAD_UNITS | Internal REX engine error.
ePREFS_NO_INT_UNITS | Internal REX engine error.
eSERVICE_START_FAIL | Internal REX engine error.
eSERVICE_STOP_FAIL | Internal REX engine error.
Description
Class

REXErrors Class

Links
REXErrors Class
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXErrors.GetCategory Method

REXErrors.GetCategory Method
REXErrors Class REX.Common Namespace REXErrors Class

Returns category for specified error code.

C#
public static REXLogger.LogCategory GetCategory(ErrorCode e);
Parameters
Parameters | Description
e | The error code.
Returns

Returns LogCategory category.

Description
Class

REXErrors Class

Links
REXErrors Class, REX.Common Namespace, REXErrors Class


REXErrors.GetMessage Method

REXErrors.GetMessage Method
REXErrors Class REX.Common Namespace REXErrors Class

Returns formated error string.

C#
public static String GetMessage(ErrorCode e);
Parameters
Parameters | Description
e | Defined error code.
Returns

Returns string formated message.

Description
Class

REXErrors Class

Links
REXErrors Class, REX.Common Namespace, REXErrors Class


REXExtension Class

REXExtension Class
REX.Common Namespace Legend Members Public Methods REXExtension Methods REXExtension Properties

Additional functionality of REXExtension class.

Class Hierarchy
C#
public class REXExtension : IREXExtension4, IREXExtension3;
Description
Namespace

REX.Common Namespace

Public Methods
Public Method | Description
REXExtension | Initializes a new instance of the REXExtension class.
REXExtension Methods
REXExtension Methods | Description
AddCommands | Adds the commands.
ApplyStyle | This is ApplyStyle, a member of class REXExtension.
ApplyStyle | This is ApplyStyle, a member of class REXExtension.
Close | Close extension with all needed actions.
Close | Close extension with all needed actions.
Close | Close extension with all needed actions.
Command | Commands the specified command struct.
Create | Creates this extension.
Event | Events the specified event struct.
GetAPI | Get reference to main API object.
GetCaption | Get standard caption.
GetCaption | Get standard caption with additional information.
GetControl | Get reference to main control.
GetData | Get the data structure.
GetForm | Get reference to main form.
GetIcon | Get reference to icon.
GetResults | Get the results structure.
GetREXEnvironment | Get the reference to REX environment object.
GetTopWindowForParent | This is GetTopWindowForParent, a member of class REXExtension.
GetTopWindowHandleForParent | This is GetTopWindowHandleForParent, a member of class REXExtension.
GetWindow | Get reference to main form.
GetWindowForParent | Get the window for parent.
GetWindowHandleForParent | Get the window for parent.
Initialize | Initializes this instance.
OnActivateLayout | Activates or deactivates layout - module can modify layout before or after activation.
OnCanActivateLayout | Called when [can activate layout].
OnCanClose | If returns true, dialog will close after OK button clicked.
OnCanClose | Called when closing module.
OnCanRun | Checks status of module and shows some information for user if module can't complete action.
OnCheckValidity | Called when check validity.
OnClear | Called when clear.
OnClose | Called during closing module.
OnCommand | Called when command.
OnCreate | Creates needed structures and verify needs.
OnCreateDialogs | Creates sub dialogs.
OnCreateLayout | Creates layout items and setups layout.
OnDataLoad | Called when data load.
OnDataLoaded | Called when data loaded.
OnDataSave | Called when data save.
OnDataSaved | Called when data saved.
OnErrorSelected | Called when error selected on errors list dialog.
OnEvent | Called when event.
OnGetExtensionName | Called when get extension name.
OnGetText | Get specified text from resources.
OnInitialize | Called when Initialize.
OnLoadJournalingData | Called when load journaling data.
OnLoadTemplate | Called when load template.
OnPreferencesChanged | Called when preferences changed.
OnRegionalSettingsChanged | Called when regional settings changed.
OnRun | Runs process calculations or other operations.
OnSaveJournalingData | Called when save journaling data.
OnSaveTemplate | Called when save template.
OnSetContext | Called when regional settings changed.
OnSetData | Get data from dialogs and sets Data's strucutres.
OnSetDialogs | Set data in dialogs.
OnShowResults | Shows results.
OnUpdate | Called when update.
OnUpdateDialogs | Called when update dialogs.
ROHTMLDocument | Access to ROHTML's document.
ROHTMLReleaseDocument | Releases ROHTML's document.
Run | Runs process calculations or other operations.
RunQuestion | Runs the question.
SetCanClose | If the method will be called on OnCanRun method, Module will not close after return false.
SetContext | Initializes this instance.
SetCreateFail | If the method will be called on OnCreate method, Module will not continue work.
SetCreateFail | If the method will be called on OnCreate method, Module will not continue work.
Setup | Setups this extension.
SetupCommands | Initializes the commands.
SetupDefaultCommands | Initializes the default commands.
ShowMessageBox | This is ShowMessageBox, a member of class REXExtension.
ShowMessageBox | This is ShowMessageBox, a member of class REXExtension.
ShowMessageBox | This is ShowMessageBox, a member of class REXExtension.
ShowMessageBox | This is ShowMessageBox, a member of class REXExtension.
ShowMessageBox | This is ShowMessageBox, a member of class REXExtension.
ShowMessageBox | This is ShowMessageBox, a member of class REXExtension.
ShowMessageBox | This is ShowMessageBox, a member of class REXExtension.
ShowPreferencesDialog | This is ShowPreferencesDialog, a member of class REXExtension.
Status | Get current status of module.
REXExtension Properties
REXExtension Properties | Description
Context | Get the reference to current context object.
DFM | Gets the DFM object to manage all UI controls which support Revit Extension units.
ExtensionContext | Get the reference to the old extension context object.
Layout | Get the reference to Layout object.
MainAccess | Get the reference to object which controls interactions between module, and main application.
Preferences | Get the reference to Preferences object.
Progress | Get the reference to progress object.
Revit | Get the reference to object which controls interactions between module, and Revit.
Style | This is Style, a member of class REXExtension.
System | Get the reference to System object.
ThisApplication | Get this application.
ThisContext | Get the context.
ThisProduct | Gets the this product.
ThisRunContext | Gets the this run context.
UI | Get the reference to UI object.
Units | Get the reference to Units object.
Links
REX.Common Namespace, Legend, Members, Public Methods, REXExtension Methods, REXExtension Properties


REXExtension.REXExtension Constructor

REXExtension.REXExtension Constructor
REXExtension Class REX.Common Namespace REXExtension Class

Initializes a new instance of the REXExtension class.

C#
public REXExtension(REXApplication App);
Parameters
Parameters | Description
App | The reference to REXApplication object.
Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.AddCommands Method

REXExtension.AddCommands Method
REXExtension Class REX.Common Namespace REXExtension Class

Adds the commands.

C#
public virtual void AddCommands();
Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.ApplyStyle Method (Window)

REXExtension.ApplyStyle Method (Window)
REXExtension Class REX.Common Namespace REXExtension Class

This is ApplyStyle, a member of class REXExtension.

C#
public void ApplyStyle(Window window);
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.ApplyStyle Method (Window, string, string)

REXExtension.ApplyStyle Method (Window, string, string)
REXExtension Class REX.Common Namespace REXExtension Class

This is ApplyStyle, a member of class REXExtension.

C#
public void ApplyStyle(Window window, string assemblyFullPath, string stylesName);
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.Close Method ()

REXExtension.Close Method ()
REXExtension Class REX.Common Namespace REXExtension Class

Close extension with all needed actions.

C#
public virtual void Close();
Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.Close Method (DialogResult, bool)

REXExtension.Close Method (DialogResult, bool)
REXExtension Class REX.Common Namespace REXExtension Class

Close extension with all needed actions.

C#
public virtual void Close(DialogResult Result, bool HideManager);
Parameters
Parameters | Description
Result | The result.
HideManager | if set to true hide manager.
Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.Close Method (bool?, bool)

REXExtension.Close Method (bool?, bool)
REXExtension Class REX.Common Namespace REXExtension Class

Close extension with all needed actions.

C#
public virtual void Close(bool? Result, bool HideManager);
Parameters
Parameters | Description
Result | The result.
HideManager | if set to true hide manager.
Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.Command Method

REXExtension.Command Method
REXExtension Class REX.Common Namespace REXExtension Class

Commands the specified command struct.

C#
public virtual object Command(ref REXCommand CommandStruct);
Parameters
Parameters | Description
CommandStruct | The command struct.
Returns

Returns result of event operation.

Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.Create Method

REXExtension.Create Method
REXExtension Class REX.Common Namespace REXExtension Class

Creates this extension.

C#
public virtual bool Create();
Returns

Returns true if succeeded.

Description

Calls: OnInitialize(), OnCreate(), OnCreateDialogs() virtual methods.

Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.Event Method

REXExtension.Event Method
REXExtension Class REX.Common Namespace REXExtension Class

Events the specified event struct.

C#
public virtual object Event(ref REXEvent EventStruct);
Parameters
Parameters | Description
EventStruct | The event struct.
Returns

Returns result of event operation.

Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.GetAPI Method

REXExtension.GetAPI Method
REXExtension Class REX.Common Namespace REXExtension Class

Get reference to main API object.

C#
public virtual Object GetAPI();
Returns

Returns reference to main API object object.

Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.GetCaption Method ()

REXExtension.GetCaption Method ()
REXExtension Class REX.Common Namespace REXExtension Class

Get standard caption.

C#
public virtual string GetCaption();
Returns

Returns caption.

Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.GetCaption Method (string)

REXExtension.GetCaption Method (string)
REXExtension Class REX.Common Namespace REXExtension Class

Get standard caption with additional information.

C#
public virtual string GetCaption(string AdditionalText);
Returns

Returns caption.

Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.GetControl Method

REXExtension.GetControl Method
REXExtension Class REX.Common Namespace REXExtension Class

Get reference to main control.

C#
public virtual REXExtensionControl GetControl();
Returns

Returns reference to MainControl object based on REXExtensionControl object.

Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.GetData Method

REXExtension.GetData Method
REXExtension Class REX.Common Namespace REXExtension Class

Get the data structure.

C#
public virtual REXData GetData();
Returns

Returns reference to object based on REXData object.

Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.GetForm Method

REXExtension.GetForm Method
REXExtension Class REX.Common Namespace REXExtension Class

Get reference to main form.

C#
public virtual REXExtensionForm GetForm();
Returns

Returns reference to MainForm object based on REXExtensionForm object.

Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.GetIcon Method

REXExtension.GetIcon Method
REXExtension Class REX.Common Namespace REXExtension Class

Get reference to icon.

C#
public virtual System.Windows.Media.ImageSource GetIcon();
Returns

Returns reference to icon object.

Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.GetResults Method

REXExtension.GetResults Method
REXExtension Class REX.Common Namespace REXExtension Class

Get the results structure.

C#
public virtual REXResults GetResults();
Returns

Returns reference to object based on REXResults object.

Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.GetREXEnvironment Method

REXExtension.GetREXEnvironment Method
REXExtension Class REX.Common Namespace REXExtension Class

Get the reference to REX environment object.

C#
public virtual REXEnvironment GetREXEnvironment();
Returns

Returns reference to REXEnvironment object.

Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.GetTopWindowForParent Method

REXExtension.GetTopWindowForParent Method
REXExtension Class REX.Common Namespace REXExtension Class

This is GetTopWindowForParent, a member of class REXExtension.

C#
public virtual Window GetTopWindowForParent();
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.GetTopWindowHandleForParent Method

REXExtension.GetTopWindowHandleForParent Method
REXExtension Class REX.Common Namespace REXExtension Class

This is GetTopWindowHandleForParent, a member of class REXExtension.

C#
public virtual IWin32Window GetTopWindowHandleForParent();
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.GetWindow Method

REXExtension.GetWindow Method
REXExtension Class REX.Common Namespace REXExtension Class

Get reference to main form.

C#
public virtual REXExtensionWindow GetWindow();
Returns

Returns reference to MainForm object based on REXExtensionForm object.

Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.GetWindowForParent Method

REXExtension.GetWindowForParent Method
REXExtension Class REX.Common Namespace REXExtension Class

Get the window for parent.

C#
public virtual Window GetWindowForParent();
Returns

Returns IWin32Window interface for main window. If MainForm is visible, method returns reference to MainForm, otherwise returns reference to main application window.

Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.GetWindowHandleForParent Method

REXExtension.GetWindowHandleForParent Method
REXExtension Class REX.Common Namespace REXExtension Class

Get the window for parent.

C#
public virtual IWin32Window GetWindowHandleForParent();
Returns

Returns IWin32Window interface for main window. If MainForm is visible, method returns reference to MainForm, otherwise returns reference to main application window.

Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.Initialize Method

REXExtension.Initialize Method
REXExtension Class REX.Common Namespace REXExtension Class

Initializes this instance.

C#
public void Initialize();
Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.OnActivateLayout Method

REXExtension.OnActivateLayout Method
REXExtension Class REX.Common Namespace REXExtension Class

Activates or deactivates layout - module can modify layout before or after activation.

C#
public virtual void OnActivateLayout(REXLayoutItem LItem, bool Activate);
Parameters
Parameters | Description
LItem | The layout item.
Activate | If set to true, layout is activated.
Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.OnCanActivateLayout Method

REXExtension.OnCanActivateLayout Method
REXExtension Class REX.Common Namespace REXExtension Class

Called when [can activate layout].

C#
public virtual bool OnCanActivateLayout(REXLayoutItem LItem);
Parameters
Parameters | Description
LItem | The layout item.
Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.OnCanClose Method ()

REXExtension.OnCanClose Method ()
REXExtension Class REX.Common Namespace REXExtension Class

If returns true, dialog will close after OK button clicked.

C#
public virtual bool OnCanClose();
Returns

Returns true if module can be closed.

Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.OnCanClose Method (REXCanCloseType)

REXExtension.OnCanClose Method (REXCanCloseType)
REXExtension Class REX.Common Namespace REXExtension Class

Called when closing module.

C#
public virtual bool OnCanClose(REXCanCloseType Type);
Parameters
Parameters | Description
Type | The closing type. See REXCanCloseType enum.
Returns

Returns true if module can be closed.

Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.OnCanRun Method

REXExtension.OnCanRun Method
REXExtension Class REX.Common Namespace REXExtension Class

Checks status of module and shows some information for user if module can't complete action.

C#
public virtual bool OnCanRun();
Returns

Returns true if module can do some action in OnRun method; otherwise false.

Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.OnCheckValidity Method

REXExtension.OnCheckValidity Method
REXExtension Class REX.Common Namespace REXExtension Class

Called when check validity.

C#
public virtual bool? OnCheckValidity();
Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.OnClear Method

REXExtension.OnClear Method
REXExtension Class REX.Common Namespace REXExtension Class

Called when clear.

C#
public virtual bool OnClear(out bool Implemented);
Parameters
Parameters | Description
Implemented | If returns true, the method is implemented.
Returns

Returns result of clear operation.

Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.OnClose Method

REXExtension.OnClose Method
REXExtension Class REX.Common Namespace REXExtension Class

Called during closing module.

C#
public virtual void OnClose();
Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.OnCommand Method

REXExtension.OnCommand Method
REXExtension Class REX.Common Namespace REXExtension Class

Called when command.

C#
public virtual object OnCommand(ref REXCommand CommandStruct);
Parameters
Parameters | Description
CommandStruct | The command struct.
Returns

Returns result of command operation.

Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.OnCreate Method

REXExtension.OnCreate Method
REXExtension Class REX.Common Namespace REXExtension Class

Creates needed structures and verify needs.

C#
public virtual void OnCreate();
Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.OnCreateDialogs Method

REXExtension.OnCreateDialogs Method
REXExtension Class REX.Common Namespace REXExtension Class

Creates sub dialogs.

C#
public virtual void OnCreateDialogs();
Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.OnCreateLayout Method

REXExtension.OnCreateLayout Method
REXExtension Class REX.Common Namespace REXExtension Class

Creates layout items and setups layout.

C#
public virtual void OnCreateLayout();
Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.OnDataLoad Method

REXExtension.OnDataLoad Method
REXExtension Class REX.Common Namespace REXExtension Class

Called when data load.

C#
public virtual bool OnDataLoad();
Returns

Returns true if succeeded.

Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.OnDataLoaded Method

REXExtension.OnDataLoaded Method
REXExtension Class REX.Common Namespace REXExtension Class

Called when data loaded.

C#
public virtual void OnDataLoaded(bool Result);
Parameters
Parameters | Description
Result | If set to true operation succeeded; Otherwise some errors found.
Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.OnDataSave Method

REXExtension.OnDataSave Method
REXExtension Class REX.Common Namespace REXExtension Class

Called when data save.

C#
public virtual bool OnDataSave();
Returns

Returns true if succeeded.

Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.OnDataSaved Method

REXExtension.OnDataSaved Method
REXExtension Class REX.Common Namespace REXExtension Class

Called when data saved.

C#
public virtual void OnDataSaved(bool Result);
Parameters
Parameters | Description
Result | If set to true operation succeeded; Otherwise some errors found.
Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.OnErrorSelected Method

REXExtension.OnErrorSelected Method
REXExtension Class REX.Common Namespace REXExtension Class

Called when error selected on errors list dialog.

C#
public virtual void OnErrorSelected(REXErrorsEventArgs e);
Parameters
Parameters | Description
e | A Autodesk.REX.Framework.REXErrorsEventArgs instance containing the event data.
Description

Raises the ErrorSelected event.

Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.OnEvent Method

REXExtension.OnEvent Method
REXExtension Class REX.Common Namespace REXExtension Class

Called when event.

C#
public virtual object OnEvent(ref REXEvent EventStruct);
Parameters
Parameters | Description
EventStruct | The event struct.
Returns

Returns result of eventoperation.

Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.OnGetExtensionName Method

REXExtension.OnGetExtensionName Method
REXExtension Class REX.Common Namespace REXExtension Class

Called when get extension name.

C#
public virtual string OnGetExtensionName(REXExtensionNameContext nameContext);
Parameters
Parameters | Description
nameContext | The name context.
Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.OnGetText Method

REXExtension.OnGetText Method
REXExtension Class REX.Common Namespace REXExtension Class

Get specified text from resources.

C#
public virtual string OnGetText(string Name);
Parameters
Parameters | Description
Name | The name of string.
Returns

Returns specified text.

Description

Needed for obfuscated strings tables.

Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.OnInitialize Method

REXExtension.OnInitialize Method
REXExtension Class REX.Common Namespace REXExtension Class

Called when Initialize.

C#
public virtual bool OnInitialize();
Returns

Returns true if succeeded.

Description

Creates dedicated extension class according main context.

Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.OnLoadJournalingData Method

REXExtension.OnLoadJournalingData Method
REXExtension Class REX.Common Namespace REXExtension Class

Called when load journaling data.

C#
public virtual void OnLoadJournalingData();
Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.OnLoadTemplate Method

REXExtension.OnLoadTemplate Method
REXExtension Class REX.Common Namespace REXExtension Class

Called when load template.

C#
public virtual bool OnLoadTemplate();
Parameters
Parameters | Description
Result | If set to true operation succeeded; Otherwise some errors found.
Description

Only if ExtensionContext.Control.StandardRunContext is equals to REXExtensionContext.REXStandardRunContext.OperationEditTemplate.

Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.OnPreferencesChanged Method

REXExtension.OnPreferencesChanged Method
REXExtension Class REX.Common Namespace REXExtension Class

Called when preferences changed.

C#
public virtual void OnPreferencesChanged();
Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.OnRegionalSettingsChanged Method

REXExtension.OnRegionalSettingsChanged Method
REXExtension Class REX.Common Namespace REXExtension Class

Called when regional settings changed.

C#
public virtual void OnRegionalSettingsChanged();
Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.OnRun Method

REXExtension.OnRun Method
REXExtension Class REX.Common Namespace REXExtension Class

Runs process calculations or other operations.

C#
public virtual void OnRun();
Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.OnSaveJournalingData Method

REXExtension.OnSaveJournalingData Method
REXExtension Class REX.Common Namespace REXExtension Class

Called when save journaling data.

C#
public virtual void OnSaveJournalingData();
Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.OnSaveTemplate Method

REXExtension.OnSaveTemplate Method
REXExtension Class REX.Common Namespace REXExtension Class

Called when save template.

C#
public virtual bool OnSaveTemplate();
Parameters
Parameters | Description
Result | If set to true operation succeeded; Otherwise some errors found.
Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.OnSetContext Method

REXExtension.OnSetContext Method
REXExtension Class REX.Common Namespace REXExtension Class

Called when regional settings changed.

C#
public virtual void OnSetContext(REXContext context);
Parameters
Parameters | Description
context |
Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.OnSetData Method

REXExtension.OnSetData Method
REXExtension Class REX.Common Namespace REXExtension Class

Get data from dialogs and sets Data's strucutres.

C#
public virtual void OnSetData();
Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.OnSetDialogs Method

REXExtension.OnSetDialogs Method
REXExtension Class REX.Common Namespace REXExtension Class

Set data in dialogs.

C#
public virtual void OnSetDialogs();
Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.OnShowResults Method

REXExtension.OnShowResults Method
REXExtension Class REX.Common Namespace REXExtension Class

Shows results.

C#
public virtual void OnShowResults();
Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.OnUpdate Method

REXExtension.OnUpdate Method
REXExtension Class REX.Common Namespace REXExtension Class

Called when update.

C#
public virtual bool OnUpdate(out bool Implemented);
Parameters
Parameters | Description
Implemented | If returns true, the method is implemented.
Returns

Returns result of clear operation.

Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.OnUpdateDialogs Method

REXExtension.OnUpdateDialogs Method
REXExtension Class REX.Common Namespace REXExtension Class

Called when update dialogs.

C#
public virtual void OnUpdateDialogs();
Description

Currently is not used.

Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.ROHTMLDocument Method

REXExtension.ROHTMLDocument Method
REXExtension Class REX.Common Namespace REXExtension Class

Access to ROHTML's document.

C#
public ROHTMLLib.IXHTMLDocument ROHTMLDocument();
Returns

Returns ROHTMLLib.IXHTMLDocument interface.

Description

Creates, initializes and returns ROHTML's document.

Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.ROHTMLReleaseDocument Method

REXExtension.ROHTMLReleaseDocument Method
REXExtension Class REX.Common Namespace REXExtension Class

Releases ROHTML's document.

C#
public void ROHTMLReleaseDocument();
Parameters
Parameters | Description
ROHTMLDocument | The ROHTML document.
Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.Run Method

REXExtension.Run Method
REXExtension Class REX.Common Namespace REXExtension Class

Runs process calculations or other operations.

C#
public virtual bool Run();
Returns

Returns true if succeeded.

Description

Calls: OnSetData(), OnCanRun(), OnClear(), OnSaveTemplate(), OnRun(), OnShowResults() methods.

Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.RunQuestion Method

REXExtension.RunQuestion Method
REXExtension Class REX.Common Namespace REXExtension Class

Runs the question.

C#
public virtual bool RunQuestion(string Caption, string Text);
Parameters
Parameters | Description
Caption | The caption.
Text | The text.
Returns

If user selects "Yes" returns true, otherwise returns false.

Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.SetCanClose Method

REXExtension.SetCanClose Method
REXExtension Class REX.Common Namespace REXExtension Class

If the method will be called on OnCanRun method, Module will not close after return false.

C#
public virtual void SetCanClose(bool CanClose);
Parameters
Parameters | Description
CanClose | if set to true can close.
Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.SetContext Method

REXExtension.SetContext Method
REXExtension Class REX.Common Namespace REXExtension Class

Initializes this instance.

C#
public void SetContext();
Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.SetCreateFail Method ()

REXExtension.SetCreateFail Method ()
REXExtension Class REX.Common Namespace REXExtension Class

If the method will be called on OnCreate method, Module will not continue work.

C#
public virtual void SetCreateFail();
Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.SetCreateFail Method (string)

REXExtension.SetCreateFail Method (string)
REXExtension Class REX.Common Namespace REXExtension Class

If the method will be called on OnCreate method, Module will not continue work.

C#
public virtual void SetCreateFail(string Error);
Parameters
Parameters | Description
Error | An error string for message box.
Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.Setup Method

REXExtension.Setup Method
REXExtension Class REX.Common Namespace REXExtension Class

Setups this extension.

C#
public virtual void Setup();
Description

Calls: OnCreateLayout(), OnSetDialogs(), OnLoadTemplate() virtual methods.

Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.SetupCommands Method

REXExtension.SetupCommands Method
REXExtension Class REX.Common Namespace REXExtension Class

Initializes the commands.

C#
public virtual void SetupCommands();
Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.SetupDefaultCommands Method

REXExtension.SetupDefaultCommands Method
REXExtension Class REX.Common Namespace REXExtension Class

Initializes the default commands.

C#
public virtual void SetupDefaultCommands();
Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.ShowMessageBox Method (IWin32Window, string)

REXExtension.ShowMessageBox Method (IWin32Window, string)
REXExtension Class REX.Common Namespace REXExtension Class

This is ShowMessageBox, a member of class REXExtension.

C#
public DialogResult ShowMessageBox(IWin32Window owner, string text);
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.ShowMessageBox Method (IWin32Window, string, MessageBoxButtons)

REXExtension.ShowMessageBox Method (IWin32Window, string, MessageBoxButtons)
REXExtension Class REX.Common Namespace REXExtension Class

This is ShowMessageBox, a member of class REXExtension.

C#
public DialogResult ShowMessageBox(IWin32Window owner, string text, MessageBoxButtons buttons);
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.ShowMessageBox Method (Window, string)

REXExtension.ShowMessageBox Method (Window, string)
REXExtension Class REX.Common Namespace REXExtension Class

This is ShowMessageBox, a member of class REXExtension.

C#
public MessageBoxResult ShowMessageBox(Window owner, string text);
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.ShowMessageBox Method (Window, string, MessageBoxButton)

REXExtension.ShowMessageBox Method (Window, string, MessageBoxButton)
REXExtension Class REX.Common Namespace REXExtension Class

This is ShowMessageBox, a member of class REXExtension.

C#
public MessageBoxResult ShowMessageBox(Window owner, string text, MessageBoxButton buttons);
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.ShowMessageBox Method (string)

REXExtension.ShowMessageBox Method (string)
REXExtension Class REX.Common Namespace REXExtension Class

This is ShowMessageBox, a member of class REXExtension.

C#
public MessageBoxResult ShowMessageBox(string text);
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.ShowMessageBox Method (string, MessageBoxButton)

REXExtension.ShowMessageBox Method (string, MessageBoxButton)
REXExtension Class REX.Common Namespace REXExtension Class

This is ShowMessageBox, a member of class REXExtension.

C#
public MessageBoxResult ShowMessageBox(string text, MessageBoxButton buttons);
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.ShowMessageBox Method (string, MessageBoxButtons)

REXExtension.ShowMessageBox Method (string, MessageBoxButtons)
REXExtension Class REX.Common Namespace REXExtension Class

This is ShowMessageBox, a member of class REXExtension.

C#
public DialogResult ShowMessageBox(string text, MessageBoxButtons buttons);
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.ShowPreferencesDialog Method

REXExtension.ShowPreferencesDialog Method
REXExtension Class REX.Common Namespace REXExtension Class

This is ShowPreferencesDialog, a member of class REXExtension.

C#
public void ShowPreferencesDialog();
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.Status Method

REXExtension.Status Method
REXExtension Class REX.Common Namespace REXExtension Class

Get current status of module.

C#
public virtual object Status();
Returns

Returns status. See Autodesk.REX.Framework.REXStatusType.

Description
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.Context Property

REXExtension.Context Property
REXExtension Class REX.Common Namespace REXExtension Class

Get the reference to current context object.

C#
public REXContext Context;
Description

The context object.

Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.DFM Property

REXExtension.DFM Property
REXExtension Class REX.Common Namespace REXExtension Class

Gets the DFM object to manage all UI controls which support Revit Extension units.

C#
public REXDFM DFM;
Description

A reference to DFM object.

Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.ExtensionContext Property

REXExtension.ExtensionContext Property
REXExtension Class REX.Common Namespace REXExtension Class

Get the reference to the old extension context object.

C#
public REXExtensionContext ExtensionContext;
Description

The extension context object.

Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.Layout Property

REXExtension.Layout Property
REXExtension Class REX.Common Namespace REXExtension Class

Get the reference to Layout object.

C#
public REXLayout Layout;
Description

Uses for setting up layout of user interface of this module.

The Layout object.

Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.MainAccess Property

REXExtension.MainAccess Property
REXExtension Class REX.Common Namespace REXExtension Class

Get the reference to object which controls interactions between module, and main application.

C#
public REXAccess MainAccess;
Description

The reference to MainAccess object.

Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.Preferences Property

REXExtension.Preferences Property
REXExtension Class REX.Common Namespace REXExtension Class

Get the reference to Preferences object.

C#
public REXPreferences Preferences;
Description

The Preferences object.

Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.Progress Property

REXExtension.Progress Property
REXExtension Class REX.Common Namespace REXExtension Class

Get the reference to progress object.

C#
public Autodesk.REX.Framework.IREXProgress Progress;
Description

The progress object.

Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.Revit Property

REXExtension.Revit Property
REXExtension Class REX.Common Namespace REXExtension Class

Get the reference to object which controls interactions between module, and Revit.

C#
public REXRevitAccess Revit;
Description

The reference to RevitAccess object.

Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.Style Property

REXExtension.Style Property
REXExtension Class REX.Common Namespace REXExtension Class

This is Style, a member of class REXExtension.

C#
public ResourceDictionary Style;
Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.System Property

REXExtension.System Property
REXExtension Class REX.Common Namespace REXExtension Class

Get the reference to System object.

C#
public REXSystem System;
Description

Uses for some system's operations like as save or load data from file, units calculation, etc.

The System> object.

Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.ThisApplication Property

REXExtension.ThisApplication Property
REXExtension Class REX.Common Namespace REXExtension Class

Get this application.

C#
public REXApplication ThisApplication;
Description

This application.

Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.ThisContext Property

REXExtension.ThisContext Property
REXExtension Class REX.Common Namespace REXExtension Class

Get the context.

C#
public REXContext ThisContext;
Description

The context.

Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.ThisProduct Property

REXExtension.ThisProduct Property
REXExtension Class REX.Common Namespace REXExtension Class

Gets the this product.

C#
public REXInterfaceType ThisProduct;
Description

The this product.

Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.ThisRunContext Property

REXExtension.ThisRunContext Property
REXExtension Class REX.Common Namespace REXExtension Class

Gets the this run context.

C#
public REX.Common.REXExtensionContext.REXStandardRunContext ThisRunContext;
Description

The this run context.

Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.UI Property

REXExtension.UI Property
REXExtension Class REX.Common Namespace REXExtension Class

Get the reference to UI object.

C#
public REXUI UI;
Description

The UI object.

Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtension.Units Property

REXExtension.Units Property
REXExtension Class REX.Common Namespace REXExtension Class

Get the reference to Units object.

C#
public REXUnits Units;
Description

The Units object.

Class

REXExtension Class

Links
REXExtension Class, REX.Common Namespace, REXExtension Class


REXExtensionContext Class

REXExtensionContext Class
REX.Common Namespace Legend Members Public Methods REXExtensionContext Enumerations REXExtensionContext Fields REXExtensionContext Structures

Internal class for controlling behavior of the extension.

Class Hierarchy
C#
public class REXExtensionContext;
Description
Namespace

REX.Common Namespace

Public Methods
Public Method | Description
REXExtensionContext | Initializes a new instance of a REXExtensionContext class and sets defaults.
REXExtensionContext Enumerations
REXExtensionContext Enumerations | Description
REXLevelType | Level type.
REXStandardOwner | Owner of module.
REXStandardRunContext | Defines standard running context.
REXExtensionContext Fields
REXExtensionContext Fields | Description
Control | Reference to Control object.
REXExtensionContext Structures
REXExtensionContext Structures | Description
REXControl | Controls behavior of module.
REXControlFlags | Flags used for detecting forced settings.
Links
REX.Common Namespace, Legend, Members, Public Methods, REXExtensionContext Enumerations, REXExtensionContext Fields, REXExtensionContext Structures


REXExtensionContext.REXExtensionContext Constructor

REXExtensionContext.REXExtensionContext Constructor
REXExtensionContext Class REX.Common Namespace REXExtensionContext Class

Initializes a new instance of a REXExtensionContext class and sets defaults.

C#
public REXExtensionContext();
Description
Class

REXExtensionContext Class

Links
REXExtensionContext Class, REX.Common Namespace, REXExtensionContext Class


REXExtensionContext.REXControl Structure

REXExtensionContext.REXControl Structure
REXExtensionContext Class Legend Members REXControl Fields REXControl Properties

Controls behavior of module.

C#
public struct REXControl {
  public bool ShowErrorsDialog;
  public string RunContext;
  public REXStandardRunContext StandardRunContext;
  public bool VerifySelection;
  public bool APIContext;
  public bool NoUI;
  public bool LanguagesSupport;
  public bool ForceHideManager;
  public bool InteractiveCommand;
  public bool RegionalSettingsSupport;
  public REXLevelType LevelType;
  public REXStandardOwner StandardOwner;
  public string Owner;
  public REXControlFlags Flags;
}
Description
Class

REXExtensionContext Class

REXControl Fields
REXControl Fields | Description
APIContext | Indicates that module is running in API context.
Flags | Flags used for detecting forced settings.
ForceHideManager | Orders to hide manager of extensions.
InteractiveCommand | Indicates that module uses interactive modal dialog.
LanguagesSupport | Indicates that module has multi-language architecture.
LevelType | Level type.
NoUI | Indicates that module can't show any messages and dialogs.
Owner | Owner of extension.
RegionalSettingsSupport | If true, regional settings will be added to menu and toolbars.
RunContext | String which set up running context.
ShowErrorsDialog | Enables or disables showing of errors in dialog.
StandardOwner | Owner of extension.
StandardRunContext | String mapped to enum which set up running context.
VerifySelection | Indicates that module is running for verification current selection.
REXControl Properties
REXControl Properties | Description
UserInterface | Enables or disables user interface operations.
Links
REXExtensionContext Class, Legend, Members, REXControl Fields, REXControl Properties


REXExtensionContext.REXControl.APIContext Field

REXExtensionContext.REXControl.APIContext Field
REXExtensionContext.REXControl Structure REX.Common Namespace REXExtensionContext.REXControl Structure

Indicates that module is running in API context.

C#
public bool APIContext;
Description
Structure

REXExtensionContext.REXControl Structure

Links
REXExtensionContext.REXControl Structure, REX.Common Namespace, REXExtensionContext.REXControl Structure


REXExtensionContext.REXControl.Flags Field

REXExtensionContext.REXControl.Flags Field
REXExtensionContext.REXControl Structure REX.Common Namespace REXExtensionContext.REXControl Structure

Flags used for detecting forced settings.

C#
public REXControlFlags Flags;
Description
Structure

REXExtensionContext.REXControl Structure

Links
REXExtensionContext.REXControl Structure, REX.Common Namespace, REXExtensionContext.REXControl Structure


REXExtensionContext.REXControl.ForceHideManager Field

REXExtensionContext.REXControl.ForceHideManager Field
REXExtensionContext.REXControl Structure REX.Common Namespace REXExtensionContext.REXControl Structure

Orders to hide manager of extensions.

C#
public bool ForceHideManager;
Description
Structure

REXExtensionContext.REXControl Structure

Links
REXExtensionContext.REXControl Structure, REX.Common Namespace, REXExtensionContext.REXControl Structure


REXExtensionContext.REXControl.InteractiveCommand Field

REXExtensionContext.REXControl.InteractiveCommand Field
REXExtensionContext.REXControl Structure REX.Common Namespace REXExtensionContext.REXControl Structure

Indicates that module uses interactive modal dialog.

C#
public bool InteractiveCommand;
Description
Structure

REXExtensionContext.REXControl Structure

Links
REXExtensionContext.REXControl Structure, REX.Common Namespace, REXExtensionContext.REXControl Structure


REXExtensionContext.REXControl.LanguagesSupport Field

REXExtensionContext.REXControl.LanguagesSupport Field
REXExtensionContext.REXControl Structure REX.Common Namespace REXExtensionContext.REXControl Structure

Indicates that module has multi-language architecture.

C#
public bool LanguagesSupport;
Description
Structure

REXExtensionContext.REXControl Structure

Links
REXExtensionContext.REXControl Structure, REX.Common Namespace, REXExtensionContext.REXControl Structure


REXExtensionContext.REXControl.LevelType Field

REXExtensionContext.REXControl.LevelType Field
REXExtensionContext.REXControl Structure REX.Common Namespace REXExtensionContext.REXControl Structure

Level type.

C#
public REXLevelType LevelType;
Description
Structure

REXExtensionContext.REXControl Structure

Links
REXExtensionContext.REXControl Structure, REX.Common Namespace, REXExtensionContext.REXControl Structure


REXExtensionContext.REXControl.NoUI Field

REXExtensionContext.REXControl.NoUI Field
REXExtensionContext.REXControl Structure REX.Common Namespace REXExtensionContext.REXControl Structure

Indicates that module can't show any messages and dialogs.

C#
public bool NoUI;
Description
Structure

REXExtensionContext.REXControl Structure

Links
REXExtensionContext.REXControl Structure, REX.Common Namespace, REXExtensionContext.REXControl Structure


REXExtensionContext.REXControl.Owner Field

REXExtensionContext.REXControl.Owner Field
REXExtensionContext.REXControl Structure REX.Common Namespace REXExtensionContext.REXControl Structure

Owner of extension.

C#
public string Owner;
Description
Structure

REXExtensionContext.REXControl Structure

Links
REXExtensionContext.REXControl Structure, REX.Common Namespace, REXExtensionContext.REXControl Structure


REXExtensionContext.REXControl.RegionalSettingsSupport Field

REXExtensionContext.REXControl.RegionalSettingsSupport Field
REXExtensionContext.REXControl Structure REX.Common Namespace REXExtensionContext.REXControl Structure

If true, regional settings will be added to menu and toolbars.

C#
public bool RegionalSettingsSupport;
Description
Structure

REXExtensionContext.REXControl Structure

Links
REXExtensionContext.REXControl Structure, REX.Common Namespace, REXExtensionContext.REXControl Structure


REXExtensionContext.REXControl.RunContext Field

REXExtensionContext.REXControl.RunContext Field
REXExtensionContext.REXControl Structure REX.Common Namespace REXExtensionContext.REXControl Structure

String which set up running context.

C#
public string RunContext;
Description

Decides about output operation.

Structure

REXExtensionContext.REXControl Structure

Links
REXExtensionContext.REXControl Structure, REX.Common Namespace, REXExtensionContext.REXControl Structure


REXExtensionContext.REXControl.ShowErrorsDialog Field

REXExtensionContext.REXControl.ShowErrorsDialog Field
REXExtensionContext.REXControl Structure REX.Common Namespace REXExtensionContext.REXControl Structure

Enables or disables showing of errors in dialog.

C#
public bool ShowErrorsDialog;
Description
Structure

REXExtensionContext.REXControl Structure

Links
REXExtensionContext.REXControl Structure, REX.Common Namespace, REXExtensionContext.REXControl Structure


REXExtensionContext.REXControl.StandardOwner Field

REXExtensionContext.REXControl.StandardOwner Field
REXExtensionContext.REXControl Structure REX.Common Namespace REXExtensionContext.REXControl Structure

Owner of extension.

C#
public REXStandardOwner StandardOwner;
Description
Structure

REXExtensionContext.REXControl Structure

Links
REXExtensionContext.REXControl Structure, REX.Common Namespace, REXExtensionContext.REXControl Structure


REXExtensionContext.REXControl.StandardRunContext Field

REXExtensionContext.REXControl.StandardRunContext Field
REXExtensionContext.REXControl Structure REX.Common Namespace REXExtensionContext.REXControl Structure

String mapped to enum which set up running context.

C#
public REXStandardRunContext StandardRunContext;
Description

Decides about output operation.

Structure

REXExtensionContext.REXControl Structure

Links
REXExtensionContext.REXControl Structure, REX.Common Namespace, REXExtensionContext.REXControl Structure


REXExtensionContext.REXControl.VerifySelection Field

REXExtensionContext.REXControl.VerifySelection Field
REXExtensionContext.REXControl Structure REX.Common Namespace REXExtensionContext.REXControl Structure

Indicates that module is running for verification current selection.

C#
public bool VerifySelection;
Description
Structure

REXExtensionContext.REXControl Structure

Links
REXExtensionContext.REXControl Structure, REX.Common Namespace, REXExtensionContext.REXControl Structure


REXExtensionContext.REXControl.UserInterface Property

REXExtensionContext.REXControl.UserInterface Property
REXExtensionContext.REXControl Structure REX.Common Namespace REXExtensionContext.REXControl Structure

Enables or disables user interface operations.

C#
public bool UserInterface;
Description

Module may force these operations independently of main context.

Structure

REXExtensionContext.REXControl Structure

Links
REXExtensionContext.REXControl Structure, REX.Common Namespace, REXExtensionContext.REXControl Structure


REX.Common.REXExtensionContext.REXControlFlags Structure

REX.Common.REXExtensionContext.REXControlFlags Structure
REXExtensionContext Class

Flags used for detecting forced settings.

C#
public struct REXControlFlags {
  public bool UserInterface;
}
Description
Class

REXExtensionContext Class

Links
REXExtensionContext Class
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REX.Common.REXExtensionContext.REXLevelType Enumeration

REX.Common.REXExtensionContext.REXLevelType Enumeration
REXExtensionContext Class

Level type.

C#
public enum REXLevelType {
  Standard,
  RSA
}
Members
Members | Description
Standard | Standard extension.
RSA | RSA protection level.
Description
Class

REXExtensionContext Class

Links
REXExtensionContext Class
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REX.Common.REXExtensionContext.REXStandardOwner Enumeration

REX.Common.REXExtensionContext.REXStandardOwner Enumeration
REXExtensionContext Class

Owner of module.

C#
public enum REXStandardOwner {
  Parent = REXInterfaceType.None,
  Other = REXInterfaceType.Common,
  RSA = REXInterfaceType.Robot,
  ASD = REXInterfaceType.RCAD,
  Revit = REXInterfaceType.Revit
}
Members
Members | Description
Parent | Standard extension.
Other | Other protection level.
RSA | RSA.
ASD | ASD.
Revit | Revit.
Description
Class

REXExtensionContext Class

Links
REXExtensionContext Class
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REX.Common.REXExtensionContext.REXStandardRunContext Enumeration

REX.Common.REXExtensionContext.REXStandardRunContext Enumeration
REXExtensionContext Class

Defines standard running context.

C#
public enum REXStandardRunContext {
  None,
  Other,
  RCad,
  Robot,
  Revit,
  ESOP,
  CBS,
  OperationClear,
  OperationUpdate,
  OperationEditTemplate
}
Members
Members | Description
None | Module is running in standard mode.
Other | Module is running in unknown mode.
RCad | Module is running n order to transfer model to Autocad Structural Detailing.
Robot | Module is running in order to transfer model to Robot Structural Analysis.
Revit | Module is running in order to transfer model to Revit Strucutre, Architecture or MEP.
ESOP | Module is running in order to transfer model to Spreadsheet Calculator.
CBS | Module is running in order to transfer model to Concrete Building Strucutres.
OperationClear | Module is running in order to clear all previously generated elements.
OperationUpdate | Module is running in order to update elements.
OperationEditTemplate | Module is running in order to edit template.
Description

Set it from REXContext object.

Class

REXExtensionContext Class

Links
REXExtensionContext Class
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXExtensionContext.Control Field

REXExtensionContext.Control Field
REXExtensionContext Class REX.Common Namespace REXExtensionContext Class

Reference to Control object.

C#
public REXControl Control = new REXControl();
Description
Class

REXExtensionContext Class

Links
REXExtensionContext Class, REX.Common Namespace, REXExtensionContext Class


REXExtensionControl Class

REXExtensionControl Class
REX.Common Namespace Legend Members Public Methods REXExtensionControl Methods REXExtensionControl Properties

Base class for user controls.

Class Hierarchy
C#
public class REXExtensionControl : System.Windows.Controls.UserControl, IREXThisExtension;
Description

Enables easy access to main module's objects.

Namespace

REX.Common Namespace

Public Methods
Public Method | Description
REXExtensionControl | Initializes a new instance of a REXExtensionControl class.
REXExtensionControl | Initializes a new instance of a REXExtensionControl class.
REXExtensionControl Methods
REXExtensionControl Methods | Description
OnActivateLayout | Called when activate layout.
REXExtensionControl Properties
REXExtensionControl Properties | Description
ThisApplication | Get this application.
ThisContext | Get this context.
ThisExtension | Get this extension.
ThisProduct | Gets the this product.
ThisRunContext | Gets the this run context.
Links
REX.Common Namespace, Legend, Members, Public Methods, REXExtensionControl Methods, REXExtensionControl Properties


REXExtensionControl.REXExtensionControl Constructor ()

REXExtensionControl.REXExtensionControl Constructor ()
REXExtensionControl Class REX.Common Namespace REXExtensionControl Class

Initializes a new instance of a REXExtensionControl class.

C#
public REXExtensionControl();
Description
Class

REXExtensionControl Class

Links
REXExtensionControl Class, REX.Common Namespace, REXExtensionControl Class


REXExtensionControl.REXExtensionControl Constructor (REXExtension)

REXExtensionControl.REXExtensionControl Constructor (REXExtension)
REXExtensionControl Class REX.Common Namespace REXExtensionControl Class

Initializes a new instance of a REXExtensionControl class.

C#
public REXExtensionControl(REXExtension Ext);
Parameters
Parameters | Description
Ext | The reference to a REXExtension object.
Description
Class

REXExtensionControl Class

Links
REXExtensionControl Class, REX.Common Namespace, REXExtensionControl Class


REXExtensionControl.OnActivateLayout Method

REXExtensionControl.OnActivateLayout Method
REXExtensionControl Class REX.Common Namespace REXExtensionControl Class

Called when activate layout.

C#
public virtual void OnActivateLayout(ref REXLayoutItem LItem, bool Activate);
Parameters
Parameters | Description
LItem | The layout item.
Activate | If set to true,layout is activated.
Description
Class

REXExtensionControl Class

Links
REXExtensionControl Class, REX.Common Namespace, REXExtensionControl Class


REXExtensionControl.ThisApplication Property

REXExtensionControl.ThisApplication Property
REXExtensionControl Class REX.Common Namespace REXExtensionControl Class

Get this application.

C#
[Browsable(false)]
public REXApplication ThisApplication;
Description

This application.

Class

REXExtensionControl Class

Links
REXExtensionControl Class, REX.Common Namespace, REXExtensionControl Class


REXExtensionControl.ThisContext Property

REXExtensionControl.ThisContext Property
REXExtensionControl Class REX.Common Namespace REXExtensionControl Class

Get this context.

C#
[Browsable(false)]
public REXContext ThisContext;
Description

This context.

Class

REXExtensionControl Class

Links
REXExtensionControl Class, REX.Common Namespace, REXExtensionControl Class


REXExtensionControl.ThisExtension Property

REXExtensionControl.ThisExtension Property
REXExtensionControl Class REX.Common Namespace REXExtensionControl Class

Get this extension.

C#
[Browsable(false)]
public REXExtension ThisExtension;
Description

This extension.

Class

REXExtensionControl Class

Links
REXExtensionControl Class, REX.Common Namespace, REXExtensionControl Class


REXExtensionControl.ThisProduct Property

REXExtensionControl.ThisProduct Property
REXExtensionControl Class REX.Common Namespace REXExtensionControl Class

Gets the this product.

C#
public REXInterfaceType ThisProduct;
Description

The this product.

Class

REXExtensionControl Class

Links
REXExtensionControl Class, REX.Common Namespace, REXExtensionControl Class


REXExtensionControl.ThisRunContext Property

REXExtensionControl.ThisRunContext Property
REXExtensionControl Class REX.Common Namespace REXExtensionControl Class

Gets the this run context.

C#
public REX.Common.REXExtensionContext.REXStandardRunContext ThisRunContext;
Description

The this run context.

Class

REXExtensionControl Class

Links
REXExtensionControl Class, REX.Common Namespace, REXExtensionControl Class


REXExtensionData Class

REXExtensionData Class
REX.Common Namespace Legend Members Public Methods REXExtensionData Enumerations REXExtensionData Methods REXExtensionData Properties

Base class for REXData and REXResults classes.

Class Hierarchy
C#
public class REXExtensionData : REXExtensionObject;
Description

Allows these structures serialization, loading and saving.

Namespace

REX.Common Namespace

Public Methods
Public Method | Description
REXExtensionData | Initializes a new instance of the REXExtensionData class.
REXExtensionData Enumerations
REXExtensionData Enumerations | Description
DataMode | Determines the target of serialization.
DataType | Determines the data type.
OperationStatus | Determines the status after operation.
REXExtensionData Methods
REXExtensionData Methods | Description
CompareData | Compares the data with another data.
CompareData | Compares the data with another data.
Load | Loads data strucuture from a BinaryReader object.
LoadHeader | Loads data strucuture from a BinaryReader object.
LoadHeader | Loads data strucuture from a BinaryReader object.
LoadHeader | This is LoadHeader, a member of class REXExtensionData.
Save | Saves data structure to a BinaryWriter object.
SaveHeader | Saves data structure to a BinaryWriter object.
SaveHeader | This is SaveHeader, a member of class REXExtensionData.
SetDefaults | Sets the defaults.
REXExtensionData Properties
REXExtensionData Properties | Description
DateTimeData | Get the date and time of data which load.
DateTimeDataCreation | Get the creation date and time of data which load.
EnableDynamicUpdate | This is EnableDynamicUpdate, a member of class REXExtensionData.
LoadedRegionalSettings | This is LoadedRegionalSettings, a member of class REXExtensionData.
Mode | Get or set the mode.
NoHeader | This is NoHeader, a member of class REXExtensionData.
ProductType | Loaded product type
RunContext | Loaded run context
StandardRunContext | Loaded standard run context
Status | Get or set the status.
Version | Get the current version.
VersionData | Get the version data which load.
Links
REX.Common Namespace, Legend, Members, Public Methods, REXExtensionData Enumerations, REXExtensionData Methods, REXExtensionData Properties


REXExtensionData.REXExtensionData Constructor

REXExtensionData.REXExtensionData Constructor
REXExtensionData Class REX.Common Namespace REXExtensionData Class

Initializes a new instance of the REXExtensionData class.

C#
public REXExtensionData(REXExtension Ext);
Parameters
Parameters | Description
Ext | The reference to a REXExtension object.
Description
Class

REXExtensionData Class

Links
REXExtensionData Class, REX.Common Namespace, REXExtensionData Class


REX.Common.REXExtensionData.DataMode Enumeration

REX.Common.REXExtensionData.DataMode Enumeration
REXExtensionData Class

Determines the target of serialization.

C#
public enum DataMode {
  ModeNone,
  ModeFile,
  ModeObject,
  ModeProject,
  ModeJournaling
}
Members
Members | Description
ModeNone | Unknown target.
ModeFile | Serialization to file.
ModeObject | Serialization to object.
ModeProject | Serialization to project.
ModeJournaling | Serialization to journaling.
Description
Class

REXExtensionData Class

Links
REXExtensionData Class
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REX.Common.REXExtensionData.DataType Enumeration

REX.Common.REXExtensionData.DataType Enumeration
REXExtensionData Class

Determines the data type.

C#
public enum DataType {
  Data,
  Results
}
Members
Members | Description
Data | Data.
Results | Results.
Description
Class

REXExtensionData Class

Links
REXExtensionData Class
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REX.Common.REXExtensionData.OperationStatus Enumeration

REX.Common.REXExtensionData.OperationStatus Enumeration
REXExtensionData Class

Determines the status after operation.

C#
public enum OperationStatus {
  OperationStatusOK,
  OperationStatusError,
  OperationStatusErrorData,
  OperationStatusBadExtension,
  OperationStatusNewExtension,
  OperationStatusDiffrentGeometry,
  OperationStatusDiffrentParams
}
Members
Members | Description
OperationStatusOK | All is ok.
OperationStatusError | Unknown error during operation.
OperationStatusErrorData | Unknown error during operation on data structures.
OperationStatusBadExtension | Trying to load data from another module.
OperationStatusNewExtension | Trying to load data from a newer module.
OperationStatusDiffrentGeometry | Geometry of element is diffrent (multiselection).
OperationStatusDiffrentParams | Parameters of element are diffrent (multiselection).
Description
Class

REXExtensionData Class

Links
REXExtensionData Class
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXExtensionData.CompareData Method (REXExtensionData)

REXExtensionData.CompareData Method (REXExtensionData)
REXExtensionData Class REX.Common Namespace REXExtensionData Class

Compares the data with another data.

C#
public int CompareData(REXExtensionData Data);
Parameters
Parameters | Description
Data | The data to compare.
Returns

Returns -1 if specified Data is older, 0 if equal, and 1 if specified Data is newer.

Description

Uses version and date time marker.

Class

REXExtensionData Class

Links
REXExtensionData Class, REX.Common Namespace, REXExtensionData Class


REXExtensionData.CompareData Method (REXExtensionData, bool)

REXExtensionData.CompareData Method (REXExtensionData, bool)
REXExtensionData Class REX.Common Namespace REXExtensionData Class

Compares the data with another data.

C#
public int CompareData(REXExtensionData Data, bool CompareOnlyDateTime);
Parameters
Parameters | Description
Data | The data to compare.
CompareOnlyDateTime | if set to true compare only date time.
Returns

Returns -1 if specified Data is older, 0 if equal, and 1 if specified Data is newer.

Description

Uses version and date time marker optionally.

Class

REXExtensionData Class

Links
REXExtensionData Class, REX.Common Namespace, REXExtensionData Class


REXExtensionData.Load Method

REXExtensionData.Load Method
REXExtensionData Class REX.Common Namespace REXExtensionData Class

Loads data strucuture from a BinaryReader object.

C#
public bool Load(ref BinaryReader Data, DataMode DataModeSet);
Parameters
Parameters | Description
Data | The data.
DataModeSet | The data mode set.
Returns

Returns true if succeeded.

Description
Class

REXExtensionData Class

Links
REXExtensionData Class, REX.Common Namespace, REXExtensionData Class


REXExtensionData.LoadHeader Method (BinaryReader, DataMode)

REXExtensionData.LoadHeader Method (BinaryReader, DataMode)
REXExtensionData Class REX.Common Namespace REXExtensionData Class

Loads data strucuture from a BinaryReader object.

C#
public bool LoadHeader(ref BinaryReader Data, DataMode DataModeSet);
Parameters
Parameters | Description
Data | The data.
DataModeSet | The data mode set.
Returns

Returns true if succeeded.

Description
Class

REXExtensionData Class

Links
REXExtensionData Class, REX.Common Namespace, REXExtensionData Class


REXExtensionData.LoadHeader Method (BinaryReader, DataMode, bool)

REXExtensionData.LoadHeader Method (BinaryReader, DataMode, bool)
REXExtensionData Class REX.Common Namespace REXExtensionData Class

Loads data strucuture from a BinaryReader object.

C#
public bool LoadHeader(ref BinaryReader Data, DataMode DataModeSet, bool CheckExtensionsModuleData);
Parameters
Parameters | Description
Data | The data.
DataModeSet | The data mode set.
Returns

Returns true if succeeded.

Description
Class

REXExtensionData Class

Links
REXExtensionData Class, REX.Common Namespace, REXExtensionData Class


REXExtensionData.LoadHeader Method (REXStorageExtensionHeader)

REXExtensionData.LoadHeader Method (REXStorageExtensionHeader)
REXExtensionData Class REX.Common Namespace REXExtensionData Class

This is LoadHeader, a member of class REXExtensionData.

C#
public void LoadHeader(REXStorageExtensionHeader header);
Class

REXExtensionData Class

Links
REXExtensionData Class, REX.Common Namespace, REXExtensionData Class


REXExtensionData.Save Method

REXExtensionData.Save Method
REXExtensionData Class REX.Common Namespace REXExtensionData Class

Saves data structure to a BinaryWriter object.

C#
public bool Save(ref BinaryWriter Data, DataMode DataModeSet);
Parameters
Parameters | Description
Data | The data.
DataModeSet | The data mode set.
Returns

Returns true if succeeded.

Description
Class

REXExtensionData Class

Links
REXExtensionData Class, REX.Common Namespace, REXExtensionData Class


REXExtensionData.SaveHeader Method (BinaryWriter, DataMode)

REXExtensionData.SaveHeader Method (BinaryWriter, DataMode)
REXExtensionData Class REX.Common Namespace REXExtensionData Class

Saves data structure to a BinaryWriter object.

C#
public bool SaveHeader(ref BinaryWriter Data, DataMode DataModeSet);
Parameters
Parameters | Description
Data | The data.
DataModeSet | The data mode set.
Returns

Returns true if succeeded.

Description
Class

REXExtensionData Class

Links
REXExtensionData Class, REX.Common Namespace, REXExtensionData Class


REXExtensionData.SaveHeader Method (REXStorageExtensionHeader)

REXExtensionData.SaveHeader Method (REXStorageExtensionHeader)
REXExtensionData Class REX.Common Namespace REXExtensionData Class

This is SaveHeader, a member of class REXExtensionData.

C#
public void SaveHeader(REXStorageExtensionHeader header);
Class

REXExtensionData Class

Links
REXExtensionData Class, REX.Common Namespace, REXExtensionData Class


REXExtensionData.SetDefaults Method

REXExtensionData.SetDefaults Method
REXExtensionData Class REX.Common Namespace REXExtensionData Class

Sets the defaults.

C#
public void SetDefaults();
Description
Class

REXExtensionData Class

Links
REXExtensionData Class, REX.Common Namespace, REXExtensionData Class


REXExtensionData.DateTimeData Property

REXExtensionData.DateTimeData Property
REXExtensionData Class REX.Common Namespace REXExtensionData Class

Get the date and time of data which load.

C#
public DateTime DateTimeData;
Description

The date and time of data.

Class

REXExtensionData Class

Links
REXExtensionData Class, REX.Common Namespace, REXExtensionData Class


REXExtensionData.DateTimeDataCreation Property

REXExtensionData.DateTimeDataCreation Property
REXExtensionData Class REX.Common Namespace REXExtensionData Class

Get the creation date and time of data which load.

C#
public DateTime DateTimeDataCreation;
Description

The date and time of data.

Class

REXExtensionData Class

Links
REXExtensionData Class, REX.Common Namespace, REXExtensionData Class


REXExtensionData.EnableDynamicUpdate Property

REXExtensionData.EnableDynamicUpdate Property
REXExtensionData Class REX.Common Namespace REXExtensionData Class

This is EnableDynamicUpdate, a member of class REXExtensionData.

C#
public bool EnableDynamicUpdate;
Class

REXExtensionData Class

Links
REXExtensionData Class, REX.Common Namespace, REXExtensionData Class


REXExtensionData.LoadedRegionalSettings Property

REXExtensionData.LoadedRegionalSettings Property
REXExtensionData Class REX.Common Namespace REXExtensionData Class

This is LoadedRegionalSettings, a member of class REXExtensionData.

C#
public Autodesk.REX.Framework.IREXRegionalSettings LoadedRegionalSettings;
Class

REXExtensionData Class

Links
REXExtensionData Class, REX.Common Namespace, REXExtensionData Class


REXExtensionData.Mode Property

REXExtensionData.Mode Property
REXExtensionData Class REX.Common Namespace REXExtensionData Class

Get or set the mode.

C#
public DataMode Mode;
Description

The mode.

Class

REXExtensionData Class

Links
REXExtensionData Class, REX.Common Namespace, REXExtensionData Class


REXExtensionData.NoHeader Property

REXExtensionData.NoHeader Property
REXExtensionData Class REX.Common Namespace REXExtensionData Class

This is NoHeader, a member of class REXExtensionData.

C#
public bool NoHeader;
Class

REXExtensionData Class

Links
REXExtensionData Class, REX.Common Namespace, REXExtensionData Class


REXExtensionData.ProductType Property

REXExtensionData.ProductType Property
REXExtensionData Class REX.Common Namespace REXExtensionData Class

Loaded product type

C#
public REXInterfaceType ProductType;
Class

REXExtensionData Class

Links
REXExtensionData Class, REX.Common Namespace, REXExtensionData Class


REXExtensionData.RunContext Property

REXExtensionData.RunContext Property
REXExtensionData Class REX.Common Namespace REXExtensionData Class

Loaded run context

C#
public string RunContext;
Class

REXExtensionData Class

Links
REXExtensionData Class, REX.Common Namespace, REXExtensionData Class


REXExtensionData.StandardRunContext Property

REXExtensionData.StandardRunContext Property
REXExtensionData Class REX.Common Namespace REXExtensionData Class

Loaded standard run context

C#
public REXExtensionContext.REXStandardRunContext StandardRunContext;
Class

REXExtensionData Class

Links
REXExtensionData Class, REX.Common Namespace, REXExtensionData Class


REXExtensionData.Status Property

REXExtensionData.Status Property
REXExtensionData Class REX.Common Namespace REXExtensionData Class

Get or set the status.

C#
public OperationStatus Status;
Description

The status.

Class

REXExtensionData Class

Links
REXExtensionData Class, REX.Common Namespace, REXExtensionData Class


REXExtensionData.Version Property

REXExtensionData.Version Property
REXExtensionData Class REX.Common Namespace REXExtensionData Class

Get the current version.

C#
public long Version;
Description

The version.

Class

REXExtensionData Class

Links
REXExtensionData Class, REX.Common Namespace, REXExtensionData Class


REXExtensionData.VersionData Property

REXExtensionData.VersionData Property
REXExtensionData Class REX.Common Namespace REXExtensionData Class

Get the version data which load.

C#
public long VersionData;
Description

The version data.

Class

REXExtensionData Class

Links
REXExtensionData Class, REX.Common Namespace, REXExtensionData Class


REXExtensionDataSerializable Class

REXExtensionDataSerializable Class
REX.Common Namespace Legend Members Public Methods REXExtensionDataSerializable Methods

Base class for REXDataSerializable and REXResultsSerializable classes.

Class Hierarchy
C#
[Serializable]
public class REXExtensionDataSerializable : System.Runtime.Serialization.ISerializableinternalclassREXExtensionDataSerializable:System.Runtime.Serialization.ISerializable;
Description

Allows these structures standard .NET serialization, loading and saving.

Namespace

REX.Common Namespace

Public Methods
Public Method | Description
REXExtensionDataSerializable | Initializes a new instance of the REXExtensionDataSerializable class.
REXExtensionDataSerializable Methods
REXExtensionDataSerializable Methods | Description
GetObjectData | A required method by ISerializable to serialize the object.
Links
REX.Common Namespace, Legend, Members, Public Methods, REXExtensionDataSerializable Methods


REXExtensionDataSerializable.REXExtensionDataSerializable Constructor

REXExtensionDataSerializable.REXExtensionDataSerializable Constructor
REXExtensionDataSerializable Class REX.Common Namespace REXExtensionDataSerializable Class

Initializes a new instance of the REXExtensionDataSerializable class.

C#
public REXExtensionDataSerializable();
Description
Class

REXExtensionDataSerializable Class

Links
REXExtensionDataSerializable Class, REX.Common Namespace, REXExtensionDataSerializable Class


REXExtensionDataSerializable.GetObjectData Method

REXExtensionDataSerializable.GetObjectData Method
REXExtensionDataSerializable Class REX.Common Namespace Example REXExtensionDataSerializable Class

A required method by ISerializable to serialize the object.

C#
public virtual void GetObjectData(System.Runtime.Serialization.SerializationInfo info, System.Runtime.Serialization.StreamingContext ctx);
Parameters
Parameters | Description
info | The info.
ctx | The CTX.
Description

Simply add variables to be serialized as name/value pairs to SerializationInfo object. Here you decide which member variables to serialize. Note that any name can be used to identify each serialized field

Example
public virtual void GetObjectData(System.Runtime.Serialization.SerializationInfo info, System.Runtime.Serialization.StreamingContext ctx)
{
    info.AddValue("s1", strPrivate);
    info.AddValue("s2", strPublic);
    into.AddValue("ob", obMyClass);       // Serializing an object
}
Class

REXExtensionDataSerializable Class

Links
REXExtensionDataSerializable Class, REX.Common Namespace, Example, REXExtensionDataSerializable Class


REXExtensionMainControl Class

REXExtensionMainControl Class
REX.Common Namespace Legend Members Public Methods REXExtensionMainControl Properties

Base class for main control.

Class Hierarchy
C#
public class REXExtensionMainControl : REXExtensionControl;
Description

Enables easy access to main module's objects and support additional actions.

Namespace

REX.Common Namespace

Public Methods
Public Method | Description
REXExtensionMainControl | Initializes a new instance of a REXExtensionMainControl class.
REXExtensionMainControl | Initializes a new instance of a REXExtensionMainControl class.
REXExtensionMainControl Properties
REXExtensionMainControl Properties | Description
Components | Get the component.
Links
REX.Common Namespace, Legend, Members, Public Methods, REXExtensionMainControl Properties


REXExtensionMainControl.REXExtensionMainControl Constructor ()

REXExtensionMainControl.REXExtensionMainControl Constructor ()
REXExtensionMainControl Class REX.Common Namespace REXExtensionMainControl Class

Initializes a new instance of a REXExtensionMainControl class.

C#
public REXExtensionMainControl();
Description
Class

REXExtensionMainControl Class

Links
REXExtensionMainControl Class, REX.Common Namespace, REXExtensionMainControl Class


REXExtensionMainControl.REXExtensionMainControl Constructor (REXExtension)

REXExtensionMainControl.REXExtensionMainControl Constructor (REXExtension)
REXExtensionMainControl Class REX.Common Namespace REXExtensionMainControl Class

Initializes a new instance of a REXExtensionMainControl class.

C#
public REXExtensionMainControl(REXExtension Ext);
Parameters
Parameters | Description
Ext | The reference to a REXExtension object.
Description
Class

REXExtensionMainControl Class

Links
REXExtensionMainControl Class, REX.Common Namespace, REXExtensionMainControl Class


REXExtensionMainControl.Components Property

REXExtensionMainControl.Components Property
REXExtensionMainControl Class REX.Common Namespace REXExtensionMainControl Class

Get the component.

C#
public virtual IContainer Components;
Description

The component.

Class

REXExtensionMainControl Class

Links
REXExtensionMainControl Class, REX.Common Namespace, REXExtensionMainControl Class


REXExtensionObject Class

REXExtensionObject Class
REX.Common Namespace Legend Members Public Methods REXExtensionObject Properties

Base class for all objects created in extension module.

Class Hierarchy
C#
public class REXExtensionObject : IREXThisExtension;
Description
Namespace

REX.Common Namespace

Public Methods
Public Method | Description
REXExtensionObject | Initializes a new instance of a REXExtensionObject class.
REXExtensionObject Properties
REXExtensionObject Properties | Description
ThisApplication | Get the application.
ThisContext | Get the context.
ThisExtension | Get the extension.
ThisProduct | Gets the this product.
ThisRunContext | Gets the this run context.
Links
REX.Common Namespace, Legend, Members, Public Methods, REXExtensionObject Properties


REXExtensionObject.REXExtensionObject Constructor

REXExtensionObject.REXExtensionObject Constructor
REXExtensionObject Class REX.Common Namespace REXExtensionObject Class

Initializes a new instance of a REXExtensionObject class.

C#
public REXExtensionObject(REXExtension Extension);
Parameters
Parameters | Description
Extension | The extension.
Description
Class

REXExtensionObject Class

Links
REXExtensionObject Class, REX.Common Namespace, REXExtensionObject Class


REXExtensionObject.ThisApplication Property

REXExtensionObject.ThisApplication Property
REXExtensionObject Class REX.Common Namespace REXExtensionObject Class

Get the application.

C#
public REXApplication ThisApplication;
Description

The application.

Class

REXExtensionObject Class

Links
REXExtensionObject Class, REX.Common Namespace, REXExtensionObject Class


REXExtensionObject.ThisContext Property

REXExtensionObject.ThisContext Property
REXExtensionObject Class REX.Common Namespace REXExtensionObject Class

Get the context.

C#
public REXContext ThisContext;
Description

The context.

Class

REXExtensionObject Class

Links
REXExtensionObject Class, REX.Common Namespace, REXExtensionObject Class


REXExtensionObject.ThisExtension Property

REXExtensionObject.ThisExtension Property
REXExtensionObject Class REX.Common Namespace REXExtensionObject Class

Get the extension.

C#
public REXExtension ThisExtension;
Description

The extension.

Class

REXExtensionObject Class

Links
REXExtensionObject Class, REX.Common Namespace, REXExtensionObject Class


REXExtensionObject.ThisProduct Property

REXExtensionObject.ThisProduct Property
REXExtensionObject Class REX.Common Namespace REXExtensionObject Class

Gets the this product.

C#
public REXInterfaceType ThisProduct;
Description

The this product.

Class

REXExtensionObject Class

Links
REXExtensionObject Class, REX.Common Namespace, REXExtensionObject Class


REXExtensionObject.ThisRunContext Property

REXExtensionObject.ThisRunContext Property
REXExtensionObject Class REX.Common Namespace REXExtensionObject Class

Gets the this run context.

C#
public REX.Common.REXExtensionContext.REXStandardRunContext ThisRunContext;
Description

The this run context.

Class

REXExtensionObject Class

Links
REXExtensionObject Class, REX.Common Namespace, REXExtensionObject Class


REXExtensionPanel Class

REXExtensionPanel Class
REX.Common Namespace Legend Members Public Methods REXExtensionPanel Methods REXExtensionPanel Properties

Base class for panel control.

Class Hierarchy
C#
public class REXExtensionPanel : System.Windows.Controls.Panel, IREXThisExtension;
Description

Enables easy access to main module's objects and support additional actions. Additionally enables one instane control container.

Namespace

REX.Common Namespace

Public Methods
Public Method | Description
REXExtensionPanel | Initializes a new instance of a REXExtensionForm class.
REXExtensionPanel | Initializes a new instance of a REXExtensionForm class.
REXExtensionPanel Methods
REXExtensionPanel Methods | Description
SetControl | Sets the control.
REXExtensionPanel Properties
REXExtensionPanel Properties | Description
ThisApplication | Get this application.
ThisContext | Get this context.
ThisExtension | Get this extension.
ThisProduct | Gets the this product.
ThisRunContext | Gets the this run context.
Links
REX.Common Namespace, Legend, Members, Public Methods, REXExtensionPanel Methods, REXExtensionPanel Properties


REXExtensionPanel.REXExtensionPanel Constructor ()

REXExtensionPanel.REXExtensionPanel Constructor ()
REXExtensionPanel Class REX.Common Namespace REXExtensionPanel Class

Initializes a new instance of a REXExtensionForm class.

C#
public REXExtensionPanel();
Description
Class

REXExtensionPanel Class

Links
REXExtensionPanel Class, REX.Common Namespace, REXExtensionPanel Class


REXExtensionPanel.REXExtensionPanel Constructor (REXExtension)

REXExtensionPanel.REXExtensionPanel Constructor (REXExtension)
REXExtensionPanel Class REX.Common Namespace REXExtensionPanel Class

Initializes a new instance of a REXExtensionForm class.

C#
public REXExtensionPanel(REXExtension Ext);
Parameters
Parameters | Description
Ext | The reference to a REXExtension object.
Description
Class

REXExtensionPanel Class

Links
REXExtensionPanel Class, REX.Common Namespace, REXExtensionPanel Class


REXExtensionPanel.SetControl Method

REXExtensionPanel.SetControl Method
REXExtensionPanel Class REX.Common Namespace REXExtensionPanel Class

Sets the control.

C#
public void SetControl(System.Windows.Controls.Control control, System.Windows.Controls.Control controlMain, bool OneInstance);
Parameters
Parameters | Description
control | The control.
OneInstance | if set to true controls one instance of user control.
Description
Class

REXExtensionPanel Class

Links
REXExtensionPanel Class, REX.Common Namespace, REXExtensionPanel Class


REXExtensionPanel.ThisApplication Property

REXExtensionPanel.ThisApplication Property
REXExtensionPanel Class REX.Common Namespace REXExtensionPanel Class

Get this application.

C#
[Browsable(false)]
public REXApplication ThisApplication;
Description

This application.

Class

REXExtensionPanel Class

Links
REXExtensionPanel Class, REX.Common Namespace, REXExtensionPanel Class


REXExtensionPanel.ThisContext Property

REXExtensionPanel.ThisContext Property
REXExtensionPanel Class REX.Common Namespace REXExtensionPanel Class

Get this context.

C#
[Browsable(false)]
public REXContext ThisContext;
Description

This context.

Class

REXExtensionPanel Class

Links
REXExtensionPanel Class, REX.Common Namespace, REXExtensionPanel Class


REXExtensionPanel.ThisExtension Property

REXExtensionPanel.ThisExtension Property
REXExtensionPanel Class REX.Common Namespace REXExtensionPanel Class

Get this extension.

C#
[Browsable(false)]
public REXExtension ThisExtension;
Description

This extension.

Class

REXExtensionPanel Class

Links
REXExtensionPanel Class, REX.Common Namespace, REXExtensionPanel Class


REXExtensionPanel.ThisProduct Property

REXExtensionPanel.ThisProduct Property
REXExtensionPanel Class REX.Common Namespace REXExtensionPanel Class

Gets the this product.

C#
public REXInterfaceType ThisProduct;
Description

The this product.

Class

REXExtensionPanel Class

Links
REXExtensionPanel Class, REX.Common Namespace, REXExtensionPanel Class


REXExtensionPanel.ThisRunContext Property

REXExtensionPanel.ThisRunContext Property
REXExtensionPanel Class REX.Common Namespace REXExtensionPanel Class

Gets the this run context.

C#
public REX.Common.REXExtensionContext.REXStandardRunContext ThisRunContext;
Description

The this run context.

Class

REXExtensionPanel Class

Links
REXExtensionPanel Class, REX.Common Namespace, REXExtensionPanel Class


REXExtensionProduct Class

REXExtensionProduct Class
REX.Common Namespace Legend Members Public Methods REXExtensionProduct Methods

Represents the Extension element used by the main Extension class to separate product dependent part of the code from general one.

Class Hierarchy
C#
public class REXExtensionProduct : REX.Common.REXExtensionObject, REX.Common.IREXExtension;
Description

It mainly concerns external API (e.g. RevitAPI).

Namespace

REX.Common Namespace

Public Methods
Public Method | Description
REXExtensionProduct | Initializes a new instance of the REXExtensionFactory class.
REXExtensionProduct Methods
REXExtensionProduct Methods | Description
OnActivateLayout | Activates or deactivates layout - module can modify layout before or after activation.
OnCanClose | If returns true dialog will close after OK button is clicked.
OnCanClose | If returns true dialog will close after OK button is clicked.
OnCanRun | Checks status of module and shows some information for user if module can't excecute action.
OnClear | Called when data are cleared.
OnClose | Called during closing module.
OnCommand | Commands the specified command struct.
OnCreate | Creates needed structures and verify needs.
OnCreateDialogs | Creates sub dialogs.
OnCreateLayout | Creates layout items and setups layout.
OnDataLoad | Called when data are loaded.
OnDataLoaded | Called when data loaded.
OnDataSave | Called when data are saved.
OnDataSaved | Called when data are saved.
OnErrorSelected | Called when an error is selected on errors list dialog.
OnEvent | Called when event.
OnGetText | Get specified text from resources.
OnInitialize | Called when Initialize.
OnLoadTemplate | Called when template is loaded.
OnPreferencesChanged | Called when preferences changed.
OnRun | Runs process calculations or other operations.
OnSaveTemplate | Called when template is saved.
OnSetData | Get data from dialogs and sets Data's strucutres.
OnSetDialogs | Set data on dialogs.
OnShowResults | Shows results.
OnUpdateDialogs | This is OnUpdateDialogs, a member of class REXExtensionProduct.
Links
REX.Common Namespace, Legend, Members, Public Methods, REXExtensionProduct Methods


REXExtensionProduct.REXExtensionProduct Constructor

REXExtensionProduct.REXExtensionProduct Constructor
REXExtensionProduct Class REX.Common Namespace REXExtensionProduct Class

Initializes a new instance of the REXExtensionFactory class.

C#
public REXExtensionProduct(REXExtension extension);
Parameters
Parameters | Description
extension | The extension.
Description
Class

REXExtensionProduct Class

Links
REXExtensionProduct Class, REX.Common Namespace, REXExtensionProduct Class


REXExtensionProduct.OnActivateLayout Method

REXExtensionProduct.OnActivateLayout Method
REXExtensionProduct Class REX.Common Namespace REXExtensionProduct Class

Activates or deactivates layout - module can modify layout before or after activation.

C#
public virtual void OnActivateLayout(REX.Common.REXLayoutItem LItem, bool Activate);
Parameters
Parameters | Description
LItem | The layout item.
Activate | If set to true activate.
Description
Class

REXExtensionProduct Class

Links
REXExtensionProduct Class, REX.Common Namespace, REXExtensionProduct Class


REXExtensionProduct.OnCanClose Method ()

REXExtensionProduct.OnCanClose Method ()
REXExtensionProduct Class REX.Common Namespace REXExtensionProduct Class

If returns true dialog will close after OK button is clicked.

C#
public virtual bool OnCanClose();
Returns

Returns true if module can be closed.

Description
Class

REXExtensionProduct Class

Links
REXExtensionProduct Class, REX.Common Namespace, REXExtensionProduct Class


REXExtensionProduct.OnCanClose Method (REX.Common.REXCanCloseType)

REXExtensionProduct.OnCanClose Method (REX.Common.REXCanCloseType)
REXExtensionProduct Class REX.Common Namespace REXExtensionProduct Class

If returns true dialog will close after OK button is clicked.

C#
public virtual bool OnCanClose(REX.Common.REXCanCloseType Type);
Parameters
Parameters | Description
Type | The closing type. See REXCanCloseType enum.
Returns

Returns true if module can be closed.

Description
Class

REXExtensionProduct Class

Links
REXExtensionProduct Class, REX.Common Namespace, REXExtensionProduct Class


REXExtensionProduct.OnCanRun Method

REXExtensionProduct.OnCanRun Method
REXExtensionProduct Class REX.Common Namespace REXExtensionProduct Class

Checks status of module and shows some information for user if module can't excecute action.

C#
public virtual bool OnCanRun();
Returns

Returns true if module can do some action in OnRun method; otherwise false.

Description
Class

REXExtensionProduct Class

Links
REXExtensionProduct Class, REX.Common Namespace, REXExtensionProduct Class


REXExtensionProduct.OnClear Method

REXExtensionProduct.OnClear Method
REXExtensionProduct Class REX.Common Namespace REXExtensionProduct Class

Called when data are cleared.

C#
public virtual bool OnClear(out bool Implemented);
Parameters
Parameters | Description
Implemented | If returns true method was implemented.
Returns

Returns result of clear operation.

Description
Class

REXExtensionProduct Class

Links
REXExtensionProduct Class, REX.Common Namespace, REXExtensionProduct Class


REXExtensionProduct.OnClose Method

REXExtensionProduct.OnClose Method
REXExtensionProduct Class REX.Common Namespace REXExtensionProduct Class

Called during closing module.

C#
public virtual void OnClose();
Description
Class

REXExtensionProduct Class

Links
REXExtensionProduct Class, REX.Common Namespace, REXExtensionProduct Class


REXExtensionProduct.OnCommand Method

REXExtensionProduct.OnCommand Method
REXExtensionProduct Class REX.Common Namespace REXExtensionProduct Class

Commands the specified command struct.

C#
public virtual object OnCommand(ref REXCommand CommandStruct);
Parameters
Parameters | Description
CommandStruct | The command struct.
Returns

Returns result of event operation.

Description
Class

REXExtensionProduct Class

Links
REXExtensionProduct Class, REX.Common Namespace, REXExtensionProduct Class


REXExtensionProduct.OnCreate Method

REXExtensionProduct.OnCreate Method
REXExtensionProduct Class REX.Common Namespace REXExtensionProduct Class

Creates needed structures and verify needs.

C#
public virtual void OnCreate();
Description
Class

REXExtensionProduct Class

Links
REXExtensionProduct Class, REX.Common Namespace, REXExtensionProduct Class


REXExtensionProduct.OnCreateDialogs Method

REXExtensionProduct.OnCreateDialogs Method
REXExtensionProduct Class REX.Common Namespace REXExtensionProduct Class

Creates sub dialogs.

C#
public virtual void OnCreateDialogs();
Description
Class

REXExtensionProduct Class

Links
REXExtensionProduct Class, REX.Common Namespace, REXExtensionProduct Class


REXExtensionProduct.OnCreateLayout Method

REXExtensionProduct.OnCreateLayout Method
REXExtensionProduct Class REX.Common Namespace REXExtensionProduct Class

Creates layout items and setups layout.

C#
public virtual void OnCreateLayout();
Description
Class

REXExtensionProduct Class

Links
REXExtensionProduct Class, REX.Common Namespace, REXExtensionProduct Class


REXExtensionProduct.OnDataLoad Method

REXExtensionProduct.OnDataLoad Method
REXExtensionProduct Class REX.Common Namespace REXExtensionProduct Class

Called when data are loaded.

C#
public virtual bool OnDataLoad();
Returns

Returns true if succeeded.

Description
Class

REXExtensionProduct Class

Links
REXExtensionProduct Class, REX.Common Namespace, REXExtensionProduct Class


REXExtensionProduct.OnDataLoaded Method

REXExtensionProduct.OnDataLoaded Method
REXExtensionProduct Class REX.Common Namespace REXExtensionProduct Class

Called when data loaded.

C#
public virtual void OnDataLoaded(bool Result);
Parameters
Parameters | Description
Result | If set to true operation succeeded; Otherwise some errors found.
Description
Class

REXExtensionProduct Class

Links
REXExtensionProduct Class, REX.Common Namespace, REXExtensionProduct Class


REXExtensionProduct.OnDataSave Method

REXExtensionProduct.OnDataSave Method
REXExtensionProduct Class REX.Common Namespace REXExtensionProduct Class

Called when data are saved.

C#
public virtual bool OnDataSave();
Returns

Returns true if succeeded.

Description
Class

REXExtensionProduct Class

Links
REXExtensionProduct Class, REX.Common Namespace, REXExtensionProduct Class


REXExtensionProduct.OnDataSaved Method

REXExtensionProduct.OnDataSaved Method
REXExtensionProduct Class REX.Common Namespace REXExtensionProduct Class

Called when data are saved.

C#
public virtual void OnDataSaved(bool Result);
Parameters
Parameters | Description
Result | If set to true operation succeeded; Otherwise some errors found.
Description
Class

REXExtensionProduct Class

Links
REXExtensionProduct Class, REX.Common Namespace, REXExtensionProduct Class


REXExtensionProduct.OnErrorSelected Method

REXExtensionProduct.OnErrorSelected Method
REXExtensionProduct Class REX.Common Namespace REXExtensionProduct Class

Called when an error is selected on errors list dialog.

C#
public virtual void OnErrorSelected(Autodesk.REX.Framework.REXErrorsEventArgs e);
Parameters
Parameters | Description
e | The Autodesk.REX.Framework.REXErrorsEventArgs instance containing the event data.
Description

Raises the ErrorSelected event.

Class

REXExtensionProduct Class

Links
REXExtensionProduct Class, REX.Common Namespace, REXExtensionProduct Class


REXExtensionProduct.OnEvent Method

REXExtensionProduct.OnEvent Method
REXExtensionProduct Class REX.Common Namespace REXExtensionProduct Class

Called when event.

C#
public virtual object OnEvent(ref REXEvent EventStruct);
Parameters
Parameters | Description
EventStruct | The event struct.
Returns

Returns result of event operation.

Description
Class

REXExtensionProduct Class

Links
REXExtensionProduct Class, REX.Common Namespace, REXExtensionProduct Class


REXExtensionProduct.OnGetText Method

REXExtensionProduct.OnGetText Method
REXExtensionProduct Class REX.Common Namespace REXExtensionProduct Class

Get specified text from resources.

C#
public virtual string OnGetText(string Name);
Parameters
Parameters | Description
Name | The name of string.
Returns

Returns specified text.

Description

Needed for obfuscated strings tables.

Class

REXExtensionProduct Class

Links
REXExtensionProduct Class, REX.Common Namespace, REXExtensionProduct Class


REXExtensionProduct.OnInitialize Method

REXExtensionProduct.OnInitialize Method
REXExtensionProduct Class REX.Common Namespace REXExtensionProduct Class

Called when Initialize.

C#
public virtual bool OnInitialize();
Description

Creates dedicated extension class according main context.

Class

REXExtensionProduct Class

Links
REXExtensionProduct Class, REX.Common Namespace, REXExtensionProduct Class


REXExtensionProduct.OnLoadTemplate Method

REXExtensionProduct.OnLoadTemplate Method
REXExtensionProduct Class REX.Common Namespace REXExtensionProduct Class

Called when template is loaded.

C#
public virtual bool OnLoadTemplate();
Parameters
Parameters | Description
Result | If set to true operation succeeded; Otherwise some errors found.
Description

Only if ExtensionContext.Control.StandardRunContext is equals to REXExtensionContext.REXStandardRunContext.OperationEditTemplate.

Class

REXExtensionProduct Class

Links
REXExtensionProduct Class, REX.Common Namespace, REXExtensionProduct Class


REXExtensionProduct.OnPreferencesChanged Method

REXExtensionProduct.OnPreferencesChanged Method
REXExtensionProduct Class REX.Common Namespace REXExtensionProduct Class

Called when preferences changed.

C#
public virtual void OnPreferencesChanged();
Description
Class

REXExtensionProduct Class

Links
REXExtensionProduct Class, REX.Common Namespace, REXExtensionProduct Class


REXExtensionProduct.OnRun Method

REXExtensionProduct.OnRun Method
REXExtensionProduct Class REX.Common Namespace REXExtensionProduct Class

Runs process calculations or other operations.

C#
public virtual void OnRun();
Description
Class

REXExtensionProduct Class

Links
REXExtensionProduct Class, REX.Common Namespace, REXExtensionProduct Class


REXExtensionProduct.OnSaveTemplate Method

REXExtensionProduct.OnSaveTemplate Method
REXExtensionProduct Class REX.Common Namespace REXExtensionProduct Class

Called when template is saved.

C#
public virtual bool OnSaveTemplate();
Parameters
Parameters | Description
Result | If set to true operation succeeded; Otherwise some errors found.
Description
Class

REXExtensionProduct Class

Links
REXExtensionProduct Class, REX.Common Namespace, REXExtensionProduct Class


REXExtensionProduct.OnSetData Method

REXExtensionProduct.OnSetData Method
REXExtensionProduct Class REX.Common Namespace REXExtensionProduct Class

Get data from dialogs and sets Data's strucutres.

C#
public virtual void OnSetData();
Description
Class

REXExtensionProduct Class

Links
REXExtensionProduct Class, REX.Common Namespace, REXExtensionProduct Class


REXExtensionProduct.OnSetDialogs Method

REXExtensionProduct.OnSetDialogs Method
REXExtensionProduct Class REX.Common Namespace REXExtensionProduct Class

Set data on dialogs.

C#
public virtual void OnSetDialogs();
Description
Class

REXExtensionProduct Class

Links
REXExtensionProduct Class, REX.Common Namespace, REXExtensionProduct Class


REXExtensionProduct.OnShowResults Method

REXExtensionProduct.OnShowResults Method
REXExtensionProduct Class REX.Common Namespace REXExtensionProduct Class

Shows results.

C#
public virtual void OnShowResults();
Description
Class

REXExtensionProduct Class

Links
REXExtensionProduct Class, REX.Common Namespace, REXExtensionProduct Class


REXExtensionProduct.OnUpdateDialogs Method

REXExtensionProduct.OnUpdateDialogs Method
REXExtensionProduct Class REX.Common Namespace REXExtensionProduct Class

This is OnUpdateDialogs, a member of class REXExtensionProduct.

C#
public virtual void OnUpdateDialogs();
Class

REXExtensionProduct Class

Links
REXExtensionProduct Class, REX.Common Namespace, REXExtensionProduct Class


REXExtensionSettings Class

REXExtensionSettings Class
REX.Common Namespace Legend Members Public Methods REXExtensionSettings Methods REXExtensionSettings Properties

Allows reading base settings from "Configuration / settings.xml" file.

Class Hierarchy
C#
public class REXExtensionSettings : REXExtensionBaseSettings, IREXThisExtensioninternalclassREXExtensionSettings:REXExtensionBaseSettings, IREXThisExtension;
Description
Namespace

REX.Common Namespace

Public Methods
Public Method | Description
REXExtensionSettings | Initializes a new instance of the REXExtensionSettings class.
REXExtensionSettings | Initializes a new instance of the REXExtensionSettings class.
REXExtensionSettings Methods
REXExtensionSettings Methods | Description
LoadSettings | This is LoadSettings, a member of class REXExtensionSettings.
REXExtensionSettings Properties
REXExtensionSettings Properties | Description
ThisApplication | Get the application.
ThisContext | Get the context.
ThisExtension | Get the extension.
Links
REX.Common Namespace, Legend, Members, Public Methods, REXExtensionSettings Methods, REXExtensionSettings Properties


REXExtensionSettings.REXExtensionSettings Constructor (Autodesk.REX.Framework.REXContext)

REXExtensionSettings.REXExtensionSettings Constructor (Autodesk.REX.Framework.REXContext)
REXExtensionSettings Class REX.Common Namespace REXExtensionSettings Class

Initializes a new instance of the REXExtensionSettings class.

C#
public REXExtensionSettings(Autodesk.REX.Framework.REXContext Ctx);
Parameters
Parameters | Description
Ctx | The reference to a REXContext object.
Description
Class

REXExtensionSettings Class

Links
REXExtensionSettings Class, REX.Common Namespace, REXExtensionSettings Class


REXExtensionSettings.REXExtensionSettings Constructor (REXExtension)

REXExtensionSettings.REXExtensionSettings Constructor (REXExtension)
REXExtensionSettings Class REX.Common Namespace REXExtensionSettings Class

Initializes a new instance of the REXExtensionSettings class.

C#
public REXExtensionSettings(REXExtension Ext);
Parameters
Parameters | Description
Ext | The reference to a REXExtension object.
Description
Class

REXExtensionSettings Class

Links
REXExtensionSettings Class, REX.Common Namespace, REXExtensionSettings Class


REXExtensionSettings.LoadSettings Method

REXExtensionSettings.LoadSettings Method
REXExtensionSettings Class REX.Common Namespace REXExtensionSettings Class

This is LoadSettings, a member of class REXExtensionSettings.

C#
public override bool LoadSettings();
Class

REXExtensionSettings Class

Links
REXExtensionSettings Class, REX.Common Namespace, REXExtensionSettings Class


REXExtensionSettings.ThisApplication Property

REXExtensionSettings.ThisApplication Property
REXExtensionSettings Class REX.Common Namespace REXExtensionSettings Class

Get the application.

C#
public REXApplication ThisApplication;
Description

The application.

Class

REXExtensionSettings Class

Links
REXExtensionSettings Class, REX.Common Namespace, REXExtensionSettings Class


REXExtensionSettings.ThisContext Property

REXExtensionSettings.ThisContext Property
REXExtensionSettings Class REX.Common Namespace REXExtensionSettings Class

Get the context.

C#
public REXContext ThisContext;
Description

The context.

Class

REXExtensionSettings Class

Links
REXExtensionSettings Class, REX.Common Namespace, REXExtensionSettings Class


REXExtensionSettings.ThisExtension Property

REXExtensionSettings.ThisExtension Property
REXExtensionSettings Class REX.Common Namespace REXExtensionSettings Class

Get the extension.

C#
public REXExtension ThisExtension;
Description

The extension.

Class

REXExtensionSettings Class

Links
REXExtensionSettings Class, REX.Common Namespace, REXExtensionSettings Class


REXExtensionWindow Class

REXExtensionWindow Class
REX.Common Namespace Legend Members Public Methods REXExtensionWindow Properties

Base class for user forms.

Class Hierarchy
C#
public class REXExtensionWindow : Window, IREXThisExtension;
Description

Enables easy access to main module's objects.

Namespace

REX.Common Namespace

Public Methods
Public Method | Description
REXExtensionWindow | Initializes a new instance of a REXExtensionForm class.
REXExtensionWindow | Initializes a new instance of a REXExtensionForm class.
REXExtensionWindow Properties
REXExtensionWindow Properties | Description
ThisApplication | Get this application.
ThisContext | Get this context.
ThisExtension | Get this extension.
ThisProduct | Gets the this product.
ThisRunContext | Gets the this run context.
WindowStatus | This is WindowStatus, a member of class REXExtensionWindow.
Links
REX.Common Namespace, Legend, Members, Public Methods, REXExtensionWindow Properties


REXExtensionWindow.REXExtensionWindow Constructor ()

REXExtensionWindow.REXExtensionWindow Constructor ()
REXExtensionWindow Class REX.Common Namespace REXExtensionWindow Class

Initializes a new instance of a REXExtensionForm class.

C#
public REXExtensionWindow();
Description
Class

REXExtensionWindow Class

Links
REXExtensionWindow Class, REX.Common Namespace, REXExtensionWindow Class


REXExtensionWindow.REXExtensionWindow Constructor (REXExtension)

REXExtensionWindow.REXExtensionWindow Constructor (REXExtension)
REXExtensionWindow Class REX.Common Namespace REXExtensionWindow Class

Initializes a new instance of a REXExtensionForm class.

C#
public REXExtensionWindow(REXExtension Ext);
Parameters
Parameters | Description
Ext | The reference to a REXExtension object.
Description
Class

REXExtensionWindow Class

Links
REXExtensionWindow Class, REX.Common Namespace, REXExtensionWindow Class


REXExtensionWindow.ThisApplication Property

REXExtensionWindow.ThisApplication Property
REXExtensionWindow Class REX.Common Namespace REXExtensionWindow Class

Get this application.

C#
[Browsable(false)]
public REXApplication ThisApplication;
Description

This application.

Class

REXExtensionWindow Class

Links
REXExtensionWindow Class, REX.Common Namespace, REXExtensionWindow Class


REXExtensionWindow.ThisContext Property

REXExtensionWindow.ThisContext Property
REXExtensionWindow Class REX.Common Namespace REXExtensionWindow Class

Get this context.

C#
[Browsable(false)]
public REXContext ThisContext;
Description

This context.

Class

REXExtensionWindow Class

Links
REXExtensionWindow Class, REX.Common Namespace, REXExtensionWindow Class


REXExtensionWindow.ThisExtension Property

REXExtensionWindow.ThisExtension Property
REXExtensionWindow Class REX.Common Namespace REXExtensionWindow Class

Get this extension.

C#
[Browsable(false)]
public REXExtension ThisExtension;
Description

This extension.

Class

REXExtensionWindow Class

Links
REXExtensionWindow Class, REX.Common Namespace, REXExtensionWindow Class


REXExtensionWindow.ThisProduct Property

REXExtensionWindow.ThisProduct Property
REXExtensionWindow Class REX.Common Namespace REXExtensionWindow Class

Gets the this product.

C#
public REXInterfaceType ThisProduct;
Description

The this product.

Class

REXExtensionWindow Class

Links
REXExtensionWindow Class, REX.Common Namespace, REXExtensionWindow Class


REXExtensionWindow.ThisRunContext Property

REXExtensionWindow.ThisRunContext Property
REXExtensionWindow Class REX.Common Namespace REXExtensionWindow Class

Gets the this run context.

C#
public REX.Common.REXExtensionContext.REXStandardRunContext ThisRunContext;
Description

The this run context.

Class

REXExtensionWindow Class

Links
REXExtensionWindow Class, REX.Common Namespace, REXExtensionWindow Class


REXExtensionWindow.WindowStatus Property

REXExtensionWindow.WindowStatus Property
REXExtensionWindow Class REX.Common Namespace REXExtensionWindow Class

This is WindowStatus, a member of class REXExtensionWindow.

C#
public REXStatusType WindowStatus;
Class

REXExtensionWindow Class

Links
REXExtensionWindow Class, REX.Common Namespace, REXExtensionWindow Class


REXFoundationApplication Class

REXFoundationApplication Class
REX.Common Namespace Legend Members Public Methods REXFoundationApplication Methods

Foundation class for REX.Foundation usage.

Class Hierarchy
C#
public class REXFoundationApplication : Autodesk.REX.Framework.IREXApplication4;
Description
Namespace

REX.Common Namespace

Public Methods
Public Method | Description
REXFoundationApplication | Initializes a new instance of the REXApplication class.
REXFoundationApplication Methods
REXFoundationApplication Methods | Description
Close | Closes this instance.
Command | Commands the specified command struct.
Control | Controls this instance.
Create | Creates and shows module as modal dialog.
Create | Creates and shows module as modal dialog.
Event | Called when event.
GetService | Gets the the service.
GetUniqueId | Returns the unique id for the module
Modal | Creates and shows module as modal dialog.
Modal | Creates and shows module as modal dialog.
Show | Shows this module.
Links
REX.Common Namespace, Legend, Members, Public Methods, REXFoundationApplication Methods


REXFoundationApplication.REXFoundationApplication Constructor

REXFoundationApplication.REXFoundationApplication Constructor
REXFoundationApplication Class REX.Common Namespace REXFoundationApplication Class

Initializes a new instance of the REXApplication class.

C#
public REXFoundationApplication();
Description
Class

REXFoundationApplication Class

Links
REXFoundationApplication Class, REX.Common Namespace, REXFoundationApplication Class


REXFoundationApplication.Close Method

REXFoundationApplication.Close Method
REXFoundationApplication Class REX.Common Namespace REXFoundationApplication Class

Closes this instance.

C#
public void Close();
Description
Class

REXFoundationApplication Class

Links
REXFoundationApplication Class, REX.Common Namespace, REXFoundationApplication Class


REXFoundationApplication.Command Method

REXFoundationApplication.Command Method
REXFoundationApplication Class REX.Common Namespace REXFoundationApplication Class

Commands the specified command struct.

C#
public object Command(ref Autodesk.REX.Framework.REXCommand CommandStruct);
Parameters
Parameters | Description
CommandStruct | The command struct.
Description
Class

REXFoundationApplication Class

Links
REXFoundationApplication Class, REX.Common Namespace, REXFoundationApplication Class


REXFoundationApplication.Control Method

REXFoundationApplication.Control Method
REXFoundationApplication Class REX.Common Namespace REXFoundationApplication Class

Controls this instance.

C#
public object Control();
Description
Class

REXFoundationApplication Class

Links
REXFoundationApplication Class, REX.Common Namespace, REXFoundationApplication Class


REXFoundationApplication.Create Method (Autodesk.REX.Framework.REXApplicationContext)

REXFoundationApplication.Create Method (Autodesk.REX.Framework.REXApplicationContext)
REXFoundationApplication Class REX.Common Namespace REXFoundationApplication Class

Creates and shows module as modal dialog.

C#
public bool Create(ref Autodesk.REX.Framework.REXApplicationContext AppContext);
Parameters
Parameters | Description
AppContext | The application context.
Returns

Returns true if suceeded.

Description
Class

REXFoundationApplication Class

Links
REXFoundationApplication Class, REX.Common Namespace, REXFoundationApplication Class


REXFoundationApplication.Create Method (Autodesk.REX.Framework.REXContext)

REXFoundationApplication.Create Method (Autodesk.REX.Framework.REXContext)
REXFoundationApplication Class REX.Common Namespace REXFoundationApplication Class

Creates and shows module as modal dialog.

C#
public bool Create(Autodesk.REX.Framework.REXContext AppContext);
Parameters
Parameters | Description
AppContext | The application context.
Returns

Returns true if suceeded.

Description
Class

REXFoundationApplication Class

Links
REXFoundationApplication Class, REX.Common Namespace, REXFoundationApplication Class


REXFoundationApplication.Event Method

REXFoundationApplication.Event Method
REXFoundationApplication Class REX.Common Namespace REXFoundationApplication Class

Called when event.

C#
public object Event(ref Autodesk.REX.Framework.REXEvent EventStruct);
Parameters
Parameters | Description
EventStruct | The event structure.
Returns

Returns result of event operation.

Description
Class

REXFoundationApplication Class

Links
REXFoundationApplication Class, REX.Common Namespace, REXFoundationApplication Class


REXFoundationApplication.GetService Method

REXFoundationApplication.GetService Method
REXFoundationApplication Class REX.Common Namespace REXFoundationApplication Class

Gets the the service.

C#
public object GetService();
Returns

Returns the service.

Description
Class

REXFoundationApplication Class

Links
REXFoundationApplication Class, REX.Common Namespace, REXFoundationApplication Class


REXFoundationApplication.GetUniqueId Method

REXFoundationApplication.GetUniqueId Method
REXFoundationApplication Class REX.Common Namespace REXFoundationApplication Class

Returns the unique id for the module

C#
public Guid GetUniqueId();
Class

REXFoundationApplication Class

Links
REXFoundationApplication Class, REX.Common Namespace, REXFoundationApplication Class


REXFoundationApplication.Modal Method (Autodesk.REX.Framework.REXApplicationContext)

REXFoundationApplication.Modal Method (Autodesk.REX.Framework.REXApplicationContext)
REXFoundationApplication Class REX.Common Namespace REXFoundationApplication Class

Creates and shows module as modal dialog.

C#
public bool Modal(ref Autodesk.REX.Framework.REXApplicationContext AppContext);
Parameters
Parameters | Description
AppContext | The application context.
Returns

Returns true if suceeded.

Description
Class

REXFoundationApplication Class

Links
REXFoundationApplication Class, REX.Common Namespace, REXFoundationApplication Class


REXFoundationApplication.Modal Method (Autodesk.REX.Framework.REXContext)

REXFoundationApplication.Modal Method (Autodesk.REX.Framework.REXContext)
REXFoundationApplication Class REX.Common Namespace REXFoundationApplication Class

Creates and shows module as modal dialog.

C#
public bool Modal(Autodesk.REX.Framework.REXContext AppContext);
Parameters
Parameters | Description
AppContext | The application context.
Returns

Returns true if suceeded.

Description
Class

REXFoundationApplication Class

Links
REXFoundationApplication Class, REX.Common Namespace, REXFoundationApplication Class


REXFoundationApplication.Show Method

REXFoundationApplication.Show Method
REXFoundationApplication Class REX.Common Namespace REXFoundationApplication Class

Shows this module.

C#
public bool Show();
Returns

Returns true if succeeded.

Description
Class

REXFoundationApplication Class

Links
REXFoundationApplication Class, REX.Common Namespace, REXFoundationApplication Class


REXLayout Class

REXLayout Class
REX.Common Namespace Legend Members Public Methods REXLayout Methods REXLayout Properties
Class Hierarchy
C#
public class REXLayout;
Namespace

REX.Common Namespace

Public Methods
Public Method | Description
REXLayout | Initializes a new instance of the REXLayout class.
REXLayout Methods
REXLayout Methods | Description
AddLayout | Adds the layout.
AddLayout | Adds the layout.
AddLayout | Adds the layout.
AddLayout_Dialog | Adds the predefined layout with one dialog.
AddLayout_Dialog_Menu | Adds the predefined layout which contains one dialog and standard menu.
AddLayout_Dialog_ToolBarMenu_ToolBar | Adds the predefined layout which contains one dialog, menu as tool bar and tool bar.
AddLayout_OptionsList_Menu_BottomDialog_RightDialog | Adds the predefined layout which contains options list, first dialog on the right side, secound dialog on the bottom and standard menu.
AddLayout_OptionsList_Menu_BottomDialog_RightDialogAndHtmlNoteOnTabs | Adds the predefined layout which contains options list, dialog and html note on tabs on the right side, secound dialog on the bottom and standard menu.
AddLayout_OptionsList_Menu_RightDialog | Adds the predefined layout which contains options list, one dialog and standard menu.
AddLayout_OptionsList_Menu_RightDialogAndViewAndHtmlNoteOnTabs | Adds the predefined layout which contains options list, one dialog, view (or dialog), html note on tabs and standard menu.
AddLayout_OptionsList_Menu_RightDialogAndViewOnTabs | Adds the predefined layout which contains options list, one dialog and view (or dialog) on tabs and standard menu.
AddLayout_OptionsList_ToolBarMenu_ToolBar_BottomDialog_RightDialog | Adds the predefined layout which contains options list, first dialog on the right side and secound dialog on the bottom, tool bar as menu and tool bar.
AddLayout_OptionsList_ToolBarMenu_ToolBar_BottomDialog_RightDialogAndHtmlNoteOnTabs | Adds the predefined layout which contains options list, dialog and html note on tabs on the right side, secound dialog on the bottom and tool bar as menu and tool bar.
AddLayout_OptionsList_ToolBarMenu_ToolBar_RightDialog | Adds the predefined layout which contains options list, one dialog, tool bar as menu and tool bar.
AddLayout_OptionsList_ToolBarMenu_ToolBar_RightDialogAndViewOnTabs | Adds the predefined layout which contains options list, dialog and view (or dialog) on tabs, tool bar as menu and tool bar.
CalculateMainControlSize | This is CalculateMainControlSize, a member of class REXLayout.
Clear | Clears all layouts items.
DeSelect | Called after deselect the specified LayoutItem.
DeSelect | This is DeSelect, a member of class REXLayout.
DisposeControls | Disposes all controls in all added layouts.
GetItem | Gets the layout item identified by mame.
GetLayoutIndex | Gets the index of the layout.
GetLayoutItem | This is GetLayoutItem, a member of class REXLayout.
InsertLayout | Adds the layout.
RemoveLayout | Removes the layout.
Select | Called after select the specified LayoutItem.
Select | This is Select, a member of class REXLayout.
SelectLayout | Selects the layout.
Setup | Setups layout and all layout's items.
ToolboxDeSelect | This is ToolboxDeSelect, a member of class REXLayout.
ToolboxGetItem | This is ToolboxGetItem, a member of class REXLayout.
ToolboxRemoveLayout | This is ToolboxRemoveLayout, a member of class REXLayout.
ToolboxSelect | This is ToolboxSelect, a member of class REXLayout.
ToolboxSelectLayout | This is ToolboxSelectLayout, a member of class REXLayout.
ToolboxSetup | This is ToolboxSetup, a member of class REXLayout.
ToolboxSetup | This is ToolboxSetup, a member of class REXLayout.
ToolboxUpdate | This is ToolboxUpdate, a member of class REXLayout.
Update | Updates layout all layout's items.
REXLayout Properties
REXLayout Properties | Description
CommandsOptions | Gets or sets the options for commands.
CommandsOptionsByEnum | Gets or sets the options for commands.
ConstOptions | Gets or sets the const options for all layouts.
ConstOptionsByEnum | Gets or sets the const options for all layouts.
Count | Gets the count of layout items.
Current | Gets the current layout item.
DefaultOptions | Gets or sets the default options for layout.
DisableEvents | Gets a value indicating whether events are disabled.
Links
REX.Common Namespace, Legend, Members, Public Methods, REXLayout Methods, REXLayout Properties


REXLayout.REXLayout Constructor

REXLayout.REXLayout Constructor
REXLayout Class REX.Common Namespace REXLayout Class

Initializes a new instance of the REXLayout class.

C#
public REXLayout(REXUI UI);
Parameters
Parameters | Description
UI | The refernce to UI class.
Description
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class


REXLayout.AddLayout Method (REXLayoutItem)

REXLayout.AddLayout Method (REXLayoutItem)
REXLayout Class REX.Common Namespace REXLayout Class

Adds the layout.

C#
public void AddLayout(REXLayoutItem LayoutItem);
Parameters
Parameters | Description
LayoutItem | The layout item.
Description
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class


REXLayout.AddLayout Method (REXLayoutItem, int)

REXLayout.AddLayout Method (REXLayoutItem, int)
REXLayout Class REX.Common Namespace REXLayout Class

Adds the layout.

C#
public void AddLayout(REXLayoutItem LayoutItem, int PreviousLayoutIndex);
Parameters
Parameters | Description
LayoutItem | The layout item.
PreviousLayoutIndex | Index of the previous layout.
Description
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class


REXLayout.AddLayout Method (REXLayoutItem, string)

REXLayout.AddLayout Method (REXLayoutItem, string)
REXLayout Class REX.Common Namespace REXLayout Class

Adds the layout.

C#
public void AddLayout(REXLayoutItem LayoutItem, string PreviousLayoutName);
Parameters
Parameters | Description
LayoutItem | The layout item.
PreviousLayoutName | Name of the previous layout.
Description
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class


REXLayout.AddLayout_Dialog Method

REXLayout.AddLayout_Dialog Method
REXLayout Class REX.Common Namespace REXLayout Class

Adds the predefined layout with one dialog.

C#
public void AddLayout_Dialog(string Name, string GroupName, string Description, Control Dialog, ImageSource LayoutImage);
Parameters
Parameters | Description
Name | The name of layout.
GroupName | Name of the group.
Description | The description.
Dialog | The dialog control.
LayoutImage | The layout image.
Description
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class


REXLayout.AddLayout_Dialog_Menu Method

REXLayout.AddLayout_Dialog_Menu Method
REXLayout Class REX.Common Namespace REXLayout Class

Adds the predefined layout which contains one dialog and standard menu.

C#
public void AddLayout_Dialog_Menu(string Name, string GroupName, string Description, Control Dialog, ImageSource LayoutImage);
Parameters
Parameters | Description
Name | The name of the layout.
GroupName | Name of the group.
Description | The description.
Dialog | The dialog control.
LayoutImage | The layout image.
Description
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class


REXLayout.AddLayout_Dialog_ToolBarMenu_ToolBar Method

REXLayout.AddLayout_Dialog_ToolBarMenu_ToolBar Method
REXLayout Class REX.Common Namespace REXLayout Class

Adds the predefined layout which contains one dialog, menu as tool bar and tool bar.

C#
public void AddLayout_Dialog_ToolBarMenu_ToolBar(string Name, string GroupName, string Description, Control Dialog, ImageSource LayoutImage);
Parameters
Parameters | Description
Name | The name of the layout.
GroupName | Name of the group.
Description | The description.
Dialog | The dialog control.
LayoutImage | The layout image.
Description
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class


REXLayout.AddLayout_OptionsList_Menu_BottomDialog_RightDialog Method

REXLayout.AddLayout_OptionsList_Menu_BottomDialog_RightDialog Method
REXLayout Class REX.Common Namespace REXLayout Class

Adds the predefined layout which contains options list, first dialog on the right side, secound dialog on the bottom and standard menu.

C#
public void AddLayout_OptionsList_Menu_BottomDialog_RightDialog(string Name, string GroupName, string Description, Control Dialog, Control BottomDialog, ImageSource LayoutImage);
Parameters
Parameters | Description
Name | The name of the layout.
GroupName | Name of the group.
Description | The description.
Dialog | The dialog control.
BottomDialog | The bottom dialog control.
LayoutImage | The layout image.
Description
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class


REXLayout.AddLayout_OptionsList_Menu_BottomDialog_RightDialogAndHtmlNoteOnTabs Method

REXLayout.AddLayout_OptionsList_Menu_BottomDialog_RightDialogAndHtmlNoteOnTabs Method
REXLayout Class REX.Common Namespace REXLayout Class

Adds the predefined layout which contains options list, dialog and html note on tabs on the right side, secound dialog on the bottom and standard menu.

C#
public void AddLayout_OptionsList_Menu_BottomDialog_RightDialogAndHtmlNoteOnTabs(string Name, string GroupName, string Description, Control Dialog, Control BottomDialog, ImageSource LayoutImage);
Parameters
Parameters | Description
Name | The name of the layout.
GroupName | Name of the group.
Description | The description.
Dialog | The dialog control.
BottomDialog | The bottom dialog control.
LayoutImage | The layout image.
Description
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class


REXLayout.AddLayout_OptionsList_Menu_RightDialog Method

REXLayout.AddLayout_OptionsList_Menu_RightDialog Method
REXLayout Class REX.Common Namespace REXLayout Class

Adds the predefined layout which contains options list, one dialog and standard menu.

C#
public void AddLayout_OptionsList_Menu_RightDialog(string Name, string GroupName, string Description, Control Dialog, ImageSource LayoutImage);
Parameters
Parameters | Description
Name | The name of the layout.
GroupName | Name of the group.
Description | The description.
Dialog | The dialog control.
LayoutImage | The layout image.
Description
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class


REXLayout.AddLayout_OptionsList_Menu_RightDialogAndViewAndHtmlNoteOnTabs Method

REXLayout.AddLayout_OptionsList_Menu_RightDialogAndViewAndHtmlNoteOnTabs Method
REXLayout Class REX.Common Namespace REXLayout Class

Adds the predefined layout which contains options list, one dialog, view (or dialog), html note on tabs and standard menu.

C#
public void AddLayout_OptionsList_Menu_RightDialogAndViewAndHtmlNoteOnTabs(string Name, string GroupName, string Description, Control Dialog, Control View, ImageSource LayoutImage);
Parameters
Parameters | Description
Name | The name of the layout.
GroupName | Name of the group.
Description | The description.
Dialog | The dialog control.
View | The view control.
LayoutImage | The layout image.
Description
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class


REXLayout.AddLayout_OptionsList_Menu_RightDialogAndViewOnTabs Method

REXLayout.AddLayout_OptionsList_Menu_RightDialogAndViewOnTabs Method
REXLayout Class REX.Common Namespace REXLayout Class

Adds the predefined layout which contains options list, one dialog and view (or dialog) on tabs and standard menu.

C#
public void AddLayout_OptionsList_Menu_RightDialogAndViewOnTabs(string Name, string GroupName, string Description, Control Dialog, Control View, ImageSource LayoutImage);
Parameters
Parameters | Description
Name | The name of the layout.
GroupName | Name of the group.
Description | The description.
Dialog | The dialog control.
View | The view control.
LayoutImage | The layout image.
Description
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class


REXLayout.AddLayout_OptionsList_ToolBarMenu_ToolBar_BottomDialog_RightDialog Method

REXLayout.AddLayout_OptionsList_ToolBarMenu_ToolBar_BottomDialog_RightDialog Method
REXLayout Class REX.Common Namespace REXLayout Class

Adds the predefined layout which contains options list, first dialog on the right side and secound dialog on the bottom, tool bar as menu and tool bar.

C#
public void AddLayout_OptionsList_ToolBarMenu_ToolBar_BottomDialog_RightDialog(string Name, string GroupName, string Description, Control Dialog, Control BottomDialog, ImageSource LayoutImage);
Parameters
Parameters | Description
Name | The name of the layout.
GroupName | Name of the group.
Description | The description.
Dialog | The dialog.
BottomDialog | The bottom dialog.
LayoutImage | The layout image.
Description
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class


REXLayout.AddLayout_OptionsList_ToolBarMenu_ToolBar_BottomDialog_RightDialogAndHtmlNoteOnTabs Method

REXLayout.AddLayout_OptionsList_ToolBarMenu_ToolBar_BottomDialog_RightDialogAndHtmlNoteOnTabs Method
REXLayout Class REX.Common Namespace REXLayout Class

Adds the predefined layout which contains options list, dialog and html note on tabs on the right side, secound dialog on the bottom and tool bar as menu and tool bar.

C#
public void AddLayout_OptionsList_ToolBarMenu_ToolBar_BottomDialog_RightDialogAndHtmlNoteOnTabs(string Name, string GroupName, string Description, Control BottomDialog, Control Dialog, ImageSource LayoutImage);
Parameters
Parameters | Description
Name | The name of the layout.
GroupName | Name of the group.
Description | The description.
BottomDialog | The bottom dialog.
Dialog | The dialog.
LayoutImage | The layout image.
Description
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class


REXLayout.AddLayout_OptionsList_ToolBarMenu_ToolBar_RightDialog Method

REXLayout.AddLayout_OptionsList_ToolBarMenu_ToolBar_RightDialog Method
REXLayout Class REX.Common Namespace REXLayout Class

Adds the predefined layout which contains options list, one dialog, tool bar as menu and tool bar.

C#
public void AddLayout_OptionsList_ToolBarMenu_ToolBar_RightDialog(string Name, string GroupName, string Description, Control Dialog, ImageSource LayoutImage);
Parameters
Parameters | Description
Name | The name of the layout.
GroupName | Name of the group.
Description | The description.
Dialog | The dialog.
LayoutImage | The layout image.
Description
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class


REXLayout.AddLayout_OptionsList_ToolBarMenu_ToolBar_RightDialogAndViewOnTabs Method

REXLayout.AddLayout_OptionsList_ToolBarMenu_ToolBar_RightDialogAndViewOnTabs Method
REXLayout Class REX.Common Namespace REXLayout Class

Adds the predefined layout which contains options list, dialog and view (or dialog) on tabs, tool bar as menu and tool bar.

C#
public void AddLayout_OptionsList_ToolBarMenu_ToolBar_RightDialogAndViewOnTabs(string Name, string GroupName, string Description, Control Dialog, Control View, ImageSource LayoutImage);
Parameters
Parameters | Description
Name | The name of the layout.
GroupName | Name of the group.
Description | The description.
Dialog | The dialog.
View | The view.
LayoutImage | The layout image.
Description
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class


REXLayout.CalculateMainControlSize Method

REXLayout.CalculateMainControlSize Method
REXLayout Class REX.Common Namespace REXLayout Class

This is CalculateMainControlSize, a member of class REXLayout.

C#
public REXSetFormStruct CalculateMainControlSize();
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class


REXLayout.Clear Method

REXLayout.Clear Method
REXLayout Class REX.Common Namespace REXLayout Class

Clears all layouts items.

C#
public void Clear();
Description

Doesn't dispose controls.

Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class


REXLayout.DeSelect Method (REXLayoutItem)

REXLayout.DeSelect Method (REXLayoutItem)
REXLayout Class REX.Common Namespace REXLayout Class

Called after deselect the specified LayoutItem.

C#
public void DeSelect(REXLayoutItem LI);
Parameters
Parameters | Description
LI | The LayoutItem.
Description
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class


REXLayout.DeSelect Method (REXToolboxItem)

REXLayout.DeSelect Method (REXToolboxItem)
REXLayout Class REX.Common Namespace REXLayout Class

This is DeSelect, a member of class REXLayout.

C#
public void DeSelect(REXToolboxItem TBI);
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class


REXLayout.DisposeControls Method

REXLayout.DisposeControls Method
REXLayout Class REX.Common Namespace REXLayout Class

Disposes all controls in all added layouts.

C#
public void DisposeControls();
Description
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class


REXLayout.GetItem Method

REXLayout.GetItem Method
REXLayout Class REX.Common Namespace REXLayout Class

Gets the layout item identified by mame.

C#
public REXLayoutItem GetItem(string Name);
Parameters
Parameters | Description
Name | The name.
Description
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class


REXLayout.GetLayoutIndex Method

REXLayout.GetLayoutIndex Method
REXLayout Class REX.Common Namespace REXLayout Class

Gets the index of the layout.

C#
public int GetLayoutIndex(string LayoutName);
Parameters
Parameters | Description
LayoutName | Name of the layout.
Description
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class


REXLayout.GetLayoutItem Method

REXLayout.GetLayoutItem Method
REXLayout Class REX.Common Namespace REXLayout Class

This is GetLayoutItem, a member of class REXLayout.

C#
public REXLayoutItem GetLayoutItem(REXToolboxItem TBI);
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class


REXLayout.InsertLayout Method

REXLayout.InsertLayout Method
REXLayout Class REX.Common Namespace REXLayout Class

Adds the layout.

C#
public void InsertLayout(REXLayoutItem LayoutItem, int Index);
Parameters
Parameters | Description
LayoutItem | The layout item.
Index | The index.
Description
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class


REXLayout.RemoveLayout Method

REXLayout.RemoveLayout Method
REXLayout Class REX.Common Namespace REXLayout Class

Removes the layout.

C#
public void RemoveLayout(string Name);
Parameters
Parameters | Description
Name | The name of the layout.
Description
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class


REXLayout.Select Method (REXLayoutItem)

REXLayout.Select Method (REXLayoutItem)
REXLayout Class REX.Common Namespace REXLayout Class

Called after select the specified LayoutItem.

C#
public void Select(REXLayoutItem LI);
Parameters
Parameters | Description
LI | The LayoutItem.
Description
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class


REXLayout.Select Method (REXToolboxItem)

REXLayout.Select Method (REXToolboxItem)
REXLayout Class REX.Common Namespace REXLayout Class

This is Select, a member of class REXLayout.

C#
public void Select(REXToolboxItem TBI);
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class


REXLayout.SelectLayout Method

REXLayout.SelectLayout Method
REXLayout Class REX.Common Namespace REXLayout Class

Selects the layout.

C#
public void SelectLayout(string Name);
Parameters
Parameters | Description
Name | The name of the layout.
Description
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class


REXLayout.Setup Method

REXLayout.Setup Method
REXLayout Class REX.Common Namespace REXLayout Class

Setups layout and all layout's items.

C#
public void Setup();
Description
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class


REXLayout.ToolboxDeSelect Method

REXLayout.ToolboxDeSelect Method
REXLayout Class REX.Common Namespace REXLayout Class

This is ToolboxDeSelect, a member of class REXLayout.

C#
public void ToolboxDeSelect(REXToolboxItem TBI);
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class


REXLayout.ToolboxGetItem Method

REXLayout.ToolboxGetItem Method
REXLayout Class REX.Common Namespace REXLayout Class

This is ToolboxGetItem, a member of class REXLayout.

C#
public REXToolboxItem ToolboxGetItem(string Name);
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class


REXLayout.ToolboxRemoveLayout Method

REXLayout.ToolboxRemoveLayout Method
REXLayout Class REX.Common Namespace REXLayout Class

This is ToolboxRemoveLayout, a member of class REXLayout.

C#
public void ToolboxRemoveLayout(string Name);
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class


REXLayout.ToolboxSelect Method

REXLayout.ToolboxSelect Method
REXLayout Class REX.Common Namespace REXLayout Class

This is ToolboxSelect, a member of class REXLayout.

C#
public void ToolboxSelect(REXToolboxItem TBI);
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class


REXLayout.ToolboxSelectLayout Method

REXLayout.ToolboxSelectLayout Method
REXLayout Class REX.Common Namespace REXLayout Class

This is ToolboxSelectLayout, a member of class REXLayout.

C#
public void ToolboxSelectLayout(string Name);
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class


REXLayout.ToolboxSetup Method ()

REXLayout.ToolboxSetup Method ()
REXLayout Class REX.Common Namespace REXLayout Class

This is ToolboxSetup, a member of class REXLayout.

C#
public void ToolboxSetup();
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class


REXLayout.ToolboxSetup Method (bool)

REXLayout.ToolboxSetup Method (bool)
REXLayout Class REX.Common Namespace REXLayout Class

This is ToolboxSetup, a member of class REXLayout.

C#
public void ToolboxSetup(bool update);
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class


REXLayout.ToolboxUpdate Method

REXLayout.ToolboxUpdate Method
REXLayout Class REX.Common Namespace REXLayout Class

This is ToolboxUpdate, a member of class REXLayout.

C#
public void ToolboxUpdate();
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class


REXLayout.Update Method

REXLayout.Update Method
REXLayout Class REX.Common Namespace REXLayout Class

Updates layout all layout's items.

C#
public void Update();
Description
Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class


REXLayout.CommandsOptions Property

REXLayout.CommandsOptions Property
REXLayout Class REX.Common Namespace REXLayout Class

Gets or sets the options for commands.

C#
public long CommandsOptions;
Description

The commands options.

Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class


REXLayout.CommandsOptionsByEnum Property

REXLayout.CommandsOptionsByEnum Property
REXLayout Class REX.Common Namespace REXLayout Class

Gets or sets the options for commands.

C#
public REXUI.CommandOptions CommandsOptionsByEnum;
Description

The commands options.

Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class


REXLayout.ConstOptions Property

REXLayout.ConstOptions Property
REXLayout Class REX.Common Namespace REXLayout Class

Gets or sets the const options for all layouts.

C#
public long ConstOptions;
Description

The const options.

Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class


REXLayout.ConstOptionsByEnum Property

REXLayout.ConstOptionsByEnum Property
REXLayout Class REX.Common Namespace REXLayout Class

Gets or sets the const options for all layouts.

C#
public REXUI.SetupOptions ConstOptionsByEnum;
Description

The const options.

Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class


REXLayout.Count Property

REXLayout.Count Property
REXLayout Class REX.Common Namespace REXLayout Class

Gets the count of layout items.

C#
public int Count;
Description

The count of layout items.

Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class


REXLayout.Current Property

REXLayout.Current Property
REXLayout Class REX.Common Namespace REXLayout Class

Gets the current layout item.

C#
public REXLayoutItem Current;
Description

The current layout item.

Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class


REXLayout.DefaultOptions Property

REXLayout.DefaultOptions Property
REXLayout Class REX.Common Namespace REXLayout Class

Gets or sets the default options for layout.

C#
public long DefaultOptions;
Description

The default options.

Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class


REXLayout.DisableEvents Property

REXLayout.DisableEvents Property
REXLayout Class REX.Common Namespace REXLayout Class

Gets a value indicating whether events are disabled.

C#
public bool DisableEvents;
Description

true if events are disabled; otherwise, false.

Class

REXLayout Class

Links
REXLayout Class, REX.Common Namespace, REXLayout Class


REXLayoutItem Class

REXLayoutItem Class
REX.Common Namespace Legend Members Public Methods REXLayoutItem Enumerations REXLayoutItem Fields REXLayoutItem Properties

Represents all layout of main control.

Class Hierarchy
C#
public class REXLayoutItem;
Description

All layout items are listed on left panel in options list control.

Namespace

REX.Common Namespace

Public Methods
Public Method | Description
REXLayoutItem | Initializes a new instance of the REXLayoutItem class.
REXLayoutItem | Initializes a new instance of the REXLayoutItem class.
REXLayoutItem | Initializes a new instance of the REXLayoutItem class.
REXLayoutItem | Initializes a new instance of the REXLayoutItem class.
REXLayoutItem | Initializes a new instance of the REXLayoutItem class.
REXLayoutItem | Initializes a new instance of the REXLayoutItem class.
REXLayoutItem | Initializes a new instance of the REXLayoutItem class.
REXLayoutItem | Initializes a new instance of the REXLayoutItem class.
REXLayoutItem | Initializes a new instance of the REXLayoutItem class.
REXLayoutItem Enumerations
REXLayoutItem Enumerations | Description
LayoutType | Determines type of layout item.
REXLayoutItem Fields
REXLayoutItem Fields | Description
ActiveTabPage | Gets or sets ActiveTabPage attribute of layout.
Description | Gets or sets Description attribute of layout.
Dialog | Gets or sets Dialog attribute of layout.
DisableCommands | Gets or sets DisableCommands attribute of layout.
GroupName | Gets or sets GroupName attribute of layout.
LayoutImage | Gets or sets LayoutImage attribute of layout.
Name | Gets or sets Name attribute of layout.
Options | Gets or sets Options attribute of layout.
Type | Gets or sets Type attribute of layout.
View | Gets or sets View attribute of layout.
Visible | Gets or sets visibility attribute of layout.
REXLayoutItem Properties
REXLayoutItem Properties | Description
DefaultDialogSize | Gets the default size of the dialog.
DefaultViewSize | Gets the default size of the view.
Links
REX.Common Namespace, Legend, Members, Public Methods, REXLayoutItem Enumerations, REXLayoutItem Fields, REXLayoutItem Properties


REXLayoutItem.REXLayoutItem Constructor (LayoutType, string, string, string)

REXLayoutItem.REXLayoutItem Constructor (LayoutType, string, string, string)
REXLayoutItem Class REX.Common Namespace REXLayoutItem Class

Initializes a new instance of the REXLayoutItem class.

C#
public REXLayoutItem(LayoutType Type, string Name, string GroupName, string Description);
Parameters
Parameters | Description
Type | The type.
Name | The name.
GroupName | Name of the group.
Description | The description.
Description
Class

REXLayoutItem Class

Links
REXLayoutItem Class, REX.Common Namespace, REXLayoutItem Class


REXLayoutItem.REXLayoutItem Constructor (LayoutType, string, string, string, REXUI.SetupOptions)

REXLayoutItem.REXLayoutItem Constructor (LayoutType, string, string, string, REXUI.SetupOptions)
REXLayoutItem Class REX.Common Namespace REXLayoutItem Class

Initializes a new instance of the REXLayoutItem class.

C#
public REXLayoutItem(LayoutType Type, string Name, string GroupName, string Description, REXUI.SetupOptions Options);
Parameters
Parameters | Description
Type | The type.
Name | The name.
GroupName | Name of the group.
Description | The description.
Options | The options.
Description
Class

REXLayoutItem Class

Links
REXLayoutItem Class, REX.Common Namespace, REXLayoutItem Class


REXLayoutItem.REXLayoutItem Constructor (LayoutType, string, string, string, REXUI.SetupOptions, Control, Control)

REXLayoutItem.REXLayoutItem Constructor (LayoutType, string, string, string, REXUI.SetupOptions, Control, Control)
REXLayoutItem Class REX.Common Namespace REXLayoutItem Class

Initializes a new instance of the REXLayoutItem class.

C#
public REXLayoutItem(LayoutType Type, string Name, string GroupName, string Description, REXUI.SetupOptions Options, Control Dialog, Control View);
Parameters
Parameters | Description
Type | The type.
Name | The name.
GroupName | Name of the group.
Description | The description.
Options | The options.
Dialog | The dialog control.
View | The view or dialog control.
Description
Class

REXLayoutItem Class

Links
REXLayoutItem Class, REX.Common Namespace, REXLayoutItem Class


REXLayoutItem.REXLayoutItem Constructor (LayoutType, string, string, string, REXUI.SetupOptions, Control, Control, ImageSource)

REXLayoutItem.REXLayoutItem Constructor (LayoutType, string, string, string, REXUI.SetupOptions, Control, Control, ImageSource)
REXLayoutItem Class REX.Common Namespace REXLayoutItem Class

Initializes a new instance of the REXLayoutItem class.

C#
public REXLayoutItem(LayoutType Type, string Name, string GroupName, string Description, REXUI.SetupOptions Options, Control Dialog, Control View, ImageSource LayoutImage);
Parameters
Parameters | Description
Type | The type.
Name | The name.
GroupName | Name of the group.
Description | The description.
Options | The options.
Dialog | The dialog control.
View | The view or dialog control.
LayoutImage | The layout image.
Description
Class

REXLayoutItem Class

Links
REXLayoutItem Class, REX.Common Namespace, REXLayoutItem Class


REXLayoutItem.REXLayoutItem Constructor (LayoutType, string, string, string, REXUI.SetupOptions, System.Windows.Controls.Control)

REXLayoutItem.REXLayoutItem Constructor (LayoutType, string, string, string, REXUI.SetupOptions, System.Windows.Controls.Control)
REXLayoutItem Class REX.Common Namespace REXLayoutItem Class

Initializes a new instance of the REXLayoutItem class.

C#
public REXLayoutItem(LayoutType Type, string Name, string GroupName, string Description, REXUI.SetupOptions Options, System.Windows.Controls.Control Dialog);
Parameters
Parameters | Description
Type | The type.
Name | The name.
GroupName | Name of the group.
Description | The description.
Options | The options.
Dialog | The dialog control.
Description
Class

REXLayoutItem Class

Links
REXLayoutItem Class, REX.Common Namespace, REXLayoutItem Class


REXLayoutItem.REXLayoutItem Constructor (LayoutType, string, string, string, long)

REXLayoutItem.REXLayoutItem Constructor (LayoutType, string, string, string, long)
REXLayoutItem Class REX.Common Namespace REXLayoutItem Class

Initializes a new instance of the REXLayoutItem class.

C#
public REXLayoutItem(LayoutType Type, string Name, string GroupName, string Description, long Options);
Parameters
Parameters | Description
Type | The type.
Name | The name.
GroupName | Name of the group.
Description | The description.
Options | The options.
Description
Class

REXLayoutItem Class

Links
REXLayoutItem Class, REX.Common Namespace, REXLayoutItem Class


REXLayoutItem.REXLayoutItem Constructor (LayoutType, string, string, string, long, Control, Control)

REXLayoutItem.REXLayoutItem Constructor (LayoutType, string, string, string, long, Control, Control)
REXLayoutItem Class REX.Common Namespace REXLayoutItem Class

Initializes a new instance of the REXLayoutItem class.

C#
public REXLayoutItem(LayoutType Type, string Name, string GroupName, string Description, long Options, Control Dialog, Control View);
Parameters
Parameters | Description
Type | The type.
Name | The name.
GroupName | Name of the group.
Description | The description.
Options | The options.
Dialog | The dialog control.
View | The view or dialog control.
ImageIndex | Index of the image.
Description
Class

REXLayoutItem Class

Links
REXLayoutItem Class, REX.Common Namespace, REXLayoutItem Class


REXLayoutItem.REXLayoutItem Constructor (LayoutType, string, string, string, long, Control, Control, ImageSource)

REXLayoutItem.REXLayoutItem Constructor (LayoutType, string, string, string, long, Control, Control, ImageSource)
REXLayoutItem Class REX.Common Namespace REXLayoutItem Class

Initializes a new instance of the REXLayoutItem class.

C#
public REXLayoutItem(LayoutType Type, string Name, string GroupName, string Description, long Options, Control Dialog, Control View, ImageSource LayoutImage);
Parameters
Parameters | Description
Type | The type.
Name | The name.
GroupName | Name of the group.
Description | The description.
Options | The options.
Dialog | The dialog control.
View | The view or dialog control.
LayoutImage | The layout image.
Description
Class

REXLayoutItem Class

Links
REXLayoutItem Class, REX.Common Namespace, REXLayoutItem Class


REXLayoutItem.REXLayoutItem Constructor (LayoutType, string, string, string, long, System.Windows.Controls.Control)

REXLayoutItem.REXLayoutItem Constructor (LayoutType, string, string, string, long, System.Windows.Controls.Control)
REXLayoutItem Class REX.Common Namespace REXLayoutItem Class

Initializes a new instance of the REXLayoutItem class.

C#
public REXLayoutItem(LayoutType Type, string Name, string GroupName, string Description, long Options, System.Windows.Controls.Control Dialog);
Parameters
Parameters | Description
Type | The type.
Name | The name.
GroupName | Name of the group.
Description | The description.
Options | The options.
Dialog | The dialog control.
Description
Class

REXLayoutItem Class

Links
REXLayoutItem Class, REX.Common Namespace, REXLayoutItem Class


REX.Common.REXLayoutItem.LayoutType Enumeration

REX.Common.REXLayoutItem.LayoutType Enumeration
REXLayoutItem Class

Determines type of layout item.

C#
public enum LayoutType {
  Group = 1,
  Layout = 2
}
Members
Members | Description
Group | Group of items.
Layout | Standard layout.
Description
Class

REXLayoutItem Class

Links
REXLayoutItem Class
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXLayoutItem.ActiveTabPage Field

REXLayoutItem.ActiveTabPage Field
REXLayoutItem Class REX.Common Namespace REXLayoutItem Class

Gets or sets ActiveTabPage attribute of layout.

C#
public int ActiveTabPage;
Description

If layout contains standard tab control: TabDialog and TabView or TabNote, The property enables control for tab control. Must call Layout.Update method after changing.

Class

REXLayoutItem Class

Links
REXLayoutItem Class, REX.Common Namespace, REXLayoutItem Class


REXLayoutItem.Description Field

REXLayoutItem.Description Field
REXLayoutItem Class REX.Common Namespace REXLayoutItem Class

Gets or sets Description attribute of layout.

C#
public string Description;
Description

Must call Layout.Update method after changing.

Class

REXLayoutItem Class

Links
REXLayoutItem Class, REX.Common Namespace, REXLayoutItem Class


REXLayoutItem.Dialog Field

REXLayoutItem.Dialog Field
REXLayoutItem Class REX.Common Namespace REXLayoutItem Class

Gets or sets Dialog attribute of layout.

C#
public Control Dialog;
Description

Must call Layout.Update method after changing.

Class

REXLayoutItem Class

Links
REXLayoutItem Class, REX.Common Namespace, REXLayoutItem Class


REXLayoutItem.DisableCommands Field

REXLayoutItem.DisableCommands Field
REXLayoutItem Class REX.Common Namespace REXLayoutItem Class

Gets or sets DisableCommands attribute of layout.

C#
public List<string> DisableCommands = new List<string>();
Description

Must call Layout.Update method after changing.

Class

REXLayoutItem Class

Links
REXLayoutItem Class, REX.Common Namespace, REXLayoutItem Class


REXLayoutItem.GroupName Field

REXLayoutItem.GroupName Field
REXLayoutItem Class REX.Common Namespace REXLayoutItem Class

Gets or sets GroupName attribute of layout.

C#
public string GroupName;
Description

Must call Layout.Update method after changing.

Class

REXLayoutItem Class

Links
REXLayoutItem Class, REX.Common Namespace, REXLayoutItem Class


REXLayoutItem.LayoutImage Field

REXLayoutItem.LayoutImage Field
REXLayoutItem Class REX.Common Namespace REXLayoutItem Class

Gets or sets LayoutImage attribute of layout.

C#
public ImageSource LayoutImage;
Description

Must call Layout.Update method after changing.

Class

REXLayoutItem Class

Links
REXLayoutItem Class, REX.Common Namespace, REXLayoutItem Class


REXLayoutItem.Name Field

REXLayoutItem.Name Field
REXLayoutItem Class REX.Common Namespace REXLayoutItem Class

Gets or sets Name attribute of layout.

C#
public string Name;
Description

Must call Layout.Update method after changing.

Class

REXLayoutItem Class

Links
REXLayoutItem Class, REX.Common Namespace, REXLayoutItem Class


REXLayoutItem.Options Field

REXLayoutItem.Options Field
REXLayoutItem Class REX.Common Namespace REXLayoutItem Class

Gets or sets Options attribute of layout.

C#
public long Options;
Description

Must call Layout.Update method after changing.

Class

REXLayoutItem Class

Links
REXLayoutItem Class, REX.Common Namespace, REXLayoutItem Class


REXLayoutItem.Type Field

REXLayoutItem.Type Field
REXLayoutItem Class REX.Common Namespace REXLayoutItem Class

Gets or sets Type attribute of layout.

C#
public LayoutType Type;
Description

Must call Layout.Update method after changing.

Class

REXLayoutItem Class

Links
REXLayoutItem Class, REX.Common Namespace, REXLayoutItem Class


REXLayoutItem.View Field

REXLayoutItem.View Field
REXLayoutItem Class REX.Common Namespace REXLayoutItem Class

Gets or sets View attribute of layout.

C#
public Control View;
Description

Must call Layout.Update method after changing.

Class

REXLayoutItem Class

Links
REXLayoutItem Class, REX.Common Namespace, REXLayoutItem Class


REXLayoutItem.Visible Field

REXLayoutItem.Visible Field
REXLayoutItem Class REX.Common Namespace REXLayoutItem Class

Gets or sets visibility attribute of layout.

C#
public bool Visible;
Description

Must call Layout.Update method after changing.

Class

REXLayoutItem Class

Links
REXLayoutItem Class, REX.Common Namespace, REXLayoutItem Class


REXLayoutItem.DefaultDialogSize Property

REXLayoutItem.DefaultDialogSize Property
REXLayoutItem Class REX.Common Namespace REXLayoutItem Class

Gets the default size of the dialog.

C#
public Size DefaultDialogSize;
Description

The default size of the dialog.

Class

REXLayoutItem Class

Links
REXLayoutItem Class, REX.Common Namespace, REXLayoutItem Class


REXLayoutItem.DefaultViewSize Property

REXLayoutItem.DefaultViewSize Property
REXLayoutItem Class REX.Common Namespace REXLayoutItem Class

Gets the default size of the view.

C#
public Size DefaultViewSize;
Description

The default size of the view.

Class

REXLayoutItem Class

Links
REXLayoutItem Class, REX.Common Namespace, REXLayoutItem Class


REXLogger Class

REXLogger Class
REX.Common Namespace Legend Members REXLogger Methods

This is class REX.Common.REXLogger.

Class Hierarchy
C#
public class REXLogger;
Namespace

REX.Common Namespace

REXLogger Methods
REXLogger Methods | Description
Log | This is Log, a member of class REXLogger.
Log | This is Log, a member of class REXLogger.
Log | This is Log, a member of class REXLogger.
Log | This is Log, a member of class REXLogger.
Log | This is Log, a member of class REXLogger.
Log | This is Log, a member of class REXLogger.
Log | This is Log, a member of class REXLogger.
Log | Logs specified warning.
Log | Logs specified warning and message.
Links
REX.Common Namespace, Legend, Members, REXLogger Methods


REXLogger.Log Method (REXErrors.ErrorCode)

REXLogger.Log Method (REXErrors.ErrorCode)
REXLogger Class REX.Common Namespace REXLogger Class

This is Log, a member of class REXLogger.

C#
public static void Log(REXErrors.ErrorCode err);
Class

REXLogger Class

Links
REXLogger Class, REX.Common Namespace, REXLogger Class


REXLogger.Log Method (REXErrors.ErrorCode, Exception)

REXLogger.Log Method (REXErrors.ErrorCode, Exception)
REXLogger Class REX.Common Namespace REXLogger Class

This is Log, a member of class REXLogger.

C#
public static void Log(REXErrors.ErrorCode err, Exception ex);
Class

REXLogger Class

Links
REXLogger Class, REX.Common Namespace, REXLogger Class


REXLogger.Log Method (REXErrors.ErrorCode, Exception, LogCategory)

REXLogger.Log Method (REXErrors.ErrorCode, Exception, LogCategory)
REXLogger Class REX.Common Namespace REXLogger Class

This is Log, a member of class REXLogger.

C#
public static void Log(REXErrors.ErrorCode err, Exception ex, LogCategory cat);
Class

REXLogger Class

Links
REXLogger Class, REX.Common Namespace, REXLogger Class


REXLogger.Log Method (REXErrors.ErrorCode, LogCategory)

REXLogger.Log Method (REXErrors.ErrorCode, LogCategory)
REXLogger Class REX.Common Namespace REXLogger Class

This is Log, a member of class REXLogger.

C#
public static void Log(REXErrors.ErrorCode err, LogCategory cat);
Class

REXLogger Class

Links
REXLogger Class, REX.Common Namespace, REXLogger Class


REXLogger.Log Method (REXErrors.ErrorCode, String)

REXLogger.Log Method (REXErrors.ErrorCode, String)
REXLogger Class REX.Common Namespace REXLogger Class

This is Log, a member of class REXLogger.

C#
public static void Log(REXErrors.ErrorCode err, String msg);
Class

REXLogger Class

Links
REXLogger Class, REX.Common Namespace, REXLogger Class


REXLogger.Log Method (REXErrors.ErrorCode, String, LogCategory)

REXLogger.Log Method (REXErrors.ErrorCode, String, LogCategory)
REXLogger Class REX.Common Namespace REXLogger Class

This is Log, a member of class REXLogger.

C#
public static void Log(REXErrors.ErrorCode err, String msg, LogCategory cat);
Class

REXLogger Class

Links
REXLogger Class, REX.Common Namespace, REXLogger Class


REXLogger.Log Method (REXErrors.ErrorCode, string, Exception)

REXLogger.Log Method (REXErrors.ErrorCode, string, Exception)
REXLogger Class REX.Common Namespace REXLogger Class

This is Log, a member of class REXLogger.

C#
public static void Log(REXErrors.ErrorCode err, string text, Exception ex);
Class

REXLogger Class

Links
REXLogger Class, REX.Common Namespace, REXLogger Class


REXLogger.Log Method (REXWarnings.WarningCode)

REXLogger.Log Method (REXWarnings.WarningCode)
REXLogger Class REX.Common Namespace REXLogger Class

Logs specified warning.

C#
public static void Log(REXWarnings.WarningCode wrn);
Parameters
Parameters | Description
wrn | The warning code.
Description
Class

REXLogger Class

Links
REXLogger Class, REX.Common Namespace, REXLogger Class


REXLogger.Log Method (REXWarnings.WarningCode, String)

REXLogger.Log Method (REXWarnings.WarningCode, String)
REXLogger Class REX.Common Namespace REXLogger Class

Logs specified warning and message.

C#
public static void Log(REXWarnings.WarningCode wrn, String msg);
Parameters
Parameters | Description
wrn | The warning code.
msg | The message.
Description
Class

REXLogger Class

Links
REXLogger Class, REX.Common Namespace, REXLogger Class


REXResults Class

REXResults Class
REX.Common Namespace Legend Members Public Methods

Base class for results.

Class Hierarchy
C#
public class REXResults : REXExtensionData;
Description
Namespace

REX.Common Namespace

Public Methods
Public Method | Description
REXResults | Initializes a new instance of a REXResults class.
Links
REX.Common Namespace, Legend, Members, Public Methods


REXResults.REXResults Constructor

REXResults.REXResults Constructor
REXResults Class REX.Common Namespace REXResults Class

Initializes a new instance of a REXResults class.

C#
public REXResults(REXExtension Ext);
Parameters
Parameters | Description
Ext | The reference to REXExtension object.
Description
Class

REXResults Class

Links
REXResults Class, REX.Common Namespace, REXResults Class


REXRevitAccess Class

REXRevitAccess Class
REX.Common Namespace Legend Members Public Methods REXRevitAccess Classes REXRevitAccess Enumerations REXRevitAccess Fields REXRevitAccess Methods REXRevitAccess Properties

The class dedicated to settings data from Revit.

Class Hierarchy
C#
public class REXRevitAccess : IREXExtensionAccess3;
Description

Called internally from base SDK's classes.

Namespace

REX.Common Namespace

Public Methods
Public Method | Description
REXRevitAccess | Initializes a new instance of the REXRevitAccess class.
REXRevitAccess Classes
REXRevitAccess Classes | Description
Versions | Constants for all known versions.
REXRevitAccess Enumerations
REXRevitAccess Enumerations | Description
CompareVersionsResult | Dedicated enum for compare Revit's version.
REXRevitAccess Fields
REXRevitAccess Fields | Description
AutoSelectionRestore | This is AutoSelectionRestore, a member of class REXRevitAccess.
UsingParameters | This is UsingParameters, a member of class REXRevitAccess.
REXRevitAccess Methods
REXRevitAccess Methods | Description
Application | Access to Autodesk.Revit.ApplicationServices.ApplicationServices.Application object.
CommandData | Access to Autodesk.Revit.ExternalCommandData.
CompareVersions | Compares the versions.
Create | Reads some data from Revit and sets system display units.
Destroy | Destroys and resets some objects connected to Revit.
Detach | Detaches this instance.
Elements | Access to Autodesk.Revit.ExternalCommandData.
Event | Events the specified ev.
Initialize | Initializes this instance.
Message | Access to message string from Autodesk.Revit.IExternalCommand.Execute command.
Update | Reads some data from Revit and set system display units.
UpdaterData | Access to updater data (in update context only).
REXRevitAccess Properties
REXRevitAccess Properties | Description
ActiveDocument | Actives the UI document.
ActiveUIDocument | Actives the UI document.
EventService | This is EventService, a member of class REXRevitAccess.
IsArchitecture | This is IsArchitecture, a member of class REXRevitAccess.
IsMEP | This is IsMEP, a member of class REXRevitAccess.
IsStructure | This is IsStructure, a member of class REXRevitAccess.
Parameters | Access to REX parameters.
Selection | Actives the UI document.
ThisApplication | This is ThisApplication, a member of class REXRevitAccess.
ThisContext | This is ThisContext, a member of class REXRevitAccess.
ThisExtension | This is ThisExtension, a member of class REXRevitAccess.
UIApplication | UIs the application.
Links
REX.Common Namespace, Legend, Members, Public Methods, REXRevitAccess Classes, REXRevitAccess Enumerations, REXRevitAccess Fields, REXRevitAccess Methods, REXRevitAccess Properties


REXRevitAccess.REXRevitAccess Constructor

REXRevitAccess.REXRevitAccess Constructor
REXRevitAccess Class REX.Common Namespace REXRevitAccess Class

Initializes a new instance of the REXRevitAccess class.

C#
public REXRevitAccess(REXApplication App);
Parameters
Parameters | Description
App | The reference to a REXApplication object.
Description
Class

REXRevitAccess Class

Links
REXRevitAccess Class, REX.Common Namespace, REXRevitAccess Class


REXRevitAccess.Versions Class

REXRevitAccess.Versions Class
REXRevitAccess Class Legend Members Versions Fields

Constants for all known versions.

Class Hierarchy
C#
public class Versions;
Description
Class

REXRevitAccess Class

Versions Fields
Versions Fields | Description
v2008 |
v2008_SP1 |
v2008_SP2 |
v2008_SP3 |
v2008_SP4 |
v2009_A |
v2009_A2 |
Links
REXRevitAccess Class, Legend, Members, Versions Fields


REXRevitAccess.Versions.v2008 Field

REXRevitAccess.Versions.v2008 Field
REXRevitAccess.Versions Class REX.Common Namespace REXRevitAccess.Versions Class
C#
public const string v2008 = "20070410_1700";
Class

REXRevitAccess.Versions Class

Links
REXRevitAccess.Versions Class, REX.Common Namespace, REXRevitAccess.Versions Class


REXRevitAccess.Versions.v2008_SP1 Field

REXRevitAccess.Versions.v2008_SP1 Field
REXRevitAccess.Versions Class REX.Common Namespace REXRevitAccess.Versions Class
C#
public const string v2008_SP1 = "20070607_1700";
Class

REXRevitAccess.Versions Class

Links
REXRevitAccess.Versions Class, REX.Common Namespace, REXRevitAccess.Versions Class


REXRevitAccess.Versions.v2008_SP2 Field

REXRevitAccess.Versions.v2008_SP2 Field
REXRevitAccess.Versions Class REX.Common Namespace REXRevitAccess.Versions Class
C#
public const string v2008_SP2 = "20070810_1700";
Class

REXRevitAccess.Versions Class

Links
REXRevitAccess.Versions Class, REX.Common Namespace, REXRevitAccess.Versions Class


REXRevitAccess.Versions.v2008_SP3 Field

REXRevitAccess.Versions.v2008_SP3 Field
REXRevitAccess.Versions Class REX.Common Namespace REXRevitAccess.Versions Class
C#
public const string v2008_SP3 = "20071109_2345";
Class

REXRevitAccess.Versions Class

Links
REXRevitAccess.Versions Class, REX.Common Namespace, REXRevitAccess.Versions Class


REXRevitAccess.Versions.v2008_SP4 Field

REXRevitAccess.Versions.v2008_SP4 Field
REXRevitAccess.Versions Class REX.Common Namespace REXRevitAccess.Versions Class
C#
public const string v2008_SP4 = "20071109_2345";
Class

REXRevitAccess.Versions Class

Links
REXRevitAccess.Versions Class, REX.Common Namespace, REXRevitAccess.Versions Class


REXRevitAccess.Versions.v2009_A Field

REXRevitAccess.Versions.v2009_A Field
REXRevitAccess.Versions Class REX.Common Namespace REXRevitAccess.Versions Class
C#
public const string v2009_A = "Development Build";
Class

REXRevitAccess.Versions Class

Links
REXRevitAccess.Versions Class, REX.Common Namespace, REXRevitAccess.Versions Class


REXRevitAccess.Versions.v2009_A2 Field

REXRevitAccess.Versions.v2009_A2 Field
REXRevitAccess.Versions Class REX.Common Namespace REXRevitAccess.Versions Class
C#
public const string v2009_A2 = "20071210_0209";
Class

REXRevitAccess.Versions Class

Links
REXRevitAccess.Versions Class, REX.Common Namespace, REXRevitAccess.Versions Class


REX.Common.REXRevitAccess.CompareVersionsResult Enumeration

REX.Common.REXRevitAccess.CompareVersionsResult Enumeration
REXRevitAccess Class

Dedicated enum for compare Revit's version.

C#
public enum CompareVersionsResult {
  Unknown,
  Lesser,
  Equal,
  Greater,
  Error
}
Members
Members | Description
Unknown | Unknown result.
Lesser | Lesser then current.
Equal | Equal to current.
Greater | Greater then current.
Error | Error on parsing one of versions.
Description
Class

REXRevitAccess Class

Links
REXRevitAccess Class
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXRevitAccess.AutoSelectionRestore Field

REXRevitAccess.AutoSelectionRestore Field
REXRevitAccess Class REX.Common Namespace REXRevitAccess Class

This is AutoSelectionRestore, a member of class REXRevitAccess.

C#
public bool AutoSelectionRestore = false;
Class

REXRevitAccess Class

Links
REXRevitAccess Class, REX.Common Namespace, REXRevitAccess Class


REXRevitAccess.UsingParameters Field

REXRevitAccess.UsingParameters Field
REXRevitAccess Class REX.Common Namespace REXRevitAccess Class

This is UsingParameters, a member of class REXRevitAccess.

C#
public bool UsingParameters = true;
Class

REXRevitAccess Class

Links
REXRevitAccess Class, REX.Common Namespace, REXRevitAccess Class


REXRevitAccess.Application Method

REXRevitAccess.Application Method
REXRevitAccess Class REX.Common Namespace REXRevitAccess Class

Access to Autodesk.Revit.ApplicationServices.ApplicationServices.Application object.

C#
public Autodesk.Revit.ApplicationServices.Application Application();
Returns

Returns reference to Autodesk.Revit.ApplicationServices.ApplicationServices.Application object.

Description
Class

REXRevitAccess Class

Links
REXRevitAccess Class, REX.Common Namespace, REXRevitAccess Class


REXRevitAccess.CommandData Method

REXRevitAccess.CommandData Method
REXRevitAccess Class REX.Common Namespace REXRevitAccess Class

Access to Autodesk.Revit.ExternalCommandData.

C#
public Autodesk.Revit.UI.ExternalCommandData CommandData();
Returns

Returns reference to Autodesk.Revit.ExternalCommandData.

Description
Class

REXRevitAccess Class

Links
REXRevitAccess Class, REX.Common Namespace, REXRevitAccess Class


REXRevitAccess.CompareVersions Method

REXRevitAccess.CompareVersions Method
REXRevitAccess Class REX.Common Namespace REXRevitAccess Class

Compares the versions.

C#
public CompareVersionsResult CompareVersions(string Version);
Parameters
Parameters | Description
Version | The version to compare.
Returns

Returns the result of comparison.

Description

Compare specified version with current version.

Class

REXRevitAccess Class

Links
REXRevitAccess Class, REX.Common Namespace, REXRevitAccess Class


REXRevitAccess.Create Method

REXRevitAccess.Create Method
REXRevitAccess Class REX.Common Namespace REXRevitAccess Class

Reads some data from Revit and sets system display units.

C#
public bool Create();
Returns

Returns true if succeeded.

Description
Class

REXRevitAccess Class

Links
REXRevitAccess Class, REX.Common Namespace, REXRevitAccess Class


REXRevitAccess.Destroy Method

REXRevitAccess.Destroy Method
REXRevitAccess Class REX.Common Namespace REXRevitAccess Class

Destroys and resets some objects connected to Revit.

C#
public bool Destroy();
Returns

Returns true if succeeded.

Description
Class

REXRevitAccess Class

Links
REXRevitAccess Class, REX.Common Namespace, REXRevitAccess Class


REXRevitAccess.Detach Method

REXRevitAccess.Detach Method
REXRevitAccess Class REX.Common Namespace REXRevitAccess Class

Detaches this instance.

C#
public void Detach();
Description
Class

REXRevitAccess Class

Links
REXRevitAccess Class, REX.Common Namespace, REXRevitAccess Class


REXRevitAccess.Elements Method

REXRevitAccess.Elements Method
REXRevitAccess Class REX.Common Namespace REXRevitAccess Class

Access to Autodesk.Revit.ExternalCommandData.

C#
public Autodesk.Revit.DB.ElementSet Elements();
Returns

Returns reference to Autodesk.Revit.ExternalCommandData.

Description
Class

REXRevitAccess Class

Links
REXRevitAccess Class, REX.Common Namespace, REXRevitAccess Class


REXRevitAccess.Event Method

REXRevitAccess.Event Method
REXRevitAccess Class REX.Common Namespace REXRevitAccess Class

Events the specified ev.

C#
public bool Event(REXAccess.REXAccessEvent Ev);
Parameters
Parameters | Description
Ev | The ev.
Description
Class

REXRevitAccess Class

Links
REXRevitAccess Class, REX.Common Namespace, REXRevitAccess Class


REXRevitAccess.Initialize Method

REXRevitAccess.Initialize Method
REXRevitAccess Class REX.Common Namespace REXRevitAccess Class

Initializes this instance.

C#
public void Initialize();
Description

Nostly sets language from parent application.

Class

REXRevitAccess Class

Links
REXRevitAccess Class, REX.Common Namespace, REXRevitAccess Class


REXRevitAccess.Message Method

REXRevitAccess.Message Method
REXRevitAccess Class REX.Common Namespace REXRevitAccess Class

Access to message string from Autodesk.Revit.IExternalCommand.Execute command.

C#
public string Message();
Returns

Returns the string.

Description
Class

REXRevitAccess Class

Links
REXRevitAccess Class, REX.Common Namespace, REXRevitAccess Class


REXRevitAccess.Update Method

REXRevitAccess.Update Method
REXRevitAccess Class REX.Common Namespace REXRevitAccess Class

Reads some data from Revit and set system display units.

C#
public void Update();
Description
Class

REXRevitAccess Class

Links
REXRevitAccess Class, REX.Common Namespace, REXRevitAccess Class


REXRevitAccess.UpdaterData Method

REXRevitAccess.UpdaterData Method
REXRevitAccess Class REX.Common Namespace REXRevitAccess Class

Access to updater data (in update context only).

C#
public Autodesk.Revit.DB.UpdaterData UpdaterData();
Returns

Return the updater data.

Description
Class

REXRevitAccess Class

Links
REXRevitAccess Class, REX.Common Namespace, REXRevitAccess Class


REXRevitAccess.ActiveDocument Property

REXRevitAccess.ActiveDocument Property
REXRevitAccess Class REX.Common Namespace REXRevitAccess Class

Actives the UI document.

C#
public Autodesk.Revit.DB.Document ActiveDocument;
Description
Class

REXRevitAccess Class

Links
REXRevitAccess Class, REX.Common Namespace, REXRevitAccess Class


REXRevitAccess.ActiveUIDocument Property

REXRevitAccess.ActiveUIDocument Property
REXRevitAccess Class REX.Common Namespace REXRevitAccess Class

Actives the UI document.

C#
public Autodesk.Revit.UI.UIDocument ActiveUIDocument;
Description
Class

REXRevitAccess Class

Links
REXRevitAccess Class, REX.Common Namespace, REXRevitAccess Class


REXRevitAccess.EventService Property

REXRevitAccess.EventService Property
REXRevitAccess Class REX.Common Namespace REXRevitAccess Class

This is EventService, a member of class REXRevitAccess.

C#
public REX.Common.Events.Revit.REXRevitEventService EventService;
Class

REXRevitAccess Class

Links
REXRevitAccess Class, REX.Common Namespace, REXRevitAccess Class


REXRevitAccess.IsArchitecture Property

REXRevitAccess.IsArchitecture Property
REXRevitAccess Class REX.Common Namespace REXRevitAccess Class

This is IsArchitecture, a member of class REXRevitAccess.

C#
public bool IsArchitecture;
Class

REXRevitAccess Class

Links
REXRevitAccess Class, REX.Common Namespace, REXRevitAccess Class


REXRevitAccess.IsMEP Property

REXRevitAccess.IsMEP Property
REXRevitAccess Class REX.Common Namespace REXRevitAccess Class

This is IsMEP, a member of class REXRevitAccess.

C#
public bool IsMEP;
Class

REXRevitAccess Class

Links
REXRevitAccess Class, REX.Common Namespace, REXRevitAccess Class


REXRevitAccess.IsStructure Property

REXRevitAccess.IsStructure Property
REXRevitAccess Class REX.Common Namespace REXRevitAccess Class

This is IsStructure, a member of class REXRevitAccess.

C#
public bool IsStructure;
Class

REXRevitAccess Class

Links
REXRevitAccess Class, REX.Common Namespace, REXRevitAccess Class


REXRevitAccess.Parameters Property

REXRevitAccess.Parameters Property
REXRevitAccess Class REX.Common Namespace REXRevitAccess Class

Access to REX parameters.

C#
public IREXStorage<Element> Parameters;
Description

Uses for serialization data to Revit's elements.

Returns reference to REXParameters2 object.

Class

REXRevitAccess Class

Links
REXRevitAccess Class, REX.Common Namespace, REXRevitAccess Class


REXRevitAccess.Selection Property

REXRevitAccess.Selection Property
REXRevitAccess Class REX.Common Namespace REXRevitAccess Class

Actives the UI document.

C#
public Autodesk.Revit.UI.Selection.Selection Selection;
Description
Class

REXRevitAccess Class

Links
REXRevitAccess Class, REX.Common Namespace, REXRevitAccess Class


REXRevitAccess.ThisApplication Property

REXRevitAccess.ThisApplication Property
REXRevitAccess Class REX.Common Namespace REXRevitAccess Class

This is ThisApplication, a member of class REXRevitAccess.

C#
public REXApplication ThisApplication;
Class

REXRevitAccess Class

Links
REXRevitAccess Class, REX.Common Namespace, REXRevitAccess Class


REXRevitAccess.ThisContext Property

REXRevitAccess.ThisContext Property
REXRevitAccess Class REX.Common Namespace REXRevitAccess Class

This is ThisContext, a member of class REXRevitAccess.

C#
public Autodesk.REX.Framework.REXContext ThisContext;
Class

REXRevitAccess Class

Links
REXRevitAccess Class, REX.Common Namespace, REXRevitAccess Class


REXRevitAccess.ThisExtension Property

REXRevitAccess.ThisExtension Property
REXRevitAccess Class REX.Common Namespace REXRevitAccess Class

This is ThisExtension, a member of class REXRevitAccess.

C#
public REXExtension ThisExtension;
Class

REXRevitAccess Class

Links
REXRevitAccess Class, REX.Common Namespace, REXRevitAccess Class


REXRevitAccess.UIApplication Property

REXRevitAccess.UIApplication Property
REXRevitAccess Class REX.Common Namespace REXRevitAccess Class

UIs the application.

C#
public Autodesk.Revit.UI.UIApplication UIApplication;
Description
Class

REXRevitAccess Class

Links
REXRevitAccess Class, REX.Common Namespace, REXRevitAccess Class


REXRevitContextAccess Class

REXRevitContextAccess Class
REX.Common Namespace Legend Members Public Methods REXRevitContextAccess Methods

Allaws for access to Revit's objects.

Class Hierarchy
C#
public class REXRevitContextAccess : IREXExtensionAccess2;
Description
Namespace

REX.Common Namespace

Public Methods
Public Method | Description
REXRevitContextAccess | This is REXRevitContextAccess, a member of class REXRevitContextAccess.
REXRevitContextAccess Methods
REXRevitContextAccess Methods | Description
Create | Reads some data from parent application and set system display units.
Destroy | Destroys and resets some objects connected to parent application.
Event | Events the specified ev.
Initialize | Initializes this instance.
Update | Reads some data from parent application and set system display units.
Links
REX.Common Namespace, Legend, Members, Public Methods, REXRevitContextAccess Methods


REXRevitContextAccess.REXRevitContextAccess Constructor

REXRevitContextAccess.REXRevitContextAccess Constructor
REXRevitContextAccess Class REX.Common Namespace REXRevitContextAccess Class

This is REXRevitContextAccess, a member of class REXRevitContextAccess.

C#
public REXRevitContextAccess(REXRevitAccess ContextAccess);
Class

REXRevitContextAccess Class

Links
REXRevitContextAccess Class, REX.Common Namespace, REXRevitContextAccess Class


REXRevitContextAccess.Create Method

REXRevitContextAccess.Create Method
REXRevitContextAccess Class REX.Common Namespace REXRevitContextAccess Class

Reads some data from parent application and set system display units.

C#
public bool Create();
Returns

Returns true if succeeded.

Description
Class

REXRevitContextAccess Class

Links
REXRevitContextAccess Class, REX.Common Namespace, REXRevitContextAccess Class


REXRevitContextAccess.Destroy Method

REXRevitContextAccess.Destroy Method
REXRevitContextAccess Class REX.Common Namespace REXRevitContextAccess Class

Destroys and resets some objects connected to parent application.

C#
public bool Destroy();
Returns

Returns true if succeeded.

Description
Class

REXRevitContextAccess Class

Links
REXRevitContextAccess Class, REX.Common Namespace, REXRevitContextAccess Class


REXRevitContextAccess.Event Method

REXRevitContextAccess.Event Method
REXRevitContextAccess Class REX.Common Namespace REXRevitContextAccess Class

Events the specified ev.

C#
public bool Event(REXAccess.REXAccessEvent Ev);
Parameters
Parameters | Description
Ev | The ev.
Description
Class

REXRevitContextAccess Class

Links
REXRevitContextAccess Class, REX.Common Namespace, REXRevitContextAccess Class


REXRevitContextAccess.Initialize Method

REXRevitContextAccess.Initialize Method
REXRevitContextAccess Class REX.Common Namespace REXRevitContextAccess Class

Initializes this instance.

C#
public void Initialize();
Description

Nostly sets language from parent application.

Class

REXRevitContextAccess Class

Links
REXRevitContextAccess Class, REX.Common Namespace, REXRevitContextAccess Class


REXRevitContextAccess.Update Method

REXRevitContextAccess.Update Method
REXRevitContextAccess Class REX.Common Namespace REXRevitContextAccess Class

Reads some data from parent application and set system display units.

C#
public void Update();
Description
Class

REXRevitContextAccess Class

Links
REXRevitContextAccess Class, REX.Common Namespace, REXRevitContextAccess Class


REXUI Class

REXUI Class
REX.Common Namespace Legend Members Public Methods REXUI Enumerations REXUI Fields REXUI Methods REXUI Properties

Main class which provides access to all data connected with main control.

Class Hierarchy
C#
public class REXUI;
Description
Namespace

REX.Common Namespace

Public Methods
Public Method | Description
REXUI | Initializes a new instance of the REXUI class.
REXUI Enumerations
REXUI Enumerations | Description
CommandOptions | Identifies commands settings on the user interface.
SetupOptions | Identifies all elements of user interface.
REXUI Fields
REXUI Fields | Description
NameDialog | Name of dialog's container.
NameHSplit | Name of horizontal splitter.
NameHSplitGrid | Name of horizontal splitter.
NameHSplitGridBottom | Name of vertical splitter.
NameHSplitGridTop | Name of vertical splitter.
NameList | Name of list of options.
NameListImageListLarge | Name of large list of large images (32 x 32 pixels).
NameListImageListSmall | Name of large list of small images (16 x 16 pixels).
NameLogo | Name of logo's container.
NameMainPanel | Name of main panel which contains all controls.
NameMenu | Name of menu bar.
NameNote | Name of note's container.
NameRightContainer | Name of inner tool strip container.
NameStatus | Name of status bar.
NameStatusHeaderLabel | Name of label which represents header placed on status bar.
NameStatusLabel | Name of label placed on status bar.
NameStatusProgress | Name of progress placed on status bar.
NameTabControl | Name of tab control.
NameTabDialog | Name of tab dialog.
NameTabNote | Name of tab note.
NameTabView | Name of tab view.
NameToolBar | Name of tool bar.
NameToolBarInner | Name of inner tool bar.
NameToolbox | Name of toolbox control.
NameToolMenu | Name of menu bar based on tool bar.
NameView | Name of view's container.
NameVSplit | Name of vertical splitter.
NameVSplitGrid | Name of vertical splitter.
NameVSplitGridLeft | Name of vertical splitter.
NameVSplitGridRight | Name of vertical splitter.
REXUI Methods
REXUI Methods | Description
AddToolStrip | Adds the tool strip to repositioning.
FindHiddenCommand | Determines whether the input command is hidden.
FindHiddenCommand | Finds the hidden command.
GetAboutLink | Gets the about link.
GetDialog | Gets the dialog control.
GetHelpLink | Gets the help link.
GetList | This is GetList, a member of class REXUI.
GetLogo | Gets the reference to PictureBox which contains logo.
GetMenu | Gets the menu control.
GetMenuBar | Gets the menu bar.
GetNote | Gets the note control.
GetNoteWebBrowser | Gets the note web browser control.
GetStatus | Gets the status control.
GetStatusHeaderLabel | Gets the status header label.
GetStatusLabel | Gets the status label.
GetStatusProgress | Gets the status progress.
GetToolBar | Gets the tool bar.
GetToolBarInner | Gets the tool bar inner.
GetToolbox | Gets the toolbox control.
GetViewer | Gets the viewer's container.
GetWindow | Gets the reference to main form.
HideAboutControls | This is HideAboutControls, a member of class REXUI.
HideAboutLink | Hides the about link.
HideCommand | Hides the command.
HideCommand | Hides the command.
HideHelpLink | Hides the help link.
LoadNoteUrl | Loads the URL to note control.
RememberControl | Remembers the active tab control in specified LayoutItem in ActivTabPage property.
SetLogo | Sets the logo image.
SetupControl | Setups the main control according to default settings.
SetupControl | Setups the main control according to layout item settings.
ShowCommand | Shows the command.
ShowCommand | Shows the command.
REXUI Properties
REXUI Properties | Description
MainControl | Gets or sets the main control.
MainWindow | Gets or sets the main form.
Links
REX.Common Namespace, Legend, Members, Public Methods, REXUI Enumerations, REXUI Fields, REXUI Methods, REXUI Properties


REXUI.REXUI Constructor

REXUI.REXUI Constructor
REXUI Class REX.Common Namespace REXUI Class

Initializes a new instance of the REXUI class.

C#
public REXUI();
Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class


REX.Common.REXUI.CommandOptions Enumeration

REX.Common.REXUI.CommandOptions Enumeration
REXUI Class

Identifies commands settings on the user interface.

C#
[Flags]
public enum CommandOptions {
  None = 0,
  ToolBarOpen = 0x1,
  ToolBarSave = 0x2,
  ToolBarCalculate = 0x4,
  ToolBarHelp = 0x8,
  ToolMenuFile = 0x10,
  ToolMenuFileOpen = 0x20,
  ToolMenuFileSave = 0x40,
  ToolMenuFileSaveAs = 0x80,
  ToolMenuFilePrint = 0x100,
  ToolMenuFileClose = 0x200,
  ToolMenuCalculation = 0x400,
  ToolMenuCalculationRun = 0x800,
  ToolMenuHelp = 0x1000,
  ToolMenuHelpRun = 0x2000,
  ToolMenuHelpAbout = 0x4000,
  MenuFile = 0x8000,
  MenuFileOpen = 0x10000,
  MenuFileSave = 0x20000,
  MenuFileSaveAs = 0x40000,
  MenuFilePrint = 0x80000,
  MenuFileClose = 0x100000,
  MenuCalculation = 0x200000,
  MenuCalculationRun = 0x400000,
  MenuHelp = 0x800000,
  MenuHelpRun = 0x1000000,
  MenuHelpAbout = 0x2000000
}
Description
Class

REXUI Class

Links
REXUI Class
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REX.Common.REXUI.SetupOptions Enumeration

REX.Common.REXUI.SetupOptions Enumeration
REXUI Class

Identifies all elements of user interface.

C#
[Flags]
public enum SetupOptions {
  None = 0,
  List = 0x1,
  TabDialog = 0x2,
  TabView = 0x4,
  TabNote = 0x8,
  DialogBottom = 0x10,
  Status = 0x20,
  Menu = 0x40,
  ToolBar = 0x80,
  ToolBarInner = 0x100,
  ToolMenu = 0x200,
  ActivateControl = 0x400,
  FormFixed = 0x800,
  VSplitFixed = 0x1000,
  HSplitFixed = 0x2000,
  DisableDocking = 0x4000,
  ToolbarIncrementForm = 0x8000,
  AutoSizeForm = 0x10000
}
Members
Members | Description
None | No options.
List | List of options on the left side of main control.
TabDialog | Dialog placed on the right side of main control.
TabView | View (or dialog) placed on the right side of main control.
TabNote | HTML note placed on the right side of main control.
DialogBottom | Dialog placed on the bottom of main control.
Status | Status bar placed on the bottom of main control.
Menu | Standard menu bar placed on the top of main control.
ToolBar | Standard tool bar placed on the top of main control, but below the menu bar.
ToolBarInner | Standard tool bar placed on the top of right panel (controls on tabs).
ToolMenu | Menu based on tool bar placed on the top of main control, but below the menu bar, like tool bar.
ActivateControl | Sets focus on control after layout selection (currently is not implemented).
FormFixed | Sets main form fixed size.
VSplitFixed | Sets main control vertical splitter fixed.
HSplitFixed | Sets main control horizontal splitter fixed.
DisableDocking | Disables tool bars docking.
ToolbarIncrementForm | Increments size of main form by height of tool bar.
AutoSizeForm | Adapts main from to size of all controls (currently is not implemented).
Description
Class

REXUI Class

Links
REXUI Class
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXUI.NameDialog Field

REXUI.NameDialog Field
REXUI Class REX.Common Namespace REXUI Class

Name of dialog's container.

C#
public static string NameDialog = "DialogContainer";
Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class


REXUI.NameHSplit Field

REXUI.NameHSplit Field
REXUI Class REX.Common Namespace REXUI Class

Name of horizontal splitter.

C#
public static string NameHSplit = "HSplit";
Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class


REXUI.NameHSplitGrid Field

REXUI.NameHSplitGrid Field
REXUI Class REX.Common Namespace REXUI Class

Name of horizontal splitter.

C#
public static string NameHSplitGrid = "HSplitGrid";
Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class


REXUI.NameHSplitGridBottom Field

REXUI.NameHSplitGridBottom Field
REXUI Class REX.Common Namespace REXUI Class

Name of vertical splitter.

C#
public static string NameHSplitGridBottom = "HSplitGridBottom";
Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class


REXUI.NameHSplitGridTop Field

REXUI.NameHSplitGridTop Field
REXUI Class REX.Common Namespace REXUI Class

Name of vertical splitter.

C#
public static string NameHSplitGridTop = "HSplitGridTop";
Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class


REXUI.NameList Field

REXUI.NameList Field
REXUI Class REX.Common Namespace REXUI Class

Name of list of options.

C#
public static string NameList = "ListView";
Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class


REXUI.NameListImageListLarge Field

REXUI.NameListImageListLarge Field
REXUI Class REX.Common Namespace REXUI Class

Name of large list of large images (32 x 32 pixels).

C#
public static string NameListImageListLarge = "ListImageListLarge";
Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class


REXUI.NameListImageListSmall Field

REXUI.NameListImageListSmall Field
REXUI Class REX.Common Namespace REXUI Class

Name of large list of small images (16 x 16 pixels).

C#
public static string NameListImageListSmall = "ListImageListSmall";
Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class


REXUI.NameLogo Field

REXUI.NameLogo Field
REXUI Class REX.Common Namespace REXUI Class

Name of logo's container.

C#
public static string NameLogo = "Logo";
Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class


REXUI.NameMainPanel Field

REXUI.NameMainPanel Field
REXUI Class REX.Common Namespace REXUI Class

Name of main panel which contains all controls.

C#
public static string NameMainPanel = "MainPanel";
Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class


REXUI.NameMenu Field

REXUI.NameMenu Field
REXUI Class REX.Common Namespace REXUI Class

Name of menu bar.

C#
public static string NameMenu = "Menu";
Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class


REXUI.NameNote Field

REXUI.NameNote Field
REXUI Class REX.Common Namespace REXUI Class

Name of note's container.

C#
public static string NameNote = "NoteContainer";
Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class


REXUI.NameRightContainer Field

REXUI.NameRightContainer Field
REXUI Class REX.Common Namespace REXUI Class

Name of inner tool strip container.

C#
public static string NameRightContainer = "ToolStripContainerInner";
Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class


REXUI.NameStatus Field

REXUI.NameStatus Field
REXUI Class REX.Common Namespace REXUI Class

Name of status bar.

C#
public static string NameStatus = "Status";
Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class


REXUI.NameStatusHeaderLabel Field

REXUI.NameStatusHeaderLabel Field
REXUI Class REX.Common Namespace REXUI Class

Name of label which represents header placed on status bar.

C#
public static string NameStatusHeaderLabel = "StatusHeaderLabel";
Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class


REXUI.NameStatusLabel Field

REXUI.NameStatusLabel Field
REXUI Class REX.Common Namespace REXUI Class

Name of label placed on status bar.

C#
public static string NameStatusLabel = "StatusLabel";
Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class


REXUI.NameStatusProgress Field

REXUI.NameStatusProgress Field
REXUI Class REX.Common Namespace REXUI Class

Name of progress placed on status bar.

C#
public static string NameStatusProgress = "StatusProgress";
Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class


REXUI.NameTabControl Field

REXUI.NameTabControl Field
REXUI Class REX.Common Namespace REXUI Class

Name of tab control.

C#
public static string NameTabControl = "TabControl";
Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class


REXUI.NameTabDialog Field

REXUI.NameTabDialog Field
REXUI Class REX.Common Namespace REXUI Class

Name of tab dialog.

C#
public static string NameTabDialog = "TabDialog";
Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class


REXUI.NameTabNote Field

REXUI.NameTabNote Field
REXUI Class REX.Common Namespace REXUI Class

Name of tab note.

C#
public static string NameTabNote = "TabNote";
Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class


REXUI.NameTabView Field

REXUI.NameTabView Field
REXUI Class REX.Common Namespace REXUI Class

Name of tab view.

C#
public static string NameTabView = "TabView";
Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class


REXUI.NameToolBar Field

REXUI.NameToolBar Field
REXUI Class REX.Common Namespace REXUI Class

Name of tool bar.

C#
public static string NameToolBar = "ToolBar";
Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class


REXUI.NameToolBarInner Field

REXUI.NameToolBarInner Field
REXUI Class REX.Common Namespace REXUI Class

Name of inner tool bar.

C#
public static string NameToolBarInner = "ToolBarInner";
Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class


REXUI.NameToolbox Field

REXUI.NameToolbox Field
REXUI Class REX.Common Namespace REXUI Class

Name of toolbox control.

C#
public static string NameToolbox = "Toolbox";
Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class


REXUI.NameToolMenu Field

REXUI.NameToolMenu Field
REXUI Class REX.Common Namespace REXUI Class

Name of menu bar based on tool bar.

C#
public static string NameToolMenu = "ToolMenu";
Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class


REXUI.NameView Field

REXUI.NameView Field
REXUI Class REX.Common Namespace REXUI Class

Name of view's container.

C#
public static string NameView = "ViewContainer";
Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class


REXUI.NameVSplit Field

REXUI.NameVSplit Field
REXUI Class REX.Common Namespace REXUI Class

Name of vertical splitter.

C#
public static string NameVSplit = "VSplit";
Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class


REXUI.NameVSplitGrid Field

REXUI.NameVSplitGrid Field
REXUI Class REX.Common Namespace REXUI Class

Name of vertical splitter.

C#
public static string NameVSplitGrid = "VSplitGrid";
Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class


REXUI.NameVSplitGridLeft Field

REXUI.NameVSplitGridLeft Field
REXUI Class REX.Common Namespace REXUI Class

Name of vertical splitter.

C#
public static string NameVSplitGridLeft = "VSplitGridLeft";
Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class


REXUI.NameVSplitGridRight Field

REXUI.NameVSplitGridRight Field
REXUI Class REX.Common Namespace REXUI Class

Name of vertical splitter.

C#
public static string NameVSplitGridRight = "VSplitGridRight";
Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class


REXUI.AddToolStrip Method

REXUI.AddToolStrip Method
REXUI Class REX.Common Namespace REXUI Class

Adds the tool strip to repositioning.

C#
public void AddToolStrip(string Name);
Parameters
Parameters | Description
Name | The name of the tool strip.
Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class


REXUI.FindHiddenCommand Method (REXUI.CommandOptions)

REXUI.FindHiddenCommand Method (REXUI.CommandOptions)
REXUI Class REX.Common Namespace REXUI Class

Determines whether the input command is hidden.

C#
public bool FindHiddenCommand(REXUI.CommandOptions command);
Parameters
Parameters | Description
command | The command.
Returns

Returns true if succeeded.

Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class


REXUI.FindHiddenCommand Method (string)

REXUI.FindHiddenCommand Method (string)
REXUI Class REX.Common Namespace REXUI Class

Finds the hidden command.

C#
public bool FindHiddenCommand(string Name);
Parameters
Parameters | Description
Name | The name of the command.
Returns

Returns true if succeeded.

Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class


REXUI.GetAboutLink Method

REXUI.GetAboutLink Method
REXUI Class REX.Common Namespace REXUI Class

Gets the about link.

C#
public FrameworkElement GetAboutLink();
Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class


REXUI.GetDialog Method

REXUI.GetDialog Method
REXUI Class REX.Common Namespace REXUI Class

Gets the dialog control.

C#
public FrameworkElement GetDialog();
Returns

Returns dialog's container.

Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class


REXUI.GetHelpLink Method

REXUI.GetHelpLink Method
REXUI Class REX.Common Namespace REXUI Class

Gets the help link.

C#
public FrameworkElement GetHelpLink();
Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class


REXUI.GetList Method

REXUI.GetList Method
REXUI Class REX.Common Namespace REXUI Class

This is GetList, a member of class REXUI.

C#
public ListView GetList();
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class


REXUI.GetLogo Method

REXUI.GetLogo Method
REXUI Class REX.Common Namespace REXUI Class

Gets the reference to PictureBox which contains logo.

C#
public Image GetLogo();
Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class


REXUI.GetMenu Method

REXUI.GetMenu Method
REXUI Class REX.Common Namespace REXUI Class

Gets the menu control.

C#
public Menu GetMenu();
Returns

Returns menu strip control.

Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class


REXUI.GetMenuBar Method

REXUI.GetMenuBar Method
REXUI Class REX.Common Namespace REXUI Class

Gets the menu bar.

C#
public ToolBar GetMenuBar();
Returns

Returns menu control.

Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class


REXUI.GetNote Method

REXUI.GetNote Method
REXUI Class REX.Common Namespace REXUI Class

Gets the note control.

C#
public FrameworkElement GetNote();
Returns

Returns html note's container.

Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class


REXUI.GetNoteWebBrowser Method

REXUI.GetNoteWebBrowser Method
REXUI Class REX.Common Namespace REXUI Class

Gets the note web browser control.

C#
public WebBrowser GetNoteWebBrowser();
Returns

Returns web browser control.

Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class


REXUI.GetStatus Method

REXUI.GetStatus Method
REXUI Class REX.Common Namespace REXUI Class

Gets the status control.

C#
public StatusBar GetStatus();
Returns

Returns status control.

Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class


REXUI.GetStatusHeaderLabel Method

REXUI.GetStatusHeaderLabel Method
REXUI Class REX.Common Namespace REXUI Class

Gets the status header label.

C#
public Label GetStatusHeaderLabel();
Returns

Returns label which represents header placed on status bar.

Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class


REXUI.GetStatusLabel Method

REXUI.GetStatusLabel Method
REXUI Class REX.Common Namespace REXUI Class

Gets the status label.

C#
public Label GetStatusLabel();
Returns

Returns label placed on status bar.

Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class


REXUI.GetStatusProgress Method

REXUI.GetStatusProgress Method
REXUI Class REX.Common Namespace REXUI Class

Gets the status progress.

C#
public ProgressBar GetStatusProgress();
Returns

Returns progress bar placed on status bar.

Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class


REXUI.GetToolBar Method

REXUI.GetToolBar Method
REXUI Class REX.Common Namespace REXUI Class

Gets the tool bar.

C#
public ToolBar GetToolBar();
Returns

Returns tool bar control.

Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class


REXUI.GetToolBarInner Method

REXUI.GetToolBarInner Method
REXUI Class REX.Common Namespace REXUI Class

Gets the tool bar inner.

C#
public ToolBar GetToolBarInner();
Returns

Returns tool bar control.

Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class


REXUI.GetToolbox Method

REXUI.GetToolbox Method
REXUI Class REX.Common Namespace REXUI Class

Gets the toolbox control.

C#
public REXToolbox GetToolbox();
Returns

Returns the tool box control.

Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class


REXUI.GetViewer Method

REXUI.GetViewer Method
REXUI Class REX.Common Namespace REXUI Class

Gets the viewer's container.

C#
public FrameworkElement GetViewer();
Returns

Returns the viewer's container.

Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class


REXUI.GetWindow Method

REXUI.GetWindow Method
REXUI Class REX.Common Namespace REXUI Class

Gets the reference to main form.

C#
public Window GetWindow();
Returns

Returns the reference to main form.

Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class


REXUI.HideAboutControls Method

REXUI.HideAboutControls Method
REXUI Class REX.Common Namespace REXUI Class

This is HideAboutControls, a member of class REXUI.

C#
public void HideAboutControls();
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class


REXUI.HideAboutLink Method

REXUI.HideAboutLink Method
REXUI Class REX.Common Namespace REXUI Class

Hides the about link.

C#
public void HideAboutLink();
Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class


REXUI.HideCommand Method (REXUI.CommandOptions)

REXUI.HideCommand Method (REXUI.CommandOptions)
REXUI Class REX.Common Namespace REXUI Class

Hides the command.

C#
public void HideCommand(REXUI.CommandOptions command);
Parameters
Parameters | Description
command | The command.
Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class


REXUI.HideCommand Method (string)

REXUI.HideCommand Method (string)
REXUI Class REX.Common Namespace REXUI Class

Hides the command.

C#
public void HideCommand(string Name);
Parameters
Parameters | Description
Name | The name of the command.
Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class


REXUI.HideHelpLink Method

REXUI.HideHelpLink Method
REXUI Class REX.Common Namespace REXUI Class

Hides the help link.

C#
public void HideHelpLink();
Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class


REXUI.LoadNoteUrl Method

REXUI.LoadNoteUrl Method
REXUI Class REX.Common Namespace REXUI Class

Loads the URL to note control.

C#
public void LoadNoteUrl(string URL);
Parameters
Parameters | Description
URL | The URL.
Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class


REXUI.RememberControl Method

REXUI.RememberControl Method
REXUI Class REX.Common Namespace REXUI Class

Remembers the active tab control in specified LayoutItem in ActivTabPage property.

C#
public void RememberControl(long Options, REXLayoutItem LayoutItem);
Parameters
Parameters | Description
Options | The layout's options.
LayoutItem | The layout item.
Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class


REXUI.SetLogo Method

REXUI.SetLogo Method
REXUI Class REX.Common Namespace REXUI Class

Sets the logo image.

C#
public void SetLogo(ImageSource LogoImage);
Parameters
Parameters | Description
LogoImage | The logo image.
Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class


REXUI.SetupControl Method (long)

REXUI.SetupControl Method (long)
REXUI Class REX.Common Namespace REXUI Class

Setups the main control according to default settings.

C#
public void SetupControl(long Options);
Parameters
Parameters | Description
Options | The options.
Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class


REXUI.SetupControl Method (long, REXLayoutItem)

REXUI.SetupControl Method (long, REXLayoutItem)
REXUI Class REX.Common Namespace REXUI Class

Setups the main control according to layout item settings.

C#
public void SetupControl(long Options, REXLayoutItem LayoutItem);
Parameters
Parameters | Description
Options | The options.
LayoutItem | The layout item.
Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class


REXUI.ShowCommand Method (REXUI.CommandOptions)

REXUI.ShowCommand Method (REXUI.CommandOptions)
REXUI Class REX.Common Namespace REXUI Class

Shows the command.

C#
public void ShowCommand(REXUI.CommandOptions command);
Parameters
Parameters | Description
command | The command.
Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class


REXUI.ShowCommand Method (string)

REXUI.ShowCommand Method (string)
REXUI Class REX.Common Namespace REXUI Class

Shows the command.

C#
public void ShowCommand(string Name);
Parameters
Parameters | Description
Name | The name of the command.
Description
Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class


REXUI.MainControl Property

REXUI.MainControl Property
REXUI Class REX.Common Namespace REXUI Class

Gets or sets the main control.

C#
public REXExtensionControl MainControl;
Description

The main control.

Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class


REXUI.MainWindow Property

REXUI.MainWindow Property
REXUI Class REX.Common Namespace REXUI Class

Gets or sets the main form.

C#
public Window MainWindow;
Description

The main form.

Class

REXUI Class

Links
REXUI Class, REX.Common Namespace, REXUI Class


REXVersion Class

REXVersion Class
REX.Common Namespace Legend Members REXVersion Fields

Foundation class for REX.Foundation usage.

Class Hierarchy
C#
public static class REXVersion;
Description
Namespace

REX.Common Namespace

REXVersion Fields
REXVersion Fields | Description
DedicatedVersionName | Dedicated version name (2009, 2010, etx).
Links
REX.Common Namespace, Legend, Members, REXVersion Fields


REXVersion.DedicatedVersionName Field

REXVersion.DedicatedVersionName Field
REXVersion Class REX.Common Namespace REXVersion Class

Dedicated version name (2009, 2010, etx).

C#
public const string DedicatedVersionName = "2018";
Description
Class

REXVersion Class

Links
REXVersion Class, REX.Common Namespace, REXVersion Class


REXWarnings Class

REXWarnings Class
REX.Common Namespace Legend Members REXWarnings Enumerations REXWarnings Methods REXWarnings Structures

This is class REX.Common.REXWarnings.

Class Hierarchy
C#
public class REXWarnings;
Namespace

REX.Common Namespace

REXWarnings Enumerations
REXWarnings Enumerations | Description
WarningCode | This is record REX.Common.REXWarnings.WarningCode.
REXWarnings Methods
REXWarnings Methods | Description
GetMessage | This is GetMessage, a member of class REXWarnings.
REXWarnings Structures
REXWarnings Structures | Description
errMapStr | This is class REX.Common.REXWarnings.errMapStr.
Links
REX.Common Namespace, Legend, Members, REXWarnings Enumerations, REXWarnings Methods, REXWarnings Structures


REXWarnings.errMapStr Structure

REXWarnings.errMapStr Structure
REXWarnings Class Legend Members Public Methods errMapStr Fields

This is class REX.Common.REXWarnings.errMapStr.

C#
public struct errMapStr {
  public WarningCode ecode;
  public String msg;
}
Class

REXWarnings Class

Public Methods
Public Method | Description
errMapStr | This is errMapStr, a member of class errMapStr.
errMapStr Fields
errMapStr Fields | Description
ecode | This is ecode, a member of class errMapStr.
msg | This is msg, a member of class errMapStr.
Links
REXWarnings Class, Legend, Members, Public Methods, errMapStr Fields


REXWarnings.errMapStr.errMapStr Constructor

REXWarnings.errMapStr.errMapStr Constructor
REXWarnings.errMapStr Structure REX.Common Namespace REXWarnings.errMapStr Structure

This is errMapStr, a member of class errMapStr.

C#
public errMapStr(WarningCode e, String m);
Structure

REXWarnings.errMapStr Structure

Links
REXWarnings.errMapStr Structure, REX.Common Namespace, REXWarnings.errMapStr Structure


REXWarnings.errMapStr.ecode Field

REXWarnings.errMapStr.ecode Field
REXWarnings.errMapStr Structure REX.Common Namespace REXWarnings.errMapStr Structure

This is ecode, a member of class errMapStr.

C#
public WarningCode ecode;
Structure

REXWarnings.errMapStr Structure

Links
REXWarnings.errMapStr Structure, REX.Common Namespace, REXWarnings.errMapStr Structure


REXWarnings.errMapStr.msg Field

REXWarnings.errMapStr.msg Field
REXWarnings.errMapStr Structure REX.Common Namespace REXWarnings.errMapStr Structure

This is msg, a member of class errMapStr.

C#
public String msg;
Structure

REXWarnings.errMapStr Structure

Links
REXWarnings.errMapStr Structure, REX.Common Namespace, REXWarnings.errMapStr Structure


REX.Common.REXWarnings.WarningCode Enumeration

REX.Common.REXWarnings.WarningCode Enumeration
REXWarnings Class

This is record REX.Common.REXWarnings.WarningCode.

C#
public enum WarningCode {
  eUNKNOWN = 0,
  eTREE_ADD_NODE = 1000,
  eLIST_ADD_NODE = 1001,
  eFILE_NOT_FOUND = 2000,
  eENGINE_PRODUCT_NOINFO = 3000
}
Class

REXWarnings Class

Links
REXWarnings Class
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXWarnings.GetMessage Method

REXWarnings.GetMessage Method
REXWarnings Class REX.Common Namespace REXWarnings Class

This is GetMessage, a member of class REXWarnings.

C#
public static String GetMessage(WarningCode e);
Class

REXWarnings Class

Links
REXWarnings Class, REX.Common Namespace, REXWarnings Class


REXWebBrowser Class

REXWebBrowser Class
REX.Common Namespace Legend Members REXWebBrowser Fields REXWebBrowser Methods

Proxy class for web browser control.

Class Hierarchy
C#
public class REXWebBrowser;
Description

Loads html page on thread.

Namespace

REX.Common Namespace

REXWebBrowser Fields
REXWebBrowser Fields | Description
ThreadRef | The reference to thread.
URL | The URL for html page.
WB | The reference to WebBrowser object.
REXWebBrowser Methods
REXWebBrowser Methods | Description
Start | Starts thread and loads html page on thread.
StartThread | Starts the thread.
Links
REX.Common Namespace, Legend, Members, REXWebBrowser Fields, REXWebBrowser Methods


REXWebBrowser.ThreadRef Field

REXWebBrowser.ThreadRef Field
REXWebBrowser Class REX.Common Namespace REXWebBrowser Class

The reference to thread.

C#
public Thread ThreadRef;
Description
Class

REXWebBrowser Class

Links
REXWebBrowser Class, REX.Common Namespace, REXWebBrowser Class


REXWebBrowser.URL Field

REXWebBrowser.URL Field
REXWebBrowser Class REX.Common Namespace REXWebBrowser Class

The URL for html page.

C#
public string URL;
Description
Class

REXWebBrowser Class

Links
REXWebBrowser Class, REX.Common Namespace, REXWebBrowser Class


REXWebBrowser.WB Field

REXWebBrowser.WB Field
REXWebBrowser Class REX.Common Namespace REXWebBrowser Class

The reference to WebBrowser object.

C#
public System.Windows.Controls.WebBrowser WB;
Description
Class

REXWebBrowser Class

Links
REXWebBrowser Class, REX.Common Namespace, REXWebBrowser Class


REXWebBrowser.Start Method

REXWebBrowser.Start Method
REXWebBrowser Class REX.Common Namespace REXWebBrowser Class

Starts thread and loads html page on thread.

C#
public void Start();
Description
Class

REXWebBrowser Class

Links
REXWebBrowser Class, REX.Common Namespace, REXWebBrowser Class


REXWebBrowser.StartThread Method

REXWebBrowser.StartThread Method
REXWebBrowser Class REX.Common Namespace REXWebBrowser Class

Starts the thread.

C#
public void StartThread();
Description
Class

REXWebBrowser Class

Links
REXWebBrowser Class, REX.Common Namespace, REXWebBrowser Class


IREXConnector Interface

IREXConnector Interface
REX.Common Namespace Legend Members IREXConnector Methods IREXConnector Properties

This is class REX.Common.IREXConnector.

Class Hierarchy
C#
public interface IREXConnector;
Namespace

REX.Common Namespace

IREXConnector Methods
IREXConnector Methods | Description
Connect | This is Connect, a member of class IREXConnector.
VerifyVersion | This is VerifyVersion, a member of class IREXConnector.
VerifyVersion | This is VerifyVersion, a member of class IREXConnector.
IREXConnector Properties
IREXConnector Properties | Description
Connected | This is Connected, a member of class IREXConnector.
Installed | This is Installed, a member of class IREXConnector.
IsCOMObject | This is IsCOMObject, a member of class IREXConnector.
Links
REX.Common Namespace, Legend, Members, IREXConnector Methods, IREXConnector Properties


IREXConnector.Connect Method

IREXConnector.Connect Method
IREXConnector Interface REX.Common Namespace IREXConnector Interface

This is Connect, a member of class IREXConnector.

C#
bool Connect();
Interface

IREXConnector Interface

Links
IREXConnector Interface, REX.Common Namespace, IREXConnector Interface


IREXConnector.VerifyVersion Method (string)

IREXConnector.VerifyVersion Method (string)
IREXConnector Interface REX.Common Namespace IREXConnector Interface

This is VerifyVersion, a member of class IREXConnector.

C#
bool VerifyVersion(ref string Version);
Interface

IREXConnector Interface

Links
IREXConnector Interface, REX.Common Namespace, IREXConnector Interface


IREXConnector.VerifyVersion Method (string, System.Collections.Generic.List<string>)

IREXConnector.VerifyVersion Method (string, System.Collections.Generic.List<string>)
IREXConnector Interface REX.Common Namespace IREXConnector Interface

This is VerifyVersion, a member of class IREXConnector.

C#
bool VerifyVersion(ref string Version, System.Collections.Generic.List<string> Versions);
Interface

IREXConnector Interface

Links
IREXConnector Interface, REX.Common Namespace, IREXConnector Interface


IREXConnector.Connected Property

IREXConnector.Connected Property
IREXConnector Interface REX.Common Namespace IREXConnector Interface

This is Connected, a member of class IREXConnector.

C#
bool Connected;
Interface

IREXConnector Interface

Links
IREXConnector Interface, REX.Common Namespace, IREXConnector Interface


IREXConnector.Installed Property

IREXConnector.Installed Property
IREXConnector Interface REX.Common Namespace IREXConnector Interface

This is Installed, a member of class IREXConnector.

C#
bool Installed;
Interface

IREXConnector Interface

Links
IREXConnector Interface, REX.Common Namespace, IREXConnector Interface


IREXConnector.IsCOMObject Property

IREXConnector.IsCOMObject Property
IREXConnector Interface REX.Common Namespace IREXConnector Interface

This is IsCOMObject, a member of class IREXConnector.

C#
bool IsCOMObject;
Interface

IREXConnector Interface

Links
IREXConnector Interface, REX.Common Namespace, IREXConnector Interface


IREXExtension Interface

IREXExtension Interface
REX.Common Namespace Legend Members IREXExtension Methods

Main interface for extension module.

Class Hierarchy
C#
public interface IREXExtension;
Description
Namespace

REX.Common Namespace

IREXExtension Methods
IREXExtension Methods | Description
OnActivateLayout | Activates or deactivates layout - module can modify layout before or after activation.
OnCanClose | If returns true, dialog will close after OK button clicked.
OnCanClose | Called when closing module.
OnCanRun | Checks status of module and shows some information for user if modult can't run action.
OnClear | Called when clear data.
OnClose | Called during closing module.
OnCommand | Called when command.
OnCreate | Creates needed structures and verify needs.
OnCreateDialogs | Creates sub dialogs.
OnCreateLayout | Creates layout items and setups layout.
OnDataLoad | Called when data are loaded.
OnDataLoaded | Called when data are loaded.
OnDataSave | Called when data are saved.
OnDataSaved | Called when data are saved.
OnErrorSelected | Called when error selected on errors list dialog.
OnEvent | Called when event.
OnGetText | Get specified text from resources.
OnInitialize | Called when initialize.
OnLoadTemplate | Called when load template.
OnPreferencesChanged | Called when preferences changed.
OnRun | Run process calculations or other operations.
OnSaveTemplate | Called when save template.
OnSetData | Get data from dialogs and sets Data's strucutres.
OnSetDialogs | Set data in dialogs.
OnShowResults | Shows results.
OnUpdateDialogs | Called when update dialogs.
Links
REX.Common Namespace, Legend, Members, IREXExtension Methods


IREXExtension.OnActivateLayout Method

IREXExtension.OnActivateLayout Method
IREXExtension Interface REX.Common Namespace IREXExtension Interface

Activates or deactivates layout - module can modify layout before or after activation.

C#
void OnActivateLayout(REXLayoutItem LItem, bool Activate);
Parameters
Parameters | Description
LItem | The layout item.
Activate | If set to true, layout is activated.
Description
Interface

IREXExtension Interface

Links
IREXExtension Interface, REX.Common Namespace, IREXExtension Interface


IREXExtension.OnCanClose Method ()

IREXExtension.OnCanClose Method ()
IREXExtension Interface REX.Common Namespace IREXExtension Interface

If returns true, dialog will close after OK button clicked.

C#
bool OnCanClose();
Returns

Returns true if module can be closed.

Description
Interface

IREXExtension Interface

Links
IREXExtension Interface, REX.Common Namespace, IREXExtension Interface


IREXExtension.OnCanClose Method (REXCanCloseType)

IREXExtension.OnCanClose Method (REXCanCloseType)
IREXExtension Interface REX.Common Namespace IREXExtension Interface

Called when closing module.

C#
bool OnCanClose(REXCanCloseType Type);
Parameters
Parameters | Description
Type | The closing type. See REXCanCloseType enum.
Returns

Returns true if module can be closed.

Description
Interface

IREXExtension Interface

Links
IREXExtension Interface, REX.Common Namespace, IREXExtension Interface


IREXExtension.OnCanRun Method

IREXExtension.OnCanRun Method
IREXExtension Interface REX.Common Namespace IREXExtension Interface

Checks status of module and shows some information for user if modult can't run action.

C#
bool OnCanRun();
Returns

Returns true if module can do some action in OnRun method; otherwise false.

Description
Interface

IREXExtension Interface

Links
IREXExtension Interface, REX.Common Namespace, IREXExtension Interface


IREXExtension.OnClear Method

IREXExtension.OnClear Method
IREXExtension Interface REX.Common Namespace IREXExtension Interface

Called when clear data.

C#
bool OnClear(out bool Implemented);
Parameters
Parameters | Description
Implemented | If returns true method was implemented.
Returns

Returns result of clear operation.

Description
Interface

IREXExtension Interface

Links
IREXExtension Interface, REX.Common Namespace, IREXExtension Interface


IREXExtension.OnClose Method

IREXExtension.OnClose Method
IREXExtension Interface REX.Common Namespace IREXExtension Interface

Called during closing module.

C#
void OnClose();
Description
Interface

IREXExtension Interface

Links
IREXExtension Interface, REX.Common Namespace, IREXExtension Interface


IREXExtension.OnCommand Method

IREXExtension.OnCommand Method
IREXExtension Interface REX.Common Namespace IREXExtension Interface

Called when command.

C#
object OnCommand(ref REXCommand CommandStruct);
Parameters
Parameters | Description
CommandStruct | The command struct.
Returns

Returns result of command operation.

Description
Interface

IREXExtension Interface

Links
IREXExtension Interface, REX.Common Namespace, IREXExtension Interface


IREXExtension.OnCreate Method

IREXExtension.OnCreate Method
IREXExtension Interface REX.Common Namespace IREXExtension Interface

Creates needed structures and verify needs.

C#
void OnCreate();
Description
Interface

IREXExtension Interface

Links
IREXExtension Interface, REX.Common Namespace, IREXExtension Interface


IREXExtension.OnCreateDialogs Method

IREXExtension.OnCreateDialogs Method
IREXExtension Interface REX.Common Namespace IREXExtension Interface

Creates sub dialogs.

C#
void OnCreateDialogs();
Description
Interface

IREXExtension Interface

Links
IREXExtension Interface, REX.Common Namespace, IREXExtension Interface


IREXExtension.OnCreateLayout Method

IREXExtension.OnCreateLayout Method
IREXExtension Interface REX.Common Namespace IREXExtension Interface

Creates layout items and setups layout.

C#
void OnCreateLayout();
Description
Interface

IREXExtension Interface

Links
IREXExtension Interface, REX.Common Namespace, IREXExtension Interface


IREXExtension.OnDataLoad Method

IREXExtension.OnDataLoad Method
IREXExtension Interface REX.Common Namespace IREXExtension Interface

Called when data are loaded.

C#
bool OnDataLoad();
Returns

Returns true if succeeded.

Description
Interface

IREXExtension Interface

Links
IREXExtension Interface, REX.Common Namespace, IREXExtension Interface


IREXExtension.OnDataLoaded Method

IREXExtension.OnDataLoaded Method
IREXExtension Interface REX.Common Namespace IREXExtension Interface

Called when data are loaded.

C#
void OnDataLoaded(bool Result);
Parameters
Parameters | Description
Result | If set to true operation succeeded; Otherwise some errors found.
Description
Interface

IREXExtension Interface

Links
IREXExtension Interface, REX.Common Namespace, IREXExtension Interface


IREXExtension.OnDataSave Method

IREXExtension.OnDataSave Method
IREXExtension Interface REX.Common Namespace IREXExtension Interface

Called when data are saved.

C#
bool OnDataSave();
Returns

Returns true if succeeded.

Description
Interface

IREXExtension Interface

Links
IREXExtension Interface, REX.Common Namespace, IREXExtension Interface


IREXExtension.OnDataSaved Method

IREXExtension.OnDataSaved Method
IREXExtension Interface REX.Common Namespace IREXExtension Interface

Called when data are saved.

C#
void OnDataSaved(bool Result);
Parameters
Parameters | Description
Result | If set to true operation succeeded; Otherwise some errors found.
Description
Interface

IREXExtension Interface

Links
IREXExtension Interface, REX.Common Namespace, IREXExtension Interface


IREXExtension.OnErrorSelected Method

IREXExtension.OnErrorSelected Method
IREXExtension Interface REX.Common Namespace IREXExtension Interface

Called when error selected on errors list dialog.

C#
void OnErrorSelected(REXErrorsEventArgs e);
Parameters
Parameters | Description
e | The Autodesk.REX.Framework.REXErrorsEventArgs instance containing the event data.
Description

Raises the ErrorSelected event.

Interface

IREXExtension Interface

Links
IREXExtension Interface, REX.Common Namespace, IREXExtension Interface


IREXExtension.OnEvent Method

IREXExtension.OnEvent Method
IREXExtension Interface REX.Common Namespace IREXExtension Interface

Called when event.

C#
object OnEvent(ref REXEvent EventStruct);
Parameters
Parameters | Description
EventStruct | The event struct.
Returns

Returns result of eventoperation.

Description
Interface

IREXExtension Interface

Links
IREXExtension Interface, REX.Common Namespace, IREXExtension Interface


IREXExtension.OnGetText Method

IREXExtension.OnGetText Method
IREXExtension Interface REX.Common Namespace IREXExtension Interface

Get specified text from resources.

C#
string OnGetText(string Name);
Parameters
Parameters | Description
Name | The name of string.
Returns

Returns specified text.

Description

Needed for obfuscated strings tables.

Interface

IREXExtension Interface

Links
IREXExtension Interface, REX.Common Namespace, IREXExtension Interface


IREXExtension.OnInitialize Method

IREXExtension.OnInitialize Method
IREXExtension Interface REX.Common Namespace IREXExtension Interface

Called when initialize.

C#
bool OnInitialize();
Returns

Returns true if succeeded.

Description
Interface

IREXExtension Interface

Links
IREXExtension Interface, REX.Common Namespace, IREXExtension Interface


IREXExtension.OnLoadTemplate Method

IREXExtension.OnLoadTemplate Method
IREXExtension Interface REX.Common Namespace IREXExtension Interface

Called when load template.

C#
bool OnLoadTemplate();
Parameters
Parameters | Description
Result | If set to true operation succeeded; Otherwise some errors found.
Description

Only if ExtensionContext.Control.StandardRunContext is equals to REXExtensionContext.REXStandardRunContext.OperationEditTemplate.

Interface

IREXExtension Interface

Links
IREXExtension Interface, REX.Common Namespace, IREXExtension Interface


IREXExtension.OnPreferencesChanged Method

IREXExtension.OnPreferencesChanged Method
IREXExtension Interface REX.Common Namespace IREXExtension Interface

Called when preferences changed.

C#
void OnPreferencesChanged();
Description
Interface

IREXExtension Interface

Links
IREXExtension Interface, REX.Common Namespace, IREXExtension Interface


IREXExtension.OnRun Method

IREXExtension.OnRun Method
IREXExtension Interface REX.Common Namespace IREXExtension Interface

Run process calculations or other operations.

C#
void OnRun();
Description
Interface

IREXExtension Interface

Links
IREXExtension Interface, REX.Common Namespace, IREXExtension Interface


IREXExtension.OnSaveTemplate Method

IREXExtension.OnSaveTemplate Method
IREXExtension Interface REX.Common Namespace IREXExtension Interface

Called when save template.

C#
bool OnSaveTemplate();
Parameters
Parameters | Description
Result | If set to true operation succeeded; Otherwise some errors found.
Description
Interface

IREXExtension Interface

Links
IREXExtension Interface, REX.Common Namespace, IREXExtension Interface


IREXExtension.OnSetData Method

IREXExtension.OnSetData Method
IREXExtension Interface REX.Common Namespace IREXExtension Interface

Get data from dialogs and sets Data's strucutres.

C#
void OnSetData();
Description
Interface

IREXExtension Interface

Links
IREXExtension Interface, REX.Common Namespace, IREXExtension Interface


IREXExtension.OnSetDialogs Method

IREXExtension.OnSetDialogs Method
IREXExtension Interface REX.Common Namespace IREXExtension Interface

Set data in dialogs.

C#
void OnSetDialogs();
Description
Interface

IREXExtension Interface

Links
IREXExtension Interface, REX.Common Namespace, IREXExtension Interface


IREXExtension.OnShowResults Method

IREXExtension.OnShowResults Method
IREXExtension Interface REX.Common Namespace IREXExtension Interface

Shows results.

C#
void OnShowResults();
Description
Interface

IREXExtension Interface

Links
IREXExtension Interface, REX.Common Namespace, IREXExtension Interface


IREXExtension.OnUpdateDialogs Method

IREXExtension.OnUpdateDialogs Method
IREXExtension Interface REX.Common Namespace IREXExtension Interface

Called when update dialogs.

C#
void OnUpdateDialogs();
Description

Currently is not used.

Interface

IREXExtension Interface

Links
IREXExtension Interface, REX.Common Namespace, IREXExtension Interface


IREXExtension2 Interface

IREXExtension2 Interface
REX.Common Namespace Legend Members IREXExtension2 Methods

Main interface for extension module.

Class Hierarchy
C#
public interface IREXExtension2 : IREXExtension;
Description
Namespace

REX.Common Namespace

IREXExtension2 Methods
IREXExtension2 Methods | Description
OnCanActivateLayout | Ask for activation - module can modify layout before or after activation.
OnGetExtensionName | Called when get extension name.
OnRegionalSettingsChanged | Called when regional settings changed.
Links
REX.Common Namespace, Legend, Members, IREXExtension2 Methods


IREXExtension2.OnCanActivateLayout Method

IREXExtension2.OnCanActivateLayout Method
IREXExtension2 Interface REX.Common Namespace IREXExtension2 Interface

Ask for activation - module can modify layout before or after activation.

C#
bool OnCanActivateLayout(REXLayoutItem LItem);
Parameters
Parameters | Description
LItem | The layout item.
Description
Interface

IREXExtension2 Interface

Links
IREXExtension2 Interface, REX.Common Namespace, IREXExtension2 Interface


IREXExtension2.OnGetExtensionName Method

IREXExtension2.OnGetExtensionName Method
IREXExtension2 Interface REX.Common Namespace IREXExtension2 Interface

Called when get extension name.

C#
string OnGetExtensionName(REXExtensionNameContext nameContext);
Parameters
Parameters | Description
nameContext | The name context.
Description
Interface

IREXExtension2 Interface

Links
IREXExtension2 Interface, REX.Common Namespace, IREXExtension2 Interface


IREXExtension2.OnRegionalSettingsChanged Method

IREXExtension2.OnRegionalSettingsChanged Method
IREXExtension2 Interface REX.Common Namespace IREXExtension2 Interface

Called when regional settings changed.

C#
void OnRegionalSettingsChanged();
Description
Interface

IREXExtension2 Interface

Links
IREXExtension2 Interface, REX.Common Namespace, IREXExtension2 Interface


IREXExtension3 Interface

IREXExtension3 Interface
REX.Common Namespace Legend Members IREXExtension3 Methods

Main interface for extension module.

Class Hierarchy
C#
public interface IREXExtension3 : IREXExtension2;
Description
Namespace

REX.Common Namespace

IREXExtension3 Methods
IREXExtension3 Methods | Description
OnSetContext | Called when regional settings changed.
Links
REX.Common Namespace, Legend, Members, IREXExtension3 Methods


IREXExtension3.OnSetContext Method

IREXExtension3.OnSetContext Method
IREXExtension3 Interface REX.Common Namespace IREXExtension3 Interface

Called when regional settings changed.

C#
void OnSetContext(REXContext context);
Description
Interface

IREXExtension3 Interface

Links
IREXExtension3 Interface, REX.Common Namespace, IREXExtension3 Interface


IREXExtension4 Interface

IREXExtension4 Interface
REX.Common Namespace Legend Members IREXExtension4 Methods

Main interface for extension module.

Class Hierarchy
C#
public interface IREXExtension4 : IREXExtension3;
Description
Namespace

REX.Common Namespace

IREXExtension4 Methods
IREXExtension4 Methods | Description
OnCheckValidity | Called when check validity.
Links
REX.Common Namespace, Legend, Members, IREXExtension4 Methods


IREXExtension4.OnCheckValidity Method

IREXExtension4.OnCheckValidity Method
IREXExtension4 Interface REX.Common Namespace IREXExtension4 Interface

Called when check validity.

C#
bool? OnCheckValidity();
Description
Interface

IREXExtension4 Interface

Links
IREXExtension4 Interface, REX.Common Namespace, IREXExtension4 Interface


IREXExtensionAccess Interface

IREXExtensionAccess Interface
REX.Common Namespace Legend Members IREXExtensionAccess Methods

Main interface for REXAccess class.

Class Hierarchy
C#
public interface IREXExtensionAccess;
Description
Namespace

REX.Common Namespace

IREXExtensionAccess Methods
IREXExtensionAccess Methods | Description
Create | Reads some data from parent application and set system display units.
Destroy | Destroys and resets some objects connected to parent application.
Initialize | Initializes this instance.
Update | Reads some data from parent application and set system display units.
Links
REX.Common Namespace, Legend, Members, IREXExtensionAccess Methods


IREXExtensionAccess.Create Method

IREXExtensionAccess.Create Method
IREXExtensionAccess Interface REX.Common Namespace IREXExtensionAccess Interface

Reads some data from parent application and set system display units.

C#
bool Create();
Returns

Returns true if succeeded.

Description
Interface

IREXExtensionAccess Interface

Links
IREXExtensionAccess Interface, REX.Common Namespace, IREXExtensionAccess Interface


IREXExtensionAccess.Destroy Method

IREXExtensionAccess.Destroy Method
IREXExtensionAccess Interface REX.Common Namespace IREXExtensionAccess Interface

Destroys and resets some objects connected to parent application.

C#
bool Destroy();
Returns

Returns true if succeeded.

Description
Interface

IREXExtensionAccess Interface

Links
IREXExtensionAccess Interface, REX.Common Namespace, IREXExtensionAccess Interface


IREXExtensionAccess.Initialize Method

IREXExtensionAccess.Initialize Method
IREXExtensionAccess Interface REX.Common Namespace IREXExtensionAccess Interface

Initializes this instance.

C#
void Initialize();
Description

Nostly sets language from parent application.

Interface

IREXExtensionAccess Interface

Links
IREXExtensionAccess Interface, REX.Common Namespace, IREXExtensionAccess Interface


IREXExtensionAccess.Update Method

IREXExtensionAccess.Update Method
IREXExtensionAccess Interface REX.Common Namespace IREXExtensionAccess Interface

Reads some data from parent application and set system display units.

C#
void Update();
Description
Interface

IREXExtensionAccess Interface

Links
IREXExtensionAccess Interface, REX.Common Namespace, IREXExtensionAccess Interface


IREXExtensionAccess2 Interface

IREXExtensionAccess2 Interface
REX.Common Namespace Legend Members IREXExtensionAccess2 Methods

Main interface for REXAccess class.

Class Hierarchy
C#
public interface IREXExtensionAccess2 : IREXExtensionAccess;
Description
Namespace

REX.Common Namespace

IREXExtensionAccess2 Methods
IREXExtensionAccess2 Methods | Description
Event | Events the specified ev.
Links
REX.Common Namespace, Legend, Members, IREXExtensionAccess2 Methods


IREXExtensionAccess2.Event Method

IREXExtensionAccess2.Event Method
IREXExtensionAccess2 Interface REX.Common Namespace IREXExtensionAccess2 Interface

Events the specified ev.

C#
bool Event(REXAccess.REXAccessEvent Ev);
Parameters
Parameters | Description
Ev | The ev.
Description
Interface

IREXExtensionAccess2 Interface

Links
IREXExtensionAccess2 Interface, REX.Common Namespace, IREXExtensionAccess2 Interface


IREXExtensionAccess3 Interface

IREXExtensionAccess3 Interface
REX.Common Namespace Legend Members IREXExtensionAccess3 Methods

Main interface for REXAccess class.

Class Hierarchy
C#
public interface IREXExtensionAccess3 : IREXExtensionAccess2;
Description
Namespace

REX.Common Namespace

IREXExtensionAccess3 Methods
IREXExtensionAccess3 Methods | Description
Detach | Detaches this instance.
Links
REX.Common Namespace, Legend, Members, IREXExtensionAccess3 Methods


IREXExtensionAccess3.Detach Method

IREXExtensionAccess3.Detach Method
IREXExtensionAccess3 Interface REX.Common Namespace IREXExtensionAccess3 Interface

Detaches this instance.

C#
void Detach();
Description
Interface

IREXExtensionAccess3 Interface

Links
IREXExtensionAccess3 Interface, REX.Common Namespace, IREXExtensionAccess3 Interface


IREXExtensionAccessUnitsControl Interface

IREXExtensionAccessUnitsControl Interface
REX.Common Namespace Legend Members IREXExtensionAccessUnitsControl Methods

Main interface for REXAccess class.

Class Hierarchy
C#
public interface IREXExtensionAccessUnitsControl;
Description
Namespace

REX.Common Namespace

IREXExtensionAccessUnitsControl Methods
IREXExtensionAccessUnitsControl Methods | Description
Setup | Setups this instance.
Update | Updates this instance.
Links
REX.Common Namespace, Legend, Members, IREXExtensionAccessUnitsControl Methods


IREXExtensionAccessUnitsControl.Setup Method

IREXExtensionAccessUnitsControl.Setup Method
IREXExtensionAccessUnitsControl Interface REX.Common Namespace IREXExtensionAccessUnitsControl Interface

Setups this instance.

C#
bool Setup();
Description
Interface

IREXExtensionAccessUnitsControl Interface

Links
IREXExtensionAccessUnitsControl Interface, REX.Common Namespace, IREXExtensionAccessUnitsControl Interface


IREXExtensionAccessUnitsControl.Update Method

IREXExtensionAccessUnitsControl.Update Method
IREXExtensionAccessUnitsControl Interface REX.Common Namespace IREXExtensionAccessUnitsControl Interface

Updates this instance.

C#
void Update();
Description
Interface

IREXExtensionAccessUnitsControl Interface

Links
IREXExtensionAccessUnitsControl Interface, REX.Common Namespace, IREXExtensionAccessUnitsControl Interface


IREXThisExtension Interface

IREXThisExtension Interface
REX.Common Namespace Legend Members IREXThisExtension Properties

Base interface for access to main extension's objects.

Class Hierarchy
C#
public interface IREXThisExtension;
Description
Namespace

REX.Common Namespace

IREXThisExtension Properties
IREXThisExtension Properties | Description
ThisApplication | This is ThisApplication, a member of class IREXThisExtension.
ThisContext | This is ThisContext, a member of class IREXThisExtension.
ThisExtension | This is ThisExtension, a member of class IREXThisExtension.
Links
REX.Common Namespace, Legend, Members, IREXThisExtension Properties


IREXThisExtension.ThisApplication Property

IREXThisExtension.ThisApplication Property
IREXThisExtension Interface REX.Common Namespace IREXThisExtension Interface

This is ThisApplication, a member of class IREXThisExtension.

C#
REXApplication ThisApplication;
Interface

IREXThisExtension Interface

Links
IREXThisExtension Interface, REX.Common Namespace, IREXThisExtension Interface


IREXThisExtension.ThisContext Property

IREXThisExtension.ThisContext Property
IREXThisExtension Interface REX.Common Namespace IREXThisExtension Interface

This is ThisContext, a member of class IREXThisExtension.

C#
REXContext ThisContext;
Interface

IREXThisExtension Interface

Links
IREXThisExtension Interface, REX.Common Namespace, IREXThisExtension Interface


IREXThisExtension.ThisExtension Property

IREXThisExtension.ThisExtension Property
IREXThisExtension Interface REX.Common Namespace IREXThisExtension Interface

This is ThisExtension, a member of class IREXThisExtension.

C#
REXExtension ThisExtension;
Interface

IREXThisExtension Interface

Links
IREXThisExtension Interface, REX.Common Namespace, IREXThisExtension Interface


REX.Common.REXCanCloseType Enumeration

REX.Common.REXCanCloseType Enumeration
REX.Common Namespace

Determines closing mode.

C#
public enum REXCanCloseType {
  Close,
  OK,
  Check
}
Members
Members | Description
Close | User selected Cancel button or closed the module.
OK | User selected OK button.
Check | OnCanClose method called for check if it is possible to close the module.
Description
Namespace

REX.Common Namespace

Links
REX.Common Namespace
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REX.Common.REXSetFormStruct Structure

REX.Common.REXSetFormStruct Structure
REX.Common Namespace

This is record REX.Common.REXSetFormStruct.

C#
public struct REXSetFormStruct {
  public Size AllControlsSize;
  public Size BottomAllControlsSize;
  public long Options;
}
Namespace

REX.Common Namespace

Links
REX.Common Namespace
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REX.Common.Revit.Units Namespace

Previous | Next
REX.Common.Revit.Units Namespace
Legend Classes

This is namespace REX.Common.Revit.Units.

Classes
Class | Description
REXUnitsControl | Display units management class for Revit context.
Links
Legend, Classes
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXUnitsControl Class

REXUnitsControl Class
REX.Common.Revit.Units Namespace Legend Members Public Methods REXUnitsControl Methods

Display units management class for Revit context.

Class Hierarchy
C#
public class REXUnitsControl : REXExtensionObject;
Description

The class is automatically used by base SDK classes for mapping units of parent program. Called from REXRCADAccess class. Used only by extensions launched from Revit.

Namespace

REX.Common.Revit.Units Namespace

Public Methods
Public Method | Description
REXUnitsControl | Initializes a new instance of the REXUnitsControl class.
REXUnitsControl Methods
REXUnitsControl Methods | Description
Setup | Setups display units.
Update | Updates display units.
Links
REX.Common.Revit.Units Namespace, Legend, Members, Public Methods, REXUnitsControl Methods


REXUnitsControl.REXUnitsControl Constructor

REXUnitsControl.REXUnitsControl Constructor
REXUnitsControl Class REX.Common.Revit.Units Namespace REXUnitsControl Class

Initializes a new instance of the REXUnitsControl class.

C#
public REXUnitsControl(REXExtension Ext);
Parameters
Parameters | Description
Ext | The reference to REXExtension class.
Description
Class

REXUnitsControl Class

Links
REXUnitsControl Class, REX.Common.Revit.Units Namespace, REXUnitsControl Class


REXUnitsControl.Setup Method

REXUnitsControl.Setup Method
REXUnitsControl Class REX.Common.Revit.Units Namespace REXUnitsControl Class

Setups display units.

C#
public bool Setup();
Returns

Returns true if succesfull.

Description
Class

REXUnitsControl Class

Links
REXUnitsControl Class, REX.Common.Revit.Units Namespace, REXUnitsControl Class


REXUnitsControl.Update Method

REXUnitsControl.Update Method
REXUnitsControl Class REX.Common.Revit.Units Namespace REXUnitsControl Class See Also

Updates display units.

C#
public void Update();
Description
See Also

Setup()

Class

REXUnitsControl Class

Links
REXUnitsControl Class, REX.Common.Revit.Units Namespace, REXUnitsControl Class, See Also


REX.ContentGenerator.Converters Namespace

Previous | Next
REX.ContentGenerator.Converters Namespace
Legend Classes Interfaces Structs, Records, Enums Types

This is namespace REX.ContentGenerator.Converters.

Classes
Class | Description
FieldParams | Represents parameters of the field.
REXContentFilter | Base class for all filters.
REXContentLogicFilter | Describes a logic filter.
REXContentParamFilter | Describes the filter for the specified parameter.
REXCustomFactory | This is class REX.ContentGenerator.Converters.REXCustomFactory.
REXDBSectionFactory | This is class REX.ContentGenerator.Converters.REXDBSectionFactory.
REXFamilyConverter | This class represents a converter which provides access to common databases.
REXMaterialFactory | This is class REX.ContentGenerator.Converters.REXMaterialFactory.
REXParamSectionFactory | This is class REX.ContentGenerator.Converters.REXParamSectionFactory.
RVTCommonSectionFactory | This is class REX.ContentGenerator.Converters.RVTCommonSectionFactory.
RVTCustomFactory | This is class REX.ContentGenerator.Converters.RVTCustomFactory.
RVTDBSectionFactory | This is class REX.ContentGenerator.Converters.RVTDBSectionFactory.
RVTFamilyConverter | This class represents a converter which provides access to Revit project.
RVTMaterialFactory | This is class REX.ContentGenerator.Converters.RVTMaterialFactory.
RVTMaterialPropertySetFactory | This is class REX.ContentGenerator.Converters.RVTMaterialPropertySetFactory.
RVTSectionFactory | This is class REX.ContentGenerator.Converters.RVTSectionFactory.
RVTSectionParamFactory | This is class REX.ContentGenerator.Converters.RVTSectionParamFactory.
Interfaces
Interface | Description
IRexContentSettings | Provides interface for the settings of the REXFamilyConverter.
IRvtContentSettings | Provides interface for the settings of the RVTFamilyConverter.
Structs, Records, Enums
Struct, Record, Enum | Description
EDBAccess | Describes the access to databases.
Types
Type | Description
ElementGenerated | Delagate for the generation event (when the list of elements is used).
Links
Legend, Classes, Interfaces, Structs, Records, Enums, Types


FieldParams Class

FieldParams Class
REX.ContentGenerator.Converters Namespace Legend Members Public Methods FieldParams Methods FieldParams Properties

Represents parameters of the field.

Class Hierarchy
C#
public class FieldParams : Attribute;
Description
Namespace

REX.ContentGenerator.Converters Namespace

Public Methods
Public Method | Description
FieldParams | Initializes a new instance of the FieldParams class.
FieldParams Methods
FieldParams Methods | Description
GetDefaultValue | Gets the default value.
GetDefaultValue | Gets the default value.
FieldParams Properties
FieldParams Properties | Description
database | Gets or sets the name in database.
display | Gets or sets the display name.
identity | Gets or sets a value indicating whether this field is used for identification.
name | Gets or sets the name.
power | Gets or sets the power.
template | Gets or sets a value indicating whether this field is used for template identification.
unitName | Gets or sets the name of the unit.
visible | Gets or sets a value indicating whether this FieldParams is visible.
Links
REX.ContentGenerator.Converters Namespace, Legend, Members, Public Methods, FieldParams Methods, FieldParams Properties


FieldParams.FieldParams Constructor

FieldParams.FieldParams Constructor
FieldParams Class REX.ContentGenerator.Converters Namespace FieldParams Class

Initializes a new instance of the FieldParams class.

C#
public FieldParams(string name, string unit_name, int pow, bool vis, string dis, string def);
Parameters
Parameters | Description
name | The name.
unit_name | The unit name.
pow | The power.
vis | If visible.
dis | The display name.
def | The default.
Description
Class

FieldParams Class

Links
FieldParams Class, REX.ContentGenerator.Converters Namespace, FieldParams Class


FieldParams.GetDefaultValue Method ()

FieldParams.GetDefaultValue Method ()
FieldParams Class REX.ContentGenerator.Converters Namespace FieldParams Class

Gets the default value.

C#
public object GetDefaultValue();
Returns

The default value.

Description
Class

FieldParams Class

Links
FieldParams Class, REX.ContentGenerator.Converters Namespace, FieldParams Class


FieldParams.GetDefaultValue Method (string)

FieldParams.GetDefaultValue Method (string)
FieldParams Class REX.ContentGenerator.Converters Namespace FieldParams Class

Gets the default value.

C#
public object GetDefaultValue(string key);
Parameters
Parameters | Description
key | The key.
Returns

The default value.

Description
Class

FieldParams Class

Links
FieldParams Class, REX.ContentGenerator.Converters Namespace, FieldParams Class


FieldParams.database Property

FieldParams.database Property
FieldParams Class REX.ContentGenerator.Converters Namespace FieldParams Class

Gets or sets the name in database.

C#
public string database;
Description

The name in the database.

Class

FieldParams Class

Links
FieldParams Class, REX.ContentGenerator.Converters Namespace, FieldParams Class


FieldParams.display Property

FieldParams.display Property
FieldParams Class REX.ContentGenerator.Converters Namespace FieldParams Class

Gets or sets the display name.

C#
public string display;
Description

The display name.

Class

FieldParams Class

Links
FieldParams Class, REX.ContentGenerator.Converters Namespace, FieldParams Class


FieldParams.identity Property

FieldParams.identity Property
FieldParams Class REX.ContentGenerator.Converters Namespace FieldParams Class

Gets or sets a value indicating whether this field is used for identification.

C#
public bool identity;
Description
Class

FieldParams Class

Links
FieldParams Class, REX.ContentGenerator.Converters Namespace, FieldParams Class


FieldParams.name Property

FieldParams.name Property
FieldParams Class REX.ContentGenerator.Converters Namespace FieldParams Class

Gets or sets the name.

C#
public string name;
Description

The name.

Class

FieldParams Class

Links
FieldParams Class, REX.ContentGenerator.Converters Namespace, FieldParams Class


FieldParams.power Property

FieldParams.power Property
FieldParams Class REX.ContentGenerator.Converters Namespace FieldParams Class

Gets or sets the power.

C#
public int power;
Description

The power.

Class

FieldParams Class

Links
FieldParams Class, REX.ContentGenerator.Converters Namespace, FieldParams Class


FieldParams.template Property

FieldParams.template Property
FieldParams Class REX.ContentGenerator.Converters Namespace FieldParams Class

Gets or sets a value indicating whether this field is used for template identification.

C#
public bool template;
Description
Class

FieldParams Class

Links
FieldParams Class, REX.ContentGenerator.Converters Namespace, FieldParams Class


FieldParams.unitName Property

FieldParams.unitName Property
FieldParams Class REX.ContentGenerator.Converters Namespace FieldParams Class

Gets or sets the name of the unit.

C#
public string unitName;
Description

The name of the unit.

Class

FieldParams Class

Links
FieldParams Class, REX.ContentGenerator.Converters Namespace, FieldParams Class


FieldParams.visible Property

FieldParams.visible Property
FieldParams Class REX.ContentGenerator.Converters Namespace FieldParams Class

Gets or sets a value indicating whether this FieldParams is visible.

C#
public bool visible;
Description

If visible.

Class

FieldParams Class

Links
FieldParams Class, REX.ContentGenerator.Converters Namespace, FieldParams Class


REXContentFilter Class

REXContentFilter Class
REX.ContentGenerator.Converters Namespace

Base class for all filters.

Class Hierarchy
C#
public abstract class REXContentFilter;
Description
Namespace

REX.ContentGenerator.Converters Namespace

Links
REX.ContentGenerator.Converters Namespace


REXContentLogicFilter Class

REXContentLogicFilter Class
REX.ContentGenerator.Converters Namespace Legend Members Public Methods REXContentLogicFilter Enumerations REXContentLogicFilter Properties

Describes a logic filter.

Class Hierarchy
C#
public class REXContentLogicFilter : REXContentFilter;
Description
Namespace

REX.ContentGenerator.Converters Namespace

Public Methods
Public Method | Description
REXContentLogicFilter | Initializes a new instance of the REXContentLogicFilter class.
REXContentLogicFilter | Initializes a new instance of the REXContentLogicFilter class.
REXContentLogicFilter Enumerations
REXContentLogicFilter Enumerations | Description
ELogicOperator | Describes operators.
REXContentLogicFilter Properties
REXContentLogicFilter Properties | Description
Filters | Gets or sets the filters.
LogicOperator | Gets or sets the logic operator.
Links
REX.ContentGenerator.Converters Namespace, Legend, Members, Public Methods, REXContentLogicFilter Enumerations, REXContentLogicFilter Properties


REXContentLogicFilter.REXContentLogicFilter Constructor (ELogicOperator)

REXContentLogicFilter.REXContentLogicFilter Constructor (ELogicOperator)
REXContentLogicFilter Class REX.ContentGenerator.Converters Namespace REXContentLogicFilter Class

Initializes a new instance of the REXContentLogicFilter class.

C#
public REXContentLogicFilter(ELogicOperator logicOperator);
Parameters
Parameters | Description
logicOperator | The logic operator.
Description
Class

REXContentLogicFilter Class

Links
REXContentLogicFilter Class, REX.ContentGenerator.Converters Namespace, REXContentLogicFilter Class


REXContentLogicFilter.REXContentLogicFilter Constructor (ELogicOperator, params REXContentFilter[])

REXContentLogicFilter.REXContentLogicFilter Constructor (ELogicOperator, params REXContentFilter[])
REXContentLogicFilter Class REX.ContentGenerator.Converters Namespace REXContentLogicFilter Class

Initializes a new instance of the REXContentLogicFilter class.

C#
public REXContentLogicFilter(ELogicOperator logicOperator, params REXContentFilter[] filters);
Parameters
Parameters | Description
logicOperator | The logic operator.
filters | The filters.
Description
Class

REXContentLogicFilter Class

Links
REXContentLogicFilter Class, REX.ContentGenerator.Converters Namespace, REXContentLogicFilter Class


REX.ContentGenerator.Converters.REXContentLogicFilter.ELogicOperator Enumeration

REX.ContentGenerator.Converters.REXContentLogicFilter.ELogicOperator Enumeration
REXContentLogicFilter Class

Describes operators.

C#
public enum ELogicOperator {
  Or,
  And
}
Members
Members | Description
Or | Agregation.
And | Conjunction.
Description
Class

REXContentLogicFilter Class

Links
REXContentLogicFilter Class
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXContentLogicFilter.Filters Property

REXContentLogicFilter.Filters Property
REXContentLogicFilter Class REX.ContentGenerator.Converters Namespace REXContentLogicFilter Class

Gets or sets the filters.

C#
public List<REXContentFilter> Filters;
Description

The filters.

Class

REXContentLogicFilter Class

Links
REXContentLogicFilter Class, REX.ContentGenerator.Converters Namespace, REXContentLogicFilter Class


REXContentLogicFilter.LogicOperator Property

REXContentLogicFilter.LogicOperator Property
REXContentLogicFilter Class REX.ContentGenerator.Converters Namespace REXContentLogicFilter Class

Gets or sets the logic operator.

C#
public ELogicOperator LogicOperator;
Description

The logic operator.

Class

REXContentLogicFilter Class

Links
REXContentLogicFilter Class, REX.ContentGenerator.Converters Namespace, REXContentLogicFilter Class


REXContentParamFilter Class

REXContentParamFilter Class
REX.ContentGenerator.Converters Namespace Legend Members Public Methods REXContentParamFilter Methods REXContentParamFilter Properties

Describes the filter for the specified parameter.

Class Hierarchy
C#
public class REXContentParamFilter : REXContentFilter;
Description
Namespace

REX.ContentGenerator.Converters Namespace

Public Methods
Public Method | Description
REXContentParamFilter | Initializes a new instance of the REXContentParamFilter class.
REXContentParamFilter | Initializes a new instance of the REXContentParamFilter class.
REXContentParamFilter | Initializes a new instance of the REXContentParamFilter class.
REXContentParamFilter Methods
REXContentParamFilter Methods | Description
Validate | Validates the specified value due to the current filter's parameters.
REXContentParamFilter Properties
REXContentParamFilter Properties | Description
ConstraintValue | Gets or sets the constraint value.
Equal | Gets or sets a value indicating whether a parameter is to be equal to the constraint value.
Less | Gets or sets a value indicating whether a parameter is to be smaller then the constraint value.
More | Gets or sets a value indicating whether a parameter is to be larger then the constraint value.
ParamName | Gets or sets the name of the parameter which is constrained.
Links
REX.ContentGenerator.Converters Namespace, Legend, Members, Public Methods, REXContentParamFilter Methods, REXContentParamFilter Properties


REXContentParamFilter.REXContentParamFilter Constructor ()

REXContentParamFilter.REXContentParamFilter Constructor ()
REXContentParamFilter Class REX.ContentGenerator.Converters Namespace REXContentParamFilter Class

Initializes a new instance of the REXContentParamFilter class.

C#
public REXContentParamFilter();
Description
Class

REXContentParamFilter Class

Links
REXContentParamFilter Class, REX.ContentGenerator.Converters Namespace, REXContentParamFilter Class


REXContentParamFilter.REXContentParamFilter Constructor (string, object)

REXContentParamFilter.REXContentParamFilter Constructor (string, object)
REXContentParamFilter Class REX.ContentGenerator.Converters Namespace REXContentParamFilter Class

Initializes a new instance of the REXContentParamFilter class.

C#
public REXContentParamFilter(string paramName, object constraintValue);
Parameters
Parameters | Description
paramName | The name of the parameter.
constraintValue | The constraint value.
Description
Class

REXContentParamFilter Class

Links
REXContentParamFilter Class, REX.ContentGenerator.Converters Namespace, REXContentParamFilter Class


REXContentParamFilter.REXContentParamFilter Constructor (string, object, bool, bool, bool)

REXContentParamFilter.REXContentParamFilter Constructor (string, object, bool, bool, bool)
REXContentParamFilter Class REX.ContentGenerator.Converters Namespace REXContentParamFilter Class

Initializes a new instance of the REXContentParamFilter class.

C#
public REXContentParamFilter(string paramName, object constraintValue, bool more, bool less, bool equal);
Parameters
Parameters | Description
paramName | The name of the parameter.
constraintValue | The constraint value.
more | Indicates whether the parameter is to be larger then the constraint value.
less | Indicates whether the parameter is to be smaller then the constraint value.
equal | Indicates whether the parameter is to be equal to the constraint value.
Description
Class

REXContentParamFilter Class

Links
REXContentParamFilter Class, REX.ContentGenerator.Converters Namespace, REXContentParamFilter Class


REXContentParamFilter.Validate Method

REXContentParamFilter.Validate Method
REXContentParamFilter Class REX.ContentGenerator.Converters Namespace REXContentParamFilter Class

Validates the specified value due to the current filter's parameters.

C#
public bool Validate(IComparable val);
Parameters
Parameters | Description
val | The value.
Returns

True if the value respects all constraints; otherwise false.

Description
Class

REXContentParamFilter Class

Links
REXContentParamFilter Class, REX.ContentGenerator.Converters Namespace, REXContentParamFilter Class


REXContentParamFilter.ConstraintValue Property

REXContentParamFilter.ConstraintValue Property
REXContentParamFilter Class REX.ContentGenerator.Converters Namespace REXContentParamFilter Class

Gets or sets the constraint value.

C#
public object ConstraintValue;
Description

The constraint value.

Class

REXContentParamFilter Class

Links
REXContentParamFilter Class, REX.ContentGenerator.Converters Namespace, REXContentParamFilter Class


REXContentParamFilter.Equal Property

REXContentParamFilter.Equal Property
REXContentParamFilter Class REX.ContentGenerator.Converters Namespace REXContentParamFilter Class

Gets or sets a value indicating whether a parameter is to be equal to the constraint value.

C#
public bool Equal;
Description
Class

REXContentParamFilter Class

Links
REXContentParamFilter Class, REX.ContentGenerator.Converters Namespace, REXContentParamFilter Class


REXContentParamFilter.Less Property

REXContentParamFilter.Less Property
REXContentParamFilter Class REX.ContentGenerator.Converters Namespace REXContentParamFilter Class

Gets or sets a value indicating whether a parameter is to be smaller then the constraint value.

C#
public bool Less;
Description
Class

REXContentParamFilter Class

Links
REXContentParamFilter Class, REX.ContentGenerator.Converters Namespace, REXContentParamFilter Class


REXContentParamFilter.More Property

REXContentParamFilter.More Property
REXContentParamFilter Class REX.ContentGenerator.Converters Namespace REXContentParamFilter Class

Gets or sets a value indicating whether a parameter is to be larger then the constraint value.

C#
public bool More;
Description
Class

REXContentParamFilter Class

Links
REXContentParamFilter Class, REX.ContentGenerator.Converters Namespace, REXContentParamFilter Class


REXContentParamFilter.ParamName Property

REXContentParamFilter.ParamName Property
REXContentParamFilter Class REX.ContentGenerator.Converters Namespace REXContentParamFilter Class

Gets or sets the name of the parameter which is constrained.

C#
public string ParamName;
Description

The name of the parameter.

Class

REXContentParamFilter Class

Links
REXContentParamFilter Class, REX.ContentGenerator.Converters Namespace, REXContentParamFilter Class


REXCustomFactory Class

REXCustomFactory Class
REX.ContentGenerator.Converters Namespace Legend Members Public Methods REXCustomFactory Methods

This is class REX.ContentGenerator.Converters.REXCustomFactory.

Class Hierarchy
C#
public class REXCustomFactory<T_REXFamilyType, T_REXDescription> : REXFamilyFactory where T_REXFamilyType : new() where T_REXDescription : new();
Namespace

REX.ContentGenerator.Converters Namespace

Public Methods
Public Method | Description
REXCustomFactory | This is REXCustomFactory, a member of class REXCustomFactory.
REXCustomFactory Methods
REXCustomFactory Methods | Description
Close | This is Close, a member of class REXCustomFactory.
GetAliasName | This is GetAliasName, a member of class REXCustomFactory.
GetAllFamilies | This is GetAllFamilies, a member of class REXCustomFactory.
GetDBList | This is GetDBList, a member of class REXCustomFactory.
GetDBList | This is GetDBList, a member of class REXCustomFactory.
GetFamiliesOfAlias | This is GetFamiliesOfAlias, a member of class REXCustomFactory.
GetFamily | This is GetFamily, a member of class REXCustomFactory.
GetFamilyDefault | This is GetFamilyDefault, a member of class REXCustomFactory.
GetFamilyOfAlias | This is GetFamilyOfAlias, a member of class REXCustomFactory.
GetFamilyTemplate | This is GetFamilyTemplate, a member of class REXCustomFactory.
Links
REX.ContentGenerator.Converters Namespace, Legend, Members, Public Methods, REXCustomFactory Methods


REXCustomFactory.REXCustomFactory Constructor

REXCustomFactory.REXCustomFactory Constructor
REXCustomFactory Class REX.ContentGenerator.Converters Namespace REXCustomFactory Class

This is REXCustomFactory, a member of class REXCustomFactory.

C#
public REXCustomFactory(string categoryName, RexConversionSettings settings);
Class

REXCustomFactory Class

Links
REXCustomFactory Class, REX.ContentGenerator.Converters Namespace, REXCustomFactory Class


REXCustomFactory.Close Method

REXCustomFactory.Close Method
REXCustomFactory Class REX.ContentGenerator.Converters Namespace REXCustomFactory Class

This is Close, a member of class REXCustomFactory.

C#
public override void Close();
Class

REXCustomFactory Class

Links
REXCustomFactory Class, REX.ContentGenerator.Converters Namespace, REXCustomFactory Class


REXCustomFactory.GetAliasName Method

REXCustomFactory.GetAliasName Method
REXCustomFactory Class REX.ContentGenerator.Converters Namespace REXCustomFactory Class

This is GetAliasName, a member of class REXCustomFactory.

C#
public override bool GetAliasName(REXDBDescription DBdesc, out string type, out System.Collections.Generic.List<string> alias);
Class

REXCustomFactory Class

Links
REXCustomFactory Class, REX.ContentGenerator.Converters Namespace, REXCustomFactory Class


REXCustomFactory.GetAllFamilies Method

REXCustomFactory.GetAllFamilies Method
REXCustomFactory Class REX.ContentGenerator.Converters Namespace REXCustomFactory Class

This is GetAllFamilies, a member of class REXCustomFactory.

C#
public override System.Collections.Generic.List<REXFamilyType> GetAllFamilies(string dir, string dbname, REXContentFilter filter, bool forMapping);
Class

REXCustomFactory Class

Links
REXCustomFactory Class, REX.ContentGenerator.Converters Namespace, REXCustomFactory Class


REXCustomFactory.GetDBList Method (REXFamilyType, string, string)

REXCustomFactory.GetDBList Method (REXFamilyType, string, string)
REXCustomFactory Class REX.ContentGenerator.Converters Namespace REXCustomFactory Class

This is GetDBList, a member of class REXCustomFactory.

C#
public override System.Collections.Generic.List<REXDBDescription> GetDBList(REXFamilyType obj, string dbname, string dir);
Class

REXCustomFactory Class

Links
REXCustomFactory Class, REX.ContentGenerator.Converters Namespace, REXCustomFactory Class


REXCustomFactory.GetDBList Method (System.Collections.Generic.List<REXFamilyType>, string, string)

REXCustomFactory.GetDBList Method (System.Collections.Generic.List<REXFamilyType>, string, string)
REXCustomFactory Class REX.ContentGenerator.Converters Namespace REXCustomFactory Class

This is GetDBList, a member of class REXCustomFactory.

C#
public override System.Collections.Generic.List<REXDBDescription> GetDBList(System.Collections.Generic.List<REXFamilyType> obj, string dbname, string dir);
Class

REXCustomFactory Class

Links
REXCustomFactory Class, REX.ContentGenerator.Converters Namespace, REXCustomFactory Class


REXCustomFactory.GetFamiliesOfAlias Method

REXCustomFactory.GetFamiliesOfAlias Method
REXCustomFactory Class REX.ContentGenerator.Converters Namespace REXCustomFactory Class

This is GetFamiliesOfAlias, a member of class REXCustomFactory.

C#
public override List<REXFamilyType> GetFamiliesOfAlias(REX.ContentGenerator.Families.EElementType el, string alias, out bool found);
Class

REXCustomFactory Class

Links
REXCustomFactory Class, REX.ContentGenerator.Converters Namespace, REXCustomFactory Class


REXCustomFactory.GetFamily Method

REXCustomFactory.GetFamily Method
REXCustomFactory Class REX.ContentGenerator.Converters Namespace REXCustomFactory Class

This is GetFamily, a member of class REXCustomFactory.

C#
public override REXFamilyType GetFamily(REXDBDescription DBdesc, REX.ContentGenerator.Families.EElementType el, EMaterial mat);
Class

REXCustomFactory Class

Links
REXCustomFactory Class, REX.ContentGenerator.Converters Namespace, REXCustomFactory Class


REXCustomFactory.GetFamilyDefault Method

REXCustomFactory.GetFamilyDefault Method
REXCustomFactory Class REX.ContentGenerator.Converters Namespace REXCustomFactory Class

This is GetFamilyDefault, a member of class REXCustomFactory.

C#
public override REXFamilyType GetFamilyDefault(REX.ContentGenerator.Families.EElementType el, EMaterial mat, string type);
Class

REXCustomFactory Class

Links
REXCustomFactory Class, REX.ContentGenerator.Converters Namespace, REXCustomFactory Class


REXCustomFactory.GetFamilyOfAlias Method

REXCustomFactory.GetFamilyOfAlias Method
REXCustomFactory Class REX.ContentGenerator.Converters Namespace REXCustomFactory Class

This is GetFamilyOfAlias, a member of class REXCustomFactory.

C#
public override REXFamilyType GetFamilyOfAlias(REX.ContentGenerator.Families.EElementType el, string alias, out bool found);
Class

REXCustomFactory Class

Links
REXCustomFactory Class, REX.ContentGenerator.Converters Namespace, REXCustomFactory Class


REXCustomFactory.GetFamilyTemplate Method

REXCustomFactory.GetFamilyTemplate Method
REXCustomFactory Class REX.ContentGenerator.Converters Namespace REXCustomFactory Class

This is GetFamilyTemplate, a member of class REXCustomFactory.

C#
public override REXFamilyType GetFamilyTemplate(REX.ContentGenerator.Families.EElementType el, EMaterial mat);
Class

REXCustomFactory Class

Links
REXCustomFactory Class, REX.ContentGenerator.Converters Namespace, REXCustomFactory Class


REXDBSectionFactory Class

REXDBSectionFactory Class
REX.ContentGenerator.Converters Namespace Legend Members Public Methods REXDBSectionFactory Methods

This is class REX.ContentGenerator.Converters.REXDBSectionFactory.

Class Hierarchy
C#
public class REXDBSectionFactory : REXFamilyFactoryDbRootAdo;
Namespace

REX.ContentGenerator.Converters Namespace

Public Methods
Public Method | Description
REXDBSectionFactory | This is REXDBSectionFactory, a member of class REXDBSectionFactory.
REXDBSectionFactory Methods
REXDBSectionFactory Methods | Description
CompareRows | This is CompareRows, a member of class REXDBSectionFactory.
FillDBDescription | This is FillDBDescription, a member of class REXDBSectionFactory.
FillDBObjectCollection | This is FillDBObjectCollection, a member of class REXDBSectionFactory.
FillFamilyTypeProperties | This is FillFamilyTypeProperties, a member of class REXDBSectionFactory.
FillFamilyTypeProperties | This is FillFamilyTypeProperties, a member of class REXDBSectionFactory.
GetAliasName | This is GetAliasName, a member of class REXDBSectionFactory.
GetAliasName | This is GetAliasName, a member of class REXDBSectionFactory.
GetFamiliesOfAlias | This is GetFamiliesOfAlias, a member of class REXDBSectionFactory.
GetFamilyDefault | This is GetFamilyDefault, a member of class REXDBSectionFactory.
GetFamilyOfAlias | This is GetFamilyOfAlias, a member of class REXDBSectionFactory.
GetFamilyTemplate | This is GetFamilyTemplate, a member of class REXDBSectionFactory.
GetNewDescription | This is GetNewDescription, a member of class REXDBSectionFactory.
GetNewDescription | This is GetNewDescription, a member of class REXDBSectionFactory.
GetNewFamily | This is GetNewFamily, a member of class REXDBSectionFactory.
RecalculatDBDesc | This is RecalculatDBDesc, a member of class REXDBSectionFactory.
ValidateDB | This is ValidateDB, a member of class REXDBSectionFactory.
ValidateDB | This is ValidateDB, a member of class REXDBSectionFactory.
ValidateDBADO | This is ValidateDBADO, a member of class REXDBSectionFactory.
Links
REX.ContentGenerator.Converters Namespace, Legend, Members, Public Methods, REXDBSectionFactory Methods


REXDBSectionFactory.REXDBSectionFactory Constructor

REXDBSectionFactory.REXDBSectionFactory Constructor
REXDBSectionFactory Class REX.ContentGenerator.Converters Namespace REXDBSectionFactory Class

This is REXDBSectionFactory, a member of class REXDBSectionFactory.

C#
public REXDBSectionFactory(RexConversionSettings Settings);
Class

REXDBSectionFactory Class

Links
REXDBSectionFactory Class, REX.ContentGenerator.Converters Namespace, REXDBSectionFactory Class


REXDBSectionFactory.CompareRows Method

REXDBSectionFactory.CompareRows Method
REXDBSectionFactory Class REX.ContentGenerator.Converters Namespace REXDBSectionFactory Class

This is CompareRows, a member of class REXDBSectionFactory.

C#
public override bool CompareRows(bool certified, REXDescription ft, IDbRootLib.IDbTableRow row, IDbRootLib.DbDatabase db, Dictionary<string, int> ColumnDict);
Class

REXDBSectionFactory Class

Links
REXDBSectionFactory Class, REX.ContentGenerator.Converters Namespace, REXDBSectionFactory Class


REXDBSectionFactory.FillDBDescription Method

REXDBSectionFactory.FillDBDescription Method
REXDBSectionFactory Class REX.ContentGenerator.Converters Namespace REXDBSectionFactory Class

This is FillDBDescription, a member of class REXDBSectionFactory.

C#
public override void FillDBDescription(IDbRootLib.IDbDatabase db, IDbRootLib.IDbTableRow row, REXDBDescription desc, string dir, string dbname, bool recalc, int tableIndex, Dictionary<string, int> ColumnDict, bool forMapping);
Class

REXDBSectionFactory Class

Links
REXDBSectionFactory Class, REX.ContentGenerator.Converters Namespace, REXDBSectionFactory Class


REXDBSectionFactory.FillDBObjectCollection Method

REXDBSectionFactory.FillDBObjectCollection Method
REXDBSectionFactory Class REX.ContentGenerator.Converters Namespace REXDBSectionFactory Class

This is FillDBObjectCollection, a member of class REXDBSectionFactory.

C#
public override void FillDBObjectCollection(bool certified, REXDescription db, DTableDataObjectCollection dtdoc, out bool ok);
Class

REXDBSectionFactory Class

Links
REXDBSectionFactory Class, REX.ContentGenerator.Converters Namespace, REXDBSectionFactory Class


REXDBSectionFactory.FillFamilyTypeProperties Method (REXFamilyType, DTableDataObjectCollection, string, string)

REXDBSectionFactory.FillFamilyTypeProperties Method (REXFamilyType, DTableDataObjectCollection, string, string)
REXDBSectionFactory Class REX.ContentGenerator.Converters Namespace REXDBSectionFactory Class

This is FillFamilyTypeProperties, a member of class REXDBSectionFactory.

C#
public override void FillFamilyTypeProperties(REXFamilyType fam, DTableDataObjectCollection col, string path, string dbName);
Class

REXDBSectionFactory Class

Links
REXDBSectionFactory Class, REX.ContentGenerator.Converters Namespace, REXDBSectionFactory Class


REXDBSectionFactory.FillFamilyTypeProperties Method (REXFamilyType, IDbRootLib.IDbTableRow, string, string)

REXDBSectionFactory.FillFamilyTypeProperties Method (REXFamilyType, IDbRootLib.IDbTableRow, string, string)
REXDBSectionFactory Class REX.ContentGenerator.Converters Namespace REXDBSectionFactory Class

This is FillFamilyTypeProperties, a member of class REXDBSectionFactory.

C#
public override void FillFamilyTypeProperties(REXFamilyType fam, IDbRootLib.IDbTableRow row, string path, string dbName);
Class

REXDBSectionFactory Class

Links
REXDBSectionFactory Class, REX.ContentGenerator.Converters Namespace, REXDBSectionFactory Class


REXDBSectionFactory.GetAliasName Method (REXDBDescription, out string, out List<string>)

REXDBSectionFactory.GetAliasName Method (REXDBDescription, out string, out List<string>)
REXDBSectionFactory Class REX.ContentGenerator.Converters Namespace REXDBSectionFactory Class

This is GetAliasName, a member of class REXDBSectionFactory.

C#
public override bool GetAliasName(REXDBDescription DBdesc, out string type, out List<string> alias);
Class

REXDBSectionFactory Class

Links
REXDBSectionFactory Class, REX.ContentGenerator.Converters Namespace, REXDBSectionFactory Class


REXDBSectionFactory.GetAliasName Method (REXDBDescription, out string, out List<string>, out string)

REXDBSectionFactory.GetAliasName Method (REXDBDescription, out string, out List<string>, out string)
REXDBSectionFactory Class REX.ContentGenerator.Converters Namespace REXDBSectionFactory Class

This is GetAliasName, a member of class REXDBSectionFactory.

C#
public override bool GetAliasName(REXDBDescription DBdesc, out string type, out List<string> alias, out string pattern);
Class

REXDBSectionFactory Class

Links
REXDBSectionFactory Class, REX.ContentGenerator.Converters Namespace, REXDBSectionFactory Class


REXDBSectionFactory.GetFamiliesOfAlias Method

REXDBSectionFactory.GetFamiliesOfAlias Method
REXDBSectionFactory Class REX.ContentGenerator.Converters Namespace REXDBSectionFactory Class

This is GetFamiliesOfAlias, a member of class REXDBSectionFactory.

C#
public override List<REXFamilyType> GetFamiliesOfAlias(REX.ContentGenerator.Families.EElementType el, string alias, out bool found);
Class

REXDBSectionFactory Class

Links
REXDBSectionFactory Class, REX.ContentGenerator.Converters Namespace, REXDBSectionFactory Class


REXDBSectionFactory.GetFamilyDefault Method

REXDBSectionFactory.GetFamilyDefault Method
REXDBSectionFactory Class REX.ContentGenerator.Converters Namespace REXDBSectionFactory Class

This is GetFamilyDefault, a member of class REXDBSectionFactory.

C#
public override REXFamilyType GetFamilyDefault(REX.ContentGenerator.Families.EElementType el, EMaterial mat, string type);
Class

REXDBSectionFactory Class

Links
REXDBSectionFactory Class, REX.ContentGenerator.Converters Namespace, REXDBSectionFactory Class


REXDBSectionFactory.GetFamilyOfAlias Method

REXDBSectionFactory.GetFamilyOfAlias Method
REXDBSectionFactory Class REX.ContentGenerator.Converters Namespace REXDBSectionFactory Class

This is GetFamilyOfAlias, a member of class REXDBSectionFactory.

C#
public override REXFamilyType GetFamilyOfAlias(REX.ContentGenerator.Families.EElementType el, string alias, out bool found);
Class

REXDBSectionFactory Class

Links
REXDBSectionFactory Class, REX.ContentGenerator.Converters Namespace, REXDBSectionFactory Class


REXDBSectionFactory.GetFamilyTemplate Method

REXDBSectionFactory.GetFamilyTemplate Method
REXDBSectionFactory Class REX.ContentGenerator.Converters Namespace REXDBSectionFactory Class

This is GetFamilyTemplate, a member of class REXDBSectionFactory.

C#
public override REXFamilyType GetFamilyTemplate(REX.ContentGenerator.Families.EElementType el, EMaterial mat);
Class

REXDBSectionFactory Class

Links
REXDBSectionFactory Class, REX.ContentGenerator.Converters Namespace, REXDBSectionFactory Class


REXDBSectionFactory.GetNewDescription Method ()

REXDBSectionFactory.GetNewDescription Method ()
REXDBSectionFactory Class REX.ContentGenerator.Converters Namespace REXDBSectionFactory Class

This is GetNewDescription, a member of class REXDBSectionFactory.

C#
public override REXDBDescription GetNewDescription();
Class

REXDBSectionFactory Class

Links
REXDBSectionFactory Class, REX.ContentGenerator.Converters Namespace, REXDBSectionFactory Class


REXDBSectionFactory.GetNewDescription Method (string, string, DTableDataObjectCollection)

REXDBSectionFactory.GetNewDescription Method (string, string, DTableDataObjectCollection)
REXDBSectionFactory Class REX.ContentGenerator.Converters Namespace REXDBSectionFactory Class

This is GetNewDescription, a member of class REXDBSectionFactory.

C#
public override REXDBDescription GetNewDescription(string dir, string dbName, DTableDataObjectCollection dtdoc);
Class

REXDBSectionFactory Class

Links
REXDBSectionFactory Class, REX.ContentGenerator.Converters Namespace, REXDBSectionFactory Class


REXDBSectionFactory.GetNewFamily Method

REXDBSectionFactory.GetNewFamily Method
REXDBSectionFactory Class REX.ContentGenerator.Converters Namespace REXDBSectionFactory Class

This is GetNewFamily, a member of class REXDBSectionFactory.

C#
public override REXFamilyType GetNewFamily();
Class

REXDBSectionFactory Class

Links
REXDBSectionFactory Class, REX.ContentGenerator.Converters Namespace, REXDBSectionFactory Class


REXDBSectionFactory.RecalculatDBDesc Method

REXDBSectionFactory.RecalculatDBDesc Method
REXDBSectionFactory Class REX.ContentGenerator.Converters Namespace REXDBSectionFactory Class

This is RecalculatDBDesc, a member of class REXDBSectionFactory.

C#
public override void RecalculatDBDesc(REXDBDescription sec, string DBPath, string DBName, bool fromInterface);
Class

REXDBSectionFactory Class

Links
REXDBSectionFactory Class, REX.ContentGenerator.Converters Namespace, REXDBSectionFactory Class


REXDBSectionFactory.ValidateDB Method (IDbRootLib.IDbDatabase)

REXDBSectionFactory.ValidateDB Method (IDbRootLib.IDbDatabase)
REXDBSectionFactory Class REX.ContentGenerator.Converters Namespace REXDBSectionFactory Class

This is ValidateDB, a member of class REXDBSectionFactory.

C#
public override bool ValidateDB(IDbRootLib.IDbDatabase db);
Class

REXDBSectionFactory Class

Links
REXDBSectionFactory Class, REX.ContentGenerator.Converters Namespace, REXDBSectionFactory Class


REXDBSectionFactory.ValidateDB Method (string)

REXDBSectionFactory.ValidateDB Method (string)
REXDBSectionFactory Class REX.ContentGenerator.Converters Namespace REXDBSectionFactory Class

This is ValidateDB, a member of class REXDBSectionFactory.

C#
public override bool ValidateDB(string dbName);
Class

REXDBSectionFactory Class

Links
REXDBSectionFactory Class, REX.ContentGenerator.Converters Namespace, REXDBSectionFactory Class


REXDBSectionFactory.ValidateDBADO Method

REXDBSectionFactory.ValidateDBADO Method
REXDBSectionFactory Class REX.ContentGenerator.Converters Namespace REXDBSectionFactory Class

This is ValidateDBADO, a member of class REXDBSectionFactory.

C#
public override bool ValidateDBADO(string dbName);
Class

REXDBSectionFactory Class

Links
REXDBSectionFactory Class, REX.ContentGenerator.Converters Namespace, REXDBSectionFactory Class


REXFamilyConverter Class

REXFamilyConverter Class
REX.ContentGenerator.Converters Namespace Legend Members Public Methods REXFamilyConverter Methods REXFamilyConverter Properties

This class represents a converter which provides access to common databases.

Class Hierarchy
C#
public class REXFamilyConverter : REX.ContentGenerator.Map.IMapConverter;
Description

It allows user to get the REXFamilyType object from the specific record in the database as well as get the record based on the specified REXFamilyType object.

Namespace

REX.ContentGenerator.Converters Namespace

Public Methods
Public Method | Description
REXFamilyConverter | Initializes a new instance of the REXFamilyConverter class.
REXFamilyConverter Methods
REXFamilyConverter Methods | Description
Close | Clears collections, releases COM objects.
FindFamily | Finds the REXFamilyType in the specific list.
GenerateMaps | Generates a file used in the mapping aliases system.
GetDatabaseDirectory | Returns directory for databases of the specific category.
GetDatabasePath | Return a path for particular database of the specified category.
GetDBList | Gets the list of database's records adequate for the list of input objects.
GetDBList | Gets the list of database's records adequate for the list of input objects.
GetDBList | Gets the list of database's records adequate for the input object.
GetDBList | Gets the list of database's records adequate for the input object.
GetDBList | Gets the list of database's records adequate for the input object.
GetDBList | Gets the list of database's records adequate for the input object.
GetDBList | Gets the list of database's records adequate for the input object.
GetDBList | Gets the list of database's records adequate for the input object.
GetDBList | Gets the list of database's records adequate for the input object.
GetDBList | Gets the list of database's records adequate for the input object.
GetDBList | Gets the list of database's records adequate for the input object.
GetDbProperty | Gets the property of specific name for the database.
GetEmptyFamilyOfAlias | Gets the empty family of alias name.
GetFamilies | Gets the list of all elements in the selected database.
GetFamilies | Gets the list of all elements in the selected database.
GetFamilies | Gets the list of all elements in selected database.
GetFamilies | Gets the list of all elements in selected database.
GetFamily | Gets the REXFamilyType object based on specific database's record.
GetFamily | Gets the REXFamilyType object based on specific database's record.
GetFamily | Gets the REXFamilyType object based on specific database's record.
GetFamily | Gets the REXFamilyType object based on the specified database's record.
GetFamilyDBSection | Gets the section of the specified name (based on data from databases).
GetFamilyDBSection | Gets the section of the specified key (based on data from the database).
GetFamilyDBSection | Gets the section of the specified name (based on data from databases).
GetFamilyDBSection | Gets the section of the specified name (based on data from the database).
GetFamilyDefault | Gets the default REXFamilyType of the specified type.
GetFamilyMaterial | Gets the material of the specific name (based on data from the database).
GetFamilyMaterial | Gets the material of the specified name (based on data from the database).
GetFamilyMaterial | Gets the material of the specific name (based on data from the database).
GetFamilyRebarHook | Gets the family rebar hook.
GetFamilyRebarShape | Gets the rebar shape of specified code and database.
GetFamilyRebarType | Gets the rebar's type of the specified steel and the bar's size (based on data from the database).
GetFamilyTemplate | Gets the dedicated template of the REXFamilyType (with initial data).
GetFilteredFamilies | Gets the list of filtered elements in the selected database.
GetFilteredFamilies | Gets the list of filtered elements in the selected database.
GetFilteredFamilies | Gets the list of filtered elements in selected database.
GetFilteredFamilies | Gets the list of filtered elements in the selected database.
GetNameForAlias | Gets the certified name for the alias.
GetRebar | Gets the rebar object due to the defined contour, the bar's type and the shape's database.
GetRebar | Gets the rebar object due to the defined contour, the bar's type and the shape's database.
GetRebar | Gets the rebar object due to the defined contour, the bar's type and the shape's database.
GetRebar | Gets the rebar object due to the defined contour, the bar's type and the shape's database.
GetRebar | Gets the rebar object due to the defined contour, the bar's type and the shape's database.
GetRebar | Gets the rebar object due to the defined contour, the bar's type and the shape's database.
GetRebar | Gets the rebar object due to the defined contour, the bar's type and the shape's database.
GetRebar | Gets the rebar object due to the defined contour, the bar's type and the shape's database.
GetRebar | Gets the rebar object due to the defined contour, the bar's type and the shape's database.
GetRebar | Gets the rebar object due to the defined contour, the bar's type and the shape's database.
GetRebar | Gets the rebar object due to the defined contour, the bar's type and the shape's database.
GetRebar | Gets the rebar object due to the defined contour, the bar's type and the shape's database.
GetRebar | Gets the rebar object due to the defined contour, the bar's type and the shape's database.
GetRebar | Gets the rebar object due to the defined contour, the bar's type and the shape's database.
GetRebar | Gets the rebar object due to the defined contour, the bar's type and the shape's database.
GetRebar | Gets the rebar object due to the defined contour, the bar's type and the shape's database.
GetRoundRebar | Gets the round rebar object due to parameters.
GetSpiralRebar | Gets the spiral rebar object due to parameters.
GetUserDatabaseDirectory | Returns directory for user databases of the specified category.
RegisterCustomFactory | Registers the custom factory.
REXFamilyConverter Properties
REXFamilyConverter Properties | Description
ContentMapper | Gets the mapper object.
Settings | Gets the settings.
Links
REX.ContentGenerator.Converters Namespace, Legend, Members, Public Methods, REXFamilyConverter Methods, REXFamilyConverter Properties


REXFamilyConverter.REXFamilyConverter Constructor

REXFamilyConverter.REXFamilyConverter Constructor
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace REXFamilyConverter Class

Initializes a new instance of the REXFamilyConverter class.

C#
public REXFamilyConverter();
Description
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, REXFamilyConverter Class


REXFamilyConverter.Close Method

REXFamilyConverter.Close Method
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace REXFamilyConverter Class

Clears collections, releases COM objects.

C#
public void Close();
Description
Remarks

It should be called before the end of the converter usage.

Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, REXFamilyConverter Class


REXFamilyConverter.FindFamily Method

REXFamilyConverter.FindFamily Method
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace REXFamilyConverter Class

Finds the REXFamilyType in the specific list.

C#
public REXFamilyType FindFamily(REXFamilyType pattern, List<REXFamilyType> families, bool assignDefault);
Parameters
Parameters | Description
pattern | The pattern.
families | The list of families.
assignDefault | If default family should be set.
Returns

Return the REXFamilyType object.

Description
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, REXFamilyConverter Class


REXFamilyConverter.GenerateMaps Method

REXFamilyConverter.GenerateMaps Method
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace REXFamilyConverter Class

Generates a file used in the mapping aliases system.

C#
public void GenerateMaps(string code, string materialDir, string sectionDir);
Parameters
Parameters | Description
code | The code.
materialDir | The material directory.
sectionDir | The section directory.
Description
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, REXFamilyConverter Class


REXFamilyConverter.GetDatabaseDirectory Method

REXFamilyConverter.GetDatabaseDirectory Method
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace Example REXFamilyConverter Class

Returns directory for databases of the specific category.

C#
public string GetDatabaseDirectory(ECategoryType category);
Description
Example

The example shows how to get directory for all databases of material category.

//Initializing the rex converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Getting directory.
string dir = rex.GetDatabaseDirectory(ECategoryType.MATERIAL);
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, REXFamilyConverter Class


REXFamilyConverter.GetDatabasePath Method

REXFamilyConverter.GetDatabasePath Method
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace Example REXFamilyConverter Class

Return a path for particular database of the specified category.

C#
public string GetDatabasePath(ECategoryType category, string dbname);
Description
Example

The example shows how to get database path of the material category.

//Initializing the rex converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Getting path.
string path = rex.GetDatabasePath(ECategoryType.MATERIAL, "Eurocode");
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, REXFamilyConverter Class


REXFamilyConverter.GetDBList Method (List<REXFamilyType>, List<string>, string, ECategoryType)

REXFamilyConverter.GetDBList Method (List<REXFamilyType>, List<string>, string, ECategoryType)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace Example REXFamilyConverter Class

Gets the list of database's records adequate for the list of input objects.

C#
public List<REXDBDescription> GetDBList(List<REXFamilyType> list, List<string> dbList, string dir, ECategoryType type);
Parameters
Parameters | Description
list | The list.
dbList | The list of databases.
dir | The directory.
type | The category of the element.
Returns

Returns the list of database's records.

Description
Example

The example shows how to get a list of records which exist in databases defined in the input list and fit to at least one specific element.

//Initializing the rex converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Definition of elements. In the current example they are created as empty families with alias names but they can be taken from different sources (e.g. Revit).
REXFamilyType fam1 = rex.GetEmptyFamilyOfAlias(REX.ContentGenerator.Families.EElementType.BEAM, "HEB 100", ECategoryType.SECTION_DB);
REXFamilyType fam2 = rex.GetEmptyFamilyOfAlias(REX.ContentGenerator.Families.EElementType.BEAM, "HEA 200", ECategoryType.SECTION_DB);
List<REXFamilyType> families = new List<REXFamilyType>() { fam1, fam2 };

//Database identification data.
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Prof";
List<string> databases = new List<string>() { "Otuapro", "CorusPro", "Aiscpro" };

//Getting the list of databases
List<REXDBDescription> dbList = rex.GetDBList(families, databases, directory, ECategoryType.SECTION_DB);
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, REXFamilyConverter Class


REXFamilyConverter.GetDBList Method (List<REXFamilyType>, string, ECategoryType)

REXFamilyConverter.GetDBList Method (List<REXFamilyType>, string, ECategoryType)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace Example REXFamilyConverter Class

Gets the list of database's records adequate for the list of input objects.

C#
public List<REXDBDescription> GetDBList(List<REXFamilyType> list, string dir, ECategoryType type);
Parameters
Parameters | Description
list | The list.
dir | The directory.
type | The category of the element.
Returns

Returns the list of database's records.

Description
Example

The example shows how to get a list of records which exist in databases from specific directory which fit to at least one specific element.

//Initializing the rex converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Definition of elements. In the current example they are created as empty families with alias names but they can be taken from different sources (e.g. Revit).        ///
REXFamilyType fam1 = rex.GetEmptyFamilyOfAlias(REX.ContentGenerator.Families.EElementType.BEAM, "HEB 100", ECategoryType.SECTION_DB);
REXFamilyType fam2 = rex.GetEmptyFamilyOfAlias(REX.ContentGenerator.Families.EElementType.BEAM, "HEA 200", ECategoryType.SECTION_DB);
List<REXFamilyType> families = new List<REXFamilyType>() { fam1, fam2 };

//Database identification data.
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Prof";

//Getting the list of databases
List<REXDBDescription> dbList = rex.GetDBList(families, directory, ECategoryType.SECTION_DB);
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, REXFamilyConverter Class


REXFamilyConverter.GetDBList Method (REXFamilyType, ECategoryType)

REXFamilyConverter.GetDBList Method (REXFamilyType, ECategoryType)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace Example REXFamilyConverter Class

Gets the list of database's records adequate for the input object.

C#
public List<REXDBDescription> GetDBList(REXFamilyType obj, ECategoryType type);
Parameters
Parameters | Description
obj | The REXFamilyType object (should be dedicated for the specific category).
type | The category of the element.
Returns

Returns the list of database's records.

Description
Example

The example shows how to get a list of records which exist in databases of the specific directory and fit to the specific element.

//Initializing the rex converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Definition of the element. In the current example it is created as the empty family with the alias name but it can be taken from different sources (e.g. Revit).
REXFamilyType fam = rex.GetEmptyFamilyOfAlias(REX.ContentGenerator.Families.EElementType.BEAM, "HEB 100", ECategoryType.SECTION_DB);

//Getting the list of databases
List<REXDBDescription> dbList = rex.GetDBList(fam,ECategoryType.SECTION_DB);
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, REXFamilyConverter Class


REXFamilyConverter.GetDBList Method (REXFamilyType, ECategoryType, List<string>)

REXFamilyConverter.GetDBList Method (REXFamilyType, ECategoryType, List<string>)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace Example REXFamilyConverter Class

Gets the list of database's records adequate for the input object.

C#
public List<REXDBDescription> GetDBList(REXFamilyType obj, ECategoryType type, List<string> directories);
Parameters
Parameters | Description
obj | The REXFamilyType object (should be dedicated for the specific category).
type | The category of the element.
directories | The list of directories.
Returns

Returns the list of database's records.

Description
Example

The example shows how to get a list of records which exist in databases of the specific directory and fit to the specific element.

//Initializing the rex converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Definition of the element. In the current example it is created as the empty family with the alias name but it can be taken from different sources (e.g. Revit).
REXFamilyType fam = rex.GetEmptyFamilyOfAlias(REX.ContentGenerator.Families.EElementType.BEAM, "HEB 100", ECategoryType.SECTION_DB);

//Database identification data.
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Prof";

//Getting the list of databases
List<REXDBDescription> dbList = rex.GetDBList(fam, ECategoryType.SECTION_DB,new List<string>(){directory});
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, REXFamilyConverter Class


REXFamilyConverter.GetDBList Method (REXFamilyType, ECategoryType, string, string)

REXFamilyConverter.GetDBList Method (REXFamilyType, ECategoryType, string, string)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace Example REXFamilyConverter Class

Gets the list of database's records adequate for the input object.

C#
public List<REXDBDescription> GetDBList(REXFamilyType obj, ECategoryType type, string directory1, string directory2);
Parameters
Parameters | Description
obj | The REXFamilyType object (should be dedicated for the specific category).
type | The category of the element.
directory1 | The first directory.
directory2 | The second directory.
Returns

Returns the list of database's records.

Description
Example

The example shows how to get a list of records which exist in databases of the specific directory and fit to the specific element.

//Initializing the rex converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Definition of the element. In the current example it is created as the empty family with the alias name but it can be taken from different sources (e.g. Revit).
REXFamilyType fam = rex.GetEmptyFamilyOfAlias(REX.ContentGenerator.Families.EElementType.BEAM, "HEB 100", ECategoryType.SECTION_DB);

//Database identification data.
string directory1 = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Prof";
string directory1 = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2012\Data\Prof";

//Getting the list of databases
List<REXDBDescription> dbList = rex.GetDBList(fam, ECategoryType.SECTION_DB,directory1,directory2);
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, REXFamilyConverter Class


REXFamilyConverter.GetDBList Method (REXFamilyType, List<string>, string, ECategoryType)

REXFamilyConverter.GetDBList Method (REXFamilyType, List<string>, string, ECategoryType)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace Example REXFamilyConverter Class

Gets the list of database's records adequate for the input object.

C#
public List<REXDBDescription> GetDBList(REXFamilyType obj, List<string> dbNames, string dir, ECategoryType type);
Parameters
Parameters | Description
obj | The REXFamilyType object (should be dedicated for the specific category).
dbNames | The list of databases.
dir | The directory.
type | The category of the element.
Returns

Returns the list of database's records.

Description
Example

The example shows how to get a list of records which exist in databases defined in the input list and fit to the specific element.

//Initializing the rex converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Definition of the element. In the current example it is created as the empty family with the alias name but it can be taken from different sources (e.g. Revit).
REXFamilyType fam = rex.GetEmptyFamilyOfAlias(REX.ContentGenerator.Families.EElementType.BEAM, "HEB 100", ECategoryType.SECTION_DB);

//Database identification data.
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Prof";
List<string> databases = new List<string>() { "Otuapro", "CorusPro", "Aiscpro" };

//Getting the list of databases
List<REXDBDescription> dbList = rex.GetDBList(fam, databases, directory, ECategoryType.SECTION_DB);
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, REXFamilyConverter Class


REXFamilyConverter.GetDBList Method (REXFamilyType, string, ECategoryType)

REXFamilyConverter.GetDBList Method (REXFamilyType, string, ECategoryType)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace Example REXFamilyConverter Class

Gets the list of database's records adequate for the input object.

C#
public List<REXDBDescription> GetDBList(REXFamilyType obj, string dir, ECategoryType type);
Parameters
Parameters | Description
obj | The REXFamilyType object (should be dedicated for the specific category).
dir | The directory.
type | The category of the element.
Returns

Returns the list of database's records.

Description
Example

The example shows how to get a list of records which exist in databases of the specific directory and fit to the specific element.

//Initializing the rex converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Definition of the element. In the current example it is created as the empty family with the alias name but it can be taken from different sources (e.g. Revit).
REXFamilyType fam = rex.GetEmptyFamilyOfAlias(REX.ContentGenerator.Families.EElementType.BEAM, "HEB 100", ECategoryType.SECTION_DB);

//Database identification data.
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Prof";

//Getting the list of databases
List<REXDBDescription> dbList = rex.GetDBList(fam, directory, ECategoryType.SECTION_DB);
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, REXFamilyConverter Class


REXFamilyConverter.GetDBList Method (REXFamilyType, string, string, ECategoryType)

REXFamilyConverter.GetDBList Method (REXFamilyType, string, string, ECategoryType)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace Example REXFamilyConverter Class

Gets the list of database's records adequate for the input object.

C#
public List<REXDBDescription> GetDBList(REXFamilyType obj, string dbName, string dir, ECategoryType type);
Parameters
Parameters | Description
obj | The REXFamilyType object (should be dedicated for the specific category).
dbName | The database's name.
dir | The directory.
type | The category of the element.
Returns

Returns the list of database's records.

Description
Example

The example shows how to get a list of records which exist in the Rcatpro database and fit to the specific element.

//Initializing the rex converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Definition of the element. In the current example it is created as the empty family with the alias name but it can be taken from different sources (e.g. Revit).        ///
REXFamilyType fam = rex.GetEmptyFamilyOfAlias(REX.ContentGenerator.Families.EElementType.BEAM, "HEB 100", ECategoryType.SECTION_DB);

//Database identification data.
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Prof";
string dbName = "Rcatpro";

//Getting the list of databases
List<REXDBDescription> dbList = rex.GetDBList(fam, dbName, directory, ECategoryType.SECTION_DB);
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, REXFamilyConverter Class


REXFamilyConverter.GetDBList Method (REXFamilyType_Custom, List<string>, string, string)

REXFamilyConverter.GetDBList Method (REXFamilyType_Custom, List<string>, string, string)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace REXFamilyConverter Class

Gets the list of database's records adequate for the input object.

C#
public List<REXDBDescription> GetDBList(REXFamilyType_Custom obj, List<string> dbNames, string dir, string customCategory);
Parameters
Parameters | Description
obj | The REXFamilyType object (the external class has to be provided).
dbNames | The list of database names(xml files).
dir | The directory.
customCategory | The custom category.
Returns

Returns the list of database's records.

Description
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, REXFamilyConverter Class


REXFamilyConverter.GetDBList Method (REXFamilyType_Custom, string, string)

REXFamilyConverter.GetDBList Method (REXFamilyType_Custom, string, string)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace REXFamilyConverter Class

Gets the list of database's records adequate for the input object.

C#
public List<REXDBDescription> GetDBList(REXFamilyType_Custom obj, string dir, string customCategory);
Parameters
Parameters | Description
obj | The REXFamilyType object (the external class has to be provided).
dir | The directory.
customCategory | The custom category.
Returns

Returns the list of database's records.

Description
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, REXFamilyConverter Class


REXFamilyConverter.GetDBList Method (REXFamilyType_Custom, string, string, string)

REXFamilyConverter.GetDBList Method (REXFamilyType_Custom, string, string, string)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace REXFamilyConverter Class

Gets the list of database's records adequate for the input object.

C#
public List<REXDBDescription> GetDBList(REXFamilyType_Custom obj, string dbName, string dir, string customCategory);
Parameters
Parameters | Description
obj | The REXFamilyType object (the external class has to be provided).
dbName | The name of the database (xml file).
dir | The directory.
customCategory | The custom category.
Returns

Returns the list of database's records.

Description
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, REXFamilyConverter Class


REXFamilyConverter.GetDbProperty Method

REXFamilyConverter.GetDbProperty Method
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace REXFamilyConverter Class

Gets the property of specific name for the database.

C#
public virtual object GetDbProperty(ECategoryType type, string dir, string dbName, string name);
Parameters
Parameters | Description
type | The category of database.
dir | The directory.
dbName | The database's name.
name | The name of the property
Returns

Returns the property value.

Description
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, REXFamilyConverter Class


REXFamilyConverter.GetEmptyFamilyOfAlias Method

REXFamilyConverter.GetEmptyFamilyOfAlias Method
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace REXFamilyConverter Class

Gets the empty family of alias name.

C#
public REXFamilyType GetEmptyFamilyOfAlias(REX.ContentGenerator.Families.EElementType el, string alias, ECategoryType type);
Parameters
Parameters | Description
el | The element type.
alias | The alias.
type | The category of the element.
Returns

Returns the REXFamilyType object.

Description
Remarks

It doesn't have any data inside despite indentification and it can be used to take proper data from the database.

Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, REXFamilyConverter Class


REXFamilyConverter.GetFamilies Method (string, ECategoryType)

REXFamilyConverter.GetFamilies Method (string, ECategoryType)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace Example REXFamilyConverter Class

Gets the list of all elements in the selected database.

C#
public List<REXFamilyType> GetFamilies(string path, ECategoryType type);
Parameters
Parameters | Description
path | The path.
type | The category of the element.
Returns

Returns the list of REXFamilyTypes.

Description
Example

The example shows how to get all sections from the Rcatptro database.

//Initializing the rex converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Database identification data.
string path = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Prof\Rcatpro.xml";

//Getting the REXFamilyType from the database.
List<REXFamilyType> families = rex.GetFamilies(path, ECategoryType.SECTION_DB);
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, REXFamilyConverter Class


REXFamilyConverter.GetFamilies Method (string, string)

REXFamilyConverter.GetFamilies Method (string, string)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace REXFamilyConverter Class

Gets the list of all elements in the selected database.

C#
public List<REXFamilyType> GetFamilies(string path, string customCategory);
Parameters
Parameters | Description
path | The path.
customCategory | The custom category.
Returns

The list of REXFamilyTypes

Description
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, REXFamilyConverter Class


REXFamilyConverter.GetFamilies Method (string, string, ECategoryType)

REXFamilyConverter.GetFamilies Method (string, string, ECategoryType)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace Example REXFamilyConverter Class

Gets the list of all elements in selected database.

C#
public List<REXFamilyType> GetFamilies(string dir, string dbName, ECategoryType type);
Parameters
Parameters | Description
dir | The directory.
dbName | The database.
type | The category of the element.
Returns

Returns the list of REXFamilyTypes.

Description
Example

The example shows how to get all sections from the Rcatptro database.

//Initializing the rex converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Database identification data.
string database = "Rcatpro";
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Prof";

//Getting the REXFamilyType from the database.
List<REXFamilyType> families = rex.GetFamilies(directory, database, ECategoryType.SECTION_DB);
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, REXFamilyConverter Class


REXFamilyConverter.GetFamilies Method (string, string, string)

REXFamilyConverter.GetFamilies Method (string, string, string)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace REXFamilyConverter Class

Gets the list of all elements in selected database.

C#
public List<REXFamilyType> GetFamilies(string dir, string dbName, string customCategory);
Parameters
Parameters | Description
dir | The directory.
dbName | The database.
customCategory | The custom category.
Returns

Returns the list of REXFamilyTypes.

Description
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, REXFamilyConverter Class


REXFamilyConverter.GetFamily Method (REXDBDescription, ECategoryType)

REXFamilyConverter.GetFamily Method (REXDBDescription, ECategoryType)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace Example REXFamilyConverter Class

Gets the REXFamilyType object based on specific database's record.

C#
public REXFamilyType GetFamily(REXDBDescription dbDesc, ECategoryType type);
Parameters
Parameters | Description
dbDesc | The database description.
type | The category of the element.
Returns

Returns the REXFamilyType object.

Description
Example

The example shows how to get the„HEA 100” section from the Rcatptro database.

//Initializing the rex converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Creating the database description for the database query.
REXSectionDBDescription dbdesc = new REXSectionDBDescription("Rcatpro");
dbdesc.Directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Prof";
dbdesc.Description.NAME = "HEA";
dbdesc.Description.DIM1 = 100;
dbdesc.Description.DIM2 = 0;
dbdesc.Description.DIM3 = 0;

//Getting the REXFamilyType from the database.
REXFamilyType fam = rex.GetFamily(dbdesc, ECategoryType.SECTION_DB);
REXFamilyType_DBSection famDBSection = fam as REXFamilyType_DBSection;
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, REXFamilyConverter Class


REXFamilyConverter.GetFamily Method (REXDBDescription, REX.ContentGenerator.Families.EElementType, EMaterial, ECategoryType)

REXFamilyConverter.GetFamily Method (REXDBDescription, REX.ContentGenerator.Families.EElementType, EMaterial, ECategoryType)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace Example REXFamilyConverter Class

Gets the REXFamilyType object based on specific database's record.

C#
public REXFamilyType GetFamily(REXDBDescription dbDesc, REX.ContentGenerator.Families.EElementType el, EMaterial mat, ECategoryType type);
Parameters
Parameters | Description
dbDesc | The database description.
el | The element type.
mat | The material.
type | The category of the element.
Returns

Returns the REXFamilyType object.

Description
Example

The example shows how to get the„HEA 100” section from the Rcatptro database.

//Initializing the rex converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Creating the database description for the database query.
REXSectionDBDescription dbdesc = new REXSectionDBDescription("Rcatpro");
dbdesc.Directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Prof";
dbdesc.Description.NAME = "HEA";
dbdesc.Description.DIM1 = 100;
dbdesc.Description.DIM2 = 0;
dbdesc.Description.DIM3 = 0;

//Getting the REXFamilyType from the database.
REXFamilyType fam = rex.GetFamily(dbdesc, REX.ContentGenerator.Families.EElementType.BEAM, EMaterial.STEEL, ECategoryType.SECTION_DB);
REXFamilyType_DBSection famDBSection = fam as REXFamilyType_DBSection;
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, REXFamilyConverter Class


REXFamilyConverter.GetFamily Method (REXDBDescription, REX.ContentGenerator.Families.EElementType, EMaterial, string)

REXFamilyConverter.GetFamily Method (REXDBDescription, REX.ContentGenerator.Families.EElementType, EMaterial, string)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace REXFamilyConverter Class

Gets the REXFamilyType object based on specific database's record.

C#
public REXFamilyType GetFamily(REXDBDescription dbDesc, REX.ContentGenerator.Families.EElementType el, EMaterial mat, string customCategory);
Parameters
Parameters | Description
dbDesc | The database description.
el | The element type.
mat | The material.
customCategory | The custom category.
Returns

Returns the REXFamilyType object.

Description
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, REXFamilyConverter Class


REXFamilyConverter.GetFamily Method (REXDBDescription, string)

REXFamilyConverter.GetFamily Method (REXDBDescription, string)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace REXFamilyConverter Class

Gets the REXFamilyType object based on the specified database's record.

C#
public REXFamilyType GetFamily(REXDBDescription dbDesc, string customCategory);
Parameters
Parameters | Description
dbDesc | The database description.
customCategory | The custom category.
Returns

Returns the REXFamilyType object.

Description
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, REXFamilyConverter Class


REXFamilyConverter.GetFamilyDBSection Method (REX.ContentGenerator.Families.EElementType, EMaterial, string)

REXFamilyConverter.GetFamilyDBSection Method (REX.ContentGenerator.Families.EElementType, EMaterial, string)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace Example REXFamilyConverter Class

Gets the section of the specified name (based on data from databases).

C#
public REXFamilyType_DBSection GetFamilyDBSection(REX.ContentGenerator.Families.EElementType elementType, EMaterial mat, string name);
Parameters
Parameters | Description
elementType | The type of the element.
mat | The material.
name | The name.
Returns

Returns the section.

Description
Example

The example shows how to get the „HEA 100” section from any database.

//Initializing the rex converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Database identification data.
string alias = "HEA 100";

//Getting the REXFamilyType from the database.
REXFamilyType_DBSection famDBSection = rex.GetFamilyDBSection(REX.ContentGenerator.Families.EElementType.BEAM, EMaterial.STEEL, alias);
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, REXFamilyConverter Class


REXFamilyConverter.GetFamilyDBSection Method (REX.ContentGenerator.Families.EElementType, EMaterial, string, double, double, double, string, string)

REXFamilyConverter.GetFamilyDBSection Method (REX.ContentGenerator.Families.EElementType, EMaterial, string, double, double, double, string, string)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace Example REXFamilyConverter Class

Gets the section of the specified key (based on data from the database).

C#
public REXFamilyType_DBSection GetFamilyDBSection(REX.ContentGenerator.Families.EElementType elementType, EMaterial mat, string name, double dim1, double dim2, double dim3, string dbName, string directory);
Parameters
Parameters | Description
elementType | The type of the element.
mat | The material.
name | The name.
dim1 | The dimension 1.
dim2 | The dimension 2.
dim3 | The dimension 3.
dbName | The name of the database.
directory | The directory where the database.
Returns

Returns the section.

Description
Example

The example shows how to get the „HEA 100” section from the Rcatpro database.

//Initializing the rex converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Database identification data.
string dbName = "Rcatpro";
string name = "HEA";
double dim1 = 100;
double dim2 = 0;
double dim3 = 0;
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Prof";

//Getting the REXFamilyType from the database.
REXFamilyType_DBSection famDBSection = rex.GetFamilyDBSection(REX.ContentGenerator.Families.EElementType.BEAM, EMaterial.STEEL, name, dim1, dim2, dim3, dbName, directory);
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, REXFamilyConverter Class


REXFamilyConverter.GetFamilyDBSection Method (REX.ContentGenerator.Families.EElementType, EMaterial, string, string)

REXFamilyConverter.GetFamilyDBSection Method (REX.ContentGenerator.Families.EElementType, EMaterial, string, string)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace Example REXFamilyConverter Class

Gets the section of the specified name (based on data from databases).

C#
public REXFamilyType_DBSection GetFamilyDBSection(REX.ContentGenerator.Families.EElementType elementType, EMaterial mat, string name, string directory);
Parameters
Parameters | Description
elementType | The type of the element.
mat | The material.
name | The name.
directory | The directory.
Returns

Returns the section.

Description
Example

The example shows how to get the „HEA 100” section from any database.

//Initializing the rex converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Database identification data.
string alias = "HEA 100";
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Prof";

//Getting the REXFamilyType from the database.
REXFamilyType_DBSection famDBSection = rex.GetFamilyDBSection(REX.ContentGenerator.Families.EElementType.BEAM, EMaterial.STEEL, alias, directory);
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, REXFamilyConverter Class


REXFamilyConverter.GetFamilyDBSection Method (REX.ContentGenerator.Families.EElementType, EMaterial, string, string, string)

REXFamilyConverter.GetFamilyDBSection Method (REX.ContentGenerator.Families.EElementType, EMaterial, string, string, string)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace Example REXFamilyConverter Class

Gets the section of the specified name (based on data from the database).

C#
public REXFamilyType_DBSection GetFamilyDBSection(REX.ContentGenerator.Families.EElementType elementType, EMaterial mat, string name, string dbName, string directory);
Parameters
Parameters | Description
elementType | The type of the element.
mat | The material.
name | The name.
dbName | The name of the database.
directory | The directory.
Returns

Returns the section.

Description
Example

The example shows how to get the „HEA 100” section from the Rcatptro database.

//Initializing the rex converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Database identification data.
string alias = "HEA 100";
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Prof";
string dbName = "Rcatpro";

//Getting the REXFamilyType from the database.
REXFamilyType_DBSection famDBSection = rex.GetFamilyDBSection(REX.ContentGenerator.Families.EElementType.BEAM, EMaterial.STEEL, alias, dbName, directory);
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, REXFamilyConverter Class


REXFamilyConverter.GetFamilyDefault Method

REXFamilyConverter.GetFamilyDefault Method
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace REXFamilyConverter Class

Gets the default REXFamilyType of the specified type.

C#
public REXFamilyType GetFamilyDefault(REX.ContentGenerator.Families.EElementType el, EMaterial mat, ECategoryType type, string typeName);
Parameters
Parameters | Description
el | The type of the element.
mat | The material.
type | The category.
typeName | The name.
Returns

Returns the REXFamilyType object.

Description
Remarks

It has all data filled with some default values (e.g. some default material with parameter is taken)

Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, REXFamilyConverter Class


REXFamilyConverter.GetFamilyMaterial Method (string)

REXFamilyConverter.GetFamilyMaterial Method (string)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace Example REXFamilyConverter Class

Gets the material of the specific name (based on data from the database).

C#
public REXFamilyType_Material GetFamilyMaterial(string name);
Parameters
Parameters | Description
name | The name of the material.
dbName | The name of the database.
directory | The directory.
Returns

Returns the material.

Description
Example

The example shows how to get the „C12/15” material from the Eurocode database.

//Initializing the rex converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Database identification data.
string name = "C12/15";
//Getting the REXFamilyType from the database.
REXFamilyType_Material famMaterial = rex.GetFamilyMaterial(name);
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, REXFamilyConverter Class


REXFamilyConverter.GetFamilyMaterial Method (string, string)

REXFamilyConverter.GetFamilyMaterial Method (string, string)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace Example REXFamilyConverter Class

Gets the material of the specified name (based on data from the database).

C#
public REXFamilyType_Material GetFamilyMaterial(string name, string directory);
Parameters
Parameters | Description
name | The name of the material.
directory | The directory.
dbname | The name of the database.
Returns

Returns the material.

Description
Example

The example shows how to get the „C12/15” material from any database.

//Initializing the rex converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Database identification data.
string name = "C12/15";
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Mate";

//Getting the REXFamilyType from the database.
REXFamilyType_Material famMaterial = rex.GetFamilyMaterial(name, directory);
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, REXFamilyConverter Class


REXFamilyConverter.GetFamilyMaterial Method (string, string, string)

REXFamilyConverter.GetFamilyMaterial Method (string, string, string)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace Example REXFamilyConverter Class

Gets the material of the specific name (based on data from the database).

C#
public REXFamilyType_Material GetFamilyMaterial(string name, string dbName, string directory);
Parameters
Parameters | Description
name | The name of material.
dbName | The name of the database.
directory | The directory.
Returns

Returns the material.

Description
Example

The example shows how to get the „C12/15” material from the Eurocode database.

//Initializing the rex converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Database identification data.
string dbName = "Eurocode";
string name = "C12/15";
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Mate";

//Getting the REXFamilyType from the database.
REXFamilyType_Material famMaterial = rex.GetFamilyMaterial(name, dbName, directory);
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, REXFamilyConverter Class


REXFamilyConverter.GetFamilyRebarHook Method

REXFamilyConverter.GetFamilyRebarHook Method
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace REXFamilyConverter Class

Gets the family rebar hook.

C#
public REXFamilyType_RebarHook GetFamilyRebarHook(EHookAngles angle, bool stirrup, bool seismic);
Parameters
Parameters | Description
angle | The angle.
stirrup | If stirrup.
seismic | If seismic.
Returns

Returns the rebar hook.

Description
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, REXFamilyConverter Class


REXFamilyConverter.GetFamilyRebarShape Method

REXFamilyConverter.GetFamilyRebarShape Method
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace REXFamilyConverter Class

Gets the rebar shape of specified code and database.

C#
public REXFamilyType_RebarShape GetFamilyRebarShape(string code, bool stirrup, string dbName);
Parameters
Parameters | Description
code | The code.
stirrup | If stirrup.
dbName | The name of the database.
Returns

Returns the rebar shape.

Description
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, REXFamilyConverter Class


REXFamilyConverter.GetFamilyRebarType Method

REXFamilyConverter.GetFamilyRebarType Method
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace Example REXFamilyConverter Class

Gets the rebar's type of the specified steel and the bar's size (based on data from the database).

C#
public REXFamilyType_RebarBarType GetFamilyRebarType(string steel, string barsize, string dbName, string directory);
Parameters
Parameters | Description
steel | The name of the steel.
barsize | The size of the bar.
dbName | The name of the database.
directory | The directory where the database is located.
Returns

Returns the rebar's type.

Description
Example

The example shows how to get the bar of Grade 40 and #8 size from the database bar_ACI 318-08 database.

//Initializing the rex converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Database identification data.
string dbName = "bar_ACI 318-08";
string grade = "Grade 40";
string size = "#8";
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Reinf";

//Getting the REXFamilyType from the database.
REXFamilyType_RebarBarType famRebarType = rex.GetFamilyRebarType(grade, size, dbName, directory);
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, REXFamilyConverter Class


REXFamilyConverter.GetFamilyTemplate Method

REXFamilyConverter.GetFamilyTemplate Method
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace REXFamilyConverter Class

Gets the dedicated template of the REXFamilyType (with initial data).

C#
public REXFamilyType GetFamilyTemplate(REX.ContentGenerator.Families.EElementType el, EMaterial mat, ECategoryType type);
Parameters
Parameters | Description
el | The element's type.
mat | The material.
type | The category of the element.
Returns

Returns the REXFamilyType object.

Description
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, REXFamilyConverter Class


REXFamilyConverter.GetFilteredFamilies Method (string, REXContentFilter, ECategoryType)

REXFamilyConverter.GetFilteredFamilies Method (string, REXContentFilter, ECategoryType)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace Example REXFamilyConverter Class

Gets the list of filtered elements in the selected database.

C#
public List<REXFamilyType> GetFilteredFamilies(string path, REXContentFilter filter, ECategoryType type);
Parameters
Parameters | Description
path | The path.
filter | The filter.
type | The category of the element.
Returns

Returns the list of REXFamilyTypes.

Description
Example

The example shows how to get filtered sections from the Rcatptro database (of HEB NAME and height more than 0.4).

//Initializing the rex converter.
REXFamilyConverter rex = new REXFamilyConverter();

REXContentParamFilter filterNAME = new REXContentParamFilter("NAME", "HEB", false, false, true);
REXContentParamFilter filterH = new REXContentParamFilter("H", 0.4, true, false, false);
REXContentLogicFilter filterLogic = new REXContentLogicFilter(REXContentLogicFilter.ELogicOperator.And, filterNAME, filterH);

//Database identification data.
string path = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Prof\Rcatpro.xml";

//Getting the REXFamilyType from the database.
List<REXFamilyType> families = rex.GetFamilies(path,filterLogic, ECategoryType.SECTION_DB);
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, REXFamilyConverter Class


REXFamilyConverter.GetFilteredFamilies Method (string, REXContentFilter, string)

REXFamilyConverter.GetFilteredFamilies Method (string, REXContentFilter, string)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace REXFamilyConverter Class

Gets the list of filtered elements in the selected database.

C#
public List<REXFamilyType> GetFilteredFamilies(string path, REXContentFilter filter, string customCategory);
Parameters
Parameters | Description
path | The path.
filter | The filter.
customCategory | The custom category.
Returns

Returns the list of REXFamilyTypes.

Description
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, REXFamilyConverter Class


REXFamilyConverter.GetFilteredFamilies Method (string, string, REXContentFilter, ECategoryType)

REXFamilyConverter.GetFilteredFamilies Method (string, string, REXContentFilter, ECategoryType)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace Example REXFamilyConverter Class

Gets the list of filtered elements in selected database.

C#
public List<REXFamilyType> GetFilteredFamilies(string dir, string dbName, REXContentFilter filter, ECategoryType type);
Parameters
Parameters | Description
dir | The directory.
dbName | The database.
filter | The filter.
type | The category of the element.
Returns

Returns the list of REXFamilyTypes.

Description
Example

The example shows how to get filtered sections from the Rcatptro database (of HEB NAME and height more than 0.4).

//Initializing the rex converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Database identification data.
string database = "Rcatpro";
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Prof";

REXContentParamFilter filterNAME = new REXContentParamFilter("NAME", "HEB", false, false, true);
REXContentParamFilter filterH = new REXContentParamFilter("H", 0.4, true, false, false);
REXContentLogicFilter filterLogic = new REXContentLogicFilter(REXContentLogicFilter.ELogicOperator.And, filterNAME, filterH);

//Getting the REXFamilyType from the database.
List<REXFamilyType> families = rex.GetFamilies(directory, database, filterLogic, ECategoryType.SECTION_DB);
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, REXFamilyConverter Class


REXFamilyConverter.GetFilteredFamilies Method (string, string, REXContentFilter, string)

REXFamilyConverter.GetFilteredFamilies Method (string, string, REXContentFilter, string)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace REXFamilyConverter Class

Gets the list of filtered elements in the selected database.

C#
public List<REXFamilyType> GetFilteredFamilies(string dir, string dbName, REXContentFilter filter, string customCategory);
Parameters
Parameters | Description
dir | The directory.
dbName | The database.
filter | The filter.
customCategory | The custom category.
Returns

Returns the list of REXFamilyTypes.

Description
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, REXFamilyConverter Class


REXFamilyConverter.GetNameForAlias Method

REXFamilyConverter.GetNameForAlias Method
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace REXFamilyConverter Class

Gets the certified name for the alias.

C#
public string GetNameForAlias(string alias, ECategoryType type);
Parameters
Parameters | Description
alias | The alias.
type | The type.
Returns

Returns the certified name.

Description
Remarks

This name exists in databases in NAME_REVIT column (sections), NAME (materials).

Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, REXFamilyConverter Class


REXFamilyConverter.GetRebar Method (List<REXxyz>, REXFamilyType_RebarBarType, bool, REXFamilyType_RebarHook, REXFamilyType_RebarHook, string)

REXFamilyConverter.GetRebar Method (List<REXxyz>, REXFamilyType_RebarBarType, bool, REXFamilyType_RebarHook, REXFamilyType_RebarHook, string)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace Example REXFamilyConverter Class

Gets the rebar object due to the defined contour, the bar's type and the shape's database.

C#
public REXFamilyType_Rebar GetRebar(List<REXxyz> contour3D, REXFamilyType_RebarBarType barType, bool stirrup, REXFamilyType_RebarHook hookStart, REXFamilyType_RebarHook hookEnd, string dbShapeName);
Parameters
Parameters | Description
contour3D | The contour of the rebar.
barType | The type of the rebar.
stirrup | If the rebar is a stirrup.
hookStart | The hook start.
hookEnd | The hook end.
dbShapeName | The name of the database.
Returns

Returns the rebar object.

Description
Example

The example shows how to get rebar object based on the specific contour.

//Initializing converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Rebar data (it can be taken from different sources e.g. Revit).
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Reinf";
REXFamilyType_RebarBarType famRebarType = rex.GetFamilyRebarType("Grade 40","#8","bar_ACI 318-08",directory);
REXFamilyType_RebarHook hookStart = new REXFamilyType_RebarHook();
hookStart.Parameters.Angle = EHookAngles.none;
REXFamilyType_RebarHook hookEnd = new REXFamilyType_RebarHook();
hookEnd.Parameters.Angle = EHookAngles.none;

//Contour.
List<REXxyz> l = new List<REXxyz>();
l.Add(new REXxyz(0, 0));
l.Add(new REXxyz(2, 0));
l.Add(new REXxyz(2, 1));

//Getting Rebar object from contour.
REXFamilyType_Rebar r = rex.GetRebar(l, famRebarType,false,hookStart,hookEnd,"barlib7_iso");

The rebar object can be used by other converters to create a rebar of the specific shape (e.g. RVTFamilyConverter: CreateRebar).

Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, REXFamilyConverter Class


REXFamilyConverter.GetRebar Method (List<REXxyz>, REXFamilyType_RebarBarType, bool, REXFamilyType_RebarHook, REXFamilyType_RebarHook, string, bool)

REXFamilyConverter.GetRebar Method (List<REXxyz>, REXFamilyType_RebarBarType, bool, REXFamilyType_RebarHook, REXFamilyType_RebarHook, string, bool)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace Example REXFamilyConverter Class

Gets the rebar object due to the defined contour, the bar's type and the shape's database.

C#
public REXFamilyType_Rebar GetRebar(List<REXxyz> contour3D, REXFamilyType_RebarBarType barType, bool stirrup, REXFamilyType_RebarHook hookStart, REXFamilyType_RebarHook hookEnd, string dbShapeName, bool closedShape);
Parameters
Parameters | Description
contour3D | The contour of the rebar.
barType | The type of the rebar.
stirrup | If the rebar is a stirrup.
hookStart | The hook start.
hookEnd | The hook end.
dbShapeName | The name of the database.
closedShape | If the rebar is closed.
Returns

Returns the rebar object.

Description
Example

The example shows how to get rebar object based on the specific contour.

//Initializing converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Rebar data (it can be taken from different sources e.g. Revit).
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Reinf";
REXFamilyType_RebarBarType famRebarType = rex.GetFamilyRebarType("Grade 40","#8","bar_ACI 318-08",directory);
REXFamilyType_RebarHook hookStart = new REXFamilyType_RebarHook();
hookStart.Parameters.Angle = EHookAngles.none;
REXFamilyType_RebarHook hookEnd = new REXFamilyType_RebarHook();
hookEnd.Parameters.Angle = EHookAngles.none;

//Contour.
List<REXxyz> l = new List<REXxyz>();
l.Add(new REXxyz(0, 0));
l.Add(new REXxyz(2, 0));
l.Add(new REXxyz(2, 1));
l.Add(new REXxyz(0, 1));
l.Add(new REXxyz(0, 0));

//Getting Rebar object from contour.
REXFamilyType_Rebar r = rex.GetRebar(l, famRebarType,false,hookStart,hookEnd,"barlib7_iso",true);

The rebar object can be used by other converters to create a rebar of the specific shape (e.g. RVTFamilyConverter: CreateRebar).

Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, REXFamilyConverter Class


REXFamilyConverter.GetRebar Method (List<REXxyz>, REXFamilyType_RebarBarType, bool, REXFamilyType_RebarHook, REXFamilyType_RebarHook, string, string)

REXFamilyConverter.GetRebar Method (List<REXxyz>, REXFamilyType_RebarBarType, bool, REXFamilyType_RebarHook, REXFamilyType_RebarHook, string, string)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace Example REXFamilyConverter Class

Gets the rebar object due to the defined contour, the bar's type and the shape's database.

C#
public REXFamilyType_Rebar GetRebar(List<REXxyz> contour3D, REXFamilyType_RebarBarType barType, bool stirrup, REXFamilyType_RebarHook hookStart, REXFamilyType_RebarHook hookEnd, string dbShapeName, string shape);
Parameters
Parameters | Description
contour3D | The contour of the rebar.
barType | The type of the rebar.
stirrup | If the rebar is a stirrup.
hookStart | The hook start.
hookEnd | The hook end.
dbShapeName | The name of the database.
shape | The suggested shape (if empty the arbitrary rebar will be generated).
Returns

Returns the rebar object.

Description
Example

The example shows how to get rebar object based on the specific contour (with shape suggested).

//Initializing converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Rebar data (it can be taken from different sources e.g. Revit).
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Reinf";
REXFamilyType_RebarBarType famRebarType = rex.GetFamilyRebarType("Grade 40","#8","bar_ACI 318-08",directory);
REXFamilyType_RebarHook hookStart = new REXFamilyType_RebarHook();
hookStart.Parameters.Angle = EHookAngles.none;
REXFamilyType_RebarHook hookEnd = new REXFamilyType_RebarHook();
hookEnd.Parameters.Angle = EHookAngles.none;

//Contour.
List<REXxyz> l = new List<REXxyz>();
l.Add(new REXxyz(0, 0));
l.Add(new REXxyz(2, 0));
l.Add(new REXxyz(2, 1));

//Getting Rebar object from contour.
REXFamilyType_Rebar r = rex.GetRebar(l,famRebarType,false,hookStart,hookEnd,"barlib7_iso","12");

The rebar object can be used by other converters to create a rebar of the specific shape (e.g. RVTFamilyConverter: CreateRebar).

Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, REXFamilyConverter Class


REXFamilyConverter.GetRebar Method (List<REXxyz>, REXFamilyType_RebarBarType, bool, REXFamilyType_RebarHook, REXFamilyType_RebarHook, string, string, bool)

REXFamilyConverter.GetRebar Method (List<REXxyz>, REXFamilyType_RebarBarType, bool, REXFamilyType_RebarHook, REXFamilyType_RebarHook, string, string, bool)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace Example REXFamilyConverter Class

Gets the rebar object due to the defined contour, the bar's type and the shape's database.

C#
public REXFamilyType_Rebar GetRebar(List<REXxyz> contour3D, REXFamilyType_RebarBarType barType, bool stirrup, REXFamilyType_RebarHook hookStart, REXFamilyType_RebarHook hookEnd, string dbShapeName, string shape, bool closedShape);
Parameters
Parameters | Description
contour3D | The contour of the rebar.
barType | The type of the rebar.
stirrup | If the rebar is a stirrup.
hookStart | The hook start.
hookEnd | The hook end.
dbShapeName | The name of the database.
shape | The suggested shape (if empty the arbitrary rebar will be generated).
closedShape | If the rebar is closed.
Returns

Returns the rebar object.

Description
Example

The example shows how to get rebar object based on the specific contour.

//Initializing converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Rebar data (it can be taken from different sources e.g. Revit).
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Reinf";
REXFamilyType_RebarBarType famRebarType = rex.GetFamilyRebarType("Grade 40", "#8", "bar_ACI 318-08", directory);
REXFamilyType_RebarHook hookStart = new REXFamilyType_RebarHook();
hookStart.Parameters.Angle = EHookAngles.none;
REXFamilyType_RebarHook hookEnd = new REXFamilyType_RebarHook();
hookEnd.Parameters.Angle = EHookAngles.none;

//Contour.
List<REXxyz> l = new List<REXxyz>();
l.Add(new REXxyz(0, 0));
l.Add(new REXxyz(2, 0));
l.Add(new REXxyz(2, 1));
l.Add(new REXxyz(0, 1));
l.Add(new REXxyz(0, 0));

//Getting Rebar object from contour.
REXFamilyType_Rebar r = rex.GetRebar(l, famRebarType, false, hookStart, hookEnd, "barlib7_iso","31",true);

The rebar object can be used by other converters to create a rebar of the specific shape (e.g. RVTFamilyConverter: CreateRebar).

Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, REXFamilyConverter Class


REXFamilyConverter.GetRebar Method (List<REXxyz>, REXxyz, REXFamilyType_RebarBarType, bool, REXFamilyType_RebarHook, REXFamilyType_RebarHook, string)

REXFamilyConverter.GetRebar Method (List<REXxyz>, REXxyz, REXFamilyType_RebarBarType, bool, REXFamilyType_RebarHook, REXFamilyType_RebarHook, string)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace Example REXFamilyConverter Class

Gets the rebar object due to the defined contour, the bar's type and the shape's database.

C#
public REXFamilyType_Rebar GetRebar(List<REXxyz> contour3D, REXxyz normal, REXFamilyType_RebarBarType barType, bool stirrup, REXFamilyType_RebarHook hookStart, REXFamilyType_RebarHook hookEnd, string dbShapeName);
Parameters
Parameters | Description
contour3D | The contour of the rebar.
normal | The normal of the plane on which the rebar is defined.
barType | The type of the rebar.
stirrup | If the rebar is a stirrup.
hookStart | The hook start.
hookEnd | The hook end.
dbShapeName | The name of the database.
Returns

Returns the rebar's type.

Description
Example

The example shows how to get rebar object based on the specific contour.

//Initializing converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Rebar data (it can be taken from different sources e.g. Revit).
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Reinf";
REXFamilyType_RebarBarType famRebarType = rex.GetFamilyRebarType("Grade 40","#8","bar_ACI 318-08",directory);
REXFamilyType_RebarHook hookStart = new REXFamilyType_RebarHook();
hookStart.Parameters.Angle = EHookAngles.none;
REXFamilyType_RebarHook hookEnd = new REXFamilyType_RebarHook();
hookEnd.Parameters.Angle = EHookAngles.none;

//Contour.
List<REXxyz> l = new List<REXxyz>();
l.Add(new REXxyz(0, 0));
l.Add(new REXxyz(2, 0));
l.Add(new REXxyz(2, 1));
REXxyz normal = new REXxyz(0, 0, 1);

//Getting Rebar object from contour.
REXFamilyType_Rebar r = rex.GetRebar(l,normal, famRebarType,false,hookStart,hookEnd,"barlib7_iso");

The rebar object can be used by other converters to create a rebar of the specific shape (e.g. RVTFamilyConverter: CreateRebar).

Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, REXFamilyConverter Class


REXFamilyConverter.GetRebar Method (List<REXxyz>, REXxyz, REXFamilyType_RebarBarType, bool, REXFamilyType_RebarHook, REXFamilyType_RebarHook, string, bool)

REXFamilyConverter.GetRebar Method (List<REXxyz>, REXxyz, REXFamilyType_RebarBarType, bool, REXFamilyType_RebarHook, REXFamilyType_RebarHook, string, bool)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace Example REXFamilyConverter Class

Gets the rebar object due to the defined contour, the bar's type and the shape's database.

C#
public REXFamilyType_Rebar GetRebar(List<REXxyz> contour3D, REXxyz normal, REXFamilyType_RebarBarType barType, bool stirrup, REXFamilyType_RebarHook hookStart, REXFamilyType_RebarHook hookEnd, string dbShapeName, bool closedShape);
Parameters
Parameters | Description
contour3D | The contour of the rebar.
normal | The normal of the plane on which the rebar is defined.
barType | The type of the rebar.
stirrup | If the rebar is a stirrup.
hookStart | The hook start.
hookEnd | The hook end.
dbShapeName | The name of the database.
closedShape | If the rebar is closed.
Returns

Returns the rebar object.

Description
Example

The example shows how to get rebar object based on the specific contour.

//Initializing converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Rebar data (it can be taken from different sources e.g. Revit).
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Reinf";
REXFamilyType_RebarBarType famRebarType = rex.GetFamilyRebarType("Grade 40", "#8", "bar_ACI 318-08", directory);
REXFamilyType_RebarHook hookStart = new REXFamilyType_RebarHook();
hookStart.Parameters.Angle = EHookAngles.none;
REXFamilyType_RebarHook hookEnd = new REXFamilyType_RebarHook();
hookEnd.Parameters.Angle = EHookAngles.none;

//Contour.
List<REXxyz> l = new List<REXxyz>();
l.Add(new REXxyz(0, 0));
l.Add(new REXxyz(2, 0));
l.Add(new REXxyz(2, 1));
l.Add(new REXxyz(0, 1));
l.Add(new REXxyz(0, 0));
REXxyz normal = new REXxyz(0, 0, 1);

//Getting Rebar object from contour.
REXFamilyType_Rebar r = rex.GetRebar(l, normal, famRebarType, false, hookStart, hookEnd, "barlib7_iso",true);

The rebar object can be used by other converters to create a rebar of the specific shape (e.g. RVTFamilyConverter: CreateRebar).

Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, REXFamilyConverter Class


REXFamilyConverter.GetRebar Method (List<REXxyz>, REXxyz, REXFamilyType_RebarBarType, bool, REXFamilyType_RebarHook, REXFamilyType_RebarHook, string, string)

REXFamilyConverter.GetRebar Method (List<REXxyz>, REXxyz, REXFamilyType_RebarBarType, bool, REXFamilyType_RebarHook, REXFamilyType_RebarHook, string, string)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace Example REXFamilyConverter Class

Gets the rebar object due to the defined contour, the bar's type and the shape's database.

C#
public REXFamilyType_Rebar GetRebar(List<REXxyz> contour3D, REXxyz normal, REXFamilyType_RebarBarType barType, bool stirrup, REXFamilyType_RebarHook hookStart, REXFamilyType_RebarHook hookEnd, string dbShapeName, string shape);
Parameters
Parameters | Description
contour3D | The contour of the rebar.
normal | The normal of the plane on which the rebar is defined.
barType | The type of the rebar.
stirrup | If the rebar is a stirrup.
hookStart | The hook start.
hookEnd | The hook end.
dbShapeName | The name of the database.
shape | The suggested shape.
Returns

Returns the rebar object.

Description
Example

The example shows how to get rebar object based on the specific contour (with shape suggested).

//Initializing converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Rebar data (it can be taken from different sources e.g. Revit).
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Reinf";
REXFamilyType_RebarBarType famRebarType = rex.GetFamilyRebarType("Grade 40","#8","bar_ACI 318-08",directory);
REXFamilyType_RebarHook hookStart = new REXFamilyType_RebarHook();
hookStart.Parameters.Angle = EHookAngles.none;
REXFamilyType_RebarHook hookEnd = new REXFamilyType_RebarHook();
hookEnd.Parameters.Angle = EHookAngles.none;

//Contour.
List<REXxyz> l = new List<REXxyz>();
l.Add(new REXxyz(0, 0));
l.Add(new REXxyz(2, 0));
l.Add(new REXxyz(2, 1));
REXxyz normal = new REXxyz(0, 0, 1);

//Getting Rebar object from contour.
REXFamilyType_Rebar r = rex.GetRebar(l,normal, famRebarType,false,hookStart,hookEnd,"barlib7_iso","12");

The rebar object can be used by other converters to create a rebar of the specific shape (e.g. RVTFamilyConverter: CreateRebar).

Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, REXFamilyConverter Class


REXFamilyConverter.GetRebar Method (List<REXxyz>, REXxyz, REXFamilyType_RebarBarType, bool, REXFamilyType_RebarHook, REXFamilyType_RebarHook, string, string, bool)

REXFamilyConverter.GetRebar Method (List<REXxyz>, REXxyz, REXFamilyType_RebarBarType, bool, REXFamilyType_RebarHook, REXFamilyType_RebarHook, string, string, bool)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace Example REXFamilyConverter Class

Gets the rebar object due to the defined contour, the bar's type and the shape's database.

C#
public REXFamilyType_Rebar GetRebar(List<REXxyz> contour3D, REXxyz normal, REXFamilyType_RebarBarType barType, bool stirrup, REXFamilyType_RebarHook hookStart, REXFamilyType_RebarHook hookEnd, string dbShapeName, string shape, bool closedShape);
Parameters
Parameters | Description
contour3D | The contour of the rebar.
normal | The normal of the plane on which the rebar is defined.
barType | The type of the rebar.
stirrup | If the rebar is a stirrup.
hookStart | The hook start.
hookEnd | The hook end.
dbShapeName | The name of the database.
shape | The suggested shape (if empty the arbitrary rebar will be generated).
closedShape | If the rebar is closed.
Returns

Returns the rebar object.

Description
Example

The example shows how to get rebar object based on the specific contour.

//Initializing converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Rebar data (it can be taken from different sources e.g. Revit).
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Reinf";
REXFamilyType_RebarBarType famRebarType = rex.GetFamilyRebarType("Grade 40", "#8", "bar_ACI 318-08", directory);
REXFamilyType_RebarHook hookStart = new REXFamilyType_RebarHook();
hookStart.Parameters.Angle = EHookAngles.none;
REXFamilyType_RebarHook hookEnd = new REXFamilyType_RebarHook();
hookEnd.Parameters.Angle = EHookAngles.none;

//Contour.
List<REXxyz> l = new List<REXxyz>();
l.Add(new REXxyz(0, 0));
l.Add(new REXxyz(2, 0));
l.Add(new REXxyz(2, 1));
l.Add(new REXxyz(0, 1));
l.Add(new REXxyz(0, 0));
REXxyz normal = new REXxyz(0, 0, 1);

//Getting Rebar object from contour.
REXFamilyType_Rebar r = rex.GetRebar(l, normal, famRebarType, false, hookStart, hookEnd, "barlib7_iso","31",true);

The rebar object can be used by other converters to create a rebar of the specific shape (e.g. RVTFamilyConverter: CreateRebar).

Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, REXFamilyConverter Class


REXFamilyConverter.GetRebar Method (REX.ContentGenerator.Geometry.Contour_3D, REXFamilyType_RebarBarType, bool, REXFamilyType_RebarHook, REXFamilyType_RebarHook, string)

REXFamilyConverter.GetRebar Method (REX.ContentGenerator.Geometry.Contour_3D, REXFamilyType_RebarBarType, bool, REXFamilyType_RebarHook, REXFamilyType_RebarHook, string)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace Example REXFamilyConverter Class

Gets the rebar object due to the defined contour, the bar's type and the shape's database.

C#
public REXFamilyType_Rebar GetRebar(REX.ContentGenerator.Geometry.Contour_3D contour3D, REXFamilyType_RebarBarType barType, bool stirrup, REXFamilyType_RebarHook hookStart, REXFamilyType_RebarHook hookEnd, string dbShapeName);
Parameters
Parameters | Description
contour3D | The contour of the rebar.
barType | The type of the rebar.
stirrup | If the rebar is a stirrup.
hookStart | The hook start.
hookEnd | The hook end.
dbShapeName | The name of the database.
Returns

Returns the rebar object.

Description
Example

The example shows how to get rebar object based on the specific contour.

//Initializing converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Rebar data (it can be taken from different sources e.g. Revit).
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Reinf";
REXFamilyType_RebarBarType famRebarType = rex.GetFamilyRebarType("Grade 40", "#8", "bar_ACI 318-08", directory);
REXFamilyType_RebarHook hookStart = new REXFamilyType_RebarHook();
hookStart.Parameters.Angle = EHookAngles.none;
REXFamilyType_RebarHook hookEnd = new REXFamilyType_RebarHook();
hookEnd.Parameters.Angle = EHookAngles.none;

//Contour.
REX.ContentGenerator.Geometry.Contour_3D cont = new REX.ContentGenerator.Geometry.Contour_3D();
cont.StartContour(new REXxyz(0, 0));
cont.LineTo(new REXxyz(2, 0));
cont.LineTo(new REXxyz(2, 1));

//Getting Rebar object from contour.
REXFamilyType_Rebar r = rex.GetRebar(cont, famRebarType, false, hookStart, hookEnd, "barlib7_iso");

The rebar object can be used by other converters to create a rebar of the specific shape (e.g. RVTFamilyConverter: CreateRebar).

Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, REXFamilyConverter Class


REXFamilyConverter.GetRebar Method (REX.ContentGenerator.Geometry.Contour_3D, REXFamilyType_RebarBarType, bool, REXFamilyType_RebarHook, REXFamilyType_RebarHook, string, bool)

REXFamilyConverter.GetRebar Method (REX.ContentGenerator.Geometry.Contour_3D, REXFamilyType_RebarBarType, bool, REXFamilyType_RebarHook, REXFamilyType_RebarHook, string, bool)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace Example REXFamilyConverter Class

Gets the rebar object due to the defined contour, the bar's type and the shape's database.

C#
public REXFamilyType_Rebar GetRebar(REX.ContentGenerator.Geometry.Contour_3D contour3D, REXFamilyType_RebarBarType barType, bool stirrup, REXFamilyType_RebarHook hookStart, REXFamilyType_RebarHook hookEnd, string dbShapeName, bool closedShape);
Parameters
Parameters | Description
contour3D | The contour of the rebar.
barType | The type of the rebar.
stirrup | If the rebar is a stirrup.
hookStart | The hook start.
hookEnd | The hook end.
dbShapeName | The name of the database.
closedShape | If the rebar is closed.
Returns

Returns the rebar object.

Description
Example

The example shows how to get rebar object based on the specific contour.

//Initializing converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Rebar data (it can be taken from different sources e.g. Revit).
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Reinf";
REXFamilyType_RebarBarType famRebarType = rex.GetFamilyRebarType("Grade 40", "#8", "bar_ACI 318-08", directory);
REXFamilyType_RebarHook hookStart = new REXFamilyType_RebarHook();
hookStart.Parameters.Angle = EHookAngles.none;
REXFamilyType_RebarHook hookEnd = new REXFamilyType_RebarHook();
hookEnd.Parameters.Angle = EHookAngles.none;

//Contour.
REX.ContentGenerator.Geometry.Contour_3D cont = new REX.ContentGenerator.Geometry.Contour_3D();
cont.StartContour(new REXxyz(0, 0));
cont.LineTo(new REXxyz(2, 0));
cont.LineTo(new REXxyz(2, 1));

//Getting Rebar object from contour.
REXFamilyType_Rebar r = rex.GetRebar(cont, famRebarType, false, hookStart, hookEnd, "barlib7_iso",true);

The rebar object can be used by other converters to create a rebar of the specific shape (e.g. RVTFamilyConverter: CreateRebar).

Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, REXFamilyConverter Class


REXFamilyConverter.GetRebar Method (REX.ContentGenerator.Geometry.Contour_3D, REXFamilyType_RebarBarType, bool, REXFamilyType_RebarHook, REXFamilyType_RebarHook, string, string)

REXFamilyConverter.GetRebar Method (REX.ContentGenerator.Geometry.Contour_3D, REXFamilyType_RebarBarType, bool, REXFamilyType_RebarHook, REXFamilyType_RebarHook, string, string)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace Example REXFamilyConverter Class

Gets the rebar object due to the defined contour, the bar's type and the shape's database.

C#
public REXFamilyType_Rebar GetRebar(REX.ContentGenerator.Geometry.Contour_3D contour3D, REXFamilyType_RebarBarType barType, bool stirrup, REXFamilyType_RebarHook hookStart, REXFamilyType_RebarHook hookEnd, string dbShapeName, string shape);
Parameters
Parameters | Description
contour3D | The contour of the rebar.
barType | The type of the rebar.
stirrup | If the rebar is a stirrup.
hookStart | The hook start.
hookEnd | The hook end.
dbShapeName | The name of the database.
shape | The suggested shape (if empty the arbitrary rebar will be generated).
Returns

Returns the rebar object.

Description
Example

The example shows how to get rebar object based on the specific contour (with shape suggested).

//Initializing converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Rebar data (it can be taken from different sources e.g. Revit).
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Reinf";
REXFamilyType_RebarBarType famRebarType = rex.GetFamilyRebarType("Grade 40", "#8", "bar_ACI 318-08", directory);
REXFamilyType_RebarHook hookStart = new REXFamilyType_RebarHook();
hookStart.Parameters.Angle = EHookAngles.none;
REXFamilyType_RebarHook hookEnd = new REXFamilyType_RebarHook();
hookEnd.Parameters.Angle = EHookAngles.none;

//Contour.
REX.ContentGenerator.Geometry.Contour_3D cont = new REX.ContentGenerator.Geometry.Contour_3D();
cont.StartContour(new REXxyz(0, 0));
cont.LineTo(new REXxyz(2, 0));
cont.LineTo(new REXxyz(2, 1));

//Getting Rebar object from contour.
REXFamilyType_Rebar r = rex.GetRebar(cont, famRebarType, false, hookStart, hookEnd, "barlib7_iso","12");

The rebar object can be used by other converters to create a rebar of the specific shape (e.g. RVTFamilyConverter: CreateRebar).

Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, REXFamilyConverter Class


REXFamilyConverter.GetRebar Method (REX.ContentGenerator.Geometry.Contour_3D, REXFamilyType_RebarBarType, bool, REXFamilyType_RebarHook, REXFamilyType_RebarHook, string, string, bool)

REXFamilyConverter.GetRebar Method (REX.ContentGenerator.Geometry.Contour_3D, REXFamilyType_RebarBarType, bool, REXFamilyType_RebarHook, REXFamilyType_RebarHook, string, string, bool)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace Example REXFamilyConverter Class

Gets the rebar object due to the defined contour, the bar's type and the shape's database.

C#
public REXFamilyType_Rebar GetRebar(REX.ContentGenerator.Geometry.Contour_3D contour3D, REXFamilyType_RebarBarType barType, bool stirrup, REXFamilyType_RebarHook hookStart, REXFamilyType_RebarHook hookEnd, string dbShapeName, string shape, bool closedShape);
Parameters
Parameters | Description
contour3D | The contour of the rebar.
barType | The type of the rebar.
stirrup | If the rebar is a stirrup.
hookStart | The hook start.
hookEnd | The hook end.
dbShapeName | The name of the database.
shape | The suggested shape (if empty the arbitrary rebar will be generated).
closedShape | If the rebar is closed.
Returns

Returns the rebar object.

Description
Example

The example shows how to get rebar object based on the specific contour.

//Initializing converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Rebar data (it can be taken from different sources e.g. Revit).
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Reinf";
REXFamilyType_RebarBarType famRebarType = rex.GetFamilyRebarType("Grade 40", "#8", "bar_ACI 318-08", directory);
REXFamilyType_RebarHook hookStart = new REXFamilyType_RebarHook();
hookStart.Parameters.Angle = EHookAngles.none;
REXFamilyType_RebarHook hookEnd = new REXFamilyType_RebarHook();
hookEnd.Parameters.Angle = EHookAngles.none;

//Contour.
REX.ContentGenerator.Geometry.Contour_3D cont = new REX.ContentGenerator.Geometry.Contour_3D();
cont.StartContour(new REXxyz(0, 0));
cont.LineTo(new REXxyz(2, 0));
cont.LineTo(new REXxyz(2, 1));

//Getting Rebar object from contour.
REXFamilyType_Rebar r = rex.GetRebar(cont, famRebarType, false, hookStart, hookEnd, "barlib7_iso","31",true);

The rebar object can be used by other converters to create a rebar of the specific shape (e.g. RVTFamilyConverter: CreateRebar).

Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, REXFamilyConverter Class


REXFamilyConverter.GetRebar Method (REX.ContentGenerator.Geometry.Contour_3D, REXxyz, REXFamilyType_RebarBarType, bool, REXFamilyType_RebarHook, REXFamilyType_RebarHook, string)

REXFamilyConverter.GetRebar Method (REX.ContentGenerator.Geometry.Contour_3D, REXxyz, REXFamilyType_RebarBarType, bool, REXFamilyType_RebarHook, REXFamilyType_RebarHook, string)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace Example REXFamilyConverter Class

Gets the rebar object due to the defined contour, the bar's type and the shape's database.

C#
public REXFamilyType_Rebar GetRebar(REX.ContentGenerator.Geometry.Contour_3D contour3D, REXxyz normal, REXFamilyType_RebarBarType barType, bool stirrup, REXFamilyType_RebarHook hookStart, REXFamilyType_RebarHook hookEnd, string dbShapeName);
Parameters
Parameters | Description
contour3D | The contour of the rebar.
normal | The normal of the plane on which the rebar is defined.
barType | The type of the rebar.
stirrup | If the rebar is a stirrup.
hookStart | The hook start.
hookEnd | The hook end.
dbShapeName | The name of the database.
Returns

Returns the rebar object.

Description
Example

The example shows how to get rebar object based on the specific contour.

//Initializing converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Rebar data (it can be taken from different sources e.g. Revit).
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Reinf";
REXFamilyType_RebarBarType famRebarType = rex.GetFamilyRebarType("Grade 40", "#8", "bar_ACI 318-08", directory);
REXFamilyType_RebarHook hookStart = new REXFamilyType_RebarHook();
hookStart.Parameters.Angle = EHookAngles.none;
REXFamilyType_RebarHook hookEnd = new REXFamilyType_RebarHook();
hookEnd.Parameters.Angle = EHookAngles.none;

//Contour.
REX.ContentGenerator.Geometry.Contour_3D cont = new REX.ContentGenerator.Geometry.Contour_3D();
cont.StartContour(new REXxyz(0, 0));
cont.LineTo(new REXxyz(2, 0));
cont.LineTo(new REXxyz(2, 1));
REXxyz normal = new REXxyz(0, 0, 1);

//Getting Rebar object from contour.
REXFamilyType_Rebar r = rex.GetRebar(cont, normal, famRebarType, false, hookStart, hookEnd, "barlib7_iso");

The rebar object can be used by other converters to create a rebar of the specific shape (e.g. RVTFamilyConverter: CreateRebar).

Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, REXFamilyConverter Class


REXFamilyConverter.GetRebar Method (REX.ContentGenerator.Geometry.Contour_3D, REXxyz, REXFamilyType_RebarBarType, bool, REXFamilyType_RebarHook, REXFamilyType_RebarHook, string, bool)

REXFamilyConverter.GetRebar Method (REX.ContentGenerator.Geometry.Contour_3D, REXxyz, REXFamilyType_RebarBarType, bool, REXFamilyType_RebarHook, REXFamilyType_RebarHook, string, bool)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace Example REXFamilyConverter Class

Gets the rebar object due to the defined contour, the bar's type and the shape's database.

C#
public REXFamilyType_Rebar GetRebar(REX.ContentGenerator.Geometry.Contour_3D contour3D, REXxyz normal, REXFamilyType_RebarBarType barType, bool stirrup, REXFamilyType_RebarHook hookStart, REXFamilyType_RebarHook hookEnd, string dbShapeName, bool closedShape);
Parameters
Parameters | Description
contour3D | The contour of the rebar.
normal | The normal of the plane on which the rebar is defined.
barType | The type of the rebar.
stirrup | If the rebar is a stirrup.
hookStart | The hook start.
hookEnd | The hook end.
dbShapeName | The name of the database.
closedShape | If the rebar is closed.
Returns

Returns the rebar object.

Description
Example

The example shows how to get rebar object based on the specific contour.

//Initializing converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Rebar data (it can be taken from different sources e.g. Revit).
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Reinf";
REXFamilyType_RebarBarType famRebarType = rex.GetFamilyRebarType("Grade 40", "#8", "bar_ACI 318-08", directory);
REXFamilyType_RebarHook hookStart = new REXFamilyType_RebarHook();
hookStart.Parameters.Angle = EHookAngles.none;
REXFamilyType_RebarHook hookEnd = new REXFamilyType_RebarHook();
hookEnd.Parameters.Angle = EHookAngles.none;

//Contour.
REX.ContentGenerator.Geometry.Contour_3D cont = new REX.ContentGenerator.Geometry.Contour_3D();
cont.StartContour(new REXxyz(0, 0));
cont.LineTo(new REXxyz(2, 0));
cont.LineTo(new REXxyz(2, 1));
REXxyz normal = new REXxyz(0, 0, 1);

//Getting Rebar object from contour.
REXFamilyType_Rebar r = rex.GetRebar(cont, normal, famRebarType, false, hookStart, hookEnd, "barlib7_iso",true);

The rebar object can be used by other converters to create a rebar of the specific shape (e.g. RVTFamilyConverter: CreateRebar).

Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, REXFamilyConverter Class


REXFamilyConverter.GetRebar Method (REX.ContentGenerator.Geometry.Contour_3D, REXxyz, REXFamilyType_RebarBarType, bool, REXFamilyType_RebarHook, REXFamilyType_RebarHook, string, string)

REXFamilyConverter.GetRebar Method (REX.ContentGenerator.Geometry.Contour_3D, REXxyz, REXFamilyType_RebarBarType, bool, REXFamilyType_RebarHook, REXFamilyType_RebarHook, string, string)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace Example REXFamilyConverter Class

Gets the rebar object due to the defined contour, the bar's type and the shape's database.

C#
public REXFamilyType_Rebar GetRebar(REX.ContentGenerator.Geometry.Contour_3D contour3D, REXxyz normal, REXFamilyType_RebarBarType barType, bool stirrup, REXFamilyType_RebarHook hookStart, REXFamilyType_RebarHook hookEnd, string dbShapeName, string shape);
Parameters
Parameters | Description
contour3D | The contour of the rebar.
normal | The normal of the plane on which the rebar is defined.
barType | The type of the rebar.
stirrup | If the rebar is a stirrup.
hookStart | The hook start.
hookEnd | The hook end.
dbShapeName | The name of the database.
shape | The suggested shape (if empty the arbitrary rebar will be generated).
Returns

Returns the rebar object.

Description
Example

The example shows how to get rebar object based on the specific contour (with shape suggested).

//Initializing converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Rebar data (it can be taken from different sources e.g. Revit).
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Reinf";
REXFamilyType_RebarBarType famRebarType = rex.GetFamilyRebarType("Grade 40", "#8", "bar_ACI 318-08", directory);
REXFamilyType_RebarHook hookStart = new REXFamilyType_RebarHook();
hookStart.Parameters.Angle = EHookAngles.none;
REXFamilyType_RebarHook hookEnd = new REXFamilyType_RebarHook();
hookEnd.Parameters.Angle = EHookAngles.none;

//Contour.
REX.ContentGenerator.Geometry.Contour_3D cont = new REX.ContentGenerator.Geometry.Contour_3D();
cont.StartContour(new REXxyz(0, 0));
cont.LineTo(new REXxyz(2, 0));
cont.LineTo(new REXxyz(2, 1));
REXxyz normal = new REXxyz(0, 0, 1);

//Getting Rebar object from contour.
REXFamilyType_Rebar r = rex.GetRebar(cont, normal, famRebarType, false, hookStart, hookEnd, "barlib7_iso","12");

The rebar object can be used by other converters to create a rebar of the specific shape (e.g. RVTFamilyConverter: CreateRebar).

Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, REXFamilyConverter Class


REXFamilyConverter.GetRebar Method (REX.ContentGenerator.Geometry.Contour_3D, REXxyz, REXFamilyType_RebarBarType, bool, REXFamilyType_RebarHook, REXFamilyType_RebarHook, string, string, bool)

REXFamilyConverter.GetRebar Method (REX.ContentGenerator.Geometry.Contour_3D, REXxyz, REXFamilyType_RebarBarType, bool, REXFamilyType_RebarHook, REXFamilyType_RebarHook, string, string, bool)
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace Example REXFamilyConverter Class

Gets the rebar object due to the defined contour, the bar's type and the shape's database.

C#
public REXFamilyType_Rebar GetRebar(REX.ContentGenerator.Geometry.Contour_3D contour3D, REXxyz normal, REXFamilyType_RebarBarType barType, bool stirrup, REXFamilyType_RebarHook hookStart, REXFamilyType_RebarHook hookEnd, string dbShapeName, string shape, bool closedShape);
Parameters
Parameters | Description
contour3D | The contour of the rebar.
normal | The normal of the plane on which the rebar is defined.
barType | The type of the rebar.
stirrup | If the rebar is a stirrup.
hookStart | The hook start.
hookEnd | The hook end.
dbShapeName | The name of the database.
shape | The suggested shape (if empty the arbitrary rebar will be generated).
closedShape | If the rebar is closed.
Returns

Returns the rebar object.

Description
Example

The example shows how to get rebar object based on the specific contour.

//Initializing converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Rebar data (it can be taken from different sources e.g. Revit).
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Reinf";
REXFamilyType_RebarBarType famRebarType = rex.GetFamilyRebarType("Grade 40", "#8", "bar_ACI 318-08", directory);
REXFamilyType_RebarHook hookStart = new REXFamilyType_RebarHook();
hookStart.Parameters.Angle = EHookAngles.none;
REXFamilyType_RebarHook hookEnd = new REXFamilyType_RebarHook();
hookEnd.Parameters.Angle = EHookAngles.none;

//Contour.
REX.ContentGenerator.Geometry.Contour_3D cont = new REX.ContentGenerator.Geometry.Contour_3D();
cont.StartContour(new REXxyz(0, 0));
cont.LineTo(new REXxyz(2, 0));
cont.LineTo(new REXxyz(2, 1));
REXxyz normal = new REXxyz(0, 0, 1);

//Getting Rebar object from contour.
REXFamilyType_Rebar r = rex.GetRebar(cont, normal, famRebarType, false, hookStart, hookEnd, "barlib7_iso","31",true);

The rebar object can be used by other converters to create a rebar of the specific shape (e.g. RVTFamilyConverter: CreateRebar).

Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, REXFamilyConverter Class


REXFamilyConverter.GetRoundRebar Method

REXFamilyConverter.GetRoundRebar Method
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace Example REXFamilyConverter Class

Gets the round rebar object due to parameters.

C#
public REXFamilyType_Rebar GetRoundRebar(REXxyz insertPt, REXxyz normal, double diameter, double lapSplice, REXFamilyType_RebarBarType barType, bool stirrup, REXFamilyType_RebarHook hookStart, REXFamilyType_RebarHook hookEnd);
Parameters
Parameters | Description
insertPt | The insertion point (the center of a circle).
normal | The normal of the plane on which the rebar is defined.
diameter | The diameter of circle (in axes).
lapSplice | The lap splice.
barType | The type of the rebar.
stirrup | If the rebar is a stirrup.
hookStart | The hook start.
hookEnd | The hook end.
Returns

Returns the rebar object.

Description
Example

The example shows how to get a round rebar.

//Initializing converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Rebar data (it can be taken from different sources e.g. Revit).
string directory = @"C:Documents and SettingsAll UsersApplication DataAutodeskStructuralCommon Data2011DataReinf";
REXFamilyType_RebarBarType famRebarType = rex.GetFamilyRebarType("Grade 40", "#8", "bar_ACI 318-08", directory);

REXFamilyType_RebarHook hookStart = new REXFamilyType_RebarHook();
hookStart.Parameters.Angle = EHookAngles.none;

REXFamilyType_RebarHook hookEnd = new REXFamilyType_RebarHook();
hookEnd.Parameters.Angle = EHookAngles.none;

REX.Common.Geometry.REXxyz normal = new REX.Common.Geometry.REXxyz(0, 0, 1);
REX.Common.Geometry.REXxyz center = new REX.Common.Geometry.REXxyz(0, 0, 0);
double diameter = 1;
double lapSplice = 0.2;

//Getting Rebar object from contour.
REXFamilyType_Rebar r = rex.GetRoundRebar(center,normal,diameter,lapSplice, famRebarType, false, hookStart, hookEnd);

The rebar object can be used by other converters to create a rebar of the specific shape (e.g. RVTFamilyConverter: CreateRebar).

Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, REXFamilyConverter Class


REXFamilyConverter.GetSpiralRebar Method

REXFamilyConverter.GetSpiralRebar Method
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace Example REXFamilyConverter Class

Gets the spiral rebar object due to parameters.

C#
public REXFamilyType_Rebar GetSpiralRebar(REXxyz insertPt, REXxyz normal, double diameter, double height, double pitch, REXFamilyType_RebarBarType barType, bool stirrup, REXFamilyType_RebarHook hookStart, REXFamilyType_RebarHook hookEnd);
Parameters
Parameters | Description
insertPt | The insertion point (the center of a circle).
normal | The normal of the plane on which the rebar is defined.
diameter | The diameter of circle (in axes).
height | The height of the rebar
pitch | The pitch.
barType | The type of the rebar.
stirrup | If the rebar is a stirrup.
hookStart | The hook start.
hookEnd | The hook end.
Returns

Returns the rebar object.

Description
Example

The example shows how to get a round rebar.

//Initializing converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Rebar data (it can be taken from different sources e.g. Revit).
string directory = @"C:Documents and SettingsAll UsersApplication DataAutodeskStructuralCommon Data2011DataReinf";
REXFamilyType_RebarBarType famRebarType = rex.GetFamilyRebarType("Grade 40", "#8", "bar_ACI 318-08", directory);

REXFamilyType_RebarHook hookStart = new REXFamilyType_RebarHook();
hookStart.Parameters.Angle = EHookAngles.none;

REXFamilyType_RebarHook hookEnd = new REXFamilyType_RebarHook();
hookEnd.Parameters.Angle = EHookAngles.none;

REX.Common.Geometry.REXxyz normal = new REX.Common.Geometry.REXxyz(0, 0, 1);
REX.Common.Geometry.REXxyz center = new REX.Common.Geometry.REXxyz(0, 0, 0);
double diameter = 1;
double height = 2;
double pitch = 0.3;

//Getting Rebar object from contour.
REXFamilyType_Rebar r = rex.GetSpiralRebar(center, normal, diameter,height,pitch, famRebarType, false, hookStart, hookEnd);

The rebar object can be used by other converters to create a rebar of the specific shape (e.g. RVTFamilyConverter: CreateRebar).

Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, REXFamilyConverter Class


REXFamilyConverter.GetUserDatabaseDirectory Method

REXFamilyConverter.GetUserDatabaseDirectory Method
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace REXFamilyConverter Class

Returns directory for user databases of the specified category.

C#
public string GetUserDatabaseDirectory(ECategoryType category);
Description
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, REXFamilyConverter Class


REXFamilyConverter.RegisterCustomFactory Method

REXFamilyConverter.RegisterCustomFactory Method
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace REXFamilyConverter Class

Registers the custom factory.

C#
public bool RegisterCustomFactory<T_REXFamilyType, T_REXDescription>(string name, string parametersFilePath) where T_REXFamilyType : new() where T_REXDescription : new();
Parameters
Parameters | Description
name | The name of the custom category(it will be used for identification so it has to be unique and consistent).
parametersFilePath | The parameters file path.
Type Parameters
Type Parameters | Description
T_REXFamilyType | The type of the custom family type.
T_REXDescription | The type of the custom description.
Returns

Returns whether registration succeeded.

Description
Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, REXFamilyConverter Class


REXFamilyConverter.ContentMapper Property

REXFamilyConverter.ContentMapper Property
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace REXFamilyConverter Class

Gets the mapper object.

C#
public REXContentMapper ContentMapper;
Description

The content mapper.

Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, REXFamilyConverter Class


REXFamilyConverter.Settings Property

REXFamilyConverter.Settings Property
REXFamilyConverter Class REX.ContentGenerator.Converters Namespace REXFamilyConverter Class

Gets the settings.

C#
public IRexContentSettings Settings;
Description

The settings.

Class

REXFamilyConverter Class

Links
REXFamilyConverter Class, REX.ContentGenerator.Converters Namespace, REXFamilyConverter Class


REXMaterialFactory Class

REXMaterialFactory Class
REX.ContentGenerator.Converters Namespace Legend Members Public Methods REXMaterialFactory Methods

This is class REX.ContentGenerator.Converters.REXMaterialFactory.

Class Hierarchy
C#
public class REXMaterialFactory : REXFamilyFactoryDbRootAdo;
Namespace

REX.ContentGenerator.Converters Namespace

Public Methods
Public Method | Description
REXMaterialFactory | This is REXMaterialFactory, a member of class REXMaterialFactory.
REXMaterialFactory Methods
REXMaterialFactory Methods | Description
CompareRows | This is CompareRows, a member of class REXMaterialFactory.
FillDBDescription | This is FillDBDescription, a member of class REXMaterialFactory.
FillDBObjectCollection | This is FillDBObjectCollection, a member of class REXMaterialFactory.
FillFamilyTypeProperties | This is FillFamilyTypeProperties, a member of class REXMaterialFactory.
FillFamilyTypeProperties | This is FillFamilyTypeProperties, a member of class REXMaterialFactory.
GetAliasName | This is GetAliasName, a member of class REXMaterialFactory.
GetFamiliesOfAlias | This is GetFamiliesOfAlias, a member of class REXMaterialFactory.
GetFamilyDefault | This is GetFamilyDefault, a member of class REXMaterialFactory.
GetFamilyOfAlias | This is GetFamilyOfAlias, a member of class REXMaterialFactory.
GetFamilyTemplate | This is GetFamilyTemplate, a member of class REXMaterialFactory.
GetMaterial | This is GetMaterial, a member of class REXMaterialFactory.
GetNewDescription | This is GetNewDescription, a member of class REXMaterialFactory.
GetNewDescription | This is GetNewDescription, a member of class REXMaterialFactory.
GetNewFamily | This is GetNewFamily, a member of class REXMaterialFactory.
GetPropertiesADO | This is GetPropertiesADO, a member of class REXMaterialFactory.
GetPropertiesDBRoot | This is GetPropertiesDBRoot, a member of class REXMaterialFactory.
RecalculatDBDesc | This is RecalculatDBDesc, a member of class REXMaterialFactory.
ValidateDB | This is ValidateDB, a member of class REXMaterialFactory.
ValidateDB | This is ValidateDB, a member of class REXMaterialFactory.
Links
REX.ContentGenerator.Converters Namespace, Legend, Members, Public Methods, REXMaterialFactory Methods


REXMaterialFactory.REXMaterialFactory Constructor

REXMaterialFactory.REXMaterialFactory Constructor
REXMaterialFactory Class REX.ContentGenerator.Converters Namespace REXMaterialFactory Class

This is REXMaterialFactory, a member of class REXMaterialFactory.

C#
public REXMaterialFactory(RexConversionSettings Settings);
Class

REXMaterialFactory Class

Links
REXMaterialFactory Class, REX.ContentGenerator.Converters Namespace, REXMaterialFactory Class


REXMaterialFactory.CompareRows Method

REXMaterialFactory.CompareRows Method
REXMaterialFactory Class REX.ContentGenerator.Converters Namespace REXMaterialFactory Class

This is CompareRows, a member of class REXMaterialFactory.

C#
public override bool CompareRows(bool certified, REXDescription ft, IDbRootLib.IDbTableRow row, IDbRootLib.DbDatabase db, Dictionary<string, int> ColumnDict);
Class

REXMaterialFactory Class

Links
REXMaterialFactory Class, REX.ContentGenerator.Converters Namespace, REXMaterialFactory Class


REXMaterialFactory.FillDBDescription Method

REXMaterialFactory.FillDBDescription Method
REXMaterialFactory Class REX.ContentGenerator.Converters Namespace REXMaterialFactory Class

This is FillDBDescription, a member of class REXMaterialFactory.

C#
public override void FillDBDescription(IDbRootLib.IDbDatabase db, IDbRootLib.IDbTableRow row, REXDBDescription desc, string dir, string dbname, bool recalc, int tableIndex, Dictionary<string, int> ColumnDict, bool forMapping);
Class

REXMaterialFactory Class

Links
REXMaterialFactory Class, REX.ContentGenerator.Converters Namespace, REXMaterialFactory Class


REXMaterialFactory.FillDBObjectCollection Method

REXMaterialFactory.FillDBObjectCollection Method
REXMaterialFactory Class REX.ContentGenerator.Converters Namespace REXMaterialFactory Class

This is FillDBObjectCollection, a member of class REXMaterialFactory.

C#
public override void FillDBObjectCollection(bool certified, REXDescription db, DTableDataObjectCollection dtdoc, out bool ok);
Class

REXMaterialFactory Class

Links
REXMaterialFactory Class, REX.ContentGenerator.Converters Namespace, REXMaterialFactory Class


REXMaterialFactory.FillFamilyTypeProperties Method (REXFamilyType, DTableDataObjectCollection, string, string)

REXMaterialFactory.FillFamilyTypeProperties Method (REXFamilyType, DTableDataObjectCollection, string, string)
REXMaterialFactory Class REX.ContentGenerator.Converters Namespace REXMaterialFactory Class

This is FillFamilyTypeProperties, a member of class REXMaterialFactory.

C#
public override void FillFamilyTypeProperties(REXFamilyType fam, DTableDataObjectCollection col, string path, string dbName);
Class

REXMaterialFactory Class

Links
REXMaterialFactory Class, REX.ContentGenerator.Converters Namespace, REXMaterialFactory Class


REXMaterialFactory.FillFamilyTypeProperties Method (REXFamilyType, IDbRootLib.IDbTableRow, string, string)

REXMaterialFactory.FillFamilyTypeProperties Method (REXFamilyType, IDbRootLib.IDbTableRow, string, string)
REXMaterialFactory Class REX.ContentGenerator.Converters Namespace REXMaterialFactory Class

This is FillFamilyTypeProperties, a member of class REXMaterialFactory.

C#
public override void FillFamilyTypeProperties(REXFamilyType fam, IDbRootLib.IDbTableRow row, string path, string dbName);
Class

REXMaterialFactory Class

Links
REXMaterialFactory Class, REX.ContentGenerator.Converters Namespace, REXMaterialFactory Class


REXMaterialFactory.GetAliasName Method

REXMaterialFactory.GetAliasName Method
REXMaterialFactory Class REX.ContentGenerator.Converters Namespace REXMaterialFactory Class

This is GetAliasName, a member of class REXMaterialFactory.

C#
public override bool GetAliasName(REXDBDescription DBdesc, out string type, out List<string> alias);
Class

REXMaterialFactory Class

Links
REXMaterialFactory Class, REX.ContentGenerator.Converters Namespace, REXMaterialFactory Class


REXMaterialFactory.GetFamiliesOfAlias Method

REXMaterialFactory.GetFamiliesOfAlias Method
REXMaterialFactory Class REX.ContentGenerator.Converters Namespace REXMaterialFactory Class

This is GetFamiliesOfAlias, a member of class REXMaterialFactory.

C#
public override List<REXFamilyType> GetFamiliesOfAlias(REX.ContentGenerator.Families.EElementType el, string alias, out bool found);
Class

REXMaterialFactory Class

Links
REXMaterialFactory Class, REX.ContentGenerator.Converters Namespace, REXMaterialFactory Class


REXMaterialFactory.GetFamilyDefault Method

REXMaterialFactory.GetFamilyDefault Method
REXMaterialFactory Class REX.ContentGenerator.Converters Namespace REXMaterialFactory Class

This is GetFamilyDefault, a member of class REXMaterialFactory.

C#
public override REXFamilyType GetFamilyDefault(REX.ContentGenerator.Families.EElementType el, EMaterial mat, string type);
Class

REXMaterialFactory Class

Links
REXMaterialFactory Class, REX.ContentGenerator.Converters Namespace, REXMaterialFactory Class


REXMaterialFactory.GetFamilyOfAlias Method

REXMaterialFactory.GetFamilyOfAlias Method
REXMaterialFactory Class REX.ContentGenerator.Converters Namespace REXMaterialFactory Class

This is GetFamilyOfAlias, a member of class REXMaterialFactory.

C#
public override REXFamilyType GetFamilyOfAlias(REX.ContentGenerator.Families.EElementType el, string alias, out bool found);
Class

REXMaterialFactory Class

Links
REXMaterialFactory Class, REX.ContentGenerator.Converters Namespace, REXMaterialFactory Class


REXMaterialFactory.GetFamilyTemplate Method

REXMaterialFactory.GetFamilyTemplate Method
REXMaterialFactory Class REX.ContentGenerator.Converters Namespace REXMaterialFactory Class

This is GetFamilyTemplate, a member of class REXMaterialFactory.

C#
public override REXFamilyType GetFamilyTemplate(REX.ContentGenerator.Families.EElementType el, EMaterial mat);
Class

REXMaterialFactory Class

Links
REXMaterialFactory Class, REX.ContentGenerator.Converters Namespace, REXMaterialFactory Class


REXMaterialFactory.GetMaterial Method

REXMaterialFactory.GetMaterial Method
REXMaterialFactory Class REX.ContentGenerator.Converters Namespace REXMaterialFactory Class

This is GetMaterial, a member of class REXMaterialFactory.

C#
public EMaterial GetMaterial(int i);
Class

REXMaterialFactory Class

Links
REXMaterialFactory Class, REX.ContentGenerator.Converters Namespace, REXMaterialFactory Class


REXMaterialFactory.GetNewDescription Method ()

REXMaterialFactory.GetNewDescription Method ()
REXMaterialFactory Class REX.ContentGenerator.Converters Namespace REXMaterialFactory Class

This is GetNewDescription, a member of class REXMaterialFactory.

C#
public override REXDBDescription GetNewDescription();
Class

REXMaterialFactory Class

Links
REXMaterialFactory Class, REX.ContentGenerator.Converters Namespace, REXMaterialFactory Class


REXMaterialFactory.GetNewDescription Method (string, string, DTableDataObjectCollection)

REXMaterialFactory.GetNewDescription Method (string, string, DTableDataObjectCollection)
REXMaterialFactory Class REX.ContentGenerator.Converters Namespace REXMaterialFactory Class

This is GetNewDescription, a member of class REXMaterialFactory.

C#
public override REXDBDescription GetNewDescription(string dir, string dbName, DTableDataObjectCollection objCol);
Class

REXMaterialFactory Class

Links
REXMaterialFactory Class, REX.ContentGenerator.Converters Namespace, REXMaterialFactory Class


REXMaterialFactory.GetNewFamily Method

REXMaterialFactory.GetNewFamily Method
REXMaterialFactory Class REX.ContentGenerator.Converters Namespace REXMaterialFactory Class

This is GetNewFamily, a member of class REXMaterialFactory.

C#
public override REXFamilyType GetNewFamily();
Class

REXMaterialFactory Class

Links
REXMaterialFactory Class, REX.ContentGenerator.Converters Namespace, REXMaterialFactory Class


REXMaterialFactory.GetPropertiesADO Method

REXMaterialFactory.GetPropertiesADO Method
REXMaterialFactory Class REX.ContentGenerator.Converters Namespace REXMaterialFactory Class

This is GetPropertiesADO, a member of class REXMaterialFactory.

C#
public override REXDBParams GetPropertiesADO(string dbpath, string dbname);
Class

REXMaterialFactory Class

Links
REXMaterialFactory Class, REX.ContentGenerator.Converters Namespace, REXMaterialFactory Class


REXMaterialFactory.GetPropertiesDBRoot Method

REXMaterialFactory.GetPropertiesDBRoot Method
REXMaterialFactory Class REX.ContentGenerator.Converters Namespace REXMaterialFactory Class

This is GetPropertiesDBRoot, a member of class REXMaterialFactory.

C#
public override REXDBParams GetPropertiesDBRoot(string dbpath, string dbname);
Class

REXMaterialFactory Class

Links
REXMaterialFactory Class, REX.ContentGenerator.Converters Namespace, REXMaterialFactory Class


REXMaterialFactory.RecalculatDBDesc Method

REXMaterialFactory.RecalculatDBDesc Method
REXMaterialFactory Class REX.ContentGenerator.Converters Namespace REXMaterialFactory Class

This is RecalculatDBDesc, a member of class REXMaterialFactory.

C#
public override void RecalculatDBDesc(REXDBDescription db, string DBPath, string DBName, bool fromInterface);
Class

REXMaterialFactory Class

Links
REXMaterialFactory Class, REX.ContentGenerator.Converters Namespace, REXMaterialFactory Class


REXMaterialFactory.ValidateDB Method (IDbRootLib.IDbDatabase)

REXMaterialFactory.ValidateDB Method (IDbRootLib.IDbDatabase)
REXMaterialFactory Class REX.ContentGenerator.Converters Namespace REXMaterialFactory Class

This is ValidateDB, a member of class REXMaterialFactory.

C#
public override bool ValidateDB(IDbRootLib.IDbDatabase db);
Class

REXMaterialFactory Class

Links
REXMaterialFactory Class, REX.ContentGenerator.Converters Namespace, REXMaterialFactory Class


REXMaterialFactory.ValidateDB Method (string)

REXMaterialFactory.ValidateDB Method (string)
REXMaterialFactory Class REX.ContentGenerator.Converters Namespace REXMaterialFactory Class

This is ValidateDB, a member of class REXMaterialFactory.

C#
public override bool ValidateDB(string dbName);
Class

REXMaterialFactory Class

Links
REXMaterialFactory Class, REX.ContentGenerator.Converters Namespace, REXMaterialFactory Class


REXParamSectionFactory Class

REXParamSectionFactory Class
REX.ContentGenerator.Converters Namespace Legend Members Public Methods REXParamSectionFactory Methods

This is class REX.ContentGenerator.Converters.REXParamSectionFactory.

Class Hierarchy
C#
public class REXParamSectionFactory : REXFamilyFactory;
Namespace

REX.ContentGenerator.Converters Namespace

Public Methods
Public Method | Description
REXParamSectionFactory | This is REXParamSectionFactory, a member of class REXParamSectionFactory.
REXParamSectionFactory Methods
REXParamSectionFactory Methods | Description
Close | This is Close, a member of class REXParamSectionFactory.
GetAliasName | This is GetAliasName, a member of class REXParamSectionFactory.
GetAllFamilies | This is GetAllFamilies, a member of class REXParamSectionFactory.
GetDBList | This is GetDBList, a member of class REXParamSectionFactory.
GetDBList | This is GetDBList, a member of class REXParamSectionFactory.
GetFamiliesOfAlias | This is GetFamiliesOfAlias, a member of class REXParamSectionFactory.
GetFamily | This is GetFamily, a member of class REXParamSectionFactory.
GetFamilyDefault | This is GetFamilyDefault, a member of class REXParamSectionFactory.
GetFamilyOfAlias | This is GetFamilyOfAlias, a member of class REXParamSectionFactory.
GetFamilyTemplate | This is GetFamilyTemplate, a member of class REXParamSectionFactory.
Links
REX.ContentGenerator.Converters Namespace, Legend, Members, Public Methods, REXParamSectionFactory Methods


REXParamSectionFactory.REXParamSectionFactory Constructor

REXParamSectionFactory.REXParamSectionFactory Constructor
REXParamSectionFactory Class REX.ContentGenerator.Converters Namespace REXParamSectionFactory Class

This is REXParamSectionFactory, a member of class REXParamSectionFactory.

C#
public REXParamSectionFactory(RexConversionSettings Settings);
Class

REXParamSectionFactory Class

Links
REXParamSectionFactory Class, REX.ContentGenerator.Converters Namespace, REXParamSectionFactory Class


REXParamSectionFactory.Close Method

REXParamSectionFactory.Close Method
REXParamSectionFactory Class REX.ContentGenerator.Converters Namespace REXParamSectionFactory Class

This is Close, a member of class REXParamSectionFactory.

C#
public override void Close();
Class

REXParamSectionFactory Class

Links
REXParamSectionFactory Class, REX.ContentGenerator.Converters Namespace, REXParamSectionFactory Class


REXParamSectionFactory.GetAliasName Method

REXParamSectionFactory.GetAliasName Method
REXParamSectionFactory Class REX.ContentGenerator.Converters Namespace REXParamSectionFactory Class

This is GetAliasName, a member of class REXParamSectionFactory.

C#
public override bool GetAliasName(REXDBDescription DBdesc, out string type, out List<string> alias);
Class

REXParamSectionFactory Class

Links
REXParamSectionFactory Class, REX.ContentGenerator.Converters Namespace, REXParamSectionFactory Class


REXParamSectionFactory.GetAllFamilies Method

REXParamSectionFactory.GetAllFamilies Method
REXParamSectionFactory Class REX.ContentGenerator.Converters Namespace REXParamSectionFactory Class

This is GetAllFamilies, a member of class REXParamSectionFactory.

C#
public override List<REXFamilyType> GetAllFamilies(string dir, string path, REXContentFilter filter, bool forMapping);
Class

REXParamSectionFactory Class

Links
REXParamSectionFactory Class, REX.ContentGenerator.Converters Namespace, REXParamSectionFactory Class


REXParamSectionFactory.GetDBList Method (List<REXFamilyType>, string, string)

REXParamSectionFactory.GetDBList Method (List<REXFamilyType>, string, string)
REXParamSectionFactory Class REX.ContentGenerator.Converters Namespace REXParamSectionFactory Class

This is GetDBList, a member of class REXParamSectionFactory.

C#
public override List<REXDBDescription> GetDBList(List<REXFamilyType> obj, string dbname, string dir);
Class

REXParamSectionFactory Class

Links
REXParamSectionFactory Class, REX.ContentGenerator.Converters Namespace, REXParamSectionFactory Class


REXParamSectionFactory.GetDBList Method (REXFamilyType, string, string)

REXParamSectionFactory.GetDBList Method (REXFamilyType, string, string)
REXParamSectionFactory Class REX.ContentGenerator.Converters Namespace REXParamSectionFactory Class

This is GetDBList, a member of class REXParamSectionFactory.

C#
public override List<REXDBDescription> GetDBList(REXFamilyType obj, string dbname, string dir);
Class

REXParamSectionFactory Class

Links
REXParamSectionFactory Class, REX.ContentGenerator.Converters Namespace, REXParamSectionFactory Class


REXParamSectionFactory.GetFamiliesOfAlias Method

REXParamSectionFactory.GetFamiliesOfAlias Method
REXParamSectionFactory Class REX.ContentGenerator.Converters Namespace REXParamSectionFactory Class

This is GetFamiliesOfAlias, a member of class REXParamSectionFactory.

C#
public override List<REXFamilyType> GetFamiliesOfAlias(REX.ContentGenerator.Families.EElementType el, string alias, out bool found);
Class

REXParamSectionFactory Class

Links
REXParamSectionFactory Class, REX.ContentGenerator.Converters Namespace, REXParamSectionFactory Class


REXParamSectionFactory.GetFamily Method

REXParamSectionFactory.GetFamily Method
REXParamSectionFactory Class REX.ContentGenerator.Converters Namespace REXParamSectionFactory Class

This is GetFamily, a member of class REXParamSectionFactory.

C#
public override REXFamilyType GetFamily(REXDBDescription DBdesc, REX.ContentGenerator.Families.EElementType el, EMaterial mat);
Class

REXParamSectionFactory Class

Links
REXParamSectionFactory Class, REX.ContentGenerator.Converters Namespace, REXParamSectionFactory Class


REXParamSectionFactory.GetFamilyDefault Method

REXParamSectionFactory.GetFamilyDefault Method
REXParamSectionFactory Class REX.ContentGenerator.Converters Namespace REXParamSectionFactory Class

This is GetFamilyDefault, a member of class REXParamSectionFactory.

C#
public override REXFamilyType GetFamilyDefault(REX.ContentGenerator.Families.EElementType el, EMaterial mat, string type);
Class

REXParamSectionFactory Class

Links
REXParamSectionFactory Class, REX.ContentGenerator.Converters Namespace, REXParamSectionFactory Class


REXParamSectionFactory.GetFamilyOfAlias Method

REXParamSectionFactory.GetFamilyOfAlias Method
REXParamSectionFactory Class REX.ContentGenerator.Converters Namespace REXParamSectionFactory Class

This is GetFamilyOfAlias, a member of class REXParamSectionFactory.

C#
public override REXFamilyType GetFamilyOfAlias(REX.ContentGenerator.Families.EElementType el, string alias, out bool found);
Class

REXParamSectionFactory Class

Links
REXParamSectionFactory Class, REX.ContentGenerator.Converters Namespace, REXParamSectionFactory Class


REXParamSectionFactory.GetFamilyTemplate Method

REXParamSectionFactory.GetFamilyTemplate Method
REXParamSectionFactory Class REX.ContentGenerator.Converters Namespace REXParamSectionFactory Class

This is GetFamilyTemplate, a member of class REXParamSectionFactory.

C#
public override REXFamilyType GetFamilyTemplate(REX.ContentGenerator.Families.EElementType el, EMaterial mat);
Class

REXParamSectionFactory Class

Links
REXParamSectionFactory Class, REX.ContentGenerator.Converters Namespace, REXParamSectionFactory Class


RVTCommonSectionFactory Class

RVTCommonSectionFactory Class
REX.ContentGenerator.Converters Namespace Legend Members Public Methods RVTCommonSectionFactory Methods

This is class REX.ContentGenerator.Converters.RVTCommonSectionFactory.

Class Hierarchy
C#
public class RVTCommonSectionFactory : RVTFamilyFactory;
Namespace

REX.ContentGenerator.Converters Namespace

Public Methods
Public Method | Description
RVTCommonSectionFactory | This is RVTCommonSectionFactory, a member of class RVTCommonSectionFactory.
RVTCommonSectionFactory Methods
RVTCommonSectionFactory Methods | Description
AddElement2FamList | This is AddElement2FamList, a member of class RVTCommonSectionFactory.
AddElement2FamList | This is AddElement2FamList, a member of class RVTCommonSectionFactory.
GetElement4ParamIdentity | This is GetElement4ParamIdentity, a member of class RVTCommonSectionFactory.
GetExistingNames | This is GetExistingNames, a member of class RVTCommonSectionFactory.
GetName4Mapping | This is GetName4Mapping, a member of class RVTCommonSectionFactory.
GetRevitTypesForInit | This is GetRevitTypesForInit, a member of class RVTCommonSectionFactory.
OnClose | This is OnClose, a member of class RVTCommonSectionFactory.
Recalculate | This is Recalculate, a member of class RVTCommonSectionFactory.
ValidateElement | This is ValidateElement, a member of class RVTCommonSectionFactory.
Links
REX.ContentGenerator.Converters Namespace, Legend, Members, Public Methods, RVTCommonSectionFactory Methods


RVTCommonSectionFactory.RVTCommonSectionFactory Constructor

RVTCommonSectionFactory.RVTCommonSectionFactory Constructor
RVTCommonSectionFactory Class REX.ContentGenerator.Converters Namespace RVTCommonSectionFactory Class

This is RVTCommonSectionFactory, a member of class RVTCommonSectionFactory.

C#
public RVTCommonSectionFactory(RvtConversionSettings Settings, CompositeLevel Fams);
Class

RVTCommonSectionFactory Class

Links
RVTCommonSectionFactory Class, REX.ContentGenerator.Converters Namespace, RVTCommonSectionFactory Class


RVTCommonSectionFactory.AddElement2FamList Method (Autodesk.Revit.DB.Element)

RVTCommonSectionFactory.AddElement2FamList Method (Autodesk.Revit.DB.Element)
RVTCommonSectionFactory Class REX.ContentGenerator.Converters Namespace RVTCommonSectionFactory Class

This is AddElement2FamList, a member of class RVTCommonSectionFactory.

C#
public override bool AddElement2FamList(Autodesk.Revit.DB.Element el);
Class

RVTCommonSectionFactory Class

Links
RVTCommonSectionFactory Class, REX.ContentGenerator.Converters Namespace, RVTCommonSectionFactory Class


RVTCommonSectionFactory.AddElement2FamList Method (Autodesk.Revit.DB.Element, REXFamilyType, bool)

RVTCommonSectionFactory.AddElement2FamList Method (Autodesk.Revit.DB.Element, REXFamilyType, bool)
RVTCommonSectionFactory Class REX.ContentGenerator.Converters Namespace RVTCommonSectionFactory Class

This is AddElement2FamList, a member of class RVTCommonSectionFactory.

C#
public override bool AddElement2FamList(Autodesk.Revit.DB.Element el, REXFamilyType ft, bool addToDict);
Class

RVTCommonSectionFactory Class

Links
RVTCommonSectionFactory Class, REX.ContentGenerator.Converters Namespace, RVTCommonSectionFactory Class


RVTCommonSectionFactory.GetElement4ParamIdentity Method

RVTCommonSectionFactory.GetElement4ParamIdentity Method
RVTCommonSectionFactory Class REX.ContentGenerator.Converters Namespace RVTCommonSectionFactory Class

This is GetElement4ParamIdentity, a member of class RVTCommonSectionFactory.

C#
public override RevitElement GetElement4ParamIdentity(RevitElement el);
Class

RVTCommonSectionFactory Class

Links
RVTCommonSectionFactory Class, REX.ContentGenerator.Converters Namespace, RVTCommonSectionFactory Class


RVTCommonSectionFactory.GetExistingNames Method

RVTCommonSectionFactory.GetExistingNames Method
RVTCommonSectionFactory Class REX.ContentGenerator.Converters Namespace RVTCommonSectionFactory Class

This is GetExistingNames, a member of class RVTCommonSectionFactory.

C#
public override List<string> GetExistingNames(REXFamilyType obj, bool type);
Class

RVTCommonSectionFactory Class

Links
RVTCommonSectionFactory Class, REX.ContentGenerator.Converters Namespace, RVTCommonSectionFactory Class


RVTCommonSectionFactory.GetName4Mapping Method

RVTCommonSectionFactory.GetName4Mapping Method
RVTCommonSectionFactory Class REX.ContentGenerator.Converters Namespace RVTCommonSectionFactory Class

This is GetName4Mapping, a member of class RVTCommonSectionFactory.

C#
public override string GetName4Mapping(Autodesk.Revit.DB.Element elem);
Class

RVTCommonSectionFactory Class

Links
RVTCommonSectionFactory Class, REX.ContentGenerator.Converters Namespace, RVTCommonSectionFactory Class


RVTCommonSectionFactory.GetRevitTypesForInit Method

RVTCommonSectionFactory.GetRevitTypesForInit Method
RVTCommonSectionFactory Class REX.ContentGenerator.Converters Namespace RVTCommonSectionFactory Class

This is GetRevitTypesForInit, a member of class RVTCommonSectionFactory.

C#
public override Type[] GetRevitTypesForInit();
Class

RVTCommonSectionFactory Class

Links
RVTCommonSectionFactory Class, REX.ContentGenerator.Converters Namespace, RVTCommonSectionFactory Class


RVTCommonSectionFactory.OnClose Method

RVTCommonSectionFactory.OnClose Method
RVTCommonSectionFactory Class REX.ContentGenerator.Converters Namespace RVTCommonSectionFactory Class

This is OnClose, a member of class RVTCommonSectionFactory.

C#
public override bool OnClose();
Class

RVTCommonSectionFactory Class

Links
RVTCommonSectionFactory Class, REX.ContentGenerator.Converters Namespace, RVTCommonSectionFactory Class


RVTCommonSectionFactory.Recalculate Method

RVTCommonSectionFactory.Recalculate Method
RVTCommonSectionFactory Class REX.ContentGenerator.Converters Namespace RVTCommonSectionFactory Class

This is Recalculate, a member of class RVTCommonSectionFactory.

C#
public override REXDescription Recalculate(REXDescription DBdesc, bool fromInterface, ECategoryType category, bool create_new);
Class

RVTCommonSectionFactory Class

Links
RVTCommonSectionFactory Class, REX.ContentGenerator.Converters Namespace, RVTCommonSectionFactory Class


RVTCommonSectionFactory.ValidateElement Method

RVTCommonSectionFactory.ValidateElement Method
RVTCommonSectionFactory Class REX.ContentGenerator.Converters Namespace RVTCommonSectionFactory Class

This is ValidateElement, a member of class RVTCommonSectionFactory.

C#
public override bool ValidateElement(RevitElement el);
Class

RVTCommonSectionFactory Class

Links
RVTCommonSectionFactory Class, REX.ContentGenerator.Converters Namespace, RVTCommonSectionFactory Class


RVTCustomFactory Class

RVTCustomFactory Class
REX.ContentGenerator.Converters Namespace Legend Members Public Methods RVTCustomFactory Methods

This is class REX.ContentGenerator.Converters.RVTCustomFactory.

Class Hierarchy
C#
public class RVTCustomFactory<T_REXFamilyType, T_REXDescription> : RVTFamilyFactory where T_REXFamilyType : new() where T_REXDescription : new();
Namespace

REX.ContentGenerator.Converters Namespace

Public Methods
Public Method | Description
RVTCustomFactory | This is RVTCustomFactory, a member of class RVTCustomFactory.
RVTCustomFactory Methods
RVTCustomFactory Methods | Description
AddElement2FamList | This is AddElement2FamList, a member of class RVTCustomFactory.
AddElement2FamList | This is AddElement2FamList, a member of class RVTCustomFactory.
GetExistingNames | This is GetExistingNames, a member of class RVTCustomFactory.
GetRevitTypesForInit | This is GetRevitTypesForInit, a member of class RVTCustomFactory.
GetSubCategory | This is GetSubCategory, a member of class RVTCustomFactory.
Recalculate | This is Recalculate, a member of class RVTCustomFactory.
Recalculate | This is Recalculate, a member of class RVTCustomFactory.
ValidateElement | This is ValidateElement, a member of class RVTCustomFactory.
Links
REX.ContentGenerator.Converters Namespace, Legend, Members, Public Methods, RVTCustomFactory Methods


RVTCustomFactory.RVTCustomFactory Constructor

RVTCustomFactory.RVTCustomFactory Constructor
RVTCustomFactory Class REX.ContentGenerator.Converters Namespace RVTCustomFactory Class

This is RVTCustomFactory, a member of class RVTCustomFactory.

C#
public RVTCustomFactory(BuiltInCategory rvtCategory, string categoryName, RvtConversionSettings Settings);
Class

RVTCustomFactory Class

Links
RVTCustomFactory Class, REX.ContentGenerator.Converters Namespace, RVTCustomFactory Class


RVTCustomFactory.AddElement2FamList Method (Element)

RVTCustomFactory.AddElement2FamList Method (Element)
RVTCustomFactory Class REX.ContentGenerator.Converters Namespace RVTCustomFactory Class

This is AddElement2FamList, a member of class RVTCustomFactory.

C#
public override bool AddElement2FamList(Element el);
Class

RVTCustomFactory Class

Links
RVTCustomFactory Class, REX.ContentGenerator.Converters Namespace, RVTCustomFactory Class


RVTCustomFactory.AddElement2FamList Method (Element, REXFamilyType, bool)

RVTCustomFactory.AddElement2FamList Method (Element, REXFamilyType, bool)
RVTCustomFactory Class REX.ContentGenerator.Converters Namespace RVTCustomFactory Class

This is AddElement2FamList, a member of class RVTCustomFactory.

C#
public override bool AddElement2FamList(Element el, REXFamilyType ft, bool addToDict);
Class

RVTCustomFactory Class

Links
RVTCustomFactory Class, REX.ContentGenerator.Converters Namespace, RVTCustomFactory Class


RVTCustomFactory.GetExistingNames Method

RVTCustomFactory.GetExistingNames Method
RVTCustomFactory Class REX.ContentGenerator.Converters Namespace RVTCustomFactory Class

This is GetExistingNames, a member of class RVTCustomFactory.

C#
public override List<string> GetExistingNames(REXFamilyType obj, bool type);
Class

RVTCustomFactory Class

Links
RVTCustomFactory Class, REX.ContentGenerator.Converters Namespace, RVTCustomFactory Class


RVTCustomFactory.GetRevitTypesForInit Method

RVTCustomFactory.GetRevitTypesForInit Method
RVTCustomFactory Class REX.ContentGenerator.Converters Namespace RVTCustomFactory Class

This is GetRevitTypesForInit, a member of class RVTCustomFactory.

C#
public override Type[] GetRevitTypesForInit();
Class

RVTCustomFactory Class

Links
RVTCustomFactory Class, REX.ContentGenerator.Converters Namespace, RVTCustomFactory Class


RVTCustomFactory.GetSubCategory Method

RVTCustomFactory.GetSubCategory Method
RVTCustomFactory Class REX.ContentGenerator.Converters Namespace RVTCustomFactory Class

This is GetSubCategory, a member of class RVTCustomFactory.

C#
public override string GetSubCategory();
Class

RVTCustomFactory Class

Links
RVTCustomFactory Class, REX.ContentGenerator.Converters Namespace, RVTCustomFactory Class


RVTCustomFactory.Recalculate Method (REXDescription, bool, ECategoryType, bool)

RVTCustomFactory.Recalculate Method (REXDescription, bool, ECategoryType, bool)
RVTCustomFactory Class REX.ContentGenerator.Converters Namespace RVTCustomFactory Class

This is Recalculate, a member of class RVTCustomFactory.

C#
public override REXDescription Recalculate(REXDescription description, bool fromInterface, ECategoryType category, bool create_new);
Class

RVTCustomFactory Class

Links
RVTCustomFactory Class, REX.ContentGenerator.Converters Namespace, RVTCustomFactory Class


RVTCustomFactory.Recalculate Method (REXDescription, bool, ECategoryType, bool, string)

RVTCustomFactory.Recalculate Method (REXDescription, bool, ECategoryType, bool, string)
RVTCustomFactory Class REX.ContentGenerator.Converters Namespace RVTCustomFactory Class

This is Recalculate, a member of class RVTCustomFactory.

C#
public REXDescription Recalculate(REXDescription description, bool fromInterface, ECategoryType category, bool create_new, string root);
Class

RVTCustomFactory Class

Links
RVTCustomFactory Class, REX.ContentGenerator.Converters Namespace, RVTCustomFactory Class


RVTCustomFactory.ValidateElement Method

RVTCustomFactory.ValidateElement Method
RVTCustomFactory Class REX.ContentGenerator.Converters Namespace RVTCustomFactory Class

This is ValidateElement, a member of class RVTCustomFactory.

C#
public override bool ValidateElement(Element el);
Class

RVTCustomFactory Class

Links
RVTCustomFactory Class, REX.ContentGenerator.Converters Namespace, RVTCustomFactory Class


RVTDBSectionFactory Class

RVTDBSectionFactory Class
REX.ContentGenerator.Converters Namespace Legend Members Public Methods RVTDBSectionFactory Methods

This is class REX.ContentGenerator.Converters.RVTDBSectionFactory.

Class Hierarchy
C#
public class RVTDBSectionFactory : RVTCommonSectionFactory;
Namespace

REX.ContentGenerator.Converters Namespace

Public Methods
Public Method | Description
RVTDBSectionFactory | This is RVTDBSectionFactory, a member of class RVTDBSectionFactory.
RVTDBSectionFactory Methods
RVTDBSectionFactory Methods | Description
IsElementSupported | This is IsElementSupported, a member of class RVTDBSectionFactory.
Recalculate | This is Recalculate, a member of class RVTDBSectionFactory.
Links
REX.ContentGenerator.Converters Namespace, Legend, Members, Public Methods, RVTDBSectionFactory Methods


RVTDBSectionFactory.RVTDBSectionFactory Constructor

RVTDBSectionFactory.RVTDBSectionFactory Constructor
RVTDBSectionFactory Class REX.ContentGenerator.Converters Namespace RVTDBSectionFactory Class

This is RVTDBSectionFactory, a member of class RVTDBSectionFactory.

C#
public RVTDBSectionFactory(RvtConversionSettings Settings, CompositeLevel Families);
Class

RVTDBSectionFactory Class

Links
RVTDBSectionFactory Class, REX.ContentGenerator.Converters Namespace, RVTDBSectionFactory Class


RVTDBSectionFactory.IsElementSupported Method

RVTDBSectionFactory.IsElementSupported Method
RVTDBSectionFactory Class REX.ContentGenerator.Converters Namespace RVTDBSectionFactory Class

This is IsElementSupported, a member of class RVTDBSectionFactory.

C#
public override bool IsElementSupported(REXFamilyType fam, ECategoryType category);
Class

RVTDBSectionFactory Class

Links
RVTDBSectionFactory Class, REX.ContentGenerator.Converters Namespace, RVTDBSectionFactory Class


RVTDBSectionFactory.Recalculate Method

RVTDBSectionFactory.Recalculate Method
RVTDBSectionFactory Class REX.ContentGenerator.Converters Namespace RVTDBSectionFactory Class

This is Recalculate, a member of class RVTDBSectionFactory.

C#
public override REXDescription Recalculate(REXDescription DBdesc, bool fromInterface, ECategoryType category, bool create_new);
Class

RVTDBSectionFactory Class

Links
RVTDBSectionFactory Class, REX.ContentGenerator.Converters Namespace, RVTDBSectionFactory Class


RVTFamilyConverter Class

RVTFamilyConverter Class
REX.ContentGenerator.Converters Namespace Legend Members Public Methods RVTFamilyConverter Events RVTFamilyConverter Methods RVTFamilyConverter Properties

This class represents a converter which provides access to Revit project.

Class Hierarchy
C#
public class RVTFamilyConverter : IMapConverter;
Description

It allows user to generate objects as well as read them.

Namespace

REX.ContentGenerator.Converters Namespace

Public Methods
Public Method | Description
RVTFamilyConverter | Initializes a new instance of the RVTFamilyConverter class.
RVTFamilyConverter | Initializes a new instance of the RVTFamilyConverter class.
RVTFamilyConverter Events
RVTFamilyConverter Events | Description
EventElementGenerated | Occurs when element is generated (when the list of elements is used).
RVTFamilyConverter Methods
RVTFamilyConverter Methods | Description
Close | Saves data to the Revit document, clears collections, releases objects.
CreateRebar | Creates the rebar element based on the input REXFamilyType_Rebar object.
GetCertifiedCategoryOfElement | Gets category of the certified element.
GetElement | Gets the Revit element created based on the REXFamilyType object.
GetElement | Gets the Revit element created based on the REXFamilyType object.
GetElement | Gets the Revit element created based on the REXFamilyType object.
GetElements | Gets the list of Revit elements created based on the list of REXFamilyTypes.
GetExistingNames | Returns the list of names existing for specific REXFamilyType object.
GetFamily | Gets the REXFamilyType object based on the input element.
GetFamily | Gets the REXFamilyType object based on the input element.
GetFamily | Gets the REXFamilyType object based on the input element.
GetRebarContour | Gets the rebar's contour based on the Revit element.
InitGlobal | Initializes lists of existing families from the Active Document.
IsElementSupported | This is IsElementSupported, a member of class RVTFamilyConverter.
RegisterCustomFactory | Registers the custom factory.
Temporary | This is Temporary, a member of class RVTFamilyConverter.
RVTFamilyConverter Properties
RVTFamilyConverter Properties | Description
ContentMapper | Gets the mapper object.
Settings | Gets the settings.
Links
REX.ContentGenerator.Converters Namespace, Legend, Members, Public Methods, RVTFamilyConverter Events, RVTFamilyConverter Methods, RVTFamilyConverter Properties


RVTFamilyConverter.RVTFamilyConverter Constructor (Autodesk.Revit.UI.ExternalCommandData, bool)

RVTFamilyConverter.RVTFamilyConverter Constructor (Autodesk.Revit.UI.ExternalCommandData, bool)
RVTFamilyConverter Class REX.ContentGenerator.Converters Namespace RVTFamilyConverter Class

Initializes a new instance of the RVTFamilyConverter class.

C#
public RVTFamilyConverter(Autodesk.Revit.UI.ExternalCommandData commandData, bool initialize);
Parameters
Parameters | Description
commandData | The Revit Application handler.
initialize | Indicates whether internal lists of families are to be filled. If set to false existing items won't be taken to considaration during generation and it is necessarry to call InitGlobal method to fill them up.
Description
Class

RVTFamilyConverter Class

Links
RVTFamilyConverter Class, REX.ContentGenerator.Converters Namespace, RVTFamilyConverter Class


RVTFamilyConverter.RVTFamilyConverter Constructor (Document, bool)

RVTFamilyConverter.RVTFamilyConverter Constructor (Document, bool)
RVTFamilyConverter Class REX.ContentGenerator.Converters Namespace RVTFamilyConverter Class

Initializes a new instance of the RVTFamilyConverter class.

C#
public RVTFamilyConverter(Document doc, bool initialize);
Parameters
Parameters | Description
doc | The Revit document.
initialize | Indicates whether internal lists of families are to be filled. If set to false existing items won't be taken to considaration during generation and it is necessarry to call InitGlobal method to fill them up.
Description
Class

RVTFamilyConverter Class

Links
RVTFamilyConverter Class, REX.ContentGenerator.Converters Namespace, RVTFamilyConverter Class


RVTFamilyConverter.Close Method

RVTFamilyConverter.Close Method
RVTFamilyConverter Class REX.ContentGenerator.Converters Namespace RVTFamilyConverter Class

Saves data to the Revit document, clears collections, releases objects.

C#
public void Close();
Description
Remarks

It should be obligatory called before the end of the converter usage.

Class

RVTFamilyConverter Class

Links
RVTFamilyConverter Class, REX.ContentGenerator.Converters Namespace, RVTFamilyConverter Class


RVTFamilyConverter.CreateRebar Method

RVTFamilyConverter.CreateRebar Method
RVTFamilyConverter Class REX.ContentGenerator.Converters Namespace Example RVTFamilyConverter Class

Creates the rebar element based on the input REXFamilyType_Rebar object.

C#
public Rebar CreateRebar(REXFamilyType_Rebar rebar, RevitElement host);
Parameters
Parameters | Description
rebar | The REXFamilyType_Rebar object.
host | The host of a rebar.
Returns

The new Revit rebar.

Description
Example

The example shows how to get the rebar element in Revit based on specific shape from the database.

//Initializing converters.
REXFamilyConverter rex = new REXFamilyConverter();//Needed for proper rebar description.
RVTFamilyConverter rvt = new RVTFamilyConverter(commandData, true);

//The RebarType taken from the Revit project (the first one on the list).
System.Collections.IEnumerator it = commandData.Application.ActiveUIDocument.Document.RebarBarTypes.GetEnumerator();
it.MoveNext();
RebarBarType RevitRebarBarType = (RebarBarType)it.Current;
REXFamilyType_RebarBarType rbt = (REXFamilyType_RebarBarType)rvt.GetFamily(RevitRebarBarType);
//Using Element property to use particular element as RebarType.
rbt.Element=RevitRebarBarType;

//The RebarHook taken from the Revit project (the first one on the list).
it = commandData.Application.ActiveUIDocument.Document.RebarHookTypes.GetEnumerator();
it.MoveNext();
RebarHookType RevitRebarHookType = (RebarHookType)it.Current;
REXFamilyType_RebarHook rht = (REXFamilyType_RebarHook)rvt.GetFamily(RevitRebarHookType);
//Using Element property to use particular element as RebarType.
rht.Element = RevitRebarHookType;

//defining contour
List<REX.Common.Geometry.REXxyz> l = new List<REX.Common.Geometry.REXxyz>();

l.Add(new REX.Common.Geometry.REXxyz(0, 0));
l.Add(new REX.Common.Geometry.REXxyz(2, 0));

//Getting the rebar object.
REXFamilyType_Rebar r = rex.GetRebar(l, rbt,false,rht,rht,"barlib7_iso");

//Creating the rebar in Revit.
it = commandData.Application.ActiveUIDocument.Selection.Elements.GetEnumerator();
it.MoveNext();
Element host = (Element)it.Current;
Rebar RevitRebar = rvt.CreateRebar(r, host);

rvt.Close();//!!To clear structures and save data to the project.
Class

RVTFamilyConverter Class

Links
RVTFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, RVTFamilyConverter Class


RVTFamilyConverter.GetCertifiedCategoryOfElement Method

RVTFamilyConverter.GetCertifiedCategoryOfElement Method
RVTFamilyConverter Class REX.ContentGenerator.Converters Namespace Example RVTFamilyConverter Class

Gets category of the certified element.

C#
public ECategoryType GetCertifiedCategoryOfElement(RevitElement el);
Parameters
Parameters | Description
el | The Revit element.
Returns

The category of the element.

Description

If the element is not certified the UNKNOWN result will be returned.

Example

The example shows how to learn if some specific element is certified and get the category of it.

//Initializing the converter.
RVTFamilyConverter rvt = new RVTFamilyConverter(commandData, true);

//Iteration threw all rebars selected in Revit.
FilteredElementCollector filterCollector = new FilteredElementCollector(commandData.Application.ActiveUIDocument.Document);
foreach (Element el in filterCollector.WhereElementIsElementType())
{
    ECategoryType category = rvt.GetCertifiedCategoryOfElement(el);

    REXFamilyType familyType = null;

    if (category != ECategoryType.UNKNOWN)//certified
    {
           familyType = rvt.GetFamily(el, category);
    }
    else//not certified
    {
        if (el is RebarHookType)
        {
            familyType = rvt.GetFamily(el, ECategoryType.REBAR_HOOK);
        }
        else if(el is RebarBarType)
        {
            familyType = rvt.GetFamily(el, ECategoryType.REBAR_BARTYPE);
        }
        else if (el is RebarShape)
        {
            familyType = rvt.GetFamily(el, ECategoryType.REBAR_SHAPE);
        }
        else if (el is FamilyInstance)
       {
            familyType = rvt.GetFamily(el, ECategoryType.SECTION_PARAM);
        }
    }
}
Class

RVTFamilyConverter Class

Links
RVTFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, RVTFamilyConverter Class


RVTFamilyConverter.GetElement Method (REXFamilyType)

RVTFamilyConverter.GetElement Method (REXFamilyType)
RVTFamilyConverter Class REX.ContentGenerator.Converters Namespace Example RVTFamilyConverter Class

Gets the Revit element created based on the REXFamilyType object.

C#
public RevitElement GetElement(REXFamilyType el);
Parameters
Parameters | Description
el | The REXFamilyType object.
Returns

The Revit element.

Description
Example

The example shows how to get Revit element bases on the REXFamilyType object.

//Initialize the converter.
RVTFamilyConverter rvt = new RVTFamilyConverter(commandData, true);

//creating parametric description
REXFamilyType_ParamSection paramSection = new REXFamilyType_ParamSection();
paramSection.ElementType = REX.ContentGenerator.Families.EElementType.BEAM;
paramSection.Material = EMaterial.CONCRETE;

//seting parameters
paramSection.Parameters.SectionType = ESectionType.RECT;
paramSection.Parameters.Tapered = false;
//setting dimensions
paramSection.Parameters.Dimensions.h = 0.3;
paramSection.Parameters.Dimensions.b = 0.2;
paramSection.Parameters.CalculataMainAxisAndCharacteristics();
paramSection.TypeName = "RECT1";

//getting Revit element
Element el = rvt.GetElement(paramSection);
FamilySymbol fs = el as FamilySymbol;
Class

RVTFamilyConverter Class

Links
RVTFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, RVTFamilyConverter Class


RVTFamilyConverter.GetElement Method (REXFamilyType, ECategoryType)

RVTFamilyConverter.GetElement Method (REXFamilyType, ECategoryType)
RVTFamilyConverter Class REX.ContentGenerator.Converters Namespace Example RVTFamilyConverter Class

Gets the Revit element created based on the REXFamilyType object.

C#
public RevitElement GetElement(REXFamilyType el, ECategoryType category);
Parameters
Parameters | Description
el | The REXFamilyType object.
category | The category of the element.
Returns

The Revit element.

Description
Example

The example shows how to get Revit element bases on the REXFamilyType object.

//Initialize the converter.
RVTFamilyConverter rvt = new RVTFamilyConverter(commandData, true);

//creating parametric description
REXFamilyType_ParamSection paramSection = new REXFamilyType_ParamSection();
paramSection.ElementType = REX.ContentGenerator.Families.EElementType.BEAM;
paramSection.Material = EMaterial.CONCRETE;

//seting parameters
paramSection.Parameters.SectionType = ESectionType.RECT;
paramSection.Parameters.Tapered = false;
//setting dimensions
paramSection.Parameters.Dimensions.h = 0.3;
paramSection.Parameters.Dimensions.b = 0.2;
paramSection.Parameters.CalculataMainAxisAndCharacteristics();
paramSection.TypeName = "RECT1";

//getting Revit element
Element el = rvt.GetElement(paramSection, ECategoryType.SECTION_PARAM);
FamilySymbol fs = el as FamilySymbol;
Class

RVTFamilyConverter Class

Links
RVTFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, RVTFamilyConverter Class


RVTFamilyConverter.GetElement Method (REXFamilyType_Custom, string)

RVTFamilyConverter.GetElement Method (REXFamilyType_Custom, string)
RVTFamilyConverter Class REX.ContentGenerator.Converters Namespace RVTFamilyConverter Class

Gets the Revit element created based on the REXFamilyType object.

C#
public RevitElement GetElement(REXFamilyType_Custom el, string customCategory);
Parameters
Parameters | Description
el | The REXFamilyType object.
customCategory | The custom category.
Returns

The Revit element.

Description
Class

RVTFamilyConverter Class

Links
RVTFamilyConverter Class, REX.ContentGenerator.Converters Namespace, RVTFamilyConverter Class


RVTFamilyConverter.GetElements Method

RVTFamilyConverter.GetElements Method
RVTFamilyConverter Class REX.ContentGenerator.Converters Namespace Example RVTFamilyConverter Class

Gets the list of Revit elements created based on the list of REXFamilyTypes.

C#
public List<RevitElement> GetElements(List<REXFamilyType> list, ECategoryType category);
Parameters
Parameters | Description
list | The list of REXFamilyTypes.
category | The category of elements.
Returns

The list of Revit elements.

Description
Example

The example shows how to get the list of Revit elements based on the list of the REXFamilyType.

//Initialize the converter.
RVTFamilyConverter rvt = new RVTFamilyConverter(commandData, true);

rvt.EventElementGenerated += new ElementGenerated(rvt_EventElementGenerated);

List<REXFamilyType> families = new List<REXFamilyType>();

for (int i = 1; i < 4; i++)
{
    //creating parametric description
    REXFamilyType_ParamSection paramSection = new REXFamilyType_ParamSection();
    paramSection.ElementType = REX.ContentGenerator.Families.EElementType.BEAM;
    paramSection.Material = EMaterial.CONCRETE;
    paramSection.Parameters.SectionType = ESectionType.RECT;
    paramSection.Parameters.Tapered = false;
    paramSection.Parameters.Dimensions.h = i*0.2;
    paramSection.Parameters.Dimensions.b = i*0.1;
    paramSection.Parameters.CalculataMainAxisAndCharacteristics();
    paramSection.TypeName = "RECT" + i.ToString();
    families.Add(paramSection);
}

List<Element> elements = rvt.GetElements(families, ECategoryType.SECTION_PARAM);

static void rvt_EventElementGenerated(string id)
{
}
Class

RVTFamilyConverter Class

Links
RVTFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, RVTFamilyConverter Class


RVTFamilyConverter.GetExistingNames Method

RVTFamilyConverter.GetExistingNames Method
RVTFamilyConverter Class REX.ContentGenerator.Converters Namespace RVTFamilyConverter Class

Returns the list of names existing for specific REXFamilyType object.

C#
public List<string> GetExistingNames(REXFamilyType el, ECategoryType category, bool typeNames);
Parameters
Parameters | Description
el | The REXFamilyType object.
category | The category of the element.
typeNames | If names of types should be returned.
Returns

The list of names.

Description
Class

RVTFamilyConverter Class

Links
RVTFamilyConverter Class, REX.ContentGenerator.Converters Namespace, RVTFamilyConverter Class


RVTFamilyConverter.GetFamily Method (RevitElement)

RVTFamilyConverter.GetFamily Method (RevitElement)
RVTFamilyConverter Class REX.ContentGenerator.Converters Namespace Example RVTFamilyConverter Class

Gets the REXFamilyType object based on the input element.

C#
public REXFamilyType GetFamily(RevitElement el);
Parameters
Parameters | Description
el | The Revit element.
Returns

The REXFamilyType object.

Description
Example

The example shows how to get REXFamilyType from the element defined in Revit.

//Initializing the converter.
RVTFamilyConverter rvt = new RVTFamilyConverter(commandData, true);

//Investigation of selected FamilyInstances
foreach(Element el in commandData.Application.ActiveUIDocument.Selection.Elements)
{
    FamilyInstance famInstance = el as FamilyInstance;

    if (famInstance != null
       && (famInstance.StructuralType == Autodesk.Revit.DB.Structure.StructuralType.Beam
       || famInstance.StructuralType == Autodesk.Revit.DB.Structure.StructuralType.Brace
       || famInstance.StructuralType == Autodesk.Revit.DB.Structure.StructuralType.Column))
    {
        //Geting REXFamilyType object from the current element.
        REXFamilyType fam = rvt.GetFamily(famInstance);

        if (fam != null)
        {
            //parametric section
            REXFamilyType_ParamSection paramSection = fam as REXFamilyType_ParamSection;

            if (paramSection != null)
            {
                continue;
            }

            //database section
            REXFamilyType_DBSection dbSection = fam as REXFamilyType_DBSection;

            if (dbSection != null)
            {
               continue;
            }
        }
    }
}
Class

RVTFamilyConverter Class

Links
RVTFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, RVTFamilyConverter Class


RVTFamilyConverter.GetFamily Method (RevitElement, ECategoryType)

RVTFamilyConverter.GetFamily Method (RevitElement, ECategoryType)
RVTFamilyConverter Class REX.ContentGenerator.Converters Namespace Example RVTFamilyConverter Class

Gets the REXFamilyType object based on the input element.

C#
public REXFamilyType GetFamily(RevitElement el, ECategoryType category);
Parameters
Parameters | Description
el | The Revit element.
category | The category of the element.
Returns

The REXFamilyType object.

Description
Example

The example shows how to get REXFamilyType from the element defined in Revit.

//Initializing the converter.
RVTFamilyConverter rvt = new RVTFamilyConverter(commandData, true);

//Investigation of selected FamilyInstances
foreach(Element el in commandData.Application.ActiveUIDocument.Selection.Elements)
{
    FamilyInstance famInstance = el as FamilyInstance;

    if (famInstance != null
       && (famInstance.StructuralType == Autodesk.Revit.DB.Structure.StructuralType.Beam
       || famInstance.StructuralType == Autodesk.Revit.DB.Structure.StructuralType.Brace
       || famInstance.StructuralType == Autodesk.Revit.DB.Structure.StructuralType.Column))
    {
        //Geting REXFamilyType object from the current element.
        REXFamilyType fam = rvt.GetFamily(famInstance, ECategoryType.SECTION_PARAM);

        if (fam != null)
        {
            REXFamilyType_ParamSection paramSection = fam as REXFamilyType_ParamSection;
        }
    }
}
Class

RVTFamilyConverter Class

Links
RVTFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, RVTFamilyConverter Class


RVTFamilyConverter.GetFamily Method (RevitElement, string)

RVTFamilyConverter.GetFamily Method (RevitElement, string)
RVTFamilyConverter Class REX.ContentGenerator.Converters Namespace RVTFamilyConverter Class

Gets the REXFamilyType object based on the input element.

C#
public REXFamilyType GetFamily(RevitElement el, string customCategory);
Parameters
Parameters | Description
el | The Revit element.
customCategory | The custom category.
Returns

The REXFamilyType object.

Description
Class

RVTFamilyConverter Class

Links
RVTFamilyConverter Class, REX.ContentGenerator.Converters Namespace, RVTFamilyConverter Class


RVTFamilyConverter.GetRebarContour Method

RVTFamilyConverter.GetRebarContour Method
RVTFamilyConverter Class REX.ContentGenerator.Converters Namespace Example RVTFamilyConverter Class

Gets the rebar's contour based on the Revit element.

C#
public Contour_3D GetRebarContour(Rebar rebar, out REXxyz normal, out double spacing, out int count, out REXxyz distribution);
Parameters
Parameters | Description
rebar | The Revit rebar.
normal | The output normal of plane vector on which the rebar is defined.
spacing | The output spacing of the rebar.
count | The output number of subrebars.
distribution | The output distribution vector.
Returns

The contour of the rebar.

Description
Example

The example shows how to get a simplified rebar contour (without bending segments) from the Revit rebar.

//Initializing the converter.
RVTFamilyConverter rvt = new RVTFamilyConverter(commandData, true);

//Iteration threw all rebars selected in Revit.
foreach (Element el in commandData.Application.ActiveUIDocument.Selection.Elements)
{
    Rebar r = el as Rebar;

    if (r != null)
    {
        REX.Common.Geometry.REXxyz normal;
        REX.Common.Geometry.REXxyz distribution;
        double spacing;
        int count;

        REX.ContentGenerator.Geometry.Contour_3D cont3D = rvt.GetRebarContour(r, out normal, out spacing, out count, out distribution);
    }
}
Class

RVTFamilyConverter Class

Links
RVTFamilyConverter Class, REX.ContentGenerator.Converters Namespace, Example, RVTFamilyConverter Class


RVTFamilyConverter.InitGlobal Method

RVTFamilyConverter.InitGlobal Method
RVTFamilyConverter Class REX.ContentGenerator.Converters Namespace RVTFamilyConverter Class

Initializes lists of existing families from the Active Document.

C#
public void InitGlobal();
Description
Class

RVTFamilyConverter Class

Links
RVTFamilyConverter Class, REX.ContentGenerator.Converters Namespace, RVTFamilyConverter Class


RVTFamilyConverter.IsElementSupported Method

RVTFamilyConverter.IsElementSupported Method
RVTFamilyConverter Class REX.ContentGenerator.Converters Namespace RVTFamilyConverter Class

This is IsElementSupported, a member of class RVTFamilyConverter.

C#
public bool IsElementSupported(REXFamilyType fam, ECategoryType category);
Class

RVTFamilyConverter Class

Links
RVTFamilyConverter Class, REX.ContentGenerator.Converters Namespace, RVTFamilyConverter Class


RVTFamilyConverter.RegisterCustomFactory Method

RVTFamilyConverter.RegisterCustomFactory Method
RVTFamilyConverter Class REX.ContentGenerator.Converters Namespace RVTFamilyConverter Class

Registers the custom factory.

C#
public bool RegisterCustomFactory<T_REXFamilyType, T_REXDescription>(string name, string parametersFilePath, string templatesFilePath, string templatesDirectory, Autodesk.Revit.DB.BuiltInCategory category) where T_REXFamilyType : new() where T_REXDescription : new();
Parameters
Parameters | Description
name | The name of the custom category (it will be used for identification so it has to be unique and consistent).
parametersFilePath | The parameters file path.
templatesFilePath | The templates file path.
templatesDirectory | The templates directory.
category | The Revit elements category.
Type Parameters
Type Parameters | Description
T_REXFamilyType | The type of the custom family type.
T_REXDescription | The type of the custom description.
Returns

True if registration succeeded.

Description
Class

RVTFamilyConverter Class

Links
RVTFamilyConverter Class, REX.ContentGenerator.Converters Namespace, RVTFamilyConverter Class


RVTFamilyConverter.Temporary Method

RVTFamilyConverter.Temporary Method
RVTFamilyConverter Class REX.ContentGenerator.Converters Namespace RVTFamilyConverter Class

This is Temporary, a member of class RVTFamilyConverter.

C#
public void Temporary();
Class

RVTFamilyConverter Class

Links
RVTFamilyConverter Class, REX.ContentGenerator.Converters Namespace, RVTFamilyConverter Class


RVTFamilyConverter.ContentMapper Property

RVTFamilyConverter.ContentMapper Property
RVTFamilyConverter Class REX.ContentGenerator.Converters Namespace RVTFamilyConverter Class

Gets the mapper object.

C#
public RVTContentMapper ContentMapper;
Description

The mapper.

Class

RVTFamilyConverter Class

Links
RVTFamilyConverter Class, REX.ContentGenerator.Converters Namespace, RVTFamilyConverter Class


RVTFamilyConverter.Settings Property

RVTFamilyConverter.Settings Property
RVTFamilyConverter Class REX.ContentGenerator.Converters Namespace RVTFamilyConverter Class

Gets the settings.

C#
public IRvtContentSettings Settings;
Description

The settings.

Class

RVTFamilyConverter Class

Links
RVTFamilyConverter Class, REX.ContentGenerator.Converters Namespace, RVTFamilyConverter Class


RVTFamilyConverter.EventElementGenerated Event

RVTFamilyConverter.EventElementGenerated Event
RVTFamilyConverter Class REX.ContentGenerator.Converters Namespace RVTFamilyConverter Class

Occurs when element is generated (when the list of elements is used).

C#
public event ElementGenerated EventElementGenerated;
Description
Class

RVTFamilyConverter Class

Links
RVTFamilyConverter Class, REX.ContentGenerator.Converters Namespace, RVTFamilyConverter Class


RVTMaterialFactory Class

RVTMaterialFactory Class
REX.ContentGenerator.Converters Namespace Legend Members Public Methods RVTMaterialFactory Methods

This is class REX.ContentGenerator.Converters.RVTMaterialFactory.

Class Hierarchy
C#
public class RVTMaterialFactory : RVTFamilyFactory;
Namespace

REX.ContentGenerator.Converters Namespace

Public Methods
Public Method | Description
RVTMaterialFactory | This is RVTMaterialFactory, a member of class RVTMaterialFactory.
RVTMaterialFactory | This is RVTMaterialFactory, a member of class RVTMaterialFactory.
RVTMaterialFactory Methods
RVTMaterialFactory Methods | Description
AddElement2FamList | This is AddElement2FamList, a member of class RVTMaterialFactory.
AddElement2FamList | This is AddElement2FamList, a member of class RVTMaterialFactory.
CreateNewMaterial | This is CreateNewMaterial, a member of class RVTMaterialFactory.
GetExistingNames | This is GetExistingNames, a member of class RVTMaterialFactory.
GetMaterialTypeCompLevel | This is GetMaterialTypeCompLevel, a member of class RVTMaterialFactory.
GetRevitTypesForInit | This is GetRevitTypesForInit, a member of class RVTMaterialFactory.
InitList | This is InitList, a member of class RVTMaterialFactory.
OnClose | This is OnClose, a member of class RVTMaterialFactory.
Recalculate | This is Recalculate, a member of class RVTMaterialFactory.
ValidateElement | This is ValidateElement, a member of class RVTMaterialFactory.
Links
REX.ContentGenerator.Converters Namespace, Legend, Members, Public Methods, RVTMaterialFactory Methods


RVTMaterialFactory.RVTMaterialFactory Constructor ()

RVTMaterialFactory.RVTMaterialFactory Constructor ()
RVTMaterialFactory Class REX.ContentGenerator.Converters Namespace RVTMaterialFactory Class

This is RVTMaterialFactory, a member of class RVTMaterialFactory.

C#
public RVTMaterialFactory();
Class

RVTMaterialFactory Class

Links
RVTMaterialFactory Class, REX.ContentGenerator.Converters Namespace, RVTMaterialFactory Class


RVTMaterialFactory.RVTMaterialFactory Constructor (RvtConversionSettings, RVTMaterialPropertySetFactory)

RVTMaterialFactory.RVTMaterialFactory Constructor (RvtConversionSettings, RVTMaterialPropertySetFactory)
RVTMaterialFactory Class REX.ContentGenerator.Converters Namespace RVTMaterialFactory Class

This is RVTMaterialFactory, a member of class RVTMaterialFactory.

C#
public RVTMaterialFactory(RvtConversionSettings Settings, RVTMaterialPropertySetFactory propertySetFactory);
Class

RVTMaterialFactory Class

Links
RVTMaterialFactory Class, REX.ContentGenerator.Converters Namespace, RVTMaterialFactory Class


RVTMaterialFactory.AddElement2FamList Method (Autodesk.Revit.DB.Element)

RVTMaterialFactory.AddElement2FamList Method (Autodesk.Revit.DB.Element)
RVTMaterialFactory Class REX.ContentGenerator.Converters Namespace RVTMaterialFactory Class

This is AddElement2FamList, a member of class RVTMaterialFactory.

C#
public override bool AddElement2FamList(Autodesk.Revit.DB.Element el);
Class

RVTMaterialFactory Class

Links
RVTMaterialFactory Class, REX.ContentGenerator.Converters Namespace, RVTMaterialFactory Class


RVTMaterialFactory.AddElement2FamList Method (Autodesk.Revit.DB.Element, REXFamilyType, bool)

RVTMaterialFactory.AddElement2FamList Method (Autodesk.Revit.DB.Element, REXFamilyType, bool)
RVTMaterialFactory Class REX.ContentGenerator.Converters Namespace RVTMaterialFactory Class

This is AddElement2FamList, a member of class RVTMaterialFactory.

C#
public override bool AddElement2FamList(Autodesk.Revit.DB.Element el, REXFamilyType ft, bool addToDict);
Class

RVTMaterialFactory Class

Links
RVTMaterialFactory Class, REX.ContentGenerator.Converters Namespace, RVTMaterialFactory Class


RVTMaterialFactory.CreateNewMaterial Method

RVTMaterialFactory.CreateNewMaterial Method
RVTMaterialFactory Class REX.ContentGenerator.Converters Namespace RVTMaterialFactory Class

This is CreateNewMaterial, a member of class RVTMaterialFactory.

C#
public Material CreateNewMaterial(EMaterial mat, string name);
Class

RVTMaterialFactory Class

Links
RVTMaterialFactory Class, REX.ContentGenerator.Converters Namespace, RVTMaterialFactory Class


RVTMaterialFactory.GetExistingNames Method

RVTMaterialFactory.GetExistingNames Method
RVTMaterialFactory Class REX.ContentGenerator.Converters Namespace RVTMaterialFactory Class

This is GetExistingNames, a member of class RVTMaterialFactory.

C#
public override List<string> GetExistingNames(REXFamilyType obj, bool type);
Class

RVTMaterialFactory Class

Links
RVTMaterialFactory Class, REX.ContentGenerator.Converters Namespace, RVTMaterialFactory Class


RVTMaterialFactory.GetMaterialTypeCompLevel Method

RVTMaterialFactory.GetMaterialTypeCompLevel Method
RVTMaterialFactory Class REX.ContentGenerator.Converters Namespace RVTMaterialFactory Class

This is GetMaterialTypeCompLevel, a member of class RVTMaterialFactory.

C#
public CompositeLevel GetMaterialTypeCompLevel(EMaterial mat);
Class

RVTMaterialFactory Class

Links
RVTMaterialFactory Class, REX.ContentGenerator.Converters Namespace, RVTMaterialFactory Class


RVTMaterialFactory.GetRevitTypesForInit Method

RVTMaterialFactory.GetRevitTypesForInit Method
RVTMaterialFactory Class REX.ContentGenerator.Converters Namespace RVTMaterialFactory Class

This is GetRevitTypesForInit, a member of class RVTMaterialFactory.

C#
public override Type[] GetRevitTypesForInit();
Class

RVTMaterialFactory Class

Links
RVTMaterialFactory Class, REX.ContentGenerator.Converters Namespace, RVTMaterialFactory Class


RVTMaterialFactory.InitList Method

RVTMaterialFactory.InitList Method
RVTMaterialFactory Class REX.ContentGenerator.Converters Namespace RVTMaterialFactory Class

This is InitList, a member of class RVTMaterialFactory.

C#
public override void InitList();
Class

RVTMaterialFactory Class

Links
RVTMaterialFactory Class, REX.ContentGenerator.Converters Namespace, RVTMaterialFactory Class


RVTMaterialFactory.OnClose Method

RVTMaterialFactory.OnClose Method
RVTMaterialFactory Class REX.ContentGenerator.Converters Namespace RVTMaterialFactory Class

This is OnClose, a member of class RVTMaterialFactory.

C#
public override bool OnClose();
Class

RVTMaterialFactory Class

Links
RVTMaterialFactory Class, REX.ContentGenerator.Converters Namespace, RVTMaterialFactory Class


RVTMaterialFactory.Recalculate Method

RVTMaterialFactory.Recalculate Method
RVTMaterialFactory Class REX.ContentGenerator.Converters Namespace RVTMaterialFactory Class

This is Recalculate, a member of class RVTMaterialFactory.

C#
public override REXDescription Recalculate(REXDescription DBdesc, bool fromInterface, ECategoryType category, bool create_new);
Class

RVTMaterialFactory Class

Links
RVTMaterialFactory Class, REX.ContentGenerator.Converters Namespace, RVTMaterialFactory Class


RVTMaterialFactory.ValidateElement Method

RVTMaterialFactory.ValidateElement Method
RVTMaterialFactory Class REX.ContentGenerator.Converters Namespace RVTMaterialFactory Class

This is ValidateElement, a member of class RVTMaterialFactory.

C#
public override bool ValidateElement(RevitElement el);
Class

RVTMaterialFactory Class

Links
RVTMaterialFactory Class, REX.ContentGenerator.Converters Namespace, RVTMaterialFactory Class


RVTMaterialPropertySetFactory Class

RVTMaterialPropertySetFactory Class
REX.ContentGenerator.Converters Namespace Legend Members Public Methods RVTMaterialPropertySetFactory Methods

This is class REX.ContentGenerator.Converters.RVTMaterialPropertySetFactory.

Class Hierarchy
C#
public class RVTMaterialPropertySetFactory : RVTFamilyFactory;
Namespace

REX.ContentGenerator.Converters Namespace

Public Methods
Public Method | Description
RVTMaterialPropertySetFactory | This is RVTMaterialPropertySetFactory, a member of class RVTMaterialPropertySetFactory.
RVTMaterialPropertySetFactory | This is RVTMaterialPropertySetFactory, a member of class RVTMaterialPropertySetFactory.
RVTMaterialPropertySetFactory Methods
RVTMaterialPropertySetFactory Methods | Description
AddElement2FamList | This is AddElement2FamList, a member of class RVTMaterialPropertySetFactory.
AddElement2FamList | This is AddElement2FamList, a member of class RVTMaterialPropertySetFactory.
CreateNewPropertySet | This is CreateNewPropertySet, a member of class RVTMaterialPropertySetFactory.
GetConcreteParameter | This is GetConcreteParameter, a member of class RVTMaterialPropertySetFactory.
GetExistingNames | This is GetExistingNames, a member of class RVTMaterialPropertySetFactory.
GetGenericParameter | This is GetGenericParameter, a member of class RVTMaterialPropertySetFactory.
GetMaterialParams | This is GetMaterialParams, a member of class RVTMaterialPropertySetFactory.
GetMaterialTypeCompLevel | This is GetMaterialTypeCompLevel, a member of class RVTMaterialPropertySetFactory.
GetParameter | This is GetParameter, a member of class RVTMaterialPropertySetFactory.
GetRevitTypesForInit | This is GetRevitTypesForInit, a member of class RVTMaterialPropertySetFactory.
GetSteelParameter | This is GetSteelParameter, a member of class RVTMaterialPropertySetFactory.
GetWoodParameter | This is GetWoodParameter, a member of class RVTMaterialPropertySetFactory.
InitList | This is InitList, a member of class RVTMaterialPropertySetFactory.
OnClose | This is OnClose, a member of class RVTMaterialPropertySetFactory.
Recalculate | This is Recalculate, a member of class RVTMaterialPropertySetFactory.
ValidateElement | This is ValidateElement, a member of class RVTMaterialPropertySetFactory.
Links
REX.ContentGenerator.Converters Namespace, Legend, Members, Public Methods, RVTMaterialPropertySetFactory Methods


RVTMaterialPropertySetFactory.RVTMaterialPropertySetFactory Constructor ()

RVTMaterialPropertySetFactory.RVTMaterialPropertySetFactory Constructor ()
RVTMaterialPropertySetFactory Class REX.ContentGenerator.Converters Namespace RVTMaterialPropertySetFactory Class

This is RVTMaterialPropertySetFactory, a member of class RVTMaterialPropertySetFactory.

C#
public RVTMaterialPropertySetFactory();
Class

RVTMaterialPropertySetFactory Class

Links
RVTMaterialPropertySetFactory Class, REX.ContentGenerator.Converters Namespace, RVTMaterialPropertySetFactory Class


RVTMaterialPropertySetFactory.RVTMaterialPropertySetFactory Constructor (RvtConversionSettings)

RVTMaterialPropertySetFactory.RVTMaterialPropertySetFactory Constructor (RvtConversionSettings)
RVTMaterialPropertySetFactory Class REX.ContentGenerator.Converters Namespace RVTMaterialPropertySetFactory Class

This is RVTMaterialPropertySetFactory, a member of class RVTMaterialPropertySetFactory.

C#
public RVTMaterialPropertySetFactory(RvtConversionSettings Settings);
Class

RVTMaterialPropertySetFactory Class

Links
RVTMaterialPropertySetFactory Class, REX.ContentGenerator.Converters Namespace, RVTMaterialPropertySetFactory Class


RVTMaterialPropertySetFactory.AddElement2FamList Method (Autodesk.Revit.DB.Element)

RVTMaterialPropertySetFactory.AddElement2FamList Method (Autodesk.Revit.DB.Element)
RVTMaterialPropertySetFactory Class REX.ContentGenerator.Converters Namespace RVTMaterialPropertySetFactory Class

This is AddElement2FamList, a member of class RVTMaterialPropertySetFactory.

C#
public override bool AddElement2FamList(Autodesk.Revit.DB.Element el);
Class

RVTMaterialPropertySetFactory Class

Links
RVTMaterialPropertySetFactory Class, REX.ContentGenerator.Converters Namespace, RVTMaterialPropertySetFactory Class


RVTMaterialPropertySetFactory.AddElement2FamList Method (Autodesk.Revit.DB.Element, REXFamilyType, bool)

RVTMaterialPropertySetFactory.AddElement2FamList Method (Autodesk.Revit.DB.Element, REXFamilyType, bool)
RVTMaterialPropertySetFactory Class REX.ContentGenerator.Converters Namespace RVTMaterialPropertySetFactory Class

This is AddElement2FamList, a member of class RVTMaterialPropertySetFactory.

C#
public override bool AddElement2FamList(Autodesk.Revit.DB.Element el, REXFamilyType ft, bool addToDict);
Class

RVTMaterialPropertySetFactory Class

Links
RVTMaterialPropertySetFactory Class, REX.ContentGenerator.Converters Namespace, RVTMaterialPropertySetFactory Class


RVTMaterialPropertySetFactory.CreateNewPropertySet Method

RVTMaterialPropertySetFactory.CreateNewPropertySet Method
RVTMaterialPropertySetFactory Class REX.ContentGenerator.Converters Namespace RVTMaterialPropertySetFactory Class

This is CreateNewPropertySet, a member of class RVTMaterialPropertySetFactory.

C#
public PropertySetElement CreateNewPropertySet(Autodesk.Revit.DB.StructuralAssetClass mat, string name);
Class

RVTMaterialPropertySetFactory Class

Links
RVTMaterialPropertySetFactory Class, REX.ContentGenerator.Converters Namespace, RVTMaterialPropertySetFactory Class


RVTMaterialPropertySetFactory.GetConcreteParameter Method

RVTMaterialPropertySetFactory.GetConcreteParameter Method
RVTMaterialPropertySetFactory Class REX.ContentGenerator.Converters Namespace RVTMaterialPropertySetFactory Class

This is GetConcreteParameter, a member of class RVTMaterialPropertySetFactory.

C#
public Autodesk.Revit.DB.BuiltInParameter GetConcreteParameter(string ParamName, StructuralBehavior behavior);
Class

RVTMaterialPropertySetFactory Class

Links
RVTMaterialPropertySetFactory Class, REX.ContentGenerator.Converters Namespace, RVTMaterialPropertySetFactory Class


RVTMaterialPropertySetFactory.GetExistingNames Method

RVTMaterialPropertySetFactory.GetExistingNames Method
RVTMaterialPropertySetFactory Class REX.ContentGenerator.Converters Namespace RVTMaterialPropertySetFactory Class

This is GetExistingNames, a member of class RVTMaterialPropertySetFactory.

C#
public override List<string> GetExistingNames(REXFamilyType obj, bool type);
Class

RVTMaterialPropertySetFactory Class

Links
RVTMaterialPropertySetFactory Class, REX.ContentGenerator.Converters Namespace, RVTMaterialPropertySetFactory Class


RVTMaterialPropertySetFactory.GetGenericParameter Method

RVTMaterialPropertySetFactory.GetGenericParameter Method
RVTMaterialPropertySetFactory Class REX.ContentGenerator.Converters Namespace RVTMaterialPropertySetFactory Class

This is GetGenericParameter, a member of class RVTMaterialPropertySetFactory.

C#
public Autodesk.Revit.DB.BuiltInParameter GetGenericParameter(string ParamName, StructuralBehavior behavior);
Class

RVTMaterialPropertySetFactory Class

Links
RVTMaterialPropertySetFactory Class, REX.ContentGenerator.Converters Namespace, RVTMaterialPropertySetFactory Class


RVTMaterialPropertySetFactory.GetMaterialParams Method

RVTMaterialPropertySetFactory.GetMaterialParams Method
RVTMaterialPropertySetFactory Class REX.ContentGenerator.Converters Namespace RVTMaterialPropertySetFactory Class

This is GetMaterialParams, a member of class RVTMaterialPropertySetFactory.

C#
public REXMaterialCharacteristics GetMaterialParams(RevitElement el);
Class

RVTMaterialPropertySetFactory Class

Links
RVTMaterialPropertySetFactory Class, REX.ContentGenerator.Converters Namespace, RVTMaterialPropertySetFactory Class


RVTMaterialPropertySetFactory.GetMaterialTypeCompLevel Method

RVTMaterialPropertySetFactory.GetMaterialTypeCompLevel Method
RVTMaterialPropertySetFactory Class REX.ContentGenerator.Converters Namespace RVTMaterialPropertySetFactory Class

This is GetMaterialTypeCompLevel, a member of class RVTMaterialPropertySetFactory.

C#
public CompositeLevel GetMaterialTypeCompLevel(EMaterial mat);
Class

RVTMaterialPropertySetFactory Class

Links
RVTMaterialPropertySetFactory Class, REX.ContentGenerator.Converters Namespace, RVTMaterialPropertySetFactory Class


RVTMaterialPropertySetFactory.GetParameter Method

RVTMaterialPropertySetFactory.GetParameter Method
RVTMaterialPropertySetFactory Class REX.ContentGenerator.Converters Namespace RVTMaterialPropertySetFactory Class

This is GetParameter, a member of class RVTMaterialPropertySetFactory.

C#
public Autodesk.Revit.DB.BuiltInParameter GetParameter(EMaterial mat, string ParamName, StructuralBehavior behavior);
Class

RVTMaterialPropertySetFactory Class

Links
RVTMaterialPropertySetFactory Class, REX.ContentGenerator.Converters Namespace, RVTMaterialPropertySetFactory Class


RVTMaterialPropertySetFactory.GetRevitTypesForInit Method

RVTMaterialPropertySetFactory.GetRevitTypesForInit Method
RVTMaterialPropertySetFactory Class REX.ContentGenerator.Converters Namespace RVTMaterialPropertySetFactory Class

This is GetRevitTypesForInit, a member of class RVTMaterialPropertySetFactory.

C#
public override Type[] GetRevitTypesForInit();
Class

RVTMaterialPropertySetFactory Class

Links
RVTMaterialPropertySetFactory Class, REX.ContentGenerator.Converters Namespace, RVTMaterialPropertySetFactory Class


RVTMaterialPropertySetFactory.GetSteelParameter Method

RVTMaterialPropertySetFactory.GetSteelParameter Method
RVTMaterialPropertySetFactory Class REX.ContentGenerator.Converters Namespace RVTMaterialPropertySetFactory Class

This is GetSteelParameter, a member of class RVTMaterialPropertySetFactory.

C#
public Autodesk.Revit.DB.BuiltInParameter GetSteelParameter(string ParamName, StructuralBehavior behavior);
Class

RVTMaterialPropertySetFactory Class

Links
RVTMaterialPropertySetFactory Class, REX.ContentGenerator.Converters Namespace, RVTMaterialPropertySetFactory Class


RVTMaterialPropertySetFactory.GetWoodParameter Method

RVTMaterialPropertySetFactory.GetWoodParameter Method
RVTMaterialPropertySetFactory Class REX.ContentGenerator.Converters Namespace RVTMaterialPropertySetFactory Class

This is GetWoodParameter, a member of class RVTMaterialPropertySetFactory.

C#
public Autodesk.Revit.DB.BuiltInParameter GetWoodParameter(string ParamName, StructuralBehavior behavior);
Class

RVTMaterialPropertySetFactory Class

Links
RVTMaterialPropertySetFactory Class, REX.ContentGenerator.Converters Namespace, RVTMaterialPropertySetFactory Class


RVTMaterialPropertySetFactory.InitList Method

RVTMaterialPropertySetFactory.InitList Method
RVTMaterialPropertySetFactory Class REX.ContentGenerator.Converters Namespace RVTMaterialPropertySetFactory Class

This is InitList, a member of class RVTMaterialPropertySetFactory.

C#
public override void InitList();
Class

RVTMaterialPropertySetFactory Class

Links
RVTMaterialPropertySetFactory Class, REX.ContentGenerator.Converters Namespace, RVTMaterialPropertySetFactory Class


RVTMaterialPropertySetFactory.OnClose Method

RVTMaterialPropertySetFactory.OnClose Method
RVTMaterialPropertySetFactory Class REX.ContentGenerator.Converters Namespace RVTMaterialPropertySetFactory Class

This is OnClose, a member of class RVTMaterialPropertySetFactory.

C#
public override bool OnClose();
Class

RVTMaterialPropertySetFactory Class

Links
RVTMaterialPropertySetFactory Class, REX.ContentGenerator.Converters Namespace, RVTMaterialPropertySetFactory Class


RVTMaterialPropertySetFactory.Recalculate Method

RVTMaterialPropertySetFactory.Recalculate Method
RVTMaterialPropertySetFactory Class REX.ContentGenerator.Converters Namespace RVTMaterialPropertySetFactory Class

This is Recalculate, a member of class RVTMaterialPropertySetFactory.

C#
public override REXDescription Recalculate(REXDescription DBdesc, bool fromInterface, ECategoryType category, bool create_new);
Class

RVTMaterialPropertySetFactory Class

Links
RVTMaterialPropertySetFactory Class, REX.ContentGenerator.Converters Namespace, RVTMaterialPropertySetFactory Class


RVTMaterialPropertySetFactory.ValidateElement Method

RVTMaterialPropertySetFactory.ValidateElement Method
RVTMaterialPropertySetFactory Class REX.ContentGenerator.Converters Namespace RVTMaterialPropertySetFactory Class

This is ValidateElement, a member of class RVTMaterialPropertySetFactory.

C#
public override bool ValidateElement(RevitElement el);
Class

RVTMaterialPropertySetFactory Class

Links
RVTMaterialPropertySetFactory Class, REX.ContentGenerator.Converters Namespace, RVTMaterialPropertySetFactory Class


RVTSectionFactory Class

RVTSectionFactory Class
REX.ContentGenerator.Converters Namespace Legend Members Public Methods RVTSectionFactory Methods

This is class REX.ContentGenerator.Converters.RVTSectionFactory.

Class Hierarchy
C#
public class RVTSectionFactory : RVTFamilyFactory;
Namespace

REX.ContentGenerator.Converters Namespace

Public Methods
Public Method | Description
RVTSectionFactory | This is RVTSectionFactory, a member of class RVTSectionFactory.
RVTSectionFactory Methods
RVTSectionFactory Methods | Description
AddElement2FamList | This is AddElement2FamList, a member of class RVTSectionFactory.
AddElement2FamList | This is AddElement2FamList, a member of class RVTSectionFactory.
GetElement | This is GetElement, a member of class RVTSectionFactory.
GetElement4ParamIdentity | This is GetElement4ParamIdentity, a member of class RVTSectionFactory.
GetElements | This is GetElements, a member of class RVTSectionFactory.
GetExistingNames | This is GetExistingNames, a member of class RVTSectionFactory.
GetFactory | This is GetFactory, a member of class RVTSectionFactory.
GetFactoryForGeneral | This is GetFactoryForGeneral, a member of class RVTSectionFactory.
GetFamily | This is GetFamily, a member of class RVTSectionFactory.
GetName4Mapping | This is GetName4Mapping, a member of class RVTSectionFactory.
GetRevitTypesForInit | This is GetRevitTypesForInit, a member of class RVTSectionFactory.
InitList | This is InitList, a member of class RVTSectionFactory.
IsElementSupported | This is IsElementSupported, a member of class RVTSectionFactory.
OnClose | This is OnClose, a member of class RVTSectionFactory.
Recalculate | This is Recalculate, a member of class RVTSectionFactory.
ResetFamilyBufor | This is ResetFamilyBufor, a member of class RVTSectionFactory.
ValidateElement | This is ValidateElement, a member of class RVTSectionFactory.
Links
REX.ContentGenerator.Converters Namespace, Legend, Members, Public Methods, RVTSectionFactory Methods


RVTSectionFactory.RVTSectionFactory Constructor

RVTSectionFactory.RVTSectionFactory Constructor
RVTSectionFactory Class REX.ContentGenerator.Converters Namespace RVTSectionFactory Class

This is RVTSectionFactory, a member of class RVTSectionFactory.

C#
public RVTSectionFactory(RvtConversionSettings Settings);
Class

RVTSectionFactory Class

Links
RVTSectionFactory Class, REX.ContentGenerator.Converters Namespace, RVTSectionFactory Class


RVTSectionFactory.AddElement2FamList Method (Autodesk.Revit.DB.Element, REXFamilyType, bool)

RVTSectionFactory.AddElement2FamList Method (Autodesk.Revit.DB.Element, REXFamilyType, bool)
RVTSectionFactory Class REX.ContentGenerator.Converters Namespace RVTSectionFactory Class

This is AddElement2FamList, a member of class RVTSectionFactory.

C#
public override bool AddElement2FamList(Autodesk.Revit.DB.Element el, REXFamilyType ft, bool addToDict);
Class

RVTSectionFactory Class

Links
RVTSectionFactory Class, REX.ContentGenerator.Converters Namespace, RVTSectionFactory Class


RVTSectionFactory.AddElement2FamList Method (RevitElement)

RVTSectionFactory.AddElement2FamList Method (RevitElement)
RVTSectionFactory Class REX.ContentGenerator.Converters Namespace RVTSectionFactory Class

This is AddElement2FamList, a member of class RVTSectionFactory.

C#
public override bool AddElement2FamList(RevitElement el);
Class

RVTSectionFactory Class

Links
RVTSectionFactory Class, REX.ContentGenerator.Converters Namespace, RVTSectionFactory Class


RVTSectionFactory.GetElement Method

RVTSectionFactory.GetElement Method
RVTSectionFactory Class REX.ContentGenerator.Converters Namespace RVTSectionFactory Class

This is GetElement, a member of class RVTSectionFactory.

C#
public override Autodesk.Revit.DB.Element GetElement(REXFamilyType obj, ECategoryType desc, bool copyFamily, bool recalculate);
Class

RVTSectionFactory Class

Links
RVTSectionFactory Class, REX.ContentGenerator.Converters Namespace, RVTSectionFactory Class


RVTSectionFactory.GetElement4ParamIdentity Method

RVTSectionFactory.GetElement4ParamIdentity Method
RVTSectionFactory Class REX.ContentGenerator.Converters Namespace RVTSectionFactory Class

This is GetElement4ParamIdentity, a member of class RVTSectionFactory.

C#
public override RevitElement GetElement4ParamIdentity(Autodesk.Revit.DB.Element el);
Class

RVTSectionFactory Class

Links
RVTSectionFactory Class, REX.ContentGenerator.Converters Namespace, RVTSectionFactory Class


RVTSectionFactory.GetElements Method

RVTSectionFactory.GetElements Method
RVTSectionFactory Class REX.ContentGenerator.Converters Namespace RVTSectionFactory Class

This is GetElements, a member of class RVTSectionFactory.

C#
public override List<Autodesk.Revit.DB.Element> GetElements(List<REXFamilyType> list, ECategoryType desc, bool recalculate);
Class

RVTSectionFactory Class

Links
RVTSectionFactory Class, REX.ContentGenerator.Converters Namespace, RVTSectionFactory Class


RVTSectionFactory.GetExistingNames Method

RVTSectionFactory.GetExistingNames Method
RVTSectionFactory Class REX.ContentGenerator.Converters Namespace RVTSectionFactory Class

This is GetExistingNames, a member of class RVTSectionFactory.

C#
public override List<string> GetExistingNames(REXFamilyType obj, bool type);
Class

RVTSectionFactory Class

Links
RVTSectionFactory Class, REX.ContentGenerator.Converters Namespace, RVTSectionFactory Class


RVTSectionFactory.GetFactory Method

RVTSectionFactory.GetFactory Method
RVTSectionFactory Class REX.ContentGenerator.Converters Namespace RVTSectionFactory Class

This is GetFactory, a member of class RVTSectionFactory.

C#
public override RVTFamilyFactory GetFactory(ECategoryType type);
Class

RVTSectionFactory Class

Links
RVTSectionFactory Class, REX.ContentGenerator.Converters Namespace, RVTSectionFactory Class


RVTSectionFactory.GetFactoryForGeneral Method

RVTSectionFactory.GetFactoryForGeneral Method
RVTSectionFactory Class REX.ContentGenerator.Converters Namespace RVTSectionFactory Class

This is GetFactoryForGeneral, a member of class RVTSectionFactory.

C#
public override RVTFamilyFactory GetFactoryForGeneral();
Class

RVTSectionFactory Class

Links
RVTSectionFactory Class, REX.ContentGenerator.Converters Namespace, RVTSectionFactory Class


RVTSectionFactory.GetFamily Method

RVTSectionFactory.GetFamily Method
RVTSectionFactory Class REX.ContentGenerator.Converters Namespace RVTSectionFactory Class

This is GetFamily, a member of class RVTSectionFactory.

C#
public override REXFamilyType GetFamily(Autodesk.Revit.DB.Element obj, ECategoryType desc, bool recalculate);
Class

RVTSectionFactory Class

Links
RVTSectionFactory Class, REX.ContentGenerator.Converters Namespace, RVTSectionFactory Class


RVTSectionFactory.GetName4Mapping Method

RVTSectionFactory.GetName4Mapping Method
RVTSectionFactory Class REX.ContentGenerator.Converters Namespace RVTSectionFactory Class

This is GetName4Mapping, a member of class RVTSectionFactory.

C#
public override string GetName4Mapping(Autodesk.Revit.DB.Element elem);
Class

RVTSectionFactory Class

Links
RVTSectionFactory Class, REX.ContentGenerator.Converters Namespace, RVTSectionFactory Class


RVTSectionFactory.GetRevitTypesForInit Method

RVTSectionFactory.GetRevitTypesForInit Method
RVTSectionFactory Class REX.ContentGenerator.Converters Namespace RVTSectionFactory Class

This is GetRevitTypesForInit, a member of class RVTSectionFactory.

C#
public override Type[] GetRevitTypesForInit();
Class

RVTSectionFactory Class

Links
RVTSectionFactory Class, REX.ContentGenerator.Converters Namespace, RVTSectionFactory Class


RVTSectionFactory.InitList Method

RVTSectionFactory.InitList Method
RVTSectionFactory Class REX.ContentGenerator.Converters Namespace RVTSectionFactory Class

This is InitList, a member of class RVTSectionFactory.

C#
public override void InitList();
Class

RVTSectionFactory Class

Links
RVTSectionFactory Class, REX.ContentGenerator.Converters Namespace, RVTSectionFactory Class


RVTSectionFactory.IsElementSupported Method

RVTSectionFactory.IsElementSupported Method
RVTSectionFactory Class REX.ContentGenerator.Converters Namespace RVTSectionFactory Class

This is IsElementSupported, a member of class RVTSectionFactory.

C#
public override bool IsElementSupported(REXFamilyType fam, ECategoryType category);
Class

RVTSectionFactory Class

Links
RVTSectionFactory Class, REX.ContentGenerator.Converters Namespace, RVTSectionFactory Class


RVTSectionFactory.OnClose Method

RVTSectionFactory.OnClose Method
RVTSectionFactory Class REX.ContentGenerator.Converters Namespace RVTSectionFactory Class

This is OnClose, a member of class RVTSectionFactory.

C#
public override bool OnClose();
Class

RVTSectionFactory Class

Links
RVTSectionFactory Class, REX.ContentGenerator.Converters Namespace, RVTSectionFactory Class


RVTSectionFactory.Recalculate Method

RVTSectionFactory.Recalculate Method
RVTSectionFactory Class REX.ContentGenerator.Converters Namespace RVTSectionFactory Class

This is Recalculate, a member of class RVTSectionFactory.

C#
public override REXDescription Recalculate(REXDescription DBdesc, bool fromInterface, ECategoryType category, bool create_new);
Class

RVTSectionFactory Class

Links
RVTSectionFactory Class, REX.ContentGenerator.Converters Namespace, RVTSectionFactory Class


RVTSectionFactory.ResetFamilyBufor Method

RVTSectionFactory.ResetFamilyBufor Method
RVTSectionFactory Class REX.ContentGenerator.Converters Namespace RVTSectionFactory Class

This is ResetFamilyBufor, a member of class RVTSectionFactory.

C#
public override void ResetFamilyBufor();
Class

RVTSectionFactory Class

Links
RVTSectionFactory Class, REX.ContentGenerator.Converters Namespace, RVTSectionFactory Class


RVTSectionFactory.ValidateElement Method

RVTSectionFactory.ValidateElement Method
RVTSectionFactory Class REX.ContentGenerator.Converters Namespace RVTSectionFactory Class

This is ValidateElement, a member of class RVTSectionFactory.

C#
public override bool ValidateElement(RevitElement el);
Class

RVTSectionFactory Class

Links
RVTSectionFactory Class, REX.ContentGenerator.Converters Namespace, RVTSectionFactory Class


RVTSectionParamFactory Class

RVTSectionParamFactory Class
REX.ContentGenerator.Converters Namespace Legend Members Public Methods RVTSectionParamFactory Methods

This is class REX.ContentGenerator.Converters.RVTSectionParamFactory.

Class Hierarchy
C#
public class RVTSectionParamFactory : RVTCommonSectionFactory;
Namespace

REX.ContentGenerator.Converters Namespace

Public Methods
Public Method | Description
RVTSectionParamFactory | This is RVTSectionParamFactory, a member of class RVTSectionParamFactory.
RVTSectionParamFactory Methods
RVTSectionParamFactory Methods | Description
AddFamily2ProjectDictionary | This is AddFamily2ProjectDictionary, a member of class RVTSectionParamFactory.
IsElementSupported | This is IsElementSupported, a member of class RVTSectionParamFactory.
Recalculate | This is Recalculate, a member of class RVTSectionParamFactory.
Links
REX.ContentGenerator.Converters Namespace, Legend, Members, Public Methods, RVTSectionParamFactory Methods


RVTSectionParamFactory.RVTSectionParamFactory Constructor

RVTSectionParamFactory.RVTSectionParamFactory Constructor
RVTSectionParamFactory Class REX.ContentGenerator.Converters Namespace RVTSectionParamFactory Class

This is RVTSectionParamFactory, a member of class RVTSectionParamFactory.

C#
public RVTSectionParamFactory(RvtConversionSettings Settings, CompositeLevel Families, RVTDBSectionFactory factoryDB);
Class

RVTSectionParamFactory Class

Links
RVTSectionParamFactory Class, REX.ContentGenerator.Converters Namespace, RVTSectionParamFactory Class


RVTSectionParamFactory.AddFamily2ProjectDictionary Method

RVTSectionParamFactory.AddFamily2ProjectDictionary Method
RVTSectionParamFactory Class REX.ContentGenerator.Converters Namespace RVTSectionParamFactory Class

This is AddFamily2ProjectDictionary, a member of class RVTSectionParamFactory.

C#
public override void AddFamily2ProjectDictionary(Autodesk.Revit.DB.Element el, Autodesk.Revit.DB.Element idElement, REXFamilyType fam);
Class

RVTSectionParamFactory Class

Links
RVTSectionParamFactory Class, REX.ContentGenerator.Converters Namespace, RVTSectionParamFactory Class


RVTSectionParamFactory.IsElementSupported Method

RVTSectionParamFactory.IsElementSupported Method
RVTSectionParamFactory Class REX.ContentGenerator.Converters Namespace RVTSectionParamFactory Class

This is IsElementSupported, a member of class RVTSectionParamFactory.

C#
public override bool IsElementSupported(REXFamilyType fam, ECategoryType category);
Class

RVTSectionParamFactory Class

Links
RVTSectionParamFactory Class, REX.ContentGenerator.Converters Namespace, RVTSectionParamFactory Class


RVTSectionParamFactory.Recalculate Method

RVTSectionParamFactory.Recalculate Method
RVTSectionParamFactory Class REX.ContentGenerator.Converters Namespace RVTSectionParamFactory Class

This is Recalculate, a member of class RVTSectionParamFactory.

C#
public override REXDescription Recalculate(REXDescription DBdesc, bool fromInterface, ECategoryType category, bool create_new);
Class

RVTSectionParamFactory Class

Links
RVTSectionParamFactory Class, REX.ContentGenerator.Converters Namespace, RVTSectionParamFactory Class


IRexContentSettings Interface

IRexContentSettings Interface
REX.ContentGenerator.Converters Namespace Legend Members IRexContentSettings Methods IRexContentSettings Properties

Provides interface for the settings of the REXFamilyConverter.

Class Hierarchy
C#
public interface IRexContentSettings;
Description
Namespace

REX.ContentGenerator.Converters Namespace

IRexContentSettings Methods
IRexContentSettings Methods | Description
GetParamsForDisplayName | Gets parameters for the specified display name of the specified category.
GetParamsForField | Gets parameters for the specified name of the specified category.
GetResource | Gets the resource for the specified name of the specified category.
LoadCustomParametersFile | Loads the custom parameters file.
IRexContentSettings Properties
IRexContentSettings Properties | Description
CodeFilteredShapeAnalysis | Gets or sets a value indicating whether the filtered list of rebar shapes should be taken to consideration during rebars analysis.
DatabaseAccess | Gets or sets the database access.
Labels | Gets or sets a value indicating whether labels are taken to consideration during mapping.
MirroredShapeAnalysis | Gets or sets a value indicating whether mirrored rebar shapes should be taken to consideration during rebars analysis.
MultiSearch | Gets or sets a value indicating whether during searching databases multiply result should be returned (if false - when first result is found algorithm will stop - In case of GetDBList(List…) function will stop if any REXFamilyType in database will be found) .
MultiThread | Gets or sets a value indicating whether multithread operations should be used for database searching (only if DbRoot is used)..
ReleaseDBAfterEachAction | Gets or sets a value indicating whether the database should be released after each action (if not it will be kept in memory).
SupportUserDatabases | Gets or sets a value indicating whether users databases should be supported
Links
REX.ContentGenerator.Converters Namespace, Legend, Members, IRexContentSettings Methods, IRexContentSettings Properties


IRexContentSettings.GetParamsForDisplayName Method

IRexContentSettings.GetParamsForDisplayName Method
IRexContentSettings Interface REX.ContentGenerator.Converters Namespace IRexContentSettings Interface

Gets parameters for the specified display name of the specified category.

C#
FieldParams GetParamsForDisplayName(string generalname, ECategoryType type);
Parameters
Parameters | Description
generalname | The name of the field.
type | The category.
Returns

Return parameters.

Description
Remarks

The general name is the same name as it is shown in Content Generator

Interface

IRexContentSettings Interface

Links
IRexContentSettings Interface, REX.ContentGenerator.Converters Namespace, IRexContentSettings Interface


IRexContentSettings.GetParamsForField Method

IRexContentSettings.GetParamsForField Method
IRexContentSettings Interface REX.ContentGenerator.Converters Namespace IRexContentSettings Interface

Gets parameters for the specified name of the specified category.

C#
FieldParams GetParamsForField(string fieldname, ECategoryType type);
Parameters
Parameters | Description
fieldname | The name of the field.
type | The type.
Returns

Return parameters.

Description
Interface

IRexContentSettings Interface

Links
IRexContentSettings Interface, REX.ContentGenerator.Converters Namespace, IRexContentSettings Interface


IRexContentSettings.GetResource Method

IRexContentSettings.GetResource Method
IRexContentSettings Interface REX.ContentGenerator.Converters Namespace IRexContentSettings Interface

Gets the resource for the specified name of the specified category.

C#
string GetResource(ECategoryType cat, string item);
Parameters
Parameters | Description
cat | The category.
item | The item.
Returns

The resource.

Description
Interface

IRexContentSettings Interface

Links
IRexContentSettings Interface, REX.ContentGenerator.Converters Namespace, IRexContentSettings Interface


IRexContentSettings.LoadCustomParametersFile Method

IRexContentSettings.LoadCustomParametersFile Method
IRexContentSettings Interface REX.ContentGenerator.Converters Namespace IRexContentSettings Interface

Loads the custom parameters file.

C#
bool LoadCustomParametersFile(string category, string path);
Parameters
Parameters | Description
category | The custom category name.
path | The path.
Returns

True if loading succeeded; otherwise, false.

Description
Interface

IRexContentSettings Interface

Links
IRexContentSettings Interface, REX.ContentGenerator.Converters Namespace, IRexContentSettings Interface


IRexContentSettings.CodeFilteredShapeAnalysis Property

IRexContentSettings.CodeFilteredShapeAnalysis Property
IRexContentSettings Interface REX.ContentGenerator.Converters Namespace IRexContentSettings Interface

Gets or sets a value indicating whether the filtered list of rebar shapes should be taken to consideration during rebars analysis.

C#
bool CodeFilteredShapeAnalysis;
Description

If filtered shapes are supported only.

Interface

IRexContentSettings Interface

Links
IRexContentSettings Interface, REX.ContentGenerator.Converters Namespace, IRexContentSettings Interface


IRexContentSettings.DatabaseAccess Property

IRexContentSettings.DatabaseAccess Property
IRexContentSettings Interface REX.ContentGenerator.Converters Namespace IRexContentSettings Interface

Gets or sets the database access.

C#
EDBAccess DatabaseAccess;
Description

The database access.

Interface

IRexContentSettings Interface

Links
IRexContentSettings Interface, REX.ContentGenerator.Converters Namespace, IRexContentSettings Interface


IRexContentSettings.Labels Property

IRexContentSettings.Labels Property
IRexContentSettings Interface REX.ContentGenerator.Converters Namespace IRexContentSettings Interface

Gets or sets a value indicating whether labels are taken to consideration during mapping.

C#
bool Labels;
Description

True if labels supported; otherwise false.

Interface

IRexContentSettings Interface

Links
IRexContentSettings Interface, REX.ContentGenerator.Converters Namespace, IRexContentSettings Interface


IRexContentSettings.MirroredShapeAnalysis Property

IRexContentSettings.MirroredShapeAnalysis Property
IRexContentSettings Interface REX.ContentGenerator.Converters Namespace IRexContentSettings Interface

Gets or sets a value indicating whether mirrored rebar shapes should be taken to consideration during rebars analysis.

C#
bool MirroredShapeAnalysis;
Description

If mirrored shapes are supported.

Interface

IRexContentSettings Interface

Links
IRexContentSettings Interface, REX.ContentGenerator.Converters Namespace, IRexContentSettings Interface


IRexContentSettings.MultiSearch Property

IRexContentSettings.MultiSearch Property
IRexContentSettings Interface REX.ContentGenerator.Converters Namespace IRexContentSettings Interface

Gets or sets a value indicating whether during searching databases multiply result should be returned (if false - when first result is found algorithm will stop - In case of GetDBList(List…) function will stop if any REXFamilyType in database will be found) .

C#
bool MultiSearch;
Description

If multiply result is needed.

Interface

IRexContentSettings Interface

Links
IRexContentSettings Interface, REX.ContentGenerator.Converters Namespace, IRexContentSettings Interface


IRexContentSettings.MultiThread Property

IRexContentSettings.MultiThread Property
IRexContentSettings Interface REX.ContentGenerator.Converters Namespace IRexContentSettings Interface

Gets or sets a value indicating whether multithread operations should be used for database searching (only if DbRoot is used)..

C#
bool MultiThread;
Description

True if multithread operations supported; otherwise, false.

Interface

IRexContentSettings Interface

Links
IRexContentSettings Interface, REX.ContentGenerator.Converters Namespace, IRexContentSettings Interface


IRexContentSettings.ReleaseDBAfterEachAction Property

IRexContentSettings.ReleaseDBAfterEachAction Property
IRexContentSettings Interface REX.ContentGenerator.Converters Namespace IRexContentSettings Interface

Gets or sets a value indicating whether the database should be released after each action (if not it will be kept in memory).

C#
bool ReleaseDBAfterEachAction;
Description

True if the database is released after usage; otherwise, false.

Interface

IRexContentSettings Interface

Links
IRexContentSettings Interface, REX.ContentGenerator.Converters Namespace, IRexContentSettings Interface


IRexContentSettings.SupportUserDatabases Property

IRexContentSettings.SupportUserDatabases Property
IRexContentSettings Interface REX.ContentGenerator.Converters Namespace IRexContentSettings Interface

Gets or sets a value indicating whether users databases should be supported

C#
bool SupportUserDatabases;
Description

True if user databases are supported; otherwise, false.

Interface

IRexContentSettings Interface

Links
IRexContentSettings Interface, REX.ContentGenerator.Converters Namespace, IRexContentSettings Interface


IRvtContentSettings Interface

IRvtContentSettings Interface
REX.ContentGenerator.Converters Namespace Legend Members IRvtContentSettings Methods IRvtContentSettings Properties

Provides interface for the settings of the RVTFamilyConverter.

Class Hierarchy
C#
public interface IRvtContentSettings;
Description
Namespace

REX.ContentGenerator.Converters Namespace

IRvtContentSettings Methods
IRvtContentSettings Methods | Description
Clean | Cleans temporary files.
LoadCustomParametersFile | Loads the custom parameters file.
SetLanguage | Sets the language for created families (names of families will be translated according to this) - “en-US”, “pl-PL” etc.
IRvtContentSettings Properties
IRvtContentSettings Properties | Description
BufferElements | Gets or sets a value indicating whether elements should be buffered after investigation – using RevitId.
CreateNewElement | Gets or sets a value indicating whether a new family should be created if the element wasn’t found among existing ones.
IgnoreFamilyNameLanguage | Gets or sets a value indicating whether language should be taken to consideration during element search (language set by SetLanguage function).
Labels | Gets or sets a value indicating whether labels should be taken to consideration during mapping.
RebarPostGenerateCorrection | Gets or sets a value indicating whether correction of rebar geometry should be made after generation process.
SupportUserDatabases | Gets or sets a value indicating whether users databases should be supported
Update | Gets or sets a value indicating whether element found in the project (if it already exists) should be updated with new data.
Links
REX.ContentGenerator.Converters Namespace, Legend, Members, IRvtContentSettings Methods, IRvtContentSettings Properties


IRvtContentSettings.Clean Method

IRvtContentSettings.Clean Method
IRvtContentSettings Interface REX.ContentGenerator.Converters Namespace IRvtContentSettings Interface

Cleans temporary files.

C#
bool Clean();
Returns

Whether cleaning succeeded.

Description
Interface

IRvtContentSettings Interface

Links
IRvtContentSettings Interface, REX.ContentGenerator.Converters Namespace, IRvtContentSettings Interface


IRvtContentSettings.LoadCustomParametersFile Method

IRvtContentSettings.LoadCustomParametersFile Method
IRvtContentSettings Interface REX.ContentGenerator.Converters Namespace IRvtContentSettings Interface

Loads the custom parameters file.

C#
bool LoadCustomParametersFile(string category, string path);
Parameters
Parameters | Description
category | The custom category name.
path | The path.
Returns

Loads the custom parameters file.

Description
Interface

IRvtContentSettings Interface

Links
IRvtContentSettings Interface, REX.ContentGenerator.Converters Namespace, IRvtContentSettings Interface


IRvtContentSettings.SetLanguage Method

IRvtContentSettings.SetLanguage Method
IRvtContentSettings Interface REX.ContentGenerator.Converters Namespace IRvtContentSettings Interface

Sets the language for created families (names of families will be translated according to this) - “en-US”, “pl-PL” etc.

C#
void SetLanguage(string lang);
Parameters
Parameters | Description
lang | The language.
Description
Interface

IRvtContentSettings Interface

Links
IRvtContentSettings Interface, REX.ContentGenerator.Converters Namespace, IRvtContentSettings Interface


IRvtContentSettings.BufferElements Property

IRvtContentSettings.BufferElements Property
IRvtContentSettings Interface REX.ContentGenerator.Converters Namespace IRvtContentSettings Interface

Gets or sets a value indicating whether elements should be buffered after investigation – using RevitId.

C#
bool BufferElements;
Description

If false it will be analyzed each time.

True if elements are buffored; otherwise, false.

Interface

IRvtContentSettings Interface

Links
IRvtContentSettings Interface, REX.ContentGenerator.Converters Namespace, IRvtContentSettings Interface


IRvtContentSettings.CreateNewElement Property

IRvtContentSettings.CreateNewElement Property
IRvtContentSettings Interface REX.ContentGenerator.Converters Namespace IRvtContentSettings Interface

Gets or sets a value indicating whether a new family should be created if the element wasn’t found among existing ones.

C#
bool CreateNewElement;
Description

True if a new family is created; otherwise, false.

Interface

IRvtContentSettings Interface

Links
IRvtContentSettings Interface, REX.ContentGenerator.Converters Namespace, IRvtContentSettings Interface


IRvtContentSettings.IgnoreFamilyNameLanguage Property

IRvtContentSettings.IgnoreFamilyNameLanguage Property
IRvtContentSettings Interface REX.ContentGenerator.Converters Namespace IRvtContentSettings Interface

Gets or sets a value indicating whether language should be taken to consideration during element search (language set by SetLanguage function).

C#
bool IgnoreFamilyNameLanguage;
Description

True if the language should be taken to considaration when created; otherwise, false.

Remarks

If IgnoreFamilyNameLanguage is set to false there will be

Interface

IRvtContentSettings Interface

Links
IRvtContentSettings Interface, REX.ContentGenerator.Converters Namespace, IRvtContentSettings Interface


IRvtContentSettings.Labels Property

IRvtContentSettings.Labels Property
IRvtContentSettings Interface REX.ContentGenerator.Converters Namespace IRvtContentSettings Interface

Gets or sets a value indicating whether labels should be taken to consideration during mapping.

C#
bool Labels;
Description

True if labels are supported; otherwise, false.

Interface

IRvtContentSettings Interface

Links
IRvtContentSettings Interface, REX.ContentGenerator.Converters Namespace, IRvtContentSettings Interface


IRvtContentSettings.RebarPostGenerateCorrection Property

IRvtContentSettings.RebarPostGenerateCorrection Property
IRvtContentSettings Interface REX.ContentGenerator.Converters Namespace IRvtContentSettings Interface

Gets or sets a value indicating whether correction of rebar geometry should be made after generation process.

C#
bool RebarPostGenerateCorrection;
Description

True if postgeneration correction; otherwise, false.

Interface

IRvtContentSettings Interface

Links
IRvtContentSettings Interface, REX.ContentGenerator.Converters Namespace, IRvtContentSettings Interface


IRvtContentSettings.SupportUserDatabases Property

IRvtContentSettings.SupportUserDatabases Property
IRvtContentSettings Interface REX.ContentGenerator.Converters Namespace IRvtContentSettings Interface

Gets or sets a value indicating whether users databases should be supported

C#
bool SupportUserDatabases;
Description

True if user databases are supported; otherwise, false.

Interface

IRvtContentSettings Interface

Links
IRvtContentSettings Interface, REX.ContentGenerator.Converters Namespace, IRvtContentSettings Interface


IRvtContentSettings.Update Property

IRvtContentSettings.Update Property
IRvtContentSettings Interface REX.ContentGenerator.Converters Namespace IRvtContentSettings Interface

Gets or sets a value indicating whether element found in the project (if it already exists) should be updated with new data.

C#
bool Update;
Description

True if elements are updated; otherwise, false.

Interface

IRvtContentSettings Interface

Links
IRvtContentSettings Interface, REX.ContentGenerator.Converters Namespace, IRvtContentSettings Interface


REX.ContentGenerator.Converters.EDBAccess Enumeration

REX.ContentGenerator.Converters.EDBAccess Enumeration
REX.ContentGenerator.Converters Namespace

Describes the access to databases.

C#
public enum EDBAccess {
  ADO_mdb,
  DbRoot_xml,
  DbRoot_mdb
}
Members
Members | Description
ADO_mdb | ADO access to mdb files.
DbRoot_xml | DBRoot access to xml files.
DbRoot_mdb | DBRoot access to mdb files.
Description
Namespace

REX.ContentGenerator.Converters Namespace

Links
REX.ContentGenerator.Converters Namespace


REX.ContentGenerator.Converters.ElementGenerated Type

REX.ContentGenerator.Converters.ElementGenerated Type
REX.ContentGenerator.Converters Namespace

Delagate for the generation event (when the list of elements is used).

C#
public delegate void ElementGenerated(string id);
Description
Namespace

REX.ContentGenerator.Converters Namespace

Links
REX.ContentGenerator.Converters Namespace


REX.ContentGenerator.Dialog Namespace

Previous | Next
REX.ContentGenerator.Dialog Namespace
Legend Classes Structs, Records, Enums

This is namespace REX.ContentGenerator.Dialog.

Classes
Class | Description
REXContentDialogCategorySettings | Contains settings for specific category.
REXContentDialogManager | Helps manage DRevitContentGenerator Extension directly by code.
REXContentDialogSettings | Describes settings of the ContentGenerator dialog.
Structs, Records, Enums
Struct, Record, Enum | Description
EContentDialogMode | Describes modes in which the ContentGenerator dialog may be run.
Links
Legend, Classes, Structs, Records, Enums
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXContentDialogCategorySettings Class

REXContentDialogCategorySettings Class
REX.ContentGenerator.Dialog Namespace Legend Members Public Methods REXContentDialogCategorySettings Properties

Contains settings for specific category.

Class Hierarchy
C#
public class REXContentDialogCategorySettings;
Description
Namespace

REX.ContentGenerator.Dialog Namespace

Public Methods
Public Method | Description
REXContentDialogCategorySettings | Initializes a new instance of the REXContentDialogCategorySettings class.
REXContentDialogCategorySettings Properties
REXContentDialogCategorySettings Properties | Description
Category | Gets the category type.
Databases | Gets or sets the list of databases.
SelectedElement | Gets or sets the selected element.
SelectedElements | Gets the selected elements.
Visible | Gets or sets a value indicating whether this category is visible.
Links
REX.ContentGenerator.Dialog Namespace, Legend, Members, Public Methods, REXContentDialogCategorySettings Properties


REXContentDialogCategorySettings.REXContentDialogCategorySettings Constructor

REXContentDialogCategorySettings.REXContentDialogCategorySettings Constructor
REXContentDialogCategorySettings Class REX.ContentGenerator.Dialog Namespace REXContentDialogCategorySettings Class

Initializes a new instance of the REXContentDialogCategorySettings class.

C#
public REXContentDialogCategorySettings(ECategoryType category, REXContentDialogSettings parent);
Parameters
Parameters | Description
category | The category.
parent | The parent.
Description
Class

REXContentDialogCategorySettings Class

Links
REXContentDialogCategorySettings Class, REX.ContentGenerator.Dialog Namespace, REXContentDialogCategorySettings Class


REXContentDialogCategorySettings.Category Property

REXContentDialogCategorySettings.Category Property
REXContentDialogCategorySettings Class REX.ContentGenerator.Dialog Namespace REXContentDialogCategorySettings Class

Gets the category type.

C#
public ECategoryType Category;
Description

The category type.

Class

REXContentDialogCategorySettings Class

Links
REXContentDialogCategorySettings Class, REX.ContentGenerator.Dialog Namespace, REXContentDialogCategorySettings Class


REXContentDialogCategorySettings.Databases Property

REXContentDialogCategorySettings.Databases Property
REXContentDialogCategorySettings Class REX.ContentGenerator.Dialog Namespace REXContentDialogCategorySettings Class

Gets or sets the list of databases.

C#
public Dictionary<string, List<REXFamilyType>> Databases;
Description

The databases.

Class

REXContentDialogCategorySettings Class

Links
REXContentDialogCategorySettings Class, REX.ContentGenerator.Dialog Namespace, REXContentDialogCategorySettings Class


REXContentDialogCategorySettings.SelectedElement Property

REXContentDialogCategorySettings.SelectedElement Property
REXContentDialogCategorySettings Class REX.ContentGenerator.Dialog Namespace REXContentDialogCategorySettings Class

Gets or sets the selected element.

C#
public REXFamilyType SelectedElement;
Description

The selected element.

Class

REXContentDialogCategorySettings Class

Links
REXContentDialogCategorySettings Class, REX.ContentGenerator.Dialog Namespace, REXContentDialogCategorySettings Class


REXContentDialogCategorySettings.SelectedElements Property

REXContentDialogCategorySettings.SelectedElements Property
REXContentDialogCategorySettings Class REX.ContentGenerator.Dialog Namespace REXContentDialogCategorySettings Class

Gets the selected elements.

C#
public List<REXFamilyType> SelectedElements;
Description

The selected elements.

Class

REXContentDialogCategorySettings Class

Links
REXContentDialogCategorySettings Class, REX.ContentGenerator.Dialog Namespace, REXContentDialogCategorySettings Class


REXContentDialogCategorySettings.Visible Property

REXContentDialogCategorySettings.Visible Property
REXContentDialogCategorySettings Class REX.ContentGenerator.Dialog Namespace REXContentDialogCategorySettings Class

Gets or sets a value indicating whether this category is visible.

C#
public bool Visible;
Description

True if the category is visible; otherwise, false.

Class

REXContentDialogCategorySettings Class

Links
REXContentDialogCategorySettings Class, REX.ContentGenerator.Dialog Namespace, REXContentDialogCategorySettings Class


REXContentDialogManager Class

REXContentDialogManager Class
REX.ContentGenerator.Dialog Namespace Legend Members Public Methods REXContentDialogManager Methods

Helps manage DRevitContentGenerator Extension directly by code.

Class Hierarchy
C#
public class REXContentDialogManager;
Description
Namespace

REX.ContentGenerator.Dialog Namespace

Public Methods
Public Method | Description
REXContentDialogManager | Initializes a new instance of the REXContentDialogManager class.
REXContentDialogManager Methods
REXContentDialogManager Methods | Description
DisposeContentDialog | Disposes the DRevitContentGenerator Extension.
SetApplicationInstance | Sets the Extension Instance.
ShowContentDialog | Loads the ContentGenerator dialog.
ShowContentDialogParentIntPtr | Loads the ContentGenerator dialog.
Links
REX.ContentGenerator.Dialog Namespace, Legend, Members, Public Methods, REXContentDialogManager Methods


REXContentDialogManager.REXContentDialogManager Constructor

REXContentDialogManager.REXContentDialogManager Constructor
REXContentDialogManager Class REX.ContentGenerator.Dialog Namespace REXContentDialogManager Class

Initializes a new instance of the REXContentDialogManager class.

C#
public REXContentDialogManager(REXContext context);
Parameters
Parameters | Description
context | The context.
Description
Class

REXContentDialogManager Class

Links
REXContentDialogManager Class, REX.ContentGenerator.Dialog Namespace, REXContentDialogManager Class


REXContentDialogManager.DisposeContentDialog Method

REXContentDialogManager.DisposeContentDialog Method
REXContentDialogManager Class REX.ContentGenerator.Dialog Namespace REXContentDialogManager Class

Disposes the DRevitContentGenerator Extension.

C#
public void DisposeContentDialog();
Description
Class

REXContentDialogManager Class

Links
REXContentDialogManager Class, REX.ContentGenerator.Dialog Namespace, REXContentDialogManager Class


REXContentDialogManager.SetApplicationInstance Method

REXContentDialogManager.SetApplicationInstance Method
REXContentDialogManager Class REX.ContentGenerator.Dialog Namespace REXContentDialogManager Class

Sets the Extension Instance.

C#
public void SetApplicationInstance(REXContentDialogSettings settings);
Parameters
Parameters | Description
settings | The dialogs settings
Description
Remarks

The loading Extension process is time consuming. It is better to set the application instance during other items initilization.

Class

REXContentDialogManager Class

Links
REXContentDialogManager Class, REX.ContentGenerator.Dialog Namespace, REXContentDialogManager Class


REXContentDialogManager.ShowContentDialog Method

REXContentDialogManager.ShowContentDialog Method
REXContentDialogManager Class REX.ContentGenerator.Dialog Namespace Example REXContentDialogManager Class

Loads the ContentGenerator dialog.

C#
public System.Windows.Forms.DialogResult ShowContentDialog(REXContentDialogSettings settings, IWin32Window owner);
Parameters
Parameters | Description
settings | The dialog's settings.
owner | The parent for the window.
Returns

Returns the result of the dialog show.

Description
Example

The example shows how to launch the DRevitContentGenerator dialog and use it as a family browser.

//Manager initialize.
REX.ContentGenerator.Dialog.REXContentDialogManager mng = new REX.ContentGenerator.Dialog.REXContentDialogManager(ThisExtension.Context);

//Settings initialize
//-general
REX.ContentGenerator.Dialog.REXContentDialogSettings settings = new REX.ContentGenerator.Dialog.REXContentDialogSettings();
settings.DialogMode = REX.ContentGenerator.Dialog.EContentDialogMode.MultiSelection;
settings.RegionalSettings = true;
settings.ShowList = true;
settings.Progress = false;
settings.Caption = "Example1";
//-for sections
settings.SectionDBSettings.SelectedElements.Clear();
settings.SectionDBSettings.Visible = true;

//Launching the dialog.
mng.ShowContentDialog(settings, ThisExtension.GetWindowForParent());

//Getting selection.
List<REXFamilyType> families = new List<REXFamilyType>(settings.SectionDBSettings.SelectedElements);

//Disposing dialog.
mng.DisposeContentDialog();
Class

REXContentDialogManager Class

Links
REXContentDialogManager Class, REX.ContentGenerator.Dialog Namespace, Example, REXContentDialogManager Class


REXContentDialogManager.ShowContentDialogParentIntPtr Method

REXContentDialogManager.ShowContentDialogParentIntPtr Method
REXContentDialogManager Class REX.ContentGenerator.Dialog Namespace Example REXContentDialogManager Class

Loads the ContentGenerator dialog.

C#
public bool ShowContentDialogParentIntPtr(REXContentDialogSettings settings, IntPtr owner);
Parameters
Parameters | Description
settings | The dialog's settings.
owner | The parent for the window.
Returns

Returns the result of the dialog show.

Description
Example

The example shows how to launch the DRevitContentGenerator dialog and use it as a family browser.

//Manager initialize.
REX.ContentGenerator.Dialog.REXContentDialogManager mng = new REX.ContentGenerator.Dialog.REXContentDialogManager(ThisExtension.Context);

//Settings initialize
//-general
REX.ContentGenerator.Dialog.REXContentDialogSettings settings = new REX.ContentGenerator.Dialog.REXContentDialogSettings();
settings.DialogMode = REX.ContentGenerator.Dialog.EContentDialogMode.MultiSelection;
settings.RegionalSettings = true;
settings.ShowList = true;
settings.Progress = false;
settings.Caption = "Example1";
//-for sections
settings.SectionDBSettings.SelectedElements.Clear();
settings.SectionDBSettings.Visible = true;

//Launching the dialog.
mng.ShowContentDialog(settings, ThisExtension.GetWindowForParent().Handle);

//Getting selection.
List<REXFamilyType> families = new List<REXFamilyType>(settings.SectionDBSettings.SelectedElements);

//Disposing dialog.
mng.DisposeContentDialog();
Class

REXContentDialogManager Class

Links
REXContentDialogManager Class, REX.ContentGenerator.Dialog Namespace, Example, REXContentDialogManager Class


REXContentDialogSettings Class

REXContentDialogSettings Class
REX.ContentGenerator.Dialog Namespace Legend Members Public Methods REXContentDialogSettings Methods REXContentDialogSettings Properties

Describes settings of the ContentGenerator dialog.

Class Hierarchy
C#
public class REXContentDialogSettings;
Description
Namespace

REX.ContentGenerator.Dialog Namespace

Public Methods
Public Method | Description
REXContentDialogSettings | Initializes a new instance of the REXContentDialogSettings class.
REXContentDialogSettings Methods
REXContentDialogSettings Methods | Description
GetSettings | Gets settings.
GetVisibleCategories | Gets visible categories.
IsVisible | Determines whether the specified category is visible.
SetOneCategoryVisible | Sets visibility of specific category.
REXContentDialogSettings Properties
REXContentDialogSettings Properties | Description
Caption | Gets or sets the caption.
Categories | Gets or sets the settings for all categories.
DialogIcon | Gets or sets the dialog icon.
DialogMode | Gets or sets the dialog mode.
MaterialSettings | Gets the settings for the material category.
Progress | Gets or sets a value indicating whether a progress bar should be visible.
RebarShapeSettings | Gets the settings for the rebar shape category.
RebarTypeSettings | Gets the settings for the rebar type category.
RegionalSettings | Gets or sets a value indicating whether regional settings are supported.
SectionDBSettings | Gets the settings for the database section category..
SectionParamSettings | Gets the settings for the parametric section category.
ShowList | Gets or sets a value indicating whether the list of categories should be visible.
ValidateTypes | Gets or sets a value indicating whether types should be validated.
Links
REX.ContentGenerator.Dialog Namespace, Legend, Members, Public Methods, REXContentDialogSettings Methods, REXContentDialogSettings Properties


REXContentDialogSettings.REXContentDialogSettings Constructor

REXContentDialogSettings.REXContentDialogSettings Constructor
REXContentDialogSettings Class REX.ContentGenerator.Dialog Namespace REXContentDialogSettings Class

Initializes a new instance of the REXContentDialogSettings class.

C#
public REXContentDialogSettings();
Description
Class

REXContentDialogSettings Class

Links
REXContentDialogSettings Class, REX.ContentGenerator.Dialog Namespace, REXContentDialogSettings Class


REXContentDialogSettings.GetSettings Method

REXContentDialogSettings.GetSettings Method
REXContentDialogSettings Class REX.ContentGenerator.Dialog Namespace REXContentDialogSettings Class

Gets settings.

C#
public REXContentDialogCategorySettings GetSettings(ECategoryType category);
Parameters
Parameters | Description
category | The category.
Returns

Returns settings.

Description
Class

REXContentDialogSettings Class

Links
REXContentDialogSettings Class, REX.ContentGenerator.Dialog Namespace, REXContentDialogSettings Class


REXContentDialogSettings.GetVisibleCategories Method

REXContentDialogSettings.GetVisibleCategories Method
REXContentDialogSettings Class REX.ContentGenerator.Dialog Namespace REXContentDialogSettings Class

Gets visible categories.

C#
public List<ECategoryType> GetVisibleCategories();
Returns

Returns categories.

Description
Class

REXContentDialogSettings Class

Links
REXContentDialogSettings Class, REX.ContentGenerator.Dialog Namespace, REXContentDialogSettings Class


REXContentDialogSettings.IsVisible Method

REXContentDialogSettings.IsVisible Method
REXContentDialogSettings Class REX.ContentGenerator.Dialog Namespace REXContentDialogSettings Class

Determines whether the specified category is visible.

C#
public bool IsVisible(ECategoryType category);
Parameters
Parameters | Description
category | The category.
Returns

Returns if the specified category is visible.

Description
Class

REXContentDialogSettings Class

Links
REXContentDialogSettings Class, REX.ContentGenerator.Dialog Namespace, REXContentDialogSettings Class


REXContentDialogSettings.SetOneCategoryVisible Method

REXContentDialogSettings.SetOneCategoryVisible Method
REXContentDialogSettings Class REX.ContentGenerator.Dialog Namespace REXContentDialogSettings Class

Sets visibility of specific category.

C#
public void SetOneCategoryVisible(ECategoryType category);
Parameters
Parameters | Description
category | The category.
Description

Rest of categories are not visible.

Class

REXContentDialogSettings Class

Links
REXContentDialogSettings Class, REX.ContentGenerator.Dialog Namespace, REXContentDialogSettings Class


REXContentDialogSettings.Caption Property

REXContentDialogSettings.Caption Property
REXContentDialogSettings Class REX.ContentGenerator.Dialog Namespace REXContentDialogSettings Class

Gets or sets the caption.

C#
public string Caption;
Description

The caption.

Class

REXContentDialogSettings Class

Links
REXContentDialogSettings Class, REX.ContentGenerator.Dialog Namespace, REXContentDialogSettings Class


REXContentDialogSettings.Categories Property

REXContentDialogSettings.Categories Property
REXContentDialogSettings Class REX.ContentGenerator.Dialog Namespace REXContentDialogSettings Class

Gets or sets the settings for all categories.

C#
public Dictionary<ECategoryType, REXContentDialogCategorySettings> Categories;
Description

The categories.

Class

REXContentDialogSettings Class

Links
REXContentDialogSettings Class, REX.ContentGenerator.Dialog Namespace, REXContentDialogSettings Class


REXContentDialogSettings.DialogIcon Property

REXContentDialogSettings.DialogIcon Property
REXContentDialogSettings Class REX.ContentGenerator.Dialog Namespace REXContentDialogSettings Class

Gets or sets the dialog icon.

C#
public System.Drawing.Icon DialogIcon;
Description

The dialog icon.

Class

REXContentDialogSettings Class

Links
REXContentDialogSettings Class, REX.ContentGenerator.Dialog Namespace, REXContentDialogSettings Class


REXContentDialogSettings.DialogMode Property

REXContentDialogSettings.DialogMode Property
REXContentDialogSettings Class REX.ContentGenerator.Dialog Namespace REXContentDialogSettings Class

Gets or sets the dialog mode.

C#
public EContentDialogMode DialogMode;
Description

The dialog mode.

Class

REXContentDialogSettings Class

Links
REXContentDialogSettings Class, REX.ContentGenerator.Dialog Namespace, REXContentDialogSettings Class


REXContentDialogSettings.MaterialSettings Property

REXContentDialogSettings.MaterialSettings Property
REXContentDialogSettings Class REX.ContentGenerator.Dialog Namespace REXContentDialogSettings Class

Gets the settings for the material category.

C#
public REXContentDialogCategorySettings MaterialSettings;
Description

The settings.

Class

REXContentDialogSettings Class

Links
REXContentDialogSettings Class, REX.ContentGenerator.Dialog Namespace, REXContentDialogSettings Class


REXContentDialogSettings.Progress Property

REXContentDialogSettings.Progress Property
REXContentDialogSettings Class REX.ContentGenerator.Dialog Namespace REXContentDialogSettings Class

Gets or sets a value indicating whether a progress bar should be visible.

C#
public bool Progress;
Description

True if the progress bar is visible; otherwise, false.

Class

REXContentDialogSettings Class

Links
REXContentDialogSettings Class, REX.ContentGenerator.Dialog Namespace, REXContentDialogSettings Class


REXContentDialogSettings.RebarShapeSettings Property

REXContentDialogSettings.RebarShapeSettings Property
REXContentDialogSettings Class REX.ContentGenerator.Dialog Namespace REXContentDialogSettings Class

Gets the settings for the rebar shape category.

C#
public REXContentDialogCategorySettings RebarShapeSettings;
Description

The settings.

Class

REXContentDialogSettings Class

Links
REXContentDialogSettings Class, REX.ContentGenerator.Dialog Namespace, REXContentDialogSettings Class


REXContentDialogSettings.RebarTypeSettings Property

REXContentDialogSettings.RebarTypeSettings Property
REXContentDialogSettings Class REX.ContentGenerator.Dialog Namespace REXContentDialogSettings Class

Gets the settings for the rebar type category.

C#
public REXContentDialogCategorySettings RebarTypeSettings;
Description

The settings.

Class

REXContentDialogSettings Class

Links
REXContentDialogSettings Class, REX.ContentGenerator.Dialog Namespace, REXContentDialogSettings Class


REXContentDialogSettings.RegionalSettings Property

REXContentDialogSettings.RegionalSettings Property
REXContentDialogSettings Class REX.ContentGenerator.Dialog Namespace REXContentDialogSettings Class

Gets or sets a value indicating whether regional settings are supported.

C#
public bool RegionalSettings;
Description

True if regional settings supported; otherwise, false.

Class

REXContentDialogSettings Class

Links
REXContentDialogSettings Class, REX.ContentGenerator.Dialog Namespace, REXContentDialogSettings Class


REXContentDialogSettings.SectionDBSettings Property

REXContentDialogSettings.SectionDBSettings Property
REXContentDialogSettings Class REX.ContentGenerator.Dialog Namespace REXContentDialogSettings Class

Gets the settings for the database section category..

C#
public REXContentDialogCategorySettings SectionDBSettings;
Description

The settings.

Class

REXContentDialogSettings Class

Links
REXContentDialogSettings Class, REX.ContentGenerator.Dialog Namespace, REXContentDialogSettings Class


REXContentDialogSettings.SectionParamSettings Property

REXContentDialogSettings.SectionParamSettings Property
REXContentDialogSettings Class REX.ContentGenerator.Dialog Namespace REXContentDialogSettings Class

Gets the settings for the parametric section category.

C#
public REXContentDialogCategorySettings SectionParamSettings;
Description

The settings.

Class

REXContentDialogSettings Class

Links
REXContentDialogSettings Class, REX.ContentGenerator.Dialog Namespace, REXContentDialogSettings Class


REXContentDialogSettings.ShowList Property

REXContentDialogSettings.ShowList Property
REXContentDialogSettings Class REX.ContentGenerator.Dialog Namespace REXContentDialogSettings Class

Gets or sets a value indicating whether the list of categories should be visible.

C#
public bool ShowList;
Description

True if the list is visible; otherwise, false.

Class

REXContentDialogSettings Class

Links
REXContentDialogSettings Class, REX.ContentGenerator.Dialog Namespace, REXContentDialogSettings Class


REXContentDialogSettings.ValidateTypes Property

REXContentDialogSettings.ValidateTypes Property
REXContentDialogSettings Class REX.ContentGenerator.Dialog Namespace REXContentDialogSettings Class

Gets or sets a value indicating whether types should be validated.

C#
public bool ValidateTypes;
Description

True if validate types; otherwise, false.

Class

REXContentDialogSettings Class

Links
REXContentDialogSettings Class, REX.ContentGenerator.Dialog Namespace, REXContentDialogSettings Class


REX.ContentGenerator.Dialog.EContentDialogMode Enumeration

REX.ContentGenerator.Dialog.EContentDialogMode Enumeration
REX.ContentGenerator.Dialog Namespace

Describes modes in which the ContentGenerator dialog may be run.

C#
public enum EContentDialogMode {
  Generator,
  Selection,
  MultiSelection
}
Members
Members | Description
Generator | Generation.
Selection | Single selection.
MultiSelection | Multiple selection.
Description
Namespace

REX.ContentGenerator.Dialog Namespace

Links
REX.ContentGenerator.Dialog Namespace
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REX.ContentGenerator.Families Namespace

Previous | Next
REX.ContentGenerator.Families Namespace
Legend Classes Structs, Records, Enums

This is namespace REX.ContentGenerator.Families.

Classes
Class | Description
REXCustomDescription | Base class for all custom description types.
REXDBDescription | Base class for all descriptions of objects in REXFamilyType which were created based on a database.
REXDescription | Base class for all descriptions of objects in REXFamilyType.
REXFamilyType | The base class for all content types supported by the REXContentGenerator.
REXFamilyType_Custom | Base class for all custom types.
REXFamilyType_DBSection | Represents a database section.
REXFamilyType_Label | Represents labels.
REXFamilyType_Material | Represents a material element.
REXFamilyType_ParamSection | Represents a parametric section.
REXFamilyType_Section | Base class for all sections.
REXLabelDescription | Represents label's parameters.
REXMaterialCharacteristics | Represents characteristics of a material.
REXMaterialDBDescription | Represents description of the material.
REXMaterialProperties | Represents properties of the material.
REXParamDescription | Base class for all descriptions of objects in REXFamilyType which were created based on a parametric description (not database).
REXSectionDBCharacteristics | Describes geometry characteristics of a database section.
REXSectionDBDescription | Represents parameters of the database section.
REXSectionDBDimensions | Describes dimensions of the database section.
REXSectionDBProperties | Describes properties of the database section.
REXSectionParamCharacteristics | Describes characteristics of the parametric section.
REXSectionParamDescription | Represents parameters of the parametric section.
REXSectionParamDimensions | Desribes dimentsions of the parametric section.
SerializableObject | Allows to save an object into a stream.
Structs, Records, Enums
Struct, Record, Enum | Description
ECategoryType | Describes the category of the element
EDBSectionType | Describes the type of the database section.
EElementType | Describes the type of the element
EMaterial | Describes the type of material
ESectionType |
Links
Legend, Classes, Structs, Records, Enums
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXCustomDescription Class

REXCustomDescription Class
REX.ContentGenerator.Families Namespace Legend Members Public Methods REXCustomDescription Methods

Base class for all custom description types.

Class Hierarchy
C#
[Serializable()]
public abstract class REXCustomDescription : REXDBDescription;
Description
Namespace

REX.ContentGenerator.Families Namespace

Public Methods
Public Method | Description
REXCustomDescription | Initializes a new instance of the REXCustomDescription class.
REXCustomDescription | Initializes a new instance of the REXCustomDescription class.
REXCustomDescription Methods
REXCustomDescription Methods | Description
Clone | Clones this instance.
GetTypeName | Gets the name of the type.
Links
REX.ContentGenerator.Families Namespace, Legend, Members, Public Methods, REXCustomDescription Methods


REXCustomDescription.REXCustomDescription Constructor ()

REXCustomDescription.REXCustomDescription Constructor ()
REXCustomDescription Class REX.ContentGenerator.Families Namespace REXCustomDescription Class

Initializes a new instance of the REXCustomDescription class.

C#
public REXCustomDescription();
Description
Class

REXCustomDescription Class

Links
REXCustomDescription Class, REX.ContentGenerator.Families Namespace, REXCustomDescription Class


REXCustomDescription.REXCustomDescription Constructor (REXCustomDescription)

REXCustomDescription.REXCustomDescription Constructor (REXCustomDescription)
REXCustomDescription Class REX.ContentGenerator.Families Namespace REXCustomDescription Class

Initializes a new instance of the REXCustomDescription class.

C#
public REXCustomDescription(REXCustomDescription pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

REXCustomDescription Class

Links
REXCustomDescription Class, REX.ContentGenerator.Families Namespace, REXCustomDescription Class


REXCustomDescription.Clone Method

REXCustomDescription.Clone Method
REXCustomDescription Class REX.ContentGenerator.Families Namespace REXCustomDescription Class

Clones this instance.

C#
public abstract override object Clone();
Returns

New instance

Description
Class

REXCustomDescription Class

Links
REXCustomDescription Class, REX.ContentGenerator.Families Namespace, REXCustomDescription Class


REXCustomDescription.GetTypeName Method

REXCustomDescription.GetTypeName Method
REXCustomDescription Class REX.ContentGenerator.Families Namespace REXCustomDescription Class

Gets the name of the type.

C#
public abstract string GetTypeName();
Description
Class

REXCustomDescription Class

Links
REXCustomDescription Class, REX.ContentGenerator.Families Namespace, REXCustomDescription Class


REXDBDescription Class

REXDBDescription Class
REX.ContentGenerator.Families Namespace Legend Members Public Methods REXDBDescription Methods REXDBDescription Properties

Base class for all descriptions of objects in REXFamilyType which were created based on a database.

Class Hierarchy
C#
[Serializable()]
public class REXDBDescription : REXDescription;
Description
Namespace

REX.ContentGenerator.Families Namespace

Public Methods
Public Method | Description
REXDBDescription | Initializes a new instance of the REXDBDescription class.
REXDBDescription | Initializes a new instance of the REXDBDescription class.
REXDBDescription | Initializes a new instance of the REXDBDescription class.
REXDBDescription | Initializes a new instance of the REXDBDescription class.
REXDBDescription | Initializes a new instance of the REXDBDescription class.
REXDBDescription | Initializes a new instance of the REXDBDescription class.
REXDBDescription Methods
REXDBDescription Methods | Description
Clone | Creates a new object that is a copy of the current instance.
CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
GetValue | Gets the value.
RecalculateParameters | Recalculates the parameters.
SetValue | Sets the value.
REXDBDescription Properties
REXDBDescription Properties | Description
DBName | Gets or sets the name of the DB.
Directory | Gets or sets the directory.
Links
REX.ContentGenerator.Families Namespace, Legend, Members, Public Methods, REXDBDescription Methods, REXDBDescription Properties


REXDBDescription.REXDBDescription Constructor ()

REXDBDescription.REXDBDescription Constructor ()
REXDBDescription Class REX.ContentGenerator.Families Namespace REXDBDescription Class

Initializes a new instance of the REXDBDescription class.

C#
public REXDBDescription();
Description
Class

REXDBDescription Class

Links
REXDBDescription Class, REX.ContentGenerator.Families Namespace, REXDBDescription Class


REXDBDescription.REXDBDescription Constructor (DTableDataObjectCollection)

REXDBDescription.REXDBDescription Constructor (DTableDataObjectCollection)
REXDBDescription Class REX.ContentGenerator.Families Namespace REXDBDescription Class

Initializes a new instance of the REXDBDescription class.

C#
public REXDBDescription(DTableDataObjectCollection pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

REXDBDescription Class

Links
REXDBDescription Class, REX.ContentGenerator.Families Namespace, REXDBDescription Class


REXDBDescription.REXDBDescription Constructor (REXDBDescription)

REXDBDescription.REXDBDescription Constructor (REXDBDescription)
REXDBDescription Class REX.ContentGenerator.Families Namespace REXDBDescription Class

Initializes a new instance of the REXDBDescription class.

C#
public REXDBDescription(REXDBDescription pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

REXDBDescription Class

Links
REXDBDescription Class, REX.ContentGenerator.Families Namespace, REXDBDescription Class


REXDBDescription.REXDBDescription Constructor (string)

REXDBDescription.REXDBDescription Constructor (string)
REXDBDescription Class REX.ContentGenerator.Families Namespace REXDBDescription Class

Initializes a new instance of the REXDBDescription class.

C#
public REXDBDescription(string dbName);
Parameters
Parameters | Description
dbName | Name of the database.
Description
Class

REXDBDescription Class

Links
REXDBDescription Class, REX.ContentGenerator.Families Namespace, REXDBDescription Class


REXDBDescription.REXDBDescription Constructor (string, string, DTableDataObjectCollection)

REXDBDescription.REXDBDescription Constructor (string, string, DTableDataObjectCollection)
REXDBDescription Class REX.ContentGenerator.Families Namespace REXDBDescription Class

Initializes a new instance of the REXDBDescription class.

C#
public REXDBDescription(string dir, string dbName, DTableDataObjectCollection col);
Parameters
Parameters | Description
dir | The directory.
dbName | The name of the database.
col | The collection.
Description
Class

REXDBDescription Class

Links
REXDBDescription Class, REX.ContentGenerator.Families Namespace, REXDBDescription Class


REXDBDescription.REXDBDescription Constructor (string, string, System.Data.DataRow)

REXDBDescription.REXDBDescription Constructor (string, string, System.Data.DataRow)
REXDBDescription Class REX.ContentGenerator.Families Namespace REXDBDescription Class

Initializes a new instance of the REXDBDescription class.

C#
public REXDBDescription(string dir, string dbName, System.Data.DataRow row);
Parameters
Parameters | Description
dir | The directory.
dbName | The name of the database.
row | The row.
Description
Class

REXDBDescription Class

Links
REXDBDescription Class, REX.ContentGenerator.Families Namespace, REXDBDescription Class


REXDBDescription.Clone Method

REXDBDescription.Clone Method
REXDBDescription Class REX.ContentGenerator.Families Namespace REXDBDescription Class

Creates a new object that is a copy of the current instance.

C#
public override object Clone();
Returns

A new object that is a copy of this instance.

Description
Class

REXDBDescription Class

Links
REXDBDescription Class, REX.ContentGenerator.Families Namespace, REXDBDescription Class


REXDBDescription.CompareTo Method

REXDBDescription.CompareTo Method
REXDBDescription Class REX.ContentGenerator.Families Namespace REXDBDescription Class

Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.

C#
public override int CompareTo(object obj);
Parameters
Parameters | Description
obj | An object to compare with this instance.
Returns

Returns a result of the comparison.

Description
Class

REXDBDescription Class

Links
REXDBDescription Class, REX.ContentGenerator.Families Namespace, REXDBDescription Class


REXDBDescription.GetValue Method

REXDBDescription.GetValue Method
REXDBDescription Class REX.ContentGenerator.Families Namespace REXDBDescription Class

Gets the value.

C#
public override object GetValue(string name);
Parameters
Parameters | Description
name | The name of parameter.
Returns

The value of the specified parameter.

Description
Class

REXDBDescription Class

Links
REXDBDescription Class, REX.ContentGenerator.Families Namespace, REXDBDescription Class


REXDBDescription.RecalculateParameters Method

REXDBDescription.RecalculateParameters Method
REXDBDescription Class REX.ContentGenerator.Families Namespace REXDBDescription Class

Recalculates the parameters.

C#
public override void RecalculateParameters(double coeff);
Parameters
Parameters | Description
coeff | The coefficient.
Description
Class

REXDBDescription Class

Links
REXDBDescription Class, REX.ContentGenerator.Families Namespace, REXDBDescription Class


REXDBDescription.SetValue Method

REXDBDescription.SetValue Method
REXDBDescription Class REX.ContentGenerator.Families Namespace REXDBDescription Class

Sets the value.

C#
public override bool SetValue(string name, object val);
Parameters
Parameters | Description
name | The name.
val | The value.
Returns

True if value set; otherwise false.

Description
Class

REXDBDescription Class

Links
REXDBDescription Class, REX.ContentGenerator.Families Namespace, REXDBDescription Class


REXDBDescription.DBName Property

REXDBDescription.DBName Property
REXDBDescription Class REX.ContentGenerator.Families Namespace REXDBDescription Class

Gets or sets the name of the DB.

C#
public string DBName;
Description

The name of the DB.

Class

REXDBDescription Class

Links
REXDBDescription Class, REX.ContentGenerator.Families Namespace, REXDBDescription Class


REXDBDescription.Directory Property

REXDBDescription.Directory Property
REXDBDescription Class REX.ContentGenerator.Families Namespace REXDBDescription Class

Gets or sets the directory.

C#
public string Directory;
Description

The directory.

Class

REXDBDescription Class

Links
REXDBDescription Class, REX.ContentGenerator.Families Namespace, REXDBDescription Class


REXDescription Class

REXDescription Class
REX.ContentGenerator.Families Namespace Legend Members Public Methods REXDescription Methods

Base class for all descriptions of objects in REXFamilyType.

Class Hierarchy
C#
[Serializable()]
public abstract class REXDescription : SerializableObject, System.Collections.IEnumerable, IComparable, ICloneable;
Description
Namespace

REX.ContentGenerator.Families Namespace

Public Methods
Public Method | Description
REXDescription | Initializes a new instance of the REXDescription class.
REXDescription | Initializes a new instance of the REXDescription class.
REXDescription | Initializes a new instance of the REXDescription class.
REXDescription | Initializes a new instance of the REXDescription class.
REXDescription Methods
REXDescription Methods | Description
Clone | Creates a new object that is a copy of the current instance.
CompareProperty | This is CompareProperty, a member of class REXDescription.
CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
GetEnumerator | Returns an enumerator that iterates through a collection.
GetValue | Gets the value.
RecalculateParameters | Recalculates the parameters.
Set2Null | Sets all values to default one.
SetValue | Sets the value.
Links
REX.ContentGenerator.Families Namespace, Legend, Members, Public Methods, REXDescription Methods


REXDescription.REXDescription Constructor ()

REXDescription.REXDescription Constructor ()
REXDescription Class REX.ContentGenerator.Families Namespace REXDescription Class

Initializes a new instance of the REXDescription class.

C#
public REXDescription();
Description
Class

REXDescription Class

Links
REXDescription Class, REX.ContentGenerator.Families Namespace, REXDescription Class


REXDescription.REXDescription Constructor (DTableDataObjectCollection)

REXDescription.REXDescription Constructor (DTableDataObjectCollection)
REXDescription Class REX.ContentGenerator.Families Namespace REXDescription Class

Initializes a new instance of the REXDescription class.

C#
public REXDescription(DTableDataObjectCollection pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

REXDescription Class

Links
REXDescription Class, REX.ContentGenerator.Families Namespace, REXDescription Class


REXDescription.REXDescription Constructor (REXDescription)

REXDescription.REXDescription Constructor (REXDescription)
REXDescription Class REX.ContentGenerator.Families Namespace REXDescription Class

Initializes a new instance of the REXDescription class.

C#
public REXDescription(REXDescription pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

REXDescription Class

Links
REXDescription Class, REX.ContentGenerator.Families Namespace, REXDescription Class


REXDescription.REXDescription Constructor (System.Data.DataRow)

REXDescription.REXDescription Constructor (System.Data.DataRow)
REXDescription Class REX.ContentGenerator.Families Namespace REXDescription Class

Initializes a new instance of the REXDescription class.

C#
public REXDescription(System.Data.DataRow pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

REXDescription Class

Links
REXDescription Class, REX.ContentGenerator.Families Namespace, REXDescription Class


REXDescription.Clone Method

REXDescription.Clone Method
REXDescription Class REX.ContentGenerator.Families Namespace REXDescription Class

Creates a new object that is a copy of the current instance.

C#
public abstract object Clone();
Returns

A new object that is a copy of this instance.

Description
Class

REXDescription Class

Links
REXDescription Class, REX.ContentGenerator.Families Namespace, REXDescription Class


REXDescription.CompareProperty Method

REXDescription.CompareProperty Method
REXDescription Class REX.ContentGenerator.Families Namespace REXDescription Class

This is CompareProperty, a member of class REXDescription.

C#
public int CompareProperty(string name, REXDescription desc);
Class

REXDescription Class

Links
REXDescription Class, REX.ContentGenerator.Families Namespace, REXDescription Class


REXDescription.CompareTo Method

REXDescription.CompareTo Method
REXDescription Class REX.ContentGenerator.Families Namespace REXDescription Class

Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.

C#
public virtual int CompareTo(object obj);
Parameters
Parameters | Description
obj | An object to compare with this instance.
Returns

Returns a result of the comparison.

Description
Class

REXDescription Class

Links
REXDescription Class, REX.ContentGenerator.Families Namespace, REXDescription Class


REXDescription.GetEnumerator Method

REXDescription.GetEnumerator Method
REXDescription Class REX.ContentGenerator.Families Namespace REXDescription Class

Returns an enumerator that iterates through a collection.

C#
public System.Collections.IEnumerator GetEnumerator();
Description
Class

REXDescription Class

Links
REXDescription Class, REX.ContentGenerator.Families Namespace, REXDescription Class


REXDescription.GetValue Method

REXDescription.GetValue Method
REXDescription Class REX.ContentGenerator.Families Namespace REXDescription Class

Gets the value.

C#
public virtual object GetValue(string name);
Parameters
Parameters | Description
name | The name.
Returns

The value.

Description
Class

REXDescription Class

Links
REXDescription Class, REX.ContentGenerator.Families Namespace, REXDescription Class


REXDescription.RecalculateParameters Method

REXDescription.RecalculateParameters Method
REXDescription Class REX.ContentGenerator.Families Namespace REXDescription Class

Recalculates the parameters.

C#
public virtual void RecalculateParameters(double coeff);
Parameters
Parameters | Description
coeff | The coefficient.
Description
Class

REXDescription Class

Links
REXDescription Class, REX.ContentGenerator.Families Namespace, REXDescription Class


REXDescription.Set2Null Method

REXDescription.Set2Null Method
REXDescription Class REX.ContentGenerator.Families Namespace REXDescription Class

Sets all values to default one.

C#
public virtual void Set2Null();
Description
Class

REXDescription Class

Links
REXDescription Class, REX.ContentGenerator.Families Namespace, REXDescription Class


REXDescription.SetValue Method

REXDescription.SetValue Method
REXDescription Class REX.ContentGenerator.Families Namespace REXDescription Class

Sets the value.

C#
public virtual bool SetValue(string name, object val);
Parameters
Parameters | Description
name | The name.
val | The value.
Returns

Returns if action succeeded.

Description
Class

REXDescription Class

Links
REXDescription Class, REX.ContentGenerator.Families Namespace, REXDescription Class


REXFamilyType Class

REXFamilyType Class
REX.ContentGenerator.Families Namespace Legend Members Public Methods REXFamilyType Methods REXFamilyType Properties

The base class for all content types supported by the REXContentGenerator.

Class Hierarchy
C#
[Serializable()]
public class REXFamilyType : SerializableObject, IComparable, ICloneable;
Description
Remarks

The REXFamilyType is the center point of the REX.ContentGenerator component. It is an intermediate container which represents the specified type of the element. Converters communicate with each other using this description and don’t have to know anything about themself.

Namespace

REX.ContentGenerator.Families Namespace

Public Methods
Public Method | Description
REXFamilyType | Initializes a new instance of the REXFamilyType class.
REXFamilyType | Initializes a new instance of the REXFamilyType class.
REXFamilyType | Initializes a new instance of the REXFamilyType class.
REXFamilyType Methods
REXFamilyType Methods | Description
Clone | Creates a new object that is a copy of the current instance.
CompareTo | Compares the current object with the other object.
REXFamilyType Properties
REXFamilyType Properties | Description
CategoryType | Gets the category.
Certified | Gets or sets a value indicating whether the element is certified.
Description | Gets or sets the description of the object.
Element | Gets or sets the element.
ElementType | Gets or sets the type of the element.
FamilyName | Gets or sets the name of the family.
Mapped | If the REXFamilyType is mapped.
Material | Gets or sets the material.
TypeName | Gets or sets the name of the type.
UniqueID | The unique id.
Links
REX.ContentGenerator.Families Namespace, Legend, Members, Public Methods, REXFamilyType Methods, REXFamilyType Properties


REXFamilyType.REXFamilyType Constructor ()

REXFamilyType.REXFamilyType Constructor ()
REXFamilyType Class REX.ContentGenerator.Families Namespace REXFamilyType Class

Initializes a new instance of the REXFamilyType class.

C#
public REXFamilyType();
Description
Class

REXFamilyType Class

Links
REXFamilyType Class, REX.ContentGenerator.Families Namespace, REXFamilyType Class


REXFamilyType.REXFamilyType Constructor (REXFamilyType)

REXFamilyType.REXFamilyType Constructor (REXFamilyType)
REXFamilyType Class REX.ContentGenerator.Families Namespace REXFamilyType Class

Initializes a new instance of the REXFamilyType class.

C#
public REXFamilyType(REXFamilyType pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

REXFamilyType Class

Links
REXFamilyType Class, REX.ContentGenerator.Families Namespace, REXFamilyType Class


REXFamilyType.REXFamilyType Constructor (string, string, REX.ContentGenerator.Families.EElementType, bool, EMaterial)

REXFamilyType.REXFamilyType Constructor (string, string, REX.ContentGenerator.Families.EElementType, bool, EMaterial)
REXFamilyType Class REX.ContentGenerator.Families Namespace REXFamilyType Class

Initializes a new instance of the REXFamilyType class.

C#
public REXFamilyType(string familyName, string typeName, REX.ContentGenerator.Families.EElementType category, bool certified, EMaterial material);
Parameters
Parameters | Description
familyName | The name of the family.
typeName | The name of the type.
category | The category.
certified | Indicates whether the object is certified.
material | The material.
Description
Class

REXFamilyType Class

Links
REXFamilyType Class, REX.ContentGenerator.Families Namespace, REXFamilyType Class


REXFamilyType.Clone Method

REXFamilyType.Clone Method
REXFamilyType Class REX.ContentGenerator.Families Namespace REXFamilyType Class

Creates a new object that is a copy of the current instance.

C#
public virtual object Clone();
Returns

A new object that is a copy of this instance.

Description
Class

REXFamilyType Class

Links
REXFamilyType Class, REX.ContentGenerator.Families Namespace, REXFamilyType Class


REXFamilyType.CompareTo Method

REXFamilyType.CompareTo Method
REXFamilyType Class REX.ContentGenerator.Families Namespace REXFamilyType Class

Compares the current object with the other object.

C#
public virtual int CompareTo(object obj);
Parameters
Parameters | Description
obj | The object.
Returns

Returns the result of the comparison.

Description
Class

REXFamilyType Class

Links
REXFamilyType Class, REX.ContentGenerator.Families Namespace, REXFamilyType Class


REXFamilyType.CategoryType Property

REXFamilyType.CategoryType Property
REXFamilyType Class REX.ContentGenerator.Families Namespace REXFamilyType Class

Gets the category.

C#
public virtual ECategoryType CategoryType;
Description

The category.

Class

REXFamilyType Class

Links
REXFamilyType Class, REX.ContentGenerator.Families Namespace, REXFamilyType Class


REXFamilyType.Certified Property

REXFamilyType.Certified Property
REXFamilyType Class REX.ContentGenerator.Families Namespace REXFamilyType Class

Gets or sets a value indicating whether the element is certified.

C#
public bool Certified;
Description

True if certified; otherwise, false.

Class

REXFamilyType Class

Links
REXFamilyType Class, REX.ContentGenerator.Families Namespace, REXFamilyType Class


REXFamilyType.Description Property

REXFamilyType.Description Property
REXFamilyType Class REX.ContentGenerator.Families Namespace REXFamilyType Class

Gets or sets the description of the object.

C#
public REXDescription Description;
Description

The description.

Class

REXFamilyType Class

Links
REXFamilyType Class, REX.ContentGenerator.Families Namespace, REXFamilyType Class


REXFamilyType.Element Property

REXFamilyType.Element Property
REXFamilyType Class REX.ContentGenerator.Families Namespace REXFamilyType Class

Gets or sets the element.

C#
public object Element;
Description

The element.

Class

REXFamilyType Class

Links
REXFamilyType Class, REX.ContentGenerator.Families Namespace, REXFamilyType Class


REXFamilyType.ElementType Property

REXFamilyType.ElementType Property
REXFamilyType Class REX.ContentGenerator.Families Namespace REXFamilyType Class

Gets or sets the type of the element.

C#
public REX.ContentGenerator.Families.EElementType ElementType;
Description

The type of the element.

Class

REXFamilyType Class

Links
REXFamilyType Class, REX.ContentGenerator.Families Namespace, REXFamilyType Class


REXFamilyType.FamilyName Property

REXFamilyType.FamilyName Property
REXFamilyType Class REX.ContentGenerator.Families Namespace REXFamilyType Class

Gets or sets the name of the family.

C#
public string FamilyName;
Description

The name of the family.

Class

REXFamilyType Class

Links
REXFamilyType Class, REX.ContentGenerator.Families Namespace, REXFamilyType Class


REXFamilyType.Mapped Property

REXFamilyType.Mapped Property
REXFamilyType Class REX.ContentGenerator.Families Namespace REXFamilyType Class

If the REXFamilyType is mapped.

C#
public bool Mapped;
Description
Class

REXFamilyType Class

Links
REXFamilyType Class, REX.ContentGenerator.Families Namespace, REXFamilyType Class


REXFamilyType.Material Property

REXFamilyType.Material Property
REXFamilyType Class REX.ContentGenerator.Families Namespace REXFamilyType Class

Gets or sets the material.

C#
public REX.ContentGenerator.Families.EMaterial Material;
Description

The material.

Class

REXFamilyType Class

Links
REXFamilyType Class, REX.ContentGenerator.Families Namespace, REXFamilyType Class


REXFamilyType.TypeName Property

REXFamilyType.TypeName Property
REXFamilyType Class REX.ContentGenerator.Families Namespace REXFamilyType Class

Gets or sets the name of the type.

C#
public string TypeName;
Description

The name of the type.

Class

REXFamilyType Class

Links
REXFamilyType Class, REX.ContentGenerator.Families Namespace, REXFamilyType Class


REXFamilyType.UniqueID Property

REXFamilyType.UniqueID Property
REXFamilyType Class REX.ContentGenerator.Families Namespace REXFamilyType Class

The unique id.

C#
public string UniqueID;
Description
Class

REXFamilyType Class

Links
REXFamilyType Class, REX.ContentGenerator.Families Namespace, REXFamilyType Class


REXFamilyType_Custom Class

REXFamilyType_Custom Class
REX.ContentGenerator.Families Namespace Legend Members Public Methods REXFamilyType_Custom Methods REXFamilyType_Custom Properties

Base class for all custom types.

Class Hierarchy
C#
[Serializable()]
public abstract class REXFamilyType_Custom : REXFamilyType;
Description
Namespace

REX.ContentGenerator.Families Namespace

Public Methods
Public Method | Description
REXFamilyType_Custom | Initializes a new instance of the REXFamilyType_Custom class.
REXFamilyType_Custom | Initializes a new instance of the REXFamilyType_Custom class.
REXFamilyType_Custom | Initializes a new instance of the REXFamilyType_Custom class.
REXFamilyType_Custom Methods
REXFamilyType_Custom Methods | Description
Clone | Creates a new object that is a copy of the current instance.
REXFamilyType_Custom Properties
REXFamilyType_Custom Properties | Description
CategoryType | Gets the category.
CustomCategory | Gets the custom category.
CustomParameters | Gets the custom parameters.
Links
REX.ContentGenerator.Families Namespace, Legend, Members, Public Methods, REXFamilyType_Custom Methods, REXFamilyType_Custom Properties


REXFamilyType_Custom.REXFamilyType_Custom Constructor ()

REXFamilyType_Custom.REXFamilyType_Custom Constructor ()
REXFamilyType_Custom Class REX.ContentGenerator.Families Namespace REXFamilyType_Custom Class

Initializes a new instance of the REXFamilyType_Custom class.

C#
public REXFamilyType_Custom();
Description
Class

REXFamilyType_Custom Class

Links
REXFamilyType_Custom Class, REX.ContentGenerator.Families Namespace, REXFamilyType_Custom Class


REXFamilyType_Custom.REXFamilyType_Custom Constructor (REXFamilyType_Custom)

REXFamilyType_Custom.REXFamilyType_Custom Constructor (REXFamilyType_Custom)
REXFamilyType_Custom Class REX.ContentGenerator.Families Namespace REXFamilyType_Custom Class

Initializes a new instance of the REXFamilyType_Custom class.

C#
public REXFamilyType_Custom(REXFamilyType_Custom pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

REXFamilyType_Custom Class

Links
REXFamilyType_Custom Class, REX.ContentGenerator.Families Namespace, REXFamilyType_Custom Class


REXFamilyType_Custom.REXFamilyType_Custom Constructor (string, string, REX.ContentGenerator.Families.EElementType, bool, EMaterial)

REXFamilyType_Custom.REXFamilyType_Custom Constructor (string, string, REX.ContentGenerator.Families.EElementType, bool, EMaterial)
REXFamilyType_Custom Class REX.ContentGenerator.Families Namespace REXFamilyType_Custom Class

Initializes a new instance of the REXFamilyType_Custom class.

C#
public REXFamilyType_Custom(string familyName, string typeName, REX.ContentGenerator.Families.EElementType category, bool certified, EMaterial mat);
Parameters
Parameters | Description
familyName | The name of the family.
typeName | The name of the type.
category | The category.
certified | Indicates whether the element is certified.
mat | The material.
Description
Class

REXFamilyType_Custom Class

Links
REXFamilyType_Custom Class, REX.ContentGenerator.Families Namespace, REXFamilyType_Custom Class


REXFamilyType_Custom.Clone Method

REXFamilyType_Custom.Clone Method
REXFamilyType_Custom Class REX.ContentGenerator.Families Namespace REXFamilyType_Custom Class

Creates a new object that is a copy of the current instance.

C#
public override abstract object Clone();
Returns

A new object that is a copy of this instance.

Description
Class

REXFamilyType_Custom Class

Links
REXFamilyType_Custom Class, REX.ContentGenerator.Families Namespace, REXFamilyType_Custom Class


REXFamilyType_Custom.CategoryType Property

REXFamilyType_Custom.CategoryType Property
REXFamilyType_Custom Class REX.ContentGenerator.Families Namespace REXFamilyType_Custom Class

Gets the category.

C#
public override ECategoryType CategoryType;
Description

The category.

Class

REXFamilyType_Custom Class

Links
REXFamilyType_Custom Class, REX.ContentGenerator.Families Namespace, REXFamilyType_Custom Class


REXFamilyType_Custom.CustomCategory Property

REXFamilyType_Custom.CustomCategory Property
REXFamilyType_Custom Class REX.ContentGenerator.Families Namespace REXFamilyType_Custom Class

Gets the custom category.

C#
public abstract string CustomCategory;
Description

The custom category.

Class

REXFamilyType_Custom Class

Links
REXFamilyType_Custom Class, REX.ContentGenerator.Families Namespace, REXFamilyType_Custom Class


REXFamilyType_Custom.CustomParameters Property

REXFamilyType_Custom.CustomParameters Property
REXFamilyType_Custom Class REX.ContentGenerator.Families Namespace REXFamilyType_Custom Class

Gets the custom parameters.

C#
public REXCustomDescription CustomParameters;
Description

The custom parameters.

Class

REXFamilyType_Custom Class

Links
REXFamilyType_Custom Class, REX.ContentGenerator.Families Namespace, REXFamilyType_Custom Class


REXFamilyType_DBSection Class

REXFamilyType_DBSection Class
REX.ContentGenerator.Families Namespace Legend Members Public Methods REXFamilyType_DBSection Methods REXFamilyType_DBSection Properties

Represents a database section.

Class Hierarchy
C#
[Serializable()]
public class REXFamilyType_DBSection : REXFamilyType_Section;
Description
Namespace

REX.ContentGenerator.Families Namespace

Public Methods
Public Method | Description
REXFamilyType_DBSection | Initializes a new instance of the REXFamilyType_DBSection class.
REXFamilyType_DBSection | Initializes a new instance of the REXFamilyType_DBSection class.
REXFamilyType_DBSection | Initializes a new instance of the REXFamilyType_DBSection class.
REXFamilyType_DBSection Methods
REXFamilyType_DBSection Methods | Description
Clone | Creates a new object that is a copy of the current instance.
CompareTo | Compares the current object with the other object.
REXFamilyType_DBSection Properties
REXFamilyType_DBSection Properties | Description
CategoryType | Gets the category.
Parameters | Gets or sets the parameters.
Links
REX.ContentGenerator.Families Namespace, Legend, Members, Public Methods, REXFamilyType_DBSection Methods, REXFamilyType_DBSection Properties


REXFamilyType_DBSection.REXFamilyType_DBSection Constructor ()

REXFamilyType_DBSection.REXFamilyType_DBSection Constructor ()
REXFamilyType_DBSection Class REX.ContentGenerator.Families Namespace REXFamilyType_DBSection Class

Initializes a new instance of the REXFamilyType_DBSection class.

C#
public REXFamilyType_DBSection();
Description
Class

REXFamilyType_DBSection Class

Links
REXFamilyType_DBSection Class, REX.ContentGenerator.Families Namespace, REXFamilyType_DBSection Class


REXFamilyType_DBSection.REXFamilyType_DBSection Constructor (REXFamilyType_DBSection)

REXFamilyType_DBSection.REXFamilyType_DBSection Constructor (REXFamilyType_DBSection)
REXFamilyType_DBSection Class REX.ContentGenerator.Families Namespace REXFamilyType_DBSection Class

Initializes a new instance of the REXFamilyType_DBSection class.

C#
public REXFamilyType_DBSection(REXFamilyType_DBSection pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

REXFamilyType_DBSection Class

Links
REXFamilyType_DBSection Class, REX.ContentGenerator.Families Namespace, REXFamilyType_DBSection Class


REXFamilyType_DBSection.REXFamilyType_DBSection Constructor (string, string, REX.ContentGenerator.Families.EElementType, bool, EMaterial)

REXFamilyType_DBSection.REXFamilyType_DBSection Constructor (string, string, REX.ContentGenerator.Families.EElementType, bool, EMaterial)
REXFamilyType_DBSection Class REX.ContentGenerator.Families Namespace REXFamilyType_DBSection Class

Initializes a new instance of the REXFamilyType_DBSection class.

C#
public REXFamilyType_DBSection(string familyName, string typeName, REX.ContentGenerator.Families.EElementType category, bool certified, EMaterial material);
Parameters
Parameters | Description
familyName | The name of the family.
typeName | The name of the type.
category | The category.
certified | Indicates whether the object is certified.
material | The material.
Description
Class

REXFamilyType_DBSection Class

Links
REXFamilyType_DBSection Class, REX.ContentGenerator.Families Namespace, REXFamilyType_DBSection Class


REXFamilyType_DBSection.Clone Method

REXFamilyType_DBSection.Clone Method
REXFamilyType_DBSection Class REX.ContentGenerator.Families Namespace REXFamilyType_DBSection Class

Creates a new object that is a copy of the current instance.

C#
public override object Clone();
Returns

A new object that is a copy of this instance.

Description
Class

REXFamilyType_DBSection Class

Links
REXFamilyType_DBSection Class, REX.ContentGenerator.Families Namespace, REXFamilyType_DBSection Class


REXFamilyType_DBSection.CompareTo Method

REXFamilyType_DBSection.CompareTo Method
REXFamilyType_DBSection Class REX.ContentGenerator.Families Namespace REXFamilyType_DBSection Class

Compares the current object with the other object.

C#
public override int CompareTo(object obj);
Parameters
Parameters | Description
obj | The object.
Returns

Returns the result of the comparison.

Description
Class

REXFamilyType_DBSection Class

Links
REXFamilyType_DBSection Class, REX.ContentGenerator.Families Namespace, REXFamilyType_DBSection Class


REXFamilyType_DBSection.CategoryType Property

REXFamilyType_DBSection.CategoryType Property
REXFamilyType_DBSection Class REX.ContentGenerator.Families Namespace REXFamilyType_DBSection Class

Gets the category.

C#
public override ECategoryType CategoryType;
Description

The category.

Class

REXFamilyType_DBSection Class

Links
REXFamilyType_DBSection Class, REX.ContentGenerator.Families Namespace, REXFamilyType_DBSection Class


REXFamilyType_DBSection.Parameters Property

REXFamilyType_DBSection.Parameters Property
REXFamilyType_DBSection Class REX.ContentGenerator.Families Namespace REXFamilyType_DBSection Class

Gets or sets the parameters.

C#
public REXSectionDBDescription Parameters;
Description

The parameters.

Class

REXFamilyType_DBSection Class

Links
REXFamilyType_DBSection Class, REX.ContentGenerator.Families Namespace, REXFamilyType_DBSection Class


REXFamilyType_Label Class

REXFamilyType_Label Class
REX.ContentGenerator.Families Namespace Legend Members Public Methods REXFamilyType_Label Methods REXFamilyType_Label Properties

Represents labels.

Class Hierarchy
C#
public class REXFamilyType_Label : REXFamilyType;
Description
Remarks

A label is not specified type which has specific name assigned. It can represent material, section etc. It is used for mapping mainly.

Namespace

REX.ContentGenerator.Families Namespace

Public Methods
Public Method | Description
REXFamilyType_Label | Initializes a new instance of the REXFamilyType_Label class.
REXFamilyType_Label | Initializes a new instance of the REXFamilyType_Label class.
REXFamilyType_Label | Initializes a new instance of the REXFamilyType_Label class.
REXFamilyType_Label Methods
REXFamilyType_Label Methods | Description
Clone | Creates a new object that is a copy of the current instance.
CompareTo | Compares the current object with the other object.
REXFamilyType_Label Properties
REXFamilyType_Label Properties | Description
CategoryType | Gets the category.
Parameters | Gets the parameters.
Links
REX.ContentGenerator.Families Namespace, Legend, Members, Public Methods, REXFamilyType_Label Methods, REXFamilyType_Label Properties


REXFamilyType_Label.REXFamilyType_Label Constructor ()

REXFamilyType_Label.REXFamilyType_Label Constructor ()
REXFamilyType_Label Class REX.ContentGenerator.Families Namespace REXFamilyType_Label Class

Initializes a new instance of the REXFamilyType_Label class.

C#
public REXFamilyType_Label();
Description
Class

REXFamilyType_Label Class

Links
REXFamilyType_Label Class, REX.ContentGenerator.Families Namespace, REXFamilyType_Label Class


REXFamilyType_Label.REXFamilyType_Label Constructor (ECategoryType, string)

REXFamilyType_Label.REXFamilyType_Label Constructor (ECategoryType, string)
REXFamilyType_Label Class REX.ContentGenerator.Families Namespace REXFamilyType_Label Class

Initializes a new instance of the REXFamilyType_Label class.

C#
public REXFamilyType_Label(ECategoryType cat, string name);
Parameters
Parameters | Description
cat | The category.
name | The name.
Description
Class

REXFamilyType_Label Class

Links
REXFamilyType_Label Class, REX.ContentGenerator.Families Namespace, REXFamilyType_Label Class


REXFamilyType_Label.REXFamilyType_Label Constructor (REXFamilyType_Label)

REXFamilyType_Label.REXFamilyType_Label Constructor (REXFamilyType_Label)
REXFamilyType_Label Class REX.ContentGenerator.Families Namespace REXFamilyType_Label Class

Initializes a new instance of the REXFamilyType_Label class.

C#
public REXFamilyType_Label(REXFamilyType_Label pattern);
Description
Class

REXFamilyType_Label Class

Links
REXFamilyType_Label Class, REX.ContentGenerator.Families Namespace, REXFamilyType_Label Class


REXFamilyType_Label.Clone Method

REXFamilyType_Label.Clone Method
REXFamilyType_Label Class REX.ContentGenerator.Families Namespace REXFamilyType_Label Class

Creates a new object that is a copy of the current instance.

C#
public override object Clone();
Returns

A new object that is a copy of this instance.

Description
Class

REXFamilyType_Label Class

Links
REXFamilyType_Label Class, REX.ContentGenerator.Families Namespace, REXFamilyType_Label Class


REXFamilyType_Label.CompareTo Method

REXFamilyType_Label.CompareTo Method
REXFamilyType_Label Class REX.ContentGenerator.Families Namespace REXFamilyType_Label Class

Compares the current object with the other object.

C#
public override int CompareTo(object obj);
Parameters
Parameters | Description
obj | The object.
Returns

Returns the result of the comparison.

Description
Class

REXFamilyType_Label Class

Links
REXFamilyType_Label Class, REX.ContentGenerator.Families Namespace, REXFamilyType_Label Class


REXFamilyType_Label.CategoryType Property

REXFamilyType_Label.CategoryType Property
REXFamilyType_Label Class REX.ContentGenerator.Families Namespace REXFamilyType_Label Class

Gets the category.

C#
public override ECategoryType CategoryType;
Description

The category.

Class

REXFamilyType_Label Class

Links
REXFamilyType_Label Class, REX.ContentGenerator.Families Namespace, REXFamilyType_Label Class


REXFamilyType_Label.Parameters Property

REXFamilyType_Label.Parameters Property
REXFamilyType_Label Class REX.ContentGenerator.Families Namespace REXFamilyType_Label Class

Gets the parameters.

C#
public REXLabelDescription Parameters;
Description

The parameters.

Class

REXFamilyType_Label Class

Links
REXFamilyType_Label Class, REX.ContentGenerator.Families Namespace, REXFamilyType_Label Class


REXFamilyType_Material Class

REXFamilyType_Material Class
REX.ContentGenerator.Families Namespace Legend Members Public Methods REXFamilyType_Material Methods REXFamilyType_Material Properties

Represents a material element.

Class Hierarchy
C#
[Serializable()]
public class REXFamilyType_Material : REXFamilyType;
Description
Namespace

REX.ContentGenerator.Families Namespace

Public Methods
Public Method | Description
REXFamilyType_Material | Initializes a new instance of the REXFamilyType_Material class.
REXFamilyType_Material | Initializes a new instance of the REXFamilyType_Material class.
REXFamilyType_Material | Initializes a new instance of the REXFamilyType_Material class.
REXFamilyType_Material Methods
REXFamilyType_Material Methods | Description
Clone | Creates a new object that is a copy of the current instance.
CompareTo | Compares the current object with the other object.
REXFamilyType_Material Properties
REXFamilyType_Material Properties | Description
CategoryType | Gets the category.
Parameters | Gets or sets the parameters.
Links
REX.ContentGenerator.Families Namespace, Legend, Members, Public Methods, REXFamilyType_Material Methods, REXFamilyType_Material Properties


REXFamilyType_Material.REXFamilyType_Material Constructor ()

REXFamilyType_Material.REXFamilyType_Material Constructor ()
REXFamilyType_Material Class REX.ContentGenerator.Families Namespace REXFamilyType_Material Class

Initializes a new instance of the REXFamilyType_Material class.

C#
public REXFamilyType_Material();
Description
Class

REXFamilyType_Material Class

Links
REXFamilyType_Material Class, REX.ContentGenerator.Families Namespace, REXFamilyType_Material Class


REXFamilyType_Material.REXFamilyType_Material Constructor (REXFamilyType_Material)

REXFamilyType_Material.REXFamilyType_Material Constructor (REXFamilyType_Material)
REXFamilyType_Material Class REX.ContentGenerator.Families Namespace REXFamilyType_Material Class

Initializes a new instance of the REXFamilyType_Material class.

C#
public REXFamilyType_Material(REXFamilyType_Material pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

REXFamilyType_Material Class

Links
REXFamilyType_Material Class, REX.ContentGenerator.Families Namespace, REXFamilyType_Material Class


REXFamilyType_Material.REXFamilyType_Material Constructor (string, string, REX.ContentGenerator.Families.EElementType, bool, EMaterial)

REXFamilyType_Material.REXFamilyType_Material Constructor (string, string, REX.ContentGenerator.Families.EElementType, bool, EMaterial)
REXFamilyType_Material Class REX.ContentGenerator.Families Namespace REXFamilyType_Material Class

Initializes a new instance of the REXFamilyType_Material class.

C#
public REXFamilyType_Material(string familyName, string typeName, REX.ContentGenerator.Families.EElementType category, bool certified, EMaterial material);
Parameters
Parameters | Description
familyName | The name of the family.
typeName | The name of the type.
category | The category.
certified | Indicates whether the object is certified.
material | The material.
Description
Class

REXFamilyType_Material Class

Links
REXFamilyType_Material Class, REX.ContentGenerator.Families Namespace, REXFamilyType_Material Class


REXFamilyType_Material.Clone Method

REXFamilyType_Material.Clone Method
REXFamilyType_Material Class REX.ContentGenerator.Families Namespace REXFamilyType_Material Class

Creates a new object that is a copy of the current instance.

C#
public override object Clone();
Returns

A new object that is a copy of this instance.

Description
Class

REXFamilyType_Material Class

Links
REXFamilyType_Material Class, REX.ContentGenerator.Families Namespace, REXFamilyType_Material Class


REXFamilyType_Material.CompareTo Method

REXFamilyType_Material.CompareTo Method
REXFamilyType_Material Class REX.ContentGenerator.Families Namespace REXFamilyType_Material Class

Compares the current object with the other object.

C#
public override int CompareTo(object obj);
Parameters
Parameters | Description
obj | The object.
Returns

Returns a result of the comparison.

Description
Class

REXFamilyType_Material Class

Links
REXFamilyType_Material Class, REX.ContentGenerator.Families Namespace, REXFamilyType_Material Class


REXFamilyType_Material.CategoryType Property

REXFamilyType_Material.CategoryType Property
REXFamilyType_Material Class REX.ContentGenerator.Families Namespace REXFamilyType_Material Class

Gets the category.

C#
public override ECategoryType CategoryType;
Description

The category.

Class

REXFamilyType_Material Class

Links
REXFamilyType_Material Class, REX.ContentGenerator.Families Namespace, REXFamilyType_Material Class


REXFamilyType_Material.Parameters Property

REXFamilyType_Material.Parameters Property
REXFamilyType_Material Class REX.ContentGenerator.Families Namespace REXFamilyType_Material Class

Gets or sets the parameters.

C#
public REXMaterialDBDescription Parameters;
Description

The parameters.

Class

REXFamilyType_Material Class

Links
REXFamilyType_Material Class, REX.ContentGenerator.Families Namespace, REXFamilyType_Material Class


REXFamilyType_ParamSection Class

REXFamilyType_ParamSection Class
REX.ContentGenerator.Families Namespace Legend Members Public Methods REXFamilyType_ParamSection Methods REXFamilyType_ParamSection Properties

Represents a parametric section.

Class Hierarchy
C#
[Serializable()]
public class REXFamilyType_ParamSection : REXFamilyType_Section;
Description
Namespace

REX.ContentGenerator.Families Namespace

Public Methods
Public Method | Description
REXFamilyType_ParamSection | Initializes a new instance of the REXFamilyType_ParamSection class.
REXFamilyType_ParamSection | Initializes a new instance of the REXFamilyType_ParamSection class.
REXFamilyType_ParamSection | Initializes a new instance of the REXFamilyType_ParamSection class.
REXFamilyType_ParamSection Methods
REXFamilyType_ParamSection Methods | Description
Clone | Creates a new object that is a copy of the current instance.
CompareTo | Compares the current object with the other object.
GetMaterialDependence | Gets the material dependence.
REXFamilyType_ParamSection Properties
REXFamilyType_ParamSection Properties | Description
CategoryType | Gets the category.
Parameters | Gets or sets the parameters.
Links
REX.ContentGenerator.Families Namespace, Legend, Members, Public Methods, REXFamilyType_ParamSection Methods, REXFamilyType_ParamSection Properties


REXFamilyType_ParamSection.REXFamilyType_ParamSection Constructor ()

REXFamilyType_ParamSection.REXFamilyType_ParamSection Constructor ()
REXFamilyType_ParamSection Class REX.ContentGenerator.Families Namespace REXFamilyType_ParamSection Class

Initializes a new instance of the REXFamilyType_ParamSection class.

C#
public REXFamilyType_ParamSection();
Description
Class

REXFamilyType_ParamSection Class

Links
REXFamilyType_ParamSection Class, REX.ContentGenerator.Families Namespace, REXFamilyType_ParamSection Class


REXFamilyType_ParamSection.REXFamilyType_ParamSection Constructor (REXFamilyType_ParamSection)

REXFamilyType_ParamSection.REXFamilyType_ParamSection Constructor (REXFamilyType_ParamSection)
REXFamilyType_ParamSection Class REX.ContentGenerator.Families Namespace REXFamilyType_ParamSection Class

Initializes a new instance of the REXFamilyType_ParamSection class.

C#
public REXFamilyType_ParamSection(REXFamilyType_ParamSection pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

REXFamilyType_ParamSection Class

Links
REXFamilyType_ParamSection Class, REX.ContentGenerator.Families Namespace, REXFamilyType_ParamSection Class


REXFamilyType_ParamSection.REXFamilyType_ParamSection Constructor (string, string, REX.ContentGenerator.Families.EElementType, bool, EMaterial)

REXFamilyType_ParamSection.REXFamilyType_ParamSection Constructor (string, string, REX.ContentGenerator.Families.EElementType, bool, EMaterial)
REXFamilyType_ParamSection Class REX.ContentGenerator.Families Namespace REXFamilyType_ParamSection Class

Initializes a new instance of the REXFamilyType_ParamSection class.

C#
public REXFamilyType_ParamSection(string familyName, string typeName, REX.ContentGenerator.Families.EElementType category, bool certified, EMaterial material);
Parameters
Parameters | Description
familyName | The name of the family.
typeName | The name of the type.
category | The category.
certified | Indicates whether the object is certified.
material | The material.
Description
Class

REXFamilyType_ParamSection Class

Links
REXFamilyType_ParamSection Class, REX.ContentGenerator.Families Namespace, REXFamilyType_ParamSection Class


REXFamilyType_ParamSection.Clone Method

REXFamilyType_ParamSection.Clone Method
REXFamilyType_ParamSection Class REX.ContentGenerator.Families Namespace REXFamilyType_ParamSection Class

Creates a new object that is a copy of the current instance.

C#
public override object Clone();
Returns

A new object that is a copy of this instance.

Description
Class

REXFamilyType_ParamSection Class

Links
REXFamilyType_ParamSection Class, REX.ContentGenerator.Families Namespace, REXFamilyType_ParamSection Class


REXFamilyType_ParamSection.CompareTo Method

REXFamilyType_ParamSection.CompareTo Method
REXFamilyType_ParamSection Class REX.ContentGenerator.Families Namespace REXFamilyType_ParamSection Class

Compares the current object with the other object.

C#
public override int CompareTo(object obj);
Parameters
Parameters | Description
obj | The object.
Returns

Returns the result of the comparison.

Description
Class

REXFamilyType_ParamSection Class

Links
REXFamilyType_ParamSection Class, REX.ContentGenerator.Families Namespace, REXFamilyType_ParamSection Class


REXFamilyType_ParamSection.GetMaterialDependence Method

REXFamilyType_ParamSection.GetMaterialDependence Method
REXFamilyType_ParamSection Class REX.ContentGenerator.Families Namespace REXFamilyType_ParamSection Class

Gets the material dependence.

C#
public bool GetMaterialDependence();
Description
Class

REXFamilyType_ParamSection Class

Links
REXFamilyType_ParamSection Class, REX.ContentGenerator.Families Namespace, REXFamilyType_ParamSection Class


REXFamilyType_ParamSection.CategoryType Property

REXFamilyType_ParamSection.CategoryType Property
REXFamilyType_ParamSection Class REX.ContentGenerator.Families Namespace REXFamilyType_ParamSection Class

Gets the category.

C#
public override ECategoryType CategoryType;
Description

The category.

Class

REXFamilyType_ParamSection Class

Links
REXFamilyType_ParamSection Class, REX.ContentGenerator.Families Namespace, REXFamilyType_ParamSection Class


REXFamilyType_ParamSection.Parameters Property

REXFamilyType_ParamSection.Parameters Property
REXFamilyType_ParamSection Class REX.ContentGenerator.Families Namespace REXFamilyType_ParamSection Class

Gets or sets the parameters.

C#
public REXSectionParamDescription Parameters;
Description

The parameters.

Class

REXFamilyType_ParamSection Class

Links
REXFamilyType_ParamSection Class, REX.ContentGenerator.Families Namespace, REXFamilyType_ParamSection Class


REXFamilyType_Section Class

REXFamilyType_Section Class
REX.ContentGenerator.Families Namespace Legend Members Public Methods

Base class for all sections.

Class Hierarchy
C#
[Serializable()]
public class REXFamilyType_Section : REXFamilyType;
Description
Namespace

REX.ContentGenerator.Families Namespace

Public Methods
Public Method | Description
REXFamilyType_Section | Initializes a new instance of the REXFamilyType_Section class.
REXFamilyType_Section | Initializes a new instance of the REXFamilyType_Section class.
REXFamilyType_Section | Initializes a new instance of the REXFamilyType_Section class.
Links
REX.ContentGenerator.Families Namespace, Legend, Members, Public Methods


REXFamilyType_Section.REXFamilyType_Section Constructor ()

REXFamilyType_Section.REXFamilyType_Section Constructor ()
REXFamilyType_Section Class REX.ContentGenerator.Families Namespace REXFamilyType_Section Class

Initializes a new instance of the REXFamilyType_Section class.

C#
public REXFamilyType_Section();
Description
Class

REXFamilyType_Section Class

Links
REXFamilyType_Section Class, REX.ContentGenerator.Families Namespace, REXFamilyType_Section Class


REXFamilyType_Section.REXFamilyType_Section Constructor (REXFamilyType_Section)

REXFamilyType_Section.REXFamilyType_Section Constructor (REXFamilyType_Section)
REXFamilyType_Section Class REX.ContentGenerator.Families Namespace REXFamilyType_Section Class

Initializes a new instance of the REXFamilyType_Section class.

C#
public REXFamilyType_Section(REXFamilyType_Section pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

REXFamilyType_Section Class

Links
REXFamilyType_Section Class, REX.ContentGenerator.Families Namespace, REXFamilyType_Section Class


REXFamilyType_Section.REXFamilyType_Section Constructor (string, string, REX.ContentGenerator.Families.EElementType, bool, EMaterial)

REXFamilyType_Section.REXFamilyType_Section Constructor (string, string, REX.ContentGenerator.Families.EElementType, bool, EMaterial)
REXFamilyType_Section Class REX.ContentGenerator.Families Namespace REXFamilyType_Section Class

Initializes a new instance of the REXFamilyType_Section class.

C#
public REXFamilyType_Section(string familyName, string typeName, REX.ContentGenerator.Families.EElementType category, bool certified, EMaterial material);
Parameters
Parameters | Description
familyName | Name of the family.
typeName | Name of the type.
category | The category.
certified | Indicates whether the object is certified.
material | The material.
Description
Class

REXFamilyType_Section Class

Links
REXFamilyType_Section Class, REX.ContentGenerator.Families Namespace, REXFamilyType_Section Class


REXLabelDescription Class

REXLabelDescription Class
REX.ContentGenerator.Families Namespace Legend Members Public Methods REXLabelDescription Methods REXLabelDescription Properties

Represents label's parameters.

Class Hierarchy
C#
public class REXLabelDescription : REXDescription;
Description
Namespace

REX.ContentGenerator.Families Namespace

Public Methods
Public Method | Description
REXLabelDescription | Initializes a new instance of the REXLabelDescription class.
REXLabelDescription | Initializes a new instance of the REXLabelDescription class.
REXLabelDescription | Initializes a new instance of the REXLabelDescription class.
REXLabelDescription Methods
REXLabelDescription Methods | Description
Clone | Creates a new object that is a copy of the current instance.
CompareTo | Compares the current object with the other object.
GetName | Gets the name.
REXLabelDescription Properties
REXLabelDescription Properties | Description
Category | Gets or sets the category.
LabelFamilyDescription | Gets or sets the label family description.
Name | Gets or sets the name.
Links
REX.ContentGenerator.Families Namespace, Legend, Members, Public Methods, REXLabelDescription Methods, REXLabelDescription Properties


REXLabelDescription.REXLabelDescription Constructor ()

REXLabelDescription.REXLabelDescription Constructor ()
REXLabelDescription Class REX.ContentGenerator.Families Namespace REXLabelDescription Class

Initializes a new instance of the REXLabelDescription class.

C#
public REXLabelDescription();
Description
Class

REXLabelDescription Class

Links
REXLabelDescription Class, REX.ContentGenerator.Families Namespace, REXLabelDescription Class


REXLabelDescription.REXLabelDescription Constructor (ECategoryType, string)

REXLabelDescription.REXLabelDescription Constructor (ECategoryType, string)
REXLabelDescription Class REX.ContentGenerator.Families Namespace REXLabelDescription Class

Initializes a new instance of the REXLabelDescription class.

C#
public REXLabelDescription(ECategoryType cat, string name);
Parameters
Parameters | Description
cat | The category.
name | The name.
Description
Class

REXLabelDescription Class

Links
REXLabelDescription Class, REX.ContentGenerator.Families Namespace, REXLabelDescription Class


REXLabelDescription.REXLabelDescription Constructor (REXLabelDescription)

REXLabelDescription.REXLabelDescription Constructor (REXLabelDescription)
REXLabelDescription Class REX.ContentGenerator.Families Namespace REXLabelDescription Class

Initializes a new instance of the REXLabelDescription class.

C#
public REXLabelDescription(REXLabelDescription pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

REXLabelDescription Class

Links
REXLabelDescription Class, REX.ContentGenerator.Families Namespace, REXLabelDescription Class


REXLabelDescription.Clone Method

REXLabelDescription.Clone Method
REXLabelDescription Class REX.ContentGenerator.Families Namespace REXLabelDescription Class

Creates a new object that is a copy of the current instance.

C#
public override object Clone();
Returns

A new object that is a copy of this instance.

Description
Class

REXLabelDescription Class

Links
REXLabelDescription Class, REX.ContentGenerator.Families Namespace, REXLabelDescription Class


REXLabelDescription.CompareTo Method

REXLabelDescription.CompareTo Method
REXLabelDescription Class REX.ContentGenerator.Families Namespace REXLabelDescription Class

Compares the current object with the other object.

C#
public override int CompareTo(object obj);
Parameters
Parameters | Description
obj | The object.
Returns

Returns the result of the comparison.

Description
Class

REXLabelDescription Class

Links
REXLabelDescription Class, REX.ContentGenerator.Families Namespace, REXLabelDescription Class


REXLabelDescription.GetName Method

REXLabelDescription.GetName Method
REXLabelDescription Class REX.ContentGenerator.Families Namespace REXLabelDescription Class

Gets the name.

C#
public override string GetName();
Returns

The name.

Description
Class

REXLabelDescription Class

Links
REXLabelDescription Class, REX.ContentGenerator.Families Namespace, REXLabelDescription Class


REXLabelDescription.Category Property

REXLabelDescription.Category Property
REXLabelDescription Class REX.ContentGenerator.Families Namespace REXLabelDescription Class

Gets or sets the category.

C#
public ECategoryType Category;
Description

The category.

Class

REXLabelDescription Class

Links
REXLabelDescription Class, REX.ContentGenerator.Families Namespace, REXLabelDescription Class


REXLabelDescription.LabelFamilyDescription Property

REXLabelDescription.LabelFamilyDescription Property
REXLabelDescription Class REX.ContentGenerator.Families Namespace REXLabelDescription Class

Gets or sets the label family description.

C#
public REXFamilyType LabelFamilyDescription;
Description

The label family description.

Remarks

Label represents any type of the content. In the LabelFamilyDescription object can be placed element which is represented by the label (for mapping mainly - to draw sections).

Class

REXLabelDescription Class

Links
REXLabelDescription Class, REX.ContentGenerator.Families Namespace, REXLabelDescription Class


REXLabelDescription.Name Property

REXLabelDescription.Name Property
REXLabelDescription Class REX.ContentGenerator.Families Namespace REXLabelDescription Class

Gets or sets the name.

C#
public string Name;
Description

The name.

Class

REXLabelDescription Class

Links
REXLabelDescription Class, REX.ContentGenerator.Families Namespace, REXLabelDescription Class


REXMaterialCharacteristics Class

REXMaterialCharacteristics Class
REX.ContentGenerator.Families Namespace Legend Members Public Methods REXMaterialCharacteristics Methods REXMaterialCharacteristics Properties

Represents characteristics of a material.

Class Hierarchy
C#
[Serializable()]
public class REXMaterialCharacteristics : REXDescription;
Description
Namespace

REX.ContentGenerator.Families Namespace

Public Methods
Public Method | Description
REXMaterialCharacteristics | Initializes a new instance of the REXMaterialCharacteristics class.
REXMaterialCharacteristics | Initializes a new instance of the REXMaterialCharacteristics class.
REXMaterialCharacteristics | Initializes a new instance of the REXMaterialCharacteristics class.
REXMaterialCharacteristics | Initializes a new instance of the REXMaterialCharacteristics class.
REXMaterialCharacteristics Methods
REXMaterialCharacteristics Methods | Description
Clone | Creates a new object that is a copy of the current instance.
REXMaterialCharacteristics Properties
REXMaterialCharacteristics Properties | Description
CS | Gets or sets the reduction factor for shear for steel / Burning velocity (mm/min) (data specific for timber design according to CB71).
DAMPCOEF | Gets or sets the damping coefficient.
E | Gets or sets the E (Young's modulus).
GMEAN | Gets or sets the average modulus G.
KIRCHOFF | Gets or sets the shear modulus G.
LX | Gets or sets the thermal expansion coefficient.
NU | Gets or sets the Poisson's ratio.
RE | Gets or sets the design strength.
RE_AXCOMP | Gets or sets the axial compression resistance (for timber).
RE_AXTENS | Gets or sets the axial tension resistance (for timber).
RE_BENDING | Gets or sets the bending strength (for timber).
RE_SHEAR | Gets or sets the shear strength (for timber).
RE_TRCOMPR | Gets or sets the transversal compression resistance (for timber).
RE_TRTENS | Gets or sets the transversal tension resistance (for timber).
RO | Gets or sets the unit weight.
RT | Gets or sets the design tensile strength.
Links
REX.ContentGenerator.Families Namespace, Legend, Members, Public Methods, REXMaterialCharacteristics Methods, REXMaterialCharacteristics Properties


REXMaterialCharacteristics.REXMaterialCharacteristics Constructor ()

REXMaterialCharacteristics.REXMaterialCharacteristics Constructor ()
REXMaterialCharacteristics Class REX.ContentGenerator.Families Namespace REXMaterialCharacteristics Class

Initializes a new instance of the REXMaterialCharacteristics class.

C#
public REXMaterialCharacteristics();
Description
Class

REXMaterialCharacteristics Class

Links
REXMaterialCharacteristics Class, REX.ContentGenerator.Families Namespace, REXMaterialCharacteristics Class


REXMaterialCharacteristics.REXMaterialCharacteristics Constructor (DTableDataObjectCollection)

REXMaterialCharacteristics.REXMaterialCharacteristics Constructor (DTableDataObjectCollection)
REXMaterialCharacteristics Class REX.ContentGenerator.Families Namespace REXMaterialCharacteristics Class

Initializes a new instance of the REXMaterialCharacteristics class.

C#
public REXMaterialCharacteristics(DTableDataObjectCollection pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

REXMaterialCharacteristics Class

Links
REXMaterialCharacteristics Class, REX.ContentGenerator.Families Namespace, REXMaterialCharacteristics Class


REXMaterialCharacteristics.REXMaterialCharacteristics Constructor (REXMaterialCharacteristics)

REXMaterialCharacteristics.REXMaterialCharacteristics Constructor (REXMaterialCharacteristics)
REXMaterialCharacteristics Class REX.ContentGenerator.Families Namespace REXMaterialCharacteristics Class

Initializes a new instance of the REXMaterialCharacteristics class.

C#
public REXMaterialCharacteristics(REXMaterialCharacteristics pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

REXMaterialCharacteristics Class

Links
REXMaterialCharacteristics Class, REX.ContentGenerator.Families Namespace, REXMaterialCharacteristics Class


REXMaterialCharacteristics.REXMaterialCharacteristics Constructor (System.Data.DataRow)

REXMaterialCharacteristics.REXMaterialCharacteristics Constructor (System.Data.DataRow)
REXMaterialCharacteristics Class REX.ContentGenerator.Families Namespace REXMaterialCharacteristics Class

Initializes a new instance of the REXMaterialCharacteristics class.

C#
public REXMaterialCharacteristics(System.Data.DataRow pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

REXMaterialCharacteristics Class

Links
REXMaterialCharacteristics Class, REX.ContentGenerator.Families Namespace, REXMaterialCharacteristics Class


REXMaterialCharacteristics.Clone Method

REXMaterialCharacteristics.Clone Method
REXMaterialCharacteristics Class REX.ContentGenerator.Families Namespace REXMaterialCharacteristics Class

Creates a new object that is a copy of the current instance.

C#
public override object Clone();
Returns

A new object that is a copy of this instance.

Description
Class

REXMaterialCharacteristics Class

Links
REXMaterialCharacteristics Class, REX.ContentGenerator.Families Namespace, REXMaterialCharacteristics Class


REXMaterialCharacteristics.CS Property

REXMaterialCharacteristics.CS Property
REXMaterialCharacteristics Class REX.ContentGenerator.Families Namespace REXMaterialCharacteristics Class

Gets or sets the reduction factor for shear for steel / Burning velocity (mm/min) (data specific for timber design according to CB71).

C#
public double CS;
Description

The factor.

Class

REXMaterialCharacteristics Class

Links
REXMaterialCharacteristics Class, REX.ContentGenerator.Families Namespace, REXMaterialCharacteristics Class


REXMaterialCharacteristics.DAMPCOEF Property

REXMaterialCharacteristics.DAMPCOEF Property
REXMaterialCharacteristics Class REX.ContentGenerator.Families Namespace REXMaterialCharacteristics Class

Gets or sets the damping coefficient.

C#
public double DAMPCOEF;
Description

The damping coefficient.

Class

REXMaterialCharacteristics Class

Links
REXMaterialCharacteristics Class, REX.ContentGenerator.Families Namespace, REXMaterialCharacteristics Class


REXMaterialCharacteristics.E Property

REXMaterialCharacteristics.E Property
REXMaterialCharacteristics Class REX.ContentGenerator.Families Namespace REXMaterialCharacteristics Class

Gets or sets the E (Young's modulus).

C#
public double E;
Description

The E.

Class

REXMaterialCharacteristics Class

Links
REXMaterialCharacteristics Class, REX.ContentGenerator.Families Namespace, REXMaterialCharacteristics Class


REXMaterialCharacteristics.GMEAN Property

REXMaterialCharacteristics.GMEAN Property
REXMaterialCharacteristics Class REX.ContentGenerator.Families Namespace REXMaterialCharacteristics Class

Gets or sets the average modulus G.

C#
public double GMEAN;
Description

The average modulus G.

Class

REXMaterialCharacteristics Class

Links
REXMaterialCharacteristics Class, REX.ContentGenerator.Families Namespace, REXMaterialCharacteristics Class


REXMaterialCharacteristics.KIRCHOFF Property

REXMaterialCharacteristics.KIRCHOFF Property
REXMaterialCharacteristics Class REX.ContentGenerator.Families Namespace REXMaterialCharacteristics Class

Gets or sets the shear modulus G.

C#
public double KIRCHOFF;
Description

The shear modulus G.

Class

REXMaterialCharacteristics Class

Links
REXMaterialCharacteristics Class, REX.ContentGenerator.Families Namespace, REXMaterialCharacteristics Class


REXMaterialCharacteristics.LX Property

REXMaterialCharacteristics.LX Property
REXMaterialCharacteristics Class REX.ContentGenerator.Families Namespace REXMaterialCharacteristics Class

Gets or sets the thermal expansion coefficient.

C#
public double LX;
Description

The thermal expansion coefficient.

Class

REXMaterialCharacteristics Class

Links
REXMaterialCharacteristics Class, REX.ContentGenerator.Families Namespace, REXMaterialCharacteristics Class


REXMaterialCharacteristics.NU Property

REXMaterialCharacteristics.NU Property
REXMaterialCharacteristics Class REX.ContentGenerator.Families Namespace REXMaterialCharacteristics Class

Gets or sets the Poisson's ratio.

C#
public double NU;
Description

Poisson's ratio.

Class

REXMaterialCharacteristics Class

Links
REXMaterialCharacteristics Class, REX.ContentGenerator.Families Namespace, REXMaterialCharacteristics Class


REXMaterialCharacteristics.RE Property

REXMaterialCharacteristics.RE Property
REXMaterialCharacteristics Class REX.ContentGenerator.Families Namespace REXMaterialCharacteristics Class

Gets or sets the design strength.

C#
public double RE;
Description

The design strength.

Class

REXMaterialCharacteristics Class

Links
REXMaterialCharacteristics Class, REX.ContentGenerator.Families Namespace, REXMaterialCharacteristics Class


REXMaterialCharacteristics.RE_AXCOMP Property

REXMaterialCharacteristics.RE_AXCOMP Property
REXMaterialCharacteristics Class REX.ContentGenerator.Families Namespace REXMaterialCharacteristics Class

Gets or sets the axial compression resistance (for timber).

C#
public double RE_AXCOMP;
Description

The Axial compression resistance (for timber).

Class

REXMaterialCharacteristics Class

Links
REXMaterialCharacteristics Class, REX.ContentGenerator.Families Namespace, REXMaterialCharacteristics Class


REXMaterialCharacteristics.RE_AXTENS Property

REXMaterialCharacteristics.RE_AXTENS Property
REXMaterialCharacteristics Class REX.ContentGenerator.Families Namespace REXMaterialCharacteristics Class

Gets or sets the axial tension resistance (for timber).

C#
public double RE_AXTENS;
Description

The axial tension resistance (for timber).

Class

REXMaterialCharacteristics Class

Links
REXMaterialCharacteristics Class, REX.ContentGenerator.Families Namespace, REXMaterialCharacteristics Class


REXMaterialCharacteristics.RE_BENDING Property

REXMaterialCharacteristics.RE_BENDING Property
REXMaterialCharacteristics Class REX.ContentGenerator.Families Namespace REXMaterialCharacteristics Class

Gets or sets the bending strength (for timber).

C#
public double RE_BENDING;
Description

The bending strength (for timber).

Class

REXMaterialCharacteristics Class

Links
REXMaterialCharacteristics Class, REX.ContentGenerator.Families Namespace, REXMaterialCharacteristics Class


REXMaterialCharacteristics.RE_SHEAR Property

REXMaterialCharacteristics.RE_SHEAR Property
REXMaterialCharacteristics Class REX.ContentGenerator.Families Namespace REXMaterialCharacteristics Class

Gets or sets the shear strength (for timber).

C#
public double RE_SHEAR;
Description

The shear strength (for timber).

Class

REXMaterialCharacteristics Class

Links
REXMaterialCharacteristics Class, REX.ContentGenerator.Families Namespace, REXMaterialCharacteristics Class


REXMaterialCharacteristics.RE_TRCOMPR Property

REXMaterialCharacteristics.RE_TRCOMPR Property
REXMaterialCharacteristics Class REX.ContentGenerator.Families Namespace REXMaterialCharacteristics Class

Gets or sets the transversal compression resistance (for timber).

C#
public double RE_TRCOMPR;
Description

The transversal compression resistance (for timber).

Class

REXMaterialCharacteristics Class

Links
REXMaterialCharacteristics Class, REX.ContentGenerator.Families Namespace, REXMaterialCharacteristics Class


REXMaterialCharacteristics.RE_TRTENS Property

REXMaterialCharacteristics.RE_TRTENS Property
REXMaterialCharacteristics Class REX.ContentGenerator.Families Namespace REXMaterialCharacteristics Class

Gets or sets the transversal tension resistance (for timber).

C#
public double RE_TRTENS;
Description

The transversal tension resistance (for timber).

Class

REXMaterialCharacteristics Class

Links
REXMaterialCharacteristics Class, REX.ContentGenerator.Families Namespace, REXMaterialCharacteristics Class


REXMaterialCharacteristics.RO Property

REXMaterialCharacteristics.RO Property
REXMaterialCharacteristics Class REX.ContentGenerator.Families Namespace REXMaterialCharacteristics Class

Gets or sets the unit weight.

C#
public double RO;
Description

The unit weight.

Class

REXMaterialCharacteristics Class

Links
REXMaterialCharacteristics Class, REX.ContentGenerator.Families Namespace, REXMaterialCharacteristics Class


REXMaterialCharacteristics.RT Property

REXMaterialCharacteristics.RT Property
REXMaterialCharacteristics Class REX.ContentGenerator.Families Namespace REXMaterialCharacteristics Class

Gets or sets the design tensile strength.

C#
public double RT;
Description

The design tensile strength.

Class

REXMaterialCharacteristics Class

Links
REXMaterialCharacteristics Class, REX.ContentGenerator.Families Namespace, REXMaterialCharacteristics Class


REXMaterialDBDescription Class

REXMaterialDBDescription Class
REX.ContentGenerator.Families Namespace Legend Members Public Methods REXMaterialDBDescription Methods REXMaterialDBDescription Properties

Represents description of the material.

Class Hierarchy
C#
[Serializable()]
public class REXMaterialDBDescription : REXDBDescription;
Description
Namespace

REX.ContentGenerator.Families Namespace

Public Methods
Public Method | Description
REXMaterialDBDescription | Initializes a new instance of the REXMaterialDBDescription class.
REXMaterialDBDescription | Initializes a new instance of the REXMaterialDBDescription class.
REXMaterialDBDescription | Initializes a new instance of the REXMaterialDBDescription class.
REXMaterialDBDescription | Initializes a new instance of the REXMaterialDBDescription class.
REXMaterialDBDescription | Initializes a new instance of the REXMaterialDBDescription class.
REXMaterialDBDescription Methods
REXMaterialDBDescription Methods | Description
Clone | Creates a new object that is a copy of the current instance.
CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
GetName | Gets the name.
REXMaterialDBDescription Properties
REXMaterialDBDescription Properties | Description
Characteristics | Gets or sets characteristics.
Description | Gets or sets the description.
NAME | Gets or sets the material name.
Links
REX.ContentGenerator.Families Namespace, Legend, Members, Public Methods, REXMaterialDBDescription Methods, REXMaterialDBDescription Properties


REXMaterialDBDescription.REXMaterialDBDescription Constructor ()

REXMaterialDBDescription.REXMaterialDBDescription Constructor ()
REXMaterialDBDescription Class REX.ContentGenerator.Families Namespace REXMaterialDBDescription Class

Initializes a new instance of the REXMaterialDBDescription class.

C#
public REXMaterialDBDescription();
Description
Class

REXMaterialDBDescription Class

Links
REXMaterialDBDescription Class, REX.ContentGenerator.Families Namespace, REXMaterialDBDescription Class


REXMaterialDBDescription.REXMaterialDBDescription Constructor (REXMaterialDBDescription)

REXMaterialDBDescription.REXMaterialDBDescription Constructor (REXMaterialDBDescription)
REXMaterialDBDescription Class REX.ContentGenerator.Families Namespace REXMaterialDBDescription Class

Initializes a new instance of the REXMaterialDBDescription class.

C#
public REXMaterialDBDescription(REXMaterialDBDescription pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

REXMaterialDBDescription Class

Links
REXMaterialDBDescription Class, REX.ContentGenerator.Families Namespace, REXMaterialDBDescription Class


REXMaterialDBDescription.REXMaterialDBDescription Constructor (string)

REXMaterialDBDescription.REXMaterialDBDescription Constructor (string)
REXMaterialDBDescription Class REX.ContentGenerator.Families Namespace REXMaterialDBDescription Class

Initializes a new instance of the REXMaterialDBDescription class.

C#
public REXMaterialDBDescription(string dbName);
Parameters
Parameters | Description
dbName | The name of the database.
Description
Class

REXMaterialDBDescription Class

Links
REXMaterialDBDescription Class, REX.ContentGenerator.Families Namespace, REXMaterialDBDescription Class


REXMaterialDBDescription.REXMaterialDBDescription Constructor (string, string, DTableDataObjectCollection)

REXMaterialDBDescription.REXMaterialDBDescription Constructor (string, string, DTableDataObjectCollection)
REXMaterialDBDescription Class REX.ContentGenerator.Families Namespace REXMaterialDBDescription Class

Initializes a new instance of the REXMaterialDBDescription class.

C#
public REXMaterialDBDescription(string dir, string dbname, DTableDataObjectCollection col);
Parameters
Parameters | Description
dir | The directory.
dbname | The name of the database.
col | The collection.
Description
Class

REXMaterialDBDescription Class

Links
REXMaterialDBDescription Class, REX.ContentGenerator.Families Namespace, REXMaterialDBDescription Class


REXMaterialDBDescription.REXMaterialDBDescription Constructor (string, string, System.Data.DataRow)

REXMaterialDBDescription.REXMaterialDBDescription Constructor (string, string, System.Data.DataRow)
REXMaterialDBDescription Class REX.ContentGenerator.Families Namespace REXMaterialDBDescription Class

Initializes a new instance of the REXMaterialDBDescription class.

C#
public REXMaterialDBDescription(string dir, string dbname, System.Data.DataRow row);
Parameters
Parameters | Description
dir | The directory.
dbname | The name of the database.
row | The row.
Description
Class

REXMaterialDBDescription Class

Links
REXMaterialDBDescription Class, REX.ContentGenerator.Families Namespace, REXMaterialDBDescription Class


REXMaterialDBDescription.Clone Method

REXMaterialDBDescription.Clone Method
REXMaterialDBDescription Class REX.ContentGenerator.Families Namespace REXMaterialDBDescription Class

Creates a new object that is a copy of the current instance.

C#
public override object Clone();
Returns

A new object that is a copy of this instance.

Description
Class

REXMaterialDBDescription Class

Links
REXMaterialDBDescription Class, REX.ContentGenerator.Families Namespace, REXMaterialDBDescription Class


REXMaterialDBDescription.CompareTo Method

REXMaterialDBDescription.CompareTo Method
REXMaterialDBDescription Class REX.ContentGenerator.Families Namespace REXMaterialDBDescription Class

Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.

C#
public override int CompareTo(object obj);
Parameters
Parameters | Description
obj | An object to compare with this instance.
Returns

Returns a result of the comparison.

Description
Class

REXMaterialDBDescription Class

Links
REXMaterialDBDescription Class, REX.ContentGenerator.Families Namespace, REXMaterialDBDescription Class


REXMaterialDBDescription.GetName Method

REXMaterialDBDescription.GetName Method
REXMaterialDBDescription Class REX.ContentGenerator.Families Namespace REXMaterialDBDescription Class

Gets the name.

C#
public override string GetName();
Returns

Returns the name.

Description
Class

REXMaterialDBDescription Class

Links
REXMaterialDBDescription Class, REX.ContentGenerator.Families Namespace, REXMaterialDBDescription Class


REXMaterialDBDescription.Characteristics Property

REXMaterialDBDescription.Characteristics Property
REXMaterialDBDescription Class REX.ContentGenerator.Families Namespace REXMaterialDBDescription Class

Gets or sets characteristics.

C#
public REX.ContentGenerator.Families.REXMaterialCharacteristics Characteristics;
Description

The characteristics.

Class

REXMaterialDBDescription Class

Links
REXMaterialDBDescription Class, REX.ContentGenerator.Families Namespace, REXMaterialDBDescription Class


REXMaterialDBDescription.Description Property

REXMaterialDBDescription.Description Property
REXMaterialDBDescription Class REX.ContentGenerator.Families Namespace REXMaterialDBDescription Class

Gets or sets the description.

C#
public REX.ContentGenerator.Families.REXMaterialProperties Description;
Description

The description.

Class

REXMaterialDBDescription Class

Links
REXMaterialDBDescription Class, REX.ContentGenerator.Families Namespace, REXMaterialDBDescription Class


REXMaterialDBDescription.NAME Property

REXMaterialDBDescription.NAME Property
REXMaterialDBDescription Class REX.ContentGenerator.Families Namespace REXMaterialDBDescription Class

Gets or sets the material name.

C#
public string NAME;
Description

The material name.

Remarks

It is taken as key for identification process in a database.

Class

REXMaterialDBDescription Class

Links
REXMaterialDBDescription Class, REX.ContentGenerator.Families Namespace, REXMaterialDBDescription Class


REXMaterialProperties Class

REXMaterialProperties Class
REX.ContentGenerator.Families Namespace Legend Members Public Methods REXMaterialProperties Methods REXMaterialProperties Properties

Represents properties of the material.

Class Hierarchy
C#
[Serializable()]
public class REXMaterialProperties : REXDescription;
Description
Namespace

REX.ContentGenerator.Families Namespace

Public Methods
Public Method | Description
REXMaterialProperties | Initializes a new instance of the REXMaterialProperties class.
REXMaterialProperties | Initializes a new instance of the REXMaterialProperties class.
REXMaterialProperties | Initializes a new instance of the REXMaterialProperties class.
REXMaterialProperties | Initializes a new instance of the REXMaterialProperties class.
REXMaterialProperties Methods
REXMaterialProperties Methods | Description
Clone | Creates a new object that is a copy of the current instance.
REXMaterialProperties Properties
REXMaterialProperties Properties | Description
DESCRIPTION | Gets or sets the detailed material description.
NAME | Gets or sets the material name.
RE_CODE | Gets or sets /1.
SECOND_NAME | Gets or sets the material's name (used for a steel to give an equivalent according to Eurocode).
THERM | Gets or sets the material type /for steel: thermal treatment-1 /for timber: natural-0, glued-1, glued KertoS specific for Kerto code-2, glued KertoQ specific for Kerto code-3, glued KertoS-4, glued KertoQ-5.
Links
REX.ContentGenerator.Families Namespace, Legend, Members, Public Methods, REXMaterialProperties Methods, REXMaterialProperties Properties


REXMaterialProperties.REXMaterialProperties Constructor ()

REXMaterialProperties.REXMaterialProperties Constructor ()
REXMaterialProperties Class REX.ContentGenerator.Families Namespace REXMaterialProperties Class

Initializes a new instance of the REXMaterialProperties class.

C#
public REXMaterialProperties();
Description
Class

REXMaterialProperties Class

Links
REXMaterialProperties Class, REX.ContentGenerator.Families Namespace, REXMaterialProperties Class


REXMaterialProperties.REXMaterialProperties Constructor (DTableDataObjectCollection)

REXMaterialProperties.REXMaterialProperties Constructor (DTableDataObjectCollection)
REXMaterialProperties Class REX.ContentGenerator.Families Namespace REXMaterialProperties Class

Initializes a new instance of the REXMaterialProperties class.

C#
public REXMaterialProperties(DTableDataObjectCollection pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

REXMaterialProperties Class

Links
REXMaterialProperties Class, REX.ContentGenerator.Families Namespace, REXMaterialProperties Class


REXMaterialProperties.REXMaterialProperties Constructor (REXMaterialProperties)

REXMaterialProperties.REXMaterialProperties Constructor (REXMaterialProperties)
REXMaterialProperties Class REX.ContentGenerator.Families Namespace REXMaterialProperties Class

Initializes a new instance of the REXMaterialProperties class.

C#
public REXMaterialProperties(REXMaterialProperties pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

REXMaterialProperties Class

Links
REXMaterialProperties Class, REX.ContentGenerator.Families Namespace, REXMaterialProperties Class


REXMaterialProperties.REXMaterialProperties Constructor (System.Data.DataRow)

REXMaterialProperties.REXMaterialProperties Constructor (System.Data.DataRow)
REXMaterialProperties Class REX.ContentGenerator.Families Namespace REXMaterialProperties Class

Initializes a new instance of the REXMaterialProperties class.

C#
public REXMaterialProperties(System.Data.DataRow pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

REXMaterialProperties Class

Links
REXMaterialProperties Class, REX.ContentGenerator.Families Namespace, REXMaterialProperties Class


REXMaterialProperties.Clone Method

REXMaterialProperties.Clone Method
REXMaterialProperties Class REX.ContentGenerator.Families Namespace REXMaterialProperties Class

Creates a new object that is a copy of the current instance.

C#
public override object Clone();
Returns

A new object that is a copy of this instance.

Description
Class

REXMaterialProperties Class

Links
REXMaterialProperties Class, REX.ContentGenerator.Families Namespace, REXMaterialProperties Class


REXMaterialProperties.DESCRIPTION Property

REXMaterialProperties.DESCRIPTION Property
REXMaterialProperties Class REX.ContentGenerator.Families Namespace REXMaterialProperties Class

Gets or sets the detailed material description.

C#
public string DESCRIPTION;
Description

The detailed material description.

Class

REXMaterialProperties Class

Links
REXMaterialProperties Class, REX.ContentGenerator.Families Namespace, REXMaterialProperties Class


REXMaterialProperties.NAME Property

REXMaterialProperties.NAME Property
REXMaterialProperties Class REX.ContentGenerator.Families Namespace REXMaterialProperties Class

Gets or sets the material name.

C#
public string NAME;
Description

The material name.

Remarks

It is taken as key for identification process in a database.

Class

REXMaterialProperties Class

Links
REXMaterialProperties Class, REX.ContentGenerator.Families Namespace, REXMaterialProperties Class


REXMaterialProperties.RE_CODE Property

REXMaterialProperties.RE_CODE Property
REXMaterialProperties Class REX.ContentGenerator.Families Namespace REXMaterialProperties Class

Gets or sets /1.

C#
public int RE_CODE;
Description

a digit stands for (characteristic or design) resistance, 2. a cubic or cylindric sample).

The resistance.

Class

REXMaterialProperties Class

Links
REXMaterialProperties Class, REX.ContentGenerator.Families Namespace, REXMaterialProperties Class


REXMaterialProperties.SECOND_NAME Property

REXMaterialProperties.SECOND_NAME Property
REXMaterialProperties Class REX.ContentGenerator.Families Namespace REXMaterialProperties Class

Gets or sets the material's name (used for a steel to give an equivalent according to Eurocode).

C#
public string SECOND_NAME;
Description

The material's name (used for a steel to give an equivalent according to Eurocode).

Class

REXMaterialProperties Class

Links
REXMaterialProperties Class, REX.ContentGenerator.Families Namespace, REXMaterialProperties Class


REXMaterialProperties.THERM Property

REXMaterialProperties.THERM Property
REXMaterialProperties Class REX.ContentGenerator.Families Namespace REXMaterialProperties Class

Gets or sets the material type /for steel: thermal treatment-1 /for timber: natural-0, glued-1, glued KertoS specific for Kerto code-2, glued KertoQ specific for Kerto code-3, glued KertoS-4, glued KertoQ-5.

C#
public int THERM;
Description

The material type.

Class

REXMaterialProperties Class

Links
REXMaterialProperties Class, REX.ContentGenerator.Families Namespace, REXMaterialProperties Class


REXParamDescription Class

REXParamDescription Class
REX.ContentGenerator.Families Namespace

Base class for all descriptions of objects in REXFamilyType which were created based on a parametric description (not database).

Class Hierarchy
C#
[Serializable()]
public abstract class REXParamDescription : REXDescription;
Description
Namespace

REX.ContentGenerator.Families Namespace

Links
REX.ContentGenerator.Families Namespace
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXSectionDBCharacteristics Class

REXSectionDBCharacteristics Class
REX.ContentGenerator.Families Namespace Legend Members Public Methods REXSectionDBCharacteristics Methods REXSectionDBCharacteristics Properties

Describes geometry characteristics of a database section.

Class Hierarchy
C#
[Serializable()]
public class REXSectionDBCharacteristics : REXDescription;
Description
Namespace

REX.ContentGenerator.Families Namespace

Public Methods
Public Method | Description
REXSectionDBCharacteristics | Initializes a new instance of the REXSectionDBCharacteristics class.
REXSectionDBCharacteristics | Initializes a new instance of the EXSectionDBCharacteristics class.
REXSectionDBCharacteristics | Initializes a new instance of the REXSectionDBCharacteristics class.
REXSectionDBCharacteristics | Initializes a new instance of the REXSectionDBCharacteristics class.
REXSectionDBCharacteristics Methods
REXSectionDBCharacteristics Methods | Description
Clone | Creates a new object that is a copy of the current instance.
REXSectionDBCharacteristics Properties
REXSectionDBCharacteristics Properties | Description
IOMEGA | Gets or sets the warping constant (for thin-walled sections).
IX | Gets or sets the torsional constant.
IY | Gets or sets the moment of inertia (Iy).
IZ | Gets or sets the moment of inertia (Iz).
MASS | Gets or sets the weight per length unit of a section.
MSY | Gets or sets the plastic section modulus (bending) about the Y axis.
MSZ | Gets or sets the plastic section modulus (bending) about the Z axis.
SX | Gets or sets the cross-sectional area.
SY | Gets or sets the reduced section area for XY-shear deformation calculations - considering the influence of shear forces along Y axis.
SZ | Gets or sets the reduced section area for XZ-shear deformation calculations - considering the influence of shear forces along Z axis.
Links
REX.ContentGenerator.Families Namespace, Legend, Members, Public Methods, REXSectionDBCharacteristics Methods, REXSectionDBCharacteristics Properties


REXSectionDBCharacteristics.REXSectionDBCharacteristics Constructor ()

REXSectionDBCharacteristics.REXSectionDBCharacteristics Constructor ()
REXSectionDBCharacteristics Class REX.ContentGenerator.Families Namespace REXSectionDBCharacteristics Class

Initializes a new instance of the REXSectionDBCharacteristics class.

C#
public REXSectionDBCharacteristics();
Description
Class

REXSectionDBCharacteristics Class

Links
REXSectionDBCharacteristics Class, REX.ContentGenerator.Families Namespace, REXSectionDBCharacteristics Class


REXSectionDBCharacteristics.REXSectionDBCharacteristics Constructor (DTableDataObjectCollection)

REXSectionDBCharacteristics.REXSectionDBCharacteristics Constructor (DTableDataObjectCollection)
REXSectionDBCharacteristics Class REX.ContentGenerator.Families Namespace REXSectionDBCharacteristics Class

Initializes a new instance of the EXSectionDBCharacteristics class.

C#
public REXSectionDBCharacteristics(DTableDataObjectCollection pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

REXSectionDBCharacteristics Class

Links
REXSectionDBCharacteristics Class, REX.ContentGenerator.Families Namespace, REXSectionDBCharacteristics Class


REXSectionDBCharacteristics.REXSectionDBCharacteristics Constructor (REXSectionDBCharacteristics)

REXSectionDBCharacteristics.REXSectionDBCharacteristics Constructor (REXSectionDBCharacteristics)
REXSectionDBCharacteristics Class REX.ContentGenerator.Families Namespace REXSectionDBCharacteristics Class

Initializes a new instance of the REXSectionDBCharacteristics class.

C#
public REXSectionDBCharacteristics(REXSectionDBCharacteristics pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

REXSectionDBCharacteristics Class

Links
REXSectionDBCharacteristics Class, REX.ContentGenerator.Families Namespace, REXSectionDBCharacteristics Class


REXSectionDBCharacteristics.REXSectionDBCharacteristics Constructor (System.Data.DataRow)

REXSectionDBCharacteristics.REXSectionDBCharacteristics Constructor (System.Data.DataRow)
REXSectionDBCharacteristics Class REX.ContentGenerator.Families Namespace REXSectionDBCharacteristics Class

Initializes a new instance of the REXSectionDBCharacteristics class.

C#
public REXSectionDBCharacteristics(System.Data.DataRow pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

REXSectionDBCharacteristics Class

Links
REXSectionDBCharacteristics Class, REX.ContentGenerator.Families Namespace, REXSectionDBCharacteristics Class


REXSectionDBCharacteristics.Clone Method

REXSectionDBCharacteristics.Clone Method
REXSectionDBCharacteristics Class REX.ContentGenerator.Families Namespace REXSectionDBCharacteristics Class

Creates a new object that is a copy of the current instance.

C#
public override object Clone();
Returns

A new object that is a copy of this instance.

Description
Class

REXSectionDBCharacteristics Class

Links
REXSectionDBCharacteristics Class, REX.ContentGenerator.Families Namespace, REXSectionDBCharacteristics Class


REXSectionDBCharacteristics.IOMEGA Property

REXSectionDBCharacteristics.IOMEGA Property
REXSectionDBCharacteristics Class REX.ContentGenerator.Families Namespace REXSectionDBCharacteristics Class

Gets or sets the warping constant (for thin-walled sections).

C#
public double IOMEGA;
Description

The warping constant.

Class

REXSectionDBCharacteristics Class

Links
REXSectionDBCharacteristics Class, REX.ContentGenerator.Families Namespace, REXSectionDBCharacteristics Class


REXSectionDBCharacteristics.IX Property

REXSectionDBCharacteristics.IX Property
REXSectionDBCharacteristics Class REX.ContentGenerator.Families Namespace REXSectionDBCharacteristics Class

Gets or sets the torsional constant.

C#
public double IX;
Description

The torsional constant.

Class

REXSectionDBCharacteristics Class

Links
REXSectionDBCharacteristics Class, REX.ContentGenerator.Families Namespace, REXSectionDBCharacteristics Class


REXSectionDBCharacteristics.IY Property

REXSectionDBCharacteristics.IY Property
REXSectionDBCharacteristics Class REX.ContentGenerator.Families Namespace REXSectionDBCharacteristics Class

Gets or sets the moment of inertia (Iy).

C#
public double IY;
Description

The moment of inertia (Iy).

Class

REXSectionDBCharacteristics Class

Links
REXSectionDBCharacteristics Class, REX.ContentGenerator.Families Namespace, REXSectionDBCharacteristics Class


REXSectionDBCharacteristics.IZ Property

REXSectionDBCharacteristics.IZ Property
REXSectionDBCharacteristics Class REX.ContentGenerator.Families Namespace REXSectionDBCharacteristics Class

Gets or sets the moment of inertia (Iz).

C#
public double IZ;
Description

The moment of inertia (Iz).

Class

REXSectionDBCharacteristics Class

Links
REXSectionDBCharacteristics Class, REX.ContentGenerator.Families Namespace, REXSectionDBCharacteristics Class


REXSectionDBCharacteristics.MASS Property

REXSectionDBCharacteristics.MASS Property
REXSectionDBCharacteristics Class REX.ContentGenerator.Families Namespace REXSectionDBCharacteristics Class

Gets or sets the weight per length unit of a section.

C#
public double MASS;
Description

The weight per length unit of a section.

Class

REXSectionDBCharacteristics Class

Links
REXSectionDBCharacteristics Class, REX.ContentGenerator.Families Namespace, REXSectionDBCharacteristics Class


REXSectionDBCharacteristics.MSY Property

REXSectionDBCharacteristics.MSY Property
REXSectionDBCharacteristics Class REX.ContentGenerator.Families Namespace REXSectionDBCharacteristics Class

Gets or sets the plastic section modulus (bending) about the Y axis.

C#
public double MSY;
Description

The plastic section modulus (bending) about the Y axis.

Class

REXSectionDBCharacteristics Class

Links
REXSectionDBCharacteristics Class, REX.ContentGenerator.Families Namespace, REXSectionDBCharacteristics Class


REXSectionDBCharacteristics.MSZ Property

REXSectionDBCharacteristics.MSZ Property
REXSectionDBCharacteristics Class REX.ContentGenerator.Families Namespace REXSectionDBCharacteristics Class

Gets or sets the plastic section modulus (bending) about the Z axis.

C#
public double MSZ;
Description

The plastic section modulus (bending) about the Z axis.

Class

REXSectionDBCharacteristics Class

Links
REXSectionDBCharacteristics Class, REX.ContentGenerator.Families Namespace, REXSectionDBCharacteristics Class


REXSectionDBCharacteristics.SX Property

REXSectionDBCharacteristics.SX Property
REXSectionDBCharacteristics Class REX.ContentGenerator.Families Namespace REXSectionDBCharacteristics Class

Gets or sets the cross-sectional area.

C#
public double SX;
Description

The cross-sectional area.

Class

REXSectionDBCharacteristics Class

Links
REXSectionDBCharacteristics Class, REX.ContentGenerator.Families Namespace, REXSectionDBCharacteristics Class


REXSectionDBCharacteristics.SY Property

REXSectionDBCharacteristics.SY Property
REXSectionDBCharacteristics Class REX.ContentGenerator.Families Namespace REXSectionDBCharacteristics Class

Gets or sets the reduced section area for XY-shear deformation calculations - considering the influence of shear forces along Y axis.

C#
public double SY;
Description

The reduced section.

Class

REXSectionDBCharacteristics Class

Links
REXSectionDBCharacteristics Class, REX.ContentGenerator.Families Namespace, REXSectionDBCharacteristics Class


REXSectionDBCharacteristics.SZ Property

REXSectionDBCharacteristics.SZ Property
REXSectionDBCharacteristics Class REX.ContentGenerator.Families Namespace REXSectionDBCharacteristics Class

Gets or sets the reduced section area for XZ-shear deformation calculations - considering the influence of shear forces along Z axis.

C#
public double SZ;
Description

The reduced section area.

Class

REXSectionDBCharacteristics Class

Links
REXSectionDBCharacteristics Class, REX.ContentGenerator.Families Namespace, REXSectionDBCharacteristics Class


REXSectionDBDescription Class

REXSectionDBDescription Class
REX.ContentGenerator.Families Namespace Legend Members Public Methods REXSectionDBDescription Methods REXSectionDBDescription Properties

Represents parameters of the database section.

Class Hierarchy
C#
[Serializable()]
public class REXSectionDBDescription : REXDBDescription;
Description
Namespace

REX.ContentGenerator.Families Namespace

Public Methods
Public Method | Description
REXSectionDBDescription | Initializes a new instance of the REXSectionDBDescription class.
REXSectionDBDescription | Initializes a new instance of the REXSectionDBDescription class.
REXSectionDBDescription | Initializes a new instance of the REXSectionDBDescription class.
REXSectionDBDescription | Initializes a new instance of the REXSectionDBDescription class.
REXSectionDBDescription | Initializes a new instance of the REXSectionDBDescription class.
REXSectionDBDescription Methods
REXSectionDBDescription Methods | Description
Clone | Creates a new object that is a copy of the current instance.
CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
GetContour | Gets the contour of the section.
GetName | Gets the name of the section.
GetSectionType | Gets the type of the section.
GetSectionType | Gets the type of the section.
REXSectionDBDescription Properties
REXSectionDBDescription Properties | Description
Characteristics | Gets or sets the characteristics of the section.
Description | Gets or sets the description of the section.
DIM1 | Gets or sets the first numeric component of the section label
DIM2 | Gets or sets the second numeric component of the section label.
DIM3 | Gets or sets the third numeric component of the section label.
Dimensions | Gets or sets the dimensions.
NAME | Gets or sets the name of the section.
Links
REX.ContentGenerator.Families Namespace, Legend, Members, Public Methods, REXSectionDBDescription Methods, REXSectionDBDescription Properties


REXSectionDBDescription.REXSectionDBDescription Constructor ()

REXSectionDBDescription.REXSectionDBDescription Constructor ()
REXSectionDBDescription Class REX.ContentGenerator.Families Namespace REXSectionDBDescription Class

Initializes a new instance of the REXSectionDBDescription class.

C#
public REXSectionDBDescription();
Description
Class

REXSectionDBDescription Class

Links
REXSectionDBDescription Class, REX.ContentGenerator.Families Namespace, REXSectionDBDescription Class


REXSectionDBDescription.REXSectionDBDescription Constructor (REXSectionDBDescription)

REXSectionDBDescription.REXSectionDBDescription Constructor (REXSectionDBDescription)
REXSectionDBDescription Class REX.ContentGenerator.Families Namespace REXSectionDBDescription Class

Initializes a new instance of the REXSectionDBDescription class.

C#
public REXSectionDBDescription(REXSectionDBDescription pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

REXSectionDBDescription Class

Links
REXSectionDBDescription Class, REX.ContentGenerator.Families Namespace, REXSectionDBDescription Class


REXSectionDBDescription.REXSectionDBDescription Constructor (string)

REXSectionDBDescription.REXSectionDBDescription Constructor (string)
REXSectionDBDescription Class REX.ContentGenerator.Families Namespace REXSectionDBDescription Class

Initializes a new instance of the REXSectionDBDescription class.

C#
public REXSectionDBDescription(string dbName);
Parameters
Parameters | Description
dbName | The name of the database.
Description
Class

REXSectionDBDescription Class

Links
REXSectionDBDescription Class, REX.ContentGenerator.Families Namespace, REXSectionDBDescription Class


REXSectionDBDescription.REXSectionDBDescription Constructor (string, string, DTableDataObjectCollection)

REXSectionDBDescription.REXSectionDBDescription Constructor (string, string, DTableDataObjectCollection)
REXSectionDBDescription Class REX.ContentGenerator.Families Namespace REXSectionDBDescription Class

Initializes a new instance of the REXSectionDBDescription class.

C#
public REXSectionDBDescription(string dir, string dbname, DTableDataObjectCollection col);
Parameters
Parameters | Description
dir | The directory.
dbname | The name of the database.
col | The collection.
Description
Class

REXSectionDBDescription Class

Links
REXSectionDBDescription Class, REX.ContentGenerator.Families Namespace, REXSectionDBDescription Class


REXSectionDBDescription.REXSectionDBDescription Constructor (string, string, System.Data.DataRow)

REXSectionDBDescription.REXSectionDBDescription Constructor (string, string, System.Data.DataRow)
REXSectionDBDescription Class REX.ContentGenerator.Families Namespace REXSectionDBDescription Class

Initializes a new instance of the REXSectionDBDescription class.

C#
public REXSectionDBDescription(string dir, string dbname, System.Data.DataRow row);
Parameters
Parameters | Description
dir | The directory.
dbname | The name of the database.
row | The row.
Description
Class

REXSectionDBDescription Class

Links
REXSectionDBDescription Class, REX.ContentGenerator.Families Namespace, REXSectionDBDescription Class


REXSectionDBDescription.Clone Method

REXSectionDBDescription.Clone Method
REXSectionDBDescription Class REX.ContentGenerator.Families Namespace REXSectionDBDescription Class

Creates a new object that is a copy of the current instance.

C#
public override object Clone();
Returns

A new object that is a copy of this instance.

Description
Class

REXSectionDBDescription Class

Links
REXSectionDBDescription Class, REX.ContentGenerator.Families Namespace, REXSectionDBDescription Class


REXSectionDBDescription.CompareTo Method

REXSectionDBDescription.CompareTo Method
REXSectionDBDescription Class REX.ContentGenerator.Families Namespace REXSectionDBDescription Class

Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.

C#
public override int CompareTo(object obj);
Parameters
Parameters | Description
obj | An object to compare with this instance.
Returns

Returns a result of the comparison.

Description
Class

REXSectionDBDescription Class

Links
REXSectionDBDescription Class, REX.ContentGenerator.Families Namespace, REXSectionDBDescription Class


REXSectionDBDescription.GetContour Method

REXSectionDBDescription.GetContour Method
REXSectionDBDescription Class REX.ContentGenerator.Families Namespace REXSectionDBDescription Class

Gets the contour of the section.

C#
public REX.ContentGenerator.Geometry.Contour_Section GetContour();
Description
Class

REXSectionDBDescription Class

Links
REXSectionDBDescription Class, REX.ContentGenerator.Families Namespace, REXSectionDBDescription Class


REXSectionDBDescription.GetName Method

REXSectionDBDescription.GetName Method
REXSectionDBDescription Class REX.ContentGenerator.Families Namespace REXSectionDBDescription Class

Gets the name of the section.

C#
public override string GetName();
Returns

Returns the name.

Description
Class

REXSectionDBDescription Class

Links
REXSectionDBDescription Class, REX.ContentGenerator.Families Namespace, REXSectionDBDescription Class


REXSectionDBDescription.GetSectionType Method ()

REXSectionDBDescription.GetSectionType Method ()
REXSectionDBDescription Class REX.ContentGenerator.Families Namespace REXSectionDBDescription Class

Gets the type of the section.

C#
public EDBSectionType GetSectionType();
Description
Class

REXSectionDBDescription Class

Links
REXSectionDBDescription Class, REX.ContentGenerator.Families Namespace, REXSectionDBDescription Class


REXSectionDBDescription.GetSectionType Method (int)

REXSectionDBDescription.GetSectionType Method (int)
REXSectionDBDescription Class REX.ContentGenerator.Families Namespace REXSectionDBDescription Class

Gets the type of the section.

C#
public static EDBSectionType GetSectionType(int st);
Parameters
Parameters | Description
st | The section type.
Description
Class

REXSectionDBDescription Class

Links
REXSectionDBDescription Class, REX.ContentGenerator.Families Namespace, REXSectionDBDescription Class


REXSectionDBDescription.Characteristics Property

REXSectionDBDescription.Characteristics Property
REXSectionDBDescription Class REX.ContentGenerator.Families Namespace REXSectionDBDescription Class

Gets or sets the characteristics of the section.

C#
public REXSectionDBCharacteristics Characteristics;
Description

The characteristics of the section.

Class

REXSectionDBDescription Class

Links
REXSectionDBDescription Class, REX.ContentGenerator.Families Namespace, REXSectionDBDescription Class


REXSectionDBDescription.Description Property

REXSectionDBDescription.Description Property
REXSectionDBDescription Class REX.ContentGenerator.Families Namespace REXSectionDBDescription Class

Gets or sets the description of the section.

C#
public REX.ContentGenerator.Families.REXSectionDBProperties Description;
Description

The description of the section.

Class

REXSectionDBDescription Class

Links
REXSectionDBDescription Class, REX.ContentGenerator.Families Namespace, REXSectionDBDescription Class


REXSectionDBDescription.DIM1 Property

REXSectionDBDescription.DIM1 Property
REXSectionDBDescription Class REX.ContentGenerator.Families Namespace REXSectionDBDescription Class

Gets or sets the first numeric component of the section label

C#
public double DIM1;
Description
Remarks

It is taken as key for identification process in a database (with combination of: NAME, DIM2, DIM3).

Class

REXSectionDBDescription Class

Links
REXSectionDBDescription Class, REX.ContentGenerator.Families Namespace, REXSectionDBDescription Class


REXSectionDBDescription.DIM2 Property

REXSectionDBDescription.DIM2 Property
REXSectionDBDescription Class REX.ContentGenerator.Families Namespace REXSectionDBDescription Class

Gets or sets the second numeric component of the section label.

C#
public double DIM2;
Description

The second numeric component of the section label.

Remarks

It is taken as key for identification process in a database (with combination of: NAME, DIM1, DIM3).

Class

REXSectionDBDescription Class

Links
REXSectionDBDescription Class, REX.ContentGenerator.Families Namespace, REXSectionDBDescription Class


REXSectionDBDescription.DIM3 Property

REXSectionDBDescription.DIM3 Property
REXSectionDBDescription Class REX.ContentGenerator.Families Namespace REXSectionDBDescription Class

Gets or sets the third numeric component of the section label.

C#
public double DIM3;
Description

The third numeric component of the section label.

Remarks

It is taken as key for identification process in a database (with combination of: NAME, DIM1, DIM2).

Class

REXSectionDBDescription Class

Links
REXSectionDBDescription Class, REX.ContentGenerator.Families Namespace, REXSectionDBDescription Class


REXSectionDBDescription.Dimensions Property

REXSectionDBDescription.Dimensions Property
REXSectionDBDescription Class REX.ContentGenerator.Families Namespace REXSectionDBDescription Class

Gets or sets the dimensions.

C#
public REX.ContentGenerator.Families.REXSectionDBDimensions Dimensions;
Description

The dimensions.

Class

REXSectionDBDescription Class

Links
REXSectionDBDescription Class, REX.ContentGenerator.Families Namespace, REXSectionDBDescription Class


REXSectionDBDescription.NAME Property

REXSectionDBDescription.NAME Property
REXSectionDBDescription Class REX.ContentGenerator.Families Namespace REXSectionDBDescription Class

Gets or sets the name of the section.

C#
public string NAME;
Description

The name.

Remarks

It is taken as key for identification process in a database (with combination of: DIM1, DIM2, DIM3).

Class

REXSectionDBDescription Class

Links
REXSectionDBDescription Class, REX.ContentGenerator.Families Namespace, REXSectionDBDescription Class


REXSectionDBDimensions Class

REXSectionDBDimensions Class
REX.ContentGenerator.Families Namespace Legend Members Public Methods REXSectionDBDimensions Methods REXSectionDBDimensions Properties

Describes dimensions of the database section.

Class Hierarchy
C#
[Serializable()]
public class REXSectionDBDimensions : REXDescription;
Description
Namespace

REX.ContentGenerator.Families Namespace

Public Methods
Public Method | Description
REXSectionDBDimensions | Initializes a new instance of the REXSectionDBDimensions class.
REXSectionDBDimensions | Initializes a new instance of the REXSectionDBDimensions class.
REXSectionDBDimensions | Initializes a new instance of the REXSectionDBDimensions class.
REXSectionDBDimensions | Initializes a new instance of the REXSectionDBDimensions class.
REXSectionDBDimensions Methods
REXSectionDBDimensions Methods | Description
Clone | Creates a new object that is a copy of the current instance.
REXSectionDBDimensions Properties
REXSectionDBDimensions Properties | Description
A_1 | Gets or sets the additional angle.
A_2 | Gets or sets the additional angle.
B | Gets or sets the section's width.
B_2 | Gets or sets the AISC k value for design.
EA | Gets or sets the web thickness.
ES | Gets or sets the flange thickness.
ES_2 | Gets or sets the AISC design value k.
GAMMA | Gets or sets the angle of rotation of the section local to principal coordinate system (maximum moments of inertia of a section).
GAP | Gets or sets the distance between sections in compound sections.
H | Gets or sets the section's height.
P1_L | Gets or sets the length of slab P2 (cross-shaped section).
P1_T | Gets or sets the thickness of slab P1 (cross-shaped section).
P2_L | Gets or sets the length of slab P2 (cross-shaped section).
P2_T | Gets or sets the Thickness of slab P2 (cross-shaped section).
P3_L | Gets or sets the Length of slab P3 (cross-shaped section).
P3_T | Gets or sets the thickness of slab P3 (cross-shaped section).
P4_L | Gets or sets the length of slab P4 (cross-shaped section).
P4_T | Gets or sets the thickness of slab P4 (cross-shaped section).
RA | Gets or sets the fillet radius (web).
RS | Gets or sets the fillet radius (flange).
SLOPE_FACTOR | Gets or sets the slope factor.
VPY | Gets or sets the extreme distance from the local Z axis of the point on the negative side of the Y axis.
VPZ | Gets or sets the extreme distance from the local Y axis of the point on the negative side of the Z axis.
VY | Gets or sets the extreme distance from the local Z axis of the point on the positive side of the Y axis.
VZ | Gets or sets the extreme distance from the local Y axis of the point on the positive side of the Z axis.
Links
REX.ContentGenerator.Families Namespace, Legend, Members, Public Methods, REXSectionDBDimensions Methods, REXSectionDBDimensions Properties


REXSectionDBDimensions.REXSectionDBDimensions Constructor ()

REXSectionDBDimensions.REXSectionDBDimensions Constructor ()
REXSectionDBDimensions Class REX.ContentGenerator.Families Namespace REXSectionDBDimensions Class

Initializes a new instance of the REXSectionDBDimensions class.

C#
public REXSectionDBDimensions();
Description
Class

REXSectionDBDimensions Class

Links
REXSectionDBDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionDBDimensions Class


REXSectionDBDimensions.REXSectionDBDimensions Constructor (DTableDataObjectCollection)

REXSectionDBDimensions.REXSectionDBDimensions Constructor (DTableDataObjectCollection)
REXSectionDBDimensions Class REX.ContentGenerator.Families Namespace REXSectionDBDimensions Class

Initializes a new instance of the REXSectionDBDimensions class.

C#
public REXSectionDBDimensions(DTableDataObjectCollection pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

REXSectionDBDimensions Class

Links
REXSectionDBDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionDBDimensions Class


REXSectionDBDimensions.REXSectionDBDimensions Constructor (REXSectionDBDimensions)

REXSectionDBDimensions.REXSectionDBDimensions Constructor (REXSectionDBDimensions)
REXSectionDBDimensions Class REX.ContentGenerator.Families Namespace REXSectionDBDimensions Class

Initializes a new instance of the REXSectionDBDimensions class.

C#
public REXSectionDBDimensions(REXSectionDBDimensions pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

REXSectionDBDimensions Class

Links
REXSectionDBDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionDBDimensions Class


REXSectionDBDimensions.REXSectionDBDimensions Constructor (System.Data.DataRow)

REXSectionDBDimensions.REXSectionDBDimensions Constructor (System.Data.DataRow)
REXSectionDBDimensions Class REX.ContentGenerator.Families Namespace REXSectionDBDimensions Class

Initializes a new instance of the REXSectionDBDimensions class.

C#
public REXSectionDBDimensions(System.Data.DataRow pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

REXSectionDBDimensions Class

Links
REXSectionDBDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionDBDimensions Class


REXSectionDBDimensions.Clone Method

REXSectionDBDimensions.Clone Method
REXSectionDBDimensions Class REX.ContentGenerator.Families Namespace REXSectionDBDimensions Class

Creates a new object that is a copy of the current instance.

C#
public override object Clone();
Returns

A new object that is a copy of this instance.

Description
Class

REXSectionDBDimensions Class

Links
REXSectionDBDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionDBDimensions Class


REXSectionDBDimensions.A_1 Property

REXSectionDBDimensions.A_1 Property
REXSectionDBDimensions Class REX.ContentGenerator.Families Namespace REXSectionDBDimensions Class

Gets or sets the additional angle.

C#
public double A_1;
Description

The additional angle.

Class

REXSectionDBDimensions Class

Links
REXSectionDBDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionDBDimensions Class


REXSectionDBDimensions.A_2 Property

REXSectionDBDimensions.A_2 Property
REXSectionDBDimensions Class REX.ContentGenerator.Families Namespace REXSectionDBDimensions Class

Gets or sets the additional angle.

C#
public double A_2;
Description

The additional angle.

Class

REXSectionDBDimensions Class

Links
REXSectionDBDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionDBDimensions Class


REXSectionDBDimensions.B Property

REXSectionDBDimensions.B Property
REXSectionDBDimensions Class REX.ContentGenerator.Families Namespace REXSectionDBDimensions Class

Gets or sets the section's width.

C#
public double B;
Description

The section's width.

Class

REXSectionDBDimensions Class

Links
REXSectionDBDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionDBDimensions Class


REXSectionDBDimensions.B_2 Property

REXSectionDBDimensions.B_2 Property
REXSectionDBDimensions Class REX.ContentGenerator.Families Namespace REXSectionDBDimensions Class

Gets or sets the AISC k value for design.

C#
public double B_2;
Description

The AISC k value for design.

Class

REXSectionDBDimensions Class

Links
REXSectionDBDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionDBDimensions Class


REXSectionDBDimensions.EA Property

REXSectionDBDimensions.EA Property
REXSectionDBDimensions Class REX.ContentGenerator.Families Namespace REXSectionDBDimensions Class

Gets or sets the web thickness.

C#
public double EA;
Description

The web thickness.

Class

REXSectionDBDimensions Class

Links
REXSectionDBDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionDBDimensions Class


REXSectionDBDimensions.ES Property

REXSectionDBDimensions.ES Property
REXSectionDBDimensions Class REX.ContentGenerator.Families Namespace REXSectionDBDimensions Class

Gets or sets the flange thickness.

C#
public double ES;
Description

The flange thickness.

Class

REXSectionDBDimensions Class

Links
REXSectionDBDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionDBDimensions Class


REXSectionDBDimensions.ES_2 Property

REXSectionDBDimensions.ES_2 Property
REXSectionDBDimensions Class REX.ContentGenerator.Families Namespace REXSectionDBDimensions Class

Gets or sets the AISC design value k.

C#
public double ES_2;
Description

The AISC design value k.

Class

REXSectionDBDimensions Class

Links
REXSectionDBDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionDBDimensions Class


REXSectionDBDimensions.GAMMA Property

REXSectionDBDimensions.GAMMA Property
REXSectionDBDimensions Class REX.ContentGenerator.Families Namespace REXSectionDBDimensions Class

Gets or sets the angle of rotation of the section local to principal coordinate system (maximum moments of inertia of a section).

C#
public double GAMMA;
Description

The angle of rotation of the section.

Class

REXSectionDBDimensions Class

Links
REXSectionDBDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionDBDimensions Class


REXSectionDBDimensions.GAP Property

REXSectionDBDimensions.GAP Property
REXSectionDBDimensions Class REX.ContentGenerator.Families Namespace REXSectionDBDimensions Class

Gets or sets the distance between sections in compound sections.

C#
public double GAP;
Description

The distance between sections in compound sections.

Class

REXSectionDBDimensions Class

Links
REXSectionDBDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionDBDimensions Class


REXSectionDBDimensions.H Property

REXSectionDBDimensions.H Property
REXSectionDBDimensions Class REX.ContentGenerator.Families Namespace REXSectionDBDimensions Class

Gets or sets the section's height.

C#
public double H;
Description

The section's height.

Class

REXSectionDBDimensions Class

Links
REXSectionDBDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionDBDimensions Class


REXSectionDBDimensions.P1_L Property

REXSectionDBDimensions.P1_L Property
REXSectionDBDimensions Class REX.ContentGenerator.Families Namespace REXSectionDBDimensions Class

Gets or sets the length of slab P2 (cross-shaped section).

C#
public double P1_L;
Description

The length of slab P2 (cross-shaped section).

Class

REXSectionDBDimensions Class

Links
REXSectionDBDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionDBDimensions Class


REXSectionDBDimensions.P1_T Property

REXSectionDBDimensions.P1_T Property
REXSectionDBDimensions Class REX.ContentGenerator.Families Namespace REXSectionDBDimensions Class

Gets or sets the thickness of slab P1 (cross-shaped section).

C#
public double P1_T;
Description

The thickness of slab P1 (cross-shaped section).

Class

REXSectionDBDimensions Class

Links
REXSectionDBDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionDBDimensions Class


REXSectionDBDimensions.P2_L Property

REXSectionDBDimensions.P2_L Property
REXSectionDBDimensions Class REX.ContentGenerator.Families Namespace REXSectionDBDimensions Class

Gets or sets the length of slab P2 (cross-shaped section).

C#
public double P2_L;
Description

The length of slab P2 (cross-shaped section).

Class

REXSectionDBDimensions Class

Links
REXSectionDBDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionDBDimensions Class


REXSectionDBDimensions.P2_T Property

REXSectionDBDimensions.P2_T Property
REXSectionDBDimensions Class REX.ContentGenerator.Families Namespace REXSectionDBDimensions Class

Gets or sets the Thickness of slab P2 (cross-shaped section).

C#
public double P2_T;
Description

The Thickness of slab P2 (cross-shaped section).

Class

REXSectionDBDimensions Class

Links
REXSectionDBDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionDBDimensions Class


REXSectionDBDimensions.P3_L Property

REXSectionDBDimensions.P3_L Property
REXSectionDBDimensions Class REX.ContentGenerator.Families Namespace REXSectionDBDimensions Class

Gets or sets the Length of slab P3 (cross-shaped section).

C#
public double P3_L;
Description

The length of slab P3 (cross-shaped section).

Class

REXSectionDBDimensions Class

Links
REXSectionDBDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionDBDimensions Class


REXSectionDBDimensions.P3_T Property

REXSectionDBDimensions.P3_T Property
REXSectionDBDimensions Class REX.ContentGenerator.Families Namespace REXSectionDBDimensions Class

Gets or sets the thickness of slab P3 (cross-shaped section).

C#
public double P3_T;
Description

The thickness of slab P3 (cross-shaped section).

Class

REXSectionDBDimensions Class

Links
REXSectionDBDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionDBDimensions Class


REXSectionDBDimensions.P4_L Property

REXSectionDBDimensions.P4_L Property
REXSectionDBDimensions Class REX.ContentGenerator.Families Namespace REXSectionDBDimensions Class

Gets or sets the length of slab P4 (cross-shaped section).

C#
public double P4_L;
Description

The length of slab P4 (cross-shaped section).

Class

REXSectionDBDimensions Class

Links
REXSectionDBDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionDBDimensions Class


REXSectionDBDimensions.P4_T Property

REXSectionDBDimensions.P4_T Property
REXSectionDBDimensions Class REX.ContentGenerator.Families Namespace REXSectionDBDimensions Class

Gets or sets the thickness of slab P4 (cross-shaped section).

C#
public double P4_T;
Description

The thickness of slab P4 (cross-shaped section).

Class

REXSectionDBDimensions Class

Links
REXSectionDBDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionDBDimensions Class


REXSectionDBDimensions.RA Property

REXSectionDBDimensions.RA Property
REXSectionDBDimensions Class REX.ContentGenerator.Families Namespace REXSectionDBDimensions Class

Gets or sets the fillet radius (web).

C#
public double RA;
Description

The fillet radius (web).

Class

REXSectionDBDimensions Class

Links
REXSectionDBDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionDBDimensions Class


REXSectionDBDimensions.RS Property

REXSectionDBDimensions.RS Property
REXSectionDBDimensions Class REX.ContentGenerator.Families Namespace REXSectionDBDimensions Class

Gets or sets the fillet radius (flange).

C#
public double RS;
Description

The fillet radius (flange).

Class

REXSectionDBDimensions Class

Links
REXSectionDBDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionDBDimensions Class


REXSectionDBDimensions.SLOPE_FACTOR Property

REXSectionDBDimensions.SLOPE_FACTOR Property
REXSectionDBDimensions Class REX.ContentGenerator.Families Namespace REXSectionDBDimensions Class

Gets or sets the slope factor.

C#
public double SLOPE_FACTOR;
Description

The slope factor.

Class

REXSectionDBDimensions Class

Links
REXSectionDBDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionDBDimensions Class


REXSectionDBDimensions.VPY Property

REXSectionDBDimensions.VPY Property
REXSectionDBDimensions Class REX.ContentGenerator.Families Namespace REXSectionDBDimensions Class

Gets or sets the extreme distance from the local Z axis of the point on the negative side of the Y axis.

C#
public double VPY;
Description

The extreme distance from the local Z axis of the point on the negative side of the Y axis.

Class

REXSectionDBDimensions Class

Links
REXSectionDBDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionDBDimensions Class


REXSectionDBDimensions.VPZ Property

REXSectionDBDimensions.VPZ Property
REXSectionDBDimensions Class REX.ContentGenerator.Families Namespace REXSectionDBDimensions Class

Gets or sets the extreme distance from the local Y axis of the point on the negative side of the Z axis.

C#
public double VPZ;
Description

The extreme distance from the local Y axis of the point on the negative side of the Z axis.

Class

REXSectionDBDimensions Class

Links
REXSectionDBDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionDBDimensions Class


REXSectionDBDimensions.VY Property

REXSectionDBDimensions.VY Property
REXSectionDBDimensions Class REX.ContentGenerator.Families Namespace REXSectionDBDimensions Class

Gets or sets the extreme distance from the local Z axis of the point on the positive side of the Y axis.

C#
public double VY;
Description

The extreme distance from the local Z axis of the point on the positive side of the Y axis.

Class

REXSectionDBDimensions Class

Links
REXSectionDBDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionDBDimensions Class


REXSectionDBDimensions.VZ Property

REXSectionDBDimensions.VZ Property
REXSectionDBDimensions Class REX.ContentGenerator.Families Namespace REXSectionDBDimensions Class

Gets or sets the extreme distance from the local Y axis of the point on the positive side of the Z axis.

C#
public double VZ;
Description

The extreme distance from the local Y axis of the point on the positive side of the Z axis.

Class

REXSectionDBDimensions Class

Links
REXSectionDBDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionDBDimensions Class


REXSectionDBProperties Class

REXSectionDBProperties Class
REX.ContentGenerator.Families Namespace Legend Members Public Methods REXSectionDBProperties Methods REXSectionDBProperties Properties

Describes properties of the database section.

Class Hierarchy
C#
[Serializable()]
public class REXSectionDBProperties : REXDescription;
Description
Namespace

REX.ContentGenerator.Families Namespace

Public Methods
Public Method | Description
REXSectionDBProperties | Initializes a new instance of the REXSectionDBProperties class.
REXSectionDBProperties | Initializes a new instance of the REXSectionDBProperties class.
REXSectionDBProperties | Initializes a new instance of the
REXSectionDBProperties | Initializes a new instance of the REXSectionDBProperties class.
REXSectionDBProperties Methods
REXSectionDBProperties Methods | Description
Clone | Creates a new object that is a copy of the current instance.
REXSectionDBProperties Properties
REXSectionDBProperties Properties | Description
DIM1 | Gets or sets the first numeric component of the section label
DIM2 | Gets or sets the second numeric component of the section label.
DIM3 | Gets or sets the third numeric component of the section label.
NAME | Gets or sets the name of the section.
NAME_REVIT | Gets or sets the Revit name.
NAME1 | Gets or sets the section name.
Names | Gets or sets the list of optional names.
SHAPE_TYPE | Gets or sets the number of the section shape type.
Links
REX.ContentGenerator.Families Namespace, Legend, Members, Public Methods, REXSectionDBProperties Methods, REXSectionDBProperties Properties


REXSectionDBProperties.REXSectionDBProperties Constructor ()

REXSectionDBProperties.REXSectionDBProperties Constructor ()
REXSectionDBProperties Class REX.ContentGenerator.Families Namespace REXSectionDBProperties Class

Initializes a new instance of the REXSectionDBProperties class.

C#
public REXSectionDBProperties();
Description
Class

REXSectionDBProperties Class

Links
REXSectionDBProperties Class, REX.ContentGenerator.Families Namespace, REXSectionDBProperties Class


REXSectionDBProperties.REXSectionDBProperties Constructor (DTableDataObjectCollection)

REXSectionDBProperties.REXSectionDBProperties Constructor (DTableDataObjectCollection)
REXSectionDBProperties Class REX.ContentGenerator.Families Namespace REXSectionDBProperties Class

Initializes a new instance of the REXSectionDBProperties class.

C#
public REXSectionDBProperties(DTableDataObjectCollection pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

REXSectionDBProperties Class

Links
REXSectionDBProperties Class, REX.ContentGenerator.Families Namespace, REXSectionDBProperties Class


REXSectionDBProperties.REXSectionDBProperties Constructor (REXSectionDBProperties)

REXSectionDBProperties.REXSectionDBProperties Constructor (REXSectionDBProperties)
REXSectionDBProperties Class REX.ContentGenerator.Families Namespace REXSectionDBProperties Class

Initializes a new instance of the

C#
public REXSectionDBProperties(REXSectionDBProperties pattern);
Parameters
Parameters | Description
pattern | The pattern.
Class

REXSectionDBProperties Class

Links
REXSectionDBProperties Class, REX.ContentGenerator.Families Namespace, REXSectionDBProperties Class


REXSectionDBProperties.REXSectionDBProperties Constructor (System.Data.DataRow)

REXSectionDBProperties.REXSectionDBProperties Constructor (System.Data.DataRow)
REXSectionDBProperties Class REX.ContentGenerator.Families Namespace REXSectionDBProperties Class

Initializes a new instance of the REXSectionDBProperties class.

C#
public REXSectionDBProperties(System.Data.DataRow pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

REXSectionDBProperties Class

Links
REXSectionDBProperties Class, REX.ContentGenerator.Families Namespace, REXSectionDBProperties Class


REXSectionDBProperties.Clone Method

REXSectionDBProperties.Clone Method
REXSectionDBProperties Class REX.ContentGenerator.Families Namespace REXSectionDBProperties Class

Creates a new object that is a copy of the current instance.

C#
public override object Clone();
Returns

A new object that is a copy of this instance.

Description
Class

REXSectionDBProperties Class

Links
REXSectionDBProperties Class, REX.ContentGenerator.Families Namespace, REXSectionDBProperties Class


REXSectionDBProperties.DIM1 Property

REXSectionDBProperties.DIM1 Property
REXSectionDBProperties Class REX.ContentGenerator.Families Namespace REXSectionDBProperties Class

Gets or sets the first numeric component of the section label

C#
public double DIM1;
Description
Remarks

It is taken as key for identification process in a database (with combination of: NAME, DIM2, DIM3).

Class

REXSectionDBProperties Class

Links
REXSectionDBProperties Class, REX.ContentGenerator.Families Namespace, REXSectionDBProperties Class


REXSectionDBProperties.DIM2 Property

REXSectionDBProperties.DIM2 Property
REXSectionDBProperties Class REX.ContentGenerator.Families Namespace REXSectionDBProperties Class

Gets or sets the second numeric component of the section label.

C#
public double DIM2;
Description

The second numeric component of the section label.

Remarks

It is taken as key for identification process in a database (with combination of: NAME, DIM1, DIM3).

Class

REXSectionDBProperties Class

Links
REXSectionDBProperties Class, REX.ContentGenerator.Families Namespace, REXSectionDBProperties Class


REXSectionDBProperties.DIM3 Property

REXSectionDBProperties.DIM3 Property
REXSectionDBProperties Class REX.ContentGenerator.Families Namespace REXSectionDBProperties Class

Gets or sets the third numeric component of the section label.

C#
public double DIM3;
Description

The third numeric component of the section label.

Remarks

It is taken as key for identification process in a database (with combination of: NAME, DIM1, DIM2).

Class

REXSectionDBProperties Class

Links
REXSectionDBProperties Class, REX.ContentGenerator.Families Namespace, REXSectionDBProperties Class


REXSectionDBProperties.NAME Property

REXSectionDBProperties.NAME Property
REXSectionDBProperties Class REX.ContentGenerator.Families Namespace REXSectionDBProperties Class

Gets or sets the name of the section.

C#
public string NAME;
Description

The name.

Remarks

It is taken as key for identification process in a database (with combination of: DIM1, DIM2, DIM3).

Class

REXSectionDBProperties Class

Links
REXSectionDBProperties Class, REX.ContentGenerator.Families Namespace, REXSectionDBProperties Class


REXSectionDBProperties.NAME_REVIT Property

REXSectionDBProperties.NAME_REVIT Property
REXSectionDBProperties Class REX.ContentGenerator.Families Namespace REXSectionDBProperties Class

Gets or sets the Revit name.

C#
public string NAME_REVIT;
Description

The Revit name.

Remarks

It is taken as key for identification process in a database when element is mapped.

Class

REXSectionDBProperties Class

Links
REXSectionDBProperties Class, REX.ContentGenerator.Families Namespace, REXSectionDBProperties Class


REXSectionDBProperties.NAME1 Property

REXSectionDBProperties.NAME1 Property
REXSectionDBProperties Class REX.ContentGenerator.Families Namespace REXSectionDBProperties Class

Gets or sets the section name.

C#
public string NAME1;
Description

The section name.

Class

REXSectionDBProperties Class

Links
REXSectionDBProperties Class, REX.ContentGenerator.Families Namespace, REXSectionDBProperties Class


REXSectionDBProperties.Names Property

REXSectionDBProperties.Names Property
REXSectionDBProperties Class REX.ContentGenerator.Families Namespace REXSectionDBProperties Class

Gets or sets the list of optional names.

C#
public List<string> Names;
Description

The list of names.

Class

REXSectionDBProperties Class

Links
REXSectionDBProperties Class, REX.ContentGenerator.Families Namespace, REXSectionDBProperties Class


REXSectionDBProperties.SHAPE_TYPE Property

REXSectionDBProperties.SHAPE_TYPE Property
REXSectionDBProperties Class REX.ContentGenerator.Families Namespace REXSectionDBProperties Class

Gets or sets the number of the section shape type.

C#
public int SHAPE_TYPE;
Description

The number of the section shape type.

Class

REXSectionDBProperties Class

Links
REXSectionDBProperties Class, REX.ContentGenerator.Families Namespace, REXSectionDBProperties Class


REXSectionParamCharacteristics Class

REXSectionParamCharacteristics Class
REX.ContentGenerator.Families Namespace Legend Members Public Methods REXSectionParamCharacteristics Methods REXSectionParamCharacteristics Properties

Describes characteristics of the parametric section.

Class Hierarchy
C#
[Serializable()]
public class REXSectionParamCharacteristics : REXDescription;
Description
Namespace

REX.ContentGenerator.Families Namespace

Public Methods
Public Method | Description
REXSectionParamCharacteristics | Initializes a new instance of the REXSectionParamCharacteristics class.
REXSectionParamCharacteristics | Initializes a new instance of the REXSectionParamCharacteristics class.
REXSectionParamCharacteristics | Initializes a new instance of the REXSectionParamCharacteristics class.
REXSectionParamCharacteristics | Initializes a new instance of the REXSectionParamCharacteristics class.
REXSectionParamCharacteristics Methods
REXSectionParamCharacteristics Methods | Description
Clone | Clones this instance.
REXSectionParamCharacteristics Properties
REXSectionParamCharacteristics Properties | Description
A | Gets or sets the Cross-section area.
IY | Gets or sets the moment of inertia about the Y axis.
IZ | Gets or sets the moment of inertia about the Z axis.
MASS | Gets or sets the nominal weight per unit length.
Links
REX.ContentGenerator.Families Namespace, Legend, Members, Public Methods, REXSectionParamCharacteristics Methods, REXSectionParamCharacteristics Properties


REXSectionParamCharacteristics.REXSectionParamCharacteristics Constructor ()

REXSectionParamCharacteristics.REXSectionParamCharacteristics Constructor ()
REXSectionParamCharacteristics Class REX.ContentGenerator.Families Namespace REXSectionParamCharacteristics Class

Initializes a new instance of the REXSectionParamCharacteristics class.

C#
public REXSectionParamCharacteristics();
Description
Class

REXSectionParamCharacteristics Class

Links
REXSectionParamCharacteristics Class, REX.ContentGenerator.Families Namespace, REXSectionParamCharacteristics Class


REXSectionParamCharacteristics.REXSectionParamCharacteristics Constructor (DTableDataObjectCollection)

REXSectionParamCharacteristics.REXSectionParamCharacteristics Constructor (DTableDataObjectCollection)
REXSectionParamCharacteristics Class REX.ContentGenerator.Families Namespace REXSectionParamCharacteristics Class

Initializes a new instance of the REXSectionParamCharacteristics class.

C#
public REXSectionParamCharacteristics(DTableDataObjectCollection pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

REXSectionParamCharacteristics Class

Links
REXSectionParamCharacteristics Class, REX.ContentGenerator.Families Namespace, REXSectionParamCharacteristics Class


REXSectionParamCharacteristics.REXSectionParamCharacteristics Constructor (REXSectionParamCharacteristics)

REXSectionParamCharacteristics.REXSectionParamCharacteristics Constructor (REXSectionParamCharacteristics)
REXSectionParamCharacteristics Class REX.ContentGenerator.Families Namespace REXSectionParamCharacteristics Class

Initializes a new instance of the REXSectionParamCharacteristics class.

C#
public REXSectionParamCharacteristics(REXSectionParamCharacteristics pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

REXSectionParamCharacteristics Class

Links
REXSectionParamCharacteristics Class, REX.ContentGenerator.Families Namespace, REXSectionParamCharacteristics Class


REXSectionParamCharacteristics.REXSectionParamCharacteristics Constructor (System.Data.DataRow)

REXSectionParamCharacteristics.REXSectionParamCharacteristics Constructor (System.Data.DataRow)
REXSectionParamCharacteristics Class REX.ContentGenerator.Families Namespace REXSectionParamCharacteristics Class

Initializes a new instance of the REXSectionParamCharacteristics class.

C#
public REXSectionParamCharacteristics(System.Data.DataRow pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

REXSectionParamCharacteristics Class

Links
REXSectionParamCharacteristics Class, REX.ContentGenerator.Families Namespace, REXSectionParamCharacteristics Class


REXSectionParamCharacteristics.Clone Method

REXSectionParamCharacteristics.Clone Method
REXSectionParamCharacteristics Class REX.ContentGenerator.Families Namespace REXSectionParamCharacteristics Class

Clones this instance.

C#
public override object Clone();
Returns

New instance

Description
Class

REXSectionParamCharacteristics Class

Links
REXSectionParamCharacteristics Class, REX.ContentGenerator.Families Namespace, REXSectionParamCharacteristics Class


REXSectionParamCharacteristics.A Property

REXSectionParamCharacteristics.A Property
REXSectionParamCharacteristics Class REX.ContentGenerator.Families Namespace REXSectionParamCharacteristics Class

Gets or sets the Cross-section area.

C#
public double A;
Description

The Cross-section area.

Class

REXSectionParamCharacteristics Class

Links
REXSectionParamCharacteristics Class, REX.ContentGenerator.Families Namespace, REXSectionParamCharacteristics Class


REXSectionParamCharacteristics.IY Property

REXSectionParamCharacteristics.IY Property
REXSectionParamCharacteristics Class REX.ContentGenerator.Families Namespace REXSectionParamCharacteristics Class

Gets or sets the moment of inertia about the Y axis.

C#
public double IY;
Description

The moment of inertia about the Y axis.

Class

REXSectionParamCharacteristics Class

Links
REXSectionParamCharacteristics Class, REX.ContentGenerator.Families Namespace, REXSectionParamCharacteristics Class


REXSectionParamCharacteristics.IZ Property

REXSectionParamCharacteristics.IZ Property
REXSectionParamCharacteristics Class REX.ContentGenerator.Families Namespace REXSectionParamCharacteristics Class

Gets or sets the moment of inertia about the Z axis.

C#
public double IZ;
Description

The moment of inertia about the Z axis.

Class

REXSectionParamCharacteristics Class

Links
REXSectionParamCharacteristics Class, REX.ContentGenerator.Families Namespace, REXSectionParamCharacteristics Class


REXSectionParamCharacteristics.MASS Property

REXSectionParamCharacteristics.MASS Property
REXSectionParamCharacteristics Class REX.ContentGenerator.Families Namespace REXSectionParamCharacteristics Class

Gets or sets the nominal weight per unit length.

C#
public double MASS;
Description

The nominal weight per unit length.

Class

REXSectionParamCharacteristics Class

Links
REXSectionParamCharacteristics Class, REX.ContentGenerator.Families Namespace, REXSectionParamCharacteristics Class


REXSectionParamDescription Class

REXSectionParamDescription Class
REX.ContentGenerator.Families Namespace Legend Members Public Methods REXSectionParamDescription Methods REXSectionParamDescription Properties

Represents parameters of the parametric section.

Class Hierarchy
C#
[Serializable()]
public class REXSectionParamDescription : REXParamDescription;
Description
Namespace

REX.ContentGenerator.Families Namespace

Public Methods
Public Method | Description
REXSectionParamDescription | Initializes a new instance of the REXSectionParamDescription class.
REXSectionParamDescription | Initializes a new instance of the REXSectionParamDescription class.
REXSectionParamDescription | Initializes a new instance of the REXSectionParamDescription class.
REXSectionParamDescription | Initializes a new instance of the REXSectionParamDescription class.
REXSectionParamDescription Methods
REXSectionParamDescription Methods | Description
CalculataMainAxisAndCharacteristics | Calculatas the main axis and characteristics of the section.
CalculateCharacteristics | Calculates characteristics of the section.
CalculateMainAxisParams | Calculates the main axis of the section.
Clone | Creates a new object that is a copy of the current instance.
CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
GetContour | Gets the contour.
GetMaterialDependence | Gets the material dependence.
REXSectionParamDescription Properties
REXSectionParamDescription Properties | Description
Angle | Gets or sets the angle of the section.
Characteristics | Gets or sets the characteristics.
CharacteristicsEnd | Gets or sets the characteristics of the end.
Contour | Gets or sets the contour.
Dimensions | Gets or sets the dimensions.
DimensionsEnd | Gets or sets the dimensions of the end.
IsTurned | Gets or sets a value indicating whether this instance is turned.
SectionType | Gets or sets the type of the section.
Tapered | Gets or sets a value indicating whether this REXSectionParamDescription is tapered.
Links
REX.ContentGenerator.Families Namespace, Legend, Members, Public Methods, REXSectionParamDescription Methods, REXSectionParamDescription Properties


REXSectionParamDescription.REXSectionParamDescription Constructor ()

REXSectionParamDescription.REXSectionParamDescription Constructor ()
REXSectionParamDescription Class REX.ContentGenerator.Families Namespace REXSectionParamDescription Class

Initializes a new instance of the REXSectionParamDescription class.

C#
public REXSectionParamDescription();
Description
Class

REXSectionParamDescription Class

Links
REXSectionParamDescription Class, REX.ContentGenerator.Families Namespace, REXSectionParamDescription Class


REXSectionParamDescription.REXSectionParamDescription Constructor (REXSectionParamDescription)

REXSectionParamDescription.REXSectionParamDescription Constructor (REXSectionParamDescription)
REXSectionParamDescription Class REX.ContentGenerator.Families Namespace REXSectionParamDescription Class

Initializes a new instance of the REXSectionParamDescription class.

C#
public REXSectionParamDescription(REXSectionParamDescription pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

REXSectionParamDescription Class

Links
REXSectionParamDescription Class, REX.ContentGenerator.Families Namespace, REXSectionParamDescription Class


REXSectionParamDescription.REXSectionParamDescription Constructor (REXSectionParams, EMaterial, REX.ContentGenerator.Families.EElementType)

REXSectionParamDescription.REXSectionParamDescription Constructor (REXSectionParams, EMaterial, REX.ContentGenerator.Families.EElementType)
REXSectionParamDescription Class REX.ContentGenerator.Families Namespace REXSectionParamDescription Class

Initializes a new instance of the REXSectionParamDescription class.

C#
public REXSectionParamDescription(REXSectionParams par, EMaterial mat, REX.ContentGenerator.Families.EElementType elemcat);
Parameters
Parameters | Description
par | The section parameters.
mat | The material.
elemcat | The type of the element.
Description
Class

REXSectionParamDescription Class

Links
REXSectionParamDescription Class, REX.ContentGenerator.Families Namespace, REXSectionParamDescription Class


REXSectionParamDescription.REXSectionParamDescription Constructor (bool)

REXSectionParamDescription.REXSectionParamDescription Constructor (bool)
REXSectionParamDescription Class REX.ContentGenerator.Families Namespace REXSectionParamDescription Class

Initializes a new instance of the REXSectionParamDescription class.

C#
public REXSectionParamDescription(bool tapered);
Parameters
Parameters | Description
tapered | Indicates whether the section is tapered.
Description
Class

REXSectionParamDescription Class

Links
REXSectionParamDescription Class, REX.ContentGenerator.Families Namespace, REXSectionParamDescription Class


REXSectionParamDescription.CalculataMainAxisAndCharacteristics Method

REXSectionParamDescription.CalculataMainAxisAndCharacteristics Method
REXSectionParamDescription Class REX.ContentGenerator.Families Namespace REXSectionParamDescription Class

Calculatas the main axis and characteristics of the section.

C#
public void CalculataMainAxisAndCharacteristics();
Description
Class

REXSectionParamDescription Class

Links
REXSectionParamDescription Class, REX.ContentGenerator.Families Namespace, REXSectionParamDescription Class


REXSectionParamDescription.CalculateCharacteristics Method

REXSectionParamDescription.CalculateCharacteristics Method
REXSectionParamDescription Class REX.ContentGenerator.Families Namespace REXSectionParamDescription Class

Calculates characteristics of the section.

C#
public void CalculateCharacteristics();
Description
Class

REXSectionParamDescription Class

Links
REXSectionParamDescription Class, REX.ContentGenerator.Families Namespace, REXSectionParamDescription Class


REXSectionParamDescription.CalculateMainAxisParams Method

REXSectionParamDescription.CalculateMainAxisParams Method
REXSectionParamDescription Class REX.ContentGenerator.Families Namespace REXSectionParamDescription Class

Calculates the main axis of the section.

C#
public void CalculateMainAxisParams();
Description
Class

REXSectionParamDescription Class

Links
REXSectionParamDescription Class, REX.ContentGenerator.Families Namespace, REXSectionParamDescription Class


REXSectionParamDescription.Clone Method

REXSectionParamDescription.Clone Method
REXSectionParamDescription Class REX.ContentGenerator.Families Namespace REXSectionParamDescription Class

Creates a new object that is a copy of the current instance.

C#
public override object Clone();
Returns

A new object that is a copy of this instance.

Description
Class

REXSectionParamDescription Class

Links
REXSectionParamDescription Class, REX.ContentGenerator.Families Namespace, REXSectionParamDescription Class


REXSectionParamDescription.CompareTo Method

REXSectionParamDescription.CompareTo Method
REXSectionParamDescription Class REX.ContentGenerator.Families Namespace REXSectionParamDescription Class

Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.

C#
public override int CompareTo(object obj);
Parameters
Parameters | Description
obj | An object to compare with this instance.
Returns

Returns a result of the comparison.

Description
Class

REXSectionParamDescription Class

Links
REXSectionParamDescription Class, REX.ContentGenerator.Families Namespace, REXSectionParamDescription Class


REXSectionParamDescription.GetContour Method

REXSectionParamDescription.GetContour Method
REXSectionParamDescription Class REX.ContentGenerator.Families Namespace REXSectionParamDescription Class

Gets the contour.

C#
public REX.ContentGenerator.Geometry.Contour_Section GetContour(bool start);
Parameters
Parameters | Description
start | If of the start.
Description
Class

REXSectionParamDescription Class

Links
REXSectionParamDescription Class, REX.ContentGenerator.Families Namespace, REXSectionParamDescription Class


REXSectionParamDescription.GetMaterialDependence Method

REXSectionParamDescription.GetMaterialDependence Method
REXSectionParamDescription Class REX.ContentGenerator.Families Namespace REXSectionParamDescription Class

Gets the material dependence.

C#
public bool GetMaterialDependence(EMaterial mat, REX.ContentGenerator.Families.EElementType type);
Parameters
Parameters | Description
mat | The material.
type | The type.
Returns

If element is material dependent.

Description
Class

REXSectionParamDescription Class

Links
REXSectionParamDescription Class, REX.ContentGenerator.Families Namespace, REXSectionParamDescription Class


REXSectionParamDescription.Angle Property

REXSectionParamDescription.Angle Property
REXSectionParamDescription Class REX.ContentGenerator.Families Namespace REXSectionParamDescription Class

Gets or sets the angle of the section.

C#
public double Angle;
Description

The angle.

Remarks

It isn't taken to considaration during generation in Revit (only for detection of not certified families)

Class

REXSectionParamDescription Class

Links
REXSectionParamDescription Class, REX.ContentGenerator.Families Namespace, REXSectionParamDescription Class


REXSectionParamDescription.Characteristics Property

REXSectionParamDescription.Characteristics Property
REXSectionParamDescription Class REX.ContentGenerator.Families Namespace REXSectionParamDescription Class

Gets or sets the characteristics.

C#
public REXSectionParamCharacteristics Characteristics;
Description

The characteristics.

Class

REXSectionParamDescription Class

Links
REXSectionParamDescription Class, REX.ContentGenerator.Families Namespace, REXSectionParamDescription Class


REXSectionParamDescription.CharacteristicsEnd Property

REXSectionParamDescription.CharacteristicsEnd Property
REXSectionParamDescription Class REX.ContentGenerator.Families Namespace REXSectionParamDescription Class

Gets or sets the characteristics of the end.

C#
public REXSectionParamCharacteristics CharacteristicsEnd;
Description

The characteristics of the end.

Class

REXSectionParamDescription Class

Links
REXSectionParamDescription Class, REX.ContentGenerator.Families Namespace, REXSectionParamDescription Class


REXSectionParamDescription.Contour Property

REXSectionParamDescription.Contour Property
REXSectionParamDescription Class REX.ContentGenerator.Families Namespace REXSectionParamDescription Class

Gets or sets the contour.

C#
public REX.ContentGenerator.Geometry.Contour_Compound2D Contour;
Description

The contour.

Class

REXSectionParamDescription Class

Links
REXSectionParamDescription Class, REX.ContentGenerator.Families Namespace, REXSectionParamDescription Class


REXSectionParamDescription.Dimensions Property

REXSectionParamDescription.Dimensions Property
REXSectionParamDescription Class REX.ContentGenerator.Families Namespace REXSectionParamDescription Class

Gets or sets the dimensions.

C#
public REX.ContentGenerator.Families.REXSectionParamDimensions Dimensions;
Description

The dimensions.

Class

REXSectionParamDescription Class

Links
REXSectionParamDescription Class, REX.ContentGenerator.Families Namespace, REXSectionParamDescription Class


REXSectionParamDescription.DimensionsEnd Property

REXSectionParamDescription.DimensionsEnd Property
REXSectionParamDescription Class REX.ContentGenerator.Families Namespace REXSectionParamDescription Class

Gets or sets the dimensions of the end.

C#
public REX.ContentGenerator.Families.REXSectionParamDimensions DimensionsEnd;
Description

The dimensions of the end.

Class

REXSectionParamDescription Class

Links
REXSectionParamDescription Class, REX.ContentGenerator.Families Namespace, REXSectionParamDescription Class


REXSectionParamDescription.IsTurned Property

REXSectionParamDescription.IsTurned Property
REXSectionParamDescription Class REX.ContentGenerator.Families Namespace REXSectionParamDescription Class

Gets or sets a value indicating whether this instance is turned.

C#
public bool IsTurned;
Description

True if the instance is turned; otherwise, false.

Class

REXSectionParamDescription Class

Links
REXSectionParamDescription Class, REX.ContentGenerator.Families Namespace, REXSectionParamDescription Class


REXSectionParamDescription.SectionType Property

REXSectionParamDescription.SectionType Property
REXSectionParamDescription Class REX.ContentGenerator.Families Namespace REXSectionParamDescription Class

Gets or sets the type of the section.

C#
public REX.ContentGenerator.Families.ESectionType SectionType;
Description

The type of the section.

Class

REXSectionParamDescription Class

Links
REXSectionParamDescription Class, REX.ContentGenerator.Families Namespace, REXSectionParamDescription Class


REXSectionParamDescription.Tapered Property

REXSectionParamDescription.Tapered Property
REXSectionParamDescription Class REX.ContentGenerator.Families Namespace REXSectionParamDescription Class

Gets or sets a value indicating whether this REXSectionParamDescription is tapered.

C#
public bool Tapered;
Description

True if tapered; otherwise, false.

Class

REXSectionParamDescription Class

Links
REXSectionParamDescription Class, REX.ContentGenerator.Families Namespace, REXSectionParamDescription Class


REXSectionParamDimensions Class

REXSectionParamDimensions Class
REX.ContentGenerator.Families Namespace Legend Members Public Methods REXSectionParamDimensions Methods REXSectionParamDimensions Properties

Desribes dimentsions of the parametric section.

Class Hierarchy
C#
[Serializable()]
public class REXSectionParamDimensions : REXDescription;
Description
Namespace

REX.ContentGenerator.Families Namespace

Public Methods
Public Method | Description
REXSectionParamDimensions | Initializes a new instance of the REXSectionParamDimensions class.
REXSectionParamDimensions | Initializes a new instance of the REXSectionParamDimensions class.
REXSectionParamDimensions | Initializes a new instance of the REXSectionParamDimensions class.
REXSectionParamDimensions | Initializes a new instance of the REXSectionParamDimensions class.
REXSectionParamDimensions Methods
REXSectionParamDimensions Methods | Description
Clone | Creates a new object that is a copy of the current instance.
REXSectionParamDimensions Properties
REXSectionParamDimensions Properties | Description
b | Gets or sets the b.
b1 | Gets or sets the b1.
b2 | Gets or sets the b2.
bf | Gets or sets the bf.
d | Gets or sets the d.
h | Gets or sets the h.
h1 | Gets or sets the h1.
h2 | Gets or sets the h2.
l1 | Gets or sets the l1.
l2 | Gets or sets the l2.
P1_L | Gets or sets the P1_L.
P1_T | Gets or sets the P1_T.
P2_L | Gets or sets the P2_L.
P2_T | Gets or sets the P2_T.
P3_L | Gets or sets the P3_L.
P3_T | Gets or sets the P3_T.
P4_L | Gets or sets the P4_L.
P4_T | Gets or sets the P4_T.
t | Gets or sets the t.
tf | Gets or sets the tf.
tf1 | Gets or sets the tf1.
tf2 | Gets or sets the tf2.
tw | Gets or sets the tw.
vpy | Gets or sets the vpy.
vpz | Gets or sets the vpz.
vy | Gets or sets the vy.
vz | Gets or sets the vz.
Links
REX.ContentGenerator.Families Namespace, Legend, Members, Public Methods, REXSectionParamDimensions Methods, REXSectionParamDimensions Properties


REXSectionParamDimensions.REXSectionParamDimensions Constructor ()

REXSectionParamDimensions.REXSectionParamDimensions Constructor ()
REXSectionParamDimensions Class REX.ContentGenerator.Families Namespace REXSectionParamDimensions Class

Initializes a new instance of the REXSectionParamDimensions class.

C#
public REXSectionParamDimensions();
Description
Class

REXSectionParamDimensions Class

Links
REXSectionParamDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionParamDimensions Class


REXSectionParamDimensions.REXSectionParamDimensions Constructor (DTableDataObjectCollection)

REXSectionParamDimensions.REXSectionParamDimensions Constructor (DTableDataObjectCollection)
REXSectionParamDimensions Class REX.ContentGenerator.Families Namespace REXSectionParamDimensions Class

Initializes a new instance of the REXSectionParamDimensions class.

C#
public REXSectionParamDimensions(DTableDataObjectCollection pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

REXSectionParamDimensions Class

Links
REXSectionParamDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionParamDimensions Class


REXSectionParamDimensions.REXSectionParamDimensions Constructor (REXSectionParamDimensions)

REXSectionParamDimensions.REXSectionParamDimensions Constructor (REXSectionParamDimensions)
REXSectionParamDimensions Class REX.ContentGenerator.Families Namespace REXSectionParamDimensions Class

Initializes a new instance of the REXSectionParamDimensions class.

C#
public REXSectionParamDimensions(REXSectionParamDimensions pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

REXSectionParamDimensions Class

Links
REXSectionParamDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionParamDimensions Class


REXSectionParamDimensions.REXSectionParamDimensions Constructor (System.Data.DataRow)

REXSectionParamDimensions.REXSectionParamDimensions Constructor (System.Data.DataRow)
REXSectionParamDimensions Class REX.ContentGenerator.Families Namespace REXSectionParamDimensions Class

Initializes a new instance of the REXSectionParamDimensions class.

C#
public REXSectionParamDimensions(System.Data.DataRow pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

REXSectionParamDimensions Class

Links
REXSectionParamDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionParamDimensions Class


REXSectionParamDimensions.Clone Method

REXSectionParamDimensions.Clone Method
REXSectionParamDimensions Class REX.ContentGenerator.Families Namespace REXSectionParamDimensions Class

Creates a new object that is a copy of the current instance.

C#
public override object Clone();
Returns

A new object that is a copy of this instance.

Description
Class

REXSectionParamDimensions Class

Links
REXSectionParamDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionParamDimensions Class


REXSectionParamDimensions.b Property

REXSectionParamDimensions.b Property
REXSectionParamDimensions Class REX.ContentGenerator.Families Namespace REXSectionParamDimensions Class

Gets or sets the b.

C#
public double b;
Description

The b.

Class

REXSectionParamDimensions Class

Links
REXSectionParamDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionParamDimensions Class


REXSectionParamDimensions.b1 Property

REXSectionParamDimensions.b1 Property
REXSectionParamDimensions Class REX.ContentGenerator.Families Namespace REXSectionParamDimensions Class

Gets or sets the b1.

C#
public double b1;
Description

The b1.

Class

REXSectionParamDimensions Class

Links
REXSectionParamDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionParamDimensions Class


REXSectionParamDimensions.b2 Property

REXSectionParamDimensions.b2 Property
REXSectionParamDimensions Class REX.ContentGenerator.Families Namespace REXSectionParamDimensions Class

Gets or sets the b2.

C#
public double b2;
Description

The b2.

Class

REXSectionParamDimensions Class

Links
REXSectionParamDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionParamDimensions Class


REXSectionParamDimensions.bf Property

REXSectionParamDimensions.bf Property
REXSectionParamDimensions Class REX.ContentGenerator.Families Namespace REXSectionParamDimensions Class

Gets or sets the bf.

C#
public double bf;
Description

The bf.

Class

REXSectionParamDimensions Class

Links
REXSectionParamDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionParamDimensions Class


REXSectionParamDimensions.d Property

REXSectionParamDimensions.d Property
REXSectionParamDimensions Class REX.ContentGenerator.Families Namespace REXSectionParamDimensions Class

Gets or sets the d.

C#
public double d;
Description

The d.

Class

REXSectionParamDimensions Class

Links
REXSectionParamDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionParamDimensions Class


REXSectionParamDimensions.h Property

REXSectionParamDimensions.h Property
REXSectionParamDimensions Class REX.ContentGenerator.Families Namespace REXSectionParamDimensions Class

Gets or sets the h.

C#
public double h;
Description

The h.

Class

REXSectionParamDimensions Class

Links
REXSectionParamDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionParamDimensions Class


REXSectionParamDimensions.h1 Property

REXSectionParamDimensions.h1 Property
REXSectionParamDimensions Class REX.ContentGenerator.Families Namespace REXSectionParamDimensions Class

Gets or sets the h1.

C#
public double h1;
Description

The h1.

Class

REXSectionParamDimensions Class

Links
REXSectionParamDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionParamDimensions Class


REXSectionParamDimensions.h2 Property

REXSectionParamDimensions.h2 Property
REXSectionParamDimensions Class REX.ContentGenerator.Families Namespace REXSectionParamDimensions Class

Gets or sets the h2.

C#
public double h2;
Description

The h2.

Class

REXSectionParamDimensions Class

Links
REXSectionParamDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionParamDimensions Class


REXSectionParamDimensions.l1 Property

REXSectionParamDimensions.l1 Property
REXSectionParamDimensions Class REX.ContentGenerator.Families Namespace REXSectionParamDimensions Class

Gets or sets the l1.

C#
public double l1;
Description

The l1.

Class

REXSectionParamDimensions Class

Links
REXSectionParamDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionParamDimensions Class


REXSectionParamDimensions.l2 Property

REXSectionParamDimensions.l2 Property
REXSectionParamDimensions Class REX.ContentGenerator.Families Namespace REXSectionParamDimensions Class

Gets or sets the l2.

C#
public double l2;
Description

The l2.

Class

REXSectionParamDimensions Class

Links
REXSectionParamDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionParamDimensions Class


REXSectionParamDimensions.P1_L Property

REXSectionParamDimensions.P1_L Property
REXSectionParamDimensions Class REX.ContentGenerator.Families Namespace REXSectionParamDimensions Class

Gets or sets the P1_L.

C#
public double P1_L;
Description

The P1_L.

Class

REXSectionParamDimensions Class

Links
REXSectionParamDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionParamDimensions Class


REXSectionParamDimensions.P1_T Property

REXSectionParamDimensions.P1_T Property
REXSectionParamDimensions Class REX.ContentGenerator.Families Namespace REXSectionParamDimensions Class

Gets or sets the P1_T.

C#
public double P1_T;
Description

The P1_T.

Class

REXSectionParamDimensions Class

Links
REXSectionParamDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionParamDimensions Class


REXSectionParamDimensions.P2_L Property

REXSectionParamDimensions.P2_L Property
REXSectionParamDimensions Class REX.ContentGenerator.Families Namespace REXSectionParamDimensions Class

Gets or sets the P2_L.

C#
public double P2_L;
Description

The P2_L.

Class

REXSectionParamDimensions Class

Links
REXSectionParamDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionParamDimensions Class


REXSectionParamDimensions.P2_T Property

REXSectionParamDimensions.P2_T Property
REXSectionParamDimensions Class REX.ContentGenerator.Families Namespace REXSectionParamDimensions Class

Gets or sets the P2_T.

C#
public double P2_T;
Description

The P2_T.

Class

REXSectionParamDimensions Class

Links
REXSectionParamDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionParamDimensions Class


REXSectionParamDimensions.P3_L Property

REXSectionParamDimensions.P3_L Property
REXSectionParamDimensions Class REX.ContentGenerator.Families Namespace REXSectionParamDimensions Class

Gets or sets the P3_L.

C#
public double P3_L;
Description

The P3_L.

Class

REXSectionParamDimensions Class

Links
REXSectionParamDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionParamDimensions Class


REXSectionParamDimensions.P3_T Property

REXSectionParamDimensions.P3_T Property
REXSectionParamDimensions Class REX.ContentGenerator.Families Namespace REXSectionParamDimensions Class

Gets or sets the P3_T.

C#
public double P3_T;
Description

The P3_T.

Class

REXSectionParamDimensions Class

Links
REXSectionParamDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionParamDimensions Class


REXSectionParamDimensions.P4_L Property

REXSectionParamDimensions.P4_L Property
REXSectionParamDimensions Class REX.ContentGenerator.Families Namespace REXSectionParamDimensions Class

Gets or sets the P4_L.

C#
public double P4_L;
Description

The P4_L.

Class

REXSectionParamDimensions Class

Links
REXSectionParamDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionParamDimensions Class


REXSectionParamDimensions.P4_T Property

REXSectionParamDimensions.P4_T Property
REXSectionParamDimensions Class REX.ContentGenerator.Families Namespace REXSectionParamDimensions Class

Gets or sets the P4_T.

C#
public double P4_T;
Description

The P4_T.

Class

REXSectionParamDimensions Class

Links
REXSectionParamDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionParamDimensions Class


REXSectionParamDimensions.t Property

REXSectionParamDimensions.t Property
REXSectionParamDimensions Class REX.ContentGenerator.Families Namespace REXSectionParamDimensions Class

Gets or sets the t.

C#
public double t;
Description

The t.

Class

REXSectionParamDimensions Class

Links
REXSectionParamDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionParamDimensions Class


REXSectionParamDimensions.tf Property

REXSectionParamDimensions.tf Property
REXSectionParamDimensions Class REX.ContentGenerator.Families Namespace REXSectionParamDimensions Class

Gets or sets the tf.

C#
public double tf;
Description

The tf.

Class

REXSectionParamDimensions Class

Links
REXSectionParamDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionParamDimensions Class


REXSectionParamDimensions.tf1 Property

REXSectionParamDimensions.tf1 Property
REXSectionParamDimensions Class REX.ContentGenerator.Families Namespace REXSectionParamDimensions Class

Gets or sets the tf1.

C#
public double tf1;
Description

The tf1.

Class

REXSectionParamDimensions Class

Links
REXSectionParamDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionParamDimensions Class


REXSectionParamDimensions.tf2 Property

REXSectionParamDimensions.tf2 Property
REXSectionParamDimensions Class REX.ContentGenerator.Families Namespace REXSectionParamDimensions Class

Gets or sets the tf2.

C#
public double tf2;
Description

The tf2.

Class

REXSectionParamDimensions Class

Links
REXSectionParamDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionParamDimensions Class


REXSectionParamDimensions.tw Property

REXSectionParamDimensions.tw Property
REXSectionParamDimensions Class REX.ContentGenerator.Families Namespace REXSectionParamDimensions Class

Gets or sets the tw.

C#
public double tw;
Description

The tw.

Class

REXSectionParamDimensions Class

Links
REXSectionParamDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionParamDimensions Class


REXSectionParamDimensions.vpy Property

REXSectionParamDimensions.vpy Property
REXSectionParamDimensions Class REX.ContentGenerator.Families Namespace REXSectionParamDimensions Class

Gets or sets the vpy.

C#
public double vpy;
Description

The vpy.

Class

REXSectionParamDimensions Class

Links
REXSectionParamDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionParamDimensions Class


REXSectionParamDimensions.vpz Property

REXSectionParamDimensions.vpz Property
REXSectionParamDimensions Class REX.ContentGenerator.Families Namespace REXSectionParamDimensions Class

Gets or sets the vpz.

C#
public double vpz;
Description

The vpz.

Class

REXSectionParamDimensions Class

Links
REXSectionParamDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionParamDimensions Class


REXSectionParamDimensions.vy Property

REXSectionParamDimensions.vy Property
REXSectionParamDimensions Class REX.ContentGenerator.Families Namespace REXSectionParamDimensions Class

Gets or sets the vy.

C#
public double vy;
Description

The vy.

Class

REXSectionParamDimensions Class

Links
REXSectionParamDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionParamDimensions Class


REXSectionParamDimensions.vz Property

REXSectionParamDimensions.vz Property
REXSectionParamDimensions Class REX.ContentGenerator.Families Namespace REXSectionParamDimensions Class

Gets or sets the vz.

C#
public double vz;
Description

The vz.

Class

REXSectionParamDimensions Class

Links
REXSectionParamDimensions Class, REX.ContentGenerator.Families Namespace, REXSectionParamDimensions Class


SerializableObject Class

SerializableObject Class
REX.ContentGenerator.Families Namespace Legend Members Public Methods SerializableObject Methods

Allows to save an object into a stream.

Class Hierarchy
C#
[Serializable()]
public abstract class SerializableObject : ISerializable;
Description
Namespace

REX.ContentGenerator.Families Namespace

Public Methods
Public Method | Description
SerializableObject | Initializes a new instance of the SerializableObject class.
SerializableObject Methods
SerializableObject Methods | Description
GetObjectData | Serializes the instance to the Serialization object.
Load | Loads object from the stream.
Save | Saves the object to the stream.
Links
REX.ContentGenerator.Families Namespace, Legend, Members, Public Methods, SerializableObject Methods


SerializableObject.SerializableObject Constructor

SerializableObject.SerializableObject Constructor
SerializableObject Class REX.ContentGenerator.Families Namespace SerializableObject Class

Initializes a new instance of the SerializableObject class.

C#
public SerializableObject();
Description
Class

SerializableObject Class

Links
SerializableObject Class, REX.ContentGenerator.Families Namespace, SerializableObject Class


SerializableObject.GetObjectData Method

SerializableObject.GetObjectData Method
SerializableObject Class REX.ContentGenerator.Families Namespace SerializableObject Class

Serializes the instance to the Serialization object.

C#
public void GetObjectData(SerializationInfo info, StreamingContext context);
Parameters
Parameters | Description
info | Serialization data.
context | The context.
Description
Class

SerializableObject Class

Links
SerializableObject Class, REX.ContentGenerator.Families Namespace, SerializableObject Class


SerializableObject.Load Method

SerializableObject.Load Method
SerializableObject Class REX.ContentGenerator.Families Namespace SerializableObject Class

Loads object from the stream.

C#
public virtual void Load(SerializationInfo info, StreamingContext context);
Parameters
Parameters | Description
info | Serialization data.
context | The context.
Description
Class

SerializableObject Class

Links
SerializableObject Class, REX.ContentGenerator.Families Namespace, SerializableObject Class


SerializableObject.Save Method

SerializableObject.Save Method
SerializableObject Class REX.ContentGenerator.Families Namespace SerializableObject Class

Saves the object to the stream.

C#
public virtual void Save(SerializationInfo info, StreamingContext context);
Parameters
Parameters | Description
info | Serialization data.
context | The context.
Description
Class

SerializableObject Class

Links
SerializableObject Class, REX.ContentGenerator.Families Namespace, SerializableObject Class


REX.ContentGenerator.Families.ECategoryType Enumeration

REX.ContentGenerator.Families.ECategoryType Enumeration
REX.ContentGenerator.Families Namespace

Describes the category of the element

C#
public enum ECategoryType {
  UNKNOWN = 0,
  SECTION_PARAM = 1,
  SECTION_DB = 2,
  MATERIAL = 3,
  REBAR_SHAPE = 4,
  REBAR_BARTYPE = 5,
  REBAR_HOOK = 6,
  BOLT = 7,
  BOLT_CLASS = 8,
  CUSTOM = 9
}
Members
Members | Description
UNKNOWN | The unknown.
SECTION_PARAM | The parametric section.
SECTION_DB | The database section.
MATERIAL | The material.
REBAR_SHAPE | The rebar shape.
REBAR_BARTYPE | The rebar type.
REBAR_HOOK | The rebar hook.
BOLT | The bolt.
BOLT_CLASS | The bolt class.
CUSTOM | The custom type.
Namespace

REX.ContentGenerator.Families Namespace

Links
REX.ContentGenerator.Families Namespace
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REX.ContentGenerator.Families.EDBSectionType Enumeration

REX.ContentGenerator.Families.EDBSectionType Enumeration
REX.ContentGenerator.Families Namespace

Describes the type of the database section.

C#
public enum EDBSectionType {
  ANGLE_EQ_LEG = 1,
  ANGLE_UNEQ_LEG,
  ANGLE_EQ_LEG_MAIN,
  ANGLE_UNEQ_LEG_MAIN,
  ANGLE_CROSS,
  ANGLE_CROSS_MAIN,
  ANGLE_DOUBLE,
  I_WIDE,
  I_WIDE_WELDED,
  I_PAR,
  I_NORM,
  I_DOUBLE,
  I_ASYM,
  T_WIDE,
  T_PAR,
  T_NORM,
  HEX_PIPE,
  RECT_PIPE,
  ROUND_PIPE,
  C_PAR,
  C_NORM,
  C_DOUBLE_PAR,
  C_DOUBLE_NORM,
  C_DOUBLE_BACK,
  C_COLD,
  RECT,
  ROUND,
  C_HCLOSED,
  U,
  RECT_PIPE_ROUND,
  COLD_SIGMA1,
  COLD_SIGMA2,
  COLD_ZED1,
  COLD_U,
  COLD_CE1,
  COLD_ANGLE,
  COLD_OMEGA,
  COLD_S01,
  COLD_CEEPLUS,
  COLD_ZEDROT,
  COLD_SIGMA,
  COLD_ZET,
  COLD_L_LIPS,
  COLD_ZETROT,
  UNKNOWN
}
Members
Members | Description
ANGLE_EQ_LEG | Equal angles.
ANGLE_UNEQ_LEG | Unequal angles.
ANGLE_EQ_LEG_MAIN | Equal angles (in principal axes).
ANGLE_UNEQ_LEG_MAIN | Unequal angles (in principal axes).
ANGLE_CROSS | 2 angles - cross-shape.
ANGLE_CROSS_MAIN | 2 angles - cross-shape (in principal axes).
ANGLE_DOUBLE | 2 angles back to back.
I_WIDE | I-sections with wide flanges.
I_WIDE_WELDED | I-sections with wide flanges (welded).
I_PAR | I-sections (with constant flange thickness).
I_NORM | Regular I-sections.
I_DOUBLE | 2 I-sections.
I_ASYM | Asymmetrical I-sections.
T_WIDE | T-sections with wide flanges.
T_PAR | T-sections (with constant flange thickness).
T_NORM | Regular T-sections.
HEX_PIPE | Hexagonal tubes.
RECT_PIPE | Rectangular tubes.
ROUND_PIPE | Round tubes.
C_PAR | Channels (with constant flange thickness).
C_NORM | Regular channels.
C_DOUBLE_PAR | 2 channels (with constant flange thickness) back to back.
C_DOUBLE_NORM | 2 regular channels back to back.
C_DOUBLE_BACK | 2 channels (with constant flange thickness) back to back.
C_COLD | Cold-bent channels.
RECT | Rectangular solid.
ROUND | Round solid.
C_HCLOSED | Half-closed channels.
U | U-type rounded section.
RECT_PIPE_ROUND | Rectangular tube - rounded.
COLD_SIGMA1 | Thin-walled sections Sigma1.
COLD_SIGMA2 | Thin-walled sections Sigma2.
COLD_ZED1 | Stiffened Z-sections (thin-walled).
COLD_U | Open channels (thin-walled).
COLD_CE1 | Half-closed channels (thin-walled).
COLD_ANGLE | Thin-walled angles.
COLD_OMEGA | Thin-walled sections Omega.
COLD_S01 | Asymmetrical Z-sections (thin-walled).
COLD_CEEPLUS | Stiffened channels (thin-walled).
COLD_ZEDROT | Stiffened Z-sections (thin-walled) (in principal axes).
COLD_SIGMA | Thin-walled sections Sigma.
COLD_ZET | Thin-walled Z-sections.
COLD_L_LIPS | Thin-walled sections (angles).
COLD_ZETROT | Thin-walled Z-sections (in principal axes).
UNKNOWN | Unknown sections.
Description
Namespace

REX.ContentGenerator.Families Namespace

Links
REX.ContentGenerator.Families Namespace
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REX.ContentGenerator.Families.EElementType Enumeration

REX.ContentGenerator.Families.EElementType Enumeration
REX.ContentGenerator.Families Namespace

Describes the type of the element

C#
public enum EElementType {
  UNKNOWN = 0,
  BEAM = 1,
  COLUMN = 2
}
Members
Members | Description
UNKNOWN | Unknown.
BEAM | Beam.
COLUMN | Column.
Namespace

REX.ContentGenerator.Families Namespace

Links
REX.ContentGenerator.Families Namespace
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REX.ContentGenerator.Families.EMaterial Enumeration

REX.ContentGenerator.Families.EMaterial Enumeration
REX.ContentGenerator.Families Namespace

Describes the type of material

C#
public enum EMaterial {
  STEEL = 1,
  WOOD = 2,
  CONCRETE = 3,
  GENERIC = 4,
  UNKNOWN = 0
}
Members
Members | Description
STEEL | Steel.
WOOD | Wood.
CONCRETE | Concrete.
GENERIC | Generic.
UNKNOWN | Unknown.
Namespace

REX.ContentGenerator.Families Namespace

Links
REX.ContentGenerator.Families Namespace
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REX.ContentGenerator.Families.ESectionType Enumeration

REX.ContentGenerator.Families.ESectionType Enumeration
REX.ContentGenerator.Families Namespace
C#
public enum ESectionType {
  RECT_HOLLOW = 1,
  RECT = 2,
  TUBE = 3,
  ROUND = 4,
  ROUNDH = 5,
  ROUNDQ = 6,
  BOX1 = 7,
  BOX2 = 8,
  BOX3 = 9,
  I = 10,
  IASYM = 11,
  T = 12,
  C = 13,
  Z = 14,
  CROSS = 15,
  POLYG = 16,
  POLYG_HOLLOW = 17,
  L = 18,
  DRECT = 19,
  CABLE = 20,
  TASYM = 21,
  UNKNOWN = 0
}
Members
Members | Description
RECT_HOLLOW | Rectangular tube
RECT | Rectangular.
TUBE | Round tubes.
ROUND | Round.
ROUNDH | Round 1-2.
ROUNDQ | Round 1-4.
BOX1 | Box-I.
BOX2 | Box-II.
BOX3 | Box-III.
I | I-sections.
IASYM | Asymmetrical I-sections.
T | T-sections.
C | C-sections.
Z | Z-sections.
CROSS | Cross-shaped.
POLYG | Polygonal.
POLYG_HOLLOW | Polygonal tubes.
L | L type
DRECT | Double rectangular.
CABLE | Cables
TASYM | Asymmetrical T-sections.
UNKNOWN | Unknown.
Namespace

REX.ContentGenerator.Families Namespace

Links
REX.ContentGenerator.Families Namespace
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REX.ContentGenerator.Geometry Namespace

Previous | Next
REX.ContentGenerator.Geometry Namespace
Legend Classes Structs, Records, Enums

This is namespace REX.ContentGenerator.Geometry.

Classes
Class | Description
Contour_3D | Represents contour 3D.
Contour_Compound2D | Represents the compound contour.
Contour_Section | Represents the contour of the section.
ContourArc | Represents the arc defined by the start, middle and end point.
ContourCircle | Represents the circle element.
ContourCont | Represents the contour element.
ContourDimension | Represents dimensions.
ContourDimensionLine | Represents the linear dimension.
ContourDimensionRadius | Represents the radial dimension.
ContourElem | Base class for all contour elements.
ContourLine | Represents the line element.
REXSectionAnalyzer | This is class REX.ContentGenerator.Geometry.REXSectionAnalyzer.
REXSectionTypeAnalyzer | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer.
REXSectionTypeAnalyzer_BOX1 | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_BOX1.
REXSectionTypeAnalyzer_BOX2 | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_BOX2.
REXSectionTypeAnalyzer_BOX3 | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_BOX3.
REXSectionTypeAnalyzer_C | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_C.
REXSectionTypeAnalyzer_CROSS | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_CROSS.
REXSectionTypeAnalyzer_DRECT | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_DRECT.
REXSectionTypeAnalyzer_I | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_I.
REXSectionTypeAnalyzer_IASYM | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_IASYM.
REXSectionTypeAnalyzer_L | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_L.
REXSectionTypeAnalyzer_POLYG | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_POLYG.
REXSectionTypeAnalyzer_POLYGHOLLOW | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_POLYGHOLLOW.
REXSectionTypeAnalyzer_RECT | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_RECT.
REXSectionTypeAnalyzer_RECTHOLLOW | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_RECTHOLLOW.
REXSectionTypeAnalyzer_ROUND | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_ROUND.
REXSectionTypeAnalyzer_ROUNDH | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_ROUNDH.
REXSectionTypeAnalyzer_ROUNDQ | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_ROUNDQ.
REXSectionTypeAnalyzer_T | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_T.
REXSectionTypeAnalyzer_TASYM | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_TASYM.
REXSectionTypeAnalyzer_TUBE | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_TUBE.
REXSectionTypeAnalyzer_Z | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_Z.
Structs, Records, Enums
Struct, Record, Enum | Description
EArcDir | Describes the direction of an arc.
EContElemType | Represents the type of the element.
ECoords | Describes the coordinate system type.
Links
Legend, Classes, Structs, Records, Enums
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


Contour_3D Class

Contour_3D Class
REX.ContentGenerator.Geometry Namespace Legend Members Public Methods Contour_3D Methods

Represents contour 3D.

Class Hierarchy
C#
public class Contour_3D : ContourCont;
Description
Namespace

REX.ContentGenerator.Geometry Namespace

Public Methods
Public Method | Description
Contour_3D | Initializes a new instance of the Contour_3D class.
Contour_3D | Initializes a new instance of the Contour_3D class.
Contour_3D | Initializes a new instance of the Contour_3D class.
Contour_3D Methods
Contour_3D Methods | Description
ArcTo | Defines an arc.
LineTo | Defines a line to the specific point.
LineTo | Defines a line to the specific point.
Reverse | Reverses elements.
StartContour | Starts the defintion of the contour.
Links
REX.ContentGenerator.Geometry Namespace, Legend, Members, Public Methods, Contour_3D Methods


Contour_3D.Contour_3D Constructor ()

Contour_3D.Contour_3D Constructor ()
Contour_3D Class REX.ContentGenerator.Geometry Namespace Contour_3D Class

Initializes a new instance of the Contour_3D class.

C#
public Contour_3D();
Description
Class

Contour_3D Class

Links
Contour_3D Class, REX.ContentGenerator.Geometry Namespace, Contour_3D Class


Contour_3D.Contour_3D Constructor (Contour_3D)

Contour_3D.Contour_3D Constructor (Contour_3D)
Contour_3D Class REX.ContentGenerator.Geometry Namespace Contour_3D Class

Initializes a new instance of the Contour_3D class.

C#
public Contour_3D(Contour_3D pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

Contour_3D Class

Links
Contour_3D Class, REX.ContentGenerator.Geometry Namespace, Contour_3D Class


Contour_3D.Contour_3D Constructor (List<REXxyz>)

Contour_3D.Contour_3D Constructor (List<REXxyz>)
Contour_3D Class REX.ContentGenerator.Geometry Namespace Contour_3D Class

Initializes a new instance of the Contour_3D class.

C#
public Contour_3D(List<REXxyz> points);
Parameters
Parameters | Description
points | The points.
Description
Class

Contour_3D Class

Links
Contour_3D Class, REX.ContentGenerator.Geometry Namespace, Contour_3D Class


Contour_3D.ArcTo Method

Contour_3D.ArcTo Method
Contour_3D Class REX.ContentGenerator.Geometry Namespace Contour_3D Class

Defines an arc.

C#
public void ArcTo(REXxyz pt, REXxyz middle);
Parameters
Parameters | Description
pt | The point.
middle | The middle point.
Description
Class

Contour_3D Class

Links
Contour_3D Class, REX.ContentGenerator.Geometry Namespace, Contour_3D Class


Contour_3D.LineTo Method (REXxyz)

Contour_3D.LineTo Method (REXxyz)
Contour_3D Class REX.ContentGenerator.Geometry Namespace Contour_3D Class

Defines a line to the specific point.

C#
public void LineTo(REXxyz pt);
Parameters
Parameters | Description
pt | The point.
Description
Class

Contour_3D Class

Links
Contour_3D Class, REX.ContentGenerator.Geometry Namespace, Contour_3D Class


Contour_3D.LineTo Method (REXxyz, bool)

Contour_3D.LineTo Method (REXxyz, bool)
Contour_3D Class REX.ContentGenerator.Geometry Namespace Contour_3D Class

Defines a line to the specific point.

C#
public void LineTo(REXxyz pt, bool trans);
Parameters
Parameters | Description
pt | The point or the vector.
trans | Indicates whether pt should be taken as a point or a transversal vector.
Description
Class

Contour_3D Class

Links
Contour_3D Class, REX.ContentGenerator.Geometry Namespace, Contour_3D Class


Contour_3D.Reverse Method

Contour_3D.Reverse Method
Contour_3D Class REX.ContentGenerator.Geometry Namespace Contour_3D Class

Reverses elements.

C#
public void Reverse();
Description
Class

Contour_3D Class

Links
Contour_3D Class, REX.ContentGenerator.Geometry Namespace, Contour_3D Class


Contour_3D.StartContour Method

Contour_3D.StartContour Method
Contour_3D Class REX.ContentGenerator.Geometry Namespace Contour_3D Class

Starts the defintion of the contour.

C#
public void StartContour(REXxyz pt);
Parameters
Parameters | Description
pt | The point.
Description
Class

Contour_3D Class

Links
Contour_3D Class, REX.ContentGenerator.Geometry Namespace, Contour_3D Class


Contour_Compound2D Class

Contour_Compound2D Class
REX.ContentGenerator.Geometry Namespace Legend Members Public Methods Contour_Compound2D Methods Contour_Compound2D Properties

Represents the compound contour.

Class Hierarchy
C#
[Serializable()]
public class Contour_Compound2D : SerializableObject;
Description
Namespace

REX.ContentGenerator.Geometry Namespace

Public Methods
Public Method | Description
Contour_Compound2D | Initializes a new instance of the Contour_Compound2D class.
Contour_Compound2D | Initializes a new instance of the Contour_Compound2D class.
Contour_Compound2D | Initializes a new instance of the Contour_Compound2D class.
Contour_Compound2D | Initializes a new instance of the Contour_Compound2D class.
Contour_Compound2D Methods
Contour_Compound2D Methods | Description
ArcTo | Defines an arc.
ArcTo | Defines an arc.
AxisLine | Defines an axis line.
Circle | Defines a circle.
Dimension | Defines a dimension.
DimensionLine | Defines a dimension line.
DimensionLine | Defines a dimension line.
DimensionRadius | Defines a radial dimension.
GetBoundingBox | Gets the bounding box.
GetGeometryParams | Gets the geometry params.
GetPoint | Gets the point in the specified plane.
LineTo | Defines a line to the specified point.
LineTo | Defines a line to the specified point.
LineToX | Defines a line to the specified point (parallel to X axis).
LineToY | Defines a line to the specified point (parallel to Y axis).
LoadFromString | Loads the contour from the string.
MultiplyLengthDim | Multiplies all length dimensions by the input coefficient.
SaveToString | Saves the contour to the string.
StartContour | Starts the definition of the contour.
StartContour | Starts the definition of the contour.
StartContour | Starts the definition of the contour.
Translate | Applies the specified translation vector to all elements.
Contour_Compound2D Properties
Contour_Compound2D Properties | Description
Axis | Gets or sets the list of axis.
Dimensions | Gets or sets the list of dimensions.
Shape | Gets or sets the list of shapes.
Links
REX.ContentGenerator.Geometry Namespace, Legend, Members, Public Methods, Contour_Compound2D Methods, Contour_Compound2D Properties


Contour_Compound2D.Contour_Compound2D Constructor ()

Contour_Compound2D.Contour_Compound2D Constructor ()
Contour_Compound2D Class REX.ContentGenerator.Geometry Namespace Contour_Compound2D Class

Initializes a new instance of the Contour_Compound2D class.

C#
public Contour_Compound2D();
Description
Class

Contour_Compound2D Class

Links
Contour_Compound2D Class, REX.ContentGenerator.Geometry Namespace, Contour_Compound2D Class


Contour_Compound2D.Contour_Compound2D Constructor (Contour_Compound2D)

Contour_Compound2D.Contour_Compound2D Constructor (Contour_Compound2D)
Contour_Compound2D Class REX.ContentGenerator.Geometry Namespace Contour_Compound2D Class

Initializes a new instance of the Contour_Compound2D class.

C#
public Contour_Compound2D(Contour_Compound2D pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

Contour_Compound2D Class

Links
Contour_Compound2D Class, REX.ContentGenerator.Geometry Namespace, Contour_Compound2D Class


Contour_Compound2D.Contour_Compound2D Constructor (List<REXxyz>)

Contour_Compound2D.Contour_Compound2D Constructor (List<REXxyz>)
Contour_Compound2D Class REX.ContentGenerator.Geometry Namespace Contour_Compound2D Class

Initializes a new instance of the Contour_Compound2D class.

C#
public Contour_Compound2D(List<REXxyz> points);
Parameters
Parameters | Description
points | The list of points.
Description
Class

Contour_Compound2D Class

Links
Contour_Compound2D Class, REX.ContentGenerator.Geometry Namespace, Contour_Compound2D Class


Contour_Compound2D.Contour_Compound2D Constructor (System.Runtime.Serialization.SerializationInfo, System.Runtime.Serialization.StreamingContext)

Contour_Compound2D.Contour_Compound2D Constructor (System.Runtime.Serialization.SerializationInfo, System.Runtime.Serialization.StreamingContext)
Contour_Compound2D Class REX.ContentGenerator.Geometry Namespace Contour_Compound2D Class

Initializes a new instance of the Contour_Compound2D class.

C#
public Contour_Compound2D(System.Runtime.Serialization.SerializationInfo info, System.Runtime.Serialization.StreamingContext context);
Parameters
Parameters | Description
info | Serialization data.
context | The context.
Description
Class

Contour_Compound2D Class

Links
Contour_Compound2D Class, REX.ContentGenerator.Geometry Namespace, Contour_Compound2D Class


Contour_Compound2D.ArcTo Method (REXxyz, REXxyz)

Contour_Compound2D.ArcTo Method (REXxyz, REXxyz)
Contour_Compound2D Class REX.ContentGenerator.Geometry Namespace Contour_Compound2D Class

Defines an arc.

C#
public void ArcTo(REXxyz pt, REXxyz middle);
Parameters
Parameters | Description
pt | The point.
middle | The middle point.
Description
Class

Contour_Compound2D Class

Links
Contour_Compound2D Class, REX.ContentGenerator.Geometry Namespace, Contour_Compound2D Class


Contour_Compound2D.ArcTo Method (double, double, double, EArcDir)

Contour_Compound2D.ArcTo Method (double, double, double, EArcDir)
Contour_Compound2D Class REX.ContentGenerator.Geometry Namespace Contour_Compound2D Class

Defines an arc.

C#
public void ArcTo(double x, double y, double r, EArcDir dir);
Parameters
Parameters | Description
x | The x coordinate.
y | The y coordinate.
r | The radius.
dir | The direction.
Description
Class

Contour_Compound2D Class

Links
Contour_Compound2D Class, REX.ContentGenerator.Geometry Namespace, Contour_Compound2D Class


Contour_Compound2D.AxisLine Method

Contour_Compound2D.AxisLine Method
Contour_Compound2D Class REX.ContentGenerator.Geometry Namespace Contour_Compound2D Class

Defines an axis line.

C#
public void AxisLine(double xst, double yst, double xend, double yend);
Parameters
Parameters | Description
xst | The x start.
yst | The y start.
xend | The x end.
yend | The y end.
Description
Class

Contour_Compound2D Class

Links
Contour_Compound2D Class, REX.ContentGenerator.Geometry Namespace, Contour_Compound2D Class


Contour_Compound2D.Circle Method

Contour_Compound2D.Circle Method
Contour_Compound2D Class REX.ContentGenerator.Geometry Namespace Contour_Compound2D Class

Defines a circle.

C#
public void Circle(double x, double y, double r);
Parameters
Parameters | Description
x | The x (center).
y | The y (center).
r | The radius.
Description
Class

Contour_Compound2D Class

Links
Contour_Compound2D Class, REX.ContentGenerator.Geometry Namespace, Contour_Compound2D Class


Contour_Compound2D.Dimension Method

Contour_Compound2D.Dimension Method
Contour_Compound2D Class REX.ContentGenerator.Geometry Namespace Contour_Compound2D Class

Defines a dimension.

C#
public void Dimension(double xst, double yst, string param);
Parameters
Parameters | Description
xst | The x start.
yst | The y start.
param | The parameter (text).
Description
Class

Contour_Compound2D Class

Links
Contour_Compound2D Class, REX.ContentGenerator.Geometry Namespace, Contour_Compound2D Class


Contour_Compound2D.DimensionLine Method (double, double, double, double, int, bool, string)

Contour_Compound2D.DimensionLine Method (double, double, double, double, int, bool, string)
Contour_Compound2D Class REX.ContentGenerator.Geometry Namespace Contour_Compound2D Class

Defines a dimension line.

C#
public void DimensionLine(double xst, double yst, double xend, double yend, int lev, bool up, string param);
Parameters
Parameters | Description
xst | The x start.
yst | The y start.
xend | The x end.
yend | The y end.
lev | The level.
up | Indicates whether the text should be placed above the line.
param | The parameter (text).
Description
Class

Contour_Compound2D Class

Links
Contour_Compound2D Class, REX.ContentGenerator.Geometry Namespace, Contour_Compound2D Class


Contour_Compound2D.DimensionLine Method (double, double, double, double, int, bool, string, bool)

Contour_Compound2D.DimensionLine Method (double, double, double, double, int, bool, string, bool)
Contour_Compound2D Class REX.ContentGenerator.Geometry Namespace Contour_Compound2D Class

Defines a dimension line.

C#
public void DimensionLine(double xst, double yst, double xend, double yend, int lev, bool up, string param, bool extend2Right);
Parameters
Parameters | Description
xst | The x start.
yst | The y start.
xend | The x end.
yend | The y end.
lev | The level.
up | Indicates whether the text should be placed above the line.
param | The parameter (text).
extend2Right | Indicates whether dimension should be extended to the right.
Description
Class

Contour_Compound2D Class

Links
Contour_Compound2D Class, REX.ContentGenerator.Geometry Namespace, Contour_Compound2D Class


Contour_Compound2D.DimensionRadius Method

Contour_Compound2D.DimensionRadius Method
Contour_Compound2D Class REX.ContentGenerator.Geometry Namespace Contour_Compound2D Class

Defines a radial dimension.

C#
public void DimensionRadius(double xst, double yst, double xend, double yend, double r, bool descOnEnd, EArcDir dir, string param);
Parameters
Parameters | Description
xst | The x start.
yst | The y start.
xend | The x end.
yend | The y end.
r | The radius.
dir | The direction.
param | The parameter (text).
DescOnEnd | Indicates whether the description should be placed on the end.
Description
Class

Contour_Compound2D Class

Links
Contour_Compound2D Class, REX.ContentGenerator.Geometry Namespace, Contour_Compound2D Class


Contour_Compound2D.GetBoundingBox Method

Contour_Compound2D.GetBoundingBox Method
Contour_Compound2D Class REX.ContentGenerator.Geometry Namespace Contour_Compound2D Class

Gets the bounding box.

C#
public REX.Common.Geometry.BoundingBoxREXxyz GetBoundingBox();
Returns

The bounding box.

Description
Class

Contour_Compound2D Class

Links
Contour_Compound2D Class, REX.ContentGenerator.Geometry Namespace, Contour_Compound2D Class


Contour_Compound2D.GetGeometryParams Method

Contour_Compound2D.GetGeometryParams Method
Contour_Compound2D Class REX.ContentGenerator.Geometry Namespace Contour_Compound2D Class

Gets the geometry params.

C#
public void GetGeometryParams(out double Ac, out double Sy, out double Sz, out double yc, out double zc, out double Jy, out double Jz, out double Jy0, out double Jz0);
Parameters
Parameters | Description
Ac | The area.
Sy | The static moment - Y.
Sz | The static moment - Z.
yc | The center - Y.
zc | The center - Z.
Jy | The moment of inertia - Y.
Jz | The moment of inertia - Z.
Jy0 | The moment of inertia - center Y.
Jz0 | The moment of inertia - center Z.
Description
Class

Contour_Compound2D Class

Links
Contour_Compound2D Class, REX.ContentGenerator.Geometry Namespace, Contour_Compound2D Class


Contour_Compound2D.GetPoint Method

Contour_Compound2D.GetPoint Method
Contour_Compound2D Class REX.ContentGenerator.Geometry Namespace Contour_Compound2D Class

Gets the point in the specified plane.

C#
public REXxyz GetPoint(REXxyz pt, ECoords coords);
Parameters
Parameters | Description
pt | The point.
coords | The coordinate system (plane).
Returns

The point.

Description
Class

Contour_Compound2D Class

Links
Contour_Compound2D Class, REX.ContentGenerator.Geometry Namespace, Contour_Compound2D Class


Contour_Compound2D.LineTo Method (double, double)

Contour_Compound2D.LineTo Method (double, double)
Contour_Compound2D Class REX.ContentGenerator.Geometry Namespace Contour_Compound2D Class

Defines a line to the specified point.

C#
public void LineTo(double x, double y);
Parameters
Parameters | Description
x | The x coordinate.
y | The y coordinate.
Description
Class

Contour_Compound2D Class

Links
Contour_Compound2D Class, REX.ContentGenerator.Geometry Namespace, Contour_Compound2D Class


Contour_Compound2D.LineTo Method (double, double, bool)

Contour_Compound2D.LineTo Method (double, double, bool)
Contour_Compound2D Class REX.ContentGenerator.Geometry Namespace Contour_Compound2D Class

Defines a line to the specified point.

C#
public void LineTo(double x, double y, bool trans);
Parameters
Parameters | Description
x | The x coordinate.
y | The y coordinate.
trans | Indicates whether x, y should be taken as a point or a transversal vector.
Description
Class

Contour_Compound2D Class

Links
Contour_Compound2D Class, REX.ContentGenerator.Geometry Namespace, Contour_Compound2D Class


Contour_Compound2D.LineToX Method

Contour_Compound2D.LineToX Method
Contour_Compound2D Class REX.ContentGenerator.Geometry Namespace Contour_Compound2D Class

Defines a line to the specified point (parallel to X axis).

C#
public void LineToX(double x);
Parameters
Parameters | Description
x | The x coordinate.
Description
Class

Contour_Compound2D Class

Links
Contour_Compound2D Class, REX.ContentGenerator.Geometry Namespace, Contour_Compound2D Class


Contour_Compound2D.LineToY Method

Contour_Compound2D.LineToY Method
Contour_Compound2D Class REX.ContentGenerator.Geometry Namespace Contour_Compound2D Class

Defines a line to the specified point (parallel to Y axis).

C#
public void LineToY(double y);
Parameters
Parameters | Description
y | The y coordinate.
Description
Class

Contour_Compound2D Class

Links
Contour_Compound2D Class, REX.ContentGenerator.Geometry Namespace, Contour_Compound2D Class


Contour_Compound2D.LoadFromString Method

Contour_Compound2D.LoadFromString Method
Contour_Compound2D Class REX.ContentGenerator.Geometry Namespace Contour_Compound2D Class

Loads the contour from the string.

C#
public void LoadFromString(string serializedString);
Parameters
Parameters | Description
serializedString | The serialized string.
Description
Class

Contour_Compound2D Class

Links
Contour_Compound2D Class, REX.ContentGenerator.Geometry Namespace, Contour_Compound2D Class


Contour_Compound2D.MultiplyLengthDim Method

Contour_Compound2D.MultiplyLengthDim Method
Contour_Compound2D Class REX.ContentGenerator.Geometry Namespace Contour_Compound2D Class

Multiplies all length dimensions by the input coefficient.

C#
public void MultiplyLengthDim(double coeff);
Parameters
Parameters | Description
coeff | The coefficient.
Description
Class

Contour_Compound2D Class

Links
Contour_Compound2D Class, REX.ContentGenerator.Geometry Namespace, Contour_Compound2D Class


Contour_Compound2D.SaveToString Method

Contour_Compound2D.SaveToString Method
Contour_Compound2D Class REX.ContentGenerator.Geometry Namespace Contour_Compound2D Class

Saves the contour to the string.

C#
public string SaveToString();
Returns

Serialized contour.

Description
Class

Contour_Compound2D Class

Links
Contour_Compound2D Class, REX.ContentGenerator.Geometry Namespace, Contour_Compound2D Class


Contour_Compound2D.StartContour Method (double, double)

Contour_Compound2D.StartContour Method (double, double)
Contour_Compound2D Class REX.ContentGenerator.Geometry Namespace Contour_Compound2D Class

Starts the definition of the contour.

C#
public ContourCont StartContour(double x, double y);
Parameters
Parameters | Description
x | The x coordinate.
y | The y coordinate.
Description
Class

Contour_Compound2D Class

Links
Contour_Compound2D Class, REX.ContentGenerator.Geometry Namespace, Contour_Compound2D Class


Contour_Compound2D.StartContour Method (double, double, bool, ContourCont)

Contour_Compound2D.StartContour Method (double, double, bool, ContourCont)
Contour_Compound2D Class REX.ContentGenerator.Geometry Namespace Contour_Compound2D Class

Starts the definition of the contour.

C#
public ContourCont StartContour(double x, double y, bool hole, ContourCont parent);
Parameters
Parameters | Description
x | The x coordinate.
y | The y coordinate.
hole | Indicates whether the current contour is a hole.
parent | The parent.
Returns

The new created contour.

Description
Class

Contour_Compound2D Class

Links
Contour_Compound2D Class, REX.ContentGenerator.Geometry Namespace, Contour_Compound2D Class


Contour_Compound2D.StartContour Method (double, double, bool, bool)

Contour_Compound2D.StartContour Method (double, double, bool, bool)
Contour_Compound2D Class REX.ContentGenerator.Geometry Namespace Contour_Compound2D Class

Starts the definition of the contour.

C#
public ContourCont StartContour(double x, double y, bool hole, bool add2Current);
Parameters
Parameters | Description
x | The x coordinate.
y | The y coordinate.
hole | Indicates whether the current contour is a hole.
add2Current | Indicates whether the contour should be added to the last contour.
Returns

The new created contour.

Description
Class

Contour_Compound2D Class

Links
Contour_Compound2D Class, REX.ContentGenerator.Geometry Namespace, Contour_Compound2D Class


Contour_Compound2D.Translate Method

Contour_Compound2D.Translate Method
Contour_Compound2D Class REX.ContentGenerator.Geometry Namespace Contour_Compound2D Class

Applies the specified translation vector to all elements.

C#
public void Translate(double x, double y);
Parameters
Parameters | Description
x | The x.
y | The y.
Description
Class

Contour_Compound2D Class

Links
Contour_Compound2D Class, REX.ContentGenerator.Geometry Namespace, Contour_Compound2D Class


Contour_Compound2D.Axis Property

Contour_Compound2D.Axis Property
Contour_Compound2D Class REX.ContentGenerator.Geometry Namespace Contour_Compound2D Class

Gets or sets the list of axis.

C#
public List<ContourLine> Axis;
Description

The list of axis.

Class

Contour_Compound2D Class

Links
Contour_Compound2D Class, REX.ContentGenerator.Geometry Namespace, Contour_Compound2D Class


Contour_Compound2D.Dimensions Property

Contour_Compound2D.Dimensions Property
Contour_Compound2D Class REX.ContentGenerator.Geometry Namespace Contour_Compound2D Class

Gets or sets the list of dimensions.

C#
public List<ContourDimension> Dimensions;
Description

The dimensions.

Class

Contour_Compound2D Class

Links
Contour_Compound2D Class, REX.ContentGenerator.Geometry Namespace, Contour_Compound2D Class


Contour_Compound2D.Shape Property

Contour_Compound2D.Shape Property
Contour_Compound2D Class REX.ContentGenerator.Geometry Namespace Contour_Compound2D Class

Gets or sets the list of shapes.

C#
public List<ContourCont> Shape;
Description

The list of shapes.

Class

Contour_Compound2D Class

Links
Contour_Compound2D Class, REX.ContentGenerator.Geometry Namespace, Contour_Compound2D Class


Contour_Section Class

Contour_Section Class
REX.ContentGenerator.Geometry Namespace Legend Members Public Methods

Represents the contour of the section.

Class Hierarchy
C#
[Serializable()]
public class Contour_Section : Contour_Compound2D;
Description
Namespace

REX.ContentGenerator.Geometry Namespace

Public Methods
Public Method | Description
Contour_Section | Initializes a new instance of the Contour_Section class.
Contour_Section | Initializes a new instance of the Contour_Section class.
Contour_Section | Initializes a new instance of the Contour_Section class.
Links
REX.ContentGenerator.Geometry Namespace, Legend, Members, Public Methods


Contour_Section.Contour_Section Constructor (REXSectionDBDimensions, int)

Contour_Section.Contour_Section Constructor (REXSectionDBDimensions, int)
Contour_Section Class REX.ContentGenerator.Geometry Namespace Contour_Section Class

Initializes a new instance of the Contour_Section class.

C#
public Contour_Section(REXSectionDBDimensions db, int typesec);
Parameters
Parameters | Description
db | The database description.
typesec | The type of the section.
Description
Class

Contour_Section Class

Links
Contour_Section Class, REX.ContentGenerator.Geometry Namespace, Contour_Section Class


Contour_Section.Contour_Section Constructor (REXSectionParamDescription, bool)

Contour_Section.Contour_Section Constructor (REXSectionParamDescription, bool)
Contour_Section Class REX.ContentGenerator.Geometry Namespace Contour_Section Class

Initializes a new instance of the Contour_Section class.

C#
public Contour_Section(REXSectionParamDescription par, bool start);
Parameters
Parameters | Description
par | The parametric description.
start | Indicates whether the contour should be taken from the start.
Description
Class

Contour_Section Class

Links
Contour_Section Class, REX.ContentGenerator.Geometry Namespace, Contour_Section Class


Contour_Section.Contour_Section Constructor (System.Runtime.Serialization.SerializationInfo, System.Runtime.Serialization.StreamingContext)

Contour_Section.Contour_Section Constructor (System.Runtime.Serialization.SerializationInfo, System.Runtime.Serialization.StreamingContext)
Contour_Section Class REX.ContentGenerator.Geometry Namespace Contour_Section Class

Initializes a new instance of the Contour_Section class.

C#
public Contour_Section(System.Runtime.Serialization.SerializationInfo info, System.Runtime.Serialization.StreamingContext context);
Parameters
Parameters | Description
info | Serialization data.
context | The context.
Description
Class

Contour_Section Class

Links
Contour_Section Class, REX.ContentGenerator.Geometry Namespace, Contour_Section Class


ContourArc Class

ContourArc Class
REX.ContentGenerator.Geometry Namespace Legend Members Public Methods ContourArc Methods ContourArc Properties

Represents the arc defined by the start, middle and end point.

Class Hierarchy
C#
[Serializable()]
public class ContourArc : ContourElem;
Description
Namespace

REX.ContentGenerator.Geometry Namespace

Public Methods
Public Method | Description
ContourArc | Initializes a new instance of the ContourArc2> class.
ContourArc | Initializes a new instance of the ContourArc2 class.
ContourArc | Initializes a new instance of the ContourArc2> class.
ContourArc | This is ContourArc, a member of class ContourArc.
ContourArc | Initializes a new instance of the ContourArc2 class.
ContourArc Methods
ContourArc Methods | Description
GetCenter | Gets the center of the arc.
GetCenter | Gets the center of the arc.
GetEnd | Gets the end.
GetMiddlePoint | Gets the middle point.
GetPointList | Gets the list of points.
GetStart | Gets the start.
MultiplyLengthDim | Multiplies length dimensions by the coefficient.
Transform | Applies the specified transformation to the element.
Translate | Applies the specified translation vector to the element.
ContourArc Properties
ContourArc Properties | Description
End | Gets or sets the end.
Middle | Gets or sets the middle.
Start | Gets or sets the start.
Links
REX.ContentGenerator.Geometry Namespace, Legend, Members, Public Methods, ContourArc Methods, ContourArc Properties


ContourArc.ContourArc Constructor (ContourArc)

ContourArc.ContourArc Constructor (ContourArc)
ContourArc Class REX.ContentGenerator.Geometry Namespace ContourArc Class

Initializes a new instance of the ContourArc2> class.

C#
public ContourArc(ContourArc pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

ContourArc Class

Links
ContourArc Class, REX.ContentGenerator.Geometry Namespace, ContourArc Class


ContourArc.ContourArc Constructor (REXxyz, REXxyz, REXxyz)

ContourArc.ContourArc Constructor (REXxyz, REXxyz, REXxyz)
ContourArc Class REX.ContentGenerator.Geometry Namespace ContourArc Class

Initializes a new instance of the ContourArc2 class.

C#
public ContourArc(REXxyz st, REXxyz end, REXxyz middle);
Parameters
Parameters | Description
st | The start.
end | The end.
middle | The middle.
Description
Class

ContourArc Class

Links
ContourArc Class, REX.ContentGenerator.Geometry Namespace, ContourArc Class


ContourArc.ContourArc Constructor (REXxyz, REXxyz, double, EArcDir)

ContourArc.ContourArc Constructor (REXxyz, REXxyz, double, EArcDir)
ContourArc Class REX.ContentGenerator.Geometry Namespace ContourArc Class

Initializes a new instance of the ContourArc2> class.

C#
public ContourArc(REXxyz st, REXxyz end, double R, EArcDir dir);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

ContourArc Class

Links
ContourArc Class, REX.ContentGenerator.Geometry Namespace, ContourArc Class


ContourArc.ContourArc Constructor (System.Runtime.Serialization.SerializationInfo, System.Runtime.Serialization.StreamingContext)

ContourArc.ContourArc Constructor (System.Runtime.Serialization.SerializationInfo, System.Runtime.Serialization.StreamingContext)
ContourArc Class REX.ContentGenerator.Geometry Namespace ContourArc Class

This is ContourArc, a member of class ContourArc.

C#
public ContourArc(System.Runtime.Serialization.SerializationInfo info, System.Runtime.Serialization.StreamingContext context);
Class

ContourArc Class

Links
ContourArc Class, REX.ContentGenerator.Geometry Namespace, ContourArc Class


ContourArc.ContourArc Constructor (double, double, double, double, double, EArcDir)

ContourArc.ContourArc Constructor (double, double, double, double, double, EArcDir)
ContourArc Class REX.ContentGenerator.Geometry Namespace ContourArc Class

Initializes a new instance of the ContourArc2 class.

C#
public ContourArc(double xst, double yst, double xend, double yend, double R, EArcDir dir);
Parameters
Parameters | Description
st | The start.
end | The end.
middle | The middle.
Description
Class

ContourArc Class

Links
ContourArc Class, REX.ContentGenerator.Geometry Namespace, ContourArc Class


ContourArc.GetCenter Method (ECoords)

ContourArc.GetCenter Method (ECoords)
ContourArc Class REX.ContentGenerator.Geometry Namespace ContourArc Class

Gets the center of the arc.

C#
public REXxyz GetCenter(ECoords coords);
Parameters
Parameters | Description
coords | The coordinate system (plane).
Returns

Returns coordinates of the center of the arc.

Description
Class

ContourArc Class

Links
ContourArc Class, REX.ContentGenerator.Geometry Namespace, ContourArc Class


ContourArc.GetCenter Method (REXxyz, REXxyz, REXxyz)

ContourArc.GetCenter Method (REXxyz, REXxyz, REXxyz)
ContourArc Class REX.ContentGenerator.Geometry Namespace ContourArc Class

Gets the center of the arc.

C#
public REXxyz GetCenter(REXxyz start, REXxyz middle, REXxyz end);
Parameters
Parameters | Description
coords | The coordinate system (plane).
Returns

Returns coordinates of the center of the arc.

Description
Class

ContourArc Class

Links
ContourArc Class, REX.ContentGenerator.Geometry Namespace, ContourArc Class


ContourArc.GetEnd Method

ContourArc.GetEnd Method
ContourArc Class REX.ContentGenerator.Geometry Namespace ContourArc Class

Gets the end.

C#
public REXxyz GetEnd(ECoords coords);
Parameters
Parameters | Description
coords | The coordinate system (plane).
Returns

The end point.

Description
Class

ContourArc Class

Links
ContourArc Class, REX.ContentGenerator.Geometry Namespace, ContourArc Class


ContourArc.GetMiddlePoint Method

ContourArc.GetMiddlePoint Method
ContourArc Class REX.ContentGenerator.Geometry Namespace ContourArc Class

Gets the middle point.

C#
public REXxyz GetMiddlePoint(ECoords coords);
Parameters
Parameters | Description
coords | The coordinate system (plane).
Returns

Returns the middle point.

Description
Class

ContourArc Class

Links
ContourArc Class, REX.ContentGenerator.Geometry Namespace, ContourArc Class


ContourArc.GetPointList Method

ContourArc.GetPointList Method
ContourArc Class REX.ContentGenerator.Geometry Namespace ContourArc Class

Gets the list of points.

C#
public override List<REXxyz> GetPointList(bool end);
Parameters
Parameters | Description
end | If the end point included.
Returns

Returns the list of points

Description
Class

ContourArc Class

Links
ContourArc Class, REX.ContentGenerator.Geometry Namespace, ContourArc Class


ContourArc.GetStart Method

ContourArc.GetStart Method
ContourArc Class REX.ContentGenerator.Geometry Namespace ContourArc Class

Gets the start.

C#
public REXxyz GetStart(ECoords coords);
Parameters
Parameters | Description
coords | The coordinate system (plane).
Returns

The start point.

Description
Class

ContourArc Class

Links
ContourArc Class, REX.ContentGenerator.Geometry Namespace, ContourArc Class


ContourArc.MultiplyLengthDim Method

ContourArc.MultiplyLengthDim Method
ContourArc Class REX.ContentGenerator.Geometry Namespace ContourArc Class

Multiplies length dimensions by the coefficient.

C#
public override void MultiplyLengthDim(double coeff);
Parameters
Parameters | Description
coeff | The coefficient.
Description
Class

ContourArc Class

Links
ContourArc Class, REX.ContentGenerator.Geometry Namespace, ContourArc Class


ContourArc.Transform Method

ContourArc.Transform Method
ContourArc Class REX.ContentGenerator.Geometry Namespace ContourArc Class

Applies the specified transformation to the element.

C#
public override void Transform(TransformDbl trans, bool toLocal);
Parameters
Parameters | Description
trans | The transformation object.
toLocal | Indicates the direction of transformation: true if from global to local; otherwise false.
Description
Class

ContourArc Class

Links
ContourArc Class, REX.ContentGenerator.Geometry Namespace, ContourArc Class


ContourArc.Translate Method

ContourArc.Translate Method
ContourArc Class REX.ContentGenerator.Geometry Namespace ContourArc Class

Applies the specified translation vector to the element.

C#
public override void Translate(double x, double y);
Parameters
Parameters | Description
x | The x.
y | The y.
Description
Class

ContourArc Class

Links
ContourArc Class, REX.ContentGenerator.Geometry Namespace, ContourArc Class


ContourArc.End Property

ContourArc.End Property
ContourArc Class REX.ContentGenerator.Geometry Namespace ContourArc Class

Gets or sets the end.

C#
public REXxyz End;
Description

The end.

Class

ContourArc Class

Links
ContourArc Class, REX.ContentGenerator.Geometry Namespace, ContourArc Class


ContourArc.Middle Property

ContourArc.Middle Property
ContourArc Class REX.ContentGenerator.Geometry Namespace ContourArc Class

Gets or sets the middle.

C#
public REXxyz Middle;
Description

The middle.

Class

ContourArc Class

Links
ContourArc Class, REX.ContentGenerator.Geometry Namespace, ContourArc Class


ContourArc.Start Property

ContourArc.Start Property
ContourArc Class REX.ContentGenerator.Geometry Namespace ContourArc Class

Gets or sets the start.

C#
public REXxyz Start;
Description

The start.

Class

ContourArc Class

Links
ContourArc Class, REX.ContentGenerator.Geometry Namespace, ContourArc Class


ContourCircle Class

ContourCircle Class
REX.ContentGenerator.Geometry Namespace Legend Members Public Methods ContourCircle Methods ContourCircle Properties

Represents the circle element.

Class Hierarchy
C#
[Serializable()]
public class ContourCircle : ContourElem;
Description
Namespace

REX.ContentGenerator.Geometry Namespace

Public Methods
Public Method | Description
ContourCircle | Initializes a new instance of the ContourCircle class.
ContourCircle | Initializes a new instance of the ContourCircle class.
ContourCircle | Initializes a new instance of the ContourCircle class.
ContourCircle | Initializes a new instance of the ContourCircle class.
ContourCircle Methods
ContourCircle Methods | Description
GetPointList | Gets the list of points.
GetStart | Gets the start (center).
MultiplyLengthDim | Multiplies length dimensions by the coefficient.
Translate | Applies the specified translation vector to the element.
ContourCircle Properties
ContourCircle Properties | Description
Center | Gets or sets the start (center).
R | Gets or sets the radius.
Links
REX.ContentGenerator.Geometry Namespace, Legend, Members, Public Methods, ContourCircle Methods, ContourCircle Properties


ContourCircle.ContourCircle Constructor (ContourCircle)

ContourCircle.ContourCircle Constructor (ContourCircle)
ContourCircle Class REX.ContentGenerator.Geometry Namespace ContourCircle Class

Initializes a new instance of the ContourCircle class.

C#
public ContourCircle(ContourCircle pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

ContourCircle Class

Links
ContourCircle Class, REX.ContentGenerator.Geometry Namespace, ContourCircle Class


ContourCircle.ContourCircle Constructor (REXxyz, double)

ContourCircle.ContourCircle Constructor (REXxyz, double)
ContourCircle Class REX.ContentGenerator.Geometry Namespace ContourCircle Class

Initializes a new instance of the ContourCircle class.

C#
public ContourCircle(REXxyz st, double r);
Parameters
Parameters | Description
st | The start (center).
r | The radius.
Description
Class

ContourCircle Class

Links
ContourCircle Class, REX.ContentGenerator.Geometry Namespace, ContourCircle Class


ContourCircle.ContourCircle Constructor (System.Runtime.Serialization.SerializationInfo, System.Runtime.Serialization.StreamingContext)

ContourCircle.ContourCircle Constructor (System.Runtime.Serialization.SerializationInfo, System.Runtime.Serialization.StreamingContext)
ContourCircle Class REX.ContentGenerator.Geometry Namespace ContourCircle Class

Initializes a new instance of the ContourCircle class.

C#
public ContourCircle(System.Runtime.Serialization.SerializationInfo info, System.Runtime.Serialization.StreamingContext context);
Parameters
Parameters | Description
info | Serialization data.
context | The context.
Description
Class

ContourCircle Class

Links
ContourCircle Class, REX.ContentGenerator.Geometry Namespace, ContourCircle Class


ContourCircle.ContourCircle Constructor (double, double, double)

ContourCircle.ContourCircle Constructor (double, double, double)
ContourCircle Class REX.ContentGenerator.Geometry Namespace ContourCircle Class

Initializes a new instance of the ContourCircle class.

C#
public ContourCircle(double xst, double yst, double r);
Parameters
Parameters | Description
xst | The x start.
yst | The y start.
r | The radius.
Description
Class

ContourCircle Class

Links
ContourCircle Class, REX.ContentGenerator.Geometry Namespace, ContourCircle Class


ContourCircle.GetPointList Method

ContourCircle.GetPointList Method
ContourCircle Class REX.ContentGenerator.Geometry Namespace ContourCircle Class

Gets the list of points.

C#
public override List<REXxyz> GetPointList(bool end);
Parameters
Parameters | Description
end | Indicates whether the end point should be included.
Returns

Returns the list of points

Description
Class

ContourCircle Class

Links
ContourCircle Class, REX.ContentGenerator.Geometry Namespace, ContourCircle Class


ContourCircle.GetStart Method

ContourCircle.GetStart Method
ContourCircle Class REX.ContentGenerator.Geometry Namespace ContourCircle Class

Gets the start (center).

C#
public REXxyz GetStart(ECoords coords);
Parameters
Parameters | Description
coords | The coordinate system (plane).
Returns

The start (center) point.

Description
Class

ContourCircle Class

Links
ContourCircle Class, REX.ContentGenerator.Geometry Namespace, ContourCircle Class


ContourCircle.MultiplyLengthDim Method

ContourCircle.MultiplyLengthDim Method
ContourCircle Class REX.ContentGenerator.Geometry Namespace ContourCircle Class

Multiplies length dimensions by the coefficient.

C#
public override void MultiplyLengthDim(double coeff);
Parameters
Parameters | Description
coeff | The coefficient.
Description
Class

ContourCircle Class

Links
ContourCircle Class, REX.ContentGenerator.Geometry Namespace, ContourCircle Class


ContourCircle.Translate Method

ContourCircle.Translate Method
ContourCircle Class REX.ContentGenerator.Geometry Namespace ContourCircle Class

Applies the specified translation vector to the element.

C#
public override void Translate(double x, double y);
Parameters
Parameters | Description
x | The x.
y | The y.
Description
Class

ContourCircle Class

Links
ContourCircle Class, REX.ContentGenerator.Geometry Namespace, ContourCircle Class


ContourCircle.Center Property

ContourCircle.Center Property
ContourCircle Class REX.ContentGenerator.Geometry Namespace ContourCircle Class

Gets or sets the start (center).

C#
public REXxyz Center;
Description

The start (center).

Class

ContourCircle Class

Links
ContourCircle Class, REX.ContentGenerator.Geometry Namespace, ContourCircle Class


ContourCircle.R Property

ContourCircle.R Property
ContourCircle Class REX.ContentGenerator.Geometry Namespace ContourCircle Class

Gets or sets the radius.

C#
public double R;
Description

The radius.

Class

ContourCircle Class

Links
ContourCircle Class, REX.ContentGenerator.Geometry Namespace, ContourCircle Class


ContourCont Class

ContourCont Class
REX.ContentGenerator.Geometry Namespace Legend Members Public Methods ContourCont Methods ContourCont Properties

Represents the contour element.

Class Hierarchy
C#
[Serializable()]
public class ContourCont : ContourElem;
Description
Namespace

REX.ContentGenerator.Geometry Namespace

Public Methods
Public Method | Description
ContourCont | Initializes a new instance of the ContourCont class.
ContourCont | Initializes a new instance of the ContourCont class.
ContourCont | Initializes a new instance of the ContourCont class.
ContourCont | Initializes a new instance of the ContourCont class.
ContourCont Methods
ContourCont Methods | Description
GetGeometryParams | Gets the geometry params.
GetPointList | Gets the list of points.
IsContourInsideMe | Determines whether the contour is inside current one.
MultiplyLengthDim | Multiplies length dimensions by the coefficient.
Transform | Applies the specified transformation to the element.
Translate | Applies the specified translation vector to the element.
ContourCont Properties
ContourCont Properties | Description
ContList | Gets or sets the list of contours.
ElemList | Gets or sets the list of elements.
Hole | Gets or sets a value indicating whether this contour is a hole.
Links
REX.ContentGenerator.Geometry Namespace, Legend, Members, Public Methods, ContourCont Methods, ContourCont Properties


ContourCont.ContourCont Constructor (ContourCont)

ContourCont.ContourCont Constructor (ContourCont)
ContourCont Class REX.ContentGenerator.Geometry Namespace ContourCont Class

Initializes a new instance of the ContourCont class.

C#
public ContourCont(ContourCont pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

ContourCont Class

Links
ContourCont Class, REX.ContentGenerator.Geometry Namespace, ContourCont Class


ContourCont.ContourCont Constructor (System.Runtime.Serialization.SerializationInfo, System.Runtime.Serialization.StreamingContext)

ContourCont.ContourCont Constructor (System.Runtime.Serialization.SerializationInfo, System.Runtime.Serialization.StreamingContext)
ContourCont Class REX.ContentGenerator.Geometry Namespace ContourCont Class

Initializes a new instance of the ContourCont class.

C#
public ContourCont(System.Runtime.Serialization.SerializationInfo info, System.Runtime.Serialization.StreamingContext context);
Parameters
Parameters | Description
info | Serialization data.
context | The context.
Description
Class

ContourCont Class

Links
ContourCont Class, REX.ContentGenerator.Geometry Namespace, ContourCont Class


ContourCont.ContourCont Constructor (bool)

ContourCont.ContourCont Constructor (bool)
ContourCont Class REX.ContentGenerator.Geometry Namespace ContourCont Class

Initializes a new instance of the ContourCont class.

C#
public ContourCont(bool isHole);
Parameters
Parameters | Description
isHole | Indicates whether the contour is a hole.
Description
Class

ContourCont Class

Links
ContourCont Class, REX.ContentGenerator.Geometry Namespace, ContourCont Class


ContourCont.ContourCont Constructor (bool, ContourCont)

ContourCont.ContourCont Constructor (bool, ContourCont)
ContourCont Class REX.ContentGenerator.Geometry Namespace ContourCont Class

Initializes a new instance of the ContourCont class.

C#
public ContourCont(bool isHole, ContourCont parent);
Parameters
Parameters | Description
isHole | Indicates whether the contour is a hole.
parent | The parent.
Description
Class

ContourCont Class

Links
ContourCont Class, REX.ContentGenerator.Geometry Namespace, ContourCont Class


ContourCont.GetGeometryParams Method

ContourCont.GetGeometryParams Method
ContourCont Class REX.ContentGenerator.Geometry Namespace ContourCont Class

Gets the geometry params.

C#
public void GetGeometryParams(out double Ac, out double Sy, out double Sz, out double yc, out double zc, out double Jy, out double Jz, out double Jy0, out double Jz0);
Parameters
Parameters | Description
Ac | The area.
Sy | The static moment - Y.
Sz | The static moment - Z.
yc | The center - Y.
zc | The center - Z.
Jy | The moment of inertia - Y.
Jz | The moment of inertia - Z.
Jy0 | The moment of inertia - center Y.
Jz0 | The moment of inertia - center Z.
Description
Class

ContourCont Class

Links
ContourCont Class, REX.ContentGenerator.Geometry Namespace, ContourCont Class


ContourCont.GetPointList Method

ContourCont.GetPointList Method
ContourCont Class REX.ContentGenerator.Geometry Namespace ContourCont Class

Gets the list of points.

C#
public override List<REXxyz> GetPointList(bool end);
Parameters
Parameters | Description
end | If the end point included.
Returns

Returns the list of points

Description
Class

ContourCont Class

Links
ContourCont Class, REX.ContentGenerator.Geometry Namespace, ContourCont Class


ContourCont.IsContourInsideMe Method

ContourCont.IsContourInsideMe Method
ContourCont Class REX.ContentGenerator.Geometry Namespace ContourCont Class

Determines whether the contour is inside current one.

C#
public bool IsContourInsideMe(ContourCont cont);
Parameters
Parameters | Description
cont | The contour.
Returns

Returns whether contour is inside.

Description
Class

ContourCont Class

Links
ContourCont Class, REX.ContentGenerator.Geometry Namespace, ContourCont Class


ContourCont.MultiplyLengthDim Method

ContourCont.MultiplyLengthDim Method
ContourCont Class REX.ContentGenerator.Geometry Namespace ContourCont Class

Multiplies length dimensions by the coefficient.

C#
public override void MultiplyLengthDim(double coeff);
Parameters
Parameters | Description
coeff | The coefficient.
Description
Class

ContourCont Class

Links
ContourCont Class, REX.ContentGenerator.Geometry Namespace, ContourCont Class


ContourCont.Transform Method

ContourCont.Transform Method
ContourCont Class REX.ContentGenerator.Geometry Namespace ContourCont Class

Applies the specified transformation to the element.

C#
public override void Transform(TransformDbl trans, bool toLocal);
Parameters
Parameters | Description
trans | The transformation object.
toLocal | If transformation from the global to the local coordinate system.
Description
Class

ContourCont Class

Links
ContourCont Class, REX.ContentGenerator.Geometry Namespace, ContourCont Class


ContourCont.Translate Method

ContourCont.Translate Method
ContourCont Class REX.ContentGenerator.Geometry Namespace ContourCont Class

Applies the specified translation vector to the element.

C#
public override void Translate(double x, double y);
Parameters
Parameters | Description
x | The x.
y | The y.
Description
Class

ContourCont Class

Links
ContourCont Class, REX.ContentGenerator.Geometry Namespace, ContourCont Class


ContourCont.ContList Property

ContourCont.ContList Property
ContourCont Class REX.ContentGenerator.Geometry Namespace ContourCont Class

Gets or sets the list of contours.

C#
public List<ContourCont> ContList;
Description

The list of contours.

Class

ContourCont Class

Links
ContourCont Class, REX.ContentGenerator.Geometry Namespace, ContourCont Class


ContourCont.ElemList Property

ContourCont.ElemList Property
ContourCont Class REX.ContentGenerator.Geometry Namespace ContourCont Class

Gets or sets the list of elements.

C#
public List<ContourElem> ElemList;
Description

The list of elements.

Class

ContourCont Class

Links
ContourCont Class, REX.ContentGenerator.Geometry Namespace, ContourCont Class


ContourCont.Hole Property

ContourCont.Hole Property
ContourCont Class REX.ContentGenerator.Geometry Namespace ContourCont Class

Gets or sets a value indicating whether this contour is a hole.

C#
public bool Hole;
Description

True if the contour is a hole; otherwise, false.

Class

ContourCont Class

Links
ContourCont Class, REX.ContentGenerator.Geometry Namespace, ContourCont Class


ContourDimension Class

ContourDimension Class
REX.ContentGenerator.Geometry Namespace Legend Members Public Methods ContourDimension Methods ContourDimension Properties

Represents dimensions.

Class Hierarchy
C#
public class ContourDimension;
Description
Namespace

REX.ContentGenerator.Geometry Namespace

Public Methods
Public Method | Description
ContourDimension | Initializes a new instance of the ContourDimension class.
ContourDimension | Initializes a new instance of the ContourDimension class.
ContourDimension Methods
ContourDimension Methods | Description
MultiplyLengthDim | Multiplies length dimensions by the coefficient.
Translate | Applies the specified translation vector to the element.
ContourDimension Properties
ContourDimension Properties | Description
Parameter | Gets or sets the parameter (text).
Start | Gets or sets the start.
Links
REX.ContentGenerator.Geometry Namespace, Legend, Members, Public Methods, ContourDimension Methods, ContourDimension Properties


ContourDimension.ContourDimension Constructor (string, REXxyz)

ContourDimension.ContourDimension Constructor (string, REXxyz)
ContourDimension Class REX.ContentGenerator.Geometry Namespace ContourDimension Class

Initializes a new instance of the ContourDimension class.

C#
public ContourDimension(string param, REXxyz st);
Parameters
Parameters | Description
param | The parameter (text).
st | The start.
Description
Class

ContourDimension Class

Links
ContourDimension Class, REX.ContentGenerator.Geometry Namespace, ContourDimension Class


ContourDimension.ContourDimension Constructor (string, double, double)

ContourDimension.ContourDimension Constructor (string, double, double)
ContourDimension Class REX.ContentGenerator.Geometry Namespace ContourDimension Class

Initializes a new instance of the ContourDimension class.

C#
public ContourDimension(string param, double xst, double yst);
Parameters
Parameters | Description
param | The parameter (text).
xst | The x start.
yst | The y start.
Description
Class

ContourDimension Class

Links
ContourDimension Class, REX.ContentGenerator.Geometry Namespace, ContourDimension Class


ContourDimension.MultiplyLengthDim Method

ContourDimension.MultiplyLengthDim Method
ContourDimension Class REX.ContentGenerator.Geometry Namespace ContourDimension Class

Multiplies length dimensions by the coefficient.

C#
public virtual void MultiplyLengthDim(double coeff);
Parameters
Parameters | Description
coeff | The coefficient.
Description
Class

ContourDimension Class

Links
ContourDimension Class, REX.ContentGenerator.Geometry Namespace, ContourDimension Class


ContourDimension.Translate Method

ContourDimension.Translate Method
ContourDimension Class REX.ContentGenerator.Geometry Namespace ContourDimension Class

Applies the specified translation vector to the element.

C#
public virtual void Translate(double x, double y);
Parameters
Parameters | Description
x | The x.
y | The y.
Description
Class

ContourDimension Class

Links
ContourDimension Class, REX.ContentGenerator.Geometry Namespace, ContourDimension Class


ContourDimension.Parameter Property

ContourDimension.Parameter Property
ContourDimension Class REX.ContentGenerator.Geometry Namespace ContourDimension Class

Gets or sets the parameter (text).

C#
public string Parameter;
Description

The parameter (text).

Class

ContourDimension Class

Links
ContourDimension Class, REX.ContentGenerator.Geometry Namespace, ContourDimension Class


ContourDimension.Start Property

ContourDimension.Start Property
ContourDimension Class REX.ContentGenerator.Geometry Namespace ContourDimension Class

Gets or sets the start.

C#
public REXxyz Start;
Description

The start.

Class

ContourDimension Class

Links
ContourDimension Class, REX.ContentGenerator.Geometry Namespace, ContourDimension Class


ContourDimensionLine Class

ContourDimensionLine Class
REX.ContentGenerator.Geometry Namespace Legend Members Public Methods ContourDimensionLine Methods ContourDimensionLine Properties

Represents the linear dimension.

Class Hierarchy
C#
public class ContourDimensionLine : ContourDimension;
Description
Namespace

REX.ContentGenerator.Geometry Namespace

Public Methods
Public Method | Description
ContourDimensionLine | Initializes a new instance of the ContourDimensionLine class.
ContourDimensionLine | Initializes a new instance of the ContourDimensionLine class.
ContourDimensionLine Methods
ContourDimensionLine Methods | Description
MultiplyLengthDim | Multiplies length dimensions by the coefficient.
Translate | Applies the specified translation vector to the element.
ContourDimensionLine Properties
ContourDimensionLine Properties | Description
End | Gets or sets the end.
Extend2Right | Gets or sets a value indicating whether the dimension should be extended to the right.
Level | Gets or sets the level.
Up | Gets or sets a value indicating whether dimension is defined above the reference.
Links
REX.ContentGenerator.Geometry Namespace, Legend, Members, Public Methods, ContourDimensionLine Methods, ContourDimensionLine Properties


ContourDimensionLine.ContourDimensionLine Constructor (REXxyz, REXxyz, int, bool, string, bool)

ContourDimensionLine.ContourDimensionLine Constructor (REXxyz, REXxyz, int, bool, string, bool)
ContourDimensionLine Class REX.ContentGenerator.Geometry Namespace ContourDimensionLine Class

Initializes a new instance of the ContourDimensionLine class.

C#
public ContourDimensionLine(REXxyz st, REXxyz end, int lev, bool up, string param, bool extend2Right);
Parameters
Parameters | Description
st | The start.
end | The end.
lev | The level.
up | Indicates whether the text should be placed above the reference.
param | The parameter (text).
extend2Right | Indicates whether the dimension should be extended to the right.
Description
Class

ContourDimensionLine Class

Links
ContourDimensionLine Class, REX.ContentGenerator.Geometry Namespace, ContourDimensionLine Class


ContourDimensionLine.ContourDimensionLine Constructor (double, double, double, double, int, bool, string, bool)

ContourDimensionLine.ContourDimensionLine Constructor (double, double, double, double, int, bool, string, bool)
ContourDimensionLine Class REX.ContentGenerator.Geometry Namespace ContourDimensionLine Class

Initializes a new instance of the ContourDimensionLine class.

C#
public ContourDimensionLine(double xst, double yst, double xend, double yend, int lev, bool up, string param, bool extend2Right);
Parameters
Parameters | Description
xst | The x start.
yst | The y start.
xend | The x end.
yend | The y end.
lev | The level.
up | Indicates whether the text should be placed above the reference.
param | The parameter (text).
extend2Right | Indicates whether the dimension should be extended to the right.
Description
Class

ContourDimensionLine Class

Links
ContourDimensionLine Class, REX.ContentGenerator.Geometry Namespace, ContourDimensionLine Class


ContourDimensionLine.MultiplyLengthDim Method

ContourDimensionLine.MultiplyLengthDim Method
ContourDimensionLine Class REX.ContentGenerator.Geometry Namespace ContourDimensionLine Class

Multiplies length dimensions by the coefficient.

C#
public override void MultiplyLengthDim(double coeff);
Parameters
Parameters | Description
coeff | The coefficient.
Description
Class

ContourDimensionLine Class

Links
ContourDimensionLine Class, REX.ContentGenerator.Geometry Namespace, ContourDimensionLine Class


ContourDimensionLine.Translate Method

ContourDimensionLine.Translate Method
ContourDimensionLine Class REX.ContentGenerator.Geometry Namespace ContourDimensionLine Class

Applies the specified translation vector to the element.

C#
public override void Translate(double x, double y);
Parameters
Parameters | Description
x | The x.
y | The y.
Description
Class

ContourDimensionLine Class

Links
ContourDimensionLine Class, REX.ContentGenerator.Geometry Namespace, ContourDimensionLine Class


ContourDimensionLine.End Property

ContourDimensionLine.End Property
ContourDimensionLine Class REX.ContentGenerator.Geometry Namespace ContourDimensionLine Class

Gets or sets the end.

C#
public REXxyz End;
Description

The end.

Class

ContourDimensionLine Class

Links
ContourDimensionLine Class, REX.ContentGenerator.Geometry Namespace, ContourDimensionLine Class


ContourDimensionLine.Extend2Right Property

ContourDimensionLine.Extend2Right Property
ContourDimensionLine Class REX.ContentGenerator.Geometry Namespace ContourDimensionLine Class

Gets or sets a value indicating whether the dimension should be extended to the right.

C#
public bool Extend2Right;
Description

True if extended to the right; otherwise, false.

Class

ContourDimensionLine Class

Links
ContourDimensionLine Class, REX.ContentGenerator.Geometry Namespace, ContourDimensionLine Class


ContourDimensionLine.Level Property

ContourDimensionLine.Level Property
ContourDimensionLine Class REX.ContentGenerator.Geometry Namespace ContourDimensionLine Class

Gets or sets the level.

C#
public int Level;
Description

The level.

Class

ContourDimensionLine Class

Links
ContourDimensionLine Class, REX.ContentGenerator.Geometry Namespace, ContourDimensionLine Class


ContourDimensionLine.Up Property

ContourDimensionLine.Up Property
ContourDimensionLine Class REX.ContentGenerator.Geometry Namespace ContourDimensionLine Class

Gets or sets a value indicating whether dimension is defined above the reference.

C#
public bool Up;
Description

True if above the reference; otherwise, false.

Class

ContourDimensionLine Class

Links
ContourDimensionLine Class, REX.ContentGenerator.Geometry Namespace, ContourDimensionLine Class


ContourDimensionRadius Class

ContourDimensionRadius Class
REX.ContentGenerator.Geometry Namespace Legend Members Public Methods ContourDimensionRadius Methods ContourDimensionRadius Properties

Represents the radial dimension.

Class Hierarchy
C#
public class ContourDimensionRadius : ContourDimension;
Description
Namespace

REX.ContentGenerator.Geometry Namespace

Public Methods
Public Method | Description
ContourDimensionRadius | Initializes a new instance of the ContourDimensionRadius class.
ContourDimensionRadius | Initializes a new instance of the ContourDimensionRadius class.
ContourDimensionRadius Methods
ContourDimensionRadius Methods | Description
MultiplyLengthDim | Multiplies length dimensions by the coefficient.
Translate | Applies the specified translation vector to the element.
ContourDimensionRadius Properties
ContourDimensionRadius Properties | Description
End | Gets or sets the end.
Up | Gets or sets a value indicating whether dimension is defined above the reference.
Links
REX.ContentGenerator.Geometry Namespace, Legend, Members, Public Methods, ContourDimensionRadius Methods, ContourDimensionRadius Properties


ContourDimensionRadius.ContourDimensionRadius Constructor (REXxyz, REXxyz, bool, string)

ContourDimensionRadius.ContourDimensionRadius Constructor (REXxyz, REXxyz, bool, string)
ContourDimensionRadius Class REX.ContentGenerator.Geometry Namespace ContourDimensionRadius Class

Initializes a new instance of the ContourDimensionRadius class.

C#
public ContourDimensionRadius(REXxyz st, REXxyz end, bool up, string param);
Parameters
Parameters | Description
st | The start.
end | The end.
up | Indicates whether the text should be placed above the reference.
param | The parameter (text).
Description
Class

ContourDimensionRadius Class

Links
ContourDimensionRadius Class, REX.ContentGenerator.Geometry Namespace, ContourDimensionRadius Class


ContourDimensionRadius.ContourDimensionRadius Constructor (double, double, double, double, bool, string)

ContourDimensionRadius.ContourDimensionRadius Constructor (double, double, double, double, bool, string)
ContourDimensionRadius Class REX.ContentGenerator.Geometry Namespace ContourDimensionRadius Class

Initializes a new instance of the ContourDimensionRadius class.

C#
public ContourDimensionRadius(double xst, double yst, double xend, double yend, bool up, string param);
Parameters
Parameters | Description
xst | The x start.
yst | The y start.
xend | The x end.
yend | The y end.
up | Indicates whether the text should be placed above the reference.
param | The parameter (text).
Description
Class

ContourDimensionRadius Class

Links
ContourDimensionRadius Class, REX.ContentGenerator.Geometry Namespace, ContourDimensionRadius Class


ContourDimensionRadius.MultiplyLengthDim Method

ContourDimensionRadius.MultiplyLengthDim Method
ContourDimensionRadius Class REX.ContentGenerator.Geometry Namespace ContourDimensionRadius Class

Multiplies length dimensions by the coefficient.

C#
public override void MultiplyLengthDim(double coeff);
Parameters
Parameters | Description
coeff | The coefficient.
Description
Class

ContourDimensionRadius Class

Links
ContourDimensionRadius Class, REX.ContentGenerator.Geometry Namespace, ContourDimensionRadius Class


ContourDimensionRadius.Translate Method

ContourDimensionRadius.Translate Method
ContourDimensionRadius Class REX.ContentGenerator.Geometry Namespace ContourDimensionRadius Class

Applies the specified translation vector to the element.

C#
public override void Translate(double x, double y);
Parameters
Parameters | Description
x | The x.
y | The y.
Description
Class

ContourDimensionRadius Class

Links
ContourDimensionRadius Class, REX.ContentGenerator.Geometry Namespace, ContourDimensionRadius Class


ContourDimensionRadius.End Property

ContourDimensionRadius.End Property
ContourDimensionRadius Class REX.ContentGenerator.Geometry Namespace ContourDimensionRadius Class

Gets or sets the end.

C#
public REXxyz End;
Description

The end.

Class

ContourDimensionRadius Class

Links
ContourDimensionRadius Class, REX.ContentGenerator.Geometry Namespace, ContourDimensionRadius Class


ContourDimensionRadius.Up Property

ContourDimensionRadius.Up Property
ContourDimensionRadius Class REX.ContentGenerator.Geometry Namespace ContourDimensionRadius Class

Gets or sets a value indicating whether dimension is defined above the reference.

C#
public bool Up;
Description

True if above the reference; otherwise, false.

Class

ContourDimensionRadius Class

Links
ContourDimensionRadius Class, REX.ContentGenerator.Geometry Namespace, ContourDimensionRadius Class


ContourElem Class

ContourElem Class
REX.ContentGenerator.Geometry Namespace Legend Members Public Methods ContourElem Methods ContourElem Properties

Base class for all contour elements.

Class Hierarchy
C#
[Serializable()]
public class ContourElem : SerializableObject;
Description
Namespace

REX.ContentGenerator.Geometry Namespace

Public Methods
Public Method | Description
ContourElem | Initializes a new instance of the ContourElem class.
ContourElem | Initializes a new instance of the ContourElem class.
ContourElem Methods
ContourElem Methods | Description
GetFlatPointInCoords | Gets the flat point in the plane.
GetPointList | Gets the list of points.
MultiplyLengthDim | Multiplies length dimensions by the coefficient.
Transform | Applies the specified transformation to the element.
Transform | Applies the specified transformation to the element.
Translate | Applies the specified translation vector to the element.
ContourElem Properties
ContourElem Properties | Description
ElemType | Gets the type of the elem.
Tag | Gets or sets the tag.
Links
REX.ContentGenerator.Geometry Namespace, Legend, Members, Public Methods, ContourElem Methods, ContourElem Properties


ContourElem.ContourElem Constructor ()

ContourElem.ContourElem Constructor ()
ContourElem Class REX.ContentGenerator.Geometry Namespace ContourElem Class

Initializes a new instance of the ContourElem class.

C#
public ContourElem();
Description
Class

ContourElem Class

Links
ContourElem Class, REX.ContentGenerator.Geometry Namespace, ContourElem Class


ContourElem.ContourElem Constructor (System.Runtime.Serialization.SerializationInfo, System.Runtime.Serialization.StreamingContext)

ContourElem.ContourElem Constructor (System.Runtime.Serialization.SerializationInfo, System.Runtime.Serialization.StreamingContext)
ContourElem Class REX.ContentGenerator.Geometry Namespace ContourElem Class

Initializes a new instance of the ContourElem class.

C#
public ContourElem(System.Runtime.Serialization.SerializationInfo info, System.Runtime.Serialization.StreamingContext context);
Parameters
Parameters | Description
info | Serialization data.
context | The context.
Description
Class

ContourElem Class

Links
ContourElem Class, REX.ContentGenerator.Geometry Namespace, ContourElem Class


ContourElem.GetFlatPointInCoords Method

ContourElem.GetFlatPointInCoords Method
ContourElem Class REX.ContentGenerator.Geometry Namespace ContourElem Class

Gets the flat point in the plane.

C#
public REXxyz GetFlatPointInCoords(REXxyz pt, ECoords coords);
Parameters
Parameters | Description
pt | The point.
coords | The coordinate system (plane).
Returns

The point

Description
Class

ContourElem Class

Links
ContourElem Class, REX.ContentGenerator.Geometry Namespace, ContourElem Class


ContourElem.GetPointList Method

ContourElem.GetPointList Method
ContourElem Class REX.ContentGenerator.Geometry Namespace ContourElem Class

Gets the list of points.

C#
public virtual List<REXxyz> GetPointList(bool end);
Parameters
Parameters | Description
end | Indicates whether the end point should be included.
Returns

Returns the list of points

Description
Class

ContourElem Class

Links
ContourElem Class, REX.ContentGenerator.Geometry Namespace, ContourElem Class


ContourElem.MultiplyLengthDim Method

ContourElem.MultiplyLengthDim Method
ContourElem Class REX.ContentGenerator.Geometry Namespace ContourElem Class

Multiplies length dimensions by the coefficient.

C#
public virtual void MultiplyLengthDim(double coeff);
Parameters
Parameters | Description
coeff | The coefficient.
Description
Class

ContourElem Class

Links
ContourElem Class, REX.ContentGenerator.Geometry Namespace, ContourElem Class


ContourElem.Transform Method (REXxyz, TransformDbl, bool)

ContourElem.Transform Method (REXxyz, TransformDbl, bool)
ContourElem Class REX.ContentGenerator.Geometry Namespace ContourElem Class

Applies the specified transformation to the element.

C#
public REXxyz Transform(REXxyz pt, TransformDbl trans, bool toLocal);
Parameters
Parameters | Description
pt | The point.
trans | The transformation object.
toLocal | Indicates the direction of transformation: true if from global to local; otherwise false.
Returns

Returns the transformed point.

Description
Class

ContourElem Class

Links
ContourElem Class, REX.ContentGenerator.Geometry Namespace, ContourElem Class


ContourElem.Transform Method (TransformDbl, bool)

ContourElem.Transform Method (TransformDbl, bool)
ContourElem Class REX.ContentGenerator.Geometry Namespace ContourElem Class

Applies the specified transformation to the element.

C#
public virtual void Transform(TransformDbl trans, bool toLocal);
Parameters
Parameters | Description
trans | The transformation object.
toLocal | Indicates the direction of transformation: true if from global to local; otherwise false.
Description
Class

ContourElem Class

Links
ContourElem Class, REX.ContentGenerator.Geometry Namespace, ContourElem Class


ContourElem.Translate Method

ContourElem.Translate Method
ContourElem Class REX.ContentGenerator.Geometry Namespace ContourElem Class

Applies the specified translation vector to the element.

C#
public virtual void Translate(double x, double y);
Parameters
Parameters | Description
x | The x.
y | The y.
Description
Class

ContourElem Class

Links
ContourElem Class, REX.ContentGenerator.Geometry Namespace, ContourElem Class


ContourElem.ElemType Property

ContourElem.ElemType Property
ContourElem Class REX.ContentGenerator.Geometry Namespace ContourElem Class

Gets the type of the elem.

C#
public EContElemType ElemType;
Description

The type of the elem.

Class

ContourElem Class

Links
ContourElem Class, REX.ContentGenerator.Geometry Namespace, ContourElem Class


ContourElem.Tag Property

ContourElem.Tag Property
ContourElem Class REX.ContentGenerator.Geometry Namespace ContourElem Class

Gets or sets the tag.

C#
public object Tag;
Description

The tag.

Class

ContourElem Class

Links
ContourElem Class, REX.ContentGenerator.Geometry Namespace, ContourElem Class


ContourLine Class

ContourLine Class
REX.ContentGenerator.Geometry Namespace Legend Members Public Methods ContourLine Methods ContourLine Properties

Represents the line element.

Class Hierarchy
C#
[Serializable()]
public class ContourLine : ContourElem;
Description
Namespace

REX.ContentGenerator.Geometry Namespace

Public Methods
Public Method | Description
ContourLine | Initializes a new instance of the ContourLine class.
ContourLine | Initializes a new instance of the ContourLine class.
ContourLine | Initializes a new instance of the ContourLine class.
ContourLine | Initializes a new instance of the ContourLine class.
ContourLine | Initializes a new instance of the ContourLine class.
ContourLine Methods
ContourLine Methods | Description
GetEnd | Gets the end point in a plane.
GetPointList | Gets the list of points.
GetStart | Gets the start point in a plane.
MultiplyLengthDim | Multiplies length dimensions by the coefficient.
Transform | Applies the specified transformation to the element.
Translate | Applies the specified translation vector to the element.
ContourLine Properties
ContourLine Properties | Description
End | Gets or sets the end point.
Start | Gets or sets the start point.
Links
REX.ContentGenerator.Geometry Namespace, Legend, Members, Public Methods, ContourLine Methods, ContourLine Properties


ContourLine.ContourLine Constructor (ContourLine)

ContourLine.ContourLine Constructor (ContourLine)
ContourLine Class REX.ContentGenerator.Geometry Namespace ContourLine Class

Initializes a new instance of the ContourLine class.

C#
public ContourLine(ContourLine pattern);
Parameters
Parameters | Description
pattern | The pattern.
Description
Class

ContourLine Class

Links
ContourLine Class, REX.ContentGenerator.Geometry Namespace, ContourLine Class


ContourLine.ContourLine Constructor (REXxyz, REXxyz)

ContourLine.ContourLine Constructor (REXxyz, REXxyz)
ContourLine Class REX.ContentGenerator.Geometry Namespace ContourLine Class

Initializes a new instance of the ContourLine class.

C#
public ContourLine(REXxyz st, REXxyz end);
Parameters
Parameters | Description
st | The start.
end | The end.
Description
Class

ContourLine Class

Links
ContourLine Class, REX.ContentGenerator.Geometry Namespace, ContourLine Class


ContourLine.ContourLine Constructor (System.Runtime.Serialization.SerializationInfo, System.Runtime.Serialization.StreamingContext)

ContourLine.ContourLine Constructor (System.Runtime.Serialization.SerializationInfo, System.Runtime.Serialization.StreamingContext)
ContourLine Class REX.ContentGenerator.Geometry Namespace ContourLine Class

Initializes a new instance of the ContourLine class.

C#
public ContourLine(System.Runtime.Serialization.SerializationInfo info, System.Runtime.Serialization.StreamingContext context);
Parameters
Parameters | Description
info | Serialization data.
context | The context.
Description
Class

ContourLine Class

Links
ContourLine Class, REX.ContentGenerator.Geometry Namespace, ContourLine Class


ContourLine.ContourLine Constructor (double, double, double, double)

ContourLine.ContourLine Constructor (double, double, double, double)
ContourLine Class REX.ContentGenerator.Geometry Namespace ContourLine Class

Initializes a new instance of the ContourLine class.

C#
public ContourLine(double xst, double yst, double xend, double yend);
Parameters
Parameters | Description
xst | The x start.
yst | The y start.
xend | The x end.
yend | The y end.
Description
Class

ContourLine Class

Links
ContourLine Class, REX.ContentGenerator.Geometry Namespace, ContourLine Class


ContourLine.ContourLine Constructor (double, double, double, double, double, double)

ContourLine.ContourLine Constructor (double, double, double, double, double, double)
ContourLine Class REX.ContentGenerator.Geometry Namespace ContourLine Class

Initializes a new instance of the ContourLine class.

C#
public ContourLine(double xst, double yst, double zst, double xend, double yend, double zend);
Parameters
Parameters | Description
xst | The x start.
yst | The y start.
zst | The z start.
xend | The x end.
yend | The y end.
zend | The z end.
Description
Class

ContourLine Class

Links
ContourLine Class, REX.ContentGenerator.Geometry Namespace, ContourLine Class


ContourLine.GetEnd Method

ContourLine.GetEnd Method
ContourLine Class REX.ContentGenerator.Geometry Namespace ContourLine Class

Gets the end point in a plane.

C#
public REXxyz GetEnd(ECoords coords);
Parameters
Parameters | Description
coords | The coordinate system (plane).
Returns

The end point.

Description
Class

ContourLine Class

Links
ContourLine Class, REX.ContentGenerator.Geometry Namespace, ContourLine Class


ContourLine.GetPointList Method

ContourLine.GetPointList Method
ContourLine Class REX.ContentGenerator.Geometry Namespace ContourLine Class

Gets the list of points.

C#
public override List<REXxyz> GetPointList(bool end);
Parameters
Parameters | Description
end | If the end point included.
Returns

Returns the list of points.

Description
Class

ContourLine Class

Links
ContourLine Class, REX.ContentGenerator.Geometry Namespace, ContourLine Class


ContourLine.GetStart Method

ContourLine.GetStart Method
ContourLine Class REX.ContentGenerator.Geometry Namespace ContourLine Class

Gets the start point in a plane.

C#
public REXxyz GetStart(ECoords coords);
Parameters
Parameters | Description
coords | The coordinate system (plane).
Returns

The start point.

Description
Class

ContourLine Class

Links
ContourLine Class, REX.ContentGenerator.Geometry Namespace, ContourLine Class


ContourLine.MultiplyLengthDim Method

ContourLine.MultiplyLengthDim Method
ContourLine Class REX.ContentGenerator.Geometry Namespace ContourLine Class

Multiplies length dimensions by the coefficient.

C#
public override void MultiplyLengthDim(double coeff);
Parameters
Parameters | Description
coeff | The coefficient.
Description
Class

ContourLine Class

Links
ContourLine Class, REX.ContentGenerator.Geometry Namespace, ContourLine Class


ContourLine.Transform Method

ContourLine.Transform Method
ContourLine Class REX.ContentGenerator.Geometry Namespace ContourLine Class

Applies the specified transformation to the element.

C#
public override void Transform(TransformDbl trans, bool toLocal);
Parameters
Parameters | Description
trans | The transformation object.
toLocal | If transformation from the global to the local coordinate system.
Description
Class

ContourLine Class

Links
ContourLine Class, REX.ContentGenerator.Geometry Namespace, ContourLine Class


ContourLine.Translate Method

ContourLine.Translate Method
ContourLine Class REX.ContentGenerator.Geometry Namespace ContourLine Class

Applies the specified translation vector to the element.

C#
public override void Translate(double x, double y);
Parameters
Parameters | Description
x | The x.
y | The y.
Description
Class

ContourLine Class

Links
ContourLine Class, REX.ContentGenerator.Geometry Namespace, ContourLine Class


ContourLine.End Property

ContourLine.End Property
ContourLine Class REX.ContentGenerator.Geometry Namespace ContourLine Class

Gets or sets the end point.

C#
public REXxyz End;
Description

The end point.

Class

ContourLine Class

Links
ContourLine Class, REX.ContentGenerator.Geometry Namespace, ContourLine Class


ContourLine.Start Property

ContourLine.Start Property
ContourLine Class REX.ContentGenerator.Geometry Namespace ContourLine Class

Gets or sets the start point.

C#
public REXxyz Start;
Description

The start point.

Class

ContourLine Class

Links
ContourLine Class, REX.ContentGenerator.Geometry Namespace, ContourLine Class


REXSectionAnalyzer Class

REXSectionAnalyzer Class
REX.ContentGenerator.Geometry Namespace

This is class REX.ContentGenerator.Geometry.REXSectionAnalyzer.

Class Hierarchy
C#
public class REXSectionAnalyzer;
Namespace

REX.ContentGenerator.Geometry Namespace

Links
REX.ContentGenerator.Geometry Namespace
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXSectionTypeAnalyzer Class

REXSectionTypeAnalyzer Class
REX.ContentGenerator.Geometry Namespace Legend Members Public Methods REXSectionTypeAnalyzer Methods

This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer.

Class Hierarchy
C#
public abstract class REXSectionTypeAnalyzer;
Namespace

REX.ContentGenerator.Geometry Namespace

Public Methods
Public Method | Description
REXSectionTypeAnalyzer | This is REXSectionTypeAnalyzer, a member of class REXSectionTypeAnalyzer.
REXSectionTypeAnalyzer Methods
REXSectionTypeAnalyzer Methods | Description
BuildVectorShape | This is BuildVectorShape, a member of class REXSectionTypeAnalyzer.
FitCompoundProfilePattern | This is FitCompoundProfilePattern, a member of class REXSectionTypeAnalyzer.
GetMaximumLength | This is GetMaximumLength, a member of class REXSectionTypeAnalyzer.
GetNextIndex | This is GetNextIndex, a member of class REXSectionTypeAnalyzer.
GetParametricDescription | This is GetParametricDescription, a member of class REXSectionTypeAnalyzer.
GetParametricDescription | This is GetParametricDescription, a member of class REXSectionTypeAnalyzer.
GetPreviousIndex | This is GetPreviousIndex, a member of class REXSectionTypeAnalyzer.
ReorderShape | This is ReorderShape, a member of class REXSectionTypeAnalyzer.
RepairCompoundSectionProfile | This is RepairCompoundSectionProfile, a member of class REXSectionTypeAnalyzer.
RepairSectionProfile | This is RepairSectionProfile, a member of class REXSectionTypeAnalyzer.
RepairShapeCounterClockWise | This is RepairShapeCounterClockWise, a member of class REXSectionTypeAnalyzer.
RepairShapeDue2BoundingBox | This is RepairShapeDue2BoundingBox, a member of class REXSectionTypeAnalyzer.
RepairShapeLines | This is RepairShapeLines, a member of class REXSectionTypeAnalyzer.
TransformCompoundProfile | This is TransformCompoundProfile, a member of class REXSectionTypeAnalyzer.
TransformProfile | This is TransformProfile, a member of class REXSectionTypeAnalyzer.
TransformShape | This is TransformShape, a member of class REXSectionTypeAnalyzer.
ValidateCircle | This is ValidateCircle, a member of class REXSectionTypeAnalyzer.
ValidateCircle | This is ValidateCircle, a member of class REXSectionTypeAnalyzer.
VectorDrivenAnalysis | This is VectorDrivenAnalysis, a member of class REXSectionTypeAnalyzer.
Links
REX.ContentGenerator.Geometry Namespace, Legend, Members, Public Methods, REXSectionTypeAnalyzer Methods


REXSectionTypeAnalyzer.REXSectionTypeAnalyzer Constructor

REXSectionTypeAnalyzer.REXSectionTypeAnalyzer Constructor
REXSectionTypeAnalyzer Class REX.ContentGenerator.Geometry Namespace REXSectionTypeAnalyzer Class

This is REXSectionTypeAnalyzer, a member of class REXSectionTypeAnalyzer.

C#
public REXSectionTypeAnalyzer();
Class

REXSectionTypeAnalyzer Class

Links
REXSectionTypeAnalyzer Class, REX.ContentGenerator.Geometry Namespace, REXSectionTypeAnalyzer Class


REXSectionTypeAnalyzer.BuildVectorShape Method

REXSectionTypeAnalyzer.BuildVectorShape Method
REXSectionTypeAnalyzer Class REX.ContentGenerator.Geometry Namespace REXSectionTypeAnalyzer Class

This is BuildVectorShape, a member of class REXSectionTypeAnalyzer.

C#
public static REXSectionShape BuildVectorShape(REXSectionShape shape);
Class

REXSectionTypeAnalyzer Class

Links
REXSectionTypeAnalyzer Class, REX.ContentGenerator.Geometry Namespace, REXSectionTypeAnalyzer Class


REXSectionTypeAnalyzer.FitCompoundProfilePattern Method

REXSectionTypeAnalyzer.FitCompoundProfilePattern Method
REXSectionTypeAnalyzer Class REX.ContentGenerator.Geometry Namespace REXSectionTypeAnalyzer Class

This is FitCompoundProfilePattern, a member of class REXSectionTypeAnalyzer.

C#
public virtual bool FitCompoundProfilePattern(ref REXCompoundSectionProfile compoundProfile, bool transform, out TransformREXxyz trans);
Class

REXSectionTypeAnalyzer Class

Links
REXSectionTypeAnalyzer Class, REX.ContentGenerator.Geometry Namespace, REXSectionTypeAnalyzer Class


REXSectionTypeAnalyzer.GetMaximumLength Method

REXSectionTypeAnalyzer.GetMaximumLength Method
REXSectionTypeAnalyzer Class REX.ContentGenerator.Geometry Namespace REXSectionTypeAnalyzer Class

This is GetMaximumLength, a member of class REXSectionTypeAnalyzer.

C#
public static double GetMaximumLength(List<REXxyz> points, out int startIndex, out int endIndex);
Class

REXSectionTypeAnalyzer Class

Links
REXSectionTypeAnalyzer Class, REX.ContentGenerator.Geometry Namespace, REXSectionTypeAnalyzer Class


REXSectionTypeAnalyzer.GetNextIndex Method

REXSectionTypeAnalyzer.GetNextIndex Method
REXSectionTypeAnalyzer Class REX.ContentGenerator.Geometry Namespace REXSectionTypeAnalyzer Class

This is GetNextIndex, a member of class REXSectionTypeAnalyzer.

C#
public static int GetNextIndex(int count, int index);
Class

REXSectionTypeAnalyzer Class

Links
REXSectionTypeAnalyzer Class, REX.ContentGenerator.Geometry Namespace, REXSectionTypeAnalyzer Class


REXSectionTypeAnalyzer.GetParametricDescription Method (REXCompoundSectionProfile, REXCompoundSectionProfile, TransformREXxyz)

REXSectionTypeAnalyzer.GetParametricDescription Method (REXCompoundSectionProfile, REXCompoundSectionProfile, TransformREXxyz)
REXSectionTypeAnalyzer Class REX.ContentGenerator.Geometry Namespace REXSectionTypeAnalyzer Class

This is GetParametricDescription, a member of class REXSectionTypeAnalyzer.

C#
public virtual REXSectionParamDescription GetParametricDescription(REXCompoundSectionProfile profileStart, REXCompoundSectionProfile profileEnd, TransformREXxyz transStart);
Class

REXSectionTypeAnalyzer Class

Links
REXSectionTypeAnalyzer Class, REX.ContentGenerator.Geometry Namespace, REXSectionTypeAnalyzer Class


REXSectionTypeAnalyzer.GetParametricDescription Method (REXCompoundSectionProfile, TransformREXxyz)

REXSectionTypeAnalyzer.GetParametricDescription Method (REXCompoundSectionProfile, TransformREXxyz)
REXSectionTypeAnalyzer Class REX.ContentGenerator.Geometry Namespace REXSectionTypeAnalyzer Class

This is GetParametricDescription, a member of class REXSectionTypeAnalyzer.

C#
public virtual REXSectionParamDescription GetParametricDescription(REXCompoundSectionProfile profileStart, TransformREXxyz transStart);
Class

REXSectionTypeAnalyzer Class

Links
REXSectionTypeAnalyzer Class, REX.ContentGenerator.Geometry Namespace, REXSectionTypeAnalyzer Class


REXSectionTypeAnalyzer.GetPreviousIndex Method

REXSectionTypeAnalyzer.GetPreviousIndex Method
REXSectionTypeAnalyzer Class REX.ContentGenerator.Geometry Namespace REXSectionTypeAnalyzer Class

This is GetPreviousIndex, a member of class REXSectionTypeAnalyzer.

C#
public static int GetPreviousIndex(int count, int index);
Class

REXSectionTypeAnalyzer Class

Links
REXSectionTypeAnalyzer Class, REX.ContentGenerator.Geometry Namespace, REXSectionTypeAnalyzer Class


REXSectionTypeAnalyzer.ReorderShape Method

REXSectionTypeAnalyzer.ReorderShape Method
REXSectionTypeAnalyzer Class REX.ContentGenerator.Geometry Namespace REXSectionTypeAnalyzer Class

This is ReorderShape, a member of class REXSectionTypeAnalyzer.

C#
public static void ReorderShape(REXSectionShape shape, int indexStart);
Class

REXSectionTypeAnalyzer Class

Links
REXSectionTypeAnalyzer Class, REX.ContentGenerator.Geometry Namespace, REXSectionTypeAnalyzer Class


REXSectionTypeAnalyzer.RepairCompoundSectionProfile Method

REXSectionTypeAnalyzer.RepairCompoundSectionProfile Method
REXSectionTypeAnalyzer Class REX.ContentGenerator.Geometry Namespace REXSectionTypeAnalyzer Class

This is RepairCompoundSectionProfile, a member of class REXSectionTypeAnalyzer.

C#
public static void RepairCompoundSectionProfile(REXCompoundSectionProfile compoundProfile);
Class

REXSectionTypeAnalyzer Class

Links
REXSectionTypeAnalyzer Class, REX.ContentGenerator.Geometry Namespace, REXSectionTypeAnalyzer Class


REXSectionTypeAnalyzer.RepairSectionProfile Method

REXSectionTypeAnalyzer.RepairSectionProfile Method
REXSectionTypeAnalyzer Class REX.ContentGenerator.Geometry Namespace REXSectionTypeAnalyzer Class

This is RepairSectionProfile, a member of class REXSectionTypeAnalyzer.

C#
public static void RepairSectionProfile(REXSectionProfile profile);
Class

REXSectionTypeAnalyzer Class

Links
REXSectionTypeAnalyzer Class, REX.ContentGenerator.Geometry Namespace, REXSectionTypeAnalyzer Class


REXSectionTypeAnalyzer.RepairShapeCounterClockWise Method

REXSectionTypeAnalyzer.RepairShapeCounterClockWise Method
REXSectionTypeAnalyzer Class REX.ContentGenerator.Geometry Namespace REXSectionTypeAnalyzer Class

This is RepairShapeCounterClockWise, a member of class REXSectionTypeAnalyzer.

C#
public static void RepairShapeCounterClockWise(REXSectionShape shape);
Class

REXSectionTypeAnalyzer Class

Links
REXSectionTypeAnalyzer Class, REX.ContentGenerator.Geometry Namespace, REXSectionTypeAnalyzer Class


REXSectionTypeAnalyzer.RepairShapeDue2BoundingBox Method

REXSectionTypeAnalyzer.RepairShapeDue2BoundingBox Method
REXSectionTypeAnalyzer Class REX.ContentGenerator.Geometry Namespace REXSectionTypeAnalyzer Class

This is RepairShapeDue2BoundingBox, a member of class REXSectionTypeAnalyzer.

C#
public static void RepairShapeDue2BoundingBox(REXSectionShape shape);
Class

REXSectionTypeAnalyzer Class

Links
REXSectionTypeAnalyzer Class, REX.ContentGenerator.Geometry Namespace, REXSectionTypeAnalyzer Class


REXSectionTypeAnalyzer.RepairShapeLines Method

REXSectionTypeAnalyzer.RepairShapeLines Method
REXSectionTypeAnalyzer Class REX.ContentGenerator.Geometry Namespace REXSectionTypeAnalyzer Class

This is RepairShapeLines, a member of class REXSectionTypeAnalyzer.

C#
public static void RepairShapeLines(REXSectionShape shape);
Class

REXSectionTypeAnalyzer Class

Links
REXSectionTypeAnalyzer Class, REX.ContentGenerator.Geometry Namespace, REXSectionTypeAnalyzer Class


REXSectionTypeAnalyzer.TransformCompoundProfile Method

REXSectionTypeAnalyzer.TransformCompoundProfile Method
REXSectionTypeAnalyzer Class REX.ContentGenerator.Geometry Namespace REXSectionTypeAnalyzer Class

This is TransformCompoundProfile, a member of class REXSectionTypeAnalyzer.

C#
public static void TransformCompoundProfile(REXCompoundSectionProfile compoundProfile, TransformREXxyz trans);
Class

REXSectionTypeAnalyzer Class

Links
REXSectionTypeAnalyzer Class, REX.ContentGenerator.Geometry Namespace, REXSectionTypeAnalyzer Class


REXSectionTypeAnalyzer.TransformProfile Method

REXSectionTypeAnalyzer.TransformProfile Method
REXSectionTypeAnalyzer Class REX.ContentGenerator.Geometry Namespace REXSectionTypeAnalyzer Class

This is TransformProfile, a member of class REXSectionTypeAnalyzer.

C#
public static void TransformProfile(REXSectionProfile profile, TransformREXxyz trans);
Class

REXSectionTypeAnalyzer Class

Links
REXSectionTypeAnalyzer Class, REX.ContentGenerator.Geometry Namespace, REXSectionTypeAnalyzer Class


REXSectionTypeAnalyzer.TransformShape Method

REXSectionTypeAnalyzer.TransformShape Method
REXSectionTypeAnalyzer Class REX.ContentGenerator.Geometry Namespace REXSectionTypeAnalyzer Class

This is TransformShape, a member of class REXSectionTypeAnalyzer.

C#
public static void TransformShape(REXSectionShape shape, TransformREXxyz trans);
Class

REXSectionTypeAnalyzer Class

Links
REXSectionTypeAnalyzer Class, REX.ContentGenerator.Geometry Namespace, REXSectionTypeAnalyzer Class


REXSectionTypeAnalyzer.ValidateCircle Method (List<REXxyz>, out double, out REXxyz)

REXSectionTypeAnalyzer.ValidateCircle Method (List<REXxyz>, out double, out REXxyz)
REXSectionTypeAnalyzer Class REX.ContentGenerator.Geometry Namespace REXSectionTypeAnalyzer Class

This is ValidateCircle, a member of class REXSectionTypeAnalyzer.

C#
public static bool ValidateCircle(List<REXxyz> Points, out double radius, out REXxyz center);
Class

REXSectionTypeAnalyzer Class

Links
REXSectionTypeAnalyzer Class, REX.ContentGenerator.Geometry Namespace, REXSectionTypeAnalyzer Class


REXSectionTypeAnalyzer.ValidateCircle Method (REXSectionShape, out double, out REXxyz)

REXSectionTypeAnalyzer.ValidateCircle Method (REXSectionShape, out double, out REXxyz)
REXSectionTypeAnalyzer Class REX.ContentGenerator.Geometry Namespace REXSectionTypeAnalyzer Class

This is ValidateCircle, a member of class REXSectionTypeAnalyzer.

C#
public static bool ValidateCircle(REXSectionShape profile, out double radius, out REXxyz center);
Class

REXSectionTypeAnalyzer Class

Links
REXSectionTypeAnalyzer Class, REX.ContentGenerator.Geometry Namespace, REXSectionTypeAnalyzer Class


REXSectionTypeAnalyzer.VectorDrivenAnalysis Method

REXSectionTypeAnalyzer.VectorDrivenAnalysis Method
REXSectionTypeAnalyzer Class REX.ContentGenerator.Geometry Namespace REXSectionTypeAnalyzer Class

This is VectorDrivenAnalysis, a member of class REXSectionTypeAnalyzer.

C#
public virtual bool VectorDrivenAnalysis();
Class

REXSectionTypeAnalyzer Class

Links
REXSectionTypeAnalyzer Class, REX.ContentGenerator.Geometry Namespace, REXSectionTypeAnalyzer Class


REXSectionTypeAnalyzer_BOX1 Class

REXSectionTypeAnalyzer_BOX1 Class
REX.ContentGenerator.Geometry Namespace

This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_BOX1.

Class Hierarchy
C#
public class REXSectionTypeAnalyzer_BOX1 : REXSectionTypeAnalyzer_RECTHOLLOW;
Namespace

REX.ContentGenerator.Geometry Namespace

Links
REX.ContentGenerator.Geometry Namespace
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXSectionTypeAnalyzer_BOX2 Class

REXSectionTypeAnalyzer_BOX2 Class
REX.ContentGenerator.Geometry Namespace

This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_BOX2.

Class Hierarchy
C#
public class REXSectionTypeAnalyzer_BOX2 : REXSectionTypeAnalyzer;
Namespace

REX.ContentGenerator.Geometry Namespace

Links
REX.ContentGenerator.Geometry Namespace
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXSectionTypeAnalyzer_BOX3 Class

REXSectionTypeAnalyzer_BOX3 Class
REX.ContentGenerator.Geometry Namespace

This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_BOX3.

Class Hierarchy
C#
public class REXSectionTypeAnalyzer_BOX3 : REXSectionTypeAnalyzer;
Namespace

REX.ContentGenerator.Geometry Namespace

Links
REX.ContentGenerator.Geometry Namespace
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXSectionTypeAnalyzer_C Class

REXSectionTypeAnalyzer_C Class
REX.ContentGenerator.Geometry Namespace

This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_C.

Class Hierarchy
C#
public class REXSectionTypeAnalyzer_C : REXSectionTypeAnalyzer;
Namespace

REX.ContentGenerator.Geometry Namespace

Links
REX.ContentGenerator.Geometry Namespace
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXSectionTypeAnalyzer_CROSS Class

REXSectionTypeAnalyzer_CROSS Class
REX.ContentGenerator.Geometry Namespace

This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_CROSS.

Class Hierarchy
C#
public class REXSectionTypeAnalyzer_CROSS : REXSectionTypeAnalyzer;
Namespace

REX.ContentGenerator.Geometry Namespace

Links
REX.ContentGenerator.Geometry Namespace
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXSectionTypeAnalyzer_DRECT Class

REXSectionTypeAnalyzer_DRECT Class
REX.ContentGenerator.Geometry Namespace

This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_DRECT.

Class Hierarchy
C#
public class REXSectionTypeAnalyzer_DRECT : REXSectionTypeAnalyzer;
Namespace

REX.ContentGenerator.Geometry Namespace

Links
REX.ContentGenerator.Geometry Namespace
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXSectionTypeAnalyzer_I Class

REXSectionTypeAnalyzer_I Class
REX.ContentGenerator.Geometry Namespace

This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_I.

Class Hierarchy
C#
public class REXSectionTypeAnalyzer_I : REXSectionTypeAnalyzer;
Namespace

REX.ContentGenerator.Geometry Namespace

Links
REX.ContentGenerator.Geometry Namespace
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXSectionTypeAnalyzer_IASYM Class

REXSectionTypeAnalyzer_IASYM Class
REX.ContentGenerator.Geometry Namespace

This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_IASYM.

Class Hierarchy
C#
public class REXSectionTypeAnalyzer_IASYM : REXSectionTypeAnalyzer;
Namespace

REX.ContentGenerator.Geometry Namespace

Links
REX.ContentGenerator.Geometry Namespace
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXSectionTypeAnalyzer_L Class

REXSectionTypeAnalyzer_L Class
REX.ContentGenerator.Geometry Namespace

This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_L.

Class Hierarchy
C#
public class REXSectionTypeAnalyzer_L : REXSectionTypeAnalyzer;
Namespace

REX.ContentGenerator.Geometry Namespace

Links
REX.ContentGenerator.Geometry Namespace
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXSectionTypeAnalyzer_POLYG Class

REXSectionTypeAnalyzer_POLYG Class
REX.ContentGenerator.Geometry Namespace

This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_POLYG.

Class Hierarchy
C#
public class REXSectionTypeAnalyzer_POLYG : REXSectionTypeAnalyzer;
Namespace

REX.ContentGenerator.Geometry Namespace

Links
REX.ContentGenerator.Geometry Namespace
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXSectionTypeAnalyzer_POLYGHOLLOW Class

REXSectionTypeAnalyzer_POLYGHOLLOW Class
REX.ContentGenerator.Geometry Namespace

This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_POLYGHOLLOW.

Class Hierarchy
C#
public class REXSectionTypeAnalyzer_POLYGHOLLOW : REXSectionTypeAnalyzer;
Namespace

REX.ContentGenerator.Geometry Namespace

Links
REX.ContentGenerator.Geometry Namespace
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXSectionTypeAnalyzer_RECT Class

REXSectionTypeAnalyzer_RECT Class
REX.ContentGenerator.Geometry Namespace

This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_RECT.

Class Hierarchy
C#
public class REXSectionTypeAnalyzer_RECT : REXSectionTypeAnalyzer;
Namespace

REX.ContentGenerator.Geometry Namespace

Links
REX.ContentGenerator.Geometry Namespace
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXSectionTypeAnalyzer_RECTHOLLOW Class

REXSectionTypeAnalyzer_RECTHOLLOW Class
REX.ContentGenerator.Geometry Namespace

This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_RECTHOLLOW.

Class Hierarchy
C#
public class REXSectionTypeAnalyzer_RECTHOLLOW : REXSectionTypeAnalyzer;
Namespace

REX.ContentGenerator.Geometry Namespace

Links
REX.ContentGenerator.Geometry Namespace
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXSectionTypeAnalyzer_ROUND Class

REXSectionTypeAnalyzer_ROUND Class
REX.ContentGenerator.Geometry Namespace Legend Members REXSectionTypeAnalyzer_ROUND Methods

This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_ROUND.

Class Hierarchy
C#
public class REXSectionTypeAnalyzer_ROUND : REXSectionTypeAnalyzer;
Namespace

REX.ContentGenerator.Geometry Namespace

REXSectionTypeAnalyzer_ROUND Methods
REXSectionTypeAnalyzer_ROUND Methods | Description
GetParametricDescription | This is GetParametricDescription, a member of class REXSectionTypeAnalyzer_ROUND.
GetParametricDescription | This is GetParametricDescription, a member of class REXSectionTypeAnalyzer_ROUND.
VectorDrivenAnalysis | This is VectorDrivenAnalysis, a member of class REXSectionTypeAnalyzer_ROUND.
Links
REX.ContentGenerator.Geometry Namespace, Legend, Members, REXSectionTypeAnalyzer_ROUND Methods


REXSectionTypeAnalyzer_ROUND.GetParametricDescription Method (REXCompoundSectionProfile, REXCompoundSectionProfile, TransformREXxyz)

REXSectionTypeAnalyzer_ROUND.GetParametricDescription Method (REXCompoundSectionProfile, REXCompoundSectionProfile, TransformREXxyz)
REXSectionTypeAnalyzer_ROUND Class REX.ContentGenerator.Geometry Namespace REXSectionTypeAnalyzer_ROUND Class

This is GetParametricDescription, a member of class REXSectionTypeAnalyzer_ROUND.

C#
public override REXSectionParamDescription GetParametricDescription(REXCompoundSectionProfile profileStart, REXCompoundSectionProfile profileEnd, TransformREXxyz transStart);
Class

REXSectionTypeAnalyzer_ROUND Class

Links
REXSectionTypeAnalyzer_ROUND Class, REX.ContentGenerator.Geometry Namespace, REXSectionTypeAnalyzer_ROUND Class


REXSectionTypeAnalyzer_ROUND.GetParametricDescription Method (REXCompoundSectionProfile, TransformREXxyz)

REXSectionTypeAnalyzer_ROUND.GetParametricDescription Method (REXCompoundSectionProfile, TransformREXxyz)
REXSectionTypeAnalyzer_ROUND Class REX.ContentGenerator.Geometry Namespace REXSectionTypeAnalyzer_ROUND Class

This is GetParametricDescription, a member of class REXSectionTypeAnalyzer_ROUND.

C#
public override REXSectionParamDescription GetParametricDescription(REXCompoundSectionProfile profileStart, TransformREXxyz transStart);
Class

REXSectionTypeAnalyzer_ROUND Class

Links
REXSectionTypeAnalyzer_ROUND Class, REX.ContentGenerator.Geometry Namespace, REXSectionTypeAnalyzer_ROUND Class


REXSectionTypeAnalyzer_ROUND.VectorDrivenAnalysis Method

REXSectionTypeAnalyzer_ROUND.VectorDrivenAnalysis Method
REXSectionTypeAnalyzer_ROUND Class REX.ContentGenerator.Geometry Namespace REXSectionTypeAnalyzer_ROUND Class

This is VectorDrivenAnalysis, a member of class REXSectionTypeAnalyzer_ROUND.

C#
public override bool VectorDrivenAnalysis();
Class

REXSectionTypeAnalyzer_ROUND Class

Links
REXSectionTypeAnalyzer_ROUND Class, REX.ContentGenerator.Geometry Namespace, REXSectionTypeAnalyzer_ROUND Class


REXSectionTypeAnalyzer_ROUNDH Class

REXSectionTypeAnalyzer_ROUNDH Class
REX.ContentGenerator.Geometry Namespace Legend Members REXSectionTypeAnalyzer_ROUNDH Methods

This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_ROUNDH.

Class Hierarchy
C#
public class REXSectionTypeAnalyzer_ROUNDH : REXSectionTypeAnalyzer;
Namespace

REX.ContentGenerator.Geometry Namespace

REXSectionTypeAnalyzer_ROUNDH Methods
REXSectionTypeAnalyzer_ROUNDH Methods | Description
GetParametricDescription | This is GetParametricDescription, a member of class REXSectionTypeAnalyzer_ROUNDH.
GetParametricDescription | This is GetParametricDescription, a member of class REXSectionTypeAnalyzer_ROUNDH.
VectorDrivenAnalysis | This is VectorDrivenAnalysis, a member of class REXSectionTypeAnalyzer_ROUNDH.
Links
REX.ContentGenerator.Geometry Namespace, Legend, Members, REXSectionTypeAnalyzer_ROUNDH Methods


REXSectionTypeAnalyzer_ROUNDH.GetParametricDescription Method (REXCompoundSectionProfile, REXCompoundSectionProfile, TransformREXxyz)

REXSectionTypeAnalyzer_ROUNDH.GetParametricDescription Method (REXCompoundSectionProfile, REXCompoundSectionProfile, TransformREXxyz)
REXSectionTypeAnalyzer_ROUNDH Class REX.ContentGenerator.Geometry Namespace REXSectionTypeAnalyzer_ROUNDH Class

This is GetParametricDescription, a member of class REXSectionTypeAnalyzer_ROUNDH.

C#
public override REXSectionParamDescription GetParametricDescription(REXCompoundSectionProfile profileStart, REXCompoundSectionProfile profileEnd, TransformREXxyz transStart);
Class

REXSectionTypeAnalyzer_ROUNDH Class

Links
REXSectionTypeAnalyzer_ROUNDH Class, REX.ContentGenerator.Geometry Namespace, REXSectionTypeAnalyzer_ROUNDH Class


REXSectionTypeAnalyzer_ROUNDH.GetParametricDescription Method (REXCompoundSectionProfile, TransformREXxyz)

REXSectionTypeAnalyzer_ROUNDH.GetParametricDescription Method (REXCompoundSectionProfile, TransformREXxyz)
REXSectionTypeAnalyzer_ROUNDH Class REX.ContentGenerator.Geometry Namespace REXSectionTypeAnalyzer_ROUNDH Class

This is GetParametricDescription, a member of class REXSectionTypeAnalyzer_ROUNDH.

C#
public override REXSectionParamDescription GetParametricDescription(REXCompoundSectionProfile profileStart, TransformREXxyz transStart);
Class

REXSectionTypeAnalyzer_ROUNDH Class

Links
REXSectionTypeAnalyzer_ROUNDH Class, REX.ContentGenerator.Geometry Namespace, REXSectionTypeAnalyzer_ROUNDH Class


REXSectionTypeAnalyzer_ROUNDH.VectorDrivenAnalysis Method

REXSectionTypeAnalyzer_ROUNDH.VectorDrivenAnalysis Method
REXSectionTypeAnalyzer_ROUNDH Class REX.ContentGenerator.Geometry Namespace REXSectionTypeAnalyzer_ROUNDH Class

This is VectorDrivenAnalysis, a member of class REXSectionTypeAnalyzer_ROUNDH.

C#
public override bool VectorDrivenAnalysis();
Class

REXSectionTypeAnalyzer_ROUNDH Class

Links
REXSectionTypeAnalyzer_ROUNDH Class, REX.ContentGenerator.Geometry Namespace, REXSectionTypeAnalyzer_ROUNDH Class


REXSectionTypeAnalyzer_ROUNDQ Class

REXSectionTypeAnalyzer_ROUNDQ Class
REX.ContentGenerator.Geometry Namespace Legend Members REXSectionTypeAnalyzer_ROUNDQ Methods

This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_ROUNDQ.

Class Hierarchy
C#
public class REXSectionTypeAnalyzer_ROUNDQ : REXSectionTypeAnalyzer;
Namespace

REX.ContentGenerator.Geometry Namespace

REXSectionTypeAnalyzer_ROUNDQ Methods
REXSectionTypeAnalyzer_ROUNDQ Methods | Description
GetParametricDescription | This is GetParametricDescription, a member of class REXSectionTypeAnalyzer_ROUNDQ.
GetParametricDescription | This is GetParametricDescription, a member of class REXSectionTypeAnalyzer_ROUNDQ.
VectorDrivenAnalysis | This is VectorDrivenAnalysis, a member of class REXSectionTypeAnalyzer_ROUNDQ.
Links
REX.ContentGenerator.Geometry Namespace, Legend, Members, REXSectionTypeAnalyzer_ROUNDQ Methods


REXSectionTypeAnalyzer_ROUNDQ.GetParametricDescription Method (REXCompoundSectionProfile, REXCompoundSectionProfile, TransformREXxyz)

REXSectionTypeAnalyzer_ROUNDQ.GetParametricDescription Method (REXCompoundSectionProfile, REXCompoundSectionProfile, TransformREXxyz)
REXSectionTypeAnalyzer_ROUNDQ Class REX.ContentGenerator.Geometry Namespace REXSectionTypeAnalyzer_ROUNDQ Class

This is GetParametricDescription, a member of class REXSectionTypeAnalyzer_ROUNDQ.

C#
public override REXSectionParamDescription GetParametricDescription(REXCompoundSectionProfile profileStart, REXCompoundSectionProfile profileEnd, TransformREXxyz transStart);
Class

REXSectionTypeAnalyzer_ROUNDQ Class

Links
REXSectionTypeAnalyzer_ROUNDQ Class, REX.ContentGenerator.Geometry Namespace, REXSectionTypeAnalyzer_ROUNDQ Class


REXSectionTypeAnalyzer_ROUNDQ.GetParametricDescription Method (REXCompoundSectionProfile, TransformREXxyz)

REXSectionTypeAnalyzer_ROUNDQ.GetParametricDescription Method (REXCompoundSectionProfile, TransformREXxyz)
REXSectionTypeAnalyzer_ROUNDQ Class REX.ContentGenerator.Geometry Namespace REXSectionTypeAnalyzer_ROUNDQ Class

This is GetParametricDescription, a member of class REXSectionTypeAnalyzer_ROUNDQ.

C#
public override REXSectionParamDescription GetParametricDescription(REXCompoundSectionProfile profileStart, TransformREXxyz transStart);
Class

REXSectionTypeAnalyzer_ROUNDQ Class

Links
REXSectionTypeAnalyzer_ROUNDQ Class, REX.ContentGenerator.Geometry Namespace, REXSectionTypeAnalyzer_ROUNDQ Class


REXSectionTypeAnalyzer_ROUNDQ.VectorDrivenAnalysis Method

REXSectionTypeAnalyzer_ROUNDQ.VectorDrivenAnalysis Method
REXSectionTypeAnalyzer_ROUNDQ Class REX.ContentGenerator.Geometry Namespace REXSectionTypeAnalyzer_ROUNDQ Class

This is VectorDrivenAnalysis, a member of class REXSectionTypeAnalyzer_ROUNDQ.

C#
public override bool VectorDrivenAnalysis();
Class

REXSectionTypeAnalyzer_ROUNDQ Class

Links
REXSectionTypeAnalyzer_ROUNDQ Class, REX.ContentGenerator.Geometry Namespace, REXSectionTypeAnalyzer_ROUNDQ Class


REXSectionTypeAnalyzer_T Class

REXSectionTypeAnalyzer_T Class
REX.ContentGenerator.Geometry Namespace

This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_T.

Class Hierarchy
C#
public class REXSectionTypeAnalyzer_T : REXSectionTypeAnalyzer;
Namespace

REX.ContentGenerator.Geometry Namespace

Links
REX.ContentGenerator.Geometry Namespace
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXSectionTypeAnalyzer_TASYM Class

REXSectionTypeAnalyzer_TASYM Class
REX.ContentGenerator.Geometry Namespace

This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_TASYM.

Class Hierarchy
C#
public class REXSectionTypeAnalyzer_TASYM : REXSectionTypeAnalyzer;
Namespace

REX.ContentGenerator.Geometry Namespace

Links
REX.ContentGenerator.Geometry Namespace
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXSectionTypeAnalyzer_TUBE Class

REXSectionTypeAnalyzer_TUBE Class
REX.ContentGenerator.Geometry Namespace Legend Members REXSectionTypeAnalyzer_TUBE Methods

This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_TUBE.

Class Hierarchy
C#
public class REXSectionTypeAnalyzer_TUBE : REXSectionTypeAnalyzer;
Namespace

REX.ContentGenerator.Geometry Namespace

REXSectionTypeAnalyzer_TUBE Methods
REXSectionTypeAnalyzer_TUBE Methods | Description
GetParametricDescription | This is GetParametricDescription, a member of class REXSectionTypeAnalyzer_TUBE.
GetParametricDescription | This is GetParametricDescription, a member of class REXSectionTypeAnalyzer_TUBE.
VectorDrivenAnalysis | This is VectorDrivenAnalysis, a member of class REXSectionTypeAnalyzer_TUBE.
Links
REX.ContentGenerator.Geometry Namespace, Legend, Members, REXSectionTypeAnalyzer_TUBE Methods


REXSectionTypeAnalyzer_TUBE.GetParametricDescription Method (REXCompoundSectionProfile, REXCompoundSectionProfile, TransformREXxyz)

REXSectionTypeAnalyzer_TUBE.GetParametricDescription Method (REXCompoundSectionProfile, REXCompoundSectionProfile, TransformREXxyz)
REXSectionTypeAnalyzer_TUBE Class REX.ContentGenerator.Geometry Namespace REXSectionTypeAnalyzer_TUBE Class

This is GetParametricDescription, a member of class REXSectionTypeAnalyzer_TUBE.

C#
public override REXSectionParamDescription GetParametricDescription(REXCompoundSectionProfile profileStart, REXCompoundSectionProfile profileEnd, TransformREXxyz transStart);
Class

REXSectionTypeAnalyzer_TUBE Class

Links
REXSectionTypeAnalyzer_TUBE Class, REX.ContentGenerator.Geometry Namespace, REXSectionTypeAnalyzer_TUBE Class


REXSectionTypeAnalyzer_TUBE.GetParametricDescription Method (REXCompoundSectionProfile, TransformREXxyz)

REXSectionTypeAnalyzer_TUBE.GetParametricDescription Method (REXCompoundSectionProfile, TransformREXxyz)
REXSectionTypeAnalyzer_TUBE Class REX.ContentGenerator.Geometry Namespace REXSectionTypeAnalyzer_TUBE Class

This is GetParametricDescription, a member of class REXSectionTypeAnalyzer_TUBE.

C#
public override REXSectionParamDescription GetParametricDescription(REXCompoundSectionProfile profileStart, TransformREXxyz transStart);
Class

REXSectionTypeAnalyzer_TUBE Class

Links
REXSectionTypeAnalyzer_TUBE Class, REX.ContentGenerator.Geometry Namespace, REXSectionTypeAnalyzer_TUBE Class


REXSectionTypeAnalyzer_TUBE.VectorDrivenAnalysis Method

REXSectionTypeAnalyzer_TUBE.VectorDrivenAnalysis Method
REXSectionTypeAnalyzer_TUBE Class REX.ContentGenerator.Geometry Namespace REXSectionTypeAnalyzer_TUBE Class

This is VectorDrivenAnalysis, a member of class REXSectionTypeAnalyzer_TUBE.

C#
public override bool VectorDrivenAnalysis();
Class

REXSectionTypeAnalyzer_TUBE Class

Links
REXSectionTypeAnalyzer_TUBE Class, REX.ContentGenerator.Geometry Namespace, REXSectionTypeAnalyzer_TUBE Class


REXSectionTypeAnalyzer_Z Class

REXSectionTypeAnalyzer_Z Class
REX.ContentGenerator.Geometry Namespace

This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_Z.

Class Hierarchy
C#
public class REXSectionTypeAnalyzer_Z : REXSectionTypeAnalyzer;
Namespace

REX.ContentGenerator.Geometry Namespace

Links
REX.ContentGenerator.Geometry Namespace
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REX.ContentGenerator.Geometry.EArcDir Enumeration

REX.ContentGenerator.Geometry.EArcDir Enumeration
REX.ContentGenerator.Geometry Namespace

Describes the direction of an arc.

C#
public enum EArcDir {
  CCW,
  CW
}
Members
Members | Description
CCW | Counterclockwise.
CW | Clockwise.
Description
Namespace

REX.ContentGenerator.Geometry Namespace

Links
REX.ContentGenerator.Geometry Namespace
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REX.ContentGenerator.Geometry.EContElemType Enumeration

REX.ContentGenerator.Geometry.EContElemType Enumeration
REX.ContentGenerator.Geometry Namespace

Represents the type of the element.

C#
public enum EContElemType {
  contour,
  line,
  arc,
  circle
}
Members
Members | Description
contour | Contour.
line | Line.
arc | Arc defined by start, middle point and end.
circle | Circle.
Description
Namespace

REX.ContentGenerator.Geometry Namespace

Links
REX.ContentGenerator.Geometry Namespace
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REX.ContentGenerator.Geometry.ECoords Enumeration

REX.ContentGenerator.Geometry.ECoords Enumeration
REX.ContentGenerator.Geometry Namespace

Describes the coordinate system type.

C#
public enum ECoords {
  XY,
  XZ,
  YZ,
  XYZ,
  USER
}
Members
Members | Description
XY | XY plane.
XZ | XZ plane.
YZ | YZ plane.
XYZ | 3D space.
USER | User.
Description
Namespace

REX.ContentGenerator.Geometry Namespace

Links
REX.ContentGenerator.Geometry Namespace
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REX.ContentGenerator.Map Namespace

Previous | Next
REX.ContentGenerator.Map Namespace
Legend Classes

This is namespace REX.ContentGenerator.Map.

Classes
Class | Description
ContentMapper | Provides interface to the mapping system of the ContentGenerator.
REXContentMapCategorySettings | Represents settings for a specific category of elements.
REXContentMapDialogSettings | Represents settings for the map dialog.
REXContentMapper | Provides interface to the mapping system of the Content Generator in REX context.
RVTContentMapper | Provides interface to the mapping system of the Content Generator in Revit context.
Links
Legend, Classes
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


ContentMapper Class

ContentMapper Class
REX.ContentGenerator.Map Namespace Legend Members ContentMapper Methods ContentMapper Properties

Provides interface to the mapping system of the ContentGenerator.

Class Hierarchy
C#
public abstract class ContentMapper;
Description
Namespace

REX.ContentGenerator.Map Namespace

ContentMapper Methods
ContentMapper Methods | Description
AddLabel | Adds the label to the list.
ApplyMapControl | Applies the map control.
CloseMapControl | Closes the map control.
CreateMapControl | Creates the map control.
GetLabels | Gets the labels.
LaunchMapDialog | Launches the map dialog.
LoadUserMap | Loads the user map to the Content Generator.
RefreshMapControl | Refreshes the map control.
ReloadGlobalMap | Reloads the global map.
ResetUserMap | Resets the user map.
SaveGlobalMap | Saves the global map.
SaveUserMap | Saves the user map.
SetDefaults | Sets defaults in the mapping system.
SetREXConverter | Sets the REX converter.
ContentMapper Properties
ContentMapper Properties | Description
DialogSettings | Gets the dialog's settings.
Links
REX.ContentGenerator.Map Namespace, Legend, Members, ContentMapper Methods, ContentMapper Properties


ContentMapper.AddLabel Method

ContentMapper.AddLabel Method
ContentMapper Class REX.ContentGenerator.Map Namespace Example ContentMapper Class

Adds the label to the list.

C#
public void AddLabel(REXFamilyType_Label fam);
Parameters
Parameters | Description
fam | The label.
Description
Example

The example shows how to use labels in a mapping system.

//Revit converter
RVTFamilyConverter rvt = new RVTFamilyConverter(ThisExtension.Revit.CommandData(), true);
rvt.Settings.Labels = true;

//-example label without description
REXFamilyType_Label label1 = new REXFamilyType_Label(ECategoryType.SECTION_DB, "test1");

//-example label with section defined manually
REXFamilyType_Label label2 = new REXFamilyType_Label(ECategoryType.SECTION_DB, "test2");
REXFamilyType_ParamSection paramSection = new REXFamilyType_ParamSection();
paramSection.Material = EMaterial.CONCRETE;
paramSection.ElementType = REX.ContentGenerator.Families.EElementType.BEAM;
paramSection.Parameters.SectionType = ESectionType.RECT;
paramSection.Parameters.Dimensions.b = 1;
paramSection.Parameters.Dimensions.h = 1;
label2.Parameters.LabelFamilyDescription = paramSection;

//-definition of category
rvt.ContentMapper.DialogSettings.SectionSettings.LabelCategoryName = "MyCategory";

//-adding labels to list
rvt.ContentMapper.DialogSettings.SectionSettings.Labels.Add(label1);
rvt.ContentMapper.DialogSettings.SectionSettings.Labels.Add(label2);

//Map dialog.
Autodesk.Revit.DB.FilteredElementCollector collector = new FilteredElementCollector(ThisExtension.Revit.ActiveDocument);
List<Element> Sections = new List<Element>();
//Sections.
rvt.ContentMapper.DialogSettings.SectionSettings.Visible = true;
//-adding elements
foreach (FamilySymbol obj in collector.OfClass(typeof(FamilySymbol)).ToElements())
{
    if(((BuiltInCategory)obj.Category.Id.IntegerValue) == BuiltInCategory.OST_StructuralFraming)
        rvt.ContentMapper.DialogSettings.SectionSettings.Elements.Add(obj);
}
if (rvt.ContentMapper.DialogSettings.SectionSettings.Elements.Count > 1)
{
    rvt.ContentMapper.SetMapElement(true, (Element)rvt.ContentMapper.DialogSettings.SectionSettings.Elements[0], label1, ECategoryType.SECTION_DB);
    rvt.ContentMapper.SetMapElement(true, (Element)rvt.ContentMapper.DialogSettings.SectionSettings.Elements[1], label2, ECategoryType.SECTION_DB);
}
//-databases start list
rvt.ContentMapper.DialogSettings.SectionSettings.Databases.Add("Rcatpro");

//Materials.
rvt.ContentMapper.DialogSettings.MaterialSettings.Visible = false;

//Rebars.
rvt.ContentMapper.DialogSettings.RebarTypeSettings.Visible = false;

//Launching
Autodesk.REX.Common.REXContext cont = ThisExtension.Context;
bool ok = rvt.ContentMapper.LaunchMapDialog(ref cont);

if (ok)
{
        REXFamilyType sect = rvt.ContentMapper.GetMapElement(Sections[0],ECategoryType.SECTION_DB);
}
Class

ContentMapper Class

Links
ContentMapper Class, REX.ContentGenerator.Map Namespace, Example, ContentMapper Class


ContentMapper.ApplyMapControl Method

ContentMapper.ApplyMapControl Method
ContentMapper Class REX.ContentGenerator.Map Namespace ContentMapper Class

Applies the map control.

C#
public void ApplyMapControl();
Description
Class

ContentMapper Class

Links
ContentMapper Class, REX.ContentGenerator.Map Namespace, ContentMapper Class


ContentMapper.CloseMapControl Method

ContentMapper.CloseMapControl Method
ContentMapper Class REX.ContentGenerator.Map Namespace ContentMapper Class

Closes the map control.

C#
public void CloseMapControl();
Description
Class

ContentMapper Class

Links
ContentMapper Class, REX.ContentGenerator.Map Namespace, ContentMapper Class


ContentMapper.CreateMapControl Method

ContentMapper.CreateMapControl Method
ContentMapper Class REX.ContentGenerator.Map Namespace Example ContentMapper Class

Creates the map control.

C#
public object CreateMapControl(ref Autodesk.REX.Framework.REXContext context);
Parameters
Parameters | Description
context | The context.
Returns

Returns the control.

Description
Example

The example shows how to customize and launch the map dialog.

//Revit converter.
RVTFamilyConverter rvt = new RVTFamilyConverter(ThisExtension.Revit.CommandData(), true);

Autodesk.Revit.DB.FilteredElementCollector collector = new FilteredElementCollector(ThisExtension.Revit.ActiveDocument);

List<Element> Sections = new List<Element>();

//General settings.
rvt.ContentMapper.DialogSettings.CheckIfAllMappedBeforeLeave = false;
rvt.ContentMapper.DialogSettings.Menu = false;
rvt.ContentMapper.DialogSettings.List = false;
rvt.ContentMapper.DialogSettings.ShowWhenNoElementsToMap = true;

//Sections.
rvt.ContentMapper.DialogSettings.SectionSettings.Visible = true;
//-adding elements
foreach (FamilySymbol obj in collector.OfClass(typeof(FamilySymbol)).ToElements())
{
    rvt.ContentMapper.DialogSettings.SectionSettings.Elements.Add(obj);
    Sections.Add(obj);
}
//-databases start list
rvt.ContentMapper.DialogSettings.SectionSettings.Databases.Add("Rcatpro");

//Launching.
Autodesk.REX.Common.REXContext cont = ThisExtension.Context;
object ctr = rvt.ContentMapper.CreateMapControl(ref cont);
Class

ContentMapper Class

Links
ContentMapper Class, REX.ContentGenerator.Map Namespace, Example, ContentMapper Class


ContentMapper.GetLabels Method

ContentMapper.GetLabels Method
ContentMapper Class REX.ContentGenerator.Map Namespace ContentMapper Class

Gets the labels.

C#
public List<REXFamilyType_Label> GetLabels(ECategoryType cat);
Parameters
Parameters | Description
cat | The category of element.
Returns

The list of defined labels.

Description
Class

ContentMapper Class

Links
ContentMapper Class, REX.ContentGenerator.Map Namespace, ContentMapper Class


ContentMapper.LaunchMapDialog Method

ContentMapper.LaunchMapDialog Method
ContentMapper Class REX.ContentGenerator.Map Namespace Example ContentMapper Class

Launches the map dialog.

C#
public bool LaunchMapDialog(ref Autodesk.REX.Framework.REXContext context);
Parameters
Parameters | Description
context | The context.
Returns

If launching succeed or if changes were accepted by user.

Description
Example

The example shows how to customize and launch the map dialog.

//Revit converter.
RVTFamilyConverter rvt = new RVTFamilyConverter(ThisExtension.Revit.CommandData(), true);

Autodesk.Revit.DB.FilteredElementCollector collector = new FilteredElementCollector(ThisExtension.Revit.ActiveDocument);

List<Element> Sections = new List<Element>();
List<Element> Rebars = new List<Element>();

//General settings.
rvt.ContentMapper.DialogSettings.CheckIfAllMappedBeforeLeave = true;
rvt.ContentMapper.DialogSettings.NotAllMappedText = "Not all elements are mapped";

//Sections.
rvt.ContentMapper.DialogSettings.SectionSettings.Visible = true;
//-adding elements
foreach (FamilySymbol obj in collector.OfClass(typeof(FamilySymbol)).ToElements())
{
    rvt.ContentMapper.DialogSettings.SectionSettings.Elements.Add(obj);
    Sections.Add(obj);
}
//-databases start list
rvt.ContentMapper.DialogSettings.SectionSettings.Databases.Add("Rcatpro");

//Materials.
rvt.ContentMapper.DialogSettings.MaterialSettings.Visible = false;

//Rebars.
rvt.ContentMapper.DialogSettings.RebarTypeSettings.Visible = true;
//-user won't be able to add databases
rvt.ContentMapper.DialogSettings.RebarTypeSettings.AllowToAddDatabases = false;
//-if there will be find the map element with some database assigned this database won't be loaded to Content dialog automatically
rvt.ContentMapper.DialogSettings.RebarTypeSettings.AddMappedDatabases = false;
//-adding elements
foreach (RebarBarType obj in collector.OfClass(typeof(RebarBarType)).ToElements())
{
     rvt.ContentMapper.DialogSettings.SectionSettings.Elements.Add(obj);
     Rebars.Add(obj);
}
//-database list
rvt.ContentMapper.DialogSettings.RebarTypeSettings.Databases.Add("bar_BAEL M");
//-available steels
rvt.ContentMapper.DialogSettings.RebarTypeSettings.SteelsAvailable.Add("HA 400");
//-if defaults should be set
rvt.ContentMapper.DialogSettings.RebarTypeSettings.SetDefaultsForUnknown = true;

//-if certified elements should be mapped
rvt.ContentMapper.DialogSettings.RebarTypeSettings.MapCertifiedFamilies = true;
//-setting default elements for rebartype
rvt.ContentMapper.SetDefaults(ThisExtension.Preferences.PreferencesBase2.RegionalSettings, ECategoryType.REBAR_BARTYPE);

//Launching.
Autodesk.REX.Common.REXContext cont = ThisExtension.Context;
bool ok = rvt.ContentMapper.LaunchMapDialog(ref cont);

if (ok)
{
    //Getting mapped element
    REXFamilyType sect = rvt.ContentMapper.GetMapElement(Sections[0],ECategoryType.SECTION_DB);
}
Class

ContentMapper Class

Links
ContentMapper Class, REX.ContentGenerator.Map Namespace, Example, ContentMapper Class


ContentMapper.LoadUserMap Method

ContentMapper.LoadUserMap Method
ContentMapper Class REX.ContentGenerator.Map Namespace ContentMapper Class

Loads the user map to the Content Generator.

C#
public void LoadUserMap(string path);
Parameters
Parameters | Description
path | The path.
Description
Class

ContentMapper Class

Links
ContentMapper Class, REX.ContentGenerator.Map Namespace, ContentMapper Class


ContentMapper.RefreshMapControl Method

ContentMapper.RefreshMapControl Method
ContentMapper Class REX.ContentGenerator.Map Namespace ContentMapper Class

Refreshes the map control.

C#
public void RefreshMapControl();
Description
Class

ContentMapper Class

Links
ContentMapper Class, REX.ContentGenerator.Map Namespace, ContentMapper Class


ContentMapper.ReloadGlobalMap Method

ContentMapper.ReloadGlobalMap Method
ContentMapper Class REX.ContentGenerator.Map Namespace ContentMapper Class

Reloads the global map.

C#
public void ReloadGlobalMap();
Description
Class

ContentMapper Class

Links
ContentMapper Class, REX.ContentGenerator.Map Namespace, ContentMapper Class


ContentMapper.ResetUserMap Method

ContentMapper.ResetUserMap Method
ContentMapper Class REX.ContentGenerator.Map Namespace ContentMapper Class

Resets the user map.

C#
public void ResetUserMap();
Description
Class

ContentMapper Class

Links
ContentMapper Class, REX.ContentGenerator.Map Namespace, ContentMapper Class


ContentMapper.SaveGlobalMap Method

ContentMapper.SaveGlobalMap Method
ContentMapper Class REX.ContentGenerator.Map Namespace ContentMapper Class

Saves the global map.

C#
public void SaveGlobalMap();
Description
Class

ContentMapper Class

Links
ContentMapper Class, REX.ContentGenerator.Map Namespace, ContentMapper Class


ContentMapper.SaveUserMap Method

ContentMapper.SaveUserMap Method
ContentMapper Class REX.ContentGenerator.Map Namespace ContentMapper Class

Saves the user map.

C#
public void SaveUserMap(string path);
Parameters
Parameters | Description
path | The path.
Description
Class

ContentMapper Class

Links
ContentMapper Class, REX.ContentGenerator.Map Namespace, ContentMapper Class


ContentMapper.SetDefaults Method

ContentMapper.SetDefaults Method
ContentMapper Class REX.ContentGenerator.Map Namespace ContentMapper Class

Sets defaults in the mapping system.

C#
public void SetDefaults(Autodesk.REX.Framework.IREXRegionalSettings regionalSettings, ECategoryType type);
Parameters
Parameters | Description
regionalSettings | Regional settings.
type | The type.
Description
Class

ContentMapper Class

Links
ContentMapper Class, REX.ContentGenerator.Map Namespace, ContentMapper Class


ContentMapper.SetREXConverter Method

ContentMapper.SetREXConverter Method
ContentMapper Class REX.ContentGenerator.Map Namespace ContentMapper Class

Sets the REX converter.

C#
public void SetREXConverter(REXFamilyConverter converter);
Parameters
Parameters | Description
converter | The converter.
Description
Remarks

If there is already defined converter it can be passed to the map object. Otherwise Content Generator will create its own instance of the REXFamilyConverter class.

Class

ContentMapper Class

Links
ContentMapper Class, REX.ContentGenerator.Map Namespace, ContentMapper Class


ContentMapper.DialogSettings Property

ContentMapper.DialogSettings Property
ContentMapper Class REX.ContentGenerator.Map Namespace ContentMapper Class

Gets the dialog's settings.

C#
public REXContentMapDialogSettings DialogSettings;
Description

The dialog's settings.

Class

ContentMapper Class

Links
ContentMapper Class, REX.ContentGenerator.Map Namespace, ContentMapper Class


REXContentMapCategorySettings Class

REXContentMapCategorySettings Class
REX.ContentGenerator.Map Namespace Legend Members Public Methods REXContentMapCategorySettings Methods REXContentMapCategorySettings Properties

Represents settings for a specific category of elements.

Class Hierarchy
C#
public class REXContentMapCategorySettings;
Description
Namespace

REX.ContentGenerator.Map Namespace

Public Methods
Public Method | Description
REXContentMapCategorySettings | Initializes a new instance of the REXContentMapCategorySettings class.
REXContentMapCategorySettings Methods
REXContentMapCategorySettings Methods | Description
ContainsLabel | Determines whether the mapping system contains the specified label.
FilterFamilies | Filters the list of families.
FilterFamily | Filters the family object according settings.
REXContentMapCategorySettings Properties
REXContentMapCategorySettings Properties | Description
AddMappedDatabases | Gets or sets a value indicating whether databases saved in loaded files should be loaded to the system.
AllowToAddDatabases | Gets or sets a value indicating whether a user is able to add databases to the list.
Category | Gets the category.
Databases | Gets or sets the list of databases supported by this category.
DatabasesResult | Gets or sets the list of databases which were finally choosen by the user in the dialog.
Elements | Gets the list of elements which should be mapped.
LabelCategoryName | Gets or sets the name of the label category.
Labels | Gets the list of labels.
MapCertifiedFamilies | Gets or sets a value indicating whether certified families are mapped.
SetDefaultsForUnknown | Gets or sets a value indicating whether defaults are set for elements which weren't mapped.
Settings | Gets the settings of the dialog.
Visible | Gets or sets a value indicating whether this category is visible.
Links
REX.ContentGenerator.Map Namespace, Legend, Members, Public Methods, REXContentMapCategorySettings Methods, REXContentMapCategorySettings Properties


REXContentMapCategorySettings.REXContentMapCategorySettings Constructor

REXContentMapCategorySettings.REXContentMapCategorySettings Constructor
REXContentMapCategorySettings Class REX.ContentGenerator.Map Namespace REXContentMapCategorySettings Class

Initializes a new instance of the REXContentMapCategorySettings class.

C#
public REXContentMapCategorySettings(ECategoryType category, REXContentMapDialogSettings settings);
Parameters
Parameters | Description
category | The category.
settings | Settings.
Description
Class

REXContentMapCategorySettings Class

Links
REXContentMapCategorySettings Class, REX.ContentGenerator.Map Namespace, REXContentMapCategorySettings Class


REXContentMapCategorySettings.ContainsLabel Method

REXContentMapCategorySettings.ContainsLabel Method
REXContentMapCategorySettings Class REX.ContentGenerator.Map Namespace REXContentMapCategorySettings Class

Determines whether the mapping system contains the specified label.

C#
public virtual bool ContainsLabel(REXFamilyType_Label label);
Parameters
Parameters | Description
label | The label.
Returns

Whether specific label is already defined in the Content Generator.

Description
Class

REXContentMapCategorySettings Class

Links
REXContentMapCategorySettings Class, REX.ContentGenerator.Map Namespace, REXContentMapCategorySettings Class


REXContentMapCategorySettings.FilterFamilies Method

REXContentMapCategorySettings.FilterFamilies Method
REXContentMapCategorySettings Class REX.ContentGenerator.Map Namespace REXContentMapCategorySettings Class

Filters the list of families.

C#
public virtual List<REXFamilyType> FilterFamilies(List<REXFamilyType> families);
Parameters
Parameters | Description
families | The input list.
Returns

The filtered family list.

Description
Class

REXContentMapCategorySettings Class

Links
REXContentMapCategorySettings Class, REX.ContentGenerator.Map Namespace, REXContentMapCategorySettings Class


REXContentMapCategorySettings.FilterFamily Method

REXContentMapCategorySettings.FilterFamily Method
REXContentMapCategorySettings Class REX.ContentGenerator.Map Namespace REXContentMapCategorySettings Class

Filters the family object according settings.

C#
public virtual bool FilterFamily(REXFamilyType family);
Parameters
Parameters | Description
family | The family object.
Description
Class

REXContentMapCategorySettings Class

Links
REXContentMapCategorySettings Class, REX.ContentGenerator.Map Namespace, REXContentMapCategorySettings Class


REXContentMapCategorySettings.AddMappedDatabases Property

REXContentMapCategorySettings.AddMappedDatabases Property
REXContentMapCategorySettings Class REX.ContentGenerator.Map Namespace REXContentMapCategorySettings Class

Gets or sets a value indicating whether databases saved in loaded files should be loaded to the system.

C#
public bool AddMappedDatabases;
Description

True if databases loaded from files are visible; otherwise, false.

Class

REXContentMapCategorySettings Class

Links
REXContentMapCategorySettings Class, REX.ContentGenerator.Map Namespace, REXContentMapCategorySettings Class


REXContentMapCategorySettings.AllowToAddDatabases Property

REXContentMapCategorySettings.AllowToAddDatabases Property
REXContentMapCategorySettings Class REX.ContentGenerator.Map Namespace REXContentMapCategorySettings Class

Gets or sets a value indicating whether a user is able to add databases to the list.

C#
public bool AllowToAddDatabases;
Description

True if a user is able to add databases; otherwise, false.

Class

REXContentMapCategorySettings Class

Links
REXContentMapCategorySettings Class, REX.ContentGenerator.Map Namespace, REXContentMapCategorySettings Class


REXContentMapCategorySettings.Category Property

REXContentMapCategorySettings.Category Property
REXContentMapCategorySettings Class REX.ContentGenerator.Map Namespace REXContentMapCategorySettings Class

Gets the category.

C#
public ECategoryType Category;
Description

The category.

Class

REXContentMapCategorySettings Class

Links
REXContentMapCategorySettings Class, REX.ContentGenerator.Map Namespace, REXContentMapCategorySettings Class


REXContentMapCategorySettings.Databases Property

REXContentMapCategorySettings.Databases Property
REXContentMapCategorySettings Class REX.ContentGenerator.Map Namespace REXContentMapCategorySettings Class

Gets or sets the list of databases supported by this category.

C#
public List<string> Databases;
Description

The list of databases.

Remarks

If the list is empty all databases will be supported.

Class

REXContentMapCategorySettings Class

Links
REXContentMapCategorySettings Class, REX.ContentGenerator.Map Namespace, REXContentMapCategorySettings Class


REXContentMapCategorySettings.DatabasesResult Property

REXContentMapCategorySettings.DatabasesResult Property
REXContentMapCategorySettings Class REX.ContentGenerator.Map Namespace REXContentMapCategorySettings Class

Gets or sets the list of databases which were finally choosen by the user in the dialog.

C#
public List<string> DatabasesResult;
Description

The list of databases.

Class

REXContentMapCategorySettings Class

Links
REXContentMapCategorySettings Class, REX.ContentGenerator.Map Namespace, REXContentMapCategorySettings Class


REXContentMapCategorySettings.Elements Property

REXContentMapCategorySettings.Elements Property
REXContentMapCategorySettings Class REX.ContentGenerator.Map Namespace REXContentMapCategorySettings Class

Gets the list of elements which should be mapped.

C#
public List<object> Elements;
Description

The list of elements.

Class

REXContentMapCategorySettings Class

Links
REXContentMapCategorySettings Class, REX.ContentGenerator.Map Namespace, REXContentMapCategorySettings Class


REXContentMapCategorySettings.LabelCategoryName Property

REXContentMapCategorySettings.LabelCategoryName Property
REXContentMapCategorySettings Class REX.ContentGenerator.Map Namespace REXContentMapCategorySettings Class

Gets or sets the name of the label category.

C#
public string LabelCategoryName;
Description

The name of the label category.

Class

REXContentMapCategorySettings Class

Links
REXContentMapCategorySettings Class, REX.ContentGenerator.Map Namespace, REXContentMapCategorySettings Class


REXContentMapCategorySettings.Labels Property

REXContentMapCategorySettings.Labels Property
REXContentMapCategorySettings Class REX.ContentGenerator.Map Namespace REXContentMapCategorySettings Class

Gets the list of labels.

C#
public List<REXFamilyType_Label> Labels;
Description

The list of labels.

Class

REXContentMapCategorySettings Class

Links
REXContentMapCategorySettings Class, REX.ContentGenerator.Map Namespace, REXContentMapCategorySettings Class


REXContentMapCategorySettings.MapCertifiedFamilies Property

REXContentMapCategorySettings.MapCertifiedFamilies Property
REXContentMapCategorySettings Class REX.ContentGenerator.Map Namespace REXContentMapCategorySettings Class

Gets or sets a value indicating whether certified families are mapped.

C#
public bool MapCertifiedFamilies;
Description

True if certified families are mapped; otherwise, false.

Class

REXContentMapCategorySettings Class

Links
REXContentMapCategorySettings Class, REX.ContentGenerator.Map Namespace, REXContentMapCategorySettings Class


REXContentMapCategorySettings.SetDefaultsForUnknown Property

REXContentMapCategorySettings.SetDefaultsForUnknown Property
REXContentMapCategorySettings Class REX.ContentGenerator.Map Namespace REXContentMapCategorySettings Class

Gets or sets a value indicating whether defaults are set for elements which weren't mapped.

C#
public bool SetDefaultsForUnknown;
Description

True if unknown elements are mapped automatically; otherwise, false.

Class

REXContentMapCategorySettings Class

Links
REXContentMapCategorySettings Class, REX.ContentGenerator.Map Namespace, REXContentMapCategorySettings Class


REXContentMapCategorySettings.Settings Property

REXContentMapCategorySettings.Settings Property
REXContentMapCategorySettings Class REX.ContentGenerator.Map Namespace REXContentMapCategorySettings Class

Gets the settings of the dialog.

C#
public REXContentMapDialogSettings Settings;
Description

Settings.

Class

REXContentMapCategorySettings Class

Links
REXContentMapCategorySettings Class, REX.ContentGenerator.Map Namespace, REXContentMapCategorySettings Class


REXContentMapCategorySettings.Visible Property

REXContentMapCategorySettings.Visible Property
REXContentMapCategorySettings Class REX.ContentGenerator.Map Namespace REXContentMapCategorySettings Class

Gets or sets a value indicating whether this category is visible.

C#
public bool Visible;
Description

True if the category is visible; otherwise, false.

Class

REXContentMapCategorySettings Class

Links
REXContentMapCategorySettings Class, REX.ContentGenerator.Map Namespace, REXContentMapCategorySettings Class


REXContentMapDialogSettings Class

REXContentMapDialogSettings Class
REX.ContentGenerator.Map Namespace Legend Members Public Methods REXContentMapDialogSettings Methods REXContentMapDialogSettings Properties

Represents settings for the map dialog.

Class Hierarchy
C#
public class REXContentMapDialogSettings;
Description
Namespace

REX.ContentGenerator.Map Namespace

Public Methods
Public Method | Description
REXContentMapDialogSettings | Initializes a new instance of the REXContentMapDialogSettings class.
REXContentMapDialogSettings Methods
REXContentMapDialogSettings Methods | Description
GetSettings | Gets settings of the specific type.
REXContentMapDialogSettings Properties
REXContentMapDialogSettings Properties | Description
CheckIfAllMappedBeforeLeave | Gets or sets a value indicating whether dialog should be validated before leaving.
List | Gets or sets a value indicating whether the list should be visible on the dialog.
Mapper | Gets the mapper.
MaterialSettings | Gets the material settings.
Menu | Gets or sets a value indicating whether menu should be visible on the dialog.
NotAllMappedText | Gets or sets the text which should appear when validation didn't succeed (if CheckIfAllMappedBeforeLeave option).
RebarTypeSettings | Gets the rebar type settings.
SectionSettings | Gets the section settings.
ShowWhenNoElementsToMap | Gets or sets a value indicating whether dialog should appear when there are no elements to map.
Links
REX.ContentGenerator.Map Namespace, Legend, Members, Public Methods, REXContentMapDialogSettings Methods, REXContentMapDialogSettings Properties


REXContentMapDialogSettings.REXContentMapDialogSettings Constructor

REXContentMapDialogSettings.REXContentMapDialogSettings Constructor
REXContentMapDialogSettings Class REX.ContentGenerator.Map Namespace REXContentMapDialogSettings Class

Initializes a new instance of the REXContentMapDialogSettings class.

C#
public REXContentMapDialogSettings(ContentMapper mapper);
Parameters
Parameters | Description
mapper | The mapper.
Description
Class

REXContentMapDialogSettings Class

Links
REXContentMapDialogSettings Class, REX.ContentGenerator.Map Namespace, REXContentMapDialogSettings Class


REXContentMapDialogSettings.GetSettings Method

REXContentMapDialogSettings.GetSettings Method
REXContentMapDialogSettings Class REX.ContentGenerator.Map Namespace REXContentMapDialogSettings Class

Gets settings of the specific type.

C#
public REXContentMapCategorySettings GetSettings(ECategoryType category);
Parameters
Parameters | Description
category | The category.
Returns

The settings.

Description
Class

REXContentMapDialogSettings Class

Links
REXContentMapDialogSettings Class, REX.ContentGenerator.Map Namespace, REXContentMapDialogSettings Class


REXContentMapDialogSettings.CheckIfAllMappedBeforeLeave Property

REXContentMapDialogSettings.CheckIfAllMappedBeforeLeave Property
REXContentMapDialogSettings Class REX.ContentGenerator.Map Namespace REXContentMapDialogSettings Class

Gets or sets a value indicating whether dialog should be validated before leaving.

C#
public bool CheckIfAllMappedBeforeLeave;
Description

True if the dialog is validated when before leaving; otherwise, false.

Class

REXContentMapDialogSettings Class

Links
REXContentMapDialogSettings Class, REX.ContentGenerator.Map Namespace, REXContentMapDialogSettings Class


REXContentMapDialogSettings.List Property

REXContentMapDialogSettings.List Property
REXContentMapDialogSettings Class REX.ContentGenerator.Map Namespace REXContentMapDialogSettings Class

Gets or sets a value indicating whether the list should be visible on the dialog.

C#
public bool List;
Description

True if the list is visible; otherwise, false.

Class

REXContentMapDialogSettings Class

Links
REXContentMapDialogSettings Class, REX.ContentGenerator.Map Namespace, REXContentMapDialogSettings Class


REXContentMapDialogSettings.Mapper Property

REXContentMapDialogSettings.Mapper Property
REXContentMapDialogSettings Class REX.ContentGenerator.Map Namespace REXContentMapDialogSettings Class

Gets the mapper.

C#
public ContentMapper Mapper;
Description

The mapper.

Class

REXContentMapDialogSettings Class

Links
REXContentMapDialogSettings Class, REX.ContentGenerator.Map Namespace, REXContentMapDialogSettings Class


REXContentMapDialogSettings.MaterialSettings Property

REXContentMapDialogSettings.MaterialSettings Property
REXContentMapDialogSettings Class REX.ContentGenerator.Map Namespace REXContentMapDialogSettings Class

Gets the material settings.

C#
public REXContentMapCategorySettings MaterialSettings;
Description

The material settings.

Class

REXContentMapDialogSettings Class

Links
REXContentMapDialogSettings Class, REX.ContentGenerator.Map Namespace, REXContentMapDialogSettings Class


REXContentMapDialogSettings.Menu Property

REXContentMapDialogSettings.Menu Property
REXContentMapDialogSettings Class REX.ContentGenerator.Map Namespace REXContentMapDialogSettings Class

Gets or sets a value indicating whether menu should be visible on the dialog.

C#
public bool Menu;
Description

True if menu is visible; otherwise, false.

Class

REXContentMapDialogSettings Class

Links
REXContentMapDialogSettings Class, REX.ContentGenerator.Map Namespace, REXContentMapDialogSettings Class


REXContentMapDialogSettings.NotAllMappedText Property

REXContentMapDialogSettings.NotAllMappedText Property
REXContentMapDialogSettings Class REX.ContentGenerator.Map Namespace REXContentMapDialogSettings Class

Gets or sets the text which should appear when validation didn't succeed (if CheckIfAllMappedBeforeLeave option).

C#
public string NotAllMappedText;
Description

The text.

Class

REXContentMapDialogSettings Class

Links
REXContentMapDialogSettings Class, REX.ContentGenerator.Map Namespace, REXContentMapDialogSettings Class


REXContentMapDialogSettings.RebarTypeSettings Property

REXContentMapDialogSettings.RebarTypeSettings Property
REXContentMapDialogSettings Class REX.ContentGenerator.Map Namespace REXContentMapDialogSettings Class

Gets the rebar type settings.

C#
public REXContentMapCategorySettingsRebarType RebarTypeSettings;
Description

The rebar type settings.

Class

REXContentMapDialogSettings Class

Links
REXContentMapDialogSettings Class, REX.ContentGenerator.Map Namespace, REXContentMapDialogSettings Class


REXContentMapDialogSettings.SectionSettings Property

REXContentMapDialogSettings.SectionSettings Property
REXContentMapDialogSettings Class REX.ContentGenerator.Map Namespace REXContentMapDialogSettings Class

Gets the section settings.

C#
public REXContentMapCategorySettings SectionSettings;
Description

The section settings.

Class

REXContentMapDialogSettings Class

Links
REXContentMapDialogSettings Class, REX.ContentGenerator.Map Namespace, REXContentMapDialogSettings Class


REXContentMapDialogSettings.ShowWhenNoElementsToMap Property

REXContentMapDialogSettings.ShowWhenNoElementsToMap Property
REXContentMapDialogSettings Class REX.ContentGenerator.Map Namespace REXContentMapDialogSettings Class

Gets or sets a value indicating whether dialog should appear when there are no elements to map.

C#
public bool ShowWhenNoElementsToMap;
Description

True if the dialog is shown when there is no elements to map; otherwise, false.

Class

REXContentMapDialogSettings Class

Links
REXContentMapDialogSettings Class, REX.ContentGenerator.Map Namespace, REXContentMapDialogSettings Class


REXContentMapper Class

REXContentMapper Class
REX.ContentGenerator.Map Namespace Legend Members REXContentMapper Fields REXContentMapper Methods

Provides interface to the mapping system of the Content Generator in REX context.

Class Hierarchy
C#
public class REXContentMapper : ContentMapper;
Description
Namespace

REX.ContentGenerator.Map Namespace

REXContentMapper Fields
REXContentMapper Fields | Description
valRexContext | This is valRexContext, a member of class REXContentMapper.
REXContentMapper Methods
REXContentMapper Methods | Description
GetMapElement | Gets the map element for the specified element.
SetMapElement | Sets the map element for specified element.
Links
REX.ContentGenerator.Map Namespace, Legend, Members, REXContentMapper Fields, REXContentMapper Methods


REXContentMapper.valRexContext Field

REXContentMapper.valRexContext Field
REXContentMapper Class REX.ContentGenerator.Map Namespace REXContentMapper Class

This is valRexContext, a member of class REXContentMapper.

C#
public const string valRexContext = "REX";
Class

REXContentMapper Class

Links
REXContentMapper Class, REX.ContentGenerator.Map Namespace, REXContentMapper Class


REXContentMapper.GetMapElement Method

REXContentMapper.GetMapElement Method
REXContentMapper Class REX.ContentGenerator.Map Namespace REXContentMapper Class

Gets the map element for the specified element.

C#
public REXFamilyType GetMapElement(REXFamilyType elem, ECategoryType type);
Parameters
Parameters | Description
elem | The element.
type | The type of the element.
Returns

The mapped REXFamilyType object.

Description
Class

REXContentMapper Class

Links
REXContentMapper Class, REX.ContentGenerator.Map Namespace, REXContentMapper Class


REXContentMapper.SetMapElement Method

REXContentMapper.SetMapElement Method
REXContentMapper Class REX.ContentGenerator.Map Namespace REXContentMapper Class

Sets the map element for specified element.

C#
public void SetMapElement(bool user, REXFamilyType elem, REXFamilyType fam, ECategoryType type);
Parameters
Parameters | Description
user | Indicates whether the user map should be used.
elem | The element.
fam | The mapped REXFamilyType object.
type | The type of the element.
Description
Class

REXContentMapper Class

Links
REXContentMapper Class, REX.ContentGenerator.Map Namespace, REXContentMapper Class


RVTContentMapper Class

RVTContentMapper Class
REX.ContentGenerator.Map Namespace Legend Members RVTContentMapper Fields RVTContentMapper Methods

Provides interface to the mapping system of the Content Generator in Revit context.

Class Hierarchy
C#
public class RVTContentMapper : ContentMapper;
Description
Namespace

REX.ContentGenerator.Map Namespace

RVTContentMapper Fields
RVTContentMapper Fields | Description
valRvtContext | This is valRvtContext, a member of class RVTContentMapper.
RVTContentMapper Methods
RVTContentMapper Methods | Description
GetMapElement | Gets the map element for specified Revit element.
SetMapElement | Sets the map element for specified Revit element.
Links
REX.ContentGenerator.Map Namespace, Legend, Members, RVTContentMapper Fields, RVTContentMapper Methods


RVTContentMapper.valRvtContext Field

RVTContentMapper.valRvtContext Field
RVTContentMapper Class REX.ContentGenerator.Map Namespace RVTContentMapper Class

This is valRvtContext, a member of class RVTContentMapper.

C#
public const string valRvtContext = "RVT";
Class

RVTContentMapper Class

Links
RVTContentMapper Class, REX.ContentGenerator.Map Namespace, RVTContentMapper Class


RVTContentMapper.GetMapElement Method

RVTContentMapper.GetMapElement Method
RVTContentMapper Class REX.ContentGenerator.Map Namespace RVTContentMapper Class

Gets the map element for specified Revit element.

C#
public REXFamilyType GetMapElement(RevitElement elem, ECategoryType type);
Parameters
Parameters | Description
elem | The element.
type | The type of the element.
Returns

The mapped REXFamilyType object.

Description
Class

RVTContentMapper Class

Links
RVTContentMapper Class, REX.ContentGenerator.Map Namespace, RVTContentMapper Class


RVTContentMapper.SetMapElement Method

RVTContentMapper.SetMapElement Method
RVTContentMapper Class REX.ContentGenerator.Map Namespace RVTContentMapper Class

Sets the map element for specified Revit element.

C#
public void SetMapElement(bool user, RevitElement elem, REXFamilyType fam, ECategoryType type);
Parameters
Parameters | Description
user | Indicates whether the user map should be used.
elem | The element.
fam | The mapped REXFamilyType object.
type | The type of the element.
Description
Class

RVTContentMapper Class

Links
RVTContentMapper Class, REX.ContentGenerator.Map Namespace, RVTContentMapper Class


REX.Controls.Common Namespace

Previous | Next
REX.Controls.Common Namespace
Legend Classes Interfaces Structs, Records, Enums

This is namespace REX.Controls.Common.

Classes
Class | Description
REXComboEditControlEngine | Represents the engine for the combobox edit control.
REXEditControlEngine | Represents the engine for edit controls.
Interfaces
Interface | Description
IComboEditControl | An interface that may be used to attach the custom control to the REXComboEditControlEngine.
IEditControl | An interface that may be used to attach the custom control to the REXEditControlEngine.
IUnitObject | Defines common functionality for controls that are unit dependent.
IUnitObject2 | Defines common functionality for controls that are unit dependent.
IUnitObject3 | Defines common functionality for controls that are unit dependent.
Structs, Records, Enums
Struct, Record, Enum | Description
EComboPropertiesType | An enumerated type listing all modes of the combo.
Links
Legend, Classes, Interfaces, Structs, Records, Enums


REXComboEditControlEngine Class

REXComboEditControlEngine Class
REX.Controls.Common Namespace Legend Members Public Methods REXComboEditControlEngine Methods REXComboEditControlEngine Properties

Represents the engine for the combobox edit control.

Class Hierarchy
C#
public class REXComboEditControlEngine<T_Background> : REXEditControlEngine<T_Background>;
Type Parameters
Type Parameters | Description
T_Background | The type of the background.
Description
Namespace

REX.Controls.Common Namespace

Public Methods
Public Method | Description
REXComboEditControlEngine | Initializes a new instance of the REXComboEditControlEngine class.
REXComboEditControlEngine Methods
REXComboEditControlEngine Methods | Description
GetPropertiesType | Gets the mode of the combo.
GetValue | Returns a double value of the control.
RefreshItems | Refreshes the internal items list based on the control items list.
RestorePropertiesType | Restores the mode of the combo.
SelectionChanged | Informs about changes in the selection.
SetPropertiesType | Sets the mode of the combo box.
SetValue | Sets the value of the double type.
SetValue | Sets the value of the string type.
TextChanged | Informs about changes in the control's text.
ValidateControl | Validates the current control based on the input values.
ValidateControl | Validates the current control based on the current text or the stored value.
ValidateControl | Validates the current control based on the input value.
ValidateControl | Validates the current control based on the input text.
REXComboEditControlEngine Properties
REXComboEditControlEngine Properties | Description
Items | Gets or sets the collection of the items contained in the control.
ListValidation | Gets or sets a value indicating whether the list should be validated.
SelectedIndex | Gets or sets the index specifying the currently selected item.
TextBoxMode | Gets or sets a value indicating whether the combobox should be in the editbox mode.
Links
REX.Controls.Common Namespace, Legend, Members, Public Methods, REXComboEditControlEngine Methods, REXComboEditControlEngine Properties


REXComboEditControlEngine.REXComboEditControlEngine Constructor

REXComboEditControlEngine.REXComboEditControlEngine Constructor
REXComboEditControlEngine Class REX.Controls.Common Namespace REXComboEditControlEngine Class

Initializes a new instance of the REXComboEditControlEngine class.

C#
public REXComboEditControlEngine(IEditControl control);
Parameters
Parameters | Description
control | The control which will use the current instance as it's engine.
Description
Class

REXComboEditControlEngine Class

Links
REXComboEditControlEngine Class, REX.Controls.Common Namespace, REXComboEditControlEngine Class


REXComboEditControlEngine.GetPropertiesType Method

REXComboEditControlEngine.GetPropertiesType Method
REXComboEditControlEngine Class REX.Controls.Common Namespace REXComboEditControlEngine Class

Gets the mode of the combo.

C#
public EComboPropertiesType GetPropertiesType();
Returns

The mode of the combo box.

Description
Class

REXComboEditControlEngine Class

Links
REXComboEditControlEngine Class, REX.Controls.Common Namespace, REXComboEditControlEngine Class


REXComboEditControlEngine.GetValue Method

REXComboEditControlEngine.GetValue Method
REXComboEditControlEngine Class REX.Controls.Common Namespace REXComboEditControlEngine Class

Returns a double value of the control.

C#
public override double GetValue();
Description
Class

REXComboEditControlEngine Class

Links
REXComboEditControlEngine Class, REX.Controls.Common Namespace, REXComboEditControlEngine Class


REXComboEditControlEngine.RefreshItems Method

REXComboEditControlEngine.RefreshItems Method
REXComboEditControlEngine Class REX.Controls.Common Namespace REXComboEditControlEngine Class

Refreshes the internal items list based on the control items list.

C#
public void RefreshItems();
Description
Class

REXComboEditControlEngine Class

Links
REXComboEditControlEngine Class, REX.Controls.Common Namespace, REXComboEditControlEngine Class


REXComboEditControlEngine.RestorePropertiesType Method

REXComboEditControlEngine.RestorePropertiesType Method
REXComboEditControlEngine Class REX.Controls.Common Namespace REXComboEditControlEngine Class

Restores the mode of the combo.

C#
public void RestorePropertiesType();
Description
Class

REXComboEditControlEngine Class

Links
REXComboEditControlEngine Class, REX.Controls.Common Namespace, REXComboEditControlEngine Class


REXComboEditControlEngine.SelectionChanged Method

REXComboEditControlEngine.SelectionChanged Method
REXComboEditControlEngine Class REX.Controls.Common Namespace REXComboEditControlEngine Class

Informs about changes in the selection.

C#
public void SelectionChanged();
Description
Class

REXComboEditControlEngine Class

Links
REXComboEditControlEngine Class, REX.Controls.Common Namespace, REXComboEditControlEngine Class


REXComboEditControlEngine.SetPropertiesType Method

REXComboEditControlEngine.SetPropertiesType Method
REXComboEditControlEngine Class REX.Controls.Common Namespace REXComboEditControlEngine Class

Sets the mode of the combo box.

C#
public void SetPropertiesType(EComboPropertiesType propertiesType);
Parameters
Parameters | Description
propertiesType | The mode of the combo box.
Description
Class

REXComboEditControlEngine Class

Links
REXComboEditControlEngine Class, REX.Controls.Common Namespace, REXComboEditControlEngine Class


REXComboEditControlEngine.SetValue Method (double)

REXComboEditControlEngine.SetValue Method (double)
REXComboEditControlEngine Class REX.Controls.Common Namespace REXComboEditControlEngine Class

Sets the value of the double type.

C#
public override void SetValue(double value);
Parameters
Parameters | Description
value | The value.
Description
Class

REXComboEditControlEngine Class

Links
REXComboEditControlEngine Class, REX.Controls.Common Namespace, REXComboEditControlEngine Class


REXComboEditControlEngine.SetValue Method (string)

REXComboEditControlEngine.SetValue Method (string)
REXComboEditControlEngine Class REX.Controls.Common Namespace REXComboEditControlEngine Class

Sets the value of the string type.

C#
public override void SetValue(string value);
Parameters
Parameters | Description
value | The value.
Description
Class

REXComboEditControlEngine Class

Links
REXComboEditControlEngine Class, REX.Controls.Common Namespace, REXComboEditControlEngine Class


REXComboEditControlEngine.TextChanged Method

REXComboEditControlEngine.TextChanged Method
REXComboEditControlEngine Class REX.Controls.Common Namespace REXComboEditControlEngine Class

Informs about changes in the control's text.

C#
public override void TextChanged(string txt);
Parameters
Parameters | Description
txt | The new text.
Description
Class

REXComboEditControlEngine Class

Links
REXComboEditControlEngine Class, REX.Controls.Common Namespace, REXComboEditControlEngine Class


REXComboEditControlEngine.ValidateControl Method (List<double>)

REXComboEditControlEngine.ValidateControl Method (List<double>)
REXComboEditControlEngine Class REX.Controls.Common Namespace REXComboEditControlEngine Class

Validates the current control based on the input values.

C#
public override bool ValidateControl(List<double> values);
Parameters
Parameters | Description
values | The list of values.
Returns

True if validated; otherwise false.

Description
Class

REXComboEditControlEngine Class

Links
REXComboEditControlEngine Class, REX.Controls.Common Namespace, REXComboEditControlEngine Class


REXComboEditControlEngine.ValidateControl Method (bool)

REXComboEditControlEngine.ValidateControl Method (bool)
REXComboEditControlEngine Class REX.Controls.Common Namespace REXComboEditControlEngine Class

Validates the current control based on the current text or the stored value.

C#
public override void ValidateControl(bool currentText);
Parameters
Parameters | Description
currentText | Declares whether the current text should be validated (true to validate the current text; false to validate the stored value).
Description
Class

REXComboEditControlEngine Class

Links
REXComboEditControlEngine Class, REX.Controls.Common Namespace, REXComboEditControlEngine Class


REXComboEditControlEngine.ValidateControl Method (double)

REXComboEditControlEngine.ValidateControl Method (double)
REXComboEditControlEngine Class REX.Controls.Common Namespace REXComboEditControlEngine Class

Validates the current control based on the input value.

C#
public override bool ValidateControl(double val);
Parameters
Parameters | Description
val | The value.
Returns

True if validated; otherwise false.

Description
Class

REXComboEditControlEngine Class

Links
REXComboEditControlEngine Class, REX.Controls.Common Namespace, REXComboEditControlEngine Class


REXComboEditControlEngine.ValidateControl Method (string)

REXComboEditControlEngine.ValidateControl Method (string)
REXComboEditControlEngine Class REX.Controls.Common Namespace REXComboEditControlEngine Class

Validates the current control based on the input text.

C#
public override bool ValidateControl(string text);
Parameters
Parameters | Description
text | The text.
Returns

True if validated; otherwise false.

Description
Class

REXComboEditControlEngine Class

Links
REXComboEditControlEngine Class, REX.Controls.Common Namespace, REXComboEditControlEngine Class


REXComboEditControlEngine.Items Property

REXComboEditControlEngine.Items Property
REXComboEditControlEngine Class REX.Controls.Common Namespace REXComboEditControlEngine Class

Gets or sets the collection of the items contained in the control.

C#
public List<string> Items;
Description

The items collection.

Class

REXComboEditControlEngine Class

Links
REXComboEditControlEngine Class, REX.Controls.Common Namespace, REXComboEditControlEngine Class


REXComboEditControlEngine.ListValidation Property

REXComboEditControlEngine.ListValidation Property
REXComboEditControlEngine Class REX.Controls.Common Namespace REXComboEditControlEngine Class

Gets or sets a value indicating whether the list should be validated.

C#
public bool ListValidation;
Description

True if validate; otherwise false.

Class

REXComboEditControlEngine Class

Links
REXComboEditControlEngine Class, REX.Controls.Common Namespace, REXComboEditControlEngine Class


REXComboEditControlEngine.SelectedIndex Property

REXComboEditControlEngine.SelectedIndex Property
REXComboEditControlEngine Class REX.Controls.Common Namespace REXComboEditControlEngine Class

Gets or sets the index specifying the currently selected item.

C#
public int SelectedIndex;
Description

The index of the selected item.

Class

REXComboEditControlEngine Class

Links
REXComboEditControlEngine Class, REX.Controls.Common Namespace, REXComboEditControlEngine Class


REXComboEditControlEngine.TextBoxMode Property

REXComboEditControlEngine.TextBoxMode Property
REXComboEditControlEngine Class REX.Controls.Common Namespace REXComboEditControlEngine Class

Gets or sets a value indicating whether the combobox should be in the editbox mode.

C#
public bool TextBoxMode;
Description

True if editbox mode; otherwise false.

Class

REXComboEditControlEngine Class

Links
REXComboEditControlEngine Class, REX.Controls.Common Namespace, REXComboEditControlEngine Class


REXEditControlEngine Class

REXEditControlEngine Class
REX.Controls.Common Namespace Legend Members Public Methods REXEditControlEngine Events REXEditControlEngine Methods REXEditControlEngine Properties

Represents the engine for edit controls.

Class Hierarchy
C#
public class REXEditControlEngine<T_Background> : IUnitObject3;
Type Parameters
Type Parameters | Description
T_Background | The type of the background.
Description
Namespace

REX.Controls.Common Namespace

Public Methods
Public Method | Description
REXEditControlEngine | Initializes a new instance of the REXEditControlEngine class.
REXEditControlEngine Events
REXEditControlEngine Events | Description
EventComplexDoubleValueChanged | Occurs when the complex value changes.
EventDoubleValueChanged | Occurs when the value changes.
REXEditControlEngine Methods
REXEditControlEngine Methods | Description
AddEnabledChangedHandler | Adds the handler to the event raised when the element changes it's enable state.
AddLostFocusHandler | Adds the handler to the event raised when the element loses logical focus.
AddTextChangedHandler | Adds the handler to the event raised when text changes.
EndEdit | Ends the edit mode.
GetBaseMaxValue | Gets the maximum value and converts it to base units.
GetBaseMinValue | Gets the minimum value and converts it to base units.
GetComplexDataBaseValue | Get the values and convert it to base units.
GetComplexDataInterfaceValue | Get the values and convert it to interface units.
GetComplexDoubleValue | Gets the complex (list) value of the double type.
GetComplexStringValue | Returns a complex string list.
GetControl | Gets the control.
GetDataBaseValue | Gets the value and converts it to base units.
GetDataInterfaceValue | Gets the value and converts it to interface units.
GetFullName | Gets the full name.
GetInterfaceMaxValue | Gets the maximum value and converts it to interface units.
GetInterfaceMinValue | Gets the minimum value and converts it to interface units.
GetLastCorrectValueStr | Gets the last correct stored value.
GetState | Gets the current state of the control.
GetStringValue | Returns the original text.
GetUniqueName | Returns the Unique ID generated for the current instance of the engine.
GetUnitName | Gets the name of the unit from EnumUnits type.
GetValue | Gets the value of the double type.
IsInEditMode | Determines whether control is in the edit mode.
Refresh | Refreshes the text on the control based on the current text.
RefreshValidationStatus | Refreshes the validation status.
Reset | Resets control (internal values).
Restore | Refreshes the text on the control based on the stored value.
RestoreOriginalText | Refreshes the text on the control based on the original text.
SetBaseMaxValue | Set the maximum value defined in base units.
SetBaseMinValue | Set the minimum value defined in base units.
SetComplexDataBaseValue | Set the list of values defined in base units.
SetComplexDataInterfaceValue | Set the list of values defined in interface units.
SetComplexValue | Sets the complex (list) value of the double type.
SetComplexValue | Sets the complex (list) value of the string type.
SetComplexValue | Sets the complex (list) value of the string type.
SetControl | Sets the control for which the current instance is the engine.
SetDataBaseValue | Set the value in base units.
SetDataInterfaceValue | Set the value in interface units.
SetExternalUnitBody | Set external IUnitBody object.
SetInterfaceMaxValue | Set the maximum value defined in interface units.
SetInterfaceMinValue | Set the minimum value defined in interface units.
SetUserTextValidation | Sets the user validation method for the text control.
SetUserValidation | Sets the user validation method.
SetUserValidationComplex | Sets the user validation method for complex values (list).
SetValue | Sets the value of the double type.
SetValue | Sets the value of the string type.
StartEdit | Starts the edit mode.
TextChanged | Informs about changes in the control's text.
ValidateComplexValue | Validates the complex (list) value of the double type.
ValidateComplexValue | Validates the complex (list) value of the string type.
ValidateComplexValue | Validates the complex (list) value of the string type.
ValidateControl | Validates the current control based on the input values.
ValidateControl | Validates the current control based on the input text.
ValidateControl | Validates the current control based on the current text or the stored value.
ValidateControl | Validates the current control based on the input value.
ValidateValue | Validates the input value of the double type.
ValidateValue | Validates the value of the string type.
ValueFormat | Returns a text containing an expression formatted according the current settings of the element.
ValueFormat | Returns a text containing an expression formatted according the current settings of the element.
ValueParse | Converts the specified text to the numeric value according the current settings of the element.
REXEditControlEngine Properties
REXEditControlEngine Properties | Description
Background | Gets or sets the background of the control.
BackgroundDisabledHidden | Gets or sets the background for the disabled state of the control in the hidden background mode.
BackgroundDisabledStandard | Gets or sets the background for the disabled state of the control.
BackgroundError | Gets or sets the background for the Error state of the control.
BackgroundNeutral | Gets or sets the background for the neutral state of the control.
BackgroundOK | Gets or sets the background for the OK state of the control.
Complex | Gets or sets a value indicating whether this REXEditControlEngine supports complex (list) values.
ComplexSeparator | Gets or sets the complex (list) separator.
ComplexSpaceSeparator | Gets or sets a value indicating whether a space should be respected as a list separator.
ComplexUnitOnEnd | Gets or sets a value indicating whether a unit symbol should be placed on the end of the formatted text.
ControlState | Gets the current state of the control.
CorrectValue | Gets or sets the correct value.
DataType | Gets or sets the type of the data in the control.
EngineeringFormat | Gets or sets a value indicating whether the text of the control should be formatted in according to the engineering (expotential) format.
Epsilon | Gets or sets the accuracy.
InvalidCharacters | Gets or sets the list invalid characters (for the control in TEXT mode).
IsEnabled | Gets or sets a value indicating whether this instance is enabled.
MaxTokens | Gets or sets the maximum number of elements in the complex mode (list).
MinTokens | Gets or sets the minimum number of elements in the complex mode (list).
OnDisableAction | Gets or sets a value indicating whether the foreground should be hidden when the control is disabled.
OriginalTextOnEnter | Gets or sets a value indicating whether an original text should be set when the user enters the control.
Power | Gets or sets the power of the unit.
RangeMax | Gets or sets the highest possible value.
RangeMaxCheck | Gets or sets a value indicating whether the value should be validated due to the RangeMax.
RangeMin | Gets or sets the minimum possible value.
RangeMinCheck | Gets or sets a value indicating whether the value should be validated due to the RangeMin.
RememberCorrect | Gets or sets a value indicating whether the correct value should be restored in case of the validation failure.
RoundingFractional | Gets or sets the rounding for fractional units.
RoundingIncrement | Gets or sets the rounding increment (for the DECIMAL DataType).
Separator | Gets or sets the decimal separator.
Tag | Gets or sets the tag.
Text | Gets the text contents of the control.
TokensRangeMaxCheck | Gets or sets a value indicating whether the number of elements should be validated due to the MaxTokens.
TokensRangeMinCheck | Gets or sets a value indicating whether the number of elements should be validated due to the MinTokens.
UnitEngine | Gets or sets the unit engine.
UnitSymbol | Gets or sets the unit symbol.
UnitType | Gets or sets the type of the unit.
Links
REX.Controls.Common Namespace, Legend, Members, Public Methods, REXEditControlEngine Events, REXEditControlEngine Methods, REXEditControlEngine Properties


REXEditControlEngine.REXEditControlEngine Constructor

REXEditControlEngine.REXEditControlEngine Constructor
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Initializes a new instance of the REXEditControlEngine class.

C#
public REXEditControlEngine(IEditControl control);
Parameters
Parameters | Description
control | The control which will use the current instance as it's engine .
Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.AddEnabledChangedHandler Method

REXEditControlEngine.AddEnabledChangedHandler Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Adds the handler to the event raised when the element changes it's enable state.

C#
public void AddEnabledChangedHandler(EventHandler eh);
Parameters
Parameters | Description
eh | The event handler.
Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.AddLostFocusHandler Method

REXEditControlEngine.AddLostFocusHandler Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Adds the handler to the event raised when the element loses logical focus.

C#
public void AddLostFocusHandler(EventHandler eh);
Parameters
Parameters | Description
eh | The event handler.
Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.AddTextChangedHandler Method

REXEditControlEngine.AddTextChangedHandler Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Adds the handler to the event raised when text changes.

C#
public void AddTextChangedHandler(EventHandler eh);
Parameters
Parameters | Description
eh | The event handler.
Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.EndEdit Method

REXEditControlEngine.EndEdit Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Ends the edit mode.

C#
public virtual void EndEdit();
Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.GetBaseMaxValue Method

REXEditControlEngine.GetBaseMaxValue Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets the maximum value and converts it to base units.

C#
public double GetBaseMaxValue();
Returns

The value.

Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.GetBaseMinValue Method

REXEditControlEngine.GetBaseMinValue Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets the minimum value and converts it to base units.

C#
public double GetBaseMinValue();
Returns

The value.

Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.GetComplexDataBaseValue Method

REXEditControlEngine.GetComplexDataBaseValue Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Get the values and convert it to base units.

C#
public List<double> GetComplexDataBaseValue();
Returns

The list of values.

Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.GetComplexDataInterfaceValue Method

REXEditControlEngine.GetComplexDataInterfaceValue Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Get the values and convert it to interface units.

C#
public List<double> GetComplexDataInterfaceValue(REXInterfaceType interfaceType);
Parameters
Parameters | Description
interfaceType | The product context.
Returns

The list of values.

Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.GetComplexDoubleValue Method

REXEditControlEngine.GetComplexDoubleValue Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets the complex (list) value of the double type.

C#
public virtual List<double> GetComplexDoubleValue();
Returns

The list of values.

Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.GetComplexStringValue Method

REXEditControlEngine.GetComplexStringValue Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Returns a complex string list.

C#
public List<string> GetComplexStringValue();
Returns

The list of values.

Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.GetControl Method

REXEditControlEngine.GetControl Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets the control.

C#
public IEditControl GetControl();
Returns

Returns the control.

Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.GetDataBaseValue Method

REXEditControlEngine.GetDataBaseValue Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets the value and converts it to base units.

C#
public double GetDataBaseValue();
Returns

The value.

Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.GetDataInterfaceValue Method

REXEditControlEngine.GetDataInterfaceValue Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets the value and converts it to interface units.

C#
public double GetDataInterfaceValue(REXInterfaceType interfaceType);
Parameters
Parameters | Description
interfaceType | The product context.
Returns

The value.

Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.GetFullName Method

REXEditControlEngine.GetFullName Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets the full name.

C#
public string GetFullName();
Returns

The full name.

Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.GetInterfaceMaxValue Method

REXEditControlEngine.GetInterfaceMaxValue Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets the maximum value and converts it to interface units.

C#
public double GetInterfaceMaxValue(REXInterfaceType interfaceType);
Parameters
Parameters | Description
interfaceType | The product context.
Returns

The value.

Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.GetInterfaceMinValue Method

REXEditControlEngine.GetInterfaceMinValue Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets the minimum value and converts it to interface units.

C#
public double GetInterfaceMinValue(REXInterfaceType interfaceType);
Parameters
Parameters | Description
interfaceType | The product context.
Returns

The value.

Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.GetLastCorrectValueStr Method

REXEditControlEngine.GetLastCorrectValueStr Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets the last correct stored value.

C#
public String GetLastCorrectValueStr();
Returns

The correct value.

Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.GetState Method

REXEditControlEngine.GetState Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets the current state of the control.

C#
public EControlState GetState();
Returns

The state of the control.

Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.GetStringValue Method

REXEditControlEngine.GetStringValue Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Returns the original text.

C#
public string GetStringValue();
Returns

The text value.

Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.GetUniqueName Method

REXEditControlEngine.GetUniqueName Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Returns the Unique ID generated for the current instance of the engine.

C#
public string GetUniqueName();
Returns

The unique ID.

Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.GetUnitName Method

REXEditControlEngine.GetUnitName Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets the name of the unit from EnumUnits type.

C#
public static string GetUnitName(Autodesk.REX.Framework.EUnitType u);
Parameters
Parameters | Description
u | The unit type.
Returns

Returns unit name.

Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.GetValue Method

REXEditControlEngine.GetValue Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets the value of the double type.

C#
public virtual double GetValue();
Returns

The value.

Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.IsInEditMode Method

REXEditControlEngine.IsInEditMode Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Determines whether control is in the edit mode.

C#
public bool IsInEditMode();
Returns

True if the control is in edit mode; otherwise, false.

Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.Refresh Method

REXEditControlEngine.Refresh Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Refreshes the text on the control based on the current text.

C#
public void Refresh();
Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.RefreshValidationStatus Method

REXEditControlEngine.RefreshValidationStatus Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Refreshes the validation status.

C#
public void RefreshValidationStatus();
Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.Reset Method

REXEditControlEngine.Reset Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Resets control (internal values).

C#
public void Reset();
Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.Restore Method

REXEditControlEngine.Restore Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Refreshes the text on the control based on the stored value.

C#
public void Restore();
Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.RestoreOriginalText Method

REXEditControlEngine.RestoreOriginalText Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Refreshes the text on the control based on the original text.

C#
public void RestoreOriginalText();
Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.SetBaseMaxValue Method

REXEditControlEngine.SetBaseMaxValue Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Set the maximum value defined in base units.

C#
public void SetBaseMaxValue(double value);
Parameters
Parameters | Description
value | The value.
Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.SetBaseMinValue Method

REXEditControlEngine.SetBaseMinValue Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Set the minimum value defined in base units.

C#
public void SetBaseMinValue(double value);
Parameters
Parameters | Description
value | The value.
Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.SetComplexDataBaseValue Method

REXEditControlEngine.SetComplexDataBaseValue Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Set the list of values defined in base units.

C#
public void SetComplexDataBaseValue(List<double> values);
Parameters
Parameters | Description
values | The values.
Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.SetComplexDataInterfaceValue Method

REXEditControlEngine.SetComplexDataInterfaceValue Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Set the list of values defined in interface units.

C#
public void SetComplexDataInterfaceValue(List<double> values, REXInterfaceType interfaceType);
Parameters
Parameters | Description
values | The values.
interfaceType | The product context.
Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.SetComplexValue Method (List<double>)

REXEditControlEngine.SetComplexValue Method (List<double>)
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Sets the complex (list) value of the double type.

C#
public virtual void SetComplexValue(List<double> values);
Parameters
Parameters | Description
values | The list of values.
Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.SetComplexValue Method (List<string>)

REXEditControlEngine.SetComplexValue Method (List<string>)
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Sets the complex (list) value of the string type.

C#
public void SetComplexValue(List<string> values);
Parameters
Parameters | Description
values | The list of values.
Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.SetComplexValue Method (String)

REXEditControlEngine.SetComplexValue Method (String)
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Sets the complex (list) value of the string type.

C#
public bool SetComplexValue(String value);
Parameters
Parameters | Description
value | The value.
Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.SetControl Method

REXEditControlEngine.SetControl Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Sets the control for which the current instance is the engine.

C#
public void SetControl(IEditControl control);
Parameters
Parameters | Description
control | The control.
Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.SetDataBaseValue Method

REXEditControlEngine.SetDataBaseValue Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Set the value in base units.

C#
public void SetDataBaseValue(double value);
Parameters
Parameters | Description
value | The value.
Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.SetDataInterfaceValue Method

REXEditControlEngine.SetDataInterfaceValue Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Set the value in interface units.

C#
public void SetDataInterfaceValue(double value, REXInterfaceType interfaceType);
Parameters
Parameters | Description
value | The value.
interfaceType | The product context.
Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.SetExternalUnitBody Method

REXEditControlEngine.SetExternalUnitBody Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Set external IUnitBody object.

C#
public void SetExternalUnitBody(IUnitBody unitBody);
Parameters
Parameters | Description
unitBody | External IUnitBody object
Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.SetInterfaceMaxValue Method

REXEditControlEngine.SetInterfaceMaxValue Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Set the maximum value defined in interface units.

C#
public void SetInterfaceMaxValue(double value, REXInterfaceType interfaceType);
Parameters
Parameters | Description
value | The value.
interfaceType | The product context.
Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.SetInterfaceMinValue Method

REXEditControlEngine.SetInterfaceMinValue Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Set the minimum value defined in interface units.

C#
public void SetInterfaceMinValue(double value, REXInterfaceType interfaceType);
Parameters
Parameters | Description
value | The value.
interfaceType | The product context.
Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.SetUserTextValidation Method

REXEditControlEngine.SetUserTextValidation Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Sets the user validation method for the text control.

C#
public void SetUserTextValidation(UserTextValidation ValidFunction);
Parameters
Parameters | Description
ValidFunction | The validation method.
Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.SetUserValidation Method

REXEditControlEngine.SetUserValidation Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Sets the user validation method.

C#
public void SetUserValidation(UserValidation ValidFunction);
Parameters
Parameters | Description
ValidFunction | The validation method.
Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.SetUserValidationComplex Method

REXEditControlEngine.SetUserValidationComplex Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Sets the user validation method for complex values (list).

C#
public void SetUserValidationComplex(UserValidationComplex ValidFunction);
Parameters
Parameters | Description
ValidFunction | The validation method.
Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.SetValue Method (Double)

REXEditControlEngine.SetValue Method (Double)
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Sets the value of the double type.

C#
public virtual void SetValue(Double value);
Parameters
Parameters | Description
value | The value.
Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.SetValue Method (String)

REXEditControlEngine.SetValue Method (String)
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Sets the value of the string type.

C#
public virtual void SetValue(String value);
Parameters
Parameters | Description
value | The value.
Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.StartEdit Method

REXEditControlEngine.StartEdit Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Starts the edit mode.

C#
public virtual void StartEdit();
Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.TextChanged Method

REXEditControlEngine.TextChanged Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Informs about changes in the control's text.

C#
public virtual void TextChanged(string txt);
Parameters
Parameters | Description
txt | The new text.
Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.ValidateComplexValue Method (List<double>)

REXEditControlEngine.ValidateComplexValue Method (List<double>)
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Validates the complex (list) value of the double type.

C#
public bool ValidateComplexValue(List<double> values);
Parameters
Parameters | Description
values | The values to validate.
Returns

True if validated; otherwise false.

Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.ValidateComplexValue Method (List<string>)

REXEditControlEngine.ValidateComplexValue Method (List<string>)
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Validates the complex (list) value of the string type.

C#
public bool ValidateComplexValue(List<string> values);
Parameters
Parameters | Description
values | The values to validate.
Returns

True if validated; otherwise false.

Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.ValidateComplexValue Method (String)

REXEditControlEngine.ValidateComplexValue Method (String)
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Validates the complex (list) value of the string type.

C#
public bool ValidateComplexValue(String value);
Parameters
Parameters | Description
value | The value to validate.
Returns

True if validated; otherwise false.

Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.ValidateControl Method (List<double>)

REXEditControlEngine.ValidateControl Method (List<double>)
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Validates the current control based on the input values.

C#
public virtual bool ValidateControl(List<double> values);
Parameters
Parameters | Description
values | The list of values.
Returns

True if validated; otherwise false.

Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.ValidateControl Method (String)

REXEditControlEngine.ValidateControl Method (String)
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Validates the current control based on the input text.

C#
public virtual bool ValidateControl(String text);
Parameters
Parameters | Description
text | The text.
Returns

True if validated; otherwise false.

Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.ValidateControl Method (bool)

REXEditControlEngine.ValidateControl Method (bool)
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Validates the current control based on the current text or the stored value.

C#
public virtual void ValidateControl(bool currentText);
Parameters
Parameters | Description
currentText | Declares whether the current text should be validated (true to validate the current text; false to validate the stored value).
Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.ValidateControl Method (double)

REXEditControlEngine.ValidateControl Method (double)
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Validates the current control based on the input value.

C#
public virtual bool ValidateControl(double val);
Parameters
Parameters | Description
val | The value.
Returns

True if validated; otherwise false.

Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.ValidateValue Method (Double)

REXEditControlEngine.ValidateValue Method (Double)
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Validates the input value of the double type.

C#
public bool ValidateValue(Double value);
Parameters
Parameters | Description
value | The value to validate.
Returns

True if validated; otherwise false.

Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.ValidateValue Method (String)

REXEditControlEngine.ValidateValue Method (String)
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Validates the value of the string type.

C#
public bool ValidateValue(String value);
Parameters
Parameters | Description
value | The value to validate.
Returns

True if validated; otherwise false.

Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.ValueFormat Method (Double)

REXEditControlEngine.ValueFormat Method (Double)
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Returns a text containing an expression formatted according the current settings of the element.

C#
public string ValueFormat(Double value);
Parameters
Parameters | Description
value | The value to format.
Returns

The formatted text.

Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.ValueFormat Method (String)

REXEditControlEngine.ValueFormat Method (String)
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Returns a text containing an expression formatted according the current settings of the element.

C#
public string ValueFormat(String value);
Parameters
Parameters | Description
value | The value to format.
Returns

The formatted text.

Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.ValueParse Method

REXEditControlEngine.ValueParse Method
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Converts the specified text to the numeric value according the current settings of the element.

C#
public double ValueParse(String value);
Parameters
Parameters | Description
value | The text.
Returns

The converted value.

Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.Background Property

REXEditControlEngine.Background Property
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets or sets the background of the control.

C#
public T_Background Background;
Description

The background.

Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.BackgroundDisabledHidden Property

REXEditControlEngine.BackgroundDisabledHidden Property
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets or sets the background for the disabled state of the control in the hidden background mode.

C#
public T_Background BackgroundDisabledHidden;
Description

The background.

Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.BackgroundDisabledStandard Property

REXEditControlEngine.BackgroundDisabledStandard Property
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets or sets the background for the disabled state of the control.

C#
public T_Background BackgroundDisabledStandard;
Description

The background.

Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.BackgroundError Property

REXEditControlEngine.BackgroundError Property
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets or sets the background for the Error state of the control.

C#
public T_Background BackgroundError;
Description

The Error background.

Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.BackgroundNeutral Property

REXEditControlEngine.BackgroundNeutral Property
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets or sets the background for the neutral state of the control.

C#
public T_Background BackgroundNeutral;
Description

The neutral background.

Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.BackgroundOK Property

REXEditControlEngine.BackgroundOK Property
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets or sets the background for the OK state of the control.

C#
public T_Background BackgroundOK;
Description

The OK background.

Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.Complex Property

REXEditControlEngine.Complex Property
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets or sets a value indicating whether this REXEditControlEngine supports complex (list) values.

C#
public Boolean Complex;
Description

True if the engine supports complex values; otherwise false.

Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.ComplexSeparator Property

REXEditControlEngine.ComplexSeparator Property
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets or sets the complex (list) separator.

C#
[DefaultValue(";")]
public string ComplexSeparator;
Description

The complex separator.

Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.ComplexSpaceSeparator Property

REXEditControlEngine.ComplexSpaceSeparator Property
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets or sets a value indicating whether a space should be respected as a list separator.

C#
public Boolean ComplexSpaceSeparator;
Description

True if space respected as a list separator; otherwise, false.

Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.ComplexUnitOnEnd Property

REXEditControlEngine.ComplexUnitOnEnd Property
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets or sets a value indicating whether a unit symbol should be placed on the end of the formatted text.

C#
public Boolean ComplexUnitOnEnd;
Description

True if the unit one the end; otherwise, false.

Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.ControlState Property

REXEditControlEngine.ControlState Property
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets the current state of the control.

C#
public EControlState ControlState;
Description

The state of the control.

Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.CorrectValue Property

REXEditControlEngine.CorrectValue Property
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets or sets the correct value.

C#
public String CorrectValue;
Description

The correct value.

Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.DataType Property

REXEditControlEngine.DataType Property
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets or sets the type of the data in the control.

C#
public REX.Controls.Common.EControlType DataType;
Description

The type of the data.

Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.EngineeringFormat Property

REXEditControlEngine.EngineeringFormat Property
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets or sets a value indicating whether the text of the control should be formatted in according to the engineering (expotential) format.

C#
[DefaultValue(false)]
public Boolean EngineeringFormat;
Description

True if engineering format; otherwise false.

Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.Epsilon Property

REXEditControlEngine.Epsilon Property
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets or sets the accuracy.

C#
public double Epsilon;
Description

The accuracy.

Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.InvalidCharacters Property

REXEditControlEngine.InvalidCharacters Property
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets or sets the list invalid characters (for the control in TEXT mode).

C#
public string InvalidCharacters;
Description

The list of invalid characters.

Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.IsEnabled Property

REXEditControlEngine.IsEnabled Property
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets or sets a value indicating whether this instance is enabled.

C#
public Boolean IsEnabled;
Description

True if this instance is enabled; otherwise, false.

Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.MaxTokens Property

REXEditControlEngine.MaxTokens Property
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets or sets the maximum number of elements in the complex mode (list).

C#
public int MaxTokens;
Description

The maximum number of elements.

Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.MinTokens Property

REXEditControlEngine.MinTokens Property
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets or sets the minimum number of elements in the complex mode (list).

C#
public int MinTokens;
Description

The minimum number of elements.

Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.OnDisableAction Property

REXEditControlEngine.OnDisableAction Property
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets or sets a value indicating whether the foreground should be hidden when the control is disabled.

C#
public EOnDisable OnDisableAction;
Description

The behaviour of the control's foreground.

Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.OriginalTextOnEnter Property

REXEditControlEngine.OriginalTextOnEnter Property
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets or sets a value indicating whether an original text should be set when the user enters the control.

C#
public bool OriginalTextOnEnter;
Description

True if original text is to be set; otherwise, false.

Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.Power Property

REXEditControlEngine.Power Property
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets or sets the power of the unit.

C#
public double Power;
Description

The power.

Remarks

Important when the UnitEngine is set.

Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.RangeMax Property

REXEditControlEngine.RangeMax Property
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets or sets the highest possible value.

C#
[DefaultValue(Double.PositiveInfinity)]
public Double RangeMax;
Description

The highest possible value.

Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.RangeMaxCheck Property

REXEditControlEngine.RangeMaxCheck Property
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets or sets a value indicating whether the value should be validated due to the RangeMax.

C#
[DefaultValue(false)]
public Boolean RangeMaxCheck;
Description

True if validate; otherwise false.

Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.RangeMin Property

REXEditControlEngine.RangeMin Property
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets or sets the minimum possible value.

C#
[DefaultValue(Double.NegativeInfinity)]
public Double RangeMin;
Description

The minimum possible value.

Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.RangeMinCheck Property

REXEditControlEngine.RangeMinCheck Property
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets or sets a value indicating whether the value should be validated due to the RangeMin.

C#
[DefaultValue(false)]
public Boolean RangeMinCheck;
Description

True if validate; otherwise false.

Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.RememberCorrect Property

REXEditControlEngine.RememberCorrect Property
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets or sets a value indicating whether the correct value should be restored in case of the validation failure.

C#
public Boolean RememberCorrect;
Description

True if the value should be restored; otherwise false.

Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.RoundingFractional Property

REXEditControlEngine.RoundingFractional Property
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets or sets the rounding for fractional units.

C#
public EFractialRound RoundingFractional;
Description

The rounding.

Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.RoundingIncrement Property

REXEditControlEngine.RoundingIncrement Property
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets or sets the rounding increment (for the DECIMAL DataType).

C#
public Double RoundingIncrement;
Description

The rounding increment.

Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.Separator Property

REXEditControlEngine.Separator Property
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets or sets the decimal separator.

C#
public String Separator;
Description

The separator.

Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.Tag Property

REXEditControlEngine.Tag Property
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets or sets the tag.

C#
public object Tag;
Description

The tag.

Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.Text Property

REXEditControlEngine.Text Property
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets the text contents of the control.

C#
public string Text;
Description

The text.

Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.TokensRangeMaxCheck Property

REXEditControlEngine.TokensRangeMaxCheck Property
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets or sets a value indicating whether the number of elements should be validated due to the MaxTokens.

C#
[DefaultValue(false)]
public Boolean TokensRangeMaxCheck;
Description

True if validate; otherwise, false.

Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.TokensRangeMinCheck Property

REXEditControlEngine.TokensRangeMinCheck Property
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets or sets a value indicating whether the number of elements should be validated due to the MinTokens.

C#
[DefaultValue(false)]
public Boolean TokensRangeMinCheck;
Description

True if validate; otherwise, false.

Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.UnitEngine Property

REXEditControlEngine.UnitEngine Property
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets or sets the unit engine.

C#
public Autodesk.REX.Framework.IREXUnits UnitEngine;
Description

The unit engine.

Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.UnitSymbol Property

REXEditControlEngine.UnitSymbol Property
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets or sets the unit symbol.

C#
[DefaultValue("")]
public String UnitSymbol;
Description

The unit symbol.

Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.UnitType Property

REXEditControlEngine.UnitType Property
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Gets or sets the type of the unit.

C#
public Autodesk.REX.Framework.EUnitType UnitType;
Description

The type of the unit.

Remarks

Important when the UnitEngine is set.

Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.EventComplexDoubleValueChanged Event

REXEditControlEngine.EventComplexDoubleValueChanged Event
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Occurs when the complex value changes.

C#
public event ComplexDoubleValueChanged EventComplexDoubleValueChanged;
Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


REXEditControlEngine.EventDoubleValueChanged Event

REXEditControlEngine.EventDoubleValueChanged Event
REXEditControlEngine Class REX.Controls.Common Namespace REXEditControlEngine Class

Occurs when the value changes.

C#
public event DoubleValueChanged EventDoubleValueChanged;
Description
Class

REXEditControlEngine Class

Links
REXEditControlEngine Class, REX.Controls.Common Namespace, REXEditControlEngine Class


IComboEditControl Interface

IComboEditControl Interface
REX.Controls.Common Namespace Legend Members IComboEditControl Methods

An interface that may be used to attach the custom control to the REXComboEditControlEngine.

Class Hierarchy
C#
public interface IComboEditControl : IEditControl;
Description
Namespace

REX.Controls.Common Namespace

IComboEditControl Methods
IComboEditControl Methods | Description
Editable | Gets a value indicating whether the control is editable.
GetItems | Gets the collection of the items contained in the control.
GetSelectedIndex | Gets the index specifying the currently selected item.
SetSelectedIndex | Sets the index specifying the currently selected item.
Links
REX.Controls.Common Namespace, Legend, Members, IComboEditControl Methods


IComboEditControl.Editable Method

IComboEditControl.Editable Method
IComboEditControl Interface REX.Controls.Common Namespace IComboEditControl Interface

Gets a value indicating whether the control is editable.

C#
bool Editable();
Returns

True if the control can be edited; otherwise false.

Description
Interface

IComboEditControl Interface

Links
IComboEditControl Interface, REX.Controls.Common Namespace, IComboEditControl Interface


IComboEditControl.GetItems Method

IComboEditControl.GetItems Method
IComboEditControl Interface REX.Controls.Common Namespace IComboEditControl Interface

Gets the collection of the items contained in the control.

C#
List<string> GetItems();
Returns

The list of items.

Description
Interface

IComboEditControl Interface

Links
IComboEditControl Interface, REX.Controls.Common Namespace, IComboEditControl Interface


IComboEditControl.GetSelectedIndex Method

IComboEditControl.GetSelectedIndex Method
IComboEditControl Interface REX.Controls.Common Namespace IComboEditControl Interface

Gets the index specifying the currently selected item.

C#
int GetSelectedIndex();
Returns

The index.

Description
Interface

IComboEditControl Interface

Links
IComboEditControl Interface, REX.Controls.Common Namespace, IComboEditControl Interface


IComboEditControl.SetSelectedIndex Method

IComboEditControl.SetSelectedIndex Method
IComboEditControl Interface REX.Controls.Common Namespace IComboEditControl Interface

Sets the index specifying the currently selected item.

C#
void SetSelectedIndex(int index);
Parameters
Parameters | Description
index | The index of the selected item.
Description
Interface

IComboEditControl Interface

Links
IComboEditControl Interface, REX.Controls.Common Namespace, IComboEditControl Interface


IEditControl Interface

IEditControl Interface
REX.Controls.Common Namespace Legend Members IEditControl Methods

An interface that may be used to attach the custom control to the REXEditControlEngine.

Class Hierarchy
C#
public interface IEditControl;
Description
Namespace

REX.Controls.Common Namespace

IEditControl Methods
IEditControl Methods | Description
GetBackground | Gets the background of the control.
GetEnable | Indicates whether the control is enabled.
GetText | Gets the text contents of the control.
SetBackground | Sets the background of the control.
SetText | Sets the text contents of the control.
Links
REX.Controls.Common Namespace, Legend, Members, IEditControl Methods


IEditControl.GetBackground Method

IEditControl.GetBackground Method
IEditControl Interface REX.Controls.Common Namespace IEditControl Interface

Gets the background of the control.

C#
object GetBackground();
Returns

The background.

Description
Interface

IEditControl Interface

Links
IEditControl Interface, REX.Controls.Common Namespace, IEditControl Interface


IEditControl.GetEnable Method

IEditControl.GetEnable Method
IEditControl Interface REX.Controls.Common Namespace IEditControl Interface

Indicates whether the control is enabled.

C#
bool GetEnable();
Returns

True if the element is enabled; otherwise, false.

Description
Interface

IEditControl Interface

Links
IEditControl Interface, REX.Controls.Common Namespace, IEditControl Interface


IEditControl.GetText Method

IEditControl.GetText Method
IEditControl Interface REX.Controls.Common Namespace IEditControl Interface

Gets the text contents of the control.

C#
string GetText();
Returns

The text contents of the control.

Description
Interface

IEditControl Interface

Links
IEditControl Interface, REX.Controls.Common Namespace, IEditControl Interface


IEditControl.SetBackground Method

IEditControl.SetBackground Method
IEditControl Interface REX.Controls.Common Namespace IEditControl Interface

Sets the background of the control.

C#
void SetBackground(object background);
Parameters
Parameters | Description
background | The background.
Description
Interface

IEditControl Interface

Links
IEditControl Interface, REX.Controls.Common Namespace, IEditControl Interface


IEditControl.SetText Method

IEditControl.SetText Method
IEditControl Interface REX.Controls.Common Namespace IEditControl Interface

Sets the text contents of the control.

C#
void SetText(string txt);
Parameters
Parameters | Description
txt | The text.
Description
Interface

IEditControl Interface

Links
IEditControl Interface, REX.Controls.Common Namespace, IEditControl Interface


IUnitObject Interface

IUnitObject Interface
REX.Controls.Common Namespace Legend Members IUnitObject Methods IUnitObject Properties

Defines common functionality for controls that are unit dependent.

Class Hierarchy
C#
public interface IUnitObject;
Description
Namespace

REX.Controls.Common Namespace

IUnitObject Methods
IUnitObject Methods | Description
AddEnabledChangedHandler | Adds the handler to the event raised when the element changes it's enable state.
AddLostFocusHandler | Adds the handler to the event raised when the element loses logical focus.
AddTextChangedHandler | Adds the handler to the event raised when text changes.
GetComplexDoubleValue | Gets the complex (list) value of the double type.
GetComplexStringValue | Gets the complex (list) string value of the string type.
GetFullName | Gets the full name of the control.
GetState | Gets the current state of the control.
GetUniqueName | Gets the unique name of the control.
GetValue | Gets the value of the double type.
Reset | Resets the instance of the element.
SetComplexValue | Sets the complex (list) value of the double type.
SetComplexValue | Sets the complex (list) value of the string type.
SetExternalUnitBody | This is SetExternalUnitBody, a member of class IUnitObject.
SetUserValidation | Sets the user validation method.
SetUserValidationComplex | Sets the user validation method for complex values (list).
SetValue | Sets the value of the double type.
SetValue | Sets the value of the string type.
IUnitObject Properties
IUnitObject Properties | Description
Complex | Gets or sets a value indicating whether this the control is in the complex mode (list mode).
ControlState | Gets the state of the control.
DataType | Gets or sets the type of the data in the control.
EngineeringFormat | Gets or sets a value indicating whether the text of the control should be formatted in according to the engineering (expotential) format.
RangeMax | Gets or sets the highest possible value.
RangeMaxCheck | Gets or sets a value indicating whether the value should be validated due to the RangeMax.
RangeMin | Gets or sets the minimum possible value.
RangeMinCheck | Gets or sets a value indicating whether the value should be validated due to the RangeMin.
RoundingFractional | Gets or sets the rounding for fractional units.
RoundingIncrement | Gets or sets the rounding increment.
Separator | Gets or sets the decimal separator.
Tag | Gets or sets the tag.
Text | Gets the text contents of the control.
UnitSymbol | Gets or sets the unit symbol.
Links
REX.Controls.Common Namespace, Legend, Members, IUnitObject Methods, IUnitObject Properties


IUnitObject.AddEnabledChangedHandler Method

IUnitObject.AddEnabledChangedHandler Method
IUnitObject Interface REX.Controls.Common Namespace IUnitObject Interface

Adds the handler to the event raised when the element changes it's enable state.

C#
void AddEnabledChangedHandler(System.EventHandler eh);
Parameters
Parameters | Description
eh | The event handler.
Description
Interface

IUnitObject Interface

Links
IUnitObject Interface, REX.Controls.Common Namespace, IUnitObject Interface


IUnitObject.AddLostFocusHandler Method

IUnitObject.AddLostFocusHandler Method
IUnitObject Interface REX.Controls.Common Namespace IUnitObject Interface

Adds the handler to the event raised when the element loses logical focus.

C#
void AddLostFocusHandler(System.EventHandler eh);
Parameters
Parameters | Description
eh | The event handler.
Description
Interface

IUnitObject Interface

Links
IUnitObject Interface, REX.Controls.Common Namespace, IUnitObject Interface


IUnitObject.AddTextChangedHandler Method

IUnitObject.AddTextChangedHandler Method
IUnitObject Interface REX.Controls.Common Namespace IUnitObject Interface

Adds the handler to the event raised when text changes.

C#
void AddTextChangedHandler(System.EventHandler eh);
Parameters
Parameters | Description
eh | The event handler.
Description
Interface

IUnitObject Interface

Links
IUnitObject Interface, REX.Controls.Common Namespace, IUnitObject Interface


IUnitObject.GetComplexDoubleValue Method

IUnitObject.GetComplexDoubleValue Method
IUnitObject Interface REX.Controls.Common Namespace IUnitObject Interface

Gets the complex (list) value of the double type.

C#
List<double> GetComplexDoubleValue();
Returns

The list of values.

Description
Interface

IUnitObject Interface

Links
IUnitObject Interface, REX.Controls.Common Namespace, IUnitObject Interface


IUnitObject.GetComplexStringValue Method

IUnitObject.GetComplexStringValue Method
IUnitObject Interface REX.Controls.Common Namespace IUnitObject Interface

Gets the complex (list) string value of the string type.

C#
List<string> GetComplexStringValue();
Returns

The list of values.

Description
Interface

IUnitObject Interface

Links
IUnitObject Interface, REX.Controls.Common Namespace, IUnitObject Interface


IUnitObject.GetFullName Method

IUnitObject.GetFullName Method
IUnitObject Interface REX.Controls.Common Namespace IUnitObject Interface

Gets the full name of the control.

C#
string GetFullName();
Returns

The full name of the control.

Description
Interface

IUnitObject Interface

Links
IUnitObject Interface, REX.Controls.Common Namespace, IUnitObject Interface


IUnitObject.GetState Method

IUnitObject.GetState Method
IUnitObject Interface REX.Controls.Common Namespace IUnitObject Interface

Gets the current state of the control.

C#
EControlState GetState();
Returns

The state of the control.

Description
Interface

IUnitObject Interface

Links
IUnitObject Interface, REX.Controls.Common Namespace, IUnitObject Interface


IUnitObject.GetUniqueName Method

IUnitObject.GetUniqueName Method
IUnitObject Interface REX.Controls.Common Namespace IUnitObject Interface

Gets the unique name of the control.

C#
string GetUniqueName();
Returns

The unique name.

Description
Interface

IUnitObject Interface

Links
IUnitObject Interface, REX.Controls.Common Namespace, IUnitObject Interface


IUnitObject.GetValue Method

IUnitObject.GetValue Method
IUnitObject Interface REX.Controls.Common Namespace IUnitObject Interface

Gets the value of the double type.

C#
Double GetValue();
Returns

The value.

Description
Interface

IUnitObject Interface

Links
IUnitObject Interface, REX.Controls.Common Namespace, IUnitObject Interface


IUnitObject.Reset Method

IUnitObject.Reset Method
IUnitObject Interface REX.Controls.Common Namespace IUnitObject Interface

Resets the instance of the element.

C#
void Reset();
Description
Interface

IUnitObject Interface

Links
IUnitObject Interface, REX.Controls.Common Namespace, IUnitObject Interface


IUnitObject.SetComplexValue Method (List<double>)

IUnitObject.SetComplexValue Method (List<double>)
IUnitObject Interface REX.Controls.Common Namespace IUnitObject Interface

Sets the complex (list) value of the double type.

C#
void SetComplexValue(List<double> values);
Parameters
Parameters | Description
values | The list of values.
Description
Interface

IUnitObject Interface

Links
IUnitObject Interface, REX.Controls.Common Namespace, IUnitObject Interface


IUnitObject.SetComplexValue Method (List<string>)

IUnitObject.SetComplexValue Method (List<string>)
IUnitObject Interface REX.Controls.Common Namespace IUnitObject Interface

Sets the complex (list) value of the string type.

C#
void SetComplexValue(List<string> values);
Parameters
Parameters | Description
values | The list of values.
Description
Interface

IUnitObject Interface

Links
IUnitObject Interface, REX.Controls.Common Namespace, IUnitObject Interface


IUnitObject.SetExternalUnitBody Method

IUnitObject.SetExternalUnitBody Method
IUnitObject Interface REX.Controls.Common Namespace IUnitObject Interface

This is SetExternalUnitBody, a member of class IUnitObject.

C#
void SetExternalUnitBody(IUnitBody unitBody);
Interface

IUnitObject Interface

Links
IUnitObject Interface, REX.Controls.Common Namespace, IUnitObject Interface


IUnitObject.SetUserValidation Method

IUnitObject.SetUserValidation Method
IUnitObject Interface REX.Controls.Common Namespace IUnitObject Interface

Sets the user validation method.

C#
void SetUserValidation(UserValidation ValidFunction);
Parameters
Parameters | Description
ValidFunction | The validation method.
Description
Interface

IUnitObject Interface

Links
IUnitObject Interface, REX.Controls.Common Namespace, IUnitObject Interface


IUnitObject.SetUserValidationComplex Method

IUnitObject.SetUserValidationComplex Method
IUnitObject Interface REX.Controls.Common Namespace IUnitObject Interface

Sets the user validation method for complex values (list).

C#
void SetUserValidationComplex(UserValidationComplex ValidFunction);
Parameters
Parameters | Description
ValidFunction | The validation method.
Description
Interface

IUnitObject Interface

Links
IUnitObject Interface, REX.Controls.Common Namespace, IUnitObject Interface


IUnitObject.SetValue Method (Double)

IUnitObject.SetValue Method (Double)
IUnitObject Interface REX.Controls.Common Namespace IUnitObject Interface

Sets the value of the double type.

C#
void SetValue(Double value);
Parameters
Parameters | Description
value | The value.
Description
Interface

IUnitObject Interface

Links
IUnitObject Interface, REX.Controls.Common Namespace, IUnitObject Interface


IUnitObject.SetValue Method (String)

IUnitObject.SetValue Method (String)
IUnitObject Interface REX.Controls.Common Namespace IUnitObject Interface

Sets the value of the string type.

C#
void SetValue(String value);
Parameters
Parameters | Description
value | The value.
Description
Interface

IUnitObject Interface

Links
IUnitObject Interface, REX.Controls.Common Namespace, IUnitObject Interface


IUnitObject.Complex Property

IUnitObject.Complex Property
IUnitObject Interface REX.Controls.Common Namespace IUnitObject Interface

Gets or sets a value indicating whether this the control is in the complex mode (list mode).

C#
bool Complex;
Description

True if complex; otherwise false.

Interface

IUnitObject Interface

Links
IUnitObject Interface, REX.Controls.Common Namespace, IUnitObject Interface


IUnitObject.ControlState Property

IUnitObject.ControlState Property
IUnitObject Interface REX.Controls.Common Namespace IUnitObject Interface

Gets the state of the control.

C#
EControlState ControlState;
Description

The state of the control.

Interface

IUnitObject Interface

Links
IUnitObject Interface, REX.Controls.Common Namespace, IUnitObject Interface


IUnitObject.DataType Property

IUnitObject.DataType Property
IUnitObject Interface REX.Controls.Common Namespace IUnitObject Interface

Gets or sets the type of the data in the control.

C#
EControlType DataType;
Description

The type of the data.

Interface

IUnitObject Interface

Links
IUnitObject Interface, REX.Controls.Common Namespace, IUnitObject Interface


IUnitObject.EngineeringFormat Property

IUnitObject.EngineeringFormat Property
IUnitObject Interface REX.Controls.Common Namespace IUnitObject Interface

Gets or sets a value indicating whether the text of the control should be formatted in according to the engineering (expotential) format.

C#
Boolean EngineeringFormat;
Description

True if engineering format; otherwise false.

Interface

IUnitObject Interface

Links
IUnitObject Interface, REX.Controls.Common Namespace, IUnitObject Interface


IUnitObject.RangeMax Property

IUnitObject.RangeMax Property
IUnitObject Interface REX.Controls.Common Namespace IUnitObject Interface

Gets or sets the highest possible value.

C#
Double RangeMax;
Description

The highest possible value.

Interface

IUnitObject Interface

Links
IUnitObject Interface, REX.Controls.Common Namespace, IUnitObject Interface


IUnitObject.RangeMaxCheck Property

IUnitObject.RangeMaxCheck Property
IUnitObject Interface REX.Controls.Common Namespace IUnitObject Interface

Gets or sets a value indicating whether the value should be validated due to the RangeMax.

C#
Boolean RangeMaxCheck;
Description

True if validate; otherwise false.

Interface

IUnitObject Interface

Links
IUnitObject Interface, REX.Controls.Common Namespace, IUnitObject Interface


IUnitObject.RangeMin Property

IUnitObject.RangeMin Property
IUnitObject Interface REX.Controls.Common Namespace IUnitObject Interface

Gets or sets the minimum possible value.

C#
Double RangeMin;
Description

The minimum possible value.

Interface

IUnitObject Interface

Links
IUnitObject Interface, REX.Controls.Common Namespace, IUnitObject Interface


IUnitObject.RangeMinCheck Property

IUnitObject.RangeMinCheck Property
IUnitObject Interface REX.Controls.Common Namespace IUnitObject Interface

Gets or sets a value indicating whether the value should be validated due to the RangeMin.

C#
Boolean RangeMinCheck;
Description

True if validate; otherwise false.

Interface

IUnitObject Interface

Links
IUnitObject Interface, REX.Controls.Common Namespace, IUnitObject Interface


IUnitObject.RoundingFractional Property

IUnitObject.RoundingFractional Property
IUnitObject Interface REX.Controls.Common Namespace IUnitObject Interface

Gets or sets the rounding for fractional units.

C#
EFractialRound RoundingFractional;
Description

The rounding.

Interface

IUnitObject Interface

Links
IUnitObject Interface, REX.Controls.Common Namespace, IUnitObject Interface


IUnitObject.RoundingIncrement Property

IUnitObject.RoundingIncrement Property
IUnitObject Interface REX.Controls.Common Namespace IUnitObject Interface

Gets or sets the rounding increment.

C#
Double RoundingIncrement;
Description

The rounding increment.

Interface

IUnitObject Interface

Links
IUnitObject Interface, REX.Controls.Common Namespace, IUnitObject Interface


IUnitObject.Separator Property

IUnitObject.Separator Property
IUnitObject Interface REX.Controls.Common Namespace IUnitObject Interface

Gets or sets the decimal separator.

C#
String Separator;
Description

The separator.

Interface

IUnitObject Interface

Links
IUnitObject Interface, REX.Controls.Common Namespace, IUnitObject Interface


IUnitObject.Tag Property

IUnitObject.Tag Property
IUnitObject Interface REX.Controls.Common Namespace IUnitObject Interface

Gets or sets the tag.

C#
object Tag;
Description

The tag.

Interface

IUnitObject Interface

Links
IUnitObject Interface, REX.Controls.Common Namespace, IUnitObject Interface


IUnitObject.Text Property

IUnitObject.Text Property
IUnitObject Interface REX.Controls.Common Namespace IUnitObject Interface

Gets the text contents of the control.

C#
string Text;
Description

The text.

Interface

IUnitObject Interface

Links
IUnitObject Interface, REX.Controls.Common Namespace, IUnitObject Interface


IUnitObject.UnitSymbol Property

IUnitObject.UnitSymbol Property
IUnitObject Interface REX.Controls.Common Namespace IUnitObject Interface

Gets or sets the unit symbol.

C#
String UnitSymbol;
Description

The unit symbol.

Interface

IUnitObject Interface

Links
IUnitObject Interface, REX.Controls.Common Namespace, IUnitObject Interface


IUnitObject2 Interface

IUnitObject2 Interface
REX.Controls.Common Namespace Legend Members IUnitObject2 Methods

Defines common functionality for controls that are unit dependent.

Class Hierarchy
C#
public interface IUnitObject2 : IUnitObject;
Description
Namespace

REX.Controls.Common Namespace

IUnitObject2 Methods
IUnitObject2 Methods | Description
ValidateComplexValue | Validates the complex (list) value of the double type.
ValidateComplexValue | Validates the complex (list) value of the string type.
ValidateValue | Validates the input value of the double type.
ValidateValue | Validates the value of the string type.
Links
REX.Controls.Common Namespace, Legend, Members, IUnitObject2 Methods


IUnitObject2.ValidateComplexValue Method (List<double>)

IUnitObject2.ValidateComplexValue Method (List<double>)
IUnitObject2 Interface REX.Controls.Common Namespace IUnitObject2 Interface

Validates the complex (list) value of the double type.

C#
bool ValidateComplexValue(List<double> values);
Parameters
Parameters | Description
values | The values to validate.
Returns

True if validated; otherwise false.

Description
Interface

IUnitObject2 Interface

Links
IUnitObject2 Interface, REX.Controls.Common Namespace, IUnitObject2 Interface


IUnitObject2.ValidateComplexValue Method (List<string>)

IUnitObject2.ValidateComplexValue Method (List<string>)
IUnitObject2 Interface REX.Controls.Common Namespace IUnitObject2 Interface

Validates the complex (list) value of the string type.

C#
bool ValidateComplexValue(List<string> values);
Parameters
Parameters | Description
values | The values to validate.
Returns

True if validated; otherwise false.

Description
Interface

IUnitObject2 Interface

Links
IUnitObject2 Interface, REX.Controls.Common Namespace, IUnitObject2 Interface


IUnitObject2.ValidateValue Method (Double)

IUnitObject2.ValidateValue Method (Double)
IUnitObject2 Interface REX.Controls.Common Namespace IUnitObject2 Interface

Validates the input value of the double type.

C#
bool ValidateValue(Double value);
Parameters
Parameters | Description
value | The value to validate.
Returns

True if validated; otherwise false.

Description
Interface

IUnitObject2 Interface

Links
IUnitObject2 Interface, REX.Controls.Common Namespace, IUnitObject2 Interface


IUnitObject2.ValidateValue Method (String)

IUnitObject2.ValidateValue Method (String)
IUnitObject2 Interface REX.Controls.Common Namespace IUnitObject2 Interface

Validates the value of the string type.

C#
bool ValidateValue(String value);
Parameters
Parameters | Description
value | The value to validate.
Returns

True if validated; otherwise false.

Description
Interface

IUnitObject2 Interface

Links
IUnitObject2 Interface, REX.Controls.Common Namespace, IUnitObject2 Interface


IUnitObject3 Interface

IUnitObject3 Interface
REX.Controls.Common Namespace Legend Members IUnitObject3 Methods

Defines common functionality for controls that are unit dependent.

Class Hierarchy
C#
public interface IUnitObject3 : IUnitObject2;
Description
Namespace

REX.Controls.Common Namespace

IUnitObject3 Methods
IUnitObject3 Methods | Description
RefreshValidationStatus | Refreshes the validation status.
ValueFormat | Returns a text containing an expression formatted according the current settings of the element.
ValueFormat | Returns a text containing an expression formatted according the current settings of the element.
ValueParse | Converts the specified text to the numeric value according the current settings of the element.
Links
REX.Controls.Common Namespace, Legend, Members, IUnitObject3 Methods


IUnitObject3.RefreshValidationStatus Method

IUnitObject3.RefreshValidationStatus Method
IUnitObject3 Interface REX.Controls.Common Namespace IUnitObject3 Interface

Refreshes the validation status.

C#
void RefreshValidationStatus();
Description
Interface

IUnitObject3 Interface

Links
IUnitObject3 Interface, REX.Controls.Common Namespace, IUnitObject3 Interface


IUnitObject3.ValueFormat Method (Double)

IUnitObject3.ValueFormat Method (Double)
IUnitObject3 Interface REX.Controls.Common Namespace IUnitObject3 Interface

Returns a text containing an expression formatted according the current settings of the element.

C#
string ValueFormat(Double value);
Parameters
Parameters | Description
value | The value to format.
Returns

The formatted text.

Description
Interface

IUnitObject3 Interface

Links
IUnitObject3 Interface, REX.Controls.Common Namespace, IUnitObject3 Interface


IUnitObject3.ValueFormat Method (String)

IUnitObject3.ValueFormat Method (String)
IUnitObject3 Interface REX.Controls.Common Namespace IUnitObject3 Interface

Returns a text containing an expression formatted according the current settings of the element.

C#
string ValueFormat(String value);
Parameters
Parameters | Description
value | The value to format.
Returns

The formatted text.

Description
Interface

IUnitObject3 Interface

Links
IUnitObject3 Interface, REX.Controls.Common Namespace, IUnitObject3 Interface


IUnitObject3.ValueParse Method

IUnitObject3.ValueParse Method
IUnitObject3 Interface REX.Controls.Common Namespace IUnitObject3 Interface

Converts the specified text to the numeric value according the current settings of the element.

C#
double ValueParse(String value);
Parameters
Parameters | Description
value | The text.
Returns

The converted value.

Description
Interface

IUnitObject3 Interface

Links
IUnitObject3 Interface, REX.Controls.Common Namespace, IUnitObject3 Interface


REX.Controls.Common.EComboPropertiesType Enumeration

REX.Controls.Common.EComboPropertiesType Enumeration
REX.Controls.Common Namespace

An enumerated type listing all modes of the combo.

C#
public enum EComboPropertiesType {
  Main,
  List
}
Description
Namespace

REX.Controls.Common Namespace

Links
REX.Controls.Common Namespace
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REX.Controls.Forms Namespace

Previous | Next
REX.Controls.Forms Namespace
Legend Classes

This is namespace REX.Controls.Forms.

Classes
Class | Description
REXComboBox | Represents a REX combo box control.
REXEditBox | Represents the REXEditBox control.
REXImageComboBox | Combo box with images.
REXImageComboBoxItem | Represents the combobox item with an image inside.
REXIndexLabel | Represents the REXIndexLabel control.
REXPictureBox | This is class REX.Controls.Forms.REXPictureBox.
REXProgressBar | Represents a REX progress bar control.
REXUnitComboBox | Represents the REXUnitComboBox control with a IREXUnitEngine.
REXUnitEditBox | Represents the REXEditBox control with a IREXUnitEngine.
Links
Legend, Classes
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXComboBox Class

REXComboBox Class
REX.Controls.Forms Namespace Legend Members Public Methods REXComboBox Methods REXComboBox Properties

Represents a REX combo box control.

Class Hierarchy
C#
[ToolboxItem(true)]
[ToolboxBitmapAttribute(typeof(REXComboBox), "REXComboBox.Icon.bmp")]
public class REXComboBox : ComboBox, IUnitObject3, Common.IComboEditControl;
Description

It works in two modes: combo box mode, edit box mode.

Namespace

REX.Controls.Forms Namespace

Public Methods
Public Method | Description
REXComboBox | Initializes a new instance of the REXComboBox class.
REXComboBox Methods
REXComboBox Methods | Description
AddEnabledChangedHandler | Adds the handler to the event raised when the element changes it's enable state.
AddLostFocusHandler | Adds the handler to the event raised when the element loses logical focus.
AddTextChangedHandler | Adds the handler to the event raised when text changes.
Editable | Gets a value indicating whether the control is editable.
GetBackground | Gets the background of the control.
GetComplexDoubleValue | Gets the complex (list) value of the double type.
GetComplexStringValue | Returns a complex string list.
GetEnable | Indicates whether the control is enabled.
GetFullName | Gets the full name.
GetItems | Gets the collection of the items contained in the control.
GetLastCorrectValueStr | Gets the last correct stored value.
GetPropertiesType | Gets the mode of the combo.
GetSelectedIndex | Gets the index specifying the currently selected item.
GetState | Gets the current state of the control.
GetText | Gets the text contents of the control.
GetUniqueName | Returns the Unique ID generated for the current instance of the engine.
GetValue | Gets the value of the double type.
OnTextBoxModeChanged | Called when text box mode changes.
Refresh | Refreshes the text on the control based on the current text.
RefreshValidationStatus | Refreshes the validation status.
Reset | Resets control (internal values).
RestorePropertiesType | Restores the mode of the combo.
SetComplexValue | Sets the complex (list) value of the double type.
SetComplexValue | Sets the complex (list) value of the string type.
SetComplexValue | Sets the complex (list) value of the string type.
SetExternalUnitBody | Sets external IUnitBody object for custom unit processing.
SetPropertiesType | Sets the mode of the combo.
SetSelectedIndex | Sets the index specifying the currently selected item.
SetUserTextValidation | Sets the user validation method for the text control.
SetUserValidation | Sets the user validation method.
SetUserValidationComplex | Sets the user validation method for complex values (list).
SetValue | Sets the value of the double type.
SetValue | Sets the value of the string type.
ValidateComplexValue | Validates the complex (list) value of the double type.
ValidateComplexValue | Validates the complex (list) value of the string type.
ValidateComplexValue | Validates the complex (list) value of the string type.
ValidateValue | Validates the input value of the double type.
ValidateValue | Validates the value of the string type.
ValueFormat | Returns a text containing an expression formatted according the current settings of the element.
ValueFormat | Returns a text containing an expression formatted according the current settings of the element.
ValueParse | Converts the specified text to the numeric value according the current settings of the element.
REXComboBox Properties
REXComboBox Properties | Description
AcceptsTab | AcceptsTab property derived from the TextBox class.
ColorBackgroundDisabled | Gets or sets the background for the disabled state of the control in the hidden background mode.
ColorBackgroundError | Gets or sets the background for the Error state of the control.
ColorBackgroundNeutral | Gets or sets the background for the neutral state of the control.
ColorBackgroundOK | Gets or sets the background for the OK state of the control.
ColorBackgroundStandard | Gets or sets the background for the disabled state of the control.
Complex | Gets or sets a value indicating whether this REXEditControlEngine supports complex (list) values.
ComplexSeparator | Gets or sets the complex (list) separator.
ComplexSpaceSeparator | Gets or sets a value indicating whether a space should be respected as a list separator.
ComplexUnitOnEnd | Gets or sets a value indicating whether a unit symbol should be placed on the end of the formatted text.
ControlState | Gets the current state of the control.
CorrectValue | Gets or sets the correct value.
DataType | Gets or sets the type of the data in the control.
DropDownWidthLimit | Gets or sets the drop down width limit.
EditBox | Gets the reference to the REXEditBox control.
Enabled | Gets or sets a value indicating whether the control can respond to user interaction.
EngineeringFormat | Gets or sets a value indicating whether the text of the control should be formatted in according to the engineering (expotential) format.
Epsilon | Gets or sets the accuracy.
InvalidCharacters | Gets or sets the list invalid characters (for the control in TEXT mode).
ListValidation | Gets or sets a value indicating whether the list should be validated.
MaxTokens | Gets or sets the maximum number of elements in the complex mode (list).
MinTokens | Gets or sets the minimum number of elements in the complex mode (list).
Name | Gets or sets the name of the control.
OnDisableAction | Gets or sets a value indicating whether the foreground should be hidden when the control is disabled.
OriginalTextOnEnter | Gets or sets a value indicating whether an original text should be set when the user enters the control.
RangeMax | Gets or sets the highest possible value.
RangeMaxCheck | Gets or sets a value indicating whether the value should be validated due to the RangeMax.
RangeMin | Gets or sets the minimum possible value.
RangeMinCheck | Gets or sets a value indicating whether the value should be validated due to the RangeMin.
RememberCorrect | Gets or sets a value indicating whether the correct value should be restored in case of the validation failure.
RoundingFractional | Gets or sets the rounding for fractional units.
RoundingIncrement | Gets or sets the rounding increment (for the DECIMAL DataType).
Separator | Gets or sets the decimal separator.
TabIndex | Gets or sets the tab order of the control within its container.
Text | Gets the text contents of the control.
TextAlign | Gets or sets the text alignment.
TextBoxMode | Gets or sets a value indicating whether the combobox is in the editbox mode.
TokensRangeMaxCheck | Gets or sets a value indicating whether the number of elements should be validated due to the MaxTokens.
TokensRangeMinCheck | Gets or sets a value indicating whether the number of elements should be validated due to the MinTokens.
UnitSymbol | Gets or sets the unit symbol.
Links
REX.Controls.Forms Namespace, Legend, Members, Public Methods, REXComboBox Methods, REXComboBox Properties


REXComboBox.REXComboBox Constructor

REXComboBox.REXComboBox Constructor
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Initializes a new instance of the REXComboBox class.

C#
public REXComboBox();
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.AddEnabledChangedHandler Method

REXComboBox.AddEnabledChangedHandler Method
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Adds the handler to the event raised when the element changes it's enable state.

C#
public void AddEnabledChangedHandler(EventHandler eh);
Parameters
Parameters | Description
eh | The event handler.
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.AddLostFocusHandler Method

REXComboBox.AddLostFocusHandler Method
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Adds the handler to the event raised when the element loses logical focus.

C#
public void AddLostFocusHandler(EventHandler eh);
Parameters
Parameters | Description
eh | The event handler.
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.AddTextChangedHandler Method

REXComboBox.AddTextChangedHandler Method
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Adds the handler to the event raised when text changes.

C#
public void AddTextChangedHandler(EventHandler eh);
Parameters
Parameters | Description
eh | The event handler.
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.Editable Method

REXComboBox.Editable Method
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets a value indicating whether the control is editable.

C#
public bool Editable();
Returns

True if the control can be edited; otherwise false.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.GetBackground Method

REXComboBox.GetBackground Method
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets the background of the control.

C#
public object GetBackground();
Returns

The background.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.GetComplexDoubleValue Method

REXComboBox.GetComplexDoubleValue Method
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets the complex (list) value of the double type.

C#
public List<double> GetComplexDoubleValue();
Returns

The list of values.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.GetComplexStringValue Method

REXComboBox.GetComplexStringValue Method
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Returns a complex string list.

C#
public List<string> GetComplexStringValue();
Returns

The list of values.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.GetEnable Method

REXComboBox.GetEnable Method
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Indicates whether the control is enabled.

C#
public bool GetEnable();
Returns

True if the element is enabled; otherwise, false.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.GetFullName Method

REXComboBox.GetFullName Method
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets the full name.

C#
public string GetFullName();
Returns

The full name.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.GetItems Method

REXComboBox.GetItems Method
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets the collection of the items contained in the control.

C#
public List<string> GetItems();
Returns

The list of items.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.GetLastCorrectValueStr Method

REXComboBox.GetLastCorrectValueStr Method
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets the last correct stored value.

C#
public String GetLastCorrectValueStr();
Returns

The correct value.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.GetPropertiesType Method

REXComboBox.GetPropertiesType Method
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets the mode of the combo.

C#
public EComboPropertiesType GetPropertiesType();
Returns

The mode of the combo box.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.GetSelectedIndex Method

REXComboBox.GetSelectedIndex Method
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets the index specifying the currently selected item.

C#
public int GetSelectedIndex();
Returns

The index.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.GetState Method

REXComboBox.GetState Method
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets the current state of the control.

C#
public EControlState GetState();
Returns

The state of the control.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.GetText Method

REXComboBox.GetText Method
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets the text contents of the control.

C#
public string GetText();
Returns

The text contents of the control.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.GetUniqueName Method

REXComboBox.GetUniqueName Method
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Returns the Unique ID generated for the current instance of the engine.

C#
public string GetUniqueName();
Returns

The unique ID.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.GetValue Method

REXComboBox.GetValue Method
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets the value of the double type.

C#
public double GetValue();
Returns

The value.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.OnTextBoxModeChanged Method

REXComboBox.OnTextBoxModeChanged Method
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Called when text box mode changes.

C#
public virtual void OnTextBoxModeChanged();
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.Refresh Method

REXComboBox.Refresh Method
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Refreshes the text on the control based on the current text.

C#
public void Refresh();
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.RefreshValidationStatus Method

REXComboBox.RefreshValidationStatus Method
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Refreshes the validation status.

C#
public void RefreshValidationStatus();
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.Reset Method

REXComboBox.Reset Method
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Resets control (internal values).

C#
public void Reset();
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.RestorePropertiesType Method

REXComboBox.RestorePropertiesType Method
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Restores the mode of the combo.

C#
public void RestorePropertiesType();
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.SetComplexValue Method (List<double>)

REXComboBox.SetComplexValue Method (List<double>)
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Sets the complex (list) value of the double type.

C#
public void SetComplexValue(List<double> values);
Parameters
Parameters | Description
values | The list of values.
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.SetComplexValue Method (List<string>)

REXComboBox.SetComplexValue Method (List<string>)
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Sets the complex (list) value of the string type.

C#
public void SetComplexValue(List<string> values);
Parameters
Parameters | Description
values | The list of values.
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.SetComplexValue Method (String)

REXComboBox.SetComplexValue Method (String)
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Sets the complex (list) value of the string type.

C#
public bool SetComplexValue(String value);
Parameters
Parameters | Description
value | The value.
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.SetExternalUnitBody Method

REXComboBox.SetExternalUnitBody Method
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Sets external IUnitBody object for custom unit processing.

C#
public void SetExternalUnitBody(IUnitBody unitBody);
Parameters
Parameters | Description
unitBody | External IUnitBody.
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.SetPropertiesType Method

REXComboBox.SetPropertiesType Method
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Sets the mode of the combo.

C#
public void SetPropertiesType(EComboPropertiesType propertiesType);
Parameters
Parameters | Description
propertiesType | The mode of the combo.
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.SetSelectedIndex Method

REXComboBox.SetSelectedIndex Method
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Sets the index specifying the currently selected item.

C#
public void SetSelectedIndex(int index);
Parameters
Parameters | Description
index | The index of the selected item.
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.SetUserTextValidation Method

REXComboBox.SetUserTextValidation Method
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Sets the user validation method for the text control.

C#
public void SetUserTextValidation(UserTextValidation ValidFunction);
Parameters
Parameters | Description
ValidFunction | The validation method.
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.SetUserValidation Method

REXComboBox.SetUserValidation Method
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Sets the user validation method.

C#
public void SetUserValidation(UserValidation ValidFunction);
Parameters
Parameters | Description
ValidFunction | The validation method.
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.SetUserValidationComplex Method

REXComboBox.SetUserValidationComplex Method
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Sets the user validation method for complex values (list).

C#
public void SetUserValidationComplex(UserValidationComplex ValidFunction);
Parameters
Parameters | Description
ValidFunction | The validation method.
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.SetValue Method (Double)

REXComboBox.SetValue Method (Double)
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Sets the value of the double type.

C#
public void SetValue(Double value);
Parameters
Parameters | Description
value | The value.
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.SetValue Method (String)

REXComboBox.SetValue Method (String)
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Sets the value of the string type.

C#
public void SetValue(String value);
Parameters
Parameters | Description
value | The value.
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.ValidateComplexValue Method (List<double>)

REXComboBox.ValidateComplexValue Method (List<double>)
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Validates the complex (list) value of the double type.

C#
public bool ValidateComplexValue(List<double> values);
Parameters
Parameters | Description
values | The values to validate.
Returns

True if validated; otherwise false.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.ValidateComplexValue Method (List<string>)

REXComboBox.ValidateComplexValue Method (List<string>)
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Validates the complex (list) value of the string type.

C#
public bool ValidateComplexValue(List<string> values);
Parameters
Parameters | Description
values | The values to validate.
Returns

True if validated; otherwise false.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.ValidateComplexValue Method (String)

REXComboBox.ValidateComplexValue Method (String)
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Validates the complex (list) value of the string type.

C#
public bool ValidateComplexValue(String value);
Parameters
Parameters | Description
value | The value to validate.
Returns

True if validated; otherwise false.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.ValidateValue Method (Double)

REXComboBox.ValidateValue Method (Double)
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Validates the input value of the double type.

C#
public bool ValidateValue(Double value);
Parameters
Parameters | Description
value | The value to validate.
Returns

True if validated; otherwise false.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.ValidateValue Method (String)

REXComboBox.ValidateValue Method (String)
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Validates the value of the string type.

C#
public bool ValidateValue(String value);
Parameters
Parameters | Description
value | The value to validate.
Returns

True if validated; otherwise false.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.ValueFormat Method (Double)

REXComboBox.ValueFormat Method (Double)
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Returns a text containing an expression formatted according the current settings of the element.

C#
public string ValueFormat(Double value);
Parameters
Parameters | Description
value | The value to format.
Returns

The formatted text.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.ValueFormat Method (String)

REXComboBox.ValueFormat Method (String)
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Returns a text containing an expression formatted according the current settings of the element.

C#
public string ValueFormat(String value);
Parameters
Parameters | Description
value | The value to format.
Returns

The formatted text.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.ValueParse Method

REXComboBox.ValueParse Method
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Converts the specified text to the numeric value according the current settings of the element.

C#
public double ValueParse(String value);
Parameters
Parameters | Description
value | The text.
Returns

The converted value.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.AcceptsTab Property

REXComboBox.AcceptsTab Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

AcceptsTab property derived from the TextBox class.

C#
[Browsable(false)]
public new Boolean AcceptsTab;
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.ColorBackgroundDisabled Property

REXComboBox.ColorBackgroundDisabled Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets or sets the background for the disabled state of the control in the hidden background mode.

C#
[Browsable(true)]
[Category("Appearance")]
public Color ColorBackgroundDisabled;
Description

The background.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.ColorBackgroundError Property

REXComboBox.ColorBackgroundError Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets or sets the background for the Error state of the control.

C#
[Browsable(true)]
[Category("Appearance")]
[DefaultValue(typeof(Color), "LightCoral")]
public Color ColorBackgroundError;
Description

The Error background.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.ColorBackgroundNeutral Property

REXComboBox.ColorBackgroundNeutral Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets or sets the background for the neutral state of the control.

C#
[Browsable(true)]
[Category("Appearance")]
[DefaultValue(typeof(SystemColors), "Window")]
public Color ColorBackgroundNeutral;
Description

The neutral background.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.ColorBackgroundOK Property

REXComboBox.ColorBackgroundOK Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets or sets the background for the OK state of the control.

C#
[Browsable(true)]
[Category("Appearance")]
[DefaultValue(typeof(Color), "LightGreen")]
[Description("test")]
public Color ColorBackgroundOK;
Description

The OK background.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.ColorBackgroundStandard Property

REXComboBox.ColorBackgroundStandard Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets or sets the background for the disabled state of the control.

C#
[Browsable(true)]
[Category("Appearance")]
[DefaultValue(typeof(Color), "LightBlue")]
public Color ColorBackgroundStandard;
Description

The background.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.Complex Property

REXComboBox.Complex Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets or sets a value indicating whether this REXEditControlEngine supports complex (list) values.

C#
[Category("Complex")]
[Browsable(true)]
public Boolean Complex;
Description

True if the engine supports complex values; otherwise false.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.ComplexSeparator Property

REXComboBox.ComplexSeparator Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets or sets the complex (list) separator.

C#
[Category("Complex")]
[Browsable(true)]
[DefaultValue(";")]
public string ComplexSeparator;
Description

The complex separator.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.ComplexSpaceSeparator Property

REXComboBox.ComplexSpaceSeparator Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets or sets a value indicating whether a space should be respected as a list separator.

C#
[Category("Complex")]
[Browsable(true)]
public Boolean ComplexSpaceSeparator;
Description

True if space respected as a list separator; otherwise, false.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.ComplexUnitOnEnd Property

REXComboBox.ComplexUnitOnEnd Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets or sets a value indicating whether a unit symbol should be placed on the end of the formatted text.

C#
[Category("Complex")]
[Browsable(true)]
public Boolean ComplexUnitOnEnd;
Description

True if the unit one the end; otherwise, false.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.ControlState Property

REXComboBox.ControlState Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets the current state of the control.

C#
[Browsable(false)]
public EControlState ControlState;
Description

The state of the control.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.CorrectValue Property

REXComboBox.CorrectValue Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets or sets the correct value.

C#
[Browsable(false)]
public String CorrectValue;
Description

The correct value.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.DataType Property

REXComboBox.DataType Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets or sets the type of the data in the control.

C#
[Browsable(true)]
[Category("Data")]
public REX.Controls.Common.EControlType DataType;
Description

The type of the data.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.DropDownWidthLimit Property

REXComboBox.DropDownWidthLimit Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets or sets the drop down width limit.

C#
public int DropDownWidthLimit;
Description

The drop down width limit.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.EditBox Property

REXComboBox.EditBox Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets the reference to the REXEditBox control.

C#
public REX.Controls.Forms.REXEditBox EditBox;
Description

Enables settings for edit box mode.

The REXEditBox control.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.Enabled Property

REXComboBox.Enabled Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets or sets a value indicating whether the control can respond to user interaction.

C#
[Browsable(true)]
public new Boolean Enabled;
Returns

true if the control can respond to user interaction; otherwise, false. The default is true.

Description

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.EngineeringFormat Property

REXComboBox.EngineeringFormat Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets or sets a value indicating whether the text of the control should be formatted in according to the engineering (expotential) format.

C#
[Browsable(true)]
[Category("Data")]
[DefaultValue(false)]
public Boolean EngineeringFormat;
Description

True if engineering format; otherwise false.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.Epsilon Property

REXComboBox.Epsilon Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets or sets the accuracy.

C#
[Browsable(true)]
public double Epsilon;
Description

The accuracy.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.InvalidCharacters Property

REXComboBox.InvalidCharacters Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets or sets the list invalid characters (for the control in TEXT mode).

C#
[Browsable(true)]
public string InvalidCharacters;
Description

The list of invalid characters.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.ListValidation Property

REXComboBox.ListValidation Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets or sets a value indicating whether the list should be validated.

C#
public bool ListValidation;
Description

True if validate; otherwise false.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.MaxTokens Property

REXComboBox.MaxTokens Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets or sets the maximum number of elements in the complex mode (list).

C#
[Category("Complex")]
[Browsable(true)]
public int MaxTokens;
Description

The maximum number of elements.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.MinTokens Property

REXComboBox.MinTokens Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets or sets the minimum number of elements in the complex mode (list).

C#
[Category("Complex")]
[Browsable(true)]
public int MinTokens;
Description

The minimum number of elements.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.Name Property

REXComboBox.Name Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets or sets the name of the control.

C#
public new string Name;
Returns

The name of the control. The default is an empty string ("").

Description

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.OnDisableAction Property

REXComboBox.OnDisableAction Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets or sets a value indicating whether the foreground should be hidden when the control is disabled.

C#
[Browsable(true)]
[Category("Data")]
public EOnDisable OnDisableAction;
Description

The behaviour of the control's foreground.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.OriginalTextOnEnter Property

REXComboBox.OriginalTextOnEnter Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets or sets a value indicating whether an original text should be set when the user enters the control.

C#
[Browsable(true)]
[Category("Behavior")]
public bool OriginalTextOnEnter;
Description

True if original text is to be set; otherwise, false.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.RangeMax Property

REXComboBox.RangeMax Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets or sets the highest possible value.

C#
[Browsable(true)]
[Category("Data")]
[DefaultValue(Double.PositiveInfinity)]
public Double RangeMax;
Description

The highest possible value.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.RangeMaxCheck Property

REXComboBox.RangeMaxCheck Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets or sets a value indicating whether the value should be validated due to the RangeMax.

C#
[Browsable(true)]
[Category("Data")]
[DefaultValue(false)]
public Boolean RangeMaxCheck;
Description

True if validate; otherwise false.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.RangeMin Property

REXComboBox.RangeMin Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets or sets the minimum possible value.

C#
[Browsable(true)]
[Category("Data")]
[DefaultValue(Double.NegativeInfinity)]
public Double RangeMin;
Description

The minimum possible value.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.RangeMinCheck Property

REXComboBox.RangeMinCheck Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets or sets a value indicating whether the value should be validated due to the RangeMin.

C#
[Browsable(true)]
[Category("Data")]
[DefaultValue(false)]
public Boolean RangeMinCheck;
Description

True if validate; otherwise false.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.RememberCorrect Property

REXComboBox.RememberCorrect Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets or sets a value indicating whether the correct value should be restored in case of the validation failure.

C#
[Browsable(true)]
[Category("Data")]
public Boolean RememberCorrect;
Description

True if the value should be restored; otherwise false.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.RoundingFractional Property

REXComboBox.RoundingFractional Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets or sets the rounding for fractional units.

C#
[Browsable(true)]
[Category("Data")]
public EFractialRound RoundingFractional;
Description

The rounding.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.RoundingIncrement Property

REXComboBox.RoundingIncrement Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets or sets the rounding increment (for the DECIMAL DataType).

C#
[Browsable(true)]
[Category("Data")]
public Double RoundingIncrement;
Description

The rounding increment.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.Separator Property

REXComboBox.Separator Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets or sets the decimal separator.

C#
[Browsable(true)]
[Category("Data")]
public String Separator;
Description

The separator.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.TabIndex Property

REXComboBox.TabIndex Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets or sets the tab order of the control within its container.

C#
public new int TabIndex;
Returns

The index value of the control within the set of controls within its container. The controls in the container are included in the tab order.

Description

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.Text Property

REXComboBox.Text Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets the text contents of the control.

C#
[Browsable(true)]
public new string Text;
Description

The text.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.TextAlign Property

REXComboBox.TextAlign Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets or sets the text alignment.

C#
public HorizontalAlignment TextAlign;
Description

The text alignment.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.TextBoxMode Property

REXComboBox.TextBoxMode Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets or sets a value indicating whether the combobox is in the editbox mode.

C#
[Browsable(true)]
public bool TextBoxMode;
Description

True if the control is in editbox mode; otherwise, false.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.TokensRangeMaxCheck Property

REXComboBox.TokensRangeMaxCheck Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets or sets a value indicating whether the number of elements should be validated due to the MaxTokens.

C#
[Category("Complex")]
[Browsable(true)]
[DefaultValue(false)]
public Boolean TokensRangeMaxCheck;
Description

True if validate; otherwise, false.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.TokensRangeMinCheck Property

REXComboBox.TokensRangeMinCheck Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets or sets a value indicating whether the number of elements should be validated due to the MinTokens.

C#
[Category("Complex")]
[Browsable(true)]
[DefaultValue(false)]
public Boolean TokensRangeMinCheck;
Description

True if validate; otherwise, false.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXComboBox.UnitSymbol Property

REXComboBox.UnitSymbol Property
REXComboBox Class REX.Controls.Forms Namespace REXComboBox Class

Gets or sets the unit symbol.

C#
[Browsable(true)]
[Category("Data")]
[DefaultValue("")]
public String UnitSymbol;
Description

The unit symbol.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.Forms Namespace, REXComboBox Class


REXEditBox Class

REXEditBox Class
REX.Controls.Forms Namespace Legend Members Public Methods REXEditBox Methods REXEditBox Properties

Represents the REXEditBox control.

Class Hierarchy
C#
[ToolboxItem(true)]
[ToolboxBitmapAttribute(typeof(REXEditBox),"REXEditBox.Icon.bmp")]
public class REXEditBox : TextBox, IUnitObject3, REX.Controls.Common.IEditControl;
Description
Namespace

REX.Controls.Forms Namespace

Public Methods
Public Method | Description
REXEditBox | Initializes a new instance of the REXEditBox class.
REXEditBox Methods
REXEditBox Methods | Description
AddEnabledChangedHandler | Adds the handler to the event raised when the element changes it's enable state.
AddLostFocusHandler | Adds the handler to the event raised when the element loses logical focus.
AddTextChangedHandler | Adds the handler to the event raised when text changes.
GetBackground | Gets the background of the control.
GetComplexDoubleValue | Gets the complex (list) value of the double type.
GetComplexStringValue | Returns a complex string list.
GetEnable | Indicates whether the control is enabled.
GetFullName | Gets the full name.
GetLastCorrectValueStr | Gets the last correct stored value.
GetState | Gets the current state of the control.
GetStringValue | Returns the original text.
GetText | Gets the text contents of the control.
GetUniqueName | Returns the Unique ID generated for the current instance of the engine.
GetValue | Gets the value of the double type.
Refresh | Refreshes the text on the control based on the current text.
RefreshValidationStatus | Refreshes the validation status.
Reset | Resets control (internal values).
SetBackground | Sets the background of the control.
SetComplexValue | Sets the complex (list) value of the double type.
SetComplexValue | Sets the complex (list) value of the string type.
SetComplexValue | Sets the complex (list) value of the string type.
SetEnable | Sets the enable state.
SetExternalUnitBody | Sets external IUnitBody object for custom unit processing.
SetText | Sets the text contents of the control.
SetUserTextValidation | Sets the user validation method for the text control.
SetUserValidation | Sets the user validation method.
SetUserValidationComplex | Sets the user validation method for complex values (list).
SetValue | Sets the value of the double type.
SetValue | Sets the value of the string type.
ValidateComplexValue | Validates the complex (list) value of the double type.
ValidateComplexValue | Validates the complex (list) value of the string type.
ValidateComplexValue | Validates the complex (list) value of the string type.
ValidateValue | Validates the input value of the double type.
ValidateValue | Validates the value of the string type.
ValueFormat | Returns a text containing an expression formatted according the current settings of the element.
ValueFormat | Returns a text containing an expression formatted according the current settings of the element.
ValueParse | Converts the specified text to the numeric value according the current settings of the element.
REXEditBox Properties
REXEditBox Properties | Description
AcceptsTab | AcceptsTab property derived from the TextBox class.
ColorBackgroundDisabled | Gets or sets the background for the disabled state of the control in the hidden background mode.
ColorBackgroundError | Gets or sets the background for the Error state of the control.
ColorBackgroundNeutral | Gets or sets the background for the neutral state of the control.
ColorBackgroundOK | Gets or sets the background for the OK state of the control.
ColorBackgroundStandard | Gets or sets the background for the disabled state of the control.
Complex | Gets or sets a value indicating whether this REXEditControlEngine supports complex (list) values.
ComplexSeparator | Gets or sets the complex (list) separator.
ComplexSpaceSeparator | Gets or sets a value indicating whether a space should be respected as a list separator.
ComplexUnitOnEnd | Gets or sets a value indicating whether a unit symbol should be placed on the end of the formatted text.
ControlState | Gets the current state of the control.
CorrectValue | Gets or sets the correct value.
DataType | Gets or sets the type of the data in the control.
Enabled | Gets or sets a value indicating whether the control can respond to user interaction.
EngineeringFormat | Gets or sets a value indicating whether the text of the control should be formatted in according to the engineering (expotential) format.
Epsilon | Gets or sets the accuracy.
InvalidCharacters | Gets or sets the list invalid characters (for the control in TEXT mode).
MaxTokens | Gets or sets the maximum number of elements in the complex mode (list).
MinTokens | Gets or sets the minimum number of elements in the complex mode (list).
Multiline | Gets or sets a value indicating whether this is a multiline T:System.Windows.Forms.TextBox control.
OnDisableAction | Gets or sets a value indicating whether the foreground should be hidden when the control is disabled.
OriginalTextOnEnter | Gets or sets a value indicating whether an original text should be set when the user enters the control.
PasswordChar | Gets or sets the character used to mask characters of a password in a single-line T:System.Windows.Forms.TextBox control.
RangeMax | Gets or sets the highest possible value.
RangeMaxCheck | Gets or sets a value indicating whether the value should be validated due to the RangeMax.
RangeMin | Gets or sets the minimum possible value.
RangeMinCheck | Gets or sets a value indicating whether the value should be validated due to the RangeMin.
RememberCorrect | Gets or sets a value indicating whether the correct value should be restored in case of the validation failure.
RoundingFractional | Gets or sets the rounding for fractional units.
RoundingIncrement | Gets or sets the rounding increment (for the DECIMAL DataType).
Separator | Gets or sets the decimal separator.
Text | Gets the text contents of the control.
TokensRangeMaxCheck | Gets or sets a value indicating whether the number of elements should be validated due to the MaxTokens.
TokensRangeMinCheck | Gets or sets a value indicating whether the number of elements should be validated due to the MinTokens.
UnitSymbol | Gets or sets the unit symbol.
UseSystemPasswordChar | Gets or sets a value indicating whether the text in the T:System.Windows.Forms.TextBox control should appear as the default password character.
WordWrap | Indicates whether a multiline text box control automatically wraps words to the beginning of the next line when necessary.
Links
REX.Controls.Forms Namespace, Legend, Members, Public Methods, REXEditBox Methods, REXEditBox Properties


REXEditBox.REXEditBox Constructor

REXEditBox.REXEditBox Constructor
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Initializes a new instance of the REXEditBox class.

C#
public REXEditBox();
Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class


REXEditBox.AddEnabledChangedHandler Method

REXEditBox.AddEnabledChangedHandler Method
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Adds the handler to the event raised when the element changes it's enable state.

C#
public void AddEnabledChangedHandler(EventHandler eh);
Parameters
Parameters | Description
eh | The event handler.
Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class


REXEditBox.AddLostFocusHandler Method

REXEditBox.AddLostFocusHandler Method
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Adds the handler to the event raised when the element loses logical focus.

C#
public void AddLostFocusHandler(EventHandler eh);
Parameters
Parameters | Description
eh | The event handler.
Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class


REXEditBox.AddTextChangedHandler Method

REXEditBox.AddTextChangedHandler Method
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Adds the handler to the event raised when text changes.

C#
public void AddTextChangedHandler(EventHandler eh);
Parameters
Parameters | Description
eh | The event handler.
Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class


REXEditBox.GetBackground Method

REXEditBox.GetBackground Method
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets the background of the control.

C#
public object GetBackground();
Returns

The background.

Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class


REXEditBox.GetComplexDoubleValue Method

REXEditBox.GetComplexDoubleValue Method
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets the complex (list) value of the double type.

C#
public List<double> GetComplexDoubleValue();
Returns

The list of values.

Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class


REXEditBox.GetComplexStringValue Method

REXEditBox.GetComplexStringValue Method
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Returns a complex string list.

C#
public List<string> GetComplexStringValue();
Returns

The list of values.

Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class


REXEditBox.GetEnable Method

REXEditBox.GetEnable Method
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Indicates whether the control is enabled.

C#
public bool GetEnable();
Returns

True if the element is enabled; otherwise, false.

Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class


REXEditBox.GetFullName Method

REXEditBox.GetFullName Method
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets the full name.

C#
public string GetFullName();
Returns

The full name.

Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class


REXEditBox.GetLastCorrectValueStr Method

REXEditBox.GetLastCorrectValueStr Method
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets the last correct stored value.

C#
public String GetLastCorrectValueStr();
Returns

The correct value.

Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class


REXEditBox.GetState Method

REXEditBox.GetState Method
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets the current state of the control.

C#
public EControlState GetState();
Returns

The state of the control.

Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class


REXEditBox.GetStringValue Method

REXEditBox.GetStringValue Method
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Returns the original text.

C#
public string GetStringValue();
Returns

The text value.

Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class


REXEditBox.GetText Method

REXEditBox.GetText Method
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets the text contents of the control.

C#
public string GetText();
Returns

The text contents of the control.

Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class


REXEditBox.GetUniqueName Method

REXEditBox.GetUniqueName Method
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Returns the Unique ID generated for the current instance of the engine.

C#
public string GetUniqueName();
Returns

The unique ID.

Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class


REXEditBox.GetValue Method

REXEditBox.GetValue Method
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets the value of the double type.

C#
public double GetValue();
Returns

The value.

Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class


REXEditBox.Refresh Method

REXEditBox.Refresh Method
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Refreshes the text on the control based on the current text.

C#
public void Refresh();
Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class


REXEditBox.RefreshValidationStatus Method

REXEditBox.RefreshValidationStatus Method
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Refreshes the validation status.

C#
public void RefreshValidationStatus();
Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class


REXEditBox.Reset Method

REXEditBox.Reset Method
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Resets control (internal values).

C#
public void Reset();
Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class


REXEditBox.SetBackground Method

REXEditBox.SetBackground Method
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Sets the background of the control.

C#
public void SetBackground(object color);
Parameters
Parameters | Description
background | The background.
Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class


REXEditBox.SetComplexValue Method (List<double>)

REXEditBox.SetComplexValue Method (List<double>)
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Sets the complex (list) value of the double type.

C#
public void SetComplexValue(List<double> values);
Parameters
Parameters | Description
values | The list of values.
Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class


REXEditBox.SetComplexValue Method (List<string>)

REXEditBox.SetComplexValue Method (List<string>)
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Sets the complex (list) value of the string type.

C#
public void SetComplexValue(List<string> values);
Parameters
Parameters | Description
values | The list of values.
Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class


REXEditBox.SetComplexValue Method (String)

REXEditBox.SetComplexValue Method (String)
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Sets the complex (list) value of the string type.

C#
public bool SetComplexValue(String value);
Parameters
Parameters | Description
value | The value.
Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class


REXEditBox.SetEnable Method

REXEditBox.SetEnable Method
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Sets the enable state.

C#
public void SetEnable(bool enable);
Parameters
Parameters | Description
enable | If the control is to be enabled.
Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class


REXEditBox.SetExternalUnitBody Method

REXEditBox.SetExternalUnitBody Method
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Sets external IUnitBody object for custom unit processing.

C#
public void SetExternalUnitBody(IUnitBody unitBody);
Parameters
Parameters | Description
unitBody | External IUnitBody.
Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class


REXEditBox.SetText Method

REXEditBox.SetText Method
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Sets the text contents of the control.

C#
public void SetText(string txt);
Parameters
Parameters | Description
txt | The text.
Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class


REXEditBox.SetUserTextValidation Method

REXEditBox.SetUserTextValidation Method
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Sets the user validation method for the text control.

C#
public void SetUserTextValidation(UserTextValidation ValidFunction);
Parameters
Parameters | Description
ValidFunction | The validation method.
Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class


REXEditBox.SetUserValidation Method

REXEditBox.SetUserValidation Method
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Sets the user validation method.

C#
public void SetUserValidation(UserValidation ValidFunction);
Parameters
Parameters | Description
ValidFunction | The validation method.
Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class


REXEditBox.SetUserValidationComplex Method

REXEditBox.SetUserValidationComplex Method
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Sets the user validation method for complex values (list).

C#
public void SetUserValidationComplex(UserValidationComplex ValidFunction);
Parameters
Parameters | Description
ValidFunction | The validation method.
Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class


REXEditBox.SetValue Method (Double)

REXEditBox.SetValue Method (Double)
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Sets the value of the double type.

C#
public void SetValue(Double value);
Parameters
Parameters | Description
value | The value.
Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class


REXEditBox.SetValue Method (String)

REXEditBox.SetValue Method (String)
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Sets the value of the string type.

C#
public void SetValue(String value);
Parameters
Parameters | Description
value | The value.
Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class


REXEditBox.ValidateComplexValue Method (List<double>)

REXEditBox.ValidateComplexValue Method (List<double>)
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Validates the complex (list) value of the double type.

C#
public bool ValidateComplexValue(List<double> values);
Parameters
Parameters | Description
values | The values to validate.
Returns

True if validated; otherwise false.

Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class


REXEditBox.ValidateComplexValue Method (List<string>)

REXEditBox.ValidateComplexValue Method (List<string>)
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Validates the complex (list) value of the string type.

C#
public bool ValidateComplexValue(List<string> values);
Parameters
Parameters | Description
values | The values to validate.
Returns

True if validated; otherwise false.

Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class


REXEditBox.ValidateComplexValue Method (String)

REXEditBox.ValidateComplexValue Method (String)
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Validates the complex (list) value of the string type.

C#
public bool ValidateComplexValue(String value);
Parameters
Parameters | Description
value | The value to validate.
Returns

True if validated; otherwise false.

Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class


REXEditBox.ValidateValue Method (Double)

REXEditBox.ValidateValue Method (Double)
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Validates the input value of the double type.

C#
public bool ValidateValue(Double value);
Parameters
Parameters | Description
value | The value to validate.
Returns

True if validated; otherwise false.

Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class


REXEditBox.ValidateValue Method (String)

REXEditBox.ValidateValue Method (String)
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Validates the value of the string type.

C#
public bool ValidateValue(String value);
Parameters
Parameters | Description
value | The value to validate.
Returns

True if validated; otherwise false.

Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class


REXEditBox.ValueFormat Method (Double)

REXEditBox.ValueFormat Method (Double)
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Returns a text containing an expression formatted according the current settings of the element.

C#
public string ValueFormat(Double value);
Parameters
Parameters | Description
value | The value to format.
Returns

The formatted text.

Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class


REXEditBox.ValueFormat Method (String)

REXEditBox.ValueFormat Method (String)
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Returns a text containing an expression formatted according the current settings of the element.

C#
public string ValueFormat(String value);
Parameters
Parameters | Description
value | The value to format.
Returns

The formatted text.

Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class


REXEditBox.ValueParse Method

REXEditBox.ValueParse Method
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Converts the specified text to the numeric value according the current settings of the element.

C#
public double ValueParse(String value);
Parameters
Parameters | Description
value | The text.
Returns

The converted value.

Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class


REXEditBox.AcceptsTab Property

REXEditBox.AcceptsTab Property
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

AcceptsTab property derived from the TextBox class.

C#
[Browsable(false)]
public new Boolean AcceptsTab;
Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class


REXEditBox.ColorBackgroundDisabled Property

REXEditBox.ColorBackgroundDisabled Property
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets or sets the background for the disabled state of the control in the hidden background mode.

C#
[Browsable(true)]
[Category("Appearance")]
public Color ColorBackgroundDisabled;
Description

The background.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class


REXEditBox.ColorBackgroundError Property

REXEditBox.ColorBackgroundError Property
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets or sets the background for the Error state of the control.

C#
[Browsable(true)]
[Category("Appearance")]
[DefaultValue(typeof(Color), "LightCoral")]
public Color ColorBackgroundError;
Description

The Error background.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class


REXEditBox.ColorBackgroundNeutral Property

REXEditBox.ColorBackgroundNeutral Property
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets or sets the background for the neutral state of the control.

C#
[Browsable(true)]
[Category("Appearance")]
[DefaultValue(typeof(SystemColors), "Window")]
public Color ColorBackgroundNeutral;
Description

The neutral background.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class


REXEditBox.ColorBackgroundOK Property

REXEditBox.ColorBackgroundOK Property
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets or sets the background for the OK state of the control.

C#
[Browsable(true)]
[Category("Appearance")]
[DefaultValue(typeof(Color), "LightGreen")]
[Description("test")]
public Color ColorBackgroundOK;
Description

The OK background.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class


REXEditBox.ColorBackgroundStandard Property

REXEditBox.ColorBackgroundStandard Property
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets or sets the background for the disabled state of the control.

C#
[Browsable(true)]
[Category("Appearance")]
[DefaultValue(typeof(Color), "LightBlue")]
public Color ColorBackgroundStandard;
Description

The background.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class


REXEditBox.Complex Property

REXEditBox.Complex Property
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets or sets a value indicating whether this REXEditControlEngine supports complex (list) values.

C#
[Category("Complex")]
[Browsable(true)]
public Boolean Complex;
Description

True if the engine supports complex values; otherwise false.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class


REXEditBox.ComplexSeparator Property

REXEditBox.ComplexSeparator Property
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets or sets the complex (list) separator.

C#
[Category("Complex")]
[Browsable(true)]
[DefaultValue(";")]
public string ComplexSeparator;
Description

The complex separator.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class


REXEditBox.ComplexSpaceSeparator Property

REXEditBox.ComplexSpaceSeparator Property
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets or sets a value indicating whether a space should be respected as a list separator.

C#
[Category("Complex")]
[Browsable(true)]
public Boolean ComplexSpaceSeparator;
Description

True if space respected as a list separator; otherwise, false.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class


REXEditBox.ComplexUnitOnEnd Property

REXEditBox.ComplexUnitOnEnd Property
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets or sets a value indicating whether a unit symbol should be placed on the end of the formatted text.

C#
[Category("Complex")]
[Browsable(true)]
public Boolean ComplexUnitOnEnd;
Description

True if the unit one the end; otherwise, false.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class


REXEditBox.ControlState Property

REXEditBox.ControlState Property
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets the current state of the control.

C#
[Browsable(false)]
public EControlState ControlState;
Description

The state of the control.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class


REXEditBox.CorrectValue Property

REXEditBox.CorrectValue Property
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets or sets the correct value.

C#
[Browsable(false)]
public String CorrectValue;
Description

The correct value.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class


REXEditBox.DataType Property

REXEditBox.DataType Property
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets or sets the type of the data in the control.

C#
[Browsable(true)]
[Category("Data")]
public REX.Controls.Common.EControlType DataType;
Description

The type of the data.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class


REXEditBox.Enabled Property

REXEditBox.Enabled Property
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets or sets a value indicating whether the control can respond to user interaction.

C#
[Browsable(true)]
public new Boolean Enabled;
Returns

true if the control can respond to user interaction; otherwise, false. The default is true.

Description

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class


REXEditBox.EngineeringFormat Property

REXEditBox.EngineeringFormat Property
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets or sets a value indicating whether the text of the control should be formatted in according to the engineering (expotential) format.

C#
[Browsable(true)]
[Category("Data")]
[DefaultValue(false)]
public Boolean EngineeringFormat;
Description

True if engineering format; otherwise false.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class


REXEditBox.Epsilon Property

REXEditBox.Epsilon Property
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets or sets the accuracy.

C#
[Browsable(true)]
public double Epsilon;
Description

The accuracy.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class


REXEditBox.InvalidCharacters Property

REXEditBox.InvalidCharacters Property
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets or sets the list invalid characters (for the control in TEXT mode).

C#
[Browsable(true)]
public string InvalidCharacters;
Description

The list of invalid characters.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class


REXEditBox.MaxTokens Property

REXEditBox.MaxTokens Property
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets or sets the maximum number of elements in the complex mode (list).

C#
[Category("Complex")]
[Browsable(true)]
public int MaxTokens;
Description

The maximum number of elements.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class


REXEditBox.MinTokens Property

REXEditBox.MinTokens Property
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets or sets the minimum number of elements in the complex mode (list).

C#
[Category("Complex")]
[Browsable(true)]
public int MinTokens;
Description

The minimum number of elements.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class


REXEditBox.Multiline Property

REXEditBox.Multiline Property
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets or sets a value indicating whether this is a multiline T:System.Windows.Forms.TextBox control.

C#
[Browsable(false)]
public new Boolean Multiline;
Returns

true if the control is a multiline T:System.Windows.Forms.TextBox control; otherwise, false. The default is false.

Description

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class


REXEditBox.OnDisableAction Property

REXEditBox.OnDisableAction Property
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets or sets a value indicating whether the foreground should be hidden when the control is disabled.

C#
[Browsable(true)]
[Category("Data")]
public EOnDisable OnDisableAction;
Description

The behaviour of the control's foreground.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class


REXEditBox.OriginalTextOnEnter Property

REXEditBox.OriginalTextOnEnter Property
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets or sets a value indicating whether an original text should be set when the user enters the control.

C#
[Browsable(true)]
[Category("Behavior")]
public bool OriginalTextOnEnter;
Description

True if original text is to be set; otherwise, false.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class


REXEditBox.PasswordChar Property

REXEditBox.PasswordChar Property
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets or sets the character used to mask characters of a password in a single-line T:System.Windows.Forms.TextBox control.

C#
[Browsable(false)]
public new Char PasswordChar;
Returns

The character used to mask characters entered in a single-line T:System.Windows.Forms.TextBox control. Set the value of this property to 0 (character value) if you do not want the control to mask characters as they are typed. Equals 0 (character value) by default.

Description

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class


REXEditBox.RangeMax Property

REXEditBox.RangeMax Property
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets or sets the highest possible value.

C#
[Browsable(true)]
[Category("Data")]
[DefaultValue(Double.PositiveInfinity)]
public Double RangeMax;
Description

The highest possible value.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class


REXEditBox.RangeMaxCheck Property

REXEditBox.RangeMaxCheck Property
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets or sets a value indicating whether the value should be validated due to the RangeMax.

C#
[Browsable(true)]
[Category("Data")]
[DefaultValue(false)]
public Boolean RangeMaxCheck;
Description

True if validate; otherwise false.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class


REXEditBox.RangeMin Property

REXEditBox.RangeMin Property
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets or sets the minimum possible value.

C#
[Browsable(true)]
[Category("Data")]
[DefaultValue(Double.NegativeInfinity)]
public Double RangeMin;
Description

The minimum possible value.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class


REXEditBox.RangeMinCheck Property

REXEditBox.RangeMinCheck Property
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets or sets a value indicating whether the value should be validated due to the RangeMin.

C#
[Browsable(true)]
[Category("Data")]
[DefaultValue(false)]
public Boolean RangeMinCheck;
Description

True if validate; otherwise false.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class


REXEditBox.RememberCorrect Property

REXEditBox.RememberCorrect Property
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets or sets a value indicating whether the correct value should be restored in case of the validation failure.

C#
[Browsable(true)]
[Category("Data")]
public Boolean RememberCorrect;
Description

True if the value should be restored; otherwise false.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class


REXEditBox.RoundingFractional Property

REXEditBox.RoundingFractional Property
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets or sets the rounding for fractional units.

C#
[Browsable(true)]
[Category("Data")]
public EFractialRound RoundingFractional;
Description

The rounding.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class


REXEditBox.RoundingIncrement Property

REXEditBox.RoundingIncrement Property
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets or sets the rounding increment (for the DECIMAL DataType).

C#
[Browsable(true)]
[Category("Data")]
[DefaultValue(1E-05)]
public Double RoundingIncrement;
Description

The rounding increment.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class


REXEditBox.Separator Property

REXEditBox.Separator Property
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets or sets the decimal separator.

C#
[Browsable(true)]
[Category("Data")]
public String Separator;
Description

The separator.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class


REXEditBox.Text Property

REXEditBox.Text Property
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets the text contents of the control.

C#
[Browsable(true)]
public new string Text;
Description

The text.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class


REXEditBox.TokensRangeMaxCheck Property

REXEditBox.TokensRangeMaxCheck Property
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets or sets a value indicating whether the number of elements should be validated due to the MaxTokens.

C#
[Category("Complex")]
[Browsable(true)]
[DefaultValue(false)]
public Boolean TokensRangeMaxCheck;
Description

True if validate; otherwise, false.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class


REXEditBox.TokensRangeMinCheck Property

REXEditBox.TokensRangeMinCheck Property
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets or sets a value indicating whether the number of elements should be validated due to the MinTokens.

C#
[Category("Complex")]
[Browsable(true)]
[DefaultValue(false)]
public Boolean TokensRangeMinCheck;
Description

True if validate; otherwise, false.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class


REXEditBox.UnitSymbol Property

REXEditBox.UnitSymbol Property
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets or sets the unit symbol.

C#
[Browsable(true)]
[Category("Data")]
[DefaultValue("")]
public String UnitSymbol;
Description

The unit symbol.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class


REXEditBox.UseSystemPasswordChar Property

REXEditBox.UseSystemPasswordChar Property
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Gets or sets a value indicating whether the text in the T:System.Windows.Forms.TextBox control should appear as the default password character.

C#
[Browsable(false)]
public new Boolean UseSystemPasswordChar;
Returns

true if the text in the T:System.Windows.Forms.TextBox control should appear as the default password character; otherwise, false.

Description

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class


REXEditBox.WordWrap Property

REXEditBox.WordWrap Property
REXEditBox Class REX.Controls.Forms Namespace REXEditBox Class

Indicates whether a multiline text box control automatically wraps words to the beginning of the next line when necessary.

C#
[Browsable(false)]
public new Boolean WordWrap;
Returns

true if the multiline text box control wraps words; false if the text box control automatically scrolls horizontally when the user types past the right edge of the control. The default is true.

Description

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.Forms Namespace, REXEditBox Class


REXImageComboBox Class

REXImageComboBox Class
REX.Controls.Forms Namespace Legend Members Public Methods REXImageComboBox Properties

Combo box with images.

Class Hierarchy
C#
[System.ComponentModel.ToolboxItem(true)]
[ToolboxBitmapAttribute(typeof(REXImageComboBox), "REXImageComboBox.Icon.bmp")]
public class REXImageComboBox : ComboBox;
Description
Namespace

REX.Controls.Forms Namespace

Public Methods
Public Method | Description
REXImageComboBox | Initializes a new instance of the ComboBoxImage class.
REXImageComboBox Properties
REXImageComboBox Properties | Description
ImageList | Get or set the image list.
Links
REX.Controls.Forms Namespace, Legend, Members, Public Methods, REXImageComboBox Properties


REXImageComboBox.REXImageComboBox Constructor

REXImageComboBox.REXImageComboBox Constructor
REXImageComboBox Class REX.Controls.Forms Namespace REXImageComboBox Class

Initializes a new instance of the ComboBoxImage class.

C#
public REXImageComboBox();
Description
Class

REXImageComboBox Class

Links
REXImageComboBox Class, REX.Controls.Forms Namespace, REXImageComboBox Class


REXImageComboBox.ImageList Property

REXImageComboBox.ImageList Property
REXImageComboBox Class REX.Controls.Forms Namespace REXImageComboBox Class

Get or set the image list.

C#
public ImageList ImageList;
Description

The image list.

Class

REXImageComboBox Class

Links
REXImageComboBox Class, REX.Controls.Forms Namespace, REXImageComboBox Class


REXImageComboBoxItem Class

REXImageComboBoxItem Class
REX.Controls.Forms Namespace Legend Members Public Methods REXImageComboBoxItem Methods REXImageComboBoxItem Properties

Represents the combobox item with an image inside.

Class Hierarchy
C#
public class REXImageComboBoxItem : object;
Description
Namespace

REX.Controls.Forms Namespace

Public Methods
Public Method | Description
REXImageComboBoxItem | Initializes a new instance of a ImageComboItem class.
REXImageComboBoxItem | Initializes a new instance of a ImageComboItem class.
REXImageComboBoxItem | Initializes a new instance of a ImageComboItem class.
REXImageComboBoxItem | Initializes a new instance of a ImageComboItem class.
REXImageComboBoxItem | Initializes a new instance of a ImageComboItem class.
REXImageComboBoxItem | Initializes a new instance of a ImageComboItem class.
REXImageComboBoxItem | Initializes a new instance of a ImageComboItem class.
REXImageComboBoxItem | Initializes a new instance of a ImageComboItem class.
REXImageComboBoxItem | Initializes a new instance of a ImageComboItem class.
REXImageComboBoxItem | Initializes a new instance of a ImageComboItem class.
REXImageComboBoxItem | Initializes a new instance of a ImageComboItem class.
REXImageComboBoxItem | Initializes a new instance of a ImageComboItem class.
REXImageComboBoxItem | Initializes a new instance of a ImageComboItem class.
REXImageComboBoxItem Methods
REXImageComboBoxItem Methods | Description
ToString | Returns a T:System.String that represents the current T:System.Object.
REXImageComboBoxItem Properties
REXImageComboBoxItem Properties | Description
ForegroundColor | Gets or sets the color of the foreground.
Image | Gets or sets the image.
ImageIndex | Gets or sets the index of the image.
Mark | Gets or sets a value indicating whether this ImageComboItem is a mark.
Tag | Gets or sets the tag.
Text | Gets or sets the text.
Tooltip | Gets or sets the tooltip.
UseTextAsTooltip | Gets or sets a value indicating whether the text should be used as a Tooltip.
VisibleOnList | Gets or sets a value indicating whether item should be visible on the list.
Links
REX.Controls.Forms Namespace, Legend, Members, Public Methods, REXImageComboBoxItem Methods, REXImageComboBoxItem Properties


REXImageComboBoxItem.REXImageComboBoxItem Constructor ()

REXImageComboBoxItem.REXImageComboBoxItem Constructor ()
REXImageComboBoxItem Class REX.Controls.Forms Namespace REXImageComboBoxItem Class

Initializes a new instance of a ImageComboItem class.

C#
public REXImageComboBoxItem();
Description
Class

REXImageComboBoxItem Class

Links
REXImageComboBoxItem Class, REX.Controls.Forms Namespace, REXImageComboBoxItem Class


REXImageComboBoxItem.REXImageComboBoxItem Constructor (Image)

REXImageComboBoxItem.REXImageComboBoxItem Constructor (Image)
REXImageComboBoxItem Class REX.Controls.Forms Namespace REXImageComboBoxItem Class

Initializes a new instance of a ImageComboItem class.

C#
public REXImageComboBoxItem(Image Image);
Parameters
Parameters | Description
ImageIndex | The image.
Description
Class

REXImageComboBoxItem Class

Links
REXImageComboBoxItem Class, REX.Controls.Forms Namespace, REXImageComboBoxItem Class


REXImageComboBoxItem.REXImageComboBoxItem Constructor (Image, string)

REXImageComboBoxItem.REXImageComboBoxItem Constructor (Image, string)
REXImageComboBoxItem Class REX.Controls.Forms Namespace REXImageComboBoxItem Class

Initializes a new instance of a ImageComboItem class.

C#
public REXImageComboBoxItem(Image Image, string Tooltip);
Parameters
Parameters | Description
ImageIndex | The image.
Description
Class

REXImageComboBoxItem Class

Links
REXImageComboBoxItem Class, REX.Controls.Forms Namespace, REXImageComboBoxItem Class


REXImageComboBoxItem.REXImageComboBoxItem Constructor (int)

REXImageComboBoxItem.REXImageComboBoxItem Constructor (int)
REXImageComboBoxItem Class REX.Controls.Forms Namespace REXImageComboBoxItem Class

Initializes a new instance of a ImageComboItem class.

C#
public REXImageComboBoxItem(int ImageIndex);
Parameters
Parameters | Description
ImageIndex | Index of the image.
Description
Class

REXImageComboBoxItem Class

Links
REXImageComboBoxItem Class, REX.Controls.Forms Namespace, REXImageComboBoxItem Class


REXImageComboBoxItem.REXImageComboBoxItem Constructor (string)

REXImageComboBoxItem.REXImageComboBoxItem Constructor (string)
REXImageComboBoxItem Class REX.Controls.Forms Namespace REXImageComboBoxItem Class

Initializes a new instance of a ImageComboItem class.

C#
public REXImageComboBoxItem(string Text);
Parameters
Parameters | Description
Text | The text.
Description
Class

REXImageComboBoxItem Class

Links
REXImageComboBoxItem Class, REX.Controls.Forms Namespace, REXImageComboBoxItem Class


REXImageComboBoxItem.REXImageComboBoxItem Constructor (string, Image)

REXImageComboBoxItem.REXImageComboBoxItem Constructor (string, Image)
REXImageComboBoxItem Class REX.Controls.Forms Namespace REXImageComboBoxItem Class

Initializes a new instance of a ImageComboItem class.

C#
public REXImageComboBoxItem(string Text, Image Image);
Parameters
Parameters | Description
Text | The text.
ImageIndex | The image.
Description
Class

REXImageComboBoxItem Class

Links
REXImageComboBoxItem Class, REX.Controls.Forms Namespace, REXImageComboBoxItem Class


REXImageComboBoxItem.REXImageComboBoxItem Constructor (string, Image, bool)

REXImageComboBoxItem.REXImageComboBoxItem Constructor (string, Image, bool)
REXImageComboBoxItem Class REX.Controls.Forms Namespace REXImageComboBoxItem Class

Initializes a new instance of a ImageComboItem class.

C#
public REXImageComboBoxItem(string Text, Image Image, bool Mark);
Parameters
Parameters | Description
Text | The text.
Mark | If set to true [mark].
ImageIndex | The image.
Description
Class

REXImageComboBoxItem Class

Links
REXImageComboBoxItem Class, REX.Controls.Forms Namespace, REXImageComboBoxItem Class


REXImageComboBoxItem.REXImageComboBoxItem Constructor (string, Image, bool, Color)

REXImageComboBoxItem.REXImageComboBoxItem Constructor (string, Image, bool, Color)
REXImageComboBoxItem Class REX.Controls.Forms Namespace REXImageComboBoxItem Class

Initializes a new instance of a ImageComboItem class.

C#
public REXImageComboBoxItem(string Text, Image Image, bool Mark, Color ForeColor);
Parameters
Parameters | Description
Text | The text.
Mark | If set to true [mark].
ForeColor | Color of the foreground.
ImageIndex | The image.
Description
Class

REXImageComboBoxItem Class

Links
REXImageComboBoxItem Class, REX.Controls.Forms Namespace, REXImageComboBoxItem Class


REXImageComboBoxItem.REXImageComboBoxItem Constructor (string, Image, bool, Color, object)

REXImageComboBoxItem.REXImageComboBoxItem Constructor (string, Image, bool, Color, object)
REXImageComboBoxItem Class REX.Controls.Forms Namespace REXImageComboBoxItem Class

Initializes a new instance of a ImageComboItem class.

C#
public REXImageComboBoxItem(string Text, Image Image, bool Mark, Color ForeColor, object Tag);
Parameters
Parameters | Description
Text | The text.
Mark | If set to true [mark].
ForeColor | Color of the foreground.
Tag | The tag.
ImageIndex | The image.
Description
Class

REXImageComboBoxItem Class

Links
REXImageComboBoxItem Class, REX.Controls.Forms Namespace, REXImageComboBoxItem Class


REXImageComboBoxItem.REXImageComboBoxItem Constructor (string, int)

REXImageComboBoxItem.REXImageComboBoxItem Constructor (string, int)
REXImageComboBoxItem Class REX.Controls.Forms Namespace REXImageComboBoxItem Class

Initializes a new instance of a ImageComboItem class.

C#
public REXImageComboBoxItem(string Text, int ImageIndex);
Parameters
Parameters | Description
Text | The text.
ImageIndex | Index of the image.
Description
Class

REXImageComboBoxItem Class

Links
REXImageComboBoxItem Class, REX.Controls.Forms Namespace, REXImageComboBoxItem Class


REXImageComboBoxItem.REXImageComboBoxItem Constructor (string, int, bool)

REXImageComboBoxItem.REXImageComboBoxItem Constructor (string, int, bool)
REXImageComboBoxItem Class REX.Controls.Forms Namespace REXImageComboBoxItem Class

Initializes a new instance of a ImageComboItem class.

C#
public REXImageComboBoxItem(string Text, int ImageIndex, bool Mark);
Parameters
Parameters | Description
Text | The text.
ImageIndex | Index of the image.
Mark | If set to true [mark].
Description
Class

REXImageComboBoxItem Class

Links
REXImageComboBoxItem Class, REX.Controls.Forms Namespace, REXImageComboBoxItem Class


REXImageComboBoxItem.REXImageComboBoxItem Constructor (string, int, bool, Color)

REXImageComboBoxItem.REXImageComboBoxItem Constructor (string, int, bool, Color)
REXImageComboBoxItem Class REX.Controls.Forms Namespace REXImageComboBoxItem Class

Initializes a new instance of a ImageComboItem class.

C#
public REXImageComboBoxItem(string Text, int ImageIndex, bool Mark, Color ForeColor);
Parameters
Parameters | Description
Text | The text.
ImageIndex | Index of the image.
Mark | If set to true [mark].
ForeColor | Color of the foreground.
Description
Class

REXImageComboBoxItem Class

Links
REXImageComboBoxItem Class, REX.Controls.Forms Namespace, REXImageComboBoxItem Class


REXImageComboBoxItem.REXImageComboBoxItem Constructor (string, int, bool, Color, object)

REXImageComboBoxItem.REXImageComboBoxItem Constructor (string, int, bool, Color, object)
REXImageComboBoxItem Class REX.Controls.Forms Namespace REXImageComboBoxItem Class

Initializes a new instance of a ImageComboItem class.

C#
public REXImageComboBoxItem(string Text, int ImageIndex, bool Mark, Color ForeColor, object Tag);
Parameters
Parameters | Description
Text | The text.
ImageIndex | Index of the image.
Mark | If set to true [mark].
ForeColor | Color of the foreground.
Tag | The tag.
Description
Class

REXImageComboBoxItem Class

Links
REXImageComboBoxItem Class, REX.Controls.Forms Namespace, REXImageComboBoxItem Class


REXImageComboBoxItem.ToString Method

REXImageComboBoxItem.ToString Method
REXImageComboBoxItem Class REX.Controls.Forms Namespace REXImageComboBoxItem Class

Returns a T:System.String that represents the current T:System.Object.

C#
public override string ToString();
Returns

A T:System.String that represents the current T:System.Object.

Description
Class

REXImageComboBoxItem Class

Links
REXImageComboBoxItem Class, REX.Controls.Forms Namespace, REXImageComboBoxItem Class


REXImageComboBoxItem.ForegroundColor Property

REXImageComboBoxItem.ForegroundColor Property
REXImageComboBoxItem Class REX.Controls.Forms Namespace REXImageComboBoxItem Class

Gets or sets the color of the foreground.

C#
public Color ForegroundColor;
Description

The color of the foreground.

Class

REXImageComboBoxItem Class

Links
REXImageComboBoxItem Class, REX.Controls.Forms Namespace, REXImageComboBoxItem Class


REXImageComboBoxItem.Image Property

REXImageComboBoxItem.Image Property
REXImageComboBoxItem Class REX.Controls.Forms Namespace REXImageComboBoxItem Class

Gets or sets the image.

C#
public Image Image;
Description

The image.

Class

REXImageComboBoxItem Class

Links
REXImageComboBoxItem Class, REX.Controls.Forms Namespace, REXImageComboBoxItem Class


REXImageComboBoxItem.ImageIndex Property

REXImageComboBoxItem.ImageIndex Property
REXImageComboBoxItem Class REX.Controls.Forms Namespace REXImageComboBoxItem Class

Gets or sets the index of the image.

C#
public int ImageIndex;
Description

The index of the image.

Class

REXImageComboBoxItem Class

Links
REXImageComboBoxItem Class, REX.Controls.Forms Namespace, REXImageComboBoxItem Class


REXImageComboBoxItem.Mark Property

REXImageComboBoxItem.Mark Property
REXImageComboBoxItem Class REX.Controls.Forms Namespace REXImageComboBoxItem Class

Gets or sets a value indicating whether this ImageComboItem is a mark.

C#
public bool Mark;
Description

true if mark; otherwise, false.

Class

REXImageComboBoxItem Class

Links
REXImageComboBoxItem Class, REX.Controls.Forms Namespace, REXImageComboBoxItem Class


REXImageComboBoxItem.Tag Property

REXImageComboBoxItem.Tag Property
REXImageComboBoxItem Class REX.Controls.Forms Namespace REXImageComboBoxItem Class

Gets or sets the tag.

C#
public object Tag;
Description

The tag.

Class

REXImageComboBoxItem Class

Links
REXImageComboBoxItem Class, REX.Controls.Forms Namespace, REXImageComboBoxItem Class


REXImageComboBoxItem.Text Property

REXImageComboBoxItem.Text Property
REXImageComboBoxItem Class REX.Controls.Forms Namespace REXImageComboBoxItem Class

Gets or sets the text.

C#
public string Text;
Description

The text.

Class

REXImageComboBoxItem Class

Links
REXImageComboBoxItem Class, REX.Controls.Forms Namespace, REXImageComboBoxItem Class


REXImageComboBoxItem.Tooltip Property

REXImageComboBoxItem.Tooltip Property
REXImageComboBoxItem Class REX.Controls.Forms Namespace REXImageComboBoxItem Class

Gets or sets the tooltip.

C#
public string Tooltip;
Description

The tooltip.

Class

REXImageComboBoxItem Class

Links
REXImageComboBoxItem Class, REX.Controls.Forms Namespace, REXImageComboBoxItem Class


REXImageComboBoxItem.UseTextAsTooltip Property

REXImageComboBoxItem.UseTextAsTooltip Property
REXImageComboBoxItem Class REX.Controls.Forms Namespace REXImageComboBoxItem Class

Gets or sets a value indicating whether the text should be used as a Tooltip.

C#
public bool UseTextAsTooltip;
Description

True if text used as a tooltip; otherwise, false.

Class

REXImageComboBoxItem Class

Links
REXImageComboBoxItem Class, REX.Controls.Forms Namespace, REXImageComboBoxItem Class


REXImageComboBoxItem.VisibleOnList Property

REXImageComboBoxItem.VisibleOnList Property
REXImageComboBoxItem Class REX.Controls.Forms Namespace REXImageComboBoxItem Class

Gets or sets a value indicating whether item should be visible on the list.

C#
public bool VisibleOnList;
Description
Class

REXImageComboBoxItem Class

Links
REXImageComboBoxItem Class, REX.Controls.Forms Namespace, REXImageComboBoxItem Class


REXIndexLabel Class

REXIndexLabel Class
REX.Controls.Forms Namespace Legend Members Public Methods REXIndexLabel Methods REXIndexLabel Properties

Represents the REXIndexLabel control.

Class Hierarchy
C#
[System.ComponentModel.ToolboxItem(true)]
[ToolboxBitmapAttribute(typeof(REXIndexLabel), "REXIndexLabel.Icon.bmp")]
public class REXIndexLabel : Label;
Description

It can be used to draw small letters below or above the text baseline.

Remarks

In order to draw small letters it is necessarry to place them in curly brackets: rex{lower}{^upper}. In order to draw the specified letter using Symbolic font it is necessarry to start it with @: @rex.

Namespace

REX.Controls.Forms Namespace

Public Methods
Public Method | Description
REXIndexLabel | Initializes a new instance of the REXIndexLabel class.
REXIndexLabel Methods
REXIndexLabel Methods | Description
GetTextSize | Gets the size of the text.
REXIndexLabel Properties
REXIndexLabel Properties | Description
AutoSize | Gets or sets a value indicating whether the control is automatically resized to display its entire contents.
IndexCoeff | Gets or sets the proportion between index and it's parent.
LeftAlign | Gets or sets a value indicating whether the content of the control should be aligned to the left.
Text | Gets the text contents of the control.
TextAlign | Gets or sets the alignment of text in the label.
Links
REX.Controls.Forms Namespace, Legend, Members, Public Methods, REXIndexLabel Methods, REXIndexLabel Properties


REXIndexLabel.REXIndexLabel Constructor

REXIndexLabel.REXIndexLabel Constructor
REXIndexLabel Class REX.Controls.Forms Namespace REXIndexLabel Class

Initializes a new instance of the REXIndexLabel class.

C#
public REXIndexLabel();
Description
Class

REXIndexLabel Class

Links
REXIndexLabel Class, REX.Controls.Forms Namespace, REXIndexLabel Class


REXIndexLabel.GetTextSize Method

REXIndexLabel.GetTextSize Method
REXIndexLabel Class REX.Controls.Forms Namespace REXIndexLabel Class

Gets the size of the text.

C#
public static SizeF GetTextSize(string text, Control control, Font font);
Parameters
Parameters | Description
text | The text.
control | The control where the text is placed.
font | The font.
Returns

The size of the text.

Description
Class

REXIndexLabel Class

Links
REXIndexLabel Class, REX.Controls.Forms Namespace, REXIndexLabel Class


REXIndexLabel.AutoSize Property

REXIndexLabel.AutoSize Property
REXIndexLabel Class REX.Controls.Forms Namespace REXIndexLabel Class

Gets or sets a value indicating whether the control is automatically resized to display its entire contents.

C#
[Browsable(false)]
public override bool AutoSize;
Returns

true if the control adjusts its width to closely fit its contents; otherwise, false. The default is true.

Description

Class

REXIndexLabel Class

Links
REXIndexLabel Class, REX.Controls.Forms Namespace, REXIndexLabel Class


REXIndexLabel.IndexCoeff Property

REXIndexLabel.IndexCoeff Property
REXIndexLabel Class REX.Controls.Forms Namespace REXIndexLabel Class

Gets or sets the proportion between index and it's parent.

C#
[Category("Appearance")]
[Description("describes proportion between index and it's parent")]
public double IndexCoeff;
Description

The index coefficient.

Class

REXIndexLabel Class

Links
REXIndexLabel Class, REX.Controls.Forms Namespace, REXIndexLabel Class


REXIndexLabel.LeftAlign Property

REXIndexLabel.LeftAlign Property
REXIndexLabel Class REX.Controls.Forms Namespace REXIndexLabel Class

Gets or sets a value indicating whether the content of the control should be aligned to the left.

C#
[Category("Appearance")]
[Description("describes text align (right and left available)")]
public bool LeftAlign;
Description

True if left alignment; otherwise, false.

Class

REXIndexLabel Class

Links
REXIndexLabel Class, REX.Controls.Forms Namespace, REXIndexLabel Class


REXIndexLabel.Text Property

REXIndexLabel.Text Property
REXIndexLabel Class REX.Controls.Forms Namespace REXIndexLabel Class

Gets the text contents of the control.

C#
public override string Text;
Description

The text.

Class

REXIndexLabel Class

Links
REXIndexLabel Class, REX.Controls.Forms Namespace, REXIndexLabel Class


REXIndexLabel.TextAlign Property

REXIndexLabel.TextAlign Property
REXIndexLabel Class REX.Controls.Forms Namespace REXIndexLabel Class

Gets or sets the alignment of text in the label.

C#
[Browsable(false)]
public override ContentAlignment TextAlign;
Returns

One of the T:System.Drawing.ContentAlignment values. The default is F:System.Drawing.ContentAlignment.TopLeft.

Description

Class

REXIndexLabel Class

Links
REXIndexLabel Class, REX.Controls.Forms Namespace, REXIndexLabel Class


REXPictureBox Class

REXPictureBox Class
REX.Controls.Forms Namespace Legend Members Public Methods

This is class REX.Controls.Forms.REXPictureBox.

Class Hierarchy
C#
[System.ComponentModel.ToolboxItem(false)]
public class REXPictureBox : PictureBox;
Namespace

REX.Controls.Forms Namespace

Public Methods
Public Method | Description
REXPictureBox | This is REXPictureBox, a member of class REXPictureBox.
Links
REX.Controls.Forms Namespace, Legend, Members, Public Methods


REXPictureBox.REXPictureBox Constructor

REXPictureBox.REXPictureBox Constructor
REXPictureBox Class REX.Controls.Forms Namespace REXPictureBox Class

This is REXPictureBox, a member of class REXPictureBox.

C#
public REXPictureBox();
Class

REXPictureBox Class

Links
REXPictureBox Class, REX.Controls.Forms Namespace, REXPictureBox Class


REXProgressBar Class

REXProgressBar Class
REX.Controls.Forms Namespace Legend Members Public Methods REXProgressBar Delegates REXProgressBar Events REXProgressBar Methods REXProgressBar Properties

Represents a REX progress bar control.

Class Hierarchy
C#
[System.ComponentModel.ToolboxItem(false)]
public class REXProgressBar : UserControl;
Description
Namespace

REX.Controls.Forms Namespace

Public Methods
Public Method | Description
REXProgressBar | Initializes a new instance of the REXProgressBar class.
REXProgressBar Delegates
REXProgressBar Delegates | Description
MaxChangedHandler | This is nested type REX.Controls.Forms.REXProgressBar.MaxChangedHandler.
MinChangedHandler | This is nested type REX.Controls.Forms.REXProgressBar.MinChangedHandler.
ValueChangedHandler | This is nested type REX.Controls.Forms.REXProgressBar.ValueChangedHandler.
REXProgressBar Events
REXProgressBar Events | Description
MaxChanged | This is MaxChanged, a member of class REXProgressBar.
MinChanged | This is MinChanged, a member of class REXProgressBar.
ValueChanged | This is ValueChanged, a member of class REXProgressBar.
REXProgressBar Methods
REXProgressBar Methods | Description
StepBack | Takes a step back.
StepForward | Takes a step forward.
REXProgressBar Properties
REXProgressBar Properties | Description
Animate | Gets or sets a value indicating whether animation should be run.
BackgroundColor | Gets or sets the color of the background.
EndColor | Gets or sets the end color.
GlowColor | Gets or sets the color of the glow.
HighlightColor | Gets or sets the color of the highlight.
MaxValue | Gets or sets the maximum value of the range of the control.
MinValue | Gets or sets the minimum value of the range of the control.
StartColor | Gets or sets the start color.
Step | Gets or sets the step.
Value | Gets or sets the current position of the progress bar.
Links
REX.Controls.Forms Namespace, Legend, Members, Public Methods, REXProgressBar Delegates, REXProgressBar Events, REXProgressBar Methods, REXProgressBar Properties


REXProgressBar.REXProgressBar Constructor

REXProgressBar.REXProgressBar Constructor
REXProgressBar Class REX.Controls.Forms Namespace REXProgressBar Class

Initializes a new instance of the REXProgressBar class.

C#
public REXProgressBar();
Description
Class

REXProgressBar Class

Links
REXProgressBar Class, REX.Controls.Forms Namespace, REXProgressBar Class


REXProgressBar.StepBack Method

REXProgressBar.StepBack Method
REXProgressBar Class REX.Controls.Forms Namespace REXProgressBar Class

Takes a step back.

C#
public void StepBack();
Description
Class

REXProgressBar Class

Links
REXProgressBar Class, REX.Controls.Forms Namespace, REXProgressBar Class


REXProgressBar.StepForward Method

REXProgressBar.StepForward Method
REXProgressBar Class REX.Controls.Forms Namespace REXProgressBar Class

Takes a step forward.

C#
public void StepForward();
Description
Class

REXProgressBar Class

Links
REXProgressBar Class, REX.Controls.Forms Namespace, REXProgressBar Class


REXProgressBar.Animate Property

REXProgressBar.Animate Property
REXProgressBar Class REX.Controls.Forms Namespace REXProgressBar Class

Gets or sets a value indicating whether animation should be run.

C#
[Category("Animation")]
public bool Animate;
Description

True if animate; otherwise, false.

Class

REXProgressBar Class

Links
REXProgressBar Class, REX.Controls.Forms Namespace, REXProgressBar Class


REXProgressBar.BackgroundColor Property

REXProgressBar.BackgroundColor Property
REXProgressBar Class REX.Controls.Forms Namespace REXProgressBar Class

Gets or sets the color of the background.

C#
[Category("Progress colors")]
public Color BackgroundColor;
Description

The color of the background.

Class

REXProgressBar Class

Links
REXProgressBar Class, REX.Controls.Forms Namespace, REXProgressBar Class


REXProgressBar.EndColor Property

REXProgressBar.EndColor Property
REXProgressBar Class REX.Controls.Forms Namespace REXProgressBar Class

Gets or sets the end color.

C#
[Category("Progress colors")]
public Color EndColor;
Description

The end color.

Class

REXProgressBar Class

Links
REXProgressBar Class, REX.Controls.Forms Namespace, REXProgressBar Class


REXProgressBar.GlowColor Property

REXProgressBar.GlowColor Property
REXProgressBar Class REX.Controls.Forms Namespace REXProgressBar Class

Gets or sets the color of the glow.

C#
[Category("Progress colors")]
public Color GlowColor;
Description

The color of the glow.

Class

REXProgressBar Class

Links
REXProgressBar Class, REX.Controls.Forms Namespace, REXProgressBar Class


REXProgressBar.HighlightColor Property

REXProgressBar.HighlightColor Property
REXProgressBar Class REX.Controls.Forms Namespace REXProgressBar Class

Gets or sets the color of the highlight.

C#
[Category("Progress colors")]
public Color HighlightColor;
Description

The color of the highlight.

Class

REXProgressBar Class

Links
REXProgressBar Class, REX.Controls.Forms Namespace, REXProgressBar Class


REXProgressBar.MaxValue Property

REXProgressBar.MaxValue Property
REXProgressBar Class REX.Controls.Forms Namespace REXProgressBar Class

Gets or sets the maximum value of the range of the control.

C#
[Category("Values")]
public int MaxValue;
Description

The maximum value of the range.

Class

REXProgressBar Class

Links
REXProgressBar Class, REX.Controls.Forms Namespace, REXProgressBar Class


REXProgressBar.MinValue Property

REXProgressBar.MinValue Property
REXProgressBar Class REX.Controls.Forms Namespace REXProgressBar Class

Gets or sets the minimum value of the range of the control.

C#
[Category("Values")]
public int MinValue;
Description

The minimum value of the range.

Class

REXProgressBar Class

Links
REXProgressBar Class, REX.Controls.Forms Namespace, REXProgressBar Class


REXProgressBar.StartColor Property

REXProgressBar.StartColor Property
REXProgressBar Class REX.Controls.Forms Namespace REXProgressBar Class

Gets or sets the start color.

C#
[Category("Progress colors")]
public Color StartColor;
Description

The start color.

Class

REXProgressBar Class

Links
REXProgressBar Class, REX.Controls.Forms Namespace, REXProgressBar Class


REXProgressBar.Step Property

REXProgressBar.Step Property
REXProgressBar Class REX.Controls.Forms Namespace REXProgressBar Class

Gets or sets the step.

C#
[Category("Values")]
public int Step;
Description

The step.

Class

REXProgressBar Class

Links
REXProgressBar Class, REX.Controls.Forms Namespace, REXProgressBar Class


REXProgressBar.Value Property

REXProgressBar.Value Property
REXProgressBar Class REX.Controls.Forms Namespace REXProgressBar Class

Gets or sets the current position of the progress bar.

C#
[Category("Values")]
public int Value;
Description

The position within the range of the progress bar.

Class

REXProgressBar Class

Links
REXProgressBar Class, REX.Controls.Forms Namespace, REXProgressBar Class


REXProgressBar.MaxChangedHandler Delegate

REXProgressBar.MaxChangedHandler Delegate
REXProgressBar Class REX.Controls.Forms Namespace REXProgressBar Class

This is nested type REX.Controls.Forms.REXProgressBar.MaxChangedHandler.

C#
public delegate void MaxChangedHandler(object sender, EventArgs e);
Class

REXProgressBar Class

Links
REXProgressBar Class, REX.Controls.Forms Namespace, REXProgressBar Class


REXProgressBar.MinChangedHandler Delegate

REXProgressBar.MinChangedHandler Delegate
REXProgressBar Class REX.Controls.Forms Namespace REXProgressBar Class

This is nested type REX.Controls.Forms.REXProgressBar.MinChangedHandler.

C#
public delegate void MinChangedHandler(object sender, EventArgs e);
Class

REXProgressBar Class

Links
REXProgressBar Class, REX.Controls.Forms Namespace, REXProgressBar Class


REXProgressBar.ValueChangedHandler Delegate

REXProgressBar.ValueChangedHandler Delegate
REXProgressBar Class REX.Controls.Forms Namespace REXProgressBar Class

This is nested type REX.Controls.Forms.REXProgressBar.ValueChangedHandler.

C#
public delegate void ValueChangedHandler(object sender, EventArgs e);
Class

REXProgressBar Class

Links
REXProgressBar Class, REX.Controls.Forms Namespace, REXProgressBar Class


REXProgressBar.MaxChanged Event

REXProgressBar.MaxChanged Event
REXProgressBar Class REX.Controls.Forms Namespace REXProgressBar Class

This is MaxChanged, a member of class REXProgressBar.

C#
public event MaxChangedHandler MaxChanged;
Class

REXProgressBar Class

Links
REXProgressBar Class, REX.Controls.Forms Namespace, REXProgressBar Class


REXProgressBar.MinChanged Event

REXProgressBar.MinChanged Event
REXProgressBar Class REX.Controls.Forms Namespace REXProgressBar Class

This is MinChanged, a member of class REXProgressBar.

C#
public event MinChangedHandler MinChanged;
Class

REXProgressBar Class

Links
REXProgressBar Class, REX.Controls.Forms Namespace, REXProgressBar Class


REXProgressBar.ValueChanged Event

REXProgressBar.ValueChanged Event
REXProgressBar Class REX.Controls.Forms Namespace REXProgressBar Class

This is ValueChanged, a member of class REXProgressBar.

C#
public event ValueChangedHandler ValueChanged;
Class

REXProgressBar Class

Links
REXProgressBar Class, REX.Controls.Forms Namespace, REXProgressBar Class


REXUnitComboBox Class

REXUnitComboBox Class
REX.Controls.Forms Namespace Legend Members REXUnitComboBox Methods REXUnitComboBox Properties

Represents the REXUnitComboBox control with a IREXUnitEngine.

Class Hierarchy
C#
[System.ComponentModel.ToolboxItem(true)]
[ToolboxBitmapAttribute(typeof(REXUnitComboBox), "REXUnitComboBox.Icon.bmp")]
public class REXUnitComboBox : REXComboBox;
Description
Namespace

REX.Controls.Forms Namespace

REXUnitComboBox Methods
REXUnitComboBox Methods | Description
GetBaseMaxValue | Gets the maximum value and converts it to base units.
GetBaseMinValue | Gets the minimum value and converts it to base units.
GetComplexDataBaseValue | Get the values and convert it to base units.
GetComplexDataInterfaceValue | Get the values and convert it to interface units.
GetDataBaseValue | Gets the value and converts it to base units.
GetDataInterfaceValue | Gets the value and converts it to interface units.
GetInterfaceMaxValue | Gets the maximum value and converts it to interface units.
GetInterfaceMinValue | Gets the minimum value and converts it to interface units.
SetBaseMaxValue | Set the maximum value defined in base units.
SetBaseMinValue | Set the minimum value defined in base units.
SetComplexDataBaseValue | Set the list of values defined in base units.
SetComplexDataInterfaceValue | Set the list of values defined in interface units.
SetDataBaseValue | Set the value in base units.
SetDataInterfaceValue | Set the value in interface units.
SetInterfaceMaxValue | Set the maximum value defined in interface units.
SetInterfaceMinValue | Set the minimum value defined in interface units.
REXUnitComboBox Properties
REXUnitComboBox Properties | Description
Power | Gets or sets the power of the unit.
UnitEngine | Gets or sets the unit engine.
UnitType | Gets or sets the type of the unit.
Links
REX.Controls.Forms Namespace, Legend, Members, REXUnitComboBox Methods, REXUnitComboBox Properties


REXUnitComboBox.GetBaseMaxValue Method

REXUnitComboBox.GetBaseMaxValue Method
REXUnitComboBox Class REX.Controls.Forms Namespace REXUnitComboBox Class

Gets the maximum value and converts it to base units.

C#
public double GetBaseMaxValue();
Returns

The value.

Description
Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.Forms Namespace, REXUnitComboBox Class


REXUnitComboBox.GetBaseMinValue Method

REXUnitComboBox.GetBaseMinValue Method
REXUnitComboBox Class REX.Controls.Forms Namespace REXUnitComboBox Class

Gets the minimum value and converts it to base units.

C#
public double GetBaseMinValue();
Returns

The value.

Description
Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.Forms Namespace, REXUnitComboBox Class


REXUnitComboBox.GetComplexDataBaseValue Method

REXUnitComboBox.GetComplexDataBaseValue Method
REXUnitComboBox Class REX.Controls.Forms Namespace REXUnitComboBox Class

Get the values and convert it to base units.

C#
public List<double> GetComplexDataBaseValue();
Returns

The list of values.

Description
Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.Forms Namespace, REXUnitComboBox Class


REXUnitComboBox.GetComplexDataInterfaceValue Method

REXUnitComboBox.GetComplexDataInterfaceValue Method
REXUnitComboBox Class REX.Controls.Forms Namespace REXUnitComboBox Class

Get the values and convert it to interface units.

C#
public List<double> GetComplexDataInterfaceValue(REXInterfaceType interfaceType);
Parameters
Parameters | Description
interfaceType | The product context.
Returns

The list of values.

Description
Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.Forms Namespace, REXUnitComboBox Class


REXUnitComboBox.GetDataBaseValue Method

REXUnitComboBox.GetDataBaseValue Method
REXUnitComboBox Class REX.Controls.Forms Namespace REXUnitComboBox Class

Gets the value and converts it to base units.

C#
public double GetDataBaseValue();
Returns

The value.

Description
Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.Forms Namespace, REXUnitComboBox Class


REXUnitComboBox.GetDataInterfaceValue Method

REXUnitComboBox.GetDataInterfaceValue Method
REXUnitComboBox Class REX.Controls.Forms Namespace REXUnitComboBox Class

Gets the value and converts it to interface units.

C#
public double GetDataInterfaceValue(REXInterfaceType interfaceType);
Parameters
Parameters | Description
interfaceType | The product context.
Returns

The value.

Description
Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.Forms Namespace, REXUnitComboBox Class


REXUnitComboBox.GetInterfaceMaxValue Method

REXUnitComboBox.GetInterfaceMaxValue Method
REXUnitComboBox Class REX.Controls.Forms Namespace REXUnitComboBox Class

Gets the maximum value and converts it to interface units.

C#
public double GetInterfaceMaxValue(REXInterfaceType interfaceType);
Parameters
Parameters | Description
interfaceType | The product context.
Returns

The value.

Description
Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.Forms Namespace, REXUnitComboBox Class


REXUnitComboBox.GetInterfaceMinValue Method

REXUnitComboBox.GetInterfaceMinValue Method
REXUnitComboBox Class REX.Controls.Forms Namespace REXUnitComboBox Class

Gets the minimum value and converts it to interface units.

C#
public double GetInterfaceMinValue(REXInterfaceType interfaceType);
Parameters
Parameters | Description
interfaceType | The product context.
Returns

The value.

Description
Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.Forms Namespace, REXUnitComboBox Class


REXUnitComboBox.SetBaseMaxValue Method

REXUnitComboBox.SetBaseMaxValue Method
REXUnitComboBox Class REX.Controls.Forms Namespace REXUnitComboBox Class

Set the maximum value defined in base units.

C#
public void SetBaseMaxValue(double value);
Parameters
Parameters | Description
value | The value.
Description
Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.Forms Namespace, REXUnitComboBox Class


REXUnitComboBox.SetBaseMinValue Method

REXUnitComboBox.SetBaseMinValue Method
REXUnitComboBox Class REX.Controls.Forms Namespace REXUnitComboBox Class

Set the minimum value defined in base units.

C#
public void SetBaseMinValue(double value);
Parameters
Parameters | Description
value | The value.
Description
Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.Forms Namespace, REXUnitComboBox Class


REXUnitComboBox.SetComplexDataBaseValue Method

REXUnitComboBox.SetComplexDataBaseValue Method
REXUnitComboBox Class REX.Controls.Forms Namespace REXUnitComboBox Class

Set the list of values defined in base units.

C#
public void SetComplexDataBaseValue(List<double> values);
Parameters
Parameters | Description
values | The values.
Description
Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.Forms Namespace, REXUnitComboBox Class


REXUnitComboBox.SetComplexDataInterfaceValue Method

REXUnitComboBox.SetComplexDataInterfaceValue Method
REXUnitComboBox Class REX.Controls.Forms Namespace REXUnitComboBox Class

Set the list of values defined in interface units.

C#
public void SetComplexDataInterfaceValue(List<double> values, REXInterfaceType interfaceType);
Parameters
Parameters | Description
values | The values.
interfaceType | The product context.
Description
Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.Forms Namespace, REXUnitComboBox Class


REXUnitComboBox.SetDataBaseValue Method

REXUnitComboBox.SetDataBaseValue Method
REXUnitComboBox Class REX.Controls.Forms Namespace REXUnitComboBox Class

Set the value in base units.

C#
public void SetDataBaseValue(double value);
Parameters
Parameters | Description
value | The value.
Description
Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.Forms Namespace, REXUnitComboBox Class


REXUnitComboBox.SetDataInterfaceValue Method

REXUnitComboBox.SetDataInterfaceValue Method
REXUnitComboBox Class REX.Controls.Forms Namespace REXUnitComboBox Class

Set the value in interface units.

C#
public void SetDataInterfaceValue(double value, REXInterfaceType interfaceType);
Parameters
Parameters | Description
value | The value.
interfaceType | The product context.
Description
Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.Forms Namespace, REXUnitComboBox Class


REXUnitComboBox.SetInterfaceMaxValue Method

REXUnitComboBox.SetInterfaceMaxValue Method
REXUnitComboBox Class REX.Controls.Forms Namespace REXUnitComboBox Class

Set the maximum value defined in interface units.

C#
public void SetInterfaceMaxValue(double value, REXInterfaceType interfaceType);
Parameters
Parameters | Description
value | The value.
interfaceType | The product context.
Description
Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.Forms Namespace, REXUnitComboBox Class


REXUnitComboBox.SetInterfaceMinValue Method

REXUnitComboBox.SetInterfaceMinValue Method
REXUnitComboBox Class REX.Controls.Forms Namespace REXUnitComboBox Class

Set the minimum value defined in interface units.

C#
public void SetInterfaceMinValue(double value, REXInterfaceType interfaceType);
Parameters
Parameters | Description
value | The value.
interfaceType | The product context.
Description
Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.Forms Namespace, REXUnitComboBox Class


REXUnitComboBox.Power Property

REXUnitComboBox.Power Property
REXUnitComboBox Class REX.Controls.Forms Namespace REXUnitComboBox Class

Gets or sets the power of the unit.

C#
public double Power;
Description

The power.

Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.Forms Namespace, REXUnitComboBox Class


REXUnitComboBox.UnitEngine Property

REXUnitComboBox.UnitEngine Property
REXUnitComboBox Class REX.Controls.Forms Namespace REXUnitComboBox Class

Gets or sets the unit engine.

C#
public Autodesk.REX.Framework.IREXUnits UnitEngine;
Description

The unit engine.

Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.Forms Namespace, REXUnitComboBox Class


REXUnitComboBox.UnitType Property

REXUnitComboBox.UnitType Property
REXUnitComboBox Class REX.Controls.Forms Namespace REXUnitComboBox Class

Gets or sets the type of the unit.

C#
public Autodesk.REX.Framework.EUnitType UnitType;
Description

The type of the unit.

Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.Forms Namespace, REXUnitComboBox Class


REXUnitEditBox Class

REXUnitEditBox Class
REX.Controls.Forms Namespace Legend Members REXUnitEditBox Methods REXUnitEditBox Properties

Represents the REXEditBox control with a IREXUnitEngine.

Class Hierarchy
C#
[System.ComponentModel.ToolboxItem(true)]
[ToolboxBitmapAttribute(typeof(REXUnitEditBox), "REXUnitEditBox.Icon.bmp")]
public class REXUnitEditBox : REXEditBox;
Description
Namespace

REX.Controls.Forms Namespace

REXUnitEditBox Methods
REXUnitEditBox Methods | Description
GetBaseMaxValue | Gets the maximum value and converts it to base units.
GetBaseMinValue | Gets the minimum value and converts it to base units.
GetComplexDataBaseValue | Get the values and convert it to base units.
GetComplexDataInterfaceValue | Get the values and convert it to interface units.
GetDataBaseValue | Gets the value and converts it to base units.
GetDataInterfaceValue | Gets the value and converts it to interface units.
GetInterfaceMaxValue | Gets the maximum value and converts it to interface units.
GetInterfaceMinValue | Gets the minimum value and converts it to interface units.
SetBaseMaxValue | Set the maximum value defined in base units.
SetBaseMinValue | Set the minimum value defined in base units.
SetComplexDataBaseValue | Set the list of values defined in base units.
SetComplexDataInterfaceValue | Set the list of values defined in interface units.
SetDataBaseValue | Set the value in base units.
SetDataInterfaceValue | Set the value in interface units.
SetInterfaceMaxValue | Set the maximum value defined in interface units.
SetInterfaceMinValue | Set the minimum value defined in interface units.
REXUnitEditBox Properties
REXUnitEditBox Properties | Description
Power | Gets or sets the power of the unit.
UnitEngine | Gets or sets the unit engine.
UnitType | Gets or sets the type of the unit.
Links
REX.Controls.Forms Namespace, Legend, Members, REXUnitEditBox Methods, REXUnitEditBox Properties


REXUnitEditBox.GetBaseMaxValue Method

REXUnitEditBox.GetBaseMaxValue Method
REXUnitEditBox Class REX.Controls.Forms Namespace REXUnitEditBox Class

Gets the maximum value and converts it to base units.

C#
public double GetBaseMaxValue();
Returns

The value.

Description
Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.Forms Namespace, REXUnitEditBox Class


REXUnitEditBox.GetBaseMinValue Method

REXUnitEditBox.GetBaseMinValue Method
REXUnitEditBox Class REX.Controls.Forms Namespace REXUnitEditBox Class

Gets the minimum value and converts it to base units.

C#
public double GetBaseMinValue();
Returns

The value.

Description
Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.Forms Namespace, REXUnitEditBox Class


REXUnitEditBox.GetComplexDataBaseValue Method

REXUnitEditBox.GetComplexDataBaseValue Method
REXUnitEditBox Class REX.Controls.Forms Namespace REXUnitEditBox Class

Get the values and convert it to base units.

C#
public List<double> GetComplexDataBaseValue();
Returns

The list of values.

Description
Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.Forms Namespace, REXUnitEditBox Class


REXUnitEditBox.GetComplexDataInterfaceValue Method

REXUnitEditBox.GetComplexDataInterfaceValue Method
REXUnitEditBox Class REX.Controls.Forms Namespace REXUnitEditBox Class

Get the values and convert it to interface units.

C#
public List<double> GetComplexDataInterfaceValue(REXInterfaceType interfaceType);
Parameters
Parameters | Description
interfaceType | The product context.
Returns

The list of values.

Description
Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.Forms Namespace, REXUnitEditBox Class


REXUnitEditBox.GetDataBaseValue Method

REXUnitEditBox.GetDataBaseValue Method
REXUnitEditBox Class REX.Controls.Forms Namespace REXUnitEditBox Class

Gets the value and converts it to base units.

C#
public double GetDataBaseValue();
Returns

The value.

Description
Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.Forms Namespace, REXUnitEditBox Class


REXUnitEditBox.GetDataInterfaceValue Method

REXUnitEditBox.GetDataInterfaceValue Method
REXUnitEditBox Class REX.Controls.Forms Namespace REXUnitEditBox Class

Gets the value and converts it to interface units.

C#
public double GetDataInterfaceValue(REXInterfaceType interfaceType);
Parameters
Parameters | Description
interfaceType | The product context.
Returns

The value.

Description
Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.Forms Namespace, REXUnitEditBox Class


REXUnitEditBox.GetInterfaceMaxValue Method

REXUnitEditBox.GetInterfaceMaxValue Method
REXUnitEditBox Class REX.Controls.Forms Namespace REXUnitEditBox Class

Gets the maximum value and converts it to interface units.

C#
public double GetInterfaceMaxValue(REXInterfaceType interfaceType);
Parameters
Parameters | Description
interfaceType | The product context.
Returns

The value.

Description
Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.Forms Namespace, REXUnitEditBox Class


REXUnitEditBox.GetInterfaceMinValue Method

REXUnitEditBox.GetInterfaceMinValue Method
REXUnitEditBox Class REX.Controls.Forms Namespace REXUnitEditBox Class

Gets the minimum value and converts it to interface units.

C#
public double GetInterfaceMinValue(REXInterfaceType interfaceType);
Parameters
Parameters | Description
interfaceType | The product context.
Returns

The value.

Description
Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.Forms Namespace, REXUnitEditBox Class


REXUnitEditBox.SetBaseMaxValue Method

REXUnitEditBox.SetBaseMaxValue Method
REXUnitEditBox Class REX.Controls.Forms Namespace REXUnitEditBox Class

Set the maximum value defined in base units.

C#
public void SetBaseMaxValue(double value);
Parameters
Parameters | Description
value | The value.
Description
Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.Forms Namespace, REXUnitEditBox Class


REXUnitEditBox.SetBaseMinValue Method

REXUnitEditBox.SetBaseMinValue Method
REXUnitEditBox Class REX.Controls.Forms Namespace REXUnitEditBox Class

Set the minimum value defined in base units.

C#
public void SetBaseMinValue(double value);
Parameters
Parameters | Description
value | The value.
Description
Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.Forms Namespace, REXUnitEditBox Class


REXUnitEditBox.SetComplexDataBaseValue Method

REXUnitEditBox.SetComplexDataBaseValue Method
REXUnitEditBox Class REX.Controls.Forms Namespace REXUnitEditBox Class

Set the list of values defined in base units.

C#
public void SetComplexDataBaseValue(List<double> values);
Parameters
Parameters | Description
values | The values.
Description
Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.Forms Namespace, REXUnitEditBox Class


REXUnitEditBox.SetComplexDataInterfaceValue Method

REXUnitEditBox.SetComplexDataInterfaceValue Method
REXUnitEditBox Class REX.Controls.Forms Namespace REXUnitEditBox Class

Set the list of values defined in interface units.

C#
public void SetComplexDataInterfaceValue(List<double> values, REXInterfaceType interfaceType);
Parameters
Parameters | Description
values | The values.
interfaceType | The product context.
Description
Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.Forms Namespace, REXUnitEditBox Class


REXUnitEditBox.SetDataBaseValue Method

REXUnitEditBox.SetDataBaseValue Method
REXUnitEditBox Class REX.Controls.Forms Namespace REXUnitEditBox Class

Set the value in base units.

C#
public void SetDataBaseValue(double value);
Parameters
Parameters | Description
value | The value.
Description
Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.Forms Namespace, REXUnitEditBox Class


REXUnitEditBox.SetDataInterfaceValue Method

REXUnitEditBox.SetDataInterfaceValue Method
REXUnitEditBox Class REX.Controls.Forms Namespace REXUnitEditBox Class

Set the value in interface units.

C#
public void SetDataInterfaceValue(double value, REXInterfaceType interfaceType);
Parameters
Parameters | Description
value | The value.
interfaceType | The product context.
Description
Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.Forms Namespace, REXUnitEditBox Class


REXUnitEditBox.SetInterfaceMaxValue Method

REXUnitEditBox.SetInterfaceMaxValue Method
REXUnitEditBox Class REX.Controls.Forms Namespace REXUnitEditBox Class

Set the maximum value defined in interface units.

C#
public void SetInterfaceMaxValue(double value, REXInterfaceType interfaceType);
Parameters
Parameters | Description
value | The value.
interfaceType | The product context.
Description
Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.Forms Namespace, REXUnitEditBox Class


REXUnitEditBox.SetInterfaceMinValue Method

REXUnitEditBox.SetInterfaceMinValue Method
REXUnitEditBox Class REX.Controls.Forms Namespace REXUnitEditBox Class

Set the minimum value defined in interface units.

C#
public void SetInterfaceMinValue(double value, REXInterfaceType interfaceType);
Parameters
Parameters | Description
value | The value.
interfaceType | The product context.
Description
Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.Forms Namespace, REXUnitEditBox Class


REXUnitEditBox.Power Property

REXUnitEditBox.Power Property
REXUnitEditBox Class REX.Controls.Forms Namespace REXUnitEditBox Class

Gets or sets the power of the unit.

C#
public double Power;
Description

The power.

Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.Forms Namespace, REXUnitEditBox Class


REXUnitEditBox.UnitEngine Property

REXUnitEditBox.UnitEngine Property
REXUnitEditBox Class REX.Controls.Forms Namespace REXUnitEditBox Class

Gets or sets the unit engine.

C#
public Autodesk.REX.Framework.IREXUnits UnitEngine;
Description

The unit engine.

Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.Forms Namespace, REXUnitEditBox Class


REXUnitEditBox.UnitType Property

REXUnitEditBox.UnitType Property
REXUnitEditBox Class REX.Controls.Forms Namespace REXUnitEditBox Class

Gets or sets the type of the unit.

C#
public Autodesk.REX.Framework.EUnitType UnitType;
Description

The type of the unit.

Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.Forms Namespace, REXUnitEditBox Class


REX.Controls.WPF Namespace

Previous | Next
REX.Controls.WPF Namespace
Legend Classes

This is namespace REX.Controls.WPF.

Classes
Class | Description
REXComboBox | Represents a REX combo box control.
REXEditBox | Represents the REXEditBox control.
REXImageComboBox | Represents combobox with images.
REXImageComboBoxItem | Represents the combobox item with an image inside.
REXIndexLabel | Represents the REXIndexLabel control.
REXToolbox | Represents the REXToolbox control
REXToolboxCategoriesCollection | Represents collection of categories of the REXToolbox control.
REXToolboxCategory | Represents the REXToolbox category.
REXToolboxCollection | Base classes for REXToolboxs collections.
REXToolboxItem | Represents the REXToolbox item.
REXToolboxItemsCollection | Represents collection of items of the REXToolbox control.
REXToolboxObject | The base class for all toolbox objects (categories and items)
REXUnitComboBox | Represents the REXUnitComboBox control with a built in IREXUnitEngine.
REXUnitEditBox | Represents the REXEditBox control with a built in IREXUnitEngine.
WPFCommon | This is class REX.Controls.WPF.WPFCommon.
Links
Legend, Classes
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXComboBox Class

REXComboBox Class
REX.Controls.WPF Namespace Legend Members Public Methods REXComboBox Fields REXComboBox Methods REXComboBox Properties

Represents a REX combo box control.

Class Hierarchy
C#
public class REXComboBox : ComboBox, IUnitObject3, Common.IComboEditControl;
Description

It works in two modes: combo box mode, edit box mode.

Namespace

REX.Controls.WPF Namespace

Public Methods
Public Method | Description
REXComboBox | Initializes a new instance of the REXComboBox class.
REXComboBox Fields
REXComboBox Fields | Description
BackgroundDisabledHiddenProperty | This is BackgroundDisabledHiddenProperty, a member of class REXComboBox.
BackgroundDisabledStandardProperty | This is BackgroundDisabledStandardProperty, a member of class REXComboBox.
BackgroundErrorProperty | This is BackgroundErrorProperty, a member of class REXComboBox.
BackgroundNeutralProperty | This is BackgroundNeutralProperty, a member of class REXComboBox.
BackgroundOKProperty | This is BackgroundOKProperty, a member of class REXComboBox.
ComplexDoubleValueProperty | This is ComplexDoubleValueProperty, a member of class REXComboBox.
ComplexProperty | This is ComplexProperty, a member of class REXComboBox.
ComplexSeparatorProperty | This is ComplexSeparatorProperty, a member of class REXComboBox.
ComplexSpaceSeparatorProperty | This is ComplexSpaceSeparatorProperty, a member of class REXComboBox.
ComplexUnitOnEndProperty | This is ComplexUnitOnEndProperty, a member of class REXComboBox.
CorrectValueProperty | This is CorrectValueProperty, a member of class REXComboBox.
DataTypeProperty | This is DataTypeProperty, a member of class REXComboBox.
DoubleValueProperty | This is DoubleValueProperty, a member of class REXComboBox.
EngineeringFormatProperty | This is EngineeringFormatProperty, a member of class REXComboBox.
EpsilonProperty | This is EpsilonProperty, a member of class REXComboBox.
InvalidCharactersProperty | This is InvalidCharactersProperty, a member of class REXComboBox.
ListValidationProperty | This is ListValidationProperty, a member of class REXComboBox.
MaxTokensProperty | This is MaxTokensProperty, a member of class REXComboBox.
MinTokensProperty | This is MinTokensProperty, a member of class REXComboBox.
OnDisableActionProperty | This is OnDisableActionProperty, a member of class REXComboBox.
OriginalTextOnEnterProperty | This is OriginalTextOnEnterProperty, a member of class REXComboBox.
RangeMaxCheckProperty | This is RangeMaxCheckProperty, a member of class REXComboBox.
RangeMaxProperty | This is RangeMaxProperty, a member of class REXComboBox.
RangeMinCheckProperty | This is RangeMinCheckProperty, a member of class REXComboBox.
RangeMinProperty | This is RangeMinProperty, a member of class REXComboBox.
RememberCorrectProperty | This is RememberCorrectProperty, a member of class REXComboBox.
RoundingFractionalProperty | This is RoundingFractionalProperty, a member of class REXComboBox.
RoundingIncrementProperty | This is RoundingIncrementProperty, a member of class REXComboBox.
SeparatorProperty | This is SeparatorProperty, a member of class REXComboBox.
TextBoxModeProperty | This is TextBoxModeProperty, a member of class REXComboBox.
TokensRangeMaxCheckProperty | This is TokensRangeMaxCheckProperty, a member of class REXComboBox.
TokensRangeMinCheckProperty | This is TokensRangeMinCheckProperty, a member of class REXComboBox.
UnitSymbolProperty | This is UnitSymbolProperty, a member of class REXComboBox.
REXComboBox Methods
REXComboBox Methods | Description
AddEnabledChangedHandler | Adds the handler to the event raised when the element changes it's enable state.
AddLostFocusHandler | Adds the handler to the event raised when the element loses logical focus.
AddTextChangedHandler | Adds the handler to the event raised when text changes.
Editable | Gets a value indicating whether the control is editable.
GetBackground | Gets the background of the control.
GetComplexDoubleValue | Gets the complex (list) value of the double type.
GetComplexStringValue | Returns a complex string list.
GetEnable | Indicates whether the control is enabled.
GetFullName | Gets the full name.
GetItems | Gets the collection of the items contained in the control.
GetLastCorrectValueStr | Gets the last correct stored value.
GetPropertiesType | Gets the mode of the combo.
GetSelectedIndex | Gets the index specifying the currently selected item.
GetState | Gets the current state of the control.
GetText | Gets the text contents of the control.
GetUniqueName | Returns the Unique ID generated for the current instance of the engine.
GetValue | Gets the value of the double type.
Refresh | Refreshes the text on the control based on the current text.
RefreshValidationStatus | Refreshes the validation status.
Reset | Resets control (internal values).
RestorePropertiesType | Restores the mode of the combo.
SetBackground | Sets the background of the control.
SetComplexValue | Sets the complex (list) value of the string type.
SetComplexValue | Sets the complex (list) value of the string type.
SetComplexValue | Set complex value to the control
SetEnable | Sets the enable state.
SetExternalUnitBody | Sets external IUnitBody object for custom unit processing.
SetPropertiesType | Sets the mode of the combo.
SetSelectedIndex | Sets the index specifying the currently selected item.
SetText | Sets the text contents of the control.
SetUserTextValidation | Sets the user validation method for the text control.
SetUserValidation | Sets the user validation method.
SetUserValidationComplex | Sets the user validation method for complex values (list).
SetValue | Sets the value of the double type.
SetValue | Sets the value of the string type.
ValidateComplexValue | Validates the complex (list) value of the double type.
ValidateComplexValue | Validates the complex (list) value of the string type.
ValidateComplexValue | Validates the complex (list) value of the string type.
ValidateValue | Validates the input value of the double type.
ValidateValue | Validates the value of the string type.
ValueFormat | Returns a text containing an expression formatted according the current settings of the element.
ValueFormat | Returns a text containing an expression formatted according the current settings of the element.
ValueParse | Converts the specified text to the numeric value according the current settings of the element.
REXComboBox Properties
REXComboBox Properties | Description
BackgroundDisabledHidden | Gets or sets the background for the disabled state of the control in the hidden background mode.
BackgroundDisabledStandard | Gets or sets the background for the disabled state of the control.
BackgroundError | Gets or sets the background for the Error state of the control.
BackgroundNeutral | Gets or sets the background for the neutral state of the control.
BackgroundOK | Gets or sets the background for the OK state of the control.
Complex | Gets or sets a value indicating whether this REXEditControlEngine supports complex (list) values.
ComplexDoubleValue | Gets or sets the complex double value.
ComplexSeparator | Gets or sets the complex (list) separator.
ComplexSpaceSeparator | Gets or sets a value indicating whether a space should be respected as a list separator.
ComplexUnitOnEnd | Gets or sets a value indicating whether a unit symbol should be placed on the end of the formatted text.
ControlState | Gets the current state of the control.
CorrectValue | Gets or sets the correct value.
DataType | Gets or sets the type of the data in the control.
DoubleValue | Gets or sets the double value.
EngineeringFormat | Gets or sets a value indicating whether the text of the control should be formatted in according to the engineering (expotential) format.
Epsilon | Gets or sets the accuracy.
InvalidCharacters | Gets or sets the list invalid characters (for the control in TEXT mode).
ListValidation | Gets or sets a value indicating whether the list should be validated.
MaxTokens | Gets or sets the maximum number of elements in the complex mode (list).
MinTokens | Gets or sets the minimum number of elements in the complex mode (list).
OnDisableAction | Gets or sets a value indicating whether the foreground should be hidden when the control is disabled.
OriginalTextOnEnter | Gets or sets a value indicating whether an original text should be set when the user enters the control.
RangeMax | Gets or sets the highest possible value.
RangeMaxCheck | Gets or sets a value indicating whether the value should be validated due to the RangeMax.
RangeMin | Gets or sets the minimum possible value.
RangeMinCheck | Gets or sets a value indicating whether the value should be validated due to the RangeMin.
RememberCorrect | Gets or sets a value indicating whether the correct value should be restored in case of the validation failure.
RoundingFractional | Gets or sets the rounding for fractional units.
RoundingIncrement | Gets or sets the rounding increment (for the DECIMAL DataType).
Separator | Gets or sets the decimal separator.
TextBoxMode | Gets or sets a value indicating whether the combobox is in the editbox mode.
TokensRangeMaxCheck | Gets or sets a value indicating whether the number of elements should be validated due to the MaxTokens.
TokensRangeMinCheck | Gets or sets a value indicating whether the number of elements should be validated due to the MinTokens.
UnitSymbol | Gets or sets the unit symbol.
Links
REX.Controls.WPF Namespace, Legend, Members, Public Methods, REXComboBox Fields, REXComboBox Methods, REXComboBox Properties


REXComboBox.REXComboBox Constructor

REXComboBox.REXComboBox Constructor
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Initializes a new instance of the REXComboBox class.

C#
public REXComboBox();
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.BackgroundDisabledHiddenProperty Field

REXComboBox.BackgroundDisabledHiddenProperty Field
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

This is BackgroundDisabledHiddenProperty, a member of class REXComboBox.

C#
public static readonly DependencyProperty BackgroundDisabledHiddenProperty;
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.BackgroundDisabledStandardProperty Field

REXComboBox.BackgroundDisabledStandardProperty Field
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

This is BackgroundDisabledStandardProperty, a member of class REXComboBox.

C#
public static readonly DependencyProperty BackgroundDisabledStandardProperty;
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.BackgroundErrorProperty Field

REXComboBox.BackgroundErrorProperty Field
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

This is BackgroundErrorProperty, a member of class REXComboBox.

C#
public static readonly DependencyProperty BackgroundErrorProperty;
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.BackgroundNeutralProperty Field

REXComboBox.BackgroundNeutralProperty Field
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

This is BackgroundNeutralProperty, a member of class REXComboBox.

C#
public static readonly DependencyProperty BackgroundNeutralProperty;
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.BackgroundOKProperty Field

REXComboBox.BackgroundOKProperty Field
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

This is BackgroundOKProperty, a member of class REXComboBox.

C#
public static readonly DependencyProperty BackgroundOKProperty;
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.ComplexDoubleValueProperty Field

REXComboBox.ComplexDoubleValueProperty Field
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

This is ComplexDoubleValueProperty, a member of class REXComboBox.

C#
public static readonly DependencyProperty ComplexDoubleValueProperty;
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.ComplexProperty Field

REXComboBox.ComplexProperty Field
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

This is ComplexProperty, a member of class REXComboBox.

C#
public static readonly DependencyProperty ComplexProperty;
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.ComplexSeparatorProperty Field

REXComboBox.ComplexSeparatorProperty Field
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

This is ComplexSeparatorProperty, a member of class REXComboBox.

C#
public static readonly DependencyProperty ComplexSeparatorProperty;
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.ComplexSpaceSeparatorProperty Field

REXComboBox.ComplexSpaceSeparatorProperty Field
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

This is ComplexSpaceSeparatorProperty, a member of class REXComboBox.

C#
public static readonly DependencyProperty ComplexSpaceSeparatorProperty;
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.ComplexUnitOnEndProperty Field

REXComboBox.ComplexUnitOnEndProperty Field
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

This is ComplexUnitOnEndProperty, a member of class REXComboBox.

C#
public static readonly DependencyProperty ComplexUnitOnEndProperty;
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.CorrectValueProperty Field

REXComboBox.CorrectValueProperty Field
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

This is CorrectValueProperty, a member of class REXComboBox.

C#
public static readonly DependencyProperty CorrectValueProperty;
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.DataTypeProperty Field

REXComboBox.DataTypeProperty Field
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

This is DataTypeProperty, a member of class REXComboBox.

C#
public static readonly DependencyProperty DataTypeProperty;
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.DoubleValueProperty Field

REXComboBox.DoubleValueProperty Field
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

This is DoubleValueProperty, a member of class REXComboBox.

C#
public static readonly DependencyProperty DoubleValueProperty;
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.EngineeringFormatProperty Field

REXComboBox.EngineeringFormatProperty Field
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

This is EngineeringFormatProperty, a member of class REXComboBox.

C#
public static readonly DependencyProperty EngineeringFormatProperty;
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.EpsilonProperty Field

REXComboBox.EpsilonProperty Field
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

This is EpsilonProperty, a member of class REXComboBox.

C#
public static readonly DependencyProperty EpsilonProperty;
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.InvalidCharactersProperty Field

REXComboBox.InvalidCharactersProperty Field
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

This is InvalidCharactersProperty, a member of class REXComboBox.

C#
public static readonly DependencyProperty InvalidCharactersProperty;
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.ListValidationProperty Field

REXComboBox.ListValidationProperty Field
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

This is ListValidationProperty, a member of class REXComboBox.

C#
public static readonly DependencyProperty ListValidationProperty;
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.MaxTokensProperty Field

REXComboBox.MaxTokensProperty Field
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

This is MaxTokensProperty, a member of class REXComboBox.

C#
public static readonly DependencyProperty MaxTokensProperty;
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.MinTokensProperty Field

REXComboBox.MinTokensProperty Field
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

This is MinTokensProperty, a member of class REXComboBox.

C#
public static readonly DependencyProperty MinTokensProperty;
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.OnDisableActionProperty Field

REXComboBox.OnDisableActionProperty Field
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

This is OnDisableActionProperty, a member of class REXComboBox.

C#
public static readonly DependencyProperty OnDisableActionProperty;
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.OriginalTextOnEnterProperty Field

REXComboBox.OriginalTextOnEnterProperty Field
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

This is OriginalTextOnEnterProperty, a member of class REXComboBox.

C#
public static readonly DependencyProperty OriginalTextOnEnterProperty;
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.RangeMaxCheckProperty Field

REXComboBox.RangeMaxCheckProperty Field
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

This is RangeMaxCheckProperty, a member of class REXComboBox.

C#
public static readonly DependencyProperty RangeMaxCheckProperty;
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.RangeMaxProperty Field

REXComboBox.RangeMaxProperty Field
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

This is RangeMaxProperty, a member of class REXComboBox.

C#
public static readonly DependencyProperty RangeMaxProperty;
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.RangeMinCheckProperty Field

REXComboBox.RangeMinCheckProperty Field
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

This is RangeMinCheckProperty, a member of class REXComboBox.

C#
public static readonly DependencyProperty RangeMinCheckProperty;
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.RangeMinProperty Field

REXComboBox.RangeMinProperty Field
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

This is RangeMinProperty, a member of class REXComboBox.

C#
public static readonly DependencyProperty RangeMinProperty;
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.RememberCorrectProperty Field

REXComboBox.RememberCorrectProperty Field
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

This is RememberCorrectProperty, a member of class REXComboBox.

C#
public static readonly DependencyProperty RememberCorrectProperty;
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.RoundingFractionalProperty Field

REXComboBox.RoundingFractionalProperty Field
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

This is RoundingFractionalProperty, a member of class REXComboBox.

C#
public static readonly DependencyProperty RoundingFractionalProperty;
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.RoundingIncrementProperty Field

REXComboBox.RoundingIncrementProperty Field
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

This is RoundingIncrementProperty, a member of class REXComboBox.

C#
public static readonly DependencyProperty RoundingIncrementProperty;
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.SeparatorProperty Field

REXComboBox.SeparatorProperty Field
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

This is SeparatorProperty, a member of class REXComboBox.

C#
public static readonly DependencyProperty SeparatorProperty;
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.TextBoxModeProperty Field

REXComboBox.TextBoxModeProperty Field
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

This is TextBoxModeProperty, a member of class REXComboBox.

C#
public static readonly DependencyProperty TextBoxModeProperty;
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.TokensRangeMaxCheckProperty Field

REXComboBox.TokensRangeMaxCheckProperty Field
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

This is TokensRangeMaxCheckProperty, a member of class REXComboBox.

C#
public static readonly DependencyProperty TokensRangeMaxCheckProperty;
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.TokensRangeMinCheckProperty Field

REXComboBox.TokensRangeMinCheckProperty Field
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

This is TokensRangeMinCheckProperty, a member of class REXComboBox.

C#
public static readonly DependencyProperty TokensRangeMinCheckProperty;
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.UnitSymbolProperty Field

REXComboBox.UnitSymbolProperty Field
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

This is UnitSymbolProperty, a member of class REXComboBox.

C#
public static readonly DependencyProperty UnitSymbolProperty;
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.AddEnabledChangedHandler Method

REXComboBox.AddEnabledChangedHandler Method
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Adds the handler to the event raised when the element changes it's enable state.

C#
public void AddEnabledChangedHandler(EventHandler eh);
Parameters
Parameters | Description
eh | The event handler.
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.AddLostFocusHandler Method

REXComboBox.AddLostFocusHandler Method
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Adds the handler to the event raised when the element loses logical focus.

C#
public void AddLostFocusHandler(EventHandler eh);
Parameters
Parameters | Description
eh | The event handler.
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.AddTextChangedHandler Method

REXComboBox.AddTextChangedHandler Method
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Adds the handler to the event raised when text changes.

C#
public void AddTextChangedHandler(EventHandler eh);
Parameters
Parameters | Description
eh | The event handler.
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.Editable Method

REXComboBox.Editable Method
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Gets a value indicating whether the control is editable.

C#
public bool Editable();
Returns

True if the control can be edited; otherwise false.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.GetBackground Method

REXComboBox.GetBackground Method
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Gets the background of the control.

C#
public object GetBackground();
Returns

The background.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.GetComplexDoubleValue Method

REXComboBox.GetComplexDoubleValue Method
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Gets the complex (list) value of the double type.

C#
public List<double> GetComplexDoubleValue();
Returns

The list of values.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.GetComplexStringValue Method

REXComboBox.GetComplexStringValue Method
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Returns a complex string list.

C#
public List<string> GetComplexStringValue();
Returns

The list of values.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.GetEnable Method

REXComboBox.GetEnable Method
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Indicates whether the control is enabled.

C#
public bool GetEnable();
Returns

True if the element is enabled; otherwise, false.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.GetFullName Method

REXComboBox.GetFullName Method
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Gets the full name.

C#
public string GetFullName();
Returns

The full name.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.GetItems Method

REXComboBox.GetItems Method
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Gets the collection of the items contained in the control.

C#
public List<string> GetItems();
Returns

The list of items.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.GetLastCorrectValueStr Method

REXComboBox.GetLastCorrectValueStr Method
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Gets the last correct stored value.

C#
public String GetLastCorrectValueStr();
Returns

The correct value.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.GetPropertiesType Method

REXComboBox.GetPropertiesType Method
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Gets the mode of the combo.

C#
public EComboPropertiesType GetPropertiesType();
Returns

The mode of the combo box.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.GetSelectedIndex Method

REXComboBox.GetSelectedIndex Method
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Gets the index specifying the currently selected item.

C#
public int GetSelectedIndex();
Returns

The index.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.GetState Method

REXComboBox.GetState Method
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Gets the current state of the control.

C#
public EControlState GetState();
Returns

The state of the control.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.GetText Method

REXComboBox.GetText Method
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Gets the text contents of the control.

C#
public string GetText();
Returns

The text contents of the control.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.GetUniqueName Method

REXComboBox.GetUniqueName Method
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Returns the Unique ID generated for the current instance of the engine.

C#
public string GetUniqueName();
Returns

The unique ID.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.GetValue Method

REXComboBox.GetValue Method
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Gets the value of the double type.

C#
public double GetValue();
Returns

The value.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.Refresh Method

REXComboBox.Refresh Method
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Refreshes the text on the control based on the current text.

C#
public void Refresh();
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.RefreshValidationStatus Method

REXComboBox.RefreshValidationStatus Method
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Refreshes the validation status.

C#
public void RefreshValidationStatus();
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.Reset Method

REXComboBox.Reset Method
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Resets control (internal values).

C#
public void Reset();
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.RestorePropertiesType Method

REXComboBox.RestorePropertiesType Method
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Restores the mode of the combo.

C#
public void RestorePropertiesType();
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.SetBackground Method

REXComboBox.SetBackground Method
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Sets the background of the control.

C#
public void SetBackground(object brush);
Parameters
Parameters | Description
background | The background.
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.SetComplexValue Method (List<double>)

REXComboBox.SetComplexValue Method (List<double>)
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Sets the complex (list) value of the string type.

C#
public void SetComplexValue(List<double> values);
Parameters
Parameters | Description
value | The value.
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.SetComplexValue Method (List<string>)

REXComboBox.SetComplexValue Method (List<string>)
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Sets the complex (list) value of the string type.

C#
public void SetComplexValue(List<string> values);
Parameters
Parameters | Description
value | The value.
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.SetComplexValue Method (String)

REXComboBox.SetComplexValue Method (String)
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Set complex value to the control

C#
public bool SetComplexValue(String value);
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.SetEnable Method

REXComboBox.SetEnable Method
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Sets the enable state.

C#
public void SetEnable(bool enable);
Parameters
Parameters | Description
enable | If the control is to be enabled.
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.SetExternalUnitBody Method

REXComboBox.SetExternalUnitBody Method
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Sets external IUnitBody object for custom unit processing.

C#
public void SetExternalUnitBody(IUnitBody unitBody);
Parameters
Parameters | Description
unitBody | External IUnitBody.
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.SetPropertiesType Method

REXComboBox.SetPropertiesType Method
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Sets the mode of the combo.

C#
public void SetPropertiesType(EComboPropertiesType propertiesType);
Parameters
Parameters | Description
propertiesType | The mode of the combo.
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.SetSelectedIndex Method

REXComboBox.SetSelectedIndex Method
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Sets the index specifying the currently selected item.

C#
public void SetSelectedIndex(int index);
Parameters
Parameters | Description
index | The index of the selected item.
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.SetText Method

REXComboBox.SetText Method
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Sets the text contents of the control.

C#
public void SetText(string txt);
Parameters
Parameters | Description
txt | The text.
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.SetUserTextValidation Method

REXComboBox.SetUserTextValidation Method
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Sets the user validation method for the text control.

C#
public void SetUserTextValidation(UserTextValidation ValidFunction);
Parameters
Parameters | Description
ValidFunction | The validation method.
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.SetUserValidation Method

REXComboBox.SetUserValidation Method
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Sets the user validation method.

C#
public void SetUserValidation(UserValidation ValidFunction);
Parameters
Parameters | Description
ValidFunction | The validation method.
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.SetUserValidationComplex Method

REXComboBox.SetUserValidationComplex Method
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Sets the user validation method for complex values (list).

C#
public void SetUserValidationComplex(UserValidationComplex ValidFunction);
Parameters
Parameters | Description
ValidFunction | The validation method.
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.SetValue Method (Double)

REXComboBox.SetValue Method (Double)
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Sets the value of the double type.

C#
public void SetValue(Double value);
Parameters
Parameters | Description
value | The value.
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.SetValue Method (String)

REXComboBox.SetValue Method (String)
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Sets the value of the string type.

C#
public void SetValue(String value);
Parameters
Parameters | Description
value | The value.
Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.ValidateComplexValue Method (List<double>)

REXComboBox.ValidateComplexValue Method (List<double>)
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Validates the complex (list) value of the double type.

C#
public bool ValidateComplexValue(List<double> values);
Parameters
Parameters | Description
values | The values to validate.
Returns

True if validated; otherwise false.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.ValidateComplexValue Method (List<string>)

REXComboBox.ValidateComplexValue Method (List<string>)
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Validates the complex (list) value of the string type.

C#
public bool ValidateComplexValue(List<string> values);
Parameters
Parameters | Description
values | The values to validate.
Returns

True if validated; otherwise false.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.ValidateComplexValue Method (String)

REXComboBox.ValidateComplexValue Method (String)
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Validates the complex (list) value of the string type.

C#
public bool ValidateComplexValue(String value);
Parameters
Parameters | Description
value | The value to validate.
Returns

True if validated; otherwise false.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.ValidateValue Method (Double)

REXComboBox.ValidateValue Method (Double)
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Validates the input value of the double type.

C#
public bool ValidateValue(Double value);
Parameters
Parameters | Description
value | The value to validate.
Returns

True if validated; otherwise false.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.ValidateValue Method (String)

REXComboBox.ValidateValue Method (String)
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Validates the value of the string type.

C#
public bool ValidateValue(String value);
Parameters
Parameters | Description
value | The value to validate.
Returns

True if validated; otherwise false.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.ValueFormat Method (Double)

REXComboBox.ValueFormat Method (Double)
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Returns a text containing an expression formatted according the current settings of the element.

C#
public string ValueFormat(Double value);
Parameters
Parameters | Description
value | The value to format.
Returns

The formatted text.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.ValueFormat Method (String)

REXComboBox.ValueFormat Method (String)
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Returns a text containing an expression formatted according the current settings of the element.

C#
public string ValueFormat(String value);
Parameters
Parameters | Description
value | The value to format.
Returns

The formatted text.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.ValueParse Method

REXComboBox.ValueParse Method
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Converts the specified text to the numeric value according the current settings of the element.

C#
public double ValueParse(String value);
Parameters
Parameters | Description
value | The text.
Returns

The converted value.

Description
Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.BackgroundDisabledHidden Property

REXComboBox.BackgroundDisabledHidden Property
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Gets or sets the background for the disabled state of the control in the hidden background mode.

C#
[Browsable(true)]
[Category("Appearance")]
public Brush BackgroundDisabledHidden;
Description

The background.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.BackgroundDisabledStandard Property

REXComboBox.BackgroundDisabledStandard Property
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Gets or sets the background for the disabled state of the control.

C#
[Browsable(true)]
[Category("Appearance")]
[DefaultValue(typeof(Color), "LightBlue")]
public Brush BackgroundDisabledStandard;
Description

The background.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.BackgroundError Property

REXComboBox.BackgroundError Property
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Gets or sets the background for the Error state of the control.

C#
[Browsable(true)]
[Category("Appearance")]
[DefaultValue(typeof(Color), "LightCoral")]
public Brush BackgroundError;
Description

The Error background.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.BackgroundNeutral Property

REXComboBox.BackgroundNeutral Property
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Gets or sets the background for the neutral state of the control.

C#
[Browsable(true)]
[Category("Appearance")]
[DefaultValue(typeof(SystemColors), "Window")]
public Brush BackgroundNeutral;
Description

The neutral background.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.BackgroundOK Property

REXComboBox.BackgroundOK Property
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Gets or sets the background for the OK state of the control.

C#
[Browsable(true)]
[Category("Appearance")]
[DefaultValue(typeof(Color), "LightGreen")]
public Brush BackgroundOK;
Description

The OK background.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.Complex Property

REXComboBox.Complex Property
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Gets or sets a value indicating whether this REXEditControlEngine supports complex (list) values.

C#
[Category("Complex")]
[Browsable(true)]
public bool Complex;
Description

True if the engine supports complex values; otherwise false.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.ComplexDoubleValue Property

REXComboBox.ComplexDoubleValue Property
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Gets or sets the complex double value.

C#
public ObservableCollection<double> ComplexDoubleValue;
Description

The complex double value.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.ComplexSeparator Property

REXComboBox.ComplexSeparator Property
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Gets or sets the complex (list) separator.

C#
[Category("Complex")]
[Browsable(true)]
[DefaultValue(";")]
public string ComplexSeparator;
Description

The complex separator.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.ComplexSpaceSeparator Property

REXComboBox.ComplexSpaceSeparator Property
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Gets or sets a value indicating whether a space should be respected as a list separator.

C#
[Category("Complex")]
[Browsable(true)]
public bool ComplexSpaceSeparator;
Description

True if space respected as a list separator; otherwise, false.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.ComplexUnitOnEnd Property

REXComboBox.ComplexUnitOnEnd Property
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Gets or sets a value indicating whether a unit symbol should be placed on the end of the formatted text.

C#
[Category("Complex")]
[Browsable(true)]
public bool ComplexUnitOnEnd;
Description

True if the unit one the end; otherwise, false.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.ControlState Property

REXComboBox.ControlState Property
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Gets the current state of the control.

C#
[Browsable(false)]
public EControlState ControlState;
Description

The state of the control.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.CorrectValue Property

REXComboBox.CorrectValue Property
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Gets or sets the correct value.

C#
public string CorrectValue;
Description

The correct value.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.DataType Property

REXComboBox.DataType Property
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Gets or sets the type of the data in the control.

C#
[Browsable(true)]
[Category("Data")]
public EControlType DataType;
Description

The type of the data.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.DoubleValue Property

REXComboBox.DoubleValue Property
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Gets or sets the double value.

C#
public double DoubleValue;
Description

The double value.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.EngineeringFormat Property

REXComboBox.EngineeringFormat Property
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Gets or sets a value indicating whether the text of the control should be formatted in according to the engineering (expotential) format.

C#
[Browsable(true)]
[Category("Data")]
[DefaultValue(false)]
public bool EngineeringFormat;
Description

True if engineering format; otherwise false.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.Epsilon Property

REXComboBox.Epsilon Property
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Gets or sets the accuracy.

C#
[Browsable(true)]
public double Epsilon;
Description

The accuracy.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.InvalidCharacters Property

REXComboBox.InvalidCharacters Property
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Gets or sets the list invalid characters (for the control in TEXT mode).

C#
[Browsable(true)]
public string InvalidCharacters;
Description

The list of invalid characters.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.ListValidation Property

REXComboBox.ListValidation Property
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Gets or sets a value indicating whether the list should be validated.

C#
[Category("Data")]
[Browsable(true)]
[DefaultValue(false)]
public bool ListValidation;
Description

True if validate; otherwise false.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.MaxTokens Property

REXComboBox.MaxTokens Property
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Gets or sets the maximum number of elements in the complex mode (list).

C#
[Category("Complex")]
[Browsable(true)]
public int MaxTokens;
Description

The maximum number of elements.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.MinTokens Property

REXComboBox.MinTokens Property
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Gets or sets the minimum number of elements in the complex mode (list).

C#
[Category("Complex")]
[Browsable(true)]
public int MinTokens;
Description

The minimum number of elements.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.OnDisableAction Property

REXComboBox.OnDisableAction Property
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Gets or sets a value indicating whether the foreground should be hidden when the control is disabled.

C#
[Browsable(true)]
[Category("Data")]
public EOnDisable OnDisableAction;
Description

The behaviour of the control's foreground.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.OriginalTextOnEnter Property

REXComboBox.OriginalTextOnEnter Property
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Gets or sets a value indicating whether an original text should be set when the user enters the control.

C#
[Browsable(true)]
[Category("Behavior")]
public bool OriginalTextOnEnter;
Description

True if original text is to be set; otherwise, false.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.RangeMax Property

REXComboBox.RangeMax Property
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Gets or sets the highest possible value.

C#
[Browsable(true)]
[Category("Data")]
[DefaultValue(Double.PositiveInfinity)]
public double RangeMax;
Description

The highest possible value.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.RangeMaxCheck Property

REXComboBox.RangeMaxCheck Property
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Gets or sets a value indicating whether the value should be validated due to the RangeMax.

C#
[Browsable(true)]
[Category("Data")]
[DefaultValue(false)]
public bool RangeMaxCheck;
Description

True if validate; otherwise false.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.RangeMin Property

REXComboBox.RangeMin Property
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Gets or sets the minimum possible value.

C#
[Browsable(true)]
[Category("Data")]
[DefaultValue(Double.NegativeInfinity)]
public double RangeMin;
Description

The minimum possible value.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.RangeMinCheck Property

REXComboBox.RangeMinCheck Property
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Gets or sets a value indicating whether the value should be validated due to the RangeMin.

C#
[Browsable(true)]
[Category("Data")]
[DefaultValue(false)]
public bool RangeMinCheck;
Description

True if validate; otherwise false.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.RememberCorrect Property

REXComboBox.RememberCorrect Property
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Gets or sets a value indicating whether the correct value should be restored in case of the validation failure.

C#
[Browsable(true)]
[Category("Data")]
public bool RememberCorrect;
Description

True if the value should be restored; otherwise false.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.RoundingFractional Property

REXComboBox.RoundingFractional Property
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Gets or sets the rounding for fractional units.

C#
[Browsable(true)]
[Category("Data")]
public EFractialRound RoundingFractional;
Description

The rounding.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.RoundingIncrement Property

REXComboBox.RoundingIncrement Property
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Gets or sets the rounding increment (for the DECIMAL DataType).

C#
[Browsable(true)]
[Category("Data")]
public double RoundingIncrement;
Description

The rounding increment.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.Separator Property

REXComboBox.Separator Property
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Gets or sets the decimal separator.

C#
[Browsable(true)]
[Category("Data")]
public string Separator;
Description

The separator.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.TextBoxMode Property

REXComboBox.TextBoxMode Property
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Gets or sets a value indicating whether the combobox is in the editbox mode.

C#
public bool TextBoxMode;
Description

True if the control is in editbox mode; otherwise, false.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.TokensRangeMaxCheck Property

REXComboBox.TokensRangeMaxCheck Property
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Gets or sets a value indicating whether the number of elements should be validated due to the MaxTokens.

C#
[Category("Complex")]
[Browsable(true)]
[DefaultValue(false)]
public bool TokensRangeMaxCheck;
Description

True if validate; otherwise, false.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.TokensRangeMinCheck Property

REXComboBox.TokensRangeMinCheck Property
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Gets or sets a value indicating whether the number of elements should be validated due to the MinTokens.

C#
[Category("Complex")]
[Browsable(true)]
[DefaultValue(false)]
public bool TokensRangeMinCheck;
Description

True if validate; otherwise, false.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXComboBox.UnitSymbol Property

REXComboBox.UnitSymbol Property
REXComboBox Class REX.Controls.WPF Namespace REXComboBox Class

Gets or sets the unit symbol.

C#
[Browsable(true)]
[Category("Data")]
[DefaultValue("")]
public string UnitSymbol;
Description

The unit symbol.

Class

REXComboBox Class

Links
REXComboBox Class, REX.Controls.WPF Namespace, REXComboBox Class


REXEditBox Class

REXEditBox Class
REX.Controls.WPF Namespace Legend Members REXEditBox Fields REXEditBox Methods REXEditBox Properties

Represents the REXEditBox control.

Class Hierarchy
C#
public class REXEditBox : System.Windows.Controls.TextBox, IUnitObject3, REX.Controls.Common.IEditControl;
Description
Namespace

REX.Controls.WPF Namespace

REXEditBox Fields
REXEditBox Fields | Description
BackgroundDisabledHiddenProperty | This is BackgroundDisabledHiddenProperty, a member of class REXEditBox.
BackgroundDisabledStandardProperty | This is BackgroundDisabledStandardProperty, a member of class REXEditBox.
BackgroundErrorProperty | This is BackgroundErrorProperty, a member of class REXEditBox.
BackgroundNeutralProperty | This is BackgroundNeutralProperty, a member of class REXEditBox.
BackgroundOKProperty | This is BackgroundOKProperty, a member of class REXEditBox.
ComplexDoubleValueProperty | This is ComplexDoubleValueProperty, a member of class REXEditBox.
ComplexProperty | This is ComplexProperty, a member of class REXEditBox.
ComplexSeparatorProperty | This is ComplexSeparatorProperty, a member of class REXEditBox.
ComplexSpaceSeparatorProperty | This is ComplexSpaceSeparatorProperty, a member of class REXEditBox.
ComplexUnitOnEndProperty | This is ComplexUnitOnEndProperty, a member of class REXEditBox.
CorrectValueProperty | This is CorrectValueProperty, a member of class REXEditBox.
DataTypeProperty | This is DataTypeProperty, a member of class REXEditBox.
DoubleValueProperty | This is DoubleValueProperty, a member of class REXEditBox.
EngineeringFormatProperty | This is EngineeringFormatProperty, a member of class REXEditBox.
EpsilonProperty | This is EpsilonProperty, a member of class REXEditBox.
InvalidCharactersProperty | This is InvalidCharactersProperty, a member of class REXEditBox.
MaxTokensProperty | This is MaxTokensProperty, a member of class REXEditBox.
MinTokensProperty | This is MinTokensProperty, a member of class REXEditBox.
OnDisableActionProperty | This is OnDisableActionProperty, a member of class REXEditBox.
OriginalTextOnEnterProperty | This is OriginalTextOnEnterProperty, a member of class REXEditBox.
RangeMaxCheckProperty | This is RangeMaxCheckProperty, a member of class REXEditBox.
RangeMaxProperty | This is RangeMaxProperty, a member of class REXEditBox.
RangeMinCheckProperty | This is RangeMinCheckProperty, a member of class REXEditBox.
RangeMinProperty | This is RangeMinProperty, a member of class REXEditBox.
RememberCorrectProperty | This is RememberCorrectProperty, a member of class REXEditBox.
RoundingFractionalProperty | This is RoundingFractionalProperty, a member of class REXEditBox.
RoundingIncrementProperty | This is RoundingIncrementProperty, a member of class REXEditBox.
SeparatorProperty | This is SeparatorProperty, a member of class REXEditBox.
TokensRangeMaxCheckProperty | This is TokensRangeMaxCheckProperty, a member of class REXEditBox.
TokensRangeMinCheckProperty | This is TokensRangeMinCheckProperty, a member of class REXEditBox.
UnitSymbolProperty | This is UnitSymbolProperty, a member of class REXEditBox.
REXEditBox Methods
REXEditBox Methods | Description
AddEnabledChangedHandler | Adds the handler to the event raised when the element changes it's enable state.
AddLostFocusHandler | Adds the handler to the event raised when the element loses logical focus.
AddTextChangedHandler | Adds the handler to the event raised when text changes.
GetBackground | Gets the background of the control.
GetComplexDoubleValue | Gets the complex (list) value of the double type.
GetComplexStringValue | Returns a complex string list.
GetEnable | Indicates whether the control is enabled.
GetFullName | Gets the full name.
GetLastCorrectValueStr | Gets the last correct stored value.
GetState | Gets the current state of the control.
GetStringValue | Returns the original text.
GetText | Gets the text contents of the control.
GetUniqueName | Returns the Unique ID generated for the current instance of the engine.
GetValue | Gets the value of the double type.
Refresh | Refreshes the text on the control based on the current text.
RefreshValidationStatus | Refreshes the validation status.
Reset | Resets control (internal values).
SetBackground | Sets the background of the control.
SetComplexValue | Sets the complex (list) value of the double type.
SetComplexValue | Sets the complex (list) value of the string type.
SetComplexValue | Sets the complex (list) value of the string type.
SetEnable | Sets the enable state.
SetExternalUnitBody | Sets external IUnitBody object for custom unit processing.
SetText | Sets the text contents of the control.
SetUserTextValidation | Sets the user validation method for the text control.
SetUserValidation | Sets the user validation method.
SetUserValidationComplex | Sets the user validation method for complex values (list).
SetValue | Sets the value of the double type.
SetValue | Sets the value of the string type.
ValidateComplexValue | Validates the complex (list) value of the double type.
ValidateComplexValue | Validates the complex (list) value of the string type.
ValidateComplexValue | Validates the complex (list) value of the string type.
ValidateValue | Validates the input value of the double type.
ValidateValue | Validates the value of the string type.
ValueFormat | Returns a text containing an expression formatted according the current settings of the element.
ValueFormat | Returns a text containing an expression formatted according the current settings of the element.
ValueParse | Converts the specified text to the numeric value according the current settings of the element.
REXEditBox Properties
REXEditBox Properties | Description
BackgroundDisabledHidden | Gets or sets the background for the disabled state of the control in the hidden background mode.
BackgroundDisabledStandard | Gets or sets the background for the standard disabled status.
BackgroundError | Gets or sets the background for the Error state of the control.
BackgroundNeutral | Gets or sets the background for the neutral state of the control.
BackgroundOK | Gets or sets the background for the OK state of the control.
Complex | Gets or sets a value indicating whether this REXEditControlEngine supports complex (list) values.
ComplexDoubleValue | Gets or sets the complex double value.
ComplexSeparator | Gets or sets the complex (list) separator.
ComplexSpaceSeparator | Gets or sets a value indicating whether a space should be respected as a list separator.
ComplexUnitOnEnd | Gets or sets a value indicating whether a unit symbol should be placed on the end of the formatted text.
ControlState | Gets the current state of the control.
CorrectValue | Gets or sets the correct value.
DataType | Gets or sets the type of the data in the control.
DoubleValue | Gets or sets the double value.
EngineeringFormat | Gets or sets a value indicating whether the text of the control should be formatted in according to the engineering (expotential) format.
Epsilon | Gets or sets the accuracy.
InvalidCharacters | Gets or sets the list invalid characters (for the control in TEXT mode).
MaxTokens | Gets or sets the maximum number of elements in the complex mode (list).
MinTokens | Gets or sets the minimum number of elements in the complex mode (list).
OnDisableAction | Gets or sets a value indicating whether the foreground should be hidden when the control is disabled.
OriginalTextOnEnter | Gets or sets a value indicating whether an original text should be set when the user enters the control.
RangeMax | Gets or sets the highest possible value.
RangeMaxCheck | Gets or sets a value indicating whether the value should be validated due to the RangeMax.
RangeMin | Gets or sets the minimum possible value.
RangeMinCheck | Gets or sets a value indicating whether the value should be validated due to the RangeMin.
RememberCorrect | Gets or sets a value indicating whether the correct value should be restored in case of the validation failure.
RoundingFractional | Gets or sets the rounding for fractional units.
RoundingIncrement | Gets or sets the rounding increment (for the DECIMAL DataType).
Separator | Gets or sets the decimal separator.
TokensRangeMaxCheck | Gets or sets a value indicating whether the number of elements should be validated due to the MaxTokens.
TokensRangeMinCheck | Gets or sets a value indicating whether the number of elements should be validated due to the MinTokens.
UnitSymbol | Gets or sets the unit symbol.
Links
REX.Controls.WPF Namespace, Legend, Members, REXEditBox Fields, REXEditBox Methods, REXEditBox Properties


REXEditBox.BackgroundDisabledHiddenProperty Field

REXEditBox.BackgroundDisabledHiddenProperty Field
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

This is BackgroundDisabledHiddenProperty, a member of class REXEditBox.

C#
public static readonly DependencyProperty BackgroundDisabledHiddenProperty;
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.BackgroundDisabledStandardProperty Field

REXEditBox.BackgroundDisabledStandardProperty Field
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

This is BackgroundDisabledStandardProperty, a member of class REXEditBox.

C#
public static readonly DependencyProperty BackgroundDisabledStandardProperty;
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.BackgroundErrorProperty Field

REXEditBox.BackgroundErrorProperty Field
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

This is BackgroundErrorProperty, a member of class REXEditBox.

C#
public static readonly DependencyProperty BackgroundErrorProperty;
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.BackgroundNeutralProperty Field

REXEditBox.BackgroundNeutralProperty Field
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

This is BackgroundNeutralProperty, a member of class REXEditBox.

C#
public static readonly DependencyProperty BackgroundNeutralProperty;
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.BackgroundOKProperty Field

REXEditBox.BackgroundOKProperty Field
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

This is BackgroundOKProperty, a member of class REXEditBox.

C#
public static readonly DependencyProperty BackgroundOKProperty;
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.ComplexDoubleValueProperty Field

REXEditBox.ComplexDoubleValueProperty Field
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

This is ComplexDoubleValueProperty, a member of class REXEditBox.

C#
public static readonly DependencyProperty ComplexDoubleValueProperty;
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.ComplexProperty Field

REXEditBox.ComplexProperty Field
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

This is ComplexProperty, a member of class REXEditBox.

C#
public static readonly DependencyProperty ComplexProperty;
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.ComplexSeparatorProperty Field

REXEditBox.ComplexSeparatorProperty Field
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

This is ComplexSeparatorProperty, a member of class REXEditBox.

C#
public static readonly DependencyProperty ComplexSeparatorProperty;
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.ComplexSpaceSeparatorProperty Field

REXEditBox.ComplexSpaceSeparatorProperty Field
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

This is ComplexSpaceSeparatorProperty, a member of class REXEditBox.

C#
public static readonly DependencyProperty ComplexSpaceSeparatorProperty;
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.ComplexUnitOnEndProperty Field

REXEditBox.ComplexUnitOnEndProperty Field
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

This is ComplexUnitOnEndProperty, a member of class REXEditBox.

C#
public static readonly DependencyProperty ComplexUnitOnEndProperty;
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.CorrectValueProperty Field

REXEditBox.CorrectValueProperty Field
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

This is CorrectValueProperty, a member of class REXEditBox.

C#
public static readonly DependencyProperty CorrectValueProperty;
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.DataTypeProperty Field

REXEditBox.DataTypeProperty Field
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

This is DataTypeProperty, a member of class REXEditBox.

C#
public static readonly DependencyProperty DataTypeProperty;
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.DoubleValueProperty Field

REXEditBox.DoubleValueProperty Field
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

This is DoubleValueProperty, a member of class REXEditBox.

C#
public static readonly DependencyProperty DoubleValueProperty;
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.EngineeringFormatProperty Field

REXEditBox.EngineeringFormatProperty Field
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

This is EngineeringFormatProperty, a member of class REXEditBox.

C#
public static readonly DependencyProperty EngineeringFormatProperty;
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.EpsilonProperty Field

REXEditBox.EpsilonProperty Field
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

This is EpsilonProperty, a member of class REXEditBox.

C#
public static readonly DependencyProperty EpsilonProperty;
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.InvalidCharactersProperty Field

REXEditBox.InvalidCharactersProperty Field
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

This is InvalidCharactersProperty, a member of class REXEditBox.

C#
public static readonly DependencyProperty InvalidCharactersProperty;
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.MaxTokensProperty Field

REXEditBox.MaxTokensProperty Field
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

This is MaxTokensProperty, a member of class REXEditBox.

C#
public static readonly DependencyProperty MaxTokensProperty;
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.MinTokensProperty Field

REXEditBox.MinTokensProperty Field
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

This is MinTokensProperty, a member of class REXEditBox.

C#
public static readonly DependencyProperty MinTokensProperty;
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.OnDisableActionProperty Field

REXEditBox.OnDisableActionProperty Field
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

This is OnDisableActionProperty, a member of class REXEditBox.

C#
public static readonly DependencyProperty OnDisableActionProperty;
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.OriginalTextOnEnterProperty Field

REXEditBox.OriginalTextOnEnterProperty Field
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

This is OriginalTextOnEnterProperty, a member of class REXEditBox.

C#
public static readonly DependencyProperty OriginalTextOnEnterProperty;
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.RangeMaxCheckProperty Field

REXEditBox.RangeMaxCheckProperty Field
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

This is RangeMaxCheckProperty, a member of class REXEditBox.

C#
public static readonly DependencyProperty RangeMaxCheckProperty;
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.RangeMaxProperty Field

REXEditBox.RangeMaxProperty Field
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

This is RangeMaxProperty, a member of class REXEditBox.

C#
public static readonly DependencyProperty RangeMaxProperty;
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.RangeMinCheckProperty Field

REXEditBox.RangeMinCheckProperty Field
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

This is RangeMinCheckProperty, a member of class REXEditBox.

C#
public static readonly DependencyProperty RangeMinCheckProperty;
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.RangeMinProperty Field

REXEditBox.RangeMinProperty Field
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

This is RangeMinProperty, a member of class REXEditBox.

C#
public static readonly DependencyProperty RangeMinProperty;
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.RememberCorrectProperty Field

REXEditBox.RememberCorrectProperty Field
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

This is RememberCorrectProperty, a member of class REXEditBox.

C#
public static readonly DependencyProperty RememberCorrectProperty;
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.RoundingFractionalProperty Field

REXEditBox.RoundingFractionalProperty Field
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

This is RoundingFractionalProperty, a member of class REXEditBox.

C#
public static readonly DependencyProperty RoundingFractionalProperty;
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.RoundingIncrementProperty Field

REXEditBox.RoundingIncrementProperty Field
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

This is RoundingIncrementProperty, a member of class REXEditBox.

C#
public static readonly DependencyProperty RoundingIncrementProperty;
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.SeparatorProperty Field

REXEditBox.SeparatorProperty Field
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

This is SeparatorProperty, a member of class REXEditBox.

C#
public static readonly DependencyProperty SeparatorProperty;
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.TokensRangeMaxCheckProperty Field

REXEditBox.TokensRangeMaxCheckProperty Field
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

This is TokensRangeMaxCheckProperty, a member of class REXEditBox.

C#
public static readonly DependencyProperty TokensRangeMaxCheckProperty;
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.TokensRangeMinCheckProperty Field

REXEditBox.TokensRangeMinCheckProperty Field
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

This is TokensRangeMinCheckProperty, a member of class REXEditBox.

C#
public static readonly DependencyProperty TokensRangeMinCheckProperty;
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.UnitSymbolProperty Field

REXEditBox.UnitSymbolProperty Field
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

This is UnitSymbolProperty, a member of class REXEditBox.

C#
public static readonly DependencyProperty UnitSymbolProperty;
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.AddEnabledChangedHandler Method

REXEditBox.AddEnabledChangedHandler Method
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Adds the handler to the event raised when the element changes it's enable state.

C#
public void AddEnabledChangedHandler(EventHandler eh);
Parameters
Parameters | Description
eh | The event handler.
Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.AddLostFocusHandler Method

REXEditBox.AddLostFocusHandler Method
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Adds the handler to the event raised when the element loses logical focus.

C#
public void AddLostFocusHandler(EventHandler eh);
Parameters
Parameters | Description
eh | The event handler.
Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.AddTextChangedHandler Method

REXEditBox.AddTextChangedHandler Method
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Adds the handler to the event raised when text changes.

C#
public void AddTextChangedHandler(EventHandler eh);
Parameters
Parameters | Description
eh | The event handler.
Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.GetBackground Method

REXEditBox.GetBackground Method
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Gets the background of the control.

C#
public object GetBackground();
Returns

The background.

Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.GetComplexDoubleValue Method

REXEditBox.GetComplexDoubleValue Method
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Gets the complex (list) value of the double type.

C#
public List<double> GetComplexDoubleValue();
Returns

The list of values.

Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.GetComplexStringValue Method

REXEditBox.GetComplexStringValue Method
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Returns a complex string list.

C#
public List<string> GetComplexStringValue();
Returns

The list of values.

Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.GetEnable Method

REXEditBox.GetEnable Method
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Indicates whether the control is enabled.

C#
public bool GetEnable();
Returns

True if the element is enabled; otherwise, false.

Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.GetFullName Method

REXEditBox.GetFullName Method
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Gets the full name.

C#
public string GetFullName();
Returns

The full name.

Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.GetLastCorrectValueStr Method

REXEditBox.GetLastCorrectValueStr Method
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Gets the last correct stored value.

C#
public String GetLastCorrectValueStr();
Returns

The correct value.

Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.GetState Method

REXEditBox.GetState Method
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Gets the current state of the control.

C#
public EControlState GetState();
Returns

The state of the control.

Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.GetStringValue Method

REXEditBox.GetStringValue Method
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Returns the original text.

C#
public string GetStringValue();
Returns

The text value.

Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.GetText Method

REXEditBox.GetText Method
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Gets the text contents of the control.

C#
public string GetText();
Returns

The text contents of the control.

Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.GetUniqueName Method

REXEditBox.GetUniqueName Method
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Returns the Unique ID generated for the current instance of the engine.

C#
public string GetUniqueName();
Returns

The unique ID.

Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.GetValue Method

REXEditBox.GetValue Method
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Gets the value of the double type.

C#
public double GetValue();
Returns

The value.

Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.Refresh Method

REXEditBox.Refresh Method
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Refreshes the text on the control based on the current text.

C#
public void Refresh();
Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.RefreshValidationStatus Method

REXEditBox.RefreshValidationStatus Method
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Refreshes the validation status.

C#
public void RefreshValidationStatus();
Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.Reset Method

REXEditBox.Reset Method
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Resets control (internal values).

C#
public void Reset();
Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.SetBackground Method

REXEditBox.SetBackground Method
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Sets the background of the control.

C#
public void SetBackground(object brush);
Parameters
Parameters | Description
background | The background.
Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.SetComplexValue Method (List<double>)

REXEditBox.SetComplexValue Method (List<double>)
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Sets the complex (list) value of the double type.

C#
public void SetComplexValue(List<double> values);
Parameters
Parameters | Description
values | The list of values.
Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.SetComplexValue Method (List<string>)

REXEditBox.SetComplexValue Method (List<string>)
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Sets the complex (list) value of the string type.

C#
public void SetComplexValue(List<string> values);
Parameters
Parameters | Description
values | The list of values.
Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.SetComplexValue Method (String)

REXEditBox.SetComplexValue Method (String)
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Sets the complex (list) value of the string type.

C#
public bool SetComplexValue(String value);
Parameters
Parameters | Description
value | The value.
Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.SetEnable Method

REXEditBox.SetEnable Method
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Sets the enable state.

C#
public void SetEnable(bool enable);
Parameters
Parameters | Description
enable | If the control is to be enabled.
Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.SetExternalUnitBody Method

REXEditBox.SetExternalUnitBody Method
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Sets external IUnitBody object for custom unit processing.

C#
public void SetExternalUnitBody(IUnitBody unitBody);
Parameters
Parameters | Description
unitBody | External IUnitBody.
Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.SetText Method

REXEditBox.SetText Method
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Sets the text contents of the control.

C#
public void SetText(string txt);
Parameters
Parameters | Description
txt | The text.
Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.SetUserTextValidation Method

REXEditBox.SetUserTextValidation Method
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Sets the user validation method for the text control.

C#
public void SetUserTextValidation(UserTextValidation ValidFunction);
Parameters
Parameters | Description
ValidFunction | The validation method.
Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.SetUserValidation Method

REXEditBox.SetUserValidation Method
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Sets the user validation method.

C#
public void SetUserValidation(UserValidation ValidFunction);
Parameters
Parameters | Description
ValidFunction | The validation method.
Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.SetUserValidationComplex Method

REXEditBox.SetUserValidationComplex Method
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Sets the user validation method for complex values (list).

C#
public void SetUserValidationComplex(UserValidationComplex ValidFunction);
Parameters
Parameters | Description
ValidFunction | The validation method.
Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.SetValue Method (Double)

REXEditBox.SetValue Method (Double)
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Sets the value of the double type.

C#
public void SetValue(Double value);
Parameters
Parameters | Description
value | The value.
Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.SetValue Method (String)

REXEditBox.SetValue Method (String)
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Sets the value of the string type.

C#
public void SetValue(String value);
Parameters
Parameters | Description
value | The value.
Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.ValidateComplexValue Method (List<double>)

REXEditBox.ValidateComplexValue Method (List<double>)
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Validates the complex (list) value of the double type.

C#
public bool ValidateComplexValue(List<double> values);
Parameters
Parameters | Description
values | The values to validate.
Returns

True if validated; otherwise false.

Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.ValidateComplexValue Method (List<string>)

REXEditBox.ValidateComplexValue Method (List<string>)
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Validates the complex (list) value of the string type.

C#
public bool ValidateComplexValue(List<string> values);
Parameters
Parameters | Description
values | The values to validate.
Returns

True if validated; otherwise false.

Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.ValidateComplexValue Method (String)

REXEditBox.ValidateComplexValue Method (String)
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Validates the complex (list) value of the string type.

C#
public bool ValidateComplexValue(String value);
Parameters
Parameters | Description
value | The value to validate.
Returns

True if validated; otherwise false.

Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.ValidateValue Method (Double)

REXEditBox.ValidateValue Method (Double)
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Validates the input value of the double type.

C#
public bool ValidateValue(Double value);
Parameters
Parameters | Description
value | The value to validate.
Returns

True if validated; otherwise false.

Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.ValidateValue Method (String)

REXEditBox.ValidateValue Method (String)
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Validates the value of the string type.

C#
public bool ValidateValue(String value);
Parameters
Parameters | Description
value | The value to validate.
Returns

True if validated; otherwise false.

Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.ValueFormat Method (Double)

REXEditBox.ValueFormat Method (Double)
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Returns a text containing an expression formatted according the current settings of the element.

C#
public string ValueFormat(Double value);
Parameters
Parameters | Description
value | The value to format.
Returns

The formatted text.

Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.ValueFormat Method (String)

REXEditBox.ValueFormat Method (String)
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Returns a text containing an expression formatted according the current settings of the element.

C#
public string ValueFormat(String value);
Parameters
Parameters | Description
value | The value to format.
Returns

The formatted text.

Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.ValueParse Method

REXEditBox.ValueParse Method
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Converts the specified text to the numeric value according the current settings of the element.

C#
public double ValueParse(String value);
Parameters
Parameters | Description
value | The text.
Returns

The converted value.

Description
Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.BackgroundDisabledHidden Property

REXEditBox.BackgroundDisabledHidden Property
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Gets or sets the background for the disabled state of the control in the hidden background mode.

C#
[Browsable(true)]
[Category("Appearance")]
public Brush BackgroundDisabledHidden;
Description

The background.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.BackgroundDisabledStandard Property

REXEditBox.BackgroundDisabledStandard Property
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Gets or sets the background for the standard disabled status.

C#
[Browsable(true)]
[Category("Appearance")]
[DefaultValue(typeof(Color), "LightBlue")]
public Brush BackgroundDisabledStandard;
Description

The background standard.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.BackgroundError Property

REXEditBox.BackgroundError Property
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Gets or sets the background for the Error state of the control.

C#
[Browsable(true)]
[Category("Appearance")]
[DefaultValue(typeof(Color), "LightCoral")]
public Brush BackgroundError;
Description

The Error background.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.BackgroundNeutral Property

REXEditBox.BackgroundNeutral Property
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Gets or sets the background for the neutral state of the control.

C#
[Browsable(true)]
[Category("Appearance")]
[DefaultValue(typeof(SystemColors), "Window")]
public Brush BackgroundNeutral;
Description

The neutral background.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.BackgroundOK Property

REXEditBox.BackgroundOK Property
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Gets or sets the background for the OK state of the control.

C#
[Browsable(true)]
[Category("Appearance")]
[DefaultValue(typeof(Color), "LightGreen")]
public Brush BackgroundOK;
Description

The OK background.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.Complex Property

REXEditBox.Complex Property
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Gets or sets a value indicating whether this REXEditControlEngine supports complex (list) values.

C#
[Category("Complex")]
[Browsable(true)]
public bool Complex;
Description

True if the engine supports complex values; otherwise false.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.ComplexDoubleValue Property

REXEditBox.ComplexDoubleValue Property
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Gets or sets the complex double value.

C#
public ObservableCollection<double> ComplexDoubleValue;
Description

The complex double value.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.ComplexSeparator Property

REXEditBox.ComplexSeparator Property
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Gets or sets the complex (list) separator.

C#
[Category("Complex")]
[Browsable(true)]
[DefaultValue(";")]
public string ComplexSeparator;
Description

The complex separator.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.ComplexSpaceSeparator Property

REXEditBox.ComplexSpaceSeparator Property
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Gets or sets a value indicating whether a space should be respected as a list separator.

C#
[Category("Complex")]
[Browsable(true)]
public bool ComplexSpaceSeparator;
Description

True if space respected as a list separator; otherwise, false.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.ComplexUnitOnEnd Property

REXEditBox.ComplexUnitOnEnd Property
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Gets or sets a value indicating whether a unit symbol should be placed on the end of the formatted text.

C#
[Category("Complex")]
[Browsable(true)]
public bool ComplexUnitOnEnd;
Description

True if the unit one the end; otherwise, false.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.ControlState Property

REXEditBox.ControlState Property
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Gets the current state of the control.

C#
[Browsable(false)]
public EControlState ControlState;
Description

The state of the control.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.CorrectValue Property

REXEditBox.CorrectValue Property
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Gets or sets the correct value.

C#
public string CorrectValue;
Description

The correct value.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.DataType Property

REXEditBox.DataType Property
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Gets or sets the type of the data in the control.

C#
[Browsable(true)]
[Category("Data")]
public EControlType DataType;
Description

The type of the data.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.DoubleValue Property

REXEditBox.DoubleValue Property
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Gets or sets the double value.

C#
public double DoubleValue;
Description

The double value.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.EngineeringFormat Property

REXEditBox.EngineeringFormat Property
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Gets or sets a value indicating whether the text of the control should be formatted in according to the engineering (expotential) format.

C#
[Browsable(true)]
[Category("Data")]
[DefaultValue(false)]
public bool EngineeringFormat;
Description

True if engineering format; otherwise false.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.Epsilon Property

REXEditBox.Epsilon Property
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Gets or sets the accuracy.

C#
[Browsable(true)]
public double Epsilon;
Description

The accuracy.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.InvalidCharacters Property

REXEditBox.InvalidCharacters Property
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Gets or sets the list invalid characters (for the control in TEXT mode).

C#
[Browsable(true)]
public string InvalidCharacters;
Description

The list of invalid characters.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.MaxTokens Property

REXEditBox.MaxTokens Property
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Gets or sets the maximum number of elements in the complex mode (list).

C#
[Category("Complex")]
[Browsable(true)]
public int MaxTokens;
Description

The maximum number of elements.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.MinTokens Property

REXEditBox.MinTokens Property
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Gets or sets the minimum number of elements in the complex mode (list).

C#
[Category("Complex")]
[Browsable(true)]
public int MinTokens;
Description

The minimum number of elements.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.OnDisableAction Property

REXEditBox.OnDisableAction Property
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Gets or sets a value indicating whether the foreground should be hidden when the control is disabled.

C#
[Browsable(true)]
[Category("Data")]
public EOnDisable OnDisableAction;
Description

The behaviour of the control's foreground.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.OriginalTextOnEnter Property

REXEditBox.OriginalTextOnEnter Property
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Gets or sets a value indicating whether an original text should be set when the user enters the control.

C#
[Browsable(true)]
[Category("Behavior")]
public bool OriginalTextOnEnter;
Description

True if original text is to be set; otherwise, false.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.RangeMax Property

REXEditBox.RangeMax Property
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Gets or sets the highest possible value.

C#
[Browsable(true)]
[Category("Data")]
[DefaultValue(Double.PositiveInfinity)]
public double RangeMax;
Description

The highest possible value.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.RangeMaxCheck Property

REXEditBox.RangeMaxCheck Property
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Gets or sets a value indicating whether the value should be validated due to the RangeMax.

C#
[Browsable(true)]
[Category("Data")]
[DefaultValue(false)]
public bool RangeMaxCheck;
Description

True if validate; otherwise false.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.RangeMin Property

REXEditBox.RangeMin Property
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Gets or sets the minimum possible value.

C#
[Browsable(true)]
[Category("Data")]
[DefaultValue(Double.NegativeInfinity)]
public double RangeMin;
Description

The minimum possible value.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.RangeMinCheck Property

REXEditBox.RangeMinCheck Property
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Gets or sets a value indicating whether the value should be validated due to the RangeMin.

C#
[Browsable(true)]
[Category("Data")]
[DefaultValue(false)]
public bool RangeMinCheck;
Description

True if validate; otherwise false.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.RememberCorrect Property

REXEditBox.RememberCorrect Property
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Gets or sets a value indicating whether the correct value should be restored in case of the validation failure.

C#
[Browsable(true)]
[Category("Data")]
public bool RememberCorrect;
Description

True if the value should be restored; otherwise false.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.RoundingFractional Property

REXEditBox.RoundingFractional Property
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Gets or sets the rounding for fractional units.

C#
[Browsable(true)]
[Category("Data")]
public EFractialRound RoundingFractional;
Description

The rounding.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.RoundingIncrement Property

REXEditBox.RoundingIncrement Property
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Gets or sets the rounding increment (for the DECIMAL DataType).

C#
[Browsable(true)]
[Category("Data")]
public double RoundingIncrement;
Description

The rounding increment.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.Separator Property

REXEditBox.Separator Property
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Gets or sets the decimal separator.

C#
[Browsable(true)]
[Category("Data")]
public string Separator;
Description

The separator.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.TokensRangeMaxCheck Property

REXEditBox.TokensRangeMaxCheck Property
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Gets or sets a value indicating whether the number of elements should be validated due to the MaxTokens.

C#
[Category("Complex")]
[Browsable(true)]
[DefaultValue(false)]
public bool TokensRangeMaxCheck;
Description

True if validate; otherwise, false.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.TokensRangeMinCheck Property

REXEditBox.TokensRangeMinCheck Property
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Gets or sets a value indicating whether the number of elements should be validated due to the MinTokens.

C#
[Category("Complex")]
[Browsable(true)]
[DefaultValue(false)]
public bool TokensRangeMinCheck;
Description

True if validate; otherwise, false.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXEditBox.UnitSymbol Property

REXEditBox.UnitSymbol Property
REXEditBox Class REX.Controls.WPF Namespace REXEditBox Class

Gets or sets the unit symbol.

C#
[Browsable(true)]
[Category("Data")]
[DefaultValue("")]
public string UnitSymbol;
Description

The unit symbol.

Class

REXEditBox Class

Links
REXEditBox Class, REX.Controls.WPF Namespace, REXEditBox Class


REXImageComboBox Class

REXImageComboBox Class
REX.Controls.WPF Namespace

Represents combobox with images.

Class Hierarchy
C#
public class REXImageComboBox : ComboBox;
Description
Namespace

REX.Controls.WPF Namespace

Links
REX.Controls.WPF Namespace
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXImageComboBoxItem Class

REXImageComboBoxItem Class
REX.Controls.WPF Namespace Legend Members REXImageComboBoxItem Fields REXImageComboBoxItem Properties

Represents the combobox item with an image inside.

Class Hierarchy
C#
[System.ComponentModel.ToolboxItem(false)]
public class REXImageComboBoxItem : ComboBoxItem;
Description
Namespace

REX.Controls.WPF Namespace

REXImageComboBoxItem Fields
REXImageComboBoxItem Fields | Description
FitToParentHeightProperty | This is FitToParentHeightProperty, a member of class REXImageComboBoxItem.
ImageProperty | This is ImageProperty, a member of class REXImageComboBoxItem.
TextProperty | This is TextProperty, a member of class REXImageComboBoxItem.
VisibleOnListProperty | This is VisibleOnListProperty, a member of class REXImageComboBoxItem.
REXImageComboBoxItem Properties
REXImageComboBoxItem Properties | Description
FitToParentHeight | Gets or sets a value indicating whether item height should be fit to the combobox's height.
Image | Gets or sets the image.
Text | Gets or sets the text.
VisibleOnList | Gets or sets a value indicating whether item should be visible on the list.
Links
REX.Controls.WPF Namespace, Legend, Members, REXImageComboBoxItem Fields, REXImageComboBoxItem Properties


REXImageComboBoxItem.FitToParentHeightProperty Field

REXImageComboBoxItem.FitToParentHeightProperty Field
REXImageComboBoxItem Class REX.Controls.WPF Namespace REXImageComboBoxItem Class

This is FitToParentHeightProperty, a member of class REXImageComboBoxItem.

C#
public static readonly DependencyProperty FitToParentHeightProperty;
Class

REXImageComboBoxItem Class

Links
REXImageComboBoxItem Class, REX.Controls.WPF Namespace, REXImageComboBoxItem Class


REXImageComboBoxItem.ImageProperty Field

REXImageComboBoxItem.ImageProperty Field
REXImageComboBoxItem Class REX.Controls.WPF Namespace REXImageComboBoxItem Class

This is ImageProperty, a member of class REXImageComboBoxItem.

C#
public static readonly DependencyProperty ImageProperty;
Class

REXImageComboBoxItem Class

Links
REXImageComboBoxItem Class, REX.Controls.WPF Namespace, REXImageComboBoxItem Class


REXImageComboBoxItem.TextProperty Field

REXImageComboBoxItem.TextProperty Field
REXImageComboBoxItem Class REX.Controls.WPF Namespace REXImageComboBoxItem Class

This is TextProperty, a member of class REXImageComboBoxItem.

C#
public static readonly DependencyProperty TextProperty;
Class

REXImageComboBoxItem Class

Links
REXImageComboBoxItem Class, REX.Controls.WPF Namespace, REXImageComboBoxItem Class


REXImageComboBoxItem.VisibleOnListProperty Field

REXImageComboBoxItem.VisibleOnListProperty Field
REXImageComboBoxItem Class REX.Controls.WPF Namespace REXImageComboBoxItem Class

This is VisibleOnListProperty, a member of class REXImageComboBoxItem.

C#
public static readonly DependencyProperty VisibleOnListProperty;
Class

REXImageComboBoxItem Class

Links
REXImageComboBoxItem Class, REX.Controls.WPF Namespace, REXImageComboBoxItem Class


REXImageComboBoxItem.FitToParentHeight Property

REXImageComboBoxItem.FitToParentHeight Property
REXImageComboBoxItem Class REX.Controls.WPF Namespace REXImageComboBoxItem Class

Gets or sets a value indicating whether item height should be fit to the combobox's height.

C#
public bool FitToParentHeight;
Description

True if item should be fit to parent; otherwise, false.

Class

REXImageComboBoxItem Class

Links
REXImageComboBoxItem Class, REX.Controls.WPF Namespace, REXImageComboBoxItem Class


REXImageComboBoxItem.Image Property

REXImageComboBoxItem.Image Property
REXImageComboBoxItem Class REX.Controls.WPF Namespace REXImageComboBoxItem Class

Gets or sets the image.

C#
public ImageSource Image;
Description

The image.

Class

REXImageComboBoxItem Class

Links
REXImageComboBoxItem Class, REX.Controls.WPF Namespace, REXImageComboBoxItem Class


REXImageComboBoxItem.Text Property

REXImageComboBoxItem.Text Property
REXImageComboBoxItem Class REX.Controls.WPF Namespace REXImageComboBoxItem Class

Gets or sets the text.

C#
public string Text;
Description

The text.

Class

REXImageComboBoxItem Class

Links
REXImageComboBoxItem Class, REX.Controls.WPF Namespace, REXImageComboBoxItem Class


REXImageComboBoxItem.VisibleOnList Property

REXImageComboBoxItem.VisibleOnList Property
REXImageComboBoxItem Class REX.Controls.WPF Namespace REXImageComboBoxItem Class

Gets or sets a value indicating whether item should be visible on the list.

C#
public bool VisibleOnList;
Description

True if item should be visible on the list; otherwise, false.

Class

REXImageComboBoxItem Class

Links
REXImageComboBoxItem Class, REX.Controls.WPF Namespace, REXImageComboBoxItem Class


REXIndexLabel Class

REXIndexLabel Class
REX.Controls.WPF Namespace Legend Members Public Methods REXIndexLabel Fields REXIndexLabel Methods REXIndexLabel Properties

Represents the REXIndexLabel control.

Class Hierarchy
C#
public class REXIndexLabel : Control;
Description

It can be used to draw small letters below or above the text baseline.

Remarks

In order to draw small letters it is necessarry to place them in curly brackets: rex{lower}{^upper}. In order to draw the specified letter using Symbolic font it is necessarry to start it with @: @rex.

Namespace

REX.Controls.WPF Namespace

Public Methods
Public Method | Description
REXIndexLabel | Initializes a new instance of the REXIndexLabel class.
REXIndexLabel Fields
REXIndexLabel Fields | Description
IndexCoeffProperty | This is IndexCoeffProperty, a member of class REXIndexLabel.
LeftAlignProperty | This is LeftAlignProperty, a member of class REXIndexLabel.
TextProperty | This is TextProperty, a member of class REXIndexLabel.
REXIndexLabel Methods
REXIndexLabel Methods | Description
GetTextSize | Gets the size of the text.
REXIndexLabel Properties
REXIndexLabel Properties | Description
IndexCoeff | Gets or sets the proportion between index and it's parent.
LeftAlign | Gets or sets a value indicating whether the content of the control should be aligned to the left.
Text | Gets or sets the current text in the REXIndexLabel.
Links
REX.Controls.WPF Namespace, Legend, Members, Public Methods, REXIndexLabel Fields, REXIndexLabel Methods, REXIndexLabel Properties


REXIndexLabel.REXIndexLabel Constructor

REXIndexLabel.REXIndexLabel Constructor
REXIndexLabel Class REX.Controls.WPF Namespace REXIndexLabel Class

Initializes a new instance of the REXIndexLabel class.

C#
public REXIndexLabel();
Description
Class

REXIndexLabel Class

Links
REXIndexLabel Class, REX.Controls.WPF Namespace, REXIndexLabel Class


REXIndexLabel.IndexCoeffProperty Field

REXIndexLabel.IndexCoeffProperty Field
REXIndexLabel Class REX.Controls.WPF Namespace REXIndexLabel Class

This is IndexCoeffProperty, a member of class REXIndexLabel.

C#
public static readonly DependencyProperty IndexCoeffProperty;
Class

REXIndexLabel Class

Links
REXIndexLabel Class, REX.Controls.WPF Namespace, REXIndexLabel Class


REXIndexLabel.LeftAlignProperty Field

REXIndexLabel.LeftAlignProperty Field
REXIndexLabel Class REX.Controls.WPF Namespace REXIndexLabel Class

This is LeftAlignProperty, a member of class REXIndexLabel.

C#
public static readonly DependencyProperty LeftAlignProperty;
Class

REXIndexLabel Class

Links
REXIndexLabel Class, REX.Controls.WPF Namespace, REXIndexLabel Class


REXIndexLabel.TextProperty Field

REXIndexLabel.TextProperty Field
REXIndexLabel Class REX.Controls.WPF Namespace REXIndexLabel Class

This is TextProperty, a member of class REXIndexLabel.

C#
public static readonly DependencyProperty TextProperty;
Class

REXIndexLabel Class

Links
REXIndexLabel Class, REX.Controls.WPF Namespace, REXIndexLabel Class


REXIndexLabel.GetTextSize Method

REXIndexLabel.GetTextSize Method
REXIndexLabel Class REX.Controls.WPF Namespace REXIndexLabel Class

Gets the size of the text.

C#
public double GetTextSize(string text, double fontSize);
Parameters
Parameters | Description
text | The text.
fontSize | The size of the font.
Returns

The size of the text.

Description
Class

REXIndexLabel Class

Links
REXIndexLabel Class, REX.Controls.WPF Namespace, REXIndexLabel Class


REXIndexLabel.IndexCoeff Property

REXIndexLabel.IndexCoeff Property
REXIndexLabel Class REX.Controls.WPF Namespace REXIndexLabel Class

Gets or sets the proportion between index and it's parent.

C#
[Category("Appearance")]
public double IndexCoeff;
Description

The index coefficient.

Class

REXIndexLabel Class

Links
REXIndexLabel Class, REX.Controls.WPF Namespace, REXIndexLabel Class


REXIndexLabel.LeftAlign Property

REXIndexLabel.LeftAlign Property
REXIndexLabel Class REX.Controls.WPF Namespace REXIndexLabel Class

Gets or sets a value indicating whether the content of the control should be aligned to the left.

C#
[Category("Appearance")]
public bool LeftAlign;
Description

True if left alignment; otherwise, false.

Class

REXIndexLabel Class

Links
REXIndexLabel Class, REX.Controls.WPF Namespace, REXIndexLabel Class


REXIndexLabel.Text Property

REXIndexLabel.Text Property
REXIndexLabel Class REX.Controls.WPF Namespace REXIndexLabel Class

Gets or sets the current text in the REXIndexLabel.

C#
[Category("Common Properties")]
public string Text;
Description

The text.

Class

REXIndexLabel Class

Links
REXIndexLabel Class, REX.Controls.WPF Namespace, REXIndexLabel Class


REXToolbox Class

REXToolbox Class
REX.Controls.WPF Namespace Legend Members Public Methods REXToolbox Delegates REXToolbox Events REXToolbox Fields REXToolbox Methods REXToolbox Properties

Represents the REXToolbox control

Class Hierarchy
C#
public class REXToolbox : DockPanel;
Namespace

REX.Controls.WPF Namespace

Public Methods
Public Method | Description
REXToolbox | Initializes a new instance of the REXToolbox class.
REXToolbox Delegates
REXToolbox Delegates | Description
EventSelectedItemChanged | This is nested type REX.Controls.WPF.REXToolbox.EventSelectedItemChanged.
REXToolbox Events
REXToolbox Events | Description
SelectedItemChanged | Occurs when the selected item changed.
REXToolbox Fields
REXToolbox Fields | Description
ApplyGradientsProperty | This is ApplyGradientsProperty, a member of class REXToolbox.
BorderBrushProperty | This is BorderBrushProperty, a member of class REXToolbox.
BorderThicknessProperty | This is BorderThicknessProperty, a member of class REXToolbox.
CategoryFontFamilyProperty | This is CategoryFontFamilyProperty, a member of class REXToolbox.
CategoryFontSizeProperty | This is CategoryFontSizeProperty, a member of class REXToolbox.
CategoryFontWeightProperty | This is CategoryFontWeightProperty, a member of class REXToolbox.
CategoryHeightProperty | This is CategoryHeightProperty, a member of class REXToolbox.
CategorySplitterProperty | This is CategorySplitterProperty, a member of class REXToolbox.
ItemBorderBrushProperty | This is ItemBorderBrushProperty, a member of class REXToolbox.
ItemBorderThicknessProperty | This is ItemBorderThicknessProperty, a member of class REXToolbox.
ItemFontFamilyProperty | This is ItemFontFamilyProperty, a member of class REXToolbox.
ItemFontSizeProperty | This is ItemFontSizeProperty, a member of class REXToolbox.
ItemFontWeightProperty | This is ItemFontWeightProperty, a member of class REXToolbox.
ItemHeightProperty | This is ItemHeightProperty, a member of class REXToolbox.
ItemHoverColorProperty | This is ItemHoverColorProperty, a member of class REXToolbox.
ItemSelectColorProperty | This is ItemSelectColorProperty, a member of class REXToolbox.
REXToolbox Methods
REXToolbox Methods | Description
Refresh | Refreshes this instance.
REXToolbox Properties
REXToolbox Properties | Description
ApplyGradients | Gets or sets a value indicating whether gradients should be applied.
BorderBrush | Gets or sets the border brush.
BorderThickness | Gets or sets the thickness of the border.
Categories | Gets the categories.
CategoryFontFamily | Gets or sets the font family of the category.
CategoryFontSize | Gets or sets the size of the category font.
CategoryFontWeight | Gets or sets the font weight of the category.
CategoryHeight | Gets or sets the height of the category.
CategorySplitter | Gets or sets the color of the category splitter.
ItemBorderBrush | Gets or sets the brush of the item's border.
ItemBorderThickness | Gets or sets the thickness of the item's border.
ItemFontFamily | Gets or sets the font family of the item.
ItemFontSize | Gets or sets the font size of the item.
ItemFontWeight | Gets or sets the font weight of the item.
ItemHeight | Gets or sets the height of the item.
ItemHoverColor | Gets or sets the background color of the item when the mouse pointer is over it.
Items | Gets the items.
ItemSelectColor | Gets or sets the background color of the selected item.
SelectedItem | Gets or sets the selected item.
SelectedItemName | Gets or sets the name of the selected item.
Links
REX.Controls.WPF Namespace, Legend, Members, Public Methods, REXToolbox Delegates, REXToolbox Events, REXToolbox Fields, REXToolbox Methods, REXToolbox Properties


REXToolbox.REXToolbox Constructor

REXToolbox.REXToolbox Constructor
REXToolbox Class REX.Controls.WPF Namespace REXToolbox Class

Initializes a new instance of the REXToolbox class.

C#
public REXToolbox();
Description
Class

REXToolbox Class

Links
REXToolbox Class, REX.Controls.WPF Namespace, REXToolbox Class


REXToolbox.ApplyGradientsProperty Field

REXToolbox.ApplyGradientsProperty Field
REXToolbox Class REX.Controls.WPF Namespace REXToolbox Class

This is ApplyGradientsProperty, a member of class REXToolbox.

C#
public static readonly DependencyProperty ApplyGradientsProperty;
Class

REXToolbox Class

Links
REXToolbox Class, REX.Controls.WPF Namespace, REXToolbox Class


REXToolbox.BorderBrushProperty Field

REXToolbox.BorderBrushProperty Field
REXToolbox Class REX.Controls.WPF Namespace REXToolbox Class

This is BorderBrushProperty, a member of class REXToolbox.

C#
public static readonly DependencyProperty BorderBrushProperty;
Class

REXToolbox Class

Links
REXToolbox Class, REX.Controls.WPF Namespace, REXToolbox Class


REXToolbox.BorderThicknessProperty Field

REXToolbox.BorderThicknessProperty Field
REXToolbox Class REX.Controls.WPF Namespace REXToolbox Class

This is BorderThicknessProperty, a member of class REXToolbox.

C#
public static readonly DependencyProperty BorderThicknessProperty;
Class

REXToolbox Class

Links
REXToolbox Class, REX.Controls.WPF Namespace, REXToolbox Class


REXToolbox.CategoryFontFamilyProperty Field

REXToolbox.CategoryFontFamilyProperty Field
REXToolbox Class REX.Controls.WPF Namespace REXToolbox Class

This is CategoryFontFamilyProperty, a member of class REXToolbox.

C#
public static readonly DependencyProperty CategoryFontFamilyProperty;
Class

REXToolbox Class

Links
REXToolbox Class, REX.Controls.WPF Namespace, REXToolbox Class


REXToolbox.CategoryFontSizeProperty Field

REXToolbox.CategoryFontSizeProperty Field
REXToolbox Class REX.Controls.WPF Namespace REXToolbox Class

This is CategoryFontSizeProperty, a member of class REXToolbox.

C#
public static readonly DependencyProperty CategoryFontSizeProperty;
Class

REXToolbox Class

Links
REXToolbox Class, REX.Controls.WPF Namespace, REXToolbox Class


REXToolbox.CategoryFontWeightProperty Field

REXToolbox.CategoryFontWeightProperty Field
REXToolbox Class REX.Controls.WPF Namespace REXToolbox Class

This is CategoryFontWeightProperty, a member of class REXToolbox.

C#
public static readonly DependencyProperty CategoryFontWeightProperty;
Class

REXToolbox Class

Links
REXToolbox Class, REX.Controls.WPF Namespace, REXToolbox Class


REXToolbox.CategoryHeightProperty Field

REXToolbox.CategoryHeightProperty Field
REXToolbox Class REX.Controls.WPF Namespace REXToolbox Class

This is CategoryHeightProperty, a member of class REXToolbox.

C#
public static readonly DependencyProperty CategoryHeightProperty;
Class

REXToolbox Class

Links
REXToolbox Class, REX.Controls.WPF Namespace, REXToolbox Class


REXToolbox.CategorySplitterProperty Field

REXToolbox.CategorySplitterProperty Field
REXToolbox Class REX.Controls.WPF Namespace REXToolbox Class

This is CategorySplitterProperty, a member of class REXToolbox.

C#
public static readonly DependencyProperty CategorySplitterProperty;
Class

REXToolbox Class

Links
REXToolbox Class, REX.Controls.WPF Namespace, REXToolbox Class


REXToolbox.ItemBorderBrushProperty Field

REXToolbox.ItemBorderBrushProperty Field
REXToolbox Class REX.Controls.WPF Namespace REXToolbox Class

This is ItemBorderBrushProperty, a member of class REXToolbox.

C#
public static readonly DependencyProperty ItemBorderBrushProperty;
Class

REXToolbox Class

Links
REXToolbox Class, REX.Controls.WPF Namespace, REXToolbox Class


REXToolbox.ItemBorderThicknessProperty Field

REXToolbox.ItemBorderThicknessProperty Field
REXToolbox Class REX.Controls.WPF Namespace REXToolbox Class

This is ItemBorderThicknessProperty, a member of class REXToolbox.

C#
public static readonly DependencyProperty ItemBorderThicknessProperty;
Class

REXToolbox Class

Links
REXToolbox Class, REX.Controls.WPF Namespace, REXToolbox Class


REXToolbox.ItemFontFamilyProperty Field

REXToolbox.ItemFontFamilyProperty Field
REXToolbox Class REX.Controls.WPF Namespace REXToolbox Class

This is ItemFontFamilyProperty, a member of class REXToolbox.

C#
public static readonly DependencyProperty ItemFontFamilyProperty;
Class

REXToolbox Class

Links
REXToolbox Class, REX.Controls.WPF Namespace, REXToolbox Class


REXToolbox.ItemFontSizeProperty Field

REXToolbox.ItemFontSizeProperty Field
REXToolbox Class REX.Controls.WPF Namespace REXToolbox Class

This is ItemFontSizeProperty, a member of class REXToolbox.

C#
public static readonly DependencyProperty ItemFontSizeProperty;
Class

REXToolbox Class

Links
REXToolbox Class, REX.Controls.WPF Namespace, REXToolbox Class


REXToolbox.ItemFontWeightProperty Field

REXToolbox.ItemFontWeightProperty Field
REXToolbox Class REX.Controls.WPF Namespace REXToolbox Class

This is ItemFontWeightProperty, a member of class REXToolbox.

C#
public static readonly DependencyProperty ItemFontWeightProperty;
Class

REXToolbox Class

Links
REXToolbox Class, REX.Controls.WPF Namespace, REXToolbox Class


REXToolbox.ItemHeightProperty Field

REXToolbox.ItemHeightProperty Field
REXToolbox Class REX.Controls.WPF Namespace REXToolbox Class

This is ItemHeightProperty, a member of class REXToolbox.

C#
public static readonly DependencyProperty ItemHeightProperty;
Class

REXToolbox Class

Links
REXToolbox Class, REX.Controls.WPF Namespace, REXToolbox Class


REXToolbox.ItemHoverColorProperty Field

REXToolbox.ItemHoverColorProperty Field
REXToolbox Class REX.Controls.WPF Namespace REXToolbox Class

This is ItemHoverColorProperty, a member of class REXToolbox.

C#
public static readonly DependencyProperty ItemHoverColorProperty;
Class

REXToolbox Class

Links
REXToolbox Class, REX.Controls.WPF Namespace, REXToolbox Class


REXToolbox.ItemSelectColorProperty Field

REXToolbox.ItemSelectColorProperty Field
REXToolbox Class REX.Controls.WPF Namespace REXToolbox Class

This is ItemSelectColorProperty, a member of class REXToolbox.

C#
public static readonly DependencyProperty ItemSelectColorProperty;
Class

REXToolbox Class

Links
REXToolbox Class, REX.Controls.WPF Namespace, REXToolbox Class


REXToolbox.Refresh Method

REXToolbox.Refresh Method
REXToolbox Class REX.Controls.WPF Namespace REXToolbox Class

Refreshes this instance.

C#
public void Refresh();
Description
Class

REXToolbox Class

Links
REXToolbox Class, REX.Controls.WPF Namespace, REXToolbox Class


REXToolbox.ApplyGradients Property

REXToolbox.ApplyGradients Property
REXToolbox Class REX.Controls.WPF Namespace REXToolbox Class

Gets or sets a value indicating whether gradients should be applied.

C#
[Category("Appearance")]
public bool ApplyGradients;
Description

True if gradients should be applied; otherwise, false.

Class

REXToolbox Class

Links
REXToolbox Class, REX.Controls.WPF Namespace, REXToolbox Class


REXToolbox.BorderBrush Property

REXToolbox.BorderBrush Property
REXToolbox Class REX.Controls.WPF Namespace REXToolbox Class

Gets or sets the border brush.

C#
[Category("Appearance")]
public Brush BorderBrush;
Description

The border brush.

Class

REXToolbox Class

Links
REXToolbox Class, REX.Controls.WPF Namespace, REXToolbox Class


REXToolbox.BorderThickness Property

REXToolbox.BorderThickness Property
REXToolbox Class REX.Controls.WPF Namespace REXToolbox Class

Gets or sets the thickness of the border.

C#
[Category("Appearance")]
public Thickness BorderThickness;
Description

The thickness of the border.

Class

REXToolbox Class

Links
REXToolbox Class, REX.Controls.WPF Namespace, REXToolbox Class


REXToolbox.Categories Property

REXToolbox.Categories Property
REXToolbox Class REX.Controls.WPF Namespace REXToolbox Class

Gets the categories.

C#
public REXToolboxCategoriesCollection Categories;
Description

The categories.

Class

REXToolbox Class

Links
REXToolbox Class, REX.Controls.WPF Namespace, REXToolbox Class


REXToolbox.CategoryFontFamily Property

REXToolbox.CategoryFontFamily Property
REXToolbox Class REX.Controls.WPF Namespace REXToolbox Class

Gets or sets the font family of the category.

C#
[Category("Appearance")]
public FontFamily CategoryFontFamily;
Description

The font family of the category.

Class

REXToolbox Class

Links
REXToolbox Class, REX.Controls.WPF Namespace, REXToolbox Class


REXToolbox.CategoryFontSize Property

REXToolbox.CategoryFontSize Property
REXToolbox Class REX.Controls.WPF Namespace REXToolbox Class

Gets or sets the size of the category font.

C#
[Category("Appearance")]
public int CategoryFontSize;
Description

The size of the category font.

Class

REXToolbox Class

Links
REXToolbox Class, REX.Controls.WPF Namespace, REXToolbox Class


REXToolbox.CategoryFontWeight Property

REXToolbox.CategoryFontWeight Property
REXToolbox Class REX.Controls.WPF Namespace REXToolbox Class

Gets or sets the font weight of the category.

C#
[Category("Appearance")]
public FontWeight CategoryFontWeight;
Description

The font weight of the category.

Class

REXToolbox Class

Links
REXToolbox Class, REX.Controls.WPF Namespace, REXToolbox Class


REXToolbox.CategoryHeight Property

REXToolbox.CategoryHeight Property
REXToolbox Class REX.Controls.WPF Namespace REXToolbox Class

Gets or sets the height of the category.

C#
[Category("Appearance")]
public int CategoryHeight;
Description

The height of the category.

Class

REXToolbox Class

Links
REXToolbox Class, REX.Controls.WPF Namespace, REXToolbox Class


REXToolbox.CategorySplitter Property

REXToolbox.CategorySplitter Property
REXToolbox Class REX.Controls.WPF Namespace REXToolbox Class

Gets or sets the color of the category splitter.

C#
[Category("Appearance")]
public Color CategorySplitter;
Description

The color of the category splitter.

Class

REXToolbox Class

Links
REXToolbox Class, REX.Controls.WPF Namespace, REXToolbox Class


REXToolbox.ItemBorderBrush Property

REXToolbox.ItemBorderBrush Property
REXToolbox Class REX.Controls.WPF Namespace REXToolbox Class

Gets or sets the brush of the item's border.

C#
[Category("Appearance")]
public Brush ItemBorderBrush;
Description

The brush of the item's border.

Class

REXToolbox Class

Links
REXToolbox Class, REX.Controls.WPF Namespace, REXToolbox Class


REXToolbox.ItemBorderThickness Property

REXToolbox.ItemBorderThickness Property
REXToolbox Class REX.Controls.WPF Namespace REXToolbox Class

Gets or sets the thickness of the item's border.

C#
[Category("Appearance")]
public Thickness ItemBorderThickness;
Description

The thickness of the item's border.

Class

REXToolbox Class

Links
REXToolbox Class, REX.Controls.WPF Namespace, REXToolbox Class


REXToolbox.ItemFontFamily Property

REXToolbox.ItemFontFamily Property
REXToolbox Class REX.Controls.WPF Namespace REXToolbox Class

Gets or sets the font family of the item.

C#
[Category("Appearance")]
public FontFamily ItemFontFamily;
Description

The font family of the item.

Class

REXToolbox Class

Links
REXToolbox Class, REX.Controls.WPF Namespace, REXToolbox Class


REXToolbox.ItemFontSize Property

REXToolbox.ItemFontSize Property
REXToolbox Class REX.Controls.WPF Namespace REXToolbox Class

Gets or sets the font size of the item.

C#
[Category("Appearance")]
public int ItemFontSize;
Description

The font size of the item.

Class

REXToolbox Class

Links
REXToolbox Class, REX.Controls.WPF Namespace, REXToolbox Class


REXToolbox.ItemFontWeight Property

REXToolbox.ItemFontWeight Property
REXToolbox Class REX.Controls.WPF Namespace REXToolbox Class

Gets or sets the font weight of the item.

C#
[Category("Appearance")]
public FontWeight ItemFontWeight;
Description

The font weight of the item.

Class

REXToolbox Class

Links
REXToolbox Class, REX.Controls.WPF Namespace, REXToolbox Class


REXToolbox.ItemHeight Property

REXToolbox.ItemHeight Property
REXToolbox Class REX.Controls.WPF Namespace REXToolbox Class

Gets or sets the height of the item.

C#
[Category("Appearance")]
public int ItemHeight;
Description

The height of the item.

Class

REXToolbox Class

Links
REXToolbox Class, REX.Controls.WPF Namespace, REXToolbox Class


REXToolbox.ItemHoverColor Property

REXToolbox.ItemHoverColor Property
REXToolbox Class REX.Controls.WPF Namespace REXToolbox Class

Gets or sets the background color of the item when the mouse pointer is over it.

C#
[Category("Appearance")]
public Color ItemHoverColor;
Description

The color of the hovered item.

Class

REXToolbox Class

Links
REXToolbox Class, REX.Controls.WPF Namespace, REXToolbox Class


REXToolbox.Items Property

REXToolbox.Items Property
REXToolbox Class REX.Controls.WPF Namespace REXToolbox Class

Gets the items.

C#
public REXToolboxItemsCollection Items;
Description

The items.

Class

REXToolbox Class

Links
REXToolbox Class, REX.Controls.WPF Namespace, REXToolbox Class


REXToolbox.ItemSelectColor Property

REXToolbox.ItemSelectColor Property
REXToolbox Class REX.Controls.WPF Namespace REXToolbox Class

Gets or sets the background color of the selected item.

C#
[Category("Appearance")]
public Color ItemSelectColor;
Description

The color of the selected item.

Class

REXToolbox Class

Links
REXToolbox Class, REX.Controls.WPF Namespace, REXToolbox Class


REXToolbox.SelectedItem Property

REXToolbox.SelectedItem Property
REXToolbox Class REX.Controls.WPF Namespace REXToolbox Class

Gets or sets the selected item.

C#
public REXToolboxItem SelectedItem;
Description

The selected item.

Class

REXToolbox Class

Links
REXToolbox Class, REX.Controls.WPF Namespace, REXToolbox Class


REXToolbox.SelectedItemName Property

REXToolbox.SelectedItemName Property
REXToolbox Class REX.Controls.WPF Namespace REXToolbox Class

Gets or sets the name of the selected item.

C#
public string SelectedItemName;
Description

The name of the selected item.

Class

REXToolbox Class

Links
REXToolbox Class, REX.Controls.WPF Namespace, REXToolbox Class


REXToolbox.EventSelectedItemChanged Delegate

REXToolbox.EventSelectedItemChanged Delegate
REXToolbox Class REX.Controls.WPF Namespace REXToolbox Class

This is nested type REX.Controls.WPF.REXToolbox.EventSelectedItemChanged.

C#
public delegate void EventSelectedItemChanged(object sender, REXToolboxItem item);
Class

REXToolbox Class

Links
REXToolbox Class, REX.Controls.WPF Namespace, REXToolbox Class


REXToolbox.SelectedItemChanged Event

REXToolbox.SelectedItemChanged Event
REXToolbox Class REX.Controls.WPF Namespace REXToolbox Class

Occurs when the selected item changed.

C#
public event EventSelectedItemChanged SelectedItemChanged;
Description
Class

REXToolbox Class

Links
REXToolbox Class, REX.Controls.WPF Namespace, REXToolbox Class


REXToolboxCategoriesCollection Class

REXToolboxCategoriesCollection Class
REX.Controls.WPF Namespace Legend Members Public Methods

Represents collection of categories of the REXToolbox control.

Class Hierarchy
C#
public class REXToolboxCategoriesCollection : REXToolboxCollection<REXToolboxCategory>;
Description
Namespace

REX.Controls.WPF Namespace

Public Methods
Public Method | Description
REXToolboxCategoriesCollection | Initializes a new instance of the REXToolboxCategoriesCollection class.
Links
REX.Controls.WPF Namespace, Legend, Members, Public Methods


REXToolboxCategoriesCollection.REXToolboxCategoriesCollection Constructor

REXToolboxCategoriesCollection.REXToolboxCategoriesCollection Constructor
REXToolboxCategoriesCollection Class REX.Controls.WPF Namespace REXToolboxCategoriesCollection Class

Initializes a new instance of the REXToolboxCategoriesCollection class.

C#
public REXToolboxCategoriesCollection(REXToolbox toolbox);
Parameters
Parameters | Description
toolbox | The toolbox.
Description
Class

REXToolboxCategoriesCollection Class

Links
REXToolboxCategoriesCollection Class, REX.Controls.WPF Namespace, REXToolboxCategoriesCollection Class


REXToolboxCategory Class

REXToolboxCategory Class
REX.Controls.WPF Namespace Legend Members Public Methods REXToolboxCategory Properties

Represents the REXToolbox category.

Class Hierarchy
C#
public class REXToolboxCategory : REXToolboxObject;
Description
Namespace

REX.Controls.WPF Namespace

Public Methods
Public Method | Description
REXToolboxCategory | Initializes a new instance of the REXToolboxCategory class.
REXToolboxCategory Properties
REXToolboxCategory Properties | Description
Items | Gets or sets the items.
Links
REX.Controls.WPF Namespace, Legend, Members, Public Methods, REXToolboxCategory Properties


REXToolboxCategory.REXToolboxCategory Constructor

REXToolboxCategory.REXToolboxCategory Constructor
REXToolboxCategory Class REX.Controls.WPF Namespace REXToolboxCategory Class

Initializes a new instance of the REXToolboxCategory class.

C#
public REXToolboxCategory();
Description
Class

REXToolboxCategory Class

Links
REXToolboxCategory Class, REX.Controls.WPF Namespace, REXToolboxCategory Class


REXToolboxCategory.Items Property

REXToolboxCategory.Items Property
REXToolboxCategory Class REX.Controls.WPF Namespace REXToolboxCategory Class

Gets or sets the items.

C#
public REXToolboxItemsCollection Items;
Description

The items.

Class

REXToolboxCategory Class

Links
REXToolboxCategory Class, REX.Controls.WPF Namespace, REXToolboxCategory Class


REXToolboxCollection Class

REXToolboxCollection Class
REX.Controls.WPF Namespace Legend Members Public Methods

Base classes for REXToolboxs collections.

Class Hierarchy
C#
public class REXToolboxCollection<T_Item> : System.Collections.ObjectModel.ObservableCollection<T_Item>;
Description
Namespace

REX.Controls.WPF Namespace

Public Methods
Public Method | Description
REXToolboxCollection | Initializes a new instance of the REXToolboxCollection<T_Item> class.
Links
REX.Controls.WPF Namespace, Legend, Members, Public Methods


REXToolboxCollection.REXToolboxCollection Constructor

REXToolboxCollection.REXToolboxCollection Constructor
REXToolboxCollection Class REX.Controls.WPF Namespace REXToolboxCollection Class

Initializes a new instance of the REXToolboxCollection<T_Item> class.

C#
public REXToolboxCollection(REXToolbox toolbox);
Parameters
Parameters | Description
toolbox | The toolbox.
Description
Class

REXToolboxCollection Class

Links
REXToolboxCollection Class, REX.Controls.WPF Namespace, REXToolboxCollection Class


REXToolboxItem Class

REXToolboxItem Class
REX.Controls.WPF Namespace Legend Members Public Methods REXToolboxItem Properties

Represents the REXToolbox item.

Class Hierarchy
C#
public class REXToolboxItem : REXToolboxObject;
Description
Namespace

REX.Controls.WPF Namespace

Public Methods
Public Method | Description
REXToolboxItem | Initializes a new instance of the REXToolboxItem class.
REXToolboxItem Properties
REXToolboxItem Properties | Description
Image | Gets or sets the image.
Links
REX.Controls.WPF Namespace, Legend, Members, Public Methods, REXToolboxItem Properties


REXToolboxItem.REXToolboxItem Constructor

REXToolboxItem.REXToolboxItem Constructor
REXToolboxItem Class REX.Controls.WPF Namespace REXToolboxItem Class

Initializes a new instance of the REXToolboxItem class.

C#
public REXToolboxItem();
Description
Class

REXToolboxItem Class

Links
REXToolboxItem Class, REX.Controls.WPF Namespace, REXToolboxItem Class


REXToolboxItem.Image Property

REXToolboxItem.Image Property
REXToolboxItem Class REX.Controls.WPF Namespace REXToolboxItem Class

Gets or sets the image.

C#
public ImageSource Image;
Description

The image.

Class

REXToolboxItem Class

Links
REXToolboxItem Class, REX.Controls.WPF Namespace, REXToolboxItem Class


REXToolboxItemsCollection Class

REXToolboxItemsCollection Class
REX.Controls.WPF Namespace Legend Members Public Methods

Represents collection of items of the REXToolbox control.

Class Hierarchy
C#
public class REXToolboxItemsCollection : REXToolboxCollection<REXToolboxItem>;
Description
Namespace

REX.Controls.WPF Namespace

Public Methods
Public Method | Description
REXToolboxItemsCollection | Initializes a new instance of the REXToolboxItemsCollection class.
Links
REX.Controls.WPF Namespace, Legend, Members, Public Methods


REXToolboxItemsCollection.REXToolboxItemsCollection Constructor

REXToolboxItemsCollection.REXToolboxItemsCollection Constructor
REXToolboxItemsCollection Class REX.Controls.WPF Namespace REXToolboxItemsCollection Class

Initializes a new instance of the REXToolboxItemsCollection class.

C#
public REXToolboxItemsCollection(REXToolbox toolbox);
Parameters
Parameters | Description
toolbox | The toolbox.
Description
Class

REXToolboxItemsCollection Class

Links
REXToolboxItemsCollection Class, REX.Controls.WPF Namespace, REXToolboxItemsCollection Class


REXToolboxObject Class

REXToolboxObject Class
REX.Controls.WPF Namespace Legend Members Public Methods REXToolboxObject Properties

The base class for all toolbox objects (categories and items)

Class Hierarchy
C#
public class REXToolboxObject;
Namespace

REX.Controls.WPF Namespace

Public Methods
Public Method | Description
REXToolboxObject | Initializes a new instance of the REXToolboxObject class.
REXToolboxObject Properties
REXToolboxObject Properties | Description
Description | Gets or sets the description.
Name | Gets or sets the name.
Tag | Gets or sets the tag.
Links
REX.Controls.WPF Namespace, Legend, Members, Public Methods, REXToolboxObject Properties


REXToolboxObject.REXToolboxObject Constructor

REXToolboxObject.REXToolboxObject Constructor
REXToolboxObject Class REX.Controls.WPF Namespace REXToolboxObject Class

Initializes a new instance of the REXToolboxObject class.

C#
public REXToolboxObject();
Description
Class

REXToolboxObject Class

Links
REXToolboxObject Class, REX.Controls.WPF Namespace, REXToolboxObject Class


REXToolboxObject.Description Property

REXToolboxObject.Description Property
REXToolboxObject Class REX.Controls.WPF Namespace REXToolboxObject Class

Gets or sets the description.

C#
public string Description;
Description

The description.

Class

REXToolboxObject Class

Links
REXToolboxObject Class, REX.Controls.WPF Namespace, REXToolboxObject Class


REXToolboxObject.Name Property

REXToolboxObject.Name Property
REXToolboxObject Class REX.Controls.WPF Namespace REXToolboxObject Class

Gets or sets the name.

C#
public string Name;
Description

The name.

Class

REXToolboxObject Class

Links
REXToolboxObject Class, REX.Controls.WPF Namespace, REXToolboxObject Class


REXToolboxObject.Tag Property

REXToolboxObject.Tag Property
REXToolboxObject Class REX.Controls.WPF Namespace REXToolboxObject Class

Gets or sets the tag.

C#
public object Tag;
Description

The tag.

Class

REXToolboxObject Class

Links
REXToolboxObject Class, REX.Controls.WPF Namespace, REXToolboxObject Class


REXUnitComboBox Class

REXUnitComboBox Class
REX.Controls.WPF Namespace Legend Members Public Methods REXUnitComboBox Fields REXUnitComboBox Methods REXUnitComboBox Properties

Represents the REXUnitComboBox control with a built in IREXUnitEngine.

Class Hierarchy
C#
public class REXUnitComboBox : REXComboBox;
Description
Namespace

REX.Controls.WPF Namespace

Public Methods
Public Method | Description
REXUnitComboBox | Initializes a new instance of the REXUnitComboBox class.
REXUnitComboBox Fields
REXUnitComboBox Fields | Description
ComplexDoubleValueBaseProperty | This is ComplexDoubleValueBaseProperty, a member of class REXUnitComboBox.
DoubleValueBaseProperty | This is DoubleValueBaseProperty, a member of class REXUnitComboBox.
PowerProperty | This is PowerProperty, a member of class REXUnitComboBox.
UnitTypeProperty | This is UnitTypeProperty, a member of class REXUnitComboBox.
REXUnitComboBox Methods
REXUnitComboBox Methods | Description
GetBaseMaxValue | Gets the maximum value and converts it to base units.
GetBaseMinValue | Gets the minimum value and converts it to base units.
GetComplexDataBaseValue | Get the values and convert it to base units.
GetComplexDataInterfaceValue | Get the values and convert it to interface units.
GetDataBaseValue | Gets the value and converts it to base units.
GetDataInterfaceValue | Gets the value and converts it to interface units.
GetInterfaceMaxValue | Gets the maximum value and converts it to interface units.
GetInterfaceMinValue | Gets the minimum value and converts it to interface units.
SetBaseMaxValue | Set the maximum value defined in base units.
SetBaseMinValue | Set the minimum value defined in base units.
SetComplexDataBaseValue | Set the list of values defined in base units.
SetComplexDataInterfaceValue | Set the list of values defined in interface units.
SetDataBaseValue | Set the value in base units.
SetDataInterfaceValue | Set the value in interface units.
SetInterfaceMaxValue | Set the maximum value defined in interface units.
SetInterfaceMinValue | Set the minimum value defined in interface units.
REXUnitComboBox Properties
REXUnitComboBox Properties | Description
ComplexDoubleValueBase | Gets or sets the complex double value.
DoubleValueBase | Gets or sets the double value.
Power | Gets or sets the power of the unit.
UnitEngine | Gets or sets the unit engine.
UnitType | Gets or sets the type of the unit.
Links
REX.Controls.WPF Namespace, Legend, Members, Public Methods, REXUnitComboBox Fields, REXUnitComboBox Methods, REXUnitComboBox Properties


REXUnitComboBox.REXUnitComboBox Constructor

REXUnitComboBox.REXUnitComboBox Constructor
REXUnitComboBox Class REX.Controls.WPF Namespace REXUnitComboBox Class

Initializes a new instance of the REXUnitComboBox class.

C#
public REXUnitComboBox();
Description
Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.WPF Namespace, REXUnitComboBox Class


REXUnitComboBox.ComplexDoubleValueBaseProperty Field

REXUnitComboBox.ComplexDoubleValueBaseProperty Field
REXUnitComboBox Class REX.Controls.WPF Namespace REXUnitComboBox Class

This is ComplexDoubleValueBaseProperty, a member of class REXUnitComboBox.

C#
public static readonly DependencyProperty ComplexDoubleValueBaseProperty;
Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.WPF Namespace, REXUnitComboBox Class


REXUnitComboBox.DoubleValueBaseProperty Field

REXUnitComboBox.DoubleValueBaseProperty Field
REXUnitComboBox Class REX.Controls.WPF Namespace REXUnitComboBox Class

This is DoubleValueBaseProperty, a member of class REXUnitComboBox.

C#
public static readonly DependencyProperty DoubleValueBaseProperty;
Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.WPF Namespace, REXUnitComboBox Class


REXUnitComboBox.PowerProperty Field

REXUnitComboBox.PowerProperty Field
REXUnitComboBox Class REX.Controls.WPF Namespace REXUnitComboBox Class

This is PowerProperty, a member of class REXUnitComboBox.

C#
public static readonly DependencyProperty PowerProperty;
Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.WPF Namespace, REXUnitComboBox Class


REXUnitComboBox.UnitTypeProperty Field

REXUnitComboBox.UnitTypeProperty Field
REXUnitComboBox Class REX.Controls.WPF Namespace REXUnitComboBox Class

This is UnitTypeProperty, a member of class REXUnitComboBox.

C#
public static readonly DependencyProperty UnitTypeProperty;
Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.WPF Namespace, REXUnitComboBox Class


REXUnitComboBox.GetBaseMaxValue Method

REXUnitComboBox.GetBaseMaxValue Method
REXUnitComboBox Class REX.Controls.WPF Namespace REXUnitComboBox Class

Gets the maximum value and converts it to base units.

C#
public double GetBaseMaxValue();
Returns

The value.

Description
Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.WPF Namespace, REXUnitComboBox Class


REXUnitComboBox.GetBaseMinValue Method

REXUnitComboBox.GetBaseMinValue Method
REXUnitComboBox Class REX.Controls.WPF Namespace REXUnitComboBox Class

Gets the minimum value and converts it to base units.

C#
public double GetBaseMinValue();
Returns

The value.

Description
Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.WPF Namespace, REXUnitComboBox Class


REXUnitComboBox.GetComplexDataBaseValue Method

REXUnitComboBox.GetComplexDataBaseValue Method
REXUnitComboBox Class REX.Controls.WPF Namespace REXUnitComboBox Class

Get the values and convert it to base units.

C#
public List<double> GetComplexDataBaseValue();
Returns

The list of values.

Description
Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.WPF Namespace, REXUnitComboBox Class


REXUnitComboBox.GetComplexDataInterfaceValue Method

REXUnitComboBox.GetComplexDataInterfaceValue Method
REXUnitComboBox Class REX.Controls.WPF Namespace REXUnitComboBox Class

Get the values and convert it to interface units.

C#
public List<double> GetComplexDataInterfaceValue(REXInterfaceType interfaceType);
Parameters
Parameters | Description
interfaceType | The product context.
Returns

The list of values.

Description
Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.WPF Namespace, REXUnitComboBox Class


REXUnitComboBox.GetDataBaseValue Method

REXUnitComboBox.GetDataBaseValue Method
REXUnitComboBox Class REX.Controls.WPF Namespace REXUnitComboBox Class

Gets the value and converts it to base units.

C#
public double GetDataBaseValue();
Returns

The value.

Description
Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.WPF Namespace, REXUnitComboBox Class


REXUnitComboBox.GetDataInterfaceValue Method

REXUnitComboBox.GetDataInterfaceValue Method
REXUnitComboBox Class REX.Controls.WPF Namespace REXUnitComboBox Class

Gets the value and converts it to interface units.

C#
public double GetDataInterfaceValue(REXInterfaceType interfaceType);
Parameters
Parameters | Description
interfaceType | The product context.
Returns

The value.

Description
Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.WPF Namespace, REXUnitComboBox Class


REXUnitComboBox.GetInterfaceMaxValue Method

REXUnitComboBox.GetInterfaceMaxValue Method
REXUnitComboBox Class REX.Controls.WPF Namespace REXUnitComboBox Class

Gets the maximum value and converts it to interface units.

C#
public double GetInterfaceMaxValue(REXInterfaceType interfaceType);
Parameters
Parameters | Description
interfaceType | The product context.
Returns

The value.

Description
Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.WPF Namespace, REXUnitComboBox Class


REXUnitComboBox.GetInterfaceMinValue Method

REXUnitComboBox.GetInterfaceMinValue Method
REXUnitComboBox Class REX.Controls.WPF Namespace REXUnitComboBox Class

Gets the minimum value and converts it to interface units.

C#
public double GetInterfaceMinValue(REXInterfaceType interfaceType);
Parameters
Parameters | Description
interfaceType | The product context.
Returns

The value.

Description
Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.WPF Namespace, REXUnitComboBox Class


REXUnitComboBox.SetBaseMaxValue Method

REXUnitComboBox.SetBaseMaxValue Method
REXUnitComboBox Class REX.Controls.WPF Namespace REXUnitComboBox Class

Set the maximum value defined in base units.

C#
public void SetBaseMaxValue(double value);
Parameters
Parameters | Description
value | The value.
Description
Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.WPF Namespace, REXUnitComboBox Class


REXUnitComboBox.SetBaseMinValue Method

REXUnitComboBox.SetBaseMinValue Method
REXUnitComboBox Class REX.Controls.WPF Namespace REXUnitComboBox Class

Set the minimum value defined in base units.

C#
public void SetBaseMinValue(double value);
Parameters
Parameters | Description
value | The value.
Description
Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.WPF Namespace, REXUnitComboBox Class


REXUnitComboBox.SetComplexDataBaseValue Method

REXUnitComboBox.SetComplexDataBaseValue Method
REXUnitComboBox Class REX.Controls.WPF Namespace REXUnitComboBox Class

Set the list of values defined in base units.

C#
public void SetComplexDataBaseValue(List<double> values);
Parameters
Parameters | Description
values | The values.
Description
Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.WPF Namespace, REXUnitComboBox Class


REXUnitComboBox.SetComplexDataInterfaceValue Method

REXUnitComboBox.SetComplexDataInterfaceValue Method
REXUnitComboBox Class REX.Controls.WPF Namespace REXUnitComboBox Class

Set the list of values defined in interface units.

C#
public void SetComplexDataInterfaceValue(List<double> values, REXInterfaceType interfaceType);
Parameters
Parameters | Description
values | The values.
interfaceType | The product context.
Description
Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.WPF Namespace, REXUnitComboBox Class


REXUnitComboBox.SetDataBaseValue Method

REXUnitComboBox.SetDataBaseValue Method
REXUnitComboBox Class REX.Controls.WPF Namespace REXUnitComboBox Class

Set the value in base units.

C#
public void SetDataBaseValue(double value);
Parameters
Parameters | Description
value | The value.
Description
Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.WPF Namespace, REXUnitComboBox Class


REXUnitComboBox.SetDataInterfaceValue Method

REXUnitComboBox.SetDataInterfaceValue Method
REXUnitComboBox Class REX.Controls.WPF Namespace REXUnitComboBox Class

Set the value in interface units.

C#
public void SetDataInterfaceValue(double value, REXInterfaceType interfaceType);
Parameters
Parameters | Description
value | The value.
interfaceType | The product context.
Description
Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.WPF Namespace, REXUnitComboBox Class


REXUnitComboBox.SetInterfaceMaxValue Method

REXUnitComboBox.SetInterfaceMaxValue Method
REXUnitComboBox Class REX.Controls.WPF Namespace REXUnitComboBox Class

Set the maximum value defined in interface units.

C#
public void SetInterfaceMaxValue(double value, REXInterfaceType interfaceType);
Parameters
Parameters | Description
value | The value.
interfaceType | The product context.
Description
Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.WPF Namespace, REXUnitComboBox Class


REXUnitComboBox.SetInterfaceMinValue Method

REXUnitComboBox.SetInterfaceMinValue Method
REXUnitComboBox Class REX.Controls.WPF Namespace REXUnitComboBox Class

Set the minimum value defined in interface units.

C#
public void SetInterfaceMinValue(double value, REXInterfaceType interfaceType);
Parameters
Parameters | Description
value | The value.
interfaceType | The product context.
Description
Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.WPF Namespace, REXUnitComboBox Class


REXUnitComboBox.ComplexDoubleValueBase Property

REXUnitComboBox.ComplexDoubleValueBase Property
REXUnitComboBox Class REX.Controls.WPF Namespace REXUnitComboBox Class

Gets or sets the complex double value.

C#
public ObservableCollection<double> ComplexDoubleValueBase;
Description

The complex double value.

Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.WPF Namespace, REXUnitComboBox Class


REXUnitComboBox.DoubleValueBase Property

REXUnitComboBox.DoubleValueBase Property
REXUnitComboBox Class REX.Controls.WPF Namespace REXUnitComboBox Class

Gets or sets the double value.

C#
public double DoubleValueBase;
Description

The double value.

Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.WPF Namespace, REXUnitComboBox Class


REXUnitComboBox.Power Property

REXUnitComboBox.Power Property
REXUnitComboBox Class REX.Controls.WPF Namespace REXUnitComboBox Class

Gets or sets the power of the unit.

C#
public double Power;
Description

The power.

Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.WPF Namespace, REXUnitComboBox Class


REXUnitComboBox.UnitEngine Property

REXUnitComboBox.UnitEngine Property
REXUnitComboBox Class REX.Controls.WPF Namespace REXUnitComboBox Class

Gets or sets the unit engine.

C#
public Autodesk.REX.Framework.IREXUnits UnitEngine;
Description

The unit engine.

Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.WPF Namespace, REXUnitComboBox Class


REXUnitComboBox.UnitType Property

REXUnitComboBox.UnitType Property
REXUnitComboBox Class REX.Controls.WPF Namespace REXUnitComboBox Class

Gets or sets the type of the unit.

C#
public Autodesk.REX.Framework.EUnitType UnitType;
Description

The type of the unit.

Class

REXUnitComboBox Class

Links
REXUnitComboBox Class, REX.Controls.WPF Namespace, REXUnitComboBox Class


REXUnitEditBox Class

REXUnitEditBox Class
REX.Controls.WPF Namespace Legend Members Public Methods REXUnitEditBox Fields REXUnitEditBox Methods REXUnitEditBox Properties

Represents the REXEditBox control with a built in IREXUnitEngine.

Class Hierarchy
C#
public class REXUnitEditBox : REXEditBox;
Description
Namespace

REX.Controls.WPF Namespace

Public Methods
Public Method | Description
REXUnitEditBox | This is REXUnitEditBox, a member of class REXUnitEditBox.
REXUnitEditBox Fields
REXUnitEditBox Fields | Description
ComplexDoubleValueBaseProperty | This is ComplexDoubleValueBaseProperty, a member of class REXUnitEditBox.
DoubleValueBaseProperty | This is DoubleValueBaseProperty, a member of class REXUnitEditBox.
PowerProperty | This is PowerProperty, a member of class REXUnitEditBox.
UnitTypeProperty | This is UnitTypeProperty, a member of class REXUnitEditBox.
REXUnitEditBox Methods
REXUnitEditBox Methods | Description
GetBaseMaxValue | Gets the maximum value and converts it to base units.
GetBaseMinValue | Gets the minimum value and converts it to base units.
GetComplexDataBaseValue | Get the values and convert it to base units.
GetComplexDataInterfaceValue | Get the values and convert it to interface units.
GetDataBaseValue | Gets the value and converts it to base units.
GetDataInterfaceValue | Gets the value and converts it to interface units.
GetInterfaceMaxValue | Gets the maximum value and converts it to interface units.
GetInterfaceMinValue | Gets the minimum value and converts it to interface units.
SetBaseMaxValue | Set the maximum value defined in base units.
SetBaseMinValue | Set the minimum value defined in base units.
SetComplexDataBaseValue | Set the list of values defined in base units.
SetComplexDataInterfaceValue | Set the list of values defined in interface units.
SetDataBaseValue | Set the value in base units.
SetDataInterfaceValue | Set the value in interface units.
SetInterfaceMaxValue | Set the maximum value defined in interface units.
SetInterfaceMinValue | Set the minimum value defined in interface units.
REXUnitEditBox Properties
REXUnitEditBox Properties | Description
ComplexDoubleValueBase | Gets or sets the complex double value.
DoubleValueBase | Gets or sets the double value.
Power | Gets or sets the power of the unit.
UnitEngine | Gets or sets the unit engine.
UnitType | Gets or sets the type of the unit.
Links
REX.Controls.WPF Namespace, Legend, Members, Public Methods, REXUnitEditBox Fields, REXUnitEditBox Methods, REXUnitEditBox Properties


REXUnitEditBox.REXUnitEditBox Constructor

REXUnitEditBox.REXUnitEditBox Constructor
REXUnitEditBox Class REX.Controls.WPF Namespace REXUnitEditBox Class

This is REXUnitEditBox, a member of class REXUnitEditBox.

C#
public REXUnitEditBox();
Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.WPF Namespace, REXUnitEditBox Class


REXUnitEditBox.ComplexDoubleValueBaseProperty Field

REXUnitEditBox.ComplexDoubleValueBaseProperty Field
REXUnitEditBox Class REX.Controls.WPF Namespace REXUnitEditBox Class

This is ComplexDoubleValueBaseProperty, a member of class REXUnitEditBox.

C#
public static readonly DependencyProperty ComplexDoubleValueBaseProperty;
Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.WPF Namespace, REXUnitEditBox Class


REXUnitEditBox.DoubleValueBaseProperty Field

REXUnitEditBox.DoubleValueBaseProperty Field
REXUnitEditBox Class REX.Controls.WPF Namespace REXUnitEditBox Class

This is DoubleValueBaseProperty, a member of class REXUnitEditBox.

C#
public static readonly DependencyProperty DoubleValueBaseProperty;
Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.WPF Namespace, REXUnitEditBox Class


REXUnitEditBox.PowerProperty Field

REXUnitEditBox.PowerProperty Field
REXUnitEditBox Class REX.Controls.WPF Namespace REXUnitEditBox Class

This is PowerProperty, a member of class REXUnitEditBox.

C#
public static readonly DependencyProperty PowerProperty;
Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.WPF Namespace, REXUnitEditBox Class


REXUnitEditBox.UnitTypeProperty Field

REXUnitEditBox.UnitTypeProperty Field
REXUnitEditBox Class REX.Controls.WPF Namespace REXUnitEditBox Class

This is UnitTypeProperty, a member of class REXUnitEditBox.

C#
public static readonly DependencyProperty UnitTypeProperty;
Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.WPF Namespace, REXUnitEditBox Class


REXUnitEditBox.GetBaseMaxValue Method

REXUnitEditBox.GetBaseMaxValue Method
REXUnitEditBox Class REX.Controls.WPF Namespace REXUnitEditBox Class

Gets the maximum value and converts it to base units.

C#
public double GetBaseMaxValue();
Returns

The value.

Description
Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.WPF Namespace, REXUnitEditBox Class


REXUnitEditBox.GetBaseMinValue Method

REXUnitEditBox.GetBaseMinValue Method
REXUnitEditBox Class REX.Controls.WPF Namespace REXUnitEditBox Class

Gets the minimum value and converts it to base units.

C#
public double GetBaseMinValue();
Returns

The value.

Description
Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.WPF Namespace, REXUnitEditBox Class


REXUnitEditBox.GetComplexDataBaseValue Method

REXUnitEditBox.GetComplexDataBaseValue Method
REXUnitEditBox Class REX.Controls.WPF Namespace REXUnitEditBox Class

Get the values and convert it to base units.

C#
public List<double> GetComplexDataBaseValue();
Returns

The list of values.

Description
Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.WPF Namespace, REXUnitEditBox Class


REXUnitEditBox.GetComplexDataInterfaceValue Method

REXUnitEditBox.GetComplexDataInterfaceValue Method
REXUnitEditBox Class REX.Controls.WPF Namespace REXUnitEditBox Class

Get the values and convert it to interface units.

C#
public List<double> GetComplexDataInterfaceValue(REXInterfaceType interfaceType);
Parameters
Parameters | Description
interfaceType | The product context.
Returns

The list of values.

Description
Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.WPF Namespace, REXUnitEditBox Class


REXUnitEditBox.GetDataBaseValue Method

REXUnitEditBox.GetDataBaseValue Method
REXUnitEditBox Class REX.Controls.WPF Namespace REXUnitEditBox Class

Gets the value and converts it to base units.

C#
public double GetDataBaseValue();
Returns

The value.

Description
Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.WPF Namespace, REXUnitEditBox Class


REXUnitEditBox.GetDataInterfaceValue Method

REXUnitEditBox.GetDataInterfaceValue Method
REXUnitEditBox Class REX.Controls.WPF Namespace REXUnitEditBox Class

Gets the value and converts it to interface units.

C#
public double GetDataInterfaceValue(REXInterfaceType interfaceType);
Parameters
Parameters | Description
interfaceType | The product context.
Returns

The value.

Description
Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.WPF Namespace, REXUnitEditBox Class


REXUnitEditBox.GetInterfaceMaxValue Method

REXUnitEditBox.GetInterfaceMaxValue Method
REXUnitEditBox Class REX.Controls.WPF Namespace REXUnitEditBox Class

Gets the maximum value and converts it to interface units.

C#
public double GetInterfaceMaxValue(REXInterfaceType interfaceType);
Parameters
Parameters | Description
interfaceType | The product context.
Returns

The value.

Description
Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.WPF Namespace, REXUnitEditBox Class


REXUnitEditBox.GetInterfaceMinValue Method

REXUnitEditBox.GetInterfaceMinValue Method
REXUnitEditBox Class REX.Controls.WPF Namespace REXUnitEditBox Class

Gets the minimum value and converts it to interface units.

C#
public double GetInterfaceMinValue(REXInterfaceType interfaceType);
Parameters
Parameters | Description
interfaceType | The product context.
Returns

The value.

Description
Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.WPF Namespace, REXUnitEditBox Class


REXUnitEditBox.SetBaseMaxValue Method

REXUnitEditBox.SetBaseMaxValue Method
REXUnitEditBox Class REX.Controls.WPF Namespace REXUnitEditBox Class

Set the maximum value defined in base units.

C#
public void SetBaseMaxValue(double value);
Parameters
Parameters | Description
value | The value.
Description
Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.WPF Namespace, REXUnitEditBox Class


REXUnitEditBox.SetBaseMinValue Method

REXUnitEditBox.SetBaseMinValue Method
REXUnitEditBox Class REX.Controls.WPF Namespace REXUnitEditBox Class

Set the minimum value defined in base units.

C#
public void SetBaseMinValue(double value);
Parameters
Parameters | Description
value | The value.
Description
Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.WPF Namespace, REXUnitEditBox Class


REXUnitEditBox.SetComplexDataBaseValue Method

REXUnitEditBox.SetComplexDataBaseValue Method
REXUnitEditBox Class REX.Controls.WPF Namespace REXUnitEditBox Class

Set the list of values defined in base units.

C#
public void SetComplexDataBaseValue(List<double> values);
Parameters
Parameters | Description
values | The values.
Description
Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.WPF Namespace, REXUnitEditBox Class


REXUnitEditBox.SetComplexDataInterfaceValue Method

REXUnitEditBox.SetComplexDataInterfaceValue Method
REXUnitEditBox Class REX.Controls.WPF Namespace REXUnitEditBox Class

Set the list of values defined in interface units.

C#
public void SetComplexDataInterfaceValue(List<double> values, REXInterfaceType interfaceType);
Parameters
Parameters | Description
values | The values.
interfaceType | The product context.
Description
Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.WPF Namespace, REXUnitEditBox Class


REXUnitEditBox.SetDataBaseValue Method

REXUnitEditBox.SetDataBaseValue Method
REXUnitEditBox Class REX.Controls.WPF Namespace REXUnitEditBox Class

Set the value in base units.

C#
public void SetDataBaseValue(double value);
Parameters
Parameters | Description
value | The value.
Description
Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.WPF Namespace, REXUnitEditBox Class


REXUnitEditBox.SetDataInterfaceValue Method

REXUnitEditBox.SetDataInterfaceValue Method
REXUnitEditBox Class REX.Controls.WPF Namespace REXUnitEditBox Class

Set the value in interface units.

C#
public void SetDataInterfaceValue(double value, REXInterfaceType interfaceType);
Parameters
Parameters | Description
value | The value.
interfaceType | The product context.
Description
Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.WPF Namespace, REXUnitEditBox Class


REXUnitEditBox.SetInterfaceMaxValue Method

REXUnitEditBox.SetInterfaceMaxValue Method
REXUnitEditBox Class REX.Controls.WPF Namespace REXUnitEditBox Class

Set the maximum value defined in interface units.

C#
public void SetInterfaceMaxValue(double value, REXInterfaceType interfaceType);
Parameters
Parameters | Description
value | The value.
interfaceType | The product context.
Description
Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.WPF Namespace, REXUnitEditBox Class


REXUnitEditBox.SetInterfaceMinValue Method

REXUnitEditBox.SetInterfaceMinValue Method
REXUnitEditBox Class REX.Controls.WPF Namespace REXUnitEditBox Class

Set the minimum value defined in interface units.

C#
public void SetInterfaceMinValue(double value, REXInterfaceType interfaceType);
Parameters
Parameters | Description
value | The value.
interfaceType | The product context.
Description
Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.WPF Namespace, REXUnitEditBox Class


REXUnitEditBox.ComplexDoubleValueBase Property

REXUnitEditBox.ComplexDoubleValueBase Property
REXUnitEditBox Class REX.Controls.WPF Namespace REXUnitEditBox Class

Gets or sets the complex double value.

C#
public ObservableCollection<double> ComplexDoubleValueBase;
Description

The complex double value.

Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.WPF Namespace, REXUnitEditBox Class


REXUnitEditBox.DoubleValueBase Property

REXUnitEditBox.DoubleValueBase Property
REXUnitEditBox Class REX.Controls.WPF Namespace REXUnitEditBox Class

Gets or sets the double value.

C#
public double DoubleValueBase;
Description

The double value.

Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.WPF Namespace, REXUnitEditBox Class


REXUnitEditBox.Power Property

REXUnitEditBox.Power Property
REXUnitEditBox Class REX.Controls.WPF Namespace REXUnitEditBox Class

Gets or sets the power of the unit.

C#
public double Power;
Description

The power.

Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.WPF Namespace, REXUnitEditBox Class


REXUnitEditBox.UnitEngine Property

REXUnitEditBox.UnitEngine Property
REXUnitEditBox Class REX.Controls.WPF Namespace REXUnitEditBox Class

Gets or sets the unit engine.

C#
public Autodesk.REX.Framework.IREXUnits UnitEngine;
Description

The unit engine.

Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.WPF Namespace, REXUnitEditBox Class


REXUnitEditBox.UnitType Property

REXUnitEditBox.UnitType Property
REXUnitEditBox Class REX.Controls.WPF Namespace REXUnitEditBox Class

Gets or sets the type of the unit.

C#
public Autodesk.REX.Framework.EUnitType UnitType;
Description

The type of the unit.

Class

REXUnitEditBox Class

Links
REXUnitEditBox Class, REX.Controls.WPF Namespace, REXUnitEditBox Class


WPFCommon Class

WPFCommon Class
REX.Controls.WPF Namespace Legend Members WPFCommon Methods

This is class REX.Controls.WPF.WPFCommon.

Class Hierarchy
C#
public class WPFCommon;
Namespace

REX.Controls.WPF Namespace

WPFCommon Methods
WPFCommon Methods | Description
FindChild | Finds the child.
SetPropertyToAllElements | This is SetPropertyToAllElements, a member of class WPFCommon.
UpdateDoubleObserveCollection | This is UpdateDoubleObserveCollection, a member of class WPFCommon.
Links
REX.Controls.WPF Namespace, Legend, Members, WPFCommon Methods


WPFCommon.FindChild Method

WPFCommon.FindChild Method
WPFCommon Class REX.Controls.WPF Namespace WPFCommon Class

Finds the child.

C#
public static T FindChild<T>(DependencyObject parent, string childName) where T : DependencyObject;
Parameters
Parameters | Description
parent | The parent.
childName | Name of the child.
Type Parameters
Type Parameters | Description
T |
Description
Class

WPFCommon Class

Links
WPFCommon Class, REX.Controls.WPF Namespace, WPFCommon Class


WPFCommon.SetPropertyToAllElements Method

WPFCommon.SetPropertyToAllElements Method
WPFCommon Class REX.Controls.WPF Namespace WPFCommon Class

This is SetPropertyToAllElements, a member of class WPFCommon.

C#
public static void SetPropertyToAllElements(DependencyObject parent, DependencyProperty property, object value);
Class

WPFCommon Class

Links
WPFCommon Class, REX.Controls.WPF Namespace, WPFCommon Class


WPFCommon.UpdateDoubleObserveCollection Method

WPFCommon.UpdateDoubleObserveCollection Method
WPFCommon Class REX.Controls.WPF Namespace WPFCommon Class

This is UpdateDoubleObserveCollection, a member of class WPFCommon.

C#
public static void UpdateDoubleObserveCollection(List<double> values, System.Collections.ObjectModel.ObservableCollection<double> obsColl);
Class

WPFCommon Class

Links
WPFCommon Class, REX.Controls.WPF Namespace, WPFCommon Class


ROHTML Namespace

Previous | Next
ROHTML Namespace
Legend Classes

This is namespace ROHTML.

Classes
Class | Description
ROHTMLMessages | This is class ROHTML.ROHTMLMessages.
ROHTMLStdImages | This is class ROHTML.ROHTMLStdImages.
ROHTMLTableFormats | This is class ROHTML.ROHTMLTableFormats.
XHTMLDocument | This is class ROHTML.XHTMLDocument.
XHTMLElement | This is class ROHTML.XHTMLElement.
XHTMLTable | This is class ROHTML.XHTMLTable.
Links
Legend, Classes
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


ROHTMLMessages Class

ROHTMLMessages Class
ROHTML Namespace Legend Members ROHTMLMessages Fields

This is class ROHTML.ROHTMLMessages.

Class Hierarchy
C#
public class ROHTMLMessages;
Namespace

ROHTML Namespace

ROHTMLMessages Fields
ROHTMLMessages Fields | Description
ROTF_MSG_ERROR | Error
ROTF_MSG_OK | Verified
Links
ROHTML Namespace, Legend, Members, ROHTMLMessages Fields


ROHTMLMessages.ROTF_MSG_ERROR Field

ROHTMLMessages.ROTF_MSG_ERROR Field
ROHTMLMessages Class ROHTML Namespace ROHTMLMessages Class

Error

C#
public const short ROTF_MSG_ERROR = &H0002;
Class

ROHTMLMessages Class

Links
ROHTMLMessages Class, ROHTML Namespace, ROHTMLMessages Class


ROHTMLMessages.ROTF_MSG_OK Field

ROHTMLMessages.ROTF_MSG_OK Field
ROHTMLMessages Class ROHTML Namespace ROHTMLMessages Class

Verified

C#
public const short ROTF_MSG_OK = &H0001;
Class

ROHTMLMessages Class

Links
ROHTMLMessages Class, ROHTML Namespace, ROHTMLMessages Class


ROHTMLStdImages Class

ROHTMLStdImages Class
ROHTML Namespace Legend Members ROHTMLStdImages Fields

This is class ROHTML.ROHTMLStdImages.

Class Hierarchy
C#
public class ROHTMLStdImages;
Namespace

ROHTML Namespace

ROHTMLStdImages Fields
ROHTMLStdImages Fields | Description
ROSTD_TABLET_ERR | Image error
ROSTD_TABLET_OK | Image verified
Links
ROHTML Namespace, Legend, Members, ROHTMLStdImages Fields


ROHTMLStdImages.ROSTD_TABLET_ERR Field

ROHTMLStdImages.ROSTD_TABLET_ERR Field
ROHTMLStdImages Class ROHTML Namespace ROHTMLStdImages Class

Image error

C#
public const short ROSTD_TABLET_ERR = &H0002;
Class

ROHTMLStdImages Class

Links
ROHTMLStdImages Class, ROHTML Namespace, ROHTMLStdImages Class


ROHTMLStdImages.ROSTD_TABLET_OK Field

ROHTMLStdImages.ROSTD_TABLET_OK Field
ROHTMLStdImages Class ROHTML Namespace ROHTMLStdImages Class

Image verified

C#
public const short ROSTD_TABLET_OK = &H0001;
Class

ROHTMLStdImages Class

Links
ROHTMLStdImages Class, ROHTML Namespace, ROHTMLStdImages Class


ROHTMLTableFormats Class

ROHTMLTableFormats Class
ROHTML Namespace Legend Members ROHTMLTableFormats Fields

This is class ROHTML.ROHTMLTableFormats.

Class Hierarchy
C#
public class ROHTMLTableFormats;
Namespace

ROHTML Namespace

ROHTMLTableFormats Fields
ROHTMLTableFormats Fields | Description
ROTF_LIST_1 | Columns:2, Style:list1
ROTF_LIST_2 | Columns:5, Width:100%, Style:list2 Column[1]:Width:8%, nowrap Column[2]:Width:8%, nowrap, Style:font-family:monospace;text-align:right; Column[3]:Width:10%, Style:text-align:center; Column[4]:Width:40% Column[5]:Style=text-align:right;
ROTF_LIST_3 | Columns:2, Width:100%, Style:list3 Column[2].style=text-align:right;
ROTF_LIST_4 | Columns:2, Style:list4 Column[1]:nowrap
ROTF_TABLE_1 | Width:100%, Style:table1, Header rows and columns:1
ROTF_TABLE_2 | Width:100%, Style:table2, Header rows and columns:1
ROTF_TABLE_3 | Width:100%, Style:table3, Header rows and columns:1
ROTF_VERIFY_1 | Columns:4, Width:100% Column[1]:Width:40%, nowrap, Column[2]:Width:25%, nowrap Column[3]:nowrap Column[4]:Width:25%, Style:text-align:right
Links
ROHTML Namespace, Legend, Members, ROHTMLTableFormats Fields


ROHTMLTableFormats.ROTF_LIST_1 Field

ROHTMLTableFormats.ROTF_LIST_1 Field
ROHTMLTableFormats Class ROHTML Namespace ROHTMLTableFormats Class

Columns:2, Style:list1

C#
public const short ROTF_LIST_1 = &H0001;
Class

ROHTMLTableFormats Class

Links
ROHTMLTableFormats Class, ROHTML Namespace, ROHTMLTableFormats Class


ROHTMLTableFormats.ROTF_LIST_2 Field

ROHTMLTableFormats.ROTF_LIST_2 Field
ROHTMLTableFormats Class ROHTML Namespace ROHTMLTableFormats Class

Columns:5, Width:100%, Style:list2 Column[1]:Width:8%, nowrap Column[2]:Width:8%, nowrap, Style:font-family:monospace;text-align:right; Column[3]:Width:10%, Style:text-align:center; Column[4]:Width:40% Column[5]:Style=text-align:right;

C#
public const short ROTF_LIST_2 = &H0002;
Class

ROHTMLTableFormats Class

Links
ROHTMLTableFormats Class, ROHTML Namespace, ROHTMLTableFormats Class


ROHTMLTableFormats.ROTF_LIST_3 Field

ROHTMLTableFormats.ROTF_LIST_3 Field
ROHTMLTableFormats Class ROHTML Namespace ROHTMLTableFormats Class

Columns:2, Width:100%, Style:list3 Column[2].style=text-align:right;

C#
public const short ROTF_LIST_3 = &H0003;
Class

ROHTMLTableFormats Class

Links
ROHTMLTableFormats Class, ROHTML Namespace, ROHTMLTableFormats Class


ROHTMLTableFormats.ROTF_LIST_4 Field

ROHTMLTableFormats.ROTF_LIST_4 Field
ROHTMLTableFormats Class ROHTML Namespace ROHTMLTableFormats Class

Columns:2, Style:list4 Column[1]:nowrap

C#
public const short ROTF_LIST_4 = &H0004;
Class

ROHTMLTableFormats Class

Links
ROHTMLTableFormats Class, ROHTML Namespace, ROHTMLTableFormats Class


ROHTMLTableFormats.ROTF_TABLE_1 Field

ROHTMLTableFormats.ROTF_TABLE_1 Field
ROHTMLTableFormats Class ROHTML Namespace ROHTMLTableFormats Class

Width:100%, Style:table1, Header rows and columns:1

C#
public const short ROTF_TABLE_1 = &H0201;
Class

ROHTMLTableFormats Class

Links
ROHTMLTableFormats Class, ROHTML Namespace, ROHTMLTableFormats Class


ROHTMLTableFormats.ROTF_TABLE_2 Field

ROHTMLTableFormats.ROTF_TABLE_2 Field
ROHTMLTableFormats Class ROHTML Namespace ROHTMLTableFormats Class

Width:100%, Style:table2, Header rows and columns:1

C#
public const short ROTF_TABLE_2 = &H0202;
Class

ROHTMLTableFormats Class

Links
ROHTMLTableFormats Class, ROHTML Namespace, ROHTMLTableFormats Class


ROHTMLTableFormats.ROTF_TABLE_3 Field

ROHTMLTableFormats.ROTF_TABLE_3 Field
ROHTMLTableFormats Class ROHTML Namespace ROHTMLTableFormats Class

Width:100%, Style:table3, Header rows and columns:1

C#
public const short ROTF_TABLE_3 = &H0203;
Class

ROHTMLTableFormats Class

Links
ROHTMLTableFormats Class, ROHTML Namespace, ROHTMLTableFormats Class


ROHTMLTableFormats.ROTF_VERIFY_1 Field

ROHTMLTableFormats.ROTF_VERIFY_1 Field
ROHTMLTableFormats Class ROHTML Namespace ROHTMLTableFormats Class

Columns:4, Width:100% Column[1]:Width:40%, nowrap, Column[2]:Width:25%, nowrap Column[3]:nowrap Column[4]:Width:25%, Style:text-align:right

C#
public const short ROTF_VERIFY_1 = &H0101;
Class

ROHTMLTableFormats Class

Links
ROHTMLTableFormats Class, ROHTML Namespace, ROHTMLTableFormats Class


XHTMLDocument Class

XHTMLDocument Class
ROHTML Namespace Legend Members XHTMLDocument Fields XHTMLDocument Methods

This is class ROHTML.XHTMLDocument.

Class Hierarchy
C#
public class XHTMLDocument;
Namespace

ROHTML Namespace

XHTMLDocument Fields
XHTMLDocument Fields | Description
Body | XHTMLElement that represents the body of the document.
CSSFile | String containing the CSS (Cascading Style Sheets) file path for the document.
Head | XHTMLElement that represents the header of the document.
Language | Short that indicates the language in which the document is written.
Name |
NumberedHeaders | Bool that indicates whether headers are numbered automatically by the document, e.g.
Status | ROHTMLMessages indicates the status of the document, it is used in note header and footer.
Version | String (read-only) that indicates the version of the component, e.g.
XHTMLDocument Methods
XHTMLDocument Methods | Description
IsVersion | Returns True if the version of the component is greater or equal to the given version, version should be formatted as follow: "MAJOR.MINOR.PATCH.COMPILATION", e.g.
Save | Saves the XHTML document to the specified location.
SaveAsSingleFile | Saves the document to the specified location as MS MHTML file.
Show | Launches Internet Explorer and navigates to the specified file.
ToString | Returns String containing the generated document.
Links
ROHTML Namespace, Legend, Members, XHTMLDocument Fields, XHTMLDocument Methods


XHTMLDocument.Body Field

XHTMLDocument.Body Field
XHTMLDocument Class ROHTML Namespace XHTMLDocument Class

XHTMLElement that represents the body of the document.

C#
public XHTMLElement Body;
Description
Class

XHTMLDocument Class

Links
XHTMLDocument Class, ROHTML Namespace, XHTMLDocument Class


XHTMLDocument.CSSFile Field

XHTMLDocument.CSSFile Field
XHTMLDocument Class ROHTML Namespace XHTMLDocument Class

String containing the CSS (Cascading Style Sheets) file path for the document.

C#
public string CSSFile;
Description

Default value is "rohtml.css". If the file name doesn't contain the full path, document tries to find the file in ROC directory (use InitSysPaths method to make it possible).

Class

XHTMLDocument Class

Links
XHTMLDocument Class, ROHTML Namespace, XHTMLDocument Class


XHTMLDocument.Head Field

XHTMLDocument.Head Field
XHTMLDocument Class ROHTML Namespace XHTMLDocument Class

XHTMLElement that represents the header of the document.

C#
public XHTMLElement Head;
Description
Class

XHTMLDocument Class

Links
XHTMLDocument Class, ROHTML Namespace, XHTMLDocument Class


XHTMLDocument.Language Field

XHTMLDocument.Language Field
XHTMLDocument Class ROHTML Namespace XHTMLDocument Class

Short that indicates the language in which the document is written.

C#
public short Language;
Description
Class

XHTMLDocument Class

Links
XHTMLDocument Class, ROHTML Namespace, XHTMLDocument Class


XHTMLDocument.Name Field

XHTMLDocument.Name Field
XHTMLDocument Class ROHTML Namespace XHTMLDocument Class
C#
public string Name;
Class

XHTMLDocument Class

Links
XHTMLDocument Class, ROHTML Namespace, XHTMLDocument Class


XHTMLDocument.NumberedHeaders Field

XHTMLDocument.NumberedHeaders Field
XHTMLDocument Class ROHTML Namespace XHTMLDocument Class

Bool that indicates whether headers are numbered automatically by the document, e.g.

C#
public bool NumberedHeaders;
Description

1.1.1. Header.

Class

XHTMLDocument Class

Links
XHTMLDocument Class, ROHTML Namespace, XHTMLDocument Class


XHTMLDocument.Status Field

XHTMLDocument.Status Field
XHTMLDocument Class ROHTML Namespace XHTMLDocument Class

ROHTMLMessages indicates the status of the document, it is used in note header and footer.

C#
public ROHTMLMessages Status;
Description
Class

XHTMLDocument Class

Links
XHTMLDocument Class, ROHTML Namespace, XHTMLDocument Class


XHTMLDocument.Version Field

XHTMLDocument.Version Field
XHTMLDocument Class ROHTML Namespace XHTMLDocument Class

String (read-only) that indicates the version of the component, e.g.

C#
public string Version;
Description

"18.0.0.1887".

Class

XHTMLDocument Class

Links
XHTMLDocument Class, ROHTML Namespace, XHTMLDocument Class


XHTMLDocument.IsVersion Method

XHTMLDocument.IsVersion Method
XHTMLDocument Class ROHTML Namespace XHTMLDocument Class

Returns True if the version of the component is greater or equal to the given version, version should be formatted as follow: "MAJOR.MINOR.PATCH.COMPILATION", e.g.

C#
public void IsVersion(String version);
Parameters
Parameters | Description
version |
Description

"18.0.4.1887".

Class

XHTMLDocument Class

Links
XHTMLDocument Class, ROHTML Namespace, XHTMLDocument Class


XHTMLDocument.Save Method

XHTMLDocument.Save Method
XHTMLDocument Class ROHTML Namespace XHTMLDocument Class

Saves the XHTML document to the specified location.

C#
public void Save(String fileName);
Parameters
Parameters | Description
fileName |
Description
Class

XHTMLDocument Class

Links
XHTMLDocument Class, ROHTML Namespace, XHTMLDocument Class


XHTMLDocument.SaveAsSingleFile Method

XHTMLDocument.SaveAsSingleFile Method
XHTMLDocument Class ROHTML Namespace XHTMLDocument Class

Saves the document to the specified location as MS MHTML file.

C#
public void SaveAsSingleFile(String fileName);
Parameters
Parameters | Description
fileName |
Description
Class

XHTMLDocument Class

Links
XHTMLDocument Class, ROHTML Namespace, XHTMLDocument Class


XHTMLDocument.Show Method

XHTMLDocument.Show Method
XHTMLDocument Class ROHTML Namespace XHTMLDocument Class

Launches Internet Explorer and navigates to the specified file.

C#
public void Show(String fileName);
Description
Class

XHTMLDocument Class

Links
XHTMLDocument Class, ROHTML Namespace, XHTMLDocument Class


XHTMLDocument.ToString Method

XHTMLDocument.ToString Method
XHTMLDocument Class ROHTML Namespace XHTMLDocument Class

Returns String containing the generated document.

C#
public string ToString();
Description
Class

XHTMLDocument Class

Links
XHTMLDocument Class, ROHTML Namespace, XHTMLDocument Class


XHTMLElement Class

XHTMLElement Class
ROHTML Namespace Legend Members XHTMLElement Fields XHTMLElement Methods

This is class ROHTML.XHTMLElement.

Class Hierarchy
C#
public class XHTMLElement;
Namespace

ROHTML Namespace

XHTMLElement Fields
XHTMLElement Fields | Description
TagName | String containing the tag name of the element (may be empty).
XHTMLElement Methods
XHTMLElement Methods | Description
AddAttribute | Adds an HTML attribute and its value to the element.
AddBlockquote | Adds an element of type "blockquote" to the document and returns newly created XHTMLElement object.
AddElement | Adds an element of given name to the document and returns newly created XHTMLElement object.
AddHeader | Adds an element of type h1 through h6 (size=1 is the largest) to the document and returns newly created XHTMLElement object.
AddHorizontalRule | Inserts a horizontal rule ().
AddImage | Adds an image retrieved from resource (DLL or EXE) using protocol.
AddImageStd | Adds a standard image loaded from internal resources to the document.
AddLine | Writes the given text, followed by a newline character, to the document.
AddLineBreak | Inserts a single line break ().
AddMessage | Adds a decorated text to the document and returns newly created XHTMLElement object.
AddMessage2 | Adds a left text aligned text with right aligned note.
AddNoteFooter | Writes calculation note footer
AddNoteHeader | Writes calculation note header
AddParagraph | Adds an element of type "p" to the document and returns newly created XHTMLElement object.
AddPicture | Adds an image loaded from file.
AddSpan | Adds an element of type "span" to the document and returns newly created XHTMLElement object.
AddSubscript | Writes the given text to the document as a subscript.
AddSuperscript | Writes the given text to the document as a superscript.
AddSymbol | Writes the given text to the document using symbol (greek) font, e.g.
AddTable | Adds a table to the document and returns newly created XHTMLTable object
AddText | Writes the given text to the document.
AddText2 | Writes the given value name and its description to the document.
AddTextBold | Writes the given text to the document using a bold font.
AddUnit | Writes the given unit name to the document, adds braces if needed and moves all digits to uppercase, e.g mm2 -> [mm2].
AddValue | Writes the given value of any type, that can be converted to a string, to the document.
AddValue2 | Writes the given value of any type and it's name.
AddValue4 | Extended AddValue method (Similar to Verify, different order of parameters)
AddValue5 | Extended AddValue method
Verify | Similar to AddValue4 (different order of parameters),
Links
ROHTML Namespace, Legend, Members, XHTMLElement Fields, XHTMLElement Methods


XHTMLElement.TagName Field

XHTMLElement.TagName Field
XHTMLElement Class ROHTML Namespace XHTMLElement Class

String containing the tag name of the element (may be empty).

C#
public string TagName;
Description
Class

XHTMLElement Class

Links
XHTMLElement Class, ROHTML Namespace, XHTMLElement Class


XHTMLElement.AddAttribute Method

XHTMLElement.AddAttribute Method
XHTMLElement Class ROHTML Namespace XHTMLElement Class

Adds an HTML attribute and its value to the element.

C#
public void AddAttribute(String name, String value);
Parameters
Parameters | Description
name |
value |
Description
Class

XHTMLElement Class

Links
XHTMLElement Class, ROHTML Namespace, XHTMLElement Class


XHTMLElement.AddBlockquote Method

XHTMLElement.AddBlockquote Method
XHTMLElement Class ROHTML Namespace XHTMLElement Class

Adds an element of type "blockquote" to the document and returns newly created XHTMLElement object.

C#
public void AddBlockquote(String text);
Parameters
Parameters | Description
text |
Description

Writes the given text to the created element of the document

Class

XHTMLElement Class

Links
XHTMLElement Class, ROHTML Namespace, XHTMLElement Class


XHTMLElement.AddElement Method

XHTMLElement.AddElement Method
XHTMLElement Class ROHTML Namespace XHTMLElement Class

Adds an element of given name to the document and returns newly created XHTMLElement object.

C#
public void AddElement(String name);
Parameters
Parameters | Description
name |
Description
Class

XHTMLElement Class

Links
XHTMLElement Class, ROHTML Namespace, XHTMLElement Class


XHTMLElement.AddHeader Method

XHTMLElement.AddHeader Method
XHTMLElement Class ROHTML Namespace XHTMLElement Class

Adds an element of type h1 through h6 (size=1 is the largest) to the document and returns newly created XHTMLElement object.

C#
public void AddHeader(Short size, String text);
Parameters
Parameters | Description
size |
text |
Description

Writes the given text to the created element of the document.

Class

XHTMLElement Class

Links
XHTMLElement Class, ROHTML Namespace, XHTMLElement Class


XHTMLElement.AddHorizontalRule Method

XHTMLElement.AddHorizontalRule Method
XHTMLElement Class ROHTML Namespace XHTMLElement Class

Inserts a horizontal rule ().

C#
public void AddHorizontalRule();
Description
Class

XHTMLElement Class

Links
XHTMLElement Class, ROHTML Namespace, XHTMLElement Class


XHTMLElement.AddImage Method

XHTMLElement.AddImage Method
XHTMLElement Class ROHTML Namespace XHTMLElement Class

Adds an image retrieved from resource (DLL or EXE) using protocol.

C#
public void AddImage(String dllName, Long number);
Parameters
Parameters | Description
dllName |
number |
Description
Class

XHTMLElement Class

Links
XHTMLElement Class, ROHTML Namespace, XHTMLElement Class


XHTMLElement.AddImageStd Method

XHTMLElement.AddImageStd Method
XHTMLElement Class ROHTML Namespace XHTMLElement Class

Adds a standard image loaded from internal resources to the document.

C#
public void AddImageStd(ROHTMLStdImages image);
Parameters
Parameters | Description
image |
Description

See ROHTMLStdImages constants description.

Class

XHTMLElement Class

Links
XHTMLElement Class, ROHTML Namespace, XHTMLElement Class


XHTMLElement.AddLine Method

XHTMLElement.AddLine Method
XHTMLElement Class ROHTML Namespace XHTMLElement Class

Writes the given text, followed by a newline character, to the document.

C#
public void AddLine(String text);
Parameters
Parameters | Description
text |
Description
Class

XHTMLElement Class

Links
XHTMLElement Class, ROHTML Namespace, XHTMLElement Class


XHTMLElement.AddLineBreak Method

XHTMLElement.AddLineBreak Method
XHTMLElement Class ROHTML Namespace XHTMLElement Class

Inserts a single line break ().

C#
public void AddLineBreak();
Description
Class

XHTMLElement Class

Links
XHTMLElement Class, ROHTML Namespace, XHTMLElement Class


XHTMLElement.AddMessage Method

XHTMLElement.AddMessage Method
XHTMLElement Class ROHTML Namespace XHTMLElement Class

Adds a decorated text to the document and returns newly created XHTMLElement object.

C#
public void AddMessage(String text, ROHTMLMessages type);
Parameters
Parameters | Description
text |
type |
Description

See ROHTMLMessages to preview available formats.

Class

XHTMLElement Class

Links
XHTMLElement Class, ROHTML Namespace, XHTMLElement Class


XHTMLElement.AddMessage2 Method

XHTMLElement.AddMessage2 Method
XHTMLElement Class ROHTML Namespace XHTMLElement Class

Adds a left text aligned text with right aligned note.

C#
public void AddMessage2(String text, String note);
Parameters
Parameters | Description
text |
note |
Description
Class

XHTMLElement Class

Links
XHTMLElement Class, ROHTML Namespace, XHTMLElement Class


XHTMLElement.AddNoteFooter Method

XHTMLElement.AddNoteFooter Method
XHTMLElement Class ROHTML Namespace XHTMLElement Class

Writes calculation note footer

C#
public void AddNoteFooter(String message, String name, Variant value);
Parameters
Parameters | Description
message |
name |
value |
Class

XHTMLElement Class

Links
XHTMLElement Class, ROHTML Namespace, XHTMLElement Class


XHTMLElement.AddNoteHeader Method

XHTMLElement.AddNoteHeader Method
XHTMLElement Class ROHTML Namespace XHTMLElement Class

Writes calculation note header

C#
public void AddNoteHeader(String title, String subtitle, String code, String dllName, Long number);
Parameters
Parameters | Description
title |
subtitle |
code |
dllName |
number |
Class

XHTMLElement Class

Links
XHTMLElement Class, ROHTML Namespace, XHTMLElement Class


XHTMLElement.AddParagraph Method

XHTMLElement.AddParagraph Method
XHTMLElement Class ROHTML Namespace XHTMLElement Class

Adds an element of type "p" to the document and returns newly created XHTMLElement object.

C#
public void AddParagraph(String text);
Parameters
Parameters | Description
text |
Description

Writes the given text to the created element of the document.

Class

XHTMLElement Class

Links
XHTMLElement Class, ROHTML Namespace, XHTMLElement Class


XHTMLElement.AddPicture Method

XHTMLElement.AddPicture Method
XHTMLElement Class ROHTML Namespace XHTMLElement Class

Adds an image loaded from file.

C#
public void AddPicture(String file);
Parameters
Parameters | Description
file |
Description
Class

XHTMLElement Class

Links
XHTMLElement Class, ROHTML Namespace, XHTMLElement Class


XHTMLElement.AddSpan Method

XHTMLElement.AddSpan Method
XHTMLElement Class ROHTML Namespace XHTMLElement Class

Adds an element of type "span" to the document and returns newly created XHTMLElement object.

C#
public void AddSpan(String text);
Parameters
Parameters | Description
text |
Description

Writes the given text to the created element of the document.

Class

XHTMLElement Class

Links
XHTMLElement Class, ROHTML Namespace, XHTMLElement Class


XHTMLElement.AddSubscript Method

XHTMLElement.AddSubscript Method
XHTMLElement Class ROHTML Namespace XHTMLElement Class

Writes the given text to the document as a subscript.

C#
public void AddSubscript(String text);
Parameters
Parameters | Description
text |
Description
Class

XHTMLElement Class

Links
XHTMLElement Class, ROHTML Namespace, XHTMLElement Class


XHTMLElement.AddSuperscript Method

XHTMLElement.AddSuperscript Method
XHTMLElement Class ROHTML Namespace XHTMLElement Class

Writes the given text to the document as a superscript.

C#
public void AddSuperscript(String text);
Parameters
Parameters | Description
text |
Description
Class

XHTMLElement Class

Links
XHTMLElement Class, ROHTML Namespace, XHTMLElement Class


XHTMLElement.AddSymbol Method

XHTMLElement.AddSymbol Method
XHTMLElement Class ROHTML Namespace XHTMLElement Class

Writes the given text to the document using symbol (greek) font, e.g.

C#
public void AddSymbol(String text);
Parameters
Parameters | Description
text |
Description

abcdefg.

Class

XHTMLElement Class

Links
XHTMLElement Class, ROHTML Namespace, XHTMLElement Class


XHTMLElement.AddTable Method

XHTMLElement.AddTable Method
XHTMLElement Class ROHTML Namespace XHTMLElement Class

Adds a table to the document and returns newly created XHTMLTable object

C#
public void AddTable();
Class

XHTMLElement Class

Links
XHTMLElement Class, ROHTML Namespace, XHTMLElement Class


XHTMLElement.AddText Method

XHTMLElement.AddText Method
XHTMLElement Class ROHTML Namespace XHTMLElement Class

Writes the given text to the document.

C#
public void AddText(String text);
Parameters
Parameters | Description
text |
Description
Class

XHTMLElement Class

Links
XHTMLElement Class, ROHTML Namespace, XHTMLElement Class


XHTMLElement.AddText2 Method

XHTMLElement.AddText2 Method
XHTMLElement Class ROHTML Namespace XHTMLElement Class

Writes the given value name and its description to the document.

C#
public void AddText2(String name, String description);
Parameters
Parameters | Description
name |
description |
Description
Class

XHTMLElement Class

Links
XHTMLElement Class, ROHTML Namespace, XHTMLElement Class


XHTMLElement.AddTextBold Method

XHTMLElement.AddTextBold Method
XHTMLElement Class ROHTML Namespace XHTMLElement Class

Writes the given text to the document using a bold font.

C#
public void AddTextBold(String text);
Parameters
Parameters | Description
text |
Description
Class

XHTMLElement Class

Links
XHTMLElement Class, ROHTML Namespace, XHTMLElement Class


XHTMLElement.AddUnit Method

XHTMLElement.AddUnit Method
XHTMLElement Class ROHTML Namespace XHTMLElement Class

Writes the given unit name to the document, adds braces if needed and moves all digits to uppercase, e.g mm2 -> [mm2].

C#
public void AddUnit(String unit);
Parameters
Parameters | Description
unit |
Description
Class

XHTMLElement Class

Links
XHTMLElement Class, ROHTML Namespace, XHTMLElement Class


XHTMLElement.AddValue Method

XHTMLElement.AddValue Method
XHTMLElement Class ROHTML Namespace XHTMLElement Class

Writes the given value of any type, that can be converted to a string, to the document.

C#
public void AddValue(Variant value);
Parameters
Parameters | Description
value |
Description

Usually useful with integer values. Text will be written using monospace font.

Class

XHTMLElement Class

Links
XHTMLElement Class, ROHTML Namespace, XHTMLElement Class


XHTMLElement.AddValue2 Method

XHTMLElement.AddValue2 Method
XHTMLElement Class ROHTML Namespace XHTMLElement Class

Writes the given value of any type and it's name.

C#
public void AddValue2(String name, Variant value);
Parameters
Parameters | Description
name |
value |
Description

Value will be written using monospace font. Name can contain subscripts in braces, e.g. name="B{1}" will be rendered as B1

Class

XHTMLElement Class

Links
XHTMLElement Class, ROHTML Namespace, XHTMLElement Class


XHTMLElement.AddValue4 Method

XHTMLElement.AddValue4 Method
XHTMLElement Class ROHTML Namespace XHTMLElement Class

Extended AddValue method (Similar to Verify, different order of parameters)

C#
public void AddValue4(String name, String condition, String message, ROHTMLMessages type, Variant value);
Parameters
Parameters | Description
name |
condition |
message |
type |
value |
Class

XHTMLElement Class

Links
XHTMLElement Class, ROHTML Namespace, XHTMLElement Class


XHTMLElement.AddValue5 Method

XHTMLElement.AddValue5 Method
XHTMLElement Class ROHTML Namespace XHTMLElement Class

Extended AddValue method

C#
public void AddValue5(String name, Variant value, String unit, String description, String note);
Parameters
Parameters | Description
name |
value |
unit |
description |
note |
Class

XHTMLElement Class

Links
XHTMLElement Class, ROHTML Namespace, XHTMLElement Class


XHTMLElement.Verify Method

XHTMLElement.Verify Method
XHTMLElement Class ROHTML Namespace XHTMLElement Class

Similar to AddValue4 (different order of parameters),

C#
public void Verify(String name, String condition, String message, Variant value, ROHTMLMessages type);
Parameters
Parameters | Description
name |
condition |
message |
value |
type |
Class

XHTMLElement Class

Links
XHTMLElement Class, ROHTML Namespace, XHTMLElement Class


XHTMLTable Class

XHTMLTable Class
ROHTML Namespace Legend Members XHTMLTable Fields XHTMLTable Methods

This is class ROHTML.XHTMLTable.

Class Hierarchy
C#
public class XHTMLTable;
Namespace

ROHTML Namespace

XHTMLTable Fields
XHTMLTable Fields | Description
Border | Short Border width in pixels.
Columns | Long Number of columns in the table.
FooterRows | Long Number of footer rows.
HeaderColumns | Long Number of header columns.
HeaderRows | Long Number of header rows.
Rows | Long Number of rows in the table (including header rows).
Width | Sets or gets the overall table width, default: "Auto".
XHTMLTable Methods
XHTMLTable Methods | Description
AddAttribute | Adds an HTML attribute and its value to the entire table.
AddColumnAttribute | Adds an HTML attribute and its value to the specified column.
AddRow | Adds one row to the table.
AutoFormat | Initializes a couple of table properties according to given predefined format.
Cell | XHTMLElement that represents the cell of the table.
ColumnWidth | String Sets or gets the column width of the desired column, e.g.
Links
ROHTML Namespace, Legend, Members, XHTMLTable Fields, XHTMLTable Methods


XHTMLTable.Border Field

XHTMLTable.Border Field
XHTMLTable Class ROHTML Namespace XHTMLTable Class

Short Border width in pixels.

C#
public short Border;
Description

0 indicates no border.

Class

XHTMLTable Class

Links
XHTMLTable Class, ROHTML Namespace, XHTMLTable Class


XHTMLTable.Columns Field

XHTMLTable.Columns Field
XHTMLTable Class ROHTML Namespace XHTMLTable Class

Long Number of columns in the table.

C#
public long Columns;
Parameters
Parameters | Description
nColumn |
Description
Class

XHTMLTable Class

Links
XHTMLTable Class, ROHTML Namespace, XHTMLTable Class


XHTMLTable.FooterRows Field

XHTMLTable.FooterRows Field
XHTMLTable Class ROHTML Namespace XHTMLTable Class

Long Number of footer rows.

C#
public long FooterRows;
Description
Class

XHTMLTable Class

Links
XHTMLTable Class, ROHTML Namespace, XHTMLTable Class


XHTMLTable.HeaderColumns Field

XHTMLTable.HeaderColumns Field
XHTMLTable Class ROHTML Namespace XHTMLTable Class

Long Number of header columns.

C#
public long HeaderColumns;
Description
Class

XHTMLTable Class

Links
XHTMLTable Class, ROHTML Namespace, XHTMLTable Class


XHTMLTable.HeaderRows Field

XHTMLTable.HeaderRows Field
XHTMLTable Class ROHTML Namespace XHTMLTable Class

Long Number of header rows.

C#
public long HeaderRows;
Description
Class

XHTMLTable Class

Links
XHTMLTable Class, ROHTML Namespace, XHTMLTable Class


XHTMLTable.Rows Field

XHTMLTable.Rows Field
XHTMLTable Class ROHTML Namespace XHTMLTable Class

Long Number of rows in the table (including header rows).

C#
public long Rows;
Description
Class

XHTMLTable Class

Links
XHTMLTable Class, ROHTML Namespace, XHTMLTable Class


XHTMLTable.Width Field

XHTMLTable.Width Field
XHTMLTable Class ROHTML Namespace XHTMLTable Class

Sets or gets the overall table width, default: "Auto".

C#
public string Width;
Description
Class

XHTMLTable Class

Links
XHTMLTable Class, ROHTML Namespace, XHTMLTable Class


XHTMLTable.AddAttribute Method

XHTMLTable.AddAttribute Method
XHTMLTable Class ROHTML Namespace XHTMLTable Class

Adds an HTML attribute and its value to the entire table.

C#
public void AddAttribute(String name, String value);
Parameters
Parameters | Description
name |
value |
Description
Class

XHTMLTable Class

Links
XHTMLTable Class, ROHTML Namespace, XHTMLTable Class


XHTMLTable.AddColumnAttribute Method

XHTMLTable.AddColumnAttribute Method
XHTMLTable Class ROHTML Namespace XHTMLTable Class

Adds an HTML attribute and its value to the specified column.

C#
public void AddColumnAttribute(Long nColumn, String name, String value);
Description
Class

XHTMLTable Class

Links
XHTMLTable Class, ROHTML Namespace, XHTMLTable Class


XHTMLTable.AddRow Method

XHTMLTable.AddRow Method
XHTMLTable Class ROHTML Namespace XHTMLTable Class

Adds one row to the table.

C#
public void AddRow();
Parameters
Parameters | Description
format |
Description
Class

XHTMLTable Class

Links
XHTMLTable Class, ROHTML Namespace, XHTMLTable Class


XHTMLTable.AutoFormat Method

XHTMLTable.AutoFormat Method
XHTMLTable Class ROHTML Namespace XHTMLTable Class

Initializes a couple of table properties according to given predefined format.

C#
public void AutoFormat(ROHTMLTableFormats format);
Parameters
Parameters | Description
format |
Description

See ROHTMLTableFormats to preview available formats.

Class

XHTMLTable Class

Links
XHTMLTable Class, ROHTML Namespace, XHTMLTable Class


XHTMLTable.Cell Method

XHTMLTable.Cell Method
XHTMLTable Class ROHTML Namespace XHTMLTable Class

XHTMLElement that represents the cell of the table.

C#
public XHTMLElement Cell(Long nRow, Long nColumn);
Parameters
Parameters | Description
nRow |
nColumn |
Description
Class

XHTMLTable Class

Links
XHTMLTable Class, ROHTML Namespace, XHTMLTable Class


XHTMLTable.ColumnWidth Method

Previous | Up
XHTMLTable.ColumnWidth Method
XHTMLTable Class ROHTML Namespace XHTMLTable Class

String Sets or gets the column width of the desired column, e.g.

C#
public string ColumnWidth(Long nColumn);
Description

"40%".

Class

XHTMLTable Class

Links
XHTMLTable Class, ROHTML Namespace, XHTMLTable Class


REX.Common Namespace Classes

REX.Common Namespace Classes
REX.Common Namespace Legend
Classes
Class | Description
REXAccess | The class dedicated to settings data from parent application.
REXApplication | Base class for Application.This object controls the lifetime of the extensions.
REXDFM | Manages UI controls registered in it.
REXDirectAccess | Base class for main DirectAccess class.
REXDirectRevitAccess | Base class for main DirectAccess class.
REXDirectRevitExecute | This is class REX.Common.REXDirectRevitExecute.
REXErrors | Supprots REX errors for logging system.
REXExtension | Additional functionality of REXExtension class.
REXExtensionContext | Internal class for controlling behavior of the extension.
REXExtensionControl | Base class for user controls.
REXExtensionData | Base class for REXData and REXResults classes.
REXExtensionDataSerializable | Base class for REXDataSerializable and REXResultsSerializable classes.
REXExtensionMainControl | Base class for main control.
REXExtensionObject | Base class for all objects created in extension module.
REXExtensionPanel | Base class for panel control.
REXExtensionProduct | Represents the Extension element used by the main Extension class to separate product dependent part of the code from general one.
REXExtensionSettings | Allows reading base settings from "Configuration / settings.xml" file.
REXExtensionWindow | Base class for user forms.
REXFoundationApplication | Foundation class for REX.Foundation usage.
REXLayout |
REXLayoutItem | Represents all layout of main control.
REXLogger | This is class REX.Common.REXLogger.
REXResults | Base class for results.
REXRevitAccess | The class dedicated to settings data from Revit.
REXRevitContextAccess | Allaws for access to Revit's objects.
REXUI | Main class which provides access to all data connected with main control.
REXVersion | Foundation class for REX.Foundation usage.
REXWarnings | This is class REX.Common.REXWarnings.
REXWebBrowser | Proxy class for web browser control.


Classes (AutoDoc Folder)

Legend
Legend
Class
abstract
static


REX.Common Namespace Interfaces

REX.Common Namespace Interfaces
REX.Common Namespace Legend
Interfaces
Interface | Description
IREXConnector | This is class REX.Common.IREXConnector.
IREXExtension | Main interface for extension module.
IREXExtension2 | Main interface for extension module.
IREXExtension3 | Main interface for extension module.
IREXExtension4 | Main interface for extension module.
IREXExtensionAccess | Main interface for REXAccess class.
IREXExtensionAccess2 | Main interface for REXAccess class.
IREXExtensionAccess3 | Main interface for REXAccess class.
IREXExtensionAccessUnitsControl | Main interface for REXAccess class.
IREXThisExtension | Base interface for access to main extension's objects.


Interfaces (AutoDoc Folder)

Legend
Legend
Interface
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


Legend

Legend
REX.Common Namespace
Legend
Class
abstract
static
Interface
Enumeration
Structure
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REX.Common Namespace Structs, Records, Enums

REX.Common Namespace Structs, Records, Enums
REX.Common Namespace Legend
Structs, Records, Enums
Struct, Record, Enum | Description
REXCanCloseType | Determines closing mode.
REXSetFormStruct | This is record REX.Common.REXSetFormStruct.


Structs, Records, Enums (AutoDoc Folder)

Legend
Legend
Enumeration
Structure
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


Legend

Legend
IREXConnector Interface
Legend
Method
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


IREXConnector Interface Members

IREXConnector Interface Members
IREXConnector Interface Legend
Members
IREXConnector Methods
IREXConnector Methods | Description
Connect | This is Connect, a member of class IREXConnector.
VerifyVersion | This is VerifyVersion, a member of class IREXConnector.
VerifyVersion | This is VerifyVersion, a member of class IREXConnector.
IREXConnector Properties
IREXConnector Properties | Description
Connected | This is Connected, a member of class IREXConnector.
Installed | This is Installed, a member of class IREXConnector.
IsCOMObject | This is IsCOMObject, a member of class IREXConnector.


Members

Legend
Legend
Method
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


IREXConnector Methods

IREXConnector Methods
IREXConnector Interface Legend
IREXConnector Methods
IREXConnector Methods | Description
Connect | This is Connect, a member of class IREXConnector.
VerifyVersion | This is VerifyVersion, a member of class IREXConnector.
VerifyVersion | This is VerifyVersion, a member of class IREXConnector.


Methods (AutoDoc Folder)

Legend
Legend
Method
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


IREXConnector Properties

IREXConnector Properties
IREXConnector Interface Legend
IREXConnector Properties
IREXConnector Properties | Description
Connected | This is Connected, a member of class IREXConnector.
Installed | This is Installed, a member of class IREXConnector.
IsCOMObject | This is IsCOMObject, a member of class IREXConnector.


Properties (AutoDoc Folder)

Legend
Legend
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


Legend

Legend
IREXExtension2 Interface
Legend
Method
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


IREXExtension2 Interface Members

IREXExtension2 Interface Members
IREXExtension2 Interface Legend
Members
IREXExtension2 Methods
IREXExtension2 Methods | Description
OnCanActivateLayout | Ask for activation - module can modify layout before or after activation.
OnGetExtensionName | Called when get extension name.
OnRegionalSettingsChanged | Called when regional settings changed.


Members

Legend
Legend
Method
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


IREXExtension2 Methods

IREXExtension2 Methods
IREXExtension2 Interface Legend
IREXExtension2 Methods
IREXExtension2 Methods | Description
OnCanActivateLayout | Ask for activation - module can modify layout before or after activation.
OnGetExtensionName | Called when get extension name.
OnRegionalSettingsChanged | Called when regional settings changed.


Legend

Legend
IREXExtension3 Interface
Legend
Method
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


IREXExtension3 Interface Members

IREXExtension3 Interface Members
IREXExtension3 Interface Legend
Members
IREXExtension3 Methods
IREXExtension3 Methods | Description
OnSetContext | Called when regional settings changed.


IREXExtension3 Methods

IREXExtension3 Methods
IREXExtension3 Interface Legend
IREXExtension3 Methods
IREXExtension3 Methods | Description
OnSetContext | Called when regional settings changed.


Legend

Legend
IREXExtension4 Interface
Legend
Method
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


IREXExtension4 Interface Members

IREXExtension4 Interface Members
IREXExtension4 Interface Legend
Members
IREXExtension4 Methods
IREXExtension4 Methods | Description
OnCheckValidity | Called when check validity.


IREXExtension4 Methods

IREXExtension4 Methods
IREXExtension4 Interface Legend
IREXExtension4 Methods
IREXExtension4 Methods | Description
OnCheckValidity | Called when check validity.


Legend

Legend
IREXExtension Interface
Legend
Method
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


IREXExtension Interface Members

IREXExtension Interface Members
IREXExtension Interface Legend
Members
IREXExtension Methods
IREXExtension Methods | Description
OnActivateLayout | Activates or deactivates layout - module can modify layout before or after activation.
OnCanClose | If returns true, dialog will close after OK button clicked.
OnCanClose | Called when closing module.
OnCanRun | Checks status of module and shows some information for user if modult can't run action.
OnClear | Called when clear data.
OnClose | Called during closing module.
OnCommand | Called when command.
OnCreate | Creates needed structures and verify needs.
OnCreateDialogs | Creates sub dialogs.
OnCreateLayout | Creates layout items and setups layout.
OnDataLoad | Called when data are loaded.
OnDataLoaded | Called when data are loaded.
OnDataSave | Called when data are saved.
OnDataSaved | Called when data are saved.
OnErrorSelected | Called when error selected on errors list dialog.
OnEvent | Called when event.
OnGetText | Get specified text from resources.
OnInitialize | Called when initialize.
OnLoadTemplate | Called when load template.
OnPreferencesChanged | Called when preferences changed.
OnRun | Run process calculations or other operations.
OnSaveTemplate | Called when save template.
OnSetData | Get data from dialogs and sets Data's strucutres.
OnSetDialogs | Set data in dialogs.
OnShowResults | Shows results.
OnUpdateDialogs | Called when update dialogs.


IREXExtension Methods

IREXExtension Methods
IREXExtension Interface Legend
IREXExtension Methods
IREXExtension Methods | Description
OnActivateLayout | Activates or deactivates layout - module can modify layout before or after activation.
OnCanClose | If returns true, dialog will close after OK button clicked.
OnCanClose | Called when closing module.
OnCanRun | Checks status of module and shows some information for user if modult can't run action.
OnClear | Called when clear data.
OnClose | Called during closing module.
OnCommand | Called when command.
OnCreate | Creates needed structures and verify needs.
OnCreateDialogs | Creates sub dialogs.
OnCreateLayout | Creates layout items and setups layout.
OnDataLoad | Called when data are loaded.
OnDataLoaded | Called when data are loaded.
OnDataSave | Called when data are saved.
OnDataSaved | Called when data are saved.
OnErrorSelected | Called when error selected on errors list dialog.
OnEvent | Called when event.
OnGetText | Get specified text from resources.
OnInitialize | Called when initialize.
OnLoadTemplate | Called when load template.
OnPreferencesChanged | Called when preferences changed.
OnRun | Run process calculations or other operations.
OnSaveTemplate | Called when save template.
OnSetData | Get data from dialogs and sets Data's strucutres.
OnSetDialogs | Set data in dialogs.
OnShowResults | Shows results.
OnUpdateDialogs | Called when update dialogs.


Legend

Legend
IREXExtensionAccess2 Interface
Legend
Method
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


IREXExtensionAccess2 Interface Members

IREXExtensionAccess2 Interface Members
IREXExtensionAccess2 Interface Legend
Members
IREXExtensionAccess2 Methods
IREXExtensionAccess2 Methods | Description
Event | Events the specified ev.


IREXExtensionAccess2 Methods

IREXExtensionAccess2 Methods
IREXExtensionAccess2 Interface Legend
IREXExtensionAccess2 Methods
IREXExtensionAccess2 Methods | Description
Event | Events the specified ev.


Legend

Legend
IREXExtensionAccess3 Interface
Legend
Method
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


IREXExtensionAccess3 Interface Members

IREXExtensionAccess3 Interface Members
IREXExtensionAccess3 Interface Legend
Members
IREXExtensionAccess3 Methods
IREXExtensionAccess3 Methods | Description
Detach | Detaches this instance.


IREXExtensionAccess3 Methods

IREXExtensionAccess3 Methods
IREXExtensionAccess3 Interface Legend
IREXExtensionAccess3 Methods
IREXExtensionAccess3 Methods | Description
Detach | Detaches this instance.


Legend

Legend
IREXExtensionAccess Interface
Legend
Method
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


IREXExtensionAccess Interface Members

IREXExtensionAccess Interface Members
IREXExtensionAccess Interface Legend
Members
IREXExtensionAccess Methods
IREXExtensionAccess Methods | Description
Create | Reads some data from parent application and set system display units.
Destroy | Destroys and resets some objects connected to parent application.
Initialize | Initializes this instance.
Update | Reads some data from parent application and set system display units.


IREXExtensionAccess Methods

IREXExtensionAccess Methods
IREXExtensionAccess Interface Legend
IREXExtensionAccess Methods
IREXExtensionAccess Methods | Description
Create | Reads some data from parent application and set system display units.
Destroy | Destroys and resets some objects connected to parent application.
Initialize | Initializes this instance.
Update | Reads some data from parent application and set system display units.


Legend

Legend
IREXExtensionAccessUnitsControl Interface
Legend
Method
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


IREXExtensionAccessUnitsControl Interface Members

IREXExtensionAccessUnitsControl Interface Members
IREXExtensionAccessUnitsControl Interface Legend
Members
IREXExtensionAccessUnitsControl Methods
IREXExtensionAccessUnitsControl Methods | Description
Setup | Setups this instance.
Update | Updates this instance.


IREXExtensionAccessUnitsControl Methods

IREXExtensionAccessUnitsControl Methods
IREXExtensionAccessUnitsControl Interface Legend
IREXExtensionAccessUnitsControl Methods
IREXExtensionAccessUnitsControl Methods | Description
Setup | Setups this instance.
Update | Updates this instance.


Legend

Legend
IREXThisExtension Interface
Legend
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


IREXThisExtension Interface Members

IREXThisExtension Interface Members
IREXThisExtension Interface Legend
Members
IREXThisExtension Properties
IREXThisExtension Properties | Description
ThisApplication | This is ThisApplication, a member of class IREXThisExtension.
ThisContext | This is ThisContext, a member of class IREXThisExtension.
ThisExtension | This is ThisExtension, a member of class IREXThisExtension.


Members

Legend
Legend
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


IREXThisExtension Properties

IREXThisExtension Properties
IREXThisExtension Interface Legend
IREXThisExtension Properties
IREXThisExtension Properties | Description
ThisApplication | This is ThisApplication, a member of class IREXThisExtension.
ThisContext | This is ThisContext, a member of class IREXThisExtension.
ThisExtension | This is ThisExtension, a member of class IREXThisExtension.


REX.Common.Revit.Units Namespace Classes

REX.Common.Revit.Units Namespace Classes
REX.Common.Revit.Units Namespace Legend
Classes
Class | Description
REXUnitsControl | Display units management class for Revit context.


Classes (AutoDoc Folder)

Legend
Legend
Class
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


Legend

Legend
REX.Common.Revit.Units Namespace
Legend
Class
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


Legend

Legend
REXUnitsControl Class
Legend
Constructor
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXUnitsControl Class Members

REXUnitsControl Class Members
REXUnitsControl Class Legend
Members
Public Methods
Public Method | Description
REXUnitsControl | Initializes a new instance of the REXUnitsControl class.
REXUnitsControl Methods
REXUnitsControl Methods | Description
Setup | Setups display units.
Update | Updates display units.


Members

Legend
Legend
Constructor
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXUnitsControl Methods

REXUnitsControl Methods
REXUnitsControl Class Legend
REXUnitsControl Methods
REXUnitsControl Methods | Description
Setup | Setups display units.
Update | Updates display units.


REXUnitsControl Class Public Methods

REXUnitsControl Class Public Methods
REXUnitsControl Class Legend
Public Methods
Public Method | Description
REXUnitsControl | Initializes a new instance of the REXUnitsControl class.


Public Methods

Legend
Legend
Constructor
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


See Also

See Also
REXUnitsControl.Update Method
See Also

Setup()


REXAccess Enumerations

REXAccess Enumerations
REXAccess Class Legend
REXAccess Enumerations
REXAccess Enumerations | Description
REXAccessEvent |


Enumerations (AutoDoc Folder)

Legend
Legend
Enumeration
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


Legend

Legend
REXAccess Class
Legend
Constructor
Enumeration
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXAccess Class Members

REXAccess Class Members
REXAccess Class Legend
Members
Public Methods
Public Method | Description
REXAccess | Initializes a new instance of the REXAccess class.
REXAccess Enumerations
REXAccess Enumerations | Description
REXAccessEvent |
REXAccess Methods
REXAccess Methods | Description
Access | This is Access, a member of class REXAccess.
Create | Reads some data from parent application and set system display units.
Destroy | Destroys and reset some objects connected to parent application.
Detach | Detaches this instance.
Event | Events the specified event.
Initialize | Initializes this instance.
Update | Reads some data from parent application and set system display units.
REXAccess Properties
REXAccess Properties | Description
Interfaces | This is Interfaces, a member of class REXAccess.


Members

Legend
Legend
Constructor
Enumeration
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXAccess Methods

REXAccess Methods
REXAccess Class Legend
REXAccess Methods
REXAccess Methods | Description
Access | This is Access, a member of class REXAccess.
Create | Reads some data from parent application and set system display units.
Destroy | Destroys and reset some objects connected to parent application.
Detach | Detaches this instance.
Event | Events the specified event.
Initialize | Initializes this instance.
Update | Reads some data from parent application and set system display units.


REXAccess Properties

REXAccess Properties
REXAccess Class Legend
REXAccess Properties
REXAccess Properties | Description
Interfaces | This is Interfaces, a member of class REXAccess.


REXAccess Class Public Methods

REXAccess Class Public Methods
REXAccess Class Legend
Public Methods
Public Method | Description
REXAccess | Initializes a new instance of the REXAccess class.


Legend

Legend
REXApplication Class
Legend
Constructor
virtual
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXApplication Class Members

REXApplication Class Members
REXApplication Class Legend
Members
Public Methods
Public Method | Description
REXApplication | Initializes a new instance of a REXApplication class.
REXApplication Methods
REXApplication Methods | Description
CheckValidity | Checks the date limit.
Close | Closes this instance.
Command | Called when command.
Control | Get main control for embeding in a application form.
Create | Create module.
Create | Create module.
Event | Called when event.
GetExtension | Get the extension.
GetService | This is GetService, a member of class REXApplication.
GetText | Gets the text.
GetUniqueId | This is GetUniqueId, a member of class REXApplication.
GetVersion | Gets the minimum required version of specified engine's component.
Modal | Creates and shows module as modal dialog.
Modal | Creates and shows module as a modal dialog.
OnCreate | Called when create application object.
RestoreCultureInfo | Restores the culture info.
Show | Shows this module.
REXApplication Properties
REXApplication Properties | Description
Context | Get the reference to the old context.
Context2 | Get the context2.
ContextProduct | Get the context product from the old context structure.
ContextProduct2 | Get the context product2.
ThisApplication | This is ThisApplication, a member of class REXApplication.
ThisContext | This is ThisContext, a member of class REXApplication.
ThisExtension | This is ThisExtension, a member of class REXApplication.
Visible | Get or set a value indicating whether this REXApplication is visible.


Members

Legend
Legend
Constructor
virtual
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXApplication Methods

REXApplication Methods
REXApplication Class Legend
REXApplication Methods
REXApplication Methods | Description
CheckValidity | Checks the date limit.
Close | Closes this instance.
Command | Called when command.
Control | Get main control for embeding in a application form.
Create | Create module.
Create | Create module.
Event | Called when event.
GetExtension | Get the extension.
GetService | This is GetService, a member of class REXApplication.
GetText | Gets the text.
GetUniqueId | This is GetUniqueId, a member of class REXApplication.
GetVersion | Gets the minimum required version of specified engine's component.
Modal | Creates and shows module as modal dialog.
Modal | Creates and shows module as a modal dialog.
OnCreate | Called when create application object.
RestoreCultureInfo | Restores the culture info.
Show | Shows this module.


Methods (AutoDoc Folder)

Legend
Legend
Method
virtual


REXApplication Properties

REXApplication Properties
REXApplication Class Legend
REXApplication Properties
REXApplication Properties | Description
Context | Get the reference to the old context.
Context2 | Get the context2.
ContextProduct | Get the context product from the old context structure.
ContextProduct2 | Get the context product2.
ThisApplication | This is ThisApplication, a member of class REXApplication.
ThisContext | This is ThisContext, a member of class REXApplication.
ThisExtension | This is ThisExtension, a member of class REXApplication.
Visible | Get or set a value indicating whether this REXApplication is visible.


Properties (AutoDoc Folder)

Legend
Legend
Property
virtual


REXApplication Class Public Methods

REXApplication Class Public Methods
REXApplication Class Legend
Public Methods
Public Method | Description
REXApplication | Initializes a new instance of a REXApplication class.


REXDFM Classes

REXDFM Classes
REXDFM Class Legend
REXDFM Classes
REXDFM Classes | Description
DisplayDefinition | Represents the display settings of the specified unit category.


REXDFM Delegates

REXDFM Delegates
REXDFM Class
REXDFM Delegates
REXDFM Delegates | Description
EventHandlerChange | Delegate to the event handler changes.
EventHandlerLost | Delegate to the event handler lost focus.


REXDFM Events

REXDFM Events
REXDFM Class Legend
REXDFM Events
REXDFM Events | Description
ControlUnitObjectError | Raises when data is changed on Control and some error was occur.
ControlUnitObjectLostFocus | Raises when Control losts focus.
ControlUnitObjectOk | Raises when data is changed on Control and no errors.


Events (AutoDoc Folder)

Legend
Legend
Event
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


Legend

Legend
REXDFM Class
Legend
Constructor
Class
Property
Event
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXDFM Class Members

REXDFM Class Members
REXDFM Class Legend
Members
Public Methods
Public Method | Description
REXDFM | Initializes a new instance of the REXDFM class.
REXDFM | Initializes a new instance of the REXDFM class.
REXDFM | Initializes a new instance of the REXDFM class.
REXDFM Classes
REXDFM Classes | Description
DisplayDefinition | Represents the display settings of the specified unit category.
REXDFM Methods
REXDFM Methods | Description
AddDisplayUnitObject | Registers an object which implements the IUnitObject interface.
AddDisplayUnitObject | Registers an object which implements the IUnitObject interface.
AddDisplayUnitObject | Registers an object which implements the IUnitObject interface.
AddDisplayUnitObject | Registers an object which implements the IUnitObject interface.
AddUnitObject | Registers an object which implements the IUnitObject interface.
AddUnitObject | Registers an object which implements the IUnitObject interface.
AddUnitObject | Registers an object which implements the IUnitObject interface.
AddUnitObject | Registers an object which implements the IUnitObject interface.
AfterParamsChange | Method called after parameters change.
BeforeParamsChange | Method called before parameters change.
Clear | Clears this instance.
CreateGroupControl | Creates the group of controls from collection of controls and all childrenss.
CreateGroupControl | Creates the group of controls from all childrens.
CreateGroupControl | Creates the group of controls from collection of controls and all childrenss.
CreateGroupControl | Creates the group of controls from all childrens.
GetComplexDataBase | Gets the values and convert it to base units.
GetComplexDataBase | Gets the values and converts them to base units.
GetComplexDataDisplay | Gets the values and convert it to display units.
GetComplexDataDisplay | Gets the values and convert it to display units.
GetComplexDataInterface | Gets the values and convert it to interface units.
GetComplexDataInterface | Gets the values and converts it to interface units.
GetDataBase | Gets the value and converts it to base units.
GetDataBase | Gets the value and converts it to base units.
GetDataDisplay | Gets the value and converts it to display units.
GetDataDisplay | Gets the value and converts it to display units.
GetDataInterface | Gets the value and converts it to interface units.
GetDataInterface | Gets the value and converts it to interface units.
GetDataText | Gets the current text.
GetDataText | Gets the current text.
GetObjectsOfNotOkState | Gets the list of registered objects which are in a state other then OK.
RemoveUnitObject | Removes the unit object.
RemoveUnitObject | Removes the unit object.
SetBaseMaxValue | Sets the maximum value defined in base units.
SetBaseMaxValue | Sets the maximum value defined in base units.
SetBaseMinValue | Sets the minimum value in base units.
SetBaseMinValue | Sets the minimum value in base units.
SetComplexDataBase | Sets the list of values in base units.
SetComplexDataBase | Sets the list of values in base units.
SetComplexDataDisplay | Sets the list of values defined in display units.
SetComplexDataDisplay | Sets the list of values defined in display units.
SetComplexDataInterface | Sets the list of values in interface units.
SetComplexDataInterface | Sets the list of values in interface units.
SetDataBase | Sets the value defined in base units.
SetDataBase | Sets the value defined in base units.
SetDataDisplay | Sets the value defined in display units.
SetDataDisplay | Sets the value defined in display units.
SetDataInterface | Sets the value defined in interface units.
SetDataInterface | Sets the value defined in interface units.
SetDataText | Sets the current text.
SetDataText | Sets the current text.
SetInterfaceMaxValue | Sets the maximum value defined in interface units.
SetInterfaceMaxValue | Sets the maximum value defined in interface units.
SetInterfaceMinValue | Sets the minimum value defined in interface units.
SetInterfaceMinValue | Sets the minimum value defined in interface units.
SetUserValidFunction | Sets the user validation function.
SetUserValidFunction | Sets the user validation function.
SetUserValidFunctionComplex | Sets the user validation function for lists of values.
SetUserValidFunctionComplex | Sets the user validation function for lists of values.
ValidateDataBase | Validates the value in base units.
ValidateDataBase | Validates the value in base units.
ValidateDataDisplay | Validates the value in display units.
ValidateDataDisplay | Validates the value in display units.
ValidateDataInterface | Validates the value in interface units.
ValidateDataInterface | Validates the value in interface units.
REXDFM Properties
REXDFM Properties | Description
AllowReplaceObject | Gets or sets a value indicating whether controlling object may be replaced during registration.
Count | Gets the number of controling objects.
REXDFM Delegates
REXDFM Delegates | Description
EventHandlerChange | Delegate to the event handler changes.
EventHandlerLost | Delegate to the event handler lost focus.
REXDFM Events
REXDFM Events | Description
ControlUnitObjectError | Raises when data is changed on Control and some error was occur.
ControlUnitObjectLostFocus | Raises when Control losts focus.
ControlUnitObjectOk | Raises when data is changed on Control and no errors.


Members

Legend
Legend
Constructor
Class
Property
Event
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXDFM Methods

REXDFM Methods
REXDFM Class Legend
REXDFM Methods
REXDFM Methods | Description
AddDisplayUnitObject | Registers an object which implements the IUnitObject interface.
AddDisplayUnitObject | Registers an object which implements the IUnitObject interface.
AddDisplayUnitObject | Registers an object which implements the IUnitObject interface.
AddDisplayUnitObject | Registers an object which implements the IUnitObject interface.
AddUnitObject | Registers an object which implements the IUnitObject interface.
AddUnitObject | Registers an object which implements the IUnitObject interface.
AddUnitObject | Registers an object which implements the IUnitObject interface.
AddUnitObject | Registers an object which implements the IUnitObject interface.
AfterParamsChange | Method called after parameters change.
BeforeParamsChange | Method called before parameters change.
Clear | Clears this instance.
CreateGroupControl | Creates the group of controls from collection of controls and all childrenss.
CreateGroupControl | Creates the group of controls from all childrens.
CreateGroupControl | Creates the group of controls from collection of controls and all childrenss.
CreateGroupControl | Creates the group of controls from all childrens.
GetComplexDataBase | Gets the values and convert it to base units.
GetComplexDataBase | Gets the values and converts them to base units.
GetComplexDataDisplay | Gets the values and convert it to display units.
GetComplexDataDisplay | Gets the values and convert it to display units.
GetComplexDataInterface | Gets the values and convert it to interface units.
GetComplexDataInterface | Gets the values and converts it to interface units.
GetDataBase | Gets the value and converts it to base units.
GetDataBase | Gets the value and converts it to base units.
GetDataDisplay | Gets the value and converts it to display units.
GetDataDisplay | Gets the value and converts it to display units.
GetDataInterface | Gets the value and converts it to interface units.
GetDataInterface | Gets the value and converts it to interface units.
GetDataText | Gets the current text.
GetDataText | Gets the current text.
GetObjectsOfNotOkState | Gets the list of registered objects which are in a state other then OK.
RemoveUnitObject | Removes the unit object.
RemoveUnitObject | Removes the unit object.
SetBaseMaxValue | Sets the maximum value defined in base units.
SetBaseMaxValue | Sets the maximum value defined in base units.
SetBaseMinValue | Sets the minimum value in base units.
SetBaseMinValue | Sets the minimum value in base units.
SetComplexDataBase | Sets the list of values in base units.
SetComplexDataBase | Sets the list of values in base units.
SetComplexDataDisplay | Sets the list of values defined in display units.
SetComplexDataDisplay | Sets the list of values defined in display units.
SetComplexDataInterface | Sets the list of values in interface units.
SetComplexDataInterface | Sets the list of values in interface units.
SetDataBase | Sets the value defined in base units.
SetDataBase | Sets the value defined in base units.
SetDataDisplay | Sets the value defined in display units.
SetDataDisplay | Sets the value defined in display units.
SetDataInterface | Sets the value defined in interface units.
SetDataInterface | Sets the value defined in interface units.
SetDataText | Sets the current text.
SetDataText | Sets the current text.
SetInterfaceMaxValue | Sets the maximum value defined in interface units.
SetInterfaceMaxValue | Sets the maximum value defined in interface units.
SetInterfaceMinValue | Sets the minimum value defined in interface units.
SetInterfaceMinValue | Sets the minimum value defined in interface units.
SetUserValidFunction | Sets the user validation function.
SetUserValidFunction | Sets the user validation function.
SetUserValidFunctionComplex | Sets the user validation function for lists of values.
SetUserValidFunctionComplex | Sets the user validation function for lists of values.
ValidateDataBase | Validates the value in base units.
ValidateDataBase | Validates the value in base units.
ValidateDataDisplay | Validates the value in display units.
ValidateDataDisplay | Validates the value in display units.
ValidateDataInterface | Validates the value in interface units.
ValidateDataInterface | Validates the value in interface units.


REXDFM Properties

REXDFM Properties
REXDFM Class Legend
REXDFM Properties
REXDFM Properties | Description
AllowReplaceObject | Gets or sets a value indicating whether controlling object may be replaced during registration.
Count | Gets the number of controling objects.


REXDFM Class Public Methods

REXDFM Class Public Methods
REXDFM Class Legend
Public Methods
Public Method | Description
REXDFM | Initializes a new instance of the REXDFM class.
REXDFM | Initializes a new instance of the REXDFM class.
REXDFM | Initializes a new instance of the REXDFM class.


DisplayDefinition Fields

DisplayDefinition Fields
REXDFM.DisplayDefinition Class Legend
DisplayDefinition Fields
DisplayDefinition Fields | Description
DisplayType | This is DisplayType, a member of class DisplayDefinition.
EngineeringFormat | This is EngineeringFormat, a member of class DisplayDefinition.
Power | This is Power, a member of class DisplayDefinition.
RoundingIncrement | This is RoundingIncrement, a member of class DisplayDefinition.
Separator | This is Separator, a member of class DisplayDefinition.
UnitDefinition | This is UnitDefinition, a member of class DisplayDefinition.
UnitSymbol | This is UnitSymbol, a member of class DisplayDefinition.


Fields (AutoDoc Folder)

Legend
Legend
Data Member
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


Legend

Legend
REXDFM.DisplayDefinition Class
Legend
Constructor
Data Member
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXDFM.DisplayDefinition Class Members

REXDFM.DisplayDefinition Class Members
REXDFM.DisplayDefinition Class Legend
Members
Public Methods
Public Method | Description
DisplayDefinition | Initializes a new instance of the DisplayDefinition class.
DisplayDefinition | Initializes a new instance of the DisplayDefinition class.
DisplayDefinition | Initializes a new instance of the DisplayDefinition class.
DisplayDefinition Fields
DisplayDefinition Fields | Description
DisplayType | This is DisplayType, a member of class DisplayDefinition.
EngineeringFormat | This is EngineeringFormat, a member of class DisplayDefinition.
Power | This is Power, a member of class DisplayDefinition.
RoundingIncrement | This is RoundingIncrement, a member of class DisplayDefinition.
Separator | This is Separator, a member of class DisplayDefinition.
UnitDefinition | This is UnitDefinition, a member of class DisplayDefinition.
UnitSymbol | This is UnitSymbol, a member of class DisplayDefinition.
DisplayDefinition Methods
DisplayDefinition Methods | Description
Equals | Determines whether the specified T:System.Object is equal to the current T:System.Object.
ReadFromCategory | Reads the unit definition based on the category.
ReadFromCategory | Reads the unit definition based on the category.


Members

Legend
Legend
Constructor
Data Member
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


DisplayDefinition Methods

DisplayDefinition Methods
REXDFM.DisplayDefinition Class Legend
DisplayDefinition Methods
DisplayDefinition Methods | Description
Equals | Determines whether the specified T:System.Object is equal to the current T:System.Object.
ReadFromCategory | Reads the unit definition based on the category.
ReadFromCategory | Reads the unit definition based on the category.


REXDFM.DisplayDefinition Class Public Methods

REXDFM.DisplayDefinition Class Public Methods
REXDFM.DisplayDefinition Class Legend
Public Methods
Public Method | Description
DisplayDefinition | Initializes a new instance of the DisplayDefinition class.
DisplayDefinition | Initializes a new instance of the DisplayDefinition class.
DisplayDefinition | Initializes a new instance of the DisplayDefinition class.


Legend

Legend
REXDirectAccess Class
Legend
Method
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXDirectAccess Class Members

REXDirectAccess Class Members
REXDirectAccess Class Legend
Members
REXDirectAccess Methods
REXDirectAccess Methods | Description
PresetContext | Presets the context.


REXDirectAccess Methods

REXDirectAccess Methods
REXDirectAccess Class Legend
REXDirectAccess Methods
REXDirectAccess Methods | Description
PresetContext | Presets the context.


Legend

Legend
REXDirectRevitAccess Class
Legend
Method
static


REXDirectRevitAccess Class Members

REXDirectRevitAccess Class Members
REXDirectRevitAccess Class Legend
Members
REXDirectRevitAccess Methods
REXDirectRevitAccess Methods | Description
GetRevitSubName | Gets the name of the revit sub.
GetRevitSubName | Gets the name of the revit sub.
MapLanguageToCultureInfoName | This is MapLanguageToCultureInfoName, a member of class REXDirectRevitAccess.
PresetContext | Presets the context.


Members

Legend
Legend
Method
static


REXDirectRevitAccess Methods

REXDirectRevitAccess Methods
REXDirectRevitAccess Class Legend
REXDirectRevitAccess Methods
REXDirectRevitAccess Methods | Description
GetRevitSubName | Gets the name of the revit sub.
GetRevitSubName | Gets the name of the revit sub.
MapLanguageToCultureInfoName | This is MapLanguageToCultureInfoName, a member of class REXDirectRevitAccess.
PresetContext | Presets the context.


Methods (AutoDoc Folder)

Legend
Legend
Method
static


Legend

Legend
REXDirectRevitExecute Class
Legend
Constructor
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXDirectRevitExecute Class Members

REXDirectRevitExecute Class Members
REXDirectRevitExecute Class Legend
Members
Public Methods
Public Method | Description
REXDirectRevitExecute | This is REXDirectRevitExecute, a member of class REXDirectRevitExecute.
REXDirectRevitExecute Methods
REXDirectRevitExecute Methods | Description
Execute | This is Execute, a member of class REXDirectRevitExecute.
Execute | This is Execute, a member of class REXDirectRevitExecute.
Execute | This is Execute, a member of class REXDirectRevitExecute.
Execute | This is Execute, a member of class REXDirectRevitExecute.
Execute | This is Execute, a member of class REXDirectRevitExecute.


REXDirectRevitExecute Methods

REXDirectRevitExecute Methods
REXDirectRevitExecute Class Legend
REXDirectRevitExecute Methods
REXDirectRevitExecute Methods | Description
Execute | This is Execute, a member of class REXDirectRevitExecute.
Execute | This is Execute, a member of class REXDirectRevitExecute.
Execute | This is Execute, a member of class REXDirectRevitExecute.
Execute | This is Execute, a member of class REXDirectRevitExecute.
Execute | This is Execute, a member of class REXDirectRevitExecute.


REXDirectRevitExecute Class Public Methods

REXDirectRevitExecute Class Public Methods
REXDirectRevitExecute Class Legend
Public Methods
Public Method | Description
REXDirectRevitExecute | This is REXDirectRevitExecute, a member of class REXDirectRevitExecute.


REXErrors Enumerations

REXErrors Enumerations
REXErrors Class Legend
REXErrors Enumerations
REXErrors Enumerations | Description
ErrorCode | Standard REX error codes.


Legend

Legend
REXErrors Class
Legend
Enumeration
Method
static


REXErrors Class Members

REXErrors Class Members
REXErrors Class Legend
Members
REXErrors Enumerations
REXErrors Enumerations | Description
ErrorCode | Standard REX error codes.
REXErrors Methods
REXErrors Methods | Description
GetCategory | Returns category for specified error code.
GetMessage | Returns formated error string.


Members

Legend
Legend
Enumeration
Method
static


REXErrors Methods

REXErrors Methods
REXErrors Class Legend
REXErrors Methods
REXErrors Methods | Description
GetCategory | Returns category for specified error code.
GetMessage | Returns formated error string.


Legend

Legend
REXExtension Class
Legend
Constructor
virtual
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXExtension Class Members

REXExtension Class Members
REXExtension Class Legend
Members
Public Methods
Public Method | Description
REXExtension | Initializes a new instance of the REXExtension class.
REXExtension Methods
REXExtension Methods | Description
AddCommands | Adds the commands.
ApplyStyle | This is ApplyStyle, a member of class REXExtension.
ApplyStyle | This is ApplyStyle, a member of class REXExtension.
Close | Close extension with all needed actions.
Close | Close extension with all needed actions.
Close | Close extension with all needed actions.
Command | Commands the specified command struct.
Create | Creates this extension.
Event | Events the specified event struct.
GetAPI | Get reference to main API object.
GetCaption | Get standard caption.
GetCaption | Get standard caption with additional information.
GetControl | Get reference to main control.
GetData | Get the data structure.
GetForm | Get reference to main form.
GetIcon | Get reference to icon.
GetResults | Get the results structure.
GetREXEnvironment | Get the reference to REX environment object.
GetTopWindowForParent | This is GetTopWindowForParent, a member of class REXExtension.
GetTopWindowHandleForParent | This is GetTopWindowHandleForParent, a member of class REXExtension.
GetWindow | Get reference to main form.
GetWindowForParent | Get the window for parent.
GetWindowHandleForParent | Get the window for parent.
Initialize | Initializes this instance.
OnActivateLayout | Activates or deactivates layout - module can modify layout before or after activation.
OnCanActivateLayout | Called when [can activate layout].
OnCanClose | If returns true, dialog will close after OK button clicked.
OnCanClose | Called when closing module.
OnCanRun | Checks status of module and shows some information for user if module can't complete action.
OnCheckValidity | Called when check validity.
OnClear | Called when clear.
OnClose | Called during closing module.
OnCommand | Called when command.
OnCreate | Creates needed structures and verify needs.
OnCreateDialogs | Creates sub dialogs.
OnCreateLayout | Creates layout items and setups layout.
OnDataLoad | Called when data load.
OnDataLoaded | Called when data loaded.
OnDataSave | Called when data save.
OnDataSaved | Called when data saved.
OnErrorSelected | Called when error selected on errors list dialog.
OnEvent | Called when event.
OnGetExtensionName | Called when get extension name.
OnGetText | Get specified text from resources.
OnInitialize | Called when Initialize.
OnLoadJournalingData | Called when load journaling data.
OnLoadTemplate | Called when load template.
OnPreferencesChanged | Called when preferences changed.
OnRegionalSettingsChanged | Called when regional settings changed.
OnRun | Runs process calculations or other operations.
OnSaveJournalingData | Called when save journaling data.
OnSaveTemplate | Called when save template.
OnSetContext | Called when regional settings changed.
OnSetData | Get data from dialogs and sets Data's strucutres.
OnSetDialogs | Set data in dialogs.
OnShowResults | Shows results.
OnUpdate | Called when update.
OnUpdateDialogs | Called when update dialogs.
ROHTMLDocument | Access to ROHTML's document.
ROHTMLReleaseDocument | Releases ROHTML's document.
Run | Runs process calculations or other operations.
RunQuestion | Runs the question.
SetCanClose | If the method will be called on OnCanRun method, Module will not close after return false.
SetContext | Initializes this instance.
SetCreateFail | If the method will be called on OnCreate method, Module will not continue work.
SetCreateFail | If the method will be called on OnCreate method, Module will not continue work.
Setup | Setups this extension.
SetupCommands | Initializes the commands.
SetupDefaultCommands | Initializes the default commands.
ShowMessageBox | This is ShowMessageBox, a member of class REXExtension.
ShowMessageBox | This is ShowMessageBox, a member of class REXExtension.
ShowMessageBox | This is ShowMessageBox, a member of class REXExtension.
ShowMessageBox | This is ShowMessageBox, a member of class REXExtension.
ShowMessageBox | This is ShowMessageBox, a member of class REXExtension.
ShowMessageBox | This is ShowMessageBox, a member of class REXExtension.
ShowMessageBox | This is ShowMessageBox, a member of class REXExtension.
ShowPreferencesDialog | This is ShowPreferencesDialog, a member of class REXExtension.
Status | Get current status of module.
REXExtension Properties
REXExtension Properties | Description
Context | Get the reference to current context object.
DFM | Gets the DFM object to manage all UI controls which support Revit Extension units.
ExtensionContext | Get the reference to the old extension context object.
Layout | Get the reference to Layout object.
MainAccess | Get the reference to object which controls interactions between module, and main application.
Preferences | Get the reference to Preferences object.
Progress | Get the reference to progress object.
Revit | Get the reference to object which controls interactions between module, and Revit.
Style | This is Style, a member of class REXExtension.
System | Get the reference to System object.
ThisApplication | Get this application.
ThisContext | Get the context.
ThisProduct | Gets the this product.
ThisRunContext | Gets the this run context.
UI | Get the reference to UI object.
Units | Get the reference to Units object.


REXExtension Methods

REXExtension Methods
REXExtension Class Legend
REXExtension Methods
REXExtension Methods | Description
AddCommands | Adds the commands.
ApplyStyle | This is ApplyStyle, a member of class REXExtension.
ApplyStyle | This is ApplyStyle, a member of class REXExtension.
Close | Close extension with all needed actions.
Close | Close extension with all needed actions.
Close | Close extension with all needed actions.
Command | Commands the specified command struct.
Create | Creates this extension.
Event | Events the specified event struct.
GetAPI | Get reference to main API object.
GetCaption | Get standard caption.
GetCaption | Get standard caption with additional information.
GetControl | Get reference to main control.
GetData | Get the data structure.
GetForm | Get reference to main form.
GetIcon | Get reference to icon.
GetResults | Get the results structure.
GetREXEnvironment | Get the reference to REX environment object.
GetTopWindowForParent | This is GetTopWindowForParent, a member of class REXExtension.
GetTopWindowHandleForParent | This is GetTopWindowHandleForParent, a member of class REXExtension.
GetWindow | Get reference to main form.
GetWindowForParent | Get the window for parent.
GetWindowHandleForParent | Get the window for parent.
Initialize | Initializes this instance.
OnActivateLayout | Activates or deactivates layout - module can modify layout before or after activation.
OnCanActivateLayout | Called when [can activate layout].
OnCanClose | If returns true, dialog will close after OK button clicked.
OnCanClose | Called when closing module.
OnCanRun | Checks status of module and shows some information for user if module can't complete action.
OnCheckValidity | Called when check validity.
OnClear | Called when clear.
OnClose | Called during closing module.
OnCommand | Called when command.
OnCreate | Creates needed structures and verify needs.
OnCreateDialogs | Creates sub dialogs.
OnCreateLayout | Creates layout items and setups layout.
OnDataLoad | Called when data load.
OnDataLoaded | Called when data loaded.
OnDataSave | Called when data save.
OnDataSaved | Called when data saved.
OnErrorSelected | Called when error selected on errors list dialog.
OnEvent | Called when event.
OnGetExtensionName | Called when get extension name.
OnGetText | Get specified text from resources.
OnInitialize | Called when Initialize.
OnLoadJournalingData | Called when load journaling data.
OnLoadTemplate | Called when load template.
OnPreferencesChanged | Called when preferences changed.
OnRegionalSettingsChanged | Called when regional settings changed.
OnRun | Runs process calculations or other operations.
OnSaveJournalingData | Called when save journaling data.
OnSaveTemplate | Called when save template.
OnSetContext | Called when regional settings changed.
OnSetData | Get data from dialogs and sets Data's strucutres.
OnSetDialogs | Set data in dialogs.
OnShowResults | Shows results.
OnUpdate | Called when update.
OnUpdateDialogs | Called when update dialogs.
ROHTMLDocument | Access to ROHTML's document.
ROHTMLReleaseDocument | Releases ROHTML's document.
Run | Runs process calculations or other operations.
RunQuestion | Runs the question.
SetCanClose | If the method will be called on OnCanRun method, Module will not close after return false.
SetContext | Initializes this instance.
SetCreateFail | If the method will be called on OnCreate method, Module will not continue work.
SetCreateFail | If the method will be called on OnCreate method, Module will not continue work.
Setup | Setups this extension.
SetupCommands | Initializes the commands.
SetupDefaultCommands | Initializes the default commands.
ShowMessageBox | This is ShowMessageBox, a member of class REXExtension.
ShowMessageBox | This is ShowMessageBox, a member of class REXExtension.
ShowMessageBox | This is ShowMessageBox, a member of class REXExtension.
ShowMessageBox | This is ShowMessageBox, a member of class REXExtension.
ShowMessageBox | This is ShowMessageBox, a member of class REXExtension.
ShowMessageBox | This is ShowMessageBox, a member of class REXExtension.
ShowMessageBox | This is ShowMessageBox, a member of class REXExtension.
ShowPreferencesDialog | This is ShowPreferencesDialog, a member of class REXExtension.
Status | Get current status of module.


REXExtension Properties

REXExtension Properties
REXExtension Class Legend
REXExtension Properties
REXExtension Properties | Description
Context | Get the reference to current context object.
DFM | Gets the DFM object to manage all UI controls which support Revit Extension units.
ExtensionContext | Get the reference to the old extension context object.
Layout | Get the reference to Layout object.
MainAccess | Get the reference to object which controls interactions between module, and main application.
Preferences | Get the reference to Preferences object.
Progress | Get the reference to progress object.
Revit | Get the reference to object which controls interactions between module, and Revit.
Style | This is Style, a member of class REXExtension.
System | Get the reference to System object.
ThisApplication | Get this application.
ThisContext | Get the context.
ThisProduct | Gets the this product.
ThisRunContext | Gets the this run context.
UI | Get the reference to UI object.
Units | Get the reference to Units object.


REXExtension Class Public Methods

REXExtension Class Public Methods
REXExtension Class Legend
Public Methods
Public Method | Description
REXExtension | Initializes a new instance of the REXExtension class.


REXExtensionContext Enumerations

REXExtensionContext Enumerations
REXExtensionContext Class Legend
REXExtensionContext Enumerations
REXExtensionContext Enumerations | Description
REXLevelType | Level type.
REXStandardOwner | Owner of module.
REXStandardRunContext | Defines standard running context.


REXExtensionContext Fields

REXExtensionContext Fields
REXExtensionContext Class Legend
REXExtensionContext Fields
REXExtensionContext Fields | Description
Control | Reference to Control object.


Legend

Legend
REXExtensionContext Class
Legend
Constructor
Structure
Enumeration
Data Member
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXExtensionContext Class Members

REXExtensionContext Class Members
REXExtensionContext Class Legend
Members
Public Methods
Public Method | Description
REXExtensionContext | Initializes a new instance of a REXExtensionContext class and sets defaults.
REXExtensionContext Structures
REXExtensionContext Structures | Description
REXControl | Controls behavior of module.
REXControlFlags | Flags used for detecting forced settings.
REXExtensionContext Enumerations
REXExtensionContext Enumerations | Description
REXLevelType | Level type.
REXStandardOwner | Owner of module.
REXStandardRunContext | Defines standard running context.
REXExtensionContext Fields
REXExtensionContext Fields | Description
Control | Reference to Control object.


Members

Legend
Legend
Constructor
Structure
Enumeration
Data Member
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXExtensionContext Class Public Methods

REXExtensionContext Class Public Methods
REXExtensionContext Class Legend
Public Methods
Public Method | Description
REXExtensionContext | Initializes a new instance of a REXExtensionContext class and sets defaults.


REXExtensionContext Structures

REXExtensionContext Structures
REXExtensionContext Class Legend
REXExtensionContext Structures
REXExtensionContext Structures | Description
REXControl | Controls behavior of module.
REXControlFlags | Flags used for detecting forced settings.


Structures (AutoDoc Folder)

Legend
Legend
Structure
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXControl Fields

REXControl Fields
REXExtensionContext.REXControl Structure Legend
REXControl Fields
REXControl Fields | Description
APIContext | Indicates that module is running in API context.
Flags | Flags used for detecting forced settings.
ForceHideManager | Orders to hide manager of extensions.
InteractiveCommand | Indicates that module uses interactive modal dialog.
LanguagesSupport | Indicates that module has multi-language architecture.
LevelType | Level type.
NoUI | Indicates that module can't show any messages and dialogs.
Owner | Owner of extension.
RegionalSettingsSupport | If true, regional settings will be added to menu and toolbars.
RunContext | String which set up running context.
ShowErrorsDialog | Enables or disables showing of errors in dialog.
StandardOwner | Owner of extension.
StandardRunContext | String mapped to enum which set up running context.
VerifySelection | Indicates that module is running for verification current selection.


Legend

Legend
REXExtensionContext.REXControl Structure
Legend
Data Member
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXExtensionContext.REXControl Structure Members

REXExtensionContext.REXControl Structure Members
REXExtensionContext.REXControl Structure Legend
Members
REXControl Fields
REXControl Fields | Description
APIContext | Indicates that module is running in API context.
Flags | Flags used for detecting forced settings.
ForceHideManager | Orders to hide manager of extensions.
InteractiveCommand | Indicates that module uses interactive modal dialog.
LanguagesSupport | Indicates that module has multi-language architecture.
LevelType | Level type.
NoUI | Indicates that module can't show any messages and dialogs.
Owner | Owner of extension.
RegionalSettingsSupport | If true, regional settings will be added to menu and toolbars.
RunContext | String which set up running context.
ShowErrorsDialog | Enables or disables showing of errors in dialog.
StandardOwner | Owner of extension.
StandardRunContext | String mapped to enum which set up running context.
VerifySelection | Indicates that module is running for verification current selection.
REXControl Properties
REXControl Properties | Description
UserInterface | Enables or disables user interface operations.


Members

Legend
Legend
Data Member
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXControl Properties

REXControl Properties
REXExtensionContext.REXControl Structure Legend
REXControl Properties
REXControl Properties | Description
UserInterface | Enables or disables user interface operations.


Legend

Legend
REXExtensionControl Class
Legend
Constructor
virtual
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXExtensionControl Class Members

REXExtensionControl Class Members
REXExtensionControl Class Legend
Members
Public Methods
Public Method | Description
REXExtensionControl | Initializes a new instance of a REXExtensionControl class.
REXExtensionControl | Initializes a new instance of a REXExtensionControl class.
REXExtensionControl Methods
REXExtensionControl Methods | Description
OnActivateLayout | Called when activate layout.
REXExtensionControl Properties
REXExtensionControl Properties | Description
ThisApplication | Get this application.
ThisContext | Get this context.
ThisExtension | Get this extension.
ThisProduct | Gets the this product.
ThisRunContext | Gets the this run context.


REXExtensionControl Methods

REXExtensionControl Methods
REXExtensionControl Class Legend
REXExtensionControl Methods
REXExtensionControl Methods | Description
OnActivateLayout | Called when activate layout.


REXExtensionControl Properties

REXExtensionControl Properties
REXExtensionControl Class Legend
REXExtensionControl Properties
REXExtensionControl Properties | Description
ThisApplication | Get this application.
ThisContext | Get this context.
ThisExtension | Get this extension.
ThisProduct | Gets the this product.
ThisRunContext | Gets the this run context.


REXExtensionControl Class Public Methods

REXExtensionControl Class Public Methods
REXExtensionControl Class Legend
Public Methods
Public Method | Description
REXExtensionControl | Initializes a new instance of a REXExtensionControl class.
REXExtensionControl | Initializes a new instance of a REXExtensionControl class.


REXExtensionData Enumerations

REXExtensionData Enumerations
REXExtensionData Class Legend
REXExtensionData Enumerations
REXExtensionData Enumerations | Description
DataMode | Determines the target of serialization.
DataType | Determines the data type.
OperationStatus | Determines the status after operation.


Legend

Legend
REXExtensionData Class
Legend
Constructor
Enumeration
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXExtensionData Class Members

REXExtensionData Class Members
REXExtensionData Class Legend
Members
Public Methods
Public Method | Description
REXExtensionData | Initializes a new instance of the REXExtensionData class.
REXExtensionData Enumerations
REXExtensionData Enumerations | Description
DataMode | Determines the target of serialization.
DataType | Determines the data type.
OperationStatus | Determines the status after operation.
REXExtensionData Methods
REXExtensionData Methods | Description
CompareData | Compares the data with another data.
CompareData | Compares the data with another data.
Load | Loads data strucuture from a BinaryReader object.
LoadHeader | Loads data strucuture from a BinaryReader object.
LoadHeader | Loads data strucuture from a BinaryReader object.
LoadHeader | This is LoadHeader, a member of class REXExtensionData.
Save | Saves data structure to a BinaryWriter object.
SaveHeader | Saves data structure to a BinaryWriter object.
SaveHeader | This is SaveHeader, a member of class REXExtensionData.
SetDefaults | Sets the defaults.
REXExtensionData Properties
REXExtensionData Properties | Description
DateTimeData | Get the date and time of data which load.
DateTimeDataCreation | Get the creation date and time of data which load.
EnableDynamicUpdate | This is EnableDynamicUpdate, a member of class REXExtensionData.
LoadedRegionalSettings | This is LoadedRegionalSettings, a member of class REXExtensionData.
Mode | Get or set the mode.
NoHeader | This is NoHeader, a member of class REXExtensionData.
ProductType | Loaded product type
RunContext | Loaded run context
StandardRunContext | Loaded standard run context
Status | Get or set the status.
Version | Get the current version.
VersionData | Get the version data which load.


REXExtensionData Methods

REXExtensionData Methods
REXExtensionData Class Legend
REXExtensionData Methods
REXExtensionData Methods | Description
CompareData | Compares the data with another data.
CompareData | Compares the data with another data.
Load | Loads data strucuture from a BinaryReader object.
LoadHeader | Loads data strucuture from a BinaryReader object.
LoadHeader | Loads data strucuture from a BinaryReader object.
LoadHeader | This is LoadHeader, a member of class REXExtensionData.
Save | Saves data structure to a BinaryWriter object.
SaveHeader | Saves data structure to a BinaryWriter object.
SaveHeader | This is SaveHeader, a member of class REXExtensionData.
SetDefaults | Sets the defaults.


REXExtensionData Properties

REXExtensionData Properties
REXExtensionData Class Legend
REXExtensionData Properties
REXExtensionData Properties | Description
DateTimeData | Get the date and time of data which load.
DateTimeDataCreation | Get the creation date and time of data which load.
EnableDynamicUpdate | This is EnableDynamicUpdate, a member of class REXExtensionData.
LoadedRegionalSettings | This is LoadedRegionalSettings, a member of class REXExtensionData.
Mode | Get or set the mode.
NoHeader | This is NoHeader, a member of class REXExtensionData.
ProductType | Loaded product type
RunContext | Loaded run context
StandardRunContext | Loaded standard run context
Status | Get or set the status.
Version | Get the current version.
VersionData | Get the version data which load.


REXExtensionData Class Public Methods

REXExtensionData Class Public Methods
REXExtensionData Class Legend
Public Methods
Public Method | Description
REXExtensionData | Initializes a new instance of the REXExtensionData class.


Legend

Legend
REXExtensionDataSerializable Class
Legend
Constructor
virtual


REXExtensionDataSerializable Class Members

REXExtensionDataSerializable Class Members
REXExtensionDataSerializable Class Legend
Members
Public Methods
Public Method | Description
REXExtensionDataSerializable | Initializes a new instance of the REXExtensionDataSerializable class.
REXExtensionDataSerializable Methods
REXExtensionDataSerializable Methods | Description
GetObjectData | A required method by ISerializable to serialize the object.


Members

Legend
Legend
Constructor
virtual


REXExtensionDataSerializable Methods

REXExtensionDataSerializable Methods
REXExtensionDataSerializable Class Legend
REXExtensionDataSerializable Methods
REXExtensionDataSerializable Methods | Description
GetObjectData | A required method by ISerializable to serialize the object.


REXExtensionDataSerializable Class Public Methods

REXExtensionDataSerializable Class Public Methods
REXExtensionDataSerializable Class Legend
Public Methods
Public Method | Description
REXExtensionDataSerializable | Initializes a new instance of the REXExtensionDataSerializable class.


Example

Example
REXExtensionDataSerializable.GetObjectData Method
public virtual void GetObjectData(System.Runtime.Serialization.SerializationInfo info, System.Runtime.Serialization.StreamingContext ctx)
{
    info.AddValue("s1", strPrivate);
    info.AddValue("s2", strPublic);
    into.AddValue("ob", obMyClass);       // Serializing an object
}


Legend

Legend
REXExtensionMainControl Class
Legend
Constructor
Property
virtual


REXExtensionMainControl Class Members

REXExtensionMainControl Class Members
REXExtensionMainControl Class Legend
Members
Public Methods
Public Method | Description
REXExtensionMainControl | Initializes a new instance of a REXExtensionMainControl class.
REXExtensionMainControl | Initializes a new instance of a REXExtensionMainControl class.
REXExtensionMainControl Properties
REXExtensionMainControl Properties | Description
Components | Get the component.


Members

Legend
Legend
Constructor
Property
virtual


REXExtensionMainControl Properties

REXExtensionMainControl Properties
REXExtensionMainControl Class Legend
REXExtensionMainControl Properties
REXExtensionMainControl Properties | Description
Components | Get the component.


REXExtensionMainControl Class Public Methods

REXExtensionMainControl Class Public Methods
REXExtensionMainControl Class Legend
Public Methods
Public Method | Description
REXExtensionMainControl | Initializes a new instance of a REXExtensionMainControl class.
REXExtensionMainControl | Initializes a new instance of a REXExtensionMainControl class.


Legend

Legend
REXExtensionObject Class
Legend
Constructor
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXExtensionObject Class Members

REXExtensionObject Class Members
REXExtensionObject Class Legend
Members
Public Methods
Public Method | Description
REXExtensionObject | Initializes a new instance of a REXExtensionObject class.
REXExtensionObject Properties
REXExtensionObject Properties | Description
ThisApplication | Get the application.
ThisContext | Get the context.
ThisExtension | Get the extension.
ThisProduct | Gets the this product.
ThisRunContext | Gets the this run context.


Members

Legend
Legend
Constructor
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXExtensionObject Properties

REXExtensionObject Properties
REXExtensionObject Class Legend
REXExtensionObject Properties
REXExtensionObject Properties | Description
ThisApplication | Get the application.
ThisContext | Get the context.
ThisExtension | Get the extension.
ThisProduct | Gets the this product.
ThisRunContext | Gets the this run context.


REXExtensionObject Class Public Methods

REXExtensionObject Class Public Methods
REXExtensionObject Class Legend
Public Methods
Public Method | Description
REXExtensionObject | Initializes a new instance of a REXExtensionObject class.


Legend

Legend
REXExtensionPanel Class
Legend
Constructor
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXExtensionPanel Class Members

REXExtensionPanel Class Members
REXExtensionPanel Class Legend
Members
Public Methods
Public Method | Description
REXExtensionPanel | Initializes a new instance of a REXExtensionForm class.
REXExtensionPanel | Initializes a new instance of a REXExtensionForm class.
REXExtensionPanel Methods
REXExtensionPanel Methods | Description
SetControl | Sets the control.
REXExtensionPanel Properties
REXExtensionPanel Properties | Description
ThisApplication | Get this application.
ThisContext | Get this context.
ThisExtension | Get this extension.
ThisProduct | Gets the this product.
ThisRunContext | Gets the this run context.


REXExtensionPanel Methods

REXExtensionPanel Methods
REXExtensionPanel Class Legend
REXExtensionPanel Methods
REXExtensionPanel Methods | Description
SetControl | Sets the control.


REXExtensionPanel Properties

REXExtensionPanel Properties
REXExtensionPanel Class Legend
REXExtensionPanel Properties
REXExtensionPanel Properties | Description
ThisApplication | Get this application.
ThisContext | Get this context.
ThisExtension | Get this extension.
ThisProduct | Gets the this product.
ThisRunContext | Gets the this run context.


REXExtensionPanel Class Public Methods

REXExtensionPanel Class Public Methods
REXExtensionPanel Class Legend
Public Methods
Public Method | Description
REXExtensionPanel | Initializes a new instance of a REXExtensionForm class.
REXExtensionPanel | Initializes a new instance of a REXExtensionForm class.


Legend

Legend
REXExtensionProduct Class
Legend
Constructor
virtual


REXExtensionProduct Class Members

REXExtensionProduct Class Members
REXExtensionProduct Class Legend
Members
Public Methods
Public Method | Description
REXExtensionProduct | Initializes a new instance of the REXExtensionFactory class.
REXExtensionProduct Methods
REXExtensionProduct Methods | Description
OnActivateLayout | Activates or deactivates layout - module can modify layout before or after activation.
OnCanClose | If returns true dialog will close after OK button is clicked.
OnCanClose | If returns true dialog will close after OK button is clicked.
OnCanRun | Checks status of module and shows some information for user if module can't excecute action.
OnClear | Called when data are cleared.
OnClose | Called during closing module.
OnCommand | Commands the specified command struct.
OnCreate | Creates needed structures and verify needs.
OnCreateDialogs | Creates sub dialogs.
OnCreateLayout | Creates layout items and setups layout.
OnDataLoad | Called when data are loaded.
OnDataLoaded | Called when data loaded.
OnDataSave | Called when data are saved.
OnDataSaved | Called when data are saved.
OnErrorSelected | Called when an error is selected on errors list dialog.
OnEvent | Called when event.
OnGetText | Get specified text from resources.
OnInitialize | Called when Initialize.
OnLoadTemplate | Called when template is loaded.
OnPreferencesChanged | Called when preferences changed.
OnRun | Runs process calculations or other operations.
OnSaveTemplate | Called when template is saved.
OnSetData | Get data from dialogs and sets Data's strucutres.
OnSetDialogs | Set data on dialogs.
OnShowResults | Shows results.
OnUpdateDialogs | This is OnUpdateDialogs, a member of class REXExtensionProduct.


REXExtensionProduct Methods

REXExtensionProduct Methods
REXExtensionProduct Class Legend
REXExtensionProduct Methods
REXExtensionProduct Methods | Description
OnActivateLayout | Activates or deactivates layout - module can modify layout before or after activation.
OnCanClose | If returns true dialog will close after OK button is clicked.
OnCanClose | If returns true dialog will close after OK button is clicked.
OnCanRun | Checks status of module and shows some information for user if module can't excecute action.
OnClear | Called when data are cleared.
OnClose | Called during closing module.
OnCommand | Commands the specified command struct.
OnCreate | Creates needed structures and verify needs.
OnCreateDialogs | Creates sub dialogs.
OnCreateLayout | Creates layout items and setups layout.
OnDataLoad | Called when data are loaded.
OnDataLoaded | Called when data loaded.
OnDataSave | Called when data are saved.
OnDataSaved | Called when data are saved.
OnErrorSelected | Called when an error is selected on errors list dialog.
OnEvent | Called when event.
OnGetText | Get specified text from resources.
OnInitialize | Called when Initialize.
OnLoadTemplate | Called when template is loaded.
OnPreferencesChanged | Called when preferences changed.
OnRun | Runs process calculations or other operations.
OnSaveTemplate | Called when template is saved.
OnSetData | Get data from dialogs and sets Data's strucutres.
OnSetDialogs | Set data on dialogs.
OnShowResults | Shows results.
OnUpdateDialogs | This is OnUpdateDialogs, a member of class REXExtensionProduct.


REXExtensionProduct Class Public Methods

REXExtensionProduct Class Public Methods
REXExtensionProduct Class Legend
Public Methods
Public Method | Description
REXExtensionProduct | Initializes a new instance of the REXExtensionFactory class.


Legend

Legend
REXExtensionSettings Class
Legend
Constructor
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXExtensionSettings Class Members

REXExtensionSettings Class Members
REXExtensionSettings Class Legend
Members
Public Methods
Public Method | Description
REXExtensionSettings | Initializes a new instance of the REXExtensionSettings class.
REXExtensionSettings | Initializes a new instance of the REXExtensionSettings class.
REXExtensionSettings Methods
REXExtensionSettings Methods | Description
LoadSettings | This is LoadSettings, a member of class REXExtensionSettings.
REXExtensionSettings Properties
REXExtensionSettings Properties | Description
ThisApplication | Get the application.
ThisContext | Get the context.
ThisExtension | Get the extension.


REXExtensionSettings Methods

REXExtensionSettings Methods
REXExtensionSettings Class Legend
REXExtensionSettings Methods
REXExtensionSettings Methods | Description
LoadSettings | This is LoadSettings, a member of class REXExtensionSettings.


REXExtensionSettings Properties

REXExtensionSettings Properties
REXExtensionSettings Class Legend
REXExtensionSettings Properties
REXExtensionSettings Properties | Description
ThisApplication | Get the application.
ThisContext | Get the context.
ThisExtension | Get the extension.


REXExtensionSettings Class Public Methods

REXExtensionSettings Class Public Methods
REXExtensionSettings Class Legend
Public Methods
Public Method | Description
REXExtensionSettings | Initializes a new instance of the REXExtensionSettings class.
REXExtensionSettings | Initializes a new instance of the REXExtensionSettings class.


Legend

Legend
REXExtensionWindow Class
Legend
Constructor
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXExtensionWindow Class Members

REXExtensionWindow Class Members
REXExtensionWindow Class Legend
Members
Public Methods
Public Method | Description
REXExtensionWindow | Initializes a new instance of a REXExtensionForm class.
REXExtensionWindow | Initializes a new instance of a REXExtensionForm class.
REXExtensionWindow Properties
REXExtensionWindow Properties | Description
ThisApplication | Get this application.
ThisContext | Get this context.
ThisExtension | Get this extension.
ThisProduct | Gets the this product.
ThisRunContext | Gets the this run context.
WindowStatus | This is WindowStatus, a member of class REXExtensionWindow.


REXExtensionWindow Properties

REXExtensionWindow Properties
REXExtensionWindow Class Legend
REXExtensionWindow Properties
REXExtensionWindow Properties | Description
ThisApplication | Get this application.
ThisContext | Get this context.
ThisExtension | Get this extension.
ThisProduct | Gets the this product.
ThisRunContext | Gets the this run context.
WindowStatus | This is WindowStatus, a member of class REXExtensionWindow.


REXExtensionWindow Class Public Methods

REXExtensionWindow Class Public Methods
REXExtensionWindow Class Legend
Public Methods
Public Method | Description
REXExtensionWindow | Initializes a new instance of a REXExtensionForm class.
REXExtensionWindow | Initializes a new instance of a REXExtensionForm class.


Legend

Legend
REXFoundationApplication Class
Legend
Constructor
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXFoundationApplication Class Members

REXFoundationApplication Class Members
REXFoundationApplication Class Legend
Members
Public Methods
Public Method | Description
REXFoundationApplication | Initializes a new instance of the REXApplication class.
REXFoundationApplication Methods
REXFoundationApplication Methods | Description
Close | Closes this instance.
Command | Commands the specified command struct.
Control | Controls this instance.
Create | Creates and shows module as modal dialog.
Create | Creates and shows module as modal dialog.
Event | Called when event.
GetService | Gets the the service.
GetUniqueId | Returns the unique id for the module
Modal | Creates and shows module as modal dialog.
Modal | Creates and shows module as modal dialog.
Show | Shows this module.


REXFoundationApplication Methods

REXFoundationApplication Methods
REXFoundationApplication Class Legend
REXFoundationApplication Methods
REXFoundationApplication Methods | Description
Close | Closes this instance.
Command | Commands the specified command struct.
Control | Controls this instance.
Create | Creates and shows module as modal dialog.
Create | Creates and shows module as modal dialog.
Event | Called when event.
GetService | Gets the the service.
GetUniqueId | Returns the unique id for the module
Modal | Creates and shows module as modal dialog.
Modal | Creates and shows module as modal dialog.
Show | Shows this module.


REXFoundationApplication Class Public Methods

REXFoundationApplication Class Public Methods
REXFoundationApplication Class Legend
Public Methods
Public Method | Description
REXFoundationApplication | Initializes a new instance of the REXApplication class.


Legend

Legend
REXLayout Class
Legend
Constructor
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXLayout Class Members

REXLayout Class Members
REXLayout Class Legend
Members
Public Methods
Public Method | Description
REXLayout | Initializes a new instance of the REXLayout class.
REXLayout Methods
REXLayout Methods | Description
AddLayout | Adds the layout.
AddLayout | Adds the layout.
AddLayout | Adds the layout.
AddLayout_Dialog | Adds the predefined layout with one dialog.
AddLayout_Dialog_Menu | Adds the predefined layout which contains one dialog and standard menu.
AddLayout_Dialog_ToolBarMenu_ToolBar | Adds the predefined layout which contains one dialog, menu as tool bar and tool bar.
AddLayout_OptionsList_Menu_BottomDialog_RightDialog | Adds the predefined layout which contains options list, first dialog on the right side, secound dialog on the bottom and standard menu.
AddLayout_OptionsList_Menu_BottomDialog_RightDialogAndHtmlNoteOnTabs | Adds the predefined layout which contains options list, dialog and html note on tabs on the right side, secound dialog on the bottom and standard menu.
AddLayout_OptionsList_Menu_RightDialog | Adds the predefined layout which contains options list, one dialog and standard menu.
AddLayout_OptionsList_Menu_RightDialogAndViewAndHtmlNoteOnTabs | Adds the predefined layout which contains options list, one dialog, view (or dialog), html note on tabs and standard menu.
AddLayout_OptionsList_Menu_RightDialogAndViewOnTabs | Adds the predefined layout which contains options list, one dialog and view (or dialog) on tabs and standard menu.
AddLayout_OptionsList_ToolBarMenu_ToolBar_BottomDialog_RightDialog | Adds the predefined layout which contains options list, first dialog on the right side and secound dialog on the bottom, tool bar as menu and tool bar.
AddLayout_OptionsList_ToolBarMenu_ToolBar_BottomDialog_RightDialogAndHtmlNoteOnTabs | Adds the predefined layout which contains options list, dialog and html note on tabs on the right side, secound dialog on the bottom and tool bar as menu and tool bar.
AddLayout_OptionsList_ToolBarMenu_ToolBar_RightDialog | Adds the predefined layout which contains options list, one dialog, tool bar as menu and tool bar.
AddLayout_OptionsList_ToolBarMenu_ToolBar_RightDialogAndViewOnTabs | Adds the predefined layout which contains options list, dialog and view (or dialog) on tabs, tool bar as menu and tool bar.
CalculateMainControlSize | This is CalculateMainControlSize, a member of class REXLayout.
Clear | Clears all layouts items.
DeSelect | Called after deselect the specified LayoutItem.
DeSelect | This is DeSelect, a member of class REXLayout.
DisposeControls | Disposes all controls in all added layouts.
GetItem | Gets the layout item identified by mame.
GetLayoutIndex | Gets the index of the layout.
GetLayoutItem | This is GetLayoutItem, a member of class REXLayout.
InsertLayout | Adds the layout.
RemoveLayout | Removes the layout.
Select | Called after select the specified LayoutItem.
Select | This is Select, a member of class REXLayout.
SelectLayout | Selects the layout.
Setup | Setups layout and all layout's items.
ToolboxDeSelect | This is ToolboxDeSelect, a member of class REXLayout.
ToolboxGetItem | This is ToolboxGetItem, a member of class REXLayout.
ToolboxRemoveLayout | This is ToolboxRemoveLayout, a member of class REXLayout.
ToolboxSelect | This is ToolboxSelect, a member of class REXLayout.
ToolboxSelectLayout | This is ToolboxSelectLayout, a member of class REXLayout.
ToolboxSetup | This is ToolboxSetup, a member of class REXLayout.
ToolboxSetup | This is ToolboxSetup, a member of class REXLayout.
ToolboxUpdate | This is ToolboxUpdate, a member of class REXLayout.
Update | Updates layout all layout's items.
REXLayout Properties
REXLayout Properties | Description
CommandsOptions | Gets or sets the options for commands.
CommandsOptionsByEnum | Gets or sets the options for commands.
ConstOptions | Gets or sets the const options for all layouts.
ConstOptionsByEnum | Gets or sets the const options for all layouts.
Count | Gets the count of layout items.
Current | Gets the current layout item.
DefaultOptions | Gets or sets the default options for layout.
DisableEvents | Gets a value indicating whether events are disabled.


REXLayout Methods

REXLayout Methods
REXLayout Class Legend
REXLayout Methods
REXLayout Methods | Description
AddLayout | Adds the layout.
AddLayout | Adds the layout.
AddLayout | Adds the layout.
AddLayout_Dialog | Adds the predefined layout with one dialog.
AddLayout_Dialog_Menu | Adds the predefined layout which contains one dialog and standard menu.
AddLayout_Dialog_ToolBarMenu_ToolBar | Adds the predefined layout which contains one dialog, menu as tool bar and tool bar.
AddLayout_OptionsList_Menu_BottomDialog_RightDialog | Adds the predefined layout which contains options list, first dialog on the right side, secound dialog on the bottom and standard menu.
AddLayout_OptionsList_Menu_BottomDialog_RightDialogAndHtmlNoteOnTabs | Adds the predefined layout which contains options list, dialog and html note on tabs on the right side, secound dialog on the bottom and standard menu.
AddLayout_OptionsList_Menu_RightDialog | Adds the predefined layout which contains options list, one dialog and standard menu.
AddLayout_OptionsList_Menu_RightDialogAndViewAndHtmlNoteOnTabs | Adds the predefined layout which contains options list, one dialog, view (or dialog), html note on tabs and standard menu.
AddLayout_OptionsList_Menu_RightDialogAndViewOnTabs | Adds the predefined layout which contains options list, one dialog and view (or dialog) on tabs and standard menu.
AddLayout_OptionsList_ToolBarMenu_ToolBar_BottomDialog_RightDialog | Adds the predefined layout which contains options list, first dialog on the right side and secound dialog on the bottom, tool bar as menu and tool bar.
AddLayout_OptionsList_ToolBarMenu_ToolBar_BottomDialog_RightDialogAndHtmlNoteOnTabs | Adds the predefined layout which contains options list, dialog and html note on tabs on the right side, secound dialog on the bottom and tool bar as menu and tool bar.
AddLayout_OptionsList_ToolBarMenu_ToolBar_RightDialog | Adds the predefined layout which contains options list, one dialog, tool bar as menu and tool bar.
AddLayout_OptionsList_ToolBarMenu_ToolBar_RightDialogAndViewOnTabs | Adds the predefined layout which contains options list, dialog and view (or dialog) on tabs, tool bar as menu and tool bar.
CalculateMainControlSize | This is CalculateMainControlSize, a member of class REXLayout.
Clear | Clears all layouts items.
DeSelect | Called after deselect the specified LayoutItem.
DeSelect | This is DeSelect, a member of class REXLayout.
DisposeControls | Disposes all controls in all added layouts.
GetItem | Gets the layout item identified by mame.
GetLayoutIndex | Gets the index of the layout.
GetLayoutItem | This is GetLayoutItem, a member of class REXLayout.
InsertLayout | Adds the layout.
RemoveLayout | Removes the layout.
Select | Called after select the specified LayoutItem.
Select | This is Select, a member of class REXLayout.
SelectLayout | Selects the layout.
Setup | Setups layout and all layout's items.
ToolboxDeSelect | This is ToolboxDeSelect, a member of class REXLayout.
ToolboxGetItem | This is ToolboxGetItem, a member of class REXLayout.
ToolboxRemoveLayout | This is ToolboxRemoveLayout, a member of class REXLayout.
ToolboxSelect | This is ToolboxSelect, a member of class REXLayout.
ToolboxSelectLayout | This is ToolboxSelectLayout, a member of class REXLayout.
ToolboxSetup | This is ToolboxSetup, a member of class REXLayout.
ToolboxSetup | This is ToolboxSetup, a member of class REXLayout.
ToolboxUpdate | This is ToolboxUpdate, a member of class REXLayout.
Update | Updates layout all layout's items.


REXLayout Properties

REXLayout Properties
REXLayout Class Legend
REXLayout Properties
REXLayout Properties | Description
CommandsOptions | Gets or sets the options for commands.
CommandsOptionsByEnum | Gets or sets the options for commands.
ConstOptions | Gets or sets the const options for all layouts.
ConstOptionsByEnum | Gets or sets the const options for all layouts.
Count | Gets the count of layout items.
Current | Gets the current layout item.
DefaultOptions | Gets or sets the default options for layout.
DisableEvents | Gets a value indicating whether events are disabled.


REXLayout Class Public Methods

REXLayout Class Public Methods
REXLayout Class Legend
Public Methods
Public Method | Description
REXLayout | Initializes a new instance of the REXLayout class.


REXLayoutItem Enumerations

REXLayoutItem Enumerations
REXLayoutItem Class Legend
REXLayoutItem Enumerations
REXLayoutItem Enumerations | Description
LayoutType | Determines type of layout item.


REXLayoutItem Fields

REXLayoutItem Fields
REXLayoutItem Class Legend
REXLayoutItem Fields
REXLayoutItem Fields | Description
ActiveTabPage | Gets or sets ActiveTabPage attribute of layout.
Description | Gets or sets Description attribute of layout.
Dialog | Gets or sets Dialog attribute of layout.
DisableCommands | Gets or sets DisableCommands attribute of layout.
GroupName | Gets or sets GroupName attribute of layout.
LayoutImage | Gets or sets LayoutImage attribute of layout.
Name | Gets or sets Name attribute of layout.
Options | Gets or sets Options attribute of layout.
Type | Gets or sets Type attribute of layout.
View | Gets or sets View attribute of layout.
Visible | Gets or sets visibility attribute of layout.


Legend

Legend
REXLayoutItem Class
Legend
Constructor
Enumeration
Data Member
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXLayoutItem Class Members

REXLayoutItem Class Members
REXLayoutItem Class Legend
Members
Public Methods
Public Method | Description
REXLayoutItem | Initializes a new instance of the REXLayoutItem class.
REXLayoutItem | Initializes a new instance of the REXLayoutItem class.
REXLayoutItem | Initializes a new instance of the REXLayoutItem class.
REXLayoutItem | Initializes a new instance of the REXLayoutItem class.
REXLayoutItem | Initializes a new instance of the REXLayoutItem class.
REXLayoutItem | Initializes a new instance of the REXLayoutItem class.
REXLayoutItem | Initializes a new instance of the REXLayoutItem class.
REXLayoutItem | Initializes a new instance of the REXLayoutItem class.
REXLayoutItem | Initializes a new instance of the REXLayoutItem class.
REXLayoutItem Enumerations
REXLayoutItem Enumerations | Description
LayoutType | Determines type of layout item.
REXLayoutItem Fields
REXLayoutItem Fields | Description
ActiveTabPage | Gets or sets ActiveTabPage attribute of layout.
Description | Gets or sets Description attribute of layout.
Dialog | Gets or sets Dialog attribute of layout.
DisableCommands | Gets or sets DisableCommands attribute of layout.
GroupName | Gets or sets GroupName attribute of layout.
LayoutImage | Gets or sets LayoutImage attribute of layout.
Name | Gets or sets Name attribute of layout.
Options | Gets or sets Options attribute of layout.
Type | Gets or sets Type attribute of layout.
View | Gets or sets View attribute of layout.
Visible | Gets or sets visibility attribute of layout.
REXLayoutItem Properties
REXLayoutItem Properties | Description
DefaultDialogSize | Gets the default size of the dialog.
DefaultViewSize | Gets the default size of the view.


Members

Legend
Legend
Constructor
Enumeration
Data Member
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXLayoutItem Properties

REXLayoutItem Properties
REXLayoutItem Class Legend
REXLayoutItem Properties
REXLayoutItem Properties | Description
DefaultDialogSize | Gets the default size of the dialog.
DefaultViewSize | Gets the default size of the view.


REXLayoutItem Class Public Methods

REXLayoutItem Class Public Methods
REXLayoutItem Class Legend
Public Methods
Public Method | Description
REXLayoutItem | Initializes a new instance of the REXLayoutItem class.
REXLayoutItem | Initializes a new instance of the REXLayoutItem class.
REXLayoutItem | Initializes a new instance of the REXLayoutItem class.
REXLayoutItem | Initializes a new instance of the REXLayoutItem class.
REXLayoutItem | Initializes a new instance of the REXLayoutItem class.
REXLayoutItem | Initializes a new instance of the REXLayoutItem class.
REXLayoutItem | Initializes a new instance of the REXLayoutItem class.
REXLayoutItem | Initializes a new instance of the REXLayoutItem class.
REXLayoutItem | Initializes a new instance of the REXLayoutItem class.


Legend

Legend
REXLogger Class
Legend
Method
static


REXLogger Class Members

REXLogger Class Members
REXLogger Class Legend
Members
REXLogger Methods
REXLogger Methods | Description
Log | This is Log, a member of class REXLogger.
Log | This is Log, a member of class REXLogger.
Log | This is Log, a member of class REXLogger.
Log | This is Log, a member of class REXLogger.
Log | This is Log, a member of class REXLogger.
Log | This is Log, a member of class REXLogger.
Log | This is Log, a member of class REXLogger.
Log | Logs specified warning.
Log | Logs specified warning and message.


REXLogger Methods

REXLogger Methods
REXLogger Class Legend
REXLogger Methods
REXLogger Methods | Description
Log | This is Log, a member of class REXLogger.
Log | This is Log, a member of class REXLogger.
Log | This is Log, a member of class REXLogger.
Log | This is Log, a member of class REXLogger.
Log | This is Log, a member of class REXLogger.
Log | This is Log, a member of class REXLogger.
Log | This is Log, a member of class REXLogger.
Log | Logs specified warning.
Log | Logs specified warning and message.


Legend

Legend
REXResults Class
Legend
Constructor
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXResults Class Members

REXResults Class Members
REXResults Class Legend
Members
Public Methods
Public Method | Description
REXResults | Initializes a new instance of a REXResults class.


REXResults Class Public Methods

REXResults Class Public Methods
REXResults Class Legend
Public Methods
Public Method | Description
REXResults | Initializes a new instance of a REXResults class.


REXRevitAccess Classes

REXRevitAccess Classes
REXRevitAccess Class Legend
REXRevitAccess Classes
REXRevitAccess Classes | Description
Versions | Constants for all known versions.


REXRevitAccess Enumerations

REXRevitAccess Enumerations
REXRevitAccess Class Legend
REXRevitAccess Enumerations
REXRevitAccess Enumerations | Description
CompareVersionsResult | Dedicated enum for compare Revit's version.


REXRevitAccess Fields

REXRevitAccess Fields
REXRevitAccess Class Legend
REXRevitAccess Fields
REXRevitAccess Fields | Description
AutoSelectionRestore | This is AutoSelectionRestore, a member of class REXRevitAccess.
UsingParameters | This is UsingParameters, a member of class REXRevitAccess.


Legend

Legend
REXRevitAccess Class
Legend
Constructor
Class
Enumeration
Data Member
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXRevitAccess Class Members

REXRevitAccess Class Members
REXRevitAccess Class Legend
Members
Public Methods
Public Method | Description
REXRevitAccess | Initializes a new instance of the REXRevitAccess class.
REXRevitAccess Classes
REXRevitAccess Classes | Description
Versions | Constants for all known versions.
REXRevitAccess Enumerations
REXRevitAccess Enumerations | Description
CompareVersionsResult | Dedicated enum for compare Revit's version.
REXRevitAccess Fields
REXRevitAccess Fields | Description
AutoSelectionRestore | This is AutoSelectionRestore, a member of class REXRevitAccess.
UsingParameters | This is UsingParameters, a member of class REXRevitAccess.
REXRevitAccess Methods
REXRevitAccess Methods | Description
Application | Access to Autodesk.Revit.ApplicationServices.ApplicationServices.Application object.
CommandData | Access to Autodesk.Revit.ExternalCommandData.
CompareVersions | Compares the versions.
Create | Reads some data from Revit and sets system display units.
Destroy | Destroys and resets some objects connected to Revit.
Detach | Detaches this instance.
Elements | Access to Autodesk.Revit.ExternalCommandData.
Event | Events the specified ev.
Initialize | Initializes this instance.
Message | Access to message string from Autodesk.Revit.IExternalCommand.Execute command.
Update | Reads some data from Revit and set system display units.
UpdaterData | Access to updater data (in update context only).
REXRevitAccess Properties
REXRevitAccess Properties | Description
ActiveDocument | Actives the UI document.
ActiveUIDocument | Actives the UI document.
EventService | This is EventService, a member of class REXRevitAccess.
IsArchitecture | This is IsArchitecture, a member of class REXRevitAccess.
IsMEP | This is IsMEP, a member of class REXRevitAccess.
IsStructure | This is IsStructure, a member of class REXRevitAccess.
Parameters | Access to REX parameters.
Selection | Actives the UI document.
ThisApplication | This is ThisApplication, a member of class REXRevitAccess.
ThisContext | This is ThisContext, a member of class REXRevitAccess.
ThisExtension | This is ThisExtension, a member of class REXRevitAccess.
UIApplication | UIs the application.


Members

Legend
Legend
Constructor
Class
Enumeration
Data Member
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXRevitAccess Methods

REXRevitAccess Methods
REXRevitAccess Class Legend
REXRevitAccess Methods
REXRevitAccess Methods | Description
Application | Access to Autodesk.Revit.ApplicationServices.ApplicationServices.Application object.
CommandData | Access to Autodesk.Revit.ExternalCommandData.
CompareVersions | Compares the versions.
Create | Reads some data from Revit and sets system display units.
Destroy | Destroys and resets some objects connected to Revit.
Detach | Detaches this instance.
Elements | Access to Autodesk.Revit.ExternalCommandData.
Event | Events the specified ev.
Initialize | Initializes this instance.
Message | Access to message string from Autodesk.Revit.IExternalCommand.Execute command.
Update | Reads some data from Revit and set system display units.
UpdaterData | Access to updater data (in update context only).


REXRevitAccess Properties

REXRevitAccess Properties
REXRevitAccess Class Legend
REXRevitAccess Properties
REXRevitAccess Properties | Description
ActiveDocument | Actives the UI document.
ActiveUIDocument | Actives the UI document.
EventService | This is EventService, a member of class REXRevitAccess.
IsArchitecture | This is IsArchitecture, a member of class REXRevitAccess.
IsMEP | This is IsMEP, a member of class REXRevitAccess.
IsStructure | This is IsStructure, a member of class REXRevitAccess.
Parameters | Access to REX parameters.
Selection | Actives the UI document.
ThisApplication | This is ThisApplication, a member of class REXRevitAccess.
ThisContext | This is ThisContext, a member of class REXRevitAccess.
ThisExtension | This is ThisExtension, a member of class REXRevitAccess.
UIApplication | UIs the application.


REXRevitAccess Class Public Methods

REXRevitAccess Class Public Methods
REXRevitAccess Class Legend
Public Methods
Public Method | Description
REXRevitAccess | Initializes a new instance of the REXRevitAccess class.


Versions Fields

Versions Fields
REXRevitAccess.Versions Class Legend
Versions Fields
Versions Fields | Description
v2008 |
v2008_SP1 |
v2008_SP2 |
v2008_SP3 |
v2008_SP4 |
v2009_A |
v2009_A2 |


Legend

Legend
REXRevitAccess.Versions Class
Legend
Data Member
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXRevitAccess.Versions Class Members

REXRevitAccess.Versions Class Members
REXRevitAccess.Versions Class Legend
Members
Versions Fields
Versions Fields | Description
v2008 |
v2008_SP1 |
v2008_SP2 |
v2008_SP3 |
v2008_SP4 |
v2009_A |
v2009_A2 |


Members

Legend
Legend
Data Member
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


Legend

Legend
REXRevitContextAccess Class
Legend
Constructor
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXRevitContextAccess Class Members

REXRevitContextAccess Class Members
REXRevitContextAccess Class Legend
Members
Public Methods
Public Method | Description
REXRevitContextAccess | This is REXRevitContextAccess, a member of class REXRevitContextAccess.
REXRevitContextAccess Methods
REXRevitContextAccess Methods | Description
Create | Reads some data from parent application and set system display units.
Destroy | Destroys and resets some objects connected to parent application.
Event | Events the specified ev.
Initialize | Initializes this instance.
Update | Reads some data from parent application and set system display units.


REXRevitContextAccess Methods

REXRevitContextAccess Methods
REXRevitContextAccess Class Legend
REXRevitContextAccess Methods
REXRevitContextAccess Methods | Description
Create | Reads some data from parent application and set system display units.
Destroy | Destroys and resets some objects connected to parent application.
Event | Events the specified ev.
Initialize | Initializes this instance.
Update | Reads some data from parent application and set system display units.


REXRevitContextAccess Class Public Methods

REXRevitContextAccess Class Public Methods
REXRevitContextAccess Class Legend
Public Methods
Public Method | Description
REXRevitContextAccess | This is REXRevitContextAccess, a member of class REXRevitContextAccess.


REXUI Enumerations

REXUI Enumerations
REXUI Class Legend
REXUI Enumerations
REXUI Enumerations | Description
CommandOptions | Identifies commands settings on the user interface.
SetupOptions | Identifies all elements of user interface.


REXUI Fields

REXUI Fields
REXUI Class Legend
REXUI Fields
REXUI Fields | Description
NameDialog | Name of dialog's container.
NameHSplit | Name of horizontal splitter.
NameHSplitGrid | Name of horizontal splitter.
NameHSplitGridBottom | Name of vertical splitter.
NameHSplitGridTop | Name of vertical splitter.
NameList | Name of list of options.
NameListImageListLarge | Name of large list of large images (32 x 32 pixels).
NameListImageListSmall | Name of large list of small images (16 x 16 pixels).
NameLogo | Name of logo's container.
NameMainPanel | Name of main panel which contains all controls.
NameMenu | Name of menu bar.
NameNote | Name of note's container.
NameRightContainer | Name of inner tool strip container.
NameStatus | Name of status bar.
NameStatusHeaderLabel | Name of label which represents header placed on status bar.
NameStatusLabel | Name of label placed on status bar.
NameStatusProgress | Name of progress placed on status bar.
NameTabControl | Name of tab control.
NameTabDialog | Name of tab dialog.
NameTabNote | Name of tab note.
NameTabView | Name of tab view.
NameToolBar | Name of tool bar.
NameToolBarInner | Name of inner tool bar.
NameToolbox | Name of toolbox control.
NameToolMenu | Name of menu bar based on tool bar.
NameView | Name of view's container.
NameVSplit | Name of vertical splitter.
NameVSplitGrid | Name of vertical splitter.
NameVSplitGridLeft | Name of vertical splitter.
NameVSplitGridRight | Name of vertical splitter.


Fields (AutoDoc Folder)

Legend
Legend
Data Member
static


Legend

Legend
REXUI Class
Legend
Constructor
Enumeration
Data Member
static
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXUI Class Members

REXUI Class Members
REXUI Class Legend
Members
Public Methods
Public Method | Description
REXUI | Initializes a new instance of the REXUI class.
REXUI Enumerations
REXUI Enumerations | Description
CommandOptions | Identifies commands settings on the user interface.
SetupOptions | Identifies all elements of user interface.
REXUI Fields
REXUI Fields | Description
NameDialog | Name of dialog's container.
NameHSplit | Name of horizontal splitter.
NameHSplitGrid | Name of horizontal splitter.
NameHSplitGridBottom | Name of vertical splitter.
NameHSplitGridTop | Name of vertical splitter.
NameList | Name of list of options.
NameListImageListLarge | Name of large list of large images (32 x 32 pixels).
NameListImageListSmall | Name of large list of small images (16 x 16 pixels).
NameLogo | Name of logo's container.
NameMainPanel | Name of main panel which contains all controls.
NameMenu | Name of menu bar.
NameNote | Name of note's container.
NameRightContainer | Name of inner tool strip container.
NameStatus | Name of status bar.
NameStatusHeaderLabel | Name of label which represents header placed on status bar.
NameStatusLabel | Name of label placed on status bar.
NameStatusProgress | Name of progress placed on status bar.
NameTabControl | Name of tab control.
NameTabDialog | Name of tab dialog.
NameTabNote | Name of tab note.
NameTabView | Name of tab view.
NameToolBar | Name of tool bar.
NameToolBarInner | Name of inner tool bar.
NameToolbox | Name of toolbox control.
NameToolMenu | Name of menu bar based on tool bar.
NameView | Name of view's container.
NameVSplit | Name of vertical splitter.
NameVSplitGrid | Name of vertical splitter.
NameVSplitGridLeft | Name of vertical splitter.
NameVSplitGridRight | Name of vertical splitter.
REXUI Methods
REXUI Methods | Description
AddToolStrip | Adds the tool strip to repositioning.
FindHiddenCommand | Determines whether the input command is hidden.
FindHiddenCommand | Finds the hidden command.
GetAboutLink | Gets the about link.
GetDialog | Gets the dialog control.
GetHelpLink | Gets the help link.
GetList | This is GetList, a member of class REXUI.
GetLogo | Gets the reference to PictureBox which contains logo.
GetMenu | Gets the menu control.
GetMenuBar | Gets the menu bar.
GetNote | Gets the note control.
GetNoteWebBrowser | Gets the note web browser control.
GetStatus | Gets the status control.
GetStatusHeaderLabel | Gets the status header label.
GetStatusLabel | Gets the status label.
GetStatusProgress | Gets the status progress.
GetToolBar | Gets the tool bar.
GetToolBarInner | Gets the tool bar inner.
GetToolbox | Gets the toolbox control.
GetViewer | Gets the viewer's container.
GetWindow | Gets the reference to main form.
HideAboutControls | This is HideAboutControls, a member of class REXUI.
HideAboutLink | Hides the about link.
HideCommand | Hides the command.
HideCommand | Hides the command.
HideHelpLink | Hides the help link.
LoadNoteUrl | Loads the URL to note control.
RememberControl | Remembers the active tab control in specified LayoutItem in ActivTabPage property.
SetLogo | Sets the logo image.
SetupControl | Setups the main control according to default settings.
SetupControl | Setups the main control according to layout item settings.
ShowCommand | Shows the command.
ShowCommand | Shows the command.
REXUI Properties
REXUI Properties | Description
MainControl | Gets or sets the main control.
MainWindow | Gets or sets the main form.


Members

Legend
Legend
Constructor
Enumeration
Data Member
static
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXUI Methods

REXUI Methods
REXUI Class Legend
REXUI Methods
REXUI Methods | Description
AddToolStrip | Adds the tool strip to repositioning.
FindHiddenCommand | Determines whether the input command is hidden.
FindHiddenCommand | Finds the hidden command.
GetAboutLink | Gets the about link.
GetDialog | Gets the dialog control.
GetHelpLink | Gets the help link.
GetList | This is GetList, a member of class REXUI.
GetLogo | Gets the reference to PictureBox which contains logo.
GetMenu | Gets the menu control.
GetMenuBar | Gets the menu bar.
GetNote | Gets the note control.
GetNoteWebBrowser | Gets the note web browser control.
GetStatus | Gets the status control.
GetStatusHeaderLabel | Gets the status header label.
GetStatusLabel | Gets the status label.
GetStatusProgress | Gets the status progress.
GetToolBar | Gets the tool bar.
GetToolBarInner | Gets the tool bar inner.
GetToolbox | Gets the toolbox control.
GetViewer | Gets the viewer's container.
GetWindow | Gets the reference to main form.
HideAboutControls | This is HideAboutControls, a member of class REXUI.
HideAboutLink | Hides the about link.
HideCommand | Hides the command.
HideCommand | Hides the command.
HideHelpLink | Hides the help link.
LoadNoteUrl | Loads the URL to note control.
RememberControl | Remembers the active tab control in specified LayoutItem in ActivTabPage property.
SetLogo | Sets the logo image.
SetupControl | Setups the main control according to default settings.
SetupControl | Setups the main control according to layout item settings.
ShowCommand | Shows the command.
ShowCommand | Shows the command.


REXUI Properties

REXUI Properties
REXUI Class Legend
REXUI Properties
REXUI Properties | Description
MainControl | Gets or sets the main control.
MainWindow | Gets or sets the main form.


REXUI Class Public Methods

REXUI Class Public Methods
REXUI Class Legend
Public Methods
Public Method | Description
REXUI | Initializes a new instance of the REXUI class.


REXVersion Fields

REXVersion Fields
REXVersion Class Legend
REXVersion Fields
REXVersion Fields | Description
DedicatedVersionName | Dedicated version name (2009, 2010, etx).


Legend

Legend
REXVersion Class
Legend
Data Member
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXVersion Class Members

REXVersion Class Members
REXVersion Class Legend
Members
REXVersion Fields
REXVersion Fields | Description
DedicatedVersionName | Dedicated version name (2009, 2010, etx).


REXWarnings Enumerations

REXWarnings Enumerations
REXWarnings Class Legend
REXWarnings Enumerations
REXWarnings Enumerations | Description
WarningCode | This is record REX.Common.REXWarnings.WarningCode.


Legend

Legend
REXWarnings Class
Legend
Structure
Enumeration
Method
static


REXWarnings Class Members

REXWarnings Class Members
REXWarnings Class Legend
Members
REXWarnings Structures
REXWarnings Structures | Description
errMapStr | This is class REX.Common.REXWarnings.errMapStr.
REXWarnings Enumerations
REXWarnings Enumerations | Description
WarningCode | This is record REX.Common.REXWarnings.WarningCode.
REXWarnings Methods
REXWarnings Methods | Description
GetMessage | This is GetMessage, a member of class REXWarnings.


Members

Legend
Legend
Structure
Enumeration
Method
static


REXWarnings Methods

REXWarnings Methods
REXWarnings Class Legend
REXWarnings Methods
REXWarnings Methods | Description
GetMessage | This is GetMessage, a member of class REXWarnings.


REXWarnings Structures

REXWarnings Structures
REXWarnings Class Legend
REXWarnings Structures
REXWarnings Structures | Description
errMapStr | This is class REX.Common.REXWarnings.errMapStr.


errMapStr Fields

errMapStr Fields
REXWarnings.errMapStr Structure Legend
errMapStr Fields
errMapStr Fields | Description
ecode | This is ecode, a member of class errMapStr.
msg | This is msg, a member of class errMapStr.


Legend

Legend
REXWarnings.errMapStr Structure
Legend
Constructor
Data Member
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXWarnings.errMapStr Structure Members

REXWarnings.errMapStr Structure Members
REXWarnings.errMapStr Structure Legend
Members
Public Methods
Public Method | Description
errMapStr | This is errMapStr, a member of class errMapStr.
errMapStr Fields
errMapStr Fields | Description
ecode | This is ecode, a member of class errMapStr.
msg | This is msg, a member of class errMapStr.


REXWarnings.errMapStr Structure Public Methods

REXWarnings.errMapStr Structure Public Methods
REXWarnings.errMapStr Structure Legend
Public Methods
Public Method | Description
errMapStr | This is errMapStr, a member of class errMapStr.


REXWebBrowser Fields

REXWebBrowser Fields
REXWebBrowser Class Legend
REXWebBrowser Fields
REXWebBrowser Fields | Description
ThreadRef | The reference to thread.
URL | The URL for html page.
WB | The reference to WebBrowser object.


Legend

Legend
REXWebBrowser Class
Legend
Data Member
Method
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXWebBrowser Class Members

REXWebBrowser Class Members
REXWebBrowser Class Legend
Members
REXWebBrowser Fields
REXWebBrowser Fields | Description
ThreadRef | The reference to thread.
URL | The URL for html page.
WB | The reference to WebBrowser object.
REXWebBrowser Methods
REXWebBrowser Methods | Description
Start | Starts thread and loads html page on thread.
StartThread | Starts the thread.


Members

Legend
Legend
Data Member
Method
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXWebBrowser Methods

REXWebBrowser Methods
REXWebBrowser Class Legend
REXWebBrowser Methods
REXWebBrowser Methods | Description
Start | Starts thread and loads html page on thread.
StartThread | Starts the thread.


REX.ContentGenerator.Converters Namespace Classes

REX.ContentGenerator.Converters Namespace Classes
REX.ContentGenerator.Converters Namespace Legend
Classes
Class | Description
FieldParams | Represents parameters of the field.
REXContentFilter | Base class for all filters.
REXContentLogicFilter | Describes a logic filter.
REXContentParamFilter | Describes the filter for the specified parameter.
REXCustomFactory | This is class REX.ContentGenerator.Converters.REXCustomFactory.
REXDBSectionFactory | This is class REX.ContentGenerator.Converters.REXDBSectionFactory.
REXFamilyConverter | This class represents a converter which provides access to common databases.
REXMaterialFactory | This is class REX.ContentGenerator.Converters.REXMaterialFactory.
REXParamSectionFactory | This is class REX.ContentGenerator.Converters.REXParamSectionFactory.
RVTCommonSectionFactory | This is class REX.ContentGenerator.Converters.RVTCommonSectionFactory.
RVTCustomFactory | This is class REX.ContentGenerator.Converters.RVTCustomFactory.
RVTDBSectionFactory | This is class REX.ContentGenerator.Converters.RVTDBSectionFactory.
RVTFamilyConverter | This class represents a converter which provides access to Revit project.
RVTMaterialFactory | This is class REX.ContentGenerator.Converters.RVTMaterialFactory.
RVTMaterialPropertySetFactory | This is class REX.ContentGenerator.Converters.RVTMaterialPropertySetFactory.
RVTSectionFactory | This is class REX.ContentGenerator.Converters.RVTSectionFactory.
RVTSectionParamFactory | This is class REX.ContentGenerator.Converters.RVTSectionParamFactory.


Classes (AutoDoc Folder)

Legend
Legend
Class
abstract


REX.ContentGenerator.Converters Namespace Interfaces

REX.ContentGenerator.Converters Namespace Interfaces
REX.ContentGenerator.Converters Namespace Legend
Interfaces
Interface | Description
IRexContentSettings | Provides interface for the settings of the REXFamilyConverter.
IRvtContentSettings | Provides interface for the settings of the RVTFamilyConverter.


Legend

Legend
REX.ContentGenerator.Converters Namespace
Legend
Class
abstract
Interface
Enumeration
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REX.ContentGenerator.Converters Namespace Structs, Records, Enums

REX.ContentGenerator.Converters Namespace Structs, Records, Enums
REX.ContentGenerator.Converters Namespace Legend
Structs, Records, Enums
Struct, Record, Enum | Description
EDBAccess | Describes the access to databases.


Structs, Records, Enums (AutoDoc Folder)

Legend
Legend
Enumeration
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REX.ContentGenerator.Converters Namespace Types

REX.ContentGenerator.Converters Namespace Types
REX.ContentGenerator.Converters Namespace
Types
Type | Description
ElementGenerated | Delagate for the generation event (when the list of elements is used).


Legend

Legend
FieldParams Class
Legend
Constructor
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


FieldParams Class Members

FieldParams Class Members
FieldParams Class Legend
Members
Public Methods
Public Method | Description
FieldParams | Initializes a new instance of the FieldParams class.
FieldParams Methods
FieldParams Methods | Description
GetDefaultValue | Gets the default value.
GetDefaultValue | Gets the default value.
FieldParams Properties
FieldParams Properties | Description
database | Gets or sets the name in database.
display | Gets or sets the display name.
identity | Gets or sets a value indicating whether this field is used for identification.
name | Gets or sets the name.
power | Gets or sets the power.
template | Gets or sets a value indicating whether this field is used for template identification.
unitName | Gets or sets the name of the unit.
visible | Gets or sets a value indicating whether this FieldParams is visible.


FieldParams Methods

FieldParams Methods
FieldParams Class Legend
FieldParams Methods
FieldParams Methods | Description
GetDefaultValue | Gets the default value.
GetDefaultValue | Gets the default value.


FieldParams Properties

FieldParams Properties
FieldParams Class Legend
FieldParams Properties
FieldParams Properties | Description
database | Gets or sets the name in database.
display | Gets or sets the display name.
identity | Gets or sets a value indicating whether this field is used for identification.
name | Gets or sets the name.
power | Gets or sets the power.
template | Gets or sets a value indicating whether this field is used for template identification.
unitName | Gets or sets the name of the unit.
visible | Gets or sets a value indicating whether this FieldParams is visible.


FieldParams Class Public Methods

FieldParams Class Public Methods
FieldParams Class Legend
Public Methods
Public Method | Description
FieldParams | Initializes a new instance of the FieldParams class.


Legend

Legend
IRexContentSettings Interface
Legend
Method
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


IRexContentSettings Interface Members

IRexContentSettings Interface Members
IRexContentSettings Interface Legend
Members
IRexContentSettings Methods
IRexContentSettings Methods | Description
GetParamsForDisplayName | Gets parameters for the specified display name of the specified category.
GetParamsForField | Gets parameters for the specified name of the specified category.
GetResource | Gets the resource for the specified name of the specified category.
LoadCustomParametersFile | Loads the custom parameters file.
IRexContentSettings Properties
IRexContentSettings Properties | Description
CodeFilteredShapeAnalysis | Gets or sets a value indicating whether the filtered list of rebar shapes should be taken to consideration during rebars analysis.
DatabaseAccess | Gets or sets the database access.
Labels | Gets or sets a value indicating whether labels are taken to consideration during mapping.
MirroredShapeAnalysis | Gets or sets a value indicating whether mirrored rebar shapes should be taken to consideration during rebars analysis.
MultiSearch | Gets or sets a value indicating whether during searching databases multiply result should be returned (if false - when first result is found algorithm will stop - In case of GetDBList(List…) function will stop if any REXFamilyType in database will be found) .
MultiThread | Gets or sets a value indicating whether multithread operations should be used for database searching (only if DbRoot is used)..
ReleaseDBAfterEachAction | Gets or sets a value indicating whether the database should be released after each action (if not it will be kept in memory).
SupportUserDatabases | Gets or sets a value indicating whether users databases should be supported


IRexContentSettings Methods

IRexContentSettings Methods
IRexContentSettings Interface Legend
IRexContentSettings Methods
IRexContentSettings Methods | Description
GetParamsForDisplayName | Gets parameters for the specified display name of the specified category.
GetParamsForField | Gets parameters for the specified name of the specified category.
GetResource | Gets the resource for the specified name of the specified category.
LoadCustomParametersFile | Loads the custom parameters file.


IRexContentSettings Properties

IRexContentSettings Properties
IRexContentSettings Interface Legend
IRexContentSettings Properties
IRexContentSettings Properties | Description
CodeFilteredShapeAnalysis | Gets or sets a value indicating whether the filtered list of rebar shapes should be taken to consideration during rebars analysis.
DatabaseAccess | Gets or sets the database access.
Labels | Gets or sets a value indicating whether labels are taken to consideration during mapping.
MirroredShapeAnalysis | Gets or sets a value indicating whether mirrored rebar shapes should be taken to consideration during rebars analysis.
MultiSearch | Gets or sets a value indicating whether during searching databases multiply result should be returned (if false - when first result is found algorithm will stop - In case of GetDBList(List…) function will stop if any REXFamilyType in database will be found) .
MultiThread | Gets or sets a value indicating whether multithread operations should be used for database searching (only if DbRoot is used)..
ReleaseDBAfterEachAction | Gets or sets a value indicating whether the database should be released after each action (if not it will be kept in memory).
SupportUserDatabases | Gets or sets a value indicating whether users databases should be supported


Legend

Legend
IRvtContentSettings Interface
Legend
Method
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


IRvtContentSettings Interface Members

IRvtContentSettings Interface Members
IRvtContentSettings Interface Legend
Members
IRvtContentSettings Methods
IRvtContentSettings Methods | Description
Clean | Cleans temporary files.
LoadCustomParametersFile | Loads the custom parameters file.
SetLanguage | Sets the language for created families (names of families will be translated according to this) - “en-US”, “pl-PL” etc.
IRvtContentSettings Properties
IRvtContentSettings Properties | Description
BufferElements | Gets or sets a value indicating whether elements should be buffered after investigation – using RevitId.
CreateNewElement | Gets or sets a value indicating whether a new family should be created if the element wasn’t found among existing ones.
IgnoreFamilyNameLanguage | Gets or sets a value indicating whether language should be taken to consideration during element search (language set by SetLanguage function).
Labels | Gets or sets a value indicating whether labels should be taken to consideration during mapping.
RebarPostGenerateCorrection | Gets or sets a value indicating whether correction of rebar geometry should be made after generation process.
SupportUserDatabases | Gets or sets a value indicating whether users databases should be supported
Update | Gets or sets a value indicating whether element found in the project (if it already exists) should be updated with new data.


IRvtContentSettings Methods

IRvtContentSettings Methods
IRvtContentSettings Interface Legend
IRvtContentSettings Methods
IRvtContentSettings Methods | Description
Clean | Cleans temporary files.
LoadCustomParametersFile | Loads the custom parameters file.
SetLanguage | Sets the language for created families (names of families will be translated according to this) - “en-US”, “pl-PL” etc.


IRvtContentSettings Properties

IRvtContentSettings Properties
IRvtContentSettings Interface Legend
IRvtContentSettings Properties
IRvtContentSettings Properties | Description
BufferElements | Gets or sets a value indicating whether elements should be buffered after investigation – using RevitId.
CreateNewElement | Gets or sets a value indicating whether a new family should be created if the element wasn’t found among existing ones.
IgnoreFamilyNameLanguage | Gets or sets a value indicating whether language should be taken to consideration during element search (language set by SetLanguage function).
Labels | Gets or sets a value indicating whether labels should be taken to consideration during mapping.
RebarPostGenerateCorrection | Gets or sets a value indicating whether correction of rebar geometry should be made after generation process.
SupportUserDatabases | Gets or sets a value indicating whether users databases should be supported
Update | Gets or sets a value indicating whether element found in the project (if it already exists) should be updated with new data.


REXContentLogicFilter Enumerations

REXContentLogicFilter Enumerations
REXContentLogicFilter Class Legend
REXContentLogicFilter Enumerations
REXContentLogicFilter Enumerations | Description
ELogicOperator | Describes operators.


Legend

Legend
REXContentLogicFilter Class
Legend
Constructor
Enumeration
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXContentLogicFilter Class Members

REXContentLogicFilter Class Members
REXContentLogicFilter Class Legend
Members
Public Methods
Public Method | Description
REXContentLogicFilter | Initializes a new instance of the REXContentLogicFilter class.
REXContentLogicFilter | Initializes a new instance of the REXContentLogicFilter class.
REXContentLogicFilter Enumerations
REXContentLogicFilter Enumerations | Description
ELogicOperator | Describes operators.
REXContentLogicFilter Properties
REXContentLogicFilter Properties | Description
Filters | Gets or sets the filters.
LogicOperator | Gets or sets the logic operator.


REXContentLogicFilter Properties

REXContentLogicFilter Properties
REXContentLogicFilter Class Legend
REXContentLogicFilter Properties
REXContentLogicFilter Properties | Description
Filters | Gets or sets the filters.
LogicOperator | Gets or sets the logic operator.


REXContentLogicFilter Class Public Methods

REXContentLogicFilter Class Public Methods
REXContentLogicFilter Class Legend
Public Methods
Public Method | Description
REXContentLogicFilter | Initializes a new instance of the REXContentLogicFilter class.
REXContentLogicFilter | Initializes a new instance of the REXContentLogicFilter class.


Legend

Legend
REXContentParamFilter Class
Legend
Constructor
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXContentParamFilter Class Members

REXContentParamFilter Class Members
REXContentParamFilter Class Legend
Members
Public Methods
Public Method | Description
REXContentParamFilter | Initializes a new instance of the REXContentParamFilter class.
REXContentParamFilter | Initializes a new instance of the REXContentParamFilter class.
REXContentParamFilter | Initializes a new instance of the REXContentParamFilter class.
REXContentParamFilter Methods
REXContentParamFilter Methods | Description
Validate | Validates the specified value due to the current filter's parameters.
REXContentParamFilter Properties
REXContentParamFilter Properties | Description
ConstraintValue | Gets or sets the constraint value.
Equal | Gets or sets a value indicating whether a parameter is to be equal to the constraint value.
Less | Gets or sets a value indicating whether a parameter is to be smaller then the constraint value.
More | Gets or sets a value indicating whether a parameter is to be larger then the constraint value.
ParamName | Gets or sets the name of the parameter which is constrained.


REXContentParamFilter Methods

REXContentParamFilter Methods
REXContentParamFilter Class Legend
REXContentParamFilter Methods
REXContentParamFilter Methods | Description
Validate | Validates the specified value due to the current filter's parameters.


REXContentParamFilter Properties

REXContentParamFilter Properties
REXContentParamFilter Class Legend
REXContentParamFilter Properties
REXContentParamFilter Properties | Description
ConstraintValue | Gets or sets the constraint value.
Equal | Gets or sets a value indicating whether a parameter is to be equal to the constraint value.
Less | Gets or sets a value indicating whether a parameter is to be smaller then the constraint value.
More | Gets or sets a value indicating whether a parameter is to be larger then the constraint value.
ParamName | Gets or sets the name of the parameter which is constrained.


REXContentParamFilter Class Public Methods

REXContentParamFilter Class Public Methods
REXContentParamFilter Class Legend
Public Methods
Public Method | Description
REXContentParamFilter | Initializes a new instance of the REXContentParamFilter class.
REXContentParamFilter | Initializes a new instance of the REXContentParamFilter class.
REXContentParamFilter | Initializes a new instance of the REXContentParamFilter class.


Legend

Legend
REXCustomFactory Class
Legend
Constructor
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXCustomFactory Class Members

REXCustomFactory Class Members
REXCustomFactory Class Legend
Members
Public Methods
Public Method | Description
REXCustomFactory | This is REXCustomFactory, a member of class REXCustomFactory.
REXCustomFactory Methods
REXCustomFactory Methods | Description
Close | This is Close, a member of class REXCustomFactory.
GetAliasName | This is GetAliasName, a member of class REXCustomFactory.
GetAllFamilies | This is GetAllFamilies, a member of class REXCustomFactory.
GetDBList | This is GetDBList, a member of class REXCustomFactory.
GetDBList | This is GetDBList, a member of class REXCustomFactory.
GetFamiliesOfAlias | This is GetFamiliesOfAlias, a member of class REXCustomFactory.
GetFamily | This is GetFamily, a member of class REXCustomFactory.
GetFamilyDefault | This is GetFamilyDefault, a member of class REXCustomFactory.
GetFamilyOfAlias | This is GetFamilyOfAlias, a member of class REXCustomFactory.
GetFamilyTemplate | This is GetFamilyTemplate, a member of class REXCustomFactory.


REXCustomFactory Methods

REXCustomFactory Methods
REXCustomFactory Class Legend
REXCustomFactory Methods
REXCustomFactory Methods | Description
Close | This is Close, a member of class REXCustomFactory.
GetAliasName | This is GetAliasName, a member of class REXCustomFactory.
GetAllFamilies | This is GetAllFamilies, a member of class REXCustomFactory.
GetDBList | This is GetDBList, a member of class REXCustomFactory.
GetDBList | This is GetDBList, a member of class REXCustomFactory.
GetFamiliesOfAlias | This is GetFamiliesOfAlias, a member of class REXCustomFactory.
GetFamily | This is GetFamily, a member of class REXCustomFactory.
GetFamilyDefault | This is GetFamilyDefault, a member of class REXCustomFactory.
GetFamilyOfAlias | This is GetFamilyOfAlias, a member of class REXCustomFactory.
GetFamilyTemplate | This is GetFamilyTemplate, a member of class REXCustomFactory.


REXCustomFactory Class Public Methods

REXCustomFactory Class Public Methods
REXCustomFactory Class Legend
Public Methods
Public Method | Description
REXCustomFactory | This is REXCustomFactory, a member of class REXCustomFactory.


Legend

Legend
REXDBSectionFactory Class
Legend
Constructor
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXDBSectionFactory Class Members

REXDBSectionFactory Class Members
REXDBSectionFactory Class Legend
Members
Public Methods
Public Method | Description
REXDBSectionFactory | This is REXDBSectionFactory, a member of class REXDBSectionFactory.
REXDBSectionFactory Methods
REXDBSectionFactory Methods | Description
CompareRows | This is CompareRows, a member of class REXDBSectionFactory.
FillDBDescription | This is FillDBDescription, a member of class REXDBSectionFactory.
FillDBObjectCollection | This is FillDBObjectCollection, a member of class REXDBSectionFactory.
FillFamilyTypeProperties | This is FillFamilyTypeProperties, a member of class REXDBSectionFactory.
FillFamilyTypeProperties | This is FillFamilyTypeProperties, a member of class REXDBSectionFactory.
GetAliasName | This is GetAliasName, a member of class REXDBSectionFactory.
GetAliasName | This is GetAliasName, a member of class REXDBSectionFactory.
GetFamiliesOfAlias | This is GetFamiliesOfAlias, a member of class REXDBSectionFactory.
GetFamilyDefault | This is GetFamilyDefault, a member of class REXDBSectionFactory.
GetFamilyOfAlias | This is GetFamilyOfAlias, a member of class REXDBSectionFactory.
GetFamilyTemplate | This is GetFamilyTemplate, a member of class REXDBSectionFactory.
GetNewDescription | This is GetNewDescription, a member of class REXDBSectionFactory.
GetNewDescription | This is GetNewDescription, a member of class REXDBSectionFactory.
GetNewFamily | This is GetNewFamily, a member of class REXDBSectionFactory.
RecalculatDBDesc | This is RecalculatDBDesc, a member of class REXDBSectionFactory.
ValidateDB | This is ValidateDB, a member of class REXDBSectionFactory.
ValidateDB | This is ValidateDB, a member of class REXDBSectionFactory.
ValidateDBADO | This is ValidateDBADO, a member of class REXDBSectionFactory.


REXDBSectionFactory Methods

REXDBSectionFactory Methods
REXDBSectionFactory Class Legend
REXDBSectionFactory Methods
REXDBSectionFactory Methods | Description
CompareRows | This is CompareRows, a member of class REXDBSectionFactory.
FillDBDescription | This is FillDBDescription, a member of class REXDBSectionFactory.
FillDBObjectCollection | This is FillDBObjectCollection, a member of class REXDBSectionFactory.
FillFamilyTypeProperties | This is FillFamilyTypeProperties, a member of class REXDBSectionFactory.
FillFamilyTypeProperties | This is FillFamilyTypeProperties, a member of class REXDBSectionFactory.
GetAliasName | This is GetAliasName, a member of class REXDBSectionFactory.
GetAliasName | This is GetAliasName, a member of class REXDBSectionFactory.
GetFamiliesOfAlias | This is GetFamiliesOfAlias, a member of class REXDBSectionFactory.
GetFamilyDefault | This is GetFamilyDefault, a member of class REXDBSectionFactory.
GetFamilyOfAlias | This is GetFamilyOfAlias, a member of class REXDBSectionFactory.
GetFamilyTemplate | This is GetFamilyTemplate, a member of class REXDBSectionFactory.
GetNewDescription | This is GetNewDescription, a member of class REXDBSectionFactory.
GetNewDescription | This is GetNewDescription, a member of class REXDBSectionFactory.
GetNewFamily | This is GetNewFamily, a member of class REXDBSectionFactory.
RecalculatDBDesc | This is RecalculatDBDesc, a member of class REXDBSectionFactory.
ValidateDB | This is ValidateDB, a member of class REXDBSectionFactory.
ValidateDB | This is ValidateDB, a member of class REXDBSectionFactory.
ValidateDBADO | This is ValidateDBADO, a member of class REXDBSectionFactory.


REXDBSectionFactory Class Public Methods

REXDBSectionFactory Class Public Methods
REXDBSectionFactory Class Legend
Public Methods
Public Method | Description
REXDBSectionFactory | This is REXDBSectionFactory, a member of class REXDBSectionFactory.


Legend

Legend
REXFamilyConverter Class
Legend
Constructor
virtual
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXFamilyConverter Class Members

REXFamilyConverter Class Members
REXFamilyConverter Class Legend
Members
Public Methods
Public Method | Description
REXFamilyConverter | Initializes a new instance of the REXFamilyConverter class.
REXFamilyConverter Methods
REXFamilyConverter Methods | Description
Close | Clears collections, releases COM objects.
FindFamily | Finds the REXFamilyType in the specific list.
GenerateMaps | Generates a file used in the mapping aliases system.
GetDatabaseDirectory | Returns directory for databases of the specific category.
GetDatabasePath | Return a path for particular database of the specified category.
GetDBList | Gets the list of database's records adequate for the list of input objects.
GetDBList | Gets the list of database's records adequate for the list of input objects.
GetDBList | Gets the list of database's records adequate for the input object.
GetDBList | Gets the list of database's records adequate for the input object.
GetDBList | Gets the list of database's records adequate for the input object.
GetDBList | Gets the list of database's records adequate for the input object.
GetDBList | Gets the list of database's records adequate for the input object.
GetDBList | Gets the list of database's records adequate for the input object.
GetDBList | Gets the list of database's records adequate for the input object.
GetDBList | Gets the list of database's records adequate for the input object.
GetDBList | Gets the list of database's records adequate for the input object.
GetDbProperty | Gets the property of specific name for the database.
GetEmptyFamilyOfAlias | Gets the empty family of alias name.
GetFamilies | Gets the list of all elements in the selected database.
GetFamilies | Gets the list of all elements in the selected database.
GetFamilies | Gets the list of all elements in selected database.
GetFamilies | Gets the list of all elements in selected database.
GetFamily | Gets the REXFamilyType object based on specific database's record.
GetFamily | Gets the REXFamilyType object based on specific database's record.
GetFamily | Gets the REXFamilyType object based on specific database's record.
GetFamily | Gets the REXFamilyType object based on the specified database's record.
GetFamilyDBSection | Gets the section of the specified name (based on data from databases).
GetFamilyDBSection | Gets the section of the specified key (based on data from the database).
GetFamilyDBSection | Gets the section of the specified name (based on data from databases).
GetFamilyDBSection | Gets the section of the specified name (based on data from the database).
GetFamilyDefault | Gets the default REXFamilyType of the specified type.
GetFamilyMaterial | Gets the material of the specific name (based on data from the database).
GetFamilyMaterial | Gets the material of the specified name (based on data from the database).
GetFamilyMaterial | Gets the material of the specific name (based on data from the database).
GetFamilyRebarHook | Gets the family rebar hook.
GetFamilyRebarShape | Gets the rebar shape of specified code and database.
GetFamilyRebarType | Gets the rebar's type of the specified steel and the bar's size (based on data from the database).
GetFamilyTemplate | Gets the dedicated template of the REXFamilyType (with initial data).
GetFilteredFamilies | Gets the list of filtered elements in the selected database.
GetFilteredFamilies | Gets the list of filtered elements in the selected database.
GetFilteredFamilies | Gets the list of filtered elements in selected database.
GetFilteredFamilies | Gets the list of filtered elements in the selected database.
GetNameForAlias | Gets the certified name for the alias.
GetRebar | Gets the rebar object due to the defined contour, the bar's type and the shape's database.
GetRebar | Gets the rebar object due to the defined contour, the bar's type and the shape's database.
GetRebar | Gets the rebar object due to the defined contour, the bar's type and the shape's database.
GetRebar | Gets the rebar object due to the defined contour, the bar's type and the shape's database.
GetRebar | Gets the rebar object due to the defined contour, the bar's type and the shape's database.
GetRebar | Gets the rebar object due to the defined contour, the bar's type and the shape's database.
GetRebar | Gets the rebar object due to the defined contour, the bar's type and the shape's database.
GetRebar | Gets the rebar object due to the defined contour, the bar's type and the shape's database.
GetRebar | Gets the rebar object due to the defined contour, the bar's type and the shape's database.
GetRebar | Gets the rebar object due to the defined contour, the bar's type and the shape's database.
GetRebar | Gets the rebar object due to the defined contour, the bar's type and the shape's database.
GetRebar | Gets the rebar object due to the defined contour, the bar's type and the shape's database.
GetRebar | Gets the rebar object due to the defined contour, the bar's type and the shape's database.
GetRebar | Gets the rebar object due to the defined contour, the bar's type and the shape's database.
GetRebar | Gets the rebar object due to the defined contour, the bar's type and the shape's database.
GetRebar | Gets the rebar object due to the defined contour, the bar's type and the shape's database.
GetRoundRebar | Gets the round rebar object due to parameters.
GetSpiralRebar | Gets the spiral rebar object due to parameters.
GetUserDatabaseDirectory | Returns directory for user databases of the specified category.
RegisterCustomFactory | Registers the custom factory.
REXFamilyConverter Properties
REXFamilyConverter Properties | Description
ContentMapper | Gets the mapper object.
Settings | Gets the settings.


REXFamilyConverter Methods

REXFamilyConverter Methods
REXFamilyConverter Class Legend
REXFamilyConverter Methods
REXFamilyConverter Methods | Description
Close | Clears collections, releases COM objects.
FindFamily | Finds the REXFamilyType in the specific list.
GenerateMaps | Generates a file used in the mapping aliases system.
GetDatabaseDirectory | Returns directory for databases of the specific category.
GetDatabasePath | Return a path for particular database of the specified category.
GetDBList | Gets the list of database's records adequate for the list of input objects.
GetDBList | Gets the list of database's records adequate for the list of input objects.
GetDBList | Gets the list of database's records adequate for the input object.
GetDBList | Gets the list of database's records adequate for the input object.
GetDBList | Gets the list of database's records adequate for the input object.
GetDBList | Gets the list of database's records adequate for the input object.
GetDBList | Gets the list of database's records adequate for the input object.
GetDBList | Gets the list of database's records adequate for the input object.
GetDBList | Gets the list of database's records adequate for the input object.
GetDBList | Gets the list of database's records adequate for the input object.
GetDBList | Gets the list of database's records adequate for the input object.
GetDbProperty | Gets the property of specific name for the database.
GetEmptyFamilyOfAlias | Gets the empty family of alias name.
GetFamilies | Gets the list of all elements in the selected database.
GetFamilies | Gets the list of all elements in the selected database.
GetFamilies | Gets the list of all elements in selected database.
GetFamilies | Gets the list of all elements in selected database.
GetFamily | Gets the REXFamilyType object based on specific database's record.
GetFamily | Gets the REXFamilyType object based on specific database's record.
GetFamily | Gets the REXFamilyType object based on specific database's record.
GetFamily | Gets the REXFamilyType object based on the specified database's record.
GetFamilyDBSection | Gets the section of the specified name (based on data from databases).
GetFamilyDBSection | Gets the section of the specified key (based on data from the database).
GetFamilyDBSection | Gets the section of the specified name (based on data from databases).
GetFamilyDBSection | Gets the section of the specified name (based on data from the database).
GetFamilyDefault | Gets the default REXFamilyType of the specified type.
GetFamilyMaterial | Gets the material of the specific name (based on data from the database).
GetFamilyMaterial | Gets the material of the specified name (based on data from the database).
GetFamilyMaterial | Gets the material of the specific name (based on data from the database).
GetFamilyRebarHook | Gets the family rebar hook.
GetFamilyRebarShape | Gets the rebar shape of specified code and database.
GetFamilyRebarType | Gets the rebar's type of the specified steel and the bar's size (based on data from the database).
GetFamilyTemplate | Gets the dedicated template of the REXFamilyType (with initial data).
GetFilteredFamilies | Gets the list of filtered elements in the selected database.
GetFilteredFamilies | Gets the list of filtered elements in the selected database.
GetFilteredFamilies | Gets the list of filtered elements in selected database.
GetFilteredFamilies | Gets the list of filtered elements in the selected database.
GetNameForAlias | Gets the certified name for the alias.
GetRebar | Gets the rebar object due to the defined contour, the bar's type and the shape's database.
GetRebar | Gets the rebar object due to the defined contour, the bar's type and the shape's database.
GetRebar | Gets the rebar object due to the defined contour, the bar's type and the shape's database.
GetRebar | Gets the rebar object due to the defined contour, the bar's type and the shape's database.
GetRebar | Gets the rebar object due to the defined contour, the bar's type and the shape's database.
GetRebar | Gets the rebar object due to the defined contour, the bar's type and the shape's database.
GetRebar | Gets the rebar object due to the defined contour, the bar's type and the shape's database.
GetRebar | Gets the rebar object due to the defined contour, the bar's type and the shape's database.
GetRebar | Gets the rebar object due to the defined contour, the bar's type and the shape's database.
GetRebar | Gets the rebar object due to the defined contour, the bar's type and the shape's database.
GetRebar | Gets the rebar object due to the defined contour, the bar's type and the shape's database.
GetRebar | Gets the rebar object due to the defined contour, the bar's type and the shape's database.
GetRebar | Gets the rebar object due to the defined contour, the bar's type and the shape's database.
GetRebar | Gets the rebar object due to the defined contour, the bar's type and the shape's database.
GetRebar | Gets the rebar object due to the defined contour, the bar's type and the shape's database.
GetRebar | Gets the rebar object due to the defined contour, the bar's type and the shape's database.
GetRoundRebar | Gets the round rebar object due to parameters.
GetSpiralRebar | Gets the spiral rebar object due to parameters.
GetUserDatabaseDirectory | Returns directory for user databases of the specified category.
RegisterCustomFactory | Registers the custom factory.


REXFamilyConverter Properties

REXFamilyConverter Properties
REXFamilyConverter Class Legend
REXFamilyConverter Properties
REXFamilyConverter Properties | Description
ContentMapper | Gets the mapper object.
Settings | Gets the settings.


REXFamilyConverter Class Public Methods

REXFamilyConverter Class Public Methods
REXFamilyConverter Class Legend
Public Methods
Public Method | Description
REXFamilyConverter | Initializes a new instance of the REXFamilyConverter class.


Example

Example
REXFamilyConverter.GetDatabaseDirectory Method

The example shows how to get directory for all databases of material category.

//Initializing the rex converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Getting directory.
string dir = rex.GetDatabaseDirectory(ECategoryType.MATERIAL);


Example

Example
REXFamilyConverter.GetDatabasePath Method

The example shows how to get database path of the material category.

//Initializing the rex converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Getting path.
string path = rex.GetDatabasePath(ECategoryType.MATERIAL, "Eurocode");


Example

Example
REXFamilyConverter.GetDBList Method (List<REXFamilyType>, List<string>, string, ECategoryType)

The example shows how to get a list of records which exist in databases defined in the input list and fit to at least one specific element.

//Initializing the rex converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Definition of elements. In the current example they are created as empty families with alias names but they can be taken from different sources (e.g. Revit).
REXFamilyType fam1 = rex.GetEmptyFamilyOfAlias(REX.ContentGenerator.Families.EElementType.BEAM, "HEB 100", ECategoryType.SECTION_DB);
REXFamilyType fam2 = rex.GetEmptyFamilyOfAlias(REX.ContentGenerator.Families.EElementType.BEAM, "HEA 200", ECategoryType.SECTION_DB);
List<REXFamilyType> families = new List<REXFamilyType>() { fam1, fam2 };

//Database identification data.
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Prof";
List<string> databases = new List<string>() { "Otuapro", "CorusPro", "Aiscpro" };

//Getting the list of databases
List<REXDBDescription> dbList = rex.GetDBList(families, databases, directory, ECategoryType.SECTION_DB);


Example

Example
REXFamilyConverter.GetDBList Method (List<REXFamilyType>, string, ECategoryType)

The example shows how to get a list of records which exist in databases from specific directory which fit to at least one specific element.

//Initializing the rex converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Definition of elements. In the current example they are created as empty families with alias names but they can be taken from different sources (e.g. Revit).        ///
REXFamilyType fam1 = rex.GetEmptyFamilyOfAlias(REX.ContentGenerator.Families.EElementType.BEAM, "HEB 100", ECategoryType.SECTION_DB);
REXFamilyType fam2 = rex.GetEmptyFamilyOfAlias(REX.ContentGenerator.Families.EElementType.BEAM, "HEA 200", ECategoryType.SECTION_DB);
List<REXFamilyType> families = new List<REXFamilyType>() { fam1, fam2 };

//Database identification data.
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Prof";

//Getting the list of databases
List<REXDBDescription> dbList = rex.GetDBList(families, directory, ECategoryType.SECTION_DB);


Example

Example
REXFamilyConverter.GetDBList Method (REXFamilyType, ECategoryType, List<string>)

The example shows how to get a list of records which exist in databases of the specific directory and fit to the specific element.

//Initializing the rex converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Definition of the element. In the current example it is created as the empty family with the alias name but it can be taken from different sources (e.g. Revit).
REXFamilyType fam = rex.GetEmptyFamilyOfAlias(REX.ContentGenerator.Families.EElementType.BEAM, "HEB 100", ECategoryType.SECTION_DB);

//Database identification data.
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Prof";

//Getting the list of databases
List<REXDBDescription> dbList = rex.GetDBList(fam, ECategoryType.SECTION_DB,new List<string>(){directory});


Example

Example
REXFamilyConverter.GetDBList Method (REXFamilyType, ECategoryType, string, string)

The example shows how to get a list of records which exist in databases of the specific directory and fit to the specific element.

//Initializing the rex converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Definition of the element. In the current example it is created as the empty family with the alias name but it can be taken from different sources (e.g. Revit).
REXFamilyType fam = rex.GetEmptyFamilyOfAlias(REX.ContentGenerator.Families.EElementType.BEAM, "HEB 100", ECategoryType.SECTION_DB);

//Database identification data.
string directory1 = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Prof";
string directory1 = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2012\Data\Prof";

//Getting the list of databases
List<REXDBDescription> dbList = rex.GetDBList(fam, ECategoryType.SECTION_DB,directory1,directory2);


Example

Example
REXFamilyConverter.GetDBList Method (REXFamilyType, ECategoryType)

The example shows how to get a list of records which exist in databases of the specific directory and fit to the specific element.

//Initializing the rex converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Definition of the element. In the current example it is created as the empty family with the alias name but it can be taken from different sources (e.g. Revit).
REXFamilyType fam = rex.GetEmptyFamilyOfAlias(REX.ContentGenerator.Families.EElementType.BEAM, "HEB 100", ECategoryType.SECTION_DB);

//Getting the list of databases
List<REXDBDescription> dbList = rex.GetDBList(fam,ECategoryType.SECTION_DB);


Example

Example
REXFamilyConverter.GetDBList Method (REXFamilyType, List<string>, string, ECategoryType)

The example shows how to get a list of records which exist in databases defined in the input list and fit to the specific element.

//Initializing the rex converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Definition of the element. In the current example it is created as the empty family with the alias name but it can be taken from different sources (e.g. Revit).
REXFamilyType fam = rex.GetEmptyFamilyOfAlias(REX.ContentGenerator.Families.EElementType.BEAM, "HEB 100", ECategoryType.SECTION_DB);

//Database identification data.
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Prof";
List<string> databases = new List<string>() { "Otuapro", "CorusPro", "Aiscpro" };

//Getting the list of databases
List<REXDBDescription> dbList = rex.GetDBList(fam, databases, directory, ECategoryType.SECTION_DB);


Example

Example
REXFamilyConverter.GetDBList Method (REXFamilyType, string, ECategoryType)

The example shows how to get a list of records which exist in databases of the specific directory and fit to the specific element.

//Initializing the rex converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Definition of the element. In the current example it is created as the empty family with the alias name but it can be taken from different sources (e.g. Revit).
REXFamilyType fam = rex.GetEmptyFamilyOfAlias(REX.ContentGenerator.Families.EElementType.BEAM, "HEB 100", ECategoryType.SECTION_DB);

//Database identification data.
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Prof";

//Getting the list of databases
List<REXDBDescription> dbList = rex.GetDBList(fam, directory, ECategoryType.SECTION_DB);


Example

Example
REXFamilyConverter.GetDBList Method (REXFamilyType, string, string, ECategoryType)

The example shows how to get a list of records which exist in the Rcatpro database and fit to the specific element.

//Initializing the rex converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Definition of the element. In the current example it is created as the empty family with the alias name but it can be taken from different sources (e.g. Revit).        ///
REXFamilyType fam = rex.GetEmptyFamilyOfAlias(REX.ContentGenerator.Families.EElementType.BEAM, "HEB 100", ECategoryType.SECTION_DB);

//Database identification data.
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Prof";
string dbName = "Rcatpro";

//Getting the list of databases
List<REXDBDescription> dbList = rex.GetDBList(fam, dbName, directory, ECategoryType.SECTION_DB);


Example

Example
REXFamilyConverter.GetFamilies Method (string, ECategoryType)

The example shows how to get all sections from the Rcatptro database.

//Initializing the rex converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Database identification data.
string path = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Prof\Rcatpro.xml";

//Getting the REXFamilyType from the database.
List<REXFamilyType> families = rex.GetFamilies(path, ECategoryType.SECTION_DB);


Example

Example
REXFamilyConverter.GetFamilies Method (string, string, ECategoryType)

The example shows how to get all sections from the Rcatptro database.

//Initializing the rex converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Database identification data.
string database = "Rcatpro";
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Prof";

//Getting the REXFamilyType from the database.
List<REXFamilyType> families = rex.GetFamilies(directory, database, ECategoryType.SECTION_DB);


Example

Example
REXFamilyConverter.GetFamily Method (REXDBDescription, ECategoryType)

The example shows how to get the„HEA 100” section from the Rcatptro database.

//Initializing the rex converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Creating the database description for the database query.
REXSectionDBDescription dbdesc = new REXSectionDBDescription("Rcatpro");
dbdesc.Directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Prof";
dbdesc.Description.NAME = "HEA";
dbdesc.Description.DIM1 = 100;
dbdesc.Description.DIM2 = 0;
dbdesc.Description.DIM3 = 0;

//Getting the REXFamilyType from the database.
REXFamilyType fam = rex.GetFamily(dbdesc, ECategoryType.SECTION_DB);
REXFamilyType_DBSection famDBSection = fam as REXFamilyType_DBSection;


Example

Example
REXFamilyConverter.GetFamily Method (REXDBDescription, REX.ContentGenerator.Families.EElementType, EMaterial, ECategoryType)

The example shows how to get the„HEA 100” section from the Rcatptro database.

//Initializing the rex converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Creating the database description for the database query.
REXSectionDBDescription dbdesc = new REXSectionDBDescription("Rcatpro");
dbdesc.Directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Prof";
dbdesc.Description.NAME = "HEA";
dbdesc.Description.DIM1 = 100;
dbdesc.Description.DIM2 = 0;
dbdesc.Description.DIM3 = 0;

//Getting the REXFamilyType from the database.
REXFamilyType fam = rex.GetFamily(dbdesc, REX.ContentGenerator.Families.EElementType.BEAM, EMaterial.STEEL, ECategoryType.SECTION_DB);
REXFamilyType_DBSection famDBSection = fam as REXFamilyType_DBSection;


Example

Example
REXFamilyConverter.GetFamilyDBSection Method (REX.ContentGenerator.Families.EElementType, EMaterial, string, double, double, double, string, string)

The example shows how to get the „HEA 100” section from the Rcatpro database.

//Initializing the rex converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Database identification data.
string dbName = "Rcatpro";
string name = "HEA";
double dim1 = 100;
double dim2 = 0;
double dim3 = 0;
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Prof";

//Getting the REXFamilyType from the database.
REXFamilyType_DBSection famDBSection = rex.GetFamilyDBSection(REX.ContentGenerator.Families.EElementType.BEAM, EMaterial.STEEL, name, dim1, dim2, dim3, dbName, directory);


Example

Example
REXFamilyConverter.GetFamilyDBSection Method (REX.ContentGenerator.Families.EElementType, EMaterial, string, string, string)

The example shows how to get the „HEA 100” section from the Rcatptro database.

//Initializing the rex converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Database identification data.
string alias = "HEA 100";
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Prof";
string dbName = "Rcatpro";

//Getting the REXFamilyType from the database.
REXFamilyType_DBSection famDBSection = rex.GetFamilyDBSection(REX.ContentGenerator.Families.EElementType.BEAM, EMaterial.STEEL, alias, dbName, directory);


Example

Example
REXFamilyConverter.GetFamilyDBSection Method (REX.ContentGenerator.Families.EElementType, EMaterial, string, string)

The example shows how to get the „HEA 100” section from any database.

//Initializing the rex converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Database identification data.
string alias = "HEA 100";
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Prof";

//Getting the REXFamilyType from the database.
REXFamilyType_DBSection famDBSection = rex.GetFamilyDBSection(REX.ContentGenerator.Families.EElementType.BEAM, EMaterial.STEEL, alias, directory);


Example

Example
REXFamilyConverter.GetFamilyDBSection Method (REX.ContentGenerator.Families.EElementType, EMaterial, string)

The example shows how to get the „HEA 100” section from any database.

//Initializing the rex converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Database identification data.
string alias = "HEA 100";

//Getting the REXFamilyType from the database.
REXFamilyType_DBSection famDBSection = rex.GetFamilyDBSection(REX.ContentGenerator.Families.EElementType.BEAM, EMaterial.STEEL, alias);


Example

Example
REXFamilyConverter.GetFamilyMaterial Method (string, string, string)

The example shows how to get the „C12/15” material from the Eurocode database.

//Initializing the rex converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Database identification data.
string dbName = "Eurocode";
string name = "C12/15";
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Mate";

//Getting the REXFamilyType from the database.
REXFamilyType_Material famMaterial = rex.GetFamilyMaterial(name, dbName, directory);


Example

Example
REXFamilyConverter.GetFamilyMaterial Method (string, string)

The example shows how to get the „C12/15” material from any database.

//Initializing the rex converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Database identification data.
string name = "C12/15";
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Mate";

//Getting the REXFamilyType from the database.
REXFamilyType_Material famMaterial = rex.GetFamilyMaterial(name, directory);


Example

Example
REXFamilyConverter.GetFamilyMaterial Method (string)

The example shows how to get the „C12/15” material from the Eurocode database.

//Initializing the rex converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Database identification data.
string name = "C12/15";
//Getting the REXFamilyType from the database.
REXFamilyType_Material famMaterial = rex.GetFamilyMaterial(name);


Example

Example
REXFamilyConverter.GetFamilyRebarType Method

The example shows how to get the bar of Grade 40 and #8 size from the database bar_ACI 318-08 database.

//Initializing the rex converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Database identification data.
string dbName = "bar_ACI 318-08";
string grade = "Grade 40";
string size = "#8";
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Reinf";

//Getting the REXFamilyType from the database.
REXFamilyType_RebarBarType famRebarType = rex.GetFamilyRebarType(grade, size, dbName, directory);


Example

Example
REXFamilyConverter.GetFilteredFamilies Method (string, REXContentFilter, ECategoryType)

The example shows how to get filtered sections from the Rcatptro database (of HEB NAME and height more than 0.4).

//Initializing the rex converter.
REXFamilyConverter rex = new REXFamilyConverter();

REXContentParamFilter filterNAME = new REXContentParamFilter("NAME", "HEB", false, false, true);
REXContentParamFilter filterH = new REXContentParamFilter("H", 0.4, true, false, false);
REXContentLogicFilter filterLogic = new REXContentLogicFilter(REXContentLogicFilter.ELogicOperator.And, filterNAME, filterH);

//Database identification data.
string path = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Prof\Rcatpro.xml";

//Getting the REXFamilyType from the database.
List<REXFamilyType> families = rex.GetFamilies(path,filterLogic, ECategoryType.SECTION_DB);


Example

Example
REXFamilyConverter.GetFilteredFamilies Method (string, string, REXContentFilter, ECategoryType)

The example shows how to get filtered sections from the Rcatptro database (of HEB NAME and height more than 0.4).

//Initializing the rex converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Database identification data.
string database = "Rcatpro";
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Prof";

REXContentParamFilter filterNAME = new REXContentParamFilter("NAME", "HEB", false, false, true);
REXContentParamFilter filterH = new REXContentParamFilter("H", 0.4, true, false, false);
REXContentLogicFilter filterLogic = new REXContentLogicFilter(REXContentLogicFilter.ELogicOperator.And, filterNAME, filterH);

//Getting the REXFamilyType from the database.
List<REXFamilyType> families = rex.GetFamilies(directory, database, filterLogic, ECategoryType.SECTION_DB);


Example

Example
REXFamilyConverter.GetRebar Method (List<REXxyz>, REXFamilyType_RebarBarType, bool, REXFamilyType_RebarHook, REXFamilyType_RebarHook, string, bool)

The example shows how to get rebar object based on the specific contour.

//Initializing converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Rebar data (it can be taken from different sources e.g. Revit).
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Reinf";
REXFamilyType_RebarBarType famRebarType = rex.GetFamilyRebarType("Grade 40","#8","bar_ACI 318-08",directory);
REXFamilyType_RebarHook hookStart = new REXFamilyType_RebarHook();
hookStart.Parameters.Angle = EHookAngles.none;
REXFamilyType_RebarHook hookEnd = new REXFamilyType_RebarHook();
hookEnd.Parameters.Angle = EHookAngles.none;

//Contour.
List<REXxyz> l = new List<REXxyz>();
l.Add(new REXxyz(0, 0));
l.Add(new REXxyz(2, 0));
l.Add(new REXxyz(2, 1));
l.Add(new REXxyz(0, 1));
l.Add(new REXxyz(0, 0));

//Getting Rebar object from contour.
REXFamilyType_Rebar r = rex.GetRebar(l, famRebarType,false,hookStart,hookEnd,"barlib7_iso",true);

The rebar object can be used by other converters to create a rebar of the specific shape (e.g. RVTFamilyConverter: CreateRebar).


Example

Example
REXFamilyConverter.GetRebar Method (List<REXxyz>, REXFamilyType_RebarBarType, bool, REXFamilyType_RebarHook, REXFamilyType_RebarHook, string, string, bool)

The example shows how to get rebar object based on the specific contour.

//Initializing converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Rebar data (it can be taken from different sources e.g. Revit).
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Reinf";
REXFamilyType_RebarBarType famRebarType = rex.GetFamilyRebarType("Grade 40", "#8", "bar_ACI 318-08", directory);
REXFamilyType_RebarHook hookStart = new REXFamilyType_RebarHook();
hookStart.Parameters.Angle = EHookAngles.none;
REXFamilyType_RebarHook hookEnd = new REXFamilyType_RebarHook();
hookEnd.Parameters.Angle = EHookAngles.none;

//Contour.
List<REXxyz> l = new List<REXxyz>();
l.Add(new REXxyz(0, 0));
l.Add(new REXxyz(2, 0));
l.Add(new REXxyz(2, 1));
l.Add(new REXxyz(0, 1));
l.Add(new REXxyz(0, 0));

//Getting Rebar object from contour.
REXFamilyType_Rebar r = rex.GetRebar(l, famRebarType, false, hookStart, hookEnd, "barlib7_iso","31",true);

The rebar object can be used by other converters to create a rebar of the specific shape (e.g. RVTFamilyConverter: CreateRebar).


Example

Example
REXFamilyConverter.GetRebar Method (List<REXxyz>, REXFamilyType_RebarBarType, bool, REXFamilyType_RebarHook, REXFamilyType_RebarHook, string, string)

The example shows how to get rebar object based on the specific contour (with shape suggested).

//Initializing converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Rebar data (it can be taken from different sources e.g. Revit).
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Reinf";
REXFamilyType_RebarBarType famRebarType = rex.GetFamilyRebarType("Grade 40","#8","bar_ACI 318-08",directory);
REXFamilyType_RebarHook hookStart = new REXFamilyType_RebarHook();
hookStart.Parameters.Angle = EHookAngles.none;
REXFamilyType_RebarHook hookEnd = new REXFamilyType_RebarHook();
hookEnd.Parameters.Angle = EHookAngles.none;

//Contour.
List<REXxyz> l = new List<REXxyz>();
l.Add(new REXxyz(0, 0));
l.Add(new REXxyz(2, 0));
l.Add(new REXxyz(2, 1));

//Getting Rebar object from contour.
REXFamilyType_Rebar r = rex.GetRebar(l,famRebarType,false,hookStart,hookEnd,"barlib7_iso","12");

The rebar object can be used by other converters to create a rebar of the specific shape (e.g. RVTFamilyConverter: CreateRebar).


Example

Example
REXFamilyConverter.GetRebar Method (List<REXxyz>, REXFamilyType_RebarBarType, bool, REXFamilyType_RebarHook, REXFamilyType_RebarHook, string)

The example shows how to get rebar object based on the specific contour.

//Initializing converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Rebar data (it can be taken from different sources e.g. Revit).
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Reinf";
REXFamilyType_RebarBarType famRebarType = rex.GetFamilyRebarType("Grade 40","#8","bar_ACI 318-08",directory);
REXFamilyType_RebarHook hookStart = new REXFamilyType_RebarHook();
hookStart.Parameters.Angle = EHookAngles.none;
REXFamilyType_RebarHook hookEnd = new REXFamilyType_RebarHook();
hookEnd.Parameters.Angle = EHookAngles.none;

//Contour.
List<REXxyz> l = new List<REXxyz>();
l.Add(new REXxyz(0, 0));
l.Add(new REXxyz(2, 0));
l.Add(new REXxyz(2, 1));

//Getting Rebar object from contour.
REXFamilyType_Rebar r = rex.GetRebar(l, famRebarType,false,hookStart,hookEnd,"barlib7_iso");

The rebar object can be used by other converters to create a rebar of the specific shape (e.g. RVTFamilyConverter: CreateRebar).


Example

Example
REXFamilyConverter.GetRebar Method (List<REXxyz>, REXxyz, REXFamilyType_RebarBarType, bool, REXFamilyType_RebarHook, REXFamilyType_RebarHook, string, bool)

The example shows how to get rebar object based on the specific contour.

//Initializing converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Rebar data (it can be taken from different sources e.g. Revit).
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Reinf";
REXFamilyType_RebarBarType famRebarType = rex.GetFamilyRebarType("Grade 40", "#8", "bar_ACI 318-08", directory);
REXFamilyType_RebarHook hookStart = new REXFamilyType_RebarHook();
hookStart.Parameters.Angle = EHookAngles.none;
REXFamilyType_RebarHook hookEnd = new REXFamilyType_RebarHook();
hookEnd.Parameters.Angle = EHookAngles.none;

//Contour.
List<REXxyz> l = new List<REXxyz>();
l.Add(new REXxyz(0, 0));
l.Add(new REXxyz(2, 0));
l.Add(new REXxyz(2, 1));
l.Add(new REXxyz(0, 1));
l.Add(new REXxyz(0, 0));
REXxyz normal = new REXxyz(0, 0, 1);

//Getting Rebar object from contour.
REXFamilyType_Rebar r = rex.GetRebar(l, normal, famRebarType, false, hookStart, hookEnd, "barlib7_iso",true);

The rebar object can be used by other converters to create a rebar of the specific shape (e.g. RVTFamilyConverter: CreateRebar).


Example

Example
REXFamilyConverter.GetRebar Method (List<REXxyz>, REXxyz, REXFamilyType_RebarBarType, bool, REXFamilyType_RebarHook, REXFamilyType_RebarHook, string, string, bool)

The example shows how to get rebar object based on the specific contour.

//Initializing converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Rebar data (it can be taken from different sources e.g. Revit).
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Reinf";
REXFamilyType_RebarBarType famRebarType = rex.GetFamilyRebarType("Grade 40", "#8", "bar_ACI 318-08", directory);
REXFamilyType_RebarHook hookStart = new REXFamilyType_RebarHook();
hookStart.Parameters.Angle = EHookAngles.none;
REXFamilyType_RebarHook hookEnd = new REXFamilyType_RebarHook();
hookEnd.Parameters.Angle = EHookAngles.none;

//Contour.
List<REXxyz> l = new List<REXxyz>();
l.Add(new REXxyz(0, 0));
l.Add(new REXxyz(2, 0));
l.Add(new REXxyz(2, 1));
l.Add(new REXxyz(0, 1));
l.Add(new REXxyz(0, 0));
REXxyz normal = new REXxyz(0, 0, 1);

//Getting Rebar object from contour.
REXFamilyType_Rebar r = rex.GetRebar(l, normal, famRebarType, false, hookStart, hookEnd, "barlib7_iso","31",true);

The rebar object can be used by other converters to create a rebar of the specific shape (e.g. RVTFamilyConverter: CreateRebar).


Example

Example
REXFamilyConverter.GetRebar Method (List<REXxyz>, REXxyz, REXFamilyType_RebarBarType, bool, REXFamilyType_RebarHook, REXFamilyType_RebarHook, string, string)

The example shows how to get rebar object based on the specific contour (with shape suggested).

//Initializing converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Rebar data (it can be taken from different sources e.g. Revit).
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Reinf";
REXFamilyType_RebarBarType famRebarType = rex.GetFamilyRebarType("Grade 40","#8","bar_ACI 318-08",directory);
REXFamilyType_RebarHook hookStart = new REXFamilyType_RebarHook();
hookStart.Parameters.Angle = EHookAngles.none;
REXFamilyType_RebarHook hookEnd = new REXFamilyType_RebarHook();
hookEnd.Parameters.Angle = EHookAngles.none;

//Contour.
List<REXxyz> l = new List<REXxyz>();
l.Add(new REXxyz(0, 0));
l.Add(new REXxyz(2, 0));
l.Add(new REXxyz(2, 1));
REXxyz normal = new REXxyz(0, 0, 1);

//Getting Rebar object from contour.
REXFamilyType_Rebar r = rex.GetRebar(l,normal, famRebarType,false,hookStart,hookEnd,"barlib7_iso","12");

The rebar object can be used by other converters to create a rebar of the specific shape (e.g. RVTFamilyConverter: CreateRebar).


Example

Example
REXFamilyConverter.GetRebar Method (List<REXxyz>, REXxyz, REXFamilyType_RebarBarType, bool, REXFamilyType_RebarHook, REXFamilyType_RebarHook, string)

The example shows how to get rebar object based on the specific contour.

//Initializing converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Rebar data (it can be taken from different sources e.g. Revit).
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Reinf";
REXFamilyType_RebarBarType famRebarType = rex.GetFamilyRebarType("Grade 40","#8","bar_ACI 318-08",directory);
REXFamilyType_RebarHook hookStart = new REXFamilyType_RebarHook();
hookStart.Parameters.Angle = EHookAngles.none;
REXFamilyType_RebarHook hookEnd = new REXFamilyType_RebarHook();
hookEnd.Parameters.Angle = EHookAngles.none;

//Contour.
List<REXxyz> l = new List<REXxyz>();
l.Add(new REXxyz(0, 0));
l.Add(new REXxyz(2, 0));
l.Add(new REXxyz(2, 1));
REXxyz normal = new REXxyz(0, 0, 1);

//Getting Rebar object from contour.
REXFamilyType_Rebar r = rex.GetRebar(l,normal, famRebarType,false,hookStart,hookEnd,"barlib7_iso");

The rebar object can be used by other converters to create a rebar of the specific shape (e.g. RVTFamilyConverter: CreateRebar).


Example

Example
REXFamilyConverter.GetRebar Method (REX.ContentGenerator.Geometry.Contour_3D, REXFamilyType_RebarBarType, bool, REXFamilyType_RebarHook, REXFamilyType_RebarHook, string, bool)

The example shows how to get rebar object based on the specific contour.

//Initializing converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Rebar data (it can be taken from different sources e.g. Revit).
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Reinf";
REXFamilyType_RebarBarType famRebarType = rex.GetFamilyRebarType("Grade 40", "#8", "bar_ACI 318-08", directory);
REXFamilyType_RebarHook hookStart = new REXFamilyType_RebarHook();
hookStart.Parameters.Angle = EHookAngles.none;
REXFamilyType_RebarHook hookEnd = new REXFamilyType_RebarHook();
hookEnd.Parameters.Angle = EHookAngles.none;

//Contour.
REX.ContentGenerator.Geometry.Contour_3D cont = new REX.ContentGenerator.Geometry.Contour_3D();
cont.StartContour(new REXxyz(0, 0));
cont.LineTo(new REXxyz(2, 0));
cont.LineTo(new REXxyz(2, 1));

//Getting Rebar object from contour.
REXFamilyType_Rebar r = rex.GetRebar(cont, famRebarType, false, hookStart, hookEnd, "barlib7_iso",true);

The rebar object can be used by other converters to create a rebar of the specific shape (e.g. RVTFamilyConverter: CreateRebar).


Example

Example
REXFamilyConverter.GetRebar Method (REX.ContentGenerator.Geometry.Contour_3D, REXFamilyType_RebarBarType, bool, REXFamilyType_RebarHook, REXFamilyType_RebarHook, string, string, bool)

The example shows how to get rebar object based on the specific contour.

//Initializing converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Rebar data (it can be taken from different sources e.g. Revit).
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Reinf";
REXFamilyType_RebarBarType famRebarType = rex.GetFamilyRebarType("Grade 40", "#8", "bar_ACI 318-08", directory);
REXFamilyType_RebarHook hookStart = new REXFamilyType_RebarHook();
hookStart.Parameters.Angle = EHookAngles.none;
REXFamilyType_RebarHook hookEnd = new REXFamilyType_RebarHook();
hookEnd.Parameters.Angle = EHookAngles.none;

//Contour.
REX.ContentGenerator.Geometry.Contour_3D cont = new REX.ContentGenerator.Geometry.Contour_3D();
cont.StartContour(new REXxyz(0, 0));
cont.LineTo(new REXxyz(2, 0));
cont.LineTo(new REXxyz(2, 1));

//Getting Rebar object from contour.
REXFamilyType_Rebar r = rex.GetRebar(cont, famRebarType, false, hookStart, hookEnd, "barlib7_iso","31",true);

The rebar object can be used by other converters to create a rebar of the specific shape (e.g. RVTFamilyConverter: CreateRebar).


Example

Example
REXFamilyConverter.GetRebar Method (REX.ContentGenerator.Geometry.Contour_3D, REXFamilyType_RebarBarType, bool, REXFamilyType_RebarHook, REXFamilyType_RebarHook, string, string)

The example shows how to get rebar object based on the specific contour (with shape suggested).

//Initializing converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Rebar data (it can be taken from different sources e.g. Revit).
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Reinf";
REXFamilyType_RebarBarType famRebarType = rex.GetFamilyRebarType("Grade 40", "#8", "bar_ACI 318-08", directory);
REXFamilyType_RebarHook hookStart = new REXFamilyType_RebarHook();
hookStart.Parameters.Angle = EHookAngles.none;
REXFamilyType_RebarHook hookEnd = new REXFamilyType_RebarHook();
hookEnd.Parameters.Angle = EHookAngles.none;

//Contour.
REX.ContentGenerator.Geometry.Contour_3D cont = new REX.ContentGenerator.Geometry.Contour_3D();
cont.StartContour(new REXxyz(0, 0));
cont.LineTo(new REXxyz(2, 0));
cont.LineTo(new REXxyz(2, 1));

//Getting Rebar object from contour.
REXFamilyType_Rebar r = rex.GetRebar(cont, famRebarType, false, hookStart, hookEnd, "barlib7_iso","12");

The rebar object can be used by other converters to create a rebar of the specific shape (e.g. RVTFamilyConverter: CreateRebar).


Example

Example
REXFamilyConverter.GetRebar Method (REX.ContentGenerator.Geometry.Contour_3D, REXFamilyType_RebarBarType, bool, REXFamilyType_RebarHook, REXFamilyType_RebarHook, string)

The example shows how to get rebar object based on the specific contour.

//Initializing converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Rebar data (it can be taken from different sources e.g. Revit).
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Reinf";
REXFamilyType_RebarBarType famRebarType = rex.GetFamilyRebarType("Grade 40", "#8", "bar_ACI 318-08", directory);
REXFamilyType_RebarHook hookStart = new REXFamilyType_RebarHook();
hookStart.Parameters.Angle = EHookAngles.none;
REXFamilyType_RebarHook hookEnd = new REXFamilyType_RebarHook();
hookEnd.Parameters.Angle = EHookAngles.none;

//Contour.
REX.ContentGenerator.Geometry.Contour_3D cont = new REX.ContentGenerator.Geometry.Contour_3D();
cont.StartContour(new REXxyz(0, 0));
cont.LineTo(new REXxyz(2, 0));
cont.LineTo(new REXxyz(2, 1));

//Getting Rebar object from contour.
REXFamilyType_Rebar r = rex.GetRebar(cont, famRebarType, false, hookStart, hookEnd, "barlib7_iso");

The rebar object can be used by other converters to create a rebar of the specific shape (e.g. RVTFamilyConverter: CreateRebar).


Example

Example
REXFamilyConverter.GetRebar Method (REX.ContentGenerator.Geometry.Contour_3D, REXxyz, REXFamilyType_RebarBarType, bool, REXFamilyType_RebarHook, REXFamilyType_RebarHook, string, bool)

The example shows how to get rebar object based on the specific contour.

//Initializing converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Rebar data (it can be taken from different sources e.g. Revit).
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Reinf";
REXFamilyType_RebarBarType famRebarType = rex.GetFamilyRebarType("Grade 40", "#8", "bar_ACI 318-08", directory);
REXFamilyType_RebarHook hookStart = new REXFamilyType_RebarHook();
hookStart.Parameters.Angle = EHookAngles.none;
REXFamilyType_RebarHook hookEnd = new REXFamilyType_RebarHook();
hookEnd.Parameters.Angle = EHookAngles.none;

//Contour.
REX.ContentGenerator.Geometry.Contour_3D cont = new REX.ContentGenerator.Geometry.Contour_3D();
cont.StartContour(new REXxyz(0, 0));
cont.LineTo(new REXxyz(2, 0));
cont.LineTo(new REXxyz(2, 1));
REXxyz normal = new REXxyz(0, 0, 1);

//Getting Rebar object from contour.
REXFamilyType_Rebar r = rex.GetRebar(cont, normal, famRebarType, false, hookStart, hookEnd, "barlib7_iso",true);

The rebar object can be used by other converters to create a rebar of the specific shape (e.g. RVTFamilyConverter: CreateRebar).


Example

Example
REXFamilyConverter.GetRebar Method (REX.ContentGenerator.Geometry.Contour_3D, REXxyz, REXFamilyType_RebarBarType, bool, REXFamilyType_RebarHook, REXFamilyType_RebarHook, string, string, bool)

The example shows how to get rebar object based on the specific contour.

//Initializing converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Rebar data (it can be taken from different sources e.g. Revit).
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Reinf";
REXFamilyType_RebarBarType famRebarType = rex.GetFamilyRebarType("Grade 40", "#8", "bar_ACI 318-08", directory);
REXFamilyType_RebarHook hookStart = new REXFamilyType_RebarHook();
hookStart.Parameters.Angle = EHookAngles.none;
REXFamilyType_RebarHook hookEnd = new REXFamilyType_RebarHook();
hookEnd.Parameters.Angle = EHookAngles.none;

//Contour.
REX.ContentGenerator.Geometry.Contour_3D cont = new REX.ContentGenerator.Geometry.Contour_3D();
cont.StartContour(new REXxyz(0, 0));
cont.LineTo(new REXxyz(2, 0));
cont.LineTo(new REXxyz(2, 1));
REXxyz normal = new REXxyz(0, 0, 1);

//Getting Rebar object from contour.
REXFamilyType_Rebar r = rex.GetRebar(cont, normal, famRebarType, false, hookStart, hookEnd, "barlib7_iso","31",true);

The rebar object can be used by other converters to create a rebar of the specific shape (e.g. RVTFamilyConverter: CreateRebar).


Example

Example
REXFamilyConverter.GetRebar Method (REX.ContentGenerator.Geometry.Contour_3D, REXxyz, REXFamilyType_RebarBarType, bool, REXFamilyType_RebarHook, REXFamilyType_RebarHook, string, string)

The example shows how to get rebar object based on the specific contour (with shape suggested).

//Initializing converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Rebar data (it can be taken from different sources e.g. Revit).
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Reinf";
REXFamilyType_RebarBarType famRebarType = rex.GetFamilyRebarType("Grade 40", "#8", "bar_ACI 318-08", directory);
REXFamilyType_RebarHook hookStart = new REXFamilyType_RebarHook();
hookStart.Parameters.Angle = EHookAngles.none;
REXFamilyType_RebarHook hookEnd = new REXFamilyType_RebarHook();
hookEnd.Parameters.Angle = EHookAngles.none;

//Contour.
REX.ContentGenerator.Geometry.Contour_3D cont = new REX.ContentGenerator.Geometry.Contour_3D();
cont.StartContour(new REXxyz(0, 0));
cont.LineTo(new REXxyz(2, 0));
cont.LineTo(new REXxyz(2, 1));
REXxyz normal = new REXxyz(0, 0, 1);

//Getting Rebar object from contour.
REXFamilyType_Rebar r = rex.GetRebar(cont, normal, famRebarType, false, hookStart, hookEnd, "barlib7_iso","12");

The rebar object can be used by other converters to create a rebar of the specific shape (e.g. RVTFamilyConverter: CreateRebar).


Example

Example
REXFamilyConverter.GetRebar Method (REX.ContentGenerator.Geometry.Contour_3D, REXxyz, REXFamilyType_RebarBarType, bool, REXFamilyType_RebarHook, REXFamilyType_RebarHook, string)

The example shows how to get rebar object based on the specific contour.

//Initializing converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Rebar data (it can be taken from different sources e.g. Revit).
string directory = @"C:\Documents and Settings\All Users\Application Data\Autodesk\Structural\Common Data\2011\Data\Reinf";
REXFamilyType_RebarBarType famRebarType = rex.GetFamilyRebarType("Grade 40", "#8", "bar_ACI 318-08", directory);
REXFamilyType_RebarHook hookStart = new REXFamilyType_RebarHook();
hookStart.Parameters.Angle = EHookAngles.none;
REXFamilyType_RebarHook hookEnd = new REXFamilyType_RebarHook();
hookEnd.Parameters.Angle = EHookAngles.none;

//Contour.
REX.ContentGenerator.Geometry.Contour_3D cont = new REX.ContentGenerator.Geometry.Contour_3D();
cont.StartContour(new REXxyz(0, 0));
cont.LineTo(new REXxyz(2, 0));
cont.LineTo(new REXxyz(2, 1));
REXxyz normal = new REXxyz(0, 0, 1);

//Getting Rebar object from contour.
REXFamilyType_Rebar r = rex.GetRebar(cont, normal, famRebarType, false, hookStart, hookEnd, "barlib7_iso");

The rebar object can be used by other converters to create a rebar of the specific shape (e.g. RVTFamilyConverter: CreateRebar).


Example

Example
REXFamilyConverter.GetRoundRebar Method

The example shows how to get a round rebar.

//Initializing converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Rebar data (it can be taken from different sources e.g. Revit).
string directory = @"C:Documents and SettingsAll UsersApplication DataAutodeskStructuralCommon Data2011DataReinf";
REXFamilyType_RebarBarType famRebarType = rex.GetFamilyRebarType("Grade 40", "#8", "bar_ACI 318-08", directory);

REXFamilyType_RebarHook hookStart = new REXFamilyType_RebarHook();
hookStart.Parameters.Angle = EHookAngles.none;

REXFamilyType_RebarHook hookEnd = new REXFamilyType_RebarHook();
hookEnd.Parameters.Angle = EHookAngles.none;

REX.Common.Geometry.REXxyz normal = new REX.Common.Geometry.REXxyz(0, 0, 1);
REX.Common.Geometry.REXxyz center = new REX.Common.Geometry.REXxyz(0, 0, 0);
double diameter = 1;
double lapSplice = 0.2;

//Getting Rebar object from contour.
REXFamilyType_Rebar r = rex.GetRoundRebar(center,normal,diameter,lapSplice, famRebarType, false, hookStart, hookEnd);

The rebar object can be used by other converters to create a rebar of the specific shape (e.g. RVTFamilyConverter: CreateRebar).


Example

Example
REXFamilyConverter.GetSpiralRebar Method

The example shows how to get a round rebar.

//Initializing converter.
REXFamilyConverter rex = new REXFamilyConverter();

//Rebar data (it can be taken from different sources e.g. Revit).
string directory = @"C:Documents and SettingsAll UsersApplication DataAutodeskStructuralCommon Data2011DataReinf";
REXFamilyType_RebarBarType famRebarType = rex.GetFamilyRebarType("Grade 40", "#8", "bar_ACI 318-08", directory);

REXFamilyType_RebarHook hookStart = new REXFamilyType_RebarHook();
hookStart.Parameters.Angle = EHookAngles.none;

REXFamilyType_RebarHook hookEnd = new REXFamilyType_RebarHook();
hookEnd.Parameters.Angle = EHookAngles.none;

REX.Common.Geometry.REXxyz normal = new REX.Common.Geometry.REXxyz(0, 0, 1);
REX.Common.Geometry.REXxyz center = new REX.Common.Geometry.REXxyz(0, 0, 0);
double diameter = 1;
double height = 2;
double pitch = 0.3;

//Getting Rebar object from contour.
REXFamilyType_Rebar r = rex.GetSpiralRebar(center, normal, diameter,height,pitch, famRebarType, false, hookStart, hookEnd);

The rebar object can be used by other converters to create a rebar of the specific shape (e.g. RVTFamilyConverter: CreateRebar).


Legend

Legend
REXMaterialFactory Class
Legend
Constructor
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXMaterialFactory Class Members

REXMaterialFactory Class Members
REXMaterialFactory Class Legend
Members
Public Methods
Public Method | Description
REXMaterialFactory | This is REXMaterialFactory, a member of class REXMaterialFactory.
REXMaterialFactory Methods
REXMaterialFactory Methods | Description
CompareRows | This is CompareRows, a member of class REXMaterialFactory.
FillDBDescription | This is FillDBDescription, a member of class REXMaterialFactory.
FillDBObjectCollection | This is FillDBObjectCollection, a member of class REXMaterialFactory.
FillFamilyTypeProperties | This is FillFamilyTypeProperties, a member of class REXMaterialFactory.
FillFamilyTypeProperties | This is FillFamilyTypeProperties, a member of class REXMaterialFactory.
GetAliasName | This is GetAliasName, a member of class REXMaterialFactory.
GetFamiliesOfAlias | This is GetFamiliesOfAlias, a member of class REXMaterialFactory.
GetFamilyDefault | This is GetFamilyDefault, a member of class REXMaterialFactory.
GetFamilyOfAlias | This is GetFamilyOfAlias, a member of class REXMaterialFactory.
GetFamilyTemplate | This is GetFamilyTemplate, a member of class REXMaterialFactory.
GetMaterial | This is GetMaterial, a member of class REXMaterialFactory.
GetNewDescription | This is GetNewDescription, a member of class REXMaterialFactory.
GetNewDescription | This is GetNewDescription, a member of class REXMaterialFactory.
GetNewFamily | This is GetNewFamily, a member of class REXMaterialFactory.
GetPropertiesADO | This is GetPropertiesADO, a member of class REXMaterialFactory.
GetPropertiesDBRoot | This is GetPropertiesDBRoot, a member of class REXMaterialFactory.
RecalculatDBDesc | This is RecalculatDBDesc, a member of class REXMaterialFactory.
ValidateDB | This is ValidateDB, a member of class REXMaterialFactory.
ValidateDB | This is ValidateDB, a member of class REXMaterialFactory.


REXMaterialFactory Methods

REXMaterialFactory Methods
REXMaterialFactory Class Legend
REXMaterialFactory Methods
REXMaterialFactory Methods | Description
CompareRows | This is CompareRows, a member of class REXMaterialFactory.
FillDBDescription | This is FillDBDescription, a member of class REXMaterialFactory.
FillDBObjectCollection | This is FillDBObjectCollection, a member of class REXMaterialFactory.
FillFamilyTypeProperties | This is FillFamilyTypeProperties, a member of class REXMaterialFactory.
FillFamilyTypeProperties | This is FillFamilyTypeProperties, a member of class REXMaterialFactory.
GetAliasName | This is GetAliasName, a member of class REXMaterialFactory.
GetFamiliesOfAlias | This is GetFamiliesOfAlias, a member of class REXMaterialFactory.
GetFamilyDefault | This is GetFamilyDefault, a member of class REXMaterialFactory.
GetFamilyOfAlias | This is GetFamilyOfAlias, a member of class REXMaterialFactory.
GetFamilyTemplate | This is GetFamilyTemplate, a member of class REXMaterialFactory.
GetMaterial | This is GetMaterial, a member of class REXMaterialFactory.
GetNewDescription | This is GetNewDescription, a member of class REXMaterialFactory.
GetNewDescription | This is GetNewDescription, a member of class REXMaterialFactory.
GetNewFamily | This is GetNewFamily, a member of class REXMaterialFactory.
GetPropertiesADO | This is GetPropertiesADO, a member of class REXMaterialFactory.
GetPropertiesDBRoot | This is GetPropertiesDBRoot, a member of class REXMaterialFactory.
RecalculatDBDesc | This is RecalculatDBDesc, a member of class REXMaterialFactory.
ValidateDB | This is ValidateDB, a member of class REXMaterialFactory.
ValidateDB | This is ValidateDB, a member of class REXMaterialFactory.


REXMaterialFactory Class Public Methods

REXMaterialFactory Class Public Methods
REXMaterialFactory Class Legend
Public Methods
Public Method | Description
REXMaterialFactory | This is REXMaterialFactory, a member of class REXMaterialFactory.


Legend

Legend
REXParamSectionFactory Class
Legend
Constructor
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXParamSectionFactory Class Members

REXParamSectionFactory Class Members
REXParamSectionFactory Class Legend
Members
Public Methods
Public Method | Description
REXParamSectionFactory | This is REXParamSectionFactory, a member of class REXParamSectionFactory.
REXParamSectionFactory Methods
REXParamSectionFactory Methods | Description
Close | This is Close, a member of class REXParamSectionFactory.
GetAliasName | This is GetAliasName, a member of class REXParamSectionFactory.
GetAllFamilies | This is GetAllFamilies, a member of class REXParamSectionFactory.
GetDBList | This is GetDBList, a member of class REXParamSectionFactory.
GetDBList | This is GetDBList, a member of class REXParamSectionFactory.
GetFamiliesOfAlias | This is GetFamiliesOfAlias, a member of class REXParamSectionFactory.
GetFamily | This is GetFamily, a member of class REXParamSectionFactory.
GetFamilyDefault | This is GetFamilyDefault, a member of class REXParamSectionFactory.
GetFamilyOfAlias | This is GetFamilyOfAlias, a member of class REXParamSectionFactory.
GetFamilyTemplate | This is GetFamilyTemplate, a member of class REXParamSectionFactory.


REXParamSectionFactory Methods

REXParamSectionFactory Methods
REXParamSectionFactory Class Legend
REXParamSectionFactory Methods
REXParamSectionFactory Methods | Description
Close | This is Close, a member of class REXParamSectionFactory.
GetAliasName | This is GetAliasName, a member of class REXParamSectionFactory.
GetAllFamilies | This is GetAllFamilies, a member of class REXParamSectionFactory.
GetDBList | This is GetDBList, a member of class REXParamSectionFactory.
GetDBList | This is GetDBList, a member of class REXParamSectionFactory.
GetFamiliesOfAlias | This is GetFamiliesOfAlias, a member of class REXParamSectionFactory.
GetFamily | This is GetFamily, a member of class REXParamSectionFactory.
GetFamilyDefault | This is GetFamilyDefault, a member of class REXParamSectionFactory.
GetFamilyOfAlias | This is GetFamilyOfAlias, a member of class REXParamSectionFactory.
GetFamilyTemplate | This is GetFamilyTemplate, a member of class REXParamSectionFactory.


REXParamSectionFactory Class Public Methods

REXParamSectionFactory Class Public Methods
REXParamSectionFactory Class Legend
Public Methods
Public Method | Description
REXParamSectionFactory | This is REXParamSectionFactory, a member of class REXParamSectionFactory.


Legend

Legend
RVTCommonSectionFactory Class
Legend
Constructor
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


RVTCommonSectionFactory Class Members

RVTCommonSectionFactory Class Members
RVTCommonSectionFactory Class Legend
Members
Public Methods
Public Method | Description
RVTCommonSectionFactory | This is RVTCommonSectionFactory, a member of class RVTCommonSectionFactory.
RVTCommonSectionFactory Methods
RVTCommonSectionFactory Methods | Description
AddElement2FamList | This is AddElement2FamList, a member of class RVTCommonSectionFactory.
AddElement2FamList | This is AddElement2FamList, a member of class RVTCommonSectionFactory.
GetElement4ParamIdentity | This is GetElement4ParamIdentity, a member of class RVTCommonSectionFactory.
GetExistingNames | This is GetExistingNames, a member of class RVTCommonSectionFactory.
GetName4Mapping | This is GetName4Mapping, a member of class RVTCommonSectionFactory.
GetRevitTypesForInit | This is GetRevitTypesForInit, a member of class RVTCommonSectionFactory.
OnClose | This is OnClose, a member of class RVTCommonSectionFactory.
Recalculate | This is Recalculate, a member of class RVTCommonSectionFactory.
ValidateElement | This is ValidateElement, a member of class RVTCommonSectionFactory.


RVTCommonSectionFactory Methods

RVTCommonSectionFactory Methods
RVTCommonSectionFactory Class Legend
RVTCommonSectionFactory Methods
RVTCommonSectionFactory Methods | Description
AddElement2FamList | This is AddElement2FamList, a member of class RVTCommonSectionFactory.
AddElement2FamList | This is AddElement2FamList, a member of class RVTCommonSectionFactory.
GetElement4ParamIdentity | This is GetElement4ParamIdentity, a member of class RVTCommonSectionFactory.
GetExistingNames | This is GetExistingNames, a member of class RVTCommonSectionFactory.
GetName4Mapping | This is GetName4Mapping, a member of class RVTCommonSectionFactory.
GetRevitTypesForInit | This is GetRevitTypesForInit, a member of class RVTCommonSectionFactory.
OnClose | This is OnClose, a member of class RVTCommonSectionFactory.
Recalculate | This is Recalculate, a member of class RVTCommonSectionFactory.
ValidateElement | This is ValidateElement, a member of class RVTCommonSectionFactory.


RVTCommonSectionFactory Class Public Methods

RVTCommonSectionFactory Class Public Methods
RVTCommonSectionFactory Class Legend
Public Methods
Public Method | Description
RVTCommonSectionFactory | This is RVTCommonSectionFactory, a member of class RVTCommonSectionFactory.


Legend

Legend
RVTCustomFactory Class
Legend
Constructor
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


RVTCustomFactory Class Members

RVTCustomFactory Class Members
RVTCustomFactory Class Legend
Members
Public Methods
Public Method | Description
RVTCustomFactory | This is RVTCustomFactory, a member of class RVTCustomFactory.
RVTCustomFactory Methods
RVTCustomFactory Methods | Description
AddElement2FamList | This is AddElement2FamList, a member of class RVTCustomFactory.
AddElement2FamList | This is AddElement2FamList, a member of class RVTCustomFactory.
GetExistingNames | This is GetExistingNames, a member of class RVTCustomFactory.
GetRevitTypesForInit | This is GetRevitTypesForInit, a member of class RVTCustomFactory.
GetSubCategory | This is GetSubCategory, a member of class RVTCustomFactory.
Recalculate | This is Recalculate, a member of class RVTCustomFactory.
Recalculate | This is Recalculate, a member of class RVTCustomFactory.
ValidateElement | This is ValidateElement, a member of class RVTCustomFactory.


RVTCustomFactory Methods

RVTCustomFactory Methods
RVTCustomFactory Class Legend
RVTCustomFactory Methods
RVTCustomFactory Methods | Description
AddElement2FamList | This is AddElement2FamList, a member of class RVTCustomFactory.
AddElement2FamList | This is AddElement2FamList, a member of class RVTCustomFactory.
GetExistingNames | This is GetExistingNames, a member of class RVTCustomFactory.
GetRevitTypesForInit | This is GetRevitTypesForInit, a member of class RVTCustomFactory.
GetSubCategory | This is GetSubCategory, a member of class RVTCustomFactory.
Recalculate | This is Recalculate, a member of class RVTCustomFactory.
Recalculate | This is Recalculate, a member of class RVTCustomFactory.
ValidateElement | This is ValidateElement, a member of class RVTCustomFactory.


RVTCustomFactory Class Public Methods

RVTCustomFactory Class Public Methods
RVTCustomFactory Class Legend
Public Methods
Public Method | Description
RVTCustomFactory | This is RVTCustomFactory, a member of class RVTCustomFactory.


Legend

Legend
RVTDBSectionFactory Class
Legend
Constructor
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


RVTDBSectionFactory Class Members

RVTDBSectionFactory Class Members
RVTDBSectionFactory Class Legend
Members
Public Methods
Public Method | Description
RVTDBSectionFactory | This is RVTDBSectionFactory, a member of class RVTDBSectionFactory.
RVTDBSectionFactory Methods
RVTDBSectionFactory Methods | Description
IsElementSupported | This is IsElementSupported, a member of class RVTDBSectionFactory.
Recalculate | This is Recalculate, a member of class RVTDBSectionFactory.


RVTDBSectionFactory Methods

RVTDBSectionFactory Methods
RVTDBSectionFactory Class Legend
RVTDBSectionFactory Methods
RVTDBSectionFactory Methods | Description
IsElementSupported | This is IsElementSupported, a member of class RVTDBSectionFactory.
Recalculate | This is Recalculate, a member of class RVTDBSectionFactory.


RVTDBSectionFactory Class Public Methods

RVTDBSectionFactory Class Public Methods
RVTDBSectionFactory Class Legend
Public Methods
Public Method | Description
RVTDBSectionFactory | This is RVTDBSectionFactory, a member of class RVTDBSectionFactory.


RVTFamilyConverter Events

RVTFamilyConverter Events
RVTFamilyConverter Class Legend
RVTFamilyConverter Events
RVTFamilyConverter Events | Description
EventElementGenerated | Occurs when element is generated (when the list of elements is used).


Legend

Legend
RVTFamilyConverter Class
Legend
Constructor
Property
Event
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


RVTFamilyConverter Class Members

RVTFamilyConverter Class Members
RVTFamilyConverter Class Legend
Members
Public Methods
Public Method | Description
RVTFamilyConverter | Initializes a new instance of the RVTFamilyConverter class.
RVTFamilyConverter | Initializes a new instance of the RVTFamilyConverter class.
RVTFamilyConverter Methods
RVTFamilyConverter Methods | Description
Close | Saves data to the Revit document, clears collections, releases objects.
CreateRebar | Creates the rebar element based on the input REXFamilyType_Rebar object.
GetCertifiedCategoryOfElement | Gets category of the certified element.
GetElement | Gets the Revit element created based on the REXFamilyType object.
GetElement | Gets the Revit element created based on the REXFamilyType object.
GetElement | Gets the Revit element created based on the REXFamilyType object.
GetElements | Gets the list of Revit elements created based on the list of REXFamilyTypes.
GetExistingNames | Returns the list of names existing for specific REXFamilyType object.
GetFamily | Gets the REXFamilyType object based on the input element.
GetFamily | Gets the REXFamilyType object based on the input element.
GetFamily | Gets the REXFamilyType object based on the input element.
GetRebarContour | Gets the rebar's contour based on the Revit element.
InitGlobal | Initializes lists of existing families from the Active Document.
IsElementSupported | This is IsElementSupported, a member of class RVTFamilyConverter.
RegisterCustomFactory | Registers the custom factory.
Temporary | This is Temporary, a member of class RVTFamilyConverter.
RVTFamilyConverter Properties
RVTFamilyConverter Properties | Description
ContentMapper | Gets the mapper object.
Settings | Gets the settings.
RVTFamilyConverter Events
RVTFamilyConverter Events | Description
EventElementGenerated | Occurs when element is generated (when the list of elements is used).


Members

Legend
Legend
Constructor
Property
Event
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


RVTFamilyConverter Methods

RVTFamilyConverter Methods
RVTFamilyConverter Class Legend
RVTFamilyConverter Methods
RVTFamilyConverter Methods | Description
Close | Saves data to the Revit document, clears collections, releases objects.
CreateRebar | Creates the rebar element based on the input REXFamilyType_Rebar object.
GetCertifiedCategoryOfElement | Gets category of the certified element.
GetElement | Gets the Revit element created based on the REXFamilyType object.
GetElement | Gets the Revit element created based on the REXFamilyType object.
GetElement | Gets the Revit element created based on the REXFamilyType object.
GetElements | Gets the list of Revit elements created based on the list of REXFamilyTypes.
GetExistingNames | Returns the list of names existing for specific REXFamilyType object.
GetFamily | Gets the REXFamilyType object based on the input element.
GetFamily | Gets the REXFamilyType object based on the input element.
GetFamily | Gets the REXFamilyType object based on the input element.
GetRebarContour | Gets the rebar's contour based on the Revit element.
InitGlobal | Initializes lists of existing families from the Active Document.
IsElementSupported | This is IsElementSupported, a member of class RVTFamilyConverter.
RegisterCustomFactory | Registers the custom factory.
Temporary | This is Temporary, a member of class RVTFamilyConverter.


RVTFamilyConverter Properties

RVTFamilyConverter Properties
RVTFamilyConverter Class Legend
RVTFamilyConverter Properties
RVTFamilyConverter Properties | Description
ContentMapper | Gets the mapper object.
Settings | Gets the settings.


RVTFamilyConverter Class Public Methods

RVTFamilyConverter Class Public Methods
RVTFamilyConverter Class Legend
Public Methods
Public Method | Description
RVTFamilyConverter | Initializes a new instance of the RVTFamilyConverter class.
RVTFamilyConverter | Initializes a new instance of the RVTFamilyConverter class.


Example

Example
RVTFamilyConverter.CreateRebar Method

The example shows how to get the rebar element in Revit based on specific shape from the database.

//Initializing converters.
REXFamilyConverter rex = new REXFamilyConverter();//Needed for proper rebar description.
RVTFamilyConverter rvt = new RVTFamilyConverter(commandData, true);

//The RebarType taken from the Revit project (the first one on the list).
System.Collections.IEnumerator it = commandData.Application.ActiveUIDocument.Document.RebarBarTypes.GetEnumerator();
it.MoveNext();
RebarBarType RevitRebarBarType = (RebarBarType)it.Current;
REXFamilyType_RebarBarType rbt = (REXFamilyType_RebarBarType)rvt.GetFamily(RevitRebarBarType);
//Using Element property to use particular element as RebarType.
rbt.Element=RevitRebarBarType;

//The RebarHook taken from the Revit project (the first one on the list).
it = commandData.Application.ActiveUIDocument.Document.RebarHookTypes.GetEnumerator();
it.MoveNext();
RebarHookType RevitRebarHookType = (RebarHookType)it.Current;
REXFamilyType_RebarHook rht = (REXFamilyType_RebarHook)rvt.GetFamily(RevitRebarHookType);
//Using Element property to use particular element as RebarType.
rht.Element = RevitRebarHookType;

//defining contour
List<REX.Common.Geometry.REXxyz> l = new List<REX.Common.Geometry.REXxyz>();

l.Add(new REX.Common.Geometry.REXxyz(0, 0));
l.Add(new REX.Common.Geometry.REXxyz(2, 0));

//Getting the rebar object.
REXFamilyType_Rebar r = rex.GetRebar(l, rbt,false,rht,rht,"barlib7_iso");

//Creating the rebar in Revit.
it = commandData.Application.ActiveUIDocument.Selection.Elements.GetEnumerator();
it.MoveNext();
Element host = (Element)it.Current;
Rebar RevitRebar = rvt.CreateRebar(r, host);

rvt.Close();//!!To clear structures and save data to the project.


Example

Example
RVTFamilyConverter.GetCertifiedCategoryOfElement Method

The example shows how to learn if some specific element is certified and get the category of it.

//Initializing the converter.
RVTFamilyConverter rvt = new RVTFamilyConverter(commandData, true);

//Iteration threw all rebars selected in Revit.
FilteredElementCollector filterCollector = new FilteredElementCollector(commandData.Application.ActiveUIDocument.Document);
foreach (Element el in filterCollector.WhereElementIsElementType())
{
    ECategoryType category = rvt.GetCertifiedCategoryOfElement(el);

    REXFamilyType familyType = null;

    if (category != ECategoryType.UNKNOWN)//certified
    {
           familyType = rvt.GetFamily(el, category);
    }
    else//not certified
    {
        if (el is RebarHookType)
        {
            familyType = rvt.GetFamily(el, ECategoryType.REBAR_HOOK);
        }
        else if(el is RebarBarType)
        {
            familyType = rvt.GetFamily(el, ECategoryType.REBAR_BARTYPE);
        }
        else if (el is RebarShape)
        {
            familyType = rvt.GetFamily(el, ECategoryType.REBAR_SHAPE);
        }
        else if (el is FamilyInstance)
       {
            familyType = rvt.GetFamily(el, ECategoryType.SECTION_PARAM);
        }
    }
}


Example

Example
RVTFamilyConverter.GetElement Method (REXFamilyType, ECategoryType)

The example shows how to get Revit element bases on the REXFamilyType object.

//Initialize the converter.
RVTFamilyConverter rvt = new RVTFamilyConverter(commandData, true);

//creating parametric description
REXFamilyType_ParamSection paramSection = new REXFamilyType_ParamSection();
paramSection.ElementType = REX.ContentGenerator.Families.EElementType.BEAM;
paramSection.Material = EMaterial.CONCRETE;

//seting parameters
paramSection.Parameters.SectionType = ESectionType.RECT;
paramSection.Parameters.Tapered = false;
//setting dimensions
paramSection.Parameters.Dimensions.h = 0.3;
paramSection.Parameters.Dimensions.b = 0.2;
paramSection.Parameters.CalculataMainAxisAndCharacteristics();
paramSection.TypeName = "RECT1";

//getting Revit element
Element el = rvt.GetElement(paramSection, ECategoryType.SECTION_PARAM);
FamilySymbol fs = el as FamilySymbol;


Example

Example
RVTFamilyConverter.GetElement Method (REXFamilyType)

The example shows how to get Revit element bases on the REXFamilyType object.

//Initialize the converter.
RVTFamilyConverter rvt = new RVTFamilyConverter(commandData, true);

//creating parametric description
REXFamilyType_ParamSection paramSection = new REXFamilyType_ParamSection();
paramSection.ElementType = REX.ContentGenerator.Families.EElementType.BEAM;
paramSection.Material = EMaterial.CONCRETE;

//seting parameters
paramSection.Parameters.SectionType = ESectionType.RECT;
paramSection.Parameters.Tapered = false;
//setting dimensions
paramSection.Parameters.Dimensions.h = 0.3;
paramSection.Parameters.Dimensions.b = 0.2;
paramSection.Parameters.CalculataMainAxisAndCharacteristics();
paramSection.TypeName = "RECT1";

//getting Revit element
Element el = rvt.GetElement(paramSection);
FamilySymbol fs = el as FamilySymbol;


Example

Example
RVTFamilyConverter.GetElements Method

The example shows how to get the list of Revit elements based on the list of the REXFamilyType.

//Initialize the converter.
RVTFamilyConverter rvt = new RVTFamilyConverter(commandData, true);

rvt.EventElementGenerated += new ElementGenerated(rvt_EventElementGenerated);

List<REXFamilyType> families = new List<REXFamilyType>();

for (int i = 1; i < 4; i++)
{
    //creating parametric description
    REXFamilyType_ParamSection paramSection = new REXFamilyType_ParamSection();
    paramSection.ElementType = REX.ContentGenerator.Families.EElementType.BEAM;
    paramSection.Material = EMaterial.CONCRETE;
    paramSection.Parameters.SectionType = ESectionType.RECT;
    paramSection.Parameters.Tapered = false;
    paramSection.Parameters.Dimensions.h = i*0.2;
    paramSection.Parameters.Dimensions.b = i*0.1;
    paramSection.Parameters.CalculataMainAxisAndCharacteristics();
    paramSection.TypeName = "RECT" + i.ToString();
    families.Add(paramSection);
}

List<Element> elements = rvt.GetElements(families, ECategoryType.SECTION_PARAM);

static void rvt_EventElementGenerated(string id)
{
}


Example

Example
RVTFamilyConverter.GetFamily Method (RevitElement, ECategoryType)

The example shows how to get REXFamilyType from the element defined in Revit.

//Initializing the converter.
RVTFamilyConverter rvt = new RVTFamilyConverter(commandData, true);

//Investigation of selected FamilyInstances
foreach(Element el in commandData.Application.ActiveUIDocument.Selection.Elements)
{
    FamilyInstance famInstance = el as FamilyInstance;

    if (famInstance != null
       && (famInstance.StructuralType == Autodesk.Revit.DB.Structure.StructuralType.Beam
       || famInstance.StructuralType == Autodesk.Revit.DB.Structure.StructuralType.Brace
       || famInstance.StructuralType == Autodesk.Revit.DB.Structure.StructuralType.Column))
    {
        //Geting REXFamilyType object from the current element.
        REXFamilyType fam = rvt.GetFamily(famInstance, ECategoryType.SECTION_PARAM);

        if (fam != null)
        {
            REXFamilyType_ParamSection paramSection = fam as REXFamilyType_ParamSection;
        }
    }
}


Example

Example
RVTFamilyConverter.GetFamily Method (RevitElement)

The example shows how to get REXFamilyType from the element defined in Revit.

//Initializing the converter.
RVTFamilyConverter rvt = new RVTFamilyConverter(commandData, true);

//Investigation of selected FamilyInstances
foreach(Element el in commandData.Application.ActiveUIDocument.Selection.Elements)
{
    FamilyInstance famInstance = el as FamilyInstance;

    if (famInstance != null
       && (famInstance.StructuralType == Autodesk.Revit.DB.Structure.StructuralType.Beam
       || famInstance.StructuralType == Autodesk.Revit.DB.Structure.StructuralType.Brace
       || famInstance.StructuralType == Autodesk.Revit.DB.Structure.StructuralType.Column))
    {
        //Geting REXFamilyType object from the current element.
        REXFamilyType fam = rvt.GetFamily(famInstance);

        if (fam != null)
        {
            //parametric section
            REXFamilyType_ParamSection paramSection = fam as REXFamilyType_ParamSection;

            if (paramSection != null)
            {
                continue;
            }

            //database section
            REXFamilyType_DBSection dbSection = fam as REXFamilyType_DBSection;

            if (dbSection != null)
            {
               continue;
            }
        }
    }
}


Example

Example
RVTFamilyConverter.GetRebarContour Method

The example shows how to get a simplified rebar contour (without bending segments) from the Revit rebar.

//Initializing the converter.
RVTFamilyConverter rvt = new RVTFamilyConverter(commandData, true);

//Iteration threw all rebars selected in Revit.
foreach (Element el in commandData.Application.ActiveUIDocument.Selection.Elements)
{
    Rebar r = el as Rebar;

    if (r != null)
    {
        REX.Common.Geometry.REXxyz normal;
        REX.Common.Geometry.REXxyz distribution;
        double spacing;
        int count;

        REX.ContentGenerator.Geometry.Contour_3D cont3D = rvt.GetRebarContour(r, out normal, out spacing, out count, out distribution);
    }
}


Legend

Legend
RVTMaterialFactory Class
Legend
Constructor
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


RVTMaterialFactory Class Members

RVTMaterialFactory Class Members
RVTMaterialFactory Class Legend
Members
Public Methods
Public Method | Description
RVTMaterialFactory | This is RVTMaterialFactory, a member of class RVTMaterialFactory.
RVTMaterialFactory | This is RVTMaterialFactory, a member of class RVTMaterialFactory.
RVTMaterialFactory Methods
RVTMaterialFactory Methods | Description
AddElement2FamList | This is AddElement2FamList, a member of class RVTMaterialFactory.
AddElement2FamList | This is AddElement2FamList, a member of class RVTMaterialFactory.
CreateNewMaterial | This is CreateNewMaterial, a member of class RVTMaterialFactory.
GetExistingNames | This is GetExistingNames, a member of class RVTMaterialFactory.
GetMaterialTypeCompLevel | This is GetMaterialTypeCompLevel, a member of class RVTMaterialFactory.
GetRevitTypesForInit | This is GetRevitTypesForInit, a member of class RVTMaterialFactory.
InitList | This is InitList, a member of class RVTMaterialFactory.
OnClose | This is OnClose, a member of class RVTMaterialFactory.
Recalculate | This is Recalculate, a member of class RVTMaterialFactory.
ValidateElement | This is ValidateElement, a member of class RVTMaterialFactory.


RVTMaterialFactory Methods

RVTMaterialFactory Methods
RVTMaterialFactory Class Legend
RVTMaterialFactory Methods
RVTMaterialFactory Methods | Description
AddElement2FamList | This is AddElement2FamList, a member of class RVTMaterialFactory.
AddElement2FamList | This is AddElement2FamList, a member of class RVTMaterialFactory.
CreateNewMaterial | This is CreateNewMaterial, a member of class RVTMaterialFactory.
GetExistingNames | This is GetExistingNames, a member of class RVTMaterialFactory.
GetMaterialTypeCompLevel | This is GetMaterialTypeCompLevel, a member of class RVTMaterialFactory.
GetRevitTypesForInit | This is GetRevitTypesForInit, a member of class RVTMaterialFactory.
InitList | This is InitList, a member of class RVTMaterialFactory.
OnClose | This is OnClose, a member of class RVTMaterialFactory.
Recalculate | This is Recalculate, a member of class RVTMaterialFactory.
ValidateElement | This is ValidateElement, a member of class RVTMaterialFactory.


RVTMaterialFactory Class Public Methods

RVTMaterialFactory Class Public Methods
RVTMaterialFactory Class Legend
Public Methods
Public Method | Description
RVTMaterialFactory | This is RVTMaterialFactory, a member of class RVTMaterialFactory.
RVTMaterialFactory | This is RVTMaterialFactory, a member of class RVTMaterialFactory.


Legend

Legend
RVTMaterialPropertySetFactory Class
Legend
Constructor
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


RVTMaterialPropertySetFactory Class Members

RVTMaterialPropertySetFactory Class Members
RVTMaterialPropertySetFactory Class Legend
Members
Public Methods
Public Method | Description
RVTMaterialPropertySetFactory | This is RVTMaterialPropertySetFactory, a member of class RVTMaterialPropertySetFactory.
RVTMaterialPropertySetFactory | This is RVTMaterialPropertySetFactory, a member of class RVTMaterialPropertySetFactory.
RVTMaterialPropertySetFactory Methods
RVTMaterialPropertySetFactory Methods | Description
AddElement2FamList | This is AddElement2FamList, a member of class RVTMaterialPropertySetFactory.
AddElement2FamList | This is AddElement2FamList, a member of class RVTMaterialPropertySetFactory.
CreateNewPropertySet | This is CreateNewPropertySet, a member of class RVTMaterialPropertySetFactory.
GetConcreteParameter | This is GetConcreteParameter, a member of class RVTMaterialPropertySetFactory.
GetExistingNames | This is GetExistingNames, a member of class RVTMaterialPropertySetFactory.
GetGenericParameter | This is GetGenericParameter, a member of class RVTMaterialPropertySetFactory.
GetMaterialParams | This is GetMaterialParams, a member of class RVTMaterialPropertySetFactory.
GetMaterialTypeCompLevel | This is GetMaterialTypeCompLevel, a member of class RVTMaterialPropertySetFactory.
GetParameter | This is GetParameter, a member of class RVTMaterialPropertySetFactory.
GetRevitTypesForInit | This is GetRevitTypesForInit, a member of class RVTMaterialPropertySetFactory.
GetSteelParameter | This is GetSteelParameter, a member of class RVTMaterialPropertySetFactory.
GetWoodParameter | This is GetWoodParameter, a member of class RVTMaterialPropertySetFactory.
InitList | This is InitList, a member of class RVTMaterialPropertySetFactory.
OnClose | This is OnClose, a member of class RVTMaterialPropertySetFactory.
Recalculate | This is Recalculate, a member of class RVTMaterialPropertySetFactory.
ValidateElement | This is ValidateElement, a member of class RVTMaterialPropertySetFactory.


RVTMaterialPropertySetFactory Methods

RVTMaterialPropertySetFactory Methods
RVTMaterialPropertySetFactory Class Legend
RVTMaterialPropertySetFactory Methods
RVTMaterialPropertySetFactory Methods | Description
AddElement2FamList | This is AddElement2FamList, a member of class RVTMaterialPropertySetFactory.
AddElement2FamList | This is AddElement2FamList, a member of class RVTMaterialPropertySetFactory.
CreateNewPropertySet | This is CreateNewPropertySet, a member of class RVTMaterialPropertySetFactory.
GetConcreteParameter | This is GetConcreteParameter, a member of class RVTMaterialPropertySetFactory.
GetExistingNames | This is GetExistingNames, a member of class RVTMaterialPropertySetFactory.
GetGenericParameter | This is GetGenericParameter, a member of class RVTMaterialPropertySetFactory.
GetMaterialParams | This is GetMaterialParams, a member of class RVTMaterialPropertySetFactory.
GetMaterialTypeCompLevel | This is GetMaterialTypeCompLevel, a member of class RVTMaterialPropertySetFactory.
GetParameter | This is GetParameter, a member of class RVTMaterialPropertySetFactory.
GetRevitTypesForInit | This is GetRevitTypesForInit, a member of class RVTMaterialPropertySetFactory.
GetSteelParameter | This is GetSteelParameter, a member of class RVTMaterialPropertySetFactory.
GetWoodParameter | This is GetWoodParameter, a member of class RVTMaterialPropertySetFactory.
InitList | This is InitList, a member of class RVTMaterialPropertySetFactory.
OnClose | This is OnClose, a member of class RVTMaterialPropertySetFactory.
Recalculate | This is Recalculate, a member of class RVTMaterialPropertySetFactory.
ValidateElement | This is ValidateElement, a member of class RVTMaterialPropertySetFactory.


RVTMaterialPropertySetFactory Class Public Methods

RVTMaterialPropertySetFactory Class Public Methods
RVTMaterialPropertySetFactory Class Legend
Public Methods
Public Method | Description
RVTMaterialPropertySetFactory | This is RVTMaterialPropertySetFactory, a member of class RVTMaterialPropertySetFactory.
RVTMaterialPropertySetFactory | This is RVTMaterialPropertySetFactory, a member of class RVTMaterialPropertySetFactory.


Legend

Legend
RVTSectionFactory Class
Legend
Constructor
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


RVTSectionFactory Class Members

RVTSectionFactory Class Members
RVTSectionFactory Class Legend
Members
Public Methods
Public Method | Description
RVTSectionFactory | This is RVTSectionFactory, a member of class RVTSectionFactory.
RVTSectionFactory Methods
RVTSectionFactory Methods | Description
AddElement2FamList | This is AddElement2FamList, a member of class RVTSectionFactory.
AddElement2FamList | This is AddElement2FamList, a member of class RVTSectionFactory.
GetElement | This is GetElement, a member of class RVTSectionFactory.
GetElement4ParamIdentity | This is GetElement4ParamIdentity, a member of class RVTSectionFactory.
GetElements | This is GetElements, a member of class RVTSectionFactory.
GetExistingNames | This is GetExistingNames, a member of class RVTSectionFactory.
GetFactory | This is GetFactory, a member of class RVTSectionFactory.
GetFactoryForGeneral | This is GetFactoryForGeneral, a member of class RVTSectionFactory.
GetFamily | This is GetFamily, a member of class RVTSectionFactory.
GetName4Mapping | This is GetName4Mapping, a member of class RVTSectionFactory.
GetRevitTypesForInit | This is GetRevitTypesForInit, a member of class RVTSectionFactory.
InitList | This is InitList, a member of class RVTSectionFactory.
IsElementSupported | This is IsElementSupported, a member of class RVTSectionFactory.
OnClose | This is OnClose, a member of class RVTSectionFactory.
Recalculate | This is Recalculate, a member of class RVTSectionFactory.
ResetFamilyBufor | This is ResetFamilyBufor, a member of class RVTSectionFactory.
ValidateElement | This is ValidateElement, a member of class RVTSectionFactory.


RVTSectionFactory Methods

RVTSectionFactory Methods
RVTSectionFactory Class Legend
RVTSectionFactory Methods
RVTSectionFactory Methods | Description
AddElement2FamList | This is AddElement2FamList, a member of class RVTSectionFactory.
AddElement2FamList | This is AddElement2FamList, a member of class RVTSectionFactory.
GetElement | This is GetElement, a member of class RVTSectionFactory.
GetElement4ParamIdentity | This is GetElement4ParamIdentity, a member of class RVTSectionFactory.
GetElements | This is GetElements, a member of class RVTSectionFactory.
GetExistingNames | This is GetExistingNames, a member of class RVTSectionFactory.
GetFactory | This is GetFactory, a member of class RVTSectionFactory.
GetFactoryForGeneral | This is GetFactoryForGeneral, a member of class RVTSectionFactory.
GetFamily | This is GetFamily, a member of class RVTSectionFactory.
GetName4Mapping | This is GetName4Mapping, a member of class RVTSectionFactory.
GetRevitTypesForInit | This is GetRevitTypesForInit, a member of class RVTSectionFactory.
InitList | This is InitList, a member of class RVTSectionFactory.
IsElementSupported | This is IsElementSupported, a member of class RVTSectionFactory.
OnClose | This is OnClose, a member of class RVTSectionFactory.
Recalculate | This is Recalculate, a member of class RVTSectionFactory.
ResetFamilyBufor | This is ResetFamilyBufor, a member of class RVTSectionFactory.
ValidateElement | This is ValidateElement, a member of class RVTSectionFactory.


RVTSectionFactory Class Public Methods

RVTSectionFactory Class Public Methods
RVTSectionFactory Class Legend
Public Methods
Public Method | Description
RVTSectionFactory | This is RVTSectionFactory, a member of class RVTSectionFactory.


Legend

Legend
RVTSectionParamFactory Class
Legend
Constructor
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


RVTSectionParamFactory Class Members

RVTSectionParamFactory Class Members
RVTSectionParamFactory Class Legend
Members
Public Methods
Public Method | Description
RVTSectionParamFactory | This is RVTSectionParamFactory, a member of class RVTSectionParamFactory.
RVTSectionParamFactory Methods
RVTSectionParamFactory Methods | Description
AddFamily2ProjectDictionary | This is AddFamily2ProjectDictionary, a member of class RVTSectionParamFactory.
IsElementSupported | This is IsElementSupported, a member of class RVTSectionParamFactory.
Recalculate | This is Recalculate, a member of class RVTSectionParamFactory.


RVTSectionParamFactory Methods

RVTSectionParamFactory Methods
RVTSectionParamFactory Class Legend
RVTSectionParamFactory Methods
RVTSectionParamFactory Methods | Description
AddFamily2ProjectDictionary | This is AddFamily2ProjectDictionary, a member of class RVTSectionParamFactory.
IsElementSupported | This is IsElementSupported, a member of class RVTSectionParamFactory.
Recalculate | This is Recalculate, a member of class RVTSectionParamFactory.


RVTSectionParamFactory Class Public Methods

RVTSectionParamFactory Class Public Methods
RVTSectionParamFactory Class Legend
Public Methods
Public Method | Description
RVTSectionParamFactory | This is RVTSectionParamFactory, a member of class RVTSectionParamFactory.


REX.ContentGenerator.Dialog Namespace Classes

REX.ContentGenerator.Dialog Namespace Classes
REX.ContentGenerator.Dialog Namespace Legend
Classes
Class | Description
REXContentDialogCategorySettings | Contains settings for specific category.
REXContentDialogManager | Helps manage DRevitContentGenerator Extension directly by code.
REXContentDialogSettings | Describes settings of the ContentGenerator dialog.


Legend

Legend
REX.ContentGenerator.Dialog Namespace
Legend
Class
Enumeration
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REX.ContentGenerator.Dialog Namespace Structs, Records, Enums

REX.ContentGenerator.Dialog Namespace Structs, Records, Enums
REX.ContentGenerator.Dialog Namespace Legend
Structs, Records, Enums
Struct, Record, Enum | Description
EContentDialogMode | Describes modes in which the ContentGenerator dialog may be run.


Legend

Legend
REXContentDialogCategorySettings Class
Legend
Constructor
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXContentDialogCategorySettings Class Members

REXContentDialogCategorySettings Class Members
REXContentDialogCategorySettings Class Legend
Members
Public Methods
Public Method | Description
REXContentDialogCategorySettings | Initializes a new instance of the REXContentDialogCategorySettings class.
REXContentDialogCategorySettings Properties
REXContentDialogCategorySettings Properties | Description
Category | Gets the category type.
Databases | Gets or sets the list of databases.
SelectedElement | Gets or sets the selected element.
SelectedElements | Gets the selected elements.
Visible | Gets or sets a value indicating whether this category is visible.


REXContentDialogCategorySettings Properties

REXContentDialogCategorySettings Properties
REXContentDialogCategorySettings Class Legend
REXContentDialogCategorySettings Properties
REXContentDialogCategorySettings Properties | Description
Category | Gets the category type.
Databases | Gets or sets the list of databases.
SelectedElement | Gets or sets the selected element.
SelectedElements | Gets the selected elements.
Visible | Gets or sets a value indicating whether this category is visible.


REXContentDialogCategorySettings Class Public Methods

REXContentDialogCategorySettings Class Public Methods
REXContentDialogCategorySettings Class Legend
Public Methods
Public Method | Description
REXContentDialogCategorySettings | Initializes a new instance of the REXContentDialogCategorySettings class.


Legend

Legend
REXContentDialogManager Class
Legend
Constructor
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXContentDialogManager Class Members

REXContentDialogManager Class Members
REXContentDialogManager Class Legend
Members
Public Methods
Public Method | Description
REXContentDialogManager | Initializes a new instance of the REXContentDialogManager class.
REXContentDialogManager Methods
REXContentDialogManager Methods | Description
DisposeContentDialog | Disposes the DRevitContentGenerator Extension.
SetApplicationInstance | Sets the Extension Instance.
ShowContentDialog | Loads the ContentGenerator dialog.
ShowContentDialogParentIntPtr | Loads the ContentGenerator dialog.


REXContentDialogManager Methods

REXContentDialogManager Methods
REXContentDialogManager Class Legend
REXContentDialogManager Methods
REXContentDialogManager Methods | Description
DisposeContentDialog | Disposes the DRevitContentGenerator Extension.
SetApplicationInstance | Sets the Extension Instance.
ShowContentDialog | Loads the ContentGenerator dialog.
ShowContentDialogParentIntPtr | Loads the ContentGenerator dialog.


REXContentDialogManager Class Public Methods

REXContentDialogManager Class Public Methods
REXContentDialogManager Class Legend
Public Methods
Public Method | Description
REXContentDialogManager | Initializes a new instance of the REXContentDialogManager class.


Example

Example
REXContentDialogManager.ShowContentDialog Method

The example shows how to launch the DRevitContentGenerator dialog and use it as a family browser.

//Manager initialize.
REX.ContentGenerator.Dialog.REXContentDialogManager mng = new REX.ContentGenerator.Dialog.REXContentDialogManager(ThisExtension.Context);

//Settings initialize
//-general
REX.ContentGenerator.Dialog.REXContentDialogSettings settings = new REX.ContentGenerator.Dialog.REXContentDialogSettings();
settings.DialogMode = REX.ContentGenerator.Dialog.EContentDialogMode.MultiSelection;
settings.RegionalSettings = true;
settings.ShowList = true;
settings.Progress = false;
settings.Caption = "Example1";
//-for sections
settings.SectionDBSettings.SelectedElements.Clear();
settings.SectionDBSettings.Visible = true;

//Launching the dialog.
mng.ShowContentDialog(settings, ThisExtension.GetWindowForParent());

//Getting selection.
List<REXFamilyType> families = new List<REXFamilyType>(settings.SectionDBSettings.SelectedElements);

//Disposing dialog.
mng.DisposeContentDialog();


Example

Example
REXContentDialogManager.ShowContentDialogParentIntPtr Method

The example shows how to launch the DRevitContentGenerator dialog and use it as a family browser.

//Manager initialize.
REX.ContentGenerator.Dialog.REXContentDialogManager mng = new REX.ContentGenerator.Dialog.REXContentDialogManager(ThisExtension.Context);

//Settings initialize
//-general
REX.ContentGenerator.Dialog.REXContentDialogSettings settings = new REX.ContentGenerator.Dialog.REXContentDialogSettings();
settings.DialogMode = REX.ContentGenerator.Dialog.EContentDialogMode.MultiSelection;
settings.RegionalSettings = true;
settings.ShowList = true;
settings.Progress = false;
settings.Caption = "Example1";
//-for sections
settings.SectionDBSettings.SelectedElements.Clear();
settings.SectionDBSettings.Visible = true;

//Launching the dialog.
mng.ShowContentDialog(settings, ThisExtension.GetWindowForParent().Handle);

//Getting selection.
List<REXFamilyType> families = new List<REXFamilyType>(settings.SectionDBSettings.SelectedElements);

//Disposing dialog.
mng.DisposeContentDialog();


Legend

Legend
REXContentDialogSettings Class
Legend
Constructor
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXContentDialogSettings Class Members

REXContentDialogSettings Class Members
REXContentDialogSettings Class Legend
Members
Public Methods
Public Method | Description
REXContentDialogSettings | Initializes a new instance of the REXContentDialogSettings class.
REXContentDialogSettings Methods
REXContentDialogSettings Methods | Description
GetSettings | Gets settings.
GetVisibleCategories | Gets visible categories.
IsVisible | Determines whether the specified category is visible.
SetOneCategoryVisible | Sets visibility of specific category.
REXContentDialogSettings Properties
REXContentDialogSettings Properties | Description
Caption | Gets or sets the caption.
Categories | Gets or sets the settings for all categories.
DialogIcon | Gets or sets the dialog icon.
DialogMode | Gets or sets the dialog mode.
MaterialSettings | Gets the settings for the material category.
Progress | Gets or sets a value indicating whether a progress bar should be visible.
RebarShapeSettings | Gets the settings for the rebar shape category.
RebarTypeSettings | Gets the settings for the rebar type category.
RegionalSettings | Gets or sets a value indicating whether regional settings are supported.
SectionDBSettings | Gets the settings for the database section category..
SectionParamSettings | Gets the settings for the parametric section category.
ShowList | Gets or sets a value indicating whether the list of categories should be visible.
ValidateTypes | Gets or sets a value indicating whether types should be validated.


REXContentDialogSettings Methods

REXContentDialogSettings Methods
REXContentDialogSettings Class Legend
REXContentDialogSettings Methods
REXContentDialogSettings Methods | Description
GetSettings | Gets settings.
GetVisibleCategories | Gets visible categories.
IsVisible | Determines whether the specified category is visible.
SetOneCategoryVisible | Sets visibility of specific category.


REXContentDialogSettings Properties

REXContentDialogSettings Properties
REXContentDialogSettings Class Legend
REXContentDialogSettings Properties
REXContentDialogSettings Properties | Description
Caption | Gets or sets the caption.
Categories | Gets or sets the settings for all categories.
DialogIcon | Gets or sets the dialog icon.
DialogMode | Gets or sets the dialog mode.
MaterialSettings | Gets the settings for the material category.
Progress | Gets or sets a value indicating whether a progress bar should be visible.
RebarShapeSettings | Gets the settings for the rebar shape category.
RebarTypeSettings | Gets the settings for the rebar type category.
RegionalSettings | Gets or sets a value indicating whether regional settings are supported.
SectionDBSettings | Gets the settings for the database section category..
SectionParamSettings | Gets the settings for the parametric section category.
ShowList | Gets or sets a value indicating whether the list of categories should be visible.
ValidateTypes | Gets or sets a value indicating whether types should be validated.


REXContentDialogSettings Class Public Methods

REXContentDialogSettings Class Public Methods
REXContentDialogSettings Class Legend
Public Methods
Public Method | Description
REXContentDialogSettings | Initializes a new instance of the REXContentDialogSettings class.


REX.ContentGenerator.Families Namespace Classes

REX.ContentGenerator.Families Namespace Classes
REX.ContentGenerator.Families Namespace Legend
Classes
Class | Description
REXCustomDescription | Base class for all custom description types.
REXDBDescription | Base class for all descriptions of objects in REXFamilyType which were created based on a database.
REXDescription | Base class for all descriptions of objects in REXFamilyType.
REXFamilyType | The base class for all content types supported by the REXContentGenerator.
REXFamilyType_Custom | Base class for all custom types.
REXFamilyType_DBSection | Represents a database section.
REXFamilyType_Label | Represents labels.
REXFamilyType_Material | Represents a material element.
REXFamilyType_ParamSection | Represents a parametric section.
REXFamilyType_Section | Base class for all sections.
REXLabelDescription | Represents label's parameters.
REXMaterialCharacteristics | Represents characteristics of a material.
REXMaterialDBDescription | Represents description of the material.
REXMaterialProperties | Represents properties of the material.
REXParamDescription | Base class for all descriptions of objects in REXFamilyType which were created based on a parametric description (not database).
REXSectionDBCharacteristics | Describes geometry characteristics of a database section.
REXSectionDBDescription | Represents parameters of the database section.
REXSectionDBDimensions | Describes dimensions of the database section.
REXSectionDBProperties | Describes properties of the database section.
REXSectionParamCharacteristics | Describes characteristics of the parametric section.
REXSectionParamDescription | Represents parameters of the parametric section.
REXSectionParamDimensions | Desribes dimentsions of the parametric section.
SerializableObject | Allows to save an object into a stream.


Legend

Legend
REX.ContentGenerator.Families Namespace
Legend
Class
abstract
Enumeration
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REX.ContentGenerator.Families Namespace Structs, Records, Enums

REX.ContentGenerator.Families Namespace Structs, Records, Enums
REX.ContentGenerator.Families Namespace Legend
Structs, Records, Enums
Struct, Record, Enum | Description
ECategoryType | Describes the category of the element
EDBSectionType | Describes the type of the database section.
EElementType | Describes the type of the element
EMaterial | Describes the type of material
ESectionType |


Legend

Legend
REXCustomDescription Class
Legend
Constructor
abstract


REXCustomDescription Class Members

REXCustomDescription Class Members
REXCustomDescription Class Legend
Members
Public Methods
Public Method | Description
REXCustomDescription | Initializes a new instance of the REXCustomDescription class.
REXCustomDescription | Initializes a new instance of the REXCustomDescription class.
REXCustomDescription Methods
REXCustomDescription Methods | Description
Clone | Clones this instance.
GetTypeName | Gets the name of the type.


Members

Legend
Legend
Constructor
abstract


REXCustomDescription Methods

REXCustomDescription Methods
REXCustomDescription Class Legend
REXCustomDescription Methods
REXCustomDescription Methods | Description
Clone | Clones this instance.
GetTypeName | Gets the name of the type.


Methods (AutoDoc Folder)

Legend
Legend
Method
abstract


REXCustomDescription Class Public Methods

REXCustomDescription Class Public Methods
REXCustomDescription Class Legend
Public Methods
Public Method | Description
REXCustomDescription | Initializes a new instance of the REXCustomDescription class.
REXCustomDescription | Initializes a new instance of the REXCustomDescription class.


Legend

Legend
REXDBDescription Class
Legend
Constructor
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXDBDescription Class Members

REXDBDescription Class Members
REXDBDescription Class Legend
Members
Public Methods
Public Method | Description
REXDBDescription | Initializes a new instance of the REXDBDescription class.
REXDBDescription | Initializes a new instance of the REXDBDescription class.
REXDBDescription | Initializes a new instance of the REXDBDescription class.
REXDBDescription | Initializes a new instance of the REXDBDescription class.
REXDBDescription | Initializes a new instance of the REXDBDescription class.
REXDBDescription | Initializes a new instance of the REXDBDescription class.
REXDBDescription Methods
REXDBDescription Methods | Description
Clone | Creates a new object that is a copy of the current instance.
CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
GetValue | Gets the value.
RecalculateParameters | Recalculates the parameters.
SetValue | Sets the value.
REXDBDescription Properties
REXDBDescription Properties | Description
DBName | Gets or sets the name of the DB.
Directory | Gets or sets the directory.


REXDBDescription Methods

REXDBDescription Methods
REXDBDescription Class Legend
REXDBDescription Methods
REXDBDescription Methods | Description
Clone | Creates a new object that is a copy of the current instance.
CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
GetValue | Gets the value.
RecalculateParameters | Recalculates the parameters.
SetValue | Sets the value.


REXDBDescription Properties

REXDBDescription Properties
REXDBDescription Class Legend
REXDBDescription Properties
REXDBDescription Properties | Description
DBName | Gets or sets the name of the DB.
Directory | Gets or sets the directory.


REXDBDescription Class Public Methods

REXDBDescription Class Public Methods
REXDBDescription Class Legend
Public Methods
Public Method | Description
REXDBDescription | Initializes a new instance of the REXDBDescription class.
REXDBDescription | Initializes a new instance of the REXDBDescription class.
REXDBDescription | Initializes a new instance of the REXDBDescription class.
REXDBDescription | Initializes a new instance of the REXDBDescription class.
REXDBDescription | Initializes a new instance of the REXDBDescription class.
REXDBDescription | Initializes a new instance of the REXDBDescription class.


Legend

Legend
REXDescription Class
Legend
Constructor
abstract
virtual


REXDescription Class Members

REXDescription Class Members
REXDescription Class Legend
Members
Public Methods
Public Method | Description
REXDescription | Initializes a new instance of the REXDescription class.
REXDescription | Initializes a new instance of the REXDescription class.
REXDescription | Initializes a new instance of the REXDescription class.
REXDescription | Initializes a new instance of the REXDescription class.
REXDescription Methods
REXDescription Methods | Description
Clone | Creates a new object that is a copy of the current instance.
CompareProperty | This is CompareProperty, a member of class REXDescription.
CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
GetEnumerator | Returns an enumerator that iterates through a collection.
GetValue | Gets the value.
RecalculateParameters | Recalculates the parameters.
Set2Null | Sets all values to default one.
SetValue | Sets the value.


Members

Legend
Legend
Constructor
abstract
virtual


REXDescription Methods

REXDescription Methods
REXDescription Class Legend
REXDescription Methods
REXDescription Methods | Description
Clone | Creates a new object that is a copy of the current instance.
CompareProperty | This is CompareProperty, a member of class REXDescription.
CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
GetEnumerator | Returns an enumerator that iterates through a collection.
GetValue | Gets the value.
RecalculateParameters | Recalculates the parameters.
Set2Null | Sets all values to default one.
SetValue | Sets the value.


Methods (AutoDoc Folder)

Legend
Legend
Method
abstract
virtual


REXDescription Class Public Methods

REXDescription Class Public Methods
REXDescription Class Legend
Public Methods
Public Method | Description
REXDescription | Initializes a new instance of the REXDescription class.
REXDescription | Initializes a new instance of the REXDescription class.
REXDescription | Initializes a new instance of the REXDescription class.
REXDescription | Initializes a new instance of the REXDescription class.


Legend

Legend
REXFamilyType Class
Legend
Constructor
virtual
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXFamilyType Class Members

REXFamilyType Class Members
REXFamilyType Class Legend
Members
Public Methods
Public Method | Description
REXFamilyType | Initializes a new instance of the REXFamilyType class.
REXFamilyType | Initializes a new instance of the REXFamilyType class.
REXFamilyType | Initializes a new instance of the REXFamilyType class.
REXFamilyType Methods
REXFamilyType Methods | Description
Clone | Creates a new object that is a copy of the current instance.
CompareTo | Compares the current object with the other object.
REXFamilyType Properties
REXFamilyType Properties | Description
CategoryType | Gets the category.
Certified | Gets or sets a value indicating whether the element is certified.
Description | Gets or sets the description of the object.
Element | Gets or sets the element.
ElementType | Gets or sets the type of the element.
FamilyName | Gets or sets the name of the family.
Mapped | If the REXFamilyType is mapped.
Material | Gets or sets the material.
TypeName | Gets or sets the name of the type.
UniqueID | The unique id.


REXFamilyType Methods

REXFamilyType Methods
REXFamilyType Class Legend
REXFamilyType Methods
REXFamilyType Methods | Description
Clone | Creates a new object that is a copy of the current instance.
CompareTo | Compares the current object with the other object.


REXFamilyType Properties

REXFamilyType Properties
REXFamilyType Class Legend
REXFamilyType Properties
REXFamilyType Properties | Description
CategoryType | Gets the category.
Certified | Gets or sets a value indicating whether the element is certified.
Description | Gets or sets the description of the object.
Element | Gets or sets the element.
ElementType | Gets or sets the type of the element.
FamilyName | Gets or sets the name of the family.
Mapped | If the REXFamilyType is mapped.
Material | Gets or sets the material.
TypeName | Gets or sets the name of the type.
UniqueID | The unique id.


REXFamilyType Class Public Methods

REXFamilyType Class Public Methods
REXFamilyType Class Legend
Public Methods
Public Method | Description
REXFamilyType | Initializes a new instance of the REXFamilyType class.
REXFamilyType | Initializes a new instance of the REXFamilyType class.
REXFamilyType | Initializes a new instance of the REXFamilyType class.


Legend

Legend
REXFamilyType_Custom Class
Legend
Constructor
abstract
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXFamilyType_Custom Class Members

REXFamilyType_Custom Class Members
REXFamilyType_Custom Class Legend
Members
Public Methods
Public Method | Description
REXFamilyType_Custom | Initializes a new instance of the REXFamilyType_Custom class.
REXFamilyType_Custom | Initializes a new instance of the REXFamilyType_Custom class.
REXFamilyType_Custom | Initializes a new instance of the REXFamilyType_Custom class.
REXFamilyType_Custom Methods
REXFamilyType_Custom Methods | Description
Clone | Creates a new object that is a copy of the current instance.
REXFamilyType_Custom Properties
REXFamilyType_Custom Properties | Description
CategoryType | Gets the category.
CustomCategory | Gets the custom category.
CustomParameters | Gets the custom parameters.


Members

Legend
Legend
Constructor
abstract
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXFamilyType_Custom Methods

REXFamilyType_Custom Methods
REXFamilyType_Custom Class Legend
REXFamilyType_Custom Methods
REXFamilyType_Custom Methods | Description
Clone | Creates a new object that is a copy of the current instance.


REXFamilyType_Custom Properties

REXFamilyType_Custom Properties
REXFamilyType_Custom Class Legend
REXFamilyType_Custom Properties
REXFamilyType_Custom Properties | Description
CategoryType | Gets the category.
CustomCategory | Gets the custom category.
CustomParameters | Gets the custom parameters.


Properties (AutoDoc Folder)

Legend
Legend
Property
abstract


REXFamilyType_Custom Class Public Methods

REXFamilyType_Custom Class Public Methods
REXFamilyType_Custom Class Legend
Public Methods
Public Method | Description
REXFamilyType_Custom | Initializes a new instance of the REXFamilyType_Custom class.
REXFamilyType_Custom | Initializes a new instance of the REXFamilyType_Custom class.
REXFamilyType_Custom | Initializes a new instance of the REXFamilyType_Custom class.


Legend

Legend
REXFamilyType_DBSection Class
Legend
Constructor
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXFamilyType_DBSection Class Members

REXFamilyType_DBSection Class Members
REXFamilyType_DBSection Class Legend
Members
Public Methods
Public Method | Description
REXFamilyType_DBSection | Initializes a new instance of the REXFamilyType_DBSection class.
REXFamilyType_DBSection | Initializes a new instance of the REXFamilyType_DBSection class.
REXFamilyType_DBSection | Initializes a new instance of the REXFamilyType_DBSection class.
REXFamilyType_DBSection Methods
REXFamilyType_DBSection Methods | Description
Clone | Creates a new object that is a copy of the current instance.
CompareTo | Compares the current object with the other object.
REXFamilyType_DBSection Properties
REXFamilyType_DBSection Properties | Description
CategoryType | Gets the category.
Parameters | Gets or sets the parameters.


REXFamilyType_DBSection Methods

REXFamilyType_DBSection Methods
REXFamilyType_DBSection Class Legend
REXFamilyType_DBSection Methods
REXFamilyType_DBSection Methods | Description
Clone | Creates a new object that is a copy of the current instance.
CompareTo | Compares the current object with the other object.


REXFamilyType_DBSection Properties

REXFamilyType_DBSection Properties
REXFamilyType_DBSection Class Legend
REXFamilyType_DBSection Properties
REXFamilyType_DBSection Properties | Description
CategoryType | Gets the category.
Parameters | Gets or sets the parameters.


REXFamilyType_DBSection Class Public Methods

REXFamilyType_DBSection Class Public Methods
REXFamilyType_DBSection Class Legend
Public Methods
Public Method | Description
REXFamilyType_DBSection | Initializes a new instance of the REXFamilyType_DBSection class.
REXFamilyType_DBSection | Initializes a new instance of the REXFamilyType_DBSection class.
REXFamilyType_DBSection | Initializes a new instance of the REXFamilyType_DBSection class.


Legend

Legend
REXFamilyType_Label Class
Legend
Constructor
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXFamilyType_Label Class Members

REXFamilyType_Label Class Members
REXFamilyType_Label Class Legend
Members
Public Methods
Public Method | Description
REXFamilyType_Label | Initializes a new instance of the REXFamilyType_Label class.
REXFamilyType_Label | Initializes a new instance of the REXFamilyType_Label class.
REXFamilyType_Label | Initializes a new instance of the REXFamilyType_Label class.
REXFamilyType_Label Methods
REXFamilyType_Label Methods | Description
Clone | Creates a new object that is a copy of the current instance.
CompareTo | Compares the current object with the other object.
REXFamilyType_Label Properties
REXFamilyType_Label Properties | Description
CategoryType | Gets the category.
Parameters | Gets the parameters.


REXFamilyType_Label Methods

REXFamilyType_Label Methods
REXFamilyType_Label Class Legend
REXFamilyType_Label Methods
REXFamilyType_Label Methods | Description
Clone | Creates a new object that is a copy of the current instance.
CompareTo | Compares the current object with the other object.


REXFamilyType_Label Properties

REXFamilyType_Label Properties
REXFamilyType_Label Class Legend
REXFamilyType_Label Properties
REXFamilyType_Label Properties | Description
CategoryType | Gets the category.
Parameters | Gets the parameters.


REXFamilyType_Label Class Public Methods

REXFamilyType_Label Class Public Methods
REXFamilyType_Label Class Legend
Public Methods
Public Method | Description
REXFamilyType_Label | Initializes a new instance of the REXFamilyType_Label class.
REXFamilyType_Label | Initializes a new instance of the REXFamilyType_Label class.
REXFamilyType_Label | Initializes a new instance of the REXFamilyType_Label class.


Legend

Legend
REXFamilyType_Material Class
Legend
Constructor
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXFamilyType_Material Class Members

REXFamilyType_Material Class Members
REXFamilyType_Material Class Legend
Members
Public Methods
Public Method | Description
REXFamilyType_Material | Initializes a new instance of the REXFamilyType_Material class.
REXFamilyType_Material | Initializes a new instance of the REXFamilyType_Material class.
REXFamilyType_Material | Initializes a new instance of the REXFamilyType_Material class.
REXFamilyType_Material Methods
REXFamilyType_Material Methods | Description
Clone | Creates a new object that is a copy of the current instance.
CompareTo | Compares the current object with the other object.
REXFamilyType_Material Properties
REXFamilyType_Material Properties | Description
CategoryType | Gets the category.
Parameters | Gets or sets the parameters.


REXFamilyType_Material Methods

REXFamilyType_Material Methods
REXFamilyType_Material Class Legend
REXFamilyType_Material Methods
REXFamilyType_Material Methods | Description
Clone | Creates a new object that is a copy of the current instance.
CompareTo | Compares the current object with the other object.


REXFamilyType_Material Properties

REXFamilyType_Material Properties
REXFamilyType_Material Class Legend
REXFamilyType_Material Properties
REXFamilyType_Material Properties | Description
CategoryType | Gets the category.
Parameters | Gets or sets the parameters.


REXFamilyType_Material Class Public Methods

REXFamilyType_Material Class Public Methods
REXFamilyType_Material Class Legend
Public Methods
Public Method | Description
REXFamilyType_Material | Initializes a new instance of the REXFamilyType_Material class.
REXFamilyType_Material | Initializes a new instance of the REXFamilyType_Material class.
REXFamilyType_Material | Initializes a new instance of the REXFamilyType_Material class.


Legend

Legend
REXFamilyType_ParamSection Class
Legend
Constructor
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXFamilyType_ParamSection Class Members

REXFamilyType_ParamSection Class Members
REXFamilyType_ParamSection Class Legend
Members
Public Methods
Public Method | Description
REXFamilyType_ParamSection | Initializes a new instance of the REXFamilyType_ParamSection class.
REXFamilyType_ParamSection | Initializes a new instance of the REXFamilyType_ParamSection class.
REXFamilyType_ParamSection | Initializes a new instance of the REXFamilyType_ParamSection class.
REXFamilyType_ParamSection Methods
REXFamilyType_ParamSection Methods | Description
Clone | Creates a new object that is a copy of the current instance.
CompareTo | Compares the current object with the other object.
GetMaterialDependence | Gets the material dependence.
REXFamilyType_ParamSection Properties
REXFamilyType_ParamSection Properties | Description
CategoryType | Gets the category.
Parameters | Gets or sets the parameters.


REXFamilyType_ParamSection Methods

REXFamilyType_ParamSection Methods
REXFamilyType_ParamSection Class Legend
REXFamilyType_ParamSection Methods
REXFamilyType_ParamSection Methods | Description
Clone | Creates a new object that is a copy of the current instance.
CompareTo | Compares the current object with the other object.
GetMaterialDependence | Gets the material dependence.


REXFamilyType_ParamSection Properties

REXFamilyType_ParamSection Properties
REXFamilyType_ParamSection Class Legend
REXFamilyType_ParamSection Properties
REXFamilyType_ParamSection Properties | Description
CategoryType | Gets the category.
Parameters | Gets or sets the parameters.


REXFamilyType_ParamSection Class Public Methods

REXFamilyType_ParamSection Class Public Methods
REXFamilyType_ParamSection Class Legend
Public Methods
Public Method | Description
REXFamilyType_ParamSection | Initializes a new instance of the REXFamilyType_ParamSection class.
REXFamilyType_ParamSection | Initializes a new instance of the REXFamilyType_ParamSection class.
REXFamilyType_ParamSection | Initializes a new instance of the REXFamilyType_ParamSection class.


Legend

Legend
REXFamilyType_Section Class
Legend
Constructor
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXFamilyType_Section Class Members

REXFamilyType_Section Class Members
REXFamilyType_Section Class Legend
Members
Public Methods
Public Method | Description
REXFamilyType_Section | Initializes a new instance of the REXFamilyType_Section class.
REXFamilyType_Section | Initializes a new instance of the REXFamilyType_Section class.
REXFamilyType_Section | Initializes a new instance of the REXFamilyType_Section class.


REXFamilyType_Section Class Public Methods

REXFamilyType_Section Class Public Methods
REXFamilyType_Section Class Legend
Public Methods
Public Method | Description
REXFamilyType_Section | Initializes a new instance of the REXFamilyType_Section class.
REXFamilyType_Section | Initializes a new instance of the REXFamilyType_Section class.
REXFamilyType_Section | Initializes a new instance of the REXFamilyType_Section class.


Legend

Legend
REXLabelDescription Class
Legend
Constructor
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXLabelDescription Class Members

REXLabelDescription Class Members
REXLabelDescription Class Legend
Members
Public Methods
Public Method | Description
REXLabelDescription | Initializes a new instance of the REXLabelDescription class.
REXLabelDescription | Initializes a new instance of the REXLabelDescription class.
REXLabelDescription | Initializes a new instance of the REXLabelDescription class.
REXLabelDescription Methods
REXLabelDescription Methods | Description
Clone | Creates a new object that is a copy of the current instance.
CompareTo | Compares the current object with the other object.
GetName | Gets the name.
REXLabelDescription Properties
REXLabelDescription Properties | Description
Category | Gets or sets the category.
LabelFamilyDescription | Gets or sets the label family description.
Name | Gets or sets the name.


REXLabelDescription Methods

REXLabelDescription Methods
REXLabelDescription Class Legend
REXLabelDescription Methods
REXLabelDescription Methods | Description
Clone | Creates a new object that is a copy of the current instance.
CompareTo | Compares the current object with the other object.
GetName | Gets the name.


REXLabelDescription Properties

REXLabelDescription Properties
REXLabelDescription Class Legend
REXLabelDescription Properties
REXLabelDescription Properties | Description
Category | Gets or sets the category.
LabelFamilyDescription | Gets or sets the label family description.
Name | Gets or sets the name.


REXLabelDescription Class Public Methods

REXLabelDescription Class Public Methods
REXLabelDescription Class Legend
Public Methods
Public Method | Description
REXLabelDescription | Initializes a new instance of the REXLabelDescription class.
REXLabelDescription | Initializes a new instance of the REXLabelDescription class.
REXLabelDescription | Initializes a new instance of the REXLabelDescription class.


Legend

Legend
REXMaterialCharacteristics Class
Legend
Constructor
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXMaterialCharacteristics Class Members

REXMaterialCharacteristics Class Members
REXMaterialCharacteristics Class Legend
Members
Public Methods
Public Method | Description
REXMaterialCharacteristics | Initializes a new instance of the REXMaterialCharacteristics class.
REXMaterialCharacteristics | Initializes a new instance of the REXMaterialCharacteristics class.
REXMaterialCharacteristics | Initializes a new instance of the REXMaterialCharacteristics class.
REXMaterialCharacteristics | Initializes a new instance of the REXMaterialCharacteristics class.
REXMaterialCharacteristics Methods
REXMaterialCharacteristics Methods | Description
Clone | Creates a new object that is a copy of the current instance.
REXMaterialCharacteristics Properties
REXMaterialCharacteristics Properties | Description
CS | Gets or sets the reduction factor for shear for steel / Burning velocity (mm/min) (data specific for timber design according to CB71).
DAMPCOEF | Gets or sets the damping coefficient.
E | Gets or sets the E (Young's modulus).
GMEAN | Gets or sets the average modulus G.
KIRCHOFF | Gets or sets the shear modulus G.
LX | Gets or sets the thermal expansion coefficient.
NU | Gets or sets the Poisson's ratio.
RE | Gets or sets the design strength.
RE_AXCOMP | Gets or sets the axial compression resistance (for timber).
RE_AXTENS | Gets or sets the axial tension resistance (for timber).
RE_BENDING | Gets or sets the bending strength (for timber).
RE_SHEAR | Gets or sets the shear strength (for timber).
RE_TRCOMPR | Gets or sets the transversal compression resistance (for timber).
RE_TRTENS | Gets or sets the transversal tension resistance (for timber).
RO | Gets or sets the unit weight.
RT | Gets or sets the design tensile strength.


REXMaterialCharacteristics Methods

REXMaterialCharacteristics Methods
REXMaterialCharacteristics Class Legend
REXMaterialCharacteristics Methods
REXMaterialCharacteristics Methods | Description
Clone | Creates a new object that is a copy of the current instance.


REXMaterialCharacteristics Properties

REXMaterialCharacteristics Properties
REXMaterialCharacteristics Class Legend
REXMaterialCharacteristics Properties
REXMaterialCharacteristics Properties | Description
CS | Gets or sets the reduction factor for shear for steel / Burning velocity (mm/min) (data specific for timber design according to CB71).
DAMPCOEF | Gets or sets the damping coefficient.
E | Gets or sets the E (Young's modulus).
GMEAN | Gets or sets the average modulus G.
KIRCHOFF | Gets or sets the shear modulus G.
LX | Gets or sets the thermal expansion coefficient.
NU | Gets or sets the Poisson's ratio.
RE | Gets or sets the design strength.
RE_AXCOMP | Gets or sets the axial compression resistance (for timber).
RE_AXTENS | Gets or sets the axial tension resistance (for timber).
RE_BENDING | Gets or sets the bending strength (for timber).
RE_SHEAR | Gets or sets the shear strength (for timber).
RE_TRCOMPR | Gets or sets the transversal compression resistance (for timber).
RE_TRTENS | Gets or sets the transversal tension resistance (for timber).
RO | Gets or sets the unit weight.
RT | Gets or sets the design tensile strength.


REXMaterialCharacteristics Class Public Methods

REXMaterialCharacteristics Class Public Methods
REXMaterialCharacteristics Class Legend
Public Methods
Public Method | Description
REXMaterialCharacteristics | Initializes a new instance of the REXMaterialCharacteristics class.
REXMaterialCharacteristics | Initializes a new instance of the REXMaterialCharacteristics class.
REXMaterialCharacteristics | Initializes a new instance of the REXMaterialCharacteristics class.
REXMaterialCharacteristics | Initializes a new instance of the REXMaterialCharacteristics class.


Legend

Legend
REXMaterialDBDescription Class
Legend
Constructor
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXMaterialDBDescription Class Members

REXMaterialDBDescription Class Members
REXMaterialDBDescription Class Legend
Members
Public Methods
Public Method | Description
REXMaterialDBDescription | Initializes a new instance of the REXMaterialDBDescription class.
REXMaterialDBDescription | Initializes a new instance of the REXMaterialDBDescription class.
REXMaterialDBDescription | Initializes a new instance of the REXMaterialDBDescription class.
REXMaterialDBDescription | Initializes a new instance of the REXMaterialDBDescription class.
REXMaterialDBDescription | Initializes a new instance of the REXMaterialDBDescription class.
REXMaterialDBDescription Methods
REXMaterialDBDescription Methods | Description
Clone | Creates a new object that is a copy of the current instance.
CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
GetName | Gets the name.
REXMaterialDBDescription Properties
REXMaterialDBDescription Properties | Description
Characteristics | Gets or sets characteristics.
Description | Gets or sets the description.
NAME | Gets or sets the material name.


REXMaterialDBDescription Methods

REXMaterialDBDescription Methods
REXMaterialDBDescription Class Legend
REXMaterialDBDescription Methods
REXMaterialDBDescription Methods | Description
Clone | Creates a new object that is a copy of the current instance.
CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
GetName | Gets the name.


REXMaterialDBDescription Properties

REXMaterialDBDescription Properties
REXMaterialDBDescription Class Legend
REXMaterialDBDescription Properties
REXMaterialDBDescription Properties | Description
Characteristics | Gets or sets characteristics.
Description | Gets or sets the description.
NAME | Gets or sets the material name.


REXMaterialDBDescription Class Public Methods

REXMaterialDBDescription Class Public Methods
REXMaterialDBDescription Class Legend
Public Methods
Public Method | Description
REXMaterialDBDescription | Initializes a new instance of the REXMaterialDBDescription class.
REXMaterialDBDescription | Initializes a new instance of the REXMaterialDBDescription class.
REXMaterialDBDescription | Initializes a new instance of the REXMaterialDBDescription class.
REXMaterialDBDescription | Initializes a new instance of the REXMaterialDBDescription class.
REXMaterialDBDescription | Initializes a new instance of the REXMaterialDBDescription class.


Legend

Legend
REXMaterialProperties Class
Legend
Constructor
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXMaterialProperties Class Members

REXMaterialProperties Class Members
REXMaterialProperties Class Legend
Members
Public Methods
Public Method | Description
REXMaterialProperties | Initializes a new instance of the REXMaterialProperties class.
REXMaterialProperties | Initializes a new instance of the REXMaterialProperties class.
REXMaterialProperties | Initializes a new instance of the REXMaterialProperties class.
REXMaterialProperties | Initializes a new instance of the REXMaterialProperties class.
REXMaterialProperties Methods
REXMaterialProperties Methods | Description
Clone | Creates a new object that is a copy of the current instance.
REXMaterialProperties Properties
REXMaterialProperties Properties | Description
DESCRIPTION | Gets or sets the detailed material description.
NAME | Gets or sets the material name.
RE_CODE | Gets or sets /1.
SECOND_NAME | Gets or sets the material's name (used for a steel to give an equivalent according to Eurocode).
THERM | Gets or sets the material type /for steel: thermal treatment-1 /for timber: natural-0, glued-1, glued KertoS specific for Kerto code-2, glued KertoQ specific for Kerto code-3, glued KertoS-4, glued KertoQ-5.


REXMaterialProperties Methods

REXMaterialProperties Methods
REXMaterialProperties Class Legend
REXMaterialProperties Methods
REXMaterialProperties Methods | Description
Clone | Creates a new object that is a copy of the current instance.


REXMaterialProperties Properties

REXMaterialProperties Properties
REXMaterialProperties Class Legend
REXMaterialProperties Properties
REXMaterialProperties Properties | Description
DESCRIPTION | Gets or sets the detailed material description.
NAME | Gets or sets the material name.
RE_CODE | Gets or sets /1.
SECOND_NAME | Gets or sets the material's name (used for a steel to give an equivalent according to Eurocode).
THERM | Gets or sets the material type /for steel: thermal treatment-1 /for timber: natural-0, glued-1, glued KertoS specific for Kerto code-2, glued KertoQ specific for Kerto code-3, glued KertoS-4, glued KertoQ-5.


REXMaterialProperties Class Public Methods

REXMaterialProperties Class Public Methods
REXMaterialProperties Class Legend
Public Methods
Public Method | Description
REXMaterialProperties | Initializes a new instance of the REXMaterialProperties class.
REXMaterialProperties | Initializes a new instance of the REXMaterialProperties class.
REXMaterialProperties | Initializes a new instance of the REXMaterialProperties class.
REXMaterialProperties | Initializes a new instance of the REXMaterialProperties class.


Legend

Legend
REXSectionDBCharacteristics Class
Legend
Constructor
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXSectionDBCharacteristics Class Members

REXSectionDBCharacteristics Class Members
REXSectionDBCharacteristics Class Legend
Members
Public Methods
Public Method | Description
REXSectionDBCharacteristics | Initializes a new instance of the REXSectionDBCharacteristics class.
REXSectionDBCharacteristics | Initializes a new instance of the EXSectionDBCharacteristics class.
REXSectionDBCharacteristics | Initializes a new instance of the REXSectionDBCharacteristics class.
REXSectionDBCharacteristics | Initializes a new instance of the REXSectionDBCharacteristics class.
REXSectionDBCharacteristics Methods
REXSectionDBCharacteristics Methods | Description
Clone | Creates a new object that is a copy of the current instance.
REXSectionDBCharacteristics Properties
REXSectionDBCharacteristics Properties | Description
IOMEGA | Gets or sets the warping constant (for thin-walled sections).
IX | Gets or sets the torsional constant.
IY | Gets or sets the moment of inertia (Iy).
IZ | Gets or sets the moment of inertia (Iz).
MASS | Gets or sets the weight per length unit of a section.
MSY | Gets or sets the plastic section modulus (bending) about the Y axis.
MSZ | Gets or sets the plastic section modulus (bending) about the Z axis.
SX | Gets or sets the cross-sectional area.
SY | Gets or sets the reduced section area for XY-shear deformation calculations - considering the influence of shear forces along Y axis.
SZ | Gets or sets the reduced section area for XZ-shear deformation calculations - considering the influence of shear forces along Z axis.


REXSectionDBCharacteristics Methods

REXSectionDBCharacteristics Methods
REXSectionDBCharacteristics Class Legend
REXSectionDBCharacteristics Methods
REXSectionDBCharacteristics Methods | Description
Clone | Creates a new object that is a copy of the current instance.


REXSectionDBCharacteristics Properties

REXSectionDBCharacteristics Properties
REXSectionDBCharacteristics Class Legend
REXSectionDBCharacteristics Properties
REXSectionDBCharacteristics Properties | Description
IOMEGA | Gets or sets the warping constant (for thin-walled sections).
IX | Gets or sets the torsional constant.
IY | Gets or sets the moment of inertia (Iy).
IZ | Gets or sets the moment of inertia (Iz).
MASS | Gets or sets the weight per length unit of a section.
MSY | Gets or sets the plastic section modulus (bending) about the Y axis.
MSZ | Gets or sets the plastic section modulus (bending) about the Z axis.
SX | Gets or sets the cross-sectional area.
SY | Gets or sets the reduced section area for XY-shear deformation calculations - considering the influence of shear forces along Y axis.
SZ | Gets or sets the reduced section area for XZ-shear deformation calculations - considering the influence of shear forces along Z axis.


REXSectionDBCharacteristics Class Public Methods

REXSectionDBCharacteristics Class Public Methods
REXSectionDBCharacteristics Class Legend
Public Methods
Public Method | Description
REXSectionDBCharacteristics | Initializes a new instance of the REXSectionDBCharacteristics class.
REXSectionDBCharacteristics | Initializes a new instance of the EXSectionDBCharacteristics class.
REXSectionDBCharacteristics | Initializes a new instance of the REXSectionDBCharacteristics class.
REXSectionDBCharacteristics | Initializes a new instance of the REXSectionDBCharacteristics class.


Legend

Legend
REXSectionDBDescription Class
Legend
Constructor
static
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXSectionDBDescription Class Members

REXSectionDBDescription Class Members
REXSectionDBDescription Class Legend
Members
Public Methods
Public Method | Description
REXSectionDBDescription | Initializes a new instance of the REXSectionDBDescription class.
REXSectionDBDescription | Initializes a new instance of the REXSectionDBDescription class.
REXSectionDBDescription | Initializes a new instance of the REXSectionDBDescription class.
REXSectionDBDescription | Initializes a new instance of the REXSectionDBDescription class.
REXSectionDBDescription | Initializes a new instance of the REXSectionDBDescription class.
REXSectionDBDescription Methods
REXSectionDBDescription Methods | Description
Clone | Creates a new object that is a copy of the current instance.
CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
GetContour | Gets the contour of the section.
GetName | Gets the name of the section.
GetSectionType | Gets the type of the section.
GetSectionType | Gets the type of the section.
REXSectionDBDescription Properties
REXSectionDBDescription Properties | Description
Characteristics | Gets or sets the characteristics of the section.
Description | Gets or sets the description of the section.
DIM1 | Gets or sets the first numeric component of the section label
DIM2 | Gets or sets the second numeric component of the section label.
DIM3 | Gets or sets the third numeric component of the section label.
Dimensions | Gets or sets the dimensions.
NAME | Gets or sets the name of the section.


Members

Legend
Legend
Constructor
static
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXSectionDBDescription Methods

REXSectionDBDescription Methods
REXSectionDBDescription Class Legend
REXSectionDBDescription Methods
REXSectionDBDescription Methods | Description
Clone | Creates a new object that is a copy of the current instance.
CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
GetContour | Gets the contour of the section.
GetName | Gets the name of the section.
GetSectionType | Gets the type of the section.
GetSectionType | Gets the type of the section.


REXSectionDBDescription Properties

REXSectionDBDescription Properties
REXSectionDBDescription Class Legend
REXSectionDBDescription Properties
REXSectionDBDescription Properties | Description
Characteristics | Gets or sets the characteristics of the section.
Description | Gets or sets the description of the section.
DIM1 | Gets or sets the first numeric component of the section label
DIM2 | Gets or sets the second numeric component of the section label.
DIM3 | Gets or sets the third numeric component of the section label.
Dimensions | Gets or sets the dimensions.
NAME | Gets or sets the name of the section.


REXSectionDBDescription Class Public Methods

REXSectionDBDescription Class Public Methods
REXSectionDBDescription Class Legend
Public Methods
Public Method | Description
REXSectionDBDescription | Initializes a new instance of the REXSectionDBDescription class.
REXSectionDBDescription | Initializes a new instance of the REXSectionDBDescription class.
REXSectionDBDescription | Initializes a new instance of the REXSectionDBDescription class.
REXSectionDBDescription | Initializes a new instance of the REXSectionDBDescription class.
REXSectionDBDescription | Initializes a new instance of the REXSectionDBDescription class.


Legend

Legend
REXSectionDBDimensions Class
Legend
Constructor
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXSectionDBDimensions Class Members

REXSectionDBDimensions Class Members
REXSectionDBDimensions Class Legend
Members
Public Methods
Public Method | Description
REXSectionDBDimensions | Initializes a new instance of the REXSectionDBDimensions class.
REXSectionDBDimensions | Initializes a new instance of the REXSectionDBDimensions class.
REXSectionDBDimensions | Initializes a new instance of the REXSectionDBDimensions class.
REXSectionDBDimensions | Initializes a new instance of the REXSectionDBDimensions class.
REXSectionDBDimensions Methods
REXSectionDBDimensions Methods | Description
Clone | Creates a new object that is a copy of the current instance.
REXSectionDBDimensions Properties
REXSectionDBDimensions Properties | Description
A_1 | Gets or sets the additional angle.
A_2 | Gets or sets the additional angle.
B | Gets or sets the section's width.
B_2 | Gets or sets the AISC k value for design.
EA | Gets or sets the web thickness.
ES | Gets or sets the flange thickness.
ES_2 | Gets or sets the AISC design value k.
GAMMA | Gets or sets the angle of rotation of the section local to principal coordinate system (maximum moments of inertia of a section).
GAP | Gets or sets the distance between sections in compound sections.
H | Gets or sets the section's height.
P1_L | Gets or sets the length of slab P2 (cross-shaped section).
P1_T | Gets or sets the thickness of slab P1 (cross-shaped section).
P2_L | Gets or sets the length of slab P2 (cross-shaped section).
P2_T | Gets or sets the Thickness of slab P2 (cross-shaped section).
P3_L | Gets or sets the Length of slab P3 (cross-shaped section).
P3_T | Gets or sets the thickness of slab P3 (cross-shaped section).
P4_L | Gets or sets the length of slab P4 (cross-shaped section).
P4_T | Gets or sets the thickness of slab P4 (cross-shaped section).
RA | Gets or sets the fillet radius (web).
RS | Gets or sets the fillet radius (flange).
SLOPE_FACTOR | Gets or sets the slope factor.
VPY | Gets or sets the extreme distance from the local Z axis of the point on the negative side of the Y axis.
VPZ | Gets or sets the extreme distance from the local Y axis of the point on the negative side of the Z axis.
VY | Gets or sets the extreme distance from the local Z axis of the point on the positive side of the Y axis.
VZ | Gets or sets the extreme distance from the local Y axis of the point on the positive side of the Z axis.


REXSectionDBDimensions Methods

REXSectionDBDimensions Methods
REXSectionDBDimensions Class Legend
REXSectionDBDimensions Methods
REXSectionDBDimensions Methods | Description
Clone | Creates a new object that is a copy of the current instance.


REXSectionDBDimensions Properties

REXSectionDBDimensions Properties
REXSectionDBDimensions Class Legend
REXSectionDBDimensions Properties
REXSectionDBDimensions Properties | Description
A_1 | Gets or sets the additional angle.
A_2 | Gets or sets the additional angle.
B | Gets or sets the section's width.
B_2 | Gets or sets the AISC k value for design.
EA | Gets or sets the web thickness.
ES | Gets or sets the flange thickness.
ES_2 | Gets or sets the AISC design value k.
GAMMA | Gets or sets the angle of rotation of the section local to principal coordinate system (maximum moments of inertia of a section).
GAP | Gets or sets the distance between sections in compound sections.
H | Gets or sets the section's height.
P1_L | Gets or sets the length of slab P2 (cross-shaped section).
P1_T | Gets or sets the thickness of slab P1 (cross-shaped section).
P2_L | Gets or sets the length of slab P2 (cross-shaped section).
P2_T | Gets or sets the Thickness of slab P2 (cross-shaped section).
P3_L | Gets or sets the Length of slab P3 (cross-shaped section).
P3_T | Gets or sets the thickness of slab P3 (cross-shaped section).
P4_L | Gets or sets the length of slab P4 (cross-shaped section).
P4_T | Gets or sets the thickness of slab P4 (cross-shaped section).
RA | Gets or sets the fillet radius (web).
RS | Gets or sets the fillet radius (flange).
SLOPE_FACTOR | Gets or sets the slope factor.
VPY | Gets or sets the extreme distance from the local Z axis of the point on the negative side of the Y axis.
VPZ | Gets or sets the extreme distance from the local Y axis of the point on the negative side of the Z axis.
VY | Gets or sets the extreme distance from the local Z axis of the point on the positive side of the Y axis.
VZ | Gets or sets the extreme distance from the local Y axis of the point on the positive side of the Z axis.


REXSectionDBDimensions Class Public Methods

REXSectionDBDimensions Class Public Methods
REXSectionDBDimensions Class Legend
Public Methods
Public Method | Description
REXSectionDBDimensions | Initializes a new instance of the REXSectionDBDimensions class.
REXSectionDBDimensions | Initializes a new instance of the REXSectionDBDimensions class.
REXSectionDBDimensions | Initializes a new instance of the REXSectionDBDimensions class.
REXSectionDBDimensions | Initializes a new instance of the REXSectionDBDimensions class.


Legend

Legend
REXSectionDBProperties Class
Legend
Constructor
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXSectionDBProperties Class Members

REXSectionDBProperties Class Members
REXSectionDBProperties Class Legend
Members
Public Methods
Public Method | Description
REXSectionDBProperties | Initializes a new instance of the REXSectionDBProperties class.
REXSectionDBProperties | Initializes a new instance of the REXSectionDBProperties class.
REXSectionDBProperties | Initializes a new instance of the
REXSectionDBProperties | Initializes a new instance of the REXSectionDBProperties class.
REXSectionDBProperties Methods
REXSectionDBProperties Methods | Description
Clone | Creates a new object that is a copy of the current instance.
REXSectionDBProperties Properties
REXSectionDBProperties Properties | Description
DIM1 | Gets or sets the first numeric component of the section label
DIM2 | Gets or sets the second numeric component of the section label.
DIM3 | Gets or sets the third numeric component of the section label.
NAME | Gets or sets the name of the section.
NAME_REVIT | Gets or sets the Revit name.
NAME1 | Gets or sets the section name.
Names | Gets or sets the list of optional names.
SHAPE_TYPE | Gets or sets the number of the section shape type.


REXSectionDBProperties Methods

REXSectionDBProperties Methods
REXSectionDBProperties Class Legend
REXSectionDBProperties Methods
REXSectionDBProperties Methods | Description
Clone | Creates a new object that is a copy of the current instance.


REXSectionDBProperties Properties

REXSectionDBProperties Properties
REXSectionDBProperties Class Legend
REXSectionDBProperties Properties
REXSectionDBProperties Properties | Description
DIM1 | Gets or sets the first numeric component of the section label
DIM2 | Gets or sets the second numeric component of the section label.
DIM3 | Gets or sets the third numeric component of the section label.
NAME | Gets or sets the name of the section.
NAME_REVIT | Gets or sets the Revit name.
NAME1 | Gets or sets the section name.
Names | Gets or sets the list of optional names.
SHAPE_TYPE | Gets or sets the number of the section shape type.


REXSectionDBProperties Class Public Methods

REXSectionDBProperties Class Public Methods
REXSectionDBProperties Class Legend
Public Methods
Public Method | Description
REXSectionDBProperties | Initializes a new instance of the REXSectionDBProperties class.
REXSectionDBProperties | Initializes a new instance of the REXSectionDBProperties class.
REXSectionDBProperties | Initializes a new instance of the
REXSectionDBProperties | Initializes a new instance of the REXSectionDBProperties class.


Legend

Legend
REXSectionParamCharacteristics Class
Legend
Constructor
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXSectionParamCharacteristics Class Members

REXSectionParamCharacteristics Class Members
REXSectionParamCharacteristics Class Legend
Members
Public Methods
Public Method | Description
REXSectionParamCharacteristics | Initializes a new instance of the REXSectionParamCharacteristics class.
REXSectionParamCharacteristics | Initializes a new instance of the REXSectionParamCharacteristics class.
REXSectionParamCharacteristics | Initializes a new instance of the REXSectionParamCharacteristics class.
REXSectionParamCharacteristics | Initializes a new instance of the REXSectionParamCharacteristics class.
REXSectionParamCharacteristics Methods
REXSectionParamCharacteristics Methods | Description
Clone | Clones this instance.
REXSectionParamCharacteristics Properties
REXSectionParamCharacteristics Properties | Description
A | Gets or sets the Cross-section area.
IY | Gets or sets the moment of inertia about the Y axis.
IZ | Gets or sets the moment of inertia about the Z axis.
MASS | Gets or sets the nominal weight per unit length.


REXSectionParamCharacteristics Methods

REXSectionParamCharacteristics Methods
REXSectionParamCharacteristics Class Legend
REXSectionParamCharacteristics Methods
REXSectionParamCharacteristics Methods | Description
Clone | Clones this instance.


REXSectionParamCharacteristics Properties

REXSectionParamCharacteristics Properties
REXSectionParamCharacteristics Class Legend
REXSectionParamCharacteristics Properties
REXSectionParamCharacteristics Properties | Description
A | Gets or sets the Cross-section area.
IY | Gets or sets the moment of inertia about the Y axis.
IZ | Gets or sets the moment of inertia about the Z axis.
MASS | Gets or sets the nominal weight per unit length.


REXSectionParamCharacteristics Class Public Methods

REXSectionParamCharacteristics Class Public Methods
REXSectionParamCharacteristics Class Legend
Public Methods
Public Method | Description
REXSectionParamCharacteristics | Initializes a new instance of the REXSectionParamCharacteristics class.
REXSectionParamCharacteristics | Initializes a new instance of the REXSectionParamCharacteristics class.
REXSectionParamCharacteristics | Initializes a new instance of the REXSectionParamCharacteristics class.
REXSectionParamCharacteristics | Initializes a new instance of the REXSectionParamCharacteristics class.


Legend

Legend
REXSectionParamDescription Class
Legend
Constructor
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXSectionParamDescription Class Members

REXSectionParamDescription Class Members
REXSectionParamDescription Class Legend
Members
Public Methods
Public Method | Description
REXSectionParamDescription | Initializes a new instance of the REXSectionParamDescription class.
REXSectionParamDescription | Initializes a new instance of the REXSectionParamDescription class.
REXSectionParamDescription | Initializes a new instance of the REXSectionParamDescription class.
REXSectionParamDescription | Initializes a new instance of the REXSectionParamDescription class.
REXSectionParamDescription Methods
REXSectionParamDescription Methods | Description
CalculataMainAxisAndCharacteristics | Calculatas the main axis and characteristics of the section.
CalculateCharacteristics | Calculates characteristics of the section.
CalculateMainAxisParams | Calculates the main axis of the section.
Clone | Creates a new object that is a copy of the current instance.
CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
GetContour | Gets the contour.
GetMaterialDependence | Gets the material dependence.
REXSectionParamDescription Properties
REXSectionParamDescription Properties | Description
Angle | Gets or sets the angle of the section.
Characteristics | Gets or sets the characteristics.
CharacteristicsEnd | Gets or sets the characteristics of the end.
Contour | Gets or sets the contour.
Dimensions | Gets or sets the dimensions.
DimensionsEnd | Gets or sets the dimensions of the end.
IsTurned | Gets or sets a value indicating whether this instance is turned.
SectionType | Gets or sets the type of the section.
Tapered | Gets or sets a value indicating whether this REXSectionParamDescription is tapered.


REXSectionParamDescription Methods

REXSectionParamDescription Methods
REXSectionParamDescription Class Legend
REXSectionParamDescription Methods
REXSectionParamDescription Methods | Description
CalculataMainAxisAndCharacteristics | Calculatas the main axis and characteristics of the section.
CalculateCharacteristics | Calculates characteristics of the section.
CalculateMainAxisParams | Calculates the main axis of the section.
Clone | Creates a new object that is a copy of the current instance.
CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
GetContour | Gets the contour.
GetMaterialDependence | Gets the material dependence.


REXSectionParamDescription Properties

REXSectionParamDescription Properties
REXSectionParamDescription Class Legend
REXSectionParamDescription Properties
REXSectionParamDescription Properties | Description
Angle | Gets or sets the angle of the section.
Characteristics | Gets or sets the characteristics.
CharacteristicsEnd | Gets or sets the characteristics of the end.
Contour | Gets or sets the contour.
Dimensions | Gets or sets the dimensions.
DimensionsEnd | Gets or sets the dimensions of the end.
IsTurned | Gets or sets a value indicating whether this instance is turned.
SectionType | Gets or sets the type of the section.
Tapered | Gets or sets a value indicating whether this REXSectionParamDescription is tapered.


REXSectionParamDescription Class Public Methods

REXSectionParamDescription Class Public Methods
REXSectionParamDescription Class Legend
Public Methods
Public Method | Description
REXSectionParamDescription | Initializes a new instance of the REXSectionParamDescription class.
REXSectionParamDescription | Initializes a new instance of the REXSectionParamDescription class.
REXSectionParamDescription | Initializes a new instance of the REXSectionParamDescription class.
REXSectionParamDescription | Initializes a new instance of the REXSectionParamDescription class.


Legend

Legend
REXSectionParamDimensions Class
Legend
Constructor
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXSectionParamDimensions Class Members

REXSectionParamDimensions Class Members
REXSectionParamDimensions Class Legend
Members
Public Methods
Public Method | Description
REXSectionParamDimensions | Initializes a new instance of the REXSectionParamDimensions class.
REXSectionParamDimensions | Initializes a new instance of the REXSectionParamDimensions class.
REXSectionParamDimensions | Initializes a new instance of the REXSectionParamDimensions class.
REXSectionParamDimensions | Initializes a new instance of the REXSectionParamDimensions class.
REXSectionParamDimensions Methods
REXSectionParamDimensions Methods | Description
Clone | Creates a new object that is a copy of the current instance.
REXSectionParamDimensions Properties
REXSectionParamDimensions Properties | Description
b | Gets or sets the b.
b1 | Gets or sets the b1.
b2 | Gets or sets the b2.
bf | Gets or sets the bf.
d | Gets or sets the d.
h | Gets or sets the h.
h1 | Gets or sets the h1.
h2 | Gets or sets the h2.
l1 | Gets or sets the l1.
l2 | Gets or sets the l2.
P1_L | Gets or sets the P1_L.
P1_T | Gets or sets the P1_T.
P2_L | Gets or sets the P2_L.
P2_T | Gets or sets the P2_T.
P3_L | Gets or sets the P3_L.
P3_T | Gets or sets the P3_T.
P4_L | Gets or sets the P4_L.
P4_T | Gets or sets the P4_T.
t | Gets or sets the t.
tf | Gets or sets the tf.
tf1 | Gets or sets the tf1.
tf2 | Gets or sets the tf2.
tw | Gets or sets the tw.
vpy | Gets or sets the vpy.
vpz | Gets or sets the vpz.
vy | Gets or sets the vy.
vz | Gets or sets the vz.


REXSectionParamDimensions Methods

REXSectionParamDimensions Methods
REXSectionParamDimensions Class Legend
REXSectionParamDimensions Methods
REXSectionParamDimensions Methods | Description
Clone | Creates a new object that is a copy of the current instance.


REXSectionParamDimensions Properties

REXSectionParamDimensions Properties
REXSectionParamDimensions Class Legend
REXSectionParamDimensions Properties
REXSectionParamDimensions Properties | Description
b | Gets or sets the b.
b1 | Gets or sets the b1.
b2 | Gets or sets the b2.
bf | Gets or sets the bf.
d | Gets or sets the d.
h | Gets or sets the h.
h1 | Gets or sets the h1.
h2 | Gets or sets the h2.
l1 | Gets or sets the l1.
l2 | Gets or sets the l2.
P1_L | Gets or sets the P1_L.
P1_T | Gets or sets the P1_T.
P2_L | Gets or sets the P2_L.
P2_T | Gets or sets the P2_T.
P3_L | Gets or sets the P3_L.
P3_T | Gets or sets the P3_T.
P4_L | Gets or sets the P4_L.
P4_T | Gets or sets the P4_T.
t | Gets or sets the t.
tf | Gets or sets the tf.
tf1 | Gets or sets the tf1.
tf2 | Gets or sets the tf2.
tw | Gets or sets the tw.
vpy | Gets or sets the vpy.
vpz | Gets or sets the vpz.
vy | Gets or sets the vy.
vz | Gets or sets the vz.


REXSectionParamDimensions Class Public Methods

REXSectionParamDimensions Class Public Methods
REXSectionParamDimensions Class Legend
Public Methods
Public Method | Description
REXSectionParamDimensions | Initializes a new instance of the REXSectionParamDimensions class.
REXSectionParamDimensions | Initializes a new instance of the REXSectionParamDimensions class.
REXSectionParamDimensions | Initializes a new instance of the REXSectionParamDimensions class.
REXSectionParamDimensions | Initializes a new instance of the REXSectionParamDimensions class.


Legend

Legend
SerializableObject Class
Legend
Constructor
virtual


SerializableObject Class Members

SerializableObject Class Members
SerializableObject Class Legend
Members
Public Methods
Public Method | Description
SerializableObject | Initializes a new instance of the SerializableObject class.
SerializableObject Methods
SerializableObject Methods | Description
GetObjectData | Serializes the instance to the Serialization object.
Load | Loads object from the stream.
Save | Saves the object to the stream.


SerializableObject Methods

SerializableObject Methods
SerializableObject Class Legend
SerializableObject Methods
SerializableObject Methods | Description
GetObjectData | Serializes the instance to the Serialization object.
Load | Loads object from the stream.
Save | Saves the object to the stream.


SerializableObject Class Public Methods

SerializableObject Class Public Methods
SerializableObject Class Legend
Public Methods
Public Method | Description
SerializableObject | Initializes a new instance of the SerializableObject class.


REX.ContentGenerator.Geometry Namespace Classes

REX.ContentGenerator.Geometry Namespace Classes
REX.ContentGenerator.Geometry Namespace Legend
Classes
Class | Description
Contour_3D | Represents contour 3D.
Contour_Compound2D | Represents the compound contour.
Contour_Section | Represents the contour of the section.
ContourArc | Represents the arc defined by the start, middle and end point.
ContourCircle | Represents the circle element.
ContourCont | Represents the contour element.
ContourDimension | Represents dimensions.
ContourDimensionLine | Represents the linear dimension.
ContourDimensionRadius | Represents the radial dimension.
ContourElem | Base class for all contour elements.
ContourLine | Represents the line element.
REXSectionAnalyzer | This is class REX.ContentGenerator.Geometry.REXSectionAnalyzer.
REXSectionTypeAnalyzer | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer.
REXSectionTypeAnalyzer_BOX1 | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_BOX1.
REXSectionTypeAnalyzer_BOX2 | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_BOX2.
REXSectionTypeAnalyzer_BOX3 | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_BOX3.
REXSectionTypeAnalyzer_C | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_C.
REXSectionTypeAnalyzer_CROSS | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_CROSS.
REXSectionTypeAnalyzer_DRECT | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_DRECT.
REXSectionTypeAnalyzer_I | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_I.
REXSectionTypeAnalyzer_IASYM | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_IASYM.
REXSectionTypeAnalyzer_L | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_L.
REXSectionTypeAnalyzer_POLYG | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_POLYG.
REXSectionTypeAnalyzer_POLYGHOLLOW | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_POLYGHOLLOW.
REXSectionTypeAnalyzer_RECT | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_RECT.
REXSectionTypeAnalyzer_RECTHOLLOW | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_RECTHOLLOW.
REXSectionTypeAnalyzer_ROUND | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_ROUND.
REXSectionTypeAnalyzer_ROUNDH | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_ROUNDH.
REXSectionTypeAnalyzer_ROUNDQ | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_ROUNDQ.
REXSectionTypeAnalyzer_T | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_T.
REXSectionTypeAnalyzer_TASYM | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_TASYM.
REXSectionTypeAnalyzer_TUBE | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_TUBE.
REXSectionTypeAnalyzer_Z | This is class REX.ContentGenerator.Geometry.REXSectionTypeAnalyzer_Z.


Legend

Legend
REX.ContentGenerator.Geometry Namespace
Legend
Class
abstract
Enumeration
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REX.ContentGenerator.Geometry Namespace Structs, Records, Enums

REX.ContentGenerator.Geometry Namespace Structs, Records, Enums
REX.ContentGenerator.Geometry Namespace Legend
Structs, Records, Enums
Struct, Record, Enum | Description
EArcDir | Describes the direction of an arc.
EContElemType | Represents the type of the element.
ECoords | Describes the coordinate system type.


Legend

Legend
Contour_3D Class
Legend
Constructor
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


Contour_3D Class Members

Contour_3D Class Members
Contour_3D Class Legend
Members
Public Methods
Public Method | Description
Contour_3D | Initializes a new instance of the Contour_3D class.
Contour_3D | Initializes a new instance of the Contour_3D class.
Contour_3D | Initializes a new instance of the Contour_3D class.
Contour_3D Methods
Contour_3D Methods | Description
ArcTo | Defines an arc.
LineTo | Defines a line to the specific point.
LineTo | Defines a line to the specific point.
Reverse | Reverses elements.
StartContour | Starts the defintion of the contour.


Contour_3D Methods

Contour_3D Methods
Contour_3D Class Legend
Contour_3D Methods
Contour_3D Methods | Description
ArcTo | Defines an arc.
LineTo | Defines a line to the specific point.
LineTo | Defines a line to the specific point.
Reverse | Reverses elements.
StartContour | Starts the defintion of the contour.


Contour_3D Class Public Methods

Contour_3D Class Public Methods
Contour_3D Class Legend
Public Methods
Public Method | Description
Contour_3D | Initializes a new instance of the Contour_3D class.
Contour_3D | Initializes a new instance of the Contour_3D class.
Contour_3D | Initializes a new instance of the Contour_3D class.


Legend

Legend
Contour_Compound2D Class
Legend
Constructor
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


Contour_Compound2D Class Members

Contour_Compound2D Class Members
Contour_Compound2D Class Legend
Members
Public Methods
Public Method | Description
Contour_Compound2D | Initializes a new instance of the Contour_Compound2D class.
Contour_Compound2D | Initializes a new instance of the Contour_Compound2D class.
Contour_Compound2D | Initializes a new instance of the Contour_Compound2D class.
Contour_Compound2D | Initializes a new instance of the Contour_Compound2D class.
Contour_Compound2D Methods
Contour_Compound2D Methods | Description
ArcTo | Defines an arc.
ArcTo | Defines an arc.
AxisLine | Defines an axis line.
Circle | Defines a circle.
Dimension | Defines a dimension.
DimensionLine | Defines a dimension line.
DimensionLine | Defines a dimension line.
DimensionRadius | Defines a radial dimension.
GetBoundingBox | Gets the bounding box.
GetGeometryParams | Gets the geometry params.
GetPoint | Gets the point in the specified plane.
LineTo | Defines a line to the specified point.
LineTo | Defines a line to the specified point.
LineToX | Defines a line to the specified point (parallel to X axis).
LineToY | Defines a line to the specified point (parallel to Y axis).
LoadFromString | Loads the contour from the string.
MultiplyLengthDim | Multiplies all length dimensions by the input coefficient.
SaveToString | Saves the contour to the string.
StartContour | Starts the definition of the contour.
StartContour | Starts the definition of the contour.
StartContour | Starts the definition of the contour.
Translate | Applies the specified translation vector to all elements.
Contour_Compound2D Properties
Contour_Compound2D Properties | Description
Axis | Gets or sets the list of axis.
Dimensions | Gets or sets the list of dimensions.
Shape | Gets or sets the list of shapes.


Contour_Compound2D Methods

Contour_Compound2D Methods
Contour_Compound2D Class Legend
Contour_Compound2D Methods
Contour_Compound2D Methods | Description
ArcTo | Defines an arc.
ArcTo | Defines an arc.
AxisLine | Defines an axis line.
Circle | Defines a circle.
Dimension | Defines a dimension.
DimensionLine | Defines a dimension line.
DimensionLine | Defines a dimension line.
DimensionRadius | Defines a radial dimension.
GetBoundingBox | Gets the bounding box.
GetGeometryParams | Gets the geometry params.
GetPoint | Gets the point in the specified plane.
LineTo | Defines a line to the specified point.
LineTo | Defines a line to the specified point.
LineToX | Defines a line to the specified point (parallel to X axis).
LineToY | Defines a line to the specified point (parallel to Y axis).
LoadFromString | Loads the contour from the string.
MultiplyLengthDim | Multiplies all length dimensions by the input coefficient.
SaveToString | Saves the contour to the string.
StartContour | Starts the definition of the contour.
StartContour | Starts the definition of the contour.
StartContour | Starts the definition of the contour.
Translate | Applies the specified translation vector to all elements.


Contour_Compound2D Properties

Contour_Compound2D Properties
Contour_Compound2D Class Legend
Contour_Compound2D Properties
Contour_Compound2D Properties | Description
Axis | Gets or sets the list of axis.
Dimensions | Gets or sets the list of dimensions.
Shape | Gets or sets the list of shapes.


Contour_Compound2D Class Public Methods

Contour_Compound2D Class Public Methods
Contour_Compound2D Class Legend
Public Methods
Public Method | Description
Contour_Compound2D | Initializes a new instance of the Contour_Compound2D class.
Contour_Compound2D | Initializes a new instance of the Contour_Compound2D class.
Contour_Compound2D | Initializes a new instance of the Contour_Compound2D class.
Contour_Compound2D | Initializes a new instance of the Contour_Compound2D class.


Legend

Legend
Contour_Section Class
Legend
Constructor
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


Contour_Section Class Members

Contour_Section Class Members
Contour_Section Class Legend
Members
Public Methods
Public Method | Description
Contour_Section | Initializes a new instance of the Contour_Section class.
Contour_Section | Initializes a new instance of the Contour_Section class.
Contour_Section | Initializes a new instance of the Contour_Section class.


Contour_Section Class Public Methods

Contour_Section Class Public Methods
Contour_Section Class Legend
Public Methods
Public Method | Description
Contour_Section | Initializes a new instance of the Contour_Section class.
Contour_Section | Initializes a new instance of the Contour_Section class.
Contour_Section | Initializes a new instance of the Contour_Section class.


Legend

Legend
ContourArc Class
Legend
Constructor
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


ContourArc Class Members

ContourArc Class Members
ContourArc Class Legend
Members
Public Methods
Public Method | Description
ContourArc | Initializes a new instance of the ContourArc2> class.
ContourArc | Initializes a new instance of the ContourArc2 class.
ContourArc | Initializes a new instance of the ContourArc2> class.
ContourArc | This is ContourArc, a member of class ContourArc.
ContourArc | Initializes a new instance of the ContourArc2 class.
ContourArc Methods
ContourArc Methods | Description
GetCenter | Gets the center of the arc.
GetCenter | Gets the center of the arc.
GetEnd | Gets the end.
GetMiddlePoint | Gets the middle point.
GetPointList | Gets the list of points.
GetStart | Gets the start.
MultiplyLengthDim | Multiplies length dimensions by the coefficient.
Transform | Applies the specified transformation to the element.
Translate | Applies the specified translation vector to the element.
ContourArc Properties
ContourArc Properties | Description
End | Gets or sets the end.
Middle | Gets or sets the middle.
Start | Gets or sets the start.


ContourArc Methods

ContourArc Methods
ContourArc Class Legend
ContourArc Methods
ContourArc Methods | Description
GetCenter | Gets the center of the arc.
GetCenter | Gets the center of the arc.
GetEnd | Gets the end.
GetMiddlePoint | Gets the middle point.
GetPointList | Gets the list of points.
GetStart | Gets the start.
MultiplyLengthDim | Multiplies length dimensions by the coefficient.
Transform | Applies the specified transformation to the element.
Translate | Applies the specified translation vector to the element.


ContourArc Properties

ContourArc Properties
ContourArc Class Legend
ContourArc Properties
ContourArc Properties | Description
End | Gets or sets the end.
Middle | Gets or sets the middle.
Start | Gets or sets the start.


ContourArc Class Public Methods

ContourArc Class Public Methods
ContourArc Class Legend
Public Methods
Public Method | Description
ContourArc | Initializes a new instance of the ContourArc2> class.
ContourArc | Initializes a new instance of the ContourArc2 class.
ContourArc | Initializes a new instance of the ContourArc2> class.
ContourArc | This is ContourArc, a member of class ContourArc.
ContourArc | Initializes a new instance of the ContourArc2 class.


Legend

Legend
ContourCircle Class
Legend
Constructor
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


ContourCircle Class Members

ContourCircle Class Members
ContourCircle Class Legend
Members
Public Methods
Public Method | Description
ContourCircle | Initializes a new instance of the ContourCircle class.
ContourCircle | Initializes a new instance of the ContourCircle class.
ContourCircle | Initializes a new instance of the ContourCircle class.
ContourCircle | Initializes a new instance of the ContourCircle class.
ContourCircle Methods
ContourCircle Methods | Description
GetPointList | Gets the list of points.
GetStart | Gets the start (center).
MultiplyLengthDim | Multiplies length dimensions by the coefficient.
Translate | Applies the specified translation vector to the element.
ContourCircle Properties
ContourCircle Properties | Description
Center | Gets or sets the start (center).
R | Gets or sets the radius.


ContourCircle Methods

ContourCircle Methods
ContourCircle Class Legend
ContourCircle Methods
ContourCircle Methods | Description
GetPointList | Gets the list of points.
GetStart | Gets the start (center).
MultiplyLengthDim | Multiplies length dimensions by the coefficient.
Translate | Applies the specified translation vector to the element.


ContourCircle Properties

ContourCircle Properties
ContourCircle Class Legend
ContourCircle Properties
ContourCircle Properties | Description
Center | Gets or sets the start (center).
R | Gets or sets the radius.


ContourCircle Class Public Methods

ContourCircle Class Public Methods
ContourCircle Class Legend
Public Methods
Public Method | Description
ContourCircle | Initializes a new instance of the ContourCircle class.
ContourCircle | Initializes a new instance of the ContourCircle class.
ContourCircle | Initializes a new instance of the ContourCircle class.
ContourCircle | Initializes a new instance of the ContourCircle class.


Legend

Legend
ContourCont Class
Legend
Constructor
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


ContourCont Class Members

ContourCont Class Members
ContourCont Class Legend
Members
Public Methods
Public Method | Description
ContourCont | Initializes a new instance of the ContourCont class.
ContourCont | Initializes a new instance of the ContourCont class.
ContourCont | Initializes a new instance of the ContourCont class.
ContourCont | Initializes a new instance of the ContourCont class.
ContourCont Methods
ContourCont Methods | Description
GetGeometryParams | Gets the geometry params.
GetPointList | Gets the list of points.
IsContourInsideMe | Determines whether the contour is inside current one.
MultiplyLengthDim | Multiplies length dimensions by the coefficient.
Transform | Applies the specified transformation to the element.
Translate | Applies the specified translation vector to the element.
ContourCont Properties
ContourCont Properties | Description
ContList | Gets or sets the list of contours.
ElemList | Gets or sets the list of elements.
Hole | Gets or sets a value indicating whether this contour is a hole.


ContourCont Methods

ContourCont Methods
ContourCont Class Legend
ContourCont Methods
ContourCont Methods | Description
GetGeometryParams | Gets the geometry params.
GetPointList | Gets the list of points.
IsContourInsideMe | Determines whether the contour is inside current one.
MultiplyLengthDim | Multiplies length dimensions by the coefficient.
Transform | Applies the specified transformation to the element.
Translate | Applies the specified translation vector to the element.


ContourCont Properties

ContourCont Properties
ContourCont Class Legend
ContourCont Properties
ContourCont Properties | Description
ContList | Gets or sets the list of contours.
ElemList | Gets or sets the list of elements.
Hole | Gets or sets a value indicating whether this contour is a hole.


ContourCont Class Public Methods

ContourCont Class Public Methods
ContourCont Class Legend
Public Methods
Public Method | Description
ContourCont | Initializes a new instance of the ContourCont class.
ContourCont | Initializes a new instance of the ContourCont class.
ContourCont | Initializes a new instance of the ContourCont class.
ContourCont | Initializes a new instance of the ContourCont class.


Legend

Legend
ContourDimension Class
Legend
Constructor
virtual
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


ContourDimension Class Members

ContourDimension Class Members
ContourDimension Class Legend
Members
Public Methods
Public Method | Description
ContourDimension | Initializes a new instance of the ContourDimension class.
ContourDimension | Initializes a new instance of the ContourDimension class.
ContourDimension Methods
ContourDimension Methods | Description
MultiplyLengthDim | Multiplies length dimensions by the coefficient.
Translate | Applies the specified translation vector to the element.
ContourDimension Properties
ContourDimension Properties | Description
Parameter | Gets or sets the parameter (text).
Start | Gets or sets the start.


ContourDimension Methods

ContourDimension Methods
ContourDimension Class Legend
ContourDimension Methods
ContourDimension Methods | Description
MultiplyLengthDim | Multiplies length dimensions by the coefficient.
Translate | Applies the specified translation vector to the element.


ContourDimension Properties

ContourDimension Properties
ContourDimension Class Legend
ContourDimension Properties
ContourDimension Properties | Description
Parameter | Gets or sets the parameter (text).
Start | Gets or sets the start.


ContourDimension Class Public Methods

ContourDimension Class Public Methods
ContourDimension Class Legend
Public Methods
Public Method | Description
ContourDimension | Initializes a new instance of the ContourDimension class.
ContourDimension | Initializes a new instance of the ContourDimension class.


Legend

Legend
ContourDimensionLine Class
Legend
Constructor
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


ContourDimensionLine Class Members

ContourDimensionLine Class Members
ContourDimensionLine Class Legend
Members
Public Methods
Public Method | Description
ContourDimensionLine | Initializes a new instance of the ContourDimensionLine class.
ContourDimensionLine | Initializes a new instance of the ContourDimensionLine class.
ContourDimensionLine Methods
ContourDimensionLine Methods | Description
MultiplyLengthDim | Multiplies length dimensions by the coefficient.
Translate | Applies the specified translation vector to the element.
ContourDimensionLine Properties
ContourDimensionLine Properties | Description
End | Gets or sets the end.
Extend2Right | Gets or sets a value indicating whether the dimension should be extended to the right.
Level | Gets or sets the level.
Up | Gets or sets a value indicating whether dimension is defined above the reference.


ContourDimensionLine Methods

ContourDimensionLine Methods
ContourDimensionLine Class Legend
ContourDimensionLine Methods
ContourDimensionLine Methods | Description
MultiplyLengthDim | Multiplies length dimensions by the coefficient.
Translate | Applies the specified translation vector to the element.


ContourDimensionLine Properties

ContourDimensionLine Properties
ContourDimensionLine Class Legend
ContourDimensionLine Properties
ContourDimensionLine Properties | Description
End | Gets or sets the end.
Extend2Right | Gets or sets a value indicating whether the dimension should be extended to the right.
Level | Gets or sets the level.
Up | Gets or sets a value indicating whether dimension is defined above the reference.


ContourDimensionLine Class Public Methods

ContourDimensionLine Class Public Methods
ContourDimensionLine Class Legend
Public Methods
Public Method | Description
ContourDimensionLine | Initializes a new instance of the ContourDimensionLine class.
ContourDimensionLine | Initializes a new instance of the ContourDimensionLine class.


Legend

Legend
ContourDimensionRadius Class
Legend
Constructor
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


ContourDimensionRadius Class Members

ContourDimensionRadius Class Members
ContourDimensionRadius Class Legend
Members
Public Methods
Public Method | Description
ContourDimensionRadius | Initializes a new instance of the ContourDimensionRadius class.
ContourDimensionRadius | Initializes a new instance of the ContourDimensionRadius class.
ContourDimensionRadius Methods
ContourDimensionRadius Methods | Description
MultiplyLengthDim | Multiplies length dimensions by the coefficient.
Translate | Applies the specified translation vector to the element.
ContourDimensionRadius Properties
ContourDimensionRadius Properties | Description
End | Gets or sets the end.
Up | Gets or sets a value indicating whether dimension is defined above the reference.


ContourDimensionRadius Methods

ContourDimensionRadius Methods
ContourDimensionRadius Class Legend
ContourDimensionRadius Methods
ContourDimensionRadius Methods | Description
MultiplyLengthDim | Multiplies length dimensions by the coefficient.
Translate | Applies the specified translation vector to the element.


ContourDimensionRadius Properties

ContourDimensionRadius Properties
ContourDimensionRadius Class Legend
ContourDimensionRadius Properties
ContourDimensionRadius Properties | Description
End | Gets or sets the end.
Up | Gets or sets a value indicating whether dimension is defined above the reference.


ContourDimensionRadius Class Public Methods

ContourDimensionRadius Class Public Methods
ContourDimensionRadius Class Legend
Public Methods
Public Method | Description
ContourDimensionRadius | Initializes a new instance of the ContourDimensionRadius class.
ContourDimensionRadius | Initializes a new instance of the ContourDimensionRadius class.


Legend

Legend
ContourElem Class
Legend
Constructor
virtual
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


ContourElem Class Members

ContourElem Class Members
ContourElem Class Legend
Members
Public Methods
Public Method | Description
ContourElem | Initializes a new instance of the ContourElem class.
ContourElem | Initializes a new instance of the ContourElem class.
ContourElem Methods
ContourElem Methods | Description
GetFlatPointInCoords | Gets the flat point in the plane.
GetPointList | Gets the list of points.
MultiplyLengthDim | Multiplies length dimensions by the coefficient.
Transform | Applies the specified transformation to the element.
Transform | Applies the specified transformation to the element.
Translate | Applies the specified translation vector to the element.
ContourElem Properties
ContourElem Properties | Description
ElemType | Gets the type of the elem.
Tag | Gets or sets the tag.


ContourElem Methods

ContourElem Methods
ContourElem Class Legend
ContourElem Methods
ContourElem Methods | Description
GetFlatPointInCoords | Gets the flat point in the plane.
GetPointList | Gets the list of points.
MultiplyLengthDim | Multiplies length dimensions by the coefficient.
Transform | Applies the specified transformation to the element.
Transform | Applies the specified transformation to the element.
Translate | Applies the specified translation vector to the element.


ContourElem Properties

ContourElem Properties
ContourElem Class Legend
ContourElem Properties
ContourElem Properties | Description
ElemType | Gets the type of the elem.
Tag | Gets or sets the tag.


ContourElem Class Public Methods

ContourElem Class Public Methods
ContourElem Class Legend
Public Methods
Public Method | Description
ContourElem | Initializes a new instance of the ContourElem class.
ContourElem | Initializes a new instance of the ContourElem class.


Legend

Legend
ContourLine Class
Legend
Constructor
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


ContourLine Class Members

ContourLine Class Members
ContourLine Class Legend
Members
Public Methods
Public Method | Description
ContourLine | Initializes a new instance of the ContourLine class.
ContourLine | Initializes a new instance of the ContourLine class.
ContourLine | Initializes a new instance of the ContourLine class.
ContourLine | Initializes a new instance of the ContourLine class.
ContourLine | Initializes a new instance of the ContourLine class.
ContourLine Methods
ContourLine Methods | Description
GetEnd | Gets the end point in a plane.
GetPointList | Gets the list of points.
GetStart | Gets the start point in a plane.
MultiplyLengthDim | Multiplies length dimensions by the coefficient.
Transform | Applies the specified transformation to the element.
Translate | Applies the specified translation vector to the element.
ContourLine Properties
ContourLine Properties | Description
End | Gets or sets the end point.
Start | Gets or sets the start point.


ContourLine Methods

ContourLine Methods
ContourLine Class Legend
ContourLine Methods
ContourLine Methods | Description
GetEnd | Gets the end point in a plane.
GetPointList | Gets the list of points.
GetStart | Gets the start point in a plane.
MultiplyLengthDim | Multiplies length dimensions by the coefficient.
Transform | Applies the specified transformation to the element.
Translate | Applies the specified translation vector to the element.


ContourLine Properties

ContourLine Properties
ContourLine Class Legend
ContourLine Properties
ContourLine Properties | Description
End | Gets or sets the end point.
Start | Gets or sets the start point.


ContourLine Class Public Methods

ContourLine Class Public Methods
ContourLine Class Legend
Public Methods
Public Method | Description
ContourLine | Initializes a new instance of the ContourLine class.
ContourLine | Initializes a new instance of the ContourLine class.
ContourLine | Initializes a new instance of the ContourLine class.
ContourLine | Initializes a new instance of the ContourLine class.
ContourLine | Initializes a new instance of the ContourLine class.


Legend

Legend
REXSectionTypeAnalyzer Class
Legend
Constructor
static
virtual


REXSectionTypeAnalyzer Class Members

REXSectionTypeAnalyzer Class Members
REXSectionTypeAnalyzer Class Legend
Members
Public Methods
Public Method | Description
REXSectionTypeAnalyzer | This is REXSectionTypeAnalyzer, a member of class REXSectionTypeAnalyzer.
REXSectionTypeAnalyzer Methods
REXSectionTypeAnalyzer Methods | Description
BuildVectorShape | This is BuildVectorShape, a member of class REXSectionTypeAnalyzer.
FitCompoundProfilePattern | This is FitCompoundProfilePattern, a member of class REXSectionTypeAnalyzer.
GetMaximumLength | This is GetMaximumLength, a member of class REXSectionTypeAnalyzer.
GetNextIndex | This is GetNextIndex, a member of class REXSectionTypeAnalyzer.
GetParametricDescription | This is GetParametricDescription, a member of class REXSectionTypeAnalyzer.
GetParametricDescription | This is GetParametricDescription, a member of class REXSectionTypeAnalyzer.
GetPreviousIndex | This is GetPreviousIndex, a member of class REXSectionTypeAnalyzer.
ReorderShape | This is ReorderShape, a member of class REXSectionTypeAnalyzer.
RepairCompoundSectionProfile | This is RepairCompoundSectionProfile, a member of class REXSectionTypeAnalyzer.
RepairSectionProfile | This is RepairSectionProfile, a member of class REXSectionTypeAnalyzer.
RepairShapeCounterClockWise | This is RepairShapeCounterClockWise, a member of class REXSectionTypeAnalyzer.
RepairShapeDue2BoundingBox | This is RepairShapeDue2BoundingBox, a member of class REXSectionTypeAnalyzer.
RepairShapeLines | This is RepairShapeLines, a member of class REXSectionTypeAnalyzer.
TransformCompoundProfile | This is TransformCompoundProfile, a member of class REXSectionTypeAnalyzer.
TransformProfile | This is TransformProfile, a member of class REXSectionTypeAnalyzer.
TransformShape | This is TransformShape, a member of class REXSectionTypeAnalyzer.
ValidateCircle | This is ValidateCircle, a member of class REXSectionTypeAnalyzer.
ValidateCircle | This is ValidateCircle, a member of class REXSectionTypeAnalyzer.
VectorDrivenAnalysis | This is VectorDrivenAnalysis, a member of class REXSectionTypeAnalyzer.


Members

Legend
Legend
Constructor
static
virtual


REXSectionTypeAnalyzer Methods

REXSectionTypeAnalyzer Methods
REXSectionTypeAnalyzer Class Legend
REXSectionTypeAnalyzer Methods
REXSectionTypeAnalyzer Methods | Description
BuildVectorShape | This is BuildVectorShape, a member of class REXSectionTypeAnalyzer.
FitCompoundProfilePattern | This is FitCompoundProfilePattern, a member of class REXSectionTypeAnalyzer.
GetMaximumLength | This is GetMaximumLength, a member of class REXSectionTypeAnalyzer.
GetNextIndex | This is GetNextIndex, a member of class REXSectionTypeAnalyzer.
GetParametricDescription | This is GetParametricDescription, a member of class REXSectionTypeAnalyzer.
GetParametricDescription | This is GetParametricDescription, a member of class REXSectionTypeAnalyzer.
GetPreviousIndex | This is GetPreviousIndex, a member of class REXSectionTypeAnalyzer.
ReorderShape | This is ReorderShape, a member of class REXSectionTypeAnalyzer.
RepairCompoundSectionProfile | This is RepairCompoundSectionProfile, a member of class REXSectionTypeAnalyzer.
RepairSectionProfile | This is RepairSectionProfile, a member of class REXSectionTypeAnalyzer.
RepairShapeCounterClockWise | This is RepairShapeCounterClockWise, a member of class REXSectionTypeAnalyzer.
RepairShapeDue2BoundingBox | This is RepairShapeDue2BoundingBox, a member of class REXSectionTypeAnalyzer.
RepairShapeLines | This is RepairShapeLines, a member of class REXSectionTypeAnalyzer.
TransformCompoundProfile | This is TransformCompoundProfile, a member of class REXSectionTypeAnalyzer.
TransformProfile | This is TransformProfile, a member of class REXSectionTypeAnalyzer.
TransformShape | This is TransformShape, a member of class REXSectionTypeAnalyzer.
ValidateCircle | This is ValidateCircle, a member of class REXSectionTypeAnalyzer.
ValidateCircle | This is ValidateCircle, a member of class REXSectionTypeAnalyzer.
VectorDrivenAnalysis | This is VectorDrivenAnalysis, a member of class REXSectionTypeAnalyzer.


Methods (AutoDoc Folder)

Legend
Legend
Method
static
virtual


REXSectionTypeAnalyzer Class Public Methods

REXSectionTypeAnalyzer Class Public Methods
REXSectionTypeAnalyzer Class Legend
Public Methods
Public Method | Description
REXSectionTypeAnalyzer | This is REXSectionTypeAnalyzer, a member of class REXSectionTypeAnalyzer.


Legend

Legend
REXSectionTypeAnalyzer_ROUND Class
Legend
Method
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXSectionTypeAnalyzer_ROUND Class Members

REXSectionTypeAnalyzer_ROUND Class Members
REXSectionTypeAnalyzer_ROUND Class Legend
Members
REXSectionTypeAnalyzer_ROUND Methods
REXSectionTypeAnalyzer_ROUND Methods | Description
GetParametricDescription | This is GetParametricDescription, a member of class REXSectionTypeAnalyzer_ROUND.
GetParametricDescription | This is GetParametricDescription, a member of class REXSectionTypeAnalyzer_ROUND.
VectorDrivenAnalysis | This is VectorDrivenAnalysis, a member of class REXSectionTypeAnalyzer_ROUND.


REXSectionTypeAnalyzer_ROUND Methods

REXSectionTypeAnalyzer_ROUND Methods
REXSectionTypeAnalyzer_ROUND Class Legend
REXSectionTypeAnalyzer_ROUND Methods
REXSectionTypeAnalyzer_ROUND Methods | Description
GetParametricDescription | This is GetParametricDescription, a member of class REXSectionTypeAnalyzer_ROUND.
GetParametricDescription | This is GetParametricDescription, a member of class REXSectionTypeAnalyzer_ROUND.
VectorDrivenAnalysis | This is VectorDrivenAnalysis, a member of class REXSectionTypeAnalyzer_ROUND.


Legend

Legend
REXSectionTypeAnalyzer_ROUNDH Class
Legend
Method
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXSectionTypeAnalyzer_ROUNDH Class Members

REXSectionTypeAnalyzer_ROUNDH Class Members
REXSectionTypeAnalyzer_ROUNDH Class Legend
Members
REXSectionTypeAnalyzer_ROUNDH Methods
REXSectionTypeAnalyzer_ROUNDH Methods | Description
GetParametricDescription | This is GetParametricDescription, a member of class REXSectionTypeAnalyzer_ROUNDH.
GetParametricDescription | This is GetParametricDescription, a member of class REXSectionTypeAnalyzer_ROUNDH.
VectorDrivenAnalysis | This is VectorDrivenAnalysis, a member of class REXSectionTypeAnalyzer_ROUNDH.


REXSectionTypeAnalyzer_ROUNDH Methods

REXSectionTypeAnalyzer_ROUNDH Methods
REXSectionTypeAnalyzer_ROUNDH Class Legend
REXSectionTypeAnalyzer_ROUNDH Methods
REXSectionTypeAnalyzer_ROUNDH Methods | Description
GetParametricDescription | This is GetParametricDescription, a member of class REXSectionTypeAnalyzer_ROUNDH.
GetParametricDescription | This is GetParametricDescription, a member of class REXSectionTypeAnalyzer_ROUNDH.
VectorDrivenAnalysis | This is VectorDrivenAnalysis, a member of class REXSectionTypeAnalyzer_ROUNDH.


Legend

Legend
REXSectionTypeAnalyzer_ROUNDQ Class
Legend
Method
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXSectionTypeAnalyzer_ROUNDQ Class Members

REXSectionTypeAnalyzer_ROUNDQ Class Members
REXSectionTypeAnalyzer_ROUNDQ Class Legend
Members
REXSectionTypeAnalyzer_ROUNDQ Methods
REXSectionTypeAnalyzer_ROUNDQ Methods | Description
GetParametricDescription | This is GetParametricDescription, a member of class REXSectionTypeAnalyzer_ROUNDQ.
GetParametricDescription | This is GetParametricDescription, a member of class REXSectionTypeAnalyzer_ROUNDQ.
VectorDrivenAnalysis | This is VectorDrivenAnalysis, a member of class REXSectionTypeAnalyzer_ROUNDQ.


REXSectionTypeAnalyzer_ROUNDQ Methods

REXSectionTypeAnalyzer_ROUNDQ Methods
REXSectionTypeAnalyzer_ROUNDQ Class Legend
REXSectionTypeAnalyzer_ROUNDQ Methods
REXSectionTypeAnalyzer_ROUNDQ Methods | Description
GetParametricDescription | This is GetParametricDescription, a member of class REXSectionTypeAnalyzer_ROUNDQ.
GetParametricDescription | This is GetParametricDescription, a member of class REXSectionTypeAnalyzer_ROUNDQ.
VectorDrivenAnalysis | This is VectorDrivenAnalysis, a member of class REXSectionTypeAnalyzer_ROUNDQ.


Legend

Legend
REXSectionTypeAnalyzer_TUBE Class
Legend
Method
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXSectionTypeAnalyzer_TUBE Class Members

REXSectionTypeAnalyzer_TUBE Class Members
REXSectionTypeAnalyzer_TUBE Class Legend
Members
REXSectionTypeAnalyzer_TUBE Methods
REXSectionTypeAnalyzer_TUBE Methods | Description
GetParametricDescription | This is GetParametricDescription, a member of class REXSectionTypeAnalyzer_TUBE.
GetParametricDescription | This is GetParametricDescription, a member of class REXSectionTypeAnalyzer_TUBE.
VectorDrivenAnalysis | This is VectorDrivenAnalysis, a member of class REXSectionTypeAnalyzer_TUBE.


REXSectionTypeAnalyzer_TUBE Methods

REXSectionTypeAnalyzer_TUBE Methods
REXSectionTypeAnalyzer_TUBE Class Legend
REXSectionTypeAnalyzer_TUBE Methods
REXSectionTypeAnalyzer_TUBE Methods | Description
GetParametricDescription | This is GetParametricDescription, a member of class REXSectionTypeAnalyzer_TUBE.
GetParametricDescription | This is GetParametricDescription, a member of class REXSectionTypeAnalyzer_TUBE.
VectorDrivenAnalysis | This is VectorDrivenAnalysis, a member of class REXSectionTypeAnalyzer_TUBE.


REX.ContentGenerator.Map Namespace Classes

REX.ContentGenerator.Map Namespace Classes
REX.ContentGenerator.Map Namespace Legend
Classes
Class | Description
ContentMapper | Provides interface to the mapping system of the ContentGenerator.
REXContentMapCategorySettings | Represents settings for a specific category of elements.
REXContentMapDialogSettings | Represents settings for the map dialog.
REXContentMapper | Provides interface to the mapping system of the Content Generator in REX context.
RVTContentMapper | Provides interface to the mapping system of the Content Generator in Revit context.


Legend

Legend
REX.ContentGenerator.Map Namespace
Legend
Class
abstract


Legend

Legend
ContentMapper Class
Legend
Method
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


ContentMapper Class Members

ContentMapper Class Members
ContentMapper Class Legend
Members
ContentMapper Methods
ContentMapper Methods | Description
AddLabel | Adds the label to the list.
ApplyMapControl | Applies the map control.
CloseMapControl | Closes the map control.
CreateMapControl | Creates the map control.
GetLabels | Gets the labels.
LaunchMapDialog | Launches the map dialog.
LoadUserMap | Loads the user map to the Content Generator.
RefreshMapControl | Refreshes the map control.
ReloadGlobalMap | Reloads the global map.
ResetUserMap | Resets the user map.
SaveGlobalMap | Saves the global map.
SaveUserMap | Saves the user map.
SetDefaults | Sets defaults in the mapping system.
SetREXConverter | Sets the REX converter.
ContentMapper Properties
ContentMapper Properties | Description
DialogSettings | Gets the dialog's settings.


ContentMapper Methods

ContentMapper Methods
ContentMapper Class Legend
ContentMapper Methods
ContentMapper Methods | Description
AddLabel | Adds the label to the list.
ApplyMapControl | Applies the map control.
CloseMapControl | Closes the map control.
CreateMapControl | Creates the map control.
GetLabels | Gets the labels.
LaunchMapDialog | Launches the map dialog.
LoadUserMap | Loads the user map to the Content Generator.
RefreshMapControl | Refreshes the map control.
ReloadGlobalMap | Reloads the global map.
ResetUserMap | Resets the user map.
SaveGlobalMap | Saves the global map.
SaveUserMap | Saves the user map.
SetDefaults | Sets defaults in the mapping system.
SetREXConverter | Sets the REX converter.


ContentMapper Properties

ContentMapper Properties
ContentMapper Class Legend
ContentMapper Properties
ContentMapper Properties | Description
DialogSettings | Gets the dialog's settings.


Example

Example
ContentMapper.AddLabel Method

The example shows how to use labels in a mapping system.

//Revit converter
RVTFamilyConverter rvt = new RVTFamilyConverter(ThisExtension.Revit.CommandData(), true);
rvt.Settings.Labels = true;

//-example label without description
REXFamilyType_Label label1 = new REXFamilyType_Label(ECategoryType.SECTION_DB, "test1");

//-example label with section defined manually
REXFamilyType_Label label2 = new REXFamilyType_Label(ECategoryType.SECTION_DB, "test2");
REXFamilyType_ParamSection paramSection = new REXFamilyType_ParamSection();
paramSection.Material = EMaterial.CONCRETE;
paramSection.ElementType = REX.ContentGenerator.Families.EElementType.BEAM;
paramSection.Parameters.SectionType = ESectionType.RECT;
paramSection.Parameters.Dimensions.b = 1;
paramSection.Parameters.Dimensions.h = 1;
label2.Parameters.LabelFamilyDescription = paramSection;

//-definition of category
rvt.ContentMapper.DialogSettings.SectionSettings.LabelCategoryName = "MyCategory";

//-adding labels to list
rvt.ContentMapper.DialogSettings.SectionSettings.Labels.Add(label1);
rvt.ContentMapper.DialogSettings.SectionSettings.Labels.Add(label2);

//Map dialog.
Autodesk.Revit.DB.FilteredElementCollector collector = new FilteredElementCollector(ThisExtension.Revit.ActiveDocument);
List<Element> Sections = new List<Element>();
//Sections.
rvt.ContentMapper.DialogSettings.SectionSettings.Visible = true;
//-adding elements
foreach (FamilySymbol obj in collector.OfClass(typeof(FamilySymbol)).ToElements())
{
    if(((BuiltInCategory)obj.Category.Id.IntegerValue) == BuiltInCategory.OST_StructuralFraming)
        rvt.ContentMapper.DialogSettings.SectionSettings.Elements.Add(obj);
}
if (rvt.ContentMapper.DialogSettings.SectionSettings.Elements.Count > 1)
{
    rvt.ContentMapper.SetMapElement(true, (Element)rvt.ContentMapper.DialogSettings.SectionSettings.Elements[0], label1, ECategoryType.SECTION_DB);
    rvt.ContentMapper.SetMapElement(true, (Element)rvt.ContentMapper.DialogSettings.SectionSettings.Elements[1], label2, ECategoryType.SECTION_DB);
}
//-databases start list
rvt.ContentMapper.DialogSettings.SectionSettings.Databases.Add("Rcatpro");

//Materials.
rvt.ContentMapper.DialogSettings.MaterialSettings.Visible = false;

//Rebars.
rvt.ContentMapper.DialogSettings.RebarTypeSettings.Visible = false;

//Launching
Autodesk.REX.Common.REXContext cont = ThisExtension.Context;
bool ok = rvt.ContentMapper.LaunchMapDialog(ref cont);

if (ok)
{
        REXFamilyType sect = rvt.ContentMapper.GetMapElement(Sections[0],ECategoryType.SECTION_DB);
}


Example

Example
ContentMapper.CreateMapControl Method

The example shows how to customize and launch the map dialog.

//Revit converter.
RVTFamilyConverter rvt = new RVTFamilyConverter(ThisExtension.Revit.CommandData(), true);

Autodesk.Revit.DB.FilteredElementCollector collector = new FilteredElementCollector(ThisExtension.Revit.ActiveDocument);

List<Element> Sections = new List<Element>();

//General settings.
rvt.ContentMapper.DialogSettings.CheckIfAllMappedBeforeLeave = false;
rvt.ContentMapper.DialogSettings.Menu = false;
rvt.ContentMapper.DialogSettings.List = false;
rvt.ContentMapper.DialogSettings.ShowWhenNoElementsToMap = true;

//Sections.
rvt.ContentMapper.DialogSettings.SectionSettings.Visible = true;
//-adding elements
foreach (FamilySymbol obj in collector.OfClass(typeof(FamilySymbol)).ToElements())
{
    rvt.ContentMapper.DialogSettings.SectionSettings.Elements.Add(obj);
    Sections.Add(obj);
}
//-databases start list
rvt.ContentMapper.DialogSettings.SectionSettings.Databases.Add("Rcatpro");

//Launching.
Autodesk.REX.Common.REXContext cont = ThisExtension.Context;
object ctr = rvt.ContentMapper.CreateMapControl(ref cont);


Example

Example
ContentMapper.LaunchMapDialog Method

The example shows how to customize and launch the map dialog.

//Revit converter.
RVTFamilyConverter rvt = new RVTFamilyConverter(ThisExtension.Revit.CommandData(), true);

Autodesk.Revit.DB.FilteredElementCollector collector = new FilteredElementCollector(ThisExtension.Revit.ActiveDocument);

List<Element> Sections = new List<Element>();
List<Element> Rebars = new List<Element>();

//General settings.
rvt.ContentMapper.DialogSettings.CheckIfAllMappedBeforeLeave = true;
rvt.ContentMapper.DialogSettings.NotAllMappedText = "Not all elements are mapped";

//Sections.
rvt.ContentMapper.DialogSettings.SectionSettings.Visible = true;
//-adding elements
foreach (FamilySymbol obj in collector.OfClass(typeof(FamilySymbol)).ToElements())
{
    rvt.ContentMapper.DialogSettings.SectionSettings.Elements.Add(obj);
    Sections.Add(obj);
}
//-databases start list
rvt.ContentMapper.DialogSettings.SectionSettings.Databases.Add("Rcatpro");

//Materials.
rvt.ContentMapper.DialogSettings.MaterialSettings.Visible = false;

//Rebars.
rvt.ContentMapper.DialogSettings.RebarTypeSettings.Visible = true;
//-user won't be able to add databases
rvt.ContentMapper.DialogSettings.RebarTypeSettings.AllowToAddDatabases = false;
//-if there will be find the map element with some database assigned this database won't be loaded to Content dialog automatically
rvt.ContentMapper.DialogSettings.RebarTypeSettings.AddMappedDatabases = false;
//-adding elements
foreach (RebarBarType obj in collector.OfClass(typeof(RebarBarType)).ToElements())
{
     rvt.ContentMapper.DialogSettings.SectionSettings.Elements.Add(obj);
     Rebars.Add(obj);
}
//-database list
rvt.ContentMapper.DialogSettings.RebarTypeSettings.Databases.Add("bar_BAEL M");
//-available steels
rvt.ContentMapper.DialogSettings.RebarTypeSettings.SteelsAvailable.Add("HA 400");
//-if defaults should be set
rvt.ContentMapper.DialogSettings.RebarTypeSettings.SetDefaultsForUnknown = true;

//-if certified elements should be mapped
rvt.ContentMapper.DialogSettings.RebarTypeSettings.MapCertifiedFamilies = true;
//-setting default elements for rebartype
rvt.ContentMapper.SetDefaults(ThisExtension.Preferences.PreferencesBase2.RegionalSettings, ECategoryType.REBAR_BARTYPE);

//Launching.
Autodesk.REX.Common.REXContext cont = ThisExtension.Context;
bool ok = rvt.ContentMapper.LaunchMapDialog(ref cont);

if (ok)
{
    //Getting mapped element
    REXFamilyType sect = rvt.ContentMapper.GetMapElement(Sections[0],ECategoryType.SECTION_DB);
}


Legend

Legend
REXContentMapCategorySettings Class
Legend
Constructor
virtual
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXContentMapCategorySettings Class Members

REXContentMapCategorySettings Class Members
REXContentMapCategorySettings Class Legend
Members
Public Methods
Public Method | Description
REXContentMapCategorySettings | Initializes a new instance of the REXContentMapCategorySettings class.
REXContentMapCategorySettings Methods
REXContentMapCategorySettings Methods | Description
ContainsLabel | Determines whether the mapping system contains the specified label.
FilterFamilies | Filters the list of families.
FilterFamily | Filters the family object according settings.
REXContentMapCategorySettings Properties
REXContentMapCategorySettings Properties | Description
AddMappedDatabases | Gets or sets a value indicating whether databases saved in loaded files should be loaded to the system.
AllowToAddDatabases | Gets or sets a value indicating whether a user is able to add databases to the list.
Category | Gets the category.
Databases | Gets or sets the list of databases supported by this category.
DatabasesResult | Gets or sets the list of databases which were finally choosen by the user in the dialog.
Elements | Gets the list of elements which should be mapped.
LabelCategoryName | Gets or sets the name of the label category.
Labels | Gets the list of labels.
MapCertifiedFamilies | Gets or sets a value indicating whether certified families are mapped.
SetDefaultsForUnknown | Gets or sets a value indicating whether defaults are set for elements which weren't mapped.
Settings | Gets the settings of the dialog.
Visible | Gets or sets a value indicating whether this category is visible.


REXContentMapCategorySettings Methods

REXContentMapCategorySettings Methods
REXContentMapCategorySettings Class Legend
REXContentMapCategorySettings Methods
REXContentMapCategorySettings Methods | Description
ContainsLabel | Determines whether the mapping system contains the specified label.
FilterFamilies | Filters the list of families.
FilterFamily | Filters the family object according settings.


REXContentMapCategorySettings Properties

REXContentMapCategorySettings Properties
REXContentMapCategorySettings Class Legend
REXContentMapCategorySettings Properties
REXContentMapCategorySettings Properties | Description
AddMappedDatabases | Gets or sets a value indicating whether databases saved in loaded files should be loaded to the system.
AllowToAddDatabases | Gets or sets a value indicating whether a user is able to add databases to the list.
Category | Gets the category.
Databases | Gets or sets the list of databases supported by this category.
DatabasesResult | Gets or sets the list of databases which were finally choosen by the user in the dialog.
Elements | Gets the list of elements which should be mapped.
LabelCategoryName | Gets or sets the name of the label category.
Labels | Gets the list of labels.
MapCertifiedFamilies | Gets or sets a value indicating whether certified families are mapped.
SetDefaultsForUnknown | Gets or sets a value indicating whether defaults are set for elements which weren't mapped.
Settings | Gets the settings of the dialog.
Visible | Gets or sets a value indicating whether this category is visible.


REXContentMapCategorySettings Class Public Methods

REXContentMapCategorySettings Class Public Methods
REXContentMapCategorySettings Class Legend
Public Methods
Public Method | Description
REXContentMapCategorySettings | Initializes a new instance of the REXContentMapCategorySettings class.


Legend

Legend
REXContentMapDialogSettings Class
Legend
Constructor
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXContentMapDialogSettings Class Members

REXContentMapDialogSettings Class Members
REXContentMapDialogSettings Class Legend
Members
Public Methods
Public Method | Description
REXContentMapDialogSettings | Initializes a new instance of the REXContentMapDialogSettings class.
REXContentMapDialogSettings Methods
REXContentMapDialogSettings Methods | Description
GetSettings | Gets settings of the specific type.
REXContentMapDialogSettings Properties
REXContentMapDialogSettings Properties | Description
CheckIfAllMappedBeforeLeave | Gets or sets a value indicating whether dialog should be validated before leaving.
List | Gets or sets a value indicating whether the list should be visible on the dialog.
Mapper | Gets the mapper.
MaterialSettings | Gets the material settings.
Menu | Gets or sets a value indicating whether menu should be visible on the dialog.
NotAllMappedText | Gets or sets the text which should appear when validation didn't succeed (if CheckIfAllMappedBeforeLeave option).
RebarTypeSettings | Gets the rebar type settings.
SectionSettings | Gets the section settings.
ShowWhenNoElementsToMap | Gets or sets a value indicating whether dialog should appear when there are no elements to map.


REXContentMapDialogSettings Methods

REXContentMapDialogSettings Methods
REXContentMapDialogSettings Class Legend
REXContentMapDialogSettings Methods
REXContentMapDialogSettings Methods | Description
GetSettings | Gets settings of the specific type.


REXContentMapDialogSettings Properties

REXContentMapDialogSettings Properties
REXContentMapDialogSettings Class Legend
REXContentMapDialogSettings Properties
REXContentMapDialogSettings Properties | Description
CheckIfAllMappedBeforeLeave | Gets or sets a value indicating whether dialog should be validated before leaving.
List | Gets or sets a value indicating whether the list should be visible on the dialog.
Mapper | Gets the mapper.
MaterialSettings | Gets the material settings.
Menu | Gets or sets a value indicating whether menu should be visible on the dialog.
NotAllMappedText | Gets or sets the text which should appear when validation didn't succeed (if CheckIfAllMappedBeforeLeave option).
RebarTypeSettings | Gets the rebar type settings.
SectionSettings | Gets the section settings.
ShowWhenNoElementsToMap | Gets or sets a value indicating whether dialog should appear when there are no elements to map.


REXContentMapDialogSettings Class Public Methods

REXContentMapDialogSettings Class Public Methods
REXContentMapDialogSettings Class Legend
Public Methods
Public Method | Description
REXContentMapDialogSettings | Initializes a new instance of the REXContentMapDialogSettings class.


REXContentMapper Fields

REXContentMapper Fields
REXContentMapper Class Legend
REXContentMapper Fields
REXContentMapper Fields | Description
valRexContext | This is valRexContext, a member of class REXContentMapper.


Legend

Legend
REXContentMapper Class
Legend
Data Member
Method
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXContentMapper Class Members

REXContentMapper Class Members
REXContentMapper Class Legend
Members
REXContentMapper Fields
REXContentMapper Fields | Description
valRexContext | This is valRexContext, a member of class REXContentMapper.
REXContentMapper Methods
REXContentMapper Methods | Description
GetMapElement | Gets the map element for the specified element.
SetMapElement | Sets the map element for specified element.


REXContentMapper Methods

REXContentMapper Methods
REXContentMapper Class Legend
REXContentMapper Methods
REXContentMapper Methods | Description
GetMapElement | Gets the map element for the specified element.
SetMapElement | Sets the map element for specified element.


RVTContentMapper Fields

RVTContentMapper Fields
RVTContentMapper Class Legend
RVTContentMapper Fields
RVTContentMapper Fields | Description
valRvtContext | This is valRvtContext, a member of class RVTContentMapper.


Legend

Legend
RVTContentMapper Class
Legend
Data Member
Method
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


RVTContentMapper Class Members

RVTContentMapper Class Members
RVTContentMapper Class Legend
Members
RVTContentMapper Fields
RVTContentMapper Fields | Description
valRvtContext | This is valRvtContext, a member of class RVTContentMapper.
RVTContentMapper Methods
RVTContentMapper Methods | Description
GetMapElement | Gets the map element for specified Revit element.
SetMapElement | Sets the map element for specified Revit element.


RVTContentMapper Methods

RVTContentMapper Methods
RVTContentMapper Class Legend
RVTContentMapper Methods
RVTContentMapper Methods | Description
GetMapElement | Gets the map element for specified Revit element.
SetMapElement | Sets the map element for specified Revit element.


REX.Controls.Common Namespace Classes

REX.Controls.Common Namespace Classes
REX.Controls.Common Namespace Legend
Classes
Class | Description
REXComboEditControlEngine | Represents the engine for the combobox edit control.
REXEditControlEngine | Represents the engine for edit controls.


REX.Controls.Common Namespace Interfaces

REX.Controls.Common Namespace Interfaces
REX.Controls.Common Namespace Legend
Interfaces
Interface | Description
IComboEditControl | An interface that may be used to attach the custom control to the REXComboEditControlEngine.
IEditControl | An interface that may be used to attach the custom control to the REXEditControlEngine.
IUnitObject | Defines common functionality for controls that are unit dependent.
IUnitObject2 | Defines common functionality for controls that are unit dependent.
IUnitObject3 | Defines common functionality for controls that are unit dependent.


Legend

Legend
REX.Controls.Common Namespace
Legend
Class
Interface
Enumeration
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REX.Controls.Common Namespace Structs, Records, Enums

REX.Controls.Common Namespace Structs, Records, Enums
REX.Controls.Common Namespace Legend
Structs, Records, Enums
Struct, Record, Enum | Description
EComboPropertiesType | An enumerated type listing all modes of the combo.


Legend

Legend
IComboEditControl Interface
Legend
Method
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


IComboEditControl Interface Members

IComboEditControl Interface Members
IComboEditControl Interface Legend
Members
IComboEditControl Methods
IComboEditControl Methods | Description
Editable | Gets a value indicating whether the control is editable.
GetItems | Gets the collection of the items contained in the control.
GetSelectedIndex | Gets the index specifying the currently selected item.
SetSelectedIndex | Sets the index specifying the currently selected item.


IComboEditControl Methods

IComboEditControl Methods
IComboEditControl Interface Legend
IComboEditControl Methods
IComboEditControl Methods | Description
Editable | Gets a value indicating whether the control is editable.
GetItems | Gets the collection of the items contained in the control.
GetSelectedIndex | Gets the index specifying the currently selected item.
SetSelectedIndex | Sets the index specifying the currently selected item.


Legend

Legend
IEditControl Interface
Legend
Method
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


IEditControl Interface Members

IEditControl Interface Members
IEditControl Interface Legend
Members
IEditControl Methods
IEditControl Methods | Description
GetBackground | Gets the background of the control.
GetEnable | Indicates whether the control is enabled.
GetText | Gets the text contents of the control.
SetBackground | Sets the background of the control.
SetText | Sets the text contents of the control.


IEditControl Methods

IEditControl Methods
IEditControl Interface Legend
IEditControl Methods
IEditControl Methods | Description
GetBackground | Gets the background of the control.
GetEnable | Indicates whether the control is enabled.
GetText | Gets the text contents of the control.
SetBackground | Sets the background of the control.
SetText | Sets the text contents of the control.


Legend

Legend
IUnitObject2 Interface
Legend
Method
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


IUnitObject2 Interface Members

IUnitObject2 Interface Members
IUnitObject2 Interface Legend
Members
IUnitObject2 Methods
IUnitObject2 Methods | Description
ValidateComplexValue | Validates the complex (list) value of the double type.
ValidateComplexValue | Validates the complex (list) value of the string type.
ValidateValue | Validates the input value of the double type.
ValidateValue | Validates the value of the string type.


IUnitObject2 Methods

IUnitObject2 Methods
IUnitObject2 Interface Legend
IUnitObject2 Methods
IUnitObject2 Methods | Description
ValidateComplexValue | Validates the complex (list) value of the double type.
ValidateComplexValue | Validates the complex (list) value of the string type.
ValidateValue | Validates the input value of the double type.
ValidateValue | Validates the value of the string type.


Legend

Legend
IUnitObject3 Interface
Legend
Method
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


IUnitObject3 Interface Members

IUnitObject3 Interface Members
IUnitObject3 Interface Legend
Members
IUnitObject3 Methods
IUnitObject3 Methods | Description
RefreshValidationStatus | Refreshes the validation status.
ValueFormat | Returns a text containing an expression formatted according the current settings of the element.
ValueFormat | Returns a text containing an expression formatted according the current settings of the element.
ValueParse | Converts the specified text to the numeric value according the current settings of the element.


IUnitObject3 Methods

IUnitObject3 Methods
IUnitObject3 Interface Legend
IUnitObject3 Methods
IUnitObject3 Methods | Description
RefreshValidationStatus | Refreshes the validation status.
ValueFormat | Returns a text containing an expression formatted according the current settings of the element.
ValueFormat | Returns a text containing an expression formatted according the current settings of the element.
ValueParse | Converts the specified text to the numeric value according the current settings of the element.


Legend

Legend
IUnitObject Interface
Legend
Method
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


IUnitObject Interface Members

IUnitObject Interface Members
IUnitObject Interface Legend
Members
IUnitObject Methods
IUnitObject Methods | Description
AddEnabledChangedHandler | Adds the handler to the event raised when the element changes it's enable state.
AddLostFocusHandler | Adds the handler to the event raised when the element loses logical focus.
AddTextChangedHandler | Adds the handler to the event raised when text changes.
GetComplexDoubleValue | Gets the complex (list) value of the double type.
GetComplexStringValue | Gets the complex (list) string value of the string type.
GetFullName | Gets the full name of the control.
GetState | Gets the current state of the control.
GetUniqueName | Gets the unique name of the control.
GetValue | Gets the value of the double type.
Reset | Resets the instance of the element.
SetComplexValue | Sets the complex (list) value of the double type.
SetComplexValue | Sets the complex (list) value of the string type.
SetExternalUnitBody | This is SetExternalUnitBody, a member of class IUnitObject.
SetUserValidation | Sets the user validation method.
SetUserValidationComplex | Sets the user validation method for complex values (list).
SetValue | Sets the value of the double type.
SetValue | Sets the value of the string type.
IUnitObject Properties
IUnitObject Properties | Description
Complex | Gets or sets a value indicating whether this the control is in the complex mode (list mode).
ControlState | Gets the state of the control.
DataType | Gets or sets the type of the data in the control.
EngineeringFormat | Gets or sets a value indicating whether the text of the control should be formatted in according to the engineering (expotential) format.
RangeMax | Gets or sets the highest possible value.
RangeMaxCheck | Gets or sets a value indicating whether the value should be validated due to the RangeMax.
RangeMin | Gets or sets the minimum possible value.
RangeMinCheck | Gets or sets a value indicating whether the value should be validated due to the RangeMin.
RoundingFractional | Gets or sets the rounding for fractional units.
RoundingIncrement | Gets or sets the rounding increment.
Separator | Gets or sets the decimal separator.
Tag | Gets or sets the tag.
Text | Gets the text contents of the control.
UnitSymbol | Gets or sets the unit symbol.


IUnitObject Methods

IUnitObject Methods
IUnitObject Interface Legend
IUnitObject Methods
IUnitObject Methods | Description
AddEnabledChangedHandler | Adds the handler to the event raised when the element changes it's enable state.
AddLostFocusHandler | Adds the handler to the event raised when the element loses logical focus.
AddTextChangedHandler | Adds the handler to the event raised when text changes.
GetComplexDoubleValue | Gets the complex (list) value of the double type.
GetComplexStringValue | Gets the complex (list) string value of the string type.
GetFullName | Gets the full name of the control.
GetState | Gets the current state of the control.
GetUniqueName | Gets the unique name of the control.
GetValue | Gets the value of the double type.
Reset | Resets the instance of the element.
SetComplexValue | Sets the complex (list) value of the double type.
SetComplexValue | Sets the complex (list) value of the string type.
SetExternalUnitBody | This is SetExternalUnitBody, a member of class IUnitObject.
SetUserValidation | Sets the user validation method.
SetUserValidationComplex | Sets the user validation method for complex values (list).
SetValue | Sets the value of the double type.
SetValue | Sets the value of the string type.


IUnitObject Properties

IUnitObject Properties
IUnitObject Interface Legend
IUnitObject Properties
IUnitObject Properties | Description
Complex | Gets or sets a value indicating whether this the control is in the complex mode (list mode).
ControlState | Gets the state of the control.
DataType | Gets or sets the type of the data in the control.
EngineeringFormat | Gets or sets a value indicating whether the text of the control should be formatted in according to the engineering (expotential) format.
RangeMax | Gets or sets the highest possible value.
RangeMaxCheck | Gets or sets a value indicating whether the value should be validated due to the RangeMax.
RangeMin | Gets or sets the minimum possible value.
RangeMinCheck | Gets or sets a value indicating whether the value should be validated due to the RangeMin.
RoundingFractional | Gets or sets the rounding for fractional units.
RoundingIncrement | Gets or sets the rounding increment.
Separator | Gets or sets the decimal separator.
Tag | Gets or sets the tag.
Text | Gets the text contents of the control.
UnitSymbol | Gets or sets the unit symbol.


Legend

Legend
REXComboEditControlEngine Class
Legend
Constructor
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXComboEditControlEngine Class Members

REXComboEditControlEngine Class Members
REXComboEditControlEngine Class Legend
Members
Public Methods
Public Method | Description
REXComboEditControlEngine | Initializes a new instance of the REXComboEditControlEngine class.
REXComboEditControlEngine Methods
REXComboEditControlEngine Methods | Description
GetPropertiesType | Gets the mode of the combo.
GetValue | Returns a double value of the control.
RefreshItems | Refreshes the internal items list based on the control items list.
RestorePropertiesType | Restores the mode of the combo.
SelectionChanged | Informs about changes in the selection.
SetPropertiesType | Sets the mode of the combo box.
SetValue | Sets the value of the double type.
SetValue | Sets the value of the string type.
TextChanged | Informs about changes in the control's text.
ValidateControl | Validates the current control based on the input values.
ValidateControl | Validates the current control based on the current text or the stored value.
ValidateControl | Validates the current control based on the input value.
ValidateControl | Validates the current control based on the input text.
REXComboEditControlEngine Properties
REXComboEditControlEngine Properties | Description
Items | Gets or sets the collection of the items contained in the control.
ListValidation | Gets or sets a value indicating whether the list should be validated.
SelectedIndex | Gets or sets the index specifying the currently selected item.
TextBoxMode | Gets or sets a value indicating whether the combobox should be in the editbox mode.


REXComboEditControlEngine Methods

REXComboEditControlEngine Methods
REXComboEditControlEngine Class Legend
REXComboEditControlEngine Methods
REXComboEditControlEngine Methods | Description
GetPropertiesType | Gets the mode of the combo.
GetValue | Returns a double value of the control.
RefreshItems | Refreshes the internal items list based on the control items list.
RestorePropertiesType | Restores the mode of the combo.
SelectionChanged | Informs about changes in the selection.
SetPropertiesType | Sets the mode of the combo box.
SetValue | Sets the value of the double type.
SetValue | Sets the value of the string type.
TextChanged | Informs about changes in the control's text.
ValidateControl | Validates the current control based on the input values.
ValidateControl | Validates the current control based on the current text or the stored value.
ValidateControl | Validates the current control based on the input value.
ValidateControl | Validates the current control based on the input text.


REXComboEditControlEngine Properties

REXComboEditControlEngine Properties
REXComboEditControlEngine Class Legend
REXComboEditControlEngine Properties
REXComboEditControlEngine Properties | Description
Items | Gets or sets the collection of the items contained in the control.
ListValidation | Gets or sets a value indicating whether the list should be validated.
SelectedIndex | Gets or sets the index specifying the currently selected item.
TextBoxMode | Gets or sets a value indicating whether the combobox should be in the editbox mode.


REXComboEditControlEngine Class Public Methods

REXComboEditControlEngine Class Public Methods
REXComboEditControlEngine Class Legend
Public Methods
Public Method | Description
REXComboEditControlEngine | Initializes a new instance of the REXComboEditControlEngine class.


REXEditControlEngine Events

REXEditControlEngine Events
REXEditControlEngine Class Legend
REXEditControlEngine Events
REXEditControlEngine Events | Description
EventComplexDoubleValueChanged | Occurs when the complex value changes.
EventDoubleValueChanged | Occurs when the value changes.


Legend

Legend
REXEditControlEngine Class
Legend
Constructor
virtual
static
Property
Event
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXEditControlEngine Class Members

REXEditControlEngine Class Members
REXEditControlEngine Class Legend
Members
Public Methods
Public Method | Description
REXEditControlEngine | Initializes a new instance of the REXEditControlEngine class.
REXEditControlEngine Methods
REXEditControlEngine Methods | Description
AddEnabledChangedHandler | Adds the handler to the event raised when the element changes it's enable state.
AddLostFocusHandler | Adds the handler to the event raised when the element loses logical focus.
AddTextChangedHandler | Adds the handler to the event raised when text changes.
EndEdit | Ends the edit mode.
GetBaseMaxValue | Gets the maximum value and converts it to base units.
GetBaseMinValue | Gets the minimum value and converts it to base units.
GetComplexDataBaseValue | Get the values and convert it to base units.
GetComplexDataInterfaceValue | Get the values and convert it to interface units.
GetComplexDoubleValue | Gets the complex (list) value of the double type.
GetComplexStringValue | Returns a complex string list.
GetControl | Gets the control.
GetDataBaseValue | Gets the value and converts it to base units.
GetDataInterfaceValue | Gets the value and converts it to interface units.
GetFullName | Gets the full name.
GetInterfaceMaxValue | Gets the maximum value and converts it to interface units.
GetInterfaceMinValue | Gets the minimum value and converts it to interface units.
GetLastCorrectValueStr | Gets the last correct stored value.
GetState | Gets the current state of the control.
GetStringValue | Returns the original text.
GetUniqueName | Returns the Unique ID generated for the current instance of the engine.
GetUnitName | Gets the name of the unit from EnumUnits type.
GetValue | Gets the value of the double type.
IsInEditMode | Determines whether control is in the edit mode.
Refresh | Refreshes the text on the control based on the current text.
RefreshValidationStatus | Refreshes the validation status.
Reset | Resets control (internal values).
Restore | Refreshes the text on the control based on the stored value.
RestoreOriginalText | Refreshes the text on the control based on the original text.
SetBaseMaxValue | Set the maximum value defined in base units.
SetBaseMinValue | Set the minimum value defined in base units.
SetComplexDataBaseValue | Set the list of values defined in base units.
SetComplexDataInterfaceValue | Set the list of values defined in interface units.
SetComplexValue | Sets the complex (list) value of the double type.
SetComplexValue | Sets the complex (list) value of the string type.
SetComplexValue | Sets the complex (list) value of the string type.
SetControl | Sets the control for which the current instance is the engine.
SetDataBaseValue | Set the value in base units.
SetDataInterfaceValue | Set the value in interface units.
SetExternalUnitBody | Set external IUnitBody object.
SetInterfaceMaxValue | Set the maximum value defined in interface units.
SetInterfaceMinValue | Set the minimum value defined in interface units.
SetUserTextValidation | Sets the user validation method for the text control.
SetUserValidation | Sets the user validation method.
SetUserValidationComplex | Sets the user validation method for complex values (list).
SetValue | Sets the value of the double type.
SetValue | Sets the value of the string type.
StartEdit | Starts the edit mode.
TextChanged | Informs about changes in the control's text.
ValidateComplexValue | Validates the complex (list) value of the double type.
ValidateComplexValue | Validates the complex (list) value of the string type.
ValidateComplexValue | Validates the complex (list) value of the string type.
ValidateControl | Validates the current control based on the input values.
ValidateControl | Validates the current control based on the input text.
ValidateControl | Validates the current control based on the current text or the stored value.
ValidateControl | Validates the current control based on the input value.
ValidateValue | Validates the input value of the double type.
ValidateValue | Validates the value of the string type.
ValueFormat | Returns a text containing an expression formatted according the current settings of the element.
ValueFormat | Returns a text containing an expression formatted according the current settings of the element.
ValueParse | Converts the specified text to the numeric value according the current settings of the element.
REXEditControlEngine Properties
REXEditControlEngine Properties | Description
Background | Gets or sets the background of the control.
BackgroundDisabledHidden | Gets or sets the background for the disabled state of the control in the hidden background mode.
BackgroundDisabledStandard | Gets or sets the background for the disabled state of the control.
BackgroundError | Gets or sets the background for the Error state of the control.
BackgroundNeutral | Gets or sets the background for the neutral state of the control.
BackgroundOK | Gets or sets the background for the OK state of the control.
Complex | Gets or sets a value indicating whether this REXEditControlEngine supports complex (list) values.
ComplexSeparator | Gets or sets the complex (list) separator.
ComplexSpaceSeparator | Gets or sets a value indicating whether a space should be respected as a list separator.
ComplexUnitOnEnd | Gets or sets a value indicating whether a unit symbol should be placed on the end of the formatted text.
ControlState | Gets the current state of the control.
CorrectValue | Gets or sets the correct value.
DataType | Gets or sets the type of the data in the control.
EngineeringFormat | Gets or sets a value indicating whether the text of the control should be formatted in according to the engineering (expotential) format.
Epsilon | Gets or sets the accuracy.
InvalidCharacters | Gets or sets the list invalid characters (for the control in TEXT mode).
IsEnabled | Gets or sets a value indicating whether this instance is enabled.
MaxTokens | Gets or sets the maximum number of elements in the complex mode (list).
MinTokens | Gets or sets the minimum number of elements in the complex mode (list).
OnDisableAction | Gets or sets a value indicating whether the foreground should be hidden when the control is disabled.
OriginalTextOnEnter | Gets or sets a value indicating whether an original text should be set when the user enters the control.
Power | Gets or sets the power of the unit.
RangeMax | Gets or sets the highest possible value.
RangeMaxCheck | Gets or sets a value indicating whether the value should be validated due to the RangeMax.
RangeMin | Gets or sets the minimum possible value.
RangeMinCheck | Gets or sets a value indicating whether the value should be validated due to the RangeMin.
RememberCorrect | Gets or sets a value indicating whether the correct value should be restored in case of the validation failure.
RoundingFractional | Gets or sets the rounding for fractional units.
RoundingIncrement | Gets or sets the rounding increment (for the DECIMAL DataType).
Separator | Gets or sets the decimal separator.
Tag | Gets or sets the tag.
Text | Gets the text contents of the control.
TokensRangeMaxCheck | Gets or sets a value indicating whether the number of elements should be validated due to the MaxTokens.
TokensRangeMinCheck | Gets or sets a value indicating whether the number of elements should be validated due to the MinTokens.
UnitEngine | Gets or sets the unit engine.
UnitSymbol | Gets or sets the unit symbol.
UnitType | Gets or sets the type of the unit.
REXEditControlEngine Events
REXEditControlEngine Events | Description
EventComplexDoubleValueChanged | Occurs when the complex value changes.
EventDoubleValueChanged | Occurs when the value changes.


Members

Legend
Legend
Constructor
virtual
static
Property
Event
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXEditControlEngine Methods

REXEditControlEngine Methods
REXEditControlEngine Class Legend
REXEditControlEngine Methods
REXEditControlEngine Methods | Description
AddEnabledChangedHandler | Adds the handler to the event raised when the element changes it's enable state.
AddLostFocusHandler | Adds the handler to the event raised when the element loses logical focus.
AddTextChangedHandler | Adds the handler to the event raised when text changes.
EndEdit | Ends the edit mode.
GetBaseMaxValue | Gets the maximum value and converts it to base units.
GetBaseMinValue | Gets the minimum value and converts it to base units.
GetComplexDataBaseValue | Get the values and convert it to base units.
GetComplexDataInterfaceValue | Get the values and convert it to interface units.
GetComplexDoubleValue | Gets the complex (list) value of the double type.
GetComplexStringValue | Returns a complex string list.
GetControl | Gets the control.
GetDataBaseValue | Gets the value and converts it to base units.
GetDataInterfaceValue | Gets the value and converts it to interface units.
GetFullName | Gets the full name.
GetInterfaceMaxValue | Gets the maximum value and converts it to interface units.
GetInterfaceMinValue | Gets the minimum value and converts it to interface units.
GetLastCorrectValueStr | Gets the last correct stored value.
GetState | Gets the current state of the control.
GetStringValue | Returns the original text.
GetUniqueName | Returns the Unique ID generated for the current instance of the engine.
GetUnitName | Gets the name of the unit from EnumUnits type.
GetValue | Gets the value of the double type.
IsInEditMode | Determines whether control is in the edit mode.
Refresh | Refreshes the text on the control based on the current text.
RefreshValidationStatus | Refreshes the validation status.
Reset | Resets control (internal values).
Restore | Refreshes the text on the control based on the stored value.
RestoreOriginalText | Refreshes the text on the control based on the original text.
SetBaseMaxValue | Set the maximum value defined in base units.
SetBaseMinValue | Set the minimum value defined in base units.
SetComplexDataBaseValue | Set the list of values defined in base units.
SetComplexDataInterfaceValue | Set the list of values defined in interface units.
SetComplexValue | Sets the complex (list) value of the double type.
SetComplexValue | Sets the complex (list) value of the string type.
SetComplexValue | Sets the complex (list) value of the string type.
SetControl | Sets the control for which the current instance is the engine.
SetDataBaseValue | Set the value in base units.
SetDataInterfaceValue | Set the value in interface units.
SetExternalUnitBody | Set external IUnitBody object.
SetInterfaceMaxValue | Set the maximum value defined in interface units.
SetInterfaceMinValue | Set the minimum value defined in interface units.
SetUserTextValidation | Sets the user validation method for the text control.
SetUserValidation | Sets the user validation method.
SetUserValidationComplex | Sets the user validation method for complex values (list).
SetValue | Sets the value of the double type.
SetValue | Sets the value of the string type.
StartEdit | Starts the edit mode.
TextChanged | Informs about changes in the control's text.
ValidateComplexValue | Validates the complex (list) value of the double type.
ValidateComplexValue | Validates the complex (list) value of the string type.
ValidateComplexValue | Validates the complex (list) value of the string type.
ValidateControl | Validates the current control based on the input values.
ValidateControl | Validates the current control based on the input text.
ValidateControl | Validates the current control based on the current text or the stored value.
ValidateControl | Validates the current control based on the input value.
ValidateValue | Validates the input value of the double type.
ValidateValue | Validates the value of the string type.
ValueFormat | Returns a text containing an expression formatted according the current settings of the element.
ValueFormat | Returns a text containing an expression formatted according the current settings of the element.
ValueParse | Converts the specified text to the numeric value according the current settings of the element.


Methods (AutoDoc Folder)

Legend
Legend
Method
virtual
static


REXEditControlEngine Properties

REXEditControlEngine Properties
REXEditControlEngine Class Legend
REXEditControlEngine Properties
REXEditControlEngine Properties | Description
Background | Gets or sets the background of the control.
BackgroundDisabledHidden | Gets or sets the background for the disabled state of the control in the hidden background mode.
BackgroundDisabledStandard | Gets or sets the background for the disabled state of the control.
BackgroundError | Gets or sets the background for the Error state of the control.
BackgroundNeutral | Gets or sets the background for the neutral state of the control.
BackgroundOK | Gets or sets the background for the OK state of the control.
Complex | Gets or sets a value indicating whether this REXEditControlEngine supports complex (list) values.
ComplexSeparator | Gets or sets the complex (list) separator.
ComplexSpaceSeparator | Gets or sets a value indicating whether a space should be respected as a list separator.
ComplexUnitOnEnd | Gets or sets a value indicating whether a unit symbol should be placed on the end of the formatted text.
ControlState | Gets the current state of the control.
CorrectValue | Gets or sets the correct value.
DataType | Gets or sets the type of the data in the control.
EngineeringFormat | Gets or sets a value indicating whether the text of the control should be formatted in according to the engineering (expotential) format.
Epsilon | Gets or sets the accuracy.
InvalidCharacters | Gets or sets the list invalid characters (for the control in TEXT mode).
IsEnabled | Gets or sets a value indicating whether this instance is enabled.
MaxTokens | Gets or sets the maximum number of elements in the complex mode (list).
MinTokens | Gets or sets the minimum number of elements in the complex mode (list).
OnDisableAction | Gets or sets a value indicating whether the foreground should be hidden when the control is disabled.
OriginalTextOnEnter | Gets or sets a value indicating whether an original text should be set when the user enters the control.
Power | Gets or sets the power of the unit.
RangeMax | Gets or sets the highest possible value.
RangeMaxCheck | Gets or sets a value indicating whether the value should be validated due to the RangeMax.
RangeMin | Gets or sets the minimum possible value.
RangeMinCheck | Gets or sets a value indicating whether the value should be validated due to the RangeMin.
RememberCorrect | Gets or sets a value indicating whether the correct value should be restored in case of the validation failure.
RoundingFractional | Gets or sets the rounding for fractional units.
RoundingIncrement | Gets or sets the rounding increment (for the DECIMAL DataType).
Separator | Gets or sets the decimal separator.
Tag | Gets or sets the tag.
Text | Gets the text contents of the control.
TokensRangeMaxCheck | Gets or sets a value indicating whether the number of elements should be validated due to the MaxTokens.
TokensRangeMinCheck | Gets or sets a value indicating whether the number of elements should be validated due to the MinTokens.
UnitEngine | Gets or sets the unit engine.
UnitSymbol | Gets or sets the unit symbol.
UnitType | Gets or sets the type of the unit.


REXEditControlEngine Class Public Methods

REXEditControlEngine Class Public Methods
REXEditControlEngine Class Legend
Public Methods
Public Method | Description
REXEditControlEngine | Initializes a new instance of the REXEditControlEngine class.


REX.Controls.Forms Namespace Classes

REX.Controls.Forms Namespace Classes
REX.Controls.Forms Namespace Legend
Classes
Class | Description
REXComboBox | Represents a REX combo box control.
REXEditBox | Represents the REXEditBox control.
REXImageComboBox | Combo box with images.
REXImageComboBoxItem | Represents the combobox item with an image inside.
REXIndexLabel | Represents the REXIndexLabel control.
REXPictureBox | This is class REX.Controls.Forms.REXPictureBox.
REXProgressBar | Represents a REX progress bar control.
REXUnitComboBox | Represents the REXUnitComboBox control with a IREXUnitEngine.
REXUnitEditBox | Represents the REXEditBox control with a IREXUnitEngine.


Legend

Legend
REX.Controls.Forms Namespace
Legend
Class
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


Legend

Legend
REXComboBox Class
Legend
Constructor
virtual
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXComboBox Class Members

REXComboBox Class Members
REXComboBox Class Legend
Members
Public Methods
Public Method | Description
REXComboBox | Initializes a new instance of the REXComboBox class.
REXComboBox Methods
REXComboBox Methods | Description
AddEnabledChangedHandler | Adds the handler to the event raised when the element changes it's enable state.
AddLostFocusHandler | Adds the handler to the event raised when the element loses logical focus.
AddTextChangedHandler | Adds the handler to the event raised when text changes.
Editable | Gets a value indicating whether the control is editable.
GetBackground | Gets the background of the control.
GetComplexDoubleValue | Gets the complex (list) value of the double type.
GetComplexStringValue | Returns a complex string list.
GetEnable | Indicates whether the control is enabled.
GetFullName | Gets the full name.
GetItems | Gets the collection of the items contained in the control.
GetLastCorrectValueStr | Gets the last correct stored value.
GetPropertiesType | Gets the mode of the combo.
GetSelectedIndex | Gets the index specifying the currently selected item.
GetState | Gets the current state of the control.
GetText | Gets the text contents of the control.
GetUniqueName | Returns the Unique ID generated for the current instance of the engine.
GetValue | Gets the value of the double type.
OnTextBoxModeChanged | Called when text box mode changes.
Refresh | Refreshes the text on the control based on the current text.
RefreshValidationStatus | Refreshes the validation status.
Reset | Resets control (internal values).
RestorePropertiesType | Restores the mode of the combo.
SetComplexValue | Sets the complex (list) value of the double type.
SetComplexValue | Sets the complex (list) value of the string type.
SetComplexValue | Sets the complex (list) value of the string type.
SetExternalUnitBody | Sets external IUnitBody object for custom unit processing.
SetPropertiesType | Sets the mode of the combo.
SetSelectedIndex | Sets the index specifying the currently selected item.
SetUserTextValidation | Sets the user validation method for the text control.
SetUserValidation | Sets the user validation method.
SetUserValidationComplex | Sets the user validation method for complex values (list).
SetValue | Sets the value of the double type.
SetValue | Sets the value of the string type.
ValidateComplexValue | Validates the complex (list) value of the double type.
ValidateComplexValue | Validates the complex (list) value of the string type.
ValidateComplexValue | Validates the complex (list) value of the string type.
ValidateValue | Validates the input value of the double type.
ValidateValue | Validates the value of the string type.
ValueFormat | Returns a text containing an expression formatted according the current settings of the element.
ValueFormat | Returns a text containing an expression formatted according the current settings of the element.
ValueParse | Converts the specified text to the numeric value according the current settings of the element.
REXComboBox Properties
REXComboBox Properties | Description
AcceptsTab | AcceptsTab property derived from the TextBox class.
ColorBackgroundDisabled | Gets or sets the background for the disabled state of the control in the hidden background mode.
ColorBackgroundError | Gets or sets the background for the Error state of the control.
ColorBackgroundNeutral | Gets or sets the background for the neutral state of the control.
ColorBackgroundOK | Gets or sets the background for the OK state of the control.
ColorBackgroundStandard | Gets or sets the background for the disabled state of the control.
Complex | Gets or sets a value indicating whether this REXEditControlEngine supports complex (list) values.
ComplexSeparator | Gets or sets the complex (list) separator.
ComplexSpaceSeparator | Gets or sets a value indicating whether a space should be respected as a list separator.
ComplexUnitOnEnd | Gets or sets a value indicating whether a unit symbol should be placed on the end of the formatted text.
ControlState | Gets the current state of the control.
CorrectValue | Gets or sets the correct value.
DataType | Gets or sets the type of the data in the control.
DropDownWidthLimit | Gets or sets the drop down width limit.
EditBox | Gets the reference to the REXEditBox control.
Enabled | Gets or sets a value indicating whether the control can respond to user interaction.
EngineeringFormat | Gets or sets a value indicating whether the text of the control should be formatted in according to the engineering (expotential) format.
Epsilon | Gets or sets the accuracy.
InvalidCharacters | Gets or sets the list invalid characters (for the control in TEXT mode).
ListValidation | Gets or sets a value indicating whether the list should be validated.
MaxTokens | Gets or sets the maximum number of elements in the complex mode (list).
MinTokens | Gets or sets the minimum number of elements in the complex mode (list).
Name | Gets or sets the name of the control.
OnDisableAction | Gets or sets a value indicating whether the foreground should be hidden when the control is disabled.
OriginalTextOnEnter | Gets or sets a value indicating whether an original text should be set when the user enters the control.
RangeMax | Gets or sets the highest possible value.
RangeMaxCheck | Gets or sets a value indicating whether the value should be validated due to the RangeMax.
RangeMin | Gets or sets the minimum possible value.
RangeMinCheck | Gets or sets a value indicating whether the value should be validated due to the RangeMin.
RememberCorrect | Gets or sets a value indicating whether the correct value should be restored in case of the validation failure.
RoundingFractional | Gets or sets the rounding for fractional units.
RoundingIncrement | Gets or sets the rounding increment (for the DECIMAL DataType).
Separator | Gets or sets the decimal separator.
TabIndex | Gets or sets the tab order of the control within its container.
Text | Gets the text contents of the control.
TextAlign | Gets or sets the text alignment.
TextBoxMode | Gets or sets a value indicating whether the combobox is in the editbox mode.
TokensRangeMaxCheck | Gets or sets a value indicating whether the number of elements should be validated due to the MaxTokens.
TokensRangeMinCheck | Gets or sets a value indicating whether the number of elements should be validated due to the MinTokens.
UnitSymbol | Gets or sets the unit symbol.


REXComboBox Methods

REXComboBox Methods
REXComboBox Class Legend
REXComboBox Methods
REXComboBox Methods | Description
AddEnabledChangedHandler | Adds the handler to the event raised when the element changes it's enable state.
AddLostFocusHandler | Adds the handler to the event raised when the element loses logical focus.
AddTextChangedHandler | Adds the handler to the event raised when text changes.
Editable | Gets a value indicating whether the control is editable.
GetBackground | Gets the background of the control.
GetComplexDoubleValue | Gets the complex (list) value of the double type.
GetComplexStringValue | Returns a complex string list.
GetEnable | Indicates whether the control is enabled.
GetFullName | Gets the full name.
GetItems | Gets the collection of the items contained in the control.
GetLastCorrectValueStr | Gets the last correct stored value.
GetPropertiesType | Gets the mode of the combo.
GetSelectedIndex | Gets the index specifying the currently selected item.
GetState | Gets the current state of the control.
GetText | Gets the text contents of the control.
GetUniqueName | Returns the Unique ID generated for the current instance of the engine.
GetValue | Gets the value of the double type.
OnTextBoxModeChanged | Called when text box mode changes.
Refresh | Refreshes the text on the control based on the current text.
RefreshValidationStatus | Refreshes the validation status.
Reset | Resets control (internal values).
RestorePropertiesType | Restores the mode of the combo.
SetComplexValue | Sets the complex (list) value of the double type.
SetComplexValue | Sets the complex (list) value of the string type.
SetComplexValue | Sets the complex (list) value of the string type.
SetExternalUnitBody | Sets external IUnitBody object for custom unit processing.
SetPropertiesType | Sets the mode of the combo.
SetSelectedIndex | Sets the index specifying the currently selected item.
SetUserTextValidation | Sets the user validation method for the text control.
SetUserValidation | Sets the user validation method.
SetUserValidationComplex | Sets the user validation method for complex values (list).
SetValue | Sets the value of the double type.
SetValue | Sets the value of the string type.
ValidateComplexValue | Validates the complex (list) value of the double type.
ValidateComplexValue | Validates the complex (list) value of the string type.
ValidateComplexValue | Validates the complex (list) value of the string type.
ValidateValue | Validates the input value of the double type.
ValidateValue | Validates the value of the string type.
ValueFormat | Returns a text containing an expression formatted according the current settings of the element.
ValueFormat | Returns a text containing an expression formatted according the current settings of the element.
ValueParse | Converts the specified text to the numeric value according the current settings of the element.


REXComboBox Properties

REXComboBox Properties
REXComboBox Class Legend
REXComboBox Properties
REXComboBox Properties | Description
AcceptsTab | AcceptsTab property derived from the TextBox class.
ColorBackgroundDisabled | Gets or sets the background for the disabled state of the control in the hidden background mode.
ColorBackgroundError | Gets or sets the background for the Error state of the control.
ColorBackgroundNeutral | Gets or sets the background for the neutral state of the control.
ColorBackgroundOK | Gets or sets the background for the OK state of the control.
ColorBackgroundStandard | Gets or sets the background for the disabled state of the control.
Complex | Gets or sets a value indicating whether this REXEditControlEngine supports complex (list) values.
ComplexSeparator | Gets or sets the complex (list) separator.
ComplexSpaceSeparator | Gets or sets a value indicating whether a space should be respected as a list separator.
ComplexUnitOnEnd | Gets or sets a value indicating whether a unit symbol should be placed on the end of the formatted text.
ControlState | Gets the current state of the control.
CorrectValue | Gets or sets the correct value.
DataType | Gets or sets the type of the data in the control.
DropDownWidthLimit | Gets or sets the drop down width limit.
EditBox | Gets the reference to the REXEditBox control.
Enabled | Gets or sets a value indicating whether the control can respond to user interaction.
EngineeringFormat | Gets or sets a value indicating whether the text of the control should be formatted in according to the engineering (expotential) format.
Epsilon | Gets or sets the accuracy.
InvalidCharacters | Gets or sets the list invalid characters (for the control in TEXT mode).
ListValidation | Gets or sets a value indicating whether the list should be validated.
MaxTokens | Gets or sets the maximum number of elements in the complex mode (list).
MinTokens | Gets or sets the minimum number of elements in the complex mode (list).
Name | Gets or sets the name of the control.
OnDisableAction | Gets or sets a value indicating whether the foreground should be hidden when the control is disabled.
OriginalTextOnEnter | Gets or sets a value indicating whether an original text should be set when the user enters the control.
RangeMax | Gets or sets the highest possible value.
RangeMaxCheck | Gets or sets a value indicating whether the value should be validated due to the RangeMax.
RangeMin | Gets or sets the minimum possible value.
RangeMinCheck | Gets or sets a value indicating whether the value should be validated due to the RangeMin.
RememberCorrect | Gets or sets a value indicating whether the correct value should be restored in case of the validation failure.
RoundingFractional | Gets or sets the rounding for fractional units.
RoundingIncrement | Gets or sets the rounding increment (for the DECIMAL DataType).
Separator | Gets or sets the decimal separator.
TabIndex | Gets or sets the tab order of the control within its container.
Text | Gets the text contents of the control.
TextAlign | Gets or sets the text alignment.
TextBoxMode | Gets or sets a value indicating whether the combobox is in the editbox mode.
TokensRangeMaxCheck | Gets or sets a value indicating whether the number of elements should be validated due to the MaxTokens.
TokensRangeMinCheck | Gets or sets a value indicating whether the number of elements should be validated due to the MinTokens.
UnitSymbol | Gets or sets the unit symbol.


REXComboBox Class Public Methods

REXComboBox Class Public Methods
REXComboBox Class Legend
Public Methods
Public Method | Description
REXComboBox | Initializes a new instance of the REXComboBox class.


Legend

Legend
REXEditBox Class
Legend
Constructor
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXEditBox Class Members

REXEditBox Class Members
REXEditBox Class Legend
Members
Public Methods
Public Method | Description
REXEditBox | Initializes a new instance of the REXEditBox class.
REXEditBox Methods
REXEditBox Methods | Description
AddEnabledChangedHandler | Adds the handler to the event raised when the element changes it's enable state.
AddLostFocusHandler | Adds the handler to the event raised when the element loses logical focus.
AddTextChangedHandler | Adds the handler to the event raised when text changes.
GetBackground | Gets the background of the control.
GetComplexDoubleValue | Gets the complex (list) value of the double type.
GetComplexStringValue | Returns a complex string list.
GetEnable | Indicates whether the control is enabled.
GetFullName | Gets the full name.
GetLastCorrectValueStr | Gets the last correct stored value.
GetState | Gets the current state of the control.
GetStringValue | Returns the original text.
GetText | Gets the text contents of the control.
GetUniqueName | Returns the Unique ID generated for the current instance of the engine.
GetValue | Gets the value of the double type.
Refresh | Refreshes the text on the control based on the current text.
RefreshValidationStatus | Refreshes the validation status.
Reset | Resets control (internal values).
SetBackground | Sets the background of the control.
SetComplexValue | Sets the complex (list) value of the double type.
SetComplexValue | Sets the complex (list) value of the string type.
SetComplexValue | Sets the complex (list) value of the string type.
SetEnable | Sets the enable state.
SetExternalUnitBody | Sets external IUnitBody object for custom unit processing.
SetText | Sets the text contents of the control.
SetUserTextValidation | Sets the user validation method for the text control.
SetUserValidation | Sets the user validation method.
SetUserValidationComplex | Sets the user validation method for complex values (list).
SetValue | Sets the value of the double type.
SetValue | Sets the value of the string type.
ValidateComplexValue | Validates the complex (list) value of the double type.
ValidateComplexValue | Validates the complex (list) value of the string type.
ValidateComplexValue | Validates the complex (list) value of the string type.
ValidateValue | Validates the input value of the double type.
ValidateValue | Validates the value of the string type.
ValueFormat | Returns a text containing an expression formatted according the current settings of the element.
ValueFormat | Returns a text containing an expression formatted according the current settings of the element.
ValueParse | Converts the specified text to the numeric value according the current settings of the element.
REXEditBox Properties
REXEditBox Properties | Description
AcceptsTab | AcceptsTab property derived from the TextBox class.
ColorBackgroundDisabled | Gets or sets the background for the disabled state of the control in the hidden background mode.
ColorBackgroundError | Gets or sets the background for the Error state of the control.
ColorBackgroundNeutral | Gets or sets the background for the neutral state of the control.
ColorBackgroundOK | Gets or sets the background for the OK state of the control.
ColorBackgroundStandard | Gets or sets the background for the disabled state of the control.
Complex | Gets or sets a value indicating whether this REXEditControlEngine supports complex (list) values.
ComplexSeparator | Gets or sets the complex (list) separator.
ComplexSpaceSeparator | Gets or sets a value indicating whether a space should be respected as a list separator.
ComplexUnitOnEnd | Gets or sets a value indicating whether a unit symbol should be placed on the end of the formatted text.
ControlState | Gets the current state of the control.
CorrectValue | Gets or sets the correct value.
DataType | Gets or sets the type of the data in the control.
Enabled | Gets or sets a value indicating whether the control can respond to user interaction.
EngineeringFormat | Gets or sets a value indicating whether the text of the control should be formatted in according to the engineering (expotential) format.
Epsilon | Gets or sets the accuracy.
InvalidCharacters | Gets or sets the list invalid characters (for the control in TEXT mode).
MaxTokens | Gets or sets the maximum number of elements in the complex mode (list).
MinTokens | Gets or sets the minimum number of elements in the complex mode (list).
Multiline | Gets or sets a value indicating whether this is a multiline T:System.Windows.Forms.TextBox control.
OnDisableAction | Gets or sets a value indicating whether the foreground should be hidden when the control is disabled.
OriginalTextOnEnter | Gets or sets a value indicating whether an original text should be set when the user enters the control.
PasswordChar | Gets or sets the character used to mask characters of a password in a single-line T:System.Windows.Forms.TextBox control.
RangeMax | Gets or sets the highest possible value.
RangeMaxCheck | Gets or sets a value indicating whether the value should be validated due to the RangeMax.
RangeMin | Gets or sets the minimum possible value.
RangeMinCheck | Gets or sets a value indicating whether the value should be validated due to the RangeMin.
RememberCorrect | Gets or sets a value indicating whether the correct value should be restored in case of the validation failure.
RoundingFractional | Gets or sets the rounding for fractional units.
RoundingIncrement | Gets or sets the rounding increment (for the DECIMAL DataType).
Separator | Gets or sets the decimal separator.
Text | Gets the text contents of the control.
TokensRangeMaxCheck | Gets or sets a value indicating whether the number of elements should be validated due to the MaxTokens.
TokensRangeMinCheck | Gets or sets a value indicating whether the number of elements should be validated due to the MinTokens.
UnitSymbol | Gets or sets the unit symbol.
UseSystemPasswordChar | Gets or sets a value indicating whether the text in the T:System.Windows.Forms.TextBox control should appear as the default password character.
WordWrap | Indicates whether a multiline text box control automatically wraps words to the beginning of the next line when necessary.


REXEditBox Methods

REXEditBox Methods
REXEditBox Class Legend
REXEditBox Methods
REXEditBox Methods | Description
AddEnabledChangedHandler | Adds the handler to the event raised when the element changes it's enable state.
AddLostFocusHandler | Adds the handler to the event raised when the element loses logical focus.
AddTextChangedHandler | Adds the handler to the event raised when text changes.
GetBackground | Gets the background of the control.
GetComplexDoubleValue | Gets the complex (list) value of the double type.
GetComplexStringValue | Returns a complex string list.
GetEnable | Indicates whether the control is enabled.
GetFullName | Gets the full name.
GetLastCorrectValueStr | Gets the last correct stored value.
GetState | Gets the current state of the control.
GetStringValue | Returns the original text.
GetText | Gets the text contents of the control.
GetUniqueName | Returns the Unique ID generated for the current instance of the engine.
GetValue | Gets the value of the double type.
Refresh | Refreshes the text on the control based on the current text.
RefreshValidationStatus | Refreshes the validation status.
Reset | Resets control (internal values).
SetBackground | Sets the background of the control.
SetComplexValue | Sets the complex (list) value of the double type.
SetComplexValue | Sets the complex (list) value of the string type.
SetComplexValue | Sets the complex (list) value of the string type.
SetEnable | Sets the enable state.
SetExternalUnitBody | Sets external IUnitBody object for custom unit processing.
SetText | Sets the text contents of the control.
SetUserTextValidation | Sets the user validation method for the text control.
SetUserValidation | Sets the user validation method.
SetUserValidationComplex | Sets the user validation method for complex values (list).
SetValue | Sets the value of the double type.
SetValue | Sets the value of the string type.
ValidateComplexValue | Validates the complex (list) value of the double type.
ValidateComplexValue | Validates the complex (list) value of the string type.
ValidateComplexValue | Validates the complex (list) value of the string type.
ValidateValue | Validates the input value of the double type.
ValidateValue | Validates the value of the string type.
ValueFormat | Returns a text containing an expression formatted according the current settings of the element.
ValueFormat | Returns a text containing an expression formatted according the current settings of the element.
ValueParse | Converts the specified text to the numeric value according the current settings of the element.


REXEditBox Properties

REXEditBox Properties
REXEditBox Class Legend
REXEditBox Properties
REXEditBox Properties | Description
AcceptsTab | AcceptsTab property derived from the TextBox class.
ColorBackgroundDisabled | Gets or sets the background for the disabled state of the control in the hidden background mode.
ColorBackgroundError | Gets or sets the background for the Error state of the control.
ColorBackgroundNeutral | Gets or sets the background for the neutral state of the control.
ColorBackgroundOK | Gets or sets the background for the OK state of the control.
ColorBackgroundStandard | Gets or sets the background for the disabled state of the control.
Complex | Gets or sets a value indicating whether this REXEditControlEngine supports complex (list) values.
ComplexSeparator | Gets or sets the complex (list) separator.
ComplexSpaceSeparator | Gets or sets a value indicating whether a space should be respected as a list separator.
ComplexUnitOnEnd | Gets or sets a value indicating whether a unit symbol should be placed on the end of the formatted text.
ControlState | Gets the current state of the control.
CorrectValue | Gets or sets the correct value.
DataType | Gets or sets the type of the data in the control.
Enabled | Gets or sets a value indicating whether the control can respond to user interaction.
EngineeringFormat | Gets or sets a value indicating whether the text of the control should be formatted in according to the engineering (expotential) format.
Epsilon | Gets or sets the accuracy.
InvalidCharacters | Gets or sets the list invalid characters (for the control in TEXT mode).
MaxTokens | Gets or sets the maximum number of elements in the complex mode (list).
MinTokens | Gets or sets the minimum number of elements in the complex mode (list).
Multiline | Gets or sets a value indicating whether this is a multiline T:System.Windows.Forms.TextBox control.
OnDisableAction | Gets or sets a value indicating whether the foreground should be hidden when the control is disabled.
OriginalTextOnEnter | Gets or sets a value indicating whether an original text should be set when the user enters the control.
PasswordChar | Gets or sets the character used to mask characters of a password in a single-line T:System.Windows.Forms.TextBox control.
RangeMax | Gets or sets the highest possible value.
RangeMaxCheck | Gets or sets a value indicating whether the value should be validated due to the RangeMax.
RangeMin | Gets or sets the minimum possible value.
RangeMinCheck | Gets or sets a value indicating whether the value should be validated due to the RangeMin.
RememberCorrect | Gets or sets a value indicating whether the correct value should be restored in case of the validation failure.
RoundingFractional | Gets or sets the rounding for fractional units.
RoundingIncrement | Gets or sets the rounding increment (for the DECIMAL DataType).
Separator | Gets or sets the decimal separator.
Text | Gets the text contents of the control.
TokensRangeMaxCheck | Gets or sets a value indicating whether the number of elements should be validated due to the MaxTokens.
TokensRangeMinCheck | Gets or sets a value indicating whether the number of elements should be validated due to the MinTokens.
UnitSymbol | Gets or sets the unit symbol.
UseSystemPasswordChar | Gets or sets a value indicating whether the text in the T:System.Windows.Forms.TextBox control should appear as the default password character.
WordWrap | Indicates whether a multiline text box control automatically wraps words to the beginning of the next line when necessary.


REXEditBox Class Public Methods

REXEditBox Class Public Methods
REXEditBox Class Legend
Public Methods
Public Method | Description
REXEditBox | Initializes a new instance of the REXEditBox class.


Legend

Legend
REXImageComboBox Class
Legend
Constructor
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXImageComboBox Class Members

REXImageComboBox Class Members
REXImageComboBox Class Legend
Members
Public Methods
Public Method | Description
REXImageComboBox | Initializes a new instance of the ComboBoxImage class.
REXImageComboBox Properties
REXImageComboBox Properties | Description
ImageList | Get or set the image list.


REXImageComboBox Properties

REXImageComboBox Properties
REXImageComboBox Class Legend
REXImageComboBox Properties
REXImageComboBox Properties | Description
ImageList | Get or set the image list.


REXImageComboBox Class Public Methods

REXImageComboBox Class Public Methods
REXImageComboBox Class Legend
Public Methods
Public Method | Description
REXImageComboBox | Initializes a new instance of the ComboBoxImage class.


Legend

Legend
REXImageComboBoxItem Class
Legend
Constructor
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXImageComboBoxItem Class Members

REXImageComboBoxItem Class Members
REXImageComboBoxItem Class Legend
Members
Public Methods
Public Method | Description
REXImageComboBoxItem | Initializes a new instance of a ImageComboItem class.
REXImageComboBoxItem | Initializes a new instance of a ImageComboItem class.
REXImageComboBoxItem | Initializes a new instance of a ImageComboItem class.
REXImageComboBoxItem | Initializes a new instance of a ImageComboItem class.
REXImageComboBoxItem | Initializes a new instance of a ImageComboItem class.
REXImageComboBoxItem | Initializes a new instance of a ImageComboItem class.
REXImageComboBoxItem | Initializes a new instance of a ImageComboItem class.
REXImageComboBoxItem | Initializes a new instance of a ImageComboItem class.
REXImageComboBoxItem | Initializes a new instance of a ImageComboItem class.
REXImageComboBoxItem | Initializes a new instance of a ImageComboItem class.
REXImageComboBoxItem | Initializes a new instance of a ImageComboItem class.
REXImageComboBoxItem | Initializes a new instance of a ImageComboItem class.
REXImageComboBoxItem | Initializes a new instance of a ImageComboItem class.
REXImageComboBoxItem Methods
REXImageComboBoxItem Methods | Description
ToString | Returns a T:System.String that represents the current T:System.Object.
REXImageComboBoxItem Properties
REXImageComboBoxItem Properties | Description
ForegroundColor | Gets or sets the color of the foreground.
Image | Gets or sets the image.
ImageIndex | Gets or sets the index of the image.
Mark | Gets or sets a value indicating whether this ImageComboItem is a mark.
Tag | Gets or sets the tag.
Text | Gets or sets the text.
Tooltip | Gets or sets the tooltip.
UseTextAsTooltip | Gets or sets a value indicating whether the text should be used as a Tooltip.
VisibleOnList | Gets or sets a value indicating whether item should be visible on the list.


REXImageComboBoxItem Methods

REXImageComboBoxItem Methods
REXImageComboBoxItem Class Legend
REXImageComboBoxItem Methods
REXImageComboBoxItem Methods | Description
ToString | Returns a T:System.String that represents the current T:System.Object.


REXImageComboBoxItem Properties

REXImageComboBoxItem Properties
REXImageComboBoxItem Class Legend
REXImageComboBoxItem Properties
REXImageComboBoxItem Properties | Description
ForegroundColor | Gets or sets the color of the foreground.
Image | Gets or sets the image.
ImageIndex | Gets or sets the index of the image.
Mark | Gets or sets a value indicating whether this ImageComboItem is a mark.
Tag | Gets or sets the tag.
Text | Gets or sets the text.
Tooltip | Gets or sets the tooltip.
UseTextAsTooltip | Gets or sets a value indicating whether the text should be used as a Tooltip.
VisibleOnList | Gets or sets a value indicating whether item should be visible on the list.


REXImageComboBoxItem Class Public Methods

REXImageComboBoxItem Class Public Methods
REXImageComboBoxItem Class Legend
Public Methods
Public Method | Description
REXImageComboBoxItem | Initializes a new instance of a ImageComboItem class.
REXImageComboBoxItem | Initializes a new instance of a ImageComboItem class.
REXImageComboBoxItem | Initializes a new instance of a ImageComboItem class.
REXImageComboBoxItem | Initializes a new instance of a ImageComboItem class.
REXImageComboBoxItem | Initializes a new instance of a ImageComboItem class.
REXImageComboBoxItem | Initializes a new instance of a ImageComboItem class.
REXImageComboBoxItem | Initializes a new instance of a ImageComboItem class.
REXImageComboBoxItem | Initializes a new instance of a ImageComboItem class.
REXImageComboBoxItem | Initializes a new instance of a ImageComboItem class.
REXImageComboBoxItem | Initializes a new instance of a ImageComboItem class.
REXImageComboBoxItem | Initializes a new instance of a ImageComboItem class.
REXImageComboBoxItem | Initializes a new instance of a ImageComboItem class.
REXImageComboBoxItem | Initializes a new instance of a ImageComboItem class.


Legend

Legend
REXIndexLabel Class
Legend
Constructor
static
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXIndexLabel Class Members

REXIndexLabel Class Members
REXIndexLabel Class Legend
Members
Public Methods
Public Method | Description
REXIndexLabel | Initializes a new instance of the REXIndexLabel class.
REXIndexLabel Methods
REXIndexLabel Methods | Description
GetTextSize | Gets the size of the text.
REXIndexLabel Properties
REXIndexLabel Properties | Description
AutoSize | Gets or sets a value indicating whether the control is automatically resized to display its entire contents.
IndexCoeff | Gets or sets the proportion between index and it's parent.
LeftAlign | Gets or sets a value indicating whether the content of the control should be aligned to the left.
Text | Gets the text contents of the control.
TextAlign | Gets or sets the alignment of text in the label.


REXIndexLabel Methods

REXIndexLabel Methods
REXIndexLabel Class Legend
REXIndexLabel Methods
REXIndexLabel Methods | Description
GetTextSize | Gets the size of the text.


REXIndexLabel Properties

REXIndexLabel Properties
REXIndexLabel Class Legend
REXIndexLabel Properties
REXIndexLabel Properties | Description
AutoSize | Gets or sets a value indicating whether the control is automatically resized to display its entire contents.
IndexCoeff | Gets or sets the proportion between index and it's parent.
LeftAlign | Gets or sets a value indicating whether the content of the control should be aligned to the left.
Text | Gets the text contents of the control.
TextAlign | Gets or sets the alignment of text in the label.


REXIndexLabel Class Public Methods

REXIndexLabel Class Public Methods
REXIndexLabel Class Legend
Public Methods
Public Method | Description
REXIndexLabel | Initializes a new instance of the REXIndexLabel class.


Legend

Legend
REXPictureBox Class
Legend
Constructor
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXPictureBox Class Members

REXPictureBox Class Members
REXPictureBox Class Legend
Members
Public Methods
Public Method | Description
REXPictureBox | This is REXPictureBox, a member of class REXPictureBox.


REXPictureBox Class Public Methods

REXPictureBox Class Public Methods
REXPictureBox Class Legend
Public Methods
Public Method | Description
REXPictureBox | This is REXPictureBox, a member of class REXPictureBox.


REXProgressBar Delegates

REXProgressBar Delegates
REXProgressBar Class
REXProgressBar Delegates
REXProgressBar Delegates | Description
MaxChangedHandler | This is nested type REX.Controls.Forms.REXProgressBar.MaxChangedHandler.
MinChangedHandler | This is nested type REX.Controls.Forms.REXProgressBar.MinChangedHandler.
ValueChangedHandler | This is nested type REX.Controls.Forms.REXProgressBar.ValueChangedHandler.


REXProgressBar Events

REXProgressBar Events
REXProgressBar Class Legend
REXProgressBar Events
REXProgressBar Events | Description
MaxChanged | This is MaxChanged, a member of class REXProgressBar.
MinChanged | This is MinChanged, a member of class REXProgressBar.
ValueChanged | This is ValueChanged, a member of class REXProgressBar.


Legend

Legend
REXProgressBar Class
Legend
Constructor
Property
Event
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXProgressBar Class Members

REXProgressBar Class Members
REXProgressBar Class Legend
Members
Public Methods
Public Method | Description
REXProgressBar | Initializes a new instance of the REXProgressBar class.
REXProgressBar Methods
REXProgressBar Methods | Description
StepBack | Takes a step back.
StepForward | Takes a step forward.
REXProgressBar Properties
REXProgressBar Properties | Description
Animate | Gets or sets a value indicating whether animation should be run.
BackgroundColor | Gets or sets the color of the background.
EndColor | Gets or sets the end color.
GlowColor | Gets or sets the color of the glow.
HighlightColor | Gets or sets the color of the highlight.
MaxValue | Gets or sets the maximum value of the range of the control.
MinValue | Gets or sets the minimum value of the range of the control.
StartColor | Gets or sets the start color.
Step | Gets or sets the step.
Value | Gets or sets the current position of the progress bar.
REXProgressBar Delegates
REXProgressBar Delegates | Description
MaxChangedHandler | This is nested type REX.Controls.Forms.REXProgressBar.MaxChangedHandler.
MinChangedHandler | This is nested type REX.Controls.Forms.REXProgressBar.MinChangedHandler.
ValueChangedHandler | This is nested type REX.Controls.Forms.REXProgressBar.ValueChangedHandler.
REXProgressBar Events
REXProgressBar Events | Description
MaxChanged | This is MaxChanged, a member of class REXProgressBar.
MinChanged | This is MinChanged, a member of class REXProgressBar.
ValueChanged | This is ValueChanged, a member of class REXProgressBar.


REXProgressBar Methods

REXProgressBar Methods
REXProgressBar Class Legend
REXProgressBar Methods
REXProgressBar Methods | Description
StepBack | Takes a step back.
StepForward | Takes a step forward.


REXProgressBar Properties

REXProgressBar Properties
REXProgressBar Class Legend
REXProgressBar Properties
REXProgressBar Properties | Description
Animate | Gets or sets a value indicating whether animation should be run.
BackgroundColor | Gets or sets the color of the background.
EndColor | Gets or sets the end color.
GlowColor | Gets or sets the color of the glow.
HighlightColor | Gets or sets the color of the highlight.
MaxValue | Gets or sets the maximum value of the range of the control.
MinValue | Gets or sets the minimum value of the range of the control.
StartColor | Gets or sets the start color.
Step | Gets or sets the step.
Value | Gets or sets the current position of the progress bar.


REXProgressBar Class Public Methods

REXProgressBar Class Public Methods
REXProgressBar Class Legend
Public Methods
Public Method | Description
REXProgressBar | Initializes a new instance of the REXProgressBar class.


Legend

Legend
REXUnitComboBox Class
Legend
Method
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXUnitComboBox Class Members

REXUnitComboBox Class Members
REXUnitComboBox Class Legend
Members
REXUnitComboBox Methods
REXUnitComboBox Methods | Description
GetBaseMaxValue | Gets the maximum value and converts it to base units.
GetBaseMinValue | Gets the minimum value and converts it to base units.
GetComplexDataBaseValue | Get the values and convert it to base units.
GetComplexDataInterfaceValue | Get the values and convert it to interface units.
GetDataBaseValue | Gets the value and converts it to base units.
GetDataInterfaceValue | Gets the value and converts it to interface units.
GetInterfaceMaxValue | Gets the maximum value and converts it to interface units.
GetInterfaceMinValue | Gets the minimum value and converts it to interface units.
SetBaseMaxValue | Set the maximum value defined in base units.
SetBaseMinValue | Set the minimum value defined in base units.
SetComplexDataBaseValue | Set the list of values defined in base units.
SetComplexDataInterfaceValue | Set the list of values defined in interface units.
SetDataBaseValue | Set the value in base units.
SetDataInterfaceValue | Set the value in interface units.
SetInterfaceMaxValue | Set the maximum value defined in interface units.
SetInterfaceMinValue | Set the minimum value defined in interface units.
REXUnitComboBox Properties
REXUnitComboBox Properties | Description
Power | Gets or sets the power of the unit.
UnitEngine | Gets or sets the unit engine.
UnitType | Gets or sets the type of the unit.


REXUnitComboBox Methods

REXUnitComboBox Methods
REXUnitComboBox Class Legend
REXUnitComboBox Methods
REXUnitComboBox Methods | Description
GetBaseMaxValue | Gets the maximum value and converts it to base units.
GetBaseMinValue | Gets the minimum value and converts it to base units.
GetComplexDataBaseValue | Get the values and convert it to base units.
GetComplexDataInterfaceValue | Get the values and convert it to interface units.
GetDataBaseValue | Gets the value and converts it to base units.
GetDataInterfaceValue | Gets the value and converts it to interface units.
GetInterfaceMaxValue | Gets the maximum value and converts it to interface units.
GetInterfaceMinValue | Gets the minimum value and converts it to interface units.
SetBaseMaxValue | Set the maximum value defined in base units.
SetBaseMinValue | Set the minimum value defined in base units.
SetComplexDataBaseValue | Set the list of values defined in base units.
SetComplexDataInterfaceValue | Set the list of values defined in interface units.
SetDataBaseValue | Set the value in base units.
SetDataInterfaceValue | Set the value in interface units.
SetInterfaceMaxValue | Set the maximum value defined in interface units.
SetInterfaceMinValue | Set the minimum value defined in interface units.


REXUnitComboBox Properties

REXUnitComboBox Properties
REXUnitComboBox Class Legend
REXUnitComboBox Properties
REXUnitComboBox Properties | Description
Power | Gets or sets the power of the unit.
UnitEngine | Gets or sets the unit engine.
UnitType | Gets or sets the type of the unit.


Legend

Legend
REXUnitEditBox Class
Legend
Method
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXUnitEditBox Class Members

REXUnitEditBox Class Members
REXUnitEditBox Class Legend
Members
REXUnitEditBox Methods
REXUnitEditBox Methods | Description
GetBaseMaxValue | Gets the maximum value and converts it to base units.
GetBaseMinValue | Gets the minimum value and converts it to base units.
GetComplexDataBaseValue | Get the values and convert it to base units.
GetComplexDataInterfaceValue | Get the values and convert it to interface units.
GetDataBaseValue | Gets the value and converts it to base units.
GetDataInterfaceValue | Gets the value and converts it to interface units.
GetInterfaceMaxValue | Gets the maximum value and converts it to interface units.
GetInterfaceMinValue | Gets the minimum value and converts it to interface units.
SetBaseMaxValue | Set the maximum value defined in base units.
SetBaseMinValue | Set the minimum value defined in base units.
SetComplexDataBaseValue | Set the list of values defined in base units.
SetComplexDataInterfaceValue | Set the list of values defined in interface units.
SetDataBaseValue | Set the value in base units.
SetDataInterfaceValue | Set the value in interface units.
SetInterfaceMaxValue | Set the maximum value defined in interface units.
SetInterfaceMinValue | Set the minimum value defined in interface units.
REXUnitEditBox Properties
REXUnitEditBox Properties | Description
Power | Gets or sets the power of the unit.
UnitEngine | Gets or sets the unit engine.
UnitType | Gets or sets the type of the unit.


REXUnitEditBox Methods

REXUnitEditBox Methods
REXUnitEditBox Class Legend
REXUnitEditBox Methods
REXUnitEditBox Methods | Description
GetBaseMaxValue | Gets the maximum value and converts it to base units.
GetBaseMinValue | Gets the minimum value and converts it to base units.
GetComplexDataBaseValue | Get the values and convert it to base units.
GetComplexDataInterfaceValue | Get the values and convert it to interface units.
GetDataBaseValue | Gets the value and converts it to base units.
GetDataInterfaceValue | Gets the value and converts it to interface units.
GetInterfaceMaxValue | Gets the maximum value and converts it to interface units.
GetInterfaceMinValue | Gets the minimum value and converts it to interface units.
SetBaseMaxValue | Set the maximum value defined in base units.
SetBaseMinValue | Set the minimum value defined in base units.
SetComplexDataBaseValue | Set the list of values defined in base units.
SetComplexDataInterfaceValue | Set the list of values defined in interface units.
SetDataBaseValue | Set the value in base units.
SetDataInterfaceValue | Set the value in interface units.
SetInterfaceMaxValue | Set the maximum value defined in interface units.
SetInterfaceMinValue | Set the minimum value defined in interface units.


REXUnitEditBox Properties

REXUnitEditBox Properties
REXUnitEditBox Class Legend
REXUnitEditBox Properties
REXUnitEditBox Properties | Description
Power | Gets or sets the power of the unit.
UnitEngine | Gets or sets the unit engine.
UnitType | Gets or sets the type of the unit.


REX.Controls.WPF Namespace Classes

REX.Controls.WPF Namespace Classes
REX.Controls.WPF Namespace Legend
Classes
Class | Description
REXComboBox | Represents a REX combo box control.
REXEditBox | Represents the REXEditBox control.
REXImageComboBox | Represents combobox with images.
REXImageComboBoxItem | Represents the combobox item with an image inside.
REXIndexLabel | Represents the REXIndexLabel control.
REXToolbox | Represents the REXToolbox control
REXToolboxCategoriesCollection | Represents collection of categories of the REXToolbox control.
REXToolboxCategory | Represents the REXToolbox category.
REXToolboxCollection | Base classes for REXToolboxs collections.
REXToolboxItem | Represents the REXToolbox item.
REXToolboxItemsCollection | Represents collection of items of the REXToolbox control.
REXToolboxObject | The base class for all toolbox objects (categories and items)
REXUnitComboBox | Represents the REXUnitComboBox control with a built in IREXUnitEngine.
REXUnitEditBox | Represents the REXEditBox control with a built in IREXUnitEngine.
WPFCommon | This is class REX.Controls.WPF.WPFCommon.


Legend

Legend
REX.Controls.WPF Namespace
Legend
Class
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXComboBox Fields

REXComboBox Fields
REXComboBox Class Legend
REXComboBox Fields
REXComboBox Fields | Description
BackgroundDisabledHiddenProperty | This is BackgroundDisabledHiddenProperty, a member of class REXComboBox.
BackgroundDisabledStandardProperty | This is BackgroundDisabledStandardProperty, a member of class REXComboBox.
BackgroundErrorProperty | This is BackgroundErrorProperty, a member of class REXComboBox.
BackgroundNeutralProperty | This is BackgroundNeutralProperty, a member of class REXComboBox.
BackgroundOKProperty | This is BackgroundOKProperty, a member of class REXComboBox.
ComplexDoubleValueProperty | This is ComplexDoubleValueProperty, a member of class REXComboBox.
ComplexProperty | This is ComplexProperty, a member of class REXComboBox.
ComplexSeparatorProperty | This is ComplexSeparatorProperty, a member of class REXComboBox.
ComplexSpaceSeparatorProperty | This is ComplexSpaceSeparatorProperty, a member of class REXComboBox.
ComplexUnitOnEndProperty | This is ComplexUnitOnEndProperty, a member of class REXComboBox.
CorrectValueProperty | This is CorrectValueProperty, a member of class REXComboBox.
DataTypeProperty | This is DataTypeProperty, a member of class REXComboBox.
DoubleValueProperty | This is DoubleValueProperty, a member of class REXComboBox.
EngineeringFormatProperty | This is EngineeringFormatProperty, a member of class REXComboBox.
EpsilonProperty | This is EpsilonProperty, a member of class REXComboBox.
InvalidCharactersProperty | This is InvalidCharactersProperty, a member of class REXComboBox.
ListValidationProperty | This is ListValidationProperty, a member of class REXComboBox.
MaxTokensProperty | This is MaxTokensProperty, a member of class REXComboBox.
MinTokensProperty | This is MinTokensProperty, a member of class REXComboBox.
OnDisableActionProperty | This is OnDisableActionProperty, a member of class REXComboBox.
OriginalTextOnEnterProperty | This is OriginalTextOnEnterProperty, a member of class REXComboBox.
RangeMaxCheckProperty | This is RangeMaxCheckProperty, a member of class REXComboBox.
RangeMaxProperty | This is RangeMaxProperty, a member of class REXComboBox.
RangeMinCheckProperty | This is RangeMinCheckProperty, a member of class REXComboBox.
RangeMinProperty | This is RangeMinProperty, a member of class REXComboBox.
RememberCorrectProperty | This is RememberCorrectProperty, a member of class REXComboBox.
RoundingFractionalProperty | This is RoundingFractionalProperty, a member of class REXComboBox.
RoundingIncrementProperty | This is RoundingIncrementProperty, a member of class REXComboBox.
SeparatorProperty | This is SeparatorProperty, a member of class REXComboBox.
TextBoxModeProperty | This is TextBoxModeProperty, a member of class REXComboBox.
TokensRangeMaxCheckProperty | This is TokensRangeMaxCheckProperty, a member of class REXComboBox.
TokensRangeMinCheckProperty | This is TokensRangeMinCheckProperty, a member of class REXComboBox.
UnitSymbolProperty | This is UnitSymbolProperty, a member of class REXComboBox.


Fields (AutoDoc Folder)

Legend
Legend
Data Member
static
read only


Legend

Legend
REXComboBox Class
Legend
Constructor
Data Member
static
read only
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXComboBox Class Members

REXComboBox Class Members
REXComboBox Class Legend
Members
Public Methods
Public Method | Description
REXComboBox | Initializes a new instance of the REXComboBox class.
REXComboBox Fields
REXComboBox Fields | Description
BackgroundDisabledHiddenProperty | This is BackgroundDisabledHiddenProperty, a member of class REXComboBox.
BackgroundDisabledStandardProperty | This is BackgroundDisabledStandardProperty, a member of class REXComboBox.
BackgroundErrorProperty | This is BackgroundErrorProperty, a member of class REXComboBox.
BackgroundNeutralProperty | This is BackgroundNeutralProperty, a member of class REXComboBox.
BackgroundOKProperty | This is BackgroundOKProperty, a member of class REXComboBox.
ComplexDoubleValueProperty | This is ComplexDoubleValueProperty, a member of class REXComboBox.
ComplexProperty | This is ComplexProperty, a member of class REXComboBox.
ComplexSeparatorProperty | This is ComplexSeparatorProperty, a member of class REXComboBox.
ComplexSpaceSeparatorProperty | This is ComplexSpaceSeparatorProperty, a member of class REXComboBox.
ComplexUnitOnEndProperty | This is ComplexUnitOnEndProperty, a member of class REXComboBox.
CorrectValueProperty | This is CorrectValueProperty, a member of class REXComboBox.
DataTypeProperty | This is DataTypeProperty, a member of class REXComboBox.
DoubleValueProperty | This is DoubleValueProperty, a member of class REXComboBox.
EngineeringFormatProperty | This is EngineeringFormatProperty, a member of class REXComboBox.
EpsilonProperty | This is EpsilonProperty, a member of class REXComboBox.
InvalidCharactersProperty | This is InvalidCharactersProperty, a member of class REXComboBox.
ListValidationProperty | This is ListValidationProperty, a member of class REXComboBox.
MaxTokensProperty | This is MaxTokensProperty, a member of class REXComboBox.
MinTokensProperty | This is MinTokensProperty, a member of class REXComboBox.
OnDisableActionProperty | This is OnDisableActionProperty, a member of class REXComboBox.
OriginalTextOnEnterProperty | This is OriginalTextOnEnterProperty, a member of class REXComboBox.
RangeMaxCheckProperty | This is RangeMaxCheckProperty, a member of class REXComboBox.
RangeMaxProperty | This is RangeMaxProperty, a member of class REXComboBox.
RangeMinCheckProperty | This is RangeMinCheckProperty, a member of class REXComboBox.
RangeMinProperty | This is RangeMinProperty, a member of class REXComboBox.
RememberCorrectProperty | This is RememberCorrectProperty, a member of class REXComboBox.
RoundingFractionalProperty | This is RoundingFractionalProperty, a member of class REXComboBox.
RoundingIncrementProperty | This is RoundingIncrementProperty, a member of class REXComboBox.
SeparatorProperty | This is SeparatorProperty, a member of class REXComboBox.
TextBoxModeProperty | This is TextBoxModeProperty, a member of class REXComboBox.
TokensRangeMaxCheckProperty | This is TokensRangeMaxCheckProperty, a member of class REXComboBox.
TokensRangeMinCheckProperty | This is TokensRangeMinCheckProperty, a member of class REXComboBox.
UnitSymbolProperty | This is UnitSymbolProperty, a member of class REXComboBox.
REXComboBox Methods
REXComboBox Methods | Description
AddEnabledChangedHandler | Adds the handler to the event raised when the element changes it's enable state.
AddLostFocusHandler | Adds the handler to the event raised when the element loses logical focus.
AddTextChangedHandler | Adds the handler to the event raised when text changes.
Editable | Gets a value indicating whether the control is editable.
GetBackground | Gets the background of the control.
GetComplexDoubleValue | Gets the complex (list) value of the double type.
GetComplexStringValue | Returns a complex string list.
GetEnable | Indicates whether the control is enabled.
GetFullName | Gets the full name.
GetItems | Gets the collection of the items contained in the control.
GetLastCorrectValueStr | Gets the last correct stored value.
GetPropertiesType | Gets the mode of the combo.
GetSelectedIndex | Gets the index specifying the currently selected item.
GetState | Gets the current state of the control.
GetText | Gets the text contents of the control.
GetUniqueName | Returns the Unique ID generated for the current instance of the engine.
GetValue | Gets the value of the double type.
Refresh | Refreshes the text on the control based on the current text.
RefreshValidationStatus | Refreshes the validation status.
Reset | Resets control (internal values).
RestorePropertiesType | Restores the mode of the combo.
SetBackground | Sets the background of the control.
SetComplexValue | Sets the complex (list) value of the string type.
SetComplexValue | Sets the complex (list) value of the string type.
SetComplexValue | Set complex value to the control
SetEnable | Sets the enable state.
SetExternalUnitBody | Sets external IUnitBody object for custom unit processing.
SetPropertiesType | Sets the mode of the combo.
SetSelectedIndex | Sets the index specifying the currently selected item.
SetText | Sets the text contents of the control.
SetUserTextValidation | Sets the user validation method for the text control.
SetUserValidation | Sets the user validation method.
SetUserValidationComplex | Sets the user validation method for complex values (list).
SetValue | Sets the value of the double type.
SetValue | Sets the value of the string type.
ValidateComplexValue | Validates the complex (list) value of the double type.
ValidateComplexValue | Validates the complex (list) value of the string type.
ValidateComplexValue | Validates the complex (list) value of the string type.
ValidateValue | Validates the input value of the double type.
ValidateValue | Validates the value of the string type.
ValueFormat | Returns a text containing an expression formatted according the current settings of the element.
ValueFormat | Returns a text containing an expression formatted according the current settings of the element.
ValueParse | Converts the specified text to the numeric value according the current settings of the element.
REXComboBox Properties
REXComboBox Properties | Description
BackgroundDisabledHidden | Gets or sets the background for the disabled state of the control in the hidden background mode.
BackgroundDisabledStandard | Gets or sets the background for the disabled state of the control.
BackgroundError | Gets or sets the background for the Error state of the control.
BackgroundNeutral | Gets or sets the background for the neutral state of the control.
BackgroundOK | Gets or sets the background for the OK state of the control.
Complex | Gets or sets a value indicating whether this REXEditControlEngine supports complex (list) values.
ComplexDoubleValue | Gets or sets the complex double value.
ComplexSeparator | Gets or sets the complex (list) separator.
ComplexSpaceSeparator | Gets or sets a value indicating whether a space should be respected as a list separator.
ComplexUnitOnEnd | Gets or sets a value indicating whether a unit symbol should be placed on the end of the formatted text.
ControlState | Gets the current state of the control.
CorrectValue | Gets or sets the correct value.
DataType | Gets or sets the type of the data in the control.
DoubleValue | Gets or sets the double value.
EngineeringFormat | Gets or sets a value indicating whether the text of the control should be formatted in according to the engineering (expotential) format.
Epsilon | Gets or sets the accuracy.
InvalidCharacters | Gets or sets the list invalid characters (for the control in TEXT mode).
ListValidation | Gets or sets a value indicating whether the list should be validated.
MaxTokens | Gets or sets the maximum number of elements in the complex mode (list).
MinTokens | Gets or sets the minimum number of elements in the complex mode (list).
OnDisableAction | Gets or sets a value indicating whether the foreground should be hidden when the control is disabled.
OriginalTextOnEnter | Gets or sets a value indicating whether an original text should be set when the user enters the control.
RangeMax | Gets or sets the highest possible value.
RangeMaxCheck | Gets or sets a value indicating whether the value should be validated due to the RangeMax.
RangeMin | Gets or sets the minimum possible value.
RangeMinCheck | Gets or sets a value indicating whether the value should be validated due to the RangeMin.
RememberCorrect | Gets or sets a value indicating whether the correct value should be restored in case of the validation failure.
RoundingFractional | Gets or sets the rounding for fractional units.
RoundingIncrement | Gets or sets the rounding increment (for the DECIMAL DataType).
Separator | Gets or sets the decimal separator.
TextBoxMode | Gets or sets a value indicating whether the combobox is in the editbox mode.
TokensRangeMaxCheck | Gets or sets a value indicating whether the number of elements should be validated due to the MaxTokens.
TokensRangeMinCheck | Gets or sets a value indicating whether the number of elements should be validated due to the MinTokens.
UnitSymbol | Gets or sets the unit symbol.


Members

Legend
Legend
Constructor
Data Member
static
read only
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXComboBox Methods

REXComboBox Methods
REXComboBox Class Legend
REXComboBox Methods
REXComboBox Methods | Description
AddEnabledChangedHandler | Adds the handler to the event raised when the element changes it's enable state.
AddLostFocusHandler | Adds the handler to the event raised when the element loses logical focus.
AddTextChangedHandler | Adds the handler to the event raised when text changes.
Editable | Gets a value indicating whether the control is editable.
GetBackground | Gets the background of the control.
GetComplexDoubleValue | Gets the complex (list) value of the double type.
GetComplexStringValue | Returns a complex string list.
GetEnable | Indicates whether the control is enabled.
GetFullName | Gets the full name.
GetItems | Gets the collection of the items contained in the control.
GetLastCorrectValueStr | Gets the last correct stored value.
GetPropertiesType | Gets the mode of the combo.
GetSelectedIndex | Gets the index specifying the currently selected item.
GetState | Gets the current state of the control.
GetText | Gets the text contents of the control.
GetUniqueName | Returns the Unique ID generated for the current instance of the engine.
GetValue | Gets the value of the double type.
Refresh | Refreshes the text on the control based on the current text.
RefreshValidationStatus | Refreshes the validation status.
Reset | Resets control (internal values).
RestorePropertiesType | Restores the mode of the combo.
SetBackground | Sets the background of the control.
SetComplexValue | Sets the complex (list) value of the string type.
SetComplexValue | Sets the complex (list) value of the string type.
SetComplexValue | Set complex value to the control
SetEnable | Sets the enable state.
SetExternalUnitBody | Sets external IUnitBody object for custom unit processing.
SetPropertiesType | Sets the mode of the combo.
SetSelectedIndex | Sets the index specifying the currently selected item.
SetText | Sets the text contents of the control.
SetUserTextValidation | Sets the user validation method for the text control.
SetUserValidation | Sets the user validation method.
SetUserValidationComplex | Sets the user validation method for complex values (list).
SetValue | Sets the value of the double type.
SetValue | Sets the value of the string type.
ValidateComplexValue | Validates the complex (list) value of the double type.
ValidateComplexValue | Validates the complex (list) value of the string type.
ValidateComplexValue | Validates the complex (list) value of the string type.
ValidateValue | Validates the input value of the double type.
ValidateValue | Validates the value of the string type.
ValueFormat | Returns a text containing an expression formatted according the current settings of the element.
ValueFormat | Returns a text containing an expression formatted according the current settings of the element.
ValueParse | Converts the specified text to the numeric value according the current settings of the element.


REXComboBox Properties

REXComboBox Properties
REXComboBox Class Legend
REXComboBox Properties
REXComboBox Properties | Description
BackgroundDisabledHidden | Gets or sets the background for the disabled state of the control in the hidden background mode.
BackgroundDisabledStandard | Gets or sets the background for the disabled state of the control.
BackgroundError | Gets or sets the background for the Error state of the control.
BackgroundNeutral | Gets or sets the background for the neutral state of the control.
BackgroundOK | Gets or sets the background for the OK state of the control.
Complex | Gets or sets a value indicating whether this REXEditControlEngine supports complex (list) values.
ComplexDoubleValue | Gets or sets the complex double value.
ComplexSeparator | Gets or sets the complex (list) separator.
ComplexSpaceSeparator | Gets or sets a value indicating whether a space should be respected as a list separator.
ComplexUnitOnEnd | Gets or sets a value indicating whether a unit symbol should be placed on the end of the formatted text.
ControlState | Gets the current state of the control.
CorrectValue | Gets or sets the correct value.
DataType | Gets or sets the type of the data in the control.
DoubleValue | Gets or sets the double value.
EngineeringFormat | Gets or sets a value indicating whether the text of the control should be formatted in according to the engineering (expotential) format.
Epsilon | Gets or sets the accuracy.
InvalidCharacters | Gets or sets the list invalid characters (for the control in TEXT mode).
ListValidation | Gets or sets a value indicating whether the list should be validated.
MaxTokens | Gets or sets the maximum number of elements in the complex mode (list).
MinTokens | Gets or sets the minimum number of elements in the complex mode (list).
OnDisableAction | Gets or sets a value indicating whether the foreground should be hidden when the control is disabled.
OriginalTextOnEnter | Gets or sets a value indicating whether an original text should be set when the user enters the control.
RangeMax | Gets or sets the highest possible value.
RangeMaxCheck | Gets or sets a value indicating whether the value should be validated due to the RangeMax.
RangeMin | Gets or sets the minimum possible value.
RangeMinCheck | Gets or sets a value indicating whether the value should be validated due to the RangeMin.
RememberCorrect | Gets or sets a value indicating whether the correct value should be restored in case of the validation failure.
RoundingFractional | Gets or sets the rounding for fractional units.
RoundingIncrement | Gets or sets the rounding increment (for the DECIMAL DataType).
Separator | Gets or sets the decimal separator.
TextBoxMode | Gets or sets a value indicating whether the combobox is in the editbox mode.
TokensRangeMaxCheck | Gets or sets a value indicating whether the number of elements should be validated due to the MaxTokens.
TokensRangeMinCheck | Gets or sets a value indicating whether the number of elements should be validated due to the MinTokens.
UnitSymbol | Gets or sets the unit symbol.


REXEditBox Fields

REXEditBox Fields
REXEditBox Class Legend
REXEditBox Fields
REXEditBox Fields | Description
BackgroundDisabledHiddenProperty | This is BackgroundDisabledHiddenProperty, a member of class REXEditBox.
BackgroundDisabledStandardProperty | This is BackgroundDisabledStandardProperty, a member of class REXEditBox.
BackgroundErrorProperty | This is BackgroundErrorProperty, a member of class REXEditBox.
BackgroundNeutralProperty | This is BackgroundNeutralProperty, a member of class REXEditBox.
BackgroundOKProperty | This is BackgroundOKProperty, a member of class REXEditBox.
ComplexDoubleValueProperty | This is ComplexDoubleValueProperty, a member of class REXEditBox.
ComplexProperty | This is ComplexProperty, a member of class REXEditBox.
ComplexSeparatorProperty | This is ComplexSeparatorProperty, a member of class REXEditBox.
ComplexSpaceSeparatorProperty | This is ComplexSpaceSeparatorProperty, a member of class REXEditBox.
ComplexUnitOnEndProperty | This is ComplexUnitOnEndProperty, a member of class REXEditBox.
CorrectValueProperty | This is CorrectValueProperty, a member of class REXEditBox.
DataTypeProperty | This is DataTypeProperty, a member of class REXEditBox.
DoubleValueProperty | This is DoubleValueProperty, a member of class REXEditBox.
EngineeringFormatProperty | This is EngineeringFormatProperty, a member of class REXEditBox.
EpsilonProperty | This is EpsilonProperty, a member of class REXEditBox.
InvalidCharactersProperty | This is InvalidCharactersProperty, a member of class REXEditBox.
MaxTokensProperty | This is MaxTokensProperty, a member of class REXEditBox.
MinTokensProperty | This is MinTokensProperty, a member of class REXEditBox.
OnDisableActionProperty | This is OnDisableActionProperty, a member of class REXEditBox.
OriginalTextOnEnterProperty | This is OriginalTextOnEnterProperty, a member of class REXEditBox.
RangeMaxCheckProperty | This is RangeMaxCheckProperty, a member of class REXEditBox.
RangeMaxProperty | This is RangeMaxProperty, a member of class REXEditBox.
RangeMinCheckProperty | This is RangeMinCheckProperty, a member of class REXEditBox.
RangeMinProperty | This is RangeMinProperty, a member of class REXEditBox.
RememberCorrectProperty | This is RememberCorrectProperty, a member of class REXEditBox.
RoundingFractionalProperty | This is RoundingFractionalProperty, a member of class REXEditBox.
RoundingIncrementProperty | This is RoundingIncrementProperty, a member of class REXEditBox.
SeparatorProperty | This is SeparatorProperty, a member of class REXEditBox.
TokensRangeMaxCheckProperty | This is TokensRangeMaxCheckProperty, a member of class REXEditBox.
TokensRangeMinCheckProperty | This is TokensRangeMinCheckProperty, a member of class REXEditBox.
UnitSymbolProperty | This is UnitSymbolProperty, a member of class REXEditBox.


Legend

Legend
REXEditBox Class
Legend
Data Member
static
read only
Method
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXEditBox Class Members

REXEditBox Class Members
REXEditBox Class Legend
Members
REXEditBox Fields
REXEditBox Fields | Description
BackgroundDisabledHiddenProperty | This is BackgroundDisabledHiddenProperty, a member of class REXEditBox.
BackgroundDisabledStandardProperty | This is BackgroundDisabledStandardProperty, a member of class REXEditBox.
BackgroundErrorProperty | This is BackgroundErrorProperty, a member of class REXEditBox.
BackgroundNeutralProperty | This is BackgroundNeutralProperty, a member of class REXEditBox.
BackgroundOKProperty | This is BackgroundOKProperty, a member of class REXEditBox.
ComplexDoubleValueProperty | This is ComplexDoubleValueProperty, a member of class REXEditBox.
ComplexProperty | This is ComplexProperty, a member of class REXEditBox.
ComplexSeparatorProperty | This is ComplexSeparatorProperty, a member of class REXEditBox.
ComplexSpaceSeparatorProperty | This is ComplexSpaceSeparatorProperty, a member of class REXEditBox.
ComplexUnitOnEndProperty | This is ComplexUnitOnEndProperty, a member of class REXEditBox.
CorrectValueProperty | This is CorrectValueProperty, a member of class REXEditBox.
DataTypeProperty | This is DataTypeProperty, a member of class REXEditBox.
DoubleValueProperty | This is DoubleValueProperty, a member of class REXEditBox.
EngineeringFormatProperty | This is EngineeringFormatProperty, a member of class REXEditBox.
EpsilonProperty | This is EpsilonProperty, a member of class REXEditBox.
InvalidCharactersProperty | This is InvalidCharactersProperty, a member of class REXEditBox.
MaxTokensProperty | This is MaxTokensProperty, a member of class REXEditBox.
MinTokensProperty | This is MinTokensProperty, a member of class REXEditBox.
OnDisableActionProperty | This is OnDisableActionProperty, a member of class REXEditBox.
OriginalTextOnEnterProperty | This is OriginalTextOnEnterProperty, a member of class REXEditBox.
RangeMaxCheckProperty | This is RangeMaxCheckProperty, a member of class REXEditBox.
RangeMaxProperty | This is RangeMaxProperty, a member of class REXEditBox.
RangeMinCheckProperty | This is RangeMinCheckProperty, a member of class REXEditBox.
RangeMinProperty | This is RangeMinProperty, a member of class REXEditBox.
RememberCorrectProperty | This is RememberCorrectProperty, a member of class REXEditBox.
RoundingFractionalProperty | This is RoundingFractionalProperty, a member of class REXEditBox.
RoundingIncrementProperty | This is RoundingIncrementProperty, a member of class REXEditBox.
SeparatorProperty | This is SeparatorProperty, a member of class REXEditBox.
TokensRangeMaxCheckProperty | This is TokensRangeMaxCheckProperty, a member of class REXEditBox.
TokensRangeMinCheckProperty | This is TokensRangeMinCheckProperty, a member of class REXEditBox.
UnitSymbolProperty | This is UnitSymbolProperty, a member of class REXEditBox.
REXEditBox Methods
REXEditBox Methods | Description
AddEnabledChangedHandler | Adds the handler to the event raised when the element changes it's enable state.
AddLostFocusHandler | Adds the handler to the event raised when the element loses logical focus.
AddTextChangedHandler | Adds the handler to the event raised when text changes.
GetBackground | Gets the background of the control.
GetComplexDoubleValue | Gets the complex (list) value of the double type.
GetComplexStringValue | Returns a complex string list.
GetEnable | Indicates whether the control is enabled.
GetFullName | Gets the full name.
GetLastCorrectValueStr | Gets the last correct stored value.
GetState | Gets the current state of the control.
GetStringValue | Returns the original text.
GetText | Gets the text contents of the control.
GetUniqueName | Returns the Unique ID generated for the current instance of the engine.
GetValue | Gets the value of the double type.
Refresh | Refreshes the text on the control based on the current text.
RefreshValidationStatus | Refreshes the validation status.
Reset | Resets control (internal values).
SetBackground | Sets the background of the control.
SetComplexValue | Sets the complex (list) value of the double type.
SetComplexValue | Sets the complex (list) value of the string type.
SetComplexValue | Sets the complex (list) value of the string type.
SetEnable | Sets the enable state.
SetExternalUnitBody | Sets external IUnitBody object for custom unit processing.
SetText | Sets the text contents of the control.
SetUserTextValidation | Sets the user validation method for the text control.
SetUserValidation | Sets the user validation method.
SetUserValidationComplex | Sets the user validation method for complex values (list).
SetValue | Sets the value of the double type.
SetValue | Sets the value of the string type.
ValidateComplexValue | Validates the complex (list) value of the double type.
ValidateComplexValue | Validates the complex (list) value of the string type.
ValidateComplexValue | Validates the complex (list) value of the string type.
ValidateValue | Validates the input value of the double type.
ValidateValue | Validates the value of the string type.
ValueFormat | Returns a text containing an expression formatted according the current settings of the element.
ValueFormat | Returns a text containing an expression formatted according the current settings of the element.
ValueParse | Converts the specified text to the numeric value according the current settings of the element.
REXEditBox Properties
REXEditBox Properties | Description
BackgroundDisabledHidden | Gets or sets the background for the disabled state of the control in the hidden background mode.
BackgroundDisabledStandard | Gets or sets the background for the standard disabled status.
BackgroundError | Gets or sets the background for the Error state of the control.
BackgroundNeutral | Gets or sets the background for the neutral state of the control.
BackgroundOK | Gets or sets the background for the OK state of the control.
Complex | Gets or sets a value indicating whether this REXEditControlEngine supports complex (list) values.
ComplexDoubleValue | Gets or sets the complex double value.
ComplexSeparator | Gets or sets the complex (list) separator.
ComplexSpaceSeparator | Gets or sets a value indicating whether a space should be respected as a list separator.
ComplexUnitOnEnd | Gets or sets a value indicating whether a unit symbol should be placed on the end of the formatted text.
ControlState | Gets the current state of the control.
CorrectValue | Gets or sets the correct value.
DataType | Gets or sets the type of the data in the control.
DoubleValue | Gets or sets the double value.
EngineeringFormat | Gets or sets a value indicating whether the text of the control should be formatted in according to the engineering (expotential) format.
Epsilon | Gets or sets the accuracy.
InvalidCharacters | Gets or sets the list invalid characters (for the control in TEXT mode).
MaxTokens | Gets or sets the maximum number of elements in the complex mode (list).
MinTokens | Gets or sets the minimum number of elements in the complex mode (list).
OnDisableAction | Gets or sets a value indicating whether the foreground should be hidden when the control is disabled.
OriginalTextOnEnter | Gets or sets a value indicating whether an original text should be set when the user enters the control.
RangeMax | Gets or sets the highest possible value.
RangeMaxCheck | Gets or sets a value indicating whether the value should be validated due to the RangeMax.
RangeMin | Gets or sets the minimum possible value.
RangeMinCheck | Gets or sets a value indicating whether the value should be validated due to the RangeMin.
RememberCorrect | Gets or sets a value indicating whether the correct value should be restored in case of the validation failure.
RoundingFractional | Gets or sets the rounding for fractional units.
RoundingIncrement | Gets or sets the rounding increment (for the DECIMAL DataType).
Separator | Gets or sets the decimal separator.
TokensRangeMaxCheck | Gets or sets a value indicating whether the number of elements should be validated due to the MaxTokens.
TokensRangeMinCheck | Gets or sets a value indicating whether the number of elements should be validated due to the MinTokens.
UnitSymbol | Gets or sets the unit symbol.


Members

Legend
Legend
Data Member
static
read only
Method
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXEditBox Properties

REXEditBox Properties
REXEditBox Class Legend
REXEditBox Properties
REXEditBox Properties | Description
BackgroundDisabledHidden | Gets or sets the background for the disabled state of the control in the hidden background mode.
BackgroundDisabledStandard | Gets or sets the background for the standard disabled status.
BackgroundError | Gets or sets the background for the Error state of the control.
BackgroundNeutral | Gets or sets the background for the neutral state of the control.
BackgroundOK | Gets or sets the background for the OK state of the control.
Complex | Gets or sets a value indicating whether this REXEditControlEngine supports complex (list) values.
ComplexDoubleValue | Gets or sets the complex double value.
ComplexSeparator | Gets or sets the complex (list) separator.
ComplexSpaceSeparator | Gets or sets a value indicating whether a space should be respected as a list separator.
ComplexUnitOnEnd | Gets or sets a value indicating whether a unit symbol should be placed on the end of the formatted text.
ControlState | Gets the current state of the control.
CorrectValue | Gets or sets the correct value.
DataType | Gets or sets the type of the data in the control.
DoubleValue | Gets or sets the double value.
EngineeringFormat | Gets or sets a value indicating whether the text of the control should be formatted in according to the engineering (expotential) format.
Epsilon | Gets or sets the accuracy.
InvalidCharacters | Gets or sets the list invalid characters (for the control in TEXT mode).
MaxTokens | Gets or sets the maximum number of elements in the complex mode (list).
MinTokens | Gets or sets the minimum number of elements in the complex mode (list).
OnDisableAction | Gets or sets a value indicating whether the foreground should be hidden when the control is disabled.
OriginalTextOnEnter | Gets or sets a value indicating whether an original text should be set when the user enters the control.
RangeMax | Gets or sets the highest possible value.
RangeMaxCheck | Gets or sets a value indicating whether the value should be validated due to the RangeMax.
RangeMin | Gets or sets the minimum possible value.
RangeMinCheck | Gets or sets a value indicating whether the value should be validated due to the RangeMin.
RememberCorrect | Gets or sets a value indicating whether the correct value should be restored in case of the validation failure.
RoundingFractional | Gets or sets the rounding for fractional units.
RoundingIncrement | Gets or sets the rounding increment (for the DECIMAL DataType).
Separator | Gets or sets the decimal separator.
TokensRangeMaxCheck | Gets or sets a value indicating whether the number of elements should be validated due to the MaxTokens.
TokensRangeMinCheck | Gets or sets a value indicating whether the number of elements should be validated due to the MinTokens.
UnitSymbol | Gets or sets the unit symbol.


REXImageComboBoxItem Fields

REXImageComboBoxItem Fields
REXImageComboBoxItem Class Legend
REXImageComboBoxItem Fields
REXImageComboBoxItem Fields | Description
FitToParentHeightProperty | This is FitToParentHeightProperty, a member of class REXImageComboBoxItem.
ImageProperty | This is ImageProperty, a member of class REXImageComboBoxItem.
TextProperty | This is TextProperty, a member of class REXImageComboBoxItem.
VisibleOnListProperty | This is VisibleOnListProperty, a member of class REXImageComboBoxItem.


Legend

Legend
REXImageComboBoxItem Class
Legend
Data Member
static
read only
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXImageComboBoxItem Class Members

REXImageComboBoxItem Class Members
REXImageComboBoxItem Class Legend
Members
REXImageComboBoxItem Fields
REXImageComboBoxItem Fields | Description
FitToParentHeightProperty | This is FitToParentHeightProperty, a member of class REXImageComboBoxItem.
ImageProperty | This is ImageProperty, a member of class REXImageComboBoxItem.
TextProperty | This is TextProperty, a member of class REXImageComboBoxItem.
VisibleOnListProperty | This is VisibleOnListProperty, a member of class REXImageComboBoxItem.
REXImageComboBoxItem Properties
REXImageComboBoxItem Properties | Description
FitToParentHeight | Gets or sets a value indicating whether item height should be fit to the combobox's height.
Image | Gets or sets the image.
Text | Gets or sets the text.
VisibleOnList | Gets or sets a value indicating whether item should be visible on the list.


Members

Legend
Legend
Data Member
static
read only
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXImageComboBoxItem Properties

REXImageComboBoxItem Properties
REXImageComboBoxItem Class Legend
REXImageComboBoxItem Properties
REXImageComboBoxItem Properties | Description
FitToParentHeight | Gets or sets a value indicating whether item height should be fit to the combobox's height.
Image | Gets or sets the image.
Text | Gets or sets the text.
VisibleOnList | Gets or sets a value indicating whether item should be visible on the list.


REXIndexLabel Fields

REXIndexLabel Fields
REXIndexLabel Class Legend
REXIndexLabel Fields
REXIndexLabel Fields | Description
IndexCoeffProperty | This is IndexCoeffProperty, a member of class REXIndexLabel.
LeftAlignProperty | This is LeftAlignProperty, a member of class REXIndexLabel.
TextProperty | This is TextProperty, a member of class REXIndexLabel.


Legend

Legend
REXIndexLabel Class
Legend
Constructor
Data Member
static
read only
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXIndexLabel Class Members

REXIndexLabel Class Members
REXIndexLabel Class Legend
Members
Public Methods
Public Method | Description
REXIndexLabel | Initializes a new instance of the REXIndexLabel class.
REXIndexLabel Fields
REXIndexLabel Fields | Description
IndexCoeffProperty | This is IndexCoeffProperty, a member of class REXIndexLabel.
LeftAlignProperty | This is LeftAlignProperty, a member of class REXIndexLabel.
TextProperty | This is TextProperty, a member of class REXIndexLabel.
REXIndexLabel Methods
REXIndexLabel Methods | Description
GetTextSize | Gets the size of the text.
REXIndexLabel Properties
REXIndexLabel Properties | Description
IndexCoeff | Gets or sets the proportion between index and it's parent.
LeftAlign | Gets or sets a value indicating whether the content of the control should be aligned to the left.
Text | Gets or sets the current text in the REXIndexLabel.


REXIndexLabel Properties

REXIndexLabel Properties
REXIndexLabel Class Legend
REXIndexLabel Properties
REXIndexLabel Properties | Description
IndexCoeff | Gets or sets the proportion between index and it's parent.
LeftAlign | Gets or sets a value indicating whether the content of the control should be aligned to the left.
Text | Gets or sets the current text in the REXIndexLabel.


REXToolbox Delegates

REXToolbox Delegates
REXToolbox Class
REXToolbox Delegates
REXToolbox Delegates | Description
EventSelectedItemChanged | This is nested type REX.Controls.WPF.REXToolbox.EventSelectedItemChanged.


REXToolbox Events

REXToolbox Events
REXToolbox Class Legend
REXToolbox Events
REXToolbox Events | Description
SelectedItemChanged | Occurs when the selected item changed.


REXToolbox Fields

REXToolbox Fields
REXToolbox Class Legend
REXToolbox Fields
REXToolbox Fields | Description
ApplyGradientsProperty | This is ApplyGradientsProperty, a member of class REXToolbox.
BorderBrushProperty | This is BorderBrushProperty, a member of class REXToolbox.
BorderThicknessProperty | This is BorderThicknessProperty, a member of class REXToolbox.
CategoryFontFamilyProperty | This is CategoryFontFamilyProperty, a member of class REXToolbox.
CategoryFontSizeProperty | This is CategoryFontSizeProperty, a member of class REXToolbox.
CategoryFontWeightProperty | This is CategoryFontWeightProperty, a member of class REXToolbox.
CategoryHeightProperty | This is CategoryHeightProperty, a member of class REXToolbox.
CategorySplitterProperty | This is CategorySplitterProperty, a member of class REXToolbox.
ItemBorderBrushProperty | This is ItemBorderBrushProperty, a member of class REXToolbox.
ItemBorderThicknessProperty | This is ItemBorderThicknessProperty, a member of class REXToolbox.
ItemFontFamilyProperty | This is ItemFontFamilyProperty, a member of class REXToolbox.
ItemFontSizeProperty | This is ItemFontSizeProperty, a member of class REXToolbox.
ItemFontWeightProperty | This is ItemFontWeightProperty, a member of class REXToolbox.
ItemHeightProperty | This is ItemHeightProperty, a member of class REXToolbox.
ItemHoverColorProperty | This is ItemHoverColorProperty, a member of class REXToolbox.
ItemSelectColorProperty | This is ItemSelectColorProperty, a member of class REXToolbox.


Legend

Legend
REXToolbox Class
Legend
Constructor
Data Member
static
read only
Property
Event
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXToolbox Class Members

REXToolbox Class Members
REXToolbox Class Legend
Members
Public Methods
Public Method | Description
REXToolbox | Initializes a new instance of the REXToolbox class.
REXToolbox Fields
REXToolbox Fields | Description
ApplyGradientsProperty | This is ApplyGradientsProperty, a member of class REXToolbox.
BorderBrushProperty | This is BorderBrushProperty, a member of class REXToolbox.
BorderThicknessProperty | This is BorderThicknessProperty, a member of class REXToolbox.
CategoryFontFamilyProperty | This is CategoryFontFamilyProperty, a member of class REXToolbox.
CategoryFontSizeProperty | This is CategoryFontSizeProperty, a member of class REXToolbox.
CategoryFontWeightProperty | This is CategoryFontWeightProperty, a member of class REXToolbox.
CategoryHeightProperty | This is CategoryHeightProperty, a member of class REXToolbox.
CategorySplitterProperty | This is CategorySplitterProperty, a member of class REXToolbox.
ItemBorderBrushProperty | This is ItemBorderBrushProperty, a member of class REXToolbox.
ItemBorderThicknessProperty | This is ItemBorderThicknessProperty, a member of class REXToolbox.
ItemFontFamilyProperty | This is ItemFontFamilyProperty, a member of class REXToolbox.
ItemFontSizeProperty | This is ItemFontSizeProperty, a member of class REXToolbox.
ItemFontWeightProperty | This is ItemFontWeightProperty, a member of class REXToolbox.
ItemHeightProperty | This is ItemHeightProperty, a member of class REXToolbox.
ItemHoverColorProperty | This is ItemHoverColorProperty, a member of class REXToolbox.
ItemSelectColorProperty | This is ItemSelectColorProperty, a member of class REXToolbox.
REXToolbox Methods
REXToolbox Methods | Description
Refresh | Refreshes this instance.
REXToolbox Properties
REXToolbox Properties | Description
ApplyGradients | Gets or sets a value indicating whether gradients should be applied.
BorderBrush | Gets or sets the border brush.
BorderThickness | Gets or sets the thickness of the border.
Categories | Gets the categories.
CategoryFontFamily | Gets or sets the font family of the category.
CategoryFontSize | Gets or sets the size of the category font.
CategoryFontWeight | Gets or sets the font weight of the category.
CategoryHeight | Gets or sets the height of the category.
CategorySplitter | Gets or sets the color of the category splitter.
ItemBorderBrush | Gets or sets the brush of the item's border.
ItemBorderThickness | Gets or sets the thickness of the item's border.
ItemFontFamily | Gets or sets the font family of the item.
ItemFontSize | Gets or sets the font size of the item.
ItemFontWeight | Gets or sets the font weight of the item.
ItemHeight | Gets or sets the height of the item.
ItemHoverColor | Gets or sets the background color of the item when the mouse pointer is over it.
Items | Gets the items.
ItemSelectColor | Gets or sets the background color of the selected item.
SelectedItem | Gets or sets the selected item.
SelectedItemName | Gets or sets the name of the selected item.
REXToolbox Delegates
REXToolbox Delegates | Description
EventSelectedItemChanged | This is nested type REX.Controls.WPF.REXToolbox.EventSelectedItemChanged.
REXToolbox Events
REXToolbox Events | Description
SelectedItemChanged | Occurs when the selected item changed.


Members

Legend
Legend
Constructor
Data Member
static
read only
Property
Event
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXToolbox Methods

REXToolbox Methods
REXToolbox Class Legend
REXToolbox Methods
REXToolbox Methods | Description
Refresh | Refreshes this instance.


REXToolbox Properties

REXToolbox Properties
REXToolbox Class Legend
REXToolbox Properties
REXToolbox Properties | Description
ApplyGradients | Gets or sets a value indicating whether gradients should be applied.
BorderBrush | Gets or sets the border brush.
BorderThickness | Gets or sets the thickness of the border.
Categories | Gets the categories.
CategoryFontFamily | Gets or sets the font family of the category.
CategoryFontSize | Gets or sets the size of the category font.
CategoryFontWeight | Gets or sets the font weight of the category.
CategoryHeight | Gets or sets the height of the category.
CategorySplitter | Gets or sets the color of the category splitter.
ItemBorderBrush | Gets or sets the brush of the item's border.
ItemBorderThickness | Gets or sets the thickness of the item's border.
ItemFontFamily | Gets or sets the font family of the item.
ItemFontSize | Gets or sets the font size of the item.
ItemFontWeight | Gets or sets the font weight of the item.
ItemHeight | Gets or sets the height of the item.
ItemHoverColor | Gets or sets the background color of the item when the mouse pointer is over it.
Items | Gets the items.
ItemSelectColor | Gets or sets the background color of the selected item.
SelectedItem | Gets or sets the selected item.
SelectedItemName | Gets or sets the name of the selected item.


REXToolbox Class Public Methods

REXToolbox Class Public Methods
REXToolbox Class Legend
Public Methods
Public Method | Description
REXToolbox | Initializes a new instance of the REXToolbox class.


Legend

Legend
REXToolboxCategoriesCollection Class
Legend
Constructor
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXToolboxCategoriesCollection Class Members

REXToolboxCategoriesCollection Class Members
REXToolboxCategoriesCollection Class Legend
Members
Public Methods
Public Method | Description
REXToolboxCategoriesCollection | Initializes a new instance of the REXToolboxCategoriesCollection class.


REXToolboxCategoriesCollection Class Public Methods

REXToolboxCategoriesCollection Class Public Methods
REXToolboxCategoriesCollection Class Legend
Public Methods
Public Method | Description
REXToolboxCategoriesCollection | Initializes a new instance of the REXToolboxCategoriesCollection class.


Legend

Legend
REXToolboxCategory Class
Legend
Constructor
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXToolboxCategory Class Members

REXToolboxCategory Class Members
REXToolboxCategory Class Legend
Members
Public Methods
Public Method | Description
REXToolboxCategory | Initializes a new instance of the REXToolboxCategory class.
REXToolboxCategory Properties
REXToolboxCategory Properties | Description
Items | Gets or sets the items.


REXToolboxCategory Properties

REXToolboxCategory Properties
REXToolboxCategory Class Legend
REXToolboxCategory Properties
REXToolboxCategory Properties | Description
Items | Gets or sets the items.


REXToolboxCategory Class Public Methods

REXToolboxCategory Class Public Methods
REXToolboxCategory Class Legend
Public Methods
Public Method | Description
REXToolboxCategory | Initializes a new instance of the REXToolboxCategory class.


Legend

Legend
REXToolboxCollection Class
Legend
Constructor
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXToolboxCollection Class Members

REXToolboxCollection Class Members
REXToolboxCollection Class Legend
Members
Public Methods
Public Method | Description
REXToolboxCollection | Initializes a new instance of the REXToolboxCollection<T_Item> class.


REXToolboxCollection Class Public Methods

REXToolboxCollection Class Public Methods
REXToolboxCollection Class Legend
Public Methods
Public Method | Description
REXToolboxCollection | Initializes a new instance of the REXToolboxCollection<T_Item> class.


Legend

Legend
REXToolboxItem Class
Legend
Constructor
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXToolboxItem Class Members

REXToolboxItem Class Members
REXToolboxItem Class Legend
Members
Public Methods
Public Method | Description
REXToolboxItem | Initializes a new instance of the REXToolboxItem class.
REXToolboxItem Properties
REXToolboxItem Properties | Description
Image | Gets or sets the image.


REXToolboxItem Properties

REXToolboxItem Properties
REXToolboxItem Class Legend
REXToolboxItem Properties
REXToolboxItem Properties | Description
Image | Gets or sets the image.


REXToolboxItem Class Public Methods

REXToolboxItem Class Public Methods
REXToolboxItem Class Legend
Public Methods
Public Method | Description
REXToolboxItem | Initializes a new instance of the REXToolboxItem class.


Legend

Legend
REXToolboxItemsCollection Class
Legend
Constructor
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXToolboxItemsCollection Class Members

REXToolboxItemsCollection Class Members
REXToolboxItemsCollection Class Legend
Members
Public Methods
Public Method | Description
REXToolboxItemsCollection | Initializes a new instance of the REXToolboxItemsCollection class.


REXToolboxItemsCollection Class Public Methods

REXToolboxItemsCollection Class Public Methods
REXToolboxItemsCollection Class Legend
Public Methods
Public Method | Description
REXToolboxItemsCollection | Initializes a new instance of the REXToolboxItemsCollection class.


Legend

Legend
REXToolboxObject Class
Legend
Constructor
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXToolboxObject Class Members

REXToolboxObject Class Members
REXToolboxObject Class Legend
Members
Public Methods
Public Method | Description
REXToolboxObject | Initializes a new instance of the REXToolboxObject class.
REXToolboxObject Properties
REXToolboxObject Properties | Description
Description | Gets or sets the description.
Name | Gets or sets the name.
Tag | Gets or sets the tag.


REXToolboxObject Properties

REXToolboxObject Properties
REXToolboxObject Class Legend
REXToolboxObject Properties
REXToolboxObject Properties | Description
Description | Gets or sets the description.
Name | Gets or sets the name.
Tag | Gets or sets the tag.


REXToolboxObject Class Public Methods

REXToolboxObject Class Public Methods
REXToolboxObject Class Legend
Public Methods
Public Method | Description
REXToolboxObject | Initializes a new instance of the REXToolboxObject class.


REXUnitComboBox Fields

REXUnitComboBox Fields
REXUnitComboBox Class Legend
REXUnitComboBox Fields
REXUnitComboBox Fields | Description
ComplexDoubleValueBaseProperty | This is ComplexDoubleValueBaseProperty, a member of class REXUnitComboBox.
DoubleValueBaseProperty | This is DoubleValueBaseProperty, a member of class REXUnitComboBox.
PowerProperty | This is PowerProperty, a member of class REXUnitComboBox.
UnitTypeProperty | This is UnitTypeProperty, a member of class REXUnitComboBox.


Legend

Legend
REXUnitComboBox Class
Legend
Constructor
Data Member
static
read only
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXUnitComboBox Class Members

REXUnitComboBox Class Members
REXUnitComboBox Class Legend
Members
Public Methods
Public Method | Description
REXUnitComboBox | Initializes a new instance of the REXUnitComboBox class.
REXUnitComboBox Fields
REXUnitComboBox Fields | Description
ComplexDoubleValueBaseProperty | This is ComplexDoubleValueBaseProperty, a member of class REXUnitComboBox.
DoubleValueBaseProperty | This is DoubleValueBaseProperty, a member of class REXUnitComboBox.
PowerProperty | This is PowerProperty, a member of class REXUnitComboBox.
UnitTypeProperty | This is UnitTypeProperty, a member of class REXUnitComboBox.
REXUnitComboBox Methods
REXUnitComboBox Methods | Description
GetBaseMaxValue | Gets the maximum value and converts it to base units.
GetBaseMinValue | Gets the minimum value and converts it to base units.
GetComplexDataBaseValue | Get the values and convert it to base units.
GetComplexDataInterfaceValue | Get the values and convert it to interface units.
GetDataBaseValue | Gets the value and converts it to base units.
GetDataInterfaceValue | Gets the value and converts it to interface units.
GetInterfaceMaxValue | Gets the maximum value and converts it to interface units.
GetInterfaceMinValue | Gets the minimum value and converts it to interface units.
SetBaseMaxValue | Set the maximum value defined in base units.
SetBaseMinValue | Set the minimum value defined in base units.
SetComplexDataBaseValue | Set the list of values defined in base units.
SetComplexDataInterfaceValue | Set the list of values defined in interface units.
SetDataBaseValue | Set the value in base units.
SetDataInterfaceValue | Set the value in interface units.
SetInterfaceMaxValue | Set the maximum value defined in interface units.
SetInterfaceMinValue | Set the minimum value defined in interface units.
REXUnitComboBox Properties
REXUnitComboBox Properties | Description
ComplexDoubleValueBase | Gets or sets the complex double value.
DoubleValueBase | Gets or sets the double value.
Power | Gets or sets the power of the unit.
UnitEngine | Gets or sets the unit engine.
UnitType | Gets or sets the type of the unit.


REXUnitComboBox Properties

REXUnitComboBox Properties
REXUnitComboBox Class Legend
REXUnitComboBox Properties
REXUnitComboBox Properties | Description
ComplexDoubleValueBase | Gets or sets the complex double value.
DoubleValueBase | Gets or sets the double value.
Power | Gets or sets the power of the unit.
UnitEngine | Gets or sets the unit engine.
UnitType | Gets or sets the type of the unit.


REXUnitComboBox Class Public Methods

REXUnitComboBox Class Public Methods
REXUnitComboBox Class Legend
Public Methods
Public Method | Description
REXUnitComboBox | Initializes a new instance of the REXUnitComboBox class.


REXUnitEditBox Fields

REXUnitEditBox Fields
REXUnitEditBox Class Legend
REXUnitEditBox Fields
REXUnitEditBox Fields | Description
ComplexDoubleValueBaseProperty | This is ComplexDoubleValueBaseProperty, a member of class REXUnitEditBox.
DoubleValueBaseProperty | This is DoubleValueBaseProperty, a member of class REXUnitEditBox.
PowerProperty | This is PowerProperty, a member of class REXUnitEditBox.
UnitTypeProperty | This is UnitTypeProperty, a member of class REXUnitEditBox.


Legend

Legend
REXUnitEditBox Class
Legend
Constructor
Data Member
static
read only
Property
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


REXUnitEditBox Class Members

REXUnitEditBox Class Members
REXUnitEditBox Class Legend
Members
Public Methods
Public Method | Description
REXUnitEditBox | This is REXUnitEditBox, a member of class REXUnitEditBox.
REXUnitEditBox Fields
REXUnitEditBox Fields | Description
ComplexDoubleValueBaseProperty | This is ComplexDoubleValueBaseProperty, a member of class REXUnitEditBox.
DoubleValueBaseProperty | This is DoubleValueBaseProperty, a member of class REXUnitEditBox.
PowerProperty | This is PowerProperty, a member of class REXUnitEditBox.
UnitTypeProperty | This is UnitTypeProperty, a member of class REXUnitEditBox.
REXUnitEditBox Methods
REXUnitEditBox Methods | Description
GetBaseMaxValue | Gets the maximum value and converts it to base units.
GetBaseMinValue | Gets the minimum value and converts it to base units.
GetComplexDataBaseValue | Get the values and convert it to base units.
GetComplexDataInterfaceValue | Get the values and convert it to interface units.
GetDataBaseValue | Gets the value and converts it to base units.
GetDataInterfaceValue | Gets the value and converts it to interface units.
GetInterfaceMaxValue | Gets the maximum value and converts it to interface units.
GetInterfaceMinValue | Gets the minimum value and converts it to interface units.
SetBaseMaxValue | Set the maximum value defined in base units.
SetBaseMinValue | Set the minimum value defined in base units.
SetComplexDataBaseValue | Set the list of values defined in base units.
SetComplexDataInterfaceValue | Set the list of values defined in interface units.
SetDataBaseValue | Set the value in base units.
SetDataInterfaceValue | Set the value in interface units.
SetInterfaceMaxValue | Set the maximum value defined in interface units.
SetInterfaceMinValue | Set the minimum value defined in interface units.
REXUnitEditBox Properties
REXUnitEditBox Properties | Description
ComplexDoubleValueBase | Gets or sets the complex double value.
DoubleValueBase | Gets or sets the double value.
Power | Gets or sets the power of the unit.
UnitEngine | Gets or sets the unit engine.
UnitType | Gets or sets the type of the unit.


REXUnitEditBox Properties

REXUnitEditBox Properties
REXUnitEditBox Class Legend
REXUnitEditBox Properties
REXUnitEditBox Properties | Description
ComplexDoubleValueBase | Gets or sets the complex double value.
DoubleValueBase | Gets or sets the double value.
Power | Gets or sets the power of the unit.
UnitEngine | Gets or sets the unit engine.
UnitType | Gets or sets the type of the unit.


REXUnitEditBox Class Public Methods

REXUnitEditBox Class Public Methods
REXUnitEditBox Class Legend
Public Methods
Public Method | Description
REXUnitEditBox | This is REXUnitEditBox, a member of class REXUnitEditBox.


Legend

Legend
WPFCommon Class
Legend
Method
static


WPFCommon Class Members

WPFCommon Class Members
WPFCommon Class Legend
Members
WPFCommon Methods
WPFCommon Methods | Description
FindChild | Finds the child.
SetPropertyToAllElements | This is SetPropertyToAllElements, a member of class WPFCommon.
UpdateDoubleObserveCollection | This is UpdateDoubleObserveCollection, a member of class WPFCommon.


WPFCommon Methods

WPFCommon Methods
WPFCommon Class Legend
WPFCommon Methods
WPFCommon Methods | Description
FindChild | Finds the child.
SetPropertyToAllElements | This is SetPropertyToAllElements, a member of class WPFCommon.
UpdateDoubleObserveCollection | This is UpdateDoubleObserveCollection, a member of class WPFCommon.


ROHTML Namespace Classes

ROHTML Namespace Classes
ROHTML Namespace Legend
Classes
Class | Description
ROHTMLMessages | This is class ROHTML.ROHTMLMessages.
ROHTMLStdImages | This is class ROHTML.ROHTMLStdImages.
ROHTMLTableFormats | This is class ROHTML.ROHTMLTableFormats.
XHTMLDocument | This is class ROHTML.XHTMLDocument.
XHTMLElement | This is class ROHTML.XHTMLElement.
XHTMLTable | This is class ROHTML.XHTMLTable.


Legend

Legend
ROHTML Namespace
Legend
Class
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


ROHTMLMessages Fields

ROHTMLMessages Fields
ROHTMLMessages Class Legend
ROHTMLMessages Fields
ROHTMLMessages Fields | Description
ROTF_MSG_ERROR | Error
ROTF_MSG_OK | Verified


Legend

Legend
ROHTMLMessages Class
Legend
Data Member
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


ROHTMLMessages Class Members

ROHTMLMessages Class Members
ROHTMLMessages Class Legend
Members
ROHTMLMessages Fields
ROHTMLMessages Fields | Description
ROTF_MSG_ERROR | Error
ROTF_MSG_OK | Verified


ROHTMLStdImages Fields

ROHTMLStdImages Fields
ROHTMLStdImages Class Legend
ROHTMLStdImages Fields
ROHTMLStdImages Fields | Description
ROSTD_TABLET_ERR | Image error
ROSTD_TABLET_OK | Image verified


Legend

Legend
ROHTMLStdImages Class
Legend
Data Member
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


ROHTMLStdImages Class Members

ROHTMLStdImages Class Members
ROHTMLStdImages Class Legend
Members
ROHTMLStdImages Fields
ROHTMLStdImages Fields | Description
ROSTD_TABLET_ERR | Image error
ROSTD_TABLET_OK | Image verified


ROHTMLTableFormats Fields

ROHTMLTableFormats Fields
ROHTMLTableFormats Class Legend
ROHTMLTableFormats Fields
ROHTMLTableFormats Fields | Description
ROTF_LIST_1 | Columns:2, Style:list1
ROTF_LIST_2 | Columns:5, Width:100%, Style:list2 Column[1]:Width:8%, nowrap Column[2]:Width:8%, nowrap, Style:font-family:monospace;text-align:right; Column[3]:Width:10%, Style:text-align:center; Column[4]:Width:40% Column[5]:Style=text-align:right;
ROTF_LIST_3 | Columns:2, Width:100%, Style:list3 Column[2].style=text-align:right;
ROTF_LIST_4 | Columns:2, Style:list4 Column[1]:nowrap
ROTF_TABLE_1 | Width:100%, Style:table1, Header rows and columns:1
ROTF_TABLE_2 | Width:100%, Style:table2, Header rows and columns:1
ROTF_TABLE_3 | Width:100%, Style:table3, Header rows and columns:1
ROTF_VERIFY_1 | Columns:4, Width:100% Column[1]:Width:40%, nowrap, Column[2]:Width:25%, nowrap Column[3]:nowrap Column[4]:Width:25%, Style:text-align:right


Legend

Legend
ROHTMLTableFormats Class
Legend
Data Member
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


ROHTMLTableFormats Class Members

ROHTMLTableFormats Class Members
ROHTMLTableFormats Class Legend
Members
ROHTMLTableFormats Fields
ROHTMLTableFormats Fields | Description
ROTF_LIST_1 | Columns:2, Style:list1
ROTF_LIST_2 | Columns:5, Width:100%, Style:list2 Column[1]:Width:8%, nowrap Column[2]:Width:8%, nowrap, Style:font-family:monospace;text-align:right; Column[3]:Width:10%, Style:text-align:center; Column[4]:Width:40% Column[5]:Style=text-align:right;
ROTF_LIST_3 | Columns:2, Width:100%, Style:list3 Column[2].style=text-align:right;
ROTF_LIST_4 | Columns:2, Style:list4 Column[1]:nowrap
ROTF_TABLE_1 | Width:100%, Style:table1, Header rows and columns:1
ROTF_TABLE_2 | Width:100%, Style:table2, Header rows and columns:1
ROTF_TABLE_3 | Width:100%, Style:table3, Header rows and columns:1
ROTF_VERIFY_1 | Columns:4, Width:100% Column[1]:Width:40%, nowrap, Column[2]:Width:25%, nowrap Column[3]:nowrap Column[4]:Width:25%, Style:text-align:right


XHTMLDocument Fields

XHTMLDocument Fields
XHTMLDocument Class Legend
XHTMLDocument Fields
XHTMLDocument Fields | Description
Body | XHTMLElement that represents the body of the document.
CSSFile | String containing the CSS (Cascading Style Sheets) file path for the document.
Head | XHTMLElement that represents the header of the document.
Language | Short that indicates the language in which the document is written.
Name |
NumberedHeaders | Bool that indicates whether headers are numbered automatically by the document, e.g.
Status | ROHTMLMessages indicates the status of the document, it is used in note header and footer.
Version | String (read-only) that indicates the version of the component, e.g.


Legend

Legend
XHTMLDocument Class
Legend
Data Member
Method
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


XHTMLDocument Class Members

XHTMLDocument Class Members
XHTMLDocument Class Legend
Members
XHTMLDocument Fields
XHTMLDocument Fields | Description
Body | XHTMLElement that represents the body of the document.
CSSFile | String containing the CSS (Cascading Style Sheets) file path for the document.
Head | XHTMLElement that represents the header of the document.
Language | Short that indicates the language in which the document is written.
Name |
NumberedHeaders | Bool that indicates whether headers are numbered automatically by the document, e.g.
Status | ROHTMLMessages indicates the status of the document, it is used in note header and footer.
Version | String (read-only) that indicates the version of the component, e.g.
XHTMLDocument Methods
XHTMLDocument Methods | Description
IsVersion | Returns True if the version of the component is greater or equal to the given version, version should be formatted as follow: "MAJOR.MINOR.PATCH.COMPILATION", e.g.
Save | Saves the XHTML document to the specified location.
SaveAsSingleFile | Saves the document to the specified location as MS MHTML file.
Show | Launches Internet Explorer and navigates to the specified file.
ToString | Returns String containing the generated document.


XHTMLDocument Methods

XHTMLDocument Methods
XHTMLDocument Class Legend
XHTMLDocument Methods
XHTMLDocument Methods | Description
IsVersion | Returns True if the version of the component is greater or equal to the given version, version should be formatted as follow: "MAJOR.MINOR.PATCH.COMPILATION", e.g.
Save | Saves the XHTML document to the specified location.
SaveAsSingleFile | Saves the document to the specified location as MS MHTML file.
Show | Launches Internet Explorer and navigates to the specified file.
ToString | Returns String containing the generated document.


XHTMLElement Fields

XHTMLElement Fields
XHTMLElement Class Legend
XHTMLElement Fields
XHTMLElement Fields | Description
TagName | String containing the tag name of the element (may be empty).


Legend

Legend
XHTMLElement Class
Legend
Data Member
Method
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


XHTMLElement Class Members

XHTMLElement Class Members
XHTMLElement Class Legend
Members
XHTMLElement Fields
XHTMLElement Fields | Description
TagName | String containing the tag name of the element (may be empty).
XHTMLElement Methods
XHTMLElement Methods | Description
AddAttribute | Adds an HTML attribute and its value to the element.
AddBlockquote | Adds an element of type "blockquote" to the document and returns newly created XHTMLElement object.
AddElement | Adds an element of given name to the document and returns newly created XHTMLElement object.
AddHeader | Adds an element of type h1 through h6 (size=1 is the largest) to the document and returns newly created XHTMLElement object.
AddHorizontalRule | Inserts a horizontal rule ().
AddImage | Adds an image retrieved from resource (DLL or EXE) using protocol.
AddImageStd | Adds a standard image loaded from internal resources to the document.
AddLine | Writes the given text, followed by a newline character, to the document.
AddLineBreak | Inserts a single line break ().
AddMessage | Adds a decorated text to the document and returns newly created XHTMLElement object.
AddMessage2 | Adds a left text aligned text with right aligned note.
AddNoteFooter | Writes calculation note footer
AddNoteHeader | Writes calculation note header
AddParagraph | Adds an element of type "p" to the document and returns newly created XHTMLElement object.
AddPicture | Adds an image loaded from file.
AddSpan | Adds an element of type "span" to the document and returns newly created XHTMLElement object.
AddSubscript | Writes the given text to the document as a subscript.
AddSuperscript | Writes the given text to the document as a superscript.
AddSymbol | Writes the given text to the document using symbol (greek) font, e.g.
AddTable | Adds a table to the document and returns newly created XHTMLTable object
AddText | Writes the given text to the document.
AddText2 | Writes the given value name and its description to the document.
AddTextBold | Writes the given text to the document using a bold font.
AddUnit | Writes the given unit name to the document, adds braces if needed and moves all digits to uppercase, e.g mm2 -> [mm2].
AddValue | Writes the given value of any type, that can be converted to a string, to the document.
AddValue2 | Writes the given value of any type and it's name.
AddValue4 | Extended AddValue method (Similar to Verify, different order of parameters)
AddValue5 | Extended AddValue method
Verify | Similar to AddValue4 (different order of parameters),


XHTMLElement Methods

XHTMLElement Methods
XHTMLElement Class Legend
XHTMLElement Methods
XHTMLElement Methods | Description
AddAttribute | Adds an HTML attribute and its value to the element.
AddBlockquote | Adds an element of type "blockquote" to the document and returns newly created XHTMLElement object.
AddElement | Adds an element of given name to the document and returns newly created XHTMLElement object.
AddHeader | Adds an element of type h1 through h6 (size=1 is the largest) to the document and returns newly created XHTMLElement object.
AddHorizontalRule | Inserts a horizontal rule ().
AddImage | Adds an image retrieved from resource (DLL or EXE) using protocol.
AddImageStd | Adds a standard image loaded from internal resources to the document.
AddLine | Writes the given text, followed by a newline character, to the document.
AddLineBreak | Inserts a single line break ().
AddMessage | Adds a decorated text to the document and returns newly created XHTMLElement object.
AddMessage2 | Adds a left text aligned text with right aligned note.
AddNoteFooter | Writes calculation note footer
AddNoteHeader | Writes calculation note header
AddParagraph | Adds an element of type "p" to the document and returns newly created XHTMLElement object.
AddPicture | Adds an image loaded from file.
AddSpan | Adds an element of type "span" to the document and returns newly created XHTMLElement object.
AddSubscript | Writes the given text to the document as a subscript.
AddSuperscript | Writes the given text to the document as a superscript.
AddSymbol | Writes the given text to the document using symbol (greek) font, e.g.
AddTable | Adds a table to the document and returns newly created XHTMLTable object
AddText | Writes the given text to the document.
AddText2 | Writes the given value name and its description to the document.
AddTextBold | Writes the given text to the document using a bold font.
AddUnit | Writes the given unit name to the document, adds braces if needed and moves all digits to uppercase, e.g mm2 -> [mm2].
AddValue | Writes the given value of any type, that can be converted to a string, to the document.
AddValue2 | Writes the given value of any type and it's name.
AddValue4 | Extended AddValue method (Similar to Verify, different order of parameters)
AddValue5 | Extended AddValue method
Verify | Similar to AddValue4 (different order of parameters),


XHTMLTable Fields

XHTMLTable Fields
XHTMLTable Class Legend
XHTMLTable Fields
XHTMLTable Fields | Description
Border | Short Border width in pixels.
Columns | Long Number of columns in the table.
FooterRows | Long Number of footer rows.
HeaderColumns | Long Number of header columns.
HeaderRows | Long Number of header rows.
Rows | Long Number of rows in the table (including header rows).
Width | Sets or gets the overall table width, default: "Auto".


Legend

Legend
XHTMLTable Class
Legend
Data Member
Method
Created with a commercial version of Doc-O-Matic. In order to make this message disappear you need to register this software. If you have problems registering this software please contact us at support@toolsfactory.com.


XHTMLTable Class Members

XHTMLTable Class Members
XHTMLTable Class Legend
Members
XHTMLTable Fields
XHTMLTable Fields | Description
Border | Short Border width in pixels.
Columns | Long Number of columns in the table.
FooterRows | Long Number of footer rows.
HeaderColumns | Long Number of header columns.
HeaderRows | Long Number of header rows.
Rows | Long Number of rows in the table (including header rows).
Width | Sets or gets the overall table width, default: "Auto".
XHTMLTable Methods
XHTMLTable Methods | Description
AddAttribute | Adds an HTML attribute and its value to the entire table.
AddColumnAttribute | Adds an HTML attribute and its value to the specified column.
AddRow | Adds one row to the table.
AutoFormat | Initializes a couple of table properties according to given predefined format.
Cell | XHTMLElement that represents the cell of the table.
ColumnWidth | String Sets or gets the column width of the desired column, e.g.


XHTMLTable Methods

XHTMLTable Methods
XHTMLTable Class Legend
XHTMLTable Methods
XHTMLTable Methods | Description
AddAttribute | Adds an HTML attribute and its value to the entire table.
AddColumnAttribute | Adds an HTML attribute and its value to the specified column.
AddRow | Adds one row to the table.
AutoFormat | Initializes a couple of table properties according to given predefined format.
Cell | XHTMLElement that represents the cell of the table.
ColumnWidth | String Sets or gets the column width of the desired column, e.g.


REX.Common Namespace

Next
REX.Common Namespace
Legend Classes Interfaces Structs, Records, Enums

This is namespace REX.Common.

Classes
Class | Description
REXAccess | The class dedicated to settings data from parent application.
REXApplication | Base class for Application.This object controls the lifetime of the extensions.
REXDFM | Manages UI controls registered in it.
REXDirectAccess | Base class for main DirectAccess class.
REXDirectRevitAccess | Base class for main DirectAccess class.
REXDirectRevitExecute | This is class REX.Common.REXDirectRevitExecute.
REXErrors | Supprots REX errors for logging system.
REXExtension | Additional functionality of REXExtension class.
REXExtensionContext | Internal class for controlling behavior of the extension.
REXExtensionControl | Base class for user controls.
REXExtensionData | Base class for REXData and REXResults classes.
REXExtensionDataSerializable | Base class for REXDataSerializable and REXResultsSerializable classes.
REXExtensionMainControl | Base class for main control.
REXExtensionObject | Base class for all objects created in extension module.
REXExtensionPanel | Base class for panel control.
REXExtensionProduct | Represents the Extension element used by the main Extension class to separate product dependent part of the code from general one.
REXExtensionSettings | Allows reading base settings from "Configuration / settings.xml" file.
REXExtensionWindow | Base class for user forms.
REXFoundationApplication | Foundation class for REX.Foundation usage.
REXLayout |
REXLayoutItem | Represents all layout of main control.
REXLogger | This is class REX.Common.REXLogger.
REXResults | Base class for results.
REXRevitAccess | The class dedicated to settings data from Revit.
REXRevitContextAccess | Allaws for access to Revit's objects.
REXUI | Main class which provides access to all data connected with main control.
REXVersion | Foundation class for REX.Foundation usage.
REXWarnings | This is class REX.Common.REXWarnings.
REXWebBrowser | Proxy class for web browser control.
Interfaces
Interface | Description
IREXConnector | This is class REX.Common.IREXConnector.
IREXExtension | Main interface for extension module.
IREXExtension2 | Main interface for extension module.
IREXExtension3 | Main interface for extension module.
IREXExtension4 | Main interface for extension module.
IREXExtensionAccess | Main interface for REXAccess class.
IREXExtensionAccess2 | Main interface for REXAccess class.
IREXExtensionAccess3 | Main interface for REXAccess class.
IREXExtensionAccessUnitsControl | Main interface for REXAccess class.
IREXThisExtension | Base interface for access to main extension's objects.
Structs, Records, Enums
Struct, Record, Enum | Description
REXCanCloseType | Determines closing mode.
REXSetFormStruct | This is record REX.Common.REXSetFormStruct.
Links
Legend, Classes, Interfaces, Structs, Records, Enums