Revit 2021.1 API
ElementClassFilter Members
ElementClassFilter Class Constructors Methods Properties See Also Send Feedback

The ElementClassFilter type exposes the following members.

Constructors

 | Name | Description
Public method | ElementClassFilter(Type) | Constructs a new instance of a filter to match elements by class.
Public method | ElementClassFilter(Type, Boolean) | Constructs a new instance of a filter to match elements by class, with the option to match all elements which are not of the given class.

Methods

 | Name | Description
Public method | GetElementClass | The class for the filter.

Properties

 | Name | Description

See Also

ElementClassFilter Class

ElementClassFilter Constructor

[image] [image]