Revit 2021.1 API
WireMaterialType Members
WireMaterialType Class Methods Properties See Also Send Feedback

The WireMaterialType type exposes the following members.

Methods

 | Name | Description
Public method | AddGroundConductorSize | Add new electrical ground conductor size type into this material type.
Public method | AddTemperatureRatingType | Add a new temperature rating type into material type.
Public method | RemoveGroundConductorSize | Remove an existing ground conductor size from this material type.
Public method | RemoveTemperatureRatingType | Remove an existing temperature rating type from this material type.

Properties

 | Name | Description
Public property | GroundConductorSizes | Get all ground conductor size types defined in this wire material type.
Public property | IsInUse | Indicate whether the wire material type is in use.
Public property | Name | Get name of wire material type. (Overrides ElementType..::..Name.)
Public property | TemperatureRatings | Get all temperature rating type definitions defined in this wire material type.

See Also

WireMaterialType Class
Autodesk.Revit.DB.Electrical Namespace

AddGroundConductorSize Method

[image]