Revit 2021.1 API
ModelPathUtils Methods
ModelPathUtils Class See Also Send Feedback

The ModelPathUtils type exposes the following members.

Methods

Name | Description
ConvertCloudGUIDsToCloudPath(Guid, Guid) | Obsolete. Converts a pair of cloud project and model GUIDs to a valid cloud path in BIM 360 US region.
ConvertCloudGUIDsToCloudPath(String, Guid, Guid) | Converts a pair of cloud project and model GUIDs to a valid cloud path.
ConvertModelPathToUserVisiblePath | Gets a string version of the path of a given ModelPath.
ConvertUserVisiblePathToModelPath | Converts a user-visible path (string) to a ModelPath.
IsValidUserVisibleFullServerPath | Determines whether the given string represents a valid server path.

See Also

ModelPathUtils Class

ConvertCloudGUIDsToCloudPath Method

[image] [image]