Revit 2021.1 API
HermiteSurface..::..Create Method (Int32, Int32, IList<(Of <(<'XYZ>)>)>, Boolean, Boolean)
HermiteSurface Class See Also Send Feedback
Create a Hermite surface using a net of 3D points as input. Specify periodicity in U and V direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2017

Syntax

C#
public static HermiteSurface Create(
    int nU,
    int nV,
    IList<XYZ> points,
    bool periodicU,
    bool periodicV
)
Visual Basic
Public Shared Function Create ( _
    nU As Integer, _
    nV As Integer, _
    points As IList(Of XYZ), _
    periodicU As Boolean, _
    periodicV As Boolean _
) As HermiteSurface
Visual C++
public:
static HermiteSurface^ Create(
    int nU,
    int nV,
    IList<XYZ^>^ points,
    bool periodicU,
    bool periodicV
)

Parameters

nU
Type: System..::..Int32
Number of points in U direction.
nV
Type: System..::..Int32
Number of points in V direction.
points
Type: System.Collections.Generic..::..IList<(Of <(<' XYZ >)>)>
Array of points. Must contain nU*nV points.
periodicU
Type: System..::..Boolean
Periodicity in U direction
periodicV
Type: System..::..Boolean
Periodicity in V direction

Return Value

A Hermite surface object created from input data.

Remarks

Points form a net of nU * nV (less one each if periodic) 3D points.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | Thrown when the input arguments are inconsistent. The most common case is incorrect number of items in one of the lists.

See Also

HermiteSurface Class
Create Overload

IsValid Method

[image]