Revit 2021.1 API
FabricationService..::..OverrideServiceButtonExclusion Method
FabricationService Class See Also Send Feedback
Overrides the default service button exclusions, used by Route and Fill, Design to Fabrication, or Multi Point Routing for the current user and session only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2017 Subscription Update

Syntax

C#
public void OverrideServiceButtonExclusion(
    int groupIndex,
    int buttonIndex,
    bool exclude
)
Visual Basic
Public Sub OverrideServiceButtonExclusion ( _
    groupIndex As Integer, _
    buttonIndex As Integer, _
    exclude As Boolean _
)
Visual C++
public:
void OverrideServiceButtonExclusion(
    int groupIndex,
    int buttonIndex,
    bool exclude
)

Parameters

groupIndex
Type: System..::..Int32
The index of the service group to exclude the service button from.
buttonIndex
Type: System..::..Int32
The index of the service button to exclude.
exclude
Type: System..::..Boolean
Pass true to exclude from being used by Route and Fill or Design to Fabrication.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | the index groupIndex is not larger or equal to 0 and less than GroupCount
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Mechanical Electrical Piping.

See Also

FabricationService Class

ResetServiceExclusionOverrides Method

[image]