Revit 2021.1 API
ElectricalDemandFactorDefinition Methods
ElectricalDemandFactorDefinition Class See Also Send Feedback

The ElectricalDemandFactorDefinition type exposes the following members.

Methods

 | Name | Description
Public method | AddValue | Adds a value to the value set for this demand factor definition
Public method | ClearValues | Clears all the values stored for this demand factor definition.
 | Create | Creates a new instance of a demand factor definition.
Public method | GetApplicableDemandFactor | This method will return the applicable demand factor for the specified number of devices or load.
Public method | GetValues | Provides access to the value set stored with this demand factor definition
Public method | GetValuesCount | Returns the number of values in the set.
Public method | RemoveValue | Removes a value to the value set for this demand factor definition
Public method | SetValues | Sets the value set to the demand factor definition.

See Also

ElectricalDemandFactorDefinition Class
Autodesk.Revit.DB.Electrical Namespace

AddValue Method

[image]