Revit 2021.1 API
FieldBuilder Methods
FieldBuilder Class See Also Send Feedback

The FieldBuilder type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | NeedsSubSchemaGUID | Checks whether the SubSchema GUID needs to be explicitly specified for this field type.
Public method | NeedsUnits | Checks whether the field type requires explicit unit conversions.
Public method | Ready | Checks whether the builder may be used.
Public method | SetDocumentation | Sets the documentation string for the Field.
Public method | SetSpec | Sets the spec describing the field's values.
Public method | SetSubSchemaGUID | Sets the GUID of the Schema of the Entities that are intended to be stored in this field.
Public method | SetUnitType | Obsolete. Sets the type of units for the field.

See Also

FieldBuilder Class
Autodesk.Revit.DB.ExtensibleStorage Namespace

Dispose Method

[image]