Revit 2021.1 API
VertexPositionNormalColored Members
VertexPositionNormalColored Class Constructors Methods Properties See Also Send Feedback

The VertexPositionNormalColored type exposes the following members.

Constructors

 | Name | Description
Public method | VertexPositionNormalColored | Constructs the vertex from a point, a normal vector, and a color.

Methods

 | Name | Description
Public method | GetColor | Gets the vertex's color.
 | GetSizeInFloats | Gets the amount of storage that the vertex takes up in a buffer, measured in floats.
Public method | SetColor | Sets the vertex's color.

Properties

 | Name | Description
Public property | Normal | The vertex's normal vector.
Public property | Position | The vertex's position.

See Also

VertexPositionNormalColored Class
Autodesk.Revit.DB.DirectContext3D Namespace

VertexPositionNormalColored Constructor

[image]