Revit 2021.1 API
AnalysisDisplayColorEntry Members
AnalysisDisplayColorEntry Class Constructors Methods Properties See Also Send Feedback

The AnalysisDisplayColorEntry type exposes the following members.

Constructors

 | Name | Description
Public method | AnalysisDisplayColorEntry()()()() | Constructs a new AnalysisDisplayColorEntry with default settings.
Public method | AnalysisDisplayColorEntry(Color) | Constructs a color entry with no value assigned.
Public method | AnalysisDisplayColorEntry(Color, Double) | Constructs a color entry with a specific value assigned.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the AnalysisDisplayColorEntry
Public method | HasValue | Check if color entry has associated value.
Public method | IsEqual | Compare color entries.

Properties

 | Name | Description
Public property | Color | Color associated with color entry.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Value | Value associated with color entry.

See Also

AnalysisDisplayColorEntry Class
Autodesk.Revit.DB.Analysis Namespace

AnalysisDisplayColorEntry Constructor

[image] [image]