Revit 2021.1 API
Definition Members
Definition Class Methods Properties See Also Send Feedback

The Definition type exposes the following members.

Methods

 | Name | Description
Public method | GetSpecTypeId | Gets the identifier of the spec describing values of the parameter.

Properties

 | Name | Description
Public property | Name | The user visible name for the parameter.
Public property | ParameterGroup | Returns the group ID of the parameter definition.
Public property | ParameterType | Returns the user visible interpretation of the parameter data.
Public property | UnitType | Obsolete. Returns the UnitType of the parameter definition.

See Also

Definition Class

Definition Methods

[image] [image]