Revit 2021.1 API
Category Members
Category Class Methods Properties See Also Send Feedback

The Category type exposes the following members.

Methods

 | Name | Description
 | GetCategory(Document, BuiltInCategory) | Retrieves a category object corresponding to a BuiltInCategory id.
 | GetCategory(Document, ElementId) | Retrieves a category object corresponding to the category id.
Public method | GetGraphicsStyle | Gets the graphics style associated with this category for the given graphics style type.
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | GetLinePatternId | Gets the line pattern id associated with this category for the given graphics style type.
Public method | GetLineWeight | Retrieves the line weight assigned to the category for the given graphics style type.
 | IsBuiltInCategoryValid | Checks if a Category exists for a given BuiltInCategory.
Public method | SetLinePatternId | Sets the line pattern id associated with this category for the given graphics style type.
Public method | SetLineWeight | Sets the line weight for the given graphics style type.

Properties

 | Name | Description
Public property | AllowsBoundParameters | To check if the category can have project parameters.
Public property | AllowsVisibilityControl | Whether the visibility can be controlled by the user for this category in this view.
Public property | CanAddSubcategory | Indicates if subcategories can be assigned to the category.
Public property | CategoryType | Gets the category type of this category.
Public property | HasMaterialQuantities | Identifies if elements of the category are able to report what materials they contain in what quantities.
Public property | Id | Returns the category id associated with the category object.
Public property | IsCuttable | Indicates if the category is cuttable or not.
Public property | IsTagCategory | Identifies if the category is associated with a type of tag for a different category.
Public property | IsVisibleInUI | Identifies if the category is visible to the user and should be displayed in UI.
Public property | LineColor | The color of lines shown for elements of this category.
Public property | Material | Retrieves or changes the material of the category.
Public property | Name | The category name.
Public property | Parent | Returns the parent category of this category.
Public property | SubCategories | Returns a map containing all of the subcategories of this category.
Public property | Visible | Retrieves or changes the visibility of the category in the active view.

See Also

Category Class

Category Methods

[image] [image]