Revit 2021.1 API
FilterStringRule Constructor
FilterStringRule Class See Also Send Feedback
Constructs an instance of FilterStringRule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011

Syntax

C#
public FilterStringRule(
    FilterableValueProvider valueProvider,
    FilterStringRuleEvaluator evaluator,
    string ruleString,
    bool caseSensitive
)
Visual Basic
Public Sub New ( _
    valueProvider As FilterableValueProvider, _
    evaluator As FilterStringRuleEvaluator, _
    ruleString As String, _
    caseSensitive As Boolean _
)
Visual C++
public:
FilterStringRule(
    FilterableValueProvider^ valueProvider,
    FilterStringRuleEvaluator^ evaluator,
    String^ ruleString,
    bool caseSensitive
)

Parameters

valueProvider
Type: Autodesk.Revit.DB..::..FilterableValueProvider
A pointer to a "value provider" object that will extract values from a Revit document.
evaluator
Type: Autodesk.Revit.DB..::..FilterStringRuleEvaluator
A pointer to the filter rule evaluator object that implements the desired test. The built-in evaluators implement commonly used tests for strings such as begins-with, ends-with, contains, equal, etc.
ruleString
Type: System..::..String
The user-supplied string against which strings from a Revit document will be tested.
caseSensitive
Type: System..::..Boolean
If true, string comparisons will be done case-sensitively.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FilterStringRule Class

FilterStringRule Methods

[image] [image]