Revit 2021.1 API
WorksetConfiguration Members
WorksetConfiguration Class Constructors Methods Properties See Also Send Feedback

The WorksetConfiguration type exposes the following members.

Constructors

 | Name | Description
Public method | WorksetConfiguration()()()() | Constructs a new workset configuration with an initial setting to open all user-created worksets.
Public method | WorksetConfiguration(WorksetConfiguration) | Constructs a new copy of the input WorksetConfiguration object.
Public method | WorksetConfiguration(WorksetConfigurationOption) | Constructs a new workset configuration with an initial setting to open or close all user-created worksets, or to open last viewed worksets.

Methods

 | Name | Description
Public method | Close | Sets a group of user-created worksets to close.
Public method | Dispose | Releases all resources used by the WorksetConfiguration
Public method | Open | Sets a group of user-created worksets to open.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

WorksetConfiguration Class

WorksetConfiguration Constructor

[image]