Revit 2021.1 API
PanelScheduleData Methods
PanelScheduleData Class See Also Send Feedback

The PanelScheduleData type exposes the following members.

Methods

 | Name | Description
Public method | AddLoadClassification | Add a Load Classification Id to the array of Load Classifications.
Public method | GetLoadClassifications | Gets an array of the load classifications associated with this panel schedule
Public method | GetNumberOfCircuitRows | Gets the number of rows in the circuit table
Public method | IsSymmetric | Check if this panel schedule is symmetric
Public method | RemoveLoadClassification | Remove a Load Classification Id from the array of Load Classifications
Public method | SetBorderAroundSchedule | Adds a border around the schedule
Public method | SetBorderAroundSections | Adds a border around the sections
Public method | SetLoadClassifications | Sets the Load Classifications associated with this panel schedule
Public method | UpdateCircuitTableForInstance | Redraw the circuit table for the given panel with the given parameter updates
Public method | UpdateCircuitTableForTemplate | Redraw the circuit table for a template with the given parameter updates
Public method | UpdateIsSectionHidden | Update if this section is hidden or not
Public method | UpdateLoadSummary | Update the load summary section
Public method | UpdateVerticalHeadersInSection | Sets if this header should have vertical text

See Also

PanelScheduleData Class
Autodesk.Revit.DB.Electrical Namespace

AddLoadClassification Method

[image]