Revit 2021.1 API
VectorAtPoint Constructor (IList<(Of <(<'XYZ>)>)>)
VectorAtPoint Class See Also Send Feedback
Creates object from an array of vectors

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012

Syntax

C#
public VectorAtPoint(
    IList<XYZ> vectors
)
Visual Basic
Public Sub New ( _
    vectors As IList(Of XYZ) _
)
Visual C++
public:
VectorAtPoint(
    IList<XYZ^>^ vectors
)

Parameters

vectors
Type: System.Collections.Generic..::..IList<(Of <(<' XYZ >)>)>
Array of vectors, each corresponding to "measurement"

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when supplied vectors contain invalid (infinite or non-number) coordinates
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

VectorAtPoint Class
VectorAtPoint Overload
Autodesk.Revit.DB.Analysis Namespace

VectorAtPoint Methods

[image] [image]