Revit 2021.1 API
IFCLevelInfo Members
IFCLevelInfo Class Methods Properties See Also Send Feedback

The IFCLevelInfo type exposes the following members.

Methods

 | Name | Description
 | Create | Creates an IFCLevelInfo.
Public method | Dispose | Releases all resources used by the IFCLevelInfo
Public method | GetBuildingStorey | Gets the IfcBuildingStorey handle.
Public method | GetLocalPlacement | Gets the local placement.
Public method | GetRelatedElements | Gets all building elements on this level.
Public method | GetRelatedProducts | Gets all building products on this level.

Properties

 | Name | Description
Public property | DistanceToNextLevel | The distance to the next story level.
Public property | Elevation | The elevation of the level.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

IFCLevelInfo Class
Autodesk.Revit.DB.IFC Namespace

IFCLevelInfo Methods

[image] [image]