Revit 2021.1 API
Categories Properties
Categories Class See Also Send Feedback

The Categories type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Whether or not the list of top-level categories is empty. (Overrides CategoryNameMap..::..IsEmpty.)
Public property | Item[([( String])]) | Gets a category which has the specified name from this list of top-level categories. (Overrides CategoryNameMap..::..Item[([( String])]) .)
Public property | Item[([( BuiltInCategory])]) | Retrieves a category object corresponding to a BuiltInCategory id.
Public property | Size | The total number of top-level categories in the document. (Overrides CategoryNameMap..::..Size.)

See Also

Categories Class

IsEmpty Property

[image]