Revit 2021.1 API
ForgeTypeId Methods
ForgeTypeId Class See Also Send Feedback

The ForgeTypeId type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Sets the typeId to an empty string
Public method | Dispose |
Public method | Empty | Checks if the typeId is an empty string
Public method | Equals | Determines whether this ForgeTypeId is equal to another. (Overrides Object..::..Equals(Object).)
Public method | GetHashCode | Returns the hash code for this ForgeTypeId (Overrides Object..::..GetHashCode()()()().)
Public method | NameEquals | Returns true if the typeid string held by this ForgeTypeId is equal to that held by the given ForgeTypeId, excluding the version number. The version number of a typeid string follows a hyphen character. This function compares the typeid strings up to the first hyphen. This is the default equality comparison method for the ForgeTypeId class, used by the equality operator (==).
Public method | StrictlyEquals | Returns true if the entire typeid string held by this ForgeTypeId is exactly equal to that held by the given ForgeTypeId. For the default equality comparison used by the equality operator (==), see NameEquals(ForgeTypeId).

See Also

ForgeTypeId Class

Clear Method

[image]