Revit 2021.1 API
ExternalServiceOptions Properties
ExternalServiceOptions Class See Also Send Feedback

The ExternalServiceOptions type exposes the following members.

Properties

 | Name | Description
Public property | IsPublic | This property denotes a service as either public or private.
Public property | IsRecordable | Indicates whether executions of the service is recorded in documents or not.
Public property | IsSelfsynchronizing | Indicates whether the service's record of used services (in a particular document) can independently wary between local clients and the corresponding central model. It is then up to the service's owner to assure proper local-central synchronization.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

ExternalServiceOptions Class
Autodesk.Revit.DB.ExternalService Namespace

IsPublic Property

[image]