Revit 2021.1 API
BeamSystem Properties
BeamSystem Class See Also Send Feedback

The BeamSystem type exposes the following members.

Properties

 | Name | Description
Public property | BeamSystemType | Retrieves or changes the type of the BeamSystem.
Public property | BeamType | Retrieves or changes the Beam Type of the BeamSystem.
Public property | Direction | The Direction of the BeamSystem.
Public property | Elevation | Retrieves or changes the Elevation of the BeamSystem.
Public property | LayoutRule | Retrieves or changes the LayoutRule of the BeamSystem.
Public property | Level | Get or change the level of the BeamSystem. When the level is changed, the elevation is changed to make the the BeamSystem remain the location.
Public property | Profile | Retrieve or set the profile of the BeamSystem.

See Also

BeamSystem Class

BeamType Property

[image]