Revit 2021.1 API
MassGBXMLExportOptions Members
MassGBXMLExportOptions Class Constructors Methods Properties See Also Send Feedback

The MassGBXMLExportOptions type exposes the following members.

Constructors

 | Name | Description
Public method | MassGBXMLExportOptions(IList<(Of <<'(ElementId>)>>)) | Constructs a new instance of the options used to export a mass model to gbXML.
Public method | MassGBXMLExportOptions(IList<(Of <<'(ElementId>)>>), IList<(Of <<'(ElementId>)>>)) | Constructs a new instance of the options used to export a mass model to gbXML.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the MassGBXMLExportOptions
Public method | GetMassIds | Gets a list of masses to use as shading surfaces in the exported gbXML--these masses must not have mass floors or mass zones so as not to end up with duplicate surface information in the gbXML output.
Public method | GetMassZoneIds | Gets a list of mass zones to analyze in the exported gbXML.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

MassGBXMLExportOptions Class
Autodesk.Revit.DB.Analysis Namespace

MassGBXMLExportOptions Constructor

[image] [image]