Revit 2021.1 API
ImageTypeOptions Constructor
ImageTypeOptions Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ImageTypeOptions()()()() | Obsolete. Constructs a new instance of the ImageTypeOptions object.
Public method | ImageTypeOptions(String) | Obsolete. Constructs a new instance of the ImageTypeOptions object. The provided string path must specify a local file. The path can be absolute or relative to the project's location. ImageType will respectively use an absolute or relative path.
Public method | ImageTypeOptions(String, Boolean) | Obsolete. Constructs a new instance of the ImageTypeOptions object. The provided string path must specify a local file. The path can be absolute or relative to the project's location. This constructor saves an additional setting that indicates whether the path used by ImageType should be absolute or relative.
Public method | ImageTypeOptions(ExternalResourceReference, ImageTypeSource) | Constructs a new instance of the ImageTypeOptions object.
Public method | ImageTypeOptions(String, Boolean, ImageTypeSource) | Constructs a new instance of the ImageTypeOptions object. The provided string path must specify a local file. The path can be absolute or relative to the project's location. This constructor saves an additional setting that indicates whether the imagetype will be a link or an import.

See Also

ImageTypeOptions Class
ImageTypeOptions Members

ImageTypeOptions Constructor

[image]