Revit 2021.1 API
Element..::..IsValidType Method (Document, ICollection<(Of <(<'ElementId>)>)>, ElementId)
Element Class See Also Send Feedback
Checks if given type is valid for the set of elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011

Syntax

C#
public static bool IsValidType(
    Document document,
    ICollection<ElementId> elementIds,
    ElementId typeId
)
Visual Basic
Public Shared Function IsValidType ( _
    document As Document, _
    elementIds As ICollection(Of ElementId), _
    typeId As ElementId _
) As Boolean
Visual C++
public:
static bool IsValidType(
    Document^ document,
    ICollection<ElementId^>^ elementIds,
    ElementId^ typeId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
elementIds
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
A collection of element IDs.
typeId
Type: Autodesk.Revit.DB..::..ElementId
ElementId of the type to check.

Return Value

True if all elements can have a type assigned and this type is valid for all elements, false otherwise.

Remarks

A type is valid for the set of elements if it is valid for each and every element in the set.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when at least one of the elements does not exist in the document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

Element Class
IsValidType Overload

LookupParameter Method

[image]