Revit 2021.1 API
BuiltInFailures..::..SweepFailures Members
BuiltInFailures..::..SweepFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..SweepFailures type exposes the following members.

Properties

Name | Description
CannotDrawSweep | Can't create sweep.
ComplexPathWithComplexProfile | Sweep cannot have a path with ellipse or spline segments and a profile with non-straight lines.
ProfileLoopEmpty | Profile sketch is empty!
SweepFailed | Proper sweep geometry creation failed.
SweepFailedError | Proper sweep geometry creation failed.

See Also

BuiltInFailures..::..SweepFailures Class

BuiltInFailures.SweepFailures Properties

[image] [image]