Revit 2021.1 API
BalusterPattern Properties
BalusterPattern Class See Also Send Feedback

The BalusterPattern type exposes the following members.

Properties

 | Name | Description
Public property | BreakPattern | The condition which controls breaking baluster patterns distribution.
Public property | DistributionJustification | Determines how baluster pattern distribution is justified.
Public property | EndSpace | The extra space added after a whole baluster pattern.
Public property | ExcessLengthFillBalusterId | The id of a Baluster family used to fill excess length, which is the extra space along the railing segment that cannot be filled with a pattern. If set to InvalidElementId, it will be the default - the id of the BaseRailingAttr containing the Baluster pattern.
Public property | ExcessLengthFillSpacing | The value defines the spacing between each baluster instance inserted in the excess length.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Length | The length of the main baluster pattern.
Public property | PatternAngle | The angle between neighboring railing segments which conditions breaking patterns distribution along a railing path.

See Also

BalusterPattern Class
Autodesk.Revit.DB.Architecture Namespace

BreakPattern Property

[image]