Revit 2021.1 API
GeometryCreationUtilities..::..CreateFixedReferenceSweptGeometry Method
GeometryCreationUtilities Class See Also Send Feedback

Overload List

Name | Description
CreateFixedReferenceSweptGeometry(CurveLoop, Int32, Double, IList<(Of <<'(CurveLoop>)>>), XYZ) | Creates a solid by sweeping one or more closed coplanar curve loops along a path while keeping the profile plane oriented so that a line in the plane that is initially perpendicular to a given fixed direction remains perpendicular as the profile is swept along the path.
CreateFixedReferenceSweptGeometry(CurveLoop, Int32, Double, IList<(Of <<'(CurveLoop>)>>), XYZ, SolidOptions) | Creates a solid by sweeping one or more closed coplanar curve loops along a path while keeping the profile plane oriented so that a line in the plane that is initially perpendicular to a given fixed direction remains perpendicular as the profile is swept along the path.

See Also

GeometryCreationUtilities Class
GeometryCreationUtilities Members

CreateFixedReferenceSweptGeometry Method (CurveLoop, Int32, Double, IList(CurveLoop), XYZ)

[image]