Revit 2021.1 API
Wire Members
Wire Class Methods Properties See Also Send Feedback

The Wire type exposes the following members.

Methods

 | Name | Description
Public method | AppendVertex | Appends one vertex to the end of the wire.
 | AreVertexPointsValid | Checks if the given vertex points are valid for the wire.
Public method | ConnectTo | Connects the wire to other elements.
 | Create | Creates a new wire.
Public method | GetMEPSystems | Gets the systems to which the wire belongs.
Public method | GetVertex | Gets the position of an existing vertex.
Public method | InsertVertex | Inserts a new vertex before the specified index.
Public method | IsVertexPointValid | Checks if the given vertex point can be added to this wire.
Public method | RemoveVertex | Removes the vertex corresponding to the specified index. Can not remove the start or end vertex if it already connects to other element.
Public method | SetVertex | Sets the position of a given vertex. If the vertex is start or end point, and the wire connects to electrical device, the wire end offset will be set according to the given vertex. If the vertex is start or end point, and the wire connects to other wire, user can't set the vertex and exception will be thrown. If the vertex is start or end point, and the wire connects to nothing, the vertex will be set as the given vertex.

Properties

 | Name | Description
Public property | GroundConductorNum | The ground conductor number. Its default value is zero after created.
Public property | HotConductorNum | The hot conductor number. Its default value is zero after created.
Public property | NeutralConductorNum | The neutral conductor number. Its default value is zero after created.
Public property | NumberOfVertices | The number of vertices of the wire, including the start and end point.
Public property | WiringType | The wiring type(arc or chamfer) for the wire.

See Also

Wire Class
Autodesk.Revit.DB.Electrical Namespace

ConnectTo Method

[image]