Revit 2021.1 API
IUpdater Methods
IUpdater Interface See Also Send Feedback

The IUpdater type exposes the following members.

Methods

 | Name | Description
Public method | Execute | The method that Revit will invoke to perform an update.
Public method | GetAdditionalInformation | Auxiliary text that Revit will use to inform the end user when the Updater is not loaded
Public method | GetChangePriority | Identifies the nature of the change the Updater will be performing Used to identify order of execution of updaters Called once during registration of the updater
Public method | GetUpdaterId | Returns globally unique updater id - used to identify the Updater Called once during registration of the updater
Public method | GetUpdaterName | Returns a name that the Updater can be identified by to the user

See Also

IUpdater Interface

Execute Method

[image]