Revit 2021.1 API
DuctFittingAndAccessoryData Members
DuctFittingAndAccessoryData Class Methods Properties See Also Send Feedback

The DuctFittingAndAccessoryData type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the DuctFittingAndAccessoryData
Public method | GetAllConnectorData | Gets the connector data of the pipe fitting or pipe accessory.
Public method | GetEntity | Returns an Entity of the Schema of the serverGUID. or an invalid entity otherwise.
Public method | GetFamilyInstanceId | Gets the Id of the fiting or accessory instance

Properties

 | Name | Description
Public property | AirViscosity | The air viscosity of the duct fitting or duct accessory, Units: (kg/(ft·s)).
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Origin | The origin position of the duct fitting or duct accessory.
Public property | PartType | The part type of the duct fitting or duct accessory.
Public property | ServerGUID | The GUID of the duct fitting or duct accessory.
Public property | SystemClassification | The system classification of the duct fitting or duct accessory.

See Also

DuctFittingAndAccessoryData Class
Autodesk.Revit.DB.Mechanical Namespace

DuctFittingAndAccessoryData Methods

[image] [image]