Revit 2021.1 API
BuiltInFailures..::..CreationFailures Properties
BuiltInFailures..::..CreationFailures Class See Also Send Feedback

The BuiltInFailures..::..CreationFailures type exposes the following members.

Properties

Name | Description
CannotCreateCornice | Could not create Wall Sweep. [Description]
CannotCreateCorniceError | Could not create Wall Sweep. [Description]
CannotCreateCorniceIntegral | Could not create integral wall sweep for wall instance. [Description]
CannotCreateCorniceIntegralError | Could not create integral wall sweep for wall instance. [Description]
CannotCreateCorniceIntegralWarn | Could not create integral wall sweep for wall instance. [Description]
CannotCreateCorniceWarn | Could not create Wall Sweep. [Description]
CannotCreateCurtainGrid | Can't create Curtain Wall Grid Line.
CannotCreateCutout | Can't make cut-out.
CannotCreateCutoutError | Can't make cut-out.
CannotCreateCutoutWarn | Can't make cut-out.
CannotCreateElementInFamily | Can't create element in this family.
CannotCreateElementInView | Can't create this kind of element in this view in the current mode.
CannotCreateExplicitCrease | Cannot create a new split line based on the picked support.
CannotCreateFascia | Could not create Fascia. [Description]
CannotCreateFasciaError | Could not create Fascia. [Description]
CannotCreateFasciaWarn | Could not create Fascia. [Description]
CannotCreateGutter | Could not create Gutter. [Description]
CannotCreateGutterError | Could not create Gutter. [Description]
CannotCreateGutterWarn | Could not create Gutter. [Description]
CannotCreateMullion | Can't create Mullion.
CannotCreateMullionError | Can't create Mullion.
CannotCreateMullionReference | Can't create Curtain Wall Mullion. The grid segment for the Mullion is probably too small.
CannotCreateMullionReferenceNoGeometry | Can't create Curtain Wall Mullion. The portion of the curtain grid it was placed on no longer exists.
CannotCreateNewDesignOption | Cannot create a new empty design option
CannotCreateOldCornerMullion | Cannot change the type of a mullion created prior to release 4.0 to a corner mullion type. Try deleting the existing mullion and placing a new one.
CannotCreateOpening | Cannot create opening.
CannotCreateOpeningCutOut | Can't create Opening cut.
CannotCreateOpeningRectangularArcWall | Creation of a Rectangular Arc Wall Opening failed.
CannotCreateReveal | Could not create Reveal. [Description]
CannotCreateRevealError | Could not create Reveal. [Description]
CannotCreateRevealIntegral | Could not create integral reveal for wall instance. [Description]
CannotCreateRevealIntegralError | Could not create integral reveal for wall instance. [Description]
CannotCreateRevealIntegralWarn | Could not create integral reveal for wall instance. [Description]
CannotCreateRevealWarn | Could not create Reveal. [Description]
CannotCreateSlabEdge | Could not create Slab Edge. [Description]
CannotCreateSlabEdgeError | Could not create Slab Edge. [Description]
CannotCreateSlabEdgeWarn | Could not create Slab Edge. [Description]
CannotCreateSystemPanel | Can't create Curtain Panel in opening. The opening is probably too small.
CannotCreateThis | Can't create [Element].
CannotDrawProfileRoof | Can't make footprint roof.
CannotDrawRoof | Can't make roof.
CannotDrawRoofError | Can't make roof.
CannotDrawRoofWall | Can't make roof.
CannotDrawSingularSlantedWall | Cannot create wall - it would intersect itself. Reduce the wall's height or slant.
CannotDrawSingularSlantedWallError | Cannot create wall - it would intersect itself. Reduce the wall's height or slant.
CannotDrawWalls | Can't make Wall.
CannotDrawWallsError | Can't make Wall.
CannotMakeRoofFromVerticalFace | Can't make roof from vertical face.
CannotMakeRoofFromVerticalFaceError | Can't make roof from vertical face.
CannotMakeSurface | Can't construct surface.
CannotMakeSurfaceError | Can't construct surface.
CannotMakeSurfaceWarn | Can't construct surface.
CannotMakeWall | Can't make Wall.
CannotUpdateWall | Can't update Wall.
SwitchFromLegendBeforeCreateSimilar | To Create Similar from a Legend View, first select the element, then activate the target view, then invoke Create Similar.

See Also

BuiltInFailures..::..CreationFailures Class

CannotCreateCornice Property

[image]