Revit 2021.1 API
ProgressChangedEventArgs Properties
ProgressChangedEventArgs Class See Also Send Feedback

The ProgressChangedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Caption | The text from the progress bar caption that describes the operation in progress
Public property | LowerRange | Lower part of progress bar range - always zero
Public property | Position | Progress bar position - value is always between zero and upperRange and is incremented by one with each event of stage "PositionChanged"
Public property | Stage | The current stage of the progress bar
Public property | UpperRange | Upper part of progress bar range - will be any non-zero number

See Also

ProgressChangedEventArgs Class
Autodesk.Revit.DB.Events Namespace

Caption Property

[image]