Revit 2021.1 API
BuiltInFailures..::..AutoJoinFailures Properties
BuiltInFailures..::..AutoJoinFailures Class See Also Send Feedback

The BuiltInFailures..::..AutoJoinFailures type exposes the following members.

Properties

Name | Description
DesignOptionAndWorksetViolation | Can't make the expected join because of editability and design option restrictions.
DesignOptionCannotReference | Design Option ' [Name] ' cannot reference Design Option ' [Name] '.
OtherNonEditJoinFailure | Two elements were not automatically joined because other elements at join are not editable.
UnexpectedJoinFailure | Join failure caused by editability or design option related problem.
Unknown | Unknown
WorksetJoinWarn | Two elements were not automatically joined because one or both is not editable.

See Also

BuiltInFailures..::..AutoJoinFailures Class

DesignOptionAndWorksetViolation Property

[image]