Revit 2021.1 API
BuiltInFailures..::..FormFailures Properties
BuiltInFailures..::..FormFailures Class See Also Send Feedback

The BuiltInFailures..::..FormFailures type exposes the following members.

Properties

Name | Description
AddProfileFailure | Failed to Add Profile
DissolveNoValidInputs | No form elements selected to dissolve.
DissolveUnableToDissolveForm | Unable to dissolve form element.
FormCreationInvalidGeomCombination | Cannot remake form that is currently cut or joined to other geometry. Please uncut or unjoin first.
FormElemRegenFailure | Unable to create form element
FormElemRegenFailureError | Unable to create form element
FormElemRegenSelfIntersection | Unable to create form element: self-intersecting or singular geometry would result.
FormElemRegenSelfIntersectionReorderProfiles | This form cannot be created due to self-intersecting geometry. Clicking the Reorder Profiles button will attempt to solve this problem.
FormElemRegenSelfIntersectionResetConnections | This form cannot be created due to self-intersecting geometry. Clicking the Reset Connections button will attempt to solve this problem.
NoSoludGeometryForVoidFormsInMass | This Mass has no solid geometry for its Void Forms to cut. They must be deleted, or solid geometry added and cut.
OpenProfileMultiSegmentSweepsNotSupported | An open profile cannot be swept along a multi-segment path.
VoidFormsNotUsed | Some Void Forms of this family do not cut anything and will be deleted. To make a Void Form cut something else use the Cut Geometry tool.

See Also

BuiltInFailures..::..FormFailures Class

AddProfileFailure Property

[image]