Revit 2021.1 API
EffectInstance Members
EffectInstance Class Constructors Methods Properties See Also Send Feedback

The EffectInstance type exposes the following members.

Constructors

 | Name | Description
Public method | EffectInstance | Constructs the effect instance for geometry having the specified vertex format.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the EffectInstance
Public method | IsValid | Tests whether the effect instance is valid for rendering.
Public method | MatchesFormat | Tests whether the effect instance is appropriate for the given vertex format.
Public method | SetAmbientColor | Sets the ambient color parameter of the effect instance.
Public method | SetColor | Sets the color parameter of the effect instance.
Public method | SetDiffuseColor | Sets the diffuse color parameter of the effect instance.
Public method | SetEmissiveColor | Sets the emissive color parameter of the effect instance.
Public method | SetGlossiness | Sets the glossiness parameter of the effect instance.
Public method | SetSpecularColor | Sets the specular color parameter of the effect instance.
Public method | SetTransparency | Sets the transparency parameter of the effect instance.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

EffectInstance Class
Autodesk.Revit.DB.DirectContext3D Namespace

EffectInstance Constructor

[image]