Revit 2021.1 API
ColorOptions Members
ColorOptions Class Methods Properties See Also Send Feedback

The ColorOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ColorOptions
 | GetColorOptions | Returns the current Revit instance's ColorOptions.

Properties

 | Name | Description
Public property | AlertColor | The color used to highlight elements when a special alert is required.
Public property | BackgroundColor | The background color applied to views.
Public property | CalculatingColor | The color used to render elements when some aspect of their properties is currently being recalculated.
Public property | EditingColor | The color used to render elements when editing.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | PreselectionColor | The color used to highlight candidates for selection before they are selected.
Public property | SelectionColor | The color used to highlight selected elements.
Public property | SelectionSemitransparent | Indicates whether or not selections will be shown in a semi-transparent manner.

See Also

ColorOptions Class

ColorOptions Methods

[image] [image]