Revit 2021.1 API
Macro Members
Macro Class Methods Properties See Also Send Feedback

The Macro type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the Macro
Public method | Execute | Executes the macro.

Properties

 | Name | Description
Public property | Description | The macro description.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | MacroModule | The Macro module.
Public property | Name | The macro name.

See Also

Macro Class
Autodesk.Revit.DB.Macros Namespace

Macro Methods

[image] [image]