Revit 2021.1 API
FieldDomainPointsByUV Constructor (IList<(Of <(<'UV>)>)>)
FieldDomainPointsByUV Class See Also Send Feedback
Creates object from an array of two-dimensional point coordinates

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011

Syntax

C#
public FieldDomainPointsByUV(
    IList<UV> points
)
Visual Basic
Public Sub New ( _
    points As IList(Of UV) _
)
Visual C++
public:
FieldDomainPointsByUV(
    IList<UV^>^ points
)

Parameters

points
Type: System.Collections.Generic..::..IList<(Of <(<' UV >)>)>
Array of two-dimensional point coordinates representing domain points (usually on surface)

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FieldDomainPointsByUV Class
FieldDomainPointsByUV Overload
Autodesk.Revit.DB.Analysis Namespace

FieldDomainPointsByUV Constructor (IList(UV), ICollection(Double), ICollection(Double))

[image]