Revit 2021.1 API
RoofComponents Members
RoofComponents Class Methods Properties See Also Send Feedback

The RoofComponents type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the RoofComponents
Public method | GetAreasOfCurveLoops | The areas of CurveLoops of roof slabs.
Public method | GetCurveLoops | The CurveLoops of roof slabs.
Public method | GetLoopFaces | The faces of the loops of roof slabs.
Public method | GetPlaneDirections | The plane directions of roof slabs.
Public method | GetPlaneOrigins | The plane origins of roof slabs.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ScaledDepth | The depth of the roof slab.

See Also

RoofComponents Class
Autodesk.Revit.DB.IFC Namespace

RoofComponents Methods

[image] [image]