Revit 2021.1 API
Application Members
Application Class Methods Properties Events See Also Send Feedback

The Application type exposes the following members.

Methods

 | Name | Description
Public method | CopyModel | Copies an existing model to a new file. Overwriting a file of the same name is allowed.
Public method | Dispose | Releases all resources used by the Application
Public method | ExtractPartAtomFromFamilyFile | Writes a PartAtom XML from the contents of a family file.
Public method | GetAssets | Gets all the Assets of the specified type.
 | GetFailureDefinitionRegistry | Returns the instance of FailureDefinitionRegistry.
Public method | GetLibraryPaths | Returns path information identifying where Revit searches for content.
Public method | GetRevitServerNetworkHosts | Gets the list of all Revit Server Network hosts in current session.
Public method | GetSystemsAnalysisWorkflowNames | Returns names for systems analysis workflows.
Public method | GetSystemsAnalysisWorkflows | Returns name and path information identifying systems analysis workflow files.
Public method | GetWorksharingCentralGUID | Gets the worksharing central GUID of the given server-based model.
Public method | IsJournalPlaying | Determines if the application is currently in journal playback mode.
 | IsValidThickness | Checks if the input value is valid to be supplied as a thickness (for an extrusion, or blend, or wall layer, or similar geometric construct).
Public method | NewFamilyDocument | New family document, including family, titleblock, and annotation symbol
Public method | NewProjectDocument(String) | New project document
Public method | NewProjectDocument(UnitSystem) | Creates a new project document with no template file specified.
Public method | NewProjectTemplateDocument | New project template document
Public method | OpenBuildingComponentDocument | Opens a Building Component document from disk.
Public method | OpenDocumentFile(String) | Opens a document from disk.
Public method | OpenDocumentFile(ModelPath, OpenOptions) | Opens a document from disk or cloud.
Public method | OpenDocumentFile(ModelPath, OpenOptions, IOpenFromCloudCallback) | Opens a document from disk or cloud.
Public method | OpenIFCDocument(String) | Opens an IFC document from disk using default options.
Public method | OpenIFCDocument(String, IFCImportOptions) | Opens an IFC document from disk using custom options.
Public method | OpenSharedParameterFile | Enables access to shared parameter groups and definitions that are maintained on disk.
Public method | PurgeReleasedAPIObjects | Explicitly purges all API objects that have been released but are still awaiting to be finalized
 | RegisterFailuresProcessor | Replaces Revit's default user interface (if present) with alternative handling for all warnings and errors (including those not generated by your application) for the rest of the Revit session; if your application is not prepared to respond to all warnings and errors, consider use of IFailuresPreprocessor (in your opened Transaction) or the FailuresProcessing event instead of this interface.
Public method | SetLibraryPaths | Sets path information identifying where Revit searches for content.
Public method | SetSystemsAnalysisWorkflows | Sets name and path information identifying systems analysis workflow files.
Public method | UpdateRenderAppearanceLibrary | Updates the stored render appearance library, giving the Revit session access to any new RPC content.
Public method | WriteJournalComment | Writes a comment to the Revit journal file.

Properties

 | Name | Description
Public property | ActiveAddInId | Retrieves the Id of the currently running external application.
Public property | AllowNavigationDuringRedraw | Checks whether or not the navigation during redraw is enabled, and enable or disable it.
Public property | AllUsersAddinsLocation | The folder location for .addin files for all users.
Public property | AngleTolerance | Angle tolerance.
Public property | BackgroundColor | The background color to use for model views in this session.
Public property | Cities | Returns a set of all the known city locations within Revit.
Public property | Create | Provides an object that can be used to create new instances of Autodesk Revit API objects.
Public property | CurrentRevitServerAccelerator | Current Revit Server accelerator.
Public property | CurrentUserAddinsLocation | The folder location for .addin files for the current user.
Public property | CurrentUsersAddinsDataFolderPath | Path to AddinsData folder for the current user.
Public property | CurrentUsersDataFolderPath | Path to data folder for the current user.
Public property | DefaultIFCProjectTemplate | Full path to the default template file for new IFC project documents. It may be empty, in which case the DefaultProjectTemplate should be used.
Public property | DefaultProjectTemplate | Full path to the default template file for new project documents.
Public property | DefaultViewDiscipline | The view discipline that will be applied to new views by default.
Public property | Documents | Returns a set of documents within Revit.
Public property | ExportIFCCategoryTable | Full path to the file that defines Revit category to IFC entity mappings for IFC export.
Public property | FamilyTemplatePath | Default path for family template files.
Public property | ImportIFCCategoryTable | Full path to the file that defines IFC entity to Revit category mappings for IFC import.
Public property | IsArchitectureEnabled | Checks whether or not the architecture discipline is enabled, and enable or disable it.
Public property | IsElectricalAnalysisEnabled | Checks whether or not electrical analysis is enabled, and enable or disable it.
Public property | IsElectricalEnabled | Checks whether or not the electrical discipline is enabled, and enable or disable it.
Public property | IsEnergyAnalysisEnabled | Checks whether or not energy analysis is enabled, and enable or disable it.
Public property | IsInfrastructureEnabled | Checks whether or not infrastructure discipline is enabled, and enable or disable it.
 | IsLoggedIn | Checks if the user is logged in from this session to their Autodesk account.
Public property | IsMassingEnabled | Checks whether or not the massing and site tools are enabled, and enable or disable them.
Public property | IsMechanicalAnalysisEnabled | Checks whether or not mechanical analysis is enabled, and enable or disable it.
Public property | IsMechanicalEnabled | Checks whether or not the mechanical discipline is enabled, and enable or disable it.
Public property | IsPipingAnalysisEnabled | Checks whether or not piping analysis is enabled, and enable or disable it.
Public property | IsPipingEnabled | Checks whether or not the piping discipline is enabled, and enable or disable it.
Public property | IsRouteAnalysisEnabled | Checks whether or not route analysis is enabled, and enable or disable it.
Public property | IsStructuralAnalysisEnabled | Checks whether or not the structural analysis is enabled, and enable or disable it.
Public property | IsStructureEnabled | Checks whether or not the structure discipline is enabled, and enable or disable it.
Public property | IsSystemsEnabled | Checks whether or not any systems disciplines (mechanical, electrical, or piping) are enabled.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Language | The language used in the current session of Revit.
Public property | LoginUserId | The user id of the user currently logged in. The user id will be empty if the user is not logged in.
 | MinimumThickness | The minimum thickness allowed in Revit for a variety of geometric constructs. These include blends, extrusions, and wall layers.
Public property | PointCloudsRootPath | Root path for point cloud files.
Public property | Product | The product type for the current session of Revit.
Public property | RecordingJournalFilename | Retrieve the name of the journal file the Revit is currently recording to.
Public property | SharedParametersFilename | Contains the fully qualified path to a shared parameters file.
Public property | ShortCurveTolerance | The enforced minimum length for any curve created by Revit.
Public property | ShowGraphicalWarningCableTrayConduitDisconnects | Whether or not to show the graphical warnings for CTC disconnects.
Public property | ShowGraphicalWarningDuctDisconnects | Whether or not to show the graphical warnings for duct disconnects.
Public property | ShowGraphicalWarningElectricalDisconnects | Whether or not to show the graphical warnings for Electrical disconnects.
Public property | ShowGraphicalWarningHangerDisconnects | Whether or not to show the graphical warnings for Fabrication Hanger disconnects.
Public property | ShowGraphicalWarningPipeDisconnects | Whether or not to show the graphical warnings for Pipe disconnects.
Public property | SubVersionNumber | The minor version number of Revit
Public property | SystemsAnalysisWorkfilesRootPath | Root path for systems analysis workfiles
Public property | Username | Gets the user name for the current Revit session.
Public property | VersionBuild | Returns the internal build number of the Autodesk Revit application.
Public property | VersionName | Returns the name of the Revit application.
Public property | VersionNumber | Return the primary version of the Revit application.
Public property | VertexTolerance | Vertex tolerance.

Events

 | Name | Description
Public event | ApplicationInitialized | Subscribe to this event to get notified after the Revit application has been initialized
Public event | DocumentChanged | Subscribe to the DocumentChanged event to be notified when Revit document has changed.
Public event | DocumentClosed | Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.
Public event | DocumentClosing | Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.
Public event | DocumentCreated | Subscribe to the DocumentCreated event to be notified immediately after Revit has finished creating a new document.
Public event | DocumentCreating | Subscribe to the DocumentCreating event to be notified when Revit is just about to create a new document.
Public event | DocumentOpened | Subscribe to the DocumentOpened event to be notified immediately after Revit has finished opening a document.
Public event | DocumentOpening | Subscribe to the DocumentOpening event to be notified when Revit is just about to open a document.
Public event | DocumentPrinted | Subscribe to the DocumentPrinted event to be notified immediately after Revit has finished printing a view or ViewSet of the document.
Public event | DocumentPrinting | Subscribe to the DocumentPrinting event to be notified when Revit is just about to print a view or ViewSet of the document.
Public event | DocumentReloadedLatest | Subscribe to the DocumentReloadedLatestEventArgs event to be notified immediately after Revit has finished reloading a document with central model.
Public event | DocumentReloadingLatest | Subscribe to the DocumentReloadingLatestEventArgs event to be notified when Revit is just about to reload latest changes from a central model.
Public event | DocumentSaved | Subscribe to the DocumentSaved event to be notified immediately after Revit has finished saving a document.
Public event | DocumentSavedAs | Subscribe to the DocumentSavedAs event to be notified immediately after Revit has finished saving document with a new file name.
Public event | DocumentSaving | Subscribe to the DocumentSaving event to be notified when Revit is just about to save a document.
Public event | DocumentSavingAs | Subscribe to the DocumentSavingAs event to be notified when Revit is just about to save the document with a new file name.
Public event | DocumentSynchronizedWithCentral | Subscribe to the DocumentSynchronizedWithCentral event to be notified immediately after Revit has finished synchronizing a document with central model.
Public event | DocumentSynchronizingWithCentral | Subscribe to the DocumentSynchronizingWithCentral event to be notified when Revit is just about to synchronize a document with central model.
Public event | DocumentWorksharingEnabled | Subscribe to the DocumentWorksharingEnabled event to be notified when a document has become workshared.
Public event | ElementTypeDuplicated | Subscribe to the ElementTypeDuplicated event to be notified immediately after Revit has finished duplicating an element type.
Public event | ElementTypeDuplicating | Subscribe to the ElementTypeDuplicating event to be notified when Revit is just about to duplicate an element type.
Public event | FailuresProcessing | Subscribe to the FailuresProcessing event to be notified when failures are being processed at the end of transaction.
Public event | FamilyLoadedIntoDocument | Subscribe to the FamilyLoadedInto event to be notified after Revit loaded a family into a document.
Public event | FamilyLoadingIntoDocument | Subscribe to the FamilyLoadingInto event to be notified when Revit is just about to load a family into a document.
Public event | FileExported | Subscribe to the FileExported event to be notified immediately after Revit has finished exporting files of formats supported by the API.
Public event | FileExporting | Subscribe to the FileExporting event to be notified when Revit is just about to export files of formats supported by the API.
Public event | FileImported | Subscribe to the FileImported event to be notified immediately after Revit has finished importing a file of format supported by the API.
Public event | FileImporting | Subscribe to the FileImporting event to be notified when Revit is just about to import a file of format supported by the API.
Public event | LinkedResourceOpened | Subscribe to the LinkedResourceOpened event to be notified immediately after Revit has finished opening a linked resource.
Public event | LinkedResourceOpening | Subscribe to the LinkedResourceOpening event to be notified when Revit is just about to open a linked resource.
Public event | ProgressChanged | Subscribe to the ProgressChanged event to be notified when an operation in Revit has progress bar data available.
Public event | ViewExported | Subscribe to the ViewExported event to be notified immediately after Revit has finished exporting a view of the document.
Public event | ViewExporting | Subscribe to the ViewExporting event to be notified when Revit is just about to export a view of the document.
Public event | ViewPrinted | Subscribe to the ViewPrinted event to be notified immediately after Revit has finished printing a view of the document.
Public event | ViewPrinting | Subscribe to the ViewPrinting event to be notified when Revit is just about to print a view of the document.
Public event | ViewsExportedByContext | Subscribe to the ViewsExportedByContext event to be notified immediately after Revit has finished exporting one or more views of the document via an export context by CustomExporter.
Public event | ViewsExportingByContext | Subscribe to the ViewsExportingByContext event to be notified when Revit is just about to export one or more views of the document via an export context by CustomExporter.
Public event | WorksharedOperationProgressChanged | Subscribe to the WorksharedOperationProgressChanged to be notified when progress has changed during Collaboration for Revit's workshared operations: open model and synchronize with central.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace

Application Methods

[image] [image]