Revit 2021.1 API
BuiltInFailures..::..StairRampFailures Properties
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback

The BuiltInFailures..::..StairRampFailures type exposes the following members.

Properties

Name | Description
ActualRiserHeightChanged | The actual riser height for one or more stairs violates the maximum set in the type.
AntiparallelRampRisers | Riser lines are parallel but not collinear. Can't build Run between these Risers.
AntiparallelRampRisersError | Riser lines are parallel but not collinear. Can't build Run between these Risers.
ArcRunRadiusTooSmall | Can't create Run. Run radius is too small.
ArcRunWidthTooLongFailure | Arc run width is too long.
AutomaticLandingConvertedToSketchedLandingWarning | Some run(s) are deleted, so automatic landing is converted to sketched landing.
BadBalustersPerTread | Number of Balusters per Tread must be an integer greater than zero.
BadFillingSpacing | Spacing for Excess Length Fill is too small.
BadRailings | Can't create Railings.
BadRailingsError | Can't create Railings.
BadRailProfile | One or more Profile Loops are invalid, probably because of self-intersection.
BadTreadRiserProfile | Tread/Riser profile is invalid.
BalustersTooClose | Baluster Separation must be equal to or greater than the Baluster widths.
BalustersTooCloseAbsolute | Baluster Separation is too small.
BalusterUpsideDown | Top reference is below Bottom reference for one or more Balusters. These Balusters are not created.
CannotAlignSupportOnPosts | Cannot align the support on the posts.
CannotComputeRailElevation | Can't compute elevation profile for one or more Rails
CannotCreateBaluster | Can't create Balusters for given Width and Height.
CannotCreateBalusterPatterns | Can't create Baluster Patterns for Railings
CannotCreateCornerBalusters | Can't create corner Baluster
CannotCreateLandingStringer | Can't create stringer at landing.
CannotCreateMiddleStringer | Can't create one or more Middle Stringers.
CannotCreateMonolithicStairs | Can't make monolithic Stairs.
CannotCreateNosing | Can't create nosing on one or more treads.
CannotCreateOneOrMoreBaluster | Can't create one or more Balusters
CannotCreateOneOrMoreTreads | Can't create geometry for one or more treads.
CannotCreateOpenMiddleStringers | Can't cut open/middle stringers geometry.
CannotCreateRail | Can't create Railing. Thickness of Rail or Balusters might be too small. If you don't want Balusters, specify "None" for Baluster Shape.
CannotCreateRailGeom | Can't create geometry for one or more Rails
CannotCreateRailWarn | Can't create Railing. Thickness of Rail or Balusters might be too small. If you don't want Balusters, specify "None" for Baluster Shape.
CannotCreateRiser | Can't create geometry for one or more risers.
CannotCreateSideStringer | Can't create one or more Side Stringers.
CannotCreateStairForLevelOverlapping | Some of the multistory stairs couldn't be created due to the overlapped levels.
CannotCreateStringers | Can't create stringers geometry.
CannotDrawStairs | Can't make stairs
CannotDrawStairsError | Can't make stairs
CannotEndWithZeroRiser | Can't end Stairs with Riser because Riser Thickness is too small.
CannotGenerateFaces | Couldn't generate surfaces for stairs.
CannotGenerateFacesError | Couldn't generate surfaces for stairs.
CannotGenerateRamp | Couldn't generate surfaces for ramp.
CannotGenerateRampError | Couldn't generate surfaces for ramp.
CannotMakeLanding | Can't make landing.
CannotOffsetBoundary | Can't create Boundary as an offset of Run Curve
CannotOffsetRail | Can't create one or more Rails with desired offset
CannotPlaceBalusterOffset | Can't place Balusters and/or Rails with desired offset
CannotPlaceBalusterPatterns | Can't place Baluster Patterns
CannotPlaceRailingOnStringerWarning | Railing is placed on tread because there is no stringer.
CannotProcessInStairsSketchEditMode | Cannot process when stair(s) in sketch edit mode.
CannotSplitRailingWithExtensions | Railings with extensions cannot be split.
ContinuousRailFilletCreationError | Cannot create specified fillet at rail path corner.
ContinuousRailFilletCreationParallel | Cannot create specified fillet at rail path corner because of the curves are already smoothed.
ContinuousRailFilletCreationWarning | Cannot create specified fillet at rail path corner.
ContinuousRailGometryCreationFailure | Cannot create the continuous rail geometry.
ContinuousRailNotContinuous | The rail is non-continuous.
ContinuousRailSupportPlacementFailure | Cannot place the supports along the rail path.
ContinuousRailTransitionFailure | Cannot create specified transition at rail path turn, hand Rail/Top Rail cannot maintain continuous.
ExtendBelowBaseGreaterThanLandingBaseElevation | Extend Below Base needs to be less than Landing Base Elevation.
ExtendBelowBaseGreaterThanRunTopElevation | Extend Below Base needs to be less than Run Top Elevation.
FailToReOrientSketchCurvesFailure | Failed to orient sketch curves.
HeightOfRunIsTooSmall | Height of run is too small.
IntermediateLandingHigherThanTopRunFailure | Run is reversed.
InvalidBalustersPattern | Invalid Balusters Pattern
InvalidLocationLineJustificationFailure | Modify the location justification to a invalid value.
InvalidParameters | Stairs run or landing has invalid parameter(s).
InvalidRailProfile | Profiles for one or more of the Rails are invalid. Make sure that every used Profile is a closed series of non-intersecting Lines.
InvalidStairsPathFailure | Invalid stairs path provided.
InvalidStartLevel | The start level and end level for this staircase must be at different elevations.
InvalidStartLevelRamp | The start level and end level for this ramp must be at different elevations.
LandingDepthIsLessThanRunWidthWarning | Landing depth is less than run width.
LandingHeightUnderStairsBottom | Cannot make landing because height of landing is equal or less than to bottom height of the stair.
LandingShapeHandleOnPinnedRunFailure | Cannot Drag the automatic landing shape handle control because the connected run is pinned.
MayUnjoinRailAndSupports | Fillet may cause the supports unjoin with the rail.
MultistoryLevelBelowTopbottomLevel | Multistory top level must be above the stair/ramp top and bottom levels.
MultistoryLevelBelowTopbottomLevelError | Multistory top level must be above the stair/ramp top and bottom levels.
MultistoryStairDoesntReach | The multistory stair/ramp could not reach its top level with integral number of flights. Maximum number of flights below the top level is created.
MultistoryStairsAutomaticLevelLandingsDeleted | Level landings are deleted because the connected stairs have been regenerated.
MultistoryStairsComponentJoinFailure | Can't keep elements joined. Avoid converting stairs to skeched-based component in Multistory stairs.
MultistoryStairsHideTopLevelParameter | You have set the stair's multistory top level to None, and Revit will remove this parameter, if you want to create a multistory stair, please use Create Multistory Stair feature.
MultistoryStandardStairBottomEndExceedsOrNotReach | One of the stairs inside multistory stairs bottom ends exceeds or cannot reach the base elevation of the stair.
MultistoryStandardStairTopEndExceedsOrNotReach | One of the stairs inside multistory stairs top ends exceed or cannot reach the top elevation of the stair.
MultusegmentRampRiser | Ramp can't have multisegment Riser.
MultusegmentRampRiserError | Ramp can't have multisegment Riser.
NoCurvesInRailing | Railing Sketch has no Lines.
NoProfileForRail | Must specify Profiles for every Rail.
NoRailingsStringer | Railings and Stringers will not be automatically generated due to bad Runs. This message may be incorrect if you have Edited the Sketch and modified some dimensions.
NoRisersInPureMonolithicStairs | Monolithic Stairs with zero tread thickness can't have risers
NoRunsRamp | Ramp has no Runs. Can't create Ramp.
NoRunsRampError | Ramp has no Runs. Can't create Ramp.
NotALineRiserRamp | Riser line must be a straight line for Ramps.
NotALineRiserRampError | Riser line must be a straight line for Ramps.
NotchThicknessIsLargerThanLandingWarning | The notch thickness is larger than landing.
NotEnoughRisers | Actual Number of Risers is different from Desired Number of Risers. Add/remove Risers or change Desired Number of Risers in Stairs Properties.
OnlyMonolithicStairs | Tread thickness can't be zero for non-monolithic stairs
PartOfRiserLiesOnBoundaryFailure | Part of the riser lies on the boundary is not allowed.
PathDoesntJoinToBorderRisersFailure | Path doesn't join to border risers is not allowed.
RailCurveTooShort | Curve in rail sketch is too short for rail creation and ignored.
RailingBadOffset | An arc in the railing sketch has a radius that conflicts with the current rail widths and offsets. Please either increase the radius or modify rail profiles and offsets.
RailingCurvesNotSplitRamp | The slope of this railing will not parallel the ramp at landings. To get a parallel railing, split the railing sketch at the ends of landings.
RailingCurvesNotSplitStairs | The slope of this railing may not parallel the stairs at runs and landings. To get a parallel railing, split the railing sketch at the ends of landings.
RailingDoublyConnected | Railings hosted on Stairs must form a single, open, connected line.
RailingNotConnected | The Railing line must be a single connected Sketch. If you want separate pieces of Railing, create two or more separate Railings.
RailPathCloseLoopForExtensionWarning | The rail path is closed at the start and end path point for extension creation.
RailPlacedOutsideOfHost | Railings are placed completely outside the host. It may change the adjustment of the railing to the host and its vertical position.
RailProfileLowerThanFilletError | Fillet cannot be created between rail segment since the radius is lower than the profile size.
RailProfileLowerThanFilletFailure | Fillet cannot be created between rail segment since the radius is lower than the profile size.
RailProfileOpen | Open Profile Loop can't be used as a Rail Profile
RailTypeChangeInconsistancyWarningWithResetBtn | Some rail type changes are not consistent with your rail instances customization in this project, you can reset them to make them corresponding with your changes.
RampDoesntReach | The ramp is not long enough to reach the top constraint. Change the slope or increase the length of the ramp.
RampDoesntReachOffset | The ramp is not long enough to reach the top constraint plus top offset. Change the slope or increase the length of the ramp.
RampLandingNotCreated | Beginning of run coincide with the end of previous run. Landing is not created between runs.
RampRunTooComplex | Ramp Run has complex boundary and may produce unreasonable geometry. Split it into few Runs by inserting Riser Lines at the end of each Run and at the beginning of the next one. If you want to create Ramp with arc an straight section you can do it using a Run tool.
RampStartHigherThanEnd | The ramp's base (base level + base offset) must be below its top (top level + top offset).
RiserCurveTooShort | Riser curve is too short to create nosing on it.
RiserHeightIsTooSmall | Riser height is too small.
RiserIntWithBoundaryMoreThanOnceFailure | Riser intersects with boundary more than once.
RisersAtSameLocation | The highlighted risers have the same location along the boundary line. Please move one of the two risers.
RiserThicknesssResetToZero | Monolithic Stairs without Treads can't have Risers. Riser Thickness for Stairs Type was automatically set to zero.
RunBottomHigherThanTopFailure | The base elevation for the run is higher than the top elevation for the run.
RunBottomUnderStairsBottomFailure | Run bottom elevation should not be below the stairs bottom elevation.
RunIsJoiningLandingWithRiserSoNotchDoesNotWorkWarning | Run is joining landing with riser, so notch configuration does not take effect. Try to set run as begin/end with tread to make a notch.
RunTopLowerThanBottomFailure | The top elevation for the run is lower than the base elevation for the run.
SpiralRunRadiusTooSmallFailure | The radius value for the run is too small.
StairIncompleteFailure | Stair element is incomplete, not all components are logic connected.
StairsActualRiserHeightGreaterThanMaximumFailure | Computed actual riser height of stairs is greater than maximum riser height defined in stairs type.
StairsActualRunWidthLessThanMinimumFailure | Actual run width is less than minimum run width defined in stairs type.
StairsActualTreadDepthLessThanMinimumFailure | Computed actual tread depth of stairs is less than minimum tread depth defined in stairs type.
StairsAlreadyAttachedToCurrentLevel | Mutistory Stairs already have a Stair attaching to this level.
StairsAreUpdatedDueToLevelHeightChange | Stair component(s) in the multistory stair are updated due to the level height changes.
StairsAutomaticLandingLayoutFailure | Fail to generate the automatic landing layout
StairsAutomaticLandingLayoutWarn | Fail to generate the automatic landing layout
StairsBottomEndExceedsOrNotReachWarning | Stair bottom end exceeds or cannot reach the base elevation of the stair. Add/remove risers at the bottom end or change base elevation settings in Stair Properties.
StairsCannotExtendToFloorStructureLayerWarning | Stairs cannot extend to floor structure layer.
StairsCommonRunGenerateLayoutFailure | Fail to get base line thus fail to generate run layout
StairsComponentJoinFailure | Can't keep elements joined.
StairsCrossingRisersDisallowedFailure | Crossing risers are not allowed
StairsGenericFailure | Stairs generic failure
StairsGenericTransformFailure | Cannot change base elevation of Stairs
StairsIllegalDesiredNumRisers | Desired Number of Risers is too small. Computed Actual Riser Height is greater than Maximum Riser Height allowed by type.
StairsInMultistoryExceedTopConstraint | Stairs in MultistoryStairs after adjusting still exceed the top constraint.
StairsOnlySingleBoundaryHasRiserWithBothEndsOnBoundaryFailure | Only single boundary case may have riser with its both ends on boundary.
StairsOtherThan2IntsByRiserAndBoundaryFailure | More than 2 intersection points between riser segment and boundary encountered
StairsPathPositionResetWarning | The stairs path doesn't intersect with riser lines.
StairsRunRunJoinNotAllowedFailure | Run-Run join is not allowed of they have same "Start With Riser"/"End With Riser" configuration at the joined end.
StairsStartHigherThanEnd | The stairs' base (Base Level + Base Offset) must be below its top (Top Level + Top Offset).
StairsStringerCannotBeCreated | The stairs stringer cannot be created.
StairsSubElementsNotConnectedWarning | Stair sub-elements are not connected
StairsSupportOverlapFailure | Some supports overlap with others
StairsSupportTooShort | A short support is being created.
StairsTopEndExceedsOrNotReachWarning | Stair top end exceeds or cannot reach the top elevation of the stair. Add/remove risers at the top end or change top elevation settings in Stair Properties.
StairsTopLowerThanBaseFailure | The top of the Stair is lower than the base of the Stair
StairStringerCantOffset | Inside stringer could not be created because of insufficient space. Please disable the inside stringer or decrease its width.
StairsWinderGenLayoutFailure | Fail to generate run layout and then cannot make winder run
StairsWinderInvalidParamsFailure | Cannot create the winder run because some values for the instance properties cannot be satisfied.
StairsZeroDesiredRisers | The number of desired risers for a staircase cannot be 0.
StringerCurvesNotSplitStairs | The slope of stringer may not parallel runs and landings. To get a parallel stringer, split boundary lines at the ends of landings.
StringerCurveTooShort | A piece of boundary is too short to create stringer on it.
TooShortCurveDowngradeGeometry | Curve is too short and may downgrade the geometry.
TreadDepthBelowMin | The Actual Tread Depth for one or more Stairs violates the Minimum Depth set in the type.
TreadDepthFailsEq | The actual tread depth and riser height for one or more stairs of this type violates the stair equation.
TreadDepthTooBigFailure | The tread depth is too large for the spiral run.
TreadFrontProfileInvalid | This profile cannot be used for the front of treads. Please choose a profile composed of a closed loop of lines with exactly one lines coincident with the y-axis. This lines will define the connection of this profile to the tread.
UnableToCreateMultistoryStairs | Unable to create Multistory stairs.
UnexpectedCurveIntersectionFailure | Computing curve intersection and find the invalid result.
WinderFilletRadiusTooLargeFailure | The value for Fillet Radius is too large to satisfy the Minimum Inside Width value.
WinderFirstLegTooShortOrRunWidthTooGreatFailure | The first leg of winder run is too short or the runwidth is too great.
WinderGenericError | Cannot make winder.
WinderLegIsTooShortFailure | A winder leg is too short.
WinderLegsAngleTooGreatOrRunWidthTooSmallFailure | The angle between two consecutive legs are too great or the runwidth is too small.
WinderLegTooShortOrRunWidthTooGreatFailure | One leg of the winder run is too small or the runwidth is too great.
WinderMinWidthTooLargeFailure | The value for Minimum Width on Inside Boundary is too large.
WinderMinWidthTooLargeForParallelTreadsFailure | The value for Minimum Width on Inside Boundary is too large to satisfy the number of Parallel Treads at the Start or End as specified in the Run Instance properties.
WinderParallelLegsFailure | Two consecutive legs are parallel.
WinderParallelTreadsNumberFailure | Cannot satisfy the number of Parallel Treads at the Start or End as specified in the Run Instance properties
WinderRunCreationFailure | The relationship between the current values of Actual Run Width, Minimum Width at Inside Boundary, and Parallel Treads at Start or End does not support the creation of the winder run.
WinderRunInsideMinTreadDepthFailure | Please enter a positive value less than Actual Tread Depth on Stair Path (%Actual Tread Depth%).
WinderRunInsideWalklineOffsetFailure | Please enter a value between 0 and half of Actual Run Width (%1/2 Actual Run Width%).
WinderRunWidthLessThan2TimesMinWidthFailure | The value for Minimum Width on Inside Boundary is too large to satisfy the number of Parallel Treads at the Start or End as specified in the Run Instance properties.
WinderRunWidthLessThanWalkLineOffsetFailure | The value for Run Width is less than two times of value of the inside walkline offset.
WinderRunWidthOrMinWidthOrTooGreatParallelTreadsFailure | The parameter runwidth is great or the parameter min width at inside boundary is too great, or number of parallel treads at both ends is too great.
WinderRunWidthOrMinWidthOrTooShortFailure | The parameter runwidth is too great or the parameter min width at inside boundary is too great, or one leg of winder run is too short.
WinderSecondLegTooShortOrRunwidthTooGreatFailure | The second leg of winder run is too short or the runwidth is too great.
WinderStraightStepsNumberFailure | The current layout cannot allow the specified number of treads. Increase the length of the run leg in the model or reduce the value for Parallel Treads at Start or Parallel Treads at End.
WinderThirdLegTooShortOrRunWidthTooGreatFailure | The third leg of winder run is too short or the runwidth is too great.
WinderTooManyEndParallelTreadsOrRunWidthFailure | The number of parallel treads at end is too great or the run width is too great.
WinderTooManyParallelTreadsAtEndFailure | The number of parallel treads at end is too great.
WinderTooManyParallelTreadsAtHeadFailure | The number of parallel treads at start is too great.
WinderTooManyStartParallelTreadsOrRunWidthFailure | The number of parallel treads at start is too great or the run width is too great.

See Also

BuiltInFailures..::..StairRampFailures Class

ActualRiserHeightChanged Property

[image]