Revit 2021.1 API
ElectricalEquipment Methods
ElectricalEquipment Class See Also Send Feedback

The ElectricalEquipment type exposes the following members.

Methods

 | Name | Description
Public method | GetCircuitNamingSchemeType | Gets enumerated type of the circuit naming scheme used with Electrical Equipment.
 | IsValidCircuitNamingSchemeId | Verifies that the circuit naming scheme id can be used with Electrical Equipment.
Public method | IsValidDistributionSystem | Verifies that the Distribution System can be assigned to the Electrical Equipment.
Public method | SetCircuitNamingSchemeType | Sets the circuit naming scheme for Electrical Equipment.

See Also

ElectricalEquipment Class
Autodesk.Revit.DB.Electrical Namespace

GetCircuitNamingSchemeType Method

[image]