Revit 2021.1 API
Floor Members
Floor Class Methods Properties See Also Send Feedback

The Floor type exposes the following members.

Methods

 | Name | Description
Public method | GetNormalAtVerticalProjectionPoint | Return a surface normal on either the top or bottom face of a floor slab at a point corresponding to the vertical projection of an arbitrary point in project space.
Public method | GetSpanDirectionSymbolIds | Retrieves span direction symbol ElementIds.
Public method | GetVerticalProjectionPoint | Return a surface point on either the top or bottom face of a floor slab corresponding to the vertical projection of an arbitrary point in project space.

Properties

 | Name | Description
Public property | FloorType | Retrieves/set an object that represents the type of the floor.
Public property | SlabShapeEditor | Get the SlabShapeEditor used for slab shape editing.
Public property | SpanDirectionAngle | Retrieve the span direction angle of the floor

See Also

Floor Class

Floor Methods

[image] [image]