Revit 2021.1 API
RoutingPreferenceManager Methods
RoutingPreferenceManager Class See Also Send Feedback

The RoutingPreferenceManager type exposes the following members.

Methods

 | Name | Description
Public method | AddRule(RoutingPreferenceRuleGroupType, RoutingPreferenceRule) | Adds a new routing preference rule to the rule group.
Public method | AddRule(RoutingPreferenceRuleGroupType, RoutingPreferenceRule, Int32) | Adds a new routing preference rule to the specified position in the rule group.
Public method | Dispose |
Public method | GetMEPPartId | Gets a fitting or segment id of given routing preference group that meets the specified routing conditions.
Public method | GetNumberOfRules | The number of RoutingPreference rules in a group.
Public method | GetRule | Gets the specified rule.
Public method | GetSharedSizes | Gets a list of all segments of a given profile shape that define a given size.
Public method | RemoveRule | Removes an existing routing preference rule. Thrown if the index is out of bounds.

See Also

RoutingPreferenceManager Class

AddRule Method

[image] [image]