Revit 2021.1 API
EnergyAnalysisSurface Methods
EnergyAnalysisSurface Class See Also Send Feedback

The EnergyAnalysisSurface type exposes the following members.

Methods

 | Name | Description
Public method | GetAdjacentAnalyticalSpace | Gets the secondary adjacent analytical space this surface is associated with.
Public method | GetAnalyticalOpenings | Returns the analytical openings of the analytical surface.
Public method | GetAnalyticalSpace | Gets the primary analytical space this surface is associated with.
Public method | GetPolyloop | Gets the planar polygon describing the opening geometry.

See Also

EnergyAnalysisSurface Class
Autodesk.Revit.DB.Analysis Namespace

GetAdjacentAnalyticalSpace Method

[image]