Revit 2021.1 API
SubTransaction Members
SubTransaction Class Constructors Methods Properties See Also Send Feedback

The SubTransaction type exposes the following members.

Constructors

 | Name | Description
Public method | SubTransaction | Instantiates a sub-transaction object

Methods

 | Name | Description
Public method | Commit | Commits all changes made to the model made during the sub-transaction.
Public method | Dispose | Releases all resources used by the SubTransaction
Public method | GetStatus | Returns the current status of the sub-transaction.
Public method | HasEnded | Determines whether the sub-transaction has ended already.
Public method | HasStarted | Determines whether the sub-transaction has been started yet.
Public method | RollBack | Discards all changes made to the model during the sub-transaction.
Public method | Start | Starts the sub-transaction.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

SubTransaction Class

SubTransaction Constructor

[image]