Revit 2021.1 API
CustomExporter Properties
CustomExporter Class See Also Send Feedback

The CustomExporter type exposes the following members.

Properties

 | Name | Description
Public property | Export2DForceDisplayStyle | This value tells the exporter of 2D views to force the given display mode for the view.
Public property | Export2DGeometricObjectsIncludingPatternLines | This flag sets the exporter of 2D views to either include or exclude output of face pattern lines as part of geometric objects when the model is being processed by the export context.
Public property | Export2DIncludingAnnotationObjects | This flag sets the exporter of 2D views to either include or exclude output of annotation objects when the model is being processed by the export context.
Public property | IncludeGeometricObjects | This flag sets the exporter to either include or exclude output of geometric objects such as faces and curves when the model is being processed by the export context.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ShouldStopOnError | This flag instructs the exporting process to either stop or continue in case an error occurs during any of the exporting methods.

See Also

CustomExporter Class

Export2DForceDisplayStyle Property

[image]