Revit 2021.1 API
SiteSubRegion Members
SiteSubRegion Class Methods Properties See Also Send Feedback

The SiteSubRegion type exposes the following members.

Methods

 | Name | Description
 | Create(Document, IList<(Of <<'(CurveLoop>)>>)) | Creates a new SiteSubRegion element and adds it to the document.
 | Create(Document, IList<(Of <<'(CurveLoop>)>>), ElementId) | Creates a new SiteSubRegion element with assigned TopographySurface to be hosted and adds it to the document.
Public method | Dispose | Releases all resources used by the SiteSubRegion
Public method | GetBoundary | Gets the boundary of current subregion.
 | IsValidBoundary | Identifies whether the given curve loops compose a valid boundary.
Public method | SetBoundary | Set the given curve loops as the boundary of an existing SiteSubRegion.

Properties

 | Name | Description
Public property | HostId | The element id of the topography surface hosting this SiteSubRegion.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | TopographySurface | The TopographySurface element which this SiteSubRegion represents.

See Also

SiteSubRegion Class
Autodesk.Revit.DB.Architecture Namespace

SiteSubRegion Methods

[image] [image]