Revit 2021.1 API
RevitLinkType Methods
RevitLinkType Class See Also Send Feedback

The RevitLinkType type exposes the following members.

Methods

 | Name | Description
 | Create(Document, ExternalResourceReference, RevitLinkOptions) | Creates a new Revit link type from an external resource reference and loads the linked document.
 | Create(Document, ModelPath, RevitLinkOptions) | Creates a new Revit link type and loads the linked document.
 | CreateFromIFC(Document, ExternalResourceReference, String, Boolean, RevitLinkOptions) | Creates a new Revit link type from an existing Revit file created via import by reference of an asscoiated IFC file.
 | CreateFromIFC(Document, String, String, Boolean, RevitLinkOptions) | Creates a new Revit link type from an existing Revit file created via import by reference of an asscoiated IFC file.
Public method | GetChildIds | Gets the ids of the immediate children of this link.
Public method | GetConversionData | Returns the optional data that is necessary to generate the Revit file for this link.
Public method | GetLinkedFileStatus | Returns the LinkedFileStatus of this link.
Public method | GetParentId | Gets the id of this link's immediate parent.
Public method | GetPhaseMap | Returns a mapping between phases in the host document and phases in the linked document.
Public method | GetRootId | Gets the id of the top-level link which this link is linked into.
 | GetTopLevelLink(Document, ExternalResourceReference) | Returns the ElementId of the (top-level) linked model with the given ExternalResourceReference.
 | GetTopLevelLink(Document, ModelPath) | Returns the ElementId of the (top-level) linked model with the given path.
Public method | HasSaveablePositions | Determines whether the link has changes to shared positioning that could be saved.
Public method | IsFromLocalPath | Checks whether the Revit link uses a local path, such as a hard drive.
Public method | IsFromRevitServer | Checks whether the Revit link is located on Revit Server.
 | IsLoaded | Checks whether the link with this id is loaded.
Public method | IsNotLoadedIntoMultipleOpenDocuments | Checks whether the link is loaded into more than one open document in this session of Revit. If the link is loaded into multiple open documents, reload will be disabled.
Public method | Load | Loads or reloads the Revit link from its currently-stored location. If the link is an external resource, Revit will contact the IExternalResourceServer to get the latest version of the link.
Public method | LoadFrom(ExternalResourceReference, WorksetConfiguration) | Loads or reloads the Revit link. The link will be loaded from the location given in the input ExternalResourceReference.
Public method | LoadFrom(ModelPath, WorksetConfiguration) | Loads or reloads the Revit link from disk. The link will be loaded from the input path.
Public method | Reload | Loads or reloads the Revit link from its currently-stored location. If the link is an external resource, Revit will contact the IExternalResourceServer to get the latest version of the link.
Public method | RevertLocalUnloadStatus | Restores the workshared load status of a link that has been unloaded only for the current user, in a local copy of a workshared model.
Public method | SavePositions | Saves shared coordinates changes back to the linked document.
Public method | Unload | Unloads the Revit link.
Public method | UnloadLocally | Unloads a Revit link for the current user only.
Public method | UpdateFromIFC(Document, ExternalResourceReference, String, Boolean) | Updates a Revit link type from an IFC file and loads the linked document.
Public method | UpdateFromIFC(Document, String, String, Boolean) | Updates a Revit link type from an IFC file and loads the linked document.

See Also

RevitLinkType Class

Create Method

[image] [image]