Revit 2021.1 API
StairsRun Members
StairsRun Class Methods Properties See Also Send Feedback

The StairsRun type exposes the following members.

Methods

 | Name | Description
 | CreateSketchedRun | Creates a sketched run in the project document by providing a group of boundary curves and riser curves.
 | CreateSketchedRunWithSlopeData | Creates a sketched run in the project document by providing a group of boundary curves and riser curves, specifying slope type and height for boundary curves.
 | CreateSpiralRun | Creates a spiral run in the project document by providing the center, start angle and included angle.
 | CreateStraightRun | Creates a straight run in the project document.
Public method | GetAllSupports | Retrieves all supports hosted by the stair's run.
Public method | GetConnections | Returns information about the connections in which the stairs run participates. The stairs run may have no connection, or have at maximum two connections at the lower and upper ends.
Public method | GetFootprintBoundary | Returns the run's boundary curves which are projected on the stairs base level.
Public method | GetLeftSupports | Retrieves all supports on the left side of run boundaries.
Public method | GetNumberSystemReference | Gets the number system reference corresponding to the given reference options.
Public method | GetRightSupports | Retrieves all supports on the right side of run boundaries.
Public method | GetStairs | Returns the stairs to which the stairs run belongs.
Public method | GetStairsPath | Returns the stairs path curves on the run. The curves are projected on base level of the stairs.
 | SetLocationPathForSpiralRun | Set Location path for a spiral run.
 | SetLocationPathForStraightRun | Set location path for a straight run by giving a line.

Properties

 | Name | Description
Public property | ActualRisersNumber | The actual number of stairs risers in the stairs run.
Public property | ActualRunWidth | Specifies the value of the tread width excluding the width of independent side supports.
Public property | ActualTreadsNumber | The actual number of stairs treads in the stairs run.
Public property | BaseElevation | The base elevation of the stairs run.
Public property | BeginsWithRiser | True if the stairs run begins with a riser, false otherwise.
Public property | EndsWithRiser | True if the stairs run ends with a riser, false otherwise.
Public property | ExtensionBelowRiserBase | Specifies a value to extend/trim the run's first step against base elevation of the stairs if the stairs begins with a riser.
Public property | ExtensionBelowTreadBase | Specifies a value to extend/trim the run's first step against base elevation of the stairs if the stairs begins with a tread.
Public property | Height | The calculated height of the stairs run.
Public property | LocationLineJustification | The position of the run relative to the Up-direction path used to create the run.
Public property | StairsRunStyle | The style of the stairs run such as straight, winder, etc.
Public property | TopElevation | The top elevation of the stairs run.

See Also

StairsRun Class
Autodesk.Revit.DB.Architecture Namespace

StairsRun Methods

[image] [image]