Revit 2021.1 API
PerformanceAdviser..::..ExecuteRules Method (Document, IList<(Of <(<'Int32>)>)>)
PerformanceAdviser Class See Also Send Feedback
Executes selected rules on a given document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012

Syntax

C#
public IList<FailureMessage> ExecuteRules(
    Document document,
    IList<int> rules
)
Visual Basic
Public Function ExecuteRules ( _
    document As Document, _
    rules As IList(Of Integer) _
) As IList(Of FailureMessage)
Visual C++
public:
IList<FailureMessage^>^ ExecuteRules(
    Document^ document,
    IList<int>^ rules
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
Document on which the rules will be executed.
rules
Type: System.Collections.Generic..::..IList<(Of <(<'Int32>)>)>
Indices of rules to be executed.

Return Value

Failure messages explaining performance problems detected in the document.

Remarks

Disabled rules are not executed.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PerformanceAdviser Class
ExecuteRules Overload

GetAllRuleIds Method

[image]