Revit 2021.1 API
TopographySurface Members
TopographySurface Class Methods Properties See Also Send Feedback

The TopographySurface type exposes the following members.

Methods

 | Name | Description
Public method | AddPoints | Adds points to a topography surface.
 | ArePointsDistinct | Identify whether the input points are distinct in XY location.
Public method | AsSiteSubRegion | Obtains the subregion object represented by this element.
Public method | ChangePointElevation | Changes the elevation value for a point.
Public method | ChangePointsElevation | Changes the elevation value for points
Public method | ContainsPoint | Identifies whether the given point exists in the topography surface.
 | Create(Document, IList<(Of <<'(XYZ>)>>)) | Creates a new topography surface element and adds it to the document.
 | Create(Document, IList<(Of <<'(XYZ>)>>), IList<(Of <<'(PolymeshFacet>)>>)) | Creates a new topography surface element from facets and adds it to the document.
Public method | DeletePoints | Deletes points from a Topography surface.
Public method | FindPoints | Filters and returns only the points of the topography surface which lie within the input bounding box.
Public method | GetBoundaryPoints | Gets the points which are on the boundary of the topography surface.
Public method | GetHostedSubRegionIds | Gets the ids of all subregion elements hosted on this topography surface.
Public method | GetInteriorPoints | Gets all of the points that are not boundary points for the topography surface.
Public method | GetPoints | Gets the points that define this topography surface.
Public method | IsBoundaryPoint | Identifies whether the given point is an existing boundary point of the current topography surface.
 | IsValidFaceSet | Identifies whether the facets can construct a valid topography surface.
 | IsValidRegion | Identify whether the points can construct a valid region for a topography surface.
Public method | MovePoint | Moves a point in a TopographySurface to a new designated location.
Public method | MovePoints | Moves a collection of points in a topography surface by a designated vector.

Properties

 | Name | Description
Public property | ArePointsEditable | Identifies whether the points of this topography surface can be edited independently. Topography surfaces created from external data will not allow editing of individual points.
Public property | AssociatedBuildingPadId | The element id of the building pad which causes this topography surface to be formed.
Public property | IsAssociatedWithBuildingPad | Identifies if this element represents a topography surface associated with a building pad.
Public property | IsSiteSubRegion | Identifies if this element represents a subregion.
Public property | MaterialId | The id of the material applied to this element.

See Also

TopographySurface Class
Autodesk.Revit.DB.Architecture Namespace

TopographySurface Methods

[image] [image]