Revit 2021.1 API
ImageType Members
ImageType Class Methods Properties See Also Send Feedback

The ImageType type exposes the following members.

Methods

 | Name | Description
Public method | CanReload | Check whether the ImageType can be reloaded from file.
 | Create(Document, ImageTypeOptions) | Creates a new ImageType element and loads the image into it.
 | Create(Document, String) | Obsolete. Creates a new ImageType element and loads the image into it.
Public method | GetImage | Get the bitmap image stored in the image symbol.
Public method | IsLoadedFromFile | Obsolete. Checks whether the ImageType was loaded from a file. Revit may generate some ImageTypes internally, such as the ImageTypes created by "Save to Project as Image".
Public method | Reload | Reloads the ImageType from the file found at the location specified by the Path property, using the same PageNumber and resolution.
Public method | ReloadFrom(String) | Obsolete. Reloads the ImageType from a new image file.
Public method | ReloadFrom(ImageTypeOptions) | Reloads the image in the ImageType from a new image file, and for a new PageNumber.
Public method | Unload | Unload the linked image.

Properties

 | Name | Description
 | ExternalResourceType | The type of external resources that represents images.
Public property | Height | The vertical size of the image
Public property | HeightInPixels | Number of pixels in the vertical direction of the image
Public property | IsViewImage | Obsolete. The ImageType was created via "Save to Project as Image" function. For such ImageTypes the file path is an empty string.
Public property | PageNumber | The number of the page in a multi-page file, that was used to create the image in the ImageType.
Public property | Path | The path to the file from which the ImageType was loaded.
Public property | PathType | The path type that was used to refer to the file from which the ImageType was loaded.
Public property | Resolution | The size of the pixels in the image, expressed in dots-per-inch (dpi)
Public property | Source | The source of the image in the ImageType.
Public property | Status | The status of the image
Public property | Width | The horizontal size of the image
Public property | WidthInPixels | Number of pixels in the horizontal direction of the image

See Also

ImageType Class

ImageType Methods

[image] [image]