Revit 2021.1 API
IFCExtrusionCreationData Properties
IFCExtrusionCreationData Class See Also Send Feedback

The IFCExtrusionCreationData type exposes the following members.

Properties

 | Name | Description
Public property | AllowVerticalOffsetOfBReps | Allows vertical shifting of breps when moving towards the origin.
Public property | AreInnerRegionsOpenings | True if inner regions of the extrusion should become openings, false otherwise.
Public property | CustomAxis | The custom extrusion axis to try when generating an extrusion.
Public property | ExtrusionDirection | The extrusion direction to generate an extrusion.
Public property | ForceOffset | True to create new local placement with identity transform.
Public property | HasCustomAxis | Identifies if the data contains a custom extrusion axis.
Public property | HasExtrusionDirection | Identifies if the data contains a extrusion direction.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | PossibleExtrusionAxes | The axes to try when generating the properties of the extrusion.
Public property | ReuseLocalPlacement | Allows re-use of local placement when creating a new local placement due to shifting of breps when moving towards the origin.
Public property | ScaledArea | The area of the extrusion, scaled to the units of export.
Public property | ScaledHeight | The height of the extrusion, scaled to the units of export.
Public property | ScaledInnerPerimeter | The inner perimeter of the extrusion, scaled to the units of export.
Public property | ScaledLength | The length of the extrusion, scaled to the units of export.
Public property | ScaledOuterPerimeter | The outer perimeter of the extrusion, scaled to the units of export.
Public property | ScaledWidth | The width of the extrusion, scaled to the units of export.
Public property | Slope | The slope of the extrusion, in degrees.

See Also

IFCExtrusionCreationData Class
Autodesk.Revit.DB.IFC Namespace

AllowVerticalOffsetOfBReps Property

[image]