Revit 2021.1 API
Transform2D Properties
Transform2D Class See Also Send Feedback

The Transform2D type exposes the following members.

Properties

 | Name | Description
Public property | BasisU | The image of (1, 0) under OfVector(UV).
Public property | BasisV | The image of (0, 1) under OfVector(UV).
Public property | Determinant | The determinant of this transformation.
Public property | HasReflection | The boolean value that indicates whether this transformation produces reflection (i.e., is orientation-reversing).
Public property | IsConformal | The boolean value that indicates whether this transformation is conformal.
Public property | IsIdentity | The boolean value that indicates whether this transformation is an identity.
Public property | IsTranslation | The boolean value that indicates whether this transformation is a translation.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Origin | The image of (0, 0) under OfPoint(UV). This defines the translational part of the transform.
Public property | Scale | The real number that represents the scale of the conformal transformation.

See Also

Transform2D Class

BasisU Property

[image]