Revit 2021.1 API
Railing Properties
Railing Class See Also Send Feedback

The Railing type exposes the following members.

Properties

 | Name | Description
Public property | CanReset | True if the railing can be reset, False otherwise.
Public property | Flipped | Indicates if the railing is flipped.
Public property | HasHost | Indicates if the railing has a host.
Public property | HostId | The host of the railing.
Public property | IsDefault | Indicates if the railing is the default one that system generates.
Public property | TopRail | The top rail of the railing.

See Also

Railing Class
Autodesk.Revit.DB.Architecture Namespace

CanReset Property

[image]