Revit 2021.1 API
AnalysisDisplayMarkersAndTextSettings Members
AnalysisDisplayMarkersAndTextSettings Class Constructors Methods Properties See Also Send Feedback

The AnalysisDisplayMarkersAndTextSettings type exposes the following members.

Constructors

 | Name | Description
Public method | AnalysisDisplayMarkersAndTextSettings()()()() | Constructs a default instance of markers and text settings.
Public method | AnalysisDisplayMarkersAndTextSettings(AnalysisDisplayMarkersAndTextSettings) | Constructs a new copy of the input AnalysisDisplayMarkersAndTextSettings object.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the AnalysisDisplayMarkersAndTextSettings
Public method | IsEqual | Compares two colored surface settings objects.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | MarkerSize | Size of marker.
Public property | MarkerType | Type of marker.
Public property | Rounding | Increment to which numeric values of analysis results are rounded in markers.
Public property | TextLabelType | Type of diagram text label visualization.
Public property | TextTypeId | Element id of text associated with the settings.

See Also

AnalysisDisplayMarkersAndTextSettings Class
Autodesk.Revit.DB.Analysis Namespace

AnalysisDisplayMarkersAndTextSettings Constructor

[image] [image]