Revit 2021.1 API
ConceptualConstructionType Members
ConceptualConstructionType Class Methods Properties See Also Send Feedback

The ConceptualConstructionType type exposes the following members.

Methods

Name | Description
GetAllConceptualConstructionsForCategory
Get all the ids of constructions applicable to the input massSubCategory
GetFloorOrSlabConstructionType
Get a Floor or Slab ConceptualConstructionType by its ConceptualConstructionFloorSlabType.
Public method GetGBSId
Gets the Green Building Studio identifier associated with the construction.
GetOpeningConstructionType
Get an Opening ConceptualConstructionType by its ConceptualConstructionOpeningType.
GetRoofConstructionType
Get a Roof ConceptualConstructionType by its ConceptualConstructionRoofType.
GetShadeConstructionType
Get a Shade ConceptualConstructionType by its ConceptualConstructionShadeType.
GetWallConstructionType
Get a Wall ConceptualConstructionType by its ConceptualConstructionWallType.
GetWindowOrSkylightConstructionType
Get a Window or Skylight ConceptualConstructionType by its ConceptualConstructionWindowSkylightType.
IsValidConceptualConstructionId
Indicates if the ElementId is an id of a ConceptualConstructionType.
IsValidConceptualConstructionIdForCategory
Indicate if a ConceptualConstruction is appropriate to assign to a MassSurfaceData of a particular Mass subcategory.
IsValidSubcategoryForMassSurfaceDatas
Validate if a subcategory is appropriate for assignment to Massing surfaces (MassSurfaceData). This is the list of acceptable values:
  1. OST_MassInteriorWall
  2. OST_MassExteriorWall
  3. OST_MassExteriorWallUnderground
  4. OST_MassRoof
  5. OST_MassFloor
  6. OST_MassSlab
  7. OST_MassShade
  8. OST_MassGlazing
  9. OST_MassSkylights
  10. OST_MassOpening
Public method IsValidSurfaceSubcategoryForConstruction
Indicates if this ConceptualConstructionType is appropriate for the input MassSurfaceData subcategory.

Properties

 | Name | Description
Public property | MassSurfaceSubCategoryId | The surface type subcategory element id associated with the ConceptualConstructionType.
Public property | MaterialId | Material used for visualization of this construction.

See Also

ConceptualConstructionType Class
Autodesk.Revit.DB.Analysis Namespace

ConceptualConstructionType Methods

[image] [image]