Revit 2021.1 API
BeamSystem Methods
BeamSystem Class See Also Send Feedback

The BeamSystem type exposes the following members.

Methods

 | Name | Description
 | BeamBelongsTo | Find out the BeamSystem to which the beam belongs.
 | Create(Document, IList<(Of <<'(Curve>)>>), SketchPlane, Int32) | Creates a 2D BeamSystem with specified profile curves.
 | Create(Document, IList<(Of <<'(Curve>)>>), Level, XYZ, Boolean) | Creates a new BeamSystem with specified profile curves.
 | Create(Document, IList<(Of <<'(Curve>)>>), Level, Int32, Boolean) | Creates a new BeamSystem with specified profile curves.
 | Create(Document, IList<(Of <<'(Curve>)>>), SketchPlane, XYZ, Boolean) | Creates a new BeamSystem with specified profile curves.
 | DropBeamSystem | Drop beam system, it will disassociate all members from the beam system and delete the beam system.
Public method | GetBeamIds | Gets all the beams of the BeamSystem.

See Also

BeamSystem Class

BeamBelongsTo Method

[image]