Revit 2021.1 API
IFCAggregate Members
IFCAggregate Class Methods Properties See Also Send Feedback

The IFCAggregate type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an element to the aggregate.
Public method | AddAggregate | Creates a nested aggregate and adds it to the aggregate.
Public method | Delete | Delete the aggregate object from the IFCFile model.
Public method | Dispose | Releases all resources used by the IFCAggregate
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetIFCAggregateIterator | Returns a IFCAggregateIterator that iterates through the collection.

Properties

 | Name | Description
Public property | Count | The number of the data values in the aggregate.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Item | Get the IFCData for this aggregate.

See Also

IFCAggregate Class
Autodesk.Revit.DB.IFC Namespace

IFCAggregate Methods

[image] [image]