Revit 2021.1 API
ExternalDefinition Members
ExternalDefinition Class Methods Properties See Also Send Feedback

The ExternalDefinition type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ExternalDefinition

Properties

 | Name | Description
Public property | Description | The description of the parameter. The description will be used as tooltip in the Revit UI including in the properties palette.
Public property | GUID | Returns the GUID associated with the shared parameter definition.
Public property | HideWhenNoValue | Indicates whether this parameter should be hidden from the properties palette when it has no value.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Name | The user visible name for the parameter. (Overrides Definition..::..Name.)
Public property | OwnerGroup | Returns or change the group ID of the external parameter definition.
Public property | ParameterGroup | Returns the group ID of the parameter definition. (Overrides Definition..::..ParameterGroup.)
Public property | ParameterType | Returns the user visible interpretation of the parameter data. (Overrides Definition..::..ParameterType.)
Public property | UserModifiable | Indicates whether the parameter can be modified by the user interface.
Public property | Visible | Indicates if the parameter is visible in the Autodesk Revit user interface.

See Also

ExternalDefinition Class

ExternalDefinition Methods

[image] [image]