Revit 2021.1 API
UnitUtils..::..ConvertFromInternalUnits Method (Double, ForgeTypeId)
UnitUtils Class See Also Send Feedback
Converts a value from Revit's internal units to a given unit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014

Syntax

C#
public static double ConvertFromInternalUnits(
    double value,
    ForgeTypeId unitTypeId
)
Visual Basic
Public Shared Function ConvertFromInternalUnits ( _
    value As Double, _
    unitTypeId As ForgeTypeId _
) As Double
Visual C++
public:
static double ConvertFromInternalUnits(
    double value,
    ForgeTypeId^ unitTypeId
)

Parameters

value
Type: System..::..Double
The value to convert.
unitTypeId
Type: Autodesk.Revit.DB..::..ForgeTypeId
Identifier of the desired unit.

Return Value

The converted value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given value for value is not finite -or- unitTypeId is not a unit identifier. See UnitUtils.IsUnit(ForgeTypeId) and UnitUtils.GetUnitTypeId(DisplayUnitType).
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

UnitUtils Class
ConvertFromInternalUnits Overload

ConvertToInternalUnits Method

[image] [image]