Revit 2021.1 API
IFCData Members
IFCData Class Constructors Methods Operators Properties See Also Send Feedback

The IFCData type exposes the following members.

Constructors

 | Name | Description
Public method | IFCData | Creates a copy object.

Methods

 | Name | Description
Public method | AsAggregate | Gets storage value as IFCAggregate when its PrimitiveType is aggregate.
Public method | AsBoolean | Gets storage value as boolean when its PrimitiveType is boolean.
Public method | AsDouble | Gets storage value as double when its PrimitiveType is double.
Public method | AsInstance | Gets storage value as IFCAnyHandle when its PrimitiveType is instance.
Public method | AsInteger | Gets storage value as integer when its PrimitiveType is integer.
Public method | AsLogical | Gets storage value as IFCLogical when its PrimitiveType is logical.
Public method | AsString | Gets storage value as string when its PrimitiveType is string, binary or enumeration.
 | CreateBinary | Creates a binary data object.
 | CreateBoolean | Creates a boolean data object.
 | CreateBooleanOfType | Creates a boolean data object of the specified type.
 | CreateDouble | Creates a double data object.
 | CreateDoubleOfType | Creates a double data object of the specified type.
 | CreateEnumeration | Creates a enum data object.
 | CreateIFCAggregate | Creates an IFCAggregate data object.
 | CreateIFCAnyHandle | Creates an IFCAnyHandle data object.
 | CreateInteger | Creates an integer data object.
 | CreateIntegerOfType | Creates an integer data object of the specified type.
 | CreateLogical | Creates a logical data object.
 | CreateLogicalOfType | Creates a logical data object of the specified type.
 | CreateString | Creates a string data object.
 | CreateStringOfType | Creates a string data object of the specified type.
Public method | Dispose | Releases all resources used by the IFCData
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | GetHashCode | Gets the hash code. (Overrides Object..::..GetHashCode()()()().)
Public method | GetSimpleType | Gets the IFC type name.
Public method | GetTypeList | Gets the multiple strings represent one IFC type name.
Public method | HasSimpleType | Determines if there is one corresponding IFC type.
Public method | SetSimpleType | Sets the corresponding IFC type by its name.
Public method | SetTypeList |

Operators

Name | Description
Equality | Determines whether two IFCDatas are the same.
Inequality | Determines whether two IFCDatas are different.

Properties

 | Name | Description
Public property | HasValue | Identifies if the data is empty or contains a value.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | PrimitiveType | The primitive data type.

See Also

IFCData Class
Autodesk.Revit.DB.IFC Namespace

IFCData Constructor

[image]