Revit 2021.1 API
ViewSystemsAnalysisReport Methods
ViewSystemsAnalysisReport Class See Also Send Feedback

The ViewSystemsAnalysisReport type exposes the following members.

Methods

 | Name | Description
 | Create | Creates a new view for the systems analysis report.
 | GetLatestSystemsAnalysisReport | Gets the latest report of systems analysis.
Public method | GetReportContent | Gets the report content in this view.
Public method | IsAnalysisCompleted | Indicates if the background systems analysis has completed or not.
Public method | RequestSystemsAnalysis | Requests a new systems analysis in the background.

See Also

ViewSystemsAnalysisReport Class
Autodesk.Revit.DB.Analysis Namespace

Create Method

[image]