Revit 2021.1 API
ScheduleFilter Methods
ScheduleFilter Class See Also Send Feedback

The ScheduleFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | GetDoubleValue | Gets the filter value for a filter using a double value.
Public method | GetElementIdValue | Gets the filter value for a filter using an ElementId value.
Public method | GetIntegerValue | Gets the filter value for a filter using an integer value.
Public method | GetStringValue | Gets the filter value for a filter using a string value.
Public method | SetNullValue | Sets the filter to have no specified value (used for HasParameter filters).
Public method | SetValue(Double) | Set the filter value to a double.
Public method | SetValue(Int32) | Set the filter value to an integer.
Public method | SetValue(String) | Set the filter value to a string.
Public method | SetValue(ElementId) | Set the filter value to an ElementId.

See Also

ScheduleFilter Class

Dispose Method

[image]