Revit 2021.1 API
Entity..::..Get<(Of <(<'FieldType>)>)> Method (String)
Entity Class See Also Send Feedback
Retrieves the value of the field in the entity.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012

Syntax

C#
public FieldType Get<FieldType>(
    string fieldName
)
Visual Basic
Public Function Get(Of FieldType) ( _
    fieldName As String _
) As FieldType
Visual C++
public:
generic<typename FieldType>
FieldType Get(
    String^ fieldName
)

Parameters

fieldName
Type: System..::..String
The name of the field to retrieve.

Type Parameters

FieldType
The type of the field

Remarks

The template parameter must match the type of the field (specified when creating the Schema) exactly; this method does not perform data type conversions. The types for containers are IList for arrays and IDictionary for maps.

This method is a shortcut that will look up the field by name. If you want to call it on many entities, it is faster if you look up the field yourself.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | The Field belongs to a different Schema from this Entity, or this Entity is invalid.
Autodesk.Revit.Exceptions..::..ArgumentException | Requested type does not match the field type.
Autodesk.Revit.Exceptions..::..ArgumentException | The name matches no field in this Entity's Schema.
Autodesk.Revit.Exceptions..::..ArgumentException | For floating-point fields, use the overload taking a ForgeTypeId parameter.
Autodesk.Revit.Exceptions..::..ArgumentException | This field's subschema prevents reading.

See Also

Entity Class
Get Overload
Autodesk.Revit.DB.ExtensibleStorage Namespace

Get(FieldType) Method (Field)

[image]