Revit 2021.1 API
ElectricalDemandFactorDefinition Members
ElectricalDemandFactorDefinition Class Constructors Methods Properties See Also Send Feedback

The ElectricalDemandFactorDefinition type exposes the following members.

Constructors

 | Name | Description
Public method | ElectricalDemandFactorDefinition | Constructs a new ElectricalDemandFactorDefinition with default settings.

Methods

 | Name | Description
Public method | AddValue | Adds a value to the value set for this demand factor definition
Public method | ClearValues | Clears all the values stored for this demand factor definition.
 | Create | Creates a new instance of a demand factor definition.
Public method | GetApplicableDemandFactor | This method will return the applicable demand factor for the specified number of devices or load.
Public method | GetValues | Provides access to the value set stored with this demand factor definition
Public method | GetValuesCount | Returns the number of values in the set.
Public method | RemoveValue | Removes a value to the value set for this demand factor definition
Public method | SetValues | Sets the value set to the demand factor definition.

Properties

 | Name | Description
Public property | AdditionalLoad | Additional load to be included during demand load calculation.
Public property | IncludeAdditionalLoad | Should the additional load (if set) be included in demand load calculations.
Public property | RuleType | The rule type for this demand factor definition.

See Also

ElectricalDemandFactorDefinition Class
Autodesk.Revit.DB.Electrical Namespace

ElectricalDemandFactorDefinition Constructor

[image]