Revit 2021.1 API
PolylineSegments Members
PolylineSegments Class Methods Properties See Also Send Feedback

The PolylineSegments type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the PolylineSegments
Public method | GetVertices | Returns an array of vertices of the polyline segments.

Properties

 | Name | Description
Public property | EndLocalParameter | Local parameter associated with the end point.
Public property | EndParameter | Parameter associated with the end point.
Public property | IsFilled | Indicates whether the area enclosed by the polyline is to be filled or not.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LineProperties | Access to the line (pen) properties of the polyline
Public property | StartLocalParameter | Local parameter associated with the start point.
Public property | StartParameter | Parameter associated with the start point.

See Also

PolylineSegments Class

PolylineSegments Methods

[image] [image]