Revit 2021.1 API
PathOfTravel..::..CreateMultiple Method (View, IList<(Of <(<'XYZ>)>)>, IList<(Of <(<'XYZ>)>)>)
PathOfTravel Class See Also Send Feedback
Creates multiple new paths of travel between same size sets of start and end points.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2020

Syntax

C#
public static IList<PathOfTravel> CreateMultiple(
    View DBView,
    IList<XYZ> pathStarts,
    IList<XYZ> pathEnds
)
Visual Basic
Public Shared Function CreateMultiple ( _
    DBView As View, _
    pathStarts As IList(Of XYZ), _
    pathEnds As IList(Of XYZ) _
) As IList(Of PathOfTravel)
Visual C++
public:
static IList<PathOfTravel^>^ CreateMultiple(
    View^ DBView,
    IList<XYZ^>^ pathStarts,
    IList<XYZ^>^ pathEnds
)

Parameters

DBView
Type: Autodesk.Revit.DB..::..View
The floor plan view to use when computing the shortest distance.
pathStarts
Type: System.Collections.Generic..::..IList<(Of <(<' XYZ >)>)>
The start points of the path. The input Z coordinates are ignored and set to the view's level elevation.
pathEnds
Type: System.Collections.Generic..::..IList<(Of <(<' XYZ >)>)>
The end points of the path. The input Z coordinates are ignored and set to the view's level elevation.

Return Value

The array of newly created path of travel elements, or nullNothingnullptra null reference (Nothing in Visual Basic) if no path between the two points is found. The order of elements corresponds to the order of start/end points in the argument arrays. There are some additional conditions that are checked and if any condition is true the nullNothingnullptra null reference (Nothing in Visual Basic) value is returned:
  • View has crop box active and start or end point lies outside of the crop
  • Start and end points are too close

Remarks

InvalidOperationException is thrown if PathOfTravel cannot be created for the following conditions:
  • View has crop box active and crop box is split
  • View model outline area is larger than the current limit (2,000,000 sq.ft.)
  • View export contains too much geometry (more than 200,000 lines)
ArgumentException exception is thrown if arrays of start and end points are of different size or if the total number of paths of travel attempted to be created is more than maximum allowed (50000).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | View is not in a family or a document in in-place edit mode. -or- View is not a floor plan view.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | The document containing DBView is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- This operation cannot be performed while the document is in edit mode. -or- The Path of Travel calculation service is not available -or- This functionality is not available in Revit LT.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document containing DBView is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document containing DBView is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document containing DBView has no open transaction.

See Also

PathOfTravel Class
CreateMultiple Overload
Autodesk.Revit.DB.Analysis Namespace

CreateMultiple Method (View, IList(XYZ), IList(XYZ), IList(PathOfTravelCalculationStatus))

[image]