Revit 2021.1 API
IFCGeometryInfo Members
IFCGeometryInfo Class Methods Properties See Also Send Feedback

The IFCGeometryInfo type exposes the following members.

Methods

 | Name | Description
 | CreateCurveGeometryInfo | Creates a new container object which holds IfcCurve handles processed from a Revit geometry object.
 | CreateFaceGeometryInfo(Double) | Creates a new container object which holds IfcFace handles processed from a Revit geometry object.
 | CreateFaceGeometryInfo(Double, Boolean) | Creates a new container object which holds IfcFace handles processed from a Revit geometry object.
 | CreateFaceGeometryInfo(ExporterIFC, Plane, XYZ, Double, Boolean) | Creates a new container object which holds IfcFace handles processed from a Revit geometry object.
 | CreateSurfaceGeometryInfo | Creates a new container object which holds IfcSurface handles processed from a Revit geometry object.
Public method | Dispose | Releases all resources used by the IFCGeometryInfo
Public method | GetCurves | Gets the IfcCurve handles created representing the processed geometry and stored in this object.
Public method | GetFaces | Gets the IfcFace handles created representing the processed geometry and stored in this object.
Public method | GetRepresentations | Gets the representation handles created representing the processed geometry and stored in this object.
Public method | GetSurfaces | Gets the IfcSurface handles created representing the processed geometry and stored in this object.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

IFCGeometryInfo Class
Autodesk.Revit.DB.IFC Namespace

IFCGeometryInfo Methods

[image] [image]