Revit 2021.1 API
ImporterIFC Methods
ImporterIFC Class See Also Send Feedback

The ImporterIFC type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | GetOptions | Gets the collection of named options set by the importer client.
Public method | ProcessIFCProject(IFCAnyHandle) | The entry point to the native IFC import function. Processes the main IfcProject and creates appropriate Revit elements.
Public method | ProcessIFCProject(IFCAnyHandle, IDictionary<(Of <<'(IFCAnyHandle, ElementId>)>>)) |
Public method | SetFile | Sets the handle to the IFC file being created during this import operation.

See Also

ImporterIFC Class
Autodesk.Revit.DB.IFC Namespace

Dispose Method

[image]