Revit 2021.1 API
Parameter Properties
Parameter Class See Also Send Feedback

The Parameter type exposes the following members.

Properties

 | Name | Description
Public property | Definition | Returns the Definition object that describes the data type, name and other details of the parameter.
Public property | DisplayUnitType | Obsolete. Get the display unit type of the parameter object.
Public property | Element | The element to which this parameter belongs.
Public property | GUID | The Guid for a shared parameter.
Public property | HasValue | Identifies if the parameter has an assigned value.
Public property | Id | The id of the parameter.
Public property | IsReadOnly | Get the readonly property of the parameter. (Overrides APIObject..::..IsReadOnly.)
Public property | IsShared | Identifies if the parameter is a shared parameter.
Public property | StorageType | Describes the type that is used internally within the parameter to store its value.
Public property | UserModifiable | Indicates whether the interactive user can modify the value of this parameter.

See Also

Parameter Class

Definition Property

[image]