Revit 2021.1 API
ReferencePointArray Members
ReferencePointArray Class Constructors Methods Properties See Also Send Feedback

The ReferencePointArray type exposes the following members.

Constructors

 | Name | Description
Public method | ReferencePointArray | Initializes a new instance of the ReferencePointArray class

Methods

 | Name | Description
Public method | Append |
Public method | Clear | Removes every reference from the array, rendering it empty.
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | Item | Gets or sets a reference at a specified index within the array.
Public property | Size | Returns the number of references that are in the array.

See Also

ReferencePointArray Class

ReferencePointArray Constructor

[image]