Revit 2021.1 API
BeamSystem..::..Create Method (Document, IList<(Of <(<'Curve>)>)>, SketchPlane, XYZ, Boolean)
BeamSystem Class See Also Send Feedback
Creates a new BeamSystem with specified profile curves.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014

Syntax

C#
public static BeamSystem Create(
    Document document,
    IList<Curve> profile,
    SketchPlane sketchPlane,
    XYZ direction,
    bool is3d
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    profile As IList(Of Curve), _
    sketchPlane As SketchPlane, _
    direction As XYZ, _
    is3d As Boolean _
) As BeamSystem
Visual C++
public:
static BeamSystem^ Create(
    Document^ document,
    IList<Curve^>^ profile,
    SketchPlane^ sketchPlane,
    XYZ^ direction,
    bool is3d
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which the new BeamSystem is created.
profile
Type: System.Collections.Generic..::..IList<(Of <(<' Curve >)>)>
The profile of the BeamSystem.
sketchPlane
Type: Autodesk.Revit.DB..::..SketchPlane
The work-plane for the BeamSystem.
direction
Type: Autodesk.Revit.DB..::..XYZ
The direction is the direction of the BeamSystem.
is3d
Type: System..::..Boolean
Whether the BeamSystem is 3D. If the BeamSystem is 3D, the sketchPlane must be a level, otherwise an exception will be thrown.

Return Value

If successful, a new BeamSystem object will be returned.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | SketchPlane is not valid for BeamSystem creation. -or- The input profile contains at least one helical curve and is not supported for this operation. -or- The profile curves must be in the sketch plane.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | The BeamSystem is 3D, but the SketchPlane is not a level.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

BeamSystem Class
Create Overload

DropBeamSystem Method

[image]