Revit 2021.1 API
FilteredElementIterator Methods
FilteredElementIterator Class See Also Send Feedback

The FilteredElementIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | GetCurrent | The current element found by the iterator.
Public method | IsDone | Identifies if the iteration has completed.
Public method | MoveNext | Increments the iterator to the next element passing the filter.
Public method | Reset | Resets the iterator to the beginning.

See Also

FilteredElementIterator Class

Dispose Method

[image]