Revit 2021.1 API
Stairs Members
Stairs Class Methods Properties See Also Send Feedback

The Stairs type exposes the following members.

Methods

 | Name | Description
Public method | GetAssociatedRailings | Gets a list of the Railing elements which are associated to the boundaries of the stairs.
Public method | GetStairsLandings | Returns all the stairs landing components in the stairs.
Public method | GetStairsRuns | Returns all the stairs run components in the stairs.
Public method | GetStairsSupports | Returns all the stairs support components in the stairs.
 | IsByComponent | Indicates if the stairs is created by stairs components(runs, landings and supports).
Public method | IsInEditMode | Indicates whether the stairs is in edit mode or not.

Properties

 | Name | Description
Public property | ActualRiserHeight | The actual height of the stairs risers in the stairs.
Public property | ActualRisersNumber | The total number of actually created risers in model.
Public property | ActualTreadDepth | The actual depth of the stairs treads in the stairs, actual tread depth is equal to minimum tread depth by default.
Public property | ActualTreadsNumber | The number of treads actually created in the stairs.
Public property | BaseElevation | The base elevation of the stairs.
Public property | DesiredRisersNumber | The number of risers is calculated based on the height between levels.
Public property | Height | The height of the stair between the base and top levels.
Public property | MultistoryStairsId | The id of the MultistoryStairs element to which this element belongs. If this stairs element is not a member of a MultistoryStairs element, this will be InvalidElementId.
Public property | NumberOfStories | The number of stories of a multi-story stair, or 1 for a single-story stair.
Public property | TopElevation | The top elevation of the stairs.

See Also

Stairs Class
Autodesk.Revit.DB.Architecture Namespace

Stairs Methods

[image] [image]