Revit 2021.1 API
BuildingPad Members
BuildingPad Class Methods Properties See Also Send Feedback

The BuildingPad type exposes the following members.

Methods

 | Name | Description
 | Create | Creates a new BuildingPad element and adds it to the document.
Public method | GetBoundary | Gets the boundary of current BuildingPad element.
Public method | SetBoundary | Set a given curve loops as the boundary of the current BuildingPad element.

Properties

 | Name | Description
Public property | AssociatedTopographySurfaceId | The element id of a topography surface created by the introduction of this building pad.
Public property | HostId | The element id of the topography surface hosting this BuidlingPad.

See Also

BuildingPad Class
Autodesk.Revit.DB.Architecture Namespace

BuildingPad Methods

[image] [image]