Revit 2021.1 API
ImporterIFC Members
ImporterIFC Class Methods Properties See Also Send Feedback

The ImporterIFC type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ImporterIFC
Public method | GetOptions | Gets the collection of named options set by the importer client.
Public method | ProcessIFCProject(IFCAnyHandle) | The entry point to the native IFC import function. Processes the main IfcProject and creates appropriate Revit elements.
Public method | ProcessIFCProject(IFCAnyHandle, IDictionary<(Of <<'(IFCAnyHandle, ElementId>)>>)) |
Public method | SetFile | Sets the handle to the IFC file being created during this import operation.

Properties

 | Name | Description
Public property | Document | Gets the document associated with the import.
Public property | FullFileName | The full file name of the IFC file to be import.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

ImporterIFC Class
Autodesk.Revit.DB.IFC Namespace

ImporterIFC Methods

[image] [image]