Revit 2021.1 API
ReferenceWithContext Members
ReferenceWithContext Class Methods Properties See Also Send Feedback

The ReferenceWithContext type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ReferenceWithContext
Public method | GetInstanceTransform | Gets the transform of the instance.
Public method | GetReference | Gets the reference of the geometric object.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Proximity | The proximity value to the ray's origin when the reference is returned by FindReferencesWithContextByDirection(XYZ, XYZ, View3D) or ReferenceIntersector.Find(XYZ, XYZ).

See Also

ReferenceWithContext Class

ReferenceWithContext Methods

[image] [image]