Revit 2021.1 API
CircleLightShape Members
CircleLightShape Class Constructors Methods Properties See Also Send Feedback

The CircleLightShape type exposes the following members.

Constructors

 | Name | Description
Public method | CircleLightShape()()()() | Creates a circle light shape object with 2.0' emit diameter.
Public method | CircleLightShape(Double) | Creates a circle light shape object with the given emit diameter.
Public method | CircleLightShape(CircleLightShape) | Creates a copy of the given circle light shape

Methods

 | Name | Description

Properties

 | Name | Description
Public property | EmitDiameter | The emit diameter.

See Also

CircleLightShape Class
Autodesk.Revit.DB.Lighting Namespace

CircleLightShape Constructor

[image] [image]