Revit 2021.1 API
MacroManagerIterator Members
MacroManagerIterator Class Methods Properties See Also Send Feedback

The MacroManagerIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the MacroManagerIterator
Public method | GetCurrent | Returns the current Macro module.
Public method | IsDone | Identifies if the iteration has completed.
Public method | MoveNext | Increments the iterator to the next item.
Public method | Reset | Resets the iterator to the initial state.

Properties

 | Name | Description
Public property | Current | Gets the item at the current position of the iterator.
Protected property | CurrentObject |
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

MacroManagerIterator Class
Autodesk.Revit.DB.Macros Namespace

MacroManagerIterator Methods

[image] [image]