Revit 2021.1 API
Entity Members
Entity Class Constructors Methods Properties See Also Send Feedback

The Entity type exposes the following members.

Constructors

 | Name | Description
Public method | Entity()()()() | The default-constructed Entity is invalid.
Public method | Entity(Guid) | Creates a new Entity corresponding to the Schema of the specified GUID.
Public method | Entity(Entity) | Constructs a new copy of the input ESEntity object.
Public method | Entity(Schema) | Creates a new Entity corresponding to the Schema.

Methods

 | Name | Description
Public method | Clear(String) | Resets the field to its default value.
Public method | Clear(Field) | Resets the field to its default value.
Public method | Dispose | Releases all resources used by the Entity
Public method | Get<(Of <<'(FieldType>)>>)(String) | Retrieves the value of the field in the entity.
Public method | Get<(Of <<'(FieldType>)>>)(Field) | Retrieves the value of the field in the entity.
Public method | Get<(Of <<'(FieldType>)>>)(String, DisplayUnitType) | Obsolete. Retrieves the value of the field in the entity.
Public method | Get<(Of <<'(FieldType>)>>)(String, ForgeTypeId) | Retrieves the value of the field in the entity.
Public method | Get<(Of <<'(FieldType>)>>)(Field, DisplayUnitType) | Obsolete. Retrieves the value of the field in the entity.
Public method | Get<(Of <<'(FieldType>)>>)(Field, ForgeTypeId) | Retrieves the value of the field in the entity.
Public method | IsValid | Checks whether this Entity has a live Schema corresponding to it.
Public method | ReadAccessGranted | Checks whether this Entity may be retrieved by the current add-in.
Public method | RecognizedField | Checks whether a Field belongs to the same Schema as this Entity.
Public method | Set<(Of <<'(FieldType>)>>)(String, FieldType) | Stores the value of the field in the entity.
Public method | Set<(Of <<'(FieldType>)>>)(Field, FieldType) | Stores the value of the field in the entity.
Public method | Set<(Of <<'(FieldType>)>>)(String, FieldType, DisplayUnitType) | Obsolete. Stores the value of the field in the entity.
Public method | Set<(Of <<'(FieldType>)>>)(String, FieldType, ForgeTypeId) | Stores the value of the field in the entity.
Public method | Set<(Of <<'(FieldType>)>>)(Field, FieldType, DisplayUnitType) | Obsolete. Stores the value of the field in the entity.
Public method | Set<(Of <<'(FieldType>)>>)(Field, FieldType, ForgeTypeId) | Stores the value of the field in the entity.
Public method | WriteAccessGranted | Checks whether this Entity may be stored by the current add-in.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Schema | The Schema describing this Entity.
Public property | SchemaGUID | The GUID of the Schema describing this Entity.

See Also

Entity Class
Autodesk.Revit.DB.ExtensibleStorage Namespace

Entity Constructor

[image] [image]