Revit 2021.1 API
Transform Properties
Transform Class See Also Send Feedback

The Transform type exposes the following members.

Properties

 | Name | Description
Public property | Basis | Defines the basis of the old coordinate system in the new coordinate system.
Public property | BasisX | The basis of the X axis of this transformation.
Public property | BasisY | The basis of the Y axis of this transformation.
Public property | BasisZ | The basis of the Z axis of this transformation.
Public property | Determinant | The determinant of this transformation.
Public property | HasReflection | The boolean value that indicates whether this transformation produces reflection.
 | Identity | The identity transformation.
Public property | Inverse | The inverse transformation of this transformation.
Public property | IsConformal | The boolean value that indicates whether this transformation is conformal.
Public property | IsIdentity | The boolean value that indicates whether this transformation is an identity.
Public property | IsTranslation | The boolean value that indicates whether this transformation is a translation.
Public property | Origin | Defines the origin of the old coordinate system in the new coordinate system.
Public property | Scale | The real number that represents the scale of the transformation.

See Also

Transform Class

Basis Property

[image]