Revit 2021.1 API
Railing Members
Railing Class Methods Properties See Also Send Feedback

The Railing type exposes the following members.

Methods

Name | Description
Create(Document, CurveLoop, ElementId, ElementId)
Creates a new railing by specifying the railing path in the project document.
Create(Document, ElementId, ElementId, RailingPlacementPosition)
Automatically creates new railings with the specified railing type on all sides of a stairs or ramp element.
Create(Document, ElementId, ElementId, ElementId, RailingPlacementPosition)
Creates new railings with the specified railing type on all sides of a stairs instance in a MultistoryStairs element.
Public method Flip
Flips the railing.
Public method GetHandRails
Get all the handrails of the railing.
Public method GetMultistoryStairsPlacementLevels
Gets the ids of the base levels of the stairs upon which this railing is placed.
Public method GetPath
Gets the railing path.
Public method GetSubelementOnLevel
Gets the subelement on given level.
IsValidHostForNewRailing
Checks whether new railing can be created and placed on the specified host.
IsValidPathForRailing
Checks whether a railing can be created along a railing path.
Public method RailingCanBeHostedByElement
Checks whether the specified element can be used as a host for the railing. The host can be:
  • stairs
  • stairs component
  • ramp
  • floor
  • slab edge
  • wall
  • roof
Public method RemoveHost
Removes the association between the railing and its host.
Public method Reset
Resets the railing to the default one that the system generates.
Public method ResetSupportPosition
Resets the continuous rails support subelements position data.
Public method SetMultistoryStairsPlacementLevels
Sets the ids of the base levels of the stairs upon which this railing is placed.
Public method SetPath
Sets the railing path.

Properties

 | Name | Description
Public property | CanReset | True if the railing can be reset, False otherwise.
Public property | Flipped | Indicates if the railing is flipped.
Public property | HasHost | Indicates if the railing has a host.
Public property | HostId | The host of the railing.
Public property | IsDefault | Indicates if the railing is the default one that system generates.
Public property | TopRail | The top rail of the railing.

See Also

Railing Class
Autodesk.Revit.DB.Architecture Namespace

Create Method

[image] [image]