Revit 2021.1 API
PathOfTravel..::..UpdateMultiple Method (Document, IList<(Of <(<'ElementId>)>)>)
PathOfTravel Class See Also Send Feedback
Updates the specified paths of travel by recalculating each path using their original start and end points.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2020

Syntax

C#
public static int UpdateMultiple(
    Document adoc,
    IList<ElementId> elementsToUpdate
)
Visual Basic
Public Shared Function UpdateMultiple ( _
    adoc As Document, _
    elementsToUpdate As IList(Of ElementId) _
) As Integer
Visual C++
public:
static int UpdateMultiple(
    Document^ adoc,
    IList<ElementId^>^ elementsToUpdate
)

Parameters

adoc
Type: Autodesk.Revit.DB..::..Document
Document of elements to be updated.
elementsToUpdate
Type: System.Collections.Generic..::..IList<(Of <(<' ElementId >)>)>
The list of ElementIdof the paths to update.

Return Value

number of successfully updated elements

Remarks

For unsuccessfully updated elements, Revit will post warnings.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | This functionality is not available in Revit LT.

See Also

PathOfTravel Class
UpdateMultiple Overload
Autodesk.Revit.DB.Analysis Namespace

UpdateMultiple Method (Document, IList(ElementId), IList(PathOfTravelCalculationStatus))

[image]