Revit 2021.1 API
LinkLoadResult Properties
LinkLoadResult Class See Also Send Feedback

The LinkLoadResult type exposes the following members.

Properties

 | Name | Description
Public property | ElementId | The id of the created or loaded linked model.
Public property | IsCircularLink | True if these results are part of a link cycle.
Public property | IsNested | True if these results represent a nested link; false otherwise.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LoadResult | Holds the results of creating or loading a link. Results can be LinkLoadResultType.LinkLoaded for success, or a variety of errors. See LinkLoadResultType for the full list.

See Also

LinkLoadResult Class

IsCircularLink Property

[image]