Revit 2021.1 API
BuildingEnvelopeAnalyzer Members
BuildingEnvelopeAnalyzer Class Methods Properties See Also Send Feedback

The BuildingEnvelopeAnalyzer type exposes the following members.

Methods

 | Name | Description
 | Create | Creates a new analyzer.
Public method | Dispose | Releases all resources used by the BuildingEnvelopeAnalyzer
Public method | GetBoundingElements | Returns the collection of building elements exposed to the outside forming the building envelope.
Public method | GetBoundingElementsForSpaceVolume | Returns the collection of bounding building elements for an enclosed space volume.
Public method | GetCenterPointsForConnectedGridCellsInSpaceVolume | Returns the collection of connected cells in an enclosed space volume.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

BuildingEnvelopeAnalyzer Class
Autodesk.Revit.DB.Analysis Namespace

BuildingEnvelopeAnalyzer Methods

[image] [image]