Revit 2021.1 API
WallSweepInfo Members
WallSweepInfo Class Constructors Methods Properties See Also Send Feedback

The WallSweepInfo type exposes the following members.

Constructors

 | Name | Description
Public method | WallSweepInfo(Boolean, WallSweepType) | Constructs a new WallSweepInfo instance.
Public method | WallSweepInfo(WallSweepType, Boolean) | Constructs a new WallSweepInfo instance.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the WallSweepInfo
Public method | IsEqual | Determines if the input object is equivalent to this WallSweepInfo.

Properties

 | Name | Description
Public property | CutsWall | Indicates if you want the sweep to cut geometry out of the host wall.
Public property | DefaultSetback | The sweep setback distance from inserts, such as windows and doors.
Public property | Distance | The distance from either the top or base of the wall.
Public property | DistanceMeasuredFrom | Indicates if Distance is measured from the top or bottom of the wall.
Public property | Id | The id of the sweep or reveal.
Public property | IsCutByInserts | Indicates if the sweep is cut by wall inserts.
Public property | IsFixed | Indicates if the described wall sweep is fixed. A sweep is fixed if it is a part of a vertical compound structure.
Public property | IsProfileFlipped | Indicates if the profile is applied upside-down.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | IsVertical | Indicates whether the sweep or reveal is swept vertically or horizontally.
Public property | MaterialId | The element id of the material used to create the sweep or reveal.
Public property | ProfileId | The element id of the profile family used to create the sweep or reveal.
Public property | WallOffset | The offset from the sweep or reveal to the wall.
Public property | WallSide | The side of the wall to which the sweep or reveal is attached.
Public property | WallSweepOrientation | Indicates how the profile of a horiztonal sweep is oriented with repect to the wall side face.
Public property | WallSweepType | The type (either a wall sweep or a reveal).

See Also

WallSweepInfo Class

WallSweepInfo Constructor

[image] [image]