Revit 2021.1 API
DWFImportOptions Constructor (IList<(Of <(<'ElementId>)>)>)
DWFImportOptions Class See Also Send Feedback
Constructs a new instance of DWFImportOptions with an array of imported sheet views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014

Syntax

C#
public DWFImportOptions(
    IList<ElementId> views
)
Visual Basic
Public Sub New ( _
    views As IList(Of ElementId) _
)
Visual C++
public:
DWFImportOptions(
    IList<ElementId^>^ views
)

Parameters

views
Type: System.Collections.Generic..::..IList<(Of <(<' ElementId >)>)>
These sheet views where DWF markups are imported.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

DWFImportOptions Class
DWFImportOptions Overload

Dispose Method

[image]