Revit 2021.1 API
FillGrid Methods
FillGrid Class See Also Send Feedback

The FillGrid type exposes the following members.

Methods

 | Name | Description
Public method | CalculateLengthPerArea | Calculates length of the pattern per unit area.
Public method | CalculateLinesPerLength | Calculates the number of solid lines of the pattern per unit length.
Public method | CalculateStrokesPerArea | Calculates the number of the segments of the pattern per unit area.
Public method | Dispose |
Public method | GetHatchingDirection | Provides the hatching propagation. Hatching is inverted.
Public method | GetPointLineZone(UV) | Gets the index of fill grid line closest to the input 2d point.
Public method | GetPointLineZone(UV, UV%) | Gets the index of fill grid line and the point on the grid line nearest to the input point.
Public method | GetSegmentDirection | Provides the segment direction.
Public method | GetSegments | Gets the segments of the fill grid.
Public method | IsEqual | Check if two fill grids are equal.
Public method | SetSegments | Sets the segments to the fill grid.

See Also

FillGrid Class

CalculateLengthPerArea Method

[image]