Revit 2021.1 API
OpenOptions Properties
OpenOptions Class See Also Send Feedback

The OpenOptions type exposes the following members.

Properties

 | Name | Description
Public property | AllowOpeningLocalByWrongUser | Specifies whether a local file is allowed to be opened as read-only by a user other than its owner.
Public property | Audit | Specifies whether to expand all elements in order to check for corruption.
Public property | DetachFromCentralOption | An option that specifies whether or not a workset-enabled document is detached from its central document.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | OpenForeignOption | An option that specifies how to open files saved by an application that was not developed or licensed by Autodesk.

See Also

OpenOptions Class

AllowOpeningLocalByWrongUser Property

[image]