Revit 2021.1 API
HostObjectSubcomponentInfo Members
HostObjectSubcomponentInfo Class Methods Properties See Also Send Feedback

The HostObjectSubcomponentInfo type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the HostObjectSubcomponentInfo
Public method | GetCurveLoop | Gets the CurveLoop representing the base profile curve loop of the roof or floor slab
Public method | GetPlane | Gets the plane representing the normal and origin of the surface containg the base profile curve loop of the roof or floor slab.

Properties

 | Name | Description
Public property | AreaOfCurveLoop | The area of the CurveLoop of the roof or floor slab.
Public property | Depth | The depth of the roof or floor slab.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LoopFace | The face of the loops of the roof or floor slab.

See Also

HostObjectSubcomponentInfo Class
Autodesk.Revit.DB.IFC Namespace

HostObjectSubcomponentInfo Methods

[image] [image]