Revit 2021.1 API
CableTray Methods
CableTray Class See Also Send Feedback

The CableTray type exposes the following members.

Methods

 | Name | Description
 | Create | Creates a new instance of cable tray.
Public method | GetShapeType | Returns the shape type for the cable tray.
 | IsValidCableTrayType | Identifies if a cable tray type is valid.
Public method | IsValidRungSpace | Identifies if the input rung space is valid.

See Also

CableTray Class
Autodesk.Revit.DB.Electrical Namespace

Create Method

[image]