Revit 2021.1 API
EnergyAnalysisDetailModelOptions Properties
EnergyAnalysisDetailModelOptions Class See Also Send Feedback

The EnergyAnalysisDetailModelOptions type exposes the following members.

Properties

 | Name | Description
Public property | EnergyModelType | It indicates whether the energy model is based on rooms/spaces or building elements.
Public property | ExportMullions | Indicates if to specify the setting for exporting mullions.
Public property | IncludeShadingSurfaces | Indicates if to set and get the setting for if shading surfaces should be included.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | SimplifyCurtainSystems | Indicates if to specify the setting for simplified curtain systems.
Public property | Tier | Level of computation for energy analysis model.

See Also

EnergyAnalysisDetailModelOptions Class
Autodesk.Revit.DB.Analysis Namespace

EnergyModelType Property

[image]