Revit 2021.1 API
AnalysisDisplayStyle Members
AnalysisDisplayStyle Class Methods Properties See Also Send Feedback

The AnalysisDisplayStyle type exposes the following members.

Methods

 | Name | Description
 | CreateAnalysisDisplayStyle(Document, String, AnalysisDisplayColoredSurfaceSettings, AnalysisDisplayColorSettings, AnalysisDisplayLegendSettings) | Factory method - creates analysis display style object of type Colored Surface for the given document.
 | CreateAnalysisDisplayStyle(Document, String, AnalysisDisplayDeformedShapeSettings, AnalysisDisplayColorSettings, AnalysisDisplayLegendSettings) | Factory method - creates analysis display style object of type Deformed Shape for the given document.
 | CreateAnalysisDisplayStyle(Document, String, AnalysisDisplayDiagramSettings, AnalysisDisplayColorSettings, AnalysisDisplayLegendSettings) | Factory method - creates analysis display style object of type Diagram for the given document.
 | CreateAnalysisDisplayStyle(Document, String, AnalysisDisplayMarkersAndTextSettings, AnalysisDisplayColorSettings, AnalysisDisplayLegendSettings) | Factory method - creates analysis display style object of type Markers and Text for the given document.
 | CreateAnalysisDisplayStyle(Document, String, AnalysisDisplayVectorSettings, AnalysisDisplayColorSettings, AnalysisDisplayLegendSettings) | Factory method - creates analysis display style object of type Vectors for the given document.
 | FindByName | Finds analysis display style by name.
Public method | GetColoredSurfaceSettings | Get colored surface settings object from the style.
Public method | GetColorSettings | Get color settings object from the style.
Public method | GetDeformedShapeSettings | Get deformed shape settings object from the style.
Public method | GetDiagramSettings | Get diagram settings object from the style.
 | GetElements | Returns set of all analysis display styles elements in the given document.
Public method | GetLegendSettings | Get legend settings object from the style.
Public method | GetMarkersAndTextSettings | Get markers and text settings object from the style.
Public method | GetVectorSettings | Get vector settings object from the style.
Public method | HasColoredSurfaceSettings | If true style has colored surface settings.
Public method | HasDeformedShapeSettings | If true style has deformed shape settings.
Public method | HasDiagramSettings | If true style has diagram settings.
Public method | HasMarkersAndTextSettings | If true style has markers and text settings.
Public method | HasVectorSettings | If true style has vector settings.
 | IsNameUnique | Verify the uniqueness of the name among all analysis display style elements of the document.
 | IsTextTypeIdValid | Verify if text type id is valid.
Public method | SetColoredSurfaceSettings | Set colored surface settings object for the style.
Public method | SetColorSettings | Set color settings object for the style.
Public method | SetDeformedShapeSettings | Set deformed shape settings object for the style.
Public method | SetDiagramSettings | Set diagram settings object for the style.
Public method | SetLegendSettings | Set legend settings object for the style.
Public method | SetMarkersAndTextSettings | Set markers and text settings object for the style.
Public method | SetName | Set name of analysis display style element.
Public method | SetVectorSettings | Set vector settings object for the style.

Properties

 | Name | Description

See Also

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace

AnalysisDisplayStyle Methods

[image] [image]