Revit 2021.1 API
Subelement Methods
Subelement Class See Also Send Feedback

The Subelement type exposes the following members.

Methods

 | Name | Description
Public method | CanHaveTypeAssigned | Identifies if the subelement can have a type assigned.
Public method | ChangeTypeId | Changes the type of the subelement.
 | Create | Creates an object representing element or subelement.
Public method | Dispose |
Public method | GetAllParameters | Returns all parameters of this subelement.
Public method | GetBoundingBox | Retrieves a box that circumscribes all geometry of the subelement.
Public method | GetGeometryObject | Retrieve one geometric primitive representing given subelement.
Public method | GetParameterValue | Obtains the current parameter value of this subelement given a parameter id.
Public method | GetReference | Obtains the reference to this subelement.
Public method | GetValidTypes | Obtains a set of types that are valid for this subelement.
Public method | HasParameter | Checks if this subelement have given parameter.
Public method | IsParameterModifiable | Checks if given parameter of this subelement is modifiable.
 | IsValidSubelementReference | Checks if given Reference identifies either a valid element or subelement.
Public method | IsValidType | Checks if given type is valid for this subelement.
Public method | SetParameterValue | Sets a new parameter value of this subelement given a parameter id.

See Also

Subelement Class

CanHaveTypeAssigned Method

[image]