Revit 2021.1 API
FieldDomainPointsByUV Constructor (IList<(Of <(<'UV>)>)>, ICollection<(Of <(<'Double>)>)>, ICollection<(Of <(<'Double>)>)>)
FieldDomainPointsByUV Class See Also Send Feedback
Creates object from an array of two-dimensional point coordinates

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011

Syntax

C#
public FieldDomainPointsByUV(
    IList<UV> points,
    ICollection<double> uCoordinates,
    ICollection<double> vCoordinates
)
Visual Basic
Public Sub New ( _
    points As IList(Of UV), _
    uCoordinates As ICollection(Of Double), _
    vCoordinates As ICollection(Of Double) _
)
Visual C++
public:
FieldDomainPointsByUV(
    IList<UV^>^ points,
    ICollection<double>^ uCoordinates,
    ICollection<double>^ vCoordinates
)

Parameters

points
Type: System.Collections.Generic..::..IList<(Of <(<' UV >)>)>
Array of two-dimensional point coordinates representing domain points (usually on surface)
uCoordinates
Type: System.Collections.Generic..::..ICollection<(Of <(<'Double>)>)>
Set of u coordinates at which to draw grid lines on the surface
vCoordinates
Type: System.Collections.Generic..::..ICollection<(Of <(<'Double>)>)>
Set of v coordinates at which to draw grid lines on the surface

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FieldDomainPointsByUV Class
FieldDomainPointsByUV Overload
Autodesk.Revit.DB.Analysis Namespace

FieldDomainPointsByUV Methods

[image] [image]