Revit 2021.1 API
ExportPatternTable Methods
ExportPatternTable Class See Also Send Feedback

The ExportPatternTable type exposes the following members.

Methods

 | Name | Description
Public method | Add | Inserts a (key,info) pair into Export pattern table.
Public method | Clear | Removes all contents stored in the table.
Public method | ContainsKey | Checks whether a pattern key exists in the table.
Public method | Dispose |
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetExportPatternInfo | Gets a copy of the pattern info associated to the input pattern key.
Public method | GetKeys | Gets all the keys stored in the map.
Public method | GetPatternTableIterator | Returns a PatternTableIterator that iterates through the collection.
Public method | GetValues | Returns all the values stored in the map.
Public method | Remove | Removes the pair (key, info) by pattern key.

See Also

ExportPatternTable Class

Add Method

[image]