Revit 2021.1 API
PanelScheduleTemplate Members
PanelScheduleTemplate Class Methods Properties See Also Send Feedback

The PanelScheduleTemplate type exposes the following members.

Methods

 | Name | Description
Public method | CopyFrom | Copies all values from other element to this object.
 | Create | Creates a new instance of a panel schedule template.
Public method | GetPanelScheduleType | Returns the panel schedule type.
Public method | GetSectionData | Gets the writable section data object.
Public method | GetTableData | Gets the writable table data object.
Public method | HasSameType | Checks if given template has the same panel schedule type with this template.
 | IsValidPanelConfiguration | Checks if given panel configuration is valid for given panel schedule type.
 | IsValidType(PanelScheduleType) | Checks if given type is valid for this panel schedule template element.
Public method | SetTableData | Assigns table data to this template

Properties

 | Name | Description
Public property | IsBranchPanelSchedule | Checks to see if this object is branch panel schedule template element.
Public property | IsDataPanelSchedule | Checks to see if this object is data panel schedule template element.
Public property | IsDefault | Checks to see if this is default template for the given panel schedule type.
Public property | IsSwitchboardSchedule | Checks to see if this object is switchboard schedule template element.

See Also

PanelScheduleTemplate Class
Autodesk.Revit.DB.Electrical Namespace

PanelScheduleTemplate Methods

[image] [image]