Revit 2021.1 API
VertexBuffer Methods
VertexBuffer Class See Also Send Feedback

The VertexBuffer type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | GetMappedHandle | Gets a handle to the buffer's memory that has been mapped. Writing data to the buffer using the handle is an alternative to using stream objects.
Public method | GetVertexStreamPosition | Gets a stream that can be used to write vertices of type VertexPosition into the buffer.
Public method | GetVertexStreamPositionColored | Gets a stream that can be used to write vertices of type VertexPositionColored into the buffer.
Public method | GetVertexStreamPositionNormal | Gets a stream that can be used to write vertices of type VertexPositionNormal into the buffer.
Public method | GetVertexStreamPositionNormalColored | Gets a stream that can be used to write vertices of type VertexPositionNormalColored into the buffer.
Public method | IsValid | Tests whether the buffer is valid for rendering.
Public method | Map | Maps a portion of the buffer into memory, so that vertex data can be written into it. (see VertexStream).
Public method | Unmap | Unmaps the buffer, so that it can be used for rendering.

See Also

VertexBuffer Class
Autodesk.Revit.DB.DirectContext3D Namespace

Dispose Method

[image]