Revit 2021.1 API
IFCLegacyStairOrRamp Methods
IFCLegacyStairOrRamp Class See Also Send Feedback

The IFCLegacyStairOrRamp type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | GetBoundaryLines | Gets boundary lines.
Public method | GetLandingGeometries | Gets the geometries of landings.
Public method | GetNumberOfRisers | Gets the number of risers.
Public method | GetNumberOfTreads | Gets the number of treads.
Public method | GetRunGeometries | Gets the geometries of runs.
Public method | GetStringerGeometries | Gets the geometries of stringers.
Public method | GetTreadsLength | Gets the length of treads.
Public method | GetWalkLines | Gets walk lines.

See Also

IFCLegacyStairOrRamp Class
Autodesk.Revit.DB.IFC Namespace

Dispose Method

[image]