Revit 2021.1 API
AssemblyInstance Methods
AssemblyInstance Class See Also Send Feedback

The AssemblyInstance type exposes the following members.

Methods

 | Name | Description
Public method | AddMemberIds | Adds member element ids for the assembly instance.
Public method | AllowsAssemblyViewCreation | Returns true if assembly views can be created for this Assembly Instance.
 | AreElementsValidForAssembly | Identifies if provided assembly members are valid.
 | CanRemoveElementsFromAssembly | Identifies if provided assembly members can be removed from the assembly instance.
 | CompareAssemblyInstances | Compares two assembly instances and returns a result with details about the differences
 | Create | Creates a new assembly instance.
Public method | Disassemble | Removes the assembly instance and releases the member elements.
Public method | GetCenter | Returns the center of the bounding box for the assembly instance. This is the default position for placed assembly instances.
Public method | GetMemberIds | Gets member element ids for the assembly instance.
Public method | GetTransform | Gets the origin of the assembly instance.
 | IsValidNamingCategory | Identifies if the naming category is valid for an assembly instance.
 | PlaceInstance | Places an assembly instance of a given assembly type at the specified location.
Public method | RemoveMemberIds | Removes member element ids from the assembly instance.
Public method | SetMemberIds | Sets member element ids for the assembly instance. All existing members are cleared.
Public method | SetTransform | Sets the origin of the assembly instance.

See Also

AssemblyInstance Class

AddMemberIds Method

[image]