Revit 2021.1 API
BalusterInfo Members
BalusterInfo Class Methods Properties See Also Send Feedback

The BalusterInfo type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the BalusterInfo
 | GetReferenceNameForHost | Gets the name string to be used as a reference to Host in the current language.
 | GetReferenceNameForTopRail | Gets the name string to be used as a reference to Top Rail in the current language.

Properties

 | Name | Description
Public property | BalusterFamilyId | The id of the family used for the baluster or post.
Public property | BaseOffset | The offset from the base reference.
Public property | BaseReferenceName | Represents the name of the reference for the bottom of this baluster or post.
Public property | DistanceFromPreviousOrSpace | The length, in case of balusters, it is a distance from a previous one. For a post, it is a space from the original position of the post.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Name | The name of the baluster.
Public property | Offset | The side offset of the baluster/post from the railing path.
Public property | TopOffset | The offset from the top reference.
Public property | TopReferenceName | Represents the name of the reference for the top of this baluster or post.

See Also

BalusterInfo Class
Autodesk.Revit.DB.Architecture Namespace

BalusterInfo Methods

[image] [image]