Revit 2021.1 API
ParameterSet Members
ParameterSet Class Constructors Methods Properties See Also Send Feedback

The ParameterSet type exposes the following members.

Constructors

 | Name | Description
Public method | ParameterSet | Initializes a new instance of the ParameterSet class

Methods

 | Name | Description
Public method | Clear | Removes every parameter from the set, rendering it empty.
Public method | Contains | Tests for the existence of a parameter within the set.
Public method | Erase | Removes a specified parameter from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | Insert | Insert the specified parameter into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | Size | Returns the number of parameters that are in the set.

See Also

ParameterSet Class

ParameterSet Constructor

[image]