Revit 2021.1 API
Wall..::..Create Method (Document, IList<(Of <(<'Curve>)>)>, Boolean)
Wall Class See Also Send Feedback
Creates a non rectangular profile wall within the project using the default wall type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)

Syntax

C#
public static Wall Create(
    Document document,
    IList<Curve> profile,
    bool structural
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    profile As IList(Of Curve), _
    structural As Boolean _
) As Wall
Visual C++
public:
static Wall^ Create(
    Document^ document,
    IList<Curve^>^ profile,
    bool structural
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which the new wall is created.
profile
Type: System.Collections.Generic..::..IList<(Of <(<' Curve >)>)>
An array of planar curves that represent the vertical profile of the wall.
structural
Type: System..::..Boolean
If set, specifies that the wall is structural in nature.

Return Value

If successful a new wall object within the project.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input profile contains at least one helical curve and is not supported for this operation.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | Failed to create the wall.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

Wall Class
Create Overload

Create Method (Document, Curve, ElementId, Boolean)

[image]