Revit 2021.1 API
EnergyAnalysisDetailModel Members
EnergyAnalysisDetailModel Class Methods Properties See Also Send Feedback

The EnergyAnalysisDetailModel type exposes the following members.

Methods

 | Name | Description
 | Create | Creates a new energy analysis detailed model.
Public method | GetAnalyticalOpenings | The collection of analytical openings.
Public method | GetAnalyticalShadingSurfaces | The collection of analytical shading surfaces.
Public method | GetAnalyticalSpaces | The collection of analytical spaces.
Public method | GetAnalyticalSurfaces | The collection of analytical surfaces.
 | GetMainEnergyAnalysisDetailModel | Gets the EnergyAnalysisDetailModel in given document.
Public method | TransformModel | Transforms all surfaces in the model according to the document's active ground plane, shared coordinates and true north.

Properties

 | Name | Description
Public property | BuildingTypeId | The building type element.
Public property | ExportCategory | Export elements of this category in energy analysis.
Public property | ExportMullions | Indicates if to specify the setting for exporting mullions.
Public property | IncludeShadingSurfaces | Indicates if to set and get the setting for if shading surfaces should be included.
Public property | SimplifyCurtainSystems | Indicates if to specify the setting for simplified curtain systems.
Public property | Tier | Level of computation for energy analysis model.

See Also

EnergyAnalysisDetailModel Class
Autodesk.Revit.DB.Analysis Namespace

EnergyAnalysisDetailModel Methods

[image] [image]