Revit 2021.1 API
XYZ..::..Subtraction Operator
XYZ Class See Also Send Feedback
Subtracts the two specified vectors and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)

Syntax

C#
public static XYZ operator -(
    XYZ left,
    XYZ right
)
Visual Basic
Public Shared Operator - ( _
    left As XYZ, _
    right As XYZ _
) As XYZ
Visual C++
public:
static XYZ^ operator -(
    XYZ^ left,
    XYZ^ right
)

Parameters

left
Type: Autodesk.Revit.DB..::..XYZ
The first vector.
right
Type: Autodesk.Revit.DB..::..XYZ
The second vector.

Return Value

The vector equal to the difference between the two source vectors.

Remarks

The subtracted vector is obtained by subtracting each coordinate of the right vector from the corresponding coordinate of the left vector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when left or right is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

XYZ Class

UnaryNegation Operator

[image]