Revit 2021.1 API
RailingType Members
RailingType Class Methods Properties See Also Send Feedback

The RailingType type exposes the following members.

Methods

 | Name | Description

Properties

 | Name | Description
Public property | BalusterPlacement | Accesses the object containing properties related to the baluster placement.
Public property | PrimaryHandrailHeight | The height of the primary handrail.
Public property | PrimaryHandrailLateralOffset | The lateral offset of the primary handrail.
Public property | PrimaryHandRailPosition | The position of the primary handrail.
Public property | PrimaryHandrailType | The type of the primary handrail.
Public property | RailStructure | The NonContinuousRailStructure.
Public property | SecondaryHandrailHeight | The height of the secondary handrail.
Public property | SecondaryHandrailLateralOffset | The lateral offset of the secondary handrail.
Public property | SecondaryHandRailPosition | The position of the secondary handrail.
Public property | SecondaryHandrailType | The type of the secondary handrail.
Public property | TopRailHeight | The height of the top rail in the railing system.
Public property | TopRailType | The type of the top rail in the railing system.

See Also

RailingType Class
Autodesk.Revit.DB.Architecture Namespace

RailingType Methods

[image] [image]