Revit 2021.1 API
MacroModule Methods
MacroModule Class See Also Send Feedback

The MacroModule type exposes the following members.

Methods

 | Name | Description
Public method | AddMacro | Adds a macro to the module.
Public method | Dispose |
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetMacro | Gets the macro with the give name.
Public method | GetMacroModuleIterator | Returns a Macro module iterator that iterates through the collection.
Public method | RemoveMacro | Removes a macro from the module.

See Also

MacroModule Class
Autodesk.Revit.DB.Macros Namespace

AddMacro Method

[image]