Revit 2021.1 API
VoltageTypeSet Members
VoltageTypeSet Class Constructors Methods Properties See Also Send Feedback

The VoltageTypeSet type exposes the following members.

Constructors

 | Name | Description
Public method | VoltageTypeSet | Initializes a new instance of the VoltageTypeSet class

Methods

 | Name | Description
Public method | Clear | Removes every voltage type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a voltage type within the set.
Public method | Erase | Removes a specified voltage type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | Insert | Insert the specified voltage type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | Size | Returns the number of voltage types that are in the set.

See Also

VoltageTypeSet Class
Autodesk.Revit.DB.Electrical Namespace

VoltageTypeSet Constructor

[image]