Revit 2021.1 API
EnergyAnalysisSurface Members
EnergyAnalysisSurface Class Methods Properties See Also Send Feedback

The EnergyAnalysisSurface type exposes the following members.

Methods

 | Name | Description
Public method | GetAdjacentAnalyticalSpace | Gets the secondary adjacent analytical space this surface is associated with.
Public method | GetAnalyticalOpenings | Returns the analytical openings of the analytical surface.
Public method | GetAnalyticalSpace | Gets the primary analytical space this surface is associated with.
Public method | GetPolyloop | Gets the planar polygon describing the opening geometry.

Properties

 | Name | Description
Public property | Azimuth | The azimuth angle for this surface.
Public property | CADLinkUniqueId | The unique id of the originating CAD object's link (linked document) associated with this surface.
Public property | CADObjectUniqueId | The unique id of the originating CAD object (model element) associated with this surface.
Public property | Corner | The lower-left coordinate for the analytical rectangular geometry viewed from outside.
Public property | Height | The height of the analytical rectangular geometry.
Public property | Normal | The outward normal for this surface.
Public property | OriginatingElementDescription | The description for the originating Revit element.
Public property | SurfaceId | The unique identifier for the surface.
Public property | SurfaceName | The unique name identifier for this surface.
Public property | SurfaceType | The analytical surface type.
Public property | Tilt | The tilt angle for this surface.
Public property | Type | The gbXML surface type attribute.
Public property | Width | The width of the analytical rectangular geometry.

See Also

EnergyAnalysisSurface Class
Autodesk.Revit.DB.Analysis Namespace

EnergyAnalysisSurface Methods

[image] [image]