Revit 2021.1 API
GeometryInstance Methods
GeometryInstance Class See Also Send Feedback

The GeometryInstance type exposes the following members.

Methods

 | Name | Description
Public method | GetInstanceGeometry()()()() | Computes the geometric representation of the instance.
Public method | GetInstanceGeometry(Transform) | Computes a transformation of the geometric representation of the instance.
Public method | GetSymbolGeometry()()()() | Computes the geometric representation of the symbol which generates this instance.
Public method | GetSymbolGeometry(Transform) | Computes a transformation of the geometric representation of the symbol which generates this instance.

See Also

GeometryInstance Class

GetInstanceGeometry Method

[image] [image]