Revit 2021.1 API
ParameterFilterElement Members
ParameterFilterElement Class Methods Properties See Also Send Feedback

The ParameterFilterElement type exposes the following members.

Methods

 | Name | Description
Public method | AllRuleParametersApplicable(ElementFilter) | Checks that the parameters of the rules used by the given ElementFilter are valid for this filter's categories.
 | AllRuleParametersApplicable(Document, ICollection<(Of <<'(ElementId>)>>), ElementFilter) | Checks that the parameters of the given ElementFilter (representing a combination of rules) are valid for the given set of categories.
Public method | ClearRules | Removes all rules from this filter.
 | Create(Document, String, ICollection<(Of <<'(ElementId>)>>)) | Creates a new ParameterFilterElement in the given document.
 | Create(Document, String, ICollection<(Of <<'(ElementId>)>>), ElementFilter) | Creates a new ParameterFilterElement in the given document.
Public method | ElementFilterIsAcceptableForParameterFilterElement(ElementFilter) | Checks that an ElementFilter is acceptable for use in defining the filtering rules for a ParameterFilterElement (i.e., for view filtering).
 | ElementFilterIsAcceptableForParameterFilterElement(Document, ISet<(Of <<'(ElementId>)>>), ElementFilter) | Checks that an ElementFilter is acceptable for use in defining the filtering rules for a given list of categories (i.e., for view filtering).
Public method | GetCategories | Gets the categories admitted by this filter.
Public method | GetElementFilter | Returns an ElementFilter representing the combination of rules used by this filter.
Public method | GetElementFilterParameters | Retrieves a list of the parameters associated with each rule in the filter.
Public method | GetElementFilterParametersForCategory | Retrieves a list of the parameters associated with all rules in the filter that are combined (using logical AND) with a FilterCategoryRule corresponding to single %categoryId%.
Public method | SetCategories | Sets the categories admitted by this filter.
Public method | SetElementFilter | Sets the rules that must be satisfied for a given element to pass this filter.

Properties

 | Name | Description

See Also

ParameterFilterElement Class

ParameterFilterElement Methods

[image] [image]