Revit 2021.1 API
IFCFamilyInstanceExtrusionExportResults Members
IFCFamilyInstanceExtrusionExportResults Class Methods Properties See Also Send Feedback

The IFCFamilyInstanceExtrusionExportResults type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the IFCFamilyInstanceExtrusionExportResults
Public method | GetCutPairOpenings | Gets the set of "openings" determined from the analysis of the instance geometry.
Public method | GetExtrusionHandle | Gets the extruded solid handle generated for the family instance.

Properties

 | Name | Description
Public property | ExtraOffset | The extra offset determined from the geometry of the family instance.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | MaterialId | The best material id determined for the family instance.

See Also

IFCFamilyInstanceExtrusionExportResults Class
Autodesk.Revit.DB.IFC Namespace

IFCFamilyInstanceExtrusionExportResults Methods

[image] [image]