Revit 2021.1 API
STLExportOptions Members
STLExportOptions Class Constructors Methods Properties See Also Send Feedback

The STLExportOptions type exposes the following members.

Constructors

 | Name | Description
Public method | STLExportOptions()()()() | Constructs a new instance of STLExportOptions with default values of all properties.
Public method | STLExportOptions(STLExportResolution) | Constructs a new instance of STLExportOptions with all predefined tessellation settings, depending on STL export resolution type. Note: in case of Custom resolution type, tessellation settings won't be predefined and will have default values.

Methods

 | Name | Description
Public method | IsGridAspectRatioSet | Checks whether the GridAspectRatio tessellation parameter is explicitly set.
Public method | IsMaxEdgeLengthSet | Checks whether the MaxEdgeLength tessellation parameter is explicitly set.
Public method | IsNormalToleranceSet | Checks whether the NormalTolerance tessellation parameter is explicitly set.
Public method | IsSurfaceToleranceSet | Checks whether the SurfaceTolerance tessellation parameter is explicitly set.
 | IsValidForGridAspectRatio | Checks whether the value is allowed (is in the allowed range) for GridAspectRatio tessellation parameter.
 | IsValidForMaxEdgeLength | Checks whether the value is allowed (is in the allowed range) for MaxEdgeLength tessellation parameter.
 | IsValidForNormalTolerance | Checks whether the value is allowed (is in the allowed range) for NormalTolerance tessellation parameter.
 | IsValidForSurfaceTolerance | Checks whether the value is allowed (is in the allowed range) for SurfaceTolerance tessellation parameter.
Public method | SetTessellationSettings | Sets all the tessellation parameters to its predefined values for the given resolution type.

Properties

 | Name | Description
Public property | ExportBinary | True to export in binary STL format, false to export in ASCII STL format. Default value is true.
Public property | ExportColor | True to export color information, false otherwise. Default value is false.
Public property | GridAspectRatio | The maximum aspect ratio allowed in the grid placed across the face. The minimum allowed value is 1.0. The maximum allowed value is 10.0. By default this property is ignored.
Public property | MaxEdgeLength | The maximum length allowed for any chord on an edge or between any two adjacent grid lines. This is a percentage value. By exporting, the real value of maximum edge length is calculated as a percent from the length of the diameter of the body bounding box. The minimum allowed value is 0.1%. The maximum allowed value is 10.0%. By default this property is ignored.
Public property | NormalTolerance | The maximum change in the surface normal between adjacent nodes in the mesh. This property is defined in degrees. The minimum allowed value is 1.0 degrees. The maximum allowed value is 45.0 degrees. Default value is 15.0 degrees.
Public property | SurfaceTolerance | The maximum distance between mesh triangles and model geometry. This is a percentage value. By exporting, the real value of surface tolerance is calculated as a percent from the length of the diameter of the body bounding box. The minimum allowed value is 0.001%. The maximum allowed value is 1.0%. Default value is 0.1%.
Public property | TargetUnit | The unit type of geometry in the resultant STL file. Default value is ExportUnit::Default.

See Also

STLExportOptions Class

STLExportOptions Constructor

[image] [image]