Revit 2021.1 API
Dimension Members
Dimension Class Methods Properties See Also Send Feedback

The Dimension type exposes the following members.

Methods

 | Name | Description
Public method | IsTextPositionAdjustable | Indicates if this dimension is supported to set/get TextPosition/LeaderEndPosition.
Public method | ResetTextPosition | Resets the text position of the dimension to the initial position determined by its type and parameters.

Properties

 | Name | Description
Public property | Above | The text shown above the segment's value.
Public property | AreReferencesAvailable | Indicates if this dimension's references can be resolved.
Public property | AreSegmentsEqual | Indicates if all segments are forced to be equal.
Public property | Below | The text shown below the segment's value.
Public property | Curve | A curve that represents the dimension line.
Public property | DimensionShape | The shape of this dimension.
Public property | DimensionType | The dimension style of this dimension.
Public property | FamilyLabel | The family parameter label of the dimension.
Public property | HasLeader | True if dimension has leader, false otherwise.
Public property | IsLocked | Indicates if this dimension is locked.
Public property | IsValid | Indicates if this dimension is valid.
Public property | LeaderEndPosition | The position of the dimension's leader end point.
Public property | Name | Retrieves or changes the name associated with the Dimension.
Public property | NumberOfSegments | The number of segments for the dimension.
Public property | Origin | The dimension origin.
Public property | Prefix | The text shown before the segment's value.
Public property | References | Returns an array of geometric references to which the dimension is attached.
Public property | Segments | The segments in the dimension.
Public property | Suffix | The text shown after the segment's value.
Public property | TextPosition | The position of the dimension text's drag point.
Public property | Value | The value of the dimension.
Public property | ValueOverride | The text that replaces the segment's value.
Public property | ValueString | The dimension value as a user visible string.
Public property | View | Supplies the view that contains the dimension if the dimension is view specific.

See Also

Dimension Class

Dimension Methods

[image] [image]