Revit 2021.1 API
MultistoryStairs Members
MultistoryStairs Class Methods Properties See Also Send Feedback

The MultistoryStairs type exposes the following members.

Methods

 | Name | Description
Public method | CanConnectLevel | Checks if the given level can be connected into multistory stairs. You cannot connect levels between standard stairs top and bottom or already connected.
Public method | CanDisconnectLevel | Checks if the given level can be disconnected from multistory stairs. You cannot disconnect the levels of standard stair (the stair associated with the Reference Level for the multistory stairs) or already disconnected.
Public method | ConnectLevels | Extends the multistory stairs by connecting input levels.
 | Create | Creates a multistory stairs from an existing component-based stairs.
Public method | DisconnectLevels | Shrinks the multistory stairs by disconnecting input levels.
Public method | GetAllConnectedLevels | Gets all connected level ids of this multistory stairs.
Public method | GetAllStairsIds | Gets the ids of all the stairs in this multistory stairs.
Public method | GetStairsOnLevel | Gets the individual stairs or stairs group on the given base level.
Public method | GetStairsPlacementLevels | Gets all the levels the given stairs group placed on.
 | IsAcceptableForMultistoryStairs | Checks if the given stairs can be used to create a multistory stairs.
Public method | IsPinned | Checks if a stair is pinned.
Public method | Pin | Restores an unpinned stairs element back into the group of stairs governed by level height.
Public method | Unpin | Removes a particular story of the stairs (identified by its base level id) from a stairs group.

Properties

 | Name | Description
Public property | ActualTreadDepth | The actual depth of the stairs treads in the stairs, actual tread depth is equal to minimum tread depth by default.
Public property | StandardStairsId | Id of the stair associated with the Reference Level for the multistory stairs. The standard stair is regarded as a definition to generate new stairs when extending multistory stairs to a different level height.

See Also

MultistoryStairs Class
Autodesk.Revit.DB.Architecture Namespace

MultistoryStairs Methods

[image] [image]