Revit 2021.1 API
IFCImportOptions Members
IFCImportOptions Class Constructors Methods Properties See Also Send Feedback

The IFCImportOptions type exposes the following members.

Constructors

 | Name | Description
Public method | IFCImportOptions | Constructs a new IFCImportOptions using default settings.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the IFCImportOptions
Public method | GetConversionData | Get the data used in the creation of the associated Revit file for an IFC link operation, if it exists.
Public method | GetExtraOptions | Get the list of extra options to be passed into the importer. Each entry in the map is a pair of option name and value.
Public method | SetExtraOptions | Set the list of extra options to be passed into the importer. Each entry in the map is a pair of option name and value. Note that any value here will overwrite the other values in the IFCImportOptions, if it has the same name.

Properties

 | Name | Description
Public property | Action | The action of the import.
Public property | AutocorrectOffAxisLines | Enable or disable correcting lines that are slight off-axis.
Public property | AutoJoin | Enable or disable auto-join at the end of import.
Public property | CreateLinkInstanceOnly | Determines whether to create a linked symbol element or not.
Public property | ForceImport | Force the IFC file to be imported regardless of an existing corresponding Revit file.
Public property | Intent | The intent of the import.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | RevitLinkFileName | The full path of the intermediate Revit file created during a previous link action. This is used during "Reload From" to determine the path to the previous generated Revit file.

See Also

IFCImportOptions Class
Autodesk.Revit.DB.IFC Namespace

IFCImportOptions Constructor

[image]