Revit 2021.1 API
GeometryObject..::..Equality Operator
GeometryObject Class See Also Send Feedback
Determines whether two GeometryObjects are the same.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)

Syntax

C#
public static bool operator ==(
    GeometryObject first,
    GeometryObject second
)
Visual Basic
Public Shared Operator = ( _
    first As GeometryObject, _
    second As GeometryObject _
) As Boolean
Visual C++
public:
static bool operator ==(
    GeometryObject^ first,
    GeometryObject^ second
)

Parameters

first
Type: Autodesk.Revit.DB..::..GeometryObject
The first GeometryObject.
second
Type: Autodesk.Revit.DB..::..GeometryObject
The second GeometryObject.

Return Value

True if the GeometryObjects are the same; otherwise, false.

Remarks

This compares the internal identifiers of the geometry, and doesn't compare them geometrically.

See Also

GeometryObject Class

Inequality Operator

[image]