Revit 2021.1 API
ExportPatternTable Members
ExportPatternTable Class Constructors Methods Properties See Also Send Feedback

The ExportPatternTable type exposes the following members.

Constructors

 | Name | Description
Public method | ExportPatternTable | Constructs a new ExportPatternTable with default values.

Methods

 | Name | Description
Public method | Add | Inserts a (key,info) pair into Export pattern table.
Public method | Clear | Removes all contents stored in the table.
Public method | ContainsKey | Checks whether a pattern key exists in the table.
Public method | Dispose | Releases all resources used by the ExportPatternTable
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetExportPatternInfo | Gets a copy of the pattern info associated to the input pattern key.
Public method | GetKeys | Gets all the keys stored in the map.
Public method | GetPatternTableIterator | Returns a PatternTableIterator that iterates through the collection.
Public method | GetValues | Returns all the values stored in the map.
Public method | Remove | Removes the pair (key, info) by pattern key.

Properties

 | Name | Description
Public property | Count | Count of the items contained in the collection.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Item | A copy of the ExportPatternInfo for the pattern's ExportPatternKey.

See Also

ExportPatternTable Class

ExportPatternTable Constructor

[image]