Revit 2021.1 API
Units..::..SetFormatOptions Method (ForgeTypeId, FormatOptions)
Units Class See Also Send Feedback
Sets the default FormatOptions for a spec.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014

Syntax

C#
public void SetFormatOptions(
    ForgeTypeId specTypeId,
    FormatOptions options
)
Visual Basic
Public Sub SetFormatOptions ( _
    specTypeId As ForgeTypeId, _
    options As FormatOptions _
)
Visual C++
public:
void SetFormatOptions(
    ForgeTypeId^ specTypeId,
    FormatOptions^ options
)

Parameters

specTypeId
Type: Autodesk.Revit.DB..::..ForgeTypeId
Identifier of the spec.
options
Type: Autodesk.Revit.DB..::..FormatOptions
The FormatOptions.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | specTypeId is not a spec identifier. See UnitUtils.IsSpec(ForgeTypeId) and UnitUtils.GetSpecTypeId(UnitType). -or- FormatOptions cannot be modified for specTypeId. See Units.IsModifiableSpec(ForgeTypeId) and Units.GetModifiableSpecs(). -or- UseDefault is true in options. -or- The unit in options is not valid for specTypeId. See UnitUtils.IsValidUnit(ForgeTypeId, ForgeTypeId) and UnitUtils.GetValidUnits(ForgeTypeId). -or- The rounding method in options is not set to Nearest.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

Units Class
SetFormatOptions Overload

SetFormatOptions Method (UnitType, FormatOptions)

[image]