Revit 2021.1 API
DuctSettings Methods
DuctSettings Class See Also Send Feedback

The DuctSettings type exposes the following members.

Methods

 | Name | Description
 | GetDuctSettings | Get the duct settings of the project.
Public method | GetPressLossCalculationServerInfo | Get the MEPServerInfo of the current pipe pressure loss calculation server.
Public method | GetSpecificFittingAngles | Gets the list of specific fitting angles.
Public method | GetSpecificFittingAngleStatus | Gets the status of given specific angle.
Public method | IsValidSpecificFittingAngle | Checks that the given value is a valid specific fitting angle. The specific fitting angles are angles of 90, 60, 45, 30, 22.5 or 11.25 degrees.
Public method | SetPressLossCalculationServerInfo | Set the MEPServerInfo of the current pipe pressure loss calculation server.
Public method | SetSpecificFittingAngleStatus | Sets the status of given specific angle.

See Also

DuctSettings Class
Autodesk.Revit.DB.Mechanical Namespace

GetDuctSettings Method

[image]