Revit 2021.1 API
CompoundStructureLayer Properties
CompoundStructureLayer Class See Also Send Feedback

The CompoundStructureLayer type exposes the following members.

Properties

 | Name | Description
Public property | DeckEmbeddingType | Embedding type for structural deck - only for a layer whose function is StructuralDeck.
Public property | DeckProfileId | The ElementId of the structural deck profile - only for a layer whose function is StructuralDeck.
Public property | Function | The function of the layer.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LayerCapFlag | Identifies if the layer participates in wrapping at end caps and/or inserts.
Public property | LayerId | The id of the layer - note that this may be different from the index in the array of layers in a CompoundStructure.
Public property | MaterialId | Id of the material assigned to this layer.
Public property | Width | Width of the layer.

See Also

CompoundStructureLayer Class

DeckEmbeddingType Property

[image]