Revit 2021.1 API
ModuleSettings Members
ModuleSettings Class Constructors Methods Properties See Also Send Feedback

The ModuleSettings type exposes the following members.

Constructors

 | Name | Description
Public method | ModuleSettings | Constructs a new module settings.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ModuleSettings

Properties

 | Name | Description
Public property | Description | The module description.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | MacroLanguageType | The Macro language type.
Public property | Name | The module name.

See Also

ModuleSettings Class
Autodesk.Revit.DB.Macros Namespace

ModuleSettings Constructor

[image]