Revit 2021.1 API
ScheduleSheetInstance..::..Create Method
ScheduleSheetInstance Class See Also Send Feedback
Create an instance of a schedule on a sheet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013

Syntax

C#
public static ScheduleSheetInstance Create(
    Document document,
    ElementId viewSheetId,
    ElementId scheduleId,
    XYZ origin
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    viewSheetId As ElementId, _
    scheduleId As ElementId, _
    origin As XYZ _
) As ScheduleSheetInstance
Visual C++
public:
static ScheduleSheetInstance^ Create(
    Document^ document,
    ElementId^ viewSheetId,
    ElementId^ scheduleId,
    XYZ^ origin
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document
viewSheetId
Type: Autodesk.Revit.DB..::..ElementId
The id of the sheet where the schedule will be placed.
scheduleId
Type: Autodesk.Revit.DB..::..ElementId
The id of the schedule view.
origin
Type: Autodesk.Revit.DB..::..XYZ
Location on the sheet where the schedule will be placed.

Return Value

The new ScheduleInstance.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | scheduleId is not a ViewSchedule that can be added to sheets. "Internal" schedules that are not user-visible but that are used in Revit to manage Keynotes and Revisions cannot be added to sheets. -or- viewSheetId is not a ViewSheet.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

ScheduleSheetInstance Class

ScheduleSheetInstance Properties

[image] [image]