Revit 2021.1 API
ExternalService Members
ExternalService Class Methods Properties See Also Send Feedback

The ExternalService type exposes the following members.

Methods

 | Name | Description
Public method | AddServer | Registers a server with its service.
Public method | Dispose | Releases all resources used by the ExternalService
Public method | GetDefaultServerId | Returns the Id of the default server if one was assigned to the service.
Public method | GetOptions | A copy of the options the service was registered with.
Public method | GetPublicAccessKey | Access key to use to execute a service.
Public method | GetRegisteredServerIds | Returns Ids of all servers registered for the service.
Public method | GetServer | Returns the instance that provides implementation for a registered server.
Public method | IsRegisteredServerId | Checks if the Id represents a valid server that has been registered for the service.
Public method | RemoveServer | Removes/unregisters a server from the service.

Properties

 | Name | Description
Public property | Description | The description for the service
Public property | IsSerializable | Indicates whether executions of the service requires serialization in documents or not.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Name | The name of the service
Public property | NumberOfServers | Indicates the number of servers currently registered with the service.
Public property | ServiceId | The Id of the service
Public property | VendorId | The vendor who provided the service

See Also

ExternalService Class
Autodesk.Revit.DB.ExternalService Namespace

ExternalService Methods

[image] [image]