Revit 2021.1 API
TextNote Members
TextNote Class Methods Properties See Also Send Feedback

The TextNote type exposes the following members.

Methods

 | Name | Description
Public method | AddLeader | Adds a leader to the text note.
 | Create(Document, ElementId, XYZ, String, ElementId) | Creates a new unwrapped TextNote element with the given properties.
 | Create(Document, ElementId, XYZ, String, TextNoteOptions) | Creates a new unwrapped text note element with the given properties.
 | Create(Document, ElementId, XYZ, Double, String, ElementId) | Creates a new line-wrapping text note element of the given width and properties.
 | Create(Document, ElementId, XYZ, Double, String, TextNoteOptions) | Creates a new line-wrapping text note element of the given width and properties.
Public method | GetFormattedText | Returns an object that contains text and associated formatting of this note.
Public method | GetLeaders | Returns a collection of leaders currently attached to the text note.
Public method | RemoveLeaders | Removes all leaders currently attached to the text note.
Public method | SetFormattedText | Sets the text and associated formatting of the text of in this text note with a given FormattedText object.

Properties

 | Name | Description
Public property | LeaderCount | Number of leader objects currently attached to the text note.
Public property | LeaderLeftAttachment | Attachment position of leaders on the left side of the text note.
Public property | LeaderRightAttachment | Attachment position of leaders on the right side of the text note.
Public property | TextNoteType | Access the type of the TextNote object.

See Also

TextNote Class

TextNote Methods

[image] [image]