Revit 2021.1 API
RouteAnalysisSettings Properties
RouteAnalysisSettings Class See Also Send Feedback

The RouteAnalysisSettings type exposes the following members.

Properties

 | Name | Description
Public property | AnalysisZoneBottomOffset | The bottom plane offset, in ft, of the zone used in route calculation. Default value is 8".
Public property | AnalysisZoneTopOffset | The top plane offset, in ft, for the zone used in route calculation. Default value is 6'8".
Public property | EnableIgnoredCategoryIds | When this setting is true, elements with category ids returned by GetIgnoredCategoryIds will be ignored in route calculation. default is true as all elements with the Door Category Id are ignored by default.
Public property | IgnoreImports | If true, import instances are ignored by route calculation. For imports to be ignored, also EnableIgnoredCategoryIds must be set to true.
Public property | MinimumLength | The constant storing minimum allowed length of path of travel

See Also

RouteAnalysisSettings Class
Autodesk.Revit.DB.Analysis Namespace

AnalysisZoneBottomOffset Property

[image]