Revit 2021.1 API
DuctFittingAndAccessoryPressureDropData Members
DuctFittingAndAccessoryPressureDropData Class Methods Properties See Also Send Feedback

The DuctFittingAndAccessoryPressureDropData type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the DuctFittingAndAccessoryPressureDropData
Public method | GetDuctFittingAndAccessoryData | Returns the fitting and accessory information.
Public method | GetPresureDropItems | Returns the pressure drop items.
Public method | SetDefaultEntity | Stores the default entity in the data.

Properties

 | Name | Description
Public property | CalculationType | The calculation type, a bitmask of FittingAndAccessoryCalculationType.
Public property | IsCurrentEntityValid | True if the current settings stored in the entity is valid.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

DuctFittingAndAccessoryPressureDropData Class
Autodesk.Revit.DB.Mechanical Namespace

DuctFittingAndAccessoryPressureDropData Methods

[image] [image]