Revit 2021.1 API
DuctPressureDropData Properties
DuctPressureDropData Class See Also Send Feedback

The DuctPressureDropData type exposes the following members.

Properties

 | Name | Description
Public property | CategoryId | The category id of duct curves. It will be OST_DuctCurves, OST_FlexDuctCurves, or OST_PlaceHolderDucts.
Public property | Coefficient | The coefficient of the duct.
Public property | Density | The density of the duct.Units: (kg/ft³).
Public property | EquivalentDiameter | The equivalent diameter of the duct. Units: (ft).
Public property | Flow | The flow of the duct. Units: (ft³/s).
Public property | Friction | The friction of the duct. Units: (kg/(ft²·s²)).
Public property | Height | The height of the duct. If the duct is round, it will be equal to the diameter of the duct. Units: (ft).
Public property | HydraulicDiameter | The hydraulic diameter of the duct. Units: (ft).
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Length | The length of the duct. Units: (ft).
Public property | Level | The calculation level of the system.
Public property | PressureDrop | The pressure drop of the duct. Units: (kg/(ft·s²)).
Public property | ReynoldsNumber | The reynolds number of the duct.
Public property | Roughness | The roughness of the duct. Units: (ft).
Public property | Shape | The profile type of the duct.
Public property | Velocity | The velocity of the duct. Units: (ft/s).
Public property | VelocityPressure | The velocity pressure of the duct. Units: (kg/(ft·s²)).
Public property | Viscosity | The viscosity of the duct. Units: (kg/(ft·s)).
Public property | WidthOrDiameter | The diameter of the duct with round profile, or the width of the duct with other profiles. Units: (ft).

See Also

DuctPressureDropData Class
Autodesk.Revit.DB.Mechanical Namespace

Coefficient Property

[image]