Revit 2021.1 API
ExternalService Methods
ExternalService Class See Also Send Feedback

The ExternalService type exposes the following members.

Methods

 | Name | Description
Public method | AddServer | Registers a server with its service.
Public method | Dispose |
Public method | GetDefaultServerId | Returns the Id of the default server if one was assigned to the service.
Public method | GetOptions | A copy of the options the service was registered with.
Public method | GetPublicAccessKey | Access key to use to execute a service.
Public method | GetRegisteredServerIds | Returns Ids of all servers registered for the service.
Public method | GetServer | Returns the instance that provides implementation for a registered server.
Public method | IsRegisteredServerId | Checks if the Id represents a valid server that has been registered for the service.
Public method | RemoveServer | Removes/unregisters a server from the service.

See Also

ExternalService Class
Autodesk.Revit.DB.ExternalService Namespace

AddServer Method

[image]