Revit 2021.1 API
DirectShapeOptions Members
DirectShapeOptions Class Methods Properties See Also Send Feedback

The DirectShapeOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the DirectShapeOptions

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ReferencingOption | Whether or not the geometry stored in a DirectShape object may be referenced.
Public property | RoomBoundingOption | Identifies whether the DirectShape supports an option for the "Room Bounding" parameter to permit participation in room boundary calculations.

See Also

DirectShapeOptions Class

DirectShapeOptions Methods

[image] [image]