Revit 2021.1 API
AlphanumericRevisionSettings Constructor (IList<(Of <(<'String>)>)>, String, String)
AlphanumericRevisionSettings Class See Also Send Feedback
Constructs an AlphanumericRevisionSettings object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2016

Syntax

C#
public AlphanumericRevisionSettings(
    IList<string> sequence,
    string prefix,
    string suffix
)
Visual Basic
Public Sub New ( _
    sequence As IList(Of String), _
    prefix As String, _
    suffix As String _
)
Visual C++
public:
AlphanumericRevisionSettings(
    IList<String^>^ sequence,
    String^ prefix,
    String^ suffix
)

Parameters

sequence
Type: System.Collections.Generic..::..IList<(Of <(<'String>)>)>

The custom sequence to be used as numbers for revisions with the Alphanumeric RevisionNumberType.

If there are more alphanumeric revisions than there are strings in the sequence, subsequent alphanumeric revisions will be assigned duplicated characters. For example, if the sequence provided were ["X", "Y"], the first alphanumeric revision would be shown as "X", the second as "Y", the third as "XX", then "YY", "XXX", etc.

prefix
Type: System..::..String
The prefix string for each revision number in the sequence.
suffix
Type: System..::..String
The suffix string for each revision number in the sequence.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Input sequence contains invalid entries.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AlphanumericRevisionSettings Class
AlphanumericRevisionSettings Overload

AlphanumericRevisionSettings Methods

[image] [image]