Revit 2021.1 API
Entity Methods
Entity Class See Also Send Feedback

The Entity type exposes the following members.

Methods

 | Name | Description
Public method | Clear(String) | Resets the field to its default value.
Public method | Clear(Field) | Resets the field to its default value.
Public method | Dispose |
Public method | Get<(Of <<'(FieldType>)>>)(String) | Retrieves the value of the field in the entity.
Public method | Get<(Of <<'(FieldType>)>>)(Field) | Retrieves the value of the field in the entity.
Public method | Get<(Of <<'(FieldType>)>>)(String, DisplayUnitType) | Obsolete. Retrieves the value of the field in the entity.
Public method | Get<(Of <<'(FieldType>)>>)(String, ForgeTypeId) | Retrieves the value of the field in the entity.
Public method | Get<(Of <<'(FieldType>)>>)(Field, DisplayUnitType) | Obsolete. Retrieves the value of the field in the entity.
Public method | Get<(Of <<'(FieldType>)>>)(Field, ForgeTypeId) | Retrieves the value of the field in the entity.
Public method | IsValid | Checks whether this Entity has a live Schema corresponding to it.
Public method | ReadAccessGranted | Checks whether this Entity may be retrieved by the current add-in.
Public method | RecognizedField | Checks whether a Field belongs to the same Schema as this Entity.
Public method | Set<(Of <<'(FieldType>)>>)(String, FieldType) | Stores the value of the field in the entity.
Public method | Set<(Of <<'(FieldType>)>>)(Field, FieldType) | Stores the value of the field in the entity.
Public method | Set<(Of <<'(FieldType>)>>)(String, FieldType, DisplayUnitType) | Obsolete. Stores the value of the field in the entity.
Public method | Set<(Of <<'(FieldType>)>>)(String, FieldType, ForgeTypeId) | Stores the value of the field in the entity.
Public method | Set<(Of <<'(FieldType>)>>)(Field, FieldType, DisplayUnitType) | Obsolete. Stores the value of the field in the entity.
Public method | Set<(Of <<'(FieldType>)>>)(Field, FieldType, ForgeTypeId) | Stores the value of the field in the entity.
Public method | WriteAccessGranted | Checks whether this Entity may be stored by the current add-in.

See Also

Entity Class
Autodesk.Revit.DB.ExtensibleStorage Namespace

Clear Method

[image] [image]