Revit 2021.1 API
EdgeArray Members
EdgeArray Class Constructors Methods Properties See Also Send Feedback

The EdgeArray type exposes the following members.

Constructors

 | Name | Description
Public method | EdgeArray | Initializes a new instance of the EdgeArray class

Methods

 | Name | Description
Public method | Append | Add the edge to the end of the array.
Public method | Clear | Removes every edge from the array, rendering it empty.
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | Insert | Insert the specified edge into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | Item | Gets or sets an edge at a specified index within the array.
Public property | Size | Returns the number of edges that are in the array.

See Also

EdgeArray Class

EdgeArray Methods

[image] [image]