Revit 2021.1 API
RoutingConditions Methods
RoutingConditions Class See Also Send Feedback

The RoutingConditions type exposes the following members.

Methods

 | Name | Description
Public method | AppendCondition | Appends a routing condition to the end of existing routing conditions. Note that the first item (indexed at 0) is the condition for the primary connector.
Public method | Clear | Clear all existing conditions
Public method | Dispose |
Public method | GetConditionAt | Gets the routing condition at the specified index position.
Public method | GetNumberOfConditions | Gets the number of included routing conditions.

See Also

RoutingConditions Class

AppendCondition Method

[image]