Revit 2021.1 API
Transform2D Methods
Transform2D Class See Also Send Feedback

The Transform2D type exposes the following members.

Methods

 | Name | Description
Public method | AlmostEqual | Determines whether this transformation and the specified transformation are the same within the tolerance (1.0e-09).
Public method | Assign | Assigns values from the input transformation to this transformation.
 | CreateIdentity | Creates the identity transformation.
Public method | Dispose |
Public method | GetInverse | Gets the inverse transformation of this transformation.
Public method | Multiply | Multiplies this transformation by the specified transformation and returns the result.
Public method | OfPoint | Applies the transformation to the point and returns the result.
Public method | OfVector | Applies the transformation to the vector and returns the result.
Public method | PostScale | Scales both the linear and translational parts of this transformation and returns the result.
Public method | PreScale | Scales the linear part of this transformation and returns the result.
Public method | SetToIdentity | Set this TrfUV to the identity transform.
Public method | TransformUVDomainIfPossible | Transforms an envelope (BoundingBoxUV) for one surface to an envelope for a coincident but differently parameterized surface.

See Also

Transform2D Class

AlmostEqual Method

[image]