Revit 2021.1 API
StairsPath Members
StairsPath Class Methods Properties See Also Send Feedback

The StairsPath type exposes the following members.

Methods

 | Name | Description
 | CanCreateOnMultistoryStairs | Checks if more stairs paths can be added on the plan views of a multistory stairs.
 | Create | Creates a new stairs path for the specified stairs with the specified stairs path type only in the plan view.
 | CreateOnMultistoryStairs | Creates a new stairs path for the stairs in a multistory stairs with the specified stairs path type only in the plan view.

Properties

 | Name | Description
Public property | DownText | The stairs down text.
Public property | DownTextOffset | The offset of stairs down text.
Public property | ShowDownText | Represents whether show stairs down text or not.
Public property | ShowUpText | Represents whether show stairs up text or not.
Public property | StairsId | The host stairs element id.
Public property | StairsPathOffset | The offset of stairs path to center line of stairs.
Public property | TextOrientation | The orientation of stair up and down text.
Public property | UpText | The stairs up text.
Public property | UpTextOffset | The offset of stairs up text.

See Also

StairsPath Class
Autodesk.Revit.DB.Architecture Namespace

StairsPath Methods

[image] [image]