Revit 2021.1 API
AirSystemData Properties
AirSystemData Class See Also Send Feedback

The AirSystemData type exposes the following members.

Properties

 | Name | Description
Public property | AirFanType | The fan type.
Public property | ChilledWaterLoopId | The chilled water loop used for the chilled water option of cooling coil.
Public property | CoolingCoilType | The cooling coil type. Note this property change would reset the chilled water loop.
Public property | HeatExchangerType | The type of heat exchanger.
Public property | HeatingCoilType | The heating coil type. Note this property change would reset the heating water loop.
Public property | HeatingHotWaterLoopId | The water loop element id for the hot-water heating coil.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | PreheatCoilType | The preheat coil type. Note this property change would reset the preheat water loop.
Public property | PreheatHotWaterLoopId | The water loop element id for the hot-water preheat coil.

See Also

AirSystemData Class
Autodesk.Revit.DB.Mechanical Namespace

AirFanType Property

[image]