Revit 2021.1 API
SystemsAnalysisOptions Members
SystemsAnalysisOptions Class Constructors Methods Properties See Also Send Feedback

The SystemsAnalysisOptions type exposes the following members.

Constructors

 | Name | Description
Public method | SystemsAnalysisOptions | Constructs a new instance of the options.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the SystemsAnalysisOptions

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | OutputFolder | The path of the output folder for systems analysis.
Public property | WeatherFile | The file name of the EnergyPlus weather (*.epw).
Public property | WorkflowFile | The file name of the EnergyPlus workflow script.

See Also

SystemsAnalysisOptions Class
Autodesk.Revit.DB.Analysis Namespace

SystemsAnalysisOptions Constructor

[image]