Revit 2021.1 API
WireMaterialTypeSet Members
WireMaterialTypeSet Class Constructors Methods Properties See Also Send Feedback

The WireMaterialTypeSet type exposes the following members.

Constructors

 | Name | Description
Public method | WireMaterialTypeSet | Initializes a new instance of the WireMaterialTypeSet class

Methods

 | Name | Description
Public method | Clear | Removes every wire material type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a wire material type within the set.
Public method | Erase | Removes a specified wire material type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | Insert | Insert the specified wire material type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | Size | Returns the number of wire material types that are in the set.

See Also

WireMaterialTypeSet Class
Autodesk.Revit.DB.Electrical Namespace

WireMaterialTypeSet Constructor

[image]