Revit 2021.1 API
RevisionSettings Methods
RevisionSettings Class See Also Send Feedback

The RevisionSettings type exposes the following members.

Methods

 | Name | Description
Public method | GetAlphanumericRevisionSettings | Returns a copy of the AlphanumericRevisionSettings owned by this RevisionSettings object.
Public method | GetNumericRevisionSettings | Returns a copy of the NumericRevisionSettings owned by this RevisionSettings object.
 | GetRevisionSettings | Returns the RevisionSettings for the given project document.
Public method | IsAcceptableRevisionCloudSpacing | Rounds the given raw value and checks whether it is an acceptable cloud spacing value after it is rounded.
 | RoundRevisionCloudSpacing | Rounds the given revision cloud spacing value according to the document's settings.
Public method | SetAlphanumericRevisionSettings | Replaces the current alphanumeric revision numbering settings with the specified AlphanumericRevisionSettings.
Public method | SetNumericRevisionSettings | Replaces the current numeric revision numbering settings with the specified NumericRevisionSettings.

See Also

RevisionSettings Class

GetAlphanumericRevisionSettings Method

[image]