Revit 2021.1 API
IFCOpeningData Members
IFCOpeningData Class Methods Properties See Also Send Feedback

The IFCOpeningData type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the IFCOpeningData
Public method | GetExtrusionData | Gets extrusion data.
Public method | GetOpeningSolids | Gets opening solids.

Properties

 | Name | Description
Public property | IsRecess | Trus if it is a recess, false if it is an opening.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | OpeningElementId | The opening element id.

See Also

IFCOpeningData Class
Autodesk.Revit.DB.IFC Namespace

IFCOpeningData Methods

[image] [image]