Revit 2021.1 API
AnalysisDisplayColoredSurfaceSettings Members
AnalysisDisplayColoredSurfaceSettings Class Constructors Methods Properties See Also Send Feedback

The AnalysisDisplayColoredSurfaceSettings type exposes the following members.

Constructors

 | Name | Description
Public method | AnalysisDisplayColoredSurfaceSettings()()()() | Constructs a default instance of colored surface settings.
Public method | AnalysisDisplayColoredSurfaceSettings(AnalysisDisplayColoredSurfaceSettings) | Constructs a new copy of the input AnalysisDisplayColoredSurfaceSettings object.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the AnalysisDisplayColoredSurfaceSettings
Public method | IsEqual | Compares two colored surface settings objects.

Properties

 | Name | Description
Public property | GridColor | Color of grid lines.
Public property | GridLineWeight | Line weight of grid lines.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ShowContourLines | If true, show contour lines in the analysis display.
Public property | ShowGridLines | If true, show grid lines in the analysis display.
Public property | Transparency | Transparency percentage of colored surface

See Also

AnalysisDisplayColoredSurfaceSettings Class
Autodesk.Revit.DB.Analysis Namespace

AnalysisDisplayColoredSurfaceSettings Constructor

[image] [image]