Revit 2021.1 API
HorizontalCurveEndpoint Properties
HorizontalCurveEndpoint Class See Also Send Feedback

The HorizontalCurveEndpoint type exposes the following members.

Properties

 | Name | Description
Public property | NextCurveType | The HorizontalCurveType of the curve which connects the endpoint to the next displayed curve. If this endpoint's Station equals DisplayedEndStation, returns Unknown curve type.
Public property | PreviousCurveType | The HorizontalCurveType of the curve which connects the endpoint to the previous displayed curve. If this endpoint's Station equals DisplayedStartStation, returns Unknown curve type.
Public property | Station | The endpoint's station value.

See Also

HorizontalCurveEndpoint Class
Autodesk.Revit.DB.Infrastructure Namespace

NextCurveType Property

[image]