Revit 2021.1 API
StairsPathType Members
StairsPathType Class Methods Properties See Also Send Feedback

The StairsPathType type exposes the following members.

Methods

 | Name | Description

Properties

 | Name | Description
Public property | ArrowheadTypeId | The arrow head type of the stairs path.
Public property | DistanceToCutMark | The distance from the stairs path arrow to cut mark.
Public property | DrawForEachRun | True if stairs paths should be drawn for each run, false if it should be drawn for the whole stairs.
Public property | EndAtRiser | Represents whether the stairs path ends at the riser.
Public property | FullStepArrow | True if the arrow fills the full step width, false if it fills by the specified arrow size.
Public property | LineShapeAtCorner | The line shape of stairs path at the corner.
Public property | ShowArrowheadToCutMark | True if the stairs path arrowhead should be shown to the cutmark, false if the arrow head is not shown.
Public property | StairsPathDirection | The style of the stairs path.
Public property | StartExtension | The start extension length of the stairs path.
Public property | StartFromRiser | True if the stairs path starts from the riser, false if it starts from the tread.
Public property | StartSymbolTypeId | The start symbol type of stairs path.

See Also

StairsPathType Class
Autodesk.Revit.DB.Architecture Namespace

StairsPathType Methods

[image] [image]