Revit 2021.1 API
ExportLinetypeTable Members
ExportLinetypeTable Class Constructors Methods Properties See Also Send Feedback

The ExportLinetypeTable type exposes the following members.

Constructors

 | Name | Description
Public method | ExportLinetypeTable | Constructs a new ExportLinetypeTable with default values.

Methods

 | Name | Description
Public method | Add | Inserts a (key, info) pair into Export line type table.
Public method | Clear | Removes all contents stored in Export line type table.
Public method | ContainsKey | Checks whether a pattern key exists in the table.
Public method | Dispose | Releases all resources used by the ExportLinetypeTable
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetExportLinetypeInfo | Gets a copy of the ExportLinetypeInfo corresponding to the given ExportLinetypeKey.
Public method | GetKeys | Gets all the keys stored in the map.
Public method | GetLinetypeTableIterator | Returns a ExportLinetypeTableIterator that iterates through the collection.
Public method | GetValues | Returns all the values stored in the map.
Public method | Remove | Removes the pair (key, info) corresponding to the given ExportLinetypeKey.

Properties

 | Name | Description
Public property | Count | Count of the items contained in the collection.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Item | A copy of the ExportLinetypeInfo for the linetype's ExportLinetypeKey.

See Also

ExportLinetypeTable Class

ExportLinetypeTable Constructor

[image]