Revit 2021.1 API
DocumentChangedEventArgs Members
DocumentChangedEventArgs Class Methods Properties See Also Send Feedback

The DocumentChangedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | GetAddedElementIds()()()() | Returns set of elements newly added to the document.
Public method | GetAddedElementIds(ElementFilter) | Returns set of newly added elements that pass the filter.
Public method | GetDeletedElementIds | Returns set of elements that were deleted from the document.
Public method | GetDocument | Returns document associated with this event
Public method | GetModifiedElementIds()()()() | Returns set of elements that were modified.
Public method | GetModifiedElementIds(ElementFilter) | Returns set of elements that were modified according to the given element filter.
Public method | GetTransactionNames | Returns names of the transactions associated with this event

Properties

 | Name | Description
Public property | Operation | The operation associated with this event

See Also

DocumentChangedEventArgs Class
Autodesk.Revit.DB.Events Namespace

DocumentChangedEventArgs Methods

[image] [image]