Revit 2021.1 API
TriangulatedShellComponent Members
TriangulatedShellComponent Class Methods Properties See Also Send Feedback

The TriangulatedShellComponent type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Empties the contents of this TriangulatedShellComponent.
Public method | Dispose | Releases all resources used by the TriangulatedShellComponent
Public method | GetTriangle | Returns the triangle corresponding to the given index.
Public method | GetVertex | Returns the vertex with a given index.

Properties

 | Name | Description
Public property | IsClosed | True if and only if the triangulation represents a topologically closed shell (i.e., each edge is shared by two triangles).
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | TriangleCount | The number of triangles in the triangulation.
Public property | VertexCount | The number of vertices in the triangulation.

See Also

TriangulatedShellComponent Class

TriangulatedShellComponent Methods

[image] [image]