Revit 2021.1 API
NumberingSchema Methods
NumberingSchema Class See Also Send Feedback

The NumberingSchema type exposes the following members.

Methods

 | Name | Description
Public method | AppendSequence | Appends all elements of one numbering sequence to the end of another sequence.
Public method | AssignElementsToSequence | Assigns the input elements to a sequence identified by the given partition name.
Public method | ChangeNumber | Replaces an existing number with a new one (that does not exist yet).
 | GetMinimumNumberOfDigits | Returns the minimum number of digits to be used for formating the Number parameter of all enumerable elements of the given document.
 | GetNumberingSchema | Returns an instance of the specified Numbering Schema in the given document.
Public method | GetNumberingSequences | Returns all numbering sequences within this numbering schema.
Public method | GetNumbers | Returns all numbers currently used in the given numbering sequence
 | GetSchemasInDocument | Returns a set of Ids of all Numbering Schema elements for a given document.
 | IsValidPartitionName | Tests if the given string can be used as a name for a numbering partition.
Public method | MergeSequences | Merges all elements from given numbering sequences to a new sequence.
Public method | MoveSequence | Moves all elements of a numbering sequence from one partition to another.
Public method | RemoveGaps | Removes gaps, if any, in a numbering sequence
 | SetMinimumNumberOfDigits | Sets a new value for the minimum number of digits to be used for formating the Number parameter of all numbered elements of the given document.
Public method | ShiftNumbers | Shifts all numbers in the sequence so the starting number has the given value.

See Also

NumberingSchema Class

AppendSequence Method

[image]