Revit 2021.1 API
IndexBuffer..::..GetMappedHandle Method
IndexBuffer Class See Also Send Feedback
Gets a handle to the buffer's memory that has been mapped. Writing data to the buffer using the handle is an alternative to using stream objects.

Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2017

Syntax

C#
public IntPtr GetMappedHandle()
Visual Basic
Public Function GetMappedHandle As IntPtr
Visual C++
public:
IntPtr GetMappedHandle()

Return Value

The handle to the mapped memory or nullptr when the buffer is not mapped.

See Also

IndexBuffer Class
Autodesk.Revit.DB.DirectContext3D Namespace

IsValid Method

[image]