Revit 2021.1 API
WireSizeSet Members
WireSizeSet Class Constructors Methods Properties See Also Send Feedback

The WireSizeSet type exposes the following members.

Constructors

 | Name | Description
Public method | WireSizeSet | Initializes a new instance of the WireSizeSet class

Methods

 | Name | Description
Public method | Clear | Removes every wire size from the set, rendering it empty.
Public method | Contains | Tests for the existence of a wire size within the set.
Public method | Erase | Removes a specified wire size from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | Insert | Insert the specified wire size into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | Size | Returns the number of wire sizes that are in the set.

See Also

WireSizeSet Class
Autodesk.Revit.DB.Electrical Namespace

WireSizeSet Constructor

[image]