Revit 2021.1 API
DuctFittingAndAccessoryConnectorData Members
DuctFittingAndAccessoryConnectorData Class Methods Properties See Also Send Feedback

The DuctFittingAndAccessoryConnectorData type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the DuctFittingAndAccessoryConnectorData
Public method | GetCoordination | Gets the coordination of the connector

Properties

 | Name | Description
Public property | Angle | the angle of the fitting, Units:(rad).
Public property | Diameter | The connector diameter, Units:(ft).
Public property | Flow | The connector flow, Units:(ft³/s)
Public property | FlowDirection | the flow direction of this connector, In or Out.
Public property | Height | The connector height, Units:(ft).
Public property | Index | return the index of this connector
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LinkIndex | the index of the connector which is linked with this connector
Public property | Profile | The connector profile.
Public property | VelocityPressure | The connector velocity pressure. Units: (kg/(ft·s²)).
Public property | Width | The connector width, Units:(ft).

See Also

DuctFittingAndAccessoryConnectorData Class
Autodesk.Revit.DB.Mechanical Namespace

DuctFittingAndAccessoryConnectorData Methods

[image] [image]