Revit 2021.1 API
SpacingRule Members
SpacingRule Class Methods Properties See Also Send Feedback

The SpacingRule type exposes the following members.

Methods

 | Name | Description
Public method | SetLayoutFixedDistance | Set the Layout property to FixedDistance.
Public method | SetLayoutFixedNumber | Set the Layout property to FixedNumber.
Public method | SetLayoutMaximumSpacing | Set the Layout property to MaximumSpacing.
Public method | SetLayoutMinimumSpacing | Set the Layout property to MinimumSpacing.
Public method | SetLayoutNone | Set the Layout property to None.

Properties

 | Name | Description
Public property | BeltMeasurement | On a curved surface, BeltMeasurement specifies where the grid's distances are measured.
Public property | Distance | The exact distance between layout lines.
Public property | GridlinesRotation | An additional rotation to be applied to this set of grid lines.
Public property | HasBeltMeasurement | True if the gridlines are not parallel due to surface curvature, and the BeltMeasurement property therefore applies.
Public property | Justification | The justification of the lines within the region.
Public property | Layout | A choice of several gridline layout rules.
Public property | Number | The exact number of lines in the region.
Public property | Offset | An additional offset applied to the first gridline.

See Also

SpacingRule Class

SpacingRule Methods

[image] [image]