Revit 2021.1 API
DirectShape Members
DirectShape Class Methods Properties See Also Send Feedback

The DirectShape type exposes the following members.

Methods

 | Name | Description
Public method | AppendShape(IList<(Of <<'(GeometryObject>)>>)) | Appends the collection of GeometryObjects into the model shape representation stored in this DirectShape.
Public method | AppendShape(ShapeBuilder) | Appends shape built by the supplied ShapeBuilderObject to shape representation stored in this DirectShape. The data stored in the supplied ShapeBuilder object will be cleared.
Public method | AppendShape(IList<(Of <<'(GeometryObject>)>>), DirectShapeTargetViewType) | Appends the collection of GeometryObjects into the model or view specific shape representation stored in this DirectShape. Passing DirectShapeTargetViewType.Default as view type will cause the model shape to be updated.
Public method | AreOptionsValid | Validates that the given DirectShapeOptions are allowed for this particular DirectShape.
Public method | AreOptionsValidForTransientDirectShape | Validates that the given DirectShapeOptions are allowed if this DirectShape is transient.
Public method | CanCreateParts | Indicates if it is possible to create parts from this DirectShape element.
 | CreateElement | Creates a DirectShape object and adds it to document.
 | CreateElementInstance | Creates a DirectShape object and adds it to document.
 | CreateGeometryInstance | Creates a copy of a definition shape that was created earlier.
Public method | GetOptions | Gets a copy of the current options for this DirectShape.
 | IsSupportedDocument | Tests whether a DirectShape or a DirectShapeType may be created in this document.
 | IsValidCategoryId | Test the category id to make sure the category is allowed for a DirectShape or DirectShapeType.
Public method | IsValidGeometry | Validates geometry to be stored in a DirectShape. Suitable geometry validation is performed. Additionally, the geometry must make sense as a shape representation for the category assigned to this DirectShape object.
Public method | IsValidShape(IList<(Of <<'(GeometryObject>)>>)) | Validates shape to be stored in a DirectShape. Supercedes and extends IsValidGeometry().
Public method | IsValidShape(IList<(Of <<'(GeometryObject>)>>), DirectShapeTargetViewType) | Validates view-specific shape to be stored in a DirectShape. Expects a non-default view type.
Public method | IsValidTypeId | Tests the type id to make sure it satisfies the following conditions It is a valid element id.It corresponds to a valid DirectShapeType.The DirectShapeType has the same category assigned. Additionally, this functions tests that the current type id in this DirectShape is invalid. The type id is initialized to invalidElementId by the create functions. Once it is set, it may no longer be changed.
Public method | SetName | Sets the name for the DirectShape element.
Public method | SetOptions | Sets the options to use for this DirectShape.
Public method | SetShape(IList<(Of <<'(GeometryObject>)>>)) | Builds the shape of this object from the supplied collection of GeometryObjects. The objects are copied. If the new shape is identical to the old one, the old shape will be kept.
Public method | SetShape(ShapeBuilder) | Sets the shape of this object to the one accumulated in the supplied Builder object. If the new shape is identical to the old one, the old shape will be kept.
Public method | SetShape(IList<(Of <<'(GeometryObject>)>>), DirectShapeTargetViewType) | Builds the shape of this object from the supplied collection of GeometryObjects. The objects are copied. If the new shape is identical to the old one, the old shape will be kept.
Public method | SetTypeId | Sets the DirectShapeType for the DirectShape element.

Properties

 | Name | Description
Public property | ApplicationDataId | A text string that identifies the data to the creating application.
Public property | ApplicationId | A text string that identifies the creating application.
Public property | TypeId | Element id of a DirectShapeType object that holds properties to be shared by this element. Optional.

See Also

DirectShape Class

AppendShape Method

[image] [image]