Revit 2021.1 API
WireframeBuilder Methods
WireframeBuilder Class See Also Send Feedback

The WireframeBuilder type exposes the following members.

Methods

 | Name | Description
Public method | AddCurve | Add a curve to the shape representation stored in this WireframeBuilder.
Public method | AddPoint | Add a point to the shape representation stored in this WireframeBuilder.
Public method | Reset | Clears the accumulated geometry.
 | ValidateCurve | Validates curve to be added to the wireframe shape being constructed. Used by addCurve to validate input. This function may be used to pre-validate the geometry being added to avoid an exception from AddCurve().
 | ValidatePoint | Validates the point object to be added to the wireframe shape being constructed. Used by AddPoint() to validate input.

See Also

WireframeBuilder Class

AddCurve Method

[image]