Revit 2021.1 API
ImageType Properties
ImageType Class See Also Send Feedback

The ImageType type exposes the following members.

Properties

 | Name | Description
 | ExternalResourceType | The type of external resources that represents images.
Public property | Height | The vertical size of the image
Public property | HeightInPixels | Number of pixels in the vertical direction of the image
Public property | IsViewImage | Obsolete. The ImageType was created via "Save to Project as Image" function. For such ImageTypes the file path is an empty string.
Public property | PageNumber | The number of the page in a multi-page file, that was used to create the image in the ImageType.
Public property | Path | The path to the file from which the ImageType was loaded.
Public property | PathType | The path type that was used to refer to the file from which the ImageType was loaded.
Public property | Resolution | The size of the pixels in the image, expressed in dots-per-inch (dpi)
Public property | Source | The source of the image in the ImageType.
Public property | Status | The status of the image
Public property | Width | The horizontal size of the image
Public property | WidthInPixels | Number of pixels in the horizontal direction of the image

See Also

ImageType Class

ExternalResourceType Property

[image]