Revit 2021.1 API
BalusterPlacement Members
BalusterPlacement Class Methods Properties See Also Send Feedback

The BalusterPlacement type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the BalusterPlacement

Properties

 | Name | Description
Public property | BalusterPattern | Accesses the object containing properties related to the baluster pattern.
Public property | BalusterPerTreadFamilyId | The id of baluster per tread family.
Public property | BalusterPerTreadNumber | The number of balusters per tread.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | PostPattern | Accesses the object containing properties related to the post pattern.
Public property | UseBalusterPerTreadOnStairs | If true, one or more balusters will be included on each tread of an associated stair. If false, this is not guaranteed to happen.

See Also

BalusterPlacement Class
Autodesk.Revit.DB.Architecture Namespace

BalusterPlacement Methods

[image] [image]