Revit 2021.1 API
IFCProductWrapper Methods
IFCProductWrapper Class See Also Send Feedback

The IFCProductWrapper type exposes the following members.

Methods

 | Name | Description
Public method | AddAnnotation | Adds an annotation handle to associate with the IfcProduct in this wrapper.
Public method | AddBuilding | Adds an IfcBuilding handle to associate with the IfcProduct in this wrapper.
Public method | AddElement | Adds an IfcElement handle to associate with the IfcProduct in this wrapper.
Public method | AddFinishMaterial | Adds a material handle to associate with the IfcProduct in this wrapper.
Public method | AddSite | Adds a site (IfcObject) handle to associate with the IfcProduct in this wrapper.
Public method | AddSpace | Adds an IfcSpace handle to associate with the IfcProduct in this wrapper.
Public method | ClearFinishMaterials | Clear finish materials in this wrapper.
 | Create(IFCProductWrapper) | Establishes a new product manager for elements and objects derived from a parent product manager.
 | Create(ExporterIFC, Boolean) | Establishes a new baseline product manager for elements and objects.
 | Create(IFCProductWrapper, Boolean) | Establishes a new product manager for elements and objects derived from a parent product manager, allowing override of allowRelateToLevel
Public method | Dispose |
Public method | FindExtrusionCreationParameters | Obtains the extrusion creation data associated with the given element.
Public method | GetAllObjects | Gets all objects associated with the IfcProduct in this wrapper.
Public method | GetAnElement | Gets the first element handle added to this wrapper.

See Also

IFCProductWrapper Class
Autodesk.Revit.DB.IFC Namespace

AddAnnotation Method

[image]