Revit 2021.1 API
InternalDefinition Properties
InternalDefinition Class See Also Send Feedback

The InternalDefinition type exposes the following members.

Properties

 | Name | Description
Public property | BuiltInParameter | Tests whether this definition identifies a built-in parameter or not.
Public property | Id | The id of the parameter.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Name | The user-visible name for the parameter. (Overrides Definition..::..Name.)
Public property | ParameterGroup | Id of a built-in parameter group to which the parameter defined by this definition belongs. (Overrides Definition..::..ParameterGroup.)
Public property | ParameterType | Returns the user-visible interpretation of the parameter data. (Overrides Definition..::..ParameterType.)
Public property | VariesAcrossGroups | Whether or not the parameter values can vary across group members.
Public property | Visible | Indicates if the parameter is visible in the Autodesk Revit user interface.

See Also

InternalDefinition Class

BuiltInParameter Property

[image]