Revit 2021.1 API
MassZone Members
MassZone Class Methods Properties See Also Send Feedback

The MassZone type exposes the following members.

Methods

 | Name | Description
Public method | GetCoincidentReferenceFromAdjacentZone | This method is used to get a Reference from an adjacent MassZone that is coincident to a Reference of this MassZone.
Public method | GetEquivalentReferenceFromMassOrLevel | Returns a Reference to a face of a MassEnergyAnalyticalModel element or an element Reference to a MassLevelData element. This Reference represents what the MassZone face was "cut from" when making the MassZone for the level.
Public method | GetMassDataElementIdForZoneFaceReference | MassZone faces come from faces of MassEnergyAnalyticalModel, and those faces have MassSurfaceData or MassLevelData elements associated with them.
Public method | GetReferencesToEnergyAnalysisFaces | Used to get References to all the faces of the MassZone that are used for Energy Analysis.
Public method | IsEmpty | Indicates if MassZone has no geometry. Such zones should not be shown to the user.

Properties

 | Name | Description
Public property | ConditionType | The gbXMLConditionType of the MassZone.
Public property | CutByLowerLevel | Indicates the relationship between the MassZone and its lower level.
Public property | CutByUpperLevel | Indicates the relationship between the MassZone and its upper level.
Public property | FloorArea | The floor area of the MassZone.
Public property | IsZoneOccupiable | A MassZone must have a level as its bottom to be occupiable; If it does not, it is still a MassZone, but it is not occupiable
Public property | LowerLevelId | The bottom level defining the MassZone.
Public property | MassEnergyAnalyticalModelId | The ElementId of the MassEnergyAnalyticalModel that the MassZone is derived from.
Public property | MaterialId | The visualization material for the MassZone. Will be InvalidElementId if material is by category or the material type is by MassZoneMaterialTypeMaterialBySurfaceType.
Public property | MaterialType | Indicates how the material of MassZone faces is determined.
Public property | SpaceType | The gbXMLSpaceType of the MassZone.
Public property | SpaceTypeId | The space type element of the MassZone.
Public property | UpperLevelId | The upper level defining the MassZone.
Public property | Volume | The volume of the MassZone.

See Also

MassZone Class
Autodesk.Revit.DB.Analysis Namespace

MassZone Methods

[image] [image]