Revit 2021.1 API
StairsRunType Properties
StairsRunType Class See Also Send Feedback

The StairsRunType type exposes the following members.

Properties

 | Name | Description
Public property | HasRisers | True if the stairs run will include risers on steps, false otherwise.
Public property | HasTreads | True if the stairs run will include treads on steps, false otherwise.
Public property | IsMonolithic | True if the stairs run is monolithic, false otherwise.
Public property | IsSlanted | True if risers will be slanted, false if they will be straight.
Public property | MaterialId | The material of the stairs run, only available for monolithic stairs run.
Public property | NosingLength | The amount of the tread depth that overhangs the next tread.
Public property | NosingProfile | The id of the nosing profile of the treads.
Public property | RiserProfile | The id of the profile of the risers.
Public property | RiserThickness | The thickness of the risers.
Public property | RiserToTreadConnect | The connection of the riser to tread in relation to each other.
Public property | StructuralDepth | The structural depth of the stairs run, only available for monolithic stairs run.
Public property | TotalDepth | The total depth of the stairs run, only available for monolithic stairs run.
Public property | TreadNosingPosition | Represents on which edges of the nosing to apply the nosing profile.
Public property | TreadProfile | The id of the profile of the treads.
Public property | TreadThickness | The thickness of the treads.
Public property | UndersideSurfaceStyle | The underside surface style of the stairs run, only available for monolithic stairs run.

See Also

StairsRunType Class
Autodesk.Revit.DB.Architecture Namespace

HasRisers Property

[image]