Revit 2021.1 API
ElectricalEquipment Properties
ElectricalEquipment Class See Also Send Feedback

The ElectricalEquipment type exposes the following members.

Properties

 | Name | Description
Public property | CircuitNamingSchemeId | The CircuitNamingSchemeId used in the Electrical Equipment. The CircuitNamingSchemeId is used to retrieve the circuit naming scheme id of the Electrical Equipment.
Public property | DistributionSystem | get or set the Distribution System for the Electrical Equipment.
Public property | IsSwitchboard | The electrical equipment is a switchboard or not. This property returns true if the electrical equipment is a switchboard.
Public property | MaxNumberOfCircuits | The maximum number of circuits for switchboard. The quantity of circuits can be assigned to switchboard through breaker.

See Also

ElectricalEquipment Class
Autodesk.Revit.DB.Electrical Namespace

CircuitNamingSchemeId Property

[image]