Revit 2021.1 API
IFCAnyHandle Methods
IFCAnyHandle Class See Also Send Feedback

The IFCAnyHandle type exposes the following members.

Methods

 | Name | Description
Public method | CreateAggregateAttribute | Creates an attribute that is an aggregate.
Public method | Delete | Deletes the handle.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | GetAttribute | Gets the attribute by name.
Public method | GetHashCode | Gets the integer value of the id as hash code (Overrides Object..::..GetHashCode()()()().)
Public method | IsSubTypeOf | Determines whether the instance is an instance of the specified instance type or a subtype of this instance type.
Public method | IsTypeOf | Determines whether the instance is an instance of exactly the specified instance type.
Public method | SetAttribute(String, IFCAnyHandle) | Sets the attribute value.
Public method | SetAttribute(String, IFCData) | Sets the attribute value.
Public method | SetAttribute(String, Boolean) | Sets the attribute value.
Public method | SetAttribute(String, IList<(Of <<'(IFCAnyHandle>)>>)) |
Public method | SetAttribute(String, IList<(Of <<'(Boolean>)>>)) |
Public method | SetAttribute(String, IList<(Of <<'(Double>)>>)) |
Public method | SetAttribute(String, IList<(Of <<'(Int32>)>>)) |
Public method | SetAttribute(String, IList<(Of <<'(String>)>>)) |
Public method | SetAttribute(String, ISet<(Of <<'(IFCAnyHandle>)>>)) |
Public method | SetAttribute(String, ISet<(Of <<'(Boolean>)>>)) |
Public method | SetAttribute(String, ISet<(Of <<'(Double>)>>)) |
Public method | SetAttribute(String, ISet<(Of <<'(Int32>)>>)) |
Public method | SetAttribute(String, ISet<(Of <<'(String>)>>)) |
Public method | SetAttribute(String, Double) | Sets the attribute value.
Public method | SetAttribute(String, Int32) | Sets the attribute value.
Public method | SetAttribute(String, String) | Sets the attribute value.
Public method | Unset | Clears the handle.
Public method | UnsetAttribute | Unsets the attribute value.

See Also

IFCAnyHandle Class
Autodesk.Revit.DB.IFC Namespace

CreateAggregateAttribute Method

[image]