Revit 2021.1 API
IFCFileReadOptions Members
IFCFileReadOptions Class Constructors Methods Properties See Also Send Feedback

The IFCFileReadOptions type exposes the following members.

Constructors

 | Name | Description
Public method | IFCFileReadOptions | Creates a default IFCFileReadOptions.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the IFCFileReadOptions

Properties

 | Name | Description
Public property | FileName | The full file name of the IFC file to be read.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | XMLConfigFileName | The XML configuration file name. It is used only for reading IFC-XML format file.

See Also

IFCFileReadOptions Class
Autodesk.Revit.DB.IFC Namespace

IFCFileReadOptions Constructor

[image]