Revit 2021.1 API
AnalysisDisplayColorSettings Members
AnalysisDisplayColorSettings Class Constructors Methods Properties See Also Send Feedback

The AnalysisDisplayColorSettings type exposes the following members.

Constructors

 | Name | Description
Public method | AnalysisDisplayColorSettings()()()() | Constructs a default instance of color settings.
Public method | AnalysisDisplayColorSettings(AnalysisDisplayColorSettings) | Constructs a new copy of the input AnalysisDisplayColorSettings object.

Methods

 | Name | Description
Public method | AreIntermediateColorsValid | Verify intermediate color entries
Public method | Colors | Get number of colors, including min, max and intermediate.
Public method | Dispose | Releases all resources used by the AnalysisDisplayColorSettings
Public method | GetIntermediateColors | Get intermediate color entries (other than the minimum and maximum settings).
Public method | IsEqual | Compares two color settings objects.
Public method | SetIntermediateColors | Set intermediate color entries (other than the minimum and maximum settings).

Properties

 | Name | Description
Public property | ColorSettingsType | Stores type of color settings
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | MaxColor | Color assigned to the maximum value.
Public property | MinColor | Color assigned to the minimum value.

See Also

AnalysisDisplayColorSettings Class
Autodesk.Revit.DB.Analysis Namespace

AnalysisDisplayColorSettings Constructor

[image] [image]