Revit 2021.1 API
Solid Members
Solid Class Methods Properties See Also Send Feedback

The Solid type exposes the following members.

Methods

 | Name | Description
Public method | ComputeCentroid | Returns the Centroid of this solid.
Public method | GetBoundingBox | Retrieves a box that circumscribes the solid geometry.
Public method | IntersectWithCurve | Calculates and returns the intersection between a curve and this solid.

Properties

 | Name | Description
Public property | Edges | The edges that belong to the solid.
Public property | Faces | The faces that belong to the solid.
Public property | SurfaceArea | Returns the total surface area of this solid.
Public property | Volume | Returns the signed volume of this solid.

See Also

Solid Class

Solid Methods

[image] [image]