Revit 2021.1 API
IFCAggregateIterator Members
IFCAggregateIterator Class Methods Properties See Also Send Feedback

The IFCAggregateIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the IFCAggregateIterator
Public method | MoveNext | Increments the iterator to the next object in the IFCAggregate.
Public method | Reset | Resets the iterator to the beginning of the aggregate.

Properties

 | Name | Description
Public property | Current | Gets the item at the current position of the iterator.
Protected property | CurrentObject |
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

IFCAggregateIterator Class
Autodesk.Revit.DB.IFC Namespace

IFCAggregateIterator Methods

[image] [image]