Revit 2021.1 API
XYZ..::..Addition Operator
XYZ Class See Also Send Feedback
Adds the two specified vectors and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)

Syntax

C#
public static XYZ operator +(
    XYZ left,
    XYZ right
)
Visual Basic
Public Shared Operator + ( _
    left As XYZ, _
    right As XYZ _
) As XYZ
Visual C++
public:
static XYZ^ operator +(
    XYZ^ left,
    XYZ^ right
)

Parameters

left
Type: Autodesk.Revit.DB..::..XYZ
The first vector.
right
Type: Autodesk.Revit.DB..::..XYZ
The second vector.

Return Value

The vector equal to the sum of the two source vectors.

Remarks

The added vector is obtained by adding each coordinate of the right vector to the corresponding coordinate of the left vector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when left or right is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

XYZ Class

Division Operator

[image]