Revit 2021.1 API
ExporterIFC Properties
ExporterIFC Class See Also Send Feedback

The ExporterIFC type exposes the following members.

Properties

 | Name | Description
Public property | ExportAs2x2 | Identifies if the file version being exported is 2x2.
Public property | ExportAs2x3 | Identifies if the file version being exported is 2x3.
Public property | ExportBaseQuantities | Identifies if the export should include IFC standard quantities currently supported by Revit.
Public property | FileName | The name of the IFC file being exported.
Public property | FileVersion | Identifies the file version being exported.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | SpaceBoundaryLevel | Identifies the level of space boundaries being exported.
Public property | WallAndColumnSplitting | Identifies if division of multi-level walls and columns by levels should take place during this export.

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace

ExportAs2x2 Property

[image]