Revit 2021.1 API
FabricationNetworkChangeService Methods
FabricationNetworkChangeService Class See Also Send Feedback

The FabricationNetworkChangeService type exposes the following members.

Methods

 | Name | Description
Public method | ApplyChange | Applies the previously set changes to the selection of fabrication parts to change the size, change the service, or both.
Public method | ChangeService(ISet<(Of <<'(ElementId>)>>), Int32, Int32) | Changes the service of the selection of fabrication parts.
Public method | ChangeService(ISet<(Of <<'(ElementId>)>>), Int32, Int32, Boolean) | Changes the service of the selection of fabrication parts.
Public method | ChangeSize | Changes the size of the selection of fabrication parts.
Public method | Dispose |
Public method | GetElementsThatFailed | Gets the set of fabrication parts that had failures due to either there was no corresponding part in the service, the size was out of range, or a connection could not be made.
Public method | GetInLinePartTypes | Get a set of element identifiers of fabrication part types for in-line parts.
Public method | GetMapOfAllSizesForStraights | Get a set of FabricationPartSizeMapSet of all straight sizes for all services.
Public method | GetStraightsThatWereNotChanged | Gets the set of fabrication part straights that were not changed due to either there was no corresponding part in the service or the size was out of range.
Public method | SetGroupId | Set the fabrication group identifier to change the elements to.
Public method | SetMapOfInLinePartTypes | Set the mapping of fabrication part types for in-line parts for the service and group to change to.
Public method | SetMapOfSizesForStraights | Set the mapping for sizes of fabrication part straights to change the sizes to.
Public method | SetRestrictGroup | Restrict the placement of parts to only use parts associated to the passed in fabrication group identifier.
Public method | SetSelection | Set the element selection to change the service or size for.
Public method | SetServiceId | Set the fabrication service identifier to change the elements to.

See Also

FabricationNetworkChangeService Class
Autodesk.Revit.DB.Fabrication Namespace

ChangeService Method

[image] [image]