Revit 2021.1 API
DistributionSysTypeSet Members
DistributionSysTypeSet Class Constructors Methods Properties See Also Send Feedback

The DistributionSysTypeSet type exposes the following members.

Constructors

 | Name | Description
Public method | DistributionSysTypeSet | Initializes a new instance of the DistributionSysTypeSet class

Methods

 | Name | Description
Public method | Clear | Removes every DistributionSys type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a DistributionSys type within the set.
Public method | Erase | Removes a specified DistributionSys type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | Insert | Insert the specified DistributionSys type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | Size | Returns the number of DistributionSys types that are in the set.

See Also

DistributionSysTypeSet Class
Autodesk.Revit.DB.Electrical Namespace

DistributionSysTypeSet Constructor

[image]