Revit 2021.1 API
ElectricalSetting Methods
ElectricalSetting Class See Also Send Feedback

The ElectricalSetting type exposes the following members.

Methods

 | Name | Description
Public method | AddDistributionSysType | Add a new distribution system type to project.
Public method | AddVoltageType | Add a new type definition of voltage into project.
Public method | AddWireMaterialType | Add a new type of wire material.
Public method | AddWireType | Add a new wire type to project.
 | GetCircuitNamingSchemeSettings | Gets the circuit naming scheme settings of the project.
 | GetElectricalSettings | Get the electrical settings of the project.
Public method | GetSpecificFittingAngles | Gets the list of specific fitting angles.
Public method | GetSpecificFittingAngleStatus | Gets the status of given specific fitting angle.
Public method | IsValidSpecificFittingAngle | Checks that the given value is a valid specific fitting angle. The specific fitting angles are angles of 90, 60, 45, 30, 22.5 or 11.25 degrees.
Public method | RemoveDistributionSysType | Remove an existing distribution system type from the project.
Public method | RemoveVoltageType | Remove the voltage type from project.
Public method | RemoveWireMaterialType | Remove the wire material type from project.
Public method | RemoveWireType | Remove wire type definition from project.
Public method | SetSpecificFittingAngleStatus | Sets the status of given specific angle.

See Also

ElectricalSetting Class
Autodesk.Revit.DB.Electrical Namespace

AddDistributionSysType Method

[image]