Revit 2021.1 API
BuiltInFailures..::..DPartFailures Properties
BuiltInFailures..::..DPartFailures Class See Also Send Feedback

The BuiltInFailures..::..DPartFailures type exposes the following members.

Properties

Name | Description
BindLinkWillDeleteAllPartsWarning | Bind Link will delete its associated Parts.
DeletingDPartWillDeleteAllPartsWarning | Deleting a Part will delete all associated Parts and the original Element will be made visible.
DeletingDPartWillDeleteMorePartsError | Deleting a Part will delete all associated Parts and the original Element will be made visible.
DeletingOriginalWillDeleteParts | Deletion of this element will delete its associated Parts.
DivideVolumesProfilesEdgeMatchForWidthAll | Division family cannot be used with the selected edge condition for all widths of hosts
DivideVolumesProfilesEdgeMatchForWidthSome | Division family cannot be used with the selected edge condition for some widths of hosts
DivideVolumesProfilesForWidthAll | Division family cannot be used for all widths of hosts
DivideVolumesProfilesForWidthSome | Division family cannot be used for some widths of hosts
DivideVolumesProfilesGapForWidthAll | Division family cannot be used with the selected division gap for all widths of hosts
DivideVolumesProfilesGapForWidthSome | Division family cannot be used with the selected division gap for some widths of hosts
DivideVolumesProfilesNonSlabSources | Some sources of a volume divider are non-slab like.
DivideVolumesSketchesWithProfileUnfriendlyCurves | Sketch contains curves to which profiles cannot be applied or chains of curves.
DivisionContainsNoParts | The division contains no parts.
DivisionContainsNoReferences | The division contains no dividing references.
ElementsAlreadyHaveParts | Some elements already have parts
IneligibleElementsForParts | Creating parts from ineligible elements
NoPartMakerCreatedInEditMode | Nothing will be divided.
PartPhaseParametersConflictWithOriginal | The creation and demolition phases of a part must lie between the corresponding phases of the original.
PartsCannotBeCreatedFromInvalidGeom | Post failure when attempts to create parts from invalid geometry.
RemovingInvalidDPartParents | Can't make Parts out of these Elements.
RemovingUndividedDPartParents | These parts are not intersected by any dividing references. They will be removed from the division.
SourceInUnloadedLink | Some elements already have parts

See Also

BuiltInFailures..::..DPartFailures Class

DeletingDPartWillDeleteAllPartsWarning Property

[image]