Revit 2021.1 API
FillPattern Properties
FillPattern Class See Also Send Feedback

The FillPattern type exposes the following members.

Properties

 | Name | Description
Public property | GridCount | Gets the count of the fill grids in this fill pattern.
Public property | HostOrientation | Orientation to host layer.
Public property | IsSolidFill | Check if the fill pattern is a solid fill pattern.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LengthPerArea | Gets length of all lines that placed on unit area.
Public property | LinesPerLength | Gets the number of solid lines that placed in unit length.
Public property | Name | The name of the fill pattern.
Public property | StrokesPerArea | Gets the number of strokes that placed on unit area.
Public property | Target | Target of this fill pattern applied to.

See Also

FillPattern Class

GridCount Property

[image]