Revit 2021.1 API
ImageTypeOptions Methods
ImageTypeOptions Class See Also Send Feedback

The ImageTypeOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | IsValid | If true the ImageTypeOptions can be used to create or reload an ImageType.
Public method | SetExternalResourceReference | Update the external resource reference to an image.
Public method | SetPath(String) | Update the path of the file that specifies the image to be used. The provided string path must specify a local file. The path can be absolute or relative to the project's location. ImageType will respectively use an absolute or relative path.
Public method | SetPath(String, Boolean) | Update the path of the file that specifies the image to be used. The provided string path must specify a local file. The path can be absolute or relative to the project's location. Additionally, indicate whether the path used by ImageType should be absolute or relative.

See Also

ImageTypeOptions Class

Dispose Method

[image]