Revit 2021.1 API
IndexBuffer Members
IndexBuffer Class Constructors Methods Properties See Also Send Feedback

The IndexBuffer type exposes the following members.

Constructors

 | Name | Description
Public method | IndexBuffer | Constructs the index buffer with the given capacity, measured in short integers.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the IndexBuffer
Public method | GetIndexStreamLine | Gets a stream that can be used to write IndexLine segment primitives into the buffer.
Public method | GetIndexStreamPoint | Gets a stream that can be used to write IndexPoint primitives into the buffer.
Public method | GetIndexStreamTriangle | Gets a stream that can be used to write IndexTriangle primitives into the buffer.
Public method | GetMappedHandle | Gets a handle to the buffer's memory that has been mapped. Writing data to the buffer using the handle is an alternative to using stream objects.
Public method | IsValid | Tests whether the buffer is valid for rendering.
Public method | Map | Maps a portion of the index buffer into memory, so that indices can be written into it. see IndexStream.
Public method | Unmap | Unmaps the buffer so that it can be used for rendering.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

IndexBuffer Class
Autodesk.Revit.DB.DirectContext3D Namespace

IndexBuffer Constructor

[image]