Revit 2021.1 API
AnalysisDisplayDeformedShapeSettings Members
AnalysisDisplayDeformedShapeSettings Class Constructors Methods Properties See Also Send Feedback

The AnalysisDisplayDeformedShapeSettings type exposes the following members.

Constructors

 | Name | Description
Public method | AnalysisDisplayDeformedShapeSettings()()()() | Constructs a default instance of deformed shape settings.
Public method | AnalysisDisplayDeformedShapeSettings(AnalysisDisplayDeformedShapeSettings) | Constructs a new copy of the input AnalysisDisplayDeformedShapeSettings object.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the AnalysisDisplayDeformedShapeSettings
Public method | IsEqual | Compares two deformed shape settings objects.

Properties

 | Name | Description
Public property | GridColor | Color of grid lines.
Public property | GridLineWeight | Line weight of grid lines.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Rounding | Increment to which numeric values of analysis results are rounded in deformed shape.
Public property | ShowContourLines | If true, show contour lines in the analysis display.
Public property | ShowGridLines | If true, show grid lines in the analysis display.
Public property | TextLabelType | Type of deformed shape text visualization.
Public property | TextTypeId | Element id of text associated with the settings.
Public property | Transparency | Transparency percentage of deformed shape color fill on surfaces

See Also

AnalysisDisplayDeformedShapeSettings Class
Autodesk.Revit.DB.Analysis Namespace

AnalysisDisplayDeformedShapeSettings Constructor

[image] [image]