Revit 2021.1 API
WorksetId Members
WorksetId Class Constructors Methods Operators Properties See Also Send Feedback

The WorksetId type exposes the following members.

Constructors

 | Name | Description
Public method | WorksetId | Create an WorksetId handle with the given integer id.

Methods

 | Name | Description
Public method | Compare | Compares two WorksetIds.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | GetHashCode | Gets the integer value of the id as hash code (Overrides Object..::..GetHashCode()()()().)
Public method | ToString | Gets a String representation of the integer value of the id. (Overrides Object..::..ToString()()()().)

Operators

Name | Description
Equality | Determines whether these two WorksetIds are the same.
GreaterThan | Determines whether one WorksetId is greater than another WorksetId.
GreaterThanOrEqual | Determines whether one WorksetId is not less than another WorksetId.
Inequality | Determines whether these two WorksetIds are different.
LessThan | Determines whether this WorksetId is less than another WorksetId.
LessThanOrEqual | Determines whether one WorksetId is not greater than another WorksetId.

Properties

 | Name | Description
Public property | IntegerValue | Provides the value of the WorksetId as an integer.
 | InvalidWorksetId | Get the invalid WorksetId whose IntegerValue is -1.

See Also

WorksetId Class

WorksetId Constructor

[image]