Revit 2021.1 API
NonContinuousRailStructure Members
NonContinuousRailStructure Class Methods Properties See Also Send Feedback

The NonContinuousRailStructure type exposes the following members.

Methods

 | Name | Description
Public method | AddNonContinuousRail | Creates and appends a new Non-Continuous Rail to the Rail Structure. The new Non-Continuous Rail will have the given name, height and offset. It will have default profile and material ElementIds.
Public method | Dispose | Releases all resources used by the NonContinuousRailStructure
Public method | GetNonContinuousRail | Gets the Non-Continuous Rail object of specified index from the Rail Structure.
Public method | GetNonContinuousRailCount | Gets number of Non-Continuous Rails.
Public method | IsValidNonContinuousRailProfile | Checks whether the input id represents a profile which can be used as the profile of this non-continuous rail.
Public method | RemoveNonContinuousRail | Removes Non-Continuous Rail from the Rail Structure.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

NonContinuousRailStructure Class
Autodesk.Revit.DB.Architecture Namespace

NonContinuousRailStructure Methods

[image] [image]