Revit 2021.1 API
Categories Methods
Categories Class See Also Send Feedback

The Categories type exposes the following members.

Methods

 | Name | Description
Public method | Contains | Identifies if a category which has the specified name is in the list of top-level categories. (Overrides CategoryNameMap..::..Contains(String).)
Public method | ForwardIterator | Retrieves a forward moving iterator to the map. (Overrides CategoryNameMap..::..ForwardIterator()()()().)
Public method | GetEnumerator | Retrieves a forward moving iterator to the map. (Overrides CategoryNameMap..::..GetEnumerator()()()().)
Public method | Insert | Inserts the specified category with the specified name into the map. (Overrides CategoryNameMap..::..Insert(String, Category).)
Public method | NewSubcategory | Add a new subcategory into the Autodesk Revit document.
Public method | ReverseIterator | Retrieves a backward moving iterator to the map. (Overrides CategoryNameMap..::..ReverseIterator()()()().)

See Also

Categories Class

Contains Method

[image]