Revit 2021.1 API
DesignToFabricationConverter Methods
DesignToFabricationConverter Class See Also Send Feedback

The DesignToFabricationConverter type exposes the following members.

Methods

 | Name | Description
Public method | Convert | Converts the set of MEP design elements into fabrication parts.
Public method | Dispose |
Public method | GetConvertedFabricationParts | Gets the set of element identifiers for newly created fabrication parts.
Public method | GetConvertedFabricationPartsWithInvalidConnections | Gets the collection of converted fabrication parts with invalid connections.
Public method | GetDesignElementAndFabricationPartsWithDifferentOffsets | Gets the collection of design elements that failed to convert and the associated set of fabrication parts with different offsets.
Public method | GetDesignElementAndFabricationPartsWithOpenConnectors | Gets the collection of design elements that failed to convert and the associated set of fabrication parts with open connectors.
Public method | GetElementsWithOpenConnector | Gets the set of fabrication part or MEP design element identifiers with open connectors, caused by fittings failing to convert.
Public method | GetPartialConvertFailureResults | Gets the partial failure results.

See Also

DesignToFabricationConverter Class
Autodesk.Revit.DB.Fabrication Namespace

Convert Method

[image]