Revit 2021.1 API
BrowserOrganization Members
BrowserOrganization Class Methods Properties See Also Send Feedback

The BrowserOrganization type exposes the following members.

Methods

 | Name | Description
Public method | AreFiltersSatisfied | Determines if the given element satisfies the filters defined by the browser organization.
 | GetCurrentBrowserOrganizationForSchedules | Gets the BrowserOrganization that applies to the Schedules section of the project browser.
 | GetCurrentBrowserOrganizationForSheets | Gets the BrowserOrganization that applies to the Sheets section of the project browser.
 | GetCurrentBrowserOrganizationForViews | Gets the BrowserOrganization that applies to the Views section of the project browser.
Public method | GetFolderItems | Returns a collection of leaf FolderItemInfo objects each containing the given element Id.

Properties

 | Name | Description
Public property | SortingOrder | The sorting order if sorting of items is applicable in the browser.
Public property | SortingParameterId | The Id of the parameter used to determine the sorting order of items in the browser.

See Also

BrowserOrganization Class

BrowserOrganization Methods

[image] [image]