Revit 2021.1 API
UV..::..Addition Operator
UV Class See Also Send Feedback
Adds the two specified 2-D vectors and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)

Syntax

C#
public static UV operator +(
    UV left,
    UV right
)
Visual Basic
Public Shared Operator + ( _
    left As UV, _
    right As UV _
) As UV
Visual C++
public:
static UV^ operator +(
    UV^ left,
    UV^ right
)

Parameters

left
Type: Autodesk.Revit.DB..::..UV
The first vector.
right
Type: Autodesk.Revit.DB..::..UV
The second vector.

Return Value

The 2-D vector equal to the sum of the two source vectors.

Remarks

The added vector is obtained by adding each coordinate of the right vector to the corresponding coordinate of the left vector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when left or right is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

UV Class

Multiply Operator

[image] [image]