Revit 2021.1 API
UnitUtils..::..Convert Method (Double, ForgeTypeId, ForgeTypeId)
UnitUtils Class See Also Send Feedback
Converts a value from one unit to another, such as square feet to square meters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014

Syntax

C#
public static double Convert(
    double value,
    ForgeTypeId currentUnitTypeId,
    ForgeTypeId desiredUnitTypeId
)
Visual Basic
Public Shared Function Convert ( _
    value As Double, _
    currentUnitTypeId As ForgeTypeId, _
    desiredUnitTypeId As ForgeTypeId _
) As Double
Visual C++
public:
static double Convert(
    double value,
    ForgeTypeId^ currentUnitTypeId,
    ForgeTypeId^ desiredUnitTypeId
)

Parameters

value
Type: System..::..Double
The value to convert.
currentUnitTypeId
Type: Autodesk.Revit.DB..::..ForgeTypeId
Identifier of the current unit.
desiredUnitTypeId
Type: Autodesk.Revit.DB..::..ForgeTypeId
Identifier of the desired unit.

Return Value

The converted value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given value for value is not finite -or- currentUnitTypeId is not a unit identifier. See UnitUtils.IsUnit(ForgeTypeId) and UnitUtils.GetUnitTypeId(DisplayUnitType). -or- desiredUnitTypeId is not a unit identifier. See UnitUtils.IsUnit(ForgeTypeId) and UnitUtils.GetUnitTypeId(DisplayUnitType).
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | currentUnitTypeId and desiredUnitTypeId have different dimensions.

See Also

UnitUtils Class
Convert Overload

ConvertFromInternalUnits Method

[image] [image]