Revit 2021.1 API
StairsLanding Members
StairsLanding Class Methods Properties See Also Send Feedback

The StairsLanding type exposes the following members.

Methods

 | Name | Description
 | CanCreateAutomaticLanding | Checks whether automatic landing(s) can be created between the given two stairs runs and logically join(s) with the stairs runs.
 | CreateAutomaticLanding | Creates automatic landing(s) between two stairs runs.
 | CreateSketchedLanding | Creates a customized landing between two runs by providing the closed boundary curves of the landing.
 | CreateSketchedLandingWithSlopeData | Creates a customized landing between two runs by providing the closed boundary curves of the landing, specifying slope type and height.
Public method | GetAllSupports | Returns all the supports hosting the stairs landing.
Public method | GetConnections | Returns information about the connections in which the stairs landing participates.
Public method | GetFootprintBoundary | Returns the landing's boundary curves which are projected on the stairs base level.
Public method | GetStairs | Returns the stairs to which the landing belongs.
Public method | GetStairsPath | Returns the stairs path curves on the landing. The curves are projected on the stairs base level.
Public method | SetSketchedLandingBoundaryAndPath | Sets the boundary and path curves of the sketched landing.

Properties

 | Name | Description
Public property | BaseElevation | The base elevation of the landing.
Public property | IsAutomaticLanding | True if the landing is an automatic landing, False otherwise.
Public property | Thickness | The thickness of the landing.

See Also

StairsLanding Class
Autodesk.Revit.DB.Architecture Namespace

StairsLanding Methods

[image] [image]