Revit 2021.1 API
Field Properties
Field Class See Also Send Feedback

The Field type exposes the following members.

Properties

 | Name | Description
Public property | ContainerType | Reports whether this is a simple field containing one value, or a container of multiple values.
Public property | Documentation | The overall description of the Field.
Public property | FieldName | The name of the field.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | KeyType | The type of the keys stored in the field.
Public property | Schema | The Schema to which this Field belongs.
Public property | SubSchema | The Schema describing the subentity (or subentities) stored in this Field.
Public property | SubSchemaGUID | The GUID of the Schema describing the subentity (or subentities) stored in this Field.
Public property | UnitType | Obsolete. The type of units represented by values stored in this field
Public property | ValueType | The type of the values stored in the field.

See Also

Field Class
Autodesk.Revit.DB.ExtensibleStorage Namespace

ContainerType Property

[image]