Revit 2021.1 API
BuiltInFailures..::..ConnectorFailures Properties
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback

The BuiltInFailures..::..ConnectorFailures type exposes the following members.

Properties

Name | Description
AirTerminalCenterNotAligned | The center of the Air Terminal doesn't align at (0,0,0): align the Air Terminal Center to the Origin Defining Reference Planes could help to solve the problem.
AllElementsRemovedFromCircuitGroup | [System] is empty and will be deleted.
DisconnectedElements | Elements are disconnected!
ElementAssignedToDefaultSystem | At least one connector on the highlighted element is currently assigned to the [Element Name]. In general items shouldn't be assigned to the Default Systems, but should be assigned as equipments or elements of a non-default system. Click the More Info button below for additional information on System Creation.
ElementHasMultipleConnectors | Revit found one or more elements with multiple connectors. Select each element and then select the connectors to use for the analytical connection.
ElementsAreDisconnected | Elements need to be disconnected.
ElementsConnectedToParent | You have selected elements that are connected to a parent object in a System. These elements cannot be removed from the System.
ElementsNeedToBeDisconnected | Elements need to be disconnected.
ExistsForSelectedElement | Connections already exists for selected element.
FittingMustBeOnDuct | The [Tap] must be attached to duct.
FittingMustBeOnDuctWarn | The [Tap] must be attached to duct.
FittingMustBeOnPipe | The [Tap] must be attached to pipe.
FittingMustBeOnPipeWarn | The [Tap] must be attached to pipe.
InvalidConnectionRef | The selected fitting has invalid connections and must be deleted to continue.
InvalidConnector | The connector is invalid, the size cannot be determined from the connector.
InvalidLoadClassificationValue | The load classification parameter cannot be empty. Please select a valid load classification element for the connector parameter and the associated family parameter.
InvalidPowerFactorValue | The value for Power Factor must be between 0 and 1.
JointGenderMismatch | The element has a connector with a fitting joint gender mismatch
JointShapeMismatch | The element has a connector with a fitting joint shape mismatch
JointSizeMismatch | The element has a connector with a fitting joint size mismatch
JointTypeMismatch | The element has a connector with a fitting joint type mismatch
LayoutConnector | [Unassigned System Type] on Connector [Index Number].
MismatchNoAvailableConnector | Cannot add [Element] to System. There is no available connector matching the System Type ([Type Name]) for the System.
MultipleNetwork | Elements in [System Name] are not connected in a single physical network due to one or both of the following:\n- There are disconnects in the system's physical network.\n- Elements in the system are connected to more than one physical network.
NetworkValidityError | The family is connected in a network and can no longer keep the connectivity. Disconnect the family from the network?
NetworkValidityErrorWasDisconnected | The family is connected in a network and can no longer keep the connectivity. Disconnect the family from the network?
NoLossDefined | No Loss Defined
NoSupportKCoefficientTable | "K Coefficient from table" is not supported on connector for the element
NotAllowedToModifyGroupElementsError | Connection to a group failed. Modification of elements within a group is not allowed.
NotAllowedToModifyGroupElementsWarning | Connection to a group failed. Modification of elements within a group is not allowed.
OpenConnector | The element has an open connector
RbsNetworkValidityError | The family is connected in a network and can no longer keep the connectivity.
RemoveConnectorLinksWarn | The links between connector [Index] and connector [Index], connector [Index] and connector [Index] are removed.
RemoveConnectorLinkWarn | The link between connector [Index] and connector [Index] is removed.
ShapesNotMatch | Shapes do not match. A connection could not be made.
SizingCalculationFlowOnlyWarn | Some elements are not sized because the system calculation is flow only. You may change the system calculation level to size them again.
SizingCalculationNoneWarn | Some elements are not sized because the system calculation level is none or performance. You may change the system calculation level to size them again.
SizingFailed | Sizing failed.
UnconnectedCircuit | The element has an unconnected circuit on its connector
UnconnectedDevice | Device has an unconnected [Type Name] connector (index = [Index Number]).
UndefinedConnector | Revit does not support Undefined connectors. The following have been replaced by the default connector: [Connector Element]

See Also

BuiltInFailures..::..ConnectorFailures Class

AirTerminalCenterNotAligned Property

[image]