Revit 2021.1 API
IFCExtrusionCreationData Methods
IFCExtrusionCreationData Class See Also Send Feedback

The IFCExtrusionCreationData type exposes the following members.

Methods

 | Name | Description
Public method | AddOpening | Adds an opening to the data.
Public method | ClearOpenings | Removes all cached openings from the data.
Public method | Dispose |
Public method | GetLocalPlacement | Gets the reference to the IfcLocalPlacement handle used when creating the extrusion.
Public method | GetOpenings | Gets a collection of all of the openings stored in this data.
Public method | SetLocalPlacement | Sets the data to reference an IfcLocalPlacement handle when creating the extrusion. Side effect: will set ReuseLocalPlacement to true.

See Also

IFCExtrusionCreationData Class
Autodesk.Revit.DB.IFC Namespace

AddOpening Method

[image]