Revit 2021.1 API
IndependentTag Methods
IndependentTag Class See Also Send Feedback

The IndependentTag type exposes the following members.

Methods

 | Name | Description
Public method | CanLeaderEndConditionBeAssigned | Checks whether the LeaderEndCondition can be changed.
 | Create(Document, ElementId, ElementId, Reference, Boolean, TagOrientation, XYZ) | Places a tag on an element or subelement.
 | Create(Document, ElementId, Reference, Boolean, TagMode, TagOrientation, XYZ) | Places a tag on an element or subelement.
Public method | GetTaggedLocalElement | Get the tagged local element, if any. If the tag is tagged on a subelement of local element, it returns the element.
Public method | GetTaggedReference | Get the host reference of the tag.
Public method | IsTaggedOnSubelement | Returns true if the tag is tagged on a subelement.

See Also

IndependentTag Class

CanLeaderEndConditionBeAssigned Method

[image]