Revit 2021.1 API
IFCFileWriteOptions Members
IFCFileWriteOptions Class Constructors Methods Properties See Also Send Feedback

The IFCFileWriteOptions type exposes the following members.

Constructors

 | Name | Description
Public method | IFCFileWriteOptions | Creates a default IFCFileWriteOptions. The default file format is ifc.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the IFCFileWriteOptions

Properties

 | Name | Description
Public property | FileFormat | The file format of the IFC file.
Public property | FileName | The full file name of the IFC file to be written.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | XMLConfigFileName | The XML configuration file name. It is used only for writing IFC-XML format file.

See Also

IFCFileWriteOptions Class
Autodesk.Revit.DB.IFC Namespace

IFCFileWriteOptions Constructor

[image]