Revit 2021.1 API
IFCExtrusionData Methods
IFCExtrusionData Class See Also Send Feedback

The IFCExtrusionData type exposes the following members.

Methods

 | Name | Description
Public method | AddLoop | Adds a curve loop to the extrusion data.
Public method | ClearLoops | Clears the curve loops stored in the extrusion data.
Public method | Dispose |
Public method | GetLoops | Gets the curve loops that form the base shape of the extrusion.
Public method | IsValid | Determines if the extrusion data represents a valid extrusion.
Public method | RemoveLoopAt | Removes the loop at the specified index.

See Also

IFCExtrusionData Class
Autodesk.Revit.DB.IFC Namespace

AddLoop Method

[image]