Revit 2021.1 API
ViewShapeBuilder Constructor
ViewShapeBuilder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ViewShapeBuilder()()()() | Default constructor for an ViewShapeBuilder object.
Public method | ViewShapeBuilder(DirectShapeTargetViewType) | A constructor for an ViewShapeBuilder object that takes a view type. It will infer the view normal from view type. View normal and view type are used to validate the geometry to be stored as a view-specific shape representation of a DirectShape object.

See Also

ViewShapeBuilder Class
ViewShapeBuilder Members

ViewShapeBuilder Constructor

[image]