Revit 2021.1 API
IDirectContext3DServer Methods
IDirectContext3DServer Interface See Also Send Feedback

The IDirectContext3DServer type exposes the following members.

Methods

 | Name | Description
Public method | CanExecute | Can be used to allow the server to execute only in certain views.
Public method | GetApplicationId | Reports this server's application ID.
Public method | GetBoundingBox | Reports a bounding box of the geometry that this server submits for drawing.
Public method | GetSourceId | Reports this server's source ID.
Public method | RenderScene | Performs rendering of the scene that the server creates.
Public method | UseInTransparentPass | Indicates whether this server will submit geometry during the rendering pass for transparent geometry.
Public method | UsesHandles | Tests whether this server uses DirectContext3D handle elements.

See Also

IDirectContext3DServer Interface
Autodesk.Revit.DB.DirectContext3D Namespace

CanExecute Method

[image]