Revit 2021.1 API
FieldDomainPointsByUV Members
FieldDomainPointsByUV Class Constructors Methods Properties See Also Send Feedback

The FieldDomainPointsByUV type exposes the following members.

Constructors

 | Name | Description
Public method | FieldDomainPointsByUV(IList<(Of <<'(UV>)>>)) | Creates object from an array of two-dimensional point coordinates
Public method | FieldDomainPointsByUV(IList<(Of <<'(UV>)>>), ICollection<(Of <<'(Double>)>>), ICollection<(Of <<'(Double>)>>)) | Creates object from an array of two-dimensional point coordinates

Methods

 | Name | Description
Public method | SetGridCoordinates | Set u and v coordinates that specify a grid on the surface. The display of the grid is controlled by AnalysisDisplayColoredSurfaceSettings::getShowGridLines(). If AnalysisDisplayColoredSurfaceSettings::getShowGridLines() returns true and both sets are empty then a grid will be displayed using a default spacing; if only one of the sets is non-empty, then only the corresponding set of grid lines will be displayed, i.e. the grid will consist solely of parallel lines at the specified coordinates.

Properties

 | Name | Description

See Also

FieldDomainPointsByUV Class
Autodesk.Revit.DB.Analysis Namespace

FieldDomainPointsByUV Constructor

[image] [image]