Revit 2021.1 API
StructuralAsset Properties
StructuralAsset Class See Also Send Feedback

The StructuralAsset type exposes the following members.

Properties

 | Name | Description
Public property | Behavior | Flag indicating whether elements of this material behave isotropically or orthotropically.
Public property | ConcreteBendingReinforcement | The bending reinforcement of the asset.
Public property | ConcreteCompression | The compression strength of concrete-based assets.
Public property | ConcreteShearReinforcement | The shear reinforcement of the asset.
Public property | ConcreteShearStrengthReduction | The shear strength reduction of the asset.
Public property | Density | The density of the asset.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Lightweight | Flag indicating whether the asset describes a material that is light-weight or not.
Public property | MetalReductionFactor | The reduction factor of the asset.
Public property | MetalResistanceCalculationStrength | The resistance calculation strength of the asset.
Public property | MetalThermallyTreated | Flag indicating whether the asset describes a material that is thermally treated or not.
Public property | MinimumTensileStrength | The minimum tensile strength of the asset.
Public property | MinimumYieldStress | The minimum yield stress of the asset.
Public property | Name | The name of the structural asset.
Public property | PoissonRatio | The Poisson ratio of the asset.
Public property | ShearModulus | The shear modulus of the asset.
Public property | StructuralAssetClass | The type of material that this structural asset describes (e.g. wood, concrete, metal.)
Public property | SubClass | The sub-class of the asset.
Public property | ThermalExpansionCoefficient | The thermal expansion coefficient of the asset.
Public property | WoodBendingStrength | The bending strength of the asset.
Public property | WoodGrade | The grade of wood used in a wood-based asset.
Public property | WoodParallelCompressionStrength | The parallel compression strength of the asset.
Public property | WoodParallelShearStrength | The parallel shear strength of the asset.
Public property | WoodPerpendicularCompressionStrength | The perpendicular compression strength of the asset.
Public property | WoodPerpendicularShearStrength | The perpendicular shear strength of the asset.
Public property | WoodSpecies | The species of wood used in a wood-based asset.
Public property | YoungModulus | The Young's modulus of the asset.

See Also

StructuralAsset Class

Behavior Property

[image]