Revit 2021.1 API
IFCExtrusionCreationData Members
IFCExtrusionCreationData Class Constructors Methods Properties See Also Send Feedback

The IFCExtrusionCreationData type exposes the following members.

Constructors

 | Name | Description
Public method | IFCExtrusionCreationData | The default constructor.

Methods

 | Name | Description
Public method | AddOpening | Adds an opening to the data.
Public method | ClearOpenings | Removes all cached openings from the data.
Public method | Dispose | Releases all resources used by the IFCExtrusionCreationData
Public method | GetLocalPlacement | Gets the reference to the IfcLocalPlacement handle used when creating the extrusion.
Public method | GetOpenings | Gets a collection of all of the openings stored in this data.
Public method | SetLocalPlacement | Sets the data to reference an IfcLocalPlacement handle when creating the extrusion. Side effect: will set ReuseLocalPlacement to true.

Properties

 | Name | Description
Public property | AllowVerticalOffsetOfBReps | Allows vertical shifting of breps when moving towards the origin.
Public property | AreInnerRegionsOpenings | True if inner regions of the extrusion should become openings, false otherwise.
Public property | CustomAxis | The custom extrusion axis to try when generating an extrusion.
Public property | ExtrusionDirection | The extrusion direction to generate an extrusion.
Public property | ForceOffset | True to create new local placement with identity transform.
Public property | HasCustomAxis | Identifies if the data contains a custom extrusion axis.
Public property | HasExtrusionDirection | Identifies if the data contains a extrusion direction.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | PossibleExtrusionAxes | The axes to try when generating the properties of the extrusion.
Public property | ReuseLocalPlacement | Allows re-use of local placement when creating a new local placement due to shifting of breps when moving towards the origin.
Public property | ScaledArea | The area of the extrusion, scaled to the units of export.
Public property | ScaledHeight | The height of the extrusion, scaled to the units of export.
Public property | ScaledInnerPerimeter | The inner perimeter of the extrusion, scaled to the units of export.
Public property | ScaledLength | The length of the extrusion, scaled to the units of export.
Public property | ScaledOuterPerimeter | The outer perimeter of the extrusion, scaled to the units of export.
Public property | ScaledWidth | The width of the extrusion, scaled to the units of export.
Public property | Slope | The slope of the extrusion, in degrees.

See Also

IFCExtrusionCreationData Class
Autodesk.Revit.DB.IFC Namespace

IFCExtrusionCreationData Constructor

[image]