Revit 2021.1 API
IFCFile..::..CreateStyle Method
IFCFile Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateStyle(ExporterIFC, IFCAnyHandle) | Creates and populates an IfcStyledItem for an IfcRepresentationItem with a IfcSurfaceStyle, IfcCurveStyle, and/or an IfcFillStyle, and assigns them to the file.
Public method | CreateStyle(ExporterIFC, IFCAnyHandle, Color, ElementId) | Creates and populates an IfcStyledItem for an IfcRepresentationItem with a IfcSurfaceStyle, IfcCurveStyle, and/or an IfcFillStyle, and assigns them to the file.

See Also

IFCFile Class
IFCFile Members
Autodesk.Revit.DB.IFC Namespace

CreateStyle Method (ExporterIFC, IFCAnyHandle)

[image]