Revit 2021.1 API
IFCImportOptions Methods
IFCImportOptions Class See Also Send Feedback

The IFCImportOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | GetConversionData | Get the data used in the creation of the associated Revit file for an IFC link operation, if it exists.
Public method | GetExtraOptions | Get the list of extra options to be passed into the importer. Each entry in the map is a pair of option name and value.
Public method | SetExtraOptions | Set the list of extra options to be passed into the importer. Each entry in the map is a pair of option name and value. Note that any value here will overwrite the other values in the IFCImportOptions, if it has the same name.

See Also

IFCImportOptions Class
Autodesk.Revit.DB.IFC Namespace

GetConversionData Method

[image]