Revit 2021.1 API
PointCloudType Members
PointCloudType Class Methods Properties See Also Send Feedback

The PointCloudType type exposes the following members.

Methods

 | Name | Description
 | Create | Creates a new point cloud type for a given point cloud engine.
Public method | GetPath | Gets the path of the link source from which the points are loaded.

Properties

 | Name | Description
Public property | ColorEncoding | The color encoding used by points extracted from instances of this point cloud.
Public property | EngineIdentifier | The identifier of the engine responsible for handling of the point cloud.
Public property | FoundStatus | Shows whether the Point Cloud external file could be found.
Public property | Offset | Returns the offset stored in the point cloud.
Public property | Scale | The multiplier applied to the points in all instances of this point cloud.

See Also

PointCloudType Class

Create Method

[image]