Revit 2021.1 API
Units Members
Units Class Constructors Methods Properties See Also Send Feedback

The Units type exposes the following members.

Constructors

 | Name | Description
Public method | Units | Creates a new Units object with default settings for Metric or Imperial units.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the Units
Public method | GetFormatOptions(ForgeTypeId) | Gets the default FormatOptions for a spec.
Public method | GetFormatOptions(UnitType) | Obsolete. Gets the default FormatOptions for a unit type.
 | GetModifiableSpecs | Gets all specs for which the default FormatOptions can be modified.
 | GetModifiableUnitTypes | Obsolete. Gets all unit types for which the default FormatOptions can be modified.
 | IsModifiableSpec | Checks whether the default FormatOptions can be modified for a given spec.
 | IsModifiableUnitType | Obsolete. Checks whether the default FormatOptions can be modified for a given unit type.
Public method | SetFormatOptions(ForgeTypeId, FormatOptions) | Sets the default FormatOptions for a spec.
Public method | SetFormatOptions(UnitType, FormatOptions) | Obsolete. Sets the default FormatOptions for a unit type.

Properties

 | Name | Description
Public property | DecimalSymbol | The symbol used to separate the integer and fractional parts of a number.
Public property | DigitGroupingAmount | The number of digits in each group when numbers are formatted with digit grouping.
Public property | DigitGroupingSymbol | The symbol used to separate groups of digits when numbers are formatted with digit grouping.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

Units Class

Units Constructor

[image]