Revit 2021.1 API
SpotLightDistribution Members
SpotLightDistribution Class Constructors Methods Properties See Also Send Feedback

The SpotLightDistribution type exposes the following members.

Constructors

Name Description
Public method SpotLightDistribution()()()()
Creates a spot light distribution object with the following values;
  • PI/6 radians spot beam angle
  • PI/2 radians spot field angle
  • PI/6 radians tilt angle
Public method SpotLightDistribution(SpotLightDistribution)
Creates a copy of the given spotlight distribution
Public method SpotLightDistribution(Double, Double, Double)
Creates a spot light distribution object with the given values.

Methods

 | Name | Description

Properties

 | Name | Description
Public property | SpotBeamAngle | The spot beam angle.
Public property | SpotFieldAngle | The spot field angle.
Public property | TiltAngle | The tilt angle.

See Also

SpotLightDistribution Class
Autodesk.Revit.DB.Lighting Namespace

SpotLightDistribution Constructor

[image] [image]