Revit 2021.1 API
RoofComponents Methods
RoofComponents Class See Also Send Feedback

The RoofComponents type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | GetAreasOfCurveLoops | The areas of CurveLoops of roof slabs.
Public method | GetCurveLoops | The CurveLoops of roof slabs.
Public method | GetLoopFaces | The faces of the loops of roof slabs.
Public method | GetPlaneDirections | The plane directions of roof slabs.
Public method | GetPlaneOrigins | The plane origins of roof slabs.

See Also

RoofComponents Class
Autodesk.Revit.DB.IFC Namespace

Dispose Method

[image]