Revit 2021.1 API
RectangleLightShape Members
RectangleLightShape Class Constructors Methods Properties See Also Send Feedback

The RectangleLightShape type exposes the following members.

Constructors

 | Name | Description
Public method | RectangleLightShape()()()() | Creates a rectangle light shape object with 4.0' emit length and a 2.0' emit width.
Public method | RectangleLightShape(RectangleLightShape) | Creates a copy of the given rectangle light shape
Public method | RectangleLightShape(Double, Double) | Creates a rectangle light shape object with the given emit length and width.

Methods

 | Name | Description

Properties

 | Name | Description
Public property | EmitLength | The emit length.
Public property | EmitWidth | The emit width.

See Also

RectangleLightShape Class
Autodesk.Revit.DB.Lighting Namespace

RectangleLightShape Constructor

[image] [image]