Revit 2021.1 API
ImageType Methods
ImageType Class See Also Send Feedback

The ImageType type exposes the following members.

Methods

 | Name | Description
Public method | CanReload | Check whether the ImageType can be reloaded from file.
 | Create(Document, ImageTypeOptions) | Creates a new ImageType element and loads the image into it.
 | Create(Document, String) | Obsolete. Creates a new ImageType element and loads the image into it.
Public method | GetImage | Get the bitmap image stored in the image symbol.
Public method | IsLoadedFromFile | Obsolete. Checks whether the ImageType was loaded from a file. Revit may generate some ImageTypes internally, such as the ImageTypes created by "Save to Project as Image".
Public method | Reload | Reloads the ImageType from the file found at the location specified by the Path property, using the same PageNumber and resolution.
Public method | ReloadFrom(String) | Obsolete. Reloads the ImageType from a new image file.
Public method | ReloadFrom(ImageTypeOptions) | Reloads the image in the ImageType from a new image file, and for a new PageNumber.
Public method | Unload | Unload the linked image.

See Also

ImageType Class

CanReload Method

[image]