Revit 2021.1 API
BuiltInFailures..::..WallJoinRoofFailures Properties
BuiltInFailures..::..WallJoinRoofFailures Class See Also Send Feedback

The BuiltInFailures..::..WallJoinRoofFailures type exposes the following members.

Properties

Name | Description
NoFromRoofForWall | Highlighted wall is set to be "From roof", however there is no roof below it that can be used.
NotCoveredAtAllByTarget | Highlighted walls are attached to, but miss, the highlighted targets.
NoUptoRoofForWall | Highlighted wall is set to be "Up to roof", however there is no roof above it that can be used.
WallMeetsRoofTangentially | The highlighted wall cannot be joined to the highlighted roof because the wall meets the roof tangentially.
WallNotCoveredByRoof | The highlighted wall(s) cannot be joined to the highlighted roof because the roof does not entirely cover the wall(s).

See Also

BuiltInFailures..::..WallJoinRoofFailures Class

NoFromRoofForWall Property

[image]