Revit 2021.1 API
Material Methods
Material Class See Also Send Feedback

The Material type exposes the following members.

Methods

 | Name | Description
Public method | ClearMaterialAspect | Removes an aspect from the material.
 | Create | Creates a new material.
Public method | Duplicate | Duplicates the material
 | IsMaterialOrValidDefault | Validates whether the specified element id is a material element.
 | IsNameUnique | Validates whether the material name is unique in document.
Public method | SetMaterialAspectByPropertySet | Sets an aspect of the material to a shared property set.

See Also

Material Class

Create Method

[image]