Revit 2021.1 API
IFCImportOptions Properties
IFCImportOptions Class See Also Send Feedback

The IFCImportOptions type exposes the following members.

Properties

 | Name | Description
Public property | Action | The action of the import.
Public property | AutocorrectOffAxisLines | Enable or disable correcting lines that are slight off-axis.
Public property | AutoJoin | Enable or disable auto-join at the end of import.
Public property | CreateLinkInstanceOnly | Determines whether to create a linked symbol element or not.
Public property | ForceImport | Force the IFC file to be imported regardless of an existing corresponding Revit file.
Public property | Intent | The intent of the import.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | RevitLinkFileName | The full path of the intermediate Revit file created during a previous link action. This is used during "Reload From" to determine the path to the previous generated Revit file.

See Also

IFCImportOptions Class
Autodesk.Revit.DB.IFC Namespace

Action Property

[image]