Revit 2021.1 API
IFCExtrusionCalculatorUtils..::..CalculateExtrusionData Method (IFCExtrusionCalculatorOptions, IList<(Of <(<'Face>)>)>)
IFCExtrusionCalculatorUtils Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 21.0.0.0 (21.1.1.109)

Syntax

C#
public static IList<IFCExtrusionData> CalculateExtrusionData(
    IFCExtrusionCalculatorOptions extrInfo,
    IList<Face> allInputFaces
)
Visual Basic
Public Shared Function CalculateExtrusionData ( _
    extrInfo As IFCExtrusionCalculatorOptions, _
    allInputFaces As IList(Of Face) _
) As IList(Of IFCExtrusionData)
Visual C++
public:
static IList<IFCExtrusionData^>^ CalculateExtrusionData(
    IFCExtrusionCalculatorOptions^ extrInfo,
    IList<Face^>^ allInputFaces
)

Parameters

extrInfo
Type: Autodesk.Revit.DB.IFC..::..IFCExtrusionCalculatorOptions
allInputFaces
Type: System.Collections.Generic..::..IList<(Of <(<' Face >)>)>

See Also

IFCExtrusionCalculatorUtils Class
CalculateExtrusionData Overload
Autodesk.Revit.DB.IFC Namespace

IFCExtrusionCreationData Class

[image]