Revit 2021.1 API
DirectShapeType Members
DirectShapeType Class Methods Properties See Also Send Feedback

The DirectShapeType type exposes the following members.

Methods

 | Name | Description
Public method | AppendShape(IList<(Of <<'(GeometryObject>)>>)) | Appends the collection of GeometryObjects into the model shape representation stored in this DirectShape.
Public method | AppendShape(ShapeBuilder) | Append shape built by the supplied ShapeBuilderObject to shape representation stored in this DirectShapeType. The data stored in the supplied ShapeBuilder object will be cleared.
Public method | AppendShape(IList<(Of <<'(GeometryObject>)>>), DirectShapeTargetViewType) | Appends the collection of GeometryObjects into the model or view specific shape representation stored in this DirectShapeType. Passing DirectShapeTargetViewType.Default as view type will cause the model shape to be updated.
Public method | AreOptionsValid | Validates that the given DirectShapeTypeOptions are allowed for this particular DirectShapeType.
Public method | CanCreateParts | Indicates if it is possible to create parts from this DirectShapeType element.
 | Create(Document, String, ElementId) | Creates a DirectShapeType element.
 | Create(Document, String, ElementId, DirectShapeTypeOptions) | Creates a DirectShapeType element.
Public method | GetOptions | Gets a copy of the current options for this DirectShapeType.
Public method | IsValidShape(IList<(Of <<'(GeometryObject>)>>)) | Validates shape to be stored in a DirectShapeType.
Public method | IsValidShape(IList<(Of <<'(GeometryObject>)>>), DirectShapeTargetViewType) | Validates view-specific shape to be stored in a DirectShapeType. Expects a non-default view type.
Public method | SetOptions | Sets the options to use for this DirectShapeType.
Public method | SetShape(IList<(Of <<'(GeometryObject>)>>)) | Builds the type shape from the supplied collection of GeometryObjects. The objects are copied. If the new shape is identical to the old one, the old shape will be kept.
Public method | SetShape(ShapeBuilder) | Sets the shape of this object to the one accumulated in the supplied Builder object. If the new shape is identical to the old one, the old shape will be kept.

Properties

 | Name | Description

See Also

DirectShapeType Class

DirectShapeType Methods

[image] [image]