Revit 2021.1 API
View Members
View Class Methods Properties See Also Send Feedback

The View type exposes the following members.

Methods

 | Name | Description
Public method | AddFilter | Adds a filter to the view.
Public method | AllowsAnalysisDisplay | Identifies if this view allows display of Analysis results.
Public method | ApplyViewTemplateParameters | Applies to this view the parameters of the input view that are not controlled by the current view template.
Public method | AreGraphicsOverridesAllowed | Determines if Visibility/Graphics Overriddes can be applied to the view.
Public method | CanCategoryBeHidden | Checks whether the category can be hidden in the view.
Public method | CanCategoryBeHiddenTemporary | Check if category can be temporarily hidden in the view.
Public method | CanEnableTemporaryViewPropertiesMode | Indicates if Temporary View Properties mode can be applied for view in current state.
Public method | CanModifyDetailLevel | Check if Detail Level can be modified.
Public method | CanModifyDisplayStyle | Indicates if DisplayStyle can be modified.
Public method | CanModifyViewDiscipline | Indicates if the View Discipline can be modified
Public method | CanUseDepthCueing | Indicates if view can use Depth Cueing
Public method | CanUseTemporaryVisibilityModes | Indicates if view can use temporary visibility modes
Public method | CanViewBeDuplicated | Identifies if this view can be duplicated.
Public method | ConvertTemporaryHideIsolateToPermanent | Convert all temporary hidden elements or categories to permanently hidden in view.
Public method | ConvertToIndependent | Convert the dependent view to independent.
Public method | CreateViewTemplate | Creates a new view template instance from this view instance.
Public method | DisableTemporaryViewMode | Disables the specified temporary view mode.
Public method | Duplicate | Duplicates this view.
Public method | EnableRevealHiddenMode | Enables Reveal Hidden elements mode.
Public method | EnableTemporaryViewPropertiesMode | Turns Temporary View Properties mode on or off. In this mode, any changes made to the view are temporary and will be discarded once the mode is disabled.
Public method | GetBackground | Returns the current background set for the view.
Public method | GetCategoryHidden | Checks if elements of the given category are set to be invisible (hidden) in this view.
Public method | GetCategoryOverrides | Gets graphic overrides for a category in view.
Public method | GetCropRegionShapeManager | Returns an object for managing view crop region shape.
 | GetCropRegionShapeManagerForReferenceCallout | Returns an object for managing view crop region shape for reference callout.
Public method | GetDependentViewIds | Get the ids of dependent views.
Public method | GetDepthCueing | Returns the current depth cueing settings for the view.
Public method | GetDirectContext3DHandleOverrides | Returns DirectContext3D handle overrides object for the view.
Public method | GetElementOverrides | Gets graphic overrides for an element in the view.
Public method | GetFilterOverrides | Gets graphic overrides that a filter applies to the view.
Public method | GetFilters | Gets the filters applied to the view.
Public method | GetFilterVisibility | Gets the visibility of the elements associated with a filter.
Public method | GetIsFilterEnabled | Identifies if the filter is enabled in this view.
Public method | GetNonControlledTemplateParameterIds | Returns a list of parameters that are not marked as included when this view is used as a template.
Public method | GetOrderedFilters | Gets the filters applied to the view in the order they are applied.
Public method | GetPointCloudOverrides | Returns point cloud overrides object for the view.
Public method | GetPrimaryViewId | Get the id of the primary view.
Public method | GetReferenceCallouts | Returns element ids of all reference callouts in the view.
Public method | GetReferenceElevations | Returns element ids of all reference elevations in the view.
Public method | GetReferenceSections | Returns element ids of all reference sections in the view.
Public method | GetSketchyLines | Returns the current sketchy lines settings for the view.
Public method | GetTemplateParameterIds | Returns a list of parameter ids that may be controlled when this view is assigned as a template.
Public method | GetTemporaryViewPropertiesId | When Temporary View Properties mode is in progress it provides view id that overrode settings for current view. Outside Temporary View Properties mode InvalidElementId will be returned.
Public method | GetTemporaryViewPropertiesName | When Temporary View Properties mode is in progress, name of applied template is returned. Outside Temporary View Properties mode, empty string will be returned.
Public method | GetViewDisplayModel | Returns the current view display model settings for the view.
Public method | GetWorksetVisibility | Returns the visibility settings of a workset for this particular view.
Public method | GetWorksharingDisplayMode | Gets the current worksharing display mode for this view.
Public method | HasDetailLevel | Check if the view has a Detail Level property
Public method | HasDisplayStyle | Indicates if view has a DisplayStyle property
Public method | HasViewDiscipline | Indicates if the view has a Discipline property
Public method | HideActiveWorkPlane | Hide the active work plane of the view.
Public method | HideCategoriesTemporary | Set multiple categories to be temporarily hidden in the view.
Public method | HideCategoryTemporary | Set one category to be temporarily hidden in the view.
Public method | HideElements | Sets the elements to be hidden in the view.
Public method | HideElementsTemporary | Set multiple elements to be temporarily hidden in the view. To hide a group completely, you must also include all members of all groups and nested groups in your input.
Public method | HideElementTemporary | Set one element to be temporarily hidden in the view. To hide a group completely, you must also include all members of all groups and nested groups in your input, therefore you should use the version of this method that accepts multiple element ids as input.
Public method | IsCategoryOverridable | Checks whether the category can have graphic overrides in this view.
Public method | IsElementVisibleInTemporaryViewMode | Identifies if the input element is visible for the temporary view mode for this view.
Public method | IsFilterApplied | Indicates if a filter is applied to the view.
Public method | IsInTemporaryViewMode | Returns true if the view is in a particular temporary view mode.
Public method | IsolateCategoriesTemporary | Set categories to be temporarily isolated in the view.
Public method | IsolateCategoryTemporary | Set one category to be temporarily isolated in the view.
Public method | IsolateElementsTemporary | Set multiple elements to be temporarily isolated in the view. To isolate a group completely, you must also include all members of all groups and nested groups in your input.
Public method | IsolateElementTemporary | Set one element to be temporarily isolated in the view. To isolate a group completely, you must also include all members of all groups and nested groups in your input, therefore you should use the version of this method that accepts multiple element ids as input.
Public method | IsTemporaryHideIsolateActive | Indicates if the view is temporarily hiding or isolating elements or categories.
Public method | IsTemporaryViewPropertiesModeEnabled | Returns true when Temporary View Properties mode is in progress, false otherwise.
 | IsValidViewScale | This validator checks that the view scale is in the allowable range.
Public method | IsValidViewTemplate | Verifies that the view represented by templateId can be set as the controlling view template for this view.
Public method | IsViewValidForTemplateCreation | Verifies that the view is valid for template creation.
Public method | IsWorksetVisible | Indicates whether the workset is visible in this view.
Public method | Print()()()() | Print this view with the default view template and using the print setting of the current active document.
Public method | Print(Boolean) | Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document.
Public method | Print(View) | Print this view with the given view template and using the print setting of the current active document.
Public method | Print(View, Boolean) | Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document.
Public method | RemoveFilter | Removes a filter from the view.
Public method | SetBackground | Sets the background for the view. Background can only be set for 3d views and for Sections/Elevations.
Public method | SetCategoryHidden | Sets if elements of the given category will be visible in this view.
Public method | SetCategoryOverrides | Sets graphic overrides for a category in view.
Public method | SetDepthCueing | Sets the depth cueing settings for the view.
Public method | SetElementOverrides | Sets graphic overrides for an element in the view.
Public method | SetFilterOverrides | Sets the overrides associated with a filter.
Public method | SetFilterVisibility | Sets the visibility of the elements associated with a filter.
Public method | SetIsFilterEnabled | Sets the filter enabled flag.
Public method | SetNonControlledTemplateParameterIds | Sets the parameters that will not be included when this view is used as a template.
Public method | SetSketchyLines | Sets the sketchy lines settings for the view.
Public method | SetViewDisplayModel | Sets the view display model settings for the view.
Public method | SetWorksetVisibility | Sets visibility for a workset in this view.
Public method | SetWorksharingDisplayMode | Sets the worksharing display mode for this view.
Public method | ShowActiveWorkPlane | Show the active work plane of the view.
Public method | SupportsRevealConstraints | Checks that the view can have the Reveal Constraints mode activated.
Public method | SupportsWorksharingDisplayMode | Checks whether this view supports the given worksharing display mode.
Public method | UnhideElements | Sets the elements to be shown in the given view if they are currently hidden.

Properties

 | Name | Description
Public property | AnalysisDisplayStyleId | Element id of Analysis Display Style associated with the view.
Public property | AreAnalyticalModelCategoriesHidden | Indicates if analytical model categories are currently hidden in the view.
Public property | AreAnnotationCategoriesHidden | Indicates if annotation categories are currently hidden in the view.
Public property | AreCoordinationModelHandlesHidden | Indicates if Coordination Model handles are currently hidden in the view.
Public property | AreImportCategoriesHidden | Indicates if import categories are currently hidden in the view.
Public property | AreModelCategoriesHidden | Indicates if model categories are currently hidden in the view.
Public property | ArePointCloudsHidden | Indicates if point clouds are currently hidden in the view.
Public property | AssociatedAssemblyInstanceId | The Id of the assembly instance that owns the assembly view.
Public property | CanBePrinted | Test whether the view can be printed.
Public property | CropBox | The Crop Box applied to the view, or an outline encompassing the crop region applied to the view.
Public property | CropBoxActive | Whether or not the Crop Box/Region is active for the view.
Public property | CropBoxVisible | Whether or not the Crop Box/Region is visible for the view.
Public property | DetailLevel | The detail level of this view.
Public property | Discipline | The Discipline of the view.
Public property | DisplayStyle | The DisplayStyle of the view. Returns DisplayStyle.Wireframe if the view has no display style.
Public property | GenLevel | The level for the view.
Public property | IsAssemblyView | Indicates if the view is assembly view.
Public property | IsTemplate | Test whether the view is a view template.
Public property | Origin | Returns the origin of the screen.
Public property | Outline | The bounds of the view in paper space (in feet).
Public property | PartsVisibility | The visibility setting for parts in this view.
Public property | RevealConstraintsMode | Indicates whether the Reveal Constraints mode is activated in the view.
Public property | RightDirection | The direction towards the right side of the screen.
Public property | Scale | The scale of the view.
Public property | ShadowIntensity | The intesity of cast shadows - 0 = no shadows, 100 = black.
Public property | SketchPlane | The sketch plane assigned to the view for model curve creation.
Public property | SunAndShadowSettings | The sun and shadow settings assigned to the view for shadow calculation and rendering.
Public property | SunlightIntensity | The intensity of the simulated (directional) sunlight. 0 = no directional light; maximum value is 100.
Public property | TemporaryViewModes | Data of temporary view modes associated with this view.
Public property | Title | The view title. This consists of the view name plus other modifiers, such as the view type, sheet number, area scheme, and/or assembly type, depending on the specifics of the view.
Public property | UpDirection | The direction towards the top of the screen.
Public property | ViewDirection | The direction towards the viewer.
Public property | ViewTemplateId | The id of the template view that controls this view's parameters.
Public property | ViewType | The type of the view.

See Also

View Class

View Methods

[image] [image]