Revit 2021.1 API
EnergyAnalysisSpace Methods
EnergyAnalysisSpace Class See Also Send Feedback

The EnergyAnalysisSpace type exposes the following members.

Methods

 | Name | Description
Public method | GetAnalyticalSurfaces | Provides a way to access the collection of analytical surfaces for a space. Geometry data defining an analytical space volume. Through an analytical surface you can connect a source element with each polygon in a space. The analytical surfaces defines an enclosed volume bounded by the center plane of walls and the top plane of roofs and floors.
Public method | GetBoundary | Gets the collection of polygons that form the 2D boundary. This method returns a collection of polyloops (planar polygons) that defines an enclosed area measured by interior bounding surfaces.
Public method | GetClosedShell | Gets the collection of polygons that form a closed shell. This method returns a collection of polyloops (planar polygons) that defines an enclosed volume measured by interior bounding surfaces.

See Also

EnergyAnalysisSpace Class
Autodesk.Revit.DB.Analysis Namespace

GetAnalyticalSurfaces Method

[image]