Revit 2021.1 API
TemperatureRatingType Properties
TemperatureRatingType Class See Also Send Feedback

The TemperatureRatingType type exposes the following members.

Properties

 | Name | Description
Public property | CorrectionFactors | Get all correction factors defined in this temperature rating type and its corresponding material type.
Public property | InsulationTypes | Get all insulation types defined in this temperature rating type and its corresponding material type.
Public property | IsInUse | Indicate whether the temperature rating type is in use.
Public property | MaterialType | Get the material type information which this temperature rating type belongs to.
Public property | Name | Get name of temperature rating type. (Overrides ElementType..::..Name.)
Public property | WireSizes | Get all electrical wire sizes defined in this temperature rating type and its corresponding material type.

See Also

TemperatureRatingType Class
Autodesk.Revit.DB.Electrical Namespace

CorrectionFactors Property

[image]