Revit 2021.1 API
ContinuousRail Members
ContinuousRail Class Methods Properties See Also Send Feedback

The ContinuousRail type exposes the following members.

Methods

 | Name | Description
Public method | GetEndExtensionPath | Retrieves the start extension path.
Public method | GetPath | Retrieves the rail path.
Public method | GetStartExtensionPath | Retrieves the start extension path.
Public method | GetSupports | Returns all the railing supports attached to the rail.

Properties

 | Name | Description
Public property | HostRailingId | The id of the host Railing that contains this rail.
Public property | Length | The length of the rail.

See Also

ContinuousRail Class
Autodesk.Revit.DB.Architecture Namespace

ContinuousRail Methods

[image] [image]