Revit 2021.1 API
SchemaBuilder Methods
SchemaBuilder Class See Also Send Feedback

The SchemaBuilder type exposes the following members.

Methods

 | Name | Description
Public method | AcceptableName | Checks whether a string is an acceptable name for a Schema or a Field.
Public method | AddArrayField | Creates a field containing an array of values in the Schema, with given name and type of contained values.
Public method | AddMapField | Creates a field containing an ordered key-value map in the Schema, with given name and type of contained values.
Public method | AddSimpleField | Creates a field containing a single value in the Schema, with given name and type.
Public method | Dispose |
Public method | Finish | Registers and returns the created Schema object.
 | GUIDIsValid | Checks whether the supplied GUID value is valid.
Public method | Ready | Checks whether the builder may be used.
Public method | SetApplicationGUID | Sets the GUID of the application or add-in that may access entities of this Schema under the Application acess level.
Public method | SetDocumentation | Sets the documentation string for the Schema.
Public method | SetReadAccessLevel | Sets top level read access (for entities)
Public method | SetSchemaName | Sets the name of the Schema.
Public method | SetVendorId | Sets the ID of the third-party vendor that may access entities of this Schema under the Vendor acess level, and to generally identify the owner of this Schema.
Public method | SetWriteAccessLevel | Sets top level write access (for entities)
 | VendorIdIsValid | Checks whether the given vendor ID string is valid. A valid vendor ID string: 1. Has a length of at least 4 characters and no more than 253 characters, and 2. Contains only letters, digits, or any of the following special characters: ! " # & \ ( ) + , . - : ; < = > ? _ ` | ~

See Also

SchemaBuilder Class
Autodesk.Revit.DB.ExtensibleStorage Namespace

AcceptableName Method

[image]