Revit 2021.1 API
IFCFile Methods
IFCFile Class See Also Send Feedback

The IFCFile type exposes the following members.

Methods

 | Name | Description
Public method | Close | Close the IFC file.
 | Create | Creates an IFC file for exporting.
Public method | CreateHeaderInstance | Creates an IFC header instance in the file model.
Public method | CreateInstance | Creates an IFC instance in the file model.
Public method | CreateStyle(ExporterIFC, IFCAnyHandle) | Creates and populates an IfcStyledItem for an IfcRepresentationItem with a IfcSurfaceStyle, IfcCurveStyle, and/or an IfcFillStyle, and assigns them to the file.
Public method | CreateStyle(ExporterIFC, IFCAnyHandle, Color, ElementId) | Creates and populates an IfcStyledItem for an IfcRepresentationItem with a IfcSurfaceStyle, IfcCurveStyle, and/or an IfcFillStyle, and assigns them to the file.
Public method | Dispose |
Public method | GetInstanceCount | Counts IFC instances of one particular type.
Public method | GetInstances | Gets IFC instances of one particular type.
Public method | Read(IFCFileReadOptions) | Reads content from a file of IFC format.
Public method | Read(IFCFileReadOptions, Int32%, Int32%) | Reads content from a file of IFC format.
Public method | Write | Writes content to a file of IFC format.

See Also

IFCFile Class
Autodesk.Revit.DB.IFC Namespace

Close Method

[image]