Revit 2021.1 API
SpatialElementBoundaryOptions Members
SpatialElementBoundaryOptions Class Constructors Methods Properties See Also Send Feedback

The SpatialElementBoundaryOptions type exposes the following members.

Constructors

 | Name | Description
Public method | SpatialElementBoundaryOptions | Constructs default options for calculation of the geometry of spatial elements (rooms, spaces).

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the SpatialElementBoundaryOptions

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | SpatialElementBoundaryLocation | The boundary of spatial element for geometry calculation.
Public property | StoreFreeBoundaryFaces | Indicates whether to include the free boundary faces in the result.

See Also

SpatialElementBoundaryOptions Class

SpatialElementBoundaryOptions Constructor

[image]