Revit 2021.1 API
StairsRun Properties
StairsRun Class See Also Send Feedback

The StairsRun type exposes the following members.

Properties

 | Name | Description
Public property | ActualRisersNumber | The actual number of stairs risers in the stairs run.
Public property | ActualRunWidth | Specifies the value of the tread width excluding the width of independent side supports.
Public property | ActualTreadsNumber | The actual number of stairs treads in the stairs run.
Public property | BaseElevation | The base elevation of the stairs run.
Public property | BeginsWithRiser | True if the stairs run begins with a riser, false otherwise.
Public property | EndsWithRiser | True if the stairs run ends with a riser, false otherwise.
Public property | ExtensionBelowRiserBase | Specifies a value to extend/trim the run's first step against base elevation of the stairs if the stairs begins with a riser.
Public property | ExtensionBelowTreadBase | Specifies a value to extend/trim the run's first step against base elevation of the stairs if the stairs begins with a tread.
Public property | Height | The calculated height of the stairs run.
Public property | LocationLineJustification | The position of the run relative to the Up-direction path used to create the run.
Public property | StairsRunStyle | The style of the stairs run such as straight, winder, etc.
Public property | TopElevation | The top elevation of the stairs run.

See Also

StairsRun Class
Autodesk.Revit.DB.Architecture Namespace

ActualRisersNumber Property

[image]