Revit 2021.1 API
AlignmentStationLabelOptions Members
AlignmentStationLabelOptions Class Constructors Methods Properties See Also Send Feedback

The AlignmentStationLabelOptions type exposes the following members.

Constructors

 | Name | Description
Public method | AlignmentStationLabelOptions | Creates an object with default values.

Methods

 | Name | Description

Properties

 | Name | Description
Public property | HasLeader | Specifies if the label will have a leader. The default value is true.
Public property | LeaderEnd | Specifies the leader end point, in model coordinates. The default value is null. When null, the end point will be the same as the Origin point, driven by the Station value.
Public property | LeaderShoulder | Specifies the leader shoulder point, in model coordinates. The default value is null. When null, the shoulder point will be the same as the Origin point, driven by the Station value.
Public property | Station | Specifies the station at which the label will be placed. The station determines the location of the label's origin: Origin by setting it to the closest point on the alignment geometry which corresponds to this station.
Public property | TypeId | Specifies the ElementId of the label type. The default value is InvalidElementId. In this case, the default type id for alignment station labels in the document is used.

See Also

AlignmentStationLabelOptions Class
Autodesk.Revit.DB.Infrastructure Namespace

AlignmentStationLabelOptions Methods

[image] [image]