Revit 2021.1 API
MEPSystem Members
MEPSystem Class Methods Properties See Also Send Feedback

The MEPSystem type exposes the following members.

Methods

 | Name | Description
Public method | Add | Add elements into the system and connect them with the system using given connectors.
Public method | DivideSystem | Divide the phyisical networks in the system and create a new system for each network.
Public method | GetCriticalPathSectionNumbers | Obtains a list of the critical path section numbers.
Public method | GetPhysicalNetworksNumber | Get the physical networks number in the system.
Public method | GetSectionByIndex | Get the section from the index.
Public method | GetSectionByNumber | Get the Section from section number
Public method | IsSystemDividable | Checks if the system is dividable. The system is dividable if there is more than one physical network in the system. Currently, only HVAC and piping systems support dividing.
Public method | Remove(ConnectorSet) | Removes connectors from system.
Public method | Remove(ICollection<(Of <<'(ElementId>)>>)) | Remove elements from system.

Properties

 | Name | Description
Public property | BaseEquipment | The base panel or equipment of the system.
Public property | BaseEquipmentConnector | The connector within base equipment which is used to connect with system.
Public property | ConnectorManager | Connector manager of the system.
Public property | Elements | Terminal elements in the system.
Public property | HasDesignParts | Indicates if the system has one or more design parts.
Public property | HasFabricationParts | Indicates if the system has one or more fabrication parts.
Public property | HasPlaceholders | Indicates if the system has one or more placeholders.
Public property | IsEmpty | Indicates if the system is empty or not.
Public property | IsMultipleNetwork | Indicates if the system is well connected or not. The flag will enable the "Divide System" button.
Public property | IsValid | Indicates if the system is valid or not. atom AtomValidateSystem default false
Public property | PressureLossOfCriticalPath | The total pressure loss of the sections in critical path.
Public property | SectionsCount | The number of sections.

See Also

MEPSystem Class

MEPSystem Methods

[image] [image]