Revit 2021.1 API
WorksetTable Members
WorksetTable Class Methods Properties See Also Send Feedback

The WorksetTable type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the WorksetTable
Public method | GetActiveWorksetId | Returns the active workset's WorksetId.
Public method | GetWorkset(Guid) | Returns the workset from a input Guid.
Public method | GetWorkset(WorksetId) | Returns the workset from a input WorksetId.
 | IsWorksetNameUnique | Checks if the given workset name is unique in the document.
 | RenameWorkset | Renames the workset.
Public method | SetActiveWorksetId | Sets the active workset.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

WorksetTable Class

WorksetTable Methods

[image] [image]