Revit 2021.1 API
SolidOrShellTessellationControls Members
SolidOrShellTessellationControls Class Constructors Methods Properties See Also Send Feedback

The SolidOrShellTessellationControls type exposes the following members.

Constructors

 | Name | Description
Public method | SolidOrShellTessellationControls | Default constructor.

Methods

 | Name | Description
Public method | DisableLevelOfDetail | Disables the use of levelOfDetail. The use of levelOfDetail is enabled by calling setLevelOfDetail (with a valid input).
Public method | Dispose | Releases all resources used by the SolidOrShellTessellationControls
Public method | UseLevelOfDetail | Returns true if the use of levelOfDetail is enabled, false if not. The use of levelOfDetail is enabled by calling setLevelOfDetail (with a valid input).

Properties

 | Name | Description
Public property | Accuracy | A positive real number specifying how accurately a triangulation should approximate a solid or shell.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LevelOfDetail | An number between 0 and 1 (inclusive) specifying the level of detail for the triangulation of a solid or shell.
Public property | MinAngleInTriangle | A non-negative real number specifying the minimum allowed angle for any triangle in the triangulation, in radians.
Public property | MinExternalAngleBetweenTriangles | A positive real number specifying the minimum allowed value for the external angle between two adjacent triangles, in radians.

See Also

SolidOrShellTessellationControls Class

SolidOrShellTessellationControls Constructor

[image]