Revit 2021.1 API
CableTraySizes Methods
CableTraySizes Class See Also Send Feedback

The CableTraySizes type exposes the following members.

Methods

 | Name | Description
Public method | AddSize | Inserts a new MEPSize into the cable tray sizes. For cable tray, the nominal diameter of MEPSize is used .
Public method | ClearAll | Removes all MEPSizes in the cable tray sizes.
Public method | Contains | Checks whether a cable tray size with the nominal diameter exists.
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
 | GetCableTraySizes | Gets the cable tray sizes of the project.
Public method | GetCableTraySizesIterator | Returns a CableTraySizeIterator to the MEP cable tray sizes.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetSizeCount | Gets the size count of the cable tray size table.
Public method | RemoveSize | Erases the existing MEPSize. For cable tray, the nominal diameter is used in MEPSize.

See Also

CableTraySizes Class
Autodesk.Revit.DB.Electrical Namespace

AddSize Method

[image]