Revit 2021.1 API
DeleteElements..::..Create Method (Document, ISet<(Of <(<'ElementId>)>)>)
DeleteElements Class See Also Send Feedback
Creates an instance of the DeleteElements resolution.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011

Syntax

C#
public static FailureResolution Create(
    Document document,
    ISet<ElementId> ids
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    ids As ISet(Of ElementId) _
) As FailureResolution
Visual C++
public:
static FailureResolution^ Create(
    Document^ document,
    ISet<ElementId^>^ ids
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document which owns the elements to delete.
ids
Type: System.Collections.Generic..::..ISet<(Of <(<' ElementId >)>)>
The ids of the elements that will be deleted when this resolution is chosen.

Return Value

The instance of the DeleteElements resolution.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input ids is empty or contains an invalid element id.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

DeleteElements Class
Create Overload

DeleteElements Properties

[image] [image]