Revit 2021.1 API
BuiltInFailures..::..EnergyAnalysisFailures Properties
BuiltInFailures..::..EnergyAnalysisFailures Class See Also Send Feedback

The BuiltInFailures..::..EnergyAnalysisFailures type exposes the following members.

Properties

Name | Description
ComputeRoomVolumeNotCheckedWarn | The setting for calculation of Volume Computations is not on. The analysis model produced will be approximate without the computation of Areas and Volumes
ModelWithNoConditionedSpacesWarn | The model has no conditioned spaces.
ModelWithNoOccupiedSpacesWarn | The model has no occupiable spaces.
NoRoofsRoomBoundingWarn | The energy analysis model does not contain any roof surfaces! If there are roofs in your model, please verify that they are room bounding, and make sure that the room offsets are high enough to include the roofs.
NoRoofsSpacesBoundingWarn | The energy analysis model does not contain any roof surfaces! If there are roofs in your model, please verify that they are space bounding, and make sure that the space offsets are high enough to include the roofs.
NoRoomBoundingElements | Can't create any energy analysis surfaces. There are no Room bounding elements defined in the current phase. Please check the Project Information settings.
NoRoomBoundingElementsWarn | Can't create any energy analysis surfaces. There are no Room bounding elements defined in the current phase. Please check the Project Information settings.
NoRoomsWarn | Revit was unable to identify any rooms. If you are sure that rooms have been created in the project, please check the Project Phase setting to verify that the Project Phase matches the phase in which rooms have been defined in your project.
NoSpaceBoundingElements | Can't create any energy analysis surfaces. There are no Space bounding elements defined in the current phase. Please check the Project Information settings.
NoSpaceBoundingElementsWarn | Can't create any energy analysis surfaces. There are no Space bounding elements defined in the current phase. Please check the Project Information settings.
NoSpaces | Revit was unable to identify any spaces. If you are sure that spaces have been created in the project, please check the Project Phase setting to verify that the Project Phase matches the phase in which spaces have been defined in your project.
NoSpacesWarn | Revit was unable to identify any spaces. If you are sure that spaces have been created in the project, please check the Project Phase setting to verify that the Project Phase matches the phase in which spaces have been defined in your project.
PlenumWithNoCeilingWarn | [Room] has Space Type set to Plenum but has no ceiling surface. A plenum must be separated from the space it serves by a ceiling.
ProblemWithLightingLoadWarn | [Room]'s lighting load is too high. This may be caused by an incorrect density value and must be corrected before this space can be included in the load calculations.
ProblemWithPeopleLoadWarn | [Room]'s number of people or people load (sensible or latent) is too high. This may be caused by an incorrect density value and must be corrected before this space can be included in the load calculations.
ProblemWithPowerLoadWarn | [Room]'s power load is too high. This may be caused by an incorrect density value and must be corrected before this space can be included in the load calculations.
RoomGeometryCannotFindFreeFacesBoundingElement | An error occurred while trying to find the free part of a face of the bounding geometry for [Room] when processing the room-bounding element [Name]. The free part of the face is found by subtracting the portions of the face that overlap various room-bounding element faces.
RoomGeometryCannotOverlapBoundingElement | An error occurred while trying to find the region where a face of the bounding geometry for [Room] overlaps a face of a room-bounding element [Name].
RoomGeometryCannotTrimBoundingElement | An error occurred while trimming the vertical shadow of a room-bounding element [Name] of the bounding geometry for [Room].
RoomNotPlacedWarn | [Family] is not placed. Physical properties such as area will display as "Not Placed" in schedules. You can place the [Family] using the option bar in the [Family] tool, or you can delete the [Family] in a schedule. [Room] will be ignored in the energy analysis model.
RoomNotUpperBoundedByElement | [Family] is not upper bounded by a roof, ceiling or floor element. This can result in incorrect adjacencies and voids in the analytical model. Please ensure that Upper Limit and Limit Offset for [Room] is set correctly.
RoomVolumeNegativeWarn | [Room] has a negative volume? [Room] will be ignored in the energy analysis model.
RoomVolumeNotComputedWarn | [Family] volume can't be computed. The bounding geometry (in 3D) can't be found for [Room]. [Room] will be ignored in the energy analysis model.
SpaceResolutionOutOfRange | Voxel size is out of range.
SurfaceResolutionOutOfRange | Pixel size is out of range.
UndefinedRooms | There are undefined Rooms in the model! Recommend creating a Room schedule and checking the Area parameter of each Room for warnings.
UndefinedSpaces | There are undefined Spaces in the model! Recommend creating a Space schedule and checking the Area parameter of each Space for warnings.
ZoneWithoutSpacesWarn | This zone has no spaces.

See Also

BuiltInFailures..::..EnergyAnalysisFailures Class

ComputeRoomVolumeNotCheckedWarn Property

[image]