Revit 2021.1 API
MassLevelData Members
MassLevelData Class Methods Properties See Also Send Feedback

The MassLevelData type exposes the following members.

Methods

 | Name | Description
Public method | IsEmpty | Indicates if the MassLevelData (Mass Floor) has a geometrical representation. May not if the level does not intersect the mass geometry.
 | IsMassFamilyInstance | Checks if the ElementId is a mass family instance.
Public method | IsValidConceptualConstructionTypeElement | Checks if the ElementId is an acceptable conceptual construction type ElementId for the MassLevelData (Mass Floor).

Properties

 | Name | Description
Public property | ConceptualConstructionId | The ElementId of the conceptual construction associated with the MassLevelData (Mass Floor).
Public property | ConceptualConstructionIsByEnergyData | Indicates if the ConceptualConstructionType of the MassLevelData (Mass Floor) is synchronized with the EnergyDataSettings or if it overrides those settings.
Public property | MaterialId | The ElementId of the visualization material used for the MassLevelData (Mass Floor)
Public property | MaterialType | Indicates if the material used for the graphical appearance is by category or a specific material, or if the material to be used should be taken from the ConceptualConstructionType of the MassLevelData.
Public property | NExteriorSurfaceArea | The exterior surface area of the volume of the mass between the level of this MassLevelData (Mass Floor) to the next in the mass.
Public property | NLevelFafArea | The surface area of the intersection of the MassLevelData's level with the mass geometry.
Public property | NLevelPerimeter | The perimeter of the intersection of the MassLevelData's level with the mass geometry.
Public property | NVolume | The volume of from the level of this MassLevelData (Mass Floor) to the next in the mass.
Public property | OwningMassId | The ElementId of the mass that the MassLevelData (Mass Floor) is associated with.
Public property | StrUsage | A String which describes the usage or occupancy type of the level of the MassLevelData.

See Also

MassLevelData Class
Autodesk.Revit.DB.Analysis Namespace

MassLevelData Methods

[image] [image]