Revit 2021.1 API
SpotLightDistribution Constructor
SpotLightDistribution Class See Also Send Feedback

Overload List

Name Description
Public method SpotLightDistribution()()()()
Creates a spot light distribution object with the following values;
  • PI/6 radians spot beam angle
  • PI/2 radians spot field angle
  • PI/6 radians tilt angle
Public method SpotLightDistribution(SpotLightDistribution)
Creates a copy of the given spotlight distribution
Public method SpotLightDistribution(Double, Double, Double)
Creates a spot light distribution object with the given values.

See Also

SpotLightDistribution Class
SpotLightDistribution Members
Autodesk.Revit.DB.Lighting Namespace

SpotLightDistribution Constructor

[image]