Revit 2021.1 API
ImporterIFC..::..ProcessIFCProject Method (IFCAnyHandle, IDictionary<(Of <(<'IFCAnyHandle, ElementId>)>)>)
ImporterIFC Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 21.0.0.0 (21.1.1.109)

Syntax

C#
public void ProcessIFCProject(
    IFCAnyHandle ifcProject,
    IDictionary<IFCAnyHandle, ElementId> createdElements
)
Visual Basic
Public Sub ProcessIFCProject ( _
    ifcProject As IFCAnyHandle, _
    createdElements As IDictionary(Of IFCAnyHandle, ElementId) _
)
Visual C++
public:
void ProcessIFCProject(
    IFCAnyHandle^ ifcProject,
    IDictionary<IFCAnyHandle^, ElementId^>^ createdElements
)

Parameters

ifcProject
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
createdElements
Type: System.Collections.Generic..::..IDictionary<(Of <(<' IFCAnyHandle, ElementId >)>)>

See Also

ImporterIFC Class
ProcessIFCProject Overload
Autodesk.Revit.DB.IFC Namespace

SetFile Method

[image]