Revit 2021.1 API
ViewSystemsAnalysisReport Members
ViewSystemsAnalysisReport Class Methods Properties See Also Send Feedback

The ViewSystemsAnalysisReport type exposes the following members.

Methods

 | Name | Description
 | Create | Creates a new view for the systems analysis report.
 | GetLatestSystemsAnalysisReport | Gets the latest report of systems analysis.
Public method | GetReportContent | Gets the report content in this view.
Public method | IsAnalysisCompleted | Indicates if the background systems analysis has completed or not.
Public method | RequestSystemsAnalysis | Requests a new systems analysis in the background.

Properties

 | Name | Description
Public property | AnalysisDateAndTime | Identifies the analysis date and time when it was requested.
Public property | SystemsAnalysisOutputFolder | The full path of the output folder for systems analysis
Public property | SystemsAnalysisWorkflowFile | The full path name of the original system analysis workflow file.
Public property | WeatherFile | The full path name of the weather file used for the systems analysis.

See Also

ViewSystemsAnalysisReport Class
Autodesk.Revit.DB.Analysis Namespace

ViewSystemsAnalysisReport Methods

[image] [image]