Revit 2021.1 API
CylindricalSurface Properties
CylindricalSurface Class See Also Send Feedback

The CylindricalSurface type exposes the following members.

Properties

 | Name | Description
Public property | Axis | Axis of the cylinder. This is the Z axis of the local coordinate system associated with this cylinder.
Public property | Origin | Center of the circle that defines the base of the cylinder. This is the origin of the local coordinate system associated with this cylinder.
Public property | Radius | Radius of the circle that defines the base of this cylinder.
Public property | XDir | X axis of the local coordinate system associated with this cylinder.
Public property | YDir | Y axis of the local coordinate system associated with this cylinder.

See Also

CylindricalSurface Class

Axis Property

[image]