Revit 2021.1 API
PathOfTravel Members
PathOfTravel Class Methods Properties See Also Send Feedback

The PathOfTravel type exposes the following members.

Methods

 | Name | Description
 | Create(View, XYZ, XYZ) | Creates a new path of travel between two points.
 | Create(View, XYZ, XYZ, PathOfTravelCalculationStatus%) | Creates a new path of travel between two points and provides creation result status.
 | CreateMapped(View, IList<(Of <<'(XYZ>)>>), IList<(Of <<'(XYZ>)>>)) | Creates multiple new paths of travel by mapping each of a set of start points to each of a set of end points.
 | CreateMapped(View, IList<(Of <<'(XYZ>)>>), IList<(Of <<'(XYZ>)>>), IList<(Of <<'(PathOfTravelCalculationStatus>)>>)%) | Creates multiple new paths of travel by mapping each of a set of start points to each of a set of end points and provides creation result statuses.
 | CreateMultiple(View, IList<(Of <<'(XYZ>)>>), IList<(Of <<'(XYZ>)>>)) | Creates multiple new paths of travel between same size sets of start and end points.
 | CreateMultiple(View, IList<(Of <<'(XYZ>)>>), IList<(Of <<'(XYZ>)>>), IList<(Of <<'(PathOfTravelCalculationStatus>)>>)%) | Creates multiple new paths of travel between same size sets of start and end points and provides creation result statuses.
 | FindEndsOfShortestPaths | For a floor plan view, calculates the paths from each start point to its closest destination and return the path end points.
 | FindShortestPaths | For a floor plan view, calculates paths from each start point to its closest destinations. Returns the path, represented by an array of XYZ points.
 | FindStartsOfLongestPathsFromRooms | For a floor plan view, calculates paths from points inside rooms to the closests of the destinations. Returns the start points of the longest path(s). If multiple paths have the same longest length, returns multiple start points.
Public method | GetCurves | Gets the array of curves representing the path of travel.
Public method | GetWaypoints | return the waypoints set for the Path of Travel
Public method | InsertWaypoint | Insert a waypoint at the specified index
 | IsInRevealObstaclesMode | Returns current state of Reveal Obstacles mode for the given view.
Public method | RemoveWaypoint | Remove a waypoint.
 | SetRevealObstaclesMode | Sets Reveal Obstacles mode for the given view.
Public method | SetWaypoint | Updates the specified waypoint.
Public method | Update | Updates the path of travel by recalculating the path between the original start and end points.
 | UpdateMultiple(Document, IList<(Of <<'(ElementId>)>>)) | Updates the specified paths of travel by recalculating each path using their original start and end points.
 | UpdateMultiple(Document, IList<(Of <<'(ElementId>)>>), IList<(Of <<'(PathOfTravelCalculationStatus>)>>)%) | Updates the specified paths of travel by recalculating each path using their original start and end points and provides creation result statuses.

Properties

 | Name | Description
Public property | LineStyle | The line style of the path.
Public property | PathEnd | The end point of the path. The Z coordinate will equal the view's level elevation. To update path calculations, call update.
Public property | PathMidpoint | The midpoint of the path. The Z coordinate will equal the view's level elevation.
Public property | PathStart | The start point of the path. The Z coordinate will equal the view's level elevation. To update path calculations, call update.

See Also

PathOfTravel Class
Autodesk.Revit.DB.Analysis Namespace

PathOfTravel Methods

[image] [image]