Revit 2021.1 API
MultiServerService..::..SetActiveServers Method (IList<(Of <(<'Guid>)>)>)
MultiServerService Class See Also Send Feedback
Changes the active servers and/or their order.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013

Syntax

C#
public void SetActiveServers(
    IList<Guid> serverIds
)
Visual Basic
Public Sub SetActiveServers ( _
    serverIds As IList(Of Guid) _
)
Visual C++
public:
void SetActiveServers(
    IList<Guid>^ serverIds
)

Parameters

serverIds
Type: System.Collections.Generic..::..IList<(Of <(<'Guid>)>)>
A set of Ids of servers that are to be set as active for this service or an empty set if no server should currently be set as active.

Remarks

More than one server can be active at any given time in a multi-server service, but it is possible that no server is active (unless the service is mandatory).

An application-wide active servers get executed when the service is invoked in the scope of the entire application (i.e. without a specific document), or if the service is executed in a document but the document does not have active servers explicitly set.

Setting active servers replaces previously active servers. Both the number of servers and their orders is significant. Servers do always get executed in the order in which they were set as active. If it is desired the order of execution is different, the same set of active servers must be set again, but in the modified, desired order.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Some of the given Ids do not represent valid servers of the service. -or- The list of servers contains duplicates. The SetActiveServers method expects a set of unique servers.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | The operation is not allowed because the service is being executed.

See Also

MultiServerService Class
SetActiveServers Overload
Autodesk.Revit.DB.ExternalService Namespace

SetActiveServers Method (IList(Guid), Document)

[image]