Revit 2021.1 API
SiteLocation Properties
SiteLocation Class See Also Send Feedback

The SiteLocation type exposes the following members.

Properties

 | Name | Description
Public property | Elevation | The elevation of the site location.
Public property | GeoCoordinateSystemDefinition | The XML string which describes the geographic coordinate system.
Public property | GeoCoordinateSystemId | The geographic coordinate system ID, such as "AMG-50" and "Beijing1954/a.GK3d-40".
Public property | Latitude | The latitude of the site location.
Public property | Longitude | The longitude of the site location.
Public property | PlaceName | The place name of the site.
Public property | TimeZone | The time-zone for the site.
Public property | WeatherStationName | The name of the weather station at the site location.

See Also

SiteLocation Class

Elevation Property

[image]