Revit 2021.1 API
Schema Members
Schema Class Methods Properties See Also Send Feedback

The Schema type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the Schema
 | EraseSchemaAndAllEntities | Obsolete. Erases all Entities corresponding to this Schema from all open documents, and erases this Schema from memory.
Public method | GetField | Gets a Field of a given name from the Schema.
Public method | ListFields | The complete list of fields in the Schema, sorted by name.
 | ListSchemas | Lists all schemas in memory.
 | Lookup | Finds the Schema corresponding to the GUID in memory.
Public method | ReadAccessGranted | Checks whether Entities of this Schema may be retrieved by the current add-in.
Public method | WriteAccessGranted | Checks whether Entities of this Schema may be stored by the current add-in.

Properties

 | Name | Description
Public property | ApplicationGUID | The GUID of the application or add-in that may access entities of this Schema under the Application access level.
Public property | Documentation | The overall description of the Schema.
Public property | GUID | The identifier of the Schema. Setter made unavailable, because it would violate set-correctness
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ReadAccessLevel | Read access level of the schema.
Public property | SchemaName | The user-friendly name of the Schema.
Public property | VendorId | The id of the third-party vendor that may access entities of this Schema under the Vendor access level.
Public property | WriteAccessLevel | Write access level of the schema.

See Also

Schema Class
Autodesk.Revit.DB.ExtensibleStorage Namespace

Schema Methods

[image] [image]