Revit 2021.1 API
FootPrintRoof Members
FootPrintRoof Class Methods Properties See Also Send Feedback

The FootPrintRoof type exposes the following members.

Methods

 | Name | Description
Public method | GetProfiles | Retrieve all the curveLoops of FootPrintRoof.

Properties

 | Name | Description
Public property | CurtainGrids | Retrieve all the CurtainGrid objects of a FootPrintRoof.
Public property | DefinesSlope | Retrieve or set the DefinesSlope of the curve.
Public property | ExtendIntoWall | Retrieve or set whether extend into wall the curve.
Public property | Offset | Retrieve or set the Offset of the curve.
Public property | Overhang | Retrieve or set the Overhang of the curve.
Public property | SlopeAngle | Retrieve or set the SlopeAngle of the curve.

See Also

FootPrintRoof Class

FootPrintRoof Methods

[image] [image]