Revit 2021.1 API
IFCLegacyStairOrRamp Members
IFCLegacyStairOrRamp Class Methods Properties See Also Send Feedback

The IFCLegacyStairOrRamp type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the IFCLegacyStairOrRamp
Public method | GetBoundaryLines | Gets boundary lines.
Public method | GetLandingGeometries | Gets the geometries of landings.
Public method | GetNumberOfRisers | Gets the number of risers.
Public method | GetNumberOfTreads | Gets the number of treads.
Public method | GetRunGeometries | Gets the geometries of runs.
Public method | GetStringerGeometries | Gets the geometries of stringers.
Public method | GetTreadsLength | Gets the length of treads.
Public method | GetWalkLines | Gets walk lines.

Properties

 | Name | Description
Public property | IsRamp | True if it is a ramp, false if it is a stair.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | RiserHeight | The height of riser.

See Also

IFCLegacyStairOrRamp Class
Autodesk.Revit.DB.IFC Namespace

IFCLegacyStairOrRamp Methods

[image] [image]