Revit 2021.1 API
GeometryInstance Members
GeometryInstance Class Methods Properties See Also Send Feedback

The GeometryInstance type exposes the following members.

Methods

 | Name | Description
Public method | GetInstanceGeometry()()()() | Computes the geometric representation of the instance.
Public method | GetInstanceGeometry(Transform) | Computes a transformation of the geometric representation of the instance.
Public method | GetSymbolGeometry()()()() | Computes the geometric representation of the symbol which generates this instance.
Public method | GetSymbolGeometry(Transform) | Computes a transformation of the geometric representation of the symbol which generates this instance.

Properties

 | Name | Description
Public property | Symbol | The symbol element that this object is referring to.
Public property | SymbolGeometry | The geometric representation of the symbol which generates this instance.
Public property | Transform | The affine transformation from the local coordinate space of the symbol into the coordinate space of the instance.

See Also

GeometryInstance Class

GeometryInstance Methods

[image] [image]