Revit 2021.1 API
FamilyItemFactory..::..NewSweep Method
FamilyItemFactory Class See Also Send Feedback
Adds a new sweep form to the family document.

Overload List

 | Name | Description
Public method | NewSweep(Boolean, ReferenceArray, SweepProfile, Int32, ProfilePlaneLocation) | Adds a new sweep form into the family document, using an array of selected references as a 3D path.
Public method | NewSweep(Boolean, CurveArray, SketchPlane, SweepProfile, Int32, ProfilePlaneLocation) | Adds a new sweep form to the family document, using a path of curve elements.

See Also

FamilyItemFactory Class
FamilyItemFactory Members
Autodesk.Revit.Creation Namespace

NewSweep Method (Boolean, ReferenceArray, SweepProfile, Int32, ProfilePlaneLocation)

[image]