Revit 2021.1 API
MacroModule Members
MacroModule Class Methods Properties See Also Send Feedback

The MacroModule type exposes the following members.

Methods

 | Name | Description
Public method | AddMacro | Adds a macro to the module.
Public method | Dispose | Releases all resources used by the MacroModule
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetMacro | Gets the macro with the give name.
Public method | GetMacroModuleIterator | Returns a Macro module iterator that iterates through the collection.
Public method | RemoveMacro | Removes a macro from the module.

Properties

 | Name | Description
Public property | Description | The module description.
Public property | Environment | The Macro environment.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | MacroLanguageType | The Macro language type.
Public property | MacroLevel | The Macro level.
Public property | MacroManager | The Macro manager.
Public property | ModuleStatus | The module status.
Public property | Name | The name of the module.

See Also

MacroModule Class
Autodesk.Revit.DB.Macros Namespace

MacroModule Methods

[image] [image]