Revit 2021.1 API
FormattedText Members
FormattedText Class Constructors Methods Properties See Also Send Feedback

The FormattedText type exposes the following members.

Constructors

 | Name | Description
Public method | FormattedText()()()() | Creates a new default FormattedText object, which contains only a carriage return character and has no formatting.
Public method | FormattedText(String) | Creates a new FormattedText object with unformatted text.

Methods

 | Name | Description
Public method | AsTextRange | Returns a TextRange object that represents the entire text.
Public method | Dispose | Releases all resources used by the FormattedText
Public method | Find | Returns a text range identifying the first occurrence of the given string within the text, starting from a given index.
Public method | GetAllCapsStatus()()()() | Returns whether All, None or a Mixed of characters in the entire text are in all caps.
Public method | GetAllCapsStatus(TextRange) | Returns whether All, None or a Mixed set of characters in a given text range are in all caps.
Public method | GetBoldStatus()()()() | Returns whether All, None or a Mixed of characters in the entire text are bold.
Public method | GetBoldStatus(TextRange) | Returns whether All, None or a Mixed set of characters in a given text range are bold.
Public method | GetIndentLevel | Returns the indent level of the paragraphs in the text range.
Public method | GetItalicStatus()()()() | Returns whether All, None or a Mixed of characters in the entire text are italic.
Public method | GetItalicStatus(TextRange) | Returns whether All, None or a Mixed set of characters in a given text range are italic.
Public method | GetListStartNumber | Returns the list start number of the paragraphs in a given text range.
Public method | GetListType | Returns the ListType of a paragraph.
Public method | GetMaximumIndentLevel | Returns the maximum allowed indent level
Public method | GetMaximumListStartNumber | Returns the maximum allowed list start number.
Public method | GetMinimumListStartNumber | Returns the minumum allowed list start number.
Public method | GetPlainText()()()() | Returns the entire text in a plain text form.
Public method | GetPlainText(TextRange) | Returns a substring of the text in a plain text form. The start and end of the substring is identified by a given TextRange.
Public method | GetSubscriptStatus()()()() | Returns whether All, None or a Mixed of characters in the entire text are subscripted.
Public method | GetSubscriptStatus(TextRange) | Returns whether All, None or a Mixed set of characters in a given text range are subscripted.
Public method | GetSuperscriptStatus()()()() | Returns whether All, None or a Mixed of characters in the entire text are superscripted.
Public method | GetSuperscriptStatus(TextRange) | Returns whether All, None or a Mixed set of characters in a given text range are superscripted.
Public method | GetUnderlineStatus()()()() | Returns whether All, None or a Mixed of characters in the entire text are underlined.
Public method | GetUnderlineStatus(TextRange) | Returns whether All, None or a Mixed set of characters in a given text range are underlined.
Public method | SetAllCapsStatus(Boolean) | Sets the characters in the entire text to be in all caps or not.
Public method | SetAllCapsStatus(TextRange, Boolean) | Sets the characters in a given text range to be in all caps or not.
Public method | SetBoldStatus(Boolean) | Sets the characters in the entire text to be bold or not bold.
Public method | SetBoldStatus(TextRange, Boolean) | Sets the characters in a given text range to be bold or not bold.
Public method | SetIndentLevel | Sets the number of tab stops that the paragraph should be indented.
Public method | SetItalicStatus(Boolean) | Sets the characters in the entire text to be italic or not italic.
Public method | SetItalicStatus(TextRange, Boolean) | Sets the characters in a given text range to be italic or not italic.
Public method | SetListStartNumber | Sets the list start number on the paragraphs in a given text range.
Public method | SetListType | Sets the ListType of a paragraph.
Public method | SetPlainText(String) | Sets the entire text with the given text in a plain text form.
Public method | SetPlainText(TextRange, String) | Sets the text with the given text in a plain text form in a range.
Public method | SetSubscriptStatus(Boolean) | Sets the characters in the entire text to be subscript or not subscript.
Public method | SetSubscriptStatus(TextRange, Boolean) | Sets the characters in a given text range to be subscript or not subscript.
Public method | SetSuperscriptStatus(Boolean) | Sets the characters in the entire text to be superscript or not superscript.
Public method | SetSuperscriptStatus(TextRange, Boolean) | Sets the characters in a given text range to be superscript or not superscript.
Public method | SetUnderlineStatus(Boolean) | Sets the characters in the entire text to be underlined or not underlined.
Public method | SetUnderlineStatus(TextRange, Boolean) | Sets the characters in a given text range to be underlined or not underlined.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

FormattedText Class

FormattedText Constructor

[image] [image]