Revit 2021.1 API
FieldValues Constructor (IList<(Of <(<'ValueAtPoint>)>)>, XYZ)
FieldValues Class See Also Send Feedback
Creates object from an array of domain point values

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012

Syntax

C#
public FieldValues(
    IList<ValueAtPoint> valueAtPoint,
    XYZ unitDirection
)
Visual Basic
Public Sub New ( _
    valueAtPoint As IList(Of ValueAtPoint), _
    unitDirection As XYZ _
)
Visual C++
public:
FieldValues(
    IList<ValueAtPoint^>^ valueAtPoint,
    XYZ^ unitDirection
)

Parameters

valueAtPoint
Type: System.Collections.Generic..::..IList<(Of <(<' ValueAtPoint >)>)>
Array of values, each corresponding to a domain point
unitDirection
Type: Autodesk.Revit.DB..::..XYZ
Unit vector that gives the same direction for values (for diagrams)

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Members of valueAtPoint contain different numbers of measurements -or- unitDirection is not a unit vector
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FieldValues Class
FieldValues Overload
Autodesk.Revit.DB.Analysis Namespace

FieldValues Methods

[image] [image]