Revit 2021.1 API
ViewPrintingEventArgs..::..Index Property
ViewPrintingEventArgs Class See Also Send Feedback
The index of the view being printed out of the set of all views being printed.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2010

Syntax

C#
public int Index { get; }
Visual Basic
Public ReadOnly Property Index As Integer
    Get
Visual C++
public:
property int Index {
    int get ();
}

Remarks

The index is zero-based. When a single view is being printed, this value should be 0.

See Also

ViewPrintingEventArgs Class
Autodesk.Revit.DB.Events Namespace

TotalViews Property

[image]