Revit 2021.1 API
SingleServerService Methods
SingleServerService Class See Also Send Feedback

The SingleServerService type exposes the following members.

Methods

 | Name | Description
Public method | GetActiveServerId()()()() | Returns the Id of the currently active application-level server of the service.
Public method | GetActiveServerId(Document) | Returns the Id of the server currently associated with the given document for the service.
Public method | SetActiveServer(Guid) | Set an active server applicable application-wide for the service.
Public method | SetActiveServer(Guid, Document) | Change the active server for a specific document.
Public method | UnsetActiveServer | Unset the active server for the particular document.

See Also

SingleServerService Class
Autodesk.Revit.DB.ExternalService Namespace

GetActiveServerId Method

[image] [image]