Revit 2021.1 API
IFCTransaction Members
IFCTransaction Class Constructors Methods Properties See Also Send Feedback

The IFCTransaction type exposes the following members.

Constructors

 | Name | Description
Public method | IFCTransaction | Instantiates a transaction object.

Methods

 | Name | Description
Public method | Commit | Commits all changes made to the IFC file during the transaction.
Public method | Dispose | Releases all resources used by the IFCTransaction
Public method | RollBack | Rolls back all changes made to the IFC file during the transaction.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

IFCTransaction Class
Autodesk.Revit.DB.IFC Namespace

IFCTransaction Constructor

[image]