Revit 2021.1 API
TextNoteOptions Members
TextNoteOptions Class Constructors Methods Properties See Also Send Feedback

The TextNoteOptions type exposes the following members.

Constructors

 | Name | Description
Public method | TextNoteOptions()()()() | Default constructor; populates the options with their respective default values.
Public method | TextNoteOptions(ElementId) | Constructs text options to create text of the given type.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the TextNoteOptions

Properties

 | Name | Description
Public property | HorizontalAlignment | Horizontal alignment of the text.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | KeepRotatedTextReadable | Flag controling whether a rotate text is to stay oriented to be always readable.
Public property | Rotation | Base line angle of a text note, in radians.
Public property | TypeId | Id of a text type that defines the style of a text note.
Public property | VerticalAlignment | Vertical alignment of the text.

See Also

TextNoteOptions Class

TextNoteOptions Constructor

[image] [image]