Revit 2021.1 API
ElectricalSystem Methods
ElectricalSystem Class See Also Send Feedback

The ElectricalSystem type exposes the following members.

Methods

 | Name | Description
Public method | AddToCircuit | Add a set of exist components to the Electrical System.
 | Create(Connector, ElectricalSystemType) | Creates a new MEP Electrical System element from an unused Connector.
 | Create(Document, IList<(Of <<'(ElementId>)>>), ElectricalSystemType) | Creates a new MEP Electrical System element from a set of electrical components.
Public method | DisconnectPanel | Disconnect the panel for the Electrical System.
Public method | GetCircuitPath | Gets the list of the electrical system circuit path node position.
Public method | IsCircuitPathValid | Checks whether the list of the electrical system circuit path node position is valid.
Public method | NewWires | Create a bunch of wires for the electrical system.
Public method | RemoveFromCircuit | remove a set of exist components from the Electrical System.
Public method | SelectPanel | Set the panel for the Electrical System.
Public method | SetCircuitPath | Sets the electrical system circuit path by the list of node position.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace

AddToCircuit Method

[image]