Revit 2021.1 API
WorksharingDisplaySettings Methods
WorksharingDisplaySettings Class See Also Send Feedback

The WorksharingDisplaySettings type exposes the following members.

Methods

 | Name | Description
Public method | CanUserHaveOverrides | Checks whether a single username can have customized graphic overrides.
Public method | GetAllUsersWithGraphicOverrides | Returns all usernames that have graphic overrides. This list consists of all users included in the user table + all users who have explicitly been assigned overrides.
Public method | GetGraphicOverrides(String) | Returns the graphic overrides assigned for elements owned by a particular user.
Public method | GetGraphicOverrides(CheckoutStatus) | Returns the graphic overrides associated with a particular ownership status.
Public method | GetGraphicOverrides(ModelUpdatesStatus) | Returns the graphic overrides assigned to a particular model update status.
Public method | GetGraphicOverrides(WorksetId) | Returns the graphic overrides assigned to elements in a particular workset.
 | GetOrCreateWorksharingDisplaySettings | Returns the worksharing display settings for the document, creating new settings for the current user if necessary.
Public method | GetRemovedUsers | Returns the set of users who have been explicitly removed from the settings.
Public method | RemoveUsers | Removes users from the list of displayed users and permanently discards any customization of the graphics. Note that a user cannot be removed if he or she owns any elements.
Public method | RestoreUsers | Adds users back to the list of displayed users and permits customization of the graphics. Any usernames that are not currently removed will be ignored. Returns the number of users who were actually restored.
Public method | SetGraphicOverrides(String, WorksharingDisplayGraphicSettings) | Sets the graphic overrides assigned to elements owned by a particular user. The username cannot be on the list of removed usernames.
Public method | SetGraphicOverrides(CheckoutStatus, WorksharingDisplayGraphicSettings) | Sets the graphic overrides assigned to elements with a particular ownership status.
Public method | SetGraphicOverrides(ModelUpdatesStatus, WorksharingDisplayGraphicSettings) | Sets the graphic overrides assigned to elements with a particular status in the central model.
Public method | SetGraphicOverrides(WorksetId, WorksharingDisplayGraphicSettings) | Sets the graphic overrides assigned to elements in a particular user workset.
Public method | UserHasGraphicOverrides | Checks whether there are graphic overrides that would apply to elements owned by the given user in the "Individual Owners" display mode.

See Also

WorksharingDisplaySettings Class

CanUserHaveOverrides Method

[image]