Revit 2021.1 API
IFCAggregate Methods
IFCAggregate Class See Also Send Feedback

The IFCAggregate type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an element to the aggregate.
Public method | AddAggregate | Creates a nested aggregate and adds it to the aggregate.
Public method | Delete | Delete the aggregate object from the IFCFile model.
Public method | Dispose |
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetIFCAggregateIterator | Returns a IFCAggregateIterator that iterates through the collection.

See Also

IFCAggregate Class
Autodesk.Revit.DB.IFC Namespace

Add Method

[image]