Revit 2021.1 API
CurtainGrid Methods
CurtainGrid Class See Also Send Feedback

The CurtainGrid type exposes the following members.

Methods

 | Name | Description
Public method | AddGridLine | Add a grid line to the curtain grid.
Public method | ChangePanelType | Change the type of a curtain panel.
Public method | GetCell | Get the specified cell located by the intersection of the grid lines.
Public method | GetCurtainCells | Gets the CurtainCells owned by this curtain grid.
Public method | GetMullionIds | Gets all ElementIds of the mullions of the curtain grid.
Public method | GetPanel | Get the specified panel located by the intersection of the grid lines.
Public method | GetPanelIds | Gets all ElementIds of the panels of the curtain grid.
Public method | GetUGridLineIds | Gets all ElementIds of grid lines in the U direction.
Public method | GetUnlockedMullionIds | Gets all ElementIds of the unlocked mullions of the curtain grid.
Public method | GetUnlockedPanelIds | Gets all ElementIds of the unlocked panels of the curtain grid.
Public method | GetVGridLineIds | Gets all ElementIds of grid lines in the V direction.

See Also

CurtainGrid Class

AddGridLine Method

[image]