Revit 2021.1 API
UnitUtils..::..ConvertToInternalUnits Method (Double, ForgeTypeId)
UnitUtils Class See Also Send Feedback
Converts a value from a given unit to Revit's internal units.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014

Syntax

C#
public static double ConvertToInternalUnits(
    double value,
    ForgeTypeId unitTypeId
)
Visual Basic
Public Shared Function ConvertToInternalUnits ( _
    value As Double, _
    unitTypeId As ForgeTypeId _
) As Double
Visual C++
public:
static double ConvertToInternalUnits(
    double value,
    ForgeTypeId^ unitTypeId
)

Parameters

value
Type: System..::..Double
The value to convert.
unitTypeId
Type: Autodesk.Revit.DB..::..ForgeTypeId
Identifier of the unit quantifying the value.

Return Value

The converted value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given value for value is not finite -or- unitTypeId is not a unit identifier. See UnitUtils.IsUnit(ForgeTypeId) and UnitUtils.GetUnitTypeId(DisplayUnitType).
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

UnitUtils Class
ConvertToInternalUnits Overload

GetAllSpecs Method

[image]