Revit 2021.1 API
LightType Members
LightType Class Methods Properties See Also Send Feedback

The LightType type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the LightType
Public method | GetInitialColor | Return a copy of an object derived from InitialColor
Public method | GetInitialIntensity | Return a copy of an object derived from InitialIntensity
Public method | GetLightDistribution | Return a copy of an object derived from LightDistribution
Public method | GetLightShape | Return a copy of an object derived from LightShape
 | GetLightType | Creates a light type object from the given document and family type ID
 | GetLightTypeFromInstance | Creates a light type object from the given document and element ID
Public method | GetLossFactor | Return a copy of an object derived from LossFactor
Public method | SetInitialColor | Replace the current initial color object with the given object
Public method | SetInitialIntensity | Replace the current initial intensity object with the given object
Public method | SetLightDistribution | Replace the current LightDistribution object with the given object
Public method | SetLightShape | Replace the current LightShape object with the given object
Public method | SetLossFactor | Replace the current loss factor object with the given object

Properties

 | Name | Description
Public property | ColorFilter | The light filter color.
Public property | DimmingColor | The dimming temperature value in Kelvins.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

LightType Class
Autodesk.Revit.DB.Lighting Namespace

Dispose Method

[image]