Revit 2021.1 API
StairsType Properties
StairsType Class See Also Send Feedback

The StairsType type exposes the following members.

Properties

 | Name | Description
Public property | ConstructionMethod | The construction method of the stairs.
Public property | EndConnectionType | The join style between a run and landing.
Public property | HasMiddleSupports | True if the stairs type has middle supports, False otherwise.
Public property | LandingType | The type for all landings in the stair element.
Public property | LeftLateralOffset | The offset for the left support from the edge of the run in a horizontal direction.
Public property | LeftSideSupportType | The type of left support used in the stair.
Public property | MaxRiserHeight | The maximum height of each riser on the stair element.
Public property | MiddleSupportsNumber | The number of middle supports used in the stair.
Public property | MiddleSupportType | The type of middle supports used in the stair.
Public property | MinRunWidth | The initial value for the width of a common run.
Public property | MinTreadDepth | The minimum tread width along the center path for all common runs (winder, arc, and straight).
Public property | NotchExtension | The horizontal length of the notch profile.
Public property | NotchHorizontalGap | The width of the horizontal gap in the stairs notch.
Public property | NotchThickness | The vertical length of the notch profile from the top.
Public property | NotchVerticalGap | The width of the vertical gap in the stairs notch.
Public property | RightLateralOffset | The offset for the right support from the edge of the run in a horizontal direction.
Public property | RightSideSupportType | The type of right support used in the stair.
Public property | RunType | The type for all runs in the stair element.

See Also

StairsType Class
Autodesk.Revit.DB.Architecture Namespace

ConstructionMethod Property

[image]