Revit 2021.1 API
LogicalAndFilter Constructor (IList<(Of <(<'ElementFilter>)>)>)
LogicalAndFilter Class See Also Send Feedback
Constructs a new instance of the logical filter with any number of input filters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011

Syntax

C#
public LogicalAndFilter(
    IList<ElementFilter> filters
)
Visual Basic
Public Sub New ( _
    filters As IList(Of ElementFilter) _
)
Visual C++
public:
LogicalAndFilter(
    IList<ElementFilter^>^ filters
)

Parameters

filters
Type: System.Collections.Generic..::..IList<(Of <(<' ElementFilter >)>)>
A collection of input filters.

Remarks

The input filters will be copied.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The filter collection is empty, or contains invalid inputs.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

LogicalAndFilter Class
LogicalAndFilter Overload

LogicalAndFilter Methods

[image] [image]