Revit 2021.1 API
LineLightShape Members
LineLightShape Class Constructors Methods Properties See Also Send Feedback

The LineLightShape type exposes the following members.

Constructors

 | Name | Description
Public method | LineLightShape()()()() | Creates a line light shape object with 2.0' emit length.
Public method | LineLightShape(Double) | Creates a line light shape object with the given emit length.
Public method | LineLightShape(LineLightShape) | Creates a copy of the given line light shape

Methods

 | Name | Description

Properties

 | Name | Description
Public property | EmitLength | The emit length.

See Also

LineLightShape Class
Autodesk.Revit.DB.Lighting Namespace

LineLightShape Constructor

[image] [image]