Revit 2021.1 API
EnergyAnalysisOpening Properties
EnergyAnalysisOpening Class See Also Send Feedback

The EnergyAnalysisOpening type exposes the following members.

Properties

 | Name | Description
Public property | CADLinkUniqueId | The unique id of the originating CAD object's link (linked document) associated with this opening.
Public property | CADObjectUniqueId | The unique id of the originating CAD object (model element) associated with this opening.
Public property | Corner | The lower-left coordinate for the analytical rectangular geometry viewed from outside.
Public property | Height | The height of the analytical rectangular geometry.
Public property | OpeningId | The unique identifier for the opening.
Public property | OpeningName | The unique name identifier for the opening.
Public property | OpeningType | The analytical opening type.
Public property | OriginatingElementDescription | The description for the originating Revit element.
Public property | Type | The gbXML opening type attribute.
Public property | Width | The width of the analytical rectangular geometry.

See Also

EnergyAnalysisOpening Class
Autodesk.Revit.DB.Analysis Namespace

CADLinkUniqueId Property

[image]