Revit 2021.1 API
ExportPatternKey Members
ExportPatternKey Class Constructors Methods Properties See Also Send Feedback

The ExportPatternKey type exposes the following members.

Constructors

 | Name | Description
Public method | ExportPatternKey()()()() | Constructs a new default ExportPatternKey.
Public method | ExportPatternKey(ExportPatternKey) | Constructs a new copy of the input ExportPatternKey object.
Public method | ExportPatternKey(FillPatternTarget, String) | Constructs a new ExportPatternKey using the original fill pattern type and name as input.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ExportPatternKey

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | OriginalFillPatternName | The original FillPattern name.
Public property | OriginalFillPatternType | The original FillPattern type.

See Also

ExportPatternKey Class

ExportPatternKey Constructor

[image] [image]