Revit 2021.1 API
Wire Properties
Wire Class See Also Send Feedback

The Wire type exposes the following members.

Properties

 | Name | Description
Public property | GroundConductorNum | The ground conductor number. Its default value is zero after created.
Public property | HotConductorNum | The hot conductor number. Its default value is zero after created.
Public property | NeutralConductorNum | The neutral conductor number. Its default value is zero after created.
Public property | NumberOfVertices | The number of vertices of the wire, including the start and end point.
Public property | WiringType | The wiring type(arc or chamfer) for the wire.

See Also

Wire Class
Autodesk.Revit.DB.Electrical Namespace

GroundConductorNum Property

[image]