Revit 2021.1 API
Category Methods
Category Class See Also Send Feedback

The Category type exposes the following members.

Methods

 | Name | Description
 | GetCategory(Document, BuiltInCategory) | Retrieves a category object corresponding to a BuiltInCategory id.
 | GetCategory(Document, ElementId) | Retrieves a category object corresponding to the category id.
Public method | GetGraphicsStyle | Gets the graphics style associated with this category for the given graphics style type.
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | GetLinePatternId | Gets the line pattern id associated with this category for the given graphics style type.
Public method | GetLineWeight | Retrieves the line weight assigned to the category for the given graphics style type.
 | IsBuiltInCategoryValid | Checks if a Category exists for a given BuiltInCategory.
Public method | SetLinePatternId | Sets the line pattern id associated with this category for the given graphics style type.
Public method | SetLineWeight | Sets the line weight for the given graphics style type.

See Also

Category Class

GetCategory Method

[image] [image]