Revit 2021.1 API
ImportInstance Methods
ImportInstance Class See Also Send Feedback

The ImportInstance type exposes the following members.

Methods

 | Name | Description
 | Create(Document, ElementId, View) | Creates a new instance of an existing DWG link type.
 | Create(Document, View, ExternalResourceReference, DGNImportOptions, LinkLoadResult%) | Creates a new instance of DGN link type from an external resource reference and loads the linked file.
 | Create(Document, View, ExternalResourceReference, DWGImportOptions, LinkLoadResult%) | Creates a new instance of DWG link type from an external resource reference and loads the linked file.
 | Create(Document, View, ExternalResourceReference, SATImportOptions, LinkLoadResult%) | Creates a new instance of SAT link type from an external resource reference and loads the linked file.
 | Create(Document, View, ExternalResourceReference, SKPImportOptions, LinkLoadResult%) | Creates a new instance of SKP link type from an external resource reference and loads the linked file.
 | Create(Document, View, String, DWGImportOptions, LinkLoadResult%) | Creates a new instance of DWG or DXF link type from a file path and loads the linked file.
Public method | GetVisibility | Gets the visibility for the import instance in a family document.
Public method | SetVisibility | Sets the visibility for the import instance in a family document.

See Also

ImportInstance Class

Create Method

[image] [image]