Revit 2021.1 API
BuildingEnvelopeAnalyzerOptions Members
BuildingEnvelopeAnalyzerOptions Class Constructors Methods Properties See Also Send Feedback

The BuildingEnvelopeAnalyzerOptions type exposes the following members.

Constructors

 | Name | Description
Public method | BuildingEnvelopeAnalyzerOptions | Constructs a new instance of BuildingEnvelopeAnalyzerOptions, using default values.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the BuildingEnvelopeAnalyzerOptions

Properties

 | Name | Description
Public property | AnalyzeEnclosedSpaceVolumes | Whether or not to analyze interior connected regions inside the building forming enclosed space volumes.
Public property | GridCellSize | The cell size for the uniform cubical grid used when analyzing the building envelope.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | OptimizeGridCellSize | Whether or not to use the exact value for the cell size or let the analyzer optimize the cell size based on the specified grid size

See Also

BuildingEnvelopeAnalyzerOptions Class
Autodesk.Revit.DB.Analysis Namespace

BuildingEnvelopeAnalyzerOptions Constructor

[image]