Revit 2021.1 API
PathOfTravel..::..UpdateMultiple Method (Document, IList<(Of <(<'ElementId>)>)>, IList<(Of <(<'PathOfTravelCalculationStatus>)>)>%)
PathOfTravel Class See Also Send Feedback
Updates the specified paths of travel by recalculating each path using their original start and end points and provides creation result statuses.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2020

Syntax

C#
public static int UpdateMultiple(
    Document adoc,
    IList<ElementId> elementsToUpdate,
    out IList<PathOfTravelCalculationStatus> resultStatus
)
Visual Basic
Public Shared Function UpdateMultiple ( _
    adoc As Document, _
    elementsToUpdate As IList(Of ElementId), _
    <OutAttribute> ByRef resultStatus As IList(Of PathOfTravelCalculationStatus) _
) As Integer
Visual C++
public:
static int UpdateMultiple(
    Document^ adoc,
    IList<ElementId^>^ elementsToUpdate,
    [OutAttribute] IList<PathOfTravelCalculationStatus>^% resultStatus
)

Parameters

adoc
Type: Autodesk.Revit.DB..::..Document
Document of elements to be updated.
elementsToUpdate
Type: System.Collections.Generic..::..IList<(Of <(<' ElementId >)>)>
The list of ElementIdof the paths to update.
resultStatus
Type: System.Collections.Generic..::..IList<(Of <(<' PathOfTravelCalculationStatus >)>)>%
Result statuses of each path of travel creation. The order of statuses corresponds to the order of elements in the array passed to the function.

Return Value

number of successfully updated elements

Remarks

For unsuccessfully updated elements, Revit will post warnings.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | This functionality is not available in Revit LT.

See Also

PathOfTravel Class
UpdateMultiple Overload
Autodesk.Revit.DB.Analysis Namespace

PathOfTravel Properties

[image] [image]