Revit 2021.1 API
IFCExtrusionCalculatorOptions Members
IFCExtrusionCalculatorOptions Class Constructors Methods Properties See Also Send Feedback

The IFCExtrusionCalculatorOptions type exposes the following members.

Constructors

 | Name | Description
Public method | IFCExtrusionCalculatorOptions | Constructs a new instance of a class used to calculate extrusions from Revit geometry.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the IFCExtrusionCalculatorOptions

Properties

 | Name | Description
Public property | CustomAxis | The custom axis to try (if extrusionAxes includes an option for a custom direction).
Public property | ExtrusionAxes | The extrusion axes to try when doing the calculation.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Scale | The scaling factor for length measurements from the default Revit units to the export units.

See Also

IFCExtrusionCalculatorOptions Class
Autodesk.Revit.DB.IFC Namespace

IFCExtrusionCalculatorOptions Constructor

[image]