Revit 2021.1 API
AnalysisDisplayDiagramSettings Properties
AnalysisDisplayDiagramSettings Class See Also Send Feedback

The AnalysisDisplayDiagramSettings type exposes the following members.

Properties

 | Name | Description
Public property | FenceType | Type of diagram fence visualization.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | OutlineColor | Color of outline and fence lines in the diagram.
Public property | OutlineLineWeight | Line weight of outline and fence lines in the diagram.
Public property | Rounding | Increment to which numeric values of analysis results are rounded in diagram.
Public property | TextLabelType | Type of diagram text label visualization.
Public property | TextTypeId | Element id of text associated with the settings.
Public property | Transparency | Transparency percentage of diagram color fill

See Also

AnalysisDisplayDiagramSettings Class
Autodesk.Revit.DB.Analysis Namespace

FenceType Property

[image]