Revit 2021.1 API
Stairs Methods
Stairs Class See Also Send Feedback

The Stairs type exposes the following members.

Methods

 | Name | Description
Public method | GetAssociatedRailings | Gets a list of the Railing elements which are associated to the boundaries of the stairs.
Public method | GetStairsLandings | Returns all the stairs landing components in the stairs.
Public method | GetStairsRuns | Returns all the stairs run components in the stairs.
Public method | GetStairsSupports | Returns all the stairs support components in the stairs.
 | IsByComponent | Indicates if the stairs is created by stairs components(runs, landings and supports).
Public method | IsInEditMode | Indicates whether the stairs is in edit mode or not.

See Also

Stairs Class
Autodesk.Revit.DB.Architecture Namespace

GetAssociatedRailings Method

[image]