Revit 2021.1 API
IFCExtrusionData Members
IFCExtrusionData Class Constructors Methods Properties See Also Send Feedback

The IFCExtrusionData type exposes the following members.

Constructors

 | Name | Description
Public method | IFCExtrusionData | Constructs a new empty extrusion data object.

Methods

 | Name | Description
Public method | AddLoop | Adds a curve loop to the extrusion data.
Public method | ClearLoops | Clears the curve loops stored in the extrusion data.
Public method | Dispose | Releases all resources used by the IFCExtrusionData
Public method | GetLoops | Gets the curve loops that form the base shape of the extrusion.
Public method | IsValid | Determines if the extrusion data represents a valid extrusion.
Public method | RemoveLoopAt | Removes the loop at the specified index.

Properties

 | Name | Description
Public property | ExtrusionBasis | The basis used for the extrusion.
Public property | ExtrusionDirection | The direction used for the extrusion.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ScaledExtrusionLength | The length of the extrusion, scaled in the units of the export.

See Also

IFCExtrusionData Class
Autodesk.Revit.DB.IFC Namespace

IFCExtrusionData Constructor

[image]