Revit 2021.1 API
ExternalResourceLoadContext Methods
ExternalResourceLoadContext Class See Also Send Feedback

The ExternalResourceLoadContext type exposes the following members.

Methods

 | Name | Description
Public method | CallingDocumentHasModelPath | Indicates whether the document requesting the external resource has a defined ModelPath.
Public method | Dispose |
Public method | GetCallingDocumentModelPath | Returns a copy of the ModelPath of the document that is requesting the external resource.
Public method | GetCurrentlyLoadedReference | Returns a copy of the ExternalResourceReference currently in use by the containing element.

See Also

ExternalResourceLoadContext Class

CallingDocumentHasModelPath Method

[image]