Revit 2021.1 API
CurveArray Methods
CurveArray Class See Also Send Feedback

The CurveArray type exposes the following members.

Methods

 | Name | Description
Public method | Append | Add the curve to the end of the array.
Public method | Clear | Removes every curve from the array, rendering it empty.
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | Insert | Insert the specified curve into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.

See Also

CurveArray Class

Append Method

[image]