Revit 2021.1 API
ProjectLocationSet Members
ProjectLocationSet Class Constructors Methods Properties See Also Send Feedback

The ProjectLocationSet type exposes the following members.

Constructors

 | Name | Description
Public method | ProjectLocationSet | Initializes a new instance of the ProjectLocationSet class

Methods

 | Name | Description
Public method | Clear | Removes every project location from the set, rendering it empty.
Public method | Contains | Tests for the existence of a project location within the set.
Public method | Erase | Removes a specified project location from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | Insert | Insert the specified project location into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | Size | Returns the number of project locations that are in the set.

See Also

ProjectLocationSet Class

ProjectLocationSet Constructor

[image]