Revit 2021.1 API
IndependentTag Properties
IndependentTag Class See Also Send Feedback

The IndependentTag type exposes the following members.

Properties

 | Name | Description
Public property | HasElbow | Whether the tag's leader has an elbow point or not.
Public property | HasLeader | Whether the tag has a leader or not.
Public property | IsMaterialTag | Identifies if it is a material tag or not.
Public property | IsMulticategoryTag | Identifies if it is a multi-category tag or not.
Public property | IsOrphaned | Identifies if the tag is orphaned or not.
Public property | LeaderElbow | The position of the elbow of the tag's leader.
Public property | LeaderEnd | The position of the leader end for a tag using free end leader behavior.
Public property | LeaderEndCondition | The leader end condition of the tag, such as if the end of the leader is attached to the host or free floating.
Public property | MultiReferenceAnnotationId | The multi-reference annotation which owns this tag.
Public property | TaggedElementId | The LinkElementId of the tagged element. If the tag is tagged on a subelement of linked element, it returns the LinkElementId of the element.
Public property | TaggedLocalElementId | The ID of the tagged local element, if any. If the tag is tagged on a subelement of local element, it returns the element ID.
Public property | TagHeadPosition | The position of the head of tag in model coordinates.
Public property | TagOrientation | The tag orientation of the tag's head, such as horizontal or vertical.
Public property | TagText | The text associated with the tag. If there are several strings assiciated with the tag, the strings will be returned concatenated.

See Also

IndependentTag Class

HasElbow Property

[image]