Revit 2021.1 API
ReferenceIntersector Constructor
ReferenceIntersector Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ReferenceIntersector(View3D) | Constructs a ReferenceIntersector which is set to return intersections from all elements and representing all reference target types.
Public method | ReferenceIntersector(ElementFilter, FindReferenceTarget, View3D) | Constructs a ReferenceIntersector which is set to return intersections from any element which passes an input filter.
Public method | ReferenceIntersector(ElementId, FindReferenceTarget, View3D) | Constructs a ReferenceIntersector which is set to return intersections from a single target element only.
Public method | ReferenceIntersector(ICollection<(Of <<'(ElementId>)>>), FindReferenceTarget, View3D) | Constructs a ReferenceIntersector which is set to return intersections from any of a set of target elements.

See Also

ReferenceIntersector Class
ReferenceIntersector Members

ReferenceIntersector Constructor (View3D)

[image]