Revit 2021.1 API
AdvancedLossFactor Members
AdvancedLossFactor Class Constructors Methods Properties See Also Send Feedback

The AdvancedLossFactor type exposes the following members.

Constructors

 | Name | Description
Public method | AdvancedLossFactor()()()() | Creates an advanced loss factor object with values set to no loss.
Public method | AdvancedLossFactor(AdvancedLossFactor) | Creates a copy of the given advanced loss factor object
Public method | AdvancedLossFactor(Double, Double, Double, Double, Double, Double, Double) | Creates an advanced loss factor object with the given values.

Methods

 | Name | Description

Properties

 | Name | Description
Public property | BallastLossFactor | The ballast loss factor.
Public property | LampLumenDepreciation | The lamp lumen depreciation loss factor.
Public property | LampTiltLossFactor | The lamp tilt loss factor.
Public property | LuminaireDirtDepreciation | The luminaire dirt depreciation loss factor.
Public property | SurfaceDepreciationLossFactor | The surface depreciation loss factor.
Public property | TemperatureLossFactor | The temperature loss factor.
Public property | VoltageLossFactor | The voltage loss factor.

See Also

AdvancedLossFactor Class
Autodesk.Revit.DB.Lighting Namespace

AdvancedLossFactor Constructor

[image] [image]