Revit 2021.1 API
DuctSettings Members
DuctSettings Class Methods Properties See Also Send Feedback

The DuctSettings type exposes the following members.

Methods

 | Name | Description
 | GetDuctSettings | Get the duct settings of the project.
Public method | GetPressLossCalculationServerInfo | Get the MEPServerInfo of the current pipe pressure loss calculation server.
Public method | GetSpecificFittingAngles | Gets the list of specific fitting angles.
Public method | GetSpecificFittingAngleStatus | Gets the status of given specific angle.
Public method | IsValidSpecificFittingAngle | Checks that the given value is a valid specific fitting angle. The specific fitting angles are angles of 90, 60, 45, 30, 22.5 or 11.25 degrees.
Public method | SetPressLossCalculationServerInfo | Set the MEPServerInfo of the current pipe pressure loss calculation server.
Public method | SetSpecificFittingAngleStatus | Sets the status of given specific angle.

Properties

 | Name | Description
Public property | AirDensity | The air density.
Public property | AirViscosity | The air dynamic viscosity.
Public property | Centerline | The abbreviation of the Centerline (=) string.
Public property | ConnectorSeparator | The duct connector separator string.
Public property | FittingAngleUsage | Determine how to use fitting angle during duct layout or modifying layout.
Public property | FittingAnnotationSize | The value of fitting annotation size.
Public property | FlatOnBottom | The abbreviation of the Flat On Bottom (FOB) string.
Public property | FlatOnTop | The abbreviation of the Flat On Top (FOT) string.
Public property | OvalDuctSizeSeparator | The oval duct size separator string.
Public property | OvalDuctSizeSuffix | The oval duct size suffix string.
Public property | RectangularDuctSizeSeparator | The rectangular duct size separator string.
Public property | RectangularDuctSizeSuffix | The rectangular duct size suffix string.
Public property | RiseDropAnnotationSize | The rise drop annotation size.
Public property | RoundDuctSizePrefix | The round duct size prefix string.
Public property | RoundDuctSizeSuffix | The round duct size suffix string.
Public property | SetDown | The abbreviation of the Set Down from top (TD) of fitting string.
Public property | SetDownFromBottom | The abbreviation of the Set Down from bottom (BD) of fitting string.
Public property | SetUp | The abbreviation of the Set Up from top (TU) of fitting string.
Public property | SetUpFromBottom | The abbreviation of the Set Up from bottom (BU) of fitting string.
Public property | UseAnnotationScaleForSingleLineFittings | Indicates whether use annotation scale for single line fittings or not.

See Also

DuctSettings Class
Autodesk.Revit.DB.Mechanical Namespace

DuctSettings Methods

[image] [image]