Revit 2021.1 API
ViewCropRegionShapeManager Members
ViewCropRegionShapeManager Class Methods Properties See Also Send Feedback

The ViewCropRegionShapeManager type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ViewCropRegionShapeManager
Public method | GetAnnotationCropShape | Gets the annotation crop box assigned to the view.
Public method | GetCropShape | Gets the crop boundaries that are curently active.
Public method | GetSplitRegionMaximum | Returns the proportional location of the maximum boundary of the specified split crop region.
Public method | GetSplitRegionMinimum | Returns the proportional location of the minimum boundary of the specified split crop region.
Public method | GetSplitRegionOffset | Returns the offset for the specified split crop region.
Public method | IsCropRegionShapeValid | Verifies that boundary represents one closed curve loop without self-intersections, consisting of non-zero length straight lines in a plane parallel to the view plane.
Public method | RemoveCropRegionShape | Removes any non-rectangular boundary of the view's crop.
Public method | RemoveSplit | Removes any split applied to the view's crop.
Public method | RemoveSplitRegion | Removes one region in split crop.
Public method | SetCropShape | Sets the boundary of the view's crop to the specified shape.
Public method | SplitRegionHorizontally | Splits horizontally one region in split crop.
Public method | SplitRegionVertically | Splits vertically one region in split crop.

Properties

 | Name | Description
Public property | BottomAnnotationCropOffset | The offset from the bottom of the view crop that determines the location of the annotation crop bottom boundary.
Public property | CanBeSplit | Verifies that the crop of the associated view is permitted to have multiple regions.
Public property | CanHaveAnnotationCrop | Verifies that the view is allowed to have an annotation crop.
Public property | CanHaveShape | Verifies that the crop of the associated view is permitted to have a non-rectangular shape.
Public property | IsSplitHorizontally | Whether or not the view's crop is split (and the split is horizontal).
Public property | IsSplitVertically | Whether or not the view's crop is split (and the split is vertical).
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LeftAnnotationCropOffset | The offset from the left of the view crop that determines the location of the annotation crop left boundary.
Public property | NumberOfSplitRegions | The number of split crop regions (1 if the crop is not currently split).
Public property | RightAnnotationCropOffset | The offset from the right of the view crop that determines the location of the annotation crop right boundary.
Public property | ShapeSet | Whether or not the view crop has a non-rectangular shape set.
Public property | Split | Whether or not the view crop is split.
Public property | TopAnnotationCropOffset | The offset from the top of the view crop that determines the location of the annotation crop top boundary.

See Also

ViewCropRegionShapeManager Class

ViewCropRegionShapeManager Methods

[image] [image]