Revit 2021.1 API
SiteSubRegion Methods
SiteSubRegion Class See Also Send Feedback

The SiteSubRegion type exposes the following members.

Methods

 | Name | Description
 | Create(Document, IList<(Of <<'(CurveLoop>)>>)) | Creates a new SiteSubRegion element and adds it to the document.
 | Create(Document, IList<(Of <<'(CurveLoop>)>>), ElementId) | Creates a new SiteSubRegion element with assigned TopographySurface to be hosted and adds it to the document.
Public method | Dispose |
Public method | GetBoundary | Gets the boundary of current subregion.
 | IsValidBoundary | Identifies whether the given curve loops compose a valid boundary.
Public method | SetBoundary | Set the given curve loops as the boundary of an existing SiteSubRegion.

See Also

SiteSubRegion Class
Autodesk.Revit.DB.Architecture Namespace

Create Method

[image] [image]