Revit 2021.1 API
ElectricalSetting Properties
ElectricalSetting Class See Also Send Feedback

The ElectricalSetting type exposes the following members.

Properties

 | Name | Description
Public property | CircuitLoadCalculationMethod | The method to calculate circuit load
Public property | CircuitNamePhaseA | Circuit Naming by Phase - Phase A Label.
Public property | CircuitNamePhaseB | Circuit Naming by Phase - Phase B Label.
Public property | CircuitNamePhaseC | Circuit Naming by Phase - Phase C Label.
Public property | CircuitPathOffset | The default circuit path offset for newly created circuit.
Public property | CircuitRating | The default circuit rating for newly created circuit.
Public property | CircuitSequence | The sequence in which power circuits are created.
Public property | DistributionSysTypes | Get all distribution system types of the project.
Public property | VoltageTypes | Get all voltage type definitions information of the project.
Public property | WireConduitTypes | Get electrical conduit types information of the project.
Public property | WireMaterialTypes | Get electrical wire material types information of the project.
Public property | WireTypes | Get all wire type definition information of the project.

See Also

ElectricalSetting Class
Autodesk.Revit.DB.Electrical Namespace

CircuitLoadCalculationMethod Property

[image]