Revit 2021.1 API
Units Methods
Units Class See Also Send Feedback

The Units type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | GetFormatOptions(ForgeTypeId) | Gets the default FormatOptions for a spec.
Public method | GetFormatOptions(UnitType) | Obsolete. Gets the default FormatOptions for a unit type.
 | GetModifiableSpecs | Gets all specs for which the default FormatOptions can be modified.
 | GetModifiableUnitTypes | Obsolete. Gets all unit types for which the default FormatOptions can be modified.
 | IsModifiableSpec | Checks whether the default FormatOptions can be modified for a given spec.
 | IsModifiableUnitType | Obsolete. Checks whether the default FormatOptions can be modified for a given unit type.
Public method | SetFormatOptions(ForgeTypeId, FormatOptions) | Sets the default FormatOptions for a spec.
Public method | SetFormatOptions(UnitType, FormatOptions) | Obsolete. Sets the default FormatOptions for a unit type.

See Also

Units Class

Dispose Method

[image]