Revit 2021.1 API
ConduitSizeSettings Methods
ConduitSizeSettings Class See Also Send Feedback

The ConduitSizeSettings type exposes the following members.

Methods

 | Name | Description
Public method | AddSize | Inserts a new ConduitSize in to the conduit size settings. The conduit standard name determines the location of the new size in the size table.
Public method | CreateConduitStandardTypeFromExisingStandardType | Creates one conduit standard type with the new name and assign the conduit sizes to it from the existing standard type.
Public method | DoesConduitStandardTypeExist | Checks if the specified conduit standard exist.
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
 | GetConduitSizeSettings | Gets the conduit size settings of the project.
Public method | GetConduitSizeSettingsIterator | Returns a ConduitSizeSettingIterator to the conduit size settings.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetSizeCount | Gets the size count of the conduit size table. The conduit standard name the location of the size in the size table.
Public method | RemoveConduitStandardType | Erases the existing ConduitSizes with this conduit standard name; the consuit standard type can not be removed if it is in use.
Public method | RemoveSize | Erase the existing ConduitSize with this nominal diameter. The conduit standard name determines the location of the size in the size table.

See Also

ConduitSizeSettings Class
Autodesk.Revit.DB.Electrical Namespace

AddSize Method

[image]