Revit 2021.1 API
MultiReferenceAnnotationOptions Properties
MultiReferenceAnnotationOptions Class See Also Send Feedback

The MultiReferenceAnnotationOptions type exposes the following members.

Properties

 | Name | Description
Public property | DimensionLineDirection | The direction vector of the dimension line.
Public property | DimensionLineOrigin | The origin point for the dimension line.
Public property | DimensionPlaneNormal | The normal vector to the dimension plane.
Public property | DimensionStyleType | The dimension style type to be used by the new MultiReferenceAnnotation.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | MultiReferenceAnnotationType | The MultiReferenceAnnotationType to be used by the new MultiReferenceAnnotation.
Public property | TagHasLeader | When true the tag will be created with an attached leader. When false the tag will be created without a leader.
Public property | TagHeadPosition | The position for the tag's head.

See Also

MultiReferenceAnnotationOptions Class

DimensionLineOrigin Property

[image]