Revit 2021.1 API
NonContinuousRailInfo Members
NonContinuousRailInfo Class Methods Properties See Also Send Feedback

The NonContinuousRailInfo type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the NonContinuousRailInfo
Public method | IsValidNonContinuousRailHeight | Checks whether the input height is valid for a non-continuous rail in its associated railing type.
Public method | IsValidNonContinuousRailMaterial | Checks whether an ElementId is a valid material Id of a non-continuous rail.
Public method | IsValidNonContinuousRailName | Checks whether the input name is valid for a non-continuous rail in its associated railing type.
Public method | IsValidNonContinuousRailProfile | Checks whether the input id represents a profile which can be used as the profile of this non-continuous rail.

Properties

 | Name | Description
Public property | Height | The height at which the non-continuous rail will be placed.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | MaterialId | The material id associated with the non-continuous rail, or invalidElementId if none.
Public property | Name | The name of the non-continuous rail.
Public property | Offset | The side offset of the non-continuous rail from a [!:Autodesk::Revit::DB::Architecture::Railing] from the railing center.
Public property | ProfileId | The profile id of the non-continuous rail, or invalidElementId if none.

See Also

NonContinuousRailInfo Class
Autodesk.Revit.DB.Architecture Namespace

NonContinuousRailInfo Methods

[image] [image]