Revit 2021.1 API
Camera Properties
Camera Class See Also Send Feedback

The Camera type exposes the following members.

Properties

 | Name | Description
Public property | EyePosition | Camera's position in the world
Public property | FarDistance | Distance to far clipping plane
Public property | HorizontalExtent | Horizontal extent of the camera's view, measured at target distance.
Public property | HorizontalOffset | Horizontal offset of the camera's view center from target, measured at target distance.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | NearDistance | Distance to near clipping plane
Public property | ProjectionMethod | Projection method
Public property | TargetDistance | Distance from camera to its target
Public property | UpDirection | Up direction of the camera
Public property | VerticalExtent | Vertical extent of the camera's view, measured at target distance.
Public property | VerticalOffset | Vertical offset of the camera's view center from target, measured at target distance.
Public property | ViewDirection | Direction that the camera is facing

See Also

Camera Class
Autodesk.Revit.DB.DirectContext3D Namespace

EyePosition Property

[image]