Revit 2021.1 API
HVACLoadBuildingType Members
HVACLoadBuildingType Class Methods Properties See Also Send Feedback

The HVACLoadBuildingType type exposes the following members.

Methods

 | Name | Description
 | Create | Creates a building type element.
Public method | IsNameUnique(String) | Determines whether a potential building type name is unique.
 | IsNameUnique(Document, String) | Determines whether a potential building type name is unique.
 | IsValidTime | Check if the string can be parsed to a valid time for opening time and closing time. A valid string can be "16:30" or "4:30 PM";

Properties

 | Name | Description
Public property | BuildingTypeName | The building type name.
Public property | ClosingTime | The closing time of the building type.
Public property | OpeningTime | The opening time of the building type.
Public property | UnoccupiedCoolingSetPoint | The unoccupied cooling set point of the building type with unit kelvin (K).

See Also

HVACLoadBuildingType Class
Autodesk.Revit.DB.Analysis Namespace

HVACLoadBuildingType Methods

[image] [image]