Revit 2021.1 API
Document..::..NewFloor Method
Document Class See Also Send Feedback
Creates a floor within the project.

Overload List

 | Name | Description
Public method | NewFloor(CurveArray, Boolean) | Creates a floor within the project with the given horizontal profile using the default floor style.
Public method | NewFloor(CurveArray, FloorType, Level, Boolean) | Creates a floor within the project with the given horizontal profile and floor style on the specified level.
Public method | NewFloor(CurveArray, FloorType, Level, Boolean, XYZ) | Creates a floor within the project with the given horizontal profile and floor style on the specified level with the specified normal vector.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace

NewFloor Method (CurveArray, FloorType, Level, Boolean)

[image]