Revit 2021.1 API
WireframeBuilder Members
WireframeBuilder Class Constructors Methods Properties See Also Send Feedback

The WireframeBuilder type exposes the following members.

Constructors

 | Name | Description
Public method | WireframeBuilder | Default constructor.

Methods

 | Name | Description
Public method | AddCurve | Add a curve to the shape representation stored in this WireframeBuilder.
Public method | AddPoint | Add a point to the shape representation stored in this WireframeBuilder.
Public method | Reset | Clears the accumulated geometry.
 | ValidateCurve | Validates curve to be added to the wireframe shape being constructed. Used by addCurve to validate input. This function may be used to pre-validate the geometry being added to avoid an exception from AddCurve().
 | ValidatePoint | Validates the point object to be added to the wireframe shape being constructed. Used by AddPoint() to validate input.

Properties

 | Name | Description

See Also

WireframeBuilder Class

WireframeBuilder Constructor

[image]