Revit 2021.1 API
Alignment Members
Alignment Class Methods Properties See Also Send Feedback

The Alignment type exposes the following members.

Methods

 | Name | Description
 | Get(Element) | Returns an Alignment object given a Revit alignment element.
 | Get(Document, Guid) | Returns an Alignment in the document given its GUID.
 | GetAlignments(Document) | Returns all alignments in the given document.
 | GetAlignments(View) | Returns all alignments visible in the given view.
Public method | GetClosestPoint | Calculates the point on the alignment's geometry which is closest to the given model point.
Public method | GetClosestStation | Calculates the alignment station closest to the given model point.
Public method | GetDisplayedHorizontalCurveEndpoints | Returns the endpoints of the alignment's horizontal curves. Only the points between DisplayedStartStation and DisplayedEndStation are returned.
Public method | GetDistance | Calculates the relative distance along the alignment between two stations based on their alignment distances according to Revit Internal Origin Coordinate Base. The distance may be positive or negative depending on the relative positions of the input stations on the alignment.
Public method | GetHCurveNormalAtStation | Calculate 2d (X and Y components of returned vector) horizontal normal at given station.
Public method | GetHCurveTangentAtStation | Calculate 2d (X and Y components of returned vector) horizontal tangent at given station.
Public method | GetPointAtStation | Calculates the model point for a given alignment station.
Public method | GetVCurveNormalAtStation | Calculate 2d (X and Y components of returned vector) vertical normal at given station.
Public method | GetVCurveTangentAtStation | Calculate 2d (X and Y components of returned vector) vertical tangent at given station.
Public method | IsValid()()()() | Checks if this object is a valid alignment.
 | IsValid(Element) | Checks if the element is a valid alignment.

Properties

 | Name | Description
Public property | Description | The Description of this alignment.
Public property | DisplayedEndStation | The value of the displayed end station.
Public property | DisplayedStartStation | The value of the displayed start station.
Public property | Element | The underlying DirectShape element.
Public property | GUID | The GUID of this alignment.
Public property | Name | The Name of this alignment.

See Also

Alignment Class
Autodesk.Revit.DB.Infrastructure Namespace

Alignment Methods

[image] [image]