Revit 2021.1 API
MassGBXMLExportOptions Constructor (IList<(Of <(<'ElementId>)>)>, IList<(Of <(<'ElementId>)>)>)
MassGBXMLExportOptions Class See Also Send Feedback
Constructs a new instance of the options used to export a mass model to gbXML.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012

Syntax

C#
public MassGBXMLExportOptions(
    IList<ElementId> massZoneIds,
    IList<ElementId> massIds
)
Visual Basic
Public Sub New ( _
    massZoneIds As IList(Of ElementId), _
    massIds As IList(Of ElementId) _
)
Visual C++
public:
MassGBXMLExportOptions(
    IList<ElementId^>^ massZoneIds,
    IList<ElementId^>^ massIds
)

Parameters

massZoneIds
Type: System.Collections.Generic..::..IList<(Of <(<' ElementId >)>)>
Indicates the mass zones to analyze in the exported gbXML.
massIds
Type: System.Collections.Generic..::..IList<(Of <(<' ElementId >)>)>
Indicates the masses to use as shading surfaces in the exported gbXML--these masses must not have mass floors or mass zones so as not to end up with duplicate surface information in the gbXML output.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

MassGBXMLExportOptions Class
MassGBXMLExportOptions Overload
Autodesk.Revit.DB.Analysis Namespace

MassGBXMLExportOptions Methods

[image] [image]