Revit 2021.1 API
PanelScheduleView Members
PanelScheduleView Class Methods Properties See Also Send Feedback

The PanelScheduleView type exposes the following members.

Methods

 | Name | Description
Public method | AddSpace | Add a space at specific cell.
Public method | AddSpare | Add a spare at specific cell.
Public method | CanMoveSlotTo | Verifies if can circuits in the source slot to the specific slot.
 | CreateInstanceView(Document, ElementId) | Creates a new instance of this view (using default template)
 | CreateInstanceView(Document, ElementId, ElementId) | Creates a new instance of this view (using specific template)
Public method | GenerateInstanceFromTemplate | Assigns the data from the template to the instance and performs any tasks specific to the instance (3rd phase, borders, etc)
Public method | GetApparentPhaseValue | Gets the apparent load for the given phase for the given slotted circuit
Public method | GetCellsBySlotNumber | Gets cells for the given slot number
Public method | GetCircuitByCell | Gets the circuit element for the given slot number
Public method | GetCircuitIdByCell | Gets the circuit id for the given slot number
Public method | GetCombinedParamValue | Returns the combined parameter text for instance view
Public method | GetLoadClassificationConnectedCurrent | Gets the Total Current for given Load Classification
Public method | GetLoadClassificationConnectedLoad | Gets the Total Load for given Load Classification
Public method | GetLoadClassificationDemandCurrent | Gets the Demand Current for given Load Classification
Public method | GetLoadClassificationDemandFactor | Gets the Demand Factor for given Load Classification
Public method | GetLoadClassificationDemandLoad | Gets the Demand Load for given Load Classification
Public method | GetLoadClassificationId | Gets the id of the associated Load Classification at the given row
Public method | GetLoadClassificationName | Gets the name of the Load Classification at the given row/column
Public method | GetLoadClassificationParamValue | Gets the load classification parameter value.
Public method | GetPanel | Gets the panel for this view
Public method | GetParamValue | Gets the cell's text based on its type
Public method | GetSectionData | Gets section data that will be written to
Public method | GetSlotNumberByCell | Gets the slot number in the circuit table
Public method | GetSpareCurrentValue | Gets the value of the apparent current parameter for a spare
Public method | GetSpareLoadValue | Gets the value of the apparent load parameter for a spare
Public method | GetTableData | Gets table data that can be written to
Public method | GetTemplate | Gets the template for this view (to set the template, you must go through generateInstanceFromTemplate)
Public method | IsCellInPhaseLoads | Check if this cell in the phase loads
Public method | IsColumnInLoadSummary | Check if this column in the load summary
Public method | IsPanelScheduleTemplate | Check if this is a panel schedule template.
Public method | IsRowInCircuitTable | Check if this row in the circuit table
Public method | IsSlotGrouped | Check if the slot is in a group
Public method | IsSlotLocked | Check if the circuit slot in this cell is locked.
Public method | IsSpace | Check if the selected cell is a space
Public method | IsSpare | Check if the circuit is a spare
Public method | MoveSlotTo | Move the circuits in the source slot to the specific slot.
Public method | RemoveSpace | Remove a space at specific cell.
Public method | RemoveSpare | Remove a spare at specific cell.
Public method | RenumberIndexes | Renumbers the Circuit Naming Index for the circuits in the panel.
Public method | SetParamValue | Sets the text for the given cell, returns true if successful, false otherwise
Public method | SetSpareCurrentValue | Sets the value of the apparent current parameter for a spare
Public method | SetSpareLoadValue | Sets the value of the apparent load parameter for a spare
Public method | SwitchPhases | Switches the circuit phases at the slot.

Properties

 | Name | Description

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace

PanelScheduleView Methods

[image] [image]