Revit 2021.1 API
ConduitSizes Members
ConduitSizes Class Methods Properties See Also Send Feedback

The ConduitSizes type exposes the following members.

Methods

 | Name | Description
Public method | Contains | Checks whether a conduit size with the nominal diameter exists.
Public method | Dispose | Releases all resources used by the ConduitSizes
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetConduitSizesIterator | Returns a ConduitSizeIterator to the conduit sizes.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.

Properties

 | Name | Description
Public property | Count | Count of the items contained in the collection.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

ConduitSizes Class
Autodesk.Revit.DB.Electrical Namespace

ConduitSizes Methods

[image] [image]