Revit 2021.1 API
RevisionSettings Members
RevisionSettings Class Methods Properties See Also Send Feedback

The RevisionSettings type exposes the following members.

Methods

 | Name | Description
Public method | GetAlphanumericRevisionSettings | Returns a copy of the AlphanumericRevisionSettings owned by this RevisionSettings object.
Public method | GetNumericRevisionSettings | Returns a copy of the NumericRevisionSettings owned by this RevisionSettings object.
 | GetRevisionSettings | Returns the RevisionSettings for the given project document.
Public method | IsAcceptableRevisionCloudSpacing | Rounds the given raw value and checks whether it is an acceptable cloud spacing value after it is rounded.
 | RoundRevisionCloudSpacing | Rounds the given revision cloud spacing value according to the document's settings.
Public method | SetAlphanumericRevisionSettings | Replaces the current alphanumeric revision numbering settings with the specified AlphanumericRevisionSettings.
Public method | SetNumericRevisionSettings | Replaces the current numeric revision numbering settings with the specified NumericRevisionSettings.

Properties

 | Name | Description
Public property | RevisionCloudSpacing | Determines the size in paper space of revision clouds drawn in a project.
Public property | RevisionNumbering | Determines how the revision number values will display on sheets.

See Also

RevisionSettings Class

RevisionSettings Methods

[image] [image]