Revit 2021.1 API
TableView Members
TableView Class Methods Properties See Also Send Feedback

The TableView type exposes the following members.

Methods

 | Name | Description
Public method | GetAvailableParameterCategories | Get all available parameter categories.
 | GetAvailableParameters | Gets a list of valid parameters for the specified category that can be used in the table view.
Public method | GetCalculatedValueName | Gets the calculated value name for a cell from the template view.
Public method | GetCalculatedValueText | Gets the calculated value text for a cell from the instance view.
Public method | GetCellText | Gets the cell's text based on its type
Public method | IsValidSectionType | Identifies if the section type is valid for this view.

Properties

 | Name | Description
Public property | MaximumColumnWidth | Gets the maximum column width
Public property | MaximumGridWidth | Gets the allowed maximum grid width
Public property | MaximumRowHeight | Gets the maximum row height
Public property | MinimumColumnWidth | Gets the minimum column width
Public property | MinimumRowHeight | Gets the minimum row height
Public property | TargetId | the element id of the element that is being viewed

See Also

TableView Class

GetAvailableParameterCategories Method

[image]