Revit 2021.1 API
ReloadLatestOptions..::..IsValidObject Property
ReloadLatestOptions Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

ReloadLatestOptions Class

ReloadSwapOutInfo Class

[image]