Revit 2021.1 API
ContinuousRailType Properties
ContinuousRailType Class See Also Send Feedback

The ContinuousRailType type exposes the following members.

Properties

 | Name | Description
Public property | DefaultJoinOption | The default join option between two rails.
Public property | EndOrTopExtensionLength | The extension length of the rail termination at the end or top.
Public property | EndOrTopExtensionStyle | The extension style of the rail termination at the end or top.
Public property | EndOrTopTermination | The termination of the rail at the end or top.
Public property | FilletRadius | The fillet radius of the rail join.
Public property | HandClearance | The horizontal distance between the inner boundary of the rail and the path.
Public property | ProfileId | The id of the profile of the rail
Public property | Projection | The horizontal distance between the outer boundary of the rail and the path.
Public property | StartOrBottomExtensionLength | The extension length of the rail termination at the beginning or bottom.
Public property | StartOrBottomExtensionStyle | The extension style of the rail termination at the beginning or bottom.
Public property | StartOrBottomTermination | The termination of the rail at the beginning or bottom.
Public property | Transition | The transition option of the rail.

See Also

ContinuousRailType Class
Autodesk.Revit.DB.Architecture Namespace

DefaultJoinOption Property

[image]