Revit 2021.1 API
ConduitSizeSettingIterator Members
ConduitSizeSettingIterator Class Methods Properties See Also Send Feedback

The ConduitSizeSettingIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ConduitSizeSettingIterator
Public method | HasCurrent | Identifies whether the iterator has a current item. There is no current item if the iterator has not started yet or has been done.
Public method | IsDone | Identifies if the iteration has completed.
Public method | MoveNext | Increments the enumerator to the next item.
Public method | Reset | Resets the iterator to the initial state.

Properties

 | Name | Description
Public property | Current | Gets the item at the current position of the iterator.
Protected property | CurrentObject |
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

ConduitSizeSettingIterator Class
Autodesk.Revit.DB.Electrical Namespace

ConduitSizeSettingIterator Methods

[image] [image]