Revit 2021.1 API
PrintManager Properties
PrintManager Class See Also Send Feedback

The PrintManager type exposes the following members.

Properties

 | Name | Description
Public property | Collate | Indicates whether to collate of the current print.
Public property | CombinedFile | Indicates whether to combine multiple selected views/sheets into a single file.
Public property | CopyNumber | The copy number.
Public property | IsVirtual | The virtual type in Autodesk Revit.
Public property | PaperSizes | Get all print sizes of current printer.
Public property | PaperSources | Get all print sources of current printer.
Public property | PrinterName | The name of the current printer.
Public property | PrintOrderReverse | Indicates whether to reverse the print order of the current print.
Public property | PrintRange | The print range.
Public property | PrintSetup | The PrintSetup which manages the print settings of current document.
Public property | PrintToFile | Indicates whether to print to file.
Public property | PrintToFileName | The file name when printing to file.
Public property | ViewSheetSetting | The ViewSheetSetting which manages the view/sheet set information of current document, and you can change the default view/sheet set for current project.

See Also

PrintManager Class

CombinedFile Property

[image]