Revit 2021.1 API
FabricationService Members
FabricationService Class Methods Properties See Also Send Feedback

The FabricationService type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the FabricationService
Public method | GetButton | Gets the service button for a given group index and button index from the service.
Public method | GetButtonCount | Gets the number of buttons for a given group in the service.
Public method | GetGroupName | Gets the name of a group based on group index.
Public method | IsCompatibleWith | Check whether the service is broadly interchangable with another one without affecting part geometry. The services must have the same fabrication system template and specification.
Public method | IsGroupExcluded | Get whether a service group is excluded from being used by the Route and Fill, Design to Fabrication, or Multi Point Routing commands. The default configuration values may be overridden by SetServiceGroupExclusions.
Public method | IsValidButtonIndex | Validates the button index.
Public method | IsValidGroupIndex | Validates the group index.
Public method | OverrideServiceButtonExclusion | Overrides the default service button exclusions, used by Route and Fill, Design to Fabrication, or Multi Point Routing for the current user and session only.
Public method | ResetServiceExclusionOverrides | Resets the overridden service group and button exclusions back to default, as defined by the configuration.
Public method | SetServiceGroupExclusions | Sets the service group exclusions, used by Route and Fill or Design to Fabrication commands, for the current user and session only. This will alter them from the default configuration exclusions to only exclude those groups passed.

Properties

 | Name | Description
Public property | Abbreviation | The short name of service.
Public property | FabricationSystemName | The fabrication system name of the service.
Public property | GroupCount | The number of groups in the service.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Name | The name of the service.
Public property | ServiceId | The service identifier of the service.

See Also

FabricationService Class

FabricationService Methods

[image] [image]