Revit 2021.1 API
Document..::..NewRoom Method
Document Class See Also Send Feedback
Creates a new room.

Overload List

 | Name | Description
Public method | NewRoom(Phase) | Creates a new unplaced room and with an assigned phase.
Public method | NewRoom(Level, UV) | Creates a new room on a level at a specified point.
Public method | NewRoom(Room, PlanCircuit) | Creates a new room within the confines of a plan circuit, or places an unplaced room within the confines of the plan circuit.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace

NewRoom Method (Phase)

[image]