Revit 2021.1 API
PanelScheduleTemplate Methods
PanelScheduleTemplate Class See Also Send Feedback

The PanelScheduleTemplate type exposes the following members.

Methods

 | Name | Description
Public method | CopyFrom | Copies all values from other element to this object.
 | Create | Creates a new instance of a panel schedule template.
Public method | GetPanelScheduleType | Returns the panel schedule type.
Public method | GetSectionData | Gets the writable section data object.
Public method | GetTableData | Gets the writable table data object.
Public method | HasSameType | Checks if given template has the same panel schedule type with this template.
 | IsValidPanelConfiguration | Checks if given panel configuration is valid for given panel schedule type.
 | IsValidType(PanelScheduleType) | Checks if given type is valid for this panel schedule template element.
Public method | SetTableData | Assigns table data to this template

See Also

PanelScheduleTemplate Class
Autodesk.Revit.DB.Electrical Namespace

CopyFrom Method

[image]