Revit 2021.1 API
TransactionGroup Members
TransactionGroup Class Constructors Methods Properties See Also Send Feedback

The TransactionGroup type exposes the following members.

Constructors

 | Name | Description
Public method | TransactionGroup(Document) | Constructs a transaction group object.
Public method | TransactionGroup(Document, String) | It constructs a transaction group object

Methods

 | Name | Description
Public method | Assimilate | Assimilates all inner transactions by merging them into a single undo item.
Public method | Commit | Commits the transaction group.
Public method | Dispose | Releases all resources used by the TransactionGroup
Public method | GetName | Returns the transaction group's name. It could be an empty string.
Public method | GetStatus | Gets the current status of the transaction group.
Public method | HasEnded | Determines whether the transaction group has ended already.
Public method | HasStarted | Determines whether the transaction has been started yet.
Public method | RollBack | Rolls back the transaction group, which effectively undoes all transactions committed inside the group.
Public method | SetName | Sets the transaction group's name.
Public method | Start()()()() | Starts the transaction group
Public method | Start(String) | Starts the transaction group with an assigned name.

Properties

 | Name | Description
Public property | IsFailureHandlingForcedModal | Forces all transactions finished inside this group to use modal failure handling regardless of what failure handling options are set for those transactions.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

TransactionGroup Class

TransactionGroup Constructor

[image] [image]