Revit 2021.1 API
NonContinuousRailInfo Properties
NonContinuousRailInfo Class See Also Send Feedback

The NonContinuousRailInfo type exposes the following members.

Properties

 | Name | Description
Public property | Height | The height at which the non-continuous rail will be placed.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | MaterialId | The material id associated with the non-continuous rail, or invalidElementId if none.
Public property | Name | The name of the non-continuous rail.
Public property | Offset | The side offset of the non-continuous rail from a [!:Autodesk::Revit::DB::Architecture::Railing] from the railing center.
Public property | ProfileId | The profile id of the non-continuous rail, or invalidElementId if none.

See Also

NonContinuousRailInfo Class
Autodesk.Revit.DB.Architecture Namespace

Height Property

[image]