Revit 2021.1 API
IExternalService Methods
IExternalService Interface See Also Send Feedback

The IExternalService type exposes the following members.

Methods

 | Name | Description
Public method | Execute | Implement this method to execute the given server.
Public method | GetDescription | Implement this method to return a description of the service.
Public method | GetName | Implement this method to return the name of the service.
Public method | GetServiceId | Implement this method to return the unique Id of the service.
Public method | GetVendorId | Implement this method to return the vendor Id of the service.
Public method | IsValidServer | Implement this method to check if the given instance represents a valid server of this service.
Public method | OnServersChanged | Implement this method to handle situations when servers for the service have changed.
Public method | OnServersDisparity | Implements this method to get notified that the servers in a just opened document differ from those currently set as active for the service.

See Also

IExternalService Interface
Autodesk.Revit.DB.ExternalService Namespace

Execute Method

[image]