Revit 2021.1 API
MassSurfaceData Members
MassSurfaceData Class Methods Properties See Also Send Feedback

The MassSurfaceData type exposes the following members.

Methods

 | Name | Description
Public method | GetFaceReferences | Gets References to the faces that the MassSurfaceData provides properties for.

Properties

 | Name | Description
Public property | Area | Area of the references that the MassSurfaceData provides properties for.
Public property | CategoryIdForConceptualSurfaceType | Returns the mass subcategory ElementId used for ConceptualSurfaceType for this MassSurfaceData.
Public property | ConceptualConstructionId | The id of the conceptual construction associated with the reference surface.
Public property | IsConceptualConstructionByEnergyData | True when the ConceptualConstructionType id is synchronized to the EnergyDataSettings. False when the ConceptualConstructionType id is overridden for this MassSurfaceData.
Public property | IsGlazingShaded | Indicates if shade geometry is auto-generated on the top edge of auto-generated glazing.
Public property | IsSlab | Indicates if a floor is a slab.
Public property | IsUnderground | Indicates if the roof, floor, slab, or wall surface reference is underground.
Public property | MassLevelDataId | The MassLevelData used when the surface is horizontal, planar, and at the same height as a MassLevelData related to the same mass as the referenced face.
Public property | MaterialId | The visualization material used for the surface for displaying the energy analytical model.
Public property | MaterialType | material type of mass zone
Public property | PercentageGlazing | The target percentage of the reference wall surface that is to be covered with automatically generated windows. Revit will use this number when determining the size, shape, and location of automatically generated windows.
Public property | PercentageSkylights | The target percentage of the reference roof surface that is to be covered with automatically generated skylights. Revit will use this number when determining the size, shape, and location of automatically generated skylights.
Public property | ReferenceElementId | The ElementId of the element whose face the MassSurfaceData primarily refers to.
Public property | ShadeDepth | How far any auto-generated shades should extend from the wall surface.
Public property | SillHeight | The height above the level where the bottoms of auto-generated windows will be located.
Public property | SkylightWidth | The length dimension to be used for the sides of each individual square skylight produced in the grid of auto-generated skylights.
Public property | SurfaceDataSource | Indicates whether the MassSurfaceData properties are driven by the EnergyDataSettings of the Document or are overridden for the surface.

See Also

MassSurfaceData Class
Autodesk.Revit.DB.Analysis Namespace

MassSurfaceData Methods

[image] [image]