Revit 2021.1 API
MacroModuleIterator Methods
MacroModuleIterator Class See Also Send Feedback

The MacroModuleIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | GetCurrent | Returns the current Macro.
Public method | IsDone | Identifies if the iteration has completed.
Public method | MoveNext | Increments the iterator to the next item.
Public method | Reset | Resets the iterator to the initial state.

See Also

MacroModuleIterator Class
Autodesk.Revit.DB.Macros Namespace

Dispose Method

[image]