Revit 2021.1 API
ExporterIFC Methods
ExporterIFC Class See Also Send Feedback

The ExporterIFC type exposes the following members.

Methods

 | Name | Description
Public method | AddBuildingStorey | Adds building storey to the exporter's internal cache.
Public method | ClearFaceWithElementHandleMap | Clear face with element handle map.
Public method | Dispose |
Public method | FindSpaceBoundingElementHandle | Looks up the handle associated to the element and level id from the ExporterIFC's internal cache.
Public method | Get2DContextHandle | Obtains the IfcRepresentationContext handle to be used for 2D entities (Annotations).
Public method | Get3DContextHandle | Obtains the IfcRepresentationContext or IfcRepresentationSubContext handle to be used for 3D entities (Model entities).
Public method | GetDoorWindowOpeningHandle | Get the handle to the opening associated with a hosted (door/window) element from the internal cache.
Public method | GetFamilyName | Gets the name of the element assigned to the current export state.
Public method | GetFile | Gets the handle to the IFC file being created during this export operation.
Public method | GetHostObjects | Returns a collection containing the host object handles in the document.
Public method | GetLevelInfo | Returns an object representing the information about a level in the document.
Public method | GetLevelInfos | Returns a collection containing the information about all levels in the document.
Public method | GetMaterialIdForCurrentExportState | This gets the material id that is associated with the element in the current export state.
Public method | GetOptions | Gets the collection of named options set by the exporter client.
Public method | GetOrCreateFillPattern | Get (or create) the IfcFillPatternStyle associated with an ElementId.
Public method | GetRelatedElements | Gets all elements not associated to stories.
Public method | GetRelatedProducts | Gets all products not associated to stories.
Public method | PopExportState | Resets the internal state of the exporter to process the previously active input element (if any), or the default state if the stack is empty.
Public method | PopTransform | Resets the internal transform of the exporter to process the previously active input element (if any), or the default transform if the stack is empty.
Public method | PushExportState | Sets the internal state of the exporter to process the geometry and properties of the input element.
Public method | PushTransform | Sets the internal transform of the exporter to process the geometry and properties of the input element.
Public method | RegisterDoorWindowForUncreatedOpening | Registers a door or window in the ExporterIFC's internal cache. The ids registered correspond to openings in walls which have not been processed and created yet.
Public method | RegisterFaceWithElementHandle | Register face with element handle to make sure the openings created are related to the right element.
Public method | RegisterShapeForPresentationLayer | Sets an IfcShapeRepresentation to be used for the IfcPresentationLayerAssignment associated with the given Revit category and element.
Public method | RegisterSpaceBoundingElementHandle | Stores a handle representing a space bounding element to the ExporterIFC's internal cache.
Public method | RemoveBuildingStorey | Removes an IFCLevelInfo corresponding to a level from the exporter's internal cache.
Public method | Set2DContextHandle | Sets the IfcRepresentationContext handle to be used for 2D entities (Annotations).
Public method | Set3DContextHandle | Sets the IfcRepresentationContext or IfcRepresentationSubContext handle to be used for 3D entities (Model entities).
Public method | SetFile | Sets the handle to the IFC file being created during this export operation.
Public method | SetMaterialIdForCurrentExportState | This sets the material id that is to be associated with the element in the current export state.
Public method | SetOwnerHistoryHandle | Sets the handle to the IfcOwnerHistory for the file.

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace

AddBuildingStorey Method

[image]