Revit 2021.1 API
MacroManager Methods
MacroManager Class See Also Send Feedback

The MacroManager type exposes the following members.

Methods

 | Name | Description
Public method | AddModule | Adds a MacroModule to the application or document.
Public method | Contains | Indicates the given module is a member of this collection.
Public method | Dispose |
 | GetApplicationMacroSecurityOptions | Gets the application macro security options.
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
 | GetDocumentMacroSecurityOptions | Gets the document macro security options.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
 | GetMacroManager(Application) | Gets the Macro manager from the application.
 | GetMacroManager(Document) | Gets the Macro manager from the document.
Public method | GetMacroManagerIterator | Returns a Macro manager iterator that iterates through the collection.
Public method | RemoveModule | Removes a MacroModule from the application or document.
 | SetApplicationMacroSecurityOptions | Sets the application macro security options.
 | SetDocumentMacroSecurityOptions | Sets the document macro security options.

See Also

MacroManager Class
Autodesk.Revit.DB.Macros Namespace

AddModule Method

[image]