Revit 2021.1 API
BarTypeDiameterOptions Members
BarTypeDiameterOptions Class Constructors Methods Properties See Also Send Feedback

The BarTypeDiameterOptions type exposes the following members.

Constructors

 | Name | Description
Public method | BarTypeDiameterOptions()()()() | Constructs a new BarTypeDiameterOptions with default settings.
Public method | BarTypeDiameterOptions(RebarBarType) | Constructs a new BarTypeDiameterOptions copying the diameter information from the bar type.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the BarTypeDiameterOptions

Properties

 | Name | Description
Public property | BarDiameter | Represents the bar diameter of the RebarBarType.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | StandardBendDiameter | Represents the standard bar bend diameter of the RebarBarType.
Public property | StandardHookBendDiameter | Represents the standard hook bend diameter of the RebarBarType.
Public property | StirrupTieBendDiameter | Represents the stirrup/tie bar and hook bend diameter of the RebarBarType.

See Also

BarTypeDiameterOptions Class

BarTypeDiameterOptions Constructor

[image]