Revit 2021.1 API
FailureDefinitionAccessor Methods
FailureDefinitionAccessor Class See Also Send Feedback

The FailureDefinitionAccessor type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | GetApplicableResolutionTypes | Retrieves a list of resolution types applicable to the failure.
Public method | GetDefaultResolutionType | Retrieves the default resolution type for the failure.
Public method | GetDescriptionText | Retrieves the description text of the failure.
Public method | GetId | Retrieves the unique identifier of the FailureDefinition.
Public method | GetResolutionCaption | Retrieves the caption for a specific resolution type.
Public method | GetSeverity | Retrieves severity of the failure.
Public method | HasResolutions | Checks if the FailureDefinition has at least one resolution.
Public method | IsResolutionApplicable | Checks if the given resolution type is applicable to the failure.
Public method | SetDefaultResolutionType | Sets the default resolution type for the failure.

See Also

FailureDefinitionAccessor Class

Dispose Method

[image]