Revit 2021.1 API
WorksharingSaveAsOptions Members
WorksharingSaveAsOptions Class Constructors Methods Properties See Also Send Feedback

The WorksharingSaveAsOptions type exposes the following members.

Constructors

 | Name | Description
Public method | WorksharingSaveAsOptions | Constructs a new WorksharingSaveAsOptions with default settings.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the WorksharingSaveAsOptions

Properties

 | Name | Description
Public property | ClearTransmitted | For a transmitted model opened with DetachAndPreserveWorksets, clear its transmitted flag in the Save/SaveAs operation.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | OpenWorksetsDefault | The default set of user-worksets to open when opening the model in the UI. Default is AskUserToSpecify.
Public property | SaveAsCentral | Whether to save the new model as a central instead of local model. True: save as a central model. Default is false: save as a local model.

See Also

WorksharingSaveAsOptions Class

WorksharingSaveAsOptions Constructor

[image]