Revit 2021.1 API
Room Members
Room Class Methods Properties See Also Send Feedback

The Room type exposes the following members.

Methods

 | Name | Description
Public method | IsPointInRoom | Determines if a point lies within the volume of the room.
Public method | Unplace | Remove the room from its location, but the project still contains the room. The room can be placed in another location after unplaced.

Properties

 | Name | Description
Public property | BaseOffset | Get or Set the Base Offset of the Room.
Public property | ClosedShell | Return the closedShell of the Room.
Public property | LimitOffset | Get or Set the Limit Offset of the Room.
Public property | UnboundedHeight | Get the Unbounded Height of the Room.
Public property | UpperLimit | Get or Set the Upper Limit of the Room.
Public property | Volume | Get the Volume of the Room.

See Also

Room Class
Autodesk.Revit.DB.Architecture Namespace

Room Methods

[image] [image]