Revit 2021.1 API
DirectShapeLibrary Methods
DirectShapeLibrary Class See Also Send Feedback

The DirectShapeLibrary type exposes the following members.

Methods

 | Name | Description
Public method | AddDefinition(String, GeometryObject) | Add a definition to be reused by instances. A definition is a single geometry object.
Public method | AddDefinition(String, IList<(Of <<'(GeometryObject>)>>)) | Add a definition to be reused by instances. A definition is a collection of geometry objects.
Public method | AddDefinitionType | Add a definition to be reused by instances. Adding a definition type will change how the instances are created. When asked to create a definition, the library object will look for a corresponding type object. If one is found, it will create an instance of geometry stored in the type object. If it is not found, the library will look for a list of geometry objects stored as definition, and will copy and transform these to create an instance.
Public method | Contains | A quick check whether a definition already exists in the library. Checks for stored geometry objects only.
Public method | ContainsType | A quick check whether a definition type already exists in the library. Checks for type objects only.
Public method | Dispose |
Public method | FindDefinition | Find a definition by id
Public method | FindDefinitionType | Find a DirectShapeType element by definition id. The element will be used for creating instances of that definition.
 | GetDirectShapeLibrary | Get the currently active Library object
Public method | Reset | Removes all definitions from library. This is useful when importing several self-contained data sets within one session. Once a data set is imported, keeping the definitions specific to that data set will slow down the searches.

See Also

DirectShapeLibrary Class

AddDefinition Method

[image] [image]