Revit 2021.1 API
FabricationHostedInfo Members
FabricationHostedInfo Class Methods Properties See Also Send Feedback

The FabricationHostedInfo type exposes the following members.

Methods

 | Name | Description
Public method | DisconnectFromHost | Disconnects the part from the host.
Public method | Dispose | Releases all resources used by the FabricationHostedInfo
Public method | GetBearerCenterline | Gets the centerline of the bearer. The method is applicable only for bearer hanger.
Public method | PlaceOnHost(ElementId, Connector, Double) | Places the part on the specified host.
Public method | PlaceOnHost(ElementId, Connector, Double, Double) | Places the part on the specified host.

Properties

 | Name | Description
Public property | HostId | Returns the Id of the host.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

FabricationHostedInfo Class

DisconnectFromHost Method

[image]