Revit 2021.1 API
Polyloop Members
Polyloop Class Methods Properties See Also Send Feedback

The Polyloop type exposes the following members.

Methods

 | Name | Description
Public method | ComputeArea | Gets the area for this polygon.
Public method | Dispose | Releases all resources used by the Polyloop
Public method | GetPoints | Gets the array of points in the polygon

Properties

 | Name | Description
Public property | Centroid | The polygon centroid.
Public property | Direction | The direction for the outward normal for this polygon.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

Polyloop Class
Autodesk.Revit.DB.Analysis Namespace

Polyloop Methods

[image] [image]