Revit 2021.1 API
Schema Properties
Schema Class See Also Send Feedback

The Schema type exposes the following members.

Properties

 | Name | Description
Public property | ApplicationGUID | The GUID of the application or add-in that may access entities of this Schema under the Application access level.
Public property | Documentation | The overall description of the Schema.
Public property | GUID | The identifier of the Schema. Setter made unavailable, because it would violate set-correctness
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ReadAccessLevel | Read access level of the schema.
Public property | SchemaName | The user-friendly name of the Schema.
Public property | VendorId | The id of the third-party vendor that may access entities of this Schema under the Vendor access level.
Public property | WriteAccessLevel | Write access level of the schema.

See Also

Schema Class
Autodesk.Revit.DB.ExtensibleStorage Namespace

ApplicationGUID Property

[image]