Revit 2021.1 API
MultiServerService Methods
MultiServerService Class See Also Send Feedback

The MultiServerService type exposes the following members.

Methods

 | Name | Description
Public method | GetActiveServerIds()()()() | Returns Ids of the currently active application-level servers registered for the service.
Public method | GetActiveServerIds(Document) | Returns Ids of the servers currently applicable to the given document for the service.
Public method | SetActiveServers(IList<(Of <<'(Guid>)>>)) | Changes the active servers and/or their order.
Public method | SetActiveServers(IList<(Of <<'(Guid>)>>), Document) | Changes the active servers and/or their order for the given document.

See Also

MultiServerService Class
Autodesk.Revit.DB.ExternalService Namespace

GetActiveServerIds Method

[image] [image]