Revit 2021.1 API
NonContinuousRailInfo Methods
NonContinuousRailInfo Class See Also Send Feedback

The NonContinuousRailInfo type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | IsValidNonContinuousRailHeight | Checks whether the input height is valid for a non-continuous rail in its associated railing type.
Public method | IsValidNonContinuousRailMaterial | Checks whether an ElementId is a valid material Id of a non-continuous rail.
Public method | IsValidNonContinuousRailName | Checks whether the input name is valid for a non-continuous rail in its associated railing type.
Public method | IsValidNonContinuousRailProfile | Checks whether the input id represents a profile which can be used as the profile of this non-continuous rail.

See Also

NonContinuousRailInfo Class
Autodesk.Revit.DB.Architecture Namespace

Dispose Method

[image]