Revit 2021.1 API
SpatialFieldManager..::..AddSpatialFieldPrimitive Method
SpatialFieldManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddSpatialFieldPrimitive()()()() | Creates empty analysis results primitive not associated with any geometry element
Public method | AddSpatialFieldPrimitive(Reference) | Creates an empty analysis results primitive associated with a reference.
Public method | AddSpatialFieldPrimitive(Curve, Transform) | Creates empty analysis results primitive associated with a curve and a transform.
Public method | AddSpatialFieldPrimitive(Face, Transform) | Creates empty analysis results primitive associated with a face and a transform.
Public method | AddSpatialFieldPrimitive(Reference, SpatialFieldPrimitiveHideMode) | Creates an empty analysis results primitive associated with a reference, with the option to control how the reference element is hidden.

See Also

SpatialFieldManager Class
SpatialFieldManager Members
Autodesk.Revit.DB.Analysis Namespace

AddSpatialFieldPrimitive Method

[image]