Revit 2021.1 API
SpatialElement Members
SpatialElement Class Methods Properties See Also Send Feedback

The SpatialElement type exposes the following members.

Methods

 | Name | Description
Public method | GetBoundarySegments | Returns the boundary segments.

Properties

 | Name | Description
Public property | Area | The area.
Public property | Level | Gets the level of the room.
Public property | Location | The location of the element. (Overrides Element..::..Location.)
Public property | Name | A human readable name for the Element. (Overrides Element..::..Name.)
Public property | Number | The number.
Public property | Perimeter | The perimeter.

See Also

SpatialElement Class

SpatialElement Methods

[image] [image]