Revit 2021.1 API
RoutingConditions Members
RoutingConditions Class Constructors Methods Properties See Also Send Feedback

The RoutingConditions type exposes the following members.

Constructors

 | Name | Description
Public method | RoutingConditions | Constructs a new instance of a RoutingConditions object with an indicated error level for conditions that do not meet any routing preference rule.

Methods

 | Name | Description
Public method | AppendCondition | Appends a routing condition to the end of existing routing conditions. Note that the first item (indexed at 0) is the condition for the primary connector.
Public method | Clear | Clear all existing conditions
Public method | Dispose | Releases all resources used by the RoutingConditions
Public method | GetConditionAt | Gets the routing condition at the specified index position.
Public method | GetNumberOfConditions | Gets the number of included routing conditions.

Properties

 | Name | Description
Public property | ErrorLevel | The error level that the routing preference manager should post errors if the routing conditions do not meet any routing preference rule, could be None, Warning, or Error
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | PreferredJunctionType | The junction type (Tee or Tap) to select if defined fittings of both junction types meet all routing conditions.

See Also

RoutingConditions Class

RoutingConditions Constructor

[image]