Revit 2021.1 API
LightGroupManager Members
LightGroupManager Class Methods Properties See Also Send Feedback

The LightGroupManager type exposes the following members.

Methods

 | Name | Description
Public method | CreateGroup | Create a new LightGroup object with the given name
Public method | DeleteGroup | Remove the given LightGroup object from the set of LightGroup objects
Public method | Dispose | Releases all resources used by the LightGroupManager
Public method | GetGroups | Get the set of contained LightGroup objects The set of LightGroup objects
Public method | GetLightDimmer | Gets the dimmer value for the given light for rendering the given view
 | GetLightGroupManager | Creates a light group manager object from the given document
Public method | IsLightGroupOn | Returns true if the given light group is on
Public method | IsLightOn | Returns true if the given light is on for rendering the given view
Public method | SetLightDimmer | Sets the dimmer value for the given light for rendering the given view
Public method | SetLightGroupOn | Turns the given light group on or off for rendering the given view depending on the bool argument
Public method | SetLightOn | Turns the given light on or off for rendering the given view depending on the bool argument

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

LightGroupManager Class
Autodesk.Revit.DB.Lighting Namespace

LightGroupManager Methods

[image] [image]