Revit 2021.1 API
AnalysisDisplayDeformedShapeSettings Properties
AnalysisDisplayDeformedShapeSettings Class See Also Send Feedback

The AnalysisDisplayDeformedShapeSettings type exposes the following members.

Properties

 | Name | Description
Public property | GridColor | Color of grid lines.
Public property | GridLineWeight | Line weight of grid lines.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Rounding | Increment to which numeric values of analysis results are rounded in deformed shape.
Public property | ShowContourLines | If true, show contour lines in the analysis display.
Public property | ShowGridLines | If true, show grid lines in the analysis display.
Public property | TextLabelType | Type of deformed shape text visualization.
Public property | TextTypeId | Element id of text associated with the settings.
Public property | Transparency | Transparency percentage of deformed shape color fill on surfaces

See Also

AnalysisDisplayDeformedShapeSettings Class
Autodesk.Revit.DB.Analysis Namespace

GridColor Property

[image]