Revit 2021.1 API
PhaseArray Members
PhaseArray Class Constructors Methods Properties See Also Send Feedback

The PhaseArray type exposes the following members.

Constructors

 | Name | Description
Public method | PhaseArray | Initializes a new instance of the PhaseArray class

Methods

 | Name | Description
Public method | Append | Add the phase to the end of the array.
Public method | Clear | Removes every phase from the array, rendering it empty.
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | Insert | Insert the specified phase into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | Item | Gets or sets a phase at a specified index within the array.
Public property | Size | Returns the number of phases that are in the array.

See Also

PhaseArray Class

PhaseArray Constructor

[image]