Revit 2021.1 API
IFCFileModelOptions Members
IFCFileModelOptions Class Constructors Methods Properties See Also Send Feedback

The IFCFileModelOptions type exposes the following members.

Constructors

 | Name | Description
Public method | IFCFileModelOptions | Creates a default IFCFileModelOptions. The default schema file is empty and cache size is 8192.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the IFCFileModelOptions

Properties

 | Name | Description
Public property | CacheSize | The cache size of the file.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | SchemaFile | The full name of an IFC schema file.
Public property | SchemaName | The name of the schema.
Public property | UserControlledInverses | Indicates if the inverses are controlled by Revit or users. True by users, false by Revit.

See Also

IFCFileModelOptions Class
Autodesk.Revit.DB.IFC Namespace

IFCFileModelOptions Constructor

[image]