Revit 2021.1 API
EffectInstance Methods
EffectInstance Class See Also Send Feedback

The EffectInstance type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | IsValid | Tests whether the effect instance is valid for rendering.
Public method | MatchesFormat | Tests whether the effect instance is appropriate for the given vertex format.
Public method | SetAmbientColor | Sets the ambient color parameter of the effect instance.
Public method | SetColor | Sets the color parameter of the effect instance.
Public method | SetDiffuseColor | Sets the diffuse color parameter of the effect instance.
Public method | SetEmissiveColor | Sets the emissive color parameter of the effect instance.
Public method | SetGlossiness | Sets the glossiness parameter of the effect instance.
Public method | SetSpecularColor | Sets the specular color parameter of the effect instance.
Public method | SetTransparency | Sets the transparency parameter of the effect instance.

See Also

EffectInstance Class
Autodesk.Revit.DB.DirectContext3D Namespace

Dispose Method

[image]