Revit 2021.1 API
XYZ Methods
XYZ Class See Also Send Feedback

The XYZ type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified vector to this vector and returns the result.
Public method | AngleOnPlaneTo | Returns the angle between this vector and the specified vector projected to the specified plane.
Public method | AngleTo | Returns the angle between this vector and the specified vector.
Public method | CrossProduct | The cross product of this vector and the specified vector.
Public method | DistanceTo | Returns the distance from this point to the specified point.
Public method | Divide | Divides this vector by the specified value and returns the result.
Public method | DotProduct | The dot product of this vector and the specified vector.
Public method | GetLength | Gets the length of this vector.
Public method | IsAlmostEqualTo(XYZ) | Determines whether this vector and the specified vector are the same within the tolerance (1.0e-09).
Public method | IsAlmostEqualTo(XYZ, Double) | Determines whether 2 vectors are the same within the given tolerance.
Public method | IsUnitLength | The boolean value that indicates whether this vector is of unit length.
 | IsWithinLengthLimits | Validates that the input point is within Revit design limits.
Public method | IsZeroLength | The boolean value that indicates whether this vector is a zero vector.
Public method | Multiply | Multiplies this vector by the specified value and returns the result.
Public method | Negate | Negates this vector.
Public method | Normalize | Returns a new XYZ whose coordinates are the normalized values from this vector.
Public method | Subtract | Subtracts the specified vector from this vector and returns the result.
Public method | ToString | Gets formatted string showing (X, Y, Z) with values formatted to 9 decimal places. (Overrides Object..::..ToString()()()().)
Public method | TripleProduct | The triple product of this vector and the two specified vectors.

See Also

XYZ Class

AngleOnPlaneTo Method

[image]