Revit 2021.1 API
FamilyType Members
FamilyType Class Methods Properties See Also Send Feedback

The FamilyType type exposes the following members.

Methods

 | Name | Description
Public method | AsDouble | Provides access to the double precision number of the given family parameter.
Public method | AsElementId | Provides access to the Autodesk::Revit::DB::ElementId^ stored in the given family parameter.
Public method | AsInteger | Provides access to the integer number of the given family parameter.
Public method | AsString | Provides access to the string contents of the given family parameter.
Public method | AsValueString | Provides access to value as a string with unit in the given family parameter.
Public method | HasValue | Indicates if this family parameter has an assigned value or not.

Properties

 | Name | Description
Public property | Name | The name of the family type.

See Also

FamilyType Class

FamilyType Methods

[image] [image]