Revit 2021.1 API
DirectContext3DHandleSettings Members
DirectContext3DHandleSettings Class Constructors Methods Properties See Also Send Feedback

The DirectContext3DHandleSettings type exposes the following members.

Constructors

 | Name | Description
Public method | DirectContext3DHandleSettings()()()() | Constructs an instance of settings with default values.
Public method | DirectContext3DHandleSettings(DirectContext3DHandleSettings) | Constructs a copy of source object.
Public method | DirectContext3DHandleSettings(Boolean, Int32) | Constructs an instance of settings with provided values.

Methods

 | Name | Description
Public method | Assign | Assigns values of the source settings to this object.
Public method | Dispose | Releases all resources used by the DirectContext3DHandleSettings
Public method | GetTransparency | Gets the transparency value of the handle and the associated DirectContext3D graphics.
Public method | IsEqual | Check if the contents of two instances of settings are equal.
Public method | SetTransparency | Sets the transparency value of the handle and the associated DirectContext3D graphics.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Visibility | Visibility of the handle and the associated DirectContext3D graphics. A value of true means that the graphics are visible.

See Also

DirectContext3DHandleSettings Class
Autodesk.Revit.DB.DirectContext3D Namespace

DirectContext3DHandleSettings Constructor

[image] [image]