Revit 2013 API
CurveElementFilter Constructor (CurveElementType, Boolean)
CurveElementFilter Class See Also
Constructs a new instance of a filter to match specific types of curve elements, with the option to match all curves which are not of the given curve type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public CurveElementFilter(
    CurveElementType curveElementType,
    bool inverted
)
Visual Basic
Public Sub New ( _
    curveElementType As CurveElementType, _
    inverted As Boolean _
)
Visual C++
public:
CurveElementFilter(
    CurveElementType curveElementType,
    bool inverted
)

Parameters

curveElementType
Type: Autodesk.Revit.DB..::..CurveElementType
The curve element type to match.
inverted
Type: System..::..Boolean
True if the filter should match all curves which are not of the given curve type.

See Also

CurveElementFilter Class
CurveElementFilter Overload