Revit 2013 API
PreviewControl Methods
PreviewControl Class See Also

The PreviewControl type exposes the following members.

Methods

 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView()()()() | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | Dispose | This method is called if the user explicitly disposes of the object (by calling the Dispose method in other managed languages, or the destructor in C++).
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property; (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)

See Also

PreviewControl Class
Autodesk.Revit.UI Namespace