Revit 2013 API
EdgeArrayArray Class
Members Example See Also
An array of edge arrays.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class EdgeArrayArray : APIObject,
    IEnumerable
Visual Basic
Public Class EdgeArrayArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class EdgeArrayArray : public APIObject,
    IEnumerable

Examples

CopyC#
public void GetEdgeArrayArray(Autodesk.Revit.ApplicationServices.Application app, Autodesk.Revit.DB.Element element)
{
    // Get geometry element of the selected element
    Options geoOptions = app.Create.NewGeometryOptions();
    Autodesk.Revit.DB.GeometryElement geoElement = element.get_Geometry(geoOptions);
    // Get geometry object
    foreach (GeometryObject o in geoElement.Objects)
    {
        Solid solid = o as Solid;
        if (null != solid)
        {
            foreach (Face face in solid.Faces)
            {
                if (face != null)
                {
                    EdgeArrayArray edgeArrays = face.EdgeLoops;
                    foreach (EdgeArray edges in edgeArrays)
                    {
                        foreach (Edge edge in edges)
                        {
                            // Get one test point
                            XYZ testPoint = edge.Evaluate(0.5);
                            string edgeInfo = string.Format("Point on edge: ({0},{1},{2})", testPoint.X, testPoint.Y, testPoint.Z);
                            TaskDialog.Show("Revit",edgeInfo);
                        }
                    }
                }
            }
        }
    }
}
CopyVB.NET
Public Sub GetEdgeArrayArray(ByVal app As Autodesk.Revit.ApplicationServices.Application, ByVal element As Autodesk.Revit.DB.Element)
    ' Get geometry element of the selected element
    Dim geoOptions As Autodesk.Revit.DB.Options = app.Create.NewGeometryOptions()
    Dim geoElement As Autodesk.Revit.DB.GeometryElement = element.Geometry(geoOptions)
    ' Get geometry object
    For Each o As GeometryObject In geoElement.Objects
        Dim solid As Solid = TryCast(o, Solid)
        If solid IsNot Nothing Then
            For Each face As Autodesk.Revit.DB.Face In solid.Faces
                If face IsNot Nothing Then
                    Dim edgeArrays As EdgeArrayArray = face.EdgeLoops
                    For Each edges As EdgeArray In edgeArrays
                        For Each edge As Autodesk.Revit.DB.Edge In edges
                            ' Get one test point
                            Dim testPoint As Autodesk.Revit.DB.XYZ = edge.Evaluate(0.5)
                            Dim edgeInfo As String = String.Format("Point on edge: ({0},{1},{2})", testPoint.X, testPoint.Y, testPoint.Z)
                            TaskDialog.Show("Revit", edgeInfo)
                        Next
                    Next
                End If
            Next
        End If
    Next
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..EdgeArrayArray

See Also

EdgeArrayArray Members