Revit 2013 API
AnalysisDisplayMarkersAndTextSettings Members
AnalysisDisplayMarkersAndTextSettings Class Constructors Methods Properties See Also

The AnalysisDisplayMarkersAndTextSettings type exposes the following members.

Constructors

 | Name | Description
Public method | AnalysisDisplayMarkersAndTextSettings()()()() | Constructs a default instance of markers and text settings.
Public method | AnalysisDisplayMarkersAndTextSettings(AnalysisDisplayMarkersAndTextSettings) | Constructs a copy of markers and text settings object.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the AnalysisDisplayMarkersAndTextSettings
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual | Compares two colored surface settings objects.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | MarkerSize | Size of marker.
Public property | MarkerType | Type of marker.
Public property | Rounding | Increment to which numeric values of analysis results are rounded in markers.
Public property | ShowText | If true, show text in the analysis display.
Public property | TextLabelType | Type of diagram text label visualization.
Public property | TextTypeId | Element id of text associated with the settings.

See Also

AnalysisDisplayMarkersAndTextSettings Class
Autodesk.Revit.DB.Analysis Namespace