Revit 2013 API
IFCProductWrapper..::..Create Method (ExporterIFC, Boolean)
IFCProductWrapper Class See Also
Establishes a new baseline product manager for elements and objects.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static IFCProductWrapper Create(
    ExporterIFC ExporterIFC,
    bool allowRelateToLevel
)
Visual Basic
Public Shared Function Create ( _
    ExporterIFC As ExporterIFC, _
    allowRelateToLevel As Boolean _
) As IFCProductWrapper
Visual C++
public:
static IFCProductWrapper^ Create(
    ExporterIFC^ ExporterIFC,
    bool allowRelateToLevel
)

Parameters

ExporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
allowRelateToLevel
Type: System..::..Boolean
True to allow associated elements and objects to relate to a level, false to never allow such a relationship.

Return Value

The new baseline product manager.

Remarks

Elements and objects associated to this product manager will be associated to a top-level IfcProduct based on the world coordinate system of the output file.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCProductWrapper Class
Create Overload
Autodesk.Revit.DB.IFC Namespace