Revit 2013 API
IFCFile..::..CreateStyle Method (ExporterIFC, IFCAnyHandle)
IFCFile Class See Also
Creates and populates an IfcStyledItem for an IfcRepresentationItem with a IfcSurfaceStyle, IfcCurveStyle, and/or an IfcFillStyle, and assigns them to the file.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IFCAnyHandle CreateStyle(
    ExporterIFC exporterIFC,
    IFCAnyHandle repItem
)
Visual Basic
Public Function CreateStyle ( _
    exporterIFC As ExporterIFC, _
    repItem As IFCAnyHandle _
) As IFCAnyHandle
Visual C++
public:
IFCAnyHandle^ CreateStyle(
    ExporterIFC^ exporterIFC,
    IFCAnyHandle^ repItem
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
repItem
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The representation item.

Return Value

The handle.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | A transaction is required for this operation.

See Also

IFCFile Class
CreateStyle Overload
Autodesk.Revit.DB.IFC Namespace