Revit 2013 API
ParameterFilterElement..::..SetRules Method
ParameterFilterElement Class See Also
Sets the rules, all of which must be satisfied for a given element to pass this filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void SetRules(
    IList<FilterRule> rules
)
Visual Basic
Public Sub SetRules ( _
    rules As IList(Of FilterRule) _
)
Visual C++
public:
void SetRules(
    IList<FilterRule^>^ rules
)

Parameters

rules
Type: System.Collections.Generic..::..IList<(Of <(<'FilterRule>)>)>

Remarks

The rules are applied in the order given. If an element fails to pass a certain rule, no further testing is done.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | One of the given rules refers to a parameter that does not apply to this filter's categories. -or- One of the rules in the given array is NULL
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterElement Class