Revit 2013 API
LabelUtils..::..GetLabelFor Method (BuiltInParameter)
LabelUtils Class See Also
Gets user-visible name for BuiltInParameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static string GetLabelFor(
    BuiltInParameter builtInParam
)
Visual Basic
Public Shared Function GetLabelFor ( _
    builtInParam As BuiltInParameter _
) As String
Visual C++
public:
static String^ GetLabelFor(
    BuiltInParameter builtInParam
)

Parameters

builtInParam
Type: Autodesk.Revit.DB..::..BuiltInParameter
The BuiltInParameter to get the user-visible name.

Remarks

The name is obtained in the current Revit language.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the BuiltInParameter cannot be found.

See Also

LabelUtils Class
GetLabelFor Overload