Revit 2013 API
FailureDefinitionAccessor..::..GetResolutionCaption Method
FailureDefinitionAccessor Class See Also
Retrieves the caption for a specific resolution type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public string GetResolutionCaption(
    FailureResolutionType type
)
Visual Basic
Public Function GetResolutionCaption ( _
    type As FailureResolutionType _
) As String
Visual C++
public:
String^ GetResolutionCaption(
    FailureResolutionType type
)

Parameters

type
Type: Autodesk.Revit.DB..::..FailureResolutionType
The resolution type.

Return Value

The caption of the resolution.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Resolution of the type is not applicable to the failure.
Autodesk.Revit.Exceptions..::..InvalidOperationException | The FailureDefinitionAccessor has not been properly initialized. -or- FailureDefinition does not have any resolutions.

See Also

FailureDefinitionAccessor Class