Revit 2013 API
SolidOrShellTessellationControls..::..MinExternalAngleBetweenTriangles Property
SolidOrShellTessellationControls Class See Also
A positive real number specifying the minimum allowed value for the external angle between two adjacent triangles, in radians.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double MinExternalAngleBetweenTriangles { get; set; }
Visual Basic
Public Property MinExternalAngleBetweenTriangles As Double
    Get
    Set
Visual C++
public:
property double MinExternalAngleBetweenTriangles {
    double get ();
    void set (double value);
}

Remarks

A small value yields more smoothly curved triangulated surfaces, usually at the expense of an increase in the number of triangles. Note that this setting has no effect for planar surfaces. This constraint may be approximately enforced.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for minExternalAngleBetweenTriangles must be greater than 0 and no more than 30000 feet.

See Also

SolidOrShellTessellationControls Class