Revit 2013 API
PhaseFilter..::..SetPhaseStatusPresentation Method
PhaseFilter Class See Also
Sets the phase status presentation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetPhaseStatusPresentation(
    ElementOnPhaseStatus status,
    PhaseStatusPresentation presentation
)
Visual Basic
Public Sub SetPhaseStatusPresentation ( _
    status As ElementOnPhaseStatus, _
    presentation As PhaseStatusPresentation _
)
Visual C++
public:
void SetPhaseStatusPresentation(
    ElementOnPhaseStatus status,
    PhaseStatusPresentation presentation
)

Parameters

status
Type: Autodesk.Revit.DB..::..ElementOnPhaseStatus
The element phase status.
presentation
Type: Autodesk.Revit.DB..::..PhaseStatusPresentation
The phase status presentation.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | status is invalid for presentation query.

See Also

PhaseFilter Class