Revit 2013 API
SunAndShadowSettings Members
SunAndShadowSettings Class Methods Properties See Also

The SunAndShadowSettings type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
 | CalculateTimeZone | Use Revit's utilities to calculate the time zone for a given longitude and latitude.
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FitToModel | Adjust SunAndShadowSettings to fit around the current model geometry.
 | GetActiveSunAndShadowSettings | Returns the current SunAndShadowSettings element assigned to the active view for the supplied document.
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetFrameAltitude | Identifies the altitude of the sun (angle in radians) for a specific frame.
Public method | GetFrameAzimuth | Identifies the azimuth of the sun (angle in radians) for a specific frame.
Public method | GetFrameTime | Identifies the date and time of the SunAndShadowSettings element for a given frame.
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMatchingPreset | Finds the name of the 'per-document' SunAndShadowSettings that matches the properties of this per-view element.
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetSunrise | Identifies the sunrise time for the SunAndShadowSettings element at its current location and indicated date.
Public method | GetSunset | Identifies the sunset time for the SunAndShadowSettings element at its current location and indicated date.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsAfterStartDateAndTime | Checks whether the end date and time is valid.
Public method | IsBeforeEndDateAndTime | Checks whether the start date and time is valid.
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsFrameValid | Checks whether the frame is valid for the supplied SunAndShadowSettings.
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsLevelValid | Checks whether the element represents a valid level.
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsTimeIntervalValid | Checks whether the time interval is valid for the SunAndShadowType.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ActiveFrame | Identifies the active animation frame for a single-day or multi-day study, starting at 1.0 for the first frame and incrementing in intervals of 1.0.
Public property | ActiveFrameTime | Identifies the date and time of the SunAndShadowSettings element for the active frame.
Public property | Altitude | Altitude setting (angle in radians). This is only relevant when dealing with a SunAndShadowSettings element that uses lighting mode.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | Azimuth | Azimuth setting (angle in radians). This is only relevant when dealing with a SunAndShadowSettings element that uses lighting mode.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | EndDateAndTime | Identifies the end date and time.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroundPlaneHeight | Identifies the ground plane height.
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Latitude | Identifies the current latitude used by the SunAndShadowSettings element.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LevelId | Identifies the element id of the Ground Plane level for the SunAndShadowSettings element.
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Longitude | Identifies the current longitude used by the SunAndShadowSettings element.
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | NumberOfFrames | Identifies the total number of animation frames for a single-day or multi-day study.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ProjectLocationId | Identifies the ProjectLocation element used by the SunAndShadowSettings element.
Public property | ProjectLocationName | Identifies the name of the project location used by the SunAndShadowSettings element.
Public property | RelativeToView | Identifies whether the SunAndShadowSettings element is relative to the view direction. This is only relevant for lighting mode.
Public property | SharesSettings | Identifies whether settings are shared globally.
Public property | StartDateAndTime | Identifies the start or current date and time.
Public property | SunAndShadowType | Identifies the type of the SunAndShadowSettings element.
Public property | SunriseToSunset | Identifies whether the current single day sun study is set to run from sunrise to sunset.
Public property | TimeInterval | Identifies the time interval between animation frames.
Public property | TimeZone | Identifies the time zone.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UsesDST | Identifies whether the SunAndShadowSettings element is using daylight savings time.
Public property | UsesGroundPlane | Identifies whether the SunAndShadowSettings element uses a ground plane.
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Visible | Visibility in current view for a per-view SunAndShadowSettings element.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

SunAndShadowSettings Class