Revit 2013 API
Transform..::..OfVector Method
Transform Class See Also
Applies the transform to the vector

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ OfVector(
    XYZ vec
)
Visual Basic
Public Function OfVector ( _
    vec As XYZ _
) As XYZ
Visual C++
public:
XYZ^ OfVector(
    XYZ^ vec
)

Parameters

vec
Type: Autodesk.Revit.DB..::..XYZ
The vector to be transformed

Return Value

The new vector after transform

Remarks

Transformation of a vector is not affected by the translational part of the transformation.

See Also

Transform Class