Revit 2013 API
DocumentEntryPoint Members
DocumentEntryPoint Class Constructors Methods Properties See Also

The DocumentEntryPoint type exposes the following members.

Constructors

 | Name | Description
Public method | DocumentEntryPoint | Initializes a new instance of the DocumentEntryPoint class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FinishInitializationEO | For Revit Macros internal use only.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOpenUIViews |
 | GetRevitUIFamilyLoadOptions |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | For Revit Macros internal use only.
Public method | OnShutdownEO | For Revit Macros internal use only.
Public method | PromptForFamilyInstancePlacement |
Public method | RefreshActiveView |
Public method | SaveAndClose |
Public method | SaveAs |
Public method | ShowElements(Element) |
Public method | ShowElements(ElementId) |
Public method | ShowElements(ICollection<(Of <<'(ElementId>)>>)) |
Public method | ShowElements(ElementSet) |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ActiveView |
Public property | AddinFolder | The full path to the Revit Macros module.
Public property | Application |
Public property | Document |
Public property | Selection |

See Also

DocumentEntryPoint Class
Autodesk.Revit.UI.Macros Namespace