Revit 2013 API
ReinforcementSettings Methods
ReinforcementSettings Class See Also

The ReinforcementSettings type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | DocumentContainsNoAreaOrPathReinforcement | Checks whether the document is free of AreaReinforcement and PathReinforcement elements. Only in this case is it permissible to change the HostStructuralRebar property.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetReinforcementSettings | Obtains the ReinforcementSettings object for the specified project document.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReinforcementSettings Class
Autodesk.Revit.DB.Structure Namespace