Revit 2013 API
ExternalEvent Members
ExternalEvent Class Methods Properties See Also

The ExternalEvent type exposes the following members.

Methods

 | Name | Description
 | Create | Creates an instance of external event.
Public method | Dispose | Releases all resources used by the ExternalEvent
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Raise | Instructing Revit to raise (signal) the external event.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsPending | Checking whether an event has been raised but not yet executed.

See Also

ExternalEvent Class
Autodesk.Revit.UI Namespace