Revit 2013 API
BaseExportOptions Members
BaseExportOptions Class Methods Properties See Also

The BaseExportOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the BaseExportOptions
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetPredefinedSetupNames | Returns a list of names of predefined setups of export options.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Colors | Export color mode. Default value is ExportColorMode.IndexColors.
Public property | HatchPatternsFileName | Custom hatch patterns (pat) file name.
Public property | HideReferencePlane | Whether or not to hide reference planes. Default value is false.
Public property | HideScopeBox | Whether or not to hide the scope box. Default value is false.
Public property | HideUnreferenceViewTags | Whether or not to hide unreference view tags. Default value is false.
Public property | LayerMapping | Name of a layer settings standard or filename (with custom layer settings). Valid standards are: AIA, CP83, BS1192, and ISO13567. default value is "" (empty) which means if no value is set, if no value is set, Revit will use a default value according to the localization.
Public property | PropOverrides | How to export overridden object styles. Default value is PropOverrideMode.ByEntity.

See Also

BaseExportOptions Class