Revit 2013 API
AnalyticalModel..::..EnableAutoDetect Method
AnalyticalModel Class See Also
Enable or disable Analytical Auto-detect.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void EnableAutoDetect(
    AnalyticalDirection direction,
    bool enabled
)
Visual Basic
Public Sub EnableAutoDetect ( _
    direction As AnalyticalDirection, _
    enabled As Boolean _
)
Visual C++
public:
void EnableAutoDetect(
    AnalyticalDirection direction,
    bool enabled
)

Parameters

direction
Type: Autodesk.Revit.DB.Structure..::..AnalyticalDirection
Direction in which to enable Analytical Auto-detect
enabled
Type: System..::..Boolean
Turn Analytical Auto-detect on (true) or off (false)

Remarks

It is possible to enable Analytical Auto-detect for one direction and have it disabled for another direction.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | direction is invalid for Analytical Auto-detect.
Autodesk.Revit.Exceptions..::..InapplicableDataException | This AnalyticalModel cannot disable Auto-detect for direction

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace