Revit 2013 API
Plane Members
Plane Class Constructors Methods Properties See Also

The Plane type exposes the following members.

Constructors

 | Name | Description
Public method | Plane(XYZ, XYZ) | Constructor for geometry plane.
Public method | Plane(XYZ, XYZ, XYZ) | Constructor for geometry plane.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Normal | Get the Normal of the plane.
Public property | Origin | Get the Origin of the plane.
Public property | XVec | Get the XVec of the plane.
Public property | YVec | Get the YVec of the plane.

See Also

Plane Class