Revit 2013 API
ParameterFilterRuleFactory Members
ParameterFilterRuleFactory Class Methods See Also

The ParameterFilterRuleFactory type exposes the following members.

Methods

 | Name | Description
 | CreateBeginsWithRule | Creates a filter rule that determines whether strings from the document begin with a certain string value.
 | CreateContainsRule | Creates a filter rule that determines whether strings from the document contain a certain string value.
 | CreateEndsWithRule | Creates a filter rule that determines whether strings from the document end with a certain string value.
 | CreateEqualsRule(ElementId, ElementId) | Creates a filter rule that determines whether ElementId values from the document equal a certain value.
 | CreateEqualsRule(ElementId, Int32) | Creates a filter rule that determines whether integer values from the document equal a certain value.
 | CreateEqualsRule(ElementId, Double, Double) | Creates a filter rule that determines whether double-precision values from the document equal a certain value.
 | CreateEqualsRule(ElementId, String, Boolean) | Creates a filter rule that determines whether strings from the document equal a certain value.
 | CreateGreaterOrEqualRule(ElementId, ElementId) | Creates a filter rule that determines whether ElementId values from the document are greater than or equal to a certain value.
 | CreateGreaterOrEqualRule(ElementId, Int32) | Creates a filter rule that determines whether integer values from the document are greater than or equal to a certain value.
 | CreateGreaterOrEqualRule(ElementId, Double, Double) | Creates a filter rule that determines whether double-precision values from the document are greater than or equal to a certain value.
 | CreateGreaterOrEqualRule(ElementId, String, Boolean) | Creates a filter rule that determines whether strings from the document are greater than or equal to a certain value.
 | CreateGreaterRule(ElementId, ElementId) | Creates a filter rule that determines whether ElementId values from the document are greater than a certain value.
 | CreateGreaterRule(ElementId, Int32) | Creates a filter rule that determines whether integer values from the document are greater than a certain value.
 | CreateGreaterRule(ElementId, Double, Double) | Creates a filter rule that determines whether double-precision values from the document are greater than a certain value.
 | CreateGreaterRule(ElementId, String, Boolean) | Creates a filter rule that determines whether strings from the document are greater than a certain value.
 | CreateLessOrEqualRule(ElementId, ElementId) | Creates a filter rule that determines whether ElementId values from the document are less than or equal to a certain value.
 | CreateLessOrEqualRule(ElementId, Int32) | Creates a filter rule that determines whether integer values from the document are less than or equal to a certain value.
 | CreateLessOrEqualRule(ElementId, Double, Double) | Creates a filter rule that determines whether double-precision values from the document are less than or equal to a certain value.
 | CreateLessOrEqualRule(ElementId, String, Boolean) | Creates a filter rule that determines whether strings from the document are less than or equal to a certain value.
 | CreateLessRule(ElementId, ElementId) | Creates a filter rule that determines whether ElementId values from the document are less than a certain value.
 | CreateLessRule(ElementId, Int32) | Creates a filter rule that determines whether integer values from the document are less than a certain value.
 | CreateLessRule(ElementId, Double, Double) | Creates a filter rule that determines whether double-precision values from the document are less than a certain value.
 | CreateLessRule(ElementId, String, Boolean) | Creates a filter rule that determines whether strings from the document are less than a certain value.
 | CreateNotBeginsWithRule | Creates a filter rule that determines whether strings from the document do not begin with a certain string value.
 | CreateNotContainsRule | Creates a filter rule that determines whether strings from the document do not contain a certain string value.
 | CreateNotEndsWithRule | Creates a filter rule that determines whether strings from the document do not end with a certain string value.
 | CreateNotEqualsRule(ElementId, ElementId) | Creates a filter rule that determines whether ElementId values from the document do not equal a certain value.
 | CreateNotEqualsRule(ElementId, Int32) | Creates a filter rule that determines whether integer values from the document do not equal a certain value.
 | CreateNotEqualsRule(ElementId, Double, Double) | Creates a filter rule that determines whether double-precision values from the document do not equal a certain value.
 | CreateNotEqualsRule(ElementId, String, Boolean) | Creates a filter rule that determines whether strings from the document do not equal a certain value.
 | CreateSharedParameterApplicableRule | Creates a filter rule that tests elements for support of a shared parameter.
Public method | Dispose | Releases all resources used by the ParameterFilterRuleFactory
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ParameterFilterRuleFactory Class