Revit 2013 API
ScheduleFilter Constructor (ScheduleFieldId, ScheduleFilterType, ElementId)
ScheduleFilter Class See Also
Creates a new ScheduleFilter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ScheduleFilter(
    ScheduleFieldId fieldId,
    ScheduleFilterType filterType,
    ElementId value
)
Visual Basic
Public Sub New ( _
    fieldId As ScheduleFieldId, _
    filterType As ScheduleFilterType, _
    value As ElementId _
)
Visual C++
public:
ScheduleFilter(
    ScheduleFieldId^ fieldId,
    ScheduleFilterType filterType,
    ElementId^ value
)

Parameters

fieldId
Type: Autodesk.Revit.DB..::..ScheduleFieldId
The ID of the field used to filter the schedule.
filterType
Type: Autodesk.Revit.DB..::..ScheduleFilterType
The filter type.
value
Type: Autodesk.Revit.DB..::..ElementId
The filter value for a filter using an ElementId value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ScheduleFilter Class
ScheduleFilter Overload