Revit 2013 API
OptionalFunctionalityUtils Methods
OptionalFunctionalityUtils Class See Also

The OptionalFunctionalityUtils type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsDGNExportAvailable | Check whether the DGN Export functionality is available in the installed Revit.
 | IsDGNImportLinkAvailable | Check whether the DGN Import/Link functionality is available in the installed Revit.
 | IsDWFExportAvailable | Check whether the DWF/DWFx Export functionality is available in the installed Revit.
 | IsDWGExportAvailable | Check whether the DWG Export functionality is available in the installed Revit.
 | IsDWGImportLinkAvailable | Check whether the DWG Import/Link functionality is available in the installed Revit.
 | IsDXFExportAvailable | Check whether the DXF Export functionality is available in the installed Revit.
 | IsFBXExportAvailable | Check whether the FBX Export functionality is available in the installed Revit.
 | IsGraphicsAvailable | Check whether the graphics functionality is available to support display, print, and export functionality.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OptionalFunctionalityUtils Class