Revit 2013 API
BoundarySegment Members
BoundarySegment Class Methods Properties See Also

The BoundarySegment type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Curve | Get the curve that is formed by the element that defines the edge of this area.
Public property | Document | Provides the document in which the element that created this segment resides.
Public property | Element | Retrieve the element that is responsible for producing this boundary segment.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BoundarySegment Class
Autodesk.Revit.DB.Mechanical Namespace