Revit 2013 API
LinePattern Members
LinePattern Class Constructors Methods Properties See Also

The LinePattern type exposes the following members.

Constructors

 | Name | Description
Public method | LinePattern()()()() | Creates a simple line pattern.
Public method | LinePattern(String) | Creates a line pattern with given name.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the LinePattern
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSegments | Gets the sequence of segments that defines this line pattern.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetSegments | Sets the sequence of segments that defines this line pattern.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Name | Line pattern name.

See Also

LinePattern Class