Revit 2013 API
CylindricalFace Class
Members Example See Also
A cylinder face of a 3d solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class CylindricalFace : Face
Visual Basic
Public Class CylindricalFace _
    Inherits Face
Visual C++
public ref class CylindricalFace : public Face

Remarks

Cylinder faces are defined by cylinder surfaces bounded by edge loops. The surfaces provide natural UV parameterization to the faces. S(u, v) = Origin + cos(u)*Radius[0] + sin(u)*Radius[1] + v*Axis

Examples

CopyC#
private void GetCylindricalFaceInfo(Face face)
{
    CylindricalFace cylindricalFace = face as CylindricalFace;
    if (null != cylindricalFace)
    {
       XYZ axis = cylindricalFace.Axis;
       XYZ origin = cylindricalFace.Origin;
       XYZ radius = cylindricalFace.get_Radius(0);
    }
}
CopyVB.NET
Private Sub GetCylindricalFaceInfo(ByVal face As Autodesk.Revit.DB.Face)
    Dim cylindricalFace As CylindricalFace = TryCast(face, CylindricalFace)
    If cylindricalFace IsNot Nothing Then
        Dim axis As Autodesk.Revit.DB.XYZ = cylindricalFace.Axis
        Dim origin As Autodesk.Revit.DB.XYZ = cylindricalFace.Origin
        Dim radius As Autodesk.Revit.DB.XYZ = cylindricalFace.Radius(0)
    End If
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..GeometryObject
Autodesk.Revit.DB..::..Face
Autodesk.Revit.DB..::..CylindricalFace

See Also

CylindricalFace Members