Revit 2013 API
Rebar..::..IsUnobscuredInView Method
Rebar Class See Also
Checks if this rebar element is shown unobscured in a view.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsUnobscuredInView(
    View view
)
Visual Basic
Public Function IsUnobscuredInView ( _
    view As View _
) As Boolean
Visual C++
public:
bool IsUnobscuredInView(
    View^ view
)

Parameters

view
Type: Autodesk.Revit.DB..::..View
The view element

Return Value

True if rebar is shown unobscured, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InapplicableDataException | This rebar element doesn't have valid visibility data.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace