Revit 2013 API
PartMakerMethodToDivideVolumes Members
PartMakerMethodToDivideVolumes Class Methods Properties See Also

The PartMakerMethodToDivideVolumes type exposes the following members.

Methods

 | Name | Description
Public method | AddIntersectingReference | Adds intersecting reference with an offset.
Public method | AreElementsValidIntersectingReferences(ICollection<(Of <<'(ElementId>)>>)) | Identifies if provided members are valid.
 | AreElementsValidIntersectingReferences(Document, ICollection<(Of <<'(ElementId>)>>)) | Identifies if provided members are valid.
Public method | CanBeDivisionProfile(ElementId) | Checks whether a family defines a profile which can be used by this method.
 | CanBeDivisionProfile(ElementId, Document) | Checks whether a family defines a profile which can be used by this method.
Public method | Dispose | Releases all resources used by the PartMakerMethodToDivideVolumes
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOffsetForIntersectingReference | Gets offset for the intersecting reference.
Public method | GetPlaneOfSketch | Gets the plane of the sketch.
Public method | GetSketchCurves | Populates the array with copies of curves in the sketch.
Public method | GetSplitRefsOffsets | Returns offsets for plane-defining splitters.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsElementValidIntersectingReference(ElementId) | Identifies if the provided member is valid.
 | IsElementValidIntersectingReference(Document, ElementId) | Identifies if the provided member is valid.
 | IsValidSketchPlane | Identifies if provided sketch plane is valid.
Public method | RemoveIntersectingReference | Removed intersecting reference.
Public method | SetOffsetForIntersectingReference | Sets offset for the intersecting reference.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UsesReference | Identifies if the PartMaker uses the intersecting reference.

Properties

 | Name | Description
Public property | DivisionGap | The gap which is created between matching profiles of parts.
Public property | ProfileFlipAcross | True if the corresponding left/upper parts profile are mirrored with respect to the division line. False if the profile of left/upper parts are defined directly by the profile family.
Public property | ProfileFlipAlong | True if the corresponding left/upper parts profile are mirrored with respect to the center line of the hosts to be divided. False if the profile of left/upper parts are defined directly by the profile family.
Public property | ProfileMatch | Determines how two profiles match.
Public property | ProfileOffset | The offset which is applied to a family-defined profile in the direction away from the division line and toward left/upper part to obtain its profile.
Public property | ProfileType | The id of the profile family applied to boundaries between parts.

See Also

PartMakerMethodToDivideVolumes Class