Revit 2013 API
TransmissionData..::..GetDesiredReferenceData Method
TransmissionData Class See Also
Gets the ExternalFileReference representing path and load status information to be used the next time this TransmissionData's document is loaded.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ExternalFileReference GetDesiredReferenceData(
    ElementId elemId
)
Visual Basic
Public Function GetDesiredReferenceData ( _
    elemId As ElementId _
) As ExternalFileReference
Visual C++
public:
ExternalFileReference^ GetDesiredReferenceData(
    ElementId^ elemId
)

Parameters

elemId
Type: Autodesk.Revit.DB..::..ElementId
The ElementId of the Element which the external file reference is a component of.

Return Value

An ExternalFileReference containing the requested path and load status information for an external file

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | elemId does not correspond to an ExternalFileReference contained in this TransmissionData.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

TransmissionData Class