Revit 2013 API
FamilyInstance Properties
FamilyInstance Class See Also

The FamilyInstance type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanFlipFacing | Property to test whether the orientation of family instance facing can be flipped.
Public property | CanFlipHand | Property to test whether the orientation of family instance hand can be flipped.
Public property | CanFlipWorkPlane | Identifies if the instance can flip its work plane.
Public property | CanRotate | Property to test whether the family instance can be rotated by 180 degrees.
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | ExtensionUtility | Property to check whether the instance can be extended and return the interface for extension operation.
Public property | FacingFlipped | Property to test whether the orientation of family instance facing is flipped.
Public property | FacingOrientation | Property to get the orientation of family instance facing.
Public property | FromRoom | The "From Room" set for the door or window in the last phase of the project.
Public property | FromRoom[([( Phase])]) |
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HandFlipped | Property to test whether the orientation of family instance hand is flipped.
Public property | HandOrientation | Property to get the orientation of family instance hand.
Public property | Host | If the instance is contained within another element, this property returns the containing element. An instance that is face hosted will return the element containing the face.
Public property | HostFace | Property to get the reference to the host face of family instance.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Invisible | Property to test whether the family instance is invisible.
Public property | IsSlantedColumn | Indicates if the family instance is a slanted column.
Public property | IsWorkPlaneFlipped | Identifies if the instance's work plane is flipped.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an instance within project. (Overrides Element..::..Location.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MEPModel | Retrieves the MEP model for the family instance.
Public property | Mirrored | Property to test whether the family instance is mirrored. (only one axis is flipped)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Room | The room in which the instance is located (during the last phase of the project).
Public property | Room[([( Phase])]) |
Public property | Space | The space in which the instance is located (during the last phase of the project).
Public property | Space[([( Phase])]) |
Public property | StructuralMaterialId | Identifies the material that defines the instance's structural analysis properties.
Public property | StructuralMaterialType | This property returns the physical material from which the instance is made.
Public property | StructuralType | Provides the primary structural type of the instance, such as beam or column etc.
Public property | StructuralUsage | Provides the primary structural usage of the instance, such as brace, girder etc.
Public property | SubComponents | Obsolete. Property to get the sub components of current family instance.
Public property | SuperComponent | Property to get the super component of current family instance.
Public property | Symbol | Returns or changes the FamilySymbol object that represents the type of the instance.
Public property | ToRoom | The "To Room" set for the door or window in the last phase of the project.
Public property | ToRoom[([( Phase])]) |
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

FamilyInstance Class