Revit 2013 API
Ellipse Properties
Ellipse Class See Also

The Ellipse type exposes the following members.

Properties

 | Name | Description
Public property | ApproximateLength | The approximate length of the curve. (Inherited from Curve.)
Public property | Center | Returns the center of the ellipse.
Public property | EndParameter | The parameter of the start or the end point of the curve. (Inherited from Curve.)
Public property | EndPoint | The start or the end point of this curve. (Inherited from Curve.)
Public property | EndPointReference | Returns a stable reference to the start point or the end point of the curve. (Inherited from Curve.)
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle; (Inherited from GeometryObject.)
Public property | IsBound | Describes whether the parameter of the curve is restricted to a particular interval. (Inherited from Curve.)
Public property | IsCyclic | The boolean value that indicates whether this curve is cyclic. (Inherited from Curve.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Length | The exact length of the curve. (Inherited from Curve.)
Public property | Normal | Returns the normal to the plane in which the ellipse is defined.
Public property | Period | The period of this curve. (Inherited from Curve.)
Public property | RadiusX | Returns the X vector radius of the ellipse.
Public property | RadiusY | Returns the Y vector radius of the ellipse.
Public property | Reference | Returns a stable reference to the curve. (Inherited from Curve.)
Public property | Transformed | Applies the specified transformation to this curve and returns the result. (Inherited from Curve.)
Public property | Visibility | The visibility. (Inherited from GeometryObject.)
Public property | XDirection | The X direction.
Public property | YDirection | The Y direction.

See Also

Ellipse Class