Revit 2013 API
LinkElementId Members
LinkElementId Class Constructors Methods Operators Properties See Also

The LinkElementId type exposes the following members.

Constructors

 | Name | Description
Public method | LinkElementId(ElementId) | Creates a new LinkElementId representing an element in the host document.
Public method | LinkElementId(ElementId, ElementId) | Creates a new LinkElementId representing an element in a linked document.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Operators

Name | Description
Equality | Determines whether these two LinkElementIds are the same.
Inequality | Determines whether these two LinkElementIds are different.

Properties

 | Name | Description
Public property | HostElementId | The id of the element in the host, or invalidElementId if there is a link.
Public property | LinkedElementId | The id of the element in the link, or invalidElementId if no link.
Public property | LinkInstanceId | The id of the link, or invalidElementId if no link.

See Also

LinkElementId Class