Revit 2013 API
SharedParameterApplicableRule Members
SharedParameterApplicableRule Class Constructors Methods Properties See Also

The SharedParameterApplicableRule type exposes the following members.

Constructors

 | Name | Description
Public method | SharedParameterApplicableRule | Constructs an instance of SharedParameterApplicableRule.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterRule.)
Public method | ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ParameterName | The name of the parameter that an element must support to pass this rule.

See Also

SharedParameterApplicableRule Class