Revit 2013 API
PathReinforcement Properties
PathReinforcement Class See Also

The PathReinforcement type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BarDescription | Obsolete. Retrieves the BarDescription property of an Path Reinforcement element.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | Curves | Obsolete. Retrieves the array of curves forming the boundary of the Path Reinforcement.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | NumBarDescriptions | Retrieves the number of distinct bar shapes. This property is deprecated in Revit 2013. Use GetRebarInSystemIds instead.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PathReinforcementType | Retrieves the type of the Path Reinforcement.
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

PathReinforcement Class
Autodesk.Revit.DB.Structure Namespace