Revit 2013 API
AnalyticalModel..::..CanDisableAutoDetect Method
AnalyticalModel Class See Also
Indicates if Analytical Auto-detect can be disabled programmatically

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool CanDisableAutoDetect(
    AnalyticalDirection direction
)
Visual Basic
Public Function CanDisableAutoDetect ( _
    direction As AnalyticalDirection _
) As Boolean
Visual C++
public:
bool CanDisableAutoDetect(
    AnalyticalDirection direction
)

Parameters

direction
Type: Autodesk.Revit.DB.Structure..::..AnalyticalDirection
Direction in which to test whether Analytical Auto-detect can be disabled

Return Value

True if Analytical Auto-detect can be disabled, false otherwise

Remarks

Certain Elements can have Auto-detect enabled (e.g., a Structural Wall) but the disabling of Auto-detect is undefined. This is because Auto-detect is actually a setting in the Analytical Projection parameter, and changing this value from Auto-detect is not defined.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | direction is invalid for Analytical Auto-detect.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace