Revit 2013 API
AnalysisDisplayColoredSurfaceSettings Members
AnalysisDisplayColoredSurfaceSettings Class Constructors Methods Properties See Also

The AnalysisDisplayColoredSurfaceSettings type exposes the following members.

Constructors

 | Name | Description
Public method | AnalysisDisplayColoredSurfaceSettings()()()() | Constructs a default instance of colored surface settings.
Public method | AnalysisDisplayColoredSurfaceSettings(AnalysisDisplayColoredSurfaceSettings) | Constructs a copy of colored surface settings object.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the AnalysisDisplayColoredSurfaceSettings
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual | Compares two colored surface settings objects.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | GridColor | Color of grid lines.
Public property | GridLineWeight | Line weight of grid lines.
Public property | ShowContourLines | If true, show contour lines in the analysis display.
Public property | ShowGridLines | If true, show grid lines in the analysis display.

See Also

AnalysisDisplayColoredSurfaceSettings Class
Autodesk.Revit.DB.Analysis Namespace