Revit 2013 API
FailureDefinitionAccessor Members
FailureDefinitionAccessor Class Methods See Also

The FailureDefinitionAccessor type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the FailureDefinitionAccessor
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetApplicableResolutionTypes | Retrieves a list of resolution types applicable to the failure.
Public method | GetDefaultResolutionType | Retrieves the default resolution type for the failure.
Public method | GetDescriptionText | Retrieves the description text of the failure.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetId | Retrieves the unique identifier of the FailureDefinition.
Public method | GetResolutionCaption | Retrieves the caption for a specific resolution type.
Public method | GetSeverity | Retrieves severity of the failure.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasResolutions | Checks if the FailureDefinition has at least one resolution.
Public method | IsResolutionApplicable | Checks if the given resolution type is applicable to the failure.
Public method | SetDefaultResolutionType | Sets the default resolution type for the failure.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FailureDefinitionAccessor Class