Revit 2013 API
InstanceVoidCutUtils Members
InstanceVoidCutUtils Class Methods See Also

The InstanceVoidCutUtils type exposes the following members.

Methods

 | Name | Description
 | AddInstanceVoidCut | Add a cut to an element using the unattached voids inside a cutting instance.
 | CanBeCutWithVoid | Indicates if the element can be cut by an instance with unattached voids.
Public method | Dispose | Releases all resources used by the InstanceVoidCutUtils
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetCuttingVoidInstances | Return ids of the instances with unattached voids cutting the element.
 | GetElementsBeingCut | Return ids of the elements being cut by the instance
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | InstanceVoidCutExists | Check whether the instance is cutting the element
 | IsVoidInstanceCuttingElement | Indicates if the element is a family instance with unattached voids that can cut other elements.
 | RemoveInstanceVoidCut | Remove a cut applied to the element by a cutting instance with unattached voids.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InstanceVoidCutUtils Class