Revit 2013 API
FamilyElementVisibility Members
FamilyElementVisibility Class Constructors Methods Properties See Also

The FamilyElementVisibility type exposes the following members.

Constructors

 | Name | Description
Public method | FamilyElementVisibility | Initializes a new instance of the FamilyElementVisibility class

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsShownInCoarse | Indicates if the instance is display with Coarse detail level in the view of project document.
Public property | IsShownInFine | Indicates if the instance is display with Fine detail level in the view of project document.
Public property | IsShownInFrontBack | Indicates if the instance is display in Front/Back view of project document.
Public property | IsShownInLeftRight | Indicates if the instance is display in Left/Right view of project document.
Public property | IsShownInMedium | Indicates if the instance is display with Medium detail level in the view of project document.
Public property | IsShownInPlanRCPCut | Indicates if the instance is displayed when cut in Plan/RCP (if the category permits).
Public property | IsShownInTopBottom | Indicates if the instance is display in Plan/RCP view of project document.
Public property | IsShownOnlyWhenCut | Indicates if the instance is displayed only if it has been cut.
Public property | VisibilityType | Indicates if the instance is Model or View specific.

See Also

FamilyElementVisibility Class