Revit 2013 API
FieldBuilder Members
FieldBuilder Class Constructors Methods See Also

The FieldBuilder type exposes the following members.

Constructors

 | Name | Description
Public method | FieldBuilder(FieldBuilder) | Initializes a new instance of the FieldBuilder class
Public method | FieldBuilder(Field, SchemaBuilder) | Initializes a new instance of the FieldBuilder class

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the FieldBuilder
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | NeedsSubSchemaGUID | Checks whether the SubSchema GUID needs to be explicitly specified for this field type.
Public method | NeedsUnits | Checks whether the field type requires explicit unit conversions.
Public method | Ready | Checks whether the builder may be used.
Public method | SetDocumentation | Sets the documentation string for the Field.
Public method | SetSubSchemaGUID | Sets the GUID of the Schema of the Entities that are intended to be stored in this field.
Public method | SetUnitType | Sets the type of units for the field.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FieldBuilder Class
Autodesk.Revit.DB.ExtensibleStorage Namespace