Revit 2013 API
FunctionId Members
FunctionId Class Methods Properties See Also

The FunctionId type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Retrieves data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | File | The name of the file including the function throwing an exception.
Public property | Function | The name of the function throwing an exception.
Public property | Line | The line number of the function throwing an exception.

See Also

FunctionId Class
Autodesk.Revit.Exceptions Namespace