Revit 2013 API
RebarHookType..::..Create Method
RebarHookType Class See Also
Creates a new RebarHookType in a document.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static RebarHookType Create(
    Document doc,
    double angle,
    double multiplier
)
Visual Basic
Public Shared Function Create ( _
    doc As Document, _
    angle As Double, _
    multiplier As Double _
) As RebarHookType
Visual C++
public:
static RebarHookType^ Create(
    Document^ doc,
    double angle,
    double multiplier
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
angle
Type: System..::..Double
Determine the hook angle of new RebarHookType.
multiplier
Type: System..::..Double
Determine the straight line multiplier of new RebarHookType.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | angle must be greater than 0 and no more than pi. -or- multiplier must be greater than 0 and no more than 99.

See Also

RebarHookType Class
Autodesk.Revit.DB.Structure Namespace