Revit 2013 API
RebarShapeMultiplanarDefinition Members
RebarShapeMultiplanarDefinition Class Constructors Methods Properties See Also

The RebarShapeMultiplanarDefinition type exposes the following members.

Constructors

 | Name | Description
Public method | RebarShapeMultiplanarDefinition | Create a RebarShapeMultiplanarDefinition for use in creating a RebarShape.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the RebarShapeMultiplanarDefinition
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetPresenceOfSegments | Simultaneously set the presence of all 3D segments.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DepthParamId | Id of the parameter driving the multiplanar depth. The depth is measured center-to-center of the bar. A valid shape parameter must be assigned to DepthParamId before the MultiplanarDefinition can be used in RebarShape creation.
Public property | IsDuplicateShapePresent | Whether the shape definition includes an offset copy of the 2D shape.
Public property | IsEndConnectorPresent | Whether a perpendicular segment is constructed from the end of the 2D shape.
Public property | IsStartConnectorPresent | Whether a perpendicular segment is constructed from the start of the 2D shape.
Public property | OutOfPlaneBendDiameter | Bend diameter to be applied to the connector segments.

See Also

RebarShapeMultiplanarDefinition Class
Autodesk.Revit.DB.Structure Namespace