Revit 2013 API
CurveLoop..::..GetEnumerator Method
CurveLoop Class See Also
Returns an enumerator that iterates through the curve loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public virtual IEnumerator<Curve> GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator(Of Curve)
Visual C++
public:
virtual IEnumerator<Curve^>^ GetEnumerator()

Return Value

An IEnumerator(Curve) object that can be used to iterate through key-value pairs in the collection.

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

See Also

CurveLoop Class