Revit 2013 API
TaskDialog Members
TaskDialog Class Constructors Methods Properties See Also

The TaskDialog type exposes the following members.

Constructors

 | Name | Description
Public method | TaskDialog | Creates a task dialog with title.

Methods

 | Name | Description
Public method | AddCommandLink(TaskDialogCommandLinkId, String) | Adds a CommandLink associated to the given id, displaying the indicating main content.
Public method | AddCommandLink(TaskDialogCommandLinkId, String, String) | Adds a CommandLink associated to the given id, displaying the indicating main and supporting content.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Show()()()() | Shows the task dialog.
 | Show(String, String) | Shows a task dialog with title, main instruction and a Close button.
 | Show(String, String, TaskDialogCommonButtons) | Shows a task dialog with title, main instruction and common buttons.
 | Show(String, String, TaskDialogCommonButtons, TaskDialogResult) | Shows a task dialog with title, main instruction, common buttons and default buttons.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WasVerificationChecked | Gets the status of the verification checkbox.

Properties

 | Name | Description
Public property | AllowCancellation | Whether the task dialog can be cancelled if no cancel button is specified.
Public property | CommonButtons | The push buttons displayed in the task dialog.
Public property | DefaultButton | The default button for the dialog.
Public property | ExpandedContent | ExpandedContent is hidden by default and will display at the bottom of the task dialog when the "Show details" button is pressed.
Public property | FooterText | FooterText is used in the footer area of the task dialog.
Public property | Id | The Id of the task dialog.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | MainContent | MainContent is the smaller text that appears just below the main instructions.
Public property | MainIcon | The icon shown in the task dialog.
Public property | MainInstruction | The large primary text that appears at the top of a task dialog.
Public property | Title | Title of the task dialog.
Public property | TitleAutoPrefix | Whether the TaskDialog's title will automatically have the add-in name added as a prefix.
Public property | VerificationText | VerificationText is used to label the verification checkbox.

See Also

TaskDialog Class
Autodesk.Revit.UI Namespace