Revit 2013 API
EnergyAnalysisOpening Members
EnergyAnalysisOpening Class Methods Properties See Also

The EnergyAnalysisOpening type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the EnergyAnalysisOpening
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalSurface | Gets the associative analytical parent surface element.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPolyloop | Gets the planar polygon describing the opening geometry.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Corner | The lower-left coordinate for the analytical rectangular geometry viewed from outside.
Public property | Height | The height of the analytical rectangular geometry.
Public property | Id | The unique identifier for the opening.
Public property | Name | The unique name identifier for the opening.
Public property | OpeningType | The analytical opening type.
Public property | OriginatingElementDescription | The description for the originating Revit element.
Public property | OriginatingElementId | The element id for the originating Revit element.
Public property | Type | The gbXML opening type attribute.
Public property | Width | The width of the analytical rectangular geometry.

See Also

EnergyAnalysisOpening Class
Autodesk.Revit.DB.Analysis Namespace