Revit 2013 API
CylindricalHelix Properties
CylindricalHelix Class See Also

The CylindricalHelix type exposes the following members.

Properties

 | Name | Description
Public property | ApproximateLength | The approximate length of the curve. (Inherited from Curve.)
Public property | BasePoint | The base point of the axis of the cylindrical helix.
Public property | EndParameter | The parameter of the start or the end point of the curve. (Inherited from Curve.)
Public property | EndPoint | The start or the end point of this curve. (Inherited from Curve.)
Public property | EndPointReference | Returns a stable reference to the start point or the end point of the curve. (Inherited from Curve.)
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle; (Inherited from GeometryObject.)
Public property | Height | Height of the cylindrical helix.
Public property | IsBound | Describes whether the parameter of the curve is restricted to a particular interval. (Inherited from Curve.)
Public property | IsCyclic | The boolean value that indicates whether this curve is cyclic. (Inherited from Curve.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsRightHanded | True if the helix is right handed, false if the helix is left handed.
Public property | Length | The exact length of the curve. (Inherited from Curve.)
Public property | Period | The period of this curve. (Inherited from Curve.)
Public property | Pitch | The pitch of the cylindrical helix.
Public property | Radius | The radius of the cylindrical helix.
Public property | Reference | Returns a stable reference to the curve. (Inherited from Curve.)
Public property | Transformed | Applies the specified transformation to this curve and returns the result. (Inherited from Curve.)
Public property | Visibility | The visibility. (Inherited from GeometryObject.)
Public property | XVector | The X direction vector.
Public property | YVector | The Y direction vector.
Public property | ZVector | The Z direction vector, which is same as the axis direction vector.

See Also

CylindricalHelix Class