Revit 2013 API
FamilyThermalProperties Members
FamilyThermalProperties Class Constructors Methods Properties See Also

The FamilyThermalProperties type exposes the following members.

Constructors

 | Name | Description
Public method | FamilyThermalProperties | Initializes a new instance of the FamilyThermalProperties class

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the FamilyThermalProperties
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Find | Find the thermal properties by the 'id' property of a constructionType node in Constructions.xml.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AnalyticConstructionName | The construction gbXML name. This value corresponds to the 'Name' property of a constructionType node in Constructions.xml.
Public property | AnalyticConstructionTypeId | The construction gbXML type. This value corresponds to the 'id' property of a constructionType node in Constructions.xml.
Public property | HeatTransferCoefficient | The heat transfer coefficient value (U-Value). The unit is watts per meter-squared kelvin (W/(m^2*K)).
Public property | SolarHeatGainCoefficient | The solar heat gain coefficient.
Public property | ThermalResistance | The calculated thermal resistance value (R-Value). The unit is meter-squared kelvin per watt ((m^2*K)/Watt).
Public property | VisualLightTransmittance | The visual light transmittance.

See Also

FamilyThermalProperties Class