Revit 2013 API
SunAndShadowSettings Methods
SunAndShadowSettings Class See Also

The SunAndShadowSettings type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
 | CalculateTimeZone | Use Revit's utilities to calculate the time zone for a given longitude and latitude.
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FitToModel | Adjust SunAndShadowSettings to fit around the current model geometry.
 | GetActiveSunAndShadowSettings | Returns the current SunAndShadowSettings element assigned to the active view for the supplied document.
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetFrameAltitude | Identifies the altitude of the sun (angle in radians) for a specific frame.
Public method | GetFrameAzimuth | Identifies the azimuth of the sun (angle in radians) for a specific frame.
Public method | GetFrameTime | Identifies the date and time of the SunAndShadowSettings element for a given frame.
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMatchingPreset | Finds the name of the 'per-document' SunAndShadowSettings that matches the properties of this per-view element.
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetSunrise | Identifies the sunrise time for the SunAndShadowSettings element at its current location and indicated date.
Public method | GetSunset | Identifies the sunset time for the SunAndShadowSettings element at its current location and indicated date.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsAfterStartDateAndTime | Checks whether the end date and time is valid.
Public method | IsBeforeEndDateAndTime | Checks whether the start date and time is valid.
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsFrameValid | Checks whether the frame is valid for the supplied SunAndShadowSettings.
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsLevelValid | Checks whether the element represents a valid level.
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsTimeIntervalValid | Checks whether the time interval is valid for the SunAndShadowType.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SunAndShadowSettings Class