Revit 2013 API
Outline..::..ContainsOtherOutline Method
Outline Class See Also
Determine if this Outline contains another Outline to within tolerance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool ContainsOtherOutline(
    Outline otherOutline,
    double tolerance
)
Visual Basic
Public Function ContainsOtherOutline ( _
    otherOutline As Outline, _
    tolerance As Double _
) As Boolean
Visual C++
public:
bool ContainsOtherOutline(
    Outline^ otherOutline,
    double tolerance
)

Parameters

otherOutline
Type: Autodesk.Revit.DB..::..Outline
The outline to test for containment.
tolerance
Type: System..::..Double
The tolerance to use when determining whether the point is contained. Defaults to zero.

Return Value

True if this outline contains the given outline, or false otherwise.

Remarks

If the tolerance is positive, the other Outline may extend the tolerance distance outside of this Outline in each coordinate. If the tolerance is negative, the other Outline must lie at least the tolerance distance inside of this Outline in each coordinate to be a match.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

Outline Class