Revit 2013 API
LogicalOrFilter Members
LogicalOrFilter Class Constructors Methods Properties See Also

The LogicalOrFilter type exposes the following members.

Constructors

 | Name | Description
Public method | LogicalOrFilter(IList<(Of <<'(ElementFilter>)>>)) | Constructs a new instance of the logical filter with any number of input filters.
Public method | LogicalOrFilter(ElementFilter, ElementFilter) | Constructs a new instance of the logical filter with two input filters.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

LogicalOrFilter Class