Revit 2013 API
ExporterIFCUtils..::..TransformAndScaleVector Method
ExporterIFCUtils Class See Also
Converts a vector from global Revit coordinates to current IFC coordinates, including scale.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static XYZ TransformAndScaleVector(
    ExporterIFC exporterIFC,
    XYZ origVector
)
Visual Basic
Public Shared Function TransformAndScaleVector ( _
    exporterIFC As ExporterIFC, _
    origVector As XYZ _
) As XYZ
Visual C++
public:
static XYZ^ TransformAndScaleVector(
    ExporterIFC^ exporterIFC,
    XYZ^ origVector
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
origVector
Type: Autodesk.Revit.DB..::..XYZ
The original vector.

Return Value

The transformed and scaled point.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace