Revit 2013 API
Transform..::..Multiply Method
Transform Class See Also
Multiplies this transformation by the specified transformation and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Transform Multiply(
    Transform right
)
Visual Basic
Public Function Multiply ( _
    right As Transform _
) As Transform
Visual C++
public:
Transform^ Multiply(
    Transform^ right
)

Parameters

right
Type: Autodesk.Revit.DB..::..Transform
The specified transformation.

Return Value

The transformation equal to the composition of the two transformations.

Remarks

The combined transformation has the same effect as applying the right transformation first, and the left transformation, second. So, (T1(T2(p)) = (T1 * T2) (p).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the handle of the specified transformation is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Transform Class