Revit 2013 API
SiteLocation..::..TimeZone Property
SiteLocation Class See Also
Time-zone that contains the site

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double TimeZone { get; set; }
Visual Basic
Public Property TimeZone As Double
    Get
    Set
Visual C++
public:
property double TimeZone {
    double get ();
    void set (double value);
}

Remarks

A property that returns the time zone in which the site resides. The value is in hours, ranging from +12 hours to -12 hours with 0 being GMT.

Set this property directly if for your desired latitude and longitude, Revit's calculation does not match with the actual time zone for your location. Note that there are no restrictions preventing you from setting this to an incorrect value for the site location, and incorrect times for Solar Studies may result.

See Also

SiteLocation Class