Revit 2013 API
CompoundStructure..::..GetAdjacentRegions Method
CompoundStructure Class See Also
Gets the ids of region bound to a specified segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public IList<int> GetAdjacentRegions(
    int segmentId
)
Visual Basic
Public Function GetAdjacentRegions ( _
    segmentId As Integer _
) As IList(Of Integer)
Visual C++
public:
IList<int>^ GetAdjacentRegions(
    int segmentId
)

Parameters

segmentId
Type: System..::..Int32
The id of a segment in this CompoundStructure.

Return Value

The ids of the regions that are bounded by the specified segment.

Remarks

The boundaries of the regions of a vertically compound structure consist of vertical horizontal segments with unique ids. The segments which define the outer boundary of the structure are adjacent to one region, other segments will be adjacent to two regions.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The segment id is invalid.
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is valid only vertically compound structures.

See Also

CompoundStructure Class