Revit 2013 API
BarDescription Members
BarDescription Class Methods Properties See Also

The BarDescription type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the BarDescription
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHookTypeId | Gets the rebar hook type identifier of a Bar Description.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BarType | Obsolete. Retrieves the Rebar Bar Type property of a Bar Description.
Public property | BarTypeId | Retrieves the Rebar Bar Type Id property of a Bar Description.
Public property | Count | Retrieves the number of bars of this shape.
Public property | HooksInSameDirection | Retrieves the Rebar Hooks In Same Direction property of a Bar Description.
Public property | HookType | Retrieves the Rebar Hook Type property of a Bar Description.
Public property | Layer | Obsolete. Retrieves the layer index (0, 1, 2, or 3) for this Bar Description.
Public property | LayerDirection | Retrieves the layer index for this Bar Description when area or path reinforcement's host is wall.
Public property | LayerFace | Retrieves the layer index for this Bar Description when area or path reinforcement's host is floor.
Public property | Length | Retrieves the length of a Bar Description.

See Also

BarDescription Class
Autodesk.Revit.DB.Structure Namespace