Revit 2013 API
PanelScheduleData Members
PanelScheduleData Class Methods Properties See Also

The PanelScheduleData type exposes the following members.

Methods

 | Name | Description
Public method | AddLoadClassification | Add a Load Classification Id to the array of Load Classifications.
Public method | Dispose | (Inherited from TableData.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLoadClassifications | Gets an array of the load classifications associated with this panel schedule
Public method | GetNumberOfCircuitRows | Gets the number of rows in the circuit table
Public method | GetSectionData | Returns the section data array element at the specified index. (Inherited from TableData.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual | Checks if this element is equal in value to the other element. (Inherited from TableData.)
Public method | IsSymmetric | Check if this panel schedule is symmetric
Public method | RemoveLoadClassification | Remove a Load Classification Id from the array of Load Classifications
Public method | SetBorderAroundSchedule | Adds a border around the schedule
Public method | SetBorderAroundSections | Adds a border around the sections
Public method | SetLoadClassifications | Sets the Load Classifications associated with this panel schedule
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateCircuitTableForInstance | Redraw the circuit table for the given panel with the given parameter updates
Public method | UpdateCircuitTableForTemplate | Redraw the circuit table for a template with the given parameter updates
Public method | UpdateIsSectionHidden | Update if this section is hidden or not
Public method | UpdateLoadSummary | Update the load summary section
Public method | UpdateVerticalHeadersInSection | Sets if this header should have vertical text

Properties

 | Name | Description
Public property | BodyShowsVerticalHeaders | Shows text in the Load Summary section's headers vertically instead of horizontally
Public property | BorderAroundSchedule | Places a border (GraphicStyle element) around the entire schedule, visible only on the instance and sheet
Public property | BorderAroundSections | Places a border (GraphicStyle element) around each section, visible only on the instance and sheet
Public property | FreezeColumnsAndRows | set to true if the columns and rows should be unmovable by the slider grips; (Inherited from TableData.)
Public property | IsFooterSectionHidden | True if the user wishes to hide the footer section; setting this value must go through the appropriate update function
Public property | IsHeaderSectionHidden | True if the user wishes to hide the header section; setting this value must go through the appropriate update function
Public property | IsPanelSinglePhase | Identifies if the panel is single phase.
Public property | IsSummarySectionHidden | True if the user wishes to hide the summary section; setting this value must go through the appropriate update function
Public property | IsThirdPhaseHidden | True if the user wishes to hide the 3rd phase column of a single phase panel
Public property | NumberOfSections | Gets the number of items in section data array. (Inherited from TableData.)
Public property | NumberOfSlots | The number of slots in the panel schedule; setting this value must go through the appropriate update function
Public property | PanelConfiguration | The panel configuration of this panel schedule
Public property | PhaseLoadType | This property determines the layout of the phase load columns; setting this value must go through the updateCircuitTable function
Public property | PhasesAsCurrents | If true, the phase columns are currents (A), otherwise they are loads (VA); setting this value must go through the appropriate update function
Public property | ScheduleType | The panel schedule type of this panel schedule
Public property | ShowCircuitNumberOnOneRowForMultiphaseCircuits | Shows the circuit number broken up on each row of the multiphase circuit rows if true, all on the first row otherwise
Public property | ShowMultipleRowsForMultiphaseCircuits | shows extra rows below multiphase circuits to indicate how many slots they take up if true, all on a single row otherwise
Public property | ShowSlotFromDeviceInsteadOfTemplate | When true, the number of rows in an instance will be the number of poles on the associated device, not a set number
Public property | SummaryShowsGroups | Show groups of load classifications in the load summary section
Public property | SummaryShowsOnlyConnectedLoads | Show only the connected load classifications in the summary section
Public property | SummaryShowsVerticalHeaders | Shows text in the Load Summary section's headers vertically instead of horizontally
Public property | Width | Gets or sets the table width in feet; (Inherited from TableData.)
Public property | WidthInPixels | Gets the width of the panel schedule in pixels; (Inherited from TableData.)

See Also

PanelScheduleData Class
Autodesk.Revit.DB.Electrical Namespace