Revit 2013 API
SpatialElementGeometryCalculator Members
SpatialElementGeometryCalculator Class Constructors Methods See Also

The SpatialElementGeometryCalculator type exposes the following members.

Constructors

 | Name | Description
Public method | SpatialElementGeometryCalculator(Document) | Constructs a new calculator with default options for the geometry of spatial elements.
Public method | SpatialElementGeometryCalculator(Document, SpatialElementBoundaryOptions) | Constructs a new calculator for the geometry of spatial elements.

Methods

 | Name | Description
Public method | CalculateSpatialElementGeometry | Compute the spatial element geometry and returns the boundary face information.
 | CanCalculateGeometry | This indicates whether the input spatial element is a valid one.
Public method | Dispose | Releases all resources used by the SpatialElementGeometryCalculator
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOptions | The options that control the calculation.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsRoomOrSpace | This indicates whether the input spatial element is a room or a space.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SpatialElementGeometryCalculator Class