Revit 2013 API
DuctSizeSettings..::..Item Property
DuctSizeSettings Class See Also
Get the DuctSizes for this DuctShape.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public DuctSizes this[
    DuctShape ductShape
] { get; }
Visual Basic
Public ReadOnly Property Item ( _
    ductShape As DuctShape _
) As DuctSizes
    Get
Visual C++
public:
property DuctSizes^ Item[DuctShape ductShape] {
    DuctSizes^ get (DuctShape ductShape);
}

Parameters

ductShape
Type: Autodesk.Revit.DB.Mechanical..::..DuctShape
The duct shape.

Return Value

The DuctSizes for this DuctShape.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | There is no DuctSizes for this DuctShape.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

DuctSizeSettings Class
Autodesk.Revit.DB.Mechanical Namespace