Revit 2013 API
TransmissionData..::..SetDesiredReferenceData Method
TransmissionData Class See Also
Sets the ExternalFileReference information which Revit should use the next time it opens the document which this TransmissionData belongs to.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void SetDesiredReferenceData(
    ElementId elemId,
    ModelPath path,
    PathType pathType,
    bool shouldLoad
)
Visual Basic
Public Sub SetDesiredReferenceData ( _
    elemId As ElementId, _
    path As ModelPath, _
    pathType As PathType, _
    shouldLoad As Boolean _
)
Visual C++
public:
void SetDesiredReferenceData(
    ElementId^ elemId,
    ModelPath^ path,
    PathType pathType,
    bool shouldLoad
)

Parameters

elemId
Type: Autodesk.Revit.DB..::..ElementId
The id of the element associated with this reference.
path
Type: Autodesk.Revit.DB..::..ModelPath
A ModelPath indicating the location to load the external file reference from.
pathType
Type: Autodesk.Revit.DB..::..PathType
A PathType value indicating what type of path the ModelPath is.
shouldLoad
Type: System..::..Boolean
True if the external file should be loaded the next time Revit opens the document. False if it should be unloaded.

Remarks

There must already be a reference associated with the given id for this function to be valid. Create a reference using AddExternalFileReference.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | elemId does not correspond to an ExternalFileReference contained in this TransmissionData. -or- These inputs will not produce a valid ExternalFileReference.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

TransmissionData Class