Revit 2013 API
StairsEditScope Constructor
StairsEditScope Class See Also
Instantiates a StairsEditScope object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public StairsEditScope(
    Document document,
    string transactionName
)
Visual Basic
Public Sub New ( _
    document As Document, _
    transactionName As String _
)
Visual C++
public:
StairsEditScope(
    Document^ document,
    String^ transactionName
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document for which this StairsEditScope is going to be used.
transactionName
Type: System..::..String
The name that will appear in the Undo menu in Revit after the StairsEditScope is successfully committed.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a primary document, it is a linked document. -or- document is not a project document. -or- transactionName is an empty string.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

StairsEditScope Class