Revit 2013 API
TaskDialogShowingEventArgs Members
TaskDialogShowingEventArgs Class Methods Properties See Also

The TaskDialogShowingEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | OverrideResult | Call this method to cause the Autodesk Revit dialog to be dismissed with the specified return value. (Inherited from DialogBoxShowingEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Public property | DialogId | String ID associated with the task dialog.
Public property | HelpId | An ID that represents the dialog that has been displayed. (Inherited from DialogBoxShowingEventArgs.)
Public property | Message | The message provided by the task dialog.

See Also

TaskDialogShowingEventArgs Class
Autodesk.Revit.UI.Events Namespace