Revit 2013 API
EnergyAnalysisSurface Methods
EnergyAnalysisSurface Class See Also

The EnergyAnalysisSurface type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAdjacentAnalyticalSpace | Gets the secondary adjacent analytical space this surface is associated with.
Public method | GetAnalyticalOpenings | Returns the analytical openings of the analytical surface.
Public method | GetAnalyticalSpace | Gets the primary analytical space this surface is associated with.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPolyloop | Gets the planar polygon describing the opening geometry.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EnergyAnalysisSurface Class
Autodesk.Revit.DB.Analysis Namespace