Revit 2013 API
TransmissionData Members
TransmissionData Class Constructors Methods Properties See Also

The TransmissionData type exposes the following members.

Constructors

 | Name | Description
Public method | TransmissionData | Constructs a TransmissionData from another TransmissionData

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the TransmissionData
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAllExternalFileReferenceIds | Gets the ids of all ExternalFileReferences.
Public method | GetDesiredReferenceData | Gets the ExternalFileReference representing path and load status information to be used the next time this TransmissionData's document is loaded.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLastSavedReferenceData | Gets the ExternalFileReference representing path and load status information concerning the most recent time this TransmissionData's document was opened.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsDocumentTransmitted | Determines whether the document at a given file location is transmitted.
 | ReadTransmissionData | Reads the TransmissionData associated with the file at the given location.
Public method | SetDesiredReferenceData | Sets the ExternalFileReference information which Revit should use the next time it opens the document which this TransmissionData belongs to.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | WriteTransmissionData | Writes the given TransmissionData into the Revit file at the given location.

Properties

 | Name | Description
Public property | IsTransmitted | Determines whether this file has been transmitted or not.
Public property | UserData | A string which users can store notes in.
Public property | Version | The format version for TransmissionData

See Also

TransmissionData Class