Revit 2013 API
MassEnergyAnalyticalModel Methods
MassEnergyAnalyticalModel Class See Also

The MassEnergyAnalyticalModel type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
 | GetCoincidentEnergyAnalyticalModelFaceReference | Returns a Reference to a Face from the same or a different MassEnergyAnalyticalModel that is coincident with the input Face.
 | GetCoincidentMassZoneFaceReferences | Returns References to Faces from MassZones coincident with an input Face from a MassEnergyAnalyticalModel.
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetJoinedMassEnergyAnalyticalModelElementIds | The ElementIds of other MassEnergyAnalyticalModels that are "joined" to this one.
 | GetMassEnergyAnalyticalModelIdForMassInstance | Get the ElementId of the MassEnergyAnalyticalModel for a mass instance.
Public method | GetMassSurfaceDataIdForReference | Get the ElementId of the MassSurfaceData corresponding to the Reference.
Public method | GetMassZoneIds | Get the MassZone ElementIds that are created from this MassEnergyAnalyticalModel.
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetReferencesToAllFaces | Get References to all Faces which are meaningful for the MassEnergyAnalyticalModel. Array of References to Faces of the MassEnergyAnalyticalModel.
Public method | GetReferencesToAllShadingFaces | Get References to all Faces of the MassEnergyAnalyticalModel which are of Mass Shade subcategory.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidSurfaceCategoryIdsForReference | The Mass surface subcategory ids that are appropriate values for the input Reference.
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MassEnergyAnalyticalModel Class
Autodesk.Revit.DB.Analysis Namespace