Revit 2013 API
Category Methods
Category Class See Also

The Category type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetGraphicsStyle | Gets the graphics style associated with this category for the given graphics style type.
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | GetLineWeight | Retrieves the line weight assigned to the category for the given graphics style type.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetLineWeight | Sets the line weight for the given graphics style type.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Category Class