Revit 2013 API
IFCExtrusionCalculatorUtils..::..CalculateExtrusionData Method (IFCExtrusionCalculatorOptions, GeometryObject)
IFCExtrusionCalculatorUtils Class See Also
Calculates the extrusion data from a Revit geometry object.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static IList<IFCExtrusionData> CalculateExtrusionData(
    IFCExtrusionCalculatorOptions extrusionOptions,
    GeometryObject geometryObject
)
Visual Basic
Public Shared Function CalculateExtrusionData ( _
    extrusionOptions As IFCExtrusionCalculatorOptions, _
    geometryObject As GeometryObject _
) As IList(Of IFCExtrusionData)
Visual C++
public:
static IList<IFCExtrusionData^>^ CalculateExtrusionData(
    IFCExtrusionCalculatorOptions^ extrusionOptions,
    GeometryObject^ geometryObject
)

Parameters

extrusionOptions
Type: Autodesk.Revit.DB.IFC..::..IFCExtrusionCalculatorOptions
The options for extrusion extraction.
geometryObject
Type: Autodesk.Revit.DB..::..GeometryObject
The geometry object.

Return Value

A collection of extrusion data calculated for the geometry. If the function fails to calculate one or more valid extrusions, this collection will be empty.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCExtrusionCalculatorUtils Class
CalculateExtrusionData Overload
Autodesk.Revit.DB.IFC Namespace