Revit 2013 API
ExternalServiceRegistry Methods
ExternalServiceRegistry Class See Also

The ExternalServiceRegistry type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExecuteService(Guid, IExternalData) | Execute a service independently of any document.
 | ExecuteService(Guid, Document, IExternalData) | Execute the service for the given document.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetService | Returns an instance of an object that represents the external service with the given Id.
 | GetServices | Returns a collection of all external services currently registered in Revit.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | RegisterService(ISingleServerService, Boolean) | A method to register a single-server service.
 | RegisterService(IMultiServerService, Boolean, ExecutionPolicy) | A method to register a multi-server service.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExternalServiceRegistry Class
Autodesk.Revit.DB.ExternalService Namespace