Revit 2013 API
DividedPath Members
DividedPath Class Methods Properties See Also

The DividedPath type exposes the following members.

Methods

 | Name | Description
 | AreCurveReferencesConnected | This checks if the references represent a connected set of curves as required by the divided path.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create(Document, IList<(Of <<'(Reference>)>>)) | Creates a new instance of a divided path with a default layout.
 | Create(Document, IList<(Of <<'(Reference>)>>), ICollection<(Of <<'(ElementId>)>>)) | Creates a new instance of a divided path whose points are determined by the intersecting elements.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Flip | Toggle the flipped value
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIntersectingElements | Get the elements whose intersection with path produces points.
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
 | IsCurveReferenceValid | This returns true if the reference represents a curve or edge that can be used to create a divided path.
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
 | IsIntersectorValidForCreation | This returns true if the intersector is an element that can be used to intersect with a newly created divided path.
Public method | IsIntersectorValidForDividedPath | This returns true if the intersector is an element that can be used to intersect with the divided path.
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidBeginningIndent | Checks that the indent value does not cause the beginningIndent and endIndent to overlop
Public method | IsValidEndIndent | Checks that the indent value does not cause the beginningIndent and endIndent to overlop
 | IsValidFixedNumberOfPoints |
Public method | IsValidMeasurementType | Checks that the measurement type enumeration value is valid
Public method | IsValidSpacingRuleJustification | Checks that the justification enumeration value is valid
Public method | IsValidSpacingRuleLayout | Checks that the spacing rule layout enumeration value is valid
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
 | SeparateReferencesIntoConnectedReferences | This function separates the input curve references into groups of connected curve references. Each group of connected curve references can be used to create a divided path.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetIntersectingElements | Set the elements whose intersection with path produces points.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BeginningIndent | The beginningIndent is an offset distance from the beginning of the first curve that determines the beginning of the range over which the layout is applied. The measurement type determines how the distance is measured.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | DisplayNodeNumbers | Controls whether the node numbers are shown when the divided path is selected
Public property | DisplayNodes | Controls whether the points of the divided path are visible
Public property | DisplayReferenceCurves | Controls whether the curves in the path are visible
Public property | Distance | The distance between points that are distributed along the path according to the selected layout. When the layout is set to 'FixedDistance' this value can be set to desired distance. The measurement type determines how the distance is measured.
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | EndIndent | The endIndent is an offset distance from the end of the last curve that determines the end of the range over which the layout is applied. The measurement type determines how the distance is measured.
Public property | FixedNumberOfPoints | The number of points used when the layout is set to 'FixedNumber'.
Public property | Flipped | If the divided path is flipped the nodes are numbered in the reverse order. It also switches the ends from which beginningIndent and endIndent are measured from.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsClosedLoop | Whether or not the path forms a closed loop.
Public property | IsCyclical | True if the first and last point coincide False otherwise.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MaximumDistance | The maximum distance is used when the layout is set to 'MaximumSpacing'. When that layout rule is used the distance between points will not exceed this value. The measurement type determines how the distance is measured.
Public property | MeasurementType | The measurement type determines how distances are calculated. Either along a straight line between two points ('ChordLength') or along the segment of the path that connects them. ('SegmentLength').
Public property | MinimumDistance | The minimum distance is used when the layout is set to 'MinimumSpacing'. When that layout rule is used the distance between points will not fall below this value. The measurement type determines how the distance is measured.
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | NumberOfPoints | The total number of points of the divided surface. This combines the layout points and the intersection points.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SpacingRuleJustification | When the layout is set to 'FixedDistance' the points may not cover the entire range of the path. The justification determines whether the points are centered on the range, or shifted towards the start or end of the range.
Public property | SpacingRuleLayout | The layout determines how points are distributed along the path.
Public property | TotalPathLength | The sum of the curve lengths.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

DividedPath Class