Revit 2013 API
ContFooting Class
Members Example See Also
An object that represents a Continuous Footing within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class ContFooting : HostObject
Visual Basic
Public Class ContFooting _
    Inherits HostObject
Visual C++
public ref class ContFooting : public HostObject

Examples

CopyC#
public void GetInfo_ContFooting(ContFooting contFooting)
{
    string message = "Wall Foundation : ";

    // Get Analytical model
    if (null != contFooting.GetAnalyticalModel())
    {
        message += "\nAnalytical model : " + contFooting.GetAnalyticalModel();
    }

    // Get Footing type name
    message += "\nFooting type name is : " + contFooting.FootingType.Name;

    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Public Sub GetInfo_ContFooting(ByVal contFooting As Autodesk.Revit.DB.ContFooting)
    Dim message As String = "Wall Foundation : "

    ' Get Analytical model
    If contFooting.GetAnalyticalModel() IsNot Nothing Then
        message += vbLf & "Analytical model : " & contFooting.GetAnalyticalModel().ToString()
    End If

    ' Get Footing type name
    message += vbLf & "Footing type name is : " + contFooting.FootingType.Name

    TaskDialog.Show("Revit", message)
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..HostObject
Autodesk.Revit.DB..::..ContFooting

See Also

ContFooting Members