Revit 2013 API
IFCData..::..SetSimpleType Method
IFCData Class See Also
Sets the corresponding IFC type by its name.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetSimpleType(
    string typeName
)
Visual Basic
Public Sub SetSimpleType ( _
    typeName As String _
)
Visual C++
public:
void SetSimpleType(
    String^ typeName
)

Parameters

typeName
Type: System..::..String
The name of the type.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCData Class
Autodesk.Revit.DB.IFC Namespace