Revit 2013 API
ExporterIFCUtils..::..ComputeRoofProjectedArea Method
ExporterIFCUtils Class See Also
Returns the projected area of the room, unscaled.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static double ComputeRoofProjectedArea(
    Element pElem
)
Visual Basic
Public Shared Function ComputeRoofProjectedArea ( _
    pElem As Element _
) As Double
Visual C++
public:
static double ComputeRoofProjectedArea(
    Element^ pElem
)

Parameters

pElem
Type: Autodesk.Revit.DB..::..Element
The roof.

Return Value

The projected area.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace