Revit 2013 API
Rectangle Members
Rectangle Class Constructors Methods Properties See Also

The Rectangle type exposes the following members.

Constructors

 | Name | Description
Public method | Rectangle | Creates an Rectangle instance with the specified four integers that represent the left, top, right and bottom of a rectangle.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Bottom | Gets y-coordinate of the bottom-right corner of the rectangle.
Public property | Left | Gets x-coordinate of the top-left corner of the rectangle.
Public property | Right | Gets x-coordinate of the bottom-right corner of the rectangle.
Public property | Top | Gets y-coordinate of the top-left corner of the rectangle.

See Also

Rectangle Class