Revit 2013 API
StructuralMaterialTypeFilter Constructor (StructuralMaterialType, Boolean)
StructuralMaterialTypeFilter Class See Also
Constructs a new instance of a filter to match family instances by structural material type, with the option to match all families which are not of the given structural material type.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public StructuralMaterialTypeFilter(
    StructuralMaterialType structuralMaterialType,
    bool inverted
)
Visual Basic
Public Sub New ( _
    structuralMaterialType As StructuralMaterialType, _
    inverted As Boolean _
)
Visual C++
public:
StructuralMaterialTypeFilter(
    StructuralMaterialType structuralMaterialType,
    bool inverted
)

Parameters

structuralMaterialType
Type: Autodesk.Revit.DB.Structure..::..StructuralMaterialType
The structural material type to match.
inverted
Type: System..::..Boolean
True if the filter should match all family instances which are not of the given structural material type.

See Also

StructuralMaterialTypeFilter Class
StructuralMaterialTypeFilter Overload
Autodesk.Revit.DB.Structure Namespace