Revit 2013 API
RebarShapeDefinitionBySegments..::..AddConstraintParallelToSegment Method
RebarShapeDefinitionBySegments Class See Also
Constrain the length of a segment by parameterizing its length.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void AddConstraintParallelToSegment(
    int iSegment,
    ElementId paramId,
    bool measureToOutsideOfBend0,
    bool measureToOutsideOfBend1
)
Visual Basic
Public Sub AddConstraintParallelToSegment ( _
    iSegment As Integer, _
    paramId As ElementId, _
    measureToOutsideOfBend0 As Boolean, _
    measureToOutsideOfBend1 As Boolean _
)
Visual C++
public:
void AddConstraintParallelToSegment(
    int iSegment,
    ElementId^ paramId,
    bool measureToOutsideOfBend0,
    bool measureToOutsideOfBend1
)

Parameters

iSegment
Type: System..::..Int32
Index of the segment (0 to NumberOfSegments - 1).
paramId
Type: Autodesk.Revit.DB..::..ElementId
Id of a parameter to drive the constraint. To obtain the id of a shared parameter, call RebarShape.GetElementIdForExternalDefinition().
measureToOutsideOfBend0
Type: System..::..Boolean
Choose between two possibilities for the first reference of the length dimension. If false, the reference is at the point where the bend begins; equivalently, at the projection of the bend centerpoint onto the segment. If true, the reference is moved outward by a distance equal to the bend radius plus the bar diameter; if the bend is a right angle or greater, this is equivalent to putting the reference at the outer face of the bend.
measureToOutsideOfBend1
Type: System..::..Boolean
Choose between two possibilities for the second reference of the length dimension.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | iSegment is not between 0 and NumberOfEdges. -or- paramId is not the id of a shared parameter in the current document, or its unit type is not UT_Length or UT_Angle.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.DB.Structure Namespace