Revit 2013 API
IFCTransaction Class
Members See Also
IFC transactions are context-like objects that guard any changes made to an IFC file.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class IFCTransaction : IDisposable
Visual Basic
Public Class IFCTransaction _
    Implements IDisposable
Visual C++
public ref class IFCTransaction : IDisposable

Remarks

Any change to an IFC file can only be made while there is an active transaction open for that file. Changes do not become a part of the file until the active transaction is committed. Consequently, all changes made in a transaction can be rolled back either explicitly or implicitly (by the destructor).

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.IFC..::..IFCTransaction

See Also

IFCTransaction Members
Autodesk.Revit.DB.IFC Namespace