Revit 2013 API
SunAndShadowSettings..::..SunAndShadowType Property
SunAndShadowSettings Class See Also
Identifies the type of the SunAndShadowSettings element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public SunAndShadowType SunAndShadowType { get; set; }
Visual Basic
Public Property SunAndShadowType As SunAndShadowType
    Get
    Set
Visual C++
public:
property SunAndShadowType SunAndShadowType {
    SunAndShadowType get ();
    void set (SunAndShadowType value);
}

Remarks

There are no restrictions on setting the type, but do note that some properties are not relevant for certain types. For example, the property EndDateAndTime is not relevant for the type SunAndShadowType.StillImage. In this example (and elsewhere), the previous value for the property is remembered for when the type is reverted. If that property has not been set yet, default values will apply.

See Also

SunAndShadowSettings Class