Revit 2013 API
ProgressChangedEventArgs Members
ProgressChangedEventArgs Class Methods Properties See Also

The ProgressChangedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Cancel | Requests to cancel the progress bar's operation.
Public method | Dispose | (Inherited from RevitAPIEventArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs.)
Public property | Caption | The text from the progress bar caption that describes the operation in progress
Public property | LowerRange | Lower part of progress bar range - always zero
Public property | Position | Progress bar position - value is always between zero and upperRange and is incremented by one with each event of stage "PositionChanged"
Public property | Stage | The current stage of the progress bar
Public property | UpperRange | Upper part of progress bar range - will be any non-zero number

See Also

ProgressChangedEventArgs Class
Autodesk.Revit.DB.Events Namespace