Revit 2013 API
CombinableElementArray Members
CombinableElementArray Class Constructors Methods Properties See Also

The CombinableElementArray type exposes the following members.

Constructors

 | Name | Description
Public method | CombinableElementArray | Initializes a new instance of the CombinableElementArray class

Methods

 | Name | Description
Public method | Append | Add the element to the end of the array.
Public method | Clear | Removes every CombinableElement from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified element into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a CombinableElement at a specified index within the array.
Public property | Size | Returns the number of CombinableElements that are in the array.

See Also

CombinableElementArray Class