Revit 2013 API
IFCData..::..AsInteger Method
IFCData Class See Also
Gets storage value as integer when its PrimitiveType is integer.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int AsInteger()
Visual Basic
Public Function AsInteger As Integer
Visual C++
public:
int AsInteger()

Return Value

The int value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InapplicableDataException | The primitive type is not integer.

See Also

IFCData Class
Autodesk.Revit.DB.IFC Namespace