Revit 2013 API
IntersectionResult Members
IntersectionResult Class Constructors Methods Properties See Also

The IntersectionResult type exposes the following members.

Constructors

 | Name | Description
Public method | IntersectionResult | Initializes a new instance of the IntersectionResult class

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Distance | Distance from the original object to located point.
Public property | EdgeObject | Edge of the face close to the point of intersection.
Public property | EdgeParameter | Parameter of a point on the edge closest to the point of intersection.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Parameter | 1d parameter of the point of intersection.
Public property | UVPoint | 2d (or two 1d) parameters of the point of intersection.
Public property | XYZPoint | Point of intersection in local 3d coordinates.

See Also

IntersectionResult Class