Revit 2013 API
ControlledApplication..::..GetLibraryPaths Method
ControlledApplication Class Example See Also
Returns path information identifying where Revit searches for content.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IDictionary<string, string> GetLibraryPaths()
Visual Basic
Public Function GetLibraryPaths As IDictionary(Of String, String)
Visual C++
public:
IDictionary<String^, String^>^ GetLibraryPaths()

Return Value

The map of library paths.

Remarks

The map that is returned contains a key that is purpose of the path, such as Material Libraries and the value in the map is the fully qualified path that is used for that search path.

Examples

CopyC#
string strLibPaths = "";
foreach (String path in application.GetLibraryPaths().Values)
{
    strLibPaths += path + "\n";
}
CopyVB.NET
Dim strLibPaths As String = ""
For Each path As [String] In application.LibraryPaths
    strLibPaths += path + vbLf
Next

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace