Revit 2013 API
StructuralWallUsageFilter Constructor (StructuralWallUsage, Boolean)
StructuralWallUsageFilter Class See Also
Constructs a new instance of a filter to match walls that have the given structural wall usage, with the option to match all walls which are not of the given structural wall usage.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public StructuralWallUsageFilter(
    StructuralWallUsage structuralWallUsage,
    bool inverted
)
Visual Basic
Public Sub New ( _
    structuralWallUsage As StructuralWallUsage, _
    inverted As Boolean _
)
Visual C++
public:
StructuralWallUsageFilter(
    StructuralWallUsage structuralWallUsage,
    bool inverted
)

Parameters

structuralWallUsage
Type: Autodesk.Revit.DB.Structure..::..StructuralWallUsage
The structural usage to match.
inverted
Type: System..::..Boolean
True if the filter should match all walls which are not of the given structural wall usage.

See Also

StructuralWallUsageFilter Class
StructuralWallUsageFilter Overload
Autodesk.Revit.DB.Structure Namespace