Revit 2013 API
SchemaBuilder..::..SetReadAccessLevel Method
SchemaBuilder Class See Also
Sets top level read access (for entities)

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public SchemaBuilder SetReadAccessLevel(
    AccessLevel readAccessLevel
)
Visual Basic
Public Function SetReadAccessLevel ( _
    readAccessLevel As AccessLevel _
) As SchemaBuilder
Visual C++
public:
SchemaBuilder^ SetReadAccessLevel(
    AccessLevel readAccessLevel
)

Parameters

readAccessLevel
Type: Autodesk.Revit.DB.ExtensibleStorage..::..AccessLevel
Read access level value to be set

Return Value

The SchemaBuilder object may be used to add more settings.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The SchemaBuilder has already finished building the Schema.

See Also

SchemaBuilder Class
Autodesk.Revit.DB.ExtensibleStorage Namespace