Revit 2013 API
IFCProductWrapper Members
IFCProductWrapper Class Methods Properties See Also

The IFCProductWrapper type exposes the following members.

Methods

 | Name | Description
Public method | AddAnnotation | Adds an annotation handle to associate with the IfcProduct in this wrapper.
Public method | AddBuilding | Adds an IfcBuilding handle to associate with the IfcProduct in this wrapper.
Public method | AddElement(IFCAnyHandle, IFCLevelInfo, IFCExtrusionCreationData, Boolean) | Adds an IfcElement handle to associate with the IfcProduct in this wrapper.
Public method | AddElement(IFCAnyHandle, IFCPlacementSetter, IFCExtrusionCreationData, Boolean) | Adds an IfcElement handle to associate with the IfcProduct in this wrapper.
Public method | AddFinishMaterial | Adds an material handle to associate with the IfcProduct in this wrapper.
Public method | AddSite | Adds a site (IfcObject) handle to associate with the IfcProduct in this wrapper.
Public method | AddSpace | Adds an IfcSpace handle to associate with the IfcProduct in this wrapper.
Public method | ClearFinishMaterials | Clear finish materials in this wrapper.
 | Create(IFCProductWrapper) | Establishes a new product manager for elements and objects derived from a parent product manager.
 | Create(ExporterIFC, Boolean) | Establishes a new baseline product manager for elements and objects.
 | Create(IFCProductWrapper, Boolean) | Establishes a new product manager for elements and objects derived from a parent product manager, allowing override of allowRelateToLevel
Public method | Dispose | Releases all resources used by the IFCProductWrapper
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindExtrusionCreationParameters | Obtains the extrusion creation data associated with the given element.
Public method | GetAllObjects | Gets all objects associated with the IfcProduct in this wrapper.
Public method | GetAnElement | Gets the first element handle added to this wrapper.
Public method | GetElements | Gets the element handles added to this wrapper.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProducts | Gets the product element handles added to this wrapper.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | The number of objects associated with the IfcProduct in this wrapper.

See Also

IFCProductWrapper Class
Autodesk.Revit.DB.IFC Namespace