Revit 2013 API
ElementIntersectsElementFilter Class
Members See Also
A filter to find elements that intersect the solid geometry of a given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class ElementIntersectsElementFilter : ElementIntersectsFilter
Visual Basic
Public Class ElementIntersectsElementFilter _
    Inherits ElementIntersectsFilter
Visual C++
public ref class ElementIntersectsElementFilter : public ElementIntersectsFilter

Remarks

This filter is a slow filter. Slow filters require that the Element be obtained and expanded in memory first. Thus it is preferable to couple this filter with at least one ElementQuickFilter, which should minimize the number of Elements that are expanded.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementSlowFilter
Autodesk.Revit.DB..::..ElementIntersectsFilter
Autodesk.Revit.DB..::..ElementIntersectsElementFilter

See Also

ElementIntersectsElementFilter Members