Revit 2013 API
RebarShapeDefinitionBySegments Members
RebarShapeDefinitionBySegments Class Constructors Methods Properties See Also

The RebarShapeDefinitionBySegments type exposes the following members.

Constructors

 | Name | Description
Public method | RebarShapeDefinitionBySegments | Create a rebar shape definition with a given number of segments.

Methods

 | Name | Description
Public method | AddBendDefaultRadius | Specify a default-radius bend.
Public method | AddBendVariableRadius | Specify a variable-radius bend.
Public method | AddConstraintParallelToSegment | Constrain the length of a segment by parameterizing its length.
Public method | AddConstraintToSegment | Add a constraint that helps determine the length of a segment.
Public method | AddFormulaParameter | Add a formula-driven parameter to the shape definition. (Inherited from RebarShapeDefinition.)
Public method | AddListeningDimensionBendToBend | Specify a dimension between two bends, measured by a read-only parameter.
Public method | AddListeningDimensionSegmentToBend | Specify a dimension perpendicular to one fixed-direction segment, referring to that segment and some other bend in the shape, measured by a read-only parameter.
Public method | AddListeningDimensionSegmentToSegment | Specify a dimension perpendicular to two fixed-direction segments, measured by a read-only parameter.
Public method | AddParameter | Add a parameter to the shape definition. (Inherited from RebarShapeDefinition.)
Public method | CheckDefaultParameterValues | Check that the shape can be solved with the default parameter values. (Inherited from RebarShapeDefinition.)
Public method | Dispose | (Inherited from RebarShapeDefinition.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetParameterDefaultValue | Return the parameter's default value as stored in the definition. (Inherited from RebarShapeDefinition.)
Public method | GetParameterFormula | Return the parameter's formula, if one is associated with it. (Inherited from RebarShapeDefinition.)
Public method | GetParameters | Return the Ids of the shared parameters in the Definition. (Inherited from RebarShapeDefinition.)
Public method | GetSegment | Return a reference to one of the segments in the definition.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVertex | Return a reference to one of the vertices in the definition.
Public method | HasParameter | Whether the definition stores the parameter. (Inherited from RebarShapeDefinition.)
Public method | RemoveParameter | Remove the parameter from the definition. (Inherited from RebarShapeDefinition.)
Public method | RemoveParameterFromSegment | Remove constraints from an edge.
Public method | SetParameterDefaultValue | Change the parameter's value as stored in the definition. (Inherited from RebarShapeDefinition.)
Public method | SetParameterFormula | Associate a formula with the parameter. (Inherited from RebarShapeDefinition.)
Public method | SetSegmentAs180DegreeBend(Int32) | Indicates that a segment is a "virtual" segment introduced to describe a 180-degree bend. The radius of the bend will be taken from the Bar Type.
Public method | SetSegmentAs180DegreeBend(Int32, ElementId, Boolean) | Indicate that a segment is a "virtual" segment introduced to describe a 180-degree bend. The radius of the bend will be driven by radiusParam.
Public method | SetSegmentFixedDirection | Fix the direction of a segment.
Public method | SetSegmentVariableDirection | Remove the fixed direction from a segment.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Complete | Report whether the shape definition is fully constrained. (Inherited from RebarShapeDefinition.)
Public property | IsPlanar | Reports whether the shape definition lies within a plane: false if a spiral, true in all other cases. (Inherited from RebarShapeDefinition.)
Public property | MajorSegmentIndex | Index of a segment that can be considered the most important. Revit attempts to preserve the orientation of this segment when a Rebar instance changes its RebarShape to one with a different number of segments.
Public property | NumberOfSegments | The number of straight segments in this shape.
Public property | NumberOfVertices | The number of vertices in this shape, always equal to NumberOfSegments + 1.

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.DB.Structure Namespace