Revit 2013 API
DefinitionBindingMapIterator Members
DefinitionBindingMapIterator Class Constructors Methods Properties See Also

The DefinitionBindingMapIterator type exposes the following members.

Constructors

 | Name | Description
Public method | DefinitionBindingMapIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the map.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the binding that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Key | Retrieves the definition that is the current focus of the iterator.

See Also

DefinitionBindingMapIterator Class