Revit 2013 API
PropertySetLibrary..::..AddPropertySet Method
PropertySetLibrary Class See Also
Adds a property set from the document to this library.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void AddPropertySet(
    ElementId propertySetId
)
Visual Basic
Public Sub AddPropertySet ( _
    propertySetId As ElementId _
)
Visual C++
public:
void AddPropertySet(
    ElementId^ propertySetId
)

Parameters

propertySetId
Type: Autodesk.Revit.DB..::..ElementId
Identifier of the property set to add.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given ElementId does not refer to a PropertySetElement
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ObjectAccessException | The property set library is read-only.

See Also

PropertySetLibrary Class