Revit 2013 API
StairsRun..::..GetNumberSystemReference Method
StairsRun Class See Also
Gets the number system reference corresponding to the given reference options.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public Reference GetNumberSystemReference(
    StairsNumberSystemReferenceOption referenceOption
)
Visual Basic
Public Function GetNumberSystemReference ( _
    referenceOption As StairsNumberSystemReferenceOption _
) As Reference
Visual C++
public:
Reference^ GetNumberSystemReference(
    StairsNumberSystemReferenceOption referenceOption
)

Parameters

referenceOption
Type: Autodesk.Revit.DB.Architecture..::..StairsNumberSystemReferenceOption
The reference option.

Return Value

The reference.

Remarks

The return value of this function is suitable for use in NumberSystem.Create() to associate a NumberSystem with the location on the StairsRun. Don't try to get geometry curve from the reference.

See Also

StairsRun Class
Autodesk.Revit.DB.Architecture Namespace