Revit 2013 API
RenderingQualitySettings..::..BlurredRefractionPrecision Property
RenderingQualitySettings Class See Also
The blurred refractions precision.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int BlurredRefractionPrecision { get; set; }
Visual Basic
Public Property BlurredRefractionPrecision As Integer
    Get
    Set
Visual C++
public:
property int BlurredRefractionPrecision {
    int get ();
    void set (int value);
}

Remarks

Increase this value when the edges of objects seen through rough glass are speckled, rather than smoothly blurred.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The blurred refractions precision is not valid. The valid range is 1 to 11.
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The RenderingQualitySettings does not use custom quality currently. To use custom quality, set RenderingQuality property to RenderingQuality.Custom.

See Also

RenderingQualitySettings Class