Revit 2013 API
ViewSection..::..IsParentViewValidForCallout Method
ViewSection Class See Also
This validator checks that the parent view is appropriate for callout views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static bool IsParentViewValidForCallout(
    Document document,
    ElementId parentViewId
)
Visual Basic
Public Shared Function IsParentViewValidForCallout ( _
    document As Document, _
    parentViewId As ElementId _
) As Boolean
Visual C++
public:
static bool IsParentViewValidForCallout(
    Document^ document,
    ElementId^ parentViewId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document which contains the ViewFamilyType and parent view.
parentViewId
Type: Autodesk.Revit.DB..::..ElementId
The view in which the new callout will appear. Callouts can be created in FloorPlan, CeilingPlan, StructuralPlan, Section, Elevation, and Detail views.

Return Value

True if the ViewFamilyType can be used for callout views in the parent view, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ViewSection Class