Revit 2013 API
ExporterIFCUtils..::..AreSolidsEqual Method
ExporterIFCUtils Class See Also
Determines whether two solids are identical, potentially offset from each other.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static bool AreSolidsEqual(
    Solid first,
    Solid second,
    out Transform trf
)
Visual Basic
Public Shared Function AreSolidsEqual ( _
    first As Solid, _
    second As Solid, _
    <OutAttribute> ByRef trf As Transform _
) As Boolean
Visual C++
public:
static bool AreSolidsEqual(
    Solid^ first,
    Solid^ second,
    [OutAttribute] Transform^% trf
)

Parameters

first
Type: Autodesk.Revit.DB..::..Solid
The first solid.
second
Type: Autodesk.Revit.DB..::..Solid
The second solid
trf
Type: Autodesk.Revit.DB..::..Transform%
The offset transform

Return Value

True if they are identical, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace