Revit 2013 API
Parameter Members
Parameter Class Methods Properties See Also

The Parameter type exposes the following members.

Methods

 | Name | Description
Public method | AsDouble | Provides access to the double precision number within the parameter.
Public method | AsElementId | Provides access to the Autodesk::Revit::DB::ElementId^ stored within the parameter.
Public method | AsInteger | Provides access to the integer number within the parameter.
Public method | AsString | Provides access to the string contents of the parameter.
Public method | AsValueString | Get the parameter value as a string with unit.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Set(Double) | Sets the parameter to a new real number value.
Public method | Set(Int32) | Sets the parameter to a new integer value.
Public method | Set(String) | Sets the parameter to a new string of text.
Public method | Set(ElementId) | Sets the parameter to a new element id.
Public method | SetValueString | Set the parameter value according to the input string.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Definition | Returns the Definition object that describes the data type, name and other details of the parameter.
Public property | DisplayUnitType | Get the display unit type of the parameter object.
Public property | Element | The element to which this parameter belongs.
Public property | GUID | The Guid for a shared parameter.
Public property | HasValue | Identifies if the parameter has an assigned value.
Public property | Id | The id of the parameter.
Public property | IsReadOnly | Get the readonly property of the parameter. (Overrides APIObject..::..IsReadOnly.)
Public property | IsShared | Identifies if the parameter is a shared parameter.
Public property | StorageType | Describes the type that is used internally within the parameter to store its value.

See Also

Parameter Class