Revit 2013 API
Face..::..ComputeNormal Method
Face Class See Also
Returns the normal vector for the face at the given point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ ComputeNormal(
    UV point
)
Visual Basic
Public Function ComputeNormal ( _
    point As UV _
) As XYZ
Visual C++
public:
XYZ^ ComputeNormal(
    UV^ point
)

Parameters

point
Type: Autodesk.Revit.DB..::..UV
The parameters to be evaluated, in natural parameterization of the face.

Return Value

The normal vector. This vector will be normalized.

Remarks

Differs from the normal returned from ComputeDerivatives(UV) in that this vector is the "face normal" vector. It will always be oriented to point out of the solid that contains the face.

See Also

Face Class