Revit 2013 API
ApplicationException Methods
ApplicationException Class See Also

The ApplicationException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Retrieves data needed to serialize the target object. (Overrides Exception..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ApplicationException Class
Autodesk.Revit.Exceptions Namespace