Revit 2013 API
FailureDefinitionAccessor..::..SetDefaultResolutionType Method
FailureDefinitionAccessor Class See Also
Sets the default resolution type for the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void SetDefaultResolutionType(
    FailureResolutionType type
)
Visual Basic
Public Sub SetDefaultResolutionType ( _
    type As FailureResolutionType _
)
Visual C++
public:
void SetDefaultResolutionType(
    FailureResolutionType type
)

Parameters

type
Type: Autodesk.Revit.DB..::..FailureResolutionType
The type of resolution to be used as default.

Remarks

If failure has multiple resolutions, one of them is designated as designated as the default resolution. The default resolution is used by Revit failure processing mechanism to resolve failures automatically when applicable.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Resolution of the type is not applicable to the failure.
Autodesk.Revit.Exceptions..::..InvalidOperationException | The FailureDefinitionAccessor has not been properly initialized. -or- FailureDefinition does not have any resolutions.

See Also

FailureDefinitionAccessor Class