Revit 2013 API
LinearArray..::..ArrayElementsWithoutAssociation Method
LinearArray Class See Also
Creates a new linear array from a set of elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static ICollection<ElementId> ArrayElementsWithoutAssociation(
    Document aDoc,
    View dBView,
    ICollection<ElementId> ids,
    int count,
    XYZ translationToAnchorMember,
    ArrayAnchorMember anchorMember
)
Visual Basic
Public Shared Function ArrayElementsWithoutAssociation ( _
    aDoc As Document, _
    dBView As View, _
    ids As ICollection(Of ElementId), _
    count As Integer, _
    translationToAnchorMember As XYZ, _
    anchorMember As ArrayAnchorMember _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ ArrayElementsWithoutAssociation(
    Document^ aDoc,
    View^ dBView,
    ICollection<ElementId^>^ ids,
    int count,
    XYZ^ translationToAnchorMember,
    ArrayAnchorMember anchorMember
)

Parameters

aDoc
Type: Autodesk.Revit.DB..::..Document
The document.
dBView
Type: Autodesk.Revit.DB..::..View
The view. If it is a 2d view, translation vector must be in the view plane if elements include view-specific elements. If elements include view-specific elements, they must belong to this view.
ids
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
The elements to array.
count
Type: System..::..Int32
The number of array members to create including the initial element grouping. Must between 2 and 200.
translationToAnchorMember
Type: Autodesk.Revit.DB..::..XYZ
The translation vector for the array.
anchorMember
Type: Autodesk.Revit.DB..::..ArrayAnchorMember
Indicates if the translation vector specifies the location of the second member of the array, or the last member of the array.

Return Value

The ids of the elements created during the operation.

Remarks

The resulting elements will not be associated with an array element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ids is empty. -or- One or more elements in ids do not exist in the document. -or- One or more elements in ids is owned by different views and thus cannot be arrayed together. -or- One or more elements in ids is not arrayable. -or- count must be between 2 and 200. -or- The view is invalid for specific view elements array. -or- The translation point vector is invalid to array the element.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | Failed to create the linear array.

See Also

LinearArray Class