Revit 2013 API
Document..::..NewFlexDuct Method (Connector, Connector, FlexDuctType)
Document Class See Also
Adds a new flexible duct into the document, using two connector, and duct type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FlexDuct NewFlexDuct(
    Connector connector1,
    Connector connector2,
    FlexDuctType ductType
)
Visual Basic
Public Function NewFlexDuct ( _
    connector1 As Connector, _
    connector2 As Connector, _
    ductType As FlexDuctType _
) As FlexDuct
Visual C++
public:
FlexDuct^ NewFlexDuct(
    Connector^ connector1,
    Connector^ connector2,
    FlexDuctType^ ductType
)

Parameters

connector1
Type: Autodesk.Revit.DB..::..Connector
The first connector to be connected to the duct.
connector2
Type: Autodesk.Revit.DB..::..Connector
The second connector to be connected to the duct.
ductType
Type: Autodesk.Revit.DB.Mechanical..::..FlexDuctType
The type of the flexible duct.

Return Value

If creation was successful then a new flexible duct is returned, otherwise an exception with failure information will be thrown.

Remarks

If the connectors are fitting or equipment connectors of the correct domain, and if the connectors’ direction match the direction of the flexible duct to be created, the connectors will be automatically connected. A transition fitting will be added at the connector(s) if necessary. If the connector's type, domain, does not match the one of the input connector, no connection will be established.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument connector1 or connector2 is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the flexible duct cannot be created or regenerate fails.

See Also

Document Class
NewFlexDuct Overload
Autodesk.Revit.Creation Namespace