Revit 2013 API
TypeBinding Members
TypeBinding Class Constructors Methods Properties See Also

The TypeBinding type exposes the following members.

Constructors

 | Name | Description
Public method | TypeBinding()()()() | Constructs an empty type binding.
Public method | TypeBinding(CategorySet) | Constructs a type binding with the set of categories passed.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Categories | Retrieve or set the categories to which a parameter definition will be bound. (Inherited from ElementBinding.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

TypeBinding Class