Revit 2013 API
IFCExtrusionCalculatorOptions Members
IFCExtrusionCalculatorOptions Class Constructors Methods Properties See Also

The IFCExtrusionCalculatorOptions type exposes the following members.

Constructors

 | Name | Description
Public method | IFCExtrusionCalculatorOptions | Constructs a new instance of a class used to calculate extrusions from Revit geometry.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the IFCExtrusionCalculatorOptions
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CustomAxis | The custom axis to try (if extrusionAxes includes an option for a custom direction).
Public property | ExtrusionAxes | The extrusion axes to try when doing the calculation.
Public property | Scale | The scaling factor for length measurements from the default Revit units to the export units.

See Also

IFCExtrusionCalculatorOptions Class
Autodesk.Revit.DB.IFC Namespace