Revit 2013 API
DXFExportOptions Members
DXFExportOptions Class Constructors Methods Properties See Also

The DXFExportOptions type exposes the following members.

Constructors

 | Name | Description
Public method | DXFExportOptions()()()() | Constructs a new instance of DXFImportOptions with default values of all properties.
Public method | DXFExportOptions(DXFExportOptions) | Constructs a new instance of DXFImportOptions as a copy of the export options.

Methods

 | Name | Description
Public method | Dispose | (Inherited from BaseExportOptions.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetPredefinedOptions | Returns an instance DXFExportOptions containing settings from a predefined export setup.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ACAPreference | The preferred way to generate geometry of ACA objects. Default value is ACAObjectPreference.Object. (Inherited from ACADExportOptions.)
Public property | Colors | Export color mode. Default value is ExportColorMode.IndexColors. (Inherited from BaseExportOptions.)
Public property | ExportingAreas | True to export area and room geometry, false otherwise. Default value is false. (Inherited from ACADExportOptions.)
Public property | ExportOfSolids | The mode used to export solids in 3D views. Default value is SolidGeometry.Polymesh. (Inherited from ACADExportOptions.)
Public property | FileVersion | ACADVersion::Default Default value is ACADVersion.Default. (Inherited from ACADExportOptions.)
Public property | HatchPatternsFileName | Custom hatch patterns (pat) file name. (Inherited from BaseExportOptions.)
Public property | HideReferencePlane | Whether or not to hide reference planes. Default value is false. (Inherited from BaseExportOptions.)
Public property | HideScopeBox | Whether or not to hide the scope box. Default value is false. (Inherited from BaseExportOptions.)
Public property | HideUnreferenceViewTags | Whether or not to hide unreference view tags. Default value is false. (Inherited from BaseExportOptions.)
Public property | LayerMapping | Name of a layer settings standard or filename (with custom layer settings). Valid standards are: AIA, CP83, BS1192, and ISO13567. default value is "" (empty) which means if no value is set, if no value is set, Revit will use a default value according to the localization. (Inherited from BaseExportOptions.)
Public property | LineScaling | The scaling mode for the line type. Default value is LineScaling.ViewScale. (Inherited from ACADExportOptions.)
Public property | LinetypesFileName | The custom linetype file name (*.lin). Default value is empty. (Inherited from ACADExportOptions.)
Public property | MarkNonplotLayers | If true and the nonplot layer suffix is not empty, all layers whose names contain that suffix will be marked as non-plot. (Inherited from ACADExportOptions.)
Public property | NonplotSuffix | If the MarkNonplotLayers attribute is set to true, all layers with names containing this suffix will be marked as non-plot. No action will be performed if the suffix is empty. (Inherited from ACADExportOptions.)
Public property | PropOverrides | How to export overridden object styles. Default value is PropOverrideMode.ByEntity. (Inherited from BaseExportOptions.)
Public property | SharedCoords | True to use the shared coordinate system's origin, false to use the project origin. Default value is false. (Inherited from ACADExportOptions.)
Public property | TargetUnit | The target unit type. Default value is ExportUnit.Default. (Inherited from ACADExportOptions.)
Public property | TextTreatment | The text treatment. Deault value is TextTreatment.Exact. (Inherited from ACADExportOptions.)

See Also

DXFExportOptions Class