Revit 2013 API
ExporterIFCUtils..::..GetConnectedWalls Method
ExporterIFCUtils Class See Also
Obtains the IFC-specific information regarding the connections between this wall and other elements.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static IList<IFCConnectedWallData> GetConnectedWalls(
    Wall pWallElem,
    IFCConnectedWallDataLocation locaction
)
Visual Basic
Public Shared Function GetConnectedWalls ( _
    pWallElem As Wall, _
    locaction As IFCConnectedWallDataLocation _
) As IList(Of IFCConnectedWallData)
Visual C++
public:
static IList<IFCConnectedWallData^>^ GetConnectedWalls(
    Wall^ pWallElem,
    IFCConnectedWallDataLocation locaction
)

Parameters

pWallElem
Type: Autodesk.Revit.DB..::..Wall
The wall.
locaction
Type: Autodesk.Revit.DB.IFC..::..IFCConnectedWallDataLocation
The location on the wall from where the connections should be obtained. This should be either IFCConnectedWallDataLocation.Start or IFCConnectedWallDataLocation.End.

Return Value

The connection information.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace