Revit 2013 API
FamilyParameter Members
FamilyParameter Class Methods Properties See Also

The FamilyParameter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssociatedParameters | The parameters from elements in the family which are associated to this parameter.
Public property | CanAssignFormula | Indicates if this parameter can be assigned a formula.
Public property | Definition | The definition.
Public property | DisplayUnitType | The display unit type.
Public property | Formula | The formula.
Public property | GUID | The globally unique identifier
Public property | Id | The id of the family parameter.
Public property | IsDeterminedByFormula | Indicates if the parameter is determined by formula.
Public property | IsInstance | Indicates if the parameter is instance or type.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsReporting | Indicates if the parameter is a reporting parameter.
Public property | StorageType | The storage type describes the type that is used internally within the parameter to store its value.

See Also

FamilyParameter Class