Revit 2013 API
Solid Properties
Solid Class See Also

The Solid type exposes the following members.

Properties

 | Name | Description
Public property | Edges | The edges that belong to the solid.
Public property | Faces | The faces that belong to the solid.
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle; (Inherited from GeometryObject.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | SurfaceArea | Returns the total surface area of this solid.
Public property | Visibility | The visibility. (Inherited from GeometryObject.)
Public property | Volume | Returns the signed volume of this solid.

See Also

Solid Class