Revit 2013 API
ColumnAttachment..::..IsValidTarget Method (FamilyInstance, Element)
ColumnAttachment Class See Also
Says whether the element can be used as a target for a new attachment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static bool IsValidTarget(
    FamilyInstance column,
    Element target
)
Visual Basic
Public Shared Function IsValidTarget ( _
    column As FamilyInstance, _
    target As Element _
) As Boolean
Visual C++
public:
static bool IsValidTarget(
    FamilyInstance^ column,
    Element^ target
)

Parameters

column
Type: Autodesk.Revit.DB..::..FamilyInstance
The column to attach. If the target is a beam or brace, the column will be checked to see if it is slanted. Otherwise, this argument is not used and may be omitted.
target
Type: Autodesk.Revit.DB..::..Element
A proposed target element for a column attachment.

Remarks

Valid targets are roofs, floors, and ceilings. Beams and braces are also valid targets, except for slanted columns.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ColumnAttachment Class
IsValidTarget Overload