Revit 2013 API
DWGImportOptions Members
DWGImportOptions Class Constructors Methods Properties See Also

The DWGImportOptions type exposes the following members.

Constructors

 | Name | Description
Public method | DWGImportOptions()()()() | Constructs a new instance of DWGImportOptions with default values of all properties.
Public method | DWGImportOptions(DWGImportOptions) | Constructs a new instance of DWGImportOptions as a copy of the import options.

Methods

 | Name | Description
Public method | Dispose | (Inherited from BaseImportOptions.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLayerSelection | Get all set layers name which user want to import into Revit. (Inherited from BaseImportOptions.)
Public method | GetLineWeights |
Public method | GetRefPoint | (Inherited from BaseImportOptions.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetLayerSelection | Set the layers name which user want to import into Revit. (Inherited from BaseImportOptions.)
Public method | SetLineWeights |
Public method | SetRefPoint | (Inherited from BaseImportOptions.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AutoCorrectAlmostVHLines | Correct almost-vertical lines and almost-horizontal lines for import model if option is set to true, the almost-vertical lines would be vertical lines and almost-horizontal lines would be horizontal lines. (Inherited from BaseImportOptions.)
Public property | ColorMode | Color mode for the import. Three modes are supported. Black and White, Preserve Colors, and Invert Colors. (Inherited from BaseImportOptions.)
Public property | CustomScale | Scaling the import. If this is defined and a valid value (> 0.0), it takes preference over units. (Inherited from BaseImportOptions.)
Public property | OrientToView | Place the import at the same orientation as the view that was passed into the import method. This option can only be used when not importing into a single view.(i.e. ThisViewOnly is set to false); (Inherited from BaseImportOptions.)
Public property | Placement | Where to place the import. Set this option to place the view at the origin or the center, or a shared coordinates. (Inherited from BaseImportOptions.)
Public property | ThisViewOnly | Imports drawings into the view that was passed into the import method. This option is not available in 3D views. (Inherited from BaseImportOptions.)
Public property | Unit | The unit of measure for imported geometry. (Inherited from BaseImportOptions.)
Public property | VisibleLayersOnly | Only import the visible layers. (Inherited from BaseImportOptions.)

See Also

DWGImportOptions Class