Revit 2013 API
IExporterIFC..::..ExportIFC Method
IExporterIFC Interface See Also
The method that Revit will invoke to perform an export to IFC.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
void ExportIFC(
    Document document,
    ExporterIFC exporter,
    View filterView
)
Visual Basic
Sub ExportIFC ( _
    document As Document, _
    exporter As ExporterIFC, _
    filterView As View _
)
Visual C++
void ExportIFC(
    Document^ document,
    ExporterIFC^ exporter,
    View^ filterView
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to export.
exporter
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The IFC exporter object.
filterView
Type: Autodesk.Revit.DB..::..View
The view whose filter visibility settings govern the export.

Remarks

There will be a transaction group opened for the document. Any changes made to the document must be temporary, as the transaction group will automatically be rolled back at the end.

See Also

IExporterIFC Interface
Autodesk.Revit.DB.IFC Namespace