Revit 2013 API
IFCFile..::..CreateInstance Method
IFCFile Class See Also
Creates an IFC instance in the file model.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IFCAnyHandle CreateInstance(
    string name
)
Visual Basic
Public Function CreateInstance ( _
    name As String _
) As IFCAnyHandle
Visual C++
public:
IFCAnyHandle^ CreateInstance(
    String^ name
)

Parameters

name
Type: System..::..String
The instance name.

Return Value

The instance handle.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCFile Class
Autodesk.Revit.DB.IFC Namespace