Revit 2013 API
DialogBoxData Members
DialogBoxData Class Methods Properties See Also

The DialogBoxData type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | OverrideResult | Call this method to cause the Autodesk Revit dialog to be dismissed with the specified return value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | HelpId | An ID that represents the dialog that has been displayed.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DialogBoxData Class
Autodesk.Revit.UI.Events Namespace