Revit 2013 API
Curve..::..MakeBound Method
Curve Class See Also
Changes the bounds of this curve to the specified values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void MakeBound(
    double startParameter,
    double endParameter
)
Visual Basic
Public Sub MakeBound ( _
    startParameter As Double, _
    endParameter As Double _
)
Visual C++
public:
void MakeBound(
    double startParameter,
    double endParameter
)

Parameters

startParameter
Type: System..::..Double
The new parameter of the start point.
endParameter
Type: System..::..Double
The new parameter of the end point.

Remarks

This method changes this curve to bound.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the specified values are infinite.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when endParameter is smaller than startParameter, or the object is internally marked as read-only.

See Also

Curve Class