Revit 2013 API
ReferenceWithContext Members
ReferenceWithContext Class Methods Properties See Also

The ReferenceWithContext type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ReferenceWithContext
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInstanceTransform | Gets the transform of the instance.
Public method | GetReference | Gets the reference of the geometric object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Proximity | The proximity value to the ray's origin when the reference is returned by FindReferencesWithContextByDirection(XYZ, XYZ, View3D) or ReferenceIntersector.Find(XYZ, XYZ).

See Also

ReferenceWithContext Class