Revit 2013 API
BoundaryConditions..::..Curve Property
BoundaryConditions Class See Also
Returns the geometric curve within a geometric loop that defines the area.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Curve this[
    int curveIndex
] { get; }
Visual Basic
Public ReadOnly Property Curve ( _
    curveIndex As Integer _
) As Curve
    Get
Visual C++
public:
property Curve^ Curve[int curveIndex] {
    Curve^ get (int curveIndex);
}

Parameters

curveIndex
Type: System..::..Int32
The index curve in the BoundaryConditions.

Return Value

If successful, returns the curve pointer. Otherwise returns nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

The curve index should be between 0 and NumCurves-1.

See Also

BoundaryConditions Class