Revit 2013 API
BuiltInFailures..::..CopyPasteFailures Members
BuiltInFailures..::..CopyPasteFailures Class Properties See Also

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..CopyPasteFailures type exposes the following members.

Properties

Name | Description
CannotCopyAttachedType | Cannot copy attached detail group type without copying the model group type it refers to.
CannotCopyAttachedTypeWarn | Cannot copy attached detail group type without copying the model group type it refers to.
CannotCopyBetweenFamilyAndProjectCorruption | Can't copy between Family and Project.
CannotCopyBetweenFamilyAndProjectError | Can't copy between Family and Project.
CannotCopyCurtainWallGridLines | Curtain wall grid lines currently cannot be copied.
CannotCopyDependentView | Dependent views cannot be copied.
CannotCopyDependentViewWarn | Dependent views cannot be copied.
CannotCopyDetails | Can't copy some or all of the detailing with the view.
CannotCopyDuplicates | Can't paste duplicate types. Only non duplicate types will be pasted.
CannotCopyElevationArrow | To duplicate Elevations, copy the elevation symbol in a plan view.
CannotCopyElevationArrowWarn | To duplicate Elevations, copy the elevation symbol in a plan view.
CannotCopyFaceHostedMonitoringElements | This instance is face-hosted and being managed by copy/monitor, so it cannot be copy/pasted. Use create similar to place a new instance instead.
CannotCopyFaceHostedMonitoringElementsWarn | This instance is face-hosted and being managed by copy/monitor, so it cannot be copy/pasted. Use create similar to place a new instance instead.
CannotCopyFamilyName | Can't [Action] because Family '[Family Name]' is different in the two documents. Update the documents to contain the same version of the Family.
CannotCopyFromProjectAndLink | Can't Copy to Clipboard elements from the project and a link instance at the same time. Only elements from the project will be copied.
CannotCopyGridLines | Curtain grid lines cannot be copied. If you are trying to copy the curtain wall, try using tab to select entire wall.
CannotCopyGridLinesWarn | Curtain grid lines cannot be copied. If you are trying to copy the curtain wall, try using tab to select entire wall.
CannotCopyHostedLoad | Can't copy Load based on the Host Element.
CannotCopyHostedLoadWarn | Can't copy Load based on the Host Element.
CannotCopyImportInstancesAcrossProjects | Linked Imported Files cannot be copied across projects. All non-RVT linked files will be pasted as imports instead.
CannotCopyIncompleteElement | Can't copy part of element
CannotCopyIncompleteElementWarn | Can't copy part of element
CannotCopyJoinedGeometry | Joined solid geometry cannot be copied as a whole. Instead, select the individual extrusions, etc., using Pick box or Ctrl-select and copy them.
CannotCopyJoinedGeometryWarn | Joined solid geometry cannot be copied as a whole. Instead, select the individual extrusions, etc., using Pick box or Ctrl-select and copy them.
CannotCopyLocked | Can't copy pinned element.
CannotCopyLockedWarn | Can't copy pinned element.
CannotCopyMassing | A massing cannot be copied. Copy the elements within the massing instead.
CannotCopyMassingWarn | A massing cannot be copied. Copy the elements within the massing instead.
CannotCopyMullions | Mullions and panels cannot be copied without copying the entire curtain wall.
CannotCopyMullionsError | Mullions and panels cannot be copied without copying the entire curtain wall.
CannotCopyMullionsWarn | Mullions and panels cannot be copied without copying the entire curtain wall.
CannotCopyMultipleSketchParents | Copying elements from unrelated Workplanes together is not supported in families. Try copying elements separately.
CannotCopyMustBeUnique | Element must be unique.
CannotCopyMustBeUniqueViewport | Multiple instances of the same view in sheets not supported.
CannotCopyMustBeUniqueViewportWarn | Multiple instances of the same view in sheets not supported.
CannotCopyMustBeUniqueWarn | Element must be unique.
CannotCopyNestedLinks | To copy a nested link, use Copy to Clipboard or Move Copy.
CannotCopyNoAttachedParent | Attached Detail Group can’t be copied without its Model Group
CannotCopyNoAttachedParentWarn | Attached Detail Group can’t be copied without its Model Group
CannotCopyNoParents | Can't Copy to Clipboard because of relationships between Elements
CannotCopyNoReferences | Elements can't be copied because they will lose their References.
CannotCopyProfile | Can't copy Profile.
CannotCopyProfileWarn | Can't copy Profile.
CannotCopyReferencePlane | Can't copy reference plane.
CannotCopyReferencePlaneWarn | Can't copy reference plane.
CannotCopyRevolveAxis | The axis cannot be copied.
CannotCopyRevolveAxisWarn | The axis cannot be copied.
CannotCopySelectedPick | The element being dragged can't be copied.
CannotCopySelection | Cannot copy selection.[Description]
CannotCopySketchGrid | Work Planes cannot be copied.
CannotCopySketchGridWarn | Work Planes cannot be copied.
CannotCopySunAndShadowSettings | SunAndShadowSettings cannot be copied.
CannotCopySunAndShadowSettingsWarn | SunAndShadowSettings cannot be copied.
CannotCopyWallPanels | Cannot copy wall panels unless their parent wall is also being copied.
CannotCopyWallPanelsWarn | Cannot copy wall panels unless their parent wall is also being copied.
CannotCopyZone | A Zone cannot be copied.
CannotCopyZoneWarn | A Zone cannot be copied.
CannotDuplicate | Elements can't be duplicated
CannotDuplicateDesignOption | Can't duplicate Design Option.
CannotDuplicateInOption | Elements can't be duplicated in a secondary Option
CannotDuplicateInOptionWarn | Elements can't be duplicated in a secondary Option
CannotDuplicateType | Cannot Duplicate Type.
CannotDuplicateWarn | Elements can't be duplicated
CannotFinalizeClusterInconsistency | Can't finalize because dependent element failed to finalize.
CannotFinalizeOrphanSerf | Can't finalize Group member without finalizing the entire Group.
CannotPasteAlignedAny | Can't Paste Aligned.
CannotPasteAlignedCorruption | Can't Paste Aligned these elements in this view.
CannotPasteAlignedError | Can't Paste Align these elements in this view.
CannotPasteAlignedSomeLevels | Can't Paste Aligned to some views.
CannotPasteCircularLinks | The pasted selection includes a linked instance of this file '[Name]'. A file cannot link itself, so the link was not pasted.
CannotPasteCurtainGridLine | Can't paste Curtain Grid Line.
CannotPasteDifferentViewSpecificElements | Cannot paste view-specific elements from different views.
CannotPasteInSketch | Can't paste elements into sketch.
CannotPasteInView | Can't paste current clipboard contents in [View Type] View. Switch to appropriate view to paste.
CannotPasteInViewError | Can't paste current clipboard contents in [View Type] View. Switch to appropriate view to paste.
CannotPasteModelPlusViewSpecificElementsIntoView | Cannot paste view-specific model plus into view.
CannotPasteNoLevelAbove | Can't paste these elements at this height because there is no Level above to Reference.
CannotPasteNoLevelBelow | Can't paste these elements at this height because there is no Level below to reference.
CannotPasteNoWorkplane | Can't paste because there is no corresponding Work Plane. Set workplane or switch to view with appropriate workplane.
CannotPasteToSheet | Elements copied to Sheets can only be copied from other Sheets.
CannotPasteViewSpecElemsFromDiffViews | Cannot paste view-specific elements from different views.
CannotTransferProjectStandards | These Project Standards cannot be transferred.[Description]
CantCopyBetweenModelAndAnnotFam | Can't copy element(s) between Model and Annotation families.
CantCopyElemsToInplaceFam | Can't copy element(s) to In Place family.
CantCopyFrom2dTo3dFam | Can't copy 2D element(s) into a 3D family.
CantCopyFrom3dTo2dFam | Can't copy 3D element(s) into a 2D family.
CantCopyFromDetailToProfileFam | Can't copy Detail element(s) into a Profile family.
CantCopyLevelsOrRefPlanesToNonMassFamily | Can't copy levels or reference planes to families that are not Mass families.
CopingColumnBeamFailure | The support order for a beam/column connection has been changed. When a beam is supported by a column that same beam cannot be coped by the column. The existing coping has been removed.
CopyImposterContentError | Cannot copy Render Appearance.
CopyImposterContentWarn | Cannot copy Render Appearance.
CopyImposterLightError | Light source cannot be copied!
CopyImposterLightWarn | Light source cannot be copied!
ElementRenamedOnPaste | The loaded type "[Name]" has been renamed to "[New Name]" to avoid conflicts with the existing type.
FinalizedElementsWillBeDeleted | Can't find new hosts for this Element.\nIt will be deleted on Finish Paste unless repositioned or rehosted.
FinalizedElementsWillBeDeletedWarn | Can't find new hosts for this Element.\nIt will be deleted on Finish Paste unless repositioned or rehosted.
FinalizedElementsWillBeModified | Can't find some new hosts for this Element.\nIt will lose references on Finish Paste unless repositioned or rehosted.
FinalizedElementsWillBeModifiedWarn | Can't find some new hosts for this Element.\nIt will lose references on Finish Paste unless repositioned or rehosted.
LostReference | A relationship between Elements in [Option Name] and [Reference Option Name] has been deleted. There is no corresponding relationship in the Primary [New Primary Option Name].
NoSketchPlane | Can't paste because no Work Plane is defined in the View.
PasteInvisibleInView | Selection is invisible in this view.
PasteInvisibleInViewWarn | The selection can’t be pasted because it is not visible in this view. Common causes and solutions The category is not visible in this view (make category visible) An annotation element falls outside this view’s annotation crop (temporarily disable annotation cropping) The element tagged by an annotation is not visible (check view extents and depth)
SomeElementsNotCopiedWarn | Some elements were not copied.[Description]

See Also

BuiltInFailures..::..CopyPasteFailures Class