Revit 2013 API
ExporterIFC..::..GetMaterialIdForCurrentExportState Method
ExporterIFC Class See Also
This gets the material id that is associated with the element in the current export state.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId GetMaterialIdForCurrentExportState()
Visual Basic
Public Function GetMaterialIdForCurrentExportState As ElementId
Visual C++
public:
ElementId^ GetMaterialIdForCurrentExportState()

Return Value

The material id.

Remarks

Even though there could be several materials associated with the element (set during PushExportState()), unless the element has support for IfcMaterialLayerSet, IFC output will include only this one.

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace