Revit 2013 API
BoundingBoxIntersectsFilter Constructor (Outline)
BoundingBoxIntersectsFilter Class See Also
Constructs a new instance of a filter to match elements with a bounding box that intersects the given Outline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public BoundingBoxIntersectsFilter(
    Outline outline
)
Visual Basic
Public Sub New ( _
    outline As Outline _
)
Visual C++
public:
BoundingBoxIntersectsFilter(
    Outline^ outline
)

Parameters

outline
Type: Autodesk.Revit.DB..::..Outline
The Outline used to find elements with a bounding box that intersect it.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | outline is an empty Outline.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

BoundingBoxIntersectsFilter Class
BoundingBoxIntersectsFilter Overload