Revit 2013 API
ApplicationEntryPoint Methods
ApplicationEntryPoint Class See Also

The ApplicationEntryPoint type exposes the following members.

Methods

 | Name | Description
Public method | CreateAddInCommandBinding |
Public method | CreateRibbonPanel(String) |
Public method | CreateRibbonPanel(String, String) |
Public method | CreateRibbonPanel(Tab, String) |
Public method | CreateRibbonTab |
 | DoDragDrop(ICollection<(Of <<'(String>)>>)) |
 | DoDragDrop(Object, IDropHandler) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FinishInitializationEO | For Revit Macros internal use only.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRibbonPanels()()()() |
Public method | GetRibbonPanels(String) |
Public method | GetRibbonPanels(Tab) |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | For Revit Macros internal use only.
Public method | OnShutdownEO | For Revit Macros internal use only.
Public method | OpenAndActivateDocument(String) |
Public method | OpenAndActivateDocument(ModelPath, OpenOptionsForUI) |
Public method | RemoveAddInCommandBinding |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ApplicationEntryPoint Class
Autodesk.Revit.UI.Macros Namespace