Revit 2013 API
FamilyItemFactory Methods
FamilyItemFactory Class See Also

The FamilyItemFactory type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | NewAlignment | Add a new locked alignment into the Autodesk Revit document. (Inherited from ItemFactoryBase.)
Public method | NewAngularDimension(View, Arc, Reference, Reference) | Creates a new angular dimension object using the default dimension type.
Public method | NewAngularDimension(View, Arc, Reference, Reference, DimensionType) | Creates a new angular dimension object using the specified dimension type.
Public method | NewAnnotationSymbol | Obsolete. Add a new instance of an Annotation Symbol into the Autodesk Revit document, using an origin and a view where the instance should be placed. (Inherited from ItemFactoryBase.)
Public method | NewArcLengthDimension(View, Arc, Reference, Reference, Reference) | Creates a new arc length dimension object using the default dimension type.
Public method | NewArcLengthDimension(View, Arc, Reference, Reference, Reference, DimensionType) | Creates a new arc length dimension object using the specified dimension type.
Public method | NewBlend | Add a new Blend instance into the Autodesk Revit family document.
Public method | NewControl | Add a new control into the Autodesk Revit family document.
Public method | NewCurveByPoints | Create a 3d curve through two or more points in an Autodesk Revit family document.
Public method | NewDetailCurve | Creates a new detail curve element. (Inherited from ItemFactoryBase.)
Public method | NewDetailCurveArray | Creates an array of new detail curve elements. (Inherited from ItemFactoryBase.)
Public method | NewDiameterDimension | Creates a new diameter dimension object using the default dimension type.
Public method | NewDimension(View, Line, ReferenceArray) | Creates a new linear dimension object using the default dimension style. (Inherited from ItemFactoryBase.)
Public method | NewDimension(View, Line, ReferenceArray, DimensionType) | Creates a new linear dimension object using the specified dimension style. (Inherited from ItemFactoryBase.)
Public method | NewDividedSurface | Create a DividedSurface element on one surface of another element.
Public method | NewDuctConnector | Obsolete. Add a new duct connector into the Autodesk Revit family document.
Public method | NewElectricalConnector | Obsolete. Add a new Electrical connector into the Autodesk Revit family document.
Public method | NewExtrusion | Add a new Extrusion instance into the Autodesk Revit family document.
Public method | NewExtrusionForm | Create new Form element by Extrude operation, and add it into the Autodesk Revit family document.
Public method | NewFamilyInstance(Face, Line, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a line on that face for its position, and a type/symbol. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(Line, FamilySymbol, View) | Add a line based detail family instance into the Autodesk Revit document, using an line and a view where the instance should be placed. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(Reference, Line, FamilySymbol) | Inserts a new instance of a family onto a face referenced by the input Reference instance, using a line on that face for its position, and a type/symbol. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(XYZ, FamilySymbol, StructuralType) | Inserts a new instance of a family into the document, using a location and a type/symbol. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(XYZ, FamilySymbol, View) | Add a new family instance into the Autodesk Revit document, using an origin and a view where the instance should be placed. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(Face, XYZ, XYZ, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a location, reference direction, and a type/symbol. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(Reference, XYZ, XYZ, FamilySymbol) | Inserts a new instance of a family onto a face referenced by the input Reference instance, using a location, reference direction, and a type/symbol. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(XYZ, FamilySymbol, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, and the host element. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(XYZ, FamilySymbol, XYZ, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, the host element and a reference direction. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstances | Obsolete. Creates Family instances within the document. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstances2 | Creates Family instances within the document. (Inherited from ItemFactoryBase.)
Public method | NewFormByCap | Create new Form element by cap operation (to create a single-surface form), and add it into the Autodesk Revit family document.
Public method | NewFormByThickenSingleSurface | Create a new Form element by thickening a single-surface form, and add it into the Autodesk Revit family document.
Public method | NewGroup(ICollection<(Of <<'(ElementId>)>>)) | Creates a new type of group. (Inherited from ItemFactoryBase.)
Public method | NewGroup(ElementSet) | Obsolete. Creates a new type of group. (Inherited from ItemFactoryBase.)
Public method | NewLevel | Creates a new level. (Inherited from ItemFactoryBase.)
Public method | NewLinearDimension(View, Line, ReferenceArray) | Generate a new linear dimension object using the default dimension type.
Public method | NewLinearDimension(View, Line, ReferenceArray, DimensionType) | Creates a new linear dimension object using the specified dimension type.
Public method | NewLoftForm | Create new Form element by Loft operation, and add it into the Autodesk Revit family document.
Public method | NewModelCurve | Creates a new model line element. (Inherited from ItemFactoryBase.)
Public method | NewModelCurveArray | Creates an array of new model line elements. (Inherited from ItemFactoryBase.)
Public method | NewModelText | Create a model text in the Autodesk Revit family document.
Public method | NewOpening | Create an opening to cut the wall or ceiling.
Public method | NewPipeConnector | Obsolete. Add a new pipe connector into the Autodesk Revit family document.
Public method | NewRadialDimension(View, Reference, XYZ) | Creates a new radial dimension object using the default dimension type.
Public method | NewRadialDimension(View, Reference, XYZ, DimensionType) | Generate a new radial dimension object using a specified dimension type.
Public method | NewReferencePlane | Creates a new instance of ReferencePlane. (Inherited from ItemFactoryBase.)
Public method | NewReferencePlane2 | Creates a new instance of ReferencePlane. (Inherited from ItemFactoryBase.)
Public method | NewReferencePoint(PointElementReference) | Create a reference point on an existing reference in an Autodesk Revit family document.
Public method | NewReferencePoint(Transform) | Create a reference point at a given location and with a given coordinate system in an Autodesk Revit family document.
Public method | NewReferencePoint(XYZ) | Create a reference point at a given location in an Autodesk Revit family document.
Public method | NewRevolution | Add a new Revolution instance into the Autodesk Revit family document.
Public method | NewRevolveForms | Create new Form elements by revolve operation, and add them into the Autodesk Revit family document.
Public method | NewSketchPlane(PlanarFace) | Creates a new sketch plane on a planar face of existing geometry. (Inherited from ItemFactoryBase.)
Public method | NewSketchPlane(Plane) | Creates a new sketch plane from an arbitrary geometric plane. (Inherited from ItemFactoryBase.)
Public method | NewSketchPlane(Reference) | Creates a new sketch plane on a reference to existing planar geometry. (Inherited from ItemFactoryBase.)
Public method | NewSweep(Boolean, ReferenceArray, SweepProfile, Int32, ProfilePlaneLocation) | Adds a new sweep form into the family document, using an array of selected references as a 3D path.
Public method | NewSweep(Boolean, CurveArray, SketchPlane, SweepProfile, Int32, ProfilePlaneLocation) | Adds a new sweep form to the family document, using a path of curve elements.
Public method | NewSweptBlend(Boolean, Reference, SweepProfile, SweepProfile) | Adds a new swept blend into the family document, using a selected reference as the path.
Public method | NewSweptBlend(Boolean, Curve, SketchPlane, SweepProfile, SweepProfile) | Add a new swept blend into the family document, using a curve as the path.
Public method | NewSweptBlendForm | Create new Form element by swept blend operation, and add it into the Autodesk Revit family document.
Public method | NewSymbolicCurve | Create a symbolic curve in an Autodesk Revit family document.
Public method | NewTextNote(View, XYZ, XYZ, XYZ, Double, TextAlignFlags, String) | Creates a new TextNote object without a leader. (Inherited from ItemFactoryBase.)
Public method | NewTextNote(View, XYZ, XYZ, XYZ, Double, TextAlignFlags, TextNoteLeaderTypes, TextNoteLeaderStyles, XYZ, XYZ, String) | Creates a new text note with a single leader. (Inherited from ItemFactoryBase.)
Public method | NewTextNotes | Obsolete. Creates TextNotes with the specified data. (Inherited from ItemFactoryBase.)
Public method | NewView3D | Obsolete. Creates a new 3D view. (Inherited from ItemFactoryBase.)
Public method | NewViewPlan | Obsolete. Creates a plan view based on the specified level. (Inherited from ItemFactoryBase.)
Public method | NewViewSection | Obsolete. Creates a new section view. (Inherited from ItemFactoryBase.)
Public method | PlaceGroup | Place an instance of a Model Group into the Autodesk Revit document, using a location and a group type. (Inherited from ItemFactoryBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace