Revit 2013 API
FileImportedEventArgs Members
FileImportedEventArgs Class Methods Properties See Also

The FileImportedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RevitAPIEventArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs.)
Public property | Document | The document associated with the event. (Inherited from RevitAPIPostDocEventArgs.)
Public property | Format | Identifies the import format, e.g. DWG or image.
Public property | ImportedInstanceId | The ElementId of the imported instance that represents the imported object(s) after a successful import. It could be used for further manipulation of that instance.
Public property | Path | Path of the source file that was imported.
Public property | Status | Indicates whether the action associated with this event succeeded, failed, or was cancelled (by an API event handler). (Inherited from RevitAPIPostEventArgs.)

See Also

FileImportedEventArgs Class
Autodesk.Revit.DB.Events Namespace