Revit 2013 API
RenderingQualitySettings..::..AreDoorsDaylightPortals Property
RenderingQualitySettings Class See Also
Indicates whether doors daylight portals.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool AreDoorsDaylightPortals { get; set; }
Visual Basic
Public Property AreDoorsDaylightPortals As Boolean
    Get
    Set
Visual C++
public:
property bool AreDoorsDaylightPortals {
    bool get ();
    void set (bool value);
}

Remarks

Set this property to true when sunlighting coming through a door looks splotchy, this can slow down rendering but helps for rooms with few places for sunlight to enter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The RenderingQualitySettings does not use custom quality currently. To use custom quality, set RenderingQuality property to RenderingQuality.Custom.

See Also

RenderingQualitySettings Class