Revit 2013 API
IFCLevelInfo..::..Create Method
IFCLevelInfo Class See Also
Creates an IFCLevelInfo.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static IFCLevelInfo Create(
    IFCAnyHandle buildingStorey,
    IFCAnyHandle localPlacement,
    double height,
    double elevation,
    double scaleFactor,
    bool isPrimaryLevel
)
Visual Basic
Public Shared Function Create ( _
    buildingStorey As IFCAnyHandle, _
    localPlacement As IFCAnyHandle, _
    height As Double, _
    elevation As Double, _
    scaleFactor As Double, _
    isPrimaryLevel As Boolean _
) As IFCLevelInfo
Visual C++
public:
static IFCLevelInfo^ Create(
    IFCAnyHandle^ buildingStorey,
    IFCAnyHandle^ localPlacement,
    double height,
    double elevation,
    double scaleFactor,
    bool isPrimaryLevel
)

Parameters

buildingStorey
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The building storey handle (IfcBuildingStorey).
localPlacement
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The local placement handle (IfcLocalPlacement).
height
Type: System..::..Double
The height of the level.
elevation
Type: System..::..Double
The elevation of the level.
scaleFactor
Type: System..::..Double
The scale factor.
isPrimaryLevel
Type: System..::..Boolean
True if this is primary level, false otherwise.

Return Value

The IFCLevelInfo object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCLevelInfo Class
Autodesk.Revit.DB.IFC Namespace