Revit 2013 API
WorksharingDisplaySettings..::..SetGraphicOverrides Method (ModelUpdatesStatus, WorksharingDisplayGraphicSettings)
WorksharingDisplaySettings Class See Also
Sets the graphic overrides assigned to elements with a particular status in the central model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void SetGraphicOverrides(
    ModelUpdatesStatus status,
    WorksharingDisplayGraphicSettings overrides
)
Visual Basic
Public Sub SetGraphicOverrides ( _
    status As ModelUpdatesStatus, _
    overrides As WorksharingDisplayGraphicSettings _
)
Visual C++
public:
void SetGraphicOverrides(
    ModelUpdatesStatus status,
    WorksharingDisplayGraphicSettings^ overrides
)

Parameters

status
Type: Autodesk.Revit.DB..::..ModelUpdatesStatus
The status in the central model.
overrides
Type: Autodesk.Revit.DB..::..WorksharingDisplayGraphicSettings
The desired graphic overrides for this status.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

WorksharingDisplaySettings Class
SetGraphicOverrides Overload