Revit 2013 API
Edge..::..AsCurve Method
Edge Class See Also
Returns a curve that corresponds to the edge's parametric orientation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Curve AsCurve()
Visual Basic
Public Function AsCurve As Curve
Visual C++
public:
Curve^ AsCurve()

Return Value

It can be an Arc, Line, or HermiteSpline.

See Also

Edge Class