Revit 2013 API
BuildingSiteExportOptions Members
BuildingSiteExportOptions Class Constructors Methods Properties See Also

The BuildingSiteExportOptions type exposes the following members.

Constructors

 | Name | Description
Public method | BuildingSiteExportOptions | Default constructor. Sets all options to their default values.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AreaPerPerson | Custom value for Area Per Person value.
Public property | PropertyLine | Optional property Line to export; it may be nullNothingnullptra null reference (Nothing in Visual Basic).
Public property | PropertyLineOffset | Property Line Offset. Default is 0.0.
Public property | TotalGrossArea | Custom value for the total area.
Public property | TotalOccupancy | Custom value for the total occupancy.

See Also

BuildingSiteExportOptions Class