Revit 2013 API
ElementMulticategoryFilter Members
ElementMulticategoryFilter Class Constructors Methods Properties See Also

The ElementMulticategoryFilter type exposes the following members.

Constructors

 | Name | Description
Public method | ElementMulticategoryFilter(ICollection<(Of <<'(BuiltInCategory>)>>)) | Constructs a new instance of a filter to match elements by built-in category.
Public method | ElementMulticategoryFilter(ICollection<(Of <<'(ElementId>)>>)) | Constructs a new instance of a filter to find elements whose category matches any of a given set of categories.
Public method | ElementMulticategoryFilter(ICollection<(Of <<'(BuiltInCategory>)>>), Boolean) | Constructs a new instance of a filter to match elements by built-in category, with the option to match all elements which are not of the given category.
Public method | ElementMulticategoryFilter(ICollection<(Of <<'(ElementId>)>>), Boolean) | Constructs a new instance of a filter to find elements whose category matches any of a given set of categories, with the option to match all elements which are of the given categories.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCategoryIds | Gets the category ids assigned to this filter.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

ElementMulticategoryFilter Class