Revit 2013 API
CompoundStructure..::..GetOffsetForLocationLine Method
CompoundStructure Class See Also
Returns the offset from the center of the compound structure to the given location line value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double GetOffsetForLocationLine(
    WallLocationLine wallLocationLine
)
Visual Basic
Public Function GetOffsetForLocationLine ( _
    wallLocationLine As WallLocationLine _
) As Double
Visual C++
public:
double GetOffsetForLocationLine(
    WallLocationLine wallLocationLine
)

Parameters

wallLocationLine
Type: Autodesk.Revit.DB..::..WallLocationLine
The alignment type of the wall's location line.

Return Value

The offset.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is valid only vertically homogeneous compound structures.

See Also

CompoundStructure Class