Revit 2013 API
IFCTypeInfo..::..Set3DMapHandle Method
IFCTypeInfo Class See Also
Sets the associated handle to a 3D IfcRepresentationMap for the type.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void Set3DMapHandle(
    IFCAnyHandle representationMapHandle
)
Visual Basic
Public Sub Set3DMapHandle ( _
    representationMapHandle As IFCAnyHandle _
)
Visual C++
public:
void Set3DMapHandle(
    IFCAnyHandle^ representationMapHandle
)

Parameters

representationMapHandle
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The handle.

Remarks

Typically used only for Building Element Proxy elements (masses).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCTypeInfo Class
Autodesk.Revit.DB.IFC Namespace