Revit 2013 API
ElectricalSetting Members
ElectricalSetting Class Methods Properties See Also

The ElectricalSetting type exposes the following members.

Methods

 | Name | Description
Public method | AddDistributionSysType | Add a new distribution system type to project.
Public method | AddVoltageType | Add a new type definition of voltage into project.
Public method | AddWireMaterialType | Add a new type of wire material.
Public method | AddWireType | Add a new wire type to project.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RemoveDistributionSysType | Remove an existing distribution system type from the project.
Public method | RemoveVoltageType | Remove the voltage type from project.
Public method | RemoveWireMaterialType | Remove the wire material type from project.
Public method | RemoveWireType | Remove wire type definition from project.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DistributionSysTypes | Get all distribution system types of the project.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | VoltageTypes | Get all voltage type definitions information of the project.
Public property | WireConduitTypes | Get electrical conduit types information of the project.
Public property | WireMaterialTypes | Get electrical wire material types information of the project.
Public property | WireTypes | Get all wire type definition information of the project.

See Also

ElectricalSetting Class
Autodesk.Revit.DB.Electrical Namespace