Revit 2013 API
Rebar Methods
Rebar Class See Also

The Rebar type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | CreateFromCurves | Creates a new instance of a Rebar element within the project.
 | CreateFromCurvesAndShape | Creates a new instance of a Rebar element within the project. The instance will have the default shape parameters from the RebarShape.
 | CreateFromRebarShape | Creates a new Rebar, as an instance of a RebarShape. The instance will have the default shape parameters from the RebarShape, and its location is based on the bounding box of the shape in the shape definition. Hooks are removed from the shape before computing its bounding box. If appropriate hooks can be found in the document, they will be assigned arbitrarily.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | DoesBarExistAtPosition | Checks whether a bar exists at the specified position.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetBarPositionTransform | Return a transform representing the relative position of any individual bar in the set.
Public method | GetBendData | Gets the RebarBendData, containing bar and hook information, of the instance.
Public method | GetCenterlineCurves(Boolean) | Obsolete. A chain of curves representing the centerline of the rebar.
Public method | GetCenterlineCurves(Boolean, Boolean, Boolean) | A chain of curves representing the centerline of the rebar.
Public method | GetDistributionPath | The distribution path of a rebar set.
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHookTypeId | Get the id of the RebarHookType to be applied to the rebar.
Public method | GetHostId | The element that contains the rebar.
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSolidInView | Checks if this rebar element is shown solidly in a 3D view.
Public method | IsUnobscuredInView | Checks if this rebar element is shown unobscured in a view.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
 | RebarShapeMatchesCurvesAndHooks | Checks if rebarShape matches curves and hooks.
Public method | ScaleToBox | Move and resize the bar to fit within a specified box. The arguments are interpreted as an arbitrary rectangle in 3D with vertices: origin, origin+xVec, origin+xVec+yVec, origin+yVec. The algorithm then proceeds as follows. First the bar is given the default values of the shape parameters from the shape definition. Then, if it is possible to do so without violating the shape definition, the parameter values are scaled so that the width and height of the shape match the lengths of xVec and yVec. If there is no way to do this within the shape definition due to overconstraining, a compromise is attempted, such as scaling the whole shape until either the width or the height is correct. Finally the shape is rotated to match the coordinate system of the box. The algorithm is the same one used in one-click placement.
Public method | ScaleToBoxFor3D | Move and resize a spiral or multiplanar instance to fit within a specified box. The arguments are interpreted as an arbitrary rectangle in 3D with vertices: origin, origin+xVec, origin+xVec+yVec, origin+yVec. One end of the rebar shape is inscribed in this rectangle. The other end is placed in the parallel plane at distance given by the height argument, in the direction of xVec cross yVec. This method replaces ScaleToBoxForSpiral() from prior releases.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetHookTypeId | Set the id of the RebarHookType to be applied to the rebar.
Public method | SetHostId | The element that contains the rebar.
Public method | SetLayoutAsFixedNumber | Sets the Layout Rule property of rebar set to FixedNumber.
Public method | SetLayoutAsMaximumSpacing | Sets the Layout Rule property of rebar set to MaximumSpacing
Public method | SetLayoutAsMinimumClearSpacing | Sets the Layout Rule property of rebar set to MinimumClearSpacing
Public method | SetLayoutAsNumberWithSpacing | Sets the Layout Rule property of rebar set to NumberWithSpacing
Public method | SetLayoutAsSingle | Sets the Layout Rule property of rebar set to Single.
Public method | SetSolidInView | Sets this rebar element to be shown solidly in a 3D view.
Public method | SetUnobscuredInView | Sets this rebar element to be shown unobscured in a view.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace