Revit 2013 API
SunAndShadowSettings..::..GetSunset Method
SunAndShadowSettings Class See Also
Identifies the sunset time for the SunAndShadowSettings element at its current location and indicated date.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public DateTime GetSunset(
    DateTime date
)
Visual Basic
Public Function GetSunset ( _
    date As DateTime _
) As DateTime
Visual C++
public:
DateTime GetSunset(
    DateTime date
)

Parameters

date
Type: System..::..DateTime
The date for which to determine sunset time.

Return Value

The date and time. The value will be in Coordinated Universal Time (UTC).

Remarks

The value returned is affected by the value of the UsesDST flag set for the current location. If this value is true, the sunset value will be adjusted for Daylight Savings Time, regardless of the value of the input date.

See Also

SunAndShadowSettings Class