Revit 2013 API
AddInIdAttribute Members
AddInIdAttribute Class Constructors Methods Properties See Also

The AddInIdAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | AddInIdAttribute | Constructs a new AddInIdAttribute.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | Value | AddInId guid value.

See Also

AddInIdAttribute Class
Autodesk.Revit.UI.Macros Namespace