Revit 2013 API
EnergyDataSettings..::..MassZoneCoreOffset Property
EnergyDataSettings Class See Also
It defines the default behavior for the automatic generation of Mass Zones for each Mass Floor in the Project. Specifying a value here will offset the outside perimeter of a Mass Zone to create the core.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public double MassZoneCoreOffset { get; set; }
Visual Basic
Public Property MassZoneCoreOffset As Double
    Get
    Set
Visual C++
public:
property double MassZoneCoreOffset {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The mass zone core offset is less than zero.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace