Revit 2013 API
ImageExportOptions..::..FilePath Property
ImageExportOptions Class See Also
The file name and path for the exported file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public string FilePath { get; set; }
Visual Basic
Public Property FilePath As String
    Get
    Set
Visual C++
public:
property String^ FilePath {
    String^ get ();
    void set (String^ value);
}

Remarks

If ExportRange is SetOfViews, the name of each view or sheet will be appended to the name provided for each exported file. This field is ignored if used to save an image to a project as a new view.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property:
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

ImageExportOptions Class