Revit 2013 API
SpatialElementBoundarySubface Members
SpatialElementBoundarySubface Class Methods Properties See Also

The SpatialElementBoundarySubface type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the SpatialElementBoundarySubface
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBoundingElementFace | Returns the face of the bounding element.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSpatialElementFace | Returns the face of the spatial element's 3D geometry.
Public method | GetSubface | Returns a face that represents the portion of the room face bounded by the boundary element.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | SpatialBoundaryElement | Element that gave rise to this room face.
Public property | SubfaceArisesFromElementFace | Indicates if the subface is coincident with a portion of a (possibly offset) face of the element.
Public property | SubfaceType | Type of the subface.

See Also

SpatialElementBoundarySubface Class