Revit 2013 API
PanelScheduleView..::..GetParamValue Method
PanelScheduleView Class See Also
Gets the cell's text based on its type

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string GetParamValue(
    SectionType sectionType,
    int nRow,
    int nCol
)
Visual Basic
Public Function GetParamValue ( _
    sectionType As SectionType, _
    nRow As Integer, _
    nCol As Integer _
) As String
Visual C++
public:
String^ GetParamValue(
    SectionType sectionType,
    int nRow,
    int nCol
)

Parameters

sectionType
Type: Autodesk.Revit.DB..::..SectionType
Section of the desired parameter value
nRow
Type: System..::..Int32
Row Number of the Section
nCol
Type: System..::..Int32
Column Number of the Section

Return Value

The cell's text

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown if there is no parameter at this cell
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown if attempt to call on a template

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace