Revit 2013 API
ElectricalSystem..::..SelectPanel Method
ElectricalSystem Class See Also
Set the panel for the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SelectPanel(
    FamilyInstance panel
)
Visual Basic
Public Sub SelectPanel ( _
    panel As FamilyInstance _
)
Visual C++
public:
void SelectPanel(
    FamilyInstance^ panel
)

Parameters

panel
Type: Autodesk.Revit.DB..::..FamilyInstance
The panel of the electrical system.

Remarks

If successful, the panel will be set for the system. Otherwise the exception will be thrown. This method will only function with the Autodesk Revit MEP application.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the panel parameter Value is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the panel cannot be set for the electrical system.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace