Revit 2013 API
EnergyDataSettings..::..BuildingConstructionClass Property
EnergyDataSettings Class See Also
Used for both the detailed and conceptual energy model Construction class of building as defined by: loose, medium, tight, or none.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public HVACLoadConstructionClass BuildingConstructionClass { get; set; }
Visual Basic
Public Property BuildingConstructionClass As HVACLoadConstructionClass
    Get
    Set
Visual C++
public:
property HVACLoadConstructionClass BuildingConstructionClass {
    HVACLoadConstructionClass get ();
    void set (HVACLoadConstructionClass value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The building construction class does not fall within an appropriate range.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace