Revit 2013 API
FamilyType Members
FamilyType Class Methods Properties See Also

The FamilyType type exposes the following members.

Methods

 | Name | Description
Public method | AsDouble | Provides access to the double precision number of the given family parameter.
Public method | AsElementId | Provides access to the Autodesk::Revit::DB::ElementId^ stored in the given family parameter.
Public method | AsInteger | Provides access to the integer number of the given family parameter.
Public method | AsString | Provides access to the string contents of the given family parameter.
Public method | AsValueString | Provides access to value as a string with unit in the given family parameter.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasValue | Indicates if this family parameter has an assigned value or not.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | The name of the family type.

See Also

FamilyType Class