Revit 2013 API
Mesh Members
Mesh Class Methods Properties See Also

The Mesh type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code; (Inherited from GeometryObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle; (Inherited from GeometryObject.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | MaterialElementId | Element ID of the material from which this mesh is composed.
Public property | NumTriangles | The number of triangles that the mesh contains.
Public property | Transformed | Transforms this mesh and returns the result.
Public property | Triangle | Retrieves a specific triangle.
Public property | Vertices | Retrieves all vertices used to define this mesh. Intended for indexed access.
Public property | Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Mesh Class