Revit 2013 API
DGNExportOptions Members
DGNExportOptions Class Constructors Methods Properties See Also

The DGNExportOptions type exposes the following members.

Constructors

 | Name | Description
Public method | DGNExportOptions()()()() | Constructs a new instance of DGNExportOptions with default values of all properties.
Public method | DGNExportOptions(DGNExportOptions) | Constructs a new instance of DGNExportOptions as a copy of the export options.

Methods

 | Name | Description
Public method | Dispose | (Inherited from BaseExportOptions.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetPredefinedOptions | Returns an instance DGNExportOptions containing settings from a predefined export setup.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Colors | Export color mode. Default value is ExportColorMode.IndexColors. (Inherited from BaseExportOptions.)
Public property | FileVersion | The DGN file version. Default value of fileVersion is DGNFileFormat.Default.
Public property | HatchPatternsFileName | Custom hatch patterns (pat) file name. (Inherited from BaseExportOptions.)
Public property | HideReferencePlane | Whether or not to hide reference planes. Default value is false. (Inherited from BaseExportOptions.)
Public property | HideScopeBox | Whether or not to hide the scope box. Default value is false. (Inherited from BaseExportOptions.)
Public property | HideUnreferenceViewTags | Whether or not to hide unreference view tags. Default value is false. (Inherited from BaseExportOptions.)
Public property | LayerMapping | Name of a layer settings standard or filename (with custom layer settings). Valid standards are: AIA, CP83, BS1192, and ISO13567. default value is "" (empty) which means if no value is set, if no value is set, Revit will use a default value according to the localization. (Inherited from BaseExportOptions.)
Public property | MasterUnits | The master units. Default value of masterUnits is true.
Public property | MergedViews | Whether to merge all views in one file (via XRefs). Default value of mergedViews is false.
Public property | PropOverrides | How to export overridden object styles. Default value is PropOverrideMode.ByEntity. (Inherited from BaseExportOptions.)
Public property | SeedName | The name of the DGN seed. Default value of seedName is empty.

See Also

DGNExportOptions Class