Revit 2013 API
CompoundStructure..::..IsSimpleRegion Method
CompoundStructure Class See Also
Determines whether the region is a simple region in this CompoundStructure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsSimpleRegion(
    int regionId
)
Visual Basic
Public Function IsSimpleRegion ( _
    regionId As Integer _
) As Boolean
Visual C++
public:
bool IsSimpleRegion(
    int regionId
)

Parameters

regionId
Type: System..::..Int32
The id of a region in this vertically compound structure.

Return Value

True if the region is simple, false otherwise.

Remarks

A region is simple if it rectangular and spans the height of the wall.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | It is not a valid region id.
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is valid only vertically compound structures.

See Also

CompoundStructure Class