Revit 2013 API
CompoundStructure..::..SetDeckEmbeddingType Method
CompoundStructure Class See Also
Sets the deck embedding type to use for the specified structural deck.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetDeckEmbeddingType(
    int layerIdx,
    StructDeckEmbeddingType embedType
)
Visual Basic
Public Sub SetDeckEmbeddingType ( _
    layerIdx As Integer, _
    embedType As StructDeckEmbeddingType _
)
Visual C++
public:
void SetDeckEmbeddingType(
    int layerIdx,
    StructDeckEmbeddingType embedType
)

Parameters

layerIdx
Type: System..::..Int32
Index of a layer in the CompoundStructure.
embedType
Type: Autodesk.Revit.DB..::..StructDeckEmbeddingType
The embedding type to be used by the specified layer if it is a structural deck.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The layer is not a structural deck.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The layer index is out of range.

See Also

CompoundStructure Class