Revit 2013 API
RoutingPreferenceManager Members
RoutingPreferenceManager Class Methods Properties See Also

The RoutingPreferenceManager type exposes the following members.

Methods

 | Name | Description
Public method | AddRule(RoutingPreferenceRuleGroupType, RoutingPreferenceRule) | Adds a new routing preference rule to the rule group.
Public method | AddRule(RoutingPreferenceRuleGroupType, RoutingPreferenceRule, Int32) | Adds a new routing preference rule to the specified position in the rule group.
Public method | Dispose | Releases all resources used by the RoutingPreferenceManager
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMEPPartId | Gets a fitting or segment id of given routing preference group that meets the specified routing conditions.
Public method | GetNumberOfRules | The number of RoutingPreference rules in a group.
Public method | GetRule | Gets the specified rule.
Public method | GetSharedSizes | Gets a list of all segments of a given profile shape that define a given size.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RemoveRule | Removes an existing routing preference rule. Thrown if the index is out of bounds.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | OwnerId | The Id of the MEPCurveType that owns the RoutingPreferenceManager
Public property | PreferredJunctionType | The preferred junction type.

See Also

RoutingPreferenceManager Class