Revit 2013 API
RebarShapeConstraintFixedSegmentDir Constructor
RebarShapeConstraintFixedSegmentDir Class See Also
Create a fixed segment direction constraint.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public RebarShapeConstraintFixedSegmentDir(
    UV dir
)
Visual Basic
Public Sub New ( _
    dir As UV _
)
Visual C++
public:
RebarShapeConstraintFixedSegmentDir(
    UV^ dir
)

Parameters

dir
Type: Autodesk.Revit.DB..::..UV
A fixed direction in UV-space.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

RebarShapeConstraintFixedSegmentDir Class
Autodesk.Revit.DB.Structure Namespace