Revit 2013 API
StairsRunType..::..TreadNosingPosition Property
StairsRunType Class See Also
Represents on which edges of the nosing to apply the nosing profile.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public TreadNosingPosition TreadNosingPosition { get; set; }
Visual Basic
Public Property TreadNosingPosition As TreadNosingPosition
    Get
    Set
Visual C++
public:
property TreadNosingPosition TreadNosingPosition {
    TreadNosingPosition get ();
    void set (TreadNosingPosition value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The run type has no tread so the data being set is not applicable.

See Also

StairsRunType Class
Autodesk.Revit.DB.Architecture Namespace