Revit 2013 API
RenderingQualitySettings..::..ImagePrecision Property
RenderingQualitySettings Class See Also
A value that controls how antialiasing is applied to the background image.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int ImagePrecision { get; set; }
Visual Basic
Public Property ImagePrecision As Integer
    Get
    Set
Visual C++
public:
property int ImagePrecision {
    int get ();
    void set (int value);
}

Remarks

Increase this value to smooth out jagged edges in the rendering.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The image precision value is not valid. The valid range is 0 to 10.
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The RenderingQualitySettings does not use custom quality currently. To use custom quality, set RenderingQuality property to RenderingQuality.Custom.

See Also

RenderingQualitySettings Class