Revit 2013 API
ElementMulticlassFilter Members
ElementMulticlassFilter Class Constructors Methods Properties See Also

The ElementMulticlassFilter type exposes the following members.

Constructors

 | Name | Description
Public method | ElementMulticlassFilter(IList<(Of <<'(Type>)>>)) | Constructs a filter using multiple types
Public method | ElementMulticlassFilter(IList<(Of <<'(Type>)>>), Boolean) | Constructs a filter using multiple types

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

ElementMulticlassFilter Class