Revit 2013 API
PrintSetup..::..SaveAs Method
PrintSetup Class See Also
Save the current print setting to another print setting with the specified name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool SaveAs(
    string newName
)
Visual Basic
Public Function SaveAs ( _
    newName As String _
) As Boolean
Visual C++
public:
bool SaveAs(
    String^ newName
)

Parameters

newName
Type: System..::..String
print setting name to be saved as.

Return Value

False if Save As operation fails, otherwise true.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the input newName already exists in current print setting list.

See Also

PrintSetup Class