Revit 2013 API
AddInId Methods
AddInId Class See Also

The AddInId type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAddInName | name of addin associated with this AddInId Attempts to obtain the name from loaded Third Party AddIns
Public method | GetAddInNameFromDocument | name of application associated with this ApplicationId First attempts to obtain the name from AddInIds stored in the document. If unsuccessful, attempts to obtain the name from loaded Third Party AddIns.
Public method | GetGUID | value of the AddInId as a GUID
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AddInId Class