Revit 2013 API
Space Members
Space Class Methods Properties See Also

The Space type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetBoundarySegments | Returns the boundary segments. (Inherited from SpatialElement.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsPointInSpace | Determines if a point lies within the volume of the Space.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ActualExhaustAirflow | Get the Actual Exhaust Airflow of the Space.
Public property | ActualHVACLoad | Get or set the Actual HVAC Load of the Space.
Public property | ActualLightingLoad | Get the Actual Lighting Load of the Space.
Public property | ActualOtherLoad | Get or set the Actual Other Load of the Space.
Public property | ActualPowerLoad | Get the Actual Power Load of the Space.
Public property | ActualReturnAirflow | Get or set the Actual Return Airflow of the Space.
Public property | ActualSupplyAirflow | Get or set the Actual Supply Airflow of the Space.
Public property | Area | The area. (Inherited from SpatialElement.)
Public property | AreaperPerson | Get the Area per Person of the Space.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | AverageEstimatedIllumination | Get the Average Estimated Illumination of the Space.
Public property | BaseHeatLoadOn | The heat load-on.
Public property | BaseOffset | Get or Set the Base Offset of the Space.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CalculatedCoolingLoad | Get the Calculated Cooling Load of the Space.
Public property | CalculatedHeatingLoad | Get the Calculated Heating Load of the Space.
Public property | CalculatedSupplyAirflow | Get or set the Calculated Supply Airflow of the Space.
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CeilingReflectance | Get or set the Ceiling Reflectance of the Space.
Public property | ClosedShell | Return the closedShell of the space.
Public property | ConditionType | Get or set the Condition type of the Space.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignCoolingLoad | Get the Design Cooling Load of the Space.
Public property | DesignExhaustAirflow | Get or set the Specified Exhaust Airflow of the Space.
Public property | DesignHeatingLoad | Get the Design Heating Load of the Space.
Public property | DesignHVACLoadperArea | Get or set the Design HVAC Load per Area of the Space.
Public property | DesignLightingLoad | Get or set the Design Lighting Load of the Space.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | DesignOtherLoadperArea | Get or set the Design Other Load per Area of the Space.
Public property | DesignPowerLoad | Get or set the Design Power Load of the Space.
Public property | DesignReturnAirflow | Get or set the Specified Return Airflow of the Space.
Public property | DesignSupplyAirflow | Get or set the Specified Supply Airflow of the Space.
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FloorReflectance | Get or set the Floor Reflectance of the Space.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | LatentHeatGainperPerson | Get or set the Latent Heat Gain per Person of the Space.
Public property | Level | Gets the level of the room. (Inherited from SpatialElement.)
Public property | LightingCalculationWorkplane | Get the Lighting Calculation Workplane of the Space.
Public property | LightingLoadUnit | Get or Set the Lighting Load Unit of the Space.
Public property | LimitOffset | Get or Set the Limit Offset of the Space.
Public property | Location | The location of the element. (Inherited from SpatialElement.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from SpatialElement.)
Public property | Number | The number. (Inherited from SpatialElement.)
Public property | NumberofPeople | Get the Number of People of the Space.
Public property | OccupancyUnit | Get the Occupancy Unit of the Space.
Public property | Occupiable | Reports whether this zone is Occupiable or not.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Perimeter | The perimeter. (Inherited from SpatialElement.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Plenum | Reports whether this zone is Plenum or not.
Public property | PowerLoadUnit | Get or Set the Power Load Unit of the Space.
Public property | ReturnAirflow | Get or set the Return type of Supply Airflow of the Space.
Public property | Room | Return the Room of the space.
Public property | SensibleHeatGainperPerson | Get the Sensible Heat Gain per Person of the Space.
Public property | SpaceCavityRatio | Get the Space Cavity Ratio of the Space.
Public property | SpaceConstruction | Get the Space Construction of the Space.
Public property | SpaceType | Get or set the Space type of the Space.
Public property | UnboundedHeight | Get the Unbounded Height of the Space.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UpperLimit | Get or Set the Upper Limit of the Space.
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Volume | Get the Volume of the Space.
Public property | WallReflectance | Get or set the Wall Reflectance of the Space.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)
Public property | Zone | Reports this space belong to which Zone.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace