Revit 2013 API
BuiltInFailures..::..RenderFailures Members
BuiltInFailures..::..RenderFailures Class Properties See Also

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..RenderFailures type exposes the following members.

Properties

Name | Description
LightParametersNotInRange | The value should be in range of [Value] and [Value].
LightSourceInsideGeometry | Light source is inside solid geometry. No light will be emitted during rendering.
ProhibitDeletionLightSource | The light source cannot be deleted with UI.
RenderLibNotInstalledWarn | Rendering library has not been installed, so the third party geometry cannot be created.

See Also

BuiltInFailures..::..RenderFailures Class