Revit 2013 API
PointCloudEngineRegistry Members
PointCloudEngineRegistry Class Methods See Also

The PointCloudEngineRegistry type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the PointCloudEngineRegistry
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetSupportedEngines | Returns a list of the identifiers supported by point cloud engines registered to Revit.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsEngineFileBased | Identifies if a given engine is file-based.
 | RegisterPointCloudEngine | Registers a new point cloud engine and associates it to a particular file extension.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | UnregisterPointCloudEngine | Unregisters the point cloud engine associated to a particular identifier.

See Also

PointCloudEngineRegistry Class
Autodesk.Revit.DB.PointClouds Namespace