Revit 2013 API
IFCProductWrapper..::..Create Method (IFCProductWrapper, Boolean)
IFCProductWrapper Class See Also
Establishes a new product manager for elements and objects derived from a parent product manager, allowing override of allowRelateToLevel

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static IFCProductWrapper Create(
    IFCProductWrapper pProductWrapper,
    bool allowRelateToLevel
)
Visual Basic
Public Shared Function Create ( _
    pProductWrapper As IFCProductWrapper, _
    allowRelateToLevel As Boolean _
) As IFCProductWrapper
Visual C++
public:
static IFCProductWrapper^ Create(
    IFCProductWrapper^ pProductWrapper,
    bool allowRelateToLevel
)

Parameters

pProductWrapper
Type: Autodesk.Revit.DB.IFC..::..IFCProductWrapper
The parent product manager.
allowRelateToLevel
Type: System..::..Boolean
True to allow associated elements and objects to relate to a level, false to never allow such a relationship.

Return Value

The new product manager.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCProductWrapper Class
Create Overload
Autodesk.Revit.DB.IFC Namespace