Revit 2013 API
AdaptiveComponentFamilyUtils Methods
AdaptiveComponentFamilyUtils Class See Also

The AdaptiveComponentFamilyUtils type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetNumberOfAdaptivePoints | Gets number of Adaptive Point Elements in Adaptive Component Family.
 | GetNumberOfPlacementPoints | Gets number of Placement Point Elements in Adaptive Component Family.
 | GetNumberOfShapeHandlePoints | Gets number of Shape Handle Point Elements in Adaptive Component Family.
 | GetPlacementNumber | Gets Placement number of an Adaptive Placement Point.
 | GetPointConstraintType | Gets constrain type of an Adaptive Shape Handle Point.
 | GetPointOrientationType | Gets orientation type of an Adaptive Placement Point.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsAdaptiveComponentFamily | Verifies if the Family is an Adaptive Component Family.
 | IsAdaptivePlacementPoint | Verifies if the Reference Point is an Adaptive Placement Point.
 | IsAdaptivePoint | Verifies if the Reference Point is an Adaptive Point.
 | IsAdaptiveShapeHandlePoint | Verifies if the Reference Point is an Adaptive Shape Handle Point.
 | MakeAdaptivePoint | Makes Reference Point an Adaptive Point or makes an Adaptive Point a Reference Point.
 | SetPlacementNumber | Sets Placement Number of an Adaptive Placement Point.
 | SetPointConstraintType | Sets constrain type of an Adaptive Shape Handle Point.
 | SetPointOrientationType | Sets orientation type of an Adaptive Placement Point.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AdaptiveComponentFamilyUtils Class