Revit 2013 API
CurveLoopIterator..::..Current Property
CurveLoopIterator Class See Also
Gets the item at the current position of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public virtual Curve Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Curve
    Get
Visual C++
public:
virtual property Curve^ Current {
    Curve^ get ();
}

Implements

IEnumerator<(Of <(<'T>)>)>..::..Current

Remarks

There is no current item if the iterator has not started yet or has been done.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | There is no current item in the iterator.

See Also

CurveLoopIterator Class