Revit 2013 API
AdvancedLossFactor Members
AdvancedLossFactor Class Constructors Methods Properties See Also

The AdvancedLossFactor type exposes the following members.

Constructors

 | Name | Description
Public method | AdvancedLossFactor()()()() | Creates an advanced loss factor object with values set to no loss.
Public method | AdvancedLossFactor(AdvancedLossFactor) | Creates a copy of the given advanced loss factor object
Public method | AdvancedLossFactor(Double, Double, Double, Double, Double, Double, Double) | Creates an advanced loss factor object with the given values.

Methods

 | Name | Description
Public method | Clone | Creates a copy of the LossFactor derived object. (Inherited from LossFactor.)
Public method | Dispose | (Inherited from LossFactor.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BallastLossFactor | The ballast loss factor.
Public property | LampLumenDepreciation | The lamp lumen depreciation loss factor.
Public property | LampTiltLossFactor | The lamp tilt loss factor.
Public property | LossFactorValue | The calculated loss factor value; (Inherited from LossFactor.)
Public property | LuminaireDirtDepreciation | The luminaire dirt depreciation loss factor.
Public property | SurfaceDepreciationLossFactor | The surface depreciation loss factor.
Public property | TemperatureLossFactor | The temperature loss factor.
Public property | VoltageLossFactor | The voltage loss factor.

See Also

AdvancedLossFactor Class
Autodesk.Revit.DB.Lighting Namespace