Revit 2013 API
ConicalFace Class
Members Example See Also
A cone face of a 3d solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class ConicalFace : Face
Visual Basic
Public Class ConicalFace _
    Inherits Face
Visual C++
public ref class ConicalFace : public Face

Remarks

Cone faces are defined by cone surfaces bounded by edge loops. The surfaces provide natural UV parameterization to the faces. S(u, v) = Origin + v*[sin(HalfAngle)*(cos(u)*Radius[0] + sin(u)*Radius[1]) + cos(HalfAngle)*Axis]

Examples

CopyC#
private void GetConicalFaceInfo(Face face)
{
    ConicalFace conicalFace = face as ConicalFace;
    if (null != conicalFace)
    {
       XYZ axis = conicalFace.Axis;
       XYZ origin = conicalFace.Origin;
        double halfAngle = conicalFace.HalfAngle;
        XYZ radius = conicalFace.get_Radius(0);
    }
}
CopyVB.NET
Private Sub GetConicalFaceInfo(ByVal face As Autodesk.Revit.DB.Face)
    Dim conicalFace As ConicalFace = TryCast(face, ConicalFace)
    If conicalFace IsNot Nothing Then
        Dim axis As Autodesk.Revit.DB.XYZ = conicalFace.Axis
        Dim origin As Autodesk.Revit.DB.XYZ = conicalFace.Origin
        Dim halfAngle As Double = conicalFace.HalfAngle
        Dim radius As Autodesk.Revit.DB.XYZ = conicalFace.Radius(0)
    End If
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..GeometryObject
Autodesk.Revit.DB..::..Face
Autodesk.Revit.DB..::..ConicalFace

See Also

ConicalFace Members