Revit 2013 API
CurveElement..::..GetLineStyleIds Method
CurveElement Class See Also
Retrieves the set of available line style Element Ids.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ICollection<ElementId> GetLineStyleIds()
Visual Basic
Public Function GetLineStyleIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetLineStyleIds()

Return Value

A collection of ElementIds of line styles. The members will be the ids of GraphicsStyle elements. These graphics styles should be associated to subcategories of the BuiltInCategory OST_Lines.

See Also

CurveElement Class