Revit 2013 API
View..::..IsValidViewTemplate Method
View Class See Also
Verify that %templateId% can be view template for this view: it can be invalidElementId or represent template view that is compatible with this view

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsValidViewTemplate(
    ElementId templateId
)
Visual Basic
Public Function IsValidViewTemplate ( _
    templateId As ElementId _
) As Boolean
Visual C++
public:
bool IsValidViewTemplate(
    ElementId^ templateId
)

Parameters

templateId
Type: Autodesk.Revit.DB..::..ElementId
Id to be validated as view template.

Return Value

True if %templateId% is valid as view template, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

View Class