Revit 2013 API
ItemFactoryBase..::..NewReferencePlane Method
ItemFactoryBase Class Example See Also
Creates a new instance of ReferencePlane.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ReferencePlane NewReferencePlane(
    XYZ bubbleEnd,
    XYZ freeEnd,
    XYZ cutVec,
    View pView
)
Visual Basic
Public Function NewReferencePlane ( _
    bubbleEnd As XYZ, _
    freeEnd As XYZ, _
    cutVec As XYZ, _
    pView As View _
) As ReferencePlane
Visual C++
public:
ReferencePlane^ NewReferencePlane(
    XYZ^ bubbleEnd,
    XYZ^ freeEnd,
    XYZ^ cutVec,
    View^ pView
)

Parameters

bubbleEnd
Type: Autodesk.Revit.DB..::..XYZ
The bubble end applied to reference plane.
freeEnd
Type: Autodesk.Revit.DB..::..XYZ
The free end applied to reference plane.
cutVec
Type: Autodesk.Revit.DB..::..XYZ
The cut vector apply to reference plane, should perpendicular to the vector (bubbleEnd-freeEnd).
pView
Type: Autodesk.Revit.DB..::..View
The specific view apply to the Reference plane.

Return Value

The newly created reference plane.

Examples

CopyC#
// Define data for reference plane creation
XYZ bubbleEnd = new XYZ(1, 0, 0);   // bubble end applied to reference plane
XYZ freeEnd = new XYZ(-5, 0, 0);    // free end applied to reference plane
// Cut vector should be perpendicular to bubbleEnd-freeEnd vector
XYZ cutVec = new XYZ(0, 0, 1);  // cut vector applied to reference plane

// Create the reference plane, applying the active view
ReferencePlane refPlane = document.Create.NewReferencePlane(bubbleEnd, freeEnd, cutVec, document.ActiveView);
CopyVB.NET
' Define data for reference plane creation
Dim bubbleEnd As New Autodesk.Revit.DB.XYZ(1, 0, 0)
' bubble end applied to reference plane
Dim freeEnd As New Autodesk.Revit.DB.XYZ(-5, 0, 0)
' free end applied to reference plane
' Cut vector should be perpendicular to bubbleEnd-freeEnd vector
Dim cutVec As New Autodesk.Revit.DB.XYZ(0, 0, 1)
' cut vector applied to reference plane
' Create the reference plane, applying the active view
Dim refPlane As ReferencePlane = document.Create.NewReferencePlane(bubbleEnd, freeEnd, cutVec, document.ActiveView)

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace