Revit 2013 API
DefinitionBindingMap Members
DefinitionBindingMap Class Constructors Methods Properties See Also

The DefinitionBindingMap type exposes the following members.

Constructors

 | Name | Description
Public method | DefinitionBindingMap | Initializes a new instance of the DefinitionBindingMap class

Methods

 | Name | Description
Public method | Clear | Removes every binding from the map, rendering it empty.
Public method | Contains |
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the map.
Public method | GetEnumerator | Retrieve a forward moving iterator to the map.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the map.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the map is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item |
Public property | Size | Returns the number of bindings that are in the map.

See Also

DefinitionBindingMap Class