Revit 2013 API
BoundingBoxContainsPointFilter Members
BoundingBoxContainsPointFilter Class Constructors Methods Properties See Also

The BoundingBoxContainsPointFilter type exposes the following members.

Constructors

 | Name | Description
Public method | BoundingBoxContainsPointFilter(XYZ) | Constructs a new instance of a filter to match elements with a bounding box that contains the given point.
Public method | BoundingBoxContainsPointFilter(XYZ, Boolean) | Constructs a new instance of a filter to match elements with a bounding box that contains the given point, with the option to invert the filter and match all elements with a bounding box that do not contain the given point.
Public method | BoundingBoxContainsPointFilter(XYZ, Double) | Constructs a new instance of a filter to match elements with a bounding box that contains the given point.
Public method | BoundingBoxContainsPointFilter(XYZ, Double, Boolean) | Constructs a new instance of a filter to match elements with a bounding box that contains the given point, with the option to invert the filter and match all elements with a bounding box that do not contain the given point.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | Point | The XYZ point to use when matching element bounding boxes.
Public property | Tolerance | Allows control over the match criteria by using a tolerance in the geometry comparison. It is suggested to use this in cases where trivial differences should be considered when matching elements.

See Also

BoundingBoxContainsPointFilter Class