Revit 2013 API
AnalysisDisplayLegendSettings Members
AnalysisDisplayLegendSettings Class Constructors Methods Properties See Also

The AnalysisDisplayLegendSettings type exposes the following members.

Constructors

 | Name | Description
Public method | AnalysisDisplayLegendSettings()()()() | Constructs a default instance of legend settings.
Public method | AnalysisDisplayLegendSettings(AnalysisDisplayLegendSettings) | Constructs a copy of legend settings object.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the AnalysisDisplayLegendSettings
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual | Compares two legend settings objects.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ColorRangeHeight | Height of color range (for Colored Surface, Markers and Text, and Vector display). Measured in paperspace units.
Public property | ColorRangeWidth | Width of color range (for Colored Surface, Markers and Text, and Vector display). Measured in paperspace units.
Public property | HeadingTextTypeId | Element id of text associated with legend heading.
Public property | NumberForScale | A fixed value to display on the legend scale (0 by default; 0 means width of legend scale is calculated dynamically).
Public property | NumberOfSteps | Number of steps (values between minimum and maximum) to be shown in legend.
Public property | Rounding | Rounding increment for numeric values of analysis results.
Public property | ScaleHeight | Height of scale (for Diagram display). Measured in paperspace units.
Public property | ShowDataDescription | If true, data description is shown in the legend.
Public property | ShowDataName | If true, data name is shown in the legend.
Public property | ShowLegend | If true, legend is shown in the view.
Public property | ShowUnits | If true, units are shown in the legend.
Public property | TextTypeId | Element id of text associated with legend body.

See Also

AnalysisDisplayLegendSettings Class
Autodesk.Revit.DB.Analysis Namespace