Revit 2013 API
BuiltInFailures..::..GenericMEPFailures Properties
BuiltInFailures..::..GenericMEPFailures Class See Also

The BuiltInFailures..::..GenericMEPFailures type exposes the following members.

Properties

Name | Description
FlowConfigMismatch | [Element Name]: It is not possible to calculate the flow since all the components in this system have the flow configuration set to Preset or System. At least one component is required to have the flow configuration set to Calculated.
FlowDirectionMismatch | [Element Name]: It is not possible to calculate the flow since the flow direction mismatch. Please check flow direction on all equipment in this system.
MaxWidthAndHeightReached | Maximum width and height reached during sizing
SegmentIsTooShort | The segment is too short.
SizingFailedZeroFlow | Sizing failed. Flow for section is 0.
ValidatePHSegmentConnWarning | The placeholder curve will not be able to connect to the required fittings for placeholder convert
ValidatePHSegmentLengthWarning | The placeholder curve is not long enough to support the required fittings for placeholder convert

See Also

BuiltInFailures..::..GenericMEPFailures Class