Revit 2013 API
SchemaBuilder..::..Finish Method
SchemaBuilder Class See Also
Registers and returns the created Schema object.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public Schema Finish()
Visual Basic
Public Function Finish As Schema
Visual C++
public:
Schema^ Finish()

Return Value

The newly created Schema.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The SchemaBuilder has already finished building the Schema. -or- A different Schema with a matching identity already exists. -or- Two fields with the same name are detected. -or- At least one field has invalid units. -or- SchemaName is not set. -or- VendorId is not set for a restricted access level. -or- ApplicationGUID is not set for an application access level.

See Also

SchemaBuilder Class
Autodesk.Revit.DB.ExtensibleStorage Namespace