Revit 2013 API
Solid Class
Members Example See Also
A 3d solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class Solid : GeometryObject
Visual Basic
Public Class Solid _
    Inherits GeometryObject
Visual C++
public ref class Solid : public GeometryObject

Remarks

A solid is defined by the faces and edges that form its boundary.

Examples

CopyC#
private void GetAndTransformSolidInfo(Application application, Element element, Options geoOptions)
{
    // Get geometry element of the selected element
    Autodesk.Revit.DB.GeometryElement geoElement = element.get_Geometry(geoOptions);

    // Get geometry object
    foreach (GeometryObject geoObject in geoElement.Objects)
    {
        // Get the geometry instance which contains the geometry information
        Autodesk.Revit.DB.GeometryInstance instance = geoObject as Autodesk.Revit.DB.GeometryInstance;
        if (null != instance)
        {
            foreach (GeometryObject instObj in instance.SymbolGeometry.Objects)
            {
                Solid solid = instObj as Solid;
                if (null == solid || 0 == solid.Faces.Size || 0 == solid.Edges.Size)
                {
                    continue;
                }

                Transform instTransform = instance.Transform;
                // Get the faces and edges from solid, and transform the formed points
                foreach (Face face in solid.Faces)
                {
                    Mesh mesh = face.Triangulate();
                    foreach (XYZ ii in mesh.Vertices)
                    {
                       XYZ point = ii;
                        XYZ transformedPoint = instTransform.OfPoint(point);
                    }
                }
                foreach (Edge edge in solid.Edges)
                {
                   foreach (XYZ ii in edge.Tessellate())
                    {
                       XYZ point = ii;
                        XYZ transformedPoint = instTransform.OfPoint(point);
                    }
                }
            }
        }
    }

}
CopyVB.NET
Private Sub GetAndTransformSolidInfo(ByVal application As Application, ByVal element As Autodesk.Revit.DB.Element, ByVal geoOptions As Autodesk.Revit.DB.Options)
    ' Get geometry element of the selected element
    Dim geoElement As Autodesk.Revit.DB.GeometryElement = element.Geometry(geoOptions)

    ' Get geometry object
    For Each geoObject As GeometryObject In geoElement.Objects
        ' Get the geometry instance which contains the geometry information
        Dim instance As Autodesk.Revit.DB.GeometryInstance = TryCast(geoObject, Autodesk.Revit.DB.GeometryInstance)
        If instance IsNot Nothing Then
            For Each instObj As GeometryObject In instance.SymbolGeometry.Objects
                Dim solid As Solid = TryCast(instObj, Solid)
                If solid Is Nothing OrElse 0 = solid.Faces.Size OrElse 0 = solid.Edges.Size Then
                    Continue For
                End If

                Dim instTransform As Transform = instance.Transform
                ' Get the faces and edges from solid, and transform the formed points
                For Each face As Autodesk.Revit.DB.Face In solid.Faces
                    Dim mesh As Mesh = face.Triangulate()
                    For Each ii As Autodesk.Revit.DB.XYZ In mesh.Vertices
                        Dim point As Autodesk.Revit.DB.XYZ = ii
                        Dim transformedPoint As Autodesk.Revit.DB.XYZ = instTransform.OfPoint(point)
                    Next
                Next
                For Each edge As Autodesk.Revit.DB.Edge In solid.Edges
                    For Each ii As Autodesk.Revit.DB.XYZ In edge.Tessellate()
                        Dim point As Autodesk.Revit.DB.XYZ = ii
                        Dim transformedPoint As Autodesk.Revit.DB.XYZ = instTransform.OfPoint(point)
                    Next
                Next
            Next
        End If
    Next

End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..GeometryObject
Autodesk.Revit.DB..::..Solid

See Also

Solid Members