Revit 2013 API
RebarHostData Methods
RebarHostData Class See Also

The RebarHostData type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAreaReinforcementsInHost | Returns all AreaReinforcement elements hosted by the referenced element.
Public method | GetCommonCoverType | If all exposed faces of the host have the same associated CoverType, return that CoverType; otherwise, return nullNothingnullptra null reference (Nothing in Visual Basic).
Public method | GetCoverType | Gets the CoverType associated with a face of the element.
Public method | GetExposedFaces | Returns all the exposed faces, that is, those that have an associated CoverType.
Public method | GetFabricAreasInHost | Returns all FabricArea elements hosted by the referenced element.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPathReinforcementsInHost | Returns all PathReinforcement elements hosted by the referenced element.
 | GetRebarHostData | Gets a RebarHostData object referring to the specified rebar host element.
Public method | GetRebarsInHost | Returns all Rebar elements hosted by the referenced element.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsFaceExposed | Checks whether the specified face is considered exposed, and therefore has an associated CoverType.
Public method | IsValidHost | Reports whether the element is a valid rebar host.
Public method | SetCommonCoverType | Associate a single CoverType with all exposed faces of the host element.
Public method | SetCoverType | Associates the specified CoverType with the specified face of the element.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarHostData Class
Autodesk.Revit.DB.Structure Namespace