Revit 2013 API
StairsRunType..::..UndersideSurfaceStyle Property
StairsRunType Class See Also
The underside surface style of the stairs run, only available for monolithic stairs run.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public StairsUndersideSurfaceStyle UndersideSurfaceStyle { get; set; }
Visual Basic
Public Property UndersideSurfaceStyle As StairsUndersideSurfaceStyle
    Get
    Set
Visual C++
public:
property StairsUndersideSurfaceStyle UndersideSurfaceStyle {
    StairsUndersideSurfaceStyle get ();
    void set (StairsUndersideSurfaceStyle value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The stairs run type is not a monolithic type so the data being set is not applicable.

See Also

StairsRunType Class
Autodesk.Revit.DB.Architecture Namespace