Revit 2013 API
ScheduleDefinition..::..AddField Method (ScheduleFieldType, ElementId)
ScheduleDefinition Class See Also
Adds a regular (non-calculated) field at the end of the list.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ScheduleField AddField(
    ScheduleFieldType fieldType,
    ElementId parameterId
)
Visual Basic
Public Function AddField ( _
    fieldType As ScheduleFieldType, _
    parameterId As ElementId _
) As ScheduleField
Visual C++
public:
ScheduleField^ AddField(
    ScheduleFieldType fieldType,
    ElementId^ parameterId
)

Parameters

fieldType
Type: Autodesk.Revit.DB..::..ScheduleFieldType
The type of data displayed by the field.
parameterId
Type: Autodesk.Revit.DB..::..ElementId
The ID of the parameter displayed by the field.

Return Value

The new field.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | The field specified by fieldType and parameterId may not included in this ScheduleDefinition. -or- The field specified by fieldType and parameterId is already included in this ScheduleDefinition.

See Also

ScheduleDefinition Class
AddField Overload