Revit 2013 API
FamilyInstance..::..StructuralType Property
FamilyInstance Class Example See Also
Provides the primary structural type of the instance, such as beam or column etc.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public StructuralType StructuralType { get; }
Visual Basic
Public ReadOnly Property StructuralType As StructuralType
    Get
Visual C++
public:
property StructuralType StructuralType {
    StructuralType get ();
}

Examples

CopyC#
public void GetStructuralType(FamilyInstance familyInstance)
{
    string message = "";
    switch (familyInstance.StructuralType)
    {
        case StructuralType.Beam:
            message = "FamilyInstance is a beam.";
            break;
        case StructuralType.Brace:
            message = "FamilyInstance is a brace.";
            break;
        case StructuralType.Column:
            message = "FamilyInstance is a column.";
            break;
        case StructuralType.Footing:
            message = "FamilyInstance is a footing.";
            break;
        default:
            message = "FamilyInstance is non-structural or unknown framing.";
            break;
    }

    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Public Sub GetStructuralType(ByVal familyInstance As Autodesk.Revit.DB.FamilyInstance)
    Dim message As String = ""
    Select Case familyInstance.StructuralType
        Case Autodesk.Revit.DB.Structure.StructuralType.Beam
            message = "FamilyInstance is a beam."
            Exit Select
        Case Autodesk.Revit.DB.Structure.StructuralType.Brace
            message = "FamilyInstance is a brace."
            Exit Select
        Case Autodesk.Revit.DB.Structure.StructuralType.Column
            message = "FamilyInstance is a column."
            Exit Select
        Case Autodesk.Revit.DB.Structure.StructuralType.Footing
            message = "FamilyInstance is a footing."
            Exit Select
        Case Else
            message = "FamilyInstance is non-structural or unknown framing."
            Exit Select
    End Select

    TaskDialog.Show("Revit", message)
End Sub

See Also

FamilyInstance Class