Revit 2013 API
WireSize Members
WireSize Class Methods Properties See Also

The WireSize type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Ampacity | Get ampacity which be used for specifying size, the unit is ampere.
Public property | Diameter | Get diameter of wire.
Public property | InUse | Get or set whether the size can be used in sizing.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Get size symbol of wire.

See Also

WireSize Class
Autodesk.Revit.DB.Electrical Namespace