Revit 2013 API
ExporterIFCUtils..::..GetLoopsFromTopBottomFace Method
ExporterIFCUtils Class See Also
Gets the curve loop(s) that represent the bottom or top face of the wall.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static IList<CurveLoop> GetLoopsFromTopBottomFace(
    ExporterIFC exporterIFC,
    Wall wall
)
Visual Basic
Public Shared Function GetLoopsFromTopBottomFace ( _
    exporterIFC As ExporterIFC, _
    wall As Wall _
) As IList(Of CurveLoop)
Visual C++
public:
static IList<CurveLoop^>^ GetLoopsFromTopBottomFace(
    ExporterIFC^ exporterIFC,
    Wall^ wall
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
wall
Type: Autodesk.Revit.DB..::..Wall
The wall.

Return Value

The curve loops. If the function has failed, this collection will be empty.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace