Revit 2013 API
View..::..SupportsWorksharingDisplayMode Method
View Class See Also
Checks whether this view supports the given worksharing display mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool SupportsWorksharingDisplayMode(
    WorksharingDisplayMode mode
)
Visual Basic
Public Function SupportsWorksharingDisplayMode ( _
    mode As WorksharingDisplayMode _
) As Boolean
Visual C++
public:
bool SupportsWorksharingDisplayMode(
    WorksharingDisplayMode mode
)

Parameters

mode
Type: Autodesk.Revit.DB..::..WorksharingDisplayMode
The mode of interest.

Return Value

Returns True if this view is a graphical view in a workshared document or if the desired mode is Off. Returns False if this view is a non-graphical view (such as a schedule or the project browser) or if this view is not in a workshared document.

Remarks

For convenience, the "Off" mode is always supported. Other display modes are supported by graphical views in workshared documents.

See Also

View Class