Revit 2013 API
UV..::..IsAlmostEqualTo Method (UV, Double)
UV Class See Also
Determines whether this 2-D vector and the specified 2-D vector are the same within a specified tolerance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsAlmostEqualTo(
    UV source,
    double tolerance
)
Visual Basic
Public Function IsAlmostEqualTo ( _
    source As UV, _
    tolerance As Double _
) As Boolean
Visual C++
public:
bool IsAlmostEqualTo(
    UV^ source,
    double tolerance
)

Parameters

source
Type: Autodesk.Revit.DB..::..UV
The vector to compare with this vector.
tolerance
Type: System..::..Double
The tolerance for equality check.

Return Value

True if the vectors are the same; otherwise, false.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when source is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when tolerance is less than 0.

See Also

UV Class
IsAlmostEqualTo Overload