Revit 2013 API
PropertySetElement..::..Duplicate Method
PropertySetElement Class See Also
Creates a duplicate of this PropertySetElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public PropertySetElement Duplicate(
    Document document,
    string name
)
Visual Basic
Public Function Duplicate ( _
    document As Document, _
    name As String _
) As PropertySetElement
Visual C++
public:
PropertySetElement^ Duplicate(
    Document^ document,
    String^ name
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which to create the PropertySetElement.
name
Type: System..::..String
The name to use for the new PropertySetElement.

Return Value

The new PropertySetElement.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given value for name is already in use as a property set name. -or- name is an empty string. -or- name cannot include prohibited characters.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PropertySetElement Class