Revit 2013 API
FieldDomainPointsByUV Members
FieldDomainPointsByUV Class Constructors Methods See Also

The FieldDomainPointsByUV type exposes the following members.

Constructors

 | Name | Description
Public method | FieldDomainPointsByUV(IList<(Of <<'(UV>)>>)) | Creates object from an array of two-dimensional point coordinates
Public method | FieldDomainPointsByUV(IList<(Of <<'(UV>)>>), ICollection<(Of <<'(Double>)>>), ICollection<(Of <<'(Double>)>>)) | Creates object from an array of two-dimensional point coordinates

Methods

 | Name | Description
Public method | Dispose | (Inherited from FieldDomainPoints.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetGridCoordinates | Set u and v coordinates that specify a grid on the surface. The display of the grid is controlled by AnalysisDisplayColoredSurfaceSettings::getShowGridLines(). If AnalysisDisplayColoredSurfaceSettings::getShowGridLines() returns true and both sets are empty then a grid will be displayed using a default spacing; if only one of the sets is non-empty, then only the corresponding set of grid lines will be displayed, i.e. the grid will consist solely of parallel lines at the specified coordinates.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FieldDomainPointsByUV Class
Autodesk.Revit.DB.Analysis Namespace