Revit 2013 API
AnalyticalModel Methods
AnalyticalModel Class See Also

The AnalyticalModel type exposes the following members.

Methods

 | Name | Description
Public method | Approximate | Switches between non-approximated (e.g., Curved) Analytical Models and approximated (made up of lines only) Analytical Models
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanApproximate | Indicates if Analytical Model can be approximated or not.
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanDisable | Reports whether the user can enable or disable the Analytical Model programmatically.
Public method | CanDisableAutoDetect | Indicates if Analytical Auto-detect can be disabled programmatically
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveRigidLinks | Indicates if Analytical Model supports Rigid Links.
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | CanSetAnalyticalOffset | Determines whether the Analytical Model Offset can be changed.
Public method | CanUseHardPoints | Indicates if Analytical Model can use Hard Points.
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | CloneAdjustment | The method clones the adjustment of one end of the AM on another AM, with respect to the one of the ends. One of the Analytical Model ends
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Disconnect | Unjoin from Hub Element.
Public method | Dispose | (Inherited from Element.)
Public method | Enable | Enables or disables Analytical Model, if the Element allows a one-operation Analytical Model toggle.
Public method | EnableAutoDetect | Enable or disable Analytical Auto-detect.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAlignmentMethod | Gets the alignment method for a given selector and direction.
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetAnalyticalModelSketchComponents | Retrieves a collection of AnalyticalModelSketchComponent objects, which are useful for those Analytical Models that have finer calibration below the Element level.
Public method | GetAnalyticalModelSupports | Retrieves the AnalyticalModelSupport array, which is useful to extract Analytical Support Information from Elements.
Public method | GetAnalyticalOffset | Obsolete. Retrieves Analytical Offset in the case where the user can do that.
Public method | GetAnalyticalProjectionDatumPlane(AnalyticalDirection) | Obsolete. Retrieves analytical model projection information for a specific direction.
Public method | GetAnalyticalProjectionDatumPlane(AnalyticalElementSelector, AnalyticalDirection) | Gets the datum plane for a given selector and direction.
Public method | GetAnalyticalProjectionType(AnalyticalDirection) | Obsolete. Retrieves Analytical Model projection information for a specific direction. In direction: direction in which the Analytical Model may be projected.
Public method | GetAnalyticalProjectionType(AnalyticalElementSelector, AnalyticalDirection) | Retrieves Analytical Model projection information for a specific direction. in direction: direction in which the Analytical Model may be projected.
Public method | GetAnalyzeAs | Returns value of Analyze As parameter for Analytical Model.
Public method | GetApproximationDeviation | Retrieves amount by which approximation is made.
Public method | GetAutoDetectMatchedElements | Retrieves other Element Ids that this Element is Auto-detecting against.
Public method | GetCurve | Returns the single curve of the Analytical Model, if it is only one curve.
Public method | GetCurves | Retrieves all curves for the Analytical Model of a given type.
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetElementId | Retrieves Element Id of the structural element corresponding to the Analytical Model.
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetManualAdjustmentMatchedElements | Retrieves other Element Ids against which the Analytical Model has been adjusted.
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOffset | Gets the offset of the analytical model at end.
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPoint | Retrieves point of the Analytical Model.
Public method | GetReference | Returns a reference to a given curve within the analytical model.
Public method | GetRigidLink | Returns rigid link curve corresponding to selector.
Public method | GetSweptProfile | Retrieves the swept profile information for Analytical Model.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasAlignment | Checks if analytical alignment is applicable at a given end.
Public method | HasDeletedLinks | Indicates if Analytical Model contains deleted Analytical Links.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasRigidLinksWith | Indicates if Analytical Model has Rigid Links with specified element.
Public method | HasSweptProfile | Indicates if this Element's Analytical Model can be represented as a swept profile.
Public method | IsAnalyzeAsValid | Determines if the given Analyze As parameter is valid for this Element.
Public method | IsApproximated | Indicates if Analytical Model is approximated or not.
Public method | IsAutoDetectEnabled | Reports if Analytical Auto-detect for the given direction is enabled.
Public method | IsElementFullySupported | Indicates if Analytical Model is fully supported.
Public method | IsEnabled | Reports whether the Analytical Model is enabled or disabled.
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsManuallyAdjusted | Indicates if the Analytical Model has been manually adjusted by the user.
Public method | IsModified | Checks if AM has been adjusted from auto-detect at any end.
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSingleCurve | Indicates if the Analytical Model can be expressed as a single curve.
Public method | IsSinglePoint | Indicates if the Analytical Model can be expressed as a single point.
Public method | IsSurface | Checks if the analytical model belongs to the surface object like floor, slab or wall.
Public method | IsValidAnalyticalProjectionType | Obsolete. Indicates if a given Analytical Projection Type is valid for the given Analytical Direction.
Public method | IsValidDatumPlaneForProjection | Obsolete. Indicates if a given Datum Plane is valid for analytical model projection with respect to the given analytical direction.
Public method | IsValidDirectionForAutoDetect | Tests if the supplied direction is valid for Analytical Auto-detect.
Public method | IsValidDirectionForProjection | Indicates if the input direction is valid for Analytical Model projection.
Public method | IsValidForManualAdjustment | Indicates if the identified reference is acceptable for Manual Analytical Adjustment.
Public method | IsValidManualAdjustmentSource | Indicates if the identified reference is acceptable as a source for Manual Analytical Adjustment.
Public method | IsValidManualAdjustmentTarget | Indicates if reference is acceptable as a "Target" for Manual Analytical Adjustment.
Public method | IsValidProjectionDatumPlane | Indicates if a given Datum Plane is valid for analytical model projection with respect to the given analytical direction.
Public method | IsValidProjectionType | Indicates if a given Analytical Projection Type is valid for the given Analytical Element Selector and Analytical Direction.
Public method | IsValidRigidLinksOption | Indicates if Rigid Links option is valid for the Analytical Model.
Public method | IsValidSelector | Indicates if the input selector is valid for the Analytical Model.
Public method | IsValidSelectorAndDirection | Indicates if the input selector is valid for analytical direction for Analytical Model.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | ManuallyAdjust | Perform Manual Analytical Adjustment on analytical model, with respect to another Element
Public method | ResetLinks | The function is trying to recreate analytical link elements that were deleted by the user.
Public method | ResetManualAdjustment | Resets all manual adjustments performed by the user onto the Analytical Model.
Public method | SetAlignmentMethod | Sets the alignment method for a given selector and direction.
Public method | SetAnalyticalOffset | Obsolete. Sets Analytical Offset in the case where the user can do that.
Public method | SetAnalyticalProjectionDatumPlane(AnalyticalDirection, ElementId) | Obsolete. Sets analytical model projection to a Datum Plane.
Public method | SetAnalyticalProjectionDatumPlane(AnalyticalElementSelector, AnalyticalDirection, ElementId) | Sets the datum plane for a given selector and direction.
Public method | SetAnalyticalProjectionType(AnalyticalDirection, AnalyticalProjectionType) | Obsolete. Sets the analytical model projection to a preset value.
Public method | SetAnalyticalProjectionType(AnalyticalElementSelector, AnalyticalDirection, AnalyticalProjectionType) | Sets the analytical model projection to a preset value.
Public method | SetAnalyzeAs | Sets value of Analyze As parameter for this Element.
Public method | SetApproximationDeviation | Adjusts the amount by which approximation is made.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetOffset | Sets the offset of the analytical model at end.
Public method | SetUsesHardPoints | Sets Hard Points for the Analytical Model.
Public method | SupportsManualAdjustment | Indicates if the Element supports Manual Analytical Adjustment.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UsesHardPoints | Indicates if the Analytical Model is using Hard Points during approximation.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace