Revit 2013 API
ExternalDefinition Members
ExternalDefinition Class Methods Properties See Also

The ExternalDefinition type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | GUID | Returns the GUID associated with the shared parameter definition.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | The user visible name for the parameter. (Overrides Definition..::..Name.)
Public property | OwnerGroup | Returns or change the group ID of the external parameter definition.
Public property | ParameterGroup | Returns the group ID of the parameter definition. (Overrides Definition..::..ParameterGroup.)
Public property | ParameterType | Returns the user visible interpretation of the parameter data. (Overrides Definition..::..ParameterType.)
Public property | Visible | Indicates if the parameter is visible in the Autodesk Revit user interface.

See Also

ExternalDefinition Class