Revit 2013 API
ToggleButtonData Properties
ToggleButtonData Class See Also

The ToggleButtonData type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyName | The assembly path of the button. (Inherited from PushButtonData.)
Public property | AvailabilityClassName | The full class name for the class providing the entry point to decide availability of this push button. (Inherited from PushButtonData.)
Public property | ClassName | The name of the class containing the implementation for the command. (Inherited from PushButtonData.)
Public property | Image | The image of the button. (Inherited from ButtonData.)
Public property | LargeImage | The large image of the button. (Inherited from ButtonData.)
Public property | LongDescription | Long description of the command tooltip; (Inherited from RibbonItemData.)
Public property | Name | The name of the item. (Inherited from RibbonItemData.)
Public property | Text | The user-visible text of the button. (Inherited from ButtonData.)
Public property | ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItemData.)
Public property | ToolTipImage | The image to show as a part of the button extended tooltip; (Inherited from RibbonItemData.)

See Also

ToggleButtonData Class
Autodesk.Revit.UI Namespace