Revit 2013 API
SaveAsOptions Members
SaveAsOptions Class Constructors Methods Properties See Also

The SaveAsOptions type exposes the following members.

Constructors

 | Name | Description
Public method | SaveAsOptions | Default constructor.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the SaveAsOptions
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | OverwriteExistingFile | Identifies if the operation should be able to overwrite an existing file.
Public property | PreviewViewId | The view id that will be used to generate the preview; this id is not saved to the document's permanent settings.
Public property | Rename | Identifies if the operation should rename the saved document, or save a copy.

See Also

SaveAsOptions Class