Revit 2013 API
PrimarySizeCriterion Members
PrimarySizeCriterion Class Constructors Methods Properties See Also

The PrimarySizeCriterion type exposes the following members.

Constructors

 | Name | Description
Public method | PrimarySizeCriterion | Constructs a PrimarySizeCriterion with a minimum and maximum size.

Methods

 | Name | Description
 | All | Creates a criterion with a range of all sizes.
Public method | Dispose | (Inherited from RoutingCriterionBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual | Verify if two criteria are the same. (Inherited from RoutingCriterionBase.)
 | None | Creates a criterion with a range of no sizes.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | MaximumSize | The maximum size of this criterion.
Public property | MinimumSize | The minimum size of this criterion.

See Also

PrimarySizeCriterion Class