Revit 2013 API
HermiteFace Class
Members Example See Also
A cubic hermite spline face of a 3d solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class HermiteFace : Face
Visual Basic
Public Class HermiteFace _
    Inherits Face
Visual C++
public ref class HermiteFace : public Face

Remarks

Hermite faces are defined by cubic hermite spline surfaces bounded by edge loops. The surfaces provide natural UV parameterization to the faces.

Examples

CopyC#
private void GetHermiteFaceInfo(Face face)
{
    HermiteFace hermiteFace = face as HermiteFace;
    if (null != hermiteFace)
    {
        IList<XYZ> points = hermiteFace.Points;
        IList<XYZ> derivs = hermiteFace.MixedDerivs;
        DoubleArray faceParams = hermiteFace.get_Params(0);
        IList<XYZ> tangents = hermiteFace.get_Tangents(0);
    }
}
CopyVB.NET
Private Sub GetHermiteFaceInfo(ByVal face As Autodesk.Revit.DB.Face)
    Dim hermiteFace As HermiteFace = TryCast(face, HermiteFace)
    If hermiteFace IsNot Nothing Then
        Dim points As IList(Of Autodesk.Revit.DB.XYZ) = hermiteFace.Points
        Dim derivs As IList(Of Autodesk.Revit.DB.XYZ) = hermiteFace.MixedDerivs
        Dim faceParams As DoubleArray = hermiteFace.Params(0)
        Dim tangents As IList(Of Autodesk.Revit.DB.XYZ) = hermiteFace.Tangents(0)
    End If
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..GeometryObject
Autodesk.Revit.DB..::..Face
Autodesk.Revit.DB..::..HermiteFace

See Also

HermiteFace Members