Revit 2013 API
SpatialFieldManager Members
SpatialFieldManager Class Methods Properties See Also

The SpatialFieldManager type exposes the following members.

Methods

 | Name | Description
Public method | AddSpatialFieldPrimitive()()()() | Creates empty analysis results primitive not associated with any geometry element
Public method | AddSpatialFieldPrimitive(Reference) | Creates an empty analysis results primitive associated with a reference.
Public method | AddSpatialFieldPrimitive(Curve, Transform) | Creates empty analysis results primitive associated with a curve and a transform.
Public method | AddSpatialFieldPrimitive(Face, Transform) | Creates empty analysis results primitive associated with a face and a transform.
Public method | AddSpatialFieldPrimitive(Reference, SpatialFieldPrimitiveHideMode) | Creates an empty analysis results primitive associated with a reference, with the option to control how the reference element is hidden.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | Clear | Clear all analysis results managed by this manager object
 | CreateSpatialFieldManager | Factory method - creates manager object for the given view
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLegend | Returns legend element or NULL
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMaximum | Calculates the maximum value for all primitives
Public method | GetMinimum | Calculates the minimum value for all primitives
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetRegisteredResults | Returns an array of indices of all registered results
Public method | GetResultSchema | Returns result schema by index
 | GetSpatialFieldManager | Retrieves manager object for the given view or returns NULL
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsResultSchemaNameUnique | Verify the uniqueness of the name among all registered result schemas.
 | IsTextTypeIdValid | Verify if text type id is valid.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | RegisterResult | Registers result and assigns it a unique result index
Public method | RemoveSpatialFieldPrimitive | Removes analysis results primitive identified by the unique index
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetMeasurementDescriptions | Sets Descriptions for all measurements
Public method | SetMeasurementNames | Sets Names for all measurements
Public method | SetResultSchema | Sets a new value for an existing result schema in the result registry
Public method | SetUnits | Obsolete. Sets names and multipliers for all units that can be used for analysis results visualization; current units can later be changed by accessor method
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateSpatialFieldPrimitive(Int32, FieldDomainPoints, FieldValues) | Obsolete. Populates analysis results data (or replaces the existing data) in the existing primitive identified by the unique index
Public method | UpdateSpatialFieldPrimitive(Int32, FieldDomainPoints, FieldValues, Int32) | Populates analysis results data (or replaces the existing data) in the existing primitive identified by the unique index

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurrentMeasurement | Stores the currently displayed measurement
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | LegendPosition | Stores current position of analysis results legend element in view
Public property | LegendShowConfigurationName | If true legend contains analysis configuration name.
Public property | LegendShowDescription | If true legend contains analysis description.
Public property | LegendTextTypeId | Stores element id of text associated with common (result-independent) part of legend in view.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | NumberOfMeasurements | Stores the total number of measurements
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ResultsVisibleInView | Enables analysis results visibility in the view.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UseRangeForAllMeasurements | Governs how minimum and maximum values (the data range) are calculated.
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace