Revit 2013 API
StairsPathType..::..LineShapeAtCorner Property
StairsPathType Class See Also
The line shape of stairs path at the corner.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public StairsPathLineShapeAtCorner LineShapeAtCorner { get; set; }
Visual Basic
Public Property LineShapeAtCorner As StairsPathLineShapeAtCorner
    Get
    Set
Visual C++
public:
property StairsPathLineShapeAtCorner LineShapeAtCorner {
    StairsPathLineShapeAtCorner get ();
    void set (StairsPathLineShapeAtCorner value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: Either the stairs path direction is not AutomaticUpDown, or it is AlwaysUp but DrawForEachRun is false.

See Also

StairsPathType Class
Autodesk.Revit.DB.Architecture Namespace