Revit 2013 API
RevolvedFace Properties
RevolvedFace Class See Also

The RevolvedFace type exposes the following members.

Properties

 | Name | Description
Public property | Area | The area of this face. (Inherited from Face.)
Public property | Axis | Axis of the surface.
Public property | Curve | Profile curve of the surface.
Public property | EdgeLoops | Each edge loop is a closed boundary of the face. (Inherited from Face.)
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle; (Inherited from GeometryObject.)
Public property | HasRegions | Reports if the face contains regions created with the Split Face command. (Inherited from Face.)
Public property | IsCyclic | The boolean value that indicates whether this face is periodic in the specified parametric direction. (Inherited from Face.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsTwoSided | Determines if a face is two-sided (degenerate); (Inherited from Face.)
Public property | MaterialElementId | Element ID of the material from which this face is composed. (Inherited from Face.)
Public property | Origin | Origin of the surface.
Public property | Period | The period of this face in the specified parametric direction. (Inherited from Face.)
Public property | Radius | Radius of the surface.
Public property | Reference | Returns a stable reference to the face. (Inherited from Face.)
Public property | Visibility | The visibility. (Inherited from GeometryObject.)

See Also

RevolvedFace Class