Revit 2013 API
RebarShapeConstraintAngleFromFixedDir Members
RebarShapeConstraintAngleFromFixedDir Class Constructors Methods Properties See Also

The RebarShapeConstraintAngleFromFixedDir type exposes the following members.

Constructors

 | Name | Description
Public method | RebarShapeConstraintAngleFromFixedDir | Create an angular constraint.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RebarShapeConstraint.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetParamId | Return the Id of the parameter associated with this constraint. (Inherited from RebarShapeConstraint.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Direction | A fixed direction in UV-space. The parameter will drive the segment's angle relative to this direction.
Public property | Sign | When the sign is 1, the Direction is rotated clockwise by the angle's value. When -1, the Direction is rotated counter-clockwise.

See Also

RebarShapeConstraintAngleFromFixedDir Class
Autodesk.Revit.DB.Structure Namespace