Revit 2013 API
IFCExtrusionCreationData..::..ScaledInnerPerimeter Property
IFCExtrusionCreationData Class See Also
The inner perimeter of the extrusion, scaled to the units of export.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double ScaledInnerPerimeter { get; set; }
Visual Basic
Public Property ScaledInnerPerimeter As Double
    Get
    Set
Visual C++
public:
property double ScaledInnerPerimeter {
    double get ();
    void set (double value);
}

Field Value

This value represents the perimeter of all of the inner curve loops within the area of the extrusion. Zero if the perimeter has never been set on this object.

See Also

IFCExtrusionCreationData Class
Autodesk.Revit.DB.IFC Namespace