Revit 2013 API
BoundingBoxIsInsideFilter Members
BoundingBoxIsInsideFilter Class Constructors Methods Properties See Also

The BoundingBoxIsInsideFilter type exposes the following members.

Constructors

 | Name | Description
Public method | BoundingBoxIsInsideFilter(Outline) | Constructs a new instance of a filter to match elements with a bounding box that is contained by the given Outline.
Public method | BoundingBoxIsInsideFilter(Outline, Boolean) | Constructs a new instance of a filter to match elements with a bounding box is contained by the given Outline, with the option to invert the filter and match all elements with a bounding box that are not contained by the given Outline.
Public method | BoundingBoxIsInsideFilter(Outline, Double) | Constructs a new instance of a filter to match elements with a bounding box that is contained by the given Outline.
Public method | BoundingBoxIsInsideFilter(Outline, Double, Boolean) | Constructs a new instance of a filter to match elements with a bounding box is contained by the given Outline, with the option to invert the filter and match all elements with a bounding box that are not contained by the given Outline.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBoundingBox | Gets the outline being used for this filter.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | Tolerance | Allows control over the match criteria by using a tolerance in the geometry comparison. It is suggested to use this in cases where trivial differences should be considered when matching elements.

See Also

BoundingBoxIsInsideFilter Class