Revit 2013 API
SpatialElementGeometryCalculator Constructor (Document, SpatialElementBoundaryOptions)
SpatialElementGeometryCalculator Class See Also
Constructs a new calculator for the geometry of spatial elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public SpatialElementGeometryCalculator(
    Document aDoc,
    SpatialElementBoundaryOptions options
)
Visual Basic
Public Sub New ( _
    aDoc As Document, _
    options As SpatialElementBoundaryOptions _
)
Visual C++
public:
SpatialElementGeometryCalculator(
    Document^ aDoc,
    SpatialElementBoundaryOptions^ options
)

Parameters

aDoc
Type: Autodesk.Revit.DB..::..Document
The document that contains the spatial elements.
options
Type: Autodesk.Revit.DB..::..SpatialElementBoundaryOptions
The options to control the calculation rules.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

SpatialElementGeometryCalculator Class
SpatialElementGeometryCalculator Overload