Revit 2013 API
SpatialFieldManager..::..AddSpatialFieldPrimitive Method (Reference, SpatialFieldPrimitiveHideMode)
SpatialFieldManager Class See Also
Creates an empty analysis results primitive associated with a reference, with the option to control how the reference element is hidden.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int AddSpatialFieldPrimitive(
    Reference reference,
    SpatialFieldPrimitiveHideMode hidingMode
)
Visual Basic
Public Function AddSpatialFieldPrimitive ( _
    reference As Reference, _
    hidingMode As SpatialFieldPrimitiveHideMode _
) As Integer
Visual C++
public:
int AddSpatialFieldPrimitive(
    Reference^ reference,
    SpatialFieldPrimitiveHideMode hidingMode
)

Parameters

reference
Type: Autodesk.Revit.DB..::..Reference
Reference pointing to the curve or face to be associated with the primitive
hidingMode
Type: Autodesk.Revit.DB.Analysis..::..SpatialFieldPrimitiveHideMode
The mode used to hide the original model element

Return Value

Unique index of primitive for future references

Remarks

There can be multiple primitives associated with one reference, normally they would be shown with different results. However this is justified only if they have different sets of domain points. Otherwise one primitive can be used to display values for different results.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | reference points to neither face nor curve
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

SpatialFieldManager Class
AddSpatialFieldPrimitive Overload
Autodesk.Revit.DB.Analysis Namespace