Revit 2013 API
MassSurfaceData Properties
MassSurfaceData Class See Also

The MassSurfaceData type exposes the following members.

Properties

 | Name | Description
Public property | Area | Area of the references that the MassSurfaceData provides properties for.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CategoryIdForConceptualSurfaceType | Returns the mass subcategory ElementId used for ConceptualSurfaceType for this MassSurfaceData.
Public property | ConceptualConstructionId | The id of the conceptual construction associated with the reference surface.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsConceptualConstructionByEnergyData | True when the ConceptualConstructionType id is synchronized to the EnergyDataSettings. False when the ConceptualConstructionType id is overridden for this MassSurfaceData.
Public property | IsGlazingShaded | Indicates if shade geometry is auto-generated on the top edge of auto-generated glazing.
Public property | IsSlab | Indicates if a floor is a slab.
Public property | IsUnderground | Indicates if the roof, floor, slab, or wall surface reference is underground.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | MassLevelDataId | The MassLevelData used when the surface is horizontal, planar, and at the same height as a MassLevelData related to the same mass as the referenced face.
Public property | MaterialId | The visualization material used for the surface for displaying the energy analytical model.
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MaterialType | material type of mass zone
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PercentageGlazing | The target percentage of the reference wall surface that is to be covered with automatically generated windows. Revit will use this number when determining the size, shape, and location of automatically generated windows.
Public property | PercentageSkylights | The target percentage of the reference roof surface that is to be covered with automatically generated skylights. Revit will use this number when determining the size, shape, and location of automatically generated skylights.
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ReferenceElementId | The ElementId of the element whose face the MassSurfaceData primarily refers to.
Public property | ShadeDepth | How far any auto-generated shades should extend from the wall surface.
Public property | SillHeight | The height above the level where the bottoms of auto-generated windows will be located.
Public property | SkylightWidth | The length dimension to be used for the sides of each individual square skylight produced in the grid of auto-generated skylights.
Public property | SurfaceDataSource | Indicates whether the MassSurfaceData properties are driven by the EnergyDataSettings of the Document or are overridden for the surface.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

MassSurfaceData Class
Autodesk.Revit.DB.Analysis Namespace