Revit 2013 API
IFCProductWrapper..::..AddFinishMaterial Method
IFCProductWrapper Class See Also
Adds an material handle to associate with the IfcProduct in this wrapper.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void AddFinishMaterial(
    IFCAnyHandle material
)
Visual Basic
Public Sub AddFinishMaterial ( _
    material As IFCAnyHandle _
)
Visual C++
public:
void AddFinishMaterial(
    IFCAnyHandle^ material
)

Parameters

material
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The material handle.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCProductWrapper Class
Autodesk.Revit.DB.IFC Namespace