Revit 2013 API
ExporterIFCUtils..::..GetNumBuildingStoreys Method
ExporterIFCUtils Class See Also
Returns the number of non-empty, non-duplicate building stories in the file.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static int GetNumBuildingStoreys(
    ExporterIFC exporterIFC
)
Visual Basic
Public Shared Function GetNumBuildingStoreys ( _
    exporterIFC As ExporterIFC _
) As Integer
Visual C++
public:
static int GetNumBuildingStoreys(
    ExporterIFC^ exporterIFC
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.

Return Value

The number of stories.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace