Revit 2013 API
AnalysisDisplayColorEntry Members
AnalysisDisplayColorEntry Class Constructors Methods Properties See Also

The AnalysisDisplayColorEntry type exposes the following members.

Constructors

 | Name | Description
Public method | AnalysisDisplayColorEntry()()()() | Initializes a new instance of the AnalysisDisplayColorEntry class
Public method | AnalysisDisplayColorEntry(Color) | Constructs a color entry with no value assigned.
Public method | AnalysisDisplayColorEntry(Color, Double) | Constructs a color entry with a specific value assigned.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the AnalysisDisplayColorEntry
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasValue | Check if color entry has associated value.
Public method | IsEqual | Compare color entries.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Color | Color associated with color entry.
Public property | Value | Value associated with color entry.

See Also

AnalysisDisplayColorEntry Class
Autodesk.Revit.DB.Analysis Namespace