Revit 2013 API
ExporterIFC..::..GetHostObjects Method
ExporterIFC Class See Also
Returns a collection containing the host object handles in the document.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IList<IDictionary<ElementId, IFCAnyHandle>> GetHostObjects()
Visual Basic
Public Function GetHostObjects As IList(Of IDictionary(Of ElementId, IFCAnyHandle))
Visual C++
public:
IList<IDictionary<ElementId^, IFCAnyHandle^>^>^ GetHostObjects()

Return Value

The collection of host objects.

Remarks

Host object handles is currently collected by RegisterSpaceBoundingElementHandle and exporting internal element and cached in the ExporterIFC object. This method returns the cached information which is needed to create wall connectivity objects.

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace