Revit 2013 API
IFCFile..::..Write Method
IFCFile Class See Also
Writes content to a file of IFC format.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void Write(
    IFCFileWriteOptions writeOptions
)
Visual Basic
Public Sub Write ( _
    writeOptions As IFCFileWriteOptions _
)
Visual C++
public:
void Write(
    IFCFileWriteOptions^ writeOptions
)

Parameters

writeOptions
Type: Autodesk.Revit.DB.IFC..::..IFCFileWriteOptions
The IFC file write options.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCFile Class
Autodesk.Revit.DB.IFC Namespace