Revit 2013 API
MEPSystemType..::..LinePatternId Property
MEPSystemType Class See Also
Indicates the line pattern color that should override the line color for all components in the system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementId LinePatternId { get; set; }
Visual Basic
Public Property LinePatternId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ LinePatternId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

MEPSystemType Class