Revit 2013 API
DuctSizeSettings..::..RemoveSize Method
DuctSizeSettings Class See Also
Erase the existing MEPSize with this nominal diameter. The duct shape determines the location of the size in the size table.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void RemoveSize(
    DuctShape shape,
    double nominalDiameter
)
Visual Basic
Public Sub RemoveSize ( _
    shape As DuctShape, _
    nominalDiameter As Double _
)
Visual C++
public:
void RemoveSize(
    DuctShape shape,
    double nominalDiameter
)

Parameters

shape
Type: Autodesk.Revit.DB.Mechanical..::..DuctShape
The shape of duct.
nominalDiameter
Type: System..::..Double
Nominal diameter.

Remarks

Does nothing if there is no existing MEPSize with this nominal diameter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Throws if the function is called during iterating the size set.

See Also

DuctSizeSettings Class
Autodesk.Revit.DB.Mechanical Namespace