Revit 2013 API
Duct..::..CreatePlaceholder Method
Duct Class See Also
Creates a new placeholder duct.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static Duct CreatePlaceholder(
    Document document,
    ElementId ductTypeId,
    ElementId levelId,
    XYZ firstPoint,
    XYZ secondPoint
)
Visual Basic
Public Shared Function CreatePlaceholder ( _
    document As Document, _
    ductTypeId As ElementId, _
    levelId As ElementId, _
    firstPoint As XYZ, _
    secondPoint As XYZ _
) As Duct
Visual C++
public:
static Duct^ CreatePlaceholder(
    Document^ document,
    ElementId^ ductTypeId,
    ElementId^ levelId,
    XYZ^ firstPoint,
    XYZ^ secondPoint
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
ductTypeId
Type: Autodesk.Revit.DB..::..ElementId
The id of the duct type.
levelId
Type: Autodesk.Revit.DB..::..ElementId
The level id for the duct.
firstPoint
Type: Autodesk.Revit.DB..::..XYZ
The first point of the placeholder line.
secondPoint
Type: Autodesk.Revit.DB..::..XYZ
The second point of the placeholder line.

Return Value

The placeholder duct.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The duct type ductTypeId is not valid duct type. -or- The level id levelId is not valid. -or- The points of firstPoint and secondPoint are equal.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Mechanical Electrical Piping.

See Also

Duct Class
Autodesk.Revit.DB.Mechanical Namespace