Revit 2013 API
CompoundStructureLayer Members
CompoundStructureLayer Class Constructors Methods Properties See Also

The CompoundStructureLayer type exposes the following members.

Constructors

 | Name | Description
Public method | CompoundStructureLayer()()()() | Creates a default compound structure layer.
Public method | CompoundStructureLayer(CompoundStructureLayer) | Creates a copy of compound structure layer.
Public method | CompoundStructureLayer(Double, MaterialFunctionAssignment, ElementId) | Creates a default compound structure layer based on the given width, function and material element id.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the CompoundStructureLayer
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DeckEmbeddingType | Embedding type for structural deck - only for a layer whose function is StructuralDeck.
Public property | DeckProfileId | The ElementId of the structural deck profile - only for a layer whose function is StructuralDeck.
Public property | Function | The function of the layer.
Public property | LayerCapFlag | Identifies if the layer participates in the cap work.
Public property | LayerId | The id of the layer - may be different from the index in the array of layers in a CompoundStructure.
Public property | MaterialId | Id of the material assigned to this layer.
Public property | Width | Width of the layer.

See Also

CompoundStructureLayer Class