Revit 2013 API
ExporterIFC..::..SetMaterialIdForCurrentExportState Method
ExporterIFC Class See Also
This sets the material id that is to be associated with the element in the current export state.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void SetMaterialIdForCurrentExportState(
    ElementId elementId
)
Visual Basic
Public Sub SetMaterialIdForCurrentExportState ( _
    elementId As ElementId _
)
Visual C++
public:
void SetMaterialIdForCurrentExportState(
    ElementId^ elementId
)

Parameters

elementId
Type: Autodesk.Revit.DB..::..ElementId
The material id.

Remarks

Even though there could be several materials associated with the element (set during PushExportState()), unless the element has support for IfcMaterialLayerSet, IFC output will include only this one.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace