Revit 2013 API
Application..::..IsPipingAnalysisEnabled Property
Application Class See Also
Checks whether or not piping analysis is enabled, and enable or disable it.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsPipingAnalysisEnabled { get; set; }
Visual Basic
Public Property IsPipingAnalysisEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool IsPipingAnalysisEnabled {
    bool get ();
    void set (bool value);
}

Remarks

Enabling piping analysis will not take effect unless the piping discipline is also enabled.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property:

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace