Revit 2013 API
StructuralAsset Methods
StructuralAsset Class See Also

The StructuralAsset type exposes the following members.

Methods

 | Name | Description
Public method | Copy | Produces a copy of the asset.
Public method | Dispose |
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(StructuralAsset) | Determines whether this structural asset is equal to another.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetPoissonRatio | Sets the Poisson ratio of the asset.
Public method | SetShearModulus | Sets the shear modulus of the asset.
Public method | SetThermalExpansionCoefficient | Sets the thermal expansion coefficient of the asset.
Public method | SetYoungModulus | Sets the Young's modulus of the asset.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StructuralAsset Class