Revit 2013 API
IFCData..::..AsBoolean Method
IFCData Class See Also
Gets storage value as boolean when its PrimitiveType is boolean.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool AsBoolean()
Visual Basic
Public Function AsBoolean As Boolean
Visual C++
public:
bool AsBoolean()

Return Value

The bool value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InapplicableDataException | The primitive type is not boolean.

See Also

IFCData Class
Autodesk.Revit.DB.IFC Namespace