Revit 2013 API
ScheduleDefinition..::..InsertField Method (SchedulableField, Int32)
ScheduleDefinition Class See Also
Adds a regular (non-calculated) field at the specified position in the list.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ScheduleField InsertField(
    SchedulableField schedulableField,
    int index
)
Visual Basic
Public Function InsertField ( _
    schedulableField As SchedulableField, _
    index As Integer _
) As ScheduleField
Visual C++
public:
ScheduleField^ InsertField(
    SchedulableField^ schedulableField,
    int index
)

Parameters

schedulableField
Type: Autodesk.Revit.DB..::..SchedulableField
A SchedulableField object representing the field.
index
Type: System..::..Int32
The index in the list of fields.

Return Value

The new field.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The field specified by schedulableField may not included in this ScheduleDefinition. -or- The field specified by schedulableField is already included in this ScheduleDefinition.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | index is not a valid insert position.

See Also

ScheduleDefinition Class
InsertField Overload