Revit 2013 API
LinePatternSegment Members
LinePatternSegment Class Constructors Methods Properties See Also

The LinePatternSegment type exposes the following members.

Constructors

 | Name | Description
Public method | LinePatternSegment()()()() | Creates a line pattern segment.
Public method | LinePatternSegment(LinePatternSegmentType, Double) | Creates a line pattern segment with given type and length.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the LinePatternSegment
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Length | Gets and sets the length of the segment.
Public property | Type | Gets and sets the type of the segment.

See Also

LinePatternSegment Class