Revit 2013 API
BuiltInFailures..::..SlabShapeFailures Properties
BuiltInFailures..::..SlabShapeFailures Class See Also

The BuiltInFailures..::..SlabShapeFailures type exposes the following members.

Properties

Name | Description
SlabShapeEditFailed | Slab Shape Edit failed. [Description]
SlabShapeEditFailedError | Slab Shape Edit failed. [Description]
SlabShapeFailedNotHorz | The Roof or Floor is no longer horizontal.
SlabShapeFailedNotOnlyLines | The Roof or Floor may only contain straight lines.
SlabShapeFailedTooThin | The Floor or Roof is too thin for its given type.
SlabShapeWarnVerticesDeleted | Some slab shape edit vertices were deleted because the Floor or Roof has changed its shape.
SlopedInnerEdge | Inner loops of a footprint sketch may not have slope-defining lines.
SlopeTailInsideSlopeLine | The tails of slope arrows must not lie in interior of slope defining lines.
SlopeZero | Adjusting this Line's Overhang will not affect its height because its slope is zero.

See Also

BuiltInFailures..::..SlabShapeFailures Class