Revit 2013 API
MullionTypeSet Members
MullionTypeSet Class Constructors Methods Properties See Also

The MullionTypeSet type exposes the following members.

Constructors

 | Name | Description
Public method | MullionTypeSet | Initializes a new instance of the MullionTypeSet class

Methods

 | Name | Description
Public method | Clear | Removes every mullion type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a mullion type within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified mullion type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified mullion type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of mullion types that are in the set.

See Also

MullionTypeSet Class