Revit 2013 API
DocumentOpeningEventArgs Members
DocumentOpeningEventArgs Class Methods Properties See Also

The DocumentOpeningEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Cancel | When the event is cancellable, may call the Cancel() method to cancel it. (Inherited from RevitAPIPreEventArgs.)
Public method | Dispose | (Inherited from RevitAPIEventArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs.)
Public property | DocumentType | Type of the document, e.g. Project or Template.
Public property | PathName | Path of the document to be opened.

See Also

DocumentOpeningEventArgs Class
Autodesk.Revit.DB.Events Namespace