Revit 2013 API
Document..::..WorksharingCentralGUID Property
Document Class See Also
The central GUID of the server-based model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public Guid WorksharingCentralGUID { get; }
Visual Basic
Public ReadOnly Property WorksharingCentralGUID As Guid
    Get
Visual C++
public:
property Guid WorksharingCentralGUID {
    Guid get ();
}

Field Value

The central GUID of the server-based model.

Remarks

The central model of this document that is file-based model or saved in a release prior to Revit 2013 did not have this GUID. Only the central model saved in Revit 2013 or later and stored on Revit Server will be able to provide this value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InapplicableDataException | Thrown when the central model of this document is not a server-based model that created in Revit 2013 or later release.

See Also

Document Class