Revit 2013 API
ScheduleField..::..GridColumnWidth Property
ScheduleField Class See Also
The width of the column in the editable grid view, measured in characters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double GridColumnWidth { get; set; }
Visual Basic
Public Property GridColumnWidth As Double
    Get
    Set
Visual C++
public:
property double GridColumnWidth {
    double get ();
    void set (double value);
}

Remarks

In a schedule with an embedded ScheduleDefinition, a column may display two fields, one from each ScheduleDefinition. In that case, the larger of the two widths is used.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: gridColumnWidth is negative.

See Also

ScheduleField Class