Revit 2013 API
FileImportedEventArgs Properties
FileImportedEventArgs Class See Also

The FileImportedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs.)
Public property | Document | The document associated with the event. (Inherited from RevitAPIPostDocEventArgs.)
Public property | Format | Identifies the import format, e.g. DWG or image.
Public property | ImportedInstanceId | The ElementId of the imported instance that represents the imported object(s) after a successful import. It could be used for further manipulation of that instance.
Public property | Path | Path of the source file that was imported.
Public property | Status | Indicates whether the action associated with this event succeeded, failed, or was cancelled (by an API event handler). (Inherited from RevitAPIPostEventArgs.)

See Also

FileImportedEventArgs Class
Autodesk.Revit.DB.Events Namespace