Revit 2013 API
RectangleLightShape Members
RectangleLightShape Class Constructors Methods Properties See Also

The RectangleLightShape type exposes the following members.

Constructors

 | Name | Description
Public method | RectangleLightShape()()()() | Creates a rectangle light shape object with 4.0' emit length and a 2.0' emit width.
Public method | RectangleLightShape(RectangleLightShape) | Creates a copy of the given rectangle light shape
Public method | RectangleLightShape(Double, Double) | Creates a rectangle light shape object with the given emit length and width.

Methods

 | Name | Description
Public method | Clone | Creates a copy of the LightShape derived object. (Inherited from LightShape.)
Public method | Dispose | (Inherited from LightShape.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | EmitLength | The emit length.
Public property | EmitWidth | The emit width.

See Also

RectangleLightShape Class
Autodesk.Revit.DB.Lighting Namespace