Revit 2013 API
PropertySetElement..::..SetStructuralAsset Method
PropertySetElement Class See Also

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void SetStructuralAsset(
    StructuralAsset structuralAsset
)
Visual Basic
Public Sub SetStructuralAsset ( _
    structuralAsset As StructuralAsset _
)
Visual C++
public:
void SetStructuralAsset(
    StructuralAsset^ structuralAsset
)

Parameters

structuralAsset
Type: Autodesk.Revit.DB..::..StructuralAsset

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the name of the asset is empty, contains prohibited characters, or is not unique
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PropertySetElement Class