Revit 2013 API
LocationCurve Members
LocationCurve Class Methods Properties See Also

The LocationCurve type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Move | Move the element within the project by a specified vector. (Inherited from Location.)
Public method | Rotate | Rotate the element within the project by a specified angle around a given axis. (Inherited from Location.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Curve | Provides the ability to get and set the curve of a curve based element.
Public property | ElementsAtJoin | Get all elements joining to the end of this element's location curve or change the order of elements participation in the end join with this location curve's end.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | JoinType | Get/change the type of the join at the specified end.

See Also

LocationCurve Class