Revit 2013 API
Document..::..GetElement Method (ElementId)
Document Class See Also
Gets the Element referenced by the input string name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public Element GetElement(
    ElementId id
)
Visual Basic
Public Function GetElement ( _
    id As ElementId _
) As Element
Visual C++
public:
Element^ GetElement(
    ElementId^ id
)

Parameters

id
Type: Autodesk.Revit.DB..::..ElementId
The ElementId, whose referenced Element will be retrieved from the model.

Return Value

The element referenced by the input argument.

Remarks

nullNothingnullptra null reference (Nothing in Visual Basic) will be returned if the input ElementId doesn't reference to a valid Element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

Document Class
GetElement Overload