Revit 2013 API
RenderingQualitySettings Members
RenderingQualitySettings Class Methods Properties See Also

The RenderingQualitySettings type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the RenderingQualitySettings
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AreCurtainWallsDaylightPortals | Indicates whether curtain walls daylight portals.
Public property | AreDoorsDaylightPortals | Indicates whether doors daylight portals.
Public property | AreShadowsEnabled | Indicates whether to make shadow edges soft(blurred).
Public property | AreWindowsDaylightPortals | Indicates whether windows daylight portals.
Public property | BlurredReflectionPrecision | The blurred reflections precision.
Public property | BlurredRefractionPrecision | The blurred refractions precision.
Public property | ImagePrecision | A value that controls how antialiasing is applied to the background image.
Public property | IndirectIlluminationBounces | The indirect illumination bounces value.
Public property | IndirectIlluminationPrecision | The indirect illumination precision value.
Public property | IndirectIlluminationSmoothness | The indirect illumination smoothness value.
Public property | MaxReflections | The maximum number of reflections.
Public property | MaxRefractions | The maximum number of refractions.
Public property | RenderingQuality | The quality applied for rendering.
Public property | ShouldComputeIndirectAndSkyIllumination | Indicates whether to include light that bounces off other objects, and light from the sky when calculating the lighting for this scene.
Public property | SoftShadowsPrecision | The soft shadows precision value.

See Also

RenderingQualitySettings Class