Revit 2013 API
Railing..::..HostId Property
Railing Class See Also
The host of the railing.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId HostId { get; set; }
Visual Basic
Public Property HostId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ HostId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The hostId is not a valid railing host.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

Railing Class
Autodesk.Revit.DB.Architecture Namespace