Revit 2013 API
Curve Members
Curve Class Methods Properties See Also

The Curve type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Returns a copy of this curve.
Public method | ComputeDerivatives | Returns the vectors describing the curve at the specified parameter.
Public method | ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter.
Public method | ComputeRawParameter | Computes the raw parameter from the normalized parameter.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Distance | Returns the shortest distance from the specified point to this curve.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | Evaluate | Evaluates a parameter on the curve.
Public method | GetHashCode | Gets the integer value of the geometry object as hash code; (Inherited from GeometryObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect(Curve) | Calculates the intersection of this curve with the specified curve.
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of this curve with the specified curve and returns the intersection results.
Public method | IsInside(Double) | Indicates whether the specified parameter value is within this curve's bounds.
Public method | IsInside(Double, Int32%) | Indicates whether the specified parameter value is within this curve's bounds and outputs the end index.
Public method | MakeBound | Changes the bounds of this curve to the specified values.
Public method | MakeUnbound | Makes this curve unbound.
Public method | Project | Projects the specified point on this curve.
Public method | Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ApproximateLength | The approximate length of the curve.
Public property | EndParameter | The parameter of the start or the end point of the curve.
Public property | EndPoint | The start or the end point of this curve.
Public property | EndPointReference | Returns a stable reference to the start point or the end point of the curve.
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle; (Inherited from GeometryObject.)
Public property | IsBound | Describes whether the parameter of the curve is restricted to a particular interval.
Public property | IsCyclic | The boolean value that indicates whether this curve is cyclic.
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Length | The exact length of the curve.
Public property | Period | The period of this curve.
Public property | Reference | Returns a stable reference to the curve.
Public property | Transformed | Applies the specified transformation to this curve and returns the result.
Public property | Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Curve Class