Revit 2013 API
PartMakerMethodToDivideVolumes..::..AddIntersectingReference Method
PartMakerMethodToDivideVolumes Class See Also
Adds intersecting reference with an offset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool AddIntersectingReference(
    ElementId intersectingReference,
    double offset
)
Visual Basic
Public Function AddIntersectingReference ( _
    intersectingReference As ElementId, _
    offset As Double _
) As Boolean
Visual C++
public:
bool AddIntersectingReference(
    ElementId^ intersectingReference,
    double offset
)

Parameters

intersectingReference
Type: Autodesk.Revit.DB..::..ElementId
Id of the new intersecting reference.
offset
Type: System..::..Double
The Offste for the new intersecting reference.

Return Value

True if the PartMaker did not already use this intersecting reference and it was added, false if the PartMaker already used this intersecting reference and this call only updated its offset.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The element id was not permitted as intersecting references. Intersecting references should be levels, grids, or reference planes.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PartMakerMethodToDivideVolumes Class