Revit 2013 API
RevolvedFace Class
Members Example See Also
A revolved face of a 3d solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class RevolvedFace : Face
Visual Basic
Public Class RevolvedFace _
    Inherits Face
Visual C++
public ref class RevolvedFace : public Face

Remarks

Revolved faces are defined by revolved surfaces bounded by edge loops. The surfaces provide natural UV parameterization to the faces. S(u, v) = Origin + Curve0(v)*cos(u)*Radius[0] + Curve0(v)*sin(u)*Radius[1] + Curve1(v)*Axis, where the profile curve has the parametric equation (Curve0(t), Curve1(t)).

Examples

CopyC#
private void GetRevolvedFaceInfo(Face face)
{
    RevolvedFace revolvedFace = face as RevolvedFace;
    if (null != revolvedFace)
    {
       XYZ origin = revolvedFace.Origin;
       XYZ axis = revolvedFace.Axis;
        Curve curve = revolvedFace.Curve;
        XYZ redius = revolvedFace.get_Radius(0);
    }
}
CopyVB.NET
Private Sub GetRevolvedFaceInfo(ByVal face As Autodesk.Revit.DB.Face)
    Dim revolvedFace As RevolvedFace = TryCast(face, RevolvedFace)
    If revolvedFace IsNot Nothing Then
        Dim origin As Autodesk.Revit.DB.XYZ = revolvedFace.Origin
        Dim axis As Autodesk.Revit.DB.XYZ = revolvedFace.Axis
        Dim curve As Curve = revolvedFace.Curve
        Dim redius As Autodesk.Revit.DB.XYZ = revolvedFace.Radius(0)
    End If
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..GeometryObject
Autodesk.Revit.DB..::..Face
Autodesk.Revit.DB..::..RevolvedFace

See Also

RevolvedFace Members