Revit 2013 API
PointOnPlane..::..NewPointOnPlane Method
PointOnPlane Class See Also
Construct a PointOnPlane given a reference and a location in space.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static PointOnPlane NewPointOnPlane(
    Document doc,
    Reference planeReference,
    XYZ position,
    XYZ xvec
)
Visual Basic
Public Shared Function NewPointOnPlane ( _
    doc As Document, _
    planeReference As Reference, _
    position As XYZ, _
    xvec As XYZ _
) As PointOnPlane
Visual C++
public:
static PointOnPlane^ NewPointOnPlane(
    Document^ doc,
    Reference^ planeReference,
    XYZ^ position,
    XYZ^ xvec
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
The document containing the plane reference.
planeReference
Type: Autodesk.Revit.DB..::..Reference
position
Type: Autodesk.Revit.DB..::..XYZ
A 3-dimensional position.
xvec
Type: Autodesk.Revit.DB..::..XYZ
The direction of the point's X-coordinate vector in the plane's coordinates. Optional; default value is the X-coordinate vector of the plane.

Return Value

A new PointOnPlane object with 2-dimensional Position, XVec, and Offset properties set to match the given 3-dimensional arguments.

See Also

PointOnPlane Class