Revit 2013 API
FilteredWorksetCollector..::..OfKind Method
FilteredWorksetCollector Class See Also
Applies a WorksetKindFilter to the collector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public FilteredWorksetCollector OfKind(
    WorksetKind worksetKind
)
Visual Basic
Public Function OfKind ( _
    worksetKind As WorksetKind _
) As FilteredWorksetCollector
Visual C++
public:
FilteredWorksetCollector^ OfKind(
    WorksetKind worksetKind
)

Parameters

worksetKind
Type: Autodesk.Revit.DB..::..WorksetKind
The WorksetKind of the workset.

Return Value

A handle to this collector. This is the same collector that has just been modified, returned so you can chain multiple calls together in one line.

Remarks

Only worksets whose WorksetKind is an exact match to the input WorksetKind will pass the collector.

If you have an active iterator to this collector it will be stopped by this call.

See Also

FilteredWorksetCollector Class