Revit 2013 API
InstanceVoidCutUtils..::..RemoveInstanceVoidCut Method
InstanceVoidCutUtils Class Example See Also
Remove a cut applied to the element by a cutting instance with unattached voids.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static void RemoveInstanceVoidCut(
    Document document,
    Element element,
    Element cuttingInstance
)
Visual Basic
Public Shared Sub RemoveInstanceVoidCut ( _
    document As Document, _
    element As Element, _
    cuttingInstance As Element _
)
Visual C++
public:
static void RemoveInstanceVoidCut(
    Document^ document,
    Element^ element,
    Element^ cuttingInstance
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document containing the two elements
element
Type: Autodesk.Revit.DB..::..Element
The element being cut
cuttingInstance
Type: Autodesk.Revit.DB..::..Element
The cutting family instance

Examples

CopyC#
// remove all cuts in all family instances created by void-cutting instances
void RemoveVoidCuts(Autodesk.Revit.DB.Document doc, FamilySymbol cuttingSymbol)
{
    FilteredElementCollector collector = new FilteredElementCollector(doc);
    collector.WherePasses(new FamilyInstanceFilter(doc, cuttingSymbol.Id)); // find elements that are family instances of the cutting family

    foreach (FamilyInstance instance in collector)
    {
        foreach (ElementId elementId in InstanceVoidCutUtils.GetElementsBeingCut(instance)) // elements being cut by this instance of the cutting family
        {
            InstanceVoidCutUtils.RemoveInstanceVoidCut(doc, doc.GetElement(elementId), instance); // remove the cut
        }
    }
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | No instance void cut exists between the two elements.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | Failed to remove the instance cut from the element

See Also

InstanceVoidCutUtils Class