Revit 2013 API
ExporterIFC..::..Set3DContextHandle Method
ExporterIFC Class See Also
Sets the IfcRepresentationContext or IfcRepresentationSubContext handle to be used for 3D entities (Model entities).

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void Set3DContextHandle(
    IFCAnyHandle contextHandle,
    string subContextName
)
Visual Basic
Public Sub Set3DContextHandle ( _
    contextHandle As IFCAnyHandle, _
    subContextName As String _
)
Visual C++
public:
void Set3DContextHandle(
    IFCAnyHandle^ contextHandle,
    String^ subContextName
)

Parameters

contextHandle
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The IfcRepresentationContext for 3D entities.
subContextName
Type: System..::..String
The name of the IfcRepresentationSubContext, or the IfcRepresentationContext if the string is empty, for 3D entities.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace