Revit 2013 API
CurveByPoints Class
Members See Also
A curve interpolating two or more points.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class CurveByPoints : CurveElement
Visual Basic
Public Class CurveByPoints _
    Inherits CurveElement
Visual C++
public ref class CurveByPoints : public CurveElement

Remarks

The points to be interpolated are represented as ReferencePoints, which must already exist in the document. In terms of appearance and graphics control, CurveByPoints behaves similarly to ModelCurve. The main difference being that a ModelCurve refers to a SketchPlane, while a CurveByPoints does not. For more methods capable of accessing data from CurveByPoints elements, see the static class CurveByPointsUtils.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..CurveElement
Autodesk.Revit.DB..::..CurveByPoints

See Also

CurveByPoints Members