Revit 2013 API
Frame Class
Members See Also
Represents a coordinate frame of reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class Frame : IDisposable
Visual Basic
Public Class Frame _
    Implements IDisposable
Visual C++
public ref class Frame : IDisposable

Remarks

A Frame consists of three vectors at a base point in 3D space. The vectors need not be orthogonal, have unit length, or even be linearly independent, although in practice Frames will usually have linearly independent vectors.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Frame

See Also

Frame Members