Revit 2013 API
PushButton Properties
PushButton Class See Also

The PushButton type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyName | The assembly path of the button.
Public property | AvailabilityClassName | The full class name for the class providing the entry point to decide availability of this push button.
Public property | ClassName | The name of the class containing the implementation for the command.
Public property | Enabled | Gets or sets a value indicating whether the item is enabled. (Inherited from RibbonItem.)
Public property | Image | The image of the button. (Inherited from RibbonButton.)
Public property | IsEnabledByContext | Indicates if this button can be executed. True if the pushbutton is permitted to be executed based on the current Revit context (active document, active view and active tool). False if the pushbutton is disabled because of the active context. (Inherited from RibbonButton.)
Public property | ItemText | Gets or sets the text displayed on the item. (Inherited from RibbonItem.)
Public property | ItemType | Gets the item type. (Inherited from RibbonItem.)
Public property | LargeImage | The large image shown on the button. (Inherited from RibbonButton.)
Public property | LongDescription | Long description of the command tooltip; (Inherited from RibbonItem.)
Public property | Name | The name of the item. (Inherited from RibbonItem.)
Public property | ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItem.)
Public property | ToolTipImage | The image to show as a part of the button extended tooltip; (Inherited from RibbonItem.)
Public property | Visible | Gets or sets a value indicating whether the item is visible. (Inherited from RibbonItem.)

See Also

PushButton Class
Autodesk.Revit.UI Namespace