Revit 2013 API
CurtainGrid Members
CurtainGrid Class Methods Properties See Also

The CurtainGrid type exposes the following members.

Methods

 | Name | Description
Public method | AddGridLine | Add a grid line to the curtain grid.
Public method | ChangePanelType | Change the type of a curtain panel.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCell | Get the specified cell located by the intersection of the grid lines.
Public method | GetCurtainCells | Gets the CurtainCells owned by this curtain grid.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMullionIds | Gets all ElementIds of the mullions of the curtain grid.
Public method | GetPanel | Get the specified panel located by the intersection of the grid lines.
Public method | GetPanelIds | Gets all ElementIds of the panels of the curtain grid.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUGridLineIds | Gets all ElementIds of grid lines in the U direction.
Public method | GetUnlockedMullionIds | Gets all ElementIds of the unlocked mullions of the curtain grid.
Public method | GetUnlockedPanelIds | Gets all ElementIds of the unlocked panels of the curtain grid.
Public method | GetVGridLineIds | Gets all ElementIds of grid lines in the V direction.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cells | Obsolete. Get all the cells owned by this curtain grid.
Public property | Grid1Angle | The angle for the U grid line pattern of the curtain grid.
Public property | Grid1Justification | The justification for the U grid line pattern of the curtain grid.
Public property | Grid1Offset | The offset for the U grid line pattern of the curtain grid.
Public property | Grid2Angle | The angle for V grid line pattern of the curtain grid.
Public property | Grid2Justification | The justification for the V grid line pattern of the curtain grid.
Public property | Grid2Offset | The offset for V grid line pattern of the curtain grid.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Mullions | Obsolete. Get all the mullions of the curtain grid. The elements in this set are instances of Mullion.
Public property | NumPanels | The number of panels.
Public property | NumULines | Get the number of grid lines in the U direction.
Public property | NumVLines | Get the number of grid lines in the V direction.
Public property | Panels | Obsolete. All the panels of the curtain grid.
Public property | UGridLines | Obsolete. All grid lines in the U direction.
Public property | UnlockedMullions | Obsolete. Get all the unlocked mullions of the curtain grid.
Public property | UnlockedPanels | Obsolete. Get all the unlocked panels of the curtain grid.
Public property | VGridLines | Obsolete. All grid lines in the V direction.

See Also

CurtainGrid Class