Revit 2013 API
MEPSize Members
MEPSize Class Constructors Methods Properties See Also

The MEPSize type exposes the following members.

Constructors

 | Name | Description
Public method | MEPSize | Constructs an object that stores the basic size information for MEP duct, pipe, cable tray and conduit.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the MEPSize
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | InnerDiameter | Inner diameter
Public property | NominalDiameter | Nominal diameter
Public property | OuterDiameter | Outer diameter
Public property | UsedInSizeLists | Whether it is used in size lists.
Public property | UsedInSizing | Whether is used in sizing.

See Also

MEPSize Class