Revit 2013 API
ScheduleDefinition..::..InsertField Method (ScheduleFieldType, ElementId, Int32)
ScheduleDefinition Class See Also
Adds a regular (non-calculated) field at the specified position in the list.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ScheduleField InsertField(
    ScheduleFieldType fieldType,
    ElementId parameterId,
    int index
)
Visual Basic
Public Function InsertField ( _
    fieldType As ScheduleFieldType, _
    parameterId As ElementId, _
    index As Integer _
) As ScheduleField
Visual C++
public:
ScheduleField^ InsertField(
    ScheduleFieldType fieldType,
    ElementId^ parameterId,
    int index
)

Parameters

fieldType
Type: Autodesk.Revit.DB..::..ScheduleFieldType
The type of data displayed by the field.
parameterId
Type: Autodesk.Revit.DB..::..ElementId
The ID of the parameter displayed by the field.
index
Type: System..::..Int32
The index in the list of fields.

Return Value

The new field.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | index is not a valid insert position.
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | The field specified by fieldType and parameterId may not included in this ScheduleDefinition. -or- The field specified by fieldType and parameterId is already included in this ScheduleDefinition.

See Also

ScheduleDefinition Class
InsertField Overload