Revit 2013 API
Application..::..NewPointOnFace Method
Application Class See Also
Construct a PointOnFace object which is used to define the placement of a ReferencePoint given a reference and a location on the face.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public PointOnFace NewPointOnFace(
    Reference faceReference,
    UV uv
)
Visual Basic
Public Function NewPointOnFace ( _
    faceReference As Reference, _
    uv As UV _
) As PointOnFace
Visual C++
public:
PointOnFace^ NewPointOnFace(
    Reference^ faceReference,
    UV^ uv
)

Parameters

faceReference
Type: Autodesk.Revit.DB..::..Reference
The reference whose face the object will be created on.
uv
Type: Autodesk.Revit.DB..::..UV
A 2-dimensional position.

Return Value

A new PointOnFace object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument faceReference or uv is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Application Class
Autodesk.Revit.Creation Namespace