Revit 2013 API
CompoundStructure..::..SetDeckProfileId Method
CompoundStructure Class See Also
Sets the profile loop to use for the specified structural deck.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetDeckProfileId(
    int layerIdx,
    ElementId profileId
)
Visual Basic
Public Sub SetDeckProfileId ( _
    layerIdx As Integer, _
    profileId As ElementId _
)
Visual C++
public:
void SetDeckProfileId(
    int layerIdx,
    ElementId^ profileId
)

Parameters

layerIdx
Type: System..::..Int32
Index of a layer in the CompoundStructure.
profileId
Type: Autodesk.Revit.DB..::..ElementId
The element id of a FamilySymbol which contains a profile loop to be used by the specified layer if it is a structural deck.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The layer is not a structural deck.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The layer index is out of range.

See Also

CompoundStructure Class