Revit 2013 API
PropertySetLibrary..::..HasPropertySet Method
PropertySetLibrary Class See Also
Determines whether the library has a property set with a given name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool HasPropertySet(
    string name
)
Visual Basic
Public Function HasPropertySet ( _
    name As String _
) As Boolean
Visual C++
public:
bool HasPropertySet(
    String^ name
)

Parameters

name
Type: System..::..String
The property set name to look for.

Return Value

True if the library contains a property set with the given name, otherwise false.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PropertySetLibrary Class