Revit 2013 API
IFCExtrusionCreationData..::..CustomAxis Property
IFCExtrusionCreationData Class See Also
The custom extrusion axis to try when generating an extrusion.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public XYZ CustomAxis { get; set; }
Visual Basic
Public Property CustomAxis As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ CustomAxis {
    XYZ^ get ();
    void set (XYZ^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

IFCExtrusionCreationData Class
Autodesk.Revit.DB.IFC Namespace