Revit 2013 API
ScheduleDefinition..::..CanFilterBySubstring Method
ScheduleDefinition Class See Also
Checks whether a field can be used with a substring-based filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool CanFilterBySubstring(
    ScheduleFieldId fieldId
)
Visual Basic
Public Function CanFilterBySubstring ( _
    fieldId As ScheduleFieldId _
) As Boolean
Visual C++
public:
bool CanFilterBySubstring(
    ScheduleFieldId^ fieldId
)

Parameters

fieldId
Type: Autodesk.Revit.DB..::..ScheduleFieldId
The ID of the field to check.

Return Value

True if the field can be used with a substring-based filter, false otherwise.

Remarks

The substring-based filter types are Contains, NotContains, BeginsWith, NonBeginsWith, EndsWith and NotEndsWith.

Only string parameters can be filtered by substring.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | fieldId is not the ID of a field in this ScheduleDefinition.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ScheduleDefinition Class