Revit 2013 API
ExternalFileReferenceType Enumeration
See Also
Enum class indicating kinds of external file references

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012
Since: 2012

Syntax

C#
public enum ExternalFileReferenceType
Visual Basic
Public Enumeration ExternalFileReferenceType
Visual C++
public enum class ExternalFileReferenceType

Members

Member name | Description
None | Uninitialized value
RevitLink | Revit linked files
CADLink | Linked CAD files
DWFMarkup | DWF markup files
KeynoteTable | The keynote table (The file which contains keynote information.)
Decal | Decals (images which appear only during rendering)
Material | Materials are not included as ExternalFileReferences in the 2012 release

See Also