Revit 2013 API
PlanarFace..::..Normal Property
PlanarFace Class See Also
Normal of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ Normal { get; }
Visual Basic
Public ReadOnly Property Normal As XYZ
    Get
Visual C++
public:
property XYZ^ Normal {
    XYZ^ get ();
}

Remarks

This property is the "surface normal" vector. This is not necessarily the normal vector pointing out of the solid that contains the face, to get that value use ComputeNormal(UV).

See Also

PlanarFace Class