Revit 2013 API
MechanicalSystemType..::..Create Method
MechanicalSystemType Class See Also
Creates a new instance of a mechanical system type and adds it to the document.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static MechanicalSystemType Create(
    Document ADoc,
    MEPSystemClassification systemClassification,
    string name
)
Visual Basic
Public Shared Function Create ( _
    ADoc As Document, _
    systemClassification As MEPSystemClassification, _
    name As String _
) As MechanicalSystemType
Visual C++
public:
static MechanicalSystemType^ Create(
    Document^ ADoc,
    MEPSystemClassification systemClassification,
    String^ name
)

Parameters

ADoc
Type: Autodesk.Revit.DB..::..Document
The document where the element will be created and added.
systemClassification
Type: Autodesk.Revit.DB..::..MEPSystemClassification
The classification for the mechanical system type to be created
name
Type: System..::..String
The name of the mechanical system type to be created.

Return Value

The newly created mechanical system type element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | The system classification is not valid for the domain of this system type.

See Also

MechanicalSystemType Class
Autodesk.Revit.DB.Mechanical Namespace