Revit 2013 API
DefinitionGroups Members
DefinitionGroups Class Methods Properties See Also

The DefinitionGroups type exposes the following members.

Methods

 | Name | Description
Public method | Contains | Tests for the existence of a definition group within the collection.
Public method | Create | Create a new parameter definition group using the name provided.
Public method | Dispose | Releases all resources used by the DefinitionGroups
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetEnumerator | Retrieves an enumerator to the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Identifies if the definition groups collection is empty.
Public property | Item | Retrieve a definition group by name.
Public property | Size | The number of definition groups in the collection.

See Also

DefinitionGroups Class