Revit 2013 API
IExternalServer..::..GetServiceId Method
IExternalServer Interface See Also
Implement this method to return the id of the service.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
ExternalServiceId GetServiceId()
Visual Basic
Function GetServiceId As ExternalServiceId
Visual C++
ExternalServiceId^ GetServiceId()

Return Value

The id of the service to which the server belongs.

Remarks

An external server belongs to only one external service. This method must return an Id that matches the Id the corresponding service was registered with.

See Also

IExternalServer Interface
Autodesk.Revit.DB.ExternalService Namespace