Revit 2013 API
ConceptualSurfaceType Class
Members See Also
This element represents a conceptual BIM object category to assign to faces in Mass geometries. There is one ConceptualSurfaceType element for each of the Mass Surface Subcategories. for serialization

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class ConceptualSurfaceType : IDisposable
Visual Basic
Public Class ConceptualSurfaceType _
    Implements IDisposable
Visual C++
public ref class ConceptualSurfaceType : IDisposable

Remarks

When Conceptual Energy Analysis is enabled in Revit Projects, massing faces will be assigned to the subcategories of Mass category that these ConceptualSurfaceType's are associated with. A default ConceptualConstructionType is associated with the ConceptualSurfaceType. This default ConceptualConstructionType is assigned to Mass faces with the corresponding subcategory. Changing the default ConceptualConstructionType associated with the ConceptualSurfaceType will update the ConceptualConstruction type for all Mass faces of that subcategory which the user has not specifically provided an override value for.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Analysis..::..ConceptualSurfaceType

See Also

ConceptualSurfaceType Members
Autodesk.Revit.DB.Analysis Namespace