Revit 2013 API
ScheduleFilter Methods
ScheduleFilter Class See Also

The ScheduleFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetDoubleValue | Gets the filter value for a filter using a double value.
Public method | GetElementIdValue | Gets the filter value for a filter using an ElementId value.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIntegerValue | Gets the filter value for a filter using an integer value.
Public method | GetStringValue | Gets the filter value for a filter using a string value.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetNullValue | Sets the filter to have no specified value (used for HasParameter filters).
Public method | SetValue(Double) | Set the filter value to a double.
Public method | SetValue(Int32) | Set the filter value to an integer.
Public method | SetValue(String) | Set the filter value to a string.
Public method | SetValue(ElementId) | Set the filter value to an ElementId.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ScheduleFilter Class