Revit 2013 API
HandRailType..::..SupportJustification Property
HandRailType Class See Also
The support justification method of the handrail.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public RailSupportJustification SupportJustification { get; set; }
Visual Basic
Public Property SupportJustification As RailSupportJustification
    Get
    Set
Visual C++
public:
property RailSupportJustification SupportJustification {
    RailSupportJustification get ();
    void set (RailSupportJustification value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The rail has no support or the support layout is not fixed distance so the data being set is not applicable.

See Also

HandRailType Class
Autodesk.Revit.DB.Architecture Namespace