Revit 2013 API
TransmissionData..::..WriteTransmissionData Method
TransmissionData Class See Also
Writes the given TransmissionData into the Revit file at the given location.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static void WriteTransmissionData(
    ModelPath path,
    TransmissionData data
)
Visual Basic
Public Shared Sub WriteTransmissionData ( _
    path As ModelPath, _
    data As TransmissionData _
)
Visual C++
public:
static void WriteTransmissionData(
    ModelPath^ path,
    TransmissionData^ data
)

Parameters

path
Type: Autodesk.Revit.DB..::..ModelPath
A ModelPath indicating the file Revit should write the TransmissionData of. This ModelPath must be a file path and an absolute path.
data
Type: Autodesk.Revit.DB..::..TransmissionData
The TransmissionData to be written into the document. Note that Revit will not check that the ElementIds in the TransmissionData correspond to real Elements.

Remarks

This function will overwrite the existing TransmissionData in the file. This function will not support models on Revit server. This must be called on a closed document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..FileArgumentNotFoundException | There is not a valid Revit file at path's location
Autodesk.Revit.Exceptions..::..InvalidOperationException | Operation is not valid for Revit Server models. -or- This function cannot be called on an opened document.

See Also

TransmissionData Class