Revit 2013 API
IFCData..::..AsString Method
IFCData Class See Also
Gets storage value as string when its PrimitiveType is string, binary or enumeration.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public string AsString()
Visual Basic
Public Function AsString As String
Visual C++
public:
String^ AsString()

Return Value

The string value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InapplicableDataException | The primitive type is not string, binary or enumeration.

See Also

IFCData Class
Autodesk.Revit.DB.IFC Namespace