Revit 2013 API
Form..::..Rehost Method (SketchPlane, XYZ)
Form Class See Also
Rehost Form to sketch plane

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void Rehost(
    SketchPlane sketchPlane,
    XYZ location
)
Visual Basic
Public Sub Rehost ( _
    sketchPlane As SketchPlane, _
    location As XYZ _
)
Visual C++
public:
void Rehost(
    SketchPlane^ sketchPlane,
    XYZ^ location
)

Parameters

sketchPlane
Type: Autodesk.Revit.DB..::..SketchPlane
The sketch plane on which to rehost the form.
location
Type: Autodesk.Revit.DB..::..XYZ
The location to which to Rehost the form.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the sketchPlane or location is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when rehosting Form failed.

See Also

Form Class
Rehost Overload