Revit 2013 API
Definitions Class
Members See Also
A base class that supports the addition of new parameter definitions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class Definitions : IEnumerable<Definition>,
    IDisposable
Visual Basic
Public Class Definitions _
    Implements IEnumerable(Of Definition), IDisposable
Visual C++
public ref class Definitions : IEnumerable<Definition^>,
    IDisposable

Remarks

There are two derivations of this class, one of which handles external parameters and another which handles internal parameters.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Definitions
Autodesk.Revit.DB..::..ExternalDefinitions
Autodesk.Revit.DB..::..InternalDefinitions

See Also

Definitions Members