Revit 2013 API
IFCFile..::..Create Method
IFCFile Class See Also
Creates an IFC file for exporting.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static IFCFile Create(
    IFCFileModelOptions modelOptions
)
Visual Basic
Public Shared Function Create ( _
    modelOptions As IFCFileModelOptions _
) As IFCFile
Visual C++
public:
static IFCFile^ Create(
    IFCFileModelOptions^ modelOptions
)

Parameters

modelOptions
Type: Autodesk.Revit.DB.IFC..::..IFCFileModelOptions
The options.

Return Value

The IFC file.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCFile Class
Autodesk.Revit.DB.IFC Namespace