Revit 2013 API
IFCTypeInfo..::..MaterialId Property
IFCTypeInfo Class See Also
The material id associated with this type.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementId MaterialId { get; set; }
Visual Basic
Public Property MaterialId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ MaterialId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

IFCTypeInfo Class
Autodesk.Revit.DB.IFC Namespace