Revit 2013 API
FilterElementIdRule Members
FilterElementIdRule Class Constructors Methods Properties See Also

The FilterElementIdRule type exposes the following members.

Constructors

 | Name | Description
Public method | FilterElementIdRule | Constructs an instance of FilterElementIdRule.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterRule.)
Public method | ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEvaluator | Gets the evaluator that implements the test for this rule. (Inherited from FilterNumericValueRule.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetEvaluator | Sets the evaluator that implements the test for this rule. (Inherited from FilterNumericValueRule.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | RuleValue | The user-supplied value against which values from a Revit document will be tested.

See Also

FilterElementIdRule Class