Revit 2013 API
EnergyDataSettings..::..BuildingHVACSystem Property
EnergyDataSettings Class See Also
The type of HVAC system used by the building for conceptual model energy calculations.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public gbXMLBuildingHVACSystem BuildingHVACSystem { get; set; }
Visual Basic
Public Property BuildingHVACSystem As gbXMLBuildingHVACSystem
    Get
    Set
Visual C++
public:
property gbXMLBuildingHVACSystem BuildingHVACSystem {
    gbXMLBuildingHVACSystem get ();
    void set (gbXMLBuildingHVACSystem value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The building HVAC system does not fall within an appropriate range.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace