Revit 2013 API
RadialArray..::..ArrayElementWithoutAssociation Method
RadialArray Class See Also
Creates a new radial array from a single element based on an input rotation axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static ICollection<ElementId> ArrayElementWithoutAssociation(
    Document aDoc,
    View dBView,
    ElementId id,
    int count,
    Line axis,
    double angle,
    ArrayAnchorMember anchorMember
)
Visual Basic
Public Shared Function ArrayElementWithoutAssociation ( _
    aDoc As Document, _
    dBView As View, _
    id As ElementId, _
    count As Integer, _
    axis As Line, _
    angle As Double, _
    anchorMember As ArrayAnchorMember _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ ArrayElementWithoutAssociation(
    Document^ aDoc,
    View^ dBView,
    ElementId^ id,
    int count,
    Line^ axis,
    double angle,
    ArrayAnchorMember anchorMember
)

Parameters

aDoc
Type: Autodesk.Revit.DB..::..Document
The view. If it is a 2d view, translation vector must be in the view plane if the element is a view-specific element.
dBView
Type: Autodesk.Revit.DB..::..View
The view.
id
Type: Autodesk.Revit.DB..::..ElementId
The element to array. The position of the rotation axis is determined by the center of the element's bounding boxes.
count
Type: System..::..Int32
The number of array members to create. The accepted range is from 3 to 200.
axis
Type: Autodesk.Revit.DB..::..Line
The rotation axis.
angle
Type: System..::..Double
The angle in radians of the rotation.
anchorMember
Type: Autodesk.Revit.DB..::..ArrayAnchorMember
Indicates if the translation vector specifies the location of the second member of the array, or the last member of the array.

Return Value

The elements created by the operation.

Remarks

The resulting elements will not be associated with an array element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The element id does not exist in the document -or- id is not arrayable. -or- count must be between 3 and 200. -or- The view is invalid for specific view elements array. -or- The rotation axis is invalid to array the element.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | Failed to create the radial array.

See Also

RadialArray Class