Revit 2013 API
UIDocument..::..SaveAndClose Method
UIDocument Class See Also
Close the document, prompting the user for saving it when necessary.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public bool SaveAndClose()
Visual Basic
Public Function SaveAndClose As Boolean
Visual C++
public:
bool SaveAndClose()

Return Value

False if closing procedure fails or if saving of a modified document was requested but failed. Also returns False if closing is cancelled by an external application during 'DocumentClosing' event. When function succeeds, True is returned.

Remarks

UI dialogs may be shown during the call (e.g. when the document has been changed since last time it was saved) to get user responses. The currently active document may not be closed by this function. It can only be closed via Revit's UI.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when attempting to close the currently active document. Thrown if there are any transactions, sub-transactions or transaction groups which were opened by the API code, and not closed. All of these items must be handled before attempting to close the document.

See Also

UIDocument Class
Autodesk.Revit.UI Namespace