Revit 2013 API
XYZ..::..Subtract Method
XYZ Class See Also
Subtracts the specified vector from this vector and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ Subtract(
    XYZ source
)
Visual Basic
Public Function Subtract ( _
    source As XYZ _
) As XYZ
Visual C++
public:
XYZ^ Subtract(
    XYZ^ source
)

Parameters

source
Type: Autodesk.Revit.DB..::..XYZ
The vector to subtract from this vector.

Return Value

The vector equal to the difference between the two vectors.

Remarks

The subtracted vector is obtained by subtracting each coordinate of the specified vector from the corresponding coordinate of this vector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when source is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

XYZ Class