Revit 2013 API
CylindricalFace Members
CylindricalFace Class Methods Properties See Also

The CylindricalFace type exposes the following members.

Methods

 | Name | Description
Public method | ComputeDerivatives | Returns the vectors describing the face at the specified point. (Inherited from Face.)
Public method | ComputeNormal | Returns the normal vector for the face at the given point. (Inherited from Face.)
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | Evaluate | Evaluates parameters on the face. (Inherited from Face.)
Public method | GetBoundingBox | Returns the UV bounding box of the face. (Inherited from Face.)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code; (Inherited from GeometryObject.)
Public method | GetRegions | Face regions (created with the Split Face command) of the face. (Inherited from Face.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect(Curve) | Calculates the intersection of the specified curve with this face. (Inherited from Face.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of the specified curve with this face and returns the intersection results. (Inherited from Face.)
Public method | IsInside(UV) | Indicates whether the specified point is within this face. (Inherited from Face.)
Public method | IsInside(UV, IntersectionResult%) | Indicates whether the specified point is within this face and outputs additional results. (Inherited from Face.)
Public method | Project | Projects the specified point on this face. (Inherited from Face.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Triangulate()()()() | Returns a triangular mesh approximation to the face. (Inherited from Face.)
Public method | Triangulate(Double) | Returns a triangular mesh approximation to the face. (Inherited from Face.)

Properties

 | Name | Description
Public property | Area | The area of this face. (Inherited from Face.)
Public property | Axis | Axis of the surface.
Public property | EdgeLoops | Each edge loop is a closed boundary of the face. (Inherited from Face.)
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle; (Inherited from GeometryObject.)
Public property | HasRegions | Reports if the face contains regions created with the Split Face command. (Inherited from Face.)
Public property | IsCyclic | The boolean value that indicates whether this face is periodic in the specified parametric direction. (Inherited from Face.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsTwoSided | Determines if a face is two-sided (degenerate); (Inherited from Face.)
Public property | MaterialElementId | Element ID of the material from which this face is composed. (Inherited from Face.)
Public property | Origin | Origin of the surface.
Public property | Period | The period of this face in the specified parametric direction. (Inherited from Face.)
Public property | Radius | Radii of the surface.
Public property | Reference | Returns a stable reference to the face. (Inherited from Face.)
Public property | Visibility | The visibility. (Inherited from GeometryObject.)

See Also

CylindricalFace Class