Revit 2013 API
ReferencePlane..::..Direction Property
ReferencePlane Class See Also
The direction of the reference plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ Direction { get; set; }
Visual Basic
Public Property Direction As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ Direction {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

When setting this property, an exception will be thrown if the direction vector is almost zero or if it is not perpendicular to the normal vector.

See Also

ReferencePlane Class