Revit 2013 API
Plane Constructor (XYZ, XYZ)
Plane Class See Also
Constructor for geometry plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Plane(
    XYZ norm,
    XYZ origin
)
Visual Basic
Public Sub New ( _
    norm As XYZ, _
    origin As XYZ _
)
Visual C++
public:
Plane(
    XYZ^ norm,
    XYZ^ origin
)

Parameters

norm
Type: Autodesk.Revit.DB..::..XYZ
The normal vector of the plane.
origin
Type: Autodesk.Revit.DB..::..XYZ
The coordinates for the origin.

Remarks

Used to construct a new Plane object.

See Also

Plane Class
Plane Overload