Revit 2013 API
Edge Members
Edge Class Methods Properties See Also

The Edge type exposes the following members.

Methods

 | Name | Description
Public method | AsCurve | Returns a curve that corresponds to the edge's parametric orientation.
Public method | AsCurveFollowingFace | Returns a curve that corresponds to this edge as oriented in its topological direction on the specified face.
Public method | ComputeDerivatives | Returns the vectors describing the edge at the specified parameter.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | Evaluate | Evaluates a parameter on the edge.
Public method | EvaluateOnFace | Evaluates a parameter on the edge to produce UV coordinates on the face.
Public method | GetHashCode | Gets the integer value of the geometry object as hash code; (Inherited from GeometryObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Tessellate | Returns a polyline approximation to the edge.
Public method | TessellateOnFace | Returns a polyline approximation to the edge in UV parameters of the face.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ApproximateLength | Returns the approximate length of the edge.
Public property | EndPointReference | Returns a stable reference to the start or the end point of the edge.
Public property | Face | Returns one of the two faces that meet at the edge.
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle; (Inherited from GeometryObject.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Reference | Returns a stable reference to the edge.
Public property | Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Edge Class