Revit 2013 API
DGNImportOptions Properties
DGNImportOptions Class See Also

The DGNImportOptions type exposes the following members.

Properties

 | Name | Description
Public property | AutoCorrectAlmostVHLines | Correct almost-vertical lines and almost-horizontal lines for import model if option is set to true, the almost-vertical lines would be vertical lines and almost-horizontal lines would be horizontal lines. (Inherited from BaseImportOptions.)
Public property | ColorMode | Color mode for the import. Three modes are supported. Black and White, Preserve Colors, and Invert Colors. (Inherited from BaseImportOptions.)
Public property | CustomScale | Scaling the import. If this is defined and a valid value (> 0.0), it takes preference over units. (Inherited from BaseImportOptions.)
Public property | DGNModelViewName | The model view name to be imported. Need user give a model view name to specify which model view need to be imported into Revit
Public property | IgnoreUnsupportedElementWarning | If true, ignore warning messages about unsupported elements in the DGN file. If false, the import process is aborted if imported dgn files have unsupported elements.
Public property | OrientToView | Place the import at the same orientation as the view that was passed into the import method. This option can only be used when not importing into a single view.(i.e. ThisViewOnly is set to false); (Inherited from BaseImportOptions.)
Public property | Placement | Where to place the import. Set this option to place the view at the origin or the center, or a shared coordinates. (Inherited from BaseImportOptions.)
Public property | ThisViewOnly | Imports drawings into the view that was passed into the import method. This option is not available in 3D views. (Inherited from BaseImportOptions.)
Public property | Unit | The unit of measure for imported geometry. (Inherited from BaseImportOptions.)
Public property | VisibleLayersOnly | Only import the visible layers. (Inherited from BaseImportOptions.)

See Also

DGNImportOptions Class