Revit 2013 API
IFCExtrusionData Members
IFCExtrusionData Class Constructors Methods Properties See Also

The IFCExtrusionData type exposes the following members.

Constructors

 | Name | Description
Public method | IFCExtrusionData | Constructs a new empty extrusion data object.

Methods

 | Name | Description
Public method | AddLoop | Adds a curve loop to the extrusion data.
Public method | ClearLoops | Clears the curve loops stored in the extrusion data.
Public method | Dispose | Releases all resources used by the IFCExtrusionData
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLoops | Gets the curve loops that form the base shape of the extrusion.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid | Determines if the extrusion data represents a valid extrusion.
Public method | RemoveLoopAt | Removes the loop at the specified index.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ExtrusionBasis | The basis used for the extrusion.
Public property | ExtrusionDirection | The direction used for the extrusion.
Public property | ScaledExtrusionLength | The length of the extrusion, scaled in the units of the export.

See Also

IFCExtrusionData Class
Autodesk.Revit.DB.IFC Namespace