Revit 2013 API
ScheduleDefinition..::..CanFilterByValue Method
ScheduleDefinition Class See Also
Checks whether a field can be used with a value-based filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool CanFilterByValue(
    ScheduleFieldId fieldId
)
Visual Basic
Public Function CanFilterByValue ( _
    fieldId As ScheduleFieldId _
) As Boolean
Visual C++
public:
bool CanFilterByValue(
    ScheduleFieldId^ fieldId
)

Parameters

fieldId
Type: Autodesk.Revit.DB..::..ScheduleFieldId
The ID of the field to check.

Return Value

True if the field can be used with a value based filter, false otherwise.

Remarks

The value-based filter types are Equal, NotEqual, GreaterThan, GreaterThanOrEqual, LessThan and LessThanOrEqual.

Only certain types of parameters can be filtered by value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | fieldId is not the ID of a field in this ScheduleDefinition.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ScheduleDefinition Class