Revit 2013 API
RebarBendData Members
RebarBendData Class Constructors Methods Properties See Also

The RebarBendData type exposes the following members.

Constructors

 | Name | Description
Public method | RebarBendData()()()() | Initializes a new instance of the RebarBendData class
Public method | RebarBendData(RebarBarType, RebarHookType, RebarHookType, RebarStyle) | Initializes a new instance of the RebarBendData class

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the RebarBendData
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BarDiameter | The diameter of the bar.
Public property | BendRadius | The radius of all fillets, except hook fillets, in the Rebar shape.
Public property | HookBendRadius | The radius of the hook fillets in the Rebar shape.
Public property | HookLength0 | The extension length of the hook at the start.
Public property | HookLength1 | The extension length of the hook at the end.

See Also

RebarBendData Class
Autodesk.Revit.DB.Structure Namespace