Revit 2013 API
UIControlledApplication Methods
UIControlledApplication Class See Also

The UIControlledApplication type exposes the following members.

Methods

 | Name | Description
Public method | CreateAddInCommandBinding | Creates a new AddInCommandBinding.
Public method | CreateRibbonPanel(String) | Create a new RibbonPanel on the Add-Ins tab.
Public method | CreateRibbonPanel(String, String) | Create a new RibbonPanel on the specified tab.
Public method | CreateRibbonPanel(Tab, String) | Create a new RibbonPanel on the designated standard Revit tab.
Public method | CreateRibbonTab | Creates a new tab on the Revit user interface.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRibbonPanels()()()() | Get all the custom Panels on Add-Ins tab of Revit.
Public method | GetRibbonPanels(String) | Get all the custom Panels on a designated Revit tab.
Public method | GetRibbonPanels(Tab) | Get all the custom Panels on a designated standard Revit tab.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RemoveAddInCommandBinding | Removes an AddInCommandBinding.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UIControlledApplication Class
Autodesk.Revit.UI Namespace