Revit 2013 API
CompoundStructure..::..SampleHeight Property
CompoundStructure Class See Also
The sample height is the presumed height of the wall to which the data in this CompoundStructure is applied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double SampleHeight { get; set; }
Visual Basic
Public Property SampleHeight As Double
    Get
    Set
Visual C++
public:
property double SampleHeight {
    double get ();
    void set (double value);
}

Field Value

The height of the wall used to define the vertically compound structure.

Remarks

This value has meaning only for vertically compound structures. In order to apply this CompoundStructure to a wall whose height differs from the sample height, the underlying grid will be rescaled.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is valid only vertically compound structures.

See Also

CompoundStructure Class