Revit 2013 API
WorksharingDisplaySettings..::..SetGraphicOverrides Method (String, WorksharingDisplayGraphicSettings)
WorksharingDisplaySettings Class See Also
Sets the graphic overrides assigned to elements owned by a particular user. The username cannot be on the list of removed usernames.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void SetGraphicOverrides(
    string username,
    WorksharingDisplayGraphicSettings overrides
)
Visual Basic
Public Sub SetGraphicOverrides ( _
    username As String, _
    overrides As WorksharingDisplayGraphicSettings _
)
Visual C++
public:
void SetGraphicOverrides(
    String^ username,
    WorksharingDisplayGraphicSettings^ overrides
)

Parameters

username
Type: System..::..String
The username of the desired user.
overrides
Type: Autodesk.Revit.DB..::..WorksharingDisplayGraphicSettings
The desired graphic overrides for this user.

Remarks

Note that you can specify usernames which do not yet exist in the document's user table.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The username is on the list of removed users.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

WorksharingDisplaySettings Class
SetGraphicOverrides Overload