Revit 2013 API
Part..::..SetFaceOffset Method
Part Class See Also
Offsets the given part face in the direction that points out of the solid shape with the specified amount. Negative value will offset the face into the solid shape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void SetFaceOffset(
    Face face,
    double offset
)
Visual Basic
Public Sub SetFaceOffset ( _
    face As Face, _
    offset As Double _
)
Visual C++
public:
void SetFaceOffset(
    Face^ face,
    double offset
)

Parameters

face
Type: Autodesk.Revit.DB..::..Face
The face to offset.
offset
Type: System..::..Double
The magnitude of the offset.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | -or- The face to be offset should be planar and satisfy constraints of its parent element
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

Part Class