Revit 2013 API
ExporterIFC..::..GetLevelInfo Method
ExporterIFC Class See Also
Returns an object representing the information about a level in the document.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IFCLevelInfo GetLevelInfo(
    ElementId levelId
)
Visual Basic
Public Function GetLevelInfo ( _
    levelId As ElementId _
) As IFCLevelInfo
Visual C++
public:
IFCLevelInfo^ GetLevelInfo(
    ElementId^ levelId
)

Parameters

levelId
Type: Autodesk.Revit.DB..::..ElementId
The level id.

Return Value

The level information.

Remarks

Level information is currently automatically collected and cached in the ExporterIFC object. This method returns the cached information for a given level, which is often needed during export of particular building elements which reference levels, as well as to implement automatic wall and column splitting.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace