Revit 2013 API
Document..::..NewSpaceBoundaryLines Method
Document Class See Also
Creates a new boundary line as an Space border.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ModelCurveArray NewSpaceBoundaryLines(
    SketchPlane sketchPlane,
    CurveArray curves,
    View view
)
Visual Basic
Public Function NewSpaceBoundaryLines ( _
    sketchPlane As SketchPlane, _
    curves As CurveArray, _
    view As View _
) As ModelCurveArray
Visual C++
public:
ModelCurveArray^ NewSpaceBoundaryLines(
    SketchPlane^ sketchPlane,
    CurveArray^ curves,
    View^ view
)

Parameters

sketchPlane
Type: Autodesk.Revit.DB..::..SketchPlane
The sketch plan
curves
Type: Autodesk.Revit.DB..::..CurveArray
The geometry curves on which the boundary lines are
view
Type: Autodesk.Revit.DB..::..View
The View for the new Space

See Also

Document Class
Autodesk.Revit.Creation Namespace