Revit 2013 API
IFCProductWrapper..::..AddSite Method
IFCProductWrapper Class See Also
Adds a site (IfcObject) handle to associate with the IfcProduct in this wrapper.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void AddSite(
    IFCAnyHandle siteHandle
)
Visual Basic
Public Sub AddSite ( _
    siteHandle As IFCAnyHandle _
)
Visual C++
public:
void AddSite(
    IFCAnyHandle^ siteHandle
)

Parameters

siteHandle
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The site handle.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCProductWrapper Class
Autodesk.Revit.DB.IFC Namespace