Revit 2013 API
Entity Members
Entity Class Constructors Methods Properties See Also

The Entity type exposes the following members.

Constructors

 | Name | Description
Public method | Entity()()()() | The default-constructed Entity is invalid.
Public method | Entity(Guid) | Creates a new Entity corresponding to the Schema of the specified GUID.
Public method | Entity(Entity) | Initializes a new instance of the Entity class
Public method | Entity(Schema) | Creates a new Entity corresponding to the Schema.

Methods

 | Name | Description
Public method | Clear(String) | Resets the field to its default value.
Public method | Clear(Field) | Resets the field to its default value.
Public method | Dispose | Releases all resources used by the Entity
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Get<(Of <<'(FieldType>)>>)(String) | Retrieves the value of the field in the entity.
Public method | Get<(Of <<'(FieldType>)>>)(Field) | Retrieves the value of the field in the entity.
Public method | Get<(Of <<'(FieldType>)>>)(String, DisplayUnitType) | Retrieves the value of the field in the entity.
Public method | Get<(Of <<'(FieldType>)>>)(Field, DisplayUnitType) | Retrieves the value of the field in the entity.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid | Checks whether this Entity has a live Schema corresponding to it.
Public method | ReadAccessGranted | Checks whether this Entity may be retrieved by the current add-in.
Public method | RecognizedField | Checks whether a Field belongs to the same Schema as this Entity.
Public method | Set<(Of <<'(FieldType>)>>)(String, FieldType) | Stores the value of the field in the entity.
Public method | Set<(Of <<'(FieldType>)>>)(Field, FieldType) | Stores the value of the field in the entity.
Public method | Set<(Of <<'(FieldType>)>>)(String, FieldType, DisplayUnitType) | Stores the value of the field in the entity.
Public method | Set<(Of <<'(FieldType>)>>)(Field, FieldType, DisplayUnitType) | Stores the value of the field in the entity.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WriteAccessGranted | Checks whether this Entity may be stored by the current add-in.

Properties

 | Name | Description
Public property | Schema | The Schema describing this Entity.
Public property | SchemaGUID | The GUID of the Schema describing this Entity.

See Also

Entity Class
Autodesk.Revit.DB.ExtensibleStorage Namespace