Revit 2013 API
PointCloudFilterUtils..::..GetFilteredOutline Method
PointCloudFilterUtils Class See Also
Computes outline of a part of a box that satisfies given PointCloudFilter.

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static Outline GetFilteredOutline(
    PointCloudFilter filter,
    Outline box
)
Visual Basic
Public Shared Function GetFilteredOutline ( _
    filter As PointCloudFilter, _
    box As Outline _
) As Outline
Visual C++
public:
static Outline^ GetFilteredOutline(
    PointCloudFilter^ filter,
    Outline^ box
)

Parameters

filter
Type: Autodesk.Revit.DB.PointClouds..::..PointCloudFilter
Point cloud filter.
box
Type: Autodesk.Revit.DB..::..Outline
A box aligned with coordinate axes.

Return Value

The bounding box of the set of all points within the original box that satisfy the filter. Not every point within the resulting outline satisfies the filter, but any point that is contained in the original box and satisfies the filter is guaranteed to be within the resulting outline.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PointCloudFilterUtils Class
Autodesk.Revit.DB.PointClouds Namespace