Revit 2013 API
Application..::..NewPointOnPlane Method
Application Class See Also
Construct a PointOnPlane object which is used to define the placement of a ReferencePoint from its property values.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public PointOnPlane NewPointOnPlane(
    Reference planeReference,
    UV position,
    UV xvec,
    double offset
)
Visual Basic
Public Function NewPointOnPlane ( _
    planeReference As Reference, _
    position As UV, _
    xvec As UV, _
    offset As Double _
) As PointOnPlane
Visual C++
public:
PointOnPlane^ NewPointOnPlane(
    Reference^ planeReference,
    UV^ position,
    UV^ xvec,
    double offset
)

Parameters

planeReference
Type: Autodesk.Revit.DB..::..Reference
A reference to some plane in the document. (Note: the reference must satisfy IsValidPlaneReference(), but this is not checked until this PointOnPlane object is assigned to a ReferencePoint.)
position
Type: Autodesk.Revit.DB..::..UV
Coordinates of the point's projection onto the plane; see the Position property.
xvec
Type: Autodesk.Revit.DB..::..UV
The direction of the point's X-coordinate vector in the plane's coordinates; see the XVec property. Optional; default value is (1, 0).
offset
Type: System..::..Double
Signed offset from the plane; see the Offset property.

Return Value

A new PointOnPlane object with 2-dimensional Position, XVec, and Offset properties set to match the given 3-dimensional arguments.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument planeReference or position or xvec is nullNothingnullptra null reference (Nothing in Visual Basic) or offset is not a valid double value.

See Also

Application Class
Autodesk.Revit.Creation Namespace