Revit 2013 API
Edge Properties
Edge Class See Also

The Edge type exposes the following members.

Properties

 | Name | Description
Public property | ApproximateLength | Returns the approximate length of the edge.
Public property | EndPointReference | Returns a stable reference to the start or the end point of the edge.
Public property | Face | Returns one of the two faces that meet at the edge.
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle; (Inherited from GeometryObject.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Reference | Returns a stable reference to the edge.
Public property | Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Edge Class