Revit 2013 API
IFCFile..::..CreateHeaderInstance Method
IFCFile Class See Also
Creates an IFC header instance in the file model.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IFCAnyHandle CreateHeaderInstance(
    string name
)
Visual Basic
Public Function CreateHeaderInstance ( _
    name As String _
) As IFCAnyHandle
Visual C++
public:
IFCAnyHandle^ CreateHeaderInstance(
    String^ name
)

Parameters

name
Type: System..::..String
The instance name.

Return Value

The instance handle.

Remarks

file_schema, file_description and file_name must be created to get IFC file written successfully. Otherwise, the output IFC file would be empty.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCFile Class
Autodesk.Revit.DB.IFC Namespace