Revit 2013 API
ThermalProperties Members
ThermalProperties Class Methods Properties See Also

The ThermalProperties type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Absorptance | Value of absorptance.
Public property | HeatTransferCoefficient | The heat transfer coefficient value (U-Value). The unit is watts per meter-squared kelvin (W/(m^2*K)).
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Roughness | Value of roughness.
Public property | ThermalMass | The calculated thermal mass value. The unit is kilogram feet-squared per second squared kelvin (kg ft^2/(s^2 K)).
Public property | ThermalResistance | The calculated thermal resistance value (R-Value). The unit is meter-squared kelvin per watt ((m^2*K)/Watt).

See Also

ThermalProperties Class