Revit 2013 API
TrussMemberInfo Members
TrussMemberInfo Class Constructors Methods Properties See Also

The TrussMemberInfo type exposes the following members.

Constructors

 | Name | Description
Public method | TrussMemberInfo | For Internal Use Only.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | hostTrussId | The host truss' ElementId of the member.
Public property | lockedToTruss | Whether the member is locked to the host truss.
Public property | memberTypeKey | Kind of the member in the truss.

See Also

TrussMemberInfo Class
Autodesk.Revit.DB.Structure Namespace