Revit 2013 API
IFCExtrusionCreationData Methods
IFCExtrusionCreationData Class See Also

The IFCExtrusionCreationData type exposes the following members.

Methods

 | Name | Description
Public method | AddOpening | Adds an opening to the data.
Public method | ClearOpenings | Removes all cached openings from the data.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLocalPlacement | Gets the reference to the IfcLocalPlacement handle used when creating the extrusion.
Public method | GetOpenings | Gets a collection of all of the openings stored in this data.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetLocalPlacement | Sets the data to reference an IfcLocalPlacement handle when creating the extrusion. Side effect: will set ReuseLocalPlacement to true.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IFCExtrusionCreationData Class
Autodesk.Revit.DB.IFC Namespace