Revit 2013 API
ParameterFilterRuleFactory..::..CreateEqualsRule Method (ElementId, String, Boolean)
ParameterFilterRuleFactory Class See Also
Creates a filter rule that determines whether strings from the document equal a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static FilterRule CreateEqualsRule(
    ElementId parameter,
    string value,
    bool caseSensitive
)
Visual Basic
Public Shared Function CreateEqualsRule ( _
    parameter As ElementId, _
    value As String, _
    caseSensitive As Boolean _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateEqualsRule(
    ElementId^ parameter,
    String^ value,
    bool caseSensitive
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
A string-typed parameter used to get values from the document for a given element.
value
Type: System..::..String
The user-supplied string value against which values from the document will be compared.
caseSensitive
Type: System..::..Boolean
If true, the string comparison will be case-sensitive.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterRuleFactory Class
CreateEqualsRule Overload