Revit 2013 API
Options Members
Options Class Constructors Methods Properties See Also

The Options type exposes the following members.

Constructors

 | Name | Description
Public method | Options()()()() | Creates a default Options object.
Public method | Options(Options) | Copy constructor.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ComputeReferences | Determines whether or not references to geometric objects are computed.
Public property | DetailLevel | The detail level for the geometry extracted with these options.
Public property | IncludeNonVisibleObjects | Whether to extract element geometry objects not set as Visible. The default is false.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | View | The view used for geometry extraction.

See Also

Options Class