Revit 2013 API
ElementArray..::..Insert Method
ElementArray Class See Also
Insert the specified element into the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Insert(
    Element item,
    int index
)
Visual Basic
Public Overridable Sub Insert ( _
    item As Element, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    Element^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::..Element
The element to be inserted into the array.
index
Type: System..::..Int32
The element will be inserted before this index.

Return Value

Returns whether the element was inserted into the array.

See Also

ElementArray Class