Revit 2013 API
ScheduleSortGroupField Constructor (ScheduleFieldId, ScheduleSortOrder)
ScheduleSortGroupField Class See Also
Creates a new ScheduleSortGroupField.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ScheduleSortGroupField(
    ScheduleFieldId fieldId,
    ScheduleSortOrder sortOrder
)
Visual Basic
Public Sub New ( _
    fieldId As ScheduleFieldId, _
    sortOrder As ScheduleSortOrder _
)
Visual C++
public:
ScheduleSortGroupField(
    ScheduleFieldId^ fieldId,
    ScheduleSortOrder sortOrder
)

Parameters

fieldId
Type: Autodesk.Revit.DB..::..ScheduleFieldId
The ID of the field that the schedule will be sorted or grouped by.
sortOrder
Type: Autodesk.Revit.DB..::..ScheduleSortOrder
The sort order, ascending or descending.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ScheduleSortGroupField Class
ScheduleSortGroupField Overload