Revit 2013 API
RoutingPreferenceManager..::..GetMEPPartId Method
RoutingPreferenceManager Class See Also
Gets a fitting or segment id of given routing preference group that meets the specified routing conditions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId GetMEPPartId(
    RoutingPreferenceRuleGroupType groupType,
    RoutingConditions conditions
)
Visual Basic
Public Function GetMEPPartId ( _
    groupType As RoutingPreferenceRuleGroupType, _
    conditions As RoutingConditions _
) As ElementId
Visual C++
public:
ElementId^ GetMEPPartId(
    RoutingPreferenceRuleGroupType groupType,
    RoutingConditions^ conditions
)

Parameters

groupType
Type: Autodesk.Revit.DB..::..RoutingPreferenceRuleGroupType
The routing preference group
conditions
Type: Autodesk.Revit.DB..::..RoutingConditions
A set of routing conditions

Return Value

The Id of the fitting or segment that met the given routing conditions.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

RoutingPreferenceManager Class