Revit 2013 API
ElementIsCurveDrivenFilter Members
ElementIsCurveDrivenFilter Class Constructors Methods Properties See Also

The ElementIsCurveDrivenFilter type exposes the following members.

Constructors

 | Name | Description
Public method | ElementIsCurveDrivenFilter()()()() | Constructs a new instance of a filter to match only curve driven elements.
Public method | ElementIsCurveDrivenFilter(Boolean) | Constructs a new instance of a filter to match only curve driven elements, with the option to match all elements which are not curve driven elements.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

ElementIsCurveDrivenFilter Class