Revit 2013 API
ExporterIFCUtils..::..IsCurveFromOtherElementSketch Method
ExporterIFCUtils Class See Also
Identifies if the given curve element is generated by another element's sketch, or if it represents an independent curve element accessible directly by the user.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static bool IsCurveFromOtherElementSketch(
    CurveElement curveElement
)
Visual Basic
Public Shared Function IsCurveFromOtherElementSketch ( _
    curveElement As CurveElement _
) As Boolean
Visual C++
public:
static bool IsCurveFromOtherElementSketch(
    CurveElement^ curveElement
)

Parameters

curveElement
Type: Autodesk.Revit.DB..::..CurveElement
The curve element.

Return Value

True if the curve element was generated by a sketch, false if it is independent.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace