Revit 2013 API
AdaptiveComponentInstanceUtils..::..GetInstancePlacementPointElementRefIds Method
AdaptiveComponentInstanceUtils Class See Also
Gets Placement Adaptive Point Element Ref ids to which the instance geometry adapts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static IList<ElementId> GetInstancePlacementPointElementRefIds(
    FamilyInstance famInst
)
Visual Basic
Public Shared Function GetInstancePlacementPointElementRefIds ( _
    famInst As FamilyInstance _
) As IList(Of ElementId)
Visual C++
public:
static IList<ElementId^>^ GetInstancePlacementPointElementRefIds(
    FamilyInstance^ famInst
)

Parameters

famInst
Type: Autodesk.Revit.DB..::..FamilyInstance
The FamilyInstance.

Return Value

The Placement Adaptive Point Element Ref ids to which the instance geometry adapts.

Remarks

The output contains placement point ref ids. The element ids are sorted in by the placement numbers (increasing order).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The FamilyInstance famInst is not an Adaptive Family Instance. -or- The FamilyInstance famInst does not have an Adaptive Family Symbol.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation failed.

See Also

AdaptiveComponentInstanceUtils Class