Revit 2013 API
StairsRunType..::..RiserToTreadConnect Property
StairsRunType Class See Also
The connection of the riser to tread in relation to each other.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public RiserToTreadConnectionOption RiserToTreadConnect { get; set; }
Visual Basic
Public Property RiserToTreadConnect As RiserToTreadConnectionOption
    Get
    Set
Visual C++
public:
property RiserToTreadConnectionOption RiserToTreadConnect {
    RiserToTreadConnectionOption get ();
    void set (RiserToTreadConnectionOption value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The run type has no riser so the data being set is not applicable.

See Also

StairsRunType Class
Autodesk.Revit.DB.Architecture Namespace