Revit 2013 API
CompoundStructure..::..FindEnclosingRegionAndSegments Method
CompoundStructure Class See Also
Given a pair of grid coordinates, and a direction for splitting, returns the enclosing region and the two segments intersected by a line through the grid point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int FindEnclosingRegionAndSegments(
    UV gridUV,
    RectangularGridSegmentOrientation splitDirection,
    out int segmentId1,
    out int segmentId2
)
Visual Basic
Public Function FindEnclosingRegionAndSegments ( _
    gridUV As UV, _
    splitDirection As RectangularGridSegmentOrientation, _
    <OutAttribute> ByRef segmentId1 As Integer, _
    <OutAttribute> ByRef segmentId2 As Integer _
) As Integer
Visual C++
public:
int FindEnclosingRegionAndSegments(
    UV^ gridUV,
    RectangularGridSegmentOrientation splitDirection,
    [OutAttribute] int% segmentId1,
    [OutAttribute] int% segmentId2
)

Parameters

gridUV
Type: Autodesk.Revit.DB..::..UV
Coordinates of a point in the rectangular grid of this compound structure.
splitDirection
Type: Autodesk.Revit.DB..::..RectangularGridSegmentOrientation
Specifies the direction of the split.
segmentId1
Type: System..::..Int32%
The id of a segment in the boundary of the containing region which is split by a line through gridUV in the specified direction.
segmentId2
Type: System..::..Int32%
The id of a segment in the boundary of the containing region which is split by a line through gridUV in the specified direction.

Return Value

Returns the id of the enclosing region, and -1 if no region encloses the point.

Remarks

Grid coordinates correspond to uv coordinates of faces.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is valid only vertically compound structures.

See Also

CompoundStructure Class