Revit 2013 API
ExporterIFCUtils..::..GetRelativeLocalPlacementOffsetTransform Method
ExporterIFCUtils Class See Also
Obtains the relative transform between two IfcLocalPlacement handles.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static Transform GetRelativeLocalPlacementOffsetTransform(
    IFCAnyHandle originalPlacement,
    IFCAnyHandle relativePlacement
)
Visual Basic
Public Shared Function GetRelativeLocalPlacementOffsetTransform ( _
    originalPlacement As IFCAnyHandle, _
    relativePlacement As IFCAnyHandle _
) As Transform
Visual C++
public:
static Transform^ GetRelativeLocalPlacementOffsetTransform(
    IFCAnyHandle^ originalPlacement,
    IFCAnyHandle^ relativePlacement
)

Parameters

originalPlacement
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The original placement from which the result transforms coordinates and directions.
relativePlacement
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The relative placement to which the result transforms coordinates and directions.

Return Value

The transform from the original placement to the new placement.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace