Revit 2013 API
IFCTypeInfo..::..IsValid Method
IFCTypeInfo Class See Also
Identifies if the object represents a valid type info.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool IsValid()
Visual Basic
Public Function IsValid As Boolean
Visual C++
public:
bool IsValid()

Return Value

True if the object is valid, false otherwise.

Remarks

A type info must have either the style, 3d map handle, or 2d map handle set to a valid value to be valid.

See Also

IFCTypeInfo Class
Autodesk.Revit.DB.IFC Namespace