Revit 2013 API
IFCTransformSetter Class
Members See Also
A state-based class that forces an extra transformation applied to objects being exported.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class IFCTransformSetter : IDisposable
Visual Basic
Public Class IFCTransformSetter _
    Implements IDisposable
Visual C++
public ref class IFCTransformSetter : IDisposable

Remarks

IFC has a system of local placements; these are created from a set of transforms in Revit. Sometimes there is a need to create a 'fake' transform to get the right local placement structure for IFC. This class is intended to maintain the transformation for the duration that it is needed. To ensure that the lifetime of the object is correctly managed, you should declare an instance of this class as a part of a 'using' statement in C# or similar construct in other lanuguages.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.IFC..::..IFCTransformSetter

See Also

IFCTransformSetter Members
Autodesk.Revit.DB.IFC Namespace