Revit 2013 API
RoutingCondition Members
RoutingCondition Class Constructors Methods Properties See Also

The RoutingCondition type exposes the following members.

Constructors

 | Name | Description
Public method | RoutingCondition | Initializes a new instance of the RoutingCondition class

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the RoutingCondition
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Diameter | The diameter of the segment or fitting specified for the routing condition. inhouse Returns zero for non-round profiles (not fully supported yet).

See Also

RoutingCondition Class