Revit 2013 API
LocationPoint Members
LocationPoint Class Methods Properties See Also

The LocationPoint type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Move | Move the element within the project by a specified vector. (Inherited from Location.)
Public method | Rotate | Rotate the element within the project by a specified angle around a given axis. (Inherited from Location.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Point | Get and set the physical location of the element.
Public property | Rotation | Retrieve the angle of rotation around the insertion point.

See Also

LocationPoint Class