Revit 2013 API
CompoundStructure..::..GetRegionEnvelope Method
CompoundStructure Class See Also
Gets the envelope that a specified region spans.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public BoundingBoxUV GetRegionEnvelope(
    int regionId
)
Visual Basic
Public Function GetRegionEnvelope ( _
    regionId As Integer _
) As BoundingBoxUV
Visual C++
public:
BoundingBoxUV^ GetRegionEnvelope(
    int regionId
)

Parameters

regionId
Type: System..::..Int32
The id of the region.

Return Value

The envelope of the region.

Remarks

This envelope indicates the external boundary of the region. The coordinate system it defines is used in the results of GetSegmentCoordinate().

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | It is not a valid region id.
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is valid only vertically compound structures.

See Also

CompoundStructure Class