Revit 2013 API
Document..::..NewFascia Method (FasciaType, ReferenceArray)
Document Class See Also
Creates a fascia along a reference array.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Fascia NewFascia(
    FasciaType FasciaType,
    ReferenceArray references
)
Visual Basic
Public Function NewFascia ( _
    FasciaType As FasciaType, _
    references As ReferenceArray _
) As Fascia
Visual C++
public:
Fascia^ NewFascia(
    FasciaType^ FasciaType,
    ReferenceArray^ references
)

Parameters

FasciaType
Type: Autodesk.Revit.DB.Architecture..::..FasciaType
The type of the fascia to create
references
Type: Autodesk.Revit.DB..::..ReferenceArray
An array of planar lines and arcs that represents the place where you want to place the fascia.

Return Value

If successful a new fascia object within the project, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Document Class
NewFascia Overload
Autodesk.Revit.Creation Namespace