Revit 2013 API
LayoutRule Class
Members See Also
The LayoutRule object is a base object for all type of layout rules for Beam System within the Autodesk Revit API.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class LayoutRule : APIObject
Visual Basic
Public MustInherit Class LayoutRule _
    Inherits APIObject
Visual C++
public ref class LayoutRule abstract : public APIObject

Remarks

This class just used as the base class of those concrete LayoutRule classes.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..LayoutRule
Autodesk.Revit.DB..::..LayoutRuleClearSpacing
Autodesk.Revit.DB..::..LayoutRuleFixedDistance
Autodesk.Revit.DB..::..LayoutRuleFixedNumber
Autodesk.Revit.DB..::..LayoutRuleMaximumSpacing

See Also

LayoutRule Members