Revit 2013 API
ExtrusionAnalyzer Methods
ExtrusionAnalyzer Class See Also

The ExtrusionAnalyzer type exposes the following members.

Methods

 | Name | Description
Public method | CalculateFaceAlignment | Calculates the alignment status of each face of the solid.
 | Create | Creates an ExtrusionAnalyzer and computes and stores the solid's shadow.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetExtrusionBase | Obtains the face that represents the base contour of the extrusion analysis.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExtrusionAnalyzer Class