Revit 2013 API
RebarShapeConstraintSegmentLength Constructor
RebarShapeConstraintSegmentLength Class See Also
Create a segment length constraint.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public RebarShapeConstraintSegmentLength(
    ElementId paramId,
    RebarShapeSegmentEndReferenceType refType0,
    RebarShapeSegmentEndReferenceType refType1
)
Visual Basic
Public Sub New ( _
    paramId As ElementId, _
    refType0 As RebarShapeSegmentEndReferenceType, _
    refType1 As RebarShapeSegmentEndReferenceType _
)
Visual C++
public:
RebarShapeConstraintSegmentLength(
    ElementId^ paramId,
    RebarShapeSegmentEndReferenceType refType0,
    RebarShapeSegmentEndReferenceType refType1
)

Parameters

paramId
Type: Autodesk.Revit.DB..::..ElementId
The Id of a Rebar Shape parameter.
refType0
Type: Autodesk.Revit.DB.Structure..::..RebarShapeSegmentEndReferenceType
Choose between two possibilities for the first reference of the length constraint.
refType1
Type: Autodesk.Revit.DB.Structure..::..RebarShapeSegmentEndReferenceType
Choose between two possibilities for the second reference of the length constraint.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

RebarShapeConstraintSegmentLength Class
Autodesk.Revit.DB.Structure Namespace