Revit 2013 API
EnergyDataSettings Properties
EnergyDataSettings Class See Also

The EnergyDataSettings type exposes the following members.

Properties

 | Name | Description
Public property | BuildingConstructionClass | Used for both the detailed and conceptual energy model Construction class of building as defined by: loose, medium, tight, or none.
Public property | BuildingHVACSystem | The type of HVAC system used by the building for conceptual model energy calculations.
Public property | BuildingOperatingSchedule | The operating schedule of the building used for conceptual model energy calculations.
Public property | BuildingType | The type of building.
Public property | CreateAnalyticalModel | If this is true, data, features, and geometry related to the Energy Analytical Model will be created, allowing the energy performance to be analyzed through GreenBuilidingXML.
Public property | EnergyModel | if this is on there should be an energy model dependent on the current AnalysisType if it is off the conceptual energy model should be turned off but setting this datum does not do the work, just reflects the state.
Public property | ExportCategory | Value is a category indicating which discipline model will be used for GreenBuildingXML export.
Public property | ExportComplexity | Value determines Export Complexity for GreenBuildingXML detailed model export.
Public property | ExportDefaults | Use for detailed model GreenBuildingXML export. When this setting is true, all building and space defaults, schedules, and constructions will be exported to GreenBuildingXML. When this setting is false, only values that are specified on the zone or space will be exported to GreenBuildingXML.
Public property | GroundPlane | Id of level which represents ground level.
Public property | IncludeThermalProperties | Indicates if thermal information from model assemblies and components is included in GreenBuildingXML export of the detailed model.
Public property | IsExportMullionsEnabled | Indicates if mullions are included in GreenBuildingXML export of the detailed model.
Public property | IsExportShadingSurfacesEnabled | Indicates if "shading surfaces" are included in GreenBuildingXML export of the detailed model.
Public property | IsExportSimplifiedCurtainSystemsEnabled | Indicates if curtain system geometry is being simplified for GreenBuildingXML export of the detailed model.
Public property | IsGlazingShaded | If this is true, glazing/windows that are auto-created on exterior walls will automatically have a shading device created on their top edge.
Public property | MassZoneCoreOffset | It defines the default behavior for the automatic generation of Mass Zones for each Mass Floor in the Project. Specifying a value here will offset the outside perimeter of a Mass Zone to create the core.
Public property | MassZoneDividePerimeter | If this is true, outward facing zones on each floor of the building will be divided based on the four compass directions.
Public property | OutsideAirChangesRatePerHour |
Public property | OutsideAirPerArea |
Public property | OutsideAirPerPerson |
Public property | PercentageGlazing | Used for the conceptual energy model. The approximate percentage of the building exterior wall surfaces which are covered by windows or other glazing.
Public property | PercentageSkylights | Used for the conceptual energy model. The approximate percentage of the building roof surfaces in massing instances for the Conceptual Energy Analytical Model.
Public property | ProjectPhase | The project phase of the EnergyData information.
Public property | ProjectReportType | Report type: None, simple, standard, detailed
Public property | ServiceType | The type of heating or cooling system.
Public property | ShadeDepth | Used for the conceptual energy model. Amount that auto-generated shading will extend from auto-generated windows.
Public property | SillHeight | Used for the conceptual energy model. The height from the nearest lower level used for auto-glazing created on walls.
Public property | SkylightWidth | Used for the conceptual energy model. The approximate width used for the skylights in massing instances when the Energy Analytical model is being created.
Public property | SliverSpaceTolerance | Used for Detailed GreenBuildingXML export. This value is used to identify sliver spaces, i.e. spaces bounded by parallel surfaces belonging to different rooms.
Public property | UseAirChangesPerHour | True if user is specifying air changes per hour, false otherwise.
Public property | UseHeatingCredits | If true, Revit will use heating credits in the final load sum calculations. If false, Revit will ignore heating credits in the final load sum calculations.
Public property | UseOutsideAirPerArea | True is user is specifying outside air per area, false otherwise.
Public property | UseOutsideAirPerPerson | True if user is specifying outside air per person, false otherwise.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace