Revit 2013 API
CurveByPointsUtils Methods
CurveByPointsUtils Class See Also

The CurveByPointsUtils type exposes the following members.

Methods

 | Name | Description
 | AddCurvesToFaceRegion | Adds The CurveElements to one or more FaceRegions.
 | CreateRectangle | Creates rectangle on face or sketchplane for two given diagonal points.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetFaceRegions | Gets the FaceRegions in the existing face.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHostFace | Gets the host face to which the CurveElement is added.
 | GetProjectionType | Gets the projection type of the CurveElement.
 | GetSketchOnSurface | Gets the relationship between the CurveElement and face.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | SetProjectionType | Sets the projection type of the CurveElement.
 | SetSketchOnSurface | Sets the relationship between the CurveElement and face.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | ValidateCurveElementIdArrayForFaceRegions | Validates that the input CurveElements can define FaceRegions. The CurveElements must be CurveByPoints. Each curve must be entirely hosted by a single Face or hosts related to a common Face (for example, Edges of a common Face, other CurveElements hosted by a common Face). To be added to the FaceRegion definition, a CurveElement must have the SketchOnSurface attribute set.

See Also

CurveByPointsUtils Class