Revit 2013 API
AnalyticalModel..::..SetAnalyzeAs Method
AnalyticalModel Class See Also
Sets value of Analyze As parameter for this Element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void SetAnalyzeAs(
    AnalyzeAs analyzeAs
)
Visual Basic
Public Sub SetAnalyzeAs ( _
    analyzeAs As AnalyzeAs _
)
Visual C++
public:
void SetAnalyzeAs(
    AnalyzeAs analyzeAs
)

Parameters

analyzeAs
Type: Autodesk.Revit.DB.Structure..::..AnalyzeAs
Indicates how Analytical Model is analyzed .

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | analyzeAs is invalid for analytical model.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace