Revit 2013 API
CompoundStructure..::..SetLayerFunction Method
CompoundStructure Class See Also
Sets the function of the specified layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetLayerFunction(
    int layerIdx,
    MaterialFunctionAssignment function
)
Visual Basic
Public Sub SetLayerFunction ( _
    layerIdx As Integer, _
    function As MaterialFunctionAssignment _
)
Visual C++
public:
void SetLayerFunction(
    int layerIdx,
    MaterialFunctionAssignment function
)

Parameters

layerIdx
Type: System..::..Int32
Index of a layer in the CompoundStructure.
function
Type: Autodesk.Revit.DB..::..MaterialFunctionAssignment
The function of the layer.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The layer index is out of range.

See Also

CompoundStructure Class