Revit 2013 API
ExporterIFCUtils..::..GetUnscaledTransform Method
ExporterIFCUtils Class See Also
Obtains the unscaled transform from an IfcLocalPlacement handle.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static Transform GetUnscaledTransform(
    ExporterIFC exporterIFC,
    IFCAnyHandle placement
)
Visual Basic
Public Shared Function GetUnscaledTransform ( _
    exporterIFC As ExporterIFC, _
    placement As IFCAnyHandle _
) As Transform
Visual C++
public:
static Transform^ GetUnscaledTransform(
    ExporterIFC^ exporterIFC,
    IFCAnyHandle^ placement
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
placement
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The placement handle.

Return Value

The transform.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace