Revit 2013 API
ViewSchedule Class
Members See Also
A schedule view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class ViewSchedule : View
Visual Basic
Public Class ViewSchedule _
    Inherits View
Visual C++
public ref class ViewSchedule : public View

Remarks

The ViewSchedule class represents schedules and other schedule-like views, including single-category and multi-category schedules, key schedules, material takeoffs, view lists, sheet lists, keynote legends, revision schedules, and note blocks. The ViewSchedule class is not used for panel schedules (see PanelScheduleView) or graphical column schedules.

A schedule is a tabular representation of data. A typical schedule shows all elements of a category (doors, rooms, etc.) with each row representing an element and each column representing a parameter. This basic structure can be modified using filters, sorting, grouping, totals, formulas, and other features.

The ScheduleDefinition class contains most settings that determine the contents of a schedule, including category, fields, filters, and sorting.

A graphical representation of a schedule can be placed on a sheet using the ScheduleSheetInstance class.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..View
Autodesk.Revit.DB..::..ViewSchedule

See Also

ViewSchedule Members