Revit 2013 API
BuiltInFailures..::..ViewFailures Members
BuiltInFailures..::..ViewFailures Class Properties See Also

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..ViewFailures type exposes the following members.

Properties

Name | Description
BadViewDirectionSetting | Plan view DBViewType has invalid view direction parameter.
CanNotDeleteLastOpenView | Deleting of all open views in a project is not allowed.
CannotPasteViewReferences | Cannot paste view references into the view they reference or into unrelated views
DetailNumberDuplicate | Detail Number is already in use. Enter a unique number.
DetailNumberEmpty | Detail Number is empty
InitialViewDeleted | The starting view for the project has been deleted.
InsertColumnViewError | Column cannot be placed in Elevation or Section view
InsertColumnViewFailure | Column cannot be placed in Elevation or Section view
InsertComponentViewError | This type of Component cannot be placed in Elevation or Section view
InsertComponentViewFailure | This type of Component cannot be placed in Elevation or Section view
InvalidDBviewScopeBox | Can't construct View Clipping and Cropping from Scope Box.
NewElementInvisibleInCurrentView | The newly created object is not visible in the current view.
NoTargetsForDependentViewPropagation | There are no valid views. Only views without dependents can be used.
NothingToApplyError | Start and end elevations are the same, nothing to Apply.
NothingToApplyWarning | Start and end elevations are the same, nothing to Apply.
ReloadLatestDeletedLastOpenView | The only open view has been deleted because of changes from the Central Model. Open another view and Reload Latest or Synchronize with Central again.
TurnCropRegionOffRemovesViewBreaks | Turning off the Crop Region of the view will remove all View Breaks. If the Crop Region is turned on at a later time, any desired View Breaks must be created again.
ViewPublishFailed | The following views could not be published.
ZeroLengthViewBreaksRemoved | Some View Regions were consolidated. When the size of a View Break between View Regions becomes zero, the View Break is removed and the adjacent View Regions are joined.
ZeroLengthViewRegionsRemoved | Some View Regions were removed. When the size of a View Region becomes zero, it is removed from the view.

See Also

BuiltInFailures..::..ViewFailures Class