Revit 2013 API
FamilyItemFactory..::..NewFamilyInstance Method
FamilyItemFactory Class See Also
Inserts a new instance of a family into the document.

Overload List

 | Name | Description
Public method | NewFamilyInstance(Face, Line, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a line on that face for its position, and a type/symbol. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(Line, FamilySymbol, View) | Add a line based detail family instance into the Autodesk Revit document, using an line and a view where the instance should be placed. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(Reference, Line, FamilySymbol) | Inserts a new instance of a family onto a face referenced by the input Reference instance, using a line on that face for its position, and a type/symbol. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(XYZ, FamilySymbol, StructuralType) | Inserts a new instance of a family into the document, using a location and a type/symbol. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(XYZ, FamilySymbol, View) | Add a new family instance into the Autodesk Revit document, using an origin and a view where the instance should be placed. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(Face, XYZ, XYZ, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a location, reference direction, and a type/symbol. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(Reference, XYZ, XYZ, FamilySymbol) | Inserts a new instance of a family onto a face referenced by the input Reference instance, using a location, reference direction, and a type/symbol. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(XYZ, FamilySymbol, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, and the host element. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(XYZ, FamilySymbol, XYZ, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, the host element and a reference direction. (Inherited from ItemFactoryBase.)

See Also

FamilyItemFactory Class
FamilyItemFactory Members
Autodesk.Revit.Creation Namespace