Revit 2013 API
IFCExtrusionData..::..AddLoop Method
IFCExtrusionData Class See Also
Adds a curve loop to the extrusion data.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void AddLoop(
    CurveLoop pLoop
)
Visual Basic
Public Sub AddLoop ( _
    pLoop As CurveLoop _
)
Visual C++
public:
void AddLoop(
    CurveLoop^ pLoop
)

Parameters

pLoop
Type: Autodesk.Revit.DB..::..CurveLoop
The curve loop.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCExtrusionData Class
Autodesk.Revit.DB.IFC Namespace