Revit 2013 API
BaseExportOptions..::..GetPredefinedSetupNames Method
BaseExportOptions Class See Also
Returns a list of names of predefined setups of export options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static IList<string> GetPredefinedSetupNames(
    Document document
)
Visual Basic
Public Shared Function GetPredefinedSetupNames ( _
    document As Document _
) As IList(Of String)
Visual C++
public:
static IList<String^>^ GetPredefinedSetupNames(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
A Revit document to retrieve names from.

Return Value

An array of strings representing names of predefined setups.

Remarks

The predefined setups may be used for export to both DWG and DXF formats. To get predefined options in the desired format use the static method getPredefinedOptions defined in DWGExportOptions or DXFExportOptions respectively.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

BaseExportOptions Class