Revit 2013 API
ExporterIFCUtils..::..TransformAndScalePoint Method
ExporterIFCUtils Class See Also
Converts a point from global Revit coordinates to current IFC coordinates, including scale.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static XYZ TransformAndScalePoint(
    ExporterIFC exporterIFC,
    XYZ origPt
)
Visual Basic
Public Shared Function TransformAndScalePoint ( _
    exporterIFC As ExporterIFC, _
    origPt As XYZ _
) As XYZ
Visual C++
public:
static XYZ^ TransformAndScalePoint(
    ExporterIFC^ exporterIFC,
    XYZ^ origPt
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
origPt
Type: Autodesk.Revit.DB..::..XYZ
The original point.

Return Value

The transformed and scaled point.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace