Revit 2013 API
FilteredElementCollector..::..WherePasses Method
FilteredElementCollector Class See Also
Applies an element filter to the collector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FilteredElementCollector WherePasses(
    ElementFilter filter
)
Visual Basic
Public Function WherePasses ( _
    filter As ElementFilter _
) As FilteredElementCollector
Visual C++
public:
FilteredElementCollector^ WherePasses(
    ElementFilter^ filter
)

Parameters

filter
Type: Autodesk.Revit.DB..::..ElementFilter
The element filter.

Return Value

A handle to this collector. This is the same collector that has just been modified, returned so you can chain multiple calls together in one line.

Remarks

The filter will be added as an additional condition that all filtered elements must pass. If you have an active iterator to this collector it will be stopped by this call.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FilteredElementCollector Class