Revit 2013 API
ParameterFilterElement..::..GetRuleParameter Method
ParameterFilterElement Class See Also
Returns the parameter for a given filter rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static ElementId GetRuleParameter(
    FilterRule rule
)
Visual Basic
Public Shared Function GetRuleParameter ( _
    rule As FilterRule _
) As ElementId
Visual C++
public:
static ElementId^ GetRuleParameter(
    FilterRule^ rule
)

Parameters

rule
Type: Autodesk.Revit.DB..::..FilterRule
The rule to query.

Return Value

The identifier of the rule's parameter.

Remarks

If the given rule is a FilterInverseRule, then getRuleParameter will return the parameter of its inner rule.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given rule is not parameter-based.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterElement Class