Revit 2013 API
SlabShapeEditor..::..DrawPoint Method
SlabShapeEditor Class See Also
Adds a point to the corresponding slab, roof or floor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public SlabShapeVertex DrawPoint(
    XYZ location
)
Visual Basic
Public Function DrawPoint ( _
    location As XYZ _
) As SlabShapeVertex
Visual C++
public:
SlabShapeVertex^ DrawPoint(
    XYZ^ location
)

Parameters

location
Type: Autodesk.Revit.DB..::..XYZ
The location of the point.

Return Value

The newly created vertex.

Remarks

If the input location is not on the top face of the slab, this function will return nullNothingnullptra null reference (Nothing in Visual Basic). Drawing a point on boundary crease may increase the number of creases. This method will regenerate the document even in manual regeneration mode.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the location is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

SlabShapeEditor Class