Revit 2013 API
FilterNumericRuleEvaluator Class
Members See Also
Base for all classes that compare numeric values from Revit to a user-supplied filter value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class FilterNumericRuleEvaluator : IDisposable
Visual Basic
Public Class FilterNumericRuleEvaluator _
    Implements IDisposable
Visual C++
public ref class FilterNumericRuleEvaluator : IDisposable

Remarks

A class derived from FilterNumericRuleEvaluator must handle both integer and double-precision types. For double-precision comparisons, an epsilon value is given. The evaluator class should use this value in a manner appropriate to the comparison being implemented.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FilterNumericRuleEvaluator
Autodesk.Revit.DB..::..FilterNumericEquals
Autodesk.Revit.DB..::..FilterNumericGreater
Autodesk.Revit.DB..::..FilterNumericGreaterOrEqual
Autodesk.Revit.DB..::..FilterNumericLess
Autodesk.Revit.DB..::..FilterNumericLessOrEqual

See Also

FilterNumericRuleEvaluator Members