Revit 2013 API
SymbolicCurveArray..::..Item Property
SymbolicCurveArray Class See Also
Gets or sets a model curve at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual SymbolicCurve this[
    int index
] { get; set; }
Visual Basic
Public Overridable Property Item ( _
    index As Integer _
) As SymbolicCurve
    Get
    Set
Visual C++
public:
virtual property SymbolicCurve^ Item[int index] {
    SymbolicCurve^ get (int index);
    void set (int index, SymbolicCurve^ value);
}

Parameters

index
Type: System..::..Int32
The index of the model curve to be set or retrieved.

Return Value

Returns the model curve at the specified index.

See Also

SymbolicCurveArray Class