Revit 2013 API
Reference Members
Reference Class Constructors Methods Properties See Also

The Reference type exposes the following members.

Constructors

 | Name | Description
Public method | Reference | Creates a Reference with the supplied element.

Methods

 | Name | Description
Public method | ConvertToStableRepresentation | Converts the reference to a stable String representation.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | ParseFromStableRepresentation | Converts a stable String representation of a reference to a Reference object.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ElementId | The element id for this reference.
Public property | ElementReferenceType | The type of reference.
Public property | GlobalPoint | The position on which the reference is hit.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | UVPoint | The UV parameters of the reference, if the reference contains a face.

See Also

Reference Class