Revit 2013 API
RenderingQualitySettings..::..ShouldComputeIndirectAndSkyIllumination Property
RenderingQualitySettings Class See Also
Indicates whether to include light that bounces off other objects, and light from the sky when calculating the lighting for this scene.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool ShouldComputeIndirectAndSkyIllumination { get; set; }
Visual Basic
Public Property ShouldComputeIndirectAndSkyIllumination As Boolean
    Get
    Set
Visual C++
public:
property bool ShouldComputeIndirectAndSkyIllumination {
    bool get ();
    void set (bool value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The RenderingQualitySettings does not use custom quality currently. To use custom quality, set RenderingQuality property to RenderingQuality.Custom.

See Also

RenderingQualitySettings Class