Revit 2013 API
SchemaBuilder..::..SetWriteAccessLevel Method
SchemaBuilder Class See Also
Sets top level write access (for entities)

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public SchemaBuilder SetWriteAccessLevel(
    AccessLevel writeAccessLevel
)
Visual Basic
Public Function SetWriteAccessLevel ( _
    writeAccessLevel As AccessLevel _
) As SchemaBuilder
Visual C++
public:
SchemaBuilder^ SetWriteAccessLevel(
    AccessLevel writeAccessLevel
)

Parameters

writeAccessLevel
Type: Autodesk.Revit.DB.ExtensibleStorage..::..AccessLevel
Write access level value to be set

Return Value

The SchemaBuilder object may be used to add more settings.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The SchemaBuilder has already finished building the Schema.

See Also

SchemaBuilder Class
Autodesk.Revit.DB.ExtensibleStorage Namespace