Revit 2013 API
LinkedFileStatus Enumeration
See Also
Enum displaying the loaded status of a linked file

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public enum LinkedFileStatus
Visual Basic
Public Enumeration LinkedFileStatus
Visual C++
public enum class LinkedFileStatus

Members

Member name | Description
Invalid | This value is the uninitialized value for the enum. It indicates that the link has not been properly initialized.
Loaded | The link is loaded.
Unloaded | The link is unloaded.
Imported | The element represented by this value was imported into Revit rather than linked into Revit.
NotFound | The linked file was not able to be found the last time Revit tried to load it.

See Also