Revit 2013 API
DuctLiningType..::..Roughness Property
DuctLiningType Class See Also

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double Roughness { get; set; }
Visual Basic
Public Property Roughness As Double
    Get
    Set
Visual C++
public:
property double Roughness {
    double get ();
    void set (double value);
}

Remarks

The roughness of Duct Lining.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The roughness value should be at least equal to or larger than 0.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Mechanical Electrical Piping.

See Also

DuctLiningType Class
Autodesk.Revit.DB.Mechanical Namespace