Revit 2013 API
Form..::..RotateProfile Method
Form Class See Also
Rotate a profile of the form, by a specified angle around a given axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void RotateProfile(
    int profileIndex,
    Line axis,
    double angle
)
Visual Basic
Public Sub RotateProfile ( _
    profileIndex As Integer, _
    axis As Line, _
    angle As Double _
)
Visual C++
public:
void RotateProfile(
    int profileIndex,
    Line^ axis,
    double angle
)

Parameters

profileIndex
Type: System..::..Int32
Index to specify the profile.
axis
Type: Autodesk.Revit.DB..::..Line
An unbounded line that represents the axis of rotation.
angle
Type: System..::..Double
The angle, in radians, by which the element is to be rotated around the specified axis.

See Also

Form Class