Revit 2013 API
AnalysisDisplayColorSettings Members
AnalysisDisplayColorSettings Class Constructors Methods Properties See Also

The AnalysisDisplayColorSettings type exposes the following members.

Constructors

 | Name | Description
Public method | AnalysisDisplayColorSettings()()()() | Constructs a default instance of color settings.
Public method | AnalysisDisplayColorSettings(AnalysisDisplayColorSettings) | Constructs copy of a color settings object.

Methods

 | Name | Description
Public method | AreIntermediateColorsValid | Verify intermediate color entries
Public method | Colors | Get number of colors, including min, max and intermediate.
Public method | Dispose | Releases all resources used by the AnalysisDisplayColorSettings
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIntermediateColors | Get intermediate color entries (other than the minimum and maximum settings).
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual | Compares two color settings objects.
Public method | SetIntermediateColors | Set intermediate color entries (other than the minimum and maximum settings).
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ColorSettingsType | Stores type of color settings
Public property | MaxColor | Color assigned to the maximum value.
Public property | MinColor | Color assigned to the minimum value.

See Also

AnalysisDisplayColorSettings Class
Autodesk.Revit.DB.Analysis Namespace