Revit 2013 API
ElectricalLoadClassification..::..DemandFactorId Property
ElectricalLoadClassification Class See Also
The demand factor definition this load classification element uses.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ElementId DemandFactorId { get; set; }
Visual Basic
Public Property DemandFactorId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ DemandFactorId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

ElectricalLoadClassification Class
Autodesk.Revit.DB.Electrical Namespace