Revit 2013 API
PipingSystemType..::..Create Method
PipingSystemType Class See Also
Creates a new instance of a piping system type and adds it to the document.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static PipingSystemType Create(
    Document ADoc,
    MEPSystemClassification systemClassification,
    string name
)
Visual Basic
Public Shared Function Create ( _
    ADoc As Document, _
    systemClassification As MEPSystemClassification, _
    name As String _
) As PipingSystemType
Visual C++
public:
static PipingSystemType^ Create(
    Document^ ADoc,
    MEPSystemClassification systemClassification,
    String^ name
)

Parameters

ADoc
Type: Autodesk.Revit.DB..::..Document
The document where the element will be created and added.
systemClassification
Type: Autodesk.Revit.DB..::..MEPSystemClassification
The classification for the piping system type to be created
name
Type: System..::..String
The name of the piping system type to be created.

Return Value

The newly created piping system type element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | The system classification is not valid for the domain of this system type.

See Also

PipingSystemType Class
Autodesk.Revit.DB.Plumbing Namespace