Revit 2013 API
SolidOrShellTessellationControls..::..MinAngleInTriangle Property
SolidOrShellTessellationControls Class See Also
A positive real number specifying the minimum allowed angle for any triangle in the triangulation, in radians.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double MinAngleInTriangle { get; set; }
Visual Basic
Public Property MinAngleInTriangle As Double
    Get
    Set
Visual C++
public:
property double MinAngleInTriangle {
    double get ();
    void set (double value);
}

Remarks

A small value can be useful when triangulating long, thin objects, in order to keep the number of triangles small, but it can result in long, thin triangles, which are not acceptable for all applications. If the value is too large, this constraint may not be satisfiable, causing the triangulation to fail. This constraint may be approximately enforced.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for minAngleInTriangle must lie between 0 and 60 degrees (exclusive), expressed in radians.

See Also

SolidOrShellTessellationControls Class