Revit 2013 API
HandRailType Properties
HandRailType Class See Also

The HandRailType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DefaultJoinOption | The default join option between two rails. (Inherited from ContinuousRailType.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | EndOrTopExtensionLength | The extension length of the rail termination at the end or top. (Inherited from ContinuousRailType.)
Public property | EndOrTopExtensionStyle | The extension style of the rail termination at the end or top. (Inherited from ContinuousRailType.)
Public property | EndOrTopTermination | The termination of the rail at the end or top. (Inherited from ContinuousRailType.)
Public property | FilletRadius | The fillet radius of the rail join. (Inherited from ContinuousRailType.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HandClearance | The horizontal distance between the inner boundary of the rail and the path. (Inherited from ContinuousRailType.)
Public property | Height | The height of the handrail.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ProfileId | The id of the profile of the rail; (Inherited from ContinuousRailType.)
Public property | Projection | The horizontal distance between the outer boundary of the rail and the path. (Inherited from ContinuousRailType.)
Public property | StartOrBottomExtensionLength | The extension length of the rail termination at the beginning or bottom. (Inherited from ContinuousRailType.)
Public property | StartOrBottomExtensionStyle | The extension style of the rail termination at the beginning or bottom. (Inherited from ContinuousRailType.)
Public property | StartOrBottomTermination | The termination of the rail at the beginning or bottom. (Inherited from ContinuousRailType.)
Public property | SupportJustification | The support justification method of the handrail.
Public property | SupportLayout | The support layout method of the handrail.
Public property | SupportNumber | The number of supports of the handrail.
Public property | SupportSpacing | The support spacing of the handrail.
Public property | SupportTypeId | The support type of the handrail.
Public property | Transition | The transition option of the rail. (Inherited from ContinuousRailType.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

HandRailType Class
Autodesk.Revit.DB.Architecture Namespace