Revit 2013 API
HostedSweep..::..SetEndPointParameter Method
HostedSweep Class See Also
Set segment's start point or end point parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool SetEndPointParameter(
    Reference targetRef,
    int endIdx,
    double param
)
Visual Basic
Public Function SetEndPointParameter ( _
    targetRef As Reference, _
    endIdx As Integer, _
    param As Double _
) As Boolean
Visual C++
public:
bool SetEndPointParameter(
    Reference^ targetRef,
    int endIdx,
    double param
)

Parameters

targetRef
Type: Autodesk.Revit.DB..::..Reference
Segment's reference whose parameter want to be set.
endIdx
Type: System..::..Int32
Start point (=0) or end point (=1).
param
Type: System..::..Double
Value of parameter.

Return Value

true if operation success.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when regeneration fails.

See Also

HostedSweep Class