Revit 2013 API
AreaTagTypeSet Methods
AreaTagTypeSet Class See Also

The AreaTagTypeSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every areatag type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a areatag type within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified areatag type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified areatag type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AreaTagTypeSet Class