Revit 2013 API
PathType Enumeration
See Also
Enum determining what kind of path a given external file reference path is. Paths are valid for all types of external file references unless otherwise specified.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012
Since: 2012

Syntax

C#
public enum PathType
Visual Basic
Public Enumeration PathType
Visual C++
public enum class PathType

Members

Member name | Description
Relative | The path is relative to the host file's location, or to the central model's location if the host is workshared.
Absolute | The path is an absolute path to a location on disk or the network.
Server | The path is to a Revit Server location. This value is only valid for ExternalFileReferenceType.RevitLink
Content | The path is relative to a location in the Revit content libraries. This value is only valid for ExternalFileReferenceType.KeynoteTable or ExternalFileReferenceType.Decal

See Also