Revit 2013 API
RebarHostData..::..GetCoverType Method
RebarHostData Class See Also
Gets the CoverType associated with a face of the element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public RebarCoverType GetCoverType(
    Reference face
)
Visual Basic
Public Function GetCoverType ( _
    face As Reference _
) As RebarCoverType
Visual C++
public:
RebarCoverType^ GetCoverType(
    Reference^ face
)

Parameters

face
Type: Autodesk.Revit.DB..::..Reference

Return Value

The cover associated with the face, if it is an exposed face. If the face is concealed, returns nullNothingnullptra null reference (Nothing in Visual Basic).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

RebarHostData Class
Autodesk.Revit.DB.Structure Namespace