Revit 2013 API
XYZ..::..AngleTo Method
XYZ Class See Also
Returns the angle between this vector and the specified vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double AngleTo(
    XYZ source
)
Visual Basic
Public Function AngleTo ( _
    source As XYZ _
) As Double
Visual C++
public:
double AngleTo(
    XYZ^ source
)

Parameters

source
Type: Autodesk.Revit.DB..::..XYZ
The specified vector.

Return Value

The real number between 0 and PI equal to the angle between the two vectors in radians..

Remarks

The angle between the two vectors is measured in the plane spanned by them.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when source is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

XYZ Class