Revit 2013 API
RebarShapeDefinitionBySegments..::..SetSegmentAs180DegreeBend Method (Int32, ElementId, Boolean)
RebarShapeDefinitionBySegments Class See Also
Indicate that a segment is a "virtual" segment introduced to describe a 180-degree bend. The radius of the bend will be driven by radiusParam.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetSegmentAs180DegreeBend(
    int iSegment,
    ElementId paramId,
    bool measureToOutsideOfBend
)
Visual Basic
Public Sub SetSegmentAs180DegreeBend ( _
    iSegment As Integer, _
    paramId As ElementId, _
    measureToOutsideOfBend As Boolean _
)
Visual C++
public:
void SetSegmentAs180DegreeBend(
    int iSegment,
    ElementId^ paramId,
    bool measureToOutsideOfBend
)

Parameters

iSegment
Type: System..::..Int32
Index of the segment (0 to NumberOfSegments - 1).
paramId
Type: Autodesk.Revit.DB..::..ElementId
Id of a parameter to drive the radius. To obtain the id of a shared parameter, call RebarShape.GetElementIdForExternalDefinition().
measureToOutsideOfBend
Type: System..::..Boolean
Choose between two possibilities for the references of the radius dimension. If true, measure to the exterior face of the bar. If false, measure to the interior face.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | iSegment is not between 0 and NumberOfEdges. -or- paramId is not the id of a shared parameter in the current document, or its unit type is not UT_Length or UT_Angle.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

RebarShapeDefinitionBySegments Class
SetSegmentAs180DegreeBend Overload
Autodesk.Revit.DB.Structure Namespace