Revit 2013 API
LoadUsageArray Members
LoadUsageArray Class Constructors Methods Properties See Also

The LoadUsageArray type exposes the following members.

Constructors

 | Name | Description
Public method | LoadUsageArray | Initializes a new instance of the LoadUsageArray class

Methods

 | Name | Description
Public method | Append | Add the load usage to the end of the array.
Public method | Clear | Removes every load usage from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified load usage into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an load usage at a specified index within the array.
Public property | Size | Returns the number of load usages that are in the array.

See Also

LoadUsageArray Class
Autodesk.Revit.DB.Structure Namespace