Revit 2013 API
ExtrusionAnalyzer Members
ExtrusionAnalyzer Class Methods Properties See Also

The ExtrusionAnalyzer type exposes the following members.

Methods

 | Name | Description
Public method | CalculateFaceAlignment | Calculates the alignment status of each face of the solid.
 | Create | Creates an ExtrusionAnalyzer and computes and stores the solid's shadow.
Public method | Dispose | Releases all resources used by the ExtrusionAnalyzer
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetExtrusionBase | Obtains the face that represents the base contour of the extrusion analysis.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | EndParameter | The end parameter (distance along the extrusion direction from the input plane) calculated by the extrusion analysis.
Public property | ExtrusionDirection | The direction of extrusion specified for the extrusion analysis.
Public property | StartParameter | The start parameter (distance along the extrusion direction from the input plane) calculated by the extrusion analysis.

See Also

ExtrusionAnalyzer Class