Revit 2013 API
Truss..::..SetProfile Method
Truss Class See Also
Add or modify the profile of a truss.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetProfile(
    CurveArray topChords,
    CurveArray bottomChords
)
Visual Basic
Public Sub SetProfile ( _
    topChords As CurveArray, _
    bottomChords As CurveArray _
)
Visual C++
public:
void SetProfile(
    CurveArray^ topChords,
    CurveArray^ bottomChords
)

Parameters

topChords
Type: Autodesk.Revit.DB..::..CurveArray
The curves serving as top chords of the truss.
bottomChords
Type: Autodesk.Revit.DB..::..CurveArray
The curves serving as bottom chords of the truss.

See Also

Truss Class
Autodesk.Revit.DB.Structure Namespace