Revit 2013 API
FillPattern Members
FillPattern Class Constructors Methods Properties See Also

The FillPattern type exposes the following members.

Constructors

 | Name | Description
Public method | FillPattern()()()() | Creates a fill pattern with FillPatternHostOrientation::FPORIENTATION_TO_VIEW and FillPatternTarget::FPTARGET_NONE.
Public method | FillPattern(FillPattern) | Creates a copy of a fill pattern.
Public method | FillPattern(String, FillPatternTarget, FillPatternHostOrientation) | Creates a fill pattern based on the given name, FillPatternTarget and FillPatternHostOrientation.
Public method | FillPattern(String, FillPatternTarget, FillPatternHostOrientation, Double, Double) | Creates a simple hatch fill pattern based on the given name, angle, spacing, FillPatternTarget and FillPatternHostOrientation.
Public method | FillPattern(String, FillPatternTarget, FillPatternHostOrientation, Double, Double, Double) | Creates a simple crosshatch fill pattern based on the given name, angle, spacing, FillPatternTarget and FillPatternHostOrientation.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the FillPattern
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExpandDots | Corrects pattern dots to make them be drawn properly for Revit.
Public method | GetFillGrid | Gets the specified fill grid.
Public method | GetFillGrids | Gets all fill grids in this fill pattern
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual | Check if the contents in two fill patterns are equal.
Public method | SetFillGrid | Sets the fill grid.
Public method | SetFillGrids | Set the fill grids in this fill pattern.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | GridCount | Gets the count of the fill grids in this fill pattern.
Public property | HostOrientation | Orientation to host layer.
Public property | IsSolidFill | Check if the fill pattern is a solid fill pattern.
Public property | LengthPerArea | Gets length of all lines that placed on unit area.
Public property | LinesPerLength | Gets the number of solid lines that placed in unit length.
Public property | Name | The name of the fill pattern.
Public property | StrokesPerArea | Gets the number of strokes that placed on unit area.
Public property | Target | Target of this fill pattern applied to.

See Also

FillPattern Class