Revit 2013 API
IFCTypeInfo Methods
IFCTypeInfo Class See Also

The IFCTypeInfo type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Get2DMapHandle | Gets the associated handle to a 2D IfcRepresentationMap for the type.
Public method | Get3DMapHandle | Gets the associated handle to a 3D IfcRepresentationMap for the type.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetStyle | Gets the associated handle to an IfcTypeProduct for the type.
Public method | GetStyleTransform | Gets the transform between the coordinate system of the type and the coordinate system of the instance's location in the Revit model.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid | Identifies if the object represents a valid type info.
Public method | Set2DMapHandle | Sets the associated handle to a 2D IfcRepresentationMap for the type.
Public method | Set3DMapHandle | Sets the associated handle to a 3D IfcRepresentationMap for the type.
Public method | SetStyle | Sets the associated handle to an IfcTypeProduct for the type.
Public method | SetStyleTransform | Sets the transform between the coordinate system of the type and the coordinate system of the instance's location in the Revit model.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IFCTypeInfo Class
Autodesk.Revit.DB.IFC Namespace