Revit 2013 API
AdaptiveComponentFamilyUtils..::..GetPointConstraintType Method
AdaptiveComponentFamilyUtils Class See Also
Gets constrain type of an Adaptive Shape Handle Point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static AdaptivePointConstraintType GetPointConstraintType(
    Document doc,
    ElementId refPointId
)
Visual Basic
Public Shared Function GetPointConstraintType ( _
    doc As Document, _
    refPointId As ElementId _
) As AdaptivePointConstraintType
Visual C++
public:
static AdaptivePointConstraintType GetPointConstraintType(
    Document^ doc,
    ElementId^ refPointId
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
The Document
refPointId
Type: Autodesk.Revit.DB..::..ElementId
The ReferencePoint id

Return Value

Constraint type of the Adaptive Shape Handle Point.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ElementId refPointId does not correspond to a valid ReferencePoint. -or- The Element corresponding to ElementId refPointId does not belong to an Adaptive Family. -or- The ElementId refPointId does not correspond to a Shape Handle Point.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AdaptiveComponentFamilyUtils Class