Revit 2013 API
ProjectLocation..::..Duplicate Method
ProjectLocation Class Example See Also
Generate a copy of this project location with the specified name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ProjectLocation Duplicate(
    string name
)
Visual Basic
Public Function Duplicate ( _
    name As String _
) As ProjectLocation
Visual C++
public:
ProjectLocation^ Duplicate(
    String^ name
)

Parameters

name
Type: System..::..String
The name to be assigned to the duplicated project location.

Return Value

If successful a duplicate of this project location object with the specified name.

Remarks

The name must not be the same as any existing site location objects.

Examples

CopyC#
public ProjectLocation DuplicateLocation(Autodesk.Revit.DB.Document document, string newName)
{
    ProjectLocation currentLocation = document.ActiveProjectLocation;
    ProjectLocationSet locations = document.ProjectLocations;
    foreach (ProjectLocation projectLocation in locations)
    {
        if (projectLocation.Name == newName)
        {
            throw new Exception("The name is same as a project location's name, please change one.");
        }
    }
    return currentLocation.Duplicate(newName);
}
CopyVB.NET
Public Function DuplicateLocation(ByVal document As Autodesk.Revit.DB.Document, ByVal newName As String) As ProjectLocation
    Dim currentLocation As ProjectLocation = document.ActiveProjectLocation
    Dim locations As ProjectLocationSet = document.ProjectLocations
    For Each projectLocation As ProjectLocation In locations
        If projectLocation.Name = newName Then
            Throw New Exception("The name is same as a project location's name, please change one.")
        End If
    Next
    Return currentLocation.Duplicate(newName)
End Function

See Also

ProjectLocation Class