Revit 2013 API
HostObjectUtils..::..GetBottomFaces Method
HostObjectUtils Class See Also
Returns the bottom faces for this host object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static IList<Reference> GetBottomFaces(
    HostObject hostObject
)
Visual Basic
Public Shared Function GetBottomFaces ( _
    hostObject As HostObject _
) As IList(Of Reference)
Visual C++
public:
static IList<Reference^>^ GetBottomFaces(
    HostObject^ hostObject
)

Parameters

hostObject
Type: Autodesk.Revit.DB..::..HostObject
The host object.

Return Value

An array of references to the faces which are at the bottom of this element.

Remarks

This utility supports host objects whose bottom faces represent one of the boundaries of CompoundStructure (such as roofs, floors or ceilings).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | This host object does not support access to top or bottom faces.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

HostObjectUtils Class