Revit 2013 API
Outline Methods
Outline Class See Also

The Outline type exposes the following members.

Methods

 | Name | Description
Public method | AddPoint | Adds a point to the bounding box, expanding it if the point is outside the existing boundary.
Public method | Contains | Determine if this Outline contains the specified point to within a tolerance.
Public method | ContainsOtherOutline | Determine if this Outline contains another Outline to within tolerance.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersects | Determine if this Outline intersects the input Outline to within a specified tolerance.
Public method | IsScaleValid | Checks if given scale is valid. Should be greater than zero.
Public method | Scale | Scales the bounding box by given scale.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Outline Class