Revit 2013 API
IFCProductWrapper..::..AddBuilding Method
IFCProductWrapper Class See Also
Adds an IfcBuilding handle to associate with the IfcProduct in this wrapper.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void AddBuilding(
    IFCAnyHandle buildingHandle
)
Visual Basic
Public Sub AddBuilding ( _
    buildingHandle As IFCAnyHandle _
)
Visual C++
public:
void AddBuilding(
    IFCAnyHandle^ buildingHandle
)

Parameters

buildingHandle
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The IfcBuilding handle.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCProductWrapper Class
Autodesk.Revit.DB.IFC Namespace