Revit 2013 API
TemperatureRatingType..::..AddCorrectionFactor Method
TemperatureRatingType Class See Also
Add a new electrical correction factor type to this temperature rating type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CorrectionFactor AddCorrectionFactor(
    long temperature,
    double factor
)
Visual Basic
Public Function AddCorrectionFactor ( _
    temperature As Long, _
    factor As Double _
) As CorrectionFactor
Visual C++
public:
CorrectionFactor^ AddCorrectionFactor(
    long long temperature,
    double factor
)

Parameters

temperature
Type: System..::..Int64
Temperature of correction factor to be added.
factor
Type: System..::..Double
Factor of correction factor to be added.

Return Value

New constructed correction factor.

See Also

TemperatureRatingType Class
Autodesk.Revit.DB.Electrical Namespace