Revit 2013 API
ExporterIFCUtils..::..CreateSubElementGUID Method
ExporterIFCUtils Class See Also
Creates a consistent GUID for an IFC entity related to a Revit element. A "related" sub-element is one that is unique for a given type of element, and can therefore by identified by a simple index value (e.g. PSet_Wall_Common property set for a wall.) The index value 0 is reserved, as this would generate the GUID of the element itself. A listing of known sub-elements is contained in IFCSubElementEnums.cs; it is expected that this list would be maintained up-to-date, instead of passing arbitrary values into this function.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static string CreateSubElementGUID(
    Element pElement,
    int subElementIndex
)
Visual Basic
Public Shared Function CreateSubElementGUID ( _
    pElement As Element, _
    subElementIndex As Integer _
) As String
Visual C++
public:
static String^ CreateSubElementGUID(
    Element^ pElement,
    int subElementIndex
)

Parameters

pElement
Type: Autodesk.Revit.DB..::..Element
The element.
subElementIndex
Type: System..::..Int32
The global index for this sub-element.

Return Value

The guid string.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace