Revit 2013 API
Document..::..NewCurtainSystem2 Method
Document Class See Also
Creates a new CurtainSystem element from a set of face references.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ICollection<ElementId> NewCurtainSystem2(
    ReferenceArray faces,
    CurtainSystemType curtainSystemType
)
Visual Basic
Public Function NewCurtainSystem2 ( _
    faces As ReferenceArray, _
    curtainSystemType As CurtainSystemType _
) As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ NewCurtainSystem2(
    ReferenceArray^ faces,
    CurtainSystemType^ curtainSystemType
)

Parameters

faces
Type: Autodesk.Revit.DB..::..ReferenceArray
The faces new CurtainSystem will be created on.
curtainSystemType
Type: Autodesk.Revit.DB..::..CurtainSystemType
The Type of CurtainSystem to be created.

Return Value

A set of ElementIds of CurtainSystems will be returned when the operation succeeds.

Remarks

The faces can belong to different masses or generic models. The number of CurtainSystems will be equal to the number of masses and generic models.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown in following cases: The input argument faces or curtainSystemType is nullNothingnullptra null reference (Nothing in Visual Basic). The size of faces is zero.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the CurtainSystem cannot be created, for example, the input faces don't belong to same mass or generic model. Or regenerate fails.

See Also

Document Class
Autodesk.Revit.Creation Namespace