Revit 2013 API
ElectricalSystem Properties
ElectricalSystem Class See Also

The ElectricalSystem type exposes the following members.

Properties

 | Name | Description
Public property | ApparentCurrent | Returns the ApparentCurrent value of the Electrical System.
Public property | ApparentCurrentPhaseA | Returns the ApparentCurrentPhaseA value of the Electrical System.
Public property | ApparentCurrentPhaseB | Returns the ApparentCurrentPhaseB value of the Electrical System.
Public property | ApparentCurrentPhaseC | Returns the ApparentCurrentPhaseC value of the Electrical System.
Public property | ApparentLoad | Returns the ApparentLoad value of the Electrical System.
Public property | ApparentLoadPhaseA | Returns the ApparentLoadPhaseA value of the Electrical System.
Public property | ApparentLoadPhaseB | Returns the ApparentLoadPhaseB value of the Electrical System.
Public property | ApparentLoadPhaseC | Returns the ApparentLoadPhaseC value of the Electrical System.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BalancedLoad | Reports whether the BalancedLoad is on or off.
Public property | BaseEquipment | The base panel or equipment of the system. (Inherited from MEPSystem.)
Public property | BaseEquipmentConnector | The connector within base equipment which is used to connect with system. (Inherited from MEPSystem.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CircuitNumber | Returns the CircuitNumber of the Electrical System.
Public property | CircuitType | Get the circuit type of the Electrical System.
Public property | ConnectorManager | Connector manager of the system. (Inherited from MEPSystem.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Elements | Terminal elements in the system. (Inherited from MEPSystem.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroundConductorsNumber | Returns the GroundConductors Number of the Electrical System.
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HotConductorsNumber | Returns the HotConductors Number of the Electrical System.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsDefaultSystem | Indicates if the system is a default system or not. (Inherited from MEPSystem.)
Public property | IsEmpty | Indicates if the system is empty or not. (Inherited from MEPSystem.)
Public property | IsValid | Indicates if the system is valid or not. atom AtomValidateSystem default false setter setIsValid public_api; (Inherited from MEPSystem.)
Public property | Length | Returns the Length value of the Electrical System.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LoadClassifications | Returns the LoadClassifications used in the Electrical System.
Public property | LoadName | Get/Set the LoadName of the Electrical System.
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Returns the Name of the Electrical System. (Overrides Element..::..Name.)
Public property | NeutralConductorsNumber | Returns the NeutralConductors Number of the Electrical System.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | PanelName | Returns the Panel name of the Electrical System.
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | PolesNumber | Returns the Poles Number of the Electrical System.
Public property | PowerFactor | Returns the PowerFactor value of the Electrical System.
Public property | PowerFactorState | Returns the PowerFactorState type of the Electrical System.
Public property | PressureLossOfCriticalPath | The total pressure loss of the sections in critical path. (Inherited from MEPSystem.)
Public property | Rating | Get/Set the Rating value of the Electrical System.
Public property | RunsNumber | Returns the Runs Number of the Electrical System.
Public property | SectionsCount | The number of sections. (Inherited from MEPSystem.)
Public property | SystemType | Returns the Electrical System Type of the Electrical System.
Public property | TrueCurrent | Returns the TrueCurrent value of the Electrical System.
Public property | TrueCurrentPhaseA | Returns the TrueCurrentPhaseA value of the Electrical System.
Public property | TrueCurrentPhaseB | Returns the TrueCurrentPhaseB value of the Electrical System.
Public property | TrueCurrentPhaseC | Returns the TrueCurrentPhaseC value of the Electrical System.
Public property | TrueLoad | Returns the TrueLoad value of the Electrical System.
Public property | TrueLoadPhaseA | Returns the TrueLoadPhaseA value of the Electrical System.
Public property | TrueLoadPhaseB | Returns the TrueLoadPhaseB value of the Electrical System.
Public property | TrueLoadPhaseC | Returns the TrueLoadPhaseC value of the Electrical System.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Voltage | Returns the Voltage value of the Electrical System.
Public property | VoltageDrop | Returns the VoltageDrop value of the Electrical System.
Public property | WireSizeString | Returns the WireSize as a String of the Electrical System.
Public property | WireType | Get/Set the wire type of the Electrical System.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace