Revit 2013 API
MechanicalFitting Members
MechanicalFitting Class Methods Properties See Also

The MechanicalFitting type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssignedElectricalSystems | Retrieves the electrical systems this electrical panel currently is assigned to. (Inherited from MEPModel.)
Public property | ConnectorManager | Retrieves the Connector Manager from this MEPModel. (Inherited from MEPModel.)
Public property | ElectricalSystems | Retrieves the electrical systems that are currently created using this MEPModel. (Inherited from MEPModel.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | PartType | The part type of the mechanical fitting.

See Also

MechanicalFitting Class
Autodesk.Revit.DB.Mechanical Namespace