Revit 2013 API
WorksetKindFilter Members
WorksetKindFilter Class Constructors Methods Properties See Also

The WorksetKindFilter type exposes the following members.

Constructors

 | Name | Description
Public method | WorksetKindFilter(WorksetKind) | Constructs a new instance of WorksetKindFilter filter to match worksets of the given WorksetKind.
Public method | WorksetKindFilter(WorksetKind, Boolean) | Constructs a new instance of WorksetKindFilter filter to match worksets of the given WorksetKind.

Methods

 | Name | Description
Public method | Dispose | (Inherited from WorksetFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IncludeStandaloneWorksetsOnly | True if the results of the filter only match stand-alone worksets; worksets that are not stand-alone will be rejected. (Inherited from WorksetFilter.)
Public property | Inverted | True if the results of the filter are inverted; worksets that would normally be accepted by this filter will be rejected, and worksets that would normally be rejected will be accepted. (Inherited from WorksetFilter.)
Public property | WorksetKind | The WorksetKind.

See Also

WorksetKindFilter Class