Revit 2013 API
Parameter..::..Set Method (ElementId)
Parameter Class See Also
Sets the parameter to a new element id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool Set(
    ElementId value
)
Visual Basic
Public Function Set ( _
    value As ElementId _
) As Boolean
Visual C++
public:
bool Set(
    ElementId^ value
)

Parameters

value
Type: Autodesk.Revit.DB..::..ElementId
The new element id to which the parameter is to be set.

Return Value

The Set method will return True if the parameter was successfully set to the new value, otherwise false.

Remarks

You should only use this method if the StorageType property reports the type of the parameter as an ElementId.

See Also

Parameter Class
Set Overload