Revit 2013 API
FailureDefinition..::..CreateFailureDefinition Method
FailureDefinition Class Example See Also
Creates an instance of a FailureDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static FailureDefinition CreateFailureDefinition(
    FailureDefinitionId id,
    FailureSeverity severity,
    string messageString
)
Visual Basic
Public Shared Function CreateFailureDefinition ( _
    id As FailureDefinitionId, _
    severity As FailureSeverity, _
    messageString As String _
) As FailureDefinition
Visual C++
public:
static FailureDefinition^ CreateFailureDefinition(
    FailureDefinitionId^ id,
    FailureSeverity severity,
    String^ messageString
)

Parameters

id
Type: Autodesk.Revit.DB..::..FailureDefinitionId
Unique identifier of the failure.
severity
Type: Autodesk.Revit.DB..::..FailureSeverity
The severity of the failure. Cannot be FailureSeverity::None.
messageString
Type: System..::..String
A user-visible string describing the failure.

Return Value

The created FailureDefinition instance.

Remarks

The newly created FailureDefinition will be added to the FailureDefinitionRegistry. Because FailureDefinition could only be registered when Revit starting up, this function cannot be used after Revit has already started. Throws InvalidOperationException if invoked after Revit start-up is completed.

Examples

CopyC#
// define a new failure id for a warning about walls
FailureDefinitionId warnId =
    new FailureDefinitionId(new Guid("FB4F5AF3-42BB-4371-B559-FB1648D5B4D1"));

// register the new warning using FailureDefinition
FailureDefinition failDef = FailureDefinition.CreateFailureDefinition(warnId,
    FailureSeverity.Warning,
    "Wall is too big (>100'). Performance problems may result.");
CopyVB.NET
' define a new failure id for a warning about walls
Dim warnId As New FailureDefinitionId(New Guid("FB4F5AF3-42BB-4371-B559-FB1648D5B4D1"))

' register the new warning using FailureDefinition
Dim failDef As FailureDefinition = FailureDefinition.CreateFailureDefinition(warnId, FailureSeverity.Warning, "Wall is too big (>100'). Performance problems may result.")

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The id of failure definition is not valid. -or- The id of failure definition is already used to register another FailureDefinition. -or- The severity of failures cannot be FailureSeverity::None. -or- Message string is empty or contains invalid characters.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FailureDefinition Class