Revit 2013 API
WorksharingDisplaySettings Methods
WorksharingDisplaySettings Class See Also

The WorksharingDisplaySettings type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | CanUserHaveOverrides | Checks whether a single username can have customized graphic overrides.
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAllUsersWithGraphicOverrides | Returns all usernames that have graphic overrides. This list consists of all users included in the user table + all users who have explicitly been assigned overrides.
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetGraphicOverrides(String) | Returns the graphic overrides assigned for elements owned by a particular user.
Public method | GetGraphicOverrides(CheckoutStatus) | Returns the graphic overrides associated with a particular ownership status.
Public method | GetGraphicOverrides(ModelUpdatesStatus) | Returns the graphic overrides assigned to a particular model update status.
Public method | GetGraphicOverrides(WorksetId) | Returns the graphic overrides assigned to elements in a particular workset.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
 | GetOrCreateWorksharingDisplaySettings | Returns the worksharing display settings for the document, creating new settings for the current user if necessary.
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetRemovedUsers | Returns the set of users who have been explicitly removed from the settings.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | RemoveUsers | Removes users from the list of displayed users and permanently discards any customization of the graphics. Note that a user cannot be removed if he or she owns any elements.
Public method | RestoreUsers | Adds users back to the list of displayed users and permits customization of the graphics. Any usernames that are not currently removed will be ignored. Returns the number of users who were actually restored.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetGraphicOverrides(String, WorksharingDisplayGraphicSettings) | Sets the graphic overrides assigned to elements owned by a particular user. The username cannot be on the list of removed usernames.
Public method | SetGraphicOverrides(CheckoutStatus, WorksharingDisplayGraphicSettings) | Sets the graphic overrides assigned to elements with a particular ownership status.
Public method | SetGraphicOverrides(ModelUpdatesStatus, WorksharingDisplayGraphicSettings) | Sets the graphic overrides assigned to elements with a particular status in the central model.
Public method | SetGraphicOverrides(WorksetId, WorksharingDisplayGraphicSettings) | Sets the graphic overrides assigned to elements in a particular user workset.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UserHasGraphicOverrides | Checks whether there are graphic overrides that would apply to elements owned by the given user in the "Individual Owners" display mode.

See Also

WorksharingDisplaySettings Class