Revit 2013 API
Application..::..IsStructuralAnalysisEnabled Property
Application Class See Also
Checks whether or not the structural analysis is enabled, and enable or disable it.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsStructuralAnalysisEnabled { get; set; }
Visual Basic
Public Property IsStructuralAnalysisEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool IsStructuralAnalysisEnabled {
    bool get ();
    void set (bool value);
}

Remarks

When structural analysis is disabled the structural analytical model will not be updated automatically by Revit. Enabling structural analysis will not take effect unless the structure discipline is also enabled.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property:

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace