Revit 2013 API
ParameterFilterRuleFactory..::..CreateNotEqualsRule Method (ElementId, Int32)
ParameterFilterRuleFactory Class See Also
Creates a filter rule that determines whether integer values from the document do not equal a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static FilterRule CreateNotEqualsRule(
    ElementId parameter,
    int value
)
Visual Basic
Public Shared Function CreateNotEqualsRule ( _
    parameter As ElementId, _
    value As Integer _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateNotEqualsRule(
    ElementId^ parameter,
    int value
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
An integer-typed parameter used to get values from the document for a given element.
value
Type: System..::..Int32
The user-supplied value against which values from the document will be compared.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterRuleFactory Class
CreateNotEqualsRule Overload