Revit 2013 API
ExternalService Methods
ExternalService Class See Also

The ExternalService type exposes the following members.

Methods

 | Name | Description
Public method | AddServer | Registers a server with its service.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetDefaultServerId | Returns the Id of the default server if one was assigned to the service.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRegisteredServerIds | Returns Ids of all servers registered for the service.
Public method | GetServer | Returns the instance that provides implementation for a registered server.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsRegisteredServerId | Checks if the Id represents a valid server that have been registered for the service.
Public method | RemoveServer | Removes/unregisters a server from the service.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExternalService Class
Autodesk.Revit.DB.ExternalService Namespace