Revit 2013 API
CompoundStructure..::..IsValidSegmentId Method
CompoundStructure Class See Also
Determines whether the specified integer is actually the id of a segment in this CompoundStructure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsValidSegmentId(
    int segmentId
)
Visual Basic
Public Function IsValidSegmentId ( _
    segmentId As Integer _
) As Boolean
Visual C++
public:
bool IsValidSegmentId(
    int segmentId
)

Parameters

segmentId
Type: System..::..Int32
The id of a segment in this CompoundStructure.

Return Value

True if the specified segment is valid, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is valid only vertically compound structures.

See Also

CompoundStructure Class