Revit 2013 API
DividedSurface..::..GetTileReference Method
DividedSurface Class See Also
Get a reference to one of the tile surfaces associated with a given seed node.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Reference GetTileReference(
    GridNode gridNode,
    int tileIndex
)
Visual Basic
Public Function GetTileReference ( _
    gridNode As GridNode, _
    tileIndex As Integer _
) As Reference
Visual C++
public:
Reference^ GetTileReference(
    GridNode gridNode,
    int tileIndex
)

Parameters

gridNode
Type: Autodesk.Revit.DB..::..GridNode
tileIndex
Type: System..::..Int32
An integer between 0 and T-1, where T is TilesPerSeedNode.

Return Value

A reference to a Face (surface). Returns nullNothingnullptra null reference (Nothing in Visual Basic) if the grid node is not a "seed node", or if the tile is omitted due to boundary conditions.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown if the grid node is outside of the range specified by NumberOfUGridlines and NumberOfVGridlines, or if tileIndex is outside the range [0, TilesPerSeedNode-1].

See Also

DividedSurface Class