Revit 2013 API
TextBox Properties
TextBox Class See Also

The TextBox type exposes the following members.

Properties

 | Name | Description
Public property | Enabled | Gets or sets a value indicating whether the item is enabled. (Inherited from RibbonItem.)
Public property | Image | The image of the TextBox.
Public property | ItemText | Gets or sets the text displayed on the item. (Inherited from RibbonItem.)
Public property | ItemType | Gets the item type. (Inherited from RibbonItem.)
Public property | LongDescription | Long description of the command tooltip; (Inherited from RibbonItem.)
Public property | Name | The name of the item. (Inherited from RibbonItem.)
Public property | PromptText | The prompt text for the text box.
Public property | SelectTextOnFocus | A value that indicates if the text is selected when the text box gains focus.
Public property | ShowImageAsButton | Gets or sets a value that indicates if the Image set in the text box should be displayed as a clickable button.
Public property | ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItem.)
Public property | ToolTipImage | The image to show as a part of the button extended tooltip; (Inherited from RibbonItem.)
Public property | Value | The object that supplies the text value.
Public property | Visible | Gets or sets a value indicating whether the item is visible. (Inherited from RibbonItem.)
Public property | Width | Gets or sets the width of the TextBox.

See Also

TextBox Class
Autodesk.Revit.UI Namespace