Revit 2013 API
PipeSettings Members
PipeSettings Class Methods Properties See Also

The PipeSettings type exposes the following members.

Methods

 | Name | Description
Public method | AddPipeSlope | Add a pipe slope value.
Public method | Dispose | Releases all resources used by the PipeSettings
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetPipeSettings | Get the pipe settings of the project.
Public method | GetPipeSlopes | Get pipe slopes.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetPipeSlopes | Set pipe slope values.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConnectorSeparator | The connector separator string.
Public property | ConnectorTolerance | The connector tolerance value.
Public property | ElbowAngleIncrement | The value of elbow angle increment.
Public property | FittingAnnotationSize | The value of fitting annotation size.
Public property | SizePrefix | The size prefix string.
Public property | SizeSuffix | The size suffix string.
Public property | UseAnnotationScaleForSingleLineFittings | Indicates whether use annotation scale for single line fittings or not.

See Also

PipeSettings Class
Autodesk.Revit.DB.Plumbing Namespace