Revit 2013 API
AnalysisResultSchema..::..SetUnits Method
AnalysisResultSchema Class Example See Also
Sets names and multipliers of all units for result visualization

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void SetUnits(
    IList<string> names,
    IList<double> multipliers
)
Visual Basic
Public Sub SetUnits ( _
    names As IList(Of String), _
    multipliers As IList(Of Double) _
)
Visual C++
public:
void SetUnits(
    IList<String^>^ names,
    IList<double>^ multipliers
)

Parameters

names
Type: System.Collections.Generic..::..IList<(Of <(<'String>)>)>
Unit names for all units (e.g., "Lb" and "Kg")
multipliers
Type: System.Collections.Generic..::..IList<(Of <(<'Double>)>)>
Numerical coefficients mapped to unit names. They adjust measurement values shown in the legend and display (e.g., 1.0 and 0.451 - if actual measurements are in Lb)

Examples

CopyC#
IList<string> unitNames = new List<string>();
unitNames.Add("Feet");
unitNames.Add("Inches");
IList<double> multipliers = new List<double>();
multipliers.Add(1);
multipliers.Add(12);

AnalysisResultSchema resultSchema = new AnalysisResultSchema("Schema Name", "Description");

resultSchema.SetUnits(unitNames, multipliers);

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | names is zero-length or contains duplicate or empty names -or- multipliers contains non-positive numbers, or its length is not equal to the length of names

See Also

AnalysisResultSchema Class
Autodesk.Revit.DB.Analysis Namespace