Revit 2013 API
UIApplication..::..GetRibbonPanels Method (String)
UIApplication Class See Also
Get all the custom Panels on a designated Revit tab.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public List<RibbonPanel> GetRibbonPanels(
    string tabName
)
Visual Basic
Public Function GetRibbonPanels ( _
    tabName As String _
) As List(Of RibbonPanel)
Visual C++
public:
List<RibbonPanel^>^ GetRibbonPanels(
    String^ tabName
)

Parameters

tabName
Type: System..::..String
The name of the tab on which the panels are located.

Remarks

Built-in panels will not be included. tabName must be the name of one of the tabs added by CreateRibbonTab(String). This method is not supported in Macros.

See Also

UIApplication Class
GetRibbonPanels Overload
Autodesk.Revit.UI Namespace