Revit 2013 API
ExporterIFCUtils..::..ExportSlabAsExtrusion Method
ExporterIFCUtils Class See Also

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static bool ExportSlabAsExtrusion(
    ExporterIFC exporterIFC,
    Element pCeilingAndFloor,
    GeometryElement pGRep,
    IFCTransformSetter pTmpTrfSetter,
    IFCAnyHandle localPlacement,
    out IList<IFCAnyHandle> localPlacementAnyArr,
    out IList<IFCAnyHandle> reps,
    out IList<IList<CurveLoop>> extrusionLoops,
    out IList<IFCExtrusionCreationData> loopExtraParams,
    Plane plane
)
Visual Basic
Public Shared Function ExportSlabAsExtrusion ( _
    exporterIFC As ExporterIFC, _
    pCeilingAndFloor As Element, _
    pGRep As GeometryElement, _
    pTmpTrfSetter As IFCTransformSetter, _
    localPlacement As IFCAnyHandle, _
    <OutAttribute> ByRef localPlacementAnyArr As IList(Of IFCAnyHandle), _
    <OutAttribute> ByRef reps As IList(Of IFCAnyHandle), _
    <OutAttribute> ByRef extrusionLoops As IList(Of IList(Of CurveLoop)), _
    <OutAttribute> ByRef loopExtraParams As IList(Of IFCExtrusionCreationData), _
    plane As Plane _
) As Boolean
Visual C++
public:
static bool ExportSlabAsExtrusion(
    ExporterIFC^ exporterIFC,
    Element^ pCeilingAndFloor,
    GeometryElement^ pGRep,
    IFCTransformSetter^ pTmpTrfSetter,
    IFCAnyHandle^ localPlacement,
    [OutAttribute] IList<IFCAnyHandle^>^% localPlacementAnyArr,
    [OutAttribute] IList<IFCAnyHandle^>^% reps,
    [OutAttribute] IList<IList<CurveLoop^>^>^% extrusionLoops,
    [OutAttribute] IList<IFCExtrusionCreationData^>^% loopExtraParams,
    Plane^ plane
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
pCeilingAndFloor
Type: Autodesk.Revit.DB..::..Element
pGRep
Type: Autodesk.Revit.DB..::..GeometryElement
pTmpTrfSetter
Type: Autodesk.Revit.DB.IFC..::..IFCTransformSetter
localPlacement
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
localPlacementAnyArr
Type: System.Collections.Generic..::..IList<(Of <(<'IFCAnyHandle>)>)>%
reps
Type: System.Collections.Generic..::..IList<(Of <(<'IFCAnyHandle>)>)>%
extrusionLoops
Type: System.Collections.Generic..::..IList<(Of <(<'IList<(Of <(<'CurveLoop>)>)>>)>)>%
loopExtraParams
Type: System.Collections.Generic..::..IList<(Of <(<'IFCExtrusionCreationData>)>)>%
plane
Type: Autodesk.Revit.DB..::..Plane

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace