Revit 2013 API
EnergyDataSettings..::..ProjectReportType Property
EnergyDataSettings Class See Also
Report type: None, simple, standard, detailed

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public HVACLoadLoadsReportType ProjectReportType { get; set; }
Visual Basic
Public Property ProjectReportType As HVACLoadLoadsReportType
    Get
    Set
Visual C++
public:
property HVACLoadLoadsReportType ProjectReportType {
    HVACLoadLoadsReportType get ();
    void set (HVACLoadLoadsReportType value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The project report type does not fall within an appropriate range.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace