Revit 2013 API
StairsType..::..MiddleSupportsNumber Property
StairsType Class See Also
The number of middle supports used in the stair.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int MiddleSupportsNumber { get; set; }
Visual Basic
Public Property MiddleSupportsNumber As Integer
    Get
    Set
Visual C++
public:
property int MiddleSupportsNumber {
    int get ();
    void set (int value);
}

Field Value

0 if the stairs type has no middle support.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The supportsNumber is a negative value.
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The stairs type has no middle support so the data being set is not applicable.

See Also

StairsType Class
Autodesk.Revit.DB.Architecture Namespace