Revit 2013 API
Frame Members
Frame Class Constructors Methods Properties See Also

The Frame type exposes the following members.

Constructors

 | Name | Description
Public method | Frame()()()() | Default constructor. Uses global origin and standard basis vectors.
Public method | Frame(XYZ, XYZ, XYZ, XYZ) | Constructor that takes the frame’s base point and three basis vectors.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the Frame
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsOrthogonal | Determines if this frame's basis vectors are orthogonal.
Public method | IsOrthonormal | Determines if this frame's basis vectors are orthonormal.
Public method | IsRightHanded | Determine if this frame's basis is right-handed.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Transform | Applies the input transform to this frame.

Properties

 | Name | Description
Public property | BasisX | The first basis vector of the frame.
Public property | BasisY | The second basis vector of the frame.
Public property | BasisZ | The third basis vector of the frame.
Public property | Origin | The frame's base point.

See Also

Frame Class