Revit 2013 API
ExportDGNSettings..::..Create Method (Document, String, DGNExportOptions)
ExportDGNSettings Class See Also
Create DGN export settings with specified values in DGNExportOptions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static ExportDGNSettings Create(
    Document document,
    string name,
    DGNExportOptions options
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    name As String, _
    options As DGNExportOptions _
) As ExportDGNSettings
Visual C++
public:
static ExportDGNSettings^ Create(
    Document^ document,
    String^ name,
    DGNExportOptions^ options
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
Document where created settings is saved.
name
Type: System..::..String
The name specified to this settings.
options
Type: Autodesk.Revit.DB..::..DGNExportOptions
The options which will be stored in these settings.

Return Value

The new DGN export settings instance.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | ExistOrEmpty
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExportDGNSettings Class
Create Overload