Revit 2013 API
PropertySetLibrary..::..RemovePropertySet Method
PropertySetLibrary Class See Also
Removes a property set with a given name from the library.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool RemovePropertySet(
    string name
)
Visual Basic
Public Function RemovePropertySet ( _
    name As String _
) As Boolean
Visual C++
public:
bool RemovePropertySet(
    String^ name
)

Parameters

name
Type: System..::..String
The name of the property set name to remove.

Return Value

True if a property set with the given name was found and removed, otherwise false.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ObjectAccessException | The property set library is read-only.

See Also

PropertySetLibrary Class