Revit 2013 API
ScheduleFilter Class
Members See Also
A filter in a schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class ScheduleFilter : IDisposable
Visual Basic
Public Class ScheduleFilter _
    Implements IDisposable
Visual C++
public ref class ScheduleFilter : IDisposable

Remarks

The ScheduleFilter class represents a single filter in a schedule. A filter is a condition that must be satisfied for an element to appear in the schedule. All filters must be satisfied for an element to appear in the schedule.

A schedule can be filtered by data that is not displayed in the schedule by marking the field used for filtering as hidden using the ScheduleField.IsHidden property.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ScheduleFilter

See Also

ScheduleFilter Members