Revit 2013 API
ExternalService..::..GetServer Method
ExternalService Class See Also
Returns the instance that provides implementation for a registered server.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IExternalServer GetServer(
    Guid serverId
)
Visual Basic
Public Function GetServer ( _
    serverId As Guid _
) As IExternalServer
Visual C++
public:
IExternalServer^ GetServer(
    Guid serverId
)

Parameters

serverId
Type: System..::..Guid
Id of a registered server

Return Value

An instance of the server interface. NULL is returned if the server is invalid (e.g. destroyed)

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | A server with this Id has not been registered for this service.

See Also

ExternalService Class
Autodesk.Revit.DB.ExternalService Namespace