Revit 2013 API
FamilyInstance..::..ToRoom Property
FamilyInstance Class See Also
The "To Room" set for the door or window in the last phase of the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Room ToRoom { get; }
Visual Basic
Public ReadOnly Property ToRoom As Room
    Get
Visual C++
public:
property Room^ ToRoom {
    Room^ get ();
}

Field Value

The "To Room" set for the door or window in the last phase of the project. nullNothingnullptra null reference (Nothing in Visual Basic) if the FamilyInstance is neither a door nor a window, or if the door or window leads to a space where there is no room (an exterior space or interior space with no room defined). Also nullNothingnullptra null reference (Nothing in Visual Basic) if there is no target room assigned to the last phase.

Remarks

Revit automatically calculates the "To Room" for a given door or window. This is the default shown when creating a door or window schedule and adding the "To Room" properties. The user can opt to swap the "From Room" and "To Room" values via the schedule if they choose. The method FlipFromToRoom()()()() also can be used to swap the values.

See Also

FamilyInstance Class
ToRoom Overload