Revit 2013 API
StairsRunType Properties
StairsRunType Class See Also

The StairsRunType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HasRisers | True if the stairs run will include risers on steps, false otherwise.
Public property | HasTreads | True if the stairs run will include treads on steps, false otherwise.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsMonolithic | True if the stairs run is monolithic, false otherwise.
Public property | IsSlanted | True if risers will be slanted, false if they will be straight.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | MaterialId | The material of the stairs run, only available for monolithic stairs run.
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | NosingLength | The amount of the tread depth that overhangs the next tread.
Public property | NosingProfile | The id of the nosing profile of the treads.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | RiserProfile | The id of the profile of the risers.
Public property | RiserThickness | The thickness of the risers.
Public property | RiserToTreadConnect | The connection of the riser to tread in relation to each other.
Public property | StructuralDepth | The structural depth of the stairs run, only available for monolithic stairs run.
Public property | TotalDepth | The total depth of the stairs run, only available for monolithic stairs run.
Public property | TreadNosingPosition | Represents on which edges of the nosing to apply the nosing profile.
Public property | TreadProfile | The id of the profile of the treads.
Public property | TreadThickness | The thickness of the treads.
Public property | UndersideSurfaceStyle | The underside surface style of the stairs run, only available for monolithic stairs run.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

StairsRunType Class
Autodesk.Revit.DB.Architecture Namespace