Revit 2013 API
LoadCombination Class
Members Example See Also
An object that represents a load combination.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class LoadCombination : Element
Visual Basic
Public Class LoadCombination _
    Inherits Element
Visual C++
public ref class LoadCombination : public Element

Examples

CopyC#
private void CombinationInformation(LoadCombination loadCombination)
{
    StringBuilder information = new StringBuilder();

    //Get the string with Load Combination Name or empty string
    information.Append("\n\nCombination Name: " + loadCombination.Name);

    //Get the string with Load Combination State
    information.Append("\nCombination state: " + loadCombination.CombinationState);

    //Load Combination State index or 0
    information.Append("\nState index : " + loadCombination.CombinationStateIndex.ToString());

    //Get the string with Load Combination Type
    information.Append("\nCombination type: " + loadCombination.CombinationType);

    //Get Load Combination Type index or 0
    information.Append("\nType index: " + loadCombination.CombinationTypeIndex.ToString());

    //Get the number of Load Combination Components
    int componentsNumber = loadCombination.NumberOfComponents;
    information.Append("\nComponents number: " + componentsNumber.ToString());
    for (int j = 0; j < componentsNumber; j++)
    {
        double factor = loadCombination.get_Factor(j);
        string caseName = loadCombination.get_CombinationCaseName(j);
        information.Append("\nCase name[" + j.ToString() + "]: " + caseName + "  factor: " +
                              factor.ToString());
    }

    //return the number of usage in the combination
    int usageNumber = loadCombination.NumberOfUsages;
    information.Append("\nNumber of usages: " + usageNumber + "\nUsage names: ");
    //get each usage name
    for (int i = 0; i < usageNumber; i++)
    {
        information.Append(loadCombination.get_UsageName(i) + "  ");
    }

    TaskDialog.Show("Revit",information.ToString());
}
CopyVB.NET
Private Sub CombinationInformation(ByVal loadCombination As LoadCombination)
    Dim information As New StringBuilder()

    'Get the string with Load Combination Name or empty string
    information.Append(vbLf & vbLf & "Combination Name: " + loadCombination.Name)

    'Get the string with Load Combination State
    information.Append(vbLf & "Combination state: " + loadCombination.CombinationState)

    'Load Combination State index or 0
    information.Append(vbLf & "State index : " + loadCombination.CombinationStateIndex.ToString())

    'Get the string with Load Combination Type
    information.Append(vbLf & "Combination type: " + loadCombination.CombinationType)

    'Get Load Combination Type index or 0
    information.Append(vbLf & "Type index: " + loadCombination.CombinationTypeIndex.ToString())

    'Get the number of Load Combination Components
    Dim componentsNumber As Integer = loadCombination.NumberOfComponents
    information.Append(vbLf & "Components number: " + componentsNumber.ToString())
    Dim j As Integer = 0
    While j < componentsNumber
        Dim factor As Double = loadCombination.Factor(j)
        Dim caseName As String = loadCombination.CombinationCaseName(j)
        information.Append(vbLf & "Case name[" + j.ToString() + "]: " + caseName + "  factor: " + factor.ToString())
        System.Math.Max(System.Threading.Interlocked.Increment(j), j - 1)
    End While

    'return the number of usage in the combination
    Dim usageNumber As Integer = loadCombination.NumberOfUsages
    information.Append(vbLf & "Number of usages: " + usageNumber + vbLf & "Usage names: ")
    'get each usage name
    Dim i As Integer = 0
    While i < usageNumber
        information.Append(loadCombination.UsageName(i) + "  ")
        System.Math.Max(System.Threading.Interlocked.Increment(i), i - 1)
    End While

    TaskDialog.Show("Revit", information.ToString())
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB.Structure..::..LoadCombination

See Also

LoadCombination Members
Autodesk.Revit.DB.Structure Namespace