Revit 2013 API
ElementTransformUtils Members
ElementTransformUtils Class Methods See Also

The ElementTransformUtils type exposes the following members.

Methods

 | Name | Description
 | CanMirrorElement | Determines whether element can be mirrored.
 | CanMirrorElements | Determines whether elements can be mirrored.
 | CopyElement | Copies an element and places the copy at a location indicated by a given transformation.
 | CopyElements | Copies a set of elements and places the copies at a location indicated by a given translation.
Public method | Dispose | Releases all resources used by the ElementTransformUtils
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | MirrorElement | Creates a mirrored copy of an element about a given plane.
 | MirrorElements | Creates a mirrored copy of a set of elements about a given plane.
 | MoveElement | Moves one element by a given transformation.
 | MoveElements | Moves a set of elements by a given transformation.
 | RotateElement | Rotates an element about the given axis and angle.
 | RotateElements | Rotates a set of elements about the given axis and angle.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElementTransformUtils Class