Revit 2013 API
Categories..::..Insert Method
Categories Class See Also
Inserts the specified category with the specified name into the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override bool Insert(
    string key,
    Category item
)
Visual Basic
Public Overrides Function Insert ( _
    key As String, _
    item As Category _
) As Boolean
Visual C++
public:
virtual bool Insert(
    String^ key,
    Category^ item
) override

Parameters

key
Type: System..::..String
The name to be used for inserting the category into the map.
item
Type: Autodesk.Revit.DB..::..Category
The category to be inserted into the map.

Return Value

Whether or not the category was inserted into the map.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Always thrown; this list is read only.

See Also

Categories Class