Revit 2013 API
DWFXExportOptions Members
DWFXExportOptions Class Constructors Methods Properties See Also

The DWFXExportOptions type exposes the following members.

Constructors

 | Name | Description
Public method | DWFXExportOptions | Default constructor. Sets all options to their default values.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ExportingAreas | Whether to also export areas and rooms' geometry. (Inherited from DWFExportOptions.)
Public property | ExportObjectData | Whether to include properties associated with elements. (Inherited from DWFExportOptions.)
Public property | ImageFormat | Controls the compression level of images embedded. (Inherited from DWFExportOptions.)
Public property | ImageQuality | Image quality level when compressed raster format(JPEG) is used. (Inherited from DWFExportOptions.)
Public property | MergedViews | Whether to merge all views in one file. (Inherited from DWFExportOptions.)
Public property | PaperFormat | Standard paper format. (Inherited from DWFExportOptions.)
Public property | PortraitLayout | Paper orientation - Portrait/Landscape. (Inherited from DWFExportOptions.)
Public property | StopOnError | Whether export process should stop when a view fails to export. (Inherited from DWFExportOptions.)

See Also

DWFXExportOptions Class