Revit 2013 API
RebarShapeConstraintProjectedSegmentLength Properties
RebarShapeConstraintProjectedSegmentLength Class See Also

The RebarShapeConstraintProjectedSegmentLength type exposes the following members.

Properties

 | Name | Description
Public property | Direction | A vector specifying the direction of the constraint. The direction is fixed, and the shape is always constructed so that the segment direction has a positive dot product with this vector.
Public property | TripleProductSign | Sign of the z-coordinate of the cross product of the Direction property with the segment vector. TripleProductSign is 1 if the segment direction is to be on the left of the constraint direction, or -1 if the segment direction is to be on the right.

See Also

RebarShapeConstraintProjectedSegmentLength Class
Autodesk.Revit.DB.Structure Namespace