Revit 2013 API
IFCData..::..GetTypeList Method
IFCData Class See Also
Gets the multiple strings represent one IFC type name.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IList<string> GetTypeList()
Visual Basic
Public Function GetTypeList As IList(Of String)
Visual C++
public:
IList<String^>^ GetTypeList()

Return Value

The strings.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | No type assigned or it is a simple type.

See Also

IFCData Class
Autodesk.Revit.DB.IFC Namespace