Revit 2013 API
Form Methods
Form Class See Also

The Form type exposes the following members.

Methods

 | Name | Description
Public method | AddEdge(Reference, Reference) | Add an edge to the form, connecting two edges on same/different profile, by a pair of specified points.
Public method | AddEdge(Reference, XYZ) | Add an edge to the form, connecting two edges on different profiles, by a specified face of the form and a point on face.
Public method | AddEdge(Reference, Double, Reference, Double) | Add an edge to the form, connecting two edges on same/different profile, by a pair of specified edge/param.
Public method | AddProfile | Add a profile into the form, by a specified edge/param.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | CanManipulateProfile | Tell if a profile can be deleted/moved/rotated.
Public method | CanManipulateSubElement | Tell if a sub element can be deleted/moved/rotated/scaled.
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | ConstrainProfiles | Constrain form profiles using the specified profile as master. This is an advanced version of property "AreProfilesConstrained", allowing specify the master profile.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | DeleteProfile | Delete a profile of the form.
Public method | DeleteSubElement | Delete a face/edge/curve/vertex of the form, specified by a reference.
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetControlPoints | Given an edge or a curve or a face, return all control points lying on it (in form of geometry references).
Public method | GetCurvesAndEdgesReference | Given a point, return all edges and curves that it is lying on.
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPathCurveIndexByCurveReference | Given a reference to certain curve in the path, return its index.
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetProfileAndCurveLoopIndexFromReference | Given a reference to certain curve or edge, get the index of its profile and curve loop respectively.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVisibility | Gets the visibility for the generic form. (Inherited from GenericForm.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsAutoCreaseEdge | Tell if an edge is an auto-crease on a top/bottom cap face.
Public method | IsBeginningFace | Given a face, tell if it is a beginning cap face.
Public method | IsConnectingEdge | Tell if an edge is a connecting edge on a side face. Connecting edges connect vertices on different profiles.
Public method | IsCurveReference | Tell if the pick is the reference to a curve of the form.
Public method | IsEdgeReference | Tell if the pick is the reference to an edge of the form.
Public method | IsEndFace | Given a face, tell if it is an end cap face.
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsFaceReference | Tell if the pick is the reference to a face of the form.
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsProfileEdge | Tell if an edge or curve is generated from a profile.
Public method | IsReferenceOnlyProfile | Tell if the profile is made by referencing existing geometry in the Revit model.
Public method | IsSideFace | Given a face, tell if it is a side face.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | IsVertexReference | Tell if the pick is the reference to a vertex of the form.
Public method | MoveProfile | Move a profile of the form, specified by a reference, and an offset vector.
Public method | MoveSubElement | Move a face/edge/curve/vertex of the form, specified by a reference, and an offset vector.
Public method | Rehost(Reference, XYZ) | Rehost Form to edge, face or curve.
Public method | Rehost(SketchPlane, XYZ) | Rehost Form to sketch plane
Public method | RotateProfile | Rotate a profile of the form, by a specified angle around a given axis.
Public method | RotateSubElement | Rotate a face/edge/curve/vertex of the form, by a specified angle around a given axis.
Public method | ScaleProfile | Scale a profile of the form, by a specified origin and scale factor.
Public method | ScaleSubElement | Scale a face/edge/curve/vertex of the form, by a specified origin and scale factor.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetVisibility | Sets the visibility for the generic form. (Inherited from GenericForm.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Form Class