Revit 2013 API
Curve..::..Project Method
Curve Class See Also
Projects the specified point on this curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public IntersectionResult Project(
    XYZ point
)
Visual Basic
Public Function Project ( _
    point As XYZ _
) As IntersectionResult
Visual C++
public:
IntersectionResult^ Project(
    XYZ^ point
)

Parameters

point
Type: Autodesk.Revit.DB..::..XYZ
The point to be projected.

Return Value

Geometric information if projection is successful.

Remarks

The following is the meaning of every IntersectionResult's members:
  • XYZPoint is the nearest point on the curve;
  • Parameter is the unnormalized parameter on the curve (use ComputeNormalizedParameter to compute the normalized value)
  • Distance is the distance from the point to the curve (equivalent to Distance).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when failed to find the closest point on the curve.

See Also

Curve Class