Revit 2013 API
CompoundStructure..::..IsRectangularRegion Method
CompoundStructure Class See Also
Determines whether the specified region is rectangular.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsRectangularRegion(
    int regionId
)
Visual Basic
Public Function IsRectangularRegion ( _
    regionId As Integer _
) As Boolean
Visual C++
public:
bool IsRectangularRegion(
    int regionId
)

Parameters

regionId
Type: System..::..Int32
The id of a region.

Return Value

True if the specified region is a rectangle, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | It is not a valid region id.
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is valid only vertically compound structures.

See Also

CompoundStructure Class