Revit 2013 API
AdaptiveComponentFamilyUtils..::..MakeAdaptivePoint Method
AdaptiveComponentFamilyUtils Class See Also
Makes Reference Point an Adaptive Point or makes an Adaptive Point a Reference Point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static void MakeAdaptivePoint(
    Document doc,
    ElementId refPointId,
    AdaptivePointType type
)
Visual Basic
Public Shared Sub MakeAdaptivePoint ( _
    doc As Document, _
    refPointId As ElementId, _
    type As AdaptivePointType _
)
Visual C++
public:
static void MakeAdaptivePoint(
    Document^ doc,
    ElementId^ refPointId,
    AdaptivePointType type
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
The Document
refPointId
Type: Autodesk.Revit.DB..::..ElementId
The ReferencePoint id
type
Type: Autodesk.Revit.DB..::..AdaptivePointType
The Adaptive Point Type

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ElementId refPointId does not correspond to a valid ReferencePoint. -or- The Element corresponding to ElementId refPointId does not belong to an Adaptive Family.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation failed.

See Also

AdaptiveComponentFamilyUtils Class