Revit 2013 API
MessageBoxShowingEventArgs Class
Members See Also
The event arguments used by the DialogBoxShowing event when a Windows message box is about to be displayed in Revit.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public class MessageBoxShowingEventArgs : DialogBoxShowingEventArgs
Visual Basic
Public Class MessageBoxShowingEventArgs _
    Inherits DialogBoxShowingEventArgs
Visual C++
public ref class MessageBoxShowingEventArgs : public DialogBoxShowingEventArgs

Remarks

When the application receives this object, a simple message box is about to be displayed in Revit that requires user interaction. The OverrideResult function can be used to cause the dialog to be dismissed and return a desired result code.

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Autodesk.Revit.DB.Events..::..RevitEventArgs
Autodesk.Revit.DB.Events..::..PreEventArgs
Autodesk.Revit.UI.Events..::..DialogBoxShowingEventArgs
Autodesk.Revit.UI.Events..::..MessageBoxShowingEventArgs

See Also

MessageBoxShowingEventArgs Members
Autodesk.Revit.UI.Events Namespace