Revit 2013 API
IFCData..::..GetSimpleType Method
IFCData Class See Also
Gets the IFC type name.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public string GetSimpleType()
Visual Basic
Public Function GetSimpleType As String
Visual C++
public:
String^ GetSimpleType()

Return Value

The name.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | No type assigned or it is not a simple type.

See Also

IFCData Class
Autodesk.Revit.DB.IFC Namespace