Revit 2013 API
ElementOwnerViewFilter Constructor (ElementId, Boolean)
ElementOwnerViewFilter Class See Also
Constructs a new instance of a filter to match elements which are owned by a particular view, with the option to invert the filter and find elements not owned by the given view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementOwnerViewFilter(
    ElementId viewId,
    bool inverted
)
Visual Basic
Public Sub New ( _
    viewId As ElementId, _
    inverted As Boolean _
)
Visual C++
public:
ElementOwnerViewFilter(
    ElementId^ viewId,
    bool inverted
)

Parameters

viewId
Type: Autodesk.Revit.DB..::..ElementId
The view id to match. Pass invalid element id to create a filter that will pass non-view-specific elements.
inverted
Type: System..::..Boolean
True if the filter should match all elements which are not owned by the given view.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ElementOwnerViewFilter Class
ElementOwnerViewFilter Overload