Revit 2013 API
PointCloudInstance..::..FilterAction Property
PointCloudInstance Class See Also
The action taken based on the results of the selection filter applied to this point cloud.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public SelectionFilterAction FilterAction { get; set; }
Visual Basic
Public Property FilterAction As SelectionFilterAction
    Get
    Set
Visual C++
public:
property SelectionFilterAction FilterAction {
    SelectionFilterAction get ();
    void set (SelectionFilterAction value);
}

Remarks

If no selection filter is applied, changing this value will have no visible effect. The filter is provided in the coordinates of the Revit model. If the point cloud is altered (e.g. by moving, rotating, scaling or other modifications) the point cloud filter is not modified and the set of highlighted or isolated points will change. The filter action is not preserved when the Revit document is saved.

See Also

PointCloudInstance Class