Revit 2013 API
Document..::..NewFloor Method (CurveArray, Boolean)
Document Class See Also
Creates a floor within the project with the given horizontal profile using the default floor style.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Floor NewFloor(
    CurveArray profile,
    bool structural
)
Visual Basic
Public Function NewFloor ( _
    profile As CurveArray, _
    structural As Boolean _
) As Floor
Visual C++
public:
Floor^ NewFloor(
    CurveArray^ profile,
    bool structural
)

Parameters

profile
Type: Autodesk.Revit.DB..::..CurveArray
An array of planar lines and arcs that represent the horizontal profile of the floor.
structural
Type: System..::..Boolean
If set, specifies that the floor is structural in nature.

Return Value

If successful a new floor object within the project, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Document Class
NewFloor Overload
Autodesk.Revit.Creation Namespace