Revit 2013 API
PlanViewRange Members
PlanViewRange Class Methods Properties See Also

The PlanViewRange type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the PlanViewRange
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLevelId | Get the element id of the level for a View Depth plane
Public method | GetOffset | Get the offset value associated with a View Depth plane
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetLevelId | Set the level for a View Depth plane
Public method | SetOffset | Set the offset value associated with a View Depth plane
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | View range for the current plane
Public property | LevelAbove | View range for the level above the specified plane
Public property | LevelBelow | View range for the level below the specified plane
Public property | Unlimited | View range is unlimited

See Also

PlanViewRange Class