Revit 2013 API
Document..::..NewSpaces2 Method (Phase, Int32)
Document Class See Also
Creates a set of new unplaced spaces on a given phase.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ICollection<ElementId> NewSpaces2(
    Phase phase,
    int count
)
Visual Basic
Public Function NewSpaces2 ( _
    phase As Phase, _
    count As Integer _
) As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ NewSpaces2(
    Phase^ phase,
    int count
)

Parameters

phase
Type: Autodesk.Revit.DB..::..Phase
The phase in which the spaces are to exist.
count
Type: System..::..Int32

Return Value

If successful, a set of ElementIds of new unplaced spaces are be returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Document Class
NewSpaces2 Overload
Autodesk.Revit.Creation Namespace