Revit 2013 API
RebarShapeDefinitionByArc Constructor (Document, RebarShapeDefinitionByArcType)
RebarShapeDefinitionByArc Class See Also
Create a non-spiral shape definition.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public RebarShapeDefinitionByArc(
    Document doc,
    RebarShapeDefinitionByArcType type
)
Visual Basic
Public Sub New ( _
    doc As Document, _
    type As RebarShapeDefinitionByArcType _
)
Visual C++
public:
RebarShapeDefinitionByArc(
    Document^ doc,
    RebarShapeDefinitionByArcType type
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
type
Type: Autodesk.Revit.DB.Structure..::..RebarShapeDefinitionByArcType

Remarks

Replaces RebarShape.NewDefinitionByArc() from prior versions.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The arc type cannot be set directly to Spiral. Instead, call SetArcTypeSpiral() to provide defaults for spiral parameters.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

RebarShapeDefinitionByArc Class
RebarShapeDefinitionByArc Overload
Autodesk.Revit.DB.Structure Namespace