Revit 2013 API
Zone Properties
Zone Class See Also

The Zone type exposes the following members.

Properties

 | Name | Description
Public property | Area | Get the Area of the Zone.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | Boundary | Returns the boundary of the Zone.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CalculatedCoolingLoad | Get the Calculated Cooling Load of the Zone.
Public property | CalculatedHeatingLoad | Get the Calculated Heating Load of the Zone.
Public property | CalculatedSupplyAirflow | Get the Calculated Supply Airflow of the Zone.
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CoolingAirTemperature | Get or set the Cooling Air Temperature of the Zone.
Public property | CoolingSetPoint | Get or set the Cooling Set Point of the Zone.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DehumidificationSetPoint | Get or set the DeHumidification Set Point of the Zone.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GrossArea | Get the Gross Area of the Zone.
Public property | GrossVolume | Get the Gross Volume of the Zone.
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HeatingAirTemperature | Get or set the Heating Air Temperature of the Zone.
Public property | HeatingSetPoint | Get or set the Heating Set Point of the Zone.
Public property | HumidificationSetPoint | Get or set the Humidification Set Point of the Zone.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsDefaultZone | Reports whether this zone is default or not.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Get or Set the Name of the Zone. (Overrides Element..::..Name.)
Public property | OutDoorAirPerArea | Get or set the OutDoor Air Per Area of the Zone.
Public property | OutDoorAirPerPerson | Get or set the OutDoor Air Per Person of the Zone.
Public property | OutdoorAirRatePerAirChangesPerHour | Get or set the Outdoor Air Rate Per Air Changes Per Hour of the Zone.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Perimeter | Get the Perimeter of the Zone.
Public property | Phase | Get the Phase of the Zone.
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ServiceType | Get or set the Service Type of the Zone.
Public property | Spaces | Get the Spaces of the Zone.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Volume | Get the Volume of the Zone.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Zone Class
Autodesk.Revit.DB.Mechanical Namespace