Revit 2013 API
AnalyticalModelSupport Methods
AnalyticalModelSupport Class See Also

The AnalyticalModelSupport type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCurve | Retrieves the curve providing support.
Public method | GetFace | Retrieves surface providing support,
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPoint | Retrieves the point providing support.
Public method | GetPriority | Retrieves the priority of the support provided.
Public method | GetSupportingElement | Retrieves the actual Element Id providing support.
Public method | GetSupportType | Gets the type of support provided.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnalyticalModelSupport Class
Autodesk.Revit.DB.Structure Namespace