Revit 2013 API
PartMakerMethodToDivideVolumes..::..IsElementValidIntersectingReference Method (Document, ElementId)
PartMakerMethodToDivideVolumes Class See Also
Identifies if the provided member is valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static bool IsElementValidIntersectingReference(
    Document document,
    ElementId elementId
)
Visual Basic
Public Shared Function IsElementValidIntersectingReference ( _
    document As Document, _
    elementId As ElementId _
) As Boolean
Visual C++
public:
static bool IsElementValidIntersectingReference(
    Document^ document,
    ElementId^ elementId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
elementId
Type: Autodesk.Revit.DB..::..ElementId
Element ids to be tested for validity for intersecting references.

Return Value

True if the reference is valid, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PartMakerMethodToDivideVolumes Class
IsElementValidIntersectingReference Overload