Revit 2013 API
IFCFamilyInstanceExtrusionExportResults Members
IFCFamilyInstanceExtrusionExportResults Class Methods Properties See Also

The IFCFamilyInstanceExtrusionExportResults type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the IFCFamilyInstanceExtrusionExportResults
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCutPairOpenings | Gets the set of "openings" determined from the analysis of the instance geometry.
Public method | GetExtrusionHandle | Gets the extruded solid handle generated for the family instance.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ExtraOffset | The extra offset determined from the geometry of the family instance.
Public property | MaterialId | The best material id determined for the family instance.

See Also

IFCFamilyInstanceExtrusionExportResults Class
Autodesk.Revit.DB.IFC Namespace