Revit 2013 API
FabricSheetType..::..SetMajorLayoutAsActualSpacing Method
FabricSheetType Class See Also
Set Major Layout Pattern as Actual Spacing.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetMajorLayoutAsActualSpacing(
    double overallWidth,
    double minorStartOverhang,
    double spacing
)
Visual Basic
Public Sub SetMajorLayoutAsActualSpacing ( _
    overallWidth As Double, _
    minorStartOverhang As Double, _
    spacing As Double _
)
Visual C++
public:
void SetMajorLayoutAsActualSpacing(
    double overallWidth,
    double minorStartOverhang,
    double spacing
)

Parameters

overallWidth
Type: System..::..Double
The entire width of the wire sheet in the minor direction.
minorStartOverhang
Type: System..::..Double
Distance from the edge of the sheet to the first wire in the minor direction.
spacing
Type: System..::..Double
Distance between the wires in the major direction.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given value for overallWidth is not a number -or- The given value for minorStartOverhang is not a number -or- The given value for spacing is not a number -or- The arguments are not consistent, please specify proper input values.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The given value for overallWidth must be greater than 0 and no more than 30000 feet. -or- The given value for minorStartOverhang must be between 0 and 30000 feet. -or- The given value for spacing must be greater than 0 and no more than 30000 feet.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural.

See Also

FabricSheetType Class
Autodesk.Revit.DB.Structure Namespace