Revit 2013 API
RoutingConditions Members
RoutingConditions Class Constructors Methods Properties See Also

The RoutingConditions type exposes the following members.

Constructors

 | Name | Description
Public method | RoutingConditions | Initializes a new instance of the RoutingConditions class

Methods

 | Name | Description
Public method | AppendCondition | Appends a routing condition to the end of existing routing conditions. Note that the first item (indexed at 0) is the condition for the primary connector.
Public method | Clear | Clear all existing conditions
Public method | Dispose | Releases all resources used by the RoutingConditions
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetConditionAt | Gets the routing condition at the specified index position.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNumberOfConditions | Gets the number of included routing conditions.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ErrorLevel | The error level that the routing preference manager should post errors if the routing conditions do not meet any routing preference rule, could be None, Warning, or Error
Public property | PreferredJunctionType | The junction type (Tee or Tap) to select if defined fittings of both junction types meet all routing conditions.

See Also

RoutingConditions Class