Revit 2013 API
RebarShapeConstraint180DegreeBendRadius Constructor
RebarShapeConstraint180DegreeBendRadius Class See Also
Create a 180-degree bend constraint driven by radius.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public RebarShapeConstraint180DegreeBendRadius(
    ElementId paramId,
    RebarShapeArcReferenceType refType
)
Visual Basic
Public Sub New ( _
    paramId As ElementId, _
    refType As RebarShapeArcReferenceType _
)
Visual C++
public:
RebarShapeConstraint180DegreeBendRadius(
    ElementId^ paramId,
    RebarShapeArcReferenceType refType
)

Parameters

paramId
Type: Autodesk.Revit.DB..::..ElementId
The Id of a Rebar Shape parameter.
refType
Type: Autodesk.Revit.DB.Structure..::..RebarShapeArcReferenceType
A choice of rule for measuring the radius.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | paramId is not a valid Element identifier.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

RebarShapeConstraint180DegreeBendRadius Class
Autodesk.Revit.DB.Structure Namespace