Revit 2013 API
Parameter..::..SetValueString Method
Parameter Class Example See Also
Set the parameter value according to the input string.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool SetValueString(
    string valueString
)
Visual Basic
Public Function SetValueString ( _
    valueString As String _
) As Boolean
Visual C++
public:
bool SetValueString(
    String^ valueString
)

Parameters

valueString
Type: System..::..String
The string that represents the parameter value.

Return Value

Indicates whether the parameter value is successfully set.

Remarks

The method only applies to parameters of value types.

Examples

CopyC#
public bool SetWithValueString(Parameter foundParameter)
{
    bool result = false;
    if (!foundParameter.IsReadOnly)
    {
        //If successful, the result is true
        result = foundParameter.SetValueString("-22\'3\"");
    }
    return result;
}
CopyVB.NET
Public Function SetWithValueString(ByVal foundParameter As Parameter) As Boolean
    Dim result As Boolean = False
    If Not foundParameter.IsReadOnly Then
        'If successful, the result is true
        result = foundParameter.SetValueString("-22'3""")
    End If
    Return result
End Function

See Also

Parameter Class