Revit 2013 API
LightGroupManager Methods
LightGroupManager Class See Also

The LightGroupManager type exposes the following members.

Methods

 | Name | Description
Public method | CreateGroup | Create a new LightGroup object with the given name
Public method | DeleteGroup | Remove the given LightGroup object from the set of LightGroup objects
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetGroups | Get the set of contained LightGroup objects The set of LightGroup objects
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLightDimmer | Gets the dimmer value for the given light for rendering the given view
 | GetLightGroupManager | Creates a light group manager object from the given document
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsLightGroupOn | Returns true if the given light group is on
Public method | IsLightOn | Returns true if the given light is on for rendering the given view
Public method | SetLightDimmer | Sets the dimmer value for the given light for rendering the given view
Public method | SetLightGroupOn | Turns the given light group on or off for rendering the given view depending on the bool argument
Public method | SetLightOn | Turns the given light on or off for rendering the given view depending on the bool argument
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LightGroupManager Class
Autodesk.Revit.DB.Lighting Namespace