Revit 2013 API
Floor..::..StructuralUsage Property
Floor Class See Also
The floors designated structural usage, such as bearing or non bearing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public SlabFoundationType StructuralUsage { get; set; }
Visual Basic
Public Property StructuralUsage As SlabFoundationType
    Get
    Set
Visual C++
public:
property SlabFoundationType StructuralUsage {
    SlabFoundationType get ();
    void set (SlabFoundationType value);
}

Remarks

The StructuralUsage property is a read only property that returns the walls designated usage. Example values of this property are Non Bearing, Bearing, Shear, Combined etc.

See Also

Floor Class