Revit 2013 API
UV..::..DotProduct Method
UV Class See Also
The dot product of this 2-D vector and the specified 2-D vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double DotProduct(
    UV source
)
Visual Basic
Public Function DotProduct ( _
    source As UV _
) As Double
Visual C++
public:
double DotProduct(
    UV^ source
)

Parameters

source
Type: Autodesk.Revit.DB..::..UV
The vector to multiply with this vector.

Return Value

The real number equal to the dot product.

Remarks

The dot product is the sum of the respective coordinates of the two vectors: Pu * Ru + Pv * Rv.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when source is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

UV Class