Revit 2013 API
DuctSizeSettingIterator Members
DuctSizeSettingIterator Class Methods Properties See Also

The DuctSizeSettingIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the DuctSizeSettingIterator
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasCurrent | Identifies whether the iterator has a current item. There is no current item if the iterator has not started yet or has been done.
Public method | IsDone | Identifies if the iteration has completed.
Public method | MoveNext | Increments the enumerator to the next item.
Public method | Reset | Resets the iterator to the initial state.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current |
Protected property | CurrentObject |

See Also

DuctSizeSettingIterator Class
Autodesk.Revit.DB.Mechanical Namespace