Revit 2013 API
IFCTransaction Members
IFCTransaction Class Constructors Methods See Also

The IFCTransaction type exposes the following members.

Constructors

 | Name | Description
Public method | IFCTransaction | Instantiates a transaction object.

Methods

 | Name | Description
Public method | Commit | Commits all changes made to the IFC file during the transaction.
Public method | Dispose | Releases all resources used by the IFCTransaction
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RollBack | Rolls back all changes made to the IFC file during the transaction.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IFCTransaction Class
Autodesk.Revit.DB.IFC Namespace