Revit 2013 API
ExporterIFC..::..GetOrCreateFillPattern Method
ExporterIFC Class See Also
Get (or create) the IfcFillPatternStyle associated with an ElementId.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IFCAnyHandle GetOrCreateFillPattern(
    ElementId fillPatternId,
    Color color,
    double planScale
)
Visual Basic
Public Function GetOrCreateFillPattern ( _
    fillPatternId As ElementId, _
    color As Color, _
    planScale As Double _
) As IFCAnyHandle
Visual C++
public:
IFCAnyHandle^ GetOrCreateFillPattern(
    ElementId^ fillPatternId,
    Color^ color,
    double planScale
)

Parameters

fillPatternId
Type: Autodesk.Revit.DB..::..ElementId
The fill pattern id.
color
Type: Autodesk.Revit.DB..::..Color
The pattern color.
planScale
Type: System..::..Double
The view scale.

Return Value

The IfcSurfaceStyle.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace