Revit 2013 API
EnergyAnalysisSurface..::..OriginatingElementId Property
EnergyAnalysisSurface Class See Also
The element id for the originating Revit element.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public LinkElementId OriginatingElementId { get; }
Visual Basic
Public ReadOnly Property OriginatingElementId As LinkElementId
    Get
Visual C++
public:
property LinkElementId^ OriginatingElementId {
    LinkElementId^ get ();
}

See Also

EnergyAnalysisSurface Class
Autodesk.Revit.DB.Analysis Namespace