Revit 2013 API
Document..::..NewFoundationWall Method
Document Class See Also
Creates a new continuous footing object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ContFooting NewFoundationWall(
    ContFootingType contFootingType,
    Wall wall
)
Visual Basic
Public Function NewFoundationWall ( _
    contFootingType As ContFootingType, _
    wall As Wall _
) As ContFooting
Visual C++
public:
ContFooting^ NewFoundationWall(
    ContFootingType^ contFootingType,
    Wall^ wall
)

Parameters

contFootingType
Type: Autodesk.Revit.DB..::..ContFootingType
The ContFooting type.
wall
Type: Autodesk.Revit.DB..::..Wall
The Wall to append a ContFooting.

See Also

Document Class
Autodesk.Revit.Creation Namespace