Revit 2013 API
AdaptiveComponentFamilyUtils..::..SetPointOrientationType Method
AdaptiveComponentFamilyUtils Class See Also
Sets orientation type of an Adaptive Placement Point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static void SetPointOrientationType(
    Document doc,
    ElementId refPointId,
    AdaptivePointOrientationType orientationType
)
Visual Basic
Public Shared Sub SetPointOrientationType ( _
    doc As Document, _
    refPointId As ElementId, _
    orientationType As AdaptivePointOrientationType _
)
Visual C++
public:
static void SetPointOrientationType(
    Document^ doc,
    ElementId^ refPointId,
    AdaptivePointOrientationType orientationType
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
The Document
refPointId
Type: Autodesk.Revit.DB..::..ElementId
The ReferencePoint id
orientationType
Type: Autodesk.Revit.DB..::..AdaptivePointOrientationType
Orientation type of the Adaptive Placement Point.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ElementId refPointId does not correspond to a valid ReferencePoint. -or- The Element corresponding to ElementId refPointId does not belong to an Adaptive Family. -or- The ElementId refPointId does not correspond to an Adaptive Placement Point.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation failed.

See Also

AdaptiveComponentFamilyUtils Class