Revit 2013 API
RenderingQualitySettings..::..IndirectIlluminationBounces Property
RenderingQualitySettings Class See Also
The indirect illumination bounces value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int IndirectIlluminationBounces { get; set; }
Visual Basic
Public Property IndirectIlluminationBounces As Integer
    Get
    Set
Visual C++
public:
property int IndirectIlluminationBounces {
    int get ();
    void set (int value);
}

Remarks

Increase this value when areas of the scene that should be indirectly illuminated are left in darkness.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The indirect illumination bounces value is not valid. The valid range is 1 to 5.
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The RenderingQualitySettings does not use custom quality currently. To use custom quality, set RenderingQuality property to RenderingQuality.Custom. -or- When setting this property: Should not compute indirect and sky illumination.

See Also

RenderingQualitySettings Class