Revit 2013 API
ParameterFilterRuleFactory..::..CreateGreaterOrEqualRule Method (ElementId, ElementId)
ParameterFilterRuleFactory Class See Also
Creates a filter rule that determines whether ElementId values from the document are greater than or equal to a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static FilterRule CreateGreaterOrEqualRule(
    ElementId parameter,
    ElementId value
)
Visual Basic
Public Shared Function CreateGreaterOrEqualRule ( _
    parameter As ElementId, _
    value As ElementId _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateGreaterOrEqualRule(
    ElementId^ parameter,
    ElementId^ value
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
An ElementId-typed parameter used to get values from the document for a given element.
value
Type: Autodesk.Revit.DB..::..ElementId
The user-supplied value against which values from the document will be compared.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterRuleFactory Class
CreateGreaterOrEqualRule Overload