Revit 2013 API
FillPattern Constructor (String, FillPatternTarget, FillPatternHostOrientation, Double, Double, Double)
FillPattern Class See Also
Creates a simple crosshatch fill pattern based on the given name, angle, spacing, FillPatternTarget and FillPatternHostOrientation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FillPattern(
    string name,
    FillPatternTarget target,
    FillPatternHostOrientation orientation,
    double angle,
    double spacing1,
    double spacing2
)
Visual Basic
Public Sub New ( _
    name As String, _
    target As FillPatternTarget, _
    orientation As FillPatternHostOrientation, _
    angle As Double, _
    spacing1 As Double, _
    spacing2 As Double _
)
Visual C++
public:
FillPattern(
    String^ name,
    FillPatternTarget target,
    FillPatternHostOrientation orientation,
    double angle,
    double spacing1,
    double spacing2
)

Parameters

name
Type: System..::..String
The name.
target
Type: Autodesk.Revit.DB..::..FillPatternTarget
The fill pattern target.
orientation
Type: Autodesk.Revit.DB..::..FillPatternHostOrientation
The fill pattern orientation.
angle
Type: System..::..Double
The angle.
spacing1
Type: System..::..Double
The spacing.
spacing2
Type: System..::..Double
The spacing.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FillPattern Class
FillPattern Overload