Revit 2013 API
PresetInitialColor Members
PresetInitialColor Class Constructors Methods Properties See Also

The PresetInitialColor type exposes the following members.

Constructors

 | Name | Description
Public method | PresetInitialColor(ColorPreset) | Creates an initial color preset object with the given preset value.
Public method | PresetInitialColor(PresetInitialColor) | Creates a copy of the given preset initial color

Methods

 | Name | Description
Public method | Clone | Creates a copy of the InitialColor derived object. (Inherited from InitialColor.)
Public method | Dispose | (Inherited from InitialColor.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Preset | The preset value
Public property | TemperatureValue | The light color temperature value in Kelvins. (Inherited from InitialColor.)

See Also

PresetInitialColor Class
Autodesk.Revit.DB.Lighting Namespace