Revit 2013 API
PropertySetLibrary..::..RenamePropertySet Method
PropertySetLibrary Class See Also
Renames a property set in the library.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool RenamePropertySet(
    string name,
    string newName
)
Visual Basic
Public Function RenamePropertySet ( _
    name As String, _
    newName As String _
) As Boolean
Visual C++
public:
bool RenamePropertySet(
    String^ name,
    String^ newName
)

Parameters

name
Type: System..::..String
The name of the existing property set name to rename.
newName
Type: System..::..String
The new name for the property set.

Return Value

True if the property set was found and renamed, otherwise false.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | No property set with the given name exists in the library. -or- The library already contains a property set with the given name.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ObjectAccessException | The property set library is read-only.

See Also

PropertySetLibrary Class