Revit 2013 API
ReinforcementSettings..::..HostStructuralRebar Property
ReinforcementSettings Class See Also
Host Structural Rebar within Area and Path Reinforcement.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool HostStructuralRebar { get; set; }
Visual Basic
Public Property HostStructuralRebar As Boolean
    Get
    Set
Visual C++
public:
property bool HostStructuralRebar {
    bool get ();
    void set (bool value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: the document contains one or more AreaReinforcement or PathReinforcement elements.

See Also

ReinforcementSettings Class
Autodesk.Revit.DB.Structure Namespace