Revit 2013 API
IExternalService..::..IsValidServer Method
IExternalService Interface See Also
Implement this method to check if the given instance represents a valid server of this service.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
bool IsValidServer(
    IExternalServer server
)
Visual Basic
Function IsValidServer ( _
    server As IExternalServer _
) As Boolean
Visual C++
bool IsValidServer(
    IExternalServer^ server
)

Parameters

server
Type: Autodesk.Revit.DB.ExternalService..::..IExternalServer
An instance of a server that is to be validated.

Return Value

True if the server is valid, False otherwise

Remarks

This method is invoked by the framework upon registration of a server for this service. The simplest implementation would be to test if the type of the object is as expected.

See Also

IExternalService Interface
Autodesk.Revit.DB.ExternalService Namespace