Revit 2013 API
PhotometricWebLightDistribution Members
PhotometricWebLightDistribution Class Constructors Methods Properties See Also

The PhotometricWebLightDistribution type exposes the following members.

Constructors

 | Name | Description
Public method | PhotometricWebLightDistribution(PhotometricWebLightDistribution) | Creates a copy of the given photometric web light distribution
Public method | PhotometricWebLightDistribution(String, Double) | Creates a photometric web light distribution object with the given filename and tilt.

Methods

 | Name | Description
Public method | Clone | Creates a copy of the LightDistribution derived object. (Inherited from LightDistribution.)
Public method | Dispose | (Inherited from LightDistribution.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | PhotometricWebFile | The filename of an IES photometric web file.
Public property | TiltAngle | The tilt angle.

See Also

PhotometricWebLightDistribution Class
Autodesk.Revit.DB.Lighting Namespace