Revit 2013 API
XYZ..::..AngleOnPlaneTo Method
XYZ Class See Also
Returns the angle between this vector and the specified vector projected to the specified plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double AngleOnPlaneTo(
    XYZ right,
    XYZ normal
)
Visual Basic
Public Function AngleOnPlaneTo ( _
    right As XYZ, _
    normal As XYZ _
) As Double
Visual C++
public:
double AngleOnPlaneTo(
    XYZ^ right,
    XYZ^ normal
)

Parameters

right
Type: Autodesk.Revit.DB..::..XYZ
The specified vector.
normal
Type: Autodesk.Revit.DB..::..XYZ
The normal vector that defines the plane.

Return Value

The real number between 0 and 2*PI equal to the projected angle between the two vectors.

Remarks

The angle is projected onto the plane orthogonal to the specified normal vector, counterclockwise with the normal pointing upwards.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when right or normal is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

XYZ Class