Revit 2013 API
SolidUtils Members
SolidUtils Class Methods See Also

The SolidUtils type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the SolidUtils
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValidForTessellation | Tests if the input solid or shell is valid for tessellation.
 | SplitVolumes | Splits a solid geometry into several separate solids.
 | TessellateSolidOrShell | This function facets (i.e., triangulates) a solid or an open shell. Each boundary component of the solid or shell is represented by a single triangulated structure.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SolidUtils Class