Revit 2013 API
FailureHandlingOptions..::..SetTransactionFinalizer Method
FailureHandlingOptions Class See Also
Setting a callback to be executed after transaction is completed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FailureHandlingOptions SetTransactionFinalizer(
    ITransactionFinalizer finalizer
)
Visual Basic
Public Function SetTransactionFinalizer ( _
    finalizer As ITransactionFinalizer _
) As FailureHandlingOptions
Visual C++
public:
FailureHandlingOptions^ SetTransactionFinalizer(
    ITransactionFinalizer^ finalizer
)

Parameters

finalizer
Type: Autodesk.Revit.DB..::..ITransactionFinalizer

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FailureHandlingOptions Class