Revit 2013 API
GeometryObjectArray..::..Item Property
GeometryObjectArray Class See Also
Gets or sets a geometry object at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual GeometryObject this[
    int index
] { get; set; }
Visual Basic
Public Overridable Property Item ( _
    index As Integer _
) As GeometryObject
    Get
    Set
Visual C++
public:
virtual property GeometryObject^ Item[int index] {
    GeometryObject^ get (int index);
    void set (int index, GeometryObject^ value);
}

Parameters

index
Type: System..::..Int32
The index of the geometry object to be set or retrieved.

Return Value

Returns the geometry object at the specified index.

See Also

GeometryObjectArray Class