Revit 2013 API
DividedPath..::..SpacingRuleJustification Property
DividedPath Class See Also
When the layout is set to 'FixedDistance' the points may not cover the entire range of the path. The justification determines whether the points are centered on the range, or shifted towards the start or end of the range.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public SpacingRuleJustification SpacingRuleJustification { get; set; }
Visual Basic
Public Property SpacingRuleJustification As SpacingRuleJustification
    Get
    Set
Visual C++
public:
property SpacingRuleJustification SpacingRuleJustification {
    SpacingRuleJustification get ();
    void set (SpacingRuleJustification value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: Invalid justification

See Also

DividedPath Class