Revit 2013 API
ExternalDefinitions Methods
ExternalDefinitions Class See Also

The ExternalDefinitions type exposes the following members.

Methods

 | Name | Description
Public method | Contains | Tests for the existence of a definition within the set. (Inherited from Definitions.)
Public method | Create(String, ParameterType) | Creates a new parameter definition using name, type and visibility. (Inherited from Definitions.)
Public method | Create(String, ParameterType, Boolean) | Creates a new parameter definition using name and type. (Inherited from Definitions.)
Public method | Dispose | (Inherited from Definitions.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Definitions.)
Public method | GetEnumerator | Retrieves an enumerator to the collection. (Inherited from Definitions.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExternalDefinitions Class