Revit 2013 API
PerformanceAdviser Class
Members Example See Also
The tool to report performance problems in a given document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class PerformanceAdviser : IDisposable
Visual Basic
Public Class PerformanceAdviser _
    Implements IDisposable
Visual C++
public ref class PerformanceAdviser : IDisposable

Remarks

Class is an application-wide singleton that performs a dual role: it is a repository of rules to run in order to detect potential performance problems as well as an access point to execute checks.

Examples

CopyC#
//Get the name of each registered PerformanceRule and then execute all of them.
foreach (PerformanceAdviserRuleId id in PerformanceAdviser.GetPerformanceAdviser().GetAllRuleIds())
{
    string ruleName = PerformanceAdviser.GetPerformanceAdviser().GetRuleName(id);
}
PerformanceAdviser.GetPerformanceAdviser().ExecuteAllRules(document);

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..PerformanceAdviser

See Also

PerformanceAdviser Members