Revit 2013 API
ExporterIFCUtils..::..GetFamilyName Method
ExporterIFCUtils Class See Also
Gets the family name of an ElementType.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static string GetFamilyName(
    ElementType elemType
)
Visual Basic
Public Shared Function GetFamilyName ( _
    elemType As ElementType _
) As String
Visual C++
public:
static String^ GetFamilyName(
    ElementType^ elemType
)

Parameters

elemType
Type: Autodesk.Revit.DB..::..ElementType
The element type element.

Return Value

The name.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace