Revit 2013 API
RoutingConditions..::..PreferredJunctionType Property
RoutingConditions Class See Also
The junction type (Tee or Tap) to select if defined fittings of both junction types meet all routing conditions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public PreferredJunctionType PreferredJunctionType { get; set; }
Visual Basic
Public Property PreferredJunctionType As PreferredJunctionType
    Get
    Set
Visual C++
public:
property PreferredJunctionType PreferredJunctionType {
    PreferredJunctionType get ();
    void set (PreferredJunctionType value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Mechanical Electrical Piping.

See Also

RoutingConditions Class