Revit 2013 API
RebarHookType..::..HookAngle Property
RebarHookType Class See Also
The hook angle, measured in radians. Must be greater than 0 and no more than pi.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double HookAngle { get; set; }
Visual Basic
Public Property HookAngle As Double
    Get
    Set
Visual C++
public:
property double HookAngle {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: hookAngle must be greater than 0 and no more than pi.

See Also

RebarHookType Class
Autodesk.Revit.DB.Structure Namespace