Revit 2013 API
ViewSection Properties
ViewSection Class See Also

The ViewSection type exposes the following members.

Properties

 | Name | Description
Public property | AnalysisDisplayStyleId | Element id of Analysis Display Style associated with the view. (Inherited from View.)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | AssociatedAssemblyInstanceId | The Id of the assembly instance that owns the assembly view. (Inherited from View.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBePrinted | Test whether the view can be printed. (Inherited from View.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CropBox | The crop box applied to the view. (Inherited from View.)
Public property | CropBoxActive | Whether or not the Crop Box/Region is active for the view. (Inherited from View.)
Public property | CropBoxVisible | Whether or not the Crop Box/Region is visible for the view. (Inherited from View.)
Public property | CutColorOverrideByElement | Override the cut lines' color by Element in this view. (Inherited from View.)
Public property | CutLinePatternOverrideByElement | Override the cut lines' pattern by Element in this view. (Inherited from View.)
Public property | CutLineWeightOverrideByElement | Override the cut lines' weight by Element in this view. (Inherited from View.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | DetailLevel | The detail level of this view. (Inherited from View.)
Public property | Discipline | The Discipline of the view. (Inherited from View.)
Public property | DisplayStyle | The DisplayStyle of the view. Returns DisplayStyle.Wireframe if the view has no display style. (Inherited from View.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | GenLevel | The level for the view. (Inherited from View.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsTemplate | Test whether the view is a view template. (Inherited from View.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | Origin | Returns the origin of the screen. (Inherited from View.)
Public property | Outline | The bounds of the view in paper space (in inches). (Inherited from View.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PartsVisibility | The visibility setting for parts in this view. (Inherited from View.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ProjColorOverrideByElement | Override the projection lines' color by Element in this view. (Inherited from View.)
Public property | ProjLinePatternOverrideByElement | Override the projection lines' pattern by Element in this view. (Inherited from View.)
Public property | ProjLineWeightOverrideByElement | Override the projection lines' weight by Element in this view. (Inherited from View.)
Public property | RightDirection | The direction towards the right side of the screen. (Inherited from View.)
Public property | Scale | The scale of the view. (Inherited from View.)
Public property | SketchPlane | The sketch plane assigned to the view for model curve creation. (Inherited from View.)
Public property | SunAndShadowSettings | The sun and shadow settings assigned to the view for shadow calculation and rendering. (Inherited from View.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UpDirection | The direction towards the top of the screen. (Inherited from View.)
Public property | ViewDirection | The direction towards the viewer. (Inherited from View.)
Public property | ViewName | The name of the view. (Inherited from View.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | ViewTemplateId | Id of template that controls view parameters. Parameters controlled by the template cannot be changed directly in this view. Any change to controlled parameters in the template will cause change of the corresponding parameters in this view. To get all template parameters call template's method getTemplateParameterIds. To get parameters that are not controlled by the template call template's method getNonControlledTemplateParameterIds. (Inherited from View.)
Public property | ViewType | The type of the view. (Inherited from View.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ViewSection Class