Revit 2013 API
InitialLuminousIntensity Members
InitialLuminousIntensity Class Constructors Methods Properties See Also

The InitialLuminousIntensity type exposes the following members.

Constructors

 | Name | Description
Public method | InitialLuminousIntensity(Double) | Creates an initial luminous intensity object with the given document and luminosity values.
Public method | InitialLuminousIntensity(InitialLuminousIntensity) | Creates a copy of the given initial luminous intensity object

Methods

 | Name | Description
Public method | Clone | Creates a copy of the InitialIntensity derived object. (Inherited from InitialIntensity.)
Public method | Dispose | (Inherited from InitialIntensity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | InitialIntensityValue | The calculated initial intensity value. (Inherited from InitialIntensity.)
Public property | Luminosity | The luminosity value.

See Also

InitialLuminousIntensity Class
Autodesk.Revit.DB.Lighting Namespace