Revit 2013 API
ScheduleSortGroupField Members
ScheduleSortGroupField Class Constructors Methods Properties See Also

The ScheduleSortGroupField type exposes the following members.

Constructors

 | Name | Description
Public method | ScheduleSortGroupField()()()() | Creates a new ScheduleSortGroupField.
Public method | ScheduleSortGroupField(ScheduleFieldId) | Creates a new ScheduleSortGroupField.
Public method | ScheduleSortGroupField(ScheduleFieldId, ScheduleSortOrder) | Creates a new ScheduleSortGroupField.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ScheduleSortGroupField
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | FieldId | The ID of the field that the schedule will be sorted or grouped by.
Public property | ShowBlankLine | Indicates if an empty row should be displayed between groups.
Public property | ShowFooter | Indicates if a footer row should be displayed after each group.
Public property | ShowFooterCount | Indicates if the footer row should display a count of elements in the group.
Public property | ShowFooterTitle | Indicates if the footer row should display a title.
Public property | ShowHeader | Indicates if a header row should be displayed before each group.
Public property | SortOrder | Indicates if elements in the schedule will be sorted in ascending or descending order.

See Also

ScheduleSortGroupField Class