Revit 2013 API
CompoundStructure..::..AssociateRegionWithLayer Method
CompoundStructure Class See Also
Associate a region with a layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void AssociateRegionWithLayer(
    int regionId,
    int layerIdx
)
Visual Basic
Public Sub AssociateRegionWithLayer ( _
    regionId As Integer, _
    layerIdx As Integer _
)
Visual C++
public:
void AssociateRegionWithLayer(
    int regionId,
    int layerIdx
)

Parameters

regionId
Type: System..::..Int32
The id of a region.
layerIdx
Type: System..::..Int32
The index of a layer in this CompoundStructure.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | It is not a valid region id.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The layer index is out of range.
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is valid only vertically compound structures.

See Also

CompoundStructure Class