Revit 2013 API
CompoundStructure..::..GetSegmentEndPoints Method
CompoundStructure Class See Also
Gets the end points of a segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void GetSegmentEndPoints(
    int segmentId,
    int regionId,
    out UV end1,
    out UV end2
)
Visual Basic
Public Sub GetSegmentEndPoints ( _
    segmentId As Integer, _
    regionId As Integer, _
    <OutAttribute> ByRef end1 As UV, _
    <OutAttribute> ByRef end2 As UV _
)
Visual C++
public:
void GetSegmentEndPoints(
    int segmentId,
    int regionId,
    [OutAttribute] UV^% end1,
    [OutAttribute] UV^% end2
)

Parameters

segmentId
Type: System..::..Int32
The segment id.
regionId
Type: System..::..Int32
The region id.
end1
Type: Autodesk.Revit.DB..::..UV%
One end point.
end2
Type: Autodesk.Revit.DB..::..UV%
The other end point.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The segment id is invalid.
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is valid only vertically compound structures.

See Also

CompoundStructure Class