Revit 2013 API
HostedSweep..::..GetEndPointParameter Method
HostedSweep Class See Also
Retrieve segment's start point or end point parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double GetEndPointParameter(
    Reference targetRef,
    int endIdx
)
Visual Basic
Public Function GetEndPointParameter ( _
    targetRef As Reference, _
    endIdx As Integer _
) As Double
Visual C++
public:
double GetEndPointParameter(
    Reference^ targetRef,
    int endIdx
)

Parameters

targetRef
Type: Autodesk.Revit.DB..::..Reference
Segment's reference whose parameter want to be get.
endIdx
Type: System..::..Int32
Start point (=0) or end point (=1).

Return Value

Start point or end point parameter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when regeneration fails.

See Also

HostedSweep Class