Revit 2013 API
SubTransaction Members
SubTransaction Class Constructors Methods See Also

The SubTransaction type exposes the following members.

Constructors

 | Name | Description
Public method | SubTransaction | Instantiates a sub-transaction object

Methods

 | Name | Description
Public method | Commit | Commits all changes made to the model made during the sub-transaction.
Public method | Dispose | Releases all resources used by the SubTransaction
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetStatus | Returns the current status of the sub-transaction.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasEnded | Determines whether the sub-transaction has ended already.
Public method | HasStarted | Determines whether the sub-transaction has been started yet.
Public method | RollBack | Discards all changes made to the model during the sub-transaction.
Public method | Start | Starts the sub-transaction.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SubTransaction Class