Revit 2013 API
BoundingBoxContainsPointFilter Constructor (XYZ, Double, Boolean)
BoundingBoxContainsPointFilter Class See Also
Constructs a new instance of a filter to match elements with a bounding box that contains the given point, with the option to invert the filter and match all elements with a bounding box that do not contain the given point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public BoundingBoxContainsPointFilter(
    XYZ point,
    double tolerance,
    bool inverted
)
Visual Basic
Public Sub New ( _
    point As XYZ, _
    tolerance As Double, _
    inverted As Boolean _
)
Visual C++
public:
BoundingBoxContainsPointFilter(
    XYZ^ point,
    double tolerance,
    bool inverted
)

Parameters

point
Type: Autodesk.Revit.DB..::..XYZ
The point used to find elements with a bounding box containing it.
tolerance
Type: System..::..Double
The tolerance value to use instead of zero. See the tolerance property for details.
inverted
Type: System..::..Boolean
True if the filter should be inverted and match all elements with a bounding box that do not contain the given point.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given value for tolerance is not finite -or- The given value for tolerance is not a number
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

BoundingBoxContainsPointFilter Class
BoundingBoxContainsPointFilter Overload