Revit 2013 API
Application..::..DefaultViewDiscipline Property
Application Class See Also
The view discipline that will be applied to new views by default.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ViewDiscipline DefaultViewDiscipline { get; set; }
Visual Basic
Public Property DefaultViewDiscipline As ViewDiscipline
    Get
    Set
Visual C++
public:
property ViewDiscipline DefaultViewDiscipline {
    ViewDiscipline get ();
    void set (ViewDiscipline value);
}

Remarks

This view discipline may be overridden by a view template when a view template is also applied to new views.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: This functionality is not available in Revit LT.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace