Revit 2013 API
ColumnAttachment..::..IsValidTarget Method (Boolean, Element)
ColumnAttachment Class See Also
Says whether the element can be used as a target for a new attachment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static bool IsValidTarget(
    bool forSlantedColumn,
    Element target
)
Visual Basic
Public Shared Function IsValidTarget ( _
    forSlantedColumn As Boolean, _
    target As Element _
) As Boolean
Visual C++
public:
static bool IsValidTarget(
    bool forSlantedColumn,
    Element^ target
)

Parameters

forSlantedColumn
Type: System..::..Boolean
If true, check whether the target is valid for a slanted column; if false, check whether the target is valid for a vertical column.
target
Type: Autodesk.Revit.DB..::..Element
A proposed target element for a column attachment.

Remarks

Valid targets are roofs, floors, ceilings, levels. Beams and braces are valid targets, except for slanted columns.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ColumnAttachment Class
IsValidTarget Overload