Revit 2013 API
PanelScheduleView..::..CreateInstanceView Method (Document, ElementId)
PanelScheduleView Class See Also
Creates a new instance of this view (using default template)

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static PanelScheduleView CreateInstanceView(
    Document ADoc,
    ElementId panelId
)
Visual Basic
Public Shared Function CreateInstanceView ( _
    ADoc As Document, _
    panelId As ElementId _
) As PanelScheduleView
Visual C++
public:
static PanelScheduleView^ CreateInstanceView(
    Document^ ADoc,
    ElementId^ panelId
)

Parameters

ADoc
Type: Autodesk.Revit.DB..::..Document
The Document
panelId
Type: Autodesk.Revit.DB..::..ElementId
Element id of the electrical panel element.

Return Value

The PanelScheduleView

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PanelScheduleView Class
CreateInstanceView Overload
Autodesk.Revit.DB.Electrical Namespace