Revit 2013 API
PrimaryDesignOptionMemberFilter Class
Members Example See Also
A filter used to find elements contained in any primary design option of any design option set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class PrimaryDesignOptionMemberFilter : ElementSlowFilter
Visual Basic
Public Class PrimaryDesignOptionMemberFilter _
    Inherits ElementSlowFilter
Visual C++
public ref class PrimaryDesignOptionMemberFilter : public ElementSlowFilter

Remarks

This filter is a slow filter. Slow filters require that the Element be obtained and expanded in memory first. Thus it is preferable to couple this filter with at least one ElementQuickFilter, which should minimize the number of Elements that are expanded.

Examples

CopyC#
// Create a PrimaryDesignOptionMember filter to find all Walls contained within all primary design options
PrimaryDesignOptionMemberFilter filter = new PrimaryDesignOptionMemberFilter();

// Apply the filter to the elements in the active document
// Use shortcut command OfClass() to only find wall instances
FilteredElementCollector collector = new FilteredElementCollector(document);
ICollection<Element> wallsOfPrimaryOpt = collector.OfClass(typeof(Wall)).WherePasses(filter).ToElements();

// Find walls not contained within primary design options: Use inverted filter to match walls
PrimaryDesignOptionMemberFilter notPrimaryOptFilter = new PrimaryDesignOptionMemberFilter(true); // inverted filter
collector = new FilteredElementCollector(document);
ICollection<Element> notPrimaryDesignOptFounds =
    collector.OfClass(typeof(Wall)).WherePasses(notPrimaryOptFilter).ToElements();
CopyVB.NET
' Create a PrimaryDesignOptionMember filter to find all Walls contained within all primary design options
Dim filter As New PrimaryDesignOptionMemberFilter()

' Apply the filter to the elements in the active document
' Use shortcut command OfClass() to only find wall instances
Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(document)
Dim wallsOfPrimaryOpt As ICollection(Of Autodesk.Revit.DB.Element) = collector.OfClass(GetType(Wall)).WherePasses(filter).ToElements()

' Find walls not contained within primary design options: Use inverted filter to match walls
Dim notPrimaryOptFilter As New PrimaryDesignOptionMemberFilter(True)
' inverted filter
collector = New Autodesk.Revit.DB.FilteredElementCollector(document)
Dim notPrimaryDesignOptFounds As ICollection(Of Autodesk.Revit.DB.Element) = collector.OfClass(GetType(Wall)).WherePasses(notPrimaryOptFilter).ToElements()

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementSlowFilter
Autodesk.Revit.DB..::..PrimaryDesignOptionMemberFilter

See Also

PrimaryDesignOptionMemberFilter Members