Revit 2013 API
CompoundStructure..::..GetSegmentIds Method
CompoundStructure Class See Also
Gets segment ids of this compound structure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public IList<int> GetSegmentIds()
Visual Basic
Public Function GetSegmentIds As IList(Of Integer)
Visual C++
public:
IList<int>^ GetSegmentIds()

Return Value

The ids of the segments which form the boundary of the regions of this CompoundStructure.

Remarks

The boundaries of the regions of a vertically compound structure consist of vertical horizontal segments with unique ids.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is valid only vertically compound structures.

See Also

CompoundStructure Class