Revit 2013 API
CompoundStructure..::..SetLayer Method
CompoundStructure Class See Also
Set a layer for this CompoundStructure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetLayer(
    int layerIdx,
    CompoundStructureLayer layer
)
Visual Basic
Public Sub SetLayer ( _
    layerIdx As Integer, _
    layer As CompoundStructureLayer _
)
Visual C++
public:
void SetLayer(
    int layerIdx,
    CompoundStructureLayer^ layer
)

Parameters

layerIdx
Type: System..::..Int32
The index of a layer. This should range from 0 to the number of layers - 1.
layer
Type: Autodesk.Revit.DB..::..CompoundStructureLayer
The layer to be set.

Remarks

This function does not support addition of new layers, use SetLayers() to change the number of layers.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The layer is not valid for this operation.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The layer index is out of range.

See Also

CompoundStructure Class