Revit 2013 API
ConnectorType Enumeration
See Also
An enumerated type listing all connector types for a connection

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum ConnectorType
Visual Basic
Public Enumeration ConnectorType
Visual C++
public enum class ConnectorType

Members

Member name | Description
Invalid | Invalid connection type
End | End connection type
Curve | Curve connection type
Logical | Logical connection type
Reference | Reference connection type
Surface | Surface connection type
EndSurface | End or Surface connection type
Physical | Physical connection type
NonEnd | Not end connection type
MasterSurface | Master surface connection type
Family | Family connection type
AllModes | All connection modes

See Also