Revit 2013 API
IFCAggregateIterator..::..Current Property
IFCAggregateIterator Class See Also
Gets the item at the current position of the iterator.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IFCData Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As IFCData
    Get
Visual C++
public:
virtual property IFCData^ Current {
    IFCData^ get ();
}

Implements

IEnumerator<(Of <(<'T>)>)>..::..Current

Remarks

There is no current item if the iterator has not started yet or has been done.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | There is no current item in the iterator.

See Also

IFCAggregateIterator Class
Autodesk.Revit.DB.IFC Namespace