Revit 2013 API
AdaptiveComponentInstanceUtils Members
AdaptiveComponentInstanceUtils Class Methods See Also

The AdaptiveComponentInstanceUtils type exposes the following members.

Methods

 | Name | Description
 | CreateAdaptiveComponentInstance | Creates a FamilyInstance of Adaptive Component Family.
Public method | Dispose | Releases all resources used by the AdaptiveComponentInstanceUtils
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetInstancePlacementPointElementRefIds | Gets Placement Adaptive Point Element Ref ids to which the instance geometry adapts.
 | GetInstancePointElementRefIds | Gets Adaptive Point Element Ref ids to which the instance geometry adapts.
 | GetInstanceShapeHandlePointElementRefIds | Gets Shape Handle Adaptive Point Element Ref ids to which the instance geometry adapts.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | HasAdaptiveFamilySymbol | Verifies if a FamilyInstance has an Adaptive Family Symbol.
 | IsAdaptiveComponentInstance | Verifies if a FamilyInstance is an Adaptive Component Instance.
 | IsAdaptiveFamilySymbol | Verifies if a FamilySymbol is a valid Adaptive Family Symbol.
 | IsInstanceFlipped | Gets the value of the flip parameter on the adaptive instance.
 | MoveAdaptiveComponentInstance | Moves Adaptive Component Instance by the specified transformation.
 | SetInstanceFlipped | Sets the value of the flip parameter on the adaptive instance.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AdaptiveComponentInstanceUtils Class