Revit 2013 API
ExporterIFC..::..RegisterSpaceBoundingElementHandle Method
ExporterIFC Class See Also
Stores a handle representing a space bounding element to the ExporterIFC's internal cache.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void RegisterSpaceBoundingElementHandle(
    IFCAnyHandle instanceHandle,
    ElementId id,
    ElementId levelId
)
Visual Basic
Public Sub RegisterSpaceBoundingElementHandle ( _
    instanceHandle As IFCAnyHandle, _
    id As ElementId, _
    levelId As ElementId _
)
Visual C++
public:
void RegisterSpaceBoundingElementHandle(
    IFCAnyHandle^ instanceHandle,
    ElementId^ id,
    ElementId^ levelId
)

Parameters

instanceHandle
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The handle to the space bounding element.
id
Type: Autodesk.Revit.DB..::..ElementId
The Revit element id associated to this handle.
levelId
Type: Autodesk.Revit.DB..::..ElementId
The level id assigned to the space bounding object.

Remarks

The cache of space bounding elements will be used during completion of export to create relationship objects such as IfcRelSpaceBoundary and IfcRelConnectsPathElements. The types of Revit elements accepted by this function are:
  • Walls
  • Curtain walls
  • Roofs
  • Floors
  • Doors
  • Windows

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace