Revit 2013 API
MEPSystem Class
Members See Also
A system in the Autodesk Revit MEP product. Default constructor Default destructor

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class MEPSystem : Element
Visual Basic
Public Class MEPSystem _
    Inherits Element
Visual C++
public ref class MEPSystem : public Element

Remarks

This is the base class for electrical, mechanical and piping systems, available only in the Autodesk Revit MEP product.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..MEPSystem
Autodesk.Revit.DB.Electrical..::..ElectricalSystem
Autodesk.Revit.DB.Mechanical..::..MechanicalSystem
Autodesk.Revit.DB.Plumbing..::..PipingSystem

See Also

MEPSystem Members