Revit 2013 API
EnergyAnalysisDetailModelOptions Members
EnergyAnalysisDetailModelOptions Class Constructors Methods Properties See Also

The EnergyAnalysisDetailModelOptions type exposes the following members.

Constructors

 | Name | Description
Public method | EnergyAnalysisDetailModelOptions | Constructs default options for energy analysis detailed model creation.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the EnergyAnalysisDetailModelOptions
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ExportMullions | Indicates if to specify the setting for exporting mullions.
Public property | IncludeShadingSurfaces | Indicates if to set and get the setting for if shading surfaces should be included.
Public property | SimplifyCurtainSystems | Indicates if to specify the setting for simplified curtain systems.
Public property | Tier | Level of computation for energy analysis model.

See Also

EnergyAnalysisDetailModelOptions Class
Autodesk.Revit.DB.Analysis Namespace