Revit 2013 API
StructuralConnectionType..::..ValidFamilySymbolId Method
StructuralConnectionType Class See Also
Checks whether the family symbol id is allowed for StructuralConnectionTypes with the given value for the applyTo property.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static bool ValidFamilySymbolId(
    Document doc,
    StructuralConnectionApplyTo applyTo,
    ElementId familySymbolId
)
Visual Basic
Public Shared Function ValidFamilySymbolId ( _
    doc As Document, _
    applyTo As StructuralConnectionApplyTo, _
    familySymbolId As ElementId _
) As Boolean
Visual C++
public:
static bool ValidFamilySymbolId(
    Document^ doc,
    StructuralConnectionApplyTo applyTo,
    ElementId^ familySymbolId
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
applyTo
Type: Autodesk.Revit.DB.Structure..::..StructuralConnectionApplyTo
familySymbolId
Type: Autodesk.Revit.DB..::..ElementId

Return Value

True if %familySymbolId% is invalidElementId; or if it is the id of a FamilySymbol of category "Connection Symbols" (OST_StructConnectionSymbols) with its "Apply To" parameter set to match the applyTo property. Returns false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

StructuralConnectionType Class
Autodesk.Revit.DB.Structure Namespace