Revit 2013 API
ISingleServerService Methods
ISingleServerService Interface See Also

The ISingleServerService type exposes the following members.

Methods

 | Name | Description
Public method | Execute | Implement this method to execute the given server. (Inherited from IExternalService.)
Public method | GetDescription | Implement this method to return a description of the service. (Inherited from IExternalService.)
Public method | GetName | Implement this method to return the name of the service. (Inherited from IExternalService.)
Public method | GetServiceId | Implement this method to return the unique Id of the service. (Inherited from IExternalService.)
Public method | GetVendorId | Implement this method to return the vendor Id of the service. (Inherited from IExternalService.)
Public method | IsValidServer | Implement this method to check if the given instance represents a valid server of this service. (Inherited from IExternalService.)
Public method | OnServersChanged | Implement this method to handle situations when servers for the service have changed. (Inherited from IExternalService.)
Public method | OnServersDisparity | Implements this method to get notified that the servers in a just opened document differ from those currently set as active for the service. (Inherited from IExternalService.)

See Also

ISingleServerService Interface
Autodesk.Revit.DB.ExternalService Namespace