Revit 2013 API
TriangleInShellComponent Members
TriangleInShellComponent Class Constructors Methods Properties See Also

The TriangleInShellComponent type exposes the following members.

Constructors

 | Name | Description
Public method | TriangleInShellComponent | Creates a copy of the given TriangleInShellComponent

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the TriangleInShellComponent
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | VertexIndex0 | Index of the triangle’s first vertex in the TriangulatedShellComponent’s array of vertices.
Public property | VertexIndex1 | Index of the triangle’s second vertex in the TriangulatedShellComponent’s array of vertices.
Public property | VertexIndex2 | Index of the triangle’s third vertex in the TriangulatedShellComponent’s array of vertices.

See Also

TriangleInShellComponent Class