Revit 2013 API
ExporterIFC..::..RegisterShapeForPresentationLayer Method
ExporterIFC Class See Also
Sets an IfcShapeRepresentation to be used for the IfcPresentationLayerAssignment associated with the given Revit category and element.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void RegisterShapeForPresentationLayer(
    Element pElement,
    ElementId categoryId,
    IFCAnyHandle newShapeRepresentation
)
Visual Basic
Public Sub RegisterShapeForPresentationLayer ( _
    pElement As Element, _
    categoryId As ElementId, _
    newShapeRepresentation As IFCAnyHandle _
)
Visual C++
public:
void RegisterShapeForPresentationLayer(
    Element^ pElement,
    ElementId^ categoryId,
    IFCAnyHandle^ newShapeRepresentation
)

Parameters

pElement
Type: Autodesk.Revit.DB..::..Element
The element.
categoryId
Type: Autodesk.Revit.DB..::..ElementId
The category id.
newShapeRepresentation
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The IfcShapeRepresentation handle.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace