Revit 2013 API
ExporterIFCUtils..::..SetGlobal3DDirectionHandles Method
ExporterIFCUtils Class See Also
Sets the handles representing the cardinal directions in 3D.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static void SetGlobal3DDirectionHandles(
    bool positive,
    IFCAnyHandle xDir,
    IFCAnyHandle yDir,
    IFCAnyHandle zDir
)
Visual Basic
Public Shared Sub SetGlobal3DDirectionHandles ( _
    positive As Boolean, _
    xDir As IFCAnyHandle, _
    yDir As IFCAnyHandle, _
    zDir As IFCAnyHandle _
)
Visual C++
public:
static void SetGlobal3DDirectionHandles(
    bool positive,
    IFCAnyHandle^ xDir,
    IFCAnyHandle^ yDir,
    IFCAnyHandle^ zDir
)

Parameters

positive
Type: System..::..Boolean
True if the handles returned should be in the positive direction, false if the handles should be in the negative direction.
xDir
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The X direction handle.
yDir
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The Y direction handle.
zDir
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The Z direction handle.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace