Revit 2013 API
RebarHookType..::..StraightLineMultiplier Property
RebarHookType Class See Also
Multiplier of bar diameter. Used to compute a default hook length. The default hook length can be overridden by the RebarBarType class.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double StraightLineMultiplier { get; set; }
Visual Basic
Public Property StraightLineMultiplier As Double
    Get
    Set
Visual C++
public:
property double StraightLineMultiplier {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: straightLineMultiplier must be greater than 0 and no more than 99.

See Also

RebarHookType Class
Autodesk.Revit.DB.Structure Namespace