Revit 2013 API
RenderingQualitySettings..::..MaxRefractions Property
RenderingQualitySettings Class See Also
The maximum number of refractions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int MaxRefractions { get; set; }
Visual Basic
Public Property MaxRefractions As Integer
    Get
    Set
Visual C++
public:
property int MaxRefractions {
    int get ();
    void set (int value);
}

Remarks

Increase this value when you can not see objects through multiple panes of glass.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The maximum number of refractions is not valid. The valid range is 0 to 100.
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The RenderingQualitySettings does not use custom quality currently. To use custom quality, set RenderingQuality property to RenderingQuality.Custom.

See Also

RenderingQualitySettings Class