Revit 2013 API
Definitions Members
Definitions Class Constructors Methods Properties See Also

The Definitions type exposes the following members.

Constructors

 | Name | Description
Public method | Definitions | Constructs an empty set of parameter definitions.

Methods

 | Name | Description
Public method | Contains | Tests for the existence of a definition within the set.
Public method | Create(String, ParameterType) | Creates a new parameter definition using name, type and visibility.
Public method | Create(String, ParameterType, Boolean) | Creates a new parameter definition using name and type.
Public method | Dispose | Releases all resources used by the Definitions
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetEnumerator | Retrieves an enumerator to the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Identifies if the definitions collection is empty.
Public property | Item | Retrieves a definition by a given name.
Public property | Size | The number of definitions in the collection.

See Also

Definitions Class