Revit 2013 API
FilteredElementIterator..::..MoveNext Method
FilteredElementIterator Class See Also
Increments the iterator to the next element passing the filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

True if there is another available element passing the filter in this iterator. False if the iterator has completed all available elements.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The FilteredElementCollector that yielded this iterator has been reset by another operation. No further iteration is permitted with this iterator.

See Also

FilteredElementIterator Class