Revit 2013 API
SelElementSet Methods
SelElementSet Class See Also

The SelElementSet type exposes the following members.

Methods

 | Name | Description
Public method | Add | Add an element into the selected element set.
Public method | Clear | Clear the selected element set. (Overrides ElementSet..::..Clear()()()().)
Public method | Contains | Tests for the existence of an element within the set. (Inherited from ElementSet.)
 | Create | Creates a new instance of a set specifically for holding selected elements.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Remove an element from the selected element set. (Overrides ElementSet..::..Erase(Element).)
Public method | ForwardIterator | Retrieve a forward moving iterator to the set. (Inherited from ElementSet.)
Public method | GetEnumerator | Retrieve a forward moving iterator to the set. (Inherited from ElementSet.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified element into the set. (Inherited from ElementSet.)
Public method | Remove | Remove an element from the selected element set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set. (Inherited from ElementSet.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SelElementSet Class
Autodesk.Revit.UI.Selection Namespace