Revit 2013 API
ImageView Methods
ImageView Class See Also

The ImageView type exposes the following members.

Methods

 | Name | Description
Public method | ApplyTemplate | Obsolete. Applies a view template to the view. (Inherited from View.)
Public method | ApplyViewTemplateParameters | Applies to this view the parameters of %otherView% that are not controlled by the current view template. To get all template parameters call template's method getTemplateParameterIds. To get parameters that are not controlled by the template call template's method getNonControlledTemplateParameterIds. To get current view template use property ViewTemplateId. (Inherited from View.)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanCategoryBeHiddenTemporary | Check if category can be temporarily hidden in the view. (Inherited from View.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | CanModifyDetailLevel | Check if Detail Level can be modified. (Inherited from View.)
Public method | CanModifyDisplayStyle | Indicates if DisplayStyle can be modified. (Inherited from View.)
Public method | CanModifyViewDiscipline | Indicates if the View Discipline can be modified; (Inherited from View.)
Public method | CanUseTemporaryVisibilityModes | Indicates if view can use temporary visibility modes; (Inherited from View.)
Public method | CanViewBeDuplicated | Checks if the view can be duplicated; (Inherited from View.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | ConvertTemporaryHideIsolateToPermanent | Convert all temporary hidden elements or categories to permanently hidden in view. (Inherited from View.)
 | Create | Create an ImageView containing an image imported from disk.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | DisableTemporaryViewMode | Disables the specified temporary view mode. (Inherited from View.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates the view; (Inherited from View.)
Public method | EnableRevealHiddenMode | Enables Reveal Hidden elements mode. (Inherited from View.)
Public method | EnableTemporaryAnalyticalDisplayMode | Enables temporary display of Analytical Model categories only. (Inherited from View.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDependentViewIds | Get the ids of dependent views. (Inherited from View.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetNonControlledTemplateParameterIds | Returns list of parameters that will NOT be controlled when this view is used as a template. This is a subset of the parameters returned by getTemplateParameterIds. (Inherited from View.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPrimaryViewId | Get the id of the primary view. (Inherited from View.)
Public method | GetTemplateParameterIds | Returns list of parameters that may be controlled when this view is used as a template. (Inherited from View.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | getVisibility | Checks if elements of the given category are set to be visible in this view. (Inherited from View.)
Public method | GetWorksetVisibility | Returns the visibility settings of a workset for this particular view. (Inherited from View.)
Public method | GetWorksharingDisplayMode | Gets the current worksharing display mode for this view. (Inherited from View.)
Public method | HasDetailLevel | Check if the view has a Detail Level property; (Inherited from View.)
Public method | HasDisplayStyle | Indicates if view has a DisplayStyle property; (Inherited from View.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasViewDiscipline | Indicates if the view has a Discipline property; (Inherited from View.)
Public method | Hide | Obsolete. Sets the elements to be hidden in the view. (Inherited from View.)
Public method | HideActiveWorkPlane | Hide the active work plane of the view. (Inherited from View.)
Public method | HideCategoriesTemporary | Set multiple categories to be temporarily hidden in the view. (Inherited from View.)
Public method | HideCategoryTemporary | Set one category to be temporarily hidden in the view. (Inherited from View.)
Public method | HideElements | Sets the elements to be hidden in the view. (Inherited from View.)
Public method | HideElementsTemporary | Set multiple elements to be temporarily hidden in the view. (Inherited from View.)
Public method | HideElementTemporary | Set one element to be temporarily hidden in the view. (Inherited from View.)
Public method | IsElementVisibleInTemporaryViewMode | Identifies if the input element is visible for the temporary view mode for this view. (Inherited from View.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsInTemporaryViewMode | Returns true if the view is in a particular temporary view mode. (Inherited from View.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsolateCategoriesTemporary | Set categories to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateCategoryTemporary | Set one category to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateElementsTemporary | Set multiple elements to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateElementTemporary | Set one element to be temporarily isolated in the view. (Inherited from View.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsTemporaryAnalyticalModeActive | Indicates if the view is temporarily displaying only the Analytical model. (Inherited from View.)
Public method | IsTemporaryHideIsolateActive | Indicates if the view is temporarily hiding or isolating elements or categories. (Inherited from View.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | IsValidViewTemplate | Verify that %templateId% can be view template for this view: it can be invalidElementId or represent template view that is compatible with this view; (Inherited from View.)
Public method | IsWorksetVisible | Indicates whether the workset is visible in this view. (Inherited from View.)
Public method | Print()()()() | Print this view with the default view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(Boolean) | Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | Print(View) | Print this view with the given view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(View, Boolean) | Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetNonControlledTemplateParameterIds | Set the parameters that will NOT be applied when this view is used as a template. This should be a subset of the parameters returned by getTemplateParameterIds (other parameters will be ignored). (Inherited from View.)
Public method | setVisibility | Set if elements of the given category will be visible in this view. (Inherited from View.)
Public method | SetWorksetVisibility | Sets visibility for a workset in this view. (Inherited from View.)
Public method | SetWorksharingDisplayMode | Sets the worksharing display mode for this view. (Inherited from View.)
Public method | ShowActiveWorkPlane | Show the active work plane of the view. (Inherited from View.)
Public method | SupportsWorksharingDisplayMode | Checks whether this view supports the given worksharing display mode. (Inherited from View.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Unhide | Obsolete. Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)
Public method | UnhideElements | Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)

See Also

ImageView Class