Revit 2013 API
Document..::..IsReadOnlyFile Property
Document Class See Also
Signals whether the document was opened from a read-only file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsReadOnlyFile { get; }
Visual Basic
Public ReadOnly Property IsReadOnlyFile As Boolean
    Get
Visual C++
public:
property bool IsReadOnlyFile {
    bool get ();
}

Field Value

True if the document was opened in read-only mode, False otherwise.

Remarks

A document could be opened this way when, for example, at the time of opening the file was being used by another Revit user, or if the disk file has the read-only attribute set.

Although it will still be possible to modify the opened document, any changes made there will not be possible to save into the original file. If the changes are to be preserved, the document must be saved under a different name using the SaveAs() method.

See Also

Document Class