Revit 2013 API
EnergyDataSettings..::..CheckBuildingOperatingSchedule Method
EnergyDataSettings Class See Also
Checks that the building operating schedule falls within an appropriate range.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static bool CheckBuildingOperatingSchedule(
    gbXMLBuildingOperatingSchedule buildingOperatingSchedule
)
Visual Basic
Public Shared Function CheckBuildingOperatingSchedule ( _
    buildingOperatingSchedule As gbXMLBuildingOperatingSchedule _
) As Boolean
Visual C++
public:
static bool CheckBuildingOperatingSchedule(
    gbXMLBuildingOperatingSchedule buildingOperatingSchedule
)

Parameters

buildingOperatingSchedule
Type: Autodesk.Revit.DB.Analysis..::..gbXMLBuildingOperatingSchedule
The building operating schedule to be checked.

Return Value

True if the building operating schedule falls within an appropriate range, false otherwise.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace