Revit 2013 API
TriOrQuadFacet..::..GetVertexIndex Method
TriOrQuadFacet Class See Also
Returns the index of the specified vertex of this facet (as an index into the external array of vertices in the TriangulationInterface that was used to create the list of TriOrQuadFacets).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int GetVertexIndex(
    int index
)
Visual Basic
Public Function GetVertexIndex ( _
    index As Integer _
) As Integer
Visual C++
public:
int GetVertexIndex(
    int index
)

Parameters

index
Type: System..::..Int32
Index of the desired vertex in this TriOrQuadFacet (between 0 and NumberOfVertices-1, inclusive).

Return Value

The index of the specified vertex in the external array of vertices (only valid if NumberOfVertices >= 3).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | index is out of range..

See Also

TriOrQuadFacet Class