Revit 2013 API
ContinuousRailType..::..ProfileId Property
ContinuousRailType Class See Also
The id of the profile of the rail

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId ProfileId { get; set; }
Visual Basic
Public Property ProfileId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ ProfileId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The profileId is not a valid element id. -or- When setting this property: The profileId is not a valid profile symbol for continuous rail.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

ContinuousRailType Class
Autodesk.Revit.DB.Architecture Namespace