Revit 2013 API
ExporterIFC..::..FindSpaceBoundingElementHandle Method
ExporterIFC Class See Also
Looks up the handle associated to the element and level id from the ExporterIFC's internal cache.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IFCAnyHandle FindSpaceBoundingElementHandle(
    ElementId id,
    ElementId levelId
)
Visual Basic
Public Function FindSpaceBoundingElementHandle ( _
    id As ElementId, _
    levelId As ElementId _
) As IFCAnyHandle
Visual C++
public:
IFCAnyHandle^ FindSpaceBoundingElementHandle(
    ElementId^ id,
    ElementId^ levelId
)

Parameters

id
Type: Autodesk.Revit.DB..::..ElementId
The Revit element id to look for.
levelId
Type: Autodesk.Revit.DB..::..ElementId
The element level id.

Return Value

The handle associated to the element and level id. If the id is not found in the cache, an empty handle is returned (HasValue == false).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace