Revit 2013 API
AnalyticalModelSweptProfile..::..GetSweptProfile Method
AnalyticalModelSweptProfile Class See Also
Returns an object that describes the profile that is swept along the driving curve.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public Profile GetSweptProfile()
Visual Basic
Public Function GetSweptProfile As Profile
Visual C++
public:
Profile^ GetSweptProfile()

Return Value

A geometric profile object.

Remarks

The profile is swept perpendicular to the driving curve.

See Also

AnalyticalModelSweptProfile Class
Autodesk.Revit.DB.Structure Namespace