Revit 2013 API
IFCFileModelOptions Members
IFCFileModelOptions Class Constructors Methods Properties See Also

The IFCFileModelOptions type exposes the following members.

Constructors

 | Name | Description
Public method | IFCFileModelOptions | Creates a default IFCFileModelOptions. The default schema file is empty and cache size is 8192.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the IFCFileModelOptions
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CacheSize | The cache size of the file.
Public property | SchemaFile | The full name of an IFC schema file.
Public property | SchemaName | The name of the schema.
Public property | UserControlledInverses | Indicates if the inverses are controlled by Revit or users. True by users, false by Revit.

See Also

IFCFileModelOptions Class
Autodesk.Revit.DB.IFC Namespace