Revit 2013 API
ElementIntersectsElementFilter Constructor (Element, Boolean)
ElementIntersectsElementFilter Class See Also
Constructs a filter to match elements which intersect the given element, with the option to match all elements not intersecting the given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementIntersectsElementFilter(
    Element element,
    bool inverted
)
Visual Basic
Public Sub New ( _
    element As Element, _
    inverted As Boolean _
)
Visual C++
public:
ElementIntersectsElementFilter(
    Element^ element,
    bool inverted
)

Parameters

element
Type: Autodesk.Revit.DB..::..Element
The element to check for intersection.
inverted
Type: System..::..Boolean
True if the filter should match all elements which do not intersect the given element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The category of the element is not supported for element intersection filters. -or- The element is not supported for element intersection filters.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ElementIntersectsElementFilter Class
ElementIntersectsElementFilter Overload