Revit 2013 API
Definition..::..ParameterType Property
Definition Class Example See Also
Returns the user visible interpretation of the parameter data.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract ParameterType ParameterType { get; }
Visual Basic
Public MustOverride ReadOnly Property ParameterType As ParameterType
    Get
Visual C++
public:
virtual property ParameterType ParameterType {
    ParameterType get () abstract;
}

Remarks

The data within the parameter is stored in a very simple manner as an integer, double, string or an element id, but to the user these values may be more meaningful as Length, Volume, Mass etc. This parameter returns the interpretation that should be used for the data.

Examples

CopyC#
//Find parameter using the Parameter's definition type.
public Parameter FindParameter(Element element)
{
    Parameter foundParameter = null;
    // This will find the first parameter that measures length
    foreach (Parameter parameter in element.Parameters)
    {
        if (parameter.Definition.ParameterType == ParameterType.Length)
        {
            foundParameter = parameter;
            break;
        }
    }
    return foundParameter;
}
CopyVB.NET
'Find parameter using the Parameter's definition type.
Public Function FindParameter(ByVal element As Autodesk.Revit.DB.Element) As Parameter
    Dim foundParameter As Parameter = Nothing
    ' This will find the first parameter that measures length
    For Each parameter As Parameter In element.Parameters
        If parameter.Definition.ParameterType = ParameterType.Length Then
            foundParameter = parameter
            Exit For
        End If
    Next
    Return foundParameter
End Function

See Also

Definition Class