Revit 2013 API
UV..::..CrossProduct Method
UV Class See Also
The cross product of this 2-D vector and the specified 2-D vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double CrossProduct(
    UV source
)
Visual Basic
Public Function CrossProduct ( _
    source As UV _
) As Double
Visual C++
public:
double CrossProduct(
    UV^ source
)

Parameters

source
Type: Autodesk.Revit.DB..::..UV
The vector to multiply with this vector.

Return Value

The real number equal to the cross product.

Remarks

The cross product of the two vectors in 2-D space is equivalent to the area of the parallelogram they span.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when source is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

UV Class