Revit 2013 API
RenderingQualitySettings..::..AreShadowsEnabled Property
RenderingQualitySettings Class See Also
Indicates whether to make shadow edges soft(blurred).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool AreShadowsEnabled { get; set; }
Visual Basic
Public Property AreShadowsEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool AreShadowsEnabled {
    bool get ();
    void set (bool value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The RenderingQualitySettings does not use custom quality currently. To use custom quality, set RenderingQuality property to RenderingQuality.Custom.

See Also

RenderingQualitySettings Class