Revit 2013 API
ExporterIFCUtils..::..AddValueString Method
ExporterIFCUtils Class See Also
Adds a string value to a built-in parameter.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static void AddValueString(
    Element element,
    ElementId builtInParameter,
    string propertyValue
)
Visual Basic
Public Shared Sub AddValueString ( _
    element As Element, _
    builtInParameter As ElementId, _
    propertyValue As String _
)
Visual C++
public:
static void AddValueString(
    Element^ element,
    ElementId^ builtInParameter,
    String^ propertyValue
)

Parameters

element
Type: Autodesk.Revit.DB..::..Element
The element.
builtInParameter
Type: Autodesk.Revit.DB..::..ElementId
The built-in parameter id.
propertyValue
Type: System..::..String
The new value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace