Revit 2013 API
DocumentChangedEventArgs Methods
DocumentChangedEventArgs Class See Also

The DocumentChangedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RevitAPIEventArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAddedElementIds | Returns set of elements newly added to the document
Public method | GetDeletedElementIds | Returns set of elements that were deleted from the document
Public method | GetDocument | Returns document associated with this event
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetModifiedElementIds | Returns set of elements that were modified
Public method | GetTransactionNames | Returns names of the transactions associated with this event
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentChangedEventArgs Class
Autodesk.Revit.DB.Events Namespace