Revit 2013 API
RebarHookType..::..GetHookExtensionLength Method
RebarHookType Class See Also
Computes the hook extension length.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double GetHookExtensionLength(
    RebarBarType barType
)
Visual Basic
Public Function GetHookExtensionLength ( _
    barType As RebarBarType _
) As Double
Visual C++
public:
double GetHookExtensionLength(
    RebarBarType^ barType
)

Parameters

barType
Type: Autodesk.Revit.DB.Structure..::..RebarBarType

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

RebarHookType Class
Autodesk.Revit.DB.Structure Namespace