Revit 2013 API
ExporterIFCUtils..::..GetOriginalSymbol Method
ExporterIFCUtils Class See Also
Returns the original family symbol of this family instance, before the instance is modified by joins, cuts, coping, extensions, or other post-processing.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static FamilySymbol GetOriginalSymbol(
    FamilyInstance familyInstance
)
Visual Basic
Public Shared Function GetOriginalSymbol ( _
    familyInstance As FamilyInstance _
) As FamilySymbol
Visual C++
public:
static FamilySymbol^ GetOriginalSymbol(
    FamilyInstance^ familyInstance
)

Parameters

familyInstance
Type: Autodesk.Revit.DB..::..FamilyInstance
The FamilyInstance.

Return Value

The original FamilySymbol.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace