Revit 2013 API
SchedulableField Members
SchedulableField Class Constructors Methods Operators Properties See Also

The SchedulableField type exposes the following members.

Constructors

 | Name | Description
Public method | SchedulableField()()()() | Creates a new SchedulableField.
Public method | SchedulableField(ScheduleFieldType) | Creates a new SchedulableField.
Public method | SchedulableField(ScheduleFieldType, ElementId) | Creates a new SchedulableField.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the SchedulableField
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | GetHashCode | Gets the integer value of the SchedulableField as hash code; (Overrides Object..::..GetHashCode()()()().)
Public method | GetName | Gets the name of the field.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Operators

Name | Description
Equality | Determines whether two SchedulableField are the same.
Inequality | Determines whether two SchedulableField are different.

Properties

 | Name | Description
Public property | FieldType | The type of data displayed by the field.
Public property | ParameterId | The ID of the parameter displayed by the field.

See Also

SchedulableField Class