Revit 2013 API
ExporterIFC..::..Get3DContextHandle Method
ExporterIFC Class See Also
Obtains the IfcRepresentationContext or IfcRepresentationSubContext handle to be used for 3D entities (Model entities).

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IFCAnyHandle Get3DContextHandle(
    string subContextName
)
Visual Basic
Public Function Get3DContextHandle ( _
    subContextName As String _
) As IFCAnyHandle
Visual C++
public:
IFCAnyHandle^ Get3DContextHandle(
    String^ subContextName
)

Parameters

subContextName
Type: System..::..String
The name of the IfcRepresentationSubContext, or the IfcRepresentationContext if the string is empty, for 3D entities.

Return Value

The IfcRepresentationContext for 3D entities.

Remarks

The context handle automatically incorporates the angle to true north for the document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace