Revit 2013 API
UpdaterRegistry..::..SetExecutionOrder Method
UpdaterRegistry Class See Also
Forces execution order between two updaters Execution order: first before second

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static void SetExecutionOrder(
    UpdaterId first,
    UpdaterId second
)
Visual Basic
Public Shared Sub SetExecutionOrder ( _
    first As UpdaterId, _
    second As UpdaterId _
)
Visual C++
public:
static void SetExecutionOrder(
    UpdaterId^ first,
    UpdaterId^ second
)

Parameters

first
Type: Autodesk.Revit.DB..::..UpdaterId
Id of first Updater
second
Type: Autodesk.Revit.DB..::..UpdaterId
Id of second Updater

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | One or both inputs are not valid UpdaterIds -or- One or both of the Updaters are not registered -or- first and second are the same id
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | The updaters do not report the same ChangePriority

See Also

UpdaterRegistry Class