Revit 2013 API
IFCAnyHandle..::..IsSubTypeOf Method
IFCAnyHandle Class See Also
Determines whether the instance is an instance of the specified instance type or a subtype of this instance type.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsSubTypeOf(
    string typeName
)
Visual Basic
Public Function IsSubTypeOf ( _
    typeName As String _
) As Boolean
Visual C++
public:
bool IsSubTypeOf(
    String^ typeName
)

Parameters

typeName
Type: System..::..String
The instance type name.

Return Value

True if the instance is an instance of the specified instance type or its subtype, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCAnyHandle Class
Autodesk.Revit.DB.IFC Namespace