Revit 2013 API
Asset Properties
Asset Class See Also

The Asset type exposes the following members.

Properties

 | Name | Description
Public property | AssetType | Get the object's AssetPropertyType
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item[([( Int32])]) | (Inherited from AssetProperties.)
Public property | Item[([( String])]) | Gets the one property that the current object contains with the given name. (Inherited from AssetProperties.)
Public property | LibraryName | Get the library name
Public property | Name | Get the name of the AssetProperty; (Inherited from AssetProperty.)
Public property | Size | Gets the number of the AssetProperty(s) in the object. (Inherited from AssetProperties.)
Public property | Title | Get the asset's title
Public property | Type | Returns the Type of the AssetProperty; (Inherited from AssetProperty.)

See Also

Asset Class
Autodesk.Revit.Utility Namespace