Revit 2013 API
IFCAggregate..::..AddAggregate Method
IFCAggregate Class See Also
Creates a nested aggregate and adds it to the aggregate.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IFCAggregate AddAggregate()
Visual Basic
Public Function AddAggregate As IFCAggregate
Visual C++
public:
IFCAggregate^ AddAggregate()

Return Value

The nested aggregate.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The aggregate is not valid.

See Also

IFCAggregate Class
Autodesk.Revit.DB.IFC Namespace