Revit 2013 API
SchemaBuilder..::..AddArrayField Method
SchemaBuilder Class See Also
Creates a field containing an array of values in the Schema, with given name and type of contained values.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public FieldBuilder AddArrayField(
    string fieldName,
    Type fieldType
)
Visual Basic
Public Function AddArrayField ( _
    fieldName As String, _
    fieldType As Type _
) As FieldBuilder
Visual C++
public:
FieldBuilder^ AddArrayField(
    String^ fieldName,
    Type^ fieldType
)

Parameters

fieldName
Type: System..::..String
The name of the new field.
fieldType
Type: System..::..Type
The type of the contents in the new field.

Return Value

The FieldBuilder object may be used to add more details to the field. Make sure to set the unit type if the field contains floating-point values.

Remarks

The supported types for the contents are the same as for simple fields. See AddSimpleField(String, Type) for details.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The parameter fieldName is not acceptable for naming Extensible Storage objects. -or- The field type is not supported.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | The SchemaBuilder has already finished building the Schema.

See Also

SchemaBuilder Class
Autodesk.Revit.DB.ExtensibleStorage Namespace