Revit 2013 API
PartMakerMethodToDivideVolumes..::..CanBeDivisionProfile Method (ElementId, Document)
PartMakerMethodToDivideVolumes Class See Also
Checks whether a family defines a profile which can be used by this method.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static bool CanBeDivisionProfile(
    ElementId familyId,
    Document familyDocument
)
Visual Basic
Public Shared Function CanBeDivisionProfile ( _
    familyId As ElementId, _
    familyDocument As Document _
) As Boolean
Visual C++
public:
static bool CanBeDivisionProfile(
    ElementId^ familyId,
    Document^ familyDocument
)

Parameters

familyId
Type: Autodesk.Revit.DB..::..ElementId
Element id of the family.
familyDocument
Type: Autodesk.Revit.DB..::..Document
The document containing the family to be tested.

Return Value

True if the family defines a profile which can be used by a part maker, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PartMakerMethodToDivideVolumes Class
CanBeDivisionProfile Overload