Revit 2013 API
FailureDefinitionRegistry Methods
FailureDefinitionRegistry Class See Also

The FailureDefinitionRegistry type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindFailureDefinition | Finds a specific FailureDefinition by a given FailureDefinitionId.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ListAllFailureDefinitions | Retrieves all the registered FailureDefinitions.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FailureDefinitionRegistry Class