Revit 2013 API
RebarShapeDefinitionBySegments Properties
RebarShapeDefinitionBySegments Class See Also

The RebarShapeDefinitionBySegments type exposes the following members.

Properties

 | Name | Description
Public property | Complete | Report whether the shape definition is fully constrained. (Inherited from RebarShapeDefinition.)
Public property | IsPlanar | Reports whether the shape definition lies within a plane: false if a spiral, true in all other cases. (Inherited from RebarShapeDefinition.)
Public property | MajorSegmentIndex | Index of a segment that can be considered the most important. Revit attempts to preserve the orientation of this segment when a Rebar instance changes its RebarShape to one with a different number of segments.
Public property | NumberOfSegments | The number of straight segments in this shape.
Public property | NumberOfVertices | The number of vertices in this shape, always equal to NumberOfSegments + 1.

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.DB.Structure Namespace