Revit 2013 API
BoundingBoxIsInsideFilter Constructor (Outline)
BoundingBoxIsInsideFilter Class See Also
Constructs a new instance of a filter to match elements with a bounding box that is contained by the given Outline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public BoundingBoxIsInsideFilter(
    Outline outline
)
Visual Basic
Public Sub New ( _
    outline As Outline _
)
Visual C++
public:
BoundingBoxIsInsideFilter(
    Outline^ outline
)

Parameters

outline
Type: Autodesk.Revit.DB..::..Outline
The Outline used to find elements with a bounding box that are contained by it.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | outline is an empty Outline.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

BoundingBoxIsInsideFilter Class
BoundingBoxIsInsideFilter Overload