Revit 2013 API
RebarShapeDefinitionBySegments..::..SetSegmentFixedDirection Method
RebarShapeDefinitionBySegments Class See Also
Fix the direction of a segment.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetSegmentFixedDirection(
    int iSegment,
    double vecCoordX,
    double vecCoordY
)
Visual Basic
Public Sub SetSegmentFixedDirection ( _
    iSegment As Integer, _
    vecCoordX As Double, _
    vecCoordY As Double _
)
Visual C++
public:
void SetSegmentFixedDirection(
    int iSegment,
    double vecCoordX,
    double vecCoordY
)

Parameters

iSegment
Type: System..::..Int32
Index of the segment (0 to NumberOfSegments - 1).
vecCoordX
Type: System..::..Double
The x-coordinate of a 2D vector specifying the segment direction.
vecCoordY
Type: System..::..Double
The y-coordinate of a 2D vector specifying the segment direction.

Remarks

The centerline of the edge will be constrained to be parallel to the vector. The edge must have at least one constraint.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | iSegment is not between 0 and NumberOfEdges. -or- The length of the vector (vecCoordX, vecCoordY) is too close to zero.

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.DB.Structure Namespace