Revit 2013 API
RoutingPreferenceRule Methods
RoutingPreferenceRule Class See Also

The RoutingPreferenceRule type exposes the following members.

Methods

 | Name | Description
Public method | AddCriterion | Adds a new routing criterion.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCriterion | Gets the specified criteria.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RemoveCriteron | Removes an existing criterion.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RoutingPreferenceRule Class