Revit 2013 API
StairsType Properties
StairsType Class See Also

The StairsType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | ConstructionMethod | The construction method of the stairs.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | EndConnectionType | The join style between a run and landing.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HasMiddleSupports | True if the stairs type has middle supports, False otherwise.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | LandingType | The type for all landings in the stair element.
Public property | LeftLateralOffset | The offset for the left support from the edge of the run in a horizontal direction.
Public property | LeftSideSupportType | The type of left support used in the stair.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MaxRiserHeight | The maximum height of each riser on the stair element.
Public property | MiddleSupportsNumber | The number of middle supports used in the stair.
Public property | MiddleSupportType | The type of middle supports used in the stair.
Public property | MinRunWidth | The initial value for the width of a common run.
Public property | MinTreadDepth | The minimum tread width along the center path for all common runs (winder, arc, and straight).
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | NotchExtension | The horizontal length of the notch profile.
Public property | NotchHorizontalGap | The width of the horizontal gap in the stairs notch.
Public property | NotchThickness | The vertical length of the notch profile from the top.
Public property | NotchVerticalGap | The width of the vertical gap in the stairs notch.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | RightLateralOffset | The offset for the right support from the edge of the run in a horizontal direction.
Public property | RightSideSupportType | The type of right support used in the stair.
Public property | RunType | The type for all runs in the stair element.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

StairsType Class
Autodesk.Revit.DB.Architecture Namespace