Revit 2013 API
RebarInSystem..::..GetHookTypeId Method
RebarInSystem Class See Also
Get the id of the RebarHookType to be applied to the rebar.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId GetHookTypeId(
    int end
)
Visual Basic
Public Function GetHookTypeId ( _
    end As Integer _
) As ElementId
Visual C++
public:
ElementId^ GetHookTypeId(
    int end
)

Parameters

end
Type: System..::..Int32
0 for the start hook, 1 for the end hook.

Return Value

The id of a RebarHookType, or invalidElementId if the rebar has no hook at the specified end.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | end must be 0 or 1.

See Also

RebarInSystem Class
Autodesk.Revit.DB.Structure Namespace