Revit 2013 API
RevitAPIPreEventArgs Class
Members See Also
The class is used as a base class for the arguments for any pre-event.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class RevitAPIPreEventArgs : RevitAPIEventArgs
Visual Basic
Public Class RevitAPIPreEventArgs _
    Inherits RevitAPIEventArgs
Visual C++
public ref class RevitAPIPreEventArgs : public RevitAPIEventArgs

Remarks

A pre-event is the event raised before executing the process that was related with the event.

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Autodesk.Revit.DB.Events..::..RevitAPIEventArgs
Autodesk.Revit.DB.Events..::..RevitAPIPreEventArgs
Autodesk.Revit.DB.Events..::..DocumentCreatingEventArgs
Autodesk.Revit.DB.Events..::..DocumentOpeningEventArgs
Autodesk.Revit.DB.Events..::..RevitAPIPreDocEventArgs

See Also

RevitAPIPreEventArgs Members
Autodesk.Revit.DB.Events Namespace