Revit 2013 API
IFCFileWriteOptions Members
IFCFileWriteOptions Class Constructors Methods Properties See Also

The IFCFileWriteOptions type exposes the following members.

Constructors

 | Name | Description
Public method | IFCFileWriteOptions | Creates a default IFCFileWriteOptions. The default file format is ifc.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the IFCFileWriteOptions
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | FileFormat | The file format of the IFC file.
Public property | FileName | The full file name of the IFC file to be written.
Public property | XMLConfigFileName | The XML configuration file name. It is used only for writing IFC-XML format file.

See Also

IFCFileWriteOptions Class
Autodesk.Revit.DB.IFC Namespace