Revit 2013 API
RebarShapeConstraintFixedSegmentDir..::..Direction Property
RebarShapeConstraintFixedSegmentDir Class See Also

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public UV Direction { get; set; }
Visual Basic
Public Property Direction As UV
    Get
    Set
Visual C++
public:
property UV^ Direction {
    UV^ get ();
    void set (UV^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

RebarShapeConstraintFixedSegmentDir Class
Autodesk.Revit.DB.Structure Namespace