Revit 2013 API
UpdaterRegistry..::..RemoveAllTriggers Method
UpdaterRegistry Class See Also
Removes all triggers associated with Updater with specified UpdaterId. Does not unregister updater.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static void RemoveAllTriggers(
    UpdaterId id
)
Visual Basic
Public Shared Sub RemoveAllTriggers ( _
    id As UpdaterId _
)
Visual C++
public:
static void RemoveAllTriggers(
    UpdaterId^ id
)

Parameters

id
Type: Autodesk.Revit.DB..::..UpdaterId
Id of specified updater

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | updater's owner AddIn does not match currently active AddIn -or- RemoveAllTriggers called while executing an updater.

See Also

UpdaterRegistry Class