Revit 2013 API
PointLoad Class
Members Example See Also
An object that represents a force/moment applied to a single point.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class PointLoad : LoadBase
Visual Basic
Public Class PointLoad _
    Inherits LoadBase
Visual C++
public ref class PointLoad : public LoadBase

Examples

CopyC#
private void Getinfo_PointLoad(PointLoad pointLoad)
{
    string message = "Point Load :";

    // Get the load case name
    message += "\nLoad case for load: " + pointLoad.LoadCaseName;

    //get the three dimensional force applied to the point load
    message += "\nForce: (" + pointLoad.Force.X + ", " +
             pointLoad.Force.Y + ", " + pointLoad.Force.Z + ")";

    //get the three dimensional moment application to the point load
    message += "\nMoment: (" + pointLoad.Moment.X + ", " +
             pointLoad.Moment.Y + ", " + pointLoad.Moment.Z + ")";

    //get the three dimensional coordinates of point load
    message += "\nPoint load location: (" + pointLoad.Point.X + ", " +
             pointLoad.Point.Y + ", " + pointLoad.Point.Z + ")";

    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Private Sub Getinfo_PointLoad(ByVal pointLoad As Autodesk.Revit.DB.Structure.PointLoad)
    Dim message As String = "Point Load :"

    ' Get the load case name
    message += vbLf & "Load case for load: " + pointLoad.LoadCaseName

    'get the three dimensional force applied to the point load
    message += vbLf & "Force: (" + pointLoad.Force.X + ", " + pointLoad.Force.Y + ", " + pointLoad.Force.Z + ")"

    'get the three dimensional moment application to the point load
    message += vbLf & "Moment: (" + pointLoad.Moment.X + ", " + pointLoad.Moment.Y + ", " + pointLoad.Moment.Z + ")"

    'get the three dimensional coordinates of point load
    message += vbLf & "Point load location: (" + pointLoad.Point.X + ", " + pointLoad.Point.Y + ", " + pointLoad.Point.Z + ")"

    TaskDialog.Show("Revit", message)
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB.Structure..::..LoadBase
Autodesk.Revit.DB.Structure..::..PointLoad

See Also

PointLoad Members
Autodesk.Revit.DB.Structure Namespace