Revit 2013 API
IFCAggregate..::..Add Method
IFCAggregate Class See Also
Adds an element to the aggregate.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void Add(
    IFCData ifcData
)
Visual Basic
Public Sub Add ( _
    ifcData As IFCData _
)
Visual C++
public:
void Add(
    IFCData^ ifcData
)

Parameters

ifcData
Type: Autodesk.Revit.DB.IFC..::..IFCData
The IFCData element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | The aggregate is not valid.

See Also

IFCAggregate Class
Autodesk.Revit.DB.IFC Namespace