Revit 2013 API
ViewActivatedEventArgs Members
ViewActivatedEventArgs Class Methods Properties See Also

The ViewActivatedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Public property | CurrentActiveView | The view that has just become active.
Public property | Document | The document associated with the event. (Inherited from PostDocEventArgs.)
Public property | PreviousActiveView | The previously active view.
Public property | Status | Indicates whether the action associated with this event succeeded, failed, or was cancelled (by an APIevent handler). (Inherited from PostEventArgs.)

See Also

ViewActivatedEventArgs Class
Autodesk.Revit.UI.Events Namespace