Revit 2013 API
SpatialElementBoundaryOptions Members
SpatialElementBoundaryOptions Class Constructors Methods Properties See Also

The SpatialElementBoundaryOptions type exposes the following members.

Constructors

 | Name | Description
Public method | SpatialElementBoundaryOptions | Constructs default options for calculation of the geometry of spatial elements (rooms, spaces).

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the SpatialElementBoundaryOptions
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | SpatialElementBoundaryLocation | The boundary of spatial element for geometry calculation.
Public property | StoreFreeBoundaryFaces | Indicates whether to include the free boundary faces in the result.

See Also

SpatialElementBoundaryOptions Class