Revit 2013 API
HostObject..::..FindInserts Method
HostObject Class See Also
Gets the ids of the instances inserted into this host object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public IList<ElementId> FindInserts(
    bool addRectOpenings,
    bool includeShadows,
    bool includeEmbeddedWalls,
    bool includeSharedEmbeddedInserts
)
Visual Basic
Public Function FindInserts ( _
    addRectOpenings As Boolean, _
    includeShadows As Boolean, _
    includeEmbeddedWalls As Boolean, _
    includeSharedEmbeddedInserts As Boolean _
) As IList(Of ElementId)
Visual C++
public:
IList<ElementId^>^ FindInserts(
    bool addRectOpenings,
    bool includeShadows,
    bool includeEmbeddedWalls,
    bool includeSharedEmbeddedInserts
)

Parameters

addRectOpenings
Type: System..::..Boolean
True if rectangular openings should be included in the return.
includeShadows
Type: System..::..Boolean
True if shadows should be included in the return.
includeEmbeddedWalls
Type: System..::..Boolean
True if embedded walls should be included in the return.
includeSharedEmbeddedInserts
Type: System..::..Boolean
True if shared embedded inserts should be included in the return.

Return Value

All the insertable instances' ids.

See Also

HostObject Class