Revit 2013 API
IFCExtrusionCalculatorOptions..::..CustomAxis Property
IFCExtrusionCalculatorOptions Class See Also
The custom axis to try (if extrusionAxes includes an option for a custom direction).

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public XYZ CustomAxis { get; set; }
Visual Basic
Public Property CustomAxis As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ CustomAxis {
    XYZ^ get ();
    void set (XYZ^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

IFCExtrusionCalculatorOptions Class
Autodesk.Revit.DB.IFC Namespace