Revit 2013 API
ExporterIFCUtils..::..GetIFCType Method
ExporterIFCUtils Class See Also
Obtains the IFC type associated to the given element for the current export.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static string GetIFCType(
    Element element,
    ExporterIFC exporterIFC
)
Visual Basic
Public Shared Function GetIFCType ( _
    element As Element, _
    exporterIFC As ExporterIFC _
) As String
Visual C++
public:
static String^ GetIFCType(
    Element^ element,
    ExporterIFC^ exporterIFC
)

Parameters

element
Type: Autodesk.Revit.DB..::..Element
The element.
exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.

Return Value

The IFC type. This is an empty string if the element should not be exported because it is not found in the mapping file.

Remarks

IFC type names are affected by the user's entries in the mapping file set for a given export operation.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace