Revit 2013 API
Connector..::..Origin Property
Connector Class See Also
The location of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual XYZ Origin { get; set; }
Visual Basic
Public Overridable Property Origin As XYZ
    Get
    Set
Visual C++
public:
virtual property XYZ^ Origin {
    XYZ^ get ();
    void set (XYZ^ value);
}

Implements

IConnector..::..Origin

Remarks

Changing the location of the connector may lead to changes of location and geometry for the connector's host element and the hosts for other elements the element is connected to.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when connector's type is NonEndConn. Thrown when the connector is a part of a family instance.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the assigned origin is invalid.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown on failure to set origin.

See Also

Connector Class