Revit 2013 API
RenderingQualitySettings..::..MaxReflections Property
RenderingQualitySettings Class See Also
The maximum number of reflections.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int MaxReflections { get; set; }
Visual Basic
Public Property MaxReflections As Integer
    Get
    Set
Visual C++
public:
property int MaxReflections {
    int get ();
    void set (int value);
}

Remarks

Increase this value when objects are missing from reflections.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The maximum number of reflections is not valid. The valid range is 0 to 100.
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The RenderingQualitySettings does not use custom quality currently. To use custom quality, set RenderingQuality property to RenderingQuality.Custom.

See Also

RenderingQualitySettings Class