Revit 2013 API
CompoundStructure..::..GetExtendableRegionIds Method
CompoundStructure Class See Also
Gets the extendable region ids for the compound structure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public IList<int> GetExtendableRegionIds(
    bool top
)
Visual Basic
Public Function GetExtendableRegionIds ( _
    top As Boolean _
) As IList(Of Integer)
Visual C++
public:
IList<int>^ GetExtendableRegionIds(
    bool top
)

Parameters

top
Type: System..::..Boolean
If true, retrieve ids of regions which are extendable at the top, otherwise retrieve the ids of regions which are extendable at the bottom.

Return Value

An array of region ids which are marked extendable.

Remarks

Regions along the top or bottom of the wall may be set to be extendable.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is valid only vertically compound structures.

See Also

CompoundStructure Class