Revit 2013 API
RenderingQualitySettings..::..AreWindowsDaylightPortals Property
RenderingQualitySettings Class See Also
Indicates whether windows daylight portals.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool AreWindowsDaylightPortals { get; set; }
Visual Basic
Public Property AreWindowsDaylightPortals As Boolean
    Get
    Set
Visual C++
public:
property bool AreWindowsDaylightPortals {
    bool get ();
    void set (bool value);
}

Remarks

Set this property to true when sunlighting coming through windows looks splotchy, this can slow down rendering but helps for rooms with few or small windows.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The RenderingQualitySettings does not use custom quality currently. To use custom quality, set RenderingQuality property to RenderingQuality.Custom.

See Also

RenderingQualitySettings Class