Revit 2013 API
SchemaBuilder Members
SchemaBuilder Class Constructors Methods See Also

The SchemaBuilder type exposes the following members.

Constructors

 | Name | Description
Public method | SchemaBuilder | Initializes a new instance of the SchemaBuilder class

Methods

 | Name | Description
Public method | AcceptableName | Checks whether a string is an acceptable name for a Schema or a Field.
Public method | AddArrayField | Creates a field containing an array of values in the Schema, with given name and type of contained values.
Public method | AddMapField | Creates a field containing an ordered key-value map in the Schema, with given name and type of contained values.
Public method | AddSimpleField | Creates a field containing a single value in the Schema, with given name and type.
Public method | Dispose | Releases all resources used by the SchemaBuilder
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Finish | Registers and returns the created Schema object.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GUIDIsValid | Checks whether the supplied GUID value is valid.
Public method | Ready | Checks whether the builder may be used.
Public method | SetApplicationGUID | Sets the GUID of the application or add-in that may access entities of this Schema under the Application acess level.
Public method | SetDocumentation | Sets the documentation string for the Schema.
Public method | SetReadAccessLevel | Sets top level read access (for entities)
Public method | SetSchemaName | Sets the name of the Schema.
Public method | SetVendorId | Sets the id of the third-party vendor that may access entities of this Schema under the Vendor acess level, and to generally identify the owner of this Schema.
Public method | SetWriteAccessLevel | Sets top level write access (for entities)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | VendorIdIsValid | Checks whether the supplied vendor id string is valid.

See Also

SchemaBuilder Class
Autodesk.Revit.DB.ExtensibleStorage Namespace