Revit 2013 API
EnergyDataSettings..::..CheckServiceType Method
EnergyDataSettings Class See Also
Checks that the service type falls within an appropriate range.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static bool CheckServiceType(
    gbXMLServiceType serviceType
)
Visual Basic
Public Shared Function CheckServiceType ( _
    serviceType As gbXMLServiceType _
) As Boolean
Visual C++
public:
static bool CheckServiceType(
    gbXMLServiceType serviceType
)

Parameters

serviceType
Type: Autodesk.Revit.DB.Analysis..::..gbXMLServiceType
The service type to be checked.

Return Value

True if the service type falls within an appropriate range, false otherwise.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace