Revit 2013 API
AdaptiveComponentInstanceUtils..::..SetInstanceFlipped Method
AdaptiveComponentInstanceUtils Class See Also
Sets the value of the flip parameter on the adaptive instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static void SetInstanceFlipped(
    FamilyInstance famInst,
    bool flip
)
Visual Basic
Public Shared Sub SetInstanceFlipped ( _
    famInst As FamilyInstance, _
    flip As Boolean _
)
Visual C++
public:
static void SetInstanceFlipped(
    FamilyInstance^ famInst,
    bool flip
)

Parameters

famInst
Type: Autodesk.Revit.DB..::..FamilyInstance
The FamilyInstance
flip
Type: System..::..Boolean
The flip flag

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The FamilyInstance famInst is not an Adaptive Family Instance. -or- The FamilyInstance famInst does not have an Adaptive Family Symbol. -or- The FamilyInstance famInst cannot be flipped or unflipped.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation failed.

See Also

AdaptiveComponentInstanceUtils Class