Revit 2013 API
ExtrusionAnalyzer..::..Create Method
ExtrusionAnalyzer Class See Also
Creates an ExtrusionAnalyzer and computes and stores the solid's shadow.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static ExtrusionAnalyzer Create(
    Solid solidGeometry,
    Plane plane,
    XYZ direction
)
Visual Basic
Public Shared Function Create ( _
    solidGeometry As Solid, _
    plane As Plane, _
    direction As XYZ _
) As ExtrusionAnalyzer
Visual C++
public:
static ExtrusionAnalyzer^ Create(
    Solid^ solidGeometry,
    Plane^ plane,
    XYZ^ direction
)

Parameters

solidGeometry
Type: Autodesk.Revit.DB..::..Solid
The geometry to analyze.
plane
Type: Autodesk.Revit.DB..::..Plane
The plane to use for the base plane for the extrusion.
direction
Type: Autodesk.Revit.DB..::..XYZ
The direction to use for the calculation for the extrusion.

Return Value

The newly created ExtrusionAnalyzer object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input direction must be transverse to the input plane.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | A failure occurred in creating the ExtrusionAnalyzer or computing the solid's shadow.

See Also

ExtrusionAnalyzer Class