Revit 2013 API
FailureDefinition..::..SetDefaultResolutionType Method
FailureDefinition Class See Also
Sets the default resolution type for the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FailureDefinition SetDefaultResolutionType(
    FailureResolutionType type
)
Visual Basic
Public Function SetDefaultResolutionType ( _
    type As FailureResolutionType _
) As FailureDefinition
Visual C++
public:
FailureDefinition^ SetDefaultResolutionType(
    FailureResolutionType type
)

Parameters

type
Type: Autodesk.Revit.DB..::..FailureResolutionType
The type of resolution to be used as default.

Return Value

The FailureDefinition.

Remarks

If failure has multiple resolutions, one of them is designated as designated as the default resolution. The default resolution is used by Revit failure processing mechanism to resolve failures automatically when applicable.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Resolution of the type is not applicable to the failure.
Autodesk.Revit.Exceptions..::..InvalidOperationException | FailureDefinition does not have any resolutions.

See Also

FailureDefinition Class