Revit 2013 API
TabbedDialogExtension Members
TabbedDialogExtension Class Constructors Methods Properties See Also

The TabbedDialogExtension type exposes the following members.

Constructors

 | Name | Description
Public method | TabbedDialogExtension | Constructs a extension instance with a control and ok action handler.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetContextualHelp | Gets the contextual help.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetContextualHelp | Sets the contextual help.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Control | The control.
Public property | OnCancelAction | The cancel handler.
Public property | OnOKAction | The ok handler.
Public property | OnRestoreDefaultsAction | The restore defaults handler.

See Also

TabbedDialogExtension Class
Autodesk.Revit.UI Namespace