Revit 2013 API
FillPattern Constructor (String, FillPatternTarget, FillPatternHostOrientation)
FillPattern Class See Also
Creates a fill pattern based on the given name, FillPatternTarget and FillPatternHostOrientation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FillPattern(
    string name,
    FillPatternTarget target,
    FillPatternHostOrientation orientation
)
Visual Basic
Public Sub New ( _
    name As String, _
    target As FillPatternTarget, _
    orientation As FillPatternHostOrientation _
)
Visual C++
public:
FillPattern(
    String^ name,
    FillPatternTarget target,
    FillPatternHostOrientation orientation
)

Parameters

name
Type: System..::..String
The name.
target
Type: Autodesk.Revit.DB..::..FillPatternTarget
The fill pattern target.
orientation
Type: Autodesk.Revit.DB..::..FillPatternHostOrientation
The fill pattern orientation.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FillPattern Class
FillPattern Overload