Revit 2013 API
SkyBackgroundSettings..::..VisibilityDistance Property
SkyBackgroundSettings Class See Also
The visibility distance of sky background.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public float VisibilityDistance { get; set; }
Visual Basic
Public Property VisibilityDistance As Single
    Get
    Set
Visual C++
public:
property float VisibilityDistance {
    float get ();
    void set (float value);
}

Remarks

Modify this value to control the haziness.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The value of visibility distance is not valid. The valid range is 0 to 500.

See Also

SkyBackgroundSettings Class