Revit 2013 API
ModelCurveArray..::..Insert Method
ModelCurveArray Class See Also
Insert the specified model curve into the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Insert(
    ModelCurve item,
    int index
)
Visual Basic
Public Overridable Sub Insert ( _
    item As ModelCurve, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    ModelCurve^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::..ModelCurve
The model curve to be inserted into the array.
index
Type: System..::..Int32
The model curve will be inserted before this index.

Return Value

Returns whether the model curve was inserted into the array.

See Also

ModelCurveArray Class