Revit 2013 API
MechanicalUtils..::..ConnectDuctPlaceholdersAtCross Method (Document, ElementId, ElementId)
MechanicalUtils Class See Also
Connects placeholders that looks like Cross connection.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static bool ConnectDuctPlaceholdersAtCross(
    Document document,
    ElementId placeholder1Id,
    ElementId placeholder2Id
)
Visual Basic
Public Shared Function ConnectDuctPlaceholdersAtCross ( _
    document As Document, _
    placeholder1Id As ElementId, _
    placeholder2Id As ElementId _
) As Boolean
Visual C++
public:
static bool ConnectDuctPlaceholdersAtCross(
    Document^ document,
    ElementId^ placeholder1Id,
    ElementId^ placeholder2Id
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
placeholder1Id
Type: Autodesk.Revit.DB..::..ElementId
The first element Id of duct placeholder.
placeholder2Id
Type: Autodesk.Revit.DB..::..ElementId
The second element Id of duct placeholder.

Return Value

True if connection succeeds, false otherwise.

Remarks

The placeholders must intersect each other. If connection succeeds, a new placeholder is created. If connection fails, the placeholders cannot be physically connected.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The element id placeholder1Id is not duct placeholder. -or- The element id placeholder2Id is not duct placeholder. -or- The elements belong to different types of system.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

MechanicalUtils Class
ConnectDuctPlaceholdersAtCross Overload
Autodesk.Revit.DB.Mechanical Namespace