Revit 2013 API
CircleLightShape Members
CircleLightShape Class Constructors Methods Properties See Also

The CircleLightShape type exposes the following members.

Constructors

 | Name | Description
Public method | CircleLightShape()()()() | Creates a circle light shape object with 2.0' emit diameter.
Public method | CircleLightShape(Double) | Creates a circle light shape object with the given emit diameter.
Public method | CircleLightShape(CircleLightShape) | Creates a copy of the given circle light shape

Methods

 | Name | Description
Public method | Clone | Creates a copy of the LightShape derived object. (Inherited from LightShape.)
Public method | Dispose | (Inherited from LightShape.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | EmitDiameter | The emit diameter.

See Also

CircleLightShape Class
Autodesk.Revit.DB.Lighting Namespace