Revit 2013 API
Document..::..NewAreaLoad Method (Element, XYZ, Boolean, AreaLoadType)
Document Class See Also
Creates a new uniform hosted area load with polygonal shape within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public AreaLoad NewAreaLoad(
    Element host,
    XYZ force,
    bool isReaction,
    AreaLoadType symbol
)
Visual Basic
Public Function NewAreaLoad ( _
    host As Element, _
    force As XYZ, _
    isReaction As Boolean, _
    symbol As AreaLoadType _
) As AreaLoad
Visual C++
public:
AreaLoad^ NewAreaLoad(
    Element^ host,
    XYZ^ force,
    bool isReaction,
    AreaLoadType^ symbol
)

Parameters

host
Type: Autodesk.Revit.DB..::..Element
The host element (Floor or Wall) of the AreaLoad application.
force
Type: Autodesk.Revit.DB..::..XYZ
The 3d area force applied to the first reference point.
isReaction
Type: System..::..Boolean
Specifies if the load is a reaction load. The load cannot be modified if isReaction=True.
symbol
Type: Autodesk.Revit.DB.Structure..::..AreaLoadType
The symbol of the AreaLoad.

Return Value

If successful, NewAreaLoad returns an object for the newly created AreaLoad. nullNothingnullptra null reference (Nothing in Visual Basic) is returned if the operation fails.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | If the product is not Revit Structure.

See Also

Document Class
NewAreaLoad Overload
Autodesk.Revit.Creation Namespace