Revit 2013 API
SolidSolidCutUtils Members
SolidSolidCutUtils Class Methods See Also

The SolidSolidCutUtils type exposes the following members.

Methods

 | Name | Description
 | AddCutBetweenSolids(Document, Element, Element) | Adds a solid-solid cut for the two elements.
 | AddCutBetweenSolids(Document, Element, Element, Boolean) | Adds a solid-solid cut for the two elements with the option to control splitting of faces of the cutting solid.
 | CanElementCutElement | Verifies if the cutting element can add a solid cut to the target element.
 | CutExistsBetweenElements | Checks that if there is a solid-solid cut between two elements.
Public method | Dispose | Releases all resources used by the SolidSolidCutUtils
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetCuttingSolids | Gets all the solids which cut the input element.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetSolidsBeingCut | Get all the solids which are cut by the input element.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsAllowedForSolidCut | Validates that the element is eligible for a solid-solid cut.
 | IsElementFromAppropriateContext | Validates that the element is from an appropriate document.
 | RemoveCutBetweenSolids | Removes the solid-solid cut between the two elements if it exists.
 | SplitFacesOfCuttingSolid | Causes the faces of the cutting element where it intersects the element it is cutting to be split or unsplit.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SolidSolidCutUtils Class