Revit 2013 API
TaskDialog..::..Show Method
TaskDialog Class See Also
Shows the task dialog.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public TaskDialogResult Show()
Visual Basic
Public Function Show As TaskDialogResult
Visual C++
public:
TaskDialogResult Show()

Return Value

The user's response to the task dialog.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the task dialog is shown out of main thread of Revit.

See Also

TaskDialog Class
Show Overload
Autodesk.Revit.UI Namespace