Revit 2013 API
ParameterFilterUtilities Members
ParameterFilterUtilities Class Methods See Also

The ParameterFilterUtilities type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ParameterFilterUtilities
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetAllFilterableCategories | Returns the set of categories that may be used in a ParameterFilterElement.
 | GetFilterableParametersInCommon | Returns the filterable parameters common to the given categories.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetInapplicableParameters | Returns the parameters that are not among the set of filterable parameters common to the given categories.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsParameterApplicable | Used to determine whether the element supports the given parameter.
 | RemoveUnfilterableCategories | Removes from the given set the categories that are not filterable.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ParameterFilterUtilities Class