Revit 2013 API
EnergyDataSettings..::..CheckBuildingConstructionClass Method
EnergyDataSettings Class See Also
Checks that the building construction class falls within an appropriate range.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static bool CheckBuildingConstructionClass(
    HVACLoadConstructionClass buildingConstructionClass
)
Visual Basic
Public Shared Function CheckBuildingConstructionClass ( _
    buildingConstructionClass As HVACLoadConstructionClass _
) As Boolean
Visual C++
public:
static bool CheckBuildingConstructionClass(
    HVACLoadConstructionClass buildingConstructionClass
)

Parameters

buildingConstructionClass
Type: Autodesk.Revit.DB.Analysis..::..HVACLoadConstructionClass
The building construction class to be checked.

Return Value

True if the building construction class falls within an appropriate range, false otherwise.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace