Revit 2013 API
ExternalFileUtils..::..GetExternalFileReference Method
ExternalFileUtils Class See Also
Gets the external file referencing data for the given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static ExternalFileReference GetExternalFileReference(
    Document aDoc,
    ElementId elemId
)
Visual Basic
Public Shared Function GetExternalFileReference ( _
    aDoc As Document, _
    elemId As ElementId _
) As ExternalFileReference
Visual C++
public:
static ExternalFileReference^ GetExternalFileReference(
    Document^ aDoc,
    ElementId^ elemId
)

Parameters

aDoc
Type: Autodesk.Revit.DB..::..Document
A Revit Document.
elemId
Type: Autodesk.Revit.DB..::..ElementId
The element whose external file reference we want.

Return Value

An object containing path and type information for the given element's external file.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The element elemId does not exist in the document -or- elemId does not represent an external file reference.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExternalFileUtils Class