Revit 2013 API
Rebar..::..RebarShapeMatchesCurvesAndHooks Method
Rebar Class See Also
Checks if rebarShape matches curves and hooks.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static bool RebarShapeMatchesCurvesAndHooks(
    RebarShape rebarShape,
    RebarBarType barType,
    XYZ norm,
    IList<Curve> curves,
    RebarHookType startHook,
    RebarHookType endHook,
    RebarHookOrientation startHookOrient,
    RebarHookOrientation endHookOrient
)
Visual Basic
Public Shared Function RebarShapeMatchesCurvesAndHooks ( _
    rebarShape As RebarShape, _
    barType As RebarBarType, _
    norm As XYZ, _
    curves As IList(Of Curve), _
    startHook As RebarHookType, _
    endHook As RebarHookType, _
    startHookOrient As RebarHookOrientation, _
    endHookOrient As RebarHookOrientation _
) As Boolean
Visual C++
public:
static bool RebarShapeMatchesCurvesAndHooks(
    RebarShape^ rebarShape,
    RebarBarType^ barType,
    XYZ^ norm,
    IList<Curve^>^ curves,
    RebarHookType^ startHook,
    RebarHookType^ endHook,
    RebarHookOrientation startHookOrient,
    RebarHookOrientation endHookOrient
)

Parameters

rebarShape
Type: Autodesk.Revit.DB.Structure..::..RebarShape
A RebarShape element that defines the shape of the rebar.
barType
Type: Autodesk.Revit.DB.Structure..::..RebarBarType
A RebarBarType element that defines bar diameter, bend radius and material of the rebar.
norm
Type: Autodesk.Revit.DB..::..XYZ
The normal to the plane that the rebar curves lie on.
curves
Type: System.Collections.Generic..::..IList<(Of <(<'Curve>)>)>
An array of curves that define the shape of the rebar curves. They must belong to the plane defined by the normal and origin. Bends and hooks should not be included in the array of curves.
startHook
Type: Autodesk.Revit.DB.Structure..::..RebarHookType
A RebarHookType element that defines the hook for the start of the bar. If this parameter is nullNothingnullptra null reference (Nothing in Visual Basic), it means to create a rebar with no hook.
endHook
Type: Autodesk.Revit.DB.Structure..::..RebarHookType
A RebarHookType element that defines the hook for the end of the bar. If this parameter is nullNothingnullptra null reference (Nothing in Visual Basic), it means to create a rebar with no hook.
startHookOrient
Type: Autodesk.Revit.DB.Structure..::..RebarHookOrientation
Defines the orientation of the hook plane at the start of the rebar with respect to the orientation of the first curve and the plane normal. Only two values are permitted: Value = Right: The hook is on your right as you stand at the end of the bar, with the bar behind you, taking the bar's normal as "up." Value = Left: The hook is on your left as you stand at the end of the bar, with the bar behind you, taking the bar's normal as "up."
endHookOrient
Type: Autodesk.Revit.DB.Structure..::..RebarHookOrientation
Defines the orientation of the hook plane at the end of the rebar with respect to the orientation of the last curve and the plane normal. Only two values are permitted: Value = Right: The hook is on your right as you stand at the end of the bar, with the bar behind you, taking the bar's normal as "up." Value = Left: The hook is on your left as you stand at the end of the bar, with the bar behind you, taking the bar's normal as "up."

Return Value

True if rebarShape matches curves and hooks.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | curves is empty. -or- curves contains a curve that is neither a line nor an arc. -or- curves do not form a valid CurveLoop. -or- The input curves contains at least one helical curve and is not supported for this operation.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | norm has zero length.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace