Revit 2013 API
Form..::..ScaleSubElement Method
Form Class See Also
Scale a face/edge/curve/vertex of the form, by a specified origin and scale factor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void ScaleSubElement(
    Reference subElementReference,
    double factor,
    XYZ origin
)
Visual Basic
Public Sub ScaleSubElement ( _
    subElementReference As Reference, _
    factor As Double, _
    origin As XYZ _
)
Visual C++
public:
void ScaleSubElement(
    Reference^ subElementReference,
    double factor,
    XYZ^ origin
)

Parameters

subElementReference
Type: Autodesk.Revit.DB..::..Reference
The geometry reference of face/edge/curve/vertex
factor
Type: System..::..Double
The scale factor, it should be large than zero.
origin
Type: Autodesk.Revit.DB..::..XYZ
The origin where scale happens.

See Also

Form Class