Revit 2013 API
ElementQuickFilter Class
Members See Also
A base class for a type of filter that operates on element records.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class ElementQuickFilter : ElementFilter
Visual Basic
Public Class ElementQuickFilter _
    Inherits ElementFilter
Visual C++
public ref class ElementQuickFilter : public ElementFilter

Remarks

Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementQuickFilter
Autodesk.Revit.DB..::..BoundingBoxContainsPointFilter
Autodesk.Revit.DB..::..BoundingBoxIntersectsFilter
Autodesk.Revit.DB..::..BoundingBoxIsInsideFilter
Autodesk.Revit.DB..::..ElementCategoryFilter
Autodesk.Revit.DB..::..ElementClassFilter
Autodesk.Revit.DB..::..ElementDesignOptionFilter
Autodesk.Revit.DB..::..ElementIsCurveDrivenFilter
Autodesk.Revit.DB..::..ElementIsElementTypeFilter
Autodesk.Revit.DB..::..ElementMulticategoryFilter
Autodesk.Revit.DB..::..ElementMulticlassFilter
Autodesk.Revit.DB..::..ElementOwnerViewFilter
Autodesk.Revit.DB..::..ElementStructuralTypeFilter
Autodesk.Revit.DB..::..ElementWorksetFilter
Autodesk.Revit.DB..::..ExclusionFilter
Autodesk.Revit.DB..::..FamilySymbolFilter

See Also

ElementQuickFilter Members