Revit 2013 API
CompoundStructure..::..CanLayerWidthBeNonZero Method
CompoundStructure Class See Also
Changing the width of an existing layer from zero to a positive value will create a rectangular region.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool CanLayerWidthBeNonZero(
    int layerIdx
)
Visual Basic
Public Function CanLayerWidthBeNonZero ( _
    layerIdx As Integer _
) As Boolean
Visual C++
public:
bool CanLayerWidthBeNonZero(
    int layerIdx
)

Parameters

layerIdx
Type: System..::..Int32
The index of a CompoundStructureLayer.

Remarks

This is only allowed if there is a vertical line such that all regions to the left are assigned to layers with index < layerIdx, and all regions to the right are assigned to layers with index > layerIdx.

See Also

CompoundStructure Class