Revit 2013 API
RoutingPreferenceManager..::..RemoveRule Method
RoutingPreferenceManager Class See Also
Removes an existing routing preference rule. Thrown if the index is out of bounds.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void RemoveRule(
    RoutingPreferenceRuleGroupType groupType,
    int index
)
Visual Basic
Public Sub RemoveRule ( _
    groupType As RoutingPreferenceRuleGroupType, _
    index As Integer _
)
Visual C++
public:
void RemoveRule(
    RoutingPreferenceRuleGroupType groupType,
    int index
)

Parameters

groupType
Type: Autodesk.Revit.DB..::..RoutingPreferenceRuleGroupType
The routing preference group type in which the rule should be removed.
index
Type: System..::..Int32
The index position of removed routing preference rule in the group.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | index is not a valid zero-based index within groupType. -or-
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Mechanical Electrical Piping.

See Also

RoutingPreferenceManager Class