Revit 2013 API
RoutingPreferenceManager Class
Members See Also
Manages default pipe segments, fittings, and selection criteria for a given MEPCurveType Default constructor. Default destructor

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class RoutingPreferenceManager : IDisposable
Visual Basic
Public Class RoutingPreferenceManager _
    Implements IDisposable
Visual C++
public ref class RoutingPreferenceManager : IDisposable

Remarks

MEPCurveTypes contain a RoutingPreferenceManager property. The RoutingPreferenceManager contains rules for selecting segment types and sizes as well as fitting types based on user selection criteria.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..RoutingPreferenceManager

See Also

RoutingPreferenceManager Members