Revit 2013 API
DuctSizeSettings Members
DuctSizeSettings Class Methods Properties See Also

The DuctSizeSettings type exposes the following members.

Methods

 | Name | Description
Public method | AddSize | Inserts a new MEPSize in to the duct size settings. The duct shape determines the location of the new size in the size table.
Public method | Dispose | Releases all resources used by the DuctSizeSettings
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetDuctSizeSettingIterator | Returns a DuctSizeSettingIterator object that iterates through the collection.
 | GetDuctSizeSettings | Get the duct size settings of the project.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSizeCount | Get the size count of the duct size table. The duct shape determines the location of the size in the size table.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RemoveSize | Erase the existing MEPSize with this nominal diameter. The duct shape determines the location of the size in the size table.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Item | Get the DuctSizes for this DuctShape.

See Also

DuctSizeSettings Class
Autodesk.Revit.DB.Mechanical Namespace