Revit 2013 API
ScheduleDefinition..::..SetFilter Method
ScheduleDefinition Class See Also
Replaces a filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetFilter(
    int index,
    ScheduleFilter filter
)
Visual Basic
Public Sub SetFilter ( _
    index As Integer, _
    filter As ScheduleFilter _
)
Visual C++
public:
void SetFilter(
    int index,
    ScheduleFilter^ filter
)

Parameters

index
Type: System..::..Int32
The index of the filter to replace.
filter
Type: Autodesk.Revit.DB..::..ScheduleFilter
The new filter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The field ID is not the ID of a field in this ScheduleDefinition. -or- The field and filter type cannot be used to filter this ScheduleDefinition. -or- The filter value is not valid for the field and filter type.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | index is not a valid filter index.
Autodesk.Revit.Exceptions..::..InvalidOperationException | This ScheduleDefinition does not support filters.

See Also

ScheduleDefinition Class