Revit 2013 API
RebarHostData..::..IsFaceExposed Method
RebarHostData Class See Also
Checks whether the specified face is considered exposed, and therefore has an associated CoverType.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool IsFaceExposed(
    Reference face
)
Visual Basic
Public Function IsFaceExposed ( _
    face As Reference _
) As Boolean
Visual C++
public:
bool IsFaceExposed(
    Reference^ face
)

Parameters

face
Type: Autodesk.Revit.DB..::..Reference

Return Value

True if %face% is exposed, false otherwise.

Remarks

This method replaces the method HasCoverTypeForReference() from the 2011 Revit API.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

RebarHostData Class
Autodesk.Revit.DB.Structure Namespace