Revit 2013 API
AnalyticalModelSweptProfile..::..GetDrivingCurve Method
AnalyticalModelSweptProfile Class See Also
Provides access to the curve that dictates the path of the swept profile.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public Curve GetDrivingCurve()
Visual Basic
Public Function GetDrivingCurve As Curve
Visual C++
public:
Curve^ GetDrivingCurve()

Return Value

A curve that defines the path of the swept profile.

Remarks

The profile may not be swept the entire length of this curve. One should check the set back properties on this object to locate how far the actual sweep is from the ends of the curve.

See Also

AnalyticalModelSweptProfile Class
Autodesk.Revit.DB.Structure Namespace