Revit 2013 API
MechanicalUtils Methods
MechanicalUtils Class See Also

The MechanicalUtils type exposes the following members.

Methods

 | Name | Description
 | ConnectDuctPlaceholdersAtCross(Document, ElementId, ElementId) | Connects placeholders that looks like Cross connection.
 | ConnectDuctPlaceholdersAtCross(Document, ElementId, ElementId, ElementId) | Connects placeholders that looks like Cross connection.
 | ConnectDuctPlaceholdersAtCross(Document, Connector, Connector, Connector, Connector) | Connects placeholders that looks like Cross connection.
 | ConnectDuctPlaceholdersAtElbow(Document, Connector, Connector) | Connects placeholders that looks like elbow connection.
 | ConnectDuctPlaceholdersAtElbow(Document, ElementId, ElementId) | Connects placeholders that looks like elbow connection.
 | ConnectDuctPlaceholdersAtTee(Document, ElementId, ElementId) | Connects two placeholders that looks like Tee connection.
 | ConnectDuctPlaceholdersAtTee(Document, Connector, Connector, Connector) | Connects three placeholders that looks like Tee connection.
 | ConvertDuctPlaceholders | Converts a collection of duct placeholder elements into duct elements.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MechanicalUtils Class
Autodesk.Revit.DB.Mechanical Namespace