Revit 2013 API
DuctSizeSettings..::..GetEnumerator Method
DuctSizeSettings Class See Also
Returns an enumerator that iterates through the collection.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator<KeyValuePair<DuctShape, DuctSizes>> GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator(Of KeyValuePair(Of DuctShape, DuctSizes))
Visual C++
public:
virtual IEnumerator<KeyValuePair<DuctShape, DuctSizes^>>^ GetEnumerator()

Return Value

An IEnumerator( KeyValuePair(DuctShape::Enum^,DuctSizes^) ) object that can be used to iterate through key-value pairs in the collection.

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

See Also

DuctSizeSettings Class
Autodesk.Revit.DB.Mechanical Namespace