Revit 2013 API
HostObject Class
Members See Also
A base class that provides support for all objects that can host other objects, such as walls roofs, and floors.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class HostObject : Element
Visual Basic
Public Class HostObject _
    Inherits Element
Visual C++
public ref class HostObject : public Element

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..HostObject
Autodesk.Revit.DB..::..CeilingAndFloor
Autodesk.Revit.DB..::..ContFooting
Autodesk.Revit.DB..::..CurtainGridLine
Autodesk.Revit.DB..::..CurtainSystemBase
Autodesk.Revit.DB.Electrical..::..Wire
Autodesk.Revit.DB..::..FaceWall
Autodesk.Revit.DB..::..HostedSweep
Autodesk.Revit.DB..::..MEPCurve
Autodesk.Revit.DB..::..RoofBase
Autodesk.Revit.DB..::..Wall
Autodesk.Revit.DB..::..WallSweep

See Also

HostObject Members