Revit 2013 API
RebarShapeConstraintSegmentLength Members
RebarShapeConstraintSegmentLength Class Constructors Methods See Also

The RebarShapeConstraintSegmentLength type exposes the following members.

Constructors

 | Name | Description
Public method | RebarShapeConstraintSegmentLength | Create a segment length constraint.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RebarShapeConstraint.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetParamId | Return the Id of the parameter associated with this constraint. (Inherited from RebarShapeConstraint.)
Public method | GetSegmentEndReferenceType | Choice of two possibilities for the start and end references of the length constraint.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarShapeConstraintSegmentLength Class
Autodesk.Revit.DB.Structure Namespace