Revit 2013 API
StairsEditScope Members
StairsEditScope Class Constructors Methods Properties See Also

The StairsEditScope type exposes the following members.

Constructors

 | Name | Description
Public method | StairsEditScope | Instantiates a StairsEditScope object.

Methods

 | Name | Description
Public method | Cancel | Cancels editing for the stairs.
Public method | Commit | Finishes editing for the stairs.
Public method | Dispose | Releases all resources used by the StairsEditScope
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Start(ElementId) | Starts an stairs edit mode for an existing Stairs element
Public method | Start(ElementId, ElementId) | Creates a new empty stairs element with a default stairs type in the specified levels and then starts stairs edit mode and editing the new stairs.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsActive | Tells if the StairsEditScope is active. In other word, the StairsEditScope has started but not committed/canceled yet.
Public property | IsPermitted | Tells if the StairsEditScope is permitted to start.

See Also

StairsEditScope Class