Revit 2013 API
ElementParameterFilter Class
Members Example See Also
A filter used to match elements by one or more parameter filter rules.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class ElementParameterFilter : ElementSlowFilter
Visual Basic
Public Class ElementParameterFilter _
    Inherits ElementSlowFilter
Visual C++
public ref class ElementParameterFilter : public ElementSlowFilter

Remarks

This filter is a slow filter. Slow filters require that the Element be obtained and expanded in memory first. Thus it is preferable to couple this filter with at least one ElementQuickFilter, which should minimize the number of Elements that are expanded.

Examples

CopyC#
// Creates an ElementParameter filter to find rooms whose area is
// greater than specified value
// Create filter by provider and evaluator
// provider
ParameterValueProvider pvp = new ParameterValueProvider(new ElementId(BuiltInParameter.ROOM_AREA));
// evaluator
FilterNumericRuleEvaluator fnrv = new FilterNumericGreater();
// rule value
double ruleValue = 100.0f; // filter room whose area is greater than 100 SF
// rule
FilterRule fRule = new FilterDoubleRule(pvp, fnrv, ruleValue, 1E-6);

// Create an ElementParameter filter
ElementParameterFilter filter = new ElementParameterFilter(fRule);

// Apply the filter to the elements in the active document
FilteredElementCollector collector = new FilteredElementCollector(document);
IList<Element> rooms = collector.WherePasses(filter).ToElements();

// Find rooms whose area is less than or equal to 100:
// Use inverted filter to match elements
ElementParameterFilter lessOrEqualFilter = new ElementParameterFilter(fRule, true);
collector = new FilteredElementCollector(document);
IList<Element> lessOrEqualFounds = collector.WherePasses(lessOrEqualFilter).ToElements();
CopyVB.NET
' Creates an ElementParameter filter to find rooms whose area is
' greater than specified value
' Create filter by provider and evaluator
Dim areaParam As BuiltInParameter = BuiltInParameter.ROOM_AREA
' provider
Dim pvp As New ParameterValueProvider(New ElementId(DirectCast(areaParam, Integer)))
' evaluator
Dim fnrv As FilterNumericRuleEvaluator = New FilterNumericGreater()
' rule value
Dim ruleValue As Double = 100.0F
' filter room whose area is greater than 100 SF
' rule
Dim fRule As FilterRule = New FilterDoubleRule(pvp, fnrv, ruleValue, 0.000001)

' Create an ElementParameter filter
Dim filter As New ElementParameterFilter(fRule)

' Apply the filter to the elements in the active document
Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(document)
Dim rooms As IList(Of Autodesk.Revit.DB.Element) = collector.WherePasses(filter).ToElements()

' Find rooms whose area is less than or equal to 100:
' Use inverted filter to match elements
Dim lessOrEqualFilter As New ElementParameterFilter(fRule, True)
collector = New Autodesk.Revit.DB.FilteredElementCollector(document)
Dim lessOrEqualFounds As IList(Of Autodesk.Revit.DB.Element) = collector.WherePasses(lessOrEqualFilter).ToElements()

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementSlowFilter
Autodesk.Revit.DB..::..ElementParameterFilter

See Also

ElementParameterFilter Members