Revit 2013 API
AnalyticalModelSketchComponent..::..SetAnalyticalAlignmentMethod Method
AnalyticalModelSketchComponent Class See Also
Sets the Alignment Method to the supplied Analytical Alignment Method

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void SetAnalyticalAlignmentMethod(
    AnalyticalAlignmentMethod alignmentMethod
)
Visual Basic
Public Sub SetAnalyticalAlignmentMethod ( _
    alignmentMethod As AnalyticalAlignmentMethod _
)
Visual C++
public:
void SetAnalyticalAlignmentMethod(
    AnalyticalAlignmentMethod alignmentMethod
)

Parameters

alignmentMethod
Type: Autodesk.Revit.DB.Structure..::..AnalyticalAlignmentMethod
Analytical Alignment Method which the Analytical Model should use for alignment.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | alignmentMethod is not valid for this Sketch component.

See Also

AnalyticalModelSketchComponent Class
Autodesk.Revit.DB.Structure Namespace