Revit 2013 API
SpotDimension Properties
SpotDimension Class See Also

The SpotDimension type exposes the following members.

Properties

 | Name | Description
Public property | Above | The text shown above the segment's value. (Inherited from Dimension.)
Public property | AreSegmentsEqual | Indicates if all segments are forced to be equal. (Inherited from Dimension.)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | Below | The text shown below the segment's value. (Inherited from Dimension.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | Curve | A curve that represents the dimension line. (Inherited from Dimension.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | DimensionShape | The shape of this dimension. (Inherited from Dimension.)
Public property | DimensionType | The dimension style of this dimension. (Inherited from Dimension.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsLocked | Indicates if this dimension is locked. (Inherited from Dimension.)
Public property | Label | The family parameter label of the dimension. (Inherited from Dimension.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | Get a location point object. This is the location of the spot dimension. (Overrides Element..::..Location.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Retrieves or changes the name associated with the Dimension. (Inherited from Dimension.)
Public property | NumberOfSegments | The number of segments for the dimension. (Inherited from Dimension.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Prefix | The text shown before the segment's value. (Inherited from Dimension.)
Public property | References | Returns an array of geometric references to which the dimension is attached. (Inherited from Dimension.)
Public property | Segments | The segments in the dimension. (Inherited from Dimension.)
Public property | SpotDimensionType | The dimension style of this dimension.
Public property | Suffix | The text shown after the segment's value. (Inherited from Dimension.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | Value | The value of the dimension. (Inherited from Dimension.)
Public property | ValueOverride | The text that replaces the segment's value. (Inherited from Dimension.)
Public property | ValueString | The dimension value as a user visible string. (Inherited from Dimension.)
Public property | View | Supplies the view that contains the dimension if the dimension is view specific. (Inherited from Dimension.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

SpotDimension Class