Revit 2013 API
ExporterIFCUtils..::..IsWallBaseRectangular Method
ExporterIFCUtils Class See Also
Identifies if the wall's base can be represented by a direct thickening of the wall's base curve.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static bool IsWallBaseRectangular(
    Wall wall,
    Curve curve
)
Visual Basic
Public Shared Function IsWallBaseRectangular ( _
    wall As Wall, _
    curve As Curve _
) As Boolean
Visual C++
public:
static bool IsWallBaseRectangular(
    Wall^ wall,
    Curve^ curve
)

Parameters

wall
Type: Autodesk.Revit.DB..::..Wall
The wall.
curve
Type: Autodesk.Revit.DB..::..Curve
The wall's base curve.

Return Value

True if the wall's base can be represented by a direct thickening of the wall's base curve. False is the wall's base shape is affected by other geometry, and thus cannot be represented by a direct thickening of the wall's base cure.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input curve points to a helical curve and is not supported for this operation.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace