Revit 2013 API
ConceptualConstructionType..::..GetAllConceptualConstructionsForCategory Method
ConceptualConstructionType Class See Also
Get all the ids of constructions applicable to the input massSubCategory

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static ICollection<ElementId> GetAllConceptualConstructionsForCategory(
    Document ccda,
    ElementId massSubCategoryId
)
Visual Basic
Public Shared Function GetAllConceptualConstructionsForCategory ( _
    ccda As Document, _
    massSubCategoryId As ElementId _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ GetAllConceptualConstructionsForCategory(
    Document^ ccda,
    ElementId^ massSubCategoryId
)

Parameters

ccda
Type: Autodesk.Revit.DB..::..Document
The document.
massSubCategoryId
Type: Autodesk.Revit.DB..::..ElementId
The ElementId of the mass subcategory.

Return Value

Returns a set of ElementIds that for the ConceptualConstructionTypes that are appropriate for the subcategory.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The mass sub-category is none of the OST_MassInteriorWall, OST_MassExteriorWall, OST_MassExteriorWallUnderground, OST_MassWallsAll, OST_MassRoof, OST_MassFloor, OST_MassSlab, OST_MassFloorsAll, OST_MassShade, OST_MassWindow, OST_MassSkylights, OST_MassGlazingAll or OST_MassOpening.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ConceptualConstructionType Class
Autodesk.Revit.DB.Analysis Namespace