Revit 2013 API
PipeSegment Class
Members See Also
The PipeSegment class represents an instance of pipe segment which has the design data for routing preference. Default constructor Default destructor

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class PipeSegment : Segment
Visual Basic
Public Class PipeSegment _
    Inherits Segment
Visual C++
public ref class PipeSegment : public Segment

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..Segment
Autodesk.Revit.DB.Plumbing..::..PipeSegment

See Also

PipeSegment Members
Autodesk.Revit.DB.Plumbing Namespace