Revit 2013 API
Face..::..GetRegions Method
Face Class See Also
Face regions (created with the Split Face command) of the face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public IList<Face> GetRegions()
Visual Basic
Public Function GetRegions As IList(Of Face)
Visual C++
public:
IList<Face^>^ GetRegions()

Return Value

A list of faces, one for the main face of the object hosting the Split Face (such as wall of floor) and one face for each Split Face regions.

Remarks

Use the FaceSplitter Class to filter and find these faces by type.

See Also

Face Class