Revit 2013 API
ElementPhaseStatusFilter Constructor (ElementId, ElementOnPhaseStatus, Boolean)
ElementPhaseStatusFilter Class See Also
Constructs a new instance of a file to match elements that have a given phase status on the input phase, with the option to match all elements that have a phase status other than the input status.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementPhaseStatusFilter(
    ElementId phaseId,
    ElementOnPhaseStatus phaseStatus,
    bool inverted
)
Visual Basic
Public Sub New ( _
    phaseId As ElementId, _
    phaseStatus As ElementOnPhaseStatus, _
    inverted As Boolean _
)
Visual C++
public:
ElementPhaseStatusFilter(
    ElementId^ phaseId,
    ElementOnPhaseStatus phaseStatus,
    bool inverted
)

Parameters

phaseId
Type: Autodesk.Revit.DB..::..ElementId
Id of the phase.
phaseStatus
Type: Autodesk.Revit.DB..::..ElementOnPhaseStatus
Target status.
inverted
Type: System..::..Boolean
True to match all phase statuses other than the input status.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ElementPhaseStatusFilter Class
ElementPhaseStatusFilter Overload