Revit 2013 API
AnalyticalModelSelector Constructor (Curve, AnalyticalCurveSelector)
AnalyticalModelSelector Class See Also
Creates a selector based on one portion of a specific analytical curve.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public AnalyticalModelSelector(
    Curve curve,
    AnalyticalCurveSelector inCurveSelector
)
Visual Basic
Public Sub New ( _
    curve As Curve, _
    inCurveSelector As AnalyticalCurveSelector _
)
Visual C++
public:
AnalyticalModelSelector(
    Curve^ curve,
    AnalyticalCurveSelector inCurveSelector
)

Parameters

curve
Type: Autodesk.Revit.DB..::..Curve
The curve upon which this selector acts.
inCurveSelector
Type: Autodesk.Revit.DB.Structure..::..AnalyticalCurveSelector
Portion of the analytical curve in which the client is interested.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input curve points to a helical curve and is not supported for this operation.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AnalyticalModelSelector Class
AnalyticalModelSelector Overload
Autodesk.Revit.DB.Structure Namespace