Revit 2013 API
ExporterIFC..::..AddBuildingStorey Method
ExporterIFC Class See Also
Adds building storey to the exporter's internal cache.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void AddBuildingStorey(
    ElementId id,
    IFCLevelInfo levelInfo
)
Visual Basic
Public Sub AddBuildingStorey ( _
    id As ElementId, _
    levelInfo As IFCLevelInfo _
)
Visual C++
public:
void AddBuildingStorey(
    ElementId^ id,
    IFCLevelInfo^ levelInfo
)

Parameters

id
Type: Autodesk.Revit.DB..::..ElementId
The level id.
levelInfo
Type: Autodesk.Revit.DB.IFC..::..IFCLevelInfo
The IFCLevelInfo object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace