Revit 2013 API
ScheduleDefinition..::..CanSortByField Method
ScheduleDefinition Class See Also
Checks whether a field can be used for sorting/grouping.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool CanSortByField(
    ScheduleFieldId fieldId
)
Visual Basic
Public Function CanSortByField ( _
    fieldId As ScheduleFieldId _
) As Boolean
Visual C++
public:
bool CanSortByField(
    ScheduleFieldId^ fieldId
)

Parameters

fieldId
Type: Autodesk.Revit.DB..::..ScheduleFieldId
The ID of the field to check.

Return Value

True if the field can be used for sorting/grouping, false otherwise.

Remarks

Schedules cannot be sorted/grouped by the Count field, Percentage fields, or Formula fields that depend on Percentage fields because those types of fields don't have meaningful values until after sorting and grouping takes place.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | fieldId is not the ID of a field in this ScheduleDefinition.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ScheduleDefinition Class