Revit 2013 API
ExporterIFC Class
Members See Also
The main class provided by Revit to allow implementation of IFC export.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class ExporterIFC : IDisposable
Visual Basic
Public Class ExporterIFC _
    Implements IDisposable
Visual C++
public ref class ExporterIFC : IDisposable

Remarks

An instance of this class is provided to clients which implement IExporterIFC in order to provide an implementation for IFC export. It contains information on the options selected by the user for the export operation, as well as members used to access specific types of data needed to implement the export properly.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.IFC..::..ExporterIFC

See Also

ExporterIFC Members
Autodesk.Revit.DB.IFC Namespace