Revit 2013 API
HandRailType..::..SupportNumber Property
HandRailType Class See Also
The number of supports of the handrail.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int SupportNumber { get; set; }
Visual Basic
Public Property SupportNumber As Integer
    Get
    Set
Visual C++
public:
property int SupportNumber {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The supportNumber is a negative value.
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The rail has no support or the support layout is not fixed number so the data being set is not applicable.

See Also

HandRailType Class
Autodesk.Revit.DB.Architecture Namespace