Revit 2013 API
FailureMessage..::..AddResolution Method
FailureMessage Class See Also
Adds a resolution for the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FailureMessage AddResolution(
    FailureResolutionType type,
    FailureResolution resolution
)
Visual Basic
Public Function AddResolution ( _
    type As FailureResolutionType, _
    resolution As FailureResolution _
) As FailureMessage
Visual C++
public:
FailureMessage^ AddResolution(
    FailureResolutionType type,
    FailureResolution^ resolution
)

Parameters

type
Type: Autodesk.Revit.DB..::..FailureResolutionType
The type of the resolution.
resolution
Type: Autodesk.Revit.DB..::..FailureResolution
The resolution.

Return Value

The FailureMessage.

Remarks

Each pair of FailureResolutionType and FailureResolution must have been defined in FailureDefinition, and could only be added once.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | type is not a valid resolution type for this FailureMessage. -or- resolution of type is not valid for this FailureMessage. -or- This FailureMessage already contains a resolution of type type.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailureMessage is already posted to a document

See Also

FailureMessage Class