Revit 2013 API
ElementSlowFilter Class
Members See Also
A base class for a type of filter that operates on expanded elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class ElementSlowFilter : ElementFilter
Visual Basic
Public Class ElementSlowFilter _
    Inherits ElementFilter
Visual C++
public ref class ElementSlowFilter : public ElementFilter

Remarks

Slow filters require that the Element be obtained and expanded in memory first. Thus it is preferable to couple slow filters with at least one ElementQuickFilter, which should minimize the number of Elements that are expanded in order to evaluate against the criteria set by this filter.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementSlowFilter
Autodesk.Revit.DB.Architecture..::..RoomFilter
Autodesk.Revit.DB.Architecture..::..RoomTagFilter
Autodesk.Revit.DB..::..AreaFilter
Autodesk.Revit.DB..::..AreaTagFilter
Autodesk.Revit.DB..::..CurveElementFilter
Autodesk.Revit.DB..::..ElementIntersectsFilter
Autodesk.Revit.DB..::..ElementLevelFilter
Autodesk.Revit.DB..::..ElementParameterFilter
Autodesk.Revit.DB..::..ElementPhaseStatusFilter
Autodesk.Revit.DB..::..FamilyInstanceFilter
Autodesk.Revit.DB.Mechanical..::..SpaceFilter
Autodesk.Revit.DB.Mechanical..::..SpaceTagFilter
Autodesk.Revit.DB..::..PrimaryDesignOptionMemberFilter
Autodesk.Revit.DB.Structure..::..FamilyStructuralMaterialTypeFilter
Autodesk.Revit.DB.Structure..::..StructuralInstanceUsageFilter
Autodesk.Revit.DB.Structure..::..StructuralMaterialTypeFilter
Autodesk.Revit.DB.Structure..::..StructuralWallUsageFilter

See Also

ElementSlowFilter Members