Revit 2013 API
FabricSheetType Members
FabricSheetType Class Methods Properties See Also

The FabricSheetType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidFabricWireType | Verifies that input is ElementId of a FabricWireType
Public method | IsValidMajorLapSplice |
Public method | IsValidMaterial | Verifies that input is ElementId of a Material
Public method | IsValidMinorLapSplice |
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetMajorLayoutAsActualSpacing | Set Major Layout Pattern as Actual Spacing.
Public method | SetMajorLayoutAsFixedNumber | Set Major Layout Pattern as Fixed Number.
Public method | SetMajorLayoutAsMaximumSpacing | Set Major Layout Pattern as Maximum Spacing.
Public method | SetMajorLayoutAsNumberWithSpacing | Set Major Layout Pattern as Number with Spacing.
Public method | SetMinorLayoutAsActualSpacing | Set Minor Layout Pattern as Actual Spacing.
Public method | SetMinorLayoutAsFixedNumber | Set Minor Layout Pattern as Fixed Number.
Public method | SetMinorLayoutAsMaximumSpacing | Set Minor Layout Pattern as Maximum Spacing.
Public method | SetMinorLayoutAsNumberWithSpacing | Set Minor Layout Pattern as Number with Spacing.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | MajorDirectionWireType | Determines which "Fabric Wire" type will be used in the major direction.
Public property | MajorEndOverhang | Determines the distance from the edge of the sheet to the last wire (measured in the major direction).
Public property | MajorLapSpliceLength | Defines the internal snapping for single fabric placement.
Public property | MajorLayoutPattern | Identifies the layout pattern of Fabric Sheet.
Public property | MajorNumberOfWires | Determines the number of wires used in the major direction (includes the 1st and last wires).
Public property | MajorReinforcementArea | Area of fabric divided by the spacing of the wire.
Public property | MajorSpacing | Determines the spacing between the wires (not including the overhangs).
Public property | MajorStartOverhang | Determines the distance from the edge of the sheet to the 1st wire (measured in the major direction).
Public property | Material | Defines wire material ElementId of the Fabric Sheet
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MinorDirectionWireType | Determines which "Fabric Wire" type will be used in the minor direction.
Public property | MinorEndOverhang | Determines the distance from the edge of the sheet to the last wire (measured in the minor direction).
Public property | MinorLapSpliceLength | Defines the internal snapping for single fabric placement.
Public property | MinorLayoutPattern | Identifies the layout pattern of Fabric Sheet.
Public property | MinorNumberOfWires | Determines the number of wires used in the minor direction (includes the 1st and last wires).
Public property | MinorReinforcementArea | Area of Wire / Spacing of Wire.
Public property | MinorSpacing | Determines the spacing between the wires (not including the overhangs).
Public property | MinorStartOverhang | Determines the distance from the edge of the sheet to the 1st wire (measured in the minor direction).
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OverallLength | Determines the length of the wire sheet (including overhangs) in the major direction.
Public property | OverallWidth | Determines the length of the wire sheet (including overhangs) in the minor direction.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | PhysicalMaterialAsset | Defines Physical Material Asset.
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SheetMass | Defines sheet mass.
Public property | SheetMassUnit | Defines sheet mass per area unit.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

FabricSheetType Class
Autodesk.Revit.DB.Structure Namespace