Revit 2013 API
RebarShapeConstraintDiameter Constructor
RebarShapeConstraintDiameter Class See Also
Create a diameter constraint.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public RebarShapeConstraintDiameter(
    ElementId paramId,
    RebarShapeArcReferenceType refType
)
Visual Basic
Public Sub New ( _
    paramId As ElementId, _
    refType As RebarShapeArcReferenceType _
)
Visual C++
public:
RebarShapeConstraintDiameter(
    ElementId^ paramId,
    RebarShapeArcReferenceType refType
)

Parameters

paramId
Type: Autodesk.Revit.DB..::..ElementId
The Id of a Rebar Shape parameter.
refType
Type: Autodesk.Revit.DB.Structure..::..RebarShapeArcReferenceType
A choice of rule for measuring the diameter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | paramId is not a valid Element identifier.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

RebarShapeConstraintDiameter Class
Autodesk.Revit.DB.Structure Namespace