Revit 2013 API
Document..::..NewFlexPipe Method (Connector, Connector, FlexPipeType)
Document Class See Also
Adds a new flexible pipe into the document, using two connector, and flexible pipe type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FlexPipe NewFlexPipe(
    Connector connector1,
    Connector connector2,
    FlexPipeType pipeType
)
Visual Basic
Public Function NewFlexPipe ( _
    connector1 As Connector, _
    connector2 As Connector, _
    pipeType As FlexPipeType _
) As FlexPipe
Visual C++
public:
FlexPipe^ NewFlexPipe(
    Connector^ connector1,
    Connector^ connector2,
    FlexPipeType^ pipeType
)

Parameters

connector1
Type: Autodesk.Revit.DB..::..Connector
The first connector to be connected to the pipe.
connector2
Type: Autodesk.Revit.DB..::..Connector
The second connector to be connected to the pipe.
pipeType
Type: Autodesk.Revit.DB.Plumbing..::..FlexPipeType
The type of the flexible pipe.

Return Value

If creation was successful then a new flexible pipe is returned, otherwise an exception with failure information will be thrown.

Remarks

If the connectors are fitting or equipment connectors of the correct domain, and if the connectors’ direction match the direction of the flexible pipe to be created, the connectors will be automatically connected. A transition fitting will be added at the connector(s) if necessary. If the connector's type, domain, does not match the one of the input connectors, no connection will be established.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument connector1 or connector2 is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the flexible pipe cannot be created or regenerate fails.

See Also

Document Class
NewFlexPipe Overload
Autodesk.Revit.Creation Namespace