Revit 2013 API
WorksharingDisplayMode Enumeration
Example See Also
Indicates which worksharing display mode a view is in.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public enum WorksharingDisplayMode
Visual Basic
Public Enumeration WorksharingDisplayMode
Visual C++
public enum class WorksharingDisplayMode

Members

Member name | Description
Off | No active worksharing display mode.
CheckoutStatus | The view is displaying the checkout status of elements.
Owners | The view is displaying the specific owners of elements.
ModelUpdates | The view is displaying model updates.
Worksets | The view is displaying which workset each element is assigned to.

Examples

CopyC#
public void GetWorksharingDisplayMode(View view)
{
    // Get and Set worksharingDisplayMode of a given view
    WorksharingDisplayMode displayMode = view.GetWorksharingDisplayMode();
    Autodesk.Revit.UI.TaskDialog.Show("GetWorksharingDisplayMode", "WorksharingDisplayMode : " + displayMode);

    view.SetWorksharingDisplayMode(WorksharingDisplayMode.CheckoutStatus);
    Autodesk.Revit.UI.TaskDialog.Show("SetWorksharingDisplayMode", "CheckoutStatus was set for View: " + view.Name);
}

See Also