Revit 2013 API
HandRailType..::..SupportLayout Property
HandRailType Class See Also
The support layout method of the handrail.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public RailSupportsLayout SupportLayout { get; set; }
Visual Basic
Public Property SupportLayout As RailSupportsLayout
    Get
    Set
Visual C++
public:
property RailSupportsLayout SupportLayout {
    RailSupportsLayout get ();
    void set (RailSupportsLayout value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The rail has no support specified so the data being set is not applicable.

See Also

HandRailType Class
Autodesk.Revit.DB.Architecture Namespace