Revit 2013 API
Plane Constructor (XYZ, XYZ, XYZ)
Plane Class See Also
Constructor for geometry plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Plane(
    XYZ xVec,
    XYZ yVec,
    XYZ origin
)
Visual Basic
Public Sub New ( _
    xVec As XYZ, _
    yVec As XYZ, _
    origin As XYZ _
)
Visual C++
public:
Plane(
    XYZ^ xVec,
    XYZ^ yVec,
    XYZ^ origin
)

Parameters

xVec
Type: Autodesk.Revit.DB..::..XYZ
The vector for x-axis.
yVec
Type: Autodesk.Revit.DB..::..XYZ
The vector for y-axis.
origin
Type: Autodesk.Revit.DB..::..XYZ
The coordinates for the origin.

Remarks

Used to construct a new Plane object.

See Also

Plane Class
Plane Overload