Revit 2013 API
LineLightShape Members
LineLightShape Class Constructors Methods Properties See Also

The LineLightShape type exposes the following members.

Constructors

 | Name | Description
Public method | LineLightShape()()()() | Creates a line light shape object with 2.0' emit length.
Public method | LineLightShape(Double) | Creates a line light shape object with the given emit length.
Public method | LineLightShape(LineLightShape) | Creates a copy of the given line light shape

Methods

 | Name | Description
Public method | Clone | Creates a copy of the LightShape derived object. (Inherited from LightShape.)
Public method | Dispose | (Inherited from LightShape.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | EmitLength | The emit length.

See Also

LineLightShape Class
Autodesk.Revit.DB.Lighting Namespace