Revit 2013 API
IFCProductWrapper Class
Members See Also
This class is used to ensure that elements and objects are associated with the current IfcProduct.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class IFCProductWrapper : IDisposable
Visual Basic
Public Class IFCProductWrapper _
    Implements IDisposable
Visual C++
public ref class IFCProductWrapper : IDisposable

Remarks

Each instance makes sure that any elements and products created during its lifetime are properly associated to their parent level (or other containing object). To ensure that the lifetime of the object is correctly managed, you should declare an instance of this class as a part of a 'using' statement in C# or similar construct in other lanuguages.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.IFC..::..IFCProductWrapper

See Also

IFCProductWrapper Members
Autodesk.Revit.DB.IFC Namespace