Revit 2013 API
ConicalFace Methods
ConicalFace Class See Also

The ConicalFace type exposes the following members.

Methods

 | Name | Description
Public method | ComputeDerivatives | Returns the vectors describing the face at the specified point. (Inherited from Face.)
Public method | ComputeNormal | Returns the normal vector for the face at the given point. (Inherited from Face.)
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | Evaluate | Evaluates parameters on the face. (Inherited from Face.)
Public method | GetBoundingBox | Returns the UV bounding box of the face. (Inherited from Face.)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code; (Inherited from GeometryObject.)
Public method | GetRegions | Face regions (created with the Split Face command) of the face. (Inherited from Face.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect(Curve) | Calculates the intersection of the specified curve with this face. (Inherited from Face.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of the specified curve with this face and returns the intersection results. (Inherited from Face.)
Public method | IsInside(UV) | Indicates whether the specified point is within this face. (Inherited from Face.)
Public method | IsInside(UV, IntersectionResult%) | Indicates whether the specified point is within this face and outputs additional results. (Inherited from Face.)
Public method | Project | Projects the specified point on this face. (Inherited from Face.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Triangulate()()()() | Returns a triangular mesh approximation to the face. (Inherited from Face.)
Public method | Triangulate(Double) | Returns a triangular mesh approximation to the face. (Inherited from Face.)

See Also

ConicalFace Class