Revit 2013 API
VectorAtPoint Class
Members Example See Also
Stores vectors at one domain point. Each vector corresponds to a "measurement" for which this vector was calculated.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class VectorAtPoint : ValueAtPointBase
Visual Basic
Public Class VectorAtPoint _
    Inherits ValueAtPointBase
Visual C++
public ref class VectorAtPoint : public ValueAtPointBase

Examples

CopyC#
// Place analysis results in the form of vectors at each of a beam or column's analytical model curve
Curve curve = familyInstance.GetAnalyticalModel().GetCurve();

Transform transform = familyInstance.GetTransform();
int index = spatialFieldManager.AddSpatialFieldPrimitive(curve, Transform.Identity);

IList<double> doubleList = new List<double>();
doubleList.Add(curve.get_EndParameter(0)); // vectors will be at each end of the analytical model curve
doubleList.Add(curve.get_EndParameter(1));
FieldDomainPointsByParameter pointsByParameter = new FieldDomainPointsByParameter(doubleList);

List<XYZ> xyzList = new List<XYZ>();
xyzList.Add(curve.ComputeDerivatives(0, true).BasisX.Normalize()); // vectors will be tangent to the curve at its ends
IList<VectorAtPoint> vectorList = new List<VectorAtPoint>();
vectorList.Add(new VectorAtPoint(xyzList));
xyzList.Clear();
xyzList.Add(curve.ComputeDerivatives(1, true).BasisX.Normalize().Negate());
vectorList.Add(new VectorAtPoint(xyzList));
FieldValues fieldValues = new FieldValues(vectorList);

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ValueAtPointBase
Autodesk.Revit.DB.Analysis..::..VectorAtPoint

See Also

VectorAtPoint Members
Autodesk.Revit.DB.Analysis Namespace