Revit 2013 API
LightType Methods
LightType Class See Also

The LightType type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInitialColor | Return a copy of an object derived from InitialColor
Public method | GetInitialIntensity | Return a copy of an object derived from InitialIntensity
Public method | GetLightDistribution | Return a copy of an object derived from LightDistribution
Public method | GetLightShape | Return a copy of an object derived from LightShape
 | GetLightType | Creates a light type object from the given document and family type ID
 | GetLightTypeFromInstance | Creates a light type object from the given document and element ID
Public method | GetLossFactor | Return a copy of an object derived from LossFactor
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetInitialColor | Replace the current initial color object with the given object
Public method | SetInitialIntensity | Replace the current initial intensity object with the given object
Public method | SetLightDistribution | Replace the current LightDistribution object with the given object
Public method | SetLightShape | Replace the current LightShape object with the given object
Public method | SetLossFactor | Replace the current loss factor object with the given object
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LightType Class
Autodesk.Revit.DB.Lighting Namespace