Revit 2013 API
StartingViewSettings Members
StartingViewSettings Class Methods Properties See Also

The StartingViewSettings type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the StartingViewSettings
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetStartingViewSettings | Returns the starting view settings for the specified document.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAcceptableStartingView | Checks whether the given Id is an acceptable starting view. InvalidElementId corresponds to "Last Viewed" and is therefore also acceptable.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ViewId | Indicates the specific view that will be opened when the model is loaded. InvalidElementId indicates that no view has been specified. In that case, Revit will open the last views that were open at the time the file was saved.

See Also

StartingViewSettings Class