Revit 2013 API
FailureResolution Class
Members See Also
Defines a resolution for a failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class FailureResolution : IDisposable
Visual Basic
Public Class FailureResolution _
    Implements IDisposable
Visual C++
public ref class FailureResolution : IDisposable

Remarks

A failure could have several permitted resolutions. List of applicable resolution types for the specific failure is defined by the FailureDefinition, actual FailureResolutions are instantiated with the FailureMessage before it is posted. Multiple resolutions per failure are allowed, although Revit UI only uses default resolution.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FailureResolution
Autodesk.Revit.DB..::..DeleteElements

See Also

FailureResolution Members