Revit 2013 API
LightFamily Members
LightFamily Class Methods See Also

The LightFamily type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the LightFamily
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLightDistributionStyle | Returns a LightDistributionStyle value for the light distribution
 | GetLightFamily | Creates a light family object from the given family document
Public method | GetLightShapeStyle | Returns a LightShapeStyle value for the light shape
Public method | GetLightSourceTransform | Returns the transformation matrix of the relocated light source.
Public method | GetLightType | Return a LightType object for the light type at the given index
Public method | GetLightTypeName | Return the name for the light type at the given index
Public method | GetNumberOfLightTypes | Return the number of light types contained in this light family
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetLightDistributionStyle | Set the light distribution style to the given shape distribution
Public method | SetLightShapeStyle | Set the light shape style to the given shape style
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LightFamily Class
Autodesk.Revit.DB.Lighting Namespace