Revit 2013 API
PanelScheduleView..::..SetParamValue Method
PanelScheduleView Class See Also
Sets the text for the given cell, returns true if successful, false otherwise

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool SetParamValue(
    SectionType sectionType,
    int nRow,
    int nCol,
    string sValue
)
Visual Basic
Public Function SetParamValue ( _
    sectionType As SectionType, _
    nRow As Integer, _
    nCol As Integer, _
    sValue As String _
) As Boolean
Visual C++
public:
bool SetParamValue(
    SectionType sectionType,
    int nRow,
    int nCol,
    String^ sValue
)

Parameters

sectionType
Type: Autodesk.Revit.DB..::..SectionType
The associated section
nRow
Type: System..::..Int32
Row Number of the Section
nCol
Type: System..::..Int32
Column Number of the Section
sValue
Type: System..::..String
String value to set the parameter

Return Value

Returns whether the function succeeded

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown if there is no parameter at this cell
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown if attempt to call on a template

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace