Revit 2013 API
SelectionFilterElement..::..Create Method
SelectionFilterElement Class See Also
Creates a new SelectionFilterElement in the given document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static SelectionFilterElement Create(
    Document document,
    string name
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    name As String _
) As SelectionFilterElement
Visual C++
public:
static SelectionFilterElement^ Create(
    Document^ document,
    String^ name
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which to create the SelectionFilterElement.
name
Type: System..::..String
The name for the new SelectionFilterElement.

Return Value

The new SelectionFilterElement.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | name is an empty string. -or- The given value for name is already in use as a filter element name.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

SelectionFilterElement Class