Revit 2013 API
AnalysisDisplayDiagramSettings Members
AnalysisDisplayDiagramSettings Class Constructors Methods Properties See Also

The AnalysisDisplayDiagramSettings type exposes the following members.

Constructors

 | Name | Description
Public method | AnalysisDisplayDiagramSettings()()()() | Constructs a default instance of diagram settings.
Public method | AnalysisDisplayDiagramSettings(AnalysisDisplayDiagramSettings) | Constructs a copy of diagram settings object.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the AnalysisDisplayDiagramSettings
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual | Compares two diagram settings objects.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | FenceType | Type of diagram fence visualization.
Public property | OutlineColor | Color of outline and fence lines in the diagram.
Public property | OutlineLineWeight | Line weight of outline and fence lines in the diagram.
Public property | Rounding | Increment to which numeric values of analysis results are rounded in diagram.
Public property | TextLabelType | Type of diagram text label visualization.
Public property | TextTypeId | Element id of text associated with the settings.
Public property | Transparency | Transparency percentage of diagram color fill

See Also

AnalysisDisplayDiagramSettings Class
Autodesk.Revit.DB.Analysis Namespace