Revit 2013 API
HostObjectUtils..::..GetSideFaces Method
HostObjectUtils Class See Also
Returns the major side faces for this host object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static IList<Reference> GetSideFaces(
    HostObject hostObject,
    ShellLayerType side
)
Visual Basic
Public Shared Function GetSideFaces ( _
    hostObject As HostObject, _
    side As ShellLayerType _
) As IList(Of Reference)
Visual C++
public:
static IList<Reference^>^ GetSideFaces(
    HostObject^ hostObject,
    ShellLayerType side
)

Parameters

hostObject
Type: Autodesk.Revit.DB..::..HostObject
The host object.
side
Type: Autodesk.Revit.DB..::..ShellLayerType
The side of the host object.

Return Value

An array of references to the faces which are on the given side of this element.

Remarks

This utility supports host objects whose CompoundStructure is nominally oriented vertically. It outputs faces which are at the boundary of the CompoundStructure (such as Walls and FaceWalls).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | This host object does not support access to side faces.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

HostObjectUtils Class