Revit 2013 API
FabricSheetType..::..SetMinorLayoutAsFixedNumber Method
FabricSheetType Class See Also
Set Minor Layout Pattern as Fixed Number.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetMinorLayoutAsFixedNumber(
    double overallLength,
    double majorStartOverhang,
    double majorEndOverhang,
    int numberOfWires
)
Visual Basic
Public Sub SetMinorLayoutAsFixedNumber ( _
    overallLength As Double, _
    majorStartOverhang As Double, _
    majorEndOverhang As Double, _
    numberOfWires As Integer _
)
Visual C++
public:
void SetMinorLayoutAsFixedNumber(
    double overallLength,
    double majorStartOverhang,
    double majorEndOverhang,
    int numberOfWires
)

Parameters

overallLength
Type: System..::..Double
The entire length of the wire sheet in the major direction.
majorStartOverhang
Type: System..::..Double
Distance from the edge of the sheet to the first wire in the major direction.
majorEndOverhang
Type: System..::..Double
Distance from the last wire to the edge of the sheet in the major direction.
numberOfWires
Type: System..::..Int32
Number of the wires to set in the minor direction.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given value for overallLength is not a number -or- The given value for majorStartOverhang is not a number -or- The given value for majorEndOverhang is not a number -or- numberOfWires must range from 2 to 1000000. -or- The arguments are not consistent, please specify proper input values.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The given value for overallLength must be greater than 0 and no more than 30000 feet. -or- The given value for majorStartOverhang must be between 0 and 30000 feet. -or- The given value for majorEndOverhang must be between 0 and 30000 feet.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural.

See Also

FabricSheetType Class
Autodesk.Revit.DB.Structure Namespace