Revit 2013 API
UIDocument Methods
UIDocument Class See Also

The UIDocument type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOpenUIViews | Get a list of all open view windows in the Revit user interface.
 | GetRevitUIFamilyLoadOptions | Return the option object that allows you to use Revit's dialog boxes to let the user respond to questions that arise during loading of families.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PromptForFamilyInstancePlacement | Prompts the user to place instances of the specified FamilySymbol.
Public method | RefreshActiveView | Refresh the display of the active view in the active document.
Public method | SaveAndClose | Close the document, prompting the user for saving it when necessary.
Public method | SaveAs | Saves the document to a file name obtained from the Revit user.
Public method | ShowElements(Element) | Shows the element by zoom to fit.
Public method | ShowElements(ElementId) | Shows the element by zoom to fit.
Public method | ShowElements(ICollection<(Of <<'(ElementId>)>>)) | Shows the elements by zoom to fit.
Public method | ShowElements(ElementSet) | Shows the elements by zoom to fit.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UIDocument Class
Autodesk.Revit.UI Namespace