Revit 2013 API
AnalyticalModel..::..GetOffset Method
AnalyticalModel Class See Also
Gets the offset of the analytical model at end.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public XYZ GetOffset(
    AnalyticalElementSelector selector
)
Visual Basic
Public Function GetOffset ( _
    selector As AnalyticalElementSelector _
) As XYZ
Visual C++
public:
XYZ^ GetOffset(
    AnalyticalElementSelector selector
)

Parameters

selector
Type: Autodesk.Revit.DB.Structure..::..AnalyticalElementSelector
End of the analytical model.

Return Value

Offset of analytical model from base analytical model at the given end.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | selector is not valid for the Analytical Model.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Function only work for curve-based elements.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace