Revit 2013 API
RenderingQualitySettings..::..BlurredReflectionPrecision Property
RenderingQualitySettings Class See Also
The blurred reflections precision.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int BlurredReflectionPrecision { get; set; }
Visual Basic
Public Property BlurredReflectionPrecision As Integer
    Get
    Set
Visual C++
public:
property int BlurredReflectionPrecision {
    int get ();
    void set (int value);
}

Remarks

Increase this value when the edges of objects in blurred reflections are speckled, rather than smoothly blurred.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The blurred reflections precision is not valid. The valid range is 1 to 11.
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The RenderingQualitySettings does not use custom quality currently. To use custom quality, set RenderingQuality property to RenderingQuality.Custom.

See Also

RenderingQualitySettings Class