Revit 2013 API
ComboBoxMemberData Members
ComboBoxMemberData Class Constructors Methods Properties See Also

The ComboBoxMemberData type exposes the following members.

Constructors

 | Name | Description
Public method | ComboBoxMemberData | Constructs a new instance of ComboBoxMemberData.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetContextualHelp | Gets the contextual help bound with this control. (Inherited from RibbonItemData.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetContextualHelp | Sets the contextual help bound with this button data. (Inherited from RibbonItemData.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | GroupName | Gets or sets a group name for the ComboBoxMember.
Public property | Image | The image shown on the ComboBoxMember.
Public property | LongDescription | Long description of the command tooltip; (Inherited from RibbonItemData.)
Public property | Name | The name of the item. (Inherited from RibbonItemData.)
Public property | Text | The user-visible text of the ComboBoxMember.
Public property | ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItemData.)
Public property | ToolTipImage | The image to show as a part of the button extended tooltip; (Inherited from RibbonItemData.)

See Also

ComboBoxMemberData Class
Autodesk.Revit.UI Namespace