Revit 2013 API
WorksetDefaultVisibilitySettings..::..SetWorksetVisibility Method
WorksetDefaultVisibilitySettings Class Example See Also
Set the default visibility of a workset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void SetWorksetVisibility(
    WorksetId worksetId,
    bool visible
)
Visual Basic
Public Sub SetWorksetVisibility ( _
    worksetId As WorksetId, _
    visible As Boolean _
)
Visual C++
public:
void SetWorksetVisibility(
    WorksetId^ worksetId,
    bool visible
)

Parameters

worksetId
Type: Autodesk.Revit.DB..::..WorksetId
Id of the workset.
visible
Type: System..::..Boolean
Whether the workset should be visible by default or not.

Examples

CopyC#
public void HideWorkset(Document doc, View view, WorksetId worksetId)
{
    // get the current visibility
    WorksetVisibility visibility = view.GetWorksetVisibility(worksetId);

    // and set it to 'Hidden' if it is not hidden yet
    if (visibility != WorksetVisibility.Hidden)
    {
        view.SetWorksetVisibility(worksetId, WorksetVisibility.Hidden);
    }

    // Get the workset’s default visibility
    WorksetDefaultVisibilitySettings defaultVisibility = WorksetDefaultVisibilitySettings.GetWorksetDefaultVisibilitySettings(doc);

    // and making sure it is set to 'false'
    if (true == defaultVisibility.IsWorksetVisible(worksetId))
    {
        defaultVisibility.SetWorksetVisibility(worksetId, false);
    }
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | There is no workset with this Id in the document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | WorksetDefaultVisibilitySettings is not applicable to family documents.

See Also

WorksetDefaultVisibilitySettings Class