Revit 2013 API
EnergyAnalysisSpace Members
EnergyAnalysisSpace Class Methods Properties See Also

The EnergyAnalysisSpace type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the EnergyAnalysisSpace
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalSurfaces | Provides a way to access the collection of analytical surfaces for a space. Geometry data defining an analytical space volume. Through an analytical surface you can connect a source element with each polygon in a space. The analytical surfaces defines an enclosed volume bounded by the center plane of walls and the top plane of roofs and floors.
Public method | GetBoundary | Gets the collection of polygons that form the 2D boundary. This method returns a collection of polyloops (planar polygons) that defines an enclosed area measured by interior bounding surfaces.
Public method | GetClosedShell | Gets the collection of polygons that form a closed shell. This method returns a collection of polyloops (planar polygons) that defines an enclosed volume measured by interior bounding surfaces.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AnalyticalVolume | The volume for this space.
Public property | Area | The area for this space.
Public property | ComposedName | The composed name for this space.
Public property | Description | The description.
Public property | InnerVolume | The analytical volume for this space.
Public property | Name | The name.
Public property | SpatialElementId | The id of spatial element associated with this space.

See Also

EnergyAnalysisSpace Class
Autodesk.Revit.DB.Analysis Namespace