Revit 2013 API
ExporterIFCUtils..::..GetElevationProfile Method
ExporterIFCUtils Class See Also
Obtains the curve loops which bound the wall's elevation profile.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static IList<CurveLoop> GetElevationProfile(
    Wall pVWall
)
Visual Basic
Public Shared Function GetElevationProfile ( _
    pVWall As Wall _
) As IList(Of CurveLoop)
Visual C++
public:
static IList<CurveLoop^>^ GetElevationProfile(
    Wall^ pVWall
)

Parameters

pVWall
Type: Autodesk.Revit.DB..::..Wall
The wall.

Return Value

The collection of curve loops.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The wall does not have an elevation profile.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace