Revit 2013 API
StructuralConnectionType..::..Create Method
StructuralConnectionType Class See Also
Create a new StructuralConnectionType, allowing the specified annotation FamilySymbol to be applied to structural members.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static StructuralConnectionType Create(
    Document doc,
    StructuralConnectionApplyTo applyTo,
    string name,
    ElementId familySymbolId
)
Visual Basic
Public Shared Function Create ( _
    doc As Document, _
    applyTo As StructuralConnectionApplyTo, _
    name As String, _
    familySymbolId As ElementId _
) As StructuralConnectionType
Visual C++
public:
static StructuralConnectionType^ Create(
    Document^ doc,
    StructuralConnectionApplyTo applyTo,
    String^ name,
    ElementId^ familySymbolId
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
applyTo
Type: Autodesk.Revit.DB.Structure..::..StructuralConnectionApplyTo
Specify which type of member this connection type can be applied to.
name
Type: System..::..String
A name for the connection type. It must be unique within the document.
familySymbolId
Type: Autodesk.Revit.DB..::..ElementId
The id of an annotation FamilySymbol. InvalidElementId is allowed. Otherwise, the FamilySymbol must be in the category "Connection Symbols" (OST_StructConnectionSymbols) and have its "Apply To" parameter set to match the applyTo argument.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | familySymbolId is the id of some element that is not a FamilySymbol, is not of the category "Connection Symbols" (OST_StructConnectionSymbols), or has its "Apply To" parameter not equal to applyTo.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

StructuralConnectionType Class
Autodesk.Revit.DB.Structure Namespace