Revit 2013 API
FamilyInstanceFilter Constructor
FamilyInstanceFilter Class See Also
Constructs a new instance of a filter to match family instances of the given family symbol.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FamilyInstanceFilter(
    Document document,
    ElementId familySymbolId
)
Visual Basic
Public Sub New ( _
    document As Document, _
    familySymbolId As ElementId _
)
Visual C++
public:
FamilyInstanceFilter(
    Document^ document,
    ElementId^ familySymbolId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document. This requirement is unique to this filter and is needed to ensure the input family symbol id is valid for the provided document. This ensures the most stability and greatest performance for this filter.
familySymbolId
Type: Autodesk.Revit.DB..::..ElementId
The family symbol id.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The familySymbolId does not represent a valid FamilySymbol record in the document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FamilyInstanceFilter Class