Revit 2013 API
IFCAggregate Members
IFCAggregate Class Methods Properties See Also

The IFCAggregate type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an element to the aggregate.
Public method | AddAggregate | Creates a nested aggregate and adds it to the aggregate.
Public method | Delete | Delete the aggregate object from the IFCFile model.
Public method | Dispose | Releases all resources used by the IFCAggregate
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIFCAggregateIterator | Returns a IFCAggregateIterator that iterates through the collection.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | The number of the data values in the aggregate.
Public property | Item | Get the IFCData for this aggregate.

See Also

IFCAggregate Class
Autodesk.Revit.DB.IFC Namespace