Revit 2013 API
WorksharingUtils..::..GetWorksharingTooltipInfo Method
WorksharingUtils Class See Also
Gets worksharing information about an element to display in an in-canvas tooltip.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static WorksharingTooltipInfo GetWorksharingTooltipInfo(
    Document document,
    ElementId elementId
)
Visual Basic
Public Shared Function GetWorksharingTooltipInfo ( _
    document As Document, _
    elementId As ElementId _
) As WorksharingTooltipInfo
Visual C++
public:
static WorksharingTooltipInfo^ GetWorksharingTooltipInfo(
    Document^ document,
    ElementId^ elementId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document containing the element
elementId
Type: Autodesk.Revit.DB..::..ElementId
The id of the element in question

Return Value

Worksharing information about the specified element.

Remarks

If there is no element corresponding to the given id, then all the strings returned in WorksharingTooltipInfo are empty.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

WorksharingUtils Class