Revit 2013 API
IFCTransaction Constructor
IFCTransaction Class See Also
Instantiates a transaction object.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IFCTransaction(
    IFCFile file
)
Visual Basic
Public Sub New ( _
    file As IFCFile _
)
Visual C++
public:
IFCTransaction(
    IFCFile^ file
)

Parameters

file
Type: Autodesk.Revit.DB.IFC..::..IFCFile
The IFC file for which this transaction is going to be used.

Remarks

The transaction starts by creating a transaction object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCTransaction Class
Autodesk.Revit.DB.IFC Namespace