Revit 2013 API
View..::..ApplyViewTemplateParameters Method
View Class See Also
Applies to this view the parameters of %otherView% that are not controlled by the current view template. To get all template parameters call template's method getTemplateParameterIds. To get parameters that are not controlled by the template call template's method getNonControlledTemplateParameterIds. To get current view template use property ViewTemplateId.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void ApplyViewTemplateParameters(
    View otherView
)
Visual Basic
Public Sub ApplyViewTemplateParameters ( _
    otherView As View _
)
Visual C++
public:
void ApplyViewTemplateParameters(
    View^ otherView
)

Parameters

otherView
Type: Autodesk.Revit.DB..::..View
View whose parameters are to be applied to this view. It does not have to be a valid template (property IsTemplate can be true or false).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

View Class