Revit 2013 API
FamilyManager..::..Set Method (FamilyParameter, Int32)
FamilyManager Class See Also
Set the integer value of a family parameter of the current family type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Set(
    FamilyParameter familyParameter,
    int value
)
Visual Basic
Public Sub Set ( _
    familyParameter As FamilyParameter, _
    value As Integer _
)
Visual C++
public:
void Set(
    FamilyParameter^ familyParameter,
    int value
)

Parameters

familyParameter
Type: Autodesk.Revit.DB..::..FamilyParameter
The family parameter of current type.
value
Type: System..::..Int32
The new value for family parameter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input argument-"familyParameter"-is an invalid family parameter.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the input argument-"familyParameter"-is out of range.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the family parameter is determined by formula, or the current family type is invalid.

See Also

FamilyManager Class
Set Overload