Revit 2013 API
FillPatternElement..::..SetFillPattern Method
FillPatternElement Class See Also
Sets the FillPattern associated to this element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void SetFillPattern(
    FillPattern newFillPattern
)
Visual Basic
Public Sub SetFillPattern ( _
    newFillPattern As FillPattern _
)
Visual C++
public:
void SetFillPattern(
    FillPattern^ newFillPattern
)

Parameters

newFillPattern
Type: Autodesk.Revit.DB..::..FillPattern
The new FillPattern object.

Remarks

The data stored inside the input FillPattern will be copied into this element. The input FillPattern itself will not be associated with the element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FillPatternElement Class