Revit 2013 API
IFCDoorWindowInfo Methods
IFCDoorWindowInfo Class See Also

The IFCDoorWindowInfo type exposes the following members.

Methods

 | Name | Description
 | CreateDoorInfo | Creates a new instance of IFCDoorWindowInfo representing a door to be exported.
 | CreateWindowInfo | Creates a new instance of IFCDoorWindowInfo representing a window to be exported.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLocalPlacement | Obtains the IfcLocalPlacement handle stored with this door/window info.
Public method | GetOpening | Obtains the handle to the IfcOpeningElement handle stored within this door/window info.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDelayedFamilyInstance |
Public method | SetLocalPlacement | Sets the IfcLocalPlacement handle stored with this door/window info.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IFCDoorWindowInfo Class
Autodesk.Revit.DB.IFC Namespace