Revit 2013 API
ViewSchedule..::..GetDefaultNameForKeySchedule Method
ViewSchedule Class See Also
Gets the default view name that will be used when creating a key schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static string GetDefaultNameForKeySchedule(
    Document document,
    ElementId categoryId
)
Visual Basic
Public Shared Function GetDefaultNameForKeySchedule ( _
    document As Document, _
    categoryId As ElementId _
) As String
Visual C++
public:
static String^ GetDefaultNameForKeySchedule(
    Document^ document,
    ElementId^ categoryId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the new schedule will be added.
categoryId
Type: Autodesk.Revit.DB..::..ElementId
The ID of the category of elements that the schedule's keys will be associated with.

Return Value

The default view name.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document. -or- categoryId is not a valid category for a key schedule.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ViewSchedule Class