Revit 2013 API
Polyloop Members
Polyloop Class Methods Properties See Also

The Polyloop type exposes the following members.

Methods

 | Name | Description
Public method | ComputeArea | Gets the area for this polygon.
Public method | Dispose | Releases all resources used by the Polyloop
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPoints | Gets the array of points in the polygon
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Centroid | The polygon centroid.
Public property | Direction | The direction for the outward normal for this polygon.

See Also

Polyloop Class
Autodesk.Revit.DB.Analysis Namespace