Revit 2013 API
ExporterIFC..::..RegisterDoorWindowForUncreatedOpening Method
ExporterIFC Class See Also
Registers a door or window in the ExporterIFC's internal cache. The ids registered correspond to openings in walls which have not been processed and created yet.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void RegisterDoorWindowForUncreatedOpening(
    ElementId familyInstanceId,
    IFCAnyHandle instanceHandle
)
Visual Basic
Public Sub RegisterDoorWindowForUncreatedOpening ( _
    familyInstanceId As ElementId, _
    instanceHandle As IFCAnyHandle _
)
Visual C++
public:
void RegisterDoorWindowForUncreatedOpening(
    ElementId^ familyInstanceId,
    IFCAnyHandle^ instanceHandle
)

Parameters

familyInstanceId
Type: Autodesk.Revit.DB..::..ElementId
The id of the door or window.
instanceHandle
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The handle to the IfcDoor or IfcWindow created for this instance.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace