Revit 2013 API
PropertySetElement..::..SetThermalAsset Method
PropertySetElement Class See Also

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void SetThermalAsset(
    ThermalAsset thermalAsset
)
Visual Basic
Public Sub SetThermalAsset ( _
    thermalAsset As ThermalAsset _
)
Visual C++
public:
void SetThermalAsset(
    ThermalAsset^ thermalAsset
)

Parameters

thermalAsset
Type: Autodesk.Revit.DB..::..ThermalAsset

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the name of the asset is empty, contains prohibited characters, or is not unique
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PropertySetElement Class