Revit 2013 API
ExporterIFCUtils..::..GetWallTrimmedCurve Method
ExporterIFCUtils Class See Also
Obtains the curve of the wall trimmed or extended according to the end conditions of the wall.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static Curve GetWallTrimmedCurve(
    Wall pVWall
)
Visual Basic
Public Shared Function GetWallTrimmedCurve ( _
    pVWall As Wall _
) As Curve
Visual C++
public:
static Curve^ GetWallTrimmedCurve(
    Wall^ pVWall
)

Parameters

pVWall
Type: Autodesk.Revit.DB..::..Wall
The wall.

Return Value

The trimmed or extended curve.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace