Revit 2013 API
UIApplication Methods
UIApplication Class See Also

The UIApplication type exposes the following members.

Methods

 | Name | Description
Public method | CreateAddInCommandBinding | Creates a new AddInCommandBinding.
Public method | CreateRibbonPanel(String) | Create a new RibbonPanel on the Add-Ins tab.
Public method | CreateRibbonPanel(String, String) | Create a new RibbonPanel on the specified tab.
Public method | CreateRibbonPanel(Tab, String) | Create a new RibbonPanel on the designated standard Revit tab.
Public method | CreateRibbonTab | Creates a new tab on the Revit user interface.
Public method | Dispose |
 | DoDragDrop(ICollection<(Of <<'(String>)>>)) | Initiates a drag and drop operation of a collection of file names on the Revit user interface.
 | DoDragDrop(Object, IDropHandler) | Initiates a drag and drop operation with a custom drop implementation.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRibbonPanels()()()() | Get all the custom Panels on Add-Ins tab of Revit.
Public method | GetRibbonPanels(String) | Get all the custom Panels on a designated Revit tab.
Public method | GetRibbonPanels(Tab) | Get all the custom Panels on a designated standard Revit tab.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | OpenAndActivateDocument(String) | Opens and activates a Revit document.
Public method | OpenAndActivateDocument(ModelPath, OpenOptionsForUI) | Opens and activates a Revit document.
Public method | RemoveAddInCommandBinding | Removes an AddInCommandBinding.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UIApplication Class
Autodesk.Revit.UI Namespace