Revit 2013 API
RebarShapeDefinitionByArc..::..AddConstraintDiameter Method
RebarShapeDefinitionByArc Class See Also
Specify a parameter to drive the diameter of the shape.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2009

Syntax

C#
public void AddConstraintDiameter(
    ElementId paramId,
    RebarShapeArcReferenceType arcRefType
)
Visual Basic
Public Sub AddConstraintDiameter ( _
    paramId As ElementId, _
    arcRefType As RebarShapeArcReferenceType _
)
Visual C++
public:
void AddConstraintDiameter(
    ElementId^ paramId,
    RebarShapeArcReferenceType arcRefType
)

Parameters

paramId
Type: Autodesk.Revit.DB..::..ElementId
Id of a parameter to drive the constraint. To obtain the id of a shared parameter, call RebarShape.GetElementIdForExternalDefinition().
arcRefType
Type: Autodesk.Revit.DB.Structure..::..RebarShapeArcReferenceType
Specify how the diameter should be measured--to the interior of the bend, the centerline of the bar, or the exterior.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

RebarShapeDefinitionByArc Class
Autodesk.Revit.DB.Structure Namespace