Revit 2013 API
ConceptualSurfaceType Methods
ConceptualSurfaceType Class See Also

The ConceptualSurfaceType type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetAllMassSubCategoryIds | Get all the mass subcategory ids for which there are ConceptualSurfaceType's.
 | GetByMassSubCategoryId | Get the ConceptualSurfaceType by its mass subcategory id.
Public method | GetConstructionTypeIds | The element ids of the ConceptualConstructionType's associated with this ConceptualSurfaceType.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConceptualSurfaceType Class
Autodesk.Revit.DB.Analysis Namespace