Revit 2013 API
ComboBox Members
ComboBox Class Methods Properties Events See Also

The ComboBox type exposes the following members.

Methods

 | Name | Description
Public method | AddItem | Adds a new item to the ComboBox.
Public method | AddItems | Adds a new items to the ComboBox.
Public method | AddSeparator | Adds a separator to the drop-down list.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from RibbonItem.)
Public method | GetContextualHelp | Gets the contextual help bound with this control. (Inherited from RibbonItem.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItems | Gets the copy of a collection of the ComboBoxMembers assigned to the ComboBox.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetContextualHelp | Sets the contextual help bound with this button. (Inherited from RibbonItem.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Gets or sets the current checked ComboBox member of the ComboBox.
Public property | Enabled | Gets or sets a value indicating whether the item is enabled. (Inherited from RibbonItem.)
Public property | Image | The image shown on the ComboBox.
Public property | ItemText | Gets or sets the text displayed on the item. (Inherited from RibbonItem.)
Public property | ItemType | Gets the item type. (Inherited from RibbonItem.)
Public property | LongDescription | Long description of the command tooltip; (Inherited from RibbonItem.)
Public property | Name | The name of the item. (Inherited from RibbonItem.)
Public property | ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItem.)
Public property | ToolTipImage | The image to show as a part of the button extended tooltip; (Inherited from RibbonItem.)
Public property | Visible | Gets or sets a value indicating whether the item is visible. (Inherited from RibbonItem.)

Events

 | Name | Description
Public event | CurrentChanged | Subscribe to this event to be notified when the current item of the ComboBox is changed.
Public event | DropDownClosed | Subscribe to this event to be notified when the drop-down of the ComboBox is closed.
Public event | DropDownOpened | Subscribe to this event to be notified when the drop-down of the ComboBox is opened.

See Also

ComboBox Class
Autodesk.Revit.UI Namespace