Revit 2013 API
AnalysisDisplayMarkersAndTextSettings Class
Members Example See Also
Contains markers and text settings for analysis display style element.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class AnalysisDisplayMarkersAndTextSettings : IDisposable
Visual Basic
Public Class AnalysisDisplayMarkersAndTextSettings _
    Implements IDisposable
Visual C++
public ref class AnalysisDisplayMarkersAndTextSettings : IDisposable

Examples

CopyC#
// Settings relating to the marker shape and size and the display of values
AnalysisDisplayMarkersAndTextSettings markerSettings = new AnalysisDisplayMarkersAndTextSettings();
markerSettings.MarkerSize = .05;
markerSettings.MarkerType = AnalysisDisplayStyleMarkerType.Triangle;
markerSettings.Rounding = .01;

// Settings relating to the marker color
AnalysisDisplayColorSettings colorSettings = new AnalysisDisplayColorSettings();
colorSettings.MaxColor = new Color(255, 0, 0);
colorSettings.MinColor = new Color(0, 255, 255);

// Settings relating to the legend
AnalysisDisplayLegendSettings legendSettings = new AnalysisDisplayLegendSettings();
legendSettings.Rounding = .01;

// Create the new display style
AnalysisDisplayStyle ads = AnalysisDisplayStyle.CreateAnalysisDisplayStyle(doc, "Markers 1", markerSettings, colorSettings, legendSettings);

// Assign the new display style to the current view
doc.ActiveView.AnalysisDisplayStyleId = ads.Id;

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Analysis..::..AnalysisDisplayMarkersAndTextSettings

See Also

AnalysisDisplayMarkersAndTextSettings Members
Autodesk.Revit.DB.Analysis Namespace