Revit 2013 API
RebarShape..::..GetAllowed Method
RebarShape Class See Also
Check whether a bar type can be used with this RebarShape. Bar types are allowed by default.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2009

Syntax

C#
public bool GetAllowed(
    RebarBarType barType
)
Visual Basic
Public Function GetAllowed ( _
    barType As RebarBarType _
) As Boolean
Visual C++
public:
bool GetAllowed(
    RebarBarType^ barType
)

Parameters

barType
Type: Autodesk.Revit.DB.Structure..::..RebarBarType
A bar type in the same document as this shape.

Return Value

True if this shape may be combined with this barType.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

RebarShape Class
Autodesk.Revit.DB.Structure Namespace