Revit 2013 API
RoutingPreferenceManager..::..GetSharedSizes Method
RoutingPreferenceManager Class See Also
Gets a list of all segments of a given profile shape that define a given size.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IList<ElementId> GetSharedSizes(
    double size,
    ConnectorProfileType shape
)
Visual Basic
Public Function GetSharedSizes ( _
    size As Double, _
    shape As ConnectorProfileType _
) As IList(Of ElementId)
Visual C++
public:
IList<ElementId^>^ GetSharedSizes(
    double size,
    ConnectorProfileType shape
)

Parameters

size
Type: System..::..Double
The size to search for.
shape
Type: Autodesk.Revit.DB..::..ConnectorProfileType
The profile shape of segment object.

Return Value

A list of all segments that define a given size.

See Also

RoutingPreferenceManager Class