Revit 2013 API
SingleServerService Methods
SingleServerService Class See Also

The SingleServerService type exposes the following members.

Methods

 | Name | Description
Public method | AddServer | Registers a server with its service. (Inherited from ExternalService.)
Public method | Dispose | (Inherited from ExternalService.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetActiveServerId()()()() | Returns the Id of the currently active application-level server of the service.
Public method | GetActiveServerId(Document) | Returns the Id of the server currently associated with the given document for the service.
Public method | GetDefaultServerId | Returns the Id of the default server if one was assigned to the service. (Inherited from ExternalService.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRegisteredServerIds | Returns Ids of all servers registered for the service. (Inherited from ExternalService.)
Public method | GetServer | Returns the instance that provides implementation for a registered server. (Inherited from ExternalService.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsRegisteredServerId | Checks if the Id represents a valid server that have been registered for the service. (Inherited from ExternalService.)
Public method | RemoveServer | Removes/unregisters a server from the service. (Inherited from ExternalService.)
Public method | SetActiveServer(Guid) | Set an active server applicable application-wide for the service.
Public method | SetActiveServer(Guid, Document) | Change the active server for a specific document.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UnsetActiveServer | Unset the active server for the particular document.

See Also

SingleServerService Class
Autodesk.Revit.DB.ExternalService Namespace