Revit 2013 API
ExporterIFCUtils..::..GetLegacyStairOrRampComponents Method
ExporterIFCUtils Class See Also
Gets the components of a stair or ramp.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static IFCLegacyStairOrRamp GetLegacyStairOrRampComponents(
    ExporterIFC exporterIFC,
    Element element
)
Visual Basic
Public Shared Function GetLegacyStairOrRampComponents ( _
    exporterIFC As ExporterIFC, _
    element As Element _
) As IFCLegacyStairOrRamp
Visual C++
public:
static IFCLegacyStairOrRamp^ GetLegacyStairOrRampComponents(
    ExporterIFC^ exporterIFC,
    Element^ element
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
element
Type: Autodesk.Revit.DB..::..Element
The legacy stair or ramp element.

Return Value

The LegacyStairOrRamp that contains the components. NULL means the components can't be determined.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace