Revit 2013 API
RailingType..::..PrimaryHandRailPosition Property
RailingType Class See Also
The position of the primary handrail.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public HandRailPosition PrimaryHandRailPosition { get; set; }
Visual Basic
Public Property PrimaryHandRailPosition As HandRailPosition
    Get
    Set
Visual C++
public:
property HandRailPosition PrimaryHandRailPosition {
    HandRailPosition get ();
    void set (HandRailPosition value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The rail has no primary hand rail.

See Also

RailingType Class
Autodesk.Revit.DB.Architecture Namespace