Revit 2013 API
Viewport..::..Create Method
Viewport Class See Also
Creates a new Viewport at a given location on a sheet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static Viewport Create(
    Document document,
    ElementId viewSheetId,
    ElementId viewId,
    XYZ point
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    viewSheetId As ElementId, _
    viewId As ElementId, _
    point As XYZ _
) As Viewport
Visual C++
public:
static Viewport^ Create(
    Document^ document,
    ElementId^ viewSheetId,
    ElementId^ viewId,
    XYZ^ point
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the new Viewport will be added.
viewSheetId
Type: Autodesk.Revit.DB..::..ElementId
The ViewSheet on which the new Viewport will be placed.
viewId
Type: Autodesk.Revit.DB..::..ElementId
The view shown in the Viewport.
point
Type: Autodesk.Revit.DB..::..XYZ
The new Viewport will be centered on this point.

Return Value

The new Viewport.

Remarks

Use ScheduleInstance.Create() to add schedules to sheets.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | viewSheetId is not a ViewSheet. -or- viewId cannot be added to the ViewSheet. -or- Plan view creation is not allowed in this family.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

Viewport Class