Revit 2013 API
TaskDialogShowingEventArgs Class
Members See Also
The event arguments used by the DialogBoxShowing event when a Revit task dialog that prompts the user for some action is shown.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public class TaskDialogShowingEventArgs : DialogBoxShowingEventArgs
Visual Basic
Public Class TaskDialogShowingEventArgs _
    Inherits DialogBoxShowingEventArgs
Visual C++
public ref class TaskDialogShowingEventArgs : public DialogBoxShowingEventArgs

Remarks

When the application receives this object, a task dialog is about to be displayed in Revit that requires user interaction. The OverrideResult function can be used to cause the dialog to be dismissed and return a desired result code.

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Autodesk.Revit.DB.Events..::..RevitEventArgs
Autodesk.Revit.DB.Events..::..PreEventArgs
Autodesk.Revit.UI.Events..::..DialogBoxShowingEventArgs
Autodesk.Revit.UI.Events..::..TaskDialogShowingEventArgs

See Also

TaskDialogShowingEventArgs Members
Autodesk.Revit.UI.Events Namespace