Revit 2013 API
FamilyManager..::..MakeInstance Method
FamilyManager Class See Also
Set the family parameter as an instance parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void MakeInstance(
    FamilyParameter familyParameter
)
Visual Basic
Public Sub MakeInstance ( _
    familyParameter As FamilyParameter _
)
Visual C++
public:
void MakeInstance(
    FamilyParameter^ familyParameter
)

Parameters

familyParameter
Type: Autodesk.Revit.DB..::..FamilyParameter

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-"familyParameter"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input argument-"familyParameter"-is an invalid parameter or a builtIn parameter.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when there is Type family parameter driven by this parameter.

See Also

FamilyManager Class