Revit 2013 API
MultiServerService Members
MultiServerService Class Methods Properties See Also

The MultiServerService type exposes the following members.

Methods

 | Name | Description
Public method | AddServer | Registers a server with its service. (Inherited from ExternalService.)
Public method | Dispose | (Inherited from ExternalService.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetActiveServerIds()()()() | Returns Ids of the currently active application-level servers registered for the service.
Public method | GetActiveServerIds(Document) | Returns Ids of the servers currently applicable to the given document for the service.
Public method | GetDefaultServerId | Returns the Id of the default server if one was assigned to the service. (Inherited from ExternalService.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRegisteredServerIds | Returns Ids of all servers registered for the service. (Inherited from ExternalService.)
Public method | GetServer | Returns the instance that provides implementation for a registered server. (Inherited from ExternalService.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsRegisteredServerId | Checks if the Id represents a valid server that have been registered for the service. (Inherited from ExternalService.)
Public method | RemoveServer | Removes/unregisters a server from the service. (Inherited from ExternalService.)
Public method | SetActiveServers(IList<(Of <<'(Guid>)>>)) | Changes the active servers and/or their order.
Public method | SetActiveServers(IList<(Of <<'(Guid>)>>), Document) | Changes the active servers and/or their order for the given document.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Description | The description for the service; (Inherited from ExternalService.)
Public property | ExecutionPolicy | Specifies how a multi-server service executes servers during its execution.
Public property | IsSerializable | Indicates whether executions of the service requires serialization in documents or not. (Inherited from ExternalService.)
Public property | Name | The name of the service; (Inherited from ExternalService.)
Public property | NumberOfServers | Indicates the number of servers currently registered with the service. (Inherited from ExternalService.)
Public property | ServiceId | The Id of the service; (Inherited from ExternalService.)
Public property | VendorId | The vendor who provided the service; (Inherited from ExternalService.)

See Also

MultiServerService Class
Autodesk.Revit.DB.ExternalService Namespace