Revit 2013 API
InitialIlluminanceIntensity Members
InitialIlluminanceIntensity Class Constructors Methods Properties See Also

The InitialIlluminanceIntensity type exposes the following members.

Constructors

 | Name | Description
Public method | InitialIlluminanceIntensity(InitialIlluminanceIntensity) | Creates a copy of the given initial illuminance intensity object
Public method | InitialIlluminanceIntensity(Double, Double) | Creates an initial illuminance intensity object with the given document and illuminance values.

Methods

 | Name | Description
Public method | Clone | Creates a copy of the InitialIntensity derived object. (Inherited from InitialIntensity.)
Public method | Dispose | (Inherited from InitialIntensity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Distance | The illuminance intensity distance value.
Public property | Illuminance | The illuminance intensity value.
Public property | InitialIntensityValue | The calculated initial intensity value. (Inherited from InitialIntensity.)

See Also

InitialIlluminanceIntensity Class
Autodesk.Revit.DB.Lighting Namespace