Revit 2013 API
CompoundStructure..::..GetSegmentOrientation Method
CompoundStructure Class See Also
Gets the orientation of a segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public RectangularGridSegmentOrientation GetSegmentOrientation(
    int segmentId
)
Visual Basic
Public Function GetSegmentOrientation ( _
    segmentId As Integer _
) As RectangularGridSegmentOrientation
Visual C++
public:
RectangularGridSegmentOrientation GetSegmentOrientation(
    int segmentId
)

Parameters

segmentId
Type: System..::..Int32
The id of a segment in this CompoundStructure.

Return Value

The orientation of the specified segment.

Remarks

The boundaries of the regions of a vertically compound structure consist of vertical horizontal segments.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The segment id is invalid.
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is valid only vertically compound structures.

See Also

CompoundStructure Class