Revit 2013 API
FailuresAccessor..::..GetFailureMessages Method (FailureSeverity)
FailuresAccessor Class See Also
Provides access to the individual failure messages if a given severity currently posted in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public IList<FailureMessageAccessor> GetFailureMessages(
    FailureSeverity severity
)
Visual Basic
Public Function GetFailureMessages ( _
    severity As FailureSeverity _
) As IList(Of FailureMessageAccessor)
Visual C++
public:
IList<FailureMessageAccessor^>^ GetFailureMessages(
    FailureSeverity severity
)

Parameters

severity
Type: Autodesk.Revit.DB..::..FailureSeverity
The failure severity for which failure messages are requested. If the requested severity is None, an empty collection is returned.

Return Value

Accessors to the individual failure messages of a given severity posted in the document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).

See Also

FailuresAccessor Class
GetFailureMessages Overload