Revit 2013 API
UV..::..Add Method
UV Class See Also
Adds the specified 2-D vector to this 2-D vector and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public UV Add(
    UV source
)
Visual Basic
Public Function Add ( _
    source As UV _
) As UV
Visual C++
public:
UV^ Add(
    UV^ source
)

Parameters

source
Type: Autodesk.Revit.DB..::..UV
The vector to add to this vector.

Return Value

The 2-D vector equal to the sum of the two vectors.

Remarks

The added vector is obtained by adding each coordinate of the specified vector to the corresponding coordinate of this vector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when source is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

UV Class