Revit 2013 API
BuiltInFailures..::..ImportFailures Properties
BuiltInFailures..::..ImportFailures Class See Also

The BuiltInFailures..::..ImportFailures type exposes the following members.

Properties

Name | Description
BadFaceFoundInDwg | One or more hatch regions were found in the imported file with unconnected boundaries. These hatch regions will be ignored.
CannotChangeImportSymbol | Can't change an imported or linked element's symbol type.
CannotExplodeElement | Can't explode the imported object.
CannotImportFile | Can't import file.
CannotRelinkWrapper | [Description]
FailedToSetWorkplane | Could not set Work Plane of [Import].\n\nPlease use the Work Plane tool to set a Work Plane for this view.
IFCGenericImportWarning | The following problems were encountered in the IFC file: [Description]
IFCGenericRevitImportWarning | Revit had the following problems importing the IFC file: [Description]
ImportTooFarAway | Imported objects located a large distance from the model might not display properly. The 'Center-to-Center' option will be used.
ImportTooManyElmentsToExplode | Import Instance has [Number] elements. Imports with more than 10,000 elements cannot be exploded.
LostAcisObjectsOnImport | Some ACIS objects could not be imported. To import them, use AutoCAD to convert them into polymesh objects and reimport.
SomeObjectsNotExploded | Import contained 3D data or points which can't be exploded. Only 2D data was exploded.
TextNotImported | Text is only imported if the "Current View Only" option is selected. To see the text in the original file, import again with this check box selected in the Import Dialog.
TooManyPickFaces | Too many faces were created from imported meshes. Host by Face tools may not select the imported meshes correctly. Decrease the complexity of the file or try importing only selected layers to resolve.
WorksetCreatedForLinkWarning | Newly created link types and instances were placed in new workset [workset name]

See Also

BuiltInFailures..::..ImportFailures Class