Revit 2013 API
StructuralAsset Constructor
StructuralAsset Class See Also
Constructs an instance of StructuralAsset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public StructuralAsset(
    string name,
    StructuralAssetClass structuralAssetClass
)
Visual Basic
Public Sub New ( _
    name As String, _
    structuralAssetClass As StructuralAssetClass _
)
Visual C++
public:
StructuralAsset(
    String^ name,
    StructuralAssetClass structuralAssetClass
)

Parameters

name
Type: System..::..String
The name of the asset.
structuralAssetClass
Type: Autodesk.Revit.DB..::..StructuralAssetClass
The type of structural material that this asset will describe.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

StructuralAsset Class