Revit 2013 API
ImageView..::..Create Method
ImageView Class See Also
Create an ImageView containing an image imported from disk.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static ImageView Create(
    Document document,
    string imageFileName
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    imageFileName As String _
) As ImageView
Visual C++
public:
static ImageView^ Create(
    Document^ document,
    String^ imageFileName
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which to create the view.
imageFileName
Type: System..::..String
The full path to the image file.

Return Value

The newly created view.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..FileArgumentNotFoundException | File does not exist.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

ImageView Class