Revit 2013 API
AnalyticalModelSurface..::..SetLoops Method
AnalyticalModelSurface Class See Also
Set new analytical model geometry (newLoops) for analytical surface elements such as floors and slabs.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool SetLoops(
    AnalyticalLoopType loopType,
    IList<CurveLoop> newLoops
)
Visual Basic
Public Function SetLoops ( _
    loopType As AnalyticalLoopType, _
    newLoops As IList(Of CurveLoop) _
) As Boolean
Visual C++
public:
bool SetLoops(
    AnalyticalLoopType loopType,
    IList<CurveLoop^>^ newLoops
)

Parameters

loopType
Type: Autodesk.Revit.DB.Structure..::..AnalyticalLoopType
Determine what kind of loops will be set. Rest of loops remain unchanged.
newLoops
Type: System.Collections.Generic..::..IList<(Of <(<'CurveLoop>)>)>
New analytical geometry for analytical surface elements.

Return Value

False if setting the new location failed for one or more curves. True if setting new location succeeded for all curves.

Remarks

Analytical surface will be automatically generated from provided newLoops. Number of newLoops and number of curves in each newloop have to correspond to loops number with the same loopType in element. To verify number of loops and their type use getLoops method. Currently you can not set arbitrary shape for analytical walls. For walls false will be returned.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when number of newLoops is different from number of current loops considering loopType. -or- Thrown when number of curves in each loop in newLoop don't correspond to number of curves in current loop. -or- Thrown when type of curves in newLoop differ from number of curves in current loop (eg. line changed to arc). -or- Thrown when length of any curve in newLoops is invalid. -or- Thrown when new loops intersect themselves or intersect with loops already set in analytical model.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AnalyticalModelSurface Class
Autodesk.Revit.DB.Structure Namespace