Revit 2013 API
IFCExtrusionCalculatorOptions Constructor
IFCExtrusionCalculatorOptions Class See Also
Constructs a new instance of a class used to calculate extrusions from Revit geometry.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IFCExtrusionCalculatorOptions(
    ExporterIFC exporterIFC,
    IFCExtrusionAxes extrusionAxes,
    XYZ customAxis,
    double scale
)
Visual Basic
Public Sub New ( _
    exporterIFC As ExporterIFC, _
    extrusionAxes As IFCExtrusionAxes, _
    customAxis As XYZ, _
    scale As Double _
)
Visual C++
public:
IFCExtrusionCalculatorOptions(
    ExporterIFC^ exporterIFC,
    IFCExtrusionAxes extrusionAxes,
    XYZ^ customAxis,
    double scale
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
extrusionAxes
Type: Autodesk.Revit.DB.IFC..::..IFCExtrusionAxes
The extrusion axes to try when doing the calculation.
customAxis
Type: Autodesk.Revit.DB..::..XYZ
The custom axis to try (if extrusionAxes includes an option for a custom direction).
scale
Type: System..::..Double
The scaling factor for length measurements from the default Revit units to the export units.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCExtrusionCalculatorOptions Class
Autodesk.Revit.DB.IFC Namespace