Revit 2013 API
ExporterIFC..::..GetLevelInfos Method
ExporterIFC Class See Also
Returns a collection containing the information about all levels in the document.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IDictionary<ElementId, IFCLevelInfo> GetLevelInfos()
Visual Basic
Public Function GetLevelInfos As IDictionary(Of ElementId, IFCLevelInfo)
Visual C++
public:
IDictionary<ElementId^, IFCLevelInfo^>^ GetLevelInfos()

Return Value

The collection of level information.

Remarks

Level information is currently automatically collected and cached in the ExporterIFC object. This method returns the cached information which is often needed during export of particular building elements which reference levels, as well as to implement automatic wall and column splitting.

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace