Revit 2013 API
MassSurfaceData..::..SurfaceDataSource Property
MassSurfaceData Class See Also
Indicates whether the MassSurfaceData properties are driven by the EnergyDataSettings of the Document or are overridden for the surface.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public MassSurfaceDataSource SurfaceDataSource { get; set; }
Visual Basic
Public Property SurfaceDataSource As MassSurfaceDataSource
    Get
    Set
Visual C++
public:
property MassSurfaceDataSource SurfaceDataSource {
    MassSurfaceDataSource get ();
    void set (MassSurfaceDataSource value);
}

Remarks

The Construction property is not governed by this setting and has a separate value to indicate if it is to be synchronized with EnergyDataSettings.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The surface data source does not fall within an appropriate range.

See Also

MassSurfaceData Class
Autodesk.Revit.DB.Analysis Namespace