Revit 2013 API
EnergyDataSettings..::..BuildingOperatingSchedule Property
EnergyDataSettings Class See Also
The operating schedule of the building used for conceptual model energy calculations.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public gbXMLBuildingOperatingSchedule BuildingOperatingSchedule { get; set; }
Visual Basic
Public Property BuildingOperatingSchedule As gbXMLBuildingOperatingSchedule
    Get
    Set
Visual C++
public:
property gbXMLBuildingOperatingSchedule BuildingOperatingSchedule {
    gbXMLBuildingOperatingSchedule get ();
    void set (gbXMLBuildingOperatingSchedule value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The building operating schedule does not fall within an appropriate range.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace