Revit 2013 API
Viewport Class
Members See Also
An element that establishes the placement of a view on a sheet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class Viewport : Element
Visual Basic
Public Class Viewport _
    Inherits Element
Visual C++
public ref class Viewport : public Element

Remarks

Viewports are used in Revit for purposes other than placement of views on sheets. Thus iteration of viewport elements in the model may locate viewports which are not assigned to sheets; you can use the SheetId property to filter these out.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..Viewport

See Also

Viewport Members