Revit 2013 API
Document..::..PathName Property
Document Class Example See Also
The fully qualified path of the document's disk file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string PathName { get; }
Visual Basic
Public ReadOnly Property PathName As String
    Get
Visual C++
public:
property String^ PathName {
    String^ get ();
}

Remarks

This string is empty if the project has not been saved or does not have a disk file associated with it yet.

Examples

CopyC#
string docPathName = document.PathName;
CopyVB.NET
Dim docPathName As String = document.PathName

See Also

Document Class