Revit 2013 API
ColumnAttachment..::..AddColumnAttachment Method
ColumnAttachment Class See Also
Attaches the column to the target. If an attachment already exists with the same "baseOrTop" value, no attachment is made.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static void AddColumnAttachment(
    Document doc,
    FamilyInstance column,
    Element target,
    int baseOrTop,
    ColumnAttachmentCutStyle cutColumnStyle,
    ColumnAttachmentJustification justification,
    double attachOffset
)
Visual Basic
Public Shared Sub AddColumnAttachment ( _
    doc As Document, _
    column As FamilyInstance, _
    target As Element, _
    baseOrTop As Integer, _
    cutColumnStyle As ColumnAttachmentCutStyle, _
    justification As ColumnAttachmentJustification, _
    attachOffset As Double _
)
Visual C++
public:
static void AddColumnAttachment(
    Document^ doc,
    FamilyInstance^ column,
    Element^ target,
    int baseOrTop,
    ColumnAttachmentCutStyle cutColumnStyle,
    ColumnAttachmentJustification justification,
    double attachOffset
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
The document containing column and target.
column
Type: Autodesk.Revit.DB..::..FamilyInstance
A column.
target
Type: Autodesk.Revit.DB..::..Element
A target element.
baseOrTop
Type: System..::..Int32
0 to attach the column base, 1 to attach the column top.
cutColumnStyle
Type: Autodesk.Revit.DB..::..ColumnAttachmentCutStyle
Control the handling of columns that intersect their targets.
justification
Type: Autodesk.Revit.DB..::..ColumnAttachmentJustification
Control the column extent in cases where the target is not a uniform height.
attachOffset
Type: System..::..Double
An additional offset for the bottom. If positive, the column base or top will be higher than the attachment point; if negative, lower.

Remarks

This method modifies both column and target elements.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | column is not a column that supports ColumnAttachments. -or- target is not a valid target for ColumnAttachments. -or- column already has an attachment at its base or top as specified by baseOrTop. -or- column already has an attachment to target.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | baseOrTop must be either 0 or 1. -or- The given value for attachOffset must be no more than 30000 feet in absolute value.

See Also

ColumnAttachment Class