Revit 2013 API
RebarShapeConstraintAngleFromFixedDir Constructor
RebarShapeConstraintAngleFromFixedDir Class See Also
Create an angular constraint.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public RebarShapeConstraintAngleFromFixedDir(
    ElementId paramId,
    int sign,
    UV direction
)
Visual Basic
Public Sub New ( _
    paramId As ElementId, _
    sign As Integer, _
    direction As UV _
)
Visual C++
public:
RebarShapeConstraintAngleFromFixedDir(
    ElementId^ paramId,
    int sign,
    UV^ direction
)

Parameters

paramId
Type: Autodesk.Revit.DB..::..ElementId
A Rebar Shape parameter of type UT_Angle.
sign
Type: System..::..Int32
The sign of the angle relative to the direction.
direction
Type: Autodesk.Revit.DB..::..UV
A fixed direction in UV-space.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | sign is not 1 or -1.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | direction has zero length.

See Also

RebarShapeConstraintAngleFromFixedDir Class
Autodesk.Revit.DB.Structure Namespace