Revit 2013 API
BuiltInFailures..::..RebarFailures Properties
BuiltInFailures..::..RebarFailures Class See Also

The BuiltInFailures..::..RebarFailures type exposes the following members.

Properties

Name | Description
BarDiameterTooLarge | Rebar Bar Diameter is too large.
BarTypeDoesNotAllowHooksOfCurrentShape | You have selected a Bar Type which does not allow the Hooks used by the current shape. Please select a different Shape / Bar Type combination, or change the Hook permissions for the desired Bar Type (see Hook Lengths under Rebar Bar properties).
BendDiameterTooLarge | Rebar Bend Diameter is too large.
BendDiameterTooSmall | Rebar Bend Diameter is too small.
CannotPlaceRebar | Can't find a host for Rebar.
CannotPlaceRebarWarn | Can't find a host for Rebar.
CoverTooLong | Rebar Cover length is too large for host thickness.
HideAllBarsInRebarSet | All Bars in Rebar Set have been hidden.
HostTopologyChange | A reinforced host has undergone a major change. The reinforcement must be removed.
IncompleteShape | Rebar Shape [Family Name] is not fully defined and cannot be loaded into the project.
InvalidRebarHost | Rebar can be placed only in Concrete Structural elements.
InvalidRebarHostFamilyCanHostRebarParam | Rebar can't be placed in this Generic Model element because rebar hosting is disabled in the family [Name].
InvalidRebarHostNonConcrete | Rebar can't be placed in a structural family unless its [Material Type] is [Concrete].
InvalidRebarHostNonStructural | Rebar can't be placed in a non-structural element.
InvalidRebarHostWrongCategory | Rebar can't be placed in a family of category [Name].
Inverted3dShape | The Rebar Shape XX cannot be inverted.
MaxHookExtensionMultiplierWarn | The maximum Hook Extension Multiplier value permitted is 99.
NoSurfPatternOnRebar | Rebar elements do not support surface patterns. The surface pattern associated with this material will not be displayed on the indicated Rebar Type.
OutOfPlaneBendDiameterTooSmall | The Out of Plane Bend Diameter for Rebar Shape XX is too small for Rebar Bar Type YY.
OutSideOfHost | Rebar is placed completely outside of its host.
RebarArrayTooShort | Rebar Set can't have coincident Bars.
RebarBendRadiusTooBig | Rebar Bend Radius is too big. Ignoring bend.
RebarBendRadiusTooBigWarn | Rebar Bend Radius is too big. Ignoring bend.
RebarConstraintWarning | Structural rebar have automatic constraints that may conflict with dimensional constraints. Using dimensional constraints with structural rebar is not recommended and should be avoided.\nGrouped structural rebar is the only exception to this recommendation, since the automatic constraints are removed on grouped rebar.
RebarHooksDontMatchShape | The Rebar's hooks do not match its Rebar Shape.
RebarIllegalBarType | There is Structural Rebar present in the project that no longer meet the criteria defined in Allowable Rebar Bar types parameter. Please review all existing Structural Rebar created with this Shape.
RebarNoMatchingHooks | The Rebar Shape '[Family Name]' has no matching hooks.
RebarShapeFailure | Can't solve Rebar Shape.
RebarSpacingTooSmall | Bar Spacing is too small.
RebarTooShortImperial | The minimum length of rebar shape is 1 inch.
RebarTooShortMetric | The minimum length of rebar shape is 25 mm.
SketchDimensionsRemoved | The sketch dimensions, that were used to create the sketch, have been removed from the completed rebar shape definition.
StandardHookBendDiameterTooLarge | Rebar Standard Hook Bend Diameter is too large.
StandardHookBendDiameterTooSmall | Rebar Standard Hook Bend Diameter is too small.
TooLargeNumberOfBars | Rebar Set must contain at most 1002 bar locations.
TooSmallNumberOfBars | Rebar Set must contain at least two bar locations.
TrySmallerBarType | Rebar Bend Diameter is too large. Try a smaller Bar Type.

See Also

BuiltInFailures..::..RebarFailures Class