Revit 2013 API
GeometryCreationUtilities Methods
GeometryCreationUtilities Class See Also

The GeometryCreationUtilities type exposes the following members.

Methods

 | Name | Description
 | CreateBlendGeometry | Creates a solid by blending two closed curve loops lying in non-coincident planes.
 | CreateExtrusionGeometry | Creates a solid by linearly extruding one or more closed coplanar curve loops.
 | CreateRevolvedGeometry | Creates a solid of revolution by revolving a set of closed curve loops around an axis by a specified angle.
 | CreateSweptBlendGeometry | Creates a solid by simultaneously sweeping and blending two or more closed planar curve loops along a single curve.
 | CreateSweptGeometry | Creates a solid by sweeping one or more closed coplanar curve loops along a path.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GeometryCreationUtilities Class