Revit 2013 API
LabelUtils..::..GetLabelFor Method (PipeLossMethodType, Document)
LabelUtils Class See Also
Gets user-visible names for PipeLossMethodType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static string GetLabelFor(
    PipeLossMethodType pipeLossMethodType,
    Document doc
)
Visual Basic
Public Shared Function GetLabelFor ( _
    pipeLossMethodType As PipeLossMethodType, _
    doc As Document _
) As String
Visual C++
public:
static String^ GetLabelFor(
    PipeLossMethodType pipeLossMethodType,
    Document^ doc
)

Parameters

pipeLossMethodType
Type: Autodesk.Revit.DB.Plumbing..::..PipeLossMethodType
The PipeLossMethodType to get the user-visible name.
doc
Type: Autodesk.Revit.DB..::..Document
The document from which to get the PipeLossMethodType.

Remarks

The name is obtained in the current Revit language.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when information for the input PipeLossMethodType cannot be found.

See Also

LabelUtils Class
GetLabelFor Overload