Revit 2013 API
PanelScheduleTemplate..::..IsValidPanelConfiguration Method
PanelScheduleTemplate Class See Also
Checks if given panel configuration is valid for given panel schedule type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static bool IsValidPanelConfiguration(
    PanelScheduleType scheduleType,
    PanelConfiguration configuration
)
Visual Basic
Public Shared Function IsValidPanelConfiguration ( _
    scheduleType As PanelScheduleType, _
    configuration As PanelConfiguration _
) As Boolean
Visual C++
public:
static bool IsValidPanelConfiguration(
    PanelScheduleType scheduleType,
    PanelConfiguration configuration
)

Parameters

scheduleType
Type: Autodesk.Revit.DB.Electrical..::..PanelScheduleType
The panel schedule type.
configuration
Type: Autodesk.Revit.DB.Electrical..::..PanelConfiguration
The given configuration to check.

Return Value

True if panel schedule template can have a valid configuration assigned, false otherwise.

Remarks

If the panel schedule type is branch panel, the valid panel configurations are:
PanelConfiguration::Enum::OneColumn
PanelConfiguration::Enum::TwoColumnsCircuitsAcross
PanelConfiguration::Enum::TwoColumnsCircuitsDown
If the panel schedule type is switchboard or data panel, the valid panel configuration is:
PanelConfiguration::Enum::OneColumn

See Also

PanelScheduleTemplate Class
Autodesk.Revit.DB.Electrical Namespace