Revit 2013 API
CompoundStructure..::..RemoveWallSweep Method
CompoundStructure Class See Also
Removes a single sweep or reveal from the compound structure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void RemoveWallSweep(
    WallSweepType wallSweepType,
    int id
)
Visual Basic
Public Sub RemoveWallSweep ( _
    wallSweepType As WallSweepType, _
    id As Integer _
)
Visual C++
public:
void RemoveWallSweep(
    WallSweepType wallSweepType,
    int id
)

Parameters

wallSweepType
Type: Autodesk.Revit.DB..::..WallSweepType
The type of a wall sweep.
id
Type: System..::..Int32
The id of the sweep or reveal to remove.

Remarks

No validation of input arguments is performed. If no reveal or sweep has the specified id, no action is performed.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is valid only vertically compound structures.

See Also

CompoundStructure Class