Revit 2013 API
ElementTransformUtils..::..MirrorElements Method
ElementTransformUtils Class See Also
Creates a mirrored copy of a set of elements about a given plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static void MirrorElements(
    Document document,
    ICollection<ElementId> elementsToMirror,
    Plane plane
)
Visual Basic
Public Shared Sub MirrorElements ( _
    document As Document, _
    elementsToMirror As ICollection(Of ElementId), _
    plane As Plane _
)
Visual C++
public:
static void MirrorElements(
    Document^ document,
    ICollection<ElementId^>^ elementsToMirror,
    Plane^ plane
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document that owns the elements.
elementsToMirror
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
The set of elements to mirror.
plane
Type: Autodesk.Revit.DB..::..Plane
The mirror plane.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | elementsToMirror cannot be mirrored. -or- The elementsToMirror is empty. -or- One or more elements in elementsToMirror do not exist in the document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ElementTransformUtils Class