Revit 2013 API
SpatialElementTag..::..Name Property
SpatialElementTag Class See Also
The name associated with the tag.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override string Name { set; }
Visual Basic
Public Overrides WriteOnly Property Name As String
    Set
Visual C++
public:
virtual property String^ Name {
    void set (String^ value) override;
}

Remarks

This overrides Element.Name to allow the API to prevent modifications to the tag's name (because this is not permitted to be modified in the Autodesk Revit UI).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when attempting to set this property, as the name of the tag may not be changed.

See Also

SpatialElementTag Class