Revit 2013 API
AssetProperties Members
AssetProperties Class Methods Properties See Also

The AssetProperties type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item[([( Int32])]) |
Public property | Item[([( String])]) | Gets the one property that the current object contains with the given name.
Public property | Name | Get the name of the AssetProperty; (Inherited from AssetProperty.)
Public property | Size | Gets the number of the AssetProperty(s) in the object.
Public property | Type | Returns the Type of the AssetProperty; (Inherited from AssetProperty.)

See Also

AssetProperties Class
Autodesk.Revit.Utility Namespace