Revit 2013 API
FabricSheetType Properties
FabricSheetType Class See Also

The FabricSheetType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | MajorDirectionWireType | Determines which "Fabric Wire" type will be used in the major direction.
Public property | MajorEndOverhang | Determines the distance from the edge of the sheet to the last wire (measured in the major direction).
Public property | MajorLapSpliceLength | Defines the internal snapping for single fabric placement.
Public property | MajorLayoutPattern | Identifies the layout pattern of Fabric Sheet.
Public property | MajorNumberOfWires | Determines the number of wires used in the major direction (includes the 1st and last wires).
Public property | MajorReinforcementArea | Area of fabric divided by the spacing of the wire.
Public property | MajorSpacing | Determines the spacing between the wires (not including the overhangs).
Public property | MajorStartOverhang | Determines the distance from the edge of the sheet to the 1st wire (measured in the major direction).
Public property | Material | Defines wire material ElementId of the Fabric Sheet
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MinorDirectionWireType | Determines which "Fabric Wire" type will be used in the minor direction.
Public property | MinorEndOverhang | Determines the distance from the edge of the sheet to the last wire (measured in the minor direction).
Public property | MinorLapSpliceLength | Defines the internal snapping for single fabric placement.
Public property | MinorLayoutPattern | Identifies the layout pattern of Fabric Sheet.
Public property | MinorNumberOfWires | Determines the number of wires used in the minor direction (includes the 1st and last wires).
Public property | MinorReinforcementArea | Area of Wire / Spacing of Wire.
Public property | MinorSpacing | Determines the spacing between the wires (not including the overhangs).
Public property | MinorStartOverhang | Determines the distance from the edge of the sheet to the 1st wire (measured in the minor direction).
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OverallLength | Determines the length of the wire sheet (including overhangs) in the major direction.
Public property | OverallWidth | Determines the length of the wire sheet (including overhangs) in the minor direction.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | PhysicalMaterialAsset | Defines Physical Material Asset.
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SheetMass | Defines sheet mass.
Public property | SheetMassUnit | Defines sheet mass per area unit.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

FabricSheetType Class
Autodesk.Revit.DB.Structure Namespace