Revit 2013 API
ElementType Class
Members See Also
Base class for all Types within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class ElementType : Element
Visual Basic
Public Class ElementType _
    Inherits Element
Visual C++
public ref class ElementType : public Element

Remarks

Element types are usually non user visible elements that define instances. For example a wall type is a type that is not visible until an instance of the wall is created.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB.Analysis..::..ConceptualConstructionType
Autodesk.Revit.DB.Architecture..::..ContinuousRailType
Autodesk.Revit.DB.Architecture..::..CutMarkType
Autodesk.Revit.DB.Architecture..::..RailingType
Autodesk.Revit.DB.Architecture..::..StairsLandingType
Autodesk.Revit.DB.Architecture..::..StairsPathType
Autodesk.Revit.DB.Architecture..::..StairsRunType
Autodesk.Revit.DB.Architecture..::..StairsType
Autodesk.Revit.DB..::..AssemblyType
Autodesk.Revit.DB..::..BeamSystemType
Autodesk.Revit.DB..::..CADLinkType
Autodesk.Revit.DB..::..DimensionType
Autodesk.Revit.DB.Electrical..::..DistributionSysType
Autodesk.Revit.DB.Electrical..::..InsulationType
Autodesk.Revit.DB.Electrical..::..TemperatureRatingType
Autodesk.Revit.DB.Electrical..::..VoltageType
Autodesk.Revit.DB.Electrical..::..WireMaterialType
Autodesk.Revit.DB.Electrical..::..WireType
Autodesk.Revit.DB..::..GroupType
Autodesk.Revit.DB..::..HostObjAttributes
Autodesk.Revit.DB..::..InsertableObject
Autodesk.Revit.DB..::..LineAndTextAttrSymbol
Autodesk.Revit.DB.Mechanical..::..DuctInsulationType
Autodesk.Revit.DB.Mechanical..::..DuctLiningType
Autodesk.Revit.DB.Mechanical..::..MEPBuildingConstruction
Autodesk.Revit.DB..::..MEPSystemType
Autodesk.Revit.DB..::..ModelTextType
Autodesk.Revit.DB.Plumbing..::..FluidType
Autodesk.Revit.DB.Plumbing..::..PipeConnectionType
Autodesk.Revit.DB.Plumbing..::..PipeInsulationType
Autodesk.Revit.DB.Plumbing..::..PipeMaterialType
Autodesk.Revit.DB.Plumbing..::..PipeScheduleType
Autodesk.Revit.DB..::..PointCloudType
Autodesk.Revit.DB..::..RevitLinkType
Autodesk.Revit.DB..::..SiteLocation
Autodesk.Revit.DB.Structure..::..AnalyticalLinkType
Autodesk.Revit.DB.Structure..::..AreaReinforcementType
Autodesk.Revit.DB.Structure..::..FabricAreaType
Autodesk.Revit.DB.Structure..::..FabricSheetType
Autodesk.Revit.DB.Structure..::..FabricWireType
Autodesk.Revit.DB.Structure..::..LoadTypeBase
Autodesk.Revit.DB.Structure..::..PathReinforcementType
Autodesk.Revit.DB.Structure..::..RebarBarType
Autodesk.Revit.DB.Structure..::..RebarCoverType
Autodesk.Revit.DB.Structure..::..RebarHookType
Autodesk.Revit.DB.Structure..::..RebarShape
Autodesk.Revit.DB.Structure..::..StructuralConnectionType
Autodesk.Revit.DB..::..TilePattern
Autodesk.Revit.DB..::..ViewFamilyType

See Also

ElementType Members