Revit 2013 API
ExternalService Members
ExternalService Class Methods Properties See Also

The ExternalService type exposes the following members.

Methods

 | Name | Description
Public method | AddServer | Registers a server with its service.
Public method | Dispose | Releases all resources used by the ExternalService
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetDefaultServerId | Returns the Id of the default server if one was assigned to the service.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRegisteredServerIds | Returns Ids of all servers registered for the service.
Public method | GetServer | Returns the instance that provides implementation for a registered server.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsRegisteredServerId | Checks if the Id represents a valid server that have been registered for the service.
Public method | RemoveServer | Removes/unregisters a server from the service.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Description | The description for the service
Public property | IsSerializable | Indicates whether executions of the service requires serialization in documents or not.
Public property | Name | The name of the service
Public property | NumberOfServers | Indicates the number of servers currently registered with the service.
Public property | ServiceId | The Id of the service
Public property | VendorId | The vendor who provided the service

See Also

ExternalService Class
Autodesk.Revit.DB.ExternalService Namespace