Revit 2013 API
ExporterIFCUtils..::..UsesInstanceGeometry Method
ExporterIFCUtils Class See Also
Identifies if the family instance has its own geometry, or uses the symbol's geometry with a transform.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static bool UsesInstanceGeometry(
    FamilyInstance familyInstance
)
Visual Basic
Public Shared Function UsesInstanceGeometry ( _
    familyInstance As FamilyInstance _
) As Boolean
Visual C++
public:
static bool UsesInstanceGeometry(
    FamilyInstance^ familyInstance
)

Parameters

familyInstance
Type: Autodesk.Revit.DB..::..FamilyInstance
The family instance.

Return Value

True if the instance has its own geometry. False if the symbol's geometry is used.

Remarks

A Family Instance can have its own copy of geometry, or use the symbol's geometry with a transform. This method identifies the source of this family instance's geometry.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace