Revit 2013 API
EnergyAnalysisSurface..::..Id Property
EnergyAnalysisSurface Class See Also
The unique identifier for the surface.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public string Id { get; }
Visual Basic
Public ReadOnly Property Id As String
    Get
Visual C++
public:
property String^ Id {
    String^ get ();
}

Remarks

This identification attribute is composed of the prefix "su" and a sequential number, separated by "-". A sample value would be "su-1".

See Also

EnergyAnalysisSurface Class
Autodesk.Revit.DB.Analysis Namespace