Revit 2013 API
AnalysisDisplayVectorSettings Members
AnalysisDisplayVectorSettings Class Constructors Methods Properties See Also

The AnalysisDisplayVectorSettings type exposes the following members.

Constructors

 | Name | Description
Public method | AnalysisDisplayVectorSettings()()()() | Constructs a default instance of vector settings.
Public method | AnalysisDisplayVectorSettings(AnalysisDisplayVectorSettings) | Constructs a copy of vector settings object.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the AnalysisDisplayVectorSettings
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual | Compares two vector settings objects.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ArrowheadScale | Type of arrow head scaling.
Public property | ArrowLineWeight | Line weight assigned to arrow lines for vectors.
Public property | Rounding | Increment to which numeric values of analysis results are rounded in vectors.
Public property | TextTypeId | Element id of text associated with the settings.
Public property | VectorOrientation | Vector orientation.
Public property | VectorPosition | Vector position.
Public property | VectorTextType | Type of vector text visualization.

See Also

AnalysisDisplayVectorSettings Class
Autodesk.Revit.DB.Analysis Namespace