Revit 2013 API
ScheduleDefinition..::..AddSortGroupField Method
ScheduleDefinition Class See Also
Adds a new sorting/grouping field at the end of the list.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void AddSortGroupField(
    ScheduleSortGroupField sortGroupField
)
Visual Basic
Public Sub AddSortGroupField ( _
    sortGroupField As ScheduleSortGroupField _
)
Visual C++
public:
void AddSortGroupField(
    ScheduleSortGroupField^ sortGroupField
)

Parameters

sortGroupField
Type: Autodesk.Revit.DB..::..ScheduleSortGroupField
The sorting/grouping field to add.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The field ID is not the ID of a field in this ScheduleDefinition. -or- The field cannot be used for sorting/grouping.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | The resulting sorting/grouping field count would be greater than 4.

See Also

ScheduleDefinition Class