Revit 2013 API
EnergyDataSettings..::..OutsideAirChangesRatePerHour Property
EnergyDataSettings Class See Also

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public double OutsideAirChangesRatePerHour { get; set; }
Visual Basic
Public Property OutsideAirChangesRatePerHour As Double
    Get
    Set
Visual C++
public:
property double OutsideAirChangesRatePerHour {
    double get ();
    void set (double value);
}

Remarks

Air Changes per hour is "unitless". It is a number. It is the number of times the air (the volume) interchanges in the room in one hour. This number is a format for expressing the requirement for airflow. The "flow" requirement for a room might be expressed, e.g., one room of 100 CF, and 3 Air Changes per Hour (ACH), would compute to 100 CF x 3 ACH / 60 min = 5 CFM.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The outside airChangesRatePerHour does not fall within an appropriate range.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace