Revit 2013 API
PropertySetLibrary..::..Find Method
PropertySetLibrary Class See Also
Finds an existing PropertySetLibrary with a given name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static ElementId Find(
    Document doc,
    string name
)
Visual Basic
Public Shared Function Find ( _
    doc As Document, _
    name As String _
) As ElementId
Visual C++
public:
static ElementId^ Find(
    Document^ doc,
    String^ name
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
The document in which to look for PropertySetLibrary elements with the given name.
name
Type: System..::..String
The name to search for.

Return Value

Identifier of the PropertySetLibrary with the given name, or invalidElementId if no library with that name exists.

Remarks

The search is case-insensitive.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PropertySetLibrary Class