Revit 2013 API
IFCProductWrapper..::..FindExtrusionCreationParameters Method
IFCProductWrapper Class See Also
Obtains the extrusion creation data associated with the given element.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IFCExtrusionCreationData FindExtrusionCreationParameters(
    IFCAnyHandle elementHandle
)
Visual Basic
Public Function FindExtrusionCreationParameters ( _
    elementHandle As IFCAnyHandle _
) As IFCExtrusionCreationData
Visual C++
public:
IFCExtrusionCreationData^ FindExtrusionCreationParameters(
    IFCAnyHandle^ elementHandle
)

Parameters

elementHandle
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The handle.

Return Value

The parameters. nullNothingnullptra null reference (Nothing in Visual Basic) if no parameters are associated with the element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCProductWrapper Class
Autodesk.Revit.DB.IFC Namespace