Revit 2013 API
Stairs..::..DesiredRisersNumber Property
Stairs Class See Also
The number of risers is calculated based on the height between levels.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int DesiredRisersNumber { get; set; }
Visual Basic
Public Property DesiredRisersNumber As Integer
    Get
    Set
Visual C++
public:
property int DesiredRisersNumber {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The numberOfRisers is a not positive value.

See Also

Stairs Class
Autodesk.Revit.DB.Architecture Namespace