Revit 2013 API
FailureDefinition..::..AddResolutionType Method
FailureDefinition Class See Also
Adds a type of possible resolution for the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FailureDefinition AddResolutionType(
    FailureResolutionType type,
    string caption,
    Type classOfResolution
)
Visual Basic
Public Function AddResolutionType ( _
    type As FailureResolutionType, _
    caption As String, _
    classOfResolution As Type _
) As FailureDefinition
Visual C++
public:
FailureDefinition^ AddResolutionType(
    FailureResolutionType type,
    String^ caption,
    Type^ classOfResolution
)

Parameters

type
Type: Autodesk.Revit.DB..::..FailureResolutionType
Type of the resolution to add. The type of resolution can be used only once for the FailureDefinition.
caption
Type: System..::..String
A simple description of the resolution.
classOfResolution
Type: System..::..Type
The runtime class of the resolution. Used to ensure that the actual FailureResoution object added to the instance of FailureMessage belongs to an applicable class.

Return Value

The FailureDefinition.

Remarks

In order to inform Revit what failure resolutions can be possibly used with a given failure, a FailureDefinition must contain a full list of resolution types applicable to the failure, including user-visible caption and runtime class of the resolution. The number of resolutions is not limited. The first added resolution becomes the default resolution.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The type has already been added as a resolution to the FailureDefinition. -or- The input classOfResolution is not a subclass of FailureResolution.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FailureDefinition Class