Revit 2013 API
DividedPath..::..MeasurementType Property
DividedPath Class See Also
The measurement type determines how distances are calculated. Either along a straight line between two points ('ChordLength') or along the segment of the path that connects them. ('SegmentLength').

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public DividedPathMeasurementType MeasurementType { get; set; }
Visual Basic
Public Property MeasurementType As DividedPathMeasurementType
    Get
    Set
Visual C++
public:
property DividedPathMeasurementType MeasurementType {
    DividedPathMeasurementType get ();
    void set (DividedPathMeasurementType value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: Invalid measurementType

See Also

DividedPath Class