Revit 2013 API
ExternalEvent..::..IsPending Property
ExternalEvent Class See Also
Checking whether an event has been raised but not yet executed.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsPending { get; }
Visual Basic
Public ReadOnly Property IsPending As Boolean
    Get
Visual C++
public:
property bool IsPending {
    bool get ();
}

Remarks

When en event is requested to raise it is not executed immediatelly; instead, it waits for the next possible opportunity, which is determined by various internal conditions in Revit (policy similar to invoking external commands). When the opportunity comes, the event is executed by calling the event's handler. In the meantime, the event is 'Pending'.

See Also

ExternalEvent Class
Autodesk.Revit.UI Namespace