Revit 2013 API
CableTray..::..RungSpace Property
CableTray Class See Also

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double RungSpace { get; set; }
Visual Basic
Public Property RungSpace As Double
    Get
    Set
Visual C++
public:
property double RungSpace {
    double get ();
    void set (double value);
}

Remarks

Distance between two rungs for the ladder cable tray. This should be positive.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The rung space value should be at least equal to or larger than rang width which is 1 inch.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Mechanical Electrical Piping.

See Also

CableTray Class
Autodesk.Revit.DB.Electrical Namespace