Revit 2013 API
UIView..::..ZoomAndCenterRectangle Method
UIView Class See Also
Zoom and center the view to a specified rectangle.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void ZoomAndCenterRectangle(
    XYZ viewCorner1,
    XYZ viewCorner2
)
Visual Basic
Public Sub ZoomAndCenterRectangle ( _
    viewCorner1 As XYZ, _
    viewCorner2 As XYZ _
)
Visual C++
public:
void ZoomAndCenterRectangle(
    XYZ^ viewCorner1,
    XYZ^ viewCorner2
)

Parameters

viewCorner1
Type: Autodesk.Revit.DB..::..XYZ
A corner of the desired view rectangle in model coordinates.
viewCorner2
Type: Autodesk.Revit.DB..::..XYZ
The opposite corner of the desired view rectangle in model coordinates.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The view corner points must differ when projected onto a plane perpendicular to the view direction.

See Also

UIView Class
Autodesk.Revit.UI Namespace