Revit 2013 API
IFCAnyHandle Members
IFCAnyHandle Class Methods Operators Properties See Also

The IFCAnyHandle type exposes the following members.

Methods

 | Name | Description
Public method | CreateAggregateAttribute | Creates an attribute that is an aggregate.
Public method | Delete | Deletes the handle.
Public method | Dispose | Releases all resources used by the IFCAnyHandle
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | GetAttribute | Gets the attribute by name.
Public method | GetHashCode | Gets the integer value of the id as hash code; (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsSubTypeOf | Determines whether the instance is an instance of the specified instance type or a subtype of this instance type.
Public method | IsTypeOf | Determines whether the instance is an instance of exactly the specified instance type.
Public method | SetAttribute(String, IFCAnyHandle) | Sets the attribute value.
Public method | SetAttribute(String, IFCData) | Sets the attribute value.
Public method | SetAttribute(String, Boolean) | Sets the attribute value.
Public method | SetAttribute(String, ICollection<(Of <<'(IFCAnyHandle>)>>)) | Sets the attribute value.
Public method | SetAttribute(String, ICollection<(Of <<'(Boolean>)>>)) | Sets the attribute value.
Public method | SetAttribute(String, ICollection<(Of <<'(Double>)>>)) | Sets the attribute value.
Public method | SetAttribute(String, ICollection<(Of <<'(Int32>)>>)) | Sets the attribute value.
Public method | SetAttribute(String, ICollection<(Of <<'(String>)>>)) | Sets the attribute value.
Public method | SetAttribute(String, Double) | Sets the attribute value.
Public method | SetAttribute(String, Int32) | Sets the attribute value.
Public method | SetAttribute(String, String) | Sets the attribute value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Unset | Clears the handle.
Public method | UnsetAttribute | Unsets the attribute value.

Operators

Name | Description
Equality | Determines whether two IFCAnyHandles are the same.
Inequality | Determines whether two IFCAnyHandles are different.

Properties

 | Name | Description
Public property | HasValue | Identifies if the handle is empty or contains a value.
Public property | Id | The integer identifier for the handle.
Public property | TypeName | The name of the type of the handle.

See Also

IFCAnyHandle Class
Autodesk.Revit.DB.IFC Namespace