Revit 2013 API
MEPModel..::..AssignedElectricalSystems Property
MEPModel Class See Also
Retrieves the electrical systems this electrical panel currently is assigned to.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElectricalSystemSet AssignedElectricalSystems { get; }
Visual Basic
Public ReadOnly Property AssignedElectricalSystems As ElectricalSystemSet
    Get
Visual C++
public:
property ElectricalSystemSet^ AssignedElectricalSystems {
    ElectricalSystemSet^ get ();
}

Remarks

This property returns a set of Electrical Systems. If there are no electrical systems created for this model, this property will be an empty set.

See Also

MEPModel Class