Revit 2013 API
ExternalFileReference..::..IsValidExternalFileReference Method
ExternalFileReference Class See Also
Checks an ExternalFileReference to see if it is properly created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static bool IsValidExternalFileReference(
    ExternalFileReference data
)
Visual Basic
Public Shared Function IsValidExternalFileReference ( _
    data As ExternalFileReference _
) As Boolean
Visual C++
public:
static bool IsValidExternalFileReference(
    ExternalFileReference^ data
)

Parameters

data
Type: Autodesk.Revit.DB..::..ExternalFileReference
The ExternalFileReference to be checked

Remarks

The following restrictions exist:
  • PathType.Server is only valid for ExternalFileReferences of type ExternalFileReferenceType.RevitLink
  • PathType.Content is only valid for ExternalFileReferences of type ExternalFileReferenceType.KeynoteTable or ExternalFileReferenceType.Decal
  • Keynote tables and Decals (ExternalFileReferenceType.KeynoteTable and ExternalFileReferenceType.Decal) may only be LinkedFileStatus.Loaded or LinkedFileStatus.NotFound.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExternalFileReference Class