Revit 2013 API
EnergyAnalysisDetailModel..::..Destroy Method
EnergyAnalysisDetailModel Class See Also
Delete the created analytical model and the analytical elements such as spaces, surfaces, and openings.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static void Destroy(
    EnergyAnalysisDetailModel model
)
Visual Basic
Public Shared Sub Destroy ( _
    model As EnergyAnalysisDetailModel _
)
Visual C++
public:
static void Destroy(
    EnergyAnalysisDetailModel^ model
)

Parameters

model
Type: Autodesk.Revit.DB.Analysis..::..EnergyAnalysisDetailModel
The model will be destroyed.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

EnergyAnalysisDetailModel Class
Autodesk.Revit.DB.Analysis Namespace