Revit 2013 API
Document..::..NewLoadNature Method
Document Class Example See Also
Creates a new instance of a LoadNature element within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public LoadNature NewLoadNature(
    string name
)
Visual Basic
Public Function NewLoadNature ( _
    name As String _
) As LoadNature
Visual C++
public:
LoadNature^ NewLoadNature(
    String^ name
)

Parameters

name
Type: System..::..String
The name for the Load Nature Element to create.

Return Value

If successful and there isn't the Load Nature Element with the same name NewLoadNature returns an object for the newly created LoadNature. If such element exist it returns existing element. nullNothingnullptra null reference (Nothing in Visual Basic) is returned if the operation fails.

Examples

CopyC#
// Create a new load nature.
LoadNature nature = document.Create.NewLoadNature("New Nature");
if (null == nature)
{
    throw new Exception("Create a new load nature failed.");
}
CopyVB.NET
' Create a new load nature.
Dim nature As LoadNature = document.Create.NewLoadNature("New Nature")
If nature Is Nothing Then
    Throw New Exception("Create a new load nature failed.")
End If

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | If the product is not Revit Structure.

See Also

Document Class
Autodesk.Revit.Creation Namespace