Revit 2013 API
BuiltInFailures..::..LoadFailures Members
BuiltInFailures..::..LoadFailures Class Properties See Also

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..LoadFailures type exposes the following members.

Properties

Name | Description
CannotMirrorBoundaryCondition | Can't mirror Boundary Conditions
CannotMirrorHostedLoad | Can't mirror Load based on the Host Element.
CannotMirrorLoad | Can't mirror Load because mirror plane is not perpendicular to sketch plane.
CannotPlaceBoundaryConditions | Can't find a host for Boundary Conditions
CannotPlaceBoundaryConditionsWarn | Can't find a host for Boundary Conditions
CannotRotateLoad | Can't rotate Load because rotation axis is not perpendicular to sketch plane.
HostChangeDisallowsLoadOrBoundaryConditions | Some Hosted Loads or BoundaryConditions lost their References. They will be deleted.
LineLoadAllZero | Line Load can't have all force components and moment components to be zero.
PointLoadAllZero | Point Load can't have all force components and moment components to be zero.

See Also

BuiltInFailures..::..LoadFailures Class