Revit 2013 API
BoundingBoxXYZ..::..BoundEnabled Property
BoundingBoxXYZ Class See Also
Indexed access for loops.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool this[
    int bound,
    int dim
] { get; set; }
Visual Basic
Public Property BoundEnabled ( _
    bound As Integer, _
    dim As Integer _
) As Boolean
    Get
    Set
Visual C++
public:
property bool BoundEnabled[int bound, int dim] {
    bool get (int bound, int dim);
    void set (int bound, int dim, bool value);
}

Parameters

bound
Type: System..::..Int32
dim
Type: System..::..Int32

Remarks

For bound, use 0 for Min and 1 for Max. For dimension, use 0 for X, 1 for Y and 2 for Z. The entire box must be enabled to enable individual bounds.

See Also

BoundingBoxXYZ Class