Revit 2013 API
DocumentPreviewSettings..::..ForceViewUpdate Method
DocumentPreviewSettings Class See Also
Sets Revit to update the preview view if necessary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void ForceViewUpdate(
    bool forceViewUpdate
)
Visual Basic
Public Sub ForceViewUpdate ( _
    forceViewUpdate As Boolean _
)
Visual C++
public:
void ForceViewUpdate(
    bool forceViewUpdate
)

Parameters

forceViewUpdate
Type: System..::..Boolean
True to force update of the preview view. False to skip update if necessary (the default).

Remarks

An update is necessary if the view has never been displayed, or if the model has been changed and the view has not been updated or accessed. If the preview view has not been updated, the preview may not be properly saved.

This setting applies only to a single Save operation and is reset to false after it is accessed.

See Also

DocumentPreviewSettings Class