Revit 2013 API
ViewOrientation3D Constructor
ViewOrientation3D Class See Also
Initializes a new instance of the ViewOrientation3D class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ViewOrientation3D(
    XYZ eyePosition,
    XYZ upDirection,
    XYZ forwardDirection
)
Visual Basic
Public Sub New ( _
    eyePosition As XYZ, _
    upDirection As XYZ, _
    forwardDirection As XYZ _
)
Visual C++
public:
ViewOrientation3D(
    XYZ^ eyePosition,
    XYZ^ upDirection,
    XYZ^ forwardDirection
)

Parameters

eyePosition
Type: Autodesk.Revit.DB..::..XYZ
The eye position
upDirection
Type: Autodesk.Revit.DB..::..XYZ
The up direction. This vector will be normalized. Up direction must be perpendicular to the forward direction.
forwardDirection
Type: Autodesk.Revit.DB..::..XYZ
The forward direction. This vector will be normalized. Forward direction must be perpendicular to the up direction.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | One or both of the input vectors cannot be normalized.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | upDirection has zero length. -or- forwardDirection has zero length.
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | The vectors upDirection and forwardDirection are not perpendicular.

See Also

ViewOrientation3D Class