Revit 2013 API
RebarShapeDefinitionBySegments..::..RemoveParameterFromSegment Method
RebarShapeDefinitionBySegments Class See Also
Remove constraints from an edge.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void RemoveParameterFromSegment(
    int iSegment,
    ElementId paramId
)
Visual Basic
Public Sub RemoveParameterFromSegment ( _
    iSegment As Integer, _
    paramId As ElementId _
)
Visual C++
public:
void RemoveParameterFromSegment(
    int iSegment,
    ElementId^ paramId
)

Parameters

iSegment
Type: System..::..Int32
Index of the segment (0 to NumberOfSegments - 1).
paramId
Type: Autodesk.Revit.DB..::..ElementId
Id of a parameter driving one or more constraints.

Remarks

This reverses the effect of any AddConstraint and SetSegmentAs180DegreeBend operations involving the specified segment and parameter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | iSegment is not between 0 and NumberOfEdges. -or- paramId is not the id of a shared parameter in the current document, or its unit type is not UT_Length or UT_Angle.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.DB.Structure Namespace