Revit 2013 API
XYZ..::..Item Property
XYZ Class See Also
Indexed access to coordinates.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double this[
    int idx
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    idx As Integer _
) As Double
    Get
Visual C++
public:
property double default[int idx] {
    double get (int idx);
}

Parameters

idx
Type: System..::..Int32
Use 0 for X, 1 for Y and 2 for Z.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when an attempt is made to access the coordinate with an index that is larger than 2.

See Also

XYZ Class