Revit 2013 API
EnergyDataSettings..::..EnergyModel Property
EnergyDataSettings Class See Also
if this is on there should be an energy model dependent on the current AnalysisType if it is off the conceptual energy model should be turned off but setting this datum does not do the work, just reflects the state.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool EnergyModel { get; set; }
Visual Basic
Public Property EnergyModel As Boolean
    Get
    Set
Visual C++
public:
property bool EnergyModel {
    bool get ();
    void set (bool value);
}

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace