Revit 2013 API
Form..::..AddEdge Method (Reference, XYZ)
Form Class See Also
Add an edge to the form, connecting two edges on different profiles, by a specified face of the form and a point on face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void AddEdge(
    Reference faceReference,
    XYZ point
)
Visual Basic
Public Sub AddEdge ( _
    faceReference As Reference, _
    point As XYZ _
)
Visual C++
public:
void AddEdge(
    Reference^ faceReference,
    XYZ^ point
)

Parameters

faceReference
Type: Autodesk.Revit.DB..::..Reference
The geometry reference of face
point
Type: Autodesk.Revit.DB..::..XYZ
A point on the face, defining the position of edge to be created.

See Also

Form Class
AddEdge Overload