Revit 2013 API
FailureHandlingOptions Methods
FailureHandlingOptions Class See Also

The FailureHandlingOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetClearAfterRollback | Checks if all posted failures should be removed silently when transaction is being rolled back.
Public method | GetDelayedMiniWarnings | Checks if showing of mini-warning dialog should be delayed till the end of next transaction.
Public method | GetFailuresPreprocessor | Getting a callback to be invoked in the beginning of failure processing.
Public method | GetForcedModalHandling | Checks if error handling dialog at the end of transaction should be modal.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTransactionFinalizer | Getting a callback to be executed after transaction is completed.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetClearAfterRollback | Set the flag to clear all posted failures silently if transaction is being rolled back intentionally and delivering failures to the user is not desired.
Public method | SetDelayedMiniWarnings | Set the flag to delay showing of mini-warning dialog (if one is to be shown as a result of warnings in the current transaction) till the end of next transaction.
Public method | SetFailuresPreprocessor | Setting a callback to be invoked in the beginning of failure processing.
Public method | SetForcedModalHandling | Set the flag whether it pops modal error dialog if the transaction failed to finish.
Public method | SetTransactionFinalizer | Setting a callback to be executed after transaction is completed.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FailureHandlingOptions Class