Revit 2013 API
StairsLanding..::..CreateSketchedLanding Method
StairsLanding Class See Also
Creates a customized landing between two runs by providing the closed boundary curves of the landing.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static StairsLanding CreateSketchedLanding(
    Document document,
    ElementId stairsId,
    CurveLoop curveLoop,
    double baseElevation
)
Visual Basic
Public Shared Function CreateSketchedLanding ( _
    document As Document, _
    stairsId As ElementId, _
    curveLoop As CurveLoop, _
    baseElevation As Double _
) As StairsLanding
Visual C++
public:
static StairsLanding^ CreateSketchedLanding(
    Document^ document,
    ElementId^ stairsId,
    CurveLoop^ curveLoop,
    double baseElevation
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document that owns the landing.
stairsId
Type: Autodesk.Revit.DB..::..ElementId
The stairs that the new sketched landing belongs to.
curveLoop
Type: Autodesk.Revit.DB..::..CurveLoop
The closed boundary curves of the new landing.
baseElevation
Type: System..::..Double
Base elevation of the new stairs run. The elevation has following restriction:
  • The base elevation is relative to the base elevation of the stairs.
  • The base elevation will be rounded automatically to a multiple of the riser height.
  • The base elevation should be equal to or greater than half of the riser height.

Return Value

The new sketched landing.

Remarks

The new stairs landing and the document will be regenerated. This should be run from within an open transaction.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The element stairsId does not exist in the document -or- The stairsId is not a valid stairs element. -or- -or- Failed to create curve element by the curveLoop.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The given value for baseElevation must be no more than 30000 feet in absolute value. -or- The baseElevation is less than half of the riser height of the stairs.
Autodesk.Revit.Exceptions..::..InvalidOperationException | The stairs element represented by stairsId is not in an active StairsEditScope. New components cannot be added to it.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.
Autodesk.Revit.Exceptions..::..RegenerationFailedException | The curveLoop doesn't satisfy restrictions to generate sketched landing.

See Also

StairsLanding Class
Autodesk.Revit.DB.Architecture Namespace