Revit 2013 API
ReferenceIntersector Methods
ReferenceIntersector Class See Also

The ReferenceIntersector type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Find | Projects a ray from the origin along the given direction, and returns all references from intersected elements which match the ReferenceIntersector’s criteria.
Public method | FindNearest | Projects a ray from the origin along the given direction, and returns all references from intersected elements which match the ReferenceIntersector’s criteria.
Public method | GetFilter | Gets the ElementFilter used in intersection testing
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTargetElementIds | Gets the set of ElementIds to test from in intersection testing
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetFilter | Sets the ElementFilter used in intersection testing
Public method | SetTargetElementIds | Sets the set of ElementIds to test from in intersection testing
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReferenceIntersector Class