Revit 2013 API
DocumentPreviewSettings Members
DocumentPreviewSettings Class Methods Properties See Also

The DocumentPreviewSettings type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the DocumentPreviewSettings
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForceViewUpdate | Sets Revit to update the preview view if necessary.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsViewIdValidForPreview | Identifies if the view id is valid as a preview view id.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsViewUpdateForced | Identifies if Revit will update the preview view if necessary.
Public property | PreviewViewId | The view id that will be used to generate the preview.

See Also

DocumentPreviewSettings Class