Revit 2013 API
AnalyticalModelSelector Members
AnalyticalModelSelector Class Constructors Methods Properties See Also

The AnalyticalModelSelector type exposes the following members.

Constructors

 | Name | Description
Public method | AnalyticalModelSelector()()()() | Creates a selector for the analytical model geometry.
Public method | AnalyticalModelSelector(AnalyticalCurveSelector) | Creates a selector for the analytical model geometry.
Public method | AnalyticalModelSelector(Curve) | Creates a selector based on a specific analytical curve.
Public method | AnalyticalModelSelector(Curve, AnalyticalCurveSelector) | Creates a selector based on one portion of a specific analytical curve.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the AnalyticalModelSelector
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CurveSelector |

See Also

AnalyticalModelSelector Class
Autodesk.Revit.DB.Structure Namespace