Revit 2013 API
RebarBarType..::..Create Method
RebarBarType Class See Also
Creates a new RebarBarType object

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static RebarBarType Create(
    Document ADoc
)
Visual Basic
Public Shared Function Create ( _
    ADoc As Document _
) As RebarBarType
Visual C++
public:
static RebarBarType^ Create(
    Document^ ADoc
)

Parameters

ADoc
Type: Autodesk.Revit.DB..::..Document

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural.

See Also

RebarBarType Class
Autodesk.Revit.DB.Structure Namespace