Revit 2013 API
DocumentEntryPoint Methods
DocumentEntryPoint Class See Also

The DocumentEntryPoint type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FinishInitializationEO | For Revit Macros internal use only.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOpenUIViews |
 | GetRevitUIFamilyLoadOptions |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | For Revit Macros internal use only.
Public method | OnShutdownEO | For Revit Macros internal use only.
Public method | PromptForFamilyInstancePlacement |
Public method | RefreshActiveView |
Public method | SaveAndClose |
Public method | SaveAs |
Public method | ShowElements(Element) |
Public method | ShowElements(ElementId) |
Public method | ShowElements(ICollection<(Of <<'(ElementId>)>>)) |
Public method | ShowElements(ElementSet) |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentEntryPoint Class
Autodesk.Revit.UI.Macros Namespace