Revit 2013 API
PipeSettings..::..GetPipeSettings Method
PipeSettings Class See Also
Get the pipe settings of the project.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static PipeSettings GetPipeSettings(
    Document aDoc
)
Visual Basic
Public Shared Function GetPipeSettings ( _
    aDoc As Document _
) As PipeSettings
Visual C++
public:
static PipeSettings^ GetPipeSettings(
    Document^ aDoc
)

Parameters

aDoc
Type: Autodesk.Revit.DB..::..Document
The document.

Return Value

The pipe settings of the project.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PipeSettings Class
Autodesk.Revit.DB.Plumbing Namespace