Revit 2013 API
IFCExtrusionCreationData..::..AddOpening Method
IFCExtrusionCreationData Class See Also
Adds an opening to the data.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void AddOpening(
    IFCExtrusionData data
)
Visual Basic
Public Sub AddOpening ( _
    data As IFCExtrusionData _
)
Visual C++
public:
void AddOpening(
    IFCExtrusionData^ data
)

Parameters

data
Type: Autodesk.Revit.DB.IFC..::..IFCExtrusionData
The opening.

Remarks

The opening is stored for retrieval later via GetOpenings().

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCExtrusionCreationData Class
Autodesk.Revit.DB.IFC Namespace