Revit 2013 API
StairsRun..::..LocationLineJustification Property
StairsRun Class See Also
The position of the run relative to the Up-direction path used to create the run.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public StairsRunJustification LocationLineJustification { get; set; }
Visual Basic
Public Property LocationLineJustification As StairsRunJustification
    Get
    Set
Visual C++
public:
property StairsRunJustification LocationLineJustification {
    StairsRunJustification get ();
    void set (StairsRunJustification value);
}

Remarks

Only common runs(straight, spiral, winder) have location line justification.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The stairs run is sketched so the data being set is not applicable.

See Also

StairsRun Class
Autodesk.Revit.DB.Architecture Namespace