Revit 2013 API
PerformanceAdviserRuleId Members
PerformanceAdviserRuleId Class Constructors Methods Operators Properties See Also

The PerformanceAdviserRuleId type exposes the following members.

Constructors

 | Name | Description
Public method | PerformanceAdviserRuleId | Creates a new PerformanceAdviserRuleId instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Operators

Name | Description
Equality | Compares two PerformanceAdviserRuleId instances.
Inequality | Compares two PerformanceAdviserRuleId instances.

Properties

 | Name | Description
Public property | Guid | The Guid of GUID-based enum object. (Inherited from GuidEnum.)

See Also

PerformanceAdviserRuleId Class