Revit 2013 API
UIApplication..::..GetRibbonPanels Method (Tab)
UIApplication Class See Also
Get all the custom Panels on a designated standard Revit tab.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public List<RibbonPanel> GetRibbonPanels(
    Tab tab
)
Visual Basic
Public Function GetRibbonPanels ( _
    tab As Tab _
) As List(Of RibbonPanel)
Visual C++
public:
List<RibbonPanel^>^ GetRibbonPanels(
    Tab tab
)

Parameters

tab
Type: Autodesk.Revit.UI..::..Tab
The tab on which the panels are located.

Remarks

Built-in panels will not be included. This method is not supported in Macros.

See Also

UIApplication Class
GetRibbonPanels Overload
Autodesk.Revit.UI Namespace