Revit 2013 API
RebarShapeDefinitionBySegments..::..SetSegmentVariableDirection Method
RebarShapeDefinitionBySegments Class See Also
Remove the fixed direction from a segment.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetSegmentVariableDirection(
    int iSegment
)
Visual Basic
Public Sub SetSegmentVariableDirection ( _
    iSegment As Integer _
)
Visual C++
public:
void SetSegmentVariableDirection(
    int iSegment
)

Parameters

iSegment
Type: System..::..Int32
Index of the segment (0 to NumberOfSegments - 1).

Remarks

The edge's angle will be allowed to vary, with a range of 90 degrees. The edge must have at least two constraints.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | iSegment is not between 0 and NumberOfEdges.

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.DB.Structure Namespace