Revit 2013 API
CompoundStructure..::..CutoffHeight Property
CompoundStructure Class See Also
Horizontal segments below or at the cutoff height have their distance to the wall bottom fixed, those above have their distance to the wall top fixed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double CutoffHeight { get; set; }
Visual Basic
Public Property CutoffHeight As Double
    Get
    Set
Visual C++
public:
property double CutoffHeight {
    double get ();
    void set (double value);
}

Field Value

The cutoff height of this CompoundStructure.

Remarks

This allows layers with one horizontal segment above and one below this line to be of variable height.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is valid only vertically compound structures.

See Also

CompoundStructure Class