Revit 2013 API
PlanViewRange..::..SetLevelId Method
PlanViewRange Class See Also
Set the level for a View Depth plane

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetLevelId(
    PlanViewPlane planViewPlane,
    ElementId id
)
Visual Basic
Public Sub SetLevelId ( _
    planViewPlane As PlanViewPlane, _
    id As ElementId _
)
Visual C++
public:
void SetLevelId(
    PlanViewPlane planViewPlane,
    ElementId^ id
)

Parameters

planViewPlane
Type: Autodesk.Revit.DB..::..PlanViewPlane
The View Depth plane
id
Type: Autodesk.Revit.DB..::..ElementId
Id of the level

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PlanViewRange Class