Revit 2013 API
RenderingQualitySettings..::..SoftShadowsPrecision Property
RenderingQualitySettings Class See Also
The soft shadows precision value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int SoftShadowsPrecision { get; set; }
Visual Basic
Public Property SoftShadowsPrecision As Integer
    Get
    Set
Visual C++
public:
property int SoftShadowsPrecision {
    int get ();
    void set (int value);
}

Remarks

Increase this value when the edges of soft shadows appear to be speckled, rather than smoothly blurred.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The soft shadows precision value is not valid. The valid range is 1 to 10.
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The RenderingQualitySettings does not use custom quality currently. To use custom quality, set RenderingQuality property to RenderingQuality.Custom. -or- When setting this property: Shadows are not enabled.

See Also

RenderingQualitySettings Class