Revit 2013 API
UV..::..DistanceTo Method
UV Class See Also
Returns the distance from this 2-D point to the specified 2-D point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double DistanceTo(
    UV source
)
Visual Basic
Public Function DistanceTo ( _
    source As UV _
) As Double
Visual C++
public:
double DistanceTo(
    UV^ source
)

Parameters

source
Type: Autodesk.Revit.DB..::..UV
The specified point.

Return Value

The real number equal to the distance between the two points.

Remarks

The distance between the two points is equal to the length of the vector that joins the two points.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when source is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

UV Class