Revit 2013 API
CompoundStructure..::..IsValid Method
CompoundStructure Class See Also
Checks for errors or inconsistencies in the data in this CompoundStructure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsValid(
    Document doc,
    out IDictionary<int, CompoundStructureError> errMap,
    out IDictionary<int, int> twoLayerErrorsMap
)
Visual Basic
Public Function IsValid ( _
    doc As Document, _
    <OutAttribute> ByRef errMap As IDictionary(Of Integer, CompoundStructureError), _
    <OutAttribute> ByRef twoLayerErrorsMap As IDictionary(Of Integer, Integer) _
) As Boolean
Visual C++
public:
bool IsValid(
    Document^ doc,
    [OutAttribute] IDictionary<int, CompoundStructureError>^% errMap,
    [OutAttribute] IDictionary<int, int>^% twoLayerErrorsMap
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
Access to the document in which the CompoundStructure will be used.
errMap
Type: System.Collections.Generic..::..IDictionary<(Of <(<'Int32, CompoundStructureError>)>)>%
This map will associate each problematic layer index to a value in CompoundStructureError. General structure errors are reported as associated to layer index -1.
twoLayerErrorsMap
Type: System.Collections.Generic..::..IDictionary<(Of <(<'Int32, Int32>)>)>%
The map is associated to a check run only for vertically Compound Structures. Essentially the Compound Structure is sliced at representative heights. It looks at the region from exterior to interior, and requires that the assigned layer indices do not decrease. If they do, an entry is generated for this map. The first entry is the last valid layer index encountered. The second entry is a region id whose assigned layer index is too small: it should be at least as large as the first entry.

Return Value

True if the compound structure is valid for the document, false otherwise.

Remarks

This check is run before the CompoundStructure may be assigned to a particular ElementType.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

CompoundStructure Class