Revit 2013 API
IFCTypeInfo..::..SetStyle Method
IFCTypeInfo Class See Also
Sets the associated handle to an IfcTypeProduct for the type.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void SetStyle(
    IFCAnyHandle typeProductHandle
)
Visual Basic
Public Sub SetStyle ( _
    typeProductHandle As IFCAnyHandle _
)
Visual C++
public:
void SetStyle(
    IFCAnyHandle^ typeProductHandle
)

Parameters

typeProductHandle
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The handle.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCTypeInfo Class
Autodesk.Revit.DB.IFC Namespace