Revit 2013 API
EnergyDataSettings..::..CheckProjectReportType Method
EnergyDataSettings Class See Also
Checks that the project report type falls within an appropriate range.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static bool CheckProjectReportType(
    HVACLoadLoadsReportType projectReportType
)
Visual Basic
Public Shared Function CheckProjectReportType ( _
    projectReportType As HVACLoadLoadsReportType _
) As Boolean
Visual C++
public:
static bool CheckProjectReportType(
    HVACLoadLoadsReportType projectReportType
)

Parameters

projectReportType
Type: Autodesk.Revit.DB.Analysis..::..HVACLoadLoadsReportType
The project report type to be checked.

Return Value

True if the project report type falls within an appropriate range, false otherwise.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace