Revit 2013 API
EnergyDataSettings..::..ExportComplexity Property
EnergyDataSettings Class See Also
Value determines Export Complexity for GreenBuildingXML detailed model export.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public gbXMLExportComplexity ExportComplexity { get; set; }
Visual Basic
Public Property ExportComplexity As gbXMLExportComplexity
    Get
    Set
Visual C++
public:
property gbXMLExportComplexity ExportComplexity {
    gbXMLExportComplexity get ();
    void set (gbXMLExportComplexity value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The export complexity does not fall within an appropriate range.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace