Revit 2013 API
PanelScheduleData..::..UpdateCircuitTableForTemplate Method
PanelScheduleData Class See Also
Redraw the circuit table for a template with the given parameter updates

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void UpdateCircuitTableForTemplate(
    PanelSchedulePhaseLoadType newType,
    int nNumSlots,
    bool bPhasesAsCurrents
)
Visual Basic
Public Sub UpdateCircuitTableForTemplate ( _
    newType As PanelSchedulePhaseLoadType, _
    nNumSlots As Integer, _
    bPhasesAsCurrents As Boolean _
)
Visual C++
public:
void UpdateCircuitTableForTemplate(
    PanelSchedulePhaseLoadType newType,
    int nNumSlots,
    bool bPhasesAsCurrents
)

Parameters

newType
Type: Autodesk.Revit.DB.Electrical..::..PanelSchedulePhaseLoadType
The new phase load type of the circuit table
nNumSlots
Type: System..::..Int32
The number of circuit slots
bPhasesAsCurrents
Type: System..::..Boolean
True if the phase columns should be currents, false if they should be loads

See Also

PanelScheduleData Class
Autodesk.Revit.DB.Electrical Namespace