Revit 2013 API
Application..::..IsMechanicalAnalysisEnabled Property
Application Class See Also
Checks whether or not mechanical analysis is enabled, and enable or disable it.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsMechanicalAnalysisEnabled { get; set; }
Visual Basic
Public Property IsMechanicalAnalysisEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool IsMechanicalAnalysisEnabled {
    bool get ();
    void set (bool value);
}

Remarks

Enabling mechanical analysis will not take effect unless the mechanical discipline is also enabled.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property:

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace