Revit 2013 API
RebarShapeParameters Members
RebarShapeParameters Class Methods See Also

The RebarShapeParameters type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the RebarShapeParameters
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetAllRebarShapeParameters | List all shape parameters used by all the existing RebarShapes in the specified document.
 | GetElementIdForExternalDefinition | Retrieve the ElementId corresponding to an external rebar shape parameter in the document, if it exists; otherwise, return InvalidElementId.
 | GetExternalDefinitionForElementId | Seach a DefinitionFile for the ExternalDefinition corresponding to a parameter in a document.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetOrCreateElementIdForExternalDefinition | Retrieve the ElementId corresponding to an external rebar shape parameter in the document, if it exists; otherwise, add the parameter to the document and generate a new ElementId.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValidExternalDefinition | Checks that an ExternalDefinition (shared parameter) may be used as a Rebar Shape parameter.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarShapeParameters Class
Autodesk.Revit.DB.Structure Namespace