Revit 2013 API
View..::..SetWorksetVisibility Method
View Class See Also
Sets visibility for a workset in this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void SetWorksetVisibility(
    WorksetId worksetId,
    WorksetVisibility visible
)
Visual Basic
Public Sub SetWorksetVisibility ( _
    worksetId As WorksetId, _
    visible As WorksetVisibility _
)
Visual C++
public:
void SetWorksetVisibility(
    WorksetId^ worksetId,
    WorksetVisibility visible
)

Parameters

worksetId
Type: Autodesk.Revit.DB..::..WorksetId
Id of the workset.
visible
Type: Autodesk.Revit.DB..::..WorksetVisibility
The visibility of the workset.

Remarks

It works even when the workset is closed. This settings overrules implicit visibility of the workset (for this particular view only).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | There is no workset with this Id in the document associated with this view.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

View Class