Revit 2013 API
CompoundStructure..::..IsValidRegionId Method
CompoundStructure Class See Also
Determines whether the specified integer is actually the id of a region in this CompoundStructure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsValidRegionId(
    int regionId
)
Visual Basic
Public Function IsValidRegionId ( _
    regionId As Integer _
) As Boolean
Visual C++
public:
bool IsValidRegionId(
    int regionId
)

Parameters

regionId
Type: System..::..Int32
The id of a region in this vertically compound structure.

Return Value

True if the region is valid, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is valid only vertically compound structures.

See Also

CompoundStructure Class