Revit 2013 API
MEPSpaceConstruction Members
MEPSpaceConstruction Class Methods Properties See Also

The MEPSpaceConstruction type exposes the following members.

Methods

 | Name | Description
Public method | DeleteConstruction | Remove an existing construction from Space constructions.
Public method | DuplicateConstruction | Create a new construction for Space constructions.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | NewConstruction | Create a new construction for Space constructions.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CurrentConstruction | Get all the Building Constructions according to the specific Construction type.
Public property | SpaceConstructions | Return all the Space constructions of current space.

See Also

MEPSpaceConstruction Class
Autodesk.Revit.DB.Mechanical Namespace