Revit 2013 API
LoadUsageArrayIterator..::..Reset Method
LoadUsageArrayIterator Class See Also
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

LoadUsageArrayIterator Class
Autodesk.Revit.DB.Structure Namespace