Revit 2013 API
PanelScheduleTemplate..::..Create Method
PanelScheduleTemplate Class See Also
Creates a new instance of a panel schedule template.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static PanelScheduleTemplate Create(
    Document document,
    PanelScheduleType type,
    PanelConfiguration config,
    string strName
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    type As PanelScheduleType, _
    config As PanelConfiguration, _
    strName As String _
) As PanelScheduleTemplate
Visual C++
public:
static PanelScheduleTemplate^ Create(
    Document^ document,
    PanelScheduleType type,
    PanelConfiguration config,
    String^ strName
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document where the element will be created and added.
type
Type: Autodesk.Revit.DB.Electrical..::..PanelScheduleType
The panel schedule type.
config
Type: Autodesk.Revit.DB.Electrical..::..PanelConfiguration
The panel configuration type.
strName
Type: System..::..String
The name of the panel schedule template to be created.

Return Value

The newly created panel schedule template element.

Remarks

If the given name has already been used by existing panel schedule templates, a unique name will be used for the newly created template.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The type is not valid for this element. -or- The config is not valid for panel schedule type type of this template.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PanelScheduleTemplate Class
Autodesk.Revit.DB.Electrical Namespace