Revit 2013 API
DWGExportOptions..::..GetPredefinedOptions Method
DWGExportOptions Class See Also
Returns an instance DWGExportOptions containing settings from a predefined export setup.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static DWGExportOptions GetPredefinedOptions(
    Document document,
    string setup
)
Visual Basic
Public Shared Function GetPredefinedOptions ( _
    document As Document, _
    setup As String _
) As DWGExportOptions
Visual C++
public:
static DWGExportOptions^ GetPredefinedOptions(
    Document^ document,
    String^ setup
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
A Revit project document to retrieve the setup from.
setup
Type: System..::..String
The name of a predefined export setup from the specified document.

Return Value

An instance of predefined DWGExportOptions, or nullNothingnullptra null reference (Nothing in Visual Basic) if the name was not found.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

DWGExportOptions Class