Revit 2013 API
IFCExtrusionBasis Enumeration
See Also
This enumerated type represents the possible bases for derivation of extrusion geometry.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public enum IFCExtrusionBasis
Visual Basic
Public Enumeration IFCExtrusionBasis
Visual C++
public enum class IFCExtrusionBasis

Members

Member name | Description
InvalidBasis | An invalid basis (typically indicating that the extrusion extraction was unsuccessful).
BasisX | The X direction.
BasisY | The Y direction.
BasisZ | The Z direction.

See Also

Autodesk.Revit.DB.IFC Namespace