Revit 2013 API
IFCGeometryInfo Members
IFCGeometryInfo Class Methods See Also

The IFCGeometryInfo type exposes the following members.

Methods

 | Name | Description
 | CreateCurveGeometryInfo | Creates a new container object which holds IfcCurve handles processed from a Revit geometry object.
 | CreateFaceGeometryInfo(Double) | Creates a new container object which holds IfcFace handles processed from a Revit geometry object.
 | CreateFaceGeometryInfo(Double, Boolean) | Creates a new container object which holds IfcFace handles processed from a Revit geometry object.
 | CreateFaceGeometryInfo(ExporterIFC, Plane, XYZ, Double, Boolean) | Creates a new container object which holds IfcFace handles processed from a Revit geometry object.
 | CreateSurfaceGeometryInfo | Creates a new container object which holds IfcSurface handles processed from a Revit geometry object.
Public method | Dispose | Releases all resources used by the IFCGeometryInfo
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCurves | Gets the IfcCurve handles created representing the processed geometry and stored in this object.
Public method | GetFaces | Gets the IfcFace handles created representing the processed geometry and stored in this object.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRepresentations | Gets the representation handles created representing the processed geometry and stored in this object.
Public method | GetSurfaces | Gets the IfcSurface handles created representing the processed geometry and stored in this object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IFCGeometryInfo Class
Autodesk.Revit.DB.IFC Namespace