Revit 2013 API
GeometryElement Properties
GeometryElement Class See Also

The GeometryElement type exposes the following members.

Properties

 | Name | Description
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle; (Inherited from GeometryObject.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | MaterialElement | Element describing the material from which this element is composed.
Public property | Objects | Obsolete. All geometric primitives contained in the element.
Public property | Visibility | The visibility. (Inherited from GeometryObject.)

See Also

GeometryElement Class