Revit 2013 API
Schema Methods
Schema Class See Also

The Schema type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EraseSchemaAndAllEntities | Erases all Entities corresponding to this Schema from all open documents, and erases this Schema from memory.
Public method | GetField | Gets a Field of a given name from the Schema.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ListFields | The complete list of fields in the Schema, sorted by name.
 | ListSchemas | Lists all schemas in memory.
 | Lookup | Finds the Schema corresponding to the GUID in memory.
Public method | ReadAccessGranted | Checks whether Entities of this Schema may be retrieved by the current add-in.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WriteAccessGranted | Checks whether Entities of this Schema may be stored by the current add-in.

See Also

Schema Class
Autodesk.Revit.DB.ExtensibleStorage Namespace