Revit 2013 API
Hub..::..GetOrigin Method
Hub Class See Also
Retrieves position of a Hub if such position is a 3D point.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public XYZ GetOrigin()
Visual Basic
Public Function GetOrigin As XYZ
Visual C++
public:
XYZ^ GetOrigin()

Return Value

The origin.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Hub does not have an Origin.

See Also

Hub Class
Autodesk.Revit.DB.Structure Namespace