Revit 2013 API
GenericForm Class
Members See Also
Provides access to the Generic Form model in Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class GenericForm : CombinableElement
Visual Basic
Public Class GenericForm _
    Inherits CombinableElement
Visual C++
public ref class GenericForm : public CombinableElement

Remarks

The Generic Form object can be queried for a generic form for use in family modeling and massing. It is the base class of Sweep, Blend, Extrusion, Revolution.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..CombinableElement
Autodesk.Revit.DB..::..GenericForm
Autodesk.Revit.DB..::..Blend
Autodesk.Revit.DB..::..Extrusion
Autodesk.Revit.DB..::..Form
Autodesk.Revit.DB..::..Revolution
Autodesk.Revit.DB..::..Sweep
Autodesk.Revit.DB..::..SweptBlend

See Also

GenericForm Members