Revit 2013 API
Wall..::..StructuralUsage Property
Wall Class See Also
Retrieves or changes the wall's designated structural usage.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public StructuralWallUsage StructuralUsage { get; set; }
Visual Basic
Public Property StructuralUsage As StructuralWallUsage
    Get
    Set
Visual C++
public:
property StructuralWallUsage StructuralUsage {
    StructuralWallUsage get ();
    void set (StructuralWallUsage value);
}

Field Value

The wall's designated structural usage, such as bearing or non bearing.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The enum value is not invalid for StructuralWallUsage.

See Also

Wall Class