Revit 2013 API
ScheduleField..::..HasTotals Property
ScheduleField Class See Also
Indicates if the field displays totals.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool HasTotals { get; set; }
Visual Basic
Public Property HasTotals As Boolean
    Get
    Set
Visual C++
public:
property bool HasTotals {
    bool get ();
    void set (bool value);
}

Field Value

True if the field displays totals, false otherwise.

Remarks

To display totals below a series of schedule rows, a footer row must be enabled where the totals will be displayed. It can either be a grand total row at the end of the schedule or a footer row for one of the schedule's grouped fields.

In a non-itemized schedule, totals are also displayed in regular rows when multiple elements appear on the same row.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: This ScheduleField cannot be totaled.

See Also

ScheduleField Class