Revit 2013 API
ExporterIFCUtils..::..GetAttachedColumns Method
ExporterIFCUtils Class See Also
Obtains a list of columns known to Revit as intersecting with this wall.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static IList<FamilyInstance> GetAttachedColumns(
    Wall pWallElem
)
Visual Basic
Public Shared Function GetAttachedColumns ( _
    pWallElem As Wall _
) As IList(Of FamilyInstance)
Visual C++
public:
static IList<FamilyInstance^>^ GetAttachedColumns(
    Wall^ pWallElem
)

Parameters

pWallElem
Type: Autodesk.Revit.DB..::..Wall
The wall.

Return Value

The columns found.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace