Revit 2013 API
CompoundStructure..::..ParticipatesInWrapping Method
CompoundStructure Class See Also
Identifies if a layer is included in wrapping at inserts and ends.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool ParticipatesInWrapping(
    int layerIdx
)
Visual Basic
Public Function ParticipatesInWrapping ( _
    layerIdx As Integer _
) As Boolean
Visual C++
public:
bool ParticipatesInWrapping(
    int layerIdx
)

Parameters

layerIdx
Type: System..::..Int32
The index of a layer.

Return Value

If true, then the layer participates in wrapping at inserts and openings. If false, the layer will not participate in wrapping.

Remarks

This method applies only to interior and exterior shell layers.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The layer index is out of range.

See Also

CompoundStructure Class