Revit 2013 API
FilterIntegerRule Constructor
FilterIntegerRule Class See Also
Constructs an instance of FilterIntegerRule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FilterIntegerRule(
    FilterableValueProvider valueProvider,
    FilterNumericRuleEvaluator evaluator,
    int ruleValue
)
Visual Basic
Public Sub New ( _
    valueProvider As FilterableValueProvider, _
    evaluator As FilterNumericRuleEvaluator, _
    ruleValue As Integer _
)
Visual C++
public:
FilterIntegerRule(
    FilterableValueProvider^ valueProvider,
    FilterNumericRuleEvaluator^ evaluator,
    int ruleValue
)

Parameters

valueProvider
Type: Autodesk.Revit.DB..::..FilterableValueProvider
A pointer to a "value provider" object that will extract values from a Revit document.
evaluator
Type: Autodesk.Revit.DB..::..FilterNumericRuleEvaluator
A pointer to the filter rule evaluator object that implements the desired test. The built-in evaluators implement commonly used tests such as less-than, greater-than less-than-or-equal-to, equal, etc.
ruleValue
Type: System..::..Int32
The user-supplied value against which values from a Revit document will be tested.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FilterIntegerRule Class