Revit 2013 API
AnalyticalModelSweptProfile Members
AnalyticalModelSweptProfile Class Methods Properties See Also

The AnalyticalModelSweptProfile type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the AnalyticalModelSweptProfile
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetDrivingCurve | Provides access to the curve that dictates the path of the swept profile.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSweptProfile | Returns an object that describes the profile that is swept along the driving curve.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | EndSetBack | The distance from the end of the driving curve to the point where the sweep actually ends.
Public property | StartSetBack | The distance from the start of the driving curve to the point where the sweep actually begins.

See Also

AnalyticalModelSweptProfile Class
Autodesk.Revit.DB.Structure Namespace