Revit 2013 API
AdaptiveComponentFamilyUtils..::..SetPointConstraintType Method
AdaptiveComponentFamilyUtils Class See Also
Sets constrain type of an Adaptive Shape Handle Point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static void SetPointConstraintType(
    Document doc,
    ElementId refPointId,
    AdaptivePointConstraintType constraintType
)
Visual Basic
Public Shared Sub SetPointConstraintType ( _
    doc As Document, _
    refPointId As ElementId, _
    constraintType As AdaptivePointConstraintType _
)
Visual C++
public:
static void SetPointConstraintType(
    Document^ doc,
    ElementId^ refPointId,
    AdaptivePointConstraintType constraintType
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
The Document
refPointId
Type: Autodesk.Revit.DB..::..ElementId
The ReferencePoint id
constraintType
Type: Autodesk.Revit.DB..::..AdaptivePointConstraintType
Constraint type of the Adaptive Shape Handle Point.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ElementId refPointId does not correspond to a valid ReferencePoint. -or- The Element corresponding to ElementId refPointId does not belong to an Adaptive Family. -or- The ElementId refPointId does not correspond to a Shape Handle Point.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation failed.

See Also

AdaptiveComponentFamilyUtils Class