Revit 2013 API
ParameterValueProvider Methods
ParameterValueProvider Class See Also

The ParameterValueProvider type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterableValueProvider.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetDoubleValue | Gets a double-precision numeric value from the given element. (Inherited from FilterableValueProvider.)
Public method | GetElementIdValue | Gets an ElementId value from the given element. (Inherited from FilterableValueProvider.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIntegerValue | Gets an integer value from the given element. (Inherited from FilterableValueProvider.)
Public method | GetStringValue | Gets a string value from the given element. (Inherited from FilterableValueProvider.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDoubleValueSupported | Determines whether the provide can provide a double-precision numeric value for the given element. (Inherited from FilterableValueProvider.)
Public method | IsElementIdValueSupported | Determines whether the provide can provide an ElementId value for the given element. (Inherited from FilterableValueProvider.)
Public method | IsIntegerValueSupported | Determines whether the provide can provide an integer value for the given element. (Inherited from FilterableValueProvider.)
Public method | IsStringValueSupported | Determines whether the provide can provide a string value for the given element. (Inherited from FilterableValueProvider.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ParameterValueProvider Class