Revit 2013 API
Selection..::..PickObject Method (ObjectType)
Selection Class Example See Also
Prompts the user to select one object.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public Reference PickObject(
    ObjectType objectType
)
Visual Basic
Public Function PickObject ( _
    objectType As ObjectType _
) As Reference
Visual C++
public:
Reference^ PickObject(
    ObjectType objectType
)

Parameters

objectType
Type: Autodesk.Revit.UI.Selection..::..ObjectType
Specifies the type of object to be selected.

Return Value

A reference object selected by user.

Note: if the user cancels the operation (for example, through ESC), the method will throw an OperationCanceledException instance.

Remarks

Revit users will be permitted to manipulate the Revit view (zooming, panning, and rotating the view), but will not be permitted to click other items in the Revit user interface. Users are not permitted to switch the active view, close the active document or Revit application in the pick session, otherwise an exception will be thrown.

The selection will not be automatically added to the active selection buffer.

Note: this method must not be called during dynamic update, otherwise ForbiddenForDynamicUpdateException will be thrown.

Examples

CopyC#
Selection choices = uidoc.Selection;
 // Pick one object from Revit.
 Reference hasPickOne = choices.PickObject(ObjectType.Element);
 if (hasPickOne != null)
 {
     TaskDialog.Show("Revit", "One element selected.");
 }
CopyVB.NET
Dim choices As Autodesk.Revit.UI.Selection.Selection = uidoc.Selection
' Pick one object from Revit.
Dim hasPickOne As Reference = choices.PickObject(Autodesk.Revit.UI.Selection.ObjectType.Element)
If hasPickOne IsNot Nothing Then
    TaskDialog.Show("Revit", "One element added to Selection.")
End If

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the objectType is not a recognized value.
Autodesk.Revit.Exceptions..::..OperationCanceledException | Thrown when the Revit user cancels this operation. Thrown when the Revit user tried to switch the active view, close the active document or Revit application when responding to this mode.
Autodesk.Revit.Exceptions..::..ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.

See Also

Selection Class
PickObject Overload
Autodesk.Revit.UI.Selection Namespace