Revit 2013 API
IFCExtrusionAxes Enumeration
See Also
Represents the possible axes to try when generating an extrusion using IFCCreateExtrusionData.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public enum IFCExtrusionAxes
Visual Basic
Public Enumeration IFCExtrusionAxes
Visual C++
public enum class IFCExtrusionAxes

Members

Member name | Description
TryDefault | The default value.
TryX | The x-axis.
TryY | The y-axis.
TryXY | The x- and y-axes.
TryZ | The z-axis.
TryXZ | The x- and z-axes.
TryYZ | The y- and z-axes.
TryXYZ | The x-, y-, and z-axes.
TryCustom | A custom direction.
TryXYZAndCustom | The x-, y-, and z-axes, and a custom direction.

See Also

Autodesk.Revit.DB.IFC Namespace