Revit 2013 API
ViewSchedule..::..Export Method
ViewSchedule Class See Also
Exports the schedule data to a text file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void Export(
    string folder,
    string name,
    ViewScheduleExportOptions options
)
Visual Basic
Public Sub Export ( _
    folder As String, _
    name As String, _
    options As ViewScheduleExportOptions _
)
Visual C++
public:
void Export(
    String^ folder,
    String^ name,
    ViewScheduleExportOptions^ options
)

Parameters

folder
Type: System..::..String
Path to the location where the file will be saved.
name
Type: System..::..String
Name of file.
options
Type: Autodesk.Revit.DB..::..ViewScheduleExportOptions
Options that relate to schedule export.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | NullOrEmpty -or- Contains invalid characters
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidPathArgumentException | The folder does not exist.

See Also

ViewSchedule Class