Revit 2013 API
ExporterIFCUtils..::..CreateAlternateGUID Method
ExporterIFCUtils Class See Also
Creates a GUID for the given element.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static string CreateAlternateGUID(
    Element pElement
)
Visual Basic
Public Shared Function CreateAlternateGUID ( _
    pElement As Element _
) As String
Visual C++
public:
static String^ CreateAlternateGUID(
    Element^ pElement
)

Parameters

pElement
Type: Autodesk.Revit.DB..::..Element
The element.

Return Value

The guid string.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace