Revit 2013 API
FlexDuct Class
Members See Also
A flex duct in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class FlexDuct : MEPCurve
Visual Basic
Public Class FlexDuct _
    Inherits MEPCurve
Visual C++
public ref class FlexDuct : public MEPCurve

Remarks

The flex duct is only available in the Autodesk Revit MEP product.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..HostObject
Autodesk.Revit.DB..::..MEPCurve
Autodesk.Revit.DB.Mechanical..::..FlexDuct

See Also

FlexDuct Members
Autodesk.Revit.DB.Mechanical Namespace