Revit 2013 API
IFCData..::..AsDouble Method
IFCData Class See Also
Gets storage value as double when its PrimitiveType is double.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double AsDouble()
Visual Basic
Public Function AsDouble As Double
Visual C++
public:
double AsDouble()

Return Value

The double value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InapplicableDataException | The primitive type is not double.

See Also

IFCData Class
Autodesk.Revit.DB.IFC Namespace