Revit 2013 API
PlanTopology Members
PlanTopology Class Methods Properties See Also

The PlanTopology type exposes the following members.

Methods

 | Name | Description
Public method | ~PlanTopology |
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRoomIds | Retrieves room ElementIds of the PlanTopology in the last phase.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Circuits | The Circuits of the PlanTopology.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | The Level of the PlanTopology.
Public property | Phase | The phase of the PlanTopology.
Public property | Rooms | Obsolete. Retrieves rooms of the PlanTopology in the last phase.

See Also

PlanTopology Class