Revit 2013 API
AnalysisResultSchema Class
Members Example See Also
Contains all information about one analysis result. Each result may contain several measurements.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class AnalysisResultSchema : IDisposable
Visual Basic
Public Class AnalysisResultSchema _
    Implements IDisposable
Visual C++
public ref class AnalysisResultSchema : IDisposable

Remarks

In order to take effect, the AnalysisResultSchema object has to be registered by calling SpatialFieldManager::RegisterResult, which returns result index for future references; to make changes to the properties of an already registered object, use method SpatialFieldManager::SetResultSchema and supply result index and replacing object.

Examples

CopyC#
IList<string> unitNames = new List<string>();
unitNames.Add("Feet");
unitNames.Add("Inches");
IList<double> multipliers = new List<double>();
multipliers.Add(1);
multipliers.Add(12);

AnalysisResultSchema resultSchema = new AnalysisResultSchema("Schema Name", "Description");

resultSchema.SetUnits(unitNames, multipliers);

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Analysis..::..AnalysisResultSchema

See Also

AnalysisResultSchema Members
Autodesk.Revit.DB.Analysis Namespace