Revit 2013 API
Connector..::..AssignedPipeLossMethod Property
Connector Class See Also
The pipe loss method of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public PipeLossMethodType AssignedPipeLossMethod { get; }
Visual Basic
Public ReadOnly Property AssignedPipeLossMethod As PipeLossMethodType
    Get
Visual C++
public:
property PipeLossMethodType AssignedPipeLossMethod {
    PipeLossMethodType get ();
}

Remarks

Assigned duct pipe loss method may be assigned for connectors of some family instances, for more information, refer to PipeConnector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the connector's domain is not DomainPiping. Thrown when the connector is not in a family instance.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown on failure to get pipe loss method.

See Also

Connector Class