Revit 2013 API
CompoundStructure..::..GetWidth Method (Int32)
CompoundStructure Class See Also
Computes the width of the envelope (2d bounding box) of the specified region.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double GetWidth(
    int regionId
)
Visual Basic
Public Function GetWidth ( _
    regionId As Integer _
) As Double
Visual C++
public:
double GetWidth(
    int regionId
)

Parameters

regionId
Type: System..::..Int32
The id of a region in this vertically compound structure.

Return Value

The width of the envelope (2d bounding box) of the region.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | It is not a valid region id.
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is valid only vertically compound structures.

See Also

CompoundStructure Class
GetWidth Overload