Revit 2013 API
SpotLightDistribution Members
SpotLightDistribution Class Constructors Methods Properties See Also

The SpotLightDistribution type exposes the following members.

Constructors

Name Description
Public method SpotLightDistribution()()()()
Creates a spot light distribution object with the following values;
  • PI/6 radians spot beam angle
  • PI/2 radians spot field angle
  • PI/6 radians tilt angle
Public method SpotLightDistribution(SpotLightDistribution)
Creates a copy of the given spotlight distribution
Public method SpotLightDistribution(Double, Double, Double)
Creates a spot light distribution object with the given values.

Methods

 | Name | Description
Public method | Clone | Creates a copy of the LightDistribution derived object. (Inherited from LightDistribution.)
Public method | Dispose | (Inherited from LightDistribution.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | SpotBeamAngle | The spot beam angle.
Public property | SpotFieldAngle | The spot field angle.
Public property | TiltAngle | The tilt angle.

See Also

SpotLightDistribution Class
Autodesk.Revit.DB.Lighting Namespace