Revit 2013 API
FilteredWorksetCollector..::..WherePasses Method
FilteredWorksetCollector Class See Also
Applies a workset filter to the collector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public FilteredWorksetCollector WherePasses(
    WorksetFilter filter
)
Visual Basic
Public Function WherePasses ( _
    filter As WorksetFilter _
) As FilteredWorksetCollector
Visual C++
public:
FilteredWorksetCollector^ WherePasses(
    WorksetFilter^ filter
)

Parameters

filter
Type: Autodesk.Revit.DB..::..WorksetFilter
The workset filter.

Return Value

A handle to this collector. This is the same collector that has just been modified, returned so you can chain multiple calls together in one line.

Remarks

The filter will be added as an additional condition that all filtered worksets must pass. If you have an active iterator to this collector it will be stopped by this call.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FilteredWorksetCollector Class