Revit 2013 API
SlabEdgeTypeSet Members
SlabEdgeTypeSet Class Constructors Methods Properties See Also Send Feedback

The SlabEdgeTypeSet type exposes the following members.

Constructors

 | Name | Description
Public method | SlabEdgeTypeSet | Initializes a new instance of the SlabEdgeTypeSet class

Methods

 | Name | Description
Public method | Clear | Removes every slab edge type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a slab edge type within the set.
Public method | Erase | Removes a specified slab edge type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | Insert | Insert the specified slab edge type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | Size | Returns the number of slab edge types that are in the set.

See Also

SlabEdgeTypeSet Class

SlabEdgeTypeSet Constructor

[image]