Revit 2013 API
CurveLoop Methods
CurveLoop Class See Also Send Feedback

The CurveLoop type exposes the following members.

Methods

 | Name | Description
Public method | Append | Append the curve to this loop.
 | Create | Creates a new curve loop.
 | CreateViaCopy | Creates a new curve loop as a copy of the input.
 | CreateViaThicken | Creates a new closed curve loop by thickening the input curve with respect to a given plane.
Public method | Dispose |
Public method | Flip | Reverses the orientation of the curve loop.
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetCurveLoopIterator | Returns a curve that iterates through the curve loop.
Public method | GetEnumerator | Returns an enumerator that iterates through the curve loop.
Public method | GetExactLength | Returns the sum of exact lengths of all curves in the loop.
Public method | GetPlane | Gets the plane of the curve loop, if it is planar.
Public method | GetRectangularHeight | Returns the width of a curve loop if it is rectangular with respect to the projection plane.
Public method | GetRectangularWidth | Returns the width of a curve loop if it is rectangular with respect to the projection plane.
Public method | HasPlane | Identifies if the CurveLoop is planar.
Public method | IsCounterclockwise | Determines if this CurveLoop is oriented counter-clockwise (CCW) or clockwise (CW) with respect to the specified 3D direction.
Public method | IsOpen | Returns whether the curve loop is open or closed, as determined by an internal flag.
Public method | IsRectangular | Identifies if the curve loop is rectangular with respect to a given projection plane.

See Also

CurveLoop Class

Append Method

[image]