Revit 2013 API
Application..::..NewArc Method (Plane, Double, Double, Double)
Application Class Example See Also Send Feedback
Creates a new geometric arc object based on plane, radius, and angles.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Arc NewArc(
    Plane plane,
    double radius,
    double startAngle,
    double endAngle
)
Visual Basic
Public Function NewArc ( _
    plane As Plane, _
    radius As Double, _
    startAngle As Double, _
    endAngle As Double _
) As Arc
Visual C++
public:
Arc^ NewArc(
    Plane^ plane,
    double radius,
    double startAngle,
    double endAngle
)

Parameters

plane
Type: Autodesk.Revit.DB..::..Plane
The plane which the arc resides in. The plane's origin is the center of the arc.
radius
Type: System..::..Double
startAngle
Type: System..::..Double
The start angle of the arc (in radians).
endAngle
Type: System..::..Double
The end angle of the arc (in radians).

Remarks

Examples

CopyC#
Arc CreateArcByGivingPlane(Autodesk.Revit.ApplicationServices.Application application, Plane plane)
{
    // Create an arc which is placed on the plane and whose center is the plane's origin
    double radius = 10;
    double startAngle = 0;      // The unit is radian
    double endAngle = 2 * Math.PI;        // this arc will be a circle
    return application.Create.NewArc(plane, radius, startAngle, endAngle);
}
CopyVB.NET
Function CreateArcByGivingPlane(ByVal application As Autodesk.Revit.ApplicationServices.Application, ByVal plane As Plane) As Arc
    ' Create an arc which is placed on the plane and whose center is the plane's origin
    Dim radius As Double = 10
    Dim startAngle As Double = 0
    ' The unit is radian
    Dim endAngle As Double = 2 * Math.PI
    ' this arc will be a circle
    Return application.Create.NewArc(plane, radius, startAngle, endAngle)
End Function

See Also

Application Class
NewArc Overload
Autodesk.Revit.Creation Namespace

NewArc Method (XYZ, Double, Double, Double, XYZ, XYZ)

[image]