Revit 2013 API
AnalyticalModelSurface..::..GetLoops Method
AnalyticalModelSurface Class See Also Send Feedback
Retrieves Analytical Model Loops with respect to the loopType.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IList<CurveLoop> GetLoops(
    AnalyticalLoopType loopType
)
Visual Basic
Public Function GetLoops ( _
    loopType As AnalyticalLoopType _
) As IList(Of CurveLoop)
Visual C++
public:
IList<CurveLoop^>^ GetLoops(
    AnalyticalLoopType loopType
)

Parameters

loopType
Type: Autodesk.Revit.DB.Structure..::..AnalyticalLoopType

Return Value

Loops that satisfy loopType criteria are returned.

Remarks

For multiple concentric loops, only the outermost loop will be considered External. All other loops will be considered Internal.

See Also

AnalyticalModelSurface Class
Autodesk.Revit.DB.Structure Namespace

GetOpeningLoops Method

[image]