Revit 2013 API
PartMaker..::..IsElementDivided Method
PartMaker Class See Also Send Feedback
Is the element a source for this PartMaker

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
[ObsoleteAttribute("This method will be obsolete from the next release. Use isSourceElement instead.")]
public bool IsElementDivided(
    ElementId elemId
)
Visual Basic
<ObsoleteAttribute("This method will be obsolete from the next release. Use isSourceElement instead.")> _
Public Function IsElementDivided ( _
    elemId As ElementId _
) As Boolean
Visual C++
[ObsoleteAttribute(L"This method will be obsolete from the next release. Use isSourceElement instead.")]
public:
bool IsElementDivided(
    ElementId^ elemId
)

Parameters

elemId
Type: Autodesk.Revit.DB..::..ElementId

Return Value

Returns true if elemId is among the source elements of this PartMaker

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PartMaker Class

IsSourceElement Method

[image]