Revit 2013 API
PartUtils..::..GetOffsetForIntersectingReference Method
PartUtils Class See Also Send Feedback
Get offset for the intersecting reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2013; use PartMakerMethodToDivideVolumes.GetOffsetForIntersectingReference() instead.")]
public static double GetOffsetForIntersectingReference(
    PartMaker partMaker,
    ElementId intersectingReference
)
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2013; use PartMakerMethodToDivideVolumes.GetOffsetForIntersectingReference() instead.")> _
Public Shared Function GetOffsetForIntersectingReference ( _
    partMaker As PartMaker, _
    intersectingReference As ElementId _
) As Double
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2013; use PartMakerMethodToDivideVolumes.GetOffsetForIntersectingReference() instead.")]
public:
static double GetOffsetForIntersectingReference(
    PartMaker^ partMaker,
    ElementId^ intersectingReference
)

Parameters

partMaker
Type: Autodesk.Revit.DB..::..PartMaker
PartMaker that uses the intersecting reference.
intersectingReference
Type: Autodesk.Revit.DB..::..ElementId
The intersecting reference to obtain offset value from.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | PartMaker does not use the specified intersecting reference.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PartUtils Class

GetPartMakerMethodToDivideVolume Method

[image]