Revit 2013 API
MeshArray Members
MeshArray Class Constructors Methods Properties See Also Send Feedback

The MeshArray type exposes the following members.

Constructors

 | Name | Description
Public method | MeshArray | Initializes a new instance of the MeshArray class

Methods

 | Name | Description
Public method | Append | Add the mesh to the end of the array.
Public method | Clear | Removes every mesh from the array, rendering it empty.
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | Insert | Insert the specified mesh into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | Item | Gets or sets a mesh at a specified index within the array.
Public property | Size | Returns the number of meshes that are in the array.

See Also

MeshArray Class

MeshArray Constructor

[image]