Revit 2013 API
IExternalCommand Interface
Members Example See Also Send Feedback
An interface that should be implemented to provide the implementation for a Revit add-in External Command.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public interface IExternalCommand
Visual Basic
Public Interface IExternalCommand
Visual C++
public interface class IExternalCommand

Remarks

To add an external command to Autodesk Revit the developer should implement an object that supports the IExternalCommand interface.

Examples

CopyC#
public Autodesk.Revit.UI.Result Execute(ExternalCommandData commandData,
    ref string message, ElementSet elements)
{
    try
    {
        Document doc = commandData.Application.ActiveUIDocument.Document;
        UIDocument uidoc = commandData.Application.ActiveUIDocument;
        // Delete selected elements
        ICollection<Autodesk.Revit.DB.ElementId> ids =
            doc.Delete(uidoc.Selection.Elements);

        TaskDialog taskDialog = new TaskDialog("Revit");
        taskDialog.MainContent =
           ("Click Yes to return Succeeded. Selected members will be deleted.\n" +
           "Click No to return Failed.  Selected members will not be deleted.\n" +
           "Click Cancel to return Cancelled.  Selected members will not be deleted.");
        TaskDialogCommonButtons buttons = TaskDialogCommonButtons.Yes |
            TaskDialogCommonButtons.No | TaskDialogCommonButtons.Cancel;
        taskDialog.CommonButtons = buttons;
        TaskDialogResult taskDialogResult = taskDialog.Show();

        if (taskDialogResult == TaskDialogResult.Yes)
        {
            return Autodesk.Revit.UI.Result.Succeeded;
        }
        else if (taskDialogResult == TaskDialogResult.No)
        {
            elements = uidoc.Selection.Elements;
            message = "Failed to delete selection.";
            return Autodesk.Revit.UI.Result.Failed;
        }
        else
        {
            return Autodesk.Revit.UI.Result.Cancelled;
        }
    }
    catch
    {
        message = "Unexpected Exception thrown.";
        return Autodesk.Revit.UI.Result.Failed;
    }

}
CopyVB.NET
Public Function Execute(ByVal commandData As ExternalCommandData, ByRef message As String, ByVal elements As ElementSet) As Autodesk.Revit.UI.Result _
        Implements IExternalCommand.Execute
    Try
        Dim doc As Document = commandData.Application.ActiveUIDocument.Document
        Dim uidoc As UIDocument = commandData.Application.ActiveUIDocument
        ' Delete selected elements
        Dim ids As ICollection(Of Autodesk.Revit.DB.ElementId) = doc.Delete(uidoc.Selection.Elements)

        Dim taskDialog As New TaskDialog("Revit")
        taskDialog.MainContent = ("Click Yes to return Succeeded. Selected members will be deleted." & vbLf + "Click No to return Failed.  Selected members will not be deleted." & vbLf + "Click Cancel to return Cancelled.  Selected members will not be deleted.")
        Dim buttons As TaskDialogCommonButtons = TaskDialogCommonButtons.Yes Or TaskDialogCommonButtons.No Or TaskDialogCommonButtons.Cancel
        taskDialog.CommonButtons = buttons
        Dim taskDialogResult As TaskDialogResult = taskDialog.Show()

        If taskDialogResult = taskDialogResult.Yes Then
            Return Autodesk.Revit.UI.Result.Succeeded
        ElseIf taskDialogResult = taskDialogResult.No Then
            elements = uidoc.Selection.Elements
            message = "Failed to delete selection."
            Return Autodesk.Revit.UI.Result.Failed
        Else
            Return Autodesk.Revit.UI.Result.Cancelled
        End If
    Catch
        message = "Unexpected Exception thrown."
        Return Autodesk.Revit.UI.Result.Failed
    End Try

End Function

See Also

IExternalCommand Members
Autodesk.Revit.UI Namespace

IExternalCommand Members

[image] [image]