Revit 2013 API
IFCStairRampContainerInfo Members
IFCStairRampContainerInfo Class Methods See Also Send Feedback

The IFCStairRampContainerInfo type exposes the following members.

Methods

 | Name | Description
Public method | AddComponent | Adds a handle to one of the contained component lists.
 | AddStairRampContainerInfo | Add or replace stair/ramp containment information in the exporter class.
 | AppendStairRampContainerInfo | Appends stair/ramp containment information to an existing entry.
 | ContainsStairOrRamp | Checks if the stair or ramp element id has containment information.
 | Create(IFCAnyHandle, IList<(Of <<'(IFCAnyHandle>)>>), IFCAnyHandle) | Creates a new instance of an IFCStairRamp.
 | Create(IList<(Of <<'(IFCAnyHandle>)>>), IList<(Of <<'(IList<(Of <<'(IFCAnyHandle>)>>)>)>>), IList<(Of <<'(IFCAnyHandle>)>>)) | Creates a new instance of an IFCStairRamp.
Public method | Dispose | Releases all resources used by the IFCStairRampContainerInfo
Public method | GetComponents | Gets the list of handles to one of the contained component lists.
 | GetContainerInfo | Gets the containment information for a stair or ramp.
Public method | GetLocalPlacement | Gets the local placement of one of the contained component lists.
Public method | GetStairOrRampHandles | Returns the handles of the hosts in this container.

See Also

IFCStairRampContainerInfo Class
Autodesk.Revit.DB.IFC Namespace

IFCStairRampContainerInfo Methods

[image] [image]