Revit 2013 API
AddInId Members
AddInId Class Constructors Methods See Also Send Feedback

The AddInId type exposes the following members.

Constructors

 | Name | Description
Public method | AddInId | creates an AddInId object with a given GUID

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the AddInId
Public method | GetAddInName | name of addin associated with this AddInId Attempts to obtain the name from loaded Third Party AddIns
Public method | GetAddInNameFromDocument | name of application associated with this ApplicationId First attempts to obtain the name from AddInIds stored in the document. If unsuccessful, attempts to obtain the name from loaded Third Party AddIns.
Public method | GetGUID | value of the AddInId as a GUID

See Also

AddInId Class

AddInId Constructor

[image]