Revit 2013 API
FailureHandlingOptions Members
FailureHandlingOptions Class Methods See Also Send Feedback

The FailureHandlingOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the FailureHandlingOptions
Public method | GetClearAfterRollback | Checks if all posted failures should be removed silently when transaction is being rolled back.
Public method | GetDelayedMiniWarnings | Checks if showing of mini-warning dialog should be delayed till the end of next transaction.
Public method | GetFailuresPreprocessor | Getting a callback to be invoked in the beginning of failure processing.
Public method | GetForcedModalHandling | Checks if error handling dialog at the end of transaction should be modal.
Public method | GetTransactionFinalizer | Getting a callback to be executed after transaction is completed.
Public method | SetClearAfterRollback | Set the flag to clear all posted failures silently if transaction is being rolled back intentionally and delivering failures to the user is not desired.
Public method | SetDelayedMiniWarnings | Set the flag to delay showing of mini-warning dialog (if one is to be shown as a result of warnings in the current transaction) till the end of next transaction.
Public method | SetFailuresPreprocessor | Setting a callback to be invoked in the beginning of failure processing.
Public method | SetForcedModalHandling | Set the flag whether it pops modal error dialog if the transaction failed to finish.
Public method | SetTransactionFinalizer | Setting a callback to be executed after transaction is completed.

See Also

FailureHandlingOptions Class

FailureHandlingOptions Methods

[image] [image]