Revit 2013 API
BeamSystem Class
Members Example See Also Send Feedback
An object that represents a BeamSystem within the Autodesk Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class BeamSystem : Element
Visual Basic
Public Class BeamSystem _
    Inherits Element
Visual C++
public ref class BeamSystem : public Element

Remarks

This object derived from the Element base object. It can be used access the properties of a BeamSystem, such as elevation, level etc. All the beams belongs to a BeamSystem can be got and there is a static method to find out the BeamSystem to which the beam belongs.

Examples

CopyC#
public void GetInfo_BeamSystemType(BeamSystem beamSystem)
{
    string message = "BeamSystem : ";
    // Get BeamSystem type name
    message += "\nBeamSystem type name : " + beamSystem.BeamSystemType.Name;

    // Rename the BeamSystem type used by this BeamSystem
    beamSystem.BeamSystemType.Name = "TestBeamSystemTypeName";
    // Get BeamSystem type name
    message += "\nBeamSystem type name after set: " + beamSystem.BeamSystemType.Name;

    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Public Sub GetInfo_BeamSystemType(ByVal beamSystem As BeamSystem)
    Dim message As String = "BeamSystem : "
    ' Get BeamSystem type name
    message += vbLf & "BeamSystem type name : " + beamSystem.BeamSystemType.Name

    ' Rename the BeamSystem type used by this BeamSystem
    beamSystem.BeamSystemType.Name = "TestBeamSystemTypeName"
    ' Get BeamSystem type name
    message += vbLf & "BeamSystem type name after set: " + beamSystem.BeamSystemType.Name

    TaskDialog.Show("Revit", message)
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..BeamSystem

See Also

BeamSystem Members

BeamSystem Members

[image] [image]