Revit 2013 API
Rebar..::..Host Property
Rebar Class See Also Send Feedback
The element that contains the rebar.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This property is obsolete in Revit 2013. Use GetHostId and SetHostId instead.")]
public Element Host { get; set; }
Visual Basic
<ObsoleteAttribute("This property is obsolete in Revit 2013. Use GetHostId and SetHostId instead.")> _
Public Property Host As Element
    Get
    Set
Visual C++
[ObsoleteAttribute(L"This property is obsolete in Revit 2013. Use GetHostId and SetHostId instead.")]
public:
property Element^ Host {
    Element^ get ();
    void set (Element^ value);
}

Remarks

Returns the Autodesk Revit element that the rebar object belongs to, such as a structural wall, floor, foundation, beam, brace or column.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace

IncludeFirstBar Property

[image]