Revit 2013 API
ExporterIFCUtils..::..ExportRoofAsContainer Method
ExporterIFCUtils Class See Also Send Feedback
Exports a roof as a container of multiple roof slabs. Returns the handle, if successful.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static IFCAnyHandle ExportRoofAsContainer(
    ExporterIFC exporterIFC,
    string ifcEnumType,
    Element pRoofBase,
    GeometryElement geometry,
    IFCProductWrapper wrapper
)
Visual Basic
Public Shared Function ExportRoofAsContainer ( _
    exporterIFC As ExporterIFC, _
    ifcEnumType As String, _
    pRoofBase As Element, _
    geometry As GeometryElement, _
    wrapper As IFCProductWrapper _
) As IFCAnyHandle
Visual C++
public:
static IFCAnyHandle^ ExportRoofAsContainer(
    ExporterIFC^ exporterIFC,
    String^ ifcEnumType,
    Element^ pRoofBase,
    GeometryElement^ geometry,
    IFCProductWrapper^ wrapper
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
ifcEnumType
Type: System..::..String
The roof type.
pRoofBase
Type: Autodesk.Revit.DB..::..Element
The roof element.
geometry
Type: Autodesk.Revit.DB..::..GeometryElement
The geometry of the element.
wrapper
Type: Autodesk.Revit.DB.IFC..::..IFCProductWrapper
The product wrapper.

Return Value

The IfcRoof container.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace

ExportSlabAsExtrusion Method

[image]