Revit 2013 API
Level Class
Members Example See Also Send Feedback
Represents a Level line within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class Level : Element
Visual Basic
Public Class Level _
    Inherits Element
Visual C++
public ref class Level : public Element

Remarks

The Name property can be used to retrieve the user visible name of the level that appears in the level bubble.

Examples

CopyC#
private void Getinfo_Level(Document document)
{
    StringBuilder levelInformation = new StringBuilder();
    int levelNumber = 0;
    FilteredElementCollector collector = new FilteredElementCollector(document);
    ICollection<Element> collection = collector.OfClass(typeof(Level)).ToElements();
    foreach (Element e in collection)
    {
        Level level = e as Level;

        if (null != level)
        {
            // keep track of number of levels
            levelNumber++;

            //get the name of the level
            levelInformation.Append("\nLevel Name: " + level.Name);

            //get the elevation of the level
            levelInformation.Append("\n\tElevation: " + level.Elevation);

            // get the project elevation of the level
            levelInformation.Append("\n\tProject Elevation: " + level.ProjectElevation);
        }
    }

    //number of total levels in current document
    levelInformation.Append("\n\n There are " + levelNumber + " levels in the document!");

    //show the level information in the messagebox
    TaskDialog.Show("Revit",levelInformation.ToString());
}
CopyVB.NET
Private Sub Getinfo_Level(ByVal document As Document)
    Dim levelInformation As New StringBuilder()
    Dim levelNumber As Integer = 0
    Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(document)
    Dim collection As ICollection(Of Autodesk.Revit.DB.Element) = collector.OfClass(GetType(Autodesk.Revit.DB.Level)).ToElements()
    For Each e As Autodesk.Revit.DB.Element In collection
        Dim level As Autodesk.Revit.DB.Level = TryCast(e, Autodesk.Revit.DB.Level)

        If level IsNot Nothing Then
            ' keep track of number of levels
            System.Math.Max(System.Threading.Interlocked.Increment(levelNumber), levelNumber - 1)

            'get the name of the level
            levelInformation.Append(vbLf & "Level Name: " + level.Name)

            'get the elevation of the level
            levelInformation.Append(vbLf & vbTab & "Elevation: " + level.Elevation)

            ' get the project elevation of the level
            levelInformation.Append(vbLf & vbTab & "Project Elevation: " + level.ProjectElevation)
        End If
    Next

    'number of total levels in current document
    levelInformation.Append(vbLf & vbLf & " There are " + levelNumber + " levels in the document!")

    'show the level information in the messagebox
    TaskDialog.Show("Revit", levelInformation.ToString())
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..Level

See Also

Level Members

Level Members

[image] [image]