Revit 2013 API
PropertySetElement Methods
PropertySetElement Class See Also Send Feedback

The PropertySetElement type exposes the following members.

Methods

 | Name | Description
 | Create(Document, MaterialAspect) | Obsolete. Creates a new PropertySetElement initialized with default properties pertinent to the given material aspect.
 | Create(Document, StructuralAsset) | Creates a new PropertySetElement to contain the given asset.
 | Create(Document, ThermalAsset) | Creates a new PropertySetElement to contain the given asset.
Public method | Duplicate | Creates a duplicate of this PropertySetElement.
Public method | GetStructuralAsset |
Public method | GetThermalAsset |
Public method | SetStructuralAsset |
Public method | SetThermalAsset |

See Also

PropertySetElement Class

Create Method

[image] [image]