Revit 2013 API
Transaction Methods
Transaction Class See Also Send Feedback

The Transaction type exposes the following members.

Methods

 | Name | Description
Public method | Commit()()()() | Commits all changes made to the model during the transaction.
Public method | Commit(FailureHandlingOptions) | Commits all changes made to the model during the transaction.
Public method | Dispose |
Public method | GetFailureHandlingOptions | Returns the current failure handling options.
Public method | GetName | Returns the transaction's name.
Public method | GetStatus | Returns the current status of the transaction.
Public method | HasEnded | Determines whether the transaction has ended already.
Public method | HasStarted | Determines whether the transaction has been started yet.
Public method | RollBack()()()() | Rolls back all changes made to the model during the transaction.
Public method | RollBack(FailureHandlingOptions) | Rolls back all changes made to the model during the transaction.
Public method | SetFailureHandlingOptions | Sets options for handling failures to be used when the transaction is being committed or rolled back.
Public method | SetName | Sets the transaction's name.
Public method | Start()()()() | Starts the transaction.
Public method | Start(String) | Starts the transaction with an assigned name.

See Also

Transaction Class

Commit Method

[image] [image]