Revit 2013 API
Selection..::..PickElementsByRectangle Method (String)
Selection Class Example See Also Send Feedback
Prompts the user to select multiple elements by drawing a rectangle while showing a custom status prompt string.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public IList<Element> PickElementsByRectangle(
    string statusPrompt
)
Visual Basic
Public Function PickElementsByRectangle ( _
    statusPrompt As String _
) As IList(Of Element)
Visual C++
public:
IList<Element^>^ PickElementsByRectangle(
    String^ statusPrompt
)

Parameters

statusPrompt
Type: System..::..String
The message shown on the status bar.

Return Value

A collection of elements selected by the user.

Note: if the user cancels the operation (for example, through ESC), the method will throw an OperationCanceledException instance.

Remarks

Revit users will be permitted to manipulate the Revit view (zooming, panning, and rotating the view), but will not be permitted to click other items in the Revit user interface. Users are not permitted to switch the active view, close the active document or Revit application in the pick session, otherwise an exception will be thrown.

The selection will not be automatically added to the active selection buffer.

Note: this method must not be called during dynamic update, otherwise ForbiddenForDynamicUpdateException will be thrown.

Examples

CopyC#
// Choose objects from Revit.
IList<Element> rectanglePick = uidoc.Selection.PickElementsByRectangle("Select by rectangle");
foreach (Element element in rectanglePick)
{
    uidoc.Selection.Elements.Add(element);
}
TaskDialog.Show("Revit", string.Format("{0} elements added to Selection.", rectanglePick.Count));
CopyVB.NET
Dim selectionCount As Integer = choices.Elements.Size
' Choose objects from Revit.
Dim hasPickSome As IList(Of Autodesk.Revit.DB.Element) = choices.PickElementsByRectangle("Select by rectangle")
If hasPickSome.Count > 0 Then
    Dim newSelectionCount As Integer = choices.Elements.Size
    Dim prompt As String = String.Format("{0} elements added to Selection.", newSelectionCount - selectionCount)
    TaskDialog.Show("Revit", prompt)
End If

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the statusPrompt is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..OperationCanceledException | Thrown when the Revit user cancelled this operation. Thrown when the Revit user tried to switch the active view, close the active document or Revit application when responding to this mode.
Autodesk.Revit.Exceptions..::..ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.

See Also

Selection Class
PickElementsByRectangle Overload
Autodesk.Revit.UI.Selection Namespace

PickElementsByRectangle Method (ISelectionFilter)

[image]