Revit 2013 API
CompoundStructure..::..GetWallSweepsInfo Method
CompoundStructure Class See Also Send Feedback
Obtains a list of the intrinsic wall sweeps or reveals in this CompoundStructure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public IList<WallSweepInfo> GetWallSweepsInfo(
    WallSweepType wallSweepType
)
Visual Basic
Public Function GetWallSweepsInfo ( _
    wallSweepType As WallSweepType _
) As IList(Of WallSweepInfo)
Visual C++
public:
IList<WallSweepInfo^>^ GetWallSweepsInfo(
    WallSweepType wallSweepType
)

Parameters

wallSweepType
Type: Autodesk.Revit.DB..::..WallSweepType
Whether to obtain wall sweeps or reveals.

Return Value

An array which describes the intrinsic wall sweeps or reveals.

See Also

CompoundStructure Class

GetWidth Method

[image] [image]