Revit 2013 API
RenderingSettings..::..BackgroundStyle Property
RenderingSettings Class See Also Send Feedback
The enum value that controls the background style for rendering.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public BackgroundStyle BackgroundStyle { get; set; }
Visual Basic
Public Property BackgroundStyle As BackgroundStyle
    Get
    Set
Visual C++
public:
property BackgroundStyle BackgroundStyle {
    BackgroundStyle get ();
    void set (BackgroundStyle value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The enum value is not invalid for BackgroundStyle.

See Also

RenderingSettings Class

LightingSource Property

[image]