Revit 2013 API
ColumnAttachment Members
ColumnAttachment Class Methods Properties See Also Send Feedback

The ColumnAttachment type exposes the following members.

Methods

 | Name | Description
 | AddColumnAttachment | Attaches the column to the target. If an attachment already exists with the same "baseOrTop" value, no attachment is made.
Public method | Dispose | Releases all resources used by the ColumnAttachment
 | GetColumnAttachment(FamilyInstance, ElementId) | Look up a column attachment by specifying the target id.
 | GetColumnAttachment(FamilyInstance, Int32) | Look up a column attachment. There is at most one attachment on the base and one on the top.
 | IsValidColumn | Says whether a FamilyInstance supports column attachments.
 | IsValidTarget(Boolean, Element) | Says whether the element can be used as a target for a new attachment.
 | IsValidTarget(FamilyInstance, Element) | Says whether the element can be used as a target for a new attachment.
 | RemoveColumnAttachment(FamilyInstance, ElementId) | Removes any attachment of the column to the specified target.
 | RemoveColumnAttachment(FamilyInstance, Int32) | Removes an attachment at the top or base of a column, if there is one.
Public method | SetJustification |

Properties

 | Name | Description
Public property | AttachOffset |
Public property | BaseOrTop |
Public property | CutStyle |
Public property | Justification |
Public property | TargetId |

See Also

ColumnAttachment Class

ColumnAttachment Methods

[image] [image]