Revit 2013 API
RebarInSystem Properties
RebarInSystem Class See Also Send Feedback

The RebarInSystem type exposes the following members.

Properties

 | Name | Description
Public property | ArrayLength | Identifies the distribution path length of rebar set.
Public property | BarsOnNormalSide | Identifies if the bars of the rebar set are on the same side of the rebar plane indicated by the normal.
Public property | LayoutRule | Identifies the layout rule of rebar set.
Public property | MaxSpacing | Identifies the maximum spacing between rebar in rebar set.
Public property | Normal | A unit-length vector normal to the plane of the rebar
Public property | NumberOfBarPositions |
Public property | Quantity | Identifies the number of bars in rebar set.
Public property | RebarShapeId | The RebarShape element that defines the shape of the rebar.
Public property | ScheduleMark | The Schedule Mark parameter. On creation, the Schedule Mark is set to a value that is unique to the host, but it can be set to any value.
Public property | SystemId | The Id of an AreaReinforcement or PathReinforcement element that owns this element.
Public property | TotalLength | The length of an individual bar multiplied by Quantity.
Public property | Volume | The volume of an individual bar multiplied by Quantity.

See Also

RebarInSystem Class
Autodesk.Revit.DB.Structure Namespace

ArrayLength Property

[image]