Revit 2013 API
Document..::..NewWall Method (Curve, Level, Boolean)
Document Class Example See Also Send Feedback
Creates a new rectangular profile wall within the project using the default wall style.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2013. Please call a static creation method of Wall class instead.")]
public Wall NewWall(
    Curve curve,
    Level level,
    bool structural
)
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2013. Please call a static creation method of Wall class instead.")> _
Public Function NewWall ( _
    curve As Curve, _
    level As Level, _
    structural As Boolean _
) As Wall
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2013. Please call a static creation method of Wall class instead.")]
public:
Wall^ NewWall(
    Curve^ curve,
    Level^ level,
    bool structural
)

Parameters

curve
Type: Autodesk.Revit.DB..::..Curve
An arc or line representing the base line of the wall.
level
Type: Autodesk.Revit.DB..::..Level
The level on which the wall is to be placed.
structural
Type: System..::..Boolean
If set, specifies that the wall is structural in nature.

Return Value

If successful a new wall object within the project, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Examples

CopyC#
public Wall CreateWallUsingCurve1(Autodesk.Revit.DB.Document document, Level level)
{
    // Build a location line for the wall creation
    XYZ start = new XYZ(0, 0, 0);
    XYZ end = new XYZ(10, 10, 0);
    Line geomLine = document.Application.Create.NewLineBound(start, end);

    // Create a wall using the location line
    return Wall.Create(document, geomLine, level.Id, true);
}
CopyVB.NET
Public Function CreateWallUsingCurve1(ByVal document As Autodesk.Revit.DB.Document, ByVal level As Level) As Wall
    ' Build a location line for the wall creation
    Dim start As New Autodesk.Revit.DB.XYZ(0, 0, 0)
    Dim [end] As New Autodesk.Revit.DB.XYZ(10, 10, 0)
    Dim geomLine As Line = document.Application.Create.NewLineBound(start, [end])

    ' Create a wall using the location line
    Return document.Create.NewWall(geomLine, level, True)
End Function

See Also

Document Class
NewWall Overload
Autodesk.Revit.Creation Namespace

NewWall Method (CurveArray, WallType, Level, Boolean)

[image]