Revit 2013 API
ControlledApplication Properties
ControlledApplication Class See Also Send Feedback

The ControlledApplication type exposes the following members.

Properties

 | Name | Description
Public property | ActiveAddInId | Retrieves the Id of the currently running external application.
Public property | Cities | Returns a set of all the known city locations within Revit.
Public property | Create | Provides an object that can be used to create new instances of Autodesk Revit API objects.
Public property | IsQuiescent | Returns if the current application is quiescent.
Public property | Language | The language used in the current session of Revit.
Public property | Product | The product type for the current session of Revit.
Public property | RecordingJournalFilename | Retrieve the name of the journal file the Revit is currently recording to.
Public property | SharedParametersFilename | Contains the fully qualified path to a shared parameters file.
Public property | VersionBuild | Returns the internal build number of the Autodesk Revit application.
Public property | VersionName | Returns the name of the Revit application.
Public property | VersionNumber | Return the primary version of the Revit application.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace

ActiveAddInId Property

[image]