Revit 2013 API
RevitLinkLoadResultType Enumeration
See Also Send Feedback
Enum listing the possible results after loading a linked model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013
Since: 2013

Syntax

C#
public enum RevitLinkLoadResultType
Visual Basic
Public Enumeration RevitLinkLoadResultType
Visual C++
public enum class RevitLinkLoadResultType

Members

Member name | Description
LinkLoaded | The linked model loaded correctly.
LinkNotFound | The linked model could not be found.
LinkNotOpenable | An error occurred trying to read the linked model.
LinkOpenAsHost | The linked model is already opened directly in Revit.
SameModelAsHost | The linked model has the same path as the currently active document.
SameCentralModelAsHost | Either the linked model and its host document are both locals of the same central model, or one is a local and the other is its central.
LinkNotLoadedOtherError | An unknown error occurred.

Remarks

For all values except LinkLoadResultType.LinkLoaded, the linked model is not loaded and no new link is created (if Revit was trying to create a link).

See Also

RevitLinkOptions Class

[image]