Revit 2013 API
AssemblyInstance Members
AssemblyInstance Class Methods Properties See Also Send Feedback

The AssemblyInstance type exposes the following members.

Methods

 | Name | Description
Public method | AddMemberIds | Adds member element ids for the assembly instance.
Public method | AllowsAssemblyViewCreation | Returns true if assembly views can be created for this Assembly Instance.
 | AreElementsValidForAssembly | Identifies if provided assembly members are valid.
 | CanRemoveElementsFromAssembly | Identifies if provided assembly members can be removed from the assembly instance.
 | CompareAssemblyInstances | Compares two assembly instances and returns a result with details about the differences
 | Create | Creates a new assembly instance.
Public method | Disassemble | Removes the assembly instance and releases the member elements.
Public method | GetCenter | Returns the center of the bounding box for the assembly instance. This is the default position for placed assembly instances.
Public method | GetMemberIds | Gets member element ids for the assembly instance.
Public method | GetTransform | Gets the origin of the assembly instance.
 | IsValidNamingCategory | Identifies if the naming category is valid for an assembly instance.
 | PlaceInstance | Places an assembly instance of a given assembly type at the specified location.
Public method | RemoveMemberIds | Removes member element ids from the assembly instance.
Public method | SetMemberIds | Sets member element ids for the assembly instance. All existing members are cleared.
Public method | SetTransform | Sets the origin of the assembly instance.

Properties

 | Name | Description
Public property | AssemblyTypeName | The name for the assembly type. All matching assembly instances share this name. Unique assembly instances are named automatically based on their naming category.
Public property | Location | This property is used to find the physical location of the assembly instance within project. (Overrides Element..::..Location.)
Public property | NamingCategoryId | Id of the category that drives the default naming scheme for the assembly instance.

See Also

AssemblyInstance Class

AssemblyInstance Methods

[image] [image]