Revit 2013 API
Element..::..AssemblyInstanceId Property
Element Class See Also Send Feedback
The id of the assembly instance to which the element belongs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementId AssemblyInstanceId { get; }
Visual Basic
Public ReadOnly Property AssemblyInstanceId As ElementId
    Get
Visual C++
public:
property ElementId^ AssemblyInstanceId {
    ElementId^ get ();
}

Field Value

Assembly instance id, or InvalidElementId if element is not a member of an assembly.

See Also

Element Class

BoundingBox Property

[image]