Revit 2013 API
BuiltInFailures..::..OverlapFailures Properties
BuiltInFailures..::..OverlapFailures Class See Also Send Feedback

The BuiltInFailures..::..OverlapFailures type exposes the following members.

Properties

Name | Description
AreaBoundaryLinesOverlap | Highlighted area boundary lines overlap. Color fills, area tags, and areas may not behave correctly.
CurvesOverlap | Highlighted lines overlap. Lines may not form closed loops.
DivisionSketchOverlap | Curves in the sketch of the Division overlap.
DuplicateInstances | There are identical instances in the same place. This will result in double counting in schedules.
DuplicatePoints | There are identical points in the same place. Lines created from points may not work as expected.
DuplicateRebar | There are identical rebar in the same place. This will result in double counting in schedules.
LevelsOverlap | Highlighted levels overlap.
RoomSeparationLinesOverlap | Highlighted room separation lines overlap. One of them may be ignored when Revit finds room boundaries. Delete one of the lines.
SpaceSeparationLinesOverlap | Highlighted space separation lines overlap. One of them may be ignored when Revit finds space boundaries. Delete one of the lines.
WallAreaBoundaryOverlap | Wall and area boundary line overlap. Color fills, area tags and areas may not behave correctly.
WallRoomSeparationOverlap | A wall and a room separation line overlap. One of them may be ignored when Revit finds room boundaries. Shorten or delete the room separation line to remove the overlap.
WallsOverlap | Highlighted walls overlap. One of them may be ignored when Revit finds room boundaries. Use Cut Geometry to embed one wall within the other.
WallSpaceSeparationOverlap | A wall and a space separation line overlap. One of them may be ignored when Revit finds space boundaries. Shorten or delete the space separation line to remove the overlap.

See Also

BuiltInFailures..::..OverlapFailures Class

AreaBoundaryLinesOverlap Property

[image]