Revit 2013 API
RevitLinkType Members
RevitLinkType Class Methods Properties See Also Send Feedback

The RevitLinkType type exposes the following members.

Methods

 | Name | Description
 | Create | Creates a new Revit link type and loads the linked document.
Public method | GetChildIds | Gets the ids of the immediate children of this link.
Public method | GetParentId | Gets the id of this link's immediate parent.
Public method | GetRootId | Gets the id of the top-level link which this link is linked into.
 | GetTopLevelLink | Returns the ElementId of the (top-level) linked model with the given path.
 | IsLoaded | Checks whether the link with this id is loaded.

Properties

 | Name | Description
Public property | AttachmentType | The attachment/overlay status of this link.
Public property | IsNestedLink | Indicates whether this link is a nested or top-level link.

See Also

RevitLinkType Class

RevitLinkType Methods

[image] [image]