Revit 2013 API
FloorTypeSet Members
FloorTypeSet Class Constructors Methods Properties See Also Send Feedback

The FloorTypeSet type exposes the following members.

Constructors

 | Name | Description
Public method | FloorTypeSet | Initializes a new instance of the FloorTypeSet class

Methods

 | Name | Description
Public method | Clear | Removes every floor type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a floor type within the set.
Public method | Erase | Removes a specified floor type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | Insert | Insert the specified floor type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | Size | Returns the number of floor types that are in the set.

See Also

FloorTypeSet Class

FloorTypeSet Constructor

[image]