Revit 2013 API
LightType..::..SetInitialIntensity Method
LightType Class See Also Send Feedback
Replace the current initial intensity object with the given object

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetInitialIntensity(
    InitialIntensity initialIntensity
)
Visual Basic
Public Sub SetInitialIntensity ( _
    initialIntensity As InitialIntensity _
)
Visual C++
public:
void SetInitialIntensity(
    InitialIntensity^ initialIntensity
)

Parameters

initialIntensity
Type: Autodesk.Revit.DB.Lighting..::..InitialIntensity
An object derived from an InitialIntensity object

Remarks

The argument object is cloned

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

LightType Class
Autodesk.Revit.DB.Lighting Namespace

SetLightDistribution Method

[image]