Revit 2013 API
UpdaterRegistry Class
Members See Also Send Feedback
Application level singleton that stores registered Updaters Note: In order to use UpdaterRegistry functionality, add-ins must be registered using manifest files (rather than Revit.ini) UpdaterId::getAddInId() for any Updater/UpdaterId to be modified must match the addInId field in the add-in's manifest file. An add-in cannot add, remove, or modify updaters that do not belong to it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class UpdaterRegistry : IDisposable
Visual Basic
Public Class UpdaterRegistry _
    Implements IDisposable
Visual C++
public ref class UpdaterRegistry : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..UpdaterRegistry

See Also

UpdaterRegistry Members

UpdaterRegistry Members

[image] [image]