Revit 2013 API
AnalyticalModel..::..SetAnalyticalOffset Method
AnalyticalModel Class See Also Send Feedback
Sets Analytical Offset in the case where the user can do that.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2012. Call setOffset() instead.")]
public void SetAnalyticalOffset(
    XYZ offset
)
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2012. Call setOffset() instead.")> _
Public Sub SetAnalyticalOffset ( _
    offset As XYZ _
)
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2012. Call setOffset() instead.")]
public:
void SetAnalyticalOffset(
    XYZ^ offset
)

Parameters

offset
Type: Autodesk.Revit.DB..::..XYZ
Offset for the entire Analytical Model.

Remarks

This is different than Manual Analytical Adjustment, in that it is a basic offset that applies to the entire Analytical Model at once. Additionally, it is set in a different manner than Manual Analytical Adjustment, since it does not depend on another Element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InapplicableDataException | This AnalyticalModel does not support offset.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace

SetAnalyticalProjectionDatumPlane Method

[image] [image]