Revit 2013 API
FilteredElementCollector Constructor (Document, ElementId)
FilteredElementCollector Class Example See Also Send Feedback
Constructs a new FilteredElementCollector that will search and filter the visible elements in a view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FilteredElementCollector(
    Document document,
    ElementId viewId
)
Visual Basic
Public Sub New ( _
    document As Document, _
    viewId As ElementId _
)
Visual C++
public:
FilteredElementCollector(
    Document^ document,
    ElementId^ viewId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document that owns the view.
viewId
Type: Autodesk.Revit.DB..::..ElementId
The view id.

Remarks

Elements that will be passed by the collector have graphics that may be visible in the input view. Some elements may still be hidden because they are obscured by other elements. Accessing these visible elements may require Revit to rebuild the geometry of the view. The first time your code constructs a collector for a given view, or the first time your code constructs a collector for a view whose display settings have just been changed, you may experience a significant performance degradation.

Examples

CopyC#
private void CountElements(Autodesk.Revit.DB.Document document)
{
    StringBuilder message = new StringBuilder();
    FilteredElementCollector viewCollector =
        new FilteredElementCollector(document, document.ActiveView.Id);
    viewCollector.OfCategory(BuiltInCategory.OST_Walls);
    message.AppendLine("Wall category elements within active View: "
       + viewCollector.ToElementIds().Count);

    FilteredElementCollector docCollector = new FilteredElementCollector(document);
    docCollector.OfCategory(BuiltInCategory.OST_Walls);
    message.AppendLine("Wall category elements within document: "
       + docCollector.ToElementIds().Count);

    TaskDialog.Show("Revit", message.ToString());
}
CopyVB.NET
Private Sub CountElements(ByVal document As Autodesk.Revit.DB.Document)
    Dim message As New StringBuilder()
    Dim viewCollector As New Autodesk.Revit.DB.FilteredElementCollector(document, document.ActiveView.Id)
    viewCollector.OfCategory(BuiltInCategory.OST_Walls)
    message.AppendLine("Wall category elements within active View: " + viewCollector.ToElementIds().Count)

    Dim docCollector As New Autodesk.Revit.DB.FilteredElementCollector(document)
    docCollector.OfCategory(BuiltInCategory.OST_Walls)
    message.AppendLine("Wall category elements within document: " + docCollector.ToElementIds().Count)

    TaskDialog.Show("Revit", message.ToString())
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | viewId is not a view. -or- viewId is not valid for element iteration, because it has no way of representing drawn elements. Many view templates will fail this check.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FilteredElementCollector Class
FilteredElementCollector Overload

FilteredElementCollector Constructor (Document, ICollection(ElementId))

[image]