Revit 2013 API
Material..::..SetMaterialAspectByPropertySet Method
Material Class See Also Send Feedback
Set an aspect of the material to a shared property set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetMaterialAspectByPropertySet(
    MaterialAspect aspect,
    ElementId propertySetId
)
Visual Basic
Public Sub SetMaterialAspectByPropertySet ( _
    aspect As MaterialAspect, _
    propertySetId As ElementId _
)
Visual C++
public:
void SetMaterialAspectByPropertySet(
    MaterialAspect aspect,
    ElementId^ propertySetId
)

Parameters

aspect
Type: Autodesk.Revit.DB..::..MaterialAspect
The material aspect.
propertySetId
Type: Autodesk.Revit.DB..::..ElementId
Identifier of a shared property set (an instance of PropertySetElement).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

Material Class

SetMaterialAspectToIndependent Method

[image]