Revit 2013 API
RebarShapeConstraintProjectedSegmentLength Members
RebarShapeConstraintProjectedSegmentLength Class Constructors Methods Properties See Also Send Feedback

The RebarShapeConstraintProjectedSegmentLength type exposes the following members.

Constructors

 | Name | Description
Public method | RebarShapeConstraintProjectedSegmentLength | Initializes a new instance of the RebarShapeConstraintProjectedSegmentLength class

Methods

 | Name | Description
Public method | GetSegmentEndReferenceType | Choice of two possibilities for the start and end references of the length constraint.

Properties

 | Name | Description
Public property | Direction | A vector specifying the direction of the constraint. The direction is fixed, and the shape is always constructed so that the segment direction has a positive dot product with this vector.
Public property | TripleProductSign | Sign of the z-coordinate of the cross product of the Direction property with the segment vector. TripleProductSign is 1 if the segment direction is to be on the left of the constraint direction, or -1 if the segment direction is to be on the right.

See Also

RebarShapeConstraintProjectedSegmentLength Class
Autodesk.Revit.DB.Structure Namespace

RebarShapeConstraintProjectedSegmentLength Constructor

[image]