Revit 2013 API
Document..::..NewTopographySurface Method
Document Class See Also Send Feedback
Creates a new TopographySurface element in the document, and initializes it with a set of points.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public TopographySurface NewTopographySurface(
    IList<XYZ> points
)
Visual Basic
Public Function NewTopographySurface ( _
    points As IList(Of XYZ) _
) As TopographySurface
Visual C++
public:
TopographySurface^ NewTopographySurface(
    IList<XYZ^>^ points
)

Parameters

points
Type: System.Collections.Generic..::..IList<(Of <(<'XYZ>)>)>
An array of initial points for the surface.

Return Value

The TopographySurface element.

Remarks

This method will regenerate the document even in manual regeneration mode.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when input argument 'points' is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when points.Size is less than 3, to create a TopographySurface needs at least 3 points.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when regeneration fails.

See Also

Document Class
Autodesk.Revit.Creation Namespace

NewTransitionFitting Method

[image]