Revit 2013 API
RebarBendData Class
Members See Also Send Feedback
The class contains values that specify the bar diameter, bend diameters, and hook lengths of a rebar.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class RebarBendData : IDisposable
Visual Basic
Public Class RebarBendData _
    Implements IDisposable
Visual C++
public ref class RebarBendData : IDisposable

Remarks

These values are the ones required by RebarShape.ComputeShapeCurves() besides the shape-specific parameters. The purpose of collecting the values in this class is to allow you to create and analyze an accurate representation of a RebarShape, without creating a Rebar instance, and without referring to RebarBarType, RebarHookType, and RebarStyle. If you do have a Rebar instance, its GetBendData() method will produce a RebarBendData object.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Structure..::..RebarBendData

See Also

RebarBendData Members
Autodesk.Revit.DB.Structure Namespace

RebarBendData Members

[image] [image]