Revit 2013 API
Application..::..NewLineUnbound Method
Application Class Example See Also Send Feedback
Creates a new unbounded geometric line object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Line NewLineUnbound(
    XYZ point,
    XYZ direction
)
Visual Basic
Public Function NewLineUnbound ( _
    point As XYZ, _
    direction As XYZ _
) As Line
Visual C++
public:
Line^ NewLineUnbound(
    XYZ^ point,
    XYZ^ direction
)

Parameters

point
Type: Autodesk.Revit.DB..::..XYZ
A point through which the line will pass.
direction
Type: Autodesk.Revit.DB..::..XYZ
A vector for the direction of the line.

Return Value

A new unbounded line object.

Remarks

The line returned will be infinite in length and pass through the point provided in the specified direction. This method is useful for generating an axis around which an element can be rotated.

Examples

CopyC#
// define start point and direction for unbound line
XYZ startPoint = new XYZ(0, 0, 0);
XYZ directionPt = new XYZ(10, 10, 10);

// create line
Line line = application.Create.NewLineUnbound(startPoint, directionPt);
CopyVB.NET
' define start point and direction for unbound line
Dim startPoint As New Autodesk.Revit.DB.XYZ(0, 0, 0)
Dim directionPt As New Autodesk.Revit.DB.XYZ(10, 10, 10)

' create line
Dim line As Line = application.Create.NewLineUnbound(startPoint, directionPt)

See Also

Application Class
Autodesk.Revit.Creation Namespace

NewLoadCaseArray Method

[image]