Revit 2013 API
Grid Members
Grid Class Methods Properties See Also Send Feedback

The Grid type exposes the following members.

Methods

 | Name | Description
Public method | ExtendToAllLevels | Adjust the grid to cut all levels.
Public method | GetExtents | Gets the extents of the grid in the model.

Properties

 | Name | Description
Public property | Curve | Retrieves an object that represents the geometry of the grid line.
Public property | GridType | Get and Set the type of the grid object.
Public property | IsCurved | Test to see if the grid line is curved or straight.

See Also

Grid Class

Grid Methods

[image] [image]