Revit 2013 API
Family Properties
Family Class See Also Send Feedback

The Family type exposes the following members.

Properties

 | Name | Description
Public property | CurtainPanelHorizontalSpacing | For Curtain Panel families, the horizontal spacing of the driving mesh.
Public property | CurtainPanelTilePattern | For Curtain Panel families, the choice of tile pattern.
Public property | CurtainPanelVerticalSpacing | For Curtain Panel families, the vertical spacing of the driving mesh.
Public property | FamilyPlacementType | Identifies the type of placement required by a given family.
Public property | IsConceptualMassFamily | Whether the Family is a Conceptual Mass family.
Public property | IsCurtainPanelFamily | Whether the Family is a Curtain Panel family. Curtain Panel family symbols are used as the ObjectTypes of DividedSurface elements.
Public property | IsEditable | Indicates if this family supports editing.
Public property | IsInPlace | Indicates if this family is an in-place family or not.
Public property | ShowSpatialElementCalculationPoint | For families that can have a calculation point for spatial elements, hide or show the calculation point. SpatialElementCalculationPoint elements.
Public property | Symbols | A set of all symbols (types) that belong to a Family.

See Also

Family Class

CurtainPanelHorizontalSpacing Property

[image]