Revit 2013 API
AnnotationSymbolTypeSet Members
AnnotationSymbolTypeSet Class Constructors Methods Properties See Also Send Feedback

The AnnotationSymbolTypeSet type exposes the following members.

Constructors

 | Name | Description
Public method | AnnotationSymbolTypeSet | Initializes a new instance of the AnnotationSymbolTypeSet class

Methods

 | Name | Description
Public method | Clear | Removes every AnnotationSymbol type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a AnnotationSymbol type within the set.
Public method | Erase | Removes a specified AnnotationSymbol type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | Insert | Insert the specified AnnotationSymbol type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | Size | Returns the number of AnnotationSymbol types that are in the set.

See Also

AnnotationSymbolTypeSet Class

AnnotationSymbolTypeSet Constructor

[image]