Revit 2013 API
DuctSizeIterator Members
DuctSizeIterator Class Methods Properties See Also Send Feedback

The DuctSizeIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the DuctSizeIterator
Public method | GetCurrent | Returns the current MEPSize.
Public method | HasCurrent | Identifies if the iterator has a current item.
Public method | IsDone | Identifies if the iteration has completed.
Public method | MoveNext | Increments the iterator to the next item.
Public method | Reset | Resets the iterator to the initial state.

Properties

 | Name | Description
Public property | Current | Gets the item at the current position of the iterator.
Protected property | CurrentObject |

See Also

DuctSizeIterator Class
Autodesk.Revit.DB.Mechanical Namespace

DuctSizeIterator Methods

[image] [image]