Revit 2013 API
FabricReinSpanSymbol..::..Create Method
FabricReinSpanSymbol Class See Also Send Feedback
Creates a new instance of FabricReinSpanSymbol in the project

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static FabricReinSpanSymbol Create(
    Document doc,
    ElementId viewId,
    LinkElementId hostId,
    XYZ point,
    ElementId symbolId
)
Visual Basic
Public Shared Function Create ( _
    doc As Document, _
    viewId As ElementId, _
    hostId As LinkElementId, _
    point As XYZ, _
    symbolId As ElementId _
) As FabricReinSpanSymbol
Visual C++
public:
static FabricReinSpanSymbol^ Create(
    Document^ doc,
    ElementId^ viewId,
    LinkElementId^ hostId,
    XYZ^ point,
    ElementId^ symbolId
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
A document.
viewId
Type: Autodesk.Revit.DB..::..ElementId
The id of the view in which the symbol should appear
hostId
Type: Autodesk.Revit.DB..::..LinkElementId
The id of the FabricSheet host (either in the document, or linked from another document)
point
Type: Autodesk.Revit.DB..::..XYZ
The span symbol's head position
symbolId
Type: Autodesk.Revit.DB..::..ElementId
The id of the family symbol of this symbol

Return Value

A reference to the newly-created symbol.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural.

See Also

FabricReinSpanSymbol Class
Autodesk.Revit.DB.Structure Namespace

FabricReinSpanSymbol Properties

[image] [image]