Revit 2013 API
PartUtils..::..IsMaxDivisionDepthReached Method
PartUtils Class See Also Send Feedback
Identifies if elements have reached their maximum division depth.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
[ObsoleteAttribute("This method will be obsolete in the next version. It returns false always.")]
public static bool IsMaxDivisionDepthReached(
    Document doc,
    ElementId elementId
)
Visual Basic
<ObsoleteAttribute("This method will be obsolete in the next version. It returns false always.")> _
Public Shared Function IsMaxDivisionDepthReached ( _
    doc As Document, _
    elementId As ElementId _
) As Boolean
Visual C++
[ObsoleteAttribute(L"This method will be obsolete in the next version. It returns false always.")]
public:
static bool IsMaxDivisionDepthReached(
    Document^ doc,
    ElementId^ elementId
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
The document.
elementId
Type: Autodesk.Revit.DB..::..ElementId
Element ids to be tested for division

Return Value

True if maximum division depth was reached for an element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PartUtils Class

IsMergedPart Method

[image]