Revit 2013 API
Document..::..RoofTypes Property
Document Class See Also Send Feedback
Retrieves an object that contains all the roof types that are currently loaded into the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public RoofTypeSet RoofTypes { get; }
Visual Basic
Public ReadOnly Property RoofTypes As RoofTypeSet
    Get
Visual C++
public:
property RoofTypeSet^ RoofTypes {
    RoofTypeSet^ get ();
}

Remarks

This property returns a set of RoofType objects.

See Also

Document Class

RoomTagTypes Property

[image]