Revit 2013 API
CurveElement Properties
CurveElement Class See Also Send Feedback

The CurveElement type exposes the following members.

Properties

 | Name | Description
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property.
Public property | CurveElementType | The curve element type.
Public property | GeometryCurve | Geometry curve of the curve element.
Public property | LineStyle | The line style of this curve element.
Public property | LineStyles | Obsolete. All available line styles.
Public property | SketchPlane | The sketch plane the curve element lies in.

See Also

CurveElement Class

CenterPointReference Property

[image]