Revit 2013 API
Selection Members
Selection Class Methods Properties See Also Send Feedback

The Selection type exposes the following members.

Methods

 | Name | Description
Public method | GetElementIds | The ids of the elements that are currently selected.
Public method | PickBox(PickBoxStyle) | Invokes a general purpose two-click editor that lets the user to specify a rectangular area on the screen.
Public method | PickBox(PickBoxStyle, String) | Invokes a general purpose two-click editor that lets the user to specify a rectangular area on the screen.
Public method | PickElementsByRectangle()()()() | Prompts the user to select multiple elements by drawing a rectangle.
Public method | PickElementsByRectangle(String) | Prompts the user to select multiple elements by drawing a rectangle while showing a custom status prompt string.
Public method | PickElementsByRectangle(ISelectionFilter) | Prompts the user to select multiple elements by drawing a rectangle which pass a customer filter.
Public method | PickElementsByRectangle(ISelectionFilter, String) | Prompts the user to select multiple elements by drawing a rectangle which pass a customer filter while showing a custom status prompt string.
Public method | PickObject(ObjectType) | Prompts the user to select one object.
Public method | PickObject(ObjectType, ISelectionFilter) | Prompts the user to select one object which passes a custom filter.
Public method | PickObject(ObjectType, String) | Prompts the user to select one object while showing a custom status prompt string.
Public method | PickObject(ObjectType, ISelectionFilter, String) | Prompts the user to select one object which passes a custom filter while showing a custom status prompt string.
Public method | PickObjects(ObjectType) | Prompts the user to select multiple objects.
Public method | PickObjects(ObjectType, ISelectionFilter) | Prompts the user to select multiple objects which pass a customer filter.
Public method | PickObjects(ObjectType, String) | Prompts the user to select multiple objects while showing a custom status prompt string.
Public method | PickObjects(ObjectType, ISelectionFilter, String) | Prompts the user to select multiple objects which pass a custom filter while showing a custom status prompt string.
Public method | PickObjects(ObjectType, ISelectionFilter, String, IList<(Of <<'(Reference>)>>)) | Prompts the user to select multiple objects which pass a custom filter while showing a custom status prompt string. A preselected set of objects may be supplied and will be selected at the start of the selection.
Public method | PickPoint()()()() | Prompts the user to pick a point on the active work plane.
Public method | PickPoint(String) | Prompts the user to pick a point on the active work plane while showing a custom status prompt string.
Public method | PickPoint(ObjectSnapTypes) | Prompts the user to pick a point on the active work plane using specified snap settings.
Public method | PickPoint(ObjectSnapTypes, String) | Prompts the user to pick a point on the active work plane using specified snap settings while showing a custom status prompt string.

Properties

 | Name | Description
Public property | Elements | The elements that are shown as selected in the Revit user-interface.

See Also

Selection Class
Autodesk.Revit.UI.Selection Namespace

Selection Methods

[image] [image]