Revit 2013 API
AnalyticalModel..::..IsValidAnalyticalProjectionType Method
AnalyticalModel Class See Also Send Feedback
Indicates if a given Analytical Projection Type is valid for the given Analytical Direction.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2012. Call isValidProjectionType() instead.")]
public bool IsValidAnalyticalProjectionType(
    AnalyticalDirection direction,
    AnalyticalProjectionType projectionType
)
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2012. Call isValidProjectionType() instead.")> _
Public Function IsValidAnalyticalProjectionType ( _
    direction As AnalyticalDirection, _
    projectionType As AnalyticalProjectionType _
) As Boolean
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2012. Call isValidProjectionType() instead.")]
public:
bool IsValidAnalyticalProjectionType(
    AnalyticalDirection direction,
    AnalyticalProjectionType projectionType
)

Parameters

direction
Type: Autodesk.Revit.DB.Structure..::..AnalyticalDirection
Direction in which Analytical Model may be projected.
projectionType
Type: Autodesk.Revit.DB.Structure..::..AnalyticalProjectionType
Analytical Projection Type for Analytical Model Projection.

Return Value

True if Analytical Projection Type is valid; false otherwise. False if direction does not satisfy isValidDirectionForProjection().

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace

IsValidDatumPlaneForProjection Method

[image]