Revit 2013 API
SpatialElementCalculationPoint..::..Position Property
SpatialElementCalculationPoint Class See Also Send Feedback
The position of the spatial element calculation point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public XYZ Position { get; set; }
Visual Basic
Public Property Position As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ Position {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

This is used as the search point for family instances placement inside rooms and spaces.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

SpatialElementCalculationPoint Class

SpatialElementGeometryCalculator Class

[image]