Revit 2013 API
UIApplication Members
UIApplication Class Constructors Methods Properties Events See Also Send Feedback

The UIApplication type exposes the following members.

Constructors

 | Name | Description
Public method | UIApplication | Use a database level Application to construct a UI-level Application.

Methods

 | Name | Description
Public method | CreateAddInCommandBinding | Creates a new AddInCommandBinding.
Public method | CreateRibbonPanel(String) | Create a new RibbonPanel on the Add-Ins tab.
Public method | CreateRibbonPanel(String, String) | Create a new RibbonPanel on the specified tab.
Public method | CreateRibbonPanel(Tab, String) | Create a new RibbonPanel on the designated standard Revit tab.
Public method | CreateRibbonTab | Creates a new tab on the Revit user interface.
Public method | Dispose | Releases all resources used by the UIApplication
 | DoDragDrop(ICollection<(Of <<'(String>)>>)) | Initiates a drag and drop operation of a collection of file names on the Revit user interface.
 | DoDragDrop(Object, IDropHandler) | Initiates a drag and drop operation with a custom drop implementation.
Public method | GetRibbonPanels()()()() | Get all the custom Panels on Add-Ins tab of Revit.
Public method | GetRibbonPanels(String) | Get all the custom Panels on a designated Revit tab.
Public method | GetRibbonPanels(Tab) | Get all the custom Panels on a designated standard Revit tab.
Public method | OpenAndActivateDocument(String) | Opens and activates a Revit document.
Public method | OpenAndActivateDocument(ModelPath, OpenOptionsForUI) | Opens and activates a Revit document.
Public method | RemoveAddInCommandBinding | Removes an AddInCommandBinding.

Properties

 | Name | Description
Public property | ActiveAddInId | Get current active external application or external command id.
Public property | ActiveUIDocument | Provides access to an object that represents the currently active project.
Public property | Application | Returns the database level Application represented by this UI level Application.
Public property | DrawingAreaExtents | Get the rectangle that represents the screen pixel coordinates of drawing area.
Public property | LoadedApplications | Returns an array of successfully loaded external applications.
Public property | MainWindowExtents | Get the rectangle that represents the screen pixel coordinates of Revit main window.

Events

 | Name | Description
Public event | ApplicationClosing | Subscribe to the ApplicationClosing event to be notified when the Revit application is just about to be closed.
Public event | DialogBoxShowing | Subscribe to the DialogBoxShowing event to be notified when Revit is just about to show a dialog box or a message box.
Public event | DisplayingOptionsDialog | Subscribe to the options dialog displaying event to be notified when Revit options dialog is displaying.
Public event | Idling | Subscribe to the Idling event to be notified when Revit is not in an active tool or transaction.
Public event | ViewActivated | Subscribe to the ViewActivated event to be notified immediately after Revit has finished activating a view of a document.
Public event | ViewActivating | Subscribe to the ViewActivating event to be notified when Revit is just about to activate a view of a document.

See Also

UIApplication Class
Autodesk.Revit.UI Namespace

UIApplication Constructor

[image]