Revit 2013 API
Application..::..NewLine Method
Application Class Example See Also Send Feedback
Creates a new bound or unbounded geometric line object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Line NewLine(
    XYZ point,
    XYZ endOrDirection,
    bool bound
)
Visual Basic
Public Function NewLine ( _
    point As XYZ, _
    endOrDirection As XYZ, _
    bound As Boolean _
) As Line
Visual C++
public:
Line^ NewLine(
    XYZ^ point,
    XYZ^ endOrDirection,
    bool bound
)

Parameters

point
Type: Autodesk.Revit.DB..::..XYZ
A start point or a point through which the line will pass.
endOrDirection
Type: Autodesk.Revit.DB..::..XYZ
An end point of a vector for the direction of the line.
bound
Type: System..::..Boolean
Set to True if you wish the line to be bound or False is the line is to be infinite.

Return Value

A new bounded or unbounded line object.

Remarks

If the bound parameter is False then the point parameter is considered to be a point on the line and the endOrDirection parameter is considered to be a directional vector. If the bound parameter is True then the point parameter is considered to be the start of the line and the endOrDirection parameter is considered to be the end of the line.

Examples

CopyC#
XYZ startPoint = new XYZ(0, 0, 0);
XYZ endPoint = new XYZ(10, 10, 10);

// Create unbound line
Line line1 = application.Create.NewLine(startPoint, endPoint, false);

// Create bound line
Line line2 = application.Create.NewLine(startPoint, endPoint, true);
CopyVB.NET
Dim startPoint As New Autodesk.Revit.DB.XYZ(0, 0, 0)
Dim endPoint As New Autodesk.Revit.DB.XYZ(10, 10, 10)

' Create unbound line
Dim line1 As Line = application.Create.NewLine(startPoint, endPoint, False)

' Create bound line
Dim line2 As Line = application.Create.NewLine(startPoint, endPoint, True)

See Also

Application Class
Autodesk.Revit.Creation Namespace

NewLineBound Method

[image]