Revit 2013 API
Document..::..NewCurtainSystem Method (FaceArray, CurtainSystemType)
Document Class See Also Send Feedback
Creates a new CurtainSystem element from a set of faces.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CurtainSystem NewCurtainSystem(
    FaceArray faces,
    CurtainSystemType curtainSystemType
)
Visual Basic
Public Function NewCurtainSystem ( _
    faces As FaceArray, _
    curtainSystemType As CurtainSystemType _
) As CurtainSystem
Visual C++
public:
CurtainSystem^ NewCurtainSystem(
    FaceArray^ faces,
    CurtainSystemType^ curtainSystemType
)

Parameters

faces
Type: Autodesk.Revit.DB..::..FaceArray
The faces new CurtainSystem will be created on.
curtainSystemType
Type: Autodesk.Revit.DB..::..CurtainSystemType
The Type of CurtainSystem to be created.

Return Value

The CurtainSystem created will be returned when the operation succeeds.

Remarks

The input faces will be copied during the operations so that they can be any faces.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown in following cases: The input argument faces or curtainSystemType is nullNothingnullptra null reference (Nothing in Visual Basic). The size of faces is zero.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the CurtainSystem cannot be created or regenerate fails.

See Also

Document Class
NewCurtainSystem Overload
Autodesk.Revit.Creation Namespace

NewCurtainSystem Method (ReferenceArray, CurtainSystemType)

[image]