Revit 2013 API
UpdaterRegistry Methods
UpdaterRegistry Class See Also Send Feedback

The UpdaterRegistry type exposes the following members.

Methods

 | Name | Description
 | AddTrigger(UpdaterId, ElementFilter, ChangeType) | Adds trigger with the specified element filter and ChangeType for all documents associated with this Updater
 | AddTrigger(UpdaterId, Document, ElementFilter, ChangeType) | Adds trigger with the specified element filter and ChangeType for the specified document
 | AddTrigger(UpdaterId, Document, ICollection<(Of <<'(ElementId>)>>), ChangeType) | Adds a trigger to an updater with specified set of elements and ChangeType
Public method | Dispose |
 | GetIsUpdaterOptional | Check if the updater is optional or not.
 | GetRegisteredUpdaterInfos()()()() | Returns UpdaterInfos for all the application-wide updaters.
 | GetRegisteredUpdaterInfos(Document) | Returns UpdaterInfos for all the updaters applicable to the specified document.
 | IsUpdaterRegistered | Checks whether an updater with the given id is registered
 | RegisterUpdater(IUpdater) | Registers an updater on an application level
 | RegisterUpdater(IUpdater, Document) | Registers the updater for the specified document
 | RegisterUpdater(IUpdater, Boolean) | Registers an updater on an application level
 | RegisterUpdater(IUpdater, Document, Boolean) | Registers the updater for the specified document
 | RemoveAllTriggers | Removes all triggers associated with Updater with specified UpdaterId. Does not unregister updater.
 | RemoveDocumentTriggers | Removes all triggers associated with specified document and Updater Does not unregister updater.
 | SetExecutionOrder | Forces execution order between two updaters Execution order: first before second
 | SetIsUpdaterOptional | Set kind of specified updater.
 | UnregisterUpdater | Removes the updater associated with the input id from the UpdaterRegistry. Also removes all triggers associated with the Updater.

See Also

UpdaterRegistry Class

AddTrigger Method

[image] [image]