Revit 2013 API
TaskDialog Properties
TaskDialog Class See Also Send Feedback

The TaskDialog type exposes the following members.

Properties

 | Name | Description
Public property | AllowCancellation | Whether the task dialog can be cancelled if no cancel button is specified.
Public property | CommonButtons | The push buttons displayed in the task dialog.
Public property | DefaultButton | The default button for the dialog.
Public property | ExpandedContent | ExpandedContent is hidden by default and will display at the bottom of the task dialog when the "Show details" button is pressed.
Public property | FooterText | FooterText is used in the footer area of the task dialog.
Public property | Id | The Id of the task dialog.
Public property | MainContent | MainContent is the smaller text that appears just below the main instructions.
Public property | MainIcon | The icon shown in the task dialog.
Public property | MainInstruction | The large primary text that appears at the top of a task dialog.
Public property | Title | Title of the task dialog.
Public property | TitleAutoPrefix | Whether the TaskDialog's title will automatically have the add-in name added as a prefix.
Public property | VerificationText | VerificationText is used to label the verification checkbox.

See Also

TaskDialog Class
Autodesk.Revit.UI Namespace

AllowCancellation Property

[image]