Revit 2013 API
FilledRegion Members
FilledRegion Class Methods Properties See Also Send Feedback

The FilledRegion type exposes the following members.

Methods

 | Name | Description
 | Create | Creates a filled region from the given boundaries.
Public method | GetBoundaries | Gets the boundaries.
 | GetValidLineStyleIdsForFilledRegion | Gets the line style Ids which are permitted to be assigned to a filled region.
 | IsValidFilledRegionTypeId | Indicates whether the given Id is a valid filled region type Id.
 | IsValidLineStyleIdForFilledRegion | Indicates whether the given Id is a valid line style Id.
Public method | SetLineStyleId | Sets the line style Id for all boundaries.

Properties

 | Name | Description
Public property | IsMasking | Indicates whether the filled region is masking or not.

See Also

FilledRegion Class

FilledRegion Methods

[image] [image]