Revit 2013 API
BarDescription..::..BarType Property
BarDescription Class See Also Send Feedback
Retrieves the Rebar Bar Type property of a Bar Description.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This property is obsolete in Revit 2013. Use property BarTypeId instead.")]
public RebarBarType BarType { get; }
Visual Basic
<ObsoleteAttribute("This property is obsolete in Revit 2013. Use property BarTypeId instead.")> _
Public ReadOnly Property BarType As RebarBarType
    Get
Visual C++
[ObsoleteAttribute(L"This property is obsolete in Revit 2013. Use property BarTypeId instead.")]
public:
property RebarBarType^ BarType {
    RebarBarType^ get ();
}

See Also

BarDescription Class
Autodesk.Revit.DB.Structure Namespace

BarTypeId Property

[image]