Revit 2013 API
View..::..HideCategoriesTemporary Method
View Class See Also Send Feedback
Set multiple categories to be temporarily hidden in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void HideCategoriesTemporary(
    IList<ElementId> elementIds
)
Visual Basic
Public Sub HideCategoriesTemporary ( _
    elementIds As IList(Of ElementId) _
)
Visual C++
public:
void HideCategoriesTemporary(
    IList<ElementId^>^ elementIds
)

Parameters

elementIds
Type: System.Collections.Generic..::..IList<(Of <(<'ElementId>)>)>
Ids of the categories to be hidden

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Some elements in elementIds do not correspond to a Category.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

View Class

HideCategoryTemporary Method

[image]