Revit 2013 API
SpatialFieldManager Members
SpatialFieldManager Class Methods Properties See Also Send Feedback

The SpatialFieldManager type exposes the following members.

Methods

 | Name | Description
Public method | AddSpatialFieldPrimitive()()()() | Creates empty analysis results primitive not associated with any geometry element
Public method | AddSpatialFieldPrimitive(Reference) | Creates an empty analysis results primitive associated with a reference.
Public method | AddSpatialFieldPrimitive(Curve, Transform) | Creates empty analysis results primitive associated with a curve and a transform.
Public method | AddSpatialFieldPrimitive(Face, Transform) | Creates empty analysis results primitive associated with a face and a transform.
Public method | AddSpatialFieldPrimitive(Reference, SpatialFieldPrimitiveHideMode) | Creates an empty analysis results primitive associated with a reference, with the option to control how the reference element is hidden.
Public method | Clear | Clear all analysis results managed by this manager object
 | CreateSpatialFieldManager | Factory method - creates manager object for the given view
Public method | GetLegend | Returns legend element or NULL
Public method | GetMaximum | Calculates the maximum value for all primitives
Public method | GetMinimum | Calculates the minimum value for all primitives
Public method | GetRegisteredResults | Returns an array of indices of all registered results
Public method | GetResultSchema | Returns result schema by index
 | GetSpatialFieldManager | Retrieves manager object for the given view or returns NULL
Public method | IsResultSchemaNameUnique | Verify the uniqueness of the name among all registered result schemas.
 | IsTextTypeIdValid | Verify if text type id is valid.
Public method | RegisterResult | Registers result and assigns it a unique result index
Public method | RemoveSpatialFieldPrimitive | Removes analysis results primitive identified by the unique index
Public method | SetMeasurementDescriptions | Sets Descriptions for all measurements
Public method | SetMeasurementNames | Sets Names for all measurements
Public method | SetResultSchema | Sets a new value for an existing result schema in the result registry
Public method | SetUnits | Obsolete. Sets names and multipliers for all units that can be used for analysis results visualization; current units can later be changed by accessor method
Public method | UpdateSpatialFieldPrimitive(Int32, FieldDomainPoints, FieldValues) | Obsolete. Populates analysis results data (or replaces the existing data) in the existing primitive identified by the unique index
Public method | UpdateSpatialFieldPrimitive(Int32, FieldDomainPoints, FieldValues, Int32) | Populates analysis results data (or replaces the existing data) in the existing primitive identified by the unique index

Properties

 | Name | Description
Public property | CurrentMeasurement | Stores the currently displayed measurement
Public property | LegendPosition | Stores current position of analysis results legend element in view
Public property | LegendShowConfigurationName | If true legend contains analysis configuration name.
Public property | LegendShowDescription | If true legend contains analysis description.
Public property | LegendTextTypeId | Stores element id of text associated with common (result-independent) part of legend in view.
Public property | NumberOfMeasurements | Stores the total number of measurements
Public property | ResultsVisibleInView | Enables analysis results visibility in the view.
Public property | UseRangeForAllMeasurements | Governs how minimum and maximum values (the data range) are calculated.

See Also

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace

SpatialFieldManager Methods

[image] [image]