Revit 2013 API
Element..::..ChangeTypeId Method (ElementId)
Element Class See Also Send Feedback
Changes type of the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ElementId ChangeTypeId(
    ElementId typeId
)
Visual Basic
Public Function ChangeTypeId ( _
    typeId As ElementId _
) As ElementId
Visual C++
public:
ElementId^ ChangeTypeId(
    ElementId^ typeId
)

Parameters

typeId
Type: Autodesk.Revit.DB..::..ElementId
Identifier of the type to assign to this element.

Return Value

The new element id if new element is created, or invalid element id.

Remarks

In some cases, applying a change in type will result in a new element being created. The only active examples of this are when applying a normal wall type to a curtain panel, or converting such a wall back to a curtain panel. In this situation the new element id is returned. Note: this function needs an open transaction. Note: this function calls regeneration.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The type typeId is not valid for this element.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | This Element cannot have type assigned.

See Also

Element Class
ChangeTypeId Overload

ChangeTypeId Method (Document, ICollection(ElementId), ElementId)

[image]