Revit 2013 API
Viewport Methods
Viewport Class See Also Send Feedback

The Viewport type exposes the following members.

Methods

 | Name | Description
 | CanAddViewToSheet | Verifies that the view can be added to the ViewSheet.
 | Create | Creates a new Viewport at a given location on a sheet.
Public method | GetBoxOutline | Returns the outline of the viewport on the sheet, excluding the viewport label.
Public method | GetLabelOutline | Gets the outline viewport's label on the sheet.

See Also

Viewport Class

CanAddViewToSheet Method

[image]