Revit 2013 API
ExternalServiceRegistry Methods
ExternalServiceRegistry Class See Also Send Feedback

The ExternalServiceRegistry type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
 | ExecuteService(Guid, IExternalData) | Execute a service independently of any document.
 | ExecuteService(Guid, Document, IExternalData) | Execute the service for the given document.
 | GetService | Returns an instance of an object that represents the external service with the given Id.
 | GetServices | Returns a collection of all external services currently registered in Revit.
 | RegisterService(ISingleServerService, Boolean) | A method to register a single-server service.
 | RegisterService(IMultiServerService, Boolean, ExecutionPolicy) | A method to register a multi-server service.

See Also

ExternalServiceRegistry Class
Autodesk.Revit.DB.ExternalService Namespace

Dispose Method

[image]