Revit 2013 API
PointCloudInstance..::..GetPoints Method
PointCloudInstance Class Example See Also Send Feedback
Extracts a collection of points based on a filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public PointCollection GetPoints(
    PointCloudFilter filter,
    int numPoints
)
Visual Basic
Public Function GetPoints ( _
    filter As PointCloudFilter, _
    numPoints As Integer _
) As PointCollection
Visual C++
public:
PointCollection^ GetPoints(
    PointCloudFilter^ filter,
    int numPoints
)

Parameters

filter
Type: Autodesk.Revit.DB.PointClouds..::..PointCloudFilter
The filter to control which points are extracted. The filter should be passed in the coordinates of the Revit model.
numPoints
Type: System..::..Int32
The maximum number of points requested.

Return Value

A collection object containing points that pass the filter, but no more than the maximum number requested.

Remarks

If there are more points in the cloud passing the filter than the number requested in this function, the results may not be consistent if the same call is made again.

Examples

CopyC#
private void GetPointCloudDataByIteration(PointCloudInstance pcInstance, PointCloudFilter pointCloudFilter)
{
    // read points by iteration
    PointCollection points = pcInstance.GetPoints(pointCloudFilter, 10000); // Get points.  Number of points is determined by the needs of the client
    foreach (CloudPoint point in points)
    {
        // Process each point
        System.Drawing.Color color = System.Drawing.ColorTranslator.FromWin32(point.Color);
        String pointDescription = String.Format("({0}, {1}, {2}, {3}", point.X, point.Y, point.Z, color.ToString());
    }
}
    // read points by pointer
public unsafe void GetPointCloudDataByPointer(PointCloudInstance pcInstance, PointCloudFilter pointCloudFilter)
{
    PointCollection points = pcInstance.GetPoints(pointCloudFilter, 10000);
    CloudPoint* pointBuffer = (CloudPoint*)points.GetPointBufferPointer().ToPointer();
    int totalCount = points.Count;
    for (int numberOfPoints = 0; numberOfPoints < totalCount; numberOfPoints++)
    {
        CloudPoint point = *(pointBuffer + numberOfPoints);
        // Process each point
        System.Drawing.Color color = System.Drawing.ColorTranslator.FromWin32(point.Color);
        String pointDescription = String.Format("({0}, {1}, {2}, {3}", point.X, point.Y, point.Z, color.ToString());
    }
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The number of points read must range from 1 to 1000000.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PointCloudInstance Class

GetSelectionFilter Method

[image]