Revit 2013 API
ItemFactoryBase..::..NewFamilyInstances2 Method
ItemFactoryBase Class See Also Send Feedback
Creates Family instances within the document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ICollection<ElementId> NewFamilyInstances2(
    List<FamilyInstanceCreationData> dataList
)
Visual Basic
Public Function NewFamilyInstances2 ( _
    dataList As List(Of FamilyInstanceCreationData) _
) As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ NewFamilyInstances2(
    List<FamilyInstanceCreationData^>^ dataList
)

Parameters

dataList
Type: System.Collections.Generic..::..List<(Of <(<'FamilyInstanceCreationData>)>)>
A list of FamilyInstanceCreationData which wraps the creation arguments of the families to be created.

Return Value

If the creation is successful, a set of ElementIds which contains the Family instances should be returned, otherwise the exception will be thrown.

Remarks

This batch creation method is not supported in VSTA for Revit 2010.

Note: ForbiddenForDynamicUpdateException might be thrown during a dynamic update if the inserted instance establishes a mutual dependency with another structure.

Note: if the created family instance includes nested instances, the API framework will automatically regenerate the document during this method call. This happens regardless of the setting for RegenerationMode.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | If FamilyInstanceCreationData's 'curve' or 'symbol' member is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | If regeneration fails at the end of the batch creation.

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace

NewGroup Method

[image] [image]