Revit 2013 API
Rebar..::..SetHookTypeId Method
Rebar Class See Also Send Feedback
Set the id of the RebarHookType to be applied to the rebar.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2009

Syntax

C#
public void SetHookTypeId(
    int end,
    ElementId hookTypeId
)
Visual Basic
Public Sub SetHookTypeId ( _
    end As Integer, _
    hookTypeId As ElementId _
)
Visual C++
public:
void SetHookTypeId(
    int end,
    ElementId^ hookTypeId
)

Parameters

end
Type: System..::..Int32
0 for the start hook, 1 for the end hook.
hookTypeId
Type: Autodesk.Revit.DB..::..ElementId
The id of a RebarHookType element, or invalidElementId if the rebar should have no hook at the specified end.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | end must be 0 or 1.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace

SetHostId Method

[image]