Revit 2013 API
Document..::..Element Property (String)
Document Class See Also Send Feedback
Retrieves an element from the document given a unique id string.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This method has been obsoleted. Use GetElement() instead.")]
public Element this[
    string
] { get; }
Visual Basic
<ObsoleteAttribute("This method has been obsoleted. Use GetElement() instead.")> _
Public ReadOnly Property Element ( _
     As String _
) As Element
    Get
Visual C++
[ObsoleteAttribute(L"This method has been obsoleted. Use GetElement() instead.")]
public:
property Element^ Element[String^ ] {
    Element^ get (String^ );
}

Parameters

Type: System..::..String

Remarks

Returns the element corresponding to the unique id that was passed. The Element property is used to retrieve a known Element from the Revit database within the Document. If the Element specified by the uniqueId does not exist then an empty reference will be returned.

See Also

Document Class
Element Overload

Element Property (ElementId)

[image]