Revit 2013 API
View..::..ApplyTemplate Method
View Class See Also Send Feedback
Applies a view template to the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2013. Use property ViewTemplateId or call Revit.DB.View.ApplyViewTemplateParameters(Autodesk.Revit.DB.View viewTemplate) instead.")]
public void ApplyTemplate(
    View viewTemplate
)
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2013. Use property ViewTemplateId or call Revit.DB.View.ApplyViewTemplateParameters(Autodesk.Revit.DB.View viewTemplate) instead.")> _
Public Sub ApplyTemplate ( _
    viewTemplate As View _
)
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2013. Use property ViewTemplateId or call Revit.DB.View.ApplyViewTemplateParameters(Autodesk.Revit.DB.View viewTemplate) instead.")]
public:
void ApplyTemplate(
    View^ viewTemplate
)

Parameters

viewTemplate
Type: Autodesk.Revit.DB..::..View
View to be used as the template.

See Also

View Class

ApplyViewTemplateParameters Method

[image]