Revit 2013 API
ThermalAsset Constructor
ThermalAsset Class See Also Send Feedback
Constructs an instance of ThermalAsset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ThermalAsset(
    string name,
    ThermalMaterialType materialType
)
Visual Basic
Public Sub New ( _
    name As String, _
    materialType As ThermalMaterialType _
)
Visual C++
public:
ThermalAsset(
    String^ name,
    ThermalMaterialType materialType
)

Parameters

name
Type: System..::..String
The name of the asset.
materialType
Type: Autodesk.Revit.DB..::..ThermalMaterialType
The type of thermal material that this asset will describe.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | name is an empty string. -or- name cannot include prohibited characters.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ThermalAsset Class

ThermalAsset Methods

[image] [image]