Revit 2013 API
Application Events
Application Class See Also Send Feedback

The Application type exposes the following members.

Events

 | Name | Description
Public event | ApplicationInitialized | Subscribe to this event to get notified after the Revit application has been initialized
Public event | DocumentChanged | Subscribe to the DocumentChanged event to be notified when Revit document has changed.
Public event | DocumentClosed | Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.
Public event | DocumentClosing | Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.
Public event | DocumentCreated | Subscribe to the DocumentCreated event to be notified immediately after Revit has finished creating a new document.
Public event | DocumentCreating | Subscribe to the DocumentCreating event to be notified when Revit is just about to create a new document.
Public event | DocumentOpened | Subscribe to the DocumentOpened event to be notified immediately after Revit has finished opening a document.
Public event | DocumentOpening | Subscribe to the DocumentOpening event to be notified when Revit is just about to open a document.
Public event | DocumentPrinted | Subscribe to the DocumentPrinted event to be notified immediately after Revit has finished printing a view or ViewSet of the document.
Public event | DocumentPrinting | Subscribe to the DocumentPrinting event to be notified when Revit is just about to print a view or ViewSet of the document.
Public event | DocumentSaved | Subscribe to the DocumentSaved event to be notified immediately after Revit has finished saving a document.
Public event | DocumentSavedAs | Subscribe to the DocumentSavedAs event to be notified immediately after Revit has finished saving document with a new file name.
Public event | DocumentSaving | Subscribe to the DocumentSaving event to be notified when Revit is just about to save a document.
Public event | DocumentSavingAs | Subscribe to the DocumentSavingAs event to be notified when Revit is just about to save the document with a new file name.
Public event | DocumentSynchronizedWithCentral | Subscribe to the DocumentSynchronizedWithCentral event to be notified immediately after Revit has finished synchronizing a document with central model.
Public event | DocumentSynchronizingWithCentral | Subscribe to the DocumentSynchronizingWithCentral event to be notified when Revit is just about to synchronize a document with central model.
Public event | FailuresProcessing | Subscribe to the FailuresProcessing event to be notified when failures are being processed at the end of transaction.
Public event | FileExported | Subscribe to the FileExported event to be notified immediately after Revit has finished exporting files of formats supported by the API.
Public event | FileExporting | Subscribe to the FileExporting event to be notified when Revit is just about to export files of formats supported by the API.
Public event | FileImported | Subscribe to the FileImported event to be notified immediately after Revit has finished importing a file of format supported by the API.
Public event | FileImporting | Subscribe to the FileImporting event to be notified when Revit is just about to import a file of format supported by the API.
Public event | ProgressChanged | Subscribe to the ProgressChanged event to be notified when an operation in Revit has progress bar data available.
Public event | ViewPrinted | Subscribe to the ViewPrinted event to be notified immediately after Revit has finished printing a view of the document.
Public event | ViewPrinting | Subscribe to the ViewPrinting event to be notified when Revit is just about to print a view of the document.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace

ApplicationInitialized Event

[image]