Revit 2013 API
WorksetDefaultVisibilitySettings Class
Members See Also Send Feedback
An object that manages default visibility of worksets in a document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class WorksetDefaultVisibilitySettings : IDisposable
Visual Basic
Public Class WorksetDefaultVisibilitySettings _
    Implements IDisposable
Visual C++
public ref class WorksetDefaultVisibilitySettings : IDisposable

Remarks

WorksetDefaultVisibilitySettings does not exist for family documents. In case worksharing is disabled in a document, all elements are moved into a single workset; that workset, and any worksets (re)created if worksharing is re-enabled, is visible by default regardless of any current settings.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..WorksetDefaultVisibilitySettings

See Also

WorksetDefaultVisibilitySettings Members

WorksetDefaultVisibilitySettings Members

[image] [image]