Revit 2013 API
Application..::..NewProfiledWallCreationData Method (CurveArray, Boolean)
Application Class See Also Send Feedback
Creates an object which wraps the arguments of NewWall() for batch creation

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ProfiledWallCreationData NewProfiledWallCreationData(
    CurveArray profile,
    bool structural
)
Visual Basic
Public Function NewProfiledWallCreationData ( _
    profile As CurveArray, _
    structural As Boolean _
) As ProfiledWallCreationData
Visual C++
public:
ProfiledWallCreationData^ NewProfiledWallCreationData(
    CurveArray^ profile,
    bool structural
)

Parameters

profile
Type: Autodesk.Revit.DB..::..CurveArray
An array of planar lines and arcs that represent the vertical profile of the wall.
structural
Type: System..::..Boolean
If set, specifies that the wall is structural in nature.

See Also

Application Class
NewProfiledWallCreationData Overload
Autodesk.Revit.Creation Namespace

NewProfiledWallCreationData Method (CurveArray, WallType, Level, Boolean)

[image]