Revit 2013 API
UpdaterRegistry..::..SetIsUpdaterOptional Method
UpdaterRegistry Class See Also Send Feedback
Set kind of specified updater.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static void SetIsUpdaterOptional(
    UpdaterId id,
    bool isOptional
)
Visual Basic
Public Shared Sub SetIsUpdaterOptional ( _
    id As UpdaterId, _
    isOptional As Boolean _
)
Visual C++
public:
static void SetIsUpdaterOptional(
    UpdaterId^ id,
    bool isOptional
)

Parameters

id
Type: Autodesk.Revit.DB..::..UpdaterId
Id of the updater
isOptional
Type: System..::..Boolean

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | The updater has not been registered.

See Also

UpdaterRegistry Class

UnregisterUpdater Method

[image]