Revit 2013 API
IFCStairRampContainerInfo..::..Create Method (IFCAnyHandle, IList<(Of <(<'IFCAnyHandle>)>)>, IFCAnyHandle)
IFCStairRampContainerInfo Class See Also Send Feedback
Creates a new instance of an IFCStairRamp.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static IFCStairRampContainerInfo Create(
    IFCAnyHandle hnd,
    IList<IFCAnyHandle> comps,
    IFCAnyHandle pLocalPlacementHnd
)
Visual Basic
Public Shared Function Create ( _
    hnd As IFCAnyHandle, _
    comps As IList(Of IFCAnyHandle), _
    pLocalPlacementHnd As IFCAnyHandle _
) As IFCStairRampContainerInfo
Visual C++
public:
static IFCStairRampContainerInfo^ Create(
    IFCAnyHandle^ hnd,
    IList<IFCAnyHandle^>^ comps,
    IFCAnyHandle^ pLocalPlacementHnd
)

Parameters

hnd
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
Stairs IFC handle
comps
Type: System.Collections.Generic..::..IList<(Of <(<'IFCAnyHandle>)>)>
Handles of created sub-components
pLocalPlacementHnd
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
Local placement of the Stairs

Return Value

The new IFCStairRamp.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCStairRampContainerInfo Class
Create Overload
Autodesk.Revit.DB.IFC Namespace

Create Method (IList(IFCAnyHandle), IList(IList(IFCAnyHandle)), IList(IFCAnyHandle))

[image]