Revit 2013 API
ViewSheet Members
ViewSheet Class Methods Properties See Also Send Feedback

The ViewSheet type exposes the following members.

Methods

 | Name | Description
Public method | AddView | Obsolete. Places view on the sheet at the given location.
Public method | ConvertToRealSheet | Convert a placeholder sheet to a real one with an optional titleblock
 | Create | Creates a new ViewSheet.
 | CreatePlaceholder | Create a placeholder sheet in document.
Public method | DeleteViewport | Removes a viewport from the sheet by deleting it from the document.
Public method | GetAllViewports | Returns the ElementIds of Viewports on this sheet.

Properties

 | Name | Description
Public property | IsPlaceholder | Identifies whether or not the view sheet represents a placeholder sheet.
Public property | SheetNumber | Sheet number is unique in the document.
Public property | Views | Returns the set of all views on the sheet.

See Also

ViewSheet Class

ViewSheet Methods

[image] [image]