Revit 2013 API
StairsRun Methods
StairsRun Class See Also Send Feedback

The StairsRun type exposes the following members.

Methods

 | Name | Description
 | CreateSketchedRun | Creates a sketched run in the project document by providing a group of boundary curves and riser curves.
 | CreateSpiralRun | Creates a spiral run in the project document by providing the center, start angle and included angle.
 | CreateStraightRun | Creates a straight run in the project document.
Public method | GetAllSupports | Retrieves all supports hosted by the stair's run.
Public method | GetFootprintBoundary | Returns the run's boundary curves which are projected on the stairs base level.
Public method | GetLeftSupports | Retrieves all supports on the left side of run boundaries.
Public method | GetNumberSystemReference | Gets the number system reference corresponding to the given reference options.
Public method | GetRightSupports | Retrieves all supports on the right side of run boundaries.
Public method | GetStairs | Returns the stairs to which the stairs run belongs.
Public method | GetStairsPath | Returns the stairs path curves on the run. The curves are projected on base level of the stairs.

See Also

StairsRun Class
Autodesk.Revit.DB.Architecture Namespace

CreateSketchedRun Method

[image]