Revit 2013 API
PartUtils..::..PartMakerUsesReference Method
PartUtils Class See Also Send Feedback
Identifies if the PartMaker uses the intersecting reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2013; use PartMakerMethodToDivideVolumes.PartMakerUsesReference() instead.")]
public static bool PartMakerUsesReference(
    PartMaker partMaker,
    ElementId intersectingReference
)
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2013; use PartMakerMethodToDivideVolumes.PartMakerUsesReference() instead.")> _
Public Shared Function PartMakerUsesReference ( _
    partMaker As PartMaker, _
    intersectingReference As ElementId _
) As Boolean
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2013; use PartMakerMethodToDivideVolumes.PartMakerUsesReference() instead.")]
public:
static bool PartMakerUsesReference(
    PartMaker^ partMaker,
    ElementId^ intersectingReference
)

Parameters

partMaker
Type: Autodesk.Revit.DB..::..PartMaker
PartMaker to be tested.
intersectingReference
Type: Autodesk.Revit.DB..::..ElementId
Intersecting reference to be tested.

Return Value

True if the intersecting reference is used by the PartMaker.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PartUtils Class

SetOffsetForIntersectingReference Method

[image]