Revit 2013 API
Document..::..LightingDeviceTypes Property
Document Class See Also Send Feedback
Returns an object that contains all of the available lighting device types currently loaded to this project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilySymbolSet LightingDeviceTypes { get; }
Visual Basic
Public ReadOnly Property LightingDeviceTypes As FamilySymbolSet
    Get
Visual C++
public:
property FamilySymbolSet^ LightingDeviceTypes {
    FamilySymbolSet^ get ();
}

Remarks

The LightingDeviceTypes property returns an object that contains the lighting device types which can be used to change the type of a lighting device from one type to another.

See Also

Document Class

LightingFixtureTypes Property

[image]