Revit 2013 API
ScheduleDefinition..::..AddField Method (ScheduleFieldType)
ScheduleDefinition Class See Also Send Feedback
Adds a regular (non-calculated) field at the end of the list.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ScheduleField AddField(
    ScheduleFieldType fieldType
)
Visual Basic
Public Function AddField ( _
    fieldType As ScheduleFieldType _
) As ScheduleField
Visual C++
public:
ScheduleField^ AddField(
    ScheduleFieldType fieldType
)

Parameters

fieldType
Type: Autodesk.Revit.DB..::..ScheduleFieldType
The type of data displayed by the field.

Return Value

The new field.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The field specified by fieldType may not included in this ScheduleDefinition. -or- The field specified by fieldType is already included in this ScheduleDefinition.

See Also

ScheduleDefinition Class
AddField Overload

AddField Method (ScheduleFieldType, ElementId)

[image]