Revit 2013 API
ScheduleField Properties
ScheduleField Class See Also Send Feedback

The ScheduleField type exposes the following members.

Properties

 | Name | Description
Public property | ColumnHeading | The column heading text.
Public property | Definition | The ScheduleDefinition that this field belongs to.
Public property | FieldId | The ID of the field in the containing ScheduleDefinition.
Public property | FieldIndex | The index of the field in the containing ScheduleDefinition.
Public property | FieldType | The type of data displayed by the field.
Public property | GridColumnWidth | The width of the column in the editable grid view, measured in characters.
Public property | HasTotals | Indicates if the field displays totals.
Public property | HeadingOrientation | The orientation of the column heading text.
Public property | HorizontalAlignment | The horizontal alignment of text in the column.
Public property | IsHidden | Indicates if the field is hidden in the schedule.
Public property | ParameterId | The ID of the parameter displayed by the field.
Public property | PercentageBy | The ID of the grouped schedule field used to calculate percentage totals.
Public property | PercentageOf | The ID of the field to calculate percentages of.
Public property | Schedule | The schedule that this field belongs to.
Public property | SheetColumnWidth | The width of the column on a sheet.
Public property | TotalByAssemblyType | In an assembly schedule view, indicates if totals are calculated for all assembly instances of the same type or only for a single instance.

See Also

ScheduleField Class

ColumnHeading Property

[image]