Revit 2013 API
AnalyticalModel..::..GetAlignmentMethod Method
AnalyticalModel Class See Also Send Feedback
Gets the alignment method for a given selector and direction.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public AnalyticalAlignmentMethod GetAlignmentMethod(
    AnalyticalElementSelector selector,
    AnalyticalDirection direction
)
Visual Basic
Public Function GetAlignmentMethod ( _
    selector As AnalyticalElementSelector, _
    direction As AnalyticalDirection _
) As AnalyticalAlignmentMethod
Visual C++
public:
AnalyticalAlignmentMethod GetAlignmentMethod(
    AnalyticalElementSelector selector,
    AnalyticalDirection direction
)

Parameters

selector
Type: Autodesk.Revit.DB.Structure..::..AnalyticalElementSelector
End of the analytical model.
direction
Type: Autodesk.Revit.DB.Structure..::..AnalyticalDirection
Direction of the analytical model.

Return Value

The alignment method at a given end.

Remarks

Applicable for analytical models of linear elements (beams, braces, columns).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | direction is invalid for analytical model

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace

GetAnalyticalModelSketchComponents Method

[image]