Revit 2013 API
GeometryCreationUtilities..::..CreateSweptBlendGeometry Method
GeometryCreationUtilities Class See Also Send Feedback
Creates a solid by simultaneously sweeping and blending two or more closed planar curve loops along a single curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static Solid CreateSweptBlendGeometry(
    Curve pathCurve,
    IList<double> pathParams,
    IList<CurveLoop> profileLoops,
    IList<ICollection<VertexPair>> vertexPairs
)
Visual Basic
Public Shared Function CreateSweptBlendGeometry ( _
    pathCurve As Curve, _
    pathParams As IList(Of Double), _
    profileLoops As IList(Of CurveLoop), _
    vertexPairs As IList(Of ICollection(Of VertexPair)) _
) As Solid
Visual C++
public:
static Solid^ CreateSweptBlendGeometry(
    Curve^ pathCurve,
    IList<double>^ pathParams,
    IList<CurveLoop^>^ profileLoops,
    IList<ICollection<VertexPair^>^>^ vertexPairs
)

Parameters

pathCurve
Type: Autodesk.Revit.DB..::..Curve
The sweep path, consisting of a single bounded, open curve.
pathParams
Type: System.Collections.Generic..::..IList<(Of <(<'Double>)>)>
An increasing sequence of parameters along the path curve (lying within the curve’s bounds). These parameters specify the locations of the planes orthogonal to the path that contain the profile loops. This array must have the same size as the input array "profileLoops".
profileLoops
Type: System.Collections.Generic..::..IList<(Of <(<'CurveLoop>)>)>
Closed, planar curve loops arrayed along the path. The solid will have these profiles as cross-sections at the points specified by the input pathParams. The solid will blend smoothly between the profiles. This array must have the same size as the input array “pathParams”, and each profile loop must lie in the plane orthogonal to the path at the point specified by the corresponding entry in the input array “pathParams”. Each profile loop must define a single planar domain and must be free of intersections and degeneracies. No orientation conditions on the loops are imposed.
vertexPairs
Type: System.Collections.Generic..::..IList<(Of <(<'ICollection<(Of <(<'VertexPair>)>)>>)>)>
This input specifies how adjacent profile loops should be connected. It must contain one less element than the "profileLoops" input, and entry vertexPairs[idx] specifies how profileLoops[idx] and profileLoops[idx+1] should be connected (indexing starts at 0).

Return Value

The requested solid.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input pathCurve is a helical curve and is not supported for this operation. -or- The input argument pathCurve should be bounded. The input argument pathCurve should be non-degenerate. -or- The input argument pathParams should be an increasing array. -or- The profile CurveLoops do not satisfy the input requirements.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

GeometryCreationUtilities Class

CreateSweptGeometry Method

[image]