Revit 2013 API
ItemFactoryBase..::..NewSketchPlane Method (Reference)
ItemFactoryBase Class See Also Send Feedback
Creates a new sketch plane on a reference to existing planar geometry.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public SketchPlane NewSketchPlane(
    Reference planarFaceReference
)
Visual Basic
Public Function NewSketchPlane ( _
    planarFaceReference As Reference _
) As SketchPlane
Visual C++
public:
SketchPlane^ NewSketchPlane(
    Reference^ planarFaceReference
)

Parameters

planarFaceReference
Type: Autodesk.Revit.DB..::..Reference
The planar face reference to locate sketch plane.

Return Value

If successful a new sketch plane will be returned. Otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the argument is an invalid object, or reference of the argument is nullNothingnullptra null reference (Nothing in Visual Basic), or the host of this face is invalid.

See Also

ItemFactoryBase Class
NewSketchPlane Overload
Autodesk.Revit.Creation Namespace

NewTextNote Method

[image] [image]