Revit 2013 API
RebarShapeDefinitionByArc Members
RebarShapeDefinitionByArc Class Constructors Methods Properties See Also Send Feedback

The RebarShapeDefinitionByArc type exposes the following members.

Constructors

 | Name | Description
Public method | RebarShapeDefinitionByArc(Document, RebarShapeDefinitionByArcType) | Create a non-spiral shape definition.
Public method | RebarShapeDefinitionByArc(Document, Double, Double, Int32, Int32) | Create a spiral shape definition.

Methods

 | Name | Description
Public method | AddConstraintArcLength | Specify a parameter to drive the arc length of the shape.
Public method | AddConstraintChordLength | Specify a parameter to drive the chord length (the straight-line distance between the endpoints of the arc).
Public method | AddConstraintCircumference | Specify a parameter to drive the circumference of the shape.
Public method | AddConstraintDiameter | Specify a parameter to drive the diameter of the shape.
Public method | AddConstraintRadius | Specify a parameter to drive the radius of the shape.
Public method | AddConstraintSagittaLength | Specify a parameter to drive the sagittal length (the height of the circular segment, measured perpendicular to the chord).
Public method | GetConstraints | Retrieve the list of constraints associated with this definition.
Public method | SetArcTypeSpiral | Set the RebarShapeDefinitionByArc.Type property to Spiral.
Public method | SetConstraints | Assign a new list of constraints to this definition.

Properties

 | Name | Description
Public property | Type | Among those rebar shapes defined by an arc, specify which kind.

See Also

RebarShapeDefinitionByArc Class
Autodesk.Revit.DB.Structure Namespace

RebarShapeDefinitionByArc Constructor

[image] [image]