Revit 2013 API
WorksharingDisplayGraphicSettings Class
Members Example See Also Send Feedback
Represents the graphical settings that can be assigned to elements in the worksharing display modes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class WorksharingDisplayGraphicSettings : IDisposable
Visual Basic
Public Class WorksharingDisplayGraphicSettings _
    Implements IDisposable
Visual C++
public ref class WorksharingDisplayGraphicSettings : IDisposable

Examples

CopyC#
public WorksharingDisplayGraphicSettings GetWorksharingDisplaySettings(Document doc, String userName, WorksetId worksetId, bool ownedbyCurrentUser)
{
    WorksharingDisplayGraphicSettings graphicSettings;

    // get or create a WorksharingDisplaySettings current active document
    WorksharingDisplaySettings displaySettings = WorksharingDisplaySettings.GetOrCreateWorksharingDisplaySettings(doc);

    // get graphic settings for a user, if specified
    if (!String.IsNullOrEmpty(userName))
        graphicSettings = displaySettings.GetGraphicOverrides(userName);

    // get graphicSettings for a workset, if specified
    else if (worksetId != WorksetId.InvalidWorksetId)
        graphicSettings = displaySettings.GetGraphicOverrides(worksetId);

    // get graphic settings for the OwnedByCurrentUser status
    else if (ownedbyCurrentUser)
        graphicSettings = displaySettings.GetGraphicOverrides(CheckoutStatus.OwnedByCurrentUser);

    // otherwise get graphic settings for the CurrentWithCentral status
    else
        graphicSettings = displaySettings.GetGraphicOverrides(ModelUpdatesStatus.CurrentWithCentral);

    return graphicSettings;
}

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..WorksharingDisplayGraphicSettings

See Also

WorksharingDisplayGraphicSettings Members

WorksharingDisplayGraphicSettings Members

[image] [image]