Revit 2013 API
RebarShapeMultiplanarDefinition Properties
RebarShapeMultiplanarDefinition Class See Also Send Feedback

The RebarShapeMultiplanarDefinition type exposes the following members.

Properties

 | Name | Description
Public property | DepthParamId | Id of the parameter driving the multiplanar depth. The depth is measured center-to-center of the bar. A valid shape parameter must be assigned to DepthParamId before the MultiplanarDefinition can be used in RebarShape creation.
Public property | IsDuplicateShapePresent | Whether the shape definition includes an offset copy of the 2D shape.
Public property | IsEndConnectorPresent | Whether a perpendicular segment is constructed from the end of the 2D shape.
Public property | IsStartConnectorPresent | Whether a perpendicular segment is constructed from the start of the 2D shape.
Public property | OutOfPlaneBendDiameter | Bend diameter to be applied to the connector segments.

See Also

RebarShapeMultiplanarDefinition Class
Autodesk.Revit.DB.Structure Namespace

DepthParamId Property

[image]