Revit 2013 API
AreaReinforcement..::..Curves Property
AreaReinforcement Class See Also Send Feedback
Retrieves the array of curves forming the boundary of the Area Reinforcement.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This property is obsolete in Revit 2013. Call GetCurveElementIds() instead.")]
public ElementArray Curves { get; }
Visual Basic
<ObsoleteAttribute("This property is obsolete in Revit 2013. Call GetCurveElementIds() instead.")> _
Public ReadOnly Property Curves As ElementArray
    Get
Visual C++
[ObsoleteAttribute(L"This property is obsolete in Revit 2013. Call GetCurveElementIds() instead.")]
public:
property ElementArray^ Curves {
    ElementArray^ get ();
}

Remarks

Each element in the array is of type AreaReinforcementCurve. Each element has a Curve property to retrieve the geometric curve, together with some Parameters allowing the developer to override the clear cover side, hook type, and hook direction of each layer of bars terminating at the curve.

See Also

AreaReinforcement Class
Autodesk.Revit.DB.Structure Namespace

Direction Property

[image]