Revit 2013 API
Document..::..NewWall Method
Document Class See Also Send Feedback
Creates a new wall within the project.

Overload List

 | Name | Description
Public method | NewWall(CurveArray, Boolean) | Obsolete. Creates a non rectangular profile wall within the project using the default wall type.
Public method | NewWall(Curve, Level, Boolean) | Obsolete. Creates a new rectangular profile wall within the project using the default wall style.
Public method | NewWall(CurveArray, WallType, Level, Boolean) | Obsolete. Creates a non rectangular profile wall within the project using the specified wall type.
Public method | NewWall(CurveArray, WallType, Level, Boolean, XYZ) | Obsolete. Creates a non rectangular profile wall within the project using the specified wall type and normal vector.
Public method | NewWall(Curve, WallType, Level, Double, Double, Boolean, Boolean) | Obsolete. Creates a new rectangular profile wall within the project using the specified wall type, height, and offset.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace

NewWall Method (CurveArray, Boolean)

[image]