Revit 2013 API
ExporterIFCUtils..::..GetTransformForDoorOrWindow Method
ExporterIFCUtils Class See Also Send Feedback
Obtains the transform for the door or window instance.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static Transform GetTransformForDoorOrWindow(
    FamilyInstance familyInstance,
    FamilySymbol familySymbol,
    IFCDoorWindowInfo info
)
Visual Basic
Public Shared Function GetTransformForDoorOrWindow ( _
    familyInstance As FamilyInstance, _
    familySymbol As FamilySymbol, _
    info As IFCDoorWindowInfo _
) As Transform
Visual C++
public:
static Transform^ GetTransformForDoorOrWindow(
    FamilyInstance^ familyInstance,
    FamilySymbol^ familySymbol,
    IFCDoorWindowInfo^ info
)

Parameters

familyInstance
Type: Autodesk.Revit.DB..::..FamilyInstance
The family instance.
familySymbol
Type: Autodesk.Revit.DB..::..FamilySymbol
The family symbol.
info
Type: Autodesk.Revit.DB.IFC..::..IFCDoorWindowInfo
The door or window info.

Return Value

The transform.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace

GetUnscaledTransform Method

[image]