Revit 2013 API
IFCPlacementSetter Class
Members See Also Send Feedback
A state-based class that establishes the current IfcLocalPlacement applied to an element being exported.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class IFCPlacementSetter : IDisposable
Visual Basic
Public Class IFCPlacementSetter _
    Implements IDisposable
Visual C++
public ref class IFCPlacementSetter : IDisposable

Remarks

This class is intended to maintain the placement for the duration that it is needed. To ensure that the lifetime of the object is correctly managed, you should declare an instance of this class as a part of a 'using' statement in C# or similar construct in other lanuguages.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.IFC..::..IFCPlacementSetter

See Also

IFCPlacementSetter Members
Autodesk.Revit.DB.IFC Namespace

IFCPlacementSetter Members

[image] [image]