Revit 2013 API
XYZ..::..IsAlmostEqualTo Method (XYZ, Double)
XYZ Class See Also Send Feedback
Determines whether 2 vectors are the same within the given tolerance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsAlmostEqualTo(
    XYZ source,
    double tolerance
)
Visual Basic
Public Function IsAlmostEqualTo ( _
    source As XYZ, _
    tolerance As Double _
) As Boolean
Visual C++
public:
bool IsAlmostEqualTo(
    XYZ^ source,
    double tolerance
)

Parameters

source
Type: Autodesk.Revit.DB..::..XYZ
The vector to compare with this vector.
tolerance
Type: System..::..Double
The tolerance for equality check.

Return Value

True if the vectors are the same; otherwise, false.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when source is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when tolerance is less than 0.

See Also

XYZ Class
IsAlmostEqualTo Overload

IsUnitLength Method

[image]