Revit 2013 API
AreaLoad Class
Members Example See Also Send Feedback
An object that represents a force applied across an area.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class AreaLoad : LoadBase
Visual Basic
Public Class AreaLoad _
    Inherits LoadBase
Visual C++
public ref class AreaLoad : public LoadBase

Examples

CopyC#
public void GetInfo_AreaLoad(AreaLoad areaLoad)
{
    string message = "AreaLoad Force : ";
    // Get areaload force1 position
    message += "\nAreaLoad Force1 position :(" + areaLoad.Force1.X + ", "
        + areaLoad.Force1.Y + ", " + areaLoad.Force1.Z + ")";
    // Get areaload force2 position
    message += "\nAreaLoad Force2 position :(" + areaLoad.Force2.X + ", "
        + areaLoad.Force2.Y + ", " + areaLoad.Force2.Z + ")";
    // Get areaload force3 position
    message += "\nAreaLoad Force3 position :(" + areaLoad.Force3.X + ", "
        + areaLoad.Force3.Y + ", " + areaLoad.Force3.Z + ")";

    // Get loop number
    message += "\nLoop number is :" + areaLoad.NumLoops;
    for (int i = 0; i < areaLoad.NumLoops; i++)
    {
        // Get curve number
        message += "\nCurve number is : " + areaLoad.get_NumCurves(i);
        for (int j = 0; j < areaLoad.get_NumCurves(i); j++)
        {
            Autodesk.Revit.DB.Curve curve = areaLoad.get_Curve(i, j);
            // Get curve start point
            message += "\nCurve start point:(" + curve.get_EndPoint(0).X + ", "
                + curve.get_EndPoint(0).Y + ", " + curve.get_EndPoint(0).Z + ")";
            // Get curve end point
            message += "; Curve end point:(" + curve.get_EndPoint(1).X + ", "
                + curve.get_EndPoint(1).Y + ", " + curve.get_EndPoint(1).Z + ")";
        }
    }

    // Get ref points information
    for (int k = 0; k < areaLoad.NumRefPoints; k++)
    {
        // Get areaload Ref point
        message += "\nAreaLoad Ref point :(" + areaLoad.get_RefPoint(k).X + ", "
            + areaLoad.get_RefPoint(k).Y + ", " + areaLoad.get_RefPoint(k).Z + ")";
    }
    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Public Sub GetInfo_AreaLoad(ByVal areaLoad As Autodesk.Revit.DB.Structure.AreaLoad)
    Dim message As String = "AreaLoad Force : "
    ' Get areaload force1 position
    message += vbLf & "AreaLoad Force1 position :(" + areaLoad.Force1.X + ", " + areaLoad.Force1.Y + ", " + areaLoad.Force1.Z + ")"
    ' Get areaload force2 position
    message += vbLf & "AreaLoad Force2 position :(" + areaLoad.Force2.X + ", " + areaLoad.Force2.Y + ", " + areaLoad.Force2.Z + ")"
    ' Get areaload force3 position
    message += vbLf & "AreaLoad Force3 position :(" + areaLoad.Force3.X + ", " + areaLoad.Force3.Y + ", " + areaLoad.Force3.Z + ")"

    ' Get loop number
    message += vbLf & "Loop number is :" + areaLoad.NumLoops
    Dim i As Integer = 0
    While i < areaLoad.NumLoops
        ' Get curve number
        message += vbLf & "Curve number is : " + areaLoad.NumCurves(i)
        Dim j As Integer = 0
        While j < areaLoad.NumCurves(i)
            Dim curve As Autodesk.Revit.DB.Curve = areaLoad.Curve(i, j)
            ' Get curve start point
            message += vbLf & "Curve start point:(" + curve.EndPoint(0).X + ", " + curve.EndPoint(0).Y + ", " + curve.EndPoint(0).Z + ")"
            ' Get curve end point
            message += "; Curve end point:(" + curve.EndPoint(1).X + ", " + curve.EndPoint(1).Y + ", " + curve.EndPoint(1).Z + ")"
            System.Math.Max(System.Threading.Interlocked.Increment(j), j - 1)
        End While
        System.Math.Max(System.Threading.Interlocked.Increment(i), i - 1)
    End While

    ' Get ref points information
    Dim k As Integer = 0
    While k < areaLoad.NumRefPoints
        ' Get areaload Ref point
        message += vbLf & "AreaLoad Ref point :(" + areaLoad.RefPoint(k).X + ", " + areaLoad.RefPoint(k).Y + ", " + areaLoad.RefPoint(k).Z + ")"
        System.Math.Max(System.Threading.Interlocked.Increment(k), k - 1)
    End While
    TaskDialog.Show("Revit", message)
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB.Structure..::..LoadBase
Autodesk.Revit.DB.Structure..::..AreaLoad

See Also

AreaLoad Members
Autodesk.Revit.DB.Structure Namespace

AreaLoad Members

[image] [image]