Revit 2013 API
Application..::..OpenDocumentFile Method (String)
Application Class See Also Send Feedback
Opens a document from disk.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Document OpenDocumentFile(
    string fileName
)
Visual Basic
Public Overridable Function OpenDocumentFile ( _
    fileName As String _
) As Document
Visual C++
public:
virtual Document^ OpenDocumentFile(
    String^ fileName
)

Parameters

fileName
Type: System..::..String
The file to be opened.

Remarks

This method opens the document into memory but does not make it visible to the user in any way.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | If 'fileName' is nullNothingnullptra null reference (Nothing in Visual Basic) or an empty string.
Autodesk.Revit.Exceptions..::..ApplicationException | If the file cannot be opened.

See Also

Application Class
OpenDocumentFile Overload
Autodesk.Revit.ApplicationServices Namespace

OpenDocumentFile Method (ModelPath, OpenOptions)

[image]