Revit 2013 API
PushButton..::..AvailabilityClassName Property
PushButton Class See Also Send Feedback
The full class name for the class providing the entry point to decide availability of this push button.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public string AvailabilityClassName { get; set; }
Visual Basic
Public Property AvailabilityClassName As String
    Get
    Set
Visual C++
public:
property String^ AvailabilityClassName {
    String^ get ();
    void set (String^ value);
}

Remarks

This is the class implementing IExternalCommandAvailability interface.

See Also

PushButton Class
Autodesk.Revit.UI Namespace

ClassName Property

[image]