Revit 2013 API
LinearArray Members
LinearArray Class Methods Properties See Also Send Feedback

The LinearArray type exposes the following members.

Methods

 | Name | Description
 | ArrayElementsWithoutAssociation | Creates a new linear array from a set of elements.
 | ArrayElementWithoutAssociation | Creates a new linear array from a single element.
 | Create(Document, View, ElementId, Int32, XYZ, ArrayAnchorMember) | Creates a new linear array element from a single element.
 | Create(Document, View, ICollection<(Of <<'(ElementId>)>>), Int32, XYZ, ArrayAnchorMember) | Creates a new linear array element from a set of elements.
Public method | GetCopiedMemberIds | Retrieves the copied member Ids of the Array. (Overrides BaseArray..::..GetCopiedMemberIds()()()().)
Public method | GetOriginalMemberIds | Retrieves the original member Ids of the Array. (Overrides BaseArray..::..GetOriginalMemberIds()()()().)
 | IsElementArrayable | Indicates whether the input element is arrayable.
 | IsValidArraySize | This indicates whether the input count is valid.

Properties

 | Name | Description
Public property | CopyMembers | Obsolete. Retrieve the copied members of the Array. (Overrides BaseArray..::..CopyMembers.)
Public property | NumMembers | Retrieves or changes the number of the arrayed members. (Overrides BaseArray..::..NumMembers.)
Public property | OrigMembers | Obsolete. Retrieve the original members of the Array. (Overrides BaseArray..::..OrigMembers.)

See Also

LinearArray Class

LinearArray Methods

[image] [image]