Revit 2013 API
FamilyBase..::..FamilyCategory Property
FamilyBase Class Example See Also Send Feedback
Retrieves a Category object that represents the category or sub category in which the elements ( this family could generate ) reside.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Category FamilyCategory { get; }
Visual Basic
Public ReadOnly Property FamilyCategory As Category
    Get
Visual C++
public:
property Category^ FamilyCategory {
    Category^ get ();
}

Remarks

All category objects can be retrieved from the application by using the Categories property of the Application.Settings object.

Examples

CopyC#
public void GetBeamAndColumnSymbols(Document document)
{
    FamilySymbolSet columnTypes = new FamilySymbolSet();
    FamilySymbolSet framingTypes = new FamilySymbolSet();
    FilteredElementCollector collector = new FilteredElementCollector(document);
    ICollection<Element> elements = collector.OfClass(typeof(Family)).ToElements();

    foreach(Element element in elements)
    {
        Family tmpFamily = element as Family;
        Category category = tmpFamily.FamilyCategory;
        if (null != category)
        {
            if ((int)BuiltInCategory.OST_StructuralColumns == category.Id.IntegerValue)
            {
                foreach (FamilySymbol tmpSymbol in tmpFamily.Symbols)
                {
                    columnTypes.Insert(tmpSymbol);
                }
            }
            else if ((int)BuiltInCategory.OST_StructuralFraming == category.Id.IntegerValue)
            {
                foreach (FamilySymbol tmpSymbol in tmpFamily.Symbols)
                {
                    framingTypes.Insert(tmpSymbol);
                }
            }
        }
    }

    string message = "Column Types: ";
    FamilySymbolSetIterator fsItor = columnTypes.ForwardIterator();
    fsItor.Reset();
    while (fsItor.MoveNext())
    {
        FamilySymbol familySybmol = fsItor.Current as FamilySymbol;
        message += "\n" + familySybmol.Name;
    }

    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Public Sub GetBeamAndColumnSymbols(ByVal document As Document)
    Dim columnTypes As New FamilySymbolSet()
    Dim framingTypes As New FamilySymbolSet()
    Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(document)
    Dim elements As ICollection(Of Autodesk.Revit.DB.Element) = collector.OfClass(GetType(Family)).ToElements()

    For Each element As Autodesk.Revit.DB.Element In elements
        Dim tmpFamily As Family = TryCast(element, Family)
        Dim category As Category = tmpFamily.FamilyCategory
        If category IsNot Nothing Then
            If DirectCast(BuiltInCategory.OST_StructuralColumns, Integer) = category.Id.IntegerValue Then
                For Each tmpSymbol As FamilySymbol In tmpFamily.Symbols
                    columnTypes.Insert(tmpSymbol)
                Next
            ElseIf DirectCast(BuiltInCategory.OST_StructuralFraming, Integer) = category.Id.IntegerValue Then
                For Each tmpSymbol As FamilySymbol In tmpFamily.Symbols
                    framingTypes.Insert(tmpSymbol)
                Next
            End If
        End If
    Next

    Dim message As String = "Column Types: "
    Dim fsItor As FamilySymbolSetIterator = columnTypes.ForwardIterator()
    fsItor.Reset()
    While fsItor.MoveNext()
        Dim familySybmol As FamilySymbol = TryCast(fsItor.Current, FamilySymbol)
        message += vbLf + familySybmol.Name
    End While

    TaskDialog.Show("Revit", message)
End Sub

See Also

FamilyBase Class

Parameter Property

[image] [image]