Revit 2013 API
FamilySymbol Members
FamilySymbol Class Methods Properties See Also Send Feedback

The FamilySymbol type exposes the following members.

Methods

 | Name | Description
Public method | GetFamilyPointLocations | Returns the Point Locations for the Family Symbol.
Public method | GetThermalProperties | Returns the thermal properties.
Public method | SetThermalProperties | Set the thermal properties.

Properties

 | Name | Description
Public property | Family | Returns the Family object to which the symbol belongs.
Public property | StructuralMaterialType | This property returns the physical material from which the type is made.

See Also

FamilySymbol Class

FamilySymbol Methods

[image] [image]