Revit 2013 API
Application..::..NewArc Method (XYZ, XYZ, XYZ)
Application Class Example See Also Send Feedback
Creates a new geometric arc object based on three points.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Arc NewArc(
    XYZ end0,
    XYZ end1,
    XYZ pointOnCurve
)
Visual Basic
Public Function NewArc ( _
    end0 As XYZ, _
    end1 As XYZ, _
    pointOnCurve As XYZ _
) As Arc
Visual C++
public:
Arc^ NewArc(
    XYZ^ end0,
    XYZ^ end1,
    XYZ^ pointOnCurve
)

Parameters

end0
Type: Autodesk.Revit.DB..::..XYZ
The start point of the arc.
end1
Type: Autodesk.Revit.DB..::..XYZ
The end point of the arc.
pointOnCurve
Type: Autodesk.Revit.DB..::..XYZ
A point on the arc.

Remarks

Examples

CopyC#
// Create a new arc using two ends and a point on the curve
XYZ end0 = new XYZ(1, 0, 0);    // start point of the arc
XYZ end1 = new XYZ(10, 10, 10); // end point of the arc
XYZ pointOnCurve = new XYZ(10, 0, 0);   // point along arc

Arc arc = application.Create.NewArc(end0, end1, pointOnCurve);
CopyVB.NET
' Create a new arc using two ends and a point on the curve
Dim end0 As New Autodesk.Revit.DB.XYZ(1, 0, 0)
' start point of the arc
Dim end1 As New Autodesk.Revit.DB.XYZ(10, 10, 10)
' end point of the arc
Dim pointOnCurve As New Autodesk.Revit.DB.XYZ(10, 0, 0)
' point along arc
Dim arc As Arc = application.Create.NewArc(end0, end1, pointOnCurve)

See Also

Application Class
NewArc Overload
Autodesk.Revit.Creation Namespace

NewArc Method (Plane, Double, Double, Double)

[image]