Revit 2013 API
SchedulableField Constructor (ScheduleFieldType, ElementId)
SchedulableField Class See Also Send Feedback
Creates a new SchedulableField.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public SchedulableField(
    ScheduleFieldType fieldType,
    ElementId parameterId
)
Visual Basic
Public Sub New ( _
    fieldType As ScheduleFieldType, _
    parameterId As ElementId _
)
Visual C++
public:
SchedulableField(
    ScheduleFieldType fieldType,
    ElementId^ parameterId
)

Parameters

fieldType
Type: Autodesk.Revit.DB..::..ScheduleFieldType
The type of data displayed by the field.
parameterId
Type: Autodesk.Revit.DB..::..ElementId
The ID of the parameter displayed by the field.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | fieldType is a calculated field type (Formula or Percentage).
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

SchedulableField Class
SchedulableField Overload

SchedulableField Methods

[image] [image]