Revit 2013 API
View..::..IsolateCategoriesTemporary Method
View Class See Also Send Feedback
Set categories to be temporarily isolated in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void IsolateCategoriesTemporary(
    IList<ElementId> elementIds
)
Visual Basic
Public Sub IsolateCategoriesTemporary ( _
    elementIds As IList(Of ElementId) _
)
Visual C++
public:
void IsolateCategoriesTemporary(
    IList<ElementId^>^ elementIds
)

Parameters

elementIds
Type: System.Collections.Generic..::..IList<(Of <(<'ElementId>)>)>
Ids of categories to be isolated.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Some elements in elementIds do not correspond to a Category.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

View Class

IsolateCategoryTemporary Method

[image]