Revit 2013 API
ReferenceIntersector..::..FindNearest Method
ReferenceIntersector Class See Also Send Feedback
Projects a ray from the origin along the given direction, and returns all references from intersected elements which match the ReferenceIntersector’s criteria.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ReferenceWithContext FindNearest(
    XYZ origin,
    XYZ direction
)
Visual Basic
Public Function FindNearest ( _
    origin As XYZ, _
    direction As XYZ _
) As ReferenceWithContext
Visual C++
public:
ReferenceWithContext^ FindNearest(
    XYZ^ origin,
    XYZ^ direction
)

Parameters

origin
Type: Autodesk.Revit.DB..::..XYZ
The origin of the ray.
direction
Type: Autodesk.Revit.DB..::..XYZ
The direction of the ray.

Return Value

The intersected reference nearest to the ray origin, nullNothingnullptra null reference (Nothing in Visual Basic) if none is found

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ReferenceIntersector Class

GetFilter Method

[image]