Revit 2013 API
Document..::..NewSpace Method (Level, UV)
Document Class See Also Send Feedback
Creates a new space element on the given level at the given location.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Space NewSpace(
    Level level,
    UV point
)
Visual Basic
Public Function NewSpace ( _
    level As Level, _
    point As UV _
) As Space
Visual C++
public:
Space^ NewSpace(
    Level^ level,
    UV^ point
)

Parameters

level
Type: Autodesk.Revit.DB..::..Level
The level on which the space is to exist.
point
Type: Autodesk.Revit.DB..::..UV
A 2D point that dictates the location on that specified level.

Return Value

If successful the new space element is returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when level or point is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the space cannot be created.

See Also

Document Class
NewSpace Overload
Autodesk.Revit.Creation Namespace

NewSpace Method (Level, Phase, UV)

[image]