Revit 2013 API
PipingSystem Members
PipingSystem Class Methods Properties See Also Send Feedback

The PipingSystem type exposes the following members.

Methods

 | Name | Description
 | Create(Document, ElementId) | Creates a new instance of a piping system and adds it to the document.
 | Create(Document, ElementId, String) | Creates a new instance of a piping system and adds it to the document.

Properties

 | Name | Description
Public property | BaseEquipmentConnector | The connector within base equipment which is used to connect with system.
Public property | FixtureUnits | Indicates the computed total fixture units for the piping system.
Public property | Flow | Indicates the computed total flow for the piping system.
Public property | IsWellConnected | Indicates if the system is well connected or not.
Public property | PipingNetwork | Pipes and fittings which are contained in this system.
Public property | StaticPressure | Indicates the computed static pressure for the piping system.
Public property | SystemType | The type of this piping system.

See Also

PipingSystem Class
Autodesk.Revit.DB.Plumbing Namespace

PipingSystem Methods

[image] [image]