Revit 2013 API
TextBox Members
TextBox Class Methods Properties Events See Also Send Feedback

The TextBox type exposes the following members.

Methods

 | Name | Description

Properties

 | Name | Description
Public property | Image | The image of the TextBox.
Public property | PromptText | The prompt text for the text box.
Public property | SelectTextOnFocus | A value that indicates if the text is selected when the text box gains focus.
Public property | ShowImageAsButton | Gets or sets a value that indicates if the Image set in the text box should be displayed as a clickable button.
Public property | Value | The object that supplies the text value.
Public property | Width | Gets or sets the width of the TextBox.

Events

 | Name | Description
Public event | EnterPressed | Subscribe to this event to be notified when the Enter button is pressed in the text box.

See Also

TextBox Class
Autodesk.Revit.UI Namespace

TextBox Methods

[image] [image]