Revit 2013 API
BuiltInFailures..::..FabricFailures Properties
BuiltInFailures..::..FabricFailures Class See Also Send Feedback

The BuiltInFailures..::..FabricFailures type exposes the following members.

Properties

Name | Description
CannotPlaceFabricArea | Can't find a host for Fabric Area.
CannotPlaceFabricAreaWarn | Can't find a host for Fabric Area.
CoverOffsetTooLong | Cover offset is greater than host thickness.
FabricAreaWrongHost | Fabric Area can be placed only in Structural Floors and straight Structural Walls.
FabricAreaWrongLapSplice | Fabric Area Sheet lap splice is incorrect. Can't create Fabric Area.
FabricAreaWrongSheetAlignment | Fabric Area Sheet Alignment is incorrect. Can't create Fabric Area.
MajorLapSpliceFailure | The lap splice in the major direction is greater than the half of the overall length.
MajorOverhangFailure | At least one of the overhangs in the major direction is lower than radius of the wire in the minor direction.
MajorSpacingFailure | The spacing in the major direction is lower than diameter of the wire in the minor direction.
MinorLapSpliceFailure | The lap splice in the minor direction is greater than the half of the overall width.
MinorOverhangFailure | At least one of the overhangs in the minor direction is lower than radius of the wire in the major direction.
MinorSpacingFailure | The spacing in the minor direction is lower than diameter of the wire in the major direction.
NoSurfPatternOnWire | Wire elements do not support surface patterns. The surface pattern associated with this material will not be displayed on the indicated Fabric Sheet Type.
NoWireMaterialDensity | Material does not have a density defined. The weight of the Fabric Sheet cannot be computed.
WireDiameterTooLarge | Fabric Wire Diameter is too large.
WrongFabricSheetEndOverhang | Wrong Start Overhang of the Fabric Sheet Type.
WrongFabricSheetLayoutPattern | The Layout Pattern cannot accommodate the current data. Try decreasing the Number of Wires/Spacing.
WrongFabricSheetNumberOfWires | Wrong Number of Wires of the Fabric Sheet Type.
WrongFabricSheetOverallLength | Wrong Overall Length/Width of the Fabric Sheet Type.
WrongFabricSheetSpacing | Wrong Spacing of the Fabric Sheet Type.
WrongFabricSheetStartOverhang | Wrong Start Overhang of the Fabric Sheet Type.

See Also

BuiltInFailures..::..FabricFailures Class

CannotPlaceFabricArea Property

[image]