Revit 2013 API
AnalyticalModel..::..IsValidProjectionType Method
AnalyticalModel Class See Also Send Feedback
Indicates if a given Analytical Projection Type is valid for the given Analytical Element Selector and Analytical Direction.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsValidProjectionType(
    AnalyticalElementSelector selector,
    AnalyticalDirection direction,
    AnalyticalProjectionType projectionType
)
Visual Basic
Public Function IsValidProjectionType ( _
    selector As AnalyticalElementSelector, _
    direction As AnalyticalDirection, _
    projectionType As AnalyticalProjectionType _
) As Boolean
Visual C++
public:
bool IsValidProjectionType(
    AnalyticalElementSelector selector,
    AnalyticalDirection direction,
    AnalyticalProjectionType projectionType
)

Parameters

selector
Type: Autodesk.Revit.DB.Structure..::..AnalyticalElementSelector
Selector of element part.
direction
Type: Autodesk.Revit.DB.Structure..::..AnalyticalDirection
Direction in which Analytical Model may be projected.
projectionType
Type: Autodesk.Revit.DB.Structure..::..AnalyticalProjectionType
Analytical Projection Type for Analytical Model Projection.

Return Value

True if Projection Type is valid; false otherwise.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace

IsValidRigidLinksOption Method

[image]