Revit 2013 API
LightFamily..::..SetLightShapeStyle Method
LightFamily Class See Also Send Feedback
Set the light shape style to the given shape style

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetLightShapeStyle(
    LightShapeStyle lightShapeStyle
)
Visual Basic
Public Sub SetLightShapeStyle ( _
    lightShapeStyle As LightShapeStyle _
)
Visual C++
public:
void SetLightShapeStyle(
    LightShapeStyle lightShapeStyle
)

Parameters

lightShapeStyle
Type: Autodesk.Revit.DB.Lighting..::..LightShapeStyle
The light shape style value to set the light shape style to

See Also

LightFamily Class
Autodesk.Revit.DB.Lighting Namespace

LightGroup Class

[image]