Revit 2013 API
CurveElement..::..LineStyle Property
CurveElement Class See Also Send Feedback
The line style of this curve element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Element LineStyle { get; set; }
Visual Basic
Public Property LineStyle As Element
    Get
    Set
Visual C++
public:
property Element^ LineStyle {
    Element^ get ();
    void set (Element^ value);
}

Remarks

The return of this property will be a GraphicsStyle element. These graphics styles should be associated to subcategories of the BuiltInCategory OST_Lines.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when regeneration failed. Thrown when fail to get line style.

See Also

CurveElement Class

LineStyles Property

[image]