Revit 2013 API
ExporterIFCUtils..::..CreateGUID Method (Element)
ExporterIFCUtils Class See Also Send Feedback
Creates a GUID for the given element.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static string CreateGUID(
    Element element
)
Visual Basic
Public Shared Function CreateGUID ( _
    element As Element _
) As String
Visual C++
public:
static String^ CreateGUID(
    Element^ element
)

Parameters

element
Type: Autodesk.Revit.DB..::..Element
The element.

Return Value

The guid string.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
CreateGUID Overload
Autodesk.Revit.DB.IFC Namespace

CreateNonCOBIERoomQuantities Method

[image]