Revit 2013 API
ExternalService..::..RemoveServer Method
ExternalService Class See Also Send Feedback
Removes/unregisters a server from the service.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void RemoveServer(
    Guid serverId
)
Visual Basic
Public Sub RemoveServer ( _
    serverId As Guid _
)
Visual C++
public:
void RemoveServer(
    Guid serverId
)

Parameters

serverId
Type: System..::..Guid
Id of the server to be unregistered.

Remarks

It is possible to remove servers that are currently set as active, because it is possible for a service having assigned no active server. This does not apply to mandatory services, which will always have at least one server registered - the default server - and at least one server set as active at all times.

A server cannot be removed during the service's execution or when another server is just being added or removed (e.g. during OnServersChanged call-back to the service).

Default server may not be removed. An attempt to do so will lead to an exception.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | A server with this Id has not been registered for this service. -or- The given serverId belongs to the default server of the service. Default servers may not be removed.
Autodesk.Revit.Exceptions..::..InvalidOperationException | The operation is not allowed because the service is being executed. -or- The service provider is not valid.

See Also

ExternalService Class
Autodesk.Revit.DB.ExternalService Namespace

ExternalService Properties

[image] [image]