Revit 2013 API
FamilyUtils..::..ConvertFamilyToFaceHostBased Method
FamilyUtils Class See Also Send Feedback
Converts a family to be face host based.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static void ConvertFamilyToFaceHostBased(
    Document aDoc,
    ElementId famId
)
Visual Basic
Public Shared Sub ConvertFamilyToFaceHostBased ( _
    aDoc As Document, _
    famId As ElementId _
)
Visual C++
public:
static void ConvertFamilyToFaceHostBased(
    Document^ aDoc,
    ElementId^ famId
)

Parameters

aDoc
Type: Autodesk.Revit.DB..::..Document
The document containing the family to be converted.
famId
Type: Autodesk.Revit.DB..::..ElementId
The family id.

Remarks

Converts a family hosted by some element other than a face to be hosted by a face. This is done by replacing the existing host (wall, roof, ceiling, floor) with a face. Conversion can succeed only if FamilyUtils.FamilyCanConvertToFaceHostBased() returns true.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input famId cannot be converted to face host based.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | The family is already unhosted. -or- Failed to convert the family to face host based.

See Also

FamilyUtils Class

Dispose Method

[image]