Revit 2013 API
FasciaTypeSet Members
FasciaTypeSet Class Constructors Methods Properties See Also Send Feedback

The FasciaTypeSet type exposes the following members.

Constructors

 | Name | Description
Public method | FasciaTypeSet | Initializes a new instance of the FasciaTypeSet class

Methods

 | Name | Description
Public method | Clear | Removes every fascia type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a fascia type within the set.
Public method | Erase | Removes a specified fascia type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | Insert | Insert the specified fascia type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | Size | Returns the number of fascia types that are in the set.

See Also

FasciaTypeSet Class
Autodesk.Revit.DB.Architecture Namespace

FasciaTypeSet Constructor

[image]