Revit 2013 API
ReferenceIntersector Members
ReferenceIntersector Class Constructors Methods Properties See Also Send Feedback

The ReferenceIntersector type exposes the following members.

Constructors

 | Name | Description
Public method | ReferenceIntersector(View3D) | Constructs a ReferenceIntersector which is set to return intersections from all elements and representing all reference target types.
Public method | ReferenceIntersector(ElementFilter, FindReferenceTarget, View3D) | Constructs a ReferenceIntersector which is set to return intersections from any element which passes the filter.
Public method | ReferenceIntersector(ElementId, FindReferenceTarget, View3D) | Constructs a ReferenceIntersector which is set to return intersections from a single target element only.
Public method | ReferenceIntersector(ICollection<(Of <<'(ElementId>)>>), FindReferenceTarget, View3D) | Constructs a ReferenceIntersector which is set to return intersections from any of a set of target elements. # Find any intersection with any of the target elements.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ReferenceIntersector
Public method | Find | Projects a ray from the origin along the given direction, and returns all references from intersected elements which match the ReferenceIntersector’s criteria.
Public method | FindNearest | Projects a ray from the origin along the given direction, and returns all references from intersected elements which match the ReferenceIntersector’s criteria.
Public method | GetFilter | Gets the ElementFilter used in intersection testing
Public method | GetTargetElementIds | Gets the set of ElementIds to test from in intersection testing
Public method | SetFilter | Sets the ElementFilter used in intersection testing
Public method | SetTargetElementIds | Sets the set of ElementIds to test from in intersection testing

Properties

 | Name | Description
Public property | TargetType | The type of reference to find
Public property | ViewId | The 3DView used for intersecting

See Also

ReferenceIntersector Class

ReferenceIntersector Constructor

[image] [image]