Revit 2013 API
CurtainGridLine..::..Move Method
CurtainGridLine Class See Also Send Feedback
It is used to move unlocked type-driven grid lines or user defined grid lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool Move(
    XYZ moveVec
)
Visual Basic
Public Function Move ( _
    moveVec As XYZ _
) As Boolean
Visual C++
public:
bool Move(
    XYZ^ moveVec
)

Parameters

moveVec
Type: Autodesk.Revit.DB..::..XYZ
The vector by which the element is to be moved.

Return Value

If the element is moved successfully then the method return true, otherwise false.

Remarks

Grid line can only move within its surface and U line can only be moved along V direction. So the move distance on grid surface will be calculated from moveVec.

See Also

CurtainGridLine Class

RemoveSegment Method

[image]