Revit 2013 API
CurtainGrid Properties
CurtainGrid Class See Also Send Feedback

The CurtainGrid type exposes the following members.

Properties

 | Name | Description
Public property | Cells | Obsolete. Get all the cells owned by this curtain grid.
Public property | Grid1Angle | The angle for the U grid line pattern of the curtain grid.
Public property | Grid1Justification | The justification for the U grid line pattern of the curtain grid.
Public property | Grid1Offset | The offset for the U grid line pattern of the curtain grid.
Public property | Grid2Angle | The angle for V grid line pattern of the curtain grid.
Public property | Grid2Justification | The justification for the V grid line pattern of the curtain grid.
Public property | Grid2Offset | The offset for V grid line pattern of the curtain grid.
Public property | Mullions | Obsolete. Get all the mullions of the curtain grid. The elements in this set are instances of Mullion.
Public property | NumPanels | The number of panels.
Public property | NumULines | Get the number of grid lines in the U direction.
Public property | NumVLines | Get the number of grid lines in the V direction.
Public property | Panels | Obsolete. All the panels of the curtain grid.
Public property | UGridLines | Obsolete. All grid lines in the U direction.
Public property | UnlockedMullions | Obsolete. Get all the unlocked mullions of the curtain grid.
Public property | UnlockedPanels | Obsolete. Get all the unlocked panels of the curtain grid.
Public property | VGridLines | Obsolete. All grid lines in the V direction.

See Also

CurtainGrid Class

Cells Property

[image]