Revit 2013 API
UpdaterRegistry..::..IsUpdaterRegistered Method
UpdaterRegistry Class See Also Send Feedback
Checks whether an updater with the given id is registered

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static bool IsUpdaterRegistered(
    UpdaterId id
)
Visual Basic
Public Shared Function IsUpdaterRegistered ( _
    id As UpdaterId _
) As Boolean
Visual C++
public:
static bool IsUpdaterRegistered(
    UpdaterId^ id
)

Parameters

id
Type: Autodesk.Revit.DB..::..UpdaterId
Id to check in the registry

Return Value

Returns true if the updater is registered

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

UpdaterRegistry Class

RegisterUpdater Method

[image] [image]