Revit 2013 API
DuctConnector..::..SystemType Property
DuctConnector Class See Also Send Feedback
The system type of the duct connector.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DuctSystemType SystemType { get; set; }
Visual Basic
Public Property SystemType As DuctSystemType
    Get
    Set
Visual C++
public:
property DuctSystemType SystemType {
    DuctSystemType get ();
    void set (DuctSystemType value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input system type is not within the permitted range.

See Also

DuctConnector Class
Autodesk.Revit.DB.Mechanical Namespace

DuctFlowConfigurationType Enumeration

[image]