Revit 2013 API
SaveAsOptions..::..Rename Property
SaveAsOptions Class See Also Send Feedback
Identifies if the operation should rename the saved document, or save a copy.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool Rename { get; set; }
Visual Basic
Public Property Rename As Boolean
    Get
    Set
Visual C++
public:
property bool Rename {
    bool get ();
    void set (bool value);
}

Field Value

True if the operation should associate the saved document in memory with the new filename and path. False if the operation should not change the document in memory, the new document will be a copy. Default is true.

See Also

SaveAsOptions Class

SaveOptions Class

[image]