Revit 2013 API
ScheduleDefinition Properties
ScheduleDefinition Class See Also Send Feedback

The ScheduleDefinition type exposes the following members.

Properties

 | Name | Description
Public property | AreaSchemeId | In an area schedule, the ID of the area scheme to display.
Public property | CategoryId | The category ID of elements appearing in the schedule.
Public property | EmbeddedDefinition | The embedded ScheduleDefinition.
Public property | FamilyId | In a note block schedule, the ID of the Generic Annotation family displayed by the schedule.
Public property | HasEmbeddedSchedule | Indicates if this ScheduleDefinition has an embedded ScheduleDefinition.
Public property | IncludeLinkedFiles | Indicates if the schedule includes elements from linked files.
Public property | IsEmbedded | Indicates if this is an embedded ScheduleDefinition.
Public property | IsItemized | Indicates if the schedule displays each element on a separate row or combines multiple grouped elements onto the same row.
Public property | IsKeySchedule | Indicates if the schedule is a key schedule.
Public property | IsMaterialTakeoff | Indicates if the schedule is a material takeoff.
Public property | ShowGrandTotal | Indicates if a grand total row should be displayed at the bottom of the schedule.
Public property | ShowGrandTotalCount | Indicates if the grand total row should display a count of elements in the schedule.
Public property | ShowGrandTotalTitle | Indicates if the grand total row should display a title.

See Also

ScheduleDefinition Class

AreaSchemeId Property

[image]