Revit 2013 API
TableSectionData..::..SetCellParamIdAndCategoryId Method (Int32, ElementId, ElementId)
TableSectionData Class See Also Send Feedback
Sets a column's category and parameter Id

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetCellParamIdAndCategoryId(
    int nCol,
    ElementId paramId,
    ElementId categoryId
)
Visual Basic
Public Sub SetCellParamIdAndCategoryId ( _
    nCol As Integer, _
    paramId As ElementId, _
    categoryId As ElementId _
)
Visual C++
public:
void SetCellParamIdAndCategoryId(
    int nCol,
    ElementId^ paramId,
    ElementId^ categoryId
)

Parameters

nCol
Type: System..::..Int32
paramId
Type: Autodesk.Revit.DB..::..ElementId
categoryId
Type: Autodesk.Revit.DB..::..ElementId

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

TableSectionData Class
SetCellParamIdAndCategoryId Overload

SetCellParamIdAndCategoryId Method (Int32, Int32, ElementId, ElementId)

[image]