Revit 2013 API
ExporterIFCUtils..::..AddClippingsToBaseExtrusion Method
ExporterIFCUtils Class See Also Send Feedback
Processes the geometry of the wall to create an extruded area solid representing the geometry of the wall (including any clippings imposed by neighboring elements).

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static IFCAnyHandle AddClippingsToBaseExtrusion(
    ExporterIFC exporterIFC,
    Wall wall,
    XYZ setterOffset,
    IFCRange range,
    IFCRange zSpan,
    IFCAnyHandle baseBodyItemHandle,
    out IList<IFCExtrusionData> pCutPairOpenings
)
Visual Basic
Public Shared Function AddClippingsToBaseExtrusion ( _
    exporterIFC As ExporterIFC, _
    wall As Wall, _
    setterOffset As XYZ, _
    range As IFCRange, _
    zSpan As IFCRange, _
    baseBodyItemHandle As IFCAnyHandle, _
    <OutAttribute> ByRef pCutPairOpenings As IList(Of IFCExtrusionData) _
) As IFCAnyHandle
Visual C++
public:
static IFCAnyHandle^ AddClippingsToBaseExtrusion(
    ExporterIFC^ exporterIFC,
    Wall^ wall,
    XYZ^ setterOffset,
    IFCRange^ range,
    IFCRange^ zSpan,
    IFCAnyHandle^ baseBodyItemHandle,
    [OutAttribute] IList<IFCExtrusionData^>^% pCutPairOpenings
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
wall
Type: Autodesk.Revit.DB..::..Wall
The wall.
setterOffset
Type: Autodesk.Revit.DB..::..XYZ
The offset from the placement setter.
range
Type: Autodesk.Revit.DB.IFC..::..IFCRange
The range. This consists of two double values representing the height in Z at the start and the end of the range. If the values are identical the entire wall is used.
zSpan
Type: Autodesk.Revit.DB.IFC..::..IFCRange
The overall span in Z of the wall.
baseBodyItemHandle
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The IfcExtrudedAreaSolid handle generated initially for the wall.
pCutPairOpenings
Type: System.Collections.Generic..::..IList<(Of <(<'IFCExtrusionData>)>)>%
A collection of extruded openings that can be derived from the wall geometry.

Return Value

IfcEtxtrudedAreaSolid handle. This may be the same handle as was input, or a modified handle derived from the clipping geometry. If the function fails this handle will have no value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace

AddOpeningsToElement Method

[image]