Revit 2013 API
AdaptiveComponentFamilyUtils..::..GetNumberOfShapeHandlePoints Method
AdaptiveComponentFamilyUtils Class See Also Send Feedback
Gets number of Shape Handle Point Elements in Adaptive Component Family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static int GetNumberOfShapeHandlePoints(
    FamilyBase famBase
)
Visual Basic
Public Shared Function GetNumberOfShapeHandlePoints ( _
    famBase As FamilyBase _
) As Integer
Visual C++
public:
static int GetNumberOfShapeHandlePoints(
    FamilyBase^ famBase
)

Parameters

famBase
Type: Autodesk.Revit.DB..::..FamilyBase
The Family

Return Value

Number of Adaptive Shape Handle Point Element References in the Adaptive Component Family.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The Family famBase is not an Adaptive Component Family.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation failed.

See Also

AdaptiveComponentFamilyUtils Class

GetPlacementNumber Method

[image]