Revit 2013 API
AssemblyInstance Class
Members Example See Also Send Feedback
Combines multiple elements for tagging, filtering, scheduling and creating isolated assembly views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class AssemblyInstance : Element
Visual Basic
Public Class AssemblyInstance _
    Inherits Element
Visual C++
public ref class AssemblyInstance : public Element

Examples

CopyC#
// Create assembly instance, name the assembly, and create views of the assembly
void CreateAssemblyAndViews(Autodesk.Revit.DB.Document doc, ICollection<ElementId> elementIds)
{
    Transaction transaction = new Transaction(doc);
    ElementId categoryId = doc.GetElement(elementIds.First()).Category.Id; // use category of one of the assembly elements
    if (AssemblyInstance.IsValidNamingCategory(doc, categoryId, elementIds))
    {
        transaction.Start("Create Assembly Instance");
        AssemblyInstance assemblyInstance = AssemblyInstance.Create(doc, elementIds, categoryId);
        transaction.Commit(); // commit the transaction that creates the assembly instance before modifying the instance's name

        transaction.Start("Set Assembly Name");
        assemblyInstance.AssemblyTypeName = "My Assembly Name";
        transaction.Commit();

        if (assemblyInstance.AllowsAssemblyViewCreation()) // create assembly views for this assembly instance
        {
            transaction.Start("View Creation");
            View3D view3d = AssemblyViewUtils.Create3DOrthographic(doc, assemblyInstance.Id);
            View partList = AssemblyViewUtils.CreatePartList(doc, assemblyInstance.Id);
            transaction.Commit();
        }
    }
}

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..AssemblyInstance

See Also

AssemblyInstance Members

AssemblyInstance Members

[image] [image]