Revit 2013 API
ExternalFileReference..::..ExternalFileReferenceType Property
ExternalFileReference Class See Also Send Feedback
The type of external file which this object references.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ExternalFileReferenceType ExternalFileReferenceType { get; }
Visual Basic
Public ReadOnly Property ExternalFileReferenceType As ExternalFileReferenceType
    Get
Visual C++
public:
property ExternalFileReferenceType ExternalFileReferenceType {
    ExternalFileReferenceType get ();
}

Field Value

ExternalFileReferenceType.RevitLink for Revit links, ExternalFileReferenceType.CADLink for CAD link types. ExternalFileReferenceType.DWFMarkup for DWF markups. ExternalFileReferenceType.KeynoteTable for the keynote table element. ExternalFileReferenceType.Decal for rendering decals. ExternalFileReferenceType.Material for material files (not in this release).

See Also

ExternalFileReference Class

PathType Property

[image]