Revit 2013 API
AnalyticalModel..::..GetAnalyticalProjectionDatumPlane Method (AnalyticalDirection)
AnalyticalModel Class See Also Send Feedback
Retrieves analytical model projection information for a specific direction.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2012. Call getAnalyticalProjectionDatumPlane(AnalyticalElementSelector::Enum selector, AnalyticalDirection::Enum direction) instead.")]
public ElementId GetAnalyticalProjectionDatumPlane(
    AnalyticalDirection direction
)
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2012. Call getAnalyticalProjectionDatumPlane(AnalyticalElementSelector::Enum selector, AnalyticalDirection::Enum direction) instead.")> _
Public Function GetAnalyticalProjectionDatumPlane ( _
    direction As AnalyticalDirection _
) As ElementId
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2012. Call getAnalyticalProjectionDatumPlane(AnalyticalElementSelector::Enum selector, AnalyticalDirection::Enum direction) instead.")]
public:
ElementId^ GetAnalyticalProjectionDatumPlane(
    AnalyticalDirection direction
)

Parameters

direction
Type: Autodesk.Revit.DB.Structure..::..AnalyticalDirection
Direction in which analytical model is projected.

Return Value

Datum Plane on to which analytical model is projected, or invalidElementId if not projected to a Datum Plane.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | direction is invalid for analytical model

See Also

AnalyticalModel Class
GetAnalyticalProjectionDatumPlane Overload
Autodesk.Revit.DB.Structure Namespace

GetAnalyticalProjectionDatumPlane Method (AnalyticalElementSelector, AnalyticalDirection)

[image]