Revit 2013 API
AreaReinforcement..::..RemoveAreaReinforcementSystem Method
AreaReinforcement Class See Also Send Feedback
Deletes the specified AreaReinforcement, and converts its RebarInSystem elements to equivalent Rebar elements.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static IList<ElementId> RemoveAreaReinforcementSystem(
    Document doc,
    AreaReinforcement system
)
Visual Basic
Public Shared Function RemoveAreaReinforcementSystem ( _
    doc As Document, _
    system As AreaReinforcement _
) As IList(Of ElementId)
Visual C++
public:
static IList<ElementId^>^ RemoveAreaReinforcementSystem(
    Document^ doc,
    AreaReinforcement^ system
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
The document.
system
Type: Autodesk.Revit.DB.Structure..::..AreaReinforcement
An AreaReinforcement element in the document.

Return Value

The ids of the newly created Rebar elements.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The document doc does not contain the element system
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural.

See Also

AreaReinforcement Class
Autodesk.Revit.DB.Structure Namespace

AreaReinforcement Properties

[image] [image]