Revit 2013 API
StairsRun..::..ExtensionBelowBase Property
StairsRun Class See Also Send Feedback
Specifies a value to extend/trim the run’s first step against base elevation of the stairs.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double ExtensionBelowBase { get; set; }
Visual Basic
Public Property ExtensionBelowBase As Double
    Get
    Set
Visual C++
public:
property double ExtensionBelowBase {
    double get ();
    void set (double value);
}

Remarks

This is useful in cases where the run attaches to the face of a floor opening rather than resting on the surface of the floor. Negative value extends the run’s first step below the stairs’ base elevation. Positive value trims it above the stairs’ base elevation. This value should not be greater than run’s top elevation.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for extendBelowBase must be no more than 30000 feet in absolute value. -or- When setting this property: The extendBelowBase is not less than run height. -or- When setting this property: The extendBelowBase is greater than the top elevation of the stairs run.
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The run cannot extend its below base because its base joins with other stairs components.

See Also

StairsRun Class
Autodesk.Revit.DB.Architecture Namespace

Height Property

[image]