Revit 2013 API
ConnectorElement Class
Members See Also Send Feedback
A base class that provides support for all connector elements occurring in families.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class ConnectorElement : Element,
    IConnector
Visual Basic
Public Class ConnectorElement _
    Inherits Element _
    Implements IConnector
Visual C++
public ref class ConnectorElement : public Element,
    IConnector

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ConnectorElement
Autodesk.Revit.DB.Electrical..::..ElectricalConnector
Autodesk.Revit.DB.Mechanical..::..DuctConnector
Autodesk.Revit.DB.Plumbing..::..PipeConnector

See Also

ConnectorElement Members

ConnectorElement Members

[image] [image]