Revit 2013 API
AdaptiveComponentFamilyUtils..::..IsAdaptiveComponentFamily Method
AdaptiveComponentFamilyUtils Class See Also Send Feedback
Verifies if the Family is an Adaptive Component Family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static bool IsAdaptiveComponentFamily(
    FamilyBase famBase
)
Visual Basic
Public Shared Function IsAdaptiveComponentFamily ( _
    famBase As FamilyBase _
) As Boolean
Visual C++
public:
static bool IsAdaptiveComponentFamily(
    FamilyBase^ famBase
)

Parameters

famBase
Type: Autodesk.Revit.DB..::..FamilyBase
The Family

Return Value

True if the Family is an Adaptive Component Family.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AdaptiveComponentFamilyUtils Class

IsAdaptivePlacementPoint Method

[image]