Revit 2013 API
ExporterIFCUtils..::..CreateDoorPropertySet Method
ExporterIFCUtils Class See Also Send Feedback
Adds the door-specific property set to the export.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static void CreateDoorPropertySet(
    ExporterIFC exporterIFC,
    Element pElem,
    IFCProductWrapper pWrapper
)
Visual Basic
Public Shared Sub CreateDoorPropertySet ( _
    exporterIFC As ExporterIFC, _
    pElem As Element, _
    pWrapper As IFCProductWrapper _
)
Visual C++
public:
static void CreateDoorPropertySet(
    ExporterIFC^ exporterIFC,
    Element^ pElem,
    IFCProductWrapper^ pWrapper
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
pElem
Type: Autodesk.Revit.DB..::..Element
The door element.
pWrapper
Type: Autodesk.Revit.DB.IFC..::..IFCProductWrapper
The product wrapper.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace

CreateDoorWindowBaseQuantities Method

[image]