Revit 2013 API
Edge Methods
Edge Class See Also Send Feedback

The Edge type exposes the following members.

Methods

 | Name | Description
Public method | AsCurve | Returns a curve that corresponds to the edge's parametric orientation.
Public method | AsCurveFollowingFace | Returns a curve that corresponds to this edge as oriented in its topological direction on the specified face.
Public method | ComputeDerivatives | Returns the vectors describing the edge at the specified parameter.
Public method | Evaluate | Evaluates a parameter on the edge.
Public method | EvaluateOnFace | Evaluates a parameter on the edge to produce UV coordinates on the face.
Public method | Tessellate | Returns a polyline approximation to the edge.
Public method | TessellateOnFace | Returns a polyline approximation to the edge in UV parameters of the face.

See Also

Edge Class

AsCurve Method

[image]