Revit 2013 API
Application..::..OpenDocumentFile Method (ModelPath, OpenOptions)
Application Class See Also Send Feedback
Opens a document from disk.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public virtual Document OpenDocumentFile(
    ModelPath modelPath,
    OpenOptions openOptions
)
Visual Basic
Public Overridable Function OpenDocumentFile ( _
    modelPath As ModelPath, _
    openOptions As OpenOptions _
) As Document
Visual C++
public:
virtual Document^ OpenDocumentFile(
    ModelPath^ modelPath,
    OpenOptions^ openOptions
)

Parameters

modelPath
Type: Autodesk.Revit.DB..::..ModelPath
The file to be opened.
openOptions
Type: Autodesk.Revit.DB..::..OpenOptions

Remarks

This method opens the document into memory but does not make it visible to the user in any way.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | If 'modelPath' is nullNothingnullptra null reference (Nothing in Visual Basic)
Autodesk.Revit.Exceptions..::..ArgumentNullException | If 'options' is nullNothingnullptra null reference (Nothing in Visual Basic)
Autodesk.Revit.Exceptions..::..ArgumentException | If the modelPath is not a FilePath
Autodesk.Revit.Exceptions..::..ApplicationException | If the file cannot be opened.

See Also

Application Class
OpenDocumentFile Overload
Autodesk.Revit.ApplicationServices Namespace

OpenIFCDocument Method

[image]