Revit 2013 API
Transform..::..Rotation Property
Transform Class See Also Send Feedback
The transformation that rotates by the specified angle about the specified axis and point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static Transform this[
    XYZ origin,
    XYZ axis,
    double angle
] { get; }
Visual Basic
Public Shared ReadOnly Property Rotation ( _
    origin As XYZ, _
    axis As XYZ, _
    angle As Double _
) As Transform
    Get
Visual C++
public:
static property Transform^ Rotation[XYZ^ origin, XYZ^ axis, double angle] {
    Transform^ get (XYZ^ origin, XYZ^ axis, double angle);
}

Parameters

origin
Type: Autodesk.Revit.DB..::..XYZ
The point to rotate about.
axis
Type: Autodesk.Revit.DB..::..XYZ
The axis vector to rotate about.
angle
Type: System..::..Double
The rotation angle in radians.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the specified value is an infinite number.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the specified values fail to define the transformation.

See Also

Transform Class

Scale Property

[image]