Revit 2013 API
View3D..::..SectionBox Property
View3D Class See Also Send Feedback
The section box of the 3D view cuts the model by its bounds.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public BoundingBoxXYZ SectionBox { get; set; }
Visual Basic
Public Property SectionBox As BoundingBoxXYZ
    Get
    Set
Visual C++
public:
property BoundingBoxXYZ^ SectionBox {
    BoundingBoxXYZ^ get ();
    void set (BoundingBoxXYZ^ value);
}

Remarks

To turn off section box, pass in nullNothingnullptra null reference (Nothing in Visual Basic) or a disabled box. Individual bound enabled flags are currently ignored.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InapplicableDataException | Thrown when getting this property, if the view is a template and does not have a section box applied.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when setting this property, if the view is a template and cannot have a section box applied.

See Also

View3D Class

ViewDetailLevel Enumeration

[image]