Revit 2013 API
BuiltInFailures..::..SystemsFailures Members
BuiltInFailures..::..SystemsFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..SystemsFailures type exposes the following members.

Properties

Name | Description
AddingOtherConnectedMembersToSystem | "You have selected elements that are connected to other elements. These elements will also be added to the System."
DefaultSystemOver50Elems | The default system "[Element Name]" is now over 50 elements. To improve performance, Revit is no longer calculating the critical path pressure drop and the more complex duct sizing has been disabled. If you want to use these features, you must define logical systems in the model instead of using the default system.
ElementsBelongToOtherSystem | You have selected elements that are already part of other Systems that have assigned Equipment. The elements you selected cannot be added to this System.
FamilyDoesntMatchSystemProperties | The family no longer matches the properties for the System. Disconnect the family from the System?
FamilyDoesntMatchSystemPropertiesWasDisconnected | The family no longer matches the properties for the System. Disconnect the family from the System?
MismatchSystemType | Cannot add [Element] to System. The System Type for the available connector does not match the System Type ([Type Name]) for the System.
SelectedElementsArePartOfOtherSystem | You have selected elements that are already part of other System. They will be removed from the original Systems and added to this one.

See Also

BuiltInFailures..::..SystemsFailures Class

BuiltInFailures.SystemsFailures Properties

[image] [image]