Revit 2013 API
Truss Members
Truss Class Methods Properties See Also Send Feedback

The Truss type exposes the following members.

Methods

 | Name | Description
Public method | AttachChord | Attach a truss's specific chord to a specified element, the element should be a roof or floor.
Public method | DetachChord | Detach a truss's specific chord from the element to which it is attached.
 | DropTruss | Drop truss Family, it will disassociate all members from the truss and delete the truss.
Public method | GetTrussMemberInfo | Query if a given element is a member of a truss, its lock status and its usage, etc.
Public method | RemoveProfile | Remove the profile of a truss.
Public method | SetProfile | Add or modify the profile of a truss.
Public method | TogglePinMember | Pin/Unpin a truss member.

Properties

 | Name | Description
Public property | Curves | Get all the truss curves.
Public property | Members | Get all the members of truss.
Public property | TrussType | Retrieve/set an object that represents the type of the truss.

See Also

Truss Class
Autodesk.Revit.DB.Structure Namespace

Truss Methods

[image] [image]