Revit 2013 API
FamilySymbol..::..GetThermalProperties Method
FamilySymbol Class See Also Send Feedback
Returns the thermal properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public FamilyThermalProperties GetThermalProperties()
Visual Basic
Public Function GetThermalProperties As FamilyThermalProperties
Visual C++
public:
FamilyThermalProperties^ GetThermalProperties()

Return Value

The thermal properties. nullNothingnullptra null reference (Nothing in Visual Basic) if the family symbol does not contain thermal properties.

See Also

FamilySymbol Class

SetThermalProperties Method

[image]