Revit 2013 API
TaskDialog Methods
TaskDialog Class See Also Send Feedback

The TaskDialog type exposes the following members.

Methods

 | Name | Description
Public method | AddCommandLink(TaskDialogCommandLinkId, String) | Adds a CommandLink associated to the given id, displaying the indicating main content.
Public method | AddCommandLink(TaskDialogCommandLinkId, String, String) | Adds a CommandLink associated to the given id, displaying the indicating main and supporting content.
Public method | Show()()()() | Shows the task dialog.
 | Show(String, String) | Shows a task dialog with title, main instruction and a Close button.
 | Show(String, String, TaskDialogCommonButtons) | Shows a task dialog with title, main instruction and common buttons.
 | Show(String, String, TaskDialogCommonButtons, TaskDialogResult) | Shows a task dialog with title, main instruction, common buttons and default buttons.
Public method | WasVerificationChecked | Gets the status of the verification checkbox.

See Also

TaskDialog Class
Autodesk.Revit.UI Namespace

AddCommandLink Method

[image] [image]