Revit 2013 API
XYZ..::..IsAlmostEqualTo Method (XYZ)
XYZ Class See Also Send Feedback
Determines whether this vector and the specified vector are the same within the tolerance (1.0e-09).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsAlmostEqualTo(
    XYZ source
)
Visual Basic
Public Function IsAlmostEqualTo ( _
    source As XYZ _
) As Boolean
Visual C++
public:
bool IsAlmostEqualTo(
    XYZ^ source
)

Parameters

source
Type: Autodesk.Revit.DB..::..XYZ
The vector to compare with this vector.

Return Value

True if the vectors are the same; otherwise, false.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when source is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

XYZ Class
IsAlmostEqualTo Overload

IsAlmostEqualTo Method (XYZ, Double)

[image]