Revit 2013 API
AnalyticalModel..::..SetAnalyticalProjectionDatumPlane Method (AnalyticalDirection, ElementId)
AnalyticalModel Class See Also Send Feedback
Sets analytical model projection to a Datum Plane.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2012. Call setAnalyticalProjectionDatumPlane(AnalyticalElementSelector::Enum selector, AnalyticalDirection::Enum direction, ElementId datumPlaneId) instead.")]
public void SetAnalyticalProjectionDatumPlane(
    AnalyticalDirection direction,
    ElementId datumPlaneId
)
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2012. Call setAnalyticalProjectionDatumPlane(AnalyticalElementSelector::Enum selector, AnalyticalDirection::Enum direction, ElementId datumPlaneId) instead.")> _
Public Sub SetAnalyticalProjectionDatumPlane ( _
    direction As AnalyticalDirection, _
    datumPlaneId As ElementId _
)
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2012. Call setAnalyticalProjectionDatumPlane(AnalyticalElementSelector::Enum selector, AnalyticalDirection::Enum direction, ElementId datumPlaneId) instead.")]
public:
void SetAnalyticalProjectionDatumPlane(
    AnalyticalDirection direction,
    ElementId^ datumPlaneId
)

Parameters

direction
Type: Autodesk.Revit.DB.Structure..::..AnalyticalDirection
Direction in which analytical model may be projected.
datumPlaneId
Type: Autodesk.Revit.DB..::..ElementId
Datum Plane on to which analytical model may be projected.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | direction is invalid for analytical model -or- Datum Plane is invalid projection target.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AnalyticalModel Class
SetAnalyticalProjectionDatumPlane Overload
Autodesk.Revit.DB.Structure Namespace

SetAnalyticalProjectionDatumPlane Method (AnalyticalElementSelector, AnalyticalDirection, ElementId)

[image]