Revit 2013 API
PipeConnector..::..SystemType Property
PipeConnector Class See Also Send Feedback
The system type of the pipe connector.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public PipeSystemType SystemType { get; set; }
Visual Basic
Public Property SystemType As PipeSystemType
    Get
    Set
Visual C++
public:
property PipeSystemType SystemType {
    PipeSystemType get ();
    void set (PipeSystemType value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input system type is not within the permitted range.

See Also

PipeConnector Class
Autodesk.Revit.DB.Plumbing Namespace

PipeFlowConfigurationType Enumeration

[image]