Revit 2013 API
FabricSheetType Members
FabricSheetType Class Methods Properties See Also Send Feedback

The FabricSheetType type exposes the following members.

Methods

 | Name | Description
Public method | IsValidFabricWireType | Verifies that input is ElementId of a FabricWireType
Public method | IsValidMajorLapSplice |
Public method | IsValidMaterial | Verifies that input is ElementId of a Material
Public method | IsValidMinorLapSplice |
Public method | SetMajorLayoutAsActualSpacing | Set Major Layout Pattern as Actual Spacing.
Public method | SetMajorLayoutAsFixedNumber | Set Major Layout Pattern as Fixed Number.
Public method | SetMajorLayoutAsMaximumSpacing | Set Major Layout Pattern as Maximum Spacing.
Public method | SetMajorLayoutAsNumberWithSpacing | Set Major Layout Pattern as Number with Spacing.
Public method | SetMinorLayoutAsActualSpacing | Set Minor Layout Pattern as Actual Spacing.
Public method | SetMinorLayoutAsFixedNumber | Set Minor Layout Pattern as Fixed Number.
Public method | SetMinorLayoutAsMaximumSpacing | Set Minor Layout Pattern as Maximum Spacing.
Public method | SetMinorLayoutAsNumberWithSpacing | Set Minor Layout Pattern as Number with Spacing.

Properties

 | Name | Description
Public property | MajorDirectionWireType | Determines which "Fabric Wire" type will be used in the major direction.
Public property | MajorEndOverhang | Determines the distance from the edge of the sheet to the last wire (measured in the major direction).
Public property | MajorLapSpliceLength | Defines the internal snapping for single fabric placement.
Public property | MajorLayoutPattern | Identifies the layout pattern of Fabric Sheet.
Public property | MajorNumberOfWires | Determines the number of wires used in the major direction (includes the 1st and last wires).
Public property | MajorReinforcementArea | Area of fabric divided by the spacing of the wire.
Public property | MajorSpacing | Determines the spacing between the wires (not including the overhangs).
Public property | MajorStartOverhang | Determines the distance from the edge of the sheet to the 1st wire (measured in the major direction).
Public property | Material | Defines wire material ElementId of the Fabric Sheet
Public property | MinorDirectionWireType | Determines which "Fabric Wire" type will be used in the minor direction.
Public property | MinorEndOverhang | Determines the distance from the edge of the sheet to the last wire (measured in the minor direction).
Public property | MinorLapSpliceLength | Defines the internal snapping for single fabric placement.
Public property | MinorLayoutPattern | Identifies the layout pattern of Fabric Sheet.
Public property | MinorNumberOfWires | Determines the number of wires used in the minor direction (includes the 1st and last wires).
Public property | MinorReinforcementArea | Area of Wire / Spacing of Wire.
Public property | MinorSpacing | Determines the spacing between the wires (not including the overhangs).
Public property | MinorStartOverhang | Determines the distance from the edge of the sheet to the 1st wire (measured in the minor direction).
Public property | OverallLength | Determines the length of the wire sheet (including overhangs) in the major direction.
Public property | OverallWidth | Determines the length of the wire sheet (including overhangs) in the minor direction.
Public property | PhysicalMaterialAsset | Defines Physical Material Asset.
Public property | SheetMass | Defines sheet mass.
Public property | SheetMassUnit | Defines sheet mass per area unit.

See Also

FabricSheetType Class
Autodesk.Revit.DB.Structure Namespace

FabricSheetType Methods

[image] [image]