Revit 2013 API
Dimension Class
Members Example See Also Send Feedback
An object that represents a dimension within the Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class Dimension : Element
Visual Basic
Public Class Dimension _
    Inherits Element
Visual C++
public ref class Dimension : public Element

Examples

CopyC#
public void GetInfo_Dimension(Dimension dimension)
{
    string message = "Dimension : ";
    // Get Dimension name
    message += "\nDimension name is : " + dimension.Name;

    // Get Dimension Curve
    Autodesk.Revit.DB.Curve curve = dimension.Curve;
    if (curve != null && curve.IsBound)
    {
        // Get curve start point
        message += "\nCurve start point:(" + curve.get_EndPoint(0).X + ", "
             + curve.get_EndPoint(0).Y + ", " + curve.get_EndPoint(0).Z + ")";
        // Get curve end point
        message += "; Curve end point:(" + curve.get_EndPoint(1).X + ", "
             + curve.get_EndPoint(1).Y + ", " + curve.get_EndPoint(1).Z + ")";
    }

    // Get Dimension type name
    message += "\nDimension type name is : " + dimension.DimensionType.Name;

    // Get Dimension view name
    message += "\nDimension view name is : " + dimension.View.ViewName;

    // Get Dimension reference count
    message += "\nDimension references count is " + dimension.References.Size;

    if ((int)BuiltInCategory.OST_Dimensions == dimension.Category.Id.IntegerValue)
    {
        message += "\nDimension is a permanent dimension.";
    }
    else if ((int)BuiltInCategory.OST_Constraints == dimension.Category.Id.IntegerValue)
    {
        message += "\nDimension is a constraint element.";
    }

    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Public Sub GetInfo_Dimension(ByVal dimension As Autodesk.Revit.DB.Dimension)
    Dim message As String = "Dimension : "
    ' Get Dimension name
    message += vbLf & "Dimension name is : " + dimension.Name

    ' Get Dimension Curve
    Dim curve As Autodesk.Revit.DB.Curve = dimension.Curve
    If curve IsNot Nothing AndAlso curve.IsBound Then
        ' Get curve start point
        message += vbLf & "Curve start point:(" + curve.EndPoint(0).X + ", " + curve.EndPoint(0).Y + ", " + curve.EndPoint(0).Z + ")"
        ' Get curve end point
        message += "; Curve end point:(" + curve.EndPoint(1).X + ", " + curve.EndPoint(1).Y + ", " + curve.EndPoint(1).Z + ")"
    End If

    ' Get Dimension type name
    message += vbLf & "Dimension type name is : " + dimension.DimensionType.Name

    ' Get Dimension view name
    message += vbLf & "Dimension view name is : " + dimension.View.ViewName

    ' Get Dimension reference count
    message += vbLf & "Dimension references count is " + dimension.References.Size

    If DirectCast(BuiltInCategory.OST_Dimensions, Integer) = dimension.Category.Id.IntegerValue Then
        message += vbLf & "Dimension is a permanent dimension."
    ElseIf DirectCast(BuiltInCategory.OST_Constraints, Integer) = dimension.Category.Id.IntegerValue Then
        message += vbLf & "Dimension is a constraint element."
    End If

    TaskDialog.Show("Revit", message)
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..Dimension
Autodesk.Revit.DB..::..SpotDimension

See Also

Dimension Members

Dimension Members

[image] [image]