Revit 2013 API
AnalyticalModel..::..GetAnalyticalProjectionType Method (AnalyticalDirection)
AnalyticalModel Class See Also Send Feedback
Retrieves Analytical Model projection information for a specific direction. In direction: direction in which the Analytical Model may be projected.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2012. Call getAnalyticalProjectionType(AnalyticalElementSelector::Enum selector, AnalyticalDirection::Enum direction) instead.")]
public AnalyticalProjectionType GetAnalyticalProjectionType(
    AnalyticalDirection direction
)
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2012. Call getAnalyticalProjectionType(AnalyticalElementSelector::Enum selector, AnalyticalDirection::Enum direction) instead.")> _
Public Function GetAnalyticalProjectionType ( _
    direction As AnalyticalDirection _
) As AnalyticalProjectionType
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2012. Call getAnalyticalProjectionType(AnalyticalElementSelector::Enum selector, AnalyticalDirection::Enum direction) instead.")]
public:
AnalyticalProjectionType GetAnalyticalProjectionType(
    AnalyticalDirection direction
)

Parameters

direction
Type: Autodesk.Revit.DB.Structure..::..AnalyticalDirection
Direction of projection.

Return Value

Indicates if the projection is a preset value, or refers to a Datum Plane.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | direction is invalid for analytical model

See Also

AnalyticalModel Class
GetAnalyticalProjectionType Overload
Autodesk.Revit.DB.Structure Namespace

GetAnalyticalProjectionType Method (AnalyticalElementSelector, AnalyticalDirection)

[image]