Revit 2013 API
ItemFactoryBase..::..NewFamilyInstance Method (Face, XYZ, XYZ, FamilySymbol)
ItemFactoryBase Class See Also Send Feedback
Inserts a new instance of a family onto a face of an existing element, using a location, reference direction, and a type/symbol.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilyInstance NewFamilyInstance(
    Face face,
    XYZ location,
    XYZ referenceDirection,
    FamilySymbol symbol
)
Visual Basic
Public Function NewFamilyInstance ( _
    face As Face, _
    location As XYZ, _
    referenceDirection As XYZ, _
    symbol As FamilySymbol _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewFamilyInstance(
    Face^ face,
    XYZ^ location,
    XYZ^ referenceDirection,
    FamilySymbol^ symbol
)

Parameters

face
Type: Autodesk.Revit.DB..::..Face
A face of a geometry object.
location
Type: Autodesk.Revit.DB..::..XYZ
Point on the face where the instance is to be placed.
referenceDirection
Type: Autodesk.Revit.DB..::..XYZ
A vector that defines the direction of the family instance. Note that this direction defines the rotation of the instance on the face, and thus cannot be parallel to the face normal.
symbol
Type: Autodesk.Revit.DB..::..FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted. Note that this symbol must represent a family whose FamilyPlacementType is WorkPlaneBased.

Return Value

An instance of the new object if creation was successful, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

Use this method to insert one family instance on a face of another element, using a point on the face and a vector to define the position and direction of the new symbol.

The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

The host object must support insertion of instances, otherwise this method will fail. If the instances fails to be created an exception may be thrown.

Some Families, such as Beams, have more than one endpoint and are inserted in the same manner as single point instances. Once inserted, these linear family instances can have their endpoints changed by using the instance's Element.Location property.

Note: if the created family instance includes nested instances, the API framework will automatically regenerate the document during this method call. This happens regardless of the setting for RegenerationMode.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when a non-optional argument was null.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the function cannot get the Reference from the face, or, when the Family cannot be placed as line-based on an input face reference, because its FamilyPlacementType is not WorkPlaneBased
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | Thrown when reference direction is parallel to face normal at insertion point.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when Revit is unable to place the family instance.

See Also

ItemFactoryBase Class
NewFamilyInstance Overload
Autodesk.Revit.Creation Namespace

NewFamilyInstance Method (Reference, XYZ, XYZ, FamilySymbol)

[image]