Revit 2013 API
AnalyticalModelSketchComponent Members
AnalyticalModelSketchComponent Class Methods See Also Send Feedback

The AnalyticalModelSketchComponent type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the AnalyticalModelSketchComponent
Public method | EnableAutoDetect | Enables Auto-detect on Sketch Component.
Public method | GetAnalyticalAlignmentMethod | Retrieves Analytical Alignment Method preset for Sketch Component.
Public method | GetAnalyticalProjectionDatumPlane | Retrieves Datum Plane ElementId for Analytical Projection
Public method | GetAnalyticalProjectionType | Retrieves Analytical Projection Type preset for Sketch Component.
Public method | GetAutoDetectMatchedElements | Retrieves ElementIds that Sketch Component is Auto-detecting against.
Public method | GetComponentElementId | Retrieves ElementId of Sketch Component, if such an operation makes sense.
Public method | IsAutoDetectEnabled | Indicates whether Auto-detect is enabled on the given Sketch component.
Public method | IsValidAnalyticalAlignmentMethod | Indicates whether Analytical Alignment Method is valid for Sketch Component.
Public method | IsValidAnalyticalProjectionType | Indicates whether Analytical Projection Type is valid for Sketch Component.
Public method | IsValidDatumPlaneForProjection | Indicates whether Datum Plane is valid Analytical Projection of Sketch Component.
Public method | SetAnalyticalAlignmentMethod | Sets the Alignment Method to the supplied Analytical Alignment Method
Public method | SetAnalyticalProjectionDatumPlane | Sets the Analytical Projection to supplied Datum Plane.
Public method | SetAnalyticalProjectionType | Sets the Analytical Projection to the supplied Analytical Projection Type.

See Also

AnalyticalModelSketchComponent Class
Autodesk.Revit.DB.Structure Namespace

AnalyticalModelSketchComponent Methods

[image] [image]