Revit 2013 API
Face Members
Face Class Methods Properties See Also Send Feedback

The Face type exposes the following members.

Methods

 | Name | Description
Public method | ComputeDerivatives | Returns the vectors describing the face at the specified point.
Public method | ComputeNormal | Returns the normal vector for the face at the given point.
Public method | Evaluate | Evaluates parameters on the face.
Public method | GetBoundingBox | Returns the UV bounding box of the face.
Public method | GetRegions | Face regions (created with the Split Face command) of the face.
Public method | Intersect(Curve) | Calculates the intersection of the specified curve with this face.
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of the specified curve with this face and returns the intersection results.
Public method | IsInside(UV) | Indicates whether the specified point is within this face.
Public method | IsInside(UV, IntersectionResult%) | Indicates whether the specified point is within this face and outputs additional results.
Public method | Project | Projects the specified point on this face.
Public method | Triangulate()()()() | Returns a triangular mesh approximation to the face.
Public method | Triangulate(Double) | Returns a triangular mesh approximation to the face.

Properties

 | Name | Description
Public property | Area | The area of this face.
Public property | EdgeLoops | Each edge loop is a closed boundary of the face.
Public property | HasRegions | Reports if the face contains regions created with the Split Face command.
Public property | IsCyclic | The boolean value that indicates whether this face is periodic in the specified parametric direction.
Public property | IsTwoSided | Determines if a face is two-sided (degenerate)
Public property | MaterialElementId | Element ID of the material from which this face is composed.
Public property | Period | The period of this face in the specified parametric direction.
Public property | Reference | Returns a stable reference to the face.

See Also

Face Class

Face Methods

[image] [image]