Revit 2013 API
ParameterFilterElement Members
ParameterFilterElement Class Methods Properties See Also Send Feedback

The ParameterFilterElement type exposes the following members.

Methods

 | Name | Description
 | AllCategoriesFilterable | Checks that all of the given categories are filterable.
Public method | AllRuleParametersApplicable(IList<(Of <<'(FilterRule>)>>)) | Checks that the parameters of the given rules are valid for this filter's categories.
 | AllRuleParametersApplicable(Document, ICollection<(Of <<'(ElementId>)>>), IList<(Of <<'(FilterRule>)>>)) | Checks that the parameters of the given rules are valid for the given set of categories.
Public method | ClearRules | Removes all rules from this filter.
 | Create(Document, String, ICollection<(Of <<'(ElementId>)>>)) | Creates a new ParameterFilterElement in the given document.
 | Create(Document, String, ICollection<(Of <<'(ElementId>)>>), IList<(Of <<'(FilterRule>)>>)) | Creates a new ParameterFilterElement in the given document.
Public method | GetCategories | Gets the categories admitted by this filter.
 | GetRuleParameter | Returns the parameter for a given filter rule.
Public method | GetRuleParameters | Retrieves a list of the parameters associated with each rule in the filter. The order of the resulting array corresponds to the order in which the associated filter rules are applied.
Public method | GetRules | Returns the rules of this filter, in the order in which they are applied.
Public method | SetCategories | Sets the categories admitted by this filter.
Public method | SetRules | Sets the rules, all of which must be satisfied for a given element to pass this filter.

Properties

 | Name | Description

See Also

ParameterFilterElement Class

ParameterFilterElement Methods

[image] [image]