Revit 2013 API
IFCDoorWindowInfo..::..CreateDoorInfo Method
IFCDoorWindowInfo Class See Also Send Feedback
Creates a new instance of IFCDoorWindowInfo representing a door to be exported.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static IFCDoorWindowInfo CreateDoorInfo(
    ExporterIFC exporterIFC,
    FamilyInstance familyInstance,
    FamilySymbol familyType,
    HostObject hostObj,
    ElementId overrideLevelId,
    Transform trf
)
Visual Basic
Public Shared Function CreateDoorInfo ( _
    exporterIFC As ExporterIFC, _
    familyInstance As FamilyInstance, _
    familyType As FamilySymbol, _
    hostObj As HostObject, _
    overrideLevelId As ElementId, _
    trf As Transform _
) As IFCDoorWindowInfo
Visual C++
public:
static IFCDoorWindowInfo^ CreateDoorInfo(
    ExporterIFC^ exporterIFC,
    FamilyInstance^ familyInstance,
    FamilySymbol^ familyType,
    HostObject^ hostObj,
    ElementId^ overrideLevelId,
    Transform^ trf
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter handle.
familyInstance
Type: Autodesk.Revit.DB..::..FamilyInstance
The door instance.
familyType
Type: Autodesk.Revit.DB..::..FamilySymbol
The door element type.
hostObj
Type: Autodesk.Revit.DB..::..HostObject
The host for the door. Optional, if nullNothingnullptra null reference (Nothing in Visual Basic) the door will be considered unhosted in the output.
overrideLevelId
Type: Autodesk.Revit.DB..::..ElementId
Id for the level to associate to the door. If InvalidElementId, this will be obtained from the instance itself.
trf
Type: Autodesk.Revit.DB..::..Transform
Transform of the door instance.

Return Value

The new IFCDoorWindowInfo handle.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCDoorWindowInfo Class
Autodesk.Revit.DB.IFC Namespace

CreateWindowInfo Method

[image]