Revit 2013 API
RebarBarType Methods
RebarBarType Class See Also Send Feedback

The RebarBarType type exposes the following members.

Methods

 | Name | Description
 | Create | Creates a new RebarBarType object
Public method | GetAutoCalcHookLengths | Identifies if the hook lengths of a hook type are automatically calculated for this bar type
Public method | GetHookLength | Identifies the hook length for a hook type
Public method | GetHookOffsetLength | Identifies the hook offset length for a hook type
Public method | GetHookPermission | Identifies if a hook type is permitted for this bar type
Public method | SetAutoCalcHookLengths | Identifies if the hook lengths of a hook type are automatically calculated for this bar type
Public method | SetHookLength | Identifies the hook length for a hook type
Public method | SetHookOffsetLength | Identifies the hook offset length for a hook type
Public method | SetHookPermission | Identifies if a hook type is permitted for this bar type

See Also

RebarBarType Class
Autodesk.Revit.DB.Structure Namespace

Create Method

[image]