Revit 2013 API
ViewPlan..::..Create Method
ViewPlan Class See Also Send Feedback
Creates a new ViewPlan.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static ViewPlan Create(
    Document document,
    ElementId viewFamilyTypeId,
    ElementId levelId
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    viewFamilyTypeId As ElementId, _
    levelId As ElementId _
) As ViewPlan
Visual C++
public:
static ViewPlan^ Create(
    Document^ document,
    ElementId^ viewFamilyTypeId,
    ElementId^ levelId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the ViewPlan will be added.
viewFamilyTypeId
Type: Autodesk.Revit.DB..::..ElementId
The id of the ViewFamilyType which will be used by the new ViewPlan. The type needs to be a FloorPlan, CeilingPlan, AreaPlan, or StructuralPlan ViewType.
levelId
Type: Autodesk.Revit.DB..::..ElementId
The id of the Level to associate with the new plan view.

Return Value

The new ViewPlan.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | This view family type is not a plan view type. -or- The ElementId levelId does not correspond to a Level. -or- The view family type cannot be created in this discipline of Revit. -or- Plan view creation is not allowed in this family.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

ViewPlan Class

CreateAreaPlan Method

[image]