Revit 2013 API
TableSectionData Members
TableSectionData Class Methods Properties See Also Send Feedback

The TableSectionData type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the TableSectionData
Public method | GetCellCalculatedValue(Int32) | Gets the calculated value for the specified column
Public method | GetCellCalculatedValue(Int32, Int32) | Gets the calculated value for the specified cell
Public method | GetCellCategoryId(Int32) | Returns a column's ParamId Associated with the paramId to find the correct element
Public method | GetCellCategoryId(Int32, Int32) | Returns a cell's CategoryId and if no CategoryId exists for this cell, it would come from the column. Associated with the paramId to find the correct element.
Public method | GetCellCombinedParameters(Int32) | Returns an array of combined parameter data for the specified column
Public method | GetCellCombinedParameters(Int32, Int32) | Returns an array of combined parameter data for the specified cell
Public method | GetCellParamId(Int32) | Returns a column's ParamId
Public method | GetCellParamId(Int32, Int32) | Returns a cell's ParamId and if no ParamId exists for this cell, it would come from the column
Public method | GetCellText | Returns a cell's text depending on its type
Public method | GetCellType(Int32) | Returns a column's cell type and if no type exists for this column, it would come from the section
Public method | GetCellType(Int32, Int32) | Returns a cell's Type and if no Type exists for this cell, it would come from the column, or the row, or the section
Public method | GetColumnWidth | Returns a column's width in feet
Public method | GetColumnWidthInPixels | This returns a column's width in pixels
Public method | GetMergedCell | Gets the whole merged cell that this cell is a part of.
Public method | GetRowHeight | Returns a row's height in feet
Public method | GetRowHeightInPixels | This returns a row's height in pixels
Public method | GetTableCellStyle | Returns a cell's style and if no style exists for this cell, it would come from the column, or the section
Public method | MergeCells | Merges cells for the given area.
Public method | SetCellCalculatedValue(Int32, TableCellCalculatedValueData) | Allows the caller to set the calculated value for a specified column
Public method | SetCellCalculatedValue(Int32, Int32, TableCellCalculatedValueData) | Allows the caller to set the calculated value for a specified cell
Public method | SetCellCombinedParameters(Int32, IList<(Of <<'(TableCellCombinedParameterData>)>>)) | Allows the caller to set combined parameter for a specified column
Public method | SetCellCombinedParameters(Int32, Int32, IList<(Of <<'(TableCellCombinedParameterData>)>>)) | Allows the caller to set combined parameter for a specified cell
Public method | SetCellParamIdAndCategoryId(Int32, ElementId, ElementId) | Sets a column's category and parameter Id
Public method | SetCellParamIdAndCategoryId(Int32, Int32, ElementId, ElementId) | Sets a cell's category and parameter Id
Public method | SetCellStyle(TableCellStyle) | Sets a section's style
Public method | SetCellStyle(Int32, TableCellStyle) | Sets a column's style
Public method | SetCellStyle(Int32, Int32, TableCellStyle) | Sets a cell's style
Public method | SetCellText | Sets a cell's style
Public method | SetCellType(Int32, CellType) | Sets a column's cell type
Public method | SetCellType(Int32, Int32, CellType) | Sets a cell's Type
Public method | SetColumnWidth | Sets a column's width in feet
Public method | SetColumnWidthInPixels | This sets a column's width in pixels
Public method | SetMergedCell | Sets the merged cell that this cell is a part of.
Public method | SetRowHeight | Sets a row's height in feet
Public method | SetRowHeightInPixels | This sets a row's height in pixels

Properties

 | Name | Description
Public property | HideSection |
Public property | NeedsRefresh |
Public property | NumberOfColumns | Gets or sets the number of items in column data array.
Public property | NumberOfRows | Gets or sets the number of items in row data array.

See Also

TableSectionData Class

TableSectionData Methods

[image] [image]