Revit 2013 API
Document..::..Export Method
Document Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Export(String, String, MassGBXMLExportOptions) | Exports a gbXML file from a mass model document.
Public method | Export(String, String, GBXMLExportOptions) | Exports the document in Green-Building XML format.
Public method | Export(String, String, IFCExportOptions) | Exports the document to the Industry Standard Classes (IFC) format.
Public method | Export(String, String, ViewSet, DWFExportOptions) | Exports the current view or a selection of views in DWF format.
Public method | Export(String, String, ViewSet, DWFXExportOptions) | Exports the current view or a selection of views in DWFX format.
Public method | Export(String, String, ViewSet, FBXExportOptions) | Exports the document in 3D-Studio Max (FBX) format.
Public method | Export(String, String, ViewSet, SATExportOptions) | Exports the current view or a selection of views in SAT format.
Public method | Export(String, String, ICollection<(Of <<'(ElementId>)>>), DGNExportOptions) | Exports a selection of views in DGN format.
Public method | Export(String, String, ICollection<(Of <<'(ElementId>)>>), DWGExportOptions) | Exports a selection of views in DWG format.
Public method | Export(String, String, ICollection<(Of <<'(ElementId>)>>), DXFExportOptions) | Exports a selection of views in DXF format.
Public method | Export(String, String, View3D, ViewPlan, BuildingSiteExportOptions) | Exports the document in the format of Civil Engineering design applications.

See Also

Document Class
Document Members

Export Method (String, String, MassGBXMLExportOptions)

[image]