Revit 2013 API
WorksharingUtils..::..GetCheckoutStatus Method (Document, ElementId)
WorksharingUtils Class See Also Send Feedback
Gets the ownership status of an element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static CheckoutStatus GetCheckoutStatus(
    Document document,
    ElementId elementId
)
Visual Basic
Public Shared Function GetCheckoutStatus ( _
    document As Document, _
    elementId As ElementId _
) As CheckoutStatus
Visual C++
public:
static CheckoutStatus GetCheckoutStatus(
    Document^ document,
    ElementId^ elementId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document containing the element
elementId
Type: Autodesk.Revit.DB..::..ElementId
The id of the element in question

Return Value

A summary of whether the element is unowned, owned by the current user, or owned by another user

Remarks

For performance reasons, the model is not validated to be workshared, and the element id is also not validated; the element is not expanded

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

WorksharingUtils Class
GetCheckoutStatus Overload

GetCheckoutStatus Method (Document, ElementId, String)

[image]