Revit 2013 API
FamilyInstance..::..SetCopings Method
FamilyInstance Class See Also Send Feedback
Specify the set of coping cutters on this element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2013.  Call SetCopingIds(System.Collections.Generic.ICollection<Autodesk.Revit.DB.ElementId>  cutters) instead.")]
public bool SetCopings(
    ElementSet cutters
)
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2013.  Call SetCopingIds(System.Collections.Generic.ICollection<Autodesk.Revit.DB.ElementId>  cutters) instead.")> _
Public Function SetCopings ( _
    cutters As ElementSet _
) As Boolean
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2013.  Call SetCopingIds(System.Collections.Generic.ICollection<Autodesk.Revit.DB.ElementId>  cutters) instead.")]
public:
bool SetCopings(
    ElementSet^ cutters
)

Parameters

cutters
Type: Autodesk.Revit.DB..::..ElementSet
A set of coping cutters (steel beams and steel columns).

Remarks

The set must contain elements of FamilyInstance type only. The set may be nullNothingnullptra null reference (Nothing in Visual Basic) or empty, but may not contain the element being coped.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when 'cutters' contains this instance.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when regeneration fails.

See Also

FamilyInstance Class

FamilyInstance Properties

[image] [image]