Revit 2013 API
GroupType Class
Members Example See Also Send Feedback
Represents a type of a user defined group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class GroupType : ElementType
Visual Basic
Public Class GroupType _
    Inherits ElementType
Visual C++
public ref class GroupType : public ElementType

Remarks

The GroupType object can be used to swap the type of an existing group or to place an new instance of a group.

Examples

CopyC#
public void GetInfo_GroupType(GroupType groupType)
{
    string message = "GroupType";
    //Retrieve a set of all the groups that have this type.
    foreach (Group group in groupType.Groups)
    {
        // Get GroupType group name
        message = "\nThe group type name is : " + groupType.Name;
        //Returns all the members of the group.
        message += "\nThe types and ids of the group members are : ";
        foreach (Element element in group.Members)
        {
            // Get GroupType group element id
            message += "\n\t" + element.GetType().Name + " : " + element.Id.IntegerValue;
        }
    }
    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Public Sub GetInfo_GroupType(ByVal groupType As GroupType)
    Dim message As String = "GroupType"
    'Retrieve a set of all the groups that have this type.
    For Each group As Group In groupType.Groups
        ' Get GroupType group name
        message = vbLf & "The group type name is : " & groupType.Name.ToString()
        'Returns all the members of the group.
        message += vbLf & "The types and ids of the group members are : "
        For Each element As Autodesk.Revit.DB.Element In group.Members
            ' Get GroupType group element id
            message += vbLf & vbTab + element.[GetType]().Name & " : " + element.Id.ToString()
        Next
    Next
    TaskDialog.Show("Revit", message)
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..GroupType

See Also

GroupType Members

GroupType Members

[image] [image]