Revit 2013 API
StairsRunType..::..TotalDepth Property
StairsRunType Class See Also Send Feedback
The total depth of the stairs run, only available for monolithic stairs run.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double TotalDepth { get; }
Visual Basic
Public ReadOnly Property TotalDepth As Double
    Get
Visual C++
public:
property double TotalDepth {
    double get ();
}

Field Value

The total depth of the stairs run, 0.0 if the stairs run is not monolithic.

See Also

StairsRunType Class
Autodesk.Revit.DB.Architecture Namespace

TreadNosingPosition Property

[image]