Revit 2013 API
FamilyInstance Methods
FamilyInstance Class See Also Send Feedback

The FamilyInstance type exposes the following members.

Methods

 | Name | Description
Public method | AddCoping | Adds a coping (cut) to a steel beam.
Public method | flipFacing | The orientation of family instance facing will be flipped. If it can not be flipped, return false, otherwise return true.
Public method | FlipFromToRoom | Flips the settings of "From Room" and "To Room" for the door or window instance.
Public method | flipHand | The orientation of family instance hand will be flipped. If it can not be flipped, return false, otherwise return true.
Public method | GetCopingIds | Lists the elements currently used as coping cutters for this element.
Public method | GetCopings | Obsolete. Lists the elements currently used as coping cutters for this element.
Public method | GetFamilyPointPlacementReferences | Returns the Point Placement References for the Family Instance.
Public method | GetOriginalGeometry | Returns the original geometry of the instance, before the instance is modified by joins, cuts, coping, extensions, or other post-processing.
Public method | GetSubComponentIds | Gets the sub component ElementIds of the current family instance.
Public method | RemoveCoping | Removes a coping (cut) from a steel beam.
Public method | rotate | The family instance will be flipped by 180 degrees. If it can not be rotated, return false, otherwise return true.
Public method | SetCopingIds | Specifies the set of coping cutters on this element.
Public method | SetCopings | Obsolete. Specify the set of coping cutters on this element.

See Also

FamilyInstance Class

AddCoping Method

[image]