Revit 2013 API
AnalyticalModel..::..SetAlignmentMethod Method
AnalyticalModel Class See Also Send Feedback
Sets the alignment method for a given selector and direction.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void SetAlignmentMethod(
    AnalyticalElementSelector selector,
    AnalyticalDirection direction,
    AnalyticalAlignmentMethod method
)
Visual Basic
Public Sub SetAlignmentMethod ( _
    selector As AnalyticalElementSelector, _
    direction As AnalyticalDirection, _
    method As AnalyticalAlignmentMethod _
)
Visual C++
public:
void SetAlignmentMethod(
    AnalyticalElementSelector selector,
    AnalyticalDirection direction,
    AnalyticalAlignmentMethod method
)

Parameters

selector
Type: Autodesk.Revit.DB.Structure..::..AnalyticalElementSelector
End of the analytical model.
direction
Type: Autodesk.Revit.DB.Structure..::..AnalyticalDirection
Direction of the analytical model.
method
Type: Autodesk.Revit.DB.Structure..::..AnalyticalAlignmentMethod
The alignment method at a given end.

Remarks

Applicable for analytical models of linear elements (beams, braces, columns).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | direction is invalid for analytical model -or- method is in valid for analytical model

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace

SetAnalyticalOffset Method

[image]