Revit 2013 API
AnalyticalModel Class
Members See Also Send Feedback
AnalyticalModel represents the Analytical Model portion of a given Structural Element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class AnalyticalModel : Element
Visual Basic
Public Class AnalyticalModel _
    Inherits Element
Visual C++
public ref class AnalyticalModel : public Element

Remarks

AnalyticalModel is made up of the following information:
  • Curves, representing the graphical representation of the Element with respect to analysis.
  • Support Information.
  • Adjustment Information, both Manual and Automatic.
  • Parameter Information, including projection, hard points, approximation, and rigid links.
  • Analytical Offset.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB.Structure..::..AnalyticalModel
Autodesk.Revit.DB.Structure..::..AnalyticalModelSurface

See Also

AnalyticalModel Members
Autodesk.Revit.DB.Structure Namespace

AnalyticalModel Members

[image] [image]