Revit 2013 API
View..::..ProjLinePatternOverrideByElement Property
View Class See Also Send Feedback
Override the projection lines' pattern by Element in this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public LinePatternElement this[
    ICollection<ElementId> ids
] { get; set; }
Visual Basic
Public Property ProjLinePatternOverrideByElement ( _
    ids As ICollection(Of ElementId) _
) As LinePatternElement
    Get
    Set
Visual C++
public:
property LinePatternElement^ ProjLinePatternOverrideByElement[ICollection<ElementId^>^ ids] {
    LinePatternElement^ get (ICollection<ElementId^>^ ids);
    void set (ICollection<ElementId^>^ ids, LinePatternElement^ value);
}

Parameters

ids
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
A set of element ids for the elements that are to be overridden.

Field Value

The line pattern of the elements that are to be overridden. nullNothingnullptra null reference (Nothing in Visual Basic) indicates that no override should be applied.

See Also

View Class

ProjLineWeightOverrideByElement Property

[image]