Revit 2013 API
ScheduleDefinition..::..AreaSchemeId Property
ScheduleDefinition Class See Also Send Feedback
In an area schedule, the ID of the area scheme to display.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId AreaSchemeId { get; }
Visual Basic
Public ReadOnly Property AreaSchemeId As ElementId
    Get
Visual C++
public:
property ElementId^ AreaSchemeId {
    ElementId^ get ();
}

Field Value

The ID of an area scheme in an area schedule, InvalidElementId otherwise.

Remarks

Schedules of the Areas category show area elements belonging to a single area scheme.

Key schedules of the Areas category apply to all area schemes, so they don't have an area scheme ID.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

ScheduleDefinition Class

CategoryId Property

[image]