Revit 2013 API
ParameterFilterElement..::..SetCategories Method
ParameterFilterElement Class See Also Send Feedback
Sets the categories admitted by this filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void SetCategories(
    ICollection<ElementId> categories
)
Visual Basic
Public Sub SetCategories ( _
    categories As ICollection(Of ElementId) _
)
Visual C++
public:
void SetCategories(
    ICollection<ElementId^>^ categories
)

Parameters

categories
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>

Remarks

Testing that an element's category is a member of this set is, essentially, the first rule of the filter.

Changing the set of categories will clear the element's filter rules.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | One of the given categories is not filterable
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterElement Class

SetRules Method

[image]