Revit 2013 API
ExporterIFCUtils..::..GetRoomBoundaryAsCurveLoopArray Method
ExporterIFCUtils Class See Also Send Feedback
Obtains the spatial element boundary curves as an array of CurveLoops, needed for processing into IFC-specific elements later.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static IList<CurveLoop> GetRoomBoundaryAsCurveLoopArray(
    SpatialElement spatialElement,
    SpatialElementBoundaryOptions options,
    bool cleanCurves
)
Visual Basic
Public Shared Function GetRoomBoundaryAsCurveLoopArray ( _
    spatialElement As SpatialElement, _
    options As SpatialElementBoundaryOptions, _
    cleanCurves As Boolean _
) As IList(Of CurveLoop)
Visual C++
public:
static IList<CurveLoop^>^ GetRoomBoundaryAsCurveLoopArray(
    SpatialElement^ spatialElement,
    SpatialElementBoundaryOptions^ options,
    bool cleanCurves
)

Parameters

spatialElement
Type: Autodesk.Revit.DB..::..SpatialElement
The spatial element.
options
Type: Autodesk.Revit.DB..::..SpatialElementBoundaryOptions
The options for extraction of the boundaries.
cleanCurves
Type: System..::..Boolean
If true, curves will be trimmed to meet their neighbors. If false, no trimming will take place.

Return Value

The list of CurveLoops.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | Unable to get boundary curve loops for the spatial element.

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace

GetSpatialElementBoundaryOptions Method

[image]