Revit 2013 API
Document..::..NewAreaReinforcement Method
Document Class Example See Also Send Feedback
Creates a new instance of an Area Reinforcement element within the project

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public AreaReinforcement NewAreaReinforcement(
    Element host,
    CurveArray curves,
    XYZ direction
)
Visual Basic
Public Function NewAreaReinforcement ( _
    host As Element, _
    curves As CurveArray, _
    direction As XYZ _
) As AreaReinforcement
Visual C++
public:
AreaReinforcement^ NewAreaReinforcement(
    Element^ host,
    CurveArray^ curves,
    XYZ^ direction
)

Parameters

host
Type: Autodesk.Revit.DB..::..Element
The element to which the Area Reinforcement belongs. The element must be a structural floor or wall.
curves
Type: Autodesk.Revit.DB..::..CurveArray
An array of curves that define the boundary of the area. They must belong to the top face of the floor or the exterior face of the wall.
direction
Type: Autodesk.Revit.DB..::..XYZ

Return Value

If successful, NewAreaReinforcement returns an object for the newly created Rebar. nullNothingnullptra null reference (Nothing in Visual Basic) is returned if the operation fails.

Remarks

Note: this method must not be called during dynamic update, otherwise ForbiddenForDynamicUpdateException will be thrown.

Examples

CopyC#
AreaReinforcement CreateAreaReinforcementInWall(Wall wall, Autodesk.Revit.Creation.Document docCreation)
{
    // Get the wall analytical profile whose curves will define the boundary of the the area reinforcement
    AnalyticalModel analytical = wall.GetAnalyticalModel() as AnalyticalModel;
    if (null == analytical)
    {
        throw new Exception("Can't get AnalyticalModel from the selected wall");
    }

    CurveArray curves = analytical.GetCurves(AnalyticalCurveType.ActiveCurves) as CurveArray;

    //define the Major Direction of AreaReinforcement,
    //we get direction of first Line on the Wall as the Major Direction
    Line firstLine = (Line)(curves.get_Item(0));
    XYZ majorDirection = new XYZ(
        firstLine.get_EndPoint(1).X - firstLine.get_EndPoint(0).X,
        firstLine.get_EndPoint(1).Y - firstLine.get_EndPoint(0).Y,
        firstLine.get_EndPoint(1).Z - firstLine.get_EndPoint(0).Z);

    // Create the area reinforcement
    AreaReinforcement rein = docCreation.NewAreaReinforcement(wall, curves, majorDirection);

    return rein;
}
CopyVB.NET
Function CreateAreaReinforcementInWall(ByVal wall As Wall, ByVal docCreation As Autodesk.Revit.Creation.Document) As Autodesk.Revit.DB.Structure.AreaReinforcement
    ' Get the wall analytical profile whose curves will define the boundary of the the area reinforcement
    Dim analytical As Autodesk.Revit.DB.Structure.AnalyticalModel = TryCast(wall.GetAnalyticalModel(), Autodesk.Revit.DB.Structure.AnalyticalModel)
    If analytical Is Nothing Then
        Throw New Exception("Can't get AnalyticalModel from the selected wall")
    End If

    Dim curves As CurveArray = TryCast(analytical.GetCurves(Autodesk.Revit.DB.Structure.AnalyticalCurveType.ActiveCurves), CurveArray)

    'define the Major Direction of AreaReinforcement,
    'we get direction of first Line on the Wall as the Major Direction
    Dim firstLine As Line = DirectCast((curves.Item(0)), Line)
    Dim majorDirection As New Autodesk.Revit.DB.XYZ(firstLine.EndPoint(1).X - firstLine.EndPoint(0).X, firstLine.EndPoint(1).Y - firstLine.EndPoint(0).Y, firstLine.EndPoint(1).Z - firstLine.EndPoint(0).Z)

    ' Create the area reinforcement
    Dim rein As Autodesk.Revit.DB.Structure.AreaReinforcement = docCreation.NewAreaReinforcement(wall, curves, majorDirection)

    Return rein
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | If the product is not Revit Structure.
Autodesk.Revit.Exceptions..::..ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.

See Also

Document Class
Autodesk.Revit.Creation Namespace

NewAreas Method

[image]