Revit 2013 API
PathReinforcement..::..BarDescription Property
PathReinforcement Class See Also Send Feedback
Retrieves the BarDescription property of an Path Reinforcement element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This property is obsolete in Revit 2013. Use GetRebarInSystemIds() instead.")]
public BarDescription this[
    int idx
] { get; }
Visual Basic
<ObsoleteAttribute("This property is obsolete in Revit 2013. Use GetRebarInSystemIds() instead.")> _
Public ReadOnly Property BarDescription ( _
    idx As Integer _
) As BarDescription
    Get
Visual C++
[ObsoleteAttribute(L"This property is obsolete in Revit 2013. Use GetRebarInSystemIds() instead.")]
public:
property BarDescription^ BarDescription[int idx] {
    BarDescription^ get (int idx);
}

Parameters

idx
Type: System..::..Int32
Index of a Bar Description.

See Also

PathReinforcement Class
Autodesk.Revit.DB.Structure Namespace

Curves Property

[image]