Revit 2013 API
FamilyItemFactory..::..NewReferencePoint Method (PointElementReference)
FamilyItemFactory Class See Also Send Feedback
Create a reference point on an existing reference in an Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ReferencePoint NewReferencePoint(
    PointElementReference
)
Visual Basic
Public Function NewReferencePoint ( _
     As PointElementReference _
) As ReferencePoint
Visual C++
public:
ReferencePoint^ NewReferencePoint(
    PointElementReference^
)

Parameters

Type: Autodesk.Revit.DB..::..PointElementReference

Return Value

The newly created ReferencePoint.

Remarks

The location and coordinate system of the point is determined by the particular PointReference subclass, and the point will remain constrained to that reference.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the family is not a Conceptual Mass Family.

See Also

FamilyItemFactory Class
NewReferencePoint Overload
Autodesk.Revit.Creation Namespace

NewReferencePoint Method (Transform)

[image]