Revit 2013 API
AnalyticalModel..::..IsSurface Method
AnalyticalModel Class See Also Send Feedback
Checks if the analytical model belongs to the surface object like floor, slab or wall.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsSurface()
Visual Basic
Public Function IsSurface As Boolean
Visual C++
public:
bool IsSurface()

Return Value

True is returned when this object is AnalyticalModelSurface class, false otherwise.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace

IsValidAnalyticalProjectionType Method

[image]