Revit 2013 API
DuctSizeSettings Methods
DuctSizeSettings Class See Also Send Feedback

The DuctSizeSettings type exposes the following members.

Methods

 | Name | Description
Public method | AddSize | Inserts a new MEPSize in to the duct size settings. The duct shape determines the location of the new size in the size table.
Public method | Dispose |
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetDuctSizeSettingIterator | Returns a DuctSizeSettingIterator object that iterates through the collection.
 | GetDuctSizeSettings | Get the duct size settings of the project.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetSizeCount | Get the size count of the duct size table. The duct shape determines the location of the size in the size table.
Public method | RemoveSize | Erase the existing MEPSize with this nominal diameter. The duct shape determines the location of the size in the size table.

See Also

DuctSizeSettings Class
Autodesk.Revit.DB.Mechanical Namespace

AddSize Method

[image]