Revit 2013 API
View3D Methods
View3D Class See Also Send Feedback

The View3D type exposes the following members.

Methods

 | Name | Description
Public method | CanSaveOrientation | Returns true if the View3D's orientation can be saved, false otherwise.
 | CreateIsometric | Returns a new isometric View3D.
 | CreatePerspective | Returns a new perspective View3D.
Public method | GetOrientation | Gets the current non-saved orientation of the View3D.
Public method | GetRenderingSettings | Returns the current rendering settings for this 3d view.
Public method | GetSavedOrientation | Gets the saved orientation of the View3D.
Public method | HasBeenLocked | Identifies if the view has ever been locked.
Public method | RestoreOrientationAndLock | Locks the view and restores its orientation.
Public method | SaveOrientation | Converts the temporary orientation of the View3D into its saved orientation.
Public method | SaveOrientationAndLock | Locks the view and saves its orientation
Public method | SetOrientation | Sets the temporary orientation of the View3D. The new orientation is not saved in the document.
Public method | SetRenderingSettings | Changes the rendering settings for this 3d view.
Public method | Unlock | Unlocks the view. Has no effect if the view is already unlocked.

See Also

View3D Class

CanSaveOrientation Method

[image]