Revit 2013 API
CompoundStructureLayer..::..DeckEmbeddingType Property
CompoundStructureLayer Class See Also Send Feedback
Embedding type for structural deck - only for a layer whose function is StructuralDeck.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public StructDeckEmbeddingType DeckEmbeddingType { get; set; }
Visual Basic
Public Property DeckEmbeddingType As StructDeckEmbeddingType
    Get
    Set
Visual C++
public:
property StructDeckEmbeddingType DeckEmbeddingType {
    StructDeckEmbeddingType get ();
    void set (StructDeckEmbeddingType value);
}

See Also

CompoundStructureLayer Class

DeckProfileId Property

[image]