Revit 2013 API
RevitLinkType..::..Create Method
RevitLinkType Class See Also Send Feedback
Creates a new Revit link type and loads the linked document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static RevitLinkLoadResult Create(
    Document document,
    ModelPath path,
    RevitLinkOptions options
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    path As ModelPath, _
    options As RevitLinkOptions _
) As RevitLinkLoadResult
Visual C++
public:
static RevitLinkLoadResult^ Create(
    Document^ document,
    ModelPath^ path,
    RevitLinkOptions^ options
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which to create the Revit link.
path
Type: Autodesk.Revit.DB..::..ModelPath
The path of the link to load. This may be a server path. This must be a full path.
options
Type: Autodesk.Revit.DB..::..RevitLinkOptions
An options class for loading Revit links.

Return Value

An object containing the results of creating and loading the Revit link type. It contains the ElementId of the new link.

Remarks

This function regenerates the input document. While the options argument allows specification of a path type, the input path argument must be a full path. Relative vs. absolute determines how Revit will store the path, but it needs a complete path to find the linked document initially.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document. -or- Server paths cannot be relative. -or- document already contains a linked model at path path.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..FileArgumentNotFoundException | There is not a valid Revit file at path's location
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

RevitLinkType Class

GetChildIds Method

[image]