Revit 2013 API
ReferenceIntersector Constructor (ElementId, FindReferenceTarget, View3D)
ReferenceIntersector Class See Also Send Feedback
Constructs a ReferenceIntersector which is set to return intersections from a single target element only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ReferenceIntersector(
    ElementId targetElementId,
    FindReferenceTarget targetType,
    View3D dbView3d
)
Visual Basic
Public Sub New ( _
    targetElementId As ElementId, _
    targetType As FindReferenceTarget, _
    dbView3d As View3D _
)
Visual C++
public:
ReferenceIntersector(
    ElementId^ targetElementId,
    FindReferenceTarget targetType,
    View3D^ dbView3d
)

Parameters

targetElementId
Type: Autodesk.Revit.DB..::..ElementId
The target element id.
targetType
Type: Autodesk.Revit.DB..::..FindReferenceTarget
The target type of references to return.
dbView3d
Type: Autodesk.Revit.DB..::..View3D
The view to find references in

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ReferenceIntersector Class
ReferenceIntersector Overload

ReferenceIntersector Constructor (ICollection(ElementId), FindReferenceTarget, View3D)

[image]