Revit 2013 API
Railing..::..Create Method
Railing Class See Also Send Feedback
Automatically creates new railings with the specified railing type on all sides of a stairs element.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static ICollection<ElementId> Create(
    Document document,
    ElementId stairsId,
    ElementId railingTypeId,
    RailingPlacementPosition placePosition
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    stairsId As ElementId, _
    railingTypeId As ElementId, _
    placePosition As RailingPlacementPosition _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ Create(
    Document^ document,
    ElementId^ stairsId,
    ElementId^ railingTypeId,
    RailingPlacementPosition placePosition
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
stairsId
Type: Autodesk.Revit.DB..::..ElementId
The stairs to which the new railing will host. The stairs should have no associated railings yet.
railingTypeId
Type: Autodesk.Revit.DB..::..ElementId
The railing type of the new railing is to be created.
placePosition
Type: Autodesk.Revit.DB.Architecture..::..RailingPlacementPosition
The placement position of the new railing.

Return Value

The new railing instances successfully created on the stairs.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The stairsId is not a stairs or ramp element. -or- The railingTypeId is not a railing type.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | The stairsId already has associated railings or is in editing mode so association of railings is not permitted.

See Also

Railing Class
Autodesk.Revit.DB.Architecture Namespace

Flip Method

[image]