Revit 2013 API
Document..::..LoadFamilySymbol Method (String, String, IFamilyLoadOptions, FamilySymbol%)
Document Class See Also Send Feedback
Loads only the specified family type/symbol from a family file into the document and provides a reference to the loaded family symbol.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool LoadFamilySymbol(
    string filename,
    string name,
    IFamilyLoadOptions familyLoadOptions,
    out FamilySymbol symbol
)
Visual Basic
Public Function LoadFamilySymbol ( _
    filename As String, _
    name As String, _
    familyLoadOptions As IFamilyLoadOptions, _
    <OutAttribute> ByRef symbol As FamilySymbol _
) As Boolean
Visual C++
public:
bool LoadFamilySymbol(
    String^ filename,
    String^ name,
    IFamilyLoadOptions^ familyLoadOptions,
    [OutAttribute] FamilySymbol^% symbol
)

Parameters

filename
Type: System..::..String
The fully qualified filename of the Family file, usually ending in .rfa.
name
Type: System..::..String
The name of the type/symbol to be loaded, such as "W11x14".
familyLoadOptions
Type: Autodesk.Revit.DB..::..IFamilyLoadOptions
The interface implementation to use when loading a family into the document.
symbol
Type: Autodesk.Revit.DB..::..FamilySymbol%
A reference to the family symbol that was loaded if successful, otherwise Nothing.

Return Value

True if the family type/symbol was loaded successfully into the project, otherwise False.

Remarks

The path to the installed Autodesk Revit family files can be found by using the Application.Options object and its methods. The name of the family type/symbol is the same name as returned by the Name property on the FamilySymbol object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when filename or name is nullNothingnullptra null reference (Nothing in Visual Basic) or empty.

See Also

Document Class
LoadFamilySymbol Overload

PostFailure Method

[image]