Revit 2013 API
Material..::..Create Method
Material Class Example See Also Send Feedback
Creates a new material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static ElementId Create(
    Document document,
    string name
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    name As String _
) As ElementId
Visual C++
public:
static ElementId^ Create(
    Document^ document,
    String^ name
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which to create the material.
name
Type: System..::..String
The name of the new material.

Return Value

Identifier of the new material.

Examples

CopyC#
//Create the material
ElementId materialId = Material.Create(document, "My Material");
Material material = document.GetElement(materialId) as Material;

//Create a new property set that can be used by this material or other materials.
PropertySetElement propertySet = PropertySetElement.Create(document, Autodesk.Revit.DB.MaterialAspect.Structural);

//Edit parameters in the property set.
propertySet.get_Parameter(BuiltInParameter.PROPERTY_SET_NAME).Set("My Property Set");
propertySet.get_Parameter(BuiltInParameter.PHY_MATERIAL_PARAM_CLASS).Set((int)StructuralMaterialType.Concrete);
propertySet.get_Parameter(BuiltInParameter.PHY_MATERIAL_PARAM_UNIT_WEIGHT).Set(232);

//Assign the property set to the material.
material.SetMaterialAspectByPropertySet(Autodesk.Revit.DB.MaterialAspect.Structural, propertySet.Id);

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | name cannot include prohibited characters.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

Material Class

Duplicate Method

[image]