Revit 2013 API
Application..::..NewProfiledWallCreationData Method (CurveArray, WallType, Level, Boolean)
Application Class See Also Send Feedback
Creates an object which wraps the arguments of NewWall() for batch creation

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ProfiledWallCreationData NewProfiledWallCreationData(
    CurveArray profile,
    WallType wallType,
    Level level,
    bool structural
)
Visual Basic
Public Function NewProfiledWallCreationData ( _
    profile As CurveArray, _
    wallType As WallType, _
    level As Level, _
    structural As Boolean _
) As ProfiledWallCreationData
Visual C++
public:
ProfiledWallCreationData^ NewProfiledWallCreationData(
    CurveArray^ profile,
    WallType^ wallType,
    Level^ level,
    bool structural
)

Parameters

profile
Type: Autodesk.Revit.DB..::..CurveArray
An array of planar lines and arcs that represent the vertical profile of the wall.
wallType
Type: Autodesk.Revit.DB..::..WallType
A wall type to be used by the new wall instead of the default type.
level
Type: Autodesk.Revit.DB..::..Level
The level on which the wall is to be placed.
structural
Type: System..::..Boolean
If set, specifies that the wall is structural in nature.

See Also

Application Class
NewProfiledWallCreationData Overload
Autodesk.Revit.Creation Namespace

NewProfiledWallCreationData Method (CurveArray, WallType, Level, Boolean, XYZ)

[image]