Revit 2013 API
DialogBoxShowingEventArgs Class
Members See Also Send Feedback
The base class for the event arguments used by the DialogBoxShowing event.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public class DialogBoxShowingEventArgs : PreEventArgs
Visual Basic
Public Class DialogBoxShowingEventArgs _
    Inherits PreEventArgs
Visual C++
public ref class DialogBoxShowingEventArgs : public PreEventArgs

Remarks

The actual type of the event arguments will be different depending upon the type of dialog shown. When the application receives this object, a dialog is to be displayed in Revit that requires user interaction. The OverrideResult function can be used to cause the dialog to be dismissed and return a desired result code.

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Autodesk.Revit.DB.Events..::..RevitEventArgs
Autodesk.Revit.DB.Events..::..PreEventArgs
Autodesk.Revit.UI.Events..::..DialogBoxShowingEventArgs
Autodesk.Revit.UI.Events..::..MessageBoxShowingEventArgs
Autodesk.Revit.UI.Events..::..TaskDialogShowingEventArgs

See Also

DialogBoxShowingEventArgs Members
Autodesk.Revit.UI.Events Namespace

DialogBoxShowingEventArgs Members

[image] [image]