Revit 2013 API
ExporterIFCUtils..::..GetSpatialElementBoundaryOptions Method
ExporterIFCUtils Class See Also Send Feedback
Obtains the SpatialElementBoundaryOptions needed for IFC export.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static SpatialElementBoundaryOptions GetSpatialElementBoundaryOptions(
    ExporterIFC exporterIFC,
    SpatialElement spatialElement
)
Visual Basic
Public Shared Function GetSpatialElementBoundaryOptions ( _
    exporterIFC As ExporterIFC, _
    spatialElement As SpatialElement _
) As SpatialElementBoundaryOptions
Visual C++
public:
static SpatialElementBoundaryOptions^ GetSpatialElementBoundaryOptions(
    ExporterIFC^ exporterIFC,
    SpatialElement^ spatialElement
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
spatialElement
Type: Autodesk.Revit.DB..::..SpatialElement
The spatial element for which the options are required. Optional, if nullNothingnullptra null reference (Nothing in Visual Basic) generic options will be obtained.

Return Value

The options.

Remarks

Some varieties of these options cannot be created directly from SpatialElementBoundaryOptions so far.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace

GetTransformForDoorOrWindow Method

[image]