Revit 2013 API
ModelLine Class
Members See Also Send Feedback
Represents a ModelLine within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class ModelLine : ModelCurve
Visual Basic
Public Class ModelLine _
    Inherits ModelCurve
Visual C++
public ref class ModelLine : public ModelCurve

Remarks

Currently it's just a place holder for specific type. All the geometry-related functionality is provided by geometry curve object from ModelCurve::geometryCurve property.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..CurveElement
Autodesk.Revit.DB..::..ModelCurve
Autodesk.Revit.DB..::..ModelLine

See Also

ModelLine Members

ModelLine Members

[image] [image]