Revit 2013 API
TopographySurface..::..AddPoints Method
TopographySurface Class See Also Send Feedback
Adds new points to a topography surface element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void AddPoints(
    IList<XYZ> points
)
Visual Basic
Public Sub AddPoints ( _
    points As IList(Of XYZ) _
)
Visual C++
public:
void AddPoints(
    IList<XYZ^>^ points
)

Parameters

points
Type: System.Collections.Generic..::..IList<(Of <(<'XYZ>)>)>
An array of points for the topography surface.

Remarks

This method will regenerate the document even in manual regeneration mode.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the topography surface is invalid or regeneration fails.

See Also

TopographySurface Class

TopographySurface Properties

[image] [image]