Revit 2013 API
RebarInSystem Methods
RebarInSystem Class See Also Send Feedback

The RebarInSystem type exposes the following members.

Methods

 | Name | Description
Public method | DoesBarExistAtPosition | Checks whether a bar exists at the specified position.
Public method | GetBarPositionTransform | Return a transform representing the relative position of any individual bar in the set.
Public method | GetBendData | Gets the RebarBendData, containing bar and hook information, of the instance.
Public method | GetCenterlineCurves | A chain of curves representing the centerline of the rebar.
Public method | GetDistributionPath | The distribution path of a rebar set.
Public method | GetHookTypeId | Get the id of the RebarHookType to be applied to the rebar.
Public method | GetHostId | The element that contains the rebar.
Public method | IsSolidInView | Checks if this rebar element is shown solidly in a 3D view.
Public method | IsUnobscuredInView | Checks if this rebar element is shown unobscured in a view.

See Also

RebarInSystem Class
Autodesk.Revit.DB.Structure Namespace

DoesBarExistAtPosition Method

[image]