Revit 2013 API
Document..::..Export Method (String, String, ICollection<(Of <(<'ElementId>)>)>, DWGExportOptions)
Document Class See Also Send Feedback
Exports a selection of views in DWG format.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool Export(
    string folder,
    string name,
    ICollection<ElementId> views,
    DWGExportOptions options
)
Visual Basic
Public Function Export ( _
    folder As String, _
    name As String, _
    views As ICollection(Of ElementId), _
    options As DWGExportOptions _
) As Boolean
Visual C++
public:
bool Export(
    String^ folder,
    String^ name,
    ICollection<ElementId^>^ views,
    DWGExportOptions^ options
)

Parameters

folder
Type: System..::..String
Output folder, into which file(s) will be exported. The folder must exist.
name
Type: System..::..String
Either the name of a single file or a prefix for a set of files. If empty, automatic naming will be used. If nullNothingnullptra null reference (Nothing in Visual Basic), throw ArgumentException.
views
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
Selection of views to be exported. The set must contain at least one valid view.
options
Type: Autodesk.Revit.DB..::..DWGExportOptions
Various options applicable to the DWG format. If nullNothingnullptra null reference (Nothing in Visual Basic), all options will be set to their respective default values.

Return Value

True if successful, otherwise False.

Remarks

All the views must be printable for the Export to succeed. It can be assured by checking the CanBePrinted property of each view.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | NullOrEmpty -or- Contains invalid characters -or- non empty list of views must be provided -or- some of the views is not printable(exportable) -or- Thrown when the options in DWGExportOptions is invalid.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DirectoryNotFoundException | Thrown when the directory does not exist.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Export is temporarily disabled. -or- Exporting is not allowed in the current application mode.
Autodesk.Revit.Exceptions..::..InvalidPathArgumentException | The folder does not exist.
Autodesk.Revit.Exceptions..::..OptionalFunctionalityNotAvailableException | The DWG module is not available in the installed Revit. -or- The Graphics module is not available in the installed Revit.

See Also

Document Class
Export Overload

Export Method (String, String, ICollection(ElementId), DXFExportOptions)

[image]