Revit 2013 API
FamilySymbol..::..SetThermalProperties Method
FamilySymbol Class See Also Send Feedback
Set the thermal properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetThermalProperties(
    FamilyThermalProperties thermalProperties
)
Visual Basic
Public Sub SetThermalProperties ( _
    thermalProperties As FamilyThermalProperties _
)
Visual C++
public:
void SetThermalProperties(
    FamilyThermalProperties^ thermalProperties
)

Parameters

thermalProperties
Type: Autodesk.Revit.DB..::..FamilyThermalProperties

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the input argument-"thermalProperties"-is invalid,

See Also

FamilySymbol Class

FamilySymbol Properties

[image] [image]