Revit 2013 API
EnergyDataSettings Methods
EnergyDataSettings Class See Also Send Feedback

The EnergyDataSettings type exposes the following members.

Methods

Name | Description
CheckBuildingConstructionClass
Checks that the building construction class falls within an appropriate range.
CheckBuildingHVACSystem
Checks that the building HVAC system falls within an appropriate range.
CheckBuildingOperatingSchedule
Checks that the building operating schedule falls within an appropriate range.
CheckBuildingType
Checks that the building type falls within an appropriate range.
Public method CheckConstructionSetElement
Checks that the construction set ElementId is acceptable.
CheckExportCategory
Checks whether the export category falls within the list:
  1. OST_Rooms
  2. OST_MEPSpaces
CheckExportComplexity
Checks that the export complexity falls within an appropriate range.
Public method CheckGroundPlane(ElementId)
The ground plane should be an Element of type Level. This method checks to confirm that an ElementId is for a Level element.
CheckGroundPlane(Document, ElementId)
The ground plane should be an Element of type Level. This method checks to confirm that an ElementId is for a Level element.
Public method CheckProjectPhase
Checks that the input element is a project phase.
CheckProjectReportType
Checks that the project report type falls within an appropriate range.
CheckRangeOfMassZoneCoreOffset
Checks that the mass zone core offset is greater than or equal to zero.
CheckRangeOfPercentageGlazing
Checks that the percentage glazing value is between 0.00 and 0.95.
CheckRangeOfPercentageSkylights
Checks that the percentage skylights value is between 0.00 and 0.95.
CheckRangeOfShadeDepth
Checks that the shade depth is greater than or equal to zero.
CheckRangeOfSillHeight
Checks that the sill height is greater than or equal to zero.
CheckRangeOfSkylightWidth
Checks that the skylight width is greater than or equal to eight inches.
CheckRangeOfSliverSpaceTolerance
Checks that the sliver space tolerance is greater than or equal to zero.
CheckServiceType
Checks that the service type falls within an appropriate range.
Public method | Dispose
EnableConceptualEnergyAnalyticalModel
Turns on functionality related to conceptual energy analysis.
GetBuildingConstructionSetElementId
Id of the building construction set.
GetFromDocument
Every project document has a EnergyDataSettings element. Family documents do not have EnergyDataSettings elements.
IsDocumentUsingEnergyDataAnalyticalModel
Get EnergyDataSettings element and if it exists, return result from getCreateAnalyticalModel.
Public method SetCreateAnalyticalModel
If this is true, data, features, and geometry related to the Energy Analytical Model will be created, allowing the energy performance to be analyzed through GreenBuilidingXML.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace

CheckBuildingConstructionClass Method

[image]