Revit 2013 API
CompoundStructureLayer Constructor
CompoundStructureLayer Class See Also Send Feedback
Creates a default compound structure layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CompoundStructureLayer()
Visual Basic
Public Sub New
Visual C++
public:
CompoundStructureLayer()

Remarks

Sets Width to 0. Sets Function to None. Sets DeckEmbeddingType to Invalid. Sets MaterialId to invalidElementId. Sets DeckProfileId to invalidElementId. Sets LayerCapFlag to true. Note that the combination of these default values does not create a completely valid CompoundStructureLayer. You should change the necessary values before adding to a CompoundStructure.

See Also

CompoundStructureLayer Class
CompoundStructureLayer Overload

CompoundStructureLayer Constructor (CompoundStructureLayer)

[image]