Revit 2013 API
RebarBarTypeSet Members
RebarBarTypeSet Class Constructors Methods Properties See Also Send Feedback

The RebarBarTypeSet type exposes the following members.

Constructors

 | Name | Description
Public method | RebarBarTypeSet | Initializes a new instance of the RebarBarTypeSet class

Methods

 | Name | Description
Public method | Clear | Removes every RebarBar type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a RebarBar type within the set.
Public method | Erase | Removes a specified RebarBar type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | Insert | Insert the specified RebarBar type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | Size | Returns the number of RebarBar types that are in the set.

See Also

RebarBarTypeSet Class
Autodesk.Revit.DB.Structure Namespace

RebarBarTypeSet Constructor

[image]