Revit 2013 API
View..::..CutLineWeightOverrideByElement Property
View Class See Also Send Feedback
Override the cut lines' weight by Element in this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int this[
    ICollection<ElementId> ids
] { get; set; }
Visual Basic
Public Property CutLineWeightOverrideByElement ( _
    ids As ICollection(Of ElementId) _
) As Integer
    Get
    Set
Visual C++
public:
property int CutLineWeightOverrideByElement[ICollection<ElementId^>^ ids] {
    int get (ICollection<ElementId^>^ ids);
    void set (ICollection<ElementId^>^ ids, int value);
}

Parameters

ids
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
A set of element ids for the elements that are to be overridden.

Field Value

The line pattern of the elements that are to be overridden. A negative value indicates that no override should be applied.

See Also

View Class

DetailLevel Property

[image]