Revit 2013 API
ViewSchedule..::..CreateNoteBlock Method
ViewSchedule Class Example See Also Send Feedback
Creates a note block.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static ViewSchedule CreateNoteBlock(
    Document document,
    ElementId familyId
)
Visual Basic
Public Shared Function CreateNoteBlock ( _
    document As Document, _
    familyId As ElementId _
) As ViewSchedule
Visual C++
public:
static ViewSchedule^ CreateNoteBlock(
    Document^ document,
    ElementId^ familyId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the new schedule will be added.
familyId
Type: Autodesk.Revit.DB..::..ElementId
The ID of the family whose elements will be included in the schedule.

Return Value

The newly created schedule.

Remarks

A note block is a schedule of the Generic Annotations category that shows elements of a single family rather than all elements in the category.

Examples

CopyC#
//Get first ElementId of AnnotationSymbolType families.
ElementId annotationSymbolTypeId = ElementId.InvalidElementId;
if (!doc.AnnotationSymbolTypes.IsEmpty)
{
    foreach (AnnotationSymbolType type in doc.AnnotationSymbolTypes)
    {
        annotationSymbolTypeId = type.Family.Id;
        break;
    }
}

//Create a noteblock view schedule.
ViewSchedule noteBlockSchedule = ViewSchedule.CreateNoteBlock(doc, annotationSymbolTypeId);

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document. -or- familyId is not a valid family for a note block.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

ViewSchedule Class

CreateRevisionSchedule Method

[image]