Revit 2013 API
ExternalCommandData..::..JournalData Property
ExternalCommandData Class Example See Also Send Feedback
A data map that can be used to read and write data to the Autodesk Revit journal file.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public IDictionary<string, string> JournalData { get; set; }
Visual Basic
Public Property JournalData As IDictionary(Of String, String)
    Get
    Set
Visual C++
public:
property IDictionary<String^, String^>^ JournalData {
    IDictionary<String^, String^>^ get ();
    void set (IDictionary<String^, String^>^ value);
}

Remarks

The data map is a string to string map that can be used to store data in the Revit journal file at the end of execution of the external command. If the command is then executed from the journal file during playback this data is then passed to the external command in this Data property so the external command can execute with this passed data in a UI-less mode, hence providing non interactive journal playback for automated testing purposes. For more information on Revit's journaling features contact the Autodesk Developer Network.

Examples

CopyC#
void WriteJournalData(ExternalCommandData commandData)
{
    // Get the StringStringMap class which can write data into.
    Autodesk.Revit.Collections.StringStringMap dataMap = commandData.JournalData as Autodesk.Revit.Collections.StringStringMap;
    dataMap.Clear();

    // Begin to add the support data
    dataMap.Insert("Name", "Autodesk.Revit");
    dataMap.Insert("Information", "This is an example.");
    dataMap.Insert("Greeting", "Hello Everyone.");
}

/// <summary>
/// This sample shows how to get data from journal file.
/// </summary>
void ReadJournalData(ExternalCommandData commandData)
{
    // Get the StringStringMap class which can write data into.
    Autodesk.Revit.Collections.StringStringMap dataMap = commandData.JournalData as Autodesk.Revit.Collections.StringStringMap;

    // Begin to get the support data.
    String prompt = "Name: " + dataMap.get_Item("Name");
    prompt += "\nInformation: " + dataMap.get_Item("Information");
    prompt += "\nGreeting: " + dataMap.get_Item("Greeting");

    TaskDialog.Show("Revit",prompt);
}
CopyVB.NET
Sub WriteJournalData(ByVal commandData As ExternalCommandData)
    ' Get the StringStringMap class which can write data into.
    Dim dataMap As Autodesk.Revit.Collections.StringStringMap = commandData.Data
    dataMap.Clear()

    ' Begin to add the support data
    dataMap.Insert("Name", "Autodesk.Revit")
    dataMap.Insert("Information", "This is an example.")
    dataMap.Insert("Greeting", "Hello Everyone.")
End Sub

' <summary>
' This sample shows how to get data from journal file.
' </summary>
Sub ReadJournalData(ByVal commandData As ExternalCommandData)
    ' Get the StringStringMap class which can write data into.
    Dim dataMap As Autodesk.Revit.Collections.StringStringMap = commandData.Data

    ' Begin to get the support data.
    Dim prompt As [String] = "Name: " + dataMap.Item("Name")
    prompt += vbLf & "Information: " + dataMap.Item("Information")
    prompt += vbLf & "Greeting: " + dataMap.Item("Greeting")

    TaskDialog.Show("Revit", prompt)
End Sub

See Also

ExternalCommandData Class
Autodesk.Revit.UI Namespace

View Property

[image]