Revit 2013 API
StairsEditScope..::..Cancel Method
StairsEditScope Class See Also Send Feedback
Cancels editing for the stairs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void Cancel()
Visual Basic
Public Sub Cancel
Visual C++
public:
void Cancel()

Remarks

All the changes made after starting the StairsEditScope will be rolled back.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | StairsEditScope is not active. StairsEditScope can only be committed or cancelled when it is active. -or- StairsEditScope cannot be closed, for there is a transaction or transaction group still open in the document.

See Also

StairsEditScope Class

Commit Method

[image]