Revit 2013 API
RebarHookType Methods
RebarHookType Class See Also Send Feedback

The RebarHookType type exposes the following members.

Methods

 | Name | Description
 | Create | Creates a new RebarHookType in a document.
Public method | GetDefaultHookLength | Computes the default hook length, which is equal to barDiameter * multiplier.
Public method | GetHookExtensionLength | Computes the hook extension length.
Public method | IsOffsetLengthRequired | Check whether hook offset length is required. remarks: If hook angle is no more than 90 degree, hook offset length is not meaningful. returns: True if hook offset length is required, otherwise false.

See Also

RebarHookType Class
Autodesk.Revit.DB.Structure Namespace

Create Method

[image]