Revit 2013 API
ExporterIFCUtils..::..CreateOpeningQuantities Method
ExporterIFCUtils Class See Also Send Feedback
Creates the opening quantities and adds them to the export.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static void CreateOpeningQuantities(
    ExporterIFC exporterIFC,
    IFCAnyHandle openingElement,
    IFCExtrusionCreationData extraParams
)
Visual Basic
Public Shared Sub CreateOpeningQuantities ( _
    exporterIFC As ExporterIFC, _
    openingElement As IFCAnyHandle, _
    extraParams As IFCExtrusionCreationData _
)
Visual C++
public:
static void CreateOpeningQuantities(
    ExporterIFC^ exporterIFC,
    IFCAnyHandle^ openingElement,
    IFCExtrusionCreationData^ extraParams
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
openingElement
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The opening element handle.
extraParams
Type: Autodesk.Revit.DB.IFC..::..IFCExtrusionCreationData
Geometric information obtained from the opening.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace

CreatePreCOBIEGSAQuantities Method

[image]