Revit 2013 API
Face Methods
Face Class See Also Send Feedback

The Face type exposes the following members.

Methods

 | Name | Description
Public method | ComputeDerivatives | Returns the vectors describing the face at the specified point.
Public method | ComputeNormal | Returns the normal vector for the face at the given point.
Public method | Evaluate | Evaluates parameters on the face.
Public method | GetBoundingBox | Returns the UV bounding box of the face.
Public method | GetRegions | Face regions (created with the Split Face command) of the face.
Public method | Intersect(Curve) | Calculates the intersection of the specified curve with this face.
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of the specified curve with this face and returns the intersection results.
Public method | IsInside(UV) | Indicates whether the specified point is within this face.
Public method | IsInside(UV, IntersectionResult%) | Indicates whether the specified point is within this face and outputs additional results.
Public method | Project | Projects the specified point on this face.
Public method | Triangulate()()()() | Returns a triangular mesh approximation to the face.
Public method | Triangulate(Double) | Returns a triangular mesh approximation to the face.

See Also

Face Class

ComputeDerivatives Method

[image]