Revit 2013 API
FieldBuilder Members
FieldBuilder Class Constructors Methods See Also Send Feedback

The FieldBuilder type exposes the following members.

Constructors

 | Name | Description
Public method | FieldBuilder(FieldBuilder) | Initializes a new instance of the FieldBuilder class
Public method | FieldBuilder(Field, SchemaBuilder) | Initializes a new instance of the FieldBuilder class

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the FieldBuilder
Public method | NeedsSubSchemaGUID | Checks whether the SubSchema GUID needs to be explicitly specified for this field type.
Public method | NeedsUnits | Checks whether the field type requires explicit unit conversions.
Public method | Ready | Checks whether the builder may be used.
Public method | SetDocumentation | Sets the documentation string for the Field.
Public method | SetSubSchemaGUID | Sets the GUID of the Schema of the Entities that are intended to be stored in this field.
Public method | SetUnitType | Sets the type of units for the field.

See Also

FieldBuilder Class
Autodesk.Revit.DB.ExtensibleStorage Namespace

FieldBuilder Constructor

[image] [image]