Revit 2013 API
ItemFactoryBase..::..NewGroup Method (ElementSet)
ItemFactoryBase Class Example See Also Send Feedback
Creates a new type of group.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2013.  Call NewGroup(System.Collections.Generic.ICollection<Autodesk.Revit.DB.ElementId> elementIds) instead.")]
public Group NewGroup(
    ElementSet elements
)
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2013.  Call NewGroup(System.Collections.Generic.ICollection<Autodesk.Revit.DB.ElementId> elementIds) instead.")> _
Public Function NewGroup ( _
    elements As ElementSet _
) As Group
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2013.  Call NewGroup(System.Collections.Generic.ICollection<Autodesk.Revit.DB.ElementId> elementIds) instead.")]
public:
Group^ NewGroup(
    ElementSet^ elements
)

Parameters

elements
Type: Autodesk.Revit.DB..::..ElementSet
A set of elements which will be made into the new group.

Return Value

A new instance of a group containing the elements specified.

Remarks

  • The new group may contain more members than just the set input to this method. Elements which are closely connected with the inputs (such as sketch and sketch plane) will also be added to the group.
  • Initially the group will have a generic name, such as Group 1. This can be changed by changing the name of the group type as follows: newGroup.GroupType.Name = newName.
  • If a newly-created element is being added to a group, calling document.Regenerate() may be needed to avoid a warning visible in the UI that the group has changed outside group edit mode.

Examples

CopyC#
Group group = null;
UIDocument uidoc = new UIDocument(document);
ElementSet selection = uidoc.Selection.Elements;
if (selection.Size > 0)
{
    // Group all selected elements
    group = document.Create.NewGroup(selection);

}
CopyVB.NET
Dim group As Group = Nothing
Dim uidoc As New UIDocument(document)
Dim selection As ElementSet = uidoc.Selection.Elements
If selection.Size > 0 Then
    ' Group all selected elements

    group = document.Create.NewGroup(selection)
Else

See Also

ItemFactoryBase Class
NewGroup Overload
Autodesk.Revit.Creation Namespace

NewLevel Method

[image]