Revit 2013 API
Application..::..GetWorksharingCentralGUID Method
Application Class See Also Send Feedback
Gets the worksharing central GUID of the given server-based model.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public Guid GetWorksharingCentralGUID(
    ServerPath serverModelPath
)
Visual Basic
Public Function GetWorksharingCentralGUID ( _
    serverModelPath As ServerPath _
) As Guid
Visual C++
public:
Guid GetWorksharingCentralGUID(
    ServerPath^ serverModelPath
)

Parameters

serverModelPath
Type: Autodesk.Revit.DB..::..ServerPath
The server-based model path.

Return Value

The worksharing central GUID.

Remarks

The given server-based model saved in a release prior to Revit 2013 did not have this GUID. Only the given server-based model saved in Revit 2013 or later will be able to provide this value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InapplicableDataException | Thrown when the given model is not created in Revit 2013 or later release.
Autodesk.Revit.Exceptions..::..RevitServerCommunicationException | Thrown when there is any network communication error.
Autodesk.Revit.Exceptions..::..RevitServerInternalException | Thrown when there is any server internal error.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace

NewFamilyDocument Method

[image]