Revit 2013 API
IFCFile..::..CreateCurveBoundedPlane Method
IFCFile Class See Also Send Feedback
Creates a handle representing an IfcCurveBoundedPlane and assigns it to the file.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IFCAnyHandle CreateCurveBoundedPlane(
    IList<XYZ> outerLoop,
    IList<IList<XYZ>> innerLoops
)
Visual Basic
Public Function CreateCurveBoundedPlane ( _
    outerLoop As IList(Of XYZ), _
    innerLoops As IList(Of IList(Of XYZ)) _
) As IFCAnyHandle
Visual C++
public:
IFCAnyHandle^ CreateCurveBoundedPlane(
    IList<XYZ^>^ outerLoop,
    IList<IList<XYZ^>^>^ innerLoops
)

Parameters

outerLoop
Type: System.Collections.Generic..::..IList<(Of <(<'XYZ>)>)>
A set of points that represents the outer boundary.
innerLoops
Type: System.Collections.Generic..::..IList<(Of <(<'IList<(Of <(<'XYZ>)>)>>)>)>
A collection of sets of points that represent inner loops.

Return Value

The handle.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | A transaction is required for this operation.

See Also

IFCFile Class
Autodesk.Revit.DB.IFC Namespace

CreateHeaderInstance Method

[image]