Revit 2013 API
RoutingConditions Class
Members See Also Send Feedback
RoutingConditions contain routing information that is used as input when determining if a routing criterion, such as minimum or maximum diameter, is met. inhouse RoutingConditions is a collection of RoutingCondition data, each of them typically represents routing information on one connector. inhouse The class is passed into the routing preference manager in order to retrieve an appropriate part. inhouse For example: inhouse RoutingConditions myConditions; inhouse myConditions.appendCondition( RoutingCondition(dDiameter) ); // The array must have a primary condition inhouse myConditions.appendCondition( RoutingCondition(dDiameter2) ); // The array may have more conditions inhouse ElementId myPart = pRPM->getMEPPartId(myGroupType, myConditions); Default destructor

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class RoutingConditions : IDisposable
Visual Basic
Public Class RoutingConditions _
    Implements IDisposable
Visual C++
public ref class RoutingConditions : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..RoutingConditions

See Also

RoutingConditions Members

RoutingConditions Members

[image] [image]