Revit 2013 API
IFCTypeInfo Members
IFCTypeInfo Class Constructors Methods Properties See Also Send Feedback

The IFCTypeInfo type exposes the following members.

Constructors

 | Name | Description
Public method | IFCTypeInfo | Constructs a new empty type info object.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the IFCTypeInfo
Public method | Get2DMapHandle | Gets the associated handle to a 2D IfcRepresentationMap for the type.
Public method | Get3DMapHandle | Gets the associated handle to a 3D IfcRepresentationMap for the type.
Public method | GetStyle | Gets the associated handle to an IfcTypeProduct for the type.
Public method | GetStyleTransform | Gets the transform between the coordinate system of the type and the coordinate system of the instance's location in the Revit model.
Public method | IsValid | Identifies if the object represents a valid type info.
Public method | Set2DMapHandle | Sets the associated handle to a 2D IfcRepresentationMap for the type.
Public method | Set3DMapHandle | Sets the associated handle to a 3D IfcRepresentationMap for the type.
Public method | SetStyle | Sets the associated handle to an IfcTypeProduct for the type.
Public method | SetStyleTransform | Sets the transform between the coordinate system of the type and the coordinate system of the instance's location in the Revit model.

Properties

 | Name | Description
Public property | MaterialId | The material id associated with this type.
Public property | ScaledArea | The area of the type's cross-section, scaled into the units of export.
Public property | ScaledDepth | The depth of the type, scaled into the units of export.
Public property | ScaledInnerPerimeter | The inner perimeter of the boundaries of the type's cross-section, scaled into the units of export.
Public property | ScaledOuterPerimeter | The outer perimeter of the boundaries of the type's cross-section, scaled into the units of export.

See Also

IFCTypeInfo Class
Autodesk.Revit.DB.IFC Namespace

IFCTypeInfo Constructor

[image]