Revit 2013 API
ScheduleFieldType Enumeration
See Also Send Feedback
The type of data displayed in a schedule field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013
Since: 2013

Syntax

C#
public enum ScheduleFieldType
Visual Basic
Public Enumeration ScheduleFieldType
Visual C++
public enum class ScheduleFieldType

Members

Member name | Description
Instance | An instance parameter of the scheduled elements. All shared parameters also use this type, regardless of whether they are instance or type parameters.
ElementType | A type parameter of the scheduled elements.
Count | The number of elements appearing on the schedule row.
ViewBased

A specialized type of field used for a few parameters whose displayed values can change based on the settings of the view:

  • ROOM_AREA and ROOM_PERIMETER in room and space schedules.
  • PROJECT_REVISION_REVISION_NUM in revision schedules.
  • KEYNOTE_NUMBER in keynote legends that are numbered by sheet.
Formula | A formula calculated from the values of other fields in the schedule.
Percentage | A value indicating what percent of the total of another field each element represents.
Room | A parameter of the room that a scheduled element belongs to.
FromRoom | A parameter of the room on the "from" side of a door or window.
ToRoom | A parameter of the room on the "to" side of a door or window.
ProjectInfo | A parameter of the Project Info element in the project that the scheduled element belongs to, which may be a linked file. Only allowed in schedules that include elements from linked files.
Material | In a material takeoff, a parameter of one of the materials of a scheduled element.
MaterialQuantity | In a material takeoff, a value representing how a particular material is used within a scheduled element. The parameter ID can be MATERIAL_AREA, MATERIAL_VOLUME, or MATERIAL_ASPAINT.
RevitLinkInstance | A parameter of the RevitLinkInstance that an element in a linked file belongs to. Currently RVT_LINK_INSTANCE_NAME is the only supported parameter. Only allowed in schedules that include elements from linked files.
RevitLinkType | A parameter of the RevitLinkType that an element in a linked file belongs to. Currently RVT_LINK_FILE_NAME_WITHOUT_EXT is the only supported parameter. Only allowed in schedules that include elements from linked files.
StructuralMaterial | A parameter of the structural material of a scheduled element.
Space | A parameter of the space that a scheduled element belongs to.

See Also

ScheduleFilter Class

[image]