Revit 2013 API
RoomTagTypeSet Members
RoomTagTypeSet Class Constructors Methods Properties See Also Send Feedback

The RoomTagTypeSet type exposes the following members.

Constructors

 | Name | Description
Public method | RoomTagTypeSet | Initializes a new instance of the RoomTagTypeSet class

Methods

 | Name | Description
Public method | Clear | Removes every room tag type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a room tag type within the set.
Public method | Erase | Removes a specified room tag type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | Insert | Insert the specified room tag type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | Size | Returns the number of room tag types that are in the set.

See Also

RoomTagTypeSet Class
Autodesk.Revit.DB.Architecture Namespace

RoomTagTypeSet Constructor

[image]