Revit 2013 API
ReinforcementSettings..::..GetReinforcementSettings Method
ReinforcementSettings Class See Also Send Feedback
Obtains the ReinforcementSettings object for the specified project document.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static ReinforcementSettings GetReinforcementSettings(
    Document doc
)
Visual Basic
Public Shared Function GetReinforcementSettings ( _
    doc As Document _
) As ReinforcementSettings
Visual C++
public:
static ReinforcementSettings^ GetReinforcementSettings(
    Document^ doc
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
A project document.

Return Value

The ReinforcementSettings object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | doc is not a project document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural.

See Also

ReinforcementSettings Class
Autodesk.Revit.DB.Structure Namespace

ReinforcementSettings Properties

[image] [image]