Revit 2013 API
ComboBox Members
ComboBox Class Methods Properties Events See Also Send Feedback

The ComboBox type exposes the following members.

Methods

 | Name | Description
Public method | AddItem | Adds a new item to the ComboBox.
Public method | AddItems | Adds a new items to the ComboBox.
Public method | AddSeparator | Adds a separator to the drop-down list.
Public method | GetItems | Gets the copy of a collection of the ComboBoxMembers assigned to the ComboBox.

Properties

 | Name | Description
Public property | Current | Gets or sets the current checked ComboBox member of the ComboBox.
Public property | Image | The image shown on the ComboBox.

Events

 | Name | Description
Public event | CurrentChanged | Subscribe to this event to be notified when the current item of the ComboBox is changed.
Public event | DropDownClosed | Subscribe to this event to be notified when the drop-down of the ComboBox is closed.
Public event | DropDownOpened | Subscribe to this event to be notified when the drop-down of the ComboBox is opened.

See Also

ComboBox Class
Autodesk.Revit.UI Namespace

ComboBox Methods

[image] [image]