Revit 2013 API
TextNoteTypeSet Members
TextNoteTypeSet Class Constructors Methods Properties See Also Send Feedback

The TextNoteTypeSet type exposes the following members.

Constructors

 | Name | Description
Public method | TextNoteTypeSet | Initializes a new instance of the TextNoteTypeSet class

Methods

 | Name | Description
Public method | Clear | Removes every textnote type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a textnote type within the set.
Public method | Erase | Removes a specified textnote type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | Insert | Insert the specified textnote type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | Size | Returns the number of textnote types that are in the set.

See Also

TextNoteTypeSet Class

TextNoteTypeSet Constructor

[image]