Revit 2013 API
Railing Methods
Railing Class See Also Send Feedback

The Railing type exposes the following members.

Methods

 | Name | Description
 | Create | Automatically creates new railings with the specified railing type on all sides of a stairs element.
Public method | Flip | Flips the railing.
Public method | GetHandRails | Get all the handrails of the railing.
Public method | GetPath | Gets the railing path.
 | IsValidHostForNewRailing | Checks whether new railing can be created and placed on the specified host.
Public method | RemoveHost | Removes the association between the railing and its host.
Public method | Reset | Resets the railing to the default one that the system generates.

See Also

Railing Class
Autodesk.Revit.DB.Architecture Namespace

Create Method

[image]