Revit 2013 API
PathReinforcement..::..Curves Property
PathReinforcement Class Example See Also Send Feedback
Retrieves the array of curves forming the boundary of the Path Reinforcement.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This property is obsolete in Revit 2013. Call GetCurveElementIds() instead.")]
public ElementArray Curves { get; }
Visual Basic
<ObsoleteAttribute("This property is obsolete in Revit 2013. Call GetCurveElementIds() instead.")> _
Public ReadOnly Property Curves As ElementArray
    Get
Visual C++
[ObsoleteAttribute(L"This property is obsolete in Revit 2013. Call GetCurveElementIds() instead.")]
public:
property ElementArray^ Curves {
    ElementArray^ get ();
}

Remarks

Each element in the array is of type ModelCurve.

Examples

CopyC#
private void Getinfo_PathReinforcementCurve(PathReinforcement pathReinforcement)
{
    string message = "Path Reinforcement Curves : ";

    // Get path reinforcement curves by iterating the Curves property
    foreach (Autodesk.Revit.DB.Element ii in pathReinforcement.Curves)
    {
        ModelCurve pathReinforcementCurve = ii as ModelCurve;
        if (null == pathReinforcementCurve)
        {
            continue;
        }

        Autodesk.Revit.DB.Curve curve = pathReinforcementCurve.GeometryCurve;

        // Get curve start point
        message += "\nCurve start point:(" + curve.get_EndPoint(0).X + ", "
            + curve.get_EndPoint(0).Y + ", " + curve.get_EndPoint(0).Z + ")";
        // Get curve end point
        message += "; Curve end point:(" + curve.get_EndPoint(1).X + ", "
            + curve.get_EndPoint(1).Y + ", " + curve.get_EndPoint(1).Z + ")";

    }
    TaskDialog.Show("Revit",message);

}
CopyVB.NET
Private Sub Getinfo_PathReinforcementCurve(ByVal pathReinforcement As Autodesk.Revit.DB.Structure.PathReinforcement)
    Dim message As String = "Path Reinforcement Curves : "

    ' Get path reinforcement curves by iterating the Curves property
    For Each ii As Autodesk.Revit.DB.Element In pathReinforcement.Curves
        Dim pathReinforcementCurve As ModelCurve = TryCast(ii, ModelCurve)
        If pathReinforcementCurve Is Nothing Then
            Continue For
        End If

        Dim curve As Autodesk.Revit.DB.Curve = pathReinforcementCurve.GeometryCurve

        ' Get curve start point
        message += vbLf & "Curve start point:(" + curve.EndPoint(0).X + ", " + curve.EndPoint(0).Y + ", " + curve.EndPoint(0).Z + ")"
        ' Get curve end point

        message += "; Curve end point:(" + curve.EndPoint(1).X + ", " + curve.EndPoint(1).Y + ", " + curve.EndPoint(1).Z + ")"
    Next
    TaskDialog.Show("Revit", message)

End Sub

See Also

PathReinforcement Class
Autodesk.Revit.DB.Structure Namespace

NumBarDescriptions Property

[image]