Revit 2013 API
ExporterIFCUtils..::..CreateProjectLevelGUID Method
ExporterIFCUtils Class See Also Send Feedback
Creates a GUID from Revit project for given GUIDType.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static string CreateProjectLevelGUID(
    Document document,
    IFCProjectLevelGUIDType guidType
)
Visual Basic
Public Shared Function CreateProjectLevelGUID ( _
    document As Document, _
    guidType As IFCProjectLevelGUIDType _
) As String
Visual C++
public:
static String^ CreateProjectLevelGUID(
    Document^ document,
    IFCProjectLevelGUIDType guidType
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
guidType
Type: Autodesk.Revit.DB.IFC..::..IFCProjectLevelGUIDType
The GUID type.

Return Value

The guid string.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace

CreateSubElementGUID Method

[image]