Revit 2013 API
ExternalDefinition Class
Members Example See Also Send Feedback
The ExternalDefinition object adds properties specific to Autodesk Revit shared parameter definitions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class ExternalDefinition : Definition
Visual Basic
Public Class ExternalDefinition _
    Inherits Definition
Visual C++
public ref class ExternalDefinition : public Definition

Remarks

The ExternalDefinition object can be created by a definition Group object from a shared parameters file. External parameter definition must belong to a Group which is nothing more than a collection of shared parameter definitions. The following process should be followed to add a parameter to an element: Open the shared parameters file, via the Application.OpenSharedParameterFile method. Access an existing or create a new group, via the DefinitionFile.Groups property. Access an existing or create a new external parameter definition, via the DefinitionGroup.Definitions property. Create a new Binding object with the categories to which the parameter will be bound using an InstanceBinding or a TypeBinding object. Finally add the binding and definition to the document using the Document.ParameterBindings object.

Examples

CopyC#
private void ReadEditExternalParam(DefinitionFile file)
{
    // get ExternalDefinition from shared parameter file
    DefinitionGroups myGroups = file.Groups;
    DefinitionGroup myGroup = myGroups.get_Item("MyGroup");
    if (null == myGroup)
        return;

    Definitions myDefinitions = myGroup.Definitions;
    ExternalDefinition myExtDef =
        myDefinitions.get_Item("MyParam") as ExternalDefinition;
    if (null == myExtDef)
        return;

    StringBuilder strBuilder = new StringBuilder();
    // iterate every property of the ExternalDefinition
    strBuilder.AppendLine("GUID: " + myExtDef.GUID.ToString())
        .AppendLine("Name: " + myExtDef.Name)
        .AppendLine("OwnerGroup: " + myExtDef.OwnerGroup.Name)
        .AppendLine("Parameter Group" + myExtDef.ParameterGroup.ToString())
        .AppendLine("Parameter Type" + myExtDef.ParameterType.ToString())
        .AppendLine("Is Visible: " + myExtDef.Visible.ToString());

    TaskDialog.Show("Revit",strBuilder.ToString());

    // change the OwnerGroup of the ExternalDefinition
    myExtDef.OwnerGroup = myGroups.get_Item("AnotherGroup");
}
CopyVB.NET
Private Sub ReadEditExternalParam(ByVal file As DefinitionFile)
    ' get ExternalDefinition from shared parameter file
    Dim myGroups As DefinitionGroups = file.Groups
    Dim myGroup As DefinitionGroup = myGroups.Item("MyGroup")
    If myGroup Is Nothing Then
        Return
    End If

    Dim myDefinitions As Definitions = myGroup.Definitions
    Dim myExtDef As ExternalDefinition = TryCast(myDefinitions.Item("MyParam"), ExternalDefinition)
    If myExtDef Is Nothing Then
        Return
    End If

    Dim strBuilder As New StringBuilder()
    ' iterate every property of the ExternalDefinition
    strBuilder.AppendLine("GUID: " + myExtDef.GUID.ToString()).AppendLine("Name: " + myExtDef.Name).AppendLine("OwnerGroup: " + myExtDef.OwnerGroup.Name).AppendLine("Parameter Group" + myExtDef.ParameterGroup.ToString()).AppendLine("Parameter Type" + myExtDef.ParameterType.ToString()).AppendLine("Is Visible: " + myExtDef.Visible.ToString())

    TaskDialog.Show("Revit", strBuilder.ToString())

    ' change the OwnerGroup of the ExternalDefinition
    myExtDef.OwnerGroup = myGroups.Item("AnotherGroup")
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..Definition
Autodesk.Revit.DB..::..ExternalDefinition

See Also

ExternalDefinition Members

ExternalDefinition Members

[image] [image]