Revit 2013 API
StairsPath..::..Create Method
StairsPath Class See Also Send Feedback
Creates a new stairs path for the specified stairs with the specified stairs path type only in the plan view.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static StairsPath Create(
    Document document,
    LinkElementId stairsId,
    ElementId typeId,
    ElementId planViewId
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    stairsId As LinkElementId, _
    typeId As ElementId, _
    planViewId As ElementId _
) As StairsPath
Visual C++
public:
static StairsPath^ Create(
    Document^ document,
    LinkElementId^ stairsId,
    ElementId^ typeId,
    ElementId^ planViewId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
stairsId
Type: Autodesk.Revit.DB..::..LinkElementId
The id of the stairs element either in the host document or in a linked document.
typeId
Type: Autodesk.Revit.DB..::..ElementId
The type of stairs path.
planViewId
Type: Autodesk.Revit.DB..::..ElementId
The plan view in which the stairs path will be shown.

Return Value

The new stairs path.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The stairsId is not a valid stairs. -or- The typeId is not a valid stairs path type. -or- The planViewId is not a valid plan view. -or- The stairsId already has a stairs path. -or- The stairsId is not visible in planViewId.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

StairsPath Class
Autodesk.Revit.DB.Architecture Namespace

StairsPath Properties

[image] [image]