Revit 2013 API
UpdaterRegistry..::..RegisterUpdater Method (IUpdater, Boolean)
UpdaterRegistry Class See Also Send Feedback
Registers an updater on an application level

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static void RegisterUpdater(
    IUpdater updater,
    bool isOptional
)
Visual Basic
Public Shared Sub RegisterUpdater ( _
    updater As IUpdater, _
    isOptional As Boolean _
)
Visual C++
public:
static void RegisterUpdater(
    IUpdater^ updater,
    bool isOptional
)

Parameters

updater
Type: Autodesk.Revit.DB..::..IUpdater
Updater to be registered
isOptional
Type: System..::..Boolean
Kind of the updater

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Updater's Id is not valid.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | updater's owner AddIn does not match currently active AddIn i.e. IUpdater::getUpdaterId()::getAddInId() != add-in's addInId field in the manifest file -or- updater is already registered on the application level -or- RegisterUpdater called while executing an updater.

See Also

UpdaterRegistry Class
RegisterUpdater Overload

RegisterUpdater Method (IUpdater, Document, Boolean)

[image]