Revit 2013 API
PipeConnector..::..LinkedConnector Property
PipeConnector Class See Also Send Feedback
The linked pipe connector.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This property is obsolete in Revit 2013.  Please call GetLinkedConnectorElement and SetLinkedConnectorElement() instead.")]
public PipeConnector LinkedConnector { get; set; }
Visual Basic
<ObsoleteAttribute("This property is obsolete in Revit 2013.  Please call GetLinkedConnectorElement and SetLinkedConnectorElement() instead.")> _
Public Property LinkedConnector As PipeConnector
    Get
    Set
Visual C++
[ObsoleteAttribute(L"This property is obsolete in Revit 2013.  Please call GetLinkedConnectorElement and SetLinkedConnectorElement() instead.")]
public:
property PipeConnector^ LinkedConnector {
    PipeConnector^ get ();
    void set (PipeConnector^ value);
}

Remarks

Get this property to acquire the current linked pipe connector. If the property is nullNothingnullptra null reference (Nothing in Visual Basic), the connector has no link. Set this property to link this connector to another pipe connector. Set it to nullNothingnullptra null reference (Nothing in Visual Basic) to remove the link.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the connector to link to is the same as the connector being linked to.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown if the document is not modifiable or document regeneration fails.

See Also

PipeConnector Class
Autodesk.Revit.DB.Plumbing Namespace

Parameter Property

[image] [image]