Revit 2013 API
AssetPropertyType Enumeration
See Also Send Feedback
An enumerated to list AssetProperty Types in Revit.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum AssetPropertyType
Visual Basic
Public Enumeration AssetPropertyType
Visual C++
public enum class AssetPropertyType

Members

Member name | Description
APT_Unknown |
APT_Properties |
APT_Boolean |
APT_Enum |
APT_Integer |
APT_Float |
APT_Double | AssetPropertyDouble.
APT_DoubleArray2d | AssetPropertyDoubleArray2d.
APT_DoubleArray3d | AssetPropertyDoubleArray3d.
APT_DoubleArray4d | AssetPropertyDoubleArray4d.
APT_Double44 | AssetPropertyDoubleMatrix44.
APT_String |
APT_Time |
APT_Distance |
APT_Asset |
APT_Reference |
APT_Last |

See Also

Autodesk.Revit.Utility Namespace

AssetSet Class

[image]