Revit 2013 API
WorksetTable..::..GetActiveWorksetId Method
WorksetTable Class Example See Also Send Feedback
Returns the active workset's WorksetId.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public WorksetId GetActiveWorksetId()
Visual Basic
Public Function GetActiveWorksetId As WorksetId
Visual C++
public:
WorksetId^ GetActiveWorksetId()

Return Value

WorksetId of the active workset.

Examples

CopyC#
public Workset GetActiveWorkset(Document doc)
{
    // Get the workset table from the document
    WorksetTable worksetTable = doc.GetWorksetTable();
    // Get the Id of the active workset
    WorksetId activeId = worksetTable.GetActiveWorksetId();
    // Find the workset with that Id
    Workset workset = worksetTable.GetWorkset(activeId);
    return workset;
}

See Also

WorksetTable Class

GetWorkset Method

[image] [image]