Revit 2013 API
WallSweepInfo Constructor (Boolean, WallSweepType)
WallSweepInfo Class See Also Send Feedback
Constructs a new WallSweepInfo instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public WallSweepInfo(
    bool fixed,
    WallSweepType type
)
Visual Basic
Public Sub New ( _
    fixed As Boolean, _
    type As WallSweepType _
)
Visual C++
public:
WallSweepInfo(
    bool fixed,
    WallSweepType type
)

Parameters

fixed
Type: System..::..Boolean
True if the WallSweepInfo should be fixed (suitable for use in CompoundStructure.AddWallSweep()). False if the WallSweepInfo should be suitable for use in standalone wall sweep or reveal elements.
type
Type: Autodesk.Revit.DB..::..WallSweepType
The type of the WallSweepInfo instance.

See Also

WallSweepInfo Class
WallSweepInfo Overload

WallSweepInfo Constructor (WallSweepType, Boolean)

[image]