Revit 2013 API
PartUtils..::..AreElementsValidIntersectingReferences Method
PartUtils Class See Also Send Feedback
Identifies if provided members are valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2013; use PartMakerMethodToDivideVolumes.AreElementsValidIntersectingReferences() instead.")]
public static bool AreElementsValidIntersectingReferences(
    Document document,
    ICollection<ElementId> elementIds
)
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2013; use PartMakerMethodToDivideVolumes.AreElementsValidIntersectingReferences() instead.")> _
Public Shared Function AreElementsValidIntersectingReferences ( _
    document As Document, _
    elementIds As ICollection(Of ElementId) _
) As Boolean
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2013; use PartMakerMethodToDivideVolumes.AreElementsValidIntersectingReferences() instead.")]
public:
static bool AreElementsValidIntersectingReferences(
    Document^ document,
    ICollection<ElementId^>^ elementIds
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
elementIds
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
Element ids to be tested for validity for intersecting references.

Return Value

True if all references are valid, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PartUtils Class

ArePartsValidForDivide Method

[image]