Revit 2013 API
RebarShapeVertex Properties
RebarShapeVertex Class See Also Send Feedback

The RebarShapeVertex type exposes the following members.

Properties

 | Name | Description
Public property | BendAngle | The range of permissible angles at this bend.
Public property | Turn | The sense of the turn: 1 for a left turn, -1 for a right turn. 0 is permissible for the first and last vertex, since they do not correspond to bends. (0 is also the default, so the Turn property must be set on each internal vertex before the RebarShapeDefinitionBySegments is used.)

See Also

RebarShapeVertex Class
Autodesk.Revit.DB.Structure Namespace

BendAngle Property

[image]