Revit 2013 API
IFCData..::..SetTypeList Method
IFCData Class See Also Send Feedback
Sets the corresponding IFC type by its type list name.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetTypeList(
    IList<string> typeList
)
Visual Basic
Public Sub SetTypeList ( _
    typeList As IList(Of String) _
)
Visual C++
public:
void SetTypeList(
    IList<String^>^ typeList
)

Parameters

typeList
Type: System.Collections.Generic..::..IList<(Of <(<'String>)>)>
The strings represent the name.

Remarks

This sets the IFC type represented by a string list. For example, DIMENSION(DIAMETER(INCH(5.0))). It's primitive type is double and the value is 5.0. Its IFC type is DIMENSION/DIAMETER/INCH. The string list represents the type is "DIMENSION"-"DIAMETER"-"INCH".

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCData Class
Autodesk.Revit.DB.IFC Namespace

IFCData Operators

[image] [image]