Revit 2013 API
StructuralInstanceUsageFilter Constructor (StructuralInstanceUsage)
StructuralInstanceUsageFilter Class See Also Send Feedback
Constructs a new instance of a filter to match structural family instances (typically columns, beams, or braces) of the given structural usage.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public StructuralInstanceUsageFilter(
    StructuralInstanceUsage structuralUsage
)
Visual Basic
Public Sub New ( _
    structuralUsage As StructuralInstanceUsage _
)
Visual C++
public:
StructuralInstanceUsageFilter(
    StructuralInstanceUsage structuralUsage
)

Parameters

structuralUsage
Type: Autodesk.Revit.DB.Structure..::..StructuralInstanceUsage
The family instance structural usage.

See Also

StructuralInstanceUsageFilter Class
StructuralInstanceUsageFilter Overload
Autodesk.Revit.DB.Structure Namespace

StructuralInstanceUsageFilter Constructor (StructuralInstanceUsage, Boolean)

[image]