Revit 2013 API
EnergyAnalysisOpening Properties
EnergyAnalysisOpening Class See Also Send Feedback

The EnergyAnalysisOpening type exposes the following members.

Properties

 | Name | Description
Public property | Corner | The lower-left coordinate for the analytical rectangular geometry viewed from outside.
Public property | Height | The height of the analytical rectangular geometry.
Public property | Id | The unique identifier for the opening.
Public property | Name | The unique name identifier for the opening.
Public property | OpeningType | The analytical opening type.
Public property | OriginatingElementDescription | The description for the originating Revit element.
Public property | OriginatingElementId | The element id for the originating Revit element.
Public property | Type | The gbXML opening type attribute.
Public property | Width | The width of the analytical rectangular geometry.

See Also

EnergyAnalysisOpening Class
Autodesk.Revit.DB.Analysis Namespace

Corner Property

[image]