Revit 2013 API
Wall Properties
Wall Class See Also Send Feedback

The Wall type exposes the following members.

Properties

 | Name | Description
Public property | CurtainGrid | Get the grid object of a curtain wall
Public property | Flipped | Property to test whether the wall orientation is flipped.
Public property | Orientation | The normal vector projected from the exterior side of the wall.
Public property | StructuralUsage | Retrieves or changes the wall's designated structural usage.
Public property | WallType | Retrieves or changes the type of the wall.
Public property | Width | Get the overall thickness of the wall.

See Also

Wall Class

CurtainGrid Property

[image]