Revit 2013 API
IFCStairRampContainerInfo..::..AppendStairRampContainerInfo Method
IFCStairRampContainerInfo Class See Also Send Feedback
Appends stair/ramp containment information to an existing entry.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static void AppendStairRampContainerInfo(
    ExporterIFC exporterIFC,
    ElementId stairId,
    IFCStairRampContainerInfo info
)
Visual Basic
Public Shared Sub AppendStairRampContainerInfo ( _
    exporterIFC As ExporterIFC, _
    stairId As ElementId, _
    info As IFCStairRampContainerInfo _
)
Visual C++
public:
static void AppendStairRampContainerInfo(
    ExporterIFC^ exporterIFC,
    ElementId^ stairId,
    IFCStairRampContainerInfo^ info
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
stairId
Type: Autodesk.Revit.DB..::..ElementId
The stairs id.
info
Type: Autodesk.Revit.DB.IFC..::..IFCStairRampContainerInfo
The containment information.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCStairRampContainerInfo Class
Autodesk.Revit.DB.IFC Namespace

ContainsStairOrRamp Method

[image]