Revit 2013 API
RevitLinkLoadResult Members
RevitLinkLoadResult Class Constructors Methods Properties See Also Send Feedback

The RevitLinkLoadResult type exposes the following members.

Constructors

 | Name | Description
Public method | RevitLinkLoadResult | Initializes a new instance of the RevitLinkLoadResult class

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the RevitLinkLoadResult
Public method | GetCentralModelName | Gets the central model's name. If the link is not workshared, this returns an empty FilePath. If the link is itself a central model, this returns the link's name.
Public method | GetModelName | Gets the name of the model.
Public method | GetNestedLinkLoadResults | Gets the results for this link's nested links.
Public method | GetParentModelName | Returns the name of the parent of the linked model, or an empty FilePath if the link is a top-level link.

Properties

 | Name | Description
Public property | ElementId | The id of the created or loaded linked model.
Public property | IsCircularLink | True if these results are part of a link cycle.
Public property | IsNested | True if these results represent a nested link; false otherwise.
Public property | LoadResult | Holds the results of creating or loading a link. Results can be LinkLoadResultType.LinkLoaded for success, or a variety of errors. See LinkLoadResultType for the full list.

See Also

RevitLinkLoadResult Class

RevitLinkLoadResult Constructor

[image]