Revit 2013 API
ExporterIFCUtils..::..AddOpeningsToElement Method
ExporterIFCUtils Class See Also Send Feedback
Adds the openings from the element as separate IfcElements related to the element.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static void AddOpeningsToElement(
    ExporterIFC exporterIFC,
    IFCAnyHandle elementHandle,
    Element element,
    double scaledWidth,
    IFCRange range,
    IFCPlacementSetter setter,
    IFCAnyHandle localPlacement,
    IFCProductWrapper localWrapper
)
Visual Basic
Public Shared Sub AddOpeningsToElement ( _
    exporterIFC As ExporterIFC, _
    elementHandle As IFCAnyHandle, _
    element As Element, _
    scaledWidth As Double, _
    range As IFCRange, _
    setter As IFCPlacementSetter, _
    localPlacement As IFCAnyHandle, _
    localWrapper As IFCProductWrapper _
)
Visual C++
public:
static void AddOpeningsToElement(
    ExporterIFC^ exporterIFC,
    IFCAnyHandle^ elementHandle,
    Element^ element,
    double scaledWidth,
    IFCRange^ range,
    IFCPlacementSetter^ setter,
    IFCAnyHandle^ localPlacement,
    IFCProductWrapper^ localWrapper
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
elementHandle
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The element handle.
element
Type: Autodesk.Revit.DB..::..Element
The element.
scaledWidth
Type: System..::..Double
The width of the element, scaled in the units of export.
range
Type: Autodesk.Revit.DB.IFC..::..IFCRange
The range. This consists of two double values representing the height in Z at the start and the end of the range. If the values are identical the entire element is used.
setter
Type: Autodesk.Revit.DB.IFC..::..IFCPlacementSetter
The placement setter.
localPlacement
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The local placement for the element.
localWrapper
Type: Autodesk.Revit.DB.IFC..::..IFCProductWrapper
The product wrapper.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace

AddValueString Method

[image]