Revit 2013 API
ViewSheet..::..ConvertToRealSheet Method
ViewSheet Class See Also Send Feedback
Convert a placeholder sheet to a real one with an optional titleblock

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void ConvertToRealSheet(
    ElementId titleblockElementId
)
Visual Basic
Public Sub ConvertToRealSheet ( _
    titleblockElementId As ElementId _
)
Visual C++
public:
void ConvertToRealSheet(
    ElementId^ titleblockElementId
)

Parameters

titleblockElementId
Type: Autodesk.Revit.DB..::..ElementId
The type id of titleblock for the real sheet. If it is nullNothingnullptra null reference (Nothing in Visual Basic) or an InvalidElementId, no titleblock will be created.

Remarks

This method should only be called on a placeholder sheet, otherwise exception will occur.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | If titleblockElementId is a valid type id but not a titleblock symbol id.
Autodesk.Revit.Exceptions..::..InvalidOperationException | If the method is not called on a placeholder sheet or the input titleblock could not be applied.

See Also

ViewSheet Class

Create Method

[image]