Revit 2013 API
ItemFactoryBase..::..NewViewPlan Method
ItemFactoryBase Class Example See Also Send Feedback
Creates a plan view based on the specified level.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This method is Obsolete in Revit 2013.  Call ViewPlan.Create() instead.")]
public ViewPlan NewViewPlan(
    string pViewName,
    Level pLevel,
    ViewPlanType viewType
)
Visual Basic
<ObsoleteAttribute("This method is Obsolete in Revit 2013.  Call ViewPlan.Create() instead.")> _
Public Function NewViewPlan ( _
    pViewName As String, _
    pLevel As Level, _
    viewType As ViewPlanType _
) As ViewPlan
Visual C++
[ObsoleteAttribute(L"This method is Obsolete in Revit 2013.  Call ViewPlan.Create() instead.")]
public:
ViewPlan^ NewViewPlan(
    String^ pViewName,
    Level^ pLevel,
    ViewPlanType viewType
)

Parameters

pViewName
Type: System..::..String
The name for the new plan view, must be unique or nullNothingnullptra null reference (Nothing in Visual Basic).
pLevel
Type: Autodesk.Revit.DB..::..Level
The level on which the plan view is to be associated.
viewType
Type: Autodesk.Revit.DB..::..ViewPlanType
The type of plan view to be created.

Return Value

if successful, a new plan view object within the project, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

if pViewName is nullNothingnullptra null reference (Nothing in Visual Basic), the pLevel's name will be used as the new plan view's name.

Examples

CopyC#
// Create a Level and a Floor Plan based on it
 double elevation = 10.0;
 Level level1 = document.Create.NewLevel(elevation);
 ViewPlan floorView = document.Create.NewViewPlan(null, level1, ViewPlanType.FloorPlan);

 // Create another Level and a Ceiling Plan based on it
 elevation += 10.0;
 Level level2 = document.Create.NewLevel(elevation);
 ViewPlan ceilingView = document.Create.NewViewPlan(null, level2, ViewPlanType.CeilingPlan);
CopyVB.NET
' Create a Level and a Floor Plan based on it
Dim elevation As Double = 10
Dim level1 As Level = document.Create.NewLevel(elevation)
Dim floorView As ViewPlan = document.Create.NewViewPlan(Nothing, level1, ViewPlanType.FloorPlan)

' Create another Level and a Ceiling Plan based on it
elevation += 10
Dim level2 As Level = document.Create.NewLevel(elevation)
Dim ceilingView As ViewPlan = document.Create.NewViewPlan(Nothing, level2, ViewPlanType.CeilingPlan)

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | If the name is not unique

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace

NewViewSection Method

[image]