Revit 2013 API
Document..::..RebarBarTypes Property
Document Class See Also Send Feedback
Retrieves an object that contains all the rebar bar types that are currently loaded into the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public RebarBarTypeSet RebarBarTypes { get; }
Visual Basic
Public ReadOnly Property RebarBarTypes As RebarBarTypeSet
    Get
Visual C++
public:
property RebarBarTypeSet^ RebarBarTypes {
    RebarBarTypeSet^ get ();
}

Remarks

This property returns a set of rebarbartype objects. These objects can be used change the type of a rebar from one type to another.

See Also

Document Class

RebarCoverTypes Property

[image]