Revit 2013 API
ElectricalSystem Properties
ElectricalSystem Class See Also Send Feedback

The ElectricalSystem type exposes the following members.

Properties

 | Name | Description
Public property | ApparentCurrent | Returns the ApparentCurrent value of the Electrical System.
Public property | ApparentCurrentPhaseA | Returns the ApparentCurrentPhaseA value of the Electrical System.
Public property | ApparentCurrentPhaseB | Returns the ApparentCurrentPhaseB value of the Electrical System.
Public property | ApparentCurrentPhaseC | Returns the ApparentCurrentPhaseC value of the Electrical System.
Public property | ApparentLoad | Returns the ApparentLoad value of the Electrical System.
Public property | ApparentLoadPhaseA | Returns the ApparentLoadPhaseA value of the Electrical System.
Public property | ApparentLoadPhaseB | Returns the ApparentLoadPhaseB value of the Electrical System.
Public property | ApparentLoadPhaseC | Returns the ApparentLoadPhaseC value of the Electrical System.
Public property | BalancedLoad | Reports whether the BalancedLoad is on or off.
Public property | CircuitNumber | Returns the CircuitNumber of the Electrical System.
Public property | CircuitType | Get the circuit type of the Electrical System.
Public property | GroundConductorsNumber | Returns the GroundConductors Number of the Electrical System.
Public property | HotConductorsNumber | Returns the HotConductors Number of the Electrical System.
Public property | Length | Returns the Length value of the Electrical System.
Public property | LoadClassifications | Returns the LoadClassifications used in the Electrical System.
Public property | LoadName | Get/Set the LoadName of the Electrical System.
Public property | Name | Returns the Name of the Electrical System. (Overrides Element..::..Name.)
Public property | NeutralConductorsNumber | Returns the NeutralConductors Number of the Electrical System.
Public property | PanelName | Returns the Panel name of the Electrical System.
Public property | PolesNumber | Returns the Poles Number of the Electrical System.
Public property | PowerFactor | Returns the PowerFactor value of the Electrical System.
Public property | PowerFactorState | Returns the PowerFactorState type of the Electrical System.
Public property | Rating | Get/Set the Rating value of the Electrical System.
Public property | RunsNumber | Returns the Runs Number of the Electrical System.
Public property | SystemType | Returns the Electrical System Type of the Electrical System.
Public property | TrueCurrent | Returns the TrueCurrent value of the Electrical System.
Public property | TrueCurrentPhaseA | Returns the TrueCurrentPhaseA value of the Electrical System.
Public property | TrueCurrentPhaseB | Returns the TrueCurrentPhaseB value of the Electrical System.
Public property | TrueCurrentPhaseC | Returns the TrueCurrentPhaseC value of the Electrical System.
Public property | TrueLoad | Returns the TrueLoad value of the Electrical System.
Public property | TrueLoadPhaseA | Returns the TrueLoadPhaseA value of the Electrical System.
Public property | TrueLoadPhaseB | Returns the TrueLoadPhaseB value of the Electrical System.
Public property | TrueLoadPhaseC | Returns the TrueLoadPhaseC value of the Electrical System.
Public property | Voltage | Returns the Voltage value of the Electrical System.
Public property | VoltageDrop | Returns the VoltageDrop value of the Electrical System.
Public property | WireSizeString | Returns the WireSize as a String of the Electrical System.
Public property | WireType | Get/Set the wire type of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace

ApparentCurrent Property

[image]