Revit 2013 API
AnalyticalLinkType..::..IsValidAnalyticalFixityState Method
AnalyticalLinkType Class See Also Send Feedback
Returns whether the input fixity state is valid for Analytical Link Type parameters.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static bool IsValidAnalyticalFixityState(
    AnalyticalFixityState fixityState
)
Visual Basic
Public Shared Function IsValidAnalyticalFixityState ( _
    fixityState As AnalyticalFixityState _
) As Boolean
Visual C++
public:
static bool IsValidAnalyticalFixityState(
    AnalyticalFixityState fixityState
)

Parameters

fixityState
Type: Autodesk.Revit.DB.Structure..::..AnalyticalFixityState
The fixity state value to check.

Return Value

True if valid.

See Also

AnalyticalLinkType Class
Autodesk.Revit.DB.Structure Namespace

AnalyticalLinkType Properties

[image] [image]