Revit 2013 API
Application..::..OpenIFCDocument Method
Application Class See Also Send Feedback
Opens an IFC document from disk.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Document OpenIFCDocument(
    string fileName
)
Visual Basic
Public Overridable Function OpenIFCDocument ( _
    fileName As String _
) As Document
Visual C++
public:
virtual Document^ OpenIFCDocument(
    String^ fileName
)

Parameters

fileName
Type: System..::..String
The IFC file to be opened.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | If nullNothingnullptra null reference (Nothing in Visual Basic) is passed as 'fileName'.
Autodesk.Revit.Exceptions..::..ArgumentException | If 'fileName' is an empty string.
Autodesk.Revit.Exceptions..::..FileArgumentNotFoundException | If the file specified by 'fileName' cannot be found.
Autodesk.Revit.Exceptions..::..InvalidOperationException | If Revit is missing document templates or if the file cannot be opened.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace

OpenSharedParameterFile Method

[image]