Revit 2013 API
Document..::..NewRoom Method (Phase)
Document Class See Also Send Feedback
Creates a new unplaced room and with an assigned phase.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Room NewRoom(
    Phase phase
)
Visual Basic
Public Function NewRoom ( _
    phase As Phase _
) As Room
Visual C++
public:
Room^ NewRoom(
    Phase^ phase
)

Parameters

phase
Type: Autodesk.Revit.DB..::..Phase
The phase in which the room is to exist.

Return Value

If successful the new room , otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Document Class
NewRoom Overload
Autodesk.Revit.Creation Namespace

NewRoom Method (Level, UV)

[image]