Revit 2013 API
BoundingBoxXYZ Members
BoundingBoxXYZ Class Constructors Methods Properties See Also Send Feedback

The BoundingBoxXYZ type exposes the following members.

Constructors

 | Name | Description
Public method | BoundingBoxXYZ | Initializes a new instance of the BoundingBoxXYZ class

Methods

 | Name | Description

Properties

 | Name | Description
Public property | BoundEnabled | Indexed access for loops.
Public property | Bounds | Indexed access for loops. Use 0 for Min and 1 for Max.
Public property | Enabled | Defines whether bounding box is turned on.
Public property | Max | Maximum coordinates (upper-right-front corner of the box).
Public property | MaxEnabled | Defines whether the maximum bound is active for given dimension.
Public property | Min | Minimum coordinates (lower-left-rear corner of the box).
Public property | MinEnabled | Defines whether the minimum bound is active for given dimension.
Public property | Transform | The transform FROM the coordinate space of the box TO the model space.

See Also

BoundingBoxXYZ Class

BoundingBoxXYZ Constructor

[image]