Revit 2013 API
RoutingCondition..::..Diameter Property
RoutingCondition Class See Also Send Feedback
The diameter of the segment or fitting specified for the routing condition. inhouse Returns zero for non-round profiles (not fully supported yet).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double Diameter { get; }
Visual Basic
Public ReadOnly Property Diameter As Double
    Get
Visual C++
public:
property double Diameter {
    double get ();
}

See Also

RoutingCondition Class

RoutingConditions Class

[image]