Revit 2013 API
DetailElementOrderUtils..::..SendBackward Method
DetailElementOrderUtils Class See Also Send Feedback
Moves the given detail instance one step closer to the back of all other detail instances in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static void SendBackward(
    Document pDocument,
    View pDBView,
    ElementId detailElementId
)
Visual Basic
Public Shared Sub SendBackward ( _
    pDocument As Document, _
    pDBView As View, _
    detailElementId As ElementId _
)
Visual C++
public:
static void SendBackward(
    Document^ pDocument,
    View^ pDBView,
    ElementId^ detailElementId
)

Parameters

pDocument
Type: Autodesk.Revit.DB..::..Document
The document.
pDBView
Type: Autodesk.Revit.DB..::..View
The view.
detailElementId
Type: Autodesk.Revit.DB..::..ElementId
The detail elementId

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The element detailElementId is not a detail element.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

DetailElementOrderUtils Class

SendToBack Method

[image]