Revit 2013 API
Reference Members
Reference Class Constructors Methods Properties See Also Send Feedback

The Reference type exposes the following members.

Constructors

 | Name | Description
Public method | Reference | Creates a Reference with the supplied element.

Methods

 | Name | Description
Public method | ConvertToStableRepresentation | Converts the reference to a stable String representation.
 | ParseFromStableRepresentation | Converts a stable String representation of a reference to a Reference object.

Properties

 | Name | Description
Public property | ElementId | The element id for this reference.
Public property | ElementReferenceType | The type of reference.
Public property | GlobalPoint | The position on which the reference is hit.
Public property | UVPoint | The UV parameters of the reference, if the reference contains a face.

See Also

Reference Class

Reference Constructor

[image]