Revit 2013 API
DuctConnector..::..LinkedConnector Property
DuctConnector Class See Also Send Feedback
The linked duct connector.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This property is obsolete in Revit 2013.  Please call GetLinkedConnectorElement and SetLinkedConnectorElement() instead.")]
public DuctConnector LinkedConnector { get; set; }
Visual Basic
<ObsoleteAttribute("This property is obsolete in Revit 2013.  Please call GetLinkedConnectorElement and SetLinkedConnectorElement() instead.")> _
Public Property LinkedConnector As DuctConnector
    Get
    Set
Visual C++
[ObsoleteAttribute(L"This property is obsolete in Revit 2013.  Please call GetLinkedConnectorElement and SetLinkedConnectorElement() instead.")]
public:
property DuctConnector^ LinkedConnector {
    DuctConnector^ get ();
    void set (DuctConnector^ value);
}

Remarks

Get this property to acquire the current linked duct connector. If the property is nullNothingnullptra null reference (Nothing in Visual Basic), the connector has no link. Set this property to link this connector to another duct connector. Set it to nullNothingnullptra null reference (Nothing in Visual Basic) to remove the link.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the connector to link to is the same as the connector being linked to.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown if the document is not modifiable or document regeneration fails.

See Also

DuctConnector Class
Autodesk.Revit.DB.Mechanical Namespace

Parameter Property

[image] [image]