Revit 2013 API
UIApplication..::..DoDragDrop Method (Object, IDropHandler)
UIApplication Class See Also Send Feedback
Initiates a drag and drop operation with a custom drop implementation.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static void DoDragDrop(
    Object dropData,
    IDropHandler handler
)
Visual Basic
Public Shared Sub DoDragDrop ( _
    dropData As Object, _
    handler As IDropHandler _
)
Visual C++
public:
static void DoDragDrop(
    Object^ dropData,
    IDropHandler^ handler
)

Parameters

dropData
Type: System..::..Object
Any arbitrary data to be passed to the drop handler when the drop occurs.
handler
Type: Autodesk.Revit.UI..::..IDropHandler
The handler to be executed when the drop occurs.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when dropData or handler is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

UIApplication Class
DoDragDrop Overload
Autodesk.Revit.UI Namespace

GetRibbonPanels Method

[image] [image]