Revit 2013 API
MechanicalUtils..::..ConnectDuctPlaceholdersAtCross Method (Document, Connector, Connector, Connector, Connector)
MechanicalUtils Class See Also Send Feedback
Connects placeholders that looks like Cross connection.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static bool ConnectDuctPlaceholdersAtCross(
    Document document,
    Connector connector1,
    Connector connector2,
    Connector connector3,
    Connector connector4
)
Visual Basic
Public Shared Function ConnectDuctPlaceholdersAtCross ( _
    document As Document, _
    connector1 As Connector, _
    connector2 As Connector, _
    connector3 As Connector, _
    connector4 As Connector _
) As Boolean
Visual C++
public:
static bool ConnectDuctPlaceholdersAtCross(
    Document^ document,
    Connector^ connector1,
    Connector^ connector2,
    Connector^ connector3,
    Connector^ connector4
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
connector1
Type: Autodesk.Revit.DB..::..Connector
The first end connector of placeholder to be connected to the second.
connector2
Type: Autodesk.Revit.DB..::..Connector
The second end connector of placeholder to be connected to the first.
connector3
Type: Autodesk.Revit.DB..::..Connector
The third end connector of placeholder to be connected to the forth.
connector4
Type: Autodesk.Revit.DB..::..Connector
The fourth end connector of placeholder to be connected to the third.

Return Value

True if connection succeeds, false otherwise.

Remarks

The placeholders may or may not have physical connection. However a) The ends of four connectors should intersect at same point; b) the first and second placeholders should be collinear each other; c) the third and fourth placeholders should be collinear each other and d) the third and fourth should have intersection with first or second placeholder. If connection fails, the placeholders cannot be physically connected.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The owner of connector is not duct placeholder. -or- The owners of connectors belong to different types of system. -or- The curves of connector1 and connector2 are not collinear or either the connecto1 or connector2 is not connector of curve end. -or- The curves of connector3 and connector4 are not collinear or either the connecto1 or connector2 is not connector of curve end.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

MechanicalUtils Class
ConnectDuctPlaceholdersAtCross Overload
Autodesk.Revit.DB.Mechanical Namespace

ConnectDuctPlaceholdersAtElbow Method

[image] [image]