Revit 2013 API
ExporterIFCUtils..::..GetRebarGeometry Method
ExporterIFCUtils Class See Also Send Feedback
Generates the geometry for a Rebar for a specific view. The filter view is allowed to be null, but no geometry will be generated if it is.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static GeometryElement GetRebarGeometry(
    Rebar rebar,
    View filterView
)
Visual Basic
Public Shared Function GetRebarGeometry ( _
    rebar As Rebar, _
    filterView As View _
) As GeometryElement
Visual C++
public:
static GeometryElement^ GetRebarGeometry(
    Rebar^ rebar,
    View^ filterView
)

Parameters

rebar
Type: Autodesk.Revit.DB.Structure..::..Rebar
The rebar element.
filterView
Type: Autodesk.Revit.DB..::..View
The view in which the geometry is generated.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace

GetRelativeLocalPlacementOffsetTransform Method

[image]