Revit 2013 API
View..::..AssociatedAssemblyInstanceId Property
View Class See Also Send Feedback
The Id of the assembly instance that owns the assembly view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementId AssociatedAssemblyInstanceId { get; }
Visual Basic
Public ReadOnly Property AssociatedAssemblyInstanceId As ElementId
    Get
Visual C++
public:
property ElementId^ AssociatedAssemblyInstanceId {
    ElementId^ get ();
}

Field Value

The assembly instance id, or InvalidElementId if the view is not an assembly view.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

View Class

CanBePrinted Property

[image]