Revit 2013 API
Duct Members
Duct Class Methods Properties See Also Send Feedback

The Duct type exposes the following members.

Methods

 | Name | Description
 | CreatePlaceholder | Creates a new placeholder duct.
 | IsDuctTypeId | Checks if given type is valid duct type.
 | IsLevelId | Checks if given element id is valid level element.

Properties

 | Name | Description
Public property | DuctType | The duct type of this duct.
Public property | IsPlaceholder | Identifies if the duct is a placeholder or not.

See Also

Duct Class
Autodesk.Revit.DB.Mechanical Namespace

Duct Methods

[image] [image]