Revit 2013 API
RoofTypeSet Members
RoofTypeSet Class Constructors Methods Properties See Also Send Feedback

The RoofTypeSet type exposes the following members.

Constructors

 | Name | Description
Public method | RoofTypeSet | Initializes a new instance of the RoofTypeSet class

Methods

 | Name | Description
Public method | Clear | Removes every roof type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a roof type within the set.
Public method | Erase | Removes a specified roof type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | Insert | Insert the specified roof type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | Size | Returns the number of roof types that are in the set.

See Also

RoofTypeSet Class

RoofTypeSet Constructor

[image]