Revit 2013 API
FilterStringRule..::..CaseSensitive Property
FilterStringRule Class See Also Send Feedback
The boolean flag that determines whether or not the filter rule respects case when comparing strings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
[ObsoleteAttribute("Case-sensitivity for filter rules is being phased out. In Revit 2013, case-sensitive filter rules will continue to use the old behavior. Case-insensitive filter rules will now use the same string matching algorithm used elsewhere in Revit.")]
public bool CaseSensitive { get; set; }
Visual Basic
<ObsoleteAttribute("Case-sensitivity for filter rules is being phased out. In Revit 2013, case-sensitive filter rules will continue to use the old behavior. Case-insensitive filter rules will now use the same string matching algorithm used elsewhere in Revit.")> _
Public Property CaseSensitive As Boolean
    Get
    Set
Visual C++
[ObsoleteAttribute(L"Case-sensitivity for filter rules is being phased out. In Revit 2013, case-sensitive filter rules will continue to use the old behavior. Case-insensitive filter rules will now use the same string matching algorithm used elsewhere in Revit.")]
public:
property bool CaseSensitive {
    bool get ();
    void set (bool value);
}

See Also

FilterStringRule Class

RuleString Property

[image]