Revit 2013 API
IFCProductWrapper..::..AddAnnotation Method
IFCProductWrapper Class See Also Send Feedback
Adds an annotation handle to associate with the IfcProduct in this wrapper.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void AddAnnotation(
    IFCAnyHandle annoHnd,
    IFCLevelInfo levelInfo,
    bool relateToLevel
)
Visual Basic
Public Sub AddAnnotation ( _
    annoHnd As IFCAnyHandle, _
    levelInfo As IFCLevelInfo, _
    relateToLevel As Boolean _
)
Visual C++
public:
void AddAnnotation(
    IFCAnyHandle^ annoHnd,
    IFCLevelInfo^ levelInfo,
    bool relateToLevel
)

Parameters

annoHnd
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The annotation handle.
levelInfo
Type: Autodesk.Revit.DB.IFC..::..IFCLevelInfo
Information on the associated level. Optional, can be nullNothingnullptra null reference (Nothing in Visual Basic).
relateToLevel
Type: System..::..Boolean
True to relate the annotation to the level, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCProductWrapper Class
Autodesk.Revit.DB.IFC Namespace

AddBuilding Method

[image]