Revit 2013 API
Application Members
Application Class Constructors Methods Properties Events See Also Send Feedback

The Application type exposes the following members.

Constructors

 | Name | Description
Public method | Application | Initializes a new instance of the Application class

Methods

 | Name | Description
Public method | CopyModel | Copies an existing model to a new file. Overwriting a file of the same name is allowed.
Public method | Dispose | Releases all resources used by the Application
Public method | ExtractPartAtomFromFamilyFile | Writes a PartAtom XML from the contents of a family file.
 | GetFailureDefinitionRegistry | Returns the instance of FailureDefinitionRegistry.
Public method | GetLibraryPaths | Returns path information identifying where Revit searches for content.
Public method | GetRevitServerNetworkHosts |
Public method | GetWorksharingCentralGUID | Gets the worksharing central GUID of the given server-based model.
Public method | NewFamilyDocument | New family document, including family, titleblock, and annotation symbol
Public method | NewProjectDocument | New project document
Public method | NewProjectTemplateDocument | New project template document
Public method | OpenBuildingComponentDocument | Opens a Building Component document from disk.
Public method | OpenDocumentFile(String) | Opens a document from disk.
Public method | OpenDocumentFile(ModelPath, OpenOptions) | Opens a document from disk.
Public method | OpenIFCDocument | Opens an IFC document from disk.
Public method | OpenSharedParameterFile | Enables access to shared parameter groups and definitions that are maintained on disk.
Public method | PurgeReleasedAPIObjects | Explicitly purges all API objects that have been released but are still awaiting to be finalized
 | RegisterFailuresProcessor | Registers Revit application-wide instance of Failures Processor.
Public method | SetLibraryPaths | Sets path information identifying where Revit searches for content.
Public method | WriteJournalComment | Writes a comment to the Revit journal file.

Properties

 | Name | Description
Public property | ActiveAddInId | Retrieves the Id of the currently running external application.
Public property | Assets |
Public property | Cities | Returns a set of all the known city locations within Revit.
Public property | Create | Provides an object that can be used to create new instances of Autodesk Revit API objects.
Public property | CurrentRevitServerAccelerator | Current Revit Server accelerator.
Public property | DefaultProjectTemplate | Full path to the default template file for new project documents.
Public property | DefaultViewDiscipline | The view discipline that will be applied to new views by default.
Public property | Documents | Returns a set of documents within Revit.
Public property | FamilyTemplatePath | Default path for family template files.
Public property | IsArchitectureEnabled | Checks whether or not the architecture discipline is enabled, and enable or disable it.
Public property | IsElectricalAnalysisEnabled | Checks whether or not electrical analysis is enabled, and enable or disable it.
Public property | IsElectricalEnabled | Checks whether or not the electrical discipline is enabled, and enable or disable it.
Public property | IsEnergyAnalysisEnabled | Checks whether or not energy analysis is enabled, and enable or disable it.
Public property | IsMassingEnabled | Checks whether or not the massing and site tools are enabled, and enable or disable them.
Public property | IsMechanicalAnalysisEnabled | Checks whether or not mechanical analysis is enabled, and enable or disable it.
Public property | IsMechanicalEnabled | Checks whether or not the mechanical discipline is enabled, and enable or disable it.
Public property | IsPipingAnalysisEnabled | Checks whether or not piping analysis is enabled, and enable or disable it.
Public property | IsPipingEnabled | Checks whether or not the piping discipline is enabled, and enable or disable it.
Public property | IsQuiescent | Returns if the current application is quiescent.
Public property | IsStructuralAnalysisEnabled | Checks whether or not the structural analysis is enabled, and enable or disable it.
Public property | IsStructureEnabled | Checks whether or not the structure discipline is enabled, and enable or disable it.
Public property | IsSystemsEnabled | Checks whether or not any systems disciplines (mechanical, electrical, or piping) are enabled.
Public property | Language | The language used in the current session of Revit.
Public property | ObjectFactory | Provides an object that can be used to create other instances of Autodesk Revit API objects.
Public property | Product | The product type for the current session of Revit.
Public property | RecordingJournalFilename | Retrieve the name of the journal file the Revit is currently recording to.
Public property | SharedParametersFilename | Contains the fully qualified path to a shared parameters file.
Public property | ShowGraphicalWarningCableTrayConduitDisconnects | Whether or not to show the graphical warnings for CTC disconnects.
Public property | ShowGraphicalWarningDuctDisconnects | Whether or not to show the graphical warnings for duct disconnects.
Public property | ShowGraphicalWarningElectricalDisconnects | Whether or not to show the graphical warnings for Electrical disconnects.
Public property | ShowGraphicalWarningPipeDisconnects | Whether or not to show the graphical warnings for Pipe disconnects.
Public property | Username | Gets the user name for the current Revit session.
Public property | VersionBuild | Returns the internal build number of the Autodesk Revit application.
Public property | VersionName | Returns the name of the Revit application.
Public property | VersionNumber | Return the primary version of the Revit application.
Public property | VertexTolerance | Gets the vertex tolerance.

Events

 | Name | Description
Public event | ApplicationInitialized | Subscribe to this event to get notified after the Revit application has been initialized
Public event | DocumentChanged | Subscribe to the DocumentChanged event to be notified when Revit document has changed.
Public event | DocumentClosed | Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.
Public event | DocumentClosing | Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.
Public event | DocumentCreated | Subscribe to the DocumentCreated event to be notified immediately after Revit has finished creating a new document.
Public event | DocumentCreating | Subscribe to the DocumentCreating event to be notified when Revit is just about to create a new document.
Public event | DocumentOpened | Subscribe to the DocumentOpened event to be notified immediately after Revit has finished opening a document.
Public event | DocumentOpening | Subscribe to the DocumentOpening event to be notified when Revit is just about to open a document.
Public event | DocumentPrinted | Subscribe to the DocumentPrinted event to be notified immediately after Revit has finished printing a view or ViewSet of the document.
Public event | DocumentPrinting | Subscribe to the DocumentPrinting event to be notified when Revit is just about to print a view or ViewSet of the document.
Public event | DocumentSaved | Subscribe to the DocumentSaved event to be notified immediately after Revit has finished saving a document.
Public event | DocumentSavedAs | Subscribe to the DocumentSavedAs event to be notified immediately after Revit has finished saving document with a new file name.
Public event | DocumentSaving | Subscribe to the DocumentSaving event to be notified when Revit is just about to save a document.
Public event | DocumentSavingAs | Subscribe to the DocumentSavingAs event to be notified when Revit is just about to save the document with a new file name.
Public event | DocumentSynchronizedWithCentral | Subscribe to the DocumentSynchronizedWithCentral event to be notified immediately after Revit has finished synchronizing a document with central model.
Public event | DocumentSynchronizingWithCentral | Subscribe to the DocumentSynchronizingWithCentral event to be notified when Revit is just about to synchronize a document with central model.
Public event | FailuresProcessing | Subscribe to the FailuresProcessing event to be notified when failures are being processed at the end of transaction.
Public event | FileExported | Subscribe to the FileExported event to be notified immediately after Revit has finished exporting files of formats supported by the API.
Public event | FileExporting | Subscribe to the FileExporting event to be notified when Revit is just about to export files of formats supported by the API.
Public event | FileImported | Subscribe to the FileImported event to be notified immediately after Revit has finished importing a file of format supported by the API.
Public event | FileImporting | Subscribe to the FileImporting event to be notified when Revit is just about to import a file of format supported by the API.
Public event | ProgressChanged | Subscribe to the ProgressChanged event to be notified when an operation in Revit has progress bar data available.
Public event | ViewPrinted | Subscribe to the ViewPrinted event to be notified immediately after Revit has finished printing a view of the document.
Public event | ViewPrinting | Subscribe to the ViewPrinting event to be notified when Revit is just about to print a view of the document.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace

Application Constructor

[image]