Revit 2013 API
ExporterIFCUtils..::..ValidateCurveLoops Method
ExporterIFCUtils Class See Also Send Feedback
Does validity checks on a list of curve loops to ensure that they are all co-planar, closed, and properly oriented.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static IList<CurveLoop> ValidateCurveLoops(
    IList<CurveLoop> curveLoops,
    XYZ extrDirVec
)
Visual Basic
Public Shared Function ValidateCurveLoops ( _
    curveLoops As IList(Of CurveLoop), _
    extrDirVec As XYZ _
) As IList(Of CurveLoop)
Visual C++
public:
static IList<CurveLoop^>^ ValidateCurveLoops(
    IList<CurveLoop^>^ curveLoops,
    XYZ^ extrDirVec
)

Parameters

curveLoops
Type: System.Collections.Generic..::..IList<(Of <(<'CurveLoop>)>)>
The loops to check.
extrDirVec
Type: Autodesk.Revit.DB..::..XYZ
The normal.

Return Value

returns the curve loops properly oriented, if possible. If not, the return contains no loops.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace

IExporterIFC Interface

[image]