Revit 2013 API
FamilySymbol Class
Members Example See Also Send Feedback
Represents a single Type within a Family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class FamilySymbol : InsertableObject
Visual Basic
Public Class FamilySymbol _
    Inherits InsertableObject
Visual C++
public ref class FamilySymbol : public InsertableObject

Remarks

The FamilySymbol object represents a Type within a Family. Each family can contain one or more family symbols.

Examples

CopyC#
public void GetInfo_FamilySymbol(FamilySymbol familySymbol)
{
    string message;
    // Get FamilySymbol family name
    message = "Family name is : " + familySymbol.Family.Name;

    // Get FamilySymbol material
    message += "\nFamilySymbol materials are :";
    foreach (Material material in familySymbol.Materials)
    {
        message += "\n" + material.Name;
    }

    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Public Sub GetInfo_FamilySymbol(ByVal familySymbol As FamilySymbol)
    Dim message As String
    ' Get FamilySymbol family name
    message = "Family name is : " + familySymbol.Family.Name

    ' Get FamilySymbol material
    message += vbLf & "FamilySymbol material is : " & familySymbol.Materials.GetEnumerator().ToString()

    TaskDialog.Show("Revit", message)
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..InsertableObject
Autodesk.Revit.DB..::..FamilySymbol
Autodesk.Revit.DB..::..AnnotationSymbolType
Autodesk.Revit.DB.Architecture..::..RoomTagType
Autodesk.Revit.DB..::..AreaTagType
Autodesk.Revit.DB.Mechanical..::..SpaceTagType
Autodesk.Revit.DB..::..MullionType
Autodesk.Revit.DB..::..PanelType
Autodesk.Revit.DB.Structure..::..TrussType

See Also

FamilySymbol Members

FamilySymbol Members

[image] [image]