Revit 2013 API
FamilyItemFactory..::..NewPipeConnector Method
FamilyItemFactory Class Example See Also Send Feedback
Add a new pipe connector into the Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2013.  Please call ConnectorElement::CreatePipeConnector() instead")]
public PipeConnector NewPipeConnector(
    Reference planarFaceReference,
    PipeSystemType systemType
)
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2013.  Please call ConnectorElement::CreatePipeConnector() instead")> _
Public Function NewPipeConnector ( _
    planarFaceReference As Reference, _
    systemType As PipeSystemType _
) As PipeConnector
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2013.  Please call ConnectorElement::CreatePipeConnector() instead")]
public:
PipeConnector^ NewPipeConnector(
    Reference^ planarFaceReference,
    PipeSystemType systemType
)

Parameters

planarFaceReference
Type: Autodesk.Revit.DB..::..Reference
A reference to a planar face where the connector will be placed.
systemType
Type: Autodesk.Revit.DB.Plumbing..::..PipeSystemType
Indicates the system type of this new Pipe connector.

Return Value

If creation was successful the new pipe connector is returned, otherwise an exception with failure information will be thrown.

Remarks

This method creates a Pipe Connector in a family document. The pipe connector will be placed at the centroid of the planar face.

Examples

CopyC#
public void CreatePipeConnectors(UIDocument uiDocument, Extrusion extrusion)
{
    // get the faces of the extrusion
    Options geoOptions = uiDocument.Document.Application.Create.NewGeometryOptions();
    geoOptions.View = uiDocument.Document.ActiveView;
    geoOptions.ComputeReferences = true;

    List<PlanarFace> planarFaces = new List<PlanarFace>();
    Autodesk.Revit.DB.GeometryElement geoElement = extrusion.get_Geometry(geoOptions);
    foreach (GeometryObject geoObject in geoElement.Objects)
    {
        Solid geoSolid = geoObject as Solid;
        if (null != geoSolid)
        {
            foreach (Face geoFace in geoSolid.Faces)
            {
                if (geoFace is PlanarFace)
                {
                    planarFaces.Add(geoFace as PlanarFace);
                }
            }
        }
    }

    if (planarFaces.Count > 1)
    {
        // Create the Supply Hydronic pipe connector
        PipeConnector connSupply =
            uiDocument.Document.FamilyCreate.NewPipeConnector(planarFaces[0].Reference,
                                                   PipeSystemType.SupplyHydronic);
        Parameter param = connSupply.get_Parameter(BuiltInParameter.CONNECTOR_RADIUS);
        param.Set(1.0); // 1' radius
        param = connSupply.get_Parameter(BuiltInParameter.RBS_PIPE_FLOW_DIRECTION_PARAM);
        param.Set(2);

        // Create the Return Hydronic pipe connector
        PipeConnector connReturn =
            uiDocument.Document.FamilyCreate.NewPipeConnector(planarFaces[1].Reference,
                                                   PipeSystemType.ReturnHydronic);

        param = connReturn.get_Parameter(BuiltInParameter.CONNECTOR_RADIUS);
        param.Set(0.5); // 6" radius
        param = connReturn.get_Parameter(BuiltInParameter.RBS_PIPE_FLOW_DIRECTION_PARAM);
        param.Set(1);
    }
}
CopyVB.NET
Public Sub CreatePipeConnectors(ByVal uiDocument As UIDocument, ByVal extrusion As Extrusion)
    ' get the faces of the extrusion
    Dim geoOptions As Options = uiDocument.Document.Application.Create.NewGeometryOptions()
    geoOptions.View = uiDocument.Document.ActiveView
    geoOptions.ComputeReferences = True

    Dim planarFaces As New List(Of PlanarFace)()
    Dim geoElement As Autodesk.Revit.DB.GeometryElement = extrusion.Geometry(geoOptions)
    For Each geoObject As GeometryObject In geoElement.Objects
        Dim geoSolid As Solid = TryCast(geoObject, Solid)
        If geoSolid IsNot Nothing Then
            For Each geoFace As Face In geoSolid.Faces
                If TypeOf geoFace Is PlanarFace Then
                    planarFaces.Add(TryCast(geoFace, PlanarFace))
                End If
            Next
        End If
    Next

    If planarFaces.Count > 1 Then
        ' Create the Supply Hydronic pipe connector
        Dim connSupply As PipeConnector = uiDocument.Document.FamilyCreate.NewPipeConnector(planarFaces(0).Reference, PipeSystemType.SupplyHydronic)
        Dim param As Parameter = connSupply.Parameter(BuiltInParameter.CONNECTOR_RADIUS)
        param.[Set](1)
        ' 1' radius
        param = connSupply.Parameter(BuiltInParameter.RBS_PIPE_FLOW_DIRECTION_PARAM)
        param.[Set](2)

        ' Create the Return Hydronic pipe connector
        Dim connReturn As PipeConnector = uiDocument.Document.FamilyCreate.NewPipeConnector(planarFaces(1).Reference, PipeSystemType.ReturnHydronic)

        param = connReturn.Parameter(BuiltInParameter.CONNECTOR_RADIUS)
        param.[Set](0.5)
        ' 6" radius
        param = connReturn.Parameter(BuiltInParameter.RBS_PIPE_FLOW_DIRECTION_PARAM)
        param.[Set](1)
    End If
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the argument planarFaceReference is invalid.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace

NewRadialDimension Method

[image] [image]