Revit 2013 API
Curve..::..Transformed Property
Curve Class Example See Also Send Feedback
Applies the specified transformation to this curve and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Curve this[
    Transform transform
] { get; }
Visual Basic
Public ReadOnly Property Transformed ( _
    transform As Transform _
) As Curve
    Get
Visual C++
public:
property Curve^ Transformed[Transform^ transform] {
    Curve^ get (Transform^ transform);
}

Parameters

transform
Type: Autodesk.Revit.DB..::..Transform
The transformation to be applied.

Return Value

The transformed curve.

Examples

CopyC#
public void GetAndTransformCurve(Autodesk.Revit.ApplicationServices.Application app,
    Autodesk.Revit.DB.Element element, Options geoOptions)
{
    // Get geometry element of the selected element
    Autodesk.Revit.DB.GeometryElement geoElement = element.get_Geometry(geoOptions);

    // Get geometry object
    foreach (GeometryObject geoObject in geoElement.Objects)
    {
        // Get the geometry instance which contains the geometry information
       Autodesk.Revit.DB.GeometryInstance instance =
           geoObject as Autodesk.Revit.DB.GeometryInstance;
        if (null != instance)
        {
            foreach (GeometryObject o in instance.SymbolGeometry.Objects)
            {
                // Get curve
                Curve curve = o as Curve;
                if (curve != null)
                {
                    // transfrom the curve to make it in the instance's coordinate space
                    curve = curve.get_Transformed(instance.Transform);
                }
            }
        }
    }
}
CopyVB.NET
Public Sub GetAndTransformCurve(ByVal app As Autodesk.Revit.ApplicationServices.Application, ByVal element As Autodesk.Revit.DB.Element, ByVal geoOptions As Autodesk.Revit.DB.Options)
    ' Get geometry element of the selected element
    Dim geoElement As Autodesk.Revit.DB.GeometryElement = element.Geometry(geoOptions)

    ' Get geometry object
    For Each geoObject As GeometryObject In geoElement.Objects
        ' Get the geometry instance which contains the geometry information
        Dim instance As Autodesk.Revit.DB.GeometryInstance = TryCast(geoObject, Autodesk.Revit.DB.GeometryInstance)
        If instance IsNot Nothing Then
            For Each o As GeometryObject In instance.SymbolGeometry.Objects
                ' Get curve
                Dim curve As Curve = TryCast(o, Curve)
                If curve IsNot Nothing Then
                    ' transfrom the curve to make it in the instance's coordinate space
                    curve = curve.Transformed(instance.Transform)
                End If
            Next
        End If
    Next
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the specified transformation is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the transformation is not valid or the transformation application fails.

See Also

Curve Class

CurveArrArray Class

[image]