Revit 2013 API
FamilyThermalProperties..::..Find Method
FamilyThermalProperties Class See Also Send Feedback
Find the thermal properties by the 'id' property of a constructionType node in Constructions.xml.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static FamilyThermalProperties Find(
    Document pADoc,
    string constructionId
)
Visual Basic
Public Shared Function Find ( _
    pADoc As Document, _
    constructionId As String _
) As FamilyThermalProperties
Visual C++
public:
static FamilyThermalProperties^ Find(
    Document^ pADoc,
    String^ constructionId
)

Parameters

pADoc
Type: Autodesk.Revit.DB..::..Document
The document
constructionId
Type: System..::..String
The 'id' property of a constructionType node in Constructions.xml

Return Value

Return the thermal properties found.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FamilyThermalProperties Class

FamilyThermalProperties Properties

[image] [image]