Revit 2013 API
CategorySet Methods
CategorySet Class See Also Send Feedback

The CategorySet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains | Tests for the existence of a category within the set.
Public method | Erase | Removes a specified category from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | Insert | Insert the specified category into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.

See Also

CategorySet Class

Clear Method

[image]