Revit 2013 API
CurtainGridLine..::..AddMullions Method
CurtainGridLine Class See Also Send Feedback
Add mullions on the specified segments of a grid. If a segment already had mullion, just keep it and do nothing to that segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementSet AddMullions(
    Curve segment,
    MullionType mullionType,
    bool oneSegmentOnly
)
Visual Basic
Public Function AddMullions ( _
    segment As Curve, _
    mullionType As MullionType, _
    oneSegmentOnly As Boolean _
) As ElementSet
Visual C++
public:
ElementSet^ AddMullions(
    Curve^ segment,
    MullionType^ mullionType,
    bool oneSegmentOnly
)

Parameters

segment
Type: Autodesk.Revit.DB..::..Curve
Curve of the segment.
mullionType
Type: Autodesk.Revit.DB..::..MullionType
The type of the mullion.
oneSegmentOnly
Type: System..::..Boolean
If it is true, we only add one mullion to the specified segment, otherwise we add mullions to all the segments of the grid line.

Return Value

If operation succeeds, the created mullion will be returned.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | If one of the segments are not the tagged edge of the host element, this exception will be thrown.
Autodesk.Revit.Exceptions..::..InvalidOperationException | The operation fails to create one or several mullions as required or regeneration fails.

See Also

CurtainGridLine Class

AddSegment Method

[image]