Revit 2013 API
MaterialSet Members
MaterialSet Class Constructors Methods Properties See Also Send Feedback

The MaterialSet type exposes the following members.

Constructors

 | Name | Description
Public method | MaterialSet | Initializes a new instance of the MaterialSet class

Methods

 | Name | Description
Public method | Clear | Removes every material from the set, rendering it empty.
Public method | Contains |
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | Size | Returns the number of materials that are in the set.

See Also

MaterialSet Class

MaterialSet Constructor

[image]