Revit 2013 API
MechanicalUtils Members
MechanicalUtils Class Methods See Also Send Feedback

The MechanicalUtils type exposes the following members.

Methods

 | Name | Description
 | ConnectDuctPlaceholdersAtCross(Document, ElementId, ElementId) | Connects placeholders that looks like Cross connection.
 | ConnectDuctPlaceholdersAtCross(Document, ElementId, ElementId, ElementId) | Connects placeholders that looks like Cross connection.
 | ConnectDuctPlaceholdersAtCross(Document, Connector, Connector, Connector, Connector) | Connects placeholders that looks like Cross connection.
 | ConnectDuctPlaceholdersAtElbow(Document, Connector, Connector) | Connects placeholders that looks like elbow connection.
 | ConnectDuctPlaceholdersAtElbow(Document, ElementId, ElementId) | Connects placeholders that looks like elbow connection.
 | ConnectDuctPlaceholdersAtTee(Document, ElementId, ElementId) | Connects two placeholders that looks like Tee connection.
 | ConnectDuctPlaceholdersAtTee(Document, Connector, Connector, Connector) | Connects three placeholders that looks like Tee connection.
 | ConvertDuctPlaceholders | Converts a collection of duct placeholder elements into duct elements.
Public method | Dispose | Releases all resources used by the MechanicalUtils

See Also

MechanicalUtils Class
Autodesk.Revit.DB.Mechanical Namespace

MechanicalUtils Methods

[image] [image]