Revit 2013 API
ExporterIFC..::..RegisterDoorWindowForOpeningUpdate Method
ExporterIFC Class See Also Send Feedback
Registers information about a door or window with the ExporterIFC's internal cache so that an existing opening applied to wall elements will have its size updated based on the size of the instance.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void RegisterDoorWindowForOpeningUpdate(
    IFCDoorWindowInfo info
)
Visual Basic
Public Sub RegisterDoorWindowForOpeningUpdate ( _
    info As IFCDoorWindowInfo _
)
Visual C++
public:
void RegisterDoorWindowForOpeningUpdate(
    IFCDoorWindowInfo^ info
)

Parameters

info
Type: Autodesk.Revit.DB.IFC..::..IFCDoorWindowInfo
The door or window info handle.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace

RegisterDoorWindowForUncreatedOpening Method

[image]