Revit 2013 API
ElementSet Class
Members Example See Also Send Feedback
A set that contains element objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class ElementSet : APIObject, IEnumerable
Visual Basic
Public Class ElementSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class ElementSet : public APIObject,
    IEnumerable

Examples

CopyC#
ElementSet elems = uidoc.Selection.Elements;

string info = "Selected elements:\n";
foreach (Autodesk.Revit.DB.Element elem in elems)
{
    info += elem.Name + "\n";
}

TaskDialog.Show("Revit",info);
CopyVB.NET
Dim elems As ElementSet = uidoc.Selection.Elements

Dim info As String = "Selected elements:" & vbLf
For Each elem As Autodesk.Revit.DB.Element In elems
    info += elem.Name + vbLf
Next

TaskDialog.Show("Revit", info)

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..ElementSet
Autodesk.Revit.UI.Selection..::..SelElementSet

See Also

ElementSet Members

ElementSet Members

[image] [image]