Revit 2013 API
ExporterIFC..::..AddViewIdToExport Method
ExporterIFC Class See Also Send Feedback
Adds a view to be exported to the exporter's internal cache.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void AddViewIdToExport(
    ElementId viewId,
    ElementId levelId
)
Visual Basic
Public Sub AddViewIdToExport ( _
    viewId As ElementId, _
    levelId As ElementId _
)
Visual C++
public:
void AddViewIdToExport(
    ElementId^ viewId,
    ElementId^ levelId
)

Parameters

viewId
Type: Autodesk.Revit.DB..::..ElementId
The view id.
levelId
Type: Autodesk.Revit.DB..::..ElementId
The level id for the view.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace

Dispose Method

[image]