Revit 2013 API
IExternalService..::..GetServiceId Method
IExternalService Interface See Also Send Feedback
Implement this method to return the unique Id of the service.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
ExternalServiceId GetServiceId()
Visual Basic
Function GetServiceId As ExternalServiceId
Visual C++
ExternalServiceId^ GetServiceId()

Return Value

The extensible enum value representing the Id of the service.

Remarks

A service Id is an item in an extensible enum in which all service Ids are contained.

See Also

IExternalService Interface
Autodesk.Revit.DB.ExternalService Namespace

GetVendorId Method

[image]