Revit 2013 API
Curve..::..EndParameter Property
Curve Class See Also Send Feedback
The parameter of the start or the end point of the curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double this[
    int index
] { get; set; }
Visual Basic
Public Property EndParameter ( _
    index As Integer _
) As Double
    Get
    Set
Visual C++
public:
property double EndParameter[int index] {
    double get (int index);
    void set (int index, double value);
}

Parameters

index
Type: System..::..Int32
Use 0 for the start point; 1 for the end point.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the specified index is not 0 or 1 both in the getter and setter.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the specified parameter is not within curve bounds in the setter, or the object is internally marked as read-only in the setter, or the curve is unbound both in the getter and setter.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the value of parameter is infinite in the setter.

See Also

Curve Class

EndPoint Property

[image]