Revit 2013 API
RebarBarType..::..StirrupTieBendDiameter Property
RebarBarType Class See Also Send Feedback
Defines bar and hook bend diameter for rebar whose style is stirrup/tie

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double StirrupTieBendDiameter { get; set; }
Visual Basic
Public Property StirrupTieBendDiameter As Double
    Get
    Set
Visual C++
public:
property double StirrupTieBendDiameter {
    double get ();
    void set (double value);
}

Field Value

The bar and hook bend diameter for rebar whose style is stirrup/tie

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: the bend diameter stirrupTieBendDiam isn't between bar diameter and 99.0
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

RebarBarType Class
Autodesk.Revit.DB.Structure Namespace

RebarBarTypeSet Class

[image]