Revit 2013 API
Document Properties
Document Class See Also Send Feedback

The Document type exposes the following members.

Properties

 | Name | Description
Public property | ActiveProjectLocation | Retrieve the active project location.
Public property | ActiveView | The document's active view.
Public property | AnnotationSymbolTypes | Retrieves an object that contains all the annotation types that are currently loaded into the project.
Public property | Application | Returns the Application in which the Document resides.
Public property | BeamSystemTypes | Retrieves an object that contains all of beam system types that are currently loaded into the project.
Public property | ContFootingTypes | Retrieves an object that contains all of continuous footing types that are currently loaded into the project.
Public property | Create | An object that can be used to create new instances of Autodesk Revit API elements within a project.
Public property | CurtainSystemTypes | This property is used to retrieve all the CurtainSystem types in current system.
Public property | DeckProfiles | Returns an object that contains all of the available deck profiles currently loaded to this project.
Public property | DimensionTypes | Retrieves an object that contains all of dimension types that are currently loaded into the project.
Public property | DisplayUnitSystem | Provides access to display unit type with in the document.
Public property | ElectricalEquipmentTypes | Returns an object that contains all of the available electrical equipment types currently loaded to this project.
Public property | Element[([( String])]) | Obsolete. Retrieves an element from the document given a unique id string.
Public property | Element[([( ElementId])]) | Obsolete. Retrieves an element from the document given a Revit element id.
Public property | FamilyCreate | An object that can be used to create new instances of Autodesk Revit API elements within a family document.
Public property | FamilyManager | The family manager object provides access to family types and parameters.
Public property | FasciaTypes | Retrieves an object that contains all the Fascia types that are currently loaded into the project.
Public property | FloorTypes | Retrieves an object that contains all the floor types that are currently loaded into the project.
Public property | GridTypes | Retrieves an object that contains all of Grid types that are currently loaded into the project.
Public property | GutterTypes | Retrieves an object that contains all the Gutter types that are currently loaded into the project.
Public property | IsFamilyDocument | Identifies if the current document is a family document.
Public property | IsModifiable | The document's state of modifiability.
Public property | IsModified | The state of changes made to the document.
Public property | IsReadOnly | Identifies if the document is read-only or can possibly be modified.
Public property | IsReadOnlyFile | Signals whether the document was opened from a read-only file.
Public property | IsWorkshared | Identifies if worksharing (i.e. editing permissions and multiple worksets) have been enabled in the document.
Public property | LevelTypes | Retrieves an object that contains all the level types that are currently loaded into the project.
Public property | LightingDeviceTypes | Returns an object that contains all of the available lighting device types currently loaded to this project.
Public property | LightingFixtureTypes | Returns an object that contains all of the available lighting fixture types currently loaded to this project.
Public property | MassDisplayTemporaryOverride | This setting controls temporary display in views of objects with mass category or subcategories.
Public property | MechanicalEquipmentTypes | Returns an object that contains all of the available mechanical equipment types currently loaded to this project.
Public property | MullionTypes | This property is used to retrieve all the mullion types in current system.
Public property | OwnerFamily | Get the Family of this Family Document.
Public property | PanelTypes | Retrieves a set of PanelType objects that contains all the panel types that are currently loaded into the project.
Public property | ParameterBindings | Retrieves an object from which mappings between parameter definitions and categories can be found.
Public property | PathName | The fully qualified path of the document's disk file.
Public property | Phases | Retrieves all the object that represent phases within the project.
Public property | PlanTopologies | Get the PlanTopologies of the current project in the last phase.
Public property | PlanTopologies[([( Phase])]) | Gets the PlanTopologies of the current project in a given phase.
Public property | PlanTopology[([( Level])]) | Get the PlanTopology of a given level in the last phase.
Public property | PlanTopology[([( Level, Phase])]) | Get the PlanTopology of a given level in a given phase.
Public property | PrintManager | Retrieve the PrintManager of current project.
Public property | PrintSettings | Obsolete. Retrieve all Print Settings of current project.
Public property | ProjectInformation | Return the Project Information of the current project.
Public property | ProjectLocations | Retrieve all the project locations associated with this project
Public property | ProjectUnit | Provides access to Project Unit Setting with in the document.
Public property | ReactionsAreUpToDate | Reports if the analytical model has regenerated in a document with reaction loads.
Public property | RebarBarTypes | Retrieves an object that contains all the rebar bar types that are currently loaded into the project.
Public property | RebarCoverTypes | Retrieves an object that contains all the rebar cover types that are currently loaded into the project.
Public property | RebarHookTypes | Retrieves an object that contains all the rebar hook types that are currently loaded into the project.
Public property | RebarShapes | Retrieves an object that contains all the rebar shape types that are currently loaded into the project.
Public property | RoofTypes | Retrieves an object that contains all the roof types that are currently loaded into the project.
Public property | RoomTagTypes | Retrieves an object that contains all of RoomTag types that are currently loaded into the project.
Public property | Settings | Provides access to general application settings, such as Categories.
Public property | SiteLocation | Returns the site location information.
Public property | SlabEdgeTypes | Retrieves an object that contains all the SlabEdge types that are currently loaded into the project.
Public property | SpaceTagTypes | Retrieves an object that contains all of RoomTag types that are currently loaded into the project.
Public property | SpotDimensionTypes | Retrieves an object that contains all of SpotDimension types that are currently loaded into the project.
Public property | TextNoteTypes | Retrieves an object that contains all of TextNote types that are currently loaded into the project.
Public property | Title | The document's title.
Public property | TitleBlocks | Titleblocks currently loaded into the document.
Public property | TrussTypes | Retrieves an object that contains all the truss types that are currently loaded into the project.
Public property | TypeOfStorage | Get the storage type of the specified BuiltInParameter.
Public property | ViewSheetSets | The view sheet sets stored in the document.
Public property | WallTypes | Retrieves an object that contains all the wall types that are currently loaded into the project.
Public property | WorksharingCentralFilename | Obsolete. The name and path of the central model for a workshared document.
Public property | WorksharingCentralGUID | The central GUID of the server-based model.

See Also

Document Class

ActiveProjectLocation Property

[image]