Revit 2013 API
AnalyticalModel..::..IsValidSelectorAndDirection Method
AnalyticalModel Class See Also Send Feedback
Indicates if the input selector is valid for analytical direction for Analytical Model.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsValidSelectorAndDirection(
    AnalyticalElementSelector selector,
    AnalyticalDirection direction
)
Visual Basic
Public Function IsValidSelectorAndDirection ( _
    selector As AnalyticalElementSelector, _
    direction As AnalyticalDirection _
) As Boolean
Visual C++
public:
bool IsValidSelectorAndDirection(
    AnalyticalElementSelector selector,
    AnalyticalDirection direction
)

Parameters

selector
Type: Autodesk.Revit.DB.Structure..::..AnalyticalElementSelector
Selector of element part
direction
Type: Autodesk.Revit.DB.Structure..::..AnalyticalDirection
Direction which will be validated for the Analytical Model

Return Value

True if selector is valid for given direction, false otherwise

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace

ManuallyAdjust Method

[image]