Revit 2013 API
UpdaterRegistry..::..GetIsUpdaterOptional Method
UpdaterRegistry Class See Also Send Feedback
Check if the updater is optional or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static bool GetIsUpdaterOptional(
    UpdaterId id
)
Visual Basic
Public Shared Function GetIsUpdaterOptional ( _
    id As UpdaterId _
) As Boolean
Visual C++
public:
static bool GetIsUpdaterOptional(
    UpdaterId^ id
)

Parameters

id
Type: Autodesk.Revit.DB..::..UpdaterId
Id of the updater to check

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | The updater has not been registered.

See Also

UpdaterRegistry Class

GetRegisteredUpdaterInfos Method

[image] [image]