Revit 2013 API
ParameterFilterElement..::..AllRuleParametersApplicable Method (Document, ICollection<(Of <(<'ElementId>)>)>, IList<(Of <(<'FilterRule>)>)>)
ParameterFilterElement Class See Also Send Feedback
Checks that the parameters of the given rules are valid for the given set of categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static bool AllRuleParametersApplicable(
    Document aDocument,
    ICollection<ElementId> categories,
    IList<FilterRule> rules
)
Visual Basic
Public Shared Function AllRuleParametersApplicable ( _
    aDocument As Document, _
    categories As ICollection(Of ElementId), _
    rules As IList(Of FilterRule) _
) As Boolean
Visual C++
public:
static bool AllRuleParametersApplicable(
    Document^ aDocument,
    ICollection<ElementId^>^ categories,
    IList<FilterRule^>^ rules
)

Parameters

aDocument
Type: Autodesk.Revit.DB..::..Document
The document containing the filter, categories, and parameters involved in this validation.
categories
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
The set of categories against which to check the rule parameters.
rules
Type: System.Collections.Generic..::..IList<(Of <(<'FilterRule>)>)>
The rules to check.

Return Value

True if all the parameters of the given rules are valid for this filter, otherwise false.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterElement Class
AllRuleParametersApplicable Overload

ClearRules Method

[image]