Revit 2013 API
NurbSpline Members
NurbSpline Class Methods Properties See Also Send Feedback

The NurbSpline type exposes the following members.

Methods

 | Name | Description
Public method | SetControlPointsAndWeights | Set the control points, weights simultaneously.

Properties

 | Name | Description
Public property | CtrlPoints | Returns the control points of the nurb spline.
Public property | Degree | Returns the degree of the nurb spline.
Public property | isClosed | Return/set the nurb spline's isClosed property.
Public property | isRational | Returns whether the nurb spline is rational or not.
Public property | Knots | Return/set the knots of the nurb spline.
Public property | Weights | Returns the weights of the nurb spline.

See Also

NurbSpline Class

NurbSpline Methods

[image] [image]