Revit 2013 API
PartUtils..::..GetDividedParents Method
PartUtils Class See Also Send Feedback
Returns an array of elements that lead to the creation of this Part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
[ObsoleteAttribute("This method will be obsolete in the next version.")]
public static ICollection<ElementId> GetDividedParents(
    Part part
)
Visual Basic
<ObsoleteAttribute("This method will be obsolete in the next version.")> _
Public Shared Function GetDividedParents ( _
    part As Part _
) As ICollection(Of ElementId)
Visual C++
[ObsoleteAttribute(L"This method will be obsolete in the next version.")]
public:
static ICollection<ElementId^>^ GetDividedParents(
    Part^ part
)

Parameters

part
Type: Autodesk.Revit.DB..::..Part
The Part element

Return Value

Ids of divided elements that lead to the creation of this Part

Remarks

The array is ordered by the order of creation of the returned elements. The first element is the original element. Each consecutive element is a Part made from the previous element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PartUtils Class

GetMergedParts Method

[image]