Revit 2013 API
View..::..DisplayStyle Property
View Class See Also Send Feedback
The DisplayStyle of the view. Returns DisplayStyle.Wireframe if the view has no display style.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public DisplayStyle DisplayStyle { get; set; }
Visual Basic
Public Property DisplayStyle As DisplayStyle
    Get
    Set
Visual C++
public:
property DisplayStyle DisplayStyle {
    DisplayStyle get ();
    void set (DisplayStyle value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: DisplayStyle cannot be set to Raytrace. Because setting a view's display style to raytrace enters a special restricted mode with limited capabilities, it is not permitted to directly assign the display style to this value. -or- When setting this property: DisplayStyle cannot be set to Undefined. -or- When setting this property: DisplayStyle of Drafting Views can be set only to Wireframe or HLR
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: DisplayStyle cannot be modified. -or- When setting this property: View does not have a DisplayStyle property.

See Also

View Class

GenLevel Property

[image]