Revit 2013 API
ItemFactoryBase..::..NewFamilyInstance Method (XYZ, FamilySymbol, Element, StructuralType)
ItemFactoryBase Class See Also Send Feedback
Inserts a new instance of a family into the document, using a location, type/symbol, and the host element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilyInstance NewFamilyInstance(
    XYZ location,
    FamilySymbol symbol,
    Element host,
    StructuralType structuralType
)
Visual Basic
Public Function NewFamilyInstance ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    host As Element, _
    structuralType As StructuralType _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewFamilyInstance(
    XYZ^ location,
    FamilySymbol^ symbol,
    Element^ host,
    StructuralType structuralType
)

Parameters

location
Type: Autodesk.Revit.DB..::..XYZ
The physical location where the instance is to be placed.
symbol
Type: Autodesk.Revit.DB..::..FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
host
Type: Autodesk.Revit.DB..::..Element
The object into which the FamilyInstance is to be inserted, often known as the host.
structuralType
Type: Autodesk.Revit.DB.Structure..::..StructuralType
If structural then specify the type of the component.

Return Value

If creation was successful then an instance to the new object is returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

This method is used to insert one family instance into another element, such as inserting a window into a wall. If the instance fails to be created an exception may be thrown.

The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

The host object must be one that supports insertion of instances otherwise this method will fail.

Some Families, such as Beams, have more than one endpoint and are inserted in the same manner as single point instances. Once inserted these linear family instances can have their endpoints changed by using the instance's Element.Location property.

Note: ForbiddenForDynamicUpdateException might be thrown during a dynamic update if the inserted instance establishes a mutual dependency with another structure.

Note: if the created family instance includes nested instances, the API framework will automatically regenerate the document during this method call. This happens regardless of the setting for RegenerationMode.

See Also

ItemFactoryBase Class
NewFamilyInstance Overload
Autodesk.Revit.Creation Namespace

NewFamilyInstance Method (XYZ, FamilySymbol, XYZ, Element, StructuralType)

[image]