Revit 2013 API
RebarBendData Constructor (RebarBarType, RebarHookType, RebarHookType, RebarStyle)
RebarBendData Class See Also Send Feedback
Initializes a new instance of the RebarBendData class

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public RebarBendData(
    RebarBarType barType,
    RebarHookType hookType0,
    RebarHookType hookType1,
    RebarStyle style
)
Visual Basic
Public Sub New ( _
    barType As RebarBarType, _
    hookType0 As RebarHookType, _
    hookType1 As RebarHookType, _
    style As RebarStyle _
)
Visual C++
public:
RebarBendData(
    RebarBarType^ barType,
    RebarHookType^ hookType0,
    RebarHookType^ hookType1,
    RebarStyle style
)

Parameters

barType
Type: Autodesk.Revit.DB.Structure..::..RebarBarType
hookType0
Type: Autodesk.Revit.DB.Structure..::..RebarHookType
hookType1
Type: Autodesk.Revit.DB.Structure..::..RebarHookType
style
Type: Autodesk.Revit.DB.Structure..::..RebarStyle

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

RebarBendData Class
RebarBendData Overload
Autodesk.Revit.DB.Structure Namespace

RebarBendData Methods

[image] [image]