Revit 2013 API
Zone Members
Zone Class Methods Properties See Also Send Feedback

The Zone type exposes the following members.

Methods

 | Name | Description
Public method | AddSpaces | Add a set of existing spaces to Zone element.
Public method | RemoveSpaces | Remove a set of existing spaces to the current Zone element.

Properties

 | Name | Description
Public property | Area | Get the Area of the Zone.
Public property | Boundary | Returns the boundary of the Zone.
Public property | CalculatedCoolingLoad | Get the Calculated Cooling Load of the Zone.
Public property | CalculatedHeatingLoad | Get the Calculated Heating Load of the Zone.
Public property | CalculatedSupplyAirflow | Get the Calculated Supply Airflow of the Zone.
Public property | CoolingAirTemperature | Get or set the Cooling Air Temperature of the Zone.
Public property | CoolingSetPoint | Get or set the Cooling Set Point of the Zone.
Public property | DehumidificationSetPoint | Get or set the DeHumidification Set Point of the Zone.
Public property | GrossArea | Get the Gross Area of the Zone.
Public property | GrossVolume | Get the Gross Volume of the Zone.
Public property | HeatingAirTemperature | Get or set the Heating Air Temperature of the Zone.
Public property | HeatingSetPoint | Get or set the Heating Set Point of the Zone.
Public property | HumidificationSetPoint | Get or set the Humidification Set Point of the Zone.
Public property | IsDefaultZone | Reports whether this zone is default or not.
Public property | Name | Get or Set the Name of the Zone. (Overrides Element..::..Name.)
Public property | OutDoorAirPerArea | Get or set the OutDoor Air Per Area of the Zone.
Public property | OutDoorAirPerPerson | Get or set the OutDoor Air Per Person of the Zone.
Public property | OutdoorAirRatePerAirChangesPerHour | Get or set the Outdoor Air Rate Per Air Changes Per Hour of the Zone.
Public property | Perimeter | Get the Perimeter of the Zone.
Public property | Phase | Get the Phase of the Zone.
Public property | ServiceType | Get or set the Service Type of the Zone.
Public property | Spaces | Get the Spaces of the Zone.
Public property | Volume | Get the Volume of the Zone.

See Also

Zone Class
Autodesk.Revit.DB.Mechanical Namespace

Zone Methods

[image] [image]