Revit 2013 API
Face Properties
Face Class See Also Send Feedback

The Face type exposes the following members.

Properties

 | Name | Description
Public property | Area | The area of this face.
Public property | EdgeLoops | Each edge loop is a closed boundary of the face.
Public property | HasRegions | Reports if the face contains regions created with the Split Face command.
Public property | IsCyclic | The boolean value that indicates whether this face is periodic in the specified parametric direction.
Public property | IsTwoSided | Determines if a face is two-sided (degenerate)
Public property | MaterialElementId | Element ID of the material from which this face is composed.
Public property | Period | The period of this face in the specified parametric direction.
Public property | Reference | Returns a stable reference to the face.

See Also

Face Class

Area Property

[image]