Revit 2013 API
BeamSystem Members
BeamSystem Class Methods Properties See Also Send Feedback

The BeamSystem type exposes the following members.

Methods

 | Name | Description
 | BeamBelongsTo | Find out the BeamSystem to which the beam belongs.
 | DropBeamSystem | Drop beam system, it will disassociate all members from the beam system and delete the beam system.
Public method | GetAllBeams | Obsolete. Get all the beams of the BeamSystem.
Public method | GetBeamIds | Gets all the beams of the BeamSystem.

Properties

 | Name | Description
Public property | BeamSystemType | Retrieves or changes the type of the BeamSystem.
Public property | BeamType | Retrieves or changes the Beam Type of the BeamSystem.
Public property | Direction | Retrieves or changes the Direction of the BeamSystem.
Public property | Elevation | Retrieves or changes the Elevation of the BeamSystem.
Public property | LayoutRule | Retrieves or changes the LayoutRule of the BeamSystem.
Public property | Level | Get or change the level of the BeamSystem. When the level is changed, the elevation is changed to make the the BeamSystem remain the location.
Public property | Profile | Retrieve or set the profile of the BeamSystem.

See Also

BeamSystem Class

BeamSystem Methods

[image] [image]