Revit 2013 API
LabelUtils..::..GetLabelFor Method (UnitType)
LabelUtils Class See Also Send Feedback
Gets user-visible name for UnitType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static string GetLabelFor(
    UnitType unitType
)
Visual Basic
Public Shared Function GetLabelFor ( _
    unitType As UnitType _
) As String
Visual C++
public:
static String^ GetLabelFor(
    UnitType unitType
)

Parameters

unitType
Type: Autodesk.Revit.DB..::..UnitType
The UnitType to get the user-visible name.

Remarks

The name is obtained in the current Revit language.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when information for the input UnitType cannot be found.

See Also

LabelUtils Class
GetLabelFor Overload

GetLabelFor Method (DuctLossMethodType, Document)

[image]