Revit 2013 API
View3D..::..CreateIsometric Method
View3D Class See Also Send Feedback
Returns a new isometric View3D.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static View3D CreateIsometric(
    Document document,
    ElementId viewFamilyTypeId
)
Visual Basic
Public Shared Function CreateIsometric ( _
    document As Document, _
    viewFamilyTypeId As ElementId _
) As View3D
Visual C++
public:
static View3D^ CreateIsometric(
    Document^ document,
    ElementId^ viewFamilyTypeId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the new View3D will be added.
viewFamilyTypeId
Type: Autodesk.Revit.DB..::..ElementId
The id of the ViewFamilyType which will be used by the new View3D. The type needs to be a ThreeDimensional ViewType.

Return Value

The new isometric View3D.

Remarks

The new View3D will receive a unique view name. The view will be oriented in the same position as the default 3D view.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | This View Family Type is not a ThreeDimensional view type. -or- 3D view creation is not allowed in this family.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

View3D Class

CreatePerspective Method

[image]