Revit 2013 API
ModelCurve Class
Members See Also Send Feedback
A model element that exists in 3D space and is visible in all views of a Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class ModelCurve : CurveElement
Visual Basic
Public Class ModelCurve _
    Inherits CurveElement
Visual C++
public ref class ModelCurve : public CurveElement

Remarks

You can use model curves to represent 3D geometry in a building design, such as cords or cables that secure a tarp.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..CurveElement
Autodesk.Revit.DB..::..ModelCurve
Autodesk.Revit.DB..::..ModelArc
Autodesk.Revit.DB..::..ModelEllipse
Autodesk.Revit.DB..::..ModelHermiteSpline
Autodesk.Revit.DB..::..ModelLine
Autodesk.Revit.DB..::..ModelNurbSpline

See Also

ModelCurve Members

ModelCurve Members

[image] [image]