Revit 2013 API
ExporterIFC..::..SetBuilding Method
ExporterIFC Class See Also Send Feedback
Sets the global IfcBuilding object.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetBuilding(
    IFCAnyHandle building
)
Visual Basic
Public Sub SetBuilding ( _
    building As IFCAnyHandle _
)
Visual C++
public:
void SetBuilding(
    IFCAnyHandle^ building
)

Parameters

building
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The IfcBuilding handle.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace

SetFile Method

[image]