Revit 2013 API
Application..::..CopyModel Method
Application Class See Also Send Feedback
Copies an existing model to a new file. Overwriting a file of the same name is allowed.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void CopyModel(
    ModelPath sourceModelPath,
    string destFilePath,
    bool overwrite
)
Visual Basic
Public Sub CopyModel ( _
    sourceModelPath As ModelPath, _
    destFilePath As String, _
    overwrite As Boolean _
)
Visual C++
public:
void CopyModel(
    ModelPath^ sourceModelPath,
    String^ destFilePath,
    bool overwrite
)

Parameters

sourceModelPath
Type: Autodesk.Revit.DB..::..ModelPath
The path of the file-based or server-based source model.
destFilePath
Type: System..::..String
The path of the destination file.
overwrite
Type: System..::..Boolean
True if the destination file can be overwritten; otherwise, false.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DirectoryNotFoundException | Thrown when the directory of destination file doesn't exist.
Autodesk.Revit.Exceptions..::..FileArgumentAlreadyExistsException | The destination file exists and can't be overwritten. -or- destFilePath is the path of an existing folder, and cannot be overwritten with a copied file.
Autodesk.Revit.Exceptions..::..FileArgumentNotFoundException | The Revit model specified by sourceModelPath doesn't exist.
Autodesk.Revit.Exceptions..::..InvalidPathArgumentException | The destination file name includes one or more invalid characters.
Autodesk.Revit.Exceptions..::..RevitServerCommunicationException | Thrown when there is any network communication error.
Autodesk.Revit.Exceptions..::..RevitServerInternalException | Thrown when there is any server internal error.
Autodesk.Revit.Exceptions..::..RevitServerModelContentionException | Thrown when the server-based source model is being accessed by other users.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace

Dispose Method

[image]