Revit 2013 API
GeometryElement..::..Objects Property
GeometryElement Class See Also Send Feedback
All geometric primitives contained in the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This property will be obsolete from 2013; Call GetEnumerator() instead.")]
public GeometryObjectArray Objects { get; }
Visual Basic
<ObsoleteAttribute("This property will be obsolete from 2013; Call GetEnumerator() instead.")> _
Public ReadOnly Property Objects As GeometryObjectArray
    Get
Visual C++
[ObsoleteAttribute(L"This property will be obsolete from 2013; Call GetEnumerator() instead.")]
public:
property GeometryObjectArray^ Objects {
    GeometryObjectArray^ get ();
}

Remarks

Branching on dynamic type of the objects is advised. Faces and edges are contained in solids and never directly in an element.

See Also

GeometryElement Class

GeometryInstance Class

[image]