Revit 2013 API
Material Properties
Material Class See Also Send Feedback

The Material type exposes the following members.

Properties

 | Name | Description
Public property | Color | The color of the material.
Public property | CutPattern | The cut pattern of the material.
Public property | CutPatternColor | The cut pattern color of the material.
Public property | Glow | Whether the material can glow.
Public property | MaterialClass | The name of the general material type, e.g. 'Wood.'
Public property | RenderAppearance | The rendering appearance property of the material.
Public property | Shininess | The shininess of the material.
Public property | Smoothness | The smoothness of the material.
Public property | StructuralAssetId | The ElementId of the structural PropertySetElement.
Public property | SurfacePattern | The surface pattern of the material.
Public property | SurfacePatternColor | The surface pattern color of the material.
Public property | ThermalAssetId | The ElementId of the thermal PropertySetElement.
Public property | Transparency | The transparency of the material.

See Also

Material Class

Color Property

[image]