Revit 2013 API
AnalyticalModel..::..SetAnalyticalProjectionDatumPlane Method (AnalyticalElementSelector, AnalyticalDirection, ElementId)
AnalyticalModel Class See Also Send Feedback
Sets the datum plane for a given selector and direction.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void SetAnalyticalProjectionDatumPlane(
    AnalyticalElementSelector selector,
    AnalyticalDirection direction,
    ElementId datumPlaneId
)
Visual Basic
Public Sub SetAnalyticalProjectionDatumPlane ( _
    selector As AnalyticalElementSelector, _
    direction As AnalyticalDirection, _
    datumPlaneId As ElementId _
)
Visual C++
public:
void SetAnalyticalProjectionDatumPlane(
    AnalyticalElementSelector selector,
    AnalyticalDirection direction,
    ElementId^ datumPlaneId
)

Parameters

selector
Type: Autodesk.Revit.DB.Structure..::..AnalyticalElementSelector
End of the analytical model.
direction
Type: Autodesk.Revit.DB.Structure..::..AnalyticalDirection
Direction in which analytical model may be projected.
datumPlaneId
Type: Autodesk.Revit.DB..::..ElementId
Datum Plane on to which analytical model may be projected.

Remarks

Applicable for analytical models of linear elements (beams, braces, columns). This Datum Plane identifies a Level, a Grid, or a Ref Plane.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | direction is invalid for analytical model -or- Datum Plane is invalid projection target.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AnalyticalModel Class
SetAnalyticalProjectionDatumPlane Overload
Autodesk.Revit.DB.Structure Namespace

SetAnalyticalProjectionType Method

[image] [image]