Revit 2013 API
Document..::..Delete Method (ElementSet)
Document Class Example See Also Send Feedback
Deletes several elements from the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2013.  Call Delete(System.Collections.Generic.ICollection<Autodesk.Revit.DB.ElementId> elementIds) instead.")]
public ICollection<ElementId> Delete(
    ElementSet elements
)
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2013.  Call Delete(System.Collections.Generic.ICollection<Autodesk.Revit.DB.ElementId> elementIds) instead.")> _
Public Function Delete ( _
    elements As ElementSet _
) As ICollection(Of ElementId)
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2013.  Call Delete(System.Collections.Generic.ICollection<Autodesk.Revit.DB.ElementId> elementIds) instead.")]
public:
ICollection<ElementId^>^ Delete(
    ElementSet^ elements
)

Parameters

elements
Type: Autodesk.Revit.DB..::..ElementSet
A set of elements that are to be deleted.

Return Value

The deleted element id set if the deletion succeeds, or nullNothingnullptra null reference (Nothing in Visual Basic) if the deletion fails.

Remarks

This method will delete the elements and any other elements that are totally dependent upon those elements. Any references to the deleted elements will become invalid and hence cause an exception to be thrown if they are accessed.

Note: in a family document, the predefined elements (those elements inherited from its family template file) can't be deleted by this method.

Examples

CopyC#
// Delete all the selected elements via the set of elements
UIDocument uidoc = new UIDocument(document);
ElementSet elementSet = uidoc.Selection.Elements;
ICollection<Autodesk.Revit.DB.ElementId> deletedIdSet = document.Delete(elementSet);

if (0 == deletedIdSet.Count)
{
    throw new Exception("Deleting the selected elements in Revit failed.");
}

TaskDialog.Show("Revit","The selected element has been removed.");
CopyVB.NET
' Delete all the selected elements via the set of elements
Dim uidoc As New UIDocument(document)
Dim elementSet As ElementSet = uidoc.Selection.Elements
Dim deletedIdSet As ICollection(Of Autodesk.Revit.DB.ElementId) = document.Delete(elementSet)

If 0 = deletedIdSet.Count Then
    Throw New Exception("Deleting the selected elements in Revit failed.")
End If

TaskDialog.Show("Revit", "The selected element has been removed.")

See Also

Document Class
Delete Overload

Dispose Method

[image]