Revit 2013 API
LightType..::..GetLightTypeFromInstance Method
LightType Class See Also Send Feedback
Creates a light type object from the given document and element ID

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static LightType GetLightTypeFromInstance(
    Document document,
    ElementId instanceId
)
Visual Basic
Public Shared Function GetLightTypeFromInstance ( _
    document As Document, _
    instanceId As ElementId _
) As LightType
Visual C++
public:
static LightType^ GetLightTypeFromInstance(
    Document^ document,
    ElementId^ instanceId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document the instanceId is from
instanceId
Type: Autodesk.Revit.DB..::..ElementId
The ID of the light fixture instance

Return Value

The newly created LightType object

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ElementId is the argument that is being validated The ElementId is not valid because it is not for a light element.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

LightType Class
Autodesk.Revit.DB.Lighting Namespace

GetLossFactor Method

[image]