Revit 2013 API
IFCPlacementSetter..::..Create Method (ExporterIFC, Element, Transform, Transform, ElementId)
IFCPlacementSetter Class See Also Send Feedback
Creates a new placement setter instance for the given element with the ability to specific overridden transformations and level id.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static IFCPlacementSetter Create(
    ExporterIFC exporterIFC,
    Element element,
    Transform instanceOffsetTrf,
    Transform orientationTrf,
    ElementId overrideLevelId
)
Visual Basic
Public Shared Function Create ( _
    exporterIFC As ExporterIFC, _
    element As Element, _
    instanceOffsetTrf As Transform, _
    orientationTrf As Transform, _
    overrideLevelId As ElementId _
) As IFCPlacementSetter
Visual C++
public:
static IFCPlacementSetter^ Create(
    ExporterIFC^ exporterIFC,
    Element^ element,
    Transform^ instanceOffsetTrf,
    Transform^ orientationTrf,
    ElementId^ overrideLevelId
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
element
Type: Autodesk.Revit.DB..::..Element
The element.
instanceOffsetTrf
Type: Autodesk.Revit.DB..::..Transform
The offset transformation for the instance of a type. Optional, can be nullNothingnullptra null reference (Nothing in Visual Basic).
orientationTrf
Type: Autodesk.Revit.DB..::..Transform
The orientation transformation for the local coordinates being used to export the element. Optional, can be nullNothingnullptra null reference (Nothing in Visual Basic).
overrideLevelId
Type: Autodesk.Revit.DB..::..ElementId
The level id to reference.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | A transaction is required for this operation.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCPlacementSetter Class
Create Overload
Autodesk.Revit.DB.IFC Namespace

Dispose Method

[image]