Revit 2013 API
UIControlledApplication Members
UIControlledApplication Class Methods Properties Events See Also Send Feedback

The UIControlledApplication type exposes the following members.

Methods

 | Name | Description
Public method | CreateAddInCommandBinding | Creates a new AddInCommandBinding.
Public method | CreateRibbonPanel(String) | Create a new RibbonPanel on the Add-Ins tab.
Public method | CreateRibbonPanel(String, String) | Create a new RibbonPanel on the specified tab.
Public method | CreateRibbonPanel(Tab, String) | Create a new RibbonPanel on the designated standard Revit tab.
Public method | CreateRibbonTab | Creates a new tab on the Revit user interface.
Public method | GetRibbonPanels()()()() | Get all the custom Panels on Add-Ins tab of Revit.
Public method | GetRibbonPanels(String) | Get all the custom Panels on a designated Revit tab.
Public method | GetRibbonPanels(Tab) | Get all the custom Panels on a designated standard Revit tab.
Public method | RemoveAddInCommandBinding | Removes an AddInCommandBinding.

Properties

 | Name | Description
Public property | ActiveAddInId | Get current active external application or external command id.
Public property | ControlledApplication | Returns the database level ControlledApplication represented by this UI-level ControlledApplication.
Public property | LoadedApplications | Returns an array of successfully loaded external applications.

Events

 | Name | Description
Public event | ApplicationClosing | Subscribe to the ApplicationClosing event to be notified when the Revit application is just about to be closed.
Public event | DialogBoxShowing | Subscribe to the DialogBoxShowing event to be notified when Revit is just about to show a dialog box or a message box.
Public event | DisplayingOptionsDialog | Subscribe to the options dialog displaying event to be notified when Revit options dialog is displaying.
Public event | Idling | Subscribe to the Idling event to be notified when Revit is not in an active tool or transaction.
Public event | ViewActivated | Subscribe to the ViewActivated event to be notified immediately after Revit has finished activating a view of a document.
Public event | ViewActivating | Subscribe to the ViewActivating event to be notified when Revit is just about to activate a view of a document.

See Also

UIControlledApplication Class
Autodesk.Revit.UI Namespace

UIControlledApplication Methods

[image] [image]