Revit 2013 API
AdaptiveComponentInstanceUtils Class
Members Example See Also Send Feedback
An interface for Adaptive Component Instances.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class AdaptiveComponentInstanceUtils : IDisposable
Visual Basic
Public Class AdaptiveComponentInstanceUtils _
    Implements IDisposable
Visual C++
public ref class AdaptiveComponentInstanceUtils : IDisposable

Examples

CopyC#
private void CreateAdaptiveComponentInstance(Document document, FamilySymbol symbol)
{
    // Create a new instance of an adaptive component family
    FamilyInstance instance = AdaptiveComponentInstanceUtils.CreateAdaptiveComponentInstance(document, symbol);

    // Get the placement points of this instance
    IList<ElementId> placePointIds = new List<ElementId>();
    placePointIds = AdaptiveComponentInstanceUtils.GetInstancePlacementPointElementRefIds(instance);
    double x = 0;

    // Set the position of each placement point
    foreach (ElementId id in placePointIds)
    {
        ReferencePoint point = document.GetElement(id) as ReferencePoint;
        point.Position = new Autodesk.Revit.DB.XYZ(10*x, 10*Math.Cos(x), 0);
        x += Math.PI/6;
    }
}

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..AdaptiveComponentInstanceUtils

See Also

AdaptiveComponentInstanceUtils Members

AdaptiveComponentInstanceUtils Members

[image] [image]