Revit 2013 API
RebarShapeDefinitionBySegments Members
RebarShapeDefinitionBySegments Class Constructors Methods Properties See Also Send Feedback

The RebarShapeDefinitionBySegments type exposes the following members.

Constructors

 | Name | Description
Public method | RebarShapeDefinitionBySegments | Create a rebar shape definition with a given number of segments.

Methods

 | Name | Description
Public method | AddBendDefaultRadius | Specify a default-radius bend.
Public method | AddBendVariableRadius | Specify a variable-radius bend.
Public method | AddConstraintParallelToSegment | Constrain the length of a segment by parameterizing its length.
Public method | AddConstraintToSegment | Add a constraint that helps determine the length of a segment.
Public method | AddListeningDimensionBendToBend | Specify a dimension between two bends, measured by a read-only parameter.
Public method | AddListeningDimensionSegmentToBend | Specify a dimension perpendicular to one fixed-direction segment, referring to that segment and some other bend in the shape, measured by a read-only parameter.
Public method | AddListeningDimensionSegmentToSegment | Specify a dimension perpendicular to two fixed-direction segments, measured by a read-only parameter.
Public method | GetSegment | Return a reference to one of the segments in the definition.
Public method | GetVertex | Return a reference to one of the vertices in the definition.
Public method | RemoveParameterFromSegment | Remove constraints from an edge.
Public method | SetSegmentAs180DegreeBend(Int32) | Indicates that a segment is a "virtual" segment introduced to describe a 180-degree bend. The radius of the bend will be taken from the Bar Type.
Public method | SetSegmentAs180DegreeBend(Int32, ElementId, Boolean) | Indicate that a segment is a "virtual" segment introduced to describe a 180-degree bend. The radius of the bend will be driven by radiusParam.
Public method | SetSegmentFixedDirection | Fix the direction of a segment.
Public method | SetSegmentVariableDirection | Remove the fixed direction from a segment.

Properties

 | Name | Description
Public property | MajorSegmentIndex | Index of a segment that can be considered the most important. Revit attempts to preserve the orientation of this segment when a Rebar instance changes its RebarShape to one with a different number of segments.
Public property | NumberOfSegments | The number of straight segments in this shape.
Public property | NumberOfVertices | The number of vertices in this shape, always equal to NumberOfSegments + 1.

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.DB.Structure Namespace

RebarShapeDefinitionBySegments Constructor

[image]