Revit 2013 API
AnalyticalLinkType..::..RotationX Property
AnalyticalLinkType Class See Also Send Feedback
Fixity of rotation around X.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public AnalyticalFixityState RotationX { get; set; }
Visual Basic
Public Property RotationX As AnalyticalFixityState
    Get
    Set
Visual C++
public:
property AnalyticalFixityState RotationX {
    AnalyticalFixityState get ();
    void set (AnalyticalFixityState value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The fixity state rotationX is not valid for Analytical Link Type parameters.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

AnalyticalLinkType Class
Autodesk.Revit.DB.Structure Namespace

RotationY Property

[image]