Revit 2013 API
Material..::..SurfacePattern Property
Material Class See Also Send Feedback
The surface pattern of the material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FillPatternElement SurfacePattern { get; set; }
Visual Basic
Public Property SurfacePattern As FillPatternElement
    Get
    Set
Visual C++
public:
property FillPatternElement^ SurfacePattern {
    FillPatternElement^ get ();
    void set (FillPatternElement^ value);
}

Field Value

The surface pattern element, or nullNothingnullptra null reference (Nothing in Visual Basic), if the material does not have an associated surface pattern.

See Also

Material Class

SurfacePatternColor Property

[image]