Revit 2013 API
ExporterIFCRegistry..::..RegisterIFCExporter Method
ExporterIFCRegistry Class See Also Send Feedback
Registers an IFC Exporter with the Revit application.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static void RegisterIFCExporter(
    IExporterIFC exporter
)
Visual Basic
Public Shared Sub RegisterIFCExporter ( _
    exporter As IExporterIFC _
)
Visual C++
public:
static void RegisterIFCExporter(
    IExporterIFC^ exporter
)

Parameters

exporter
Type: Autodesk.Revit.DB.IFC..::..IExporterIFC
Exporter to be registered

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | There is already an IFC exporter registered on the application-level. Only one exporter can be registered in a given session of Revit. Check the journal file for the path of the DLL which was successfully registered as the IFC exporter for the session.

See Also

ExporterIFCRegistry Class
Autodesk.Revit.DB.IFC Namespace

ExporterIFCUtils Class

[image]