Revit 2013 API
Document..::..NewPipe Method (XYZ, XYZ, PipeType)
Document Class Example See Also Send Feedback
Adds a new pipe into the document, using two points and pipe type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Pipe NewPipe(
    XYZ point1,
    XYZ point2,
    PipeType pipeType
)
Visual Basic
Public Function NewPipe ( _
    point1 As XYZ, _
    point2 As XYZ, _
    pipeType As PipeType _
) As Pipe
Visual C++
public:
Pipe^ NewPipe(
    XYZ^ point1,
    XYZ^ point2,
    PipeType^ pipeType
)

Parameters

point1
Type: Autodesk.Revit.DB..::..XYZ
The first point of the pipe.
point2
Type: Autodesk.Revit.DB..::..XYZ
The second point of the pipe.
pipeType
Type: Autodesk.Revit.DB.Plumbing..::..PipeType
The type of the pipe.

Return Value

If creation was successful then a new pipe is returned, otherwise an exception with failure information will be thrown.

Examples

CopyC#
public Pipe CreateNewPipe(Document document)
{
    // find a pipe type

    FilteredElementCollector collector = new FilteredElementCollector(document);
    collector.OfClass(typeof(PipeType));
    PipeType pipeType = collector.FirstElement() as PipeType;

    Pipe pipe = null;
    if (null != pipeType)
    {
        // create pipe between 2 points
        XYZ p1 = new XYZ(0, 0, 0);
        XYZ p2 = new XYZ(10, 0, 0);

        pipe = document.Create.NewPipe(p1, p2, pipeType);
    }

    return pipe;
}
CopyVB.NET
Public Function CreateNewPipe(ByVal document As Document) As Pipe
    ' find a pipe type

    Dim collector As New FilteredElementCollector(document)
    collector.OfClass(GetType(PipeType))
    Dim pipeType As PipeType = TryCast(collector.FirstElement(), PipeType)

    Dim pipe As Pipe = Nothing
    If pipeType IsNot Nothing Then
        ' create pipe between 2 points
        Dim p1 As New XYZ(0, 0, 0)
        Dim p2 As New XYZ(10, 0, 0)

        pipe = document.Create.NewPipe(p1, p2, pipeType)
    End If

    Return pipe
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument point1 or point2 is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the pipe cannot be created or regenerate fails.

See Also

Document Class
NewPipe Overload
Autodesk.Revit.Creation Namespace

NewPipingSystem Method

[image]