Revit 2013 API
AnalyticalModel..::..GetAnalyticalProjectionDatumPlane Method (AnalyticalElementSelector, AnalyticalDirection)
AnalyticalModel Class See Also Send Feedback
Gets the datum plane for a given selector and direction.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementId GetAnalyticalProjectionDatumPlane(
    AnalyticalElementSelector selector,
    AnalyticalDirection direction
)
Visual Basic
Public Function GetAnalyticalProjectionDatumPlane ( _
    selector As AnalyticalElementSelector, _
    direction As AnalyticalDirection _
) As ElementId
Visual C++
public:
ElementId^ GetAnalyticalProjectionDatumPlane(
    AnalyticalElementSelector selector,
    AnalyticalDirection direction
)

Parameters

selector
Type: Autodesk.Revit.DB.Structure..::..AnalyticalElementSelector
End of the analytical model.
direction
Type: Autodesk.Revit.DB.Structure..::..AnalyticalDirection
Direction in which analytical model is projected.

Return Value

Datum Plane on to which analytical model is projected, or invalidElementId if not projected to a Datum Plane.

Remarks

Applicable for analytical models of linear elements (beams, braces, columns). This Datum Plane identifies a Level, a Grid, or a Ref Plane.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | direction is invalid for analytical model

See Also

AnalyticalModel Class
GetAnalyticalProjectionDatumPlane Overload
Autodesk.Revit.DB.Structure Namespace

GetAnalyticalProjectionType Method

[image] [image]