Revit 2013 API
RebarBarType Members
RebarBarType Class Methods Properties See Also Send Feedback

The RebarBarType type exposes the following members.

Methods

 | Name | Description
 | Create | Creates a new RebarBarType object
Public method | GetAutoCalcHookLengths | Identifies if the hook lengths of a hook type are automatically calculated for this bar type
Public method | GetHookLength | Identifies the hook length for a hook type
Public method | GetHookOffsetLength | Identifies the hook offset length for a hook type
Public method | GetHookPermission | Identifies if a hook type is permitted for this bar type
Public method | SetAutoCalcHookLengths | Identifies if the hook lengths of a hook type are automatically calculated for this bar type
Public method | SetHookLength | Identifies the hook length for a hook type
Public method | SetHookOffsetLength | Identifies the hook offset length for a hook type
Public method | SetHookPermission | Identifies if a hook type is permitted for this bar type

Properties

 | Name | Description
Public property | BarDiameter | Defines bar diameter of rebar
Public property | MaximumBendRadius | Defines maximum bend radius of rebar
Public property | StandardBendDiameter | Defines bar bend diameter for rebar whose style is standard
Public property | StandardHookBendDiameter | Defines hook bend diameter for rebar whose style is standard
Public property | StirrupTieBendDiameter | Defines bar and hook bend diameter for rebar whose style is stirrup/tie

See Also

RebarBarType Class
Autodesk.Revit.DB.Structure Namespace

RebarBarType Methods

[image] [image]