Revit 2013 API
ScheduleDefinition..::..CategoryId Property
ScheduleDefinition Class See Also Send Feedback
The category ID of elements appearing in the schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId CategoryId { get; }
Visual Basic
Public ReadOnly Property CategoryId As ElementId
    Get
Visual C++
public:
property ElementId^ CategoryId {
    ElementId^ get ();
}

Field Value

The ID of the schedule's category.

Remarks

Most schedules show elements of a single category. In multi-category schedules, the category ID is InvalidElementId. In key schedules, the the schedule's category is the category of elements that the keys are associated with.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

ScheduleDefinition Class

EmbeddedDefinition Property

[image]