Revit 2013 API
ItemFactoryBase..::..NewFamilyInstance Method (Line, FamilySymbol, View)
ItemFactoryBase Class See Also Send Feedback
Add a line based detail family instance into the Autodesk Revit document, using an line and a view where the instance should be placed.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilyInstance NewFamilyInstance(
    Line line,
    FamilySymbol symbol,
    View specView
)
Visual Basic
Public Function NewFamilyInstance ( _
    line As Line, _
    symbol As FamilySymbol, _
    specView As View _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewFamilyInstance(
    Line^ line,
    FamilySymbol^ symbol,
    View^ specView
)

Parameters

line
Type: Autodesk.Revit.DB..::..Line
The line location of family instance. The line must in the plane of the view.
symbol
Type: Autodesk.Revit.DB..::..FamilySymbol
A family symbol object that represents the type of the instance that is to be inserted.
specView
Type: Autodesk.Revit.DB..::..View
A 2D view in which to display the family instance.

Remarks

This overload applies only to 2D family line based detail symbols. The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when input argument line or symbol or specView is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when input argument line or symbol or specView is invalid, or cannot make such type in the specView, or the line is not in the plane of specView.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when failed to create the instance.

See Also

ItemFactoryBase Class
NewFamilyInstance Overload
Autodesk.Revit.Creation Namespace

NewFamilyInstance Method (Reference, Line, FamilySymbol)

[image]