Revit 2013 API
AnalyticalModelSweptProfile Members
AnalyticalModelSweptProfile Class Methods Properties See Also Send Feedback

The AnalyticalModelSweptProfile type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the AnalyticalModelSweptProfile
Public method | GetDrivingCurve | Provides access to the curve that dictates the path of the swept profile.
Public method | GetSweptProfile | Returns an object that describes the profile that is swept along the driving curve.

Properties

 | Name | Description
Public property | EndSetBack | The distance from the end of the driving curve to the point where the sweep actually ends.
Public property | StartSetBack | The distance from the start of the driving curve to the point where the sweep actually begins.

See Also

AnalyticalModelSweptProfile Class
Autodesk.Revit.DB.Structure Namespace

AnalyticalModelSweptProfile Methods

[image] [image]