Revit 2013 API
ElementMulticlassFilter Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class ElementMulticlassFilter : ElementQuickFilter
Visual Basic
Public Class ElementMulticlassFilter _
    Inherits ElementQuickFilter
Visual C++
public ref class ElementMulticlassFilter : public ElementQuickFilter

Remarks

Only elements whose class is an exact match to the input class, or elements whose type is derived from the input class will pass the collector.

There is a small subset of Element subclasses in the API that are not supported by this filter. These classes exist in the API, but not in Revit's native object model, which means that this filter doesn't support them. In order to use a class filter to find elements of these types, it is necessary to use a higher level class and then process the results further to find elements matching only the subclass. For a list of subclasses affected by this restriction, consult the documentation for ElementClassFilter.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementQuickFilter
Autodesk.Revit.DB..::..ElementMulticlassFilter

See Also

ElementMulticlassFilter Members

ElementMulticlassFilter Members

[image] [image]