Revit 2013 API
DocumentEntryPoint Members
DocumentEntryPoint Class Constructors Methods Properties See Also Send Feedback

The DocumentEntryPoint type exposes the following members.

Constructors

 | Name | Description
Public method | DocumentEntryPoint | Initializes a new instance of the DocumentEntryPoint class

Methods

 | Name | Description
Public method | FinishInitializationEO | For Revit Macros internal use only.
Public method | GetOpenUIViews |
 | GetRevitUIFamilyLoadOptions |
Public method | Initialize | For Revit Macros internal use only.
Public method | OnShutdownEO | For Revit Macros internal use only.
Public method | PromptForFamilyInstancePlacement |
Public method | RefreshActiveView |
Public method | SaveAndClose |
Public method | SaveAs |
Public method | ShowElements(Element) |
Public method | ShowElements(ElementId) |
Public method | ShowElements(ICollection<(Of <<'(ElementId>)>>)) |
Public method | ShowElements(ElementSet) |

Properties

 | Name | Description
Public property | ActiveView |
Public property | AddinFolder | The full path to the Revit Macros module.
Public property | Application |
Public property | Document |
Public property | Selection |

See Also

DocumentEntryPoint Class
Autodesk.Revit.UI.Macros Namespace

DocumentEntryPoint Constructor

[image]