Revit 2013 API
ServerPath Class
Members See Also Send Feedback
This class represents a path to a Revit server location, rather than a location on disk or a network drive.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class ServerPath : ModelPath
Visual Basic
Public Class ServerPath _
    Inherits ModelPath
Visual C++
public ref class ServerPath : public ModelPath

Remarks

ServerPaths must refer to Revit files. ServerPaths are relative to the central server location, and are of the form "Revit Server\{filepath}". The {filename} portion is a relative path to a Revit file. For example: Revit Server\filename.rvt Revit Server\Old Files\filename.rvt and Revit Server\Old Files\Last Week\Tuesday\filename.rvt are all valid server paths. Revit Server\Old Files\.rvt and Revit Server\filename are not valid server paths.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ModelPath
Autodesk.Revit.DB..::..ServerPath

See Also

ServerPath Members

ServerPath Members

[image] [image]