Revit 2013 API
ReferenceIntersector..::..ViewId Property
ReferenceIntersector Class See Also Send Feedback
The 3DView used for intersecting

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId ViewId { get; set; }
Visual Basic
Public Property ViewId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ ViewId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

ReferenceIntersector Class

ReferencePlane Class

[image]