Revit 2013 API
BarDescription..::..Length Property
BarDescription Class See Also Send Feedback
Retrieves the length of a Bar Description.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double Length { get; }
Visual Basic
Public ReadOnly Property Length As Double
    Get
Visual C++
public:
property double Length {
    double get ();
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

BarDescription Class
Autodesk.Revit.DB.Structure Namespace

BoundaryConditionsType Enumeration

[image]