Revit 2013 API
UIApplication..::..OpenAndActivateDocument Method (ModelPath, OpenOptionsForUI)
UIApplication Class See Also Send Feedback
Opens and activates a Revit document.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public UIDocument OpenAndActivateDocument(
    ModelPath modelPath,
    OpenOptionsForUI openOptions
)
Visual Basic
Public Function OpenAndActivateDocument ( _
    modelPath As ModelPath, _
    openOptions As OpenOptionsForUI _
) As UIDocument
Visual C++
public:
UIDocument^ OpenAndActivateDocument(
    ModelPath^ modelPath,
    OpenOptionsForUI^ openOptions
)

Parameters

modelPath
Type: Autodesk.Revit.DB..::..ModelPath
A path to a revit file to be opened. The file can be either a Revit project, template, or family document.
openOptions
Type: Autodesk.Revit.UI..::..OpenOptionsForUI
Options for opening the file.

Remarks

This method, if successful, changes the active document. It is not allowed to have an open transaction in the active document when calling this method. Consequently, this method can only be used in manual transaction mode, not in automatic mode. Additionally, this method may not be called from inside an event handler.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | If nullNothingnullptra null reference (Nothing in Visual Basic) is passed as 'modelPath'.
Autodesk.Revit.Exceptions..::..ArgumentNullException | If nullNothingnullptra null reference (Nothing in Visual Basic) is passed as 'openOptions'.
Autodesk.Revit.Exceptions..::..FileArgumentNotFoundException | The file specified by 'modelPath' cannot be found or the given 'modelPath' is not a Revit file (a project, template, or family document).
Autodesk.Revit.Exceptions..::..ArgumentException | If the modelPath is not a FilePath
Autodesk.Revit.Exceptions..::..InvalidOperationException
  • If the active document is currently modifiable.
  • If an API event handler is currently being executed.

See Also

UIApplication Class
OpenAndActivateDocument Overload
Autodesk.Revit.UI Namespace

RemoveAddInCommandBinding Method

[image]