Revit 2013 API
Element..::..PhaseCreated Property
Element Class Example See Also Send Feedback
An object representing the phase when the element is created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This property is obsolete in 2013. Use CreatedPhaseId instead.")]
public Phase PhaseCreated { get; }
Visual Basic
<ObsoleteAttribute("This property is obsolete in 2013. Use CreatedPhaseId instead.")> _
Public ReadOnly Property PhaseCreated As Phase
    Get
Visual C++
[ObsoleteAttribute(L"This property is obsolete in 2013. Use CreatedPhaseId instead.")]
public:
property Phase^ PhaseCreated {
    Phase^ get ();
}

Remarks

Elements always have a phase for when they are created.

Examples

CopyC#
void ShowPhaseCreatedName(Element element)
{
    // Get the Phase Create property, and assert it should not be null
    Autodesk.Revit.DB.Phase phaseCreated = element.PhaseCreated;
    if (null == phaseCreated)
    {
        throw new Exception("Elements always have a phase for when they are created.");
    }
    else
    {
        // Show the Phase Create name to the user.
        String prompt = "The phase created is: " + phaseCreated.Name;
        TaskDialog.Show("Revit",prompt);
    }
}
CopyVB.NET
Sub ShowPhaseCreatedName(ByVal element As Autodesk.Revit.DB.Element)
    ' Get the Phase Create property, and assert it should not be null
    Dim phaseCreated As Autodesk.Revit.DB.Phase = element.PhaseCreated
    If phaseCreated Is Nothing Then
        Throw New Exception("Elements always have a phase for when they are created.")
    Else
        ' Show the Phase Create name to the user.
        Dim prompt As [String] = "The phase created is: " + phaseCreated.Name
        TaskDialog.Show("Revit", prompt)
    End If
End Sub

See Also

Element Class

PhaseDemolished Property

[image]