Revit 2013 API
CompoundStructure..::..IsCoreLayer Method
CompoundStructure Class See Also Send Feedback
Check if the specified layer is a core layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsCoreLayer(
    int layerIdx
)
Visual Basic
Public Function IsCoreLayer ( _
    layerIdx As Integer _
) As Boolean
Visual C++
public:
bool IsCoreLayer(
    int layerIdx
)

Parameters

layerIdx
Type: System..::..Int32
The index of a layer in this CompoundStructure.

Return Value

Returns true if the number of exterior layers <= layerIdx <= LayerCount - the number of interior layers - 1, and returns false otherwise.

See Also

CompoundStructure Class

IsEqual Method

[image]