Revit 2013 API
Material..::..RenderAppearance Property
Material Class See Also Send Feedback
The rendering appearance property of the material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Asset RenderAppearance { get; set; }
Visual Basic
Public Property RenderAppearance As Asset
    Get
    Set
Visual C++
public:
property Asset^ RenderAppearance {
    Asset^ get ();
    void set (Asset^ value);
}

Field Value

The rendering appearance property, or nullNothingnullptra null reference (Nothing in Visual Basic), if the render library isn't available.

See Also

Material Class

Shininess Property

[image]