Revit 2013 API
Segment Class
Members See Also Send Feedback
Base class for pipe, duct, cable tray and conduit segment. Default constructor Default destructor

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class Segment : Element
Visual Basic
Public Class Segment _
    Inherits Element
Visual C++
public ref class Segment : public Element

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..Segment
Autodesk.Revit.DB.Plumbing..::..PipeSegment

See Also

Segment Members

Segment Members

[image] [image]