Revit 2013 API
ExporterIFCUtils..::..CreateNonCOBIERoomQuantities Method
ExporterIFCUtils Class See Also Send Feedback
Creates the non-COBIE spatial element quantities and adds them to the export.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static void CreateNonCOBIERoomQuantities(
    ExporterIFC exporterIFC,
    IFCAnyHandle spaceHnd,
    SpatialElement roomElem,
    double scaledArea,
    double scaledHeight
)
Visual Basic
Public Shared Sub CreateNonCOBIERoomQuantities ( _
    exporterIFC As ExporterIFC, _
    spaceHnd As IFCAnyHandle, _
    roomElem As SpatialElement, _
    scaledArea As Double, _
    scaledHeight As Double _
)
Visual C++
public:
static void CreateNonCOBIERoomQuantities(
    ExporterIFC^ exporterIFC,
    IFCAnyHandle^ spaceHnd,
    SpatialElement^ roomElem,
    double scaledArea,
    double scaledHeight
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
spaceHnd
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The spatial element handle.
roomElem
Type: Autodesk.Revit.DB..::..SpatialElement
The spatial element.
scaledArea
Type: System..::..Double
The area of the spatial element, in the units of export.
scaledHeight
Type: System..::..Double
The height of the spatial element, in the units of export.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace

CreateOpeningQuantities Method

[image]