Revit 2013 API
PanelScheduleView..::..AddFontId Method
PanelScheduleView Class See Also Send Feedback
Adds a unique combination of font name, size, and color within the table view to the font table

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementId AddFontId(
    string fontName,
    double fontSize,
    Color fontColor
)
Visual Basic
Public Function AddFontId ( _
    fontName As String, _
    fontSize As Double, _
    fontColor As Color _
) As ElementId
Visual C++
public:
ElementId^ AddFontId(
    String^ fontName,
    double fontSize,
    Color^ fontColor
)

Parameters

fontName
Type: System..::..String
The new font's name
fontSize
Type: System..::..Double
The new font's size
fontColor
Type: Autodesk.Revit.DB..::..Color
The new font's color

Return Value

The ElementId of the new font

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace

CreateInstanceView Method

[image] [image]