Revit 2013 API
SunAndShadowSettings..::..TimeInterval Property
SunAndShadowSettings Class See Also Send Feedback
Identifies the time interval between animation frames.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public SunStudyTimeInterval TimeInterval { get; set; }
Visual Basic
Public Property TimeInterval As SunStudyTimeInterval
    Get
    Set
Visual C++
public:
property SunStudyTimeInterval TimeInterval {
    SunStudyTimeInterval get ();
    void set (SunStudyTimeInterval value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: the time interval value interval is not valid for the current SunAndShadowType.

See Also

SunAndShadowSettings Class

TimeZone Property

[image]