Revit 2013 API
ItemFactoryBase..::..NewGroup Method (ICollection<(Of <(<'ElementId>)>)>)
ItemFactoryBase Class See Also Send Feedback
Creates a new type of group.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Group NewGroup(
    ICollection<ElementId> elementIds
)
Visual Basic
Public Function NewGroup ( _
    elementIds As ICollection(Of ElementId) _
) As Group
Visual C++
public:
Group^ NewGroup(
    ICollection<ElementId^>^ elementIds
)

Parameters

elementIds
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
A set of elements which will be made into the new group.

Return Value

A new instance of a group containing the elements specified.

Remarks

  • The new group may contain more members than just the set input to this method. Elements which are closely connected with the inputs (such as sketch and sketch plane) will also be added to the group.
  • Initially the group will have a generic name, such as Group 1. This can be changed by changing the name of the group type as follows: newGroup.GroupType.Name = newName.
  • If a newly-created element is being added to a group, calling document.Regenerate() may be needed to avoid a warning visible in the UI that the group has changed outside group edit mode.

See Also

ItemFactoryBase Class
NewGroup Overload
Autodesk.Revit.Creation Namespace

NewGroup Method (ElementSet)

[image]