Revit 2013 API
Document..::..NewAreaLoad Method (CurveArray, array<Int32>[]()[][], array<Int32>[]()[][], IList<(Of <(<'XYZ>)>)>, Boolean, AreaLoadType)
Document Class See Also Send Feedback
Creates a new unhosted area load with variable forces at the vertices within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public AreaLoad NewAreaLoad(
    CurveArray curvesArr,
    int[] refPntIdxs,
    int[] ends,
    IList<XYZ> forces,
    bool isReaction,
    AreaLoadType symbol
)
Visual Basic
Public Function NewAreaLoad ( _
    curvesArr As CurveArray, _
    refPntIdxs As Integer(), _
    ends As Integer(), _
    forces As IList(Of XYZ), _
    isReaction As Boolean, _
    symbol As AreaLoadType _
) As AreaLoad
Visual C++
public:
AreaLoad^ NewAreaLoad(
    CurveArray^ curvesArr,
    array<int>^ refPntIdxs,
    array<int>^ ends,
    IList<XYZ^>^ forces,
    bool isReaction,
    AreaLoadType^ symbol
)

Parameters

curvesArr
Type: Autodesk.Revit.DB..::..CurveArray
An array of curves that define the shape of the area load curves.
refPntIdxs
Type: array<System..::..Int32>[]()[][]
The indices of the curves in curvesArr that will be used to define the reference points for the load.
ends
Type: array<System..::..Int32>[]()[][]
Identifies which of the curve end points should be used for the reference points, for each member of refPntIdxs. The value should be 0 for the start point or 1 for the end point of the curve.
forces
Type: System.Collections.Generic..::..IList<(Of <(<'XYZ>)>)>
The 3d area forces applied to each of the reference points in the refPntIdxs array.
isReaction
Type: System..::..Boolean
Specifies if the load is a reaction load. The load cannot be modified if isReaction=True.
symbol
Type: Autodesk.Revit.DB.Structure..::..AreaLoadType
The symbol of the AreaLoad.

Return Value

If successful, NewAreaLoad returns an object for the newly created AreaLoad. nullNothingnullptra null reference (Nothing in Visual Basic) is returned if the operation fails.

Remarks

The size of the refPntIdxs, ends, and forces arrays must be the same, and a maximum of 3 values is permitted.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | If the product is not Revit Structure.

See Also

Document Class
NewAreaLoad Overload
Autodesk.Revit.Creation Namespace

NewAreaLoad Method (CurveArray, Int32[], Int32[], XYZ, XYZ, XYZ, Boolean, AreaLoadType)

[image]