Revit 2013 API
RebarShapeConstraintProjectedSegmentLength..::..Direction Property
RebarShapeConstraintProjectedSegmentLength Class See Also Send Feedback
A vector specifying the direction of the constraint. The direction is fixed, and the shape is always constructed so that the segment direction has a positive dot product with this vector.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public UV Direction { get; }
Visual Basic
Public ReadOnly Property Direction As UV
    Get
Visual C++
public:
property UV^ Direction {
    UV^ get ();
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: direction has zero length.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

RebarShapeConstraintProjectedSegmentLength Class
Autodesk.Revit.DB.Structure Namespace

TripleProductSign Property

[image]