Revit 2013 API
AnalysisDisplayStyle Class
Members Example See Also Send Feedback
Exposes API for manipulation of analysis display style.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class AnalysisDisplayStyle : Element
Visual Basic
Public Class AnalysisDisplayStyle _
    Inherits Element
Visual C++
public ref class AnalysisDisplayStyle : public Element

Examples

CopyC#
Document doc = commandData.Application.ActiveUIDocument.Document;

AnalysisDisplayStyle analysisDisplayStyle = null;
// Look for an existing analysis display style with a specific name
FilteredElementCollector collector1 = new FilteredElementCollector(doc);
ICollection<Element> collection = collector1.OfClass(typeof(AnalysisDisplayStyle)).ToElements();
var displayStyle = from element in collection
                   where element.Name == "Display Style 1"
                   select element;

// If display style does not already exist in the document, create it
if (displayStyle.Count() == 0)
{
    AnalysisDisplayColoredSurfaceSettings coloredSurfaceSettings =
        new AnalysisDisplayColoredSurfaceSettings();
    coloredSurfaceSettings.ShowGridLines = true;

    AnalysisDisplayColorSettings colorSettings = new AnalysisDisplayColorSettings();
    Color orange = new Color(255, 205, 0);
    Color purple = new Color(200, 0, 200);
    colorSettings.MaxColor = orange;
    colorSettings.MinColor = purple;

    AnalysisDisplayLegendSettings legendSettings = new AnalysisDisplayLegendSettings();
    legendSettings.NumberOfSteps = 10;
    legendSettings.Rounding = 0.05;
    legendSettings.ShowDataDescription = false;
    legendSettings.ShowLegend = true;

    analysisDisplayStyle = AnalysisDisplayStyle.CreateAnalysisDisplayStyle(doc,
        "Display Style 1", coloredSurfaceSettings, colorSettings, legendSettings);
}
else
{
    analysisDisplayStyle = displayStyle.Cast<AnalysisDisplayStyle>().ElementAt<AnalysisDisplayStyle>(0);
}

// now assign the display style to the view
doc.ActiveView.AnalysisDisplayStyleId = analysisDisplayStyle.Id;
CopyVB.NET
Dim doc As Document = commandData.Application.ActiveUIDocument.Document

Dim analysisDisplayStyl As Autodesk.Revit.DB.Analysis.AnalysisDisplayStyle = Nothing
' Look for an existing analysis display style with a specific name
Dim collector1 As New Autodesk.Revit.DB.FilteredElementCollector(doc)
Dim collection As ICollection(Of Autodesk.Revit.DB.Element) = collector1.OfClass(GetType(Autodesk.Revit.DB.Analysis.AnalysisDisplayStyle)).ToElements()
Dim displayStyle As System.Collections.Generic.IEnumerable(Of Autodesk.Revit.DB.Element)
displayStyle = From element In collection _
 Where element.Name = "Display Style 1" _
 Select element

' If display style does not already exist in the document, create it
If displayStyle.Count() = 0 Then
    Dim coloredSurfaceSettings As New Autodesk.Revit.DB.Analysis.AnalysisDisplayColoredSurfaceSettings()
    coloredSurfaceSettings.ShowGridLines = True

    Dim colorSettings As New Autodesk.Revit.DB.Analysis.AnalysisDisplayColorSettings()
    Dim orange As New Color(255, 205, 0)
    Dim purple As New Color(200, 0, 200)
    colorSettings.MaxColor = orange
    colorSettings.MinColor = purple

    Dim legendSettings As New Autodesk.Revit.DB.Analysis.AnalysisDisplayLegendSettings()
    legendSettings.NumberOfSteps = 10
    legendSettings.Rounding = 0.05
    legendSettings.ShowDataDescription = False
    legendSettings.ShowLegend = True

    Dim collector2 As New Autodesk.Revit.DB.FilteredElementCollector(doc)
    Dim elementCollection As ICollection(Of Autodesk.Revit.DB.Element) = collector2.OfClass(GetType(TextNoteType)).ToElements()
    Dim textElements As System.Collections.Generic.IEnumerable(Of Autodesk.Revit.DB.Element)
    textElements = From element In collector2 _
     Where element.Name = "LegendText" _
     Select element

    ' if LegendText exists, use it for this Display Style
    If textElements.Count() > 0 Then
        Dim textType As TextNoteType = textElements.Cast(Of TextNoteType)().ElementAt(0)
        legendSettings.SetTextTypeId(textType.Id, doc)
    End If
    analysisDisplayStyl = Autodesk.Revit.DB.Analysis.AnalysisDisplayStyle.CreateAnalysisDisplayStyle(doc, "Display Style 1", coloredSurfaceSettings, colorSettings, legendSettings)
Else
    analysisDisplayStyl = displayStyle.Cast(Of Autodesk.Revit.DB.Analysis.AnalysisDisplayStyle)().ElementAt(0)
End If

' now assign the display style to the view
doc.ActiveView.AnalysisDisplayStyleId = analysisDisplayStyl.Id

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB.Analysis..::..AnalysisDisplayStyle

See Also

AnalysisDisplayStyle Members
Autodesk.Revit.DB.Analysis Namespace

AnalysisDisplayStyle Members

[image] [image]