Revit 2013 API
SpatialElementCalculationPoint Class
Members See Also Send Feedback
A Spatial Element Calculation Point is used as a search point for room and space relations for all instances of this family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class SpatialElementCalculationPoint : Element
Visual Basic
Public Class SpatialElementCalculationPoint _
    Inherits Element
Visual C++
public ref class SpatialElementCalculationPoint : public Element

Remarks

The Spatial Element Calculation Point is graphically showed as a location point marker with a "snake" line from the origin of the family. If the Spatial Element Calculation Point is turned on, this point will be used as a search point for room and space relations for all instances of this family. A user can turn on the Spatial Element Calculation Point in the family editor. An application can turn on the Spatial Element Calculation Point by setting the family's ROOM_CALCULATION_POINT parameter. A user can move the location of the Spatial Element Calculation Point in the family editor. A user can visually verify the location of the Spatial Element Calculation Point by selecting the fixture in the project.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..SpatialElementCalculationPoint

See Also

SpatialElementCalculationPoint Members

SpatialElementCalculationPoint Members

[image] [image]