Revit 2013 API
EnergyDataSettings..::..ServiceType Property
EnergyDataSettings Class See Also Send Feedback
The type of heating or cooling system.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public gbXMLServiceType ServiceType { get; set; }
Visual Basic
Public Property ServiceType As gbXMLServiceType
    Get
    Set
Visual C++
public:
property gbXMLServiceType ServiceType {
    gbXMLServiceType get ();
    void set (gbXMLServiceType value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The service type does not fall within an appropriate range.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace

ShadeDepth Property

[image]