Revit 2013 API
ProfiledWallCreationData Constructor (CurveArray, WallType, Level, Boolean)
ProfiledWallCreationData Class See Also Send Feedback
Initializes a new instance of the ProfiledWallCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ProfiledWallCreationData(
    CurveArray profile,
    WallType wallType,
    Level level,
    bool structural
)
Visual Basic
Public Sub New ( _
    profile As CurveArray, _
    wallType As WallType, _
    level As Level, _
    structural As Boolean _
)
Visual C++
public:
ProfiledWallCreationData(
    CurveArray^ profile,
    WallType^ wallType,
    Level^ level,
    bool structural
)

Parameters

profile
Type: Autodesk.Revit.DB..::..CurveArray
An array of planar lines and arcs that represent the vertical profile of the wall.
wallType
Type: Autodesk.Revit.DB..::..WallType
A wall type to be used by the new wall instead of the default type.
level
Type: Autodesk.Revit.DB..::..Level
The level on which the wall is to be placed.
structural
Type: System..::..Boolean
If set, specifies that the wall is structural in nature.

See Also

ProfiledWallCreationData Class
ProfiledWallCreationData Overload
Autodesk.Revit.Creation Namespace

ProfiledWallCreationData Constructor (CurveArray, WallType, Level, Boolean, XYZ)

[image]