Revit 2013 API
ViewFamilyType..::..DefaultTemplateId Property
ViewFamilyType Class See Also Send Feedback
Default template id. It will be the view template for all newly created instances of this view type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId DefaultTemplateId { get; set; }
Visual Basic
Public Property DefaultTemplateId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ DefaultTemplateId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: val is not valid as default template id.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

ViewFamilyType Class

Parameter Property

[image] [image]