Revit 2013 API
Document Methods
Document Class See Also Send Feedback

The Document type exposes the following members.

Methods

 | Name | Description
Public method | AutoJoinElements | Forces the elements in the Revit document to automatically join to their neighbors where appropriate.
Public method | Close()()()() | Closes the document, save the changes if there are.
Public method | Close(Boolean) | Closes the document with the option to save.
Public method | CombineElements | Combine a set of combinable elements into a geometry combination.
Public method | ConvertDetailToModelCurves | Converts a group of DetailCurves to equivalent ModelCurves.
Public method | ConvertModelToDetailCurves | Converts a group of ModelCurves to equivalent DetailCurves.
Public method | ConvertModelToSymbolicCurves | Converts a group of ModelCurves to equivalent SymbolicCurves.
Public method | ConvertSymbolicToModelCurves | Converts a group of SymbolicCurves to equivalent ModelCurves.
Public method | Delete(Element) | Deletes an element from the document.
Public method | Delete(ElementId) | Deletes an element from the document given the id of that element.
Public method | Delete(ICollection<(Of <<'(ElementId>)>>)) | Deletes several elements from the document given their ids.
Public method | Delete(ElementSet) | Obsolete. Deletes several elements from the document.
Public method | Dispose |
Public method | EditFamily | Gets the document of a loaded family to edit.
Public method | Equals | Determines whether the specified Object equals to this Object. (Overrides Object..::..Equals(Object).)
Public method | Export(String, String, MassGBXMLExportOptions) | Exports a gbXML file from a mass model document.
Public method | Export(String, String, GBXMLExportOptions) | Exports the document in Green-Building XML format.
Public method | Export(String, String, IFCExportOptions) | Exports the document to the Industry Standard Classes (IFC) format.
Public method | Export(String, String, ViewSet, DWFExportOptions) | Exports the current view or a selection of views in DWF format.
Public method | Export(String, String, ViewSet, DWFXExportOptions) | Exports the current view or a selection of views in DWFX format.
Public method | Export(String, String, ViewSet, FBXExportOptions) | Exports the document in 3D-Studio Max (FBX) format.
Public method | Export(String, String, ViewSet, SATExportOptions) | Exports the current view or a selection of views in SAT format.
Public method | Export(String, String, ICollection<(Of <<'(ElementId>)>>), DGNExportOptions) | Exports a selection of views in DGN format.
Public method | Export(String, String, ICollection<(Of <<'(ElementId>)>>), DWGExportOptions) | Exports a selection of views in DWG format.
Public method | Export(String, String, ICollection<(Of <<'(ElementId>)>>), DXFExportOptions) | Exports a selection of views in DXF format.
Public method | Export(String, String, View3D, ViewPlan, BuildingSiteExportOptions) | Exports the document in the format of Civil Engineering design applications.
Public method | ExportImage | Exports a view or set of views into an image file.
Public method | FindReferencesWithContextByDirection | Finds the references that intersect a line extended in a certain direction from an origin point.
Public method | GetDocumentPreviewSettings | Returns the preview settings for the given document.
Public method | GetElement(String) | Gets the Element referenced by the input string name.
Public method | GetElement(ElementId) | Gets the Element referenced by the input string name.
Public method | GetElement(Reference) | Gets the Element referenced by the input reference.
Public method | GetHashCode | Gets the hash code of this document instance. (Overrides Object..::..GetHashCode()()()().)
Public method | GetPrintSettingIds | Retrieves all Print Settings of current project.
Public method | GetRoomAtPoint(XYZ) | Gets a room containing the point.
Public method | GetRoomAtPoint(XYZ, Phase) | Gets a room containing the point.
Public method | GetSpaceAtPoint(XYZ) | Gets a space containing the point.
Public method | GetSpaceAtPoint(XYZ, Phase) | Gets a space containing the point.
Public method | GetWorksetId | Get Id of the Workset which owns the element.
Public method | GetWorksetTable | Get the WorksetTable of this document.
Public method | GetWorksharingCentralModelPath | Gets the central model path of the worksharing model.
Public method | Import(String, GBXMLImportOptions) | Imports a Green-Building XML file into the document.
Public method | Import(String, DGNImportOptions, View, ElementId%) | Imports a DGN file to the document.
Public method | Import(String, DWGImportOptions, View, ElementId%) | Imports a DWG or DXF file to the document.
Public method | Import(String, ImageImportOptions, View, Element%) | Imports an image (a bitmap) into the document.
Public method | Link(String, DGNImportOptions, View, ElementId%) | Links a DGN file to the document.
Public method | Link(String, DWGImportOptions, View, ElementId%) | Links a DWG or DXF file to the document.
Public method | LoadFamily(String) | Loads an entire family and all its types/symbols into the document.
Public method | LoadFamily(Document) | Loads the contents of this family document into another document.
Public method | LoadFamily(String, Family%) | Loads an entire family and all its types/symbols into the document and provides a reference to the loaded family.
Public method | LoadFamily(Document, IFamilyLoadOptions) | Loads the contents of this family document into another document.
Public method | LoadFamily(String, IFamilyLoadOptions, Family%) | Loads an entire family and all its types/symbols into the document and provides a reference to the loaded family.
Public method | LoadFamilySymbol(String, String) | Loads only a specified family type/symbol from a family file into the document.
Public method | LoadFamilySymbol(String, String, FamilySymbol%) | Loads only the specified family type/symbol from a family file into the document and provides a reference to the loaded family symbol.
Public method | LoadFamilySymbol(String, String, IFamilyLoadOptions, FamilySymbol%) | Loads only the specified family type/symbol from a family file into the document and provides a reference to the loaded family symbol.
Public method | PostFailure | Posts a failure to be displayed to the user at the end of transaction.
Public method | Print(ViewSet) | Prints a set of views with default view template and default print settings.
Public method | Print(ViewSet, View) | Prints a set of views with a specified view template and default print settings.
Public method | Print(ViewSet, Boolean) | Prints a set of views with default view template and default print settings.
Public method | Print(ViewSet, View, Boolean) | Prints a set of views with a specified view template and default print settings.
Public method | Regenerate | Updates the elements in the Revit document to reflect all changes.
Public method | Save()()()() | Saves the document.
Public method | Save(SaveOptions) | Saves the document.
Public method | SaveAs(String) | Saves the document to a given file name.
Public method | SaveAs(String, SaveAsOptions) | Saves the document to a given file name with options to change the document's name in Revit and overwrite an existing file.
Public method | SaveToProjectAsImage | Creates an image view from the currently active view.
Public method | SeparateElements | Separate a set of combinable elements out of combinations they currently belong to.
Public method | UnpostFailure | Deletes the posted failure message associated with a given FailureMessageKey.

See Also

Document Class

AutoJoinElements Method

[image]