Revit 2013 API
Rebar..::..RebarShape Property
Rebar Class See Also Send Feedback
Get/Set the RebarShape associated with the Rebar.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This property is obsolete in Revit 2013. Use the RebarShapeId property instead.")]
public RebarShape RebarShape { get; set; }
Visual Basic
<ObsoleteAttribute("This property is obsolete in Revit 2013. Use the RebarShapeId property instead.")> _
Public Property RebarShape As RebarShape
    Get
    Set
Visual C++
[ObsoleteAttribute(L"This property is obsolete in Revit 2013. Use the RebarShapeId property instead.")]
public:
property RebarShape^ RebarShape {
    RebarShape^ get ();
    void set (RebarShape^ value);
}

Remarks

When set, the instance will choose values for its shape parameters to try to preserve its previous shape.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace

RebarShapeId Property

[image]