Revit 2013 API
SunAndShadowSettings..::..IsLevelValid Method
SunAndShadowSettings Class See Also Send Feedback
Checks whether the element represents a valid level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsLevelValid(
    ElementId levelId
)
Visual Basic
Public Function IsLevelValid ( _
    levelId As ElementId _
) As Boolean
Visual C++
public:
bool IsLevelValid(
    ElementId^ levelId
)

Parameters

levelId
Type: Autodesk.Revit.DB..::..ElementId
Level element id.

Return Value

True if the element is a valid Level, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

SunAndShadowSettings Class

IsTimeIntervalValid Method

[image]