Revit 2013 API
BindingMap..::..ReInsert Method (Definition, Binding, BuiltInParameterGroup)
BindingMap Class See Also Send Feedback
Removes an existing parameter and creates a new binding for a given parameter in a specified group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool ReInsert(
    Definition key,
    Binding item,
    BuiltInParameterGroup parameterGroup
)
Visual Basic
Public Overridable Function ReInsert ( _
    key As Definition, _
    item As Binding, _
    parameterGroup As BuiltInParameterGroup _
) As Boolean
Visual C++
public:
virtual bool ReInsert(
    Definition^ key,
    Binding^ item,
    BuiltInParameterGroup parameterGroup
)

Parameters

key
Type: Autodesk.Revit.DB..::..Definition
A parameter definition which can be an existing definition or one from a shared parameters file.
item
Type: Autodesk.Revit.DB..::..Binding
An InstanceBinding or TypeBinding object which contains the set of categories to which the parameter should be bound.
parameterGroup
Type: Autodesk.Revit.DB..::..BuiltInParameterGroup
The GroupID of the parameter definition.

Remarks

Note the type of the binding object dictates whether the parameter is bound to all instances or just types. A parameter definition cannot be bound to both instances and types. If the parameter binding already exists, remove the binding, create a new parameter binding. If the parameter binding related to the input key doesn't exist in the database, ReInsert will fail and false will be returned. In this case, Insert should be called.

See Also

BindingMap Class
ReInsert Overload

Remove Method

[image]