Revit 2013 API
SchedulableField..::..FieldType Property
SchedulableField Class See Also Send Feedback
The type of data displayed by the field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ScheduleFieldType FieldType { get; set; }
Visual Basic
Public Property FieldType As ScheduleFieldType
    Get
    Set
Visual C++
public:
property ScheduleFieldType FieldType {
    ScheduleFieldType get ();
    void set (ScheduleFieldType value);
}

Field Value

See ScheduleFieldType for details.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: fieldType is a calculated field type (Formula or Percentage).

See Also

SchedulableField Class

ParameterId Property

[image]