Revit 2013 API
FamilyStructuralMaterialTypeFilter Constructor (StructuralMaterialType)
FamilyStructuralMaterialTypeFilter Class See Also Send Feedback
Constructs a new instance of a filter to match families that have the given structural material type.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FamilyStructuralMaterialTypeFilter(
    StructuralMaterialType structuralMaterialType
)
Visual Basic
Public Sub New ( _
    structuralMaterialType As StructuralMaterialType _
)
Visual C++
public:
FamilyStructuralMaterialTypeFilter(
    StructuralMaterialType structuralMaterialType
)

Parameters

structuralMaterialType
Type: Autodesk.Revit.DB.Structure..::..StructuralMaterialType
The structural material type to match.

See Also

FamilyStructuralMaterialTypeFilter Class
FamilyStructuralMaterialTypeFilter Overload
Autodesk.Revit.DB.Structure Namespace

FamilyStructuralMaterialTypeFilter Constructor (StructuralMaterialType, Boolean)

[image]