Revit 2013 API
FamilyParameter..::..GUID Property
FamilyParameter Class Example See Also Send Feedback
The globally unique identifier

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public Guid GUID { get; }
Visual Basic
Public ReadOnly Property GUID As Guid
    Get
Visual C++
public:
property Guid GUID {
    Guid get ();
}

Examples

CopyC#
foreach (FamilyParameter familyParam in familyDoc.FamilyManager.Parameters)
{
    string familyParamName = familyParam.Definition.Name;
    try
    {
        Guid guid = familyParam.GUID;
        TaskDialog.Show("Revit",familyParamName + " is shared. Guid is " + guid);
    }
    catch (System.Exception)
    {
        TaskDialog.Show("Revit",familyParamName + " is NOT shared");
    }
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the parameter is not a shared parameter.

See Also

FamilyParameter Class

Id Property

[image]