Revit 2013 API
RebarInSystem..::..BarsOnNormalSide Property
RebarInSystem Class See Also Send Feedback
Identifies if the bars of the rebar set are on the same side of the rebar plane indicated by the normal.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool BarsOnNormalSide { get; }
Visual Basic
Public ReadOnly Property BarsOnNormalSide As Boolean
    Get
Visual C++
public:
property bool BarsOnNormalSide {
    bool get ();
}

Field Value

True if the bars of rebar set are on the same side of the rebar plane indicated by the normal, and false if the bars are on the opposite side.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InapplicableDataException | This rebar element represents a single bar (the layout rule is Single).

See Also

RebarInSystem Class
Autodesk.Revit.DB.Structure Namespace

LayoutRule Property

[image]