Revit 2013 API
IFCPlacementSetter..::..Create Method (ExporterIFC, Element)
IFCPlacementSetter Class See Also Send Feedback
Creates a new placement setter instance for the given element.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static IFCPlacementSetter Create(
    ExporterIFC exporterIFC,
    Element element
)
Visual Basic
Public Shared Function Create ( _
    exporterIFC As ExporterIFC, _
    element As Element _
) As IFCPlacementSetter
Visual C++
public:
static IFCPlacementSetter^ Create(
    ExporterIFC^ exporterIFC,
    Element^ element
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
element
Type: Autodesk.Revit.DB..::..Element
The element.

Return Value

The placement setter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | A transaction is required for this operation.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCPlacementSetter Class
Create Overload
Autodesk.Revit.DB.IFC Namespace

Create Method (ExporterIFC, Element, Transform, Transform, ElementId)

[image]