Revit 2013 API
IFCExtrusionCalculatorUtils..::..CalculateExtrusionData Method (IFCExtrusionCalculatorOptions, IList<(Of <(<'Face>)>)>)
IFCExtrusionCalculatorUtils Class See Also Send Feedback
Calculates the extrusion data from a collection of Revit geometry faces.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static IList<IFCExtrusionData> CalculateExtrusionData(
    IFCExtrusionCalculatorOptions extrInfo,
    IList<Face> allInputFaces
)
Visual Basic
Public Shared Function CalculateExtrusionData ( _
    extrInfo As IFCExtrusionCalculatorOptions, _
    allInputFaces As IList(Of Face) _
) As IList(Of IFCExtrusionData)
Visual C++
public:
static IList<IFCExtrusionData^>^ CalculateExtrusionData(
    IFCExtrusionCalculatorOptions^ extrInfo,
    IList<Face^>^ allInputFaces
)

Parameters

extrInfo
Type: Autodesk.Revit.DB.IFC..::..IFCExtrusionCalculatorOptions
The options for extrusion extraction.
allInputFaces
Type: System.Collections.Generic..::..IList<(Of <(<'Face>)>)>
The collection of faces.

Return Value

A collection of extrusion data calculated for the geometry. If the function fails to calculate one or more valid extrusions, this collection will be empty.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCExtrusionCalculatorUtils Class
CalculateExtrusionData Overload
Autodesk.Revit.DB.IFC Namespace

Dispose Method

[image]