Revit 2013 API
IFCStairRampContainerInfo..::..AddComponent Method
IFCStairRampContainerInfo Class See Also Send Feedback
Adds a handle to one of the contained component lists.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void AddComponent(
    int index,
    IFCAnyHandle hnd
)
Visual Basic
Public Sub AddComponent ( _
    index As Integer, _
    hnd As IFCAnyHandle _
)
Visual C++
public:
void AddComponent(
    int index,
    IFCAnyHandle^ hnd
)

Parameters

index
Type: System..::..Int32
The component list index.
hnd
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The handle.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCStairRampContainerInfo Class
Autodesk.Revit.DB.IFC Namespace

AddStairRampContainerInfo Method

[image]