Revit 2013 API
PropertySetLibrary Members
PropertySetLibrary Class Methods Properties See Also Send Feedback

The PropertySetLibrary type exposes the following members.

Methods

 | Name | Description
Public method | AddPropertySet | Adds a property set from the document to this library.
Public method | AddPropertySetWithName | Adds a property set from the document to this library using an alternate name.
Public method | AddToDocument | Adds a property set from a library to the document. The property set will be available for use even if the library is unloaded.
Public method | AddToDocumentWithName | Adds a property set from a library to the document. The property set will be available for use even if the library is unloaded.
 | Create | Creates a new property set library in the given document.
Public method | ExportXml | Export this property set library to an external, XML-based file.
 | Find | Finds an existing PropertySetLibrary with a given name.
Public method | GetName |
Public method | HasPropertySet | Determines whether the library has a property set with a given name.
 | ImportXml | Import an external property set library into a Revit document.
Public method | RemovePropertySet | Removes a property set with a given name from the library.
Public method | RenamePropertySet | Renames a property set in the library.
Public method | RenameSubclass | Changes the subclass field of all property sets in this library from one value to another.
Public method | SetName |

Properties

 | Name | Description
Public property | Locked | Indicates whether a property set library is locked into a document or not. Locked libraries are read-only and cannot be removed.
Public property | ReadOnly | Indicates whether a property set library is read-only or not. Read-only libraries cannot be renamed, or added to.

See Also

PropertySetLibrary Class

PropertySetLibrary Methods

[image] [image]