Revit 2013 API
IFCTypeInfo Properties
IFCTypeInfo Class See Also Send Feedback

The IFCTypeInfo type exposes the following members.

Properties

 | Name | Description
Public property | MaterialId | The material id associated with this type.
Public property | ScaledArea | The area of the type's cross-section, scaled into the units of export.
Public property | ScaledDepth | The depth of the type, scaled into the units of export.
Public property | ScaledInnerPerimeter | The inner perimeter of the boundaries of the type's cross-section, scaled into the units of export.
Public property | ScaledOuterPerimeter | The outer perimeter of the boundaries of the type's cross-section, scaled into the units of export.

See Also

IFCTypeInfo Class
Autodesk.Revit.DB.IFC Namespace

MaterialId Property

[image]