Revit 2013 API
Element..::..Level Property
Element Class Example See Also Send Feedback
If the element is level based then level to which the element is assigned is returned.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Level Level { get; }
Visual Basic
Public Overridable ReadOnly Property Level As Level
    Get
Visual C++
public:
virtual property Level^ Level {
    Level^ get ();
}

Remarks

A number of elements use a level as a base reference, such as a column.

Examples

CopyC#
private void GetLevelInformation(Autodesk.Revit.DB.Element element)
{
    // Get the level object to which the element is assigned.
    Level level = element.Level;
    if (null == level)
    {
        TaskDialog.Show("Revit","The element isn't based on a level.");
    }
    else
    {
        // Format the prompt information(Name and elevation)
        String prompt = "The element is based on a level.";
        prompt += "\nThe level name is:  " + level.Name;
        prompt += "\nThe level elevation is:  " + level.Elevation;

        // Show the information to the user.
        TaskDialog.Show("Revit",prompt);
    }
}
CopyVB.NET
Private Sub GetLevelInformation(ByVal element As Autodesk.Revit.DB.Element)
    ' Get the level object to which the element is assigned.
    Dim level As Level = element.Level
    If level Is Nothing Then
        TaskDialog.Show("Revit", "The element isn't based on a level.")
    Else
        ' Format the prompt information(Name and elevation)
        Dim prompt As [String] = "The element is based on a level."
        prompt += vbLf & "The level name is:  " + level.Name
        prompt += vbLf & "The level elevation is:  " + level.Elevation

        ' Show the information to the user.
        TaskDialog.Show("Revit", prompt)
    End If
End Sub

See Also

Element Class

Location Property

[image]