Revit 2013 API
IFCPlacementSetter Methods
IFCPlacementSetter Class See Also Send Feedback

The IFCPlacementSetter type exposes the following members.

Methods

 | Name | Description
 | Create(ExporterIFC, Element) | Creates a new placement setter instance for the given element.
 | Create(ExporterIFC, Element, Transform, Transform, ElementId) | Creates a new placement setter instance for the given element with the ability to specific overridden transformations and level id.
Public method | Dispose |
Public method | GetLevelInfo | Gets the level info related to the element's local placement.
Public method | GetOffsetLevelInfoAndHandle | Gets the level info related to an offset of the element's local placement.
Public method | GetPlacement | Gets the handle to the IfcLocalPlacement stored with this setter.
Public method | UpdateRoomRelativeCoordinates | Obtains the handle to an alternate local placement for a room-related element.

See Also

IFCPlacementSetter Class
Autodesk.Revit.DB.IFC Namespace

Create Method

[image] [image]