Revit 2013 API
RevitLinkType..::..AttachmentType Property
RevitLinkType Class See Also Send Feedback
The attachment/overlay status of this link.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public AttachmentType AttachmentType { get; }
Visual Basic
Public ReadOnly Property AttachmentType As AttachmentType
    Get
Visual C++
public:
property AttachmentType AttachmentType {
    AttachmentType get ();
}

Field Value

AttachmentType.Overlay if this link is an overlay, AttachmentType.Attachment if this link is an attachment.

Remarks

"Attachment" links are considered to be part of their parent link and will be brought along if their parent is linked into another document. "Overlay" links are only visible when their parent is open directly. For example: A user has a file B which contains a link C, and they wish to link B into another file, A. If C is an overlay, C will not be loaded into A. If C is an attachment, then C will be loaded into A along with B.

See Also

RevitLinkType Class

IsNestedLink Property

[image]