Revit 2013 API
Rebar..::..BarType Property
Rebar Class See Also Send Feedback
Return the type of the rebar.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This property is obsolete in Revit 2013. Use GetTypeId and ChangeTypeId instead.")]
public RebarBarType BarType { get; set; }
Visual Basic
<ObsoleteAttribute("This property is obsolete in Revit 2013. Use GetTypeId and ChangeTypeId instead.")> _
Public Property BarType As RebarBarType
    Get
    Set
Visual C++
[ObsoleteAttribute(L"This property is obsolete in Revit 2013. Use GetTypeId and ChangeTypeId instead.")]
public:
property RebarBarType^ BarType {
    RebarBarType^ get ();
    void set (RebarBarType^ value);
}

Remarks

Returns a RebarBarType element that defines bar diameter and bend radius for the rebar.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace

BaseFinishingTurns Property

[image]