Revit 2013 API
Material Class
Members Example See Also Send Feedback
Represents a material element within an Autodesk Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class Material : Element
Visual Basic
Public Class Material _
    Inherits Element
Visual C++
public ref class Material : public Element

Remarks

This is the parent class for concrete material subclasses. Currently, the supported materials are wood, steel, generic, concrete and other.

Examples

CopyC#
private void GetMaterialInformation(Material material)
{
    StringBuilder message = new StringBuilder("Material : " + material.Name);
    //color of the material
    message.Append(string.Format("\nColor: Red[{0}]; Green[{1}]; Blue[{2}]",
                    material.Color.Red, material.Color.Green, material.Color.Blue));

    //cut pattern and pattern color of the material
    if (null != material.CutPattern)
    {
        message.Append("\nCut Pattern: " + material.CutPattern.Name);
        message.Append(string.Format("\nCut Pattern Color: Red[{0}]; Green[{1}]; Blue[{2}]",
                        material.CutPatternColor.Red, material.CutPatternColor.Green, material.CutPatternColor.Blue));
    }

    //surface pattern and pattern color of the material
    if (null != material.SurfacePattern)
    {
        message.Append("\nSurface Pattern: " + material.SurfacePattern.Name);
        message.Append(string.Format("\nSurface Pattern Color: Red[{0}]; Green[{1}]; Blue[{2}]",
                        material.SurfacePatternColor.Red, material.SurfacePatternColor.Green, material.SurfacePatternColor.Blue));
    }

    //some shading property of the material
    bool glow = material.Glow;
    message.Append("\nMaterial can glow: " + glow);
    int shininess = material.Shininess;
    message.Append("\nShininess: " + shininess);
    int smoothness = material.Smoothness;
    message.Append("\nSmoothness: " + smoothness);
    int transparency = material.Transparency;
    message.Append("\nTransparency: " + transparency);

    TaskDialog.Show("Revit",message.ToString());
}
CopyVB.NET
Private Sub GetMaterialInformation(ByVal material As Autodesk.Revit.DB.Material)
    Dim message As New StringBuilder("Material : " + material.Name)
    'color of the material
    message.Append(String.Format(vbLf & "Color: Red[{0}]; Green[{1}]; Blue[{2}]", material.Color.Red, material.Color.Green, material.Color.Blue))

    'cut pattern and pattern color of the material
    If material.CutPattern IsNot Nothing Then
        message.Append(vbLf & "Cut Pattern: " + material.CutPattern.Name)
        message.Append(String.Format(vbLf & "Cut Pattern Color: Red[{0}]; Green[{1}]; Blue[{2}]", material.CutPatternColor.Red, material.CutPatternColor.Green, material.CutPatternColor.Blue))
    End If

    'surface pattern and pattern color of the material
    If material.SurfacePattern IsNot Nothing Then
        message.Append(vbLf & "Surface Pattern: " + material.SurfacePattern.Name)
        message.Append(String.Format(vbLf & "Surface Pattern Color: Red[{0}]; Green[{1}]; Blue[{2}]", material.SurfacePatternColor.Red, material.SurfacePatternColor.Green, material.SurfacePatternColor.Blue))
    End If

    'some shading property of the material
    Dim glow As Boolean = material.Glow
    message.Append(vbLf & "Material can glow: " + glow)
    Dim shininess As Integer = material.Shininess
    message.Append(vbLf & "Shininess: " + shininess)
    Dim smoothness As Integer = material.Smoothness
    message.Append(vbLf & "Smoothness: " + smoothness)
    Dim transparency As Integer = material.Transparency
    message.Append(vbLf & "Transparency: " + transparency)

    TaskDialog.Show("Revit", message.ToString())
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..Material

See Also

Material Members

Material Members

[image] [image]