Revit 2013 API
LightType..::..SetInitialColor Method
LightType Class See Also Send Feedback
Replace the current initial color object with the given object

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetInitialColor(
    InitialColor initialColor
)
Visual Basic
Public Sub SetInitialColor ( _
    initialColor As InitialColor _
)
Visual C++
public:
void SetInitialColor(
    InitialColor^ initialColor
)

Parameters

initialColor
Type: Autodesk.Revit.DB.Lighting..::..InitialColor
An object derived from an InitialColor object The object pointed to is cloned internally

Remarks

The argument object is cloned

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

LightType Class
Autodesk.Revit.DB.Lighting Namespace

SetInitialIntensity Method

[image]