Revit 2013 API
Connector Members
Connector Class Methods Properties See Also Send Feedback

The Connector type exposes the following members.

Methods

 | Name | Description
Public method | ConnectTo | Make connection between two connectors.
Public method | DisconnectFrom | Remove connection between two connectors.
Public method | Dispose | Releases all resources used by the Connector
Public method | IsConnectedTo | Identifies if the connector is connected to the specified connector.

Properties

 | Name | Description
Public property | AllRefs | All references of the connector.
Public property | Angle | The angle of the Connector.
Public property | AssignedDuctFlowConfiguration | The assigned duct flow configuration of the connector.
Public property | AssignedDuctLossMethod | The duct loss method of the connector.
Public property | AssignedFixtureUnits | The assigned fixture units of the connector.
Public property | AssignedFlow | The assigned flow of the connector.
Public property | AssignedFlowDirection | The assigned flow direction of the connector.
Public property | AssignedFlowFactor | The assigned flow factor of this connector.
Public property | AssignedKCoefficient | The assigned kCoefficient of the connector.
Public property | AssignedLossCoefficient | The assigned loss coefficient of the connector.
Public property | AssignedPipeFlowConfiguration | The pipe flow configuration type of the connector.
Public property | AssignedPipeLossMethod | The pipe loss method of the connector.
Public property | AssignedPressureDrop | The assigned pressure drop of the connector.
Public property | Coefficient | The coefficient of the connector.
Public property | ConnectorManager | The connector manager of the connector.
Public property | ConnectorType | The connector type of the connector.
Public property | CoordinateSystem | The coordinate system of the connector.
Public property | Demand | The demand of the connector.
Public property | Direction | The direction of the connector.
Public property | Domain | The domain of the connector.
Public property | DuctSystemType | The duct system type of the connector.
Public property | ElectricalSystemType | The electrical system type of the connector.
Public property | EngagementLength | Connector engagement length
Public property | Flow | The flow of the connector.
Public property | GenderType | Connector gender type
Public property | Height | The height of the connector.
Public property | IsConnected | Identifies if the connector is physically connected to a connector on another element.
Public property | IsMovable | whether the connector can be moved.
Public property | JointType | Connector joint type
Public property | MEPSystem | The system of the connector belong to.
Public property | Origin | The location of the connector.
Public property | Owner | The host of the connector.
Public property | PipeSystemType | The pipe system type of the connector.
Public property | PressureDrop | The pressure drop of the connector.
Public property | Radius | The radius of the connector.
Public property | Shape | The shape of the connector.
Public property | VelocityPressure | The velocity pressure of the connector.
Public property | Width | The width of the connector.

See Also

Connector Class

Connector Methods

[image] [image]