Revit 2013 API
Application..::..NewProjectDocument Method
Application Class See Also Send Feedback
New project document

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Document NewProjectDocument(
    string templateFileName
)
Visual Basic
Public Overridable Function NewProjectDocument ( _
    templateFileName As String _
) As Document
Visual C++
public:
virtual Document^ NewProjectDocument(
    String^ templateFileName
)

Parameters

templateFileName
Type: System..::..String
The template file name.

Remarks

This command corresponds to New->Project command in the user-interface.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | If 'templateFileName' is nullNothingnullptra null reference (Nothing in Visual Basic) or an empty string.
Autodesk.Revit.Exceptions..::..InvalidOperationException | If the new project document cannot be created.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace

NewProjectTemplateDocument Method

[image]