Revit 2013 API
UIApplication Events
UIApplication Class See Also Send Feedback

The UIApplication type exposes the following members.

Events

 | Name | Description
Public event | ApplicationClosing | Subscribe to the ApplicationClosing event to be notified when the Revit application is just about to be closed.
Public event | DialogBoxShowing | Subscribe to the DialogBoxShowing event to be notified when Revit is just about to show a dialog box or a message box.
Public event | DisplayingOptionsDialog | Subscribe to the options dialog displaying event to be notified when Revit options dialog is displaying.
Public event | Idling | Subscribe to the Idling event to be notified when Revit is not in an active tool or transaction.
Public event | ViewActivated | Subscribe to the ViewActivated event to be notified immediately after Revit has finished activating a view of a document.
Public event | ViewActivating | Subscribe to the ViewActivating event to be notified when Revit is just about to activate a view of a document.

See Also

UIApplication Class
Autodesk.Revit.UI Namespace

ApplicationClosing Event

[image]