Revit 2013 API
AreaTagTypeSet Members
AreaTagTypeSet Class Constructors Methods Properties See Also Send Feedback

The AreaTagTypeSet type exposes the following members.

Constructors

 | Name | Description
Public method | AreaTagTypeSet | Initializes a new instance of the AreaTagTypeSet class

Methods

 | Name | Description
Public method | Clear | Removes every areatag type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a areatag type within the set.
Public method | Erase | Removes a specified areatag type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | Insert | Insert the specified areatag type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | Size | Returns the number of areatag types that are in the set.

See Also

AreaTagTypeSet Class

AreaTagTypeSet Constructor

[image]