Revit 2013 API
ExternalDefinition Properties
ExternalDefinition Class See Also Send Feedback

The ExternalDefinition type exposes the following members.

Properties

 | Name | Description
Public property | GUID | Returns the GUID associated with the shared parameter definition.
Public property | Name | The user visible name for the parameter. (Overrides Definition..::..Name.)
Public property | OwnerGroup | Returns or change the group ID of the external parameter definition.
Public property | ParameterGroup | Returns the group ID of the parameter definition. (Overrides Definition..::..ParameterGroup.)
Public property | ParameterType | Returns the user visible interpretation of the parameter data. (Overrides Definition..::..ParameterType.)
Public property | Visible | Indicates if the parameter is visible in the Autodesk Revit user interface.

See Also

ExternalDefinition Class

GUID Property

[image]