Revit 2013 API
Material..::..Shininess Property
Material Class See Also Send Feedback
The shininess of the material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int Shininess { get; set; }
Visual Basic
Public Property Shininess As Integer
    Get
    Set
Visual C++
public:
property int Shininess {
    int get ();
    void set (int value);
}

Field Value

The value ranges from 0 to 128. If trying to set the value out of the range, ArgumentException will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: values for shininess must be between 0 and 128

See Also

Material Class

Smoothness Property

[image]