Revit 2013 API
AssemblyViewUtils..::..CreateDetailSection Method
AssemblyViewUtils Class See Also Send Feedback
Creates a new detail section assembly view for the assembly instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static ViewSection CreateDetailSection(
    Document document,
    ElementId assemblyInstanceId,
    AssemblyDetailViewOrientation direction
)
Visual Basic
Public Shared Function CreateDetailSection ( _
    document As Document, _
    assemblyInstanceId As ElementId, _
    direction As AssemblyDetailViewOrientation _
) As ViewSection
Visual C++
public:
static ViewSection^ CreateDetailSection(
    Document^ document,
    ElementId^ assemblyInstanceId,
    AssemblyDetailViewOrientation direction
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the view will be added.
assemblyInstanceId
Type: Autodesk.Revit.DB..::..ElementId
Id of the assembly instance that owns the new view.
direction
Type: Autodesk.Revit.DB..::..AssemblyDetailViewOrientation
The direction for the new view.

Return Value

A new detail section assembly view.

Remarks

The detail section will cut through the center of the assembly instance's outline. The document must be regenerated before using the detail section.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | assemblyInstanceId is not an AssemblyInstance.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AssemblyViewUtils Class

CreateMaterialTakeoff Method

[image]