Revit 2013 API
PhaseFilter..::..GetPhaseStatusPresentation Method
PhaseFilter Class See Also Send Feedback
Gets the phase status presentation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public PhaseStatusPresentation GetPhaseStatusPresentation(
    ElementOnPhaseStatus status
)
Visual Basic
Public Function GetPhaseStatusPresentation ( _
    status As ElementOnPhaseStatus _
) As PhaseStatusPresentation
Visual C++
public:
PhaseStatusPresentation GetPhaseStatusPresentation(
    ElementOnPhaseStatus status
)

Parameters

status
Type: Autodesk.Revit.DB..::..ElementOnPhaseStatus
The element phase status.

Return Value

The phase status presentation.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | status is invalid for presentation query.

See Also

PhaseFilter Class

SetPhaseStatusPresentation Method

[image]