Revit 2013 API
CurveElement..::..GeometryCurve Property
CurveElement Class See Also Send Feedback
Geometry curve of the curve element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Curve GeometryCurve { get; set; }
Visual Basic
Public Property GeometryCurve As Curve
    Get
    Set
Visual C++
public:
property Curve^ GeometryCurve {
    Curve^ get ();
    void set (Curve^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when try to set a curve of different type.

See Also

CurveElement Class

LineStyle Property

[image]