Revit 2013 API
FabricWireType..::..WireDiameter Property
FabricWireType Class See Also Send Feedback
Determines the diameter of the wire. This should be positive lesser than 1.0.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double WireDiameter { get; set; }
Visual Basic
Public Property WireDiameter As Double
    Get
    Set
Visual C++
public:
property double WireDiameter {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The given value for wireDiameter is not a number
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The wire diameter wireDiameter is negative or greater than 1.0.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

FabricWireType Class
Autodesk.Revit.DB.Structure Namespace

FamilyStructuralMaterialTypeFilter Class

[image]