Revit 2013 API
RenderingSettings..::..LightingSource Property
RenderingSettings Class See Also Send Feedback
The lighting scheme type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public LightingSource LightingSource { get; set; }
Visual Basic
Public Property LightingSource As LightingSource
    Get
    Set
Visual C++
public:
property LightingSource LightingSource {
    LightingSource get ();
    void set (LightingSource value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The enum value is not valid for Lighting.

See Also

RenderingSettings Class

PrinterResolution Property

[image]