Revit 2013 API
Element..::..DemolishedPhaseId Property
Element Class See Also Send Feedback
Id of a Phase at which the Element was demolished.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId DemolishedPhaseId { get; set; }
Visual Basic
Public Property DemolishedPhaseId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ DemolishedPhaseId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Remarks

After setting the property DemolishedPhaseId regeneration can fail if CreatedPhaseId and DemolishedPhaseId are out of order, i.e. their index in the property Document.Phases. Can be set to invalid element id.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The element does not allow setting the property DemolishedPhaseId to the value of demolishedPhaseId.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The element does not have properties CreatedPhaseId and DemolishedPhaseId. -or- When setting this property: The element does not allow setting the properties CreatedPhaseId and DemolishedPhaseId.

See Also

Element Class

DesignOption Property

[image]