Revit 2013 API
ItemFactoryBase..::..NewAnnotationSymbol Method
ItemFactoryBase Class See Also Send Feedback
Add a new instance of an Annotation Symbol into the Autodesk Revit document, using an origin and a view where the instance should be placed.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This method is deprecated in Revit 2013.  Use NewFamilyInstance(XYZ, FamilySymbol, View)  to place any view-based family instance including annotation symbols.")]
public AnnotationSymbol NewAnnotationSymbol(
    XYZ origin,
    AnnotationSymbolType annotationSymbolType,
    View specView
)
Visual Basic
<ObsoleteAttribute("This method is deprecated in Revit 2013.  Use NewFamilyInstance(XYZ, FamilySymbol, View)  to place any view-based family instance including annotation symbols.")> _
Public Function NewAnnotationSymbol ( _
    origin As XYZ, _
    annotationSymbolType As AnnotationSymbolType, _
    specView As View _
) As AnnotationSymbol
Visual C++
[ObsoleteAttribute(L"This method is deprecated in Revit 2013.  Use NewFamilyInstance(XYZ, FamilySymbol, View)  to place any view-based family instance including annotation symbols.")]
public:
AnnotationSymbol^ NewAnnotationSymbol(
    XYZ^ origin,
    AnnotationSymbolType^ annotationSymbolType,
    View^ specView
)

Parameters

origin
Type: Autodesk.Revit.DB..::..XYZ
The origin of the annotation symbol. If created on ViewPlan, the origin will be projected onto the ViewPlan.
annotationSymbolType
Type: Autodesk.Revit.DB..::..AnnotationSymbolType
An annotation symbol type that represents the type of the instance that is to be inserted.
specView
Type: Autodesk.Revit.DB..::..View
A 2D view in which to display the annotation symbol.

Return Value

If creation was successful then an instance to the new object is returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods. The location may be different from its origin on ViewPlane.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | One or more required arguments was nullNothingnullptra null reference (Nothing in Visual Basic)
Autodesk.Revit.Exceptions..::..ArgumentException | The input view was not 2D.

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace

NewDetailCurve Method

[image]