Revit 2013 API
Family Class
Members Example See Also Send Feedback
The Family object defines an entire family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class Family : FamilyBase
Visual Basic
Public Class Family _
    Inherits FamilyBase
Visual C++
public ref class Family : public FamilyBase

Remarks

This object gets the family symbols that belong to the family so that instances can be swapped from one symbol to another. Families within the Revit API represented by three objects - Family, FamilySymbol and FamilyInstance. Each object plays a significant part in the structure of Families. The Family object represents the entire family such as an 'I Beam'. You can think of that object as representing the entire family file on disk. The Family object contains a number of FamilySymbols. The FamilySymbol object represents a specific set of family settings within that Family and represents what is known in the Revit user interface as a Type, such as 'W14x32'. The FamilyInstance object represents an actual instance of that Type (FamilySymbol) within the Autodesk Revit project. For example the FamilyInstance would be a single instance of a W14x32 column within the project. Therefore: Each FamilyInstance has one FamilySymbol, e.g. an instance of a W14x32. Each FamilySymbol belongs to one Family, e.g. the W14x32 symbol belongs to an 'I Beam' family. Each Family will contain one or more FamilySymbols, e.g. the 'I Beam' family contains a W14x32 symbol, a W12x32 symbol etc.

Examples

CopyC#
public void GetInfoForSymbols(Family family)
{
    StringBuilder message = new StringBuilder("Selected element's family name is : " + family.Name);

    if (family.Symbols.IsEmpty)
    {
        message.AppendLine("Contains no family symbols.");
    }
    else
    {
        message.AppendLine("The family symbols contained in this family are : ");

        // Get family symbols which is contained in this family
        foreach (FamilySymbol familySymbol in family.Symbols)
        {
            // Get family symbol name
            message.AppendLine("\nName: " + familySymbol.Name);
           foreach (Material material in familySymbol.Materials)
           {
            message.AppendLine("\tMaterial: " + material.Name);
           }
        }
    }

    TaskDialog.Show("Revit",message.ToString());
}
CopyVB.NET
Public Sub GetInfoForSymbols(ByVal family As Autodesk.Revit.DB.Family)
    Dim message As New StringBuilder("Selected element's family name is : " + family.Name)

    If family.Symbols.IsEmpty Then
        message.AppendLine("Contains no family symbols.")
    Else
        message.AppendLine("The family symbols contained in this family are : ")

        ' Get family symbols which is contained in this family
        For Each familySymbol As Autodesk.Revit.DB.FamilySymbol In family.Symbols
            ' Get family symbol name
            message.AppendLine(vbLf & "Name: " + familySymbol.Name)
            For Each material As Autodesk.Revit.DB.Material In familySymbol.Materials
                message.AppendLine(vbTab & "Material: " + material.Name)
            Next
        Next
    End If

    TaskDialog.Show("Revit", message.ToString())
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..FamilyBase
Autodesk.Revit.DB..::..Family

See Also

Family Members

Family Members

[image] [image]