Revit 2013 API
UpdaterRegistry..::..RegisterUpdater Method (IUpdater, Document, Boolean)
UpdaterRegistry Class See Also Send Feedback
Registers the updater for the specified document

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static void RegisterUpdater(
    IUpdater updater,
    Document doc,
    bool isOptional
)
Visual Basic
Public Shared Sub RegisterUpdater ( _
    updater As IUpdater, _
    doc As Document, _
    isOptional As Boolean _
)
Visual C++
public:
static void RegisterUpdater(
    IUpdater^ updater,
    Document^ doc,
    bool isOptional
)

Parameters

updater
Type: Autodesk.Revit.DB..::..IUpdater
Updater to be registered
doc
Type: Autodesk.Revit.DB..::..Document
Document for which this updater is registered
isOptional
Type: System..::..Boolean
Kind of the updater

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Updater's Id is not valid.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | updater is already registered for this document or on the application level -or- updater's owner AddIn does not match currently active AddIn i.e. IUpdater::getUpdaterId()::getAddInId() != add-in's addInId field in the manifest file -or- RegisterUpdater called while executing an updater.

See Also

UpdaterRegistry Class
RegisterUpdater Overload

RemoveAllTriggers Method

[image]