Revit 2013 API
AnalyticalModelSketchComponent..::..IsValidAnalyticalAlignmentMethod Method
AnalyticalModelSketchComponent Class See Also Send Feedback
Indicates whether Analytical Alignment Method is valid for Sketch Component.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsValidAnalyticalAlignmentMethod(
    AnalyticalAlignmentMethod alignmentMethod
)
Visual Basic
Public Function IsValidAnalyticalAlignmentMethod ( _
    alignmentMethod As AnalyticalAlignmentMethod _
) As Boolean
Visual C++
public:
bool IsValidAnalyticalAlignmentMethod(
    AnalyticalAlignmentMethod alignmentMethod
)

Parameters

alignmentMethod
Type: Autodesk.Revit.DB.Structure..::..AnalyticalAlignmentMethod
Analytical Alignment Method preset to test for validity.

Return Value

True means alignment method is valid, false otherwise.

See Also

AnalyticalModelSketchComponent Class
Autodesk.Revit.DB.Structure Namespace

IsValidAnalyticalProjectionType Method

[image]