Revit 2013 API
ExporterIFCUtils..::..CreateCurveFromCurveLoop Method
ExporterIFCUtils Class See Also Send Feedback
Creates an IFCCurve from a Curve Loop, projected onto a plane.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static IFCAnyHandle CreateCurveFromCurveLoop(
    ExporterIFC exporterIFC,
    CurveLoop curveLoop,
    Plane plane,
    XYZ projDir
)
Visual Basic
Public Shared Function CreateCurveFromCurveLoop ( _
    exporterIFC As ExporterIFC, _
    curveLoop As CurveLoop, _
    plane As Plane, _
    projDir As XYZ _
) As IFCAnyHandle
Visual C++
public:
static IFCAnyHandle^ CreateCurveFromCurveLoop(
    ExporterIFC^ exporterIFC,
    CurveLoop^ curveLoop,
    Plane^ plane,
    XYZ^ projDir
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
curveLoop
Type: Autodesk.Revit.DB..::..CurveLoop
The curve loop.
plane
Type: Autodesk.Revit.DB..::..Plane
The plane to project the curve onto.
projDir
Type: Autodesk.Revit.DB..::..XYZ
The projection direction.

Return Value

The handle.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace

CreateDoorPropertySet Method

[image]