Revit 2013 API
AnalysisResultSchema Members
AnalysisResultSchema Class Constructors Methods Properties See Also Send Feedback

The AnalysisResultSchema type exposes the following members.

Constructors

 | Name | Description
Public method | AnalysisResultSchema(AnalysisResultSchema) | Initializes a new instance of the AnalysisResultSchema class
Public method | AnalysisResultSchema(String, String) | Creates object and assigns name and description

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the AnalysisResultSchema
Public method | GetNumberOfUnits | returns number of possible units
Public method | GetUnitsMultiplier | returns units multiplier by index
Public method | GetUnitsName | returns units name by index
Public method | IsEqual |
Public method | SetUnits | Sets names and multipliers of all units for result visualization

Properties

 | Name | Description
Public property | AnalysisDisplayStyleId | ElementId of analysis display style overriding the style set for view; -1 if the style is not overridden
Public property | CurrentUnits | Stores the index in the array of applicable units
Public property | Description | Description of analysis result in view
Public property | IsVisible | If true analysis result is visible in view
Public property | Name | Name of analysis result in view
Public property | Scale | Multiplier used for displaying diagram or vector values in view.

See Also

AnalysisResultSchema Class
Autodesk.Revit.DB.Analysis Namespace

AnalysisResultSchema Constructor

[image] [image]