Revit 2013 API
PreEventArgs Class
Members See Also Send Feedback
The class is used as a base class for the arguments for any pre-event.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class PreEventArgs : RevitEventArgs
Visual Basic
Public Class PreEventArgs _
    Inherits RevitEventArgs
Visual C++
public ref class PreEventArgs : public RevitEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Autodesk.Revit.DB.Events..::..RevitEventArgs
Autodesk.Revit.DB.Events..::..PreEventArgs
Autodesk.Revit.DB.Events..::..PreDocEventArgs
Autodesk.Revit.UI.Events..::..ApplicationClosingEventArgs
Autodesk.Revit.UI.Events..::..DialogBoxShowingEventArgs
Autodesk.Revit.UI.Events..::..DisplayingOptionsDialogEventArgs
Autodesk.Revit.UI.Events..::..IdlingEventArgs

See Also

PreEventArgs Members
Autodesk.Revit.DB.Events Namespace

PreEventArgs Members

[image] [image]