Revit 2013 API
Document..::..NewWall Method (CurveArray, Boolean)
Document Class See Also Send Feedback
Creates a non rectangular profile wall within the project using the default wall type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2013. Please call a static creation method of Wall class instead.")]
public Wall NewWall(
    CurveArray profile,
    bool structural
)
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2013. Please call a static creation method of Wall class instead.")> _
Public Function NewWall ( _
    profile As CurveArray, _
    structural As Boolean _
) As Wall
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2013. Please call a static creation method of Wall class instead.")]
public:
Wall^ NewWall(
    CurveArray^ profile,
    bool structural
)

Parameters

profile
Type: Autodesk.Revit.DB..::..CurveArray
An array of planar lines and arcs that represent the vertical profile of the wall.
structural
Type: System..::..Boolean
If set, specifies that the wall is structural in nature.

Return Value

If successful a new wall object within the project, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Document Class
NewWall Overload
Autodesk.Revit.Creation Namespace

NewWall Method (Curve, Level, Boolean)

[image]