Revit 2013 API
Application Members
Application Class Methods Properties See Also Send Feedback

The Application type exposes the following members.

Methods

 | Name | Description
Public method | NewArc(XYZ, XYZ, XYZ) | Creates a new geometric arc object based on three points.
Public method | NewArc(Plane, Double, Double, Double) | Creates a new geometric arc object based on plane, radius, and angles.
Public method | NewArc(XYZ, Double, Double, Double, XYZ, XYZ) | Creates a new geometric arc object based on center, radius, unit vectors, and angles.
Public method | NewAreaCreationData | Creates an object which wraps the arguments of Area for batch creation.
Public method | NewBoundingBoxUV()()()() | Creates an empty two-dimensional rectangle.
Public method | NewBoundingBoxUV(Double, Double, Double, Double) | Creates a two-dimensional rectangle with supplied values.
Public method | NewBoundingBoxXYZ | Creates a three-dimensional rectangular box.
Public method | NewBuildingSiteExportOptions | Creates Building Site Export options.
Public method | NewCategorySet | Creates a new instance of a set specifically for holding category objects.
Public method | NewColor | Returns a new color object.
Public method | NewCombinableElementArray | Returns an array that can hold combinable element objects.
Public method | NewCurveArrArray | Creates an empty array that can store geometric curve loops.
Public method | NewCurveArray | Creates an empty array that can store geometric curves.
Public method | NewCurveLoopsProfile | Creates a new CurveLoopsProfile object.
Public method | NewDoubleArray | Creates a new instance of a double array.
Public method | NewDWFExportOptions | Creates DWF Export options.
Public method | NewDWFXExportOptions | Creates DWFX Export options.
Public method | NewElementArray | Obsolete. Returns an array that can hold element objects.
Public method | NewElementId | Creates a new Autodesk::Revit::DB::ElementId^ object.
Public method | NewElementSet | Creates a new instance of a set specifically for holding elements.
Public method | NewEllipse | Creates a new geometric ellipse object.
Public method | NewFaceArray | Creates a new instance of a face array.
Public method | NewFamilyInstanceCreationData(Face, Line, FamilySymbol) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method | NewFamilyInstanceCreationData(XYZ, FamilySymbol, StructuralType) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method | NewFamilyInstanceCreationData(Curve, FamilySymbol, Level, StructuralType) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method | NewFamilyInstanceCreationData(Face, XYZ, XYZ, FamilySymbol) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method | NewFamilyInstanceCreationData(XYZ, FamilySymbol, Element, StructuralType) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method | NewFamilyInstanceCreationData(XYZ, FamilySymbol, Level, StructuralType) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method | NewFamilyInstanceCreationData(XYZ, FamilySymbol, Element, Level, StructuralType) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method | NewFamilyInstanceCreationData(XYZ, FamilySymbol, XYZ, Element, StructuralType) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method | NewFamilySymbolProfile | Creates a new FamilySymbolProfile object.
Public method | NewFBXExportOptions | Creates 3D-Studio Max (FBX) Export options.
Public method | NewGBXMLExportOptions | Creates Green-Building XML Export options.
Public method | NewGBXMLImportOptions | Creates Green-Building XML Import options.
Public method | NewGeometryOptions | Creates an object to specify user preferences in parsing of geometry.
Public method | NewHermiteSpline(IList<(Of <<'(XYZ>)>>), Boolean) | Creates a Hermite spline with default tangency at its endpoints.
Public method | NewHermiteSpline(IList<(Of <<'(XYZ>)>>), Boolean, XYZ, XYZ) | Creates a Hermite spline with specified tangency at its endpoints.
Public method | NewImageImportOptions | Creates Image Import options.
Public method | NewInstanceBinding()()()() | Creates a new empty instance binding object.
Public method | NewInstanceBinding(CategorySet) | Creates a new instance binding object containing the categories passed as a parameter.
Public method | NewIntersectionResultArray | Creates a new instance of an IntersectionResult array.
Public method | NewLine | Creates a new bound or unbounded geometric line object.
Public method | NewLineBound | Creates a new bounded geometric line object.
Public method | NewLineUnbound | Creates a new unbounded geometric line object.
Public method | NewLoadCaseArray | Creates a new instance of a LoadCase array.
Public method | NewLoadCombinationArray | Creates a new instance of a LoadCombination array.
Public method | NewLoadUsageArray | Creates a new instance of a LoadUsage array.
Public method | NewMaterialSet | Obsolete. Create a new instance of MaterialSet.
Public method | NewNurbSpline(IList<(Of <<'(XYZ>)>>), IList<(Of <<'(Double>)>>)) | Creates a new geometric NurbSpline object using the same calculations that Revit uses when sketching splines in the user interface.
Public method | NewNurbSpline(IList<(Of <<'(XYZ>)>>), DoubleArray, DoubleArray, Int32, Boolean, Boolean) | Creates a new geometric nurbSpline object.
Public method | NewPlane(CurveArray) | Creates a new geometric plane from a loop of planar curves.
Public method | NewPlane(XYZ, XYZ) | Creates a new geometric plane object based on a normal vector and an origin.
Public method | NewPlane(XYZ, XYZ, XYZ) | Creates a new geometric plane object based on two coordinate vectors and an origin.
Public method | NewPoint | Creates a new geometric point object.
Public method | NewPointOnEdge | Create a PointOnEdge object which is used to define the placement of a ReferencePoint.
Public method | NewPointOnEdgeEdgeIntersection | Construct a PointOnEdgeEdgeIntersection object which is used to define the placement of a ReferencePoint given two references to edge.
Public method | NewPointOnEdgeFaceIntersection | Construct a PointOnEdgeFaceIntersection object which is used to define the placement of a ReferencePoint given a references to edge and a reference to face.
Public method | NewPointOnFace | Construct a PointOnFace object which is used to define the placement of a ReferencePoint given a reference and a location on the face.
Public method | NewPointOnPlane | Construct a PointOnPlane object which is used to define the placement of a ReferencePoint from its property values.
Public method | NewPointRelativeToPoint | Create a PointRelativeToPoint object, which is used to define the placement of a ReferencePoint relative to a host point.
Public method | NewProfiledWallCreationData(CurveArray, Boolean) | Creates an object which wraps the arguments of NewWall() for batch creation
Public method | NewProfiledWallCreationData(CurveArray, WallType, Level, Boolean) | Creates an object which wraps the arguments of NewWall() for batch creation
Public method | NewProfiledWallCreationData(CurveArray, WallType, Level, Boolean, XYZ) | Creates an object which wraps the arguments of NewWall() for batch creation
Public method | NewProjectPosition | Creates a new project position object.
Public method | NewRectangularWallCreationData(Curve, Level, Boolean) | Creates an object which wraps the arguments of NewWall() for batch creation
Public method | NewRectangularWallCreationData(Curve, WallType, Level, Double, Double, Boolean, Boolean) | Creates an object which wraps the arguments of NewWall() for batch creation
Public method | NewReferenceArray | Creates a new instance of a reference array.
Public method | NewReferencePointArray | Creates an empty array that can store ReferencePoint objects.
Public method | NewRoomCreationData | Creates an object which wraps the arguments of NewRoom() for batch creation.
Public method | NewSATExportOptions | Creates SAT Export options.
Public method | NewSpaceSet | Creates a new instance of a space set.
Public method | NewStringStringMap | Creates a new map that maps one string to another string.
Public method | NewTextNoteCreationData(View, XYZ, XYZ, XYZ, Double, TextAlignFlags, String) | Creates an object which wraps the arguments of NewTextNote() for batch creation.
Public method | NewTextNoteCreationData(View, XYZ, XYZ, XYZ, Double, TextAlignFlags, TextNoteLeaderTypes, TextNoteLeaderStyles, XYZ, XYZ, String) | Creates an object which wraps the arguments of NewTextNote() for batch creation.
Public method | NewTypeBinding()()()() | Creates a new empty type binding object.
Public method | NewTypeBinding(CategorySet) | Creates a new type binding object containing the categories passed as a parameter.
Public method | NewUV()()()() | Creates a UV object at the origin.
Public method | NewUV(UV) | Creates a UV object by copying the supplied UV object.
Public method | NewUV(Double, Double) | Creates a UV object representing coordinates in 2-space with supplied values.
Public method | NewVertexIndexPair | Creates a new VertexIndexPair object.
Public method | NewVertexIndexPairArray | Returns an array that can hold VertexIndexPair objects.
Public method | NewViewSet | Creates a new instance of a View set.
Public method | NewVolumeCalculationOptions | Creates options related to room volume and area computations.
Public method | NewXYZ()()()() | Creates a XYZ object at the origin.
Public method | NewXYZ(XYZ) | Creates a XYZ object by copying the supplied XYZ object.
Public method | NewXYZ(Double, Double, Double) | Creates a XYZ object representing coordinates in 3-space with supplied values.

Properties

 | Name | Description

See Also

Application Class
Autodesk.Revit.Creation Namespace

Application Methods

[image] [image]