Revit 2013 API
IFCPlacementSetter..::..UpdateRoomRelativeCoordinates Method
IFCPlacementSetter Class See Also Send Feedback
Obtains the handle to an alternate local placement for a room-related element.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementId UpdateRoomRelativeCoordinates(
    Element element,
    out IFCAnyHandle placementToUse
)
Visual Basic
Public Function UpdateRoomRelativeCoordinates ( _
    element As Element, _
    <OutAttribute> ByRef placementToUse As IFCAnyHandle _
) As ElementId
Visual C++
public:
ElementId^ UpdateRoomRelativeCoordinates(
    Element^ element,
    [OutAttribute] IFCAnyHandle^% placementToUse
)

Parameters

element
Type: Autodesk.Revit.DB..::..Element
The element.
placementToUse
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle%
The handle to the IfcLocalPlacement to use for the given room-related element.

Return Value

The id of the spatial element related to the element. InvalidElementId if the element is not room-related, in which case the output will contain the placement handle from GetPlacement().

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCPlacementSetter Class
Autodesk.Revit.DB.IFC Namespace

IFCPlacementSetter Properties

[image] [image]