Revit 2013 API
IFCTransformSetter..::..InitializeFromBoundingBox Method
IFCTransformSetter Class See Also Send Feedback
Initializes the transformation in the transform setter.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public Transform InitializeFromBoundingBox(
    ExporterIFC exporterIFC,
    IList<GeometryObject> geometryList,
    IFCExtrusionCreationData exportBodyParams
)
Visual Basic
Public Function InitializeFromBoundingBox ( _
    exporterIFC As ExporterIFC, _
    geometryList As IList(Of GeometryObject), _
    exportBodyParams As IFCExtrusionCreationData _
) As Transform
Visual C++
public:
Transform^ InitializeFromBoundingBox(
    ExporterIFC^ exporterIFC,
    IList<GeometryObject^>^ geometryList,
    IFCExtrusionCreationData^ exportBodyParams
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
geometryList
Type: System.Collections.Generic..::..IList<(Of <(<'GeometryObject>)>)>
The set of geometry used to determine the bounding box.
exportBodyParams
Type: Autodesk.Revit.DB.IFC..::..IFCExtrusionCreationData
The extrusion creation data which contains the local placement.

Return Value

The transform corresponding to the movement, if any.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCTransformSetter Class
Autodesk.Revit.DB.IFC Namespace

IFCTypeInfo Class

[image]