Revit 2013 API
CurveElementFilter Constructor (CurveElementType)
CurveElementFilter Class See Also Send Feedback
Constructs a new instance of a filter to match specific types of curve elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public CurveElementFilter(
    CurveElementType curveElementType
)
Visual Basic
Public Sub New ( _
    curveElementType As CurveElementType _
)
Visual C++
public:
CurveElementFilter(
    CurveElementType curveElementType
)

Parameters

curveElementType
Type: Autodesk.Revit.DB..::..CurveElementType
The curve element type to match.

See Also

CurveElementFilter Class
CurveElementFilter Overload

CurveElementFilter Constructor (CurveElementType, Boolean)

[image]