Revit 2013 API
RebarShapeSet Members
RebarShapeSet Class Constructors Methods Properties See Also Send Feedback

The RebarShapeSet type exposes the following members.

Constructors

 | Name | Description
Public method | RebarShapeSet | Initializes a new instance of the RebarShapeSet class

Methods

 | Name | Description
Public method | Clear | Removes every rebar shape from the set, rendering it empty.
Public method | Contains | Tests for the existence of a rebar shape within the set.
Public method | Erase | Removes a specified rebar shape from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | Insert | Insert the specified rebar shape into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | Size | Returns the number of rebar shapes that are in the set.

See Also

RebarShapeSet Class
Autodesk.Revit.DB.Structure Namespace

RebarShapeSet Constructor

[image]