Revit 2013 API
ReferenceIntersector Constructor (View3D)
ReferenceIntersector Class See Also Send Feedback
Constructs a ReferenceIntersector which is set to return intersections from all elements and representing all reference target types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ReferenceIntersector(
    View3D dbView3d
)
Visual Basic
Public Sub New ( _
    dbView3d As View3D _
)
Visual C++
public:
ReferenceIntersector(
    View3D^ dbView3d
)

Parameters

dbView3d
Type: Autodesk.Revit.DB..::..View3D
The view to find references in

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ReferenceIntersector Class
ReferenceIntersector Overload

ReferenceIntersector Constructor (ElementFilter, FindReferenceTarget, View3D)

[image]