Revit 2013 API
Floor..::..SpanDirectionSymbols Property
Floor Class Example See Also Send Feedback
An array of span direction symbols associated with this floor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2013.  Call GetSpanDirectionSymbolIds() instead.")]
public ElementArray SpanDirectionSymbols { get; }
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2013.  Call GetSpanDirectionSymbolIds() instead.")> _
Public ReadOnly Property SpanDirectionSymbols As ElementArray
    Get
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2013.  Call GetSpanDirectionSymbolIds() instead.")]
public:
property ElementArray^ SpanDirectionSymbols {
    ElementArray^ get ();
}

Remarks

By using the ObjectType property of these span direction symbols it is possible to read if the floor has one way or two way span direction graphics.

Examples

CopyC#
public void SpanDirectionSymbolsInfo(Floor floor)
{
    string msg = "";
    if (0 == floor.SpanDirectionSymbols.Size)
    {
        msg = "No span direction symbol!";
    }
    foreach (Element element in floor.SpanDirectionSymbols)
    {
        msg += "Span direction symbol name is : " + element.Name;
    }

    // Give the user some information.
    TaskDialog.Show("Revit",msg);
}
CopyVB.NET
Public Sub SpanDirectionSymbolsInfo(ByVal floor As Autodesk.Revit.DB.Floor)
    Dim msg As String = ""
    If 0 = floor.SpanDirectionSymbols.Size Then
        msg = "No span direction symbol!"
    End If
    For Each element As Autodesk.Revit.DB.Element In floor.SpanDirectionSymbols
        msg += "Span direction symbol name is : " + element.Name
    Next

    ' Give the user some information.
    TaskDialog.Show("Revit", msg)
End Sub

See Also

Floor Class

StructuralUsage Property

[image]