Revit 2013 API
AssemblyViewUtils..::..CreateSheet Method
AssemblyViewUtils Class See Also Send Feedback
Creates a new sheet assembly view for the assembly instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static ViewSheet CreateSheet(
    Document document,
    ElementId assemblyInstanceId,
    ElementId titleBlockId
)
Visual Basic
Public Shared Function CreateSheet ( _
    document As Document, _
    assemblyInstanceId As ElementId, _
    titleBlockId As ElementId _
) As ViewSheet
Visual C++
public:
static ViewSheet^ CreateSheet(
    Document^ document,
    ElementId^ assemblyInstanceId,
    ElementId^ titleBlockId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the view will be added.
assemblyInstanceId
Type: Autodesk.Revit.DB..::..ElementId
Id of the assembly instance that owns the new view.
titleBlockId
Type: Autodesk.Revit.DB..::..ElementId
Id of the titleblock family to use. For no titleblock, pass invalidElementId.

Return Value

A new sheet assembly view.

Remarks

The document must be regenerated before using the sheet.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | assemblyInstanceId is not an AssemblyInstance. -or- titleBlockId is not a TitleBlock.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AssemblyViewUtils Class

Dispose Method

[image]