Revit 2013 API
ExporterIFCUtils..::..CreateBeamColumnBaseQuantities Method
ExporterIFCUtils Class See Also Send Feedback
Creates the beam and column base quantities and adds them to the export.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static void CreateBeamColumnBaseQuantities(
    ExporterIFC exporterIFC,
    IFCAnyHandle beamColumnElement,
    Element pElem,
    IFCTypeInfo typeInfo
)
Visual Basic
Public Shared Sub CreateBeamColumnBaseQuantities ( _
    exporterIFC As ExporterIFC, _
    beamColumnElement As IFCAnyHandle, _
    pElem As Element, _
    typeInfo As IFCTypeInfo _
)
Visual C++
public:
static void CreateBeamColumnBaseQuantities(
    ExporterIFC^ exporterIFC,
    IFCAnyHandle^ beamColumnElement,
    Element^ pElem,
    IFCTypeInfo^ typeInfo
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
beamColumnElement
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The beam or column element handle.
pElem
Type: Autodesk.Revit.DB..::..Element
The beam or column.
typeInfo
Type: Autodesk.Revit.DB.IFC..::..IFCTypeInfo
Information about the type of the beam or column.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace

CreateColumnPropertySet Method

[image]