Revit 2013 API
AnalyticalModel..::..IsAnalyzeAsValid Method
AnalyticalModel Class See Also Send Feedback
Determines if the given Analyze As parameter is valid for this Element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsAnalyzeAsValid(
    AnalyzeAs analyzeAs
)
Visual Basic
Public Function IsAnalyzeAsValid ( _
    analyzeAs As AnalyzeAs _
) As Boolean
Visual C++
public:
bool IsAnalyzeAsValid(
    AnalyzeAs analyzeAs
)

Parameters

analyzeAs
Type: Autodesk.Revit.DB.Structure..::..AnalyzeAs
Indicates how Analytical Model is analyzed.

Return Value

True if valid; false otherwise.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace

IsApproximated Method

[image]