Revit 2013 API
BeamSystem..::..GetAllBeams Method
BeamSystem Class See Also Send Feedback
Get all the beams of the BeamSystem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2013.  Call GetBeamIds() instead.")]
public ElementSet GetAllBeams()
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2013.  Call GetBeamIds() instead.")> _
Public Function GetAllBeams As ElementSet
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2013.  Call GetBeamIds() instead.")]
public:
ElementSet^ GetAllBeams()

Return Value

The beams.

See Also

BeamSystem Class

GetBeamIds Method

[image]