Revit 2013 API
VolumeCalculationOptions..::..VolumeComputationEnable Property
VolumeCalculationOptions Class Example See Also Send Feedback
True to enable volume computation in Revit. False to disable it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool VolumeComputationEnable { get; set; }
Visual Basic
Public Property VolumeComputationEnable As Boolean
    Get
    Set
Visual C++
public:
property bool VolumeComputationEnable {
    bool get ();
    void set (bool value);
}

Examples

CopyC#
public void GetRoomDimensions(Document doc, Room room)
{
    String roominfo = "Room dimensions:\n";
    // turn on volume calculations:
    VolumeCalculationOptions options = new VolumeCalculationOptions();
    options.VolumeComputationEnable = true;
    doc.Settings.VolumeCalculationSetting.VolumeCalculationOptions = options;
    roominfo += "Vol: " + room.Volume + "\n";
    roominfo += "Area: " + room.Area + "\n";
    roominfo += "Perimeter: " + room.Perimeter + "\n";
    roominfo += "Unbounded height: " + room.UnboundedHeight + "\n";
    TaskDialog.Show("Revit",roominfo);
}
CopyVB.NET
Public Sub GetRoomDimensions(ByVal doc As Document, ByVal room As Room)
    Dim roominfo As [String] = "Room dimensions:" & vbLf
    ' turn on volume calculations:
    Dim options As New VolumeCalculationOptions()
    options.VolumeComputationEnable = True
    doc.Settings.VolumeCalculationSetting.VolumeCalculationOptions = options
    roominfo += "Vol: " + room.Volume + vbLf
    roominfo += "Area: " + room.Area + vbLf
    roominfo += "Perimiter: " + room.Perimeter + vbLf
    roominfo += "Unbounded height: " + room.UnboundedHeight + vbLf
    TaskDialog.Show("Revit", roominfo)
End Sub

See Also

VolumeCalculationOptions Class

VolumeCalculationSetting Class

[image]