Revit 2013 API
FabricArea..::..CoverOffset Property
FabricArea Class See Also Send Feedback
Additional cover offset of the fabric distribution.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double CoverOffset { get; set; }
Visual Basic
Public Property CoverOffset As Double
    Get
    Set
Visual C++
public:
property double CoverOffset {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The given value for coverOffset is not a number -or- When setting this property: coverOffset is greater then the host thickness.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for coverOffset must be between 0 and 30000 feet.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

FabricArea Class
Autodesk.Revit.DB.Structure Namespace

Direction Property

[image]