Revit 2013 API
RebarShapeConstraintAngleFromFixedDir Members
RebarShapeConstraintAngleFromFixedDir Class Constructors Methods Properties See Also Send Feedback

The RebarShapeConstraintAngleFromFixedDir type exposes the following members.

Constructors

 | Name | Description
Public method | RebarShapeConstraintAngleFromFixedDir | Create an angular constraint.

Methods

 | Name | Description

Properties

 | Name | Description
Public property | Direction | A fixed direction in UV-space. The parameter will drive the segment's angle relative to this direction.
Public property | Sign | When the sign is 1, the Direction is rotated clockwise by the angle's value. When -1, the Direction is rotated counter-clockwise.

See Also

RebarShapeConstraintAngleFromFixedDir Class
Autodesk.Revit.DB.Structure Namespace

RebarShapeConstraintAngleFromFixedDir Constructor

[image]