Revit 2013 API
ExternalFileReference..::..IsValidPathTypeForExternalFileReference Method
ExternalFileReference Class See Also Send Feedback
Checks whether a PathType enum value will be valid to use with this ExternalFileReference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool IsValidPathTypeForExternalFileReference(
    PathType pathType
)
Visual Basic
Public Function IsValidPathTypeForExternalFileReference ( _
    pathType As PathType _
) As Boolean
Visual C++
public:
bool IsValidPathTypeForExternalFileReference(
    PathType pathType
)

Parameters

pathType
Type: Autodesk.Revit.DB..::..PathType

Remarks

  • PathType.Server is only valid for ExternalFileReferences of type ExternalFileReferenceType.RevitLink
  • PathType.Content is only valid for ExternalFileReferences of type ExternalFileReferenceType.KeynoteTable and ExternalFileReferenceType.Decal

See Also

ExternalFileReference Class

ExternalFileReference Properties

[image] [image]