Revit 2013 API
RectangularWallCreationData Constructor (Curve, Level, Boolean)
RectangularWallCreationData Class See Also Send Feedback
Initializes a new instance of the RectangularWallCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public RectangularWallCreationData(
    Curve curve,
    Level level,
    bool structural
)
Visual Basic
Public Sub New ( _
    curve As Curve, _
    level As Level, _
    structural As Boolean _
)
Visual C++
public:
RectangularWallCreationData(
    Curve^ curve,
    Level^ level,
    bool structural
)

Parameters

curve
Type: Autodesk.Revit.DB..::..Curve
An arc or line representing the base line of the wall.
level
Type: Autodesk.Revit.DB..::..Level
The level on which the wall is to be placed.
structural
Type: System..::..Boolean
If set, specifies that the wall is structural in nature.

See Also

RectangularWallCreationData Class
RectangularWallCreationData Overload
Autodesk.Revit.Creation Namespace

RectangularWallCreationData Constructor (Curve, WallType, Level, Double, Double, Boolean, Boolean)

[image]