Revit 2013 API
SunAndShadowSettings..::..LevelId Property
SunAndShadowSettings Class See Also Send Feedback
Identifies the element id of the Ground Plane level for the SunAndShadowSettings element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ElementId LevelId { get; set; }
Visual Basic
Public Property LevelId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ LevelId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: the element level is not a valid Level element.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

SunAndShadowSettings Class

Longitude Property

[image]