Revit 2013 API
LocationCurve..::..Curve Property
LocationCurve Class Example See Also Send Feedback
Provides the ability to get and set the curve of a curve based element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Curve Curve { get; set; }
Visual Basic
Public Property Curve As Curve
    Get
    Set
Visual C++
public:
property Curve^ Curve {
    Curve^ get ();
    void set (Curve^ value);
}

Remarks

This property can be used to set the location of curve based element to any desired position. Many elements are curve based. Some examples are walls, beams and braces.

Examples

CopyC#
void MoveUsingCurveParam(Autodesk.Revit.ApplicationServices.Application application, Wall wall)
{
    LocationCurve wallLine = wall.Location as LocationCurve;
    XYZ p1 = XYZ.Zero;
    XYZ p2 = new XYZ(10, 20, 0);
    Line newWallLine = application.Create.NewLineBound(p1, p2);

    // Change the wall line to a new line.
    wallLine.Curve = newWallLine;
}
CopyVB.NET
Sub MoveUsingCurveParam(ByVal application As Autodesk.Revit.ApplicationServices.Application, ByVal wall As Wall)
    Dim wallLine As LocationCurve = TryCast(wall.Location, LocationCurve)
    Dim p1 As Autodesk.Revit.DB.XYZ = Autodesk.Revit.DB.XYZ.Zero
    Dim p2 As New Autodesk.Revit.DB.XYZ(10, 20, 0)
    Dim newWallLine As Line = application.Create.NewLineBound(p1, p2)

    ' Change the wall line to a new line.
    wallLine.Curve = newWallLine
End Sub

See Also

LocationCurve Class

ElementsAtJoin Property

[image]