Revit 2013 API
Part Members
Part Class Methods Properties See Also Send Feedback

The Part type exposes the following members.

Methods

 | Name | Description
Public method | CanOffsetFace | Checks if it is possible to offset the given face.
Public method | GetDividedParents | Obsolete. Returns ids of divided elements that lead to the creation of this Part.
Public method | GetSourceElementIds | Gets a collection of elements from which this Part is created by the PartMaker. May return more than one source only if there is merge involved somewhere in the history of this Part.
Public method | GetSourceElementOriginalCategoryIds | Gets the category ids of the source elements which were used to form this part.
Public method | ResetPartShape | Resets all face offsets applied to part faces.
Public method | SetFaceOffset | Offsets the given part face in the direction that points out of the solid shape with the specified amount. Negative value will offset the face into the solid shape.

Properties

 | Name | Description
Public property | Excluded | True if the part is excluded, false otherwise
Public property | OriginalCategoryId | The category Id of the original element corresponding to this Part.
Public property | OriginalDividedElementId | Obsolete. The original (non-Part) element of which this element is a part of.
Public property | ParentDividedElementId | Obsolete. The parent element id that this Part is created from.
Public property | PartMaker | The PartMaker that created this Part.

See Also

Part Class

Part Methods

[image] [image]