Revit 2013 API
InvalidOperationException Class
Members See Also Send Feedback
The exception that is thrown when a method call is invalid for the object's current state.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[SerializableAttribute]
public class InvalidOperationException : ApplicationException
Visual Basic
<SerializableAttribute> _
Public Class InvalidOperationException _
    Inherits ApplicationException
Visual C++
[SerializableAttribute]
public ref class InvalidOperationException : public ApplicationException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Autodesk.Revit.Exceptions..::..ApplicationException
Autodesk.Revit.Exceptions..::..InvalidOperationException
Autodesk.Revit.Exceptions..::..AutoJoinFailedException
Autodesk.Revit.Exceptions..::..DisabledDisciplineException
Autodesk.Revit.Exceptions..::..FamilyContextException
Autodesk.Revit.Exceptions..::..ForbiddenForDynamicUpdateException
Autodesk.Revit.Exceptions..::..InapplicableDataException
Autodesk.Revit.Exceptions..::..InvalidLicenseException
Autodesk.Revit.Exceptions..::..InvalidObjectException
Autodesk.Revit.Exceptions..::..ModificationForbiddenException
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException
Autodesk.Revit.Exceptions..::..ObjectAccessException
Autodesk.Revit.Exceptions..::..OptionalFunctionalityNotAvailableException
Autodesk.Revit.Exceptions..::..RegenerationFailedException

See Also

InvalidOperationException Members
Autodesk.Revit.Exceptions Namespace

InvalidOperationException Members

[image] [image]