Revit 2013 API
ReferenceIntersector..::..SetFilter Method
ReferenceIntersector Class See Also Send Feedback
Sets the ElementFilter used in intersection testing

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetFilter(
    ElementFilter filter
)
Visual Basic
Public Sub SetFilter ( _
    filter As ElementFilter _
)
Visual C++
public:
void SetFilter(
    ElementFilter^ filter
)

Parameters

filter
Type: Autodesk.Revit.DB..::..ElementFilter
The ElementFilter

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ReferenceIntersector Class

SetTargetElementIds Method

[image]