Revit 2013 API
ItemFactoryBase..::..NewViewSection Method
ItemFactoryBase Class Example See Also Send Feedback
Creates a new section view.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This method is Obsolete in Revit 2013.  Call ViewSection.CreateDetail() instead.")]
public ViewSection NewViewSection(
    BoundingBoxXYZ box
)
Visual Basic
<ObsoleteAttribute("This method is Obsolete in Revit 2013.  Call ViewSection.CreateDetail() instead.")> _
Public Function NewViewSection ( _
    box As BoundingBoxXYZ _
) As ViewSection
Visual C++
[ObsoleteAttribute(L"This method is Obsolete in Revit 2013.  Call ViewSection.CreateDetail() instead.")]
public:
ViewSection^ NewViewSection(
    BoundingBoxXYZ^ box
)

Parameters

box
Type: Autodesk.Revit.DB..::..BoundingBoxXYZ
The view volume of the section will correspond geometrically to the specified bounding box.

Return Value

The newly created section view.

Remarks

The view's forward direction will correspond to the Z direction of the box, and the view's up direction will correspond to the Y direction of the box. The right hand direction of the view will be computed so that (right, up, forward) will form a left-handed coordinate system. The resulting view will be cropped, and far clipping will be active.

Examples

CopyC#
// Get a BoundingBoxXYZ instance from Revit
BoundingBoxXYZ box = document.ActiveView.CropBox;
if (null == box)
{
    throw new Exception("No BoundingBoxXYZ instance found.");
}

// Create a new view section.
ViewSection viewSection = document.Create.NewViewSection(box);
CopyVB.NET
' Get a BoundingBoxXYZ instance from Revit
Dim box As BoundingBoxXYZ = document.ActiveView.CropBox
If box Is Nothing Then
    Throw New Exception("No BoundingBoxXYZ instance found.")
End If

' Create a new view section.
Dim viewSection As ViewSection = document.Create.NewViewSection(box)

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace

PlaceGroup Method

[image]