Revit 2013 API
Edge Members
Edge Class Methods Properties See Also Send Feedback

The Edge type exposes the following members.

Methods

 | Name | Description
Public method | AsCurve | Returns a curve that corresponds to the edge's parametric orientation.
Public method | AsCurveFollowingFace | Returns a curve that corresponds to this edge as oriented in its topological direction on the specified face.
Public method | ComputeDerivatives | Returns the vectors describing the edge at the specified parameter.
Public method | Evaluate | Evaluates a parameter on the edge.
Public method | EvaluateOnFace | Evaluates a parameter on the edge to produce UV coordinates on the face.
Public method | Tessellate | Returns a polyline approximation to the edge.
Public method | TessellateOnFace | Returns a polyline approximation to the edge in UV parameters of the face.

Properties

 | Name | Description
Public property | ApproximateLength | Returns the approximate length of the edge.
Public property | EndPointReference | Returns a stable reference to the start or the end point of the edge.
Public property | Face | Returns one of the two faces that meet at the edge.
Public property | Reference | Returns a stable reference to the edge.

See Also

Edge Class

Edge Methods

[image] [image]