Revit 2013 API
ItemFactoryBase..::..NewFamilyInstance Method (XYZ, FamilySymbol, StructuralType)
ItemFactoryBase Class Example See Also Send Feedback
Inserts a new instance of a family into the document, using a location and a type/symbol.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilyInstance NewFamilyInstance(
    XYZ location,
    FamilySymbol symbol,
    StructuralType structuralType
)
Visual Basic
Public Function NewFamilyInstance ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    structuralType As StructuralType _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewFamilyInstance(
    XYZ^ location,
    FamilySymbol^ symbol,
    StructuralType structuralType
)

Parameters

location
Type: Autodesk.Revit.DB..::..XYZ
The physical location where the instance is to be placed.
symbol
Type: Autodesk.Revit.DB..::..FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
structuralType
Type: Autodesk.Revit.DB.Structure..::..StructuralType
If structural then specify the type of the component.

Return Value

If creation was successful then an instance to the new object is returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

Use this method to insert a family instance that does not require a host element or level.

The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

Some Families, such as Beams, have more than one endpoint and are inserted in the same manner as single point instances. Once inserted these linear family instances can have their endpoints changed by using the instance's Element.Location property.

Note: if the created family instance includes nested instances, the API framework will automatically regenerate the document during this method call. This happens regardless of the setting for RegenerationMode.

Examples

CopyC#
String fileName = @"C:\Documents and Settings\All Users\Application Data\Autodesk\RST 2010\Imperial Library\Furniture\Table-Dining Round w Chairs.rfa";

 // try to load family
 Family family = null;
 if (!document.LoadFamily(fileName, out family))
 {
     throw new Exception("Unable to load " + fileName);
 }

 // Loop through table symbols and add a new table for each
 FamilySymbolSetIterator symbolItor = family.Symbols.ForwardIterator();
 double x = 0.0, y = 0.0;
 while (symbolItor.MoveNext())
 {
     FamilySymbol symbol = symbolItor.Current as FamilySymbol;
     XYZ location = new XYZ(x, y, 10.0);
     // Do not use the overloaded NewFamilyInstance() method that contains
     // the Level argument, otherwise Revit cannot show the instances
     // correctly in 3D View, for the table is not level-based component.
     FamilyInstance instance = document.Create.NewFamilyInstance(location, symbol, StructuralType.NonStructural);
     x += 10.0;
 }
CopyVB.NET
Dim fileName As [String] = "C:\Documents and Settings\All Users\Application Data\Autodesk\RST 2010\Imperial Library\Furniture\Table-Dining Round w Chairs.rfa"

' try to load family
Dim family As Family = Nothing
If Not document.LoadFamily(fileName, family) Then
    Throw New Exception("Unable to load " + fileName)
End If

' Loop through table symbols and add a new table for each
Dim symbolItor As FamilySymbolSetIterator = family.Symbols.ForwardIterator()
Dim x As Double = 0, y As Double = 0
While symbolItor.MoveNext()
    Dim symbol As FamilySymbol = TryCast(symbolItor.Current, FamilySymbol)
    Dim location As New Autodesk.Revit.DB.XYZ(x, y, 10)
    ' Do not use the overloaded NewFamilyInstance() method that contains
    ' the Level argument, otherwise Revit cannot show the instances
    ' correctly in 3D View, for the table is not level-based component.
    Dim instance As Autodesk.Revit.DB.FamilyInstance = document.Create.NewFamilyInstance(location, symbol, Autodesk.Revit.DB.Structure.StructuralType.NonStructural)
    x += 10
End While

See Also

ItemFactoryBase Class
NewFamilyInstance Overload
Autodesk.Revit.Creation Namespace

NewFamilyInstance Method (XYZ, FamilySymbol, View)

[image]