Revit 2013 API
BoundarySegmentArray Members
BoundarySegmentArray Class Constructors Methods Properties See Also Send Feedback

The BoundarySegmentArray type exposes the following members.

Constructors

 | Name | Description
Public method | BoundarySegmentArray | Initializes a new instance of the BoundarySegmentArray class

Methods

 | Name | Description
Public method | Append | Add the boundary segment to the end of the array.
Public method | Clear | Removes every boundary segment from the array, rendering it empty.
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | Insert | Insert the specified boundary segment into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | Item | Gets or sets a boundary segment at a specified index within the array.
Public property | Size | Returns the number of boundary segments that are in the array.

See Also

BoundarySegmentArray Class
Autodesk.Revit.DB.Architecture Namespace

BoundarySegmentArray Constructor

[image]