Revit 2013 API
FamilySymbolFilter Class
Members See Also Send Feedback
A filter used to find all family symbols of the given family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class FamilySymbolFilter : ElementQuickFilter
Visual Basic
Public Class FamilySymbolFilter _
    Inherits ElementQuickFilter
Visual C++
public ref class FamilySymbolFilter : public ElementQuickFilter

Remarks

This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementQuickFilter
Autodesk.Revit.DB..::..FamilySymbolFilter

See Also

FamilySymbolFilter Members

FamilySymbolFilter Members

[image] [image]