Revit 2013 API
PartUtils..::..GetPartMakerMethodToDivideVolume Method
PartUtils Class See Also Send Feedback
Obtains the object allowing access to the divided volume properties of the PartMaker.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static PartMakerMethodToDivideVolumes GetPartMakerMethodToDivideVolume(
    PartMaker partMaker
)
Visual Basic
Public Shared Function GetPartMakerMethodToDivideVolume ( _
    partMaker As PartMaker _
) As PartMakerMethodToDivideVolumes
Visual C++
public:
static PartMakerMethodToDivideVolumes^ GetPartMakerMethodToDivideVolume(
    PartMaker^ partMaker
)

Parameters

partMaker
Type: Autodesk.Revit.DB..::..PartMaker
The PartMaker.

Return Value

The object handle. Returns nullNothingnullptra null reference (Nothing in Visual Basic) if the PartMaker does not represent divided volumes.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PartUtils Class

HasAssociatedParts Method

[image] [image]