Revit 2013 API
DGNImportOptions Members
DGNImportOptions Class Constructors Methods Properties See Also Send Feedback

The DGNImportOptions type exposes the following members.

Constructors

 | Name | Description
Public method | DGNImportOptions()()()() | Constructs a new instance of DGNImportOptions with default values of all properties.
Public method | DGNImportOptions(DGNImportOptions) | Constructs a new instance of DGNImportOptions as a copy of the import options.

Methods

 | Name | Description

Properties

 | Name | Description
Public property | DGNModelViewName | The model view name to be imported. Need user give a model view name to specify which model view need to be imported into Revit
Public property | IgnoreUnsupportedElementWarning | If true, ignore warning messages about unsupported elements in the DGN file. If false, the import process is aborted if imported dgn files have unsupported elements.

See Also

DGNImportOptions Class

DGNImportOptions Constructor

[image] [image]