Revit 2013 API
ParameterFilterElement..::..AllRuleParametersApplicable Method (IList<(Of <(<'FilterRule>)>)>)
ParameterFilterElement Class See Also Send Feedback
Checks that the parameters of the given rules are valid for this filter's categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool AllRuleParametersApplicable(
    IList<FilterRule> rules
)
Visual Basic
Public Function AllRuleParametersApplicable ( _
    rules As IList(Of FilterRule) _
) As Boolean
Visual C++
public:
bool AllRuleParametersApplicable(
    IList<FilterRule^>^ rules
)

Parameters

rules
Type: System.Collections.Generic..::..IList<(Of <(<'FilterRule>)>)>
The rules to check.

Return Value

True if all the parameters of the given rules are valid for this filter, otherwise false.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterElement Class
AllRuleParametersApplicable Overload

AllRuleParametersApplicable Method (Document, ICollection(ElementId), IList(FilterRule))

[image]