Revit 2013 API
Material Methods
Material Class See Also Send Feedback

The Material type exposes the following members.

Methods

 | Name | Description
Public method | ClearMaterialAspect | Removes an aspect from the material.
 | Create | Creates a new material.
Public method | Duplicate | Duplicates the material.
Public method | GetCutPatternColor | Returns the color of the cut pattern for the material element.
Public method | GetCutPatternId | Returns the cut pattern id of the material.
Public method | GetMaterialAspectPropertySet | Obsolete. Gets the identifier of the shared property set for a given aspect.
Public method | GetSmoothness | Obsolete. Gets the smoothness value.
Public method | SetMaterialAspect | Obsolete. Set the value of an aspect of the material
Public method | SetMaterialAspectByPropertySet | Set an aspect of the material to a shared property set.
Public method | SetMaterialAspectToIndependent | Obsolete. Set an aspect of the material from a shared property set to a custom property set owned by the material.
Public method | SetSmoothness | Obsolete. Sets the smoothness value.

See Also

Material Class

ClearMaterialAspect Method

[image]