Revit 2013 API
Category Properties
Category Class See Also Send Feedback

The Category type exposes the following members.

Properties

 | Name | Description
Public property | AllowsBoundParameters | To check if the category can have project parameters.
Public property | AllowsVisibilityControl | Whether the visibility can be controlled by the user for this category in this view.
Public property | CanAddSubcategory | Indicates if subcategories can be assigned to the category.
Public property | HasMaterialQuantities | Identifies if elements of the category are able to report what materials they contain in what quantities.
Public property | Id | Returns the category id associated with the category object.
Public property | IsCuttable | Indicates if the category is cuttable or not.
Public property | LineColor | The color of lines shown for elements of this category.
Public property | Material | Retrieves or changes the material of the category.
Public property | Name | The category name.
Public property | Parent | Returns the parent category of this category.
Public property | SubCategories | Returns a map containing all of the subcategories of this category.
Public property | Visible | Retrieves or changes the visibility of the category in the active view.

See Also

Category Class

AllowsBoundParameters Property

[image]