Revit 2013 API
BoundaryConditions..::..associateWithLoad Method
BoundaryConditions Class See Also Send Feedback
Sets the Autodesk::Revit::DB::ElementId^ of Load to associate.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool associateWithLoad(
    ElementId elementToAssociateId
)
Visual Basic
Public Function associateWithLoad ( _
    elementToAssociateId As ElementId _
) As Boolean
Visual C++
public:
bool associateWithLoad(
    ElementId^ elementToAssociateId
)

Parameters

elementToAssociateId
Type: Autodesk.Revit.DB..::..ElementId
The Autodesk::Revit::DB::ElementId^ of Load to associate.

Return Value

If the Autodesk::Revit::DB::ElementId^ was set returns true. Otherwise returns false.

Remarks

Autodesk::Revit::DB::ElementId^ may be set if the internal Load with the elementToAssociateId exist and it's type fit the BoundaryConditions type only.

See Also

BoundaryConditions Class

BoundaryConditions Properties

[image] [image]