Revit 2013 API
ExporterIFCUtils..::..SortCurveLoops Method
ExporterIFCUtils Class See Also Send Feedback
Sorts a set of curve loops such that outer and inner loops are separated.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static IList<IList<CurveLoop>> SortCurveLoops(
    IList<CurveLoop> loops
)
Visual Basic
Public Shared Function SortCurveLoops ( _
    loops As IList(Of CurveLoop) _
) As IList(Of IList(Of CurveLoop))
Visual C++
public:
static IList<IList<CurveLoop^>^>^ SortCurveLoops(
    IList<CurveLoop^>^ loops
)

Parameters

loops
Type: System.Collections.Generic..::..IList<(Of <(<'CurveLoop>)>)>
The curve loops.

Return Value

The sorted collection of loops.

Remarks

Outer loops are separated and inner loops are grouped according to their outer loop. Loops are assumed to be non-intersecting, and there will be no nesting of inner loops (that is, an inner loop of an inner loop is another outer loop).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace

TransformAndScalePoint Method

[image]