Revit 2013 API
Wall..::..Create Method (Document, Curve, ElementId, ElementId, Double, Double, Boolean, Boolean)
Wall Class See Also Send Feedback
Creates a new rectangular profile wall within the project using the specified wall type, height, and offset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static Wall Create(
    Document document,
    Curve curve,
    ElementId wallTypeId,
    ElementId levelId,
    double height,
    double offset,
    bool flip,
    bool structural
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    curve As Curve, _
    wallTypeId As ElementId, _
    levelId As ElementId, _
    height As Double, _
    offset As Double, _
    flip As Boolean, _
    structural As Boolean _
) As Wall
Visual C++
public:
static Wall^ Create(
    Document^ document,
    Curve^ curve,
    ElementId^ wallTypeId,
    ElementId^ levelId,
    double height,
    double offset,
    bool flip,
    bool structural
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which the new wall is created.
curve
Type: Autodesk.Revit.DB..::..Curve
An arc or line representing the base line of the wall.
wallTypeId
Type: Autodesk.Revit.DB..::..ElementId
Id of the wall type to be used by the new wall instead of the default type.
levelId
Type: Autodesk.Revit.DB..::..ElementId
Id of the level on which the wall is to be placed.
height
Type: System..::..Double
The height of the wall other than the default height.
offset
Type: System..::..Double
Modifies the wall's Base Offset parameter to determine its vertical placement.
flip
Type: System..::..Boolean
Change which side of the wall is considered to be the inside and outside of the wall.
structural
Type: System..::..Boolean
If set, specifies that the wall is structural in nature.

Return Value

If successful a new wall object within the project.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The curve argument is not valid for rectangular wall creation. -or- The input curve points to a helical curve and is not supported for this operation.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The given value for height must be greater than 0 and no more than 30000 feet. -or- The given value for offset must be no more than 30000 feet in absolute value.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

Wall Class
Create Overload

Flip Method

[image]