Revit 2013 API
IFamilyLoadOptions..::..OnFamilyFound Method
IFamilyLoadOptions Interface See Also Send Feedback
This is the method called when the family was found in the target document already.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
bool OnFamilyFound(
    bool familyInUse,
    out bool overwriteParameterValues
)
Visual Basic
Function OnFamilyFound ( _
    familyInUse As Boolean, _
    <OutAttribute> ByRef overwriteParameterValues As Boolean _
) As Boolean
Visual C++
bool OnFamilyFound(
    bool familyInUse,
    [OutAttribute] bool% overwriteParameterValues
)

Parameters

familyInUse
Type: System..::..Boolean
Indicates if at least one instance of the family is placed in the project or not.
overwriteParameterValues
Type: System..::..Boolean%
This is a boolean argument by reference which determines if overwrite the parameter values of existing types or not. The default value is false, and it can be overwritten if you want to change the behavior.

Return Value

Return true to continue loading the family, false to cancel.

See Also

IFamilyLoadOptions Interface

OnSharedFamilyFound Method

[image]