Revit 2013 API
BarDescription..::..HooksInSameDirection Property
BarDescription Class See Also Send Feedback
Retrieves the Rebar Hooks In Same Direction property of a Bar Description.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool HooksInSameDirection { get; }
Visual Basic
Public ReadOnly Property HooksInSameDirection As Boolean
    Get
Visual C++
public:
property bool HooksInSameDirection {
    bool get ();
}

Remarks

If true, both hooks are bent in the same direction; if false, the hooks are bent in opposite directions.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

BarDescription Class
Autodesk.Revit.DB.Structure Namespace

HookType Property

[image]