Revit 2013 API
AnalyticalModel..::..IsValidDatumPlaneForProjection Method
AnalyticalModel Class See Also Send Feedback
Indicates if a given Datum Plane is valid for analytical model projection with respect to the given analytical direction.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2012. Call isValidProjectionDatumPlane() instead.")]
public bool IsValidDatumPlaneForProjection(
    AnalyticalDirection direction,
    ElementId datumPlaneId
)
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2012. Call isValidProjectionDatumPlane() instead.")> _
Public Function IsValidDatumPlaneForProjection ( _
    direction As AnalyticalDirection, _
    datumPlaneId As ElementId _
) As Boolean
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2012. Call isValidProjectionDatumPlane() instead.")]
public:
bool IsValidDatumPlaneForProjection(
    AnalyticalDirection direction,
    ElementId^ datumPlaneId
)

Parameters

direction
Type: Autodesk.Revit.DB.Structure..::..AnalyticalDirection
Direction of analytical model projection.
datumPlaneId
Type: Autodesk.Revit.DB..::..ElementId
Datum Plane on to which analytical model is projected.

Return Value

True if Datum Plane is valid, false otherwise.

Remarks

Validity of a Datum Plane for analytical projection is both element and context specific. For instance, two different Beams may have two different results.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace

IsValidDirectionForAutoDetect Method

[image]