Revit 2013 API
AnalyticalModel..::..ManuallyAdjust Method
AnalyticalModel Class Example See Also Send Feedback
Perform Manual Analytical Adjustment on analytical model, with respect to another Element

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool ManuallyAdjust(
    Reference source,
    Reference target,
    bool lock
)
Visual Basic
Public Function ManuallyAdjust ( _
    source As Reference, _
    target As Reference, _
    lock As Boolean _
) As Boolean
Visual C++
public:
bool ManuallyAdjust(
    Reference^ source,
    Reference^ target,
    bool lock
)

Parameters

source
Type: Autodesk.Revit.DB..::..Reference
Which part of Analytical Model needs to change.
target
Type: Autodesk.Revit.DB..::..Reference
Which part of another Analytical Model change should be made against.
lock
Type: System..::..Boolean
Whether adjustment should be locked or unlocked.

Return Value

Indicates the successful completion of the Manual Analytical Adjustment operation. True if source Element was adjusted successfully, false otherwise.

Remarks

If the Manual Analytical Adjustment is locked, then the Source Analytical Model will update itself whenever the Target Analytical Model changes. If the Manual Analytical Adjustment is not locked, then the Source Analytical Model will remain at a given offset, not following the target. Success, in this context, is achieved when the Source adjusts itself against the Target. Additionally, this requires an open transaction on the current document. Model regeneration is required after the operation.

Examples

CopyC#
// to do

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if source cannot be used as source reference, or if target cannot be used as target reference.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace

ResetLinks Method

[image]