Revit 2013 API
Transaction..::..SetName Method
Transaction Class See Also Send Feedback
Sets the transaction's name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetName(
    string name
)
Visual Basic
Public Sub SetName ( _
    name As String _
)
Visual C++
public:
void SetName(
    String^ name
)

Parameters

name
Type: System..::..String
A name for the transaction.

Remarks

A transaction needs a name before it can be started, i.e. before one of the 'Start' method is invoked for this transaction object. The name will later appear in the Undo menu in Revit after a transaction is successfully committed.

Another ways of setting the name is either during construction or during the Start(String) method.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The name argument is an empty string.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

Transaction Class

Start Method

[image] [image]