Revit 2013 API
Rebar Methods
Rebar Class See Also Send Feedback

The Rebar type exposes the following members.

Methods

 | Name | Description
 | CreateFromCurves | Creates a new instance of a Rebar element within the project.
 | CreateFromCurvesAndShape | Creates a new instance of a Rebar element within the project. The instance will have the default shape parameters from the RebarShape.
 | CreateFromRebarShape | Creates a new Rebar, as an instance of a RebarShape. The instance will have the default shape parameters from the RebarShape, and its location is based on the bounding box of the shape in the shape definition. Hooks are removed from the shape before computing its bounding box. If appropriate hooks can be found in the document, they will be assigned arbitrarily.
Public method | DoesBarExistAtPosition | Checks whether a bar exists at the specified position.
Public method | GetBarPositionTransform | Return a transform representing the relative position of any individual bar in the set.
Public method | GetBendData | Gets the RebarBendData, containing bar and hook information, of the instance.
Public method | GetCenterlineCurves(Boolean) | Obsolete. A chain of curves representing the centerline of the rebar.
Public method | GetCenterlineCurves(Boolean, Boolean, Boolean) | A chain of curves representing the centerline of the rebar.
Public method | GetDistributionPath | The distribution path of a rebar set.
Public method | GetHookTypeId | Get the id of the RebarHookType to be applied to the rebar.
Public method | GetHostId | The element that contains the rebar.
Public method | IsSolidInView | Checks if this rebar element is shown solidly in a 3D view.
Public method | IsUnobscuredInView | Checks if this rebar element is shown unobscured in a view.
 | RebarShapeMatchesCurvesAndHooks | Checks if rebarShape matches curves and hooks.
Public method | ScaleToBox | Move and resize the bar to fit within a specified box. The arguments are interpreted as an arbitrary rectangle in 3D with vertices: origin, origin+xVec, origin+xVec+yVec, origin+yVec. The algorithm then proceeds as follows. First the bar is given the default values of the shape parameters from the shape definition. Then, if it is possible to do so without violating the shape definition, the parameter values are scaled so that the width and height of the shape match the lengths of xVec and yVec. If there is no way to do this within the shape definition due to overconstraining, a compromise is attempted, such as scaling the whole shape until either the width or the height is correct. Finally the shape is rotated to match the coordinate system of the box. The algorithm is the same one used in one-click placement.
Public method | ScaleToBoxFor3D | Move and resize a spiral or multiplanar instance to fit within a specified box. The arguments are interpreted as an arbitrary rectangle in 3D with vertices: origin, origin+xVec, origin+xVec+yVec, origin+yVec. One end of the rebar shape is inscribed in this rectangle. The other end is placed in the parallel plane at distance given by the height argument, in the direction of xVec cross yVec. This method replaces ScaleToBoxForSpiral() from prior releases.
Public method | SetHookTypeId | Set the id of the RebarHookType to be applied to the rebar.
Public method | SetHostId | The element that contains the rebar.
Public method | SetLayoutAsFixedNumber | Sets the Layout Rule property of rebar set to FixedNumber.
Public method | SetLayoutAsMaximumSpacing | Sets the Layout Rule property of rebar set to MaximumSpacing
Public method | SetLayoutAsMinimumClearSpacing | Sets the Layout Rule property of rebar set to MinimumClearSpacing
Public method | SetLayoutAsNumberWithSpacing | Sets the Layout Rule property of rebar set to NumberWithSpacing
Public method | SetLayoutAsSingle | Sets the Layout Rule property of rebar set to Single.
Public method | SetSolidInView | Sets this rebar element to be shown solidly in a 3D view.
Public method | SetUnobscuredInView | Sets this rebar element to be shown unobscured in a view.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace

CreateFromCurves Method

[image]