Revit 2013 API
ItemFactoryBase..::..NewView3D Method
ItemFactoryBase Class Example See Also Send Feedback
Creates a new 3D view.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2013. Call View3D.CreateIsometric() instead.")]
public View3D NewView3D(
    XYZ viewDirection
)
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2013. Call View3D.CreateIsometric() instead.")> _
Public Function NewView3D ( _
    viewDirection As XYZ _
) As View3D
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2013. Call View3D.CreateIsometric() instead.")]
public:
View3D^ NewView3D(
    XYZ^ viewDirection
)

Parameters

viewDirection
Type: Autodesk.Revit.DB..::..XYZ
The view direction - the vector pointing from the eye towards the model.

Return Value

The newly created 3D view.

Examples

CopyC#
// Create a new View3D
XYZ direction = new XYZ(1, 1, 1);
View3D view3D = document.Create.NewView3D(direction);
if (null == view3D)
{
    throw new Exception("Failed to create new View3D");
}
CopyVB.NET
' Create a new View3D
Dim direction As New Autodesk.Revit.DB.XYZ(1, 1, 1)
Dim view3D As View3D = document.Create.NewView3D(direction)
If view3D Is Nothing Then
    Throw New Exception("Failed to create new View3D")
End If

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace

NewViewPlan Method

[image]