Revit 2013 API
Application Methods
Application Class See Also Send Feedback

The Application type exposes the following members.

Methods

 | Name | Description
Public method | CopyModel | Copies an existing model to a new file. Overwriting a file of the same name is allowed.
Public method | Dispose |
Public method | ExtractPartAtomFromFamilyFile | Writes a PartAtom XML from the contents of a family file.
 | GetFailureDefinitionRegistry | Returns the instance of FailureDefinitionRegistry.
Public method | GetLibraryPaths | Returns path information identifying where Revit searches for content.
Public method | GetRevitServerNetworkHosts |
Public method | GetWorksharingCentralGUID | Gets the worksharing central GUID of the given server-based model.
Public method | NewFamilyDocument | New family document, including family, titleblock, and annotation symbol
Public method | NewProjectDocument | New project document
Public method | NewProjectTemplateDocument | New project template document
Public method | OpenBuildingComponentDocument | Opens a Building Component document from disk.
Public method | OpenDocumentFile(String) | Opens a document from disk.
Public method | OpenDocumentFile(ModelPath, OpenOptions) | Opens a document from disk.
Public method | OpenIFCDocument | Opens an IFC document from disk.
Public method | OpenSharedParameterFile | Enables access to shared parameter groups and definitions that are maintained on disk.
Public method | PurgeReleasedAPIObjects | Explicitly purges all API objects that have been released but are still awaiting to be finalized
 | RegisterFailuresProcessor | Registers Revit application-wide instance of Failures Processor.
Public method | SetLibraryPaths | Sets path information identifying where Revit searches for content.
Public method | WriteJournalComment | Writes a comment to the Revit journal file.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace

CopyModel Method

[image]