Revit 2013 API
IExternalService..::..OnServersDisparity Method
IExternalService Interface See Also Send Feedback
Implements this method to get notified that the servers in a just opened document differ from those currently set as active for the service.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
bool OnServersDisparity(
    Document document,
    IList<Guid> oldServers
)
Visual Basic
Function OnServersDisparity ( _
    document As Document, _
    oldServers As IList(Of Guid) _
) As Boolean
Visual C++
bool OnServersDisparity(
    Document^ document,
    IList<Guid>^ oldServers
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The coresponding document
oldServers
Type: System.Collections.Generic..::..IList<(Of <(<'Guid>)>)>
Ids of servers previously used in the document. Please note that the Ids may belong to servers that are currently not registered with the service.

Return Value

Return False if you want the framework to handle the situation; return True if the situation has already been handled.

Remarks

This method may only be invoked in a serializable service. Services registered as non-serializable never receive this call.

This notification is sent when Revit opens a document which has a record of the service used (executed at least once) and the record shows that the server (or servers) used differ from those currently set as active for the service.

Unless the situation is explicitly handled in this call (by returning True), the framework will follow up by assigning the formerly used servers as the currently active servers of that document, after it will notify the service about the change by invoking the OnServersChanged method on the services interface.

See Also

IExternalService Interface
Autodesk.Revit.DB.ExternalService Namespace

IMultiServerService Interface

[image]