Revit 2013 API
IPointCloudAccess Members
IPointCloudAccess Interface Methods See Also Send Feedback

The IPointCloudAccess type exposes the following members.

Methods

 | Name | Description
Public method | CreatePointSetIterator(PointCloudFilter, ElementId) | Implement this method to return an iterator for iterating over blocks of this point cloud.
Public method | CreatePointSetIterator(PointCloudFilter, Double, ElementId) | Implement this method to return an iterator for iterating over blocks of this point cloud.
Public method | Free | Completes the lifetime of the object providing this interface.
Public method | GetColorEncoding | Returns the encoding used by points in this point cloud.
Public method | GetExtent | Implement this method to returns an object that contains the bounding box of the entire point cloud, aligned to the point cloud coordinate system.
Public method | GetName | Implement this method to return the name of the point cloud that will be used when Revit needs to refer to the point cloud type, e.g. in the Manage Links dialog or in the Type Properties dialog.
Public method | GetOffset | Implement this method to return the offset stored in the point cloud.
Public method | GetUnitsToFeetConversionFactor | Implement this method to return the conversion factor from the units of the point cloud to feet.
Public method | ReadPoints | Implement this method so that on successive invocations it will return distinct subsets of points which meet the criterion.

See Also

IPointCloudAccess Interface
Autodesk.Revit.DB.PointClouds Namespace

IPointCloudAccess Methods

[image] [image]