Revit 2013 API
FabricSheetType Methods
FabricSheetType Class See Also Send Feedback

The FabricSheetType type exposes the following members.

Methods

 | Name | Description
Public method | IsValidFabricWireType | Verifies that input is ElementId of a FabricWireType
Public method | IsValidMajorLapSplice |
Public method | IsValidMaterial | Verifies that input is ElementId of a Material
Public method | IsValidMinorLapSplice |
Public method | SetMajorLayoutAsActualSpacing | Set Major Layout Pattern as Actual Spacing.
Public method | SetMajorLayoutAsFixedNumber | Set Major Layout Pattern as Fixed Number.
Public method | SetMajorLayoutAsMaximumSpacing | Set Major Layout Pattern as Maximum Spacing.
Public method | SetMajorLayoutAsNumberWithSpacing | Set Major Layout Pattern as Number with Spacing.
Public method | SetMinorLayoutAsActualSpacing | Set Minor Layout Pattern as Actual Spacing.
Public method | SetMinorLayoutAsFixedNumber | Set Minor Layout Pattern as Fixed Number.
Public method | SetMinorLayoutAsMaximumSpacing | Set Minor Layout Pattern as Maximum Spacing.
Public method | SetMinorLayoutAsNumberWithSpacing | Set Minor Layout Pattern as Number with Spacing.

See Also

FabricSheetType Class
Autodesk.Revit.DB.Structure Namespace

IsValidFabricWireType Method

[image]