Revit 2013 API
Element..::..PhaseDemolished Property
Element Class Example See Also Send Feedback
An object representing the phase for when the element is to be demolished.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This property is obsolete in 2013. Use DemolishedPhaseId instead.")]
public Phase PhaseDemolished { get; }
Visual Basic
<ObsoleteAttribute("This property is obsolete in 2013. Use DemolishedPhaseId instead.")> _
Public ReadOnly Property PhaseDemolished As Phase
    Get
Visual C++
[ObsoleteAttribute(L"This property is obsolete in 2013. Use DemolishedPhaseId instead.")]
public:
property Phase^ PhaseDemolished {
    Phase^ get ();
}

Remarks

The element may not have a demolition phase. If it does not then this property will return nullNothingnullptra null reference (Nothing in Visual Basic).

Examples

CopyC#
void ShowPhaseDemolishedName(Element element)
{
    // Get the Phase Demolished property, and check whether it be null
    Autodesk.Revit.DB.Phase phaseDemolished = element.PhaseDemolished;
    if (null == phaseDemolished)
    {
        TaskDialog.Show("Revit","This Element doesn't have Phase Demolished parameter.");
    }
    else
    {
        // Show the Phase Demolished name to the user.
        String prompt = "The phase demolished is: " + phaseDemolished.Name;
        TaskDialog.Show("Revit",prompt);
    }
}
CopyVB.NET
Sub ShowPhaseDemolishedName(ByVal element As Autodesk.Revit.DB.Element)
    ' Get the Phase Demolished property, and check whether it be null
    Dim phaseDemolished As Autodesk.Revit.DB.Phase = element.PhaseDemolished
    If phaseDemolished Is Nothing Then
        TaskDialog.Show("Revit", "This Element doesn't have Phase Demolished parameter.")
    Else
        ' Show the Phase Demolished name to the user.
        Dim prompt As [String] = "The phase demolished is: " + phaseDemolished.Name
        TaskDialog.Show("Revit", prompt)
    End If
End Sub

See Also

Element Class

Pinned Property

[image]