Revit 2013 API
IFCAnyHandle..::..SetAttribute Method (String, ICollection<(Of <(<'Int32>)>)>)
IFCAnyHandle Class See Also Send Feedback
Sets the attribute value.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetAttribute(
    string name,
    ICollection<int> values
)
Visual Basic
Public Sub SetAttribute ( _
    name As String, _
    values As ICollection(Of Integer) _
)
Visual C++
public:
void SetAttribute(
    String^ name,
    ICollection<int>^ values
)

Parameters

name
Type: System..::..String
The attribute name.
values
Type: System.Collections.Generic..::..ICollection<(Of <(<'Int32>)>)>

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCAnyHandle Class
SetAttribute Overload
Autodesk.Revit.DB.IFC Namespace

SetAttribute Method (String, ICollection(String))

[image]