Revit 2013 API
Material..::..SetMaterialAspectToIndependent Method
Material Class See Also Send Feedback
Set an aspect of the material from a shared property set to a custom property set owned by the material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This function will be removed in a future release. Use setStructuralAssetId or setThermalAssetId instead.")]
public void SetMaterialAspectToIndependent(
    MaterialAspect aspect
)
Visual Basic
<ObsoleteAttribute("This function will be removed in a future release. Use setStructuralAssetId or setThermalAssetId instead.")> _
Public Sub SetMaterialAspectToIndependent ( _
    aspect As MaterialAspect _
)
Visual C++
[ObsoleteAttribute(L"This function will be removed in a future release. Use setStructuralAssetId or setThermalAssetId instead.")]
public:
void SetMaterialAspectToIndependent(
    MaterialAspect aspect
)

Parameters

aspect
Type: Autodesk.Revit.DB..::..MaterialAspect
The material aspect.

Remarks

If the material previously owned a custom property for the given aspect, do nothing If the material previously referred to a shared property set for the given aspect, Revit will create a copy of the shared property set to be owned by this material. If the material did not previously refer to a shared property set, Revit will create a default property set for the given aspect.

See Also

Material Class

SetSmoothness Method

[image]