Revit 2013 API
Document..::..NewAreaViewPlan Method
Document Class See Also Send Feedback
Creates a new view for the new area.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2013.  Call ViewPlan.CreateAreaPlan()  instead.")]
public ViewPlan NewAreaViewPlan(
    string pViewName,
    Level pLevel,
    AreaElemType areaElemType
)
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2013.  Call ViewPlan.CreateAreaPlan()  instead.")> _
Public Function NewAreaViewPlan ( _
    pViewName As String, _
    pLevel As Level, _
    areaElemType As AreaElemType _
) As ViewPlan
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2013.  Call ViewPlan.CreateAreaPlan()  instead.")]
public:
ViewPlan^ NewAreaViewPlan(
    String^ pViewName,
    Level^ pLevel,
    AreaElemType areaElemType
)

Parameters

pViewName
Type: System..::..String
The name of new created view
pLevel
Type: Autodesk.Revit.DB..::..Level
areaElemType
Type: Autodesk.Revit.DB..::..AreaElemType
The type of area element

See Also

Document Class
Autodesk.Revit.Creation Namespace

NewBeamSystem Method

[image] [image]