Revit 2013 API
View3D..::..EyePosition Property
View3D Class See Also Send Feedback
The position of the camera.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This property is obsolete in Revit 2013. Use ViewOrientation3D.EyePosition or View.Origin instead.")]
public XYZ EyePosition { get; }
Visual Basic
<ObsoleteAttribute("This property is obsolete in Revit 2013. Use ViewOrientation3D.EyePosition or View.Origin instead.")> _
Public ReadOnly Property EyePosition As XYZ
    Get
Visual C++
[ObsoleteAttribute(L"This property is obsolete in Revit 2013. Use ViewOrientation3D.EyePosition or View.Origin instead.")]
public:
property XYZ^ EyePosition {
    XYZ^ get ();
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InapplicableDataException | The view is a template and does not have an eye position applied.

See Also

View3D Class

IsLocked Property

[image]