Revit 2013 API
GridTypeSet Members
GridTypeSet Class Constructors Methods Properties See Also Send Feedback

The GridTypeSet type exposes the following members.

Constructors

 | Name | Description
Public method | GridTypeSet | Initializes a new instance of the GridTypeSet class

Methods

 | Name | Description
Public method | Clear | Removes every grid type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a grid type within the set.
Public method | Erase | Removes a specified grid type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | Insert | Insert the specified grid type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | Size | Returns the number of grid types that are in the set.

See Also

GridTypeSet Class

GridTypeSet Constructor

[image]