Revit 2013 API
Element Members
Element Class Methods Properties See Also Send Feedback

The Element type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element.
Public method | CanBeHidden | Indicates if the element can be hidden in the view.
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model.
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned.
 | CanHaveTypeAssigned(Document, ICollection<(Of <<'(ElementId>)>>)) | Checks if all elements in the set can have a type assigned.
Public method | ChangeTypeId(ElementId) | Changes type of the element.
 | ChangeTypeId(Document, ICollection<(Of <<'(ElementId>)>>), ElementId) | Changes the type of all elements in the given set.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element
Public method | Dispose | Releases all resources used by the Element
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element.
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element.
 | GetChangeTypeAny | Returns ChangeType associated with any change in an element.
 | GetChangeTypeElementAddition | Returns ChangeType associated with element addition
 | GetChangeTypeElementDeletion | Returns ChangeType associated with element deletion.
 | GetChangeTypeGeometry | Returns ChangeType associated with a change in the geometry of an element
 | GetChangeTypeParameter(ElementId) | Returns ChangeType associated with a change in a parameter's value
 | GetChangeTypeParameter(Parameter) | Returns ChangeType associated with a change in a parameter's value
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element.
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise.
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element.
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object.
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference.
Public method | GetMaterialArea | Get the area of the given material on this element.
Public method | GetMaterialVolume | Get the volume of the given material on this element.
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring.
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring.
Public method | GetPhaseStatus | Gets the status of a given element in the input phase
Public method | GetTypeId | Returns the identifier of this element's type.
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element.
 | GetValidTypes(Document, ICollection<(Of <<'(ElementId>)>>)) | Obtains a set of types that are valid for all given elements.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId.
Public method | IsExternalFileReference | Determines whether this Element represents an external file.
Public method | IsHidden | Identifies if the element has been permanently hidden in the view.
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models.
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements.
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element.
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element.
 | IsValidType(Document, ICollection<(Of <<'(ElementId>)>>), ElementId) | Checks if given type is valid for the set of elements.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element.
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished.
Public property | DesignOption | Returns the design option to which the element belongs.
Public property | Document | Returns the Document in which the Element resides.
Public property | Geometry | Retrieves the geometric representation of the element.
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic).
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project.
Public property | Level | If the element is level based then level to which the element is assigned is returned.
Public property | Location | This property is used to find the physical location of an element within a project.
Public property | Materials | Get all materials present in the element.
Public property | Name | A human readable name for the Element.
Public property | OwnerViewId | The id of the view that owns the element.
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter.
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name.
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id.
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element.
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element.
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created.
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished.
Public property | Pinned | Identifies if the element has been pinned to prevent changes.
Public property | UniqueId | A stable unique identifier for an element within the document.
Public property | ViewSpecific | Identifies if the element is owned by a view.
Public property | WorksetId | Get Id of the Workset which owns the element.

See Also

Element Class

Element Methods

[image] [image]