Revit 2013 API
EnergyAnalysisSurface Properties
EnergyAnalysisSurface Class See Also Send Feedback

The EnergyAnalysisSurface type exposes the following members.

Properties

 | Name | Description
Public property | Azimuth | The azimuth angle for this surface.
Public property | Corner | The lower-left coordinate for the analytical rectangular geometry viewed from outside.
Public property | Height | The height of the analytical rectangular geometry.
Public property | Id | The unique identifier for the surface.
Public property | Name | The unique name identifier for this surface.
Public property | Normal | The outward normal for this surface.
Public property | OriginatingElementDescription | The description for the originating Revit element.
Public property | OriginatingElementId | The element id for the originating Revit element.
Public property | SurfaceType | The analytical surface type.
Public property | Tilt | The tilt angle for this surface.
Public property | Type | The gbXML surface type attribute.
Public property | Width | The width of the analytical rectangular geometry.

See Also

EnergyAnalysisSurface Class
Autodesk.Revit.DB.Analysis Namespace

Azimuth Property

[image]