Revit 2013 API
ExclusionFilter Class
Members Example See Also Send Feedback
A filter used to exclude a set of elements automatically.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class ExclusionFilter : ElementQuickFilter
Visual Basic
Public Class ExclusionFilter _
    Inherits ElementQuickFilter
Visual C++
public ref class ExclusionFilter : public ElementQuickFilter

Remarks

This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.

Examples

CopyC#
// Use Exclusion filter to find exclude a set of elements in the document automatically

// Find all walls that are not currently selected,
// Get all element ids which are current selected by users, exclude these ids when filtering
ICollection<ElementId> excludes = new List<ElementId>();
ElementSetIterator elemIter = uiDocument.Selection.Elements.ForwardIterator();
elemIter.Reset();
while (elemIter.MoveNext())
{
    Element curElem = elemIter.Current as Element;
    excludes.Add(curElem.Id);
}

// Create filter to exclude all selected element ids
ExclusionFilter filter = new ExclusionFilter(excludes);

// Apply the filter to the elements in the active document,
// Use shortcut method OfClass() to find Walls only
FilteredElementCollector collector = new FilteredElementCollector(uiDocument.Document);
IList<Element> walls = collector.WherePasses(filter).OfClass(typeof(Wall)).ToElements();
CopyVB.NET
' Use Exclusion filter to find exclude a set of elements in the document automatically

' Find all walls that are not currently selected,
' Get all element ids which are current selected by users, exclude these ids when filtering
Dim excludes As ICollection(Of ElementId) = New List(Of ElementId)()
Dim elemIter As ElementSetIterator = uiDocument.Selection.Elements.ForwardIterator()
elemIter.Reset()
While elemIter.MoveNext()
    Dim curElem As Autodesk.Revit.DB.Element = TryCast(elemIter.Current, Autodesk.Revit.DB.Element)
    excludes.Add(curElem.Id)
End While

' Create filter to exclude all selected element ids
Dim filter As New ExclusionFilter(excludes)

' Apply the filter to the elements in the active document,
' Use shortcut method OfClass() to find Walls only
Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(uiDocument.Document)
Dim walls As IList(Of Autodesk.Revit.DB.Element) = collector.WherePasses(filter).OfClass(GetType(Wall)).ToElements()

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementQuickFilter
Autodesk.Revit.DB..::..ExclusionFilter

See Also

ExclusionFilter Members

ExclusionFilter Members

[image] [image]