Revit 2013 API
RebarShape Members
RebarShape Class Methods Properties See Also Send Feedback

The RebarShape type exposes the following members.

Methods

 | Name | Description
 | Create | Create a new instance of a Rebar Shape, which defines the shape of a rebar.
Public method | GetAllowed | Check whether a bar type can be used with this RebarShape. Bar types are allowed by default.
Public method | GetCurvesForBrowser | Generate curves for the shape, as used in the shape browser.
Public method | GetHookAngle | Get the hook angle, expressed as an integral number of degrees (common values are 0, 90, 135, and 180).
Public method | GetHookOrientation | Get the hook orientation.
Public method | GetMultiplanarDefinition | The optional 3D structure of the shape.
Public method | GetRebarShapeDefinition | Return the definition of the RebarShape.
Public method | IsSameShapeIgnoringHooks | Test whether two shapes have equivalent definitions by comparing the RebarShapeDefinition and MultiplanarDefinition properties.
Public method | SetAllowed | Specify which bar types can be used with this RebarShape. Bar types are allowed by default.

Properties

 | Name | Description
Public property | HigherEnd | Defines the higher end of rebar shape.
Public property | RebarStyle | Whether the shape represents a standard bar or a stirrup.
Public property | SimpleArc | Check whether this shape consists of a single arc, possibly with hooks.
Public property | SimpleLine | Check whether this shape consists of a single straight segment, possibly with hooks.
Public property | StirrupTieAttachment |

See Also

RebarShape Class
Autodesk.Revit.DB.Structure Namespace

RebarShape Methods

[image] [image]