Revit 2013 API
FabricSheet..::..GetWireCenterlines Method (WireDistributionDirection)
FabricSheet Class See Also Send Feedback
A list of curves representing the wires centerlines of the Fabric Sheet.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IList<Curve> GetWireCenterlines(
    WireDistributionDirection wireDirection
)
Visual Basic
Public Function GetWireCenterlines ( _
    wireDirection As WireDistributionDirection _
) As IList(Of Curve)
Visual C++
public:
IList<Curve^>^ GetWireCenterlines(
    WireDistributionDirection wireDirection
)

Parameters

wireDirection
Type: Autodesk.Revit.DB.Structure..::..WireDistributionDirection
Direction of wire distribution in the Fabric Sheet.

Return Value

The centerline curves or empty array if the curves cannot be computed.

See Also

FabricSheet Class
GetWireCenterlines Overload
Autodesk.Revit.DB.Structure Namespace

FabricSheet Properties

[image] [image]