Revit 2013 API
RevitServerException Class
Members See Also Send Feedback
The exception that is base class for all exceptions originating from the Revit server.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[SerializableAttribute]
public class RevitServerException : ApplicationException
Visual Basic
<SerializableAttribute> _
Public Class RevitServerException _
    Inherits ApplicationException
Visual C++
[SerializableAttribute]
public ref class RevitServerException : public ApplicationException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Autodesk.Revit.Exceptions..::..ApplicationException
Autodesk.Revit.Exceptions..::..RevitServerException
Autodesk.Revit.Exceptions..::..RevitServerCommunicationException
Autodesk.Revit.Exceptions..::..RevitServerInternalException
Autodesk.Revit.Exceptions..::..RevitServerModelContentionException

See Also

RevitServerException Members
Autodesk.Revit.Exceptions Namespace

RevitServerException Members

[image] [image]