Revit 2013 API
ElementTransformUtils..::..MirrorElement Method
ElementTransformUtils Class Example See Also Send Feedback
Creates a mirrored copy of an element about a given plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static void MirrorElement(
    Document document,
    ElementId elementToMirror,
    Plane plane
)
Visual Basic
Public Shared Sub MirrorElement ( _
    document As Document, _
    elementToMirror As ElementId, _
    plane As Plane _
)
Visual C++
public:
static void MirrorElement(
    Document^ document,
    ElementId^ elementToMirror,
    Plane^ plane
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document that owns the element.
elementToMirror
Type: Autodesk.Revit.DB..::..ElementId
The element to mirror.
plane
Type: Autodesk.Revit.DB..::..Plane
The mirror plane.

Examples

CopyC#
public void MirrorWall(Autodesk.Revit.DB.Document document, Wall wall)
{
    Reference reference = HostObjectUtils.GetSideFaces(wall, ShellLayerType.Exterior).First();
    Face face = wall.GetGeometryObjectFromReference(reference) as Face; // get one of the wall's major side faces

    UV bboxMin = face.GetBoundingBox().Min;
    Plane plane = new Plane(face.ComputeNormal(bboxMin), face.Evaluate(bboxMin).Add(new XYZ(10, 10, 0)));
    // create a plane based on this side face with an offset of 10 in the X & Y directions

    ElementTransformUtils.MirrorElement(document, wall.Id, plane);
}
CopyVB.NET
Public Sub MirrorColumn(ByVal document As Autodesk.Revit.DB.Document, ByVal column As Autodesk.Revit.DB.FamilyInstance)
    Dim uidoc As New UIDocument(document)
    Dim analytical As Autodesk.Revit.DB.Structure.AnalyticalModel = TryCast(column.GetAnalyticalModel(), Autodesk.Revit.DB.Structure.AnalyticalModel)
    Dim lineReference As Reference = analytical.GetCurve().Reference
    document.Mirror(column, lineReference)

    'The selected element is changed after the Mirror operation.
    For Each newColumn As Autodesk.Revit.DB.FamilyInstance In uidoc.Selection.Elements
        Dim isMirror As Boolean = newColumn.Mirrored

        TaskDialog.Show("Revit", "Column is mirrored: " + isMirror)

        'Offset the new column
        Dim translationVec As New Autodesk.Revit.DB.XYZ(10, 20, 30)
        newColumn.Location.Move(translationVec)
    Next
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | elementToMirror cannot be mirrored. -or- The element elementToMirror does not exist in the document
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ElementTransformUtils Class

MirrorElements Method

[image]