Revit 2013 API
ConnectorElement..::..CreateElectricalConnector Method
ConnectorElement Class See Also Send Feedback
Create a new electrical ConnectorElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static ConnectorElement CreateElectricalConnector(
    Document document,
    ElectricalSystemType electricalSystemType,
    Reference planarFace
)
Visual Basic
Public Shared Function CreateElectricalConnector ( _
    document As Document, _
    electricalSystemType As ElectricalSystemType, _
    planarFace As Reference _
) As ConnectorElement
Visual C++
public:
static ConnectorElement^ CreateElectricalConnector(
    Document^ document,
    ElectricalSystemType electricalSystemType,
    Reference^ planarFace
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to add the connector to.
electricalSystemType
Type: Autodesk.Revit.DB.Electrical..::..ElectricalSystemType
The ElectricalSystemTYpe of the connector.
planarFace
Type: Autodesk.Revit.DB..::..Reference
The planar face to place the connector on.

Return Value

The electrical ConnectorElement.

Remarks

Regenerates the document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The reference is not a planar face. -or- document is not a family document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | Connector creation is not allowed in this family.

See Also

ConnectorElement Class

CreatePipeConnector Method

[image]