Revit 2013 API
AnalyticalModel..::..GetPoint Method
AnalyticalModel Class Example See Also Send Feedback
Retrieves point of the Analytical Model.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public XYZ GetPoint()
Visual Basic
Public Function GetPoint As XYZ
Visual C++
public:
XYZ^ GetPoint()

Return Value

Point of the Analytical Model.

Examples

CopyC#
// retrieve and iterate current selected element
UIDocument uidoc = commandData.Application.ActiveUIDocument;
ElementSet selection = uidoc.Selection.Elements;
foreach (Element e in selection)
{
    // if the element is structural footing
    FamilyInstance familyInst = e as FamilyInstance;
    if (null != familyInst && familyInst.StructuralType == StructuralType.Footing)
    {
        AnalyticalModel model = familyInst.GetAnalyticalModel();
        // structural footing should be expressable as a single point
        if (model.IsSinglePoint() == true)
        {
            XYZ analyticalLocationPoint = model.GetPoint();
        }
    }
}
CopyVB.NET
' retrieve and iterate current selected element
Dim uidoc As UIDocument = commandData.Application.ActiveUIDocument
Dim selection As ElementSet = uidoc.Selection.Elements
For Each e As Autodesk.Revit.DB.Element In selection
    ' if the element is structural footing
    Dim familyInst As Autodesk.Revit.DB.FamilyInstance = TryCast(e, Autodesk.Revit.DB.FamilyInstance)
    If familyInst IsNot Nothing AndAlso familyInst.StructuralType = Autodesk.Revit.DB.Structure.StructuralType.Footing Then
        Dim model As Autodesk.Revit.DB.Structure.AnalyticalModel = familyInst.GetAnalyticalModel()
        ' structural footing should be expressable as a single point
        If model.IsSinglePoint() = True Then
            Dim analyticalLocationPoint As Autodesk.Revit.DB.XYZ = model.GetPoint()
        End If
    End If

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InapplicableDataException | This AnalyticalModel cannot be expressed as a single point.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace

GetReference Method

[image]