Revit 2013 API
GeometryObjectArray Members
GeometryObjectArray Class Constructors Methods Properties See Also Send Feedback

The GeometryObjectArray type exposes the following members.

Constructors

 | Name | Description
Public method | GeometryObjectArray | Initializes a new instance of the GeometryObjectArray class

Methods

 | Name | Description
Public method | Append | Add the geometry object to the end of the array.
Public method | Clear | Removes every geometry object from the array, rendering it empty.
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | Insert | Insert the specified geometry object into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | Item | Gets or sets a geometry object at a specified index within the array.
Public property | Size | Returns the number of geometry objects that are in the array.

See Also

GeometryObjectArray Class

GeometryObjectArray Constructor

[image]