Revit 2013 API
UIApplication Class
Members See Also Send Feedback
Represents an active session of the Autodesk Revit user interface, providing access to UI customization methods, events, and the active document.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public class UIApplication : IDisposable
Visual Basic
Public Class UIApplication _
    Implements IDisposable
Visual C++
public ref class UIApplication : IDisposable

Remarks

You can access documents from the database level Application object, obtained from the Application property. If you have an instance of the database level Application object, you can construct a UIApplication from it.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.UI..::..UIApplication

See Also

UIApplication Members
Autodesk.Revit.UI Namespace

UIApplication Members

[image] [image]