Revit 2013 API
ExporterIFC..::..GetOwnerHistoryHandle Method
ExporterIFC Class See Also Send Feedback
Gets the handle to the IfcOwnerHistory for the file.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IFCAnyHandle GetOwnerHistoryHandle()
Visual Basic
Public Function GetOwnerHistoryHandle As IFCAnyHandle
Visual C++
public:
IFCAnyHandle^ GetOwnerHistoryHandle()

Return Value

The handle to the IfcOwnerHistory for the file.

Remarks

IfcOwnerHistory defines all history and identification related information. In order to provide fast access it is directly attached to all independent objects, relationships and properties. IfcOwnerHistory is used to identify the creating and owning application and user for the associated object, as well as capture the last modifying application and user. Currently in Revit export to IFC, there is one owner history for the entire file with some default (for the file) values.

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace

GetProject Method

[image]