Revit 2013 API
MassSurfaceData..::..MaterialType Property
MassSurfaceData Class See Also Send Feedback
material type of mass zone

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public MassSurfaceDataMaterialType MaterialType { get; set; }
Visual Basic
Public Property MaterialType As MassSurfaceDataMaterialType
    Get
    Set
Visual C++
public:
property MassSurfaceDataMaterialType MaterialType {
    MassSurfaceDataMaterialType get ();
    void set (MassSurfaceDataMaterialType value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The material type does not fall within an appropriate range.

See Also

MassSurfaceData Class
Autodesk.Revit.DB.Analysis Namespace

Parameter Property

[image] [image]