Revit 2013 API
LineLoad Class
Members Example See Also Send Feedback
An object that represents a force/moment applied in a linear manner.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class LineLoad : LoadBase
Visual Basic
Public Class LineLoad _
    Inherits LoadBase
Visual C++
public ref class LineLoad : public LoadBase

Remarks

The load/moment may be uniform or it may vary between the two ends of the line.

Examples

CopyC#
 private void LineLoadInformation(LineLoad lineLoad)
{
     StringBuilder information = new StringBuilder("Line Load: ");

     // Get the load case name
     information.Append("\nLoad case for load: " + lineLoad.LoadCaseName);

     //Get the three dimensional force applied to the start point and end point of the line load.
     information.Append("\nForce at the start of this line load: " + XYZToString(lineLoad.Force1));
     information.Append("\nForce at the end of this line load: " + XYZToString(lineLoad.Force2));

     //Get the three dimensional location of the start point and end point for the line load.
     information.Append("\nStart point of this line load: " + XYZToString(lineLoad.StartPoint));
     information.Append("\nEnd Point of this line load: " + XYZToString(lineLoad.EndPoint));

     //Get the three dimensional moment applied to the start point and end point of the line load.
     information.Append("\nMoment at the start of this line load: " + XYZToString(lineLoad.Moment1));
     information.Append("\nMoment at the end of this line load: " + XYZToString(lineLoad.Moment2));

     //Whether the load is projected or not
     if (lineLoad.ProjectedLoad)
     {
         information.Append("\nThis line load is projected.");
     }
     else
     {
         information.Append("\nThis line load is not projected");
     }

     //Report if the load is uniform
     if (false != lineLoad.UniformLoad)
     {
         information.Append("\nThis load is uniform.");
     }
     else
     {
         information.Append("\nThis load is not uniform.");
     }

     //show information of lineload in a MessageBox.
     TaskDialog.Show("Revit",information.ToString());
 }

 // output the point's three coordinates
 string XYZToString(XYZ point)
 {
     return "(" + point.X + ", " + point.Y + ", " + point.Z + ")";
 }
CopyVB.NET
Private Sub LineLoadInformation(ByVal lineLoad As Autodesk.Revit.DB.Structure.LineLoad)
    Dim information As New StringBuilder("Line Load: ")

    ' Get the load case name
    information.Append(vbLf & "Load case for load: " + lineLoad.LoadCaseName)

    'Get the three dimensional force applied to the start point and end point of the line load.
    information.Append(vbLf & "Force at the start of this line load: " + XYZToString(lineLoad.Force1))
    information.Append(vbLf & "Force at the end of this line load: " + XYZToString(lineLoad.Force2))

    'Get the three dimensional location of the start point and end point for the line load.
    information.Append(vbLf & "Start point of this line load: " + XYZToString(lineLoad.StartPoint))
    information.Append(vbLf & "End Point of this line load: " + XYZToString(lineLoad.EndPoint))

    'Get the three dimensional moment applied to the start point and end point of the line load.
    information.Append(vbLf & "Moment at the start of this line load: " + XYZToString(lineLoad.Moment1))
    information.Append(vbLf & "Moment at the end of this line load: " + XYZToString(lineLoad.Moment2))

    'Whether the load is projected or not
    If lineLoad.ProjectedLoad Then
        information.Append(vbLf & "This line load is projected.")
    Else
        information.Append(vbLf & "This line load is not projected")
    End If

    'Report if the load is uniform
    If 0 <> lineLoad.UniformLoad Then
        information.Append(vbLf & "This load is uniform.")
    Else
        information.Append(vbLf & "This load is not uniform.")
    End If

    'show information of lineload in a MessageBox.
    TaskDialog.Show("Revit", information.ToString())
End Sub

' output the point's three coordinates
Function XYZToString(ByVal point As Autodesk.Revit.DB.XYZ) As String
    Return "(" + point.X + ", " + point.Y + ", " + point.Z + ")"
End Function

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB.Structure..::..LoadBase
Autodesk.Revit.DB.Structure..::..LineLoad

See Also

LineLoad Members
Autodesk.Revit.DB.Structure Namespace

LineLoad Members

[image] [image]