Revit 2013 API
CompoundStructure Class
Members See Also Send Feedback
Describes the internal structure of a wall, floor, roof or ceiling.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class CompoundStructure : IDisposable
Visual Basic
Public Class CompoundStructure _
    Implements IDisposable
Visual C++
public ref class CompoundStructure : IDisposable

Remarks

If IsVerticallyCompound is false, then it describes a series of parallel layers, each with specified width, function, material etc. If IsVerticallyCompound is true (which should apply only for CompoundStructures assigned to walls) then horizontal sections at different elevations may have different layered structures. In this case, the structure describes a vertical section via a rectangle which is divided into polygonal regions whose sides are all vertical or horizontal segments. A map associates each of these regions with the index of a layer in the CompoundStructure which determines the properties of that region.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..CompoundStructure

See Also

CompoundStructure Members

CompoundStructure Members

[image] [image]