Revit 2013 API
ExporterIFC..::..RegisterSpatialElementHandle Method
ExporterIFC Class See Also Send Feedback
Stores a handle representing a spatial element to the ExporterIFC's internal cache.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void RegisterSpatialElementHandle(
    ElementId id,
    IFCAnyHandle hnd
)
Visual Basic
Public Sub RegisterSpatialElementHandle ( _
    id As ElementId, _
    hnd As IFCAnyHandle _
)
Visual C++
public:
void RegisterSpatialElementHandle(
    ElementId^ id,
    IFCAnyHandle^ hnd
)

Parameters

id
Type: Autodesk.Revit.DB..::..ElementId
The spatial element id.
hnd
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The handle representing the spatial element.

Remarks

The cache of spatial elements will be used in UpdateRoomRelativeCoordinates and during completion of export to create relationship objects such as IfcRelContainedInSpatialStructure.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace

RelateSpatialElement Method

[image]