Revit 2013 API
AssemblyViewUtils..::..Create3DOrthographic Method
AssemblyViewUtils Class See Also Send Feedback
Creates a new orthographic 3D assembly view for the assembly instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static View3D Create3DOrthographic(
    Document document,
    ElementId assemblyInstanceId
)
Visual Basic
Public Shared Function Create3DOrthographic ( _
    document As Document, _
    assemblyInstanceId As ElementId _
) As View3D
Visual C++
public:
static View3D^ Create3DOrthographic(
    Document^ document,
    ElementId^ assemblyInstanceId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the view will be added.
assemblyInstanceId
Type: Autodesk.Revit.DB..::..ElementId
Id of the assembly instance that owns the new view.

Return Value

A new orthographic 3D assembly view.

Remarks

The view will have the same orientation as the Default 3D view. The document must be regenerated before using the 3D view.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | assemblyInstanceId is not an AssemblyInstance.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AssemblyViewUtils Class

CreateDetailSection Method

[image]