Revit 2013 API
AnalysisDisplayDiagramSettings Constructor (AnalysisDisplayDiagramSettings)
AnalysisDisplayDiagramSettings Class See Also Send Feedback
Constructs a copy of diagram settings object.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public AnalysisDisplayDiagramSettings(
    AnalysisDisplayDiagramSettings other
)
Visual Basic
Public Sub New ( _
    other As AnalysisDisplayDiagramSettings _
)
Visual C++
public:
AnalysisDisplayDiagramSettings(
    AnalysisDisplayDiagramSettings^ other
)

Parameters

other
Type: Autodesk.Revit.DB.Analysis..::..AnalysisDisplayDiagramSettings
Diagram settings object to copy.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AnalysisDisplayDiagramSettings Class
AnalysisDisplayDiagramSettings Overload
Autodesk.Revit.DB.Analysis Namespace

AnalysisDisplayDiagramSettings Methods

[image] [image]