Revit 2013 API
PlumbingUtils Members
PlumbingUtils Class Methods See Also Send Feedback

The PlumbingUtils type exposes the following members.

Methods

 | Name | Description
 | ConnectPipePlaceholdersAtCross(Document, ElementId, ElementId) | Connects placeholders that looks like Cross connection.
 | ConnectPipePlaceholdersAtCross(Document, ElementId, ElementId, ElementId) | Connects placeholders that looks like Cross connection.
 | ConnectPipePlaceholdersAtCross(Document, Connector, Connector, Connector, Connector) | Connects placeholders that looks like Cross connection.
 | ConnectPipePlaceholdersAtElbow(Document, Connector, Connector) | Connects placeholders that looks like elbow connection.
 | ConnectPipePlaceholdersAtElbow(Document, ElementId, ElementId) | Connects placeholders that looks like elbow connection.
 | ConnectPipePlaceholdersAtTee(Document, ElementId, ElementId) | Connects two placeholders that looks like Tee connection.
 | ConnectPipePlaceholdersAtTee(Document, Connector, Connector, Connector) | Connects three placeholders that looks like Tee connection.
 | ConvertPipePlaceholders | Converts a collection of pipe placeholder elements into pipe elements.
Public method | Dispose | Releases all resources used by the PlumbingUtils

See Also

PlumbingUtils Class
Autodesk.Revit.DB.Plumbing Namespace

PlumbingUtils Methods

[image] [image]