Revit 2013 API
ExporterIFC..::..FindSpatialElementHandle Method
ExporterIFC Class See Also Send Feedback
Looks up the handle associated to the element id from the ExporterIFC's internal cache.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IFCAnyHandle FindSpatialElementHandle(
    ElementId id
)
Visual Basic
Public Function FindSpatialElementHandle ( _
    id As ElementId _
) As IFCAnyHandle
Visual C++
public:
IFCAnyHandle^ FindSpatialElementHandle(
    ElementId^ id
)

Parameters

id
Type: Autodesk.Revit.DB..::..ElementId
The spatial element id to look for.

Return Value

The handle associated to the element id. If the id is not found in the cache, an empty handle is returned (HasValue == false).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace

Get2DContextHandle Method

[image]