Revit 2013 API
PartUtils..::..IsValidSketchPlane Method
PartUtils Class See Also Send Feedback
Identifies if provided sketch plane is valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2013; use PartMakerMethodToDivideVolumes.IsValidSketchPlane() instead.")]
public static bool IsValidSketchPlane(
    Document document,
    ElementId sketchPlaneId
)
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2013; use PartMakerMethodToDivideVolumes.IsValidSketchPlane() instead.")> _
Public Shared Function IsValidSketchPlane ( _
    document As Document, _
    sketchPlaneId As ElementId _
) As Boolean
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2013; use PartMakerMethodToDivideVolumes.IsValidSketchPlane() instead.")]
public:
static bool IsValidSketchPlane(
    Document^ document,
    ElementId^ sketchPlaneId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
sketchPlaneId
Type: Autodesk.Revit.DB..::..ElementId
SketchPlane ids to be tested for validity for PartMaker.

Return Value

True if SketchPlane valid, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PartUtils Class

PartMakerUsesReference Method

[image]