Revit 2013 API
Line..::..Bound Property
Line Class See Also Send Feedback
Returns the bounded line between the specified points.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static Line this[
    XYZ startPoint,
    XYZ endPoint
] { get; }
Visual Basic
Public Shared ReadOnly Property Bound ( _
    startPoint As XYZ, _
    endPoint As XYZ _
) As Line
    Get
Visual C++
public:
static property Line^ Bound[XYZ^ startPoint, XYZ^ endPoint] {
    Line^ get (XYZ^ startPoint, XYZ^ endPoint);
}

Parameters

startPoint
Type: Autodesk.Revit.DB..::..XYZ
The start point of the line.
endPoint
Type: Autodesk.Revit.DB..::..XYZ
The end point of the line.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the specified points are almost equal.

See Also

Line Class

Direction Property

[image]