Revit 2013 API
StructuralSettings Properties
StructuralSettings Class See Also Send Feedback

The StructuralSettings type exposes the following members.

Properties

 | Name | Description
Public property | AnalyticalModelAdjustmentTolerance | Tolerance for the analytical adjustment distance.
Public property | AnalyticalModelAutoCheckConsistency | Whether to check automatically for consistency between the analytical and physical models.
Public property | AnalyticalModelAutoCheckMemberSupports | Whether to check automatically for member supports.
Public property | AnalyticalModelCheckAdjustment | Whether to check for analytical model distance from default location is larger than the tolerance defined by the property AnalyticalModelAdjustmentTolerance.
Public property | AnalyticalModelCheckBeamSlabDistance | Whether to check the analytical model distance between beam and slab for a level.
Public property | AnalyticalModelCheckCircularReferences | Whether to check member supports for circular references.
Public property | AnalyticalModelCheckDiscrepancy | Whether to check for distance between analytical and physical models greater than a tolerance defined by AnalyticalModelDiscrepancyTolerance.
Public property | AnalyticalModelCheckInstability | Whether to check for possible instability based on release conditions.
Public property | AnalyticalModelCheckSupportDistance | Check that joins in the physical model are consistent with proximity in the analytical model.
Public property | AnalyticalModelDiscrepancyTolerance | Tolerance for the analytical-to-physical model distance.
Public property | AnalyticalModelHorizontalAutofixTolerance | Tolerance for horizontal auto-detect for the analytical model.
Public property | AnalyticalModelSupportDistanceTolerance | The maximum distance between two structural elements, where analytical model support rules still apply.
Public property | AnalyticalModelVerticalAutofixTolerance | Tolerance for vertical auto-detect for the analytical model.
Public property | BoundaryConditionAreaAndLineSymbolSpacing | Symbol spacing for boundary conditions.
Public property | BoundaryConditionFamilySymbolFixed | The id of the FamilySymbol to represent a fixed boundary condition.
Public property | BoundaryConditionFamilySymbolPinned | The id of the FamilySymbol to represent a pinned boundary condition.
Public property | BoundaryConditionFamilySymbolRoller | The id of the FamilySymbol to represent a roller boundary condition.
Public property | BoundaryConditionFamilySymbolUserDefined | The id of the FamilySymbol to represent a user-defined boundary condition.
Public property | BraceAboveSymbol | The id of the ElementType to represent a brace above a beam in plan view.
Public property | BraceBelowSymbol | The id of the ElementType to represent a brace below a beam in plan view.
Public property | BraceParallelLineOffset | The distance by which brace symbols in plan views will be offset.
Public property | CheckAnalyticalModelAsset | Whether to check for valid Asset within the Material of associated Physical Element.
Public property | DifferentiateAnalyticalEnds | Whether to use a subcategory for the ends of a linear analytical model, rather than the main category.
Public property | KickerBraceSymbol | The id of the ElementType to represent a kicker brace.
Public property | ShowBraceAbove | Whether to show brace symbols above beams in plan views.
Public property | ShowBraceBelow | Whether to show brace symbols below beams in plan views.
Public property | SymbolicCutbackForBeamAndTruss | Symbolic cutback distance to be applied to all beams and trusses.
Public property | SymbolicCutbackForBrace | Symbolic cutback distance to be applied to all braces.
Public property | SymbolicCutbackForColumn | Symbolic cutback distance to be applied to all columns.

See Also

StructuralSettings Class
Autodesk.Revit.DB.Structure Namespace

AnalyticalModelAdjustmentTolerance Property

[image]