Revit 2013 API
AnalyticalModel..::..GetAnalyticalProjectionType Method (AnalyticalElementSelector, AnalyticalDirection)
AnalyticalModel Class See Also Send Feedback
Retrieves Analytical Model projection information for a specific direction. in direction: direction in which the Analytical Model may be projected.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public AnalyticalProjectionType GetAnalyticalProjectionType(
    AnalyticalElementSelector selector,
    AnalyticalDirection direction
)
Visual Basic
Public Function GetAnalyticalProjectionType ( _
    selector As AnalyticalElementSelector, _
    direction As AnalyticalDirection _
) As AnalyticalProjectionType
Visual C++
public:
AnalyticalProjectionType GetAnalyticalProjectionType(
    AnalyticalElementSelector selector,
    AnalyticalDirection direction
)

Parameters

selector
Type: Autodesk.Revit.DB.Structure..::..AnalyticalElementSelector
End of the analytical model.
direction
Type: Autodesk.Revit.DB.Structure..::..AnalyticalDirection
Direction of the analytical model.

Return Value

Indicates if the projection is a preset value, or refers to a Datum Plane.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | direction is invalid for analytical model

See Also

AnalyticalModel Class
GetAnalyticalProjectionType Overload
Autodesk.Revit.DB.Structure Namespace

GetAnalyzeAs Method

[image]