Revit 2013 API
FamilySymbolSet Members
FamilySymbolSet Class Constructors Methods Properties See Also Send Feedback

The FamilySymbolSet type exposes the following members.

Constructors

 | Name | Description
Public method | FamilySymbolSet | Initializes a new instance of the FamilySymbolSet class

Methods

 | Name | Description
Public method | Clear | Removes every symbol from the set, rendering it empty.
Public method | Contains | Tests for the existence of a family symbol within the set.
Public method | Erase | Removes a specified family symbol from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | Insert | Insert the specified family symbol into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | Size | Returns the number of family symbols that are in the set.

See Also

FamilySymbolSet Class

FamilySymbolSet Constructor

[image]