Revit 2013 API
ExporterIFCUtils..::..CreatePreCOBIEGSAQuantities Method
ExporterIFCUtils Class See Also Send Feedback
Creates the spatial element quantities required by GSA before COBIE and adds them to the export.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static void CreatePreCOBIEGSAQuantities(
    ExporterIFC exporterIFC,
    IFCAnyHandle elemHnd,
    string quantityName,
    string areaName,
    double dArea
)
Visual Basic
Public Shared Sub CreatePreCOBIEGSAQuantities ( _
    exporterIFC As ExporterIFC, _
    elemHnd As IFCAnyHandle, _
    quantityName As String, _
    areaName As String, _
    dArea As Double _
)
Visual C++
public:
static void CreatePreCOBIEGSAQuantities(
    ExporterIFC^ exporterIFC,
    IFCAnyHandle^ elemHnd,
    String^ quantityName,
    String^ areaName,
    double dArea
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
elemHnd
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The spatial element handle.
quantityName
Type: System..::..String
The name of the quantity.
areaName
Type: System..::..String
The name of the area.
dArea
Type: System..::..Double
The area value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace

CreateProjectLevelGUID Method

[image]