Revit 2013 API
ExporterIFC Members
ExporterIFC Class Methods Properties See Also Send Feedback

The ExporterIFC type exposes the following members.

Methods

 | Name | Description
Public method | AddBuildingStorey | Adds building storey to the exporter's internal cache.
Public method | AddViewIdToExport | Adds a view to be exported to the exporter's internal cache.
Public method | Dispose | Releases all resources used by the ExporterIFC
Public method | FindSpaceBoundingElementHandle | Looks up the handle associated to the element and level id from the ExporterIFC's internal cache.
Public method | FindSpatialElementHandle | Looks up the handle associated to the element id from the ExporterIFC's internal cache.
Public method | Get2DContextHandle | Obtains the IfcRepresentationContext handle to be used for 2D entities (Annotations).
Public method | Get3DContextHandle | Obtains the IfcRepresentationContext or IfcRepresentationSubContext handle to be used for 3D entities (Model entities).
Public method | GetBuilding | Gets the global IfcBuilding object.
Public method | GetFamilyName | Gets the name of the element assigned to the current export state.
Public method | GetFile | Gets the handle to the IFC file being created during this export operation.
Public method | GetHostObjects | Returns a collection containing the host object handles in the document.
Public method | GetLevelInfo | Returns an object representing the information about a level in the document.
Public method | GetLevelInfos | Returns a collection containing the information about all levels in the document.
Public method | GetMaterialIdForCurrentExportState | This gets the material id that is associated with the element in the current export state.
Public method | GetName | Gets the name of the element assigned to the current export state.
Public method | GetOptions | Gets the collection of named options set by the exporter client.
Public method | GetOrCreateFillPattern | Get (or create) the IfcFillPatternStyle associated with an ElementId.
Public method | GetOwnerHistoryHandle | Gets the handle to the IfcOwnerHistory for the file.
Public method | GetProject | Gets the global IfcProject object.
Public method | GetRelatedElements | Gets all elements not associated to stories.
Public method | GetRelatedProducts | Gets all products not associated to stories.
Public method | GetSite | Gets the global IfcSite object.
Public method | GetStairRampContainers | Returns all of the IFCStairContainmentInfos created, with the id of the associated Stairs or Ramp element.
Public method | GetViewIdsToExport | Returns the ids of the views to be exported.
Public method | PopExportState | Resets the internal state of the exporter to process the previously active input element (if any), or the default state if the stack is empty.
Public method | PushExportState | Sets the internal state of the exporter to process the geometry and properties of the input element.
Public method | RegisterDoorWindowForOpeningUpdate | Registers information about a door or window with the ExporterIFC's internal cache so that an existing opening applied to wall elements will have its size updated based on the size of the instance.
Public method | RegisterDoorWindowForUncreatedOpening | Registers a door or window in the ExporterIFC's internal cache. The ids registered correspond to openings in walls which have not been processed and created yet.
Public method | RegisterShapeForPresentationLayer | Sets an IfcShapeRepresentation to be used for the IfcPresentationLayerAssignment associated with the given Revit category and element.
Public method | RegisterSpaceBoundingElementHandle | Stores a handle representing a space bounding element to the ExporterIFC's internal cache.
Public method | RegisterSpatialElementHandle | Stores a handle representing a spatial element to the ExporterIFC's internal cache.
Public method | RelateSpatialElement | Relates the input element handle to the given spatial element.
Public method | RemoveBuildingStorey | Removes an IFCLevelInfo corresponding to a level from the exporter's internal cache.
Public method | Set2DContextHandle | Sets the IfcRepresentationContext handle to be used for 2D entities (Annotations).
Public method | Set3DContextHandle | Sets the IfcRepresentationContext or IfcRepresentationSubContext handle to be used for 3D entities (Model entities).
Public method | SetBuilding | Sets the global IfcBuilding object.
Public method | SetFile | Sets the handle to the IFC file being created during this export operation.
Public method | SetMaterialIdForCurrentExportState | This sets the material id that is to be associated with the element in the current export state.
Public method | SetOwnerHistoryHandle | Sets the handle to the IfcOwnerHistory for the file.
Public method | SetProject | Sets the global IfcProject object.
Public method | SetSite | Sets the global IfcSite object.

Properties

 | Name | Description
Public property | ExportAs2x2 | Identifies if the file version being exported is 2x2.
Public property | ExportAs2x3 | Identifies if the file version being exported is 2x3.
Public property | ExportBaseQuantities | Identifies if the export should include IFC standard quantities currently supported by Revit.
Public property | FileName |
Public property | FileVersion | Identifies the file version being exported.
Public property | LinearScale | The scale factor from feet to the display units of the document.
Public property | SpaceBoundaryLevel | Identifies the level of space boundaries being exported.
Public property | WallAndColumnSplitting | Identifies if division of multi-level walls and columns by levels should take place during this export.

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace

ExporterIFC Methods

[image] [image]