Revit 2013 API
ViewSheet Methods
ViewSheet Class See Also Send Feedback

The ViewSheet type exposes the following members.

Methods

 | Name | Description
Public method | AddView | Obsolete. Places view on the sheet at the given location.
Public method | ConvertToRealSheet | Convert a placeholder sheet to a real one with an optional titleblock
 | Create | Creates a new ViewSheet.
 | CreatePlaceholder | Create a placeholder sheet in document.
Public method | DeleteViewport | Removes a viewport from the sheet by deleting it from the document.
Public method | GetAllViewports | Returns the ElementIds of Viewports on this sheet.

See Also

ViewSheet Class

AddView Method

[image]