Revit 2013 API
Wall..::..Create Method (Document, Curve, ElementId, Boolean)
Wall Class See Also Send Feedback
Creates a new rectangular profile wall within the project using the default wall style.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static Wall Create(
    Document document,
    Curve curve,
    ElementId levelId,
    bool structural
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    curve As Curve, _
    levelId As ElementId, _
    structural As Boolean _
) As Wall
Visual C++
public:
static Wall^ Create(
    Document^ document,
    Curve^ curve,
    ElementId^ levelId,
    bool structural
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which the new wall is created.
curve
Type: Autodesk.Revit.DB..::..Curve
An arc or line representing the base line of the wall.
levelId
Type: Autodesk.Revit.DB..::..ElementId
Id of the level on which the wall is to be placed.
structural
Type: System..::..Boolean
If set, specifies that the wall is structural in nature.

Return Value

If successful a new wall object within the project.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The curve argument is not valid for rectangular wall creation. -or- The input curve points to a helical curve and is not supported for this operation.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

Wall Class
Create Overload

Create Method (Document, IList(Curve), ElementId, ElementId, Boolean)

[image]