Revit 2013 API
LabelUtils..::..GetLabelFor Method (DisplayUnitType)
LabelUtils Class See Also Send Feedback
Gets user-visible name for DisplayUnitType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static string GetLabelFor(
    DisplayUnitType displayUnitType
)
Visual Basic
Public Shared Function GetLabelFor ( _
    displayUnitType As DisplayUnitType _
) As String
Visual C++
public:
static String^ GetLabelFor(
    DisplayUnitType displayUnitType
)

Parameters

displayUnitType
Type: Autodesk.Revit.DB..::..DisplayUnitType
The DisplayUnitType to get the user-visible name.

Remarks

The name is obtained in the current Revit language.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when information for the input DisplayUnitType cannot be found.

See Also

LabelUtils Class
GetLabelFor Overload

GetLabelFor Method (ParameterType)

[image]