Revit 2013 API
Dimension..::..IsLocked Property
Dimension Class See Also Send Feedback
Indicates if this dimension is locked.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsLocked { get; set; }
Visual Basic
Public Property IsLocked As Boolean
    Get
    Set
Visual C++
public:
property bool IsLocked {
    bool get ();
    void set (bool value);
}

Remarks

This property always returns false if the dimension is a radial or spot dimension. This property cannot be set if the dimension has been labeled, or if the dimension shape is radial or spot, or if the dimension is linear with more than one segment.

See Also

Dimension Class

Label Property

[image]