Revit 2013 API
ReinforcementSettings Members
ReinforcementSettings Class Methods Properties See Also Send Feedback

The ReinforcementSettings type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ReinforcementSettings
Public method | DocumentContainsNoAreaOrPathReinforcement | Checks whether the document is free of AreaReinforcement and PathReinforcement elements. Only in this case is it permissible to change the HostStructuralRebar property.
 | GetReinforcementSettings | Obtains the ReinforcementSettings object for the specified project document.

Properties

 | Name | Description
Public property | HostStructuralRebar | Host Structural Rebar within Area and Path Reinforcement.

See Also

ReinforcementSettings Class
Autodesk.Revit.DB.Structure Namespace

ReinforcementSettings Methods

[image] [image]