Revit 2013 API
ConnectorElement Members
ConnectorElement Class Methods Properties See Also Send Feedback

The ConnectorElement type exposes the following members.

Methods

 | Name | Description
Public method | AssignAsPrimary | Assign a connector as a primary connector.
 | CreateCableTrayConnector | Create a new cable tray ConnectorElement.
 | CreateConduitConnector | Create a new conduit ConnectorElement.
 | CreateDuctConnector | Create a new duct ConnectorElement.
 | CreateElectricalConnector | Create a new electrical ConnectorElement.
 | CreatePipeConnector | Create a new pipe ConnectorElement.
Public method | GetLinkedConnectorElement | Get the linked connector element.
Public method | SetLinkedConnectorElement | Set the linked connector element.

Properties

 | Name | Description
Public property | CoordinateSystem | The coordinate system of the connector.
Public property | Domain | The domain of the connector.
Public property | Height | The height of the connector.
Public property | IsPrimary | Identifies if this is the primary connector in the family.
Public property | Origin | The location of the connector in family document.
Public property | Radius | The radius of the connector.
Public property | Shape | The shape of the connector.
Public property | Width | The width of the connector.

See Also

ConnectorElement Class

ConnectorElement Methods

[image] [image]