Revit 2013 API
Truss..::..GetTrussMemberInfo Method
Truss Class See Also Send Feedback
Query if a given element is a member of a truss, its lock status and its usage, etc.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public TrussMemberInfo GetTrussMemberInfo(
    ElementId elemId
)
Visual Basic
Public Function GetTrussMemberInfo ( _
    elemId As ElementId _
) As TrussMemberInfo
Visual C++
public:
TrussMemberInfo^ GetTrussMemberInfo(
    ElementId^ elemId
)

Parameters

elemId
Type: Autodesk.Revit.DB..::..ElementId
The querying element.

Return Value

A struct TrussMemberInfo that contains the querying element's host truss, whether to lock to the truss, usage type, etc.

See Also

Truss Class
Autodesk.Revit.DB.Structure Namespace

RemoveProfile Method

[image]