Revit 2013 API
PipeConnector Class
Members See Also Send Feedback
A pipe connector that is assigned to a mechanical equipment or pipe fitting family. Provides access to the pipe connector in Autodesk Revit MEP family document.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This class is obsolete in Revit 2013. Use ConnectorElement instead.")]
public class PipeConnector : ConnectorElement
Visual Basic
<ObsoleteAttribute("This class is obsolete in Revit 2013. Use ConnectorElement instead.")> _
Public Class PipeConnector _
    Inherits ConnectorElement
Visual C++
[ObsoleteAttribute(L"This class is obsolete in Revit 2013. Use ConnectorElement instead.")]
public ref class PipeConnector : public ConnectorElement

Remarks

This element type is accessible only in Autodesk Revit MEP family documents. Pipe connectors that are accessible in MEP project documents are not elements, and are represented by Connector.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ConnectorElement
Autodesk.Revit.DB.Plumbing..::..PipeConnector

See Also

PipeConnector Members
Autodesk.Revit.DB.Plumbing Namespace

PipeConnector Members

[image] [image]