Revit 2013 API
ExternalServiceRegistry..::..ExecuteService Method (Guid, Document, IExternalData)
ExternalServiceRegistry Class See Also Send Feedback
Execute the service for the given document.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static ExternalServiceResult ExecuteService(
    Guid executionKey,
    Document document,
    IExternalData data
)
Visual Basic
Public Shared Function ExecuteService ( _
    executionKey As Guid, _
    document As Document, _
    data As IExternalData _
) As ExternalServiceResult
Visual C++
public:
static ExternalServiceResult ExecuteService(
    Guid executionKey,
    Document^ document,
    IExternalData^ data
)

Parameters

executionKey
Type: System..::..Guid
Access key of the service to be executed. The key is not the same as the service's Id. It is the value that was returned to the caller who registered the service.
document
Type: Autodesk.Revit.DB..::..Document
The document for which the service is going to be executed.
data
Type: Autodesk.Revit.DB.ExternalService..::..IExternalData
The associated data. The type must be of the class defined by the service.

Return Value

The result of executing the external service.

Remarks

Execution of a service should be invoked only by the application that registered the service. The execution will use the active server (or servers in the case of a multi-server service) currently set for the given document. If there is no server specifically set for the document the current application-wide server (or servers) will be applied.

This method is primarily intended for executing of serializable services. If the service was registered as non-serializable, the document should not be modified during the execution (it means no server's information will be stored inside the document.) In such a case the given document simply indicates to execute the server(s) that were registered for that particular document.

Be aware that serializable service may only be executed in a document that is currently modifiable. An exception will be thrown if it isn't so. This requirement does not apply to non-serializable services.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The execution key is either invalid or of a service that is not registered. To execute a service, the key returned by RegisterService method must be used. -or- The execution key is of a service that is already being executed.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | Executing a serializable service in a document that is not modifiable.

See Also

ExternalServiceRegistry Class
ExecuteService Overload
Autodesk.Revit.DB.ExternalService Namespace

GetService Method

[image]