Revit 2013 API
WallTypeSet Members
WallTypeSet Class Constructors Methods Properties See Also Send Feedback

The WallTypeSet type exposes the following members.

Constructors

 | Name | Description
Public method | WallTypeSet | Initializes a new instance of the WallTypeSet class

Methods

 | Name | Description
Public method | Clear | Removes every wall type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a wall type within the set.
Public method | Erase | Removes a specified wall type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | Insert | Insert the specified wall type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | Size | Returns the number of wall types that are in the set.

See Also

WallTypeSet Class

WallTypeSet Constructor

[image]