Revit 2013 API
Definitions..::..Create Method (String, ParameterType, Boolean)
Definitions Class See Also Send Feedback
Creates a new parameter definition using name and type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Definition Create(
    string name,
    ParameterType type,
    bool visible
)
Visual Basic
Public Function Create ( _
    name As String, _
    type As ParameterType, _
    visible As Boolean _
) As Definition
Visual C++
public:
Definition^ Create(
    String^ name,
    ParameterType type,
    bool visible
)

Parameters

name
Type: System..::..String
The name of the parameter definition to be created.
type
Type: Autodesk.Revit.DB..::..ParameterType
The name of the parameter type for the new definition.
visible
Type: System..::..Boolean

Return Value

If successful a reference to the new parameter definition is returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

If an attempt is made to create a new internal definition an exception will be thrown. Only external (shared) parameter definitions can be made.

See Also

Definitions Class
Create Overload

Dispose Method

[image]