Revit 2013 API
IFCStairRampContainerInfo..::..Create Method (IList<(Of <(<'IFCAnyHandle>)>)>, IList<(Of <(<'IList<(Of <(<'IFCAnyHandle>)>)>>)>)>, IList<(Of <(<'IFCAnyHandle>)>)>)
IFCStairRampContainerInfo Class See Also Send Feedback
Creates a new instance of an IFCStairRamp.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static IFCStairRampContainerInfo Create(
    IList<IFCAnyHandle> hnds,
    IList<IList<IFCAnyHandle>> comps,
    IList<IFCAnyHandle> localPlacementHndArr
)
Visual Basic
Public Shared Function Create ( _
    hnds As IList(Of IFCAnyHandle), _
    comps As IList(Of IList(Of IFCAnyHandle)), _
    localPlacementHndArr As IList(Of IFCAnyHandle) _
) As IFCStairRampContainerInfo
Visual C++
public:
static IFCStairRampContainerInfo^ Create(
    IList<IFCAnyHandle^>^ hnds,
    IList<IList<IFCAnyHandle^>^>^ comps,
    IList<IFCAnyHandle^>^ localPlacementHndArr
)

Parameters

hnds
Type: System.Collections.Generic..::..IList<(Of <(<'IFCAnyHandle>)>)>
Stairs IFC handles
comps
Type: System.Collections.Generic..::..IList<(Of <(<'IList<(Of <(<'IFCAnyHandle>)>)>>)>)>
Handles of created sub-components
localPlacementHndArr
Type: System.Collections.Generic..::..IList<(Of <(<'IFCAnyHandle>)>)>
Local placement of the Stairs

Return Value

The new IFCStairRamp.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCStairRampContainerInfo Class
Create Overload
Autodesk.Revit.DB.IFC Namespace

Dispose Method

[image]