Revit 2013 API
PlanarFace Class
Members Example See Also Send Feedback
A planar face of a 3d solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class PlanarFace : Face
Visual Basic
Public Class PlanarFace _
    Inherits Face
Visual C++
public ref class PlanarFace : public Face

Remarks

Planar faces are defined by planes bounded by edge loops. The planes provide natural UV parameterization to the faces. S(u, v) = Origin + u*Vector[0] + v*Vector[1]

Examples

CopyC#
private void GetPlanarFaceInfo(Face face)
{
    PlanarFace planarFace = face as PlanarFace;
    if (null != planarFace)
    {
       XYZ origin = planarFace.Origin;
        XYZ normal = planarFace.Normal;
        XYZ vector = planarFace.get_Vector(0);
    }
}
CopyVB.NET
Private Sub GetPlanarFaceInfo(ByVal face As Autodesk.Revit.DB.Face)
    Dim planarFace As PlanarFace = TryCast(face, PlanarFace)
    If planarFace IsNot Nothing Then
        Dim origin As Autodesk.Revit.DB.XYZ = planarFace.Origin
        Dim normal As Autodesk.Revit.DB.XYZ = planarFace.Normal
        Dim vector As Autodesk.Revit.DB.XYZ = planarFace.Vector(0)
    End If
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..GeometryObject
Autodesk.Revit.DB..::..Face
Autodesk.Revit.DB..::..PlanarFace

See Also

PlanarFace Members

PlanarFace Members

[image] [image]