Revit 2013 API
SelElementSet Class
Members See Also Send Feedback
This class contains the current user selection of elements within the project.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public class SelElementSet : ElementSet
Visual Basic
Public Class SelElementSet _
    Inherits ElementSet
Visual C++
public ref class SelElementSet : public ElementSet

Remarks

Add or Remove elements from the selected element set. The elements in the set will be highlighted as selected elements in the UI.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..ElementSet
Autodesk.Revit.UI.Selection..::..SelElementSet

See Also

SelElementSet Members
Autodesk.Revit.UI.Selection Namespace

SelElementSet Members

[image] [image]