Revit 2013 API
SolidSolidCutUtils Class
Members See Also Send Feedback
Exposes utilities which can cause one solid to cut another.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class SolidSolidCutUtils : IDisposable
Visual Basic
Public Class SolidSolidCutUtils _
    Implements IDisposable
Visual C++
public ref class SolidSolidCutUtils : IDisposable

Remarks

These utilities are applicable for the generic forms, geometry combinations and family instances in conceptual model, pattern based curtain panel, or adaptive component families, and family instances which are permitted to participate in joining in projects. Thus, for example, a beam cannot cut a wall (as the wall is not a family instance) in projects. Nor can a steel beam participate in cutting another family (because steel beams do not participate in joining).

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..SolidSolidCutUtils

See Also

SolidSolidCutUtils Members

SolidSolidCutUtils Members

[image] [image]