Revit 2013 API
Document..::..MechanicalEquipmentTypes Property
Document Class See Also Send Feedback
Returns an object that contains all of the available mechanical equipment types currently loaded to this project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilySymbolSet MechanicalEquipmentTypes { get; }
Visual Basic
Public ReadOnly Property MechanicalEquipmentTypes As FamilySymbolSet
    Get
Visual C++
public:
property FamilySymbolSet^ MechanicalEquipmentTypes {
    FamilySymbolSet^ get ();
}

Remarks

The MechanicalEquipmentTypes property returns an object that contains the mechanical equipment types which can be used to change the type of a mechanical equipment from one type to another.

See Also

Document Class

MullionTypes Property

[image]