Revit 2013 API
Wall Methods
Wall Class See Also Send Feedback

The Wall type exposes the following members.

Methods

 | Name | Description
 | Create(Document, IList<(Of <<'(Curve>)>>), Boolean) | Creates a non rectangular profile wall within the project using the default wall type.
 | Create(Document, Curve, ElementId, Boolean) | Creates a new rectangular profile wall within the project using the default wall style.
 | Create(Document, IList<(Of <<'(Curve>)>>), ElementId, ElementId, Boolean) | Creates a non rectangular profile wall within the project using the specified wall type.
 | Create(Document, IList<(Of <<'(Curve>)>>), ElementId, ElementId, Boolean, XYZ) | Creates a non rectangular profile wall within the project using the specified wall type and normal vector.
 | Create(Document, Curve, ElementId, ElementId, Double, Double, Boolean, Boolean) | Creates a new rectangular profile wall within the project using the specified wall type, height, and offset.
Public method | Flip | The wall orientation will be flipped.

See Also

Wall Class

Create Method

[image] [image]