Revit 2013 API
Viewport..::..ViewId Property
Viewport Class See Also Send Feedback
The element id of the associated View.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId ViewId { get; }
Visual Basic
Public ReadOnly Property ViewId As ElementId
    Get
Visual C++
public:
property ElementId^ ViewId {
    ElementId^ get ();
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

Viewport Class

ViewportRotation Enumeration

[image]