Revit 2013 API
RebarHookType Members
RebarHookType Class Methods Properties See Also Send Feedback

The RebarHookType type exposes the following members.

Methods

 | Name | Description
 | Create | Creates a new RebarHookType in a document.
Public method | GetDefaultHookLength | Computes the default hook length, which is equal to barDiameter * multiplier.
Public method | GetHookExtensionLength | Computes the hook extension length.
Public method | IsOffsetLengthRequired | Check whether hook offset length is required. remarks: If hook angle is no more than 90 degree, hook offset length is not meaningful. returns: True if hook offset length is required, otherwise false.

Properties

 | Name | Description
Public property | HookAngle | The hook angle, measured in radians. Must be greater than 0 and no more than pi.
Public property | StraightLineMultiplier | Multiplier of bar diameter. Used to compute a default hook length. The default hook length can be overridden by the RebarBarType class.
Public property | Style | The hook may only be applied to shapes of the specified style.

See Also

RebarHookType Class
Autodesk.Revit.DB.Structure Namespace

RebarHookType Methods

[image] [image]