Revit 2013 API
BuiltInFailures..::..AnalyticalModelFailures Properties
BuiltInFailures..::..AnalyticalModelFailures Class See Also Send Feedback

The BuiltInFailures..::..AnalyticalModelFailures type exposes the following members.

Properties

Name | Description
AdjustCurveTooShort | AdjustCurve is too short.
AdjustEdgeTooShort | AdjustEdge is too short.
AnalyticalBeamSlabWarning | Beam and Slab Analytical Models do not have the same Analytical Projection Plane.
AnalyticalDiscrepancyWarning | Distance between Analytical and Physical Models of Structural Element is beyond tolerance of [Value]
AnalyticalGapWarning | Detected physical connection between Structural Elements, but did not detect Analytical intersection.
AnalyticalLinkNotConnected | Analytical Link has lost one or more references.
AnalyticalMemberInstability | Possible Member Instability, based on Release Conditions
AnalyticalModelInstability | Possible Model Instability
AnalyticalPhysicalCheckDone | Analytical / Physical Model Consistency check is complete.
AnalyticalSupportCycleWarning | Circular support chain detected
AnalyticalTopBottomPlanesReversed | Analytical Top Projection Plane is partially or completely below Analytical Bottom Projection Plane. Please reset top and/or bottom planes to valid values.
AutoDetectIgnoreLeaderWarning | Analytical Model for Structural Element has reset to its default location.
BoundaryLinesIntersect | Boundary lines intersect.
CannotCreateAnalyticalGeometry | Cannot construct Analytical Geometry.
CannotKeepAnalyticalAdjustment | Analytical model Adjustment distance exceeds current Adjustment Snapping Distance. To adjust snap settings, go to the Structural Settings Dialog.
CannotMakeAnalyticalGeometry | Cannot construct Analytical Geometry.
LoadsMayBeNotUpToDate | Some of reactions may be not up-to-date
ProjectionPlaneInvalidWall | Projection plane becomes invalid for this wall.
ProjectionPlanesNotIntersect | Can't project Analytical Model. Planes do not intersect each other.
ProjectionPlanesParallel | Can't project Analytical Model. Two or more projection planes are parallel.
StructAnalyticalErrorProjection | Can't project Analytical Model to Analytical Projection Surface
StructuralElementMayNotBeSupported | Structural Element may not be supported -- verify support for Element.
StructWallAnalyticalErrorAlign | Can't align Analytical Model with joined Walls.
StructWallAnalyticalErrorConversion | Can't convert Edges to Analytical Model curves.
SupportCheckDone | Member support check is complete. No unsupported elements detected.

See Also

BuiltInFailures..::..AnalyticalModelFailures Class

AdjustCurveTooShort Property

[image]