Revit 2013 API
LightType..::..GetLightType Method
LightType Class See Also Send Feedback
Creates a light type object from the given document and family type ID

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static LightType GetLightType(
    Document document,
    ElementId typeId
)
Visual Basic
Public Shared Function GetLightType ( _
    document As Document, _
    typeId As ElementId _
) As LightType
Visual C++
public:
static LightType^ GetLightType(
    Document^ document,
    ElementId^ typeId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document the typeId is from
typeId
Type: Autodesk.Revit.DB..::..ElementId
The ID of the light family type

Return Value

The newly created LightType object

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ElementId is the argument that is being validated The ElementId is not valid because it is not for a light element.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

LightType Class
Autodesk.Revit.DB.Lighting Namespace

GetLightTypeFromInstance Method

[image]