Revit 2013 API
Element..::..DesignOption Property
Element Class Example See Also Send Feedback
Returns the design option to which the element belongs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DesignOption DesignOption { get; }
Visual Basic
Public ReadOnly Property DesignOption As DesignOption
    Get
Visual C++
public:
property DesignOption^ DesignOption {
    DesignOption^ get ();
}

Remarks

If the element is not in a design option, i.e. in the main model, then this property will return nullNothingnullptra null reference (Nothing in Visual Basic).

Examples

CopyC#
void Getinfo_DesignOption(Document document)
{
    // Get the selected Elements in the Active Document
    UIDocument uidoc = new UIDocument(document);
    ElementSet selection = uidoc.Selection.Elements;

    foreach (Autodesk.Revit.DB.Element element in selection)
    {
        //Use the DesignOption property of Element
        if (element.DesignOption != null)
        {
            TaskDialog.Show("Revit",element.DesignOption.Name.ToString());
        }
    }
}
CopyVB.NET
Sub Getinfo_DesignOption(ByVal document As Document)
    ' Get the selected Elements in the Active Document
    Dim uidoc As New UIDocument(document)
    Dim selection As ElementSet = uidoc.Selection.Elements

    For Each element As Autodesk.Revit.DB.Element In selection
        'Use the DesignOption property of Element
        If element.DesignOption IsNot Nothing Then
            TaskDialog.Show("Revit", element.DesignOption.Name.ToString())
        End If
    Next
End Sub

See Also

Element Class

Document Property

[image]