Revit 2013 API
AnalyticalModelSurface Members
AnalyticalModelSurface Class Methods Properties See Also Send Feedback

The AnalyticalModelSurface type exposes the following members.

Methods

 | Name | Description
Public method | GetHiddenOpenings | Retrieves Identifiers of all hidden openings.
Public method | GetLoops | Retrieves Analytical Model Loops with respect to the loopType.
Public method | GetOpeningLoops | Retrieves Array of CurveLoops of Analytical Surface Opening.. Only valid openings for hide are allowed.
Public method | GetOpenings | Retrieves Analytical Surface Openings Identifiers valid to be used in showOpening/hideOpening functions.
Public method | HasOpenings | Checks if the analytical model surface have any openings.
Public method | HideOpening | Hides set of curves originating from Opening.
Public method | IsOpeningHidden | Returns true if opening with given Identifier is hidden.
Public method | IsValidOpeningForHide | Returns true if opening with given Identifier could be hidden, false for all other Identifiers.
Public method | SetLoops | Set new analytical model geometry (newLoops) for analytical surface elements such as floors and slabs.
Public method | ShowOpening | Shows previously hidden set of curves originating from Opening.

Properties

 | Name | Description

See Also

AnalyticalModelSurface Class
Autodesk.Revit.DB.Structure Namespace

AnalyticalModelSurface Methods

[image] [image]