Revit 2013 API
FamilyManager..::..AddParameter Method (ExternalDefinition, BuiltInParameterGroup, Boolean)
FamilyManager Class See Also Send Feedback
Add a new shared parameter to the family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilyParameter AddParameter(
    ExternalDefinition familyDefinition,
    BuiltInParameterGroup parameterGroup,
    bool isInstance
)
Visual Basic
Public Function AddParameter ( _
    familyDefinition As ExternalDefinition, _
    parameterGroup As BuiltInParameterGroup, _
    isInstance As Boolean _
) As FamilyParameter
Visual C++
public:
FamilyParameter^ AddParameter(
    ExternalDefinition^ familyDefinition,
    BuiltInParameterGroup parameterGroup,
    bool isInstance
)

Parameters

familyDefinition
Type: Autodesk.Revit.DB..::..ExternalDefinition
The definition of the loaded shared parameter.
parameterGroup
Type: Autodesk.Revit.DB..::..BuiltInParameterGroup
The group to which the family parameter belongs.
isInstance
Type: System..::..Boolean
Indicates if the new parameter is instance or type.

Return Value

If creation was successful the new shared parameter is returned, otherwise an exception with failure information will be thrown.

Remarks

This method can work even without any family type, but it cannot be assigned the value via FamilyManager.Set methods when there is no current type.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the shared family parameter creation is not supported.

See Also

FamilyManager Class
AddParameter Overload

AddParameter Method (String, BuiltInParameterGroup, Category, Boolean)

[image]