Revit 2013 API
CurveElement..::..SketchPlane Property
CurveElement Class See Also Send Feedback
The sketch plane the curve element lies in.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual SketchPlane SketchPlane { get; set; }
Visual Basic
Public Overridable Property SketchPlane As SketchPlane
    Get
    Set
Visual C++
public:
virtual property SketchPlane^ SketchPlane {
    SketchPlane^ get ();
    void set (SketchPlane^ value);
}

Remarks

The new sketch plane must be parallel to the existing sketch plane. Setting this property is not permitted for detail curves because they must be placed only on view-specific planes.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the modification failed, when the sketch plane is not parallel to the existing plane, or when this property is set on a DetailCurve.

See Also

CurveElement Class

CurveElementFilter Class

[image]