Revit 2013 API
Room Class
Members Example See Also Send Feedback
Provides access to the room topology in Autodesk Revit.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class Room : SpatialElement
Visual Basic
Public Class Room _
    Inherits SpatialElement
Visual C++
public ref class Room : public SpatialElement

Remarks

The room object can be queried for its boundary for use in space planning tools.

Examples

CopyC#
private void Getinfo_Room(Room room)
{
    string message = "Room: ";

    //get the name of the room
    message += "\nRoom Name: " + room.Name;

    //get the room position
    LocationPoint location = room.Location as LocationPoint;
    XYZ point = location.Point;
    message += "\nRoom position: " + XYZToString(point);

    //get the room number
    message += "\nRoom number: " + room.Number;

    Autodesk.Revit.DB.Architecture.BoundarySegmentArray boundarySegmentArray = room.GetBoundarySegments(new SpatialElementBoundaryOptions()) as Autodesk.Revit.DB.Architecture.BoundarySegmentArray;
    if (null != boundarySegmentArray)  //the room may not be bound
    {
        if (0 != boundarySegmentArray.Size)
        {
            message += "\nBoundarySegment of the room: ";
            foreach (Autodesk.Revit.DB.Architecture.BoundarySegment boundarySegment in boundarySegmentArray)
            {
                // Get curve start point
                XYZ start = boundarySegment.Curve.get_EndPoint(0);
                message += "\nCurve start point: " + XYZToString(start);
                // Get curve end point
                XYZ end = boundarySegment.Curve.get_EndPoint(1);
                message += " Curve end point: " + XYZToString(end);

                // Show the boundary elements
                message += "\nBoundary element id: " + boundarySegment.Element.Id.IntegerValue;
            }
        }
    }

    TaskDialog.Show("Revit",message);
}

// output the point's three coordinates
string XYZToString(XYZ point)
{
    return "(" + point.X + ", " + point.Y + ", " + point.Z + ")";
}
CopyVB.NET
Private Sub Getinfo_Room(ByVal room As Room)
    Dim message As String = "Room: "

    'get the name of the room
    message += vbLf & "Room Name: " + room.Name

    'get the room position
    Dim location As LocationPoint = TryCast(room.Location, LocationPoint)
    Dim point As Autodesk.Revit.DB.XYZ = location.Point
    message += vbLf & "Room position: " + XYZToString(point)

    'get the room number
    message += vbLf & "Room number: " + room.Number

    'get the boundary segment of the room
    If room.Boundary IsNot Nothing Then
        'the room may not be bound
        If 0 <> room.Boundary.Size Then
            message += vbLf & "BoundarySegment of the room: "
            For Each boundarySegmentArray As Autodesk.Revit.DB.Architecture.BoundarySegmentArray In room.Boundary
                For Each boundarySegment As Autodesk.Revit.DB.Architecture.BoundarySegment In boundarySegmentArray
                    ' Get curve start point
                    Dim start As Autodesk.Revit.DB.XYZ = boundarySegment.Curve.EndPoint(0)
                    message += vbLf & "Curve start point: " + XYZToString(start)
                    ' Get curve end point
                    Dim [end] As Autodesk.Revit.DB.XYZ = boundarySegment.Curve.EndPoint(1)
                    message += " Curve end point: " + XYZToString([end])

                    ' Show the boundary elements
                    message += vbLf & "Boundary element id: " + boundarySegment.Element.Id.IntegerValue
                Next
            Next
        End If
    End If

    TaskDialog.Show("Revit", message)
End Sub

' output the point's three coordinates
Function XYZToString(ByVal point As Autodesk.Revit.DB.XYZ) As String
    Return "(" + point.X + ", " + point.Y + ", " + point.Z + ")"
End Function

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..SpatialElement
Autodesk.Revit.DB.Architecture..::..Room

See Also

Room Members
Autodesk.Revit.DB.Architecture Namespace

Room Members

[image] [image]