Revit 2013 API
Material..::..SetMaterialAspect Method
Material Class See Also Send Feedback
Set the value of an aspect of the material

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This function will be removed in a future release. Use setStructuralAssetId or setThermalAssetId instead.")]
public void SetMaterialAspect(
    MaterialAspect aspect,
    ElementId propertySetId,
    bool bShared
)
Visual Basic
<ObsoleteAttribute("This function will be removed in a future release. Use setStructuralAssetId or setThermalAssetId instead.")> _
Public Sub SetMaterialAspect ( _
    aspect As MaterialAspect, _
    propertySetId As ElementId, _
    bShared As Boolean _
)
Visual C++
[ObsoleteAttribute(L"This function will be removed in a future release. Use setStructuralAssetId or setThermalAssetId instead.")]
public:
void SetMaterialAspect(
    MaterialAspect aspect,
    ElementId^ propertySetId,
    bool bShared
)

Parameters

aspect
Type: Autodesk.Revit.DB..::..MaterialAspect
The material aspect
propertySetId
Type: Autodesk.Revit.DB..::..ElementId
Identifier of a property set (an instance of PropertySetElement)
bShared
Type: System..::..Boolean
Set the property set as shared or custom

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

Material Class

SetMaterialAspectByPropertySet Method

[image]