Revit 2013 API
PartUtils..::..SetOffsetForIntersectingReference Method
PartUtils Class See Also Send Feedback
Set offset for the intersecting reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2013; use PartMakerMethodToDivideVolumes.SetOffsetForIntersectingReference() instead.")]
public static void SetOffsetForIntersectingReference(
    PartMaker partMaker,
    ElementId intersectingReference,
    double offset
)
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2013; use PartMakerMethodToDivideVolumes.SetOffsetForIntersectingReference() instead.")> _
Public Shared Sub SetOffsetForIntersectingReference ( _
    partMaker As PartMaker, _
    intersectingReference As ElementId, _
    offset As Double _
)
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2013; use PartMakerMethodToDivideVolumes.SetOffsetForIntersectingReference() instead.")]
public:
static void SetOffsetForIntersectingReference(
    PartMaker^ partMaker,
    ElementId^ intersectingReference,
    double offset
)

Parameters

partMaker
Type: Autodesk.Revit.DB..::..PartMaker
PartMaker that uses the intersecting reference to be offset.
intersectingReference
Type: Autodesk.Revit.DB..::..ElementId
The intersecting reference that will be offset.
offset
Type: System..::..Double
Offset amount for the intersecting reference.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | PartMaker does not use the specified intersecting reference.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PartUtils Class

Path3d Class

[image]