Revit 2013 API
ExporterIFCUtils..::..CreateWallBaseQuantities Method
ExporterIFCUtils Class See Also Send Feedback
Creates the wall base quantities and adds them to the export.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static void CreateWallBaseQuantities(
    ExporterIFC exporterIFC,
    IFCAnyHandle wallElement,
    Wall pElem,
    double width
)
Visual Basic
Public Shared Sub CreateWallBaseQuantities ( _
    exporterIFC As ExporterIFC, _
    wallElement As IFCAnyHandle, _
    pElem As Wall, _
    width As Double _
)
Visual C++
public:
static void CreateWallBaseQuantities(
    ExporterIFC^ exporterIFC,
    IFCAnyHandle^ wallElement,
    Wall^ pElem,
    double width
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
wallElement
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The wall element handle.
pElem
Type: Autodesk.Revit.DB..::..Wall
The wall element.
width
Type: System..::..Double
The width of the wall.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace

CreateWindowPropertySet Method

[image]