Revit 2013 API
IFCStairRampContainerInfo..::..ContainsStairOrRamp Method
IFCStairRampContainerInfo Class See Also Send Feedback
Checks if the stair or ramp element id has containment information.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static bool ContainsStairOrRamp(
    ExporterIFC exporterIFC,
    ElementId elemId
)
Visual Basic
Public Shared Function ContainsStairOrRamp ( _
    exporterIFC As ExporterIFC, _
    elemId As ElementId _
) As Boolean
Visual C++
public:
static bool ContainsStairOrRamp(
    ExporterIFC^ exporterIFC,
    ElementId^ elemId
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
elemId
Type: Autodesk.Revit.DB..::..ElementId
The stair or ramp element id.

Return Value

Returns true if the stair or ramp element id has containment information.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCStairRampContainerInfo Class
Autodesk.Revit.DB.IFC Namespace

Create Method

[image] [image]