Revit 2013 API
MechanicalUtils..::..ConnectDuctPlaceholdersAtElbow Method (Document, Connector, Connector)
MechanicalUtils Class Example See Also Send Feedback
Connects placeholders that looks like elbow connection.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static bool ConnectDuctPlaceholdersAtElbow(
    Document document,
    Connector connector1,
    Connector connector2
)
Visual Basic
Public Shared Function ConnectDuctPlaceholdersAtElbow ( _
    document As Document, _
    connector1 As Connector, _
    connector2 As Connector _
) As Boolean
Visual C++
public:
static bool ConnectDuctPlaceholdersAtElbow(
    Document^ document,
    Connector^ connector1,
    Connector^ connector2
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
connector1
Type: Autodesk.Revit.DB..::..Connector
The first end connector of placeholder to be connected to.
connector2
Type: Autodesk.Revit.DB..::..Connector
The second end connector of placeholder to be connected to.

Return Value

True if connection succeeds, false otherwise.

Remarks

The placeholders may have physical connection or may not connect at all. In the latter case, the first one connects to the end of second one. If connection fails, the placeholders cannot be physically connected.

Examples

CopyC#
//Create a point to be the connection point of two ductPlaceholders
XYZ connectionPoint = new XYZ(150, 0, 0);

//Create two new ductPlaceholders, duct1 and duct2, each ductPlaceholder has connectionPoint as its parameter
Duct duct1 = Duct.CreatePlaceholder(document, ductTypeId, levelId, new XYZ(100, 0, 0), connectionPoint);
Duct duct2 = Duct.CreatePlaceholder(document, ductTypeId, levelId, connectionPoint, new XYZ(150, 50, 0));

//Get Connectors of duct1 and duct2's ConnectorManager and change their type to IEnumerable<Connector>
//Get the first connector from the IEnumerable where the origin of the connector is almost equal to connectionPoint
Connector connector1 = duct1.ConnectorManager.Connectors.Cast<Connector>().Where(c => c.Origin.IsAlmostEqualTo(connectionPoint)).First();
Connector connector2 = duct2.ConnectorManager.Connectors.Cast<Connector>().Where(c => c.Origin.IsAlmostEqualTo(connectionPoint)).First();

//Connect duct1 and duct2 with elbow fitting by their intersecting connectors(whose origin is almost equal to connectionPoint)
bool connectResult = MechanicalUtils.ConnectDuctPlaceholdersAtElbow(document, connector1, connector2);

//Convert duct1 and duct2 to real ducts
ICollection<ElementId> convertedElementsId = MechanicalUtils.ConvertDuctPlaceholders(document, new ElementId[] { duct1.Id, duct2.Id });

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The owner of connector is not duct placeholder. -or- The owners of connectors belong to different types of system.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

MechanicalUtils Class
ConnectDuctPlaceholdersAtElbow Overload
Autodesk.Revit.DB.Mechanical Namespace

ConnectDuctPlaceholdersAtElbow Method (Document, ElementId, ElementId)

[image]