Revit 2013 API
RadialArray Members
RadialArray Class Methods Properties See Also Send Feedback

The RadialArray type exposes the following members.

Methods

 | Name | Description
 | ArrayElementsWithoutAssociation | Creates a new radial array from a set of elements based on an input rotation axis.
 | ArrayElementWithoutAssociation | Creates a new radial array from a single element based on an input rotation axis.
 | Create(Document, View, ElementId, Int32, Line, Double, ArrayAnchorMember) | Creates a new radial array element from a single element based on an input rotation axis.
 | Create(Document, View, ICollection<(Of <<'(ElementId>)>>), Int32, Line, Double, ArrayAnchorMember) | Creates a new radial array element from a set of elements based on an input rotation axis.
Public method | GetCopiedMemberIds | Retrieves the copied member Ids of the Array. (Overrides BaseArray..::..GetCopiedMemberIds()()()().)
Public method | GetOriginalMemberIds | Retrieves the original member Ids of the Array. (Overrides BaseArray..::..GetOriginalMemberIds()()()().)
 | IsValidArraySize | This indicates whether the input count is valid.

Properties

 | Name | Description
Public property | CopyMembers | Obsolete. Retrieve the copied members of the Array. (Overrides BaseArray..::..CopyMembers.)
Public property | NumMembers | Retrieves or changes the number of the arrayed members. (Overrides BaseArray..::..NumMembers.)
Public property | OrigMembers | Obsolete. Retrieve the original members of the Array. (Overrides BaseArray..::..OrigMembers.)

See Also

RadialArray Class

RadialArray Methods

[image] [image]