Revit 2013 API
View Properties
View Class See Also Send Feedback

The View type exposes the following members.

Properties

 | Name | Description
Public property | AnalysisDisplayStyleId | Element id of Analysis Display Style associated with the view.
Public property | AssociatedAssemblyInstanceId | The Id of the assembly instance that owns the assembly view.
Public property | CanBePrinted | Test whether the view can be printed.
Public property | CropBox | The crop box applied to the view.
Public property | CropBoxActive | Whether or not the Crop Box/Region is active for the view.
Public property | CropBoxVisible | Whether or not the Crop Box/Region is visible for the view.
Public property | CutColorOverrideByElement | Override the cut lines' color by Element in this view.
Public property | CutLinePatternOverrideByElement | Override the cut lines' pattern by Element in this view.
Public property | CutLineWeightOverrideByElement | Override the cut lines' weight by Element in this view.
Public property | DetailLevel | The detail level of this view.
Public property | Discipline | The Discipline of the view.
Public property | DisplayStyle | The DisplayStyle of the view. Returns DisplayStyle.Wireframe if the view has no display style.
Public property | GenLevel | The level for the view.
Public property | IsTemplate | Test whether the view is a view template.
Public property | Origin | Returns the origin of the screen.
Public property | Outline | The bounds of the view in paper space (in inches).
Public property | PartsVisibility | The visibility setting for parts in this view.
Public property | ProjColorOverrideByElement | Override the projection lines' color by Element in this view.
Public property | ProjLinePatternOverrideByElement | Override the projection lines' pattern by Element in this view.
Public property | ProjLineWeightOverrideByElement | Override the projection lines' weight by Element in this view.
Public property | RightDirection | The direction towards the right side of the screen.
Public property | Scale | The scale of the view.
Public property | SketchPlane | The sketch plane assigned to the view for model curve creation.
Public property | SunAndShadowSettings | The sun and shadow settings assigned to the view for shadow calculation and rendering.
Public property | UpDirection | The direction towards the top of the screen.
Public property | ViewDirection | The direction towards the viewer.
Public property | ViewName | The name of the view.
Public property | ViewTemplateId | Id of template that controls view parameters. Parameters controlled by the template cannot be changed directly in this view. Any change to controlled parameters in the template will cause change of the corresponding parameters in this view. To get all template parameters call template's method getTemplateParameterIds. To get parameters that are not controlled by the template call template's method getNonControlledTemplateParameterIds.
Public property | ViewType | The type of the view.

See Also

View Class

AnalysisDisplayStyleId Property

[image]