Revit 2013 API
Rebar..::..CreateFromCurvesAndShape Method
Rebar Class See Also Send Feedback
Creates a new instance of a Rebar element within the project. The instance will have the default shape parameters from the RebarShape.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static Rebar CreateFromCurvesAndShape(
    Document doc,
    RebarShape rebarShape,
    RebarBarType barType,
    RebarHookType startHook,
    RebarHookType endHook,
    Element host,
    XYZ norm,
    IList<Curve> curves,
    RebarHookOrientation startHookOrient,
    RebarHookOrientation endHookOrient
)
Visual Basic
Public Shared Function CreateFromCurvesAndShape ( _
    doc As Document, _
    rebarShape As RebarShape, _
    barType As RebarBarType, _
    startHook As RebarHookType, _
    endHook As RebarHookType, _
    host As Element, _
    norm As XYZ, _
    curves As IList(Of Curve), _
    startHookOrient As RebarHookOrientation, _
    endHookOrient As RebarHookOrientation _
) As Rebar
Visual C++
public:
static Rebar^ CreateFromCurvesAndShape(
    Document^ doc,
    RebarShape^ rebarShape,
    RebarBarType^ barType,
    RebarHookType^ startHook,
    RebarHookType^ endHook,
    Element^ host,
    XYZ^ norm,
    IList<Curve^>^ curves,
    RebarHookOrientation startHookOrient,
    RebarHookOrientation endHookOrient
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
A document.
rebarShape
Type: Autodesk.Revit.DB.Structure..::..RebarShape
A RebarShape element that defines the shape of the rebar. A RebarShape element matches curves and hooks. A RebarShape element provides RebarStyle of the rebar.
barType
Type: Autodesk.Revit.DB.Structure..::..RebarBarType
A RebarBarType element that defines bar diameter, bend radius and material of the rebar.
startHook
Type: Autodesk.Revit.DB.Structure..::..RebarHookType
A RebarHookType element that defines the hook for the start of the bar. If this parameter is nullNothingnullptra null reference (Nothing in Visual Basic), it means to create a rebar with no hook.
endHook
Type: Autodesk.Revit.DB.Structure..::..RebarHookType
A RebarHookType element that defines the hook for the end of the bar. If this parameter is nullNothingnullptra null reference (Nothing in Visual Basic), it means to create a rebar with no hook.
host
Type: Autodesk.Revit.DB..::..Element
The element to which the rebar belongs. The element must support rebar hosting; see Autodesk.Revit.DB.Structure.RebarHostData.
norm
Type: Autodesk.Revit.DB..::..XYZ
The normal to the plane that the rebar curves lie on.
curves
Type: System.Collections.Generic..::..IList<(Of <(<'Curve>)>)>
An array of curves that define the shape of the rebar curves. They must belong to the plane defined by the normal and origin. Bends and hooks should not be included in the array of curves.
startHookOrient
Type: Autodesk.Revit.DB.Structure..::..RebarHookOrientation
Defines the orientation of the hook plane at the start of the rebar with respect to the orientation of the first curve and the plane normal. Only two values are permitted: Value = Right: The hook is on your right as you stand at the end of the bar, with the bar behind you, taking the bar's normal as "up." Value = Left: The hook is on your left as you stand at the end of the bar, with the bar behind you, taking the bar's normal as "up."
endHookOrient
Type: Autodesk.Revit.DB.Structure..::..RebarHookOrientation
Defines the orientation of the hook plane at the end of the rebar with respect to the orientation of the last curve and the plane normal. Only two values are permitted: Value = Right: The hook is on your right as you stand at the end of the bar, with the bar behind you, taking the bar's normal as "up." Value = Left: The hook is on your left as you stand at the end of the bar, with the bar behind you, taking the bar's normal as "up."

Return Value

The newly created Rebar instance, or nullNothingnullptra null reference (Nothing in Visual Basic) if the operation fails.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | host is not a valid rebar host. -or- curves is empty. -or- curves contains a curve that is neither a line nor an arc. -or- curves do not form a valid CurveLoop. -or- The input curves contains at least one helical curve and is not supported for this operation.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | norm has zero length.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural.
Autodesk.Revit.Exceptions..::..InvalidOperationException | rebarShape does not match curves.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace

CreateFromRebarShape Method

[image]