Revit 2013 API
Curve..::..EndPointReference Property
Curve Class See Also Send Feedback
Returns a stable reference to the start point or the end point of the curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Reference this[
    int index
] { get; }
Visual Basic
Public ReadOnly Property EndPointReference ( _
    index As Integer _
) As Reference
    Get
Visual C++
public:
property Reference^ EndPointReference[int index] {
    Reference^ get (int index);
}

Parameters

index
Type: System..::..Int32
Use 0 for the start point; 1 for the end point.

Return Value

Reference to the point or nullNothingnullptra null reference (Nothing in Visual Basic) if reference cannot be obtained.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the specified index is not 0 or 1.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the object is internally marked as read-only or this curve is unbound.

See Also

Curve Class

IsBound Property

[image]