Revit 2013 API
Space Members
Space Class Methods Properties See Also Send Feedback

The Space type exposes the following members.

Methods

 | Name | Description
Public method | IsPointInSpace | Determines if a point lies within the volume of the Space.

Properties

 | Name | Description
Public property | ActualExhaustAirflow | Get the Actual Exhaust Airflow of the Space.
Public property | ActualHVACLoad | Get or set the Actual HVAC Load of the Space.
Public property | ActualLightingLoad | Get the Actual Lighting Load of the Space.
Public property | ActualOtherLoad | Get or set the Actual Other Load of the Space.
Public property | ActualPowerLoad | Get the Actual Power Load of the Space.
Public property | ActualReturnAirflow | Get or set the Actual Return Airflow of the Space.
Public property | ActualSupplyAirflow | Get or set the Actual Supply Airflow of the Space.
Public property | AreaperPerson | Get the Area per Person of the Space.
Public property | AverageEstimatedIllumination | Get the Average Estimated Illumination of the Space.
Public property | BaseHeatLoadOn | The heat load-on.
Public property | BaseOffset | Get or Set the Base Offset of the Space.
Public property | CalculatedCoolingLoad | Get the Calculated Cooling Load of the Space.
Public property | CalculatedHeatingLoad | Get the Calculated Heating Load of the Space.
Public property | CalculatedSupplyAirflow | Get or set the Calculated Supply Airflow of the Space.
Public property | CeilingReflectance | Get or set the Ceiling Reflectance of the Space.
Public property | ClosedShell | Return the closedShell of the space.
Public property | ConditionType | Get or set the Condition type of the Space.
Public property | DesignCoolingLoad | Get the Design Cooling Load of the Space.
Public property | DesignExhaustAirflow | Get or set the Specified Exhaust Airflow of the Space.
Public property | DesignHeatingLoad | Get the Design Heating Load of the Space.
Public property | DesignHVACLoadperArea | Get or set the Design HVAC Load per Area of the Space.
Public property | DesignLightingLoad | Get or set the Design Lighting Load of the Space.
Public property | DesignOtherLoadperArea | Get or set the Design Other Load per Area of the Space.
Public property | DesignPowerLoad | Get or set the Design Power Load of the Space.
Public property | DesignReturnAirflow | Get or set the Specified Return Airflow of the Space.
Public property | DesignSupplyAirflow | Get or set the Specified Supply Airflow of the Space.
Public property | FloorReflectance | Get or set the Floor Reflectance of the Space.
Public property | LatentHeatGainperPerson | Get or set the Latent Heat Gain per Person of the Space.
Public property | LightingCalculationWorkplane | Get the Lighting Calculation Workplane of the Space.
Public property | LightingLoadUnit | Get or Set the Lighting Load Unit of the Space.
Public property | LimitOffset | Get or Set the Limit Offset of the Space.
Public property | NumberofPeople | Get the Number of People of the Space.
Public property | OccupancyUnit | Get the Occupancy Unit of the Space.
Public property | Occupiable | Reports whether this zone is Occupiable or not.
Public property | Plenum | Reports whether this zone is Plenum or not.
Public property | PowerLoadUnit | Get or Set the Power Load Unit of the Space.
Public property | ReturnAirflow | Get or set the Return type of Supply Airflow of the Space.
Public property | Room | Return the Room of the space.
Public property | SensibleHeatGainperPerson | Get the Sensible Heat Gain per Person of the Space.
Public property | SpaceCavityRatio | Get the Space Cavity Ratio of the Space.
Public property | SpaceConstruction | Get the Space Construction of the Space.
Public property | SpaceType | Get or set the Space type of the Space.
Public property | UnboundedHeight | Get the Unbounded Height of the Space.
Public property | UpperLimit | Get or Set the Upper Limit of the Space.
Public property | Volume | Get the Volume of the Space.
Public property | WallReflectance | Get or set the Wall Reflectance of the Space.
Public property | Zone | Reports this space belong to which Zone.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace

Space Methods

[image] [image]