Revit 2013 API
Curve..::..ComputeDerivatives Method
Curve Class See Also Send Feedback
Returns the vectors describing the curve at the specified parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Transform ComputeDerivatives(
    double parameter,
    bool normalized
)
Visual Basic
Public Function ComputeDerivatives ( _
    parameter As Double, _
    normalized As Boolean _
) As Transform
Visual C++
public:
Transform^ ComputeDerivatives(
    double parameter,
    bool normalized
)

Parameters

parameter
Type: System..::..Double
The parameter to be evaluated.
normalized
Type: System..::..Boolean
Indicates that the specified parameter is normalized.

Return Value

The transformation containing a tangent vector, derivative of tangent vector, and bi-normal vector.

Remarks

The following is the meaning of the transformation members: Origin is the point on the curve (equivalent to Evaluate); BasisX is the tangent vector (the first derivative); BasisY is the second derivative; BasisZ is the bi-normal vector (tangent x normal). Normal and bi-normal are zero if the curve is straight at the point. None of the vectors are normalized.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the specified parameter is infinite.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when normalized is true and this curve is unbound or the parameter is not within [0, 1] interval.

See Also

Curve Class

ComputeNormalizedParameter Method

[image]