Revit 2013 API
ExporterIFCUtils..::..CanExportWallGeometryAsExtrusion Method
ExporterIFCUtils Class See Also Send Feedback
Identifies if the base geometry of the wall can be represented as an extrusion.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static bool CanExportWallGeometryAsExtrusion(
    Element element,
    IFCRange range
)
Visual Basic
Public Shared Function CanExportWallGeometryAsExtrusion ( _
    element As Element, _
    range As IFCRange _
) As Boolean
Visual C++
public:
static bool CanExportWallGeometryAsExtrusion(
    Element^ element,
    IFCRange^ range
)

Parameters

element
Type: Autodesk.Revit.DB..::..Element
The wall or in-place wall element.
range
Type: Autodesk.Revit.DB.IFC..::..IFCRange
The range. This consists of two double values representing the height in Z at the start and the end of the range. If the values are identical the entire wall is used.

Return Value

True if the wall export can be made in the form of an extrusion, false if the geometry cannot be assigned to an extrusion.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace

CollectGeometryInfo Method

[image] [image]