Revit 2013 API
ViewSchedule Members
ViewSchedule Class Methods Properties See Also Send Feedback

The ViewSchedule type exposes the following members.

Methods

 | Name | Description
 | CreateKeynoteLegend | Creates a keynote legend.
 | CreateKeySchedule | Create a key schedule.
 | CreateMaterialTakeoff | Creates a material takeoff.
 | CreateNoteBlock | Creates a note block.
 | CreateRevisionSchedule | Creates a revision schedule.
 | CreateSchedule(Document, ElementId) | Creates a regular schedule.
 | CreateSchedule(Document, ElementId, ElementId) | Creates a regular schedule.
 | CreateSheetList | Creates a sheet list.
 | CreateViewList | Creates a view list.
Public method | Export | Exports the schedule data to a text file.
 | GetDefaultNameForKeynoteLegend | Gets the default view name that will be used when creating a keynote legend.
 | GetDefaultNameForKeySchedule | Gets the default view name that will be used when creating a key schedule.
 | GetDefaultNameForMaterialTakeoff | Gets the default view name that will be used when creating a material takeoff.
 | GetDefaultNameForNoteBlock | Gets the default view name that will be used when creating a note block.
 | GetDefaultNameForRevisionSchedule | Gets the default view name that will be used when creating a revision schedule.
 | GetDefaultNameForSchedule(Document, ElementId) | Gets the default view name that will be used when creating a regular schedule.
 | GetDefaultNameForSchedule(Document, ElementId, ElementId) | Gets the default view name that will be used when creating a schedule.
 | GetDefaultNameForSheetList | Gets the default view name that will be used when creating a sheet list.
 | GetDefaultNameForViewList | Gets the default view name that will be used when creating a view list.
 | GetDefaultParameterNameForKeySchedule | Gets the default parameter name that will be used when creating a key schedule.
 | GetValidCategoriesForKeySchedule | Gets a list of categories that can be used for a key schedule.
 | GetValidCategoriesForMaterialTakeoff | Gets a list of categories that can be used for a material takeoff.
 | GetValidCategoriesForSchedule | Gets a list of categories that can be used for a regular schedule.
 | GetValidFamiliesForNoteBlock | Gets a list of families that can be used for a note block.
 | IsValidCategoryForKeySchedule | Checks whether a category can be used for a key schedule.
 | IsValidCategoryForMaterialTakeoff | Checks whether a category can be used for a material takeoff.
 | IsValidCategoryForSchedule | Checks whether a category can be used for a regular schedule.
 | IsValidFamilyForNoteBlock | Checks whether a family can be used for a note block.

Properties

 | Name | Description
Public property | Definition | The primary ScheduleDefinition.
Public property | EmbeddedDefinition | The embedded ScheduleDefinition.
Public property | IsInternalKeynoteSchedule | Identifies if this ViewSchedule is an internal schedule used when keynotes are filtered based on the elements that are shown on a sheet.
Public property | IsTitleblockRevisionSchedule | Identifies if this ViewSchedule is an internal schedule used to display revision schedules as part of a titleblock.
Public property | KeyScheduleParameterName | In a key schedule, the name of the parameter for choosing one of the keys.

See Also

ViewSchedule Class

ViewSchedule Methods

[image] [image]