Revit 2013 API
ExporterIFCUtils..::..CreateColumnPropertySet Method
ExporterIFCUtils Class See Also Send Feedback
Adds the column-specific property set to the export.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static void CreateColumnPropertySet(
    ExporterIFC exporterIFC,
    Element pElem,
    IFCExtrusionCreationData params,
    IFCProductWrapper pWrapper
)
Visual Basic
Public Shared Sub CreateColumnPropertySet ( _
    exporterIFC As ExporterIFC, _
    pElem As Element, _
    params As IFCExtrusionCreationData, _
    pWrapper As IFCProductWrapper _
)
Visual C++
public:
static void CreateColumnPropertySet(
    ExporterIFC^ exporterIFC,
    Element^ pElem,
    IFCExtrusionCreationData^ params,
    IFCProductWrapper^ pWrapper
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
pElem
Type: Autodesk.Revit.DB..::..Element
The column element.
params
Type: Autodesk.Revit.DB.IFC..::..IFCExtrusionCreationData
The geometric parameters related to the column.
pWrapper
Type: Autodesk.Revit.DB.IFC..::..IFCProductWrapper
The product wrapper.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace

CreateCoveringPropertySet Method

[image]