Revit 2013 API
BaseImportOptions Members
BaseImportOptions Class Methods Properties See Also Send Feedback

The BaseImportOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the BaseImportOptions
Public method | GetLayerSelection | Get all set layers name which user want to import into Revit.
Public method | GetRefPoint |
Public method | SetLayerSelection | Set the layers name which user want to import into Revit.
Public method | SetRefPoint |

Properties

 | Name | Description
Public property | AutoCorrectAlmostVHLines | Correct almost-vertical lines and almost-horizontal lines for import model if option is set to true, the almost-vertical lines would be vertical lines and almost-horizontal lines would be horizontal lines.
Public property | ColorMode | Color mode for the import. Three modes are supported. Black and White, Preserve Colors, and Invert Colors.
Public property | CustomScale | Scaling the import. If this is defined and a valid value (> 0.0), it takes preference over units.
Public property | OrientToView | Place the import at the same orientation as the view that was passed into the import method. This option can only be used when not importing into a single view.(i.e. ThisViewOnly is set to false)
Public property | Placement | Where to place the import. Set this option to place the view at the origin or the center, or a shared coordinates.
Public property | ThisViewOnly | Imports drawings into the view that was passed into the import method. This option is not available in 3D views.
Public property | Unit | The unit of measure for imported geometry.
Public property | VisibleLayersOnly | Only import the visible layers.

See Also

BaseImportOptions Class

BaseImportOptions Methods

[image] [image]