Revit 2013 API
ItemFactoryBase..::..NewSketchPlane Method (Plane)
ItemFactoryBase Class Example See Also Send Feedback
Creates a new sketch plane from an arbitrary geometric plane.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public SketchPlane NewSketchPlane(
    Plane geometryPlane
)
Visual Basic
Public Function NewSketchPlane ( _
    geometryPlane As Plane _
) As SketchPlane
Visual C++
public:
SketchPlane^ NewSketchPlane(
    Plane^ geometryPlane
)

Parameters

geometryPlane
Type: Autodesk.Revit.DB..::..Plane
The geometry plane to locate sketch plane.

Return Value

If successful a new sketch plane will be returned. Otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

Examples

CopyC#
public static SketchPlane CreateSketchPlane(Autodesk.Revit.DB.Document document, Plane plane)
{
    SketchPlane sketchPlane = null;

    // create a sketch plane using Geometry.Plane
    sketchPlane = document.FamilyCreate.NewSketchPlane(plane);

    // throw exception if creation failed
    if (null == sketchPlane)
    {
        throw new Exception("Create the sketch plane failed.");
    }

    return sketchPlane;
}
CopyVB.NET
Public Shared Function CreateSketchPlane(ByVal document As Autodesk.Revit.DB.Document, ByVal plane As Plane) As SketchPlane
    Dim sketchPlane As SketchPlane = Nothing

    ' create a sketch plane using Geometry.Plane
    sketchPlane = document.FamilyCreate.NewSketchPlane(plane)

    ' throw exception if creation failed
    If sketchPlane Is Nothing Then
        Throw New Exception("Create the sketch plane failed.")
    End If

    Return sketchPlane
End Function

See Also

ItemFactoryBase Class
NewSketchPlane Overload
Autodesk.Revit.Creation Namespace

NewSketchPlane Method (Reference)

[image]