Revit 2013 API
CompoundStructure..::..SetLayers Method
CompoundStructure Class See Also Send Feedback
Set the characteristics of the layers for this CompoundStructure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetLayers(
    IList<CompoundStructureLayer> layers
)
Visual Basic
Public Sub SetLayers ( _
    layers As IList(Of CompoundStructureLayer) _
)
Visual C++
public:
void SetLayers(
    IList<CompoundStructureLayer^>^ layers
)

Parameters

layers
Type: System.Collections.Generic..::..IList<(Of <(<'CompoundStructureLayer>)>)>
The layers to be set.

Remarks

This function will replace all existing layers with the contents of the input. Properties such as VariableLayerIndex may need to be reset after setting a new set of layers.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

CompoundStructure Class

SetLayerWidth Method

[image]