Revit 2013 API
WorksharingUtils..::..GetModelUpdatesStatus Method
WorksharingUtils Class See Also Send Feedback
Gets the status of an element in the central model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static ModelUpdatesStatus GetModelUpdatesStatus(
    Document document,
    ElementId elementId
)
Visual Basic
Public Shared Function GetModelUpdatesStatus ( _
    document As Document, _
    elementId As ElementId _
) As ModelUpdatesStatus
Visual C++
public:
static ModelUpdatesStatus GetModelUpdatesStatus(
    Document^ document,
    ElementId^ elementId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document containing the element
elementId
Type: Autodesk.Revit.DB..::..ElementId
The id of the element in question

Return Value

The status of the element in the local session versus the central model

Remarks

For performance reasons, the model is not validated to be workshared, and the element id is also not validated; the element is not expanded

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

WorksharingUtils Class

GetWorksharingTooltipInfo Method

[image]