Revit 2013 API
Document..::..DeckProfiles Property
Document Class See Also Send Feedback
Returns an object that contains all of the available deck profiles currently loaded to this project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilySymbolSet DeckProfiles { get; }
Visual Basic
Public ReadOnly Property DeckProfiles As FamilySymbolSet
    Get
Visual C++
public:
property FamilySymbolSet^ DeckProfiles {
    FamilySymbolSet^ get ();
}

Remarks

The DeckProfiles property returns an object that contains the deck profiles which can be used to change the profile of a layer within a compound structure object.

See Also

Document Class

DimensionTypes Property

[image]