Revit 2013 API
Document..::..NewSpaces Method (Level, Phase, View)
Document Class See Also Send Feedback
Creates new spaces on the available plan circuits of a the given level.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This method is Obsolete in Revit 2012.  Call NewSpaces2( Autodesk.Revit.DB.Level level, Autodesk.Revit.DBPhase phase, AutodeskRevitDBView view ) instead.")]
public ElementSet NewSpaces(
    Level level,
    Phase phase,
    View view
)
Visual Basic
<ObsoleteAttribute("This method is Obsolete in Revit 2012.  Call NewSpaces2( Autodesk.Revit.DB.Level level, Autodesk.Revit.DBPhase phase, AutodeskRevitDBView view ) instead.")> _
Public Function NewSpaces ( _
    level As Level, _
    phase As Phase, _
    view As View _
) As ElementSet
Visual C++
[ObsoleteAttribute(L"This method is Obsolete in Revit 2012.  Call NewSpaces2( Autodesk.Revit.DB.Level level, Autodesk.Revit.DBPhase phase, AutodeskRevitDBView view ) instead.")]
public:
ElementSet^ NewSpaces(
    Level^ level,
    Phase^ phase,
    View^ view
)

Parameters

level
Type: Autodesk.Revit.DB..::..Level
The level on which the spaces is to exist.
phase
Type: Autodesk.Revit.DB..::..Phase
The phase in which the spaces is to exist.
view
Type: Autodesk.Revit.DB..::..View
The view on which the space tags for the spaces are to display.

Return Value

If successful an Element set which contains the rooms should be returned, otherwise the exception will be thrown.

Remarks

This method will regenerate the document even in manual regeneration mode.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The view of the relevant level can not be retrieved.
Autodesk.Revit.Exceptions..::..InvalidOperationException | The phase is invalid or regeneration fails at the end of the creation.

See Also

Document Class
NewSpaces Overload
Autodesk.Revit.Creation Namespace

NewSpaces2 Method

[image] [image]