Revit 2013 API
Document..::..NewBeamSystem Method (CurveArray, SketchPlane, XYZ, Boolean)
Document Class See Also Send Feedback
Creates a new BeamSystem with specified profile curves.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public BeamSystem NewBeamSystem(
    CurveArray profile,
    SketchPlane sketchPlane,
    XYZ direction,
    bool is3d
)
Visual Basic
Public Function NewBeamSystem ( _
    profile As CurveArray, _
    sketchPlane As SketchPlane, _
    direction As XYZ, _
    is3d As Boolean _
) As BeamSystem
Visual C++
public:
BeamSystem^ NewBeamSystem(
    CurveArray^ profile,
    SketchPlane^ sketchPlane,
    XYZ^ direction,
    bool is3d
)

Parameters

profile
Type: Autodesk.Revit.DB..::..CurveArray
The profile of the BeamSystem. The profile must be a closed curve loop in the sketch plane.
sketchPlane
Type: Autodesk.Revit.DB..::..SketchPlane
The work plane of the BeamSystem.
direction
Type: Autodesk.Revit.DB..::..XYZ
The direction is the direction of the BeamSystem.
is3d
Type: System..::..Boolean
If the BeamSystem is 3D, the sketchPlane must be a level, or an exception will be thrown.

Return Value

If successful a new BeamSystem object will be returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic). Suitable exceptions will be fired if the parameters are invalid.

Remarks

Other properties are set to default value and can be set later. Such as level, elevation, direction, etc.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input profile, sketchPlane, or direction is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when profile is not suitable for creating beam system.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown if calling this function when the document is not modifiable. Thrown if the BeamSystem is 3D, but the sketchPlane is not a level.

See Also

Document Class
NewBeamSystem Overload
Autodesk.Revit.Creation Namespace

NewCrossFitting Method

[image]