Revit 2013 API
Element..::..GetMaterialVolume Method
Element Class See Also Send Feedback
Get the volume of the given material on this element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double GetMaterialVolume(
    Material material
)
Visual Basic
Public Function GetMaterialVolume ( _
    material As Material _
) As Double
Visual C++
public:
double GetMaterialVolume(
    Material^ material
)

Parameters

material
Type: Autodesk.Revit.DB..::..Material

Return Value

The volume, or 0.0 if the input material is not a member of Materials.

Remarks

This value is calculated by Revit to show in material takeoff schedules. In some cases the value may be approximate.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | The input material was nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | The material comes from a different document than this element.

See Also

Element Class

GetMonitoredLinkElementIds Method

[image]