Revit 2013 API
PipingSystemType Members
PipingSystemType Class Methods Properties See Also Send Feedback

The PipingSystemType type exposes the following members.

Methods

 | Name | Description
 | Create | Creates a new instance of a piping system type and adds it to the document.
Public method | ValidateRiseDropSymbolType | Confirm the parameter is a valid piping rise/drop symbol type

Properties

 | Name | Description
Public property | FlowConversionMethod |
Public property | FluidTemperature | Fluid Temperature
Public property | FluidType | Fluid Type
Public property | SingleLineBendDropType | Symbol for a 1 line drop
Public property | SingleLineBendRiseType | Symbol for a 1 line rise
Public property | SingleLineJunctionDropType | Symbol for a 1 line junction drop
Public property | SingleLineJunctionRiseType | Symbol for a 1 line junction rise
Public property | TwoLineDropType | Symbol for a 2 line drop
Public property | TwoLineRiseType | Symbol for a 2 line rise

See Also

PipingSystemType Class
Autodesk.Revit.DB.Plumbing Namespace

PipingSystemType Methods

[image] [image]