Revit 2013 API
Parameter..::..AsValueString Method
Parameter Class Example See Also Send Feedback
Get the parameter value as a string with unit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string AsValueString()
Visual Basic
Public Function AsValueString As String
Visual C++
public:
String^ AsValueString()

Return Value

The string that represents the parameter value.

Remarks

The method only applies to parameters of value types. If the parameter is not a value, the method returns nullNothingnullptra null reference (Nothing in Visual Basic).

Examples

CopyC#
String ShowValueParameterInformation(Parameter attribute)
{
    string paramValue = null;
    switch (attribute.StorageType)
    {
        case StorageType.Integer:
            if (ParameterType.YesNo
                                == attribute.Definition.ParameterType)
            {
                paramValue = null;
            }
            else
            {
                paramValue = attribute.AsValueString();
            }
            break;
        case StorageType.Double:
            paramValue = attribute.AsValueString();
            break;
        default:
            paramValue = null;
            break;
    }

    return paramValue;
}
CopyVB.NET
Function ShowValueParameterInformation(ByVal attribute As Parameter) As [String]
    Dim paramValue As String = Nothing
    Select Case attribute.StorageType
        Case StorageType.[Integer]
            If ParameterType.YesNo = attribute.Definition.ParameterType Then
                paramValue = Nothing
            Else
                paramValue = attribute.AsValueString()
            End If
            Exit Select
        Case StorageType.[Double]
            paramValue = attribute.AsValueString()
            Exit Select
        Case Else
            paramValue = Nothing
            Exit Select
    End Select

    Return paramValue
End Function

See Also

Parameter Class

Set Method

[image] [image]