Revit 2013 API
Document..::..NewWalls Method (List<(Of <(<'ProfiledWallCreationData>)>)>)
Document Class See Also Send Feedback
Creates profile walls within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2013.  Please call a static creation method of Wall class instead.  Create each wall in a loop and call Document.Regenerate() or Transaction.Commit() after the loop exits.")]
public ElementSet NewWalls(
    List<ProfiledWallCreationData> dataList
)
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2013.  Please call a static creation method of Wall class instead.  Create each wall in a loop and call Document.Regenerate() or Transaction.Commit() after the loop exits.")> _
Public Function NewWalls ( _
    dataList As List(Of ProfiledWallCreationData) _
) As ElementSet
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2013.  Please call a static creation method of Wall class instead.  Create each wall in a loop and call Document.Regenerate() or Transaction.Commit() after the loop exits.")]
public:
ElementSet^ NewWalls(
    List<ProfiledWallCreationData^>^ dataList
)

Parameters

dataList
Type: System.Collections.Generic..::..List<(Of <(<'ProfiledWallCreationData>)>)>
A list of ProfiledWallCreationData which wraps the creation arguments of the walls to be created.

Return Value

If the creation is successful an ElementSet which contains the walls should be returned, otherwise the exception will be thrown.

Remarks

This batch creation method is not supported in VSTA for Revit 2010.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | If ProfiledWallCreationData's profile is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | If regeneration fails at the end of the batch creation.

See Also

Document Class
NewWalls Overload
Autodesk.Revit.Creation Namespace

NewWalls Method (List(RectangularWallCreationData))

[image]