Revit 2013 API
Application..::..NewEllipse Method
Application Class See Also Send Feedback
Creates a new geometric ellipse object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Ellipse NewEllipse(
    XYZ center,
    double radX,
    double radY,
    XYZ xVec,
    XYZ yVec,
    double param0,
    double param1
)
Visual Basic
Public Function NewEllipse ( _
    center As XYZ, _
    radX As Double, _
    radY As Double, _
    xVec As XYZ, _
    yVec As XYZ, _
    param0 As Double, _
    param1 As Double _
) As Ellipse
Visual C++
public:
Ellipse^ NewEllipse(
    XYZ^ center,
    double radX,
    double radY,
    XYZ^ xVec,
    XYZ^ yVec,
    double param0,
    double param1
)

Parameters

center
Type: Autodesk.Revit.DB..::..XYZ
The center of the ellipse.
radX
Type: System..::..Double
The x vector radius of the ellipse. Should be > 0.
radY
Type: System..::..Double
The y vector radius of the ellipse. Should be > 0.
xVec
Type: Autodesk.Revit.DB..::..XYZ
The x axis to define the ellipse plane.
yVec
Type: Autodesk.Revit.DB..::..XYZ
The y axis to define the ellipse plane. xVec must be orthogonal with yVec.
param0
Type: System..::..Double
The raw parameter value at the start of the ellipse. Should be greater than or equal to -2PI and less than Param1.
param1
Type: System..::..Double
The raw parameter value at the end of the ellipse. Should be greater than Param0 and less than or equal to 2*PI.

Remarks

PI represents the value used in Revit internal code: 3.14159265358979.

See Also

Application Class
Autodesk.Revit.Creation Namespace

NewFaceArray Method

[image]