Revit 2013 API
ExternalServiceRegistry..::..RegisterService Method (IMultiServerService, Boolean, ExecutionPolicy)
ExternalServiceRegistry Class See Also Send Feedback
A method to register a multi-server service.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static Guid RegisterService(
    IMultiServerService service,
    bool isSerializable,
    ExecutionPolicy policy
)
Visual Basic
Public Shared Function RegisterService ( _
    service As IMultiServerService, _
    isSerializable As Boolean, _
    policy As ExecutionPolicy _
) As Guid
Visual C++
public:
static Guid RegisterService(
    IMultiServerService^ service,
    bool isSerializable,
    ExecutionPolicy policy
)

Parameters

service
Type: Autodesk.Revit.DB.ExternalService..::..IMultiServerService
An instance of the external service class that implements IMultiServerService interface.
isSerializable
Type: System..::..Boolean
Designates the service as either serializable or non-serializable.
policy
Type: Autodesk.Revit.DB.ExternalService..::..ExecutionPolicy
Specifies how the service handles servers during its execution.

Return Value

An execution key to access the service when executing it.

Remarks

Each service can only be registered once. Revit checks the Id of every service getting registered and throws an exception upon an attempt to register a service with an Id that already exists.

Services need to be registered before Revit ends its initialization. For external applications that means they have to register their services during OnStartup. This will give servers which need to register to services a chance to do so during the ApplicationInitialized event, which is raised after a successfully processing OnStartup routines.

A service can be registered as either serializable or non-serializable. It is expected that a service that is once registered as serializable will always be registered as serializable. Failure to comply with this policy may lead to data loss in some documents when they are opened in a Revit session with the service currently registered as non-serializable.

An application registering a service must specify a policy to follow when executing the service. Once set, the policy remain constant during the Revit session, but a different policy may be used next time, if there is ever a need for such a change. More about the various execution policies can be found in the description of the ExecutionPolicy enumerated type.

A service is supposed to be executed only by the application that registered it. To enforce this requirement, the registering method return an execution key (a Guid) that is required as an argument to ExecuteService methods.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given service is not a valid implementation of ISingleServerService. -or- The given service does not return valid values from the interface methods. At least one of the Name, VendorId, Description, and ServiceId is either empty or invalid. -or- A service with this Id is either invalid or not unique.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | Service cannot be registered because the registry of services has been already closed. All external services must be registered before the ApplicationInitialized event is raised.

See Also

ExternalServiceRegistry Class
RegisterService Overload
Autodesk.Revit.DB.ExternalService Namespace

ExternalServiceResult Enumeration

[image]