Revit 2013 API
Rebar..::..CreateFromCurves Method
Rebar Class Example See Also Send Feedback
Creates a new instance of a Rebar element within the project.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2009

Syntax

C#
public static Rebar CreateFromCurves(
    Document doc,
    RebarStyle style,
    RebarBarType barType,
    RebarHookType startHook,
    RebarHookType endHook,
    Element host,
    XYZ norm,
    IList<Curve> curves,
    RebarHookOrientation startHookOrient,
    RebarHookOrientation endHookOrient,
    bool useExistingShapeIfPossible,
    bool createNewShape
)
Visual Basic
Public Shared Function CreateFromCurves ( _
    doc As Document, _
    style As RebarStyle, _
    barType As RebarBarType, _
    startHook As RebarHookType, _
    endHook As RebarHookType, _
    host As Element, _
    norm As XYZ, _
    curves As IList(Of Curve), _
    startHookOrient As RebarHookOrientation, _
    endHookOrient As RebarHookOrientation, _
    useExistingShapeIfPossible As Boolean, _
    createNewShape As Boolean _
) As Rebar
Visual C++
public:
static Rebar^ CreateFromCurves(
    Document^ doc,
    RebarStyle style,
    RebarBarType^ barType,
    RebarHookType^ startHook,
    RebarHookType^ endHook,
    Element^ host,
    XYZ^ norm,
    IList<Curve^>^ curves,
    RebarHookOrientation startHookOrient,
    RebarHookOrientation endHookOrient,
    bool useExistingShapeIfPossible,
    bool createNewShape
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
A document.
style
Type: Autodesk.Revit.DB.Structure..::..RebarStyle
The usage of the bar, "standard" or "stirrup/tie".
barType
Type: Autodesk.Revit.DB.Structure..::..RebarBarType
A RebarBarType element that defines bar diameter, bend radius and material of the rebar.
startHook
Type: Autodesk.Revit.DB.Structure..::..RebarHookType
A RebarHookType element that defines the hook for the start of the bar. If this parameter is nullNothingnullptra null reference (Nothing in Visual Basic), it means to create a rebar with no hook.
endHook
Type: Autodesk.Revit.DB.Structure..::..RebarHookType
A RebarHookType element that defines the hook for the end of the bar. If this parameter is nullNothingnullptra null reference (Nothing in Visual Basic), it means to create a rebar with no hook.
host
Type: Autodesk.Revit.DB..::..Element
The element to which the rebar belongs. The element must support rebar hosting; see Autodesk.Revit.DB.Structure.RebarHostData.
norm
Type: Autodesk.Revit.DB..::..XYZ
The normal to the plane that the rebar curves lie on.
curves
Type: System.Collections.Generic..::..IList<(Of <(<'Curve>)>)>
An array of curves that define the shape of the rebar curves. They must belong to the plane defined by the normal and origin. Bends and hooks should not be included in the array of curves.
startHookOrient
Type: Autodesk.Revit.DB.Structure..::..RebarHookOrientation
Defines the orientation of the hook plane at the start of the rebar with respect to the orientation of the first curve and the plane normal. Only two values are permitted: Value = Right: The hook is on your right as you stand at the end of the bar, with the bar behind you, taking the bar's normal as "up." Value = Left: The hook is on your left as you stand at the end of the bar, with the bar behind you, taking the bar's normal as "up."
endHookOrient
Type: Autodesk.Revit.DB.Structure..::..RebarHookOrientation
Defines the orientation of the hook plane at the end of the rebar with respect to the orientation of the last curve and the plane normal. Only two values are permitted: Value = Right: The hook is on your right as you stand at the end of the bar, with the bar behind you, taking the bar's normal as "up." Value = Left: The hook is on your left as you stand at the end of the bar, with the bar behind you, taking the bar's normal as "up."
useExistingShapeIfPossible
Type: System..::..Boolean
Attempts to assign a RebarShape from those existing in the document. If no shape matches, NewRebar returns or creates a new shape, according to the parameter createNewShape. When both parameters are "true", the behavior is the same as sketching rebar in the UI. At least one of these parameters must be "true".
createNewShape
Type: System..::..Boolean
Creates a shape in the document to match the curves, hooks, and style specified, and assigns it to the new rebar instance. Shape creation will not succeed unless one or more other shapes already exist in the document, and these shapes have enough shape parameters to define a shape for these curves.

Return Value

The newly created Rebar instance, or nullNothingnullptra null reference (Nothing in Visual Basic) if the operation fails.

Examples

CopyC#
Rebar CreateRebar(Autodesk.Revit.DB.Document document, FamilyInstance column, RebarBarType barType, RebarHookType hookType)
{
    // Define the rebar geometry information - Line rebar
    LocationPoint location = column.Location as LocationPoint;
    XYZ origin = location.Point;
    XYZ normal = new XYZ(1, 0, 0);
    XYZ rebarLineEnd = new XYZ(origin.X, origin.Y, origin.Z + 9);
    Line rebarLine = document.Application.Create.NewLineBound(origin, rebarLineEnd);

    // Create the line rebar
    IList<Curve> curves = new List<Curve>();
    curves.Add(rebarLine);

    Rebar rebar = Rebar.CreateFromCurves(document, Autodesk.Revit.DB.Structure.RebarStyle.Standard, barType, hookType, hookType,
                        column, origin, curves, RebarHookOrientation.Right, RebarHookOrientation.Left, true, true);

    if (null != rebar)
    {
        // set specific layout for new rebar
        Parameter paramLayout = rebar.get_Parameter(BuiltInParameter.REBAR_ELEM_LAYOUT_RULE);
        paramLayout.Set(1); // 1 = Fixed Number
        Parameter paramNum = rebar.get_Parameter(BuiltInParameter.REBAR_ELEM_QUANTITY_OF_BARS);
        paramNum.Set(10);
        rebar.ArrayLength = 1.5;
    }

    return rebar;
}
CopyVB.NET
Function CreateRebar(ByVal document As Autodesk.Revit.DB.Document, ByVal column As Autodesk.Revit.DB.FamilyInstance, _
                     ByVal barType As Autodesk.Revit.DB.Structure.RebarBarType, _
                     ByVal hookType As Autodesk.Revit.DB.Structure.RebarHookType) _
                     As Autodesk.Revit.DB.Structure.Rebar
    ' Define the rebar geometry information - Line rebar
    Dim location As LocationPoint = TryCast(column.Location, LocationPoint)
    Dim origin As Autodesk.Revit.DB.XYZ = location.Point
    Dim normal As New Autodesk.Revit.DB.XYZ(1, 0, 0)
    Dim rebarLineEnd As New Autodesk.Revit.DB.XYZ(origin.X, origin.Y, origin.Z + 9)
    Dim rebarLine As Line = document.Application.Create.NewLineBound(origin, rebarLineEnd)

    ' Create the line rebar
    Dim curves As New CurveArray()
    curves.Append(rebarLine)

    Dim rebar As Autodesk.Revit.DB.Structure.Rebar = _
        document.Create.NewRebar(Autodesk.Revit.DB.Structure.RebarStyle.Standard, barType, _
                                 hookType, hookType, column, origin, curves, _
                                 Autodesk.Revit.DB.Structure.RebarHookOrientation.Right, _
                                 Autodesk.Revit.DB.Structure.RebarHookOrientation.Left, True, True)

    If rebar IsNot Nothing Then
        ' set specific layout for new rebar
        Dim paramLayout As Parameter = rebar.Parameter(BuiltInParameter.REBAR_ELEM_LAYOUT_RULE)
        paramLayout.[Set](1)
        ' 1 = Fixed Number
        Dim paramNum As Parameter = rebar.Parameter(BuiltInParameter.REBAR_ELEM_QUANTITY_OF_BARS)
        paramNum.[Set](10)
        rebar.ArrayLength = 1.5
    End If

    Return rebar
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | host is not a valid rebar host. -or- curves is empty. -or- curves contains a curve that is neither a line nor an arc. -or- curves do not form a valid CurveLoop. -or- The input curves contains at least one helical curve and is not supported for this operation.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | norm has zero length.
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | Both useExistingShapeIfPossible and createNewShape are false.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace

CreateFromCurvesAndShape Method

[image]