Revit 2013 API
Document Methods
Document Class See Also Send Feedback

The Document type exposes the following members.

Methods

 | Name | Description
Public method | NewArea | Creates a new area
Public method | NewAreaBoundaryConditions(Element, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double) | Creates a new Area BoundaryConditions element on a host element.
Public method | NewAreaBoundaryConditions(Reference, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double) | Creates a new Area BoundaryConditions element on a reference.
Public method | NewAreaBoundaryLine | Creates a new boundary line as an Area border.
Public method | NewAreaLoad(Element, XYZ, Boolean, AreaLoadType) | Creates a new uniform hosted area load with polygonal shape within the project.
Public method | NewAreaLoad(IList<(Of <<'(XYZ>)>>), XYZ, Boolean, AreaLoadType) | Creates a new uniform unhosted area load with polygonal shape within the project.
Public method | NewAreaLoad(CurveArray, array<Int32>[]()[][], array<Int32>[]()[][], IList<(Of <<'(XYZ>)>>), Boolean, AreaLoadType) | Creates a new unhosted area load with variable forces at the vertices within the project.
Public method | NewAreaLoad(CurveArray, array<Int32>[]()[][], array<Int32>[]()[][], XYZ, XYZ, XYZ, Boolean, AreaLoadType) | Creates a new unhosted area load with variable forces at the vertices within the project.
Public method | NewAreaReinforcement | Creates a new instance of an Area Reinforcement element within the project
Public method | NewAreas | Creates new areas
Public method | NewAreaTag | Creates a new area tag.
Public method | NewAreaViewPlan | Obsolete. Creates a new view for the new area.
Public method | NewBeamSystem(CurveArray, Level) | Creates a new 2D BeamSystem with specified profile curves.
Public method | NewBeamSystem(CurveArray, SketchPlane) | Creates a new BeamSystem with specified profile curves.
Public method | NewBeamSystem(CurveArray, Level, XYZ, Boolean) | Creates a new BeamSystem with specified profile curves.
Public method | NewBeamSystem(CurveArray, SketchPlane, XYZ, Boolean) | Creates a new BeamSystem with specified profile curves.
Public method | NewCrossFitting | Add a new family instance of a cross fitting into the Autodesk Revit document, using four connectors.
Public method | NewCurtainSystem(FaceArray, CurtainSystemType) | Creates a new CurtainSystem element from a set of faces.
Public method | NewCurtainSystem(ReferenceArray, CurtainSystemType) | Obsolete. Creates a new CurtainSystem element from a set of face references.
Public method | NewCurtainSystem2 | Creates a new CurtainSystem element from a set of face references.
Public method | NewDuct(Connector, Connector, DuctType) | Adds a new duct into the document, using two connectors and duct type.
Public method | NewDuct(XYZ, Connector, DuctType) | Adds a new duct into the document, using a point, connector and duct type.
Public method | NewDuct(XYZ, XYZ, DuctType) | Adds a new duct into the document, using two points and duct type.
Public method | NewElbowFitting | Add a new family instance of an elbow fitting into the Autodesk Revit document, using two connectors.
Public method | NewElectricalSystem(Connector, ElectricalSystemType) | Creates a new MEP Electrical System element from an unused Connector.
Public method | NewElectricalSystem(ICollection<(Of <<'(ElementId>)>>), ElectricalSystemType) | Creates a new MEP Electrical System element from a set of electrical components.
Public method | NewElectricalSystem(ElementSet, ElectricalSystemType) | Obsolete. Creates a new MEP Electrical System element from a set of electrical components.
Public method | NewExtrusionRoof | Creates a new Extrusion Roof.
Public method | NewFamilyInstance(Curve, FamilySymbol, Level, StructuralType) | Inserts a new instance of a family into the document, using a curve, type/symbol and reference level.
Public method | NewFamilyInstance(XYZ, FamilySymbol, Level, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol and a base level.
Public method | NewFamilyInstance(XYZ, FamilySymbol, Element, Level, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, the host element and a base level.
Public method | NewFascia(FasciaType, Reference) | Creates a fascia along a reference.
Public method | NewFascia(FasciaType, ReferenceArray) | Creates a fascia along a reference array.
Public method | NewFlexDuct(IList<(Of <<'(XYZ>)>>), FlexDuctType) | Adds a new flexible duct into the document, using a point array and duct type.
Public method | NewFlexDuct(Connector, Connector, FlexDuctType) | Adds a new flexible duct into the document, using two connector, and duct type.
Public method | NewFlexDuct(Connector, IList<(Of <<'(XYZ>)>>), FlexDuctType) | Adds a new flexible duct into the document, using a connector, point array and duct type.
Public method | NewFlexPipe(IList<(Of <<'(XYZ>)>>), FlexPipeType) | Adds a new flexible pipe into the document, using a point array and pipe type.
Public method | NewFlexPipe(Connector, Connector, FlexPipeType) | Adds a new flexible pipe into the document, using two connector, and flexible pipe type.
Public method | NewFlexPipe(Connector, IList<(Of <<'(XYZ>)>>), FlexPipeType) | Adds a new flexible pipe into the document, using a connector, point array and pipe type.
Public method | NewFloor(CurveArray, Boolean) | Creates a floor within the project with the given horizontal profile using the default floor style.
Public method | NewFloor(CurveArray, FloorType, Level, Boolean) | Creates a floor within the project with the given horizontal profile and floor style on the specified level.
Public method | NewFloor(CurveArray, FloorType, Level, Boolean, XYZ) | Creates a floor within the project with the given horizontal profile and floor style on the specified level with the specified normal vector.
Public method | NewFootPrintRoof | Creates a new FootPrintRoof element.
Public method | NewFoundationSlab | Creates a foundation slab within the project with the given horizontal profile and floor style on the specified level.
Public method | NewFoundationWall | Creates a new continuous footing object.
Public method | NewGrid(Arc) | Creates a new radial grid line.
Public method | NewGrid(Line) | Creates a new linear grid line.
Public method | NewGrids | Creates new grid lines.
Public method | NewGutter(GutterType, Reference) | Creates a gutter along a reference.
Public method | NewGutter(GutterType, ReferenceArray) | Creates a gutter along a reference array.
Public method | NewLineBoundaryConditions(Element, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double) | Creates a new Line BoundaryConditions element on a host element.
Public method | NewLineBoundaryConditions(Reference, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double) | Creates a new Line BoundaryConditions element on a reference.
Public method | NewLineLoad(Element, IList<(Of <<'(XYZ>)>>), IList<(Of <<'(XYZ>)>>), Boolean, Boolean, Boolean, LineLoadType, SketchPlane) | Creates a new hosted line load within the project using data at two points.
Public method | NewLineLoad(Reference, IList<(Of <<'(XYZ>)>>), IList<(Of <<'(XYZ>)>>), Boolean, Boolean, Boolean, LineLoadType, SketchPlane) | Creates a new hosted line load within the project using data at an array of points.
Public method | NewLineLoad(IList<(Of <<'(XYZ>)>>), IList<(Of <<'(XYZ>)>>), IList<(Of <<'(XYZ>)>>), Boolean, Boolean, Boolean, LineLoadType, SketchPlane) | Creates a new unhosted line load within the project using data at an array of points.
Public method | NewLineLoad(XYZ, XYZ, XYZ, XYZ, XYZ, XYZ, Boolean, Boolean, Boolean, LineLoadType, SketchPlane) | Creates a new unhosted line load within the project using data at two points.
Public method | NewLoadCase | Creates a new instance of a LoadCase element within the project.
Public method | NewLoadCombination | Creates a new instance of a LoadCombination element within the project.
Public method | NewLoadNature | Creates a new instance of a LoadNature element within the project.
Public method | NewLoadUsage | Creates a new instance of a LoadUsage element within the project.
Public method | NewMechanicalSystem | Creates a new MEP mechanical system element.
Public method | NewOpening(Element, CurveArray, eRefFace) | Creates a new opening in a beam, brace and column.
Public method | NewOpening(Element, CurveArray, Boolean) | Creates a new opening in a roof, floor and ceiling.
Public method | NewOpening(Level, Level, CurveArray) | Creates a new shaft opening between a set of levels.
Public method | NewOpening(Wall, XYZ, XYZ) | Creates a rectangular opening on a wall.
Public method | NewPathReinforcement | Creates a new instance of a Path Reinforcement element within the project
Public method | NewPipe(Connector, Connector, PipeType) | Adds a new pipe into the document, using two connectors and duct type.
Public method | NewPipe(XYZ, Connector, PipeType) | Adds a new pipe into the document, using a point, connector and pipe type.
Public method | NewPipe(XYZ, XYZ, PipeType) | Adds a new pipe into the document, using two points and pipe type.
Public method | NewPipingSystem | Creates a new MEP piping system element.
Public method | NewPointBoundaryConditions | Creates a new Point BoundaryConditions Element.
Public method | NewPointLoad(Reference, XYZ, XYZ, Boolean, PointLoadType, SketchPlane) | Creates a new hosted point load within the project.
Public method | NewPointLoad(XYZ, XYZ, XYZ, Boolean, PointLoadType, SketchPlane) | Creates a new unhosted point load within the project.
Public method | NewRebarBarType | Creates a new instance of Rebar Bar Type, which defines the bar diameter, bar bend diameter and bar material of the rebar.
Public method | NewRoom(Phase) | Creates a new unplaced room and with an assigned phase.
Public method | NewRoom(Level, UV) | Creates a new room on a level at a specified point.
Public method | NewRoom(Room, PlanCircuit) | Creates a new room within the confines of a plan circuit, or places an unplaced room within the confines of the plan circuit.
Public method | NewRoomBoundaryLines | Creates a new boundary line as an Room border.
Public method | NewRooms(Level) | Obsolete. Creates new rooms in each plan circuit found in the given level in the last phase.
Public method | NewRooms(List<(Of <<'(RoomCreationData>)>>)) | Obsolete. Creates new rooms using the specified placement data.
Public method | NewRooms(Level, Phase) | Obsolete. Creates new rooms in each plan circuit found in the given level in the given phase.
Public method | NewRooms(Phase, Int32) | Obsolete. Creates new unplaced rooms in the given phase.
Public method | NewRooms2(Level) | Creates new rooms in each plan circuit found in the given level in the last phase.
Public method | NewRooms2(Level, Phase) | Creates new rooms in each plan circuit found in the given level in the given phase.
Public method | NewRooms2(Phase, Int32) | Creates new unplaced rooms in the given phase.
Public method | NewRoomTag | Creates a new RoomTag.
Public method | NewSlab | Creates a slab within the project with the given horizontal profile using the default floor style.
Public method | NewSlabEdge(SlabEdgeType, Reference) | Creates a slab edge along a reference.
Public method | NewSlabEdge(SlabEdgeType, ReferenceArray) | Creates a slab edge along a reference array.
Public method | NewSpace(Phase) | Creates a new unplaced space on a given phase.
Public method | NewSpace(Level, UV) | Creates a new space element on the given level at the given location.
Public method | NewSpace(Level, Phase, UV) | Creates a new space element on the given level, at the given location, and assigned to the given phase.
Public method | NewSpaceBoundaryLines | Creates a new boundary line as an Space border.
Public method | NewSpaces(Phase, Int32) | Obsolete. Creates a set of new unplaced spaces on a given phase.
Public method | NewSpaces(Level, Phase, View) | Obsolete. Creates new spaces on the available plan circuits of a the given level.
Public method | NewSpaces2(Phase, Int32) | Creates a set of new unplaced spaces on a given phase.
Public method | NewSpaces2(Level, Phase, View) | Creates new spaces on the available plan circuits of a the given level.
Public method | NewSpaceTag | Creates a new SpaceTag.
Public method | NewSpotCoordinate | Generate a new spot coordinate object within the project.
Public method | NewSpotElevation | Generate a new spot elevation object within the project.
Public method | NewTag | Creates a new IndependentTag Element.
Public method | NewTakeoffFitting | Add a new family instance of an takeoff fitting into the Autodesk Revit document, using one connector and one MEP curve.
Public method | NewTeeFitting | Add a new family instance of a tee fitting into the Autodesk Revit document, using three connectors.
Public method | NewTopographySurface | Creates a new TopographySurface element in the document, and initializes it with a set of points.
Public method | NewTransitionFitting | Add a new family instance of an transition fitting into the Autodesk Revit document, using two connectors.
Public method | NewTruss | Creates a New Truss.
Public method | NewUnionFitting | Add a new family instance of an union fitting into the Autodesk Revit document, using two connectors.
Public method | NewViewDrafting | Creates a new drafting view.
Public method | NewViewSheet | Creates a new sheet view.
Public method | NewWall(CurveArray, Boolean) | Obsolete. Creates a non rectangular profile wall within the project using the default wall type.
Public method | NewWall(Curve, Level, Boolean) | Obsolete. Creates a new rectangular profile wall within the project using the default wall style.
Public method | NewWall(CurveArray, WallType, Level, Boolean) | Obsolete. Creates a non rectangular profile wall within the project using the specified wall type.
Public method | NewWall(CurveArray, WallType, Level, Boolean, XYZ) | Obsolete. Creates a non rectangular profile wall within the project using the specified wall type and normal vector.
Public method | NewWall(Curve, WallType, Level, Double, Double, Boolean, Boolean) | Obsolete. Creates a new rectangular profile wall within the project using the specified wall type, height, and offset.
Public method | NewWalls(List<(Of <<'(ProfiledWallCreationData>)>>)) | Obsolete. Creates profile walls within the project.
Public method | NewWalls(List<(Of <<'(RectangularWallCreationData>)>>)) | Obsolete. Creates rectangular walls within the project.
Public method | NewWire | Creates a new wire element.
Public method | NewZone | Creates a new Zone element.

See Also

Document Class
Autodesk.Revit.Creation Namespace

NewArea Method

[image]