Revit 2013 API
Document..::..NewGrids Method
Document Class See Also Send Feedback
Creates new grid lines.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementSet NewGrids(
    CurveArray curves
)
Visual Basic
Public Function NewGrids ( _
    curves As CurveArray _
) As ElementSet
Visual C++
public:
ElementSet^ NewGrids(
    CurveArray^ curves
)

Parameters

curves
Type: Autodesk.Revit.DB..::..CurveArray
The curves which represent the new grid lines. These curves must be lines or bounded arcs.

Return Value

An Element set that contains the Grids.

Remarks

All input curves should lie on horizontal planes.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | If the curve is an unbounded arc (a circle).
Autodesk.Revit.Exceptions..::..ArgumentNullException | If any curve supplied in the input is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | If any grid line is not created successfully or regeneration fails at the end of the batch creation.

See Also

Document Class
Autodesk.Revit.Creation Namespace

NewGroup Method

[image] [image]