Revit 2013 API
Document..::..Delete Method (ICollection<(Of <(<'ElementId>)>)>)
Document Class Example See Also Send Feedback
Deletes several elements from the document given their ids.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ICollection<ElementId> Delete(
    ICollection<ElementId> ids
)
Visual Basic
Public Function Delete ( _
    ids As ICollection(Of ElementId) _
) As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ Delete(
    ICollection<ElementId^>^ ids
)

Parameters

ids
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
A set of element ids for the elements that are to be deleted.

Return Value

The deleted element id set if the deletion succeeds, or nullNothingnullptra null reference (Nothing in Visual Basic) if the deletion fails.

Remarks

This method will delete the elements and any other elements that are totally dependent upon those elements. Any references to the deleted elements will become invalid and hence cause an exception to be thrown if they are accessed.

Note: in a family document, the predefined elements (those elements inherited from its family template file) can't be deleted by this method.

Examples

CopyC#
// Delete all the selected elements via the set of element ids.
ICollection<Autodesk.Revit.DB.ElementId> idSelection = null ;
 UIDocument uidoc = new UIDocument(document);
 foreach (Autodesk.Revit.DB.Element elem in uidoc.Selection.Elements)
 {
     Autodesk.Revit.DB.ElementId id = elem.Id;
     idSelection.Add(id);
 }
 ICollection<Autodesk.Revit.DB.ElementId> deletedIdSet = document.Delete(idSelection);

 if (0 == deletedIdSet.Count)
 {
     throw new Exception("Deleting the selected elements in Revit failed.");
 }

 TaskDialog.Show("Revit","The selected element has been removed.");
CopyVB.NET
' Delete all the selected elements via the set of element ids.
Dim idSelection As ICollection(Of Autodesk.Revit.DB.ElementId) = Nothing
Dim uidoc As New UIDocument(document)
For Each elem As Autodesk.Revit.DB.Element In uidoc.Selection.Elements
    Dim id As Autodesk.Revit.DB.ElementId = elem.Id
    idSelection.Add(id)
Next
Dim deletedIdSet As ICollection(Of Autodesk.Revit.DB.ElementId) = document.Delete(idSelection)

If 0 = deletedIdSet.Count Then
    Throw New Exception("Deleting the selected elements in Revit failed.")
End If

TaskDialog.Show("Revit", "The selected element has been removed.")

See Also

Document Class
Delete Overload

Delete Method (ElementSet)

[image]