Revit 2013 API
ItemFactoryBase..::..NewFamilyInstances Method
ItemFactoryBase Class Example See Also Send Feedback
Creates Family instances within the document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This method is Obsolete in Revit 2013.  Call NewFamilyInstances2(List<FamilyInstanceCreationData> dataList) instead.")]
public ElementSet NewFamilyInstances(
    List<FamilyInstanceCreationData> dataList
)
Visual Basic
<ObsoleteAttribute("This method is Obsolete in Revit 2013.  Call NewFamilyInstances2(List<FamilyInstanceCreationData> dataList) instead.")> _
Public Function NewFamilyInstances ( _
    dataList As List(Of FamilyInstanceCreationData) _
) As ElementSet
Visual C++
[ObsoleteAttribute(L"This method is Obsolete in Revit 2013.  Call NewFamilyInstances2(List<FamilyInstanceCreationData> dataList) instead.")]
public:
ElementSet^ NewFamilyInstances(
    List<FamilyInstanceCreationData^>^ dataList
)

Parameters

dataList
Type: System.Collections.Generic..::..List<(Of <(<'FamilyInstanceCreationData>)>)>
A list of FamilyInstanceCreationData which wraps the creation arguments of the families to be created.

Return Value

If the creation is successful an ElementSet which contains the Family instances should be returned, otherwise the exception will be thrown.

Remarks

This batch creation method is not supported in VSTA for Revit 2010.

Note: ForbiddenForDynamicUpdateException might be thrown during a dynamic update if the inserted instance establishes a mutual dependency with another structure.

Note: if the created family instance includes nested instances, the API framework will automatically regenerate the document during this method call. This happens regardless of the setting for RegenerationMode.

Examples

CopyC#
ElementSet BatchCreateColumns(Autodesk.Revit.DB.Document document, Level level)
{
    List<FamilyInstanceCreationData> fiCreationDatas = new List<FamilyInstanceCreationData>();

    ElementSet elementSet = null;

    //Try to get a FamilySymbol
    FamilySymbol familySymbol = null;
    FilteredElementCollector collector = new FilteredElementCollector(document);
    ICollection<Element> collection = collector.OfClass(typeof(FamilySymbol)).ToElements();
    foreach (Element e in collection)
    {
        familySymbol = e as FamilySymbol;
        if (null != familySymbol.Category)
        {
            if ("Structural Columns" == familySymbol.Category.Name)
            {
                break;
            }
        }
    }

    if (null != familySymbol)
    {
        //Create 10 FamilyInstanceCreationData items for batch creation
        for (int i = 1; i < 11; i++)
        {
            XYZ location = new XYZ(i * 10, 100, 0);
            FamilyInstanceCreationData fiCreationData =
                new FamilyInstanceCreationData(location, familySymbol, level,  StructuralType.Column);

            if (null != fiCreationData)
            {
                fiCreationDatas.Add(fiCreationData);
            }
        }

        if (fiCreationDatas.Count > 0)
        {
            // Create Columns
            elementSet = document.Create.NewFamilyInstances(fiCreationDatas);
        }
        else
        {
            throw new Exception("Batch creation failed.");
        }
    }
    else
    {
        throw new Exception("No column types found.");
    }

    return elementSet;
}
CopyVB.NET
Function BatchCreateColumns(ByVal document As Autodesk.Revit.DB.Document, ByVal level As Level) As ElementSet
    Dim fiCreationDatas As New List(Of FamilyInstanceCreationData)()

    Dim elementSet As ElementSet = Nothing

    'Try to get a FamilySymbol
    Dim familySymbol As FamilySymbol = Nothing
    Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(document)
    Dim collection As ICollection(Of Autodesk.Revit.DB.Element) = collector.OfClass(GetType(FamilySymbol)).ToElements()
    For Each e As Autodesk.Revit.DB.Element In collection
        familySymbol = TryCast(e, FamilySymbol)
        If familySymbol.Category IsNot Nothing Then
            If "Structural Columns" = familySymbol.Category.Name Then
                Exit For
            End If
        End If
    Next

    If familySymbol IsNot Nothing Then
        'Create 10 FamilyInstanceCreationData items for batch creation
        Dim i As Integer = 1
        While i < 11
            Dim location As New Autodesk.Revit.DB.XYZ(i * 10, 100, 0)
            Dim fiCreationData As New FamilyInstanceCreationData(location, familySymbol, level, Autodesk.Revit.DB.Structure.StructuralType.Column)

            If fiCreationData IsNot Nothing Then
                fiCreationDatas.Add(fiCreationData)
            End If
            System.Math.Max(System.Threading.Interlocked.Increment(i), i - 1)
        End While

        If fiCreationDatas.Count > 0 Then
            ' Create Columns
            elementSet = document.Create.NewFamilyInstances(fiCreationDatas)
        Else
            Throw New Exception("Batch creation failed.")
        End If
    Else
        Throw New Exception("No column types found.")
    End If

    Return elementSet
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | If FamilyInstanceCreationData's 'curve' or 'symbol' member is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | If regeneration fails at the end of the batch creation.

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace

NewFamilyInstances2 Method

[image]