Revit 2013 API
Document..::..WallTypes Property
Document Class See Also Send Feedback
Retrieves an object that contains all the wall types that are currently loaded into the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public WallTypeSet WallTypes { get; }
Visual Basic
Public ReadOnly Property WallTypes As WallTypeSet
    Get
Visual C++
public:
property WallTypeSet^ WallTypes {
    WallTypeSet^ get ();
}

Remarks

This property returns a set of WallType objects. These objects can be used change the type of a wall from one type to another.

See Also

Document Class

WorksharingCentralFilename Property

[image]