Revit 2013 API
StructuralAsset..::..UnitWeight Property
StructuralAsset Class See Also Send Feedback
The weight per unit volume of the material described by the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
[ObsoleteAttribute("Unit weight is deprecated and will be removed in a future version of Revit. Use density instead.")]
public double UnitWeight { get; set; }
Visual Basic
<ObsoleteAttribute("Unit weight is deprecated and will be removed in a future version of Revit. Use density instead.")> _
Public Property UnitWeight As Double
    Get
    Set
Visual C++
[ObsoleteAttribute(L"Unit weight is deprecated and will be removed in a future version of Revit. Use density instead.")]
public:
property double UnitWeight {
    double get ();
    void set (double value);
}

Remarks

The value is in kilograms per square foot, square second (kg / ft² · s²).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for unitWeight must be non-negative.

See Also

StructuralAsset Class

WoodBendingStrength Property

[image]