Revit 2013 API
IFCProductWrapper..::..AddElement Method (IFCAnyHandle, IFCLevelInfo, IFCExtrusionCreationData, Boolean)
IFCProductWrapper Class See Also Send Feedback
Adds an IfcElement handle to associate with the IfcProduct in this wrapper.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void AddElement(
    IFCAnyHandle elementHandle,
    IFCLevelInfo pLevelInfo,
    IFCExtrusionCreationData params,
    bool relateToLevel
)
Visual Basic
Public Sub AddElement ( _
    elementHandle As IFCAnyHandle, _
    pLevelInfo As IFCLevelInfo, _
    params As IFCExtrusionCreationData, _
    relateToLevel As Boolean _
)
Visual C++
public:
void AddElement(
    IFCAnyHandle^ elementHandle,
    IFCLevelInfo^ pLevelInfo,
    IFCExtrusionCreationData^ params,
    bool relateToLevel
)

Parameters

elementHandle
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The IfcElement handle.
pLevelInfo
Type: Autodesk.Revit.DB.IFC..::..IFCLevelInfo
The level info.
params
Type: Autodesk.Revit.DB.IFC..::..IFCExtrusionCreationData
The extrusion creation data associated with the given element. Optional, can be nullNothingnullptra null reference (Nothing in Visual Basic).
relateToLevel
Type: System..::..Boolean
True to relate the element to the level, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCProductWrapper Class
AddElement Overload
Autodesk.Revit.DB.IFC Namespace

AddElement Method (IFCAnyHandle, IFCPlacementSetter, IFCExtrusionCreationData, Boolean)

[image]