Revit 2013 API
AssemblyViewUtils..::..CreateMaterialTakeoff Method
AssemblyViewUtils Class See Also Send Feedback
Creates a new material takeoff multicategory schedule assembly view for the assembly instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static ViewSchedule CreateMaterialTakeoff(
    Document document,
    ElementId assemblyInstanceId
)
Visual Basic
Public Shared Function CreateMaterialTakeoff ( _
    document As Document, _
    assemblyInstanceId As ElementId _
) As ViewSchedule
Visual C++
public:
static ViewSchedule^ CreateMaterialTakeoff(
    Document^ document,
    ElementId^ assemblyInstanceId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the view will be added.
assemblyInstanceId
Type: Autodesk.Revit.DB..::..ElementId
Id of the assembly instance that owns the new view.

Return Value

A new material takeoff multicategory schedule assembly view.

Remarks

The material takeoff schedule will be preloaded with fields “Material: Name” and “Material: Volume”. The document must be regenerated before using the schedule.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | assemblyInstanceId is not an AssemblyInstance.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AssemblyViewUtils Class

CreatePartList Method

[image]