Revit 2013 API
StairsEditScope Class
Members See Also Send Feedback
StairsEditScope allows user to maintain a stairs-editing session.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class StairsEditScope : IDisposable
Visual Basic
Public Class StairsEditScope _
    Implements IDisposable
Visual C++
public ref class StairsEditScope : IDisposable

Remarks

Start/end of a StairsEditScope will start/end a transaction group. After a StairsEditScope is started, user can start transactions and edit the stairs. Individual transactions the user creates inside StairsEditScope will not appear in the undo menu. All transactions committed during the edit mode will be merged into a single one which will bear the given name passed into StairsEditScope constructor.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..StairsEditScope

See Also

StairsEditScope Members

StairsEditScope Members

[image] [image]