Revit 2013 API
RebarShape..::..GetHookAngle Method
RebarShape Class See Also Send Feedback
Get the hook angle, expressed as an integral number of degrees (common values are 0, 90, 135, and 180).

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public int GetHookAngle(
    int index
)
Visual Basic
Public Function GetHookAngle ( _
    index As Integer _
) As Integer
Visual C++
public:
int GetHookAngle(
    int index
)

Parameters

index
Type: System..::..Int32
0 for the starting hook, 1 for the ending hook.

Remarks

Replaces the property RebarShape.HookAngle from prior releases.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | index must be 0 or 1.

See Also

RebarShape Class
Autodesk.Revit.DB.Structure Namespace

GetHookOrientation Method

[image]