Revit 2013 API
ExternalApplicationArray Members
ExternalApplicationArray Class Constructors Methods Properties See Also Send Feedback

The ExternalApplicationArray type exposes the following members.

Constructors

 | Name | Description
Public method | ExternalApplicationArray | Initializes a new instance of the ExternalApplicationArray class

Methods

 | Name | Description
Public method | Append | Add the item to the end of the array.
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | Insert | Insert the specified item into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.

See Also

ExternalApplicationArray Class
Autodesk.Revit.UI Namespace

ExternalApplicationArray Constructor

[image]