Revit 2013 API
Rebar Properties
Rebar Class See Also Send Feedback

The Rebar type exposes the following members.

Properties

 | Name | Description
Public property | ArrayLength | Identifies the distribution path length of rebar set.
Public property | BarsOnNormalSide | Identifies if the bars of the rebar set are on the same side of the rebar plane indicated by the normal.
Public property | BarType | Obsolete. Return the type of the rebar.
Public property | BaseFinishingTurns | For a spiral, the number of finishing turns at the lower end of the spiral.
Public property | DistributionPath | Obsolete. For Rebar with an array layout, return the distribution path (a line).
Public property | Height | For a spiral, the overall height.
Public property | Host | Obsolete. The element that contains the rebar.
Public property | IncludeFirstBar | Identifies if the first bar in rebar set is shown.
Public property | IncludeLastBar | Identifies if the last bar in rebar set is shown.
Public property | LayoutRule | Identifies the layout rule of rebar set.
Public property | MaxSpacing | Identifies the maximum spacing between rebar in rebar set.
Public property | MultiplanarDepth | For a multiplanar rebar, the depth of the instance.
Public property | Normal | A unit-length vector normal to the plane of the rebar
Public property | NumberOfBarPositions | The number of potential bars in the set.
Public property | Pitch | For a spiral, the pitch, or vertical distance traveled in one rotation.
Public property | Quantity | Identifies the number of bars in rebar set.
Public property | RebarShape | Obsolete. Get/Set the RebarShape associated with the Rebar.
Public property | RebarShapeId | The RebarShape element that defines the shape of the rebar.
Public property | ScheduleMark | The Schedule Mark parameter. On creation, the Schedule Mark is set to a value that is unique to the host, but it can be set to any value.
Public property | TopFinishingTurns | For a spiral, the number of finishing turns at the upper end of the spiral.
Public property | TotalLength | The length of an individual bar multiplied by Quantity.
Public property | Volume | The volume of an individual bar multiplied by Quantity.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace

ArrayLength Property

[image]