Revit 2013 API
DividedSurface Class
Members Example See Also Send Feedback
An element that represents a mesh on the surface of another element, a family instance, an import instance or a geometry combination, and a tile pattern built on that mesh.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class DividedSurface : Element
Visual Basic
Public Class DividedSurface _
    Inherits Element
Visual C++
public ref class DividedSurface : public Element

Remarks

The type of this element may be set to: a TilePattern element, a FamilySymbol element from a Curtain Panel family.

Examples

CopyC#
public void TileSurface(Document document, Form form)
{
    // cover surface with OctagonRotate tile pattern
    TilePatterns tilePatterns = document.Settings.TilePatterns;
    DividedSurfaceData dsData = form.GetDividedSurfaceData();
    if (dsData != null)
    {
        foreach (Reference r in dsData.GetReferencesWithDividedSurfaces())
        {
            DividedSurface ds = dsData.GetDividedSurfaceForReference(r);
            ds.ChangeTypeId(tilePatterns.GetTilePattern(TilePatternsBuiltIn.OctagonRotate).Id);
        }
    }
}
CopyVB.NET
Public Sub TileSurface(ByVal document As Document, ByVal form As Form)
    ' cover surface with OctagonRotate tile pattern
    Dim tilePatterns As TilePatterns = document.Settings.TilePatterns
    Dim dsData As DividedSurfaceData = form.GetDividedSurfaceData()
    If dsData IsNot Nothing Then
        For Each r As Reference In dsData.GetReferencesWithDividedSurfaces()
            Dim ds As Autodesk.Revit.DB.DividedSurface = dsData.GetDividedSurfaceForReference(r)
            ds.ChangeTypeId(tilePatterns.GetTilePattern(TilePatternsBuiltIn.OctagonRotate).Id)
        Next
    End If
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..DividedSurface

See Also

DividedSurface Members

DividedSurface Members

[image] [image]