Revit 2013 API
ExporterIFCUtils Methods
ExporterIFCUtils Class See Also Send Feedback

The ExporterIFCUtils type exposes the following members.

Methods

 | Name | Description
 | AddClippingsToBaseExtrusion | Processes the geometry of the wall to create an extruded area solid representing the geometry of the wall (including any clippings imposed by neighboring elements).
 | AddOpeningsToElement | Adds the openings from the element as separate IfcElements related to the element.
 | AddValueString | Adds a string value to a built-in parameter.
 | AreSolidsEqual | Determines whether two solids are identical, potentially offset from each other.
 | CanExportWallGeometryAsExtrusion | Identifies if the base geometry of the wall can be represented as an extrusion.
 | CollectGeometryInfo(ExporterIFC, IFCGeometryInfo, GeometryObject, XYZ, Boolean) | Collects all the target geometry from the input geometry object and adds it as IFC handles to the IFCInfo.
 | CollectGeometryInfo(ExporterIFC, IFCGeometryInfo, GeometryObject, XYZ, Boolean, Transform) | Collects all the target geometry from the input geometry object and adds it as IFC handles to the IFCInfo.
 | ComputeAreaOfCurveLoops | Computes total area of the list of curve loops. If the area cannot be calculated, returns 0.0.
 | ComputeRoofProjectedArea | Returns the projected area of the room, unscaled.
 | ConvertUnits | Converts a value from universal units to display units.
 | CreateAlternateGUID | Creates a GUID for the given element.
 | CreateBeamColumnBaseQuantities | Creates the beam and column base quantities and adds them to the export.
 | CreateColumnPropertySet | Adds the column-specific property set to the export.
 | CreateCoveringPropertySet | Adds the covering-specific property set to the export.
 | CreateCurtainWallPropertySet | Adds the curtain wall-specific property set to the export.
 | CreateCurveFromCurveLoop | Creates an IFCCurve from a Curve Loop, projected onto a plane.
 | CreateDoorPropertySet | Adds the door-specific property set to the export.
 | CreateDoorWindowBaseQuantities | Creates the door or window base quantities and adds them to the export.
 | CreateExtrudedSurfaceFromCurve | Creates an IfcConnectionGeometry handle from the extrusion of a curve into a surface.
 | CreateGUID()()()() | Creates a randomized GUID.
 | CreateGUID(Element) | Creates a GUID for the given element.
 | CreateNonCOBIERoomQuantities | Creates the non-COBIE spatial element quantities and adds them to the export.
 | CreateOpeningQuantities | Creates the opening quantities and adds them to the export.
 | CreatePreCOBIEGSAQuantities | Creates the spatial element quantities required by GSA before COBIE and adds them to the export.
 | CreateProjectLevelGUID | Creates a GUID from Revit project for given GUIDType.
 | CreateSubElementGUID | Creates a consistent GUID for an IFC entity related to a Revit element. A "related" sub-element is one that is unique for a given type of element, and can therefore by identified by a simple index value (e.g. PSet_Wall_Common property set for a wall.) The index value 0 is reserved, as this would generate the GUID of the element itself. A listing of known sub-elements is contained in IFCSubElementEnums.cs; it is expected that this list would be maintained up-to-date, instead of passing arbitrary values into this function.
 | CreateWallBaseQuantities | Creates the wall base quantities and adds them to the export.
 | CreateWindowPropertySet | Adds the window-specific property set to the export.
Public method | Dispose |
 | EndExportInternal | Use the internal Revit implementation to relate elements at the end of export.
 | ExportExtrudedSlabOpenings |
 | ExportFamilyInstanceAsExtrusion(ExporterIFC, FamilyInstance, Boolean, ElementId, IFCExtrusionCreationData) | Creates a single extruded solid handle to represent the given family instance.
 | ExportFamilyInstanceAsExtrusion(ExporterIFC, FamilyInstance, Boolean, IFCRange, ElementId, IFCExtrusionCreationData) | Creates a single extruded solid handle to represent the given family instance.
 | ExportLegacyStairsAsContainer | Adds data from a legacy staircase to the export.
 | ExportRampAsContainer | Adds data from a ramp to the export.
 | ExportRoofAsContainer | Exports a roof as a container of multiple roof slabs. Returns the handle, if successful.
 | ExportSlabAsExtrusion |
 | GetAttachedColumns | Obtains a list of columns known to Revit as intersecting with this wall.
 | GetConnectedWalls | Obtains the IFC-specific information regarding the connections between this wall and other elements.
 | GetElevationProfile | Obtains the curve loops which bound the wall's elevation profile.
 | GetFamilyName | Gets the family name of an ElementType.
 | GetGeometryFromInplaceWall | Obtains a special snapshot of the geometry of an in-place wall element suitable for export.
 | GetGlobal2DDirectionHandles | Obtains the handles representing the cardinal directions in 2D.
 | GetGlobal2DOriginHandle | Obtains the handle representing the 2D origin.
 | GetGlobal3DDirectionHandles | Obtains the handles representing the cardinal directions in 3D.
 | GetGlobal3DOriginHandle | Obtains the handle representing the 3D origin.
 | GetIFCClassName | Obtains the IFC class name associated to the given element for the current export.
 | GetIFCClassNameByCategory | Obtains the IFC class name associated to a given category id for the current export.
 | GetIFCType | Obtains the IFC type associated to the given element for the current export.
 | GetLegacyCurtainSubElements | Gets the sub elements from a legacy curtain element.
 | GetLegacyStairOrRampComponents | Gets the components of a stair or ramp.
 | GetLegacyStairsProperties | Returns one or more properties for legacy (created in R2012 or before) Stairs.
 | GetLoopsFromTopBottomFace | Gets the curve loop(s) that represent the bottom or top face of the wall.
 | GetMinSymbolHeight | Obtains the minimum height of the given FamilySymbol.
 | GetMinSymbolWidth | Obtains the minimum width of the given FamilySymbol.
 | GetNumBuildingStoreys | Returns the number of non-empty, non-duplicate building stories in the file.
 | GetOriginalSymbol | Returns the original family symbol of this family instance, before the instance is modified by joins, cuts, coping, extensions, or other post-processing.
 | GetRebarGeometry | Generates the geometry for a Rebar for a specific view. The filter view is allowed to be null, but no geometry will be generated if it is.
 | GetRelativeLocalPlacementOffsetTransform | Obtains the relative transform between two IfcLocalPlacement handles.
 | GetRoomBoundaryAsCurveLoopArray | Obtains the spatial element boundary curves as an array of CurveLoops, needed for processing into IFC-specific elements later.
 | GetSpatialElementBoundaryOptions | Obtains the SpatialElementBoundaryOptions needed for IFC export.
 | GetTransformForDoorOrWindow | Obtains the transform for the door or window instance.
 | GetUnscaledTransform | Obtains the unscaled transform from an IfcLocalPlacement handle.
 | GetWallBaseOffset | Obtains the base offset of the wall.
 | GetWallHeightDirection |
 | GetWallTrimmedCurve | Obtains the curve of the wall trimmed or extended according to the end conditions of the wall.
 | HasElevationProfile | Identifies if the wall has a sketched elevation profile.
 | IsCurveFromOtherElementSketch | Identifies if the given curve element is generated by another element's sketch, or if it represents an independent curve element accessible directly by the user.
 | IsCurveLoopConvexWithOpenings | Checks if the region bounded by the input curve loop can be represented as the subtraction of 0 or more convex polygons from a base convex polygon.
 | IsWallBaseRectangular | Identifies if the wall's base can be represented by a direct thickening of the wall's base curve.
 | IsWallCompletelyClipped | Determines if the input wall is completely removed by interaction with other elements within the given range.
 | IsWallJoinedToTop | Checks if wall is joined to top.
 | SetGlobal2DDirectionHandles | Sets the handles representing the cardinal directions in 2D.
 | SetGlobal2DOriginHandle | Sets the handle representing the 2D origin.
 | SetGlobal3DDirectionHandles | Sets the handles representing the cardinal directions in 3D.
 | SetGlobal3DOriginHandle | Sets the handle representing the 3D origin.
 | SortCurveLoops | Sorts a set of curve loops such that outer and inner loops are separated.
 | TransformAndScalePoint | Converts a point from global Revit coordinates to current IFC coordinates, including scale.
 | TransformAndScaleVector | Converts a vector from global Revit coordinates to current IFC coordinates, including scale.
 | UpdateBuildingPlacement | Update building local placement to be to site local placement.
 | UsesInstanceGeometry | Identifies if the family instance has its own geometry, or uses the symbol's geometry with a transform.
 | ValidateCurveLoops | Does validity checks on a list of curve loops to ensure that they are all co-planar, closed, and properly oriented.

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace

AddClippingsToBaseExtrusion Method

[image]