Revit 2013 API
Element..::..CreatedPhaseId Property
Element Class See Also Send Feedback
Id of a Phase at which the Element was created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId CreatedPhaseId { get; set; }
Visual Basic
Public Property CreatedPhaseId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ CreatedPhaseId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Remarks

After setting the property CreatedPhaseId regeneration can fail if CreatedPhaseId and DemolishedPhaseId are out of order, i.e. their index in the property Document.Phases.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The element does not allow setting the property CreatedPhaseId to the value of createdPhaseId.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The element does not have properties CreatedPhaseId and DemolishedPhaseId. -or- When setting this property: The element does not allow setting the properties CreatedPhaseId and DemolishedPhaseId.

See Also

Element Class

DemolishedPhaseId Property

[image]