Revit 2013 API
BoundarySegmentArray Methods
BoundarySegmentArray Class See Also Send Feedback

The BoundarySegmentArray type exposes the following members.

Methods

 | Name | Description
Public method | Append | Add the boundary segment to the end of the array.
Public method | Clear | Removes every boundary segment from the array, rendering it empty.
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | Insert | Insert the specified boundary segment into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.

See Also

BoundarySegmentArray Class

Append Method

[image]