Revit 2013 API
RoofTypeSet Methods
RoofTypeSet Class See Also Send Feedback

The RoofTypeSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every roof type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a roof type within the set.
Public method | Erase | Removes a specified roof type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | Insert | Insert the specified roof type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.

See Also

RoofTypeSet Class

Clear Method

[image]