Revit 2013 API
Document..::..SaveAs Method (String, SaveAsOptions)
Document Class Example See Also Send Feedback
Saves the document to a given file name with options to change the document's name in Revit and overwrite an existing file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool SaveAs(
    string fileName,
    SaveAsOptions options
)
Visual Basic
Public Function SaveAs ( _
    fileName As String, _
    options As SaveAsOptions _
) As Boolean
Visual C++
public:
bool SaveAs(
    String^ fileName,
    SaveAsOptions^ options
)

Parameters

fileName
Type: System..::..String
File name and path to be saved as. Either a relative or absolute path can be provided.
options
Type: Autodesk.Revit.DB..::..SaveAsOptions
Options which govern the SaveAs operation.

Return Value

False if save operation fails. Also returns False if saving as is cancelled by an external application during 'DocumentSavingAs' event. When function succeeds, True is returned.

Remarks

This method may not be called unless all transactions, sub-transactions, and transaction groups that were opened by the API code were closed. That also implies that this method cannot be called during dynamic updates.Event handlers are not allowed to save document that are currently in modifiable state.

Examples

CopyC#
// Get the document's preview settings
DocumentPreviewSettings settings = document.GetDocumentPreviewSettings();

// Find a candidate plan view
FilteredElementCollector collector = new FilteredElementCollector(document);
collector.OfClass(typeof(ViewPlan));

Func<ViewPlan, bool> isValidForPreview = v => settings.IsViewIdValidForPreview(v.Id);

ViewPlan viewForPreview = collector.OfType<ViewPlan>().First<ViewPlan>(isValidForPreview);

// Save the document
SaveAsOptions options = new SaveAsOptions();
options.PreviewViewId = viewForPreview.Id;

document.SaveAs(@"c:\renamed_family.rfa", options);

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown if the specified fileName is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the specified fileName is an empty string. Thrown if the specified fileName is invalid (for example, a string that contains the invalid characters). Thrown if options.PreviewViewId is invalid for generating a preview.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown if there are any transactions, sub-transactions or transaction groups which were opened by the API code, and not closed. All of these items must be handled before attempting to close the document. Thrown if overwriteExistingFile is 'false' but there is an existing file with the same fileName. Thrown if overwriteExistingFile is 'true' but the saving target file is read only.
Autodesk.Revit.Exceptions..::..ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.

See Also

Document Class
SaveAs Overload

SaveToProjectAsImage Method

[image]