Revit 2013 API
RibbonItem Members
RibbonItem Class Methods Properties See Also Send Feedback

The RibbonItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | GetContextualHelp | Gets the contextual help bound with this control.
Public method | SetContextualHelp | Sets the contextual help bound with this button.

Properties

 | Name | Description
Public property | Enabled | Gets or sets a value indicating whether the item is enabled.
Public property | ItemText | Gets or sets the text displayed on the item.
Public property | ItemType | Gets the item type.
Public property | LongDescription | Long description of the command tooltip
Public property | Name | The name of the item.
Public property | ToolTip | The description that appears as a ToolTip for the item.
Public property | ToolTipImage | The image to show as a part of the button extended tooltip
Public property | Visible | Gets or sets a value indicating whether the item is visible.

See Also

RibbonItem Class
Autodesk.Revit.UI Namespace

RibbonItem Methods

[image] [image]