Revit 2013 API
ViewFamilyType..::..IsValidDefaultTemplate Method
ViewFamilyType Class See Also Send Feedback
Verify that %templateId% can be default template for this view type: it can be invalidElementId or represent template view that is compatible with this view type

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsValidDefaultTemplate(
    ElementId templateId
)
Visual Basic
Public Function IsValidDefaultTemplate ( _
    templateId As ElementId _
) As Boolean
Visual C++
public:
bool IsValidDefaultTemplate(
    ElementId^ templateId
)

Parameters

templateId
Type: Autodesk.Revit.DB..::..ElementId
Id to be validated as default template.

Return Value

True if %templateId% is valid as default template, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ViewFamilyType Class

ViewFamilyType Properties

[image] [image]