Revit 2013 API
ApplicationEntryPoint Members
ApplicationEntryPoint Class Constructors Methods Properties Events See Also Send Feedback

The ApplicationEntryPoint type exposes the following members.

Constructors

 | Name | Description
Public method | ApplicationEntryPoint | Initializes a new instance of the ApplicationEntryPoint class

Methods

 | Name | Description
Public method | CreateAddInCommandBinding |
Public method | CreateRibbonPanel(String) |
Public method | CreateRibbonPanel(String, String) |
Public method | CreateRibbonPanel(Tab, String) |
Public method | CreateRibbonTab |
 | DoDragDrop(ICollection<(Of <<'(String>)>>)) |
 | DoDragDrop(Object, IDropHandler) |
Public method | FinishInitializationEO | For Revit Macros internal use only.
Public method | GetRibbonPanels()()()() |
Public method | GetRibbonPanels(String) |
Public method | GetRibbonPanels(Tab) |
Public method | Initialize | For Revit Macros internal use only.
Public method | OnShutdownEO | For Revit Macros internal use only.
Public method | OpenAndActivateDocument(String) |
Public method | OpenAndActivateDocument(ModelPath, OpenOptionsForUI) |
Public method | RemoveAddInCommandBinding |

Properties

 | Name | Description
Public property | ActiveAddInId |
Public property | ActiveUIDocument |
Public property | AddinFolder | The full path to the Revit Macros module.
Public property | Application | Returns the database level Application represented by this UI level Application.
Public property | DrawingAreaExtents |
Public property | LoadedApplications |
Public property | MainWindowExtents |

Events

 | Name | Description
Public event | ApplicationClosing |
Public event | DialogBoxShowing |
Public event | DisplayingOptionsDialog |
Public event | Idling |
Public event | ViewActivated |
Public event | ViewActivating |

See Also

ApplicationEntryPoint Class
Autodesk.Revit.UI.Macros Namespace

ApplicationEntryPoint Constructor

[image]