Revit 2013 API
ElementType Members
ElementType Class Methods Properties See Also Send Feedback

The ElementType type exposes the following members.

Methods

 | Name | Description
Public method | Duplicate | Duplicate this object.
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element.
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type.
Public method | IsSimilarType | Checks if given type is similar to this type.

Properties

 | Name | Description
Public property | Name | Set the name for the ElementType. (Overrides Element..::..Name.)

See Also

ElementType Class

ElementType Methods

[image] [image]