Revit 2013 API
SunAndShadowSettings..::..IsTimeIntervalValid Method
SunAndShadowSettings Class See Also Send Feedback
Checks whether the time interval is valid for the SunAndShadowType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsTimeIntervalValid(
    SunStudyTimeInterval interval
)
Visual Basic
Public Function IsTimeIntervalValid ( _
    interval As SunStudyTimeInterval _
) As Boolean
Visual C++
public:
bool IsTimeIntervalValid(
    SunStudyTimeInterval interval
)

Parameters

interval
Type: Autodesk.Revit.DB..::..SunStudyTimeInterval
Time interval value.

Return Value

True if the time interval is valid for the current SunAndShadowType, false otherwise.

See Also

SunAndShadowSettings Class

SunAndShadowSettings Properties

[image] [image]