Revit 2013 API
Application..::..NewLineBound Method
Application Class Example See Also Send Feedback
Creates a new bounded geometric line object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Line NewLineBound(
    XYZ start,
    XYZ end
)
Visual Basic
Public Function NewLineBound ( _
    start As XYZ, _
    end As XYZ _
) As Line
Visual C++
public:
Line^ NewLineBound(
    XYZ^ start,
    XYZ^ end
)

Parameters

start
Type: Autodesk.Revit.DB..::..XYZ
A start point for the line.
end
Type: Autodesk.Revit.DB..::..XYZ
An end point for the line.

Return Value

A new bounded line object.

Remarks

The new line is bounded and has the start parameter as the start point and the end parameter as the end point.

Examples

CopyC#
// define start and end for bound line
XYZ startPoint = new XYZ(0, 0, 0);
XYZ endPoint = new XYZ(10, 10, 10);

// create line
Line line = application.Create.NewLineBound(startPoint, endPoint);
CopyVB.NET
' define start and end for bound line
Dim startPoint As New Autodesk.Revit.DB.XYZ(0, 0, 0)
Dim endPoint As New Autodesk.Revit.DB.XYZ(10, 10, 10)

' create line
Dim line As Line = application.Create.NewLineBound(startPoint, endPoint)

See Also

Application Class
Autodesk.Revit.Creation Namespace

NewLineUnbound Method

[image]