Revit 2013 API
DividedSurfaceData..::..GetDividedSurfaceForReference Method
DividedSurfaceData Class See Also Send Feedback
Find the DividedSurface element that is associated with a surface of this element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DividedSurface GetDividedSurfaceForReference(
    Reference reference
)
Visual Basic
Public Function GetDividedSurfaceForReference ( _
    reference As Reference _
) As DividedSurface
Visual C++
public:
DividedSurface^ GetDividedSurfaceForReference(
    Reference^ reference
)

Parameters

reference
Type: Autodesk.Revit.DB..::..Reference

Return Value

A DividedSurface element, if there is one associated with this face; null if the reference is to a face without a DividedSurface.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when reference is not a face (surface) reference.

See Also

DividedSurfaceData Class

GetReferencesWithDividedSurfaces Method

[image]