Revit 2013 API
TemporaryViewMode Enumeration
See Also Send Feedback
Enumeration to represent the various temporary view modes a view can be in.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public enum TemporaryViewMode
Visual Basic
Public Enumeration TemporaryViewMode
Visual C++
public enum class TemporaryViewMode

Members

Member name | Description
RevealHiddenElements | The view is in reveal hidden elements mode
TemporaryHideIsolate | The view is in temporary hide/isolate mode
WorksharingDisplay | The view is in one of the worksharing display modes
AnalyticalModel | The view is in the mode that isolates the analytical model
Raytrace | The view is in the mode that shows the model in interactive raytracing

See Also

TextAlignFlags Enumeration

[image]