Revit 2013 API
Document..::..NewFamilyInstance Method (XYZ, FamilySymbol, Level, StructuralType)
Document Class Example See Also Send Feedback
Inserts a new instance of a family into the document, using a location, type/symbol and a base level.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilyInstance NewFamilyInstance(
    XYZ location,
    FamilySymbol symbol,
    Level level,
    StructuralType structuralType
)
Visual Basic
Public Function NewFamilyInstance ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    level As Level, _
    structuralType As StructuralType _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewFamilyInstance(
    XYZ^ location,
    FamilySymbol^ symbol,
    Level^ level,
    StructuralType structuralType
)

Parameters

location
Type: Autodesk.Revit.DB..::..XYZ
The physical location where the instance is to be placed.
symbol
Type: Autodesk.Revit.DB..::..FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
level
Type: Autodesk.Revit.DB..::..Level
A Level object that is used as the base level for the object.
structuralType
Type: Autodesk.Revit.DB.Structure..::..StructuralType
If structural then specify the type of the component.

Return Value

If creation was successful then an instance to the new object is returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

This method is used to add a family instance that doesn't require a host element, but that can be associated to a level. If the instance fails to be created an exception may be thrown.

The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

All levels within the document can be found by iterating over the entire document and searching for objects of type Autodesk.Revit.Elements.Level.

Some families, such as Beams, have more than one endpoint and are inserted in the same manner as single point instances. Once inserted these linear family instances can have their endpoints changed by using the instance's Element.Location property.

Note: if the created family instance includes nested instances, the API framework will automatically regenerate the document during this method call. This happens regardless of the setting for RegenerationMode.

Examples

CopyC#
FamilyInstance CreateColumn(Autodesk.Revit.DB.Document document, Level level)
{
    // Get a Column type from Revit
    FamilySymbol columnType = null;
    FilteredElementCollector collector = new FilteredElementCollector(document);
    ICollection<Element> collection = collector.OfClass(typeof(FamilySymbol)).ToElements();
    foreach (Element e in collection)
    {
        columnType = e as FamilySymbol;
        if (null != columnType && null != columnType.Category)
        {
            if ("Structural Columns" == columnType.Category.Name)
            {
                break;
            }
        }
    }

    FamilyInstance instance;
    if (null != columnType)
    {
        // Create a column at the origin
        XYZ origin = new XYZ(0, 0, 0);

        instance = document.Create.NewFamilyInstance(origin, columnType, level,
                                                      StructuralType.Column);
    }
    else
    {
        throw new Exception("No column types found.");
    }

    return instance;
}
CopyVB.NET
Function CreateColumn(ByVal document As Autodesk.Revit.DB.Document, ByVal level As Level) As Autodesk.Revit.DB.FamilyInstance
    ' Get a Column type from Revit
    Dim columnType As FamilySymbol = Nothing
    Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(document)
    Dim collection As ICollection(Of Autodesk.Revit.DB.Element) = collector.OfClass(GetType(FamilySymbol)).ToElements()
    For Each e As Autodesk.Revit.DB.Element In collection
        columnType = TryCast(e, FamilySymbol)
        If columnType IsNot Nothing AndAlso columnType.Category IsNot Nothing Then
            If "Structural Columns" = columnType.Category.Name Then
                Exit For
            End If
        End If
    Next

    Dim instance As Autodesk.Revit.DB.FamilyInstance
    If columnType IsNot Nothing Then
        ' Create a column at the origin
        Dim origin As New Autodesk.Revit.DB.XYZ(0, 0, 0)

        instance = document.Create.NewFamilyInstance(origin, columnType, level, Autodesk.Revit.DB.Structure.StructuralType.Column)
    Else
        Throw New Exception("No column types found.")
    End If

    Return instance
End Function

See Also

Document Class
NewFamilyInstance Overload
Autodesk.Revit.Creation Namespace

NewFamilyInstance Method (XYZ, FamilySymbol, Element, Level, StructuralType)

[image]