Revit 2013 API
View..::..Discipline Property
View Class See Also Send Feedback
The Discipline of the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ViewDiscipline Discipline { get; set; }
Visual Basic
Public Property Discipline As ViewDiscipline
    Get
    Set
Visual C++
public:
property ViewDiscipline Discipline {
    ViewDiscipline get ();
    void set (ViewDiscipline value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | View must have a Discipline property -or- When setting this property: View Discipline must be modifiable.

See Also

View Class

DisplayStyle Property

[image]