Revit 2013 API
Material Members
Material Class Methods Properties See Also Send Feedback

The Material type exposes the following members.

Methods

 | Name | Description
Public method | ClearMaterialAspect | Removes an aspect from the material.
 | Create | Creates a new material.
Public method | Duplicate | Duplicates the material.
Public method | GetCutPatternColor | Returns the color of the cut pattern for the material element.
Public method | GetCutPatternId | Returns the cut pattern id of the material.
Public method | GetMaterialAspectPropertySet | Obsolete. Gets the identifier of the shared property set for a given aspect.
Public method | GetSmoothness | Obsolete. Gets the smoothness value.
Public method | SetMaterialAspect | Obsolete. Set the value of an aspect of the material
Public method | SetMaterialAspectByPropertySet | Set an aspect of the material to a shared property set.
Public method | SetMaterialAspectToIndependent | Obsolete. Set an aspect of the material from a shared property set to a custom property set owned by the material.
Public method | SetSmoothness | Obsolete. Sets the smoothness value.

Properties

 | Name | Description
Public property | Color | The color of the material.
Public property | CutPattern | The cut pattern of the material.
Public property | CutPatternColor | The cut pattern color of the material.
Public property | Glow | Whether the material can glow.
Public property | MaterialClass | The name of the general material type, e.g. 'Wood.'
Public property | RenderAppearance | The rendering appearance property of the material.
Public property | Shininess | The shininess of the material.
Public property | Smoothness | The smoothness of the material.
Public property | StructuralAssetId | The ElementId of the structural PropertySetElement.
Public property | SurfacePattern | The surface pattern of the material.
Public property | SurfacePatternColor | The surface pattern color of the material.
Public property | ThermalAssetId | The ElementId of the thermal PropertySetElement.
Public property | Transparency | The transparency of the material.

See Also

Material Class

Material Methods

[image] [image]