Revit 2013 API
MEPSection Members
MEPSection Class Methods Properties See Also Send Feedback

The MEPSection type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the MEPSection
Public method | GetCoefficient | Gets the loss coefficient for the specified element id in this section.
Public method | GetElementIds | Gets all element ids that are contained in the section.
Public method | GetPressureDrop | Gets the pressure drop for the specified element id in this section.
Public method | GetSegmentLength | Get the length for the specified segment id in this section.
Public method | IsMain | Check whether the type of fitting in this section is main.

Properties

 | Name | Description
Public property | FixtureUnit | The fixture unit of the section.
Public property | Flow | The flow of the section.
Public property | Friction | The friction of the section.
Public property | FrictionFactor | The friction factor of the section.
Public property | Number | The Section number.
Public property | ReynoldsNumber | The Reynolds number of the section.
Public property | Roughness | The roughness of the section.
Public property | TotalCoefficient | The loss coefficient of the section.
Public property | TotalCurveLength | The total length of all segments in the section.
Public property | TotalPressureLoss | The total pressure loss of the section.
Public property | Velocity | The velocity of the section.
Public property | VelocityPressure | The velocity pressure of the section.

See Also

MEPSection Class
Autodesk.Revit.DB.Mechanical Namespace

MEPSection Methods

[image] [image]