Revit 2013 API
RoutingConditions..::..GetConditionAt Method
RoutingConditions Class See Also Send Feedback
Gets the routing condition at the specified index position.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public RoutingCondition GetConditionAt(
    int index
)
Visual Basic
Public Function GetConditionAt ( _
    index As Integer _
) As RoutingCondition
Visual C++
public:
RoutingCondition^ GetConditionAt(
    int index
)

Parameters

index
Type: System..::..Int32
The 0-based index to access the collection of available conditions. The method throws the exception ArgumentOutOfRangeException if the index is out of range.

Return Value

The found routing condition.

See Also

RoutingConditions Class

GetNumberOfConditions Method

[image]