Revit 2013 API
View..::..Duplicate Method
View Class See Also Send Feedback
Duplicates the view

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId Duplicate(
    ViewDuplicateOption duplicateOption
)
Visual Basic
Public Function Duplicate ( _
    duplicateOption As ViewDuplicateOption _
) As ElementId
Visual C++
public:
ElementId^ Duplicate(
    ViewDuplicateOption duplicateOption
)

Parameters

duplicateOption
Type: Autodesk.Revit.DB..::..ViewDuplicateOption

Return Value

The id of the newly created view

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | View cannot be duplicated

See Also

View Class

EnableRevealHiddenMode Method

[image]