Revit 2013 API
CurveElement Members
CurveElement Class Methods Properties See Also Send Feedback

The CurveElement type exposes the following members.

Methods

 | Name | Description
Public method | GetLineStyleIds | Retrieves the set of available line style Element Ids.

Properties

 | Name | Description
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property.
Public property | CurveElementType | The curve element type.
Public property | GeometryCurve | Geometry curve of the curve element.
Public property | LineStyle | The line style of this curve element.
Public property | LineStyles | Obsolete. All available line styles.
Public property | SketchPlane | The sketch plane the curve element lies in.

See Also

CurveElement Class

CurveElement Methods

[image] [image]