Revit 2013 API
IFCDoorWindowInfo..::..CreateWindowInfo Method
IFCDoorWindowInfo Class See Also Send Feedback
Creates a new instance of IFCDoorWindowInfo representing a window to be exported.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static IFCDoorWindowInfo CreateWindowInfo(
    ExporterIFC exporterIFC,
    FamilyInstance familyInstance,
    FamilySymbol FamilyType,
    HostObject hostObj,
    ElementId overrideLevelId,
    Transform trf
)
Visual Basic
Public Shared Function CreateWindowInfo ( _
    exporterIFC As ExporterIFC, _
    familyInstance As FamilyInstance, _
    FamilyType As FamilySymbol, _
    hostObj As HostObject, _
    overrideLevelId As ElementId, _
    trf As Transform _
) As IFCDoorWindowInfo
Visual C++
public:
static IFCDoorWindowInfo^ CreateWindowInfo(
    ExporterIFC^ exporterIFC,
    FamilyInstance^ familyInstance,
    FamilySymbol^ FamilyType,
    HostObject^ hostObj,
    ElementId^ overrideLevelId,
    Transform^ trf
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter handle.
familyInstance
Type: Autodesk.Revit.DB..::..FamilyInstance
The window instance.
FamilyType
Type: Autodesk.Revit.DB..::..FamilySymbol
The window element type.
hostObj
Type: Autodesk.Revit.DB..::..HostObject
The host for the window. Optional, if nullNothingnullptra null reference (Nothing in Visual Basic) the window will be considered unhosted in the output.
overrideLevelId
Type: Autodesk.Revit.DB..::..ElementId
Id for the level to associate to the window. If InvalidElementId, this will be obtained from the instance itself.
trf
Type: Autodesk.Revit.DB..::..Transform
Transform of the window instance.

Return Value

The new IFCDoorWindowInfo handle.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCDoorWindowInfo Class
Autodesk.Revit.DB.IFC Namespace

Dispose Method

[image]