Revit 2013 API
RebarHookType..::..GetDefaultHookLength Method
RebarHookType Class See Also Send Feedback
Computes the default hook length, which is equal to barDiameter * multiplier.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double GetDefaultHookLength(
    double barDiameter
)
Visual Basic
Public Function GetDefaultHookLength ( _
    barDiameter As Double _
) As Double
Visual C++
public:
double GetDefaultHookLength(
    double barDiameter
)

Parameters

barDiameter
Type: System..::..Double

See Also

RebarHookType Class
Autodesk.Revit.DB.Structure Namespace

GetHookExtensionLength Method

[image]