Revit 2013 API
Truss Methods
Truss Class See Also Send Feedback

The Truss type exposes the following members.

Methods

 | Name | Description
Public method | AttachChord | Attach a truss's specific chord to a specified element, the element should be a roof or floor.
Public method | DetachChord | Detach a truss's specific chord from the element to which it is attached.
 | DropTruss | Drop truss Family, it will disassociate all members from the truss and delete the truss.
Public method | GetTrussMemberInfo | Query if a given element is a member of a truss, its lock status and its usage, etc.
Public method | RemoveProfile | Remove the profile of a truss.
Public method | SetProfile | Add or modify the profile of a truss.
Public method | TogglePinMember | Pin/Unpin a truss member.

See Also

Truss Class
Autodesk.Revit.DB.Structure Namespace

AttachChord Method

[image]