Revit 2013 API
Workset Class
Members Example See Also Send Feedback
Represents a workset in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class Workset : IDisposable
Visual Basic
Public Class Workset _
    Implements IDisposable
Visual C++
public ref class Workset : IDisposable

Remarks

Worksets are a way to divide a set of elements in the Revit document into subsets for worksharing. There may be one or many worksets in a document. Each element in the document must belong to one and only one workset.

Examples

CopyC#
public Workset GetActiveWorkset(Document doc)
{
    // Get the workset table from the document
    WorksetTable worksetTable = doc.GetWorksetTable();
    // Get the Id of the active workset
    WorksetId activeId = worksetTable.GetActiveWorksetId();
    // Find the workset with that Id
    Workset workset = worksetTable.GetWorkset(activeId);
    return workset;
}

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Workset

See Also

Workset Members

Workset Members

[image] [image]