Revit 2013 API
AnalyticalLinkType..::..TranslationZ Property
AnalyticalLinkType Class See Also Send Feedback
Fixity of translation along Z.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public AnalyticalFixityState TranslationZ { get; set; }
Visual Basic
Public Property TranslationZ As AnalyticalFixityState
    Get
    Set
Visual C++
public:
property AnalyticalFixityState TranslationZ {
    AnalyticalFixityState get ();
    void set (AnalyticalFixityState value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The fixity state translationZ is not valid for Analytical Link Type parameters.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

AnalyticalLinkType Class
Autodesk.Revit.DB.Structure Namespace

AnalyticalLoopType Enumeration

[image]