Revit 2013 API
CompoundStructure..::..HasStructuralDeck Property
CompoundStructure Class See Also Send Feedback
Check if the compound structure has a structural deck.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool HasStructuralDeck { get; }
Visual Basic
Public ReadOnly Property HasStructuralDeck As Boolean
    Get
Visual C++
public:
property bool HasStructuralDeck {
    bool get ();
}

Field Value

True if IsStructuralDeck returns true for any one of the available layers.

See Also

CompoundStructure Class

IsEmpty Property

[image]