Revit 2013 API
AnalyticalModel..::..SetAnalyticalProjectionType Method (AnalyticalElementSelector, AnalyticalDirection, AnalyticalProjectionType)
AnalyticalModel Class See Also Send Feedback
Sets the analytical model projection to a preset value.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void SetAnalyticalProjectionType(
    AnalyticalElementSelector selector,
    AnalyticalDirection direction,
    AnalyticalProjectionType projectionType
)
Visual Basic
Public Sub SetAnalyticalProjectionType ( _
    selector As AnalyticalElementSelector, _
    direction As AnalyticalDirection, _
    projectionType As AnalyticalProjectionType _
)
Visual C++
public:
void SetAnalyticalProjectionType(
    AnalyticalElementSelector selector,
    AnalyticalDirection direction,
    AnalyticalProjectionType projectionType
)

Parameters

selector
Type: Autodesk.Revit.DB.Structure..::..AnalyticalElementSelector
End of the analytical model.
direction
Type: Autodesk.Revit.DB.Structure..::..AnalyticalDirection
Direction of the analytical model.
projectionType
Type: Autodesk.Revit.DB.Structure..::..AnalyticalProjectionType
Preset value for Analytical Model projection.

Remarks

This should be used if setting the analytical model projection to something other than a Datum Plane.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | direction is invalid for analytical model -or- The analytical model does not provide projectionType for the selector or direction

See Also

AnalyticalModel Class
SetAnalyticalProjectionType Overload
Autodesk.Revit.DB.Structure Namespace

SetAnalyzeAs Method

[image]