Revit 2013 API
ElementType..::..Duplicate Method
ElementType Class See Also Send Feedback
Duplicate this object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementType Duplicate(
    string name
)
Visual Basic
Public Function Duplicate ( _
    name As String _
) As ElementType
Visual C++
public:
ElementType^ Duplicate(
    String^ name
)

Parameters

name
Type: System..::..String
The new name that will be assigned to the duplicated object.

Return Value

If successful the duplicated object is returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

This method attempts to duplicate the object and assign it the specified name. In some cases the name must be unique, i.e. not already exist in the project. If the name is required to be unique and the name is not unique, a System.ArgumentException will be thrown. If for some reason the object cannot be duplicated a ApplicationException will be thrown.

See Also

ElementType Class

GetPreviewImage Method

[image]