Revit 2013 API
BuiltInFailures..::..ConnectorFailures Properties
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback

The BuiltInFailures..::..ConnectorFailures type exposes the following members.

Properties

Name | Description
AllElementsRemovedFromCircuitGroup | [System] is empty and will be deleted.
AlwaysVertical | [Family Name] - 'Always vertical' should be checked:\n [Description]
DisconnectedElements | Elements are disconnected!
DuctPipeOpositDirection | The duct/pipe has been modified to be in the opposite direction causing the connections to be invalid.
ElementAssignedToDefaultSystem | At least one connector on the highlighted element is currently assigned to the [Element Name]. In general items shouldn't be assigned to the Default Systems, but should be assigned as equipments or elements of a non-default system. Click the More Info button below for additional information on System Creation.
ElementsAreDisconnected | Elements need to be disconnected.
ElementsConnectedToParent | You have selected elements that are connected to a parent object in a System. These elements cannot be removed from the System.
ElementsNeedToBeDisconnected | Elements need to be disconnected.
ElementsNotAlignment | [Family Name] - The following Elements don't align at (0,0,0) :\n [Description]
ExistsForSelectedElement | Connections already exists for selected element.
FittingMustBeOnDuct | The [Tap] must be attached to duct.
FittingMustBeOnDuctWarn | The [Tap] must be attached to duct.
FittingMustBeOnPipe | The [Tap] must be attached to pipe.
FittingMustBeOnPipeWarn | The [Tap] must be attached to pipe.
InvalidConnectionRef | The selected fitting has invalid connections and must be deleted to continue.
InvalidConnector | The connector is invalid, the size cannot be determined from the connector.
InvalidIESParamValue | [Family Name] - The value of IES parameter is invalid:\n [Description]
InvalidPartType | [Family Name] - The part type is invalid:\n [Description]
InvalidPowerFactorValue | The value for Power Factor must be between 0 and 1.
JointGenderMismatch | The element has a connector with a fitting joint gender mismatch
JointShapeMismatch | The element has a connector with a fitting joint shape mismatch
JointSizeMismatch | The element has a connector with a fitting joint size mismatch
JointTypeMismatch | The element has a connector with a fitting joint type mismatch
LayoutConnector | [Unassigned System Type] on Connector [Index Number].
MismatchNoAvailableConnector | Cannot add [Element] to System. There is no available connector matching the System Type ([Type Name]) for the System.
NetworkValidityError | The family is connected in a network and can no longer keep the connectivity. Disconnect the family from the network?
NetworkValidityErrorWasDisconnected | The family is connected in a network and can no longer keep the connectivity. Disconnect the family from the network?
NoLossDefined | No Loss Defined
NoShapeHandle | [Family Name] - RME family should not have shape handle:\n [Description]
NotAllowedToModifyGroupElementsError | Connection to a group failed. Modification of elements within a group is not allowed.
NotAllowedToModifyGroupElementsWarning | Connection to a group failed. Modification of elements within a group is not allowed.
NotWellConnected | [Element Name] is not "Well Connected".
OpenConnector | The element has an open connector
OverConstrainParams | [Family Name] - Change following parameters will cause over constrain :\n [Description]
RbsNetworkValidityError | The family is connected in a network and can no longer keep the connectivity.
RemoveConnectorLinksWarn | The links between connector [Index] and connector [Index], connector [Index] and connector [Index] are removed.
RemoveConnectorLinkWarn | The link between connector [Index] and connector [Index] is removed.
ShapesNotMatch | Shapes do not match. A connection could not be made.
SizingCalculationFlowOnlyWarn | Some elements are not sized because the system calculation is flow only. You may change the system calculation level to size them again.
SizingCalculationNoneWarn | Some elements are not sized because the system calculation is none. You may change the system calculation level to size them again.
SizingFailed | Sizing failed.
TransitionDoesNotFitOrConnectorsMismatch | Can not place transition. The transition does not fit or the connectors mismatch.
UnconnectedCircuit | The element has an unconnected circuit on its connector
UnconnectedDevice | Device has an unconnected [Type Name] connector (index = [Index Number]).
UndefinedConnector | Revit does not support Undefined connectors. The following have been replaced by the default connector: [Connector Element]
UnLockedDimensions | [Family Name] - Dimensions should be locked or labeled:\n [Description]
WrongConnector | [Family Name] - Connector is wrong:\n [Description]
WrongConnectorDomain | [Family Name] - Connector Domain is wrong:\n [Description]
WrongConnectorLink | [Family Name] - Connector link is wrong:\n [Description]
WrongConnectorMappingParam | [Family Name] - connector mapping parameter is wrong:\n [Description]
WrongConnectorNumber | [Family Name] - The number of connector is wrong:\n [Description]
WrongConnectorParamValue | [Family Name] - connector parameter value is wrong:\n [Description]
WrongFamilyName | [Family Name] - Family name is wrong:\n [Description]
WrongPrimaryConnector | [Family Name] - Primary connector is wrong:\n [Description]
WrongPrimaryConnectorSystemType | [Family Name] - System Type of primary connector is wrong:\n [Description]

See Also

BuiltInFailures..::..ConnectorFailures Class

AllElementsRemovedFromCircuitGroup Property

[image]