Revit 2013 API
RebarShape..::..Create Method
RebarShape Class See Also Send Feedback
Create a new instance of a Rebar Shape, which defines the shape of a rebar.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static RebarShape Create(
    Document doc,
    RebarShapeDefinition definition,
    RebarShapeMultiplanarDefinition multiplanarDefinition,
    RebarStyle style,
    StirrupTieAttachmentType attachmentType,
    int startHookAngle,
    RebarHookOrientation startHookOrientation,
    int endHookAngle,
    RebarHookOrientation endHookOrientation,
    int higherEnd
)
Visual Basic
Public Shared Function Create ( _
    doc As Document, _
    definition As RebarShapeDefinition, _
    multiplanarDefinition As RebarShapeMultiplanarDefinition, _
    style As RebarStyle, _
    attachmentType As StirrupTieAttachmentType, _
    startHookAngle As Integer, _
    startHookOrientation As RebarHookOrientation, _
    endHookAngle As Integer, _
    endHookOrientation As RebarHookOrientation, _
    higherEnd As Integer _
) As RebarShape
Visual C++
public:
static RebarShape^ Create(
    Document^ doc,
    RebarShapeDefinition^ definition,
    RebarShapeMultiplanarDefinition^ multiplanarDefinition,
    RebarStyle style,
    StirrupTieAttachmentType attachmentType,
    int startHookAngle,
    RebarHookOrientation startHookOrientation,
    int endHookAngle,
    RebarHookOrientation endHookOrientation,
    int higherEnd
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
A document to contain the RebarShape.
definition
Type: Autodesk.Revit.DB.Structure..::..RebarShapeDefinition
The definition of the rebar shape, as a set of curves in a plane driven by parameters.
multiplanarDefinition
Type: Autodesk.Revit.DB.Structure..::..RebarShapeMultiplanarDefinition
If not null, the created RebarShape will be a 3D shape. The shape is built out of the planar RebarShapeDefinition, with additional out-of-plane segments defined by the RebarShapeMultiplanarDefinition object. Not supported in conjunction with RebarShapeDefinitionByArc of type Spiral or LappedCircle.
style
Type: Autodesk.Revit.DB.Structure..::..RebarStyle
Whether the shape is to be used as a standard bar or a stirrup/tie.
attachmentType
Type: Autodesk.Revit.DB.Structure..::..StirrupTieAttachmentType
When the style is stirrup/tie, specify whether it will attach to the interior of cover (cover is measured to the stirrups), or to the exterior of cover (cover is measured to the standard bars). Ignored when the style is Standard.
startHookAngle
Type: System..::..Int32
The start hook angle, expressed as an integral number of degrees. If 0, the shape will have no start hook. Common values are 0, 90, 135, and 180.
startHookOrientation
Type: Autodesk.Revit.DB.Structure..::..RebarHookOrientation
The orientation of the start hook. Ignored when startHookAngle is 0.
endHookAngle
Type: System..::..Int32
The end hook angle, expressed as an integral number of degrees. If 0, the shape will have no end hook. Common values are 0, 90, 135, and 180.
endHookOrientation
Type: Autodesk.Revit.DB.Structure..::..RebarHookOrientation
The orientation of the end hook. Ignored when endHookAngle is 0.
higherEnd
Type: System..::..Int32
When the rebar crosses itself, one end will be "lifted" to avoid self-intersection. Specify which end should be lifted: 0 for start, 1 for end.

Return Value

A new RebarShape instance.

Remarks

Replaces the method Autodesk.Revit.Creation.NewRebarShape() from prior releases.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | definition is linked to a Document other than doc. -or- A multiplanar definition is specified when the given RebarShapeDefinition does not support it. The following RebarShapeDefinitions do not support multiplanar: a simple line; spiral; lapped circle. -or- The DepthParamId property of multiplanarDefinition is invalid or has not been added to definition.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | startHookAngle must be at least 0 and no more than 180. -or- endHookAngle must be at least 0 and no more than 180. -or- higherEnd must be 0 or 1.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural.

See Also

RebarShape Class
Autodesk.Revit.DB.Structure Namespace

GetAllowed Method

[image]