Revit 2013 API
AnalyticalModel..::..IsValidDirectionForProjection Method
AnalyticalModel Class See Also Send Feedback
Indicates if the input direction is valid for Analytical Model projection.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsValidDirectionForProjection(
    AnalyticalDirection direction
)
Visual Basic
Public Function IsValidDirectionForProjection ( _
    direction As AnalyticalDirection _
) As Boolean
Visual C++
public:
bool IsValidDirectionForProjection(
    AnalyticalDirection direction
)

Parameters

direction
Type: Autodesk.Revit.DB.Structure..::..AnalyticalDirection
Direction in which the Analytical Model may be projected.

Return Value

True if AnalyticalDirection is valid for Element, false otherwise.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace

IsValidForManualAdjustment Method

[image]