Revit 2013 API
RebarHookType Properties
RebarHookType Class See Also Send Feedback

The RebarHookType type exposes the following members.

Properties

 | Name | Description
Public property | HookAngle | The hook angle, measured in radians. Must be greater than 0 and no more than pi.
Public property | StraightLineMultiplier | Multiplier of bar diameter. Used to compute a default hook length. The default hook length can be overridden by the RebarBarType class.
Public property | Style | The hook may only be applied to shapes of the specified style.

See Also

RebarHookType Class
Autodesk.Revit.DB.Structure Namespace

HookAngle Property

[image]