Revit 2013 API
UpdaterData Members
UpdaterData Class Methods See Also Send Feedback

The UpdaterData type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the UpdaterData
Public method | GetAddedElementIds | Returns set of elements newly added to the document. This set is mutually exclusive of elements returned by getDeletedElementIds() and getModifiedElementIds().
Public method | GetDeletedElementIds | Returns set of elements that were deleted from the document. This set is mutually exclusive of elements returned by getAddedElementIds() and getModifiedElementIds().
Public method | GetDocument | Returns document associated with this UpdaterData
Public method | GetModifiedElementIds | Returns set of elements that were modified. This set is mutually exclusive of elements returned by getAddedElementIds() and getDeletedElementIds().
Public method | IsChangeTriggered | Allows updater to check if specific change has happened to an element. Compares input type to the types that caused Updater::execute() to be triggered. If input type was not registered as a trigger for the associated Updater, this method will always return false for that ChangeType. For example, if the only trigger registered for UpdaterX is ChangeTypeAny for Element A, then passing in ChangeTypeGeometry will return false even if the geometry of A changed because the registered trigger was ChangeTypeAny. However, passing in ChangeTypeAny will return true.

See Also

UpdaterData Class

UpdaterData Methods

[image] [image]