Revit 2013 API
IFCPlacementSetter..::..GetOffsetLevelInfoAndHandle Method
IFCPlacementSetter Class See Also Send Feedback
Gets the level info related to an offset of the element's local placement.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IFCLevelInfo GetOffsetLevelInfoAndHandle(
    double offset,
    double scale,
    out IFCAnyHandle pPlacementHnd,
    out double pScaledOffsetFromNewLevel
)
Visual Basic
Public Function GetOffsetLevelInfoAndHandle ( _
    offset As Double, _
    scale As Double, _
    <OutAttribute> ByRef pPlacementHnd As IFCAnyHandle, _
    <OutAttribute> ByRef pScaledOffsetFromNewLevel As Double _
) As IFCLevelInfo
Visual C++
public:
IFCLevelInfo^ GetOffsetLevelInfoAndHandle(
    double offset,
    double scale,
    [OutAttribute] IFCAnyHandle^% pPlacementHnd,
    [OutAttribute] double% pScaledOffsetFromNewLevel
)

Parameters

offset
Type: System..::..Double
The vertical offset to the local placement.
scale
Type: System..::..Double
The linear scale.
pPlacementHnd
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle%
The handle to the new local placement.
pScaledOffsetFromNewLevel
Type: System..::..Double%
The scaled offset from the new level.

Return Value

The level info.

See Also

IFCPlacementSetter Class
Autodesk.Revit.DB.IFC Namespace

GetPlacement Method

[image]