Revit 2013 API
PlanTopology..::..Rooms Property
PlanTopology Class See Also Send Feedback
Retrieves rooms of the PlanTopology in the last phase.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This property is obsolete in Revit 2013.  Call GetRoomIds() instead.")]
public ElementSet Rooms { get; }
Visual Basic
<ObsoleteAttribute("This property is obsolete in Revit 2013.  Call GetRoomIds() instead.")> _
Public ReadOnly Property Rooms As ElementSet
    Get
Visual C++
[ObsoleteAttribute(L"This property is obsolete in Revit 2013.  Call GetRoomIds() instead.")]
public:
property ElementSet^ Rooms {
    ElementSet^ get ();
}

Remarks

The Rooms returned are in the phase of PlanTopology and the current design option.

See Also

PlanTopology Class

PlanTopologySet Class

[image]