Revit 2013 API
ConnectorElement..::..CreatePipeConnector Method
ConnectorElement Class See Also Send Feedback
Create a new pipe ConnectorElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static ConnectorElement CreatePipeConnector(
    Document document,
    PipeSystemType pipeSystemType,
    Reference planarFace
)
Visual Basic
Public Shared Function CreatePipeConnector ( _
    document As Document, _
    pipeSystemType As PipeSystemType, _
    planarFace As Reference _
) As ConnectorElement
Visual C++
public:
static ConnectorElement^ CreatePipeConnector(
    Document^ document,
    PipeSystemType pipeSystemType,
    Reference^ planarFace
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to add the connector to.
pipeSystemType
Type: Autodesk.Revit.DB.Plumbing..::..PipeSystemType
The PipeSystemType of the connector.
planarFace
Type: Autodesk.Revit.DB..::..Reference
The planar face to place the connector on.

Return Value

The pipe ConnectorElement.

Remarks

Regenerates the document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The reference is not a planar face. -or- document is not a family document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | Connector creation is not allowed in this family.

See Also

ConnectorElement Class

GetLinkedConnectorElement Method

[image]