Revit 2013 API
BeamSystem..::..BeamType Property
BeamSystem Class Example See Also Send Feedback
Retrieves or changes the Beam Type of the BeamSystem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilySymbol BeamType { get; set; }
Visual Basic
Public Property BeamType As FamilySymbol
    Get
    Set
Visual C++
public:
property FamilySymbol^ BeamType {
    FamilySymbol^ get ();
    void set (FamilySymbol^ value);
}

Examples

CopyC#
public void GetInfo_BeamType(BeamSystem beamSystem)
{
    string message = "BeamSystem : ";
    // Get BeamSystem type name
    message += "\nBeam type name : " + beamSystem.BeamType.Name;
    // Get BeamSystem type material
    foreach (Material material in beamSystem.BeamType.Materials)
    {
       message += "\nBeam type material : " + material.Name;
    }
    // Get BeamSystem family name
    message += "\nBeam family name : " + beamSystem.BeamType.Family.Name;

    // Rename BeamType used by this BeamSystem
    beamSystem.BeamType.Name = "TestBeamTypeName";
    // Rename the Family used by the BeamType that is used by this BeamSystem
    beamSystem.BeamType.Family.Name = "TestBeamTypeFamilyName";

    // Get BeamSystem type name
    message += "\nBeam type name after set : " + beamSystem.BeamType.Name;
    // Get BeamSystem family name
    message += "\nBeam family name after set : " + beamSystem.BeamType.Family.Name;

    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Public Sub GetInfo_BeamType(ByVal beamSystem As BeamSystem)
    Dim message As String = "BeamSystem : "
    ' Get BeamSystem type name
    message += vbLf & "Beam type name : " + beamSystem.BeamType.Name
    ' Get BeamSystem type material
    For Each material As Autodesk.Revit.DB.Material In beamSystem.BeamType.Materials
        message += vbLf & "Beam type material : " + material.Name
    Next
    ' Get BeamSystem family name
    message += vbLf & "Beam family name : " + beamSystem.BeamType.Family.Name

    ' Rename BeamType used by this BeamSystem
    beamSystem.BeamType.Name = "TestBeamTypeName"
    ' Rename the Family used by the BeamType that is used by this BeamSystem
    beamSystem.BeamType.Family.Name = "TestBeamTypeFamilyName"

    ' Get BeamSystem type name
    message += vbLf & "Beam type name after set : " + beamSystem.BeamType.Name
    ' Get BeamSystem family name
    message += vbLf & "Beam family name after set : " + beamSystem.BeamType.Family.Name

    TaskDialog.Show("Revit", message)
End Sub

See Also

BeamSystem Class

Direction Property

[image]