Revit 2013 API
AdaptiveComponentFamilyUtils Class
Members Example See Also Send Feedback
An interface for Adaptive Component Instances.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class AdaptiveComponentFamilyUtils : IDisposable
Visual Basic
Public Class AdaptiveComponentFamilyUtils _
    Implements IDisposable
Visual C++
public ref class AdaptiveComponentFamilyUtils : IDisposable

Examples

CopyC#
private void CreateAdaptiveComponentFamily(Document document)
{
    // check if this family is an Adaptive Component family
    if (!(AdaptiveComponentFamilyUtils.IsAdaptiveComponentFamily(document.OwnerFamily))) return;
    Transaction transaction = new Transaction(document); ;
    int placementCtr = 1;
    ReferencePointArray refPointArray = new ReferencePointArray();
    for (int i = 0; i < 10; i++)
    {
        transaction.SetName("Point" + i);
        transaction.Start();
        ReferencePoint referencePoint = document.FamilyCreate.NewReferencePoint(new XYZ(i, 0, 0));
        if (i % 2 == 0)
        // Even-numbered reference points will be Placement Points
        {
            AdaptiveComponentFamilyUtils.MakeAdaptivePoint(document, referencePoint.Id, AdaptivePointType.PlacementPoint);
            transaction.Commit();
            AdaptiveComponentFamilyUtils.SetPlacementNumber(document, referencePoint.Id, placementCtr);
            placementCtr++;
        }
        else
        // Odd-numbered points will be Shape Handle Points
        {
            AdaptiveComponentFamilyUtils.MakeAdaptivePoint(document, referencePoint.Id, AdaptivePointType.ShapeHandlePoint);
            transaction.Commit();
        }
        refPointArray.Append(referencePoint);
    }
    // Create a curve running through all Reference Points
    transaction.SetName("Curve");
    transaction.Start();
    CurveByPoints curve = document.FamilyCreate.NewCurveByPoints(refPointArray);
    transaction.Commit();
}

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..AdaptiveComponentFamilyUtils

See Also

AdaptiveComponentFamilyUtils Members

AdaptiveComponentFamilyUtils Members

[image] [image]