Revit 2013 API
IFCDoorWindowInfo Members
IFCDoorWindowInfo Class Methods Properties See Also Send Feedback

The IFCDoorWindowInfo type exposes the following members.

Methods

 | Name | Description
 | CreateDoorInfo | Creates a new instance of IFCDoorWindowInfo representing a door to be exported.
 | CreateWindowInfo | Creates a new instance of IFCDoorWindowInfo representing a window to be exported.
Public method | Dispose | Releases all resources used by the IFCDoorWindowInfo
Public method | GetLocalPlacement | Obtains the IfcLocalPlacement handle stored with this door/window info.
Public method | GetOpening | Obtains the handle to the IfcOpeningElement handle stored within this door/window info.
Public method | SetDelayedFamilyInstance |
Public method | SetLocalPlacement | Sets the IfcLocalPlacement handle stored with this door/window info.

Properties

 | Name | Description
Public property | AssignedLevelId | The level id assigned to this instance.
Public property | DoorOperationType | The door operation type calculated for the door instance.
Public property | HostId | The id of the host element of the door or window.
Public property | InsertId | The id of the door or window element.
Public property | IsFlippedInX | True if the door or window is flipped in the X direction, false otherwise.
Public property | IsFlippedInY | True if the door or window is flipped in the Y direction, false otherwise.
Public property | IsSymbolFlipped | True if the element type geometry for the door or window should be flipped, false otherwise.
Public property | NeedsOpening | True if the door or window should be exported related to a rectangular opening in the host wall, false otherwise.
Public property | OpeningHeight | The height of the opening.
Public property | OpeningWidth | The width of the opening.
Public property | RepresentsDoor | True if the information is related to door export, false if it related to window export.

See Also

IFCDoorWindowInfo Class
Autodesk.Revit.DB.IFC Namespace

IFCDoorWindowInfo Methods

[image] [image]