Revit 2013 API
PropertySetElement..::..Create Method (Document, MaterialAspect)
PropertySetElement Class See Also Send Feedback
Creates a new PropertySetElement initialized with default properties pertinent to the given material aspect.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2013. Use the version that takes an asset (StructuralAsset, ThermalAsset, etc.) argument instead.")]
public static PropertySetElement Create(
    Document document,
    MaterialAspect materialAspect
)
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2013. Use the version that takes an asset (StructuralAsset, ThermalAsset, etc.) argument instead.")> _
Public Shared Function Create ( _
    document As Document, _
    materialAspect As MaterialAspect _
) As PropertySetElement
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2013. Use the version that takes an asset (StructuralAsset, ThermalAsset, etc.) argument instead.")]
public:
static PropertySetElement^ Create(
    Document^ document,
    MaterialAspect materialAspect
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which to create the PropertySetElement.
materialAspect
Type: Autodesk.Revit.DB..::..MaterialAspect
The material aspect that defines the default values that will be present in the PropertySetElement.

Return Value

The new PropertySetElement.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given material aspect is not supported.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PropertySetElement Class
Create Overload

Create Method (Document, StructuralAsset)

[image]