Revit 2013 API
RenderingSettings Members
RenderingSettings Class Methods Properties See Also Send Feedback

The RenderingSettings type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the RenderingSettings
Public method | GetBackgroundSettings | Returns an object that represents the rendering background settings.
Public method | GetRenderingImageExposureSettings | Returns an object that represents the rendering image exposure settings.
Public method | GetRenderingQualitySettings | Returns an object that represents the rendering quality settings.
Public method | GetRenderingRegionOutline | Returns the outline of the rendering region.
Public method | SetBackgroundSettings | Changes the rendering background settings details for the current background style.
Public method | SetRenderingImageExposureSettings | Changes the rendering image exposure settings.
Public method | SetRenderingQualitySettings | Change rendering quality settings.

Properties

 | Name | Description
Public property | BackgroundStyle | The enum value that controls the background style for rendering.
Public property | LightingSource | The lighting scheme type.
Public property | PrinterResolution | The resolution level when using printer.
Public property | ResolutionTarget | The resolution target.
Public property | ResolutionValue | The rendering resolution in dots per inch (DPI).
Public property | UsesRegionRendering | The bool value that indicates whether to use region rendering.

See Also

RenderingSettings Class

RenderingSettings Methods

[image] [image]