Revit 2013 API
LightFamily..::..SetLightDistributionStyle Method
LightFamily Class See Also Send Feedback
Set the light distribution style to the given shape distribution

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetLightDistributionStyle(
    LightDistributionStyle lightDistributionStyle
)
Visual Basic
Public Sub SetLightDistributionStyle ( _
    lightDistributionStyle As LightDistributionStyle _
)
Visual C++
public:
void SetLightDistributionStyle(
    LightDistributionStyle lightDistributionStyle
)

Parameters

lightDistributionStyle
Type: Autodesk.Revit.DB.Lighting..::..LightDistributionStyle
The light distribution style to set the light distribution type to

See Also

LightFamily Class
Autodesk.Revit.DB.Lighting Namespace

SetLightShapeStyle Method

[image]