Revit 2013 API
ViewSheet..::..AddView Method
ViewSheet Class Example See Also Send Feedback
Places view on the sheet at the given location.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This method is obsolete in 2013. Call Viewport.Create instead.")]
public void AddView(
    View newView,
    UV location
)
Visual Basic
<ObsoleteAttribute("This method is obsolete in 2013. Call Viewport.Create instead.")> _
Public Sub AddView ( _
    newView As View, _
    location As UV _
)
Visual C++
[ObsoleteAttribute(L"This method is obsolete in 2013. Call Viewport.Create instead.")]
public:
void AddView(
    View^ newView,
    UV^ location
)

Parameters

newView
Type: Autodesk.Revit.DB..::..View
The view to be placed.
location
Type: Autodesk.Revit.DB..::..UV
Sheet coordinates (in inches) of the center of the view.

Remarks

Views cannot be added to placeholder sheets. Invalid operation exception occurs if the sheet is a placeholder sheet. Argument exception occurs if the view is of inappropriate type (e.g. ViewSheet) or the view is already placed on another sheet. The lower left corner of the sheet has coordinates [0,0]. Empty views are not placed on the sheet but no exception occurs.

Note: this method must not be called during dynamic update, otherwise ForbiddenForDynamicUpdateException will be thrown.

Examples

CopyC#
private void PlaceViewOnSheet(Document document, ViewSheet viewSheet)
{
    //Argument exception occurs if the view is of inappropriate type (e.g. ViewSheet)
    //or the view is already placed on another sheet.
    //The lower left corner of the sheet has coordinates [0,0].
    //Empty views are not placed on the sheet but no exception occurs.

    //put a view into the sheet
    //the location of the view in the view sheet
   UV viewLocation = new UV(1.5, 1.5);
    //get a view form the view list
    Autodesk.Revit.DB.View tempView = document.ActiveView;
    if (null != tempView)
    {
        viewSheet.AddView(tempView, viewLocation);
        TaskDialog.Show("Revit","Added a view to the sheet successfully.");
    }
}
CopyVB.NET
Private Sub PlaceViewOnSheet(ByVal document As Document, ByVal viewSheet As ViewSheet)
    'Argument exception occurs if the view is of inappropriate type (e.g. ViewSheet)
    'or the view is already placed on another sheet.
    'The lower left corner of the sheet has coordinates [0,0].
    'Empty views are not placed on the sheet but no exception occurs.

    'put a view into the sheet
    'the location of the view in the view sheet
    Dim viewLocation As New Autodesk.Revit.DB.UV(1.5, 1.5)
    'get a view form the view list
    Dim tempView As Autodesk.Revit.DB.View = document.ActiveView
    If tempView IsNot Nothing Then
        viewSheet.AddView(tempView, viewLocation)
        TaskDialog.Show("Revit", "nAdd a view to the viewSheet successfully.")
    End If
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.

See Also

ViewSheet Class

ConvertToRealSheet Method

[image]