Revit 2013 API
TrussTypeSet Members
TrussTypeSet Class Constructors Methods Properties See Also Send Feedback

The TrussTypeSet type exposes the following members.

Constructors

 | Name | Description
Public method | TrussTypeSet | Initializes a new instance of the TrussTypeSet class

Methods

 | Name | Description
Public method | Clear | Removes every Truss type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a Truss type within the set.
Public method | Erase | Removes a specified Truss type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | Insert | Insert the specified Truss type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | Size | Returns the number of Truss types that are in the set.

See Also

TrussTypeSet Class
Autodesk.Revit.DB.Structure Namespace

TrussTypeSet Constructor

[image]