Revit 2013 API
SpotDimensionTypeSet Members
SpotDimensionTypeSet Class Constructors Methods Properties See Also Send Feedback

The SpotDimensionTypeSet type exposes the following members.

Constructors

 | Name | Description
Public method | SpotDimensionTypeSet | Initializes a new instance of the SpotDimensionTypeSet class

Methods

 | Name | Description
Public method | Clear | Removes every spotdimension type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a spotdimension type within the set.
Public method | Erase | Removes a specified spotdimension type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | Insert | Insert the specified spotdimension type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | Size | Returns the number of spotdimension types that are in the set.

See Also

SpotDimensionTypeSet Class

SpotDimensionTypeSet Constructor

[image]