Revit 2013 API
IFCGeometryInfo..::..CreateCurveGeometryInfo Method
IFCGeometryInfo Class See Also Send Feedback
Creates a new container object which holds IfcCurve handles processed from a Revit geometry object.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static IFCGeometryInfo CreateCurveGeometryInfo(
    ExporterIFC ExporterIFC,
    Plane plane,
    XYZ projectionDir,
    bool planViewOnly
)
Visual Basic
Public Shared Function CreateCurveGeometryInfo ( _
    ExporterIFC As ExporterIFC, _
    plane As Plane, _
    projectionDir As XYZ, _
    planViewOnly As Boolean _
) As IFCGeometryInfo
Visual C++
public:
static IFCGeometryInfo^ CreateCurveGeometryInfo(
    ExporterIFC^ ExporterIFC,
    Plane^ plane,
    XYZ^ projectionDir,
    bool planViewOnly
)

Parameters

ExporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
plane
Type: Autodesk.Revit.DB..::..Plane
The plane in which the curve handles must lie.
projectionDir
Type: Autodesk.Revit.DB..::..XYZ
The normal vector to the input plane.
planViewOnly
Type: System..::..Boolean
True to match curves with plan view visibility only, false to match curves regardless of their plan view visibility.

Return Value

The new geometry info container.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCGeometryInfo Class
Autodesk.Revit.DB.IFC Namespace

CreateFaceGeometryInfo Method

[image] [image]