Revit 2013 API
ScheduleDefinition..::..FamilyId Property
ScheduleDefinition Class See Also Send Feedback
In a note block schedule, the ID of the Generic Annotation family displayed by the schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId FamilyId { get; }
Visual Basic
Public ReadOnly Property FamilyId As ElementId
    Get
Visual C++
public:
property ElementId^ FamilyId {
    ElementId^ get ();
}

Field Value

The ID of a Generic Annotation family in a Note Block schedule, InvalidElementId otherwise.

Remarks

A note block is a schedule of the Generic Annotations category that shows elements of a single family rather than all elements in the category.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

ScheduleDefinition Class

HasEmbeddedSchedule Property

[image]