Revit 2013 API
ElementStructuralTypeFilter Constructor (StructuralType)
ElementStructuralTypeFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements by structural type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ElementStructuralTypeFilter(
    StructuralType structuralType
)
Visual Basic
Public Sub New ( _
    structuralType As StructuralType _
)
Visual C++
public:
ElementStructuralTypeFilter(
    StructuralType structuralType
)

Parameters

structuralType
Type: Autodesk.Revit.DB.Structure..::..StructuralType
The structural type to match.

See Also

ElementStructuralTypeFilter Class
ElementStructuralTypeFilter Overload

ElementStructuralTypeFilter Constructor (StructuralType, Boolean)

[image]