Revit 2013 API
Document..::..NewGrid Method (Arc)
Document Class Example See Also Send Feedback
Creates a new radial grid line.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Grid NewGrid(
    Arc arc
)
Visual Basic
Public Function NewGrid ( _
    arc As Arc _
) As Grid
Visual C++
public:
Grid^ NewGrid(
    Arc^ arc
)

Parameters

arc
Type: Autodesk.Revit.DB..::..Arc
An arc object that represents the location of the new grid line.

Return Value

The newly created grid line.

Remarks

The arc should be on a horizontal plane.

Examples

CopyC#
// Create the geometry arc which the grid locates
XYZ end0 = new XYZ(0, 0, 0);
XYZ end1 = new XYZ(10, 40, 0);
XYZ pointOnCurve = new XYZ(5, 7, 0);
Arc geomArc = document.Application.Create.NewArc(end0, end1, pointOnCurve);

// Create a grid using the geometry arc
Grid arcGrid = document.Create.NewGrid(geomArc);

if (null == arcGrid)
{
    throw new Exception("Create a new curved grid failed.");
}

// Modify the name of the created grid
arcGrid.Name = "New Name2";
CopyVB.NET
' Create the geometry arc which the grid locates
Dim end0 As New Autodesk.Revit.DB.XYZ(0, 0, 0)
Dim end1 As New Autodesk.Revit.DB.XYZ(10, 40, 0)
Dim pointOnCurve As New Autodesk.Revit.DB.XYZ(5, 7, 0)
Dim geomArc As Arc = document.Application.Create.NewArc(end0, end1, pointOnCurve)

' Create a grid using the geometry arc
Dim arcGrid As Grid = document.Create.NewGrid(geomArc)

If arcGrid Is Nothing Then
    Throw New Exception("Create a new curved grid failed.")
End If

' Modify the name of the created grid
arcGrid.Name = "New Name2"

See Also

Document Class
NewGrid Overload
Autodesk.Revit.Creation Namespace

NewGrid Method (Line)

[image]