Revit 2013 API
PipeType..::..Roughness Property
PipeType Class See Also Send Feedback
The roughness of the pipe type.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This property is obsolete in Revit 2013.  Please use Segment::Roughness instead.")]
public override double Roughness { set; }
Visual Basic
<ObsoleteAttribute("This property is obsolete in Revit 2013.  Please use Segment::Roughness instead.")> _
Public Overrides WriteOnly Property Roughness As Double
    Set
Visual C++
[ObsoleteAttribute(L"This property is obsolete in Revit 2013.  Please use Segment::Roughness instead.")]
public:
virtual property double Roughness {
    void set (double value) override;
}

Remarks

set for this property will always throw an exception.

See Also

PipeType Class
Autodesk.Revit.DB.Plumbing Namespace

PipingSystem Class

[image]