Revit 2013 API
RebarShapeVertex..::..Turn Property
RebarShapeVertex Class See Also Send Feedback
The sense of the turn: 1 for a left turn, -1 for a right turn. 0 is permissible for the first and last vertex, since they do not correspond to bends. (0 is also the default, so the Turn property must be set on each internal vertex before the RebarShapeDefinitionBySegments is used.)

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public RebarShapeVertexTurn Turn { get; set; }
Visual Basic
Public Property Turn As RebarShapeVertexTurn
    Get
    Set
Visual C++
public:
property RebarShapeVertexTurn Turn {
    RebarShapeVertexTurn get ();
    void set (RebarShapeVertexTurn value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: turn must be Left or Right.

See Also

RebarShapeVertex Class
Autodesk.Revit.DB.Structure Namespace

RebarShapeVertexTurn Enumeration

[image]