Revit 2013 API
Document..::..NewSpaces Method (Phase, Int32)
Document Class See Also Send Feedback
Creates a set of new unplaced spaces on a given phase.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This method is Obsolete in Revit 2012.  Call NewSpaces2( Autodesk.Revit.DB.Phase phase, int count ) instead.")]
public ElementSet NewSpaces(
    Phase phase,
    int count
)
Visual Basic
<ObsoleteAttribute("This method is Obsolete in Revit 2012.  Call NewSpaces2( Autodesk.Revit.DB.Phase phase, int count ) instead.")> _
Public Function NewSpaces ( _
    phase As Phase, _
    count As Integer _
) As ElementSet
Visual C++
[ObsoleteAttribute(L"This method is Obsolete in Revit 2012.  Call NewSpaces2( Autodesk.Revit.DB.Phase phase, int count ) instead.")]
public:
ElementSet^ NewSpaces(
    Phase^ phase,
    int count
)

Parameters

phase
Type: Autodesk.Revit.DB..::..Phase
The phase in which the spaces are to exist.
count
Type: System..::..Int32

Return Value

If successful, a set if new unplaced spaces are be returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Document Class
NewSpaces Overload
Autodesk.Revit.Creation Namespace

NewSpaces Method (Level, Phase, View)

[image]