Revit 2013 API
FamilyThermalProperties Members
FamilyThermalProperties Class Constructors Methods Properties See Also Send Feedback

The FamilyThermalProperties type exposes the following members.

Constructors

 | Name | Description
Public method | FamilyThermalProperties | Initializes a new instance of the FamilyThermalProperties class

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the FamilyThermalProperties
 | Find | Find the thermal properties by the 'id' property of a constructionType node in Constructions.xml.

Properties

 | Name | Description
Public property | AnalyticConstructionName | The construction gbXML name. This value corresponds to the 'Name' property of a constructionType node in Constructions.xml.
Public property | AnalyticConstructionTypeId | The construction gbXML type. This value corresponds to the 'id' property of a constructionType node in Constructions.xml.
Public property | HeatTransferCoefficient | The heat transfer coefficient value (U-Value). The unit is watts per meter-squared kelvin (W/(m^2*K)).
Public property | SolarHeatGainCoefficient | The solar heat gain coefficient.
Public property | ThermalResistance | The calculated thermal resistance value (R-Value). The unit is meter-squared kelvin per watt ((m^2*K)/Watt).
Public property | VisualLightTransmittance | The visual light transmittance.

See Also

FamilyThermalProperties Class

FamilyThermalProperties Constructor

[image]