Revit 2013 API
FabricArea Members
FabricArea Class Methods Properties See Also Send Feedback

The FabricArea type exposes the following members.

Methods

 | Name | Description
Public method | CopyCurveLoopsInSketch | Creates copies of the CurveLoops in the FabricArea sketch.
 | Create | create FabricArea from an array of GCurves A document The element that will host the FabricArea. An array of curves that will define the outline of the FabricArea. This includes curves defining openings in the interior of the area. A vector to the define the major direction of the fabric distribution
Public method | GetCurveElementIds | Retrieves the identifiers of the set of curves forming the boundary of the Fabric Area.
Public method | GetFabricSheetElementIds | Retrieves the identifiers of all the FabricSheet Elements in the FabricArea.
Public method | GetTotalSheetMass | Calculated all sheet mass: Volume of Wire * Unit Weight.
Public method | GetValidViewsForTags | Gets ids of the views where tags and symbols can be placed for the FabricArea and/or FabricSheets
Public method | IsCoverOffsetValid |
Public method | IsFabricSheetType |
Public method | IsValidMajorLapSplice |
Public method | IsValidMinorLapSplice |
Public method | SetFabricLocation | Set Fabric location in the host.
Public method | SetFabricSheetTypeId | Fabric Sheet Type Id. Defines the Fabric Sheet to be hosted and replicated by this element.
Public method | SetMajorSheetAlignment | Set Major Sheet Alignment in the distribution.
Public method | SetMinorSheetAlignment | Set Minor Sheet Alignment in the distribution.

Properties

 | Name | Description
Public property | CoverOffset | Additional cover offset of the fabric distribution.
Public property | Direction | Retrieve the Major Direction of the Fabric Area.
Public property | FabricAreaType | Retrieves the type of the Fabric Area.
Public property | FabricLocation | Fabric location in the host.
Public property | FabricSheetTypeId | Fabric Sheet Type Id. Defines the Fabric Sheet to be hosted and replicated by this element.
Public property | HostId | Host element (slab, wall, etc.) Id.
Public property | LapSplicePosition | Fabric lap splice position in the fabric distribution
Public property | MajorLapSpliceLength | Fabric lap splice length in major direction in the fabric distribution.
Public property | MajorSheetAlignment | Fabric Sheet alignment in the fabric distribution
Public property | MinorLapSpliceLength | Fabric lap splice length in minor direction in the fabric distribution.
Public property | MinorSheetAlignment | Fabric Sheet alignment in the fabric distribution
Public property | SketchId | Sketch element id
Public property | TagViewId | Tag new members in view

See Also

FabricArea Class
Autodesk.Revit.DB.Structure Namespace

FabricArea Methods

[image] [image]