Revit 2013 API
Element..::..GetDividedSurfaceData Method
Element Class See Also Send Feedback
Get an interface to the divided surfaces on this element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DividedSurfaceData GetDividedSurfaceData()
Visual Basic
Public Function GetDividedSurfaceData As DividedSurfaceData
Visual C++
public:
DividedSurfaceData^ GetDividedSurfaceData()

Return Value

An object that can be used to find information about this element's divided surfaces. Divided surfaces are only supported in Conceptual Massing families; outside of that environment, this method returns nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

Divided surfaces are supported on the following element types: Form, GeomCombination, FamilyInstance, and ImportInstance.

See Also

Element Class

GetEntity Method

[image]