Revit 2013 API
ReferenceArrayArray Members
ReferenceArrayArray Class Constructors Methods Properties See Also Send Feedback

The ReferenceArrayArray type exposes the following members.

Constructors

 | Name | Description
Public method | ReferenceArrayArray | Initializes a new instance of the ReferenceArrayArray class

Methods

 | Name | Description
Public method | Append |
Public method | Clear | Removes every ReferenceArray from the array, rendering it empty.
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | Item | Gets or sets a ReferenceArray at a specified index within the array.
Public property | Size | Returns the number of ReferenceArrays that are in the array.

See Also

ReferenceArrayArray Class

ReferenceArrayArray Constructor

[image]