Revit 2013 API
PartUtils..::..AreElementsValidForDivide Method
PartUtils Class See Also Send Feedback
Identifies if provided members are valid for dividing parts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
[ObsoleteAttribute("This method will be obsolete in the next version. Use ArePartsValidForDivide instead.")]
public static bool AreElementsValidForDivide(
    Document document,
    ICollection<ElementId> elementIdsToDivide
)
Visual Basic
<ObsoleteAttribute("This method will be obsolete in the next version. Use ArePartsValidForDivide instead.")> _
Public Shared Function AreElementsValidForDivide ( _
    document As Document, _
    elementIdsToDivide As ICollection(Of ElementId) _
) As Boolean
Visual C++
[ObsoleteAttribute(L"This method will be obsolete in the next version. Use ArePartsValidForDivide instead.")]
public:
static bool AreElementsValidForDivide(
    Document^ document,
    ICollection<ElementId^>^ elementIdsToDivide
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
elementIdsToDivide
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
Element ids to be tested for validity for dividing parts.

Return Value

True if all member ids are valid, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PartUtils Class

AreElementsValidIntersectingReferences Method

[image]