Revit 2013 API
PartMaker..::..SetDividedElementIds Method
PartMaker Class See Also Send Feedback
Set the divided elements for the PartMaker.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
[ObsoleteAttribute("This method will be obsolete from the next release. Use setSourceElementIds instead.")]
public void SetDividedElementIds(
    ICollection<ElementId> dividedElementIds
)
Visual Basic
<ObsoleteAttribute("This method will be obsolete from the next release. Use setSourceElementIds instead.")> _
Public Sub SetDividedElementIds ( _
    dividedElementIds As ICollection(Of ElementId) _
)
Visual C++
[ObsoleteAttribute(L"This method will be obsolete from the next release. Use setSourceElementIds instead.")]
public:
void SetDividedElementIds(
    ICollection<ElementId^>^ dividedElementIds
)

Parameters

dividedElementIds
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
Elements to be divided.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | One or more element ids was not permitted to be a source for this PartMaker Elements should be Parts that have no PartMaker yet
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PartMaker Class

SetSourceElementIds Method

[image]