Revit 2013 API
FluidType Members
FluidType Class Methods Properties See Also Send Feedback

The FluidType type exposes the following members.

Methods

 | Name | Description
Public method | AddTemperature | Adds a fluid temperature to the set.
Public method | ClearAllTemperatures | Clears all fluid temperatures in the set.
 | Create(Document, String) | Creates a new empty fluid type and adds it to the document.
 | Create(Document, String, FluidType) | Creates a new fluid type and adds it to the document.
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetFluidTemperatureSetIterator | Returns a FluidTemperatureSetIterator that iterates through the collection.
 | GetFluidType | Gets a fluid type by name.
Public method | GetTemperature | Gets the FluidTemperature object corresponding to a given temperature value.
 | IsFluidInUse | Identifies if the fluid type is in use.
Public method | RemoveTemperature | Removes a fluid temperature via the temperature value from the set.

Properties

 | Name | Description

See Also

FluidType Class
Autodesk.Revit.DB.Plumbing Namespace

FluidType Methods

[image] [image]