Revit 2013 API
RebarHostData Members
RebarHostData Class Methods See Also Send Feedback

The RebarHostData type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the RebarHostData
Public method | GetAreaReinforcementsInHost | Returns all AreaReinforcement elements hosted by the referenced element.
Public method | GetCommonCoverType | If all exposed faces of the host have the same associated CoverType, return that CoverType; otherwise, return nullNothingnullptra null reference (Nothing in Visual Basic).
Public method | GetCoverType | Gets the CoverType associated with a face of the element.
Public method | GetExposedFaces | Returns all the exposed faces, that is, those that have an associated CoverType.
Public method | GetFabricAreasInHost | Returns all FabricArea elements hosted by the referenced element.
Public method | GetPathReinforcementsInHost | Returns all PathReinforcement elements hosted by the referenced element.
 | GetRebarHostData | Gets a RebarHostData object referring to the specified rebar host element.
Public method | GetRebarsInHost | Returns all Rebar elements hosted by the referenced element.
Public method | IsFaceExposed | Checks whether the specified face is considered exposed, and therefore has an associated CoverType.
Public method | IsValidHost | Reports whether the element is a valid rebar host.
Public method | SetCommonCoverType | Associate a single CoverType with all exposed faces of the host element.
Public method | SetCoverType | Associates the specified CoverType with the specified face of the element.

See Also

RebarHostData Class
Autodesk.Revit.DB.Structure Namespace

RebarHostData Methods

[image] [image]