Revit 2013 API
SpatialFieldManager..::..UpdateSpatialFieldPrimitive Method (Int32, FieldDomainPoints, FieldValues)
SpatialFieldManager Class See Also Send Feedback
Populates analysis results data (or replaces the existing data) in the existing primitive identified by the unique index

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2012; use the overload accepting the result index instead.")]
public void UpdateSpatialFieldPrimitive(
    int idx,
    FieldDomainPoints fieldDomainPoints,
    FieldValues fieldValues
)
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2012; use the overload accepting the result index instead.")> _
Public Sub UpdateSpatialFieldPrimitive ( _
    idx As Integer, _
    fieldDomainPoints As FieldDomainPoints, _
    fieldValues As FieldValues _
)
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2012; use the overload accepting the result index instead.")]
public:
void UpdateSpatialFieldPrimitive(
    int idx,
    FieldDomainPoints^ fieldDomainPoints,
    FieldValues^ fieldValues
)

Parameters

idx
Type: System..::..Int32
Unique index identifying the primitive
fieldDomainPoints
Type: Autodesk.Revit.DB.Analysis..::..FieldDomainPoints
Set of domain points. If %fieldDomainPoints% is nullNothingnullptra null reference (Nothing in Visual Basic) only fieldValues are updated
fieldValues
Type: Autodesk.Revit.DB.Analysis..::..FieldValues
Set of data values. Number of values in fieldValues must coincide with the number of points in fieldDomainPoints

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | idx refers to non-existent primitive -or- fieldValues has incorrect number of measurements in ValueAtPoint objects
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | fieldDomainPoints and fieldValues have inconsistent number of points
Autodesk.Revit.Exceptions..::..InvalidOperationException | Legacy method cannot be used in new multi-result environment

See Also

SpatialFieldManager Class
UpdateSpatialFieldPrimitive Overload
Autodesk.Revit.DB.Analysis Namespace

UpdateSpatialFieldPrimitive Method (Int32, FieldDomainPoints, FieldValues, Int32)

[image]