Revit 2013 API
GeometryObject..::..GraphicsStyleId Property
GeometryObject Class Example See Also Send Feedback
The ElementId of the GeometryObject's GraphicsStyle

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementId GraphicsStyleId { get; }
Visual Basic
Public ReadOnly Property GraphicsStyleId As ElementId
    Get
Visual C++
public:
property ElementId^ GraphicsStyleId {
    ElementId^ get ();
}

Remarks

This property provides the id of the GraphicsStyle assigned to the GeometryObject. This can be used to find the category of the object.

Examples

CopyC#
// find the name of the GraphicsSytleCategory for every geometric primitive in a family instance
        Options options = app.Create.NewGeometryOptions();
        GeometryElement geomElem = element.get_Geometry(options);
        foreach (GeometryObject geomObj in geomElem.Objects)
        {
            GeometryInstance geomInst = geomObj as GeometryInstance;
            if (geomInst != null)
            {
                foreach (Object obj in geomInst.SymbolGeometry.Objects)
                {
                    GeometryObject geomObject = obj as GeometryObject;
                    GraphicsStyle gStyle = doc.GetElement(geomObject.GraphicsStyleId) as GraphicsStyle;
                    if (gStyle != null)
                    {
                        string gstyleName = gStyle.GraphicsStyleCategory.Name;
                    }
                }
            }
        }

See Also

GeometryObject Class

IsElementGeometry Property

[image]