Revit 2013 API
FamilyItemFactory..::..NewDividedSurface Method
FamilyItemFactory Class Example See Also Send Feedback
Create a DividedSurface element on one surface of another element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DividedSurface NewDividedSurface(
    Reference hostReference
)
Visual Basic
Public Function NewDividedSurface ( _
    hostReference As Reference _
) As DividedSurface
Visual C++
public:
DividedSurface^ NewDividedSurface(
    Reference^ hostReference
)

Parameters

hostReference
Type: Autodesk.Revit.DB..::..Reference
Reference to a surface on an existing element. The element must be one of the following: Form, GeomCombination, FamilyInstance, or ImportInstance.

Return Value

The newly created DividedSurface element.

Examples

CopyC#
public void DivideSurface(Document document, Form form)
{
    Autodesk.Revit.ApplicationServices.Application application = document.Application;
    Options opt = application.Create.NewGeometryOptions();
    opt.ComputeReferences = true;

    Autodesk.Revit.DB.GeometryElement geomElem = form.get_Geometry(opt);
    foreach (GeometryObject geomObj in geomElem.Objects)
    {
        Solid solid = geomObj as Solid;
        foreach (Face face in solid.Faces)
        {
            if (face.Reference != null)
            {
                DividedSurface ds = document.FamilyCreate.NewDividedSurface(face.Reference);
                // create a divided surface with fixed number of U and V grid lines
                SpacingRule srU = ds.USpacingRule;
                srU.SetLayoutFixedNumber(16, SpacingRuleJustification.Center, 0, 0);

                SpacingRule srV = ds.VSpacingRule;
                srV.SetLayoutFixedNumber(24, SpacingRuleJustification.Center, 0, 0);

                break;  // just divide one face of form
            }
        }
    }
}
CopyVB.NET
Public Sub DivideSurface(ByVal document As Document, ByVal form As Form)
    Dim application As Autodesk.Revit.ApplicationServices.Application = document.Application
    Dim opt As Autodesk.Revit.DB.Options = application.Create.NewGeometryOptions()
    opt.ComputeReferences = True

    Dim geomElem As Autodesk.Revit.DB.GeometryElement = form.Geometry(opt)
    For Each geomObj As GeometryObject In geomElem.Objects
        Dim solid As Solid = TryCast(geomObj, Solid)
        For Each face As Autodesk.Revit.DB.Face In solid.Faces
            If face.Reference IsNot Nothing Then
                Dim ds As DividedSurface = document.FamilyCreate.NewDividedSurface(face.Reference)
                ' create a divided surface with fixed number of U and V grid lines
                Dim srU As SpacingRule = ds.USpacingRule
                srU.SetLayoutFixedNumber(16, SpacingRuleJustification.Center, 0, 0)

                Dim srV As SpacingRule = ds.VSpacingRule
                srV.SetLayoutFixedNumber(24, SpacingRuleJustification.Center, 0, 0)

                ' just divide one face of form
                Exit For
            End If
        Next
    Next
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when surface is not a reference to a surface, or when the referenced element does not support divided surfaces.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace

NewDuctConnector Method

[image]