Revit 2013 API
FamilyInstance Members
FamilyInstance Class Methods Properties See Also Send Feedback

The FamilyInstance type exposes the following members.

Methods

 | Name | Description
Public method | AddCoping | Adds a coping (cut) to a steel beam.
Public method | flipFacing | The orientation of family instance facing will be flipped. If it can not be flipped, return false, otherwise return true.
Public method | FlipFromToRoom | Flips the settings of "From Room" and "To Room" for the door or window instance.
Public method | flipHand | The orientation of family instance hand will be flipped. If it can not be flipped, return false, otherwise return true.
Public method | GetCopingIds | Lists the elements currently used as coping cutters for this element.
Public method | GetCopings | Obsolete. Lists the elements currently used as coping cutters for this element.
Public method | GetFamilyPointPlacementReferences | Returns the Point Placement References for the Family Instance.
Public method | GetOriginalGeometry | Returns the original geometry of the instance, before the instance is modified by joins, cuts, coping, extensions, or other post-processing.
Public method | GetSubComponentIds | Gets the sub component ElementIds of the current family instance.
Public method | RemoveCoping | Removes a coping (cut) from a steel beam.
Public method | rotate | The family instance will be flipped by 180 degrees. If it can not be rotated, return false, otherwise return true.
Public method | SetCopingIds | Specifies the set of coping cutters on this element.
Public method | SetCopings | Obsolete. Specify the set of coping cutters on this element.

Properties

 | Name | Description
Public property | CanFlipFacing | Property to test whether the orientation of family instance facing can be flipped.
Public property | CanFlipHand | Property to test whether the orientation of family instance hand can be flipped.
Public property | CanFlipWorkPlane | Identifies if the instance can flip its work plane.
Public property | CanRotate | Property to test whether the family instance can be rotated by 180 degrees.
Public property | ExtensionUtility | Property to check whether the instance can be extended and return the interface for extension operation.
Public property | FacingFlipped | Property to test whether the orientation of family instance facing is flipped.
Public property | FacingOrientation | Property to get the orientation of family instance facing.
Public property | FromRoom | The "From Room" set for the door or window in the last phase of the project.
Public property | FromRoom[([( Phase])]) |
Public property | HandFlipped | Property to test whether the orientation of family instance hand is flipped.
Public property | HandOrientation | Property to get the orientation of family instance hand.
Public property | Host | If the instance is contained within another element, this property returns the containing element. An instance that is face hosted will return the element containing the face.
Public property | HostFace | Property to get the reference to the host face of family instance.
Public property | Invisible | Property to test whether the family instance is invisible.
Public property | IsSlantedColumn | Indicates if the family instance is a slanted column.
Public property | IsWorkPlaneFlipped | Identifies if the instance's work plane is flipped.
Public property | Location | This property is used to find the physical location of an instance within project. (Overrides Element..::..Location.)
Public property | MEPModel | Retrieves the MEP model for the family instance.
Public property | Mirrored | Property to test whether the family instance is mirrored. (only one axis is flipped)
Public property | Room | The room in which the instance is located (during the last phase of the project).
Public property | Room[([( Phase])]) |
Public property | Space | The space in which the instance is located (during the last phase of the project).
Public property | Space[([( Phase])]) |
Public property | StructuralMaterialId | Identifies the material that defines the instance's structural analysis properties.
Public property | StructuralMaterialType | This property returns the physical material from which the instance is made.
Public property | StructuralType | Provides the primary structural type of the instance, such as beam or column etc.
Public property | StructuralUsage | Provides the primary structural usage of the instance, such as brace, girder etc.
Public property | SubComponents | Obsolete. Property to get the sub components of current family instance.
Public property | SuperComponent | Property to get the super component of current family instance.
Public property | Symbol | Returns or changes the FamilySymbol object that represents the type of the instance.
Public property | ToRoom | The "To Room" set for the door or window in the last phase of the project.
Public property | ToRoom[([( Phase])]) |

See Also

FamilyInstance Class

FamilyInstance Methods

[image] [image]