Revit 2013 API
Selection Class
Members Example See Also Send Feedback
Contains the current user selection of elements within the project.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public class Selection : APIObject
Visual Basic
Public Class Selection _
    Inherits APIObject
Visual C++
public ref class Selection : public APIObject

Remarks

The Selection object is used to retrieve the current user selected elements when an external API command is executed.

Examples

CopyC#
[Autodesk.Revit.Attributes.Transaction(TransactionMode.ReadOnly)]
[Autodesk.Revit.Attributes.Regeneration(RegenerationOption.Manual)]
public class Document_Selection : IExternalCommand
{
    public Autodesk.Revit.UI.Result Execute(ExternalCommandData commandData,
        ref string message, ElementSet elements)
    {
        try
        {
            // Select some elements in Revit before invoking this command

            // Get the handle of current document.
            UIDocument uidoc = commandData.Application.ActiveUIDocument;

            // Get the element selection of current document.
            Selection selection = uidoc.Selection;
            ElementSet collection = selection.Elements;

            if (0 == collection.Size)
            {
                // If no elements selected.
                TaskDialog.Show("Revit","You haven't selected any elements.");
            }
            else
            {
                String info = "Ids of selected elements in the document are: ";
                foreach (Element elem in collection)
                {
                   info += "\n\t" + elem.Id.IntegerValue;
                }

                TaskDialog.Show("Revit",info);
            }
        }
        catch (Exception e)
        {
            message = e.Message;
            return Autodesk.Revit.UI.Result.Failed;
        }

        return Autodesk.Revit.UI.Result.Succeeded;
    }
    /// </ExampleMethod>
}
CopyVB.NET
<Autodesk.Revit.Attributes.Transaction(TransactionMode.[ReadOnly])> _
<Autodesk.Revit.Attributes.Regeneration(RegenerationOption.Manual)> _
Public Class Document_Selection
    Implements IExternalCommand
    Public Function Execute(ByVal commandData As ExternalCommandData, ByRef message As String, ByVal elements As ElementSet) As Autodesk.Revit.UI.Result Implements IExternalCommand.Execute
        Try
            ' Select some elements in Revit before invoking this command

            ' Get the handle of current document.
            Dim uidoc As UIDocument = commandData.Application.ActiveUIDocument

            ' Get the element selection of current document.
            Dim selection As Autodesk.Revit.UI.Selection.Selection = uidoc.Selection
            Dim collection As ElementSet = selection.Elements

            If 0 = collection.Size Then
                ' If no elements selected.
                TaskDialog.Show("Revit", "You haven't selected any elements.")
            Else
                Dim info As [String] = "Ids of selected elements in the document are: "
                For Each elem As Autodesk.Revit.DB.Element In collection
                    info += vbLf & vbTab + elem.Id.IntegerValue
                Next

                TaskDialog.Show("Revit", info)
            End If
        Catch e As Exception
            message = e.Message
            Return Autodesk.Revit.UI.Result.Failed
        End Try

        Return Autodesk.Revit.UI.Result.Succeeded
    End Function
    ' </ExampleMethod>
End Class

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.UI.Selection..::..Selection

See Also

Selection Members
Autodesk.Revit.UI.Selection Namespace

Selection Members

[image] [image]