Revit 2013 API
DimensionSegment Members
DimensionSegment Class Methods Properties See Also Send Feedback

The DimensionSegment type exposes the following members.

Methods

 | Name | Description

Properties

 | Name | Description
Public property | Above | The text shown above the segment's value.
Public property | Below | The text shown below the segment's value.
Public property | IsLocked | Indicates if this segment is locked.
Public property | Origin | The segment origin.
Public property | Prefix | The text shown before the segment's value.
Public property | Suffix | The text shown after the segment's value.
Public property | Value | The length of the segment.
Public property | ValueOverride | The text that replaces the segment's value.
Public property | ValueString | The displayed value shown for the dimension segment.

See Also

DimensionSegment Class

DimensionSegment Methods

[image] [image]