Revit 2013 API
StringStringMapIterator..::..Current Property
StringStringMapIterator Class See Also Send Feedback
Retrieves the string item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

StringStringMapIterator Class
Autodesk.Revit.Collections Namespace

Key Property

[image]