Revit 2013 API
Rebar..::..ScaleToBoxFor3D Method
Rebar Class See Also Send Feedback
Move and resize a spiral or multiplanar instance to fit within a specified box. The arguments are interpreted as an arbitrary rectangle in 3D with vertices: origin, origin+xVec, origin+xVec+yVec, origin+yVec. One end of the rebar shape is inscribed in this rectangle. The other end is placed in the parallel plane at distance given by the height argument, in the direction of xVec cross yVec. This method replaces ScaleToBoxForSpiral() from prior releases.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void ScaleToBoxFor3D(
    XYZ origin,
    XYZ xVec,
    XYZ yVec,
    double height
)
Visual Basic
Public Sub ScaleToBoxFor3D ( _
    origin As XYZ, _
    xVec As XYZ, _
    yVec As XYZ, _
    height As Double _
)
Visual C++
public:
void ScaleToBoxFor3D(
    XYZ^ origin,
    XYZ^ xVec,
    XYZ^ yVec,
    double height
)

Parameters

origin
Type: Autodesk.Revit.DB..::..XYZ
One corner of the rectangle.
xVec
Type: Autodesk.Revit.DB..::..XYZ
Vector representing the first edge of the rectangle. The length must be positive.
yVec
Type: Autodesk.Revit.DB..::..XYZ
Vector representing the second edge of the rectangle. Must be perpendicular to xVec.
height
Type: System..::..Double
New value for the Height or MultiplanarDepth property.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | xVec has zero length. -or- yVec has zero length.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural.
Autodesk.Revit.Exceptions..::..InvalidOperationException | This Rebar is not an instance of a spiral or multiplanar shape. -or- The operation has failed for geometric reasons, such as the box being too small given the bar diameter.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace

SetHookTypeId Method

[image]