Revit 2013 API
WorksharingUtils Class
Members Example See Also Send Feedback
A static class that contains utility functions related to worksharing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class WorksharingUtils : IDisposable
Visual Basic
Public Class WorksharingUtils _
    Implements IDisposable
Visual C++
public ref class WorksharingUtils : IDisposable

Examples

CopyC#
public void GetElementWorksharingInfo(Document doc, ElementId elemId)
{
    String message = String.Empty;
    message += "Element Id: " + elemId;

    Element elem = doc.GetElement(elemId);
    if(null == elem)
    {
       message += "Element does not exist";
       return;
    }

    // The workset the element belongs to
    WorksetId worksetId = elem.WorksetId;
    message += ("\nWorkset Id : " + worksetId.ToString());

    // Model Updates Status of the element
    ModelUpdatesStatus updateStatus = WorksharingUtils.GetModelUpdatesStatus(doc, elemId);
    message += ("\nUpdate status : " + updateStatus.ToString());

    // Checkout Status of the element
    CheckoutStatus checkoutStatus = WorksharingUtils.GetCheckoutStatus(doc, elemId);
    message += ("\nCheckout status : " + checkoutStatus.ToString());

    // Getting WorksharingTooltipInfo of a given element Id
    WorksharingTooltipInfo tooltipInfo = WorksharingUtils.GetWorksharingTooltipInfo(doc, elemId);
    message += ("\nCreator : " + tooltipInfo.Creator);
    message += ("\nCurrent Owner : " + tooltipInfo.Owner);
    message += ("\nLast Changed by : " + tooltipInfo.LastChangedBy);

    Autodesk.Revit.UI.TaskDialog.Show("GetElementWorksharingInfo", message);
}

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..WorksharingUtils

See Also

WorksharingUtils Members

WorksharingUtils Members

[image] [image]