Revit 2013 API
CompoundStructure..::..SplitRegion Method (UV, RectangularGridSegmentOrientation)
CompoundStructure Class See Also Send Feedback
Splits the region which contains the specified grid point by a line with the specified direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int SplitRegion(
    UV gridUV,
    RectangularGridSegmentOrientation splitDirection
)
Visual Basic
Public Function SplitRegion ( _
    gridUV As UV, _
    splitDirection As RectangularGridSegmentOrientation _
) As Integer
Visual C++
public:
int SplitRegion(
    UV^ gridUV,
    RectangularGridSegmentOrientation splitDirection
)

Parameters

gridUV
Type: Autodesk.Revit.DB..::..UV
Coordinates of a point in the rectangular grid of this compound structure.
splitDirection
Type: Autodesk.Revit.DB..::..RectangularGridSegmentOrientation
Specifies the direction of the split.

Return Value

The id of the region created by this operation.

Remarks

This method is meant to be used in conjunction with FindEnclosingRegionAndSegments(). Grid coordinates correspond to uv coordinates of faces.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is valid only vertically compound structures.

See Also

CompoundStructure Class
SplitRegion Overload

SplitRegion Method (UV, RectangularGridSegmentOrientation, Int32)

[image]