Revit 2013 API
PathReinforcement Members
PathReinforcement Class Methods Properties See Also Send Feedback

The PathReinforcement type exposes the following members.

Methods

 | Name | Description
Public method | GetCurveElementIds | Retrieves the set of ElementIds of curves forming the boundary of the Path Reinforcement.
Public method | GetRebarInSystemIds | Returns the ids of the RebarInSystem elements owned by the PathReinforcement element.
 | RemovePathReinforcementSystem | Deletes the specified PathReinforcement, and converts its RebarInSystem elements to equivalent Rebar elements.

Properties

 | Name | Description
Public property | BarDescription | Obsolete. Retrieves the BarDescription property of an Path Reinforcement element.
Public property | Curves | Obsolete. Retrieves the array of curves forming the boundary of the Path Reinforcement.
Public property | NumBarDescriptions | Retrieves the number of distinct bar shapes. This property is deprecated in Revit 2013. Use GetRebarInSystemIds instead.
Public property | PathReinforcementType | Retrieves the type of the Path Reinforcement.

See Also

PathReinforcement Class
Autodesk.Revit.DB.Structure Namespace

PathReinforcement Methods

[image] [image]