Revit 2013 API
TextNote..::..AddLeader Method
TextNote Class See Also Send Feedback
Add a leader for the current TextNote object and return the new leader.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Leader AddLeader(
    TextNoteLeaderTypes
)
Visual Basic
Public Function AddLeader ( _
     As TextNoteLeaderTypes _
) As Leader
Visual C++
public:
Leader^ AddLeader(
    TextNoteLeaderTypes
)

Parameters

Type: Autodesk.Revit.DB..::..TextNoteLeaderTypes

Remarks

If the current leader type is not same with the input type, Autodesk::Revit::Exceptions::InvalidOperationException will be thrown.

See Also

TextNote Class

RemoveLeaders Method

[image]