Revit 2013 API
View Methods
View Class See Also Send Feedback

The View type exposes the following members.

Methods

 | Name | Description
Public method | ApplyTemplate | Obsolete. Applies a view template to the view.
Public method | ApplyViewTemplateParameters | Applies to this view the parameters of %otherView% that are not controlled by the current view template. To get all template parameters call template's method getTemplateParameterIds. To get parameters that are not controlled by the template call template's method getNonControlledTemplateParameterIds. To get current view template use property ViewTemplateId.
Public method | CanCategoryBeHiddenTemporary | Check if category can be temporarily hidden in the view.
Public method | CanModifyDetailLevel | Check if Detail Level can be modified.
Public method | CanModifyDisplayStyle | Indicates if DisplayStyle can be modified.
Public method | CanModifyViewDiscipline | Indicates if the View Discipline can be modified
Public method | CanUseTemporaryVisibilityModes | Indicates if view can use temporary visibility modes
Public method | CanViewBeDuplicated | Checks if the view can be duplicated
Public method | ConvertTemporaryHideIsolateToPermanent | Convert all temporary hidden elements or categories to permanently hidden in view.
Public method | DisableTemporaryViewMode | Disables the specified temporary view mode.
Public method | Duplicate | Duplicates the view
Public method | EnableRevealHiddenMode | Enables Reveal Hidden elements mode.
Public method | EnableTemporaryAnalyticalDisplayMode | Enables temporary display of Analytical Model categories only.
Public method | GetDependentViewIds | Get the ids of dependent views.
Public method | GetNonControlledTemplateParameterIds | Returns list of parameters that will NOT be controlled when this view is used as a template. This is a subset of the parameters returned by getTemplateParameterIds.
Public method | GetPrimaryViewId | Get the id of the primary view.
Public method | GetTemplateParameterIds | Returns list of parameters that may be controlled when this view is used as a template.
Public method | getVisibility | Checks if elements of the given category are set to be visible in this view.
Public method | GetWorksetVisibility | Returns the visibility settings of a workset for this particular view.
Public method | GetWorksharingDisplayMode | Gets the current worksharing display mode for this view.
Public method | HasDetailLevel | Check if the view has a Detail Level property
Public method | HasDisplayStyle | Indicates if view has a DisplayStyle property
Public method | HasViewDiscipline | Indicates if the view has a Discipline property
Public method | Hide | Obsolete. Sets the elements to be hidden in the view.
Public method | HideActiveWorkPlane | Hide the active work plane of the view.
Public method | HideCategoriesTemporary | Set multiple categories to be temporarily hidden in the view.
Public method | HideCategoryTemporary | Set one category to be temporarily hidden in the view.
Public method | HideElements | Sets the elements to be hidden in the view.
Public method | HideElementsTemporary | Set multiple elements to be temporarily hidden in the view.
Public method | HideElementTemporary | Set one element to be temporarily hidden in the view.
Public method | IsElementVisibleInTemporaryViewMode | Identifies if the input element is visible for the temporary view mode for this view.
Public method | IsInTemporaryViewMode | Returns true if the view is in a particular temporary view mode.
Public method | IsolateCategoriesTemporary | Set categories to be temporarily isolated in the view.
Public method | IsolateCategoryTemporary | Set one category to be temporarily isolated in the view.
Public method | IsolateElementsTemporary | Set multiple elements to be temporarily isolated in the view.
Public method | IsolateElementTemporary | Set one element to be temporarily isolated in the view.
Public method | IsTemporaryAnalyticalModeActive | Indicates if the view is temporarily displaying only the Analytical model.
Public method | IsTemporaryHideIsolateActive | Indicates if the view is temporarily hiding or isolating elements or categories.
 | IsValidViewScale | This validator checks that the view scale is in the allowable range.
Public method | IsValidViewTemplate | Verify that %templateId% can be view template for this view: it can be invalidElementId or represent template view that is compatible with this view
Public method | IsWorksetVisible | Indicates whether the workset is visible in this view.
Public method | Print()()()() | Print this view with the default view template and using the print setting of the current active document.
Public method | Print(Boolean) | Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document.
Public method | Print(View) | Print this view with the given view template and using the print setting of the current active document.
Public method | Print(View, Boolean) | Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document.
Public method | SetNonControlledTemplateParameterIds | Set the parameters that will NOT be applied when this view is used as a template. This should be a subset of the parameters returned by getTemplateParameterIds (other parameters will be ignored).
Public method | setVisibility | Set if elements of the given category will be visible in this view.
Public method | SetWorksetVisibility | Sets visibility for a workset in this view.
Public method | SetWorksharingDisplayMode | Sets the worksharing display mode for this view.
Public method | ShowActiveWorkPlane | Show the active work plane of the view.
Public method | SupportsWorksharingDisplayMode | Checks whether this view supports the given worksharing display mode.
Public method | Unhide | Obsolete. Sets the elements to be shown in the given view if they are currently hidden.
Public method | UnhideElements | Sets the elements to be shown in the given view if they are currently hidden.

See Also

View Class

ApplyTemplate Method

[image]