Revit 2013 API
AssemblyInstance..::..CompareAssemblyInstances Method
AssemblyInstance Class Example See Also Send Feedback
Compares two assembly instances and returns a result with details about the differences

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static AssemblyDifference CompareAssemblyInstances(
    AssemblyInstance instance1,
    AssemblyInstance instance2
)
Visual Basic
Public Shared Function CompareAssemblyInstances ( _
    instance1 As AssemblyInstance, _
    instance2 As AssemblyInstance _
) As AssemblyDifference
Visual C++
public:
static AssemblyDifference^ CompareAssemblyInstances(
    AssemblyInstance^ instance1,
    AssemblyInstance^ instance2
)

Parameters

instance1
Type: Autodesk.Revit.DB..::..AssemblyInstance
The first assembly instance to compare
instance2
Type: Autodesk.Revit.DB..::..AssemblyInstance
the second assembly instance to compare

Return Value

An object describing the difference between the two instances

Remarks

Only the first found difference is returned. If the instances are identical, AssemblyDifferenceNone will be returned.

Examples

CopyC#
// Identify the difference, if any, between two assembly instances
void FindAssemblyDifferences(AssemblyInstance instance1, AssemblyInstance instance2)
{
    Autodesk.Revit.DB.Document doc = instance1.Document;
        AssemblyDifference difference = AssemblyInstance.CompareAssemblyInstances(instance1, instance2);

        AssemblyDifferenceNone diffNone = difference as AssemblyDifferenceNone;
        if (diffNone != null)
        {
            TaskDialog.Show("Revit", "Assemblies are identical");
            return;
        }

        AssemblyDifferenceConfiguration diffConfig = difference as AssemblyDifferenceConfiguration;
        if (diffConfig != null)
        {
            TaskDialog.Show("Revit", "Elements are not arranged in space relative to each other in the same way");
            return;
        }

        AssemblyDifferenceMemberCount diffMemberCount = difference as AssemblyDifferenceMemberCount;
        if (diffMemberCount != null)
        {
            TaskDialog.Show("Revit", "Elements counts differ: " + diffMemberCount.Count1 + " & " + diffMemberCount.Count2);
            return;
        }

        AssemblyDifferenceNamingCategory diffNameCat = difference as AssemblyDifferenceNamingCategory;
        if (diffNameCat != null)
        {
            int catInt1 = diffNameCat.NamingCategoryId1.IntegerValue;
            int catInt2 = diffNameCat.NamingCategoryId2.IntegerValue;
            TaskDialog.Show("Revit", "Naming categories differ: " +
                doc.Settings.Categories.get_Item((BuiltInCategory)catInt1).Name + " & " +
                doc.Settings.Categories.get_Item((BuiltInCategory)catInt2).Name);
            return;
        }

        AssemblyDifferenceMemberDifference memberDifference = difference as AssemblyDifferenceMemberDifference;
        if (memberDifference != null)
        {
            AssemblyMemberDifference assemblyMemberDifference = memberDifference.MemberDifference as AssemblyMemberDifference;

            AssemblyMemberDifferentCategory differentCategory = assemblyMemberDifference as AssemblyMemberDifferentCategory;
            if (differentCategory != null)
            {
                int int1 = differentCategory.CategoryId1.IntegerValue;
                int int2 = differentCategory.CategoryId2.IntegerValue;
                TaskDialog.Show("Revit", "Element categories differ: " +
                    doc.Settings.Categories.get_Item((BuiltInCategory)int1).Name + " & " +
                    doc.Settings.Categories.get_Item((BuiltInCategory)int2).Name);
                return;
            }
            AssemblyMemberDifferentGeometry differentGeometry = assemblyMemberDifference as AssemblyMemberDifferentGeometry;
            if (differentGeometry != null)
            {
                TaskDialog.Show("Revit", "Member geometry differs");
                return;
            }
            AssemblyMemberDifferentParameters differentParameters = assemblyMemberDifference as AssemblyMemberDifferentParameters;
            if (differentParameters != null)
            {
                TaskDialog.Show("Revit", "Member parameters differs");
                return;
            }
            AssemblyMemberDifferentType differentType = assemblyMemberDifference as AssemblyMemberDifferentType;
            if (differentType != null)
            {
                TaskDialog.Show("Revit", "Element types differ: " + doc.GetElement(differentType.TypeId1).Name + " & " + doc.GetElement(differentType.TypeId2).Name);
                return;
            }
        }
        return;
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AssemblyInstance Class

Create Method

[image]