Revit 2013 API
MechanicalUtils..::..ConnectDuctPlaceholdersAtTee Method (Document, Connector, Connector, Connector)
MechanicalUtils Class See Also Send Feedback
Connects three placeholders that looks like Tee connection.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static bool ConnectDuctPlaceholdersAtTee(
    Document document,
    Connector connector1,
    Connector connector2,
    Connector connector3
)
Visual Basic
Public Shared Function ConnectDuctPlaceholdersAtTee ( _
    document As Document, _
    connector1 As Connector, _
    connector2 As Connector, _
    connector3 As Connector _
) As Boolean
Visual C++
public:
static bool ConnectDuctPlaceholdersAtTee(
    Document^ document,
    Connector^ connector1,
    Connector^ connector2,
    Connector^ connector3
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
connector1
Type: Autodesk.Revit.DB..::..Connector
The first end connector of placeholder to be connected to the second.
connector2
Type: Autodesk.Revit.DB..::..Connector
The second end connector of placeholder to be connected to the first.
connector3
Type: Autodesk.Revit.DB..::..Connector
The third end connector of placeholder to be connected to the first or second.

Return Value

True if connection succeeds, false otherwise.

Remarks

The three placeholders may or may not have physically connections. However, the first one should be collinear with the second and third one must have intersection with first and second. If first placeholder and second placeholder have the same size, the second one is merged with first one and original placeholder element will be invalid. If connection fails, the placeholders cannot be physically connected.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The owner of connector is not duct placeholder. -or- The owners of connectors belong to different types of system. -or- The curves of connector1 and connector2 are not collinear or either the connecto1 or connector2 is not connector of curve end.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

MechanicalUtils Class
ConnectDuctPlaceholdersAtTee Overload
Autodesk.Revit.DB.Mechanical Namespace

ConvertDuctPlaceholders Method

[image]