Revit 2013 API
AnalyticalModel..::..IsValidRigidLinksOption Method
AnalyticalModel Class See Also Send Feedback
Indicates if Rigid Links option is valid for the Analytical Model.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsValidRigidLinksOption(
    AnalyticalRigidLinksOption rigidLinksOption
)
Visual Basic
Public Function IsValidRigidLinksOption ( _
    rigidLinksOption As AnalyticalRigidLinksOption _
) As Boolean
Visual C++
public:
bool IsValidRigidLinksOption(
    AnalyticalRigidLinksOption rigidLinksOption
)

Parameters

rigidLinksOption
Type: Autodesk.Revit.DB.Structure..::..AnalyticalRigidLinksOption
Rigid Links option to validate.

Return Value

True if option is valid, false otherwise.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace

IsValidSelector Method

[image]