Revit 2013 API
Document..::..NewTruss Method
Document Class Example See Also Send Feedback
Creates a New Truss.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Truss NewTruss(
    TrussType trussType,
    SketchPlane sketchPlane,
    Curve baseCurve
)
Visual Basic
Public Function NewTruss ( _
    trussType As TrussType, _
    sketchPlane As SketchPlane, _
    baseCurve As Curve _
) As Truss
Visual C++
public:
Truss^ NewTruss(
    TrussType^ trussType,
    SketchPlane^ sketchPlane,
    Curve^ baseCurve
)

Parameters

trussType
Type: Autodesk.Revit.DB.Structure..::..TrussType
The type for truss.
sketchPlane
Type: Autodesk.Revit.DB..::..SketchPlane
The sketch plane where the truss is going to reside. It could be nullNothingnullptra null reference (Nothing in Visual Basic).
baseCurve
Type: Autodesk.Revit.DB..::..Curve
The curve that represents truss's base curve. It must be a line, must not be a vertical line, and must be within the sketch plane if sketchPlane is valid.

Examples

CopyC#
Truss CreateTruss(Autodesk.Revit.DB.Document document,
    FamilyInstance column1, FamilyInstance column2)
{
    Truss truss = null;
    Transaction transaction = new Transaction(document, "Add Truss");
    if (transaction.Start() == TransactionStatus.Started)
    {
        //sketchPlane
        XYZ origin = new XYZ(0, 0, 0);
        XYZ xDirection = new XYZ(1, 0, 0);
        XYZ yDirection = new XYZ(0, 1, 0);
        Plane plane = document.Application.Create.NewPlane(xDirection, yDirection, origin);
        SketchPlane sketchPlane = document.Create.NewSketchPlane(plane);

        //new base Line - use line that spans two selected columns
        AnalyticalModel frame1 = column1.GetAnalyticalModel() as AnalyticalModel;
        XYZ centerPoint1 = (frame1.GetCurve() as Line).get_EndPoint(0);

        AnalyticalModel frame2 = column2.GetAnalyticalModel() as AnalyticalModel;
        XYZ centerPoint2 = (frame2.GetCurve() as Line).get_EndPoint(0);

        XYZ startPoint = new XYZ(centerPoint1.X, centerPoint1.Y, 0);
        XYZ endPoint = new XYZ(centerPoint2.X, centerPoint2.Y, 0);
        Autodesk.Revit.DB.Line baseLine = null;

        try
        {
            baseLine = document.Application.Create.NewLineBound(startPoint, endPoint);
        }
        catch (System.ArgumentException)
        {
            throw new Exception("Selected columns are too close to create truss.");
        }

        // use the active view for where the truss's tag will be placed; View used in
        // NewTruss should be plan or elevation view parallel to the truss's base line
        Autodesk.Revit.DB.View view = document.ActiveView;

        // Get a truss type for the truss
        TrussType trussType = null;
        foreach (TrussType currentType in document.TrussTypes)
        {
            if (null != currentType)
            {
                trussType = currentType;
                break;
            }
        }

        if (null != trussType)
        {
            truss = document.Create.NewTruss(trussType, sketchPlane, baseLine);
            transaction.Commit();
        }
        else
        {
            transaction.RollBack();
            throw new Exception("No truss types found in document.");
        }
    }

    return truss;
}
CopyVB.NET
Function CreateTruss(ByVal document As Autodesk.Revit.DB.Document, ByVal column1 As Autodesk.Revit.DB.FamilyInstance, ByVal column2 As Autodesk.Revit.DB.FamilyInstance) As Truss
    Dim truss As Truss = Nothing
    Dim transaction As New Transaction(document, "Add Truss")
    If transaction.Start() = TransactionStatus.Started Then
        'sketchPlane
        Dim origin As New Autodesk.Revit.DB.XYZ(0, 0, 0)
        Dim xDirection As New Autodesk.Revit.DB.XYZ(1, 0, 0)
        Dim yDirection As New Autodesk.Revit.DB.XYZ(0, 1, 0)
        Dim plane As Plane = document.Application.Create.NewPlane(xDirection, yDirection, origin)
        Dim sketchPlane As SketchPlane = document.Create.NewSketchPlane(plane)

        'new base Line - use line that spans two selected columns
        Dim frame1 As Autodesk.Revit.DB.Structure.AnalyticalModel = TryCast(column1.GetAnalyticalModel(), Autodesk.Revit.DB.Structure.AnalyticalModel)
        Dim centerPoint1 As Autodesk.Revit.DB.XYZ = (TryCast(frame1.GetCurve(), Line)).EndPoint(0)

        Dim frame2 As Autodesk.Revit.DB.Structure.AnalyticalModel = TryCast(column2.GetAnalyticalModel(), Autodesk.Revit.DB.Structure.AnalyticalModel)
        Dim centerPoint2 As Autodesk.Revit.DB.XYZ = (TryCast(frame2.GetCurve(), Line)).EndPoint(0)

        Dim startPoint As New Autodesk.Revit.DB.XYZ(centerPoint1.X, centerPoint1.Y, 0)
        Dim endPoint As New Autodesk.Revit.DB.XYZ(centerPoint2.X, centerPoint2.Y, 0)
        Dim baseLine As Autodesk.Revit.DB.Line = Nothing

        Try
            baseLine = document.Application.Create.NewLineBound(startPoint, endPoint)
        Catch generatedExceptionName As System.ArgumentException
            Throw New Exception("Selected columns are too close to create truss.")
        End Try

        ' use the active view for where the truss's tag will be placed; View used in
        ' NewTruss should be plan or elevation view parallel to the truss's base line
        Dim view As Autodesk.Revit.DB.View = document.ActiveView

        ' Get a truss type for the truss
        Dim trussType As TrussType = Nothing
        For Each currentType As TrussType In document.TrussTypes
            If currentType IsNot Nothing Then
                trussType = currentType
                Exit For
            End If
        Next

        If trussType IsNot Nothing Then
            truss = document.Create.NewTruss(trussType, sketchPlane, baseLine, view)
            transaction.Commit()
        Else
            transaction.RollBack()
            Throw New Exception("No truss types found in document.")
        End If
    End If

    Return truss
End Function

See Also

Document Class
Autodesk.Revit.Creation Namespace

NewUnionFitting Method

[image]