Revit 2013 API
FilteredElementIdIterator Members
FilteredElementIdIterator Class Methods Properties See Also Send Feedback

The FilteredElementIdIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the FilteredElementIdIterator
Public method | GetCurrent | The current element id found by the iterator.
Public method | IsDone | Identifies if the iteration has completed.
Public method | MoveNext | Increments the iterator to the next element id passing the filter.
Public method | Reset | Resets the iterator to the beginning.

Properties

 | Name | Description
Public property | Current |
Protected property | CurrentObject |

See Also

FilteredElementIdIterator Class

FilteredElementIdIterator Methods

[image] [image]