Revit 2013 API
AnalyticalModelSelector Members
AnalyticalModelSelector Class Constructors Methods Properties See Also Send Feedback

The AnalyticalModelSelector type exposes the following members.

Constructors

 | Name | Description
Public method | AnalyticalModelSelector()()()() | Creates a selector for the analytical model geometry.
Public method | AnalyticalModelSelector(AnalyticalCurveSelector) | Creates a selector for the analytical model geometry.
Public method | AnalyticalModelSelector(Curve) | Creates a selector based on a specific analytical curve.
Public method | AnalyticalModelSelector(Curve, AnalyticalCurveSelector) | Creates a selector based on one portion of a specific analytical curve.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the AnalyticalModelSelector

Properties

 | Name | Description
Public property | CurveSelector |

See Also

AnalyticalModelSelector Class
Autodesk.Revit.DB.Structure Namespace

AnalyticalModelSelector Constructor

[image] [image]