Revit 2013 API
ViewSchedule..::..CreateSchedule Method (Document, ElementId, ElementId)
ViewSchedule Class Example See Also Send Feedback
Creates a regular schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static ViewSchedule CreateSchedule(
    Document document,
    ElementId categoryId,
    ElementId areaSchemeId
)
Visual Basic
Public Shared Function CreateSchedule ( _
    document As Document, _
    categoryId As ElementId, _
    areaSchemeId As ElementId _
) As ViewSchedule
Visual C++
public:
static ViewSchedule^ CreateSchedule(
    Document^ document,
    ElementId^ categoryId,
    ElementId^ areaSchemeId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the new schedule will be added.
categoryId
Type: Autodesk.Revit.DB..::..ElementId
The ID of the category whose elements will be included in the schedule, or InvalidElementId for a multi-category schedule.
areaSchemeId
Type: Autodesk.Revit.DB..::..ElementId
The ID of an area scheme in an area schedule, InvalidElementId otherwise.

Return Value

The newly created schedule.

Examples

CopyC#
FilteredElementCollector collector1 = new FilteredElementCollector(doc);
collector1.OfCategory(BuiltInCategory.OST_AreaSchemes);
//Get first ElementId of AreaScheme.
ElementId areaSchemeId = collector1.FirstElementId();

//If you want to create an area schedule, you must use CreateSchedule method with three arguments. The input of second argument must be ElementId of BuiltInCategory.OST_Areas category and the input of third argument must be ElementId of a areaScheme.
ViewSchedule areaSchedule = Autodesk.Revit.DB.ViewSchedule.CreateSchedule(doc, new ElementId(BuiltInCategory.OST_Areas), areaSchemeId);

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document. -or- categoryId is not a valid category for a regular schedule. -or- In a non-area schedule, areaSchemeId is not InvalidElementId. -or- In an area schedule, areaSchemeId is not the ID of an area scheme.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

ViewSchedule Class
CreateSchedule Overload

CreateSheetList Method

[image]