Revit 2013 API
Document..::..NewFloor Method (CurveArray, FloorType, Level, Boolean, XYZ)
Document Class Example See Also Send Feedback
Creates a floor within the project with the given horizontal profile and floor style on the specified level with the specified normal vector.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Floor NewFloor(
    CurveArray profile,
    FloorType floorType,
    Level level,
    bool structural,
    XYZ normal
)
Visual Basic
Public Function NewFloor ( _
    profile As CurveArray, _
    floorType As FloorType, _
    level As Level, _
    structural As Boolean, _
    normal As XYZ _
) As Floor
Visual C++
public:
Floor^ NewFloor(
    CurveArray^ profile,
    FloorType^ floorType,
    Level^ level,
    bool structural,
    XYZ^ normal
)

Parameters

profile
Type: Autodesk.Revit.DB..::..CurveArray
An array of planar lines and arcs that represent the horizontal profile of the floor.
floorType
Type: Autodesk.Revit.DB..::..FloorType
A floor type to be used by the new floor instead of the default type.
level
Type: Autodesk.Revit.DB..::..Level
The level on which the floor is to be placed.
structural
Type: System..::..Boolean
If set, specifies that the floor is structural in nature.
normal
Type: Autodesk.Revit.DB..::..XYZ
A vector that must be perpendicular to the profile which dictates which side of the floor is considered to be upper and down.

Return Value

if successful, a new floor object within the project, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

The Face formed by profile should be suitable to create floor, otherwise an exception thrown.

Examples

CopyC#
Floor CreateFloor(UIApplication application, Level level)
{
    // Get the Revit document
    Autodesk.Revit.DB.Document document = application.ActiveUIDocument.Document;

    // Get the application creation object
    Autodesk.Revit.Creation.Application appCreation = application.Application.Create;

    // Get a floor type for floor creation
    FloorType floorType = null;
    FloorTypeSet floorTypes = document.FloorTypes;
    FloorTypeSetIterator iter = floorTypes.ForwardIterator();
    iter.Reset();
    while (iter.MoveNext())
    {
        floorType = iter.Current as FloorType;
        if (null != floorType)
        {
            break;
        }
    }

    // Build a floor profile for the floor creation
    XYZ first = new XYZ(0, 0, 0);
    XYZ second = new XYZ(20, 0, 0);
    XYZ third = new XYZ(20, 15, 0);
    XYZ fourth = new XYZ(0, 15, 0);
    CurveArray profile = new CurveArray();
    profile.Append(appCreation.NewLineBound(first, second));
    profile.Append(appCreation.NewLineBound(second, third));
    profile.Append(appCreation.NewLineBound(third, fourth));
    profile.Append(appCreation.NewLineBound(fourth, first));

    // The normal vector (0,0,1) that must be perpendicular to the profile.
    XYZ normal = XYZ.BasisZ;

    return document.Create.NewFloor(profile, floorType, level, true, normal);
}
CopyVB.NET
Function CreateFloor(ByVal application As UIApplication, ByVal level As Level) As Autodesk.Revit.DB.Floor
    ' Get the Revit document
    Dim document As Autodesk.Revit.DB.Document = application.ActiveUIDocument.Document

    ' Get the application creation object
    Dim appCreation As Autodesk.Revit.Creation.Application = application.Application.Create

    ' Get a floor type for floor creation
    Dim floorType As FloorType = Nothing
    Dim floorTypes As FloorTypeSet = document.FloorTypes
    Dim iter As FloorTypeSetIterator = floorTypes.ForwardIterator()
    iter.Reset()
    While iter.MoveNext()
        floorType = TryCast(iter.Current, FloorType)
        If floorType IsNot Nothing Then
            Exit While
        End If
    End While

    ' Build a floor profile for the floor creation
    Dim first As New Autodesk.Revit.DB.XYZ(0, 0, 0)
    Dim second As New Autodesk.Revit.DB.XYZ(20, 0, 0)
    Dim third As New Autodesk.Revit.DB.XYZ(20, 15, 0)
    Dim fourth As New Autodesk.Revit.DB.XYZ(0, 15, 0)
    Dim profile As New CurveArray()
    profile.Append(appCreation.NewLineBound(first, second))
    profile.Append(appCreation.NewLineBound(second, third))
    profile.Append(appCreation.NewLineBound(third, fourth))
    profile.Append(appCreation.NewLineBound(fourth, first))

    ' The normal vector (0,0,1) that must be perpendicular to the profile.
    Dim normal As Autodesk.Revit.DB.XYZ = Autodesk.Revit.DB.XYZ.BasisZ

    Return document.Create.NewFloor(profile, floorType, level, True, normal)
End Function

See Also

Document Class
NewFloor Overload
Autodesk.Revit.Creation Namespace

NewFootPrintRoof Method

[image]