Revit 2013 API
ViewSheet..::..Create Method
ViewSheet Class See Also Send Feedback
Creates a new ViewSheet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static ViewSheet Create(
    Document document,
    ElementId titleBlockTypeId
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    titleBlockTypeId As ElementId _
) As ViewSheet
Visual C++
public:
static ViewSheet^ Create(
    Document^ document,
    ElementId^ titleBlockTypeId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the ViewSheet will be added.
titleBlockTypeId
Type: Autodesk.Revit.DB..::..ElementId
The type id of the TitleBlock type which will be used by the new ViewSheet. For no TitleBlock, pass invalid element ID.

Return Value

The new ViewSheet.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ElementId titleBlockTypeId does not correspond to a TitleBlock type. -or- document is not a project document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

ViewSheet Class

CreatePlaceholder Method

[image]