Revit 2013 API
Document..::..Element Property (ElementId)
Document Class See Also Send Feedback
Retrieves an element from the document given a Revit element id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This method has been obsoleted. Use GetElement() instead.")]
public Element this[
    ElementId id
] { get; }
Visual Basic
<ObsoleteAttribute("This method has been obsoleted. Use GetElement() instead.")> _
Public ReadOnly Property Element ( _
    id As ElementId _
) As Element
    Get
Visual C++
[ObsoleteAttribute(L"This method has been obsoleted. Use GetElement() instead.")]
public:
property Element^ Element[ElementId^ id] {
    Element^ get (ElementId^ id);
}

Parameters

id
Type: Autodesk.Revit.DB..::..ElementId
The Autodesk::Revit::DB::ElementId^ of the element to be retrieved from the Document.

Remarks

Returns the element corresponding to the id that was passed. The Element property is used to retrieve a known Element from the Revit database within the Document. If the Element specified by the Autodesk::Revit::DB::ElementId^ does not exist then an empty reference will be returned.

See Also

Document Class
Element Overload

FamilyCreate Property

[image]