Revit 2013 API
RebarShapeDefinitionByArc Methods
RebarShapeDefinitionByArc Class See Also Send Feedback

The RebarShapeDefinitionByArc type exposes the following members.

Methods

 | Name | Description
Public method | AddConstraintArcLength | Specify a parameter to drive the arc length of the shape.
Public method | AddConstraintChordLength | Specify a parameter to drive the chord length (the straight-line distance between the endpoints of the arc).
Public method | AddConstraintCircumference | Specify a parameter to drive the circumference of the shape.
Public method | AddConstraintDiameter | Specify a parameter to drive the diameter of the shape.
Public method | AddConstraintRadius | Specify a parameter to drive the radius of the shape.
Public method | AddConstraintSagittaLength | Specify a parameter to drive the sagittal length (the height of the circular segment, measured perpendicular to the chord).
Public method | GetConstraints | Retrieve the list of constraints associated with this definition.
Public method | SetArcTypeSpiral | Set the RebarShapeDefinitionByArc.Type property to Spiral.
Public method | SetConstraints | Assign a new list of constraints to this definition.

See Also

RebarShapeDefinitionByArc Class
Autodesk.Revit.DB.Structure Namespace

AddConstraintArcLength Method

[image]