Revit 2013 API
FamilyElementVisibilityType Enumeration
See Also Send Feedback
Indicates the Visibility type of generic forms.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum FamilyElementVisibilityType
Visual Basic
Public Enumeration FamilyElementVisibilityType
Visual C++
public enum class FamilyElementVisibilityType

Members

Member name | Description
Model | The element will be displayed in 3D views and model other model views.
ViewSpecific | The element will be displayed only in the view where it is created. This applies to items like detail components, annotations, and view-specific imports.

Remarks

Use this enum to indicate the visibility type of new forms.

See Also

FamilyHostingBehavior Enumeration

[image]