Revit 2013 API
BoundaryConditions Class
Members Example See Also Send Feedback
An object that represents a force applied across an area.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class BoundaryConditions : Element
Visual Basic
Public Class BoundaryConditions _
    Inherits Element
Visual C++
public ref class BoundaryConditions : public Element

Examples

CopyC#
public void GetInfo_BoundaryConditions(BoundaryConditions boundaryConditions)
{
    string message = "BoundaryConditions : ";

    Parameter param = boundaryConditions.get_Parameter(BuiltInParameter.BOUNDARY_CONDITIONS_TYPE);
    switch (param.AsInteger())
    {
        case 0:
          XYZ point = boundaryConditions.Point;
            message += "\nThis BoundaryConditions is a Point Boundary Conditions.";
            message += "\nLocation point: (" + point.X + ", "
                        + point.Y + ", " + point.Z + ")";
            break;
        case 1:
            message += "\nThis BoundaryConditions is a Line Boundary Conditions.";
            Curve curve = boundaryConditions.get_Curve(0);
            // Get curve start point
            message += "\nLocation Line: start point: (" + curve.get_EndPoint(0).X + ", "
                    + curve.get_EndPoint(0).Y + ", " + curve.get_EndPoint(0).Z + ")";
            // Get curve end point
            message += ";  end point:(" + curve.get_EndPoint(1).X + ", "
                    + curve.get_EndPoint(1).Y + ", " + curve.get_EndPoint(1).Z + ")";
            break;
        case 2:
            message += "\nThis BoundaryConditions is an Area Boundary Conditions.";
            for (int i = 0; i < boundaryConditions.NumCurves; i++)
            {
                Autodesk.Revit.DB.Curve areaCurve = boundaryConditions.get_Curve(i);
                // Get curve start point
                message += "\nCurve start point:(" + areaCurve.get_EndPoint(0).X + ", "
                     + areaCurve.get_EndPoint(0).Y + ", " + areaCurve.get_EndPoint(0).Z + ")";
                // Get curve end point
                message += "; Curve end point:(" + areaCurve.get_EndPoint(1).X + ", "
                     + areaCurve.get_EndPoint(1).Y + ", " + areaCurve.get_EndPoint(1).Z + ")";
            }
            break;
        default:
            break;
    }

    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Public Sub GetInfo_BoundaryConditions(ByVal boundaryConditions As Autodesk.Revit.DB.BoundaryConditions)
    Dim message As String = "BoundaryConditions : "

    Dim param As Parameter = boundaryConditions.Parameter(BuiltInParameter.BOUNDARY_CONDITIONS_TYPE)
    Select Case param.AsInteger()
        Case 0
            Dim point As Autodesk.Revit.DB.XYZ = boundaryConditions.Point
            message += vbLf & "This BoundaryConditions is a Point Boundary Conditions."
            message += vbLf & "Location point: (" + point.X + ", " + point.Y + ", " + point.Z + ")"
            Exit Select
        Case 1
            message += vbLf & "This BoundaryConditions is a Line Boundary Conditions."
            Dim curve As Curve = boundaryConditions.Curve(0)
            ' Get curve start point
            message += vbLf & "Location Line: start point: (" + curve.EndPoint(0).X + ", " + curve.EndPoint(0).Y + ", " + curve.EndPoint(0).Z + ")"
            ' Get curve end point
            message += ";  end point:(" + curve.EndPoint(1).X + ", " + curve.EndPoint(1).Y + ", " + curve.EndPoint(1).Z + ")"
            Exit Select
        Case 2
            message += vbLf & "This BoundaryConditions is an Area Boundary Conditions."
            Dim i As Integer = 0
            While i < boundaryConditions.NumCurves
                Dim areaCurve As Autodesk.Revit.DB.Curve = boundaryConditions.Curve(i)
                ' Get curve start point
                message += vbLf & "Curve start point:(" + areaCurve.EndPoint(0).X + ", " + areaCurve.EndPoint(0).Y + ", " + areaCurve.EndPoint(0).Z + ")"
                ' Get curve end point
                message += "; Curve end point:(" + areaCurve.EndPoint(1).X + ", " + areaCurve.EndPoint(1).Y + ", " + areaCurve.EndPoint(1).Z + ")"
                System.Math.Max(System.Threading.Interlocked.Increment(i), i - 1)
            End While
            Exit Select
        Case Else
            Exit Select
    End Select

    TaskDialog.Show("Revit", message)
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..BoundaryConditions

See Also

BoundaryConditions Members

BoundaryConditions Members

[image] [image]