Revit 2013 API
ScheduleSortGroupField Members
ScheduleSortGroupField Class Constructors Methods Properties See Also Send Feedback

The ScheduleSortGroupField type exposes the following members.

Constructors

 | Name | Description
Public method | ScheduleSortGroupField()()()() | Creates a new ScheduleSortGroupField.
Public method | ScheduleSortGroupField(ScheduleFieldId) | Creates a new ScheduleSortGroupField.
Public method | ScheduleSortGroupField(ScheduleFieldId, ScheduleSortOrder) | Creates a new ScheduleSortGroupField.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ScheduleSortGroupField

Properties

 | Name | Description
Public property | FieldId | The ID of the field that the schedule will be sorted or grouped by.
Public property | ShowBlankLine | Indicates if an empty row should be displayed between groups.
Public property | ShowFooter | Indicates if a footer row should be displayed after each group.
Public property | ShowFooterCount | Indicates if the footer row should display a count of elements in the group.
Public property | ShowFooterTitle | Indicates if the footer row should display a title.
Public property | ShowHeader | Indicates if a header row should be displayed before each group.
Public property | SortOrder | Indicates if elements in the schedule will be sorted in ascending or descending order.

See Also

ScheduleSortGroupField Class

ScheduleSortGroupField Constructor

[image] [image]