Revit 2013 API
RebarShapeDefinition Members
RebarShapeDefinition Class Methods Properties See Also Send Feedback

The RebarShapeDefinition type exposes the following members.

Methods

 | Name | Description
Public method | AddFormulaParameter | Add a formula-driven parameter to the shape definition.
Public method | AddParameter | Add a parameter to the shape definition.
Public method | CheckDefaultParameterValues | Check that the shape can be solved with the default parameter values.
Public method | Dispose | Releases all resources used by the RebarShapeDefinition
Public method | GetParameterDefaultValue | Return the parameter's default value as stored in the definition.
Public method | GetParameterFormula | Return the parameter's formula, if one is associated with it.
Public method | GetParameters | Return the Ids of the shared parameters in the Definition.
Public method | HasParameter | Whether the definition stores the parameter.
Public method | RemoveParameter | Remove the parameter from the definition.
Public method | SetParameterDefaultValue | Change the parameter's value as stored in the definition.
Public method | SetParameterFormula | Associate a formula with the parameter.

Properties

 | Name | Description
Public property | Complete | Report whether the shape definition is fully constrained.
Public property | IsPlanar | Reports whether the shape definition lies within a plane: false if a spiral, true in all other cases.

See Also

RebarShapeDefinition Class
Autodesk.Revit.DB.Structure Namespace

RebarShapeDefinition Methods

[image] [image]