Revit 2013 API
FabricArea..::..Create Method
FabricArea Class See Also Send Feedback
create FabricArea from an array of GCurves A document The element that will host the FabricArea. An array of curves that will define the outline of the FabricArea. This includes curves defining openings in the interior of the area. A vector to the define the major direction of the fabric distribution

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static FabricArea Create(
    Document aDoc,
    Element hostElement,
    IList<CurveLoop> curveLoops,
    XYZ majorDirection
)
Visual Basic
Public Shared Function Create ( _
    aDoc As Document, _
    hostElement As Element, _
    curveLoops As IList(Of CurveLoop), _
    majorDirection As XYZ _
) As FabricArea
Visual C++
public:
static FabricArea^ Create(
    Document^ aDoc,
    Element^ hostElement,
    IList<CurveLoop^>^ curveLoops,
    XYZ^ majorDirection
)

Parameters

aDoc
Type: Autodesk.Revit.DB..::..Document
hostElement
Type: Autodesk.Revit.DB..::..Element
curveLoops
Type: System.Collections.Generic..::..IList<(Of <(<'CurveLoop>)>)>
majorDirection
Type: Autodesk.Revit.DB..::..XYZ

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Not all curveLoops in curveLoops are closed and continuous. -or- Not all curveLoops in curveLoops are in the same plane. -or- curveLoops should only contain lines or arcs. -or- the host Element is not a valid host for Area Rebar, Path Rebar or Fabric Area reinforcement
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | majorDirection has zero length.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural.

See Also

FabricArea Class
Autodesk.Revit.DB.Structure Namespace

GetCurveElementIds Method

[image]