Revit 2013 API
Curve..::..EndPoint Property
Curve Class See Also Send Feedback
The start or the end point of this curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ this[
    int index
] { get; }
Visual Basic
Public ReadOnly Property EndPoint ( _
    index As Integer _
) As XYZ
    Get
Visual C++
public:
property XYZ^ EndPoint[int index] {
    XYZ^ get (int index);
}

Parameters

index
Type: System..::..Int32
Use 0 for the start point; 1 for the end point.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when this curve is unbound.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the specified index is not 0 or 1.

See Also

Curve Class

EndPointReference Property

[image]