Revit 2013 API
Document..::..NewBeamSystem Method (CurveArray, Level, XYZ, Boolean)
Document Class See Also Send Feedback
Creates a new BeamSystem with specified profile curves.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public BeamSystem NewBeamSystem(
    CurveArray profile,
    Level level,
    XYZ direction,
    bool is3d
)
Visual Basic
Public Function NewBeamSystem ( _
    profile As CurveArray, _
    level As Level, _
    direction As XYZ, _
    is3d As Boolean _
) As BeamSystem
Visual C++
public:
BeamSystem^ NewBeamSystem(
    CurveArray^ profile,
    Level^ level,
    XYZ^ direction,
    bool is3d
)

Parameters

profile
Type: Autodesk.Revit.DB..::..CurveArray
The profile of the BeamSystem. The profile must be a closed curve loop in the level.
level
Type: Autodesk.Revit.DB..::..Level
The level on which the BeamSystem is to be created. The work plane of the BeamSystem will be the ketch plane associated with the Level. If there is no current sketch plane associated with the level yet, we will create a default one.
direction
Type: Autodesk.Revit.DB..::..XYZ
The direction is the direction of the BeamSystem. This argument is optional – may be null.
is3d
Type: System..::..Boolean
Whether the BeamSystem is 3D or not

Return Value

If successful a new BeamSystem object will be returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic). Suitable exceptions will be fired if the parameters are invalid.

Remarks

Other properties are set to default value and can be set later. Such as elevation, direction, etc.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input profile or level is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when profile or level is not suitable for creating beam system.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown if calling this function when the document is not modifiable.

See Also

Document Class
NewBeamSystem Overload
Autodesk.Revit.Creation Namespace

NewBeamSystem Method (CurveArray, SketchPlane, XYZ, Boolean)

[image]