Revit 2013 API
Rebar Members
Rebar Class Methods Properties See Also Send Feedback

The Rebar type exposes the following members.

Methods

 | Name | Description
 | CreateFromCurves | Creates a new instance of a Rebar element within the project.
 | CreateFromCurvesAndShape | Creates a new instance of a Rebar element within the project. The instance will have the default shape parameters from the RebarShape.
 | CreateFromRebarShape | Creates a new Rebar, as an instance of a RebarShape. The instance will have the default shape parameters from the RebarShape, and its location is based on the bounding box of the shape in the shape definition. Hooks are removed from the shape before computing its bounding box. If appropriate hooks can be found in the document, they will be assigned arbitrarily.
Public method | DoesBarExistAtPosition | Checks whether a bar exists at the specified position.
Public method | GetBarPositionTransform | Return a transform representing the relative position of any individual bar in the set.
Public method | GetBendData | Gets the RebarBendData, containing bar and hook information, of the instance.
Public method | GetCenterlineCurves(Boolean) | Obsolete. A chain of curves representing the centerline of the rebar.
Public method | GetCenterlineCurves(Boolean, Boolean, Boolean) | A chain of curves representing the centerline of the rebar.
Public method | GetDistributionPath | The distribution path of a rebar set.
Public method | GetHookTypeId | Get the id of the RebarHookType to be applied to the rebar.
Public method | GetHostId | The element that contains the rebar.
Public method | IsSolidInView | Checks if this rebar element is shown solidly in a 3D view.
Public method | IsUnobscuredInView | Checks if this rebar element is shown unobscured in a view.
 | RebarShapeMatchesCurvesAndHooks | Checks if rebarShape matches curves and hooks.
Public method | ScaleToBox | Move and resize the bar to fit within a specified box. The arguments are interpreted as an arbitrary rectangle in 3D with vertices: origin, origin+xVec, origin+xVec+yVec, origin+yVec. The algorithm then proceeds as follows. First the bar is given the default values of the shape parameters from the shape definition. Then, if it is possible to do so without violating the shape definition, the parameter values are scaled so that the width and height of the shape match the lengths of xVec and yVec. If there is no way to do this within the shape definition due to overconstraining, a compromise is attempted, such as scaling the whole shape until either the width or the height is correct. Finally the shape is rotated to match the coordinate system of the box. The algorithm is the same one used in one-click placement.
Public method | ScaleToBoxFor3D | Move and resize a spiral or multiplanar instance to fit within a specified box. The arguments are interpreted as an arbitrary rectangle in 3D with vertices: origin, origin+xVec, origin+xVec+yVec, origin+yVec. One end of the rebar shape is inscribed in this rectangle. The other end is placed in the parallel plane at distance given by the height argument, in the direction of xVec cross yVec. This method replaces ScaleToBoxForSpiral() from prior releases.
Public method | SetHookTypeId | Set the id of the RebarHookType to be applied to the rebar.
Public method | SetHostId | The element that contains the rebar.
Public method | SetLayoutAsFixedNumber | Sets the Layout Rule property of rebar set to FixedNumber.
Public method | SetLayoutAsMaximumSpacing | Sets the Layout Rule property of rebar set to MaximumSpacing
Public method | SetLayoutAsMinimumClearSpacing | Sets the Layout Rule property of rebar set to MinimumClearSpacing
Public method | SetLayoutAsNumberWithSpacing | Sets the Layout Rule property of rebar set to NumberWithSpacing
Public method | SetLayoutAsSingle | Sets the Layout Rule property of rebar set to Single.
Public method | SetSolidInView | Sets this rebar element to be shown solidly in a 3D view.
Public method | SetUnobscuredInView | Sets this rebar element to be shown unobscured in a view.

Properties

 | Name | Description
Public property | ArrayLength | Identifies the distribution path length of rebar set.
Public property | BarsOnNormalSide | Identifies if the bars of the rebar set are on the same side of the rebar plane indicated by the normal.
Public property | BarType | Obsolete. Return the type of the rebar.
Public property | BaseFinishingTurns | For a spiral, the number of finishing turns at the lower end of the spiral.
Public property | DistributionPath | Obsolete. For Rebar with an array layout, return the distribution path (a line).
Public property | Height | For a spiral, the overall height.
Public property | Host | Obsolete. The element that contains the rebar.
Public property | IncludeFirstBar | Identifies if the first bar in rebar set is shown.
Public property | IncludeLastBar | Identifies if the last bar in rebar set is shown.
Public property | LayoutRule | Identifies the layout rule of rebar set.
Public property | MaxSpacing | Identifies the maximum spacing between rebar in rebar set.
Public property | MultiplanarDepth | For a multiplanar rebar, the depth of the instance.
Public property | Normal | A unit-length vector normal to the plane of the rebar
Public property | NumberOfBarPositions | The number of potential bars in the set.
Public property | Pitch | For a spiral, the pitch, or vertical distance traveled in one rotation.
Public property | Quantity | Identifies the number of bars in rebar set.
Public property | RebarShape | Obsolete. Get/Set the RebarShape associated with the Rebar.
Public property | RebarShapeId | The RebarShape element that defines the shape of the rebar.
Public property | ScheduleMark | The Schedule Mark parameter. On creation, the Schedule Mark is set to a value that is unique to the host, but it can be set to any value.
Public property | TopFinishingTurns | For a spiral, the number of finishing turns at the upper end of the spiral.
Public property | TotalLength | The length of an individual bar multiplied by Quantity.
Public property | Volume | The volume of an individual bar multiplied by Quantity.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace

Rebar Methods

[image] [image]