Revit 2013 API
ParameterFilterElement Class
Members Example See Also Send Feedback
Admits elements that satisfy two conditions:
  1. The element's category must be one of a certain set of allowed categories.
  2. The element must pass a series of filter rules.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class ParameterFilterElement : FilterElement
Visual Basic
Public Class ParameterFilterElement _
    Inherits FilterElement
Visual C++
public ref class ParameterFilterElement : public FilterElement

Examples

CopyC#
private void CreateViewFilter(Autodesk.Revit.DB.Document doc)
{
    List<ElementId> categories = new List<ElementId>();
    categories.Add(new ElementId(BuiltInCategory.OST_Walls));
    ParameterFilterElement parameterFilterElement = ParameterFilterElement.Create(doc, "Comments = foo", categories);

    FilteredElementCollector parameterCollector = new FilteredElementCollector(doc);
    Parameter parameter = parameterCollector.OfClass(typeof(Wall)).FirstElement().get_Parameter("Comments");

    List<FilterRule> filterRules = new List<FilterRule>();
    filterRules.Add(ParameterFilterRuleFactory.CreateEqualsRule(parameter.Id, "foo", true));
    parameterFilterElement.SetRules(filterRules);
}

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..FilterElement
Autodesk.Revit.DB..::..ParameterFilterElement

See Also

ParameterFilterElement Members

ParameterFilterElement Members

[image] [image]