Revit 2013 API
IFCStairRampContainerInfo..::..GetContainerInfo Method
IFCStairRampContainerInfo Class See Also Send Feedback
Gets the containment information for a stair or ramp.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static IFCStairRampContainerInfo GetContainerInfo(
    ExporterIFC exporterIFC,
    ElementId elemId
)
Visual Basic
Public Shared Function GetContainerInfo ( _
    exporterIFC As ExporterIFC, _
    elemId As ElementId _
) As IFCStairRampContainerInfo
Visual C++
public:
static IFCStairRampContainerInfo^ GetContainerInfo(
    ExporterIFC^ exporterIFC,
    ElementId^ elemId
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
elemId
Type: Autodesk.Revit.DB..::..ElementId
The stair or ramp element id.

Return Value

The containment information.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCStairRampContainerInfo Class
Autodesk.Revit.DB.IFC Namespace

GetLocalPlacement Method

[image]