Revit 2013 API
FailureHandlingOptions..::..SetFailuresPreprocessor Method
FailureHandlingOptions Class See Also Send Feedback
Setting a callback to be invoked in the beginning of failure processing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FailureHandlingOptions SetFailuresPreprocessor(
    IFailuresPreprocessor preprocessor
)
Visual Basic
Public Function SetFailuresPreprocessor ( _
    preprocessor As IFailuresPreprocessor _
) As FailureHandlingOptions
Visual C++
public:
FailureHandlingOptions^ SetFailuresPreprocessor(
    IFailuresPreprocessor^ preprocessor
)

Parameters

preprocessor
Type: Autodesk.Revit.DB..::..IFailuresPreprocessor

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FailureHandlingOptions Class

SetForcedModalHandling Method

[image]