Revit 2013 API
ProjectUnit Class
Members Example See Also Send Feedback
Provides access to the Project Unit... in Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class ProjectUnit : Element
Visual Basic
Public Class ProjectUnit _
    Inherits Element
Visual C++
public ref class ProjectUnit : public Element

Remarks

The ProjectUnit object can be queried for its D in space planning tools.

Examples

CopyC#
ProjectUnit projectUnit = document.ProjectUnit;

if (null != projectUnit)
{
    string message = "Project Unit: ";

    //get the DecimalSymbolType
    message += "\nDecimal Symbol Type: " + projectUnit.DecimalSymbolType.ToString();

    //show the usage for FormatOptions property
    message += "\nFormat Options: ";
    FormatOptions formatOptions = projectUnit.get_FormatOptions(UnitType.UT_Length);
    message += "\n\tLength : " + formatOptions.Name;
    formatOptions = projectUnit.get_FormatOptions(UnitType.UT_Volume);
    message += "\n\tVolume : " + formatOptions.Name;

    //get the Digit Grouping Amount of the project
    DigitGroupingAmount dga = projectUnit.DigitGroupingAmount;
    message += "\nDigit Grouping Amount: " + dga.ToString();

    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Dim projectUnit As ProjectUnit = document.ProjectUnit

If projectUnit IsNot Nothing Then
    Dim message As String = "Project Unit: "

    'get the DecimalSymbolType
    message += vbLf & "Decimal Symbol Type: " + projectUnit.DecimalSymbolType.ToString()

    'show the usage for FormatOptions property
    message += vbLf & "Format Options: "
    Dim formatOptions As Autodesk.Revit.DB.FormatOptions = projectUnit.FormatOptions(Autodesk.Revit.DB.UnitType.UT_Length)
    message += vbLf & vbTab & "Length : " + formatOptions.Name
    formatOptions = projectUnit.FormatOptions(Autodesk.Revit.DB.UnitType.UT_Volume)
    message += vbLf & vbTab & "Volume : " + formatOptions.Name

    'get the Digit Grouping Amount of the project
    Dim dga As Autodesk.Revit.DB.DigitGroupingAmount = projectUnit.DigitGroupingAmount
    message += vbLf & "Digit Grouping Amount: " + dga.ToString()

    TaskDialog.Show("Revit", message)
End If

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ProjectUnit

See Also

ProjectUnit Members

ProjectUnit Members

[image] [image]