Revit 2013 API
ExternalFileReference..::..PathType Property
ExternalFileReference Class See Also Send Feedback
The path type of the link (relative, absolute, or server).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public PathType PathType { get; }
Visual Basic
Public ReadOnly Property PathType As PathType
    Get
Visual C++
public:
property PathType PathType {
    PathType get ();
}

Field Value

See the PathType enum for a list of the options.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: pathType is not a compatible path type for this ExternalFileReference.

See Also

ExternalFileReference Class

ExternalFileReferenceType Enumeration

[image]