Revit 2013 API
Dimension Members
Dimension Class Methods Properties See Also Send Feedback

The Dimension type exposes the following members.

Methods

 | Name | Description

Properties

 | Name | Description
Public property | Above | The text shown above the segment's value.
Public property | AreSegmentsEqual | Indicates if all segments are forced to be equal.
Public property | Below | The text shown below the segment's value.
Public property | Curve | A curve that represents the dimension line.
Public property | DimensionShape | The shape of this dimension.
Public property | DimensionType | The dimension style of this dimension.
Public property | IsLocked | Indicates if this dimension is locked.
Public property | Label | The family parameter label of the dimension.
Public property | Name | Retrieves or changes the name associated with the Dimension.
Public property | NumberOfSegments | The number of segments for the dimension.
Public property | Prefix | The text shown before the segment's value.
Public property | References | Returns an array of geometric references to which the dimension is attached.
Public property | Segments | The segments in the dimension.
Public property | Suffix | The text shown after the segment's value.
Public property | Value | The value of the dimension.
Public property | ValueOverride | The text that replaces the segment's value.
Public property | ValueString | The dimension value as a user visible string.
Public property | View | Supplies the view that contains the dimension if the dimension is view specific.

See Also

Dimension Class

Dimension Methods

[image] [image]