Revit 2013 API
ExporterIFC..::..GetStairRampContainers Method
ExporterIFC Class See Also Send Feedback
Returns all of the IFCStairContainmentInfos created, with the id of the associated Stairs or Ramp element.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IDictionary<ElementId, IFCStairRampContainerInfo> GetStairRampContainers()
Visual Basic
Public Function GetStairRampContainers As IDictionary(Of ElementId, IFCStairRampContainerInfo)
Visual C++
public:
IDictionary<ElementId^, IFCStairRampContainerInfo^>^ GetStairRampContainers()

Return Value

The collection of containers.

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace

GetViewIdsToExport Method

[image]