Revit 2013 API
CompoundStructureLayer Constructor (Double, MaterialFunctionAssignment, ElementId)
CompoundStructureLayer Class See Also Send Feedback
Creates a default compound structure layer based on the given width, function and material element id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CompoundStructureLayer(
    double width,
    MaterialFunctionAssignment function,
    ElementId materialId
)
Visual Basic
Public Sub New ( _
    width As Double, _
    function As MaterialFunctionAssignment, _
    materialId As ElementId _
)
Visual C++
public:
CompoundStructureLayer(
    double width,
    MaterialFunctionAssignment function,
    ElementId^ materialId
)

Parameters

width
Type: System..::..Double
The width of the layer.
function
Type: Autodesk.Revit.DB..::..MaterialFunctionAssignment
The function of the layer.
materialId
Type: Autodesk.Revit.DB..::..ElementId
The material element id of the layer.

Remarks

Sets LayerCapFlag to true. Sets DeckEmbeddingType to Invalid. Sets DeckProfileId to invalidElementId.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

CompoundStructureLayer Class
CompoundStructureLayer Overload

CompoundStructureLayer Methods

[image] [image]