Revit 2013 API
Pipe..::..CreatePlaceholder Method
Pipe Class See Also Send Feedback
Creates a new placeholder pipe.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static Pipe CreatePlaceholder(
    Document document,
    ElementId pipeTypeId,
    ElementId levelId,
    XYZ firstPoint,
    XYZ secondPoint
)
Visual Basic
Public Shared Function CreatePlaceholder ( _
    document As Document, _
    pipeTypeId As ElementId, _
    levelId As ElementId, _
    firstPoint As XYZ, _
    secondPoint As XYZ _
) As Pipe
Visual C++
public:
static Pipe^ CreatePlaceholder(
    Document^ document,
    ElementId^ pipeTypeId,
    ElementId^ levelId,
    XYZ^ firstPoint,
    XYZ^ secondPoint
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
pipeTypeId
Type: Autodesk.Revit.DB..::..ElementId
The id of the pipe type.
levelId
Type: Autodesk.Revit.DB..::..ElementId
The level id for the pipe.
firstPoint
Type: Autodesk.Revit.DB..::..XYZ
The first point of the placeholder line.
secondPoint
Type: Autodesk.Revit.DB..::..XYZ
The second point of the placeholder line.

Return Value

The placeholder pipe.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The pipe type pipeTypeId is not valid pipe type. -or- The level id levelId is not valid. -or- The points of firstPoint and secondPoint are equal.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Mechanical Electrical Piping.

See Also

Pipe Class
Autodesk.Revit.DB.Plumbing Namespace

IsLevelId Method

[image]