Revit 2013 API
ExporterIFCUtils..::..ComputeAreaOfCurveLoops Method
ExporterIFCUtils Class See Also Send Feedback
Computes total area of the list of curve loops. If the area cannot be calculated, returns 0.0.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static double ComputeAreaOfCurveLoops(
    IList<CurveLoop> curveLoops
)
Visual Basic
Public Shared Function ComputeAreaOfCurveLoops ( _
    curveLoops As IList(Of CurveLoop) _
) As Double
Visual C++
public:
static double ComputeAreaOfCurveLoops(
    IList<CurveLoop^>^ curveLoops
)

Parameters

curveLoops
Type: System.Collections.Generic..::..IList<(Of <(<'CurveLoop>)>)>

Return Value

Computed area.

Remarks

All curve loops in the list must be planar and lie in the same plane.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace

ComputeRoofProjectedArea Method

[image]