Revit 2013 API
CompoundStructure..::..GetCoreBoundaryLayerIndex Method
CompoundStructure Class See Also Send Feedback
Returns the index of the layer just below the core boundary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int GetCoreBoundaryLayerIndex(
    ShellLayerType shellLayerType
)
Visual Basic
Public Function GetCoreBoundaryLayerIndex ( _
    shellLayerType As ShellLayerType _
) As Integer
Visual C++
public:
int GetCoreBoundaryLayerIndex(
    ShellLayerType shellLayerType
)

Parameters

shellLayerType
Type: Autodesk.Revit.DB..::..ShellLayerType
The type of the shell layer.

Return Value

The index of the layer.

Remarks

-1 returned if there is no such a layer.

See Also

CompoundStructure Class

GetDeckEmbeddingType Method

[image]