Revit 2013 API
ExporterIFCUtils..::..ExportLegacyStairsAsContainer Method
ExporterIFCUtils Class See Also Send Feedback
Adds data from a legacy staircase to the export.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static void ExportLegacyStairsAsContainer(
    ExporterIFC exporterIFC,
    string ifcEnumType,
    Element element,
    GeometryElement geometry,
    bool useCoarseTessellation,
    IFCProductWrapper productWrapper
)
Visual Basic
Public Shared Sub ExportLegacyStairsAsContainer ( _
    exporterIFC As ExporterIFC, _
    ifcEnumType As String, _
    element As Element, _
    geometry As GeometryElement, _
    useCoarseTessellation As Boolean, _
    productWrapper As IFCProductWrapper _
)
Visual C++
public:
static void ExportLegacyStairsAsContainer(
    ExporterIFC^ exporterIFC,
    String^ ifcEnumType,
    Element^ element,
    GeometryElement^ geometry,
    bool useCoarseTessellation,
    IFCProductWrapper^ productWrapper
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
ifcEnumType
Type: System..::..String
The stairs type.
element
Type: Autodesk.Revit.DB..::..Element
The stairs.
geometry
Type: Autodesk.Revit.DB..::..GeometryElement
The geometry of the wall.
useCoarseTessellation
Type: System..::..Boolean
Export using a coarse tessellation if true, default tessellation if false.
productWrapper
Type: Autodesk.Revit.DB.IFC..::..IFCProductWrapper
The product wrapper.

Remarks

This function applies only to legacy stairs found in documents create in R2012 or before.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace

ExportRampAsContainer Method

[image]