Revit 2013 API
Rebar..::..Quantity Property
Rebar Class See Also Send Feedback
Identifies the number of bars in rebar set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2009

Syntax

C#
public int Quantity { get; }
Visual Basic
Public ReadOnly Property Quantity As Integer
    Get
Visual C++
public:
property int Quantity {
    int get ();
}

Field Value

The number of bars in rebar set.

Remarks

Quantity is equal to NumberOfBarPositions if IncludeFirstBar and IncludeLastBar are set. If any end bars are excluded, they are not counted in the Quantity.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace

RebarShape Property

[image]