Revit 2013 API
ExternalFileUtils..::..IsExternalFileReference Method
ExternalFileUtils Class See Also Send Feedback
Determines whether the given element represents an external file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static bool IsExternalFileReference(
    Document aDoc,
    ElementId elemId
)
Visual Basic
Public Shared Function IsExternalFileReference ( _
    aDoc As Document, _
    elemId As ElementId _
) As Boolean
Visual C++
public:
static bool IsExternalFileReference(
    Document^ aDoc,
    ElementId^ elemId
)

Parameters

aDoc
Type: Autodesk.Revit.DB..::..Document
A Revit Document.
elemId
Type: Autodesk.Revit.DB..::..ElementId
The element to be checked for an external file reference.

Return Value

True if the given element represents an external file; false otherwise.

Remarks

Linked files are references to external files, but imported files are not, as their data is brought wholly into Revit.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The element elemId does not exist in the document
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExternalFileUtils Class

Extrusion Class

[image]