Revit 2013 API
Curve Methods
Curve Class See Also Send Feedback

The Curve type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Returns a copy of this curve.
Public method | ComputeDerivatives | Returns the vectors describing the curve at the specified parameter.
Public method | ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter.
Public method | ComputeRawParameter | Computes the raw parameter from the normalized parameter.
Public method | Distance | Returns the shortest distance from the specified point to this curve.
Public method | Evaluate | Evaluates a parameter on the curve.
Public method | Intersect(Curve) | Calculates the intersection of this curve with the specified curve.
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of this curve with the specified curve and returns the intersection results.
Public method | IsInside(Double) | Indicates whether the specified parameter value is within this curve's bounds.
Public method | IsInside(Double, Int32%) | Indicates whether the specified parameter value is within this curve's bounds and outputs the end index.
Public method | MakeBound | Changes the bounds of this curve to the specified values.
Public method | MakeUnbound | Makes this curve unbound.
Public method | Project | Projects the specified point on this curve.
Public method | Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve.

See Also

Curve Class

Clone Method

[image]