Revit 2013 API
ExporterIFCUtils..::..GetWallHeightDirection Method
ExporterIFCUtils Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static XYZ GetWallHeightDirection(
    Wall wall
)
Visual Basic
Public Shared Function GetWallHeightDirection ( _
    wall As Wall _
) As XYZ
Visual C++
public:
static XYZ^ GetWallHeightDirection(
    Wall^ wall
)

Parameters

wall
Type: Autodesk.Revit.DB..::..Wall
The wall.

Return Value

The direction of the wall.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace

GetWallTrimmedCurve Method

[image]