Revit 2013 API
BuiltInFailures..::..KeynoteFailures Members
BuiltInFailures..::..KeynoteFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..KeynoteFailures type exposes the following members.

Properties

Name | Description
CyclicalKeynote | A sub-keynote '[Value]' specified as parent for its current ancestor '[Value]'
DuplicateKeynote | Duplicate key value '[Value]', text: '[Text]'
MissingKeynote | No parent keynote '[Value]' for '[Value]'
MissKeynoteParameter | No Keynote Parameter.\nTo resolve, select key value parameter in keynoting system.
MissKeynotingSystem | No Keynoting System associated with Tag Family.\nTo resolve, select keynoting system for the tag family.
NotAssociatedKeynoteParameter | Current tag keynoting system uses key value parameter that is not associated with this element category.\nTo resolve, associate parameter with category or change keynoting system.
WrongKeynote | Cannot understand keynote line '[Number]'

See Also

BuiltInFailures..::..KeynoteFailures Class

BuiltInFailures.KeynoteFailures Properties

[image] [image]