Revit 2013 API
EnergyDataSettings..::..CheckBuildingType Method
EnergyDataSettings Class See Also Send Feedback
Checks that the building type falls within an appropriate range.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static bool CheckBuildingType(
    gbXMLBuildingType buildingType
)
Visual Basic
Public Shared Function CheckBuildingType ( _
    buildingType As gbXMLBuildingType _
) As Boolean
Visual C++
public:
static bool CheckBuildingType(
    gbXMLBuildingType buildingType
)

Parameters

buildingType
Type: Autodesk.Revit.DB.Analysis..::..gbXMLBuildingType
The building type to be checked.

Return Value

True if the building type falls within an appropriate range, false otherwise.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace

CheckConstructionSetElement Method

[image]