Revit 2013 API
UpdaterRegistry..::..GetRegisteredUpdaterInfos Method (Document)
UpdaterRegistry Class See Also Send Feedback
Returns UpdaterInfos for all the updaters applicable to the specified document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static IList<UpdaterInfo> GetRegisteredUpdaterInfos(
    Document doc
)
Visual Basic
Public Shared Function GetRegisteredUpdaterInfos ( _
    doc As Document _
) As IList(Of UpdaterInfo)
Visual C++
public:
static IList<UpdaterInfo^>^ GetRegisteredUpdaterInfos(
    Document^ doc
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
Document the updater registered to.

Remarks

The returned value includes UpdaterInfos for all the application-wide updaters and updaters registered to the specified document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

UpdaterRegistry Class
GetRegisteredUpdaterInfos Overload

IsUpdaterRegistered Method

[image]