Revit 2013 API
RebarShapeDefinitionBySegments..::..AddBendDefaultRadius Method
RebarShapeDefinitionBySegments Class See Also Send Feedback
Specify a default-radius bend.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void AddBendDefaultRadius(
    int vertexIndex,
    int turn,
    RebarShapeBendAngle angle
)
Visual Basic
Public Sub AddBendDefaultRadius ( _
    vertexIndex As Integer, _
    turn As Integer, _
    angle As RebarShapeBendAngle _
)
Visual C++
public:
void AddBendDefaultRadius(
    int vertexIndex,
    int turn,
    RebarShapeBendAngle angle
)

Parameters

vertexIndex
Type: System..::..Int32
Index of the vertex (1 to NumberOfVertices - 2).
turn
Type: System..::..Int32
Specify 1 for a left turn, -1 for a right turn.
angle
Type: Autodesk.Revit.DB.Structure..::..RebarShapeBendAngle
Specify whether the bend is acute, obtuse, etc.

Remarks

You must add a bend at each vertex except the first and last.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | vertexIndex is not between 0 and NumberOfVertices. -or- turn is neither -1 nor 1.

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.DB.Structure Namespace

AddBendVariableRadius Method

[image]