Revit 2013 API
FamilyManager..::..AddParameter Method
FamilyManager Class See Also Send Feedback
Add a new parameter to the family.

Overload List

 | Name | Description
Public method | AddParameter(ExternalDefinition, BuiltInParameterGroup, Boolean) | Add a new shared parameter to the family.
Public method | AddParameter(String, BuiltInParameterGroup, Category, Boolean) | Add a new family type parameter to control the type of a nested family within another family.
Public method | AddParameter(String, BuiltInParameterGroup, ParameterType, Boolean) | Add a new family parameter with a given name.

See Also

FamilyManager Class
FamilyManager Members

AddParameter Method (ExternalDefinition, BuiltInParameterGroup, Boolean)

[image]