Revit 2013 API
Application..::..NewNurbSpline Method (IList<(Of <(<'XYZ>)>)>, IList<(Of <(<'Double>)>)>)
Application Class See Also Send Feedback
Creates a new geometric NurbSpline object using the same calculations that Revit uses when sketching splines in the user interface.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public NurbSpline NewNurbSpline(
    IList<XYZ> ctrlPoints,
    IList<double> weights
)
Visual Basic
Public Function NewNurbSpline ( _
    ctrlPoints As IList(Of XYZ), _
    weights As IList(Of Double) _
) As NurbSpline
Visual C++
public:
NurbSpline^ NewNurbSpline(
    IList<XYZ^>^ ctrlPoints,
    IList<double>^ weights
)

Parameters

ctrlPoints
Type: System.Collections.Generic..::..IList<(Of <(<'XYZ>)>)>
The control points of the nurbSpline.
weights
Type: System.Collections.Generic..::..IList<(Of <(<'Double>)>)>
The weights of the nurbSpline.

Remarks

Knots and degree of the spline are computed from the control points and weights.

See Also

Application Class
NewNurbSpline Overload
Autodesk.Revit.Creation Namespace

NewNurbSpline Method (IList(XYZ), DoubleArray, DoubleArray, Int32, Boolean, Boolean)

[image]