Revit 2013 API
LinePatternSegment Constructor (LinePatternSegmentType, Double)
LinePatternSegment Class See Also Send Feedback
Creates a line pattern segment with given type and length.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public LinePatternSegment(
    LinePatternSegmentType type,
    double length
)
Visual Basic
Public Sub New ( _
    type As LinePatternSegmentType, _
    length As Double _
)
Visual C++
public:
LinePatternSegment(
    LinePatternSegmentType type,
    double length
)

Parameters

type
Type: Autodesk.Revit.DB..::..LinePatternSegmentType
The segment type.
length
Type: System..::..Double
The length.

See Also

LinePatternSegment Class
LinePatternSegment Overload

LinePatternSegment Methods

[image] [image]