Revit 2013 API
TransmissionData..::..ReadTransmissionData Method
TransmissionData Class See Also Send Feedback
Reads the TransmissionData associated with the file at the given location.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static TransmissionData ReadTransmissionData(
    ModelPath path
)
Visual Basic
Public Shared Function ReadTransmissionData ( _
    path As ModelPath _
) As TransmissionData
Visual C++
public:
static TransmissionData^ ReadTransmissionData(
    ModelPath^ path
)

Parameters

path
Type: Autodesk.Revit.DB..::..ModelPath
A ModelPath indicating the file Revit should read the TransmissionData of. If this ModelPath is a file path, it must be an absolute path.

Return Value

The TransmissionData containing external file information for the file at the given location.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..FileArgumentNotFoundException | There is not a valid Revit file at path's location
Autodesk.Revit.Exceptions..::..RevitServerCommunicationException | There is a network communication error happening.
Autodesk.Revit.Exceptions..::..RevitServerInternalException | There is a server internal error happening.
Autodesk.Revit.Exceptions..::..RevitServerModelContentionException | The server-based model is being accessed by other users.

See Also

TransmissionData Class

SetDesiredReferenceData Method

[image]