Revit 2013 API
ExporterIFCUtils..::..ExportExtrudedSlabOpenings Method
ExporterIFCUtils Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static void ExportExtrudedSlabOpenings(
    ExporterIFC exporterIFC,
    Element pElem,
    IFCPlacementSetter setter,
    IFCAnyHandle localPlacementAny,
    IList<IFCAnyHandle> elementSlabAnyArr,
    IList<IList<CurveLoop>> extrusionLoops,
    Plane plane,
    IFCProductWrapper pWrapper
)
Visual Basic
Public Shared Sub ExportExtrudedSlabOpenings ( _
    exporterIFC As ExporterIFC, _
    pElem As Element, _
    setter As IFCPlacementSetter, _
    localPlacementAny As IFCAnyHandle, _
    elementSlabAnyArr As IList(Of IFCAnyHandle), _
    extrusionLoops As IList(Of IList(Of CurveLoop)), _
    plane As Plane, _
    pWrapper As IFCProductWrapper _
)
Visual C++
public:
static void ExportExtrudedSlabOpenings(
    ExporterIFC^ exporterIFC,
    Element^ pElem,
    IFCPlacementSetter^ setter,
    IFCAnyHandle^ localPlacementAny,
    IList<IFCAnyHandle^>^ elementSlabAnyArr,
    IList<IList<CurveLoop^>^>^ extrusionLoops,
    Plane^ plane,
    IFCProductWrapper^ pWrapper
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
pElem
Type: Autodesk.Revit.DB..::..Element
setter
Type: Autodesk.Revit.DB.IFC..::..IFCPlacementSetter
localPlacementAny
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
elementSlabAnyArr
Type: System.Collections.Generic..::..IList<(Of <(<'IFCAnyHandle>)>)>
extrusionLoops
Type: System.Collections.Generic..::..IList<(Of <(<'IList<(Of <(<'CurveLoop>)>)>>)>)>
plane
Type: Autodesk.Revit.DB..::..Plane
pWrapper
Type: Autodesk.Revit.DB.IFC..::..IFCProductWrapper

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace

ExportFamilyInstanceAsExtrusion Method

[image] [image]