Revit 2013 API
ScheduleDefinition..::..AddField Method (SchedulableField)
ScheduleDefinition Class Example See Also Send Feedback
Adds a regular (non-calculated) field at the end of the list.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ScheduleField AddField(
    SchedulableField schedulableField
)
Visual Basic
Public Function AddField ( _
    schedulableField As SchedulableField _
) As ScheduleField
Visual C++
public:
ScheduleField^ AddField(
    SchedulableField^ schedulableField
)

Parameters

schedulableField
Type: Autodesk.Revit.DB..::..SchedulableField
A SchedulableField object representing the field.

Return Value

The new field.

Examples

CopyC#
/// <summary>
/// Add fields to view schedule.
/// </summary>
/// <param name="schedules">List of view schedule.</param>
public void AddFieldToSchedule(List<ViewSchedule> schedules)
{
    IList<SchedulableField> schedulableFields = null;

    foreach (ViewSchedule vs in schedules)
    {
        //Get all schedulable fields from view schedule definition.
        schedulableFields = vs.Definition.GetSchedulableFields();

        foreach (SchedulableField sf in schedulableFields)
        {
            bool fieldAlreadyAdded = false;
            //Get all schedule field ids
            IList<ScheduleFieldId> ids = vs.Definition.GetFieldOrder();
            foreach (ScheduleFieldId id in ids)
            {
                //If the GetSchedulableField() method of gotten schedule field returns same schedulable field, it means the field is already added to the view schedule.
                if (vs.Definition.GetField(id).GetSchedulableField() == sf)
                {
                    fieldAlreadyAdded = true;
                    break;
                }
            }

            //If schedulable field doesn't exist in view schedule, add it.
            if (fieldAlreadyAdded == false)
            {
                vs.Definition.AddField(sf);
            }
        }
    }
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The field specified by schedulableField may not included in this ScheduleDefinition. -or- The field specified by schedulableField is already included in this ScheduleDefinition.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ScheduleDefinition Class
AddField Overload

AddField Method (ScheduleFieldType)

[image]