Revit 2013 API
Document..::..Export Method (String, String, GBXMLExportOptions)
Document Class See Also Send Feedback
Exports the document in Green-Building XML format.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool Export(
    string folder,
    string name,
    GBXMLExportOptions options
)
Visual Basic
Public Function Export ( _
    folder As String, _
    name As String, _
    options As GBXMLExportOptions _
) As Boolean
Visual C++
public:
bool Export(
    String^ folder,
    String^ name,
    GBXMLExportOptions^ options
)

Parameters

folder
Type: System..::..String
Output folder, into which file(s) will be exported. The folder must exist.
name
Type: System..::..String
Either the name of a single file or a prefix for a set of files. If nullNothingnullptra null reference (Nothing in Visual Basic) or empty, automatic naming will be used.
options
Type: Autodesk.Revit.DB..::..GBXMLExportOptions
Options applicable to the gbXML format.

Return Value

True if successful, otherwise False.

Remarks

Though the 'options' argument is not currently used, an object still must be provided (may be nullNothingnullptra null reference (Nothing in Visual Basic)).

See Also

Document Class
Export Overload

Export Method (String, String, IFCExportOptions)

[image]