Revit 2013 API
ApplicationEntryPoint Methods
ApplicationEntryPoint Class See Also Send Feedback

The ApplicationEntryPoint type exposes the following members.

Methods

 | Name | Description
Public method | CreateAddInCommandBinding |
Public method | CreateRibbonPanel(String) |
Public method | CreateRibbonPanel(String, String) |
Public method | CreateRibbonPanel(Tab, String) |
Public method | CreateRibbonTab |
 | DoDragDrop(ICollection<(Of <<'(String>)>>)) |
 | DoDragDrop(Object, IDropHandler) |
Public method | FinishInitializationEO | For Revit Macros internal use only.
Public method | GetRibbonPanels()()()() |
Public method | GetRibbonPanels(String) |
Public method | GetRibbonPanels(Tab) |
Public method | Initialize | For Revit Macros internal use only.
Public method | OnShutdownEO | For Revit Macros internal use only.
Public method | OpenAndActivateDocument(String) |
Public method | OpenAndActivateDocument(ModelPath, OpenOptionsForUI) |
Public method | RemoveAddInCommandBinding |

See Also

ApplicationEntryPoint Class
Autodesk.Revit.UI.Macros Namespace

CreateAddInCommandBinding Method

[image]