Revit 2013 API
Rebar..::..GetCenterlineCurves Method (Boolean)
Rebar Class See Also Send Feedback
A chain of curves representing the centerline of the rebar.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2009

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Autodesk Revit 2013. Call the three-argument function with the same name instead.")]
public IList<Curve> GetCenterlineCurves(
    bool adjustForSelfIntersection
)
Visual Basic
<ObsoleteAttribute("This method is obsolete in Autodesk Revit 2013. Call the three-argument function with the same name instead.")> _
Public Function GetCenterlineCurves ( _
    adjustForSelfIntersection As Boolean _
) As IList(Of Curve)
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Autodesk Revit 2013. Call the three-argument function with the same name instead.")]
public:
IList<Curve^>^ GetCenterlineCurves(
    bool adjustForSelfIntersection
)

Parameters

adjustForSelfIntersection
Type: System..::..Boolean
If the curves overlap, as in a planar stirrup, this parameter controls whether they should be adjusted to avoid intersection (as in fine views), or kept in a single plane for simplicity (as in coarse views).

Return Value

The centerline curves, including the hooks and bends, or an empty array if the curves cannot be computed because the parameter values are inconsistent with the constraints of the RebarShape definition.

Remarks

If the Rebar is a set, meaning GetLayoutRule() does not return Single, this method returns the first rebar in the set, even if the first bar is suppressed by IncludeFirstBar being false. This function is equivalent to calling GetCenterlineCurves(adjustForSelfIntersection, false, false).

See Also

Rebar Class
GetCenterlineCurves Overload
Autodesk.Revit.DB.Structure Namespace

GetCenterlineCurves Method (Boolean, Boolean, Boolean)

[image]