Revit 2013 API
LabelUtils..::..GetLabelFor Method (gbXMLBuildingType, Document)
LabelUtils Class See Also Send Feedback
Gets user-visible name for gbXMLBuildingType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static string GetLabelFor(
    gbXMLBuildingType gbXMLBuildingType,
    Document doc
)
Visual Basic
Public Shared Function GetLabelFor ( _
    gbXMLBuildingType As gbXMLBuildingType, _
    doc As Document _
) As String
Visual C++
public:
static String^ GetLabelFor(
    gbXMLBuildingType gbXMLBuildingType,
    Document^ doc
)

Parameters

gbXMLBuildingType
Type: Autodesk.Revit.DB.Analysis..::..gbXMLBuildingType
The gbXMLBuildingType to get the user-visible name.
doc
Type: Autodesk.Revit.DB..::..Document
The document from which to get the gbXMLBuildingType.

Remarks

The name is obtained in the current Revit language.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-"doc"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the gbXMLBuildingType cannot be found.

See Also

LabelUtils Class
GetLabelFor Overload

GetLabelFor Method (PipeFlowState, Document)

[image]