Revit 2013 API
MEPSystem Properties
MEPSystem Class See Also Send Feedback

The MEPSystem type exposes the following members.

Properties

 | Name | Description
Public property | BaseEquipment | The base panel or equipment of the system.
Public property | BaseEquipmentConnector | The connector within base equipment which is used to connect with system.
Public property | ConnectorManager | Connector manager of the system.
Public property | Elements | Terminal elements in the system.
Public property | IsDefaultSystem | Indicates if the system is a default system or not.
Public property | IsEmpty | Indicates if the system is empty or not.
Public property | IsValid | Indicates if the system is valid or not. atom AtomValidateSystem default false setter setIsValid public_api
Public property | PressureLossOfCriticalPath | The total pressure loss of the sections in critical path.
Public property | SectionsCount | The number of sections.

See Also

MEPSystem Class

BaseEquipment Property

[image]