Revit 2013 API
EnergyDataSettings Class
Members Example See Also Send Feedback
This element contains settings for gbXML Export and Heating and Cooling Load Calculations and project level settings for Conceptual Energy Analysis. for serialization

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class EnergyDataSettings : IDisposable
Visual Basic
Public Class EnergyDataSettings _
    Implements IDisposable
Visual C++
public ref class EnergyDataSettings : IDisposable

Examples

CopyC#
public void GetInfo_EnergyData(Document document)
{
   EnergyDataSettings energyData = EnergyDataSettings.GetFromDocument(document);

   if (null != energyData)
    {
        string message = "energyData : ";
        message += "\nBuildingType : " + energyData.BuildingType;
        TaskDialog.Show("Revit",message);
    }
}
CopyVB.NET
Public Sub GetInfo_EnergyData(ByVal document As Document)
    Dim energyData As Autodesk.Revit.DB.Analysis.EnergyDataSettings = Autodesk.Revit.DB.Analysis.EnergyDataSettings.GetFromDocument(document)

    If energyData IsNot Nothing Then
        Dim message As String = "energyData : "
        message += vbLf & "BuildingType : " + energyData.BuildingType
        TaskDialog.Show("Revit", message)
    End If
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Analysis..::..EnergyDataSettings

See Also

EnergyDataSettings Members
Autodesk.Revit.DB.Analysis Namespace

EnergyDataSettings Members

[image] [image]