Revit 2013 API
Parameter Methods
Parameter Class See Also Send Feedback

The Parameter type exposes the following members.

Methods

 | Name | Description
Public method | AsDouble | Provides access to the double precision number within the parameter.
Public method | AsElementId | Provides access to the Autodesk::Revit::DB::ElementId^ stored within the parameter.
Public method | AsInteger | Provides access to the integer number within the parameter.
Public method | AsString | Provides access to the string contents of the parameter.
Public method | AsValueString | Get the parameter value as a string with unit.
Public method | Set(Double) | Sets the parameter to a new real number value.
Public method | Set(Int32) | Sets the parameter to a new integer value.
Public method | Set(String) | Sets the parameter to a new string of text.
Public method | Set(ElementId) | Sets the parameter to a new element id.
Public method | SetValueString | Set the parameter value according to the input string.

See Also

Parameter Class

AsDouble Method

[image]