Revit 2013 API
CompoundStructure..::..IsVerticallyCompound Property
CompoundStructure Class See Also Send Feedback
Identifies if this CompoundStructure represents a layout that is more complicated than a simple set of parallel layers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsVerticallyCompound { get; }
Visual Basic
Public ReadOnly Property IsVerticallyCompound As Boolean
    Get
Visual C++
public:
property bool IsVerticallyCompound {
    bool get ();
}

Field Value

If true, then the layers of this CompoundStructure may be arranged into a grid pattern in two-dimension; otherwise it is a simple compound structure with a single set of parallel layers.

Remarks

Vertically compound structures should be assigned only to walls.

See Also

CompoundStructure Class

LayerCount Property

[image]