Revit 2013 API
ViewFamilyType..::..PlanViewDirection Property
ViewFamilyType Class See Also Send Feedback
The PlanViewDirection of this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public PlanViewDirection PlanViewDirection { get; set; }
Visual Basic
Public Property PlanViewDirection As PlanViewDirection
    Get
    Set
Visual C++
public:
property PlanViewDirection PlanViewDirection {
    PlanViewDirection get ();
    void set (PlanViewDirection value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: Cannot set PlanViewDirection to Undefined
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: View must be a Structural Plan

See Also

ViewFamilyType Class

ViewFamily Property

[image]