Revit 2013 API
ExporterIFCUtils..::..ExportFamilyInstanceAsExtrusion Method (ExporterIFC, FamilyInstance, Boolean, ElementId, IFCExtrusionCreationData)
ExporterIFCUtils Class See Also Send Feedback
Creates a single extruded solid handle to represent the given family instance.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static IFCFamilyInstanceExtrusionExportResults ExportFamilyInstanceAsExtrusion(
    ExporterIFC exporterIFC,
    FamilyInstance familyInstance,
    bool useInstanceGeometry,
    ElementId overrideLevelId,
    IFCExtrusionCreationData extraParams
)
Visual Basic
Public Shared Function ExportFamilyInstanceAsExtrusion ( _
    exporterIFC As ExporterIFC, _
    familyInstance As FamilyInstance, _
    useInstanceGeometry As Boolean, _
    overrideLevelId As ElementId, _
    extraParams As IFCExtrusionCreationData _
) As IFCFamilyInstanceExtrusionExportResults
Visual C++
public:
static IFCFamilyInstanceExtrusionExportResults^ ExportFamilyInstanceAsExtrusion(
    ExporterIFC^ exporterIFC,
    FamilyInstance^ familyInstance,
    bool useInstanceGeometry,
    ElementId^ overrideLevelId,
    IFCExtrusionCreationData^ extraParams
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
familyInstance
Type: Autodesk.Revit.DB..::..FamilyInstance
The family instance to export.
useInstanceGeometry
Type: System..::..Boolean
True to use the geometry of the instance (with the transformation applied to the geometry). False to use the geometry of the symbol.
overrideLevelId
Type: Autodesk.Revit.DB..::..ElementId
Id of the level to which the geometry should be related.
extraParams
Type: Autodesk.Revit.DB.IFC..::..IFCExtrusionCreationData
The extrusion creation data to associate with the created extrusion.

Return Value

The results of the export operation.

Remarks

The return value includes the extruded solid handle, the best material id to assign to it, an "extra offset" calculated during the extrusion process, and a collection of "openings" (extrusions which cut the base handle). This routine currently only works for families which consist of one Extrusion element. If the function fails, HasValue for the handle returned will be false.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
ExportFamilyInstanceAsExtrusion Overload
Autodesk.Revit.DB.IFC Namespace

ExportFamilyInstanceAsExtrusion Method (ExporterIFC, FamilyInstance, Boolean, IFCRange, ElementId, IFCExtrusionCreationData)

[image]