Revit 2013 API
BuiltInFailures..::..SiteFailures Members
BuiltInFailures..::..SiteFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..SiteFailures type exposes the following members.

Properties

Name | Description
BuildingPadNotConnected | Can't create a single Pad with several connected regions.
BuildingPadOverlap | Pads can't overlap (but can share edges).
CannotComputeProperArea | Property Lines must close. Area will not be computed.
CannotIntersectSiteRegions | Subregions cannot intersect.
CannotMakeSurface | Can't construct surface.
ContourLabelEmpty | Contour Label doesn't intersect any contours.
EnterValueOrFormula | Enter a value or a formula starting with '='.
GradingInSamePhase | The Surface being Graded was created in the current Phase. Grading it will result in it being created and destroyed in the same Phase.
NoHostForRegion | Subregion does not appear to overlap a Toposurface with an appropriate Phase and Design Option.
NoHostForRegionWarn | Subregion does not appear to overlap a Toposurface with an appropriate Phase and Design Option.
NoSurfPatternOnSite | Topographical surfaces do not support surface patterns. The surface pattern associated with this material will not be displayed on the indicated surface.
NotEnoughPointsInSurface | The surface must have at least three distinct Points.
PointNotInSurface | A Point is outside of the Surface boundary. Insert the Point on the boundary instead, and then drag it to the desired location.
PointRelativeOutside | In order to place Points relative to the existing Surface, the Point must be placed within the area of the existing Surface. The height of the new Point will be relative to the current Surface elevation at that Point.
PropertyIntersect | Property lines intersect. Area calculations will not be precise.
RegionPhaseMismatch | Subregions must have the same Phase Created parameter and Phase Demolished parameter as the host Toposurface. Subregion phase will be set to match the Toposurface.
ResetToposurfacePhaseCreated | The parameter Phase Created of the Toposurface is not set to the first Phase. No pre-existing toposurface were detected. The parameter will be reset to the first Phase unless Keep Phase Created option is picked.
SiteEditPointsClipped | Portions of the topographic surface or points on the surface may not be visible in this view due to clipping by the view.
SiteEditPointsInvisible | In your currently active view, topographic elements are not visible. You can change the visibility settings from the View menu, but it is recommended that you edit topography in either a Site view or a 3D view, as undesired clipping can occur in other views.
SiteMergeDisconnected | The two surfaces you are trying to merge are disconnected from one another. They should overlap, or at least share edges.
SitePhasesDontOverlap | The phases of the two surfaces you are merging do not overlap. You can continue the operation, or cancel it and select a different pair of surfaces.
SiteRegionOptionConflict | Subregions must be in the same Design Option as their Toposurface.
SurfaceSelfIntersection | The splitting boundary drawn would result in a self-intersection of the surface boundary. Please edit your splitting lines to correct the problem.
SurfaceSplit | The splitting boundary must split the Surface into exactly two pieces.
SurfaceSplitError | The splitting boundary must split the Surface into exactly two pieces.
SurfaceSplitNoIntersection | The splitting boundary must divide the Surface into separate pieces. There may be a gap in the splitting Lines or the Sketch may be incomplete.
SurfaceTriangulationFailed | The Site Surface failed to triangulate.

See Also

BuiltInFailures..::..SiteFailures Class

BuiltInFailures.SiteFailures Properties

[image] [image]