Revit 2013 API
AnalyticalModel..::..IsValidProjectionDatumPlane Method
AnalyticalModel Class See Also Send Feedback
Indicates if a given Datum Plane is valid for analytical model projection with respect to the given analytical direction.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsValidProjectionDatumPlane(
    AnalyticalElementSelector selector,
    AnalyticalDirection direction,
    ElementId datumPlaneId
)
Visual Basic
Public Function IsValidProjectionDatumPlane ( _
    selector As AnalyticalElementSelector, _
    direction As AnalyticalDirection, _
    datumPlaneId As ElementId _
) As Boolean
Visual C++
public:
bool IsValidProjectionDatumPlane(
    AnalyticalElementSelector selector,
    AnalyticalDirection direction,
    ElementId^ datumPlaneId
)

Parameters

selector
Type: Autodesk.Revit.DB.Structure..::..AnalyticalElementSelector
End of the analytical model.
direction
Type: Autodesk.Revit.DB.Structure..::..AnalyticalDirection
Direction of analytical model projection.
datumPlaneId
Type: Autodesk.Revit.DB..::..ElementId
Datum Plane on to which analytical model is projected.

Return Value

True if Datum Plane is valid, false otherwise.

Remarks

Validity of a Datum Plane for analytical projection is both element and context specific. For instance, two different Beams may have two different results.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace

IsValidProjectionType Method

[image]