Revit 2013 API
EnergyDataSettings..::..BuildingType Property
EnergyDataSettings Class See Also Send Feedback
The type of building.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public gbXMLBuildingType BuildingType { get; set; }
Visual Basic
Public Property BuildingType As gbXMLBuildingType
    Get
    Set
Visual C++
public:
property gbXMLBuildingType BuildingType {
    gbXMLBuildingType get ();
    void set (gbXMLBuildingType value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The building type does not fall within an appropriate range.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace

CreateAnalyticalModel Property

[image]