Revit 2013 API
AnalyticalModel..::..GetAnalyticalOffset Method
AnalyticalModel Class See Also Send Feedback
Retrieves Analytical Offset in the case where the user can do that.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2012. Call getOffset() instead.")]
public XYZ GetAnalyticalOffset()
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2012. Call getOffset() instead.")> _
Public Function GetAnalyticalOffset As XYZ
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2012. Call getOffset() instead.")]
public:
XYZ^ GetAnalyticalOffset()

Return Value

Offset of Analytical Model.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InapplicableDataException | This AnalyticalModel does not support offset.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace

GetAnalyticalProjectionDatumPlane Method

[image] [image]