Revit 2013 API
WallSweepInfo..::..IsFixed Property
WallSweepInfo Class See Also Send Feedback
Indicates if the described wall sweep is fixed. A sweep is fixed if it is a part of a vertical compound structure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool IsFixed { get; }
Visual Basic
Public ReadOnly Property IsFixed As Boolean
    Get
Visual C++
public:
property bool IsFixed {
    bool get ();
}

Field Value

True if it is fixed, false if it is allowed to be moved.

Remarks

Wall sweeps from the definition of a vertical compound structure are fixed based on the wall type's definition. They are not permitted to be moved by users. Other wall sweeps defined outside of CompoundStructure by UI or API are permitted to be moved.

See Also

WallSweepInfo Class

IsProfileFlipped Property

[image]