Revit 2013 API
FamilyInstance Class
Members Example See Also Send Feedback
This object represents a single instance of a family type, such as a single I beam.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class FamilyInstance : Instance
Visual Basic
Public Class FamilyInstance _
    Inherits Instance
Visual C++
public ref class FamilyInstance : public Instance

Remarks

Examples of FamilyInstance objects within Autodesk Revit are Beams, Columns, Braces and Desks. The FamilyInstance object provides more detailed properties that enable the type of the family instance to be changed, thus changing their appearance within the project.

Examples

CopyC#
public void GetInfo_FamilyInstance(FamilyInstance familyInstance)
{
    string message = "FamilyInstance : ";
    // Get FamilyInstance AnalyticalModel type
    if (null != familyInstance.GetAnalyticalModel())
    {
        message += "\nFamilyInstance AnalyticalModel is : " + familyInstance.GetAnalyticalModel();
    }

    // Get FamilyInstance host name
    if (familyInstance.Host != null)
    {
        message += "\nFamilyInstance host name is : " + familyInstance.Host.Name;
    }

    // Get FamilyInstance Material
    foreach (Material material in familyInstance.Materials)
    {
       message += "\nFamilyInstance Material is : " + material.Name;
    }
    // Get FamilyInstance room name
    if (familyInstance.Room != null)
    {
        message += "\nFamilyInstance room name is : " + familyInstance.Room.Name;
    }

    // Get FamilyInstance structural type
    message += "\nFamilyInstance structural type is : " + familyInstance.StructuralType;

    // Get FamilyInstance structural usage
    message += "\nFamilyInstance structural usage is : " + familyInstance.StructuralUsage;

    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Public Sub GetInfo_FamilyInstance(ByVal familyInstance As Autodesk.Revit.DB.FamilyInstance)
    Dim message As String = "FamilyInstance : "
    ' Get FamilyInstance AnalyticalModel type
    If familyInstance.GetAnalyticalModel() IsNot Nothing Then
        message += vbLf & "FamilyInstance AnalyticalModel is : " & familyInstance.GetAnalyticalModel().ToString()
    End If

    ' Get FamilyInstance host name
    If familyInstance.Host IsNot Nothing Then
        message += vbLf & "FamilyInstance host name is : " + familyInstance.Host.Name
    End If

    ' Get FamilyInstance Material
    For Each material As Autodesk.Revit.DB.Material In familyInstance.Materials
        message += vbLf & "FamilyInstance Material is : " + material.Name
    Next
    ' Get FamilyInstance room name
    If familyInstance.Room IsNot Nothing Then
        message += vbLf & "FamilyInstance room name is : " + familyInstance.Room.Name
    End If

    ' Get FamilyInstance structural type
    message += vbLf & "FamilyInstance structural type is : " + familyInstance.StructuralType

    ' Get FamilyInstance structural usage
    message += vbLf & "FamilyInstance structural usage is : " + familyInstance.StructuralUsage

    TaskDialog.Show("Revit", message)
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..Instance
Autodesk.Revit.DB..::..FamilyInstance
Autodesk.Revit.DB..::..AnnotationSymbol
Autodesk.Revit.DB..::..Mullion
Autodesk.Revit.DB..::..Panel

See Also

FamilyInstance Members

FamilyInstance Members

[image] [image]