Revit 2013 API
PartUtils Members
PartUtils Class Methods See Also Send Feedback

The PartUtils type exposes the following members.

Methods

 | Name | Description
 | AreElementsValidForCreateParts | Identifies if the given elements can be used to create parts.
 | AreElementsValidForDivide | Obsolete. Identifies if provided members are valid for dividing parts.
 | AreElementsValidIntersectingReferences | Obsolete. Identifies if provided members are valid.
 | ArePartsValidForDivide | Identifies if provided members are valid for dividing parts.
 | ArePartsValidForMerge | Identifies whether Part elements may be merged.
 | CreateMergedPart | Create a single merged part which represents the Parts specified by partsToMerge.
 | CreateParts(Document, ICollection<(Of <<'(ElementId>)>>)) | Creates a new set of parts out of the original elements.
 | CreateParts(Document, ICollection<(Of <<'(LinkElementId>)>>)) | Creates a new set of parts out of the original elements.
Public method | Dispose | Releases all resources used by the PartUtils
 | DivideParts | Creates divided parts out of parts.
 | FindMergeableClusters | Segregates a set of elements into subsets which are valid for merge.
 | GetAssociatedPartMaker(Document, ElementId) | Gets associated PartMaker for an element.
 | GetAssociatedPartMaker(Document, LinkElementId) | Gets associated PartMaker for an element.
 | GetAssociatedParts(Document, ElementId, Boolean, Boolean) | Returns all Parts that are associated with the given element.
 | GetAssociatedParts(Document, LinkElementId, Boolean, Boolean) | Returns all Parts that are associated with the given element
 | GetChainLengthToOriginal | Calculates the length of the longest chain of divisions/merges to reach to an original non-Part element that is the source of the tested part.
 | GetDividedParents | Obsolete. Returns an array of elements that lead to the creation of this Part.
 | GetMergedParts | Retrieves the element ids of the source elements of a merged part.
 | GetOffsetForIntersectingReference | Obsolete. Get offset for the intersecting reference.
 | GetPartMakerMethodToDivideVolume | Obtains the object allowing access to the divided volume properties of the PartMaker.
 | HasAssociatedParts(Document, ElementId) | Checks if an element has associated parts.
 | HasAssociatedParts(Document, LinkElementId) | Checks if an element has associated parts.
 | IsMaxDivisionDepthReached | Obsolete. Identifies if elements have reached their maximum division depth.
 | IsMergedPart | Is the Part the result of a merge.
 | IsPartDerivedFromLink | Is the Part derived from link geometry.
 | IsValidForCreateParts | Identifies if the given element can be used to create parts.
 | IsValidSketchPlane | Obsolete. Identifies if provided sketch plane is valid.
 | PartMakerUsesReference | Obsolete. Identifies if the PartMaker uses the intersecting reference.
 | SetOffsetForIntersectingReference | Obsolete. Set offset for the intersecting reference.

See Also

PartUtils Class

PartUtils Methods

[image] [image]