Revit 2013 API
PushButtonData Members
PushButtonData Class Constructors Methods Properties See Also Send Feedback

The PushButtonData type exposes the following members.

Constructors

 | Name | Description
Public method | PushButtonData | Constructs a new instance of PushButtonData.

Methods

 | Name | Description

Properties

 | Name | Description
Public property | AssemblyName | The assembly path of the button.
Public property | AvailabilityClassName | The full class name for the class providing the entry point to decide availability of this push button.
Public property | ClassName | The name of the class containing the implementation for the command.

See Also

PushButtonData Class
Autodesk.Revit.UI Namespace

PushButtonData Constructor

[image]