Revit 2013 API
UpdaterRegistry..::..AddTrigger Method (UpdaterId, Document, ElementFilter, ChangeType)
UpdaterRegistry Class See Also Send Feedback
Adds trigger with the specified element filter and ChangeType for the specified document

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static void AddTrigger(
    UpdaterId id,
    Document doc,
    ElementFilter filter,
    ChangeType change
)
Visual Basic
Public Shared Sub AddTrigger ( _
    id As UpdaterId, _
    doc As Document, _
    filter As ElementFilter, _
    change As ChangeType _
)
Visual C++
public:
static void AddTrigger(
    UpdaterId^ id,
    Document^ doc,
    ElementFilter^ filter,
    ChangeType^ change
)

Parameters

id
Type: Autodesk.Revit.DB..::..UpdaterId
Id of updater that trigger should be added to
doc
Type: Autodesk.Revit.DB..::..Document
Document that elements in 'elements' are contained in
filter
Type: Autodesk.Revit.DB..::..ElementFilter
Element filter that defines elements that affect this trigger
change
Type: Autodesk.Revit.DB..::..ChangeType
ChangeType associated with this trigger

Remarks

This method only works with CategoryFilter and ParameterFilter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | updater's owner AddIn does not match currently active AddIn -or- id does not correspond to any registered Updaters -or- AddTrigger called while executing an updater.

See Also

UpdaterRegistry Class
AddTrigger Overload

AddTrigger Method (UpdaterId, Document, ICollection(ElementId), ChangeType)

[image]