Revit 2013 API
FamilyInstance..::..SubComponents Property
FamilyInstance Class Example See Also Send Feedback
Property to get the sub components of current family instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This property is obsolete in Revit 2013.  Call GetSubComponentIds() instead.")]
public ElementSet SubComponents { get; }
Visual Basic
<ObsoleteAttribute("This property is obsolete in Revit 2013.  Call GetSubComponentIds() instead.")> _
Public ReadOnly Property SubComponents As ElementSet
    Get
Visual C++
[ObsoleteAttribute(L"This property is obsolete in Revit 2013.  Call GetSubComponentIds() instead.")]
public:
property ElementSet^ SubComponents {
    ElementSet^ get ();
}

Remarks

When the FamilyInstance has no sub component, it returns nullNothingnullptra null reference (Nothing in Visual Basic)

Examples

CopyC#
public void GetSubAndSuperComponents(FamilyInstance familyInstance)
{
    ElementSet subElemSet = familyInstance.SubComponents;
    if (subElemSet != null)
    {
        string subElems = "";
        foreach (Autodesk.Revit.DB.Element ee in subElemSet)
        {
            FamilyInstance f = ee as FamilyInstance;
            subElems = subElems + f.Name + "\n";
        }
        TaskDialog.Show("Revit","Subcomponent count = " + subElemSet.Size + "\n" + subElems);
    }
    FamilyInstance super = familyInstance.SuperComponent as FamilyInstance;
    if (super != null)
    {
        TaskDialog.Show("Revit","SUPER component: " + super.Name);
    }
}
CopyVB.NET
Public Sub GetSubAndSuperComponents(ByVal familyInstance As Autodesk.Revit.DB.FamilyInstance)
    Dim subElemSet As ElementSet = familyInstance.SubComponents
    If subElemSet IsNot Nothing Then
        Dim subElems As String = ""
        For Each ee As Autodesk.Revit.DB.Element In subElemSet
            Dim f As Autodesk.Revit.DB.FamilyInstance = TryCast(ee, Autodesk.Revit.DB.FamilyInstance)
            subElems = subElems + f.Name + vbLf
        Next
        TaskDialog.Show("Revit", "Subcomponent count = " + subElemSet.Size + vbLf + subElems)
    End If
    Dim super As Autodesk.Revit.DB.FamilyInstance = TryCast(familyInstance.SuperComponent, Autodesk.Revit.DB.FamilyInstance)
    If super IsNot Nothing Then
        TaskDialog.Show("Revit", "SUPER component: " + super.Name)
    End If
End Sub

See Also

FamilyInstance Class

SuperComponent Property

[image]