Revit 2013 API
ExporterIFCUtils..::..ConvertUnits Method
ExporterIFCUtils Class See Also Send Feedback
Converts a value from universal units to display units.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static double ConvertUnits(
    Document Doc,
    double value,
    DisplayUnitType displayUnitType
)
Visual Basic
Public Shared Function ConvertUnits ( _
    Doc As Document, _
    value As Double, _
    displayUnitType As DisplayUnitType _
) As Double
Visual C++
public:
static double ConvertUnits(
    Document^ Doc,
    double value,
    DisplayUnitType displayUnitType
)

Parameters

Doc
Type: Autodesk.Revit.DB..::..Document
The document.
value
Type: System..::..Double
The value to be converted.
displayUnitType
Type: Autodesk.Revit.DB..::..DisplayUnitType
The display unit type.

Return Value

The converted value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace

CreateAlternateGUID Method

[image]