Revit 2013 API
Application..::..NewHermiteSpline Method (IList<(Of <(<'XYZ>)>)>, Boolean)
Application Class See Also Send Feedback
Creates a Hermite spline with default tangency at its endpoints.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public HermiteSpline NewHermiteSpline(
    IList<XYZ> ctrlPoints,
    bool bPeriodic
)
Visual Basic
Public Function NewHermiteSpline ( _
    ctrlPoints As IList(Of XYZ), _
    bPeriodic As Boolean _
) As HermiteSpline
Visual C++
public:
HermiteSpline^ NewHermiteSpline(
    IList<XYZ^>^ ctrlPoints,
    bool bPeriodic
)

Parameters

ctrlPoints
Type: System.Collections.Generic..::..IList<(Of <(<'XYZ>)>)>
The control points of the Hermite spline.
bPeriodic
Type: System..::..Boolean
True if the Hermite spline is to be periodic.

Remarks

The tangents at the ends of the spline are computed from the control points.

See Also

Application Class
NewHermiteSpline Overload
Autodesk.Revit.Creation Namespace

NewHermiteSpline Method (IList(XYZ), Boolean, XYZ, XYZ)

[image]