Revit 2013 API
PushButton Class
Members Example See Also Send Feedback
The PushButton object represents an button on a RibbonPanel.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public class PushButton : RibbonButton
Visual Basic
Public Class PushButton _
    Inherits RibbonButton
Visual C++
public ref class PushButton : public RibbonButton

Remarks

Use of this class is not supported in Revit Macros.

Examples

CopyC#
private void AddPushButton(RibbonPanel panel)
{
    PushButton pushButton = panel.AddItem(new PushButtonData("HelloWorld",
        "HelloWorld", @"D:\HelloWorld.dll", "HelloWorld.CsHelloWorld")) as PushButton;

    pushButton.ToolTip = "Say Hello World";
    // Set the large image shown on button
    pushButton.LargeImage =
        new BitmapImage(new Uri(@"D:\Sample\HelloWorld\bin\Debug\39-Globe_32x32.png"));
}
CopyVB.NET
Private Sub AddPushButton(ByVal panel As RibbonPanel)
    Dim pushButton As PushButton = TryCast(panel.AddItem(New PushButtonData("HelloWorld", "HelloWorld", "D:\HelloWorld.dll", "HelloWorld.CsHelloWorld")), PushButton)

    pushButton.ToolTip = "Say Hello World"
    ' Set the large image shown on button
    pushButton.LargeImage = New BitmapImage(New Uri("D:\Sample\HelloWorld\bin\Debug\39-Globe_32x32.png"))
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.UI..::..RibbonItem
Autodesk.Revit.UI..::..RibbonButton
Autodesk.Revit.UI..::..PushButton
Autodesk.Revit.UI..::..ToggleButton

See Also

PushButton Members
Autodesk.Revit.UI Namespace

PushButton Members

[image] [image]