Revit 2013 API
FormatUtils..::..Format Method
FormatUtils Class See Also Send Feedback
Formats a value into a user-visible string based on the default display units for a document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static string Format(
    Document document,
    UnitType unitType,
    double value
)
Visual Basic
Public Shared Function Format ( _
    document As Document, _
    unitType As UnitType, _
    value As Double _
) As String
Visual C++
public:
static String^ Format(
    Document^ document,
    UnitType unitType,
    double value
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
unitType
Type: Autodesk.Revit.DB..::..UnitType
The unit type for the input value.
value
Type: System..::..Double
The value to format.

Return Value

The formatted string.

Remarks

The default display units for the input unit type and document will be used. Default settings will also be used for rounding.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given value for value is not finite -or- The given value for value is not a number
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements).

See Also

FormatUtils Class

FormUtils Class

[image]