Revit 2013 API
FabricSheet Members
FabricSheet Class Methods Properties See Also Send Feedback

The FabricSheet type exposes the following members.

Methods

 | Name | Description
Public method | GetWireCenterlines()()()() | A list of curves representing the wires centerlines of the Fabric Sheet in the both distribution directions.
Public method | GetWireCenterlines(WireDistributionDirection) | A list of curves representing the wires centerlines of the Fabric Sheet.

Properties

 | Name | Description
Public property | CutOverallLength | Sheet Length after cutting
Public property | CutOverallWidth | Sheet Width after cutting
Public property | CutSheetMass | Gets the sheet mass after cutting
Public property | FabricAreaOwnerId | Fabric Area (Region Element) Id.
Public property | SheetTypeId | Fabric Sheet Type Id.

See Also

FabricSheet Class
Autodesk.Revit.DB.Structure Namespace

FabricSheet Methods

[image] [image]