Revit 2013 API
PanelScheduleView..::..GetFontId Method (String, Double, Color)
PanelScheduleView Class See Also Send Feedback
Gets the font id for the combination of font name, size, and color

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementId GetFontId(
    string fontName,
    double fontSize,
    Color fontColor
)
Visual Basic
Public Function GetFontId ( _
    fontName As String, _
    fontSize As Double, _
    fontColor As Color _
) As ElementId
Visual C++
public:
ElementId^ GetFontId(
    String^ fontName,
    double fontSize,
    Color^ fontColor
)

Parameters

fontName
Type: System..::..String
The font's name
fontSize
Type: System..::..Double
The font's size
fontColor
Type: Autodesk.Revit.DB..::..Color
The font's color

Return Value

The id of the font

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PanelScheduleView Class
GetFontId Overload
Autodesk.Revit.DB.Electrical Namespace

GetFontId Method (SectionType, Int32, Int32)

[image]