Revit 2013 API
PointCloudFilter Members
PointCloudFilter Class Methods See Also Send Feedback

The PointCloudFilter type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Returns a copy of the filter. The engine is permitted to copy the filter multiple times e.g. to parallelize filtering.
Public method | Dispose | Releases all resources used by the PointCloudFilter
Public method | PrepareForCell | Informs the filter that a series of points within a given cell is about to be checked.
Public method | TestCell | Checks whether a given cell, i.e. a box aligned with the XYZ axes, is inside, outside or on the border of the volume of interest.
Public method | TestPoint | Checks if a point is inside the volume of interest.

See Also

PointCloudFilter Class
Autodesk.Revit.DB.PointClouds Namespace

PointCloudFilter Methods

[image] [image]