Revit 2013 API
UIDocument Members
UIDocument Class Constructors Methods Properties See Also Send Feedback

The UIDocument type exposes the following members.

Constructors

 | Name | Description
Public method | UIDocument | Use a database level Document to construct a UI-level Document.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the UIDocument
Public method | GetOpenUIViews | Get a list of all open view windows in the Revit user interface.
 | GetRevitUIFamilyLoadOptions | Return the option object that allows you to use Revit's dialog boxes to let the user respond to questions that arise during loading of families.
Public method | PromptForFamilyInstancePlacement | Prompts the user to place instances of the specified FamilySymbol.
Public method | RefreshActiveView | Refresh the display of the active view in the active document.
Public method | SaveAndClose | Close the document, prompting the user for saving it when necessary.
Public method | SaveAs | Saves the document to a file name obtained from the Revit user.
Public method | ShowElements(Element) | Shows the element by zoom to fit.
Public method | ShowElements(ElementId) | Shows the element by zoom to fit.
Public method | ShowElements(ICollection<(Of <<'(ElementId>)>>)) | Shows the elements by zoom to fit.
Public method | ShowElements(ElementSet) | Shows the elements by zoom to fit.

Properties

 | Name | Description
Public property | ActiveView | The currently active view of the currently active document.
Public property | Application | Retrieves an object that represents the current Application.
Public property | Document | Returns the database level document represented by this UI-level document.
Public property | Selection | Retrieve the currently selected Elements in Autodesk Revit.

See Also

UIDocument Class
Autodesk.Revit.UI Namespace

UIDocument Constructor

[image]