Revit 2013 API
View..::..SetWorksharingDisplayMode Method
View Class See Also Send Feedback
Sets the worksharing display mode for this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetWorksharingDisplayMode(
    WorksharingDisplayMode displayMode
)
Visual Basic
Public Sub SetWorksharingDisplayMode ( _
    displayMode As WorksharingDisplayMode _
)
Visual C++
public:
void SetWorksharingDisplayMode(
    WorksharingDisplayMode displayMode
)

Parameters

displayMode
Type: Autodesk.Revit.DB..::..WorksharingDisplayMode
The desired display mode. "Off" will turn off all worksharing display modes.

Remarks

Turning on a worksharing display mode will disable other temporary view modes such as reveal hidden elements and temporary hide/isolate.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | This View does not support the requested worksharing display mode.

See Also

View Class

ShowActiveWorkPlane Method

[image]