Revit 2013 API
EnergyAnalysisDetailModel Methods
EnergyAnalysisDetailModel Class See Also Send Feedback

The EnergyAnalysisDetailModel type exposes the following members.

Methods

 | Name | Description
 | Create | Creates a new energy analysis detailed model.
 | Destroy | Delete the created analytical model and the analytical elements such as spaces, surfaces, and openings.
Public method | Dispose |
Public method | GetAnalyticalOpenings | The collection of analytical openings.
Public method | GetAnalyticalShadingSurfaces | The collection of analytical shading surfaces.
Public method | GetAnalyticalSpaces | The collection of analytical spaces.
Public method | GetAnalyticalSurfaces | The collection of analytical surfaces.
Public method | TransformModel | Transforms all surfaces in the model according to the document's active ground plane, shared coordinates and true north.

See Also

EnergyAnalysisDetailModel Class
Autodesk.Revit.DB.Analysis Namespace

Create Method

[image]