Revit 2013 API
TransactionGroup..::..Commit Method
TransactionGroup Class See Also Send Feedback
Commits the transaction group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public TransactionStatus Commit()
Visual Basic
Public Function Commit As TransactionStatus
Visual C++
public:
TransactionStatus Commit()

Return Value

If finished successfully, this method returns TransactionStatus.Committed.

Remarks

Committing a group does not change the model. It only confirms the commitment of all inner groups and transactions.

Commit can be called only when all inner transaction groups and transactions are finished, i.e. after they were either committed or rolled back. If there is still a transaction or an inner transaction group open, an attempt to commit this outer group will cause an exception.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The Transaction group has not been started (its status is not 'Started').. -or- The transaction's document is currently in failure mode. Transaction groups cannot be closed until failure handling is finished. You may use a transaction finalizer to close a group after the failure handling ends.

See Also

TransactionGroup Class

Dispose Method

[image]