Revit 2013 API
RenderingSettings..::..PrinterResolution Property
RenderingSettings Class See Also Send Feedback
The resolution level when using printer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public PrinterResolution PrinterResolution { get; set; }
Visual Basic
Public Property PrinterResolution As PrinterResolution
    Get
    Set
Visual C++
public:
property PrinterResolution PrinterResolution {
    PrinterResolution get ();
    void set (PrinterResolution value);
}

Remarks

The suitable resolution value is decided by default. You may obtain it from the ResolutionValue property.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The enum value is not invalid for PrinterResolution.
Autodesk.Revit.Exceptions..::..InvalidOperationException | The resolution target is not printer.

See Also

RenderingSettings Class

ResolutionTarget Property

[image]