Revit 2013 API
ScheduleDefinition..::..AddFilter Method
ScheduleDefinition Class See Also Send Feedback
Adds a new filter at the end of the list.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void AddFilter(
    ScheduleFilter filter
)
Visual Basic
Public Sub AddFilter ( _
    filter As ScheduleFilter _
)
Visual C++
public:
void AddFilter(
    ScheduleFilter^ filter
)

Parameters

filter
Type: Autodesk.Revit.DB..::..ScheduleFilter
The filter to add.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The field ID is not the ID of a field in this ScheduleDefinition. -or- The field and filter type cannot be used to filter this ScheduleDefinition. -or- The filter value is not valid for the field and filter type.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | This ScheduleDefinition does not support filters. -or- The resulting filter count would be greater than 4.

See Also

ScheduleDefinition Class

AddSortGroupField Method

[image]