Revit 2013 API
Application..::..NewTextNoteCreationData Method (View, XYZ, XYZ, XYZ, Double, TextAlignFlags, String)
Application Class See Also Send Feedback
Creates an object which wraps the arguments of NewTextNote() for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public TextNoteCreationData NewTextNoteCreationData(
    View theView,
    XYZ origin,
    XYZ baseVec,
    XYZ upVec,
    double lineWidth,
    TextAlignFlags textAlign,
    string strText
)
Visual Basic
Public Function NewTextNoteCreationData ( _
    theView As View, _
    origin As XYZ, _
    baseVec As XYZ, _
    upVec As XYZ, _
    lineWidth As Double, _
    textAlign As TextAlignFlags, _
    strText As String _
) As TextNoteCreationData
Visual C++
public:
TextNoteCreationData^ NewTextNoteCreationData(
    View^ theView,
    XYZ^ origin,
    XYZ^ baseVec,
    XYZ^ upVec,
    double lineWidth,
    TextAlignFlags textAlign,
    String^ strText
)

Parameters

theView
Type: Autodesk.Revit.DB..::..View
The view where the text note object will be visible.
origin
Type: Autodesk.Revit.DB..::..XYZ
The origin of the text note.
baseVec
Type: Autodesk.Revit.DB..::..XYZ
The horizontal direction for text in the text note.
upVec
Type: Autodesk.Revit.DB..::..XYZ
The vertical direction for text in the text note.
lineWidth
Type: System..::..Double
The width of the rectangle bounding the note text.
textAlign
Type: Autodesk.Revit.DB..::..TextAlignFlags
Flags indicating the alignment of the note. This should be a bitwise OR including one of TEF_ALIGN_TOP, TEF_ALIGN_MIDDLE and TEF_ALIGN_BOTTOM and one of TEF_ALIGN_LEFT, TEF_ALIGN_CENTER and TEF_ALIGN_RIGHT. The defaults for this flag are TEF_ALIGN_TOP | TEF_ALIGN_LEFT.
strText
Type: System..::..String
Text to display in the text note. Include new line characters to force a multiple line note to be created. Notes may also wrap automatically based on the width of the note rectangle.

See Also

Application Class
NewTextNoteCreationData Overload
Autodesk.Revit.Creation Namespace

NewTextNoteCreationData Method (View, XYZ, XYZ, XYZ, Double, TextAlignFlags, TextNoteLeaderTypes, TextNoteLeaderStyles, XYZ, XYZ, String)

[image]