Revit 2013 API
Document..::..NewRoomTag Method
Document Class Example See Also Send Feedback
Creates a new RoomTag.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public RoomTag NewRoomTag(
    Room room,
    UV point,
    View view
)
Visual Basic
Public Function NewRoomTag ( _
    room As Room, _
    point As UV, _
    view As View _
) As RoomTag
Visual C++
public:
RoomTag^ NewRoomTag(
    Room^ room,
    UV^ point,
    View^ view
)

Parameters

room
Type: Autodesk.Revit.DB.Architecture..::..Room
The Room which the tag refers.
point
Type: Autodesk.Revit.DB..::..UV
A 2D point that dictates the location on the level of the room.
view
Type: Autodesk.Revit.DB..::..View
The view where the tag will lie.

Return Value

If successful a RoomTag object will be returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic). Suitable exceptions will be fired if the parameters are invalid.

Remarks

This method will regenerate the document even in manual regeneration mode.

Examples

CopyC#
RoomTag CreateRoomTag(Autodesk.Revit.DB.Document document, Room room)
{
    // Create a UV structure which determine the room tag location
   UV roomTagLocation = new UV(0, 0);

    // Create a new room tag in the created room
    RoomTag roomTag = document.Create.NewRoomTag(room, roomTagLocation, null);
    if (null == roomTag)
    {
        throw new Exception("Create a new room tag failed.");
    }

    // Give the user some information
    TaskDialog.Show("Revit","Room tag created successfully.");

    return roomTag;
}
CopyVB.NET
Function CreateRoomTag(ByVal document As Autodesk.Revit.DB.Document, ByVal room As Room) As Autodesk.Revit.DB.Architecture.RoomTag
    ' Create a UV structure which determine the room tag location
    Dim roomTagLocation As New Autodesk.Revit.DB.UV(0, 0)

    ' Create a new room tag in the created room
    Dim roomTag As Autodesk.Revit.DB.Architecture.RoomTag = document.Create.NewRoomTag(room, roomTagLocation, Nothing)
    If roomTag Is Nothing Then
        Throw New Exception("Create a new room tag failed.")
    End If

    ' Give the user some information
    TaskDialog.Show("Revit", "Room tag created successfully.")

    Return roomTag
End Function

See Also

Document Class
Autodesk.Revit.Creation Namespace

NewSketchPlane Method

[image] [image]