Revit 2013 API
PanelScheduleView..::..GetCellText Method
PanelScheduleView Class See Also Send Feedback
Gets the cell's text based on its type

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string GetCellText(
    SectionType sectionType,
    int nRow,
    int nCol
)
Visual Basic
Public Function GetCellText ( _
    sectionType As SectionType, _
    nRow As Integer, _
    nCol As Integer _
) As String
Visual C++
public:
String^ GetCellText(
    SectionType sectionType,
    int nRow,
    int nCol
)

Parameters

sectionType
Type: Autodesk.Revit.DB..::..SectionType
The requested section type
nRow
Type: System..::..Int32
Row Number in the Section
nCol
Type: System..::..Int32
Column Number in the Section

Return Value

The text for the given cell

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown if this is an invalid cell

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace

GetCircuitByCell Method

[image]