Revit 2013 API
AreaReinforcement Class
Members Example See Also Send Feedback
An object that represents an Area Reinforcement within the Autodesk Revit project.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class AreaReinforcement : Element
Visual Basic
Public Class AreaReinforcement _
    Inherits Element
Visual C++
public ref class AreaReinforcement : public Element

Remarks

This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object. The Area Reinforcement element is available only in the Autodesk Revit Structure product.

Examples

CopyC#
public void GetInfo_AreaReinforcement(AreaReinforcement areaReinforcement)
{
    string message = "AreaReinforcement : ";

    // Show the AreaReinforcement Type information
    //message += "\nType : " + areaReinforcement.AreaReinforcementType.Name;

    // Show the AreaReinforcement bar information
    message += "\nNumber of distinct bar shapes : " + areaReinforcement.NumBarDescriptions;

    for (int i = 0; i < areaReinforcement.NumBarDescriptions; i++)
    {
        message += "\nBar Description " + i;
        message += "\n\tBar count : " +
                          areaReinforcement.get_BarDescription(i).Count;
        message += "\n\tBar type name : " +
                          areaReinforcement.get_BarDescription(i).BarType.Name;
        message += "\n\tBar layer index : " +
                          areaReinforcement.get_BarDescription(i).Layer;
        message += "\n\tBar length : " +
                          areaReinforcement.get_BarDescription(i).Length;
    }

    // Show the AreaReinforcement Curves information
    message += "\nArea Reinforcement has " + areaReinforcement.Curves.Size + " boundary curves.";

    foreach (Autodesk.Revit.DB.Element ii in areaReinforcement.Curves)
    {
        AreaReinforcementCurve reinCurve = ii as AreaReinforcementCurve;
        if (null == reinCurve)
        {
            continue;
        }
        Curve curve = reinCurve.Curve; // get the location curve
        XYZ start = curve.get_EndPoint(0);  // get the start point of the curve
        XYZ end = curve.get_EndPoint(1);    // get the end point of the curve
        message += "\nCurve: Start point (" + start.X + ", " + start.Y + ", " + start.Z + ")";
        message += "\n       End point (" + end.X + ", " + end.Y + ", " + end.Z + ")";
    }

    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Public Sub GetInfo_AreaReinforcement(ByVal areaReinforcement As Autodesk.Revit.DB.Structure.AreaReinforcement)
    Dim message As String = "AreaReinforcement : "

    ' Show the AreaReinforcement Type information
    'message += "\nType : " + areaReinforcement.AreaReinforcementType.Name;

    ' Show the AreaReinforcement bar information
    message += vbLf & "Number of distinct bar shapes : " + areaReinforcement.NumBarDescriptions

    Dim i As Integer = 0
    While i < areaReinforcement.NumBarDescriptions
        message += vbLf & "Bar Description " + i
        message += vbLf & vbTab & "Bar count : " + areaReinforcement.BarDescription(i).Count
        message += vbLf & vbTab & "Bar type name : " + areaReinforcement.BarDescription(i).BarType.Name
        message += vbLf & vbTab & "Bar layer index : " + areaReinforcement.BarDescription(i).Layer
        message += vbLf & vbTab & "Bar length : " + areaReinforcement.BarDescription(i).Length
        System.Math.Max(System.Threading.Interlocked.Increment(i), i - 1)
    End While

    ' Show the AreaReinforcement Curves information
    message += vbLf & "Area Reinforcement has " + areaReinforcement.Curves.Size + " boundary curves."

    For Each ii As Autodesk.Revit.DB.Element In areaReinforcement.Curves
        Dim reinCurve As AreaReinforcementCurve = TryCast(ii, AreaReinforcementCurve)
        If reinCurve Is Nothing Then
            Continue For
        End If
        Dim curve As Curve = reinCurve.Curve
        ' get the location curve
        Dim start As Autodesk.Revit.DB.XYZ = curve.EndPoint(0)
        ' get the start point of the curve
        Dim [end] As Autodesk.Revit.DB.XYZ = curve.EndPoint(1)
        ' get the end point of the curve
        message += vbLf & "Curve: Start point (" + start.X + ", " + start.Y + ", " + start.Z + ")"
        message += vbLf & "       End point (" + [end].X + ", " + [end].Y + ", " + [end].Z + ")"
    Next

    TaskDialog.Show("Revit", message)
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB.Structure..::..AreaReinforcement

See Also

AreaReinforcement Members
Autodesk.Revit.DB.Structure Namespace

AreaReinforcement Members

[image] [image]