Revit 2013 API
Document..::..NewWall Method (Curve, WallType, Level, Double, Double, Boolean, Boolean)
Document Class Example See Also Send Feedback
Creates a new rectangular profile wall within the project using the specified wall type, height, and offset.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2013. Please call a static creation method of Wall class instead.")]
public Wall NewWall(
    Curve curve,
    WallType wallType,
    Level level,
    double height,
    double offset,
    bool flip,
    bool structural
)
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2013. Please call a static creation method of Wall class instead.")> _
Public Function NewWall ( _
    curve As Curve, _
    wallType As WallType, _
    level As Level, _
    height As Double, _
    offset As Double, _
    flip As Boolean, _
    structural As Boolean _
) As Wall
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2013. Please call a static creation method of Wall class instead.")]
public:
Wall^ NewWall(
    Curve^ curve,
    WallType^ wallType,
    Level^ level,
    double height,
    double offset,
    bool flip,
    bool structural
)

Parameters

curve
Type: Autodesk.Revit.DB..::..Curve
An arc or line representing the base line of the wall.
wallType
Type: Autodesk.Revit.DB..::..WallType
A wall type to be used by the new wall instead of the default type.
level
Type: Autodesk.Revit.DB..::..Level
The level on which the wall is to be placed.
height
Type: System..::..Double
The height of the wall other than the default height.
offset
Type: System..::..Double
Modifies the wall's Base Offset parameter to determine its vertical placement.
flip
Type: System..::..Boolean
Change which side of the wall is considered to be the inside and outside of the wall.
structural
Type: System..::..Boolean
If set, specifies that the wall is structural in nature.

Return Value

If successful a new wall object within the project, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Examples

CopyC#
public Wall CreateWallUsingCurve2(Autodesk.Revit.DB.Document document, Level level, WallType wallType)
{
    // Build a location line for the wall creation
    XYZ start = new XYZ(0, 0, 0);
    XYZ end = new XYZ(10, 10, 0);
    Line geomLine = document.Application.Create.NewLineBound(start, end);

    // Determine the other parameters
    double height = 15;
    double offset = 3;

    // Create a wall using the location line and wall type
    return Wall.Create(document, geomLine, wallType.Id, level.Id, height, offset, true, true);
}
CopyVB.NET
Public Function CreateWallUsingCurve2(ByVal document As Autodesk.Revit.DB.Document, ByVal level As Level, ByVal wallType As WallType) As Wall
    ' Build a location line for the wall creation
    Dim start As New Autodesk.Revit.DB.XYZ(0, 0, 0)
    Dim [end] As New Autodesk.Revit.DB.XYZ(10, 10, 0)
    Dim geomLine As Line = document.Application.Create.NewLineBound(start, [end])

    ' Determine the other parameters
    Dim height As Double = 15
    Dim offset As Double = 3

    ' Create a wall using the location line and wall type
    Return document.Create.NewWall(geomLine, wallType, level, height, offset, True, _
     True)
End Function

See Also

Document Class
NewWall Overload
Autodesk.Revit.Creation Namespace

NewWalls Method

[image] [image]