Revit 2013 API
Application Properties
Application Class See Also Send Feedback

The Application type exposes the following members.

Properties

 | Name | Description
Public property | ActiveAddInId | Retrieves the Id of the currently running external application.
Public property | Assets |
Public property | Cities | Returns a set of all the known city locations within Revit.
Public property | Create | Provides an object that can be used to create new instances of Autodesk Revit API objects.
Public property | CurrentRevitServerAccelerator | Current Revit Server accelerator.
Public property | DefaultProjectTemplate | Full path to the default template file for new project documents.
Public property | DefaultViewDiscipline | The view discipline that will be applied to new views by default.
Public property | Documents | Returns a set of documents within Revit.
Public property | FamilyTemplatePath | Default path for family template files.
Public property | IsArchitectureEnabled | Checks whether or not the architecture discipline is enabled, and enable or disable it.
Public property | IsElectricalAnalysisEnabled | Checks whether or not electrical analysis is enabled, and enable or disable it.
Public property | IsElectricalEnabled | Checks whether or not the electrical discipline is enabled, and enable or disable it.
Public property | IsEnergyAnalysisEnabled | Checks whether or not energy analysis is enabled, and enable or disable it.
Public property | IsMassingEnabled | Checks whether or not the massing and site tools are enabled, and enable or disable them.
Public property | IsMechanicalAnalysisEnabled | Checks whether or not mechanical analysis is enabled, and enable or disable it.
Public property | IsMechanicalEnabled | Checks whether or not the mechanical discipline is enabled, and enable or disable it.
Public property | IsPipingAnalysisEnabled | Checks whether or not piping analysis is enabled, and enable or disable it.
Public property | IsPipingEnabled | Checks whether or not the piping discipline is enabled, and enable or disable it.
Public property | IsQuiescent | Returns if the current application is quiescent.
Public property | IsStructuralAnalysisEnabled | Checks whether or not the structural analysis is enabled, and enable or disable it.
Public property | IsStructureEnabled | Checks whether or not the structure discipline is enabled, and enable or disable it.
Public property | IsSystemsEnabled | Checks whether or not any systems disciplines (mechanical, electrical, or piping) are enabled.
Public property | Language | The language used in the current session of Revit.
Public property | ObjectFactory | Provides an object that can be used to create other instances of Autodesk Revit API objects.
Public property | Product | The product type for the current session of Revit.
Public property | RecordingJournalFilename | Retrieve the name of the journal file the Revit is currently recording to.
Public property | SharedParametersFilename | Contains the fully qualified path to a shared parameters file.
Public property | ShowGraphicalWarningCableTrayConduitDisconnects | Whether or not to show the graphical warnings for CTC disconnects.
Public property | ShowGraphicalWarningDuctDisconnects | Whether or not to show the graphical warnings for duct disconnects.
Public property | ShowGraphicalWarningElectricalDisconnects | Whether or not to show the graphical warnings for Electrical disconnects.
Public property | ShowGraphicalWarningPipeDisconnects | Whether or not to show the graphical warnings for Pipe disconnects.
Public property | Username | Gets the user name for the current Revit session.
Public property | VersionBuild | Returns the internal build number of the Autodesk Revit application.
Public property | VersionName | Returns the name of the Revit application.
Public property | VersionNumber | Return the primary version of the Revit application.
Public property | VertexTolerance | Gets the vertex tolerance.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace

ActiveAddInId Property

[image]