Revit 2013 API
Document..::..NewRooms Method (Phase, Int32)
Document Class See Also Send Feedback
Creates new unplaced rooms in the given phase.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2013.  Call NewRooms2(Autodesk.Revit.DB.Phase phase, int count) instead.")]
public ElementSet NewRooms(
    Phase phase,
    int count
)
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2013.  Call NewRooms2(Autodesk.Revit.DB.Phase phase, int count) instead.")> _
Public Function NewRooms ( _
    phase As Phase, _
    count As Integer _
) As ElementSet
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2013.  Call NewRooms2(Autodesk.Revit.DB.Phase phase, int count) instead.")]
public:
ElementSet^ NewRooms(
    Phase^ phase,
    int count
)

Parameters

phase
Type: Autodesk.Revit.DB..::..Phase
The phase on which the rooms are to exist.
count
Type: System..::..Int32
The number of the rooms to be created.

Return Value

If successful an Element set which contain the rooms should be returned, otherwise the exception will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | If the room can not be created successfully or regeneration fails at the end of the creation.

See Also

Document Class
NewRooms Overload
Autodesk.Revit.Creation Namespace

NewRooms2 Method

[image] [image]