Revit 2013 API
XYZ..::..Multiply Operator (Double, XYZ)
XYZ Class See Also Send Feedback
Multiplies the specified number and the specified vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static XYZ operator *(
    double value,
    XYZ right
)
Visual Basic
Public Shared Operator * ( _
    value As Double, _
    right As XYZ _
) As XYZ
Visual C++
public:
static XYZ^ operator *(
    double value,
    XYZ^ right
)

Parameters

value
Type: System..::..Double
The value to multiply with the specified vector.
right
Type: Autodesk.Revit.DB..::..XYZ
The vector to multiply with the value.

Return Value

The multiplied vector.

Remarks

The multiplied vector is obtained by multiplying each coordinate of the specified vector by the specified value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when right is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the specified value is an infinite number.

See Also

XYZ Class
Multiply Overload

Multiply Operator (XYZ, Double)

[image]