Revit 2013 API
Material..::..SetSmoothness Method
Material Class See Also Send Feedback
Sets the smoothness value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This method is deprecated in Autodesk Revit 2013.  Please use the Smoothness property instead.")]
public void SetSmoothness(
    float val
)
Visual Basic
<ObsoleteAttribute("This method is deprecated in Autodesk Revit 2013.  Please use the Smoothness property instead.")> _
Public Sub SetSmoothness ( _
    val As Single _
)
Visual C++
[ObsoleteAttribute(L"This method is deprecated in Autodesk Revit 2013.  Please use the Smoothness property instead.")]
public:
void SetSmoothness(
    float val
)

Parameters

val
Type: System..::..Single
The smoothness value, ranges from 0 to 1.

See Also

Material Class

Material Properties

[image] [image]