Revit 2013 API
TransactionStatus Enumeration
See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public enum TransactionStatus
Visual Basic
Public Enumeration TransactionStatus
Visual C++
public enum class TransactionStatus

Members

Member name | Description
Uninitialized | initial value, the transaction has not been started yet in this status
Started | transaction has begun (until committed or rolled back)
RolledBack | rolled back (aborted)
Committed | simply committed, ended an empty transaction, flushed all, or undo is disabled
Pending | returned from error handling that took over managing the transaction
Error | error while committing or rolling back
Proceed | while still in error handling (internal status)

See Also

Transform Class

[image]