Revit 2013 API
ControlledApplication Methods
ControlledApplication Class See Also Send Feedback

The ControlledApplication type exposes the following members.

Methods

 | Name | Description
 | GetFailureDefinitionRegistry | Returns the instance of FailureDefinitionRegistry.
Public method | GetLibraryPaths | Returns path information identifying where Revit searches for content.
Public method | OpenSharedParameterFile | Enables access to shared parameter groups and definitions that are maintained on disk.
 | RegisterFailuresProcessor | Registers Revit application-wide instance of Failures Processor.
Public method | SetLibraryPaths | Sets path information identifying where Revit searches for content.
Public method | WriteJournalComment | Writes a comment to the Revit journal file.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace

GetFailureDefinitionRegistry Method

[image]