Revit 2013 API
ExporterIFCUtils..::..CreateDoorWindowBaseQuantities Method
ExporterIFCUtils Class See Also Send Feedback
Creates the door or window base quantities and adds them to the export.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static void CreateDoorWindowBaseQuantities(
    ExporterIFC exporterIFC,
    IFCAnyHandle instanceHandle,
    double scaledHeight,
    double scaledWidth
)
Visual Basic
Public Shared Sub CreateDoorWindowBaseQuantities ( _
    exporterIFC As ExporterIFC, _
    instanceHandle As IFCAnyHandle, _
    scaledHeight As Double, _
    scaledWidth As Double _
)
Visual C++
public:
static void CreateDoorWindowBaseQuantities(
    ExporterIFC^ exporterIFC,
    IFCAnyHandle^ instanceHandle,
    double scaledHeight,
    double scaledWidth
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
instanceHandle
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The door or window handle.
scaledHeight
Type: System..::..Double
The height of the element, in the units of export.
scaledWidth
Type: System..::..Double
The width of the element, in the units of export.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace

CreateExtrudedSurfaceFromCurve Method

[image]