Revit 2013 API
ElectricalSetting Class
Members See Also Send Feedback
An object that represents electrical information within the Autodesk Revit project.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class ElectricalSetting : APIObject
Visual Basic
Public Class ElectricalSetting _
    Inherits APIObject
Visual C++
public ref class ElectricalSetting : public APIObject

Remarks

ElectricalSetting includes voltage type, distribution system type, wire type, and demand factor setting. All basic operations of these electrical elements are supported.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Electrical..::..ElectricalSetting

See Also

ElectricalSetting Members
Autodesk.Revit.DB.Electrical Namespace

ElectricalSetting Members

[image] [image]