Revit 2013 API
BarDescription..::..GetHookTypeId Method
BarDescription Class See Also Send Feedback
Gets the rebar hook type identifier of a Bar Description.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId GetHookTypeId(
    int end
)
Visual Basic
Public Function GetHookTypeId ( _
    end As Integer _
) As ElementId
Visual C++
public:
ElementId^ GetHookTypeId(
    int end
)

Parameters

end
Type: System..::..Int32
0 for the starting hook, 1 for the ending hook

Return Value

id of the rebar hook type

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | end must be 0 or 1.

See Also

BarDescription Class
Autodesk.Revit.DB.Structure Namespace

BarDescription Properties

[image] [image]