Revit 2013 API
RebarShapeDefinitionBySegments..::..AddBendVariableRadius Method
RebarShapeDefinitionBySegments Class See Also Send Feedback
Specify a variable-radius bend.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void AddBendVariableRadius(
    int vertexIndex,
    int turn,
    RebarShapeBendAngle angle,
    ElementId paramId,
    bool measureIncludingBarThickness
)
Visual Basic
Public Sub AddBendVariableRadius ( _
    vertexIndex As Integer, _
    turn As Integer, _
    angle As RebarShapeBendAngle, _
    paramId As ElementId, _
    measureIncludingBarThickness As Boolean _
)
Visual C++
public:
void AddBendVariableRadius(
    int vertexIndex,
    int turn,
    RebarShapeBendAngle angle,
    ElementId^ paramId,
    bool measureIncludingBarThickness
)

Parameters

vertexIndex
Type: System..::..Int32
Index of the vertex (1 to NumberOfVertices - 2).
turn
Type: System..::..Int32
Specify 1 for a left turn, -1 for a right turn.
angle
Type: Autodesk.Revit.DB.Structure..::..RebarShapeBendAngle
Specify whether the bend is acute, obtuse, etc.
paramId
Type: Autodesk.Revit.DB..::..ElementId
Id of a parameter driving the radius.
measureIncludingBarThickness
Type: System..::..Boolean
If true, the radius is measured to the outside of the bend; if false, it is measured to the inside.

Remarks

You must add a bend between each two segments.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | vertexIndex is not between 0 and NumberOfVertices. -or- turn is neither -1 nor 1. -or- paramId is not the id of a shared parameter in the current document, or its unit type is not UT_Length or UT_Angle.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.DB.Structure Namespace

AddConstraintParallelToSegment Method

[image]