Revit 2013 API
Document..::..NewRooms Method (Level, Phase)
Document Class See Also Send Feedback
Creates new rooms in each plan circuit found in the given level in the given phase.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2013.  Call NewRooms2(Autodesk.Revit.DB.Level level, Autodesk.Revit.DB.Phase phase) instead.")]
public ElementSet NewRooms(
    Level level,
    Phase phase
)
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2013.  Call NewRooms2(Autodesk.Revit.DB.Level level, Autodesk.Revit.DB.Phase phase) instead.")> _
Public Function NewRooms ( _
    level As Level, _
    phase As Phase _
) As ElementSet
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2013.  Call NewRooms2(Autodesk.Revit.DB.Level level, Autodesk.Revit.DB.Phase phase) instead.")]
public:
ElementSet^ NewRooms(
    Level^ level,
    Phase^ phase
)

Parameters

level
Type: Autodesk.Revit.DB..::..Level
The level from which the circuits are found.
phase
Type: Autodesk.Revit.DB..::..Phase
The phase on which the room is to exist.

Return Value

If successful an Element set which contains the rooms should be returned, otherwise the exception will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | If the view of the relevant level can not be retrieved.
Autodesk.Revit.Exceptions..::..InvalidOperationException | If the phase is invalid, or regeneration fails at the end of the creation.

See Also

Document Class
NewRooms Overload
Autodesk.Revit.Creation Namespace

NewRooms Method (Phase, Int32)

[image]