Revit 2013 API
Application..::..NewHermiteSpline Method (IList<(Of <(<'XYZ>)>)>, Boolean, XYZ, XYZ)
Application Class See Also Send Feedback
Creates a Hermite spline with specified tangency at its endpoints.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public HermiteSpline NewHermiteSpline(
    IList<XYZ> ctrlPoints,
    bool bPeriodic,
    XYZ startTangent,
    XYZ endTangent
)
Visual Basic
Public Function NewHermiteSpline ( _
    ctrlPoints As IList(Of XYZ), _
    bPeriodic As Boolean, _
    startTangent As XYZ, _
    endTangent As XYZ _
) As HermiteSpline
Visual C++
public:
HermiteSpline^ NewHermiteSpline(
    IList<XYZ^>^ ctrlPoints,
    bool bPeriodic,
    XYZ^ startTangent,
    XYZ^ endTangent
)

Parameters

ctrlPoints
Type: System.Collections.Generic..::..IList<(Of <(<'XYZ>)>)>
The control points of the Hermite spline.
bPeriodic
Type: System..::..Boolean
True if the Hermite spline is to be periodic.
startTangent
Type: Autodesk.Revit.DB..::..XYZ
Tangent vector at the start of the spline. Can be null, in which case the tangent is computed from the control points.
endTangent
Type: Autodesk.Revit.DB..::..XYZ
Tangent vector at the end of the spline. Can be null, in which case the tangent is computed from the control points.

Remarks

See Also

Application Class
NewHermiteSpline Overload
Autodesk.Revit.Creation Namespace

NewImageImportOptions Method

[image]