Revit 2013 API
Document..::..Delete Method (Element)
Document Class Example See Also Send Feedback
Deletes an element from the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ICollection<ElementId> Delete(
    Element element
)
Visual Basic
Public Function Delete ( _
    element As Element _
) As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ Delete(
    Element^ element
)

Parameters

element
Type: Autodesk.Revit.DB..::..Element
The element that is to be deleted.

Return Value

The deleted element id set if the deletion succeeds, or nullNothingnullptra null reference (Nothing in Visual Basic) if the deletion fails.

Remarks

This method will delete the element and any elements that are totally dependent upon that element. Any references to the deleted elements will become invalid and hence cause an exception to be thrown if they are accessed.

Note: in a family document, the predefined elements (those elements inherited from its family template file) can't be deleted by this method.

Examples

CopyC#
private void DeleteElement(Autodesk.Revit.DB.Document document, Element element)
{
    // Delete a selected element.
   ICollection<Autodesk.Revit.DB.ElementId> deletedIdSet = document.Delete(element);

    if (0 == deletedIdSet.Count)
    {
        throw new Exception("Deleting the selected element in Revit failed.");
    }

    String prompt = "The selected element has been removed and ";
    prompt += deletedIdSet.Count - 1;
    prompt += " more dependent elements have also been removed.";

    // Give the user some information
    TaskDialog.Show("Revit",prompt);

}
CopyVB.NET
Private Sub DeleteElement(ByVal document As Autodesk.Revit.DB.Document, ByVal element As Autodesk.Revit.DB.Element)
    ' Delete a selected element.
    Dim deletedIdSet As ICollection(Of Autodesk.Revit.DB.ElementId) = document.Delete(element)

    If 0 = deletedIdSet.Count Then
        Throw New Exception("Deleting the selected element in Revit failed.")
    End If

    Dim prompt As [String] = "The selected element has been removed and "
    prompt += deletedIdSet.Count - 1
    prompt += " more dependent elements have also been removed."

    ' Give the user some information
    TaskDialog.Show("Revit", prompt)

End Sub

See Also

Document Class
Delete Overload

Delete Method (ElementId)

[image]