Revit 2013 API
AreaReinforcement..::..GetCurveElementIds Method
AreaReinforcement Class See Also Send Feedback
Retrieves the set of curves forming the boundary of the Area Reinforcement.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IList<ElementId> GetCurveElementIds()
Visual Basic
Public Function GetCurveElementIds As IList(Of ElementId)
Visual C++
public:
IList<ElementId^>^ GetCurveElementIds()

Return Value

A collection of ElementIds of AreaReinforcementCurve elements.

Remarks

Each ElementId in the collection is an Id of an Element of type AreaReinforcementCurve. Each element has a Curve property to retrieve the geometric curve, together with some Parameters allowing the developer to override the clear cover side, hook type, and hook direction of each layer of bars terminating at the curve.

See Also

AreaReinforcement Class
Autodesk.Revit.DB.Structure Namespace

GetRebarInSystemIds Method

[image]