Revit 2013 API
ScheduleField..::..GetSchedulableField Method
ScheduleField Class See Also Send Feedback
Gets a SchedulableField object representing this field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public SchedulableField GetSchedulableField()
Visual Basic
Public Function GetSchedulableField As SchedulableField
Visual C++
public:
SchedulableField^ GetSchedulableField()

Return Value

The SchedulableField object.

Remarks

A SchedulableField object can only be obtained for non-calculated fields (field types other than Formula or Percentage).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This ScheduleField is a calculated field (Formula or Percentage).

See Also

ScheduleField Class

IsCalculatedField Method

[image]