Revit 2013 API
RebarHostData..::..IsValidHost Method
RebarHostData Class See Also Send Feedback
Reports whether the element is a valid rebar host.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool IsValidHost()
Visual Basic
Public Function IsValidHost As Boolean
Visual C++
public:
bool IsValidHost()

Return Value

True if the referenced Element can currently host Rebar elements, false otherwise.

Remarks

If GetRebarHostData() returns a RebarHostData object, but RebarHostData.IsValidHost() returns false, this means that the element can be made a valid rebar host, generally by setting a property like FLOOR_PARAM_IS_STRUCTURAL or by changing the element's physical material to concrete. On the other hand, if GetRebarHostData() returns nullNothingnullptra null reference (Nothing in Visual Basic), the element cannot be made into a rebar host. This method replaces the Valid property from the 2011 Revit API.

See Also

RebarHostData Class
Autodesk.Revit.DB.Structure Namespace

SetCommonCoverType Method

[image]