Revit 2013 API
ApplicationEntryPoint..::..OpenAndActivateDocument Method (ModelPath, OpenOptionsForUI)
ApplicationEntryPoint Class See Also Send Feedback

Namespace: Autodesk.Revit.UI.Macros
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public UIDocument OpenAndActivateDocument(
    ModelPath modelPath,
    OpenOptionsForUI openOptions
)
Visual Basic
Public Function OpenAndActivateDocument ( _
    modelPath As ModelPath, _
    openOptions As OpenOptionsForUI _
) As UIDocument
Visual C++
public:
UIDocument^ OpenAndActivateDocument(
    ModelPath^ modelPath,
    OpenOptionsForUI^ openOptions
)

Parameters

modelPath
Type: Autodesk.Revit.DB..::..ModelPath
openOptions
Type: Autodesk.Revit.UI..::..OpenOptionsForUI

See Also

ApplicationEntryPoint Class
OpenAndActivateDocument Overload
Autodesk.Revit.UI.Macros Namespace

RemoveAddInCommandBinding Method

[image]