Revit 2013 API
FabricSheetType..::..MajorDirectionWireType Property
FabricSheetType Class See Also Send Feedback
Determines which "Fabric Wire" type will be used in the major direction.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId MajorDirectionWireType { get; set; }
Visual Basic
Public Property MajorDirectionWireType As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ MajorDirectionWireType {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: the ElementId majorDirectionWireType is either invalid or not a FabricWireType.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

FabricSheetType Class
Autodesk.Revit.DB.Structure Namespace

MajorEndOverhang Property

[image]