Revit 2013 API
StringStringMapIterator..::..Key Property
StringStringMapIterator Class See Also Send Feedback
Retrieves the string key that is the current focus of the iterator.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual string Key { get; }
Visual Basic
Public Overridable ReadOnly Property Key As String
    Get
Visual C++
public:
virtual property String^ Key {
    String^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid key as per expected behavior of IEnumerator.

See Also

StringStringMapIterator Class
Autodesk.Revit.Collections Namespace

Autodesk.Revit.Creation Namespace

[image]