Revit 2013 API
PointLocationOnCurve Constructor
PointLocationOnCurve Class See Also Send Feedback
Constructs a new instance of a class, with given or default values, to place a point on a curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public PointLocationOnCurve(
    PointOnCurveMeasurementType measType,
    double measValue,
    PointOnCurveMeasureFrom measFrom
)
Visual Basic
Public Sub New ( _
    measType As PointOnCurveMeasurementType, _
    measValue As Double, _
    measFrom As PointOnCurveMeasureFrom _
)
Visual C++
public:
PointLocationOnCurve(
    PointOnCurveMeasurementType measType,
    double measValue,
    PointOnCurveMeasureFrom measFrom
)

Parameters

measType
Type: Autodesk.Revit.DB..::..PointOnCurveMeasurementType
measValue
Type: System..::..Double
measFrom
Type: Autodesk.Revit.DB..::..PointOnCurveMeasureFrom

See Also

PointLocationOnCurve Class

PointLocationOnCurve Methods

[image] [image]