Revit 2013 API
FormatOptions..::..Unitsymbol Property
FormatOptions Class See Also Send Feedback
Retrieves the Unit Symbol of Units Type that are currently selected.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public UnitSymbolType Unitsymbol { get; set; }
Visual Basic
Public Property Unitsymbol As UnitSymbolType
    Get
    Set
Visual C++
public:
property UnitSymbolType Unitsymbol {
    UnitSymbolType get ();
    void set (UnitSymbolType value);
}

Remarks

You can set or get Unit Symbol of Units Type that are currently selected. If current DisplayUnitType does NOT support Unit Symbol and you have inputted as well, it will throw an InvalidOperationException. If current DisplayUnitType support, and you set a unfit enum value, it will throw an ArgumentOutOfRangeException.

See Also

FormatOptions Class

FormatUtils Class

[image]