Revit 2013 API
Document..::..NewBeamSystem Method (CurveArray, SketchPlane)
Document Class See Also Send Feedback
Creates a new BeamSystem with specified profile curves.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public BeamSystem NewBeamSystem(
    CurveArray profile,
    SketchPlane sketchPlane
)
Visual Basic
Public Function NewBeamSystem ( _
    profile As CurveArray, _
    sketchPlane As SketchPlane _
) As BeamSystem
Visual C++
public:
BeamSystem^ NewBeamSystem(
    CurveArray^ profile,
    SketchPlane^ sketchPlane
)

Parameters

profile
Type: Autodesk.Revit.DB..::..CurveArray
The profile is the profile of the BeamSystem.
sketchPlane
Type: Autodesk.Revit.DB..::..SketchPlane
The work plane of the BeamSystem.

Return Value

If successful a new BeamSystem object will be returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic). Suitable exceptions will be fired if the parameters are invalid.

Remarks

Other properties are set to default value and can be set later. Such as level, elevation, direction, etc.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input profile or sketchPlane is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when profile is not suitable for creating beam system.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown if calling this function when the document is not modifiable.

See Also

Document Class
NewBeamSystem Overload
Autodesk.Revit.Creation Namespace

NewBeamSystem Method (CurveArray, Level, XYZ, Boolean)

[image]