Revit 2013 API
IFCWindowStyleOperation Enumeration
See Also Send Feedback
The types of window configurations, as defined in IFC2x3.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012
Since: 2012

Syntax

C#
public enum IFCWindowStyleOperation
Visual Basic
Public Enumeration IFCWindowStyleOperation
Visual C++
public enum class IFCWindowStyleOperation

Members

Member name | Description
SinglePanel | Window has a single panel.
DoublePanelVertical | Window has two vertically stacked panels.
DoublePanelHorizontal | Window has two panels side to side.
TriplePanelVertical | Window has three vertically stacked panels.
TriplePanelBottom | Window has two panels side to side, and one panel below these two.
TriplePanelTop | Window has two panels side to side, and one panel above these two.
TriplePanelLeft | Window has two vertically stacked panels, and one panel to the left of these.
TriplePanelRight | Window has two vertically stacked panels, and one panel to the right of these.
TriplePanelHorizontal | Window has three panels side to side.
UserDefined | User-defined window operation.
NotDefined | Undefined window operation.

See Also

Autodesk.Revit.DB.IFC Namespace

Autodesk.Revit.DB.Lighting Namespace

[image]