Revit 2013 API
ItemFactoryBase..::..NewTextNotes Method
ItemFactoryBase Class See Also Send Feedback
Creates TextNotes with the specified data.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2013. Call NewTextNote() instead.  Create each TextNote in a loop and call Document.Regenerate() or Transaction.Commit() after the loop exits.")]
public ElementSet NewTextNotes(
    List<TextNoteCreationData> dataList
)
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2013. Call NewTextNote() instead.  Create each TextNote in a loop and call Document.Regenerate() or Transaction.Commit() after the loop exits.")> _
Public Function NewTextNotes ( _
    dataList As List(Of TextNoteCreationData) _
) As ElementSet
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2013. Call NewTextNote() instead.  Create each TextNote in a loop and call Document.Regenerate() or Transaction.Commit() after the loop exits.")]
public:
ElementSet^ NewTextNotes(
    List<TextNoteCreationData^>^ dataList
)

Parameters

dataList
Type: System.Collections.Generic..::..List<(Of <(<'TextNoteCreationData>)>)>
A list of TextNoteCreationData which wraps the creation arguments of the TextNotes to be created.

Return Value

If the creation is successful an ElementSet which contains the TextNotes should be returned, otherwise Autodesk::Revit::Exceptions::InvalidOperationException will be thrown.

Remarks

This batch creation method is not supported in VSTA for Revit 2010.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when (1) Any one of theView, origin, baseVec, upVec, strText in TextNoteCreationData is nullNothingnullptra null reference (Nothing in Visual Basic). (2) Any one of leaderEnd is nullNothingnullptra null reference (Nothing in Visual Basic) in TextNoteCreationData when leaderStyle != Autodesk::Revit::DB::TextNoteLeaderStyles::LCS_NONE . (3) Any one of leaderElbow is nullNothingnullptra null reference (Nothing in Visual Basic) TextNoteCreationData when leaderStyle == Autodesk::Revit::DB::TextNoteLeaderStyles::LCS_TWO_SEG_LINE.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when one lineWidth in textNoteCreationData is not a finite number.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when (1) Any one textAlign in TextNoteCreationData is not a valid TextAlignFlags or it is not a valid bitwise OR of TextAlignFlags. (2) Any one leaderStyle in TextNoteCreationData is not a valid TextNoteLeaderTypes or any one leaderType in TextNoteCreationData is not a valid TextNoteLeaderTypes when leaderStyle != Autodesk::Revit::DB::TextNoteLeaderStyles::LCS_NONE
Autodesk.Revit.Exceptions..::..InvalidOperationException | If the phase is invalid or regeneration fails at the end of the batch creation.

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace

NewView3D Method

[image]