Revit 2013 API
CurveLoop..::..CreateViaThicken Method
CurveLoop Class See Also Send Feedback
Creates a new closed curve loop by thickening the input curve with respect to a given plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static CurveLoop CreateViaThicken(
    Curve pCurve,
    double thickness,
    XYZ normal
)
Visual Basic
Public Shared Function CreateViaThicken ( _
    pCurve As Curve, _
    thickness As Double, _
    normal As XYZ _
) As CurveLoop
Visual C++
public:
static CurveLoop^ CreateViaThicken(
    Curve^ pCurve,
    double thickness,
    XYZ^ normal
)

Parameters

pCurve
Type: Autodesk.Revit.DB..::..Curve
The input curve.
thickness
Type: System..::..Double
The distance between the offset curves created on either side of the input curve.
normal
Type: Autodesk.Revit.DB..::..XYZ
The normal vector to the plane used for thickening.

Return Value

The new curve loop.

Remarks

The new loop will be created via offsets of the input curve (in the plane of the normal vector) with the endpoints connected with lines.The original curve will be at the center of the new loop.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input pCurve points to a helical curve and is not supported for this operation.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The given value for thickness must be greater than 0 and no more than 30000 feet.

See Also

CurveLoop Class

Dispose Method

[image]