Revit 2013 API
Document..::..NewViewDrafting Method
Document Class Example See Also Send Feedback
Creates a new drafting view.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ViewDrafting NewViewDrafting()
Visual Basic
Public Function NewViewDrafting As ViewDrafting
Visual C++
public:
ViewDrafting^ NewViewDrafting()

Return Value

The newly created drafting view.

Examples

CopyC#
// Create a new ViewDrafting instance
ViewDrafting view = document.Create.NewViewDrafting();
view.ViewName = "MyViewDrafting";

// Set the CropBox
BoundingBoxXYZ boundingBox = new BoundingBoxXYZ();
boundingBox.Max = new XYZ(100, 100, 50);
boundingBox.Min = new XYZ(-100, -100, -50);
view.CropBox = boundingBox;

// Use current view as template
view.ApplyTemplate(document.ActiveView);
CopyVB.NET
' Create a new ViewDrafting instance
Dim view As ViewDrafting = document.Create.NewViewDrafting()
view.ViewName = "MyViewDrafting"

' Set the CropBox
Dim boundingBox As New BoundingBoxXYZ()
boundingBox.Max = New Autodesk.Revit.DB.XYZ(100, 100, 50)
boundingBox.Min = New Autodesk.Revit.DB.XYZ(-100, -100, -50)
view.CropBox = boundingBox

' Use current view as template
view.ApplyTemplate(document.ActiveView)

See Also

Document Class
Autodesk.Revit.Creation Namespace

NewViewSheet Method

[image]