Revit 2013 API
AreaReinforcement Members
AreaReinforcement Class Methods Properties See Also Send Feedback

The AreaReinforcement type exposes the following members.

Methods

 | Name | Description
Public method | GetCurveElementIds | Retrieves the set of curves forming the boundary of the Area Reinforcement.
Public method | GetRebarInSystemIds | Returns the ids of the RebarInSystem elements owned by the AreaReinforcement element.
 | RemoveAreaReinforcementSystem | Deletes the specified AreaReinforcement, and converts its RebarInSystem elements to equivalent Rebar elements.

Properties

 | Name | Description
Public property | AdditionalBottomCoverOffset | Additional offset from the bottom or interior cover reference.
Public property | AdditionalTopCoverOffset | Additional offset from the top or exterior cover reference.
Public property | AreaReinforcementType | Retrieves the type of the Area Reinforcement.
Public property | BarDescription | Obsolete. Retrieves the BarDescription property of an Area Reinforcement element.
Public property | Curves | Obsolete. Retrieves the array of curves forming the boundary of the Area Reinforcement.
Public property | Direction | Retrieve or change the Major Direction of the Area Reinforcement.
Public property | NumBarDescriptions | Obsolete. Retrieves the number of distinct bar shapes.

See Also

AreaReinforcement Class
Autodesk.Revit.DB.Structure Namespace

AreaReinforcement Methods

[image] [image]