Revit 2013 API
Transaction..::..SetFailureHandlingOptions Method
Transaction Class Example See Also Send Feedback
Sets options for handling failures to be used when the transaction is being committed or rolled back.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetFailureHandlingOptions(
    FailureHandlingOptions options
)
Visual Basic
Public Sub SetFailureHandlingOptions ( _
    options As FailureHandlingOptions _
)
Visual C++
public:
void SetFailureHandlingOptions(
    FailureHandlingOptions^ options
)

Parameters

options
Type: Autodesk.Revit.DB..::..FailureHandlingOptions
An instance of FailureHandlingOptions to be applied to the transaction

Remarks

Options can be set at any time before the transaction is either committed or rolled back. See FailureHandlingOptions for details about available options. Once committed or rolled back, the transaction object will reset its options to their default values.

Examples

CopyC#
Transaction t = new Transaction(doc);
t.Start("room");
FailureHandlingOptions failOpt = t.GetFailureHandlingOptions();
failOpt.SetFailuresPreprocessor(new RoomWarningSwallower());
t.SetFailureHandlingOptions(failOpt);

doc.Create.NewRoom(level, new UV(0, 0));
t.Commit();
CopyVB.NET
Dim t As New Transaction(doc)
t.Start("room")
Dim failOpt As Autodesk.Revit.DB.FailureHandlingOptions
failOpt = t.GetFailureHandlingOptions()
failOpt.SetFailuresPreprocessor(New RoomWarningSwallower())
t.SetFailureHandlingOptions(failOpt)

doc.Create.NewRoom(level, New Autodesk.Revit.DB.UV(0, 0))
t.Commit()

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

Transaction Class

SetName Method

[image]