Revit 2013 API
ElementMulticategoryFilter Constructor (ICollection<(Of <(<'ElementId>)>)>)
ElementMulticategoryFilter Class See Also Send Feedback
Constructs a new instance of a filter to find elements whose category matches any of a given set of categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementMulticategoryFilter(
    ICollection<ElementId> categoryIds
)
Visual Basic
Public Sub New ( _
    categoryIds As ICollection(Of ElementId) _
)
Visual C++
public:
ElementMulticategoryFilter(
    ICollection<ElementId^>^ categoryIds
)

Parameters

categoryIds
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
The category ids to match.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | One or more categories was not valid for filtering.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ElementMulticategoryFilter Class
ElementMulticategoryFilter Overload

ElementMulticategoryFilter Constructor (ICollection(BuiltInCategory), Boolean)

[image]