Revit 2013 API
Document..::..NewRooms Method (List<(Of <(<'RoomCreationData>)>)>)
Document Class See Also Send Feedback
Creates new rooms using the specified placement data.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2013.  Call NewRoom(Autodesk.Revit.DB.Level, Autodesk.Revit.DB.UV) instead.   Create each room in a loop and call Document.Regenerate() or Transaction.Commit() after the loop exits.")]
public ElementSet NewRooms(
    List<RoomCreationData> dataList
)
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2013.  Call NewRoom(Autodesk.Revit.DB.Level, Autodesk.Revit.DB.UV) instead.   Create each room in a loop and call Document.Regenerate() or Transaction.Commit() after the loop exits.")> _
Public Function NewRooms ( _
    dataList As List(Of RoomCreationData) _
) As ElementSet
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2013.  Call NewRoom(Autodesk.Revit.DB.Level, Autodesk.Revit.DB.UV) instead.   Create each room in a loop and call Document.Regenerate() or Transaction.Commit() after the loop exits.")]
public:
ElementSet^ NewRooms(
    List<RoomCreationData^>^ dataList
)

Parameters

dataList
Type: System.Collections.Generic..::..List<(Of <(<'RoomCreationData>)>)>
A list of RoomCreationData which wraps the creation arguments of the rooms to be created.

Return Value

If successful an ElementSet contains the rooms should be returned, otherwise the exception will be thrown.

Remarks

This batch creation method is not supported in VSTA for Revit 2010.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | One or more of the RoomCreationData's level or point is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | The relevant room tag is not created successfully, or regeneration fails at the end of the batch creation.

See Also

Document Class
NewRooms Overload
Autodesk.Revit.Creation Namespace

NewRooms Method (Level, Phase)

[image]