Revit 2013 API
RebarShape..::..GetHookOrientation Method
RebarShape Class See Also Send Feedback
Get the hook orientation.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public RebarHookOrientation GetHookOrientation(
    int index
)
Visual Basic
Public Function GetHookOrientation ( _
    index As Integer _
) As RebarHookOrientation
Visual C++
public:
RebarHookOrientation GetHookOrientation(
    int index
)

Parameters

index
Type: System..::..Int32
0 for the starting hook, 1 for the ending hook.

Remarks

Replaces the property RebarShape.HookOrientation from prior releases.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | index must be 0 or 1.

See Also

RebarShape Class
Autodesk.Revit.DB.Structure Namespace

GetMultiplanarDefinition Method

[image]