Revit 2013 API
RebarInSystem Members
RebarInSystem Class Methods Properties See Also Send Feedback

The RebarInSystem type exposes the following members.

Methods

 | Name | Description
Public method | DoesBarExistAtPosition | Checks whether a bar exists at the specified position.
Public method | GetBarPositionTransform | Return a transform representing the relative position of any individual bar in the set.
Public method | GetBendData | Gets the RebarBendData, containing bar and hook information, of the instance.
Public method | GetCenterlineCurves | A chain of curves representing the centerline of the rebar.
Public method | GetDistributionPath | The distribution path of a rebar set.
Public method | GetHookTypeId | Get the id of the RebarHookType to be applied to the rebar.
Public method | GetHostId | The element that contains the rebar.
Public method | IsSolidInView | Checks if this rebar element is shown solidly in a 3D view.
Public method | IsUnobscuredInView | Checks if this rebar element is shown unobscured in a view.

Properties

 | Name | Description
Public property | ArrayLength | Identifies the distribution path length of rebar set.
Public property | BarsOnNormalSide | Identifies if the bars of the rebar set are on the same side of the rebar plane indicated by the normal.
Public property | LayoutRule | Identifies the layout rule of rebar set.
Public property | MaxSpacing | Identifies the maximum spacing between rebar in rebar set.
Public property | Normal | A unit-length vector normal to the plane of the rebar
Public property | NumberOfBarPositions |
Public property | Quantity | Identifies the number of bars in rebar set.
Public property | RebarShapeId | The RebarShape element that defines the shape of the rebar.
Public property | ScheduleMark | The Schedule Mark parameter. On creation, the Schedule Mark is set to a value that is unique to the host, but it can be set to any value.
Public property | SystemId | The Id of an AreaReinforcement or PathReinforcement element that owns this element.
Public property | TotalLength | The length of an individual bar multiplied by Quantity.
Public property | Volume | The volume of an individual bar multiplied by Quantity.

See Also

RebarInSystem Class
Autodesk.Revit.DB.Structure Namespace

RebarInSystem Methods

[image] [image]