Revit 2013 API
FamilyParameter Members
FamilyParameter Class Methods Properties See Also Send Feedback

The FamilyParameter type exposes the following members.

Methods

 | Name | Description

Properties

 | Name | Description
Public property | AssociatedParameters | The parameters from elements in the family which are associated to this parameter.
Public property | CanAssignFormula | Indicates if this parameter can be assigned a formula.
Public property | Definition | The definition.
Public property | DisplayUnitType | The display unit type.
Public property | Formula | The formula.
Public property | GUID | The globally unique identifier
Public property | Id | The id of the family parameter.
Public property | IsDeterminedByFormula | Indicates if the parameter is determined by formula.
Public property | IsInstance | Indicates if the parameter is instance or type.
Public property | IsReporting | Indicates if the parameter is a reporting parameter.
Public property | StorageType | The storage type describes the type that is used internally within the parameter to store its value.

See Also

FamilyParameter Class

FamilyParameter Methods

[image] [image]