Revit 2013 API
CurtainGrid..::..Panels Property
CurtainGrid Class See Also Send Feedback
All the panels of the curtain grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This property is obsolete in Revit 2013.  Call GetPanelIds() instead.")]
public ElementSet Panels { get; }
Visual Basic
<ObsoleteAttribute("This property is obsolete in Revit 2013.  Call GetPanelIds() instead.")> _
Public ReadOnly Property Panels As ElementSet
    Get
Visual C++
[ObsoleteAttribute(L"This property is obsolete in Revit 2013.  Call GetPanelIds() instead.")]
public:
property ElementSet^ Panels {
    ElementSet^ get ();
}

Remarks

For curtain walls, the element in this set is either an instance of Panel or Wall. For curtain systems, the set contains only instances of Panel.

See Also

CurtainGrid Class

UGridLines Property

[image]