Revit 2013 API
BarDescription Class
Members See Also Send Feedback
A description of a straight rebar, possibly with hooks.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This class is obsolete in Revit 2013. Use RebarInSystem instead.")]
public class BarDescription : IDisposable
Visual Basic
<ObsoleteAttribute("This class is obsolete in Revit 2013. Use RebarInSystem instead.")> _
Public Class BarDescription _
    Implements IDisposable
Visual C++
[ObsoleteAttribute(L"This class is obsolete in Revit 2013. Use RebarInSystem instead.")]
public ref class BarDescription : IDisposable

Remarks

An AreaReinforcement or PathReinforcement element generates a collection of BarDescription objects with multiplicities.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Structure..::..BarDescription

See Also

BarDescription Members
Autodesk.Revit.DB.Structure Namespace

BarDescription Members

[image] [image]