Revit 2013 API
IndependentTag Members
IndependentTag Class Methods Properties See Also Send Feedback

The IndependentTag type exposes the following members.

Methods

 | Name | Description
Public method | CanLeaderEndConditionBeAssigned | Checks whether the LeaderEndCondition can be assigned.
Public method | GetTaggedLocalElement | Get the tagged local element if any.

Properties

 | Name | Description
Public property | HasLeader | Whether the tag has a leader or not.
Public property | IsMaterialTag | Identifies if it is a material tag or not.
Public property | IsMulticategoryTag | Identifies if it is a multi-category tag or not.
Public property | IsOrphaned | Identifies if the tag is orphaned or not.
Public property | LeaderElbow | Returns the position of the elbow of leader.
Public property | LeaderEnd | Returns the position of the end of leader.
Public property | LeaderEndCondition | The leader end condition of the tag.
Public property | TaggedElementId | The LinkElementId of the tagged element.
Public property | TaggedLocalElementId | The id of the tagged local element if any.
Public property | TagHeadPosition | Returns the position of the head of tag.
Public property | TagOrientation | The tag orientation of the tag.
Public property | TagText | Returns the text of the Tag.

See Also

IndependentTag Class

IndependentTag Methods

[image] [image]