Revit 2013 API
UIApplication Properties
UIApplication Class See Also Send Feedback

The UIApplication type exposes the following members.

Properties

 | Name | Description
Public property | ActiveAddInId | Get current active external application or external command id.
Public property | ActiveUIDocument | Provides access to an object that represents the currently active project.
Public property | Application | Returns the database level Application represented by this UI level Application.
Public property | DrawingAreaExtents | Get the rectangle that represents the screen pixel coordinates of drawing area.
Public property | LoadedApplications | Returns an array of successfully loaded external applications.
Public property | MainWindowExtents | Get the rectangle that represents the screen pixel coordinates of Revit main window.

See Also

UIApplication Class
Autodesk.Revit.UI Namespace

ActiveAddInId Property

[image]