Revit 2013 API
Document..::..NewLineLoad Method (IList<(Of <(<'XYZ>)>)>, IList<(Of <(<'XYZ>)>)>, IList<(Of <(<'XYZ>)>)>, Boolean, Boolean, Boolean, LineLoadType, SketchPlane)
Document Class See Also Send Feedback
Creates a new unhosted line load within the project using data at an array of points.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public LineLoad NewLineLoad(
    IList<XYZ> points,
    IList<XYZ> forces,
    IList<XYZ> moments,
    bool uniform,
    bool projected,
    bool isReaction,
    LineLoadType symbol,
    SketchPlane plane
)
Visual Basic
Public Function NewLineLoad ( _
    points As IList(Of XYZ), _
    forces As IList(Of XYZ), _
    moments As IList(Of XYZ), _
    uniform As Boolean, _
    projected As Boolean, _
    isReaction As Boolean, _
    symbol As LineLoadType, _
    plane As SketchPlane _
) As LineLoad
Visual C++
public:
LineLoad^ NewLineLoad(
    IList<XYZ^>^ points,
    IList<XYZ^>^ forces,
    IList<XYZ^>^ moments,
    bool uniform,
    bool projected,
    bool isReaction,
    LineLoadType^ symbol,
    SketchPlane^ plane
)

Parameters

points
Type: System.Collections.Generic..::..IList<(Of <(<'XYZ>)>)>
The end points of the LineLoad application.
forces
Type: System.Collections.Generic..::..IList<(Of <(<'XYZ>)>)>
The applied 3d linear forces in the end points.
moments
Type: System.Collections.Generic..::..IList<(Of <(<'XYZ>)>)>
The applied 3d linear moments in the end points.
uniform
Type: System..::..Boolean
Set to True if you wish to create the uniform load.
projected
Type: System..::..Boolean
Set to True if you wish to create the projected load.
isReaction
Type: System..::..Boolean
Specifies if the load is a reaction load. The load cannot be modified if isReaction=True.
symbol
Type: Autodesk.Revit.DB.Structure..::..LineLoadType
The symbol of the LineLoad.
plane
Type: Autodesk.Revit.DB..::..SketchPlane
Indicate the work plane of the LineLoad.

Return Value

If successful, NewLineLoad returns an object for the newly created LineLoad. nullNothingnullptra null reference (Nothing in Visual Basic) is returned if the operation fails.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | If the product is not Revit Structure.

See Also

Document Class
NewLineLoad Overload
Autodesk.Revit.Creation Namespace

NewLineLoad Method (XYZ, XYZ, XYZ, XYZ, XYZ, XYZ, Boolean, Boolean, Boolean, LineLoadType, SketchPlane)

[image]