Revit 2013 API
IFCProductWrapper..::..AddSpace Method
IFCProductWrapper Class See Also Send Feedback
Adds an IfcSpace handle to associate with the IfcProduct in this wrapper.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void AddSpace(
    IFCAnyHandle spaceHandle,
    IFCLevelInfo pLevelInfo,
    IFCExtrusionCreationData pParams,
    bool relateToLevel
)
Visual Basic
Public Sub AddSpace ( _
    spaceHandle As IFCAnyHandle, _
    pLevelInfo As IFCLevelInfo, _
    pParams As IFCExtrusionCreationData, _
    relateToLevel As Boolean _
)
Visual C++
public:
void AddSpace(
    IFCAnyHandle^ spaceHandle,
    IFCLevelInfo^ pLevelInfo,
    IFCExtrusionCreationData^ pParams,
    bool relateToLevel
)

Parameters

spaceHandle
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The IfcSpace handle.
pLevelInfo
Type: Autodesk.Revit.DB.IFC..::..IFCLevelInfo
Information on the associated level.
pParams
Type: Autodesk.Revit.DB.IFC..::..IFCExtrusionCreationData
The extrusion creation data associated with the given space. Optional, can be nullNothingnullptra null reference (Nothing in Visual Basic).
relateToLevel
Type: System..::..Boolean
True to relate the space to the level, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCProductWrapper Class
Autodesk.Revit.DB.IFC Namespace

ClearFinishMaterials Method

[image]