Revit 2013 API
MechanicalSystem Members
MechanicalSystem Class Methods Properties See Also Send Feedback

The MechanicalSystem type exposes the following members.

Methods

 | Name | Description
 | Create(Document, ElementId) | Creates a new instance of a mechanical system and adds it to the document.
 | Create(Document, ElementId, String) | Creates a new instance of a mechanical system and adds it to the document.

Properties

 | Name | Description
Public property | BaseEquipmentConnector | The connector within the base equipment which is used to connect with the system.
Public property | DuctNetwork | The ducts and fittings contained within the system.
Public property | Flow | Indicates the computed total flow for the mechanical system.
Public property | IsWellConnected | Indicates if the system is well connected or not.
Public property | StaticPressure | Indicates the computed static pressure for the mechanical system.
Public property | SystemType | The type of this duct system.

See Also

MechanicalSystem Class
Autodesk.Revit.DB.Mechanical Namespace

MechanicalSystem Methods

[image] [image]