Revit 2013 API
Element..::..Group Property
Element Class Example See Also Send Feedback
Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Group Group { get; }
Visual Basic
Public ReadOnly Property Group As Group
    Get
Visual C++
public:
property Group^ Group {
    Group^ get ();
}

Examples

CopyC#
private void ShowGroupInformation(Autodesk.Revit.DB.Document document, Autodesk.Revit.DB.Element element)
{
    // Get group information for the selected element
    String prompt = null;
    Autodesk.Revit.DB.Group group = element.Group;
    if (null == group)
    {
        prompt = "The element isn't in any group.";
    }
    else
    {
        prompt = "The element " + element.Id.IntegerValue + " is in a group.";
        prompt += "\nThe group id is " + group.Id.IntegerValue;
        prompt += "\nThe group's category is " + group.Category.Name;
        prompt += "\nAll group contained element ids are:";
        Autodesk.Revit.DB.ElementArray groupMembers = group.Members;
        foreach (Autodesk.Revit.DB.Element e in groupMembers)
        {
           prompt += "\n\t" + e.Id.IntegerValue;
        }
    }

    TaskDialog.Show("Revit",prompt);
}
CopyVB.NET
Private Sub ShowGroupInformation(ByVal document As Autodesk.Revit.DB.Document, ByVal element As Autodesk.Revit.DB.Element)
    ' Get group information for the selected element
    Dim prompt As [String] = Nothing
    Dim group As Autodesk.Revit.DB.Group = element.Group
    If group Is Nothing Then
        prompt = "The element isn't in any group."
    Else
        prompt = "The element " + element.Id.IntegerValue + " is in a group."
        prompt += vbLf & "The group id is " + group.Id.IntegerValue
        prompt += vbLf & "The group's category is " + group.Category.Name
        prompt += vbLf & "All group contained element ids are:"
        Dim groupMembers As Autodesk.Revit.DB.ElementArray = group.Members
        For Each e As Autodesk.Revit.DB.Element In groupMembers
            prompt += vbLf & vbTab + e.Id.IntegerValue
        Next
    End If

    TaskDialog.Show("Revit", prompt)
End Sub

See Also

Element Class

Id Property

[image]