Revit 2013 API
AnalyticalModel Methods
AnalyticalModel Class See Also Send Feedback

The AnalyticalModel type exposes the following members.

Methods

 | Name | Description
Public method | Approximate | Switches between non-approximated (e.g., Curved) Analytical Models and approximated (made up of lines only) Analytical Models
Public method | CanApproximate | Indicates if Analytical Model can be approximated or not.
Public method | CanDisable | Reports whether the user can enable or disable the Analytical Model programmatically.
Public method | CanDisableAutoDetect | Indicates if Analytical Auto-detect can be disabled programmatically
Public method | CanHaveRigidLinks | Indicates if Analytical Model supports Rigid Links.
Public method | CanSetAnalyticalOffset | Determines whether the Analytical Model Offset can be changed.
Public method | CanUseHardPoints | Indicates if Analytical Model can use Hard Points.
Public method | CloneAdjustment | The method clones the adjustment of one end of the AM on another AM, with respect to the one of the ends. One of the Analytical Model ends
Public method | Disconnect | Unjoin from Hub Element.
Public method | Enable | Enables or disables Analytical Model, if the Element allows a one-operation Analytical Model toggle.
Public method | EnableAutoDetect | Enable or disable Analytical Auto-detect.
Public method | GetAlignmentMethod | Gets the alignment method for a given selector and direction.
Public method | GetAnalyticalModelSketchComponents | Retrieves a collection of AnalyticalModelSketchComponent objects, which are useful for those Analytical Models that have finer calibration below the Element level.
Public method | GetAnalyticalModelSupports | Retrieves the AnalyticalModelSupport array, which is useful to extract Analytical Support Information from Elements.
Public method | GetAnalyticalOffset | Obsolete. Retrieves Analytical Offset in the case where the user can do that.
Public method | GetAnalyticalProjectionDatumPlane(AnalyticalDirection) | Obsolete. Retrieves analytical model projection information for a specific direction.
Public method | GetAnalyticalProjectionDatumPlane(AnalyticalElementSelector, AnalyticalDirection) | Gets the datum plane for a given selector and direction.
Public method | GetAnalyticalProjectionType(AnalyticalDirection) | Obsolete. Retrieves Analytical Model projection information for a specific direction. In direction: direction in which the Analytical Model may be projected.
Public method | GetAnalyticalProjectionType(AnalyticalElementSelector, AnalyticalDirection) | Retrieves Analytical Model projection information for a specific direction. in direction: direction in which the Analytical Model may be projected.
Public method | GetAnalyzeAs | Returns value of Analyze As parameter for Analytical Model.
Public method | GetApproximationDeviation | Retrieves amount by which approximation is made.
Public method | GetAutoDetectMatchedElements | Retrieves other Element Ids that this Element is Auto-detecting against.
Public method | GetCurve | Returns the single curve of the Analytical Model, if it is only one curve.
Public method | GetCurves | Retrieves all curves for the Analytical Model of a given type.
Public method | GetElementId | Retrieves Element Id of the structural element corresponding to the Analytical Model.
Public method | GetManualAdjustmentMatchedElements | Retrieves other Element Ids against which the Analytical Model has been adjusted.
Public method | GetOffset | Gets the offset of the analytical model at end.
Public method | GetPoint | Retrieves point of the Analytical Model.
Public method | GetReference | Returns a reference to a given curve within the analytical model.
Public method | GetRigidLink | Returns rigid link curve corresponding to selector.
Public method | GetSweptProfile | Retrieves the swept profile information for Analytical Model.
Public method | HasAlignment | Checks if analytical alignment is applicable at a given end.
Public method | HasDeletedLinks | Indicates if Analytical Model contains deleted Analytical Links.
Public method | HasRigidLinksWith | Indicates if Analytical Model has Rigid Links with specified element.
Public method | HasSweptProfile | Indicates if this Element's Analytical Model can be represented as a swept profile.
Public method | IsAnalyzeAsValid | Determines if the given Analyze As parameter is valid for this Element.
Public method | IsApproximated | Indicates if Analytical Model is approximated or not.
Public method | IsAutoDetectEnabled | Reports if Analytical Auto-detect for the given direction is enabled.
Public method | IsElementFullySupported | Indicates if Analytical Model is fully supported.
Public method | IsEnabled | Reports whether the Analytical Model is enabled or disabled.
Public method | IsManuallyAdjusted | Indicates if the Analytical Model has been manually adjusted by the user.
Public method | IsModified | Checks if AM has been adjusted from auto-detect at any end.
Public method | IsSingleCurve | Indicates if the Analytical Model can be expressed as a single curve.
Public method | IsSinglePoint | Indicates if the Analytical Model can be expressed as a single point.
Public method | IsSurface | Checks if the analytical model belongs to the surface object like floor, slab or wall.
Public method | IsValidAnalyticalProjectionType | Obsolete. Indicates if a given Analytical Projection Type is valid for the given Analytical Direction.
Public method | IsValidDatumPlaneForProjection | Obsolete. Indicates if a given Datum Plane is valid for analytical model projection with respect to the given analytical direction.
Public method | IsValidDirectionForAutoDetect | Tests if the supplied direction is valid for Analytical Auto-detect.
Public method | IsValidDirectionForProjection | Indicates if the input direction is valid for Analytical Model projection.
Public method | IsValidForManualAdjustment | Indicates if the identified reference is acceptable for Manual Analytical Adjustment.
Public method | IsValidManualAdjustmentSource | Indicates if the identified reference is acceptable as a source for Manual Analytical Adjustment.
Public method | IsValidManualAdjustmentTarget | Indicates if reference is acceptable as a "Target" for Manual Analytical Adjustment.
Public method | IsValidProjectionDatumPlane | Indicates if a given Datum Plane is valid for analytical model projection with respect to the given analytical direction.
Public method | IsValidProjectionType | Indicates if a given Analytical Projection Type is valid for the given Analytical Element Selector and Analytical Direction.
Public method | IsValidRigidLinksOption | Indicates if Rigid Links option is valid for the Analytical Model.
Public method | IsValidSelector | Indicates if the input selector is valid for the Analytical Model.
Public method | IsValidSelectorAndDirection | Indicates if the input selector is valid for analytical direction for Analytical Model.
Public method | ManuallyAdjust | Perform Manual Analytical Adjustment on analytical model, with respect to another Element
Public method | ResetLinks | The function is trying to recreate analytical link elements that were deleted by the user.
Public method | ResetManualAdjustment | Resets all manual adjustments performed by the user onto the Analytical Model.
Public method | SetAlignmentMethod | Sets the alignment method for a given selector and direction.
Public method | SetAnalyticalOffset | Obsolete. Sets Analytical Offset in the case where the user can do that.
Public method | SetAnalyticalProjectionDatumPlane(AnalyticalDirection, ElementId) | Obsolete. Sets analytical model projection to a Datum Plane.
Public method | SetAnalyticalProjectionDatumPlane(AnalyticalElementSelector, AnalyticalDirection, ElementId) | Sets the datum plane for a given selector and direction.
Public method | SetAnalyticalProjectionType(AnalyticalDirection, AnalyticalProjectionType) | Obsolete. Sets the analytical model projection to a preset value.
Public method | SetAnalyticalProjectionType(AnalyticalElementSelector, AnalyticalDirection, AnalyticalProjectionType) | Sets the analytical model projection to a preset value.
Public method | SetAnalyzeAs | Sets value of Analyze As parameter for this Element.
Public method | SetApproximationDeviation | Adjusts the amount by which approximation is made.
Public method | SetOffset | Sets the offset of the analytical model at end.
Public method | SetUsesHardPoints | Sets Hard Points for the Analytical Model.
Public method | SupportsManualAdjustment | Indicates if the Element supports Manual Analytical Adjustment.
Public method | UsesHardPoints | Indicates if the Analytical Model is using Hard Points during approximation.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace

Approximate Method

[image]