Revit 2013 API
Material..::..GetMaterialAspectPropertySet Method
Material Class See Also Send Feedback
Gets the identifier of the shared property set for a given aspect.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This function will be removed in a future release. Use getStructuralAssetId or getThermalAssetId instead.")]
public ElementId GetMaterialAspectPropertySet(
    MaterialAspect aspect
)
Visual Basic
<ObsoleteAttribute("This function will be removed in a future release. Use getStructuralAssetId or getThermalAssetId instead.")> _
Public Function GetMaterialAspectPropertySet ( _
    aspect As MaterialAspect _
) As ElementId
Visual C++
[ObsoleteAttribute(L"This function will be removed in a future release. Use getStructuralAssetId or getThermalAssetId instead.")]
public:
ElementId^ GetMaterialAspectPropertySet(
    MaterialAspect aspect
)

Parameters

aspect
Type: Autodesk.Revit.DB..::..MaterialAspect
The material aspect.

Return Value

Identifier of the shared property set, or invalidElementId if independent (i.e. owned by the material).

See Also

Material Class

GetSmoothness Method

[image]