Revit 2013 API
ExporterIFCUtils..::..CreateExtrudedSurfaceFromCurve Method
ExporterIFCUtils Class See Also Send Feedback
Creates an IfcConnectionGeometry handle from the extrusion of a curve into a surface.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static IFCAnyHandle CreateExtrudedSurfaceFromCurve(
    ExporterIFC exporterIFC,
    Curve curve,
    XYZ extrusionDir,
    double length,
    double baseHeightNonScaled
)
Visual Basic
Public Shared Function CreateExtrudedSurfaceFromCurve ( _
    exporterIFC As ExporterIFC, _
    curve As Curve, _
    extrusionDir As XYZ, _
    length As Double, _
    baseHeightNonScaled As Double _
) As IFCAnyHandle
Visual C++
public:
static IFCAnyHandle^ CreateExtrudedSurfaceFromCurve(
    ExporterIFC^ exporterIFC,
    Curve^ curve,
    XYZ^ extrusionDir,
    double length,
    double baseHeightNonScaled
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
curve
Type: Autodesk.Revit.DB..::..Curve
The curve.
extrusionDir
Type: Autodesk.Revit.DB..::..XYZ
The direction of extrusion.
length
Type: System..::..Double
The length of the extrusion.
baseHeightNonScaled
Type: System..::..Double
The Z location of the base of the extrusion. This value will be subtracted from the Z coordinate of the endpoint of the curve to determine the placement.

Return Value

The IfcConnectionGeometry handle.

Remarks

At the conclusion of this method, an IfcProfileDef handle representing the swept curve, an IfcSurface handle representing the extrusion, and an IfcConnectionGeometry will all be created and added to the export file.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input curve is a helical curve and is not supported for this operation.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace

CreateGUID Method

[image] [image]