Revit 2013 API
GeometryCreationUtilities Members
GeometryCreationUtilities Class Methods See Also Send Feedback

The GeometryCreationUtilities type exposes the following members.

Methods

 | Name | Description
 | CreateBlendGeometry | Creates a solid by blending two closed curve loops lying in non-coincident planes.
 | CreateExtrusionGeometry | Creates a solid by linearly extruding one or more closed coplanar curve loops.
 | CreateRevolvedGeometry | Creates a solid of revolution by revolving a set of closed curve loops around an axis by a specified angle.
 | CreateSweptBlendGeometry | Creates a solid by simultaneously sweeping and blending two or more closed planar curve loops along a single curve.
 | CreateSweptGeometry | Creates a solid by sweeping one or more closed coplanar curve loops along a path.
Public method | Dispose | Releases all resources used by the GeometryCreationUtilities

See Also

GeometryCreationUtilities Class

GeometryCreationUtilities Methods

[image] [image]