Revit 2013 API
BoundarySegment Class
Members Example See Also Send Feedback
An object that represents a segment of a room boundary.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class BoundarySegment : APIObject
Visual Basic
Public Class BoundarySegment _
    Inherits APIObject
Visual C++
public ref class BoundarySegment : public APIObject

Remarks

These objects define the exterior boundary of a room. The geometry of the segment can be retrieved along with the element that is responsible for producing that boundary.

Examples

CopyC#
public void GetInfo_BoundarySegment(Room room)
{
    if (room.GetBoundarySegments(new SpatialElementBoundaryOptions()) != null)
    {
        string message = "BoundarySegment";
        foreach (Autodesk.Revit.DB.Architecture.BoundarySegmentArray boundarySegmentArray in room.GetBoundarySegments(new SpatialElementBoundaryOptions()))
        {
           foreach (Autodesk.Revit.DB.Architecture.BoundarySegment boundarySegment in boundarySegmentArray)
            {
                // Get curve start point
                message += "\nCurve start point:(" + boundarySegment.Curve.get_EndPoint(0).X + ","
                               + boundarySegment.Curve.get_EndPoint(0).Y + "," +
                              boundarySegment.Curve.get_EndPoint(0).Z + ")";
                // Get curve end point
                message += "; Curve end point:(" + boundarySegment.Curve.get_EndPoint(1).X + ","
                     + boundarySegment.Curve.get_EndPoint(1).Y + "," +
                     boundarySegment.Curve.get_EndPoint(1).Z + ")";
                // Get document path name
                message += "; Document path name:" + boundarySegment.Document.PathName;
                // Get boundary segment element name
                message += "; Element name:" + boundarySegment.Element.Name;
            }
        }
        TaskDialog.Show("Revit",message);
    }
}
CopyVB.NET
Public Sub GetInfo_BoundarySegment(ByVal room As Room)
    If room.Boundary IsNot Nothing Then
        Dim message As String = "BoundarySegment"
        For Each boundarySegmentArray As Autodesk.Revit.DB.Architecture.BoundarySegmentArray In room.Boundary
            For Each boundarySegment As Autodesk.Revit.DB.Architecture.BoundarySegment In boundarySegmentArray
                ' Get curve start point
                message += vbLf & "Curve start point:(" + boundarySegment.Curve.EndPoint(0).X + "," + boundarySegment.Curve.EndPoint(0).Y + "," + boundarySegment.Curve.EndPoint(0).Z + ")"
                ' Get curve end point
                message += "; Curve end point:(" + boundarySegment.Curve.EndPoint(1).X + "," + boundarySegment.Curve.EndPoint(1).Y + "," + boundarySegment.Curve.EndPoint(1).Z + ")"
                ' Get document path name
                message += "; Document path name:" + boundarySegment.Document.PathName
                ' Get boundary segment element name
                message += "; Element name:" + boundarySegment.Element.Name
            Next
        Next
        TaskDialog.Show("Revit", message)
    End If
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Architecture..::..BoundarySegment

See Also

BoundarySegment Members
Autodesk.Revit.DB.Architecture Namespace

BoundarySegment Members

[image] [image]