Revit 2013 API
ExporterIFCUtils..::..CreateCoveringPropertySet Method
ExporterIFCUtils Class See Also Send Feedback
Adds the covering-specific property set to the export.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static void CreateCoveringPropertySet(
    ExporterIFC exporterIFC,
    Element elem,
    IFCProductWrapper wrapper
)
Visual Basic
Public Shared Sub CreateCoveringPropertySet ( _
    exporterIFC As ExporterIFC, _
    elem As Element, _
    wrapper As IFCProductWrapper _
)
Visual C++
public:
static void CreateCoveringPropertySet(
    ExporterIFC^ exporterIFC,
    Element^ elem,
    IFCProductWrapper^ wrapper
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
elem
Type: Autodesk.Revit.DB..::..Element
The covering element.
wrapper
Type: Autodesk.Revit.DB.IFC..::..IFCProductWrapper
The product wrapper.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace

CreateCurtainWallPropertySet Method

[image]