Revit 2013 API
BarDescription..::..HookType Property
BarDescription Class See Also Send Feedback
Retrieves the Rebar Hook Type property of a Bar Description.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public RebarHookType this[
    int end
] { get; }
Visual Basic
Public ReadOnly Property HookType ( _
    end As Integer _
) As RebarHookType
    Get
Visual C++
public:
property RebarHookType^ HookType[int end] {
    RebarHookType^ get (int end);
}

Parameters

end
Type: System..::..Int32
Which end of the bar: 0 or 1.

See Also

BarDescription Class
Autodesk.Revit.DB.Structure Namespace

Layer Property

[image]