Revit 2013 API
IFCDoorStyleOperation Enumeration
See Also Send Feedback
The types of door operations, as defined in IFC2x3. This relates to how the door opens.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012
Since: 2012

Syntax

C#
public enum IFCDoorStyleOperation
Visual Basic
Public Enumeration IFCDoorStyleOperation
Visual C++
public enum class IFCDoorStyleOperation

Members

Member name | Description
SingleSwingLeft | Single swing door to the left.
SingleSwingRight | Single swing door to the right.
DoubleDoorSingleSwing | Double door, single swing.
DoubleDoorSingleSwingOppositeLeft | Double door, single swing opposite left.
DoubleDoorSingleSwingOppositeRight | Double door, single swing opposite right.
DoubleSwingLeft | Double door swing left.
DoubleSwingRight | Double door swing right.
DoubleDoorDoubleSwing | Double door double swing.
SlidingToLeft | Sliding door, sliding to the left.
SlidingToRight | Sliding door, sliding to the right.
DoubleDoorSliding | Sliding double door.
FoldingToLeft | Folding door to the left.
FoldingToRight | Folding door to the right.
DoubleDoorFolding | Double folding door.
Revolving | Revolving Door.
RollingUp | Door rolls up.
UserDefined | User-defined door operation.
NotDefined | Undefined door operation.

See Also

Autodesk.Revit.DB.IFC Namespace

IFCDoorWindowInfo Class

[image]