Revit 2013 API
Document Members
Document Class Methods Properties Events See Also Send Feedback

The Document type exposes the following members.

Methods

 | Name | Description
Public method | AutoJoinElements | Forces the elements in the Revit document to automatically join to their neighbors where appropriate.
Public method | Close()()()() | Closes the document, save the changes if there are.
Public method | Close(Boolean) | Closes the document with the option to save.
Public method | CombineElements | Combine a set of combinable elements into a geometry combination.
Public method | ConvertDetailToModelCurves | Converts a group of DetailCurves to equivalent ModelCurves.
Public method | ConvertModelToDetailCurves | Converts a group of ModelCurves to equivalent DetailCurves.
Public method | ConvertModelToSymbolicCurves | Converts a group of ModelCurves to equivalent SymbolicCurves.
Public method | ConvertSymbolicToModelCurves | Converts a group of SymbolicCurves to equivalent ModelCurves.
Public method | Delete(Element) | Deletes an element from the document.
Public method | Delete(ElementId) | Deletes an element from the document given the id of that element.
Public method | Delete(ICollection<(Of <<'(ElementId>)>>)) | Deletes several elements from the document given their ids.
Public method | Delete(ElementSet) | Obsolete. Deletes several elements from the document.
Public method | Dispose | Releases all resources used by the Document
Public method | EditFamily | Gets the document of a loaded family to edit.
Public method | Equals | Determines whether the specified Object equals to this Object. (Overrides Object..::..Equals(Object).)
Public method | Export(String, String, MassGBXMLExportOptions) | Exports a gbXML file from a mass model document.
Public method | Export(String, String, GBXMLExportOptions) | Exports the document in Green-Building XML format.
Public method | Export(String, String, IFCExportOptions) | Exports the document to the Industry Standard Classes (IFC) format.
Public method | Export(String, String, ViewSet, DWFExportOptions) | Exports the current view or a selection of views in DWF format.
Public method | Export(String, String, ViewSet, DWFXExportOptions) | Exports the current view or a selection of views in DWFX format.
Public method | Export(String, String, ViewSet, FBXExportOptions) | Exports the document in 3D-Studio Max (FBX) format.
Public method | Export(String, String, ViewSet, SATExportOptions) | Exports the current view or a selection of views in SAT format.
Public method | Export(String, String, ICollection<(Of <<'(ElementId>)>>), DGNExportOptions) | Exports a selection of views in DGN format.
Public method | Export(String, String, ICollection<(Of <<'(ElementId>)>>), DWGExportOptions) | Exports a selection of views in DWG format.
Public method | Export(String, String, ICollection<(Of <<'(ElementId>)>>), DXFExportOptions) | Exports a selection of views in DXF format.
Public method | Export(String, String, View3D, ViewPlan, BuildingSiteExportOptions) | Exports the document in the format of Civil Engineering design applications.
Public method | ExportImage | Exports a view or set of views into an image file.
Public method | FindReferencesWithContextByDirection | Finds the references that intersect a line extended in a certain direction from an origin point.
Public method | GetDocumentPreviewSettings | Returns the preview settings for the given document.
Public method | GetElement(String) | Gets the Element referenced by the input string name.
Public method | GetElement(ElementId) | Gets the Element referenced by the input string name.
Public method | GetElement(Reference) | Gets the Element referenced by the input reference.
Public method | GetHashCode | Gets the hash code of this document instance. (Overrides Object..::..GetHashCode()()()().)
Public method | GetPrintSettingIds | Retrieves all Print Settings of current project.
Public method | GetRoomAtPoint(XYZ) | Gets a room containing the point.
Public method | GetRoomAtPoint(XYZ, Phase) | Gets a room containing the point.
Public method | GetSpaceAtPoint(XYZ) | Gets a space containing the point.
Public method | GetSpaceAtPoint(XYZ, Phase) | Gets a space containing the point.
Public method | GetWorksetId | Get Id of the Workset which owns the element.
Public method | GetWorksetTable | Get the WorksetTable of this document.
Public method | GetWorksharingCentralModelPath | Gets the central model path of the worksharing model.
Public method | Import(String, GBXMLImportOptions) | Imports a Green-Building XML file into the document.
Public method | Import(String, DGNImportOptions, View, ElementId%) | Imports a DGN file to the document.
Public method | Import(String, DWGImportOptions, View, ElementId%) | Imports a DWG or DXF file to the document.
Public method | Import(String, ImageImportOptions, View, Element%) | Imports an image (a bitmap) into the document.
Public method | Link(String, DGNImportOptions, View, ElementId%) | Links a DGN file to the document.
Public method | Link(String, DWGImportOptions, View, ElementId%) | Links a DWG or DXF file to the document.
Public method | LoadFamily(String) | Loads an entire family and all its types/symbols into the document.
Public method | LoadFamily(Document) | Loads the contents of this family document into another document.
Public method | LoadFamily(String, Family%) | Loads an entire family and all its types/symbols into the document and provides a reference to the loaded family.
Public method | LoadFamily(Document, IFamilyLoadOptions) | Loads the contents of this family document into another document.
Public method | LoadFamily(String, IFamilyLoadOptions, Family%) | Loads an entire family and all its types/symbols into the document and provides a reference to the loaded family.
Public method | LoadFamilySymbol(String, String) | Loads only a specified family type/symbol from a family file into the document.
Public method | LoadFamilySymbol(String, String, FamilySymbol%) | Loads only the specified family type/symbol from a family file into the document and provides a reference to the loaded family symbol.
Public method | LoadFamilySymbol(String, String, IFamilyLoadOptions, FamilySymbol%) | Loads only the specified family type/symbol from a family file into the document and provides a reference to the loaded family symbol.
Public method | PostFailure | Posts a failure to be displayed to the user at the end of transaction.
Public method | Print(ViewSet) | Prints a set of views with default view template and default print settings.
Public method | Print(ViewSet, View) | Prints a set of views with a specified view template and default print settings.
Public method | Print(ViewSet, Boolean) | Prints a set of views with default view template and default print settings.
Public method | Print(ViewSet, View, Boolean) | Prints a set of views with a specified view template and default print settings.
Public method | Regenerate | Updates the elements in the Revit document to reflect all changes.
Public method | Save()()()() | Saves the document.
Public method | Save(SaveOptions) | Saves the document.
Public method | SaveAs(String) | Saves the document to a given file name.
Public method | SaveAs(String, SaveAsOptions) | Saves the document to a given file name with options to change the document's name in Revit and overwrite an existing file.
Public method | SaveToProjectAsImage | Creates an image view from the currently active view.
Public method | SeparateElements | Separate a set of combinable elements out of combinations they currently belong to.
Public method | UnpostFailure | Deletes the posted failure message associated with a given FailureMessageKey.

Properties

 | Name | Description
Public property | ActiveProjectLocation | Retrieve the active project location.
Public property | ActiveView | The document's active view.
Public property | AnnotationSymbolTypes | Retrieves an object that contains all the annotation types that are currently loaded into the project.
Public property | Application | Returns the Application in which the Document resides.
Public property | BeamSystemTypes | Retrieves an object that contains all of beam system types that are currently loaded into the project.
Public property | ContFootingTypes | Retrieves an object that contains all of continuous footing types that are currently loaded into the project.
Public property | Create | An object that can be used to create new instances of Autodesk Revit API elements within a project.
Public property | CurtainSystemTypes | This property is used to retrieve all the CurtainSystem types in current system.
Public property | DeckProfiles | Returns an object that contains all of the available deck profiles currently loaded to this project.
Public property | DimensionTypes | Retrieves an object that contains all of dimension types that are currently loaded into the project.
Public property | DisplayUnitSystem | Provides access to display unit type with in the document.
Public property | ElectricalEquipmentTypes | Returns an object that contains all of the available electrical equipment types currently loaded to this project.
Public property | Element[([( String])]) | Obsolete. Retrieves an element from the document given a unique id string.
Public property | Element[([( ElementId])]) | Obsolete. Retrieves an element from the document given a Revit element id.
Public property | FamilyCreate | An object that can be used to create new instances of Autodesk Revit API elements within a family document.
Public property | FamilyManager | The family manager object provides access to family types and parameters.
Public property | FasciaTypes | Retrieves an object that contains all the Fascia types that are currently loaded into the project.
Public property | FloorTypes | Retrieves an object that contains all the floor types that are currently loaded into the project.
Public property | GridTypes | Retrieves an object that contains all of Grid types that are currently loaded into the project.
Public property | GutterTypes | Retrieves an object that contains all the Gutter types that are currently loaded into the project.
Public property | IsFamilyDocument | Identifies if the current document is a family document.
Public property | IsModifiable | The document's state of modifiability.
Public property | IsModified | The state of changes made to the document.
Public property | IsReadOnly | Identifies if the document is read-only or can possibly be modified.
Public property | IsReadOnlyFile | Signals whether the document was opened from a read-only file.
Public property | IsWorkshared | Identifies if worksharing (i.e. editing permissions and multiple worksets) have been enabled in the document.
Public property | LevelTypes | Retrieves an object that contains all the level types that are currently loaded into the project.
Public property | LightingDeviceTypes | Returns an object that contains all of the available lighting device types currently loaded to this project.
Public property | LightingFixtureTypes | Returns an object that contains all of the available lighting fixture types currently loaded to this project.
Public property | MassDisplayTemporaryOverride | This setting controls temporary display in views of objects with mass category or subcategories.
Public property | MechanicalEquipmentTypes | Returns an object that contains all of the available mechanical equipment types currently loaded to this project.
Public property | MullionTypes | This property is used to retrieve all the mullion types in current system.
Public property | OwnerFamily | Get the Family of this Family Document.
Public property | PanelTypes | Retrieves a set of PanelType objects that contains all the panel types that are currently loaded into the project.
Public property | ParameterBindings | Retrieves an object from which mappings between parameter definitions and categories can be found.
Public property | PathName | The fully qualified path of the document's disk file.
Public property | Phases | Retrieves all the object that represent phases within the project.
Public property | PlanTopologies | Get the PlanTopologies of the current project in the last phase.
Public property | PlanTopologies[([( Phase])]) | Gets the PlanTopologies of the current project in a given phase.
Public property | PlanTopology[([( Level])]) | Get the PlanTopology of a given level in the last phase.
Public property | PlanTopology[([( Level, Phase])]) | Get the PlanTopology of a given level in a given phase.
Public property | PrintManager | Retrieve the PrintManager of current project.
Public property | PrintSettings | Obsolete. Retrieve all Print Settings of current project.
Public property | ProjectInformation | Return the Project Information of the current project.
Public property | ProjectLocations | Retrieve all the project locations associated with this project
Public property | ProjectUnit | Provides access to Project Unit Setting with in the document.
Public property | ReactionsAreUpToDate | Reports if the analytical model has regenerated in a document with reaction loads.
Public property | RebarBarTypes | Retrieves an object that contains all the rebar bar types that are currently loaded into the project.
Public property | RebarCoverTypes | Retrieves an object that contains all the rebar cover types that are currently loaded into the project.
Public property | RebarHookTypes | Retrieves an object that contains all the rebar hook types that are currently loaded into the project.
Public property | RebarShapes | Retrieves an object that contains all the rebar shape types that are currently loaded into the project.
Public property | RoofTypes | Retrieves an object that contains all the roof types that are currently loaded into the project.
Public property | RoomTagTypes | Retrieves an object that contains all of RoomTag types that are currently loaded into the project.
Public property | Settings | Provides access to general application settings, such as Categories.
Public property | SiteLocation | Returns the site location information.
Public property | SlabEdgeTypes | Retrieves an object that contains all the SlabEdge types that are currently loaded into the project.
Public property | SpaceTagTypes | Retrieves an object that contains all of RoomTag types that are currently loaded into the project.
Public property | SpotDimensionTypes | Retrieves an object that contains all of SpotDimension types that are currently loaded into the project.
Public property | TextNoteTypes | Retrieves an object that contains all of TextNote types that are currently loaded into the project.
Public property | Title | The document's title.
Public property | TitleBlocks | Titleblocks currently loaded into the document.
Public property | TrussTypes | Retrieves an object that contains all the truss types that are currently loaded into the project.
Public property | TypeOfStorage | Get the storage type of the specified BuiltInParameter.
Public property | ViewSheetSets | The view sheet sets stored in the document.
Public property | WallTypes | Retrieves an object that contains all the wall types that are currently loaded into the project.
Public property | WorksharingCentralFilename | Obsolete. The name and path of the central model for a workshared document.
Public property | WorksharingCentralGUID | The central GUID of the server-based model.

Events

 | Name | Description
Public event | DocumentClosing | Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.
Public event | DocumentPrinted | Subscribe to the DocumentPrinted event to be notified immediately after Revit has finished printing a view or ViewSet of the document.
Public event | DocumentPrinting | Subscribe to the DocumentPrinting event to be notified when Revit is just about to print a view or ViewSet of the document.
Public event | DocumentSaved | Subscribe to the DocumentSaved event to be notified immediately after Revit has finished saving a document.
Public event | DocumentSavedAs | Subscribe to the DocumentSavedAs event to be notified immediately after Revit has finished saving document with a new file name.
Public event | DocumentSaving | Subscribe to the DocumentSaving event to be notified when Revit is just about to save a document.
Public event | DocumentSavingAs | Subscribe to the DocumentSavingAs event to be notified when Revit is just about to save the document with a new file name.
Public event | ViewPrinted | Subscribe to the ViewPrinted event to be notified immediately after Revit has finished printing a view of the document.
Public event | ViewPrinting | Subscribe to the ViewPrinting event to be notified when Revit is just about to print a view of the document.

See Also

Document Class

Document Methods

[image] [image]