Revit 2013 API
SlabShapeEditor..::..ResetSlabShape Method
SlabShapeEditor Class Example See Also Send Feedback
Removes the modifications made during editing and resets the element geometry back to the unmodified state.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void ResetSlabShape()
Visual Basic
Public Sub ResetSlabShape
Visual C++
public:
void ResetSlabShape()

Remarks

Calling this method will reset the slab back to its original state and disable Slab Shape Editing. If further editing is needed, call Enable again.

Examples

CopyC#
private void ResetSlabShapes(Autodesk.Revit.DB.Document document)
{
    UIDocument uidoc = new UIDocument(document);
    Selection choices = uidoc.Selection;
    ElementSet collection = choices.Elements;
    foreach (Autodesk.Revit.DB.Element elem in collection)
    {
        Floor floor = elem as Floor;
        if (floor != null)
        {
            SlabShapeEditor slabShapeEditor = floor.SlabShapeEditor;
            slabShapeEditor.ResetSlabShape();
        }
    }

}
CopyVB.NET
Private Sub ResetSlabShapes(ByVal document As Autodesk.Revit.DB.Document)
    Dim uidoc As New UIDocument(document)
    Dim choices As Autodesk.Revit.UI.Selection.Selection = uidoc.Selection
    Dim collection As ElementSet = choices.Elements
    For Each elem As Autodesk.Revit.DB.Element In collection
        Dim floor As Floor = TryCast(elem, Floor)
        If floor IsNot Nothing Then
            Dim slabShapeEditor As SlabShapeEditor = floor.SlabShapeEditor
            slabShapeEditor.ResetSlabShape()
        End If
    Next

End Sub

See Also

SlabShapeEditor Class

SlabShapeEditor Properties

[image] [image]