Revit 2013 API
GeometryObject..::..Inequality Operator
GeometryObject Class See Also Send Feedback
Determines whether two GeometryObjects are different.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static bool operator !=(
    GeometryObject first,
    GeometryObject second
)
Visual Basic
Public Shared Operator <> ( _
    first As GeometryObject, _
    second As GeometryObject _
) As Boolean
Visual C++
public:
static bool operator !=(
    GeometryObject^ first,
    GeometryObject^ second
)

Parameters

first
Type: Autodesk.Revit.DB..::..GeometryObject
The first GeometryObject.
second
Type: Autodesk.Revit.DB..::..GeometryObject
The second GeometryObject.

Return Value

True if the GeometryObjects are different; otherwise, false.

Remarks

This compares the internal identifiers of the geometry, and doesn't compare them geometrically.

See Also

GeometryObject Class

GeometryObject Properties

[image] [image]