Revit 2013 API
ElectricalConnector Class
Members See Also Send Feedback
An electrical connector that is assigned to an electrical equipment or device family. Provides access to the electrical connector in Autodesk Revit MEP family document.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This class is obsolete in Revit 2013. Use ConnectorElement instead.")]
public class ElectricalConnector : ConnectorElement
Visual Basic
<ObsoleteAttribute("This class is obsolete in Revit 2013. Use ConnectorElement instead.")> _
Public Class ElectricalConnector _
    Inherits ConnectorElement
Visual C++
[ObsoleteAttribute(L"This class is obsolete in Revit 2013. Use ConnectorElement instead.")]
public ref class ElectricalConnector : public ConnectorElement

Remarks

This element type is accessible only in Autodesk Revit MEP family documents. Electrical connectors that are accessible in MEP project documents are not elements, and are represented by Connector.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ConnectorElement
Autodesk.Revit.DB.Electrical..::..ElectricalConnector

See Also

ElectricalConnector Members
Autodesk.Revit.DB.Electrical Namespace

ElectricalConnector Members

[image] [image]