Revit 2013 API
Application..::..NewArc Method (XYZ, Double, Double, Double, XYZ, XYZ)
Application Class Example See Also Send Feedback
Creates a new geometric arc object based on center, radius, unit vectors, and angles.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Arc NewArc(
    XYZ center,
    double radius,
    double startAngle,
    double endAngle,
    XYZ xAxis,
    XYZ yAxis
)
Visual Basic
Public Function NewArc ( _
    center As XYZ, _
    radius As Double, _
    startAngle As Double, _
    endAngle As Double, _
    xAxis As XYZ, _
    yAxis As XYZ _
) As Arc
Visual C++
public:
Arc^ NewArc(
    XYZ^ center,
    double radius,
    double startAngle,
    double endAngle,
    XYZ^ xAxis,
    XYZ^ yAxis
)

Parameters

center
Type: Autodesk.Revit.DB..::..XYZ
The center of the arc.
radius
Type: System..::..Double
The radius of the arc.
startAngle
Type: System..::..Double
The start angle of the arc (in radians).
endAngle
Type: System..::..Double
The end angle of the arc (in radians).
xAxis
Type: Autodesk.Revit.DB..::..XYZ
The x axis to define the arc plane. Must be normalized.
yAxis
Type: Autodesk.Revit.DB..::..XYZ
The y axis to define the arc plane. Must be normalized.

Remarks

Examples

CopyC#
// Create a new arc defined by its center, radios, angles and 2 axes
double radius = 10;
double startAngle = 0;      // In radian
double endAngle = Math.PI;        // In radian
XYZ center = new XYZ(5, 0, 0);
XYZ xAxis = new XYZ(1, 0, 0);   // The x axis to define the arc plane. Must be normalized
XYZ yAxis = new XYZ(0, 1, 0);   // The y axis to define the arc plane. Must be normalized

Arc arc = application.Create.NewArc(center, radius, startAngle, endAngle, xAxis, yAxis);
CopyVB.NET
' Create a new arc defined by its center, radios, angles and 2 axes
Dim radius As Double = 10
Dim startAngle As Double = 0
' In radian
Dim endAngle As Double = Math.PI
' In radian
Dim center As New Autodesk.Revit.DB.XYZ(5, 0, 0)
Dim xAxis As New Autodesk.Revit.DB.XYZ(1, 0, 0)
' The x axis to define the arc plane. Must be normalized
Dim yAxis As New Autodesk.Revit.DB.XYZ(0, 1, 0)
' The y axis to define the arc plane. Must be normalized
Dim arc As Arc = application.Create.NewArc(center, radius, startAngle, endAngle, xAxis, yAxis)

See Also

Application Class
NewArc Overload
Autodesk.Revit.Creation Namespace

NewAreaCreationData Method

[image]