Revit 2013 API
ItemFactoryBase Members
ItemFactoryBase Class Methods Properties See Also Send Feedback

The ItemFactoryBase type exposes the following members.

Methods

 | Name | Description
Public method | NewAlignment | Add a new locked alignment into the Autodesk Revit document.
Public method | NewAnnotationSymbol | Obsolete. Add a new instance of an Annotation Symbol into the Autodesk Revit document, using an origin and a view where the instance should be placed.
Public method | NewDetailCurve | Creates a new detail curve element.
Public method | NewDetailCurveArray | Creates an array of new detail curve elements.
Public method | NewDimension(View, Line, ReferenceArray) | Creates a new linear dimension object using the default dimension style.
Public method | NewDimension(View, Line, ReferenceArray, DimensionType) | Creates a new linear dimension object using the specified dimension style.
Public method | NewFamilyInstance(Face, Line, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a line on that face for its position, and a type/symbol.
Public method | NewFamilyInstance(Line, FamilySymbol, View) | Add a line based detail family instance into the Autodesk Revit document, using an line and a view where the instance should be placed.
Public method | NewFamilyInstance(Reference, Line, FamilySymbol) | Inserts a new instance of a family onto a face referenced by the input Reference instance, using a line on that face for its position, and a type/symbol.
Public method | NewFamilyInstance(XYZ, FamilySymbol, StructuralType) | Inserts a new instance of a family into the document, using a location and a type/symbol.
Public method | NewFamilyInstance(XYZ, FamilySymbol, View) | Add a new family instance into the Autodesk Revit document, using an origin and a view where the instance should be placed.
Public method | NewFamilyInstance(Face, XYZ, XYZ, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a location, reference direction, and a type/symbol.
Public method | NewFamilyInstance(Reference, XYZ, XYZ, FamilySymbol) | Inserts a new instance of a family onto a face referenced by the input Reference instance, using a location, reference direction, and a type/symbol.
Public method | NewFamilyInstance(XYZ, FamilySymbol, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, and the host element.
Public method | NewFamilyInstance(XYZ, FamilySymbol, XYZ, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, the host element and a reference direction.
Public method | NewFamilyInstances | Obsolete. Creates Family instances within the document.
Public method | NewFamilyInstances2 | Creates Family instances within the document.
Public method | NewGroup(ICollection<(Of <<'(ElementId>)>>)) | Creates a new type of group.
Public method | NewGroup(ElementSet) | Obsolete. Creates a new type of group.
Public method | NewLevel | Creates a new level.
Public method | NewModelCurve | Creates a new model line element.
Public method | NewModelCurveArray | Creates an array of new model line elements.
Public method | NewReferencePlane | Creates a new instance of ReferencePlane.
Public method | NewReferencePlane2 | Creates a new instance of ReferencePlane.
Public method | NewSketchPlane(PlanarFace) | Creates a new sketch plane on a planar face of existing geometry.
Public method | NewSketchPlane(Plane) | Creates a new sketch plane from an arbitrary geometric plane.
Public method | NewSketchPlane(Reference) | Creates a new sketch plane on a reference to existing planar geometry.
Public method | NewTextNote(View, XYZ, XYZ, XYZ, Double, TextAlignFlags, String) | Creates a new TextNote object without a leader.
Public method | NewTextNote(View, XYZ, XYZ, XYZ, Double, TextAlignFlags, TextNoteLeaderTypes, TextNoteLeaderStyles, XYZ, XYZ, String) | Creates a new text note with a single leader.
Public method | NewTextNotes | Obsolete. Creates TextNotes with the specified data.
Public method | NewView3D | Obsolete. Creates a new 3D view.
Public method | NewViewPlan | Obsolete. Creates a plan view based on the specified level.
Public method | NewViewSection | Obsolete. Creates a new section view.
Public method | PlaceGroup | Place an instance of a Model Group into the Autodesk Revit document, using a location and a group type.

Properties

 | Name | Description

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace

ItemFactoryBase Methods

[image] [image]