Revit 2013 API
ExternalServiceRegistry..::..ExecuteService Method (Guid, IExternalData)
ExternalServiceRegistry Class See Also Send Feedback
Execute a service independently of any document.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static ExternalServiceResult ExecuteService(
    Guid executionKey,
    IExternalData data
)
Visual Basic
Public Shared Function ExecuteService ( _
    executionKey As Guid, _
    data As IExternalData _
) As ExternalServiceResult
Visual C++
public:
static ExternalServiceResult ExecuteService(
    Guid executionKey,
    IExternalData^ data
)

Parameters

executionKey
Type: System..::..Guid
Access key of the service to be executed. The key is not the same as the service's Id. It is the value that was returned to the caller who registered the service.
data
Type: Autodesk.Revit.DB.ExternalService..::..IExternalData
The associated data. The type is defined by the service.

Return Value

The result of executing the external service.

Remarks

Execution of a service should be invoked only by the application that registered the service. The execution will use the currently active server (or servers in the case of a multi-server service).

This method does not take a document as one of its argument and therefore it is not intended for executions that modify documents. If the service or its server(s) is expected to modify documents, the other ExecuteService method is supposed to be used. Please note that only serializable services are allowed to modify the document in which a service is being executed.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The execution key is either invalid or of a service that is not registered. To execute a service, the key returned by RegisterService method must be used. -or- The execution key is of a service that is already being executed.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExternalServiceRegistry Class
ExecuteService Overload
Autodesk.Revit.DB.ExternalService Namespace

ExecuteService Method (Guid, Document, IExternalData)

[image]