Revit 2013 API
CompoundStructure..::..SetNumberOfShellLayers Method
CompoundStructure Class See Also Send Feedback
Sets the number of interior or exterior shell layers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetNumberOfShellLayers(
    ShellLayerType shellLayerType,
    int numLayers
)
Visual Basic
Public Sub SetNumberOfShellLayers ( _
    shellLayerType As ShellLayerType, _
    numLayers As Integer _
)
Visual C++
public:
void SetNumberOfShellLayers(
    ShellLayerType shellLayerType,
    int numLayers
)

Parameters

shellLayerType
Type: Autodesk.Revit.DB..::..ShellLayerType
If ShellLayerType::Exterior sets the number of exterior shell layers, otherwise sets the number of interior shell layers.
numLayers
Type: System..::..Int32
Number of layers in the specified shell.

Remarks

There must be at least one core layer, i.e. one layer which is not a shell layer.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Number of shell layers is negative.
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | Too many shell layers: there must be at least one core layer.

See Also

CompoundStructure Class

SetParticipatesInWrapping Method

[image]