Revit 2013 API
ConceptualSurfaceType Members
ConceptualSurfaceType Class Methods Properties See Also Send Feedback

The ConceptualSurfaceType type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ConceptualSurfaceType
 | GetAllMassSubCategoryIds | Get all the mass subcategory ids for which there are ConceptualSurfaceType's.
 | GetByMassSubCategoryId | Get the ConceptualSurfaceType by its mass subcategory id.
Public method | GetConstructionTypeIds | The element ids of the ConceptualConstructionType's associated with this ConceptualSurfaceType.

Properties

 | Name | Description
Public property | DefaultConstructionTypeId | The element id of the user specified ConceptualConstructionType to be used by default on creation for mass faces of this mass subcategory.
Public property | MassSubCategoryId | The mass subcategory id of the ConceptualSurfaceType.

See Also

ConceptualSurfaceType Class
Autodesk.Revit.DB.Analysis Namespace

ConceptualSurfaceType Methods

[image] [image]