Revit 2013 API
Document..::..NewSpace Method (Phase)
Document Class See Also Send Feedback
Creates a new unplaced space on a given phase.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Space NewSpace(
    Phase phase
)
Visual Basic
Public Function NewSpace ( _
    phase As Phase _
) As Space
Visual C++
public:
Space^ NewSpace(
    Phase^ phase
)

Parameters

phase
Type: Autodesk.Revit.DB..::..Phase
The phase in which the space is to exist.

Return Value

If successful the new space should be returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Document Class
NewSpace Overload
Autodesk.Revit.Creation Namespace

NewSpace Method (Level, UV)

[image]