Revit 2013 API
FabricSheetType..::..IsValidMaterial Method
FabricSheetType Class See Also Send Feedback
Verifies that input is ElementId of a Material

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsValidMaterial(
    ElementId elemId
)
Visual Basic
Public Function IsValidMaterial ( _
    elemId As ElementId _
) As Boolean
Visual C++
public:
bool IsValidMaterial(
    ElementId^ elemId
)

Parameters

elemId
Type: Autodesk.Revit.DB..::..ElementId
ElementId of expected Material

Return Value

True if ElementId is of a Material

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FabricSheetType Class
Autodesk.Revit.DB.Structure Namespace

IsValidMinorLapSplice Method

[image]