Revit 2013 API
Rebar Class
Members Example See Also Send Feedback
Represents a rebar element in Autodesk Revit.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2009

Syntax

C#
public class Rebar : Element
Visual Basic
Public Class Rebar _
    Inherits Element
Visual C++
public ref class Rebar : public Element

Examples

CopyC#
private void Getinfo_Rebar(Rebar rebar)
{
    string message = "Rebar: ";
    //get the bar type of the rebar
    message += "\nBar Type: " + rebar.BarType.Name;

    //get the curve information
    IList<Curve> curves = rebar.GetCenterlineCurves(false, false, false);
    message += "\n\nThe Curves property has " + curves.Count + " curves:";
    foreach (Curve curve in curves)
    {
        // Get curve start point
        message += "\nCurve start point:(" + curve.get_EndPoint(0).X + ", "
            + curve.get_EndPoint(0).Y + ", " + curve.get_EndPoint(0).Z + ")";
        // Get curve end point
        message += "; Curve end point:(" + curve.get_EndPoint(1).X + ", "
            + curve.get_EndPoint(1).Y + ", " + curve.get_EndPoint(1).Z + ")";
    }

    //get the host element of the rebar
    if (null != rebar.Host) //maybe some rebars don't have host
    {
        message += "\n\nThe host element ID : " + rebar.Host.Id.IntegerValue;
    }

    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Private Sub Getinfo_Rebar(ByVal rebar As Autodesk.Revit.DB.Structure.Rebar)
    Dim message As String = "Rebar: "
    'get the bar type of the rebar
    message += vbLf & "Bar Type: " + rebar.BarType.Name

    'get the curve information
    Dim curves As CurveArray = rebar.Curves
    message += vbLf & vbLf & "The Curves property has " + curves.Size + " curves:"
    For Each curve As Curve In curves
        ' Get curve start point
        message += vbLf & "Curve start point:(" + curve.EndPoint(0).X + ", " + curve.EndPoint(0).Y + ", " + curve.EndPoint(0).Z + ")"
        ' Get curve end point
        message += "; Curve end point:(" + curve.EndPoint(1).X + ", " + curve.EndPoint(1).Y + ", " + curve.EndPoint(1).Z + ")"
    Next

    'get the host element of the rebar
    If rebar.Host IsNot Nothing Then
        'maybe some rebars don't have host
        message += vbLf & vbLf & "The host element ID : " + rebar.Host.Id.IntegerValue
    End If

    TaskDialog.Show("Revit", message)
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB.Structure..::..Rebar

See Also

Rebar Members
Autodesk.Revit.DB.Structure Namespace

Rebar Members

[image] [image]