Revit 2013 API
MEPSystem Members
MEPSystem Class Methods Properties See Also Send Feedback

The MEPSystem type exposes the following members.

Methods

 | Name | Description
Public method | Add | Add elements into the system and connect them with the system using given connectors.
Public method | GetCriticalPathSectionNumbers | Obtains a list of the critical path section numbers.
Public method | GetSectionByIndex | Get the section from the index.
Public method | GetSectionByNumber | Get the Section from section number
Public method | Remove(ICollection<(Of <<'(ElementId>)>>)) | Remove elements from system.
Public method | Remove(ElementSet) | Obsolete. Remove elements from system.

Properties

 | Name | Description
Public property | BaseEquipment | The base panel or equipment of the system.
Public property | BaseEquipmentConnector | The connector within base equipment which is used to connect with system.
Public property | ConnectorManager | Connector manager of the system.
Public property | Elements | Terminal elements in the system.
Public property | IsDefaultSystem | Indicates if the system is a default system or not.
Public property | IsEmpty | Indicates if the system is empty or not.
Public property | IsValid | Indicates if the system is valid or not. atom AtomValidateSystem default false setter setIsValid public_api
Public property | PressureLossOfCriticalPath | The total pressure loss of the sections in critical path.
Public property | SectionsCount | The number of sections.

See Also

MEPSystem Class

MEPSystem Methods

[image] [image]