Revit 2013 API
ScheduleField..::..ParameterId Property
ScheduleField Class See Also Send Feedback
The ID of the parameter displayed by the field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId ParameterId { get; }
Visual Basic
Public ReadOnly Property ParameterId As ElementId
    Get
Visual C++
public:
property ElementId^ ParameterId {
    ElementId^ get ();
}

Field Value

The parameter ID, or InvalidElementId.

Remarks

Most field types require a parameter ID. Count, Formula, and Percentage fields don't have parameter IDs.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

ScheduleField Class

PercentageBy Property

[image]