Revit 2013 API
Selection..::..PickObjects Method
Selection Class See Also Send Feedback
Prompts the user to select multiple objects.

Overload List

 | Name | Description
Public method | PickObjects(ObjectType) | Prompts the user to select multiple objects.
Public method | PickObjects(ObjectType, ISelectionFilter) | Prompts the user to select multiple objects which pass a customer filter.
Public method | PickObjects(ObjectType, String) | Prompts the user to select multiple objects while showing a custom status prompt string.
Public method | PickObjects(ObjectType, ISelectionFilter, String) | Prompts the user to select multiple objects which pass a custom filter while showing a custom status prompt string.
Public method | PickObjects(ObjectType, ISelectionFilter, String, IList<(Of <<'(Reference>)>>)) | Prompts the user to select multiple objects which pass a custom filter while showing a custom status prompt string. A preselected set of objects may be supplied and will be selected at the start of the selection.

See Also

Selection Class
Selection Members
Autodesk.Revit.UI.Selection Namespace

PickObjects Method (ObjectType)

[image]