Revit 2013 API
DuctConnector Class
Members See Also Send Feedback
A duct connector that is assigned to a mechanical equipment or duct fitting family. Provides access to the duct connector in Autodesk Revit MEP family document.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This class is obsolete in Revit 2013. Use ConnectorElement instead.")]
public class DuctConnector : ConnectorElement
Visual Basic
<ObsoleteAttribute("This class is obsolete in Revit 2013. Use ConnectorElement instead.")> _
Public Class DuctConnector _
    Inherits ConnectorElement
Visual C++
[ObsoleteAttribute(L"This class is obsolete in Revit 2013. Use ConnectorElement instead.")]
public ref class DuctConnector : public ConnectorElement

Remarks

This element type is accessible only in Autodesk Revit MEP family documents. Duct connectors that are accessible in MEP project documents are not elements, and are represented by Connector.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ConnectorElement
Autodesk.Revit.DB.Mechanical..::..DuctConnector

See Also

DuctConnector Members
Autodesk.Revit.DB.Mechanical Namespace

DuctConnector Members

[image] [image]