Revit 2013 API
PipeMaterialType Class
Members See Also Send Feedback
A pipe material type in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This class is obsolete in Revit 2013.  Please use Autodesk::Revit::DB::Material instead.")]
public class PipeMaterialType : ElementType
Visual Basic
<ObsoleteAttribute("This class is obsolete in Revit 2013.  Please use Autodesk::Revit::DB::Material instead.")> _
Public Class PipeMaterialType _
    Inherits ElementType
Visual C++
[ObsoleteAttribute(L"This class is obsolete in Revit 2013.  Please use Autodesk::Revit::DB::Material instead.")]
public ref class PipeMaterialType : public ElementType

Remarks

The pipe material type is only available in the Autodesk Revit MEP product.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB.Plumbing..::..PipeMaterialType

See Also

PipeMaterialType Members
Autodesk.Revit.DB.Plumbing Namespace

PipeMaterialType Members

[image] [image]