Revit 2013 API
Document..::..NewFamilyInstance Method (XYZ, FamilySymbol, Element, Level, StructuralType)
Document Class Example See Also Send Feedback
Inserts a new instance of a family into the document, using a location, type/symbol, the host element and a base level.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilyInstance NewFamilyInstance(
    XYZ location,
    FamilySymbol symbol,
    Element host,
    Level level,
    StructuralType structuralType
)
Visual Basic
Public Function NewFamilyInstance ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    host As Element, _
    level As Level, _
    structuralType As StructuralType _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewFamilyInstance(
    XYZ^ location,
    FamilySymbol^ symbol,
    Element^ host,
    Level^ level,
    StructuralType structuralType
)

Parameters

location
Type: Autodesk.Revit.DB..::..XYZ
The physical location where the instance is to be placed on the specified level.
symbol
Type: Autodesk.Revit.DB..::..FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
host
Type: Autodesk.Revit.DB..::..Element
A host object into which the instance will be embedded
level
Type: Autodesk.Revit.DB..::..Level
A Level object that is used as the base level for the object.
structuralType
Type: Autodesk.Revit.DB.Structure..::..StructuralType
If structural then specify the type of the component.

Return Value

If creation was successful then an instance to the new object is returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

This form of NewFamilyInstance is the most commonly used in Autodesk Revit since there are a large number of elements that use levels, such as Walls, Columns etc. If the instance fails to be created an exception may be thrown.

The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

All levels within the document can be found by iterating over the entire document and searching for objects of type Autodesk.Revit.Elements.Level.

Some Families, such as Beams, have more than one endpoint and are inserted in the same manner as single point instances. Once inserted these linear family instances can have their endpoints changed by using the instance's Element.Location property.

Note: ForbiddenForDynamicUpdateException might be thrown during a dynamic update if the inserted instance establishes a mutual dependency with another structure.

Note: if the created family instance includes nested instances, the API framework will automatically regenerate the document during this method call. This happens regardless of the setting for RegenerationMode.

Examples

CopyC#
void CreateDoorsInWall(Autodesk.Revit.DB.Document document, Wall wall)
{
    String fileName = @"C:\Documents and Settings\All Users\Application Data\Autodesk\RST 2011\Imperial Library\Doors\Single-Decorative 2.rfa";

    Family family = null;
    if (!document.LoadFamily(fileName, out family))
    {
        throw new Exception("Unable to load " + fileName);
    }

    // get the active view's level for beam creation
    Level level = document.ActiveView.Level;

    FamilySymbolSetIterator symbolItor = family.Symbols.ForwardIterator();
    double x = 0, y = 0, z = 0;
    while (symbolItor.MoveNext())
    {
        FamilySymbol symbol = symbolItor.Current as FamilySymbol;
        XYZ location = new XYZ(x, y, z);
        FamilyInstance instance = document.Create.NewFamilyInstance(location, symbol, wall, level, StructuralType.NonStructural);
        x += 10;
        y += 10;
        z += 1.5;
    }
}
CopyVB.NET
Sub CreateDoorsInWall(ByVal document As Autodesk.Revit.DB.Document, ByVal wall As Wall)
    Dim fileName As [String] = "C:\Documents and Settings\All Users\Application Data\Autodesk\RST 2011\Imperial Library\Doors\Single-Decorative 2.rfa"

    Dim family As Family = Nothing
    If Not document.LoadFamily(fileName, family) Then
        Throw New Exception("Unable to load " + fileName)
    End If

    ' get the active view's level for beam creation
    Dim level As Level = document.ActiveView.Level

    Dim symbolItor As FamilySymbolSetIterator = family.Symbols.ForwardIterator()
    Dim x As Double = 0, y As Double = 0, z As Double = 0
    While symbolItor.MoveNext()
        Dim symbol As FamilySymbol = TryCast(symbolItor.Current, FamilySymbol)
        Dim location As New Autodesk.Revit.DB.XYZ(x, y, z)
        Dim instance As Autodesk.Revit.DB.FamilyInstance = document.Create.NewFamilyInstance(location, symbol, wall, level, Autodesk.Revit.DB.Structure.StructuralType.NonStructural)
        x += 10
        y += 10
        z += 1.5
    End While
End Sub

See Also

Document Class
NewFamilyInstance Overload
Autodesk.Revit.Creation Namespace

NewFascia Method

[image] [image]