Revit 2013 API
PointCloudFilter Class
Members Example See Also Send Feedback
A class used to describe the criteria an application desires when obtaining members of a point cloud.

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class PointCloudFilter : IDisposable
Visual Basic
Public Class PointCloudFilter _
    Implements IDisposable
Visual C++
public ref class PointCloudFilter : IDisposable

Remarks

Client applications which wish to obtain points from a point cloud will have to create a PointCloudFilter to define the volume of interest (see PointCloudFilterFactory). Engine implementations will need to use the methods contained within the point cloud to determine which points to return to Revit.

Examples

CopyC#
    // Filter will match 1/8 of the overall point cloud
    // Use the bounding box (filter coordinates are in the coordinates of the model)
    BoundingBoxXYZ boundingBox = pointCloudInstance.get_BoundingBox(null);
    List<Plane> planes = new List<Plane>();
    XYZ midpoint = (boundingBox.Min + boundingBox.Max) / 2.0;

    // X boundaries
    planes.Add(app.Create.NewPlane(XYZ.BasisX, boundingBox.Min));
    planes.Add(app.Create.NewPlane(-XYZ.BasisX, midpoint));

    // Y boundaries
    planes.Add(app.Create.NewPlane(XYZ.BasisY, boundingBox.Min));
    planes.Add(app.Create.NewPlane(-XYZ.BasisY, midpoint));

    // Z boundaries
    planes.Add(app.Create.NewPlane(XYZ.BasisZ, boundingBox.Min));
    planes.Add(app.Create.NewPlane(-XYZ.BasisZ, midpoint));

    // Create filter
    PointCloudFilter filter = PointCloudFilterFactory.CreateMultiPlaneFilter(planes);

    return filter;
}

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.PointClouds..::..PointCloudFilter

See Also

PointCloudFilter Members
Autodesk.Revit.DB.PointClouds Namespace

PointCloudFilter Members

[image] [image]