Revit 2013 API
CompoundStructure..::..ClearWallSweeps Method
CompoundStructure Class See Also Send Feedback
Removes all sweeps or reveals.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void ClearWallSweeps(
    WallSweepType wallSweepType
)
Visual Basic
Public Sub ClearWallSweeps ( _
    wallSweepType As WallSweepType _
)
Visual C++
public:
void ClearWallSweeps(
    WallSweepType wallSweepType
)

Parameters

wallSweepType
Type: Autodesk.Revit.DB..::..WallSweepType
The type of a wall sweep.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is valid only vertically compound structures.

See Also

CompoundStructure Class

CreateSimpleCompoundStructure Method

[image]