Revit 2013 API
Transform..::..Reflection Property
Transform Class Example See Also Send Feedback
The transformation that reflects about the specified plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static Transform this[
    Plane plane
] { get; }
Visual Basic
Public Shared ReadOnly Property Reflection ( _
    plane As Plane _
) As Transform
    Get
Visual C++
public:
static property Transform^ Reflection[Plane^ plane] {
    Transform^ get (Plane^ plane);
}

Parameters

plane
Type: Autodesk.Revit.DB..::..Plane
The plane to reflect about.

Examples

CopyC#
private Transform Reflect(ReferencePlane refPlane)
{
    Transform mirTrans = Transform.get_Reflection(refPlane.Plane);

    return mirTrans;
}
CopyVB.NET
Private Function Reflect(ByVal refPlane As ReferencePlane) As Transform
    Dim mirTrans As Transform = Transform.Reflection(refPlane.Plane)

    Return mirTrans
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the handle of the plane is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Transform Class

Rotation Property

[image]