Revit 2013 API
StringStringMap..::..Item Property
StringStringMap Class See Also Send Feedback
Gets or sets a string item at a specified string key within the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual string this[
    string key
] { get; set; }
Visual Basic
Public Overridable Property Item ( _
    key As String _
) As String
    Get
    Set
Visual C++
public:
virtual property String^ Item[String^ key] {
    String^ get (String^ key);
    void set (String^ key, String^ value);
}

Parameters

key
Type: System..::..String
The string key of the string item to be set or retrieved.

Return Value

Returns the string item at the specified string key.

See Also

StringStringMap Class
Autodesk.Revit.Collections Namespace

Size Property

[image]