Revit 2013 API
RadialArray Methods
RadialArray Class See Also Send Feedback

The RadialArray type exposes the following members.

Methods

 | Name | Description
 | ArrayElementsWithoutAssociation | Creates a new radial array from a set of elements based on an input rotation axis.
 | ArrayElementWithoutAssociation | Creates a new radial array from a single element based on an input rotation axis.
 | Create(Document, View, ElementId, Int32, Line, Double, ArrayAnchorMember) | Creates a new radial array element from a single element based on an input rotation axis.
 | Create(Document, View, ICollection<(Of <<'(ElementId>)>>), Int32, Line, Double, ArrayAnchorMember) | Creates a new radial array element from a set of elements based on an input rotation axis.
Public method | GetCopiedMemberIds | Retrieves the copied member Ids of the Array. (Overrides BaseArray..::..GetCopiedMemberIds()()()().)
Public method | GetOriginalMemberIds | Retrieves the original member Ids of the Array. (Overrides BaseArray..::..GetOriginalMemberIds()()()().)
 | IsValidArraySize | This indicates whether the input count is valid.

See Also

RadialArray Class

ArrayElementsWithoutAssociation Method

[image]