Revit 2013 API
Material..::..Duplicate Method
Material Class Example See Also Send Feedback
Duplicates the material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Material Duplicate(
    string name
)
Visual Basic
Public Overridable Function Duplicate ( _
    name As String _
) As Material
Visual C++
public:
virtual Material^ Duplicate(
    String^ name
)

Parameters

name
Type: System..::..String
Name of the new material.

Return Value

The new material.

Remarks

If the name specified contains invalid characters, or the name has been used by other materials in the project, an ArgumentException will be thrown. If duplication fails, nullNothingnullptra null reference (Nothing in Visual Basic) will be returned.

Examples

CopyC#
private bool DuplicateMaterial(Material material)
{
    bool duplicated = false;
    //try to duplicate a new instance of Material class using duplicate method
    //make sure the name of new material is unique in MaterailSet
    string newName = "new" + material.Name;
    Material myMaterial = material.Duplicate(newName);
    if (null == myMaterial)
    {
        TaskDialog.Show("Revit","Failed to duplicate a material!");
    }
    else
    {
        duplicated = true;
    }

    return duplicated;
}
CopyVB.NET
Private Function DuplicateMaterial(ByVal material As Autodesk.Revit.DB.Material) As Boolean
    Dim duplicated As Boolean = False
    'try to duplicate a new instance of Material class using duplicate method
    'make sure the name of new material is unique in MaterailSet
    Dim newName As String = "new" + material.Name
    Dim myMaterial As Autodesk.Revit.DB.Material = material.Duplicate(newName)
    If myMaterial Is Nothing Then
        TaskDialog.Show("Revit", "Failed to duplicate a material!")
    Else
        duplicated = True
    End If

    Return duplicated
End Function

See Also

Material Class

GetCutPatternColor Method

[image]