Revit 2013 API
Railing Members
Railing Class Methods Properties See Also Send Feedback

The Railing type exposes the following members.

Methods

 | Name | Description
 | Create | Automatically creates new railings with the specified railing type on all sides of a stairs element.
Public method | Flip | Flips the railing.
Public method | GetHandRails | Get all the handrails of the railing.
Public method | GetPath | Gets the railing path.
 | IsValidHostForNewRailing | Checks whether new railing can be created and placed on the specified host.
Public method | RemoveHost | Removes the association between the railing and its host.
Public method | Reset | Resets the railing to the default one that the system generates.

Properties

 | Name | Description
Public property | CanReset | True if the railing can be reset, False otherwise.
Public property | Flipped | Indicates if the railing is flipped.
Public property | HasHost | Indicates if the railing has a host.
Public property | HostId | The host of the railing.
Public property | IsDefault | Indicates if the railing is the default one that system generates.
Public property | TopRail | The top rail of the railing.

See Also

Railing Class
Autodesk.Revit.DB.Architecture Namespace

Railing Methods

[image] [image]