Revit 2013 API
AssemblyInstance..::..AddMemberIds Method
AssemblyInstance Class See Also Send Feedback
Adds member element ids for the assembly instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void AddMemberIds(
    ICollection<ElementId> memberIds
)
Visual Basic
Public Sub AddMemberIds ( _
    memberIds As ICollection(Of ElementId) _
)
Visual C++
public:
void AddMemberIds(
    ICollection<ElementId^>^ memberIds
)

Parameters

memberIds
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
Element ids to be added to the assembly instance.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | One or more element ids was not permitted for membership in the assembly instance. Elements should be of a valid category and should not be a member of an existing assembly.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AssemblyInstance Class

AllowsAssemblyViewCreation Method

[image]