Revit 2013 API
LightFamily..::..GetLightSourceTransform Method
LightFamily Class See Also Send Feedback
Returns the transformation matrix of the relocated light source.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public Transform GetLightSourceTransform()
Visual Basic
Public Function GetLightSourceTransform As Transform
Visual C++
public:
Transform^ GetLightSourceTransform()

Return Value

The light source transform.

Remarks

When the user moves or rotates the light source in family editor, the returned value contains the transformation matrix of the new location. It may be an identity matrix.

See Also

LightFamily Class
Autodesk.Revit.DB.Lighting Namespace

GetLightType Method

[image]