Revit 2013 API
FabricArea Properties
FabricArea Class See Also Send Feedback

The FabricArea type exposes the following members.

Properties

 | Name | Description
Public property | CoverOffset | Additional cover offset of the fabric distribution.
Public property | Direction | Retrieve the Major Direction of the Fabric Area.
Public property | FabricAreaType | Retrieves the type of the Fabric Area.
Public property | FabricLocation | Fabric location in the host.
Public property | FabricSheetTypeId | Fabric Sheet Type Id. Defines the Fabric Sheet to be hosted and replicated by this element.
Public property | HostId | Host element (slab, wall, etc.) Id.
Public property | LapSplicePosition | Fabric lap splice position in the fabric distribution
Public property | MajorLapSpliceLength | Fabric lap splice length in major direction in the fabric distribution.
Public property | MajorSheetAlignment | Fabric Sheet alignment in the fabric distribution
Public property | MinorLapSpliceLength | Fabric lap splice length in minor direction in the fabric distribution.
Public property | MinorSheetAlignment | Fabric Sheet alignment in the fabric distribution
Public property | SketchId | Sketch element id
Public property | TagViewId | Tag new members in view

See Also

FabricArea Class
Autodesk.Revit.DB.Structure Namespace

CoverOffset Property

[image]