Revit 2013 API
RebarHookTypeSet Members
RebarHookTypeSet Class Constructors Methods Properties See Also Send Feedback

The RebarHookTypeSet type exposes the following members.

Constructors

 | Name | Description
Public method | RebarHookTypeSet | Initializes a new instance of the RebarHookTypeSet class

Methods

 | Name | Description
Public method | Clear | Removes every RebarHook type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a RebarHook type within the set.
Public method | Erase | Removes a specified RebarHook type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | Insert | Insert the specified RebarHook type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | Size | Returns the number of RebarHook types that are in the set.

See Also

RebarHookTypeSet Class
Autodesk.Revit.DB.Structure Namespace

RebarHookTypeSet Constructor

[image]