Revit 2013 API
RibbonPanel Members
RibbonPanel Class Methods Properties See Also Send Feedback

The RibbonPanel type exposes the following members.

Methods

 | Name | Description
Public method | AddItem | Adds a Ribbon item to the panel.
Public method | AddSeparator | Adds a new Separator to the panel.
Public method | AddSlideOut | Adds a slideout to the current panel.
Public method | AddStackedItems(RibbonItemData, RibbonItemData) | Adds two stacked items to the panel.
Public method | AddStackedItems(RibbonItemData, RibbonItemData, RibbonItemData) | Adds three stacked items to the panel.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | GetItems | Gets a copy of the collection of RibbonItems assigned to the RibbonPanel.

Properties

 | Name | Description
Public property | Enabled | Gets or sets a value indicating whether the RibbonPanel can respond to user interaction.
Public property | Name | Gets or sets the name of the RibbonPanel.
Public property | Title | Gets or sets the text of the RibbonPanel.
Public property | Visible | Gets or sets a value indicating whether the RibbonPanel is displayed.

See Also

RibbonPanel Class
Autodesk.Revit.UI Namespace

RibbonPanel Methods

[image] [image]