Revit 2013 API
Wall Members
Wall Class Methods Properties See Also Send Feedback

The Wall type exposes the following members.

Methods

 | Name | Description
 | Create(Document, IList<(Of <<'(Curve>)>>), Boolean) | Creates a non rectangular profile wall within the project using the default wall type.
 | Create(Document, Curve, ElementId, Boolean) | Creates a new rectangular profile wall within the project using the default wall style.
 | Create(Document, IList<(Of <<'(Curve>)>>), ElementId, ElementId, Boolean) | Creates a non rectangular profile wall within the project using the specified wall type.
 | Create(Document, IList<(Of <<'(Curve>)>>), ElementId, ElementId, Boolean, XYZ) | Creates a non rectangular profile wall within the project using the specified wall type and normal vector.
 | Create(Document, Curve, ElementId, ElementId, Double, Double, Boolean, Boolean) | Creates a new rectangular profile wall within the project using the specified wall type, height, and offset.
Public method | Flip | The wall orientation will be flipped.

Properties

 | Name | Description
Public property | CurtainGrid | Get the grid object of a curtain wall
Public property | Flipped | Property to test whether the wall orientation is flipped.
Public property | Orientation | The normal vector projected from the exterior side of the wall.
Public property | StructuralUsage | Retrieves or changes the wall's designated structural usage.
Public property | WallType | Retrieves or changes the type of the wall.
Public property | Width | Get the overall thickness of the wall.

See Also

Wall Class

Wall Methods

[image] [image]