Revit 2013 API
FamilyItemFactory..::..NewReferencePoint Method (Transform)
FamilyItemFactory Class See Also Send Feedback
Create a reference point at a given location and with a given coordinate system in an Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ReferencePoint NewReferencePoint(
    Transform
)
Visual Basic
Public Function NewReferencePoint ( _
     As Transform _
) As ReferencePoint
Visual C++
public:
ReferencePoint^ NewReferencePoint(
    Transform^
)

Parameters

Type: Autodesk.Revit.DB..::..Transform

Return Value

The newly created ReferencePoint.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the family is not a Conceptual Mass Family.

See Also

FamilyItemFactory Class
NewReferencePoint Overload
Autodesk.Revit.Creation Namespace

NewReferencePoint Method (XYZ)

[image]