Revit 2013 API
ElementTransformUtils..::..CopyElements Method
ElementTransformUtils Class See Also Send Feedback
Copies a set of elements and places the copies at a location indicated by a given translation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static ICollection<ElementId> CopyElements(
    Document document,
    ICollection<ElementId> elementsToCopy,
    XYZ translation
)
Visual Basic
Public Shared Function CopyElements ( _
    document As Document, _
    elementsToCopy As ICollection(Of ElementId), _
    translation As XYZ _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ CopyElements(
    Document^ document,
    ICollection<ElementId^>^ elementsToCopy,
    XYZ^ translation
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document that owns the elements.
elementsToCopy
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
The set of elements to copy.
translation
Type: Autodesk.Revit.DB..::..XYZ
The translation vector for the new elements.

Return Value

The ids of the newly created copied elements.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The elementsToCopy is empty. -or- One or more elements in elementsToCopy do not exist in the document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ElementTransformUtils Class

Dispose Method

[image]