Revit 2013 API
BasicFileInfo Members
BasicFileInfo Class Methods Properties See Also Send Feedback

The BasicFileInfo type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the BasicFileInfo
 | Extract | Retrieves basic file data.

Properties

 | Name | Description
Public property | CentralPath | Returns the central model path.
Public property | IsCentral | Checks if the file is workshared and Central.
Public property | IsCreatedLocal | Checks if the file is created local.
Public property | IsInProgress | Checks if the file is workshared and is in process of becoming Central.
Public property | IsLocal | Checks if the file is workshared and Local.
Public property | IsSavedInCurrentVersion | Checks if the file is saved in the current version.
Public property | IsWorkshared | Checks if the file is workshared.
Public property | LanguageWhenSaved | Return the language active for the last save
Public property | SavedInVersion | Returns the version in which file is saved.
Public property | Username | Returns the username.

See Also

BasicFileInfo Class

BasicFileInfo Methods

[image] [image]