Revit 2013 API
AnalyticalModel..::..HasAlignment Method
AnalyticalModel Class See Also Send Feedback
Checks if analytical alignment is applicable at a given end.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool HasAlignment(
    AnalyticalDirection direction
)
Visual Basic
Public Function HasAlignment ( _
    direction As AnalyticalDirection _
) As Boolean
Visual C++
public:
bool HasAlignment(
    AnalyticalDirection direction
)

Parameters

direction
Type: Autodesk.Revit.DB.Structure..::..AnalyticalDirection
The direction of the analytical model.

Return Value

True if analytical alignment is supported.

Remarks

True for analytical models of linear elements (beams, braces, columns).

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace

HasDeletedLinks Method

[image]