Revit 2013 API
AnalyticalModel..::..Enable Method
AnalyticalModel Class See Also Send Feedback
Enables or disables Analytical Model, if the Element allows a one-operation Analytical Model toggle.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void Enable(
    bool enable
)
Visual Basic
Public Sub Enable ( _
    enable As Boolean _
)
Visual C++
public:
void Enable(
    bool enable
)

Parameters

enable
Type: System..::..Boolean
Enable (true) or disable (false) Analytical Model.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This AnalyticalModel does not support enabling or disabling the analytical model.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace

EnableAutoDetect Method

[image]