Revit 2013 API
LocationPoint..::..Point Property
LocationPoint Class Example See Also Send Feedback
Get and set the physical location of the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ Point { get; set; }
Visual Basic
Public Property Point As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ Point {
    XYZ^ get ();
    void set (XYZ^ value);
}

Examples

CopyC#
void LocationMove(FamilyInstance column)
{
    LocationPoint columnPoint = column.Location as LocationPoint;
    if (null != columnPoint)
    {
        XYZ newLocation = new XYZ(10, 20, 0);
        // Move the column to the new location
        columnPoint.Point = newLocation;
    }
}
CopyVB.NET
Sub LocationMove(ByVal column As Autodesk.Revit.DB.FamilyInstance)
    Dim columnPoint As LocationPoint = TryCast(column.Location, LocationPoint)
    If columnPoint IsNot Nothing Then
        Dim newLocation As New Autodesk.Revit.DB.XYZ(10, 20, 0)
        ' Move the column to the new location
        columnPoint.Point = newLocation
    End If
End Sub

See Also

LocationPoint Class

Rotation Property

[image]