Revit 2013 API
AnalyticalLinkType..::..RotationZ Property
AnalyticalLinkType Class See Also Send Feedback
Fixity of rotation around Z.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public AnalyticalFixityState RotationZ { get; set; }
Visual Basic
Public Property RotationZ As AnalyticalFixityState
    Get
    Set
Visual C++
public:
property AnalyticalFixityState RotationZ {
    AnalyticalFixityState get ();
    void set (AnalyticalFixityState value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The fixity state rotationZ is not valid for Analytical Link Type parameters.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

AnalyticalLinkType Class
Autodesk.Revit.DB.Structure Namespace

TranslationX Property

[image]