Revit 2013 API
FabricArea..::..SetFabricSheetTypeId Method
FabricArea Class See Also Send Feedback
Fabric Sheet Type Id. Defines the Fabric Sheet to be hosted and replicated by this element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetFabricSheetTypeId(
    ElementId fabricSheetTypeId
)
Visual Basic
Public Sub SetFabricSheetTypeId ( _
    fabricSheetTypeId As ElementId _
)
Visual C++
public:
void SetFabricSheetTypeId(
    ElementId^ fabricSheetTypeId
)

Parameters

fabricSheetTypeId
Type: Autodesk.Revit.DB..::..ElementId

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | fabricSheetTypeId is not a Fabric Sheet Type.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural.

See Also

FabricArea Class
Autodesk.Revit.DB.Structure Namespace

SetMajorSheetAlignment Method

[image]