Revit 2013 API
AnalyticalLink..::..Create Method
AnalyticalLink Class See Also Send Feedback
Creates a new instance of a AnalyticalLink element between two Hubs.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static AnalyticalLink Create(
    Document doc,
    ElementId type,
    ElementId startHubId,
    ElementId endHubId
)
Visual Basic
Public Shared Function Create ( _
    doc As Document, _
    type As ElementId, _
    startHubId As ElementId, _
    endHubId As ElementId _
) As AnalyticalLink
Visual C++
public:
static AnalyticalLink^ Create(
    Document^ doc,
    ElementId^ type,
    ElementId^ startHubId,
    ElementId^ endHubId
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
Document to which new AnalyticalLink should be added.
type
Type: Autodesk.Revit.DB..::..ElementId
AnalyticalLinkType for the new AnalyticalLink.
startHubId
Type: Autodesk.Revit.DB..::..ElementId
Hub at start of AnalyticalLink.
endHubId
Type: Autodesk.Revit.DB..::..ElementId
Hub at end of AnalyticalLink.

Return Value

The newly created AnalyticalLink instance.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | startHubId is not a valid Hub ID for an AnalyticalLink element. -or- endHubId is not a valid Hub ID for an AnalyticalLink element. -or- Thrown if startHubId or endHubId do not represent ids of Hubs. -or- Thrown if startHubId == endHubId. -or- Thrown if type does not represent an id of an AnalyticalLinkType.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural.

See Also

AnalyticalLink Class
Autodesk.Revit.DB.Structure Namespace

IsAutoGenerated Method

[image]