Revit 2013 API
StairsType..::..LeftSideSupportType Property
StairsType Class See Also Send Feedback
The type of left support used in the stair.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId LeftSideSupportType { get; set; }
Visual Basic
Public Property LeftSideSupportType As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ LeftSideSupportType {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: leftSideSupportTypeId is not a valid support type.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The left support style is not carriage(open), so this related data cannot be set.

See Also

StairsType Class
Autodesk.Revit.DB.Architecture Namespace

MaxRiserHeight Property

[image]