Revit 2013 API
FormatOptions..::..Rounding Property
FormatOptions Class See Also Send Feedback
Retrieves the Rounding/Accuracy of Units Type that are currently selected.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double Rounding { get; set; }
Visual Basic
Public Property Rounding As Double
    Get
    Set
Visual C++
public:
property double Rounding {
    double get ();
    void set (double value);
}

Remarks

You can set a non-negative double value to Rounding property, if there is no this type in UI ComboBox, it will show us Custom value. and if you input a negative value, it will correct to 1.

See Also

FormatOptions Class

Units Property

[image]