Revit 2013 API
ReferenceWithContext Class
Members See Also Send Feedback
An object including a reference to a geometric object and related context, as instance transform etc.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class ReferenceWithContext : IDisposable
Visual Basic
Public Class ReferenceWithContext _
    Implements IDisposable
Visual C++
public ref class ReferenceWithContext : IDisposable

Remarks

The ReferenceWithContext is used as the returned value from the method FindReferencesWithContextByDirection(XYZ, XYZ, View3D) or or ReferenceIntersector.Find(XYZ, XYZ). It includes a reference intersecting a line extended in a certain direction from an origin point and the context of the geometric object, as the transform and proximity.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ReferenceWithContext

See Also

ReferenceWithContext Members

ReferenceWithContext Members

[image] [image]