Revit 2013 API
AnalyticalLink Members
AnalyticalLink Class Methods Properties See Also Send Feedback

The AnalyticalLink type exposes the following members.

Methods

 | Name | Description
 | Create | Creates a new instance of a AnalyticalLink element between two Hubs.
Public method | IsAutoGenerated | Specifies whether or not an AnalyticalLink was created by an AnalyticalModel element.
 | IsValidHub | Checks whether input hub is valid for an AnalyticalLink.

Properties

 | Name | Description
Public property | End |
Public property | EndHubId | Hub ID at end of AnalyticalLink.
Public property | OwnerId | ElementId of AnalyticalModel element which created the AnalyticalLink (if any) invalidElementId if this Analytical Link was created by the User or API
Public property | Start |
Public property | StartHubId | Hub ID at start of AnalyticalLink.

See Also

AnalyticalLink Class
Autodesk.Revit.DB.Structure Namespace

AnalyticalLink Methods

[image] [image]