Revit 2013 API
UIApplication Methods
UIApplication Class See Also Send Feedback

The UIApplication type exposes the following members.

Methods

 | Name | Description
Public method | CreateAddInCommandBinding | Creates a new AddInCommandBinding.
Public method | CreateRibbonPanel(String) | Create a new RibbonPanel on the Add-Ins tab.
Public method | CreateRibbonPanel(String, String) | Create a new RibbonPanel on the specified tab.
Public method | CreateRibbonPanel(Tab, String) | Create a new RibbonPanel on the designated standard Revit tab.
Public method | CreateRibbonTab | Creates a new tab on the Revit user interface.
Public method | Dispose |
 | DoDragDrop(ICollection<(Of <<'(String>)>>)) | Initiates a drag and drop operation of a collection of file names on the Revit user interface.
 | DoDragDrop(Object, IDropHandler) | Initiates a drag and drop operation with a custom drop implementation.
Public method | GetRibbonPanels()()()() | Get all the custom Panels on Add-Ins tab of Revit.
Public method | GetRibbonPanels(String) | Get all the custom Panels on a designated Revit tab.
Public method | GetRibbonPanels(Tab) | Get all the custom Panels on a designated standard Revit tab.
Public method | OpenAndActivateDocument(String) | Opens and activates a Revit document.
Public method | OpenAndActivateDocument(ModelPath, OpenOptionsForUI) | Opens and activates a Revit document.
Public method | RemoveAddInCommandBinding | Removes an AddInCommandBinding.

See Also

UIApplication Class
Autodesk.Revit.UI Namespace

CreateAddInCommandBinding Method

[image]