Revit 2013 API
CompoundStructure..::..GetNumberOfShellLayers Method
CompoundStructure Class See Also Send Feedback
Retrieves the number of interior or exterior shell layers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int GetNumberOfShellLayers(
    ShellLayerType shellLayerType
)
Visual Basic
Public Function GetNumberOfShellLayers ( _
    shellLayerType As ShellLayerType _
) As Integer
Visual C++
public:
int GetNumberOfShellLayers(
    ShellLayerType shellLayerType
)

Parameters

shellLayerType
Type: Autodesk.Revit.DB..::..ShellLayerType
If ShellLayerType::Exterior gets the number of exterior shell layers, otherwise gets the number of interior shell layers.

Return Value

The number of shell layers in the interior or exterior shell, as specified by shellLayerType.

Remarks

There must be at least one core layer, i.e. one layer which is not a shell layer.

See Also

CompoundStructure Class

GetOffsetForLocationLine Method

[image]