Revit 2013 API
FabricSheetType..::..Material Property
FabricSheetType Class See Also Send Feedback
Defines wire material ElementId of the Fabric Sheet

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId Material { get; set; }
Visual Basic
Public Property Material As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ Material {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

FabricSheetType Class
Autodesk.Revit.DB.Structure Namespace

MinorDirectionWireType Property

[image]