Revit 2013 API
Document..::..LightingFixtureTypes Property
Document Class See Also Send Feedback
Returns an object that contains all of the available lighting fixture types currently loaded to this project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilySymbolSet LightingFixtureTypes { get; }
Visual Basic
Public ReadOnly Property LightingFixtureTypes As FamilySymbolSet
    Get
Visual C++
public:
property FamilySymbolSet^ LightingFixtureTypes {
    FamilySymbolSet^ get ();
}

Remarks

The LightingFixtureTypes property returns an object that contains the lighting fixture types which can be used to change the type of a lighting fixture from one type to another.

See Also

Document Class

MassDisplayTemporaryOverride Property

[image]