Revit 2013 API
Categories..::..Item Property (BuiltInCategory)
Categories Class See Also Send Feedback
Retrieves a category object corresponding to a BuiltInCategory id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Category this[
    BuiltInCategory categoryId
] { get; }
Visual Basic
Public Overridable ReadOnly Property Item ( _
    categoryId As BuiltInCategory _
) As Category
    Get
Visual C++
public:
virtual property Category^ Item[BuiltInCategory categoryId] {
    Category^ get (BuiltInCategory categoryId);
}

Parameters

categoryId
Type: Autodesk.Revit.DB..::..BuiltInCategory

Remarks

Unlike the method that obtains categories by name, this routine will obtain the handle even of built-in subcategories.

See Also

Categories Class
Item Overload

Size Property

[image]