Revit 2013 API
DocumentPreviewSettings Class
Members Example See Also Send Feedback
Contains the settings related to the saving of preview images for a given document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class DocumentPreviewSettings : IDisposable
Visual Basic
Public Class DocumentPreviewSettings _
    Implements IDisposable
Visual C++
public ref class DocumentPreviewSettings : IDisposable

Examples

CopyC#
// Get the document's preview settings
DocumentPreviewSettings settings = document.GetDocumentPreviewSettings();

// Find a candidate 3D view
FilteredElementCollector collector = new FilteredElementCollector(document);
collector.OfClass(typeof(View3D));

Func<View3D, bool> isValidForPreview = v => settings.IsViewIdValidForPreview(v.Id);

View3D viewForPreview = collector.OfType<View3D>().First<View3D>(isValidForPreview);

// Set the preview settings
Transaction setTransaction = new Transaction(document, "Set preview view id");
setTransaction.Start();
settings.PreviewViewId = viewForPreview.Id;
setTransaction.Commit();

// Save the document
document.Save();

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..DocumentPreviewSettings

See Also

DocumentPreviewSettings Members

DocumentPreviewSettings Members

[image] [image]