Revit 2013 API
Pipe Members
Pipe Class Methods Properties See Also Send Feedback

The Pipe type exposes the following members.

Methods

 | Name | Description
 | CreatePlaceholder | Creates a new placeholder pipe.
 | IsLevelId | Checks if given element id is valid level element.
 | IsPipeTypeId | Checks if given type is valid pipe type.

Properties

 | Name | Description
Public property | FlowState | The flow state of the pipe.
Public property | IsPlaceholder | Identifies if the pipe is a placeholder or not.
Public property | PipeType | The pipe type of this pipe.

See Also

Pipe Class
Autodesk.Revit.DB.Plumbing Namespace

Pipe Methods

[image] [image]