Revit 2013 API
ExporterIFC..::..RelateSpatialElement Method
ExporterIFC Class See Also Send Feedback
Relates the input element handle to the given spatial element.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void RelateSpatialElement(
    ElementId roomId,
    IFCAnyHandle elemHnd
)
Visual Basic
Public Sub RelateSpatialElement ( _
    roomId As ElementId, _
    elemHnd As IFCAnyHandle _
)
Visual C++
public:
void RelateSpatialElement(
    ElementId^ roomId,
    IFCAnyHandle^ elemHnd
)

Parameters

roomId
Type: Autodesk.Revit.DB..::..ElementId
The spatial element id, which must have been registered with RegisterSpatialElementHandle().
elemHnd
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The element handle.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace

RemoveBuildingStorey Method

[image]