Revit 2013 API
RenderingQualitySettings Properties
RenderingQualitySettings Class See Also Send Feedback

The RenderingQualitySettings type exposes the following members.

Properties

 | Name | Description
Public property | AreCurtainWallsDaylightPortals | Indicates whether curtain walls daylight portals.
Public property | AreDoorsDaylightPortals | Indicates whether doors daylight portals.
Public property | AreShadowsEnabled | Indicates whether to make shadow edges soft(blurred).
Public property | AreWindowsDaylightPortals | Indicates whether windows daylight portals.
Public property | BlurredReflectionPrecision | The blurred reflections precision.
Public property | BlurredRefractionPrecision | The blurred refractions precision.
Public property | ImagePrecision | A value that controls how antialiasing is applied to the background image.
Public property | IndirectIlluminationBounces | The indirect illumination bounces value.
Public property | IndirectIlluminationPrecision | The indirect illumination precision value.
Public property | IndirectIlluminationSmoothness | The indirect illumination smoothness value.
Public property | MaxReflections | The maximum number of reflections.
Public property | MaxRefractions | The maximum number of refractions.
Public property | RenderingQuality | The quality applied for rendering.
Public property | ShouldComputeIndirectAndSkyIllumination | Indicates whether to include light that bounces off other objects, and light from the sky when calculating the lighting for this scene.
Public property | SoftShadowsPrecision | The soft shadows precision value.

See Also

RenderingQualitySettings Class

AreCurtainWallsDaylightPortals Property

[image]