Revit 2013 API
Document..::..NewBeamSystem Method (CurveArray, Level)
Document Class Example See Also Send Feedback
Creates a new 2D BeamSystem with specified profile curves.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public BeamSystem NewBeamSystem(
    CurveArray profile,
    Level level
)
Visual Basic
Public Function NewBeamSystem ( _
    profile As CurveArray, _
    level As Level _
) As BeamSystem
Visual C++
public:
BeamSystem^ NewBeamSystem(
    CurveArray^ profile,
    Level^ level
)

Parameters

profile
Type: Autodesk.Revit.DB..::..CurveArray
The profile of the BeamSystem. The profile must be a closed curve loop in the level.
level
Type: Autodesk.Revit.DB..::..Level
The level on which the BeamSystem is to be created. The work plane of the BeamSystem will be the ketch plane associated with the Level. If there is no current sketch plane associated with the level yet, we will create a default one.

Return Value

If successful a new BeamSystem object will be returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic). Suitable exceptions will be fired if the parameters are invalid.

Remarks

Other properties are set to default value and can be set later. Such as elevation, direction, etc.

Examples

CopyC#
// Build a profile for the beam system creation
XYZ first = new XYZ(0, 0, 0);
XYZ second = new XYZ(40, 0, 0);
XYZ third = new XYZ(40, 25, 0);
XYZ fourth = new XYZ(0, 25, 0);
CurveArray profile = new CurveArray();
profile.Append(Line.get_Bound(first, second));
profile.Append(Line.get_Bound(second, third));
profile.Append(Line.get_Bound(third, fourth));
profile.Append(Line.get_Bound(fourth, first));

// Create a beam system
BeamSystem beamSystem = document.Create.NewBeamSystem(profile, level);
if (null != beamSystem)
{
    // Change some properties, such as elevation
    Parameter elevationPara = beamSystem.get_Parameter(BuiltInParameter.INSTANCE_ELEVATION_PARAM);
    if (null != elevationPara)
    {
        elevationPara.Set(10.0);
    }
}
CopyVB.NET
' Build a profile for the beam system creation
Dim first As New Autodesk.Revit.DB.XYZ(0, 0, 0)
Dim second As New Autodesk.Revit.DB.XYZ(40, 0, 0)
Dim third As New Autodesk.Revit.DB.XYZ(40, 25, 0)
Dim fourth As New Autodesk.Revit.DB.XYZ(0, 25, 0)
Dim profile As New CurveArray()
profile.Append(Line.Bound(first, second))
profile.Append(Line.Bound(second, third))
profile.Append(Line.Bound(third, fourth))
profile.Append(Line.Bound(fourth, first))

' Create a beam system
Dim beamSystem As BeamSystem = document.Create.NewBeamSystem(profile)
If beamSystem IsNot Nothing Then
    ' Change some properties, such as elevation
    Dim elevationPara As Parameter = beamSystem.Parameter(BuiltInParameter.INSTANCE_ELEVATION_PARAM)
    If elevationPara IsNot Nothing Then
        elevationPara.[Set](10)
    End If
End If

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input profile or level is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when profile or level is not suitable for creating beam system.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown if calling this function when the document is not modifiable.

See Also

Document Class
NewBeamSystem Overload
Autodesk.Revit.Creation Namespace

NewBeamSystem Method (CurveArray, SketchPlane)

[image]