Revit 2013 API
EnergyAnalysisDetailModel Class
Members Example See Also Send Feedback
Manage the analytical thermal model.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class EnergyAnalysisDetailModel : IDisposable
Visual Basic
Public Class EnergyAnalysisDetailModel _
    Implements IDisposable
Visual C++
public ref class EnergyAnalysisDetailModel : IDisposable

Remarks

The Export to gbXML and the Heating and Cooling Loads features produces an analytical thermal model from the physical model of a building. The analytical thermal model is composed of spaces, zones and planar surfaces that represent the actual volumetric elements of the building.

Examples

CopyC#
// Collect space and surface data from the building's analytical thermal model
EnergyAnalysisDetailModelOptions options = new EnergyAnalysisDetailModelOptions();
options.Tier = EnergyAnalysisDetailModelTier.Final; // include constructions, schedules, and non-graphical data in the computation of the energy analysis model

EnergyAnalysisDetailModel eadm = EnergyAnalysisDetailModel.Create(doc, options); // Create a new energy analysis detailed model from the physical model
IList<EnergyAnalysisSpace> spaces = eadm.GetAnalyticalSpaces();
StringBuilder builder = new StringBuilder();
builder.AppendLine("Spaces: " + spaces.Count);
foreach (EnergyAnalysisSpace space in spaces)
{
    builder.AppendLine("   >>> " + space.Name + " related to " + space.SpatialElementId);
    IList<EnergyAnalysisSurface> surfaces = space.GetAnalyticalSurfaces();
    builder.AppendLine("       has " + surfaces.Count + " surfaces.");
    foreach (EnergyAnalysisSurface surface in surfaces)
    {
        builder.AppendLine("            +++ Surface from " + surface.OriginatingElementDescription);
    }
}
TaskDialog.Show("EAM", builder.ToString());

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Analysis..::..EnergyAnalysisDetailModel

See Also

EnergyAnalysisDetailModel Members
Autodesk.Revit.DB.Analysis Namespace

EnergyAnalysisDetailModel Members

[image] [image]