Revit 2013 API
PipeType..::..Material Property
PipeType Class See Also Send Feedback
The material type of the pipe type.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This property is obsolete in Revit 2013.  Please use Autodesk::Revit::DB::Plumbing::PipeSegment::MaterialId instead.")]
public PipeMaterialType Material { get; }
Visual Basic
<ObsoleteAttribute("This property is obsolete in Revit 2013.  Please use Autodesk::Revit::DB::Plumbing::PipeSegment::MaterialId instead.")> _
Public ReadOnly Property Material As PipeMaterialType
    Get
Visual C++
[ObsoleteAttribute(L"This property is obsolete in Revit 2013.  Please use Autodesk::Revit::DB::Plumbing::PipeSegment::MaterialId instead.")]
public:
property PipeMaterialType^ Material {
    PipeMaterialType^ get ();
}

See Also

PipeType Class
Autodesk.Revit.DB.Plumbing Namespace

Parameter Property

[image] [image]