Revit 2013 API
LoadCaseArray Members
LoadCaseArray Class Constructors Methods Properties See Also Send Feedback

The LoadCaseArray type exposes the following members.

Constructors

 | Name | Description
Public method | LoadCaseArray | Initializes a new instance of the LoadCaseArray class

Methods

 | Name | Description
Public method | Append | Add the load case to the end of the array.
Public method | Clear | Removes every load case from the array, rendering it empty.
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | Insert | Insert the specified load case into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | Item | Gets or sets an load case at a specified index within the array.
Public property | Size | Returns the number of load cases that are in the array.

See Also

LoadCaseArray Class
Autodesk.Revit.DB.Structure Namespace

LoadCaseArray Constructor

[image]