Revit 2013 API
Selection..::..GetElementIds Method
Selection Class See Also Send Feedback
The ids of the elements that are currently selected.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public ICollection<ElementId> GetElementIds()
Visual Basic
Public Function GetElementIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetElementIds()

Return Value

A collection containing the ids of the selected elements.

Remarks

Refers to the same set of elements as the Selection.Elements property. The collection returned by this method allows these elements to be processed with the same filtering logic and FilteredElementCollector constructor as regular iterations.

See Also

Selection Class
Autodesk.Revit.UI.Selection Namespace

PickBox Method

[image] [image]