Revit 2013 API
FamilyUtils..::..FamilyCanConvertToFaceHostBased Method
FamilyUtils Class See Also Send Feedback
Indicates whether the family can be converted to face host based.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static bool FamilyCanConvertToFaceHostBased(
    Document aDoc,
    ElementId famId
)
Visual Basic
Public Shared Function FamilyCanConvertToFaceHostBased ( _
    aDoc As Document, _
    famId As ElementId _
) As Boolean
Visual C++
public:
static bool FamilyCanConvertToFaceHostBased(
    Document^ aDoc,
    ElementId^ famId
)

Parameters

aDoc
Type: Autodesk.Revit.DB..::..Document
famId
Type: Autodesk.Revit.DB..::..ElementId

Return Value

True if the family can be converted to face-based. Otherwise false, which will be returned if there any family instances exist in the project, the family is already face-based, or the family does not have a host. Also, false is returned if the family does not belong to one of the following categories:
  • OST_CommunicationDevices
  • OST_DataDevices
  • OST_DuctTerminal
  • OST_ElectricalEquipment
  • OST_ElectricalFixtures
  • OST_FireAlarmDevices
  • OST_LightingDevices
  • OST_LightingFixtures
  • OST_MechanicalEquipment
  • OST_NurseCallDevices
  • OST_PlumbingFixtures
  • OST_SecurityDevices
  • OST_Sprinklers
  • OST_TelephoneDevices

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FamilyUtils Class

FBXExportOptions Class

[image]