Revit 2013 API
FamilyManager Members
FamilyManager Class Methods Properties See Also Send Feedback

The FamilyManager type exposes the following members.

Methods

 | Name | Description
Public method | AddParameter(ExternalDefinition, BuiltInParameterGroup, Boolean) | Add a new shared parameter to the family.
Public method | AddParameter(String, BuiltInParameterGroup, Category, Boolean) | Add a new family type parameter to control the type of a nested family within another family.
Public method | AddParameter(String, BuiltInParameterGroup, ParameterType, Boolean) | Add a new family parameter with a given name.
Public method | AssociateElementParameterToFamilyParameter | Associates or disassociates the element parameter to an existing family parameter.
Public method | CanElementParameterBeAssociated | Indicates if this element parameter can be associated with a family parameter.
Public method | DeleteCurrentType | Remove the current family type.
Public method | GetAssociatedFamilyParameter | Gets the associated family parameter of an element parameter.
Public method | IsParameterLockable | For Conceptual Mass and Curtain Panel families, indicate whether the specified parameter can be locked.
Public method | IsParameterLocked | For Conceptual Mass and Curtain Panel families, indicate whether the specified dimension-driving parameter is locked.
Public method | MakeInstance | Set the family parameter as an instance parameter.
Public method | MakeNonReporting | Set the reporting family parameter as a regular/driving parameter.
Public method | MakeReporting | Set the family parameter as a reporting parameter.
Public method | MakeType | Set the family parameter as a type parameter.
Public method | NewType | Add a new family type with a given name and makes it be the current type.
Public method | RemoveParameter | Remove an existing family parameter from the family.
Public method | RenameCurrentType | Rename the current family type.
Public method | RenameParameter | Rename a family parameter.
Public method | ReplaceParameter(FamilyParameter, ExternalDefinition, BuiltInParameterGroup, Boolean) | Replace a family parameter with a shared parameter.
Public method | ReplaceParameter(FamilyParameter, String, BuiltInParameterGroup, Boolean) | Replace a shared family parameter with a new non-shared family parameter.
Public method | Set(FamilyParameter, ElementId) | Set the Autodesk::Revit::DB::ElementId^ value of a family parameter of the current family type.
Public method | Set(FamilyParameter, Double) | Set the double value of a family parameter of the current family type.
Public method | Set(FamilyParameter, Int32) | Set the integer value of a family parameter of the current family type.
Public method | Set(FamilyParameter, String) | Set the string value of a family parameter of the current family type.
Public method | SetFormula | Set the formula of a family parameter.
Public method | SetParameterLocked | For Conceptual Mass and Curtain Panel families, lock or unlock a dimension-driving parameter.
Public method | SetValueString | Set the string value of a family parameter of the current family type.

Properties

 | Name | Description
Public property | CurrentType | The current family type.
Public property | Parameter[([( Guid])]) | Obtains the parameter of this type with a given GUID for a shared parameter.
Public property | Parameter[([( String])]) | Obtains the parameter of this type with a given name.
Public property | Parameter[([( BuiltInParameter])]) | Obtains the parameter of this type with a given parameter id.
Public property | Parameter[([( Definition])]) | Obtains the parameter of this type with a given definition.
Public property | Parameters | All family parameters in this family.
Public property | Types | All family types in the family.

See Also

FamilyManager Class

FamilyManager Methods

[image] [image]