Revit 2013 API
FailureDefinition..::..IsResolutionApplicable Method
FailureDefinition Class See Also Send Feedback
Checks if the given resolution type is applicable to the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsResolutionApplicable(
    FailureResolutionType type
)
Visual Basic
Public Function IsResolutionApplicable ( _
    type As FailureResolutionType _
) As Boolean
Visual C++
public:
bool IsResolutionApplicable(
    FailureResolutionType type
)

Parameters

type
Type: Autodesk.Revit.DB..::..FailureResolutionType
The resolution type to check.

Return Value

True if the given resolution type is applicable to the failure, false otherwise.

See Also

FailureDefinition Class

SetDefaultResolutionType Method

[image]